Palm API Guide, Palm OS Platform

5.6

This file contains documentation on all APIs from Palm, Inc. for Palm OS by ACCESS. It includes the API function definitions for the following product lines:
  • Centro
  • Treo
  • Tungsten
  • Zire
  • LifeDrive

The goal of this document is to provide developers with a detailed reference of all functions, parameters, and constant definitions. For more information on developing applications, refer to the document "Palm Developer Guide, Palm OS Platform" available as part of the SDK download and also separately at the PDN website.

Click the following links to see:

  • Libraries
  • Header Files
  • Sample Codes

The newest addition to the line of Palm products, Palm Centro smartphone for AT&T:

USAGE RESTRICTIONS Your right to access and use the following "PDN Materials" is subject to and governed by the following terms and the terms and conditions of the Palm Developer Network Program License Agreement, available at https://pdn.palm.com/regac/pdn/page?Page_Name=terms.

DISCLAIMER AND LIMITATION OF LIABILITY Palm, Inc. ("Palm") provides these PDN Materials as a courtesy to members of its Palm Developer Network ("PDN"). Palm provides the PDN Materials on an "AS IS" basis and does not guarantee nor assume any liability for the accuracy or completeness of these PDN Materials, nor does Palm guarantee that the PDN Materials will be without errors. You assume the entire risk of using the PDN Materials, including any damage or loss resulting from your use of the PDN Materials or any loss or claims by third parties which may arise from your use of the PDN Materials.

TO THE MAXIMUM EXTENT PERMITTED BY APPLICABLE LAW, THE PDN MATERIALS ARE PROVIDED TO YOU ON AN "AS IS" BASIS AND WITHOUT ANY WARRANTY OF ANY KIND OR NATURE. TO THE MAXIMUM EXTENT PERMITTED BY APPLICABLE LAW, PALM AND ITS SUPPLIERS EXPRESSLY DISCLAIM ANY IMPLIED OR STATUTORY WARRANTIES, INCLUDING WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, TITLE, ACCURACY, CORRESPONDENCE WITH DESCRIPTION, SATISFACTORY QUALITY AND NON-INFRINGEMENT.

TO THE MAXIMUM EXTENT PERMITTED BY APPLICABLE LAW, NEITHER PALM NOR ITS SUPPLIERS SHALL BE LIABLE FOR INCIDENTAL, CONSEQUENTIAL, INDIRECT, SPECIAL, OR PUNITIVE DAMAGES OF ANY KIND, LOSS OF INFORMATION OR DATA, LOSS OF REVENUE, LOSS OF BUSINESS OR OTHER FINANCIAL LOSS ARISING OUT OF OR IN CONNECTION WITH THE USE OF THE PDN MATERIALS, WHETHER BASED IN CONTRACT, TORT (INCLUDING NEGLIGENCE), STRICT PRODUCT LIABILITY OR ANY OTHER THEORY, EVEN IF PALM HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES AND EVEN IF ANY LIMITED REMEDY IS DEEMED TO HAVE FAILED OF ITS ESSENTIAL PURPOSE. Some countries, states, or provinces do not allow the limitation of incidental or consequential damages so the above provisions may be limited in their application to you.

COPYRIGHT AND TRADEMARK © 2004-2008 Palm, Inc. All rights reserved. Palm, LifeDrive, Zire, Tungsten, Treo, Centro, Blazer, Handspring, Graffiti, HotSync, VersaMail, Palm Powered, and Palm OS by ACCESS are among the trademarks or registered trademarks owned by or licensed to Palm, Inc. Adobe and Acrobat are either registered trademarks or trademarks of Adobe Systems Incorporated in the United States and/or other countries. All other brand and product names are or may be trademarks of, and are used to identify products or services of, their respective owners.

The foregoing provisions shall be governed by the laws of the State of California and by the federal laws of the United States, excluding their conflicts of laws provisions. The United Nations Convention on Contracts for the International Sale of Goods (1980) is hereby excluded in its entirety from application to the foregoing provisions. In the event any provision is found to be invalid, illegal or unenforceable, the validity, legality and enforceability of any of the remaining provisions shall not in any way be affected or impaired.

Please read the Palm Developer Network Program License Agreement before using the PDN Materials. If you do not agree to the terms and conditions of the Palm Developer Network Program License Agreement, you may not access or use the PDN Materials. USING OR ACCESSING ANY PART OF THE PDN MATERIALS INDICATES THAT YOU ACCEPT THE TERMS OF THE DEVELOPER NETWORK PROGRAM LICENSE AGREEMENT.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:52 2008 for Palm API Guide


API Guide Home
(Online version only)

Palm API Guide Modules

Here is a list of all modules:
  • Carrier Customization Library
  • HTML Library
  • HTTP Library
  • NetMaster Library
  • NetPref Library
  • Network Library
  • Smart Text Engine Library
  • Telephony Library
  • Hardware Utility Library
  • Background Service Library
  • Display Extent Library
  • System API
  • Status Bar Library
  • Pen Input Manager Library
  • Camera Library
  • Codec Plugin Manager
  • Default Helper Library
  • Favorites Database Library
  • File Browser Library
  • Hi-Resolution Timer Library
  • Sound Library
  • Imaging Library
  • LCD Overlay Library
  • Locations Library
  • Multi Connector Library
  • Key Library
  • Gadget Library
  • UI Utility Library
  • Ring Tone Library
  • Transparency Library
  • Versamail Library
  • Handspring Extensions
  • 5-Way Navigation Library
  • Full Screen Writing API
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:08 2008 for Palm API Guide


Carrier Customization Library

Files

  • file CarrierCustomLibErr.h
    This file contains the error codes for the Carrier Customization Library.

  • file CarrierCustomLibTraps.h
    This file contains the trap for the Carrier Customization Library.

  • file CarrierCustomLibTypes.h
    This file contains public data types exported by the Carrier Customization Library.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:08 2008 for Palm API Guide


HTML Library

Detailed Description

The HTML Library helps applications render data. Please note that there is a limit of 64K of text data for a single content data object, so it is recommended that you do appropriate checks when adding text data for rendering, especially when adding text data repeatedly. Additionally, the caller application is required to provide a set of form widget creation functions to the Html Library for dynamic UI creation. Please see the HtmlLibSetFormWidgetProc routine for details.

Note:
It is important to be aware that this library modifies the active form pointer, so make sure to NOT cache the form pointer, but re-get it before use.

Files

  • file HtmlLib68K.h
    Public 68K include file for HTML shared library.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:08 2008 for Palm API Guide


HTTP Library

Files

  • file HS_HTTPLib68K.h
    Public 68k include file for the HTTP Library.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:08 2008 for Palm API Guide


NetMaster Library

Files

  • file NetMasterLibrary.h
    This is the main header file for the NetMaster Library.

  • file NetMasterLibTypes.h
    This file contains public data types exported by the NetMaster Library.

  • file NetMasterLibErrors.h
    This is the error declarations file for the NetMaster Library.

  • file NetMasterLibTarget.h
    This is the target parameters file for the NetMaster Library.

  • file NetMasterLibTraps.h
    Trap definitions for the NetMaster Library.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:08 2008 for Palm API Guide


NetPref Library

Files

  • file NetPrefLibrary.h
    This is the main header file for the NetPref Library.

  • file NetPrefLibTypes.h
    This file contains public data types exported by the NetPref Library.

  • file NetPrefLibErrors.h
    This is the error declarations file for the NetPref Library.

  • file NetPrefLibTarget.h
    This is the target parameters file for the NetPref Library.

  • file NetPrefLibTraps.h
    Trap definitions for the NetPref Library.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:08 2008 for Palm API Guide


Network Library

Files

  • file PalmNetServices.h
    NetServices provides a set of API to access 802.11.

  • file PalmVPPI.h
    This is the API for VPN panel plug-ins (VPPIs).

  • file PalmWiFiCommon.h
    Constants and structures common to the wifi network panel and driver.

  • file PalmWPPI.h
    This is the API for Wi-Fi panel plug-ins (WPPIs).

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:08 2008 for Palm API Guide


Smart Text Engine Library

Files

  • file SmartTextEngineDef.h
    Public include file for Smart Text Engine shared library.

  • file SmartTextEngineErrors.h
    Error codes for Smart Text Engine shared library.

  • file SmartTextEngineTraps.h
    Trap definitions for the Smart Text Engine shared library.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:08 2008 for Palm API Guide


Telephony Library

Files

  • file HsPhone.h
    Header file for the phone library (CDMA or GSM).

  • file HsPhoneAudio.h
    Header File for Phone Library API ---- AUDIO CATEGORY.

  • file HsPhoneCDMA.h
    Header File for Phone Library API ---- CDMA CATEGORY.

  • file HsPhoneGSM.h
    Header File for Phone Library API ---- GSM CATEGORY.

  • file HsPhoneIOTA.h
    Header File for Phone Library API ---- IOTA CATEGORY.

  • file HsPhoneLibrary.h
    Header File for Phone Library API ---- LIBRARY CATEGORY.

  • file HsPhoneMisc.h
    Header File for Phone Library API ---- MISC CATEGORY.

  • file HsPhoneNetwork.h
    Header File for Phone Library API ---- NETWORK CATEGORY.

  • file HsPhonePower.h
    Header File for Phone Library API ---- POWER CATEGORY.

  • file HsPhoneSecurity.h
    Header File for Phone Library API ---- SECURITY CATEGORY.

  • file HsPhoneSMS.h
    Header File for Phone Library API ---- SMS CATEGORY.

  • file HsPhoneAudioTypes.h
    File contains Phone Audio data types.

  • file HsPhoneCallControlTypes.h
    Types for Phone Library call control functionality.

  • file HsPhoneCDMATypes.h
    Header File for Phone Library API ---- NETWORK CATEGORY.

  • file HsPhoneErrors.h
    Errors returned by API function in GSM/CDMA Library.

  • file HsPhoneEvent.h
    Header file for the phone library (CDMA or GSM).

  • file HsPhoneGSMTypes.h
    Header File for Phone Library API ---- NETWORK CATEGORY.

  • file HsPhoneIOTATypes.h
    Header File for Phone Library API ---- IOTA CATEGORY.

  • file hsPhoneLocationTypes.h
    File contains Phone Location data types.

  • file HsPhoneMiscTypes.h
    Header File for Phone Library API ---- NETWORK CATEGORY.

  • file HsPhoneNetworkTypes.h
    Header File for Phone Library API ---- NETWORK CATEGORY.

  • file HsPhoneSecurityTypes.h
    Header File for Phone Library API ---- NETWORK CATEGORY.

  • file HsPhoneSMSTypes.h
    Header File for Phone Library API ---- NETWORK CATEGORY.

  • file HsPhoneTrace.h
    Trace constants, types, and definitions for Phone Library.

  • file HsPhoneTraps.h
    Traps of all functions exported by the Phone Library.

  • file HsPhoneTypes.h
    Telephony data types that are common between ARM and 68K.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:08 2008 for Palm API Guide


Hardware Utility Library

Detailed Description

This library provides support for applications to control the state of certain pieces of hardware on the device.

This library currently allows the application to programmatically turn the display on/off as well as controling the behavior of the LED light if available.

Files

  • file HardwareUtils68K.h
    Public common header file to the Hardware Utilities Library used by 68K applications.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:08 2008 for Palm API Guide


Background Service Library

Detailed Description

This library provides support for applications to perform background network request bypassing NetLib through the default connection.

Application can use this library to connect to a server on a network and perform network request by sending protocol-specific string and receiving the returned response. Applications can also utilize this library to make background HTTP request by connecting to a web server at port 80 and sending HTTP GET/POST string with specific URL.

Network requests are queued up and the responses are returned through the callback function that is passed to the network request API.

Files

  • file PalmBGService.h
    Public 68K header file for palmOne Background Network Service Library.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:08 2008 for Palm API Guide


Display Extent Library

Files

  • file PalmDisplayExtent.h
    Public API for the Display Extent Library.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:08 2008 for Palm API Guide


System API

Files

  • file PalmErrorBase.h
    Include file for Error Management.

  • file PalmLaunchCodes.h
    Device specific launch codes.

  • file PalmLED.h
    Palm's Generic LED dirver.

  • file PalmNative.h
    Functions and macros to help building ARM code.

  • file PalmPower.h
    Battery notification.

  • file PmPalmOSNVFS.h
    Public 68k header file containing the definitions and API for NVFS devices.

  • file HsChars.h
  • file HsCreators.h
    Public header file for the creator IDs used by Handspring.

  • file HsErrors.h
  • file PalmCreators.h
    Contains Palm-specific creator codes.

  • file PalmFeatures.h
    Contains Palm-specific feature definitions.

  • file palmOneCreators.h
    Contains Palm-specific creator codes.

  • file palmOneFeatures.h
    Contains Palm-specific feature definitions.

  • file palmOneResources.h
    Palm-specific system types and resources.

  • file PalmShimSettings.h
    Shim settings for NetIFSettingGet()/Set().

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:08 2008 for Palm API Guide


Status Bar Library

Detailed Description

This library provides support to manipulate the state of the status bar on devices that utilize the Dynamic Input Area (DIA).

Devices such as Tungsten T3 and Tungsten T5 allow users to collapse/expand the input area to support tall forms. This library allows the status/control bar to be hidden programmatically so that forms can be displayed full screen.

Most of the APIs in the library should already exist in Palm OS SDK, and applications that are developed for DIA-enabled OS should first try to use the PalmSource's status bar API.

Files

  • file palmOneStatusBar.h
    Public common header file for palmOne defined Status Bar library.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:08 2008 for Palm API Guide


Pen Input Manager Library

Files

  • file PalmPin.h
    Public API for the Pen Input Manager Library.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:08 2008 for Palm API Guide


Camera Library

Detailed Description

This library provides camera support for Zire 72 and Treo 650 devices.

Developers who want to provide camera support to their application on Zire 72 and Treo 650 devices should use Camera Manager Library API instead of the old Camera Library.

Files

  • file CameraLib.h
    Public 68K include file for camera support for Treo 600 devices.

  • file palmOneCamera.h
    Public 68K include file for camera support for Treo 650 devices. This version of the library adds functionality for Zire72, and Treo 650.

  • file palmOneCameraSlider.h
    Public 68K file for camera slider notification for Zire 71 devices.

  • file CameraLibCommon.h
    Public 68K common header file for camera support for Treo 600 devices.

  • file palmOneCameraCommon.h
    Public 68K common header file for camera support for Zire 72 and Treo 650 devices.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:08 2008 for Palm API Guide


Codec Plugin Manager

Detailed Description

This library is used to provide support for audio/video/image codecs plugin and encoding/decoding routines.

The Codec Plugin Manager library is used to unify all different type of codecs that are available for palmOne devices and provide a generic API for developers to access these codecs for encoding/decoding.

A typical application would use the library the following way:

  • Check if an input/output format pair is supported [optional]
  • Create a CodecSession with parameters that match the formats
  • Call EncodeDecode()
  • ...
  • Delete the session

For more information, please also check the palmOne Developer Guide.

Files

  • file palmOneCodecPluginMgr.h
    The Codec Plugin Manager is used to unify all different type of codecs that are available for PalmOne devices and provide a generic API for developers to access these codecs.

  • file palmOneCodecFormat.h
    Public 68K common header file for Codec Plugin Manager API - Codec Formats.

  • file palmOneCodecPluginMgrCommon.h
    Public 68K common header file for Codec Plugin Manager API - Library Definitions.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:08 2008 for Palm API Guide


Default Helper Library

Detailed Description

This library is used to provide support for applications to be the default handler for certain services on the device.

This library is used in conjunction with Helper API from the Palm OS SDK. Typically, an application which wants to be a default app to handle certain services (SMS, Email, etc) will register itself in the following way:

  • Check if the application is already the default handler for a particular service
  • Call DefaultHelperLibSetDefaultHelper() if it's not already the default app. Please refer to Palm OS Helper API Service Class ID Constants for service ID.

Files

  • file DefaultHelperLib.h
    Default Helper library owns control over the Default Helpers database.

  • file DefaultHelperLibTypes.h
    Public 68K common header file for Default Helper Library API.

  • file MmsHelperCommon.h
    Public 68k common header files to be used with Default Helper Library.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:08 2008 for Palm API Guide


Favorites Database Library

Detailed Description

This library is used to provide support for applications to insert new entries to the Phone Favorites view on Treo 650 devices.

An application which wants to insert a new entry to the Phone application Favorites view programmatically can call the appropriate FavDBNew*() API depending on the favority type. Currently, this library supports adding new application, phone number, sms destination, web url, email address, and phone view.

Files

  • file FavoritesDBLib.h
    Contains the API to control the Favorites DB.

  • file FavoritesDBLibTypes.h
    Public 68K common header file for FavoritesDB library API.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:08 2008 for Palm API Guide


File Browser Library

Detailed Description

This library is used to provide support for Files application integration.

Applications which want to utilize the File Browser UI or register itself with the Files application on Tungsten devices should use this library to do so. Registration with the Files app has to be done in addition to registration with the Exchange Library.

Registering with the Files application is also done using Exchange Library but with palmOne defined registration IDs (exgRegEditCreatorID, etc). This will enable the application to be launched automatically when a certain file type or extension is selected on the Files app. Developers can also use the APIs available in this library to present File Browser UI in their own application to the user (open and save dialogs).

Files

  • file FileBrowserLib68K.h
    This file contains the FileBrowser Library APIs.

  • file FileBrowserLibCommon.h
    Public 68K common header file for File Browser library API.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:08 2008 for Palm API Guide


Hi-Resolution Timer Library

Detailed Description

This library provides support for high resolution timer on Palm OS devices.

Applications which would like to use a more granular (higher resolution) timer than the standard Palm OS sysTicksPerSecond() can use this library to do so.

Files

  • file palmOneHiResTimer.h
    Public 68k include file for Hi-Resolution timer for Palm OS.

  • file PalmHiResTime.h
    Exported High Resolution timer definitions.

  • file palmOneHiResTimerCommon.h
    Public 68k common header file for Hi-Resolution Timer API.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:08 2008 for Palm API Guide


Sound Library

Detailed Description

This library provides support for the specific sound functionality of the Treo smartphones.

Developers should be able to use Palm OS Sound Manager APIs for most of the work. The calling application should always load this library with SysLibLoad() before use, even if it is already open by another application (ie. SysLibFind() returns a valid refNum). When the application is done with the library it should be unloaded with SysLibRemove(). We do this because there is no good way to synchronize loading and unloading of libraries among multiple applications. It also greatly simplifies internal synchronization.

Files

  • file PalmAudioPlayback.h
    Public 68K include file that supports the stopping of audio playback on Treo 600 and Treo 650 smartphones.

  • file PalmSoundCustomCtrl.h
    Public 68K include file for the Sound Manager custom controls for the IMA_ADPCM codec for Treo 600 and Treo 650 smartphones.

  • file PalmSoundMgrExt.h
    Public 68K include file for the Extended Sound Manager.

  • file HsSoundLib.h
    Public 68K include file for main sound support for Treo 600 and Treo 650 smartphones.

  • file palmOneSndFileStream.h
    Public 68K include file for sound files stream support for Treo 600 and Treo 650 smartphones.

  • file HsSoundLibCommon.h
    Public 68K/Arm common header file for sound support for Treo 600, Treo 650, and Treo 700p smartphones and later models.

  • file PmSoundLibAudioGroup.h
    Public 68K header file used to associate sound channels with Audio groups on Treo 600 and Treo 650 smartphones.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:08 2008 for Palm API Guide


Imaging Library

Detailed Description

This library provides support for image drawing and manipulation on Treo 600 devices.

Applications can use this library to draw JPEG images on the screen or create thumbnails and such on the Treo 600 devices. This library also allows some interaction with the camera within the 3rd party application itself. For the newer devices, developers should try to use palmOne Photo Library before using the Image Library.

palmOne Photo Library allows better integration with the built-in Media application and storing image on the device. Developers who would like to use this library should first check the version of the library and then make the appropriate API calls depending on the version.

The database API provides applications with the ability to:

  • Get the list of albums.
  • Create, delete and rename albums.
  • Get the list of photos in each album.
  • Add photos to albums.

The image manipulation API provides applications with the ability to:

  • Create and capture images and video clips.
  • Read and write image data.
  • Convert images to different formats.
  • Display images.
  • Scale, rotate and crop images.

Files

  • file ImageLib.h
    Public 68k include file for the Imaging Library.

  • file palmOnePhoto.h
    Palm Photos API: This API is used to access Palm Photos database and manipulate images.

  • file ImageLibCommon.h
    Public 68k common header file for the Image Library API on Treo 600 devices.

  • file palmOnePhotoCommon.h
    Palm Photos API: This file contains all the defines, enumerations, structures needed by PalmPhoto.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:08 2008 for Palm API Guide


LCD Overlay Library

Detailed Description

This library provide support for displaying YCbCr images directly on the screen.

Note that the image that is drawn on the screen will always sit on top of the form above everything else.

Files

  • file palmOneLcdOverlay.h
    Public 68k include file for LCDOverlay API that can be used to display YCbCr images directly on the screen.

  • file PalmLcdOverlay.h
    Exported LCD Overlay functions.

  • file palmOneLcdOverlayCommon.h
    Public 68k common header file for LCDOverlay API.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:08 2008 for Palm API Guide


Locations Library

Detailed Description

This library provides location/timezone/DST support for applications.

Developers who want to provide location/timezone/DST or country information to their application on Palm devices should use Locations Library API.

Files

  • file LocsLib.h
    Public 68K include file for location/timezone/DST support on Palm devices.

  • file LocsLibCommon.h
    Public 68K common header file for locations library.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:08 2008 for Palm API Guide


Multi Connector Library

Detailed Description

This library provides support for multi-connector related functionalities.

Applications can register itself to be notified when a peripheral is attached or detached to the multi-connector port. Applications can also use this library to enable/disable the power pin and to re-route audio output.

Files

  • file PmConnectorLib.h
    palmOne library that exports multi-connector related APIs.

  • file PmConnectorLibCommon.h
    Public 68k common header file for Multi-Connector Library for palmOne devices that use multi-connector.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:08 2008 for Palm API Guide


Key Library

Detailed Description

This library provides support for the key-related functionalities.

Application can use this library to detect the state of particular keys, whether they are pressed or released. This library can also be used to enable/disable a certain key programmatically, translate keycodes to characters, and also manage the different settings of the keypad.

Files

  • file PmKeyLib.h
    System Library that exports key-related APIs.

  • file PmKeyLibCommon.h
    Public 68k common header file for system library that exports key-related APIs.

  • file HsKeyCodes.h
  • file HsKeyCommon.h
    Header file with additional keyboard related definitions.

  • file HsKeyTypes.h
    palmOne's key constant definitions shared by DAL and Palm OS (see Palm OS' CmnKeyTypes.h)

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:08 2008 for Palm API Guide


Gadget Library

Detailed Description

This library provides supports for application that wants to manage system gadgets or support big buttons in the applications.

Application that wishes to update/ retrieve the status of system gadget such as the battery indicator, signal strength or bluetooth indicator can use this library to do so. This library also provides APIs for application that wants to include big button resource.

Files

  • file PmSysGadgetLib.h
    System Library that exports status-related APIs.

  • file PmSysGadgetLibCommon.h
    Public 68k header file for system Library that exports system gadget related APIs.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:08 2008 for Palm API Guide


UI Utility Library

Detailed Description

This library provides support for the misc. UI-related functionalities.

Applications can use this library API to retrieve the different layers of colors of the focus ring and use the colors to manually draw custom-shaped focus rings. Please also refer to the HsNav.h header file for more of the library constants and definitions.

Files

  • file PmUIUtilLib.h
    This is the public header for PmUIUtil library.

  • file PmUIUtilLibCommon.h
    Public 68k common header file for system Library that exports UI utility API functions.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:08 2008 for Palm API Guide


Ring Tone Library

Detailed Description

This library provides support for application that wants to manage or play ring tones from within the application itself.

Applications that wish to play, manage or create ring tones from within the application themselves can use the APIs provided by this library. This library can also be used to set different ring tones preferences that are used by the system when there is, for example, an incoming call, email or sms alert, etc.

The calling application should always load this library with SysLibLoad() before use, even if it is already open by another application(ie, SysLibFind() returns a valid refnum). When the application is done with the library, it should be unloaded with SysLibRemove(). We do this because there is no good way to synchronize loading and unloading of libraries among multiple applications. It also greatly simplifies internal synchronization.

Files

  • file TonesLib.h
    Public 68K include file that controls the MIDI tones on a device.

  • file TonesLibTypes.h
    Public 68K header file for the Ring Tone library on Treo devices.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:08 2008 for Palm API Guide


Transparency Library

Detailed Description

This library can be used to couple data between a Ccp channel and a serial port.

It is meant to be used for diagnostics and tethered mode. Since it is a library, it can work without being in a certain application.

Files

  • file TransparencyLib.h
    Transparency Library that couples a Ccp channel and a serial port.

  • file TransparencyLibTypes.h
    Public common header file for the Transparency Library on Treo devices.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:08 2008 for Palm API Guide


Versamail Library

Detailed Description

This library provide supports for application that wish to provide users with the Versamail Font Picker dialog and support the font from with the app.

This library also allows application to programmatically manage style and size for the font types that Versamail support. Other VersaMail supports include launching VersaMail to add a new email with attachment and also the ability to create a plugin to send/view attachments.

Files

  • file palmOneVMFontLib.h
    Defines APIs and structures for the Palm VersaMail Font Picker / Font Manager Service which lets users get / set font characteristics.

  • file PalmVMLaunch.h
    Defines APIs and structures for launching VersaMail to add a new message from an application.

  • file PalmVMPlugin.h
    Defines APIs and structures for the VersaMail Plugin Service which lets users write plugins to view/send attachments.

  • file VMFontLibCommon.h
    Public common header file for the Versamail Font Library.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:08 2008 for Palm API Guide


Handspring Extensions

Files

  • file HsExt.h
    Header file that 68K programs include to access Handspring Extensions functionality.

  • file HsExtCommon.h
    Common defines shared between HsExt.h (include for 68K programs) and HsExtArm.h (include for ARM programs).

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:08 2008 for Palm API Guide


5-Way Navigation Library

Detailed Description

This library provides 5-way navigation support for applications on the Treo 600 devices.

The 5-way navigation features and APIs described here have already existed in Palm OS SDK for Palm OS ver. 5.4.1 and above, and applications that are developed for newer devices should be using PalmSource's Palm OS definitions of these features and APIs. Developers can use palmOne defined features to extend support back to Treo 600 devices.

For more information on 5-way navigation support, please refer to palmOne Developer Guide and also the Palm OS Documentation.

Files

  • file HsNav.h
    Header file that 68K programs include to access HsNav functionality.

  • file HsNavCommon.h
    Public common header file for 5-way navigation support on Treo 600.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:08 2008 for Palm API Guide


Full Screen Writing API

Detailed Description

This library provides support for applications to enable/disable full screen graffiti programmatically.

Applications can use the functions in this library to enable or disable fullscreen writing, enable and disable the Graffiti 2 shift indicator (GSI) as a control for fullscreen writing, enable and disable Graffiti 2 inking, and even change the colors of Graffiti 2 inking and the GSI.

Developers can check whether the GoLCD Manager is installed by examining its feature set. Call FtrGet as follows:

 err = FtrGet (goLcdCreator, goLcdFtrNumVersion, &value);

Files

  • file PalmGoLCD.h
    Public include header file for the GoLCD Library.

  • file PalmGoLCDCommon.h
    Public common header file for the GoLCD Library.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:08 2008 for Palm API Guide


Palm API Guide Data Structures

Here are the data structures with brief descriptions:
_dataLinks | Structure used for datalinks while sending /rcving data
_HelperServiceMMSDetailsType | Helpers of this Service Class send an MMS message
_HelperServiceMMSObjectType |
_PalmPhotoCaptureParamV2 | Photo/video image capture parameters
_PalmPhotoCreateParam | Photo image create parameters
_PalmPhotoDisplayParam | Photo image display parameters
_PalmPhotoExtraInfo | Photo image extra info parameters
_PalmPhotoFileLocation | Photo file location
_PalmPhotoImageInfo | Photo information
_PalmPhotoReadWriteParam | Photo image manipulation param
_PalmPhotoSelectionParam | Photo selection dialog parameters
_PalmPhotoSelections | Photo selections
_PhnCDMAMediaTVSettings |
_PhnLibMMSServerInfo |
_pluginExtendedQueryParams | Structure used for launch code MMPRO_PLUGIN_EXTENDED_QUERY_LAUNCHCODE
_pluginGetInfoParams | Structure used for launch code MMPRO_PLUGIN_GET_INFO_LAUNCHCODE
_pluginParams | Structure used for launch code MMPRO_PLUGIN_RECEIVE_LAUNCHCODE
_pluginQueryParams | Structure used for launch code MMPRO_PLUGIN_QUERY_LAUNCHCODE
_pluginSendParams | Structure used for launch code MMPRO_PLUGIN_SEND_LAUNCHCODE
AacFileRef |
AddrAddToRecordParamsType |
AddrCallerIDParamsType |
AddrCreateNewRecordParamsType |
AddrDescriptor |
Address |
AddressAppRecord |
AddressAppRecordHeader |
AddressType |
AddrHsLookupUserDataType |
AddrHsLookupUserDataV2Type |
AddrListLookupTypeGetParamsType |
AddrPhonebookAppParamsType |
AddrPhotoCallerIDParamsType |
AiaExtentChangedEventDataType |
ApptTimeZoneType |
BGResult | Structure containing Result of response for a protocol request
BSSListStruct | BSS list
CamLibBitmapInfoTag | Bitmap info structure for every format except PalmBMPV4. Data starts after the parameters
CamLibCaptureTag | Capture settings structure. The callback is called with userDataP passed
CamLibColorSpaceTag | Color Space structure
CamLibSettingTag | Settings Capabilities structure. For settings without manual values, only type is used
CamLibStatusTag | Container for the camera status kCamLibStatus*
CamLibStreamTag | Video stream structure. Used for capturing a video stream
Coordinate |
DevAppLaunchCmdGenericCallType | For devAppLaunchCmdGenericCall
DialPnlDispatchDialParamsType |
DialPnlIsDialingAvailableParamsType |
DSTDataTag |
FrmNavHeaderTag |
FrmNavOrderEntryTag |
HS_HTTPLibAppinfo_ |
HS_HTTPLibAuthInfo_ |
HS_HTTPLibIPAddr_ |
HS_HTTPLibNetLibInfo_ |
HS_HTTPLibOpaque_ |
HS_HTTPLibPeer_ |
HS_HTTPLibSplit_ |
HS_HTTPLibTime_ |
HsBigButtonMappingType |
HsBigButtonReourceType |
HsDialPrefsUSDialingRulesType |
HsSndBufferData | Holds sound buffer information
HsSndMidiProgressMsg |
HsSndPortInfo | Holds sound port information
HtmlLibFocusTargetInfo |
HtmlLibFormWidgetProc | The following are necessary form widget creation/deletion routines that need to get set using HtmlLibSetFormWidgetProc. Please see sample code after looking at HtmlLibSetFormWidgetProc
HttpUASelectionRule |
LcdOverlayLibSettingTag | Generic settings For settings without manual values, only type is used
LocationDataTag |
LocDBInfoTag |
LocDBRecordTag |
LocsLibNotifyDataTag |
LocsLibNotifyLocsDataTag |
LocsLibSelLocsTag |
MailAddRecordAttachment | Structure to add attachment in MailAddRecordParamsTypePlus
MailAddRecordParamsTypePlus | Structure to add a message + attachment passed with MMPRO_ADD_MESSAGE_WITH_ATTACHMENT Categories & MailAddRecordParamsType are defined in AppLaunchCmd.h
MMProAttachDataLinks | Data links used in an attachment, used in MMProAttachStruct2
MMProAttachStruct | Structure for adding attachments in MMProLaunchStruct
MMProAttachStruct2 | Structure for adding attachments in MMProLaunchStruct2
MMProLaunchStruct | Structure to add a message + attachment passed with MMPRO_LAUNCH_CODE
MMProLaunchStruct2 | Structure to add a message + attachment passed with MMPRO_LAUNCH_CODE
NBSNotificationEventType |
Net80211DeviceInfo | Device information concerning Hardware and Firmware information for the "adapter"
NetBssInfoType | Structure to hold BSS Info data
NetMasterClientEventInfoType | This structure is passed as the 'detailsP' of the notification
NetMasterClientEventVPNConnInstallType | Data block for netMasterClientEventVPNConnInstall
NetPrefFallbackInfoType | Fallback info structure
NetPrefGPRSQOSType | NetPrefGPRSQOSType -- GPRS Quality Of Service (QOS) info
NetServicesProfile | Profile entries for SmartConnect
NetServicesProfileInfo | Data returned from NetServicesProfileGetInfo
NetServicesProfileOrder | Priority order to smart connect
NetServicesProfileV1 | Profile entries version 1
NetSSID | Structure used to get and set the current SSID for the driver (not the Network interface)
NetWepKey | Structure used to set the wep keys
NetworkDeviceQueryData | Structure to hold network query data
P1clRecordDetails |
PalmAudioAACDecParamType | AAC decoding parameters
PalmAudioAACParamType | AAC format parameters
PalmAudioADPCMParamType | IMA-ADPCM format parameters
PalmAudioAMRParamType |
PalmAudioMP2ParamType | MPEG-1 audio decoding parameters
PalmAudioPCMParamType | PCM format parameters
PalmAudioPlaybackNotifyEventTypeTag |
PalmAudioQCELPDecParamType |
PalmAudioQCELPParamType |
PalmFileFormatParamType | File format parameters
PalmImageBMPParamType | BMP format parameters
PalmImageGIFFrameParamType | GIF frame parameters
PalmImageINDEXParamType | Index image parameters
PalmImageJPEGEncodeParamType | JPEG format encoding parameters
PalmImageParamType | RAW image format parameters
PalmImagePlanarType | Planar image structure, passed during EncodeDecode
PalmVideoAVCCustomGetDecodedFrameType | AVC/H264 Custom Control API structure for getting a decoded frame
PalmVideoAVCCustomGetInfoType | AVC/H264 Custom Control API structure for GetInfo about frame
PalmVideoAVCCustomSetCropModeType | AVC/H264 Custom Control API structure for getting a decoded frame
PalmVideoAVCDecodeParamType | AVC/H264 video format decoding parameters
PalmVideoAVCOutputBufferType | AVC/H264 video format decoding parameters
PalmVideoMPEG1DecodeParamType | MPEG-1 video decoding parameters
PalmVideoMPEG4DecodeParamType | MPEG-4 video format decoding parameters
PalmVideoMPEG4EncodeParamType | MPEG-4 video format encoding parameters
ParsedInfo | Holds parsed item information
ParsedInfoList | Holds the list of parsed item information
PhnCdmaSystemInfoType |
PhnConferenceDesc |
PhnConnectionType |
PhnDataSessionStateType |
PhnDisconnectEventType |
PhnError |
PhnEventType |
PhnEventType::Data |
PhnGPRSPDPContextListNodeType |
PhnGPRSPDPContextType |
PhnIndicationType |
PhnIOTAPhnDlsLockType | Holds lock state of user's ability to change the download server URL address
PhnIOTAPhnHomepagetype |
PhnIOTAPhnNAIIMStore |
PhnIOTAPhnNAIPPGType |
PhnIOTAPhnNAISIPCfgSvr |
PhnIOTAPhnNAISIPDatagwyType |
PhnIOTAPhnNAISIPDataxchType |
PhnIOTAPhnNAISIPEdgeProxyType |
PhnIOTAPhnProxyAddrWdpType |
PhnIOTAPhnSIPRetryCntType |
PhnIOTAPhnSIPRetryTimerType |
PhnIOTAPhnTlsRcUrlType |
PhnIOTAPhnTrustedDomainType |
PhnIOTAReportType |
PhnKeyPressedParams |
PhnLibLengthInfoType |
PhnLineStateType |
PhnMiscDbgRptType |
PhnMMIEntryType | MMI Decode struct
PhnMMIResultType | MMI result struct
PhnMovedMsgDescType |
PhnMovedMsgsParamsType |
PhnMsgBoxDataType |
PhnNetworkTime |
PhnOnexMipRRQType |
PhnOneXStatus |
PhnOperatorListType |
PhnOperatorType |
PhnPasswordEventType |
PhnPDDataType |
PhnPDPList |
PhnPDPPayload |
PhnPDPWrite |
PhnPhoneBookInfoType |
PhnPhoneEquipmentMode |
PhnPowerEventType |
PhnProgressEventType |
PhnRadioStateType |
PhnRegistrationType |
PhnRingingInfoType |
PhnRingingProfileType |
PhnRoamPrefInfoType |
PhnSATEventDataSvc |
PhnSATEventDisplayText |
PhnSATEventGetInkey |
PhnSATEventGetInput |
PhnSATEventHeader |
PhnSATEventIdleModeText |
PhnSATEventLaunchBrowser |
PhnSATEventMenu |
PhnSATEventMenuRec |
PhnSATEventPlayTone |
PhnSATEventRefresh |
PhnSATEventRunAT |
PhnSATEventSendDTMF |
PhnSATEventSendSMS |
PhnSATEventSetupCall |
PhnSATEventType |
PhnSMSParams |
PhnSMSPrefType |
PhnSubscriberAddrInfo |
PhnUSSDEventType |
PhoneAppLaunchCmdCallerIDLookupType |
PhoneAppLaunchCmdDialType |
PhoneAppLaunchCmdGetALSLineNumberType |
PhoneAppLaunchCmdGetDialPrefFlagType |
PhoneAppLaunchCmdSendDTMFToneType |
PhoneAppLaunchCmdSetWallpaperType |
PmBroadcastNewMsgCountNotifyParamType | Param structure for pmNotifyBroadcastNewMsgCount notifications
PmConnectorNotifyDataType | Container for the notification details
PmGetNewMsgCountNotifyParamType | Param structure for pmNotifyGetNewMsgCountFromHelper notifications
PmSysGadgetBbutMappingType | This is the structure of a single big button mapping..
PmSysGadgetBbutResourceType | This is the structure of a big button resource..
PmSysGadgetPttNotificationType | This is the structure used by the PTT notification event
PosType |
PowerPanelAppPrefs |
SmsHeader |
SMSSendOptions |
SndCodecCustomControlType | Holds Custom Control type information for the Extended Sound Manager
SoundPreference | Structure containing all the Sound Preference data
SoundPreference::_tonePrefs |
SoundPreferenceCalendar | Structure for Calendar Sound Pref
SoundPreferenceEmail | Structure for Email Sound Pref
SoundPreferenceIM | Structure for IM Sound Pref
SoundPreferenceMMS | Structure for MMS Sound Pref
SoundPreferenceNetworkSounds | Structure for network related sounds
SoundPreferencePhone | Structure for Phone Sound Pref
SoundPreferenceSMS | Structure for SMS Sound Pref
SoundPrefsLaunchCmdParamType |
SysVPPILaunchCmdClearPWCacheType | Structure used by the VPN Panel to clear the password cache
SysVPPILaunchCmdDeleteAccountType | Structure used by the VPN Panel to delete an account
SysVPPILaunchCmdEditAccountType | Structure used by the VPN Panel to edit an account
SysVPPILaunchCmdErrorDialogType | Structure used by the VPN Panel to show the error dialog
SysVPPILaunchCmdGetAccountsType | Structure used by the VPN Panel to query the account from a VPPI
SysVPPILaunchCmdProgressPaintType | Structure used by the VPN Panel to show the progess dialog
SysVPPILaunchCmdPromptAndConfigureType | Structure used by the VPN Panel to request the VPPI to display a dialog
SysVPPILaunchCmdSetCurrentAccountType | Structure used by the VPN Panel to set the current account
SysVPPILaunchCmdWillPWPromptType | Structure used by the VPN Panel to determine is the VPPI will prompt for password
SysWPPILaunchCmdClearPWCache |
SysWPPILaunchCmdErrorDialogType |
SysWPPILaunchCmdGetAuthenticationMethodsType |
SysWPPILaunchCmdGetDescriptionType |
SysWPPILaunchCmdPromptAndConfigureType |
SysWPPILaunchCmdType |
tagIOTANotificationEventType |
tagSndFileStreamData | Holds data about a sound file stream
tagSndFileStreamFileSpec | Descriptions of the stream file
tagSndFileStreamHsSoundCommandParam | SndFileStreamDeviceControl param when cmd == hsSoundLibCreatorID
ToneIdentifier | No definition
ToneItemType | Tone characteristics
UPNotificationEventType |
VMFontType | Font characteristics structure used to describe a font
VMFontUIRules | Font UI rules structure used for the font picker setting
VPNAccountType | VPN Account structure
vpnNotifyVPNLibTag |
WAPNotificationEventType |
webBrowserMinimalModeLaunchInfo |
webBrowserURLWithSvcIDLaunchInfo |
WiFiAuthenticationMethodType |
WUNotificationEventType |
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:08 2008 for Palm API Guide


_dataLinks Struct Reference

Detailed Description

Structure used for datalinks while sending /rcving data.

Definition at line 92 of file PalmVMPlugin.h.

Data Fields

  • CharPtr data
  • ULong size

Field Documentation

CharPtr data

pointer to data

Definition at line 94 of file PalmVMPlugin.h.

ULong size

size of data

Definition at line 95 of file PalmVMPlugin.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:09 2008 for Palm API Guide


_HelperServiceMMSDetailsType Struct Reference

Collaboration diagram for _HelperServiceMMSDetailsType:

[legend]

Detailed Description

Helpers of this Service Class send an MMS message.

"To" address(es) are passed in the 'pData' element of the main structure (HelperNotifyExecuteType)

The 'pDetails' struct member may optionally point to HelperServiceMMSDetailsType for this service class.

Definition at line 59 of file MmsHelperCommon.h.

Data Fields

  • UInt16 version
  • Char * cc
  • Char * subject
  • Char * message
  • HelperServiceMMSObjectType * object
  • Char * bcc
  • Boolean justSend

Field Documentation

UInt16 version

This is currently version 1

Definition at line 61 of file MmsHelperCommon.h.

Char* cc

IN: carbon copy address string or NULL -- will be duplicated by helper if necessary; multiple addresses are separated by semicolon (ex. "john@host.com; jane@host.com")

Definition at line 63 of file MmsHelperCommon.h.

Char* subject

IN: subject string or NULL -- will be duplicated by helper if necessary (ex. "helper API")

Definition at line 68 of file MmsHelperCommon.h.

Char* message

IN: initial message body string or NULL -- will be duplicated by helper if necessary (ex. "Lets discuss the helper API tomorrow.") Message will be put on first page.

Definition at line 71 of file MmsHelperCommon.h.

HelperServiceMMSObjectType* object

IN: Head of Linked list of objects to send or NULL

Definition at line 76 of file MmsHelperCommon.h.

Char* bcc

IN: blind carbon copy address string or NULL -- will be duplicated by helper if necessary; multiple addresses are separated by semicolon (ex. "john@host.com; jane@host.com")

Definition at line 78 of file MmsHelperCommon.h.

Boolean justSend

IN: Set this to true to send without invoking any UI

Definition at line 83 of file MmsHelperCommon.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:09 2008 for Palm API Guide


_HelperServiceMMSObjectType Struct Reference

Collaboration diagram for _HelperServiceMMSObjectType:

[legend]

Detailed Description

Structure to hold the MMS object. This structure is part of the linked list which is pointed by the object member of HelperServiceMMSDetailsType

Definition at line 29 of file MmsHelperCommon.h.

Data Fields

  • Int16 pageNum
  • Char * mimeType
  • MemPtr bufferP
  • UInt32 bufferLen
  • Char * tempFileName
  • Boolean isVFSFileName
  • Boolean freeTempFile
  • Char * name
  • _HelperServiceMMSObjectType * nextP

Field Documentation

Int16 pageNum

IN: page of message this content should appear on.

Definition at line 31 of file MmsHelperCommon.h.

Char* mimeType

IN: IANA Mime type for this object (compulsory!) The object may be passed in a buffer or via a file. Either set bufferP and bufferLen or set tempFileName

Definition at line 32 of file MmsHelperCommon.h.

MemPtr bufferP

IN: The object is stored in a buffer if this is non-NULL

Definition at line 37 of file MmsHelperCommon.h.

UInt32 bufferLen

IN: Length of the buffer

Definition at line 38 of file MmsHelperCommon.h.

Char* tempFileName

IN: The temporary file its stored in if bufferP is NULL

Definition at line 40 of file MmsHelperCommon.h.

Boolean isVFSFileName

IN: Is the file local or under VFS e.g Memory card?

Definition at line 41 of file MmsHelperCommon.h.

Boolean freeTempFile

IN: If set, the file should be deleted by the helper application

Definition at line 42 of file MmsHelperCommon.h.

Char* name

IN: the name of the object as sent to us (maybe the filename)

Definition at line 44 of file MmsHelperCommon.h.

struct _HelperServiceMMSObjectType* nextP

IN: Linked list pointer of objects to send.

Definition at line 46 of file MmsHelperCommon.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:09 2008 for Palm API Guide


_PalmPhotoCaptureParamV2 Struct Reference

Collaboration diagram for _PalmPhotoCaptureParamV2:

[legend]

Detailed Description

Photo/video image capture parameters.

The callback function allows the calling application to cancel the image capture operation. The user may cancel the operation by interacting with the capture application. New in v2.0.

Definition at line 199 of file palmOnePhoto.h.

Data Fields

  • PalmPhotoFileLocation fileLocation
  • PalmPhotoImageInfo imageInfo
  • PalmPhotoCaptureCallbackV2 captureCallback
  • void * userDataP

Field Documentation

PalmPhotoFileLocation fileLocation

IN: file location of new file.

Definition at line 201 of file palmOnePhoto.h.

PalmPhotoImageInfo imageInfo

supported for video) IN: file information.

Definition at line 204 of file palmOnePhoto.h.

PalmPhotoCaptureCallbackV2 captureCallback

IN: capture callback.

Definition at line 205 of file palmOnePhoto.h.

void* userDataP

IN: User data.

Definition at line 206 of file palmOnePhoto.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:09 2008 for Palm API Guide


_PalmPhotoCreateParam Struct Reference

Collaboration diagram for _PalmPhotoCreateParam:

[legend]

Detailed Description

Photo image create parameters.

Set imageInfo can determines the type of the file. To create a JPEG image, set imageInfo.fileFormat to palmPhotoJPEGFileFormat.

Definition at line 184 of file palmOnePhoto.h.

Data Fields

  • PalmPhotoFileLocation fileLocation
  • PalmPhotoImageInfo imageInfo

Field Documentation

PalmPhotoFileLocation fileLocation

IN: file location of new file.

Definition at line 186 of file palmOnePhoto.h.

PalmPhotoImageInfo imageInfo

IN: file information.

Definition at line 187 of file palmOnePhoto.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:09 2008 for Palm API Guide


_PalmPhotoDisplayParam Struct Reference

Detailed Description

Photo image display parameters.

The bounds might be ignored by the application. New in v2.0: If playing a video, winH and rect are ignored.

Definition at line 169 of file palmOnePhoto.h.

Data Fields

  • WinHandle winH
  • RectangleType rect
  • PalmPhotoDisplayCallback displayCallback
  • void * userDataP

Field Documentation

WinHandle winH

IN: WinHandle.

Definition at line 171 of file palmOnePhoto.h.

RectangleType rect

IN: Display rectangle.

Definition at line 172 of file palmOnePhoto.h.

PalmPhotoDisplayCallback displayCallback

IN: display callback.

Definition at line 173 of file palmOnePhoto.h.

void* userDataP

IN: User data.

Definition at line 174 of file palmOnePhoto.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:09 2008 for Palm API Guide


_PalmPhotoExtraInfo Struct Reference

Detailed Description

Photo image extra info parameters.

Gets extra information on an image.

Definition at line 373 of file palmOnePhotoCommon.h.

Data Fields

  • PalmPhotoExtraInfoType infoType
  • UInt16 reserved
  • void * infoP
  • UInt32 infoSize

Field Documentation

PalmPhotoExtraInfoType infoType

IN: Image info type.

Definition at line 375 of file palmOnePhotoCommon.h.

UInt16 reserved

reserved for future use

Definition at line 376 of file palmOnePhotoCommon.h.

void* infoP

OUT: Points to the information selected.

Definition at line 377 of file palmOnePhotoCommon.h.

UInt32 infoSize

OUT: Size of the buffer pointed by infoP.

Definition at line 378 of file palmOnePhotoCommon.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:09 2008 for Palm API Guide


_PalmPhotoFileLocation Struct Reference

Detailed Description

Photo file location.

This structure is used to open, create and query location information of an image.

Definition at line 325 of file palmOnePhotoCommon.h.

Data Fields

  • PalmPhotoLocationType fileLocationType
  • UInt16 reserved
  • union {
    • struct {
      • Char name [dmDBNameLength]
      • UInt32 type
      • UInt32 creator
    • } StreamFile
    • struct {
      • Char name [PALM_PHOTO_MAX_PATH+1]
      • UInt16 volumeRef
      • UInt16 reserved
    • } VFSFile
    • struct {
      • void * bufferP
      • UInt32 bufferSize
    • } MemoryFile
  • } file

Field Documentation

PalmPhotoLocationType fileLocationType

File location type.

Definition at line 327 of file palmOnePhotoCommon.h.

UInt16 reserved

reserved for future use

Definition at line 328 of file palmOnePhotoCommon.h.

Char name[PALM_PHOTO_MAX_PATH+1]

File name on the device.

Definition at line 332 of file palmOnePhotoCommon.h.

UInt32 type

Type of the stream.

Definition at line 333 of file palmOnePhotoCommon.h.

UInt32 creator

Creator of the stream.

Definition at line 334 of file palmOnePhotoCommon.h.

struct { ... } StreamFile

File format: stream

UInt16 volumeRef

Volume where the file is located.

Definition at line 339 of file palmOnePhotoCommon.h.

struct { ... } VFSFile

File format: VFS

void* bufferP

Buffer holding the image.

Definition at line 344 of file palmOnePhotoCommon.h.

UInt32 bufferSize

Size of the buffer.

Definition at line 345 of file palmOnePhotoCommon.h.

struct { ... } MemoryFile

File format: Memory

union { ... } file

Image location.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:09 2008 for Palm API Guide


_PalmPhotoImageInfo Struct Reference

Detailed Description

Photo information.

This structure contains the basic image information.

Definition at line 357 of file palmOnePhotoCommon.h.

Data Fields

  • UInt32 width
  • UInt32 height
  • UInt32 bitsPerPixel
  • UInt32 filesize
  • PalmPhotoFileFormat fileFormat
  • PalmPhotoQualityType imageQuality

Field Documentation

UInt32 width

Width in pixels of the image.

Definition at line 359 of file palmOnePhotoCommon.h.

UInt32 height

Height in pixels of the image.

Definition at line 360 of file palmOnePhotoCommon.h.

UInt32 bitsPerPixel

Color depth of the image.

Definition at line 361 of file palmOnePhotoCommon.h.

UInt32 filesize

File size, in bytes.

Definition at line 362 of file palmOnePhotoCommon.h.

PalmPhotoFileFormat fileFormat

File format, e.g., JPEG, GIF.

Definition at line 363 of file palmOnePhotoCommon.h.

PalmPhotoQualityType imageQuality

Image quality.

Definition at line 364 of file palmOnePhotoCommon.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:09 2008 for Palm API Guide


_PalmPhotoReadWriteParam Struct Reference

Detailed Description

Photo image manipulation param.

This parameter is used to set the callback for reading and writing data of an image. The imageFormat provides the user a way to convert images. For example, reading a JPEG image and setting imageFormat to RGB565 should convert the JPEG to RGB565.

Definition at line 154 of file palmOnePhoto.h.

Data Fields

  • PalmPhotoFileFormat imageFormat
  • UInt16 reserved
  • PalmPhotoReadWriteCallback rwCallback
  • void * userDataP

Field Documentation

PalmPhotoFileFormat imageFormat

IN: Memory file image format.

Definition at line 156 of file palmOnePhoto.h.

UInt16 reserved

reserved for future use

Definition at line 157 of file palmOnePhoto.h.

PalmPhotoReadWriteCallback rwCallback

IN: Read/Write callback.

Definition at line 158 of file palmOnePhoto.h.

void* userDataP

IN: User data.

Definition at line 159 of file palmOnePhoto.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:09 2008 for Palm API Guide


_PalmPhotoSelectionParam Struct Reference

Collaboration diagram for _PalmPhotoSelectionParam:

[legend]

Detailed Description

Photo selection dialog parameters.

This structure is used for the selection dialog and direct image selection. When using the PMPSelectImages API, selectionCount contains the maximum number of images that can be selected. If selectionCount is set to PALM_PHOTO_SELECT_ALL, the range would be [offset, end]. If albumID is set to PALM_PHOTO_ALBUM_ALL, all images can be selected.

NOTE: The API allocates memory inside of selectedImages. It is the caller's responsibility to free that memory via PalmPhotoFreeSelections().

Definition at line 134 of file palmOnePhoto.h.

Data Fields

  • UInt16 albumID
  • UInt16 reserved
  • UInt32 offset
  • Int32 selectionCount
  • PalmPhotoFilterCallback filterCallback
  • void * userDataP
  • PalmPhotoSelections selectedImages

Field Documentation

UInt16 albumID

IN: Album ID for selection.

Definition at line 136 of file palmOnePhoto.h.

UInt16 reserved

reserved for future use

Definition at line 137 of file palmOnePhoto.h.

UInt32 offset

IN: Range start.

Definition at line 138 of file palmOnePhoto.h.

Int32 selectionCount

IN: Number of images to select.

Definition at line 139 of file palmOnePhoto.h.

PalmPhotoFilterCallback filterCallback

IN: Callback to filter the selections.

Definition at line 140 of file palmOnePhoto.h.

void* userDataP

IN: User data to be passed during callback.

Definition at line 141 of file palmOnePhoto.h.

PalmPhotoSelections selectedImages

OUT: Struct containing handle array.

Definition at line 142 of file palmOnePhoto.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:09 2008 for Palm API Guide


_PalmPhotoSelections Struct Reference

Detailed Description

Photo selections.

This strucutre is used during image selections, either by using the PalmPhotoSelectDlg() function of the PalmPhotoSelect() function.

Definition at line 390 of file palmOnePhotoCommon.h.

Data Fields

  • UInt32 imageCount
  • PalmPhotoHandle * imageH

Field Documentation

UInt32 imageCount

Number of images.

Definition at line 392 of file palmOnePhotoCommon.h.

PalmPhotoHandle* imageH

Array of image handles.

Definition at line 393 of file palmOnePhotoCommon.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:09 2008 for Palm API Guide


_PhnCDMAMediaTVSettings Struct Reference

Detailed Description

Definition at line 905 of file HsPhoneCDMATypes.h.

Data Fields

  • UInt32 version
  • char homePage [phnMaxUrlLen+1]
  • UInt32 proxyAddr
  • UInt16 proxyPort
  • UInt32 streamBufferSize
  • UInt32 streamTimeout

Field Documentation

UInt32 version

(1) should be set to the structure version that you are requesting

Definition at line 907 of file HsPhoneCDMATypes.h.

char homePage[phnMaxUrlLen+1]

NULL terminated string

Definition at line 909 of file HsPhoneCDMATypes.h.

UInt32 proxyAddr

proxy IP address

Definition at line 910 of file HsPhoneCDMATypes.h.

UInt16 proxyPort

proxy port

Definition at line 911 of file HsPhoneCDMATypes.h.

UInt32 streamBufferSize

stream buffer size

Definition at line 912 of file HsPhoneCDMATypes.h.

UInt32 streamTimeout

streaming timeout

Definition at line 913 of file HsPhoneCDMATypes.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:09 2008 for Palm API Guide


_PhnLibMMSServerInfo Struct Reference

Detailed Description

Definition at line 482 of file HsPhoneSMSTypes.h.

Data Fields

  • UInt32 version
  • UInt32 max_message_size
  • UInt8 mms_server_name [kMMSStringMaxLen+1]
  • UInt8 mml_server_name [kMMSStringMaxLen+1]
  • UInt8 pix_place_server [kMMSPixPlaceMaxLen+1]
  • UInt8 user_agent [kMMSStringMaxLen+1]
  • UInt8 maxRetries
  • UInt8 timeout
  • Boolean deliveryAck

Field Documentation

UInt32 version

must be set to PhnLibMMSServerInfoVersion

Definition at line 484 of file HsPhoneSMSTypes.h.

UInt32 max_message_size

max message size kB

Definition at line 485 of file HsPhoneSMSTypes.h.

UInt8 mms_server_name[kMMSStringMaxLen+1]

MMS server [NULL terminated string]

Definition at line 486 of file HsPhoneSMSTypes.h.

UInt8 mml_server_name[kMMSStringMaxLen+1]

MML server [NULL terminated string]

Definition at line 487 of file HsPhoneSMSTypes.h.

UInt8 pix_place_server[kMMSPixPlaceMaxLen+1]

MMS Pix place address [NULL terminated string]

Definition at line 488 of file HsPhoneSMSTypes.h.

UInt8 user_agent[kMMSStringMaxLen+1]

user agent string [NULL terminated string]

Definition at line 489 of file HsPhoneSMSTypes.h.

UInt8 maxRetries

number of retry attempts

Definition at line 490 of file HsPhoneSMSTypes.h.

UInt8 timeout

MMSC timeout

Definition at line 491 of file HsPhoneSMSTypes.h.

Boolean deliveryAck

delivery ack setting

Definition at line 492 of file HsPhoneSMSTypes.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:09 2008 for Palm API Guide


_pluginExtendedQueryParams Struct Reference

Detailed Description

Structure used for launch code MMPRO_PLUGIN_EXTENDED_QUERY_LAUNCHCODE.

Definition at line 167 of file PalmVMPlugin.h.

Data Fields

  • int type
  • Char * MIMEtype
  • Char * fileExt
  • DmOpenRef db
  • Boolean supported
  • int numItems
  • char ** listNames
  • char ** listPtrs
  • ULong ** size
  • UInt32 ret
  • Char Unused [50]

Field Documentation

int type

[in] attachment type

Definition at line 169 of file PalmVMPlugin.h.

Char* MIMEtype

[in] attachment MIME type

Definition at line 170 of file PalmVMPlugin.h.

Char* fileExt

[in] attachment file extention

Definition at line 171 of file PalmVMPlugin.h.

DmOpenRef db

[in]reference to open database for large memory allocations

Definition at line 173 of file PalmVMPlugin.h.

Boolean supported

[out] we support this extension

Definition at line 174 of file PalmVMPlugin.h.

int numItems

[out] number of items selected

Definition at line 175 of file PalmVMPlugin.h.

char** listNames

[out] name of the attachment files

Definition at line 176 of file PalmVMPlugin.h.

char** listPtrs

[out] attachments renders and ready to send

Definition at line 177 of file PalmVMPlugin.h.

ULong** size

[out] size for each attachment

Definition at line 178 of file PalmVMPlugin.h.

UInt32 ret

[out] return code for error handling and special cases;

Definition at line 179 of file PalmVMPlugin.h.

Char Unused[50]

unused space for future releases

Definition at line 180 of file PalmVMPlugin.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:09 2008 for Palm API Guide


_pluginGetInfoParams Struct Reference

Detailed Description

Structure used for launch code MMPRO_PLUGIN_GET_INFO_LAUNCHCODE.

Definition at line 63 of file PalmVMPlugin.h.

Data Fields

  • PluginInfo getInfo
  • UInt32 version
  • Boolean supportsSending
  • Boolean supportsReceiving
  • char ** listSendNames
  • UInt16 numSendTypes
  • Int16 numReceiveTypes
  • char ** listSendFileExt
  • char ** listReceiveFileExt
  • UInt32 * listMaxSizeExt
  • char ** listSendMIMEtypes
  • char ** listReceiveMIMEtypes
  • UInt32 * listMaxSizeMime
  • UInt32 ret
  • Char Unused [50]

Field Documentation

PluginInfo getInfo

[in] what plugin information needed.

Definition at line 65 of file PalmVMPlugin.h.

UInt32 version

[out] plugin version.

Definition at line 67 of file PalmVMPlugin.h.

Boolean supportsSending

[out] can provide data to be passed as an email attachment.

Definition at line 68 of file PalmVMPlugin.h.

Boolean supportsReceiving

[out] can view files passed to it.

Definition at line 69 of file PalmVMPlugin.h.

char** listSendNames

[out] list of names of the types. (suitable for listing in popup)

Definition at line 71 of file PalmVMPlugin.h.

UInt16 numSendTypes

[out] the number of types it can send (each one should appear in popup)

Definition at line 73 of file PalmVMPlugin.h.

Int16 numReceiveTypes

[out] the number of types it can receive

Definition at line 74 of file PalmVMPlugin.h.

char** listSendFileExt

[out] list of supported file extensions to Send.

Definition at line 76 of file PalmVMPlugin.h.

char** listReceiveFileExt

[out] list of supported file extensions it can read.

Definition at line 77 of file PalmVMPlugin.h.

UInt32* listMaxSizeExt

lout] list of max file size supported for each file ext.

Definition at line 78 of file PalmVMPlugin.h.

char** listSendMIMEtypes

[out] list of supported MIME types to Send.

Definition at line 80 of file PalmVMPlugin.h.

char** listReceiveMIMEtypes

[out] list of supported MIME types it can read.

Definition at line 81 of file PalmVMPlugin.h.

UInt32* listMaxSizeMime

lout] list of max file size supported for each MIME type.

Definition at line 82 of file PalmVMPlugin.h.

UInt32 ret

[out] return code for error handling and special cases;

Definition at line 83 of file PalmVMPlugin.h.

Char Unused[50]

unused space for future releases

Definition at line 84 of file PalmVMPlugin.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:10 2008 for Palm API Guide


_pluginParams Struct Reference

Collaboration diagram for _pluginParams:

[legend]

Detailed Description

Structure used for launch code MMPRO_PLUGIN_RECEIVE_LAUNCHCODE.

Definition at line 103 of file PalmVMPlugin.h.

Data Fields

  • ULong version
  • Char * MIMEtype
  • Char * fileExt
  • ULong size
  • CharPtr fname
  • CharPtr data
  • DmOpenRef db
  • UInt numDataLinks
  • dataLinks * moreData
  • UInt32 ret
  • Char Unused [50]

Field Documentation

ULong version

[in] plugin version

Definition at line 105 of file PalmVMPlugin.h.

Char* MIMEtype

[in] attachment MIME type

Definition at line 106 of file PalmVMPlugin.h.

Char* fileExt

[in] attachment file extention

Definition at line 107 of file PalmVMPlugin.h.

ULong size

[in] size of data

Definition at line 108 of file PalmVMPlugin.h.

CharPtr fname

[in] filename of attachment

Definition at line 109 of file PalmVMPlugin.h.

CharPtr data

[in] the data

Definition at line 110 of file PalmVMPlugin.h.

DmOpenRef db

[in] reference to open database for large memory allocations

Definition at line 111 of file PalmVMPlugin.h.

UInt numDataLinks

[in] number of data links

Definition at line 112 of file PalmVMPlugin.h.

dataLinks* moreData

[in] ptr to data links

Definition at line 113 of file PalmVMPlugin.h.

UInt32 ret

[out] return code for error handling and special cases;

Definition at line 114 of file PalmVMPlugin.h.

Char Unused[50]

unused space for future releases

Definition at line 115 of file PalmVMPlugin.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:10 2008 for Palm API Guide


_pluginQueryParams Struct Reference

Detailed Description

Structure used for launch code MMPRO_PLUGIN_QUERY_LAUNCHCODE.

Definition at line 124 of file PalmVMPlugin.h.

Data Fields

  • Char * fileExt
  • Char * MIMEtype
  • DmOpenRef db
  • int numItems
  • UInt32 * itemSizes
  • char ** listItems
  • void ** itemDescriptors
  • UInt32 ret
  • Char Unused [50]

Field Documentation

Char* fileExt

[in] file extention of list of files requested

Definition at line 126 of file PalmVMPlugin.h.

Char* MIMEtype

[in] MIME type of list of files requested

Definition at line 127 of file PalmVMPlugin.h.

DmOpenRef db

[in]reference to open database for large memory allocations

Definition at line 128 of file PalmVMPlugin.h.

int numItems

[out] number of items of this type

Definition at line 129 of file PalmVMPlugin.h.

UInt32* itemSizes

[out] size of items

Definition at line 130 of file PalmVMPlugin.h.

char** listItems

[out] the items

Definition at line 131 of file PalmVMPlugin.h.

void** itemDescriptors

[out] private descriptors defined/recognized by plugin. This memory will be freed by VersaMail

Definition at line 132 of file PalmVMPlugin.h.

UInt32 ret

[out] return code for error handling and special cases;

Definition at line 133 of file PalmVMPlugin.h.

Char Unused[50]

unused space for future releases

Definition at line 134 of file PalmVMPlugin.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:10 2008 for Palm API Guide


_pluginSendParams Struct Reference

Collaboration diagram for _pluginSendParams:

[legend]

Detailed Description

Structure used for launch code MMPRO_PLUGIN_SEND_LAUNCHCODE.

Definition at line 142 of file PalmVMPlugin.h.

Data Fields

  • Char * MIMEtype
  • Char * fileExt
  • DmOpenRef db
  • int selectedItem
  • void * selectedDescriptor
  • char * item
  • char * name
  • char * ptr
  • ULong size
  • UInt numDataLinks
  • dataLinks * moreData
  • UInt32 ret
  • Char Unused [50]

Field Documentation

Char* MIMEtype

[in] attachment MIME type

Definition at line 144 of file PalmVMPlugin.h.

Char* fileExt

[in] attachment file extention

Definition at line 145 of file PalmVMPlugin.h.

DmOpenRef db

[in]reference to open database for large memory allocations

Definition at line 147 of file PalmVMPlugin.h.

int selectedItem

[in] item number that was selected

Definition at line 148 of file PalmVMPlugin.h.

void* selectedDescriptor

[in] descriptor of item that was selected

Definition at line 149 of file PalmVMPlugin.h.

char* item

[in] the item selected

Definition at line 150 of file PalmVMPlugin.h.

char* name

[out] name of the attachment file

Definition at line 151 of file PalmVMPlugin.h.

char* ptr

[out] attachment rendered and ready to send! this memory will be freed by MMPRO

Definition at line 152 of file PalmVMPlugin.h.

ULong size

[out] size of attachment above

Definition at line 154 of file PalmVMPlugin.h.

UInt numDataLinks

[out] number of data links

Definition at line 156 of file PalmVMPlugin.h.

dataLinks* moreData

[out] ptr to data links

Definition at line 157 of file PalmVMPlugin.h.

UInt32 ret

[out] return code for error handling and special cases;

Definition at line 158 of file PalmVMPlugin.h.

Char Unused[50]

unused space for future releases

Definition at line 159 of file PalmVMPlugin.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:10 2008 for Palm API Guide


AacFileRef Struct Reference

Detailed Description

Definition at line 429 of file palmOneCodecFormat.h.

Data Fields

  • UInt32 flags
  • union {
    • struct {
      • UInt32 volRefNum
      • FileRef fileRef
    • } file
    • struct {
      • FileHand fileH
      • UInt32 type
      • UInt32 creator
    • } stream
  • } u

Field Documentation

UInt32 flags

Set to VFS or FileStream

Definition at line 430 of file palmOneCodecFormat.h.

UInt32 volRefNum

Definition at line 434 of file palmOneCodecFormat.h.

FileRef fileRef

Definition at line 435 of file palmOneCodecFormat.h.

struct { ... } file

FileHand fileH

Definition at line 439 of file palmOneCodecFormat.h.

UInt32 type

Definition at line 440 of file palmOneCodecFormat.h.

UInt32 creator

Definition at line 441 of file palmOneCodecFormat.h.

struct { ... } stream

union { ... } u

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:10 2008 for Palm API Guide


AddrAddToRecordParamsType Struct Reference

Detailed Description

Contains data when launching phone book with create new record view.

Definition at line 267 of file HsAppLaunchCmd.h.

Data Fields

  • Char * data
  • UInt32 uniqueID
  • UInt8 field

Field Documentation

Char* data

Data to save (Null terminated string)

Definition at line 269 of file HsAppLaunchCmd.h.

UInt32 uniqueID

The UID of the contact to save the phone number to

Definition at line 270 of file HsAppLaunchCmd.h.

UInt8 field

Phone number, URL, or email address field number. They are defined in ViewForm.c as follows: define kAddrDBRecMobileFld 5 // phone3 define kAddrDBRecEMailFld 7 // phone5 define kAddrDBRecURLFld 14 // custom1 The values are based on the field definition in AddressDB.h.

Definition at line 271 of file HsAppLaunchCmd.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:10 2008 for Palm API Guide


AddrCallerIDParamsType Struct Reference

Detailed Description

Parameter block for addrAppLaunchCmdCallerID.

Definition at line 176 of file HsAppLaunchCmd.h.

Data Fields

  • Char * lookupString
  • Char * formatString
  • Char * resultString
  • Boolean(* callback )(void *)
  • void * ref
  • UInt32 uniqueID
  • UInt16 flags
  • UInt16 recordNum

Field Documentation

Char* lookupString

Must be only digits and include country code. Example: 14085551212

Definition at line 178 of file HsAppLaunchCmd.h.

Char* formatString

Format of the output string like AddrLookupParamsPtr->formatString Example ^name ( ^phonetypelabel ) might result in "David ( work )"

Definition at line 180 of file HsAppLaunchCmd.h.

Char* resultString

Returned heap allocated string resultStringH;

Definition at line 184 of file HsAppLaunchCmd.h.

Boolean(* callback)(void *)

Call back; Returns true to stop execution

void* ref

Reference that gets passed to callbackFunc

Definition at line 186 of file HsAppLaunchCmd.h.

UInt32 uniqueID

Unique ID of the matching record 0 if no match

Definition at line 187 of file HsAppLaunchCmd.h.

UInt16 flags

Flags associated with the called ID

Definition at line 188 of file HsAppLaunchCmd.h.

UInt16 recordNum

record number of the matching record.

Definition at line 189 of file HsAppLaunchCmd.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:10 2008 for Palm API Guide


AddrCreateNewRecordParamsType Struct Reference

Detailed Description

Contains data when launching phone book with create new record view.

Definition at line 247 of file HsAppLaunchCmd.h.

Data Fields

  • Char * data
  • UInt8 field

Field Documentation

Char* data

Data to save (Null terminated string)

Definition at line 249 of file HsAppLaunchCmd.h.

UInt8 field

Phone number, URL, or email address field number. They are defined in ViewForm.c as follows: define kAddrDBRecMobileFld 5 // phone3 define kAddrDBRecEMailFld 7 // phone5 define kAddrDBRecURLFld 14 // custom1 The values are based on the field definition in AddressDB.h.

Definition at line 250 of file HsAppLaunchCmd.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:10 2008 for Palm API Guide


AddrDescriptor Struct Reference

Detailed Description

Item description here

Definition at line 108 of file HsPhoneSMSTypes.h.

Data Fields

  • UInt16 count

Field Documentation

UInt16 count

Length of list

Definition at line 109 of file HsPhoneSMSTypes.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:10 2008 for Palm API Guide


Address Struct Reference

Detailed Description

This should probably be private to the library

Definition at line 94 of file HsPhoneSMSTypes.h.

Data Fields

  • AddressAppPhoneLabelType kind
  • char filler
  • UInt32 uniqueID
  • UInt16 phoneBookIndex
  • UInt16 count [3]

Field Documentation

AddressAppPhoneLabelType kind

Definition at line 96 of file HsPhoneSMSTypes.h.

char filler

Definition at line 97 of file HsPhoneSMSTypes.h.

UInt32 uniqueID

Definition at line 98 of file HsPhoneSMSTypes.h.

UInt16 phoneBookIndex

Definition at line 99 of file HsPhoneSMSTypes.h.

UInt16 count[3]

Definition at line 100 of file HsPhoneSMSTypes.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:10 2008 for Palm API Guide


AddressAppRecord Struct Reference

Collaboration diagram for AddressAppRecord:

[legend]

Detailed Description

Item description here

Definition at line 148 of file HsPhoneSMSTypes.h.

Data Fields

  • MemHandle mData
  • UInt32 mID
  • Boolean mLocked
  • Int8 reserved1
  • AddressAppRecordHeader * mHeader

Field Documentation

MemHandle mData

Definition at line 156 of file HsPhoneSMSTypes.h.

UInt32 mID

Definition at line 157 of file HsPhoneSMSTypes.h.

Boolean mLocked

Definition at line 158 of file HsPhoneSMSTypes.h.

Int8 reserved1

padding

Definition at line 159 of file HsPhoneSMSTypes.h.

AddressAppRecordHeader* mHeader

Definition at line 160 of file HsPhoneSMSTypes.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:10 2008 for Palm API Guide


AddressAppRecordHeader Struct Reference

Detailed Description

Item description here

Definition at line 134 of file HsPhoneSMSTypes.h.

Data Fields

  • UInt32 options
  • UInt32 flags
  • UInt8 companyOffset
  • char data

Field Documentation

UInt32 options

Definition at line 135 of file HsPhoneSMSTypes.h.

UInt32 flags

Definition at line 136 of file HsPhoneSMSTypes.h.

UInt8 companyOffset

Definition at line 137 of file HsPhoneSMSTypes.h.

char data

Definition at line 138 of file HsPhoneSMSTypes.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:10 2008 for Palm API Guide


AddressType Struct Reference

Collaboration diagram for AddressType:

[legend]

Detailed Description

Item description here

Definition at line 122 of file HsPhoneSMSTypes.h.

Data Fields

  • UInt16 addressSize
  • Address address

Field Documentation

UInt16 addressSize

Definition at line 123 of file HsPhoneSMSTypes.h.

Address address

Definition at line 124 of file HsPhoneSMSTypes.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:10 2008 for Palm API Guide


AddrHsLookupUserDataType Struct Reference

Detailed Description

Structure that contains the data used for looking up user info in address book app

Definition at line 285 of file HsAppLaunchCmd.h.

Data Fields

  • UInt16 version
  • Boolean matchFound
  • Boolean useMultiFilter

Field Documentation

UInt16 version

IN: Version of the userData structure

Definition at line 287 of file HsAppLaunchCmd.h.

Boolean matchFound

OUT: TRUE if ANY match was found. (i.e. 1 or more matches were found) FALSE if NO match was found.

Definition at line 288 of file HsAppLaunchCmd.h.

Boolean useMultiFilter

IN: TRUE if lookup should use multifilter. FALSE if lookup should NOT use multifilter.

Definition at line 292 of file HsAppLaunchCmd.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:10 2008 for Palm API Guide


AddrHsLookupUserDataV2Type Struct Reference

Detailed Description

Definition at line 299 of file HsAppLaunchCmd.h.

Data Fields

  • UInt16 version
  • Boolean matchFound
  • Boolean useMultiFilter
  • Boolean displaySIMbook

Field Documentation

UInt16 version

IN: Version of the userData structure

Definition at line 301 of file HsAppLaunchCmd.h.

Boolean matchFound

OUT: TRUE if ANY match was found. (i.e. 1 or more matches were found) FALSE if NO match was found.

Definition at line 302 of file HsAppLaunchCmd.h.

Boolean useMultiFilter

IN: TRUE if lookup should use multifilter. FALSE if lookup should NOT use multifilter.

Definition at line 306 of file HsAppLaunchCmd.h.

Boolean displaySIMbook

IN: TRUE if lookup should display Simbook entries. FALSE if lookup should NOT display Simbook entries.

Definition at line 308 of file HsAppLaunchCmd.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:10 2008 for Palm API Guide


AddrListLookupTypeGetParamsType Struct Reference

Detailed Description

Contains data used when launching address book for contact lookup.

Definition at line 211 of file HsAppLaunchCmd.h.

Data Fields

  • UInt16 version
  • AddrListLookupTypeEnum type

Field Documentation

UInt16 version

IN/OUT: Should always be 0...

Definition at line 213 of file HsAppLaunchCmd.h.

AddrListLookupTypeEnum type

OUT: The type of phone lookup that will occur if you do a lookup by listName.

Definition at line 214 of file HsAppLaunchCmd.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:10 2008 for Palm API Guide


AddrPhonebookAppParamsType Struct Reference

Detailed Description

Parameter block for addrAppLaunchCmdHsPhonebook.

Definition at line 225 of file HsAppLaunchCmd.h.

Data Fields

  • Char * lookupStrP
  • Boolean activeCall
  • Boolean lookup
  • Char * newPhoneNum

Field Documentation

Char* lookupStrP

The lookup string that should be preloaded in the lookup field

Definition at line 227 of file HsAppLaunchCmd.h.

Boolean activeCall

Whether the active call icon should be usable or not... could change in a sublaunch when a call is dropped

Definition at line 229 of file HsAppLaunchCmd.h.

Boolean lookup

True if this notification is for a lookup false if it is for a new contact

Definition at line 232 of file HsAppLaunchCmd.h.

Char* newPhoneNum

Phone number of the new contact.

Definition at line 234 of file HsAppLaunchCmd.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:10 2008 for Palm API Guide


AddrPhotoCallerIDParamsType Struct Reference

Detailed Description

Support for addrAppNotificationPhotoCallerID

Definition at line 317 of file HsAppLaunchCmd.h.

Data Fields

  • UInt16 recordNum
  • Coord xExtent
  • Coord yExtent
  • void * imageBits

Field Documentation

UInt16 recordNum

Record for which we want to get the picture id

Definition at line 319 of file HsAppLaunchCmd.h.

Coord xExtent

Dimension of the photo required. Pass 0 to get max size.

Definition at line 320 of file HsAppLaunchCmd.h.

Coord yExtent

Dimension of the photo required. Pass 0 to get max size.

Definition at line 321 of file HsAppLaunchCmd.h.

void* imageBits

Bits that represent the caller id image. image size returned in xExtent & yExtent

Definition at line 322 of file HsAppLaunchCmd.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:10 2008 for Palm API Guide


AiaExtentChangedEventDataType Struct Reference

Detailed Description

Definition at line 103 of file PalmPin.h.

Data Fields

  • RectangleType newDim
  • RectangleType oldDim

Field Documentation

RectangleType newDim

Definition at line 105 of file PalmPin.h.

RectangleType oldDim

Definition at line 106 of file PalmPin.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:10 2008 for Palm API Guide


ApptTimeZoneType Struct Reference

Collaboration diagram for ApptTimeZoneType:

[legend]

Detailed Description

Definition at line 275 of file DatebookLibCommon.h.

Data Fields

  • Int16 uTC
  • DSTType dSTStart
  • DSTType dSTEnd
  • Int16 dSTAdjustmentInMinutes
  • CountryType country
  • UInt8 custom: 1
  • UInt8 reserved: 7
  • Char name [apptMaxTimeZoneNameLen+1]

Field Documentation

Int16 uTC

Definition at line 276 of file DatebookLibCommon.h.

DSTType dSTStart

Definition at line 277 of file DatebookLibCommon.h.

DSTType dSTEnd

Definition at line 278 of file DatebookLibCommon.h.

Int16 dSTAdjustmentInMinutes

Definition at line 279 of file DatebookLibCommon.h.

CountryType country

Definition at line 280 of file DatebookLibCommon.h.

UInt8 custom

Definition at line 281 of file DatebookLibCommon.h.

UInt8 reserved

Definition at line 281 of file DatebookLibCommon.h.

Char name[apptMaxTimeZoneNameLen+1]

Definition at line 283 of file DatebookLibCommon.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:11 2008 for Palm API Guide


BGResult Struct Reference

Detailed Description

Structure containing Result of response for a protocol request.

Definition at line 109 of file PalmBGService.h.

Data Fields

  • UInt32 majorResult
  • UInt32 protocolErr
  • char protocolErrString [IBG_MAXBUFSZ]

Field Documentation

UInt32 majorResult

One of the above defined return values

Definition at line 111 of file PalmBGService.h.

UInt32 protocolErr

Any protocol specific error code, if any

Definition at line 112 of file PalmBGService.h.

char protocolErrString[IBG_MAXBUFSZ]

Any protocol err response from the server

Definition at line 113 of file PalmBGService.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:11 2008 for Palm API Guide


BSSListStruct Struct Reference

Collaboration diagram for BSSListStruct:

[legend]

Detailed Description

BSS list.

This data structure is returned from a BSS scan. The count field indicates how many BSS structures are provide.

Definition at line 439 of file PalmWiFiCommon.h.

Data Fields

  • UInt32 count
  • NetBssInfoType BSS [1]

Field Documentation

UInt32 count

Definition at line 441 of file PalmWiFiCommon.h.

NetBssInfoType BSS[1]

Definition at line 442 of file PalmWiFiCommon.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:11 2008 for Palm API Guide


CamLibBitmapInfoTag Struct Reference

Detailed Description

Bitmap info structure for every format except PalmBMPV4. Data starts after the parameters.

Definition at line 175 of file palmOneCameraCommon.h.

Data Fields

  • UInt16 width
  • UInt16 height
  • UInt32 numBytes
  • UInt8 bitsPerPixel
  • UInt8 reserved0
  • UInt16 reserved1

Field Documentation

UInt16 width

Width of the bitmap.

Definition at line 177 of file palmOneCameraCommon.h.

UInt16 height

Height of the bitmap.

Definition at line 178 of file palmOneCameraCommon.h.

UInt32 numBytes

Number or Bytes to be streamed.

Definition at line 179 of file palmOneCameraCommon.h.

UInt8 bitsPerPixel

Number of bits per pixel.

Definition at line 180 of file palmOneCameraCommon.h.

UInt8 reserved0

For packing.

Definition at line 181 of file palmOneCameraCommon.h.

UInt16 reserved1

For packing.

Definition at line 182 of file palmOneCameraCommon.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:11 2008 for Palm API Guide


CamLibCaptureTag Struct Reference

Detailed Description

Capture settings structure. The callback is called with userDataP passed.

Definition at line 200 of file palmOneCameraCommon.h.

Data Fields

  • CamLibCaptureCallbackFunc * callbackP
  • void * userDataP

Field Documentation

CamLibCaptureCallbackFunc* callbackP

Callback function.

Definition at line 202 of file palmOneCameraCommon.h.

void* userDataP

User data pointer.

Definition at line 203 of file palmOneCameraCommon.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:11 2008 for Palm API Guide


CamLibColorSpaceTag Struct Reference

Detailed Description

Color Space structure.

Definition at line 242 of file palmOneCameraCommon.h.

Data Fields

  • Int32 value

Field Documentation

Int32 value

Value.

Definition at line 244 of file palmOneCameraCommon.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:11 2008 for Palm API Guide


CamLibSettingTag Struct Reference

Detailed Description

Settings Capabilities structure. For settings without manual values, only type is used.

Definition at line 231 of file palmOneCameraCommon.h.

Data Fields

  • UInt32 type
  • Int32 value
  • Int32 minValue
  • Int32 maxValue

Field Documentation

UInt32 type

Setting type.

Definition at line 233 of file palmOneCameraCommon.h.

Int32 value

For manual settings only.

Definition at line 234 of file palmOneCameraCommon.h.

Int32 minValue

Used for Get/Query only and is valid for manual value.

Definition at line 235 of file palmOneCameraCommon.h.

Int32 maxValue

Used for Get/Query only and is valid for manual value.

Definition at line 236 of file palmOneCameraCommon.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:11 2008 for Palm API Guide


CamLibStatusTag Struct Reference

Detailed Description

Container for the camera status kCamLibStatus*.

Definition at line 169 of file palmOneCameraCommon.h.

Data Fields

  • UInt32 status

Field Documentation

UInt32 status

Camera status

Definition at line 171 of file palmOneCameraCommon.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:11 2008 for Palm API Guide


CamLibStreamTag Struct Reference

Detailed Description

Video stream structure. Used for capturing a video stream.

When used with WaitfForFram, bufP will contain the full frame buffer.

Definition at line 211 of file palmOneCameraCommon.h.

Data Fields

  • void * lock
  • void * bufP
  • UInt32 size
  • UInt32 frameTime
  • UInt32 frameNum

Field Documentation

void* lock

Reserved.

Definition at line 213 of file palmOneCameraCommon.h.

void* bufP

Pointer to base of frame buffer content.

Definition at line 214 of file palmOneCameraCommon.h.

UInt32 size

Size in bytes of frame buffer.

Definition at line 215 of file palmOneCameraCommon.h.

UInt32 frameTime

Time-stamp when frame was captured.

Definition at line 216 of file palmOneCameraCommon.h.

UInt32 frameNum

Number of frames (relative to start) in stream.

Definition at line 217 of file palmOneCameraCommon.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:11 2008 for Palm API Guide


Coordinate Struct Reference

Detailed Description

Container to store degree and minute of a coordinate

Definition at line 257 of file LocsLibCommon.h.

Data Fields

  • Int16 degree
  • Int16 minute

Field Documentation

Int16 degree

Definition at line 258 of file LocsLibCommon.h.

Int16 minute

Definition at line 259 of file LocsLibCommon.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:11 2008 for Palm API Guide


DevAppLaunchCmdGenericCallType Struct Reference

Detailed Description

For devAppLaunchCmdGenericCall.

Definition at line 62 of file PalmLaunchCodes.h.

Data Fields

  • UInt32 senderCreatorId
  • void * userDataP
  • UInt8 operation
  • UInt8 response

Field Documentation

UInt32 senderCreatorId

IN: the creator ID of the calling code resource

Definition at line 63 of file PalmLaunchCodes.h.

void* userDataP

IN: pointer to custom data (optional)

Definition at line 64 of file PalmLaunchCodes.h.

UInt8 operation

IN: one of the sysAppLaunchGenericCallOp<operation> codes

Definition at line 65 of file PalmLaunchCodes.h.

UInt8 response

IN: set to 0; OUT: one of the sysAppLaunchGenericCallRet<response> codes, or 0 if not handled

Definition at line 66 of file PalmLaunchCodes.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:11 2008 for Palm API Guide


DialPnlDispatchDialParamsType Struct Reference

Detailed Description

Use with the function DispatchDial (UInt16 service, void* paramP)

Definition at line 349 of file HsAppLaunchCmd.h.

Data Fields

  • UInt32 serviceID
  • void * dataP
  • Char * descriptionStr
  • UInt8 handled
  • Err err

Field Documentation

UInt32 serviceID

IN: The service type to dial...

Definition at line 351 of file HsAppLaunchCmd.h.

void* dataP

IN: Basic Data to send to the helper...

Definition at line 352 of file HsAppLaunchCmd.h.

Char* descriptionStr

IN: Description of data to dial...

Definition at line 353 of file HsAppLaunchCmd.h.

UInt8 handled

OUT: Non-zero if handled

Definition at line 354 of file HsAppLaunchCmd.h.

Err err

OUT: Err code returned...

Definition at line 355 of file HsAppLaunchCmd.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:11 2008 for Palm API Guide


DialPnlIsDialingAvailableParamsType Struct Reference

Detailed Description

Support for dialPnlLaunchCmd... commands

Definition at line 334 of file HsAppLaunchCmd.h.

Data Fields

  • Boolean result
  • UInt8 _reserved0
  • const UInt32 * serviceIDsP
  • UInt16 numServices

Field Documentation

Boolean result

OUT: Space for result...

Definition at line 336 of file HsAppLaunchCmd.h.

UInt8 _reserved0

IN: Reserved byte--MUST BE 0.

Definition at line 337 of file HsAppLaunchCmd.h.

const UInt32* serviceIDsP

IN: Array of services to check...

Definition at line 339 of file HsAppLaunchCmd.h.

UInt16 numServices

IN: Num elements in service IDs array.

Definition at line 340 of file HsAppLaunchCmd.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:11 2008 for Palm API Guide


DSTDataTag Struct Reference

Detailed Description

Definition at line 239 of file LocsLibCommon.h.

Data Fields

  • UInt8 hour
  • UInt8 dayOrd
  • UInt8 weekOrd
  • UInt8 month

Field Documentation

UInt8 hour

1 - 24, usually 1 for 1 a.m.

Definition at line 241 of file LocsLibCommon.h.

UInt8 dayOrd

0 = Sun, 1 = Mon, 2 = Tues, 3 = Weds, 4 = Thurs, 5 = Fri, 6 = Sat.

Definition at line 242 of file LocsLibCommon.h.

UInt8 weekOrd

0 = 1st, 1 = 2nd, 2 = 3rd, 3 = 4th, 4 = Last

Definition at line 243 of file LocsLibCommon.h.

UInt8 month

1 - 12 = Jan - Dec No year member, as the DST date should be consistent from year to year in regards to this "1st Sunday in October" format used here. DST boundary alerts are always set for the current year, or to the following year as needed.

Definition at line 244 of file LocsLibCommon.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:11 2008 for Palm API Guide


FrmNavHeaderTag Struct Reference

Detailed Description

Definition at line 260 of file HsNavCommon.h.

Data Fields

  • UInt16 version
  • UInt16 numberOfObjects
  • UInt16 headerSizeInBytes
  • UInt16 listElementSizeInBytes
  • FrmNavHeaderFlagsType navFlags
  • UInt16 initialObjectIDHint
  • UInt16 jumpToObjectIDHint
  • UInt16 bottomLeftObjectIDHint
  • UInt16 padding1

Field Documentation

UInt16 version

Definition at line 262 of file HsNavCommon.h.

UInt16 numberOfObjects

Definition at line 263 of file HsNavCommon.h.

UInt16 headerSizeInBytes

Definition at line 264 of file HsNavCommon.h.

UInt16 listElementSizeInBytes

Definition at line 265 of file HsNavCommon.h.

FrmNavHeaderFlagsType navFlags

Definition at line 266 of file HsNavCommon.h.

UInt16 initialObjectIDHint

Definition at line 267 of file HsNavCommon.h.

UInt16 jumpToObjectIDHint

Definition at line 268 of file HsNavCommon.h.

UInt16 bottomLeftObjectIDHint

Definition at line 269 of file HsNavCommon.h.

UInt16 padding1

Definition at line 270 of file HsNavCommon.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:11 2008 for Palm API Guide


FrmNavOrderEntryTag Struct Reference

Detailed Description

Definition at line 251 of file HsNavCommon.h.

Data Fields

  • UInt16 objectID
  • FrmNavObjectFlagsType objectFlags
  • UInt16 aboveObjectID
  • UInt16 belowObjectID

Field Documentation

UInt16 objectID

Definition at line 253 of file HsNavCommon.h.

FrmNavObjectFlagsType objectFlags

Definition at line 254 of file HsNavCommon.h.

UInt16 aboveObjectID

Definition at line 255 of file HsNavCommon.h.

UInt16 belowObjectID

Definition at line 256 of file HsNavCommon.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:11 2008 for Palm API Guide


HS_HTTPLibAppinfo_ Struct Reference

Detailed Description

Definition at line 39 of file HS_HTTPLibApp.h.

Data Fields

  • UInt32 appCreator
  • Int32 maxSockets
  • Int32 isForeground
  • UInt32 recvBufferSize
  • Char * cookieDBName
  • UInt32 cookieDBCreator
  • UInt32 cookieDBType
  • UInt16 cookieDBVersion
  • Int32 cookieMaxJarSize
  • Char * certDBName
  • UInt32 certDBType
  • UInt16 certDBVersion

Field Documentation

UInt32 appCreator

Definition at line 40 of file HS_HTTPLibApp.h.

Int32 maxSockets

Definition at line 41 of file HS_HTTPLibApp.h.

Int32 isForeground

Definition at line 42 of file HS_HTTPLibApp.h.

UInt32 recvBufferSize

Definition at line 43 of file HS_HTTPLibApp.h.

Char* cookieDBName

Definition at line 45 of file HS_HTTPLibApp.h.

UInt32 cookieDBCreator

Definition at line 46 of file HS_HTTPLibApp.h.

UInt32 cookieDBType

Definition at line 47 of file HS_HTTPLibApp.h.

UInt16 cookieDBVersion

Definition at line 48 of file HS_HTTPLibApp.h.

Int32 cookieMaxJarSize

Definition at line 49 of file HS_HTTPLibApp.h.

Char* certDBName

Definition at line 51 of file HS_HTTPLibApp.h.

UInt32 certDBType

Definition at line 52 of file HS_HTTPLibApp.h.

UInt16 certDBVersion

Definition at line 53 of file HS_HTTPLibApp.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:11 2008 for Palm API Guide


HS_HTTPLibAuthInfo_ Struct Reference

Detailed Description

Definition at line 71 of file HS_HTTPLib68K.h.

Data Fields

  • HS_HTTPLibString fUser
  • HS_HTTPLibString fPass
  • HS_HTTPLibString fRealm
  • HS_HTTPLibString fChallenge
  • HS_HTTPLibString fNextNonce
  • Int32 fNC

Field Documentation

HS_HTTPLibString fUser

Definition at line 72 of file HS_HTTPLib68K.h.

HS_HTTPLibString fPass

Definition at line 73 of file HS_HTTPLib68K.h.

HS_HTTPLibString fRealm

Definition at line 74 of file HS_HTTPLib68K.h.

HS_HTTPLibString fChallenge

Definition at line 75 of file HS_HTTPLib68K.h.

HS_HTTPLibString fNextNonce

Definition at line 76 of file HS_HTTPLib68K.h.

Int32 fNC

Definition at line 77 of file HS_HTTPLib68K.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:11 2008 for Palm API Guide


HS_HTTPLibIPAddr_ Struct Reference

Detailed Description

Definition at line 25 of file HS_HTTPLibApp.h.

Data Fields

  • Int32 type
  • Char addr [16]

Field Documentation

Int32 type

Definition at line 26 of file HS_HTTPLibApp.h.

Char addr[16]

Definition at line 27 of file HS_HTTPLibApp.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:11 2008 for Palm API Guide


HS_HTTPLibNetLibInfo_ Struct Reference

Detailed Description

Definition at line 62 of file HS_HTTPLibApp.h.

Data Fields

  • UInt16 refNum
  • HS_HTTPLibNetLibOpenProc openProc
  • HS_HTTPLibNetLibCloseProc closeProc
  • HS_HTTPLibNetLibOnlineProc onlineProc
  • HS_HTTPLibNetLibOfflineProc offlineProc

Field Documentation

UInt16 refNum

Definition at line 64 of file HS_HTTPLibApp.h.

HS_HTTPLibNetLibOpenProc openProc

Definition at line 65 of file HS_HTTPLibApp.h.

HS_HTTPLibNetLibCloseProc closeProc

Definition at line 66 of file HS_HTTPLibApp.h.

HS_HTTPLibNetLibOnlineProc onlineProc

Definition at line 67 of file HS_HTTPLibApp.h.

HS_HTTPLibNetLibOfflineProc offlineProc

Definition at line 68 of file HS_HTTPLibApp.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:11 2008 for Palm API Guide


HS_HTTPLibOpaque_ Struct Reference

Detailed Description

Definition at line 20 of file HS_HTTPLibApp.h.

Data Fields

  • Int32 fDummy

Field Documentation

Int32 fDummy

Definition at line 21 of file HS_HTTPLibApp.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:11 2008 for Palm API Guide


HS_HTTPLibPeer_ Struct Reference

Detailed Description

Definition at line 82 of file HS_HTTPLibApp.h.

Data Fields

  • Int32(* HS_HTTPLibPeerTCPOpen )(Int32 in_domain, HS_HTTPLibOpaque in_aux)
  • void(* HS_HTTPLibPeerTCPClose )(Int32 in_desc, HS_HTTPLibOpaque in_aux)
  • Int32(* HS_HTTPLibPeerTCPIsConnected )(Int32 in_desc, HS_HTTPLibOpaque in_aux)
  • Int32(* HS_HTTPLibPeerTCPConnect )(Int32 in_desc, HS_HTTPLibIPAddr *in_addr, Int32 in_port, HS_HTTPLibOpaque in_aux)
  • Int32(* HS_HTTPLibPeerTCPRead )(Int32 in_desc, Char *out_buf, Int32 in_len, HS_HTTPLibOpaque in_aux)
  • Int32(* HS_HTTPLibPeerTCPWrite )(Int32 in_desc, Char *in_buf, Int32 in_len, HS_HTTPLibOpaque in_aux)
  • Int32(* HS_HTTPLibPeerTCPCanReadWrite )(Int32 in_desc, Int32 in_rw, HS_HTTPLibOpaque in_aux)

Field Documentation

Int32(* HS_HTTPLibPeerTCPOpen)(Int32 in_domain, HS_HTTPLibOpaque in_aux)

void(* HS_HTTPLibPeerTCPClose)(Int32 in_desc, HS_HTTPLibOpaque in_aux)

Int32(* HS_HTTPLibPeerTCPIsConnected)(Int32 in_desc, HS_HTTPLibOpaque in_aux)

Int32(* HS_HTTPLibPeerTCPConnect)(Int32 in_desc, HS_HTTPLibIPAddr *in_addr, Int32 in_port, HS_HTTPLibOpaque in_aux)

Int32(* HS_HTTPLibPeerTCPRead)(Int32 in_desc, Char *out_buf, Int32 in_len, HS_HTTPLibOpaque in_aux)

Int32(* HS_HTTPLibPeerTCPWrite)(Int32 in_desc, Char *in_buf, Int32 in_len, HS_HTTPLibOpaque in_aux)

Int32(* HS_HTTPLibPeerTCPCanReadWrite)(Int32 in_desc, Int32 in_rw, HS_HTTPLibOpaque in_aux)

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:11 2008 for Palm API Guide


HS_HTTPLibSplit_ Struct Reference

Detailed Description

structure for glueing

Definition at line 50 of file HS_HTTPLib68K.h.

Data Fields

  • Char * s
  • Int32 len

Field Documentation

Char* s

Definition at line 51 of file HS_HTTPLib68K.h.

Int32 len

Definition at line 52 of file HS_HTTPLib68K.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:11 2008 for Palm API Guide


HS_HTTPLibTime_ Struct Reference

Detailed Description

Definition at line 56 of file HS_HTTPLib68K.h.

Data Fields

  • Int32 day
  • Int32 msec

Field Documentation

Int32 day

days (either backward or forward) since 01 January, 1970 UTC

Definition at line 57 of file HS_HTTPLib68K.h.

Int32 msec

milliseconds since midnight [0-86399999]

Definition at line 58 of file HS_HTTPLib68K.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:11 2008 for Palm API Guide


HsBigButtonMappingType Struct Reference

Detailed Description

This is the structure of a single big button mapping...

Definition at line 65 of file HsExtUtilBigButtonCommon.h.

Data Fields

  • UInt8 flags
  • UInt8 font
  • UInt16 gadgetID
  • UInt16 bitmapID
  • UInt16 stringID

Field Documentation

UInt8 flags

Definition at line 67 of file HsExtUtilBigButtonCommon.h.

UInt8 font

Definition at line 68 of file HsExtUtilBigButtonCommon.h.

UInt16 gadgetID

Definition at line 70 of file HsExtUtilBigButtonCommon.h.

UInt16 bitmapID

Definition at line 72 of file HsExtUtilBigButtonCommon.h.

UInt16 stringID

Definition at line 73 of file HsExtUtilBigButtonCommon.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:11 2008 for Palm API Guide


HsBigButtonReourceType Struct Reference

Collaboration diagram for HsBigButtonReourceType:

[legend]

Detailed Description

This is the structure of a big button resource...

Definition at line 80 of file HsExtUtilBigButtonCommon.h.

Data Fields

  • UInt16 version
  • HsBigButtonMappingType mapArr [0]

Field Documentation

UInt16 version

Definition at line 82 of file HsExtUtilBigButtonCommon.h.

HsBigButtonMappingType mapArr[0]

Definition at line 83 of file HsExtUtilBigButtonCommon.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:12 2008 for Palm API Guide


HsDialPrefsUSDialingRulesType Struct Reference

Detailed Description

HsDialPrefsUSDialingRulesType

Definition at line 547 of file HsAppLaunchCmd.h.

Data Fields

  • UInt8 rulesEnabled
  • UInt8 _reserved0
  • UInt8 areaCodeCtl
  • UInt8 add1BeforeAreaCode
  • char autoAreaCode [hsDialPrefsAutoAreaCodeLength]
  • UInt8 prefix6DigitCtl
  • UInt8 prefix5DigitCtl
  • UInt8 prefix4DigitCtl
  • char auto6DigitPrefix [hsDialPrefs6DigitPrefixLength]
  • char auto5DigitPrefix [hsDialPrefs5DigitPrefixLength]
  • char auto4DigitPrefix [hsDialPrefs4DigitPrefixLength]

Field Documentation

UInt8 rulesEnabled

[OUT] if non-zero, then these should be be applied; if zero -- don't apply.

Definition at line 549 of file HsAppLaunchCmd.h.

UInt8 _reserved0

caller must set to 0 (zero) -- for byte alignment, and reserved for future use by the DialPrefs API

Definition at line 551 of file HsAppLaunchCmd.h.

UInt8 areaCodeCtl

[OUT] one of hsDialPrefsAddAreaCodeUnknown, hsDialPrefsAddAreaCodeNo, or hsDialPrefsAddAreaCodeYes; default is hsDialPrefsAddAreaCodeUnknown

Definition at line 554 of file HsAppLaunchCmd.h.

UInt8 add1BeforeAreaCode

[OUT] if non-zero, automatically add "1" in front of the area code of US/Canada numbers; if zero -- don't. Default is to add the "1" in front of US/Canada area codes.

Definition at line 559 of file HsAppLaunchCmd.h.

char autoAreaCode[hsDialPrefsAutoAreaCodeLength]

[OUT] the "auto" area code digits to add to 7-digit numbers if areaCodeCtl is hsDialPrefsAddAreaCodeYes; ignore otherwise;

Definition at line 565 of file HsAppLaunchCmd.h.

UInt8 prefix6DigitCtl

Definition at line 568 of file HsAppLaunchCmd.h.

UInt8 prefix5DigitCtl

Definition at line 572 of file HsAppLaunchCmd.h.

UInt8 prefix4DigitCtl

Definition at line 576 of file HsAppLaunchCmd.h.

char auto6DigitPrefix[hsDialPrefs6DigitPrefixLength]

Definition at line 582 of file HsAppLaunchCmd.h.

char auto5DigitPrefix[hsDialPrefs5DigitPrefixLength]

Definition at line 583 of file HsAppLaunchCmd.h.

char auto4DigitPrefix[hsDialPrefs4DigitPrefixLength]

Definition at line 584 of file HsAppLaunchCmd.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:12 2008 for Palm API Guide


HsSndBufferData Struct Reference

Detailed Description

Holds sound buffer information.

When using the hsSndCmdPlay command in function HsSndFormatPlay, you should pass a pointer to a properly filled HsSndBufferData structure. This structure provides information about the buffer of coded audio data that is going to be processed and played.

Definition at line 550 of file HsSoundLibCommon.h.

Data Fields

  • UInt32 signature
  • UInt32 flags
  • UInt32 amplitude
  • void * buffer
  • UInt32 bufferSize
  • HsSndBufferProc progress_callback
  • void * progress_userdata
  • HsSndBufferProc completion_callback
  • void * completion_userdata
  • UInt32 controls
  • UInt32 reserved1
  • UInt32 reserved2

Field Documentation

UInt32 signature

Always set to hsSndBufferData_Signature or error returned.

Definition at line 552 of file HsSoundLibCommon.h.

UInt32 flags

Flags and status bits for the buffer. Use the hsSndBufferFlags_* symbols appropriately. Set any undefined or unused flags to zero.

Definition at line 553 of file HsSoundLibCommon.h.

UInt32 amplitude

Volume level for playback. (Valid range from 0 to hsSndAmplitude_unity.)

Definition at line 554 of file HsSoundLibCommon.h.

void* buffer

Pointer to beginning of coded audio data to process and/or play.

Definition at line 555 of file HsSoundLibCommon.h.

UInt32 bufferSize

Size in bytes of the buffer of coded audio data.

Definition at line 556 of file HsSoundLibCommon.h.

HsSndBufferProc progress_callback

When Not NULL, is invoked at regular intervals. If progress_callback returns an error, then the play session terminates.

Definition at line 557 of file HsSoundLibCommon.h.

void* progress_userdata

Passed to progress_callback when invoked.

Definition at line 558 of file HsSoundLibCommon.h.

HsSndBufferProc completion_callback

When Not NULL, it will be invoked when buffer processing completed.

Definition at line 559 of file HsSoundLibCommon.h.

void* completion_userdata

Passed to completion_callback when invoked.

Definition at line 560 of file HsSoundLibCommon.h.

UInt32 controls

Compound field with repeat count and end delay controls. Use HsSndBufControl_Set* macros with this field. Repeat Field: valid range from 1 to 254, or hsSndBufControl_repeatForever (255). The processing of the buffer will be looped according to this number. When repeatForever is used, then termination should be done by returning an error code from the progress callback. Alternatively, for non-blocking playback, the caller may issue another "Play" call with the "Stop" command. This field is valid and non-zero when hsSndBufFlags_yesRepeat is set in the buffer flags, otherwise this field must be set to zero. A repeat value of 1 means play one time. Values of 2 and greater will perform the requested number of playbacks by looping on the same buffer data. Use HsSndBufControl_SetRepeat macro to set values in this field. endDelay fld: Valid range from 1 to 255, each unit is a 1/50th second delay. Use HsSndBufControl_SetEndDelay macro to set values in this field. This field is valid and non-zero when hsSndBufFlags_yesEndDelay is set in the buffer flags, otherwise this field must be set to zero.

Definition at line 578 of file HsSoundLibCommon.h.

UInt32 reserved1

reserved, must set to zero

Definition at line 579 of file HsSoundLibCommon.h.

UInt32 reserved2

reserved, must set to zero

Definition at line 580 of file HsSoundLibCommon.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:12 2008 for Palm API Guide


HsSndMidiProgressMsg Struct Reference

Detailed Description

Definition at line 593 of file HsSoundLibCommon.h.

Data Fields

  • UInt32 signature
  • UInt32 msgType
  • UInt32 param1
  • UInt32 param2

Field Documentation

UInt32 signature

Definition at line 595 of file HsSoundLibCommon.h.

UInt32 msgType

Definition at line 596 of file HsSoundLibCommon.h.

UInt32 param1

Definition at line 597 of file HsSoundLibCommon.h.

UInt32 param2

Definition at line 598 of file HsSoundLibCommon.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:12 2008 for Palm API Guide


HsSndPortInfo Struct Reference

Detailed Description

Holds sound port information.

Definition at line 438 of file HsSoundLibCommon.h.

Data Fields

  • UInt32 signature
  • UInt32 flags
  • HsSndPortID portID
  • Int16 minVol
  • Int16 maxVol
  • Int16 unityVol
  • Int16 stepVol
  • Int16 currentVol
  • Int16 currentPan
  • UInt16 stepDB
  • UInt16 boostDB
  • UInt16 reserved1
  • UInt16 reserved2

Field Documentation

UInt32 signature

Always set to hsSndPortInfo_Signature.

Definition at line 440 of file HsSoundLibCommon.h.

UInt32 flags

Control and information about port.

Definition at line 441 of file HsSoundLibCommon.h.

HsSndPortID portID

Identifies the portID.

Definition at line 442 of file HsSoundLibCommon.h.

Int16 minVol

Bottom value of the volume range.

Definition at line 443 of file HsSoundLibCommon.h.

Int16 maxVol

Top value of the volume range.

Definition at line 444 of file HsSoundLibCommon.h.

Int16 unityVol

Volume value when there is no gain or dampening.

Definition at line 445 of file HsSoundLibCommon.h.

Int16 stepVol

Step size for volume changes within vol range.

Definition at line 446 of file HsSoundLibCommon.h.

Int16 currentVol

Tracks current volume setting.

Definition at line 447 of file HsSoundLibCommon.h.

Int16 currentPan

Pan control (0 is midpoint pan between L and R) max pan = maxVol - minVol.

Definition at line 448 of file HsSoundLibCommon.h.

UInt16 stepDB

How many dBs per step = (stepDB >> 8) / (stepDB & 0x0F).

Definition at line 449 of file HsSoundLibCommon.h.

UInt16 boostDB

How many dBs with boost = (boostDB >> 8) / (boostDB & 0x0F).

Definition at line 450 of file HsSoundLibCommon.h.

UInt16 reserved1

Reserved field, set to zero

Definition at line 451 of file HsSoundLibCommon.h.

UInt16 reserved2

Reserved field, set to zero

Definition at line 452 of file HsSoundLibCommon.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:12 2008 for Palm API Guide


HtmlLibFocusTargetInfo Struct Reference

Detailed Description

Definition at line 176 of file HtmlLib68K.h.

Data Fields

  • HtmlFocusTargetType type
  • RectangleType bounds
  • UInt16 formObjectID

Field Documentation

HtmlFocusTargetType type

Definition at line 177 of file HtmlLib68K.h.

RectangleType bounds

Definition at line 178 of file HtmlLib68K.h.

UInt16 formObjectID

Definition at line 179 of file HtmlLib68K.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:12 2008 for Palm API Guide


HtmlLibFormWidgetProc Struct Reference

Detailed Description

The following are necessary form widget creation/deletion routines that need to get set using HtmlLibSetFormWidgetProc. Please see sample code after looking at HtmlLibSetFormWidgetProc.

See also:
HtmlLibSetFormWidgetProc

Definition at line 167 of file HtmlLib68K.h.

Data Fields

  • NewControlProc * newControlProc
  • NewListProc * newListProc
  • NewFieldProc * newFieldProc
  • DeleteObjectProc * deleteObjectProc

Field Documentation

NewControlProc* newControlProc

Definition at line 168 of file HtmlLib68K.h.

NewListProc* newListProc

Definition at line 169 of file HtmlLib68K.h.

NewFieldProc* newFieldProc

Definition at line 170 of file HtmlLib68K.h.

DeleteObjectProc* deleteObjectProc

Definition at line 171 of file HtmlLib68K.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:12 2008 for Palm API Guide


HttpUASelectionRule Struct Reference

Detailed Description

Definition at line 94 of file HS_HTTPLib68K.h.

Data Fields

  • Int32 fType
  • Char * fMatchString
  • Char * fUserAgent

Field Documentation

Int32 fType

Definition at line 95 of file HS_HTTPLib68K.h.

Char* fMatchString

substring to be matched

Definition at line 96 of file HS_HTTPLib68K.h.

Char* fUserAgent

Definition at line 97 of file HS_HTTPLib68K.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:12 2008 for Palm API Guide


LcdOverlayLibSettingTag Struct Reference

Detailed Description

Generic settings For settings without manual values, only type is used.

Definition at line 119 of file PalmLcdOverlay.h.

Data Fields

  • UInt32 type
  • Int32 value
  • Int32 minValue
  • Int32 maxValue

Field Documentation

UInt32 type

For Manual, use constant below

Definition at line 121 of file PalmLcdOverlay.h.

Int32 value

For manual only

Definition at line 122 of file PalmLcdOverlay.h.

Int32 minValue

This value is used for Get/Query Only and is valid for Manual value

Definition at line 123 of file PalmLcdOverlay.h.

Int32 maxValue

This value is used for Get/Query Only and is valid for Manual value

Definition at line 124 of file PalmLcdOverlay.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:12 2008 for Palm API Guide


LocationDataTag Struct Reference

Collaboration diagram for LocationDataTag:

[legend]

Detailed Description

Location data format

Definition at line 270 of file LocsLibCommon.h.

Data Fields

  • Int16 uTC
  • DSTType dSTStart
  • DSTType dSTEnd
  • Int16 dSTAdjustmentInMinutes
  • CountryType country
  • UInt8 custom: 1
  • UInt8 reserved: 7
  • Char * name
  • PosType position
  • Char * note

Field Documentation

Int16 uTC

timezone

Definition at line 272 of file LocsLibCommon.h.

DSTType dSTStart

date/time when DST begins, e.g. 31 Oct 2am

Definition at line 273 of file LocsLibCommon.h.

DSTType dSTEnd

date/time when DST end

Definition at line 274 of file LocsLibCommon.h.

Int16 dSTAdjustmentInMinutes

0 = DST not observed, 60 = observed.

Definition at line 275 of file LocsLibCommon.h.

CountryType country

see Palm OS documentation for values

Definition at line 276 of file LocsLibCommon.h.

UInt8 custom

not used

Definition at line 277 of file LocsLibCommon.h.

UInt8 reserved

not used

Definition at line 277 of file LocsLibCommon.h.

Char* name

for db record type use name[]

Definition at line 279 of file LocsLibCommon.h.

PosType position

Position (Longitude & Latitude) values

Definition at line 280 of file LocsLibCommon.h.

Char* note

Note for each City

Definition at line 281 of file LocsLibCommon.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:12 2008 for Palm API Guide


LocDBInfoTag Struct Reference

Detailed Description

Helpful struct for passing db info as an argument

Definition at line 293 of file LocsLibCommon.h.

Data Fields

  • Char * dbName
  • UInt32 dbCreatorID
  • UInt32 dbType
  • UInt16 dbCardNum

Field Documentation

Char* dbName

name of location database

Definition at line 295 of file LocsLibCommon.h.

UInt32 dbCreatorID

creator of the database

Definition at line 296 of file LocsLibCommon.h.

UInt32 dbType

database type

Definition at line 297 of file LocsLibCommon.h.

UInt16 dbCardNum

cardNo where database resides

Definition at line 298 of file LocsLibCommon.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:12 2008 for Palm API Guide


LocDBRecordTag Struct Reference

Collaboration diagram for LocDBRecordTag:

[legend]

Detailed Description

Location database record format

Definition at line 304 of file LocsLibCommon.h.

Data Fields

  • Int16 uTC
  • DSTType dSTStart
  • DSTType dSTEnd
  • Int16 dSTAdjustmentInMinutes
  • CountryType country
  • UInt8 custom: 1
  • UInt8 reserved: 7
  • Char name [0]

Field Documentation

Int16 uTC

timezone

Definition at line 306 of file LocsLibCommon.h.

DSTType dSTStart

time when DST begins e.g. 2am

Definition at line 307 of file LocsLibCommon.h.

DSTType dSTEnd

time when DST end

Definition at line 308 of file LocsLibCommon.h.

Int16 dSTAdjustmentInMinutes

0 = DST not observed, 60 = observed.

Definition at line 309 of file LocsLibCommon.h.

CountryType country

Country. See Palm OS documentation for values

Definition at line 310 of file LocsLibCommon.h.

UInt8 custom

not used

Definition at line 311 of file LocsLibCommon.h.

UInt8 reserved

not used

Definition at line 311 of file LocsLibCommon.h.

Char name[0]

LocationType uses Char* name

Definition at line 313 of file LocsLibCommon.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:12 2008 for Palm API Guide


LocsLibNotifyDataTag Struct Reference

Collaboration diagram for LocsLibNotifyDataTag:

[legend]

Detailed Description

Helpful struct for passing notification info as an arg

Definition at line 334 of file LocsLibCommon.h.

Data Fields

  • Boolean showWaitDialogue
  • UInt32 notifyType
  • LocsLibNotifyLocsDataType locationData

Field Documentation

Boolean showWaitDialogue

If true, a "Please Wait" dialogue will be displayed while waiting for broadcast completion

Definition at line 336 of file LocsLibCommon.h.

UInt32 notifyType

One of the Locs lib notification type constants.

Definition at line 337 of file LocsLibCommon.h.

LocsLibNotifyLocsDataType locationData

The location data to broadcast.

Definition at line 338 of file LocsLibCommon.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:13 2008 for Palm API Guide


LocsLibNotifyLocsDataTag Struct Reference

Collaboration diagram for LocsLibNotifyLocsDataTag:

[legend]

Detailed Description

Struct used to pass notification location data to interested apps

Definition at line 325 of file LocsLibCommon.h.

Data Fields

  • LocationType locationDataNew
  • const Char * locationNameOldP

Field Documentation

LocationType locationDataNew

new location data

Definition at line 327 of file LocsLibCommon.h.

const Char* locationNameOldP

name of old location

Definition at line 328 of file LocsLibCommon.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:13 2008 for Palm API Guide


LocsLibSelLocsTag Struct Reference

Collaboration diagram for LocsLibSelLocsTag:

[legend]

Detailed Description

Container for the selected location in the location database

Definition at line 350 of file LocsLibCommon.h.

Data Fields

  • LocationType * locationP
  • UInt32 dirtySelections
  • Boolean needSelLoc
  • Boolean warnIfLocExists
  • Boolean noEditOnSelect
  • Boolean preSelect
  • Boolean sendChangeNotify
  • Boolean noAddToCustomDB
  • UInt8 numSelLocs
  • UInt8 reserved
  • Char ** selLocsListP

Field Documentation

LocationType* locationP

Location data of the location selected from the Add Sel list. Caller must allocate the memory.

Definition at line 352 of file LocsLibCommon.h.

UInt32 dirtySelections

indicates which selections were modified e.g.: the 1st selection, element 0, would be indicated by dirtySelections & kLocsLibSel01

Definition at line 353 of file LocsLibCommon.h.

Boolean needSelLoc

true if the caller wants a location name being chosen from the Add Sel list to be saved in the selLocsList.

Definition at line 356 of file LocsLibCommon.h.

Boolean warnIfLocExists

false if the caller doesn't want the user warned if selecting a location that already exists in the custom db.

Definition at line 357 of file LocsLibCommon.h.

Boolean noEditOnSelect

true if the caller wants the "Edit Location" dialogue to NOT be displayed after user selects a location; only applies to LocsLibLaunchSelDialogue().

Definition at line 358 of file LocsLibCommon.h.

Boolean preSelect

true if the caller wants the current location to be preselected in the Add Sel list; only applies to ADD/SEL location dialogue (shows master default list of locations).

Definition at line 359 of file LocsLibCommon.h.

Boolean sendChangeNotify

true if the caller wants the selected location data to be broadcast to all registered apps; only applies to LocsLibLaunchSelDialogue().

Definition at line 360 of file LocsLibCommon.h.

Boolean noAddToCustomDB

true if the caller doesn't want the selected location to be added to the custom db.

Definition at line 361 of file LocsLibCommon.h.

UInt8 numSelLocs

Number of items in the selLocsList

Definition at line 362 of file LocsLibCommon.h.

UInt8 reserved

Reserved, not used

Definition at line 363 of file LocsLibCommon.h.

Char** selLocsListP

List of locations names that are "selected" and the caller needs to know if they are changed.

Definition at line 364 of file LocsLibCommon.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:13 2008 for Palm API Guide


MailAddRecordAttachment Struct Reference

Detailed Description

Structure to add attachment in MailAddRecordParamsTypePlus.

Definition at line 117 of file PalmVMLaunch.h.

Data Fields

  • char * attachType
  • char * attachDescription
  • char * attachFileName
  • union {
    • char * attachData
    • LocalID attachDBID
  • } data
  • UInt32 attachSize

Field Documentation

char* attachType

Mime Type of attachment

Definition at line 119 of file PalmVMLaunch.h.

char* attachDescription

Attachment description

Definition at line 120 of file PalmVMLaunch.h.

char* attachFileName

FileName of attachment

Definition at line 121 of file PalmVMLaunch.h.

char* attachData

Pointer to attachment data

Definition at line 124 of file PalmVMLaunch.h.

LocalID attachDBID

Currently not supported

Definition at line 125 of file PalmVMLaunch.h.

union { ... } data

UInt32 attachSize

Size of attachment

Definition at line 128 of file PalmVMLaunch.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:13 2008 for Palm API Guide


MailAddRecordParamsTypePlus Struct Reference

Collaboration diagram for MailAddRecordParamsTypePlus:

[legend]

Detailed Description

Structure to add a message + attachment passed with MMPRO_ADD_MESSAGE_WITH_ATTACHMENT Categories & MailAddRecordParamsType are defined in AppLaunchCmd.h.

Definition at line 137 of file PalmVMLaunch.h.

Data Fields

  • MailAddRecordParamsType mainParams
  • UInt8 category
  • MailAddRecordAttachment attachments [MM_MAX_ATTACHMENTS]
  • Int16 numAttachments

Field Documentation

MailAddRecordParamsType mainParams

Email data

Definition at line 139 of file PalmVMLaunch.h.

UInt8 category

Mail Category usually Oubox / Draft

Definition at line 140 of file PalmVMLaunch.h.

MailAddRecordAttachment attachments[MM_MAX_ATTACHMENTS]

Pointer to array of attachments

Definition at line 141 of file PalmVMLaunch.h.

Int16 numAttachments

No. of attachments

Definition at line 142 of file PalmVMLaunch.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:13 2008 for Palm API Guide


MMProAttachDataLinks Struct Reference

Detailed Description

Data links used in an attachment, used in MMProAttachStruct2.

Definition at line 79 of file PalmVMLaunch.h.

Data Fields

  • CharPtr data
  • ULong size

Field Documentation

CharPtr data

Pointer to the data link

Definition at line 81 of file PalmVMLaunch.h.

ULong size

Size of data link

Definition at line 82 of file PalmVMLaunch.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:13 2008 for Palm API Guide


MMProAttachStruct Struct Reference

Detailed Description

Structure for adding attachments in MMProLaunchStruct.

Definition at line 53 of file PalmVMLaunch.h.

Data Fields

  • int type
  • char * attachName
  • char * attachment
  • unsigned long aSize

Field Documentation

int type

Type of attachment

Definition at line 55 of file PalmVMLaunch.h.

char* attachName

Name of attachment

Definition at line 56 of file PalmVMLaunch.h.

char* attachment

Pointer to attachment data

Definition at line 57 of file PalmVMLaunch.h.

unsigned long aSize

Size of attachment

Definition at line 58 of file PalmVMLaunch.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:13 2008 for Palm API Guide


MMProAttachStruct2 Struct Reference

Collaboration diagram for MMProAttachStruct2:

[legend]

Detailed Description

Structure for adding attachments in MMProLaunchStruct2.

Definition at line 88 of file PalmVMLaunch.h.

Data Fields

  • int type
  • char * attachName
  • char * attachment
  • unsigned long aSize
  • UInt numDataLinks
  • MMProAttachDataLinks * moreData

Field Documentation

int type

Type of attachment

Definition at line 90 of file PalmVMLaunch.h.

char* attachName

Name of attachment

Definition at line 91 of file PalmVMLaunch.h.

char* attachment

Pointer to attachment data

Definition at line 92 of file PalmVMLaunch.h.

unsigned long aSize

Size of attachment

Definition at line 93 of file PalmVMLaunch.h.

UInt numDataLinks

No. of datalinks

Definition at line 94 of file PalmVMLaunch.h.

MMProAttachDataLinks* moreData

Array of data link(s)

Definition at line 95 of file PalmVMLaunch.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:14 2008 for Palm API Guide


MMProLaunchStruct Struct Reference

Collaboration diagram for MMProLaunchStruct:

[legend]

Detailed Description

Structure to add a message + attachment passed with MMPRO_LAUNCH_CODE.

Definition at line 64 of file PalmVMLaunch.h.

Data Fields

  • Boolean interactive
  • char * to
  • char * cc
  • char * bcc
  • char * subject
  • char * body
  • int numAttach
  • MMProAttachStruct * attachments

Field Documentation

Boolean interactive

Not used

Definition at line 66 of file PalmVMLaunch.h.

char* to

To field

Definition at line 67 of file PalmVMLaunch.h.

char* cc

cc field

Definition at line 68 of file PalmVMLaunch.h.

char* bcc

bcc field

Definition at line 69 of file PalmVMLaunch.h.

char* subject

subject field

Definition at line 70 of file PalmVMLaunch.h.

char* body

body field

Definition at line 71 of file PalmVMLaunch.h.

int numAttach

Number of attachments

Definition at line 72 of file PalmVMLaunch.h.

MMProAttachStruct* attachments

Array of attachment(s)

Definition at line 73 of file PalmVMLaunch.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:14 2008 for Palm API Guide


MMProLaunchStruct2 Struct Reference

Collaboration diagram for MMProLaunchStruct2:

[legend]

Detailed Description

Structure to add a message + attachment passed with MMPRO_LAUNCH_CODE.

Definition at line 101 of file PalmVMLaunch.h.

Data Fields

  • Boolean interactive
  • char * to
  • char * cc
  • char * bcc
  • char * subject
  • char * body
  • int numAttach
  • MMProAttachStruct2 * attachments

Field Documentation

Boolean interactive

Definition at line 103 of file PalmVMLaunch.h.

char* to

To field

Definition at line 104 of file PalmVMLaunch.h.

char* cc

cc field

Definition at line 105 of file PalmVMLaunch.h.

char* bcc

bcc field

Definition at line 106 of file PalmVMLaunch.h.

char* subject

subject field

Definition at line 107 of file PalmVMLaunch.h.

char* body

body field

Definition at line 108 of file PalmVMLaunch.h.

int numAttach

Number of attachments

Definition at line 109 of file PalmVMLaunch.h.

MMProAttachStruct2* attachments

Pointer to attachment array

Definition at line 110 of file PalmVMLaunch.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:14 2008 for Palm API Guide


NBSNotificationEventType Struct Reference

Detailed Description

Structure passed to the callbacks registered for incoming NBS notifications

Definition at line 322 of file HsPhoneSMSTypes.h.

Data Fields

  • UInt16 version
  • Boolean NBSdatagram
  • Boolean binary
  • void * headerP
  • UInt8 headerLen
  • Int8 reserved0
  • void * dataP
  • UInt8 dataLen
  • UInt8 refNum
  • UInt8 maxNum
  • UInt8 seqNum
  • Int8 reserved1
  • Int8 reserved1a
  • UInt32 srcPort
  • UInt32 dstPort
  • UInt32 msgID
  • char * senderP
  • UInt32 datetime
  • Int32 reserved2
  • Int32 reserved3

Field Documentation

UInt16 version

version number to provide future backwards compatibility

Definition at line 324 of file HsPhoneSMSTypes.h.

Boolean NBSdatagram

helper fields flag if it is an NBS datagram

Definition at line 327 of file HsPhoneSMSTypes.h.

Boolean binary

true if binary data

Definition at line 328 of file HsPhoneSMSTypes.h.

void* headerP

pointer to raw header

Definition at line 330 of file HsPhoneSMSTypes.h.

UInt8 headerLen

length of headerP

Definition at line 331 of file HsPhoneSMSTypes.h.

Int8 reserved0

padding

Definition at line 332 of file HsPhoneSMSTypes.h.

void* dataP

pointer to data body

Definition at line 333 of file HsPhoneSMSTypes.h.

UInt8 dataLen

length of dataP

Definition at line 334 of file HsPhoneSMSTypes.h.

UInt8 refNum

NBS datagram fields NBS reference number

Definition at line 337 of file HsPhoneSMSTypes.h.

UInt8 maxNum

max segment number 1-255

Definition at line 338 of file HsPhoneSMSTypes.h.

UInt8 seqNum

sequence number 1-255, no more than maxNum

Definition at line 339 of file HsPhoneSMSTypes.h.

Int8 reserved1

padding

Definition at line 340 of file HsPhoneSMSTypes.h.

Int8 reserved1a

mo padding

Definition at line 341 of file HsPhoneSMSTypes.h.

UInt32 srcPort

source port

Definition at line 343 of file HsPhoneSMSTypes.h.

UInt32 dstPort

destination port

Definition at line 344 of file HsPhoneSMSTypes.h.

UInt32 msgID

SMS related fields ID into the SMS database to reference this message this ID is not gauranteed to be valid once the notification callback returns. Users should make a copy of the msg if they want to work on it after the callback returns.

Definition at line 347 of file HsPhoneSMSTypes.h.

char* senderP

sender number - null terminated

Definition at line 355 of file HsPhoneSMSTypes.h.

UInt32 datetime

date/time stamp

Definition at line 356 of file HsPhoneSMSTypes.h.

Int32 reserved2

reserved

Definition at line 357 of file HsPhoneSMSTypes.h.

Int32 reserved3

reserved

Definition at line 358 of file HsPhoneSMSTypes.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:14 2008 for Palm API Guide


Net80211DeviceInfo Struct Reference

Detailed Description

Device information concerning Hardware and Firmware information for the "adapter".

Revision information and product name data is returned.

Definition at line 85 of file PalmNetServices.h.

Data Fields

  • UInt32 validFlags
  • UInt32 fwRev [2]
  • Int32 serialNumberSize
  • UInt8 serialNumber [kNetSerialNumberLength]
  • Char driverDate [kNetDriverDateLength]
  • Char fwName [kNetFWNameLength]

Field Documentation

UInt32 validFlags

Bit flag indicating validity of fields.

Definition at line 87 of file PalmNetServices.h.

UInt32 fwRev[2]

Firmware revision. STA/BB (32 bits), PRI/MAC (32 bits). Valid is (validFlags & 1) == 1.

Definition at line 88 of file PalmNetServices.h.

Int32 serialNumberSize

Serial number size. Valid is (validFlags & 8) == 1.

Definition at line 89 of file PalmNetServices.h.

UInt8 serialNumber[kNetSerialNumberLength]

Serial number. Valid is (validFlags & 8) == 1.

Definition at line 90 of file PalmNetServices.h.

Char driverDate[kNetDriverDateLength]

Driver date. Valid is (validFlags & 2) == 1.

Definition at line 91 of file PalmNetServices.h.

Char fwName[kNetFWNameLength]

Firmware name. Valid is (validFlags & 4) == 1.

Definition at line 92 of file PalmNetServices.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:14 2008 for Palm API Guide


NetBssInfoType Struct Reference

Detailed Description

Structure to hold BSS Info data.

Accessing the BSS scan info returned via the network interface via the following structure needs to be verified for each specific toolchain and compiler. It has been verified with the combination of ADS V1.2 and CW 8.3. The data format has been done to be as toolchain/architecture/alignment independent as possible, however, if a different combination other than the one listed is used, the format must be verified. The macro's defined above can also be used to access the individual entities of the returned BSS scan data.

Definition at line 377 of file PalmWiFiCommon.h.

Data Fields

  • UInt32 validFlag
  • UInt8 bssMacAddr [BSSINFO_MAC_ADDR_SIZE]
  • UInt32 bssSsidLength
  • UInt8 bssSsid [BSSINFO_SSID_SIZE]
  • UInt32 bssWepEnabled
  • Int32 bssRssi
  • UInt32 bssNetworkType
  • UInt32 bssBeaconPeriod
  • UInt32 bssAtimWindow
  • UInt32 bssDSFreq
  • UInt32 bssHopPattern
  • UInt32 bssHopSet
  • UInt32 bssHopDwell
  • UInt32 bssNetworkMode
  • UInt8 bssSupportedRates [BSSINFO_SUPPORTED_RATES_SIZE]
  • UInt32 bssChannelId
  • Int32 bssANL

Field Documentation

UInt32 validFlag

Definition at line 379 of file PalmWiFiCommon.h.

UInt8 bssMacAddr[BSSINFO_MAC_ADDR_SIZE]

Definition at line 380 of file PalmWiFiCommon.h.

UInt32 bssSsidLength

Definition at line 381 of file PalmWiFiCommon.h.

UInt8 bssSsid[BSSINFO_SSID_SIZE]

Definition at line 382 of file PalmWiFiCommon.h.

UInt32 bssWepEnabled

Definition at line 383 of file PalmWiFiCommon.h.

Int32 bssRssi

Definition at line 384 of file PalmWiFiCommon.h.

UInt32 bssNetworkType

Definition at line 385 of file PalmWiFiCommon.h.

UInt32 bssBeaconPeriod

Definition at line 386 of file PalmWiFiCommon.h.

UInt32 bssAtimWindow

Definition at line 387 of file PalmWiFiCommon.h.

UInt32 bssDSFreq

Definition at line 388 of file PalmWiFiCommon.h.

UInt32 bssHopPattern

Definition at line 389 of file PalmWiFiCommon.h.

UInt32 bssHopSet

Definition at line 390 of file PalmWiFiCommon.h.

UInt32 bssHopDwell

Definition at line 391 of file PalmWiFiCommon.h.

UInt32 bssNetworkMode

Definition at line 392 of file PalmWiFiCommon.h.

UInt8 bssSupportedRates[BSSINFO_SUPPORTED_RATES_SIZE]

Definition at line 393 of file PalmWiFiCommon.h.

UInt32 bssChannelId

Definition at line 394 of file PalmWiFiCommon.h.

Int32 bssANL

Definition at line 395 of file PalmWiFiCommon.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:14 2008 for Palm API Guide


NetMasterClientEventInfoType Struct Reference

Collaboration diagram for NetMasterClientEventInfoType:

[legend]

Detailed Description

This structure is passed as the 'detailsP' of the notification.

See also:
Palm OS Notification Manager

Definition at line 199 of file NetMasterLibTypes.h.

Data Fields

  • UInt16 version
  • NetMasterClientEventEnum eventID
  • union {
    • void * genericEventDataP
    • NetMasterClientEventVPNConnInstallType * vpnConnInstallP
  • } eventData
  • UInt32 inReserved1
  • UInt32 inReserved2
  • UInt32 inReserved3
  • UInt32 inReserved4

Field Documentation

UInt16 version

Version of this structure -- all future versions MUST define backward compatible Event structures. NetMaster Library sets this to netMasterClientCurrentEventVersion at the time the library was built.

Definition at line 209 of file NetMasterLibTypes.h.

NetMasterClientEventEnum eventID

Event ID

Definition at line 212 of file NetMasterLibTypes.h.

void* genericEventDataP

genericEventDataP is for the convenience of the internal code only.

Definition at line 219 of file NetMasterLibTypes.h.

NetMasterClientEventVPNConnInstallType* vpnConnInstallP

For netMasterClientEventVPNConnInstall

Definition at line 222 of file NetMasterLibTypes.h.

union { ... } eventData

Data corresponding to the event ID

UInt32 inReserved1

Reserved values; Set to 0 by NetMaster library

Definition at line 227 of file NetMasterLibTypes.h.

UInt32 inReserved2

Reserved values; Set to 0 by NetMaster library

Definition at line 228 of file NetMasterLibTypes.h.

UInt32 inReserved3

Reserved values; Set to 0 by NetMaster library

Definition at line 229 of file NetMasterLibTypes.h.

UInt32 inReserved4

Reserved values; Set to 0 by NetMaster library

Definition at line 230 of file NetMasterLibTypes.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:14 2008 for Palm API Guide


NetMasterClientEventVPNConnInstallType Struct Reference

Detailed Description

Data block for netMasterClientEventVPNConnInstall.

Definition at line 149 of file NetMasterLibTypes.h.

Data Fields

  • Char defaultConnProfileName [cncProfileNameSize]
  • UInt32 inReserved1
  • UInt32 inReserved2
  • Char vpnConnProfileOverrideName [cncProfileNameSize]

Field Documentation

Char defaultConnProfileName[cncProfileNameSize]

Name of the connection that NetLib will use unless the VPN client overrides it by setting vpnConnProfileOverrideName to a non-empty connection name string. Watch out for the case where the user inadvertently selected the VPN connection name itself as the connection name for the network profile. VPN vendors that choose to override this connection name, will likely wish to save this connection name so that their destination connection.

Definition at line 163 of file NetMasterLibTypes.h.

UInt32 inReserved1

set to zero by this lib

Definition at line 165 of file NetMasterLibTypes.h.

UInt32 inReserved2

set to zero by this lib

Definition at line 166 of file NetMasterLibTypes.h.

Char vpnConnProfileOverrideName[cncProfileNameSize]

The VPN vendor may override the default connection name that NetLib will use by setting this field to a non-empty string -- this string MUST be a valid connection name that presently exists in the connection panel!

If the VPN vendor presently does *not* wish to override the default connection (based on user settings in the VPN vendor's configuration UI), the VPN vendor should leave this field alone (don't modify it in any way in this case to avoid conflicts with other VPN vendor that may be currently installed on the same device).

Definition at line 185 of file NetMasterLibTypes.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:14 2008 for Palm API Guide


NetPrefFallbackInfoType Struct Reference

Detailed Description

Fallback info structure.

Definition at line 440 of file NetPrefLibTypes.h.

Data Fields

  • NetPrefFallbackAlgrorithmEnum algorithm
  • NetPrefFallbackStatusFlagsType fbStatusFlags
  • union {
    • struct NetPrefMutexStickyFBAStatusTypeTag {
      • NetPrefMutexStickyFBAStatusEnum statusID
    • } mutexSticky
  • } status

Field Documentation

NetPrefFallbackAlgrorithmEnum algorithm

Fallback algorithm ID.

IMPORTANT: when changing fallback algorithm, the caller MUST zero-initialize the rest of the NetPrefFallbackInfoType structure.

Definition at line 448 of file NetPrefLibTypes.h.

NetPrefFallbackStatusFlagsType fbStatusFlags

Fallback algoritm status. There is a field here for every fallback algorithm that requires status to be maintained.

THIS STATUS STRUCTURE IS FOR USE BY THE HANDSPRING NetMaster LIBRARY ONLY!!!

Definition at line 456 of file NetPrefLibTypes.h.

NetPrefMutexStickyFBAStatusEnum statusID

Definition at line 463 of file NetPrefLibTypes.h.

struct { ... } ::NetPrefMutexStickyFBAStatusTypeTag mutexSticky

Status for netPrefFallbackAlgrorithmMutexSticky fallback algorithm

union { ... } status

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:15 2008 for Palm API Guide


NetPrefGPRSQOSType Struct Reference

Detailed Description

NetPrefGPRSQOSType -- GPRS Quality Of Service (QOS) info.

Definition at line 335 of file NetPrefLibTypes.h.

Data Fields

  • Int8 qosReqPrecedenceClass
  • Int8 qosReqDelayClass
  • Int8 qosReqReliabilityClass
  • Int8 qosReqPeakThruClass
  • Int8 qosReqMeanThruClass
  • Int8 qosMinPrecedenceClass
  • Int8 qosMinDelayClass
  • Int8 qosMinReliabilityClass
  • Int8 qosMinPeakThruClass
  • Int8 qosMinMeanThruClass
  • Int8 pdpDataCompression
  • Int8 pdpHeaderCompression
  • UInt32 reserved [4]

Field Documentation

Int8 qosReqPrecedenceClass

see ccsmCS_QOSReqPrecClassField

Definition at line 346 of file NetPrefLibTypes.h.

Int8 qosReqDelayClass

see ccsmCS_QOSReqDelayClassField

Definition at line 347 of file NetPrefLibTypes.h.

Int8 qosReqReliabilityClass

see ccsmCS_QOSReqRelClassField

Definition at line 348 of file NetPrefLibTypes.h.

Int8 qosReqPeakThruClass

see ccsmCS_QOSReqPeakThruClassField

Definition at line 349 of file NetPrefLibTypes.h.

Int8 qosReqMeanThruClass

see ccsmCS_QOSReqMeanThruClassField

Definition at line 350 of file NetPrefLibTypes.h.

Int8 qosMinPrecedenceClass

see ccsmCS_QOSMinPrecClassField

Definition at line 351 of file NetPrefLibTypes.h.

Int8 qosMinDelayClass

see ccsmCS_QOSMinDelayClassField

Definition at line 352 of file NetPrefLibTypes.h.

Int8 qosMinReliabilityClass

see ccsmCS_QOSMinRelClassField

Definition at line 353 of file NetPrefLibTypes.h.

Int8 qosMinPeakThruClass

see ccsmCS_QOSMinPeakThruClassField

Definition at line 354 of file NetPrefLibTypes.h.

Int8 qosMinMeanThruClass

see ccsmCS_QOSMinMeanThruClassField

Definition at line 355 of file NetPrefLibTypes.h.

Int8 pdpDataCompression

see ccsmCS_PDPDataComprField

Definition at line 356 of file NetPrefLibTypes.h.

Int8 pdpHeaderCompression

see ccsmCS_PDPHeaderComprField

Definition at line 357 of file NetPrefLibTypes.h.

UInt32 reserved[4]

Reserved by Handspring -- init to zero

Definition at line 359 of file NetPrefLibTypes.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:15 2008 for Palm API Guide


NetServicesProfile Struct Reference

Detailed Description

Profile entries for SmartConnect.

Definition at line 109 of file PalmNetServices.h.

Data Fields

  • Char profileName [32]
  • UInt8 SSID [32]
  • UInt32 ssidLength
  • UInt16 ipAllocType
  • UInt16 preambleType
  • UInt16 keyIndex
  • UInt16 authentication
  • UInt32 opMode
  • UInt32 channel
  • UInt32 reqIP
  • UInt32 ipMask
  • UInt32 ipGateway
  • UInt32 ipPrimaryDNS
  • UInt32 ipSecondaryDNS
  • UInt8 wep [4][16]
  • UInt8 dhcpRequestDNS

Field Documentation

Char profileName[32]

ASCII string - profile reference.

Definition at line 111 of file PalmNetServices.h.

UInt8 SSID[32]

SSID associated with this profile.

Definition at line 112 of file PalmNetServices.h.

UInt32 ssidLength

Length of bytes of the SSID.

Definition at line 113 of file PalmNetServices.h.

UInt16 ipAllocType

DHCP/STATIC/IPIPA.

Definition at line 114 of file PalmNetServices.h.

UInt16 preambleType

Long or short preamble.

Definition at line 115 of file PalmNetServices.h.

UInt16 keyIndex

WEP key index. Only valid if wep active.

Definition at line 116 of file PalmNetServices.h.

UInt16 authentication

OPEN / 64 bit / 128 bit.

Definition at line 117 of file PalmNetServices.h.

UInt32 opMode

BSS, IBSS.

Definition at line 118 of file PalmNetServices.h.

UInt32 channel

DS Channel. Only used for ad-hoc.

Definition at line 119 of file PalmNetServices.h.

UInt32 reqIP

Static IP address.

Definition at line 120 of file PalmNetServices.h.

UInt32 ipMask

IP mask.

Definition at line 121 of file PalmNetServices.h.

UInt32 ipGateway

IP gateway.

Definition at line 122 of file PalmNetServices.h.

UInt32 ipPrimaryDNS

IP primary DNS.

Definition at line 123 of file PalmNetServices.h.

UInt32 ipSecondaryDNS

IP secondary DNS.

Definition at line 124 of file PalmNetServices.h.

UInt8 wep[4][16]

WEP keys. Up to 5 keys.

Definition at line 125 of file PalmNetServices.h.

UInt8 dhcpRequestDNS

0 = DNS info static, 1 = DNS from DHCP.

Definition at line 126 of file PalmNetServices.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:15 2008 for Palm API Guide


NetServicesProfileInfo Struct Reference

Detailed Description

Data returned from NetServicesProfileGetInfo.

Definition at line 99 of file PalmNetServices.h.

Data Fields

  • UInt16 profileRev
  • UInt16 numProfiles
  • UInt16 profileEntrySize

Field Documentation

UInt16 profileRev

Revision of profile database.

Definition at line 101 of file PalmNetServices.h.

UInt16 numProfiles

Number of profiles contained in the database.

Definition at line 102 of file PalmNetServices.h.

UInt16 profileEntrySize

Size of each individual profile entry.

Definition at line 103 of file PalmNetServices.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:15 2008 for Palm API Guide


NetServicesProfileOrder Struct Reference

Detailed Description

Priority order to smart connect.

Provided for ease of reference.

Definition at line 173 of file PalmNetServices.h.

Data Fields

  • UInt16 order [MAX_ACTIVE_PROFILES+1]

Field Documentation

UInt16 order[MAX_ACTIVE_PROFILES+1]

Array of order for each active profiles.

Definition at line 175 of file PalmNetServices.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:15 2008 for Palm API Guide


NetServicesProfileV1 Struct Reference

Detailed Description

Profile entries version 1.

Definition at line 137 of file PalmNetServices.h.

Data Fields

  • Char profileName [32]
  • UInt8 SSID [32]
  • UInt32 ssidLength
  • UInt16 ipAllocType
  • UInt16 preambleType
  • UInt16 keyIndex
  • UInt16 authentication
  • UInt32 opMode
  • UInt32 channel
  • UInt32 reqIP
  • UInt32 ipMask
  • UInt32 ipGateway
  • UInt32 ipPrimaryDNS
  • UInt32 ipSecondaryDNS
  • UInt8 wep [4][16]
  • UInt8 dhcpRequestDNS

Field Documentation

Char profileName[32]

ASCII string - profile reference.

Definition at line 139 of file PalmNetServices.h.

UInt8 SSID[32]

SSID associated with this profile.

Definition at line 140 of file PalmNetServices.h.

UInt32 ssidLength

Length of bytes of the SSID.

Definition at line 141 of file PalmNetServices.h.

UInt16 ipAllocType

DHCP/STATIC/IPIPA.

Definition at line 142 of file PalmNetServices.h.

UInt16 preambleType

Long or short preamble.

Definition at line 143 of file PalmNetServices.h.

UInt16 keyIndex

WEP key index. Only valid if wep active.

Definition at line 144 of file PalmNetServices.h.

UInt16 authentication

OPEN / 64 bit / 128 bit.

Definition at line 145 of file PalmNetServices.h.

UInt32 opMode

BSS, IBSS.

Definition at line 146 of file PalmNetServices.h.

UInt32 channel

DS Channel. Only used for ad-hoc.

Definition at line 147 of file PalmNetServices.h.

UInt32 reqIP

Static IP address.

Definition at line 148 of file PalmNetServices.h.

UInt32 ipMask

IP mask.

Definition at line 149 of file PalmNetServices.h.

UInt32 ipGateway

IP gateway.

Definition at line 150 of file PalmNetServices.h.

UInt32 ipPrimaryDNS

IP primary DNS.

Definition at line 151 of file PalmNetServices.h.

UInt32 ipSecondaryDNS

IP secondary DNS.

Definition at line 152 of file PalmNetServices.h.

UInt8 wep[4][16]

WEP keys. Up to 5 keys.

Definition at line 153 of file PalmNetServices.h.

UInt8 dhcpRequestDNS

0 = DNS info static, 1 = DNS from DHCP.

Definition at line 154 of file PalmNetServices.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:15 2008 for Palm API Guide


NetSSID Struct Reference

Detailed Description

Structure used to get and set the current SSID for the driver (not the Network interface).

Definition at line 448 of file PalmWiFiCommon.h.

Data Fields

  • UInt32 ssidLength
  • UInt8 ssid [32]

Field Documentation

UInt32 ssidLength

Definition at line 450 of file PalmWiFiCommon.h.

UInt8 ssid[32]

Definition at line 451 of file PalmWiFiCommon.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:15 2008 for Palm API Guide


NetWepKey Struct Reference

Detailed Description

Structure used to set the wep keys.

The API's do not return the wep keys via a query.

Definition at line 459 of file PalmWiFiCommon.h.

Data Fields

  • UInt32 keyIndex
  • UInt32 keyLength
  • UInt8 key [16]

Field Documentation

UInt32 keyIndex

Definition at line 461 of file PalmWiFiCommon.h.

UInt32 keyLength

Definition at line 462 of file PalmWiFiCommon.h.

UInt8 key[16]

Definition at line 463 of file PalmWiFiCommon.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:15 2008 for Palm API Guide


NetworkDeviceQueryData Struct Reference

Collaboration diagram for NetworkDeviceQueryData:

[legend]

Detailed Description

Structure to hold network query data.

Definition at line 401 of file PalmWiFiCommon.h.

Data Fields

  • UInt32 qid
  • void * InfoBuffer
  • UInt32 InfoBufferLength
  • UInt32 InfoSize
  • UInt32 InfoSizeRequired
  • NetworkDeviceQueryData * linkP

Field Documentation

UInt32 qid

Definition at line 403 of file PalmWiFiCommon.h.

void* InfoBuffer

Definition at line 404 of file PalmWiFiCommon.h.

UInt32 InfoBufferLength

Definition at line 405 of file PalmWiFiCommon.h.

UInt32 InfoSize

Definition at line 406 of file PalmWiFiCommon.h.

UInt32 InfoSizeRequired

Definition at line 407 of file PalmWiFiCommon.h.

struct NetworkDeviceQueryData* linkP

Added a link pointer. This is required if the driver needs to provide an intermediate buffer space as a translation process.

Definition at line 413 of file PalmWiFiCommon.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:15 2008 for Palm API Guide


P1clRecordDetails Struct Reference

Detailed Description

Definition at line 95 of file DatebookLibCommon.h.

Data Fields

  • UInt8 Action
  • UInt32 RecordUId
  • UInt16 RecordIndex
  • UInt32 CreatorId

Field Documentation

UInt8 Action

Definition at line 97 of file DatebookLibCommon.h.

UInt32 RecordUId

Definition at line 98 of file DatebookLibCommon.h.

UInt16 RecordIndex

Definition at line 99 of file DatebookLibCommon.h.

UInt32 CreatorId

Definition at line 100 of file DatebookLibCommon.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:15 2008 for Palm API Guide


PalmAudioAACDecParamType Struct Reference

Detailed Description

AAC decoding parameters.

Definition at line 415 of file palmOneCodecFormat.h.

Data Fields

  • UInt32 fileFormat
  • union {
    • void * ascP
    • void * esdsP
  • } u
  • void * frameP
  • UInt32 frameSize
  • UInt32 sampleRate

Field Documentation

UInt32 fileFormat

RAW, ADTS, ADIF, MP4A and LATM

Definition at line 416 of file palmOneCodecFormat.h.

void* ascP

Parameter block for MP4A

Definition at line 419 of file palmOneCodecFormat.h.

void* esdsP

Parameter block for RAW

Definition at line 420 of file palmOneCodecFormat.h.

union { ... } u

void* frameP

First AAC frame

Definition at line 423 of file palmOneCodecFormat.h.

UInt32 frameSize

Frame size

Definition at line 424 of file palmOneCodecFormat.h.

UInt32 sampleRate

Definition at line 425 of file palmOneCodecFormat.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:15 2008 for Palm API Guide


PalmAudioAACParamType Struct Reference

Detailed Description

AAC format parameters.

Definition at line 403 of file palmOneCodecFormat.h.

Data Fields

  • UInt32 bitRate
  • UInt32 sampleRate
  • UInt32 sampleWidth
  • UInt32 profile

Field Documentation

UInt32 bitRate

Bits per second.

Definition at line 404 of file palmOneCodecFormat.h.

UInt32 sampleRate

Sample rate (44100, 32000...).

Definition at line 405 of file palmOneCodecFormat.h.

UInt32 sampleWidth

Sample width (mono/stereo).

Definition at line 406 of file palmOneCodecFormat.h.

UInt32 profile

Profile used if any.

Definition at line 407 of file palmOneCodecFormat.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:15 2008 for Palm API Guide


PalmAudioADPCMParamType Struct Reference

Detailed Description

IMA-ADPCM format parameters.

Definition at line 393 of file palmOneCodecFormat.h.

Data Fields

  • UInt32 sampleRate
  • UInt32 sampleWidth
  • UInt32 blockSize

Field Documentation

UInt32 sampleRate

Sample rate (44100, 32000...).

Definition at line 394 of file palmOneCodecFormat.h.

UInt32 sampleWidth

Sample width (mono/stereo).

Definition at line 395 of file palmOneCodecFormat.h.

UInt32 blockSize

Block Size.

Definition at line 396 of file palmOneCodecFormat.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:15 2008 for Palm API Guide


PalmAudioAMRParamType Struct Reference

Detailed Description

Definition at line 450 of file palmOneCodecFormat.h.

Data Fields

  • UInt32 mode
  • UInt32 dtxMode

Field Documentation

UInt32 mode

Encoding mode (i.e. kBits/second).

Definition at line 451 of file palmOneCodecFormat.h.

UInt32 dtxMode

Discontinuous transmission mode.

Definition at line 452 of file palmOneCodecFormat.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:15 2008 for Palm API Guide


PalmAudioMP2ParamType Struct Reference

Detailed Description

MPEG-1 audio decoding parameters.

Definition at line 478 of file palmOneCodecFormat.h.

Data Fields

  • UInt32 avgBytesPerSec
  • UInt32 bitsPerSample
  • UInt32 channels
  • UInt32 sampleRate

Field Documentation

UInt32 avgBytesPerSec

Definition at line 479 of file palmOneCodecFormat.h.

UInt32 bitsPerSample

Definition at line 480 of file palmOneCodecFormat.h.

UInt32 channels

Definition at line 481 of file palmOneCodecFormat.h.

UInt32 sampleRate

Definition at line 482 of file palmOneCodecFormat.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:15 2008 for Palm API Guide


PalmAudioPCMParamType Struct Reference

Detailed Description

PCM format parameters.

Definition at line 383 of file palmOneCodecFormat.h.

Data Fields

  • UInt32 sampleRate
  • UInt32 sampleType
  • UInt32 sampleWidth

Field Documentation

UInt32 sampleRate

Sample rate (44100, 32000...).

Definition at line 384 of file palmOneCodecFormat.h.

UInt32 sampleType

Sample type (use the one one from Sound Manager).

Definition at line 385 of file palmOneCodecFormat.h.

UInt32 sampleWidth

Sample width (mono/stereo).

Definition at line 386 of file palmOneCodecFormat.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:15 2008 for Palm API Guide


PalmAudioPlaybackNotifyEventTypeTag Struct Reference

Detailed Description

Audio playback notification structure.

Structure that is sent as part of notifyDetailsP when a kPalmAudioPlaybackNotifyEvent is thrown.

Definition at line 105 of file PalmAudioPlayback.h.

Data Fields

  • UInt32 version
  • PalmAudioPlaybackActionCodeType actionCode
  • void * dataP

Field Documentation

UInt32 version

Version.

Definition at line 107 of file PalmAudioPlayback.h.

PalmAudioPlaybackActionCodeType actionCode

Action code.

Definition at line 108 of file PalmAudioPlayback.h.

void* dataP

Data for action code, currently NULL.

Definition at line 109 of file PalmAudioPlayback.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:15 2008 for Palm API Guide


PalmAudioQCELPDecParamType Struct Reference

Detailed Description

Definition at line 469 of file palmOneCodecFormat.h.

Data Fields

  • UInt32 headerSize
  • UInt32 headerP

Field Documentation

UInt32 headerSize

size of RIFF header.

Definition at line 470 of file palmOneCodecFormat.h.

UInt32 headerP

RIFF header.

Definition at line 471 of file palmOneCodecFormat.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:15 2008 for Palm API Guide


PalmAudioQCELPParamType Struct Reference

Detailed Description

Definition at line 459 of file palmOneCodecFormat.h.

Data Fields

  • UInt32 maxRate
  • UInt32 minRate
  • UInt32 reducedRate

Field Documentation

UInt32 maxRate

Maximum rate.

Definition at line 460 of file palmOneCodecFormat.h.

UInt32 minRate

Minimum rate.

Definition at line 461 of file palmOneCodecFormat.h.

UInt32 reducedRate

Reduced rate flag.

Definition at line 462 of file palmOneCodecFormat.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:16 2008 for Palm API Guide


PalmFileFormatParamType Struct Reference

Detailed Description

File format parameters.

Definition at line 489 of file palmOneCodecFormat.h.

Data Fields

  • UInt32 fileLocationType
  • FileRef vfsFileRef
  • FileHand streamFileHandle

Field Documentation

UInt32 fileLocationType

File location type.

Definition at line 490 of file palmOneCodecFormat.h.

FileRef vfsFileRef

File Reference for VFS type.

Definition at line 491 of file palmOneCodecFormat.h.

FileHand streamFileHandle

File Handle for File Stream type.

Definition at line 492 of file palmOneCodecFormat.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:16 2008 for Palm API Guide


PalmImageBMPParamType Struct Reference

Detailed Description

BMP format parameters.

Definition at line 500 of file palmOneCodecFormat.h.

Data Fields

  • UInt32 xPixelsPerMeter
  • UInt32 yPixelsPerMeter
  • UInt32 colorUsed
  • UInt32 colorImportant
  • UInt32 compression

Field Documentation

UInt32 xPixelsPerMeter

Horizontal resolution.

Definition at line 501 of file palmOneCodecFormat.h.

UInt32 yPixelsPerMeter

Vertical resolution.

Definition at line 502 of file palmOneCodecFormat.h.

UInt32 colorUsed

Number of color indices actually used.

Definition at line 503 of file palmOneCodecFormat.h.

UInt32 colorImportant

Number of color indices actually required. 0 = all colors required.

Definition at line 504 of file palmOneCodecFormat.h.

UInt32 compression

Bitmap compression.

Definition at line 505 of file palmOneCodecFormat.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:16 2008 for Palm API Guide


PalmImageGIFFrameParamType Struct Reference

Detailed Description

GIF frame parameters.

Each GIF frame contains more info than a simple palette and image buffer.

Definition at line 526 of file palmOneCodecFormat.h.

Data Fields

  • UInt32 leftPosition
  • UInt32 topPosition
  • UInt32 imageWidth
  • UInt32 imageHeight
  • UInt32 localColorBits
  • UInt32 hasLocalColorTable
  • UInt32 isInterlaced
  • UInt32 hasTransparentColor
  • UInt32 transparentColorIndex
  • UInt32 disposalMethod
  • UInt32 delayTime
  • UInt8 localColorTable [256 *3]
  • UInt32 imageDataSize
  • UInt8 * imageDataP

Field Documentation

UInt32 leftPosition

Left position of the image.

Definition at line 527 of file palmOneCodecFormat.h.

UInt32 topPosition

Top posistion of the image.

Definition at line 528 of file palmOneCodecFormat.h.

UInt32 imageWidth

Image width.

Definition at line 529 of file palmOneCodecFormat.h.

UInt32 imageHeight

Image height.

Definition at line 530 of file palmOneCodecFormat.h.

UInt32 localColorBits

Number of bits for the local color table.

Definition at line 531 of file palmOneCodecFormat.h.

UInt32 hasLocalColorTable

1 if has local color table, 0 otherwise.

Definition at line 532 of file palmOneCodecFormat.h.

UInt32 isInterlaced

1 if interlaced, 0 otherwise.

Definition at line 533 of file palmOneCodecFormat.h.

UInt32 hasTransparentColor

1 if has transparency, 0 otherwise.

Definition at line 534 of file palmOneCodecFormat.h.

UInt32 transparentColorIndex

Transparency color index.

Definition at line 535 of file palmOneCodecFormat.h.

UInt32 disposalMethod

Disposal method. (Refer to GIF standard)

Definition at line 536 of file palmOneCodecFormat.h.

UInt32 delayTime

Delay for the current image.

Definition at line 537 of file palmOneCodecFormat.h.

UInt8 localColorTable[256 *3]

Local color table.

Definition at line 538 of file palmOneCodecFormat.h.

UInt32 imageDataSize

Size of the image buffer.

Definition at line 539 of file palmOneCodecFormat.h.

UInt8* imageDataP

Raw Image.

Definition at line 540 of file palmOneCodecFormat.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:16 2008 for Palm API Guide


PalmImageINDEXParamType Struct Reference

Detailed Description

Index image parameters.

Definition at line 547 of file palmOneCodecFormat.h.

Data Fields

  • UInt32 width
  • UInt32 height
  • UInt32 rowByte
  • UInt32 endianess
  • UInt32 colorBits
  • UInt8 * colorTable
  • UInt8 * imageDataP

Field Documentation

UInt32 width

Width of the image.

Definition at line 548 of file palmOneCodecFormat.h.

UInt32 height

Height of the image.

Definition at line 549 of file palmOneCodecFormat.h.

UInt32 rowByte

Rowbyte of the image.

Definition at line 550 of file palmOneCodecFormat.h.

UInt32 endianess

Big Endian, Little Endian.

Definition at line 551 of file palmOneCodecFormat.h.

UInt32 colorBits

Number of bits for the color table.

Definition at line 552 of file palmOneCodecFormat.h.

UInt8* colorTable

Color table. Should have the size 4*2^(colorBits).

Definition at line 553 of file palmOneCodecFormat.h.

UInt8* imageDataP

Raw Image data.

Definition at line 554 of file palmOneCodecFormat.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:16 2008 for Palm API Guide


PalmImageJPEGEncodeParamType Struct Reference

Detailed Description

JPEG format encoding parameters.

Definition at line 513 of file palmOneCodecFormat.h.

Data Fields

  • UInt32 quality
  • UInt32 restartInterval
  • UInt32 JPEGMode
  • UInt32 subSampling

Field Documentation

UInt32 quality

JPEG quality between 0 and 100.

Definition at line 514 of file palmOneCodecFormat.h.

UInt32 restartInterval

Number of restart intervals.

Definition at line 515 of file palmOneCodecFormat.h.

UInt32 JPEGMode

Baseline/Progressive...

Definition at line 516 of file palmOneCodecFormat.h.

UInt32 subSampling

SubSampling YCbCr (444, 422, 411).

Definition at line 517 of file palmOneCodecFormat.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:16 2008 for Palm API Guide


PalmImageParamType Struct Reference

Detailed Description

RAW image format parameters.

Definition at line 356 of file palmOneCodecFormat.h.

Data Fields

  • UInt32 width
  • UInt32 height
  • UInt32 rowByte
  • UInt32 endianess

Field Documentation

UInt32 width

Width of the image.

Definition at line 357 of file palmOneCodecFormat.h.

UInt32 height

Height of the image.

Definition at line 358 of file palmOneCodecFormat.h.

UInt32 rowByte

Rowbyte of the image.

Definition at line 359 of file palmOneCodecFormat.h.

UInt32 endianess

Big Endian, Little Endian.

Definition at line 360 of file palmOneCodecFormat.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:16 2008 for Palm API Guide


PalmImagePlanarType Struct Reference

Detailed Description

Planar image structure, passed during EncodeDecode.

Definition at line 369 of file palmOneCodecFormat.h.

Data Fields

  • UInt32 width
  • UInt32 height
  • void * planeP [MAX_PLANE_COUNT]
  • UInt32 planeWidth [MAX_PLANE_COUNT]
  • UInt32 planeCount

Field Documentation

UInt32 width

Width of the image.

Definition at line 370 of file palmOneCodecFormat.h.

UInt32 height

Height of the image.

Definition at line 371 of file palmOneCodecFormat.h.

void* planeP[MAX_PLANE_COUNT]

Image planes.

Definition at line 374 of file palmOneCodecFormat.h.

UInt32 planeWidth[MAX_PLANE_COUNT]

Width of each plane.

Definition at line 375 of file palmOneCodecFormat.h.

UInt32 planeCount

Number of planes used.

Definition at line 376 of file palmOneCodecFormat.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:16 2008 for Palm API Guide


PalmVideoAVCCustomGetDecodedFrameType Struct Reference

Collaboration diagram for PalmVideoAVCCustomGetDecodedFrameType:

[legend]

Detailed Description

AVC/H264 Custom Control API structure for getting a decoded frame.

Definition at line 621 of file palmOneCodecFormat.h.

Data Fields

  • PalmImagePlanarType planarData
  • Int32 framesReady
  • UInt16 picWidth
  • UInt16 picWidthCropped
  • UInt16 picHeight
  • UInt16 picHeightCropped
  • UInt16 stride
  • UInt32 compositionTimestamp
  • double compositionTime

Field Documentation

PalmImagePlanarType planarData

Definition at line 622 of file palmOneCodecFormat.h.

Int32 framesReady

Definition at line 623 of file palmOneCodecFormat.h.

UInt16 picWidth

width of lum. plane in pixels

Definition at line 624 of file palmOneCodecFormat.h.

UInt16 picWidthCropped

Width of cropped lum. plane in pixels

Definition at line 625 of file palmOneCodecFormat.h.

UInt16 picHeight

Ht of lum. plane in pixels

Definition at line 626 of file palmOneCodecFormat.h.

UInt16 picHeightCropped

height of cropped lum. plane in pixels

Definition at line 627 of file palmOneCodecFormat.h.

UInt16 stride

offset from start of one line of from to start of next

Definition at line 628 of file palmOneCodecFormat.h.

UInt32 compositionTimestamp

timestamp moment in time decoded data to be played back

Definition at line 629 of file palmOneCodecFormat.h.

double compositionTime

time describing moment in time decoded data to be played back

Definition at line 630 of file palmOneCodecFormat.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:17 2008 for Palm API Guide


PalmVideoAVCCustomGetInfoType Struct Reference

Detailed Description

AVC/H264 Custom Control API structure for GetInfo about frame.

Definition at line 608 of file palmOneCodecFormat.h.

Data Fields

  • UInt16 frameWidth
  • UInt16 frameHeight
  • UInt16 frameWidthCropped
  • UInt16 frameHeightCropped
  • UInt16 horizontalOffset
  • UInt16 verticalOffset
  • UInt32 chromaFormat

Field Documentation

UInt16 frameWidth

width of lum. plane in pixels

Definition at line 609 of file palmOneCodecFormat.h.

UInt16 frameHeight

Ht of lum. plane in pixels

Definition at line 610 of file palmOneCodecFormat.h.

UInt16 frameWidthCropped

Width of cropped lum. plane in pixels

Definition at line 611 of file palmOneCodecFormat.h.

UInt16 frameHeightCropped

height of cropped lum. plane in pixels

Definition at line 612 of file palmOneCodecFormat.h.

UInt16 horizontalOffset

Horizontal offset of cropped lum. plane

Definition at line 613 of file palmOneCodecFormat.h.

UInt16 verticalOffset

Vertical offset of cropped lum. plane

Definition at line 614 of file palmOneCodecFormat.h.

UInt32 chromaFormat

Chroma format, only YUV420 for now

Definition at line 615 of file palmOneCodecFormat.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:17 2008 for Palm API Guide


PalmVideoAVCCustomSetCropModeType Struct Reference

Detailed Description

AVC/H264 Custom Control API structure for getting a decoded frame.

Definition at line 636 of file palmOneCodecFormat.h.

Data Fields

  • Boolean bCroppedMode

Field Documentation

Boolean bCroppedMode

TRUE - output cropped size, FALSE - full size

Definition at line 637 of file palmOneCodecFormat.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:17 2008 for Palm API Guide


PalmVideoAVCDecodeParamType Struct Reference

Detailed Description

AVC/H264 video format decoding parameters.

Definition at line 598 of file palmOneCodecFormat.h.

Data Fields

  • UInt8 * NALUnit
  • UInt32 NALUnitSize
  • UInt32 compositionTimestamp
  • double compositionTime

Field Documentation

UInt8* NALUnit

Definition at line 599 of file palmOneCodecFormat.h.

UInt32 NALUnitSize

Definition at line 600 of file palmOneCodecFormat.h.

UInt32 compositionTimestamp

Definition at line 601 of file palmOneCodecFormat.h.

double compositionTime

Definition at line 602 of file palmOneCodecFormat.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:17 2008 for Palm API Guide


PalmVideoAVCOutputBufferType Struct Reference

Detailed Description

AVC/H264 video format decoding parameters.

Definition at line 643 of file palmOneCodecFormat.h.

Data Fields

  • Int32 framesReady

Field Documentation

Int32 framesReady

No. of avail. decoded frames

Definition at line 644 of file palmOneCodecFormat.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:17 2008 for Palm API Guide


PalmVideoMPEG1DecodeParamType Struct Reference

Detailed Description

MPEG-1 video decoding parameters.

Definition at line 561 of file palmOneCodecFormat.h.

Data Fields

  • UInt32 width
  • UInt32 height
  • UInt32 skipBFrames

Field Documentation

UInt32 width

Width.

Definition at line 562 of file palmOneCodecFormat.h.

UInt32 height

Height.

Definition at line 563 of file palmOneCodecFormat.h.

UInt32 skipBFrames

B Frame are very time consuming. If True skip B-Frames.

Definition at line 564 of file palmOneCodecFormat.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:17 2008 for Palm API Guide


PalmVideoMPEG4DecodeParamType Struct Reference

Detailed Description

MPEG-4 video format decoding parameters.

Definition at line 588 of file palmOneCodecFormat.h.

Data Fields

  • UInt32 profile
  • UInt32 volWidth
  • UInt32 volHeight

Field Documentation

UInt32 profile

Profile used if any.

Definition at line 589 of file palmOneCodecFormat.h.

UInt32 volWidth

Video Object Layer width.

Definition at line 590 of file palmOneCodecFormat.h.

UInt32 volHeight

Video Object Layer width.

Definition at line 591 of file palmOneCodecFormat.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:17 2008 for Palm API Guide


PalmVideoMPEG4EncodeParamType Struct Reference

Detailed Description

MPEG-4 video format encoding parameters.

Definition at line 571 of file palmOneCodecFormat.h.

Data Fields

  • UInt32 profile
  • UInt32 volWidth
  • UInt32 volHeight
  • UInt32 keyFrame
  • UInt32 frameRate
  • UInt32 bitRate
  • UInt32 algorithm
  • UInt32 IVOPQuantization
  • UInt32 VOVOLVersionID
  • UInt32 searchRange

Field Documentation

UInt32 profile

Profile used if any.

Definition at line 572 of file palmOneCodecFormat.h.

UInt32 volWidth

Video Object Layer width.

Definition at line 573 of file palmOneCodecFormat.h.

UInt32 volHeight

Video Object Layer height.

Definition at line 574 of file palmOneCodecFormat.h.

UInt32 keyFrame

Number of P-Frames between two I-Frames.

Definition at line 575 of file palmOneCodecFormat.h.

UInt32 frameRate

Number of frames per second.

Definition at line 576 of file palmOneCodecFormat.h.

UInt32 bitRate

Bit rate target.

Definition at line 577 of file palmOneCodecFormat.h.

UInt32 algorithm

MV_FAST, SEA...

Definition at line 578 of file palmOneCodecFormat.h.

UInt32 IVOPQuantization

Quantization step in I-VOP frames.

Definition at line 579 of file palmOneCodecFormat.h.

UInt32 VOVOLVersionID

Version ID for VO & VOL header.

Definition at line 580 of file palmOneCodecFormat.h.

UInt32 searchRange

Motion search range (in pixels).

Definition at line 581 of file palmOneCodecFormat.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:18 2008 for Palm API Guide


ParsedInfo Struct Reference

Detailed Description

Holds parsed item information.

Given a message, or list of messages, this structure gives the locations of all parsed items.

Definition at line 273 of file SmartTextEngineDef.h.

Data Fields

  • UInt16 parsedType
  • UInt16 startLocation
  • UInt16 itemLength
  • UInt16 msgNumber
  • UInt16 color
  • UInt16 nameLength
  • UInt32 miscData

Field Documentation

UInt16 parsedType

what kind of data did we find?

Definition at line 275 of file SmartTextEngineDef.h.

UInt16 startLocation

the starting location of the parsed data we found

Definition at line 276 of file SmartTextEngineDef.h.

UInt16 itemLength

the character length of the parsed data we found

Definition at line 277 of file SmartTextEngineDef.h.

UInt16 msgNumber

when parsing a list of message, this is the message number, otherwise 0

Definition at line 278 of file SmartTextEngineDef.h.

UInt16 color

used to store the font color (for custom hyperlinks)

Definition at line 279 of file SmartTextEngineDef.h.

UInt16 nameLength

used to store the length of the link name (for custom hyperlinks)

Definition at line 280 of file SmartTextEngineDef.h.

UInt32 miscData

used now to store left indentation and other info. Adapt as needed.

Definition at line 281 of file SmartTextEngineDef.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:18 2008 for Palm API Guide


ParsedInfoList Struct Reference

Collaboration diagram for ParsedInfoList:

[legend]

Detailed Description

Holds the list of parsed item information.

Definition at line 287 of file SmartTextEngineDef.h.

Data Fields

  • UInt16 size
  • UInt16 maxSize
  • ParsedInfo info [1]

Field Documentation

UInt16 size

how many items did we find in the text?

Definition at line 289 of file SmartTextEngineDef.h.

UInt16 maxSize

maximum number of items that can be added without resizing

Definition at line 290 of file SmartTextEngineDef.h.

ParsedInfo info[1]

parsing info follows

Definition at line 291 of file SmartTextEngineDef.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:18 2008 for Palm API Guide


PhnCdmaSystemInfoType Struct Reference

Detailed Description

CDMA System info

Definition at line 149 of file HsPhoneMiscTypes.h.

Data Fields

  • UInt16 sid
  • UInt16 nid
  • UInt8 bandClass
  • UInt16 chNum
  • UInt8 wsCode

Field Documentation

UInt16 sid

Definition at line 151 of file HsPhoneMiscTypes.h.

UInt16 nid

Definition at line 152 of file HsPhoneMiscTypes.h.

UInt8 bandClass

Definition at line 153 of file HsPhoneMiscTypes.h.

UInt16 chNum

Definition at line 154 of file HsPhoneMiscTypes.h.

UInt8 wsCode

Definition at line 155 of file HsPhoneMiscTypes.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:18 2008 for Palm API Guide


PhnConferenceDesc Struct Reference

Detailed Description

Definition at line 659 of file HsPhoneEvent.h.

Data Fields

  • PhnConnectionID call1ID
  • PhnConnectionID call2ID
  • PhnConnectionID conferenceID

Field Documentation

PhnConnectionID call1ID

Definition at line 661 of file HsPhoneEvent.h.

PhnConnectionID call2ID

Definition at line 662 of file HsPhoneEvent.h.

PhnConnectionID conferenceID

Definition at line 663 of file HsPhoneEvent.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:18 2008 for Palm API Guide


PhnConnectionType Struct Reference

Detailed Description

Phone connection info

Definition at line 49 of file HsPhoneCallControlTypes.h.

Data Fields

  • PhnConnectionID id
  • PhnConnectStateType state
  • PhoneServiceClassType service
  • Boolean incoming
  • Boolean multiparty
  • PhnAddressHandle address
  • DWord owner
  • Int16 lineNumber

Field Documentation

PhnConnectionID id

Definition at line 51 of file HsPhoneCallControlTypes.h.

PhnConnectStateType state

Definition at line 52 of file HsPhoneCallControlTypes.h.

PhoneServiceClassType service

Definition at line 53 of file HsPhoneCallControlTypes.h.

Boolean incoming

Definition at line 54 of file HsPhoneCallControlTypes.h.

Boolean multiparty

Definition at line 55 of file HsPhoneCallControlTypes.h.

PhnAddressHandle address

Definition at line 56 of file HsPhoneCallControlTypes.h.

DWord owner

Definition at line 57 of file HsPhoneCallControlTypes.h.

Int16 lineNumber

Definition at line 58 of file HsPhoneCallControlTypes.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:18 2008 for Palm API Guide


PhnDataSessionStateType Struct Reference

Detailed Description

Definition at line 628 of file HsPhoneNetworkTypes.h.

Data Fields

  • UInt32 version
  • PhnDataServiceType availableService
  • PhnDataServiceType sessionType
  • PhnPacketDataSessionType sessionStatus
  • PhnPacketDataEndStatusType disconnectStatus

Field Documentation

UInt32 version

(1.0) should be set to the structure version that you are requesting

Definition at line 630 of file HsPhoneNetworkTypes.h.

PhnDataServiceType availableService

(1.0) data connection type available

Definition at line 631 of file HsPhoneNetworkTypes.h.

PhnDataServiceType sessionType

(1.0) data connection type (valid only if status is Active or Dormant)

Definition at line 632 of file HsPhoneNetworkTypes.h.

PhnPacketDataSessionType sessionStatus

(1.0) data connection status

Definition at line 633 of file HsPhoneNetworkTypes.h.

PhnPacketDataEndStatusType disconnectStatus

(1.0) data connection end status (only useful after a data call has been terminated)

Definition at line 634 of file HsPhoneNetworkTypes.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:19 2008 for Palm API Guide


PhnDisconnectEventType Struct Reference

Detailed Description

Definition at line 638 of file HsPhoneEvent.h.

Data Fields

  • PhoneServiceClassType service
  • Err code

Field Documentation

PhoneServiceClassType service

type of call being disconnected

Definition at line 640 of file HsPhoneEvent.h.

Err code

cause of disconnect (0 for normal hangup)

Definition at line 641 of file HsPhoneEvent.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:19 2008 for Palm API Guide


PhnError Struct Reference

Detailed Description

Definition at line 671 of file HsPhoneEvent.h.

Data Fields

  • Err code
  • UInt32 id
  • UInt16 networkError

Field Documentation

Err code

Definition at line 673 of file HsPhoneEvent.h.

UInt32 id

Definition at line 674 of file HsPhoneEvent.h.

UInt16 networkError

Error code returned by the network. If this field is non-zero it contains that error code returned by the network. The 'code' above will be the Phone Library version of this error.

Definition at line 678 of file HsPhoneEvent.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:19 2008 for Palm API Guide


PhnEventType Struct Reference

Collaboration diagram for PhnEventType:

[legend]

Detailed Description

Phone Event Structure

Definition at line 1441 of file HsPhoneEvent.h.

Data Fields

  • UInt8 eventType
  • Boolean acknowledge
  • UInt16 connectionID
  • UInt16 launchCode
  • Ptr launchParams
  • PhnEventType::Data data

Data Structures

  • union Data

Field Documentation

UInt8 eventType

PhnEventCode

Definition at line 1443 of file HsPhoneEvent.h.

Boolean acknowledge

Definition at line 1444 of file HsPhoneEvent.h.

UInt16 connectionID

Definition at line 1445 of file HsPhoneEvent.h.

UInt16 launchCode

Definition at line 1446 of file HsPhoneEvent.h.

Ptr launchParams

Definition at line 1447 of file HsPhoneEvent.h.

union PhnEventType::Data data

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:20 2008 for Palm API Guide


PhnEventType::Data

PhnEventType::Data Union Reference

Collaboration diagram for PhnEventType::Data:

[legend]

Detailed Description

Definition at line 1448 of file HsPhoneEvent.h.

Data Fields

  • PhnDisconnectEventType disconnect
  • PhnSubscriberAddrInfo info
  • PhnConferenceDesc conference
  • PhnError error
  • PhnSMSParams params
  • PhnKeyPressedParams keyPressed
  • PhnRegistrationType registration
  • PhnMsgBoxDataType msgBox
  • PhnPowerEventType power
  • PhnPasswordEventType password
  • PhnProgressEventType progress
  • PhnIndicationType indication
  • PhnMovedMsgsParamsType moved
  • PhnUSSDEventType ussd
  • PhnSATEventType sat
  • PhnPhoneEquipmentMode phoneEquipmentMode
  • PhnMiscDbgRptType miscDbgRpt
  • PhnPDDataType PDDataInfo
  • PhnOneXStatus oneXStatus
  • PhnMIPFailType mipSessionFailReason
  • PhnIOTAReportType iotaInfo
  • PhnDataChannelType dataChannelAvailability
  • PhnOnexMipRRQType PhnOnxMipRRQ
  • PhnOneXDataFailType oneXFailReason
  • WAPNotificationEventType wapEvtParams
  • PhnDataSessionStateType dataSesstionStatus
  • PhnNetworkTime networkTime

Field Documentation

PhnDisconnectEventType disconnect

Definition at line 1450 of file HsPhoneEvent.h.

PhnSubscriberAddrInfo info

Definition at line 1451 of file HsPhoneEvent.h.

PhnConferenceDesc conference

Definition at line 1452 of file HsPhoneEvent.h.

PhnError error

Definition at line 1453 of file HsPhoneEvent.h.

PhnSMSParams params

Definition at line 1454 of file HsPhoneEvent.h.

PhnKeyPressedParams keyPressed

Definition at line 1455 of file HsPhoneEvent.h.

PhnRegistrationType registration

Definition at line 1456 of file HsPhoneEvent.h.

PhnMsgBoxDataType msgBox

Definition at line 1457 of file HsPhoneEvent.h.

PhnPowerEventType power

Definition at line 1458 of file HsPhoneEvent.h.

PhnPasswordEventType password

Definition at line 1459 of file HsPhoneEvent.h.

PhnProgressEventType progress

Definition at line 1460 of file HsPhoneEvent.h.

PhnIndicationType indication

Definition at line 1461 of file HsPhoneEvent.h.

PhnMovedMsgsParamsType moved

Definition at line 1462 of file HsPhoneEvent.h.

PhnUSSDEventType ussd

Definition at line 1463 of file HsPhoneEvent.h.

PhnSATEventType sat

Definition at line 1464 of file HsPhoneEvent.h.

PhnPhoneEquipmentMode phoneEquipmentMode

Definition at line 1465 of file HsPhoneEvent.h.

PhnMiscDbgRptType miscDbgRpt

Definition at line 1466 of file HsPhoneEvent.h.

PhnPDDataType PDDataInfo

sent asynchronously by the modem

Definition at line 1467 of file HsPhoneEvent.h.

PhnOneXStatus oneXStatus

Definition at line 1468 of file HsPhoneEvent.h.

PhnMIPFailType mipSessionFailReason

Definition at line 1469 of file HsPhoneEvent.h.

PhnIOTAReportType iotaInfo

Definition at line 1470 of file HsPhoneEvent.h.

PhnDataChannelType dataChannelAvailability

phnEvtDataChannel event <currently not="" used>="">

Definition at line 1471 of file HsPhoneEvent.h.

PhnOnexMipRRQType PhnOnxMipRRQ

Definition at line 1472 of file HsPhoneEvent.h.

PhnOneXDataFailType oneXFailReason

Definition at line 1473 of file HsPhoneEvent.h.

WAPNotificationEventType wapEvtParams

Definition at line 1474 of file HsPhoneEvent.h.

PhnDataSessionStateType dataSesstionStatus

Sent when the data session state changes

Definition at line 1475 of file HsPhoneEvent.h.

PhnNetworkTime networkTime

GSM Only, phnEvtNetworkTime

Definition at line 1476 of file HsPhoneEvent.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:21 2008 for Palm API Guide


PhnGPRSPDPContextListNodeType Struct Reference

Collaboration diagram for PhnGPRSPDPContextListNodeType:

[legend]

Detailed Description

This is a list node that is returened when we retreive the current list of PDP contexts stored on the device

Definition at line 233 of file HsPhoneGSMTypes.h.

Data Fields

  • PhnGPRSPDPContextType type
  • PhnGPRSPDPContextListNodeType * nextP

Field Documentation

struct PhnGPRSPDPContextType type

Definition at line 235 of file HsPhoneGSMTypes.h.

struct PhnGPRSPDPContextListNodeType* nextP

Definition at line 236 of file HsPhoneGSMTypes.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:21 2008 for Palm API Guide


PhnGPRSPDPContextType Struct Reference

Detailed Description

Used when we get a list of context that are currently stored on the radio.

Definition at line 218 of file HsPhoneGSMTypes.h.

Data Fields

  • UInt16 contextId
  • PhnGPRSPDPType pdpType
  • char * apn
  • char * pdpAddr
  • UInt16 pdpDataCompression
  • UInt16 pdpHdrCompression

Field Documentation

UInt16 contextId

Definition at line 220 of file HsPhoneGSMTypes.h.

PhnGPRSPDPType pdpType

Definition at line 221 of file HsPhoneGSMTypes.h.

char* apn

Definition at line 222 of file HsPhoneGSMTypes.h.

char* pdpAddr

Definition at line 223 of file HsPhoneGSMTypes.h.

UInt16 pdpDataCompression

0 means OFF, 1 means ON

Definition at line 224 of file HsPhoneGSMTypes.h.

UInt16 pdpHdrCompression

Definition at line 225 of file HsPhoneGSMTypes.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:21 2008 for Palm API Guide


PhnIndicationType Struct Reference

Detailed Description

Definition at line 826 of file HsPhoneEvent.h.

Data Fields

  • PhnIndicationKind kind
  • char filler
  • union {
    • struct {
      • Boolean state
    • } simReady
    • struct {
      • GSMSIMMessagesDialogKind dialog
      • Boolean moveMessages
      • DWord mSIMMessagesAcknowledge
    • } simMessages
    • struct {
      • PhnPasswordType type
    • } passwordAccepted
    • struct {
      • Boolean state
    • } networkAvailable
    • struct {
      • ContinuePowerOnOffCallback continuePowerOnOff
    • } powerOnOffContinueCallback
    • struct {
      • UInt32 indicationCode
    • } otaspMsg
  • } data

Field Documentation

PhnIndicationKind kind

Definition at line 828 of file HsPhoneEvent.h.

char filler

Definition at line 829 of file HsPhoneEvent.h.

Boolean state

Definition at line 834 of file HsPhoneEvent.h.

struct { ... } simReady

GSMSIMMessagesDialogKind dialog

Definition at line 838 of file HsPhoneEvent.h.

Boolean moveMessages

Definition at line 839 of file HsPhoneEvent.h.

DWord mSIMMessagesAcknowledge

creator of move msg dialog for subsequent events

Definition at line 840 of file HsPhoneEvent.h.

struct { ... } simMessages

PhnPasswordType type

Definition at line 844 of file HsPhoneEvent.h.

struct { ... } passwordAccepted

struct { ... } networkAvailable

ContinuePowerOnOffCallback continuePowerOnOff

Definition at line 852 of file HsPhoneEvent.h.

struct { ... } powerOnOffContinueCallback

UInt32 indicationCode

Definition at line 856 of file HsPhoneEvent.h.

struct { ... } otaspMsg

union { ... } data

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:21 2008 for Palm API Guide


PhnIOTAPhnDlsLockType Struct Reference

Detailed Description

Holds lock state of user's ability to change the download server URL address.

Definition at line 286 of file HsPhoneIOTATypes.h.

Data Fields

  • Boolean iota_ph_dls_lock

Field Documentation

Boolean iota_ph_dls_lock

Definition at line 288 of file HsPhoneIOTATypes.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:21 2008 for Palm API Guide


PhnIOTAPhnHomepagetype Struct Reference

Detailed Description

Definition at line 295 of file HsPhoneIOTATypes.h.

Data Fields

  • UInt8 url [kIOTAUrlMaxLen]

Field Documentation

UInt8 url[kIOTAUrlMaxLen]

Definition at line 297 of file HsPhoneIOTATypes.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:21 2008 for Palm API Guide


PhnIOTAPhnNAIIMStore Struct Reference

Detailed Description

Definition at line 223 of file HsPhoneIOTATypes.h.

Data Fields

  • UInt8 index
  • UInt8 url [kIOTAUrlArrayMaxLen]

Field Documentation

UInt8 index

Definition at line 225 of file HsPhoneIOTATypes.h.

UInt8 url[kIOTAUrlArrayMaxLen]

Definition at line 226 of file HsPhoneIOTATypes.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:21 2008 for Palm API Guide


PhnIOTAPhnNAIPPGType Struct Reference

Detailed Description

Definition at line 211 of file HsPhoneIOTATypes.h.

Data Fields

  • UInt8 index
  • UInt8 url [kIOTAUrlArrayMaxLen]

Field Documentation

UInt8 index

Definition at line 213 of file HsPhoneIOTATypes.h.

UInt8 url[kIOTAUrlArrayMaxLen]

Definition at line 214 of file HsPhoneIOTATypes.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:21 2008 for Palm API Guide


PhnIOTAPhnNAISIPCfgSvr Struct Reference

Detailed Description

Definition at line 199 of file HsPhoneIOTATypes.h.

Data Fields

  • UInt8 index
  • UInt8 url [kIOTAUrlArrayMaxLen]

Field Documentation

UInt8 index

Definition at line 201 of file HsPhoneIOTATypes.h.

UInt8 url[kIOTAUrlArrayMaxLen]

Definition at line 202 of file HsPhoneIOTATypes.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:21 2008 for Palm API Guide


PhnIOTAPhnNAISIPDatagwyType Struct Reference

Detailed Description

Definition at line 247 of file HsPhoneIOTATypes.h.

Data Fields

  • UInt8 index
  • UInt8 url [kIOTAUrlArrayMaxLen]

Field Documentation

UInt8 index

Definition at line 249 of file HsPhoneIOTATypes.h.

UInt8 url[kIOTAUrlArrayMaxLen]

Definition at line 250 of file HsPhoneIOTATypes.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:21 2008 for Palm API Guide


PhnIOTAPhnNAISIPDataxchType Struct Reference

Detailed Description

Definition at line 235 of file HsPhoneIOTATypes.h.

Data Fields

  • UInt8 index
  • UInt8 url [kIOTAUrlArrayMaxLen]

Field Documentation

UInt8 index

Definition at line 237 of file HsPhoneIOTATypes.h.

UInt8 url[kIOTAUrlArrayMaxLen]

Definition at line 238 of file HsPhoneIOTATypes.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:22 2008 for Palm API Guide


PhnIOTAPhnNAISIPEdgeProxyType Struct Reference

Detailed Description

Definition at line 172 of file HsPhoneIOTATypes.h.

Data Fields

  • UInt8 index
  • UInt8 addr [kIOTAProxyADDRMaxLen]

Field Documentation

UInt8 index

Definition at line 174 of file HsPhoneIOTATypes.h.

UInt8 addr[kIOTAProxyADDRMaxLen]

Definition at line 175 of file HsPhoneIOTATypes.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:22 2008 for Palm API Guide


PhnIOTAPhnProxyAddrWdpType Struct Reference

Detailed Description

Definition at line 184 of file HsPhoneIOTATypes.h.

Data Fields

  • UInt8 index
  • UInt8 addr [kIOTAProxyADDRMaxLen]

Field Documentation

UInt8 index

Definition at line 186 of file HsPhoneIOTATypes.h.

UInt8 addr[kIOTAProxyADDRMaxLen]

Definition at line 187 of file HsPhoneIOTATypes.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:22 2008 for Palm API Guide


PhnIOTAPhnSIPRetryCntType Struct Reference

Detailed Description

Definition at line 275 of file HsPhoneIOTATypes.h.

Data Fields

  • UInt8 index
  • UInt8 cnt [kIOTAPhnSipRetryCntMaxLen]

Field Documentation

UInt8 index

Definition at line 277 of file HsPhoneIOTATypes.h.

UInt8 cnt[kIOTAPhnSipRetryCntMaxLen]

Definition at line 278 of file HsPhoneIOTATypes.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:22 2008 for Palm API Guide


PhnIOTAPhnSIPRetryTimerType Struct Reference

Detailed Description

Definition at line 261 of file HsPhoneIOTATypes.h.

Data Fields

  • UInt8 index
  • UInt8 timer [kIOTAPhnSipRetryTimerMaxLen]

Field Documentation

UInt8 index

Definition at line 263 of file HsPhoneIOTATypes.h.

UInt8 timer[kIOTAPhnSipRetryTimerMaxLen]

Definition at line 264 of file HsPhoneIOTATypes.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:22 2008 for Palm API Guide


PhnIOTAPhnTlsRcUrlType Struct Reference

Detailed Description

Definition at line 159 of file HsPhoneIOTATypes.h.

Data Fields

  • UInt8 index
  • UInt8 cert [kIOTACertMaxBlockLen]

Field Documentation

UInt8 index

Definition at line 161 of file HsPhoneIOTATypes.h.

UInt8 cert[kIOTACertMaxBlockLen]

Definition at line 162 of file HsPhoneIOTATypes.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:22 2008 for Palm API Guide


PhnIOTAPhnTrustedDomainType Struct Reference

Detailed Description

Definition at line 307 of file HsPhoneIOTATypes.h.

Data Fields

  • UInt8 url [kIOTATrustedDomainMaxLen]

Field Documentation

UInt8 url[kIOTATrustedDomainMaxLen]

Definition at line 309 of file HsPhoneIOTATypes.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:22 2008 for Palm API Guide


PhnIOTAReportType Struct Reference

Detailed Description

Definition at line 59 of file HsPhoneIOTATypes.h.

Data Fields

  • PhnIOTAStatus status
  • UInt8 namInUse
  • PHNErrorCode error

Field Documentation

PhnIOTAStatus status

the status that the modem changes into

Definition at line 61 of file HsPhoneIOTATypes.h.

UInt8 namInUse

namInUse4IOTA currently

Definition at line 62 of file HsPhoneIOTATypes.h.

PHNErrorCode error

== 0 normally, only != 0 for phnIOTAEnd and phnIOTACommit if Commit failed.

Definition at line 63 of file HsPhoneIOTATypes.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:22 2008 for Palm API Guide


PhnKeyPressedParams Struct Reference

Detailed Description

Definition at line 796 of file HsPhoneEvent.h.

Data Fields

  • PhnModuleButtonType key
  • UInt16 modifiers

Field Documentation

PhnModuleButtonType key

Definition at line 798 of file HsPhoneEvent.h.

UInt16 modifiers

Definition at line 799 of file HsPhoneEvent.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:22 2008 for Palm API Guide


PhnLibLengthInfoType Struct Reference

Detailed Description

SMS length information

Note:
For CDMA, this can be used to retrieve the SMS/EMS limits. length = max segment length. size = max EMS length

Definition at line 376 of file HsPhoneSMSTypes.h.

Data Fields

  • UInt16 size
  • Boolean substitution
  • UInt16 length
  • UInt16 segmentCount
  • Boolean requestSmsInfo

Field Documentation

UInt16 size

unused

Definition at line 378 of file HsPhoneSMSTypes.h.

Boolean substitution

Substitute characters if needed (GSM ONLY)

Definition at line 379 of file HsPhoneSMSTypes.h.

UInt16 length

total length of message

Definition at line 380 of file HsPhoneSMSTypes.h.

UInt16 segmentCount

number of segments used

Definition at line 381 of file HsPhoneSMSTypes.h.

Boolean requestSmsInfo

unused

Definition at line 382 of file HsPhoneSMSTypes.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:22 2008 for Palm API Guide


PhnLineStateType Struct Reference

Detailed Description

Line State

Definition at line 101 of file HsPhoneMiscTypes.h.

Data Fields

  • UInt16 version
  • UInt16 size
  • Boolean activeLine
  • Boolean divertIndicator
  • Boolean voiceMailIndicator

Field Documentation

UInt16 version

Definition at line 103 of file HsPhoneMiscTypes.h.

UInt16 size

Definition at line 104 of file HsPhoneMiscTypes.h.

Boolean activeLine

Definition at line 105 of file HsPhoneMiscTypes.h.

Boolean divertIndicator

Definition at line 106 of file HsPhoneMiscTypes.h.

Boolean voiceMailIndicator

Definition at line 107 of file HsPhoneMiscTypes.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:22 2008 for Palm API Guide


PhnMiscDbgRptType Struct Reference

Detailed Description

Definition at line 1181 of file HsPhoneEvent.h.

Data Fields

  • PhnMiscDbgUpdateKind miscUpdate

Field Documentation

PhnMiscDbgUpdateKind miscUpdate

Definition at line 1183 of file HsPhoneEvent.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:22 2008 for Palm API Guide


PhnMMIEntryType Struct Reference

Detailed Description

MMI Decode struct.

Definition at line 394 of file HsPhoneNetworkTypes.h.

Data Fields

  • UInt16 size
  • PhnMMIActionCode actionCode
  • PhnMMIServiceCode serviceCode
  • Boolean sendHit
  • char text [kMaxMMISequenceLen+1]
  • union {
    • struct {
      • char number [kMaxPhoneNumberLen+1]
      • PhnTeleserviceType type
      • UInt16 time
    • } mmiForwarding
    • struct {
      • PhnTeleserviceType type
      • char pwd [maxPasswordLen+1]
    • } mmiBarring
    • struct {
      • PhnTeleserviceType type
    • } mmiCallWaiting
    • struct {
      • char oldPwd [maxPasswordLen+1]
      • char newPwd [maxPasswordLen+1]
      • char repeatNewPwd [maxPasswordLen+1]
    • } mmiPassword
    • struct {
      • PhnCallControlType action
      • PhnConnectionID id
    • } mmiCallControl
    • struct {
      • char name [kMaxPhoneNumberLen+1]
      • char number [kMaxPhoneNumberLen+1]
      • GSMDialCLIRMode mode
    • } mmiPhoneNumber
  • } data

Field Documentation

UInt16 size

Definition at line 396 of file HsPhoneNetworkTypes.h.

PhnMMIActionCode actionCode

Definition at line 397 of file HsPhoneNetworkTypes.h.

PhnMMIServiceCode serviceCode

Definition at line 398 of file HsPhoneNetworkTypes.h.

Boolean sendHit

Definition at line 399 of file HsPhoneNetworkTypes.h.

char text[kMaxMMISequenceLen+1]

Definition at line 400 of file HsPhoneNetworkTypes.h.

char number[kMaxPhoneNumberLen+1]

Definition at line 405 of file HsPhoneNetworkTypes.h.

PhnTeleserviceType type

Definition at line 406 of file HsPhoneNetworkTypes.h.

UInt16 time

Definition at line 407 of file HsPhoneNetworkTypes.h.

struct { ... } mmiForwarding

char pwd[maxPasswordLen+1]

Definition at line 412 of file HsPhoneNetworkTypes.h.

struct { ... } mmiBarring

struct { ... } mmiCallWaiting

char oldPwd[maxPasswordLen+1]

Definition at line 420 of file HsPhoneNetworkTypes.h.

char newPwd[maxPasswordLen+1]

Definition at line 421 of file HsPhoneNetworkTypes.h.

char repeatNewPwd[maxPasswordLen+1]

Definition at line 422 of file HsPhoneNetworkTypes.h.

struct { ... } mmiPassword

PhnCallControlType action

Definition at line 426 of file HsPhoneNetworkTypes.h.

PhnConnectionID id

Definition at line 427 of file HsPhoneNetworkTypes.h.

struct { ... } mmiCallControl

char name[kMaxPhoneNumberLen+1]

Definition at line 431 of file HsPhoneNetworkTypes.h.

GSMDialCLIRMode mode

Definition at line 433 of file HsPhoneNetworkTypes.h.

struct { ... } mmiPhoneNumber

union { ... } data

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:22 2008 for Palm API Guide


PhnMMIResultType Struct Reference

Detailed Description

MMI result struct.

Definition at line 446 of file HsPhoneNetworkTypes.h.

Data Fields

  • UInt16 size
  • PhnMMIServiceCode serviceCode
  • union {
    • struct {
      • Boolean enabled
      • char number [kMaxPhoneNumberLen+1]
      • PhnTeleserviceType type
      • UInt16 time
    • } mmiForwarding
    • struct {
      • Boolean enabled
      • PhnTeleserviceType type
    • } mmiBarring
    • struct {
      • Boolean enabled
      • PhnTeleserviceType type
    • } mmiCallWaiting
    • struct {
      • Boolean enabled
    • } mmiCallerID
    • struct {
      • GSMCLIRDisplayStatus displayStatus
      • PhnCLIRStatus subscriptionStatus
    • } mmiNumberSent
    • struct {
      • Boolean enabled
    • } mmiColp
    • struct {
      • Boolean enabled
    • } mmiColr
    • struct {
      • char imei [kMaxImeiLen+1]
    • } mmiIMEI
  • } data

Field Documentation

UInt16 size

Definition at line 448 of file HsPhoneNetworkTypes.h.

PhnMMIServiceCode serviceCode

Definition at line 449 of file HsPhoneNetworkTypes.h.

Boolean enabled

Definition at line 454 of file HsPhoneNetworkTypes.h.

char number[kMaxPhoneNumberLen+1]

Definition at line 455 of file HsPhoneNetworkTypes.h.

PhnTeleserviceType type

Definition at line 456 of file HsPhoneNetworkTypes.h.

UInt16 time

Definition at line 457 of file HsPhoneNetworkTypes.h.

struct { ... } mmiForwarding

struct { ... } mmiBarring

struct { ... } mmiCallWaiting

struct { ... } mmiCallerID

GSMCLIRDisplayStatus displayStatus

Definition at line 475 of file HsPhoneNetworkTypes.h.

PhnCLIRStatus subscriptionStatus

Definition at line 476 of file HsPhoneNetworkTypes.h.

struct { ... } mmiNumberSent

struct { ... } mmiColp

struct { ... } mmiColr

char imei[kMaxImeiLen+1]

Definition at line 488 of file HsPhoneNetworkTypes.h.

struct { ... } mmiIMEI

union { ... } data

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:22 2008 for Palm API Guide


PhnMovedMsgDescType Struct Reference

Detailed Description

Definition at line 926 of file HsPhoneEvent.h.

Data Fields

  • PhnDatabaseID msgID
  • DWord msgOwner
  • Err error
  • UInt8 event

Field Documentation

PhnDatabaseID msgID

Definition at line 927 of file HsPhoneEvent.h.

DWord msgOwner

Definition at line 928 of file HsPhoneEvent.h.

Err error

Definition at line 929 of file HsPhoneEvent.h.

UInt8 event

Definition at line 930 of file HsPhoneEvent.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:23 2008 for Palm API Guide


PhnMovedMsgsParamsType Struct Reference

Collaboration diagram for PhnMovedMsgsParamsType:

[legend]

Detailed Description

Definition at line 936 of file HsPhoneEvent.h.

Data Fields

  • UInt16 count
  • PhnMovedMsgDescType * list

Field Documentation

UInt16 count

Definition at line 937 of file HsPhoneEvent.h.

PhnMovedMsgDescType* list

Definition at line 938 of file HsPhoneEvent.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:23 2008 for Palm API Guide


PhnMsgBoxDataType Struct Reference

Detailed Description

Definition at line 128 of file HsPhoneNetworkTypes.h.

Data Fields

  • Boolean indicatorOn
  • PhnMsgBoxType type
  • Int16 messageCount
  • Int16 lineNumber
  • PhnMsgBoxPriorityType priority

Field Documentation

Boolean indicatorOn

Definition at line 130 of file HsPhoneNetworkTypes.h.

PhnMsgBoxType type

Definition at line 131 of file HsPhoneNetworkTypes.h.

Int16 messageCount

Definition at line 132 of file HsPhoneNetworkTypes.h.

Int16 lineNumber

Definition at line 133 of file HsPhoneNetworkTypes.h.

PhnMsgBoxPriorityType priority

voicemail priority - example: normal, urgent etc.

Definition at line 134 of file HsPhoneNetworkTypes.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:23 2008 for Palm API Guide


PhnNetworkTime Struct Reference

Detailed Description

Definition at line 642 of file HsPhoneNetworkTypes.h.

Data Fields

  • UInt32 timeInSecs
  • Boolean daylightSavings
  • Int16 timeZone
  • UInt8 daylightSavingsHour

Field Documentation

UInt32 timeInSecs

Current time in minutes

Definition at line 644 of file HsPhoneNetworkTypes.h.

Boolean daylightSavings

Is this daylight savings

Definition at line 645 of file HsPhoneNetworkTypes.h.

Int16 timeZone

Number of minutes east of GMT

Definition at line 646 of file HsPhoneNetworkTypes.h.

UInt8 daylightSavingsHour

DST adjusted hours : GSM Only

Definition at line 647 of file HsPhoneNetworkTypes.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:23 2008 for Palm API Guide


PhnOnexMipRRQType Struct Reference

Detailed Description

Definition at line 1221 of file HsPhoneEvent.h.

Data Fields

  • Boolean init_rrq
  • DWord life_timer
  • DWord rrq_timer
  • DWord traffic_ck_delay_timer

Field Documentation

Boolean init_rrq

true if initial registration, false if reregistration

Definition at line 1223 of file HsPhoneEvent.h.

DWord life_timer

new lifetime value in seconds

Definition at line 1224 of file HsPhoneEvent.h.

DWord rrq_timer

new reregistration time value in seconds

Definition at line 1225 of file HsPhoneEvent.h.

DWord traffic_ck_delay_timer

time in seconds to delay checking for data to trigger re-registration

Definition at line 1226 of file HsPhoneEvent.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:23 2008 for Palm API Guide


PhnOneXStatus Struct Reference

Detailed Description

This is now deprecated. It is only implemented to maintain backwards compatibility Currently, the only user is NetMaster and the Phone App

Definition at line 577 of file HsPhoneNetworkTypes.h.

Data Fields

  • PhnOneXProtRevType oneXStatusPRev
  • PhnPacketDataSessionType pdSessionStatus
  • PhnMIPSessionType mipSessionType

Field Documentation

PhnOneXProtRevType oneXStatusPRev

Definition at line 579 of file HsPhoneNetworkTypes.h.

PhnPacketDataSessionType pdSessionStatus

Definition at line 580 of file HsPhoneNetworkTypes.h.

PhnMIPSessionType mipSessionType

Definition at line 581 of file HsPhoneNetworkTypes.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:23 2008 for Palm API Guide


PhnOperatorListType Struct Reference

Collaboration diagram for PhnOperatorListType:

[legend]

Detailed Description

Operator list

Definition at line 159 of file HsPhoneNetworkTypes.h.

Data Fields

  • short count
  • PhnOperatorType opData [1]

Field Documentation

short count

Definition at line 161 of file HsPhoneNetworkTypes.h.

PhnOperatorType opData[1]

Definition at line 162 of file HsPhoneNetworkTypes.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:23 2008 for Palm API Guide


PhnOperatorType Struct Reference

Detailed Description

Definition at line 146 of file HsPhoneNetworkTypes.h.

Data Fields

  • PhnOperatorStatus status
  • PhnOperatorID id
  • char longname [MAX_LONGOPERATORNAME_LENGTH+1]
  • char shortname [MAX_SHORTOPERATORNAME_LENGTH+1]
  • Boolean isRoaming

Field Documentation

PhnOperatorStatus status

Definition at line 148 of file HsPhoneNetworkTypes.h.

PhnOperatorID id

Not really used since CDMA just allows one service provider

Definition at line 149 of file HsPhoneNetworkTypes.h.

char longname[MAX_LONGOPERATORNAME_LENGTH+1]

name + terminating NULL char

Definition at line 150 of file HsPhoneNetworkTypes.h.

char shortname[MAX_SHORTOPERATORNAME_LENGTH+1]

name + terminating NULL char

Definition at line 151 of file HsPhoneNetworkTypes.h.

Boolean isRoaming

in sync with the current roaming status

Definition at line 152 of file HsPhoneNetworkTypes.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:23 2008 for Palm API Guide


PhnPasswordEventType Struct Reference

Detailed Description

Definition at line 870 of file HsPhoneEvent.h.

Data Fields

  • PhnPasswordType type
  • PhnPasswordType prevType
  • Err error
  • PhnPassword pin
  • PhnPassword puk

Field Documentation

PhnPasswordType type

Definition at line 871 of file HsPhoneEvent.h.

PhnPasswordType prevType

Definition at line 872 of file HsPhoneEvent.h.

Err error

Definition at line 873 of file HsPhoneEvent.h.

PhnPassword pin

Definition at line 874 of file HsPhoneEvent.h.

PhnPassword puk

Definition at line 875 of file HsPhoneEvent.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:23 2008 for Palm API Guide


PhnPDDataType Struct Reference

Detailed Description

Definition at line 772 of file HsPhoneCDMATypes.h.

Data Fields

  • DWord lat
  • DWord lon
  • DWord time_stamp
  • UInt8 loc_uncertainty_ang
  • PhnPDPAUncerttype loc_uncertainty_a
  • PhnPDPAUncerttype loc_uncertainty_p
  • UInt8 phn_pd_svc_mask
  • UInt16 altitude
  • UInt16 heading
  • UInt16 velocity_hor
  • Boolean fix_t
  • UInt16 velocity_ver
  • PhnPDPAUncerttype loc_uncertainty_v

Field Documentation

DWord lat

Two's complement value of the latitude of the modem, in units of 360/2^25 degrees.

Definition at line 775 of file HsPhoneCDMATypes.h.

DWord lon

Two's complement value of the longitude of the modem, in units of 360/2^26 degrees.

Definition at line 779 of file HsPhoneCDMATypes.h.

DWord time_stamp

CDMA system time, in seconds, at the time the solution was valid.

Definition at line 783 of file HsPhoneCDMATypes.h.

UInt8 loc_uncertainty_ang

Angle of axis with respect to True North for position uncertainty, in units of 5.625 degrees, in the range from 0 to 84.375 degrees, where 0 degrees is True North and the angle increases towards the East.

Definition at line 786 of file HsPhoneCDMATypes.h.

PhnPDPAUncerttype loc_uncertainty_a

Standard deviation of axis along angle specified for position uncertainty.

Definition at line 792 of file HsPhoneCDMATypes.h.

PhnPDPAUncerttype loc_uncertainty_p

Standard deviation of axis perpendicular to angle specified for position uncertainty.

Definition at line 796 of file HsPhoneCDMATypes.h.

UInt8 phn_pd_svc_mask

Bit mask indicating which of the following optional fields contain valid data.

Definition at line 800 of file HsPhoneCDMATypes.h.

UInt16 altitude

Height of the modem, in units of 1 meter, in the range from -500 m to 15883 m, where the binary value of the field conveys the height plus 500 m. Valid if OPT_FIELD_MASK field has PDSM_PD_ALTITUDE_VALID bit set.

Definition at line 804 of file HsPhoneCDMATypes.h.

UInt16 heading

Direction of the modem, in units of 360/2^10 degrees, in the range from 0 to 360x(1-2^10) degrees (where 0 degrees is True North and the angle increases towards the East. Valid if OPT_FIELD_MASK field has PDSM_PD_VELOCITY_VALID bit set.

Definition at line 810 of file HsPhoneCDMATypes.h.

UInt16 velocity_hor

Horizontal component of the velocity of the modem, in units of 0.25 m/s, in the range from 0 to 127.75 m/s. Valid if OPT_FIELD_MASK field has PDSM_PD_VELOCITY_VALID bit set.

Definition at line 816 of file HsPhoneCDMATypes.h.

Boolean fix_t

Boolean indicating fixed type. 0 means 2D fix and 1 means 3D fix.

Definition at line 821 of file HsPhoneCDMATypes.h.

UInt16 velocity_ver

Two's complement value of the vertical component of the velocity of the modem, in units of 0.5 m/s, in the range from -64m/s to +63.5m/s. Valid if OPT_FIELD_MASK field has PDSM_PD_VELOCITY_VALID bit set and FIX_T is set to TRUE.

Definition at line 825 of file HsPhoneCDMATypes.h.

PhnPDPAUncerttype loc_uncertainty_v

Standard deviation of vertical error for position uncertainty. Valid if OPT_FIELD_MASK field has PDSM_PD_VELOCITY_VALID bit set.

Definition at line 831 of file HsPhoneCDMATypes.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:23 2008 for Palm API Guide


PhnPDPList Struct Reference

Detailed Description

None of the PDP strings (like service string, dial string, passwords etc.) require null terminator and no need to count null terminator for the length.

PhnPDPList structure lists status of all the packet data profile slots

Definition at line 347 of file HsPhoneCDMATypes.h.

Data Fields

  • Boolean idx0_set
  • Boolean idx1_set
  • Boolean idx2_set
  • Boolean idx3_set
  • Boolean idx4_set
  • Boolean idx5_set
  • Boolean idx6_set
  • Boolean idx7_set
  • Boolean idx_RSVD8_set
  • Boolean idx_RSVD9_set
  • Boolean qnc_set
  • Boolean active_idx_set
  • UInt8 active_idx
  • UInt8 idx0_uid [phnPDPUidLen]
  • UInt8 idx1_uid [phnPDPUidLen]
  • UInt8 idx2_uid [phnPDPUidLen]
  • UInt8 idx3_uid [phnPDPUidLen]
  • UInt8 idx4_uid [phnPDPUidLen]
  • UInt8 idx5_uid [phnPDPUidLen]
  • UInt8 idx6_uid [phnPDPUidLen]
  • UInt8 idx7_uid [phnPDPUidLen]
  • UInt8 idx_rsvd8_uid [phnPDPUidLen]
  • UInt8 idx_rsvd9_uid [phnPDPUidLen]
  • UInt8 qnc_uid [phnPDPUidLen]
  • UInt8 num_stand_pdp_idxs
  • UInt8 first_stand_pdp_idx
  • UInt8 num_def_pdp_idxs
  • UInt8 first_def_pdp_idx
  • UInt8 num_tmp_pdp_idxs
  • UInt8 first_tmp_pdp_idx

Field Documentation

Boolean idx0_set

Boolean indicating if index contains a valid PDP in the modem.

Definition at line 350 of file HsPhoneCDMATypes.h.

Boolean idx1_set

Boolean indicating if index contains a valid PDP in the modem.

Definition at line 353 of file HsPhoneCDMATypes.h.

Boolean idx2_set

Boolean indicating if index contains a valid PDP in the modem.

Definition at line 356 of file HsPhoneCDMATypes.h.

Boolean idx3_set

Boolean indicating if index contains a valid PDP in the modem.

Definition at line 359 of file HsPhoneCDMATypes.h.

Boolean idx4_set

Boolean indicating if index contains a valid PDP in the modem.

Definition at line 362 of file HsPhoneCDMATypes.h.

Boolean idx5_set

Boolean indicating if index contains a valid PDP in the modem.

Definition at line 365 of file HsPhoneCDMATypes.h.

Boolean idx6_set

Boolean indicating if index contains a valid PDP in the modem.

Definition at line 368 of file HsPhoneCDMATypes.h.

Boolean idx7_set

Boolean indicating if index contains a valid PDP in the modem.

Definition at line 371 of file HsPhoneCDMATypes.h.

Boolean idx_RSVD8_set

Reserved field.

Definition at line 374 of file HsPhoneCDMATypes.h.

Boolean idx_RSVD9_set

Reserved field.

Definition at line 377 of file HsPhoneCDMATypes.h.

Boolean qnc_set

Boolean indicating if a valid QNC profile is stored in the modem.

Definition at line 380 of file HsPhoneCDMATypes.h.

Boolean active_idx_set

Boolean indicating if there is currently an active index set in the modem.

Definition at line 383 of file HsPhoneCDMATypes.h.

UInt8 active_idx

Indication of which index is currently the active index in the modem if ACTIVE_IDX_SET.

Definition at line 387 of file HsPhoneCDMATypes.h.

UInt8 idx0_uid[phnPDPUidLen]

The Unique ID for the PDP stored in index if index is set.

Definition at line 391 of file HsPhoneCDMATypes.h.

UInt8 idx1_uid[phnPDPUidLen]

The Unique ID for the PDP stored in index if index is set.

Definition at line 394 of file HsPhoneCDMATypes.h.

UInt8 idx2_uid[phnPDPUidLen]

The Unique ID for the PDP stored in index if index is set.

Definition at line 397 of file HsPhoneCDMATypes.h.

UInt8 idx3_uid[phnPDPUidLen]

The Unique ID for the PDP stored in index if index is set.

Definition at line 400 of file HsPhoneCDMATypes.h.

UInt8 idx4_uid[phnPDPUidLen]

The Unique ID for the PDP stored in index if index is set.

Definition at line 403 of file HsPhoneCDMATypes.h.

UInt8 idx5_uid[phnPDPUidLen]

The Unique ID for the PDP stored in index if index is set.

Definition at line 406 of file HsPhoneCDMATypes.h.

UInt8 idx6_uid[phnPDPUidLen]

The Unique ID for the PDP stored in index if index is set.

Definition at line 409 of file HsPhoneCDMATypes.h.

UInt8 idx7_uid[phnPDPUidLen]

The Unique ID for the PDP stored in index if index is set.

Definition at line 412 of file HsPhoneCDMATypes.h.

UInt8 idx_rsvd8_uid[phnPDPUidLen]

Reserved field.

Definition at line 415 of file HsPhoneCDMATypes.h.

UInt8 idx_rsvd9_uid[phnPDPUidLen]

Reserved field.

Definition at line 418 of file HsPhoneCDMATypes.h.

UInt8 qnc_uid[phnPDPUidLen]

The Unique ID for the QNC profile stored in the modem.

Definition at line 421 of file HsPhoneCDMATypes.h.

UInt8 num_stand_pdp_idxs

The number of standard PDPs in the modem.

Definition at line 424 of file HsPhoneCDMATypes.h.

UInt8 first_stand_pdp_idx

IF NUM_STAND_PDP_IDXS is greater than zero, indicates the first standard PDP index (assumes set of all standard PDP indexes are sequential).

Definition at line 427 of file HsPhoneCDMATypes.h.

UInt8 num_def_pdp_idxs

The number of default PDPs in the modem that cannot be modified by an IOTA session.

Definition at line 431 of file HsPhoneCDMATypes.h.

UInt8 first_def_pdp_idx

IF NUM_DEF_PDP_IDXS is greater than zero, indicates the first default PDP index (assumes set of all default PDP indexes are sequential).

Definition at line 435 of file HsPhoneCDMATypes.h.

UInt8 num_tmp_pdp_idxs

The Unique ID for the QNC profile stored in the modem.

Definition at line 439 of file HsPhoneCDMATypes.h.

UInt8 first_tmp_pdp_idx

IF NUM_TMP_PDP_IDXS is greater than zero, indicates the first default PDP index (assumes set of all default PDP indexes are sequential).

Definition at line 442 of file HsPhoneCDMATypes.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:24 2008 for Palm API Guide


PhnPDPPayload Struct Reference

Detailed Description

Packet data profile payload

Definition at line 636 of file HsPhoneCDMATypes.h.

Data Fields

  • UInt8 uid [phnPDPUidLen]
  • Boolean restrict_nai
  • UInt8 nai_length
  • UInt8 nai [phnMaxNAILen]
  • Boolean restrict_mn_aaa_ss
  • Boolean stored_mn_aaa_ss
  • UInt8 mn_aaa_ss_length
  • UInt8 mn_aaa_ss [phnMaxMNAAASharedSecretLen]
  • Boolean restrict_mn_ha_ss
  • UInt8 mn_ha_ss_length
  • UInt8 mn_ha_ss [phnMaxMNHASharedSecretLen]
  • Boolean restrict_mn_aaa_spi
  • Boolean set_mn_aaa_spi
  • DWord mn_aaa_spi
  • Boolean restrict_mn_ha_spi
  • Boolean set_mn_ha_spi
  • DWord mn_ha_spi
  • Boolean restrict_rev_tunnel_pref
  • Boolean rev_tunnel_pref
  • Boolean restrict_home_addr
  • DWord home_addr
  • Boolean restrict_ha_addr
  • DWord prim_ha_addr
  • DWord sec_ha_addr
  • UInt8 svc_str_length
  • UInt8 svc_str [phnMaxSvcStrLen]
  • UInt8 dial_str_length
  • UInt8 dial_str [phnMaxDialStrLen]
  • Boolean dns_server_assigned
  • DWord prim_dns_addr
  • DWord sec_dns_addr
  • PhnPDPConnectionType connection_type
  • PhnPDPService pdp_services

Field Documentation

UInt8 uid[phnPDPUidLen]

The binary UID for this PDP.

Definition at line 638 of file HsPhoneCDMATypes.h.

Boolean restrict_nai

Boolean indicating if the NAI field is restricted from being read from this PDP index. None of the following NAI fields will contain valid data if set to TRUE.

Definition at line 641 of file HsPhoneCDMATypes.h.

UInt8 nai_length

The number of characters in the NAI.

Definition at line 646 of file HsPhoneCDMATypes.h.

UInt8 nai[phnMaxNAILen]

The user NAI character string in ASCII representation.

Definition at line 649 of file HsPhoneCDMATypes.h.

Boolean restrict_mn_aaa_ss

Boolean indicating if the MN-AAA shared secret field is restricted from being read from this PDP index. None of the following MN-AAA shared secret fields will contain valid data if set to TRUE.

Definition at line 652 of file HsPhoneCDMATypes.h.

Boolean stored_mn_aaa_ss

Boolean indicating if the MN-AAA shared secret parameter is stored with this PDP profile.

Definition at line 657 of file HsPhoneCDMATypes.h.

UInt8 mn_aaa_ss_length

Length of the MN-AAA shared secret parameter for this PDP if the STORE_MN_AAA_SS field is set to FALSE. Maximum length shall be 16.

Definition at line 661 of file HsPhoneCDMATypes.h.

UInt8 mn_aaa_ss[phnMaxMNAAASharedSecretLen]

Text/binary string of the MN-AAA shared secret parameter stored in the modem for this PDP.

Definition at line 665 of file HsPhoneCDMATypes.h.

Boolean restrict_mn_ha_ss

Boolean indicating if the MN-HA shared secret field is restricted from being read from this PDP index. None of the following MN-HA shared secret fields will contain valid data if set to TRUE.

Definition at line 669 of file HsPhoneCDMATypes.h.

UInt8 mn_ha_ss_length

Length of the MN-HA shared secret parameter stored in the modem for this PDP. Maximum length shall be 16.

Definition at line 674 of file HsPhoneCDMATypes.h.

UInt8 mn_ha_ss[phnMaxMNHASharedSecretLen]

Text/binary string of the MN-HA shared secret parameter stored in the modem for this PDP.

Definition at line 678 of file HsPhoneCDMATypes.h.

Boolean restrict_mn_aaa_spi

Boolean indicating if the SPI for MN-AAA authentication field is restricted from being read from this PDP index. None of the following SPI for MN-AAA authentication fields will contain valid data if set to TRUE.

Definition at line 682 of file HsPhoneCDMATypes.h.

Boolean set_mn_aaa_spi

Boolean indicating if the SPI for MN-AAA authentication is set for this PDP

Definition at line 688 of file HsPhoneCDMATypes.h.

DWord mn_aaa_spi

Integer value of the SPI for MN-AAA authentication for this PDP.

Definition at line 692 of file HsPhoneCDMATypes.h.

Boolean restrict_mn_ha_spi

Boolean indicating if the SPI for MN-HA authentication field is restricted from being read from this PDP index. None of the following SPI for MN-AAA authentication fields will contain valid data if set to TRUE.

Definition at line 695 of file HsPhoneCDMATypes.h.

Boolean set_mn_ha_spi

Boolean indicating if the SPI for MN-HA authentication is set for this PDP.

Definition at line 701 of file HsPhoneCDMATypes.h.

DWord mn_ha_spi

Integer value of the SPI for MN-HA authentication parameter for this PDP.

Definition at line 705 of file HsPhoneCDMATypes.h.

Boolean restrict_rev_tunnel_pref

Boolean indicating if the reverse tunnel setting is restricted from being read from this PDP index. The REV_TUNNEL_PREF field will not contain valid data if set to TRUE.

Definition at line 709 of file HsPhoneCDMATypes.h.

Boolean rev_tunnel_pref

Boolean indicating if reverse tunnel is used for this PDP.

Definition at line 714 of file HsPhoneCDMATypes.h.

Boolean restrict_home_addr

Boolean indicating if the modem's Home Address setting is restricted from being read from this PDP index. The HOME_ADDR field will not contain valid data if set to TRUE.

Definition at line 717 of file HsPhoneCDMATypes.h.

DWord home_addr

The home IP address of the modem for this PDP. An address of 0.0.0.0 indicates the IP address will be dynamically assigned by the PDSN for Mobile IP and Simple IP.

Definition at line 722 of file HsPhoneCDMATypes.h.

Boolean restrict_ha_addr

Boolean indicating if the Home Agent IP address fields are restricted from being read from this PDP index. None of the following Home Agent IP address fields will contain valid data if set to TRUE.

Definition at line 727 of file HsPhoneCDMATypes.h.

DWord prim_ha_addr

The Primary Home Agent IP address for this PDP

Definition at line 732 of file HsPhoneCDMATypes.h.

DWord sec_ha_addr

The Secondary Home Agent IP address for this PDP

Definition at line 735 of file HsPhoneCDMATypes.h.

UInt8 svc_str_length

The length of the service string for this PDP.

Definition at line 738 of file HsPhoneCDMATypes.h.

UInt8 svc_str[phnMaxSvcStrLen]

Text string of the service string for this PDP.

Definition at line 741 of file HsPhoneCDMATypes.h.

UInt8 dial_str_length

The length of the dial string for this PDP.

Definition at line 744 of file HsPhoneCDMATypes.h.

UInt8 dial_str[phnMaxDialStrLen]

The dial string for this PDP.

Definition at line 747 of file HsPhoneCDMATypes.h.

Boolean dns_server_assigned

Boolean indicating if specific DNS server IP addresses are assigned for this PDP.

Definition at line 750 of file HsPhoneCDMATypes.h.

DWord prim_dns_addr

The Primary DNS server IP address for this PDP if the DNS_SERVER_ASSIGNED field is set to TRUE.

Definition at line 754 of file HsPhoneCDMATypes.h.

DWord sec_dns_addr

The Secondary DNS server IP address for this PDP if the DNS_SERVER_ASSIGNED field is set to TRUE.

Definition at line 758 of file HsPhoneCDMATypes.h.

PhnPDPConnectionType connection_type

Connection type of the PDP

Definition at line 762 of file HsPhoneCDMATypes.h.

PhnPDPService pdp_services

Services for which this PDP should be used

Definition at line 765 of file HsPhoneCDMATypes.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:24 2008 for Palm API Guide


PhnPDPWrite Struct Reference

Detailed Description

Definition at line 450 of file HsPhoneCDMATypes.h.

Data Fields

  • UInt8 idx
  • Boolean use_existing_nai
  • UInt8 nai_length
  • UInt8 nai [phnMaxNAILen]
  • Boolean use_existing_mn_aaa_ss
  • Boolean store_mn_aaa_ss
  • UInt8 mn_aaa_ss_length
  • UInt8 mn_aaa_ss [phnMaxMNAAASharedSecretLen]
  • Boolean use_existing_mn_ha_ss
  • UInt8 reserved1
  • UInt8 mn_ha_ss_length
  • UInt8 mn_ha_ss [phnMaxMNHASharedSecretLen]
  • Boolean use_existing_mn_aaa_spi
  • UInt8 reserved2
  • Boolean set_mn_aaa_spi
  • DWord mn_aaa_spi
  • Boolean use_existing_mn_ha_spi
  • UInt8 reserved3
  • Boolean set_mn_ha_spi
  • DWord mn_ha_spi
  • Boolean use_existing_rev_tunnel_pref
  • UInt8 reserved4
  • Boolean rev_tunnel_pref
  • Boolean use_existing_home_addr
  • UInt8 reserved5
  • DWord home_addr
  • Boolean use_existing_ha_addr
  • UInt8 reserved6
  • DWord prim_ha_addr
  • DWord sec_ha_addr
  • Boolean use_existing_svc_str
  • Boolean use_default_svc_str
  • UInt8 svc_str_length
  • UInt8 svc_str [phnMaxSvcStrLen]
  • Boolean use_existing_dial_str
  • Boolean use_default_dial_str
  • UInt8 dial_str_length
  • UInt8 dial_str [phnMaxDialStrLen]
  • Boolean use_existing_dns_server
  • Boolean dns_server_assigned
  • DWord prim_dns_addr
  • DWord sec_dns_addr
  • PhnPDPConnectionType connection_type
  • PhnPDPService pdp_services

Field Documentation

UInt8 idx

The index of the PDP to write to in the modem. The set of valid indexes that can be written to is dependent on the modem platform being used.

Definition at line 452 of file HsPhoneCDMATypes.h.

Boolean use_existing_nai

Boolean indicating if the NAI currently stored in this PDP should be saved. If set to FALSE, the following two fields are used for new NAI value.

Definition at line 457 of file HsPhoneCDMATypes.h.

UInt8 nai_length

The number of characters in the NAI.

Definition at line 462 of file HsPhoneCDMATypes.h.

UInt8 nai[phnMaxNAILen]

The user NAI character string in ASCII representation

Definition at line 465 of file HsPhoneCDMATypes.h.

Boolean use_existing_mn_aaa_ss

Boolean indicating if the MN-AAA-SS currently stored in this PDP should be saved. If set to FALSE, the following three fields are used for new MN-AAA-SS value.

Definition at line 468 of file HsPhoneCDMATypes.h.

Boolean store_mn_aaa_ss

Boolean indicating if the MN-AAA shared secret parameter is to be stored with this PDP profile. Setting this field to FALSE requires the host to send a temporary MN-AAA shared secret value to the modem before using this PDP to connect to a network.

Definition at line 474 of file HsPhoneCDMATypes.h.

UInt8 mn_aaa_ss_length

Length of the MN-AAA shared secret parameter to store in the modem for this PDP if the STORE_MN_AAA_SS field is set to TRUE.

Definition at line 480 of file HsPhoneCDMATypes.h.

UInt8 mn_aaa_ss[phnMaxMNAAASharedSecretLen]

Text/binary string of the MN-AAA shared secret parameter to store in the modem for this PDP if the STORE_MN_AAA_SS field is set to TRUE.

Definition at line 484 of file HsPhoneCDMATypes.h.

Boolean use_existing_mn_ha_ss

Boolean indicating if the MN-HA-SS currently stored in this PDP should be saved. If set to FALSE, the following three fields are used for new MN-HA-SS value.

Definition at line 488 of file HsPhoneCDMATypes.h.

UInt8 reserved1

for future use

Definition at line 493 of file HsPhoneCDMATypes.h.

UInt8 mn_ha_ss_length

Length of the MN-HA shared secret parameter to store in the modem for this PDP

Definition at line 496 of file HsPhoneCDMATypes.h.

UInt8 mn_ha_ss[phnMaxMNHASharedSecretLen]

Text/binary string of the MN-HA shared secret parameter to store in the modem for this PDP

Definition at line 500 of file HsPhoneCDMATypes.h.

Boolean use_existing_mn_aaa_spi

Boolean indicating if the MN-AAA SPI currently stored in this PDP should be saved. If set to FALSE, the following three fields are used for new MN-AAA SPI value.

Definition at line 504 of file HsPhoneCDMATypes.h.

UInt8 reserved2

for future use

Definition at line 509 of file HsPhoneCDMATypes.h.

Boolean set_mn_aaa_spi

Boolean indicating if the SPI for MN-AAA authentication is to be set for this PDP

Definition at line 512 of file HsPhoneCDMATypes.h.

DWord mn_aaa_spi

Integer value of the SPI for MN-AAA authentication parameter to store in the modem for this PDP if the SET_MN_AAA_SPI field is set to TRUE.

Definition at line 516 of file HsPhoneCDMATypes.h.

Boolean use_existing_mn_ha_spi

Boolean indicating if the MN-HA SPI currently stored in this PDP should be saved. If set to FALSE, the following three fields are used for new MN-HA SPI value.

Definition at line 520 of file HsPhoneCDMATypes.h.

UInt8 reserved3

for future use

Definition at line 525 of file HsPhoneCDMATypes.h.

Boolean set_mn_ha_spi

Boolean indicating if the SPI for MN-HA authentication is to be set for this PDP

Definition at line 528 of file HsPhoneCDMATypes.h.

DWord mn_ha_spi

Integer value of the SPI for MN-HA authentication parameter to store in the modem for this PDP if the SET_MN_HA_SPI field is set to TRUE.

Definition at line 532 of file HsPhoneCDMATypes.h.

Boolean use_existing_rev_tunnel_pref

Boolean indicating if the Reverse Tunneling Preference currently stored in this PDP should be saved. If set to FALSE, the following two fields are used for new Reverse Tunneling Preference values.

Definition at line 536 of file HsPhoneCDMATypes.h.

UInt8 reserved4

for future use

Definition at line 541 of file HsPhoneCDMATypes.h.

Boolean rev_tunnel_pref

Boolean indicating if reverse tunnel is to be used for this PDP.

Definition at line 544 of file HsPhoneCDMATypes.h.

Boolean use_existing_home_addr

Boolean indicating if the Home Address currently stored in this PDP should be saved. If set to FALSE, the following two fields are used for new Home Address value.

Definition at line 547 of file HsPhoneCDMATypes.h.

UInt8 reserved5

for future use

Definition at line 552 of file HsPhoneCDMATypes.h.

DWord home_addr

The home IP address of the modem. Setting this address to 0.0.0.0 will allow the IP address to be dynamically assigned by the PDSN for Mobile IP and Simple IP.

Definition at line 555 of file HsPhoneCDMATypes.h.

Boolean use_existing_ha_addr

Boolean indicating if the Home Agent IP Address currently stored in this PDP should be saved. If set to FALSE, the following three fields are used for new Home Agent IP Address values.

Definition at line 560 of file HsPhoneCDMATypes.h.

UInt8 reserved6

for future use

Definition at line 565 of file HsPhoneCDMATypes.h.

DWord prim_ha_addr

The Primary Home Agent IP address for this PDP

Definition at line 568 of file HsPhoneCDMATypes.h.

DWord sec_ha_addr

The Secondary Home Agent IP address for this PDP

Definition at line 571 of file HsPhoneCDMATypes.h.

Boolean use_existing_svc_str

Boolean indicating if the Service String currently stored in this PDP should be saved. If set to FALSE, the following three fields are used for new Service String value.

Definition at line 574 of file HsPhoneCDMATypes.h.

Boolean use_default_svc_str

Boolean indicating if the service string name that the modem would create for this profile (the carrier name string + user name portion of NAI) should be stored as the service string for this PDP.

Definition at line 579 of file HsPhoneCDMATypes.h.

UInt8 svc_str_length

The length of the service string to be stored for this PDP if USE_DEFAULT_SVC_STR is set to FALSE.

Definition at line 584 of file HsPhoneCDMATypes.h.

UInt8 svc_str[phnMaxSvcStrLen]

Text string of the service string to be stored for this PDP if USE_DEFAULT_SVC_STR is set to FALSE.

Definition at line 588 of file HsPhoneCDMATypes.h.

Boolean use_existing_dial_str

Boolean indicating if the Dial String currently stored in this PDP should be saved. If set to FALSE, the following three fields are used for new Dial String values.

Definition at line 592 of file HsPhoneCDMATypes.h.

Boolean use_default_dial_str

Boolean indicating if the dial string to associated and stored with this PDP should be set to the default Packet Data dial string stored in the modem.

Definition at line 597 of file HsPhoneCDMATypes.h.

UInt8 dial_str_length

The length of the dial string to be associated and stored with this PDP if USE_DEFAULT_DIAL_STR is FALSE.

Definition at line 602 of file HsPhoneCDMATypes.h.

UInt8 dial_str[phnMaxDialStrLen]

The dial string to be associated and stored with this PDP if USE_DEFAULT_DIAL_STR is FALSE.

Definition at line 606 of file HsPhoneCDMATypes.h.

Boolean use_existing_dns_server

Boolean indicating if the DNS Server currently stored in this PDP should be saved. If set to FALSE, the following three fields are used for new DNS Server values.

Definition at line 610 of file HsPhoneCDMATypes.h.

Boolean dns_server_assigned

Boolean indicating if specific DNS server IP addresses are to be associated and stored with this PDP.

Definition at line 615 of file HsPhoneCDMATypes.h.

DWord prim_dns_addr

The Primary DNS server IP address for this PDP if the DNS_SERVER_ASSIGNED field is set to TRUE.

Definition at line 619 of file HsPhoneCDMATypes.h.

DWord sec_dns_addr

The Secondary DNS server IP address for this PDP if the DNS_SERVER_ASSIGNED field is set to TRUE.

Definition at line 623 of file HsPhoneCDMATypes.h.

PhnPDPConnectionType connection_type

Connection type of the PDP

Definition at line 627 of file HsPhoneCDMATypes.h.

PhnPDPService pdp_services

Services for which this PDP should be used

Definition at line 630 of file HsPhoneCDMATypes.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:25 2008 for Palm API Guide


PhnPhoneBookInfoType Struct Reference

Detailed Description

Definition at line 73 of file HsPhoneGSMTypes.h.

Data Fields

  • UInt16 firstEntry
  • UInt16 lastEntry
  • UInt16 maxNameLength
  • UInt16 maxNumberLength

Field Documentation

UInt16 firstEntry

Definition at line 74 of file HsPhoneGSMTypes.h.

UInt16 lastEntry

Definition at line 75 of file HsPhoneGSMTypes.h.

UInt16 maxNameLength

Definition at line 76 of file HsPhoneGSMTypes.h.

UInt16 maxNumberLength

Definition at line 77 of file HsPhoneGSMTypes.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:25 2008 for Palm API Guide


PhnPhoneEquipmentMode Struct Reference

Detailed Description

Definition at line 1160 of file HsPhoneEvent.h.

Data Fields

  • long mode

Field Documentation

long mode

Definition at line 1161 of file HsPhoneEvent.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:25 2008 for Palm API Guide


PhnPowerEventType Struct Reference

Detailed Description

Definition at line 815 of file HsPhoneEvent.h.

Data Fields

  • PhnPowerType state

Field Documentation

PhnPowerType state

Definition at line 817 of file HsPhoneEvent.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:25 2008 for Palm API Guide


PhnProgressEventType Struct Reference

Detailed Description

Definition at line 917 of file HsPhoneEvent.h.

Data Fields

  • PhnProgressType progress
  • PhnOpenDialogType dialog
  • DWord data

Field Documentation

PhnProgressType progress

Definition at line 918 of file HsPhoneEvent.h.

PhnOpenDialogType dialog

Definition at line 919 of file HsPhoneEvent.h.

DWord data

only for SMS progress

Definition at line 920 of file HsPhoneEvent.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:25 2008 for Palm API Guide


PhnRadioStateType Struct Reference

Detailed Description

Radio state

Definition at line 86 of file HsPhoneMiscTypes.h.

Data Fields

  • UInt16 version
  • UInt32 size
  • UInt16 maxConnections
  • Boolean alsSupported
  • Int16 activeLineNumber

Field Documentation

UInt16 version

Definition at line 88 of file HsPhoneMiscTypes.h.

UInt32 size

Definition at line 89 of file HsPhoneMiscTypes.h.

UInt16 maxConnections

Definition at line 90 of file HsPhoneMiscTypes.h.

Boolean alsSupported

GSM only feature. if False activeLineNumber should always be 1

Definition at line 91 of file HsPhoneMiscTypes.h.

Int16 activeLineNumber

Definition at line 92 of file HsPhoneMiscTypes.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:25 2008 for Palm API Guide


PhnRegistrationType Struct Reference

Detailed Description

Definition at line 806 of file HsPhoneEvent.h.

Data Fields

  • PhnRegistrationStatus status

Field Documentation

PhnRegistrationStatus status

Definition at line 808 of file HsPhoneEvent.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:25 2008 for Palm API Guide


PhnRingingInfoType Struct Reference

Collaboration diagram for PhnRingingInfoType:

[legend]

Detailed Description

Item description here

Definition at line 82 of file HsPhoneAudioTypes.h.

Data Fields

  • PhnRingingProfileType profiles [kSliderPositions]

Field Documentation

PhnRingingProfileType profiles[kSliderPositions]

Definition at line 83 of file HsPhoneAudioTypes.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:25 2008 for Palm API Guide


PhnRingingProfileType Struct Reference

Detailed Description

Definition at line 52 of file HsPhoneAudioTypes.h.

Data Fields

  • UInt8 ringerID
  • UInt16 volume
  • Boolean vibrate
  • Boolean msgAlert
  • Boolean svcAlert

Field Documentation

UInt8 ringerID

Definition at line 54 of file HsPhoneAudioTypes.h.

UInt16 volume

Definition at line 55 of file HsPhoneAudioTypes.h.

Boolean vibrate

Definition at line 56 of file HsPhoneAudioTypes.h.

Boolean msgAlert

Definition at line 57 of file HsPhoneAudioTypes.h.

Boolean svcAlert

Definition at line 58 of file HsPhoneAudioTypes.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:26 2008 for Palm API Guide


PhnRoamPrefInfoType Struct Reference

Detailed Description

CDMA Roam Preferences

Definition at line 233 of file HsPhoneNetworkTypes.h.

Data Fields

  • Boolean roamCallGuardEnable
  • Boolean roamRingerEnable
  • UInt8 roamRingerID

Field Documentation

Boolean roamCallGuardEnable

Definition at line 235 of file HsPhoneNetworkTypes.h.

Boolean roamRingerEnable

Definition at line 236 of file HsPhoneNetworkTypes.h.

UInt8 roamRingerID

Definition at line 237 of file HsPhoneNetworkTypes.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:26 2008 for Palm API Guide


PhnSATEventDataSvc Struct Reference

Detailed Description

Definition at line 1133 of file HsPhoneEvent.h.

Data Fields

  • UInt32 signature
  • UInt32 notificationType
  • UInt8 chanId
  • UInt8 serviceType
  • UInt8 loginNeeded
  • UInt8 passwdNeeded
  • UInt32 alphaIdOffset

Field Documentation

UInt32 signature

Definition at line 1134 of file HsPhoneEvent.h.

UInt32 notificationType

Definition at line 1135 of file HsPhoneEvent.h.

UInt8 chanId

Definition at line 1137 of file HsPhoneEvent.h.

UInt8 serviceType

Definition at line 1138 of file HsPhoneEvent.h.

UInt8 loginNeeded

See GSMSATDataSvcType

Definition at line 1139 of file HsPhoneEvent.h.

UInt8 passwdNeeded

Definition at line 1140 of file HsPhoneEvent.h.

UInt32 alphaIdOffset

Definition at line 1141 of file HsPhoneEvent.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:26 2008 for Palm API Guide


PhnSATEventDisplayText Struct Reference

Detailed Description

Definition at line 961 of file HsPhoneEvent.h.

Data Fields

  • UInt32 signature
  • UInt32 notificationType
  • UInt32 textOffset
  • UInt16 priority
  • UInt16 clearMode

Field Documentation

UInt32 signature

Definition at line 962 of file HsPhoneEvent.h.

UInt32 notificationType

Definition at line 963 of file HsPhoneEvent.h.

UInt32 textOffset

Definition at line 965 of file HsPhoneEvent.h.

UInt16 priority

Definition at line 966 of file HsPhoneEvent.h.

UInt16 clearMode

Definition at line 967 of file HsPhoneEvent.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:26 2008 for Palm API Guide


PhnSATEventGetInkey Struct Reference

Detailed Description

Definition at line 974 of file HsPhoneEvent.h.

Data Fields

  • UInt32 signature
  • UInt32 notificationType
  • UInt32 textOffset
  • UInt16 format
  • UInt16 helpInfo

Field Documentation

UInt32 signature

Definition at line 975 of file HsPhoneEvent.h.

UInt32 notificationType

Definition at line 976 of file HsPhoneEvent.h.

UInt32 textOffset

Definition at line 978 of file HsPhoneEvent.h.

UInt16 format

See GSMSATEventInputFormatEnum

Definition at line 979 of file HsPhoneEvent.h.

UInt16 helpInfo

Definition at line 980 of file HsPhoneEvent.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:26 2008 for Palm API Guide


PhnSATEventGetInput Struct Reference

Detailed Description

Definition at line 997 of file HsPhoneEvent.h.

Data Fields

  • UInt32 signature
  • UInt32 notificationType
  • UInt32 textOffset
  • UInt16 format
  • UInt16 helpInfo
  • UInt16 echoMode
  • UInt16 minSize
  • UInt32 defaultOffset
  • UInt16 maxSize
  • UInt16 pad

Field Documentation

UInt32 signature

Definition at line 998 of file HsPhoneEvent.h.

UInt32 notificationType

Definition at line 999 of file HsPhoneEvent.h.

UInt32 textOffset

Definition at line 1001 of file HsPhoneEvent.h.

UInt16 format

See GSMSATEventInputFormatEnum

Definition at line 1002 of file HsPhoneEvent.h.

UInt16 helpInfo

Definition at line 1003 of file HsPhoneEvent.h.

UInt16 echoMode

Definition at line 1004 of file HsPhoneEvent.h.

UInt16 minSize

Definition at line 1005 of file HsPhoneEvent.h.

UInt32 defaultOffset

offset of default value string at end of cmd block (0 if none) <chg 05-13-2002 TRS> bug # 13829

Definition at line 1006 of file HsPhoneEvent.h.

UInt16 maxSize

Definition at line 1007 of file HsPhoneEvent.h.

UInt16 pad

Definition at line 1008 of file HsPhoneEvent.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:26 2008 for Palm API Guide


PhnSATEventHeader Struct Reference

Detailed Description

Definition at line 988 of file HsPhoneEvent.h.

Data Fields

  • UInt32 signature
  • UInt32 notificationType

Field Documentation

UInt32 signature

Definition at line 989 of file HsPhoneEvent.h.

UInt32 notificationType

Definition at line 990 of file HsPhoneEvent.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:26 2008 for Palm API Guide


PhnSATEventIdleModeText Struct Reference

Detailed Description

Definition at line 1110 of file HsPhoneEvent.h.

Data Fields

  • UInt32 signature
  • UInt32 notificationType
  • UInt32 alphaIdOffset

Field Documentation

UInt32 signature

Definition at line 1111 of file HsPhoneEvent.h.

UInt32 notificationType

Definition at line 1112 of file HsPhoneEvent.h.

UInt32 alphaIdOffset

Definition at line 1114 of file HsPhoneEvent.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:26 2008 for Palm API Guide


PhnSATEventLaunchBrowser Struct Reference

Detailed Description

Definition at line 1095 of file HsPhoneEvent.h.

Data Fields

  • UInt32 signature
  • UInt32 notificationType
  • UInt32 action
  • UInt32 urlOffset
  • UInt32 bearerOffset
  • UInt32 provOffset
  • UInt32 gatewayProxyOffset
  • UInt32 alphaIdOffset

Field Documentation

UInt32 signature

Definition at line 1096 of file HsPhoneEvent.h.

UInt32 notificationType

Definition at line 1097 of file HsPhoneEvent.h.

UInt32 action

Definition at line 1098 of file HsPhoneEvent.h.

UInt32 urlOffset

Definition at line 1099 of file HsPhoneEvent.h.

UInt32 bearerOffset

Definition at line 1100 of file HsPhoneEvent.h.

UInt32 provOffset

Definition at line 1101 of file HsPhoneEvent.h.

UInt32 gatewayProxyOffset

Definition at line 1102 of file HsPhoneEvent.h.

UInt32 alphaIdOffset

Definition at line 1103 of file HsPhoneEvent.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:26 2008 for Palm API Guide


PhnSATEventMenu Struct Reference

Collaboration diagram for PhnSATEventMenu:

[legend]

Detailed Description

Definition at line 1055 of file HsPhoneEvent.h.

Data Fields

  • UInt32 signature
  • UInt32 notificationType
  • UInt32 titleOffset
  • UInt32 defaultItem
  • UInt32 recordCount
  • PhnSATEventMenuRec record [1]

Field Documentation

UInt32 signature

Definition at line 1056 of file HsPhoneEvent.h.

UInt32 notificationType

Definition at line 1057 of file HsPhoneEvent.h.

UInt32 titleOffset

Definition at line 1059 of file HsPhoneEvent.h.

UInt32 defaultItem

only valid in submenu

Definition at line 1060 of file HsPhoneEvent.h.

UInt32 recordCount

Definition at line 1061 of file HsPhoneEvent.h.

PhnSATEventMenuRec record[1]

Definition at line 1062 of file HsPhoneEvent.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:26 2008 for Palm API Guide


PhnSATEventMenuRec Struct Reference

Detailed Description

Definition at line 1044 of file HsPhoneEvent.h.

Data Fields

  • UInt32 labelOffset
  • UInt32 features
  • UInt16 id
  • UInt16 nextAction

Field Documentation

UInt32 labelOffset

Definition at line 1045 of file HsPhoneEvent.h.

UInt32 features

Definition at line 1046 of file HsPhoneEvent.h.

UInt16 id

Definition at line 1047 of file HsPhoneEvent.h.

UInt16 nextAction

Definition at line 1048 of file HsPhoneEvent.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:27 2008 for Palm API Guide


PhnSATEventPlayTone Struct Reference

Detailed Description

Definition at line 1029 of file HsPhoneEvent.h.

Data Fields

  • UInt32 signature
  • UInt32 notificationType
  • UInt32 textOffset
  • UInt16 toneType
  • UInt16 timeUnit
  • UInt16 timeInterval
  • UInt16 pad

Field Documentation

UInt32 signature

Definition at line 1030 of file HsPhoneEvent.h.

UInt32 notificationType

Definition at line 1031 of file HsPhoneEvent.h.

UInt32 textOffset

Definition at line 1033 of file HsPhoneEvent.h.

UInt16 toneType

Definition at line 1034 of file HsPhoneEvent.h.

UInt16 timeUnit

valid only if timeInterval > 0

Definition at line 1035 of file HsPhoneEvent.h.

UInt16 timeInterval

Definition at line 1036 of file HsPhoneEvent.h.

UInt16 pad

Definition at line 1037 of file HsPhoneEvent.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:27 2008 for Palm API Guide


PhnSATEventRefresh Struct Reference

Detailed Description

Definition at line 1082 of file HsPhoneEvent.h.

Data Fields

  • UInt32 signature
  • UInt32 notificationType
  • UInt32 EFList
  • UInt16 refreshType
  • UInt16 pad

Field Documentation

UInt32 signature

Definition at line 1083 of file HsPhoneEvent.h.

UInt32 notificationType

Definition at line 1084 of file HsPhoneEvent.h.

UInt32 EFList

This is a bitmap of the efs to be refreshed

Definition at line 1085 of file HsPhoneEvent.h.

UInt16 refreshType

Definition at line 1086 of file HsPhoneEvent.h.

UInt16 pad

Definition at line 1087 of file HsPhoneEvent.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:27 2008 for Palm API Guide


PhnSATEventRunAT Struct Reference

Detailed Description

Definition at line 1121 of file HsPhoneEvent.h.

Data Fields

  • UInt32 signature
  • UInt32 notificationType
  • UInt32 alphaIdOffset

Field Documentation

UInt32 signature

Definition at line 1122 of file HsPhoneEvent.h.

UInt32 notificationType

Definition at line 1123 of file HsPhoneEvent.h.

UInt32 alphaIdOffset

Definition at line 1125 of file HsPhoneEvent.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:27 2008 for Palm API Guide


PhnSATEventSendDTMF Struct Reference

Detailed Description

Definition at line 1148 of file HsPhoneEvent.h.

Data Fields

  • UInt32 signature
  • UInt32 notificationType
  • UInt32 alphaIdOffset
  • UInt32 dtmfChar

Field Documentation

UInt32 signature

Definition at line 1149 of file HsPhoneEvent.h.

UInt32 notificationType

Definition at line 1150 of file HsPhoneEvent.h.

UInt32 alphaIdOffset

Definition at line 1152 of file HsPhoneEvent.h.

UInt32 dtmfChar

Definition at line 1153 of file HsPhoneEvent.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:27 2008 for Palm API Guide


PhnSATEventSendSMS Struct Reference

Detailed Description

Definition at line 1070 of file HsPhoneEvent.h.

Data Fields

  • UInt32 signature
  • UInt32 notificationType
  • UInt32 textOffset

Field Documentation

UInt32 signature

Definition at line 1071 of file HsPhoneEvent.h.

UInt32 notificationType

Definition at line 1072 of file HsPhoneEvent.h.

UInt32 textOffset

Definition at line 1074 of file HsPhoneEvent.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:27 2008 for Palm API Guide


PhnSATEventSetupCall Struct Reference

Detailed Description

Definition at line 1015 of file HsPhoneEvent.h.

Data Fields

  • UInt32 signature
  • UInt32 notificationType
  • UInt32 numberOffset
  • UInt32 promptOffset
  • UInt16 type
  • UInt16 callType

Field Documentation

UInt32 signature

Definition at line 1016 of file HsPhoneEvent.h.

UInt32 notificationType

Definition at line 1017 of file HsPhoneEvent.h.

UInt32 numberOffset

Definition at line 1019 of file HsPhoneEvent.h.

UInt32 promptOffset

Definition at line 1020 of file HsPhoneEvent.h.

UInt16 type

Definition at line 1021 of file HsPhoneEvent.h.

UInt16 callType

Definition at line 1022 of file HsPhoneEvent.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:27 2008 for Palm API Guide


PhnSATEventType Struct Reference

Detailed Description

Definition at line 952 of file HsPhoneEvent.h.

Data Fields

  • MemHandle dataH
  • UInt32 notificationType

Field Documentation

MemHandle dataH

Definition at line 953 of file HsPhoneEvent.h.

UInt32 notificationType

Definition at line 954 of file HsPhoneEvent.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:27 2008 for Palm API Guide


PhnSMSParams Struct Reference

Detailed Description

Struct that is sent when a new sms message event id - Unique id oldStatus - newStatus -

version - Version number of the struct size - Size of the struct msgType - Indicates if message should be discarded or replaced msgClass - Indicates msg class msgInd - True if msg contains an indicator msg indicator.store - True = store msg; False = may delete msg indicator.activate - True then activate indicator; False = deactivate indicator indicator.indType - Type of indicator to display trasactionID - timeStamp - Time in seconds serviceCenterNumber- Service Center Number senderNumber - Number of sender callbackAddress - CallBack number destPort - sourcePort -

Definition at line 738 of file HsPhoneEvent.h.

Data Fields

  • UInt32 id
  • UInt8 oldStatus
  • UInt8 newStatus
  • UInt16 version
  • UInt16 size
  • PhnSMSType msgType
  • PhnSMSClass msgClass
  • Boolean moveRequested
  • Boolean msgInd
  • struct {
    • Boolean store
    • Boolean activate
    • PhnMsgBoxType indType
  • } indicator
  • UInt8 trasactionID
  • UInt32 timeStamp
  • char serviceCenterNumber [kMaxPhoneNumberLen+1]
  • char senderNumber [kMaxPhoneNumberLen+1]
  • char callbackAddress [kMaxPhoneNumberLen+1]
  • Int32 destPort
  • Int32 sourcePort
  • UInt16 networkMsgId
  • UInt8 priority
  • UInt8 privacy

Field Documentation

UInt32 id

Definition at line 740 of file HsPhoneEvent.h.

UInt8 oldStatus

Definition at line 741 of file HsPhoneEvent.h.

UInt8 newStatus

Definition at line 742 of file HsPhoneEvent.h.

UInt16 version

Definition at line 745 of file HsPhoneEvent.h.

UInt16 size

Definition at line 746 of file HsPhoneEvent.h.

PhnSMSType msgType

Definition at line 747 of file HsPhoneEvent.h.

PhnSMSClass msgClass

Definition at line 748 of file HsPhoneEvent.h.

Boolean moveRequested

Definition at line 749 of file HsPhoneEvent.h.

Boolean msgInd

Definition at line 750 of file HsPhoneEvent.h.

Boolean store

Definition at line 752 of file HsPhoneEvent.h.

Boolean activate

Definition at line 753 of file HsPhoneEvent.h.

PhnMsgBoxType indType

Definition at line 754 of file HsPhoneEvent.h.

struct { ... } indicator

UInt8 trasactionID

Definition at line 757 of file HsPhoneEvent.h.

UInt32 timeStamp

Definition at line 758 of file HsPhoneEvent.h.

char serviceCenterNumber[kMaxPhoneNumberLen+1]

Definition at line 760 of file HsPhoneEvent.h.

char senderNumber[kMaxPhoneNumberLen+1]

Definition at line 761 of file HsPhoneEvent.h.

char callbackAddress[kMaxPhoneNumberLen+1]

Definition at line 762 of file HsPhoneEvent.h.

Int32 destPort

Definition at line 764 of file HsPhoneEvent.h.

Int32 sourcePort

Definition at line 765 of file HsPhoneEvent.h.

UInt16 networkMsgId

Definition at line 767 of file HsPhoneEvent.h.

UInt8 priority

Definition at line 768 of file HsPhoneEvent.h.

UInt8 privacy

Definition at line 769 of file HsPhoneEvent.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:27 2008 for Palm API Guide


PhnSMSPrefType Struct Reference

Detailed Description

CDMA SMS Preference ?

Definition at line 245 of file HsPhoneSMSTypes.h.

Data Fields

  • Boolean audioAlertEnable
  • Boolean confirmDeletion

Field Documentation

Boolean audioAlertEnable

Definition at line 247 of file HsPhoneSMSTypes.h.

Boolean confirmDeletion

Definition at line 248 of file HsPhoneSMSTypes.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:27 2008 for Palm API Guide


PhnSubscriberAddrInfo Struct Reference

Detailed Description

Definition at line 648 of file HsPhoneEvent.h.

Data Fields

  • PhnAddressHandle caller
  • PhoneServiceClassType service
  • Int16 lineNumber

Field Documentation

PhnAddressHandle caller

Definition at line 650 of file HsPhoneEvent.h.

PhoneServiceClassType service

Definition at line 651 of file HsPhoneEvent.h.

Int16 lineNumber

Definition at line 652 of file HsPhoneEvent.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:27 2008 for Palm API Guide


PhnUSSDEventType Struct Reference

Detailed Description

Definition at line 944 of file HsPhoneEvent.h.

Data Fields

  • long result
  • CharPtr string

Field Documentation

long result

Definition at line 945 of file HsPhoneEvent.h.

CharPtr string

Definition at line 946 of file HsPhoneEvent.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:27 2008 for Palm API Guide


PhoneAppLaunchCmdCallerIDLookupType Struct Reference

Detailed Description

Contains data used by phoneAppLaunchCmdCallerIDLookup

Definition at line 589 of file HsAppLaunchCmd.h.

Data Fields

  • Char * numberP
  • Char * nameP

Field Documentation

Char* numberP

the view type to display be applied; if zero -- don't apply.

Definition at line 591 of file HsAppLaunchCmd.h.

Char* nameP

if not NULL, the view manager will pass this data block to the view once the view has been opened

Definition at line 592 of file HsAppLaunchCmd.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:27 2008 for Palm API Guide


PhoneAppLaunchCmdDialType Struct Reference

Detailed Description

Contains the data used by Phone app launch command dial.

Definition at line 470 of file HsAppLaunchCmd.h.

Data Fields

  • UInt8 version
  • Boolean confirm
  • Char * name
  • Char * number
  • Char * extraDigits
  • UInt32 failLaunchCreator
  • UInt16 failLaunchCode
  • void * failLaunchParams
  • UInt16 dialMethod

Field Documentation

UInt8 version

version number, set to one

Definition at line 472 of file HsAppLaunchCmd.h.

Boolean confirm

confirm before dialing.

Definition at line 473 of file HsAppLaunchCmd.h.

Char* name

optional

Definition at line 474 of file HsAppLaunchCmd.h.

Char* number

optional

Definition at line 475 of file HsAppLaunchCmd.h.

Char* extraDigits

optional

Definition at line 476 of file HsAppLaunchCmd.h.

UInt32 failLaunchCreator

app to relaunch if dialling fails

Definition at line 478 of file HsAppLaunchCmd.h.

UInt16 failLaunchCode

launch code to use when relaunching

Definition at line 479 of file HsAppLaunchCmd.h.

void* failLaunchParams

params to use when relaunching

Definition at line 480 of file HsAppLaunchCmd.h.

UInt16 dialMethod

Method to use to dial the phone number See PhoneAppDialMethodEnum.

Definition at line 481 of file HsAppLaunchCmd.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:28 2008 for Palm API Guide


PhoneAppLaunchCmdGetALSLineNumberType Struct Reference

Detailed Description

Data structure that goes with phoneAppLaunchCmdGetALSLineNumber launch cmd

Definition at line 511 of file HsAppLaunchCmd.h.

Data Fields

  • UInt8 lineNumber

Field Documentation

UInt8 lineNumber

ALS Line number

Definition at line 513 of file HsAppLaunchCmd.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:28 2008 for Palm API Guide


PhoneAppLaunchCmdGetDialPrefFlagType Struct Reference

Detailed Description

Contains data used by PhoneAppLaunchCmdGetDialPref

Definition at line 504 of file HsAppLaunchCmd.h.

Data Fields

  • Boolean displayDialPrefs

Field Documentation

Boolean displayDialPrefs

If true Dial Preferences option is made available

Definition at line 506 of file HsAppLaunchCmd.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:28 2008 for Palm API Guide


PhoneAppLaunchCmdSendDTMFToneType Struct Reference

Detailed Description

Contains data used by PhoneAppLaunchCmdSendDTMFTone.

Definition at line 496 of file HsAppLaunchCmd.h.

Data Fields

  • char tone
  • Boolean repeated

Field Documentation

char tone

the key that was pressed to trigger the launch cmd

Definition at line 498 of file HsAppLaunchCmd.h.

Boolean repeated

true if the character was on autoRepeat

Definition at line 499 of file HsAppLaunchCmd.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:28 2008 for Palm API Guide


PhoneAppLaunchCmdSetWallpaperType Struct Reference

Collaboration diagram for PhoneAppLaunchCmdSetWallpaperType:

[legend]

Detailed Description

Contains data used by PhoneAppLaunchCmdSetWallpaper.

Definition at line 487 of file HsAppLaunchCmd.h.

Data Fields

  • UInt32 wallpaperUID
  • PalmPhotoFileLocation wallpaperLocation

Field Documentation

UInt32 wallpaperUID

OBSOLETE

Definition at line 489 of file HsAppLaunchCmd.h.

PalmPhotoFileLocation wallpaperLocation

path to image

Definition at line 491 of file HsAppLaunchCmd.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:28 2008 for Palm API Guide


PmBroadcastNewMsgCountNotifyParamType Struct Reference

Detailed Description

Param structure for pmNotifyBroadcastNewMsgCount notifications.

Definition at line 53 of file HsHelper.h.

Data Fields

  • UInt32 helperServiceClass
  • UInt16 msgCount

Field Documentation

UInt32 helperServiceClass

Definition at line 55 of file HsHelper.h.

UInt16 msgCount

Definition at line 56 of file HsHelper.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:28 2008 for Palm API Guide


PmConnectorNotifyDataType Struct Reference

Detailed Description

Container for the notification details.

Definition at line 142 of file PmConnectorLibCommon.h.

Data Fields

  • UInt32 serialPortId
  • UInt32 deviceClass
  • UInt32 athenaDeviceCreatorCode
  • UInt32 reserved1
  • UInt32 reserved2

Field Documentation

UInt32 serialPortId

Definition at line 143 of file PmConnectorLibCommon.h.

UInt32 deviceClass

Definition at line 144 of file PmConnectorLibCommon.h.

UInt32 athenaDeviceCreatorCode

Definition at line 145 of file PmConnectorLibCommon.h.

UInt32 reserved1

Definition at line 146 of file PmConnectorLibCommon.h.

UInt32 reserved2

Definition at line 147 of file PmConnectorLibCommon.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:28 2008 for Palm API Guide


PmGetNewMsgCountNotifyParamType Struct Reference

Detailed Description

Param structure for pmNotifyGetNewMsgCountFromHelper notifications.

Definition at line 43 of file HsHelper.h.

Data Fields

  • UInt32 helperServiceClass

Field Documentation

UInt32 helperServiceClass

Definition at line 45 of file HsHelper.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:28 2008 for Palm API Guide


PmSysGadgetBbutMappingType Struct Reference

Detailed Description

This is the structure of a single big button mapping...

Definition at line 120 of file PmSysGadgetLibCommon.h.

Data Fields

  • UInt8 flags
  • UInt8 font
  • UInt16 gadgetID
  • UInt16 bitmapID
  • UInt16 stringID

Field Documentation

UInt8 flags

Definition at line 122 of file PmSysGadgetLibCommon.h.

UInt8 font

Definition at line 123 of file PmSysGadgetLibCommon.h.

UInt16 gadgetID

Definition at line 125 of file PmSysGadgetLibCommon.h.

UInt16 bitmapID

Definition at line 127 of file PmSysGadgetLibCommon.h.

UInt16 stringID

Definition at line 128 of file PmSysGadgetLibCommon.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:28 2008 for Palm API Guide


PmSysGadgetBbutResourceType Struct Reference

Collaboration diagram for PmSysGadgetBbutResourceType:

[legend]

Detailed Description

This is the structure of a big button resource...

Definition at line 135 of file PmSysGadgetLibCommon.h.

Data Fields

  • UInt16 version
  • PmSysGadgetBbutMappingType mapArr [0]

Field Documentation

UInt16 version

Definition at line 137 of file PmSysGadgetLibCommon.h.

PmSysGadgetBbutMappingType mapArr[0]

Definition at line 138 of file PmSysGadgetLibCommon.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:28 2008 for Palm API Guide


PmSysGadgetPttNotificationType Struct Reference

Detailed Description

This is the structure used by the PTT notification event.

Definition at line 145 of file PmSysGadgetLibCommon.h.

Data Fields

  • UInt32 creatorId
  • UInt16 uBitmapId
  • UInt16 uStatus

Field Documentation

UInt32 creatorId

Definition at line 147 of file PmSysGadgetLibCommon.h.

UInt16 uBitmapId

Definition at line 148 of file PmSysGadgetLibCommon.h.

UInt16 uStatus

Definition at line 149 of file PmSysGadgetLibCommon.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:28 2008 for Palm API Guide


PosType Struct Reference

Collaboration diagram for PosType:

[legend]

Detailed Description

Container to store longitude and latitude of a specific location

Definition at line 263 of file LocsLibCommon.h.

Data Fields

  • Coordinate latitude
  • Coordinate longitude

Field Documentation

Coordinate latitude

Definition at line 264 of file LocsLibCommon.h.

Coordinate longitude

Definition at line 265 of file LocsLibCommon.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:28 2008 for Palm API Guide


PowerPanelAppPrefs Struct Reference

Detailed Description

App Preferences

Definition at line 48 of file Slider.h.

Data Fields

  • UInt8 autoOnWhenOpened
  • UInt8 autoOffWhenClosed

Field Documentation

UInt8 autoOnWhenOpened

non-zero if the device should auto-on when opened

Definition at line 51 of file Slider.h.

UInt8 autoOffWhenClosed

non-zero if the device should auto-off when closed

Definition at line 53 of file Slider.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:28 2008 for Palm API Guide


SmsHeader Struct Reference

Detailed Description

Definition at line 304 of file HsPhoneSMSTypes.h.

Data Fields

  • UInt32 owner
  • SMSMessageType type
  • SMSMessageStatus status
  • UInt32 date
  • UInt32 flags
  • UInt8 validity
  • UInt8 segments
  • UInt16 size [1]

Field Documentation

UInt32 owner

application owning this message

Definition at line 305 of file HsPhoneSMSTypes.h.

SMSMessageType type

message type

Definition at line 306 of file HsPhoneSMSTypes.h.

SMSMessageStatus status

message status

Definition at line 307 of file HsPhoneSMSTypes.h.

UInt32 date

date of sending or receipt

Definition at line 308 of file HsPhoneSMSTypes.h.

UInt32 flags

miscellaneous flags

Definition at line 309 of file HsPhoneSMSTypes.h.

UInt8 validity

validity period

Definition at line 310 of file HsPhoneSMSTypes.h.

UInt8 segments

number of segments (incoming message) Size of field Addresses. If there is segmentation information for a message this field contains also the sizes of the parts. The array is therefore a variable-size array.

Definition at line 311 of file HsPhoneSMSTypes.h.

UInt16 size[1]

Definition at line 315 of file HsPhoneSMSTypes.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:28 2008 for Palm API Guide


SMSSendOptions Struct Reference

Detailed Description

Definition at line 295 of file HsPhoneSMSTypes.h.

Data Fields

  • Boolean freeReply
  • Boolean statusReport
  • unsigned char validity

Field Documentation

Boolean freeReply

Definition at line 296 of file HsPhoneSMSTypes.h.

Boolean statusReport

Definition at line 297 of file HsPhoneSMSTypes.h.

unsigned char validity

Definition at line 298 of file HsPhoneSMSTypes.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:28 2008 for Palm API Guide


SndCodecCustomControlType Struct Reference

Detailed Description

Holds Custom Control type information for the Extended Sound Manager.

This structure is used to set/get values specific to a codec. Note that if this custom control comes from a 68K app, it's the responsibility of the 68K app to flip and align the fields of the structure correctly. The fields are defined as being in little-endian format.

Definition at line 75 of file PalmSoundCustomCtrl.h.

Data Fields

  • UInt32 apiCreator
  • UInt32 apiSelector
  • void * valueP
  • UInt16 * valueLenP

Field Documentation

UInt32 apiCreator

Codec creator. (codecDriverIMAADPCM...)

Definition at line 76 of file PalmSoundCustomCtrl.h.

UInt32 apiSelector

Codec selector. (codecIMAADPCMSetBlockSize...)

Definition at line 77 of file PalmSoundCustomCtrl.h.

void* valueP

Pointer to the parameters to be passed to the codec.

Definition at line 78 of file PalmSoundCustomCtrl.h.

UInt16* valueLenP

Size of the parameters to be passed to the codec.

Definition at line 79 of file PalmSoundCustomCtrl.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:29 2008 for Palm API Guide


SoundPreference Struct Reference

Collaboration diagram for SoundPreference:

[legend]

Detailed Description

Structure containing all the Sound Preference data.

Definition at line 300 of file TonesLibTypes.h.

Data Fields

  • SoundPreference::_tonePrefs tonePrefs
  • ToneVolume soundOnVolume
  • Boolean soundOnVibrate
  • Boolean soundOffVibrate

Data Structures

  • union _tonePrefs

Field Documentation

union SoundPreference::_tonePrefs tonePrefs

union of various sound preferences Holds data for various Sound Prefs

ToneVolume soundOnVolume

Volume of tone

Definition at line 312 of file TonesLibTypes.h.

Boolean soundOnVibrate

No definition.

Definition at line 313 of file TonesLibTypes.h.

Boolean soundOffVibrate

No definition.

Definition at line 314 of file TonesLibTypes.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:29 2008 for Palm API Guide


SoundPreference::_tonePrefs

SoundPreference::_tonePrefs Union Reference

Collaboration diagram for SoundPreference::_tonePrefs:

[legend]

Detailed Description

union of various sound preferences

Definition at line 302 of file TonesLibTypes.h.

Data Fields

  • SoundPreferenceIM imSoundPrefs
  • SoundPreferencePhone phoneSoundPrefs
  • SoundPreferenceEmail emailSoundPrefs
  • SoundPreferenceCalendar calendarSoundPrefs
  • SoundPreferenceSMS smsSoundPrefs
  • SoundPreferenceMMS mmsSoundPrefs
  • SoundPreferenceNetworkSounds networkSoundPrefs

Field Documentation

SoundPreferenceIM imSoundPrefs

No definition.

Definition at line 304 of file TonesLibTypes.h.

SoundPreferencePhone phoneSoundPrefs

No definition.

Definition at line 305 of file TonesLibTypes.h.

SoundPreferenceEmail emailSoundPrefs

No definition.

Definition at line 306 of file TonesLibTypes.h.

SoundPreferenceCalendar calendarSoundPrefs

No definition.

Definition at line 307 of file TonesLibTypes.h.

SoundPreferenceSMS smsSoundPrefs

No definition.

Definition at line 308 of file TonesLibTypes.h.

SoundPreferenceMMS mmsSoundPrefs

No definition.

Definition at line 309 of file TonesLibTypes.h.

SoundPreferenceNetworkSounds networkSoundPrefs

No definition.

Definition at line 310 of file TonesLibTypes.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:29 2008 for Palm API Guide


SoundPreferenceCalendar Struct Reference

Collaboration diagram for SoundPreferenceCalendar:

[legend]

Detailed Description

Structure for Calendar Sound Pref.

Definition at line 260 of file TonesLibTypes.h.

Data Fields

  • ToneIdentifier alarmTone
  • ToneIdentifier reminderTone
  • TonePlayNumberTimes playSoundTimes
  • TonePlayNumberTimes repeatAlarmTimes
  • ToneRepeatInterval repeatInterval
  • UInt16 presetTime
  • ToneTimeUnit presetTimeUnit
  • Boolean alarmPreset

Field Documentation

ToneIdentifier alarmTone

Tone used for alarm

Definition at line 261 of file TonesLibTypes.h.

ToneIdentifier reminderTone

Tone used for event reminder

Definition at line 262 of file TonesLibTypes.h.

TonePlayNumberTimes playSoundTimes

Number of times tone should be played

Definition at line 263 of file TonesLibTypes.h.

TonePlayNumberTimes repeatAlarmTimes

Number of time alarm should be repeated

Definition at line 264 of file TonesLibTypes.h.

ToneRepeatInterval repeatInterval

Alarm repeat interval

Definition at line 265 of file TonesLibTypes.h.

UInt16 presetTime

Alarm preset time

Definition at line 266 of file TonesLibTypes.h.

ToneTimeUnit presetTimeUnit

Alarm preset time unit (minute, hour, day)

Definition at line 267 of file TonesLibTypes.h.

Boolean alarmPreset

Preset alarm if true

Definition at line 268 of file TonesLibTypes.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:29 2008 for Palm API Guide


SoundPreferenceEmail Struct Reference

Collaboration diagram for SoundPreferenceEmail:

[legend]

Detailed Description

Structure for Email Sound Pref.

Definition at line 252 of file TonesLibTypes.h.

Data Fields

  • ToneIdentifier alertTone
  • Boolean newMailAlert

Field Documentation

ToneIdentifier alertTone

Tone used for new email alert

Definition at line 253 of file TonesLibTypes.h.

Boolean newMailAlert

Play tone if true

Definition at line 254 of file TonesLibTypes.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:30 2008 for Palm API Guide


SoundPreferenceIM Struct Reference

Collaboration diagram for SoundPreferenceIM:

[legend]

Detailed Description

Structure for IM Sound Pref.

Definition at line 231 of file TonesLibTypes.h.

Data Fields

  • ToneIdentifier chatTone
  • ToneIdentifier messageTone

Field Documentation

ToneIdentifier chatTone

Tone used for chatting

Definition at line 233 of file TonesLibTypes.h.

ToneIdentifier messageTone

Tone used for messaging

Definition at line 234 of file TonesLibTypes.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:30 2008 for Palm API Guide


SoundPreferenceMMS Struct Reference

Collaboration diagram for SoundPreferenceMMS:

[legend]

Detailed Description

Structure for MMS Sound Pref.

Definition at line 284 of file TonesLibTypes.h.

Data Fields

  • ToneIdentifier messageTone

Field Documentation

ToneIdentifier messageTone

Tone used when MMS arrives

Definition at line 285 of file TonesLibTypes.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:30 2008 for Palm API Guide


SoundPreferenceNetworkSounds Struct Reference

Detailed Description

Structure for network related sounds.

Definition at line 291 of file TonesLibTypes.h.

Data Fields

  • Boolean signalFadedTone
  • Boolean eriStatusTone

Field Documentation

Boolean signalFadedTone

Definition at line 292 of file TonesLibTypes.h.

Boolean eriStatusTone

Definition at line 293 of file TonesLibTypes.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:30 2008 for Palm API Guide


SoundPreferencePhone Struct Reference

Collaboration diagram for SoundPreferencePhone:

[legend]

Detailed Description

Structure for Phone Sound Pref.

Definition at line 241 of file TonesLibTypes.h.

Data Fields

  • ToneIdentifier unknownCallerTone
  • ToneIdentifier knownCallerTone
  • ToneIdentifier roamingTone
  • ToneIdentifier voicemailTone
  • Boolean serviceTone

Field Documentation

ToneIdentifier unknownCallerTone

Tone used when caller is unknown

Definition at line 242 of file TonesLibTypes.h.

ToneIdentifier knownCallerTone

Tone used when caller is known

Definition at line 243 of file TonesLibTypes.h.

ToneIdentifier roamingTone

Tone used when roaming

Definition at line 244 of file TonesLibTypes.h.

ToneIdentifier voicemailTone

Tone used for incoming voicemail

Definition at line 245 of file TonesLibTypes.h.

Boolean serviceTone

No definition.

Definition at line 246 of file TonesLibTypes.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:30 2008 for Palm API Guide


SoundPreferenceSMS Struct Reference

Collaboration diagram for SoundPreferenceSMS:

[legend]

Detailed Description

Structure for SMS Sound Pref.

Definition at line 274 of file TonesLibTypes.h.

Data Fields

  • ToneIdentifier messageTone
  • Boolean privacy
  • Boolean msgAlert
  • Boolean rcptAlert

Field Documentation

ToneIdentifier messageTone

Tone used for SMS

Definition at line 275 of file TonesLibTypes.h.

Boolean privacy

No definition.

Definition at line 276 of file TonesLibTypes.h.

Boolean msgAlert

If true, alert when new SMS arrives

Definition at line 277 of file TonesLibTypes.h.

Boolean rcptAlert

If true, alert when recipient receives SMS

Definition at line 278 of file TonesLibTypes.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:30 2008 for Palm API Guide


SoundPrefsLaunchCmdParamType Struct Reference

Detailed Description

Contains data used by SoundPrefsLaunchCmd.

Definition at line 644 of file HsAppLaunchCmd.h.

Data Fields

  • SoundPrefsView launchView

Field Documentation

SoundPrefsView launchView

Launch to the tones/volume view.

Definition at line 646 of file HsAppLaunchCmd.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:30 2008 for Palm API Guide


SysVPPILaunchCmdClearPWCacheType Struct Reference

Detailed Description

Structure used by the VPN Panel to clear the password cache.

Definition at line 128 of file PalmVPPI.h.

Data Fields

  • Err errOut

Field Documentation

Err errOut

Error code.

Definition at line 130 of file PalmVPPI.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:30 2008 for Palm API Guide


SysVPPILaunchCmdDeleteAccountType Struct Reference

Collaboration diagram for SysVPPILaunchCmdDeleteAccountType:

[legend]

Detailed Description

Structure used by the VPN Panel to delete an account.

Definition at line 71 of file PalmVPPI.h.

Data Fields

  • VPNAccountType account
  • Err err

Field Documentation

VPNAccountType account

Account to delete.

Definition at line 73 of file PalmVPPI.h.

Err err

Error code.

Definition at line 74 of file PalmVPPI.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:30 2008 for Palm API Guide


SysVPPILaunchCmdEditAccountType Struct Reference

Collaboration diagram for SysVPPILaunchCmdEditAccountType:

[legend]

Detailed Description

Structure used by the VPN Panel to edit an account.

Definition at line 57 of file PalmVPPI.h.

Data Fields

  • Boolean useWizardUI
  • VPNAccountType account
  • Err err
  • Boolean useSavedAccount
  • Boolean dirtyBit

Field Documentation

Boolean useWizardUI

Whether to show Previous & Done buttons instead of OK & Cancel buttons.

Definition at line 59 of file PalmVPPI.h.

VPNAccountType account

Account edited or created.

Definition at line 60 of file PalmVPPI.h.

Err err

Return error.

Definition at line 61 of file PalmVPPI.h.

Boolean useSavedAccount

Whether the account information is temporary (for saved state) or permanent.

Definition at line 62 of file PalmVPPI.h.

Boolean dirtyBit

Whether any account settings have been changed.

Definition at line 63 of file PalmVPPI.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:31 2008 for Palm API Guide


SysVPPILaunchCmdErrorDialogType Struct Reference

Detailed Description

Structure used by the VPN Panel to show the error dialog.

Definition at line 117 of file PalmVPPI.h.

Data Fields

  • UInt32 error
  • Err errOut

Field Documentation

UInt32 error

Error value sent by the VPN Shim (in).

Definition at line 119 of file PalmVPPI.h.

Err errOut

Error code (out).

Definition at line 120 of file PalmVPPI.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:31 2008 for Palm API Guide


SysVPPILaunchCmdGetAccountsType Struct Reference

Collaboration diagram for SysVPPILaunchCmdGetAccountsType:

[legend]

Detailed Description

Structure used by the VPN Panel to query the account from a VPPI.

Definition at line 45 of file PalmVPPI.h.

Data Fields

  • UInt32 numAccounts
  • VPNAccountType * accounts
  • Err err

Field Documentation

UInt32 numAccounts

Number of accounts.

Definition at line 47 of file PalmVPPI.h.

VPNAccountType* accounts

Array of accounts.

Definition at line 48 of file PalmVPPI.h.

Err err

Error set by the VPPI before returning the account list.

Definition at line 49 of file PalmVPPI.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:31 2008 for Palm API Guide


SysVPPILaunchCmdProgressPaintType Struct Reference

Detailed Description

Structure used by the VPN Panel to show the progess dialog.

Definition at line 105 of file PalmVPPI.h.

Data Fields

  • UInt32 stage
  • RectangleType clientRect
  • Err errOut

Field Documentation

UInt32 stage

Stage calue sent by the VPN Shim to the VPPI (in).

Definition at line 107 of file PalmVPPI.h.

RectangleType clientRect

Rectangle in which the progress dialog box is displayed (in).

Definition at line 108 of file PalmVPPI.h.

Err errOut

Error code (out).

Definition at line 109 of file PalmVPPI.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:31 2008 for Palm API Guide


SysVPPILaunchCmdPromptAndConfigureType Struct Reference

Detailed Description

Structure used by the VPN Panel to request the VPPI to display a dialog.

Definition at line 93 of file PalmVPPI.h.

Data Fields

  • UInt32 origCreator
  • UInt32 origInstance
  • Err errOut

Field Documentation

UInt32 origCreator

Creator that launched the prompt dialog (in).

Definition at line 95 of file PalmVPPI.h.

UInt32 origInstance

Instance that laucnhed the prompt dialog (in).

Definition at line 96 of file PalmVPPI.h.

Err errOut

Error code (out).

Definition at line 97 of file PalmVPPI.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:31 2008 for Palm API Guide


SysVPPILaunchCmdSetCurrentAccountType Struct Reference

Collaboration diagram for SysVPPILaunchCmdSetCurrentAccountType:

[legend]

Detailed Description

Structure used by the VPN Panel to set the current account.

Definition at line 82 of file PalmVPPI.h.

Data Fields

  • VPNAccountType account
  • Err err

Field Documentation

VPNAccountType account

Account to set as current account.

Definition at line 84 of file PalmVPPI.h.

Err err

Error code.

Definition at line 85 of file PalmVPPI.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:31 2008 for Palm API Guide


SysVPPILaunchCmdWillPWPromptType Struct Reference

Detailed Description

Structure used by the VPN Panel to determine is the VPPI will prompt for password.

Definition at line 138 of file PalmVPPI.h.

Data Fields

  • UInt32 secsFromNow
  • Err errOut

Field Documentation

UInt32 secsFromNow

Seconds from now at which the VPPI will prompt for password (in).

Definition at line 140 of file PalmVPPI.h.

Err errOut

Error code (out).

Definition at line 141 of file PalmVPPI.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:31 2008 for Palm API Guide


SysWPPILaunchCmdClearPWCache Struct Reference

Detailed Description

Definition at line 210 of file PalmWPPI.h.

Data Fields

  • Err errOut

Field Documentation

Err errOut

Definition at line 212 of file PalmWPPI.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:31 2008 for Palm API Guide


SysWPPILaunchCmdErrorDialogType Struct Reference

Detailed Description

Definition at line 198 of file PalmWPPI.h.

Data Fields

  • UInt32 error
  • Err errOut

Field Documentation

UInt32 error

Definition at line 200 of file PalmWPPI.h.

Err errOut

Definition at line 201 of file PalmWPPI.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:31 2008 for Palm API Guide


SysWPPILaunchCmdGetAuthenticationMethodsType Struct Reference

Collaboration diagram for SysWPPILaunchCmdGetAuthenticationMethodsType:

[legend]

Detailed Description

Definition at line 66 of file PalmWPPI.h.

Data Fields

  • UInt32 numAuthenticationMethods
  • WiFiAuthenticationMethodType * authenticationMethods
  • Err err

Field Documentation

UInt32 numAuthenticationMethods

Definition at line 68 of file PalmWPPI.h.

WiFiAuthenticationMethodType* authenticationMethods

Definition at line 69 of file PalmWPPI.h.

Err err

Definition at line 70 of file PalmWPPI.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:31 2008 for Palm API Guide


SysWPPILaunchCmdGetDescriptionType Struct Reference

Detailed Description

Definition at line 162 of file PalmWPPI.h.

Data Fields

  • UInt32 authenticationMethodID
  • Char * description
  • UInt32 descriptionSize
  • Err err

Field Documentation

UInt32 authenticationMethodID

Definition at line 164 of file PalmWPPI.h.

Char* description

Definition at line 165 of file PalmWPPI.h.

UInt32 descriptionSize

Definition at line 166 of file PalmWPPI.h.

Err err

Definition at line 167 of file PalmWPPI.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:31 2008 for Palm API Guide


SysWPPILaunchCmdPromptAndConfigureType Struct Reference

Detailed Description

Definition at line 185 of file PalmWPPI.h.

Data Fields

  • UInt32 ifCreator
  • UInt32 ifInstance
  • Err errOut

Field Documentation

UInt32 ifCreator

Definition at line 187 of file PalmWPPI.h.

UInt32 ifInstance

Definition at line 188 of file PalmWPPI.h.

Err errOut

Definition at line 189 of file PalmWPPI.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:31 2008 for Palm API Guide


SysWPPILaunchCmdType Struct Reference

Detailed Description

Definition at line 105 of file PalmWPPI.h.

Data Fields

  • UInt32 authenticationMethodID
  • UInt32 cookie
  • Boolean save
  • Boolean cancel
  • Boolean assigned
  • Char credentialsLabel [kMaxWiFiCredentialsLabelLength+1]
  • Char credentialsSelectorTrigger [kMaxWiFiCredentialsSelectorTriggerLength+1]
  • Err err

Field Documentation

UInt32 authenticationMethodID

a 32-bit ID used by the WPPI to identify the authentication method

Definition at line 107 of file PalmWPPI.h.

UInt32 cookie

a unique ID or other identifier used to look up the credentials

Definition at line 108 of file PalmWPPI.h.

Boolean save

whether to save the user's changes (only for sysWPPILaunchCmdClose)

Definition at line 109 of file PalmWPPI.h.

Boolean cancel

whether the user tapped Cancel (only for sysWPPILaunchCmdDialog)

Definition at line 110 of file PalmWPPI.h.

Boolean assigned

whether credentials are considered assigned for validation purposes

Definition at line 111 of file PalmWPPI.h.

Char credentialsLabel[kMaxWiFiCredentialsLabelLength+1]

the label to use for the credentials line in the Edit Network dialog

Definition at line 112 of file PalmWPPI.h.

Char credentialsSelectorTrigger[kMaxWiFiCredentialsSelectorTriggerLength+1]

the selector trigger label indicating whether credentials have been assigned

Definition at line 113 of file PalmWPPI.h.

Err err

non-zero on entry; set by WPPI to indicate success or failure

Definition at line 114 of file PalmWPPI.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:31 2008 for Palm API Guide


tagIOTANotificationEventType Struct Reference

Detailed Description

Structure passed to the callbacks registered for incoming IOTA notifications

Definition at line 318 of file HsPhoneIOTATypes.h.

Data Fields

  • UInt16 version
  • void * headerP
  • UInt8 headerLen
  • void * dataP
  • UInt8 dataLen
  • UInt32 msgID
  • UInt32 datetime
  • Int32 reserved2
  • Int32 reserved3

Field Documentation

UInt16 version

version number to provide future backwards compatibility

Definition at line 320 of file HsPhoneIOTATypes.h.

void* headerP

pointer to raw header

Definition at line 322 of file HsPhoneIOTATypes.h.

UInt8 headerLen

length of headerP

Definition at line 323 of file HsPhoneIOTATypes.h.

void* dataP

pointer to data body

Definition at line 324 of file HsPhoneIOTATypes.h.

UInt8 dataLen

length of dataP

Definition at line 325 of file HsPhoneIOTATypes.h.

UInt32 msgID

SMS related fields ID into the SMS database to reference this message this ID is not gauranteed to be valid once the notification callback returns. Users should make a copy of the msg if they want to work on it after the callback returns.

Definition at line 328 of file HsPhoneIOTATypes.h.

UInt32 datetime

date/time stamp

Definition at line 335 of file HsPhoneIOTATypes.h.

Int32 reserved2

reserved

Definition at line 336 of file HsPhoneIOTATypes.h.

Int32 reserved3

reserved

Definition at line 337 of file HsPhoneIOTATypes.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:32 2008 for Palm API Guide


tagSndFileStreamData Struct Reference

Detailed Description

Holds data about a sound file stream.

Definition at line 211 of file palmOneSndFileStream.h.

Data Fields

  • UInt16 streamFlags
  • UInt16 streamMode
  • UInt32 streamRefCon
  • UInt16 playbackCount
  • UInt16 streamComplete
  • UInt32 dataSize
  • UInt32 dataDuration
  • UInt32 customDataSize
  • UInt32 fileFormat
  • UInt32 sampleFormat
  • UInt32 sampleRate
  • UInt32 sampleType
  • UInt32 sampleWidth
  • UInt32 sampleBlockAlign
  • UInt32 maximumMilliseconds
  • UInt32 maximumBytes
  • UInt32 currentMillisecond
  • UInt32 lastByte
  • MemPtr customDataP

Field Documentation

UInt16 streamFlags

Flag for the sound file stream.

Definition at line 213 of file palmOneSndFileStream.h.

UInt16 streamMode

Use mode sndInput or sndOutput for sound file stream.

Definition at line 214 of file palmOneSndFileStream.h.

UInt32 streamRefCon

Reserved for third party use.

Definition at line 215 of file palmOneSndFileStream.h.

UInt16 playbackCount

How many times to play the sound. Values of 0 and 1 both cause the sound to be played back one time. Is decremented each time play back of the sound is restarted.

Definition at line 217 of file palmOneSndFileStream.h.

UInt16 streamComplete

Set to true when the stream has stopped because the playbackCount has been decremented to zero, maximumBytes is reached, or maximumMilliseconds is reached

Definition at line 221 of file palmOneSndFileStream.h.

UInt32 dataSize

Size of the audio data in bytes.

Definition at line 225 of file palmOneSndFileStream.h.

UInt32 dataDuration

Duration of the audio data in milliseconds.

Definition at line 226 of file palmOneSndFileStream.h.

UInt32 customDataSize

Size of custom data in bytes.

Definition at line 227 of file palmOneSndFileStream.h.

UInt32 fileFormat

Format of the sound file stream. For example, kSndFileFormatWAV.

Definition at line 229 of file palmOneSndFileStream.h.

UInt32 sampleFormat

Format of the soud sample. Example: palmCodecAudioIMA_ADPCM

Definition at line 230 of file palmOneSndFileStream.h.

UInt32 sampleRate

Sample rate of hte sound file in frames/sec. For example, 8000.

Definition at line 231 of file palmOneSndFileStream.h.

UInt32 sampleType

Type of the sound file. For example, sndInt16.

Definition at line 232 of file palmOneSndFileStream.h.

UInt32 sampleWidth

Whether the sound is stereo, mono, and so forth. For example, sndMono.

Definition at line 233 of file palmOneSndFileStream.h.

UInt32 sampleBlockAlign

Block alignment of the sound file. For example, 256 for IMA ADPCM.

Definition at line 234 of file palmOneSndFileStream.h.

UInt32 maximumMilliseconds

Maximum milliseconds of play back.

Definition at line 236 of file palmOneSndFileStream.h.

UInt32 maximumBytes

Maximum value for lastPlayedBytes.

Definition at line 237 of file palmOneSndFileStream.h.

UInt32 currentMillisecond

Current millisecond of audio.

Definition at line 239 of file palmOneSndFileStream.h.

UInt32 lastByte

Last byte played or recorded on channel,

Definition at line 240 of file palmOneSndFileStream.h.

MemPtr customDataP

Pointer to custom data.

Definition at line 242 of file palmOneSndFileStream.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:32 2008 for Palm API Guide


tagSndFileStreamFileSpec Struct Reference

Detailed Description

Descriptions of the stream file.

Used with SndFileStreamCreate()/SndFileStreamOpen()

Definition at line 261 of file palmOneSndFileStream.h.

Data Fields

  • UInt16 flags
  • UInt16 volRefNum
  • Char * fileNameP
  • UInt32 fileCreator
  • UInt32 fileType

Field Documentation

UInt16 flags

Set to kSndFileStreamFileSpecFlagVFS or kSndFileStreamFileSpecFlagFileStream

Definition at line 263 of file palmOneSndFileStream.h.

UInt16 volRefNum

The volume reference number returned from VFSVolumeEnumerate().

Definition at line 265 of file palmOneSndFileStream.h.

Char* fileNameP

Name of the stream file

Definition at line 267 of file palmOneSndFileStream.h.

UInt32 fileCreator

Creator ID of the stream file

Definition at line 269 of file palmOneSndFileStream.h.

UInt32 fileType

See File Stream Database Types

Definition at line 270 of file palmOneSndFileStream.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:32 2008 for Palm API Guide


tagSndFileStreamHsSoundCommandParam Struct Reference

Detailed Description

SndFileStreamDeviceControl param when cmd == hsSoundLibCreatorID.

Contains hsFormat/hsCmd pair to be used with PmSndStream() calls.

Definition at line 302 of file palmOneSndFileStream.h.

Data Fields

  • UInt16 hsFormat
  • UInt16 hsCmd

Field Documentation

UInt16 hsFormat

Definition at line 304 of file palmOneSndFileStream.h.

UInt16 hsCmd

Definition at line 305 of file palmOneSndFileStream.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:32 2008 for Palm API Guide


ToneIdentifier Struct Reference

Detailed Description

No definition.

Definition at line 212 of file TonesLibTypes.h.

Data Fields

  • UInt32 id
  • ToneType toneType

Field Documentation

UInt32 id

Tone ID

Definition at line 213 of file TonesLibTypes.h.

ToneType toneType

Tony Type (AMR, MIDI, etc).

See also:
ToneType

Definition at line 214 of file TonesLibTypes.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:32 2008 for Palm API Guide


ToneItemType Struct Reference

Collaboration diagram for ToneItemType:

[legend]

Detailed Description

Tone characteristics.

Definition at line 220 of file TonesLibTypes.h.

Data Fields

  • Char name [kMaxTonesNameSize]
  • ToneIdentifier identifier
  • Boolean protectedTone

Field Documentation

Char name[kMaxTonesNameSize]

Name of the ring tone.

Definition at line 222 of file TonesLibTypes.h.

ToneIdentifier identifier

Unique ID for the ring tone.

Definition at line 223 of file TonesLibTypes.h.

Boolean protectedTone

Whether Tone is protected and cannot be beamed or sent.

Definition at line 224 of file TonesLibTypes.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:32 2008 for Palm API Guide


UPNotificationEventType Struct Reference

Detailed Description

Structure passed to the callbacks registered for incoming UP notifications

Definition at line 1327 of file HsPhoneEvent.h.

Data Fields

  • UInt16 version
  • void * headerP
  • UInt8 headerLen
  • char UPData [UPDataSize+1]
  • UInt8 _filler100_
  • UInt32 msgID
  • UInt32 datetime
  • Int32 reserved2
  • Int32 reserved3

Field Documentation

UInt16 version

version number to provide future backwards compatibility

Definition at line 1329 of file HsPhoneEvent.h.

void* headerP

pointer to raw header

Definition at line 1331 of file HsPhoneEvent.h.

UInt8 headerLen

length of headerP

Definition at line 1332 of file HsPhoneEvent.h.

char UPData[UPDataSize+1]

Network wakeup fields stores the raw data

Definition at line 1335 of file HsPhoneEvent.h.

UInt8 _filler100_

Definition at line 1336 of file HsPhoneEvent.h.

UInt32 msgID

SMS related fields ID into the SMS database to reference this message this ID is not gauranteed to be valid once the notification callback returns. Users should make a copy of the msg if they want to work on it after the callback returns.

Definition at line 1339 of file HsPhoneEvent.h.

UInt32 datetime

date/time stamp

Definition at line 1346 of file HsPhoneEvent.h.

Int32 reserved2

reserved

Definition at line 1347 of file HsPhoneEvent.h.

Int32 reserved3

reserved

Definition at line 1348 of file HsPhoneEvent.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:32 2008 for Palm API Guide


VMFontType Struct Reference

Detailed Description

Font characteristics structure used to describe a font.

Definition at line 158 of file VMFontLibCommon.h.

Data Fields

  • VMFontFace face
  • VMFontSize size
  • VMFontStyle style

Field Documentation

VMFontFace face

Font face.

Definition at line 159 of file VMFontLibCommon.h.

VMFontSize size

Size of Font.

Definition at line 160 of file VMFontLibCommon.h.

VMFontStyle style

Font Style

Definition at line 161 of file VMFontLibCommon.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:32 2008 for Palm API Guide


VMFontUIRules Struct Reference

Detailed Description

Font UI rules structure used for the font picker setting.

Definition at line 145 of file VMFontLibCommon.h.

Data Fields

  • Boolean fontFaceVisible
  • Boolean fontStyleVisible
  • Boolean fontSizeVisible
  • VMFontSizeRule sizeRule
  • VMFontStyleRule styleRule

Field Documentation

Boolean fontFaceVisible

Shows/Hides Font face

Definition at line 146 of file VMFontLibCommon.h.

Boolean fontStyleVisible

Shows/Hides Font Style

Definition at line 147 of file VMFontLibCommon.h.

Boolean fontSizeVisible

Shows/Hides Font Size

Definition at line 148 of file VMFontLibCommon.h.

VMFontSizeRule sizeRule

Shows the size selected: allSize, smallFonts, largeFonts

Definition at line 149 of file VMFontLibCommon.h.

VMFontStyleRule styleRule

Shows the style selected: allStyle, plainOnly

Definition at line 150 of file VMFontLibCommon.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:32 2008 for Palm API Guide


VPNAccountType Struct Reference

Detailed Description

VPN Account structure.

Definition at line 33 of file PalmVPPI.h.

Data Fields

  • UInt32 vppiCreator
  • UInt32 accountID
  • Char accountName [kMaxVPNAccountNameLength+1]

Field Documentation

UInt32 vppiCreator

Creator ID of the VPPI that "owns" the account.

Definition at line 35 of file PalmVPPI.h.

UInt32 accountID

Arbitrary 32-bit ID used by the VPI to identify the account.

Definition at line 36 of file PalmVPPI.h.

Char accountName[kMaxVPNAccountNameLength+1]

User-specified account name.

Definition at line 37 of file PalmVPPI.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:32 2008 for Palm API Guide


vpnNotifyVPNLibTag Struct Reference

Detailed Description

Notification structure sent in vpnLibEventNotification

Definition at line 56 of file PalmShimSettings.h.

Data Fields

  • VPNLibEventNotificationTypeEnum eType
  • UInt8 padding1
  • UInt16 padding2
  • UInt32 ifCreator
  • UInt16 ifInstance
  • UInt16 padding3

Field Documentation

VPNLibEventNotificationTypeEnum eType

Definition at line 58 of file PalmShimSettings.h.

UInt8 padding1

Definition at line 59 of file PalmShimSettings.h.

UInt16 padding2

Definition at line 60 of file PalmShimSettings.h.

UInt32 ifCreator

interface creator

Definition at line 61 of file PalmShimSettings.h.

UInt16 ifInstance

interface instance

Definition at line 62 of file PalmShimSettings.h.

UInt16 padding3

Definition at line 63 of file PalmShimSettings.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:32 2008 for Palm API Guide


WAPNotificationEventType Struct Reference

Detailed Description

Definition at line 1415 of file HsPhoneEvent.h.

Data Fields

  • UInt16 version
  • char * wapMsg
  • char _filler1_
  • UInt32 length
  • UInt32 datetime
  • UInt32 id
  • PhnWAPPushContent contentType
  • PhnWAPPushAppId appId

Field Documentation

UInt16 version

version number to provide future backwards compatibility

Definition at line 1417 of file HsPhoneEvent.h.

char* wapMsg

Network wakeup fields

Definition at line 1420 of file HsPhoneEvent.h.

char _filler1_

for 16 bit allignment

Definition at line 1421 of file HsPhoneEvent.h.

UInt32 length

SMS related fields originally the msgID, now it stores the length of the wapMsg

Definition at line 1424 of file HsPhoneEvent.h.

UInt32 datetime

date/time stamp

Definition at line 1425 of file HsPhoneEvent.h.

UInt32 id

VERSION 3 ADDITION msgID

Definition at line 1428 of file HsPhoneEvent.h.

PhnWAPPushContent contentType

WAP push message content type

Definition at line 1429 of file HsPhoneEvent.h.

PhnWAPPushAppId appId

WAP push message application id

Definition at line 1430 of file HsPhoneEvent.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:32 2008 for Palm API Guide


webBrowserMinimalModeLaunchInfo Struct Reference

Detailed Description

Contains data used when launching web browser in minimal mode.

Definition at line 674 of file HsAppLaunchCmd.h.

Data Fields

  • Char * launchUrl
  • Char * doneButtonLabel

Field Documentation

Char* launchUrl

URL to browse when launching

Definition at line 675 of file HsAppLaunchCmd.h.

Char* doneButtonLabel

Label on the Done button

Definition at line 676 of file HsAppLaunchCmd.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:33 2008 for Palm API Guide


webBrowserURLWithSvcIDLaunchInfo Struct Reference

Detailed Description

Contains data used when launching web browser with a specific SvcID.

Definition at line 683 of file HsAppLaunchCmd.h.

Data Fields

  • UInt32 svcID
  • Char * launchUrl

Field Documentation

UInt32 svcID

Network SvcID from NetPref

Definition at line 684 of file HsAppLaunchCmd.h.

Char* launchUrl

URL to browse when launching

Definition at line 685 of file HsAppLaunchCmd.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:33 2008 for Palm API Guide


WiFiAuthenticationMethodType Struct Reference

Detailed Description

Definition at line 59 of file PalmWPPI.h.

Data Fields

  • UInt32 wppiCreator
  • UInt32 authenticationMethodID
  • Char authenticationMethodName [kMaxWiFiAuthenticationMethodNameLength+1]

Field Documentation

UInt32 wppiCreator

the creator ID of the WPPI that provides the authentication method

Definition at line 61 of file PalmWPPI.h.

UInt32 authenticationMethodID

an arbitrary 32-bit ID used by the WPPI to identify the authentication method

Definition at line 62 of file PalmWPPI.h.

Char authenticationMethodName[kMaxWiFiAuthenticationMethodNameLength+1]

the user-visible name for the authentication method (max width is 50 pixels)

Definition at line 63 of file PalmWPPI.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:33 2008 for Palm API Guide


WUNotificationEventType Struct Reference

Detailed Description

Structure passed to the callbacks registered for incoming wakeup notifications

Definition at line 1288 of file HsPhoneEvent.h.

Data Fields

  • UInt16 version
  • void * headerP
  • UInt8 headerLen
  • char NAI [NAITextSize]
  • char _filler1_
  • UInt32 netTimeStamp
  • UInt8 reasonCode
  • char _filler2_
  • char password [PasswordSize]
  • char _filler3_
  • UInt32 msgID
  • UInt32 datetime
  • Int32 reserved2
  • Int32 reserved3

Field Documentation

UInt16 version

version number to provide future backwards compatibility

Definition at line 1290 of file HsPhoneEvent.h.

void* headerP

pointer to raw header

Definition at line 1292 of file HsPhoneEvent.h.

UInt8 headerLen

length of headerP

Definition at line 1293 of file HsPhoneEvent.h.

char NAI[NAITextSize]

Network wakeup fields stores the NAI

Definition at line 1296 of file HsPhoneEvent.h.

char _filler1_

for 16 bit allignment

Definition at line 1297 of file HsPhoneEvent.h.

UInt32 netTimeStamp

timestamp from the message

Definition at line 1298 of file HsPhoneEvent.h.

UInt8 reasonCode

a reason code from the message

Definition at line 1299 of file HsPhoneEvent.h.

char _filler2_

for 16 bit allignment

Definition at line 1300 of file HsPhoneEvent.h.

char password[PasswordSize]

the password (encrypted)

Definition at line 1301 of file HsPhoneEvent.h.

char _filler3_

for 16 bit allignment

Definition at line 1302 of file HsPhoneEvent.h.

UInt32 msgID

SMS related fields ID into the SMS database to reference this message this ID is not gauranteed to be valid once the notification callback returns. Users should make a copy of the msg if they want to work on it after the callback returns.

Definition at line 1305 of file HsPhoneEvent.h.

UInt32 datetime

date/time stamp

Definition at line 1312 of file HsPhoneEvent.h.

Int32 reserved2

reserved

Definition at line 1313 of file HsPhoneEvent.h.

Int32 reserved3

reserved

Definition at line 1314 of file HsPhoneEvent.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:33 2008 for Palm API Guide


  • All
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- _ -

  • _filler100_ : UPNotificationEventType
  • _filler1_ : WUNotificationEventType , WAPNotificationEventType
  • _filler2_ : WUNotificationEventType
  • _filler3_ : WUNotificationEventType
  • _reserved0 : DialPnlIsDialingAvailableParamsType , HsDialPrefsUSDialingRulesType
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:08 2008 for Palm API Guide


Palm API Guide File List

Here is a list of all files with brief descriptions:
CameraLib.h [code] | Public 68K include file for camera support for Treo 600 devices
CameraLibCommon.h [code] | Public 68K common header file for camera support for Treo 600 devices
CarrierCustomLib.h [code] | This is the main header file for the Carrier Customization Library
CarrierCustomLibErr.h [code] | This file contains the error codes for the Carrier Customization Library
CarrierCustomLibTraps.h [code] | This file contains the trap for the Carrier Customization Library
CarrierCustomLibTypes.h [code] | This file contains public data types exported by the Carrier Customization Library
Contacts.h [code] |
DatebookLibCommon.h [code] |
DefaultHelperLib.h [code] | Default Helper library owns control over the Default Helpers database
DefaultHelperLibTypes.h [code] | Public 68K common header file for Default Helper Library API
FarCall.h [code] |
FavoritesDBLib.h [code] | Contains the API to control the Favorites DB
FavoritesDBLibTypes.h [code] | Public 68K common header file for FavoritesDB library API
FileBrowserLib68K.h [code] | This file contains the FileBrowser Library APIs
FileBrowserLibCommon.h [code] | Public 68K common header file for File Browser library API
HardwareUtils68K.h [code] | Public common header file to the Hardware Utilities Library used by 68K applications
Hs.h [code] |
HS_HTTPLib68K.h [code] | Public 68k include file for the HTTP Library
HS_HTTPLibApp.h [code] |
HS_HTTPLibConst.h [code] |
HsAppLaunchCmd.h [code] | Public header file akin to Palm's AppLaunchCmd.h
HsChars.h [code] |
HsCommon.h [code] |
HsCreators.h [code] | Public header file for the creator IDs used by Handspring
HsErrorClasses.h [code] |
HsErrors.h [code] |
HsExgMgr.h [code] | Extensions to the Exchange Manager
HsExgMgrCommon.h [code] |
HsExt.h [code] | Header file that 68K programs include to access Handspring Extensions functionality
HsExtCommon.h [code] | Common defines shared between HsExt.h (include for 68K programs) and HsExtArm.h (include for ARM programs)
HsExtKbdUtils.h [code] |
HsExtTraps.h [code] | Definitions of selectors used for the 68K trap based calls to HsExtensions
HsExtUtilBigButton.h [code] |
HsExtUtilBigButtonCommon.h [code] |
HsExtUtilBigButtonRsc.h [code] |
HsHelper.h [code] |
HsKeyCodes.h [code] |
HsKeyCommon.h [code] | Header file with additional keyboard related definitions
HsKeyTypes.h [code] | PalmOne's key constant definitions shared by DAL and Palm OS (see Palm OS' CmnKeyTypes.h)
HsNav.h [code] | Header file that 68K programs include to access HsNav functionality
HsNavCommon.h [code] | Public common header file for 5-way navigation support on Treo 600
HsPhone.h [code] | Header file for the phone library (CDMA or GSM)
HsPhoneAudio.h [code] | Header File for Phone Library API ---- AUDIO CATEGORY
HsPhoneAudioTypes.h [code] | File contains Phone Audio data types
HsPhoneCallControlTypes.h [code] | Types for Phone Library call control functionality
HsPhoneCDMA.h [code] | Header File for Phone Library API ---- CDMA CATEGORY
HsPhoneCDMATypes.h [code] | Header File for Phone Library API ---- NETWORK CATEGORY
HsPhoneErrors.h [code] | Errors returned by API function in GSM/CDMA Library
HsPhoneEvent.h [code] | Header file for the phone library (CDMA or GSM)
HsPhoneGSM.h [code] | Header File for Phone Library API ---- GSM CATEGORY
HsPhoneGSMTypes.h [code] | Header File for Phone Library API ---- NETWORK CATEGORY
HsPhoneIOTA.h [code] | Header File for Phone Library API ---- IOTA CATEGORY
HsPhoneIOTATypes.h [code] | Header File for Phone Library API ---- IOTA CATEGORY
HsPhoneLibrary.h [code] | Header File for Phone Library API ---- LIBRARY CATEGORY
hsPhoneLocationTypes.h [code] | File contains Phone Location data types
HsPhoneMisc.h [code] | Header File for Phone Library API ---- MISC CATEGORY
HsPhoneMiscTypes.h [code] | Header File for Phone Library API ---- NETWORK CATEGORY
HsPhoneNetwork.h [code] | Header File for Phone Library API ---- NETWORK CATEGORY
HsPhoneNetworkTypes.h [code] | Header File for Phone Library API ---- NETWORK CATEGORY
HsPhonePower.h [code] | Header File for Phone Library API ---- POWER CATEGORY
HsPhoneSecurity.h [code] | Header File for Phone Library API ---- SECURITY CATEGORY
HsPhoneSecurityTypes.h [code] | Header File for Phone Library API ---- NETWORK CATEGORY
HsPhoneSMS.h [code] | Header File for Phone Library API ---- SMS CATEGORY
HsPhoneSMSTypes.h [code] | Header File for Phone Library API ---- NETWORK CATEGORY
HsPhoneTrace.h [code] | Trace constants, types, and definitions for Phone Library
HsPhoneTraps.h [code] | Traps of all functions exported by the Phone Library
HsPhoneTypes.h [code] | Telephony data types that are common between ARM and 68K
HsSoundLib.h [code] | Public 68K include file for main sound support for Treo 600 and Treo 650 smartphones
HsSoundLibCommon.h [code] | Public 68K/Arm common header file for sound support for Treo 600, Treo 650, and Treo 700p smartphones and later models
HsSoundLibTraps.h [code] |
HtmlLib68K.h [code] | Public 68K include file for HTML shared library
HtmlLibTrap.h [code] |
ImageLib.h [code] | Public 68k include file for the Imaging Library
ImageLibCommon.h [code] | Public 68k common header file for the Image Library API on Treo 600 devices
ImageLibTraps.h [code] |
LocsLib.h [code] | Public 68K include file for location/timezone/DST support on Palm devices
LocsLibCommon.h [code] | Public 68K common header file for locations library
MmsHelperCommon.h [code] | Public 68k common header files to be used with Default Helper Library
NetMasterLibErrors.h [code] | This is the error declarations file for the NetMaster Library
NetMasterLibrary.h [code] | This is the main header file for the NetMaster Library
NetMasterLibTarget.h [code] | This is the target parameters file for the NetMaster Library
NetMasterLibTraps.h [code] | Trap definitions for the NetMaster Library
NetMasterLibTypes.h [code] | This file contains public data types exported by the NetMaster Library
NetPrefLibErrors.h [code] | This is the error declarations file for the NetPref Library
NetPrefLibFieldInfoTable.h [code] | This header file contains record field information for NetPref settings
NetPrefLibrary.h [code] | This is the main header file for the NetPref Library
NetPrefLibTarget.h [code] | This is the target parameters file for the NetPref Library
NetPrefLibTraps.h [code] | Trap definitions for the NetPref Library
NetPrefLibTypes.h [code] | This file contains public data types exported by the NetPref Library
PalmAudioPlayback.h [code] | Public 68K include file that supports the stopping of audio playback on Treo 600 and Treo 650 smartphones
PalmBGService.h [code] | Public 68K header file for palmOne Background Network Service Library
PalmCreators.h [code] | Contains Palm-specific creator codes
PalmDisplayExtent.h [code] | Public API for the Display Extent Library
PalmErrorBase.h [code] | Include file for Error Management
PalmFeatures.h [code] | Contains Palm-specific feature definitions
PalmGoLCD.h [code] | Public include header file for the GoLCD Library
PalmGoLCDCommon.h [code] | Public common header file for the GoLCD Library
PalmHiResTime.h [code] | Exported High Resolution timer definitions
PalmLaunchCodes.h [code] | Device specific launch codes
PalmLcdOverlay.h [code] | Exported LCD Overlay functions
PalmLED.h [code] | Palm's Generic LED dirver
PalmNative.h [code] | Functions and macros to help building ARM code
PalmNetServices.h [code] | NetServices provides a set of API to access 802.11
Incs/palmOne_68K.h [code] |
palmOne_68K.h [code] |
palmOneCamera.h [code] | Public 68K include file for camera support for Treo 650 devices. This version of the library adds functionality for Zire72, and Treo 650
palmOneCameraCommon.h [code] | Public 68K common header file for camera support for Zire 72 and Treo 650 devices
palmOneCameraSlider.h [code] | Public 68K file for camera slider notification for Zire 71 devices
68k/system/palmOneChars.h [code] |
common/system/palmOneChars.h [code] |
palmOneCodecFormat.h [code] | Public 68K common header file for Codec Plugin Manager API - Codec Formats
palmOneCodecPluginMgr.h [code] | The Codec Plugin Manager is used to unify all different type of codecs that are available for PalmOne devices and provide a generic API for developers to access these codecs
palmOneCodecPluginMgrCommon.h [code] | Public 68K common header file for Codec Plugin Manager API - Library Definitions
palmOneCreators.h [code] | Contains Palm-specific creator codes
palmOneFeatures.h [code] | Contains Palm-specific feature definitions
palmOneHiResTimer.h [code] | Public 68k include file for Hi-Resolution timer for Palm OS
palmOneHiResTimerCommon.h [code] | Public 68k common header file for Hi-Resolution Timer API
palmOneLcdOverlay.h [code] | Public 68k include file for LCDOverlay API that can be used to display YCbCr images directly on the screen
palmOneLcdOverlayCommon.h [code] | Public 68k common header file for LCDOverlay API
68k/system/palmOneNavigator.h [code] |
common/system/palmOneNavigator.h [code] |
palmOnePhoto.h [code] | Palm Photos API: This API is used to access Palm Photos database and manipulate images
palmOnePhotoCommon.h [code] | Palm Photos API: This file contains all the defines, enumerations, structures needed by PalmPhoto.h
palmOneResources.h [code] | Palm-specific system types and resources
palmOneSndFileStream.h [code] | Public 68K include file for sound files stream support for Treo 600 and Treo 650 smartphones
palmOneStatusBar.h [code] | Public common header file for palmOne defined Status Bar library
palmOneSystemCommon.h [code] | This is the common public header for palmOne system definitions
palmOneVMFontLib.h [code] | Defines APIs and structures for the Palm VersaMail Font Picker / Font Manager Service which lets users get / set font characteristics
PalmPhoto.h [code] |
PalmPin.h [code] | Public API for the Pen Input Manager Library
PalmPower.h [code] | Battery notification
PalmResources.h [code] |
PalmShimSettings.h [code] | Shim settings for NetIFSettingGet()/Set()
PalmSoundCustomCtrl.h [code] | Public 68K include file for the Sound Manager custom controls for the IMA_ADPCM codec for Treo 600 and Treo 650 smartphones
PalmSoundMgrExt.h [code] | Public 68K include file for the Extended Sound Manager
PalmStatusBar.h [code] |
PalmVMLaunch.h [code] | Defines APIs and structures for launching VersaMail to add a new message from an application
PalmVMPlugin.h [code] | Defines APIs and structures for the VersaMail Plugin Service which lets users write plugins to view/send attachments
PalmVPPI.h [code] | This is the API for VPN panel plug-ins (VPPIs)
PalmWiFiCommon.h [code] | Constants and structures common to the wifi network panel and driver
PalmWPPI.h [code] | This is the API for Wi-Fi panel plug-ins (WPPIs)
PmConnectorLib.h [code] | PalmOne library that exports multi-connector related APIs
PmConnectorLibCommon.h [code] | Public 68k common header file for Multi-Connector Library for palmOne devices that use multi-connector
PmKeyLib.h [code] | System Library that exports key-related APIs
PmKeyLibCommon.h [code] | Public 68k common header file for system library that exports key-related APIs
PmLibErrors.h [code] | Errors common to all our portable Pm Libraries
PmPalmOSNVFS.h [code] | Public 68k header file containing the definitions and API for NVFS devices
PmSoundLibAudioGroup.h [code] | Public 68K header file used to associate sound channels with Audio groups on Treo 600 and Treo 650 smartphones
PmSysGadgetLib.h [code] | System Library that exports status-related APIs
PmSysGadgetLibBbutRscCommon.h [code] |
PmSysGadgetLibCommon.h [code] | Public 68k header file for system Library that exports system gadget related APIs
PmUIUtilLib.h [code] | This is the public header for PmUIUtil library
PmUIUtilLibCommon.h [code] | Public 68k common header file for system Library that exports UI utility API functions
Slider.h [code] |
SmartTextEngine.h [code] | Public 68K include file for Smart Text Engine shared library
SmartTextEngineDef.h [code] | Public include file for Smart Text Engine shared library
SmartTextEngineErrors.h [code] | Error codes for Smart Text Engine shared library
SmartTextEngineRsc.h [code] |
SmartTextEngineTraps.h [code] | Trap definitions for the Smart Text Engine shared library
TonesLib.h [code] | Public 68K include file that controls the MIDI tones on a device
TonesLibTypes.h [code] | Public 68K header file for the Ring Tone library on Treo devices
TransparencyLib.h [code] | Transparency Library that couples a Ccp channel and a serial port
TransparencyLibTypes.h [code] | Public common header file for the Transparency Library on Treo devices
VMFontLibCommon.h [code] | Public common header file for the Versamail Font Library
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:37 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » camera

CameraLib.h File Reference

Detailed Description

Public 68K include file for camera support for Treo 600 devices.

Notes: The calling application should always load this library with SysLibLoad() before use, even if it is already open by another application(ie, SysLibFind() returns a valid refnum). When the application is done with the library, it should be unloaded with SysLibRemove(). We do this because there is no good way to synchronize loading and unloading of libraries among multiple applications. It also greatly simplifies internal synchronization.

Definition in file CameraLib.h.

Include dependency graph for CameraLib.h:

Go to the source code of this file.

Functions

  • Err CameraLibOpen (UInt16 refnum)
  • Err CameraLibClose (UInt16 refnum)
  • Err CameraLibSleep (UInt16 refnum)
  • Err CameraLibWake (UInt16 refnum)
  • Err CameraLibCapture (UInt16 refnum, void *buffer, UInt16 format)
  • Err CameraLibPreview (UInt16 refnum, void *buffer, UInt16 format, UInt32 width, UInt32 height)
  • Err CameraLibPreviewStart (UInt16 refnum, WinHandle windowH, UInt32 x, UInt32 y)
  • Err CameraLibPreviewStop (UInt16 refnum)
  • Err CameraLibRegisterGet (UInt16 refnum, UInt32 reg, UInt32 *valueP)
  • Err CameraLibRegisterSet (UInt16 refnum, UInt32 reg, UInt32 value)

Function Documentation

Err CameraLibCapture | ( | UInt16 | refnum,
 |  | void * | buffer,
 |  | UInt16 | format
 | ) |  |

Returns a full image (640X480) in the specified color space. This function is not really necessary, since CameraLibPreview could be used instead. This function might be deprecated in the future.

Parameters:
refnum,: IN: Library reference number.
buffer,: IN: Buffer to hold the image.
format,: IN: Format of the image you want returned.
Return values:
Err Error code.

Err CameraLibClose ( UInt16 refnum )

Closes the Camera library. Library should always be unloaded with SysLibRemove() after CameraLibClose() is called. See note at top of file.

Parameters:
refnum,: IN: Library reference number.
Return values:
Err Error code.

Err CameraLibOpen ( UInt16 refnum )

Standard library open routine. Library should always be loaded with SysLibLoad()(not SysLibFind()) before calling CameraLibOpen(). See note at top of file.

Parameters:
refnum,: IN: Library reference number.
Return values:
Err Error code.

Err CameraLibPreview | ( | UInt16 | refnum,
 |  | void * | buffer,
 |  | UInt16 | format,
 |  | UInt32 | width,
 |  | UInt32 | height
 | ) |  |

Returns an image using the window width and height (pixels) you specify. If the width and height are less the dimensions of a full camera image (640x480) a simple pixel sub-sampling algorithm is used to decimate the image.

Parameters:
refnum,: IN: Library reference number.
buffer,: IN: Buffer to hold the image.
format,: IN: Format of the image you want returned.
width,: IN: The width in pixels of the image you want captured.
height,: IN: The height in pixels of the image you want captured.
Return values:
Err Error code.

Err CameraLibPreviewStart | ( | UInt16 | refnum,
 |  | WinHandle | windowH,
 |  | UInt32 | x,
 |  | UInt32 | y
 | ) |  |

Puts the camera library in preview mode and establishes a preview window. While in this mode, QQVGA images are continuously copied to the LCD screen of the device. Call CameraLibPreviewStop to exit preview mode.

Parameters:
refnum,: IN: Library reference number.
windowH,: IN: Window handle of the PalmOS window that the image is to be displayed in.
x,: IN: Window-relative coordinate of the left edge of the image.
y,: IN: Window-relative coordinate of the top edge of the image.
Return values:
Err Error code.

Err CameraLibPreviewStop ( UInt16 refnum )

Stops preview mode.

See also:
CameraLibPreviewStart.
Parameters:
refnum,: IN: Library reference number.
Return values:
Err Error code.

Err CameraLibRegisterGet | ( | UInt16 | refnum,
 |  | UInt32 | reg,
 |  | UInt32 * | valueP
 | ) |  |

Gets the current setting of the camera register.

Parameters:
refnum,: IN: Library reference number.
reg,: IN: Register number.
valueP,: OUT: Pointer to where register data will be stored.
Return values:
Err Error code.

Err CameraLibRegisterSet | ( | UInt16 | refnum,
 |  | UInt32 | reg,
 |  | UInt32 | value
 | ) |  |

Sets the value of the camera register.

Parameters:
refnum,: IN: Library reference number.
reg,: IN: Register number.
value,: IN: The data value you want to set the register to.
Return values:
Err Error code.

Err CameraLibSleep ( UInt16 refnum )

Standard library sleep function.

Parameters:
refnum,: IN: Library reference number.
Return values:
Err Error code.

Err CameraLibWake ( UInt16 refnum )

Standard library wake function.

Parameters:
refnum,: IN: Library reference number.
Return values:
Err Error code.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:55 2008 for Palm API Guide


Header Files » Incs » common » libraries » camera

CameraLibCommon.h File Reference

Detailed Description

Public 68K common header file for camera support for Treo 600 devices.

This file contains the library constants and error codes used in the APIs.

Definition in file CameraLibCommon.h.

Go to the source code of this file.

Defines

  • #define kCameraLibType sysFileTLibrary
  • #define kCameraLibCreator 'HsCa'
  • #define kCameraLibName "CameraLib"
Image Format
  • #define kCameraImageFormatRGB1 1
  • #define kCameraImageFormatRGB4 2
  • #define kCameraImageFormatRGB8 3
  • #define kCameraImageFormatRGB16 4
  • #define kCameraImageFormatRGB24 5
  • #define kCameraImageFormatRGB32 6
  • #define kCameraImageFormatYCrCb 7
  • #define kCameraImageLittleEndian 0x8000
  • #define kCameraImageFormatYCbCr kCameraImageFormatYCrCb
Error Codes
  • #define errCam 0xaf00
  • #define errCamNoFrame (errCam + 0)
  • #define errInPreviewMode (errCam + 1)
  • #define errCamOverflow (errCam + 2)
  • #define errInvalidAddress (errCam + 3)
  • #define errCamWriteFailed (errCam + 4)
Function Traps
  • #define kCameraLibTrapOpen sysLibTrapOpen
  • #define kCameraLibTrapClose sysLibTrapClose
  • #define kCameraLibTrapSleep sysLibTrapSleep
  • #define kCameraLibTrapWake sysLibTrapWake
  • #define kCameraLibTrapCameraLibCapture (sysLibTrapCustom)
  • #define kCameraLibTrapCameraLibPreview (sysLibTrapCustom+1)
  • #define kCameraLibTrapCameraLibPreviewStart (sysLibTrapCustom+2)
  • #define kCameraLibTrapCameraLibPreviewStop (sysLibTrapCustom+3)
  • #define kCameraLibTrapCameraLibRegisterGet (sysLibTrapCustom+4)
  • #define kCameraLibTrapCameraLibRegisterSet (sysLibTrapCustom+5)

Define Documentation

#define errCam 0xaf00

Definition at line 44 of file CameraLibCommon.h.

#define errCamNoFrame (errCam + 0)

Definition at line 45 of file CameraLibCommon.h.

#define errCamOverflow (errCam + 2)

Definition at line 47 of file CameraLibCommon.h.

#define errCamWriteFailed (errCam + 4)

Definition at line 49 of file CameraLibCommon.h.

#define errInPreviewMode (errCam + 1)

Definition at line 46 of file CameraLibCommon.h.

#define errInvalidAddress (errCam + 3)

Definition at line 48 of file CameraLibCommon.h.

#define kCameraImageFormatRGB1 1

Whatever RGB1 Format is

Definition at line 29 of file CameraLibCommon.h.

#define kCameraImageFormatRGB16 4

Whatever RGB16 Format is

Definition at line 32 of file CameraLibCommon.h.

#define kCameraImageFormatRGB24 5

Whatever RGB24 Format is

Definition at line 33 of file CameraLibCommon.h.

#define kCameraImageFormatRGB32 6

Whatever RGB32 Format is

Definition at line 34 of file CameraLibCommon.h.

#define kCameraImageFormatRGB4 2

Whatever RGB4 Format is

Definition at line 30 of file CameraLibCommon.h.

#define kCameraImageFormatRGB8 3

Whatever RGB8 Format is

Definition at line 31 of file CameraLibCommon.h.

#define kCameraImageFormatYCbCr kCameraImageFormatYCrCb

not used

Definition at line 37 of file CameraLibCommon.h.

#define kCameraImageFormatYCrCb 7

Whatever RGBYCrCb Format is

Definition at line 35 of file CameraLibCommon.h.

#define kCameraImageLittleEndian 0x8000

Whatever LittleEndian Format is

Definition at line 36 of file CameraLibCommon.h.

#define kCameraLibCreator 'HsCa'

Camera library creator ID

Definition at line 21 of file CameraLibCommon.h.

#define kCameraLibName "CameraLib"

Camera library database name

Definition at line 22 of file CameraLibCommon.h.

#define kCameraLibTrapCameraLibCapture (sysLibTrapCustom)

Definition at line 60 of file CameraLibCommon.h.

#define kCameraLibTrapCameraLibPreview (sysLibTrapCustom+1)

Definition at line 61 of file CameraLibCommon.h.

#define kCameraLibTrapCameraLibPreviewStart (sysLibTrapCustom+2)

Definition at line 62 of file CameraLibCommon.h.

#define kCameraLibTrapCameraLibPreviewStop (sysLibTrapCustom+3)

Definition at line 63 of file CameraLibCommon.h.

#define kCameraLibTrapCameraLibRegisterGet (sysLibTrapCustom+4)

Definition at line 64 of file CameraLibCommon.h.

#define kCameraLibTrapCameraLibRegisterSet (sysLibTrapCustom+5)

Definition at line 65 of file CameraLibCommon.h.

#define kCameraLibTrapClose sysLibTrapClose

Definition at line 57 of file CameraLibCommon.h.

#define kCameraLibTrapOpen sysLibTrapOpen

Definition at line 56 of file CameraLibCommon.h.

#define kCameraLibTrapSleep sysLibTrapSleep

Definition at line 58 of file CameraLibCommon.h.

#define kCameraLibTrapWake sysLibTrapWake

Definition at line 59 of file CameraLibCommon.h.

#define kCameraLibType sysFileTLibrary

Default library type

Definition at line 20 of file CameraLibCommon.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:55 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » carriercustomlib

CarrierCustomLib.h File Reference

Detailed Description

This is the main header file for the Carrier Customization Library.

Version:
1.0
Date:
12/01/2002
This includes all the other required headers, so there is no need to include Traps, Errors, and Types if this is included.

Usage Model:

This library is automatically loaded at boot time by HsExtensions. Apps that call this library should only have to call SysLibFind. They should never have to load the library. LibOpen and LibClose should not be called either.

Definition in file CarrierCustomLib.h.

Include dependency graph for CarrierCustomLib.h:

Go to the source code of this file.

Defines

  • #define ENCRYPTED_DATABASE true
  • #define MVNONAME_LENGTH 10
  • #define CCUSTOM_LIB_TRAP(trapNum) SYS_TRAP(trapNum)

Functions

  • Err CCustomLibOpen (UInt16 refNum)
  • Err CCustomLibClose (UInt16 refNum)
  • Err CCustomLibSleep (UInt16 refNum)
  • Err CCustomLibWake (UInt16 refNum)
  • Err CCustomLibVersionGet (UInt16 refNum, UInt32 *majorVerP, UInt32 *minorVerP, UInt32 *bugFixVerP)
  • Err CCustomLibGetCarrierSetting (UInt16 refNum, CCSMSettingsType settingsType, void *dataP)
  • Err CCustomLibGetCarrierCode (UInt16 refNum, UInt8 *length, char **dataP)
  • Err CCustomLibGetCarrierCodeLength (UInt16 refNum, UInt8 *lengthP, char *carrierCodeP)

Define Documentation

#define CCUSTOM_LIB_TRAP ( trapNum ) SYS_TRAP(trapNum)

Definition at line 54 of file CarrierCustomLib.h.

#define ENCRYPTED_DATABASE true

internal

Definition at line 47 of file CarrierCustomLib.h.

#define MVNONAME_LENGTH 10

Definition at line 49 of file CarrierCustomLib.h.

Function Documentation

Err CCustomLibClose ( UInt16 refNum )

Closes library and frees up allocated resources Close the library and decrements the reference count. This should never be called by an application.

Parameters:
refNum,: IN: CCustomLib reference number (from SysLibFind or SysLibLoad)
Return values:
Err Error Code.

Err CCustomLibGetCarrierCode | ( | UInt16 | refNum,
 |  | UInt8 * | length,
 |  | char ** | dataP
 | ) |  |

Returns the carrier ID from the SIM. Makes a copy of MMC/MNC code and returns it.

Parameters:
refNum,: IN: CCustomLib reference number (from SysLibFind or SysLibLoad)
length,: IN,OUT: length of buffer passed in, length of buffer used/needed (not including terminator)
dataP,: OUT: pointer to store the value
Return values:
Err Error code.

Err CCustomLibGetCarrierCodeLength | ( | UInt16 | refNum,
 |  | UInt8 * | lengthP,
 |  | char * | carrierCodeP
 | ) |  |

Returns the actual length of the carrier ID. If no carrier code is passed it, returns the length of the current carrier ID. This length is usually 6 for North American countries and 5 for others.

Parameters:
refNum,: IN: CCustomLib reference number (from SysLibFind or SysLibLoad)
lengthP,: IN,OUT: length of carrier code. Uses the current carrier if no carrier code is passed in
carrierCodeP,: IN: optional carrier code
Return values:
Err Error code.

Err CCustomLibGetCarrierSetting | ( | UInt16 | refNum,
 |  | CCSMSettingsType | settingsType,
 |  | void * | dataP
 | ) |  |

Returns the specified setting. Returns the carrier settings for the given field. Any memory allocation must be freed by the calling application. Currently, only string types are allocated.

Parameters:
refNum,: IN: CCustomLib reference number (from SysLibFind or SysLibLoad)
settingsType,: IN: object type specified by settingsTypeEnum
dataP,: IN,OUT: allocated object containing data, undefined on err
Return values:
Err Error code.

Err CCustomLibOpen ( UInt16 refNum )

Open the library, initialize library globals Initializes the library globals, based on the last known carrier. This should never be called by an application, as it is automatically loaded by the system and opened.

Parameters:
refNum,: IN: CCustomLib reference number (from SysLibFind or SysLibLoad)
Return values:
Err Error Code.

Err CCustomLibSleep ( UInt16 refNum )

Standard library sleep routine

Parameters:
refNum,: IN: CCustomLib reference number (from SysLibFind or SysLibLoad)
Return values:
Err Error code.

Err CCustomLibVersionGet | ( | UInt16 | refNum,
 |  | UInt32 * | majorVerP,
 |  | UInt32 * | minorVerP,
 |  | UInt32 * | bugFixVerP
 | ) |  |

Get Library API Version number.

Parameters:
refNum,: IN: Library reference number
majorVerP,: OUT: Major version number
minorVerP,: OUT: Minor version number
bugFixVerP,: OUT: Bug fix version number
Return values:
Err Customization Library error code

Err CCustomLibWake ( UInt16 refNum )

Standard library wake routine

Parameters:
refNum,: IN: CCustomLib reference number (from SysLibFind or SysLibLoad)
Return values:
Err Error code.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:56 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » carriercustomlib

CarrierCustomLibErr.h File Reference

Detailed Description

This file contains the error codes for the Carrier Customization Library.

Version:
1.0
Date:
12/17/2002

Definition in file CarrierCustomLibErr.h.

Go to the source code of this file.

Defines

  • #define ccsmErrClass 0x9000
  • #define ccsmErrUnknownCarrier ccsmErrClass + 0x01
  • #define ccsmErrMemory ccsmErrClass + 0x02
  • #define ccsmErrPhoneLibLoad ccsmErrClass + 0x03
  • #define ccsmErrPhoneNotPowered ccsmErrClass + 0x04
  • #define ccsmErrInvalidArg ccsmErrClass + 0x05
  • #define ccsmErrUnknownSetting ccsmErrClass + 0x06
  • #define ccsmErrBufferTooSmall ccsmErrClass + 0x07
  • #define ccsmErrNotRegistered ccsmErrClass + 0x08
  • #define ccsmErrUnknownField ccsmErrClass + 0x09
  • #define ccsmErrLibUninitialized ccsmErrClass + 0x0A
  • #define ccsmErrUndefinedField ccsmErrClass + 0x0B
  • #define ccsmErrProfileUnspecified ccsmErrClass + 0x50
  • #define ccsmErrUnspecified ccsmErrClass + 0x51
  • #define ccsmErrUnimplemented ccsmErrClass + 0xA5

Define Documentation

#define ccsmErrBufferTooSmall ccsmErrClass + 0x07

0x9007 need more space in buffer

Definition at line 35 of file CarrierCustomLibErr.h.

#define ccsmErrClass 0x9000

0x9000 Carrier customization library error base number

Definition at line 27 of file CarrierCustomLibErr.h.

#define ccsmErrInvalidArg ccsmErrClass + 0x05

0x9005 invalid arguement error

Definition at line 33 of file CarrierCustomLibErr.h.

#define ccsmErrLibUninitialized ccsmErrClass + 0x0A

0x900A library was not initialized

Definition at line 38 of file CarrierCustomLibErr.h.

#define ccsmErrMemory ccsmErrClass + 0x02

0x9002 memory error

Definition at line 30 of file CarrierCustomLibErr.h.

#define ccsmErrNotRegistered ccsmErrClass + 0x08

0x9008 radio is not registered

Definition at line 36 of file CarrierCustomLibErr.h.

#define ccsmErrPhoneLibLoad ccsmErrClass + 0x03

0x9003 phone library not loaded

Definition at line 31 of file CarrierCustomLibErr.h.

#define ccsmErrPhoneNotPowered ccsmErrClass + 0x04

0x9004 phone is not powered

Definition at line 32 of file CarrierCustomLibErr.h.

#define ccsmErrProfileUnspecified ccsmErrClass + 0x50

0x9050 requested profile is not specified

Definition at line 41 of file CarrierCustomLibErr.h.

#define ccsmErrUndefinedField ccsmErrClass + 0x0B

0x900B the field did not have a value specified

Definition at line 39 of file CarrierCustomLibErr.h.

#define ccsmErrUnimplemented ccsmErrClass + 0xA5

0x90F5 Unimplemented feature

Definition at line 43 of file CarrierCustomLibErr.h.

#define ccsmErrUnknownCarrier ccsmErrClass + 0x01

0x9001 carrier code on SIM card not recognized

Definition at line 29 of file CarrierCustomLibErr.h.

#define ccsmErrUnknownField ccsmErrClass + 0x09

0x9009 requested field not in database record

Definition at line 37 of file CarrierCustomLibErr.h.

#define ccsmErrUnknownSetting ccsmErrClass + 0x06

0x9006 unknown setting requested error

Definition at line 34 of file CarrierCustomLibErr.h.

#define ccsmErrUnspecified ccsmErrClass + 0x51

0x9051 settings is not specified for carrier

Definition at line 42 of file CarrierCustomLibErr.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:56 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » carriercustomlib

CarrierCustomLibTraps.h File Reference

Detailed Description

This file contains the trap for the Carrier Customization Library.

Version:
1.0
Date:
12/11/2002

Definition in file CarrierCustomLibTraps.h.

Go to the source code of this file.

Defines

Function Trap Numbers
Trap IDs for the Carrier Customization Library's public functions. The order of the traps must be the same as the routines are listed in NetPrefLibDispatchTable.c.

  • #define CCustomLibTrapVersionGet (sysLibTrapCustom + 0)
  • #define CCustomLibTrapGetCarrierSetting (sysLibTrapCustom + 1)
  • #define CCustomLibTrapGetProfileSetting (sysLibTrapCustom + 2)
  • #define CCustomLibTrapGetCarrierProfile (sysLibTrapCustom + 3)
  • #define CCustomLibTrapReleaseCarrierProfile (sysLibTrapCustom + 4)
  • #define CCustomLibTrapGetCarrierCode (sysLibTrapCustom + 5)
  • #define CCustomLibTrapGetCarrierCodeLength (sysLibTrapCustom + 6)
  • #define CCustomLibTrapRefresh (sysLibTrapCustom + 7)
  • #define CCustomLibTrapRetrieveNVSetting (sysLibTrapCustom + 8)

Define Documentation

#define CCustomLibTrapGetCarrierCode (sysLibTrapCustom + 5)

Definition at line 39 of file CarrierCustomLibTraps.h.

#define CCustomLibTrapGetCarrierCodeLength (sysLibTrapCustom + 6)

Definition at line 40 of file CarrierCustomLibTraps.h.

#define CCustomLibTrapGetCarrierProfile (sysLibTrapCustom + 3)

Definition at line 37 of file CarrierCustomLibTraps.h.

#define CCustomLibTrapGetCarrierSetting (sysLibTrapCustom + 1)

Definition at line 35 of file CarrierCustomLibTraps.h.

#define CCustomLibTrapGetProfileSetting (sysLibTrapCustom + 2)

Definition at line 36 of file CarrierCustomLibTraps.h.

#define CCustomLibTrapRefresh (sysLibTrapCustom + 7)

Definition at line 41 of file CarrierCustomLibTraps.h.

#define CCustomLibTrapReleaseCarrierProfile (sysLibTrapCustom + 4)

Definition at line 38 of file CarrierCustomLibTraps.h.

#define CCustomLibTrapRetrieveNVSetting (sysLibTrapCustom + 8)

Definition at line 42 of file CarrierCustomLibTraps.h.

#define CCustomLibTrapVersionGet (sysLibTrapCustom + 0)

Definition at line 34 of file CarrierCustomLibTraps.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:56 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » carriercustomlib

CarrierCustomLibTypes.h File Reference

Detailed Description

This file contains public data types exported by the Carrier Customization Library.

Version:
1.0
Date:
12/16/2002

Definition in file CarrierCustomLibTypes.h.

Go to the source code of this file.

Defines

  • #define kCCLibType 'libr'
  • #define kCarrierCustomizationCLibName "CarrierCustomization.lib"
  • #define kCarrierListDBName "CarrierProfiles2"
  • #define kNetworkListDBName "NetworkProfiles2"
API Version numbers
Current library API version number. Returned by NetPrefLibVersionGet()

  • #define CCSMVersionMajor 0
  • #define CCSMVersionMinor 6
  • #define CCSMVersionBugFix 0
Carrier codes
  • #define kSprintMCCMNC "310000"
  • #define kVerizonMCCMNC "310555"
  • #define kBellMobilityMCCMNC "310505"
  • #define kGenericMCCMNC "310999"

Typedefs

  • typedef void * CCSMCarrierHandle
  • typedef UInt16 CCSMSettingsType
  • typedef UInt32 CCSMSystemFlagsType
  • typedef UInt32 CCSMPhoneFlagsType
  • typedef UInt32 CCSMRadioBandType
  • typedef UInt32 CCSMMessagingFlagsType
  • typedef UInt32 CCSMBrowserFlagsType

Enumerations

  • enum {
    kCCSMSettingsSystemReserved,
    kCCSMSettingsShowNetworkSelect,
    kCCSMSettingsIndicateRoaming,
    kCCSMSettingsEditableMSISDN,
    kCCSMSettingsShowEmergencyMode,
    kCCSMSettingsCarrierMSISDN,
    kCCSMSettingsRadioBand,
    kCCSMSettingsVoiceMailNumber,
    kCCSMSettingsPOP3Server,
    kCCSMSettingsSMTPServer,
    kCCSMSettingsSMSCNumber,
    kCCSMSettingsSMSEmailGateway,
    kCCSMSettingsMMSURL,
    kCCSMSettingsMMSWAPGateway,
    kCCSMSettingsMMSPort,
    kCCSMSettingsMMSMaxMsgSize,
    kCCSMSettingsPrimaryProxyServer,
    kCCSMSettingsPrimaryProxyPort,
    kCCSMSettingsPrimarySecureProxyServer,
    kCCSMSettingsPrimarySecureProxyPort,
    kCCSMSettingsSecondaryProxyServer,
    kCCSMSettingsSecondaryProxyPort,
    kCCSMSettingsSecondarySecureProxyServer,
    kCCSMSettingsSecondarySecureProxyPort,
    kCCMSSettingsPrimaryTrustedDomain,
    kCCMSSettingsSecondaryTrustedDomain,
    kCCMSSettingsUAProfilingURL,
    kCCSMSettingsHTTPHeaders,
    kCCSMSettingsNAIHeaderFormat,
    kCCSMSettingsMSISDNHeaderFormat,
    kCCSMSettingsEncryptMSISDN,
    kCCSMSettingsHomepageURL,
    kCCSMSettingsGPRSAutoAttach,
    kCCSMSettingsNAI,
    kCCSMSettingsBrowserFlags,
    kCCSMSettingsBrowserProxyFlags,
    kCCSMSettingsProxyUsername,
    kCCSMSettingsProxyPassword,
    kCCSMSettingsMessagingFlags,
    kCCSMSettingsSMSMaxMsgSize,
    kCCSMSettingsSMSValidityPeriod,
    kCCSMSettingsE911Timeout,
    kCCSMSettingsMMSUAProf,
    kCCSMSettingsMMSUAString,
    kCCSMSettingsMMSMaxVideoSize,
    kCCSMSettingsMMSVersionNumber,
    kCCSMSettingsEmailSMTPServer,
    kCCSMSettingsSPNSupported,
    kCCSMSettingsWapSupportLevel,
    kCCSMSettingsSMSSupportDeliveryReceipt,
    kCCSMSettingsCSDDisable,
    kCCSMSettingsReserved = 0x8000
    }
  • enum CCSMSystemFlagsEnum { kCCSMSystemSettingReserved = 0x00000000 }
  • enum CCSMPhoneFlagsEnum {
    kCCSMPhoneSettingsReserved = 0x00000000,
    kCCSMPhoneSettingsNetworkSelect = 0x00000001,
    kCCSMPhoneSettingsRoamingIndicator = 0x00000002,
    kCCSMPhoneSettingsEditMSISDN = 0x00000004,
    kCCSMPhoneSettingsShowEmergencyMode = 0x00000008,
    kCCSMPhoneSettingsEnableTTY = 0x00000010,
    kCCSMPhoneSettingsUseEFSPN = 0x00000020
    }
  • enum CCSMRadioBandEnum {
    kCCSMRadioBandUnknown,
    kCCSMRadioBandEurope,
    kCCSMRadioBandNorthAmerica
    }
  • enum CCSMMessagingSettingsEnum {
    kCCSMMessagingSettingsReserved = 0x00000000,
    kCCSMMessagingSettingsStripPhonePlus = 0x00000001,
    kCCSMMessagingSettings11DigitRecipient = 0x00000002,
    kCCSMMessagingSettingsNormaliseMMSAddress = 0x00000004,
    kCCSMMessagingSettingsWAPProtocol20 = 0x00000008,
    kCCSMMessagingSettingsDisableMMSFallback = 0x00000010
    }
  • enum CCSMBrowserSettingsEnum {
    kCCSMBrowserSettingsReserved = 0x00000000,
    kCCSMBrowserSettingsEncryptMSISDN = 0x00000001,
    kCCSMBrowserSettingsCSDDisconnectOnExit = 0x00000002,
    kCCSMBrowserSettingsPDataDisconnectOnExit = 0x00000004,
    kCCSMBrowserSettingsDormantOnExit = 0x00000008,
    kCCSMBrowserSettingsHideDisconnect = 0x00000010,
    kCCSMBrowserSettingsVersionInWAPProfile = 0x00000020,
    kCCSMPrimaryProxyAuthenticate = 0x00000001,
    kCCSMPrimaryProxyLocked = 0x00000002,
    kCCSMPrimaryProxyHide = 0x00000004,
    kCCSMSecondaryProxyAuthenticate = 0x00010000,
    kCCSMSecondaryProxyLocked = 0x00020000,
    kCCSMSecondaryProxyHide = 0x00040000
    }

Define Documentation

#define CCSMVersionBugFix 0

Definition at line 51 of file CarrierCustomLibTypes.h.

#define CCSMVersionMajor 0

Definition at line 49 of file CarrierCustomLibTypes.h.

#define CCSMVersionMinor 6

Definition at line 50 of file CarrierCustomLibTypes.h.

#define kBellMobilityMCCMNC "310505"

Definition at line 60 of file CarrierCustomLibTypes.h.

#define kCarrierCustomizationCLibName "CarrierCustomization.lib"

Carrier Customization Library name

Definition at line 39 of file CarrierCustomLibTypes.h.

#define kCarrierListDBName "CarrierProfiles2"

Name of carrier list database

Definition at line 40 of file CarrierCustomLibTypes.h.

#define kCCLibType 'libr'

Standard library type

Definition at line 38 of file CarrierCustomLibTypes.h.

#define kGenericMCCMNC "310999"

Definition at line 61 of file CarrierCustomLibTypes.h.

#define kNetworkListDBName "NetworkProfiles2"

Name of network list database

Definition at line 41 of file CarrierCustomLibTypes.h.

#define kSprintMCCMNC "310000"

Definition at line 58 of file CarrierCustomLibTypes.h.

#define kVerizonMCCMNC "310555"

Definition at line 59 of file CarrierCustomLibTypes.h.

Typedef Documentation

typedef UInt32 CCSMBrowserFlagsType

Used with CCSMBrowserSettingsEnum

Definition at line 239 of file CarrierCustomLibTypes.h.

typedef void* CCSMCarrierHandle

pointer type to hold the carrier object

Definition at line 64 of file CarrierCustomLibTypes.h.

typedef UInt32 CCSMMessagingFlagsType

Used with CCSMMessagingSettingsEnum

Definition at line 211 of file CarrierCustomLibTypes.h.

typedef UInt32 CCSMPhoneFlagsType

used with CCSMPhoneFlagsEnum

Definition at line 182 of file CarrierCustomLibTypes.h.

typedef UInt32 CCSMRadioBandType

used with CCSMRadioBandEnum

Definition at line 194 of file CarrierCustomLibTypes.h.

typedef UInt16 CCSMSettingsType

used with the settingsTypeEnum

Definition at line 155 of file CarrierCustomLibTypes.h.

typedef UInt32 CCSMSystemFlagsType

Used with CCSMSystemFlagsEnum

Definition at line 166 of file CarrierCustomLibTypes.h.

Enumeration Type Documentation

anonymous enum

Enumeration for the type of carrier settings. The following are applicable to CDMA as well.

We want to keep the groups together. This helps keep track of which structure the setting resides in.

Enumerator:
kCCSMSettingsSystemReserved | system settings place holder
kCCSMSettingsShowNetworkSelect | <Boolean> enable/disable network select
kCCSMSettingsIndicateRoaming | <Boolean> enable/disable roaming indicator
kCCSMSettingsEditableMSISDN | <Boolean> User editable MSISDN
kCCSMSettingsShowEmergencyMode | <Boolean> enable/disable emergency mode indicator
kCCSMSettingsCarrierMSISDN | <char *> carrier MSISDN
kCCSMSettingsRadioBand | <UInt32> radio band to start search with
kCCSMSettingsVoiceMailNumber | <char *> carriers voice mail number
kCCSMSettingsPOP3Server | <char *> pop3 server -- will be deprecated
kCCSMSettingsSMTPServer | <char *> smtp server -- will be deprecated
kCCSMSettingsSMSCNumber | <char *> smsc number
kCCSMSettingsSMSEmailGateway | <char *> sms email gateway
kCCSMSettingsMMSURL | <char *> MMS URL
kCCSMSettingsMMSWAPGateway | <char *> MMS WAP gateway
kCCSMSettingsMMSPort | <UInt32> MMS port number
kCCSMSettingsMMSMaxMsgSize | <UInt32> max MMS message size (kbytes)
kCCSMSettingsPrimaryProxyServer | <char *> Proxy server
kCCSMSettingsPrimaryProxyPort | <UInt32> Proxy port
kCCSMSettingsPrimarySecureProxyServer | <char *> Secure proxy server
kCCSMSettingsPrimarySecureProxyPort | <UInt32> Secure proxy port
kCCSMSettingsSecondaryProxyServer | <char *> Proxy server
kCCSMSettingsSecondaryProxyPort | <UInt32> Proxy port
kCCSMSettingsSecondarySecureProxyServer | <char *> Secure proxy server
kCCSMSettingsSecondarySecureProxyPort | <UInt32> Secure proxy port
kCCMSSettingsPrimaryTrustedDomain | <char *> GSM: Primary trusted domain <char *> CDMA: phone:downloadserver.url
kCCMSSettingsSecondaryTrustedDomain | <char *> GSM Only: Secondary trusted domain
kCCMSSettingsUAProfilingURL | <char *> UA Profiling URL
kCCSMSettingsHTTPHeaders | <char *> carrier specific HTTP headers to send
kCCSMSettingsNAIHeaderFormat | <char *> header format to send NAI (see sprintf format)
kCCSMSettingsMSISDNHeaderFormat | <char *> header format to send MSISDN (see sprintf format)
kCCSMSettingsEncryptMSISDN | <Boolean> encrypt MSISDN header
kCCSMSettingsHomepageURL | <char *> home page string
kCCSMSettingsGPRSAutoAttach | <Boolean> flag whether or not to display the GPRS attached icon
kCCSMSettingsNAI | <char *> Slot 1 username. CDMA only
kCCSMSettingsBrowserFlags | <UInt32> flags that controls browser behaviour
kCCSMSettingsBrowserProxyFlags | <UInt32> flags that controls browser behaviour
kCCSMSettingsProxyUsername | <char *> proxy username
kCCSMSettingsProxyPassword | <char *> password for the proxy
kCCSMSettingsMessagingFlags | <UInt32> messaging flags
kCCSMSettingsSMSMaxMsgSize | <UInt32> max SMS message size (bytes)
kCCSMSettingsSMSValidityPeriod | <UInt32> SMS validity period network specific value
kCCSMSettingsE911Timeout | <UInt32> E911 timeout value (seconds)
kCCSMSettingsMMSUAProf | <char *> UA Prof
kCCSMSettingsMMSUAString | <char *> UA Prof string
kCCSMSettingsMMSMaxVideoSize | <Int32> MMS maximum video size
kCCSMSettingsMMSVersionNumber | <Int32> MMS version (11 = 1.1)
kCCSMSettingsEmailSMTPServer | <char *> SMTP Server
kCCSMSettingsSPNSupported | <Boolean> flag if SPN is supported
kCCSMSettingsWapSupportLevel | <UInt16> WAP level supported.
kCCSMSettingsSMSSupportDeliveryReceipt | <Boolean> WAP level supported.
kCCSMSettingsCSDDisable | <Boolean> CSD disable or not
kCCSMSettingsReserved | reserved

Definition at line 74 of file CarrierCustomLibTypes.h.

00075 {
00076   kCCSMSettingsSystemReserved,         /**< system settings place holder */
00077
00078   //                                         <Data type returned> description
00079   // phone settings
00080   kCCSMSettingsShowNetworkSelect,      /**< <Boolean> enable/disable network select */
00081   kCCSMSettingsIndicateRoaming,        /**< <Boolean> enable/disable roaming indicator */
00082   kCCSMSettingsEditableMSISDN,         /**< <Boolean> User editable MSISDN */
00083   kCCSMSettingsShowEmergencyMode,      /**< <Boolean> enable/disable emergency mode indicator */
00084   kCCSMSettingsCarrierMSISDN,          /**< <char *>  carrier MSISDN */
00085   kCCSMSettingsRadioBand,              /**< <UInt32>  radio band to start search with */
00086   kCCSMSettingsVoiceMailNumber,        /**< <char *>  carriers voice mail number */
00087
00088   // Messaging settings
00089   kCCSMSettingsPOP3Server,             /**< <char *>  pop3 server -- will be deprecated */
00090   kCCSMSettingsSMTPServer,             /**< <char *>  smtp server -- will be deprecated */
00091   kCCSMSettingsSMSCNumber,             /**< <char *>  smsc number */
00092   kCCSMSettingsSMSEmailGateway,        /**< <char *>  sms email gateway */
00093   kCCSMSettingsMMSURL,                 /**< <char *>  MMS URL */
00094   kCCSMSettingsMMSWAPGateway,          /**< <char *>  MMS WAP gateway */
00095   kCCSMSettingsMMSPort,                /**< <UInt32>  MMS port number */
00096   kCCSMSettingsMMSMaxMsgSize,          /**< <UInt32> max MMS message size (kbytes) */
00097
00098   // Browser settings
00099   kCCSMSettingsPrimaryProxyServer,          /**< <char *>  Proxy server */
00100   kCCSMSettingsPrimaryProxyPort,            /**< <UInt32>  Proxy port */
00101   kCCSMSettingsPrimarySecureProxyServer,    /**< <char *>  Secure proxy server */
00102   kCCSMSettingsPrimarySecureProxyPort,      /**< <UInt32>  Secure proxy port */
00103   kCCSMSettingsSecondaryProxyServer,        /**< <char *>  Proxy server */
00104   kCCSMSettingsSecondaryProxyPort,          /**< <UInt32>  Proxy port */
00105   kCCSMSettingsSecondarySecureProxyServer,  /**< <char *>  Secure proxy server */
00106   kCCSMSettingsSecondarySecureProxyPort,    /**< <UInt32>  Secure proxy port */
00107   kCCMSSettingsPrimaryTrustedDomain,        /**< <char *>  GSM:  Primary trusted domain */
00108                                             /**< <char *>  CDMA: phone:downloadserver.url */
00109
00110   kCCMSSettingsSecondaryTrustedDomain,      /**< <char *>  GSM Only: Secondary trusted domain */
00111   kCCMSSettingsUAProfilingURL,              /**< <char *>  UA Profiling URL */
00112   kCCSMSettingsHTTPHeaders,                 /**< <char *>  carrier specific HTTP headers to send */
00113   kCCSMSettingsNAIHeaderFormat,             /**< <char *>  header format to send NAI (see sprintf format) */
00114   kCCSMSettingsMSISDNHeaderFormat,          /**< <char *>  header format to send MSISDN (see sprintf format) */
00115   kCCSMSettingsEncryptMSISDN,               /**< <Boolean> encrypt MSISDN header */
00116   kCCSMSettingsHomepageURL,                 /**< <char *> home page string */
00117
00118   // network settings
00119   kCCSMSettingsGPRSAutoAttach,              /**< <Boolean> flag whether or not to display the GPRS attached icon  */
00120
00121   // NVRAM settings.
00122   kCCSMSettingsNAI,                         /**< <char *> Slot 1 username.  CDMA only */
00123
00124   // new items
00125   kCCSMSettingsBrowserFlags,                /**< <UInt32> flags that controls browser behaviour */
00126   kCCSMSettingsBrowserProxyFlags,           /**< <UInt32> flags that controls browser behaviour */
00127
00128   kCCSMSettingsProxyUsername,               /**< <char *> proxy username */
00129   kCCSMSettingsProxyPassword,               /**< <char *> password for the proxy */
00130   kCCSMSettingsMessagingFlags,              /**< <UInt32> messaging flags */
00131   kCCSMSettingsSMSMaxMsgSize,               /**< <UInt32> max SMS message size (bytes) */
00132   kCCSMSettingsSMSValidityPeriod,           /**< <UInt32> SMS validity period network specific value */
00133   kCCSMSettingsE911Timeout,                 /**< <UInt32> E911 timeout value (seconds) */
00134
00135   // MMS Settings
00136   kCCSMSettingsMMSUAProf,                   /**< <char *> UA Prof */
00137   kCCSMSettingsMMSUAString,                 /**< <char *> UA Prof string*/
00138   kCCSMSettingsMMSMaxVideoSize,             /**< <Int32> MMS maximum video size */
00139   kCCSMSettingsMMSVersionNumber,            /**< <Int32> MMS version (11 = 1.1) */
00140
00141   // Email settings
00142   kCCSMSettingsEmailSMTPServer,             /**< <char *> SMTP Server */
00143
00144   // extra phone settings
00145   kCCSMSettingsSPNSupported,                /**< <Boolean> flag if SPN is supported */
00146
00147   kCCSMSettingsWapSupportLevel,             /**< <UInt16> WAP level supported. */
00148
00149   kCCSMSettingsSMSSupportDeliveryReceipt,   /**< <Boolean> WAP level supported. */
00150
00151   kCCSMSettingsCSDDisable,                  /**< <Boolean> CSD disable or not */
00152
00153   kCCSMSettingsReserved = 0x8000      /**< reserved */
00154 };

enum CCSMBrowserSettingsEnum

enumeration for the browser settings flags

Enumerator:
kCCSMBrowserSettingsReserved | reserved setting
kCCSMBrowserSettingsEncryptMSISDN | send encrypted MSISDN
kCCSMBrowserSettingsCSDDisconnectOnExit | disconnect on exit for CSD connections
kCCSMBrowserSettingsPDataDisconnectOnExit | disconnect on exit for packet data connections
kCCSMBrowserSettingsDormantOnExit | force dormancy on exit
kCCSMBrowserSettingsHideDisconnect | hide disconnect button
kCCSMBrowserSettingsVersionInWAPProfile | Add version in WAP profile header
kCCSMPrimaryProxyAuthenticate | proxy properties
kCCSMPrimaryProxyLocked | proxy properties
kCCSMPrimaryProxyHide | proxy properties
kCCSMSecondaryProxyAuthenticate | proxy properties
kCCSMSecondaryProxyLocked | proxy properties
kCCSMSecondaryProxyHide | proxy properties

Definition at line 217 of file CarrierCustomLibTypes.h.

00218 {
00219   kCCSMBrowserSettingsReserved              = 0x00000000,  /**< reserved setting */
00220   kCCSMBrowserSettingsEncryptMSISDN         = 0x00000001,  /**< send encrypted MSISDN */
00221   kCCSMBrowserSettingsCSDDisconnectOnExit   = 0x00000002,  /**< disconnect on exit for CSD connections */
00222   kCCSMBrowserSettingsPDataDisconnectOnExit = 0x00000004,  /**< disconnect on exit for packet data connections */
00223   kCCSMBrowserSettingsDormantOnExit         = 0x00000008,  /**< force dormancy on exit */
00224
00225   kCCSMBrowserSettingsHideDisconnect        = 0x00000010,  /**< hide disconnect button */
00226   kCCSMBrowserSettingsVersionInWAPProfile   = 0x00000020,  /**< Add version in WAP profile header */
00227
00228
00229
00230   kCCSMPrimaryProxyAuthenticate             = 0x00000001,  /**< proxy properties */
00231   kCCSMPrimaryProxyLocked                   = 0x00000002,  /**< proxy properties */
00232   kCCSMPrimaryProxyHide                     = 0x00000004,  /**< proxy properties */
00233
00234   kCCSMSecondaryProxyAuthenticate           = 0x00010000,  /**< proxy properties */
00235   kCCSMSecondaryProxyLocked                 = 0x00020000,  /**< proxy properties */
00236   kCCSMSecondaryProxyHide                   = 0x00040000   /**< proxy properties */
00237 }

enum CCSMMessagingSettingsEnum

enumeration for the messaging settings flags

Enumerator:
kCCSMMessagingSettingsReserved | reserved setting
kCCSMMessagingSettingsStripPhonePlus | does the network require the phone number to be stripped
kCCSMMessagingSettings11DigitRecipient | flag if a number requires 10 or 11 digits (I assume US only)
kCCSMMessagingSettingsNormaliseMMSAddress | Flag if MMS address should be normalised or not
kCCSMMessagingSettingsWAPProtocol20 | *internal* Use WAP 2.0 for MMS?
kCCSMMessagingSettingsDisableMMSFallback | Flag to disable the fallback account when connecting

Definition at line 199 of file CarrierCustomLibTypes.h.

00200 {
00201   kCCSMMessagingSettingsReserved              = 0x00000000,  /**< reserved setting */
00202   kCCSMMessagingSettingsStripPhonePlus        = 0x00000001,  /**< does the network require the phone number to be stripped */
00203   kCCSMMessagingSettings11DigitRecipient      = 0x00000002,  /**< flag if a number requires 10 or 11 digits (I assume US only) */
00204   kCCSMMessagingSettingsNormaliseMMSAddress   = 0x00000004,  /**< Flag if MMS address should be normalised or not */
00205   kCCSMMessagingSettingsWAPProtocol20         = 0x00000008,  /**< *internal* Use WAP 2.0 for MMS? */
00206   kCCSMMessagingSettingsDisableMMSFallback    = 0x00000010   /**< Flag to disable the fallback account when connecting */
00207
00208   //  kCCSMMessagingSettingsCameraProtocol        = 0x00000020,  /**< *internal* Use lightsurf or not */
00209 }

enum CCSMPhoneFlagsEnum

enumeration for the phone settings flags

Enumerator:
kCCSMPhoneSettingsReserved | reserved setting
kCCSMPhoneSettingsNetworkSelect | Network Select disable/enable
kCCSMPhoneSettingsRoamingIndicator | Roaming indicator yes/no
kCCSMPhoneSettingsEditMSISDN | Editable MSISDN
kCCSMPhoneSettingsShowEmergencyMode | use Emergency mode
kCCSMPhoneSettingsEnableTTY | enable TTY
kCCSMPhoneSettingsUseEFSPN | Use EF SPN if any

Definition at line 171 of file CarrierCustomLibTypes.h.

00172 {
00173   kCCSMPhoneSettingsReserved          = 0x00000000,  /**< reserved setting */
00174   kCCSMPhoneSettingsNetworkSelect     = 0x00000001,  /**< Network Select disable/enable */
00175   kCCSMPhoneSettingsRoamingIndicator  = 0x00000002,  /**< Roaming indicator yes/no */
00176   kCCSMPhoneSettingsEditMSISDN        = 0x00000004,  /**< Editable MSISDN */
00177   kCCSMPhoneSettingsShowEmergencyMode = 0x00000008,  /**< use Emergency mode */
00178   kCCSMPhoneSettingsEnableTTY         = 0x00000010,  /**< enable TTY */
00179   kCCSMPhoneSettingsUseEFSPN          = 0x00000020   /**< Use EF SPN if any */
00180 }

enum CCSMRadioBandEnum

enumeration for the radio band Used to optimize which band the radio starts scanning on.

Enumerator:
kCCSMRadioBandUnknown | unknown radio band
kCCSMRadioBandEurope | european radio
kCCSMRadioBandNorthAmerica | north american radio

Definition at line 187 of file CarrierCustomLibTypes.h.

00188 {
00189   kCCSMRadioBandUnknown,        /**< unknown radio band */
00190   kCCSMRadioBandEurope,         /**< european radio */
00191   kCCSMRadioBandNorthAmerica    /**< north american radio */
00192 }

enum CCSMSystemFlagsEnum

system settings

Enumerator:
kCCSMSystemSettingReserved reserved setting

Definition at line 161 of file CarrierCustomLibTypes.h.

00162 {
00163   kCCSMSystemSettingReserved  = 0x00000000  /**< reserved setting */
00164 }

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:56 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » address » 2.0 » pub

Contacts.h File Reference

Include dependency graph for Contacts.h:

Go to the source code of this file.

Defines

  • #define CONTACTS_LIB_TRAP SYS_TRAP
  • #define ContactsLibCreatorID 'P1CT'
  • #define ContactsLibTypeID sysFileTLibrary
  • #define ContactsLibName "ContactsLib-P1CT"
  • #define ContactsLibErrorClass (appErrorClass | 0x7300)
  • #define ContactsLibErrTooManyClients (ContactsLibErrorClass | 1)
  • #define ContactsLibErrInvalidHandle (ContactsLibErrorClass | 2)
  • #define ContactsLibErrInvalidParam (ContactsLibErrorClass | 3)
  • #define ContactsLibErrUIdNotFound (ContactsLibErrorClass | 4)
  • #define ContactsLibErrCategoryNotFound (ContactsLibErrorClass | 5)
  • #define ContactsLibErrLibAlreadyInUse (ContactsLibErrorClass | 6)
  • #define ContactsLibErrVerNotSupported (ContactsLibErrorClass | 7)
  • #define ContactsLibErrOutOfMemory (ContactsLibErrorClass | 8)
  • #define ContactsLibErrSizeParamOverFlow (ContactsLibErrorClass | 9)
  • #define ContactsLibErrEmptyContact (ContactsLibErrorClass | 10)
  • #define ContactsLibErrInvalidReference (ContactsLibErrorClass | 11)
  • #define ContactsLibErrContactNotFound (ContactsLibErrorClass | 12)
  • #define ContactsLibErrAttachAlreadyExist (ContactsLibErrorClass | 13)
  • #define ContactsLibErrAttachNotExist (ContactsLibErrorClass | 14)
  • #define ContactsLibErrAttachOverFlow (ContactsLibErrorClass | 15)
  • #define ContactsLibErrRecordNotFound (ContactsLibErrorClass | 16)
  • #define ContactsLibErrAttachOverflow (ContactsLibErrorClass | 17)
  • #define ContactsLibErrInvalidField (ContactsLibErrorClass | 18)
  • #define ContactsLibErrTooManySession (ContactsLibErrorClass | 19)
  • #define ContactsLibErrAlreadyInWriteMode (ContactsLibErrorClass | 20)
  • #define ContactsLibErrInvalidSessionHandle (ContactsLibErrorClass | 21)
  • #define ContactsLibErrFieldNotFound (ContactsLibErrorClass | 23)
  • #define ContactsLibErrStringNotFound (ContactsLibErrorClass | 24)
  • #define ContactsLibErrInvalidAppInfoBlock (ContactsLibErrorClass | 25)
  • #define ContactsLibErrAppInfoIsMising (ContactsLibErrorClass | 26)
  • #define ContactsLibErrReadOnlySession (ContactsLibErrorClass | 27)
  • #define ContactsLibErrUIdExist (ContactsLibErrorClass | 28)
  • #define ContactsLibErrMaxLimitReached (ContactsLibErrorClass | 29)
  • #define ContactsLibErrListNotExist (ContactsLibErrorClass | 30)
  • #define ContactsLibErrContactNotLocked (ContactsLibErrorClass | 31)
  • #define ContactsLibErrLibStillOpen (ContactsLibErrorClass | 32)
  • #define PALM_OS
  • #define ContactsNumCategories dmRecNumCategories
  • #define ContactsAllCategories dmAllCategories
  • #define ContactsUnfiledCategory dmUnfiledCategory
  • #define ContactsSeekForward dmSeekForward
  • #define ContactsSeekBackward dmSeekBackward
  • #define ContactsLabelLength 16
  • #define ContactsLibTrapGetVersion (sysLibTrapCustom)
  • #define ContactsLibTrapOpenSession (sysLibTrapCustom + 23)
  • #define ContactsLibTrapCloseSession (sysLibTrapCustom + 24)
  • #define ContactsLibTrapCreateHandle (sysLibTrapCustom + 90)
  • #define ContactsLibTrapReleaseHandle (sysLibTrapCustom + 4)
  • #define ContactsLibTrapAddContact (sysLibTrapCustom + 8)
  • #define ContactsLibTrapUpdateContact (sysLibTrapCustom + 7)
  • #define ContactsLibTrapDeleteContact (sysLibTrapCustom + 9)
  • #define ContactsLibTrapGetContact (sysLibTrapCustom + 12)
  • #define ContactsLibTrapGetNumOfRecord (sysLibTrapCustom + 28)
  • #define ContactsLibTrapSeekRecord (sysLibTrapCustom + 35)
  • #define ContactsLibTrapGetFirstContact (sysLibTrapCustom + 10)
  • #define ContactsLibTrapGetNextContact (sysLibTrapCustom + 11)
  • #define ContactsLibTrapDoesFieldExist (sysLibTrapCustom + 36)
  • #define ContactsLibTrapIsEmptyContact (sysLibTrapCustom + 30)
  • #define ContactsLibTrapSetUInt8Field (sysLibTrapCustom + 51)
  • #define ContactsLibTrapSetUInt16Field (sysLibTrapCustom + 53)
  • #define ContactsLibTrapSetDateField (sysLibTrapCustom + 55)
  • #define ContactsLibTrapSetStringField (sysLibTrapCustom + 57)
  • #define ContactsLibTrapSetBinaryField (sysLibTrapCustom + 59)
  • #define ContactsLibTrapGetUInt8Field (sysLibTrapCustom + 50)
  • #define ContactsLibTrapGetUInt16Field (sysLibTrapCustom + 52)
  • #define ContactsLibTrapGetUInt32Field (sysLibTrapCustom + 63)
  • #define ContactsLibTrapGetDateField (sysLibTrapCustom + 54)
  • #define ContactsLibTrapGetStringField (sysLibTrapCustom + 56)
  • #define ContactsLibTrapGetBinaryField (sysLibTrapCustom + 58)
  • #define ContactsLibTrapGetFieldLabel (sysLibTrapCustom + 31)
  • #define ContactsLibTrapSetFieldLabel (sysLibTrapCustom + 32)
  • #define ContactsLibTrapGetLabelText (sysLibTrapCustom + 82)
  • #define ContactsLibTrapRenameCustomLabel (sysLibTrapCustom + 33)
  • #define ContactsLibTrapGetCategoryList (sysLibTrapCustom + 2)
  • #define ContactsLibTrapGetNextCategory (sysLibTrapCustom + 37)
  • #define ContactsLibTrapGetCategoryName (sysLibTrapCustom + 27)
  • #define ContactsLibTrapSetCategoryName (sysLibTrapCustom + 38)
  • #define ContactsLibTrapCategoryFind (sysLibTrapCustom + 39)
  • #define ContactsLibTrapPosInCategory (sysLibTrapCustom + 48)
  • #define ContactsLibTrapGetRingtoneForCategory (sysLibTrapCustom + 91)
  • #define ContactsLibTrapLookUpString (sysLibTrapCustom + 40)
  • #define ContactsLibGetLastErr (sysLibTrapCustom + 64)

Typedefs

  • typedef MemHandle ContactsContHandle
  • typedef MemHandle ContactsSession
  • typedef DateType ContactsDateType
  • typedef char ContactsLabel [ContactsLabelLength]
  • typedef enum ContactsLabelTypes ContactsLabelType

Enumerations

  • enum ContactsLibFieldLabels {
    contactsNoType,
    contactsWorkPhone,
    contactsHomePhone,
    contactsFaxPhone,
    contactsOtherPhone,
    contactsEmailPhone,
    contactsMainPhone,
    contactsPagerPhone,
    contactsMobilePhone,
    contactsOtherChat,
    contactsAimChat,
    contactsMsnChat,
    contactsYahooChat,
    contactsIcqChat,
    contactsWorkAddress,
    contactsHomeAddress,
    contactsOtherAddress
    }
  • enum ContactsLibAllFields {
    contactsLastName,
    contactsFirstName,
    contactsCompany,
    contactsTitle,
    contactsPhone1,
    contactsPhone2,
    contactsPhone3,
    contactsPhone4,
    contactsPhone5,
    contactsPhone6,
    contactsPhone7,
    contactsChat1,
    contactsChat2,
    contactsWebpage,
    contactsCustom1,
    contactsCustom2,
    contactsCustom3,
    contactsCustom4,
    contactsCustom5,
    contactsCustom6,
    contactsCustom7,
    contactsCustom8,
    contactsCustom9,
    contactsAddress1,
    contactsCity1,
    contactsState1,
    contactsZipCode1,
    contactsCountry1,
    contactsAddress2,
    contactsCity2,
    contactsState2,
    contactsZipCode2,
    contactsCountry2,
    contactsAddress3,
    contactsCity3,
    contactsState3,
    contactsZipCode3,
    contactsCountry3,
    contactsNote,
    contactsBirthdate,
    contactsBirthdayMask,
    contactsBirthdayPreset,
    contactsPicture,
    contactsUniqueID = contactsPicture + 2,
    contactsIndex,
    contactsCategoryID,
    contactsPrivate = contactsCategoryID + 2,
    contactsBusy,
    contactsDirty,
    contactsRingtoneInfo = contactsDirty + 4,
    contactsAnniversaryDate,
    contactsAnniversaryMask,
    contactsAnniversaryPreset,
    contactsNumFields
    }
  • enum ContactsLibStrFields {
    contactsStrLastName,
    contactsStrFirstName,
    contactsStrCompany,
    contactsStrTitle,
    contactsStrPhone1,
    contactsStrPhone2,
    contactsStrPhone3,
    contactsStrPhone4,
    contactsStrPhone5,
    contactsStrPhone6,
    contactsStrPhone7,
    contactsStrChat1,
    contactsStrChat2,
    contactsStrWebpage,
    contactsStrCustom1,
    contactsStrCustom2,
    contactsStrCustom3,
    contactsStrCustom4,
    contactsStrCustom5,
    contactsStrCustom6,
    contactsStrCustom7,
    contactsStrCustom8,
    contactsStrCustom9,
    contactsStrAddress1,
    contactsStrCity1,
    contactsStrState1,
    contactsStrZipCode1,
    contactsStrCountry1,
    contactsStrAddress2,
    contactsStrCity2,
    contactsStrState2,
    contactsStrZipCode2,
    contactsStrCountry2,
    contactsStrAddress3,
    contactsStrCity3,
    contactsStrState3,
    contactsStrZipCode3,
    contactsStrCountry3,
    contactsStrNote
    }
  • enum ContactsLibCustomFields {
    contactsCustomCustom1 = contactsCustom1,
    contactsCustomCustom2,
    contactsCustomCustom3,
    contactsCustomCustom4,
    contactsCustomCustom5,
    contactsCustomCustom6,
    contactsCustomCustom7,
    contactsCustomCustom8,
    contactsCustomCustom9
    }
  • enum ContactsLibWithLabelFields {
    contactsWithLabelPhone1 = contactsPhone1,
    contactsWithLabelPhone2,
    contactsWithLabelPhone3,
    contactsWithLabelPhone4,
    contactsWithLabelPhone5,
    contactsWithLabelPhone6,
    contactsWithLabelPhone7,
    contactsWithLabelChat1,
    contactsWithLabelChat2,
    contactsWithLabelAddress1 = contactsAddress1,
    contactsWithLabelAddress2 = contactsAddress2,
    contactsWithLabelAddress3 = contactsAddress3
    }
  • enum ContactsLabelTypes {
    ContactsChatLabel,
    ContactsAddressLabel,
    ContactsPhoneLabel
    }
  • enum ContactsLibDateFields {
    contactsDateBirthdate = contactsBirthdate,
    contactsDateAnniversary = contactsAnniversaryDate
    }
  • enum ContactsLibUInt16Fields {
    contactsUInt16Index = contactsIndex,
    contactsUInt16Category = contactsCategoryID
    }
  • enum ContactsLibUInt32Fields { contactsUInt32UniqueID = contactsUniqueID }
  • enum ContactsLibUInt8Fields {
    contactsUInt8Private = contactsPrivate,
    contactsUInt8Busy,
    contactsUInt8Dirty,
    contactsUInt8BirthdayMask = contactsBirthdayMask,
    contactsUInt8BirthdayPreset,
    contactsUInt8AnniversaryMask = contactsAnniversaryMask,
    contactsUInt8AnniversaryPreset
    }
  • enum ContactsLibBinaryFields {
    contactsBinaryPictureData = contactsPicture,
    contactsBinaryRingtoneIdentifier = contactsRingtoneInfo
    }
  • enum SessionMode {
    ContactsLibSessionModeReadOnly = 0x0001,
    ContactsLibSessionModeReadWrite = 0x0003
    }

Functions

  • __inline Err ContactsLib_OpenLibrary (UInt16 *refNumP)
  • __inline Err ContactsLib_CloseLibrary (UInt16 *refNumP)
  • UInt32 ContactsGetVersion (UInt16 libRefnum) CONTACTS_LIB_TRAP(ContactsLibTrapGetVersion)
  • ContactsSession ContactsOpenSession (UInt16 libRefnum, SessionMode mode) CONTACTS_LIB_TRAP(ContactsLibTrapOpenSession)
  • Err ContactsCloseSession (UInt16 libRefnum, ContactsSession hCurSession) CONTACTS_LIB_TRAP(ContactsLibTrapCloseSession)
  • ContactsContHandle ContactsCreateHandle (UInt16 libRefnum, ContactsSession hSession) CONTACTS_LIB_TRAP(ContactsLibTrapCreateHandle)
  • Err ContactsReleaseHandle (UInt16 libRefnum, ContactsContHandle hContact) CONTACTS_LIB_TRAP(ContactsLibTrapReleaseHandle)
  • Err ContactsAddContact (UInt16 libRefnum, ContactsSession hSession, ContactsContHandle hContact) CONTACTS_LIB_TRAP(ContactsLibTrapAddContact)
  • Err ContactsUpdateContact (UInt16 libRefnum, ContactsSession hSession, ContactsContHandle hContact) CONTACTS_LIB_TRAP(ContactsLibTrapUpdateContact)
  • Err ContactsDeleteContact (UInt16 libRefnum, ContactsSession hSession, ContactsContHandle hContact, Boolean archive) CONTACTS_LIB_TRAP(ContactsLibTrapDeleteContact)
  • ContactsContHandle ContactsGetContact (UInt16 libRefnum, ContactsSession hSession, UInt16 *indexP, UInt32 *uniqueIDP, Boolean ignored) CONTACTS_LIB_TRAP(ContactsLibTrapGetContact)
  • UInt16 ContactsGetNumRecords (UInt16 libRefnum, ContactsSession hSession, UInt16 category) CONTACTS_LIB_TRAP(ContactsLibTrapGetNumOfRecord)
  • UInt16 ContactsPosInCategory (UInt16 libRefnum, ContactsSession hSession, ContactsContHandle hContact, UInt16 *pIndex, UInt16 category) CONTACTS_LIB_TRAP(ContactsLibTrapPosInCategory)
  • Boolean ContactsSeekRecord (UInt16 libRefnum, ContactsSession hSession, UInt16 *indexP, UInt16 offset, Int16 direction, UInt16 category) CONTACTS_LIB_TRAP(ContactsLibTrapSeekRecord)
  • ContactsContHandle ContactsGetFirstContact (UInt16 libRefnum, ContactsSession hSession, UInt16 category) CONTACTS_LIB_TRAP(ContactsLibTrapGetFirstContact)
  • ContactsContHandle ContactsGetNextContact (UInt16 libRefnum, ContactsSession hSession, ContactsContHandle hSourceContact, UInt16 Category) CONTACTS_LIB_TRAP(ContactsLibTrapGetNextContact)
  • Boolean ContactsDoesFieldExist (UInt16 libRefnum, ContactsContHandle hContact, ContactsLibAllFields NameOfField) CONTACTS_LIB_TRAP(ContactsLibTrapDoesFieldExist)
  • Boolean ContactsIsEmptyContact (UInt16 libRefnum, ContactsSession hSession, ContactsContHandle hCont, UInt16 *Index, UInt32 *UniqueID) CONTACTS_LIB_TRAP(ContactsLibTrapIsEmptyContact)
  • Err ContactsSetUInt8Field (UInt16 libRefnum, ContactsContHandle hContact, ContactsLibUInt8Fields nameOfField, UInt8 fieldValue) CONTACTS_LIB_TRAP(ContactsLibTrapSetUInt8Field)
  • Err ContactsSetUInt16Field (UInt16 libRefnum, ContactsContHandle hContact, ContactsLibUInt16Fields NameOfField, UInt16 FieldValue) CONTACTS_LIB_TRAP(ContactsLibTrapSetUInt16Field)
  • Err ContactsSetDateField (UInt16 libRefnum, ContactsContHandle hContact, ContactsLibDateFields nameOfField, ContactsDateType fieldValue) CONTACTS_LIB_TRAP(ContactsLibTrapSetDateField)
  • Err ContactsSetStringField (UInt16 libRefnum, ContactsContHandle hContact, ContactsLibStrFields nameOfField, char *FieldValue) CONTACTS_LIB_TRAP(ContactsLibTrapSetStringField)
  • Err ContactsSetBinaryField (UInt16 libRefnum, ContactsContHandle hContact, ContactsLibBinaryFields NameOfField, void *pFieldData, UInt16 DataSize) CONTACTS_LIB_TRAP(ContactsLibTrapSetBinaryField)
  • Err ContactsGetUInt8Field (UInt16 libRefnum, ContactsContHandle hContact, ContactsLibUInt8Fields NameOfField, UInt8 *pFieldValue) CONTACTS_LIB_TRAP(ContactsLibTrapGetUInt8Field)
  • Err ContactsGetUInt16Field (UInt16 libRefnum, ContactsContHandle hContact, ContactsLibUInt16Fields NameOfField, UInt16 *pFieldValue) CONTACTS_LIB_TRAP(ContactsLibTrapGetUInt16Field)
  • Err ContactsGetUInt32Field (UInt16 libRefnum, ContactsContHandle hContact, ContactsLibUInt32Fields NameOfField, UInt32 *pFieldValue) CONTACTS_LIB_TRAP(ContactsLibTrapGetUInt32Field)
  • Err ContactsGetDateField (UInt16 libRefnum, ContactsContHandle hContact, ContactsLibDateFields NameOfField, DateType *pFieldValue) CONTACTS_LIB_TRAP(ContactsLibTrapGetDateField)
  • Err ContactsGetStringField (UInt16 libRefnum, ContactsContHandle hContact, ContactsLibStrFields NameOfField, char **pFieldValue) CONTACTS_LIB_TRAP(ContactsLibTrapGetStringField)
  • void * ContactsGetBinaryField (UInt16 libRefnum, ContactsContHandle hContact, ContactsLibBinaryFields NameOfField, UInt16 *pDataSize) CONTACTS_LIB_TRAP(ContactsLibTrapGetBinaryField)
  • Err ContactsGetRingtoneForCategory (UInt16 libRefnum, UInt16 categoryID, void *tone) CONTACTS_LIB_TRAP(ContactsLibTrapGetRingtoneForCategory)
  • Int16 ContactsGetFieldLabel (UInt16 libRefnum, ContactsContHandle hContact, ContactsLibWithLabelFields FieldNum) CONTACTS_LIB_TRAP(ContactsLibTrapGetFieldLabel)
  • void ContactsSetFieldLabel (UInt16 libRefnum, ContactsContHandle hToCont, ContactsLibWithLabelFields FieldNum, Int16 LabelIndex) CONTACTS_LIB_TRAP(ContactsLibTrapSetFieldLabel)
  • char * ContactsGetLabelText (UInt16 libRefnum, ContactsSession hSession, ContactsLabelType type, UInt16 labelNum, UInt16 *pSizeOfBuffer) CONTACTS_LIB_TRAP(ContactsLibTrapGetLabelText)
  • Err ContactsRenameCustomLabel (UInt16 libRefnum, ContactsSession hSession, ContactsLibCustomFields fieldNum, Char *fieldLabel) CONTACTS_LIB_TRAP(ContactsLibTrapRenameCustomLabel)
  • void ContactsGetCategoryList (UInt16 libRefnum, ContactsSession hSession, char *pCategoryList[ContactsNumCategories]) CONTACTS_LIB_TRAP(ContactsLibTrapGetCategoryList)
  • UInt16 ContactsGetNextCategory (UInt16 libRefnum, ContactsSession hSession, UInt16 currentCategory) CONTACTS_LIB_TRAP(ContactsLibTrapGetNextCategory)
  • Char * ContactsGetCategoryName (UInt16 libRefnum, ContactsSession hSession, UInt16 categoryIndex) CONTACTS_LIB_TRAP(ContactsLibTrapGetCategoryName)
  • void ContactsSetCategoryName (UInt16 libRefnum, ContactsSession hSession, UInt16 categoryIndex, const Char *pCatName) CONTACTS_LIB_TRAP(ContactsLibTrapGetCategoryName)
  • UInt16 ContactsCategoryFind (UInt16 libRefnum, ContactsSession hSession, const Char *pCatName) CONTACTS_LIB_TRAP(ContactsLibTrapCategoryFind)
  • ContactsContHandle ContactsLookUpString (UInt16 libRefnum, ContactsSession hSession, Char *key, Boolean sortByCompany, UInt16 category, Boolean *completeMatch, UInt16 *pNumMatchingChars, Boolean masked) CONTACTS_LIB_TRAP(ContactsLibTrapLookUpString)
  • Err ContactsGetLastError (UInt16 libRefnum) CONTACTS_LIB_TRAP(ContactsLibGetLastErr)

Define Documentation

#define CONTACTS_LIB_TRAP SYS_TRAP

Definition at line 38 of file Contacts.h.

#define ContactsAllCategories dmAllCategories

Definition at line 94 of file Contacts.h.

#define ContactsLabelLength 16

Definition at line 102 of file Contacts.h.

#define ContactsLibCreatorID 'P1CT'

Definition at line 43 of file Contacts.h.

Referenced by ContactsLib_OpenLibrary().

#define ContactsLibErrAlreadyInWriteMode (ContactsLibErrorClass | 20)

Definition at line 74 of file Contacts.h.

#define ContactsLibErrAppInfoIsMising (ContactsLibErrorClass | 26)

Definition at line 79 of file Contacts.h.

#define ContactsLibErrAttachAlreadyExist (ContactsLibErrorClass | 13)

Definition at line 67 of file Contacts.h.

#define ContactsLibErrAttachNotExist (ContactsLibErrorClass | 14)

Definition at line 68 of file Contacts.h.

#define ContactsLibErrAttachOverflow (ContactsLibErrorClass | 17)

Definition at line 71 of file Contacts.h.

#define ContactsLibErrAttachOverFlow (ContactsLibErrorClass | 15)

Definition at line 69 of file Contacts.h.

#define ContactsLibErrCategoryNotFound (ContactsLibErrorClass | 5)

Definition at line 59 of file Contacts.h.

#define ContactsLibErrContactNotFound (ContactsLibErrorClass | 12)

Definition at line 66 of file Contacts.h.

#define ContactsLibErrContactNotLocked (ContactsLibErrorClass | 31)

Definition at line 84 of file Contacts.h.

#define ContactsLibErrEmptyContact (ContactsLibErrorClass | 10)

Definition at line 64 of file Contacts.h.

#define ContactsLibErrFieldNotFound (ContactsLibErrorClass | 23)

Definition at line 76 of file Contacts.h.

#define ContactsLibErrInvalidAppInfoBlock (ContactsLibErrorClass | 25)

Definition at line 78 of file Contacts.h.

#define ContactsLibErrInvalidField (ContactsLibErrorClass | 18)

Definition at line 72 of file Contacts.h.

#define ContactsLibErrInvalidHandle (ContactsLibErrorClass | 2)

Definition at line 56 of file Contacts.h.

#define ContactsLibErrInvalidParam (ContactsLibErrorClass | 3)

Definition at line 57 of file Contacts.h.

#define ContactsLibErrInvalidReference (ContactsLibErrorClass | 11)

Definition at line 65 of file Contacts.h.

#define ContactsLibErrInvalidSessionHandle (ContactsLibErrorClass | 21)

Definition at line 75 of file Contacts.h.

#define ContactsLibErrLibAlreadyInUse (ContactsLibErrorClass | 6)

Definition at line 60 of file Contacts.h.

#define ContactsLibErrLibStillOpen (ContactsLibErrorClass | 32)

Definition at line 85 of file Contacts.h.

Referenced by ContactsLib_CloseLibrary().

#define ContactsLibErrListNotExist (ContactsLibErrorClass | 30)

Definition at line 83 of file Contacts.h.

#define ContactsLibErrMaxLimitReached (ContactsLibErrorClass | 29)

Definition at line 82 of file Contacts.h.

#define ContactsLibErrorClass (appErrorClass | 0x7300)

Definition at line 54 of file Contacts.h.

#define ContactsLibErrOutOfMemory (ContactsLibErrorClass | 8)

Definition at line 62 of file Contacts.h.

#define ContactsLibErrReadOnlySession (ContactsLibErrorClass | 27)

Definition at line 80 of file Contacts.h.

#define ContactsLibErrRecordNotFound (ContactsLibErrorClass | 16)

Definition at line 70 of file Contacts.h.

#define ContactsLibErrSizeParamOverFlow (ContactsLibErrorClass | 9)

Definition at line 63 of file Contacts.h.

#define ContactsLibErrStringNotFound (ContactsLibErrorClass | 24)

Definition at line 77 of file Contacts.h.

#define ContactsLibErrTooManyClients (ContactsLibErrorClass | 1)

Definition at line 55 of file Contacts.h.

#define ContactsLibErrTooManySession (ContactsLibErrorClass | 19)

Definition at line 73 of file Contacts.h.

#define ContactsLibErrUIdExist (ContactsLibErrorClass | 28)

Definition at line 81 of file Contacts.h.

#define ContactsLibErrUIdNotFound (ContactsLibErrorClass | 4)

Definition at line 58 of file Contacts.h.

#define ContactsLibErrVerNotSupported (ContactsLibErrorClass | 7)

Definition at line 61 of file Contacts.h.

#define ContactsLibGetLastErr (sysLibTrapCustom + 64)

Definition at line 372 of file Contacts.h.

#define ContactsLibName "ContactsLib-P1CT"

Definition at line 49 of file Contacts.h.

Referenced by ContactsLib_OpenLibrary().

#define ContactsLibTrapAddContact (sysLibTrapCustom + 8)

Definition at line 327 of file Contacts.h.

#define ContactsLibTrapCategoryFind (sysLibTrapCustom + 39)

Definition at line 365 of file Contacts.h.

#define ContactsLibTrapCloseSession (sysLibTrapCustom + 24)

Definition at line 322 of file Contacts.h.

#define ContactsLibTrapCreateHandle (sysLibTrapCustom + 90)

Definition at line 324 of file Contacts.h.

#define ContactsLibTrapDeleteContact (sysLibTrapCustom + 9)

Definition at line 329 of file Contacts.h.

#define ContactsLibTrapDoesFieldExist (sysLibTrapCustom + 36)

Definition at line 338 of file Contacts.h.

#define ContactsLibTrapGetBinaryField (sysLibTrapCustom + 58)

Definition at line 353 of file Contacts.h.

#define ContactsLibTrapGetCategoryList (sysLibTrapCustom + 2)

Definition at line 361 of file Contacts.h.

#define ContactsLibTrapGetCategoryName (sysLibTrapCustom + 27)

Definition at line 363 of file Contacts.h.

#define ContactsLibTrapGetContact (sysLibTrapCustom + 12)

Definition at line 331 of file Contacts.h.

#define ContactsLibTrapGetDateField (sysLibTrapCustom + 54)

Definition at line 351 of file Contacts.h.

#define ContactsLibTrapGetFieldLabel (sysLibTrapCustom + 31)

Definition at line 355 of file Contacts.h.

#define ContactsLibTrapGetFirstContact (sysLibTrapCustom + 10)

Definition at line 334 of file Contacts.h.

#define ContactsLibTrapGetLabelText (sysLibTrapCustom + 82)

Definition at line 357 of file Contacts.h.

#define ContactsLibTrapGetNextCategory (sysLibTrapCustom + 37)

Definition at line 362 of file Contacts.h.

#define ContactsLibTrapGetNextContact (sysLibTrapCustom + 11)

Definition at line 335 of file Contacts.h.

#define ContactsLibTrapGetNumOfRecord (sysLibTrapCustom + 28)

Definition at line 332 of file Contacts.h.

#define ContactsLibTrapGetRingtoneForCategory (sysLibTrapCustom + 91)

Definition at line 368 of file Contacts.h.

#define ContactsLibTrapGetStringField (sysLibTrapCustom + 56)

Definition at line 352 of file Contacts.h.

#define ContactsLibTrapGetUInt16Field (sysLibTrapCustom + 52)

Definition at line 349 of file Contacts.h.

#define ContactsLibTrapGetUInt32Field (sysLibTrapCustom + 63)

Definition at line 350 of file Contacts.h.

#define ContactsLibTrapGetUInt8Field (sysLibTrapCustom + 50)

Definition at line 348 of file Contacts.h.

#define ContactsLibTrapGetVersion (sysLibTrapCustom)

Definition at line 319 of file Contacts.h.

#define ContactsLibTrapIsEmptyContact (sysLibTrapCustom + 30)

Definition at line 339 of file Contacts.h.

#define ContactsLibTrapLookUpString (sysLibTrapCustom + 40)

Definition at line 370 of file Contacts.h.

#define ContactsLibTrapOpenSession (sysLibTrapCustom + 23)

Definition at line 321 of file Contacts.h.

#define ContactsLibTrapPosInCategory (sysLibTrapCustom + 48)

Definition at line 366 of file Contacts.h.

#define ContactsLibTrapReleaseHandle (sysLibTrapCustom + 4)

Definition at line 325 of file Contacts.h.

#define ContactsLibTrapRenameCustomLabel (sysLibTrapCustom + 33)

Definition at line 359 of file Contacts.h.

#define ContactsLibTrapSeekRecord (sysLibTrapCustom + 35)

Definition at line 333 of file Contacts.h.

#define ContactsLibTrapSetBinaryField (sysLibTrapCustom + 59)

Definition at line 345 of file Contacts.h.

#define ContactsLibTrapSetCategoryName (sysLibTrapCustom + 38)

Definition at line 364 of file Contacts.h.

#define ContactsLibTrapSetDateField (sysLibTrapCustom + 55)

Definition at line 343 of file Contacts.h.

#define ContactsLibTrapSetFieldLabel (sysLibTrapCustom + 32)

Definition at line 356 of file Contacts.h.

#define ContactsLibTrapSetStringField (sysLibTrapCustom + 57)

Definition at line 344 of file Contacts.h.

#define ContactsLibTrapSetUInt16Field (sysLibTrapCustom + 53)

Definition at line 342 of file Contacts.h.

#define ContactsLibTrapSetUInt8Field (sysLibTrapCustom + 51)

Definition at line 341 of file Contacts.h.

#define ContactsLibTrapUpdateContact (sysLibTrapCustom + 7)

Definition at line 328 of file Contacts.h.

#define ContactsLibTypeID sysFileTLibrary

Definition at line 44 of file Contacts.h.

Referenced by ContactsLib_OpenLibrary().

#define ContactsNumCategories dmRecNumCategories

Definition at line 93 of file Contacts.h.

#define ContactsSeekBackward dmSeekBackward

Definition at line 97 of file Contacts.h.

#define ContactsSeekForward dmSeekForward

Definition at line 96 of file Contacts.h.

#define ContactsUnfiledCategory dmUnfiledCategory

Definition at line 95 of file Contacts.h.

#define PALM_OS

Definition at line 88 of file Contacts.h.

Typedef Documentation

typedef MemHandle ContactsContHandle

Definition at line 90 of file Contacts.h.

typedef DateType ContactsDateType

Definition at line 99 of file Contacts.h.

typedef char ContactsLabel[ContactsLabelLength]

Definition at line 103 of file Contacts.h.

typedef enum ContactsLabelTypes ContactsLabelType

typedef MemHandle ContactsSession

Definition at line 91 of file Contacts.h.

Enumeration Type Documentation

enum ContactsLabelTypes

Enumerator:
ContactsChatLabel
ContactsAddressLabel
ContactsPhoneLabel

Definition at line 271 of file Contacts.h.

00272 {
00273     ContactsChatLabel,
00274     ContactsAddressLabel,
00275     ContactsPhoneLabel
00276 } ContactsLabelType;

enum ContactsLibAllFields

Enumerator:
contactsLastName
contactsFirstName
contactsCompany
contactsTitle
contactsPhone1
contactsPhone2
contactsPhone3
contactsPhone4
contactsPhone5
contactsPhone6
contactsPhone7
contactsChat1
contactsChat2
contactsWebpage
contactsCustom1
contactsCustom2
contactsCustom3
contactsCustom4
contactsCustom5
contactsCustom6
contactsCustom7
contactsCustom8
contactsCustom9
contactsAddress1
contactsCity1
contactsState1
contactsZipCode1
contactsCountry1
contactsAddress2
contactsCity2
contactsState2
contactsZipCode2
contactsCountry2
contactsAddress3
contactsCity3
contactsState3
contactsZipCode3
contactsCountry3
contactsNote
contactsBirthdate
contactsBirthdayMask
contactsBirthdayPreset
contactsPicture
contactsUniqueID
contactsIndex
contactsCategoryID
contactsPrivate
contactsBusy
contactsDirty
contactsRingtoneInfo
contactsAnniversaryDate
contactsAnniversaryMask
contactsAnniversaryPreset
contactsNumFields

Definition at line 128 of file Contacts.h.

00129 {
00130     contactsLastName,
00131     contactsFirstName,
00132     contactsCompany,
00133     contactsTitle,
00134
00135     contactsPhone1,
00136     contactsPhone2,
00137     contactsPhone3,
00138     contactsPhone4,
00139     contactsPhone5,
00140     contactsPhone6,
00141     contactsPhone7,
00142
00143     contactsChat1,
00144     contactsChat2,
00145
00146     contactsWebpage,
00147
00148     contactsCustom1,
00149     contactsCustom2,
00150     contactsCustom3,
00151     contactsCustom4,
00152     contactsCustom5,
00153     contactsCustom6,
00154     contactsCustom7,
00155     contactsCustom8,
00156     contactsCustom9,
00157
00158     contactsAddress1,
00159     contactsCity1,
00160     contactsState1,
00161     contactsZipCode1,
00162     contactsCountry1,
00163     contactsAddress2,
00164     contactsCity2,
00165     contactsState2,
00166     contactsZipCode2,
00167     contactsCountry2,
00168     contactsAddress3,
00169     contactsCity3,
00170     contactsState3,
00171     contactsZipCode3,
00172     contactsCountry3,
00173
00174     contactsNote,
00175
00176     contactsBirthdate,
00177     contactsBirthdayMask,
00178     contactsBirthdayPreset,
00179     contactsPicture,
00180     contactsUniqueID        = contactsPicture + 2,
00181     contactsIndex,
00182     contactsCategoryID,
00183     contactsPrivate         = contactsCategoryID + 2,
00184     contactsBusy,
00185     contactsDirty,
00186     contactsRingtoneInfo    = contactsDirty + 4,
00187     contactsAnniversaryDate,
00188     contactsAnniversaryMask,
00189     contactsAnniversaryPreset,
00190     contactsNumFields
00191 } ContactsLibAllFields;

enum ContactsLibBinaryFields

Enumerator:
contactsBinaryPictureData
contactsBinaryRingtoneIdentifier

Definition at line 306 of file Contacts.h.

00307 {
00308     contactsBinaryPictureData           = contactsPicture,
00309     contactsBinaryRingtoneIdentifier    = contactsRingtoneInfo
00310 } ContactsLibBinaryFields;

enum ContactsLibCustomFields

Enumerator:
contactsCustomCustom1
contactsCustomCustom2
contactsCustomCustom3
contactsCustomCustom4
contactsCustomCustom5
contactsCustomCustom6
contactsCustomCustom7
contactsCustomCustom8
contactsCustomCustom9

Definition at line 242 of file Contacts.h.

00243 {
00244     contactsCustomCustom1   = contactsCustom1,
00245     contactsCustomCustom2,
00246     contactsCustomCustom3,
00247     contactsCustomCustom4,
00248     contactsCustomCustom5,
00249     contactsCustomCustom6,
00250     contactsCustomCustom7,
00251     contactsCustomCustom8,
00252     contactsCustomCustom9
00253 } ContactsLibCustomFields;

enum ContactsLibDateFields

Enumerator:
contactsDateBirthdate
contactsDateAnniversary

Definition at line 278 of file Contacts.h.

00279 {
00280     contactsDateBirthdate               = contactsBirthdate,
00281     contactsDateAnniversary             = contactsAnniversaryDate
00282 } ContactsLibDateFields;

enum ContactsLibFieldLabels

Enumerator:
contactsNoType
contactsWorkPhone
contactsHomePhone
contactsFaxPhone
contactsOtherPhone
contactsEmailPhone
contactsMainPhone
contactsPagerPhone
contactsMobilePhone
contactsOtherChat
contactsAimChat
contactsMsnChat
contactsYahooChat
contactsIcqChat
contactsWorkAddress
contactsHomeAddress
contactsOtherAddress

Definition at line 106 of file Contacts.h.

00107 {
00108     contactsNoType,
00109     contactsWorkPhone,      // applicable to Phone1-7 fields
00110     contactsHomePhone,      // applicable to Phone1-7 fields
00111     contactsFaxPhone,       // applicable to Phone1-7 fields
00112     contactsOtherPhone,     // applicable to Phone1-7 fields
00113     contactsEmailPhone,     // applicable to Phone1-7 fields
00114     contactsMainPhone,      // applicable to Phone1-7 fields
00115     contactsPagerPhone,     // applicable to Phone1-7 fields
00116     contactsMobilePhone,    // applicable to Phone1-7 fields
00117     contactsOtherChat,      // applicable to Chat1 & Chat2 fields
00118     contactsAimChat,        // applicable to Chat1 & Chat2 fields
00119     contactsMsnChat,        // applicable to Chat1 & Chat2 fields
00120     contactsYahooChat,      // applicable to Chat1 & Chat2 fields
00121     contactsIcqChat,        // applicable to Chat1 & Chat2 fields
00122     contactsWorkAddress,    // applicable to Address1-3 fields
00123     contactsHomeAddress,    // applicable to Address1-3 fields
00124     contactsOtherAddress    // applicable to Address1-3 fields
00125 }   ContactsLibFieldLabels;

enum ContactsLibStrFields

Enumerator:
contactsStrLastName
contactsStrFirstName
contactsStrCompany
contactsStrTitle
contactsStrPhone1
contactsStrPhone2
contactsStrPhone3
contactsStrPhone4
contactsStrPhone5
contactsStrPhone6
contactsStrPhone7
contactsStrChat1
contactsStrChat2
contactsStrWebpage
contactsStrCustom1
contactsStrCustom2
contactsStrCustom3
contactsStrCustom4
contactsStrCustom5
contactsStrCustom6
contactsStrCustom7
contactsStrCustom8
contactsStrCustom9
contactsStrAddress1
contactsStrCity1
contactsStrState1
contactsStrZipCode1
contactsStrCountry1
contactsStrAddress2
contactsStrCity2
contactsStrState2
contactsStrZipCode2
contactsStrCountry2
contactsStrAddress3
contactsStrCity3
contactsStrState3
contactsStrZipCode3
contactsStrCountry3
contactsStrNote

Definition at line 193 of file Contacts.h.

00194 {
00195     contactsStrLastName,
00196     contactsStrFirstName,
00197     contactsStrCompany,
00198     contactsStrTitle,
00199
00200     contactsStrPhone1,          // phone fields, all can accept a label
00201     contactsStrPhone2,
00202     contactsStrPhone3,
00203     contactsStrPhone4,
00204     contactsStrPhone5,
00205     contactsStrPhone6,
00206     contactsStrPhone7,
00207
00208     contactsStrChat1,           // instant message id and service, both can accept a label
00209     contactsStrChat2,
00210
00211     contactsStrWebpage,
00212
00213     contactsStrCustom1,         // custom fields
00214     contactsStrCustom2,
00215     contactsStrCustom3,
00216     contactsStrCustom4,
00217     contactsStrCustom5,
00218     contactsStrCustom6,
00219     contactsStrCustom7,
00220     contactsStrCustom8,
00221     contactsStrCustom9,
00222
00223     contactsStrAddress1,        // first set of address fields, Address1 can accept a label
00224     contactsStrCity1,
00225     contactsStrState1,
00226     contactsStrZipCode1,
00227     contactsStrCountry1,
00228     contactsStrAddress2,        // second set of address fields, Address2 can accept a label
00229     contactsStrCity2,
00230     contactsStrState2,
00231     contactsStrZipCode2,
00232     contactsStrCountry2,
00233     contactsStrAddress3,        // third set of address fields, Address3 can accept a label
00234     contactsStrCity3,
00235     contactsStrState3,
00236     contactsStrZipCode3,
00237     contactsStrCountry3,
00238
00239     contactsStrNote             // This field is assumed to be < 32K
00240 } ContactsLibStrFields;

enum ContactsLibUInt16Fields

Enumerator:
contactsUInt16Index
contactsUInt16Category

Definition at line 284 of file Contacts.h.

00285 {
00286     contactsUInt16Index                 = contactsIndex,
00287     contactsUInt16Category              = contactsCategoryID
00288 } ContactsLibUInt16Fields;

enum ContactsLibUInt32Fields

Enumerator:
contactsUInt32UniqueID

Definition at line 290 of file Contacts.h.

00291 {
00292     contactsUInt32UniqueID              = contactsUniqueID
00293 } ContactsLibUInt32Fields;

enum ContactsLibUInt8Fields

Enumerator:
contactsUInt8Private
contactsUInt8Busy
contactsUInt8Dirty
contactsUInt8BirthdayMask
contactsUInt8BirthdayPreset
contactsUInt8AnniversaryMask
contactsUInt8AnniversaryPreset

Definition at line 295 of file Contacts.h.

00296 {
00297     contactsUInt8Private                = contactsPrivate,
00298     contactsUInt8Busy,
00299     contactsUInt8Dirty,
00300     contactsUInt8BirthdayMask           = contactsBirthdayMask,
00301     contactsUInt8BirthdayPreset,
00302     contactsUInt8AnniversaryMask        = contactsAnniversaryMask,
00303     contactsUInt8AnniversaryPreset
00304 } ContactsLibUInt8Fields;

enum ContactsLibWithLabelFields

Enumerator:
contactsWithLabelPhone1
contactsWithLabelPhone2
contactsWithLabelPhone3
contactsWithLabelPhone4
contactsWithLabelPhone5
contactsWithLabelPhone6
contactsWithLabelPhone7
contactsWithLabelChat1
contactsWithLabelChat2
contactsWithLabelAddress1
contactsWithLabelAddress2
contactsWithLabelAddress3

Definition at line 255 of file Contacts.h.

00256 {
00257     contactsWithLabelPhone1         = contactsPhone1,
00258     contactsWithLabelPhone2,
00259     contactsWithLabelPhone3,
00260     contactsWithLabelPhone4,
00261     contactsWithLabelPhone5,
00262     contactsWithLabelPhone6,
00263     contactsWithLabelPhone7,
00264     contactsWithLabelChat1,
00265     contactsWithLabelChat2,
00266     contactsWithLabelAddress1       = contactsAddress1,
00267     contactsWithLabelAddress2       = contactsAddress2,
00268     contactsWithLabelAddress3       = contactsAddress3
00269 } ContactsLibWithLabelFields;

enum SessionMode

Enumerator:
ContactsLibSessionModeReadOnly
ContactsLibSessionModeReadWrite

Definition at line 312 of file Contacts.h.

00313 {
00314     ContactsLibSessionModeReadOnly  = 0x0001,
00315     ContactsLibSessionModeReadWrite = 0x0003
00316 } SessionMode;

Function Documentation

Err ContactsAddContact | ( | UInt16 | libRefnum,
 |  | ContactsSession | hSession,
 |  | ContactsContHandle | hContact
 | ) |  |

UInt16 ContactsCategoryFind | ( | UInt16 | libRefnum,
 |  | ContactsSession | hSession,
 |  | const Char * | pCatName
 | ) |  |

Err ContactsCloseSession | ( | UInt16 | libRefnum,
 |  | ContactsSession | hCurSession
 | ) |  |

ContactsContHandle ContactsCreateHandle | ( | UInt16 | libRefnum,
 |  | ContactsSession | hSession
 | ) |  |

Err ContactsDeleteContact | ( | UInt16 | libRefnum,
 |  | ContactsSession | hSession,
 |  | ContactsContHandle | hContact,
 |  | Boolean | archive
 | ) |  |

Boolean ContactsDoesFieldExist | ( | UInt16 | libRefnum,
 |  | ContactsContHandle | hContact,
 |  | ContactsLibAllFields | NameOfField
 | ) |  |

void* ContactsGetBinaryField | ( | UInt16 | libRefnum,
 |  | ContactsContHandle | hContact,
 |  | ContactsLibBinaryFields | NameOfField,
 |  | UInt16 * | pDataSize
 | ) |  |

void ContactsGetCategoryList | ( | UInt16 | libRefnum,
 |  | ContactsSession | hSession,
 |  | char * | pCategoryList[ContactsNumCategories]
 | ) |  |

Char* ContactsGetCategoryName | ( | UInt16 | libRefnum,
 |  | ContactsSession | hSession,
 |  | UInt16 | categoryIndex
 | ) |  |

ContactsContHandle ContactsGetContact | ( | UInt16 | libRefnum,
 |  | ContactsSession | hSession,
 |  | UInt16 * | indexP,
 |  | UInt32 * | uniqueIDP,
 |  | Boolean | ignored
 | ) |  |

Err ContactsGetDateField | ( | UInt16 | libRefnum,
 |  | ContactsContHandle | hContact,
 |  | ContactsLibDateFields | NameOfField,
 |  | DateType * | pFieldValue
 | ) |  |

Int16 ContactsGetFieldLabel | ( | UInt16 | libRefnum,
 |  | ContactsContHandle | hContact,
 |  | ContactsLibWithLabelFields | FieldNum
 | ) |  |

ContactsContHandle ContactsGetFirstContact | ( | UInt16 | libRefnum,
 |  | ContactsSession | hSession,
 |  | UInt16 | category
 | ) |  |

char* ContactsGetLabelText | ( | UInt16 | libRefnum,
 |  | ContactsSession | hSession,
 |  | ContactsLabelType | type,
 |  | UInt16 | labelNum,
 |  | UInt16 * | pSizeOfBuffer
 | ) |  |

Err ContactsGetLastError ( UInt16 libRefnum )

UInt16 ContactsGetNextCategory | ( | UInt16 | libRefnum,
 |  | ContactsSession | hSession,
 |  | UInt16 | currentCategory
 | ) |  |

ContactsContHandle ContactsGetNextContact | ( | UInt16 | libRefnum,
 |  | ContactsSession | hSession,
 |  | ContactsContHandle | hSourceContact,
 |  | UInt16 | Category
 | ) |  |

UInt16 ContactsGetNumRecords | ( | UInt16 | libRefnum,
 |  | ContactsSession | hSession,
 |  | UInt16 | category
 | ) |  |

Err ContactsGetRingtoneForCategory | ( | UInt16 | libRefnum,
 |  | UInt16 | categoryID,
 |  | void * | tone
 | ) |  |

Err ContactsGetStringField | ( | UInt16 | libRefnum,
 |  | ContactsContHandle | hContact,
 |  | ContactsLibStrFields | NameOfField,
 |  | char ** | pFieldValue
 | ) |  |

Err ContactsGetUInt16Field | ( | UInt16 | libRefnum,
 |  | ContactsContHandle | hContact,
 |  | ContactsLibUInt16Fields | NameOfField,
 |  | UInt16 * | pFieldValue
 | ) |  |

Err ContactsGetUInt32Field | ( | UInt16 | libRefnum,
 |  | ContactsContHandle | hContact,
 |  | ContactsLibUInt32Fields | NameOfField,
 |  | UInt32 * | pFieldValue
 | ) |  |

Err ContactsGetUInt8Field | ( | UInt16 | libRefnum,
 |  | ContactsContHandle | hContact,
 |  | ContactsLibUInt8Fields | NameOfField,
 |  | UInt8 * | pFieldValue
 | ) |  |

UInt32 ContactsGetVersion ( UInt16 libRefnum )

Boolean ContactsIsEmptyContact | ( | UInt16 | libRefnum,
 |  | ContactsSession | hSession,
 |  | ContactsContHandle | hCont,
 |  | UInt16 * | Index,
 |  | UInt32 * | UniqueID
 | ) |  |

__inline Err ContactsLib_CloseLibrary ( UInt16 * refNumP )

Definition at line 452 of file Contacts.h.

References ContactsLibErrLibStillOpen.

00453 {
00454     Err error;
00455
00456     if (*refNumP == sysInvalidRefNum)
00457     {
00458         return sysErrParamErr;
00459     }
00460
00461     error = ContactsLibClose(*refNumP);
00462
00463     if (error == errNone)
00464     {
00465         /* no users left, so unload library */
00466         SysLibRemove(*refNumP);
00467
00468         *refNumP = sysInvalidRefNum;    // invalidate so caller cannot use any longer.
00469     }
00470     else if (error == ContactsLibErrLibStillOpen)
00471     {
00472         /* don't unload library, but mask "still open" from caller  */
00473         error = errNone;
00474     }
00475
00476     return error;
00477 }

__inline Err ContactsLib_OpenLibrary ( UInt16 * refNumP )

Definition at line 400 of file Contacts.h.

References ContactsLibCreatorID, ContactsLibName, and ContactsLibTypeID.

00401 {
00402     Err error;
00403     Boolean loaded = false;
00404
00405     /* first try to find the library */
00406     error = SysLibFind(ContactsLibName, refNumP);
00407
00408     /* If not found, load the library instead */
00409     if (error == sysErrLibNotFound)
00410     {
00411         error = SysLibLoad(ContactsLibTypeID, ContactsLibCreatorID, refNumP);
00412         loaded = true;
00413     }
00414
00415     if (error == errNone)
00416     {
00417         error = ContactsLibOpen(*refNumP);
00418         if (error != errNone)
00419         {
00420             if (loaded)
00421             {
00422                 SysLibRemove(*refNumP);
00423             }
00424
00425             *refNumP = sysInvalidRefNum;
00426         }
00427     }
00428
00429     return error;
00430 }

ContactsContHandle ContactsLookUpString | ( | UInt16 | libRefnum,
 |  | ContactsSession | hSession,
 |  | Char * | key,
 |  | Boolean | sortByCompany,
 |  | UInt16 | category,
 |  | Boolean * | completeMatch,
 |  | UInt16 * | pNumMatchingChars,
 |  | Boolean | masked
 | ) |  |

ContactsSession ContactsOpenSession | ( | UInt16 | libRefnum,
 |  | SessionMode | mode
 | ) |  |

UInt16 ContactsPosInCategory | ( | UInt16 | libRefnum,
 |  | ContactsSession | hSession,
 |  | ContactsContHandle | hContact,
 |  | UInt16 * | pIndex,
 |  | UInt16 | category
 | ) |  |

Err ContactsReleaseHandle | ( | UInt16 | libRefnum,
 |  | ContactsContHandle | hContact
 | ) |  |

Err ContactsRenameCustomLabel | ( | UInt16 | libRefnum,
 |  | ContactsSession | hSession,
 |  | ContactsLibCustomFields | fieldNum,
 |  | Char * | fieldLabel
 | ) |  |

Boolean ContactsSeekRecord | ( | UInt16 | libRefnum,
 |  | ContactsSession | hSession,
 |  | UInt16 * | indexP,
 |  | UInt16 | offset,
 |  | Int16 | direction,
 |  | UInt16 | category
 | ) |  |

Err ContactsSetBinaryField | ( | UInt16 | libRefnum,
 |  | ContactsContHandle | hContact,
 |  | ContactsLibBinaryFields | NameOfField,
 |  | void * | pFieldData,
 |  | UInt16 | DataSize
 | ) |  |

void ContactsSetCategoryName | ( | UInt16 | libRefnum,
 |  | ContactsSession | hSession,
 |  | UInt16 | categoryIndex,
 |  | const Char * | pCatName
 | ) |  |

Err ContactsSetDateField | ( | UInt16 | libRefnum,
 |  | ContactsContHandle | hContact,
 |  | ContactsLibDateFields | nameOfField,
 |  | ContactsDateType | fieldValue
 | ) |  |

void ContactsSetFieldLabel | ( | UInt16 | libRefnum,
 |  | ContactsContHandle | hToCont,
 |  | ContactsLibWithLabelFields | FieldNum,
 |  | Int16 | LabelIndex
 | ) |  |

Err ContactsSetStringField | ( | UInt16 | libRefnum,
 |  | ContactsContHandle | hContact,
 |  | ContactsLibStrFields | nameOfField,
 |  | char * | FieldValue
 | ) |  |

Err ContactsSetUInt16Field | ( | UInt16 | libRefnum,
 |  | ContactsContHandle | hContact,
 |  | ContactsLibUInt16Fields | NameOfField,
 |  | UInt16 | FieldValue
 | ) |  |

Err ContactsSetUInt8Field | ( | UInt16 | libRefnum,
 |  | ContactsContHandle | hContact,
 |  | ContactsLibUInt8Fields | nameOfField,
 |  | UInt8 | fieldValue
 | ) |  |

Err ContactsUpdateContact | ( | UInt16 | libRefnum,
 |  | ContactsSession | hSession,
 |  | ContactsContHandle | hContact
 | ) |  |

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:56 2008 for Palm API Guide


Header Files » Incs » common » libraries » datebook

DatebookLibCommon.h File Reference

Include dependency graph for DatebookLibCommon.h:

Go to the source code of this file.

Data Structures

  • struct P1clRecordDetails
  • struct ApptTimeZoneType

Defines

  • #define P1clLibCreatorID 'P1CL'
  • #define P1clTypeID sysFileTLibrary
  • #define P1clLibName "CalendarLib-P1CL"
  • #define P1cl_CURRENT_VERSION 0x0200
  • #define apptMaxTimeZoneNameLen kLocNameMaxLength
  • #define SysNotifyPIMRecordChange 'pmdb'
  • #define P1clErrorClass (appErrorClass |0x7000)
  • #define P1clErrTooManyClients (P1clErrorClass | 1)
  • #define P1clErrInvalidHandle (P1clErrorClass | 2)
  • #define P1clErrInvalidParam (P1clErrorClass | 3)
  • #define P1clErrUIdNotFound (P1clErrorClass | 4)
  • #define P1clErrCategoryNotFound (P1clErrorClass | 5)
  • #define P1clErrAlreadyInUse (P1clErrorClass | 6)
  • #define P1clErrVerNotSupported (P1clErrorClass | 7)
  • #define P1clErrOutOfMemory (P1clErrorClass | 8)
  • #define P1clErrSizeParamOverFlow (P1clErrorClass | 9)
  • #define P1clErrEmptyDateBook (P1clErrorClass | 10)
  • #define P1clErrAlarmDoesNotExist (P1clErrorClass | 11)
  • #define P1clErrRepeatInfoDoesNotExist (P1clErrorClass | 12)
  • #define P1clErrDescDoesNotExist (P1clErrorClass | 13)
  • #define P1clErrNoteDoesNotExist (P1clErrorClass | 14)
  • #define P1clErrInvalidReference (P1clErrorClass | 15)
  • #define P1clErrApptNotFound (P1clErrorClass | 16)
  • #define P1clErrAttachAlreadyExist (P1clErrorClass | 17)
  • #define P1clErrAttachNotExist (P1clErrorClass | 18)
  • #define P1clErrAttachOverFlow (P1clErrorClass | 19)
  • #define P1clErrRecordNotFound (P1clErrorClass | 21)
  • #define P1clErrAttachOverflow (P1clErrorClass | 22)
  • #define P1clErrInvalidField (P1clErrorClass | 23)
  • #define P1clErrNoDateTime (P1clErrorClass | 24)
  • #define P1clErrLibAlreadyInUse (P1clErrorClass | 25)
  • #define P1clErrTooManySession (P1clErrorClass | 26)
  • #define P1clErrAlreadyInWriteMode (P1clErrorClass | 27)
  • #define P1clErrInvalidSession (P1clErrorClass | 28)
  • #define P1clErrInvalidAtrib (P1clErrorClass | 29)
  • #define P1clErrFieldNotFound (P1clErrorClass | 30)
  • #define P1clErrStringNotFound (P1clErrorClass | 31)
  • #define P1clErrInvalidAppInfoBlock (P1clErrorClass | 32)
  • #define P1clErrAppInfoIsMising (P1clErrorClass | 33)
  • #define P1clErrReadOnlySession (P1clErrorClass | 34)
  • #define P1clErrUIdExist (P1clErrorClass | 35)
  • #define P1clErrMaxLimitReached (P1clErrorClass | 36)
  • #define P1clErrListNotExist (P1clErrorClass | 37)
  • #define P1clErrApptNotLocked (P1clErrorClass | 38)
  • #define P1clErrApptBusy (P1clErrorClass | 39)
  • #define P1clErrEmptyAppt (P1clErrorClass | 40)
  • #define P1clErrFieldNotExist (P1clErrorClass | 41)
  • #define P1clErrRepeatTypeDoesNotExist (P1clErrorClass | 42)
  • #define P1clErrAttendeeNotFound (P1clErrorClass | 43)
  • #define P1clErrAttendeeOutofLimit (P1clErrorClass | 44)
  • #define P1clErrLibStillOpen (P1clErrorClass | 45)
  • #define P1clErrFailedToEmptyDatabase (P1clErrorClass | 46)
  • #define P1clTrapGetVersion (sysLibTrapCustom)
  • #define P1clTrapCheckVersion (sysLibTrapCustom + 1)
  • #define P1clTrapOpenSession (sysLibTrapCustom + 2)
  • #define P1clTrapCloseSession (sysLibTrapCustom + 3)
  • #define P1clTrapCreateHandle (sysLibTrapCustom + 4)
  • #define P1clTrapReleaseHandle (sysLibTrapCustom + 5)
  • #define P1clTrapGetAppt (sysLibTrapCustom + 6)
  • #define P1clTrapGetFirstAppt (sysLibTrapCustom + 7)
  • #define P1clTrapGetNextAppt (sysLibTrapCustom + 8)
  • #define P1clTrapIsEmptyAppt (sysLibTrapCustom + 9)
  • #define P1clTrapSplitRepeatingEvent (sysLibTrapCustom + 10)
  • #define P1clTrapApptFindNextRepeat (sysLibTrapCustom + 11)
  • #define P1clTrapApptRepeatsOnDate (sysLibTrapCustom + 12)
  • #define P1clTrapHasMultipleOccurences (sysLibTrapCustom + 13)
  • #define P1clTrapGetApptList (sysLibTrapCustom + 14)
  • #define P1clTrapGetUInt16FromListHandle (sysLibTrapCustom + 15)
  • #define P1clTrapGetTimeFromListHandle (sysLibTrapCustom + 16)
  • #define P1clTrapGetUInt32FromListHandle (sysLibTrapCustom + 17)
  • #define P1clTrapGetBooleanFromListHandle (sysLibTrapCustom + 18)
  • #define P1clTrapGetApptFromListHandle (sysLibTrapCustom + 19)
  • #define P1clTrapUpdateAppt (sysLibTrapCustom + 20)
  • #define P1clTrapAddAppt (sysLibTrapCustom + 21)
  • #define P1clTrapDeleteAppt (sysLibTrapCustom + 22)
  • #define P1clTrapFindNextAlarm (sysLibTrapCustom + 23)
  • #define P1clTrapSortCalendar (sysLibTrapCustom + 24)
  • #define P1clTrapFindSaveMatch (sysLibTrapCustom + 25)
  • #define P1clTrapPurgeAppts (sysLibTrapCustom + 26)
  • #define P1clTrapAttnForgetIt (sysLibTrapCustom + 27)
  • #define P1clTrapApptPostTriggeredAlarms (sysLibTrapCustom + 28)
  • #define P1clTrapGetCalendarDBInfo (sysLibTrapCustom + 29)
  • #define P1clTrapCreateException (sysLibTrapCustom + 30)
  • #define P1clTrapDeleteExceptionList (sysLibTrapCustom + 31)
  • #define P1clTrapFindConflict (sysLibTrapCustom + 32)
  • #define P1clTrapGetStringField (sysLibTrapCustom + 33)
  • #define P1clTrapSetStringField (sysLibTrapCustom + 34)
  • #define P1clTrapGetUInt8Field (sysLibTrapCustom + 35)
  • #define P1clTrapSetUInt8Field (sysLibTrapCustom + 36)
  • #define P1clTrapGetInt8Field (sysLibTrapCustom + 37)
  • #define P1clTrapSetInt8Field (sysLibTrapCustom + 38)
  • #define P1clTrapGetUInt16Field (sysLibTrapCustom + 39)
  • #define P1clTrapSetUInt16Field (sysLibTrapCustom + 40)
  • #define P1clTrapGetInt16Field (sysLibTrapCustom + 41)
  • #define P1clTrapSetInt16Field (sysLibTrapCustom + 42)
  • #define P1clTrapGetUInt32Field (sysLibTrapCustom + 43)
  • #define P1clTrapSetUInt32Field (sysLibTrapCustom + 44)
  • #define P1clTrapGetDateTimeField (sysLibTrapCustom + 45)
  • #define P1clTrapSetDateTimeField (sysLibTrapCustom + 46)
  • #define P1clTrapGetTimeField (sysLibTrapCustom + 47)
  • #define P1clTrapSetTimeField (sysLibTrapCustom + 48)
  • #define P1clTrapGetDateField (sysLibTrapCustom + 49)
  • #define P1clTrapSetDateField (sysLibTrapCustom + 50)
  • #define P1clTrapGetDSTField (sysLibTrapCustom + 51)
  • #define P1clTrapSetDSTField (sysLibTrapCustom + 52)
  • #define P1clTrapGetNumOfException (sysLibTrapCustom + 53)
  • #define P1clTrapIsException (sysLibTrapCustom + 54)
  • #define P1clTrapAddExceptionDate (sysLibTrapCustom + 55)
  • #define P1clTrapCreateAttendeeHandle (sysLibTrapCustom + 56)
  • #define P1clTrapReleaseAttendeeHandle (sysLibTrapCustom + 57)
  • #define P1clTrapGetFirstAttendee (sysLibTrapCustom + 58)
  • #define P1clTrapGetNextAttendee (sysLibTrapCustom + 59)
  • #define P1clTrapGetAttendee (sysLibTrapCustom + 60)
  • #define P1clTrapAddAttendee (sysLibTrapCustom + 61)
  • #define P1clTrapUpdateAttendee (sysLibTrapCustom + 62)
  • #define P1clTrapDeleteAttendee (sysLibTrapCustom + 63)
  • #define P1clTrapGetAttendeeUInt8Field (sysLibTrapCustom + 64)
  • #define P1clTrapSetAttendeeUInt8Field (sysLibTrapCustom + 65)
  • #define P1clTrapGetAttendeeStringField (sysLibTrapCustom + 66)
  • #define P1clTrapSetAttendeeStringField (sysLibTrapCustom + 67)
  • #define P1clTrapCreateBlobHandle (sysLibTrapCustom + 68)
  • #define P1clTrapReleaseBlobHandle (sysLibTrapCustom + 69)
  • #define P1clTrapGetBlob (sysLibTrapCustom + 70)
  • #define P1clTrapSetBlob (sysLibTrapCustom + 71)
  • #define P1clTrapDeleteBlob (sysLibTrapCustom + 72)
  • #define P1clTrapGetBlobData (sysLibTrapCustom + 73)
  • #define P1clTrapSetBlobData (sysLibTrapCustom + 74)
  • #define P1clTrapGetBlobCreatorId (sysLibTrapCustom + 75)
  • #define P1clTrapSetBlobCreatorId (sysLibTrapCustom + 76)
  • #define P1clTrapGetLastError (sysLibTrapCustom + 77)
  • #define P1clTrapTxnPrepareSync (sysLibTrapCustom + 78)
  • #define P1clTrapTxnGetChange (sysLibTrapCustom + 79)
  • #define P1clTrapTxnGetNumChanges (sysLibTrapCustom + 80)
  • #define P1clTrapLogMarkAllCompleted (sysLibTrapCustom + 81)
  • #define P1clTrapTxnLogMarkCompleted (sysLibTrapCustom + 82)
  • #define P1clTrapTxnSyncComplete (sysLibTrapCustom + 83)
  • #define P1clTrapDeleteServerId (sysLibTrapCustom + 84)
  • #define P1clTrapGetApptFromServerId (sysLibTrapCustom + 85)
  • #define P1clTrapSetServerId (sysLibTrapCustom + 86)
  • #define P1clTrapCategoryTruncateName (sysLibTrapCustom + 87)
  • #define P1clTrapCategorySetTriggerLabel (sysLibTrapCustom + 88)
  • #define P1clTrapCategoryGetNext (sysLibTrapCustom + 89)
  • #define P1clTrapCategoryPopupList (sysLibTrapCustom + 90)
  • #define P1clTrapCategorySelect (sysLibTrapCustom + 91)
  • #define P1clTrapCategoryEdit (sysLibTrapCustom + 92)
  • #define P1clTrapCategoryDrawBullet (sysLibTrapCustom + 93)
  • #define P1clTrapCategorySetColor (sysLibTrapCustom + 94)
  • #define P1clTrapCategoryGetRGBColor (sysLibTrapCustom + 95)
  • #define P1clTrapCategoryGetColor (sysLibTrapCustom + 96)
  • #define P1clTrapCategoryGetUnusedColor (sysLibTrapCustom + 97)
  • #define P1clTrapCategorySetName (sysLibTrapCustom + 98)
  • #define P1clTrapCategoryGetName (sysLibTrapCustom + 99)
  • #define P1clTrapCategoryFind (sysLibTrapCustom + 100)
  • #define P1clTrapCategoryFreeList (sysLibTrapCustom + 101)
  • #define P1clTrapCategoryCreateList (sysLibTrapCustom + 102)
  • #define P1clTrapCategoryGetVersion (sysLibTrapCustom + 103)
  • #define P1clTrapGiveAllTimedEventsTimeZones (sysLibTrapCustom + 104)
  • #define P1clTrapConvertFromDeviceTimeZone (sysLibTrapCustom + 105)
  • #define P1clTrapConvertToDeviceTimeZone (sysLibTrapCustom + 106)
  • #define P1clTrapCountryForTimeZoneAbbreviation (sysLibTrapCustom + 107)
  • #define P1clTrapApptTimeZoneAbbreviation (sysLibTrapCustom + 108)
  • #define P1clTrapApptTimeZoneCompare (sysLibTrapCustom + 109)
  • #define P1clTrapGetExtendedDescription (sysLibTrapCustom + 110)
  • #define P1clTrapHasExtendedDescription (sysLibTrapCustom + 111)
  • #define P1clTrapApptGetFirstOccurrence (sysLibTrapCustom + 112)
  • #define P1clTrapUpdateEventsWithDeletedTimeZone (sysLibTrapCustom + 113)
  • #define P1clTrapUpdateEventsWithEditedTimeZone (sysLibTrapCustom + 114)
  • #define P1clTrapCopyStringField (sysLibTrapCustom + 115)
  • #define P1clTrapDateExportVCal (sysLibTrapCustom + 116)
  • #define P1clTrapNumRecordsInCategory (sysLibTrapCustom + 117)
  • #define P1clTrapSeekRecordInCategory (sysLibTrapCustom + 118)
  • #define P1clTrapDateSetGoToParams (sysLibTrapCustom + 119)
  • #define P1clTrapGetSessionInfo (sysLibTrapCustom + 120)
  • #define P1clTrapCopyRepeatDescription (sysLibTrapCustom + 121)
  • #define P1clTrapGetConflict (sysLibTrapCustom + 122)
  • #define P1clTrapGetDefaultTimeZone (sysLibTrapCustom + 123)
  • #define P1clTrapSetRepeateEndDate (sysLibTrapCustom + 124)
  • #define P1clTrapAddMultiDayEvent (sysLibTrapCustom + 125)
  • #define P1clTrapAddAllToTransactionLog (sysLibTrapCustom + 126)
  • #define P1clTrapSetExceptionExt (sysLibTrapCustom + 127)
  • #define P1clTrapAddExceptionExt (sysLibTrapCustom + 128)
  • #define P1clTrapGetExceptionDate (sysLibTrapCustom + 129)
  • #define P1clTrapDeleteRepeatInfo (sysLibTrapCustom + 130)
  • #define P1clTrapDeleteAlarmInfo (sysLibTrapCustom + 131)
  • #define P1clTrapAccountReset (sysLibTrapCustom + 132)
  • #define P1clTrapAddMultiDayEvent2 (sysLibTrapCustom + 133)
  • #define P1clTrapTxnGetChange2 (sysLibTrapCustom + 134)
  • #define P1clTrapPurgeAllAppts (sysLibTrapCustom + 135)
  • #define P1clTrapDeleteOldAndDuplicates (sysLibTrapCustom + 136)
  • #define P1clTrapAccountResetServerId (sysLibTrapCustom + 137)
  • #define P1clTrapAddLocalToTransactionLog (sysLibTrapCustom + 138)
  • #define P1clTrapSortCalendarSpecial (sysLibTrapCustom + 139)
  • #define P1clTrapTxnIsKnownDataSource (sysLibTrapCustom + 140)
  • #define P1clTrapSetServerIdByUniqueID (sysLibTrapCustom + 141)
  • #define P1clTrapPerformPostSyncFunctions (sysLibTrapCustom + 142)

Typedefs

  • typedef P1clRecordDetails * P1clRecordDetailsPtr
  • typedef UInt8 P1clListFieldType
  • typedef UInt8 P1clTimeZoneType
  • typedef UInt8 P1clActionType
  • typedef UInt8 P1clAlarmUnitType
  • typedef UInt8 P1clRepeatTypes
  • typedef UInt8 P1clFieldTypes
  • typedef UInt8 P1clDeleteType
  • typedef UInt8 AttachType
  • typedef UInt8 P1clAttendeeRoleType
  • typedef UInt8 P1clAttendeeFieldType
  • typedef UInt8 P1clTxnEntry
  • typedef UInt8 P1clApptStatusType
  • typedef MemHandle P1clApptHandle
  • typedef MemHandle P1clAttachHandle
  • typedef MemHandle P1clApptListHandle
  • typedef MemHandle P1clSession
  • typedef MemHandle P1clAttendeeHandle
  • typedef MemHandle P1clTxnIterator
  • typedef UInt32 P1clSyncSource
  • typedef UInt32 P1clPersistentID
  • typedef UInt32 IDatSyncSource
  • typedef Boolean(*) DateBookCompAttachFucPtr (void *pSource, void *SearchString)

Enumerations

  • enum _P1clListFieldType {
    P1clListStartTime,
    P1clListEndTime,
    P1clListStartSec,
    P1clListEndSec,
    P1clListStartedDayBefore,
    P1clListContinuesOnNextDay,
    P1clListRepeatsDaily,
    P1clListIsFirstOccurrence,
    P1clListIsLastOccurrence,
    P1clListUId,
    P1clListIndex
    }
  • enum _P1clTimeZoneType {
    P1clDeviceTimeZone,
    P1clEventTimeZone
    }
  • enum _P1clActionType {
    P1clAdd,
    P1clUpdate,
    P1clDelete
    }
  • enum _P1clAlarmUnitType {
    P1clMinutes,
    P1clHours,
    P1clDays
    }
  • enum _P1clRepeatTypes {
    P1clrepeatNone,
    P1clrepeatDaily,
    P1clrepeatWeekly,
    P1clrepeatMonthlyByDay,
    P1clrepeatMonthlyByDate,
    P1clrepeatYearly
    }
  • enum _P1clFieldsTypes {
    P1clStartTime,
    P1clEndTime,
    P1clDateOfAppt,
    P1clrepeatEndDate,
    P1clrepeatFreq,
    P1clrepeatOn,
    P1clrepeatStartofWeek,
    P1clrepeatType,
    P1clalarmAdvance,
    P1clalarmUnit,
    P1clNote,
    P1clDescription,
    P1clLocation,
    P1clExceptionDate,
    P1clNumOfAttendee,
    P1clStartDateTimeOfAppt,
    P1clUID,
    P1clIndex,
    P1clCategory,
    P1clColor,
    P1clPrivate,
    P1clBusy,
    P1clDirty,
    P1clTzuTC,
    P1clTzdSTStart,
    P1clTzdSTEnd,
    P1clTzdSTAdjustmentInMinutes,
    P1clTzCountry,
    P1clTzcustom,
    P1clTzLocName,
    P1clApptStatus,
    P1clMaxCategoryLength,
    P1clNumFields
    }
  • enum _P1clDeleteType {
    P1clNoType,
    P1clDeleteCurrent,
    P1clDeleteCurrentFuture,
    P1clDeleteAll,
    P1clRemoveAll
    }
  • enum _P1clAttachType {
    P1clCreatorIDType,
    P1clBlobSizeType,
    P1clDataBlobType
    }
  • enum _P1clAttendeeRoleType {
    P1cloriginator,
    P1clrequiredAttendee,
    P1cloptionalAttendee
    }
  • enum _P1clAttendeeFieldType {
    P1clAttendeeRole,
    P1clAttendeeName,
    P1clAttendeeEmail
    }
  • enum _P1clTxnEntry {
    P1clNewEntry,
    P1clModifyEntry,
    P1clDeleteEntry
    }
  • enum _P1clApptStatusType {
    P1clShowAsBusy,
    P1clShowAsFree,
    P1clShowAsTentative,
    P1clShowAsOutOfOffice
    }

Define Documentation

#define apptMaxTimeZoneNameLen kLocNameMaxLength

Definition at line 40 of file DatebookLibCommon.h.

#define P1cl_CURRENT_VERSION 0x0200

Definition at line 37 of file DatebookLibCommon.h.

#define P1clErrAlarmDoesNotExist (P1clErrorClass | 11)

Definition at line 58 of file DatebookLibCommon.h.

#define P1clErrAlreadyInUse (P1clErrorClass | 6)

Definition at line 53 of file DatebookLibCommon.h.

#define P1clErrAlreadyInWriteMode (P1clErrorClass | 27)

Definition at line 73 of file DatebookLibCommon.h.

#define P1clErrAppInfoIsMising (P1clErrorClass | 33)

Definition at line 79 of file DatebookLibCommon.h.

#define P1clErrApptBusy (P1clErrorClass | 39)

Definition at line 85 of file DatebookLibCommon.h.

#define P1clErrApptNotFound (P1clErrorClass | 16)

Definition at line 63 of file DatebookLibCommon.h.

#define P1clErrApptNotLocked (P1clErrorClass | 38)

Definition at line 84 of file DatebookLibCommon.h.

#define P1clErrAttachAlreadyExist (P1clErrorClass | 17)

Definition at line 64 of file DatebookLibCommon.h.

#define P1clErrAttachNotExist (P1clErrorClass | 18)

Definition at line 65 of file DatebookLibCommon.h.

#define P1clErrAttachOverflow (P1clErrorClass | 22)

Definition at line 68 of file DatebookLibCommon.h.

#define P1clErrAttachOverFlow (P1clErrorClass | 19)

Definition at line 66 of file DatebookLibCommon.h.

#define P1clErrAttendeeNotFound (P1clErrorClass | 43)

Definition at line 89 of file DatebookLibCommon.h.

#define P1clErrAttendeeOutofLimit (P1clErrorClass | 44)

Definition at line 90 of file DatebookLibCommon.h.

#define P1clErrCategoryNotFound (P1clErrorClass | 5)

Definition at line 52 of file DatebookLibCommon.h.

#define P1clErrDescDoesNotExist (P1clErrorClass | 13)

Definition at line 60 of file DatebookLibCommon.h.

#define P1clErrEmptyAppt (P1clErrorClass | 40)

Definition at line 86 of file DatebookLibCommon.h.

#define P1clErrEmptyDateBook (P1clErrorClass | 10)

Definition at line 57 of file DatebookLibCommon.h.

#define P1clErrFailedToEmptyDatabase (P1clErrorClass | 46)

Definition at line 92 of file DatebookLibCommon.h.

#define P1clErrFieldNotExist (P1clErrorClass | 41)

Definition at line 87 of file DatebookLibCommon.h.

#define P1clErrFieldNotFound (P1clErrorClass | 30)

Definition at line 76 of file DatebookLibCommon.h.

#define P1clErrInvalidAppInfoBlock (P1clErrorClass | 32)

Definition at line 78 of file DatebookLibCommon.h.

#define P1clErrInvalidAtrib (P1clErrorClass | 29)

Definition at line 75 of file DatebookLibCommon.h.

#define P1clErrInvalidField (P1clErrorClass | 23)

Definition at line 69 of file DatebookLibCommon.h.

#define P1clErrInvalidHandle (P1clErrorClass | 2)

Definition at line 49 of file DatebookLibCommon.h.

#define P1clErrInvalidParam (P1clErrorClass | 3)

Definition at line 50 of file DatebookLibCommon.h.

#define P1clErrInvalidReference (P1clErrorClass | 15)

Definition at line 62 of file DatebookLibCommon.h.

#define P1clErrInvalidSession (P1clErrorClass | 28)

Definition at line 74 of file DatebookLibCommon.h.

#define P1clErrLibAlreadyInUse (P1clErrorClass | 25)

Definition at line 71 of file DatebookLibCommon.h.

#define P1clErrLibStillOpen (P1clErrorClass | 45)

Definition at line 91 of file DatebookLibCommon.h.

#define P1clErrListNotExist (P1clErrorClass | 37)

Definition at line 83 of file DatebookLibCommon.h.

#define P1clErrMaxLimitReached (P1clErrorClass | 36)

Definition at line 82 of file DatebookLibCommon.h.

#define P1clErrNoDateTime (P1clErrorClass | 24)

Definition at line 70 of file DatebookLibCommon.h.

#define P1clErrNoteDoesNotExist (P1clErrorClass | 14)

Definition at line 61 of file DatebookLibCommon.h.

#define P1clErrorClass (appErrorClass |0x7000)

Definition at line 47 of file DatebookLibCommon.h.

#define P1clErrOutOfMemory (P1clErrorClass | 8)

Definition at line 55 of file DatebookLibCommon.h.

#define P1clErrReadOnlySession (P1clErrorClass | 34)

Definition at line 80 of file DatebookLibCommon.h.

#define P1clErrRecordNotFound (P1clErrorClass | 21)

Definition at line 67 of file DatebookLibCommon.h.

#define P1clErrRepeatInfoDoesNotExist (P1clErrorClass | 12)

Definition at line 59 of file DatebookLibCommon.h.

#define P1clErrRepeatTypeDoesNotExist (P1clErrorClass | 42)

Definition at line 88 of file DatebookLibCommon.h.

#define P1clErrSizeParamOverFlow (P1clErrorClass | 9)

Definition at line 56 of file DatebookLibCommon.h.

#define P1clErrStringNotFound (P1clErrorClass | 31)

Definition at line 77 of file DatebookLibCommon.h.

#define P1clErrTooManyClients (P1clErrorClass | 1)

Definition at line 48 of file DatebookLibCommon.h.

#define P1clErrTooManySession (P1clErrorClass | 26)

Definition at line 72 of file DatebookLibCommon.h.

#define P1clErrUIdExist (P1clErrorClass | 35)

Definition at line 81 of file DatebookLibCommon.h.

#define P1clErrUIdNotFound (P1clErrorClass | 4)

Definition at line 51 of file DatebookLibCommon.h.

#define P1clErrVerNotSupported (P1clErrorClass | 7)

Definition at line 54 of file DatebookLibCommon.h.

#define P1clLibCreatorID 'P1CL'

Definition at line 29 of file DatebookLibCommon.h.

#define P1clLibName "CalendarLib-P1CL"

Definition at line 31 of file DatebookLibCommon.h.

#define P1clTrapAccountReset (sysLibTrapCustom + 132)

Definition at line 485 of file DatebookLibCommon.h.

#define P1clTrapAccountResetServerId (sysLibTrapCustom + 137)

Definition at line 490 of file DatebookLibCommon.h.

#define P1clTrapAddAllToTransactionLog (sysLibTrapCustom + 126)

Definition at line 479 of file DatebookLibCommon.h.

#define P1clTrapAddAppt (sysLibTrapCustom + 21)

Definition at line 374 of file DatebookLibCommon.h.

#define P1clTrapAddAttendee (sysLibTrapCustom + 61)

Definition at line 414 of file DatebookLibCommon.h.

#define P1clTrapAddExceptionDate (sysLibTrapCustom + 55)

Definition at line 408 of file DatebookLibCommon.h.

#define P1clTrapAddExceptionExt (sysLibTrapCustom + 128)

Definition at line 481 of file DatebookLibCommon.h.

#define P1clTrapAddLocalToTransactionLog (sysLibTrapCustom + 138)

Definition at line 491 of file DatebookLibCommon.h.

#define P1clTrapAddMultiDayEvent (sysLibTrapCustom + 125)

Definition at line 478 of file DatebookLibCommon.h.

#define P1clTrapAddMultiDayEvent2 (sysLibTrapCustom + 133)

Definition at line 486 of file DatebookLibCommon.h.

#define P1clTrapApptFindNextRepeat (sysLibTrapCustom + 11)

Definition at line 364 of file DatebookLibCommon.h.

#define P1clTrapApptGetFirstOccurrence (sysLibTrapCustom + 112)

Definition at line 465 of file DatebookLibCommon.h.

#define P1clTrapApptPostTriggeredAlarms (sysLibTrapCustom + 28)

Definition at line 381 of file DatebookLibCommon.h.

#define P1clTrapApptRepeatsOnDate (sysLibTrapCustom + 12)

Definition at line 365 of file DatebookLibCommon.h.

#define P1clTrapApptTimeZoneAbbreviation (sysLibTrapCustom + 108)

Definition at line 461 of file DatebookLibCommon.h.

#define P1clTrapApptTimeZoneCompare (sysLibTrapCustom + 109)

Definition at line 462 of file DatebookLibCommon.h.

#define P1clTrapAttnForgetIt (sysLibTrapCustom + 27)

Definition at line 380 of file DatebookLibCommon.h.

#define P1clTrapCategoryCreateList (sysLibTrapCustom + 102)

Definition at line 455 of file DatebookLibCommon.h.

#define P1clTrapCategoryDrawBullet (sysLibTrapCustom + 93)

Definition at line 446 of file DatebookLibCommon.h.

#define P1clTrapCategoryEdit (sysLibTrapCustom + 92)

Definition at line 445 of file DatebookLibCommon.h.

#define P1clTrapCategoryFind (sysLibTrapCustom + 100)

Definition at line 453 of file DatebookLibCommon.h.

#define P1clTrapCategoryFreeList (sysLibTrapCustom + 101)

Definition at line 454 of file DatebookLibCommon.h.

#define P1clTrapCategoryGetColor (sysLibTrapCustom + 96)

Definition at line 449 of file DatebookLibCommon.h.

#define P1clTrapCategoryGetName (sysLibTrapCustom + 99)

Definition at line 452 of file DatebookLibCommon.h.

#define P1clTrapCategoryGetNext (sysLibTrapCustom + 89)

Definition at line 442 of file DatebookLibCommon.h.

#define P1clTrapCategoryGetRGBColor (sysLibTrapCustom + 95)

Definition at line 448 of file DatebookLibCommon.h.

#define P1clTrapCategoryGetUnusedColor (sysLibTrapCustom + 97)

Definition at line 450 of file DatebookLibCommon.h.

#define P1clTrapCategoryGetVersion (sysLibTrapCustom + 103)

Definition at line 456 of file DatebookLibCommon.h.

#define P1clTrapCategoryPopupList (sysLibTrapCustom + 90)

Definition at line 443 of file DatebookLibCommon.h.

#define P1clTrapCategorySelect (sysLibTrapCustom + 91)

Definition at line 444 of file DatebookLibCommon.h.

#define P1clTrapCategorySetColor (sysLibTrapCustom + 94)

Definition at line 447 of file DatebookLibCommon.h.

#define P1clTrapCategorySetName (sysLibTrapCustom + 98)

Definition at line 451 of file DatebookLibCommon.h.

#define P1clTrapCategorySetTriggerLabel (sysLibTrapCustom + 88)

Definition at line 441 of file DatebookLibCommon.h.

#define P1clTrapCategoryTruncateName (sysLibTrapCustom + 87)

Definition at line 440 of file DatebookLibCommon.h.

#define P1clTrapCheckVersion (sysLibTrapCustom + 1)

Definition at line 354 of file DatebookLibCommon.h.

#define P1clTrapCloseSession (sysLibTrapCustom + 3)

Definition at line 356 of file DatebookLibCommon.h.

#define P1clTrapConvertFromDeviceTimeZone (sysLibTrapCustom + 105)

Definition at line 458 of file DatebookLibCommon.h.

#define P1clTrapConvertToDeviceTimeZone (sysLibTrapCustom + 106)

Definition at line 459 of file DatebookLibCommon.h.

#define P1clTrapCopyRepeatDescription (sysLibTrapCustom + 121)

Definition at line 474 of file DatebookLibCommon.h.

#define P1clTrapCopyStringField (sysLibTrapCustom + 115)

Definition at line 468 of file DatebookLibCommon.h.

#define P1clTrapCountryForTimeZoneAbbreviation (sysLibTrapCustom + 107)

Definition at line 460 of file DatebookLibCommon.h.

#define P1clTrapCreateAttendeeHandle (sysLibTrapCustom + 56)

Definition at line 409 of file DatebookLibCommon.h.

#define P1clTrapCreateBlobHandle (sysLibTrapCustom + 68)

Definition at line 421 of file DatebookLibCommon.h.

#define P1clTrapCreateException (sysLibTrapCustom + 30)

Definition at line 383 of file DatebookLibCommon.h.

#define P1clTrapCreateHandle (sysLibTrapCustom + 4)

Definition at line 357 of file DatebookLibCommon.h.

#define P1clTrapDateExportVCal (sysLibTrapCustom + 116)

Definition at line 469 of file DatebookLibCommon.h.

#define P1clTrapDateSetGoToParams (sysLibTrapCustom + 119)

Definition at line 472 of file DatebookLibCommon.h.

#define P1clTrapDeleteAlarmInfo (sysLibTrapCustom + 131)

Definition at line 484 of file DatebookLibCommon.h.

#define P1clTrapDeleteAppt (sysLibTrapCustom + 22)

Definition at line 375 of file DatebookLibCommon.h.

#define P1clTrapDeleteAttendee (sysLibTrapCustom + 63)

Definition at line 416 of file DatebookLibCommon.h.

#define P1clTrapDeleteBlob (sysLibTrapCustom + 72)

Definition at line 425 of file DatebookLibCommon.h.

#define P1clTrapDeleteExceptionList (sysLibTrapCustom + 31)

Definition at line 384 of file DatebookLibCommon.h.

#define P1clTrapDeleteOldAndDuplicates (sysLibTrapCustom + 136)

Definition at line 489 of file DatebookLibCommon.h.

#define P1clTrapDeleteRepeatInfo (sysLibTrapCustom + 130)

Definition at line 483 of file DatebookLibCommon.h.

#define P1clTrapDeleteServerId (sysLibTrapCustom + 84)

Definition at line 437 of file DatebookLibCommon.h.

#define P1clTrapFindConflict (sysLibTrapCustom + 32)

Definition at line 385 of file DatebookLibCommon.h.

#define P1clTrapFindNextAlarm (sysLibTrapCustom + 23)

Definition at line 376 of file DatebookLibCommon.h.

#define P1clTrapFindSaveMatch (sysLibTrapCustom + 25)

Definition at line 378 of file DatebookLibCommon.h.

#define P1clTrapGetAppt (sysLibTrapCustom + 6)

Definition at line 359 of file DatebookLibCommon.h.

#define P1clTrapGetApptFromListHandle (sysLibTrapCustom + 19)

Definition at line 372 of file DatebookLibCommon.h.

#define P1clTrapGetApptFromServerId (sysLibTrapCustom + 85)

Definition at line 438 of file DatebookLibCommon.h.

#define P1clTrapGetApptList (sysLibTrapCustom + 14)

Definition at line 367 of file DatebookLibCommon.h.

#define P1clTrapGetAttendee (sysLibTrapCustom + 60)

Definition at line 413 of file DatebookLibCommon.h.

#define P1clTrapGetAttendeeStringField (sysLibTrapCustom + 66)

Definition at line 419 of file DatebookLibCommon.h.

#define P1clTrapGetAttendeeUInt8Field (sysLibTrapCustom + 64)

Definition at line 417 of file DatebookLibCommon.h.

#define P1clTrapGetBlob (sysLibTrapCustom + 70)

Definition at line 423 of file DatebookLibCommon.h.

#define P1clTrapGetBlobCreatorId (sysLibTrapCustom + 75)

Definition at line 428 of file DatebookLibCommon.h.

#define P1clTrapGetBlobData (sysLibTrapCustom + 73)

Definition at line 426 of file DatebookLibCommon.h.

#define P1clTrapGetBooleanFromListHandle (sysLibTrapCustom + 18)

Definition at line 371 of file DatebookLibCommon.h.

#define P1clTrapGetCalendarDBInfo (sysLibTrapCustom + 29)

Definition at line 382 of file DatebookLibCommon.h.

#define P1clTrapGetConflict (sysLibTrapCustom + 122)

Definition at line 475 of file DatebookLibCommon.h.

#define P1clTrapGetDateField (sysLibTrapCustom + 49)

Definition at line 402 of file DatebookLibCommon.h.

#define P1clTrapGetDateTimeField (sysLibTrapCustom + 45)

Definition at line 398 of file DatebookLibCommon.h.

#define P1clTrapGetDefaultTimeZone (sysLibTrapCustom + 123)

Definition at line 476 of file DatebookLibCommon.h.

#define P1clTrapGetDSTField (sysLibTrapCustom + 51)

Definition at line 404 of file DatebookLibCommon.h.

#define P1clTrapGetExceptionDate (sysLibTrapCustom + 129)

Definition at line 482 of file DatebookLibCommon.h.

#define P1clTrapGetExtendedDescription (sysLibTrapCustom + 110)

Definition at line 463 of file DatebookLibCommon.h.

#define P1clTrapGetFirstAppt (sysLibTrapCustom + 7)

Definition at line 360 of file DatebookLibCommon.h.

#define P1clTrapGetFirstAttendee (sysLibTrapCustom + 58)

Definition at line 411 of file DatebookLibCommon.h.

#define P1clTrapGetInt16Field (sysLibTrapCustom + 41)

Definition at line 394 of file DatebookLibCommon.h.

#define P1clTrapGetInt8Field (sysLibTrapCustom + 37)

Definition at line 390 of file DatebookLibCommon.h.

#define P1clTrapGetLastError (sysLibTrapCustom + 77)

Definition at line 430 of file DatebookLibCommon.h.

#define P1clTrapGetNextAppt (sysLibTrapCustom + 8)

Definition at line 361 of file DatebookLibCommon.h.

#define P1clTrapGetNextAttendee (sysLibTrapCustom + 59)

Definition at line 412 of file DatebookLibCommon.h.

#define P1clTrapGetNumOfException (sysLibTrapCustom + 53)

Definition at line 406 of file DatebookLibCommon.h.

#define P1clTrapGetSessionInfo (sysLibTrapCustom + 120)

Definition at line 473 of file DatebookLibCommon.h.

#define P1clTrapGetStringField (sysLibTrapCustom + 33)

Definition at line 386 of file DatebookLibCommon.h.

#define P1clTrapGetTimeField (sysLibTrapCustom + 47)

Definition at line 400 of file DatebookLibCommon.h.

#define P1clTrapGetTimeFromListHandle (sysLibTrapCustom + 16)

Definition at line 369 of file DatebookLibCommon.h.

#define P1clTrapGetUInt16Field (sysLibTrapCustom + 39)

Definition at line 392 of file DatebookLibCommon.h.

#define P1clTrapGetUInt16FromListHandle (sysLibTrapCustom + 15)

Definition at line 368 of file DatebookLibCommon.h.

#define P1clTrapGetUInt32Field (sysLibTrapCustom + 43)

Definition at line 396 of file DatebookLibCommon.h.

#define P1clTrapGetUInt32FromListHandle (sysLibTrapCustom + 17)

Definition at line 370 of file DatebookLibCommon.h.

#define P1clTrapGetUInt8Field (sysLibTrapCustom + 35)

Definition at line 388 of file DatebookLibCommon.h.

#define P1clTrapGetVersion (sysLibTrapCustom)

Definition at line 353 of file DatebookLibCommon.h.

#define P1clTrapGiveAllTimedEventsTimeZones (sysLibTrapCustom + 104)

Definition at line 457 of file DatebookLibCommon.h.

#define P1clTrapHasExtendedDescription (sysLibTrapCustom + 111)

Definition at line 464 of file DatebookLibCommon.h.

#define P1clTrapHasMultipleOccurences (sysLibTrapCustom + 13)

Definition at line 366 of file DatebookLibCommon.h.

#define P1clTrapIsEmptyAppt (sysLibTrapCustom + 9)

Definition at line 362 of file DatebookLibCommon.h.

#define P1clTrapIsException (sysLibTrapCustom + 54)

Definition at line 407 of file DatebookLibCommon.h.

#define P1clTrapLogMarkAllCompleted (sysLibTrapCustom + 81)

Definition at line 434 of file DatebookLibCommon.h.

#define P1clTrapNumRecordsInCategory (sysLibTrapCustom + 117)

Definition at line 470 of file DatebookLibCommon.h.

#define P1clTrapOpenSession (sysLibTrapCustom + 2)

Definition at line 355 of file DatebookLibCommon.h.

#define P1clTrapPerformPostSyncFunctions (sysLibTrapCustom + 142)

Definition at line 495 of file DatebookLibCommon.h.

#define P1clTrapPurgeAllAppts (sysLibTrapCustom + 135)

Definition at line 488 of file DatebookLibCommon.h.

#define P1clTrapPurgeAppts (sysLibTrapCustom + 26)

Definition at line 379 of file DatebookLibCommon.h.

#define P1clTrapReleaseAttendeeHandle (sysLibTrapCustom + 57)

Definition at line 410 of file DatebookLibCommon.h.

#define P1clTrapReleaseBlobHandle (sysLibTrapCustom + 69)

Definition at line 422 of file DatebookLibCommon.h.

#define P1clTrapReleaseHandle (sysLibTrapCustom + 5)

Definition at line 358 of file DatebookLibCommon.h.

#define P1clTrapSeekRecordInCategory (sysLibTrapCustom + 118)

Definition at line 471 of file DatebookLibCommon.h.

#define P1clTrapSetAttendeeStringField (sysLibTrapCustom + 67)

Definition at line 420 of file DatebookLibCommon.h.

#define P1clTrapSetAttendeeUInt8Field (sysLibTrapCustom + 65)

Definition at line 418 of file DatebookLibCommon.h.

#define P1clTrapSetBlob (sysLibTrapCustom + 71)

Definition at line 424 of file DatebookLibCommon.h.

#define P1clTrapSetBlobCreatorId (sysLibTrapCustom + 76)

Definition at line 429 of file DatebookLibCommon.h.

#define P1clTrapSetBlobData (sysLibTrapCustom + 74)

Definition at line 427 of file DatebookLibCommon.h.

#define P1clTrapSetDateField (sysLibTrapCustom + 50)

Definition at line 403 of file DatebookLibCommon.h.

#define P1clTrapSetDateTimeField (sysLibTrapCustom + 46)

Definition at line 399 of file DatebookLibCommon.h.

#define P1clTrapSetDSTField (sysLibTrapCustom + 52)

Definition at line 405 of file DatebookLibCommon.h.

#define P1clTrapSetExceptionExt (sysLibTrapCustom + 127)

Definition at line 480 of file DatebookLibCommon.h.

#define P1clTrapSetInt16Field (sysLibTrapCustom + 42)

Definition at line 395 of file DatebookLibCommon.h.

#define P1clTrapSetInt8Field (sysLibTrapCustom + 38)

Definition at line 391 of file DatebookLibCommon.h.

#define P1clTrapSetRepeateEndDate (sysLibTrapCustom + 124)

Definition at line 477 of file DatebookLibCommon.h.

#define P1clTrapSetServerId (sysLibTrapCustom + 86)

Definition at line 439 of file DatebookLibCommon.h.

#define P1clTrapSetServerIdByUniqueID (sysLibTrapCustom + 141)

Definition at line 494 of file DatebookLibCommon.h.

#define P1clTrapSetStringField (sysLibTrapCustom + 34)

Definition at line 387 of file DatebookLibCommon.h.

#define P1clTrapSetTimeField (sysLibTrapCustom + 48)

Definition at line 401 of file DatebookLibCommon.h.

#define P1clTrapSetUInt16Field (sysLibTrapCustom + 40)

Definition at line 393 of file DatebookLibCommon.h.

#define P1clTrapSetUInt32Field (sysLibTrapCustom + 44)

Definition at line 397 of file DatebookLibCommon.h.

#define P1clTrapSetUInt8Field (sysLibTrapCustom + 36)

Definition at line 389 of file DatebookLibCommon.h.

#define P1clTrapSortCalendar (sysLibTrapCustom + 24)

Definition at line 377 of file DatebookLibCommon.h.

#define P1clTrapSortCalendarSpecial (sysLibTrapCustom + 139)

Definition at line 492 of file DatebookLibCommon.h.

#define P1clTrapSplitRepeatingEvent (sysLibTrapCustom + 10)

Definition at line 363 of file DatebookLibCommon.h.

#define P1clTrapTxnGetChange (sysLibTrapCustom + 79)

Definition at line 432 of file DatebookLibCommon.h.

#define P1clTrapTxnGetChange2 (sysLibTrapCustom + 134)

Definition at line 487 of file DatebookLibCommon.h.

#define P1clTrapTxnGetNumChanges (sysLibTrapCustom + 80)

Definition at line 433 of file DatebookLibCommon.h.

#define P1clTrapTxnIsKnownDataSource (sysLibTrapCustom + 140)

Definition at line 493 of file DatebookLibCommon.h.

#define P1clTrapTxnLogMarkCompleted (sysLibTrapCustom + 82)

Definition at line 435 of file DatebookLibCommon.h.

#define P1clTrapTxnPrepareSync (sysLibTrapCustom + 78)

Definition at line 431 of file DatebookLibCommon.h.

#define P1clTrapTxnSyncComplete (sysLibTrapCustom + 83)

Definition at line 436 of file DatebookLibCommon.h.

#define P1clTrapUpdateAppt (sysLibTrapCustom + 20)

Definition at line 373 of file DatebookLibCommon.h.

#define P1clTrapUpdateAttendee (sysLibTrapCustom + 62)

Definition at line 415 of file DatebookLibCommon.h.

#define P1clTrapUpdateEventsWithDeletedTimeZone (sysLibTrapCustom + 113)

Definition at line 466 of file DatebookLibCommon.h.

#define P1clTrapUpdateEventsWithEditedTimeZone (sysLibTrapCustom + 114)

Definition at line 467 of file DatebookLibCommon.h.

#define P1clTypeID sysFileTLibrary

Definition at line 30 of file DatebookLibCommon.h.

#define SysNotifyPIMRecordChange 'pmdb'

Definition at line 41 of file DatebookLibCommon.h.

Typedef Documentation

typedef UInt8 AttachType

Definition at line 226 of file DatebookLibCommon.h.

typedef Boolean(* ) DateBookCompAttachFucPtr(void *pSource, void *SearchString)

Definition at line 350 of file DatebookLibCommon.h.

typedef UInt32 IDatSyncSource

Definition at line 348 of file DatebookLibCommon.h.

typedef UInt8 P1clActionType

Definition at line 140 of file DatebookLibCommon.h.

typedef UInt8 P1clAlarmUnitType

Definition at line 150 of file DatebookLibCommon.h.

typedef MemHandle P1clApptHandle

Definition at line 333 of file DatebookLibCommon.h.

typedef MemHandle P1clApptListHandle

Definition at line 335 of file DatebookLibCommon.h.

typedef UInt8 P1clApptStatusType

Definition at line 268 of file DatebookLibCommon.h.

typedef MemHandle P1clAttachHandle

Definition at line 334 of file DatebookLibCommon.h.

typedef UInt8 P1clAttendeeFieldType

Definition at line 246 of file DatebookLibCommon.h.

typedef MemHandle P1clAttendeeHandle

Definition at line 337 of file DatebookLibCommon.h.

typedef UInt8 P1clAttendeeRoleType

Definition at line 236 of file DatebookLibCommon.h.

typedef UInt8 P1clDeleteType

Definition at line 216 of file DatebookLibCommon.h.

typedef UInt8 P1clFieldTypes

Definition at line 203 of file DatebookLibCommon.h.

typedef UInt8 P1clListFieldType

Definition at line 121 of file DatebookLibCommon.h.

typedef UInt32 P1clPersistentID

Definition at line 340 of file DatebookLibCommon.h.

typedef P1clRecordDetails* P1clRecordDetailsPtr

Definition at line 103 of file DatebookLibCommon.h.

typedef UInt8 P1clRepeatTypes

Definition at line 163 of file DatebookLibCommon.h.

typedef MemHandle P1clSession

Definition at line 336 of file DatebookLibCommon.h.

typedef UInt32 P1clSyncSource

Definition at line 339 of file DatebookLibCommon.h.

typedef UInt8 P1clTimeZoneType

Definition at line 130 of file DatebookLibCommon.h.

typedef UInt8 P1clTxnEntry

Definition at line 256 of file DatebookLibCommon.h.

typedef MemHandle P1clTxnIterator

Definition at line 338 of file DatebookLibCommon.h.

Enumeration Type Documentation

enum _P1clActionType

Enumerator:
P1clAdd
P1clUpdate
P1clDelete

Definition at line 133 of file DatebookLibCommon.h.

00134 {
00135     P1clAdd,
00136     P1clUpdate,
00137     P1clDelete
00138 };

enum _P1clAlarmUnitType

Enumerator:
P1clMinutes
P1clHours
P1clDays

Definition at line 143 of file DatebookLibCommon.h.

00144 {
00145     P1clMinutes,
00146     P1clHours,
00147     P1clDays
00148 };

enum _P1clApptStatusType

Enumerator:
P1clShowAsBusy
P1clShowAsFree
P1clShowAsTentative
P1clShowAsOutOfOffice

Definition at line 260 of file DatebookLibCommon.h.

00261 {
00262     P1clShowAsBusy,                 // (default) Show as busy to strongly discourage conflicts.
00263     P1clShowAsFree,                 // Allow others to schedule meetings that conflict with this one.
00264     P1clShowAsTentative,            // Show as tentative to discourage conflicts.
00265     P1clShowAsOutOfOffice           // Show as out of office to even more strongly discourage conflicts.
00266 };

enum _P1clAttachType

Enumerator:
P1clCreatorIDType
P1clBlobSizeType
P1clDataBlobType

Definition at line 219 of file DatebookLibCommon.h.

00220 {
00221     P1clCreatorIDType,
00222     P1clBlobSizeType,
00223     P1clDataBlobType
00224 };

enum _P1clAttendeeFieldType

Enumerator:
P1clAttendeeRole
P1clAttendeeName
P1clAttendeeEmail

Definition at line 239 of file DatebookLibCommon.h.

00240 {
00241     P1clAttendeeRole,           // The person who set up the meeting.
00242     P1clAttendeeName,           // An attendee that the originator feels is required.
00243     P1clAttendeeEmail
00244 };

enum _P1clAttendeeRoleType

Enumerator:
P1cloriginator
P1clrequiredAttendee
P1cloptionalAttendee

Definition at line 229 of file DatebookLibCommon.h.

00230 {
00231     P1cloriginator,                 // The person who set up the meeting.
00232     P1clrequiredAttendee,           // An attendee that the originator feels is required.
00233     P1cloptionalAttendee
00234 };

enum _P1clDeleteType

Enumerator:
P1clNoType
P1clDeleteCurrent
P1clDeleteCurrentFuture
P1clDeleteAll
P1clRemoveAll

Definition at line 206 of file DatebookLibCommon.h.

00207 {
00208     P1clNoType,                     //This will be true if the Appointment is non Repeat event
00209     P1clDeleteCurrent,              //This will indicate delete of the event for the current date(Date passed as param to the P1clDeleteAppt)
00210     P1clDeleteCurrentFuture,        //It will indicate the delete of all the future event of the Repeating event
00211     P1clDeleteAll,                  //It will indicate the delete of all the event of the Repeating event
00212     P1clRemoveAll                   //It will Remove the record from the DB same as DmRemoveRecord ()
00213
00214 };

enum _P1clFieldsTypes

Enumerator:
P1clStartTime
P1clEndTime
P1clDateOfAppt
P1clrepeatEndDate
P1clrepeatFreq
P1clrepeatOn
P1clrepeatStartofWeek
P1clrepeatType
P1clalarmAdvance
P1clalarmUnit
P1clNote
P1clDescription
P1clLocation
P1clExceptionDate
P1clNumOfAttendee
P1clStartDateTimeOfAppt
P1clUID
P1clIndex
P1clCategory
P1clColor
P1clPrivate
P1clBusy
P1clDirty
P1clTzuTC
P1clTzdSTStart
P1clTzdSTEnd
P1clTzdSTAdjustmentInMinutes
P1clTzCountry
P1clTzcustom
P1clTzLocName
P1clApptStatus
P1clMaxCategoryLength
P1clNumFields

Definition at line 166 of file DatebookLibCommon.h.

00167 {
00168     P1clStartTime,
00169     P1clEndTime,
00170     P1clDateOfAppt,
00171     P1clrepeatEndDate,
00172     P1clrepeatFreq,
00173     P1clrepeatOn,
00174     P1clrepeatStartofWeek,
00175     P1clrepeatType,
00176     P1clalarmAdvance,
00177     P1clalarmUnit,
00178     P1clNote,
00179     P1clDescription,
00180     P1clLocation,
00181     P1clExceptionDate,
00182     P1clNumOfAttendee,
00183     P1clStartDateTimeOfAppt,                    //Date and time of the appointment in Sec elapsed from 12:00AM Jan 1, 1904
00184     P1clUID,                            //Place for the attributes These will be after P1ctaddressFieldsCount
00185     P1clIndex,
00186     P1clCategory,
00187     P1clColor,
00188     P1clPrivate,
00189     P1clBusy,
00190     P1clDirty,
00191     P1clTzuTC,
00192     P1clTzdSTStart,
00193     P1clTzdSTEnd,
00194     P1clTzdSTAdjustmentInMinutes,
00195     P1clTzCountry,
00196     P1clTzcustom,
00197     P1clTzLocName,
00198     P1clApptStatus,
00199     P1clMaxCategoryLength,
00200     P1clNumFields
00201 };

enum _P1clListFieldType

Enumerator:
P1clListStartTime
P1clListEndTime
P1clListStartSec
P1clListEndSec
P1clListStartedDayBefore
P1clListContinuesOnNextDay
P1clListRepeatsDaily
P1clListIsFirstOccurrence
P1clListIsLastOccurrence
P1clListUId
P1clListIndex

Definition at line 106 of file DatebookLibCommon.h.

00107 {
00108     P1clListStartTime,
00109     P1clListEndTime,
00110     P1clListStartSec,
00111     P1clListEndSec,
00112     P1clListStartedDayBefore,
00113     P1clListContinuesOnNextDay,
00114     P1clListRepeatsDaily,
00115     P1clListIsFirstOccurrence,
00116     P1clListIsLastOccurrence,
00117     P1clListUId,
00118     P1clListIndex
00119 };

enum _P1clRepeatTypes

Enumerator:
P1clrepeatNone
P1clrepeatDaily
P1clrepeatWeekly
P1clrepeatMonthlyByDay
P1clrepeatMonthlyByDate
P1clrepeatYearly

Definition at line 153 of file DatebookLibCommon.h.

00154 {
00155     P1clrepeatNone,
00156     P1clrepeatDaily,
00157     P1clrepeatWeekly,
00158     P1clrepeatMonthlyByDay,
00159     P1clrepeatMonthlyByDate,
00160     P1clrepeatYearly
00161 };

enum _P1clTimeZoneType

Enumerator:
P1clDeviceTimeZone
P1clEventTimeZone

Definition at line 124 of file DatebookLibCommon.h.

00125 {
00126     P1clDeviceTimeZone,     //Current Time Zone of the Device
00127     P1clEventTimeZone       //Time zone of the Event. I.e. Time zone of the event when it was created/updated.
00128 };

enum _P1clTxnEntry

Enumerator:
P1clNewEntry
P1clModifyEntry
P1clDeleteEntry

Definition at line 249 of file DatebookLibCommon.h.

00250 {
00251     P1clNewEntry,
00252     P1clModifyEntry,
00253     P1clDeleteEntry
00254  };

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:57 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » defaulthelperlibrary

DefaultHelperLib.h File Reference

Detailed Description

Default Helper library owns control over the Default Helpers database.

Definition in file DefaultHelperLib.h.

Go to the source code of this file.

Defines

  • #define DEFAULTHELPERLIB_TRAP(x) SYS_TRAP( x )

Functions

  • Err DefaultHelperLibOpen (UInt16 refNum) DEFAULTHELPERLIB_TRAP(sysLibTrapOpen)
  • Err DefaultHelperLibClose (UInt16 refNum) DEFAULTHELPERLIB_TRAP(sysLibTrapClose)
  • Err DefaultHelperLibWake (UInt16 refNum) DEFAULTHELPERLIB_TRAP(sysLibTrapWake)
  • Err DefaultHelperLibSleep (UInt16 refNum) DEFAULTHELPERLIB_TRAP(sysLibTrapSleep)
  • Err DefaultHelperLibGetDefaultHelper (UInt16 refNum, UInt32 serviceID, UInt32 *defaultAppCreatorP) DEFAULTHELPERLIB_TRAP(defaultHelperLibTrapGetDefaultHelper)
  • Err DefaultHelperLibSetDefaultHelper (UInt16 refNum, UInt32 serviceID, UInt32 defaultAppCreator) DEFAULTHELPERLIB_TRAP(defaultHelperLibTrapSetDefaultHelper)

Define Documentation

#define DEFAULTHELPERLIB_TRAP ( x ) SYS_TRAP( x )

Helper macro.

Definition at line 24 of file DefaultHelperLib.h.

Function Documentation

Err DefaultHelperLibClose ( UInt16 refNum )

Standard library close function

Parameters:
refNum,: IN: Default helper library reference number (from SysLibFind()/SysLibLoad())
Return values:
Err Error code.

Err DefaultHelperLibGetDefaultHelper | ( | UInt16 | refNum,
 |  | UInt32 | serviceID,
 |  | UInt32 * | defaultAppCreatorP
 | ) |  |

Given a specified serviceID, return the creator type of the default helper application.

Parameters:
refNum,: IN: Default helper library reference number (from SysLibFind()/SysLibLoad())
serviceID,: IN: Type of service to get info from.
defaultAppCreatorP OUT: Upon return of the function, a pointer to the creator type of the default application for the specified serviceID.
Return values:
Err Error code.

Err DefaultHelperLibOpen ( UInt16 refNum )

Standard library open function

Parameters:
refNum,: IN: Default helper library reference number (from SysLibFind()/SysLibLoad())
Return values:
Err Error code.

Err DefaultHelperLibSetDefaultHelper | ( | UInt16 | refNum,
 |  | UInt32 | serviceID,
 |  | UInt32 | defaultAppCreator
 | ) |  |

Given a specified serviceID, set the creator type of the default helper application.

Parameters:
refNum,: IN: Default helper library reference number (from SysLibFind()/SysLibLoad())
serviceID,: IN: Type of service to get info from.
defaultAppCreator,: IN: Creator type of the application to be set as the default application for the specified serviceID. If 0, then remove the helper service from the Default Apps database.
Return values:
Err Error code.

Err DefaultHelperLibSleep ( UInt16 refNum )

Standard library sleep function

Parameters:
refNum,: IN: Default helper library reference number (from SysLibFind()/SysLibLoad())
Return values:
Err Error code.

Err DefaultHelperLibWake ( UInt16 refNum )

Standard library wake function

Parameters:
refNum,: IN: Default helper library reference number (from SysLibFind()/SysLibLoad())
Return values:
Err Error code.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:57 2008 for Palm API Guide


Header Files » Incs » common » libraries » defaulthelperlibrary

DefaultHelperLibTypes.h File Reference

Detailed Description

Public 68K common header file for Default Helper Library API.

Version:
1.0
This file contains the type information and constants for Default Helper Library.

Definition in file DefaultHelperLibTypes.h.

Go to the source code of this file.

Defines

  • #define defaultHelperLibName "DefaultHelper-HsDh"
  • #define defaultHelperLibCreator 'HsDh'
  • #define defaultHelperLibType sysFileTLibrary
Error Codes
  • #define defaultHelperLibErrClass 0x9000
  • #define defaultHelperLibErrCreateDBFailed (defaultHelperLibErrClass | 1)
  • #define defaultHelperLibErrNoMemory (defaultHelperLibErrClass | 2)
  • #define defaultHelperLibErrNoHelperApp (defaultHelperLibErrClass | 3)
  • #define defaultHelperLibErrDBNotFound (defaultHelperLibErrClass | 4)
  • #define defaultHelperLibErrDBWriteFailed (defaultHelperLibErrClass | 5)
  • #define defaultHelperLibErrUserCancel (defaultHelperLibErrClass | 6)
  • #define defaultHelperLibErrBadParams (defaultHelperLibErrClass | 7)
Function Traps
  • #define defaultHelperLibTrapGetDefaultHelper sysLibTrapCustom
  • #define defaultHelperLibTrapSetDefaultHelper sysLibTrapCustom+1

Define Documentation

#define defaultHelperLibCreator 'HsDh'

Default Helper Library creator ID

Definition at line 38 of file DefaultHelperLibTypes.h.

#define defaultHelperLibErrBadParams (defaultHelperLibErrClass | 7)

Definition at line 52 of file DefaultHelperLibTypes.h.

#define defaultHelperLibErrClass 0x9000

Definition at line 45 of file DefaultHelperLibTypes.h.

#define defaultHelperLibErrCreateDBFailed (defaultHelperLibErrClass | 1)

Definition at line 46 of file DefaultHelperLibTypes.h.

#define defaultHelperLibErrDBNotFound (defaultHelperLibErrClass | 4)

Definition at line 49 of file DefaultHelperLibTypes.h.

#define defaultHelperLibErrDBWriteFailed (defaultHelperLibErrClass | 5)

Definition at line 50 of file DefaultHelperLibTypes.h.

#define defaultHelperLibErrNoHelperApp (defaultHelperLibErrClass | 3)

Definition at line 48 of file DefaultHelperLibTypes.h.

#define defaultHelperLibErrNoMemory (defaultHelperLibErrClass | 2)

Definition at line 47 of file DefaultHelperLibTypes.h.

#define defaultHelperLibErrUserCancel (defaultHelperLibErrClass | 6)

Definition at line 51 of file DefaultHelperLibTypes.h.

#define defaultHelperLibName "DefaultHelper-HsDh"

Default Helper Library name

Definition at line 37 of file DefaultHelperLibTypes.h.

#define defaultHelperLibTrapGetDefaultHelper sysLibTrapCustom

Definition at line 59 of file DefaultHelperLibTypes.h.

#define defaultHelperLibTrapSetDefaultHelper sysLibTrapCustom+1

Definition at line 60 of file DefaultHelperLibTypes.h.

#define defaultHelperLibType sysFileTLibrary

Standard library type

Definition at line 39 of file DefaultHelperLibTypes.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:57 2008 for Palm API Guide


Header Files » Incs » 68k » system

FarCall.h File Reference

Go to the source code of this file.

Defines

  • #define FAR_CALL(funcName)
  • #define FAR_DECLARE(funcName)
  • #define FAR_PTR(outPtr, funcPtr) do { *(outPtr) = (funcPtr); } while (0)

Define Documentation

#define FAR_CALL ( funcName )

file FarCall.h

Version:
1.0
Date:
06/06/2000
Macros for declaring a function that will be located more than 32K away from its caller. This is trickier than it sounds, since the branch instructions in the 68K don't support greater than 16-bit jumps.

History: 22-feb-2000 dia Initial version 08-mar-2000 dia Fixed off-by-two error (don't know why it worked before). 06-Apr-2000 BP Added support for gcc 2.95 and new callseq attribute 11-Apr-2000 BP Added FAR_PTR for function pointers 06-jun-2000 dia Fixed FAR_PTR--it wasn't loading right.

Definition at line 117 of file FarCall.h.

#define FAR_DECLARE ( funcName )

Value:

funcName##FnType funcName;                              \
            static funcName##FnType * const Far##funcName = funcName                       \

Definition at line 122 of file FarCall.h.

#define FAR_PTR | ( | outPtr,
 |  | funcPtr | ) | do { *(outPtr) = (funcPtr); } while (0)

Definition at line 127 of file FarCall.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:57 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » favoritesdblibrary

FavoritesDBLib.h File Reference

Detailed Description

Contains the API to control the Favorites DB.

Definition in file FavoritesDBLib.h.

Go to the source code of this file.

Enumerations

  • enum FavDBLibPhoneViewEnum {
    favDBLibPhoneViewCallLog = 0,
    favDBLibPhoneViewDialPad,
    favDBLibPhoneViewContacts
    }

Functions

  • Err FavDBLibOpen (UInt16 refNum)
  • Err FavDBLibClose (UInt16 refNum)
  • Err FavDBLibWake (UInt16 refNum)
  • Err FavDBLibSleep (UInt16 refNum)
  • Err FavDBLibNewAppFavorite (UInt16 refNum, Word position, CharPtr labelP, WChar quickKey, Word flags, UInt32 appCreator, WordPtr indexP)
  • Err FavDBLibNewPhoneFavorite (UInt16 refNum, Word position, CharPtr labelP, WChar quickKey, Word flags, CharPtr numberP, CharPtr extraDigitsP, Boolean autoDialExtraDigits, UInt32 ringID, UInt16 ringToneType, WordPtr indexP)
  • Err FavDBLibNewMsgFavorite (UInt16 refNum, Word position, CharPtr labelP, WChar quickKey, Word flags, CharPtr contactIdP, WordPtr indexP)
  • Err FavDBLibNewWebFavorite (UInt16 refNum, Word position, CharPtr labelP, WChar quickKey, Word flags, CharPtr urlP, WordPtr indexP)
  • Err FavDBLibNewEmailFavorite (UInt16 refNum, Word position, CharPtr labelP, WChar quickKey, Word flags, CharPtr contactIdP, WordPtr indexP)
  • Err FavDBLibNewPhoneViewFavorite (UInt16 refNum, Word position, CharPtr labelP, WChar quickKey, Word flags, UInt16 phoneView, WordPtr indexP)
  • CharPtr FavDBLibResolveAddress (UInt16 refNum, CharPtr addressP, Word kind)
  • Boolean FavDBLibSeekSpeedDialRecord (UInt16 refNum, UInt16 *indexP, Int16 offset, Int16 direction)
  • Boolean FavDBLibGetRecordLabel (UInt16 refNum, UInt16 index, CharPtr *labelPP)
  • Err FavDBLibGetRecordId (UInt16 refNum, UInt16 index, UInt32 *uniqueIdP)
  • Err FavDBLibIsFavoriteWithId (UInt16 refNum, UInt32 keyId, BooleanPtr existsP)
  • Boolean FavDBLibGetSpeedDialInfo (UInt16 refNum, UInt16 index, CharPtr *numberPP, CharPtr *extraDigitsPP, BooleanPtr autoExtraDigitsP, BooleanPtr isVoicemailP)
  • Boolean FavDBLibLookupInSpeedDialDB (UInt16 refNum, CharPtr keyP, CharPtr *nameP)

Enumeration Type Documentation

enum FavDBLibPhoneViewEnum

List of different views in the phone applications.

Enumerator:
favDBLibPhoneViewCallLog | call log view
favDBLibPhoneViewDialPad | dial pad view
favDBLibPhoneViewContacts | contacts view

Definition at line 19 of file FavoritesDBLib.h.

00020 {
00021   favDBLibPhoneViewCallLog = 0, /**< call log view */
00022   favDBLibPhoneViewDialPad,     /**< dial pad view */
00023   favDBLibPhoneViewContacts     /**< contacts view */
00024 } FavDBLibPhoneViewEnum;

Function Documentation

Err FavDBLibClose ( UInt16 refNum )

Standard library close function

Parameters:
refNum,: IN: Favorites DB library reference number (from SysLibFind()/SysLibLoad())
Return values:
Err Error code.

Err FavDBLibGetRecordId | ( | UInt16 | refNum,
 |  | UInt16 | index,
 |  | UInt32 * | uniqueIdP
 | ) |  |

Get the unique ID of an entry given the record index in the Favorites DB.

Parameters:
refNum,: IN: library reference number.
index,: IN: index of the record to get unique id from.
uniqueIdP,: OUT: unique ID of the record.
Return values:
Err Error code.

Boolean FavDBLibGetRecordLabel | ( | UInt16 | refNum,
 |  | UInt16 | index,
 |  | CharPtr * | labelPP
 | ) |  |

Get the label from the favorite item given the record index.

Parameters:
refNum,: IN: library reference number.
index,: IN: index of the record to get label from.
labelPP,: OUT: pointer to the label string.
Return values:
Boolean True if found. Otherwise, false.

Boolean FavDBLibGetSpeedDialInfo | ( | UInt16 | refNum,
 |  | UInt16 | index,
 |  | CharPtr * | numberPP,
 |  | CharPtr * | extraDigitsPP,
 |  | BooleanPtr | autoExtraDigitsP,
 |  | BooleanPtr | isVoicemailP
 | ) |  |

Get full info about the favorite phone number given the record index.

Parameters:
refNum,: IN: library reference number.
index,: IN: index of the item in the DB.
numberPP,: OUT: pointer to the speed dial phone number.
extraDigitsPP,: OUT: pointer to the extra digits in the phone number.
autoExtraDigitsP,: OUT: if true, extra digits are auto-dialed.
isVoicemailP,: OUT: if true, phone number is a voicemail number.
Return values:
Boolean True if found.

Err FavDBLibIsFavoriteWithId | ( | UInt16 | refNum,
 |  | UInt32 | keyId,
 |  | BooleanPtr | existsP
 | ) |  |

Determine whether item with keyId is in the favorites DB.

Parameters:
refNum,: IN: library reference number.
keyId,: IN: unique id of the item whose info is to be obtained.
existsP,: OUT: true if item is found among favorites.
Return values:
Err Error code.

Boolean FavDBLibLookupInSpeedDialDB | ( | UInt16 | refNum,
 |  | CharPtr | keyP,
 |  | CharPtr * | nameP
 | ) |  |

no definition.

Parameters:
refNum,: IN: library reference number.
keyP,: IN: no definition.
nameP,: OUT: no definition.
Return values:
Boolean True if found.

Err FavDBLibNewAppFavorite | ( | UInt16 | refNum,
 |  | Word | position,
 |  | CharPtr | labelP,
 |  | WChar | quickKey,
 |  | Word | flags,
 |  | UInt32 | appCreator,
 |  | WordPtr | indexP
 | ) |  |

Create a new favorite application entry.

Parameters:
refNum,: IN: library reference number.
position,: IN: position of the new favorite app in the entries.
labelP,: IN: pointer to the label of the newly created entry.
quickKey,: IN: shortcut used to start favorite app.
flags | IN: no definition.
appCreator | IN: Creator ID of the new favorite app.
indexP | OUT: index of the new entry in the DB.
Return values:
Err Error code.

Err FavDBLibNewEmailFavorite | ( | UInt16 | refNum,
 |  | Word | position,
 |  | CharPtr | labelP,
 |  | WChar | quickKey,
 |  | Word | flags,
 |  | CharPtr | contactIdP,
 |  | WordPtr | indexP
 | ) |  |

Create a new favorite email entry.

Parameters:
refNum,: IN: library reference number.
position,: IN: position of the new favorite email in the entries.
labelP,: IN: pointer to the label of the newly created entry.
quickKey,: IN: shortcut used to start sending email to the new favorite .
flags,: IN: no definition.
contactIdP,: IN: Email address in string.
indexP,: OUT: index of the new entry in the DB.
Return values:
Err Error code.

Err FavDBLibNewMsgFavorite | ( | UInt16 | refNum,
 |  | Word | position,
 |  | CharPtr | labelP,
 |  | WChar | quickKey,
 |  | Word | flags,
 |  | CharPtr | contactIdP,
 |  | WordPtr | indexP
 | ) |  |

Create a new favorite messaging destination.

Parameters:
refNum,: IN: library reference number.
position,: IN: position of the new favorite contact in the entries.
labelP,: IN: pointer to the label of the newly created entry.
quickKey,: IN: shortcut used to start composing message to the contact.
flags,: IN: No definition.
contactIdP | IN: Mobile number/ Email address of the new favorites messaging contact.
indexP | OUT: index of the new entry in the DB.
Return values:
Err Error code.

Err FavDBLibNewPhoneFavorite | ( | UInt16 | refNum,
 |  | Word | position,
 |  | CharPtr | labelP,
 |  | WChar | quickKey,
 |  | Word | flags,
 |  | CharPtr | numberP,
 |  | CharPtr | extraDigitsP,
 |  | Boolean | autoDialExtraDigits,
 |  | UInt32 | ringID,
 |  | UInt16 | ringToneType,
 |  | WordPtr | indexP
 | ) |  |

Create a new favorite phone number.

Parameters:
refNum,: IN: library reference number.
position,: IN: position of the new favorite phone number in the entries.
labelP,: IN: pointer to the label of the newly created entry.
quickKey,: IN: shortcut used to call the number.
flags,: IN: no definition.
numberP,: IN: New favorite phone number in string.
extraDigitsP,: IN: Extra digits.
autoDialExtraDigits,: IN: Always include extra digit when dialing if true.
ringID,: IN: Ring tone ID for this number.
ringToneType,: IN: Ring tone type for this number.
indexP,: OUT: index of the new entry in the DB.
Return values:
Err Error code.

Err FavDBLibNewPhoneViewFavorite | ( | UInt16 | refNum,
 |  | Word | position,
 |  | CharPtr | labelP,
 |  | WChar | quickKey,
 |  | Word | flags,
 |  | UInt16 | phoneView,
 |  | WordPtr | indexP
 | ) |  |

Create a new favorite phone app view.

Parameters:
refNum,: IN: library reference number.
position,: IN: position of the new favorite in the entries.
labelP,: IN: pointer to the label of the newly created entry.
quickKey,: IN: shortcut used to launch phone app in the favorite view.
flags,: IN: no definition.
phoneView,: IN: See FavDBLibPhoneViewEnum for values.
indexP,: OUT: index of the new entry in the DB.
Return values:
Err Error code.

Err FavDBLibNewWebFavorite | ( | UInt16 | refNum,
 |  | Word | position,
 |  | CharPtr | labelP,
 |  | WChar | quickKey,
 |  | Word | flags,
 |  | CharPtr | urlP,
 |  | WordPtr | indexP
 | ) |  |

Create a new favorite URL.

Parameters:
refNum,: IN: library reference number.
position,: IN: position of the new favorite URL.
labelP,: IN: pointer to the label of the newly created entry.
quickKey,: IN: shortcut used to launch the URL.
flags,: IN: no definition.
urlP,: IN: the URL in string.
indexP,: OUT: index of the new entry in the DB.
Return values:
Err Error code.

Err FavDBLibOpen ( UInt16 refNum )

Standard library open function

Parameters:
refNum,: IN: Favorites DB library reference number (from SysLibFind()/SysLibLoad())
Return values:
Err Error code.

CharPtr FavDBLibResolveAddress | ( | UInt16 | refNum,
 |  | CharPtr | addressP,
 |  | Word | kind
 | ) |  |

No definition.

Parameters:
refNum,: IN: library reference number.
addressP,: IN: pointer to the address string to be resolved.
kind,: IN: no definition.
Return values:
CharPtr no definition.

Boolean FavDBLibSeekSpeedDialRecord | ( | UInt16 | refNum,
 |  | UInt16 * | indexP,
 |  | Int16 | offset,
 |  | Int16 | direction
 | ) |  |

No definition.

Parameters:
refNum,: IN: library reference number.
indexP,: IN,OUT: no definition.
offset,: IN: offset in the DB record indeces to start search from.
direction,: IN: Forward/backward search from offset.
Return values:
Boolean True if found. Otherwise, false.

Err FavDBLibSleep ( UInt16 refNum )

Standard library sleep function

Parameters:
refNum,: IN: Favorites DB library reference number (from SysLibFind()/SysLibLoad())
Return values:
Err Error code.

Err FavDBLibWake ( UInt16 refNum )

Standard library wake function

Parameters:
refNum,: IN: Favorites DB library reference number (from SysLibFind()/SysLibLoad())
Return values:
Err Error code.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:57 2008 for Palm API Guide


Header Files » Incs » common » libraries » favoritesdblibrary

FavoritesDBLibTypes.h File Reference

Detailed Description

Public 68K common header file for FavoritesDB library API.

This file contains the FavoritesDB library constants and error codes.

Definition in file FavoritesDBLibTypes.h.

Go to the source code of this file.

Defines

  • #define favoritesDBLibName "FavoritesDBLibrary"
  • #define favoritesDBLibCreator 'HsFD'
  • #define favoritesDBLibType sysFileTLibrary
Error Codes
  • #define favoritesDBLibErrClass 0x9000
  • #define favoritesDBLibErrCreateDBFailed (favoritesDBLibErrClass | 1)
  • #define favoritesDBLibErrNoMemory (favoritesDBLibErrClass | 2)
  • #define favoritesDBLibErrDBNotFound (favoritesDBLibErrClass | 4)
  • #define favoritesDBLibErrDBWriteFailed (favoritesDBLibErrClass | 5)
  • #define favoritesDBLibErrUserCancel (favoritesDBLibErrClass | 6)
  • #define favoritesDBLibErrBadParams (favoritesDBLibErrClass | 7)
Function Traps
  • #define favoritesDBLibTrapNewAppFavorite sysLibTrapCustom
  • #define favoritesDBLibTrapNewPhoneFavorite sysLibTrapCustom+1
  • #define favoritesDBLibTrapNewMsgFavorite sysLibTrapCustom+2
  • #define favoritesDBLibTrapNewWebFavorite sysLibTrapCustom+3
  • #define favoritesDBLibTrapNewEmailFavorite sysLibTrapCustom+4
  • #define favoritesDBLibTrapNewPhoneViewFavorite sysLibTrapCustom+5
  • #define favoritesDBLibTrapResolveAddress sysLibTrapCustom+6
  • #define favoritesDBLibTrapSeekSpeedDialRecord sysLibTrapCustom+7
  • #define favoritesDBLibTrapGetRecordLabel sysLibTrapCustom+8
  • #define favoritesDBLibTrapGetRecordId sysLibTrapCustom+9
  • #define favoritesDBLibIsFavoriteWithId sysLibTrapCustom+10
  • #define favoritesDBLibTrapGetSpeedDialInfo sysLibTrapCustom+11
  • #define favoritesDBLibTrapLookupInSpeedDialDB sysLibTrapCustom+12

Define Documentation

#define favoritesDBLibCreator 'HsFD'

Favorites DB library creator ID

Definition at line 36 of file FavoritesDBLibTypes.h.

#define favoritesDBLibErrBadParams (favoritesDBLibErrClass | 7)

Definition at line 49 of file FavoritesDBLibTypes.h.

#define favoritesDBLibErrClass 0x9000

Definition at line 43 of file FavoritesDBLibTypes.h.

#define favoritesDBLibErrCreateDBFailed (favoritesDBLibErrClass | 1)

Definition at line 44 of file FavoritesDBLibTypes.h.

#define favoritesDBLibErrDBNotFound (favoritesDBLibErrClass | 4)

Definition at line 46 of file FavoritesDBLibTypes.h.

#define favoritesDBLibErrDBWriteFailed (favoritesDBLibErrClass | 5)

Definition at line 47 of file FavoritesDBLibTypes.h.

#define favoritesDBLibErrNoMemory (favoritesDBLibErrClass | 2)

Definition at line 45 of file FavoritesDBLibTypes.h.

#define favoritesDBLibErrUserCancel (favoritesDBLibErrClass | 6)

Definition at line 48 of file FavoritesDBLibTypes.h.

#define favoritesDBLibIsFavoriteWithId sysLibTrapCustom+10

Definition at line 66 of file FavoritesDBLibTypes.h.

#define favoritesDBLibName "FavoritesDBLibrary"

Favorites DB library name

Definition at line 35 of file FavoritesDBLibTypes.h.

#define favoritesDBLibTrapGetRecordId sysLibTrapCustom+9

Definition at line 65 of file FavoritesDBLibTypes.h.

#define favoritesDBLibTrapGetRecordLabel sysLibTrapCustom+8

Definition at line 64 of file FavoritesDBLibTypes.h.

#define favoritesDBLibTrapGetSpeedDialInfo sysLibTrapCustom+11

Definition at line 67 of file FavoritesDBLibTypes.h.

#define favoritesDBLibTrapLookupInSpeedDialDB sysLibTrapCustom+12

Definition at line 68 of file FavoritesDBLibTypes.h.

#define favoritesDBLibTrapNewAppFavorite sysLibTrapCustom

Definition at line 56 of file FavoritesDBLibTypes.h.

#define favoritesDBLibTrapNewEmailFavorite sysLibTrapCustom+4

Definition at line 60 of file FavoritesDBLibTypes.h.

#define favoritesDBLibTrapNewMsgFavorite sysLibTrapCustom+2

Definition at line 58 of file FavoritesDBLibTypes.h.

#define favoritesDBLibTrapNewPhoneFavorite sysLibTrapCustom+1

Definition at line 57 of file FavoritesDBLibTypes.h.

#define favoritesDBLibTrapNewPhoneViewFavorite sysLibTrapCustom+5

Definition at line 61 of file FavoritesDBLibTypes.h.

#define favoritesDBLibTrapNewWebFavorite sysLibTrapCustom+3

Definition at line 59 of file FavoritesDBLibTypes.h.

#define favoritesDBLibTrapResolveAddress sysLibTrapCustom+6

Definition at line 62 of file FavoritesDBLibTypes.h.

#define favoritesDBLibTrapSeekSpeedDialRecord sysLibTrapCustom+7

Definition at line 63 of file FavoritesDBLibTypes.h.

#define favoritesDBLibType sysFileTLibrary

Standard library type

Definition at line 37 of file FavoritesDBLibTypes.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:57 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » filebrowser

FileBrowserLib68K.h File Reference

Detailed Description

This file contains the FileBrowser Library APIs.

Version:
1.0

Definition in file FileBrowserLib68K.h.

Go to the source code of this file.

Defines

  • #define FILE_BROWSER_LIB_TRAP(trapNum) SYS_TRAP(trapNum)

Functions

  • Err FileBrowserLibOpen (UInt16 refNum) FILE_BROWSER_LIB_TRAP(sysLibTrapOpen)
  • Err FileBrowserLibClose (UInt16 refNum) FILE_BROWSER_LIB_TRAP(sysLibTrapClose)
  • Err FileBrowserLibSleep (UInt16 refNum) FILE_BROWSER_LIB_TRAP(sysLibTrapSleep)
  • Err FileBrowserLibWake (UInt16 refNum) FILE_BROWSER_LIB_TRAP(sysLibTrapWake)
  • Boolean FileBrowserLibHandleEvent (UInt16 refNum, EventType *eventP) FILE_BROWSER_LIB_TRAP(exgLibTrapHandleEvent)
  • Err FileBrowserLibConnect (UInt16 refNum, ExgSocketType *socketP) FILE_BROWSER_LIB_TRAP(exgLibTrapConnect)
  • Err FileBrowserLibAccept (UInt16 refNum, ExgSocketType *socketP) FILE_BROWSER_LIB_TRAP(exgLibTrapAccept)
  • Err FileBrowserLibDisconnect (UInt16 refNum, ExgSocketType *socketP, Err err) FILE_BROWSER_LIB_TRAP(exgLibTrapDisconnect)
  • Err FileBrowserLibPut (UInt16 refNum, ExgSocketType *socketP) FILE_BROWSER_LIB_TRAP(exgLibTrapPut)
  • Err FileBrowserLibGet (UInt16 refNum, ExgSocketType *socketP) FILE_BROWSER_LIB_TRAP(exgLibTrapGet)
  • UInt32 FileBrowserLibSend (UInt16 refNum, ExgSocketType *socketP, const void *bufP, UInt32 bufLen, Err *errP) FILE_BROWSER_LIB_TRAP(exgLibTrapSend)
  • UInt32 FileBrowserLibReceive (UInt16 refNum, ExgSocketType *socketP, void *bufP, UInt32 bufSize, Err *errP) FILE_BROWSER_LIB_TRAP(exgLibTrapReceive)
  • Err FileBrowserLibControl (UInt16 refNum, UInt16 op, void *valueP, UInt16 *valueLenP) FILE_BROWSER_LIB_TRAP(exgLibTrapControl)
  • Err FileBrowserLibRequest (UInt16 refNum, ExgSocketType *socketP) FILE_BROWSER_LIB_TRAP(exgLibTrapRequest)
  • Boolean FileBrowserLibShowOpenDialog (UInt16 refNum, UInt16 *volRefNumP, Char *path, UInt16 numExtensions, const Char **extensions, const Char *fileType, const Char *title, UInt32 flags) FILE_BROWSER_LIB_TRAP(kFileBrowserLibTrapShowOpenDialog)
  • Boolean FileBrowserLibShowSaveAsDialog (UInt16 refNum, UInt16 *volRefNumP, Char *path, UInt16 numExtensions, const Char **extensions, const Char *defaultExtension, const Char *fileType, const Char *title, UInt32 flags) FILE_BROWSER_LIB_TRAP(kFileBrowserLibTrapShowSaveAsDialog)
  • Err FileBrowserLibParseFileURL (UInt16 refNum, const Char *urlP, UInt16 *volRefNumP, Char **filePathP) FILE_BROWSER_LIB_TRAP(kFileBrowserLibTrapParseFileURL)
  • Boolean FileBrowserLibShowMultiselectDialog (UInt16 refNum, UInt16 *volRefNumP, Char *path, UInt16 *numFilesP, UInt16 maxFiles, Char **filenames, UInt16 numExtensions, const Char **extensions, const Char *fileType, const Char *title, UInt32 flags) FILE_BROWSER_LIB_TRAP(kFileBrowserLibTrapShowMultiselectDialog)

Define Documentation

#define FILE_BROWSER_LIB_TRAP ( trapNum ) SYS_TRAP(trapNum)

Definition at line 31 of file FileBrowserLib68K.h.

Function Documentation

Err FileBrowserLibAccept | ( | UInt16 | refNum,
 |  | ExgSocketType * | socketP
 | ) |  |

Entry point to accept an incoming connection

Parameters:
refNum,: IN: library reference number
socketP,: IN: the exchange socket
Return values:
Err Error code.

Err FileBrowserLibClose ( UInt16 refNum )

Standard File Browser library close function

Parameters:
refNum,: IN: library reference number
Return values:
Err Error code

Err FileBrowserLibConnect | ( | UInt16 | refNum,
 |  | ExgSocketType * | socketP
 | ) |  |

Entry point to establish an exchange connection

Parameters:
refNum,: IN: library reference number
socketP,: IN: the exchange socket
Return values:
Err Error code.

Err FileBrowserLibControl | ( | UInt16 | refNum,
 |  | UInt16 | op,
 |  | void * | valueP,
 |  | UInt16 * | valueLenP
 | ) |  |

Entry point to execute various commands.

Parameters:
refNum,: IN: the library reference number
op,: IN: command to execute
valueP,: IN,OUT: buffer with incoming or outgoing data
valueLenP,: IN,OUT: size of buffer and size of result (not used for some operations)
Return values:
Err Error code.

Err FileBrowserLibDisconnect | ( | UInt16 | refNum,
 |  | ExgSocketType * | socketP,
 |  | Err | err
 | ) |  |

Entry point to disconnect an outgoing or incoming connection and clean up afterwards.

Parameters:
refNum,: IN: library reference number
socketP,: IN: the exchange socket
err,: IN: OS error code to report to user
Return values:
Err Error code.

Err FileBrowserLibGet | ( | UInt16 | refNum,
 |  | ExgSocketType * | socketP
 | ) |  |

Entry point to start a Get operation

Parameters:
refNum,: IN: library reference number
socketP,: IN: the exchange socket
Return values:
Err Error code.

Boolean FileBrowserLibHandleEvent | ( | UInt16 | refNum,
 |  | EventType * | eventP
 | ) |  |

Entry point to handle an event

Parameters:
refNum,: IN: library reference number
eventP,: IN: the event to handle
Return values:
Boolean True if the event was handled and should not be passed to a higher level handler.

Err FileBrowserLibOpen ( UInt16 refNum )

Standard File Browser library open function

Parameters:
refNum,: IN: library reference number
Return values:
Err Error code

Err FileBrowserLibParseFileURL | ( | UInt16 | refNum,
 |  | const Char * | urlP,
 |  | UInt16 * | volRefNumP,
 |  | Char ** | filePathP
 | ) |  |

Entry point to parse a URL (file:) received in a sysAppLaunchCmdExgReceiveData launch resulting from the open dialog. Pass NULL for unwanted results. Caller must free the others.

Parameters:
refNum,: IN: library reference number
urlP,: IN: URL to be parsed
volRefNumP,: OUT: pass back the file's volume's volRefNum
filePathP,: OUT: pass back the file's path
Return values:
Err Error code

Err FileBrowserLibPut | ( | UInt16 | refNum,
 |  | ExgSocketType * | socketP
 | ) |  |

Entry point to start a Put operation. Creates a connection if one doesn't already exist.

Parameters:
refNum,: IN: library reference number
socketP,: IN: the exchange socket
Return values:
Err Error code.

UInt32 FileBrowserLibReceive | ( | UInt16 | refNum,
 |  | ExgSocketType * | socketP,
 |  | void * | bufP,
 |  | UInt32 | bufSize,
 |  | Err * | errP
 | ) |  |

Entry point to receive data for an object

Parameters:
refNum,: IN: the library reference number
socketP,: IN: the exchange socket
bufP,: OUT: buffer to store received data
bufSize,: IN: size of buffer
errP,: OUT: passed back error code
Return values:
UInt32 number of bytes received.

Err FileBrowserLibRequest | ( | UInt16 | refNum,
 |  | ExgSocketType * | socketP
 | ) |  |

Entry point to do a Request operation (Unimplemented)

Parameters:
refNum,: IN: the library reference number
socketP,: IN: the exchange socket
Return values:
Err Error code.

UInt32 FileBrowserLibSend | ( | UInt16 | refNum,
 |  | ExgSocketType * | socketP,
 |  | const void * | bufP,
 |  | UInt32 | bufLen,
 |  | Err * | errP
 | ) |  |

Entry point to send data for an object

Parameters:
refNum,: IN: library reference number
socketP,: IN: the exchange socket
bufP,: IN: the buffer containing data to send
bufLen,: IN: bytes to send
errP,: OUT: passed back error code
Return values:
UInt32 number of bytes sent.

Boolean FileBrowserLibShowMultiselectDialog | ( | UInt16 | refNum,
 |  | UInt16 * | volRefNumP,
 |  | Char * | path,
 |  | UInt16 * | numFilesP,
 |  | UInt16 | maxFiles,
 |  | Char ** | filenames,
 |  | UInt16 | numExtensions,
 |  | const Char ** | extensions,
 |  | const Char * | fileType,
 |  | const Char * | title,
 |  | UInt32 | flags
 | ) |  |

Entry point to pop up a dialog in which multiple files can be selected

Parameters:
refNum,: IN: library reference number
volRefNumP,: IN: the default volume and the result
path,: IN: the default path
numFilesP | OUT: number of files selected
maxFiles | IN: maximum number of files allowed to select
filenames | OUT: names of files selected
numExtensions,: IN: number of extensions to display
extensions,: IN: compatible extensions to display
fileType,: IN: optional MIME type or extension to get default directory on each volume
title,: IN: open dialog title
flags,: IN: any combo of kOpenFlag* flags
Return values:
Boolean True if one or more files are selected

Boolean FileBrowserLibShowOpenDialog | ( | UInt16 | refNum,
 |  | UInt16 * | volRefNumP,
 |  | Char * | path,
 |  | UInt16 | numExtensions,
 |  | const Char ** | extensions,
 |  | const Char * | fileType,
 |  | const Char * | title,
 |  | UInt32 | flags
 | ) |  |

Pop up an Open dialog

Parameters:
refNum,: IN: library reference number
volRefNumP,: IN: the default volume and the result
path,: IN: the default path and the result (must be at least kFileBrowserLibPathBufferSize bytes).
numExtensions,: IN: number of extensions to display
extensions,: IN: compatible extensions to display
fileType,: IN: optional MIME type or extension to get default directory on each volume
title,: IN: open dialog title
flags,: IN: any combo of kOpenFlag* flags
Return values:
Boolean True if a file is selected

Boolean FileBrowserLibShowSaveAsDialog | ( | UInt16 | refNum,
 |  | UInt16 * | volRefNumP,
 |  | Char * | path,
 |  | UInt16 | numExtensions,
 |  | const Char ** | extensions,
 |  | const Char * | defaultExtension,
 |  | const Char * | fileType,
 |  | const Char * | title,
 |  | UInt32 | flags
 | ) |  |

Pop up a Save dialog

Parameters:
refNum,: IN: library reference number
volRefNumP,: IN: the default volume and the result
path,: IN: the default path and the result (must be at least kFileBrowserLibPathBufferSize bytes)
numExtensions,: IN: number of extensions to display
extensions,: IN: valid extensions to display
defaultExtension IN: default extension to display initially
fileType,: IN: optional MIME type or extension to get default directory on each volume
title,: IN: open dialog title
flags,: IN: any combo of kSaveAsFlag* flags
Return values:
Boolean True if a file is saved

Err FileBrowserLibSleep ( UInt16 refNum )

Standard File Browser library sleep function

Parameters:
refNum,: IN: library reference number
Return values:
Err Error code

Err FileBrowserLibWake ( UInt16 refNum )

Standard File Browser library wake function

Parameters:
refNum,: IN: library reference number
Return values:
Err Error code

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:57 2008 for Palm API Guide


Header Files » Incs » common » libraries » filebrowser

FileBrowserLibCommon.h File Reference

Detailed Description

Public 68K common header file for File Browser library API.

Version:
1.0
This file contains the File Browser Library common definitions and error codes.

Definition in file FileBrowserLibCommon.h.

Include dependency graph for FileBrowserLibCommon.h:

Go to the source code of this file.

Defines

  • #define kFileBrowserLibName "FileBrowser-PFil"
  • #define kFileBrowserLibFlagOneVolume 0x00000001UL
  • #define kFileBrowserLibMaxPathLength 2047
  • #define kFileBrowserLibPathBufferSize (kFileBrowserLibMaxPathLength + 1)
  • #define exgRegEditCreatorID 0xff7b
  • #define exgRegEditExtensionID 0xff7d
  • #define exgRegEditTypeID 0xff7e
  • #define kFileBrowserLibCtlGetVersion exgLibCtlSpecificOp
  • #define kFileBrowserLibAPIVersion0 0
  • #define kFileBrowserLibAPIVersion1 1
Flags for Open dialog

  • #define kFileBrowserLibFlagNoFiles 0x00000002UL
  • #define kFileBrowserLibFlagNoFolders 0x00000004UL
Flags for Save As dialog

  • #define kFileBrowserLibFlagPromptOverwrite 0x00000008UL
  • #define kFileBrowserLibFlagRequireExtension 0x00000010UL
  • #define kFileBrowserLibFlagNoNewFolder 0x00000020UL
Flags for Open & Save As dialog

  • #define kFileBrowserLibFlagNoDirChange 0x00000040UL
  • #define kFileBrowserLibFlagNoSubDir 0x00000080UL
Error Codes

  • #define kFileBrowserLibErrorClass (oemErrorClass + 0x0400)
  • #define kFileBrowserLibErrStillOpen (kFileBrowserLibErrorClass | 0x01)
  • #define kFileBrowserLibErrPathTooLong (kFileBrowserLibErrorClass | 0x02)
  • #define kFileBrowserLibErrMemError (kFileBrowserLibErrorClass | 0x03)
  • #define kFileBrowserLibErrCantFind (kFileBrowserLibErrorClass | 0x04)
  • #define kFileBrowserLibErrInternal (kFileBrowserLibErrorClass | 0x05)
  • #define kFileBrowserLibErrCantOpen (kFileBrowserLibErrorClass | 0x06)
  • #define kFileBrowserLibErrCantParse (kFileBrowserLibErrorClass | 0x07)
Function Traps

  • #define kFileBrowserLibTrapShowOpenDialog (exgLibTrapLast)
  • #define kFileBrowserLibTrapShowSaveAsDialog (exgLibTrapLast + 1)
  • #define kFileBrowserLibTrapParseFileURL (exgLibTrapLast + 2)
  • #define kFileBrowserLibTrapShowMultiselectDialog (exgLibTrapLast + 3)

Define Documentation

#define exgRegEditCreatorID 0xff7b

Definition at line 78 of file FileBrowserLibCommon.h.

#define exgRegEditExtensionID 0xff7d

Definition at line 79 of file FileBrowserLibCommon.h.

#define exgRegEditTypeID 0xff7e

Definition at line 80 of file FileBrowserLibCommon.h.

#define kFileBrowserLibAPIVersion0 0

Definition at line 86 of file FileBrowserLibCommon.h.

#define kFileBrowserLibAPIVersion1 1

Definition at line 87 of file FileBrowserLibCommon.h.

#define kFileBrowserLibCtlGetVersion exgLibCtlSpecificOp

Definition at line 83 of file FileBrowserLibCommon.h.

#define kFileBrowserLibErrCantFind (kFileBrowserLibErrorClass | 0x04)

Definition at line 95 of file FileBrowserLibCommon.h.

#define kFileBrowserLibErrCantOpen (kFileBrowserLibErrorClass | 0x06)

Definition at line 97 of file FileBrowserLibCommon.h.

#define kFileBrowserLibErrCantParse (kFileBrowserLibErrorClass | 0x07)

Definition at line 98 of file FileBrowserLibCommon.h.

#define kFileBrowserLibErrInternal (kFileBrowserLibErrorClass | 0x05)

Definition at line 96 of file FileBrowserLibCommon.h.

#define kFileBrowserLibErrMemError (kFileBrowserLibErrorClass | 0x03)

Definition at line 94 of file FileBrowserLibCommon.h.

#define kFileBrowserLibErrorClass (oemErrorClass + 0x0400)

Definition at line 91 of file FileBrowserLibCommon.h.

#define kFileBrowserLibErrPathTooLong (kFileBrowserLibErrorClass | 0x02)

Definition at line 93 of file FileBrowserLibCommon.h.

#define kFileBrowserLibErrStillOpen (kFileBrowserLibErrorClass | 0x01)

Definition at line 92 of file FileBrowserLibCommon.h.

#define kFileBrowserLibFlagNoDirChange 0x00000040UL

stay within tree

Definition at line 68 of file FileBrowserLibCommon.h.

#define kFileBrowserLibFlagNoFiles 0x00000002UL

no files; only folders

Definition at line 55 of file FileBrowserLibCommon.h.

#define kFileBrowserLibFlagNoFolders 0x00000004UL

no folders; only files

Definition at line 56 of file FileBrowserLibCommon.h.

#define kFileBrowserLibFlagNoNewFolder 0x00000020UL

no New Folder button

Definition at line 63 of file FileBrowserLibCommon.h.

#define kFileBrowserLibFlagNoSubDir 0x00000080UL

stay within folder

Definition at line 69 of file FileBrowserLibCommon.h.

#define kFileBrowserLibFlagOneVolume 0x00000001UL

Flags for Open and Save As dialogs

Definition at line 51 of file FileBrowserLibCommon.h.

#define kFileBrowserLibFlagPromptOverwrite 0x00000008UL

warn before replacing

Definition at line 61 of file FileBrowserLibCommon.h.

#define kFileBrowserLibFlagRequireExtension 0x00000010UL

only given extensions

Definition at line 62 of file FileBrowserLibCommon.h.

#define kFileBrowserLibMaxPathLength 2047

Definition at line 73 of file FileBrowserLibCommon.h.

#define kFileBrowserLibName "FileBrowser-PFil"

Use SysLibFind to find this library. There is no need to load it. This must match the database name since this is an Exchange Library In Application (ELIA).

Definition at line 49 of file FileBrowserLibCommon.h.

#define kFileBrowserLibPathBufferSize (kFileBrowserLibMaxPathLength + 1)

Definition at line 74 of file FileBrowserLibCommon.h.

#define kFileBrowserLibTrapParseFileURL (exgLibTrapLast + 2)

Definition at line 105 of file FileBrowserLibCommon.h.

#define kFileBrowserLibTrapShowMultiselectDialog (exgLibTrapLast + 3)

Definition at line 106 of file FileBrowserLibCommon.h.

#define kFileBrowserLibTrapShowOpenDialog (exgLibTrapLast)

Definition at line 103 of file FileBrowserLibCommon.h.

#define kFileBrowserLibTrapShowSaveAsDialog (exgLibTrapLast + 1)

Definition at line 104 of file FileBrowserLibCommon.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:57 2008 for Palm API Guide


Header Files » Incs » 68k » system

HardwareUtils68K.h File Reference

Detailed Description

Public common header file to the Hardware Utilities Library used by 68K applications.

Version:
1.0
This file contains the library constants and function prototypes for the library.

Definition in file HardwareUtils68K.h.

Include dependency graph for HardwareUtils68K.h:

Go to the source code of this file.

Defines

Library Constants
  • #define kHWUtilsType sysFileTLibrary
  • #define kHWUtilsCreator 'HWut'
  • #define kHWUtilsName "HardwareUtils"
Function Traps
  • #define kHWUtilsTrapOpen sysLibTrapOpen
  • #define kHWUtilsTrapClose sysLibTrapClose
  • #define kHWUtilsTrapBlinkLED (sysLibTrapCustom + 0)
  • #define kHWUtilsTrapSetBlinkRate (sysLibTrapCustom + 1)
  • #define kHWUtilsTrapEnableDisplay (sysLibTrapCustom + 2)
  • #define kHWUtilsTrapGetDisplayState (sysLibTrapCustom + 3)

Functions

  • Err HWUOpen (UInt16 refnum)
    Standard library open routine.
  • Err HWUClose (UInt16 refnum)
    Standard library close routine.
  • Err HWUBlinkLED (UInt16 refnum, Boolean b)
    Set the LED blink state.
  • Err HWUSetBlinkRate (UInt16 refnum, UInt16 rate)
    Set the blink rate of the LED light.
  • Err HWUEnableDisplay (UInt16 refnum, Boolean on)
    Set the state of the display.
  • Boolean HWUGetDisplayState (UInt16 refnum)
    Retrieve the current state of the display.

Define Documentation

#define kHWUtilsCreator 'HWut'

Definition at line 41 of file HardwareUtils68K.h.

#define kHWUtilsName "HardwareUtils"

Definition at line 42 of file HardwareUtils68K.h.

#define kHWUtilsTrapBlinkLED (sysLibTrapCustom + 0)

Definition at line 51 of file HardwareUtils68K.h.

#define kHWUtilsTrapClose sysLibTrapClose

Definition at line 50 of file HardwareUtils68K.h.

#define kHWUtilsTrapEnableDisplay (sysLibTrapCustom + 2)

Definition at line 53 of file HardwareUtils68K.h.

#define kHWUtilsTrapGetDisplayState (sysLibTrapCustom + 3)

Definition at line 54 of file HardwareUtils68K.h.

#define kHWUtilsTrapOpen sysLibTrapOpen

Definition at line 49 of file HardwareUtils68K.h.

#define kHWUtilsTrapSetBlinkRate (sysLibTrapCustom + 1)

Definition at line 52 of file HardwareUtils68K.h.

#define kHWUtilsType sysFileTLibrary

Definition at line 40 of file HardwareUtils68K.h.

Function Documentation

Err HWUBlinkLED | ( | UInt16 | refnum,
 |  | Boolean | b
 | ) |  |

Set the LED blink state.

Parameters:
refnum,: IN: Library reference number
b,: IN: True if LED should be blinking. False otherwise.
Returns:
Error code

Err HWUClose ( UInt16 refnum )

Standard library close routine.

Parameters:
refnum,: IN: Library reference number
Returns:
Error code.

Err HWUEnableDisplay | ( | UInt16 | refnum,
 |  | Boolean | on
 | ) |  |

Set the state of the display.

Parameters:
refnum,: IN: Library reference number
on,: IN: True to enable display. False otherwise.
Returns:
Error code.

Boolean HWUGetDisplayState ( UInt16 refnum )

Retrieve the current state of the display.

Parameters:
refnum,: IN: Library reference number
Returns:
True if the display is on. False otherwise.

Err HWUOpen ( UInt16 refnum )

Standard library open routine.

Parameters:
refnum,: IN: Library reference number
Returns:
Error code.

Err HWUSetBlinkRate | ( | UInt16 | refnum,
 |  | UInt16 | rate
 | ) |  |

Set the blink rate of the LED light.

Parameters:
refnum,: IN: Library reference number
rate,: IN: The rate at which the LED should blink.
Returns:
Error code.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:58 2008 for Palm API Guide


Header Files » Incs » 68k

Hs.h File Reference

Include dependency graph for Hs.h:

Go to the source code of this file.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:58 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » http

HS_HTTPLib68K.h File Reference

Detailed Description

Public 68k include file for the HTTP Library.

Version:
2.0
Date:

Definition in file HS_HTTPLib68K.h.

Include dependency graph for HS_HTTPLib68K.h:

Go to the source code of this file.

Data Structures

  • struct HS_HTTPLibSplit_
  • struct HS_HTTPLibTime_
  • struct HS_HTTPLibAuthInfo_
  • struct HttpUASelectionRule

Typedefs

  • typedef HS_HTTPLibSplit_ HS_HTTPLibSplit
  • typedef HS_HTTPLibTime_ HS_HTTPLibTime
  • typedef void * HS_HTTPLibDataHandle
  • typedef void * HS_HTTPLibVHandle
  • typedef void * HS_HTTPLibString
  • typedef void * HS_HTTPLibFixedString
  • typedef void * HS_HTTPLibURLString
  • typedef HS_HTTPLibAuthInfo_ HS_HTTPLibAuthInfo
  • typedef void * HS_HTTPLibStream
  • typedef void * HS_HTTPLibSSL
  • typedef void * HS_HTTPLibCookies
  • typedef void * HS_HTTPLibCertPtr
  • typedef void * HS_HTTPLibCertList
  • typedef void * HS_HTTPLibClientCertList
  • typedef void * HS_HTTPLibSSLClassPtr
  • typedef Int32(*) HS_HTTPLibCookieConfirmProc (HS_HTTPLibCookies in_cookie, HS_HTTPLibURLString in_url, Char *in_header, Int32 in_header_len, HS_HTTPLibOpaque in_aux)
  • typedef Int32(*) HS_HTTPLibServerCertConfirmProc (HS_HTTPLibSSL in_ssl, Int32 in_verify_result, HS_HTTPLibCertList in_list, HS_HTTPLibOpaque in_aux)
  • typedef Int32(*) HS_HTTPLibClientCertSelectProc (HS_HTTPLibSSL in_ssl, HS_HTTPLibClientCertList in_list, HS_HTTPLibOpaque in_aux)
  • typedef Int32(*) HS_HTTPLibTunnelingCallbackProc (HS_HTTPLibStream stream, Char *buf, Int32 len, void *in_aux)
  • typedef void(*) HS_HTTPLibWakeUpCallbackProc (HS_HTTPLibOpaque in_aux)

Enumerations

  • enum {
    httpUASelectTypeHost,
    httpUASelectTypePath
    }

Functions

  • Err HS_HTTPLibOpen (UInt16 refnum)
    This function opens the HTTP library and increments the open count. This function will create and initialize the library’s common data at first opening.
  • Err HS_HTTPLibClose (UInt16 refnum, UInt16 *usecountP)
    This function decrements open count and finalizes the library’s common data at the last close.
  • Err HS_HTTPLibSleep (UInt16 refnum)
    Standard library sleep function.
  • Err HS_HTTPLibWake (UInt16 refnum)
    Standard library wake function.
  • UInt16 HS_HTTPLibOpenCount (UInt16 refnum)
    This function returns the open count of this library.
  • HS_HTTPLibHandle HS_HTTPLibInitialize (UInt16 refnum, HS_HTTPLibAppInfo *appInfoP, HS_HTTPLibNetLibInfo *netLibInfoP, HS_HTTPLibPeer *peerP)
    This function initializes the library instance and sets application dependent information in the global variables. The return value is the handle of library instance. If an error occurs during the initialization, the return value is NULL.
  • void HS_HTTPLibFinalize (UInt16 refnum, HS_HTTPLibHandle libH)
    This function finalizes the library instance.
  • HS_HTTPLibSSLClassPtr HS_HTTPLibSSLClass (UInt16 refnum, HS_HTTPLibHandle libH)
    Parameters:
    refnum,: IN:

  • void HS_HTTPLibRegisterSSLClass (UInt16 refnum, HS_HTTPLibHandle libH, HS_HTTPLibSSLClassPtr sslClassP)
    Parameters:
    refnum,: IN:

  • void HS_HTTPLibClearDNSCache (UInt16 refnum, HS_HTTPLibHandle libH)
    This function clears the DNS cache information.
  • void HS_HTTPLibCloseAllKeepAlive (UInt16 refnum, HS_HTTPLibHandle libH)
    This function closes the all idle keep alive sockets relating this application. Nonidle sockets are not closed by this function.
  • void HS_HTTPLibMakeProxy (UInt16 refnum, HS_HTTPLibHandle libH, HS_HTTPLibFixedString *out_proxy_host, Int32 *out_proxy_http_port, Int32 *out_proxy_https_port, HS_HTTPLibString *out_no_proxy_hosts)
    Set the proxy information of this application to out_proxy_host, out_proxy_http_port, out_proxy_https_port, out_no_proxy_hosts. If out_proxy_host is NULL, the value of *out_proxy_http_port, *out_proxy_https_port, *out_no_proxy_hosts are not set, otherwise the values of *out_proxy_http_port, *out_proxy_https are set. If out_no_proxy_hosts is NULL, *out_no_proxy_hosts is not set. The format of out_no_proxy_hosts is the list separated by “,”. The responsibility of delete *out_proxy_host, *out_no_proxy_hosts is caller.
  • void HS_HTTPLibSetHTTPPort (UInt16 refnum, HS_HTTPLibHandle libH, Int32 in_port)
    This function sets the default HTTP port number. If there is no indication in URL, this port number is used for TCP connection.
  • void HS_HTTPLibSetHTTPSPort (UInt16 refnum, HS_HTTPLibHandle libH, Int32 in_port)
    This function sets the default HTTPS port number. If there is no indication in https URL, this port number is used for TCP connection.
  • void HS_HTTPLibSetMaxRequestHeader (UInt16 refnum, HS_HTTPLibHandle libH, Int32 in_size)
    This function sets the maximal size of Request-Line. If in_size is -1, the maximal size is unlimited. Note that this function does not set the maximal size of Request- Header. See RFC2616 for the definitions of Request-Line and Request-Header.
  • void HS_HTTPLibSetMaxRequestBody (UInt16 refnum, HS_HTTPLibHandle libH, Int32 in_size)
    This function sets the maximal size of Request-Body. If in_size is -1, the maximal size is unlimited.
  • Boolean HS_HTTPLibSetProxy (UInt16 refnum, HS_HTTPLibHandle libH, Char *in_proxy_host, Int32 in_proxy_host_len, Int32 in_proxy_http_port, Int32 in_proxy_https_port, Char *in_no_proxy_hosts, Int32 in_no_proxy_hosts_len)
    This function sets the proxy server setting for this application. If in_proxy_host is NULL, in_proxy_host, in_proxy_http_port, in_proxy_https_port are not set. If in_no_proxy_hosts is NULL, in_no_proxy_hosts is not set. The format of in_no_proxy_hosts is comma (“,”) separated list.
  • Boolean HS_HTTPLibSetUserAgent (UInt16 refnum, HS_HTTPLibHandle libH, Char *in_useragent, Int32 in_useragent_len)
    This function sets the UserAgent string for the application. If in_useragent is NULL, setting is cleared.
  • Boolean HS_HTTPLibSetDefaultHeaders (UInt16 refnum, HS_HTTPLibHandle libH, Char *in_default_headers, Int32 in_default_headers_len)
    This function sets the default header, i.e. this string is added to the Request-header of the Request created at HS_HTTPLibStreamCreateRequest. If in_default_headers is NULL, the setting is cleared.
  • void HS_HTTPLibSetUseProxy (UInt16 refnum, HS_HTTPLibHandle libH, Boolean in_bool)
    This function sets whether this application uses proxy server.
  • void HS_HTTPLibSetHTTP11OverProxy (UInt16 refnum, HS_HTTPLibHandle libH, Boolean in_bool)
    This function sets whether this application permits HTTP1.1 over proxy server. If false is set, the application use HTTP/1.0.
  • void HS_HTTPLibSetSendReferer (UInt16 refnum, HS_HTTPLibHandle libH, Boolean in_bool)
    Parameters:
    refnum,: IN:

  • void HS_HTTPLibSetSendProxyKeepAlive (UInt16 refnum, HS_HTTPLibHandle libH, Boolean in_bool)
    Parameters:
    refnum,: IN:

  • void HS_HTTPLibSetSendCookie (UInt16 refnum, HS_HTTPLibHandle libH, Boolean in_bool)
    This function sets whether this application sends Cookie.
  • void HS_HTTPLibSetConnectTimeOut (UInt16 refnum, HS_HTTPLibHandle libH, Int32 in_msec)
    This function sets the limit of Connection timeout. If in_msec is -1, no timeout is set. The condition of timeout is in_msec has passed from TCP connect without HTTP connection established.
  • void HS_HTTPLibSetReqTimeOut (UInt16 refnum, HS_HTTPLibHandle libH, Int32 in_msec)
    This function sets the limit of sending Request timeout. If in_msec is -1, no timeout is set. The condition of timeout is in_msec has passed from the start of Request sending without sending done.
  • void HS_HTTPLibSetRspTimeOut (UInt16 refnum, HS_HTTPLibHandle libH, Int32 in_msec)
    This function sets the limit of receiving Response timeout. If in_msec is -1, no timeout is set. The condition of timeout is in_msec has passed from the end of sending request without receiving Response. Or in_msec has passed from the last receiving a part of Response without receiving any part of Response.
  • void HS_HTTPLibSetTunnelingCallback (UInt16 refnum, HS_HTTPLibHandle libH, HS_HTTPLibTunnelingCallbackProc in_cb, void *in_aux)
    Parameters:
    refnum,: IN:

  • Boolean HS_HTTPLibIsUseProxy (UInt16 refnum, HS_HTTPLibHandle libH)
    This function returns whether this application uses proxy.
  • Boolean HS_HTTPLibIsHTTP11OverProxy (UInt16 refnum, HS_HTTPLibHandle libH)
    This function returns whether this application permits HTTP/1.1 over proxy.
  • Boolean HS_HTTPLibIsSendReferer (UInt16 refnum, HS_HTTPLibHandle libH)
    Parameters:
    refnum,: IN:

  • Boolean HS_HTTPLibIsSendCookie (UInt16 refnum, HS_HTTPLibHandle libH)
    This function returns whether this application sends Cookie.
  • HS_HTTPLibStream HS_HTTPLibStreamNew (UInt16 refnum, HS_HTTPLibHandle libH)
    This function creates a new stream and returns the handle of stream instance. At this time, TCP/SSL socket is not opened.
  • void HS_HTTPLibStreamDelete (UInt16 refnum, HS_HTTPLibStream stream)
    This function deletes the stream instance. If this function is called without calling HS_HTTPLibStreamClose, this function closes the TCP/SSL socket by calling HS_HTTPLibStreamClose, however if the socket is in keep-alive, it is not closed.
  • Int32 HS_HTTPLibStreamCreateRequest (UInt16 refnum, HS_HTTPLibStream stream, Int32 in_method, Char *in_url, UInt32 in_url_len, Char *in_header, UInt32 in_header_len, Char *in_referer, UInt32 in_referer_len, Int32 in_version, Boolean in_no_cache, Boolean in_pipeline, Int32 in_ssl_flag)
    This function creates a request. If using proxy and SSL connection, CONNECT request message is made. If there are cached authenticate informations, add authenticate header. Add default headers and in_header to Request-Header.
  • Int32 HS_HTTPLibStreamCreateRequestWithChunkEncoding (UInt16 refnum, HS_HTTPLibStream stream, Int32 in_method, Char *in_url, UInt32 in_url_len, Char *in_header, UInt32 in_header_len, Char *in_referer, UInt32 in_referer_len, Int32 in_version, Boolean in_no_cache, Boolean in_pipeline, Int32 in_ssl_flag)
    This function creates request for chunk-encoding post. If using proxy and SSL connection, CONNECT request message is made. If there are cached authenticate informations, add authenticate header. Add default headers and in_header to Request-Header. Do not use this API unless you want to create chunk-encoding request. Transfer- Encoding: chunked is added to the request header.
  • Int32 HS_HTTPLibStreamSendRequest (UInt16 refnum, HS_HTTPLibStream stream, Int32 *out_sleep)
    This function sends the request. This call opens and connects a TCP connection if not already established. It automatically retries at where pipeline stalled if pipeline is enable.
  • Int32 HS_HTTPLibStreamSendRequestWithPostData (UInt16 refnum, HS_HTTPLibStream stream, Char *in_buf, Int32 in_len, Int32 *out_len, Int32 *out_sleep)
    This function sends the POST request. This call opens and connects a TCP connection if not already established. It automatically retries at where pipeline stalled if pipeline is enable.
  • Int32 HS_HTTPLibStreamSendRequestWithChunkEncoding (UInt16 refnum, HS_HTTPLibStream stream, Char *in_buf, Int32 in_offset, Int32 in_len, Boolean isFinish, Int32 *out_len, Int32 *out_sleep)
    This function sends chunk encoding data. This call opens and connects a TCP connection if not already established. It automatically retries at where pipeline stalled if pipeline is enable. The sequence of chunked data sending is 1. call HS_HTTPLibStreamCreateRequestWithChunkEncoding() 2. call HS_HTTPLibStreamSendRequestWithChunkEncoding() while return value is not httpErrorOK or error. 3. If there remains data, goto 2. 4. end If only one chunked data is sent, this API returns httpErrorOK. The address of data for one chunk is in_buf + in_offset, this value should not be changed while sending only one chunked data. isFinish is used to indicate the chunked data is the last chunk.
  • Int32 HS_HTTPLibStreamReceiveResponse (UInt16 refnum, HS_HTTPLibStream stream, Char *out_buf, Int32 in_len, Int32 *out_len, Int32 *out_sleep)
    This function receives response. It automatically retries at where pipeline stalled if pipeline is enable.
  • Int32 HS_HTTPLibStreamGetFlag (UInt16 refnum, HS_HTTPLibStream stream)
    Parameters:
    refnum,: IN:

  • void HS_HTTPLibStreamSuspendTimer (UInt16 refnum, HS_HTTPLibStream stream)
    Parameters:
    refnum,: IN:

  • void HS_HTTPLibStreamResumeTimer (UInt16 refnum, HS_HTTPLibStream stream)
    Parameters:
    refnum,: IN:

  • void HS_HTTPLibStreamClose (UInt16 refnum, HS_HTTPLibStream stream)
    This function closes the HTTP stream. If the TCP/SSL socket is in keep-alive, it is not closed.
  • Boolean HS_HTTPLibStreamIsHeaderReceived (UInt16 refnum, HS_HTTPLibStream stream)
    This function returns whether the response header is completely received.
  • Int32 HS_HTTPLibStreamSetPostData (UInt16 refnum, HS_HTTPLibStream stream, Int32 in_encoding, Char *in_data, Int32 in_len)
    This function sets the POST data.
  • Int32 HS_HTTPLibStreamGetScheme (UInt16 refnum, HS_HTTPLibStream stream)
    This function returns the scheme given at the HS_HTTPLibStreamCreateRequest.
  • Int32 HS_HTTPLibStreamGetState (UInt16 refnum, HS_HTTPLibStream stream)
    This function returns the state of the stream. The state changes follow the below sequence (but skipping the states that are not relevant to the current request).
  • Int32 HS_HTTPLibStreamGetStatusCode (UInt16 refnum, HS_HTTPLibStream stream)
    This function returns the Status Code.
  • Int32 HS_HTTPLibStreamGetResponseHeaderLength (UInt16 refnum, HS_HTTPLibStream stream)
    This function returns the size of the response header.
  • HS_HTTPLibVHandle HS_HTTPLibStreamGetResponseHeader (UInt16 refnum, HS_HTTPLibStream stream)
    This function returns the handle of the response header. The responsibility to delete the handle is library, the application can not delete this return value. To lock/unlock the handle, the application should use the APIs,.
  • Int32 HS_HTTPLibStreamGetContentLength (UInt16 refnum, HS_HTTPLibStream stream)
    This function returns the content’s size (byte).
  • Int32 HS_HTTPLibStreamGetEntityLength (UInt16 refnum, HS_HTTPLibStream stream)
    This function returns the size of response body (byte).
  • Boolean HS_HTTPLibStreamAddHeaderLine (UInt16 refnum, HS_HTTPLibStream stream, Char *in_str, Int32 in_len)
    This function adds the line to the Request header. If there is already the same kind of header line, old one is deleted.
  • Boolean HS_HTTPLibStreamAddHeader (UInt16 refnum, HS_HTTPLibStream stream, Int32 in_type, Char *in_str, Int32 in_len)
    This function sets the value of corresponding header. If there is already the same kind of header line, old one is deleted.
  • Boolean HS_HTTPLibStreamGetHeader (UInt16 refnum, HS_HTTPLibStream stream, Int32 in_type, Int32 *out_off, Int32 *out_len)
    This function returns the offset and length of corresponding header value.
  • HS_HTTPLibCertList HS_HTTPLibMakeCertList (UInt16 refnum, HS_HTTPLibStream stream)
    This function returns the Server certification used for SSL. The responsibility to delete the return handle is the application. To delete the return value, the application should use HS_HTTPLibCertListDelete.
  • Boolean HS_HTTPLibHeaderSplitByX (UInt16 refnum, HS_HTTPLibSplit *inout_ss, Int32 in_id, Char *in_cs)
    Parameters:
    refnum,: IN:

  • void HS_HTTPLibAuthInfoTidy (UInt16 refnum, HS_HTTPLibAuthInfo *in_info, Boolean in_new)
    This function initialize/finalize the HS_HTTPLibAuthInfo struct. The application should call this function setting in_new = true before using HS_HTTPLibAuthInfo. The application should call this function setting in_new = false after using HS_HTTPLibAuthInfo.
  • Boolean HS_HTTPLibSetUserPass (UInt16 refnum, HS_HTTPLibHandle libH, Int32 in_type, Int32 in_target, HS_HTTPLibSplit *in_challenge, HS_HTTPLibSplit *in_realm, Char *in_user, Int32 in_user_len, Char *in_pass, Int32 in_pass_len, Char *in_url, Int32 in_url_len, Char *in_host, Int32 in_host_len, Int32 in_port)
    This function sets the authentication information.
  • Boolean HS_HTTPLibFindAuthInfo (UInt16 refnum, HS_HTTPLibHandle libH, Int32 in_target, Char *in_url, Int32 in_url_len, Char *in_host, Int32 in_host_len, Int32 in_port, HS_HTTPLibSplit *in_realm, HS_HTTPLibAuthInfo *out_info)
    Parameters:
    refnum,: IN:

  • Boolean HS_HTTPLibMakeAuthInfo (UInt16 refnum, HS_HTTPLibHandle libH, Int32 in_target, Char *in_url, Int32 in_url_len, Char *in_host, Int32 in_host_len, Int32 in_port, HS_HTTPLibSplit *in_realm, HS_HTTPLibAuthInfo *out_info)
    This function returns the authentication information to the out_info. Before calling this API, the application should intialize HS_HTTPLibAuthInfo by HS_HTTPLibAuthInfoTidy(out_info, true).
  • HS_HTTPLibString HS_HTTPLibAuthInfoUser (UInt16 refnum, HS_HTTPLibAuthInfo *in_info)
    This function returns the User Name. The application should not delete this return value.
  • HS_HTTPLibString HS_HTTPLibAuthInfoPass (UInt16 refnum, HS_HTTPLibAuthInfo *in_info)
    This function returns the Password. The application should not delete this return value.
  • HS_HTTPLibString HS_HTTPLibAuthInfoRealm (UInt16 refnum, HS_HTTPLibAuthInfo *in_info)
    This function returns the Realm. The application should not delete this return value.
  • Boolean HS_HTTPLibAuthCacheGetChallengeTokenSS (UInt16 refnum, HS_HTTPLibSplit *in_challenge_ss, Char *in_token, HS_HTTPLibSplit *out_ss)
    Parameters:
    refnum,: IN:

  • void HS_HTTPLibSetCookieMode (UInt16 refnum, HS_HTTPLibHandle libH, Int32 in_mode, HS_HTTPLibCookieConfirmProc in_cb, HS_HTTPLibOpaque in_opaque)
    This function sets the Cookie mode.
  • void HS_HTTPLibSetCookieMax (UInt16 refnum, HS_HTTPLibHandle libH, Int32 in_max_total_cookies, Int32 in_max_cookies_per_domain, Int32 in_max_len_per_cookie)
    This function sets the max size of Cookie entries.
  • Int32 HS_HTTPLibSetCookie (UInt16 refnum, HS_HTTPLibHandle libH, HS_HTTPLibURLString in_url, Char *in_header, Int32 in_header_len)
    This function sets the Cookie abiding with the confirmation mode set by HS_HTTPLibSetCookieMode. The application should not use this API in callback function. The API HS_HTTPLibSetCookieX is designed for use in callback.
  • Int32 HS_HTTPLibSetCookieX (UInt16 refnum, HS_HTTPLibHandle libH, HS_HTTPLibURLString in_url, Char *in_header, Int32 in_header_len)
    This function sets the Cookie. This function is designed for callback confirm function.
  • HS_HTTPLibString HS_HTTPLibMakeCookiesString (UInt16 refnum, HS_HTTPLibHandle libH, Char *in_url, Int32 in_urllen, Boolean in_secure, Int32 *out_len)
    Parameters:
    refnum,: IN:

  • HS_HTTPLibString HS_HTTPLibSaveCookiesEntries (UInt16 refnum, HS_HTTPLibHandle libH, Int32 *out_len)
    Parameters:
    refnum,: IN:

  • Boolean HS_HTTPLibLoadCookiesEntries (UInt16 refnum, HS_HTTPLibHandle libH, Char *in_s, Int32 in_slen)
    Parameters:
    refnum,: IN:

  • void HS_HTTPLibCookieMakeEmpty (UInt16 refnum, HS_HTTPLibHandle libH, Int32 in_flag)
    This function clears Cookies.
  • void HS_HTTPLibSetDNSMaxRetry (UInt16 refnum, HS_HTTPLibHandle libH, Int32 in_retry)
    Parameters:
    refnum,: IN:

  • void HS_HTTPLibSetDNSRetryInterval (UInt16 refnum, HS_HTTPLibHandle libH, Int32 in_interval)
    Parameters:
    refnum,: IN:

  • void HS_HTTPLibSetSSLVersionFlag (UInt16 refnum, HS_HTTPLibHandle libH, Int32 in_flag, Boolean in_on)
    Set the SSL version.
  • Int32 HS_HTTPLibSSLTimeout (UInt16 refnum, HS_HTTPLibHandle libH)
    Set the timeout period for SSL use.
  • Int32 HS_HTTPLibSSLOpenCertDB (UInt16 refnum, HS_HTTPLibHandle libH, HS_HTTPLibCertList *out_list)
    TBD.
  • void HS_HTTPLibSSLCloseCertDB (UInt16 refnum, HS_HTTPLibHandle libH)
    TBD.
  • HS_HTTPLibCertList HS_HTTPLibCertListNew (UInt16 refnum, Int32 in_type)
    Parameters:
    refnum,: IN:

  • void HS_HTTPLibCertListDelete (UInt16 refnum, HS_HTTPLibCertList in_list)
    TBD.
  • HS_HTTPLibCertList HS_HTTPLibCertListClone (UInt16 refnum, HS_HTTPLibCertList in_list)
    TBD.
  • void * HS_HTTPLibCertListLock (UInt16 refnum, HS_HTTPLibCertList in_list)
    Lock the certificate list and return its pointer.
  • void HS_HTTPLibCertListUnlock (UInt16 refnum, HS_HTTPLibCertList in_list)
    Unlock the certificate list.
  • Int32 HS_HTTPLibCertListType (UInt16 refnum, HS_HTTPLibCertList in_list)
    TBD.
  • Int32 HS_HTTPLibCertListLength (UInt16 refnum, HS_HTTPLibCertList in_list)
    TBD.
  • Int32 HS_HTTPLibCertListBeginDecode (UInt16 refnum, HS_HTTPLibCertList in_list, Int32 in_index, HS_HTTPLibCertPtr *out_cert)
    TBD.
  • void HS_HTTPLibCertListEndDecode (UInt16 refnum, HS_HTTPLibCertList in_list, HS_HTTPLibCertPtr in_cert)
    TBD.
  • Int32 HS_HTTPLibCertListImportCert (UInt16 refnum, HS_HTTPLibCertList in_list, void *in_info, Boolean in_over_write)
    TBD.
  • Int32 HS_HTTPLibCertPeekVersion (UInt16 refnum, HS_HTTPLibCertPtr in_cert)
    Parameters:
    refnum,: IN:

  • Int32 HS_HTTPLibCertPeekSerialNumber (UInt16 refnum, HS_HTTPLibCertPtr in_cert, Char **out_str)
    Parameters:
    refnum,: IN:

  • Int32 HS_HTTPLibCertPeekSignAlgo (UInt16 refnum, HS_HTTPLibCertPtr in_cert)
    Parameters:
    refnum,: IN:

  • Boolean HS_HTTPLibCertBeginPeekIssuerRDN (UInt16 refnum, HS_HTTPLibCertPtr in_cert, Int32 in_attr)
    Parameters:
    refnum,: IN:

  • Int32 HS_HTTPLibCertPeekIssuerRDN (UInt16 refnum, HS_HTTPLibCertPtr in_cert, Char **out_str)
    Parameters:
    refnum,: IN:

  • Int32 HS_HTTPLibCertPeekIssuerRDNStrType (UInt16 refnum, HS_HTTPLibCertPtr in_cert)
    Parameters:
    refnum,: IN:

  • void HS_HTTPLibCertEndPeekIssuerRDN (UInt16 refnum, HS_HTTPLibCertPtr in_cert)
    Parameters:
    refnum,: IN:

  • Boolean HS_HTTPLibCertBeginPeekSubjectRDN (UInt16 refnum, HS_HTTPLibCertPtr in_cert, Int32 in_attr)
    Parameters:
    refnum,: IN:

  • Int32 HS_HTTPLibCertPeekSubjectRDN (UInt16 refnum, HS_HTTPLibCertPtr in_cert, Char **out_str)
    Parameters:
    refnum,: IN:

  • Int32 HS_HTTPLibCertPeekSubjectRDNStrType (UInt16 refnum, HS_HTTPLibCertPtr in_cert)
    Parameters:
    refnum,: IN:

  • void HS_HTTPLibCertEndPeekSubjectRDN (UInt16 refnum, HS_HTTPLibCertPtr in_cert)
    Parameters:
    refnum,: IN:

  • void HS_HTTPLibCertPeekValidityStart (UInt16 refnum, HS_HTTPLibCertPtr in_cert, HS_HTTPLibTime *in_time)
    Parameters:
    refnum,: IN:

  • void HS_HTTPLibCertPeekValidityEnd (UInt16 refnum, HS_HTTPLibCertPtr in_cert, HS_HTTPLibTime *in_time)
    Parameters:
    refnum,: IN:

  • Int32 HS_HTTPLibCertPeekRSAPublicKeyBits (UInt16 refnum, HS_HTTPLibCertPtr in_cert)
    Parameters:
    refnum,: IN:

  • HS_HTTPLibClientCertList HS_HTTPLibClientCertListNew (UInt16 refnum)
    Parameters:
    refnum,: IN:

  • HS_HTTPLibClientCertList HS_HTTPLibClientCertListClone (UInt16 refnum, HS_HTTPLibClientCertList in_list)
    TBD.
  • void HS_HTTPLibClientCertListDelete (UInt16 refnum, HS_HTTPLibClientCertList in_list)
    Parameters:
    refnum,: IN:

  • Int32 HS_HTTPLibClientCertListLength (UInt16 refnum, HS_HTTPLibClientCertList in_list)
    TBD.
  • Boolean HS_HTTPLibClientCertListIsValid (UInt16 refnum, HS_HTTPLibClientCertList in_list, Int32 in_index)
    TBD.
  • void HS_HTTPLibClientCertListSetValid (UInt16 refnum, HS_HTTPLibClientCertList in_list, Int32 in_index, Boolean in_valid)
    TBD.
  • void HS_HTTPLibSetSSLServerCertConfirmProc (UInt16 refnum, HS_HTTPLibHandle libH, HS_HTTPLibServerCertConfirmProc in_cb, HS_HTTPLibOpaque in_opaque)
    This function sets the server certificate callback function for this application.
  • void HS_HTTPLibServerCertConfirm (UInt16 refnum, HS_HTTPLibSSL in_ssl, Int32 in_verify_result, Boolean in_confirm)
    This function sets the result of confirmation. This function should be called in the callback function.
  • void HS_HTTPLibSetSSLClientCertSelectProc (UInt16 refnum, HS_HTTPLibHandle libH, HS_HTTPLibClientCertSelectProc in_cb, HS_HTTPLibOpaque in_opaque)
    This function sets the client certification select callback function.For now, there is no corresponding function in SSL library, the callback will not be called.
  • void HS_HTTPLibClientCertSelect (UInt16 refnum, HS_HTTPLibSSL in_ssl, Int32 in_index)
    This function sets the selected certification. For now, there is no corresponding function in SSL library, the callback will not be called.
  • void HS_HTTPLibSetNetLibProc (UInt16 refnum, HS_HTTPLibHandle libH, UInt16 netLibRefnum, HS_HTTPLibNetLibOpenProc in_open, HS_HTTPLibNetLibCloseProc in_close, HS_HTTPLibNetLibOnlineProc in_online, HS_HTTPLibNetLibOfflineProc in_offline)
    This function sets the callback functions concerning NetLib. But for now, there is no call to callback functions from Peer layer.
  • Int32 HS_HTTPLibDataHandle_Length (UInt16 refnum, HS_HTTPLibDataHandle in_handle)
    Parameters:
    refnum,: IN:

  • void * HS_HTTPLibDataHandle_Lock (UInt16 refnum, HS_HTTPLibDataHandle in_handle)
    Parameters:
    refnum,: IN:

  • void HS_HTTPLibDataHandle_Unlock (UInt16 refnum, HS_HTTPLibDataHandle in_handle)
    Parameters:
    refnum,: IN:

  • void HS_HTTPLibDataHandle_Delete (UInt16 refnum, HS_HTTPLibDataHandle in_handle)
    Parameters:
    refnum,: IN:

  • Int32 HS_HTTPLibVHandle_Length (UInt16 refnum, HS_HTTPLibVHandle in_vhandle)
    This function returns the length of the handle (byte).
  • void * HS_HTTPLibVHandle_Lock (UInt16 refnum, HS_HTTPLibVHandle in_vhandle)
    This function locks the handle of type HS_HTTPLibVHandle.
  • void HS_HTTPLibVHandle_Unlock (UInt16 refnum, HS_HTTPLibVHandle in_vhandle)
    This function unlocks the handle of type HS_HTTPLibVHandle.
  • void HS_HTTPLibVHandle_Delete (UInt16 refnum, HS_HTTPLibVHandle in_vhandle)
    This function deletes the handle of type HS_HTTPLibVHandle.
  • Int32 HS_HTTPLibString_Length (UInt16 refnum, HS_HTTPLibString in_str)
    This function returns the length of the handle (byte).
  • HS_HTTPLibString HS_HTTPLibStringNew (UInt16 refnum, Char *in_str, Int32 in_len)
    This function creates a new handle of type HS_HTTPLibString.
  • void * HS_HTTPLibString_Lock (UInt16 refnum, HS_HTTPLibString in_str)
    This function locks the handle of type HS_HTTPLibString.
  • void HS_HTTPLibString_Unlock (UInt16 refnum, HS_HTTPLibString in_str)
    This function unlocks the handle of type HS_HTTPLibString.
  • void HS_HTTPLibString_Delete (UInt16 refnum, HS_HTTPLibString in_str)
    This function deletes the handle of type HS_HTTPLibString.
  • Int32 HS_HTTPLibFixedString_Length (UInt16 refnum, HS_HTTPLibFixedString in_str)
    This function returns the length of the handle (byte).
  • HS_HTTPLibFixedString HS_HTTPLibFixedStringNew (UInt16 refnum, Char *in_str, Int32 in_len)
    This function creates a new handle of type HS_HTTPLibFixedString.
  • void * HS_HTTPLibFixedString_Lock (UInt16 refnum, HS_HTTPLibFixedString in_str)
    This function locks the handle of type HS_HTTPLibFixedString.
  • void HS_HTTPLibFixedString_Unlock (UInt16 refnum, HS_HTTPLibFixedString in_str)
    This function unlocks the handle of type HS_HTTPLibFixedString.
  • void HS_HTTPLibFixedString_Delete (UInt16 refnum, HS_HTTPLibFixedString in_str)
    This function deletes the handle of type HS_HTTPLibFixedString.
  • Int32 HS_HTTPLibURLString_Length (UInt16 refnum, HS_HTTPLibURLString in_str)
    This function returns the length of the handle (byte).
  • HS_HTTPLibURLString HS_HTTPLibURLStringNew (UInt16 refnum, Char *in_str, Int32 in_len)
    This function creates a new handle of type HS_HTTPLibURLString.
  • void * HS_HTTPLibURLString_Lock (UInt16 refnum, HS_HTTPLibURLString in_str)
    This function locks the handle of type HS_HTTPLibURLString.
  • void HS_HTTPLibURLString_Unlock (UInt16 refnum, HS_HTTPLibURLString in_str)
    This function unlocks the handle of type HS_HTTPLibURLString.
  • void HS_HTTPLibURLString_Delete (UInt16 refnum, HS_HTTPLibURLString in_str)
    This function deletes the handle of type HS_HTTPLibURLString.
  • void * HS_HTTPLibCertListGetCipherInfo (UInt16 refnum, void *iself)
    This returns the cipher info. SslCipherSuiteInfo is the structure defined in SslLib.h.
  • void HS_HTTPLibSetMaxKeepAliveTimeout (UInt16 refnum, HS_HTTPLibHandle libH, Int32 in_msec)
    Parameters:
    refnum,: IN:

  • void HS_HTTPLibStreamGetRequestSent (UInt16 refnum, HS_HTTPLibStream stream, Int32 *out_total, Int32 *out_sent)
    Parameters:
    refnum,: IN:

  • Boolean HS_HTTPLibStreamGetHeaderWithOffset (UInt16 refnum, HS_HTTPLibStream stream, Int32 in_type, Int32 in_ofs, Int32 *out_off, Int32 *out_len)
    Parameters:
    refnum,: IN:

  • Boolean HS_HTTPLibSetUserPassX (UInt16 refnum, HS_HTTPLibHandle libH, Int32 in_type, Int32 in_target, HS_HTTPLibSplit *in_challenge, HS_HTTPLibSplit *in_realm, Char *in_user, Int32 in_user_len, Char *in_pass, Int32 in_pass_len, Char *in_url, Int32 in_url_len, Char *in_host, Int32 in_host_len, Int32 in_port, Boolean in_keep_user, Boolean in_keep_pass)
    Parameters:
    refnum,: IN:

  • void HS_HTTPLibFindAuthCandidate (UInt16 refnum, HS_HTTPLibHandle libH, Int32 in_target, Char *in_url, Int32 in_url_len, Char *in_host, Int32 in_host_len, Int32 in_port, Char *in_realm, Int32 in_realm_len, HS_HTTPLibString *out_user, HS_HTTPLibString *out_pass, Boolean *out_keep_user, Boolean *out_keep_pass)
    Parameters:
    refnum,: IN:

  • void HS_HTTPLibSetWakeUpCallback (UInt16 refnum, HS_HTTPLibHandle libH, HS_HTTPLibWakeUpCallbackProc in_proc, HS_HTTPLibOpaque in_opaque)
    Parameters:
    refnum,: IN:

  • Boolean HS_HTTPLibSetUseragentSelectionRule (UInt16 refnum, HS_HTTPLibHandle libH, HttpUASelectionRule *rules, Int32 len)
    Parameters:
    refnum,: IN:

Typedef Documentation

typedef struct HS_HTTPLibAuthInfo_ HS_HTTPLibAuthInfo

Definition at line 79 of file HS_HTTPLib68K.h.

typedef void* HS_HTTPLibCertList

Definition at line 105 of file HS_HTTPLib68K.h.

typedef void* HS_HTTPLibCertPtr

Definition at line 104 of file HS_HTTPLib68K.h.

typedef void* HS_HTTPLibClientCertList

Definition at line 106 of file HS_HTTPLib68K.h.

typedef Int32(*) HS_HTTPLibClientCertSelectProc(HS_HTTPLibSSL in_ssl, HS_HTTPLibClientCertList in_list, HS_HTTPLibOpaque in_aux)

Definition at line 111 of file HS_HTTPLib68K.h.

typedef Int32(*) HS_HTTPLibCookieConfirmProc(HS_HTTPLibCookies in_cookie, HS_HTTPLibURLString in_url, Char *in_header, Int32 in_header_len, HS_HTTPLibOpaque in_aux)

Definition at line 109 of file HS_HTTPLib68K.h.

typedef void* HS_HTTPLibCookies

Definition at line 103 of file HS_HTTPLib68K.h.

typedef void* HS_HTTPLibDataHandle

Definition at line 62 of file HS_HTTPLib68K.h.

typedef void* HS_HTTPLibFixedString

Definition at line 65 of file HS_HTTPLib68K.h.

typedef Int32(*) HS_HTTPLibServerCertConfirmProc(HS_HTTPLibSSL in_ssl, Int32 in_verify_result, HS_HTTPLibCertList in_list, HS_HTTPLibOpaque in_aux)

Definition at line 110 of file HS_HTTPLib68K.h.

typedef struct HS_HTTPLibSplit_ HS_HTTPLibSplit

Definition at line 54 of file HS_HTTPLib68K.h.

typedef void* HS_HTTPLibSSL

Definition at line 102 of file HS_HTTPLib68K.h.

typedef void* HS_HTTPLibSSLClassPtr

Definition at line 107 of file HS_HTTPLib68K.h.

typedef void* HS_HTTPLibStream

Definition at line 101 of file HS_HTTPLib68K.h.

typedef void* HS_HTTPLibString

Definition at line 64 of file HS_HTTPLib68K.h.

typedef struct HS_HTTPLibTime_ HS_HTTPLibTime

Definition at line 60 of file HS_HTTPLib68K.h.

typedef Int32(*) HS_HTTPLibTunnelingCallbackProc(HS_HTTPLibStream stream, Char *buf, Int32 len, void *in_aux)

Definition at line 112 of file HS_HTTPLib68K.h.

typedef void* HS_HTTPLibURLString

Definition at line 66 of file HS_HTTPLib68K.h.

typedef void* HS_HTTPLibVHandle

Definition at line 63 of file HS_HTTPLib68K.h.

typedef void(*) HS_HTTPLibWakeUpCallbackProc(HS_HTTPLibOpaque in_aux)

Definition at line 113 of file HS_HTTPLib68K.h.

Enumeration Type Documentation

anonymous enum

This sets the rules for HttpLib to use to select useragent for each request. The rule should be set as little as possible so that it does not slow down browser performance.

Enumerator:
httpUASelectTypeHost
httpUASelectTypePath

Definition at line 86 of file HS_HTTPLib68K.h.

00086      {
00087     httpUASelectTypeHost,       /**<        */
00088     httpUASelectTypePath        /**<        */
00089 };

Function Documentation

Boolean HS_HTTPLibAuthCacheGetChallengeTokenSS | ( | UInt16 | refnum,
 |  | HS_HTTPLibSplit * | in_challenge_ss,
 |  | Char * | in_token,
 |  | HS_HTTPLibSplit * | out_ss
 | ) |  |

Parameters:
refnum,: IN:

Parameters:
*in_challenge_ss,: IN:
*in_token,: IN:
*out_ss,: IN:
Return values:
Err error code.

HS_HTTPLibString HS_HTTPLibAuthInfoPass | ( | UInt16 | refnum,
 |  | HS_HTTPLibAuthInfo * | in_info
 | ) |  |

This function returns the Password. The application should not delete this return value.

Parameters:
refnum,: IN: Library reference number.
*in_info,: IN: The pointer to the authentication information.
Returns:
The handle of password.

HS_HTTPLibString HS_HTTPLibAuthInfoRealm | ( | UInt16 | refnum,
 |  | HS_HTTPLibAuthInfo * | in_info
 | ) |  |

This function returns the Realm. The application should not delete this return value.

Parameters:
refnum,: IN: Library reference number.
*in_info,: IN: The pointer to the authentication information.
Returns:
The handle of Realm.

void HS_HTTPLibAuthInfoTidy | ( | UInt16 | refnum,
 |  | HS_HTTPLibAuthInfo * | in_info,
 |  | Boolean | in_new
 | ) |  |

This function initialize/finalize the HS_HTTPLibAuthInfo struct. The application should call this function setting in_new = true before using HS_HTTPLibAuthInfo. The application should call this function setting in_new = false after using HS_HTTPLibAuthInfo.

Parameters:
refnum,: IN: Library reference number.
*in_info,: IN: The pointer to the authenticate information struct.
in_new,: IN: True if initialize the member. False if initialize the member after deleting.
Returns:
None.

HS_HTTPLibString HS_HTTPLibAuthInfoUser | ( | UInt16 | refnum,
 |  | HS_HTTPLibAuthInfo * | in_info
 | ) |  |

This function returns the User Name. The application should not delete this return value.

Parameters:
refnum,: IN: Library reference number.
*in_info,: IN: The pointer to the authentication information.
Returns:
The handle of User Name.

Boolean HS_HTTPLibCertBeginPeekIssuerRDN | ( | UInt16 | refnum,
 |  | HS_HTTPLibCertPtr | in_cert,
 |  | Int32 | in_attr
 | ) |  |

Parameters:
refnum,: IN:

Parameters:
in_cert,: IN:
in_attr,: IN:
Return values:
Err error code.

Boolean HS_HTTPLibCertBeginPeekSubjectRDN | ( | UInt16 | refnum,
 |  | HS_HTTPLibCertPtr | in_cert,
 |  | Int32 | in_attr
 | ) |  |

Parameters:
refnum,: IN:

Parameters:
in_cert,: IN:
in_attr,: IN:
Return values:
Err error code.

void HS_HTTPLibCertEndPeekIssuerRDN | ( | UInt16 | refnum,
 |  | HS_HTTPLibCertPtr | in_cert
 | ) |  |

Parameters:
refnum,: IN:

Parameters:
in_cert,: IN:
Return values:
Err error code.

void HS_HTTPLibCertEndPeekSubjectRDN | ( | UInt16 | refnum,
 |  | HS_HTTPLibCertPtr | in_cert
 | ) |  |

Parameters:
refnum,: IN:

Parameters:
in_cert,: IN:
Return values:
Err error code.

Int32 HS_HTTPLibCertListBeginDecode | ( | UInt16 | refnum,
 |  | HS_HTTPLibCertList | in_list,
 |  | Int32 | in_index,
 |  | HS_HTTPLibCertPtr * | out_cert
 | ) |  |

TBD.

Parameters:
refnum,: IN: Library reference number.
in_list,: IN: The handle of the server’s certification list.
in_index,: IN: -
*out_cert,: OUT: -
Return values:
Int32

HS_HTTPLibCertList HS_HTTPLibCertListClone | ( | UInt16 | refnum,
 |  | HS_HTTPLibCertList | in_list
 | ) |  |

TBD.

Parameters:
refnum,: IN: Library reference number.
in_list,: IN: The handle of the server’s certification list.
Returns:
Handle to the clone of the certification list.

void HS_HTTPLibCertListDelete | ( | UInt16 | refnum,
 |  | HS_HTTPLibCertList | in_list
 | ) |  |

TBD.

Parameters:
refnum,: IN: Library reference number.
in_list,: IN: The handle of the server’s certification list.
Returns:
None.

void HS_HTTPLibCertListEndDecode | ( | UInt16 | refnum,
 |  | HS_HTTPLibCertList | in_list,
 |  | HS_HTTPLibCertPtr | in_cert
 | ) |  |

TBD.

Parameters:
refnum,: IN: Library reference number.
in_list,: IN: The handle of the server’s certification list.
in_cert,: IN: -
Returns:
None.

void* HS_HTTPLibCertListGetCipherInfo | ( | UInt16 | refnum,
 |  | void * | iself
 | ) |  |

This returns the cipher info. SslCipherSuiteInfo is the structure defined in SslLib.h.

The implementation of this API in ARM native version is mere macro.

Parameters:
refnum,: IN: Library reference number.
*iself,: IN: -
Return values:
nothing

Int32 HS_HTTPLibCertListImportCert | ( | UInt16 | refnum,
 |  | HS_HTTPLibCertList | in_list,
 |  | void * | in_info,
 |  | Boolean | in_over_write
 | ) |  |

TBD.

Parameters:
refnum,: IN: Library reference number.
in_list,: IN: The handle of the server’s certification list.
*in_info,: IN: -
in_over_write,: IN: -
Return values:
Int32

Int32 HS_HTTPLibCertListLength | ( | UInt16 | refnum,
 |  | HS_HTTPLibCertList | in_list
 | ) |  |

TBD.

Parameters:
refnum,: IN: Library reference number.
in_list,: IN: The handle of the server’s certification list.
Return values:
Int32

void* HS_HTTPLibCertListLock | ( | UInt16 | refnum,
 |  | HS_HTTPLibCertList | in_list
 | ) |  |

Lock the certificate list and return its pointer.

Parameters:
refnum,: IN: Library reference number.
in_list,: IN: The handle of the server's certification list.
Returns:
Pointer to the certificate list.

HS_HTTPLibCertList HS_HTTPLibCertListNew | ( | UInt16 | refnum,
 |  | Int32 | in_type
 | ) |  |

Parameters:
refnum,: IN:

Parameters:
in_type,: IN:
Returns:

Int32 HS_HTTPLibCertListType | ( | UInt16 | refnum,
 |  | HS_HTTPLibCertList | in_list
 | ) |  |

TBD.

Parameters:
refnum,: IN: Library reference number.
in_list,: IN: The handle of the server’s certification list.
Return values:
Int32

void HS_HTTPLibCertListUnlock | ( | UInt16 | refnum,
 |  | HS_HTTPLibCertList | in_list
 | ) |  |

Unlock the certificate list.

Parameters:
refnum,: IN: Library reference number.
in_list,: IN: The handle of the server’s certification list.
Returns:
None.

Int32 HS_HTTPLibCertPeekIssuerRDN | ( | UInt16 | refnum,
 |  | HS_HTTPLibCertPtr | in_cert,
 |  | Char ** | out_str
 | ) |  |

Parameters:
refnum,: IN:

Parameters:
in_cert,: IN:
**out_str,: IN:
Return values:
Err error code.

Int32 HS_HTTPLibCertPeekIssuerRDNStrType | ( | UInt16 | refnum,
 |  | HS_HTTPLibCertPtr | in_cert
 | ) |  |

Parameters:
refnum,: IN:

Parameters:
in_cert,: IN:
Return values:
Err error code.

Int32 HS_HTTPLibCertPeekRSAPublicKeyBits | ( | UInt16 | refnum,
 |  | HS_HTTPLibCertPtr | in_cert
 | ) |  |

Parameters:
refnum,: IN:

Parameters:
in_cert,: IN:
Return values:
Err error code.

Int32 HS_HTTPLibCertPeekSerialNumber | ( | UInt16 | refnum,
 |  | HS_HTTPLibCertPtr | in_cert,
 |  | Char ** | out_str
 | ) |  |

Parameters:
refnum,: IN:

Parameters:
in_cert,: IN:
**out_str,: IN:
Return values:
Err error code.

Int32 HS_HTTPLibCertPeekSignAlgo | ( | UInt16 | refnum,
 |  | HS_HTTPLibCertPtr | in_cert
 | ) |  |

Parameters:
refnum,: IN:

Parameters:
in_cert,: IN:
Return values:
Err error code.

Int32 HS_HTTPLibCertPeekSubjectRDN | ( | UInt16 | refnum,
 |  | HS_HTTPLibCertPtr | in_cert,
 |  | Char ** | out_str
 | ) |  |

Parameters:
refnum,: IN:

Parameters:
in_cert,: IN:
**out_str,: IN:
Return values:
Err error code.

Int32 HS_HTTPLibCertPeekSubjectRDNStrType | ( | UInt16 | refnum,
 |  | HS_HTTPLibCertPtr | in_cert
 | ) |  |

Parameters:
refnum,: IN:

Parameters:
in_cert,: IN:
Return values:
Err error code.

void HS_HTTPLibCertPeekValidityEnd | ( | UInt16 | refnum,
 |  | HS_HTTPLibCertPtr | in_cert,
 |  | HS_HTTPLibTime * | in_time
 | ) |  |

Parameters:
refnum,: IN:

Parameters:
in_cert,: IN:
*in_time,: IN:
Return values:
Err error code.

void HS_HTTPLibCertPeekValidityStart | ( | UInt16 | refnum,
 |  | HS_HTTPLibCertPtr | in_cert,
 |  | HS_HTTPLibTime * | in_time
 | ) |  |

Parameters:
refnum,: IN:

Parameters:
in_cert,: IN:
*in_time,: IN:
Return values:
Err error code.

Int32 HS_HTTPLibCertPeekVersion | ( | UInt16 | refnum,
 |  | HS_HTTPLibCertPtr | in_cert
 | ) |  |

Parameters:
refnum,: IN:

Parameters:
in_cert,: IN:
Return values:
Err error code.

void HS_HTTPLibClearDNSCache | ( | UInt16 | refnum,
 |  | HS_HTTPLibHandle | libH
 | ) |  |

This function clears the DNS cache information.

Parameters:
refnum,: IN: Library reference number
libH,: IN: The handle of HTTP library instance
Returns:
None.

HS_HTTPLibClientCertList HS_HTTPLibClientCertListClone | ( | UInt16 | refnum,
 |  | HS_HTTPLibClientCertList | in_list
 | ) |  |

TBD.

Parameters:
refnum,: IN:
in_list,: IN:
Return values:
HS_HTTPLibClientCertList

void HS_HTTPLibClientCertListDelete | ( | UInt16 | refnum,
 |  | HS_HTTPLibClientCertList | in_list
 | ) |  |

Parameters:
refnum,: IN:

Parameters:
in_list,: IN:
Return values:
nothing

Boolean HS_HTTPLibClientCertListIsValid | ( | UInt16 | refnum,
 |  | HS_HTTPLibClientCertList | in_list,
 |  | Int32 | in_index
 | ) |  |

TBD.

Parameters:
refnum,: IN:
in_list,: IN:
in_index,: IN:
Return values:
Boolean

Int32 HS_HTTPLibClientCertListLength | ( | UInt16 | refnum,
 |  | HS_HTTPLibClientCertList | in_list
 | ) |  |

TBD.

Parameters:
refnum,: IN:
in_list,: IN:
Return values:
Nothing

HS_HTTPLibClientCertList HS_HTTPLibClientCertListNew ( UInt16 refnum )

Parameters:
refnum,: IN:

Return values:
Err error code.

void HS_HTTPLibClientCertListSetValid | ( | UInt16 | refnum,
 |  | HS_HTTPLibClientCertList | in_list,
 |  | Int32 | in_index,
 |  | Boolean | in_valid
 | ) |  |

TBD.

Parameters:
refnum,: IN:
in_list,: IN:
in_index,: IN:
in_valid,: IN:
Return values:
Nothing

void HS_HTTPLibClientCertSelect | ( | UInt16 | refnum,
 |  | HS_HTTPLibSSL | in_ssl,
 |  | Int32 | in_index
 | ) |  |

This function sets the selected certification. For now, there is no corresponding function in SSL library, the callback will not be called.

Parameters:
refnum,: IN: Library reference number.
in_ssl,: IN: -
in_index,: IN: -
Returns:
None.

Err HS_HTTPLibClose | ( | UInt16 | refnum,
 |  | UInt16 * | usecountP
 | ) |  |

This function decrements open count and finalizes the library’s common data at the last close.

Parameters:
refnum,: IN: Library reference number
usecountP,: OUT: Open count
Returns:
Error code.

void HS_HTTPLibCloseAllKeepAlive | ( | UInt16 | refnum,
 |  | HS_HTTPLibHandle | libH
 | ) |  |

This function closes the all idle keep alive sockets relating this application. Nonidle sockets are not closed by this function.

This call should be made at library finalization if keep-alive sockets are active.

Parameters:
refnum,: IN: Library reference number
libH,: IN: The handle of HTTP library instance
Returns:
None.

void HS_HTTPLibCookieMakeEmpty | ( | UInt16 | refnum,
 |  | HS_HTTPLibHandle | libH,
 |  | Int32 | in_flag
 | ) |  |

This function clears Cookies.

Parameters:
refnum,: IN: Library reference number.
libH,: IN: The handle of HTTP library instance.
in_flag,: IN: httpCookieClearAll clear all Cookies httpCookieClearSessionCookiesOnly clear session Cookies only
Returns:
None.

void HS_HTTPLibDataHandle_Delete | ( | UInt16 | refnum,
 |  | HS_HTTPLibDataHandle | in_handle
 | ) |  |

Parameters:
refnum,: IN:

Parameters:
in_handle,: IN:
Return values:
Err error code.

Int32 HS_HTTPLibDataHandle_Length | ( | UInt16 | refnum,
 |  | HS_HTTPLibDataHandle | in_handle
 | ) |  |

Parameters:
refnum,: IN:

Parameters:
in_handle,: IN:
Return values:
Err error code.

void* HS_HTTPLibDataHandle_Lock | ( | UInt16 | refnum,
 |  | HS_HTTPLibDataHandle | in_handle
 | ) |  |

Parameters:
refnum,: IN:

Parameters:
in_handle,: IN:
Return values:
Err error code.

void HS_HTTPLibDataHandle_Unlock | ( | UInt16 | refnum,
 |  | HS_HTTPLibDataHandle | in_handle
 | ) |  |

Parameters:
refnum,: IN:

Parameters:
in_handle,: IN:
Return values:
Err error code.

void HS_HTTPLibFinalize | ( | UInt16 | refnum,
 |  | HS_HTTPLibHandle | libH
 | ) |  |

This function finalizes the library instance.

This call should be made when the application is finished using the library.

Parameters:
refnum,: IN: Library reference number
libH,: IN: The handle of HTTP library instance
Returns:
None.

void HS_HTTPLibFindAuthCandidate | ( | UInt16 | refnum,
 |  | HS_HTTPLibHandle | libH,
 |  | Int32 | in_target,
 |  | Char * | in_url,
 |  | Int32 | in_url_len,
 |  | Char * | in_host,
 |  | Int32 | in_host_len,
 |  | Int32 | in_port,
 |  | Char * | in_realm,
 |  | Int32 | in_realm_len,
 |  | HS_HTTPLibString * | out_user,
 |  | HS_HTTPLibString * | out_pass,
 |  | Boolean * | out_keep_user,
 |  | Boolean * | out_keep_pass
 | ) |  |

Parameters:
refnum,: IN:

Parameters:
libH,: IN:
in_target,: IN:
*in_url,: IN:
in_url_len,: IN:
*in_host,: IN:
in_host_len,: IN:
in_port,: IN:
*in_realm,: IN:
in_realm_len,: IN:
*out_user,: IN:
*out_pass,: IN:
*out_keep_user,: IN:
*out_keep_pass,: IN:
libH,: IN:
Return values:
Err error code.

Boolean HS_HTTPLibFindAuthInfo | ( | UInt16 | refnum,
 |  | HS_HTTPLibHandle | libH,
 |  | Int32 | in_target,
 |  | Char * | in_url,
 |  | Int32 | in_url_len,
 |  | Char * | in_host,
 |  | Int32 | in_host_len,
 |  | Int32 | in_port,
 |  | HS_HTTPLibSplit * | in_realm,
 |  | HS_HTTPLibAuthInfo * | out_info
 | ) |  |

Parameters:
refnum,: IN:

Parameters:
libH,: IN:
in_target,: IN:
*in_url,: IN:
in_url_len,: IN:
*in_host,: IN:
in_host_len,: IN:
in_port,: IN:
*in_realm,: IN:
*out_info,: IN:
Return values:
Err error code.

void HS_HTTPLibFixedString_Delete | ( | UInt16 | refnum,
 |  | HS_HTTPLibFixedString | in_str
 | ) |  |

This function deletes the handle of type HS_HTTPLibFixedString.

Parameters:
refnum,: IN: Library reference number.
in_str,: IN: The handle.
Return values:
nothing

Int32 HS_HTTPLibFixedString_Length | ( | UInt16 | refnum,
 |  | HS_HTTPLibFixedString | in_str
 | ) |  |

This function returns the length of the handle (byte).

Parameters:
refnum,: IN: Library reference number.
in_str,: IN: The handle.
Return values:
Int32

void* HS_HTTPLibFixedString_Lock | ( | UInt16 | refnum,
 |  | HS_HTTPLibFixedString | in_str
 | ) |  |

This function locks the handle of type HS_HTTPLibFixedString.

Parameters:
refnum,: IN: Library reference number.
in_str,: IN: The handle.
Return values:
void *

void HS_HTTPLibFixedString_Unlock | ( | UInt16 | refnum,
 |  | HS_HTTPLibFixedString | in_str
 | ) |  |

This function unlocks the handle of type HS_HTTPLibFixedString.

Parameters:
refnum,: IN: Library reference number.
in_str,: IN: The handle.
Return values:
nothing

HS_HTTPLibFixedString HS_HTTPLibFixedStringNew | ( | UInt16 | refnum,
 |  | Char * | in_str,
 |  | Int32 | in_len
 | ) |  |

This function creates a new handle of type HS_HTTPLibFixedString.

Parameters:
refnum,: IN: Library reference number.
*in_str,: IN: The pointer to the string.
in_len,: IN: The length of in_str.
Return values:
HS_HTTPLibFixedString

Boolean HS_HTTPLibHeaderSplitByX | ( | UInt16 | refnum,
 |  | HS_HTTPLibSplit * | inout_ss,
 |  | Int32 | in_id,
 |  | Char * | in_cs
 | ) |  |

Parameters:
refnum,: IN:

Parameters:
*inout_ss,: IN:
in_id,: IN:
*in_cs,: IN:
Return values:
Err error code.

HS_HTTPLibHandle HS_HTTPLibInitialize | ( | UInt16 | refnum,
 |  | HS_HTTPLibAppInfo * | appInfoP,
 |  | HS_HTTPLibNetLibInfo * | netLibInfoP,
 |  | HS_HTTPLibPeer * | peerP
 | ) |  |

This function initializes the library instance and sets application dependent information in the global variables. The return value is the handle of library instance. If an error occurs during the initialization, the return value is NULL.

This call should be made after the application has called HS_HTTPLibOpen and assigned the HS_HTTPLibAppInfo, HS_HTTPLibNetLibInfo, and HS_HTTPLibPeer global variables with the application’s parameters. A reciprocal call to HS_HTTPLibFinalize should be made when the application is finished using the library.

Parameters:
refnum,: IN: Library reference number
*appInfoP,: IN:
*netLibInfoP,: IN:
*peerP,: IN:
Return values:
HS_HTTPLibHandle non NULL if successful. NULL if failed

Boolean HS_HTTPLibIsHTTP11OverProxy | ( | UInt16 | refnum,
 |  | HS_HTTPLibHandle | libH
 | ) |  |

This function returns whether this application permits HTTP/1.1 over proxy.

Parameters:
refnum,: IN: Library reference number
libH,: IN: The handle of HTTP library instance
Returns:
True if this application permits HTTP/1.1 over proxy. False if this application does not permit HTTP/1.1 over proxy.

Boolean HS_HTTPLibIsSendCookie | ( | UInt16 | refnum,
 |  | HS_HTTPLibHandle | libH
 | ) |  |

This function returns whether this application sends Cookie.

Parameters:
refnum,: IN: Library reference number
libH,: IN: The handle of HTTP library instance
Returns:
True if this application sends Cookie. False if this application does not send Cookie.

Boolean HS_HTTPLibIsSendReferer | ( | UInt16 | refnum,
 |  | HS_HTTPLibHandle | libH
 | ) |  |

Parameters:
refnum,: IN:

Parameters:
libH,: IN:
Return values:
Err error code.

Boolean HS_HTTPLibIsUseProxy | ( | UInt16 | refnum,
 |  | HS_HTTPLibHandle | libH
 | ) |  |

This function returns whether this application uses proxy.

Parameters:
refnum,: IN: Library reference number
libH,: IN: The handle of HTTP library instance
Returns:
True if this application uses proxy. False if this application does not uses proxy.

Boolean HS_HTTPLibLoadCookiesEntries | ( | UInt16 | refnum,
 |  | HS_HTTPLibHandle | libH,
 |  | Char * | in_s,
 |  | Int32 | in_slen
 | ) |  |

Parameters:
refnum,: IN:

Parameters:
libH,: IN:
*in_s,: IN:
in_slen,: IN:
Return values:
Err error code.

Boolean HS_HTTPLibMakeAuthInfo | ( | UInt16 | refnum,
 |  | HS_HTTPLibHandle | libH,
 |  | Int32 | in_target,
 |  | Char * | in_url,
 |  | Int32 | in_url_len,
 |  | Char * | in_host,
 |  | Int32 | in_host_len,
 |  | Int32 | in_port,
 |  | HS_HTTPLibSplit * | in_realm,
 |  | HS_HTTPLibAuthInfo * | out_info
 | ) |  |

This function returns the authentication information to the out_info. Before calling this API, the application should intialize HS_HTTPLibAuthInfo by HS_HTTPLibAuthInfoTidy(out_info, true).

After using the authentication information, the application should finalize HS_HTTPLibAuthInfoTidy by HS_HTTPLibAuthInfoTidy(out_info, false).

Parameters:
refnum,: IN: Library reference number.
libH,: IN: The handle of HTTP library instance.
in_target,: IN: The authentication target. httpAuthTargetPage Authentication Information for Page httpAuthTargetProxy Authentication Information for Proxy
*in_url,: IN: The pointer to the URL (httpAuthTargetPage only).
in_url_len,: IN: The length of in_url.
*in_host,: IN: The pointer to the proxy host name (httpAuthTargetProxy only).
in_host_len,: IN: The length of in_host.
in_port,: IN: The port of proxy (httpAuthTargetProxy only).
*in_realm,: IN: The realm.
*out_info,: OUT: The pointer to the authentication information.
Returns:
True if setting successful. False if failed (no information in cache or memory shortage).

HS_HTTPLibCertList HS_HTTPLibMakeCertList | ( | UInt16 | refnum,
 |  | HS_HTTPLibStream | stream
 | ) |  |

This function returns the Server certification used for SSL. The responsibility to delete the return handle is the application. To delete the return value, the application should use HS_HTTPLibCertListDelete.

Parameters:
refnum,: IN: Library reference number.
stream,: IN: The handle of stream instance.
Returns:
The handle of SSL server certification chain. NULL if no server certification or memory shortage.

HS_HTTPLibString HS_HTTPLibMakeCookiesString | ( | UInt16 | refnum,
 |  | HS_HTTPLibHandle | libH,
 |  | Char * | in_url,
 |  | Int32 | in_urllen,
 |  | Boolean | in_secure,
 |  | Int32 * | out_len
 | ) |  |

Parameters:
refnum,: IN:

Parameters:
libH,: IN:
*in_url,: IN:
in_urllen,: IN:
in_secure,: IN:
*out_len,: IN:
Return values:
Err error code.

void HS_HTTPLibMakeProxy | ( | UInt16 | refnum,
 |  | HS_HTTPLibHandle | libH,
 |  | HS_HTTPLibFixedString * | out_proxy_host,
 |  | Int32 * | out_proxy_http_port,
 |  | Int32 * | out_proxy_https_port,
 |  | HS_HTTPLibString * | out_no_proxy_hosts
 | ) |  |

Set the proxy information of this application to out_proxy_host, out_proxy_http_port, out_proxy_https_port, out_no_proxy_hosts. If out_proxy_host is NULL, the value of *out_proxy_http_port, *out_proxy_https_port, *out_no_proxy_hosts are not set, otherwise the values of *out_proxy_http_port, *out_proxy_https are set. If out_no_proxy_hosts is NULL, *out_no_proxy_hosts is not set. The format of out_no_proxy_hosts is the list separated by “,”. The responsibility of delete *out_proxy_host, *out_no_proxy_hosts is caller.

Parameters:
refnum,: IN: Library reference number
libH,: IN: The handle of HTTP library instance
*out_proxy_host,: OUT: The pointer to handle of proxy host string
*out_proxy_http_port,: OUT: The pointer to HTTP port number
*out_proxy_https_port,: OUT: The pointer to HTTPS port number
*out_no_proxy_hosts,: OUT: The pointer to handle of the list string of hosts connect without using proxy server.
Returns:
None.

Err HS_HTTPLibOpen ( UInt16 refnum )

This function opens the HTTP library and increments the open count. This function will create and initialize the library’s common data at first opening.

Parameters:
refnum,: IN: Library reference number
Returns:
Error code.

UInt16 HS_HTTPLibOpenCount ( UInt16 refnum )

This function returns the open count of this library.

Parameters:
refnum,: IN: Library reference number
Returns:
Open count.

void HS_HTTPLibRegisterSSLClass | ( | UInt16 | refnum,
 |  | HS_HTTPLibHandle | libH,
 |  | HS_HTTPLibSSLClassPtr | sslClassP
 | ) |  |

Parameters:
refnum,: IN:

Parameters:
libH,: IN:
sslClassP,: IN:
Return values:
Err error code.

HS_HTTPLibString HS_HTTPLibSaveCookiesEntries | ( | UInt16 | refnum,
 |  | HS_HTTPLibHandle | libH,
 |  | Int32 * | out_len
 | ) |  |

Parameters:
refnum,: IN:

Parameters:
libH,: IN:
*out_len,: IN:
Return values:
Err error code.

void HS_HTTPLibServerCertConfirm | ( | UInt16 | refnum,
 |  | HS_HTTPLibSSL | in_ssl,
 |  | Int32 | in_verify_result,
 |  | Boolean | in_confirm
 | ) |  |

This function sets the result of confirmation. This function should be called in the callback function.

Parameters:
refnum,: IN: Library reference number.
in_ssl,: IN: -
in_verify_result,: IN: -
in_confirm,: IN: -
Returns:
None.

void HS_HTTPLibSetConnectTimeOut | ( | UInt16 | refnum,
 |  | HS_HTTPLibHandle | libH,
 |  | Int32 | in_msec
 | ) |  |

This function sets the limit of Connection timeout. If in_msec is -1, no timeout is set. The condition of timeout is in_msec has passed from TCP connect without HTTP connection established.

With this function the different connection timeouts can be set at library initialization.

Parameters:
refnum,: IN: Library reference number
libH,: IN: The handle of HTTP library instance
in_msec,: IN: Time Limit (msec)
Return values:
Nothing

Int32 HS_HTTPLibSetCookie | ( | UInt16 | refnum,
 |  | HS_HTTPLibHandle | libH,
 |  | HS_HTTPLibURLString | in_url,
 |  | Char * | in_header,
 |  | Int32 | in_header_len
 | ) |  |

This function sets the Cookie abiding with the confirmation mode set by HS_HTTPLibSetCookieMode. The application should not use this API in callback function. The API HS_HTTPLibSetCookieX is designed for use in callback.

Parameters:
refnum,: IN: Library reference number.
libH,: IN: The handle of HTTP library instance.
in_url,: IN: The handle of URL.
*in_header,: IN: The pointer to the header string.
in_header_len,: IN: The length of in_header.
Returns:
httpErrorOK Cookie is set. httpErrorNoMem memory shortage httpErrorInval failed by other reason

void HS_HTTPLibSetCookieMax | ( | UInt16 | refnum,
 |  | HS_HTTPLibHandle | libH,
 |  | Int32 | in_max_total_cookies,
 |  | Int32 | in_max_cookies_per_domain,
 |  | Int32 | in_max_len_per_cookie
 | ) |  |

This function sets the max size of Cookie entries.

Parameters:
refnum,: IN: Library reference number.
libH,: IN: The handle of HTTP library instance.
in_max_total_cookies,: IN: The size of max Cookie entries.
in_max_cookies_per_domain,: IN: The size of Cookie entries per one domain.
in_max_len_per_cookie,: IN: The max size of one Cookie.
Returns:
None.

void HS_HTTPLibSetCookieMode | ( | UInt16 | refnum,
 |  | HS_HTTPLibHandle | libH,
 |  | Int32 | in_mode,
 |  | HS_HTTPLibCookieConfirmProc | in_cb,
 |  | HS_HTTPLibOpaque | in_opaque
 | ) |  |

This function sets the Cookie mode.

Parameters:
refnum,: IN: Library reference number.
libH,: IN: The handle of HTTP library instance.
in_mode,: IN: The mode of receiving Cookie. httpCookieNotifyBeforeSet Confirm before Cookie set httpCookieAlwaysSet Cookie is always set httpCookieNeverSet Cookie is not set
in_cb,: IN: The confirm callback function.
in_opaque,:,: IN: The opaque which is given to the callback function.
Returns:
None.

Int32 HS_HTTPLibSetCookieX | ( | UInt16 | refnum,
 |  | HS_HTTPLibHandle | libH,
 |  | HS_HTTPLibURLString | in_url,
 |  | Char * | in_header,
 |  | Int32 | in_header_len
 | ) |  |

This function sets the Cookie. This function is designed for callback confirm function.

Parameters:
refnum,: IN: Library reference number.
libH,: IN: The handle of HTTP library instance.
in_url,: IN: The handle of URL.
*in_header,: IN: The pointer to the header string.
in_header_len,: IN: The length of in_header.
Returns:
httpErrorOK Cookie is set. httpErrorNoMem memory shortage httpErrorInval failed by other reason

Boolean HS_HTTPLibSetDefaultHeaders | ( | UInt16 | refnum,
 |  | HS_HTTPLibHandle | libH,
 |  | Char * | in_default_headers,
 |  | Int32 | in_default_headers_len
 | ) |  |

This function sets the default header, i.e. this string is added to the Request-header of the Request created at HS_HTTPLibStreamCreateRequest. If in_default_headers is NULL, the setting is cleared.

This call allows the application to set the application defined standard headers without having the populate each request with HS_HTTPLibStreamAddHeader.

Parameters:
refnum,: IN: Library reference number
libH,: IN: The handle of HTTP library instance
*in_default_headers,: IN: The string of default header
in_default_headers_len,: IN: The length of in_default_headers
Returns:
True if setting is successful. False if failed. (The main reason is memory shortage.)

void HS_HTTPLibSetDNSMaxRetry | ( | UInt16 | refnum,
 |  | HS_HTTPLibHandle | libH,
 |  | Int32 | in_retry
 | ) |  |

Parameters:
refnum,: IN:

Parameters:
libH,: IN:
in_retry,: IN:
Return values:
Err error code.

void HS_HTTPLibSetDNSRetryInterval | ( | UInt16 | refnum,
 |  | HS_HTTPLibHandle | libH,
 |  | Int32 | in_interval
 | ) |  |

Parameters:
refnum,: IN:

Parameters:
libH,: IN:
in_interval,: IN:
Return values:
Err error code.

void HS_HTTPLibSetHTTP11OverProxy | ( | UInt16 | refnum,
 |  | HS_HTTPLibHandle | libH,
 |  | Boolean | in_bool
 | ) |  |

This function sets whether this application permits HTTP1.1 over proxy server. If false is set, the application use HTTP/1.0.

Parameters:
refnum,: IN: Library reference number
libH,: IN: The handle of HTTP library instance
in_bool,: IN: True if permitting HTTP/1.1 over proxy server False if not permitting HTTP/1.1 over proxy server
Returns:
None.

void HS_HTTPLibSetHTTPPort | ( | UInt16 | refnum,
 |  | HS_HTTPLibHandle | libH,
 |  | Int32 | in_port
 | ) |  |

This function sets the default HTTP port number. If there is no indication in URL, this port number is used for TCP connection.

Parameters:
refnum,: IN: Library reference number
libH,: IN: The handle of HTTP library instance
in_port,: IN: The HTTP port number
Returns:
None.

void HS_HTTPLibSetHTTPSPort | ( | UInt16 | refnum,
 |  | HS_HTTPLibHandle | libH,
 |  | Int32 | in_port
 | ) |  |

This function sets the default HTTPS port number. If there is no indication in https URL, this port number is used for TCP connection.

Parameters:
refnum,: IN: Library reference number
libH,: IN: The handle of HTTP library instance
in_port,: IN: The HTTPS port number
Returns:
None.

void HS_HTTPLibSetMaxKeepAliveTimeout | ( | UInt16 | refnum,
 |  | HS_HTTPLibHandle | libH,
 |  | Int32 | in_msec
 | ) |  |

Parameters:
refnum,: IN:

Parameters:
libH,: IN:
in_msec,:,: IN:
Return values:
Err error code.

void HS_HTTPLibSetMaxRequestBody | ( | UInt16 | refnum,
 |  | HS_HTTPLibHandle | libH,
 |  | Int32 | in_size
 | ) |  |

This function sets the maximal size of Request-Body. If in_size is -1, the maximal size is unlimited.

Parameters:
refnum,: IN: Library reference number
libH,: IN: The handle of HTTP library instance
in_size,: IN: The maximal size (byte)
Returns:
None.

void HS_HTTPLibSetMaxRequestHeader | ( | UInt16 | refnum,
 |  | HS_HTTPLibHandle | libH,
 |  | Int32 | in_size
 | ) |  |

This function sets the maximal size of Request-Line. If in_size is -1, the maximal size is unlimited. Note that this function does not set the maximal size of Request- Header. See RFC2616 for the definitions of Request-Line and Request-Header.

Parameters:
refnum,: IN: Library reference number
libH,: IN: The handle of HTTP library instance
in_size,: IN: The maximal size (byte)
Returns:
None.

void HS_HTTPLibSetNetLibProc | ( | UInt16 | refnum,
 |  | HS_HTTPLibHandle | libH,
 |  | UInt16 | netLibRefnum,
 |  | HS_HTTPLibNetLibOpenProc | in_open,
 |  | HS_HTTPLibNetLibCloseProc | in_close,
 |  | HS_HTTPLibNetLibOnlineProc | in_online,
 |  | HS_HTTPLibNetLibOfflineProc | in_offline
 | ) |  |

This function sets the callback functions concerning NetLib. But for now, there is no call to callback functions from Peer layer.

Parameters:
refnum,: IN: Library reference number.
libH,: IN:
netLibRefnum,: IN:
in_open,: IN:
in_close,: IN:
in_online,: IN:
in_offline,: IN:
Returns:
None.

Boolean HS_HTTPLibSetProxy | ( | UInt16 | refnum,
 |  | HS_HTTPLibHandle | libH,
 |  | Char * | in_proxy_host,
 |  | Int32 | in_proxy_host_len,
 |  | Int32 | in_proxy_http_port,
 |  | Int32 | in_proxy_https_port,
 |  | Char * | in_no_proxy_hosts,
 |  | Int32 | in_no_proxy_hosts_len
 | ) |  |

This function sets the proxy server setting for this application. If in_proxy_host is NULL, in_proxy_host, in_proxy_http_port, in_proxy_https_port are not set. If in_no_proxy_hosts is NULL, in_no_proxy_hosts is not set. The format of in_no_proxy_hosts is comma (“,”) separated list.

This call can be grouped with other proxy setting calls if the application is making the same type of request for all the requests.

Parameters:
refnum,: IN: Library reference number
libH,: IN: The handle of HTTP library instance
*in_proxy_host,: IN: The proxy host name
in_proxy_host_len,: IN: The length of in_proxy_host string
in_proxy_http_port,: IN: The HTTP port of proxy server
in_proxy_https_port,: IN: The HTTPS port of proxy server
*in_no_proxy_hosts,: IN: The list of hosts not using proxy
in_no_proxy_hosts_len,: IN: The length of in_no_proxy_hosts
Returns:
True if setting is succeed. False if failed.(the main reason is memory shortage)

void HS_HTTPLibSetReqTimeOut | ( | UInt16 | refnum,
 |  | HS_HTTPLibHandle | libH,
 |  | Int32 | in_msec
 | ) |  |

This function sets the limit of sending Request timeout. If in_msec is -1, no timeout is set. The condition of timeout is in_msec has passed from the start of Request sending without sending done.

Parameters:
refnum,: IN: Library reference number
libH,: IN: The handle of HTTP library instance
in_msec,: IN: Time Limit (msec)
Returns:
None.

void HS_HTTPLibSetRspTimeOut | ( | UInt16 | refnum,
 |  | HS_HTTPLibHandle | libH,
 |  | Int32 | in_msec
 | ) |  |

This function sets the limit of receiving Response timeout. If in_msec is -1, no timeout is set. The condition of timeout is in_msec has passed from the end of sending request without receiving Response. Or in_msec has passed from the last receiving a part of Response without receiving any part of Response.

Parameters:
refnum,: IN: Library reference number
libH,: IN: The handle of HTTP library instance
in_msec,: IN: Time Limit (msec)
Return values:
Nothing

void HS_HTTPLibSetSendCookie | ( | UInt16 | refnum,
 |  | HS_HTTPLibHandle | libH,
 |  | Boolean | in_bool
 | ) |  |

This function sets whether this application sends Cookie.

Parameters:
refnum,: IN: Library reference number
libH,: IN: The handle of HTTP library instance
in_bool,: IN: True if sending Cookie False if not sending Cookie
Returns:
None.

void HS_HTTPLibSetSendProxyKeepAlive | ( | UInt16 | refnum,
 |  | HS_HTTPLibHandle | libH,
 |  | Boolean | in_bool
 | ) |  |

Parameters:
refnum,: IN:

Parameters:
libH,: IN:
in_bool,: IN:
Return values:
Err error code.

void HS_HTTPLibSetSendReferer | ( | UInt16 | refnum,
 |  | HS_HTTPLibHandle | libH,
 |  | Boolean | in_bool
 | ) |  |

Parameters:
refnum,: IN:

Parameters:
libH,: IN:
in_bool,: IN:
Return values:
Err error code.

void HS_HTTPLibSetSSLClientCertSelectProc | ( | UInt16 | refnum,
 |  | HS_HTTPLibHandle | libH,
 |  | HS_HTTPLibClientCertSelectProc | in_cb,
 |  | HS_HTTPLibOpaque | in_opaque
 | ) |  |

This function sets the client certification select callback function.For now, there is no corresponding function in SSL library, the callback will not be called.

Parameters:
refnum,: IN: Library reference number.
libH,: IN: -
in_cb,: IN: -
in_opaque,: IN: -
Returns:
None.

void HS_HTTPLibSetSSLServerCertConfirmProc | ( | UInt16 | refnum,
 |  | HS_HTTPLibHandle | libH,
 |  | HS_HTTPLibServerCertConfirmProc | in_cb,
 |  | HS_HTTPLibOpaque | in_opaque
 | ) |  |

This function sets the server certificate callback function for this application.

Parameters:
refnum,: IN: Library reference number.
libH,: IN: -
in_cb,: IN: -
in_opaque,: IN: -
Returns:
Nothing

void HS_HTTPLibSetSSLVersionFlag | ( | UInt16 | refnum,
 |  | HS_HTTPLibHandle | libH,
 |  | Int32 | in_flag,
 |  | Boolean | in_on
 | ) |  |

Set the SSL version.

Parameters:
refnum,: IN: Library reference number.
libH,: IN: The handle of HTTP library instance.
in_flag,: IN: -
in_on,: IN: -
Returns:
None.

void HS_HTTPLibSetTunnelingCallback | ( | UInt16 | refnum,
 |  | HS_HTTPLibHandle | libH,
 |  | HS_HTTPLibTunnelingCallbackProc | in_cb,
 |  | void * | in_aux
 | ) |  |

Parameters:
refnum,: IN:

Parameters:
libH,: IN:
in_cb,: IN:
*in_aux,: IN:
Return values:
Err error code.

void HS_HTTPLibSetUseProxy | ( | UInt16 | refnum,
 |  | HS_HTTPLibHandle | libH,
 |  | Boolean | in_bool
 | ) |  |

This function sets whether this application uses proxy server.

Parameters:
refnum,: IN: Library reference number
libH,: IN: The handle of HTTP library instance
in_bool,: IN: True if using proxy server. False if not using proxy server.
Returns:
None.

Boolean HS_HTTPLibSetUserAgent | ( | UInt16 | refnum,
 |  | HS_HTTPLibHandle | libH,
 |  | Char * | in_useragent,
 |  | Int32 | in_useragent_len
 | ) |  |

This function sets the UserAgent string for the application. If in_useragent is NULL, setting is cleared.

This call allows the application to set the user agent identfication in the requests.

Parameters:
refnum,: IN: Library reference number
libH,: IN: The handle of HTTP library instance
*in_useragent,: IN: The string of User Agent
in_useragent_len,: IN: The length of in_useragent
Returns:
True if setting is successful. False if failed.(The main reason is memory shortage.)

Boolean HS_HTTPLibSetUseragentSelectionRule | ( | UInt16 | refnum,
 |  | HS_HTTPLibHandle | libH,
 |  | HttpUASelectionRule * | rules,
 |  | Int32 | len
 | ) |  |

Parameters:
refnum,: IN:

Parameters:
libH,: IN:
*rules,: IN:
len,: IN:
Return values:
Err error code.

Boolean HS_HTTPLibSetUserPass | ( | UInt16 | refnum,
 |  | HS_HTTPLibHandle | libH,
 |  | Int32 | in_type,
 |  | Int32 | in_target,
 |  | HS_HTTPLibSplit * | in_challenge,
 |  | HS_HTTPLibSplit * | in_realm,
 |  | Char * | in_user,
 |  | Int32 | in_user_len,
 |  | Char * | in_pass,
 |  | Int32 | in_pass_len,
 |  | Char * | in_url,
 |  | Int32 | in_url_len,
 |  | Char * | in_host,
 |  | Int32 | in_host_len,
 |  | Int32 | in_port
 | ) |  |

This function sets the authentication information.

Parameters:
refnum,: IN: Library reference number.
libH,: IN: The handle of HTTP library instance.
in_type,: IN: The authentication type. httpAuthTypeBasic Basic authentication httpAuthTypeDigest Digest Authentication
in_target,: IN: The authentication target. httpAuthTargetPage Authentication Information for Page httpAuthTargetProxy Authentication Information for Proxy
*in_challenge,: IN: The challenge.
*in_realm,: IN: The realm.
*in_user,: IN: The pointer to the User ID.
in_user_len,: IN: The length of in_user.
*in_pass,: IN: The pointer to the Password.
in_pass_len,: IN: The length of in_pass.
*in_url,: IN: The pointer to the URL (httpAuthTargetPage only).
in_url_len,: IN: The length of in_url.
*in_host,: IN: The pointer to the proxy host name (httpAuthTargetProxy only).
in_host_len,: IN: The length of in_host.
in_port,: IN: The port of proxy (httpAuthTargetProxy only).
Returns:
True if setting successful. False if failed (memory shortage).

Boolean HS_HTTPLibSetUserPassX | ( | UInt16 | refnum,
 |  | HS_HTTPLibHandle | libH,
 |  | Int32 | in_type,
 |  | Int32 | in_target,
 |  | HS_HTTPLibSplit * | in_challenge,
 |  | HS_HTTPLibSplit * | in_realm,
 |  | Char * | in_user,
 |  | Int32 | in_user_len,
 |  | Char * | in_pass,
 |  | Int32 | in_pass_len,
 |  | Char * | in_url,
 |  | Int32 | in_url_len,
 |  | Char * | in_host,
 |  | Int32 | in_host_len,
 |  | Int32 | in_port,
 |  | Boolean | in_keep_user,
 |  | Boolean | in_keep_pass
 | ) |  |

Parameters:
refnum,: IN:

Parameters:
libH,: IN:
in_type,: IN:
in_target,: IN:
*in_challenge,: IN:
*in_realm,: IN:
*in_user,: IN:
in_user_len,: IN:
*in_pass,: IN:
in_pass_len,: IN:
*in_url,: IN:
in_url_len,: IN:
*in_host,: IN:
in_host_len,: IN:
in_port,: IN:
in_keep_user,: IN:
in_keep_pass,: IN:
Return values:
Err error code.

void HS_HTTPLibSetWakeUpCallback | ( | UInt16 | refnum,
 |  | HS_HTTPLibHandle | libH,
 |  | HS_HTTPLibWakeUpCallbackProc | in_proc,
 |  | HS_HTTPLibOpaque | in_opaque
 | ) |  |

Parameters:
refnum,: IN:

Parameters:
libH,: IN:
in_proc,: IN:
in_opaque,: IN:
Return values:
Err error code.

Err HS_HTTPLibSleep ( UInt16 refnum )

Standard library sleep function.

Parameters:
refnum,: IN: Library reference number
Returns:
Error code.

HS_HTTPLibSSLClassPtr HS_HTTPLibSSLClass | ( | UInt16 | refnum,
 |  | HS_HTTPLibHandle | libH
 | ) |  |

Parameters:
refnum,: IN:

Parameters:
libH,: IN:
Return values:
Err error code.

void HS_HTTPLibSSLCloseCertDB | ( | UInt16 | refnum,
 |  | HS_HTTPLibHandle | libH
 | ) |  |

TBD.

Parameters:
refnum,: IN: Library reference number.
libH,: IN: The handle of HTTP library instance.
Returns:
None.

Int32 HS_HTTPLibSSLOpenCertDB | ( | UInt16 | refnum,
 |  | HS_HTTPLibHandle | libH,
 |  | HS_HTTPLibCertList * | out_list
 | ) |  |

TBD.

Parameters:
refnum,: IN: Library reference number.
libH,: IN: The handle of HTTP library instance.
*out_list,: OUT: -
Return values:
Int32

Int32 HS_HTTPLibSSLTimeout | ( | UInt16 | refnum,
 |  | HS_HTTPLibHandle | libH
 | ) |  |

Set the timeout period for SSL use.

Parameters:
refnum,: IN: Library reference number.
libH,: IN: The handle of HTTP library instance.
Returns:
Timeout.

Boolean HS_HTTPLibStreamAddHeader | ( | UInt16 | refnum,
 |  | HS_HTTPLibStream | stream,
 |  | Int32 | in_type,
 |  | Char * | in_str,
 |  | Int32 | in_len
 | ) |  |

This function sets the value of corresponding header. If there is already the same kind of header line, old one is deleted.

Parameters:
refnum,: IN: Library reference number.
stream,: IN: The handle of stream instance.
in_type,: IN: The type of header (See httpHeaderIDEnum).
*in_str,: IN: The pointer to the header value string.
in_len,: IN: The length of in_str.
Returns:
True if successful False failed (memory shortage)

Boolean HS_HTTPLibStreamAddHeaderLine | ( | UInt16 | refnum,
 |  | HS_HTTPLibStream | stream,
 |  | Char * | in_str,
 |  | Int32 | in_len
 | ) |  |

This function adds the line to the Request header. If there is already the same kind of header line, old one is deleted.

Parameters:
refnum,: IN: Library reference number.
stream,: IN: The handle of stream instance.
*in_str,: IN: The pointer to the header strong to add.
in_len,: IN: The length of in_str.
Returns:
True if successful. False failed (memory shortage)

void HS_HTTPLibStreamClose | ( | UInt16 | refnum,
 |  | HS_HTTPLibStream | stream
 | ) |  |

This function closes the HTTP stream. If the TCP/SSL socket is in keep-alive, it is not closed.

Parameters:
refnum,: IN: Library reference number
stream,: IN: The handle of stream instance.
Returns:
None.

Int32 HS_HTTPLibStreamCreateRequest | ( | UInt16 | refnum,
 |  | HS_HTTPLibStream | stream,
 |  | Int32 | in_method,
 |  | Char * | in_url,
 |  | UInt32 | in_url_len,
 |  | Char * | in_header,
 |  | UInt32 | in_header_len,
 |  | Char * | in_referer,
 |  | UInt32 | in_referer_len,
 |  | Int32 | in_version,
 |  | Boolean | in_no_cache,
 |  | Boolean | in_pipeline,
 |  | Int32 | in_ssl_flag
 | ) |  |

This function creates a request. If using proxy and SSL connection, CONNECT request message is made. If there are cached authenticate informations, add authenticate header. Add default headers and in_header to Request-Header.

Parameters:
refnum,: IN: Library reference number.
stream,: IN: The handle of stream instance.
in_method,: IN: The HTTP method httpMethodGET GET httpMethodPOST POST
*in_url,: IN: The URL string.
in_url_len,: IN: The length of in_url.
*in_header,: IN: The header string to add the Request-Header. Each line is terminated by <CR><LF>.
in_header_len,: IN: The length of in_header.
*in_referer,: IN: The referer string.
in_referer_len,: IN: The length of in_referer.
in_version,: IN: The version httpVersion_0_9 HTTP/0.9 httpVersion_1_0 HTTP/1.0 httpVersion_1_1 HTTP/1.1
in_no_cache,: IN: True if no-cache is added to the header False if no-cache is not added to the header
in_pipeline,: IN: True if doing pipeline False if not doing pipeline
in_ssl_flag,: IN: The flag sent to SSL instance. httpSSLFlagConnV2 connect by v2 protocol httpSSLFlagConnV3 connect by v3 protocol httpSSLFlagConnTLS connect by TLS(v3.1) protocol httpSSLFlagConnV2V3 autoselect within v2,v3 httpSSLFlagConnV2TLS autoselect within v2,tls httpSSLFlagConnV3TLS autoselect within v3,tls httpSSLFlagConnV2V3TLS autoselect within v2,v3,tls
Returns:
httpErrorOK succeed httpErrorNoMem memory shortage httpErrorReqHeaderSizeOver if Request header size is over the maximal setting. If the Request-Line size is set to unlimited, httpErrorReqHeaderSizeOver is not returned.

Int32 HS_HTTPLibStreamCreateRequestWithChunkEncoding | ( | UInt16 | refnum,
 |  | HS_HTTPLibStream | stream,
 |  | Int32 | in_method,
 |  | Char * | in_url,
 |  | UInt32 | in_url_len,
 |  | Char * | in_header,
 |  | UInt32 | in_header_len,
 |  | Char * | in_referer,
 |  | UInt32 | in_referer_len,
 |  | Int32 | in_version,
 |  | Boolean | in_no_cache,
 |  | Boolean | in_pipeline,
 |  | Int32 | in_ssl_flag
 | ) |  |

This function creates request for chunk-encoding post. If using proxy and SSL connection, CONNECT request message is made. If there are cached authenticate informations, add authenticate header. Add default headers and in_header to Request-Header. Do not use this API unless you want to create chunk-encoding request. Transfer- Encoding: chunked is added to the request header.

Parameters:
refnum,: IN: Library reference number.
stream,: IN: The handle of stream instance.
in_method,: IN: The HTTP method httpMethodGET GET httpMethodPOST POST
*in_url,: IN: The URL string.
in_url_len,: IN: The length of in_url.
*in_header,: IN: The header string to add the Request-Header. Each line is terminated by <CR><LF>.
in_header_len,: IN: The length of in_header.
*in_referer,: IN: The referer string.
in_referer_len,: IN: The length of in_referer.
in_version,: IN: The version httpVersion_0_9 HTTP/0.9 httpVersion_1_0 HTTP/1.0 httpVersion_1_1 HTTP/1.1
in_no_cache,: IN: True if no-cache is added to the header False if no-cache is not added to the header
in_pipeline,: IN: True if doing pipeline False if not doing pipeline
in_ssl_flag,: IN: The flag sent to SSL instance. httpSSLFlagConnV2 connect by v2 protocol httpSSLFlagConnV3 connect by v3 protocol httpSSLFlagConnTLS connect by TLS(v3.1) protocol httpSSLFlagConnV2V3 autoselect within v2,v3 httpSSLFlagConnV2TLS autoselect within v2,tls httpSSLFlagConnV3TLS autoselect within v3,tls httpSSLFlagConnV2V3TLS autoselect within v2,v3,tls
Returns:
httpErrorOK succeed httpErrorNoMem memory shortage httpErrorReqHeaderSizeOver if the Request header size is over the maximal setting. If the Request-Line size is set to unlimited, httpErrorReqHeaderSizeOver is not returned.

void HS_HTTPLibStreamDelete | ( | UInt16 | refnum,
 |  | HS_HTTPLibStream | stream
 | ) |  |

This function deletes the stream instance. If this function is called without calling HS_HTTPLibStreamClose, this function closes the TCP/SSL socket by calling HS_HTTPLibStreamClose, however if the socket is in keep-alive, it is not closed.

Parameters:
refnum,: IN: Library reference number
stream,: IN: The handle of stream instance.
Returns:
None.

Int32 HS_HTTPLibStreamGetContentLength | ( | UInt16 | refnum,
 |  | HS_HTTPLibStream | stream
 | ) |  |

This function returns the content’s size (byte).

Parameters:
refnum,: IN: Library reference number.
stream,: IN: The handle of stream instance.
Returns:
The Content-Length (byte) -1 if not received

Int32 HS_HTTPLibStreamGetEntityLength | ( | UInt16 | refnum,
 |  | HS_HTTPLibStream | stream
 | ) |  |

This function returns the size of response body (byte).

Parameters:
refnum,: IN: Library reference number.
stream,: IN: The handle of stream instance.
Returns:
The size of response body (byte) -1 if not received

Int32 HS_HTTPLibStreamGetFlag | ( | UInt16 | refnum,
 |  | HS_HTTPLibStream | stream
 | ) |  |

Parameters:
refnum,: IN:

Parameters:
stream,: IN:
Return values:
Err error code.

Boolean HS_HTTPLibStreamGetHeader | ( | UInt16 | refnum,
 |  | HS_HTTPLibStream | stream,
 |  | Int32 | in_type,
 |  | Int32 * | out_off,
 |  | Int32 * | out_len
 | ) |  |

This function returns the offset and length of corresponding header value.

Parameters:
refnum,: IN: Library reference number.
stream,: IN: The handle of stream instance.
in_type,: IN: The type of header (See httpHeaderIDEnum).
*out_off,: IN: The offset to the header value.
*out_len,: IN: The length of corresponding header value.
Returns:
True if successful False there is no corresponding header

Boolean HS_HTTPLibStreamGetHeaderWithOffset | ( | UInt16 | refnum,
 |  | HS_HTTPLibStream | stream,
 |  | Int32 | in_type,
 |  | Int32 | in_ofs,
 |  | Int32 * | out_off,
 |  | Int32 * | out_len
 | ) |  |

Parameters:
refnum,: IN:

Parameters:
stream,: IN:
in_type IN:
in_ofs,: IN:
*out_off,: IN:
*out_len,: IN:
Return values:
Err error code.

void HS_HTTPLibStreamGetRequestSent | ( | UInt16 | refnum,
 |  | HS_HTTPLibStream | stream,
 |  | Int32 * | out_total,
 |  | Int32 * | out_sent
 | ) |  |

Parameters:
refnum,: IN:

Parameters:
stream,: IN:
*out_total,: IN:
*out_sent,: IN:
Return values:
Err error code.

HS_HTTPLibVHandle HS_HTTPLibStreamGetResponseHeader | ( | UInt16 | refnum,
 |  | HS_HTTPLibStream | stream
 | ) |  |

This function returns the handle of the response header. The responsibility to delete the handle is library, the application can not delete this return value. To lock/unlock the handle, the application should use the APIs,.

Parameters:
refnum,: IN: Library reference number.
stream,: IN: The handle of stream instance.
Returns:
non NULL the handle of header NULL if not received

Int32 HS_HTTPLibStreamGetResponseHeaderLength | ( | UInt16 | refnum,
 |  | HS_HTTPLibStream | stream
 | ) |  |

This function returns the size of the response header.

Parameters:
refnum,: IN: Library reference number.
stream,: IN: The handle of stream instance.
Returns:
header size (byte) -1 if not received

Int32 HS_HTTPLibStreamGetScheme | ( | UInt16 | refnum,
 |  | HS_HTTPLibStream | stream
 | ) |  |

This function returns the scheme given at the HS_HTTPLibStreamCreateRequest.

Parameters:
refnum,: IN: Library reference number.
stream,: IN: The handle of stream instance.
Returns:
httpSchemeHTTP HTTP httpSchemeHTTPS HTTPS

Int32 HS_HTTPLibStreamGetState | ( | UInt16 | refnum,
 |  | HS_HTTPLibStream | stream
 | ) |  |

This function returns the state of the stream. The state changes follow the below sequence (but skipping the states that are not relevant to the current request).

Parameters:
refnum,: IN: Library reference number.
stream,: IN: The handle of stream instance.
Returns:
httpStreamStateNew The instance is created httpStreamStateDormant The instance is dormant httpStreamStateReqCreated The request is created httpStreamStateReqResolve Name resolve begins httpStreamStateReqResolving Name resolving httpStreamStateReqOpen TCP/SSL open httpStreamStateReqConnect TCP connect begins httpStreamStateReqConnecting TCP connecting httpStreamStateReqProxyConnect Proxy Tunneling begins httpStreamStateReqProxyConnecting Proxy Tunneling httpStreamStateReqSSLHandShaking SSL HandShaking httpStreamStateReqSSLHandShaked SSL handShake done httpStreamStateReqSending Sending the request httpStreamStateReqSent Sending the request done httpStreamStateRspHeaderWaiting Waiting the response header httpStreamStateRspContinue Waiting response receiving done for Status-Code 100 httpStreamStateRspHeaderReceiving Receiving the response header httpStreamStateRspHeaderReceived Receiving the response header done httpStreamStateRspEntityReceiving Receiving the response body

Int32 HS_HTTPLibStreamGetStatusCode | ( | UInt16 | refnum,
 |  | HS_HTTPLibStream | stream
 | ) |  |

This function returns the Status Code.

Parameters:
refnum,: IN: Library reference number.
stream,: IN: The handle of stream instance.
Returns:
httpStatusCodeContinue 100 httpStatusCodeSwitchingProtocols 101 httpStatusCodeOK 200 httpStatusCodeCreated 201 httpStatusCodeAccepted 202 httpStatusCodeNonAuthoritativeInformation 203 httpStatusCodeNoContent 204 httpStatusCodeResetContent 205 httpStatusCodePartialContent 206 httpStatusCodeMultipleChoices 300 httpStatusCodeMovedPermanently 301 httpStatusCodeFound 302 httpStatusCodeSeeOther 303 httpStatusCodeNotModified 304 httpStatusCodeUseProxy 305 httpStatusCodeTemporaryRedirect 307 httpStatusCodeBadRequest 400

Boolean HS_HTTPLibStreamIsHeaderReceived | ( | UInt16 | refnum,
 |  | HS_HTTPLibStream | stream
 | ) |  |

This function returns whether the response header is completely received.

This function is typically called after HS_HTTPLibStreamReceiveResponse when receiving the response header.

Parameters:
refnum,: IN: Library reference number.
stream,: IN: The handle of stream instance.
Returns:
True if header is completely received. False if header is not received.

HS_HTTPLibStream HS_HTTPLibStreamNew | ( | UInt16 | refnum,
 |  | HS_HTTPLibHandle | libH
 | ) |  |

This function creates a new stream and returns the handle of stream instance. At this time, TCP/SSL socket is not opened.

Parameters:
refnum,: IN: Library reference number
libH,: IN: The handle of HTTP library instance
Returns:
non NULL if successful. NULL if failed (the main reason is memory shortage).

Int32 HS_HTTPLibStreamReceiveResponse | ( | UInt16 | refnum,
 |  | HS_HTTPLibStream | stream,
 |  | Char * | out_buf,
 |  | Int32 | in_len,
 |  | Int32 * | out_len,
 |  | Int32 * | out_sleep
 | ) |  |

This function receives response. It automatically retries at where pipeline stalled if pipeline is enable.

Because the data streaming could block and resume at where the pipeline was stalled, the application can call this function in a loop until the receiving is finished.

Parameters:
refnum,: IN: Library reference number.
stream,: IN: The handle of stream instance.
*out_buf,: OUT: The pointer to the receive buffer.
in_len,: IN: The size of the receive buffer (byte).
*out_len,: OUT: The received size (byte).
*out_sleep,: OUT: The time of the application can sleep (msec) This value is not used for application.
Returns:
httpErrorOK receiving done httpErrorWouldBlock application can call this function consecutively httpErrorIOSleep application can sleep httpErrorNoMem memory shortage httpErrorTCPRead cannot read TCP httpErrorTCPWrite cannot write TCP httpErrorSSLHandShake cannot SSL handshake httpErrorSSLRead cannot read SSL httpErrorSSLWrite cannot write SSL httpErrorReqTimedout request timeout httpErrorRspTimedout response timeout httpErrorAuthUnknown unknown authentication type httpErrorAuthNoHeader authentication request without authentication header httpErrorAuthFormat wrong format of authentication header httpErrorRedirectFormat wrong format of redirect header httpErrorRedirectCanceled redirect is canceled by user httpErrorRspHeaderSizeOver size over of response header httpErrorReqTooManyContinue it exceeds the limit times of Continue

void HS_HTTPLibStreamResumeTimer | ( | UInt16 | refnum,
 |  | HS_HTTPLibStream | stream
 | ) |  |

Parameters:
refnum,: IN:

Parameters:
stream,: IN:
Return values:
Err error code.

Int32 HS_HTTPLibStreamSendRequest | ( | UInt16 | refnum,
 |  | HS_HTTPLibStream | stream,
 |  | Int32 * | out_sleep
 | ) |  |

This function sends the request. This call opens and connects a TCP connection if not already established. It automatically retries at where pipeline stalled if pipeline is enable.

Because the data streaming could block and resume at where the pipeline was stalled, the application can call this function in a loop until the sending is finished.

Parameters:
refnum,: IN: Library reference number.
stream,: IN: The handle of stream instance.
*out_sleep,: OUT: The time of the application can sleep (msec). This value is not used for application.
Returns:
httpErrorOK sending done httpErrorWouldBlock application can call this function consecutively httpErrorIOSleep application can sleep httpErrorNoMem memory shortage httpErrorDNSInval DNS message invalid httpErrorDNSNoServer DNS server is not found httpErrorDNSTimedout Timeout at DNS resolve httpErrorDNSNotFound DNS server can not find the name httpErrorTCPOpen cannot open TCP httpErrorTCPConnec cannot connect TCP httpErrorTCPRead cannot read TCP httpErrorTCPWrite cannot write TCP httpErrorSSLConnect cannot Proxy Tunneling httpErrorSSLHandShake cannot SSL handshake httpErrorSSLRead cannot SSL read httpErrorSSLWrite cannot SSL write httpErrorReqTimedout request timeout httpErrorRspTimedout response timeout at Proxy Tunneling (SSL only)

Int32 HS_HTTPLibStreamSendRequestWithChunkEncoding | ( | UInt16 | refnum,
 |  | HS_HTTPLibStream | stream,
 |  | Char * | in_buf,
 |  | Int32 | in_offset,
 |  | Int32 | in_len,
 |  | Boolean | isFinish,
 |  | Int32 * | out_len,
 |  | Int32 * | out_sleep
 | ) |  |

This function sends chunk encoding data. This call opens and connects a TCP connection if not already established. It automatically retries at where pipeline stalled if pipeline is enable. The sequence of chunked data sending is 1. call HS_HTTPLibStreamCreateRequestWithChunkEncoding() 2. call HS_HTTPLibStreamSendRequestWithChunkEncoding() while return value is not httpErrorOK or error. 3. If there remains data, goto 2. 4. end If only one chunked data is sent, this API returns httpErrorOK. The address of data for one chunk is in_buf + in_offset, this value should not be changed while sending only one chunked data. isFinish is used to indicate the chunked data is the last chunk.

Parameters:
refnum,: IN: Library reference number
stream,: IN: The handle of stream instance.
*in_buf,: IN: The pointer to POST data.
in_offset,: IN: The offset to POST data.
in_len,: IN: The length of in_buf.
isFinish,: IN: True if the send data is the last chunk. False if send data is not the last chunk.
*out_len,: OUT: The size of sending data at this time (byte).
*out_sleep,: OUT: The time of the application can sleep (msec) This value is not used for application.
Returns:
httpErrorOK sending done httpErrorWouldBlock application can call this function consecutively httpErrorIOSleep application can sleep httpErrorNoMem memory shortage httpErrorDNSInval DNS message invalid httpErrorDNSNoServer DNS server is not found httpErrorDNSTimedout Timeout at DNS resolve httpErrorDNSNotFound DNS server can not find the name httpErrorTCPOpen cannot open TCP httpErrorTCPConnec cannot connect TCP httpErrorTCPRead cannot read TCP httpErrorTCPWrite cannot write TCP httpErrorSSLConnect cannot Proxy Tunneling httpErrorSSLHandShake cannot SSL handshake httpErrorSSLRead cannot read SSL httpErrorSSLWrite cannot write SSL httpErrorReqTimedout request timeout httpErrorRspTimedout response timeout at Proxy Tunneling (SSL only)

Int32 HS_HTTPLibStreamSendRequestWithPostData | ( | UInt16 | refnum,
 |  | HS_HTTPLibStream | stream,
 |  | Char * | in_buf,
 |  | Int32 | in_len,
 |  | Int32 * | out_len,
 |  | Int32 * | out_sleep
 | ) |  |

This function sends the POST request. This call opens and connects a TCP connection if not already established. It automatically retries at where pipeline stalled if pipeline is enable.

Because the data streaming could block and resume at where the pipeline was stalled, the application can call this function in a loop until the sending is finished.

Parameters:
refnum,: IN: Library reference number.
stream,: IN: The handle of stream instance.
*in_buf,: IN: The pointer to POST data.
in_len,: IN: The length of in_buf.
*out_len,: OUT: The size of sending data at this time (byte).
*out_sleep,: OUT: The time of the application can sleep (msec) This value is not used for application.
Returns:
httpErrorOK sending done httpErrorWouldBlock application can call this function consecutively httpErrorIOSleep application can sleep httpErrorNoMem memory shortage httpErrorDNSInval DNS message invalid

Int32 HS_HTTPLibStreamSetPostData | ( | UInt16 | refnum,
 |  | HS_HTTPLibStream | stream,
 |  | Int32 | in_encoding,
 |  | Char * | in_data,
 |  | Int32 | in_len
 | ) |  |

This function sets the POST data.

Parameters:
refnum,: IN: Library reference number.
stream,: IN: The handle of stream instance.
in_encoding,: IN: The type of encoding. httpPostURLENCODED URL encoding httpPostPLAINTEXT plain text (non encoding) httpPostMULTIPART multi-part encoding
*in_data,: IN: The pointer to the POST data.
in_len,: IN: The length of in_data.
Returns:
httpErrorOK setting done httpErrorNoMem memory shortage httpErrorReqBodySizeOver the size of request body exceeds limit. If the application does not set the limit by HS_HTTPLibSetMaxRequestBody, httpErrorReqBodySizeOver is not returned.

void HS_HTTPLibStreamSuspendTimer | ( | UInt16 | refnum,
 |  | HS_HTTPLibStream | stream
 | ) |  |

Parameters:
refnum,: IN:

Parameters:
stream,: IN:
Return values:
Err error code.

void HS_HTTPLibString_Delete | ( | UInt16 | refnum,
 |  | HS_HTTPLibString | in_str
 | ) |  |

This function deletes the handle of type HS_HTTPLibString.

Parameters:
refnum,: IN: Library reference number.
in_str,: IN: The handle.
Return values:
Nothing

Int32 HS_HTTPLibString_Length | ( | UInt16 | refnum,
 |  | HS_HTTPLibString | in_str
 | ) |  |

This function returns the length of the handle (byte).

Parameters:
refnum,: IN: Library reference number.
in_str,: IN: The handle.
Return values:
Int32

void* HS_HTTPLibString_Lock | ( | UInt16 | refnum,
 |  | HS_HTTPLibString | in_str
 | ) |  |

This function locks the handle of type HS_HTTPLibString.

Parameters:
refnum,: IN: Library reference number.
in_str,: IN: The handle.
Return values:
void *

void HS_HTTPLibString_Unlock | ( | UInt16 | refnum,
 |  | HS_HTTPLibString | in_str
 | ) |  |

This function unlocks the handle of type HS_HTTPLibString.

Parameters:
refnum,: IN: Library reference number.
in_str,: IN: The handle.
Return values:
Nothing

HS_HTTPLibString HS_HTTPLibStringNew | ( | UInt16 | refnum,
 |  | Char * | in_str,
 |  | Int32 | in_len
 | ) |  |

This function creates a new handle of type HS_HTTPLibString.

Parameters:
refnum,: IN: Library reference number.
*in_str,: IN: The pointer to the string.
in_len,: IN: The length of in_str.
Return values:
HS_HTTPLibString

void HS_HTTPLibURLString_Delete | ( | UInt16 | refnum,
 |  | HS_HTTPLibURLString | in_str
 | ) |  |

This function deletes the handle of type HS_HTTPLibURLString.

Parameters:
refnum,: IN: Library reference number.
in_str,: IN: The handle.
Return values:
nothing

Int32 HS_HTTPLibURLString_Length | ( | UInt16 | refnum,
 |  | HS_HTTPLibURLString | in_str
 | ) |  |

This function returns the length of the handle (byte).

Parameters:
refnum,: IN: Library reference number.
in_str,: IN: The handle.
Return values:
Int32

void* HS_HTTPLibURLString_Lock | ( | UInt16 | refnum,
 |  | HS_HTTPLibURLString | in_str
 | ) |  |

This function locks the handle of type HS_HTTPLibURLString.

Parameters:
refnum,: IN: Library reference number.
in_str,: IN: The handle.
Return values:
void *

void HS_HTTPLibURLString_Unlock | ( | UInt16 | refnum,
 |  | HS_HTTPLibURLString | in_str
 | ) |  |

This function unlocks the handle of type HS_HTTPLibURLString.

Parameters:
refnum,: IN: Library reference number.
in_str,: IN: The handle.
Return values:
nothing

HS_HTTPLibURLString HS_HTTPLibURLStringNew | ( | UInt16 | refnum,
 |  | Char * | in_str,
 |  | Int32 | in_len
 | ) |  |

This function creates a new handle of type HS_HTTPLibURLString.

Parameters:
refnum,: IN: Library reference number.
*in_str,: IN: The pointer to the string.
in_len,: IN: The length of in_str.
Return values:
HS_HTTPLibURLString

void HS_HTTPLibVHandle_Delete | ( | UInt16 | refnum,
 |  | HS_HTTPLibVHandle | in_vhandle
 | ) |  |

This function deletes the handle of type HS_HTTPLibVHandle.

Parameters:
refnum,: IN: Library reference number.
in_vhandle,: IN: The handle.
Return values:
Nothing

Int32 HS_HTTPLibVHandle_Length | ( | UInt16 | refnum,
 |  | HS_HTTPLibVHandle | in_vhandle
 | ) |  |

This function returns the length of the handle (byte).

Parameters:
refnum,: IN: Library reference number.
in_vhandle,: IN: The handle.
Return values:
Int32

void* HS_HTTPLibVHandle_Lock | ( | UInt16 | refnum,
 |  | HS_HTTPLibVHandle | in_vhandle
 | ) |  |

This function locks the handle of type HS_HTTPLibVHandle.

Parameters:
refnum,: IN: Library reference number.
in_vhandle,: IN: The handle.
Return values:
void *

void HS_HTTPLibVHandle_Unlock | ( | UInt16 | refnum,
 |  | HS_HTTPLibVHandle | in_vhandle
 | ) |  |

This function unlocks the handle of type HS_HTTPLibVHandle.

Parameters:
refnum,: IN: Library reference number.
in_vhandle,: IN: The handle.
Return values:
Nothing

Err HS_HTTPLibWake ( UInt16 refnum )

Standard library wake function.

Parameters:
refnum,: IN: Library reference number
Returns:
Error code.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:59 2008 for Palm API Guide


Header Files » Incs » common » libraries » http

HS_HTTPLibApp.h File Reference

Go to the source code of this file.

Data Structures

  • struct HS_HTTPLibOpaque_
  • struct HS_HTTPLibIPAddr_
  • struct HS_HTTPLibAppinfo_
  • struct HS_HTTPLibNetLibInfo_
  • struct HS_HTTPLibPeer_

Defines

  • #define HS_HTTPLibID 'AsHT'
  • #define HS_HTTPLibDBType 'libr'
  • #define HS_HTTPLibName "HTTPLibrary"
  • #define sysNotifyStopEvent 'test'
  • #define httpIPAddrTypeV4 4
  • #define httpIPAddrLenV4 4

Typedefs

  • typedef MemHandle HS_HTTPLibHandle
  • typedef HS_HTTPLibOpaque_ * HS_HTTPLibOpaque
  • typedef HS_HTTPLibIPAddr_ HS_HTTPLibIPAddr
  • typedef HS_HTTPLibAppinfo_ HS_HTTPLibAppInfo
  • typedef Boolean(*) HS_HTTPLibNetLibOpenProc (HS_HTTPLibHandle in_libH, HS_HTTPLibOpaque in_aux)
  • typedef Boolean(*) HS_HTTPLibNetLibCloseProc (HS_HTTPLibHandle in_libH, HS_HTTPLibOpaque in_aux)
  • typedef Boolean(*) HS_HTTPLibNetLibOnlineProc (HS_HTTPLibHandle in_libH, HS_HTTPLibOpaque in_aux)
  • typedef Boolean(*) HS_HTTPLibNetLibOfflineProc (HS_HTTPLibHandle in_libH, HS_HTTPLibOpaque in_aux)
  • typedef HS_HTTPLibNetLibInfo_ HS_HTTPLibNetLibInfo
  • typedef Int32(*) HS_TCPOpenPeer (Int32 in_domain, HS_HTTPLibOpaque in_aux)
  • typedef void(*) HS_TCPClosePeer (Int32 in_desc, HS_HTTPLibOpaque in_aux)
  • typedef Int32(*) HS_TCPIsConnectedPeer (Int32 in_desc, HS_HTTPLibOpaque in_aux)
  • typedef Int32(*) HS_TCPConnectPeer (Int32 in_desc, HS_HTTPLibIPAddr *in_addr, Int32 in_port, HS_HTTPLibOpaque in_aux)
  • typedef Int32(*) HS_TCPReadPeer (Int32 in_desc, Char *out_buf, Int32 in_len, HS_HTTPLibOpaque in_aux)
  • typedef Int32(*) HS_TCPWritePeer (Int32 in_desc, Char *in_buf, Int32 in_len, HS_HTTPLibOpaque in_aux)
  • typedef Int32(*) HS_TCPCanReadWritePeer (Int32 in_desc, Int32 in_rw, HS_HTTPLibOpaque in_aux)
  • typedef HS_HTTPLibPeer_ HS_HTTPLibPeer

Define Documentation

#define HS_HTTPLibDBType 'libr'

Definition at line 12 of file HS_HTTPLibApp.h.

#define HS_HTTPLibID 'AsHT'

Definition at line 11 of file HS_HTTPLibApp.h.

#define HS_HTTPLibName "HTTPLibrary"

Definition at line 13 of file HS_HTTPLibApp.h.

#define httpIPAddrLenV4 4

Definition at line 32 of file HS_HTTPLibApp.h.

#define httpIPAddrTypeV4 4

Definition at line 31 of file HS_HTTPLibApp.h.

#define sysNotifyStopEvent 'test'

Definition at line 15 of file HS_HTTPLibApp.h.

Typedef Documentation

typedef struct HS_HTTPLibAppinfo_ HS_HTTPLibAppInfo

Definition at line 55 of file HS_HTTPLibApp.h.

typedef MemHandle HS_HTTPLibHandle

Definition at line 19 of file HS_HTTPLibApp.h.

typedef struct HS_HTTPLibIPAddr_ HS_HTTPLibIPAddr

Definition at line 29 of file HS_HTTPLibApp.h.

typedef Boolean(*) HS_HTTPLibNetLibCloseProc(HS_HTTPLibHandle in_libH, HS_HTTPLibOpaque in_aux)

Definition at line 58 of file HS_HTTPLibApp.h.

typedef struct HS_HTTPLibNetLibInfo_ HS_HTTPLibNetLibInfo

Definition at line 70 of file HS_HTTPLibApp.h.

typedef Boolean(*) HS_HTTPLibNetLibOfflineProc(HS_HTTPLibHandle in_libH, HS_HTTPLibOpaque in_aux)

Definition at line 60 of file HS_HTTPLibApp.h.

typedef Boolean(*) HS_HTTPLibNetLibOnlineProc(HS_HTTPLibHandle in_libH, HS_HTTPLibOpaque in_aux)

Definition at line 59 of file HS_HTTPLibApp.h.

typedef Boolean(*) HS_HTTPLibNetLibOpenProc(HS_HTTPLibHandle in_libH, HS_HTTPLibOpaque in_aux)

Definition at line 57 of file HS_HTTPLibApp.h.

typedef struct HS_HTTPLibOpaque_* HS_HTTPLibOpaque

Definition at line 23 of file HS_HTTPLibApp.h.

typedef struct HS_HTTPLibPeer_ HS_HTTPLibPeer

Definition at line 93 of file HS_HTTPLibApp.h.

typedef Int32(*) HS_TCPCanReadWritePeer(Int32 in_desc, Int32 in_rw, HS_HTTPLibOpaque in_aux)

Definition at line 80 of file HS_HTTPLibApp.h.

typedef void(*) HS_TCPClosePeer(Int32 in_desc, HS_HTTPLibOpaque in_aux)

Definition at line 75 of file HS_HTTPLibApp.h.

typedef Int32(*) HS_TCPConnectPeer(Int32 in_desc, HS_HTTPLibIPAddr *in_addr, Int32 in_port, HS_HTTPLibOpaque in_aux)

Definition at line 77 of file HS_HTTPLibApp.h.

typedef Int32(*) HS_TCPIsConnectedPeer(Int32 in_desc, HS_HTTPLibOpaque in_aux)

Definition at line 76 of file HS_HTTPLibApp.h.

typedef Int32(*) HS_TCPOpenPeer(Int32 in_domain, HS_HTTPLibOpaque in_aux)

Definition at line 74 of file HS_HTTPLibApp.h.

typedef Int32(*) HS_TCPReadPeer(Int32 in_desc, Char *out_buf, Int32 in_len, HS_HTTPLibOpaque in_aux)

Definition at line 78 of file HS_HTTPLibApp.h.

typedef Int32(*) HS_TCPWritePeer(Int32 in_desc, Char *in_buf, Int32 in_len, HS_HTTPLibOpaque in_aux)

Definition at line 79 of file HS_HTTPLibApp.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:59 2008 for Palm API Guide


Header Files » Incs » common » libraries » http

HS_HTTPLibConst.h File Reference

Go to the source code of this file.

Defines

  • #define kHTTPLibTrapOpen sysLibTrapOpen
  • #define kHTTPLibTrapClose sysLibTrapClose
  • #define kHTTPLibTrapSleep sysLibTrapSleep
  • #define kHTTPLibTrapWake sysLibTrapWake
  • #define kHTTPLibTrapOpenCount (sysLibTrapCustom + 0)
  • #define kHTTPLibTrapInitialize (sysLibTrapCustom + 1)
  • #define kHTTPLibTrapFinalize (sysLibTrapCustom + 2)
  • #define kHTTPLibTrapSSLClass (sysLibTrapCustom + 3)
  • #define kHTTPLibTrapRegisterSSLClass (sysLibTrapCustom + 4)
  • #define kHTTPLibTrapClearDNSCache (sysLibTrapCustom + 5)
  • #define kHTTPLibTrapCloseAllKeepAlive (sysLibTrapCustom + 6)
  • #define kHTTPLibTrapMakeProxy (sysLibTrapCustom + 7)
  • #define kHTTPLibTrapSetHTTPPort (sysLibTrapCustom + 8)
  • #define kHTTPLibTrapSetHTTPSPort (sysLibTrapCustom + 9)
  • #define kHTTPLibTrapSetMaxRequestHeader (sysLibTrapCustom + 10)
  • #define kHTTPLibTrapSetMaxRequestBody (sysLibTrapCustom + 11)
  • #define kHTTPLibTrapSetProxy (sysLibTrapCustom + 12)
  • #define kHTTPLibTrapSetUserAgent (sysLibTrapCustom + 13)
  • #define kHTTPLibTrapSetDefaultHeaders (sysLibTrapCustom + 14)
  • #define kHTTPLibTrapSetUseProxy (sysLibTrapCustom + 15)
  • #define kHTTPLibTrapSetHTTP11OverProxy (sysLibTrapCustom + 16)
  • #define kHTTPLibTrapSetSendReferer (sysLibTrapCustom + 17)
  • #define kHTTPLibTrapSetSendProxyKeepAlive (sysLibTrapCustom + 18)
  • #define kHTTPLibTrapSetSendCookie (sysLibTrapCustom + 19)
  • #define kHTTPLibTrapSetConnectTimeOut (sysLibTrapCustom + 20)
  • #define kHTTPLibTrapSetReqTimeOut (sysLibTrapCustom + 21)
  • #define kHTTPLibTrapSetRspTimeOut (sysLibTrapCustom + 22)
  • #define kHTTPLibTrapIsUseProxy (sysLibTrapCustom + 23)
  • #define kHTTPLibTrapIsHTTP11OverProxy (sysLibTrapCustom + 24)
  • #define kHTTPLibTrapIsSendReferer (sysLibTrapCustom + 25)
  • #define kHTTPLibTrapIsSendCookie (sysLibTrapCustom + 26)
  • #define kHTTPLibTrapStreamNew (sysLibTrapCustom + 27)
  • #define kHTTPLibTrapStreamDelete (sysLibTrapCustom + 28)
  • #define kHTTPLibTrapStreamCreateRequest (sysLibTrapCustom + 29)
  • #define kHTTPLibTrapStreamCreateRequestWithChunkEncoding (sysLibTrapCustom + 30)
  • #define kHTTPLibTrapStreamSendRequest (sysLibTrapCustom + 31)
  • #define kHTTPLibTrapStreamSendRequestWithPostData (sysLibTrapCustom + 32)
  • #define kHTTPLibTrapStreamSendRequestWithChunkEncoding (sysLibTrapCustom + 33)
  • #define kHTTPLibTrapStreamReceiveResponse (sysLibTrapCustom + 34)
  • #define kHTTPLibTrapStreamGetFlag (sysLibTrapCustom + 35)
  • #define kHTTPLibTrapStreamClose (sysLibTrapCustom + 36)
  • #define kHTTPLibTrapStreamIsHeaderReceived (sysLibTrapCustom + 37)
  • #define kHTTPLibTrapStreamSetPostData (sysLibTrapCustom + 38)
  • #define kHTTPLibTrapStreamGetScheme (sysLibTrapCustom + 39)
  • #define kHTTPLibTrapStreamGetState (sysLibTrapCustom + 40)
  • #define kHTTPLibTrapStreamGetStatusCode (sysLibTrapCustom + 41)
  • #define kHTTPLibTrapStreamGetResponseHeaderLength (sysLibTrapCustom + 42)
  • #define kHTTPLibTrapStreamGetResponseHeader (sysLibTrapCustom + 43)
  • #define kHTTPLibTrapStreamGetContentLength (sysLibTrapCustom + 44)
  • #define kHTTPLibTrapStreamGetEntityLength (sysLibTrapCustom + 45)
  • #define kHTTPLibTrapStreamAddHeaderLine (sysLibTrapCustom + 46)
  • #define kHTTPLibTrapStreamAddHeader (sysLibTrapCustom + 47)
  • #define kHTTPLibTrapStreamGetHeader (sysLibTrapCustom + 48)
  • #define kHTTPLibTrapMakeCertList (sysLibTrapCustom + 49)
  • #define kHTTPLibTrapHeaderSplitByX (sysLibTrapCustom + 50)
  • #define kHTTPLibTrapAuthInfoTidy (sysLibTrapCustom + 51)
  • #define kHTTPLibTrapSetUserPass (sysLibTrapCustom + 52)
  • #define kHTTPLibTrapFindAuthInfo (sysLibTrapCustom + 53)
  • #define kHTTPLibTrapMakeAuthInfo (sysLibTrapCustom + 54)
  • #define kHTTPLibTrapAuthInfoUser (sysLibTrapCustom + 55)
  • #define kHTTPLibTrapAuthInfoPass (sysLibTrapCustom + 56)
  • #define kHTTPLibTrapAuthInfoRealm (sysLibTrapCustom + 57)
  • #define kHTTPLibTrapAuthCacheGetChallengeTokenSS (sysLibTrapCustom + 58)
  • #define kHTTPLibTrapSetCookieMode (sysLibTrapCustom + 59)
  • #define kHTTPLibTrapSetCookieMax (sysLibTrapCustom + 60)
  • #define kHTTPLibTrapSetCookie (sysLibTrapCustom + 61)
  • #define kHTTPLibTrapMakeCookiesString (sysLibTrapCustom + 62)
  • #define kHTTPLibTrapSaveCookiesEntries (sysLibTrapCustom + 63)
  • #define kHTTPLibTrapLoadCookiesEntries (sysLibTrapCustom + 64)
  • #define kHTTPLibTrapCookieMakeEmpty (sysLibTrapCustom + 65)
  • #define kHTTPLibTrapSetDNSMaxRetry (sysLibTrapCustom + 66)
  • #define kHTTPLibTrapSetDNSRetryInterval (sysLibTrapCustom + 67)
  • #define kHTTPLibTrapSetSSLVersionFlag (sysLibTrapCustom + 68)
  • #define kHTTPLibTrapSSLTimeout (sysLibTrapCustom + 69)
  • #define kHTTPLibTrapSSLOpenCertDB (sysLibTrapCustom + 70)
  • #define kHTTPLibTrapSSLCloseCertDB (sysLibTrapCustom + 71)
  • #define kHTTPLibTrapCertListNew (sysLibTrapCustom + 72)
  • #define kHTTPLibTrapCertListDelete (sysLibTrapCustom + 73)
  • #define kHTTPLibTrapCertListClone (sysLibTrapCustom + 74)
  • #define kHTTPLibTrapCertListLock (sysLibTrapCustom + 75)
  • #define kHTTPLibTrapCertListUnlock (sysLibTrapCustom + 76)
  • #define kHTTPLibTrapCertListType (sysLibTrapCustom + 77)
  • #define kHTTPLibTrapCertListLength (sysLibTrapCustom + 78)
  • #define kHTTPLibTrapCertListBeginDecode (sysLibTrapCustom + 79)
  • #define kHTTPLibTrapCertListEndDecode (sysLibTrapCustom + 80)
  • #define kHTTPLibTrapCertListImportCert (sysLibTrapCustom + 81)
  • #define kHTTPLibTrapCertPeekVersion (sysLibTrapCustom + 82)
  • #define kHTTPLibTrapCertPeekSerialNumber (sysLibTrapCustom + 83)
  • #define kHTTPLibTrapCertPeekSignAlgo (sysLibTrapCustom + 84)
  • #define kHTTPLibTrapCertBeginPeekIssuerRDN (sysLibTrapCustom + 85)
  • #define kHTTPLibTrapCertPeekIssuerRDN (sysLibTrapCustom + 86)
  • #define kHTTPLibTrapCertPeekIssuerRDNStrType (sysLibTrapCustom + 87)
  • #define kHTTPLibTrapCert_EndPeekIssuerRDN (sysLibTrapCustom + 88)
  • #define kHTTPLibTrapCertBeginPeekSubjectRDN (sysLibTrapCustom + 89)
  • #define kHTTPLibTrapCertPeekSubjectRDN (sysLibTrapCustom + 90)
  • #define kHTTPLibTrapCertPeekSubjectRDNStrType (sysLibTrapCustom + 91)
  • #define kHTTPLibTrapCert_EndPeekSubjectRDN (sysLibTrapCustom + 92)
  • #define kHTTPLibTrapCert_PeekValidityStart (sysLibTrapCustom + 93)
  • #define kHTTPLibTrapCert_PeekValidityEnd (sysLibTrapCustom + 94)
  • #define kHTTPLibTrapCert_PeekRSAPublicKeyBits (sysLibTrapCustom + 95)
  • #define kHTTPLibTrapClientCertListNew (sysLibTrapCustom + 96)
  • #define kHTTPLibTrapClientCertListClone (sysLibTrapCustom + 97)
  • #define kHTTPLibTrapClientCertListDelete (sysLibTrapCustom + 98)
  • #define kHTTPLibTrapClientCertListLength (sysLibTrapCustom + 99)
  • #define kHTTPLibTrapClientCertListIsValid (sysLibTrapCustom + 100)
  • #define kHTTPLibTrapClientCertListSetValid (sysLibTrapCustom + 101)
  • #define kHTTPLibTrapSetSSLServerCertConfirmProc (sysLibTrapCustom + 102)
  • #define kHTTPLibTrapServerCertConfirm (sysLibTrapCustom + 103)
  • #define kHTTPLibTrapSetSSLClientCertSelectProc (sysLibTrapCustom + 104)
  • #define kHTTPLibTrapClientCertSelect (sysLibTrapCustom + 105)
  • #define kHTTPLibTrapSetNetLibProc (sysLibTrapCustom + 106)
  • #define kHTTPLibTrapDataHandle_Length (sysLibTrapCustom + 107)
  • #define kHTTPLibTrapDataHandle_Lock (sysLibTrapCustom + 108)
  • #define kHTTPLibTrapDataHandle_Unlock (sysLibTrapCustom + 109)
  • #define kHTTPLibTrapDataHandle_Delete (sysLibTrapCustom + 110)
  • #define kHTTPLibTrapVHandle_Length (sysLibTrapCustom + 111)
  • #define kHTTPLibTrapVHandle_Lock (sysLibTrapCustom + 112)
  • #define kHTTPLibTrapVHandle_Unlock (sysLibTrapCustom + 113)
  • #define kHTTPLibTrapVHandle_Delete (sysLibTrapCustom + 114)
  • #define kHTTPLibTrapString_Length (sysLibTrapCustom + 115)
  • #define kHTTPLibTrapStringNew (sysLibTrapCustom + 116)
  • #define kHTTPLibTrapString_Lock (sysLibTrapCustom + 117)
  • #define kHTTPLibTrapString_Unlock (sysLibTrapCustom + 118)
  • #define kHTTPLibTrapString_Delete (sysLibTrapCustom + 119)
  • #define kHTTPLibTrapFixedString_Length (sysLibTrapCustom + 120)
  • #define kHTTPLibTrapFixedStringNew (sysLibTrapCustom + 121)
  • #define kHTTPLibTrapFixedString_Lock (sysLibTrapCustom + 122)
  • #define kHTTPLibTrapFixedString_Unlock (sysLibTrapCustom + 123)
  • #define kHTTPLibTrapFixedString_Delete (sysLibTrapCustom + 124)
  • #define kHTTPLibTrapURLString_Length (sysLibTrapCustom + 125)
  • #define kHTTPLibTrapURLStringNew (sysLibTrapCustom + 126)
  • #define kHTTPLibTrapURLString_Lock (sysLibTrapCustom + 127)
  • #define kHTTPLibTrapURLString_Unlock (sysLibTrapCustom + 128)
  • #define kHTTPLibTrapURLString_Delete (sysLibTrapCustom + 129)
  • #define kHTTPLibTrapCertListGetCipherInfo (sysLibTrapCustom + 130)
  • #define kHTTPLibTrapSetCookieX (sysLibTrapCustom + 131)
  • #define kHTTPLibTrapSetTunnelingCallback (sysLibTrapCustom + 132)
  • #define kHTTPLibTrapSetMaxKeepAliveTimeout (sysLibTrapCustom + 133)
  • #define kHTTPLibTrapStreamResumeTimer (sysLibTrapCustom + 134)
  • #define kHTTPLibTrapStreamSuspendTimer (sysLibTrapCustom + 135)
  • #define kHTTPLibTrapStreamGetRequestSent (sysLibTrapCustom + 136)
  • #define kHTTPLibTrapStreamGetHeaderWithOffset (sysLibTrapCustom + 137)
  • #define kHTTPLibTrapSetUserPassX (sysLibTrapCustom + 138)
  • #define kHTTPLibTrapFindAuthCandidate (sysLibTrapCustom + 139)
  • #define kHTTPLibTrapSetWakeUpCallback (sysLibTrapCustom + 140)
  • #define kHTTPLibTrapSetUseragentSelectionRule (sysLibTrapCustom + 141)
  • #define httpStreamRead 0x00000001
  • #define httpStreamWrite 0x00000002
  • #define httpStreamReadWrite (httpStreamRead|httpStreamWrite)
  • #define httpStreamTextCRLF "\015\012"
  • #define httpStreamTextCRLFCRLF "\015\012\015\012"
  • #define httpStreamTextCRCR "\015\015"
  • #define httpStreamTextLFLF "\012\012"
  • #define httpPostURLENCODED 0x00000001
  • #define httpPostPLAINTEXT 0x00000002
  • #define httpPostMULTIPART 0x00000004
  • #define httpSSLFlagConnV2 0x00000001
  • #define httpSSLFlagConnV3 0x00000002
  • #define httpSSLFlagConnTLS 0x00000004
  • #define httpSSLFlagConnV2V3 (httpSSLFlagConnV2 | httpSSLFlagConnV3)
  • #define httpSSLFlagConnV2TLS (httpSSLFlagConnV2 | httpSSLFlagConnTLS)
  • #define httpSSLFlagConnV3TLS (httpSSLFlagConnV3 | httpSSLFlagConnTLS)
  • #define httpSSLFlagConnV2V3TLS (httpSSLFlagConnV2 | httpSSLFlagConnV3 | httpSSLFlagConnTLS)

Typedefs

  • typedef enum httpAuthType_ httpAuthTypeEnum
  • typedef enum httpAuthTarget_ httpAuthTargetEnum
  • typedef enum httpAuthPath_ httpAuthPathEnum
  • typedef enum httpError_ httpErrorEnum
  • typedef enum httpHeaderType_ httpHeaderTypeEnum
  • typedef enum httpStreamState_ httpStreamStateEnum
  • typedef enum httpScheme_ httpSchemeEnum
  • typedef enum httpMethod_ httpMethodEnum
  • typedef enum httpVersion_ httpVersionEnum
  • typedef enum httpStatusCode_ httpStatusCodeEnum
  • typedef enum httpCookie_ httpCookieEnum
  • typedef enum httpHeaderID_ httpHeaderIDEnum

Enumerations

  • enum httpAuthType_ {
    httpAuthTypeNone = -1,
    httpAuthTypeBasic = 0,
    httpAuthTypeDigest,
    httpAuthTypeTypes
    }
  • enum httpAuthTarget_ {
    httpAuthTargetPage = 0,
    httpAuthTargetProxy,
    httpAuthTargetTargets
    }
  • enum httpAuthPath_ {
    httpAuthPathSame,
    httpAuthPathAncestor,
    httpAuthPathDescendant,
    httpAuthPathCousin
    }
  • enum httpError_ {
    httpErrorOK = 0,
    httpErrorGeneric = -1,
    httpErrorWouldBlock = -2,
    httpErrorIOSleep = -3,
    httpErrorNoMem = -6,
    httpErrorInval = -8,
    httpErrorDNSInval = -200,
    httpErrorDNSNoServer,
    httpErrorDNSTimedout,
    httpErrorDNSNotFound,
    httpErrorTCPOpen,
    httpErrorTCPConnect,
    httpErrorTCPRead,
    httpErrorTCPWrite,
    httpErrorSSLConnect,
    httpErrorSSLHandShake,
    httpErrorSSLRead,
    httpErrorSSLWrite,
    httpErrorReqTimedout,
    httpErrorRspTimedout,
    httpErrorCacheNone,
    httpErrorCacheExpire,
    httpErrorAuthUnknown,
    httpErrorAuthNoHeader,
    httpErrorAuthFormat,
    httpErrorRedirectFormat,
    httpErrorRedirectCanceled,
    httpErrorReqHeaderSizeOver,
    httpErrorReqBodySizeOver,
    httpErrorRspHeaderSizeOver,
    httpErrorReqTooManyContinue,
    httpErrorTLSIntolerant
    }
  • enum httpHeaderType_ {
    httpHeaderTypeGeneral = 0,
    httpHeaderTypeRequest,
    httpHeaderTypeResponse,
    httpHeaderTypeEntity,
    httpHeaderTypeOther,
    httpHeaderTypeTypes
    }
  • enum httpStreamState_ {
    httpStreamStateNew = 0,
    httpStreamStateDormant,
    httpStreamStateReqCreated,
    httpStreamStateReqResolve,
    httpStreamStateReqResolving,
    httpStreamStateReqOpen,
    httpStreamStateReqConnect,
    httpStreamStateReqConnecting,
    httpStreamStateReqProxyConnect,
    httpStreamStateReqProxyConnecting,
    httpStreamStateReqSSLHandShaking,
    httpStreamStateReqSSLHandShaked,
    httpStreamStateReqSending,
    httpStreamStateReqSent,
    httpStreamStateRspHeaderWaiting,
    httpStreamStateRspContinue,
    httpStreamStateRspHeaderReceiving,
    httpStreamStateRspHeaderReceived,
    httpStreamStateRspEntityReceiving,
    httpStreamStateRspEntityReceived,
    httpStreamStateObsolete,
    httpStreamStateDelete,
    httpStreamStateStates
    }
  • enum httpScheme_ {
    httpSchemeHTTP = 0,
    httpSchemeHTTPS,
    httpSchemeSchemes
    }
  • enum httpMethod_ {
    httpMethodOPTIONS = 0,
    httpMethodGET,
    httpMethodHEAD,
    httpMethodPOST,
    httpMethodPUT,
    httpMethodDELETE,
    httpMethodTRACE,
    httpMethodCONNECT,
    httpMethodMethods
    }
  • enum httpVersion_ {
    httpVersion_0_9 = 0,
    httpVersion_1_0,
    httpVersion_1_1,
    httpVersionVersions
    }
  • enum httpStatusCode_ {
    httpStatusCodeContinue = 100,
    httpStatusCodeSwitchingProtocols = 101,
    httpStatusCodeOK = 200,
    httpStatusCodeCreated = 201,
    httpStatusCodeAccepted = 202,
    httpStatusCodeNonAuthoritativeInformation = 203,
    httpStatusCodeNoContent = 204,
    httpStatusCodeResetContent = 205,
    httpStatusCodePartialContent = 206,
    httpStatusCodeMultipleChoices = 300,
    httpStatusCodeMovedPermanently = 301,
    httpStatusCodeFound = 302,
    httpStatusCodeSeeOther = 303,
    httpStatusCodeNotModified = 304,
    httpStatusCodeUseProxy = 305,
    httpStatusCodeTemporaryRedirect = 307,
    httpStatusCodeBadRequest = 400,
    httpStatusCodeUnauthorized = 401,
    httpStatusCodePaymentRequired = 402,
    httpStatusCodeForbidden = 403,
    httpStatusCodeNotFound = 404,
    httpStatusCodeMethodNotAllowed = 405,
    httpStatusCodeNotAcceptable = 406,
    httpStatusCodeProxyAuthenticationRequired = 407,
    httpStatusCodeRequestTimeout = 408,
    httpStatusCodeConflict = 409,
    httpStatusCodeGone = 410,
    httpStatusCodeLengthRequired = 411,
    httpStatusCodePreconditionFailed = 412,
    httpStatusCodeRequestEntityTooLarge = 413,
    httpStatusCodeRequestURITooLarge = 414,
    httpStatusCodeUnsupportedMediaType = 415,
    httpStatusCodeRequestedRangeNotSatisfiable = 416,
    httpStatusCodeExpectationFailed = 417,
    httpStatusCodeInternalServerError = 500,
    httpStatusCodeNotImplemented = 501,
    httpStatusCodeBadGateway = 502,
    httpStatusCodeServiceUnavailable = 503,
    httpStatusCodeGatewayTimeout = 504,
    httpStatusCodeHTTPVersionNotSupported = 505
    }
  • enum httpCookie_ {
    httpCookieNotifyBeforeSet = 0,
    httpCookieAlwaysSet,
    httpCookieNeverSet
    }
  • enum httpHeaderID_ {
    httpHeaderIDCacheControl,
    httpHeaderIDConnection,
    httpHeaderIDDate,
    httpHeaderIDPragma,
    httpHeaderIDTrailer,
    httpHeaderIDTransferEncoding,
    httpHeaderIDUpgrade,
    httpHeaderIDVia,
    httpHeaderIDWarning,
    httpHeaderIDKeepAlive,
    httpHeaderIDProxyConnection,
    httpHeaderIDAccept,
    httpHeaderIDAcceptCharset,
    httpHeaderIDAcceptEncoding,
    httpHeaderIDAcceptLanguage,
    httpHeaderIDAuthorization,
    httpHeaderIDExpect,
    httpHeaderIDFrom,
    httpHeaderIDHost,
    httpHeaderIDIfMatch,
    httpHeaderIDIfModifiedSince,
    httpHeaderIDIfNoneMatch,
    httpHeaderIDIfRange,
    httpHeaderIDIfUnmodifiedSince,
    httpHeaderIDMaxForwards,
    httpHeaderIDProxyAuthorization,
    httpHeaderIDRange,
    httpHeaderIDReferer,
    httpHeaderIDTE,
    httpHeaderIDUserAgent,
    httpHeaderIDCookie,
    httpHeaderIDAcceptRanges,
    httpHeaderIDAge,
    httpHeaderIDETag,
    httpHeaderIDLocation,
    httpHeaderIDProxyAuthenticate,
    httpHeaderIDRetryAfter,
    httpHeaderIDServer,
    httpHeaderIDVary,
    httpHeaderIDWWWAuthenticate,
    httpHeaderIDSetCookie,
    httpHeaderIDAuthenticationInfo,
    httpHeaderIDProxyAuthenticationInfo,
    httpHeaderIDAllow,
    httpHeaderIDContentEncoding,
    httpHeaderIDContentDisposition,
    httpHeaderIDContentLanguage,
    httpHeaderIDContentLength,
    httpHeaderIDContentLocation,
    httpHeaderIDContentMD5,
    httpHeaderIDContentRange,
    httpHeaderIDContentType,
    httpHeaderIDExpires,
    httpHeaderIDLastModified,
    httpHeaderIDRefresh,
    httpHeaderIDENUMS
    }
  • enum {
    httpCookieClearAtFinalize,
    httpCookieClearAll,
    httpCookieClearSessionCookiesOnly
    }
  • enum { httpDNSModeIPV4Only = 0 }
  • enum {
    httpCetListTypeUnknown = 0,
    httpCetListTypeServer,
    httpCetListTypeClient,
    httpCetListTypeBrowser,
    httpCetListTypeTypes
    }

Define Documentation

#define httpPostMULTIPART 0x00000004

Definition at line 358 of file HS_HTTPLibConst.h.

#define httpPostPLAINTEXT 0x00000002

Definition at line 357 of file HS_HTTPLibConst.h.

#define httpPostURLENCODED 0x00000001

Definition at line 356 of file HS_HTTPLibConst.h.

#define httpSSLFlagConnTLS 0x00000004

Definition at line 424 of file HS_HTTPLibConst.h.

#define httpSSLFlagConnV2 0x00000001

Definition at line 422 of file HS_HTTPLibConst.h.

#define httpSSLFlagConnV2TLS (httpSSLFlagConnV2 | httpSSLFlagConnTLS)

Definition at line 426 of file HS_HTTPLibConst.h.

#define httpSSLFlagConnV2V3 (httpSSLFlagConnV2 | httpSSLFlagConnV3)

Definition at line 425 of file HS_HTTPLibConst.h.

#define httpSSLFlagConnV2V3TLS (httpSSLFlagConnV2 | httpSSLFlagConnV3 | httpSSLFlagConnTLS)

Definition at line 428 of file HS_HTTPLibConst.h.

#define httpSSLFlagConnV3 0x00000002

Definition at line 423 of file HS_HTTPLibConst.h.

#define httpSSLFlagConnV3TLS (httpSSLFlagConnV3 | httpSSLFlagConnTLS)

Definition at line 427 of file HS_HTTPLibConst.h.

#define httpStreamRead 0x00000001

Definition at line 161 of file HS_HTTPLibConst.h.

#define httpStreamReadWrite (httpStreamRead|httpStreamWrite)

Definition at line 163 of file HS_HTTPLibConst.h.

#define httpStreamTextCRCR "\015\015"

Definition at line 190 of file HS_HTTPLibConst.h.

#define httpStreamTextCRLF "\015\012"

Definition at line 188 of file HS_HTTPLibConst.h.

#define httpStreamTextCRLFCRLF "\015\012\015\012"

Definition at line 189 of file HS_HTTPLibConst.h.

#define httpStreamTextLFLF "\012\012"

Definition at line 191 of file HS_HTTPLibConst.h.

#define httpStreamWrite 0x00000002

Definition at line 162 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapAuthCacheGetChallengeTokenSS (sysLibTrapCustom + 58)

Definition at line 75 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapAuthInfoPass (sysLibTrapCustom + 56)

Definition at line 73 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapAuthInfoRealm (sysLibTrapCustom + 57)

Definition at line 74 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapAuthInfoTidy (sysLibTrapCustom + 51)

Definition at line 68 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapAuthInfoUser (sysLibTrapCustom + 55)

Definition at line 72 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapCert_EndPeekIssuerRDN (sysLibTrapCustom + 88)

Definition at line 105 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapCert_EndPeekSubjectRDN (sysLibTrapCustom + 92)

Definition at line 109 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapCert_PeekRSAPublicKeyBits (sysLibTrapCustom + 95)

Definition at line 112 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapCert_PeekValidityEnd (sysLibTrapCustom + 94)

Definition at line 111 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapCert_PeekValidityStart (sysLibTrapCustom + 93)

Definition at line 110 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapCertBeginPeekIssuerRDN (sysLibTrapCustom + 85)

Definition at line 102 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapCertBeginPeekSubjectRDN (sysLibTrapCustom + 89)

Definition at line 106 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapCertListBeginDecode (sysLibTrapCustom + 79)

Definition at line 96 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapCertListClone (sysLibTrapCustom + 74)

Definition at line 91 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapCertListDelete (sysLibTrapCustom + 73)

Definition at line 90 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapCertListEndDecode (sysLibTrapCustom + 80)

Definition at line 97 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapCertListGetCipherInfo (sysLibTrapCustom + 130)

Definition at line 147 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapCertListImportCert (sysLibTrapCustom + 81)

Definition at line 98 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapCertListLength (sysLibTrapCustom + 78)

Definition at line 95 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapCertListLock (sysLibTrapCustom + 75)

Definition at line 92 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapCertListNew (sysLibTrapCustom + 72)

Definition at line 89 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapCertListType (sysLibTrapCustom + 77)

Definition at line 94 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapCertListUnlock (sysLibTrapCustom + 76)

Definition at line 93 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapCertPeekIssuerRDN (sysLibTrapCustom + 86)

Definition at line 103 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapCertPeekIssuerRDNStrType (sysLibTrapCustom + 87)

Definition at line 104 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapCertPeekSerialNumber (sysLibTrapCustom + 83)

Definition at line 100 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapCertPeekSignAlgo (sysLibTrapCustom + 84)

Definition at line 101 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapCertPeekSubjectRDN (sysLibTrapCustom + 90)

Definition at line 107 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapCertPeekSubjectRDNStrType (sysLibTrapCustom + 91)

Definition at line 108 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapCertPeekVersion (sysLibTrapCustom + 82)

Definition at line 99 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapClearDNSCache (sysLibTrapCustom + 5)

Definition at line 22 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapClientCertListClone (sysLibTrapCustom + 97)

Definition at line 114 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapClientCertListDelete (sysLibTrapCustom + 98)

Definition at line 115 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapClientCertListIsValid (sysLibTrapCustom + 100)

Definition at line 117 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapClientCertListLength (sysLibTrapCustom + 99)

Definition at line 116 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapClientCertListNew (sysLibTrapCustom + 96)

Definition at line 113 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapClientCertListSetValid (sysLibTrapCustom + 101)

Definition at line 118 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapClientCertSelect (sysLibTrapCustom + 105)

Definition at line 122 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapClose sysLibTrapClose

Definition at line 14 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapCloseAllKeepAlive (sysLibTrapCustom + 6)

Definition at line 23 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapCookieMakeEmpty (sysLibTrapCustom + 65)

Definition at line 82 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapDataHandle_Delete (sysLibTrapCustom + 110)

Definition at line 127 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapDataHandle_Length (sysLibTrapCustom + 107)

Definition at line 124 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapDataHandle_Lock (sysLibTrapCustom + 108)

Definition at line 125 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapDataHandle_Unlock (sysLibTrapCustom + 109)

Definition at line 126 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapFinalize (sysLibTrapCustom + 2)

Definition at line 19 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapFindAuthCandidate (sysLibTrapCustom + 139)

Definition at line 156 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapFindAuthInfo (sysLibTrapCustom + 53)

Definition at line 70 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapFixedString_Delete (sysLibTrapCustom + 124)

Definition at line 141 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapFixedString_Length (sysLibTrapCustom + 120)

Definition at line 137 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapFixedString_Lock (sysLibTrapCustom + 122)

Definition at line 139 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapFixedString_Unlock (sysLibTrapCustom + 123)

Definition at line 140 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapFixedStringNew (sysLibTrapCustom + 121)

Definition at line 138 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapHeaderSplitByX (sysLibTrapCustom + 50)

Definition at line 67 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapInitialize (sysLibTrapCustom + 1)

Definition at line 18 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapIsHTTP11OverProxy (sysLibTrapCustom + 24)

Definition at line 41 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapIsSendCookie (sysLibTrapCustom + 26)

Definition at line 43 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapIsSendReferer (sysLibTrapCustom + 25)

Definition at line 42 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapIsUseProxy (sysLibTrapCustom + 23)

Definition at line 40 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapLoadCookiesEntries (sysLibTrapCustom + 64)

Definition at line 81 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapMakeAuthInfo (sysLibTrapCustom + 54)

Definition at line 71 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapMakeCertList (sysLibTrapCustom + 49)

Definition at line 66 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapMakeCookiesString (sysLibTrapCustom + 62)

Definition at line 79 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapMakeProxy (sysLibTrapCustom + 7)

Definition at line 24 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapOpen sysLibTrapOpen

Definition at line 13 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapOpenCount (sysLibTrapCustom + 0)

Definition at line 17 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapRegisterSSLClass (sysLibTrapCustom + 4)

Definition at line 21 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapSaveCookiesEntries (sysLibTrapCustom + 63)

Definition at line 80 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapServerCertConfirm (sysLibTrapCustom + 103)

Definition at line 120 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapSetConnectTimeOut (sysLibTrapCustom + 20)

Definition at line 37 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapSetCookie (sysLibTrapCustom + 61)

Definition at line 78 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapSetCookieMax (sysLibTrapCustom + 60)

Definition at line 77 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapSetCookieMode (sysLibTrapCustom + 59)

Definition at line 76 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapSetCookieX (sysLibTrapCustom + 131)

Definition at line 148 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapSetDefaultHeaders (sysLibTrapCustom + 14)

Definition at line 31 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapSetDNSMaxRetry (sysLibTrapCustom + 66)

Definition at line 83 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapSetDNSRetryInterval (sysLibTrapCustom + 67)

Definition at line 84 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapSetHTTP11OverProxy (sysLibTrapCustom + 16)

Definition at line 33 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapSetHTTPPort (sysLibTrapCustom + 8)

Definition at line 25 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapSetHTTPSPort (sysLibTrapCustom + 9)

Definition at line 26 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapSetMaxKeepAliveTimeout (sysLibTrapCustom + 133)

Definition at line 150 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapSetMaxRequestBody (sysLibTrapCustom + 11)

Definition at line 28 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapSetMaxRequestHeader (sysLibTrapCustom + 10)

Definition at line 27 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapSetNetLibProc (sysLibTrapCustom + 106)

Definition at line 123 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapSetProxy (sysLibTrapCustom + 12)

Definition at line 29 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapSetReqTimeOut (sysLibTrapCustom + 21)

Definition at line 38 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapSetRspTimeOut (sysLibTrapCustom + 22)

Definition at line 39 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapSetSendCookie (sysLibTrapCustom + 19)

Definition at line 36 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapSetSendProxyKeepAlive (sysLibTrapCustom + 18)

Definition at line 35 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapSetSendReferer (sysLibTrapCustom + 17)

Definition at line 34 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapSetSSLClientCertSelectProc (sysLibTrapCustom + 104)

Definition at line 121 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapSetSSLServerCertConfirmProc (sysLibTrapCustom + 102)

Definition at line 119 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapSetSSLVersionFlag (sysLibTrapCustom + 68)

Definition at line 85 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapSetTunnelingCallback (sysLibTrapCustom + 132)

Definition at line 149 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapSetUseProxy (sysLibTrapCustom + 15)

Definition at line 32 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapSetUserAgent (sysLibTrapCustom + 13)

Definition at line 30 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapSetUseragentSelectionRule (sysLibTrapCustom + 141)

Definition at line 158 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapSetUserPass (sysLibTrapCustom + 52)

Definition at line 69 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapSetUserPassX (sysLibTrapCustom + 138)

Definition at line 155 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapSetWakeUpCallback (sysLibTrapCustom + 140)

Definition at line 157 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapSleep sysLibTrapSleep

Definition at line 15 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapSSLClass (sysLibTrapCustom + 3)

Definition at line 20 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapSSLCloseCertDB (sysLibTrapCustom + 71)

Definition at line 88 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapSSLOpenCertDB (sysLibTrapCustom + 70)

Definition at line 87 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapSSLTimeout (sysLibTrapCustom + 69)

Definition at line 86 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapStreamAddHeader (sysLibTrapCustom + 47)

Definition at line 64 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapStreamAddHeaderLine (sysLibTrapCustom + 46)

Definition at line 63 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapStreamClose (sysLibTrapCustom + 36)

Definition at line 53 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapStreamCreateRequest (sysLibTrapCustom + 29)

Definition at line 46 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapStreamCreateRequestWithChunkEncoding (sysLibTrapCustom + 30)

Definition at line 47 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapStreamDelete (sysLibTrapCustom + 28)

Definition at line 45 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapStreamGetContentLength (sysLibTrapCustom + 44)

Definition at line 61 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapStreamGetEntityLength (sysLibTrapCustom + 45)

Definition at line 62 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapStreamGetFlag (sysLibTrapCustom + 35)

Definition at line 52 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapStreamGetHeader (sysLibTrapCustom + 48)

Definition at line 65 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapStreamGetHeaderWithOffset (sysLibTrapCustom + 137)

Definition at line 154 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapStreamGetRequestSent (sysLibTrapCustom + 136)

Definition at line 153 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapStreamGetResponseHeader (sysLibTrapCustom + 43)

Definition at line 60 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapStreamGetResponseHeaderLength (sysLibTrapCustom + 42)

Definition at line 59 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapStreamGetScheme (sysLibTrapCustom + 39)

Definition at line 56 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapStreamGetState (sysLibTrapCustom + 40)

Definition at line 57 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapStreamGetStatusCode (sysLibTrapCustom + 41)

Definition at line 58 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapStreamIsHeaderReceived (sysLibTrapCustom + 37)

Definition at line 54 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapStreamNew (sysLibTrapCustom + 27)

Definition at line 44 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapStreamReceiveResponse (sysLibTrapCustom + 34)

Definition at line 51 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapStreamResumeTimer (sysLibTrapCustom + 134)

Definition at line 151 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapStreamSendRequest (sysLibTrapCustom + 31)

Definition at line 48 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapStreamSendRequestWithChunkEncoding (sysLibTrapCustom + 33)

Definition at line 50 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapStreamSendRequestWithPostData (sysLibTrapCustom + 32)

Definition at line 49 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapStreamSetPostData (sysLibTrapCustom + 38)

Definition at line 55 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapStreamSuspendTimer (sysLibTrapCustom + 135)

Definition at line 152 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapString_Delete (sysLibTrapCustom + 119)

Definition at line 136 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapString_Length (sysLibTrapCustom + 115)

Definition at line 132 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapString_Lock (sysLibTrapCustom + 117)

Definition at line 134 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapString_Unlock (sysLibTrapCustom + 118)

Definition at line 135 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapStringNew (sysLibTrapCustom + 116)

Definition at line 133 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapURLString_Delete (sysLibTrapCustom + 129)

Definition at line 146 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapURLString_Length (sysLibTrapCustom + 125)

Definition at line 142 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapURLString_Lock (sysLibTrapCustom + 127)

Definition at line 144 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapURLString_Unlock (sysLibTrapCustom + 128)

Definition at line 145 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapURLStringNew (sysLibTrapCustom + 126)

Definition at line 143 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapVHandle_Delete (sysLibTrapCustom + 114)

Definition at line 131 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapVHandle_Length (sysLibTrapCustom + 111)

Definition at line 128 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapVHandle_Lock (sysLibTrapCustom + 112)

Definition at line 129 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapVHandle_Unlock (sysLibTrapCustom + 113)

Definition at line 130 of file HS_HTTPLibConst.h.

#define kHTTPLibTrapWake sysLibTrapWake

Definition at line 16 of file HS_HTTPLibConst.h.

Typedef Documentation

typedef enum httpAuthPath_ httpAuthPathEnum

Definition at line 186 of file HS_HTTPLibConst.h.

typedef enum httpAuthTarget_ httpAuthTargetEnum

Definition at line 178 of file HS_HTTPLibConst.h.

typedef enum httpAuthType_ httpAuthTypeEnum

Definition at line 171 of file HS_HTTPLibConst.h.

typedef enum httpCookie_ httpCookieEnum

Definition at line 353 of file HS_HTTPLibConst.h.

typedef enum httpError_ httpErrorEnum

Definition at line 230 of file HS_HTTPLibConst.h.

typedef enum httpHeaderID_ httpHeaderIDEnum

Definition at line 418 of file HS_HTTPLibConst.h.

typedef enum httpHeaderType_ httpHeaderTypeEnum

Definition at line 241 of file HS_HTTPLibConst.h.

typedef enum httpMethod_ httpMethodEnum

Definition at line 291 of file HS_HTTPLibConst.h.

typedef enum httpScheme_ httpSchemeEnum

Definition at line 277 of file HS_HTTPLibConst.h.

typedef enum httpStatusCode_ httpStatusCodeEnum

Definition at line 345 of file HS_HTTPLibConst.h.

typedef enum httpStreamState_ httpStreamStateEnum

Definition at line 269 of file HS_HTTPLibConst.h.

typedef enum httpVersion_ httpVersionEnum

Definition at line 300 of file HS_HTTPLibConst.h.

Enumeration Type Documentation

anonymous enum

Enumerator:
httpCookieClearAtFinalize
httpCookieClearAll
httpCookieClearSessionCookiesOnly

Definition at line 430 of file HS_HTTPLibConst.h.

00431 {
00432     httpCookieClearAtFinalize,
00433     httpCookieClearAll,
00434     httpCookieClearSessionCookiesOnly
00435 };

anonymous enum

Enumerator:
httpDNSModeIPV4Only

Definition at line 437 of file HS_HTTPLibConst.h.

00437      {
00438     httpDNSModeIPV4Only = 0
00439 };

anonymous enum

Enumerator:
httpCetListTypeUnknown
httpCetListTypeServer
httpCetListTypeClient
httpCetListTypeBrowser
httpCetListTypeTypes

Definition at line 441 of file HS_HTTPLibConst.h.

00441      {
00442     httpCetListTypeUnknown = 0,
00443     httpCetListTypeServer,
00444     httpCetListTypeClient,
00445     httpCetListTypeBrowser,
00446     httpCetListTypeTypes
00447 };

enum httpAuthPath_

Enumerator:
httpAuthPathSame
httpAuthPathAncestor
httpAuthPathDescendant
httpAuthPathCousin

Definition at line 180 of file HS_HTTPLibConst.h.

00180                    {
00181     httpAuthPathSame,
00182     httpAuthPathAncestor,
00183     httpAuthPathDescendant,
00184     httpAuthPathCousin
00185 };

enum httpAuthTarget_

Enumerator:
httpAuthTargetPage
httpAuthTargetProxy
httpAuthTargetTargets

Definition at line 173 of file HS_HTTPLibConst.h.

00173                      {
00174     httpAuthTargetPage = 0,
00175     httpAuthTargetProxy,
00176     httpAuthTargetTargets
00177 };

enum httpAuthType_

Enumerator:
httpAuthTypeNone
httpAuthTypeBasic
httpAuthTypeDigest
httpAuthTypeTypes

Definition at line 165 of file HS_HTTPLibConst.h.

00165                    {
00166     httpAuthTypeNone = -1,
00167     httpAuthTypeBasic = 0,
00168     httpAuthTypeDigest,
00169     httpAuthTypeTypes
00170 };

enum httpCookie_

Enumerator:
httpCookieNotifyBeforeSet
httpCookieAlwaysSet
httpCookieNeverSet

Definition at line 348 of file HS_HTTPLibConst.h.

00348                  {
00349     httpCookieNotifyBeforeSet = 0,
00350     httpCookieAlwaysSet,
00351     httpCookieNeverSet
00352 };

enum httpError_

Enumerator:
httpErrorOK
httpErrorGeneric
httpErrorWouldBlock
httpErrorIOSleep
httpErrorNoMem
httpErrorInval
httpErrorDNSInval
httpErrorDNSNoServer
httpErrorDNSTimedout
httpErrorDNSNotFound
httpErrorTCPOpen
httpErrorTCPConnect
httpErrorTCPRead
httpErrorTCPWrite
httpErrorSSLConnect
httpErrorSSLHandShake
httpErrorSSLRead
httpErrorSSLWrite
httpErrorReqTimedout
httpErrorRspTimedout
httpErrorCacheNone
httpErrorCacheExpire
httpErrorAuthUnknown
httpErrorAuthNoHeader
httpErrorAuthFormat
httpErrorRedirectFormat
httpErrorRedirectCanceled
httpErrorReqHeaderSizeOver
httpErrorReqBodySizeOver
httpErrorRspHeaderSizeOver
httpErrorReqTooManyContinue
httpErrorTLSIntolerant

Definition at line 194 of file HS_HTTPLibConst.h.

00194                 {
00195
00196     httpErrorOK             = 0,
00197     httpErrorGeneric        = -1,
00198     httpErrorWouldBlock     = -2,
00199     httpErrorIOSleep        = -3,
00200     httpErrorNoMem          = -6,
00201     httpErrorInval          = -8,
00202
00203     httpErrorDNSInval       = -200,
00204     httpErrorDNSNoServer,
00205     httpErrorDNSTimedout,
00206     httpErrorDNSNotFound,
00207     httpErrorTCPOpen,
00208     httpErrorTCPConnect,
00209     httpErrorTCPRead,
00210     httpErrorTCPWrite,
00211     httpErrorSSLConnect,
00212     httpErrorSSLHandShake,
00213     httpErrorSSLRead,
00214     httpErrorSSLWrite,
00215     httpErrorReqTimedout,
00216     httpErrorRspTimedout,
00217     httpErrorCacheNone,
00218     httpErrorCacheExpire,
00219     httpErrorAuthUnknown,
00220     httpErrorAuthNoHeader,
00221     httpErrorAuthFormat,
00222     httpErrorRedirectFormat,
00223     httpErrorRedirectCanceled,
00224     httpErrorReqHeaderSizeOver, /* method GET */
00225     httpErrorReqBodySizeOver, /* method POST */
00226     httpErrorRspHeaderSizeOver,
00227     httpErrorReqTooManyContinue,
00228     httpErrorTLSIntolerant
00229 };

enum httpHeaderID_

Enumerator:
httpHeaderIDCacheControl
httpHeaderIDConnection
httpHeaderIDDate
httpHeaderIDPragma
httpHeaderIDTrailer
httpHeaderIDTransferEncoding
httpHeaderIDUpgrade
httpHeaderIDVia
httpHeaderIDWarning
httpHeaderIDKeepAlive
httpHeaderIDProxyConnection
httpHeaderIDAccept
httpHeaderIDAcceptCharset
httpHeaderIDAcceptEncoding
httpHeaderIDAcceptLanguage
httpHeaderIDAuthorization
httpHeaderIDExpect
httpHeaderIDFrom
httpHeaderIDHost
httpHeaderIDIfMatch
httpHeaderIDIfModifiedSince
httpHeaderIDIfNoneMatch
httpHeaderIDIfRange
httpHeaderIDIfUnmodifiedSince
httpHeaderIDMaxForwards
httpHeaderIDProxyAuthorization
httpHeaderIDRange
httpHeaderIDReferer
httpHeaderIDTE
httpHeaderIDUserAgent
httpHeaderIDCookie
httpHeaderIDAcceptRanges
httpHeaderIDAge
httpHeaderIDETag
httpHeaderIDLocation
httpHeaderIDProxyAuthenticate
httpHeaderIDRetryAfter
httpHeaderIDServer
httpHeaderIDVary
httpHeaderIDWWWAuthenticate
httpHeaderIDSetCookie
httpHeaderIDAuthenticationInfo
httpHeaderIDProxyAuthenticationInfo
httpHeaderIDAllow
httpHeaderIDContentEncoding
httpHeaderIDContentDisposition
httpHeaderIDContentLanguage
httpHeaderIDContentLength
httpHeaderIDContentLocation
httpHeaderIDContentMD5
httpHeaderIDContentRange
httpHeaderIDContentType
httpHeaderIDExpires
httpHeaderIDLastModified
httpHeaderIDRefresh
httpHeaderIDENUMS

Definition at line 360 of file HS_HTTPLibConst.h.

00360                    {
00361     httpHeaderIDCacheControl,
00362     httpHeaderIDConnection,
00363     httpHeaderIDDate,
00364     httpHeaderIDPragma,
00365     httpHeaderIDTrailer,
00366     httpHeaderIDTransferEncoding,
00367     httpHeaderIDUpgrade,
00368     httpHeaderIDVia,
00369     httpHeaderIDWarning,
00370     httpHeaderIDKeepAlive,
00371     httpHeaderIDProxyConnection,
00372     httpHeaderIDAccept,
00373     httpHeaderIDAcceptCharset,
00374     httpHeaderIDAcceptEncoding,
00375     httpHeaderIDAcceptLanguage,
00376     httpHeaderIDAuthorization,
00377     httpHeaderIDExpect,
00378     httpHeaderIDFrom,
00379     httpHeaderIDHost,
00380     httpHeaderIDIfMatch,
00381     httpHeaderIDIfModifiedSince,
00382     httpHeaderIDIfNoneMatch,
00383     httpHeaderIDIfRange,
00384     httpHeaderIDIfUnmodifiedSince,
00385     httpHeaderIDMaxForwards,
00386     httpHeaderIDProxyAuthorization,
00387     httpHeaderIDRange,
00388     httpHeaderIDReferer,
00389     httpHeaderIDTE,
00390     httpHeaderIDUserAgent,
00391     httpHeaderIDCookie,
00392     httpHeaderIDAcceptRanges,
00393     httpHeaderIDAge,
00394     httpHeaderIDETag,
00395     httpHeaderIDLocation,
00396     httpHeaderIDProxyAuthenticate,
00397     httpHeaderIDRetryAfter,
00398     httpHeaderIDServer,
00399     httpHeaderIDVary,
00400     httpHeaderIDWWWAuthenticate,
00401     httpHeaderIDSetCookie,
00402     httpHeaderIDAuthenticationInfo,
00403     httpHeaderIDProxyAuthenticationInfo,
00404     httpHeaderIDAllow,
00405     httpHeaderIDContentEncoding,
00406     httpHeaderIDContentDisposition,
00407     httpHeaderIDContentLanguage,
00408     httpHeaderIDContentLength,
00409     httpHeaderIDContentLocation,
00410     httpHeaderIDContentMD5,
00411     httpHeaderIDContentRange,
00412     httpHeaderIDContentType,
00413     httpHeaderIDExpires,
00414     httpHeaderIDLastModified,
00415     httpHeaderIDRefresh,
00416     httpHeaderIDENUMS
00417 };

enum httpHeaderType_

Enumerator:
httpHeaderTypeGeneral
httpHeaderTypeRequest
httpHeaderTypeResponse
httpHeaderTypeEntity
httpHeaderTypeOther
httpHeaderTypeTypes

Definition at line 233 of file HS_HTTPLibConst.h.

00233                      {
00234     httpHeaderTypeGeneral = 0,
00235     httpHeaderTypeRequest,
00236     httpHeaderTypeResponse,
00237     httpHeaderTypeEntity,
00238     httpHeaderTypeOther,
00239     httpHeaderTypeTypes
00240 };

enum httpMethod_

Enumerator:
httpMethodOPTIONS
httpMethodGET
httpMethodHEAD
httpMethodPOST
httpMethodPUT
httpMethodDELETE
httpMethodTRACE
httpMethodCONNECT
httpMethodMethods

Definition at line 280 of file HS_HTTPLibConst.h.

00280                  {
00281     httpMethodOPTIONS = 0,
00282     httpMethodGET,
00283     httpMethodHEAD,
00284     httpMethodPOST,
00285     httpMethodPUT,
00286     httpMethodDELETE,
00287     httpMethodTRACE,
00288     httpMethodCONNECT,
00289     httpMethodMethods
00290 };

enum httpScheme_

Enumerator:
httpSchemeHTTP
httpSchemeHTTPS
httpSchemeSchemes

Definition at line 272 of file HS_HTTPLibConst.h.

00272                  {
00273     httpSchemeHTTP = 0,
00274     httpSchemeHTTPS,
00275     httpSchemeSchemes
00276 };

enum httpStatusCode_

Enumerator:
httpStatusCodeContinue
httpStatusCodeSwitchingProtocols
httpStatusCodeOK
httpStatusCodeCreated
httpStatusCodeAccepted
httpStatusCodeNonAuthoritativeInformation
httpStatusCodeNoContent
httpStatusCodeResetContent
httpStatusCodePartialContent
httpStatusCodeMultipleChoices
httpStatusCodeMovedPermanently
httpStatusCodeFound
httpStatusCodeSeeOther
httpStatusCodeNotModified
httpStatusCodeUseProxy
httpStatusCodeTemporaryRedirect
httpStatusCodeBadRequest
httpStatusCodeUnauthorized
httpStatusCodePaymentRequired
httpStatusCodeForbidden
httpStatusCodeNotFound
httpStatusCodeMethodNotAllowed
httpStatusCodeNotAcceptable
httpStatusCodeProxyAuthenticationRequired
httpStatusCodeRequestTimeout
httpStatusCodeConflict
httpStatusCodeGone
httpStatusCodeLengthRequired
httpStatusCodePreconditionFailed
httpStatusCodeRequestEntityTooLarge
httpStatusCodeRequestURITooLarge
httpStatusCodeUnsupportedMediaType
httpStatusCodeRequestedRangeNotSatisfiable
httpStatusCodeExpectationFailed
httpStatusCodeInternalServerError
httpStatusCodeNotImplemented
httpStatusCodeBadGateway
httpStatusCodeServiceUnavailable
httpStatusCodeGatewayTimeout
httpStatusCodeHTTPVersionNotSupported

Definition at line 303 of file HS_HTTPLibConst.h.

00303                      {
00304     httpStatusCodeContinue                          = 100,
00305     httpStatusCodeSwitchingProtocols                = 101,
00306     httpStatusCodeOK                                = 200,
00307     httpStatusCodeCreated                           = 201,
00308     httpStatusCodeAccepted                          = 202,
00309     httpStatusCodeNonAuthoritativeInformation       = 203,
00310     httpStatusCodeNoContent                         = 204,
00311     httpStatusCodeResetContent                      = 205,
00312     httpStatusCodePartialContent                    = 206,
00313     httpStatusCodeMultipleChoices                   = 300,
00314     httpStatusCodeMovedPermanently                  = 301,
00315     httpStatusCodeFound                             = 302,
00316     httpStatusCodeSeeOther                          = 303,
00317     httpStatusCodeNotModified                       = 304,
00318     httpStatusCodeUseProxy                          = 305,
00319     httpStatusCodeTemporaryRedirect                 = 307,
00320     httpStatusCodeBadRequest                        = 400,
00321     httpStatusCodeUnauthorized                      = 401,
00322     httpStatusCodePaymentRequired                   = 402,
00323     httpStatusCodeForbidden                         = 403,
00324     httpStatusCodeNotFound                          = 404,
00325     httpStatusCodeMethodNotAllowed                  = 405,
00326     httpStatusCodeNotAcceptable                     = 406,
00327     httpStatusCodeProxyAuthenticationRequired       = 407,
00328     httpStatusCodeRequestTimeout                    = 408,
00329     httpStatusCodeConflict                          = 409,
00330     httpStatusCodeGone                              = 410,
00331     httpStatusCodeLengthRequired                    = 411,
00332     httpStatusCodePreconditionFailed                = 412,
00333     httpStatusCodeRequestEntityTooLarge             = 413,
00334     httpStatusCodeRequestURITooLarge                = 414,
00335     httpStatusCodeUnsupportedMediaType              = 415,
00336     httpStatusCodeRequestedRangeNotSatisfiable      = 416,
00337     httpStatusCodeExpectationFailed                 = 417,
00338     httpStatusCodeInternalServerError               = 500,
00339     httpStatusCodeNotImplemented                    = 501,
00340     httpStatusCodeBadGateway                        = 502,
00341     httpStatusCodeServiceUnavailable                = 503,
00342     httpStatusCodeGatewayTimeout                    = 504,
00343     httpStatusCodeHTTPVersionNotSupported           = 505
00344 };

enum httpStreamState_

Enumerator:
httpStreamStateNew
httpStreamStateDormant
httpStreamStateReqCreated
httpStreamStateReqResolve
httpStreamStateReqResolving
httpStreamStateReqOpen
httpStreamStateReqConnect
httpStreamStateReqConnecting
httpStreamStateReqProxyConnect
httpStreamStateReqProxyConnecting
httpStreamStateReqSSLHandShaking
httpStreamStateReqSSLHandShaked
httpStreamStateReqSending
httpStreamStateReqSent
httpStreamStateRspHeaderWaiting
httpStreamStateRspContinue
httpStreamStateRspHeaderReceiving
httpStreamStateRspHeaderReceived
httpStreamStateRspEntityReceiving
httpStreamStateRspEntityReceived
httpStreamStateObsolete
httpStreamStateDelete
httpStreamStateStates

Definition at line 244 of file HS_HTTPLibConst.h.

00244                       {
00245     httpStreamStateNew = 0,
00246     httpStreamStateDormant,
00247     httpStreamStateReqCreated,
00248     httpStreamStateReqResolve,
00249     httpStreamStateReqResolving,
00250     httpStreamStateReqOpen,
00251     httpStreamStateReqConnect,
00252     httpStreamStateReqConnecting,
00253     httpStreamStateReqProxyConnect,
00254     httpStreamStateReqProxyConnecting,
00255     httpStreamStateReqSSLHandShaking,
00256     httpStreamStateReqSSLHandShaked,
00257     httpStreamStateReqSending,
00258     httpStreamStateReqSent,
00259     httpStreamStateRspHeaderWaiting,
00260     httpStreamStateRspContinue,
00261     httpStreamStateRspHeaderReceiving,
00262     httpStreamStateRspHeaderReceived,
00263     httpStreamStateRspEntityReceiving,
00264     httpStreamStateRspEntityReceived,
00265     httpStreamStateObsolete,
00266     httpStreamStateDelete,
00267     httpStreamStateStates
00268 };

enum httpVersion_

Enumerator:
httpVersion_0_9
httpVersion_1_0
httpVersion_1_1
httpVersionVersions

Definition at line 294 of file HS_HTTPLibConst.h.

00294                   {
00295     httpVersion_0_9 = 0,
00296     httpVersion_1_0,
00297     httpVersion_1_1,
00298     httpVersionVersions
00299 };

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:07:00 2008 for Palm API Guide


Header Files » Incs » common » system

HsAppLaunchCmd.h File Reference

Detailed Description

Public header file akin to Palm's AppLaunchCmd.h.

Version:
1.0
Date:
04/20/2000

Definition in file HsAppLaunchCmd.h.

Include dependency graph for HsAppLaunchCmd.h:

Go to the source code of this file.

Data Structures

  • struct AddrCallerIDParamsType
  • struct AddrListLookupTypeGetParamsType
  • struct AddrPhonebookAppParamsType
  • struct AddrCreateNewRecordParamsType
  • struct AddrAddToRecordParamsType
  • struct AddrHsLookupUserDataType
  • struct AddrHsLookupUserDataV2Type
  • struct AddrPhotoCallerIDParamsType
  • struct DialPnlIsDialingAvailableParamsType
  • struct DialPnlDispatchDialParamsType
  • struct PhoneAppLaunchCmdDialType
  • struct PhoneAppLaunchCmdSetWallpaperType
  • struct PhoneAppLaunchCmdSendDTMFToneType
  • struct PhoneAppLaunchCmdGetDialPrefFlagType
  • struct PhoneAppLaunchCmdGetALSLineNumberType
  • struct HsDialPrefsUSDialingRulesType
  • struct PhoneAppLaunchCmdCallerIDLookupType
  • struct SoundPrefsLaunchCmdParamType
  • struct webBrowserMinimalModeLaunchInfo
  • struct webBrowserURLWithSvcIDLaunchInfo

Defines

  • #define LaunchWithCommand(type, creator, command, commandParams)
  • #define CallWithCommand(type, creator, command, commandParams)
  • #define addrLookupNoMinLength 1
  • #define AddrHsLookupUserDataVersion 0
  • #define AddrHsLookupUserDataVersion2 1
  • #define phoneAppLaunchCmdDial (sysAppLaunchCmdCustomBase)
  • #define phoneAppLaunchCmdRedial (sysAppLaunchCmdCustomBase+1)
  • #define phoneAppLaunchCmdViewCalls (sysAppLaunchCmdCustomBase+2)
  • #define phoneAppLaunchCmdPowerOn (sysAppLaunchCmdCustomBase+3)
  • #define phoneAppLaunchCmdDialVoiceMail (sysAppLaunchCmdCustomBase+4)
  • #define phoneAppLaunchCmdViewHistory (sysAppLaunchCmdCustomBase+5)
  • #define phoneAppLaunchCmdViewSpeed (sysAppLaunchCmdCustomBase+6)
  • #define phoneAppLaunchCmdViewKeypad (sysAppLaunchCmdCustomBase+7)
  • #define phoneAppLaunchCmdViewPhoneHome (sysAppLaunchCmdCustomBase+8)
  • #define phoneAppLaunchCmdActivation (sysAppLaunchCmdCustomBase+10)
  • #define phoneAppLaunchCmdSetWallpaper (sysAppLaunchCmdCustomBase+11)
  • #define phoneAppLaunchCmdStartNetInitUSSD (sysAppLaunchCmdCustomBase+12)
  • #define phoneAppLaunchCmdDialSTKSETUPCALL (sysAppLaunchCmdCustomBase+13)
  • #define phoneAppLaunchCmdNetworkSearch (sysAppLaunchCmdCustomBase+14)
  • #define phoneAppLaunchCmdSendDTMFTone (sysAppLaunchCmdCustomBase+15)
  • #define phoneAppLaunchCmdViewMissedCalls (sysAppLaunchCmdCustomBase+16)
  • #define phoneAppLaunchCmdDisplayDialPrefs (sysAppLaunchCmdCustomBase+17)
  • #define phoneAppLaunchCmdGetDialPrefFlag (sysAppLaunchCmdCustomBase+18)
  • #define phoneAppLaunchCmdGetUSDialingRules (sysAppLaunchCmdCustomBase+19)
  • #define phoneAppLaunchOptionsMenu (sysAppLaunchCmdCustomBase+20)
  • #define phoneAppLaunchCmdGetALSLineNumber (sysAppLaunchCmdCustomBase+21)
  • #define phoneAppLaunchCmdBluetoothDial (sysAppLaunchCmdCustomBase+22)
  • #define phoneAppLaunchCmdBluetoothDialVoiceMail (sysAppLaunchCmdCustomBase+23)
  • #define phoneAppLaunchCmdCallerIDLookup (sysAppLaunchCmdCustomBase+25)
  • #define phoneAppLaunchCmdRegisterAllViews (sysAppLaunchCmdCustomBase+27)
  • #define hsDialPrefsAutoAreaCodeLength 11
  • #define hsDialPrefs6DigitPrefixLength 11
  • #define hsDialPrefs5DigitPrefixLength 11
  • #define hsDialPrefs4DigitPrefixLength 11
  • #define hsDialPrefsMaxDialingPrefixLength 11
  • #define pmPhoneAppNotifyHomeAppEvent 'pEvt'
  • #define pmPhoneAppNotifySetWallpaper 'pWlp'
  • #define soundPrefsLaunchCmdPhone (sysAppLaunchCmdCustomBase)
  • #define soundPrefsLaunchCmdSMS (sysAppLaunchCmdCustomBase+1)
  • #define soundPrefsLaunchCmdIM (sysAppLaunchCmdCustomBase+2)
  • #define soundPrefsLaunchCmdEmail (sysAppLaunchCmdCustomBase+3)
  • #define soundPrefsLaunchCmdCalendar (sysAppLaunchCmdCustomBase+4)
  • #define soundPrefsLaunchCmdMMS (sysAppLaunchCmdCustomBase+5)
  • #define soundPrefsLaunchCmdGeneral (sysAppLaunchCmdCustomBase+6)
  • #define sysAppLaunchWebBrowserLaunchBookmarkDialog (sysAppLaunchCmdCustomBase)
  • #define sysAppLaunchWebBrowserGetHomePage (sysAppLaunchCmdCustomBase + 1)
  • #define sysAppLaunchWebBrowserSetHomePage (sysAppLaunchCmdCustomBase + 2)
  • #define sysAppLaunchWebBrowserAutoCrawl (sysAppLaunchCmdCustomBase + 3)
  • #define sysAppLaunchWebBrowserTutorialMode (sysAppLaunchCmdCustomBase + 4)
  • #define sysAppLaunchWebBrowserMinimalMode (sysAppLaunchCmdCustomBase + 5)
  • #define sysAppLaunchWebBrowserURLWithSvcID (sysAppLaunchCmdCustomBase + 6)
  • #define cameraAppLaunchCmdStopPreview (sysAppLaunchCmdCustomBase)
  • #define pmNotifyHighPriorityUITask 'pmUT'
  • #define pmNotifyHighPriorityAudioTask 'pmAT'

Typedefs

  • typedef AddrLookupParamsType AddrHsLookupParamsType
  • typedef AddrHsLookupParamsType * AddrHsLookupParamsPtr
  • typedef struct AddrCallerIDParamsType * AddrCallerIDParamsPtr
  • typedef UInt16 AddrListLookupTypeEnum
  • typedef struct AddrPhonebookAppParamsType * AddrPhonebookAppParamsPtr
  • typedef struct AddrCreateNewRecordParamsType * AddrCreateNewRecordParamsPtr
  • typedef struct AddrAddToRecordParamsType * AddrAddToRecordParamsPtr
  • typedef struct AddrHsLookupUserDataType * AddrHsLookupUserDataPtr
  • typedef struct AddrHsLookupUserDataV2Type * AddrHsLookupUserDataV2Ptr
  • typedef struct AddrPhotoCallerIDParamsType * AddrPhotoCallerIDParamsPtr
  • typedef struct PhoneAppLaunchCmdDialType * PhoneAppLaunchCmdDialPtr
  • typedef struct PhoneAppLaunchCmdSetWallpaperType * PhoneAppLaunchCmdSetWallpaperPtr
  • typedef struct PhoneAppLaunchCmdSendDTMFToneType * PhoneAppLaunchCmdSendDTMFTonePtr
  • typedef struct PhoneAppLaunchCmdGetDialPrefFlagType * PhoneAppLaunchCmdGetDialPrefFlagPtr
  • typedef struct PhoneAppLaunchCmdGetALSLineNumberType * PhoneAppLaunchCmdGetALSLineNumberTypePtr
  • typedef struct PhoneAppLaunchCmdCallerIDLookupType PhoneAppLaunchCmdCallerIDLookupPtr
  • typedef struct SoundPrefsLaunchCmdParamType * SoundPrefsLaunchCmdParamPtr

Enumerations

  • enum AddrCustomActionCodes {
    addrAppLaunchCmdHsLookup = sysAppLaunchCmdCustomBase + 0x2300,
    addrAppLaunchCmdCallerID
    }
  • enum AddrCustomNotificationCodes {
    addrAppNotificationHsLookup = sysAppLaunchCmdCustomBase + 0x2300,
    addrAppNotificationCmdCallerID,
    addrAppNotificationPhonebookApp,
    addrAppNotificationListLookupTypeGet = 'HsLL',
    addrAppNotificationCreateNewRecord = 'HsNR',
    addrAppNotificationDialPrefs = 'HsDP',
    addrAppNotificationBeamBusinessCard = 'HsBB',
    addrAppNotificationPhotoCallerID = 'HsPC'
    }
  • enum AddressHsLookupFields {
    addrLookupVoicePhones = 0x70,
    addrLookupAnyPhones,
    addrLookupSMSPhones,
    addrLookupSMSPhonesNoEmail
    }
  • enum {
    addrListLookupTypeLastName,
    addrListLookupTypeFirstName,
    addrListLookupTypeCompany,
    addrListLookupTypeIntelligent
    }
  • enum PhoneAppDialMethodEnum {
    PhoneAppDialMethodNormal = 0,
    PhoneAppDialMethodSATSetupCall,
    PhoneAppDialMethodSATSetupCallModeNotBusy,
    PhoneAppDialMethodSATSetupCallWithRedialModeNotBusy,
    PhoneAppDialMethodSATSetupCallHoldOtherCalls,
    PhoneAppDialMethodSATSetupCallWithRedialHoldOtherCalls,
    PhoneAppDialMethodSATSetupCallDisconnectOtherCalls,
    PhoneAppDialMethodSATSetupCallWithRedialDisconnectOtherCalls
    }
  • enum {
    hsDialPrefsAddAreaCodeUnknown = 0,
    hsDialPrefsAddAreaCodeNo,
    hsDialPrefsAddAreaCodeYes,
    hsDialPrefsAdd4DigitPrefixUnknown,
    hsDialPrefsAdd4DigitPrefixNo,
    hsDialPrefsAdd4DigitPrefixYes,
    hsDialPrefsAdd5DigitPrefixUnknown,
    hsDialPrefsAdd5DigitPrefixNo,
    hsDialPrefsAdd5DigitPrefixYes,
    hsDialPrefsAdd6DigitPrefixUnknown,
    hsDialPrefsAdd6DigitPrefixNo,
    hsDialPrefsAdd6DigitPrefixYes
    }
  • enum SoundPrefsView {
    soundPrefsViewTones,
    soundPrefsViewVolume
    }

Define Documentation

#define AddrHsLookupUserDataVersion 0

Version number of the addrAppNotificationHsLookup command and structures

Definition at line 282 of file HsAppLaunchCmd.h.

#define AddrHsLookupUserDataVersion2 1

Version number of the addrAppNotificationHsLookup command for the V2 structure

Definition at line 297 of file HsAppLaunchCmd.h.

#define addrLookupNoMinLength 1

Flag definitions for AddrCallerIDParamsType flags field If this flag is set, we match numbers that are shorter than the usual minimum required length. We match the *entire* string, not substrings.

Definition at line 172 of file HsAppLaunchCmd.h.

#define CallWithCommand | ( | type,
 |  | creator,
 |  | command,
 |  | commandParams | )

Value:

{ \
    UInt16              cardNo; \
    LocalID             dbID; \
    DmSearchStateType   searchState; \
    UInt32 result; \
    Err err; \
    DmGetNextDatabaseByTypeCreator(true, &searchState, type, \
        creator, true,  &cardNo, &dbID); \
    ErrNonFatalDisplayIf(!dbID, "Could not find db"); \
    if (dbID) \
      { \
        err = SysAppLaunch(cardNo, dbID, 0, command, (Ptr) commandParams, &result); \
        ErrNonFatalDisplayIf(err, "Could not launch db"); \
      } \
  }
internal

Definition at line 80 of file HsAppLaunchCmd.h.

#define cameraAppLaunchCmdStopPreview (sysAppLaunchCmdCustomBase)

Stop any active Camera preview

Definition at line 694 of file HsAppLaunchCmd.h.

#define hsDialPrefs4DigitPrefixLength 11

Definition at line 542 of file HsAppLaunchCmd.h.

#define hsDialPrefs5DigitPrefixLength 11

Definition at line 541 of file HsAppLaunchCmd.h.

#define hsDialPrefs6DigitPrefixLength 11

Definition at line 540 of file HsAppLaunchCmd.h.

#define hsDialPrefsAutoAreaCodeLength 11

MAX Length of the dialing prefixes for 7,6,5 and 4 digit numbers respectively, including zero-terminator.

Definition at line 539 of file HsAppLaunchCmd.h.

#define hsDialPrefsMaxDialingPrefixLength 11

Definition at line 544 of file HsAppLaunchCmd.h.

#define LaunchWithCommand | ( | type,
 |  | creator,
 |  | command,
 |  | commandParams | )

Value:

{ \
    UInt16              cardNo; \
    LocalID             dbID; \
    DmSearchStateType   searchState; \
    Err                     err; \
    DmGetNextDatabaseByTypeCreator(true, &searchState, type, \
        creator, true,  &cardNo, &dbID); \
    ErrNonFatalDisplayIf(!dbID, "Could not find db"); \
    if (dbID) \
      { \
        err = SysUIAppSwitch(cardNo, dbID, command, (Ptr) commandParams); \
        ErrNonFatalDisplayIf(err, "Could not launch db"); \
      } \
  }
Author:
dia
History:8 12-oct-1999 dia - Created by Douglas Anderson 20-apr-2000 dia - New APIs for dialing.

Definition at line 54 of file HsAppLaunchCmd.h.

#define phoneAppLaunchCmdActivation (sysAppLaunchCmdCustomBase+10)

Launch the ## Application

Definition at line 398 of file HsAppLaunchCmd.h.

#define phoneAppLaunchCmdBluetoothDial (sysAppLaunchCmdCustomBase+22)

Definition at line 436 of file HsAppLaunchCmd.h.

#define phoneAppLaunchCmdBluetoothDialVoiceMail (sysAppLaunchCmdCustomBase+23)

Definition at line 439 of file HsAppLaunchCmd.h.

#define phoneAppLaunchCmdCallerIDLookup (sysAppLaunchCmdCustomBase+25)

Definition at line 442 of file HsAppLaunchCmd.h.

#define phoneAppLaunchCmdDial (sysAppLaunchCmdCustomBase)

Launch the phone application and dial the passed number

Definition at line 371 of file HsAppLaunchCmd.h.

#define phoneAppLaunchCmdDialSTKSETUPCALL (sysAppLaunchCmdCustomBase+13)

Launch the phone application and dial the passed number for SATK SETUP CALL

Definition at line 407 of file HsAppLaunchCmd.h.

#define phoneAppLaunchCmdDialVoiceMail (sysAppLaunchCmdCustomBase+4)

Launch the phone application and dial a number

Definition at line 383 of file HsAppLaunchCmd.h.

#define phoneAppLaunchCmdDisplayDialPrefs (sysAppLaunchCmdCustomBase+17)

Display Dial Prefs

Definition at line 421 of file HsAppLaunchCmd.h.

#define phoneAppLaunchCmdGetALSLineNumber (sysAppLaunchCmdCustomBase+21)

Launch the phone application and display the Options menu

Definition at line 433 of file HsAppLaunchCmd.h.

#define phoneAppLaunchCmdGetDialPrefFlag (sysAppLaunchCmdCustomBase+18)

Query for the carrier flag to determine if Dial Prefs menu option should be displyed

Definition at line 424 of file HsAppLaunchCmd.h.

#define phoneAppLaunchCmdGetUSDialingRules (sysAppLaunchCmdCustomBase+19)

Query for the carrier flag to determine if Dial Prefs menu option should be displyed

Definition at line 427 of file HsAppLaunchCmd.h.

#define phoneAppLaunchCmdNetworkSearch (sysAppLaunchCmdCustomBase+14)

Launch the phone application to display the UI to ask the user if they would like to search again.

Definition at line 412 of file HsAppLaunchCmd.h.

#define phoneAppLaunchCmdPowerOn (sysAppLaunchCmdCustomBase+3)

Launch the phone application and prompt to power on the phone

Definition at line 380 of file HsAppLaunchCmd.h.

#define phoneAppLaunchCmdRedial (sysAppLaunchCmdCustomBase+1)

Launch the phone application and dial the last number dialed.

Definition at line 374 of file HsAppLaunchCmd.h.

#define phoneAppLaunchCmdRegisterAllViews (sysAppLaunchCmdCustomBase+27)

Definition at line 445 of file HsAppLaunchCmd.h.

#define phoneAppLaunchCmdSendDTMFTone (sysAppLaunchCmdCustomBase+15)

Launch the phone application and send DTMF tone to the network

Definition at line 415 of file HsAppLaunchCmd.h.

#define phoneAppLaunchCmdSetWallpaper (sysAppLaunchCmdCustomBase+11)

Set the Wallpaper

Definition at line 401 of file HsAppLaunchCmd.h.

#define phoneAppLaunchCmdStartNetInitUSSD (sysAppLaunchCmdCustomBase+12)

Start the Network-initiated USSD

Definition at line 404 of file HsAppLaunchCmd.h.

#define phoneAppLaunchCmdViewCalls (sysAppLaunchCmdCustomBase+2)

Launch the phone application and display the active calls view.

Definition at line 377 of file HsAppLaunchCmd.h.

#define phoneAppLaunchCmdViewHistory (sysAppLaunchCmdCustomBase+5)

Launch the phone application and display the call history view.

Definition at line 386 of file HsAppLaunchCmd.h.

#define phoneAppLaunchCmdViewKeypad (sysAppLaunchCmdCustomBase+7)

Launch the phone application and display the keypad view.

Definition at line 392 of file HsAppLaunchCmd.h.

#define phoneAppLaunchCmdViewMissedCalls (sysAppLaunchCmdCustomBase+16)

Launch the phone application and display missed calls in the call history view.

Definition at line 418 of file HsAppLaunchCmd.h.

#define phoneAppLaunchCmdViewPhoneHome (sysAppLaunchCmdCustomBase+8)

Launch the phone application and display the Phone Home view

Definition at line 395 of file HsAppLaunchCmd.h.

#define phoneAppLaunchCmdViewSpeed (sysAppLaunchCmdCustomBase+6)

Launch the phone application and display the speed dial view.

Definition at line 389 of file HsAppLaunchCmd.h.

#define phoneAppLaunchOptionsMenu (sysAppLaunchCmdCustomBase+20)

Launch the phone application and display the Options menu

Definition at line 430 of file HsAppLaunchCmd.h.

#define pmNotifyHighPriorityAudioTask 'pmAT'

Notification to request stop/pause audio preview/playback. In the event of high priority UI action like an incoming phone call, if the responsible application does not take action the sender of this notification may take appropriate action in order to handle the high priority task

Definition at line 706 of file HsAppLaunchCmd.h.

#define pmNotifyHighPriorityUITask 'pmUT'

Notification to request stop/pause video preview/playback. In the event of high priority UI action like an incoming phone call, if the responsible application does not take action the sender of this notification may take appropriate action in order to handle the high priority task

Definition at line 700 of file HsAppLaunchCmd.h.

#define pmPhoneAppNotifyHomeAppEvent 'pEvt'

This notification is broadcast by the Phone application

Definition at line 602 of file HsAppLaunchCmd.h.

#define pmPhoneAppNotifySetWallpaper 'pWlp'

The parameter for pmPhoneAppNotifyHomeAppEvent notification is of type PhnEventPtr(as defined in HsPhoneEvent.h

Definition at line 606 of file HsAppLaunchCmd.h.

#define soundPrefsLaunchCmdCalendar (sysAppLaunchCmdCustomBase+4)

Launch Sound Prefs in Calendar Prefs view

Definition at line 628 of file HsAppLaunchCmd.h.

#define soundPrefsLaunchCmdEmail (sysAppLaunchCmdCustomBase+3)

Launch Sound Prefs in Email Prefs view

Definition at line 625 of file HsAppLaunchCmd.h.

#define soundPrefsLaunchCmdGeneral (sysAppLaunchCmdCustomBase+6)

Launch Sound Prefs in the General Prefs view

Definition at line 634 of file HsAppLaunchCmd.h.

#define soundPrefsLaunchCmdIM (sysAppLaunchCmdCustomBase+2)

Launch Sound Prefs in IM Prefs view

Definition at line 622 of file HsAppLaunchCmd.h.

#define soundPrefsLaunchCmdMMS (sysAppLaunchCmdCustomBase+5)

Launch Sound Prefs in the MMS Prefs view

Definition at line 631 of file HsAppLaunchCmd.h.

#define soundPrefsLaunchCmdPhone (sysAppLaunchCmdCustomBase)

Launch sounds Prefs in Phone Prefs view

Definition at line 616 of file HsAppLaunchCmd.h.

#define soundPrefsLaunchCmdSMS (sysAppLaunchCmdCustomBase+1)

Launch Sound Prefs in SMS Prefs view

Definition at line 619 of file HsAppLaunchCmd.h.

#define sysAppLaunchWebBrowserAutoCrawl (sysAppLaunchCmdCustomBase + 3)

Launch the browser in autocrawl mode

Definition at line 665 of file HsAppLaunchCmd.h.

#define sysAppLaunchWebBrowserGetHomePage (sysAppLaunchCmdCustomBase + 1)

Retrieve the browser's home page

Definition at line 659 of file HsAppLaunchCmd.h.

#define sysAppLaunchWebBrowserLaunchBookmarkDialog (sysAppLaunchCmdCustomBase)

Launch the browser in the bookmark dialog

Definition at line 656 of file HsAppLaunchCmd.h.

#define sysAppLaunchWebBrowserMinimalMode (sysAppLaunchCmdCustomBase + 5)

Launch the browser in minimal mode

Definition at line 671 of file HsAppLaunchCmd.h.

#define sysAppLaunchWebBrowserSetHomePage (sysAppLaunchCmdCustomBase + 2)

Set the browser's home page

Definition at line 662 of file HsAppLaunchCmd.h.

#define sysAppLaunchWebBrowserTutorialMode (sysAppLaunchCmdCustomBase + 4)

Launch the browser in tips/tutorial mode

Definition at line 668 of file HsAppLaunchCmd.h.

#define sysAppLaunchWebBrowserURLWithSvcID (sysAppLaunchCmdCustomBase + 6)

Definition at line 680 of file HsAppLaunchCmd.h.

Typedef Documentation

typedef struct AddrAddToRecordParamsType * AddrAddToRecordParamsPtr

typedef struct AddrCallerIDParamsType * AddrCallerIDParamsPtr

typedef struct AddrCreateNewRecordParamsType * AddrCreateNewRecordParamsPtr

typedef AddrHsLookupParamsType* AddrHsLookupParamsPtr

Parameter block is the same as OS 3.1's block for sysAppLaunchCmdLookup

Definition at line 148 of file HsAppLaunchCmd.h.

typedef AddrLookupParamsType AddrHsLookupParamsType

Parameter block is the same as OS 3.1's block for sysAppLaunchCmdLookup

Definition at line 145 of file HsAppLaunchCmd.h.

typedef struct AddrHsLookupUserDataType * AddrHsLookupUserDataPtr

typedef struct AddrHsLookupUserDataV2Type * AddrHsLookupUserDataV2Ptr

typedef UInt16 AddrListLookupTypeEnum

AddrListLookupTypeEnum -> UInt16

Definition at line 208 of file HsAppLaunchCmd.h.

typedef struct AddrPhonebookAppParamsType * AddrPhonebookAppParamsPtr

typedef struct AddrPhotoCallerIDParamsType * AddrPhotoCallerIDParamsPtr

typedef struct PhoneAppLaunchCmdCallerIDLookupType PhoneAppLaunchCmdCallerIDLookupPtr

typedef struct PhoneAppLaunchCmdDialType * PhoneAppLaunchCmdDialPtr

typedef struct PhoneAppLaunchCmdGetALSLineNumberType * PhoneAppLaunchCmdGetALSLineNumberTypePtr

typedef struct PhoneAppLaunchCmdGetDialPrefFlagType * PhoneAppLaunchCmdGetDialPrefFlagPtr

typedef struct PhoneAppLaunchCmdSendDTMFToneType * PhoneAppLaunchCmdSendDTMFTonePtr

typedef struct PhoneAppLaunchCmdSetWallpaperType * PhoneAppLaunchCmdSetWallpaperPtr

typedef struct SoundPrefsLaunchCmdParamType * SoundPrefsLaunchCmdParamPtr

Enumeration Type Documentation

anonymous enum

Various address book lookup methods.

Enumerator:
addrListLookupTypeLastName | phone lookup will be by last name...
addrListLookupTypeFirstName | phone lookup will be by first name...
addrListLookupTypeCompany | phone lookup will be by company (currently unused)...
addrListLookupTypeIntelligent | phone lookup will be intelligent (either name or some other matching) (currently unused)...

Definition at line 200 of file HsAppLaunchCmd.h.

00201   {
00202     addrListLookupTypeLastName,           /**< phone lookup will be by last name... */
00203     addrListLookupTypeFirstName,          /**< phone lookup will be by first name... */
00204     addrListLookupTypeCompany,            /**< phone lookup will be by company (currently unused)... */
00205     addrListLookupTypeIntelligent         /**< phone lookup will be intelligent (either name or
00206                                                some other matching) (currently unused)...  */
00207   };

anonymous enum

Data structure that goes with phoneAppLaunchCmdGetUSDialingRules launch cmd

Enumerator:
hsDialPrefsAddAreaCodeUnknown | we don't know yet, so prompt when appropriate
hsDialPrefsAddAreaCodeNo | no auto-area code
hsDialPrefsAddAreaCodeYes | add area code automatically before dialing
hsDialPrefsAdd4DigitPrefixUnknown
hsDialPrefsAdd4DigitPrefixNo
hsDialPrefsAdd4DigitPrefixYes
hsDialPrefsAdd5DigitPrefixUnknown
hsDialPrefsAdd5DigitPrefixNo
hsDialPrefsAdd5DigitPrefixYes
hsDialPrefsAdd6DigitPrefixUnknown
hsDialPrefsAdd6DigitPrefixNo
hsDialPrefsAdd6DigitPrefixYes

Definition at line 518 of file HsAppLaunchCmd.h.

00519   {
00520     hsDialPrefsAddAreaCodeUnknown = 0,    /**< we don't know yet, so prompt when appropriate */
00521     hsDialPrefsAddAreaCodeNo,             /**< no auto-area code */
00522     hsDialPrefsAddAreaCodeYes,            /**< add area code automatically before dialing */
00523
00524     hsDialPrefsAdd4DigitPrefixUnknown, //For 6 digit dialing
00525     hsDialPrefsAdd4DigitPrefixNo,
00526     hsDialPrefsAdd4DigitPrefixYes,
00527
00528     hsDialPrefsAdd5DigitPrefixUnknown,
00529     hsDialPrefsAdd5DigitPrefixNo,
00530     hsDialPrefsAdd5DigitPrefixYes,
00531
00532     hsDialPrefsAdd6DigitPrefixUnknown,
00533     hsDialPrefsAdd6DigitPrefixNo,
00534     hsDialPrefsAdd6DigitPrefixYes
00535   };

enum AddrCustomActionCodes

Launch codes start at customBase + 0x2300 so that hopefully there won't be any conflict with any launch codes that PalmSource or others add to the address book. IMPORTANT: See also AddrCustomNotificationCodes .

Enumerator:
addrAppLaunchCmdHsLookup | Launch Contacts for lookup
addrAppLaunchCmdCallerID | Launch Contacts for callerID lookup

Definition at line 110 of file HsAppLaunchCmd.h.

00111   {
00112     addrAppLaunchCmdHsLookup= sysAppLaunchCmdCustomBase + 0x2300,   /**< Launch Contacts for lookup */
00113     addrAppLaunchCmdCallerID                                        /**< Launch Contacts for callerID lookup */
00114   }

enum AddrCustomNotificationCodes

Switch to using notifications rather than launch codes to avoid potential conflicts if PalmSource modifies the address book app.

Enumerator:
addrAppNotificationHsLookup
addrAppNotificationCmdCallerID
addrAppNotificationPhonebookApp
addrAppNotificationListLookupTypeGet
addrAppNotificationCreateNewRecord
addrAppNotificationDialPrefs
addrAppNotificationBeamBusinessCard
addrAppNotificationPhotoCallerID

Definition at line 119 of file HsAppLaunchCmd.h.

00120   {
00121         // NOTE:
00122         // Shouldn't be using these values!  Notification types are
00123         // supposed to be 4-character creator IDs that are registered in Palm's
00124         // Creator database!  Guess it's a little late now, since these codes are
00125         // out in the field.
00126         addrAppNotificationHsLookup = sysAppLaunchCmdCustomBase + 0x2300,
00127         addrAppNotificationCmdCallerID,
00128         addrAppNotificationPhonebookApp,
00129
00130         // DON'T ADD ANY MORE based on 2300:  See above NOTE
00131
00132         addrAppNotificationListLookupTypeGet = 'HsLL',      // Registered 2001-09-12 w/ Creator DB
00133         addrAppNotificationCreateNewRecord = 'HsNR',        // Registered 2002-07-30 w/ Creator DB
00134         addrAppNotificationDialPrefs = 'HsDP',              // Registered 2003-01-29 w/ Creator DB
00135         addrAppNotificationBeamBusinessCard = 'HsBB',       // Registered 2003-02-14 w/ Creator DB
00136         addrAppNotificationPhotoCallerID = 'HsPC'
00137   }

enum AddressHsLookupFields

Expansion to the Palm OS AddressLookupFields.

Enumerator:
addrLookupVoicePhones | All phone fields except fax and email.
addrLookupAnyPhones | All phone fields (including email)
addrLookupSMSPhones | Mobile, other and email fields
addrLookupSMSPhonesNoEmail | Mobile and other fields

Definition at line 156 of file HsAppLaunchCmd.h.

00156              {
00157     addrLookupVoicePhones=0x70,     /**< All phone fields except fax and email. */
00158     addrLookupAnyPhones ,           /**< All phone fields (including email) */
00159     addrLookupSMSPhones ,           /**< Mobile, other and email fields */
00160     addrLookupSMSPhonesNoEmail      /**< Mobile and other fields */
00161 } AddressHsLookupFields;

enum PhoneAppDialMethodEnum

Phone application dial methods.

Enumerator:
PhoneAppDialMethodNormal | Normal PhnLibDial()
PhoneAppDialMethodSATSetupCall | Use SIM Toolkit and respond affirmative to the SIM's request to set up a call.
PhoneAppDialMethodSATSetupCallModeNotBusy
PhoneAppDialMethodSATSetupCallWithRedialModeNotBusy
PhoneAppDialMethodSATSetupCallHoldOtherCalls
PhoneAppDialMethodSATSetupCallWithRedialHoldOtherCalls
PhoneAppDialMethodSATSetupCallDisconnectOtherCalls
PhoneAppDialMethodSATSetupCallWithRedialDisconnectOtherCalls

Definition at line 452 of file HsAppLaunchCmd.h.

00453   {
00454     PhoneAppDialMethodNormal = 0,     /**< Normal PhnLibDial() */
00455     PhoneAppDialMethodSATSetupCall,   /**< Use SIM Toolkit and respond
00456                                             affirmative to the SIM's request
00457                                             to set up a call. */
00458         // The below codes are added to allow passing of the call setup
00459         // options
00460         PhoneAppDialMethodSATSetupCallModeNotBusy,
00461         PhoneAppDialMethodSATSetupCallWithRedialModeNotBusy,
00462         PhoneAppDialMethodSATSetupCallHoldOtherCalls,
00463         PhoneAppDialMethodSATSetupCallWithRedialHoldOtherCalls,
00464         PhoneAppDialMethodSATSetupCallDisconnectOtherCalls,
00465         PhoneAppDialMethodSATSetupCallWithRedialDisconnectOtherCalls,
00466   }

enum SoundPrefsView

Different sound pref dialog views.

Enumerator:
soundPrefsViewTones
soundPrefsViewVolume

Definition at line 637 of file HsAppLaunchCmd.h.

00638 {
00639   soundPrefsViewTones,
00640   soundPrefsViewVolume
00641 } SoundPrefsView;

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:07:01 2008 for Palm API Guide


Header Files » Incs » common » system

HsChars.h File Reference

Detailed Description

Definitions of Handspring's character codes. (see Palm's Chars.h)

Copyright (c) 2002 Handspring Inc., All Rights Reserved

Id
//device/handheld/dev/sdk/2.2.2/incs/common/system/HsChars.h#3

Definition in file HsChars.h.

Go to the source code of this file.

Defines

  • #define hsChrRangeMin 0x1600
  • #define hsChrRangeMax 0x16FF
  • #define hsChrNoop 0x1607
  • #define hsChrSymbol 0x1609
  • #define hsChrPostProcess hsChrSymbol
  • #define hsChrAnswer 0x160A
  • #define hsChrLidStatusChg 0x160B
  • #define hsChrRadioPower 0x160C
  • #define hsChrModifierKey 0x160D
  • #define hsChrShiftPageUp 0x160E
  • #define hsChrShiftPageDown 0x160F
  • #define hsChrShutdownNetlib 0x1610
  • #define hsChrMuteOn 0x1611
  • #define hsChrMuteOff 0x1612
  • #define hsChrOptHard1 vchrHard5
  • #define hsChrOptHard2 vchrHard6
  • #define hsChrOptHard3 vchrHard7
  • #define hsChrOptHard4 vchrHard8
  • #define hsChrOptHardPower vchrHard9
  • #define hsChrOptReserved vchrHard10
  • #define hsChrOptHard11 vchrHard12
  • #define hsChrOptHard13 vchrHard14
  • #define hsChrWakeup 0x1618
  • #define hsChrKeyboardLock 0x1619
  • #define hsChrDeleteWord 0x161A
  • #define hsChrVolumeUp 0x161B
  • #define hsChrVolumeDown 0x161C
  • #define hsChrNetMasterUIExecute 0x161D
  • #define hsChrLowBatteryShutdown 0x161E
  • #define hsChrSide 0x161F
  • #define hsChrDarkMode 0x1620
  • #define hsChrRedialList 0x1621
  • #define hsChrReserved1622 0x1622
  • #define vchrHard11 0x021A
  • #define vchrHard12 0x021B
  • #define vchrHard13 0x021C
  • #define vchrHard14 0x021D

Define Documentation

#define hsChrAnswer 0x160A

Definition at line 60 of file HsChars.h.

#define hsChrDarkMode 0x1620

Definition at line 140 of file HsChars.h.

#define hsChrDeleteWord 0x161A

Definition at line 118 of file HsChars.h.

#define hsChrKeyboardLock 0x1619

Definition at line 115 of file HsChars.h.

#define hsChrLidStatusChg 0x160B

Definition at line 63 of file HsChars.h.

#define hsChrLowBatteryShutdown 0x161E

Definition at line 134 of file HsChars.h.

#define hsChrModifierKey 0x160D

Definition at line 69 of file HsChars.h.

#define hsChrMuteOff 0x1612

Definition at line 82 of file HsChars.h.

#define hsChrMuteOn 0x1611

Definition at line 81 of file HsChars.h.

#define hsChrNetMasterUIExecute 0x161D

Definition at line 126 of file HsChars.h.

#define hsChrNoop 0x1607

Definition at line 49 of file HsChars.h.

#define hsChrOptHard1 vchrHard5

Definition at line 93 of file HsChars.h.

#define hsChrOptHard11 vchrHard12

Definition at line 99 of file HsChars.h.

#define hsChrOptHard13 vchrHard14

Definition at line 100 of file HsChars.h.

#define hsChrOptHard2 vchrHard6

Definition at line 94 of file HsChars.h.

#define hsChrOptHard3 vchrHard7

Definition at line 95 of file HsChars.h.

#define hsChrOptHard4 vchrHard8

Definition at line 96 of file HsChars.h.

#define hsChrOptHardPower vchrHard9

Definition at line 97 of file HsChars.h.

#define hsChrOptReserved vchrHard10

Definition at line 98 of file HsChars.h.

#define hsChrPostProcess hsChrSymbol

Definition at line 57 of file HsChars.h.

#define hsChrRadioPower 0x160C

Definition at line 66 of file HsChars.h.

#define hsChrRangeMax 0x16FF

Definition at line 27 of file HsChars.h.

#define hsChrRangeMin 0x1600

Definition at line 26 of file HsChars.h.

#define hsChrRedialList 0x1621

Definition at line 143 of file HsChars.h.

#define hsChrReserved1622 0x1622

Definition at line 146 of file HsChars.h.

#define hsChrShiftPageDown 0x160F

Definition at line 75 of file HsChars.h.

#define hsChrShiftPageUp 0x160E

Definition at line 72 of file HsChars.h.

#define hsChrShutdownNetlib 0x1610

Definition at line 78 of file HsChars.h.

#define hsChrSide 0x161F

Definition at line 137 of file HsChars.h.

#define hsChrSymbol 0x1609

Definition at line 56 of file HsChars.h.

#define hsChrVolumeDown 0x161C

Definition at line 122 of file HsChars.h.

#define hsChrVolumeUp 0x161B

Definition at line 121 of file HsChars.h.

#define hsChrWakeup 0x1618

Definition at line 111 of file HsChars.h.

#define vchrHard11 0x021A

Definition at line 153 of file HsChars.h.

#define vchrHard12 0x021B

Definition at line 157 of file HsChars.h.

#define vchrHard13 0x021C

Definition at line 161 of file HsChars.h.

#define vchrHard14 0x021D

Definition at line 165 of file HsChars.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:07:01 2008 for Palm API Guide


Header Files » Incs » common

HsCommon.h File Reference

Detailed Description

Version:
1.0
Date:
Main Handspring Palm OS API Header file

Most functions or API's are specific to either the 68K environment or the ARM environment but both of them sometimes share the same structures, types, constants etc.. The common header files are for those shared components that are used by both the 68K and ARM parts of a library, extention etc. In general, a developer would never have to include this file seperataely. It is already included in both the 68K/Hs.h and the ARM/Hs.h.

Note: (11-Feb-2008) ARM include files are not in the general release.

Author:
Kiran Prasad

Definition in file HsCommon.h.

Include dependency graph for HsCommon.h:

Go to the source code of this file.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:07:01 2008 for Palm API Guide


Header Files » Incs » common » system

HsCreators.h File Reference

Detailed Description

Public header file for the creator IDs used by Handspring.

Version:
1.0
Date:
01/08/2000

Definition in file HsCreators.h.

Go to the source code of this file.

Defines

  • #define hsFileCLangSpoofer 'HsLS'
  • #define hsFileCAddrTester 'HsAT'
  • #define hsFileCMailWrapper 'HsMW'
  • #define hsFileCUsbTester 'HsU2'
  • #define hsFileCPhoneWrapper 'HsPW'
  • #define hsFileCSetMem 'Hssm'
  • #define hsFileCSerialCoupler 'Hssc'
  • #define hsFileCUartCoupler 'Hsuc'
  • #define hsFileCSpringWriter 'Hss1'
  • #define hsFileCUsbResetTest 'Hsur'
  • #define hsFileCGasTest 'Hsgt'
  • #define hsFileCIsolateMemoryChip 'Isom'
  • #define hsFileCCameraTest 'HsZZ'
  • #define hsFileCUseSerial 'HSUS'
  • #define hsFileCTraceViewer 'HsTV'
  • #define hsFileCPmUIUtilLibTest 'PmUT'
  • #define hsFileTCardSetup 'HsSU'
  • #define hsFileTCardSetupShell 'HApp'
  • #define hsFileTSndFile 'SndF'
  • #define hsFileCAutomaticHelper 'Auto'
  • #define hsFileCPhoneServicesPanel 'hsPS'
  • #define hsFileCLCDAdjustPanel 'HsLA'
  • #define hsFileCMultiChannelRingToneDB 'MCnl'
  • #define hsFileCDefaultAppsPanel 'HsDH'
  • #define hsFileCButtonPrefsPanel 'HsBt'
  • #define hsFileCHandspringPalmOSUpdate 'Hspt'
  • #define hsFileCHandspringSystemResource 'HsSr'
  • #define hsFileTHandspringHal 'HwAl'
  • #define hsFileTHandspringPatch 'HsPt'
  • #define hsFileTHandspringUIObj 'HsUi'
  • #define hsFileCHandspringExt 'HsEx'
  • #define hsFileCNavExt 'HsEp'
  • #define hsFileCModemMgrExt 'HsMM'
  • #define hsFileCDataMgrExt 'HsDM'
  • #define hsFileCProgressMgrExt 'HsPM'
  • #define hsFileCUIExt 'HsUI'
  • #define hsFileTCodeSeg 'CSeg'
  • #define hsFileCFFSInfoTok1 'Ffs1'
  • #define hsFileCFfsCrType 'Ffs2'
  • #define hsFileCCardAccessTime 'HsAT'
  • #define hsFileCCardWelcomeDuringReset 'HsWR'
  • #define hsFileCCardWelcomeAppTypeCreator 'HsWT'
  • #define hsFileCSmartSmallromToken 'HsSR'
  • #define hsFileCBuiltinHsExtToken 'HsHX'
  • #define hsBluetoothIdToken 'BTid'
  • #define htcManufacturingInfoToken 'HTCM'
  • #define pmLimitLocaleToken 'LLid'
  • #define pmDebugLockoutToken 'Dblk'
  • #define pmTSCalToken 'TScb'
  • #define pmKbdLayoutToken 'KBlo'
  • #define pmTSTokenValidToken 'TStv'
  • #define hsFileTModemSetupPatch 'HsMp'
  • #define hsCompressedDbCreatorId 'Lz7C'
  • #define hsCompressedDbTypeId 'Lz7C'
  • #define hsKbdLayoutDbTypeCreator 'KbLy'
  • #define hsFileCTextEncodingConverterLib 'TecL'
  • #define hsFileCTextEncodingConverterTable 'TecD'
  • #define hsRscTextEncodingConverterTable 'TecT'
  • #define hsFileCPowerKey '000P'
  • #define hsFileCKeyguard 'kLoc'
  • #define pmSlotDriverActivityIndicator 'PmAI'
  • #define pmROMTokenWrite 'TOKw'
  • #define pmROMTokenRead 'TOKr'
  • #define hsNotifyRemSleepRequestEvent 'REMq'
  • #define hsNotifyRemSleepEvent 'REMs'
  • #define hsNotifySetInitialFldStateEvent 'HsFg'
  • #define pmNotifyGetNewMsgCountFromHelper 'gMgC'
  • #define pmNotifyBroadcastNewMsgCount 'bMgC'
  • #define pmNotifyBrightModeKeyEvent 'PmBM'
  • #define pmNotifyTraceSettingsChangedEvent (hsFileCTraceViewer)
  • #define hsRscTKbdChrLookupData 'HsKb'
  • #define hsRscKbdChrDataID 2000
  • #define hsRscKbdChrShiftDataID 2001
  • #define hsRscKbdChrOptDataID 2002
  • #define hsRscTKbdKeyCodeLookupData 'HsKc'
  • #define hsRscKbdKeyCodeDataID 2000
  • #define hsRscTPostProcessLists 'HsPp'
  • #define hsRscTNavFocusColor 'HsFc'
  • #define hsRscTutorial 'HsTM'
  • #define exFileCArcSoftCamera 'CmLo'
  • #define exFileCArcSoftMedia 'Foto'
Misc. App Creator IDs
  • #define hsFileCAdvCalculator 'HsPr'
  • #define hsFileCCardSetup 'HsCd'
  • #define hsFileCSampleCardWelcome 'CWel'
  • #define hsFileCHandTerminal 'HTrm'
  • #define hsFileCFileMover 'FlMv'
  • #define hsFileCFileInstaller 'FlIn'
  • #define hsFileCDateBook3H 'HsDB'
  • #define hsFileCBackup 'HsBk'
  • #define hsFileCBackupWelcome 'HsBw'
Phone App Creator IDs
  • #define hsFileCPhone 'HsPh'
  • #define hsFileCPhone2 'HsP2'
  • #define hsFileCPhoneStub68k 'Pm68'
  • #define hsFileCPhoneMainView 'PmPm'
  • #define hsFileCPhoneDialPadView 'PmPd'
  • #define hsFileCPhonePeopleView 'PmPp'
  • #define hsFileCPhoneFavoritesView 'PmPf'
  • #define hsFileCPhoneCallLogView 'PmPl'
  • #define hsFileCPhoneActiveCallView 'PmPa'
  • #define hsFileCPhoneIncomingCallView 'PmPi'
  • #define hsFileCPhoneAppFavoritesLibrary 'PmPF'
  • #define hsFileCPhoneTips 'PhTp'
  • #define hsFileCPhoneSecurity 'HsSE'
  • #define hsFileCPhoneWizard 'HsPw'
  • #define hsFileCPhoneRingerPanel 'HsRN'
  • #define hsFileCDisplayPanel 'HsDs'
  • #define hsFileCKeyguardPanel 'HsKg'
  • #define hsFileCSMS 'SMSh'
  • #define hsFileCSimPhoneBook 'HsPB'
  • #define hsFileCSimServices 'HsSS'
  • #define hsFileCIM 'HsIM'
  • #define hsFileCSmartTextEngine 'HsST'
  • #define hsFileCTexter 'HsCh'
  • #define hsFileCMessageStore 'HsMS'
  • #define hsFileSMSTreoTransport 'Trn0'
  • #define hsFileMMSTreoTransport 'Trn1'
  • #define hsFileSMSPalmTransport 'Trn2'
  • #define hsFileMMSPalmTransport 'Trn3'
  • #define hsFilePhoneBluetoothConnect 'PhBt'
Misc. App Creator IDs
  • #define hsFileCImagine 'HsIm'
  • #define hsFileCAddrBookExtensions 'HsAX'
  • #define hsFileCDialingPanel 'HsDi'
  • #define hsFileCAddrBookOneFingerMode 'HsAl'
  • #define hsFileCPinballGame 'HsPg'
  • #define hsFileCSetISP 'HsJS'
Web Browser Creator IDs
  • #define hsFileCBlazer 'BLZ1'
  • #define hsFileCBlazer3 'BLZ5'
  • #define hsFileCBlazer3TutorialLauncher 'HsTM'
  • #define hsFileCBlazer3TipsSharedContent 'HsSC'
Misc. App Creator IDs
  • #define hsFileCCityTime 'CiAa'
  • #define hsFileCKeyboardDemo 'kDem'
  • #define hsFileCFirmwareUpdater 'HsFU'
  • #define hsFileCGPRSUpdater 'HsGU'
  • #define hsFileCRomUpdater 'hROM'
  • #define hsFileCCDMAUpdater 'HsCU'
  • #define hsFileCCDMAActivation 'HsAc'
  • #define hsFileCGSMActivation 'HsGA'
  • #define hsFileCIOTA 'Iota'
  • #define hsTetheredTreo 'HsTt'
  • #define hsFileCDebugPrefs 'hsCn'
  • #define hsFileCCamera 'Bcam'
  • #define hsFileCCameraTips 'BcTp'
  • #define hsFileCDuoHack 'DuHk'
  • #define hsFileCTutorialContent 'TMTp'
  • #define hsFileCEmailTipsContent 'HsTC'
  • #define hsFileCNavSample 'HsNS'
  • #define hsFileCSave2Card 'HsSD'
  • #define hsFileCBrightness 'brtP'
  • #define hsFileCGettingStartedApp 'GSGa'
Library Creator IDs
  • #define hsFileCSampleSerLib 'HsCs'
  • #define hsFileCTaskLib 'HsTS'
  • #define hsFileCFfsCSegLib 'FfMg'
  • #define hsFileCLdbMgr 'HsLm'
  • #define hsFileCModemSerLib 'HsMs'
  • #define hsFileCFlMgr 'FLMG'
  • #define hsFileCFluMgr 'FlMg'
  • #define hsFileCHwmCSegLib 'Hhwm'
  • #define hsFileCCDMAPhoneLib 'HsCL'
  • #define hsFileCCDMAMsgLib 'HsMg'
  • #define hsFileCGSMPhoneLib 'GSM!'
  • #define GSMLibRingsDBCreatorID 'GSMr'
  • #define hsFileCTransparencyLib 'HsTL'
  • #define hsFileCComChannelProvider 'HsCP'
  • #define hsFileSMSExchangeLib 'HsSX'
  • #define hsFileCFakeNetLib 'netl'
  • #define hsFileCPatchedNetLib 'netb'
  • #define hsFileCameraLib 'HsCa'
  • #define hsFileCARMTelephonyWrapper 'PIL!'
  • #define hsFileCTelephonyInterfaceLayer 'TIL!'
  • #define hsFileCCodecWrapper 'CdWr'
  • #define hsFileBrowserCoreLib 'AcBC'
  • #define hsFileSoundLib 'HsAu'
  • #define hsAmrLib 'AMRL'
  • #define hsAmrEncLib 'AENL'
  • #define hsAmrDecLib 'ADEL'
  • #define hsFileCMCLLib 'MCLL'
  • #define pmFileCKeyLib 'PmKe'
  • #define pmFileCUIUtilLib 'PmUU'
  • #define pmFileCSystemLib 'PmSy'
  • #define pmFileCSysGadgetLib 'PmSg'
  • #define hsFileCSerLib 'A8xZ'
  • #define hsFileCModuleSerLib 'HsSs'
  • #define hsFileCVirtualModemSerLib 'FakM'
  • #define hsFileCVirtualGSMSerLib 'VGSM'
  • #define hsFileCDirectRadioSerLib 'DirR'
  • #define hsFileCHsSerWrapperLib 'Hssw'
  • #define hsFileSPI1SerLib 'HsSp'
  • #define hsFileCHsSSLLib109a 'hSSL'
  • #define hsFileCUsbLib 'HsUs'
  • #define hsFileCSerDrvrUSBConsole 'HsUc'
  • #define hsFileCSerDrvrUSBDesktop 'HsUd'
  • #define hsFileCSerDrvrUSBRemFS 'HsUr'
  • #define hsFileCSerDrvrUSBGeneric 'HsUg'
  • #define hsFileCSerDrvrUSBGeneric2 'HsUh'
  • #define hsFileCSerDrvrAuto 'HsSA'
  • #define hsFileCSerDrvrCradle 'HsCS'
  • #define hsFileCSDLib 'Hssd'
  • #define hsFileCCCLib 'CCLb'
  • #define hsFileCOldGrfLib 'HsGf'
  • #define hsFileCTonesLib 'HsTo'
facebook Creator IDs
  • #define hsFileCFacebook 'FcBk'
  • #define hsFileCFacebookStub68k 'Fc68'
  • #define hsFileCFacebookHomeView 'PmFh'
  • #define hsFileCFacebookPhotosView 'PmFp'
  • #define hsFileCFacebookContactsView 'PmFc'
  • #define hsFileCFacebookMeView 'PmFm'
  • #define hsFileCFacebookMessageView 'PmFM'
  • #define hsFileCFacebookTips 'FbTp'

Define Documentation

#define exFileCArcSoftCamera 'CmLo'

Definition at line 646 of file HsCreators.h.

#define exFileCArcSoftMedia 'Foto'

Definition at line 648 of file HsCreators.h.

#define GSMLibRingsDBCreatorID 'GSMr'

Definition at line 301 of file HsCreators.h.

#define hsAmrDecLib 'ADEL'

Definition at line 327 of file HsCreators.h.

#define hsAmrEncLib 'AENL'

Definition at line 326 of file HsCreators.h.

#define hsAmrLib 'AMRL'

Definition at line 325 of file HsCreators.h.

#define hsBluetoothIdToken 'BTid'

Definition at line 434 of file HsCreators.h.

#define hsCompressedDbCreatorId 'Lz7C'

Definition at line 474 of file HsCreators.h.

#define hsCompressedDbTypeId 'Lz7C'

Definition at line 475 of file HsCreators.h.

#define hsFileBrowserCoreLib 'AcBC'

Definition at line 322 of file HsCreators.h.

#define hsFileCAddrBookExtensions 'HsAX'

Definition at line 139 of file HsCreators.h.

#define hsFileCAddrBookOneFingerMode 'HsAl'

Definition at line 141 of file HsCreators.h.

#define hsFileCAddrTester 'HsAT'

Definition at line 194 of file HsCreators.h.

#define hsFileCAdvCalculator 'HsPr'

Definition at line 78 of file HsCreators.h.

#define hsFileCameraLib 'HsCa'

Definition at line 316 of file HsCreators.h.

#define hsFileCARMTelephonyWrapper 'PIL!'

Definition at line 318 of file HsCreators.h.

#define hsFileCAutomaticHelper 'Auto'

Definition at line 221 of file HsCreators.h.

#define hsFileCBackup 'HsBk'

Definition at line 91 of file HsCreators.h.

#define hsFileCBackupWelcome 'HsBw'

Definition at line 92 of file HsCreators.h.

#define hsFileCBlazer 'BLZ1'

Definition at line 151 of file HsCreators.h.

#define hsFileCBlazer3 'BLZ5'

Definition at line 152 of file HsCreators.h.

#define hsFileCBlazer3TipsSharedContent 'HsSC'

Definition at line 154 of file HsCreators.h.

#define hsFileCBlazer3TutorialLauncher 'HsTM'

Definition at line 153 of file HsCreators.h.

#define hsFileCBrightness 'brtP'

Definition at line 187 of file HsCreators.h.

#define hsFileCBuiltinHsExtToken 'HsHX'

Definition at line 430 of file HsCreators.h.

#define hsFileCButtonPrefsPanel 'HsBt'

Definition at line 236 of file HsCreators.h.

#define hsFileCCamera 'Bcam'

Definition at line 180 of file HsCreators.h.

#define hsFileCCameraTest 'HsZZ'

Definition at line 205 of file HsCreators.h.

#define hsFileCCameraTips 'BcTp'

Definition at line 181 of file HsCreators.h.

#define hsFileCCardAccessTime 'HsAT'

Definition at line 416 of file HsCreators.h.

#define hsFileCCardSetup 'HsCd'

Definition at line 79 of file HsCreators.h.

#define hsFileCCardWelcomeAppTypeCreator 'HsWT'

Definition at line 422 of file HsCreators.h.

#define hsFileCCardWelcomeDuringReset 'HsWR'

Definition at line 419 of file HsCreators.h.

#define hsFileCCCLib 'CCLb'

Definition at line 384 of file HsCreators.h.

#define hsFileCCDMAActivation 'HsAc'

Definition at line 171 of file HsCreators.h.

#define hsFileCCDMAMsgLib 'HsMg'

Definition at line 297 of file HsCreators.h.

#define hsFileCCDMAPhoneLib 'HsCL'

Definition at line 295 of file HsCreators.h.

#define hsFileCCDMAUpdater 'HsCU'

Definition at line 169 of file HsCreators.h.

#define hsFileCCityTime 'CiAa'

Definition at line 161 of file HsCreators.h.

#define hsFileCCodecWrapper 'CdWr'

Definition at line 320 of file HsCreators.h.

#define hsFileCComChannelProvider 'HsCP'

Definition at line 305 of file HsCreators.h.

#define hsFileCDataMgrExt 'HsDM'

Definition at line 264 of file HsCreators.h.

#define hsFileCDateBook3H 'HsDB'

Definition at line 89 of file HsCreators.h.

#define hsFileCDebugPrefs 'hsCn'

Definition at line 178 of file HsCreators.h.

#define hsFileCDefaultAppsPanel 'HsDH'

Definition at line 234 of file HsCreators.h.

#define hsFileCDialingPanel 'HsDi'

Definition at line 140 of file HsCreators.h.

#define hsFileCDirectRadioSerLib 'DirR'

Definition at line 356 of file HsCreators.h.

#define hsFileCDisplayPanel 'HsDs'

Definition at line 114 of file HsCreators.h.

#define hsFileCDuoHack 'DuHk'

Definition at line 182 of file HsCreators.h.

#define hsFileCEmailTipsContent 'HsTC'

Definition at line 184 of file HsCreators.h.

#define hsFileCFacebook 'FcBk'

Definition at line 654 of file HsCreators.h.

#define hsFileCFacebookContactsView 'PmFc'

Definition at line 658 of file HsCreators.h.

#define hsFileCFacebookHomeView 'PmFh'

Definition at line 656 of file HsCreators.h.

#define hsFileCFacebookMessageView 'PmFM'

Definition at line 660 of file HsCreators.h.

#define hsFileCFacebookMeView 'PmFm'

Definition at line 659 of file HsCreators.h.

#define hsFileCFacebookPhotosView 'PmFp'

Definition at line 657 of file HsCreators.h.

#define hsFileCFacebookStub68k 'Fc68'

Definition at line 655 of file HsCreators.h.

#define hsFileCFacebookTips 'FbTp'

Definition at line 661 of file HsCreators.h.

#define hsFileCFakeNetLib 'netl'

Definition at line 309 of file HsCreators.h.

#define hsFileCFfsCrType 'Ffs2'

Definition at line 404 of file HsCreators.h.

#define hsFileCFfsCSegLib 'FfMg'

Definition at line 281 of file HsCreators.h.

#define hsFileCFFSInfoTok1 'Ffs1'

Definition at line 398 of file HsCreators.h.

#define hsFileCFileInstaller 'FlIn'

Definition at line 87 of file HsCreators.h.

#define hsFileCFileMover 'FlMv'

Definition at line 85 of file HsCreators.h.

#define hsFileCFirmwareUpdater 'HsFU'

Definition at line 166 of file HsCreators.h.

#define hsFileCFlMgr 'FLMG'

Definition at line 289 of file HsCreators.h.

#define hsFileCFluMgr 'FlMg'

Definition at line 291 of file HsCreators.h.

#define hsFileCGasTest 'Hsgt'

Definition at line 203 of file HsCreators.h.

#define hsFileCGettingStartedApp 'GSGa'

Definition at line 188 of file HsCreators.h.

#define hsFileCGPRSUpdater 'HsGU'

Definition at line 167 of file HsCreators.h.

#define hsFileCGSMActivation 'HsGA'

Definition at line 173 of file HsCreators.h.

#define hsFileCGSMPhoneLib 'GSM!'

Definition at line 299 of file HsCreators.h.

#define hsFileCHandspringExt 'HsEx'

Definition at line 261 of file HsCreators.h.

#define hsFileCHandspringPalmOSUpdate 'Hspt'

Definition at line 243 of file HsCreators.h.

#define hsFileCHandspringSystemResource 'HsSr'

Definition at line 246 of file HsCreators.h.

#define hsFileCHandTerminal 'HTrm'

Definition at line 83 of file HsCreators.h.

#define hsFileCHsSerWrapperLib 'Hssw'

Definition at line 358 of file HsCreators.h.

#define hsFileCHsSSLLib109a 'hSSL'

Definition at line 362 of file HsCreators.h.

#define hsFileCHwmCSegLib 'Hhwm'

Definition at line 293 of file HsCreators.h.

#define hsFileCIM 'HsIM'

Definition at line 120 of file HsCreators.h.

#define hsFileCImagine 'HsIm'

Definition at line 137 of file HsCreators.h.

#define hsFileCIOTA 'Iota'

Definition at line 175 of file HsCreators.h.

#define hsFileCIsolateMemoryChip 'Isom'

Definition at line 204 of file HsCreators.h.

#define hsFileCKeyboardDemo 'kDem'

Definition at line 164 of file HsCreators.h.

#define hsFileCKeyguard 'kLoc'

Definition at line 487 of file HsCreators.h.

#define hsFileCKeyguardPanel 'HsKg'

Definition at line 115 of file HsCreators.h.

#define hsFileCLangSpoofer 'HsLS'

Definition at line 193 of file HsCreators.h.

#define hsFileCLCDAdjustPanel 'HsLA'

Definition at line 230 of file HsCreators.h.

#define hsFileCLdbMgr 'HsLm'

Definition at line 284 of file HsCreators.h.

#define hsFileCMailWrapper 'HsMW'

Definition at line 195 of file HsCreators.h.

#define hsFileCMCLLib 'MCLL'

Definition at line 329 of file HsCreators.h.

#define hsFileCMessageStore 'HsMS'

Definition at line 125 of file HsCreators.h.

#define hsFileCModemMgrExt 'HsMM'

Definition at line 263 of file HsCreators.h.

#define hsFileCModemSerLib 'HsMs'

Definition at line 287 of file HsCreators.h.

#define hsFileCModuleSerLib 'HsSs'

Definition at line 349 of file HsCreators.h.

#define hsFileCMultiChannelRingToneDB 'MCnl'

Definition at line 232 of file HsCreators.h.

#define hsFileCNavExt 'HsEp'

Definition at line 262 of file HsCreators.h.

#define hsFileCNavSample 'HsNS'

Definition at line 185 of file HsCreators.h.

#define hsFileCOldGrfLib 'HsGf'

Definition at line 386 of file HsCreators.h.

#define hsFileCPatchedNetLib 'netb'

Definition at line 312 of file HsCreators.h.

#define hsFileCPhone 'HsPh'

Definition at line 99 of file HsCreators.h.

#define hsFileCPhone2 'HsP2'

Definition at line 100 of file HsCreators.h.

#define hsFileCPhoneActiveCallView 'PmPa'

Definition at line 107 of file HsCreators.h.

#define hsFileCPhoneAppFavoritesLibrary 'PmPF'

Definition at line 109 of file HsCreators.h.

#define hsFileCPhoneCallLogView 'PmPl'

Definition at line 106 of file HsCreators.h.

#define hsFileCPhoneDialPadView 'PmPd'

Definition at line 103 of file HsCreators.h.

#define hsFileCPhoneFavoritesView 'PmPf'

Definition at line 105 of file HsCreators.h.

#define hsFileCPhoneIncomingCallView 'PmPi'

Definition at line 108 of file HsCreators.h.

#define hsFileCPhoneMainView 'PmPm'

Definition at line 102 of file HsCreators.h.

#define hsFileCPhonePeopleView 'PmPp'

Definition at line 104 of file HsCreators.h.

#define hsFileCPhoneRingerPanel 'HsRN'

Definition at line 113 of file HsCreators.h.

#define hsFileCPhoneSecurity 'HsSE'

Definition at line 111 of file HsCreators.h.

#define hsFileCPhoneServicesPanel 'hsPS'

Definition at line 228 of file HsCreators.h.

#define hsFileCPhoneStub68k 'Pm68'

Definition at line 101 of file HsCreators.h.

#define hsFileCPhoneTips 'PhTp'

Definition at line 110 of file HsCreators.h.

#define hsFileCPhoneWizard 'HsPw'

Definition at line 112 of file HsCreators.h.

#define hsFileCPhoneWrapper 'HsPW'

Definition at line 197 of file HsCreators.h.

#define hsFileCPinballGame 'HsPg'

Definition at line 143 of file HsCreators.h.

#define hsFileCPmUIUtilLibTest 'PmUT'

Definition at line 209 of file HsCreators.h.

#define hsFileCPowerKey '000P'

Definition at line 484 of file HsCreators.h.

#define hsFileCProgressMgrExt 'HsPM'

Definition at line 266 of file HsCreators.h.

#define hsFileCRomUpdater 'hROM'

Definition at line 168 of file HsCreators.h.

#define hsFileCSampleCardWelcome 'CWel'

Definition at line 82 of file HsCreators.h.

#define hsFileCSampleSerLib 'HsCs'

Definition at line 277 of file HsCreators.h.

#define hsFileCSave2Card 'HsSD'

Definition at line 186 of file HsCreators.h.

#define hsFileCSDLib 'Hssd'

Definition at line 382 of file HsCreators.h.

#define hsFileCSerDrvrAuto 'HsSA'

Definition at line 378 of file HsCreators.h.

#define hsFileCSerDrvrCradle 'HsCS'

Definition at line 380 of file HsCreators.h.

#define hsFileCSerDrvrUSBConsole 'HsUc'

Definition at line 368 of file HsCreators.h.

#define hsFileCSerDrvrUSBDesktop 'HsUd'

Definition at line 369 of file HsCreators.h.

#define hsFileCSerDrvrUSBGeneric 'HsUg'

Definition at line 371 of file HsCreators.h.

#define hsFileCSerDrvrUSBGeneric2 'HsUh'

Definition at line 372 of file HsCreators.h.

#define hsFileCSerDrvrUSBRemFS 'HsUr'

Definition at line 370 of file HsCreators.h.

#define hsFileCSerialCoupler 'Hssc'

Definition at line 199 of file HsCreators.h.

#define hsFileCSerLib 'A8xZ'

Definition at line 347 of file HsCreators.h.

#define hsFileCSetISP 'HsJS'

Definition at line 144 of file HsCreators.h.

#define hsFileCSetMem 'Hssm'

Definition at line 198 of file HsCreators.h.

#define hsFileCSimPhoneBook 'HsPB'

Definition at line 118 of file HsCreators.h.

#define hsFileCSimServices 'HsSS'

Definition at line 119 of file HsCreators.h.

#define hsFileCSmartSmallromToken 'HsSR'

Definition at line 426 of file HsCreators.h.

#define hsFileCSmartTextEngine 'HsST'

Definition at line 122 of file HsCreators.h.

#define hsFileCSMS 'SMSh'

Definition at line 117 of file HsCreators.h.

#define hsFileCSpringWriter 'Hss1'

Definition at line 201 of file HsCreators.h.

#define hsFileCTaskLib 'HsTS'

Definition at line 279 of file HsCreators.h.

#define hsFileCTelephonyInterfaceLayer 'TIL!'

Definition at line 319 of file HsCreators.h.

#define hsFileCTextEncodingConverterLib 'TecL'

Definition at line 480 of file HsCreators.h.

#define hsFileCTextEncodingConverterTable 'TecD'

Definition at line 481 of file HsCreators.h.

#define hsFileCTexter 'HsCh'

Definition at line 123 of file HsCreators.h.

#define hsFileCTonesLib 'HsTo'

Definition at line 388 of file HsCreators.h.

#define hsFileCTraceViewer 'HsTV'

Definition at line 208 of file HsCreators.h.

#define hsFileCTransparencyLib 'HsTL'

Definition at line 303 of file HsCreators.h.

#define hsFileCTutorialContent 'TMTp'

Definition at line 183 of file HsCreators.h.

#define hsFileCUartCoupler 'Hsuc'

Definition at line 200 of file HsCreators.h.

#define hsFileCUIExt 'HsUI'

Definition at line 267 of file HsCreators.h.

#define hsFileCUsbLib 'HsUs'

Definition at line 366 of file HsCreators.h.

#define hsFileCUsbResetTest 'Hsur'

Definition at line 202 of file HsCreators.h.

#define hsFileCUsbTester 'HsU2'

Definition at line 196 of file HsCreators.h.

#define hsFileCUseSerial 'HSUS'

Definition at line 207 of file HsCreators.h.

#define hsFileCVirtualGSMSerLib 'VGSM'

Definition at line 354 of file HsCreators.h.

#define hsFileCVirtualModemSerLib 'FakM'

Definition at line 352 of file HsCreators.h.

#define hsFileMMSPalmTransport 'Trn3'

Definition at line 129 of file HsCreators.h.

#define hsFileMMSTreoTransport 'Trn1'

Definition at line 127 of file HsCreators.h.

#define hsFilePhoneBluetoothConnect 'PhBt'

Definition at line 130 of file HsCreators.h.

#define hsFileSMSExchangeLib 'HsSX'

Definition at line 307 of file HsCreators.h.

#define hsFileSMSPalmTransport 'Trn2'

Definition at line 128 of file HsCreators.h.

#define hsFileSMSTreoTransport 'Trn0'

Definition at line 126 of file HsCreators.h.

#define hsFileSoundLib 'HsAu'

Definition at line 324 of file HsCreators.h.

#define hsFileSPI1SerLib 'HsSp'

Definition at line 360 of file HsCreators.h.

#define hsFileTCardSetup 'HsSU'

Definition at line 212 of file HsCreators.h.

#define hsFileTCardSetupShell 'HApp'

Definition at line 214 of file HsCreators.h.

#define hsFileTCodeSeg 'CSeg'

Definition at line 392 of file HsCreators.h.

#define hsFileTHandspringHal 'HwAl'

Definition at line 251 of file HsCreators.h.

#define hsFileTHandspringPatch 'HsPt'

Definition at line 252 of file HsCreators.h.

#define hsFileTHandspringUIObj 'HsUi'

Definition at line 254 of file HsCreators.h.

#define hsFileTModemSetupPatch 'HsMp'

Definition at line 468 of file HsCreators.h.

#define hsFileTSndFile 'SndF'

Definition at line 216 of file HsCreators.h.

#define hsKbdLayoutDbTypeCreator 'KbLy'

Definition at line 477 of file HsCreators.h.

#define hsNotifyRemSleepEvent 'REMs'

Definition at line 508 of file HsCreators.h.

#define hsNotifyRemSleepRequestEvent 'REMq'

Definition at line 502 of file HsCreators.h.

#define hsNotifySetInitialFldStateEvent 'HsFg'

Definition at line 515 of file HsCreators.h.

#define hsRscKbdChrDataID 2000

Definition at line 555 of file HsCreators.h.

#define hsRscKbdChrOptDataID 2002

Definition at line 561 of file HsCreators.h.

#define hsRscKbdChrShiftDataID 2001

Definition at line 558 of file HsCreators.h.

#define hsRscKbdKeyCodeDataID 2000

Definition at line 568 of file HsCreators.h.

#define hsRscTextEncodingConverterTable 'TecT'

Definition at line 482 of file HsCreators.h.

#define hsRscTKbdChrLookupData 'HsKb'

Definition at line 543 of file HsCreators.h.

#define hsRscTKbdKeyCodeLookupData 'HsKc'

Definition at line 565 of file HsCreators.h.

#define hsRscTNavFocusColor 'HsFc'

Definition at line 613 of file HsCreators.h.

#define hsRscTPostProcessLists 'HsPp'

Definition at line 584 of file HsCreators.h.

#define hsRscTutorial 'HsTM'

Definition at line 616 of file HsCreators.h.

#define hsTetheredTreo 'HsTt'

Definition at line 176 of file HsCreators.h.

#define htcManufacturingInfoToken 'HTCM'

Definition at line 437 of file HsCreators.h.

#define pmDebugLockoutToken 'Dblk'

Definition at line 442 of file HsCreators.h.

#define pmFileCKeyLib 'PmKe'

Definition at line 331 of file HsCreators.h.

#define pmFileCSysGadgetLib 'PmSg'

Definition at line 337 of file HsCreators.h.

#define pmFileCSystemLib 'PmSy'

Definition at line 335 of file HsCreators.h.

#define pmFileCUIUtilLib 'PmUU'

Definition at line 333 of file HsCreators.h.

#define pmKbdLayoutToken 'KBlo'

Definition at line 451 of file HsCreators.h.

#define pmLimitLocaleToken 'LLid'

Definition at line 440 of file HsCreators.h.

#define pmNotifyBrightModeKeyEvent 'PmBM'

Definition at line 528 of file HsCreators.h.

#define pmNotifyBroadcastNewMsgCount 'bMgC'

Definition at line 523 of file HsCreators.h.

#define pmNotifyGetNewMsgCountFromHelper 'gMgC'

Definition at line 518 of file HsCreators.h.

#define pmNotifyTraceSettingsChangedEvent (hsFileCTraceViewer)

Definition at line 533 of file HsCreators.h.

#define pmROMTokenRead 'TOKr'

Definition at line 496 of file HsCreators.h.

#define pmROMTokenWrite 'TOKw'

Definition at line 493 of file HsCreators.h.

#define pmSlotDriverActivityIndicator 'PmAI'

Definition at line 490 of file HsCreators.h.

#define pmTSCalToken 'TScb'

Definition at line 445 of file HsCreators.h.

#define pmTSTokenValidToken 'TStv'

Definition at line 457 of file HsCreators.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:07:02 2008 for Palm API Guide


Header Files » Incs » common » system

HsErrorClasses.h File Reference

Detailed Description

Version:
1.0
Date:
06/17/1999
Author:
Vitaly Kruglikov
Public header file for the error classes used by Handspring viewer modules.

Definition in file HsErrorClasses.h.

Include dependency graph for HsErrorClasses.h:

Go to the source code of this file.

Defines

  • #define hsAppErrorClass appErrorClass
  • #define hsFfsErrorClass (appErrorClass | 0x0100)
  • #define hsFlmErrorClass (appErrorClass | 0x0200)
  • #define hsFlashErrorClass (appErrorClass | 0x0300)
  • #define hsFttErrorClass (appErrorClass | 0x0400)
  • #define hsFtcErrorClass (appErrorClass | 0x0500)
  • #define hsTasLibErrorClass (appErrorClass | 0x0600)
  • #define hsHwmErrorClass (appErrorClass | 0x0800)
  • #define hsSrmExtErrorClass (appErrorClass | 0x0A00)
  • #define hsSTEErrorClass (appErrorClass | 0x0C00)
  • #define hsOEMErrorClass oemErrorClass
  • #define hsOEMRadioErrorClass (hsOEMErrorClass)
  • #define hsNetMasterErrorClass (hsOEMErrorClass + 0x0100)
  • #define hsNetPrefLibErrorClass (hsOEMErrorClass + 0x0200)
  • #define hsPhoneLibErrorClass_2 (hsOEMErrorClass + 0x0300)
  • #define hsCcpErrorClass (hsOEMErrorClass + 0x0400)
  • #define hsSoundLibErrorClass (hsOEMErrorClass + 0x0500)
  • #define hsExtErrorClass (hsOEMErrorClass + 0x0600)
  • #define hsMSLErrorClass (hsOEMErrorClass + 0x0700)
  • #define pmLibErrorClass (hsOEMErrorClass + 0x0800)
  • #define hsPhoneLibErrorClass_1 (0x4000)

Define Documentation

#define hsAppErrorClass appErrorClass

Definition at line 37 of file HsErrorClasses.h.

#define hsCcpErrorClass (hsOEMErrorClass + 0x0400)

Definition at line 83 of file HsErrorClasses.h.

#define hsExtErrorClass (hsOEMErrorClass + 0x0600)

Definition at line 90 of file HsErrorClasses.h.

#define hsFfsErrorClass (appErrorClass | 0x0100)

Definition at line 38 of file HsErrorClasses.h.

#define hsFlashErrorClass (appErrorClass | 0x0300)

Definition at line 40 of file HsErrorClasses.h.

#define hsFlmErrorClass (appErrorClass | 0x0200)

Definition at line 39 of file HsErrorClasses.h.

#define hsFtcErrorClass (appErrorClass | 0x0500)

Definition at line 43 of file HsErrorClasses.h.

#define hsFttErrorClass (appErrorClass | 0x0400)

Definition at line 41 of file HsErrorClasses.h.

#define hsHwmErrorClass (appErrorClass | 0x0800)

Definition at line 48 of file HsErrorClasses.h.

#define hsMSLErrorClass (hsOEMErrorClass + 0x0700)

Definition at line 93 of file HsErrorClasses.h.

#define hsNetMasterErrorClass (hsOEMErrorClass + 0x0100)

Definition at line 71 of file HsErrorClasses.h.

#define hsNetPrefLibErrorClass (hsOEMErrorClass + 0x0200)

Definition at line 74 of file HsErrorClasses.h.

#define hsOEMErrorClass oemErrorClass

Definition at line 66 of file HsErrorClasses.h.

#define hsOEMRadioErrorClass (hsOEMErrorClass)

Definition at line 68 of file HsErrorClasses.h.

#define hsPhoneLibErrorClass_1 (0x4000)

Definition at line 111 of file HsErrorClasses.h.

#define hsPhoneLibErrorClass_2 (hsOEMErrorClass + 0x0300)

Definition at line 79 of file HsErrorClasses.h.

#define hsSoundLibErrorClass (hsOEMErrorClass + 0x0500)

Definition at line 86 of file HsErrorClasses.h.

#define hsSrmExtErrorClass (appErrorClass | 0x0A00)

Definition at line 50 of file HsErrorClasses.h.

#define hsSTEErrorClass (appErrorClass | 0x0C00)

Definition at line 51 of file HsErrorClasses.h.

#define hsTasLibErrorClass (appErrorClass | 0x0600)

Definition at line 46 of file HsErrorClasses.h.

#define pmLibErrorClass (hsOEMErrorClass + 0x0800)

Definition at line 97 of file HsErrorClasses.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:07:02 2008 for Palm API Guide


Header Files » Incs » common » system

HsErrors.h File Reference

Detailed Description

Errors that are not part of any particular component but can be returned by many different system components.

Copyright (c) 2002 Handspring Inc., All Rights Reserved

Author:
Kiran Prasad
Id
//device/handheld/dev/sdk/2.2.2/incs/common/system/HsErrors.h#1

Definition in file HsErrors.h.

Go to the source code of this file.

Defines

  • #define hsErrRadioOff (hsOEMRadioErrorClass | 0x01)
  • #define hsErrRadioNotRegistered (hsOEMRadioErrorClass | 0x02)
  • #define hsErrVoiceCallActive (hsOEMRadioErrorClass | 0x03)
  • #define hsErrSimNotReady (hsOEMRadioErrorClass | 0x04)
  • #define hsErrPhoneLocked (hsOEMRadioErrorClass | 0x05)
  • #define hsErrPhoneNotActivated (hsOEMRadioErrorClass | 0x06)

Define Documentation

#define hsErrPhoneLocked (hsOEMRadioErrorClass | 0x05)

Your Radio is currently locked and therefore we can perform the action requested.

Definition at line 54 of file HsErrors.h.

#define hsErrPhoneNotActivated (hsOEMRadioErrorClass | 0x06)

Phone is not activated.

Definition at line 59 of file HsErrors.h.

#define hsErrRadioNotRegistered (hsOEMRadioErrorClass | 0x02)

The radio is currently not registered and you can not perform the action reuqested.

Definition at line 35 of file HsErrors.h.

#define hsErrRadioOff (hsOEMRadioErrorClass | 0x01)

The radio is currently off and you can not perform the action requested.

Definition at line 29 of file HsErrors.h.

#define hsErrSimNotReady (hsOEMRadioErrorClass | 0x04)

For GSM Radio Only, Your SIM is not ready to perform this action. This can either mean there is no SIM or it is not fully read yet.

Definition at line 48 of file HsErrors.h.

#define hsErrVoiceCallActive (hsOEMRadioErrorClass | 0x03)

The radio is currently on an active voice call and so your request can not be handled.

Definition at line 41 of file HsErrors.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:07:02 2008 for Palm API Guide


Header Files » Incs » 68k » system

HsExgMgr.h File Reference

Detailed Description

Extensions to the Exchange Manager.

Version:
Date:
These functions are not currently supported by Palm, but the plan to in future releases. They gave us these functions in sample code, and we are moving into the system for OS 5 products so applications can take advantage of them.

Definition in file HsExgMgr.h.

Include dependency graph for HsExgMgr.h:

Go to the source code of this file.

Functions

  • Err HsExtExgSelectTarget (UInt16 id, const Char *dataTypeP, UInt32 *targetP)
    Parameters:
    id,: IN:

  • Err HsExtExgLocalAccept (ExgSocketPtr exgSocketP)
    Parameters:
    exgSocketP,: IN:

  • Err HsExtExgLocalDisconnect (ExgSocketPtr exgSocketP, Err err)
    Parameters:
    exgSocketP,: IN:

Function Documentation

Err HsExtExgLocalAccept ( ExgSocketPtr exgSocketP )

Parameters:
exgSocketP,: IN:

Return values:

Err HsExtExgLocalDisconnect | ( | ExgSocketPtr | exgSocketP,
 |  | Err | err
 | ) |  |

Parameters:
exgSocketP,: IN:

Parameters:
err,: IN:
Return values:

Err HsExtExgSelectTarget | ( | UInt16 | id,
 |  | const Char * | dataTypeP,
 |  | UInt32 * | targetP
 | ) |  |

Parameters:
id,: IN:

Parameters:
*dataTypeP,: IN:
*targetP,: IN:
Return values:

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:07:02 2008 for Palm API Guide


Header Files » Incs » common » system

HsExgMgrCommon.h File Reference

Detailed Description

Extensions to the Exchange Manager.

These defines are not currently supported by Palm, but the plan to in future releases. They gave us these in sample code, and we are moving into the system for OS 5 products so applications can take advantage of them.

Copyright (c) 2002 Handspring Inc., All Rights Reserved

Author:
Arun Mathias

Definition in file HsExgMgrCommon.h.

Go to the source code of this file.

Defines

  • #define hsExgGetScheme "_get"

Define Documentation

#define hsExgGetScheme "_get"

Definition at line 22 of file HsExgMgrCommon.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:07:02 2008 for Palm API Guide


Header Files » Incs » 68k » system

HsExt.h File Reference

Detailed Description

Header file that 68K programs include to access Handspring Extensions functionality.

Definition in file HsExt.h.

Include dependency graph for HsExt.h:

Go to the source code of this file.

Defines

  • #define SYS_SEL_TRAP(trapNum, selector)
  • #define HsAboutHandspringAppWithYearId(yearId)
  • #define HsAboutHandspringAppWithYearCredId(yearId, creditsId)

Functions

  • void HsAboutHandspringApp (UInt16 appCardNo, LocalID appDbId, Char *copyrightYearStrP, Char *extraCreditsStrP)
    Parameters:
    appCardNo,: IN:

  • Err HsGetVersionString (UInt16 selector, Char *outStrP, UInt16 *sizeP)
    Retrieve a null terminated version string.
  • Err HsAttrGet (UInt16 attr, UInt32 param, UInt32 *valueP)
    Get any Handspring specific attributes that aren’t appropriate to be accessed through a feature. (e.g., dynamic information about device state).
  • Err HsAttrSet (UInt16 attr, UInt32 param, UInt32 *valueP)
    Set Handspring specific attributes.
  • Err HsPrefGet (UInt16 pref, void *bufP, UInt32 *prefSizeP)
    HsExtensions maintains and utilizes a set of preferences that are not a part of the Palm OS system preferences. They can be retrieved using this function.
  • Err HsPrefSet (UInt16 pref, void *bufP, UInt32 prefSize)
    HsExtensions maintains and utilizes a set of preferences that are not a part of the Palm OS system preferences. They can be set using this function.
  • Err HsGetPhoneLibrary (UInt16 *refNum)
    Function that gets the reference number to the phone library. It decides whether it should return the GSM or the CDMA library based on the type of device. If the library is not loaded, it loads the library.
  • Err HsStatusSetGadgetType (void *frmP, UInt16 gadgetID, UInt16 type)
    Tell the system that a gadget on the form is a certain type of status gadget so that the system can properly draw and update it.
  • void HsStatusUpdateGadgets (void)
    Explicitly update all status gadgets on the current form.
  • Err HsGrfSetStateExt (Boolean capsLock, Boolean numLock, Boolean optLock, Boolean upperShift, Boolean optShift, Boolean autoShift)
    Extended version of GrfSetState to allow setting an option and option lock state.
  • Err HsGrfGetStateExt (Boolean *capsLockP, Boolean *numLockP, Boolean *optLockP, UInt16 *tempShiftP, Boolean *autoShiftedP)
    Extended version of GrfGetState to include detection of option and option lock state.
  • Boolean HsPutObjectAfterTitle (void *voidFrmP, UInt16 objID, UInt8 titleOffset)
    Places a UI object to the right of the form title. This function is useful for adjusting object positions for localized titles.
  • UInt32 HsInfo (UInt16 item, UInt16 paramSize, void *paramP)
    This call will return info on a particular attribute of the Handspring extensions.
  • UInt16 HsEvtMetaEvent (EventPtr eventP)
    Parameters:
    eventP,: IN:

  • Err HsSpringboardNotSupported (void)
    Used to determine if the device supports the Springboard expansion slot or not.
  • void * HsGetTrapAddress (UInt16 trapNum)
    Works like SysGetTrapAddress, but for Handspring trap numbers.
  • Err HsNetworkDropConnection (void)
    This function will completely close the currently active TCP/IP network connection. The open count will be 0 after this call is made.
  • void HsUnimplemented (void)
  • void * HsGetARMActiveFormPtr (void)
  • FontID HsTwoFontSelect (FontID originalFont)
    Allows the user to select a small or a large font size.
  • void HsOpenDialNumberDialog (char *numberP, char *nameP, Boolean callerID)
    Opens a window with the number filled in the address text field.
  • Err HsTurnRadioOn (void)
    Turn the radio (cell phone) on if it’s off.
  • Err HsCreateNewMessage (char *addressP, char *nameP, char *msgP)
    Launches the messaging application (SMS) to the new message form with some fields optionally prefilled with the specified values.
  • Err HsCreateNewEmail (char *addressP, char *ccP, char *subjectP, char *msgP)
    Launches the email application to the new email form with some fields optionally prefilled with the specified values.
  • Err HsBrowseUrl (char *urlP)
    Launches the browser to the specified URL.
  • Err HsNavGetFocusRingInfo (const FormType *formP, UInt16 *objectIDP, Int16 *extraInfoP, RectangleType *boundsInsideRingP, HsNavFocusRingStyleEnum *ringStyleP)
    If a form has a system drawn focus ring, gets info about the ring.
  • Err HsNavDrawFocusRing (FormType *formP, UInt16 objectID, Int16 extraInfo, RectangleType *boundsInsideRingP, HsNavFocusRingStyleEnum ringStyle, Boolean forceRestore)
    Tells the system to draw a focus ring for an object.
  • Err HsNavRemoveFocusRing (FormType *formP)
    Removes system-drawn ring from around currently focused object.
  • void HsNavObjectTakeFocus (const FormType *formP, UInt16 objID)
    Sends a frmObjectFocusTake event for an object.
  • void HsNavGetFocusColor (HsNavFocusColorEnum color, RGBColorType *rgbColorP)
    Obtains a focus color.
  • void HsNavSetFocusColor (HsNavFocusColorEnum color, RGBColorType *rgbColorP, RGBColorType *oldRgbColorP)
    Sets new focus color.
  • Err HsIndicatorState (UInt16 count, UInt16 indicatorType, UInt16 *stateP)
    Set or get the state of the LED or Vibrator.
  • Err HsLightMode (Boolean set, UInt16 *modeP)
    Get or set the current mode.
  • Err HsLightCircumstance (Boolean add, UInt16 circumstance)
    Add/remove special lighting circumstances.
  • UInt16 HsCurrentLightCircumstance (void)
  • void HsKeyCurrentStateExt (UInt32 keys[3])
    Converts HsKeysPressed() results into a bitfield.
  • void HsKeySetMaskExt (const UInt32 keyMaskNew[3], UInt32 keyMaskOld[3])
    Glue to HsKeyEnabled() based on bitfields.
  • UInt16 HsKeysPressed (UInt16 count, const UInt16 keyCodes[], Boolean pressed[])
    Get the current state of specified keys.
  • Err HsKeyStop (UInt16 keyCode)
    Stop a key from sending any more autorepeat events until it is released.
  • Boolean HsKeyEnableKey (UInt16 keyCode, Boolean enabled)
    Enable/disable a key from generating key events.
  • UInt16 HsKeyChrCodeToKeyCode (UInt16 chrCode)
    Determine which key generates a certain character.
  • void HsKeyKeyCodeToChrCode (UInt16 keyCode, UInt16 modifiersIn, UInt16 *chrP, UInt16 *modifiersOutP)
    Translate a key code to the character generated by that key.
  • Boolean HsKeyEventIsFromKeyboard (EventPtr eventP)
    Determine if an event came from the physical keyboard.
  • Boolean HsExtDoSaveAsDialog (Char *name)
    Displays a dialog to the user allowing them to confirm the saving of data, and the name that they wish to assign.
  • UInt16 HsTxtPrepFindString (const Char *inSrcP, UInt16 inSrcLen, Char *outDstP, UInt16 inDstSize)
    Parameters:
    inSrcP,: IN:

  • UInt32 HsTxtNumChars (Char const *textP)
    Parameters:
    textP,: IN:

  • void HsTxtTruncateString (Char *textP, UInt16 maxPixels, Boolean keepLabel)
    Parameters:
    textP,: IN:

  • Boolean HsTxtIsAscii (Char *textP, UInt16 textLen)
    Parameters:
    textP,: IN:

  • Boolean HsIsHTTPLibraryLoaded (void)
    Return values:
    Boolean

  • Int16 HsNavLstGetTempSelection (const FormType *formP, UInt16 listID)
    Obtains the temporarily selected item of an embedded list.
  • void HsNavLstSetTempSelection (const FormType *formP, UInt16 listID, Int16 itemNum)
    Sets the temporarily selected item for an embedded list.
  • void HsStartMemoryTracing (Boolean trace)
    Starts and stops memory tracing.

Define Documentation

#define HsAboutHandspringAppWithYearCredId | ( | yearId,
 |  | creditsId | )

Value:

do                                                                      \
      {                                                                     \
        UInt16  appCardNo;                                                  \
        LocalID appDbId;                                                    \
        MemHandle   yearStrH, extraStrH;                                    \
        Char*   yearStrP;                                                   \
        Char*   extraStrP;                                                  \
                                                                            \
        yearStrH = DmGetResource (strRsc, yearId);                          \
        yearStrP = MemHandleLock (yearStrH);                                \
        extraStrH = DmGetResource (strRsc, creditsId);                      \
        extraStrP = MemHandleLock (extraStrH);                              \
        SysCurAppDatabase(&appCardNo, &appDbId);                            \
        HsAboutHandspringApp (appCardNo, appDbId, yearStrP, extraStrP);     \
        MemPtrUnlock (extraStrP);                                           \
        DmReleaseResource (extraStrH);                                      \
        MemPtrUnlock (yearStrP);                                            \
        DmReleaseResource (yearStrH);                                       \
      }                                                                     \
    while (0)

Definition at line 97 of file HsExt.h.

#define HsAboutHandspringAppWithYearId ( yearId )

Value:

do                                                                      \
      {                                                                     \
        UInt16  appCardNo;                                                  \
        LocalID appDbId;                                                    \
        MemHandle   yearStrH;                                               \
        Char*   yearStrP;                                                   \
                                                                            \
        yearStrH = DmGetResource (strRsc, yearId);                          \
        yearStrP = MemHandleLock (yearStrH);                                \
        SysCurAppDatabase(&appCardNo, &appDbId);                            \
        HsAboutHandspringApp (appCardNo, appDbId, yearStrP, NULL);          \
        MemPtrUnlock (yearStrP);                                            \
        DmReleaseResource (yearStrH);                                       \
      }                                                                     \
    while (0)

Definition at line 80 of file HsExt.h.

#define SYS_SEL_TRAP | ( | trapNum,
 |  | selector | )

Definition at line 60 of file HsExt.h.

Function Documentation

void HsAboutHandspringApp | ( | UInt16 | appCardNo,
 |  | LocalID | appDbId,
 |  | Char * | copyrightYearStrP,
 |  | Char * | extraCreditsStrP
 | ) |  |

Parameters:
appCardNo,: IN:

Parameters:
appDbId,: IN:
copyrightYearStrP,: IN:
extraCreditsStrP,: IN:
Return values:
Error code.

Err HsAttrGet | ( | UInt16 | attr,
 |  | UInt32 | param,
 |  | UInt32 * | valueP
 | ) |  |

Get any Handspring specific attributes that aren’t appropriate to be accessed through a feature. (e.g., dynamic information about device state).

See also:
HsAttrEnum
Parameters:
attr,: IN: Which attribute is being retrieved. Most attributes are defined in “HsExtCommon.h” in the HsAttrEnum enumeration.
param,: IN: Meaning depends on ’attr’ (currently implemented attributes only take 0 for this argument).
valueP,: IN: Cast depending on attr (refer HsAttrEnum for data type this argument should point to).
Return values:
Err 0 if no error

Err HsAttrSet | ( | UInt16 | attr,
 |  | UInt32 | param,
 |  | UInt32 * | valueP
 | ) |  |

Set Handspring specific attributes.

See also:
HsAttrEnum
Parameters:
attr,: IN: Which attribute is being set.
param,: IN: Meaning depends on ’attr’ (currently implemented attributes only take 0 for this argument).
valueP,: IN: Cast depending on attr (refer HsAttrEnum for data type this argument should point to).
Return values:
Err 0 if no error hsErrNotSupported otherwise.

Err HsBrowseUrl ( char * urlP )

Launches the browser to the specified URL.

This function can be used by any application that wants to launch the web browser to a specified URL without using the helper APIs.

Parameters:
urlP,: IN: A pointer to a string that contains the phone number to put into the number field.
Return values:
Err 0 on success or the error that occurred.

Err HsCreateNewEmail | ( | char * | addressP,
 |  | char * | ccP,
 |  | char * | subjectP,
 |  | char * | msgP
 | ) |  |

Launches the email application to the new email form with some fields optionally prefilled with the specified values.

This function can be used by any application that wants to launch the email application and have some of the fields prefilled without using the helper APIs.

Parameters:
addressP,: IN: A pointer to a string that contains the address to put in the To: field.
ccP,: IN: A pointer to a string that contains the address to put in the cc: field. (optional)
subjectP,: IN: A pointer to a string that contains the subject of the new email. (optional)
msgP,: IN: A pointer to a string that contains the message text of the new email. (optional)
Return values:
Err 0 on success or the error that occurred.

Err HsCreateNewMessage | ( | char * | addressP,
 |  | char * | nameP,
 |  | char * | msgP
 | ) |  |

Launches the messaging application (SMS) to the new message form with some fields optionally prefilled with the specified values.

This function can be used by any application that wants to launch the messaging application and have some of the fields prefilled without using the helper APIs.

Parameters:
addressP,: IN: A pointer to a string that contains the phone number to put into the To: field. (optional)
nameP,: IN: A pointer to a string that contains the name to put above the To: field. (optional)
msgP,: IN: A pointer to a string that contains the message text of the new message. (optional)
Return values:
Err 0 on success or the error that occurred.

UInt16 HsCurrentLightCircumstance ( void )

UInt16 HsEvtMetaEvent ( EventPtr eventP )

Parameters:
eventP,: IN:

Return values:
UInt16 Error code.

Boolean HsExtDoSaveAsDialog ( Char * name )

Displays a dialog to the user allowing them to confirm the saving of data, and the name that they wish to assign.

Parameters:
name,: IN: Comes in as the default name and returns the name the user chose
Return values:
Boolean True if the user confirmed that the save should take place. False otherwise.

void* HsGetARMActiveFormPtr ( void )

Err HsGetPhoneLibrary ( UInt16 * refNum )

Function that gets the reference number to the phone library. It decides whether it should return the GSM or the CDMA library based on the type of device. If the library is not loaded, it loads the library.

Parameters:
refNum,: IN: Library reference number to be used in other function.
Return values:
Err 0 if no error.

void* HsGetTrapAddress ( UInt16 trapNum )

Works like SysGetTrapAddress, but for Handspring trap numbers.

For every HsExt function implemented in ARM native, there exists a wrapper 68K function that simply calls the HsExt function in question. This may seem roundabout, but HsGetTrapAddress is retained for backward compatibility.

Parameters:
trapNum,: IN: the address of the trap handler for the given selector.
Return values:
void* If the selector is invalid, returns the address of HsUnimplemented().

Err HsGetVersionString | ( | UInt16 | selector,
 |  | Char * | outStrP,
 |  | UInt16 * | sizeP
 | ) |  |

Retrieve a null terminated version string.

Parameters:
selector,: IN: Selects which version string to get
outStrP,: IN: Buffer to receive the NULL terminated version string. The buffer should be large enough to hold hsVersionStringSize bytes
sizeP,: IN: If not NULL, returns the number of bytes stored in *outStrP, including the NULL terminator
Return values:
0 if no error, hsErrNotSupported if error occurs

Err HsGrfGetStateExt | ( | Boolean * | capsLockP,
 |  | Boolean * | numLockP,
 |  | Boolean * | optLockP,
 |  | UInt16 * | tempShiftP,
 |  | Boolean * | autoShiftedP
 | ) |  |

Extended version of GrfGetState to include detection of option and option lock state.

Parameters:
capsLockP,: IN: returns true if caps lock on
numLockP,: IN: returns true if num lock on
optLockP,: IN: returns true if opt lock on
tempShiftP,: IN: returns current temporary shift
autoShiftedP,: IN: returns TRUE if shift not set by the user but by the system, for example, at the beginning of a line.
Return values:
Err Always returns 0.

Err HsGrfSetStateExt | ( | Boolean | capsLock,
 |  | Boolean | numLock,
 |  | Boolean | optLock,
 |  | Boolean | upperShift,
 |  | Boolean | optShift,
 |  | Boolean | autoShift
 | ) |  |

Extended version of GrfSetState to allow setting an option and option lock state.

The original GrfSetState does not have an autoShift parameter because it always assumed that anyone setting the shift state through the API call wanted an automatic shift. We do not make this assumption. The shift state can be set by calling either HsGrfSetStateExt() or GrfSetState(). Either way, we have to make sure that both the keyboard shift state and the Graffiti engine’s shift state get set correctly.

Parameters:
capsLock,: IN: Set to turn caps lock on
numLock,: IN: Set to true to turn num lock on
optLock,: IN: Set to true to turn option lock on
upperShift,: IN: Set to true to put into upper shift
optShift,: IN: Set to true to put into option shift
autoShift,: IN: Valid only if upperShift is true. Set to true if the graffiti engine should consider the upper shift an auto shift.
Return values:
Err Always returns 0.

Err HsIndicatorState | ( | UInt16 | count,
 |  | UInt16 | indicatorType,
 |  | UInt16 * | stateP
 | ) |  |

Set or get the state of the LED or Vibrator.

Parameters:
count,: IN: Count of how many times to blink or pulse the indicator, or one of the HsIndicatorCountEnum values to either run forever or get the current state.
indicatorType,: IN: HsIndicatorTypeEnum (LED or vibrator)
stateP,: IN: Pointer to HsIndicatorStateEnum If setting, points to state to set. If getting, as IN param points to “none” state of the source to query (or kIndicatorStateNull to query whatever source has priority). As OUT param, contains the result of the query (kIndicatorStateNull if querying for the active source and there is none)
Return values:
Err 0 if no error

UInt32 HsInfo | ( | UInt16 | item,
 |  | UInt16 | paramSize,
 |  | void * | paramP
 | ) |  |

This call will return info on a particular attribute of the Handspring extensions.

This call is designed to return info that won’t fit into a Palm OS feature call (a UInt32).

Parameters:
item,: IN: which info to return
paramSize,: IN: size of paramP block passed in
paramP,: IN: info is returned here
Return values:
UInt32 0 if no error

Boolean HsIsHTTPLibraryLoaded ( void )

Return values:
Boolean

UInt16 HsKeyChrCodeToKeyCode ( UInt16 chrCode )

Determine which key generates a certain character.

Parameters:
chrCode,: IN: the character to search for
Return values:
UInt16 The key code.

void HsKeyCurrentStateExt ( UInt32 keys[3] )

Converts HsKeysPressed() results into a bitfield.

This function provides compatibility with earlier Handspring SDKs. The preferred method of querying key states is to call HsKeysPressed().

Parameters:
keys,: IN: Array of three bitfields representing which keys are depressed.

Boolean HsKeyEnableKey | ( | UInt16 | keyCode,
 |  | Boolean | enabled
 | ) |  |

Enable/disable a key from generating key events.

Parameters:
keyCode,: IN: which key to enable/disable
enabled,: IN: true to enable, false to disable
Return values:
Boolean true if previously enabled.

Boolean HsKeyEventIsFromKeyboard ( EventPtr eventP )

Determine if an event came from the physical keyboard.

Parameters:
eventP,: IN: The event to check
Return values:
Boolean True if the event came from the keyboard

void HsKeyKeyCodeToChrCode | ( | UInt16 | keyCode,
 |  | UInt16 | modifiersIn,
 |  | UInt16 * | chrP,
 |  | UInt16 * | modifiersOutP
 | ) |  |

Translate a key code to the character generated by that key.

Parameters:
keyCode,: IN: The key to lookup
modifiersIn,: IN: Modifier mask indicating which character should be returned
chrP,: IN: The character produced by the key
modifiersOutP,: IN: The keyMask bits that must be set if a keyDown event is formed with the character. (Not including the bits set in modifiersIn)

void HsKeySetMaskExt | ( | const UInt32 | keyMaskNew[3],
 |  | UInt32 | keyMaskOld[3]
 | ) |  |

Glue to HsKeyEnabled() based on bitfields.

This function provides compatibility with earlier Handspring SDKs. The preferred method of enabling keys is to call HsKeyEnableKey().

Parameters:
keyMaskNew,: IN: new enabled mask
keyMaskOld,: IN: previous enabled mask

UInt16 HsKeysPressed | ( | UInt16 | count,
 |  | const UInt16 | keyCodes[],
 |  | Boolean | pressed[]
 | ) |  |

Get the current state of specified keys.

This extends KeyCurrentState().

Parameters:
count,: IN: number of elements in keyCodes[] and pressed[]
keyCodes[],: IN: Array of keyCodes to test
pressed[],: IN: Each element is set to true if the key specified by the corresponding element in keyCodes[] is pressed, and set to false if it’s not pressed. It is acceptable to pass NULL if only the return value is of interest.
Return values:
UInt16 Count of keys in keyCodes[] that are pressed

Err HsKeyStop ( UInt16 keyCode )

Stop a key from sending any more autorepeat events until it is released.

Parameters:
keyCode,: IN: key to stop
Return values:
Err errNone if the keyCode is the last key pressed and it’s still held.

Err HsLightCircumstance | ( | Boolean | add,
 |  | UInt16 | circumstance
 | ) |  |

Add/remove special lighting circumstances.

This function does reference counting on added circumstances, so be sure to not add a circumstance without eventually removing it (unless you intended that). Note that some circumstances don’t take effect until some point in time later (in SysHandleEvent). That’s because some circumstances only take effect when the device is idle for some amount of time.

Parameters:
add,: IN: If true, we’re adding a circumstance, If false, we’re removing it.
circumstance,: IN: The circumstance we’re adding or taking away (refer HsLightCircumstanceEnum).
Return values:
Err An error code; 0 if no error

Err HsLightMode | ( | Boolean | set,
 |  | UInt16 * | modeP
 | ) |  |

Get or set the current mode.

Parameters:
set,: IN: If true, we’ll switch to *modeP; if false we’ll put the current mode in *modeP
modeP,: IN: If we’re setting, we’ll switch to this mode (refer HsLightModeEnum). If we’re getting, we’ll put the current mode here.
Return values:
Err An error code; 0 if no error.

Err HsNavDrawFocusRing | ( | FormType * | formP,
 |  | UInt16 | objectID,
 |  | Int16 | extraInfo,
 |  | RectangleType * | boundsInsideRingP,
 |  | HsNavFocusRingStyleEnum | ringStyle,
 |  | Boolean | forceRestore
 | ) |  |

Tells the system to draw a focus ring for an object.

Parameters:
formP,: IN: Form containing object whose ring is being drawn
objectID,: IN: ID of object getting the focus ring
extraInfo,: IN: Any info that caller wants associated with the focus ring. For example, the system uses this field to store the temporarily-selected item of a focused, embedded list. Caller should pass hsNavFocusRingNoExtraInfo (0xFFFF) if there is no associated info.
boundsInsideRingP,: IN: Points to the bounds around which the ring should be drawn
ringStyle,: IN: Enumeration value that represents the desired style for the ring. hsNavFocusRingStyleObjectTypeDefault can be passed if caller just wants the default ring style for the object’s type.
forceRestore,: IN: If ring is already on the object, whether to force restoration of what’s behind the ring before redrawing the ring.
Return values:
Err Returns errNone if no error, error code otherwise.

void HsNavGetFocusColor | ( | HsNavFocusColorEnum | color,
 |  | RGBColorType * | rgbColorP
 | ) |  |

Obtains a focus color.

Parameters:
color,: IN: Enumeration value that specifies which focus color to get
rgbColorP,: IN: On exit, points to the focus color

Err HsNavGetFocusRingInfo | ( | const FormType * | formP,
 |  | UInt16 * | objectIDP,
 |  | Int16 * | extraInfoP,
 |  | RectangleType * | boundsInsideRingP,
 |  | HsNavFocusRingStyleEnum * | ringStyleP
 | ) |  |

If a form has a system drawn focus ring, gets info about the ring.

Parameters:
formP,: IN: Ptr to form whose ring info is to be obtained
objectIDP,: IN: If not NULL, on exit will point to the object with the system-drawn focus ring
extraInfoP,: IN: If not NULL, on exit will point to any extra info associated with the focus ring. Extra info is any info that the caller wants to associate with a ring. hsNavFocusRingNoExtraInfo (0xFFFF) is used to represent no extra info.
boundsInsideRingP,: IN: If not NULL, on exit will point to the bounds inside the system-drawn focus ring
ringStyleP,: IN: If not NULL, on exit will point to the style of the focus ring
Return values:
Err Error code.

Int16 HsNavLstGetTempSelection | ( | const FormType * | formP,
 |  | UInt16 | listID
 | ) |  |

Obtains the temporarily selected item of an embedded list.

Parameters:
formP,: IN: Pointer to the form containing the list whose temporary selection is to be obtained
listID,: IN: ID of list whose temporary selection is to be obtained
Return values:
Int16 Returns the temporarily selected list item

void HsNavLstSetTempSelection | ( | const FormType * | formP,
 |  | UInt16 | listID,
 |  | Int16 | itemNum
 | ) |  |

Sets the temporarily selected item for an embedded list.

Parameters:
formP,: IN: Pointer to the form containing the list whose temporary selection is to be set
listID,: IN: ID of list whose temporary selection is to be set
itemNum,: IN: Number of the item that should be temporarily selected

void HsNavObjectTakeFocus | ( | const FormType * | formP,
 |  | UInt16 | objID
 | ) |  |

Sends a frmObjectFocusTake event for an object.

Parameters:
formP,: IN: Ptr to form that contains the object
objID,: IN: ID of the object

Err HsNavRemoveFocusRing ( FormType * formP )

Removes system-drawn ring from around currently focused object.

Parameters:
formP,: IN: Ptr to form containing the object with the ring
Return values:
Err Returns errNone if no error, error code otherwise

void HsNavSetFocusColor | ( | HsNavFocusColorEnum | color,
 |  | RGBColorType * | rgbColorP,
 |  | RGBColorType * | oldRgbColorP
 | ) |  |

Sets new focus color.

Parameters:
color,: IN: Enumeration value that specifies which focus color to set
rgbColorP,: IN: Points to the new color
oldRgbColorP,: IN: If not NULL, on exit it will point to the old focus color

Err HsNetworkDropConnection ( void )

This function will completely close the currently active TCP/IP network connection. The open count will be 0 after this call is made.

Return values:
Err 0 if successful.

void HsOpenDialNumberDialog | ( | char * | numberP,
 |  | char * | nameP,
 |  | Boolean | callerID
 | ) |  |

Opens a window with the number filled in the address text field.

This function can be used by any application that wants to dial a phone number, but first give the user the option of editing the number. This functionality originally existed in the STE, but was moved to the system.

Parameters:
numberP,: IN: A pointer to a string that contains the phone number to put into the number field.
nameP,: IN: A pointer to a string that contains the name to put into the title of the dialog.
callerID,: IN: If this is true, then we will attempt to match the phone number with an entry in the address book. If a match is found, then the title of the dialog will contain the name.

Err HsPrefGet | ( | UInt16 | pref,
 |  | void * | bufP,
 |  | UInt32 * | prefSizeP
 | ) |  |

HsExtensions maintains and utilizes a set of preferences that are not a part of the Palm OS system preferences. They can be retrieved using this function.

See also:
HsPrefEnum
Parameters:
pref,: IN: IN which preference to retrieve (refer HsPrefEnum)
bufP,: IN: IN buffer to store preference (refer HsPrefEnum for the size of the buffer needed).
prefSizeP,: IN: IN/OUT on entry, size of bufP on exit, size of stored pref. If larger than size of bufP, then hsErrBufferTooSmall is returned.
Return values:
Err 0 if no err hsErrInvalidParam if pref is invalid hsErrBufferTooSmall if *prefSizeP was smaller than actual pref

Err HsPrefSet | ( | UInt16 | pref,
 |  | void * | bufP,
 |  | UInt32 | prefSize
 | ) |  |

HsExtensions maintains and utilizes a set of preferences that are not a part of the Palm OS system preferences. They can be set using this function.

See also:
HsPrefEnum
Parameters:
pref,: IN: which pref to retrieve, a HsPrefEnum
bufP,: IN: buffer to store pref
prefSize,: IN: size of pref to store
Return values:
Err 0 if no err hsErrInvalidParam if pref is invalid

Boolean HsPutObjectAfterTitle | ( | void * | voidFrmP,
 |  | UInt16 | objID,
 |  | UInt8 | titleOffset
 | ) |  |

Places a UI object to the right of the form title. This function is useful for adjusting object positions for localized titles.

Parameters:
voidFrmP,: IN: ptr to form containing the object
objID,: IN: id of the object being positioned
titleOffset,: IN: number of pixels between title bar and status gadget
Return values:
Boolean True if the object was moved from it’s original position. False otherwise

Err HsSpringboardNotSupported ( void )

Used to determine if the device supports the Springboard expansion slot or not.

On springboard devices, this function is unimplemented. To determine whether the device has a Springboard extension slot or not, use HsGetTrapAddress() to obtain the trap addresses of this function and HsUnimplemented. If they are equal, the device has the Springboard extension slot, otherwise it doesn’t.

Return values:
Err All of the Springboard functions return an error on the Treo 600.

void HsStartMemoryTracing ( Boolean trace )

Starts and stops memory tracing.

Parameters:
tarce,: IN: should tracing be started or stopped if true tracing will be started.
called from the 68K controling (test) app.

Err HsStatusSetGadgetType | ( | void * | frmP,
 |  | UInt16 | gadgetID,
 |  | UInt16 | type
 | ) |  |

Tell the system that a gadget on the form is a certain type of status gadget so that the system can properly draw and update it.

Tell the system that a gadget on the form is a certain type of status gadget so that the system can properly draw and update it. A form can only have one gadget for each status type. If more than one gadget is set to a certain type, only the last one set will be recorded. This function can also be used to erase and release a gadget whose type has already been set. To do this, type should be set to 0.

NOTE The gadget dimensions in the current implementation are hardcoded to values of 10 X 12 pixels for the battery gadget and 16 X 12 pixels for signal gadget. Scaling is not supported, so define your gadget resources accordingly.

Parameters:
frmP,: IN: pointer to the form with the gadget (we will convert to an ID before saving but want a ptr to be passed as a param to ensure that the caller is setting the gadget for a loaded form)
gadgetID,: IN: id of the gadget whose type is being specified
type,: IN: type of the gadget (pass a member of HsStatusGadgetTypeEnum—defined in HsExt.h or 0 to erase and release a gadget)
Return values:
Err 0 if no error.

void HsStatusUpdateGadgets ( void )

Explicitly update all status gadgets on the current form.

Err HsTurnRadioOn ( void )

Turn the radio (cell phone) on if it’s off.

Return values:
Err 0 if successful.

FontID HsTwoFontSelect ( FontID originalFont )

Allows the user to select a small or a large font size.

This is just like the Palm OS routine FontSelect, except it gives the user a choice of only a small and a large font. If the originalFont is not bold, then the two choices are stdFont and largeFont. If the original choice is bold, then the two choices are boldFont and largeBoldFont.

Parameters:
originalFont,: IN: The original font ID (used to select the current font).
Return values:
FontID The new font ID.

Boolean HsTxtIsAscii | ( | Char * | textP,
 |  | UInt16 | textLen
 | ) |  |

Parameters:
textP,: IN:

Parameters:
textLen,: IN:
Return values:
Boolean

UInt32 HsTxtNumChars ( Char const * textP )

Parameters:
textP,: IN:

Return values:
UInt32

UInt16 HsTxtPrepFindString | ( | const Char * | inSrcP,
 |  | UInt16 | inSrcLen,
 |  | Char * | outDstP,
 |  | UInt16 | inDstSize
 | ) |  |

Parameters:
inSrcP,: IN:

Parameters:
inSrcLen,: IN:
outDstP,: IN:
inDstSize,: IN:
Return values:
UInt16

void HsTxtTruncateString | ( | Char * | textP,
 |  | UInt16 | maxPixels,
 |  | Boolean | keepLabel
 | ) |  |

Parameters:
textP,: IN:

Parameters:
maxPixels,: IN:
keepLabel,: IN:

void HsUnimplemented ( void )

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:07:03 2008 for Palm API Guide


Header Files » Incs » common » system

HsExtCommon.h File Reference

Detailed Description

Common defines shared between HsExt.h (include for 68K programs) and HsExtArm.h (include for ARM programs).

Definition in file HsExtCommon.h.

Go to the source code of this file.

Defines

  • #define hsVersionStringSize 32
  • #define hsAttrRingSwitchMute 0
  • #define hsAttrRingSwitchLoud 0x8000
  • #define hsWordCorrectMaxWordLen 25
  • #define hsMaxSaveAsNameSize 32
  • #define hsDeviceIDTreo600 kPalmOneDeviceIDTreo600
  • #define hsDeviceIDTreo600Sim kPalmOneDeviceIDTreo600Sim
  • #define hsDeviceIDOs5Device1 kPalmOneDeviceIDTreo600
  • #define hsDeviceIDOs5Device1Sim kPalmOneDeviceIDTreo600Sim
  • #define hsAttrSysActiveHotSync 0x0001
  • #define hsAttrSysActiveProgress 0x0002
  • #define hsAttrSysActiveBeamProgress 0x0004
  • #define hsAttrPhoneTypeCDMA 0x0001
  • #define hsAttrPhoneTypeGSM 0x0002
  • #define hsOLDErrorClass (appErrorClass+0x0100)
  • #define hsErrNotSupported (hsOLDErrorClass | 0x01)
  • #define hsErrInvalidCardNum (hsOLDErrorClass | 0x02)
  • #define hsErrReadOnly (hsOLDErrorClass | 0x03)
  • #define hsErrInvalidParam (hsOLDErrorClass | 0x04)
  • #define hsErrBufferTooSmall (hsOLDErrorClass | 0x05)
  • #define hsErrInvalidCardHdr (hsOLDErrorClass | 0x06)
  • #define hsErrCardPatchAlreadyInstalled (hsOLDErrorClass | 0x07)
  • #define hsErrCardPatchNotInstalled (hsOLDErrorClass | 0x08)
  • #define hsErrNotEnoughPower (hsOLDErrorClass | 0x09)
  • #define hsErrCardNotInstalled (hsOLDErrorClass | 0x0A)
  • #define hsErrInvalidPeriod (hsOLDErrorClass | 0x0B)
  • #define hsErrPeriodicNotInstalled (hsOLDErrorClass | 0x0C)
  • #define hsErrFixedStorageRequired (hsOLDErrorClass | 0x0D)
  • #define hsErrPeriodicAlreadyInstalled (hsOLDErrorClass | 0x0E)
  • #define hsErrInUse (hsOLDErrorClass | 0x0F)
  • #define hsErrIndicatorInvalidSequence (hsOLDErrorClass | 0x10)
  • #define hsErrIndicatorInvalidCap (hsOLDErrorClass | 0x11)
  • #define hsErrIndicatorDisabled (hsOLDErrorClass | 0x12)
  • #define hsErrUnderflow (hsExtErrorClass | 0x13)
  • #define hsErrUserNoRadio (hsExtErrorClass | 0x14)
  • #define hsErrOutOfCoverage (hsExtErrorClass | 0x15)
  • #define hsErrAppStopEvent (hsExtErrorClass | 0x16)
  • #define hsErrOutOfMemory (hsExtErrorClass | 0x17)
  • #define hsErrSIMMissing (hsExtErrorClass | 0x18)
  • #define hsErrGPRSNotAttached (hsExtErrorClass | 0x19)
  • #define hsErrTimeOut (hsExtErrorClass | 0x1A)
  • #define hsErrUserInterrupted (hsExtErrorClass | 0x1B)
  • #define hsLibAliasDefault "Serial Library"
  • #define hsLibAliasHotSyncLocal "*HsLoc SerLib"
  • #define hsLibAliasHotSyncModem "*HsMdm SerLib"
  • #define hsLibAliasIrda "*Irda SerLib"
  • #define hsLibAliasConsole "*Cons SerLib"
  • #define hsLibNameBuiltInSerial "BuiltIn SerLib"
  • #define hsFtrCreator 'hsEx'
  • #define hsFtrIDVersion 0
  • #define hsFtrIDModDate 1
  • #define hsFtrIDLdbMgrLibRefNum 2
  • #define hsFtrIDNoMemSemaphore 3
  • #define hsFtrIDBugsFixed 4
  • #define hsFtrIDTypeOfKeyboard 5
  • #define hsFtrValKeyboardBasic 0x0001
  • #define hsFtrValKeyboardQwerty 0x0002
  • #define hsFtrValKeyboardJog 0x0004
  • #define hsFtrValKeyboardCommCentric 0x0008
  • #define hsFtrValKeyboardCustomApps 0x0010
  • #define hsFtrIDRadioAttributes 6
  • #define hsFtrValRadioAvailable 0x0001
  • #define hsFtrValRadioBuiltin 0x0002
  • #define hsFtrIDPowerKeyResponse 7
  • #define hsFtrValPowerKeyDoubleClkBacklight 0x0001
  • #define hsFtrValPowerKeyTripleClkInvert 0x0002
  • #define hsFtrValPowerKeyHoldRadioPower 0x0004
  • #define hsFtrIDStatusGadgetRev 8
  • #define hsFtrValStatusGadgetRev1 0x0001
  • #define hsFtrIDGrfAreaDisabled 9
  • #define hsFtrIDKeyboardLayout 10
  • #define hsFtrValKeyboardLayout_enUS 0x0001
  • #define hsFtrValKeyboardLayout_deDE 0x0002
  • #define hsFtrValKeyboardLayout_frFR 0x0003
  • #define hsFtrIDToneOnLidOpen 11
  • #define hsFtrIDCurrentAppOnSleep 12
  • #define hsFtrValCurrentAppOnSleepPhoneAppSpeedDialView 0x0001
  • #define hsFtrIDTestingBootMode 13
  • #define hsFtrIDNavigationSupported 14
  • #define hsFtrIDHardwareApiRevision 15
  • #define hsDispFtrCreator 'DisA'
  • #define hsDispFtrIDDisplayAttributes 0
Values for the display attributes, which is a bitfield.
  • #define hsDispFtrValLCDControllerTypeMask 0x000000FF
  • #define hsDispFtrValDragonballVZ 0x00000000
  • #define hsDispFtrValSed1375 0x00000001
  • #define hsDispFtrValSed1376 0x00000002
  • #define hsDispFtrValSed13A3 0x00000003
  • #define hsDispFtrValOmapX10 0x00000004
  • #define hsDispFtrValBulverdePxa27X 0x00000005
  • #define hsDispFtrValLCDDisplayTypeMask 0x0000FF00
  • #define hsDispFtrValBwStn 0x00000100
  • #define hsDispFtrValColorStn 0x00000200
  • #define hsDispFtrValColorTft 0x00000300
  • #define hsDispFtrValColorOled 0x00000400
Available Shades
This feature contains the number of shades of gray, red, green, and blue available on this display. Note that this will _never_ be bigger than the number of shades available on the controller, since the display is fundamentally limited by what you can set the controller to. See masks below for accessing...

  • #define hsDispFtrIDDisplayShades 1
  • #define hsDispFtrIDControllerShades 2
  • #define hsDispFtrValGrayOffset 24
  • #define hsDispFtrValRedOffset 16
  • #define hsDispFtrValGreenOffset 8
  • #define hsDispFtrValBlueOffset 0
Special values for hsPrefKeyguardAutoEnableTime
  • #define hsKeyguardAutoDisabled 0
  • #define hsKeyguardAutoPowerOff 0xFFFF
Values for hsPrefKeyguardFlags
  • #define hsKeyguardFlagPowerOnDialog 0x0001
Bit definitions for hsPrefTouchscreenDisableFlags
  • #define hsTouchscreenDisableFlagIncomingCall 0x0001
  • #define hsTouchscreenDisableFlagDuringCall 0x0002
Bit Flag for Light Circumstances
application may call HsCurrentLightCircumstance() to get current enabled light circumstances

test bit to see if light circumstance is enabled or disabled

  • #define hsLightCircumstanceAlertWokeDeviceFlagBit 0x0001
  • #define hsLightCircumstanceQuickTypingFlagBit 0x0002
  • #define hsLightCircumstanceUserNotLookingFlagBit 0x0004
  • #define hsLightCircumstanceUserNotLookingLongTimeFlagBit 0x0008
  • #define hsLightCircumstanceKeylightOffFlagBit 0x0010
HAL IDs
Handspring generally doesn't differentiate different HALs and uses the same ID in multiple places... Use the device ID to figure out which devide you're on. If you're looking to see which version of HsExtensions is available, see the HsExtensions feature (hsFtrIDVersion)...

  • #define hsHALIDHandspringOs35_40 'Hs01'
  • #define hsHALIDHandspringOs5Rev1 'H5_1'
  • #define hsHALIDHandspringOs5Rev1Sim 'H5s1'
  • #define hsHALIDHandspringOs5Rev2 'H5_2'
  • #define hsHALIDHandspringOs5Rev2Sim 'H5s2'
  • #define hsHALIDHandspringOs5Rev3 'P052'
  • #define hsHALIDHandspringOs5Rev3Sim 'S052'
  • #define hsHALIDHandspringOs5Rev4 'P053'
  • #define hsHALIDHandspringOs5Rev4Sim 'S053'
Device IDs
Older devices don't use 4-character constants; newer devices do. Sometimes devices will have the same ID if they are extremely similar. You may need to use alternate means to differentiate between such products.

  • #define hsDeviceIDVisor 0x00
  • #define hsDeviceIDVisorPlatinum 0x08
  • #define hsDeviceIDVisorEdge 0x09
  • #define hsDeviceIDVisorPrism 0x0A
  • #define hsDeviceIDTreo180 0x0B
  • #define hsDeviceIDTreo270 0x0D
  • #define hsDeviceIDTreo300 0x0E
  • #define hsDeviceIDVisorNeo 0x8A
  • #define hsDeviceIDVisorPro 0x8B
  • #define hsDeviceIDTreo90 0x8C

Enumerations

  • enum HsVerStrEnum {
    hsVerStrComplete,
    hsVerStrSerialNo,
    hsVerStrHardware,
    hsVerStrProductName,
    hsVerStrCarrierID,
    hsVerStrProductRev,
    hsVerStrROMBuild,
    hsVerStrFirmwareVer,
    hsVerStrPalmOSVer,
    hsVerStrLifeTime
    }
  • enum HsAttrEnum {
    hsAttr68KLidOpen,
    hsAttr68KSysSleepReason,
    hsAttr68KDisplayOn,
    hsAttr68KRingSwitch,
    hsAttr68KPostProcessRsc,
    hsAttr68KSysActive,
    hsAttr68KActiveCalls,
    hsAttr68KPhoneType,
    hsAttr68KKeyboardLocked,
    hsAttr68KKeyLockNextWakeTicks,
    hsAttrLidOpen = 0x80,
    hsAttrSysSleepReason,
    hsAttrDisplayOn,
    hsAttrRingSwitch,
    hsAttrPostProcessRsc,
    hsAttrSysActive,
    hsAttrActiveCalls,
    hsAttrPhoneType,
    hsAttrKeyboardLocked,
    hsAttrKeyLockNextWakeTicks,
    hsAttrKeyboardDB,
    hsAttrDigitizerLock,
    hsAttrE911Mode,
    hsAttrDitherSuppress,
    hsAttrHotSyncSuppress,
    hsAttrPhoneRadioPowerState,
    hsAttrAllKeysWakeFromSleep,
    hsForcePrefAutoOffDurationSecs,
    hsAttrKeyguardDialogOn,
    hsAttrReserved_SDK20_1,
    hsAttrReserved_SDK20_2,
    hsAttrReserved_SDK20_3,
    hsAttrReserved_SDK20_4,
    hsAttrReserved_SDK20_5,
    hsAttrReserved_SDK20_6,
    hsAttrReserved_SDK20_7
    }
  • enum HsPrefEnum {
    hsPrefSerialLibDef,
    hsPrefSerialLibHotSyncLocal,
    hsPrefSerialLibHotSyncModem,
    hsPrefSerialLibIrda,
    hsPrefSerialLibConsole,
    hsPrefJogScanCharAppCreator,
    hsPrefLidStatusChgCharAppCreator,
    hsPrefOptHard1CharAppCreator,
    hsPrefOptHard2CharAppCreator,
    hsPrefOptHard3CharAppCreator,
    hsPrefOptHard4CharAppCreator,
    hsPrefTempShiftTimeOut,
    hsPrefLidClosedAutoOffSeconds,
    hsPrefLCDRefreshRate,
    hsPrefNetworkTimeSelected,
    hsPrefKeyguardAutoEnableTime,
    hsPrefKeyguardAutoEnableAutoOffExtraTime,
    hsPrefKeyguardFlags,
    hsPrefTouchscreenDisableFlags,
    hsPrefOptHardPowerCharAppCreator,
    hsPrefOptReservedCharAppCreator,
    hsPrefPowerOnAppCreator,
    hsPrefSideHardCharAppCreator,
    hsPrefBlinkGreenLEDInCoverage,
    hsPrefHard11CharAppCreator,
    hsPrefOptHard11CharAppCreator,
    hsPrefUserNotLookingTime,
    hsPrefNetworkTZSelected,
    hsPrefShortSideHardCharAppCreator,
    hsPrefPowerSaveMode,
    hsPrefLast
    }
  • enum HsStatusGadgetTypeEnum {
    hsStatusGadgetBattery = 1,
    hsStatusGadgetSignal = 2
    }
  • enum HsLightModeEnum {
    hsLightModeNormal = 0,
    hsLightModeNight = 1,
    hsLightModeNumPresets,
    hsLightModeReserved = 0x7FFF
    }
  • enum HsLightCircumstanceEnum {
    hsLightCircumstanceFirst = 0,
    hsLightCircumstanceAlertWokeDevice = 0,
    hsLightCircumstanceQuickTyping = 1,
    hsLightCircumstanceUserNotLooking = 2,
    hsLightCircumstanceUserNotLookingLongTime = 3,
    hsLightCircumstanceKeylightOff = 4,
    hsLightCircumstanceNumCircumstances,
    hsLightCircumstanceReserved = 0x7FFF
    }
  • enum HsIndicatorTypeEnum {
    kIndicatorTypeLed,
    kIndicatorTypeVibrator,
    kIndicatorTypeCount
    }
  • enum HsIndicatorCountEnum {
    kIndicatorCountGetState = 0,
    kIndicatorCountForever = 0xFFFF
    }
  • enum HsIndicatorStateEnum {
    kIndicatorStateNull = 0x0000,
    kIndicatorForceNone = 0x0100,
    kIndicatorForceOn = 0x0101,
    kIndicatorForceRed = 0x0101,
    kIndicatorForceGreen,
    kIndicatorForceRedGreen,
    kIndicatorForceOff = 0x0180,
    kIndicatorRingNone = 0x0200,
    kIndicatorRingActive,
    kIndicatorRingContact,
    kIndicatorRingRoam,
    kIndicatorAlertNone = 0x0300,
    kIndicatorAlertAlert,
    kIndicatorAlertMail,
    kIndicatorAlertCalendar,
    kIndicatorAlertSMS,
    kIndicatorAlertVoicemail,
    kIndicatorAlertPending,
    kIndicatorBattNone = 0x0400,
    kIndicatorBattCharge,
    kIndicatorBattTrickle,
    kIndicatorBattFull,
    kIndicatorBattLow,
    kIndicatorUsageNone = 0x0600,
    kIndicatorUsageVoiceCall,
    kIndicatorUsageDataCall,
    kIndicatorSignalNone = 0x0500,
    kIndicatorSignalBad,
    kIndicatorSignalGood,
    kIndicatorSignalRoam
    }

Define Documentation

#define hsAttrPhoneTypeCDMA 0x0001

Type of phone. Possible values of hsAttrPhoneType CDMA Phone

Definition at line 66 of file HsExtCommon.h.

#define hsAttrPhoneTypeGSM 0x0002

GSM Phone

Definition at line 67 of file HsExtCommon.h.

#define hsAttrRingSwitchLoud 0x8000

Sounds-on position

Definition at line 76 of file HsExtCommon.h.

#define hsAttrRingSwitchMute 0

Possible values of hsAttrRingSwitch For now there are only two values, but it's left open to have a control that works more like a volume control and has a range of settings. The value of the "loud" setting was chosen so that it can be decided later to make this a bit field or a scalar value. Silent position

Definition at line 75 of file HsExtCommon.h.

#define hsAttrSysActiveBeamProgress 0x0004

Beam Progress dialog is up

Definition at line 59 of file HsExtCommon.h.

#define hsAttrSysActiveHotSync 0x0001

Current system activity. Possible bits for hsAttrSysActivity Hot sync in progress

Definition at line 57 of file HsExtCommon.h.

#define hsAttrSysActiveProgress 0x0002

Progress dialog is up (any progress dialog)

Definition at line 58 of file HsExtCommon.h.

#define hsDeviceIDOs5Device1 kPalmOneDeviceIDTreo600

Definition at line 951 of file HsExtCommon.h.

#define hsDeviceIDOs5Device1Sim kPalmOneDeviceIDTreo600Sim

Definition at line 952 of file HsExtCommon.h.

#define hsDeviceIDTreo180 0x0B

Treo 180

Definition at line 936 of file HsExtCommon.h.

#define hsDeviceIDTreo270 0x0D

Treo 270

Definition at line 937 of file HsExtCommon.h.

#define hsDeviceIDTreo300 0x0E

Treo 300

Definition at line 938 of file HsExtCommon.h.

#define hsDeviceIDTreo600 kPalmOneDeviceIDTreo600

Treo 600

Definition at line 947 of file HsExtCommon.h.

#define hsDeviceIDTreo600Sim kPalmOneDeviceIDTreo600Sim

Treo 600 Simulator

Definition at line 948 of file HsExtCommon.h.

#define hsDeviceIDTreo90 0x8C

Treo 90

Definition at line 941 of file HsExtCommon.h.

#define hsDeviceIDVisor 0x00

Visor, Visor Deluxe

Definition at line 932 of file HsExtCommon.h.

#define hsDeviceIDVisorEdge 0x09

Visor Edge

Definition at line 934 of file HsExtCommon.h.

#define hsDeviceIDVisorNeo 0x8A

Visor Neo (some Neos may have 0x08)

Definition at line 939 of file HsExtCommon.h.

#define hsDeviceIDVisorPlatinum 0x08

Visor Platinum, some Visor Neos

Definition at line 933 of file HsExtCommon.h.

#define hsDeviceIDVisorPrism 0x0A

Visor Prism

Definition at line 935 of file HsExtCommon.h.

#define hsDeviceIDVisorPro 0x8B

Visor Pro

Definition at line 940 of file HsExtCommon.h.

#define hsDispFtrCreator 'DisA'

Display Attribute Features

Definition at line 347 of file HsExtCommon.h.

#define hsDispFtrIDControllerShades 2

This feature contains the number of shades of gray, red, green, and blue available on this controller. This can be larger than the number of shades that the display can show, since the controller can do hardware dithering to deal with the fact that the display can't show all the shades.

Software dithering is handled separately. If there is software dithering, it can be suppressed. See hsAttrDitherSuppress

Definition at line 392 of file HsExtCommon.h.

#define hsDispFtrIDDisplayAttributes 0

Attributes about the display / controller combination...

Definition at line 350 of file HsExtCommon.h.

#define hsDispFtrIDDisplayShades 1

Definition at line 381 of file HsExtCommon.h.

#define hsDispFtrValBlueOffset 0

Definition at line 402 of file HsExtCommon.h.

#define hsDispFtrValBulverdePxa27X 0x00000005

Intel Bulverde PXA 270, 271, etc.

Definition at line 363 of file HsExtCommon.h.

#define hsDispFtrValBwStn 0x00000100

The black and white STN used in black and white Visors and Treos.

Definition at line 366 of file HsExtCommon.h.

#define hsDispFtrValColorOled 0x00000400

Organic LED

Definition at line 369 of file HsExtCommon.h.

#define hsDispFtrValColorStn 0x00000200

Color STN

Definition at line 367 of file HsExtCommon.h.

#define hsDispFtrValColorTft 0x00000300

Color TFT (used in Prism)

Definition at line 368 of file HsExtCommon.h.

#define hsDispFtrValDragonballVZ 0x00000000

Definition at line 358 of file HsExtCommon.h.

#define hsDispFtrValGrayOffset 24

You can use these bitmasks to get the number of shades ...note that the actual number of shades is the (value+1). This is needed so in the future we can support displays/controllers that can have 256 shades.

Definition at line 399 of file HsExtCommon.h.

#define hsDispFtrValGreenOffset 8

Definition at line 401 of file HsExtCommon.h.

#define hsDispFtrValLCDControllerTypeMask 0x000000FF

Definition at line 357 of file HsExtCommon.h.

#define hsDispFtrValLCDDisplayTypeMask 0x0000FF00

Definition at line 365 of file HsExtCommon.h.

#define hsDispFtrValOmapX10 0x00000004

TI OMAP 1510/310

Definition at line 362 of file HsExtCommon.h.

#define hsDispFtrValRedOffset 16

Definition at line 400 of file HsExtCommon.h.

#define hsDispFtrValSed1375 0x00000001

Definition at line 359 of file HsExtCommon.h.

#define hsDispFtrValSed1376 0x00000002

Definition at line 360 of file HsExtCommon.h.

#define hsDispFtrValSed13A3 0x00000003

Definition at line 361 of file HsExtCommon.h.

#define hsErrAppStopEvent (hsExtErrorClass | 0x16)

The blocking call was interrupted by AppStop event

Definition at line 134 of file HsExtCommon.h.

#define hsErrBufferTooSmall (hsOLDErrorClass | 0x05)

Error codes

Definition at line 102 of file HsExtCommon.h.

#define hsErrCardNotInstalled (hsOLDErrorClass | 0x0A)

Error codes

Definition at line 107 of file HsExtCommon.h.

#define hsErrCardPatchAlreadyInstalled (hsOLDErrorClass | 0x07)

Error codes

Definition at line 104 of file HsExtCommon.h.

#define hsErrCardPatchNotInstalled (hsOLDErrorClass | 0x08)

Error codes

Definition at line 105 of file HsExtCommon.h.

#define hsErrFixedStorageRequired (hsOLDErrorClass | 0x0D)

Error codes

Definition at line 110 of file HsExtCommon.h.

#define hsErrGPRSNotAttached (hsExtErrorClass | 0x19)

Failed to attach GPRS, or timed out while waiting to register

Definition at line 144 of file HsExtCommon.h.

#define hsErrIndicatorDisabled (hsOLDErrorClass | 0x12)

Error codes

Definition at line 115 of file HsExtCommon.h.

#define hsErrIndicatorInvalidCap (hsOLDErrorClass | 0x11)

Error codes

Definition at line 114 of file HsExtCommon.h.

#define hsErrIndicatorInvalidSequence (hsOLDErrorClass | 0x10)

Error codes

Definition at line 113 of file HsExtCommon.h.

#define hsErrInUse (hsOLDErrorClass | 0x0F)

Error codes

Definition at line 112 of file HsExtCommon.h.

#define hsErrInvalidCardHdr (hsOLDErrorClass | 0x06)

Error codes

Definition at line 103 of file HsExtCommon.h.

#define hsErrInvalidCardNum (hsOLDErrorClass | 0x02)

Error codes

Definition at line 99 of file HsExtCommon.h.

#define hsErrInvalidParam (hsOLDErrorClass | 0x04)

Error codes

Definition at line 101 of file HsExtCommon.h.

#define hsErrInvalidPeriod (hsOLDErrorClass | 0x0B)

Error codes

Definition at line 108 of file HsExtCommon.h.

#define hsErrNotEnoughPower (hsOLDErrorClass | 0x09)

Error codes

Definition at line 106 of file HsExtCommon.h.

#define hsErrNotSupported (hsOLDErrorClass | 0x01)

Error codes

Definition at line 98 of file HsExtCommon.h.

#define hsErrOutOfCoverage (hsExtErrorClass | 0x15)

Failed to register on carrier's network, or timed out while waiting to register.

Definition at line 131 of file HsExtCommon.h.

#define hsErrOutOfMemory (hsExtErrorClass | 0x17)

Request failed because of insufficient memory

Definition at line 137 of file HsExtCommon.h.

#define hsErrPeriodicAlreadyInstalled (hsOLDErrorClass | 0x0E)

Error codes

Definition at line 111 of file HsExtCommon.h.

#define hsErrPeriodicNotInstalled (hsOLDErrorClass | 0x0C)

Error codes

Definition at line 109 of file HsExtCommon.h.

#define hsErrReadOnly (hsOLDErrorClass | 0x03)

Error codes

Definition at line 100 of file HsExtCommon.h.

#define hsErrSIMMissing (hsExtErrorClass | 0x18)

The SIM is missing, invalid, wrong unlock code, or some other SIM problem detected that prevented network registration from completing.

Definition at line 141 of file HsExtCommon.h.

#define hsErrTimeOut (hsExtErrorClass | 0x1A)

The requiested operation timed out, without completing its objective

Definition at line 147 of file HsExtCommon.h.

#define hsErrUnderflow (hsExtErrorClass | 0x13)

Unexpected numerical underflow encountered

Definition at line 124 of file HsExtCommon.h.

#define hsErrUserInterrupted (hsExtErrorClass | 0x1B)

The requiested operation was interrupted or cancelled by user, before completing its objective

Definition at line 151 of file HsExtCommon.h.

#define hsErrUserNoRadio (hsExtErrorClass | 0x14)

The user replied "No" when prompted to turn on wireless mode

Definition at line 127 of file HsExtCommon.h.

#define hsFtrCreator 'hsEx'

This is the Handspring feature id. Apps can tell if they're on a handspring device if they get 0 err back from: err = FtrGet (hsFtrCreator, hsFtrIDVersion, &value)

Definition at line 198 of file HsExtCommon.h.

#define hsFtrIDBugsFixed 4

This features contains boolean flags to let developers know that a bug present in older devices has been fixed.

Definition at line 237 of file HsExtCommon.h.

#define hsFtrIDCurrentAppOnSleep 12

This feature and value (s) is used to see if PhoneApp should be relaunched when waking up.

THIS FEATURE IS DEPRICATED

Definition at line 318 of file HsExtCommon.h.

#define hsFtrIDGrfAreaDisabled 9

If this feature is set, the graffiti area is disabled

Definition at line 287 of file HsExtCommon.h.

#define hsFtrIDHardwareApiRevision 15

This feature can be used to determine the hardware "API" revision. It changes when there's a revision of the hardware, but the device is otherwise the same. Very few apps should ever need this. Drivers should generally ask the HAL directly for this info (though HALAttr) since that's more efficient.

Definition at line 340 of file HsExtCommon.h.

#define hsFtrIDKeyboardLayout 10

This feature tells which keyboard layout is being used

Definition at line 292 of file HsExtCommon.h.

#define hsFtrIDLdbMgrLibRefNum 2

Feature number indicating that the Launcher Database Mgr library is loaded. The value of the feature is the refNum of the loaded library. Call FtrGet (hsFtrCreator, hsFtrIDLdbMgrLibRefNum, ...) to get this feature.

THIS FEATURE IS DEPRICATED

Definition at line 226 of file HsExtCommon.h.

#define hsFtrIDModDate 1

Library alias names that SysLibFind maps to a real library name according to the appropriate hsPrefSerialLibXXX setting.

By Convention, library alias names start with a '*'. The exception is the "Serial Library" name which is mapped in order to be compatible with pre-existing applications that already use it. hsPrefSerialLibDef

Definition at line 216 of file HsExtCommon.h.

#define hsFtrIDNavigationSupported 14

If this feature exists, then our navigation support exists. The version of the navigation support is stored in the feature's value.

Definition at line 331 of file HsExtCommon.h.

#define hsFtrIDNoMemSemaphore 3

If this feature is present, then we won't use the optimization to grab the memory semaphore before doing multiple data manager calls.

Definition at line 232 of file HsExtCommon.h.

#define hsFtrIDPowerKeyResponse 7

This feature defines how the power putton behaves Note: In HsExtensions 1.0 for PalmOS 5.2.1 this feature is set, but ignored

Definition at line 271 of file HsExtCommon.h.

#define hsFtrIDRadioAttributes 6

This feature describes the radio hardware available

Definition at line 260 of file HsExtCommon.h.

#define hsFtrIDStatusGadgetRev 8

This feature indicates the functionality of the status gadgets API

Definition at line 280 of file HsExtCommon.h.

#define hsFtrIDTestingBootMode 13

This feature indicates whether the Manufacturing test app is present on the device.

Definition at line 325 of file HsExtCommon.h.

#define hsFtrIDToneOnLidOpen 11

This features contains the DB Id to open and play the resource with type 'smfr' with resource id 1 when the lid opens

THIS FEATURE IS DEPRICATED

Definition at line 310 of file HsExtCommon.h.

#define hsFtrIDTypeOfKeyboard 5

This feature tells what type of hardware keys a device has.

Definition at line 244 of file HsExtCommon.h.

#define hsFtrIDVersion 0

Version of Handspring extensions 0xMMmfsHHh, where:

MM.mm.f are the major, minor, and fix revs of PalmOS which is modified by this version of HsExtensions

s is the release stage (3-release,2-beta,1-alpha,0-development)

HH.h are the major and minor rev of HsExtensions for the relevant version of PalmOS

Definition at line 213 of file HsExtCommon.h.

#define hsFtrValCurrentAppOnSleepPhoneAppSpeedDialView 0x0001

PhoneApp current view is Speed dial

Definition at line 319 of file HsExtCommon.h.

#define hsFtrValKeyboardBasic 0x0001

The masks used to interpret the hardware keyboard feature Basic keys (pwr/scroll/app)

Definition at line 249 of file HsExtCommon.h.

#define hsFtrValKeyboardCommCentric 0x0008

DEPRICATED - Communicator centric buttons

Definition at line 253 of file HsExtCommon.h.

#define hsFtrValKeyboardCustomApps 0x0010

Non-standard app keys (Standard is: date/addr/todo/memo) replaces hsFtrValKeyboardCommCentric

Definition at line 254 of file HsExtCommon.h.

#define hsFtrValKeyboardJog 0x0004

Jog keys (jog-up, jog-down,jog-scan)

Definition at line 252 of file HsExtCommon.h.

#define hsFtrValKeyboardLayout_deDE 0x0002

German

Definition at line 299 of file HsExtCommon.h.

#define hsFtrValKeyboardLayout_enUS 0x0001

The values used to interpret the keyboard layout feature English

Definition at line 298 of file HsExtCommon.h.

#define hsFtrValKeyboardLayout_frFR 0x0003

French

Definition at line 300 of file HsExtCommon.h.

#define hsFtrValKeyboardQwerty 0x0002

Qwerty keys (A-Z, Period, Space, Backspace, Enter, Menu, Option, Shift)

Definition at line 250 of file HsExtCommon.h.

#define hsFtrValPowerKeyDoubleClkBacklight 0x0001

Double click for backlight

Definition at line 272 of file HsExtCommon.h.

#define hsFtrValPowerKeyHoldRadioPower 0x0004

Hold for radio power

Definition at line 274 of file HsExtCommon.h.

#define hsFtrValPowerKeyTripleClkInvert 0x0002

Triple click for invers (requires DblClkBacklight)

Definition at line 273 of file HsExtCommon.h.

#define hsFtrValRadioAvailable 0x0001

Radio is present and available for use

Definition at line 263 of file HsExtCommon.h.

#define hsFtrValRadioBuiltin 0x0002

Radio is part of the base hardware and not on a module

Definition at line 264 of file HsExtCommon.h.

#define hsFtrValStatusGadgetRev1 0x0001

Revision 1 of API

Definition at line 282 of file HsExtCommon.h.

#define hsHALIDHandspringOs35_40 'Hs01'

Used by all Handspring OS 3.5 HALs and 4.0 HALs

Definition at line 910 of file HsExtCommon.h.

#define hsHALIDHandspringOs5Rev1 'H5_1'

Used by Handspring's 5.0 HALs

Definition at line 912 of file HsExtCommon.h.

#define hsHALIDHandspringOs5Rev1Sim 'H5s1'

Used by Handspring's 5.0 Simulator HALs

Definition at line 913 of file HsExtCommon.h.

#define hsHALIDHandspringOs5Rev2 'H5_2'

Used by Handspring's 5.2 HALs

Definition at line 915 of file HsExtCommon.h.

#define hsHALIDHandspringOs5Rev2Sim 'H5s2'

Used by Handspring's 5.2 Simulator HALs

Definition at line 916 of file HsExtCommon.h.

#define hsHALIDHandspringOs5Rev3 'P052'

Used by Handspring's 5.3 HALs

Definition at line 918 of file HsExtCommon.h.

#define hsHALIDHandspringOs5Rev3Sim 'S052'

Used by Handspring's 5.3 Simulator HALs

Definition at line 919 of file HsExtCommon.h.

#define hsHALIDHandspringOs5Rev4 'P053'

Used by Handspring's 5.4 HALs

Definition at line 921 of file HsExtCommon.h.

#define hsHALIDHandspringOs5Rev4Sim 'S053'

Used by Handspring's 5.4 Simulator HALs

Definition at line 922 of file HsExtCommon.h.

#define hsKeyguardAutoDisabled 0

Never

Definition at line 672 of file HsExtCommon.h.

#define hsKeyguardAutoPowerOff 0xFFFF

When device powers off

Definition at line 673 of file HsExtCommon.h.

#define hsKeyguardFlagPowerOnDialog 0x0001

Show keyguard dialog at power-on

Definition at line 681 of file HsExtCommon.h.

#define hsLibAliasConsole "*Cons SerLib"

hsPrefSerialLibConsole

Definition at line 175 of file HsExtCommon.h.

#define hsLibAliasDefault "Serial Library"

Library alias names that SysLibFind maps to a real library name according to the appropriate hsPrefSerialLibXXX setting.

By Convention, library alias names start with a '*'. The exception is the "Serial Library" name which is mapped in order to be compatible with pre-existing applications that already use it. hsPrefSerialLibDef

Definition at line 171 of file HsExtCommon.h.

#define hsLibAliasHotSyncLocal "*HsLoc SerLib"

hsPrefSerialLibHotSyncLocal

Definition at line 172 of file HsExtCommon.h.

#define hsLibAliasHotSyncModem "*HsMdm SerLib"

hsPrefSerialLibHotSyncModem

Definition at line 173 of file HsExtCommon.h.

#define hsLibAliasIrda "*Irda SerLib"

hsPrefSerialLibIrda

Definition at line 174 of file HsExtCommon.h.

#define hsLibNameBuiltInSerial "BuiltIn SerLib"

Actual library name of the Dragonball's built-in serial library. This is the default value of the hsPrefDefSerialLib pref setting which SysLibFind uses to map an incoming library name to an actual library name.

Definition at line 184 of file HsExtCommon.h.

#define hsLightCircumstanceAlertWokeDeviceFlagBit 0x0001

Definition at line 785 of file HsExtCommon.h.

#define hsLightCircumstanceKeylightOffFlagBit 0x0010

Definition at line 789 of file HsExtCommon.h.

#define hsLightCircumstanceQuickTypingFlagBit 0x0002

Definition at line 786 of file HsExtCommon.h.

#define hsLightCircumstanceUserNotLookingFlagBit 0x0004

Definition at line 787 of file HsExtCommon.h.

#define hsLightCircumstanceUserNotLookingLongTimeFlagBit 0x0008

Definition at line 788 of file HsExtCommon.h.

#define hsMaxSaveAsNameSize 32

This is the buffer size that should be sent to HsExtDoSaveAsDialog()

Definition at line 431 of file HsExtCommon.h.

#define hsOLDErrorClass (appErrorClass+0x0100)

Error codes

Definition at line 97 of file HsExtCommon.h.

#define hsTouchscreenDisableFlagDuringCall 0x0002

Definition at line 690 of file HsExtCommon.h.

#define hsTouchscreenDisableFlagIncomingCall 0x0001

Definition at line 689 of file HsExtCommon.h.

#define hsVersionStringSize 32

Definition at line 44 of file HsExtCommon.h.

#define hsWordCorrectMaxWordLen 25

Max length (in bytes) of a word (corrected or not) in the word correction dictionary. With null, word can be 26 bytes.

Definition at line 83 of file HsExtCommon.h.

Enumeration Type Documentation

enum HsAttrEnum

Parameters to HsAttrGet/Set calls

Enumerator:
hsAttr68KLidOpen UInt16
See also:
hsAttrLidOpen
hsAttr68KSysSleepReason UInt16
See also:
hsAttrSysSleepReason
hsAttr68KDisplayOn UInt16
See also:
hsAttrDisplayOn
hsAttr68KRingSwitch UInt16
See also:
hsAttrRingSwitch
hsAttr68KPostProcessRsc UInt32
See also:
hsAttrPostProcessRsc
hsAttr68KSysActive UInt16
See also:
hsAttrSysActive
hsAttr68KActiveCalls UInt16
See also:
hsAttrActiveCalls
hsAttr68KPhoneType UInt32
See also:
hsAttrPhoneType
hsAttr68KKeyboardLocked Boolean
See also:
hsAttrKeyboardLocked
hsAttr68KKeyLockNextWakeTicks UInt32
See also:
hsAttrKeyLockNextWakeTicks
hsAttrLidOpen | false=lid closed, true=lid open (returns hsErrNotSupported if no lid)
hsAttrSysSleepReason | Same as the SleepEventParamType.reason from the last sysNotifySleepRequestEvent unless the real reason is different (e.g. hsSysSleepLid)
hsAttrDisplayOn | true = display is on, false = dispay is off
hsAttrRingSwitch | State of ring switch, can be either hsAttrRingSwitchMute or hsAttrRingSwitchLoud
hsAttrPostProcessRsc | Pointer to resource containing the post-processing lists
hsAttrSysActive | Bits representing various system activity. Current implementation sets only the hsAttrSysActiveHotSync bit if the HotSync dialog is active
hsAttrActiveCalls | Number of active voice calls
hsAttrPhoneType | returns hsAttrPhoneTypeCDMA if a CDMA phone or hsAttrPhoneTypeGSM if a GSM phone
hsAttrKeyboardLocked | true = keyguard active
hsAttrKeyLockNextWakeTicks | deprecated
hsAttrKeyboardDB | DmOpenRef of database containing keyboard layout resources
hsAttrDigitizerLock | true = digitizer is locked
hsAttrE911Mode | true = phone is in 911 mode
hsAttrDitherSuppress | count of requests to supress dithering Set to non-zero to increment, set to zero to decrement
hsAttrHotSyncSuppress | count of requests to suppress HotSync Set to non-zero to increment, set to zero to decrement
hsAttrPhoneRadioPowerState | notifies HsExt that cell phone radio was just powered on or off; non-zero if cell phone radio was powered on, zero if powered down. Power on does *not* imply completion of SIM detection or registration
hsAttrAllKeysWakeFromSleep | (Refcount) sets the device in a mode where _all_ keys wake the device from sleep and are processed. This is intended in special cases where we've powered off the screen to save power (or something similar), but the user still thinks the device of the device as on. As a side effect, this will stop 'keyboard lock' from starting when the device turns off. Set to non-zero to increment, set to zero to decrement
hsForcePrefAutoOffDurationSecs
hsAttrKeyguardDialogOn
hsAttrReserved_SDK20_1
hsAttrReserved_SDK20_2
hsAttrReserved_SDK20_3
hsAttrReserved_SDK20_4
hsAttrReserved_SDK20_5
hsAttrReserved_SDK20_6
hsAttrReserved_SDK20_7

Definition at line 474 of file HsExtCommon.h.

00475   { /*
00476      *  These attributes with various sizes are defined
00477      *  only for compatability with existing 68K code, and
00478      *  are explicitly marshalled by the 68K/ARM shim for
00479      *  the HsAttrGet() and HsAttrSet() functions.
00480      *
00481      *  Note: The definitions for hsAttrE911Mode in the
00482      *  OS 3.5 headers, and for hsAttrKeyboardLocked in
00483      *  the OS 4.0 headers both had an enum value of 8.
00484      *  Apps using hsAttrE911Mode will probably have to be
00485      *  recompiled anyway so backward compatability has
00486      *  been maintained hsAttrKeyboardLocked.
00487      */
00488     hsAttr68KLidOpen,               /**< UInt16 @see hsAttrLidOpen */
00489     hsAttr68KSysSleepReason,        /**< UInt16 @see hsAttrSysSleepReason */
00490     hsAttr68KDisplayOn,             /**< UInt16  @see hsAttrDisplayOn */
00491     hsAttr68KRingSwitch,            /**< UInt16 @see hsAttrRingSwitch */
00492     hsAttr68KPostProcessRsc,        /**< UInt32 @see hsAttrPostProcessRsc */
00493     hsAttr68KSysActive,             /**< UInt16 @see hsAttrSysActive */
00494     hsAttr68KActiveCalls,           /**< UInt16 @see hsAttrActiveCalls */
00495     hsAttr68KPhoneType,             /**< UInt32 @see hsAttrPhoneType */
00496     hsAttr68KKeyboardLocked,        /**< Boolean @see hsAttrKeyboardLocked */
00497     hsAttr68KKeyLockNextWakeTicks,  /**< UInt32 @see hsAttrKeyLockNextWakeTicks */
00498
00499     /*
00500      * All new 68K and ARM code shall use only the following
00501      * attributes, all of which take a 32-bit value parameter.
00502      */
00503     hsAttrLidOpen = 0x80,       /**< false=lid closed, true=lid open
00504                                     (returns hsErrNotSupported if no lid) */
00505     hsAttrSysSleepReason,       /**< Same as the SleepEventParamType.reason
00506                                        from the last sysNotifySleepRequestEvent
00507                                        unless the real reason is different
00508                                        (e.g. hsSysSleepLid) */
00509     hsAttrDisplayOn,            /**< true = display is on, false = dispay is off */
00510     hsAttrRingSwitch,       /**< State of ring switch, can be either hsAttrRingSwitchMute or hsAttrRingSwitchLoud */
00511     hsAttrPostProcessRsc,       /**< Pointer to resource containing the post-processing lists */
00512     hsAttrSysActive,            /**< Bits representing various system activity. Current
00513                                      implementation sets only the hsAttrSysActiveHotSync
00514                                      bit if the HotSync dialog is active*/
00515     hsAttrActiveCalls,          /**< Number of active voice calls */
00516     hsAttrPhoneType,            /**< returns hsAttrPhoneTypeCDMA if a CDMA phone
00517                                      or hsAttrPhoneTypeGSM if a GSM phone */
00518     hsAttrKeyboardLocked,       /**< true = keyguard active */
00519     hsAttrKeyLockNextWakeTicks, /**< deprecated */
00520     hsAttrKeyboardDB,           /**< DmOpenRef of database containing keyboard layout resources */
00521     hsAttrDigitizerLock,        /**< true = digitizer is locked */
00522     hsAttrE911Mode,             /**< true = phone is in 911 mode */
00523     hsAttrDitherSuppress,       /**< count of requests to supress dithering
00524                                         Set to non-zero to increment, set to zero to decrement */
00525     hsAttrHotSyncSuppress,      /**< count of requests to suppress HotSync
00526                                         Set to non-zero to increment, set to zero to decrement */
00527
00528     hsAttrPhoneRadioPowerState, /**< notifies HsExt that cell phone radio was just powered on
00529                                         or off; non-zero if cell phone radio was powered on, zero if
00530                                         powered down.  Power on does *not* imply completion of SIM
00531                                         detection or registration */
00532
00533     hsAttrAllKeysWakeFromSleep, /**< (Refcount) sets the device in a mode where _all_ keys wake
00534                                         the device from sleep and are processed.  This is intended in
00535                                         special cases where we've powered off the screen to save power
00536                                         (or something similar), but the user still thinks the device of
00537                                         the device as on.  As a side effect, this will stop 'keyboard lock'
00538                                         from starting when the device turns off.
00539                                         Set to non-zero to increment, set to zero to decrement */
00540
00541     hsForcePrefAutoOffDurationSecs, //  Forces the Keyguard dialog to have a timeout period of prefAutoOffDurationSecs
00542     hsAttrKeyguardDialogOn,         //  Denotes if the Keyguard dialog is On or not.
00543
00544     // This section is reserved so that if we need to add adds more attributes in "SDK 2.0"
00545     // products that they won't conflict with attributes added in "SDK 2.1"
00546     hsAttrReserved_SDK20_1,
00547     hsAttrReserved_SDK20_2,
00548     hsAttrReserved_SDK20_3,
00549     hsAttrReserved_SDK20_4,
00550     hsAttrReserved_SDK20_5,
00551     hsAttrReserved_SDK20_6,
00552     hsAttrReserved_SDK20_7
00553
00554     /*
00555      * Attributes greater than 0x9000 are defined for internal use
00556      * in Prv/HsExtAttr.h
00557      */
00558   } HsAttrEnum;

enum HsIndicatorCountEnum

Pass a numeric count or one of these special values to HsIndicatorState()

Enumerator:
kIndicatorCountGetState | retrieve the current state
kIndicatorCountForever | run forever

Definition at line 814 of file HsExtCommon.h.

00815   {
00816     kIndicatorCountGetState = 0,        /**< retrieve the current state */
00817     kIndicatorCountForever  = 0xFFFF    /**< run forever */
00818   }

enum HsIndicatorStateEnum

There are several different sources of turning on the indicator, (Charge, Signal, Ring, App) with each source being in exactly one state at any moment. The high byte of these enum values indicates the source, and the low byte indicates which state that source is in. Each source has a hard-coded priority, so only the indication of the highest priority source not in its "None" state will appear on the indicator. The value of the high byte does not represent the priority.

A virtual state that is used to get the state that is currently active on the indicator (the highest priority active source). This value is also the result when there is no active source. (States with * aren't used at present)

Enumerator:
kIndicatorStateNull
kIndicatorForceNone | Don't force anything
kIndicatorForceOn | Force the indicator on
kIndicatorForceRed | Force the red led on
kIndicatorForceGreen | Force the green led on
kIndicatorForceRedGreen | Force both leds on (orange)
kIndicatorForceOff | Force both leds off
kIndicatorRingNone | Phone not ringing
kIndicatorRingActive | Phone ringing
kIndicatorRingContact | *Phone ringing, CID recognized
kIndicatorRingRoam | *Phone ringing, roaming
kIndicatorAlertNone | Alert not active
kIndicatorAlertAlert | Generic alert
kIndicatorAlertMail | Incoming mail
kIndicatorAlertCalendar | Datebook alarm
kIndicatorAlertSMS | Incoming SMS
kIndicatorAlertVoicemail | Voicemail waiting
kIndicatorAlertPending | Attention alert pending
kIndicatorBattNone | Not connected to a charger
kIndicatorBattCharge | Battery is charging
kIndicatorBattTrickle | Battery is topping off
kIndicatorBattFull | Battery is fully charged
kIndicatorBattLow | *Battery is low (and not on a charger)
kIndicatorUsageNone | Not in use
kIndicatorUsageVoiceCall | Phone on an active voice call
kIndicatorUsageDataCall | Phone on an active data call
kIndicatorSignalNone | Radio turned off
kIndicatorSignalBad | Out of coverage
kIndicatorSignalGood | In coverage
kIndicatorSignalRoam | *In coverage, roaming

Definition at line 837 of file HsExtCommon.h.

00838   {
00839
00840     kIndicatorStateNull   = 0x0000,
00841
00842     kIndicatorForceNone   = 0x0100,     /**< Don't force anything */
00843     kIndicatorForceOn     = 0x0101,     /**< Force the indicator on */
00844     kIndicatorForceRed    = 0x0101,     /**< Force the red led on */
00845     kIndicatorForceGreen,               /**< Force the green led on */
00846     kIndicatorForceRedGreen,            /**< Force both leds on (orange) */
00847     kIndicatorForceOff    = 0x0180,     /**< Force both leds off */
00848
00849     kIndicatorRingNone    = 0x0200,     /**< Phone not ringing */
00850     kIndicatorRingActive,               /**< Phone ringing */
00851     kIndicatorRingContact,              /**< *Phone ringing, CID recognized */
00852     kIndicatorRingRoam,                 /**< *Phone ringing, roaming */
00853
00854     kIndicatorAlertNone   = 0x0300,     /**< Alert not active */
00855     kIndicatorAlertAlert,               /**< Generic alert */
00856     kIndicatorAlertMail,                /**< Incoming mail */
00857     kIndicatorAlertCalendar,            /**< Datebook alarm */
00858     kIndicatorAlertSMS,                 /**< Incoming SMS */
00859     kIndicatorAlertVoicemail,           /**< Voicemail waiting */
00860     kIndicatorAlertPending,             /**< Attention alert pending */
00861
00862     kIndicatorBattNone    = 0x0400,     /**< Not connected to a charger */
00863     kIndicatorBattCharge,               /**< Battery is charging */
00864     kIndicatorBattTrickle,              /**< Battery is topping off */
00865     kIndicatorBattFull,                 /**< Battery is fully charged */
00866     kIndicatorBattLow,                  /**< *Battery is low (and not on a charger) */
00867
00868     kIndicatorUsageNone   = 0x0600,     /**< Not in use */
00869     kIndicatorUsageVoiceCall,           /**< Phone on an active voice call */
00870     kIndicatorUsageDataCall,            /**< Phone on an active data call */
00871
00872     kIndicatorSignalNone  = 0x0500,         /**< Radio turned off */
00873     kIndicatorSignalBad,                /**< Out of coverage */
00874     kIndicatorSignalGood,               /**< In coverage */
00875     kIndicatorSignalRoam                /**< *In coverage, roaming */
00876   }

enum HsIndicatorTypeEnum

Enumerator:
kIndicatorTypeLed
kIndicatorTypeVibrator
kIndicatorTypeCount

Definition at line 801 of file HsExtCommon.h.

00802   {
00803     kIndicatorTypeLed,
00804     kIndicatorTypeVibrator,
00805
00806     // This must be last
00807     kIndicatorTypeCount
00808   }

enum HsLightCircumstanceEnum

These circumstances modify the mode and allow us to handle different logical circumstances on devices with different hardware.

  • These are applied in the following order: 1. Alert woke device 2. keylight off 3. Quick typing 4. User not looking 5. User not looking for a long time
Enumerator:
hsLightCircumstanceFirst
hsLightCircumstanceAlertWokeDevice | An important alert woke the device up from sleep.
hsLightCircumstanceQuickTyping | We want the user to be able to access the keyboard easily
hsLightCircumstanceUserNotLooking | We suspect the user isn't looking at the device if they're not actively using the device, so we'll dim the screen (but we don't actually want to turn it off).
hsLightCircumstanceUserNotLookingLongTime | similar to above, but if the inactivity persists then we want to turn the screen off
hsLightCircumstanceKeylightOff
hsLightCircumstanceNumCircumstances | Num circumstances. SUBJECT TO CHANGE.
hsLightCircumstanceReserved | Reserved circumstance to force compiler to use 16-bit for enum...

Definition at line 752 of file HsExtCommon.h.

00753   {
00754     hsLightCircumstanceFirst        = 0,    /**<        */
00755     hsLightCircumstanceAlertWokeDevice  = 0,    /**< An important alert woke the  device up from sleep.*/
00756     hsLightCircumstanceQuickTyping      = 1,    /**< We want the user to be able  to access the keyboard easily */
00757     hsLightCircumstanceUserNotLooking   = 2,    /**< We suspect the user isn't looking at the device if they're
00758                                  not actively using the device, so we'll dim the screen (but we don't
00759                                                   actually want to turn it off).*/
00760     hsLightCircumstanceUserNotLookingLongTime = 3,  /**< similar to above, but if the inactivity persists then
00761                                we want to turn the screen off **/
00762
00763     hsLightCircumstanceKeylightOff      = 4,    /* turn keylight off */
00764
00765     hsLightCircumstanceNumCircumstances,        /**< Num circumstances.   SUBJECT TO CHANGE.*/
00766
00767     /**
00768      *  Reserved circumstance to force compiler to use 16-bit for enum...
00769      **/
00770     hsLightCircumstanceReserved = 0x7FFF
00771   }

enum HsLightModeEnum

These are different modes that can be used to affect the light manager, which is in charge of temporary changes in the lighting situation.

Enumerator:
hsLightModeNormal | Light mode is at normal presets
hsLightModeNight | Light mode is at night-mode presets
hsLightModeNumPresets | Num presets. SUBJECT TO CHANGE.
hsLightModeReserved | Reserved mode to force compiler to use 16-bit for enum...

Definition at line 725 of file HsExtCommon.h.

00726   {
00727     // Preset modes
00728     // ------------
00729     // These modes have saved values associated with them...
00730     hsLightModeNormal = 0,      /**< Light mode is at normal presets */
00731     hsLightModeNight  = 1,      /**< Light mode is at night-mode presets */
00732
00733     hsLightModeNumPresets,  /**< Num presets.  SUBJECT TO CHANGE. */
00734
00735     /** Reserved mode to force compiler to use 16-bit for enum... */
00736     hsLightModeReserved = 0x7FFF
00737   }

enum HsPrefEnum

Equates for the HsPrefGet/Set calls

Enumerator:
hsPrefSerialLibDef | Char[] : Name of serial library to substitute for hsLibAliasDefault
hsPrefSerialLibHotSyncLocal | Char[] : Name of serial library to substitute for hsLibAliasHotSyncLocal
hsPrefSerialLibHotSyncModem | Char[] : Name of serial library to substitute for hsLibAliasHotSyncModem
hsPrefSerialLibIrda | Char[] : Name of serial library to substitute for hsLibAliasIrda
hsPrefSerialLibConsole | Char[] : Name of serial library to substitute for hsLibAliasConsole
hsPrefJogScanCharAppCreator | UInt32 : Creator type of app to launch in response to hsChrJogScan
hsPrefLidStatusChgCharAppCreator | UInt32 : Creator type of app to launch in response to hsChrLidStatusChg
hsPrefOptHard1CharAppCreator | UInt32 : Creator type of app to launch n response to hsChrOptHard1
hsPrefOptHard2CharAppCreator | UInt32 : Creator type of app to launch in response to hsChrOptHard2
hsPrefOptHard3CharAppCreator | UInt32 : Creator type of app to launch in response to hsChrOptHard3
hsPrefOptHard4CharAppCreator | UInt32 : Creator type of app to launch in response to hsChrOptHard4
hsPrefTempShiftTimeOut | UInt32 : Number of ticks until a temporary shift state (upper shift or option shift) times out.
hsPrefLidClosedAutoOffSeconds | UInt16 : Number of seconds for auto-off when the lid is closed
hsPrefLCDRefreshRate | UInt16 : Type of refresh rate for lighting see HsLCDRefreshRateEnum
hsPrefNetworkTimeSelected | UInt16: used by CDMA devices - should it read the time from the network
hsPrefKeyguardAutoEnableTime | UInt16: How many seconds to wait before enabling keyguard
hsPrefKeyguardAutoEnableAutoOffExtraTime | UInt16 : How many seconds to wait before enabling keyguard when hsPrefKeyguardAutoEnableTime is set to hsKeyguardAutoPowerOff and the device powers off due to the auto-off timer
hsPrefKeyguardFlags | UInt16 : Flags controlling keyguard's behaviour
hsPrefTouchscreenDisableFlags | UInt16: Used by the phone app to determine when to disable touchscreen
hsPrefOptHardPowerCharAppCreator | UInt32 : Creator type of app to launch in response to hsChrOptHardPower
hsPrefOptReservedCharAppCreator | UInt32 : Creator type of app to launch in response to hsChrOptReserved (for future use)
hsPrefPowerOnAppCreator | UInt32 : Creator type of app to launch instead of the normally mapped app when the app key turned the power on
hsPrefSideHardCharAppCreator | UInt32 : Creator type of app to launch instead of the normally mapped app when the side key is pressed
hsPrefBlinkGreenLEDInCoverage | UInt16 : Set to true if we want the green LED to blink when the device is in coverage
hsPrefHard11CharAppCreator | UInt32 : Creator type of app to launch in response to vchrHard11
hsPrefOptHard11CharAppCreator | UInt32 : Creator type of app to launch in response to hsChrOptHard11
hsPrefUserNotLookingTime | Int32 : After this many seconds since the last action, the user has stopped looking at the device. (auto display/kbd dim)
hsPrefNetworkTZSelected | UInt16: used by phones - should it read the time zone from the network
hsPrefShortSideHardCharAppCreator | UInt32: Creator ID of app to launch on short press of side button
hsPrefPowerSaveMode | Int32 : tied to the hsPrefUserNotLookingTime to turn off the backlight rather than just dim it. LCD remains on.
hsPrefLast

Definition at line 570 of file HsExtCommon.h.

00571   {
00572
00573     // The following are used by SysLibFind() to resolve a virtual library
00574     //  name to an actual one.  They are also used directly by SrmOpen()
00575     //  to figure out whether to override a new-style driver w/ an old-style
00576     //  driver.
00577     hsPrefSerialLibDef,     /**< Char[] : Name of serial library to substitute for hsLibAliasDefault */
00578     hsPrefSerialLibHotSyncLocal,    /**< Char[] : Name of serial library to substitute for hsLibAliasHotSyncLocal */
00579     hsPrefSerialLibHotSyncModem,    /**< Char[] : Name of serial library to substitute for hsLibAliasHotSyncModem */
00580     hsPrefSerialLibIrda,        /**< Char[] : Name of serial library to substitute for hsLibAliasIrda */
00581     hsPrefSerialLibConsole,     /**< Char[] : Name of serial library to substitute for hsLibAliasConsole */
00582
00583     /**** End of prefs recognized by Visor, Visor Deluxe, Platnium, Prism, Edge ****/
00584
00585     // The following are used in SysHandleEvent() to launch apps in response
00586     //  to associated virtual characters.
00587     hsPrefJogScanCharAppCreator,      /**< UInt32 : Creator type of app to launch in response to hsChrJogScan */
00588     hsPrefLidStatusChgCharAppCreator, /**< UInt32 : Creator type of app to launch in response to hsChrLidStatusChg */
00589     hsPrefOptHard1CharAppCreator,     /**< UInt32 : Creator type of app to launch n response to hsChrOptHard1 */
00590     hsPrefOptHard2CharAppCreator,     /**< UInt32 : Creator type of app to launch in response to hsChrOptHard2 */
00591     hsPrefOptHard3CharAppCreator,     /**< UInt32 : Creator type of app to launch in response to hsChrOptHard3 */
00592     hsPrefOptHard4CharAppCreator,     /**< UInt32 : Creator type of app to launch in response to hsChrOptHard4 */
00593
00594     // The following are used to set Key Manager preferences
00595     hsPrefTempShiftTimeOut,           /**< UInt32 : Number of ticks until a temporary
00596                         shift state (upper shift or option shift) times out. */
00597
00598     hsPrefLidClosedAutoOffSeconds,    /**< UInt16 : Number of seconds for auto-off when the lid is closed */
00599
00600     hsPrefLCDRefreshRate,         /**< UInt16 : Type of refresh rate for lighting see HsLCDRefreshRateEnum */
00601
00602     /**** End of prefs recognized by Treo 90, 180, 270, 300 ****/
00603
00604     hsPrefNetworkTimeSelected,    /**< UInt16: used by CDMA devices - should it read the time from the network*/
00605
00606     hsPrefKeyguardAutoEnableTime,     /**< UInt16: How many seconds to wait before enabling keyguard*/
00607
00608
00609     hsPrefKeyguardAutoEnableAutoOffExtraTime, /**< UInt16 : How many seconds to wait before enabling
00610                                                       keyguard when hsPrefKeyguardAutoEnableTime is
00611                                                       set to hsKeyguardAutoPowerOff and the device
00612                                                       powers off due to the auto-off timer */
00613
00614     hsPrefKeyguardFlags,              /**< UInt16 : Flags controlling keyguard's behaviour */
00615
00616     hsPrefTouchscreenDisableFlags,    /**< UInt16: Used by the phone app to determine when to disable touchscreen */
00617
00618     // The following are used in SysHandleEvent() to launch apps in response
00619     //  to associated virtual characters.
00620     hsPrefOptHardPowerCharAppCreator, /**< UInt32 : Creator type of app to launch in response to hsChrOptHardPower */
00621
00622     hsPrefOptReservedCharAppCreator,  /**< UInt32 : Creator type of app to launch in response to hsChrOptReserved (for future use) */
00623
00624     hsPrefPowerOnAppCreator,              /**< UInt32 : Creator type of app to launch
00625                                               instead of the normally mapped app when
00626                                               the app key turned the power on */
00627
00628     /**** End of prefs recognized by Treo 600 ****/
00629
00630     hsPrefSideHardCharAppCreator,       /**< UInt32 : Creator type of app to launch
00631                                               instead of the normally mapped app when
00632                                               the side key is pressed */
00633
00634     hsPrefBlinkGreenLEDInCoverage,      /**< UInt16 : Set to true if we want the green
00635                                               LED to blink when the device is in coverage */
00636
00637     /**** End of prefs recognized by Treo 650 ****/
00638
00639     hsPrefHard11CharAppCreator,       /**< UInt32 : Creator type of app to launch
00640                                               in response to vchrHard11 */
00641
00642     hsPrefOptHard11CharAppCreator,    /**< UInt32 : Creator type of app to launch
00643                                               in response to hsChrOptHard11 */
00644
00645     hsPrefUserNotLookingTime,           /**< Int32 : After this many seconds since the last
00646                                                 action, the user has stopped looking
00647                                                 at the device. (auto display/kbd dim) */
00648
00649     // <chg 2005-DEC-14 Monte Benaresh> Added next pref
00650
00651     hsPrefNetworkTZSelected,            /**< UInt16: used by phones - should it read
00652                                                 the time zone from the network*/
00653
00654     // RJS 22May06 Added next pref for PTT
00655     hsPrefShortSideHardCharAppCreator,      /**< UInt32: Creator ID of app to launch on short press of side button */
00656
00657     // RTS April 06 Added pref for Gnome/Gandalf
00658     hsPrefPowerSaveMode,            /**< Int32 : tied to the hsPrefUserNotLookingTime to turn off the backlight
00659                              rather than just dim it.  LCD remains on.*/
00660
00661     // Leave this one at end!!!
00662     hsPrefLast
00663
00664   } HsPrefEnum;

enum HsStatusGadgetTypeEnum

Equates for supporting system handled status gadgets

Enumerator:
hsStatusGadgetBattery | Status gadget is a battery meter
hsStatusGadgetSignal | Status gadget is a signal strength indicator

Definition at line 702 of file HsExtCommon.h.

00703   {
00704     hsStatusGadgetBattery = 1,          /**< Status gadget is a battery meter */
00705     hsStatusGadgetSignal = 2            /**< Status gadget is a signal strength indicator */
00706   } HsStatusGadgetTypeEnum;

enum HsVerStrEnum

Enumerator:
hsVerStrComplete | Composite, formatted for display in info dialog
hsVerStrSerialNo | Complete serial number (ROM token 'snum' is limited to 12 digits)
hsVerStrHardware | Revision of the hardware
hsVerStrProductName | Like, "Treo 600"
hsVerStrCarrierID | Carrier ID code for carrier branding
hsVerStrProductRev | Complete product; covering hardware, radio firmware and software
hsVerStrROMBuild | ROM buld number (not the same as the build number in sysFtrNumROMVersion)
hsVerStrFirmwareVer | Version of the radio firmware
hsVerStrPalmOSVer | See sysFtrNumROMVersion
hsVerStrLifeTime | Radio life timer

Definition at line 449 of file HsExtCommon.h.

00450   {
00451     hsVerStrComplete,       /**< Composite, formatted for display in info dialog */
00452     hsVerStrSerialNo,       /**< Complete serial number (ROM token 'snum' is limited to 12 digits) */
00453     hsVerStrHardware,       /**< Revision of the hardware */
00454     hsVerStrProductName,        /**< Like, "Treo 600" */
00455     hsVerStrCarrierID,      /**< Carrier ID code for carrier branding */
00456     hsVerStrProductRev,     /**< Complete product; covering hardware, radio firmware and software */
00457     hsVerStrROMBuild,       /**< ROM buld number (not the same as the build number in sysFtrNumROMVersion) */
00458     hsVerStrFirmwareVer,        /**< Version of the radio firmware */
00459     hsVerStrPalmOSVer,      /**< See sysFtrNumROMVersion */
00460     hsVerStrLifeTime        /**< Radio life timer */
00461   } HsVerStrEnum;

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:07:04 2008 for Palm API Guide


Header Files » Incs » 68k » system

HsExtKbdUtils.h File Reference

Detailed Description

Version:
Date:

Definition in file HsExtKbdUtils.h.

Go to the source code of this file.

Functions

  • Int16 HsPostProcessPopupList (Boolean overrideFont, FontID overrideFontID)
    Parameters:
    overrideFont,: IN:

Function Documentation

Int16 HsPostProcessPopupList | ( | Boolean | overrideFont,
 |  | FontID | overrideFontID
 | ) |  |

Parameters:
overrideFont,: IN:

Parameters:
overrideFontID,: IN:
Return values:
Error code.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:07:04 2008 for Palm API Guide


Header Files » Incs » 68k » system

HsExtTraps.h File Reference

Detailed Description

Definitions of selectors used for the 68K trap based calls to HsExtensions.

Version:
Date:

Definition in file HsExtTraps.h.

Go to the source code of this file.

Defines

  • #define sysTrapOEMDispatch 0xA349
    OEM trap in Palm OS 3.0 and later trap table (formerly sysTrapSysReserved4).
  • #define hsSelectorBase 0
  • #define hsSelInfo 0x0
  • #define hsSelPrvInit 0x1
  • #define hsSelPrvCallSafely 0x2
  • #define hsSelPrvCallSafelyNewStack 0x3
  • #define hsSelDatabaseCopy 0x4
  • #define hsSelExtKeyboardEnable 0x5
  • #define hsSelCardAttrGet 0x6
  • #define hsSelCardAttrSet 0x7
  • #define hsSelCardEventPost 0x8
  • #define hsSelPrvErrCatchListP 0x9
  • #define hsSelPrefGet 0xA
  • #define hsSelPrefSet 0xB
  • #define hsSelDmGetNextDBByTypeCreator 0xC
  • #define hsSelDmGetNextDBInit 0xD
  • #define hsSelCardHdrUpdate 0xE
  • #define hsSelAppEventHandlerSet 0xF
  • #define hsSelAppEventPost 0x10
  • #define hsSelUsbCommStatePtr 0x11
  • #define hsSelCardPatchInstall 0x12
  • #define hsSelCardPatchRemove 0x13
  • #define hsSelEvtResetAutoOffTimer 0x14
  • #define hsSelDmDatabaseUniqueIDSeed 0x15
  • #define hsSelAboutHandspringApp 0x16
  • #define hsSelDmDatabaseIsOpen 0x17
  • #define hsSelDmDatabaseIsProtected 0x18
  • #define hsSelDlkForceSlowSync 0x19
  • #define hsSelPrvHandleCardChangeEvent 0x1A
  • #define hsSelCardPower 0x1B
  • #define hsSelDmDatabaseDeleted 0x1C
  • #define hsSelDmLockFileSystem 0x1D
  • #define hsSelPrvLaunchCompareFunc 0x1E
  • #define hsSelPrvLEDCommand 0x1F
  • #define hsInstallSerialWrapper 0x20
  • #define hsUninstallSerialWrapper 0x21
  • #define hsPeriodicRegister 0x22
  • #define hsPeriodicUnregister 0x23
  • #define hsPeriodicPeriodsAvailable 0x24
  • #define hsSelPrvSetButtonDefault 0x25
  • #define hsSelPrvFindAppFromIDs 0x26
  • #define hsSelAttrGet 0x27
  • #define hsSelAttrSet 0x28
  • #define hsSelKeyCurrentStateExt 0x29
  • #define hsSelKeySetMaskExt 0x2A
  • #define hsSelGrfSetStateExt 0x2B
  • #define hsSelGrfGetStateExt 0x2C
  • #define hsSelKeyChrToOptChr 0x2D
  • #define hsSelKeyChrToRegChr 0x2E
  • #define hsSelPrvKeyHandleEvent 0x2F
  • #define hsSelWordCorrectInvoke 0x30
  • #define hsSelWordCorrectUndo 0x31
  • #define hsSelPrvUpdateBatteryGadget 0x32
  • #define hsSelPrvUpdateSignalGadget 0x33
  • #define hsSelStatusSetGadgetType 0x34
  • #define hsSelSysKeyboardReferenceDialog 0x35
  • #define hsSelPutObjectAfterTitle 0x36
  • #define hsSelEvtMetaEvent 0x37
  • #define hsSelStatusUpdateGadgets 0x38
  • #define hsSelLstPopupListExt 0x39
  • #define hsSelDmCreateDatabasesFromImages 0x3A
  • #define hsSelPrvLaunchDemoApp 0x3B
  • #define hsSelPrefGetAppKeyCreator 0x3C
  • #define hsSelUtilFrmDoDialogWithCallback 0x3D
  • #define hsSelHsGetTrapAddress 0x3E
  • #define hsSelHsSetTrapAddress 0x3F
  • #define hsSelUnimplemented 0x40
  • #define hsSelIndicator 0x41
  • #define hsSelUtilSclUpdateScrollBar 0x42
  • #define hsSelUtilSclScroll 0x43
  • #define hsSelUtilSclScrollPage 0x44
  • #define hsSelPrvInitPostProcess 0x45
  • #define hsSelPostProcPopupList 0x46
  • #define hsSelPeriodicUnregisterFromSelf 0x47
  • #define hsSelNetworkDropConnection 0x48
  • #define hsSelPrvSetupGoToCustomForm 0x49
  • #define hsSelPrvSetupInstallFormEventHandler 0x4A
  • #define hsSelUtilSliHandleKeyDown 0x4B
  • #define hsSelUtilWinGetMaxDepth 0x4C
  • #define hsSelLightMode 0x4D
  • #define hsSelLightCircumstance 0x4E
  • #define hsSelUtilBbutInstallFromResource 0x4F
  • #define hsSelUtilBbutHitBigButton 0x50
  • #define hsSelUtilFrmDoDialog 0x51
  • #define hsSelUtilStrCSpn 0x52
  • #define hsSelUtilFrmDoTimedDialog 0x53
  • #define hsSelReserved352H5_54 0x54
  • #define hsSelReserved352H5_55 0x55
  • #define hsSelReserved352H5_56 0x56
  • #define hsSelReserved352H5_57 0x57
  • #define hsSelReserved352H5_58 0x58
  • #define hsSelReserved352H5_59 0x59
  • #define hsSelReserved352H5_5A 0x5A
  • #define hsSelReserved352H5_5B 0x5B
  • #define hsSelReserved352H5_5C 0x5C
  • #define hsSelReserved352H5_5D 0x5D
  • #define hsSelReserved352H6_5E 0x5E
  • #define hsSelReserved352H6_5F 0x5F
  • #define hsSelReserved352H6_60 0x60
  • #define hsSelReserved352H6_61 0x61
  • #define hsSelReserved352H6_62 0x62
  • #define hsSelReserved352H6_63 0x63
  • #define hsSelReserved352H6_64 0x64
  • #define hsSelReserved352H6_65 0x65
  • #define hsSelReserved352H6_66 0x66
  • #define hsSelReserved352H6_67 0x67
  • #define hsSelReserved352H6_68 0x68
  • #define hsSelReserved352H6_69 0x69
  • #define hsSelReserved352H6_6A 0x6A
  • #define hsSelPrvShowKeyboardLockOnDialog 0x6B
  • #define hsSelPrvHandleKeyboardLock 0x6C
  • #define hsSelSpringboardNotSupported 0x6D
  • #define hsSelReserved41_6E 0x6E
  • #define hsSelReserved41_6F 0x6F
  • #define hsSelReserved41_70 0x70
  • #define hsSelReserved41_71 0x71
  • #define hsSelReserved41_72 0x72
  • #define hsSelGetPhoneLibrary 0x86
  • #define hsSelUtilFrmSetLabel 0x87
  • #define hsSelUtilCtlGetFont 0x88
  • #define hsSelGetARMActiveFormPtr 0x8E
  • #define hsSelTwoFontSelect 0x8F
  • #define hsSelOpenDialNumberDialog 0x90
  • #define hsSelTurnRadioOn 0x91
  • #define hsSelCreateNewMessage 0x92
  • #define hsSelCreateNewEmail 0x93
  • #define hsSelBrowseUrl 0x94
  • #define hsSelNavGetFocusColor 0x95
  • #define hsSelNavSetFocusColor 0x96
  • #define hsSelNavGetFocusRingInfo 0x97
  • #define hsSelNavDrawFocusRing 0x98
  • #define hsSelNavRemoveFocusRing 0x99
  • #define hsSelNavLstGetTempSelection 0x9A
  • #define hsSelNavLstSetTempSelection 0x9B
  • #define hsSelIndicatorState 0x9C
  • #define hsSelKeysPressed 0x9D
  • #define hsSelKeyEnableKey 0x9E
  • #define hsSelKeyChrCodeToKeyCode 0x9F
  • #define hsSelKeyKeyCodeToChrCode 0xA0
  • #define hsSelKeyEventIsFromKeyboard 0xA1
  • #define hsSelTraceContextInit 0xA2
  • #define hsSelTraceContextDelete 0xA3
  • #define hsSelDoSaveAsDialog 0xA4
  • #define hsSelExgSelectTarget 0xA5
  • #define hsSelExgLocalAccept 0xA6
  • #define hsSelExgLocalDisconnect 0xA7
  • #define hsSelUtilAttnNagInfo 0xA8
  • #define hsSelCrashLogGetLast 0xA9
  • #define hsSelCrashLogDisplayLast 0xAA
  • #define hsSelTxtPrepFindString 0xAB
  • #define hsSelUtilFrmSetHelpID 0xAC
  • #define hsSelUtilFrmSetLabelFont 0xAD
  • #define hsNeverUsedBeforeAvailableForUse1 0xAE
  • #define hsSelSupressDbgLockout 0xB2
  • #define hsSelIsDbgLockoutSupressed 0xB3
  • #define hsSelKeyStop 0xB4
  • #define hsSelGetVersionString 0xB5
  • #define hsSelUtilEnableAttentionMgr 0xB6
  • #define hsSelNavObjectTakeFocus 0xB7
  • #define hsSelPostProcessPopupList 0xB8
  • #define hsSelTraceSetMaxRecords 0xB9
  • #define hsSelTraceGetMaxRecords 0xBA
  • #define hsSelWaitForGPRSAttach 0xBE
  • #define hsSelIsHTTPLibraryLoaded 0xBF
  • #define hsGetCurrentLightCircumstance 0xD0
  • #define hsSelShowHighVolAlert 0xD1
  • #define hsSelStartMemoryTracing 0xD2
  • #define hsSelLast 0xD3
  • #define hsNumSels (hsSelLast - hsSelectorBase)
This is the system trap that we base all HsExt calls off of.
  • #define sysTrapHsSelector sysTrapOEMDispatch
OS-5
  • #define hsSelUtilGetObjectUsable 0x73
  • #define hsSelUtilFrmGetDefaultButtonID 0x74
  • #define hsSelUtilFrmGetEventHandler 0x75
  • #define hsSelUtilLstGetItemsText 0x76
  • #define hsSelUtilLstGetTopItem 0x77
  • #define hsSelUtilCtlGetControlStyle 0x78
Trace Functions
  • #define hsSelTraceLevelsSet 0x79
  • #define hsSelTraceLevelsGet 0x7A
  • #define hsSelTrace 0x7B
  • #define hsSelTraceData 0x7C
  • #define hsSelTraceRecordsDump 0x7D
  • #define hsSelTraceClear 0x7E
  • #define hsSelTraceOutputLevelsSet 0x7F
  • #define hsSelTraceOutputLevelsGet 0x80
  • #define hsSelTraceText 0x81
  • #define hsSelTraceFunction 0x82
  • #define hsSelTraceError 0x83
  • #define hsSelTraceFunctionError 0x84
  • #define hsSelTraceEvent 0x85
Mutex functions -- 68K bridge to ARM-native functions
  • #define hsSelUtilMutexCreate 0x89
  • #define hsSelUtilMutexDelete 0x8A
  • #define hsSelUtilMutexReserve 0x8B
  • #define hsSelUtilMutexRelease 0x8C
Additional Trace Utility functions
  • #define hsSelTraceOpenDB 0xB0
  • #define hsSelTraceCloseDB 0xB1
multi-byte friendly Txt routines
  • #define hsSelTxtNumChars 0xBB
  • #define hsSelTxtTruncateString 0xBC
  • #define hsSelTxtIsAscii 0xBD
This range is reserved for last-minute fixes in OS-5H1-C/D/E
  • #define hsSelReserved5H1_C0 0xC0
  • #define hsSelReserved5H1_C1 0xC1
  • #define hsSelReserved5H1_C2 0xC2
  • #define hsSelReserved5H1_C3 0xC3
New AcDc traps
  • #define hsSelDispatchService 0xC4
  • #define hsSelOpenDialNumberDialogExt 0xC5
  • #define hsSelAttnGetAttentionExt 0xC6
  • #define hsSelUtilBbutInstallNewButton 0xC7
  • #define hsSelUtilBbutSetLabel 0xC8
  • #define hsSelAttnUpdateExt 0xC9
  • #define hsSelUtilAttnIndicatorAllow 0xCA
  • #define hsSelUtilBbutSetBitmap 0xCB
  • #define hsSelMenuSetCurMenuCurItem 0xCC
  • #define hsSelTraceSetCommitInterval 0xCD
  • #define hsSelTraceGetCommitInterval 0xCE
  • #define hsSelWriteROMTokens 0xCF

Define Documentation

#define hsGetCurrentLightCircumstance 0xD0

Definition at line 447 of file HsExtTraps.h.

#define hsInstallSerialWrapper 0x20

Definition at line 103 of file HsExtTraps.h.

#define hsNeverUsedBeforeAvailableForUse1 0xAE

Definition at line 352 of file HsExtTraps.h.

#define hsNumSels (hsSelLast - hsSelectorBase)

Definition at line 462 of file HsExtTraps.h.

#define hsPeriodicPeriodsAvailable 0x24

Definition at line 109 of file HsExtTraps.h.

#define hsPeriodicRegister 0x22

Definition at line 107 of file HsExtTraps.h.

#define hsPeriodicUnregister 0x23

Definition at line 108 of file HsExtTraps.h.

#define hsSelAboutHandspringApp 0x16

Definition at line 79 of file HsExtTraps.h.

#define hsSelAppEventHandlerSet 0xF

Definition at line 66 of file HsExtTraps.h.

#define hsSelAppEventPost 0x10

Definition at line 67 of file HsExtTraps.h.

#define hsSelAttnGetAttentionExt 0xC6

Definition at line 419 of file HsExtTraps.h.

#define hsSelAttnUpdateExt 0xC9

Definition at line 432 of file HsExtTraps.h.

#define hsSelAttrGet 0x27

Definition at line 122 of file HsExtTraps.h.

#define hsSelAttrSet 0x28

Definition at line 123 of file HsExtTraps.h.

#define hsSelBrowseUrl 0x94

Definition at line 313 of file HsExtTraps.h.

#define hsSelCardAttrGet 0x6

Definition at line 51 of file HsExtTraps.h.

#define hsSelCardAttrSet 0x7

Definition at line 52 of file HsExtTraps.h.

#define hsSelCardEventPost 0x8

Definition at line 53 of file HsExtTraps.h.

#define hsSelCardHdrUpdate 0xE

Definition at line 64 of file HsExtTraps.h.

#define hsSelCardPatchInstall 0x12

Definition at line 71 of file HsExtTraps.h.

#define hsSelCardPatchRemove 0x13

Definition at line 72 of file HsExtTraps.h.

#define hsSelCardPower 0x1B

Definition at line 91 of file HsExtTraps.h.

#define hsSelCrashLogDisplayLast 0xAA

Definition at line 344 of file HsExtTraps.h.

#define hsSelCrashLogGetLast 0xA9

Definition at line 343 of file HsExtTraps.h.

#define hsSelCreateNewEmail 0x93

Definition at line 312 of file HsExtTraps.h.

#define hsSelCreateNewMessage 0x92

Definition at line 311 of file HsExtTraps.h.

#define hsSelDatabaseCopy 0x4

Definition at line 49 of file HsExtTraps.h.

#define hsSelDispatchService 0xC4

Definition at line 408 of file HsExtTraps.h.

#define hsSelDlkForceSlowSync 0x19

Definition at line 85 of file HsExtTraps.h.

#define hsSelDmCreateDatabasesFromImages 0x3A

DO NOT CHANGE used in object patch!

Definition at line 155 of file HsExtTraps.h.

#define hsSelDmDatabaseDeleted 0x1C

Definition at line 93 of file HsExtTraps.h.

#define hsSelDmDatabaseIsOpen 0x17

Definition at line 82 of file HsExtTraps.h.

#define hsSelDmDatabaseIsProtected 0x18

Definition at line 83 of file HsExtTraps.h.

#define hsSelDmDatabaseUniqueIDSeed 0x15

Definition at line 76 of file HsExtTraps.h.

#define hsSelDmGetNextDBByTypeCreator 0xC

Definition at line 61 of file HsExtTraps.h.

#define hsSelDmGetNextDBInit 0xD

Definition at line 62 of file HsExtTraps.h.

#define hsSelDmLockFileSystem 0x1D

Definition at line 95 of file HsExtTraps.h.

#define hsSelDoSaveAsDialog 0xA4

Definition at line 336 of file HsExtTraps.h.

#define hsSelectorBase 0

Definition at line 40 of file HsExtTraps.h.

#define hsSelEvtMetaEvent 0x37

Definition at line 149 of file HsExtTraps.h.

#define hsSelEvtResetAutoOffTimer 0x14

Definition at line 74 of file HsExtTraps.h.

#define hsSelExgLocalAccept 0xA6

Definition at line 338 of file HsExtTraps.h.

#define hsSelExgLocalDisconnect 0xA7

Definition at line 339 of file HsExtTraps.h.

#define hsSelExgSelectTarget 0xA5

Definition at line 337 of file HsExtTraps.h.

#define hsSelExtKeyboardEnable 0x5

Definition at line 50 of file HsExtTraps.h.

#define hsSelGetARMActiveFormPtr 0x8E

Definition at line 306 of file HsExtTraps.h.

#define hsSelGetPhoneLibrary 0x86

Definition at line 291 of file HsExtTraps.h.

#define hsSelGetVersionString 0xB5

Definition at line 368 of file HsExtTraps.h.

#define hsSelGrfGetStateExt 0x2C

Definition at line 129 of file HsExtTraps.h.

#define hsSelGrfSetStateExt 0x2B

Definition at line 128 of file HsExtTraps.h.

#define hsSelHsGetTrapAddress 0x3E

Definition at line 162 of file HsExtTraps.h.

#define hsSelHsSetTrapAddress 0x3F

Definition at line 166 of file HsExtTraps.h.

#define hsSelIndicator 0x41

Definition at line 172 of file HsExtTraps.h.

#define hsSelIndicatorState 0x9C

Definition at line 325 of file HsExtTraps.h.

#define hsSelInfo 0x0

Definition at line 42 of file HsExtTraps.h.

#define hsSelIsDbgLockoutSupressed 0xB3

Definition at line 364 of file HsExtTraps.h.

#define hsSelIsHTTPLibraryLoaded 0xBF

Definition at line 390 of file HsExtTraps.h.

#define hsSelKeyChrCodeToKeyCode 0x9F

Definition at line 329 of file HsExtTraps.h.

#define hsSelKeyChrToOptChr 0x2D

Definition at line 132 of file HsExtTraps.h.

#define hsSelKeyChrToRegChr 0x2E

Definition at line 133 of file HsExtTraps.h.

#define hsSelKeyCurrentStateExt 0x29

Definition at line 125 of file HsExtTraps.h.

#define hsSelKeyEnableKey 0x9E

Definition at line 328 of file HsExtTraps.h.

#define hsSelKeyEventIsFromKeyboard 0xA1

Definition at line 331 of file HsExtTraps.h.

#define hsSelKeyKeyCodeToChrCode 0xA0

Definition at line 330 of file HsExtTraps.h.

#define hsSelKeySetMaskExt 0x2A

Definition at line 126 of file HsExtTraps.h.

#define hsSelKeysPressed 0x9D

Definition at line 327 of file HsExtTraps.h.

#define hsSelKeyStop 0xB4

Definition at line 366 of file HsExtTraps.h.

#define hsSelLast 0xD3

Definition at line 458 of file HsExtTraps.h.

#define hsSelLightCircumstance 0x4E

Definition at line 197 of file HsExtTraps.h.

#define hsSelLightMode 0x4D

Definition at line 196 of file HsExtTraps.h.

#define hsSelLstPopupListExt 0x39

Definition at line 154 of file HsExtTraps.h.

#define hsSelMenuSetCurMenuCurItem 0xCC

Definition at line 438 of file HsExtTraps.h.

#define hsSelNavDrawFocusRing 0x98

Definition at line 318 of file HsExtTraps.h.

#define hsSelNavGetFocusColor 0x95

Definition at line 315 of file HsExtTraps.h.

#define hsSelNavGetFocusRingInfo 0x97

Definition at line 317 of file HsExtTraps.h.

#define hsSelNavLstGetTempSelection 0x9A

Definition at line 320 of file HsExtTraps.h.

#define hsSelNavLstSetTempSelection 0x9B

Definition at line 321 of file HsExtTraps.h.

#define hsSelNavObjectTakeFocus 0xB7

Definition at line 372 of file HsExtTraps.h.

#define hsSelNavRemoveFocusRing 0x99

Definition at line 319 of file HsExtTraps.h.

#define hsSelNavSetFocusColor 0x96

Definition at line 316 of file HsExtTraps.h.

#define hsSelNetworkDropConnection 0x48

Definition at line 186 of file HsExtTraps.h.

#define hsSelOpenDialNumberDialog 0x90

Definition at line 309 of file HsExtTraps.h.

#define hsSelOpenDialNumberDialogExt 0xC5

Definition at line 410 of file HsExtTraps.h.

#define hsSelPeriodicUnregisterFromSelf 0x47

Definition at line 183 of file HsExtTraps.h.

#define hsSelPostProcessPopupList 0xB8

Definition at line 374 of file HsExtTraps.h.

#define hsSelPostProcPopupList 0x46

Definition at line 181 of file HsExtTraps.h.

#define hsSelPrefGet 0xA

Definition at line 57 of file HsExtTraps.h.

#define hsSelPrefGetAppKeyCreator 0x3C

Definition at line 157 of file HsExtTraps.h.

#define hsSelPrefSet 0xB

Definition at line 58 of file HsExtTraps.h.

#define hsSelPrvCallSafely 0x2

Definition at line 46 of file HsExtTraps.h.

#define hsSelPrvCallSafelyNewStack 0x3

Definition at line 47 of file HsExtTraps.h.

#define hsSelPrvErrCatchListP 0x9

Definition at line 54 of file HsExtTraps.h.

#define hsSelPrvFindAppFromIDs 0x26

Definition at line 119 of file HsExtTraps.h.

#define hsSelPrvHandleCardChangeEvent 0x1A

Definition at line 87 of file HsExtTraps.h.

#define hsSelPrvHandleKeyboardLock 0x6C

Definition at line 244 of file HsExtTraps.h.

#define hsSelPrvInit 0x1

Definition at line 45 of file HsExtTraps.h.

#define hsSelPrvInitPostProcess 0x45

Definition at line 180 of file HsExtTraps.h.

#define hsSelPrvKeyHandleEvent 0x2F

Definition at line 134 of file HsExtTraps.h.

#define hsSelPrvLaunchCompareFunc 0x1E

Definition at line 97 of file HsExtTraps.h.

#define hsSelPrvLaunchDemoApp 0x3B

DO NOT CHANGE used in object patch!

Definition at line 156 of file HsExtTraps.h.

#define hsSelPrvLEDCommand 0x1F

Definition at line 101 of file HsExtTraps.h.

#define hsSelPrvSetButtonDefault 0x25

Definition at line 118 of file HsExtTraps.h.

#define hsSelPrvSetupGoToCustomForm 0x49

DO NOT CHANGE used in object patch!

Definition at line 189 of file HsExtTraps.h.

#define hsSelPrvSetupInstallFormEventHandler 0x4A

DO NOT CHANGE used in object patch!

Definition at line 190 of file HsExtTraps.h.

#define hsSelPrvShowKeyboardLockOnDialog 0x6B

Definition at line 243 of file HsExtTraps.h.

#define hsSelPrvUpdateBatteryGadget 0x32

Definition at line 137 of file HsExtTraps.h.

#define hsSelPrvUpdateSignalGadget 0x33

Definition at line 138 of file HsExtTraps.h.

#define hsSelPutObjectAfterTitle 0x36

Definition at line 147 of file HsExtTraps.h.

#define hsSelReserved352H5_54 0x54

Definition at line 211 of file HsExtTraps.h.

#define hsSelReserved352H5_55 0x55

Definition at line 212 of file HsExtTraps.h.

#define hsSelReserved352H5_56 0x56

Definition at line 213 of file HsExtTraps.h.

#define hsSelReserved352H5_57 0x57

Definition at line 214 of file HsExtTraps.h.

#define hsSelReserved352H5_58 0x58

Definition at line 215 of file HsExtTraps.h.

#define hsSelReserved352H5_59 0x59

Definition at line 216 of file HsExtTraps.h.

#define hsSelReserved352H5_5A 0x5A

Definition at line 217 of file HsExtTraps.h.

#define hsSelReserved352H5_5B 0x5B

Definition at line 218 of file HsExtTraps.h.

#define hsSelReserved352H5_5C 0x5C

Definition at line 219 of file HsExtTraps.h.

#define hsSelReserved352H5_5D 0x5D

Definition at line 220 of file HsExtTraps.h.

#define hsSelReserved352H6_5E 0x5E

Definition at line 226 of file HsExtTraps.h.

#define hsSelReserved352H6_5F 0x5F

Definition at line 227 of file HsExtTraps.h.

#define hsSelReserved352H6_60 0x60

Definition at line 228 of file HsExtTraps.h.

#define hsSelReserved352H6_61 0x61

Definition at line 229 of file HsExtTraps.h.

#define hsSelReserved352H6_62 0x62

Definition at line 230 of file HsExtTraps.h.

#define hsSelReserved352H6_63 0x63

Definition at line 231 of file HsExtTraps.h.

#define hsSelReserved352H6_64 0x64

Definition at line 232 of file HsExtTraps.h.

#define hsSelReserved352H6_65 0x65

Definition at line 233 of file HsExtTraps.h.

#define hsSelReserved352H6_66 0x66

Definition at line 234 of file HsExtTraps.h.

#define hsSelReserved352H6_67 0x67

Definition at line 235 of file HsExtTraps.h.

#define hsSelReserved352H6_68 0x68

Definition at line 236 of file HsExtTraps.h.

#define hsSelReserved352H6_69 0x69

Definition at line 237 of file HsExtTraps.h.

#define hsSelReserved352H6_6A 0x6A

Definition at line 238 of file HsExtTraps.h.

#define hsSelReserved41_6E 0x6E

Definition at line 251 of file HsExtTraps.h.

#define hsSelReserved41_6F 0x6F

Definition at line 252 of file HsExtTraps.h.

#define hsSelReserved41_70 0x70

Definition at line 253 of file HsExtTraps.h.

#define hsSelReserved41_71 0x71

Definition at line 254 of file HsExtTraps.h.

#define hsSelReserved41_72 0x72

Definition at line 255 of file HsExtTraps.h.

#define hsSelReserved5H1_C0 0xC0

Definition at line 397 of file HsExtTraps.h.

#define hsSelReserved5H1_C1 0xC1

Definition at line 398 of file HsExtTraps.h.

#define hsSelReserved5H1_C2 0xC2

Definition at line 399 of file HsExtTraps.h.

#define hsSelReserved5H1_C3 0xC3

Definition at line 400 of file HsExtTraps.h.

#define hsSelShowHighVolAlert 0xD1

Definition at line 449 of file HsExtTraps.h.

#define hsSelSpringboardNotSupported 0x6D

Definition at line 247 of file HsExtTraps.h.

#define hsSelStartMemoryTracing 0xD2

Definition at line 451 of file HsExtTraps.h.

#define hsSelStatusSetGadgetType 0x34

Definition at line 141 of file HsExtTraps.h.

#define hsSelStatusUpdateGadgets 0x38

Definition at line 151 of file HsExtTraps.h.

#define hsSelSupressDbgLockout 0xB2

Definition at line 363 of file HsExtTraps.h.

#define hsSelSysKeyboardReferenceDialog 0x35

Definition at line 144 of file HsExtTraps.h.

#define hsSelTrace 0x7B

Definition at line 278 of file HsExtTraps.h.

#define hsSelTraceClear 0x7E

Definition at line 281 of file HsExtTraps.h.

#define hsSelTraceCloseDB 0xB1

Definition at line 360 of file HsExtTraps.h.

#define hsSelTraceContextDelete 0xA3

Definition at line 334 of file HsExtTraps.h.

#define hsSelTraceContextInit 0xA2

Definition at line 333 of file HsExtTraps.h.

#define hsSelTraceData 0x7C

Definition at line 279 of file HsExtTraps.h.

#define hsSelTraceError 0x83

Definition at line 286 of file HsExtTraps.h.

#define hsSelTraceEvent 0x85

Definition at line 288 of file HsExtTraps.h.

#define hsSelTraceFunction 0x82

Definition at line 285 of file HsExtTraps.h.

#define hsSelTraceFunctionError 0x84

Definition at line 287 of file HsExtTraps.h.

#define hsSelTraceGetCommitInterval 0xCE

Definition at line 441 of file HsExtTraps.h.

#define hsSelTraceGetMaxRecords 0xBA

Definition at line 377 of file HsExtTraps.h.

#define hsSelTraceLevelsGet 0x7A

Definition at line 277 of file HsExtTraps.h.

#define hsSelTraceLevelsSet 0x79

Definition at line 276 of file HsExtTraps.h.

#define hsSelTraceOpenDB 0xB0

Definition at line 359 of file HsExtTraps.h.

#define hsSelTraceOutputLevelsGet 0x80

Definition at line 283 of file HsExtTraps.h.

#define hsSelTraceOutputLevelsSet 0x7F

Definition at line 282 of file HsExtTraps.h.

#define hsSelTraceRecordsDump 0x7D

Definition at line 280 of file HsExtTraps.h.

#define hsSelTraceSetCommitInterval 0xCD

Definition at line 440 of file HsExtTraps.h.

#define hsSelTraceSetMaxRecords 0xB9

Definition at line 376 of file HsExtTraps.h.

#define hsSelTraceText 0x81

Definition at line 284 of file HsExtTraps.h.

#define hsSelTurnRadioOn 0x91

Definition at line 310 of file HsExtTraps.h.

#define hsSelTwoFontSelect 0x8F

Definition at line 308 of file HsExtTraps.h.

#define hsSelTxtIsAscii 0xBD

Definition at line 386 of file HsExtTraps.h.

#define hsSelTxtNumChars 0xBB

Definition at line 384 of file HsExtTraps.h.

#define hsSelTxtPrepFindString 0xAB

Definition at line 346 of file HsExtTraps.h.

#define hsSelTxtTruncateString 0xBC

Definition at line 385 of file HsExtTraps.h.

#define hsSelUnimplemented 0x40

Definition at line 169 of file HsExtTraps.h.

#define hsSelUsbCommStatePtr 0x11

Definition at line 69 of file HsExtTraps.h.

#define hsSelUtilAttnIndicatorAllow 0xCA

Definition at line 434 of file HsExtTraps.h.

#define hsSelUtilAttnNagInfo 0xA8

Definition at line 341 of file HsExtTraps.h.

#define hsSelUtilBbutHitBigButton 0x50

Definition at line 200 of file HsExtTraps.h.

#define hsSelUtilBbutInstallFromResource 0x4F

Definition at line 199 of file HsExtTraps.h.

#define hsSelUtilBbutInstallNewButton 0xC7

Definition at line 421 of file HsExtTraps.h.

#define hsSelUtilBbutSetBitmap 0xCB

Definition at line 436 of file HsExtTraps.h.

#define hsSelUtilBbutSetLabel 0xC8

Definition at line 423 of file HsExtTraps.h.

#define hsSelUtilCtlGetControlStyle 0x78

Definition at line 268 of file HsExtTraps.h.

#define hsSelUtilCtlGetFont 0x88

Definition at line 293 of file HsExtTraps.h.

#define hsSelUtilEnableAttentionMgr 0xB6

Definition at line 370 of file HsExtTraps.h.

#define hsSelUtilFrmDoDialog 0x51

Definition at line 201 of file HsExtTraps.h.

#define hsSelUtilFrmDoDialogWithCallback 0x3D

Definition at line 160 of file HsExtTraps.h.

#define hsSelUtilFrmDoTimedDialog 0x53

Definition at line 204 of file HsExtTraps.h.

#define hsSelUtilFrmGetDefaultButtonID 0x74

Definition at line 264 of file HsExtTraps.h.

#define hsSelUtilFrmGetEventHandler 0x75

Definition at line 265 of file HsExtTraps.h.

#define hsSelUtilFrmSetHelpID 0xAC

Definition at line 348 of file HsExtTraps.h.

#define hsSelUtilFrmSetLabel 0x87

Definition at line 292 of file HsExtTraps.h.

#define hsSelUtilFrmSetLabelFont 0xAD

Definition at line 349 of file HsExtTraps.h.

#define hsSelUtilGetObjectUsable 0x73

Definition at line 263 of file HsExtTraps.h.

#define hsSelUtilLstGetItemsText 0x76

Definition at line 266 of file HsExtTraps.h.

#define hsSelUtilLstGetTopItem 0x77

Definition at line 267 of file HsExtTraps.h.

#define hsSelUtilMutexCreate 0x89

Definition at line 300 of file HsExtTraps.h.

#define hsSelUtilMutexDelete 0x8A

Definition at line 301 of file HsExtTraps.h.

#define hsSelUtilMutexRelease 0x8C

Definition at line 303 of file HsExtTraps.h.

#define hsSelUtilMutexReserve 0x8B

Definition at line 302 of file HsExtTraps.h.

#define hsSelUtilSclScroll 0x43

Definition at line 176 of file HsExtTraps.h.

#define hsSelUtilSclScrollPage 0x44

Definition at line 177 of file HsExtTraps.h.

#define hsSelUtilSclUpdateScrollBar 0x42

Definition at line 175 of file HsExtTraps.h.

#define hsSelUtilSliHandleKeyDown 0x4B

Definition at line 193 of file HsExtTraps.h.

#define hsSelUtilStrCSpn 0x52

Definition at line 203 of file HsExtTraps.h.

#define hsSelUtilWinGetMaxDepth 0x4C

Definition at line 194 of file HsExtTraps.h.

#define hsSelWaitForGPRSAttach 0xBE

Definition at line 389 of file HsExtTraps.h.

#define hsSelWordCorrectInvoke 0x30

Definition at line 135 of file HsExtTraps.h.

#define hsSelWordCorrectUndo 0x31

Definition at line 136 of file HsExtTraps.h.

#define hsSelWriteROMTokens 0xCF

Definition at line 443 of file HsExtTraps.h.

#define hsUninstallSerialWrapper 0x21

Definition at line 105 of file HsExtTraps.h.

#define sysTrapHsSelector sysTrapOEMDispatch

Definition at line 36 of file HsExtTraps.h.

#define sysTrapOEMDispatch 0xA349

OEM trap in Palm OS 3.0 and later trap table (formerly sysTrapSysReserved4).

Definition at line 28 of file HsExtTraps.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:07:05 2008 for Palm API Guide


Header Files » Incs » 68k » system

HsExtUtilBigButton.h File Reference

Detailed Description

Version:
3.0
Date:
12/18/2001
Description: This file contains routines for managing 'big' buttons, which are thumbable buttons with a bitmap and some text (common in applications designed to be used for telephony)

History: 2001-12-18 dia Creaded by Doug Anderson 2002-01-22 dia Supports or
as line endings now. Note that '
' is not supported (it's treated as two separate line endings)

Definition in file HsExtUtilBigButton.h.

Go to the source code of this file.

Functions

  • Err HsUtilBbutInstallFromResource (FormType *frmP)
    Parameters:
    frmP,: IN:

  • void HsUtilBbutInstallNewButton (FormType *frmP, UInt16 gadgetID, const Char *textP, FontID font, UInt8 flags)
    Parameters:
    frmP,: IN:

  • void HsUtilBbutSetLabel (FormType *frmP, UInt16 gadgetID, const Char *newLabel)
    Parameters:
    frmP,: IN:

  • void HsUtilBbutSetBitmap (FormType *frmP, UInt16 gadgetID, const BitmapPtr bitmapP)
    Parameters:
    frmP,: IN:

  • void HsUtilBbutHitBigButton (FormType *frmP, UInt16 gadgetIndex)
    Parameters:
    frmP,: IN:

Function Documentation

void HsUtilBbutHitBigButton | ( | FormType * | frmP,
 |  | UInt16 | gadgetIndex
 | ) |  |

Parameters:
frmP,: IN:

Parameters:
gadgetIndex,: IN:
Return values:
Error code.

Err HsUtilBbutInstallFromResource ( FormType * frmP )

Parameters:
frmP,: IN:

Return values:
Error code.

void HsUtilBbutInstallNewButton | ( | FormType * | frmP,
 |  | UInt16 | gadgetID,
 |  | const Char * | textP,
 |  | FontID | font,
 |  | UInt8 | flags
 | ) |  |

Parameters:
frmP,: IN:

Parameters:
gadgetID,: IN:
textP,: IN:
font,: IN:
flags,: IN:
Return values:
Error code.

void HsUtilBbutSetBitmap | ( | FormType * | frmP,
 |  | UInt16 | gadgetID,
 |  | const BitmapPtr | bitmapP
 | ) |  |

Parameters:
frmP,: IN:

Parameters:
gadgetID,: IN:
bitmapP,: IN:
Return values:
Error code.

void HsUtilBbutSetLabel | ( | FormType * | frmP,
 |  | UInt16 | gadgetID,
 |  | const Char * | newLabel
 | ) |  |

Parameters:
frmP,: IN:

Parameters:
gadgetID,: IN:
newLabel,: IN:
Return values:
Error code.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:07:05 2008 for Palm API Guide


Header Files » Incs » common » system

HsExtUtilBigButtonCommon.h File Reference

Detailed Description

<Common code for Big Buttons that can be used by ARM and 68K code.>

<This file contains all defines and enums that are used by Big Buttons. There are some structs here too that might need to be moved to 68K/ARM specific code. Moved code from HsExtUtilBigButton.h >

Copyright (c) 2002 Handspring Inc., All Rights Reserved

Author:
Arun Mathias
Id
//depot/Components/Extensions/HsExtensions/1.0E/Incs/IncsPublic/Common/HsExtUtilBigButtonCommon.h#2

Definition in file HsExtUtilBigButtonCommon.h.

Go to the source code of this file.

Data Structures

  • struct HsBigButtonMappingType
  • struct HsBigButtonReourceType

Defines

  • #define bbutGadgetMiscSelectSelector 7014
  • #define bbutGadgetMiscSelectData ((void*)0xBADC0DE1)
  • #define hsBigButtonRscType 'bBut'

Define Documentation

#define bbutGadgetMiscSelectData ((void*)0xBADC0DE1)

Magic # to make conflicts even less likely for detecting big button presses.

Definition at line 51 of file HsExtUtilBigButtonCommon.h.

#define bbutGadgetMiscSelectSelector 7014

This selector gets sent with a frmGadgetMiscEvent to let you know that the gadget has been selected. The numbers are picked semi-randomly so that generic code (like HsUtilFrmDoDialogWithCallback()) can tell that this is actually a button press without doing the wrong thing for other people's gadget events.

Note that in most code, you shouldn't need to worry about checking the data, since you know exactly what gadgets are on your form and what kind of events they send. Randomish number so people can easily detect big button presses

Definition at line 49 of file HsExtUtilBigButtonCommon.h.

#define hsBigButtonRscType 'bBut'

This is the type of big button resources. The ID should match the ID of the form... Registered: yes

Definition at line 59 of file HsExtUtilBigButtonCommon.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:07:05 2008 for Palm API Guide


Header Files » Incs » common » system

HsExtUtilBigButtonRsc.h File Reference

Go to the source code of this file.

Defines

  • #define __HS_EXT_UTIL_BIG_BUTTON_RSC__H__ 1
  • #define hsBigButtonMappingVersion0 0
  • #define hsBigButtonFlagNone 0x00
  • #define hsBigButtonFlagNoBorder 0x01
  • #define hsBigButtonFlagNoBackground 0x02
  • #define hsBigButtonFlagNoBorderOrBackground 0x03
  • #define hsBigButtonFontStd 0
  • #define hsBigButtonFontBold 1
  • #define hsBigButtonFontLarge 2
  • #define hsBigButtonFontSymbol 3
  • #define hsBigButtonFontSymbol11 4
  • #define hsBigButtonFontSymbol7 5
  • #define hsBigButtonFontLed 6
  • #define hsBigButtonFontLargeBold 7

Define Documentation

#define __HS_EXT_UTIL_BIG_BUTTON_RSC__H__ 1

Definition at line 32 of file HsExtUtilBigButtonRsc.h.

#define hsBigButtonFlagNoBackground 0x02

Definition at line 78 of file HsExtUtilBigButtonRsc.h.

#define hsBigButtonFlagNoBorder 0x01

Definition at line 77 of file HsExtUtilBigButtonRsc.h.

#define hsBigButtonFlagNoBorderOrBackground 0x03

Definition at line 79 of file HsExtUtilBigButtonRsc.h.

#define hsBigButtonFlagNone 0x00

Definition at line 76 of file HsExtUtilBigButtonRsc.h.

#define hsBigButtonFontBold 1

Definition at line 84 of file HsExtUtilBigButtonRsc.h.

#define hsBigButtonFontLarge 2

Definition at line 85 of file HsExtUtilBigButtonRsc.h.

#define hsBigButtonFontLargeBold 7

Definition at line 90 of file HsExtUtilBigButtonRsc.h.

#define hsBigButtonFontLed 6

Definition at line 89 of file HsExtUtilBigButtonRsc.h.

#define hsBigButtonFontStd 0

Definition at line 83 of file HsExtUtilBigButtonRsc.h.

#define hsBigButtonFontSymbol 3

Definition at line 86 of file HsExtUtilBigButtonRsc.h.

#define hsBigButtonFontSymbol11 4

Definition at line 87 of file HsExtUtilBigButtonRsc.h.

#define hsBigButtonFontSymbol7 5

Definition at line 88 of file HsExtUtilBigButtonRsc.h.

#define hsBigButtonMappingVersion0 0

Definition at line 71 of file HsExtUtilBigButtonRsc.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:07:05 2008 for Palm API Guide


Header Files » Incs » 68k » system

HsHelper.h File Reference

Detailed Description

Version:
1.0
Date:
Description: Public header file for the Handspring helper functions

Definition in file HsHelper.h.

Include dependency graph for HsHelper.h:

Go to the source code of this file.

Data Structures

  • struct PmGetNewMsgCountNotifyParamType
    Param structure for pmNotifyGetNewMsgCountFromHelper notifications. More...
  • struct PmBroadcastNewMsgCountNotifyParamType
    Param structure for pmNotifyBroadcastNewMsgCount notifications. More...

Defines

  • #define sysNotifyHelperEvent 'hlpr'
  • #define HelperEnumerateEnqueueEntry(enumEvtDataP, entryP)

Typedefs

  • typedef struct PmGetNewMsgCountNotifyParamType * PmGetNewMsgCountNotifyParamPtr
  • typedef struct PmBroadcastNewMsgCountNotifyParamType * PmBroadcastNewMsgCountNotifyParamPtr

Define Documentation

#define HelperEnumerateEnqueueEntry | ( | enumEvtDataP,
 |  | entryP | )

Value:

do                                                \
    {                                                 \
    (entryP)->nextP = (enumEvtDataP)    ;     \
    (enumEvtDataP) = (entryP);                \
    }                                                 \
  while (0)
MACRO: HelperEnumerateEnqueueEntry

Enqueues a node of type HelperEvtEnumerateNodeType. Each node must be individually allocated from the heap by the helper.

PROTOTYPE: void HelperEnumNodeEnqueue(HelperNotifyEnumerateType* enumEvtDataP, HelperNotifyEnumerateListType* entryP);

Definition at line 30 of file HsHelper.h.

#define sysNotifyHelperEvent 'hlpr'

Definition at line 18 of file HsHelper.h.

Typedef Documentation

typedef struct PmBroadcastNewMsgCountNotifyParamType * PmBroadcastNewMsgCountNotifyParamPtr

typedef struct PmGetNewMsgCountNotifyParamType * PmGetNewMsgCountNotifyParamPtr

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:07:05 2008 for Palm API Guide


Header Files » Incs » common » system

HsKeyCodes.h File Reference

Detailed Description

Version:
1.0
Date:
This file defines the key codes. These match the vchrs for virtual key characters, but vchars are only used in the legacy event loop. Everywhere else, they are considered deprecated in favor of key now. These are NOT ascii, unicode or otherwise although, for standard QWERTY US keboards, the key codes for the letters are the same as the lowercase ASCII values, but only so it's easier to determine what you're looking at.

Note: This is a Palm OS 6 header that we got early in order to make the Handspring key driver as close as possible to what it should be in the future. This header will be depricated in favor of Palm's official header once it's in their SDK.

Definition in file HsKeyCodes.h.

Go to the source code of this file.

Enumerations

  • enum KeyCodeType {
    keyNull = 0x0000,
    keyBackspace = 0x0008,
    keyTab = 0x0009,
    keyReturn = 0x000a,
    keyPageUp = 0x000b,
    keyPageDown = 0x000c,
    keyNumericEnter = 0x000d,
    keyEscape = 0x001b,
    keyLeftArrow = 0x001c,
    keyRightArrow = 0x001d,
    keyUpArrow = 0x001e,
    keyDownArrow = 0x001f,
    keySpace = 0x0020,
    keySingleQuote = 0x0027,
    keyComma = 0x002c,
    keyDash = 0x002d,
    keyPeriod = 0x002e,
    keySlash = 0x002f,
    keyZero = 0x0030,
    keyOne = 0x0031,
    keyTwo = 0x0032,
    keyThree = 0x0033,
    keyFour = 0x0034,
    keyFive = 0x0035,
    keySix = 0x0036,
    keySeven = 0x0037,
    keyEight = 0x0038,
    keyNine = 0x0039,
    keySemiColon = 0x003b,
    keyLessThan = 0x003c,
    keyEquals = 0x003d,
    keyAt = 0x0040,
    keyOpenBracket = 0x005b,
    keyBackslash = 0x005c,
    keyCloseBracket = 0x005d,
    keyBacktick = 0x0060,
    keyA = 0x0061,
    keyB = 0x0062,
    keyC = 0x0063,
    keyD = 0x0064,
    keyE = 0x0065,
    keyF = 0x0066,
    keyG = 0x0067,
    keyH = 0x0068,
    keyI = 0x0069,
    keyJ = 0x006a,
    keyK = 0x006b,
    keyL = 0x006c,
    keyM = 0x006d,
    keyN = 0x006e,
    keyO = 0x006f,
    keyP = 0x0070,
    keyQ = 0x0071,
    keyR = 0x0072,
    keyS = 0x0073,
    keyT = 0x0074,
    keyU = 0x0075,
    keyV = 0x0076,
    keyW = 0x0077,
    keyX = 0x0078,
    keyY = 0x0079,
    keyZ = 0x007a,
    keyNextField = 0x0103,
    keyMenu = 0x0105,
    keyLaunch = 0x0108,
    keyFind = 0x010A,
    keyPrevField = 0x010C,
    keyLockDevice = 0x0112,
    keyThumbWheelUp = 0x012E,
    keyThumbWheelDown = 0x012F,
    keyThumbWheelPush = 0x0130,
    keyThumbWheelBack = 0x0131,
    keyRockerUp = 0x0132,
    keyRockerDown = 0x0133,
    keyRockerLeft = 0x0134,
    keyRockerRight = 0x0135,
    keyRockerCenter = 0x0136,
    keyHard1 = 0x0204,
    keyHard2 = 0x0205,
    keyHard3 = 0x0206,
    keyHard4 = 0x0207,
    keyHardPower = 0x0208,
    keyHardCradle = 0x0209,
    keyHardCradle2 = 0x020A,
    keyHardContrast = 0x020B,
    keyHardAntenna = 0x020C,
    keyHardBrightness = 0x020D,
    keyHard5 = 0x0214,
    keyHard6 = 0x0215,
    keyHard7 = 0x0216,
    keyHard8 = 0x0217,
    keyHard9 = 0x0218,
    keyHard10 = 0x0219,
    keyHard11 = 0x021A,
    keyHard12 = 0x021B,
    keyHard13 = 0x021C,
    keyHard14 = 0x021D,
    hsKeyMfgTest = 0x1600,
    hsKeySymbol = 0x1609,
    hsKeyRadioPower = 0x160C,
    keyLeftShift = 0xe000,
    keyRightShift = 0xe001,
    keyLeftControl = 0xe002,
    keyRightControl = 0xe003,
    keyLeftCommand = 0xe004,
    keyRightCommand = 0xe005,
    keyLeftAlt = 0xe006,
    keyRightAlt = 0xe007,
    keySide = 0xe008,
    keyHelp = 0xe009,
    keyNumLock = 0xe00a,
    keyScrollLock = 0xe00b,
    keyCapsLock = 0xe00c,
    keyInsert = 0xe00d,
    keyDelete = 0xe00e,
    keyHome = 0xe00f,
    keyEnd = 0xe010,
    keyPrintScreen = 0xe011,
    keyPause = 0xe012,
    keyNumericPeriod = 0xe013,
    keyNumericPlus = 0xe014,
    keyNumericDash = 0xe015,
    keyNumericAsterisk = 0xe016,
    keyNumericSlash = 0xe017,
    keyNumericEquals = 0xe018,
    keyNumericZero = 0xe020,
    keyNumericOne = 0xe021,
    keyNumericTwo = 0xe022,
    keyNumericThree = 0xe023,
    keyNumericFour = 0xe024,
    keyNumericFive = 0xe025,
    keyNumericSix = 0xe026,
    keyNumericSeven = 0xe027,
    keyNumericEight = 0xe028,
    keyNumericNine = 0xe029,
    keyF1 = 0xe031,
    keyF2 = 0xe032,
    keyF3 = 0xe033,
    keyF4 = 0xe034,
    keyF5 = 0xe035,
    keyF6 = 0xe036,
    keyF7 = 0xe037,
    keyF8 = 0xe038,
    keyF9 = 0xe039,
    keyF10 = 0xe03a,
    keyF11 = 0xe03b,
    keyF12 = 0xe03c,
    keyF13 = 0xe03d,
    keyF14 = 0xe03e,
    keyF15 = 0xe03f,
    keyBack = 0xe050,
    keyForward = 0xe051,
    keyStopInternet = 0xe052,
    keyRefresh = 0xe053,
    keySearch = 0xe054,
    keyFavorites = 0xe055,
    keyHomePage = 0xe056,
    keyMail = 0xe057,
    keyMute = 0xe058,
    keyVolumeUp = 0xe059,
    keyVolumeDown = 0xe05a,
    keyPlay = 0xe05b,
    keyPauseAudio = 0x305c,
    keyPlayPause = 0xe05d,
    keyStopAudio = 0xe05e,
    keyPrevTrack = 0xe05f,
    keyNextTrack = 0xe060,
    keyFastForward = 0xe061,
    keyRewind = 0xe062,
    keyEject = 0xe063,
    keyMedia = 0xe064,
    keyMyComputer = 0xe065,
    keyMyDocuments = 0xe066,
    keyMyMusic = 0xe067,
    keyMyPictures = 0xe068,
    keyCalculator = 0xe069,
    keyLogOff = 0xe06a
    }

Enumeration Type Documentation

enum KeyCodeType

Enumerator:
keyNull
keyBackspace
keyTab
keyReturn
keyPageUp
keyPageDown
keyNumericEnter
keyEscape
keyLeftArrow
keyRightArrow
keyUpArrow
keyDownArrow
keySpace
keySingleQuote
keyComma
keyDash
keyPeriod
keySlash
keyZero
keyOne
keyTwo
keyThree
keyFour
keyFive
keySix
keySeven
keyEight
keyNine
keySemiColon
keyLessThan
keyEquals
keyAt
keyOpenBracket
keyBackslash
keyCloseBracket
keyBacktick
keyA
keyB
keyC
keyD
keyE
keyF
keyG
keyH
keyI
keyJ
keyK
keyL
keyM
keyN
keyO
keyP
keyQ
keyR
keyS
keyT
keyU
keyV
keyW
keyX
keyY
keyZ
keyNextField
keyMenu
keyLaunch
keyFind
keyPrevField
keyLockDevice
keyThumbWheelUp
keyThumbWheelDown
keyThumbWheelPush
keyThumbWheelBack
keyRockerUp
keyRockerDown
keyRockerLeft
keyRockerRight
keyRockerCenter
keyHard1
keyHard2
keyHard3
keyHard4
keyHardPower
keyHardCradle
keyHardCradle2
keyHardContrast
keyHardAntenna
keyHardBrightness
keyHard5
keyHard6
keyHard7
keyHard8
keyHard9
keyHard10
keyHard11
keyHard12
keyHard13
keyHard14
hsKeyMfgTest
hsKeySymbol
hsKeyRadioPower
keyLeftShift
keyRightShift
keyLeftControl
keyRightControl
keyLeftCommand
keyRightCommand
keyLeftAlt
keyRightAlt
keySide
keyHelp
keyNumLock
keyScrollLock
keyCapsLock
keyInsert
keyDelete
keyHome
keyEnd
keyPrintScreen
keyPause
keyNumericPeriod
keyNumericPlus
keyNumericDash
keyNumericAsterisk
keyNumericSlash
keyNumericEquals
keyNumericZero
keyNumericOne
keyNumericTwo
keyNumericThree
keyNumericFour
keyNumericFive
keyNumericSix
keyNumericSeven
keyNumericEight
keyNumericNine
keyF1
keyF2
keyF3
keyF4
keyF5
keyF6
keyF7
keyF8
keyF9
keyF10
keyF11
keyF12
keyF13
keyF14
keyF15
keyBack
keyForward
keyStopInternet
keyRefresh
keySearch
keyFavorites
keyHomePage
keyMail
keyMute
keyVolumeUp
keyVolumeDown
keyPlay
keyPauseAudio
keyPlayPause
keyStopAudio
keyPrevTrack
keyNextTrack
keyFastForward
keyRewind
keyEject
keyMedia
keyMyComputer
keyMyDocuments
keyMyMusic
keyMyPictures
keyCalculator
keyLogOff

Definition at line 49 of file HsKeyCodes.h.

00049              {
00050     keyNull                         = 0x0000,
00051
00052     keyBackspace                    = 0x0008,
00053     keyTab                          = 0x0009,
00054     keyReturn                       = 0x000a,
00055     keyPageUp                       = 0x000b,
00056     keyPageDown                     = 0x000c,
00057     keyNumericEnter                 = 0x000d,
00058
00059     keyEscape                       = 0x001b,
00060
00061     keyLeftArrow                    = 0x001c,
00062     keyRightArrow                   = 0x001d,
00063     keyUpArrow                      = 0x001e,
00064     keyDownArrow                    = 0x001f,
00065
00066     keySpace                        = 0x0020,
00067
00068     keySingleQuote                  = 0x0027,
00069     keyComma                        = 0x002c,
00070     keyDash                         = 0x002d,
00071     keyPeriod                       = 0x002e,
00072     keySlash                        = 0x002f,
00073
00074     keyZero                         = 0x0030,
00075     keyOne                          = 0x0031,
00076     keyTwo                          = 0x0032,
00077     keyThree                        = 0x0033,
00078     keyFour                         = 0x0034,
00079     keyFive                         = 0x0035,
00080     keySix                          = 0x0036,
00081     keySeven                        = 0x0037,
00082     keyEight                        = 0x0038,
00083     keyNine                         = 0x0039,
00084
00085     keySemiColon                    = 0x003b,
00086     keyLessThan                     = 0x003c, // many European keyboards have this key (next to the left shift)
00087     keyEquals                       = 0x003d,
00088     keyAt                           = 0x0040,
00089
00090     keyOpenBracket                  = 0x005b,
00091     keyBackslash                    = 0x005c,
00092     keyCloseBracket                 = 0x005d,
00093     keyBacktick                     = 0x0060,
00094
00095     keyA                            = 0x0061,
00096     keyB                            = 0x0062,
00097     keyC                            = 0x0063,
00098     keyD                            = 0x0064,
00099     keyE                            = 0x0065,
00100     keyF                            = 0x0066,
00101     keyG                            = 0x0067,
00102     keyH                            = 0x0068,
00103     keyI                            = 0x0069,
00104     keyJ                            = 0x006a,
00105     keyK                            = 0x006b,
00106     keyL                            = 0x006c,
00107     keyM                            = 0x006d,
00108     keyN                            = 0x006e,
00109     keyO                            = 0x006f,
00110     keyP                            = 0x0070,
00111     keyQ                            = 0x0071,
00112     keyR                            = 0x0072,
00113     keyS                            = 0x0073,
00114     keyT                            = 0x0074,
00115     keyU                            = 0x0075,
00116     keyV                            = 0x0076,
00117     keyW                            = 0x0077,
00118     keyX                            = 0x0078,
00119     keyY                            = 0x0079,
00120     keyZ                            = 0x007a,
00121
00122     // Some old virtual character codes that can also serve as
00123     // physical key codes for actions.
00124     keyNextField                    = 0x0103,
00125     keyMenu                         = 0x0105,
00126     keyLaunch                       = 0x0108,   // HS
00127     keyFind                         = 0x010A,
00128     keyPrevField                    = 0x010C,
00129     keyLockDevice                   = 0x0112,
00130
00131     keyThumbWheelUp                 = 0x012E,   // (JogUp)
00132     keyThumbWheelDown               = 0x012F,   // (JogDown)
00133     keyThumbWheelPush               = 0x0130,   // (JogPress)
00134     keyThumbWheelBack               = 0x0131,   // (JogBack)
00135
00136     keyRockerUp                     = 0x0132,
00137     keyRockerDown                   = 0x0133,
00138     keyRockerLeft                   = 0x0134,
00139     keyRockerRight                  = 0x0135,
00140     keyRockerCenter                 = 0x0136,
00141
00142     keyHard1                        = 0x0204,
00143     keyHard2                        = 0x0205,
00144     keyHard3                        = 0x0206,
00145     keyHard4                        = 0x0207,
00146
00147     keyHardPower                    = 0x0208,
00148     keyHardCradle                   = 0x0209,
00149     keyHardCradle2                  = 0x020A,
00150     keyHardContrast                 = 0x020B,
00151     keyHardAntenna                  = 0x020C,
00152     keyHardBrightness               = 0x020D,
00153
00154     // keyHard 5-10 are for Licensees & Silicon Partners to use.
00155     // That means that this key code might be something totally different on
00156     // a different device.  Be warned.
00157     // (note that values in this range are necessary due to the way
00158     // TxtCharIsHardKey is defined)
00159     keyHard5                        = 0x0214,
00160     keyHard6                        = 0x0215,
00161     keyHard7                        = 0x0216,
00162     keyHard8                        = 0x0217,
00163     keyHard9                        = 0x0218,
00164     keyHard10                       = 0x0219,
00165     keyHard11                       = 0x021A,
00166     keyHard12                       = 0x021B,
00167     keyHard13                       = 0x021C,
00168     keyHard14                       = 0x021D,
00169
00170     // Handspring specific keys
00171     hsKeyMfgTest                    = 0x1600,   // HS
00172     hsKeySymbol                     = 0x1609,   // HS (Keycap says "Alt")
00173     hsKeyRadioPower                 = 0x160C,   // HS
00174
00175     // These are keys that are found on standard computer keyboards
00176     // that aren't covered above
00177
00178     keyLeftShift                    = 0xe000,   // (Handspring shift key)
00179     keyRightShift                   = 0xe001,
00180     keyLeftControl                  = 0xe002,
00181     keyRightControl                 = 0xe003,
00182     keyLeftCommand                  = 0xe004,
00183     keyRightCommand                 = 0xe005,
00184     keyLeftAlt                      = 0xe006,   // (Handspring option key)
00185     keyRightAlt                     = 0xe007,
00186
00187     keySide                         = 0xe008,   // HS (side button)
00188
00189     keyHelp                         = 0xe009,
00190
00191     keyNumLock                      = 0xe00a,
00192     keyScrollLock                   = 0xe00b,
00193     keyCapsLock                     = 0xe00c,
00194
00195     keyInsert                       = 0xe00d,
00196     keyDelete                       = 0xe00e,
00197     keyHome                         = 0xe00f,
00198     keyEnd                          = 0xe010,
00199
00200     keyPrintScreen                  = 0xe011,
00201     keyPause                        = 0xe012,
00202
00203     keyNumericPeriod                = 0xe013,
00204     keyNumericPlus                  = 0xe014,
00205     keyNumericDash                  = 0xe015,
00206     keyNumericAsterisk              = 0xe016,
00207     keyNumericSlash                 = 0xe017,
00208     keyNumericEquals                = 0xe018,
00209
00210     keyNumericZero                  = 0xe020,
00211     keyNumericOne                   = 0xe021,
00212     keyNumericTwo                   = 0xe022,
00213     keyNumericThree                 = 0xe023,
00214     keyNumericFour                  = 0xe024,
00215     keyNumericFive                  = 0xe025,
00216     keyNumericSix                   = 0xe026,
00217     keyNumericSeven                 = 0xe027,
00218     keyNumericEight                 = 0xe028,
00219     keyNumericNine                  = 0xe029,
00220
00221     keyF1                           = 0xe031,
00222     keyF2                           = 0xe032,
00223     keyF3                           = 0xe033,
00224     keyF4                           = 0xe034,
00225     keyF5                           = 0xe035,
00226     keyF6                           = 0xe036,
00227     keyF7                           = 0xe037,
00228     keyF8                           = 0xe038,
00229     keyF9                           = 0xe039,
00230     keyF10                          = 0xe03a,
00231     keyF11                          = 0xe03b,
00232     keyF12                          = 0xe03c,
00233     keyF13                          = 0xe03d,
00234     keyF14                          = 0xe03e,
00235     keyF15                          = 0xe03f,
00236
00237
00238     // These are multimedia, internet or otherwise interesting buttons
00239     // that are sometimes found on keyboards or devices.
00240
00241     keyBack                         = 0xe050,
00242     keyForward                      = 0xe051,
00243     keyStopInternet                 = 0xe052,
00244     keyRefresh                      = 0xe053,
00245     keySearch                       = 0xe054,
00246     keyFavorites                    = 0xe055,
00247     keyHomePage                     = 0xe056,
00248
00249     keyMail                         = 0xe057,
00250
00251     keyMute                         = 0xe058,
00252     keyVolumeUp                     = 0xe059,
00253     keyVolumeDown                   = 0xe05a,
00254     keyPlay                         = 0xe05b,
00255     keyPauseAudio                   = 0x305c,
00256     keyPlayPause                    = 0xe05d,
00257     keyStopAudio                    = 0xe05e,
00258     keyPrevTrack                    = 0xe05f,
00259     keyNextTrack                    = 0xe060,
00260     keyFastForward                  = 0xe061,
00261     keyRewind                       = 0xe062,
00262     keyEject                        = 0xe063,
00263
00264     keyMedia                        = 0xe064,
00265
00266     keyMyComputer                   = 0xe065,
00267     keyMyDocuments                  = 0xe066,
00268     keyMyMusic                      = 0xe067,
00269     keyMyPictures                   = 0xe068,
00270     keyCalculator                   = 0xe069,
00271
00272     keyLogOff                       = 0xe06a
00273
00274
00275 } KeyCodeType;

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:07:06 2008 for Palm API Guide


Header Files » Incs » common » system

HsKeyCommon.h File Reference

Detailed Description

Header file with additional keyboard related definitions.

Definition in file HsKeyCommon.h.

Go to the source code of this file.

Defines

  • #define vchrHardRockerCenter 0x013D
  • #define keyBitThumbWheelUp 0x00001000
  • #define keyBitThumbWheelDown 0x00002000
  • #define keyBitThumbWheelPress 0x00004000
  • #define keyBitThumbWheelBack 0x00008000
  • #define keyBitRockerUp 0x00010000
  • #define keyBitRockerDown 0x00020000
  • #define keyBitRockerLeft 0x00040000
  • #define keyBitRockerRight 0x00080000
  • #define keyBitRockerCenter 0x00100000
  • #define sysFtrNumUIHardwareFlags 27
  • #define sysFtrNumUIHardwareHas5Way 0x00000001
  • #define sysFtrNumUIHardwareHasThumbWheel 0x00000002
  • #define sysFtrNumUIHardwareHasThumbWheelBack 0x00000004
  • #define sysFtrNumUIHardwareHasKbd 0x00000008
  • #define willSendUpKeyMask 0x0800

Define Documentation

#define keyBitRockerCenter 0x00100000

Definition at line 49 of file HsKeyCommon.h.

#define keyBitRockerDown 0x00020000

Definition at line 46 of file HsKeyCommon.h.

#define keyBitRockerLeft 0x00040000

Definition at line 47 of file HsKeyCommon.h.

#define keyBitRockerRight 0x00080000

Definition at line 48 of file HsKeyCommon.h.

#define keyBitRockerUp 0x00010000

Definition at line 45 of file HsKeyCommon.h.

#define keyBitThumbWheelBack 0x00008000

Definition at line 43 of file HsKeyCommon.h.

#define keyBitThumbWheelDown 0x00002000

Definition at line 41 of file HsKeyCommon.h.

#define keyBitThumbWheelPress 0x00004000

Definition at line 42 of file HsKeyCommon.h.

#define keyBitThumbWheelUp 0x00001000

Definition at line 40 of file HsKeyCommon.h.

#define sysFtrNumUIHardwareFlags 27

Definition at line 61 of file HsKeyCommon.h.

#define sysFtrNumUIHardwareHas5Way 0x00000001

Definition at line 62 of file HsKeyCommon.h.

#define sysFtrNumUIHardwareHasKbd 0x00000008

Definition at line 65 of file HsKeyCommon.h.

#define sysFtrNumUIHardwareHasThumbWheel 0x00000002

Definition at line 63 of file HsKeyCommon.h.

#define sysFtrNumUIHardwareHasThumbWheelBack 0x00000004

Definition at line 64 of file HsKeyCommon.h.

#define vchrHardRockerCenter 0x013D

Definition at line 26 of file HsKeyCommon.h.

#define willSendUpKeyMask 0x0800

Definition at line 77 of file HsKeyCommon.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:07:06 2008 for Palm API Guide


Header Files » Incs » common » system

HsKeyTypes.h File Reference

Detailed Description

palmOne's key constant definitions shared by DAL and Palm OS (see Palm OS' CmnKeyTypes.h)

Definition in file HsKeyTypes.h.

Go to the source code of this file.

Defines

  • #define keyBitNumPower 0
  • #define keyBitNumPageUp 1
  • #define keyBitNumPageDown 2
  • #define keyBitNumHard1 3
  • #define keyBitNumHard2 4
  • #define keyBitNumHard3 5
  • #define keyBitNumHard4 6
  • #define keyBitNumCradle 7
  • #define keyBitNumAntenna 8
  • #define keyBitNumContrast 9
  • #define keyBitNumJogUp 12
  • #define keyBitNumJogDown 13
  • #define keyBitNumJogPress 14
  • #define keyBitNumJogBack 15
  • #define keyBitNumRockerUp 16
  • #define keyBitNumRockerDown 17
  • #define keyBitNumRockerLeft 18
  • #define keyBitNumRockerRight 19
  • #define keyBitNumRockerCenter 20
  • #define keyBitExt1Q 0x00000001
  • #define keyBitNumExt1Q 0
  • #define keyBitExt1W 0x00000002
  • #define keyBitNumExt1W 1
  • #define keyBitExt1E 0x00000004
  • #define keyBitNumExt1E 2
  • #define keyBitExt1R 0x00000008
  • #define keyBitNumExt1R 3
  • #define keyBitExt1T 0x00000010
  • #define keyBitNumExt1T 4
  • #define keyBitExt1Y 0x00000020
  • #define keyBitNumExt1Y 5
  • #define keyBitExt1U 0x00000040
  • #define keyBitNumExt1U 6
  • #define keyBitExt1I 0x00000080
  • #define keyBitNumExt1I 7
  • #define keyBitExt1O 0x00000100
  • #define keyBitNumExt1O 8
  • #define keyBitExt1P 0x00000200
  • #define keyBitNumExt1P 9
  • #define keyBitExt1A 0x00000400
  • #define keyBitNumExt1A 10
  • #define keyBitExt1S 0x00000800
  • #define keyBitNumExt1S 11
  • #define keyBitExt1D 0x00001000
  • #define keyBitNumExt1D 12
  • #define keyBitExt1F 0x00002000
  • #define keyBitNumExt1F 13
  • #define keyBitExt1G 0x00004000
  • #define keyBitNumExt1G 14
  • #define keyBitExt1H 0x00008000
  • #define keyBitNumExt1H 15
  • #define keyBitExt1J 0x00010000
  • #define keyBitNumExt1J 16
  • #define keyBitExt1K 0x00020000
  • #define keyBitNumExt1K 17
  • #define keyBitExt1L 0x00040000
  • #define keyBitNumExt1L 18
  • #define keyBitExt1Bksp 0x00080000
  • #define keyBitNumExt1Bksp 19
  • #define keyBitExt1Opt 0x00100000
  • #define keyBitNumExt1Opt 20
  • #define keyBitExt1Z 0x00200000
  • #define keyBitNumExt1Z 21
  • #define keyBitExt1X 0x00400000
  • #define keyBitNumExt1X 22
  • #define keyBitExt1C 0x00800000
  • #define keyBitNumExt1C 23
  • #define keyBitExt1V 0x01000000
  • #define keyBitNumExt1V 24
  • #define keyBitExt1B 0x02000000
  • #define keyBitNumExt1B 25
  • #define keyBitExt1N 0x04000000
  • #define keyBitNumExt1N 26
  • #define keyBitExt1M 0x08000000
  • #define keyBitNumExt1M 27
  • #define keyBitExt1Period 0x10000000
  • #define keyBitNumExt1Period 28
  • #define keyBitExt1Enter 0x20000000
  • #define keyBitNumExt1Enter 29
  • #define keyBitExt1Shift 0x40000000
  • #define keyBitNumExt1Shift 30
  • #define keyBitExt1Space 0x80000000
  • #define keyBitNumExt1Space 31
  • #define keyBitsAllExt1 0xFFFFFFFF
  • #define keyBitExt2Symbol 0x00000001
  • #define keyBitNumExt2Symbol 0
  • #define keyBitExt2CmdMenu 0x00000002
  • #define keyBitNumExt2CmdMenu 1
  • #define keyBitExt2Launcher 0x00000020
  • #define keyBitNumExt2Launcher 5
  • #define keyBitExt2Unused6 0x00000040
  • #define keyBitNumExt2Unused6 6
  • #define keyBitExt2MfgTest 0x00000080
  • #define keyBitNumExt2MfgTest 7
  • #define keyBitExt2VolumeUp 0x00000100
  • #define keyBitNumExt2VolumeUp 8
  • #define keyBitExt2VolumeDown 0x00000200
  • #define keyBitNumExt2VolumeDown 9
  • #define keyBitExt2Side 0x00000400
  • #define keyBitNumExt2Side 10
  • #define keyBitExt2Zero 0x00000800
  • #define keyBitNumExt2Zero 11
  • #define keyBitExt2RShift 0x00001000
  • #define keyBitNumExt2RShift 12
  • #define keyBitExt2Hard11 0x00002000
  • #define keyBitNumExt2Hard11 13
  • #define keyBitsAllExt2 0xFFFFFFFF
  • #define keyBitNumUnused 0xFFFF
  • #define specialHoldKeyMask (autoRepeatKeyMask | doubleTapKeyMask)
  • #define specialReleaseKeyMask (autoRepeatKeyMask | poweredOnKeyMask)
  • #define specialAvail3KeyMask (doubleTapKeyMask | poweredOnKeyMask)
  • #define specialAvail4KeyMask (autoRepeatKeyMask | doubleTapKeyMask | poweredOnKeyMask)
  • #define specialKeyMask (autoRepeatKeyMask | doubleTapKeyMask | poweredOnKeyMask)
  • #define hsGrfTempShiftOpt (grfTempShiftLower+1)
  • #define hsGlfOptLock (glfNumLock << 1)
  • #define hsGsiOptLock 0xFE
  • #define hsGsiShiftOpt 0xFF

Define Documentation

#define hsGlfOptLock (glfNumLock << 1)

Local names for shift lock states (see GraffitiShift.h)

Definition at line 248 of file HsKeyTypes.h.

#define hsGrfTempShiftOpt (grfTempShiftLower+1)

Temp shift states (see Graffiti.h)

Definition at line 245 of file HsKeyTypes.h.

#define hsGsiOptLock 0xFE

Internal shift states (extends GsiShiftStateTag)

Definition at line 255 of file HsKeyTypes.h.

#define hsGsiShiftOpt 0xFF

Definition at line 256 of file HsKeyTypes.h.

#define keyBitExt1A 0x00000400

A key

Definition at line 105 of file HsKeyTypes.h.

#define keyBitExt1B 0x02000000

B key

Definition at line 150 of file HsKeyTypes.h.

#define keyBitExt1Bksp 0x00080000

Backspace key

Definition at line 132 of file HsKeyTypes.h.

#define keyBitExt1C 0x00800000

C key

Definition at line 144 of file HsKeyTypes.h.

#define keyBitExt1D 0x00001000

D key

Definition at line 111 of file HsKeyTypes.h.

#define keyBitExt1E 0x00000004

E key

Definition at line 81 of file HsKeyTypes.h.

#define keyBitExt1Enter 0x20000000

Enter key

Definition at line 162 of file HsKeyTypes.h.

#define keyBitExt1F 0x00002000

F key

Definition at line 114 of file HsKeyTypes.h.

#define keyBitExt1G 0x00004000

G key

Definition at line 117 of file HsKeyTypes.h.

#define keyBitExt1H 0x00008000

H key

Definition at line 120 of file HsKeyTypes.h.

#define keyBitExt1I 0x00000080

I key

Definition at line 96 of file HsKeyTypes.h.

#define keyBitExt1J 0x00010000

J key

Definition at line 123 of file HsKeyTypes.h.

#define keyBitExt1K 0x00020000

K key

Definition at line 126 of file HsKeyTypes.h.

#define keyBitExt1L 0x00040000

L key

Definition at line 129 of file HsKeyTypes.h.

#define keyBitExt1M 0x08000000

M key

Definition at line 156 of file HsKeyTypes.h.

#define keyBitExt1N 0x04000000

N key

Definition at line 153 of file HsKeyTypes.h.

#define keyBitExt1O 0x00000100

O key

Definition at line 99 of file HsKeyTypes.h.

#define keyBitExt1Opt 0x00100000

Option key

Definition at line 135 of file HsKeyTypes.h.

#define keyBitExt1P 0x00000200

P key

Definition at line 102 of file HsKeyTypes.h.

#define keyBitExt1Period 0x10000000

Period key

Definition at line 159 of file HsKeyTypes.h.

#define keyBitExt1Q 0x00000001

Q key

Definition at line 75 of file HsKeyTypes.h.

#define keyBitExt1R 0x00000008

R key

Definition at line 84 of file HsKeyTypes.h.

#define keyBitExt1S 0x00000800

S key

Definition at line 108 of file HsKeyTypes.h.

#define keyBitExt1Shift 0x40000000

Shift key

Definition at line 165 of file HsKeyTypes.h.

#define keyBitExt1Space 0x80000000

Space key

Definition at line 168 of file HsKeyTypes.h.

#define keyBitExt1T 0x00000010

T key

Definition at line 87 of file HsKeyTypes.h.

#define keyBitExt1U 0x00000040

U key

Definition at line 93 of file HsKeyTypes.h.

#define keyBitExt1V 0x01000000

V key

Definition at line 147 of file HsKeyTypes.h.

#define keyBitExt1W 0x00000002

W key

Definition at line 78 of file HsKeyTypes.h.

#define keyBitExt1X 0x00400000

X key

Definition at line 141 of file HsKeyTypes.h.

#define keyBitExt1Y 0x00000020

Y key

Definition at line 90 of file HsKeyTypes.h.

#define keyBitExt1Z 0x00200000

Z key

Definition at line 138 of file HsKeyTypes.h.

#define keyBitExt2CmdMenu 0x00000002

Cmd/menu

Definition at line 183 of file HsKeyTypes.h.

#define keyBitExt2Hard11 0x00002000

Our Phone key

Definition at line 219 of file HsKeyTypes.h.

#define keyBitExt2Launcher 0x00000020

Launcher

Definition at line 195 of file HsKeyTypes.h.

#define keyBitExt2MfgTest 0x00000080

Manufacturing Test

Definition at line 201 of file HsKeyTypes.h.

#define keyBitExt2RShift 0x00001000

Right Shift key

Definition at line 216 of file HsKeyTypes.h.

#define keyBitExt2Side 0x00000400

Side button

Definition at line 210 of file HsKeyTypes.h.

#define keyBitExt2Symbol 0x00000001

Symbol (list type)

Definition at line 180 of file HsKeyTypes.h.

#define keyBitExt2Unused6 0x00000040

UNUSED: Available for use (was going to be RadioPower)

Definition at line 198 of file HsKeyTypes.h.

#define keyBitExt2VolumeDown 0x00000200

Volume Down

Definition at line 207 of file HsKeyTypes.h.

#define keyBitExt2VolumeUp 0x00000100

Volume Up

Definition at line 204 of file HsKeyTypes.h.

#define keyBitExt2Zero 0x00000800

Zero key

Definition at line 213 of file HsKeyTypes.h.

#define keyBitNumAntenna 8

Antenna "key" <chg 3-31-98 RM>

Definition at line 44 of file HsKeyTypes.h.

#define keyBitNumContrast 9

Contrast key

Definition at line 46 of file HsKeyTypes.h.

#define keyBitNumCradle 7

Button on cradle

Definition at line 42 of file HsKeyTypes.h.

#define keyBitNumExt1A 10

Definition at line 106 of file HsKeyTypes.h.

#define keyBitNumExt1B 25

Definition at line 151 of file HsKeyTypes.h.

#define keyBitNumExt1Bksp 19

Definition at line 133 of file HsKeyTypes.h.

#define keyBitNumExt1C 23

Definition at line 145 of file HsKeyTypes.h.

#define keyBitNumExt1D 12

Definition at line 112 of file HsKeyTypes.h.

#define keyBitNumExt1E 2

Definition at line 82 of file HsKeyTypes.h.

#define keyBitNumExt1Enter 29

Definition at line 163 of file HsKeyTypes.h.

#define keyBitNumExt1F 13

Definition at line 115 of file HsKeyTypes.h.

#define keyBitNumExt1G 14

Definition at line 118 of file HsKeyTypes.h.

#define keyBitNumExt1H 15

Definition at line 121 of file HsKeyTypes.h.

#define keyBitNumExt1I 7

Definition at line 97 of file HsKeyTypes.h.

#define keyBitNumExt1J 16

Definition at line 124 of file HsKeyTypes.h.

#define keyBitNumExt1K 17

Definition at line 127 of file HsKeyTypes.h.

#define keyBitNumExt1L 18

Definition at line 130 of file HsKeyTypes.h.

#define keyBitNumExt1M 27

Definition at line 157 of file HsKeyTypes.h.

#define keyBitNumExt1N 26

Definition at line 154 of file HsKeyTypes.h.

#define keyBitNumExt1O 8

Definition at line 100 of file HsKeyTypes.h.

#define keyBitNumExt1Opt 20

Definition at line 136 of file HsKeyTypes.h.

#define keyBitNumExt1P 9

Definition at line 103 of file HsKeyTypes.h.

#define keyBitNumExt1Period 28

Definition at line 160 of file HsKeyTypes.h.

#define keyBitNumExt1Q 0

Definition at line 76 of file HsKeyTypes.h.

#define keyBitNumExt1R 3

Definition at line 85 of file HsKeyTypes.h.

#define keyBitNumExt1S 11

Definition at line 109 of file HsKeyTypes.h.

#define keyBitNumExt1Shift 30

Definition at line 166 of file HsKeyTypes.h.

#define keyBitNumExt1Space 31

Definition at line 169 of file HsKeyTypes.h.

#define keyBitNumExt1T 4

Definition at line 88 of file HsKeyTypes.h.

#define keyBitNumExt1U 6

Definition at line 94 of file HsKeyTypes.h.

#define keyBitNumExt1V 24

Definition at line 148 of file HsKeyTypes.h.

#define keyBitNumExt1W 1

Definition at line 79 of file HsKeyTypes.h.

#define keyBitNumExt1X 22

Definition at line 142 of file HsKeyTypes.h.

#define keyBitNumExt1Y 5

Definition at line 91 of file HsKeyTypes.h.

#define keyBitNumExt1Z 21

Definition at line 139 of file HsKeyTypes.h.

#define keyBitNumExt2CmdMenu 1

Definition at line 184 of file HsKeyTypes.h.

#define keyBitNumExt2Hard11 13

Definition at line 220 of file HsKeyTypes.h.

#define keyBitNumExt2Launcher 5

Definition at line 196 of file HsKeyTypes.h.

#define keyBitNumExt2MfgTest 7

Definition at line 202 of file HsKeyTypes.h.

#define keyBitNumExt2RShift 12

Definition at line 217 of file HsKeyTypes.h.

#define keyBitNumExt2Side 10

Definition at line 211 of file HsKeyTypes.h.

#define keyBitNumExt2Symbol 0

Definition at line 181 of file HsKeyTypes.h.

#define keyBitNumExt2Unused6 6

Definition at line 199 of file HsKeyTypes.h.

#define keyBitNumExt2VolumeDown 9

Definition at line 208 of file HsKeyTypes.h.

#define keyBitNumExt2VolumeUp 8

Definition at line 205 of file HsKeyTypes.h.

#define keyBitNumExt2Zero 11

Definition at line 214 of file HsKeyTypes.h.

#define keyBitNumHard1 3

App #1

Definition at line 34 of file HsKeyTypes.h.

#define keyBitNumHard2 4

App #2

Definition at line 36 of file HsKeyTypes.h.

#define keyBitNumHard3 5

App #3

Definition at line 38 of file HsKeyTypes.h.

#define keyBitNumHard4 6

App #4

Definition at line 40 of file HsKeyTypes.h.

#define keyBitNumJogBack 15

jog wheel back button

Definition at line 56 of file HsKeyTypes.h.

#define keyBitNumJogDown 13

jog wheel down

Definition at line 52 of file HsKeyTypes.h.

#define keyBitNumJogPress 14

press/center on jog wheel

Definition at line 54 of file HsKeyTypes.h.

#define keyBitNumJogUp 12

jog wheel up

Definition at line 50 of file HsKeyTypes.h.

#define keyBitNumPageDown 2

Page-down

Definition at line 32 of file HsKeyTypes.h.

#define keyBitNumPageUp 1

Page-up

Definition at line 30 of file HsKeyTypes.h.

#define keyBitNumPower 0

Power key

Definition at line 28 of file HsKeyTypes.h.

#define keyBitNumRockerCenter 20

5-way rocker center/press

Definition at line 66 of file HsKeyTypes.h.

#define keyBitNumRockerDown 17

5-way rocker down

Definition at line 60 of file HsKeyTypes.h.

#define keyBitNumRockerLeft 18

5-way rocker left

Definition at line 62 of file HsKeyTypes.h.

#define keyBitNumRockerRight 19

5-way rocker right

Definition at line 64 of file HsKeyTypes.h.

#define keyBitNumRockerUp 16

5-way rocker up

Definition at line 58 of file HsKeyTypes.h.

#define keyBitNumUnused 0xFFFF

This keyBit is guaranteed not to map to any character

Definition at line 226 of file HsKeyTypes.h.

#define keyBitsAllExt1 0xFFFFFFFF

All keys

Definition at line 171 of file HsKeyTypes.h.

#define keyBitsAllExt2 0xFFFFFFFF

All keys

Definition at line 222 of file HsKeyTypes.h.

#define specialAvail3KeyMask (doubleTapKeyMask | poweredOnKeyMask)

Definition at line 235 of file HsKeyTypes.h.

#define specialAvail4KeyMask (autoRepeatKeyMask | doubleTapKeyMask | poweredOnKeyMask)

Definition at line 236 of file HsKeyTypes.h.

#define specialHoldKeyMask (autoRepeatKeyMask | doubleTapKeyMask)

Definition at line 233 of file HsKeyTypes.h.

#define specialKeyMask (autoRepeatKeyMask | doubleTapKeyMask | poweredOnKeyMask)

Definition at line 238 of file HsKeyTypes.h.

#define specialReleaseKeyMask (autoRepeatKeyMask | poweredOnKeyMask)

Definition at line 234 of file HsKeyTypes.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:07:06 2008 for Palm API Guide


Header Files » Incs » 68k » system

HsNav.h File Reference

Detailed Description

Header file that 68K programs include to access HsNav functionality.

Version:
Date:

Definition in file HsNav.h.

Include dependency graph for HsNav.h:

Go to the source code of this file.

Functions

  • UInt16 FrmCountObjectsInNavOrder (const FormType *formP)
    Obtains the number of objects in a form’s navigation tab order.
  • Err FrmGetNavOrder (const FormType *formP, FrmNavHeaderType *navHeaderP, FrmNavOrderEntryType *navOrderP, UInt16 *numObjectsP)
    Obtains information about the navigation order of a form.
  • Err FrmSetNavOrder (FormType *formP, FrmNavHeaderType *navHeaderP, FrmNavOrderEntryType *navOrderP)
    Sets the navigation order of a form. If the object with the current focus is removed from the order, the object will be redrawn in its non-focused state and the form will have no current focus. Makes a COPY of all information passed-in.
  • Err FrmGetNavEntry (const FormType *formP, UInt16 targetObjectID, UInt16 *afterObjectIDP, UInt16 *aboveObjectIDP, UInt16 *belowObjectIDP, FrmNavObjectFlagsType *objectFlagsP)
    Gets the navigation information for a single object in the form.
  • Err FrmSetNavEntry (FormType *formP, UInt16 targetObjectID, UInt16 afterObjectID, UInt16 aboveObjectID, UInt16 belowObjectID, FrmNavObjectFlagsType objectFlags)
    Edits the navigation information for a single object in the form.
  • Err FrmGetNavState (const FormType *formP, FrmNavStateFlagsType *stateFlagsP)
    Gets the current navigation state of a form.
  • Err FrmSetNavState (FormType *formP, FrmNavStateFlagsType stateFlags)
    Sets the navigation state of a form.
  • Err FrmNavDrawFocusRing (FormType *formP, UInt16 objectID, Int16 extraInfo, RectangleType *boundsInsideRingP, FrmNavFocusRingStyleEnum ringStyle, Boolean forceRestore)
    Parameters:
    formP,: IN:

  • Err FrmNavRemoveFocusRing (FormType *formP)
    Parameters:
    formP,: IN:

  • Err FrmNavGetFocusRingInfo (const FormType *formP, UInt16 *objectIDP, Int16 *extraInfoP, RectangleType *boundsInsideRingP, FrmNavFocusRingStyleEnum *ringStyleP)
    Parameters:
    formP,: IN:

  • void FrmNavObjectTakeFocus (const FormType *formP, UInt16 objID)
    Parameters:
    formP,: IN:

Function Documentation

UInt16 FrmCountObjectsInNavOrder ( const FormType * formP )

Obtains the number of objects in a form’s navigation tab order.

Parameters:
formP,: IN: Pointer to the form whose navigation information is to be obtained.
Return values:
UInt16 Returns the number of objects in the navigation tab order.

Err FrmGetNavEntry | ( | const FormType * | formP,
 |  | UInt16 | targetObjectID,
 |  | UInt16 * | afterObjectIDP,
 |  | UInt16 * | aboveObjectIDP,
 |  | UInt16 * | belowObjectIDP,
 |  | FrmNavObjectFlagsType * | objectFlagsP
 | ) |  |

Gets the navigation information for a single object in the form.

Parameters:
formP,: IN: Pointer to the form whose navigation order is being obtained
targetObjectID,: IN: The ID of the object whose navigation information is being obtained
afterObjectIDP,: IN: On exit, will point to the ID of the object which is to the left of the target object. If the target object is the first one in the tab order, will point to an ID of 0. Caller can pass NULL if they do not need this information.
aboveObjectIDP,: IN: On exit, will point to the ID of the object that is above the target object. An ID of 0 means the target object is in the top row of the form. Caller can pass NULL if they do not need this information.
belowObjectIDP,: IN: On exit, will point to the ID of the object that is below the target object. An ID of 0 means the target object is in the bottom row of the form. Caller can pass NULL if they do not need this information.
objectFlagsP,: IN: On exit, will point to the object flags for the target object. Caller can pass NULL if they do not need this information.
Return values:
Err Returns 0 if no error, error code otherwise.

Err FrmGetNavOrder | ( | const FormType * | formP,
 |  | FrmNavHeaderType * | navHeaderP,
 |  | FrmNavOrderEntryType * | navOrderP,
 |  | UInt16 * | numObjectsP
 | ) |  |

Obtains information about the navigation order of a form.

Parameters:
formP,: IN: Pointer to the form whose focus order is to be obtained
navHeaderP,: IN: If not NULL, filled with the header information for the form’s navigation order
navOrderP,: IN: If not NULL, will point to an array with info for each object in the navigation order
numObjectsP,: IN: On entry, the number of entries allocated in the navigation order array. On exit, the number of entries filled in the navigation order array.
Return values:
Err Returns 0 if no error, error code otherwise.

Err FrmGetNavState | ( | const FormType * | formP,
 |  | FrmNavStateFlagsType * | stateFlagsP
 | ) |  |

Gets the current navigation state of a form.

Parameters:
formP,: IN: Pointer to the form whose navigation state is to be obtained.
stateFlagsP,: IN: On exit, points to a state flags field that describes the current navigation state
Return values:
Err Returns 0 if no error, error code otherwise

Err FrmNavDrawFocusRing | ( | FormType * | formP,
 |  | UInt16 | objectID,
 |  | Int16 | extraInfo,
 |  | RectangleType * | boundsInsideRingP,
 |  | FrmNavFocusRingStyleEnum | ringStyle,
 |  | Boolean | forceRestore
 | ) |  |

Parameters:
formP,: IN:

Parameters:
objectID,: IN:
extraInfo,: IN:
boundsInsideRingP,: IN:
ringStyle,: IN:
forceRestore,: IN:
Return values:
Err Error code.

Err FrmNavGetFocusRingInfo | ( | const FormType * | formP,
 |  | UInt16 * | objectIDP,
 |  | Int16 * | extraInfoP,
 |  | RectangleType * | boundsInsideRingP,
 |  | FrmNavFocusRingStyleEnum * | ringStyleP
 | ) |  |

Parameters:
formP,: IN:

Parameters:
objectIDP,: IN:
extraInfoP,: IN:
boundsInsideRingP,: IN:
ringStyleP,: IN:
Return values:
Err Error code.

void FrmNavObjectTakeFocus | ( | const FormType * | formP,
 |  | UInt16 | objID
 | ) |  |

Parameters:
formP,: IN:

Parameters:
objID,: IN:

Err FrmNavRemoveFocusRing ( FormType * formP )

Parameters:
formP,: IN:

Return values:
Err Error code.

Err FrmSetNavEntry | ( | FormType * | formP,
 |  | UInt16 | targetObjectID,
 |  | UInt16 | afterObjectID,
 |  | UInt16 | aboveObjectID,
 |  | UInt16 | belowObjectID,
 |  | FrmNavObjectFlagsType | objectFlags
 | ) |  |

Edits the navigation information for a single object in the form.

Parameters:
formP,: IN: Pointer to the form whose navigation order is being changed
targetObjectID,: IN: The ID of the object which is being edited, added, or removed.
afterObjectID,: IN: The ID of the object which will be to the left of the target object. The object that is currently to the right of the after object will then be to the right of the target object. An ID of 0 means the target object should be placed at the beginning of the order. An ID of 0xFFFF (frmInvalidObjectId) means that the target object should be completely removed from the navigation order.
aboveObjectID,: IN: The ID of the object that will be above the target object. An ID of 0 means the target object is in the top row of the form.
belowObjectID,: IN: The ID of the object that will be below the target object. An ID of 0 means the target object is in the bottom row of the form.
objectFlags,: IN: The new object flags for the target object.
Return values:
Err Returns 0 if no error, error code otherwise.

Err FrmSetNavOrder | ( | FormType * | formP,
 |  | FrmNavHeaderType * | navHeaderP,
 |  | FrmNavOrderEntryType * | navOrderP
 | ) |  |

Sets the navigation order of a form. If the object with the current focus is removed from the order, the object will be redrawn in its non-focused state and the form will have no current focus. Makes a COPY of all information passed-in.

Parameters:
formP,: IN: Pointer to the form whose focus order is to being set
navHeaderP,: IN: Sets the header information for the form’s navigation order. This parameter cannot be NULL.
navOrderP,: IN: Specifies the new navigation order for the form. The number of entries in the array must be equal to the header parameter’s numberOfObjects field. Caller can pass NULL if they do not want to change the form’s navigation order (they just want to change the header information).
Return values:
Err Returns 0 if no error, error code otherwise

Err FrmSetNavState | ( | FormType * | formP,
 |  | FrmNavStateFlagsType | stateFlags
 | ) |  |

Sets the navigation state of a form.

Parameters:
formP,: IN: Pointer to the form whose navigation state is being set
stateFlags,: IN: State flags that describe the new navigation state
Return values:
Err Returns 0 if no error, error code otherwise

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:07:07 2008 for Palm API Guide


Header Files » Incs » common » system

HsNavCommon.h File Reference

Detailed Description

Public common header file for 5-way navigation support on Treo 600.

This file contains the common constant and structures used to support 5-way navigation in an application.

Definition in file HsNavCommon.h.

Include dependency graph for HsNavCommon.h:

Go to the source code of this file.

Data Structures

  • struct FrmNavOrderEntryTag
  • struct FrmNavHeaderTag

Defines

  • #define hsNavAPIVersion 2
  • #define hsNavFocusRingWidth 6
  • #define hsNavFocusRingWidthSingleDensity 3
  • #define hsNavFocusRingNoExtraInfo ((Int16)0xFFFF)
  • #define frmNavFocusRingNoExtraInfo ((Int16)0xFFFF)
  • #define formNavRscType 'fnav'
  • #define TxtCharIsRockerKey(m, c)
  • #define sysTrapNavSelector 0xA46F
  • #define NavSelectorFrmCountObjectsInNavOrder 0x0
  • #define NavSelectorFrmGetNavOrder 0x1
  • #define NavSelectorFrmSetNavOrder 0x2
  • #define NavSelectorFrmGetNavEntry 0x3
  • #define NavSelectorFrmSetNavEntry 0x4
  • #define NavSelectorFrmGetNavState 0x5
  • #define NavSelectorFrmSetNavState 0x6
  • #define NavSelectorFrmNavDrawFocusRing 0x7
  • #define NavSelectorFrmNavRemoveFocusRing 0x8
  • #define NavSelectorFrmNavGetFocusRingInfo 0x9
  • #define NavSelectorFrmNavObjectTakeFocus 0xA
  • #define uilibErrorClass 0x3A00
  • #define uilibErrInvalidParam (uilibErrorClass | 1)
  • #define uilibErrCurrentFocusInvalid (uilibErrorClass | 2)
  • #define uilibErrObjectFocusModeOff (uilibErrorClass | 3)
  • #define uilibErrObjectNotFound (uilibErrorClass | 4)
  • #define uilibErrNoNavInfoForForm (uilibErrorClass | 5)
  • #define uilibErrInvalidFocusObject (uilibErrorClass | 6)
  • #define uilibErrFormDoesNotHaveFocus (uilibErrorClass | 7)
  • #define kFrmNavHeaderFlagsObjectFocusStartState 0x00000001
  • #define kFrmNavHeaderFlagsAppFocusStartState 0x00000002
  • #define kFrmNavHeaderFlagsAutoGenerated 0x80000000
  • #define kFrmNavHeaderFlagsStartStateMask 0x00000003
  • #define kFrmNavHeaderFlagsDefaultStartStateValue 0x00000000
  • #define kFrmNavHeaderFlagsObjectFocusStartStateValue 0x00000001
  • #define kFrmNavHeaderFlagsAppFocusStartStateValue 0x00000002
  • #define kFrmNavHeaderFlagsInvalidStartStateValue 0x00000003
  • #define kFrmNavObjectFlagsSkip 0x0001
  • #define kFrmNavObjectFlagsForceInteractionMode 0x0002
  • #define kFrmNavObjectFlagsIsBigButton 0x8000
  • #define kFrmNavStateFlagsInteractionMode 0x00000001
  • #define kFrmNavStateFlagsObjectFocusMode 0x00000002
  • #define kFrmNavInfoVersion 1
  • #define sysFtrNumFiveWayNavVersion 32

Typedefs

  • typedef UInt16 HsNavFocusColorEnum
  • typedef UInt16 HsNavFocusRingStyleEnum
  • typedef UInt16 FrmNavFocusRingStyleEnum
  • typedef UInt32 FrmNavHeaderFlagsType
  • typedef UInt16 FrmNavObjectFlagsType
  • typedef UInt32 FrmNavStateFlagsType
  • typedef FrmNavOrderEntryTag FrmNavOrderEntryType
  • typedef FrmNavHeaderTag FrmNavHeaderType

Enumerations

  • enum HsNavFocusColorEnumTag {
    hsNavFocusColorInsideBottomRightRing = 0,
    hsNavFocusColorInsideTopLeftRing = 1,
    hsNavFocusColorMiddleRing = 2,
    hsNavFocusColorOutsideRing = 3,
    hsNavFocusColorSecondaryHighlight = 4,
    hsNavFocusColorRing1 = 5,
    hsNavFocusColorRing2 = 6,
    hsNavFocusColorRing3 = 7,
    hsNavFocusColorRing4 = 8,
    hsNavFocusColorRing5 = 9,
    hsNavFocusColorRing6 = 10
    }
  • enum HsNavFocusRingStyleEnumTag {
    hsNavFocusRingStyleObjectTypeDefault = 0,
    hsNavFocusRingStyleSquare = 1,
    hsNavFocusRingStyleRound = 2,
    hsNavFocusRingStyleHorizontalBars = 3,
    hsNavFocusRingStyleInvalid = 0xFFFF
    }
  • enum FrmNavFocusRingStyleEnumTag {
    frmNavFocusRingStyleObjectTypeDefault = 0,
    frmNavFocusRingStyleSquare = 1,
    frmNavFocusRingStyleRound = 2,
    frmNavFocusRingStyleHorizontalBars = 3,
    frmNavFocusRingStyleInvalid = 0xFFFF
    }

Define Documentation

#define formNavRscType 'fnav'

Definition at line 112 of file HsNavCommon.h.

#define frmNavFocusRingNoExtraInfo ((Int16)0xFFFF)

Definition at line 104 of file HsNavCommon.h.

#define hsNavAPIVersion 2

Definition at line 49 of file HsNavCommon.h.

#define hsNavFocusRingNoExtraInfo ((Int16)0xFFFF)

Definition at line 57 of file HsNavCommon.h.

#define hsNavFocusRingWidth 6

Definition at line 55 of file HsNavCommon.h.

#define hsNavFocusRingWidthSingleDensity 3

Definition at line 56 of file HsNavCommon.h.

#define kFrmNavHeaderFlagsAppFocusStartState 0x00000002

Definition at line 190 of file HsNavCommon.h.

#define kFrmNavHeaderFlagsAppFocusStartStateValue 0x00000002

Definition at line 196 of file HsNavCommon.h.

#define kFrmNavHeaderFlagsAutoGenerated 0x80000000

Definition at line 191 of file HsNavCommon.h.

#define kFrmNavHeaderFlagsDefaultStartStateValue 0x00000000

Definition at line 194 of file HsNavCommon.h.

#define kFrmNavHeaderFlagsInvalidStartStateValue 0x00000003

Definition at line 197 of file HsNavCommon.h.

#define kFrmNavHeaderFlagsObjectFocusStartState 0x00000001

Definition at line 189 of file HsNavCommon.h.

#define kFrmNavHeaderFlagsObjectFocusStartStateValue 0x00000001

Definition at line 195 of file HsNavCommon.h.

#define kFrmNavHeaderFlagsStartStateMask 0x00000003

Definition at line 193 of file HsNavCommon.h.

#define kFrmNavInfoVersion 1

Definition at line 225 of file HsNavCommon.h.

#define kFrmNavObjectFlagsForceInteractionMode 0x0002

Definition at line 207 of file HsNavCommon.h.

#define kFrmNavObjectFlagsIsBigButton 0x8000

Definition at line 208 of file HsNavCommon.h.

#define kFrmNavObjectFlagsSkip 0x0001

Definition at line 206 of file HsNavCommon.h.

#define kFrmNavStateFlagsInteractionMode 0x00000001

Definition at line 217 of file HsNavCommon.h.

#define kFrmNavStateFlagsObjectFocusMode 0x00000002

Definition at line 218 of file HsNavCommon.h.

#define NavSelectorFrmCountObjectsInNavOrder 0x0

Definition at line 140 of file HsNavCommon.h.

#define NavSelectorFrmGetNavEntry 0x3

Definition at line 143 of file HsNavCommon.h.

#define NavSelectorFrmGetNavOrder 0x1

Definition at line 141 of file HsNavCommon.h.

#define NavSelectorFrmGetNavState 0x5

Definition at line 145 of file HsNavCommon.h.

#define NavSelectorFrmNavDrawFocusRing 0x7

Definition at line 147 of file HsNavCommon.h.

#define NavSelectorFrmNavGetFocusRingInfo 0x9

Definition at line 149 of file HsNavCommon.h.

#define NavSelectorFrmNavObjectTakeFocus 0xA

Definition at line 153 of file HsNavCommon.h.

#define NavSelectorFrmNavRemoveFocusRing 0x8

Definition at line 148 of file HsNavCommon.h.

#define NavSelectorFrmSetNavEntry 0x4

Definition at line 144 of file HsNavCommon.h.

#define NavSelectorFrmSetNavOrder 0x2

Definition at line 142 of file HsNavCommon.h.

#define NavSelectorFrmSetNavState 0x6

Definition at line 146 of file HsNavCommon.h.

#define sysFtrNumFiveWayNavVersion 32

Definition at line 236 of file HsNavCommon.h.

#define sysTrapNavSelector 0xA46F

Definition at line 138 of file HsNavCommon.h.

#define TxtCharIsRockerKey | ( | m,
 |  | c | )

Value:

((((m) & commandKeyMask) != 0) && \
                                    ((((c) >= vchrRockerUp) && ((c) <= vchrRockerCenter))))

Definition at line 125 of file HsNavCommon.h.

#define uilibErrCurrentFocusInvalid (uilibErrorClass | 2)

Definition at line 168 of file HsNavCommon.h.

#define uilibErrFormDoesNotHaveFocus (uilibErrorClass | 7)

Definition at line 173 of file HsNavCommon.h.

#define uilibErrInvalidFocusObject (uilibErrorClass | 6)

Definition at line 172 of file HsNavCommon.h.

#define uilibErrInvalidParam (uilibErrorClass | 1)

Definition at line 167 of file HsNavCommon.h.

#define uilibErrNoNavInfoForForm (uilibErrorClass | 5)

Definition at line 171 of file HsNavCommon.h.

#define uilibErrObjectFocusModeOff (uilibErrorClass | 3)

Definition at line 169 of file HsNavCommon.h.

#define uilibErrObjectNotFound (uilibErrorClass | 4)

Definition at line 170 of file HsNavCommon.h.

#define uilibErrorClass 0x3A00

Definition at line 165 of file HsNavCommon.h.

Typedef Documentation

typedef UInt16 FrmNavFocusRingStyleEnum

Definition at line 103 of file HsNavCommon.h.

typedef UInt32 FrmNavHeaderFlagsType

Definition at line 187 of file HsNavCommon.h.

typedef struct FrmNavHeaderTag FrmNavHeaderType

typedef UInt16 FrmNavObjectFlagsType

Definition at line 204 of file HsNavCommon.h.

typedef struct FrmNavOrderEntryTag FrmNavOrderEntryType

typedef UInt32 FrmNavStateFlagsType

Definition at line 215 of file HsNavCommon.h.

typedef UInt16 HsNavFocusColorEnum

Definition at line 74 of file HsNavCommon.h.

typedef UInt16 HsNavFocusRingStyleEnum

Definition at line 85 of file HsNavCommon.h.

Enumeration Type Documentation

enum FrmNavFocusRingStyleEnumTag

Enumerator:
frmNavFocusRingStyleObjectTypeDefault
frmNavFocusRingStyleSquare
frmNavFocusRingStyleRound
frmNavFocusRingStyleHorizontalBars
frmNavFocusRingStyleInvalid

Definition at line 95 of file HsNavCommon.h.

00096 {
00097   frmNavFocusRingStyleObjectTypeDefault = 0,
00098   frmNavFocusRingStyleSquare = 1,
00099   frmNavFocusRingStyleRound = 2,
00100   frmNavFocusRingStyleHorizontalBars = 3,
00101   frmNavFocusRingStyleInvalid = 0xFFFF
00102 };

enum HsNavFocusColorEnumTag

Enumerator:
hsNavFocusColorInsideBottomRightRing
hsNavFocusColorInsideTopLeftRing
hsNavFocusColorMiddleRing
hsNavFocusColorOutsideRing
hsNavFocusColorSecondaryHighlight
hsNavFocusColorRing1
hsNavFocusColorRing2
hsNavFocusColorRing3
hsNavFocusColorRing4
hsNavFocusColorRing5
hsNavFocusColorRing6

Definition at line 60 of file HsNavCommon.h.

00061 {
00062   hsNavFocusColorInsideBottomRightRing  = 0,  // Deprecated (HsNav version 1 focus treatment)
00063   hsNavFocusColorInsideTopLeftRing = 1,       // Deprecated (HsNav version 1 focus treatment)
00064   hsNavFocusColorMiddleRing = 2,              // Deprecated (HsNav version 1 focus treatment)
00065   hsNavFocusColorOutsideRing = 3,             // Deprecated (HsNav version 1 focus treatment)
00066   hsNavFocusColorSecondaryHighlight = 4,
00067   hsNavFocusColorRing1 = 5,                   // HsNav version 2 focus treatment.  Innermost ring.
00068   hsNavFocusColorRing2 = 6,                   // HsNav version 2 focus treatment.
00069   hsNavFocusColorRing3 = 7,                   // HsNav version 2 focus treatment.
00070   hsNavFocusColorRing4 = 8,                   // HsNav version 2 focus treatment.
00071   hsNavFocusColorRing5 = 9,                   // HsNav version 2 focus treatment.
00072   hsNavFocusColorRing6 = 10                   // HsNav version 2 focus treatment.  Outermost ring.
00073 };

enum HsNavFocusRingStyleEnumTag

Enumerator:
hsNavFocusRingStyleObjectTypeDefault
hsNavFocusRingStyleSquare
hsNavFocusRingStyleRound
hsNavFocusRingStyleHorizontalBars
hsNavFocusRingStyleInvalid

Definition at line 77 of file HsNavCommon.h.

00078 {
00079   hsNavFocusRingStyleObjectTypeDefault = 0,
00080   hsNavFocusRingStyleSquare = 1,
00081   hsNavFocusRingStyleRound = 2,
00082   hsNavFocusRingStyleHorizontalBars = 3,
00083   hsNavFocusRingStyleInvalid = 0xFFFF
00084 };

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:07:07 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » telephony

HsPhone.h File Reference

Detailed Description

Header file for the phone library (CDMA or GSM).

Notes: This is the generic header file that should be used by any code that uses the CDMA or GSM phone libraries. If you add a function to this file please makes sure you update both the CDMA and GSM libraries with this function and update the ARM wrapper library if appropriate.

Definition in file HsPhone.h.

Include dependency graph for HsPhone.h:

Go to the source code of this file.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:07:11 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » telephony

HsPhoneAudio.h File Reference

Detailed Description

Header File for Phone Library API ---- AUDIO CATEGORY.

Notes: All implementations of the Handspring Phone Library support a common API. This API is broken up into various categories for easier management. This file defines the Audio category. These API calls are used to play tones and other audio on an active phone connection.

Definition in file HsPhoneAudio.h.

Go to the source code of this file.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:07:11 2008 for Palm API Guide


Header Files » Incs » common » libraries » telephony

HsPhoneAudioTypes.h File Reference

Detailed Description

File contains Phone Audio data types.

Definition in file HsPhoneAudioTypes.h.

Include dependency graph for HsPhoneAudioTypes.h:

Go to the source code of this file.

Data Structures

  • struct PhnRingingProfileType
  • struct PhnRingingInfoType

Defines

Phone slider switch
  • #define kSliderLow 0
  • #define kSliderHigh 1
  • #define kSliderPositions 2

Typedefs

  • typedef UInt8 PhnTTYSetting
  • typedef Boolean PhnHACSetting
  • typedef struct PhnRingingInfoType * PhnRingingInfoPtr
  • typedef UInt8 PhnAudioSendMode

Enumerations

  • enum _PhnTTYSetting {
    phnTTYSettingAll,
    phnTTYSettingVoiceCarryOver,
    phnTTYSettingHearCarryOver,
    phnTTYSettingOff
    }
  • enum _PhnAudioSendMode {
    phnAudioLocalMode,
    phnAudioSilentMode,
    phnAudioNetworkMode
    }

Define Documentation

#define kSliderHigh 1

Definition at line 45 of file HsPhoneAudioTypes.h.

#define kSliderLow 0

Definition at line 44 of file HsPhoneAudioTypes.h.

#define kSliderPositions 2

Definition at line 46 of file HsPhoneAudioTypes.h.

Typedef Documentation

typedef UInt8 PhnAudioSendMode

Definition at line 97 of file HsPhoneAudioTypes.h.

typedef Boolean PhnHACSetting

Definition at line 77 of file HsPhoneAudioTypes.h.

typedef struct PhnRingingInfoType * PhnRingingInfoPtr

typedef UInt8 PhnTTYSetting

Definition at line 75 of file HsPhoneAudioTypes.h.

Enumeration Type Documentation

enum _PhnAudioSendMode

Enumerator:
phnAudioLocalMode
phnAudioSilentMode
phnAudioNetworkMode

Definition at line 89 of file HsPhoneAudioTypes.h.

00090 {
00091   phnAudioLocalMode,        /**<        */
00092   phnAudioSilentMode,       /**<        */
00093   phnAudioNetworkMode       /**<        */
00094 }_PhnAudioSendMode;

enum _PhnTTYSetting

Enumerator:
phnTTYSettingAll | Send/Receive Text
phnTTYSettingVoiceCarryOver | Send Voice/ Receive Text
phnTTYSettingHearCarryOver | Send Text / Receive Voice
phnTTYSettingOff | Send/Receive Voice -- NORMAL mode

Definition at line 65 of file HsPhoneAudioTypes.h.

00066   {
00067     phnTTYSettingAll,                /**< Send/Receive Text  */
00068     phnTTYSettingVoiceCarryOver,     /**< Send Voice/ Receive Text  */
00069     phnTTYSettingHearCarryOver,      /**< Send Text / Receive Voice  */
00070     phnTTYSettingOff            /**< Send/Receive Voice -- NORMAL mode  */
00071   }

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:07:12 2008 for Palm API Guide


Header Files » Incs » common » libraries » telephony

HsPhoneCallControlTypes.h File Reference

Detailed Description

Types for Phone Library call control functionality.

Definition in file HsPhoneCallControlTypes.h.

Go to the source code of this file.

Data Structures

  • struct PhnConnectionType

Defines

  • #define isValidPhnConnectStateType(c) ((c >= phnConnectionActive) && (c <= phnConnectionDormant))

Typedefs

  • typedef UInt8 PhnConnectStateType
  • typedef struct PhnConnectionType * PhnConnectionPtr

Enumerations

  • enum _PhnConnectStateType {
    phnConnectionActive,
    phnConnectionHeld,
    phnConnectionDialing,
    phnConnectionAlerting,
    phnConnectionIncoming,
    phnConnectionWaiting,
    phnConnectionUnknown,
    phnConnectionDormant
    }

Define Documentation

#define isValidPhnConnectStateType ( c ) ((c >= phnConnectionActive) && (c <= phnConnectionDormant))

meaning of feature bits in a GSMSATEventMenuRec

Definition at line 38 of file HsPhoneCallControlTypes.h.

Typedef Documentation

typedef struct PhnConnectionType* PhnConnectionPtr

typedef UInt8 PhnConnectStateType

Definition at line 37 of file HsPhoneCallControlTypes.h.

Enumeration Type Documentation

enum _PhnConnectStateType

Phone connection state

Enumerator:
phnConnectionActive
phnConnectionHeld
phnConnectionDialing
phnConnectionAlerting
phnConnectionIncoming
phnConnectionWaiting
phnConnectionUnknown
phnConnectionDormant

Definition at line 25 of file HsPhoneCallControlTypes.h.

00026   {
00027     phnConnectionActive,        /**<        */
00028     phnConnectionHeld,          /**<        */
00029     phnConnectionDialing,       /**<        */
00030     phnConnectionAlerting,      /**<        */
00031     phnConnectionIncoming,      /**<        */
00032     phnConnectionWaiting,       /**<        */
00033     phnConnectionUnknown,       /**<        */
00034     phnConnectionDormant
00035   } _PhnConnectStateType;

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:07:12 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » telephony

HsPhoneCDMA.h File Reference

Detailed Description

Header File for Phone Library API ---- CDMA CATEGORY.

Notes: All implementations of the Handspring Phone Library support a common API. This API is broken up into various categories for easier management. This file defines the public portion of the CDMA category. These API calls are used for features specific to CDMA networks.

Definition in file HsPhoneCDMA.h.

Include dependency graph for HsPhoneCDMA.h:

Go to the source code of this file.

Functions

  • CharPtr PhnLibAPGetField (UInt16 refNum, PhnAddressHandle address, PhnAddressField field)
    This function returns the field’s value for a given address in a newly allocated block. This function returns 0 if there was an error while retrieving the data.

Function Documentation

CharPtr PhnLibAPGetField | ( | UInt16 | refNum,
 |  | PhnAddressHandle | address,
 |  | PhnAddressField | field
 | ) |  |

This function returns the field’s value for a given address in a newly allocated block. This function returns 0 if there was an error while retrieving the data.

Parameters:
refNum,: IN:
address,: IN:
field,: IN:
Return values:
CharPtr

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:07:12 2008 for Palm API Guide


Header Files » Incs » common » libraries » telephony

HsPhoneCDMATypes.h File Reference

Detailed Description

Header File for Phone Library API ---- NETWORK CATEGORY.

NOTES: All implementations of the Handspring Phone Library support a common API. This API is broken up into various categories for easier management. This file defines the CDMA category. These API calls are used to interact with the wireless network.

Definition in file HsPhoneCDMATypes.h.

Include dependency graph for HsPhoneCDMATypes.h:

Go to the source code of this file.

Data Structures

  • struct PhnPDPList
  • struct PhnPDPWrite
  • struct PhnPDPPayload
  • struct PhnPDDataType
  • struct _PhnCDMAMediaTVSettings

Defines

  • #define indicatorNoCallerIDChar '?'
  • #define indicatorBlockedCallerIDChar '!'
  • #define indicatorRemainingCallerIDChar '~'
  • #define phnPDPUidLen 15
  • #define phnMaxNAILen 72
  • #define phnMaxMNHASharedSecretLen 48
  • #define phnMaxMNAAASharedSecretLen 48
  • #define phnMaxSvcStrLen 22
  • #define phnMaxDialStrLen 15
  • #define phnMaxMslLen 6
  • #define phnMaxUrlLen 128
  • #define phnOtaspMobdirCommitFlag 0x0001
  • #define phnOtaspFTCCommitFlag 0x0002
  • #define phnOtaspRoamListCommitFlag 0x0004
  • #define phnOtaspSPCCommitFlag 0x0008
  • #define phnOtaspIMSICommitFlag 0x0010
  • #define phnOtaspNamLockCommitFlag 0x0020
  • #define phnOtaspAkeyCommitFlag 0x0040
  • #define phnOtasp3GPDCommitFlag 0x0080
  • #define phnOtaspMIPStatCommitFlag 0x0100
  • #define phnOtaspMIPRetryCommitFlag 0x0200
  • #define phnOtaspSPCFail 0x0400
  • #define phnOtaspCommitFlag 0x0800
  • #define phnOtaspInitProgReqFlag 0x1000
  • #define phnOtaspProgInProgressFlag 0x2000
  • #define phnOtaspSSDCommitFlag 0x4000
  • #define phnOtaspSuccessful 0x02FF
  • #define phnOtaspUnsuccessful 0x03FF
  • #define isValidPhnOneXDataFailType(d) ((d >= phnOneXFailPrev) && (d <= phnOneXFailUnknown))
  • #define isValidPhnPDPWriteAck(w) ((w >= phnPDPWriteOK) && (w <= phnPDPWriteInternalModemErr))
  • #define isValidPDPReadAck(r) ((r >= phnPDPReadOK) && (r <= phnPDPReadInternalModemErr))
  • #define isValidPhnPDPIndexType(t) ((t >= phnPDPDefaultIndex) && (t <= phnPDPGenericIndex))
  • #define isValidPhnPDPCopyAck(c) ((c >= phnPDPCopyOK) && (c <= phnPDPCopyInternalModemErr))
  • #define isValidPhnPDPDeleteAck(d) ((d >= phnPDPDeleteOK) && (d <= phnPDPDeleteInternalModemErr))
  • #define isValidPhnPDPReplaceAck(r) ((r >= phnPDPReplaceOK) && (r <= phnPDPReplaceInternalModemErr))
  • #define PhnCDMAMediaTVSettingsMajorVersion 0x0001
  • #define PhnCDMAMediaTVSettingsMinorVersion 0x0000
  • #define PhnCDMAMediaTVSettingsVersion (((UInt32)PhnCDMAMediaTVSettingsMajorVersion << 16) | PhnCDMAMediaTVSettingsMinorVersion)

Typedefs

  • typedef UInt8 PhnPDPIndexType
  • typedef UInt8 PhnPDPCopyAck
  • typedef UInt8 PhnPDPDeleteAck
  • typedef UInt8 PhnPDPReplaceAck
  • typedef UInt8 PhnPDPConnectionType
  • typedef UInt32 PhnPDPService
  • typedef struct PhnPDDataType * PhnPDDataPtr
  • typedef UInt8 PhnSysPrefSetting
  • typedef UInt32 PhnGenericCDMAPreference
  • typedef UInt32 PhnGenericCDMASMSEncodingType
  • typedef UInt32 PhnCDMAFirmwareType
  • typedef UInt32 PhnCDMAVoicemailType
  • typedef _PhnCDMAMediaTVSettings PhnCDMAMediaTVSettingsType

Enumerations

  • enum PhnOneXDataFailType {
    phnOneXFailPrev = 0,
    phnOneXFailNoSrv = 1,
    phnOneXFailNetworkSORej = 2,
    phnOneXFailModemSORej = 3,
    phnOneXFailNetworkBusy = 4,
    phnOneXFailUnknown = 5
    }
  • enum PhnPDPAUncerttype {
    PhnPDPAUncert0_5_M = 0x00,
    PhnPDPAUncert0_75_M,
    PhnPDPAUncert1_M,
    PhnPDPAUncert1_5_M,
    PhnPDPAUncert2_M,
    PhnPDPAUncert3_M,
    PhnPDPAUncert4_M,
    PhnPDPAUncert6_M,
    PhnPDPAUncert8_M,
    PhnPDPAUncert12_M,
    PhnPDPAUncert16_M,
    PhnPDPAUncert24_M,
    PhnPDPAUncert32_M,
    PhnPDPAUncert48_M,
    PhnPDPAUncert64_M,
    PhnPDPAUncert96_M,
    PhnPDPAUncert128_M,
    PhnPDPAUncert192_M,
    PhnPDPAUncert256_M,
    PhnPDPAUncert384_M,
    PhnPDPAUncert512_M,
    PhnPDPAUncert768_M,
    PhnPDPAUncert1024_M,
    PhnPDPAUncert1536_M,
    PhnPDPAUncert2048_M,
    PhnPDPAUncert3072_M,
    PhnPDPAUncert4096_M,
    PhnPDPAUncert6144_M,
    PhnPDPAUncert8192_M,
    PhnPDPAUncert12288_M,
    PhnPDPAUncertGREATER_12288_M,
    PhnPDPAUncertNOT_COMPUTABLE_M,
    PhnPDPAUncertMAX
    }
  • enum PhnMIPFailType {
    phnMIPSuccess,
    phnMIPNoSimBindings,
    phnMIPFaReasonUnspecified = 64,
    phnMIPFaAdminProhibited = 65,
    phnMIPFaInsufficientResources = 66,
    phnMIPFaMobileNodeAuth = 67,
    phnMIPFaHomeAgentAuth = 68,
    phnMIPFaReqLifetimeTooLong = 69,
    phnMIPFaPoorlyFormedReq = 70,
    phnMIPFaPoorlyFormedReply = 71,
    phnMIPFaReqedEncapUnavail = 72,
    phnMIPFaReservedNUnavail = 73,
    phnMIPFaCantRevTun = 74,
    phnMIPFaMustRevTun = 75,
    phnMIPFaBadTtl = 76,
    phnMIPFaInvalidCareOfAddr = 77,
    phnMIPFaRegistration_Timeout = 78,
    PhnMIPFADelvStyleUnsupported = 79,
    phnMIPFaHome_Network_Unreachable = 80,
    phnMIPFaHa_Host_Unreachable = 81,
    phnMIPFaHa_Port_Unreachable = 82,
    phnMIPFaHa_Unreachable = 88,
    PhnMIPFANonzeroHomeAddrReq = 96,
    PhnMIPFAMissingNai = 97,
    phnMIPFaForeign_Agent = 98,
    PhnMIPFAMissingHomeAddr = 99,
    PhnMIPFAError1 = 100,
    PhnMIPFAError2 = 101,
    phnMIPFaUnknown_Challenge = 104,
    phnMIPFaMissing_Challenge = 105,
    phnMIPFaStale_Challenge = 106,
    phnMIPHaReasonUnspecified = 128,
    phnMIPHaAdminProhibited = 129,
    phnMIPHaInsufficientResources = 130,
    phnMIPHaMobileNodeAuth = 131,
    phnMIPHaForeignAgentAuth = 132,
    phnMIPHaRegIdMismatch = 133,
    phnMIPHaPoorlyFormedReq = 134,
    phnMIPHaTooManySimMobBindings = 135,
    phnMIPHaUnknownHaAddr = 136,
    phnMIPHaCantRevTun = 137,
    phnMIPHaMustRevTun = 138,
    phnMIPHaReqEncapNotAvail = 139,
    phnMIPHAError1 = 140,
    phnMIPHAError2 = 141
    }
  • enum PhnPDPWriteAck {
    phnPDPWriteOK,
    phnPDPWriteInvalidIndex,
    phnPDPWriteIndexInUse,
    phnPDPWriteNotAllowedAtIndex,
    phnPDPWriteInvalidNAILen,
    phnPDPWriteInvalidNAIName,
    phnPDPWriteDuplicateNAI,
    phnPDPWriteInvalidAAALen,
    phnPDPInvalidHALen,
    phnPDPWriteInvalidSvcStrLen,
    phnPDPWriteInvalidDialStrLen,
    phnPDPWriteIndexNotPrevSet,
    phnPDPWriteInternalModemErr
    }
  • enum PhnPDPReadAck {
    phnPDPReadOK,
    phnPDPReadInvalidIndex,
    phnPDPReadNotAllowedAtIndex,
    phnPDPReadIndexNotSet,
    phnPDPReadInternalModemErr
    }
  • enum _PhnPDPIndexType {
    phnPDPDefaultIndex,
    phnPDPTempIndex,
    phnPDPGenericIndex
    }
  • enum _PhnPDPCopyAck {
    phnPDPCopyOK,
    phnPDPCopyInvalidFromIndex,
    phnPDPCopyFromIndexNotActive,
    phnPDPCopyNotAllowedAtFromIndex,
    phnPDPCopyInvalidToIndex,
    phnPDPCopyToIndexInUse,
    phnPDPCopyNotAllowedAtToIndex,
    phnPDPCopyInvalidNAILen,
    phnPDPCopyInvalidNAIName,
    phnPDPCopyDuplicateNAI,
    phnPDPCopyInvalidAAALen,
    phnPDPCopyInvalidSvcStrLen,
    phnPDPCopyInternalModemErr
    }
  • enum _PhnPDPDeleteAck {
    phnPDPDeleteOK,
    phnPDPDeleteInvalidIndex,
    phnPDPDeleteIndexActive,
    phnPDPDeleteIndexNotUsed,
    phnPDPDeleteNotAllowedAtIndex,
    phnPDPDeleteInternalModemErr
    }
  • enum _PhnPDPReplaceAck {
    phnPDPReplaceOK,
    phnPDPReplaceInvalidIndex,
    phnPDPReplaceInvalidNotUsed,
    phnPDPReplaceNotAllowedAtIndex,
    phnPDPReplaceInvalidLen,
    phnPDPReplaceInternalModemErr
    }
  • enum _PhnPDPConnectionType {
    phnPDPConnectionTypeSIP = 0,
    phnPDPConnectionTypeMIPWithSIPFallback,
    phnPDPConnectionTypeMIP,
    phnPDPConnectionTypeInvalid
    }
  • enum _PhnPDPService {
    phnPDPServiceUnknown = 0x00000000,
    phnPDPServiceInternet = 0x00000001,
    phnPDPServiceWAP = 0x00000002,
    phnPDPServicePrivate = 0x00000004,
    phnPDPServiceMMS = 0x00000008,
    phnPDPServiceBrowser = 0x00000010,
    phnPDPServiceMail = 0x00000020,
    phnPDPServiceIM = 0x00000040,
    phnPDPServiceDownloads = 0x00000080,
    phnPDPServiceCorporateGateway = 0x00000100,
    phnPDPServicePictureMail = 0x00000200
    }
  • enum _PhnSysPrefSetting {
    phnSysPrefHomeOnly,
    phnSysPrefAOnly,
    phnSysPrefBOnly,
    phnSysPrefStandard
    }
  • enum _PhnGenericCDMAPreference {
    phnGenericCDMASMSEncoding,
    phnGenericCDMAVoiceMailNumber,
    phnGenericCDMAVoiceMailOption,
    phnGenericCDMAAllowPDPSlotModification
    }
  • enum _PhnGenericCDMASMSEncodingType {
    phnSMSEncodingGSM = 0,
    phnSMSEncodingASCII,
    phnSMSEncodingISO8859_1
    }
  • enum _PhnCDMAFirmwareType {
    phnCDMAFirmwareSprint = 0,
    phnCDMAFirmwareVerizon,
    phnCDMAFirmwareBellMobility,
    phnCDMAFirmwareEarthlink,
    phnCDMAFirmwareCrowdy,
    phnCDMAFirmwareAlltel
    }
  • enum _PhnCDMAVoicemailType {
    phnCDMAVoicemailMDN = 0,
    phnCDMAVoicemailMDN1,
    phnCDMAVoicemailDigits
    }

Define Documentation

#define indicatorBlockedCallerIDChar '!'

CDMA Only -- Means the caller ID is blocked

Definition at line 38 of file HsPhoneCDMATypes.h.

#define indicatorNoCallerIDChar '?'

workaround for differing header files in sdk-3.5 and sdk-internal CDMA Only -- Means there is no caller ID

Definition at line 37 of file HsPhoneCDMATypes.h.

#define indicatorRemainingCallerIDChar '~'

CDMA Only -- Means the caller ID is the remaining caller (3+ calls scenario)

Definition at line 39 of file HsPhoneCDMATypes.h.

#define isValidPDPReadAck ( r ) ((r >= phnPDPReadOK) && (r <= phnPDPReadInternalModemErr))

Definition at line 221 of file HsPhoneCDMATypes.h.

#define isValidPhnOneXDataFailType ( d ) ((d >= phnOneXFailPrev) && (d <= phnOneXFailUnknown))

Definition at line 88 of file HsPhoneCDMATypes.h.

#define isValidPhnPDPCopyAck ( c ) ((c >= phnPDPCopyOK) && (c <= phnPDPCopyInternalModemErr))

Definition at line 260 of file HsPhoneCDMATypes.h.

#define isValidPhnPDPDeleteAck ( d ) ((d >= phnPDPDeleteOK) && (d <= phnPDPDeleteInternalModemErr))

Definition at line 278 of file HsPhoneCDMATypes.h.

#define isValidPhnPDPIndexType ( t ) ((t >= phnPDPDefaultIndex) && (t <= phnPDPGenericIndex))

Definition at line 236 of file HsPhoneCDMATypes.h.

#define isValidPhnPDPReplaceAck ( r ) ((r >= phnPDPReplaceOK) && (r <= phnPDPReplaceInternalModemErr))

Definition at line 296 of file HsPhoneCDMATypes.h.

#define isValidPhnPDPWriteAck ( w ) ((w >= phnPDPWriteOK) && (w <= phnPDPWriteInternalModemErr))

Definition at line 207 of file HsPhoneCDMATypes.h.

#define PhnCDMAMediaTVSettingsMajorVersion 0x0001

Definition at line 902 of file HsPhoneCDMATypes.h.

#define PhnCDMAMediaTVSettingsMinorVersion 0x0000

Definition at line 903 of file HsPhoneCDMATypes.h.

#define PhnCDMAMediaTVSettingsVersion (((UInt32)PhnCDMAMediaTVSettingsMajorVersion << 16) | PhnCDMAMediaTVSettingsMinorVersion)

Definition at line 904 of file HsPhoneCDMATypes.h.

#define phnMaxDialStrLen 15

HI_ONEX_MAX_DIAL_STR_LEN

Definition at line 50 of file HsPhoneCDMATypes.h.

#define phnMaxMNAAASharedSecretLen 48

HI_ONEX_MAX_MN_AAA_SHARED_SECRET_LEN

Definition at line 48 of file HsPhoneCDMATypes.h.

#define phnMaxMNHASharedSecretLen 48

HI_ONEX_MAX_MN_HA_SHARED_SECRET_LEN

Definition at line 47 of file HsPhoneCDMATypes.h.

#define phnMaxMslLen 6

HI_ONEX_MSL_LEN

Definition at line 51 of file HsPhoneCDMATypes.h.

#define phnMaxNAILen 72

Max length of NAI

Definition at line 46 of file HsPhoneCDMATypes.h.

#define phnMaxSvcStrLen 22

HI_ONEX_MAX_SVC_STR_LEN

Definition at line 49 of file HsPhoneCDMATypes.h.

#define phnMaxUrlLen 128

Max URL length

Definition at line 52 of file HsPhoneCDMATypes.h.

#define phnOtasp3GPDCommitFlag 0x0080

Definition at line 63 of file HsPhoneCDMATypes.h.

#define phnOtaspAkeyCommitFlag 0x0040

Definition at line 62 of file HsPhoneCDMATypes.h.

#define phnOtaspCommitFlag 0x0800

Definition at line 67 of file HsPhoneCDMATypes.h.

#define phnOtaspFTCCommitFlag 0x0002

Definition at line 57 of file HsPhoneCDMATypes.h.

#define phnOtaspIMSICommitFlag 0x0010

Definition at line 60 of file HsPhoneCDMATypes.h.

#define phnOtaspInitProgReqFlag 0x1000

Definition at line 68 of file HsPhoneCDMATypes.h.

#define phnOtaspMIPRetryCommitFlag 0x0200

Definition at line 65 of file HsPhoneCDMATypes.h.

#define phnOtaspMIPStatCommitFlag 0x0100

Definition at line 64 of file HsPhoneCDMATypes.h.

#define phnOtaspMobdirCommitFlag 0x0001

Definition at line 56 of file HsPhoneCDMATypes.h.

#define phnOtaspNamLockCommitFlag 0x0020

Definition at line 61 of file HsPhoneCDMATypes.h.

#define phnOtaspProgInProgressFlag 0x2000

Definition at line 69 of file HsPhoneCDMATypes.h.

#define phnOtaspRoamListCommitFlag 0x0004

Definition at line 58 of file HsPhoneCDMATypes.h.

#define phnOtaspSPCCommitFlag 0x0008

Definition at line 59 of file HsPhoneCDMATypes.h.

#define phnOtaspSPCFail 0x0400

Definition at line 66 of file HsPhoneCDMATypes.h.

#define phnOtaspSSDCommitFlag 0x4000

Definition at line 70 of file HsPhoneCDMATypes.h.

#define phnOtaspSuccessful 0x02FF

Definition at line 72 of file HsPhoneCDMATypes.h.

#define phnOtaspUnsuccessful 0x03FF

Definition at line 73 of file HsPhoneCDMATypes.h.

#define phnPDPUidLen 15

Max PDP UID length

Definition at line 45 of file HsPhoneCDMATypes.h.

Typedef Documentation

typedef UInt32 PhnCDMAFirmwareType

Definition at line 889 of file HsPhoneCDMATypes.h.

typedef struct _PhnCDMAMediaTVSettings PhnCDMAMediaTVSettingsType

typedef UInt32 PhnCDMAVoicemailType

Definition at line 899 of file HsPhoneCDMATypes.h.

typedef UInt32 PhnGenericCDMAPreference

Definition at line 862 of file HsPhoneCDMATypes.h.

typedef UInt32 PhnGenericCDMASMSEncodingType

Definition at line 874 of file HsPhoneCDMATypes.h.

typedef struct PhnPDDataType * PhnPDDataPtr

typedef UInt8 PhnPDPConnectionType

Definition at line 319 of file HsPhoneCDMATypes.h.

typedef UInt8 PhnPDPCopyAck

Definition at line 258 of file HsPhoneCDMATypes.h.

typedef UInt8 PhnPDPDeleteAck

Definition at line 276 of file HsPhoneCDMATypes.h.

typedef UInt8 PhnPDPIndexType

Definition at line 234 of file HsPhoneCDMATypes.h.

typedef UInt8 PhnPDPReplaceAck

Definition at line 294 of file HsPhoneCDMATypes.h.

typedef UInt32 PhnPDPService

Definition at line 339 of file HsPhoneCDMATypes.h.

typedef UInt8 PhnSysPrefSetting

Definition at line 849 of file HsPhoneCDMATypes.h.

Enumeration Type Documentation

enum _PhnCDMAFirmwareType

Enumerator:
phnCDMAFirmwareSprint
phnCDMAFirmwareVerizon
phnCDMAFirmwareBellMobility
phnCDMAFirmwareEarthlink
phnCDMAFirmwareCrowdy CDMA rest of world
phnCDMAFirmwareAlltel

Definition at line 879 of file HsPhoneCDMATypes.h.

00880 {
00881   phnCDMAFirmwareSprint = 0,        /**<        */
00882   phnCDMAFirmwareVerizon,           /**<        */
00883   phnCDMAFirmwareBellMobility,      /**<        */
00884   phnCDMAFirmwareEarthlink,         /**<        */
00885   phnCDMAFirmwareCrowdy,            /**<CDMA rest of world*/
00886   phnCDMAFirmwareAlltel             /**<        */
00887 } _PhnCDMAFirmwareType;

enum _PhnCDMAVoicemailType

Enumerator:
phnCDMAVoicemailMDN
phnCDMAVoicemailMDN1
phnCDMAVoicemailDigits

Definition at line 892 of file HsPhoneCDMATypes.h.

00893 {
00894   phnCDMAVoicemailMDN = 0,
00895   phnCDMAVoicemailMDN1,
00896   phnCDMAVoicemailDigits
00897 } _PhnCDMAVoicemailType;

enum _PhnGenericCDMAPreference

Enumerator:
phnGenericCDMASMSEncoding
phnGenericCDMAVoiceMailNumber
phnGenericCDMAVoiceMailOption
phnGenericCDMAAllowPDPSlotModification

Definition at line 854 of file HsPhoneCDMATypes.h.

00855 {
00856   phnGenericCDMASMSEncoding,        /**<        */
00857   phnGenericCDMAVoiceMailNumber,    /**<        */
00858   phnGenericCDMAVoiceMailOption,
00859   phnGenericCDMAAllowPDPSlotModification
00860 } _PhnGenericCDMAPreference;

enum _PhnGenericCDMASMSEncodingType

Enumerator:
phnSMSEncodingGSM
phnSMSEncodingASCII
phnSMSEncodingISO8859_1

Definition at line 867 of file HsPhoneCDMATypes.h.

00868 {
00869   phnSMSEncodingGSM = 0,        /**<        */
00870   phnSMSEncodingASCII,          /**<        */
00871   phnSMSEncodingISO8859_1       /**<        */
00872 } _PhnGenericCDMASMSEncodingType;

enum _PhnPDPConnectionType

We changed the ordering of enum to match the TIL type and to keep it consistent with Crowdy NV table for the PDP. Previously, this type was only used by NetPref we impact was minimal. The new ordering also allows us to overload the NetMaster "isMobileIPValue" record value with this value. This way any of 'if (isMobileIPValue)' will return true for both MIP and MIP with fallback. Later we can check the specific in Netmaster as needed

Enumerator:
phnPDPConnectionTypeSIP | PDP contains Simple IP settings
phnPDPConnectionTypeMIPWithSIPFallback | PDP contains MobileIP settings. Also allows Simple IP fallback - for Crowdy
phnPDPConnectionTypeMIP | PDP contains Mobile IP settings
phnPDPConnectionTypeInvalid

Definition at line 311 of file HsPhoneCDMATypes.h.

00311              {
00312   phnPDPConnectionTypeSIP = 0,          /**< PDP contains Simple IP settings  */
00313   phnPDPConnectionTypeMIPWithSIPFallback, /**< PDP contains MobileIP settings. Also allows Simple IP fallback - for Crowdy  */
00314   phnPDPConnectionTypeMIP,          /**< PDP contains Mobile IP settings  */
00315   phnPDPConnectionTypeInvalid
00316
00317 } _PhnPDPConnectionType;

enum _PhnPDPCopyAck

Enumerator:
phnPDPCopyOK
phnPDPCopyInvalidFromIndex
phnPDPCopyFromIndexNotActive
phnPDPCopyNotAllowedAtFromIndex
phnPDPCopyInvalidToIndex
phnPDPCopyToIndexInUse
phnPDPCopyNotAllowedAtToIndex
phnPDPCopyInvalidNAILen
phnPDPCopyInvalidNAIName
phnPDPCopyDuplicateNAI
phnPDPCopyInvalidAAALen
phnPDPCopyInvalidSvcStrLen
phnPDPCopyInternalModemErr

Definition at line 241 of file HsPhoneCDMATypes.h.

00242 {
00243   phnPDPCopyOK,             /**<        */
00244   phnPDPCopyInvalidFromIndex,       /**<        */
00245   phnPDPCopyFromIndexNotActive,     /**<        */
00246   phnPDPCopyNotAllowedAtFromIndex,  /**<        */
00247   phnPDPCopyInvalidToIndex,     /**<        */
00248   phnPDPCopyToIndexInUse,       /**<        */
00249   phnPDPCopyNotAllowedAtToIndex,    /**<        */
00250   phnPDPCopyInvalidNAILen,      /**<        */
00251   phnPDPCopyInvalidNAIName,     /**<        */
00252   phnPDPCopyDuplicateNAI,       /**<        */
00253   phnPDPCopyInvalidAAALen,      /**<        */
00254   phnPDPCopyInvalidSvcStrLen,       /**<        */
00255   phnPDPCopyInternalModemErr        /**<        */
00256 } _PhnPDPCopyAck;           /**<        */

enum _PhnPDPDeleteAck

Enumerator:
phnPDPDeleteOK
phnPDPDeleteInvalidIndex
phnPDPDeleteIndexActive
phnPDPDeleteIndexNotUsed
phnPDPDeleteNotAllowedAtIndex
phnPDPDeleteInternalModemErr

Definition at line 266 of file HsPhoneCDMATypes.h.

00267 {
00268   phnPDPDeleteOK,           /**<        */
00269   phnPDPDeleteInvalidIndex,     /**<        */
00270   phnPDPDeleteIndexActive,      /**<        */
00271   phnPDPDeleteIndexNotUsed,     /**<        */
00272   phnPDPDeleteNotAllowedAtIndex,    /**<        */
00273   phnPDPDeleteInternalModemErr      /**<        */
00274 } _PhnPDPDeleteAck;

enum _PhnPDPIndexType

Enumerator:
phnPDPDefaultIndex
phnPDPTempIndex
phnPDPGenericIndex

Definition at line 226 of file HsPhoneCDMATypes.h.

00227 {
00228   phnPDPDefaultIndex,       /**<        */
00229   phnPDPTempIndex,      /**<        */
00230   phnPDPGenericIndex        /**<        */
00231
00232 } _PhnPDPIndexType;

enum _PhnPDPReplaceAck

Enumerator:
phnPDPReplaceOK
phnPDPReplaceInvalidIndex
phnPDPReplaceInvalidNotUsed
phnPDPReplaceNotAllowedAtIndex
phnPDPReplaceInvalidLen
phnPDPReplaceInternalModemErr

Definition at line 283 of file HsPhoneCDMATypes.h.

00284 {
00285   phnPDPReplaceOK,          /**<        */
00286   phnPDPReplaceInvalidIndex,        /**<        */
00287   phnPDPReplaceInvalidNotUsed,      /**<        */
00288   phnPDPReplaceNotAllowedAtIndex,   /**<        */
00289   phnPDPReplaceInvalidLen,          /**<        */
00290   phnPDPReplaceInternalModemErr     /**<        */
00291
00292 } _PhnPDPReplaceAck;

enum _PhnPDPService

Bit mask that identifies the services a given profile should be used for

Enumerator:
phnPDPServiceUnknown
phnPDPServiceInternet | Profile to be used for generic internet
phnPDPServiceWAP | Profile to be used for WAP
phnPDPServicePrivate | Profile to be used for application specfic gateway
phnPDPServiceMMS | Profile to be used for MMS
phnPDPServiceBrowser | Profile to be used for Browser
phnPDPServiceMail | Profile to be used for email
phnPDPServiceIM | Profile to be used for IM
phnPDPServiceDownloads | Profile to be used for downloads
phnPDPServiceCorporateGateway | Profile to be used for corporate network
phnPDPServicePictureMail | Profile for Picture Mail

Definition at line 324 of file HsPhoneCDMATypes.h.

00325 {
00326   phnPDPServiceUnknown = 0x00000000,        /**<        */
00327   phnPDPServiceInternet = 0x00000001,       /**< Profile to be used for generic internet  */
00328   phnPDPServiceWAP = 0x00000002,            /**< Profile to be used for WAP  */
00329   phnPDPServicePrivate = 0x00000004,        /**< Profile to be used for application specfic gateway  */
00330   phnPDPServiceMMS = 0x00000008,        /**< Profile to be used for MMS  */
00331   phnPDPServiceBrowser = 0x00000010,        /**< Profile to be used for Browser   */
00332   phnPDPServiceMail = 0x00000020,       /**< Profile to be used for email  */
00333   phnPDPServiceIM = 0x00000040,         /**< Profile to be used for IM  */
00334   phnPDPServiceDownloads = 0x00000080,      /**< Profile to be used for downloads  */
00335   phnPDPServiceCorporateGateway = 0x00000100,   /**< Profile to be used for corporate network  */
00336   phnPDPServicePictureMail = 0x00000200     /**< Profile for Picture Mail  */
00337 } _PhnPDPService;

enum _PhnSysPrefSetting

Enumerator:
phnSysPrefHomeOnly
phnSysPrefAOnly
phnSysPrefBOnly
phnSysPrefStandard

Definition at line 840 of file HsPhoneCDMATypes.h.

00841 {
00842   phnSysPrefHomeOnly,       /**<        */
00843   phnSysPrefAOnly,      /**<        */
00844   phnSysPrefBOnly,      /**<        */
00845   phnSysPrefStandard        /**<        */
00846
00847 } _PhnSysPrefSetting;

enum PhnMIPFailType

Enumerator:
phnMIPSuccess
phnMIPNoSimBindings
phnMIPFaReasonUnspecified
phnMIPFaAdminProhibited
phnMIPFaInsufficientResources
phnMIPFaMobileNodeAuth
phnMIPFaHomeAgentAuth
phnMIPFaReqLifetimeTooLong
phnMIPFaPoorlyFormedReq
phnMIPFaPoorlyFormedReply
phnMIPFaReqedEncapUnavail
phnMIPFaReservedNUnavail
phnMIPFaCantRevTun
phnMIPFaMustRevTun
phnMIPFaBadTtl
phnMIPFaInvalidCareOfAddr
phnMIPFaRegistration_Timeout
PhnMIPFADelvStyleUnsupported
phnMIPFaHome_Network_Unreachable
phnMIPFaHa_Host_Unreachable
phnMIPFaHa_Port_Unreachable
phnMIPFaHa_Unreachable
PhnMIPFANonzeroHomeAddrReq
PhnMIPFAMissingNai
phnMIPFaForeign_Agent
PhnMIPFAMissingHomeAddr
PhnMIPFAError1
PhnMIPFAError2
phnMIPFaUnknown_Challenge
phnMIPFaMissing_Challenge
phnMIPFaStale_Challenge
phnMIPHaReasonUnspecified
phnMIPHaAdminProhibited
phnMIPHaInsufficientResources
phnMIPHaMobileNodeAuth
phnMIPHaForeignAgentAuth
phnMIPHaRegIdMismatch
phnMIPHaPoorlyFormedReq
phnMIPHaTooManySimMobBindings
phnMIPHaUnknownHaAddr
phnMIPHaCantRevTun
phnMIPHaMustRevTun
phnMIPHaReqEncapNotAvail
phnMIPHAError1
phnMIPHAError2

Definition at line 134 of file HsPhoneCDMATypes.h.

00134              {
00135
00136     phnMIPSuccess,              /**<        */
00137     phnMIPNoSimBindings,            /**<        */
00138     phnMIPFaReasonUnspecified=64,       /**<        */
00139     phnMIPFaAdminProhibited=65,         /**<        */
00140     phnMIPFaInsufficientResources=66,       /**<        */
00141     phnMIPFaMobileNodeAuth=67,          /**<        */
00142     phnMIPFaHomeAgentAuth=68,           /**<        */
00143     phnMIPFaReqLifetimeTooLong=69,      /**<        */
00144     phnMIPFaPoorlyFormedReq=70,         /**<        */
00145     phnMIPFaPoorlyFormedReply=71,       /**<        */
00146     phnMIPFaReqedEncapUnavail=72,       /**<        */
00147     phnMIPFaReservedNUnavail=73,        /**<        */
00148     phnMIPFaCantRevTun=74,          /**<        */
00149     phnMIPFaMustRevTun=75,          /**<        */
00150     phnMIPFaBadTtl=76,              /**<        */
00151     phnMIPFaInvalidCareOfAddr=77,       /**<        */
00152     phnMIPFaRegistration_Timeout=78,        /**<        */
00153     PhnMIPFADelvStyleUnsupported=79,    /**<        */
00154     phnMIPFaHome_Network_Unreachable=80,    /**<        */
00155     phnMIPFaHa_Host_Unreachable=81,     /**<        */
00156     phnMIPFaHa_Port_Unreachable=82,     /**<        */
00157     phnMIPFaHa_Unreachable=88,          /**<        */
00158     PhnMIPFANonzeroHomeAddrReq=96,      /**<        */
00159     PhnMIPFAMissingNai=97,          /**<        */
00160     phnMIPFaForeign_Agent=98,           /**<        */
00161     PhnMIPFAMissingHomeAddr=99,     /**<        */
00162     PhnMIPFAError1=100,                 /**<        */
00163     PhnMIPFAError2 =101,            /**<        */
00164     phnMIPFaUnknown_Challenge=104,      /**<        */
00165     phnMIPFaMissing_Challenge=105,      /**<        */
00166     phnMIPFaStale_Challenge=106,        /**<        */
00167     phnMIPHaReasonUnspecified=128,      /**<        */
00168     phnMIPHaAdminProhibited=129,        /**<        */
00169     phnMIPHaInsufficientResources=130,      /**<        */
00170     phnMIPHaMobileNodeAuth=131,         /**<        */
00171     phnMIPHaForeignAgentAuth=132,       /**<        */
00172     phnMIPHaRegIdMismatch=133,          /**<        */
00173     phnMIPHaPoorlyFormedReq=134,            /**<        */
00174     phnMIPHaTooManySimMobBindings=135,      /**<        */
00175     phnMIPHaUnknownHaAddr=136,          /**<        */
00176     phnMIPHaCantRevTun=137,             /**<        */
00177     phnMIPHaMustRevTun=138,             /**<        */
00178     phnMIPHaReqEncapNotAvail=139,       /**<        */
00179     phnMIPHAError1=140,         /**<        */
00180     phnMIPHAError2=141          /**<        */
00181
00182 } PhnMIPFailType;

enum PhnOneXDataFailType

Enumerator:
phnOneXFailPrev | current used PREV does not support the type of data call attempted
phnOneXFailNoSrv | modem did not have service when the data call was attempted
phnOneXFailNetworkSORej | The network rejected the service option for the data call
phnOneXFailModemSORej | The modem does not support or restricts the service option for the data call
phnOneXFailNetworkBusy | The network was busy
phnOneXFailUnknown

Definition at line 79 of file HsPhoneCDMATypes.h.

00079               {
00080     phnOneXFailPrev=0,      /**< current used PREV does not support the type of data call attempted */
00081     phnOneXFailNoSrv=1,     /**< modem did not have service when the data call was attempted */
00082     phnOneXFailNetworkSORej=2,  /**< The network rejected the service option for the data call */
00083     phnOneXFailModemSORej=3,    /**< The modem does not support or restricts the service option for the data call */
00084     phnOneXFailNetworkBusy=4,   /**< The network was busy */
00085     phnOneXFailUnknown=5    /**<        */
00086 } PhnOneXDataFailType;

enum PhnPDPAUncerttype

Enumerator:
PhnPDPAUncert0_5_M | Standard deviation of 0.5 meters
PhnPDPAUncert0_75_M | Standard deviation of 0.75 meters
PhnPDPAUncert1_M | Standard deviation of 1 meter
PhnPDPAUncert1_5_M | Standard deviation of 1.5 meters
PhnPDPAUncert2_M | Standard deviation of 2 meters
PhnPDPAUncert3_M | Standard deviation of 3 meters
PhnPDPAUncert4_M | Standard deviation of 4 meters
PhnPDPAUncert6_M | Standard deviation of 6 meters
PhnPDPAUncert8_M | Standard deviation of 8 meters
PhnPDPAUncert12_M | Standard deviation of 12 meters
PhnPDPAUncert16_M | Standard deviation of 16 meters
PhnPDPAUncert24_M | Standard deviation of 24 meters
PhnPDPAUncert32_M | Standard deviation of 32 meters
PhnPDPAUncert48_M | Standard deviation of 48 meters
PhnPDPAUncert64_M | Standard deviation of 64 meters
PhnPDPAUncert96_M | Standard deviation of 96 meters
PhnPDPAUncert128_M | Standard deviation of 128 meters
PhnPDPAUncert192_M | Standard deviation of 192 meters
PhnPDPAUncert256_M | Standard deviation of 256 meters
PhnPDPAUncert384_M | Standard deviation of 384 meters
PhnPDPAUncert512_M | Standard deviation of 512 meters
PhnPDPAUncert768_M | Standard deviation of 768 meters
PhnPDPAUncert1024_M | Standard deviation of 1,024 meters
PhnPDPAUncert1536_M | Standard deviation of 1,536 meters
PhnPDPAUncert2048_M | Standard deviation of 2,048 meters
PhnPDPAUncert3072_M | Standard deviation of 3,072 meters
PhnPDPAUncert4096_M | Standard deviation of 4,096 meters
PhnPDPAUncert6144_M | Standard deviation of 6,144 meters
PhnPDPAUncert8192_M | Standard deviation of 8,192 meters
PhnPDPAUncert12288_M | Standard deviation of 12,2288 meters
PhnPDPAUncertGREATER_12288_M | Standard deviation that is greater than 12,288 meters
PhnPDPAUncertNOT_COMPUTABLE_M | Standard deviation is not computable
PhnPDPAUncertMAX

Definition at line 94 of file HsPhoneCDMATypes.h.

00094             {
00095     PhnPDPAUncert0_5_M = 0x00,      /**< Standard deviation of 0.5 meters */
00096     PhnPDPAUncert0_75_M,        /**< Standard deviation of 0.75 meters */
00097     PhnPDPAUncert1_M,           /**< Standard deviation of 1 meter */
00098     PhnPDPAUncert1_5_M,         /**< Standard deviation of 1.5 meters */
00099     PhnPDPAUncert2_M,           /**< Standard deviation of 2 meters */
00100     PhnPDPAUncert3_M,               /**< Standard deviation of 3 meters */
00101     PhnPDPAUncert4_M,           /**< Standard deviation of 4 meters */
00102     PhnPDPAUncert6_M,               /**< Standard deviation of 6 meters */
00103     PhnPDPAUncert8_M,           /**< Standard deviation of 8 meters */
00104     PhnPDPAUncert12_M,          /**< Standard deviation of 12 meters */
00105     PhnPDPAUncert16_M,              /**< Standard deviation of 16 meters */
00106     PhnPDPAUncert24_M,          /**< Standard deviation of 24 meters */
00107     PhnPDPAUncert32_M,              /**< Standard deviation of 32 meters */
00108     PhnPDPAUncert48_M,              /**< Standard deviation of 48 meters */
00109     PhnPDPAUncert64_M,          /**< Standard deviation of 64 meters */
00110     PhnPDPAUncert96_M,          /**< Standard deviation of 96 meters */
00111     PhnPDPAUncert128_M,             /**< Standard deviation of 128 meters */
00112     PhnPDPAUncert192_M,             /**< Standard deviation of 192 meters */
00113     PhnPDPAUncert256_M,             /**< Standard deviation of 256 meters */
00114     PhnPDPAUncert384_M,             /**< Standard deviation of 384 meters */
00115     PhnPDPAUncert512_M,             /**< Standard deviation of 512 meters */
00116     PhnPDPAUncert768_M,             /**< Standard deviation of 768 meters */
00117     PhnPDPAUncert1024_M,            /**< Standard deviation of 1,024 meters */
00118     PhnPDPAUncert1536_M,            /**< Standard deviation of 1,536 meters */
00119     PhnPDPAUncert2048_M,            /**< Standard deviation of 2,048 meters */
00120     PhnPDPAUncert3072_M,            /**< Standard deviation of 3,072 meters */
00121     PhnPDPAUncert4096_M,            /**< Standard deviation of 4,096 meters */
00122     PhnPDPAUncert6144_M,            /**< Standard deviation of 6,144 meters */
00123     PhnPDPAUncert8192_M,            /**< Standard deviation of 8,192 meters */
00124     PhnPDPAUncert12288_M,           /**< Standard deviation of 12,2288 meters */
00125     PhnPDPAUncertGREATER_12288_M,       /**< Standard deviation that is greater than 12,288 meters */
00126     PhnPDPAUncertNOT_COMPUTABLE_M,      /**< Standard deviation is not computable */
00127     PhnPDPAUncertMAX
00128 } PhnPDPAUncerttype;

enum PhnPDPReadAck

Enumerator:
phnPDPReadOK
phnPDPReadInvalidIndex
phnPDPReadNotAllowedAtIndex
phnPDPReadIndexNotSet
phnPDPReadInternalModemErr

Definition at line 212 of file HsPhoneCDMATypes.h.

00213 {
00214   phnPDPReadOK,             /**<        */
00215   phnPDPReadInvalidIndex,       /**<        */
00216   phnPDPReadNotAllowedAtIndex,      /**<        */
00217   phnPDPReadIndexNotSet,        /**<        */
00218   phnPDPReadInternalModemErr        /**<        */
00219 }PhnPDPReadAck;

enum PhnPDPWriteAck

Enumerator:
phnPDPWriteOK
phnPDPWriteInvalidIndex
phnPDPWriteIndexInUse
phnPDPWriteNotAllowedAtIndex
phnPDPWriteInvalidNAILen
phnPDPWriteInvalidNAIName
phnPDPWriteDuplicateNAI
phnPDPWriteInvalidAAALen
phnPDPInvalidHALen
phnPDPWriteInvalidSvcStrLen
phnPDPWriteInvalidDialStrLen
phnPDPWriteIndexNotPrevSet
phnPDPWriteInternalModemErr

Definition at line 188 of file HsPhoneCDMATypes.h.

00189 {
00190
00191   phnPDPWriteOK,            /**<        */
00192   phnPDPWriteInvalidIndex,      /**<        */
00193   phnPDPWriteIndexInUse,        /**<        */
00194   phnPDPWriteNotAllowedAtIndex,     /**<        */
00195   phnPDPWriteInvalidNAILen,     /**<        */
00196   phnPDPWriteInvalidNAIName,        /**<        */
00197   phnPDPWriteDuplicateNAI,      /**<        */
00198   phnPDPWriteInvalidAAALen,     /**<        */
00199   phnPDPInvalidHALen,           /**<        */
00200   phnPDPWriteInvalidSvcStrLen,      /**<        */
00201   phnPDPWriteInvalidDialStrLen,     /**<        */
00202   phnPDPWriteIndexNotPrevSet,       /**<        */
00203   phnPDPWriteInternalModemErr       /**<        */
00204
00205 }PhnPDPWriteAck;

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:07:14 2008 for Palm API Guide


Header Files » Incs » common » libraries » telephony

HsPhoneErrors.h File Reference

Detailed Description

Errors returned by API function in GSM/CDMA Library.

NOTES: This file is meant to contain all error codes that are returned by an API in the phone library. If the error is not being returned by an API call, please do not add it to this file, but keep it in a private header file in the libraries.

Definition in file HsPhoneErrors.h.

Include dependency graph for HsPhoneErrors.h:

Go to the source code of this file.

Typedefs

  • typedef Err PHNErrorCode

Enumerations

  • enum PHNErrorCodeRange_1 {
    phnErrorClass = hsPhoneLibErrorClass_1,
    phnErrParam,
    phnErrUnknownError,
    phnErrNoResponse,
    phnErrNotOpen,
    phnErrStillOpen,
    phnErrMemory,
    phnErrUnknownID,
    phnErrNoPower,
    phnErrNoNetwork,
    phnErrNoConnection,
    phnErrNotAllowed,
    phnErrIllegalFacility,
    phnErrIllegalCondition,
    phnErrIllegalStatus,
    phnErrIllegalIndex,
    phnErrIllegalChars,
    phnErrIllegalMsg,
    phnErrIllegalType,
    phnErrIllegalNumber,
    phnErrTimeout,
    phnErrUnknownApp,
    phnErrUnknownNumber,
    phnErrBufferTooSmall,
    phnErrPasswordRequired,
    phnErrResponsePending,
    phnErrCancelled,
    phnErrNoRecipient,
    phnErrPhoneFailure,
    phnErrPhoneNotConnected,
    phnErrPhoneAdaptorLinkReserved,
    phnErrNotSupported,
    phnErrPhPINRequired,
    phnErrPhFPINRequired,
    phnErrPhFPUKRequired,
    phnErrNoSIM,
    phnErrPINRequired,
    phnErrPUKRequired,
    phnErrSIMFailure,
    phnErrSIMBusy,
    phnErrSIMWrong,
    phnErrIncorrectPassword,
    phnErrPIN2Required,
    phnErrPUK2Required,
    phnErrMemoryFull,
    phnErrInvalidMemIndex,
    phnErrNotFound,
    phnErrMemFailure,
    phnErrStringTooLong,
    phnErrInvalidTextChars,
    phnErrDialStringTooLong,
    phnErrInvalidDialChars,
    phnErrNoNetworkService,
    phnErrNetworkTimeout,
    phnErrNetworkNotAllowed,
    phnErrNetPINRequired,
    phnErrNetPUKRequired,
    phnErrNetSubPINRequired,
    phnErrNetSubPUKRequired,
    phnErrSPPINRequired,
    phnErrSPPUKRequired,
    phnErrCorpPINRequired,
    phnErrCorpPUKRequired,
    phnErrIllegalMS,
    phnErrIllegalME,
    phnErrGPRSNotAllowed,
    phnErrPLMNNotAllowed,
    phnErrLocAreaNotAllowed,
    phnErrRoamingNotAllowed,
    phnErrOptionNotSupported,
    phnErrReqOptionNotSubscribed,
    phnErrOptionTempOutOfOrder,
    phnErrUnspecifiedGPSRError,
    phnErrAuthenticationFailure,
    phnErrInvalidMobileClass,
    phnErrUnassignedNumber,
    phnErrOperDeterminedBarring,
    phnErrCallBarred,
    phnErrSMSXferRejected,
    phnErrDestOutOfService,
    phnErrUnidentifedSubscriber,
    phnErrFacRejected,
    phnErrUnknownSubscriber,
    phnErrNetworkOutOfOrder,
    phnErrTemporaryFailure,
    phnErrCongestion,
    phnErrResourcesUnavailable,
    phnErrReqFacNotSubscribed,
    phnErrReqFacNotImplemented,
    phnErrInvalidSMSReference,
    phnErrInvalidMsg,
    phnErrInvalidMandInfo,
    phnErrMsgTypeNonExistent,
    phnErrMsgNoCompatible,
    phnErrInfoElemNonExistent,
    phnErrProtocolError,
    phnErrInterworking,
    phnErrTelematicIWNotSupported,
    phnErrSMType0NotSupported,
    phnErrCannotReplaceMsg,
    phnErrUnspecifiedTPPIDError,
    phnErrAlphabetNotSupported,
    phnErrMsgClassNotSupported,
    phnErrUnspecifiedTPDCSError,
    phnErrCmdCannotBeActioned,
    phnErrCmdUnsupported,
    phnErrUnspecifiedTPCmdError,
    phnErrTPDUNotSupported,
    phnErrSCBusy,
    phnErrNoSCSubscription,
    phnErrSCSystemFailure,
    phnErrInvalidSMEAddr,
    phnErrDestSMEBarred,
    phnErrSMRejectedDuplicate,
    phnErrTPVPFNotSupported,
    phnErrTPVPNotSupported,
    phnErrSMSStorageFull,
    phnErrNoSMSStorage,
    phnErrErrorInMS,
    phnErrSIMApplToolkitBusy,
    phnErrMEFailure,
    phnErrSMSServReserved,
    phnErrInvalidParameter,
    phnErrFiller,
    phnErrFiller2,
    phnErrFiller3,
    phnErrMemoryFailure,
    phnErrSCAddrUnknown,
    phnErrNoCNMAAckExpected,
    phnErrFDNMismatch,
    phnErrEmergencyCallsOnly,
    phnErrACMLimitExceeded,
    phnErrHoldError,
    phnErrNumberBlacklisted,
    phnErrLidClosed,
    phnErrSATUnavailable,
    phnErrSATInactive,
    phnErrUNUSED,
    phnErrRadioNotAvailable,
    phnErrIntermediateResult,
    phnErrUnexpectedResponse,
    phnErrDuplicatePage,
    phnErrFirmwareBootNotInprogress,
    phnErrFirmwareBootInprogress,
    phnErrMMFailed,
    phnErrLowerLayer,
    phnErrCPError,
    phnErrCommandInProgress,
    phnErrSATNotSupported,
    phnErrSATNoInd,
    phnErrNeedResetModule,
    phnErrCOPSAbort,
    phnErrCSDUnassignedNumber,
    phnErrCSDNoRouteToDestination,
    phnErrCSDChannelUnacceptable,
    phnErrCSDOperatorBarring,
    phnErrCSDNumberBusy,
    phnErrCSDNoUserResponse,
    phnErrCSDNoAnswer,
    phnErrCSDCallRejected,
    phnErrCSDNumberChanged,
    phnErrCSDDestinationOutOfOrder,
    phnErrCSDInvalidNumberFormat,
    phnErrCSDFacilityRejected,
    phnErrCSDNoCircuitAvailable,
    phnErrCSDNetworkOutOfOrder,
    phnErrCSDTempFailure,
    phnErrCSDSwitchingCongestion,
    phnErrCSDAccessInfoDiscarded,
    phnErrCSDReqCircuitNotAvailable,
    phnErrCSDResourceNotAvailable,
    phnErrCSDQOSNotAvailable,
    phnErrCSDFacilityNotSubscribed,
    phnErrCSDIncomingCallsBarredCUG,
    phnErrCSDBearerNotCapable,
    phnErrCSDBearerNotAvailable,
    phnErrCSDServiceNotAvailble,
    phnErrCSDBearerNotImplemented,
    phnErrCSDACMOutOfRange,
    phnErrCSDFacilityNotImplemented,
    phnErrCSDRestrictedBearer,
    phnErrCSDServiceNotImplented,
    phnErrCSDInvalidTransID,
    phnErrCSDUserNotMemberCUG,
    phnErrCSDIncompatibleDestination,
    phnErrCSDInvalidTransitNetwork,
    phnErrCSDSemanticallyIncorrectMessage,
    phnErrCSDInvalidMandatoryInfo,
    phnErrCSDMessageTypeNotImplemented,
    phnErrCSDMessageTypeNotCompatible,
    phnErrCSDInfoNotImplemented,
    phnErrCSDIEError,
    phnErrCSDMessageNotCompatible,
    phnErrCSDRecoveryOnTimerExpiry,
    phnErrCSDProtocolError,
    phnErrGPRSRoamingNotAllowed,
    phnErrGPRSNetworkRequestDetach,
    phnErrGPRSNoService,
    phnErrGPRSNoAccess,
    phnErrGPRSServiceRefused,
    phnErrGPRSNetworkRequestPDPDeactivate,
    phnErrGPRSPDPDactivateLCCLinkActivation,
    phnErrGPRSPDPDeactivateNwkRactivate,
    phnErrGPRSPDPDactivateGMMAbort,
    phnErrGPRSPDPDeactivateSNDCPFailure,
    phnErrGPRSPDPActivateFailGMMError,
    phnErrGPRSPDPActivateFailNetReject,
    phnErrGPRSPDPActivateFailNoNSAPI,
    phnErrGPRSPDPActivateFailSMRefuse,
    phnErrCSDFDNError,
    phnErrCSDCallOperationNotAllowed,
    phnErrCSDCallBarringOutgoing,
    phnErrCSDCallBarringIncoming,
    phnErrCSDCallImpossible,
    phnErrCSDLowerLayerFailure,
    phnErrGPRSAPNMissing,
    phnErrNoCarrier,
    phnErrSMSFDNError,
    phnErrNullParam,
    phnErrBadServiceCode,
    phnErrBadATResult,
    phnErrBadATCmd,
    phnErrSIMDataDownload,
    phnErrLAST_1
    }
  • enum PHNErrorCodeRange_2 {
    phnErrorClass_2 = hsPhoneLibErrorClass_2,
    phnErrSaveNV,
    phnErrReadNV,
    phnErrFiller4,
    phnErrFiller5,
    phnErrDuplicatePlaceHoldler,
    phnErrFiller6,
    phnErrBatteryLowAlert,
    phnErrBatteryCharging,
    phnErrBadCRC,
    phnErrNoAppRegistered,
    phnErrSndDelClass,
    phnErrSndDelInvalidRingerID,
    phnErrSndDelUnusedRingerID,
    phnErrSndDelUndeletableRingerID,
    phnErrSndDelInternalMdmError,
    phnErrSndSaveClass,
    phnErrSndSaveFileNameInvalid,
    phnErrSndSaveBadDataLen,
    phnErrSndSaveBadRingerID,
    phnErrSndSaveBadSoundType,
    phnErrSndSaveOutOfMem,
    phnErrSndSaveInternalModem,
    phnErrSndSaveBadRsp,
    phnErrSndSaveContClass,
    phnErrSndSaveContBadDataLen,
    phnErrSndSaveContSeqNum,
    phnErrSndSaveContOutOfMem,
    phnErrSndSaveContInternalModem,
    phnErrModemBusy,
    phnErrModemOffline,
    phnErrIOTACommitFailed,
    phnErrIOTACommitInProgress,
    phnErrIS683ProtRevNotSupported,
    phnErrInvalidNAM,
    phnErrNAMMismatched,
    phnErrIOTASessionActive,
    phnErrIOTANoSession,
    phnErrNVUnInitialized,
    phnErrNvBadItem,
    phnErrPoweringDown,
    phnErrDenied,
    phnErrNotYetSupported,
    phnErrSMSMemoryFull,
    phnErrSMSMemoryOK,
    phnErrCauseCode16,
    phnErrMissingCarKitDriver,
    phnErrHCIMismatch,
    phnErrLAST_2
    }

Typedef Documentation

typedef Err PHNErrorCode

PHN Library result codes

Definition at line 34 of file HsPhoneErrors.h.

Enumeration Type Documentation

enum PHNErrorCodeRange_1

Enumerator:
phnErrorClass
phnErrParam | 0x4001 - invalid [in] params or invalid state machine.
phnErrUnknownError | 0x4002 poorly used error code; in GSM library indicates unexpected error code from radio, or various random parameters having unexpected values
phnErrNoResponse | 0x4003 Fail to receive event from modem.
phnErrNotOpen | 0x4004 phone library is not loaded for universal function or PhnLibOpen is not called before the function is called.
phnErrStillOpen | 0x4005 opencount of phone lib is > 0 after PhnLibClose is called.
phnErrMemory | 0x4006 insufficient memory to perform the operation
phnErrUnknownID | 0x4007 id from list is valid (e.g. from GSM connection list, SMS msg list, address book, etc)
phnErrNoPower | 0x4008 when phone is off.
phnErrNoNetwork | 0x4009 No service.
phnErrNoConnection | 0x400a NOT USED IN GSM LIBRARY
phnErrNotAllowed | 0x400b operation not allowed (WISMO CME ERROR: 3, CMS ERROR: 302)
phnErrIllegalFacility | 0x400c invalid GSM barring facility specified when activating/deactivating call barring
phnErrIllegalCondition | 0x400d provided condition for operation is invalid (such as GSM call forwarding condition)
phnErrIllegalStatus | 0x400e invalid GSM SMS Message Status detected
phnErrIllegalIndex | 0x400f index out of range in list (such as SIM PhoneBook or segmented SMS msg)
phnErrIllegalChars | 0x4010 character out of GSM valid set in SMS or other text
phnErrIllegalMsg | 0x4011 NOT USED IN GSM LIBRARY
phnErrIllegalType | 0x4012 unexpected type encountered (for example unexpected SMS message type for operation)
phnErrIllegalNumber | 0x4013 unexpected character in DTMF string or GSM phone number
phnErrTimeout | 0x4014 NOT USED IN GSM LIBRARY
phnErrUnknownApp | 0x4015 NOT USED IN GSM LIBRARY
phnErrUnknownNumber | 0x4016 given GSM phone number not found in address book
phnErrBufferTooSmall | 0x4017 NOT USED IN GSM LIBRARY
phnErrPasswordRequired | 0x4018 required GSM password or PIN is missing or invalid
phnErrResponsePending | 0x4019 operation failed because radio was busy processing another command
phnErrCancelled | 0x401a operation cancelled by user (e.g. cancel while entering password)
phnErrNoRecipient | 0x401b operation failed because GSM SMS message had no recipients specified
phnErrPhoneFailure | 0x401c Error reading/writing value to phone.
phnErrPhoneNotConnected | 0x401d WISMO CME ERROR: 1
phnErrPhoneAdaptorLinkReserved | 0x401e WISMO CME ERROR: 2
phnErrNotSupported | 0x401f Operation not supported (WISMO CME ERROR: 4; CMS ERROR: 303)
phnErrPhPINRequired | 0x4020 WISMO CME ERROR: 5 (PH-SIM PIN required (SIM lock))
phnErrPhFPINRequired | 0x4021 WISMO CME ERROR: 6
phnErrPhFPUKRequired | 0x4022 WISMO CME ERROR: 7
phnErrNoSIM | 0x4023 WISMO CME ERROR: 10 (SIM not inserted)
phnErrPINRequired | 0x4024 WISMO CME ERROR: 11 (SIM PIN required)
phnErrPUKRequired | 0x4025 WISMO CME ERROR: 12 (SIM PUK required)
phnErrSIMFailure | 0x4026 WISMO CME ERROR: 13 (SIM failure)
phnErrSIMBusy | 0x4027 WISMO CME ERROR: 14; CMS ERROR: 314; NOT DOCUMENTED IN WISMO DOC
phnErrSIMWrong | 0x4028 WISMO CME ERROR: 15; CMS ERROR: 315; NOT DOCUMENTED IN WISMO DOC
phnErrIncorrectPassword | 0x4029 WISMO CME ERROR: 16 (Incorrect password)
phnErrPIN2Required | 0x402a WISMO CME ERROR: 17 (SIM PIN2 required)
phnErrPUK2Required | 0x402b WISMO CME ERROR: 18 (SIM PUK2 required)
phnErrMemoryFull | 0x402c WISMO CME ERROR: 20 (Memory full )
phnErrInvalidMemIndex | 0x402d WISMO CME ERROR: 21 (Invalid index)
phnErrNotFound | 0x402e WISMO CME ERROR: 22 (Not found)
phnErrMemFailure | 0x402f WISMO CME ERROR: 23 NOT DOCUMENTED IN WISMO DOC
phnErrStringTooLong | 0x4030 WISMO CME ERROR: 24 (Text string too long)
phnErrInvalidTextChars | 0x4031 WISMO CME ERROR: 25 NOT DOCUMENTED IN WISMO DOC
phnErrDialStringTooLong | 0x4032 WISMO CME ERROR: 26 (Dial string too long)
phnErrInvalidDialChars | 0x4033 WISMO CME ERROR: 27 (Invalid characters in dial string)
phnErrNoNetworkService | 0x4034 WISMO CME ERROR: 30 (No network service); signal faded on CDMA
phnErrNetworkTimeout | 0x4035 WISMO CME ERROR: 31; CMS ERROR: 332 NOT DOCUMENTED IN WISMO DOC
phnErrNetworkNotAllowed | 0x4036 WISMO CME ERROR: 32 (Network not allowed - emergency calls only)
phnErrNetPINRequired | 0x4037 WISMO CME ERROR: 40 (Network personalisation PIN required (Network lock))
phnErrNetPUKRequired | 0x4038 WISMO CME ERROR: 41
phnErrNetSubPINRequired | 0x4039 WISMO CME ERROR: 42
phnErrNetSubPUKRequired | 0x403a WISMO CME ERROR: 43
phnErrSPPINRequired | 0x403b WISMO CME ERROR: 44
phnErrSPPUKRequired | 0x403c WISMO CME ERROR: 45
phnErrCorpPINRequired | 0x403d WISMO CME ERROR: 46
phnErrCorpPUKRequired | 0x403e WISMO CME ERROR: 47
phnErrIllegalMS | 0x403f WISMO CME ERROR: 103
phnErrIllegalME | 0x4040 WISMO CME ERROR: 106
phnErrGPRSNotAllowed | 0x4041 WISMO CME ERROR: 107
phnErrPLMNNotAllowed | 0x4042 WISMO CME ERROR: 111
phnErrLocAreaNotAllowed | 0x4043 WISMO CME ERROR: 112
phnErrRoamingNotAllowed | 0x4044 WISMO CME ERROR: 113
phnErrOptionNotSupported | 0x4045 WISMO CME ERROR: 132
phnErrReqOptionNotSubscribed | 0x4046 WISMO CME ERROR: 133
phnErrOptionTempOutOfOrder | 0x4047 WISMO CME ERROR: 134
phnErrUnspecifiedGPSRError | 0x4048 WISMO CME ERROR: 148
phnErrAuthenticationFailure | 0x4049 WISMO CME ERROR: 149
phnErrInvalidMobileClass | 0x404a WISMO CME ERROR: 150
phnErrUnassignedNumber | 0x404b WISMO CMS ERROR: 1
phnErrOperDeterminedBarring | 0x404c WISMO CMS ERROR: 8
phnErrCallBarred | 0x404d WISMO CMS ERROR: 10 or 18 Call guard option does not allow call
phnErrSMSXferRejected | 0x404e WISMO CMS ERROR: 21
phnErrDestOutOfService | 0x404f WISMO CMS ERROR: 27
phnErrUnidentifedSubscriber | 0x4050 WISMO CMS ERROR: 28
phnErrFacRejected | 0x4051 WISMO CMS ERROR: 29
phnErrUnknownSubscriber | 0x4052 WISMO CMS ERROR: 30
phnErrNetworkOutOfOrder | 0x4053 WISMO CMS ERROR: 38
phnErrTemporaryFailure | 0x4054 WISMO CMS ERROR: 41
phnErrCongestion | 0x4055 WISMO CMS ERROR: 42, APEX 2,10,16,17
phnErrResourcesUnavailable | 0x4056 No resources/network busy
phnErrReqFacNotSubscribed | 0x4057 GSM Error
phnErrReqFacNotImplemented | 0x4058 GSM Error
phnErrInvalidSMSReference | 0x4059 GSM Error
phnErrInvalidMsg | 0x405a GSM Error
phnErrInvalidMandInfo | 0x405b GSM Error
phnErrMsgTypeNonExistent | 0x405c GSM Error
phnErrMsgNoCompatible | 0x405d GSM Error
phnErrInfoElemNonExistent | 0x405e GSM Error
phnErrProtocolError | 0x405f GSM Error
phnErrInterworking | 0x4060 GSM Error
phnErrTelematicIWNotSupported | 0x4061 GSM Error
phnErrSMType0NotSupported | 0x4062 GSM Error
phnErrCannotReplaceMsg | 0x4063 GSM Error
phnErrUnspecifiedTPPIDError | 0x4064 GSM Error
phnErrAlphabetNotSupported | 0x4065 GSM Error
phnErrMsgClassNotSupported | 0x4066 GSM Error
phnErrUnspecifiedTPDCSError | 0x4067 GSM Error
phnErrCmdCannotBeActioned | 0x4068 GSM Error
phnErrCmdUnsupported | 0x4069 GSM Error
phnErrUnspecifiedTPCmdError | 0x406a GSM Error
phnErrTPDUNotSupported | 0x406b GSM Error
phnErrSCBusy | 0x406c GSM Error
phnErrNoSCSubscription | 0x406d GSM Error
phnErrSCSystemFailure | 0x406e GSM Error
phnErrInvalidSMEAddr | 0x406f GSM Error
phnErrDestSMEBarred | 0x4070 GSM Error
phnErrSMRejectedDuplicate | 0x4071 GSM Error
phnErrTPVPFNotSupported | 0x4072 GSM Error
phnErrTPVPNotSupported | 0x4073 GSM Error
phnErrSMSStorageFull | 0x4074 GSM Error
phnErrNoSMSStorage | 0x4075 GSM Error
phnErrErrorInMS | 0x4076 GSM Error
phnErrSIMApplToolkitBusy | 0x4077 GSM Error
phnErrMEFailure | 0x4078 GSM Error
phnErrSMSServReserved | 0x4079 WISMO CMS ERROR: 301 (SMS service of ME reserved)
phnErrInvalidParameter | 0x407a GSM Error
phnErrFiller | 0x407b GSM Error
phnErrFiller2 | 0x407c GSM Error
phnErrFiller3 | 0x407d GSM Error
phnErrMemoryFailure | 0x407e Memory access failure
phnErrSCAddrUnknown | 0x407f GSM Error
phnErrNoCNMAAckExpected | 0x4080 GSM Error
phnErrFDNMismatch | Errors returned by the firmware (NO CARRIER) 0x4081 GSM Error
phnErrEmergencyCallsOnly | 0x4082 GSM Error
phnErrACMLimitExceeded | 0x4083 GSM Error
phnErrHoldError | 0x4084 GSM Error
phnErrNumberBlacklisted | 0x4085 GSM Error
phnErrLidClosed | 0x4086
phnErrSATUnavailable | 0x4087 GSM Error
phnErrSATInactive | 0x4088 GSM Error
phnErrUNUSED | 0x4089 GSM Error
phnErrRadioNotAvailable | 0x408a GSM Error
phnErrIntermediateResult | 0x408b GSM Error
phnErrUnexpectedResponse | 0x408c GSM Error
phnErrDuplicatePage | 0x408d GSM Error
phnErrFirmwareBootNotInprogress | 0x408e GSM Error
phnErrFirmwareBootInprogress | 0x408f GSM Error
phnErrMMFailed | These error codes map directly to Wismo error codes, but maybe could be used by other radios? 0x4090 GSM Error
phnErrLowerLayer | 0x4091 GSM Error
phnErrCPError | 0x4092 GSM Error
phnErrCommandInProgress | 0x4093 GSM Error
phnErrSATNotSupported | 0x4094 GSM Error
phnErrSATNoInd | 0x4095 GSM Error
phnErrNeedResetModule | 0x4096 GSM Error
phnErrCOPSAbort | 0x4097 GSM Error
phnErrCSDUnassignedNumber | CSD CEER Errors 0x4098 GSM Error
phnErrCSDNoRouteToDestination | 0x4099 GSM Error
phnErrCSDChannelUnacceptable | 0x409a GSM Error
phnErrCSDOperatorBarring | 0x409b GSM Error
phnErrCSDNumberBusy | 0x409c GSM Error
phnErrCSDNoUserResponse | 0x409d GSM Error
phnErrCSDNoAnswer | 0x409e GSM Error
phnErrCSDCallRejected | 0x409f GSM Error
phnErrCSDNumberChanged | 0x40a0 GSM Error
phnErrCSDDestinationOutOfOrder | 0x40a1 GSM Error
phnErrCSDInvalidNumberFormat | 0x40a2 GSM Error
phnErrCSDFacilityRejected | 0x40a3 GSM Error
phnErrCSDNoCircuitAvailable | 0x40a4 GSM Error
phnErrCSDNetworkOutOfOrder | 0x40a5 GSM Error
phnErrCSDTempFailure | 0x40a6 GSM Error
phnErrCSDSwitchingCongestion | 0x40a7 GSM Error
phnErrCSDAccessInfoDiscarded | 0x40a8 GSM Error
phnErrCSDReqCircuitNotAvailable | 0x40a9 GSM Error
phnErrCSDResourceNotAvailable | 0x40aa GSM Error
phnErrCSDQOSNotAvailable | 0x40ab GSM Error
phnErrCSDFacilityNotSubscribed | 0x40ac GSM Error
phnErrCSDIncomingCallsBarredCUG | 0x40ad GSM Error
phnErrCSDBearerNotCapable | 0x40ae GSM Error
phnErrCSDBearerNotAvailable | 0x40af GSM Error
phnErrCSDServiceNotAvailble | 0x40b0 GSM Error
phnErrCSDBearerNotImplemented | 0x40b1 GSM Error
phnErrCSDACMOutOfRange | 0x40b2 GSM Error
phnErrCSDFacilityNotImplemented | 0x40b3 GSM Error
phnErrCSDRestrictedBearer | 0x40b4 GSM Error
phnErrCSDServiceNotImplented | 0x40b5 GSM Error
phnErrCSDInvalidTransID | 0x40b6 GSM Error
phnErrCSDUserNotMemberCUG | 0x40b7 GSM Error
phnErrCSDIncompatibleDestination | 0x40b8 GSM Error
phnErrCSDInvalidTransitNetwork | 0x40b9 GSM Error
phnErrCSDSemanticallyIncorrectMessage | 0x40ba GSM Error
phnErrCSDInvalidMandatoryInfo | 0x40bb GSM Error
phnErrCSDMessageTypeNotImplemented | 0x40bc GSM Error
phnErrCSDMessageTypeNotCompatible | 0x40bd GSM Error
phnErrCSDInfoNotImplemented | 0x40be GSM Error
phnErrCSDIEError | 0x40bf GSM Error
phnErrCSDMessageNotCompatible | 0x40c0 GSM Error
phnErrCSDRecoveryOnTimerExpiry | 0x40c1 GSM Error
phnErrCSDProtocolError | 0x40c2 GSM Error
phnErrGPRSRoamingNotAllowed | GPRS CEER Errors 0x40c3 GSM Error
phnErrGPRSNetworkRequestDetach | 0x40c4 GSM Error
phnErrGPRSNoService | 0x40c5 GSM Error
phnErrGPRSNoAccess | 0x40c6 GSM Error
phnErrGPRSServiceRefused | 0x40c7 GSM Error
phnErrGPRSNetworkRequestPDPDeactivate | 0x40c8 GSM Error
phnErrGPRSPDPDactivateLCCLinkActivation | 0x40c9 GSM Error
phnErrGPRSPDPDeactivateNwkRactivate | 0x40ca GSM Error
phnErrGPRSPDPDactivateGMMAbort | 0x40cb GSM Error
phnErrGPRSPDPDeactivateSNDCPFailure | 0x40cc GSM Error
phnErrGPRSPDPActivateFailGMMError | 0x40cd GSM Error
phnErrGPRSPDPActivateFailNetReject | 0x40ce GSM Error
phnErrGPRSPDPActivateFailNoNSAPI | 0x40cf GSM Error
phnErrGPRSPDPActivateFailSMRefuse | 0x40d0 GSM Error
phnErrCSDFDNError | MORE CSD Errors 0x40d1 GSM Error
phnErrCSDCallOperationNotAllowed | 0x40d2 GSM Error
phnErrCSDCallBarringOutgoing | 0x40d3 GSM Error
phnErrCSDCallBarringIncoming | 0x40d4 GSM Error
phnErrCSDCallImpossible | 0x40d5 GSM Error
phnErrCSDLowerLayerFailure | 0x40d6 GSM Error
phnErrGPRSAPNMissing | More GPRS Errors 0x40d7 GSM Error
phnErrNoCarrier | More Errors 0x40d8 GSM Error
phnErrSMSFDNError | 0x40d9 GSM Error : SMS Fixed Dialing error (CMS ERROR: 531)
phnErrNullParam | 0x40da GSM Error : provided parameter is unexpectedly null
phnErrBadServiceCode | 0x40db GSM Error : intermediate response has unexpected service code
phnErrBadATResult | 0x40dc GSM Error : AT response from radio is missing or invalid
phnErrBadATCmd | 0x40dd GSM Error : AT cmd to radio is missing or invalid
phnErrSIMDataDownload | 0x40de GSM Error : SIM Data Download error (CMS ERROR: 213)
phnErrLAST_1 | IMPORTANT: the last valid error code for this error class is 0x40FF. If you exceed this range, you will collide with the next error class that belongs to PalmSource, and will have all kinds of conflicts, such as wrong error strings and wrong interpretation of errors by applications.

Definition at line 36 of file HsPhoneErrors.h.

00037   {
00038     phnErrorClass = hsPhoneLibErrorClass_1,
00039     phnErrParam,                    /**< 0x4001 - invalid [in] params or invalid state machine. */
00040     phnErrUnknownError,             /**< 0x4002 poorly used error code; in GSM library indicates unexpected error code from radio, or various random parameters having unexpected values */
00041     phnErrNoResponse,               /**< 0x4003 Fail to receive event from modem. */
00042     phnErrNotOpen,                  /**< 0x4004 phone library is not loaded for universal function or   PhnLibOpen is not called before the function is called. */
00043     phnErrStillOpen,                /**< 0x4005 opencount of phone lib is > 0 after PhnLibClose is called. */
00044     phnErrMemory,                   /**< 0x4006 insufficient memory to perform the operation */
00045     phnErrUnknownID,                /**< 0x4007 id from list is valid (e.g. from GSM connection list, SMS msg list, address book, etc) */
00046     phnErrNoPower,                  /**< 0x4008 when phone is off. */
00047     phnErrNoNetwork,                /**< 0x4009 No service. */
00048     phnErrNoConnection,             /**< 0x400a NOT USED IN GSM LIBRARY */
00049     phnErrNotAllowed,               /**< 0x400b operation not allowed (WISMO CME ERROR: 3, CMS ERROR: 302) */
00050     phnErrIllegalFacility,              /**< 0x400c invalid GSM barring facility specified when activating/deactivating call barring */
00051     phnErrIllegalCondition,             /**< 0x400d provided condition for operation is invalid (such as GSM call forwarding condition) */
00052     phnErrIllegalStatus,                /**< 0x400e invalid GSM SMS Message Status detected */
00053     phnErrIllegalIndex,             /**< 0x400f index out of range in list (such as SIM PhoneBook or segmented SMS msg) */
00054     phnErrIllegalChars,             /**< 0x4010 character out of GSM valid set in SMS or other text */
00055     phnErrIllegalMsg,               /**< 0x4011 NOT USED IN GSM LIBRARY */
00056     phnErrIllegalType,              /**< 0x4012 unexpected type encountered (for example unexpected SMS message type for operation) */
00057     phnErrIllegalNumber,                /**< 0x4013 unexpected character in DTMF string or GSM phone number */
00058     phnErrTimeout,                  /**< 0x4014 NOT USED IN GSM LIBRARY */
00059     phnErrUnknownApp,               /**< 0x4015 NOT USED IN GSM LIBRARY */
00060     phnErrUnknownNumber,                /**< 0x4016 given GSM phone number not found in address book */
00061     phnErrBufferTooSmall,               /**< 0x4017 NOT USED IN GSM LIBRARY */
00062     phnErrPasswordRequired,             /**< 0x4018 required GSM password or PIN is missing or invalid */
00063     phnErrResponsePending,              /**< 0x4019 operation failed because radio was busy processing another command */
00064     phnErrCancelled,                /**< 0x401a operation cancelled by user (e.g. cancel while entering password) */
00065     phnErrNoRecipient,              /**< 0x401b operation failed because GSM SMS message had no recipients specified */
00066     phnErrPhoneFailure,             /**< 0x401c Error reading/writing value to phone. */
00067     phnErrPhoneNotConnected,                /**< 0x401d WISMO CME ERROR: 1 */
00068     phnErrPhoneAdaptorLinkReserved,         /**< 0x401e WISMO CME ERROR: 2 */
00069     phnErrNotSupported,                     /**< 0x401f Operation not supported (WISMO CME ERROR: 4; CMS ERROR: 303) */
00070     phnErrPhPINRequired,                    /**< 0x4020 WISMO CME ERROR: 5 (PH-SIM PIN required (SIM lock)) */
00071     phnErrPhFPINRequired,                   /**< 0x4021 WISMO CME ERROR: 6 */
00072     phnErrPhFPUKRequired,                   /**< 0x4022 WISMO CME ERROR: 7 */
00073     phnErrNoSIM,                            /**< 0x4023 WISMO CME ERROR: 10 (SIM not inserted) */
00074     phnErrPINRequired,                      /**< 0x4024 WISMO CME ERROR: 11 (SIM PIN required) */
00075     phnErrPUKRequired,                      /**< 0x4025 WISMO CME ERROR: 12 (SIM PUK required) */
00076     phnErrSIMFailure,                       /**< 0x4026 WISMO CME ERROR: 13 (SIM failure) */
00077     phnErrSIMBusy,                          /**< 0x4027 WISMO CME ERROR: 14; CMS ERROR: 314; NOT DOCUMENTED IN WISMO DOC */
00078     phnErrSIMWrong,                         /**< 0x4028 WISMO CME ERROR: 15; CMS ERROR: 315; NOT DOCUMENTED IN WISMO DOC */
00079     phnErrIncorrectPassword,                /**< 0x4029 WISMO CME ERROR: 16 (Incorrect password) */
00080     phnErrPIN2Required,                     /**< 0x402a WISMO CME ERROR: 17 (SIM PIN2 required) */
00081     phnErrPUK2Required,                     /**< 0x402b WISMO CME ERROR: 18 (SIM PUK2 required) */
00082     phnErrMemoryFull,                       /**< 0x402c WISMO CME ERROR: 20 (Memory full ) */
00083     phnErrInvalidMemIndex,                  /**< 0x402d WISMO CME ERROR: 21 (Invalid index) */
00084     phnErrNotFound,                         /**< 0x402e WISMO CME ERROR: 22 (Not found) */
00085     phnErrMemFailure,                       /**< 0x402f WISMO CME ERROR: 23 NOT DOCUMENTED IN WISMO DOC */
00086     phnErrStringTooLong,                    /**< 0x4030 WISMO CME ERROR: 24 (Text string too long) */
00087     phnErrInvalidTextChars,                 /**< 0x4031 WISMO CME ERROR: 25 NOT DOCUMENTED IN WISMO DOC */
00088     phnErrDialStringTooLong,                /**< 0x4032 WISMO CME ERROR: 26 (Dial string too long) */
00089     phnErrInvalidDialChars,                 /**< 0x4033 WISMO CME ERROR: 27 (Invalid characters in dial string) */
00090     phnErrNoNetworkService,                 /**< 0x4034 WISMO CME ERROR: 30 (No network service); signal faded on CDMA */
00091     phnErrNetworkTimeout,                   /**< 0x4035 WISMO CME ERROR: 31; CMS ERROR: 332 NOT DOCUMENTED IN WISMO DOC */
00092     phnErrNetworkNotAllowed,                /**< 0x4036 WISMO CME ERROR: 32 (Network not allowed - emergency calls only) */
00093     phnErrNetPINRequired,                   /**< 0x4037 WISMO CME ERROR: 40 (Network personalisation PIN required (Network lock)) */
00094     phnErrNetPUKRequired,                   /**< 0x4038 WISMO CME ERROR: 41 */
00095     phnErrNetSubPINRequired,                /**< 0x4039 WISMO CME ERROR: 42 */
00096     phnErrNetSubPUKRequired,                /**< 0x403a WISMO CME ERROR: 43 */
00097     phnErrSPPINRequired,                    /**< 0x403b WISMO CME ERROR: 44 */
00098     phnErrSPPUKRequired,                    /**< 0x403c WISMO CME ERROR: 45 */
00099     phnErrCorpPINRequired,                  /**< 0x403d WISMO CME ERROR: 46 */
00100     phnErrCorpPUKRequired,                  /**< 0x403e WISMO CME ERROR: 47 */
00101     phnErrIllegalMS,                        /**< 0x403f WISMO CME ERROR: 103 */
00102     phnErrIllegalME,                        /**< 0x4040 WISMO CME ERROR: 106 */
00103     phnErrGPRSNotAllowed,                   /**< 0x4041 WISMO CME ERROR: 107 */
00104     phnErrPLMNNotAllowed,                   /**< 0x4042 WISMO CME ERROR: 111 */
00105     phnErrLocAreaNotAllowed,                /**< 0x4043 WISMO CME ERROR: 112 */
00106     phnErrRoamingNotAllowed,                /**< 0x4044 WISMO CME ERROR: 113 */
00107     phnErrOptionNotSupported,               /**< 0x4045 WISMO CME ERROR: 132 */
00108     phnErrReqOptionNotSubscribed,           /**< 0x4046 WISMO CME ERROR: 133 */
00109     phnErrOptionTempOutOfOrder,             /**< 0x4047 WISMO CME ERROR: 134 */
00110     phnErrUnspecifiedGPSRError,             /**< 0x4048 WISMO CME ERROR: 148 */
00111     phnErrAuthenticationFailure,            /**< 0x4049 WISMO CME ERROR: 149 */
00112     phnErrInvalidMobileClass,               /**< 0x404a WISMO CME ERROR: 150 */
00113     phnErrUnassignedNumber,                 /**< 0x404b WISMO CMS ERROR: 1 */
00114     phnErrOperDeterminedBarring,            /**< 0x404c WISMO CMS ERROR: 8 */
00115     phnErrCallBarred,                       /**< 0x404d WISMO CMS ERROR: 10 or 18  Call guard option does not allow call */
00116     phnErrSMSXferRejected,                  /**< 0x404e WISMO CMS ERROR: 21 */
00117     phnErrDestOutOfService,                 /**< 0x404f WISMO CMS ERROR: 27 */
00118     phnErrUnidentifedSubscriber,            /**< 0x4050 WISMO CMS ERROR: 28 */
00119     phnErrFacRejected,                      /**< 0x4051 WISMO CMS ERROR: 29 */
00120     phnErrUnknownSubscriber,                /**< 0x4052 WISMO CMS ERROR: 30 */
00121     phnErrNetworkOutOfOrder,                /**< 0x4053 WISMO CMS ERROR: 38 */
00122     phnErrTemporaryFailure,                 /**< 0x4054 WISMO CMS ERROR: 41 */
00123     phnErrCongestion,                       /**< 0x4055 WISMO CMS ERROR: 42, APEX 2,10,16,17  */
00124     phnErrResourcesUnavailable,             /**< 0x4056   No resources/network busy  */
00125     phnErrReqFacNotSubscribed,              /**< 0x4057 GSM Error */
00126     phnErrReqFacNotImplemented,             /**< 0x4058 GSM Error */
00127     phnErrInvalidSMSReference,              /**< 0x4059 GSM Error */
00128     phnErrInvalidMsg,                       /**< 0x405a GSM Error */
00129     phnErrInvalidMandInfo,                  /**< 0x405b GSM Error */
00130     phnErrMsgTypeNonExistent,               /**< 0x405c GSM Error */
00131     phnErrMsgNoCompatible,                  /**< 0x405d GSM Error */
00132     phnErrInfoElemNonExistent,              /**< 0x405e GSM Error */
00133     phnErrProtocolError,                    /**< 0x405f GSM Error */
00134     phnErrInterworking,                     /**< 0x4060 GSM Error */
00135     phnErrTelematicIWNotSupported,          /**< 0x4061 GSM Error */
00136     phnErrSMType0NotSupported,              /**< 0x4062 GSM Error */
00137     phnErrCannotReplaceMsg,                 /**< 0x4063 GSM Error */
00138     phnErrUnspecifiedTPPIDError,            /**< 0x4064 GSM Error */
00139     phnErrAlphabetNotSupported,             /**< 0x4065 GSM Error */
00140     phnErrMsgClassNotSupported,             /**< 0x4066 GSM Error */
00141     phnErrUnspecifiedTPDCSError,            /**< 0x4067 GSM Error */
00142     phnErrCmdCannotBeActioned,              /**< 0x4068 GSM Error */
00143     phnErrCmdUnsupported,                   /**< 0x4069 GSM Error */
00144     phnErrUnspecifiedTPCmdError,            /**< 0x406a GSM Error */
00145     phnErrTPDUNotSupported,                 /**< 0x406b GSM Error */
00146     phnErrSCBusy,                           /**< 0x406c GSM Error */
00147     phnErrNoSCSubscription,                 /**< 0x406d GSM Error */
00148     phnErrSCSystemFailure,                  /**< 0x406e GSM Error */
00149     phnErrInvalidSMEAddr,                   /**< 0x406f GSM Error */
00150     phnErrDestSMEBarred,                    /**< 0x4070 GSM Error */
00151     phnErrSMRejectedDuplicate,              /**< 0x4071 GSM Error */
00152     phnErrTPVPFNotSupported,                /**< 0x4072 GSM Error */
00153     phnErrTPVPNotSupported,                 /**< 0x4073 GSM Error */
00154     phnErrSMSStorageFull,                   /**< 0x4074 GSM Error */
00155     phnErrNoSMSStorage,                     /**< 0x4075 GSM Error */
00156     phnErrErrorInMS,                        /**< 0x4076 GSM Error */
00157     phnErrSIMApplToolkitBusy,               /**< 0x4077 GSM Error */
00158     phnErrMEFailure,                        /**< 0x4078 GSM Error */
00159     phnErrSMSServReserved,                  /**< 0x4079 WISMO CMS ERROR: 301 (SMS service of ME reserved) */
00160     phnErrInvalidParameter,                 /**< 0x407a GSM Error */
00161     phnErrFiller,                           /**< 0x407b GSM Error */
00162     phnErrFiller2,                          /**< 0x407c GSM Error */
00163     phnErrFiller3,                          /**< 0x407d GSM Error */
00164     phnErrMemoryFailure,                    /**< 0x407e Memory access failure */
00165     phnErrSCAddrUnknown,                    /**< 0x407f GSM Error */
00166     phnErrNoCNMAAckExpected,                /**< 0x4080 GSM Error */
00167         /** Errors returned by the firmware (NO CARRIER) */
00168     phnErrFDNMismatch,                      /**< 0x4081  GSM Error */
00169     phnErrEmergencyCallsOnly,               /**< 0x4082  GSM Error */
00170     phnErrACMLimitExceeded,                 /**< 0x4083  GSM Error */
00171     phnErrHoldError,                        /**< 0x4084  GSM Error */
00172     phnErrNumberBlacklisted,                /**< 0x4085  GSM Error */
00173     phnErrLidClosed,                        /**< 0x4086 */
00174     phnErrSATUnavailable,                   /**< 0x4087  GSM Error */
00175     phnErrSATInactive,                      /**< 0x4088  GSM Error */
00176     phnErrUNUSED,                           /**< 0x4089  GSM Error */
00177     phnErrRadioNotAvailable,                /**< 0x408a  GSM Error */
00178     phnErrIntermediateResult,               /**< 0x408b  GSM Error */
00179     phnErrUnexpectedResponse,               /**< 0x408c  GSM Error */
00180     phnErrDuplicatePage,                    /**< 0x408d  GSM Error */
00181     phnErrFirmwareBootNotInprogress,        /**< 0x408e  GSM Error */
00182     phnErrFirmwareBootInprogress,           /**< 0x408f  GSM Error */
00183         /** These error codes map directly to Wismo error
00184             codes, but maybe could be used by other radios? */
00185     phnErrMMFailed,                 /**< 0x4090  GSM Error */
00186     phnErrLowerLayer,               /**< 0x4091  GSM Error */
00187     phnErrCPError,                  /**< 0x4092  GSM Error */
00188     phnErrCommandInProgress,            /**< 0x4093  GSM Error */
00189     phnErrSATNotSupported,              /**< 0x4094  GSM Error */
00190     phnErrSATNoInd,                 /**< 0x4095  GSM Error */
00191     phnErrNeedResetModule,              /**< 0x4096  GSM Error */
00192     phnErrCOPSAbort,                /**< 0x4097  GSM Error */
00193
00194
00195     /** CSD CEER Errors */
00196     phnErrCSDUnassignedNumber,              /**< 0x4098  GSM Error */
00197     phnErrCSDNoRouteToDestination,          /**< 0x4099  GSM Error */
00198     phnErrCSDChannelUnacceptable,           /**< 0x409a  GSM Error */
00199     phnErrCSDOperatorBarring,               /**< 0x409b  GSM Error */
00200     phnErrCSDNumberBusy,                    /**< 0x409c  GSM Error */
00201     phnErrCSDNoUserResponse,                /**< 0x409d  GSM Error */
00202     phnErrCSDNoAnswer,                      /**< 0x409e  GSM Error */
00203     phnErrCSDCallRejected,                  /**< 0x409f  GSM Error */
00204     phnErrCSDNumberChanged,                 /**< 0x40a0  GSM Error */
00205     phnErrCSDDestinationOutOfOrder,         /**< 0x40a1  GSM Error */
00206     phnErrCSDInvalidNumberFormat,           /**< 0x40a2  GSM Error */
00207     phnErrCSDFacilityRejected,              /**< 0x40a3  GSM Error */
00208     phnErrCSDNoCircuitAvailable,            /**< 0x40a4  GSM Error */
00209     phnErrCSDNetworkOutOfOrder,             /**< 0x40a5  GSM Error */
00210     phnErrCSDTempFailure,                   /**< 0x40a6  GSM Error */
00211     phnErrCSDSwitchingCongestion,           /**< 0x40a7  GSM Error */
00212     phnErrCSDAccessInfoDiscarded,           /**< 0x40a8  GSM Error */
00213     phnErrCSDReqCircuitNotAvailable,        /**< 0x40a9  GSM Error */
00214     phnErrCSDResourceNotAvailable,          /**< 0x40aa  GSM Error */
00215     phnErrCSDQOSNotAvailable,               /**< 0x40ab  GSM Error */
00216     phnErrCSDFacilityNotSubscribed,         /**< 0x40ac  GSM Error */
00217     phnErrCSDIncomingCallsBarredCUG,        /**< 0x40ad  GSM Error */
00218     phnErrCSDBearerNotCapable,              /**< 0x40ae  GSM Error */
00219     phnErrCSDBearerNotAvailable,            /**< 0x40af  GSM Error */
00220     phnErrCSDServiceNotAvailble,            /**< 0x40b0  GSM Error */
00221     phnErrCSDBearerNotImplemented,          /**< 0x40b1  GSM Error */
00222     phnErrCSDACMOutOfRange,                 /**< 0x40b2  GSM Error */
00223     phnErrCSDFacilityNotImplemented,        /**< 0x40b3  GSM Error */
00224     phnErrCSDRestrictedBearer,              /**< 0x40b4  GSM Error */
00225     phnErrCSDServiceNotImplented,           /**< 0x40b5  GSM Error */
00226     phnErrCSDInvalidTransID,                /**< 0x40b6  GSM Error */
00227     phnErrCSDUserNotMemberCUG,              /**< 0x40b7  GSM Error */
00228     phnErrCSDIncompatibleDestination,       /**< 0x40b8  GSM Error */
00229     phnErrCSDInvalidTransitNetwork,         /**< 0x40b9  GSM Error */
00230     phnErrCSDSemanticallyIncorrectMessage,      /**< 0x40ba  GSM Error */
00231     phnErrCSDInvalidMandatoryInfo,          /**< 0x40bb  GSM Error */
00232     phnErrCSDMessageTypeNotImplemented,     /**< 0x40bc  GSM Error */
00233     phnErrCSDMessageTypeNotCompatible,      /**< 0x40bd  GSM Error */
00234     phnErrCSDInfoNotImplemented,            /**< 0x40be  GSM Error */
00235     phnErrCSDIEError,                       /**< 0x40bf  GSM Error */
00236     phnErrCSDMessageNotCompatible,          /**< 0x40c0  GSM Error */
00237     phnErrCSDRecoveryOnTimerExpiry,         /**< 0x40c1  GSM Error */
00238     phnErrCSDProtocolError,                 /**< 0x40c2  GSM Error */
00239     /** GPRS CEER Errors */
00240     phnErrGPRSRoamingNotAllowed,            /**< 0x40c3  GSM Error */
00241     phnErrGPRSNetworkRequestDetach,         /**< 0x40c4  GSM Error */
00242     phnErrGPRSNoService,                    /**< 0x40c5  GSM Error */
00243     phnErrGPRSNoAccess,                     /**< 0x40c6  GSM Error */
00244     phnErrGPRSServiceRefused,               /**< 0x40c7  GSM Error */
00245     phnErrGPRSNetworkRequestPDPDeactivate,      /**< 0x40c8  GSM Error */
00246     phnErrGPRSPDPDactivateLCCLinkActivation,    /**< 0x40c9  GSM Error */
00247     phnErrGPRSPDPDeactivateNwkRactivate,        /**< 0x40ca  GSM Error */
00248     phnErrGPRSPDPDactivateGMMAbort,             /**< 0x40cb  GSM Error */
00249     phnErrGPRSPDPDeactivateSNDCPFailure,        /**< 0x40cc  GSM Error */
00250     phnErrGPRSPDPActivateFailGMMError,          /**< 0x40cd  GSM Error */
00251     phnErrGPRSPDPActivateFailNetReject,         /**< 0x40ce  GSM Error */
00252     phnErrGPRSPDPActivateFailNoNSAPI,           /**< 0x40cf  GSM Error */
00253     phnErrGPRSPDPActivateFailSMRefuse,          /**< 0x40d0  GSM Error */
00254     /** MORE CSD Errors */
00255     phnErrCSDFDNError,                          /**< 0x40d1  GSM Error */
00256     phnErrCSDCallOperationNotAllowed,           /**< 0x40d2  GSM Error */
00257     phnErrCSDCallBarringOutgoing,               /**< 0x40d3  GSM Error */
00258     phnErrCSDCallBarringIncoming,               /**< 0x40d4  GSM Error */
00259     phnErrCSDCallImpossible,                    /**< 0x40d5  GSM Error */
00260     phnErrCSDLowerLayerFailure,                 /**< 0x40d6  GSM Error */
00261     /** More GPRS Errors */
00262     phnErrGPRSAPNMissing,                       /**< 0x40d7  GSM Error */
00263     /** More Errors */
00264     phnErrNoCarrier,                            /**< 0x40d8  GSM Error */
00265     phnErrSMSFDNError,              /**< 0x40d9  GSM Error : SMS Fixed Dialing error (CMS ERROR: 531) */
00266     phnErrNullParam,                    /**< 0x40da GSM Error : provided parameter is unexpectedly null */
00267     phnErrBadServiceCode,                   /**< 0x40db GSM Error : intermediate response has unexpected service code */
00268     phnErrBadATResult,                  /**< 0x40dc GSM Error : AT response from radio is missing or invalid */
00269     phnErrBadATCmd,                     /**< 0x40dd GSM Error : AT cmd to radio is missing or invalid */
00270     phnErrSIMDataDownload,              /**< 0x40de GSM Error : SIM Data Download error (CMS ERROR: 213) */
00271
00272     /**
00273      *  0x40df to 0x40FF are reserves for GSM errors in the original Treo's
00274      *  Phone Library
00275      */
00276
00277
00278
00279     /**
00280          *  IMPORTANT: the last valid error code for this error class is 0x40FF.
00281      *  If you exceed this range, you will collide with the next error class
00282      *  that belongs to PalmSource, and will have all kinds of conflicts, such
00283      *  as wrong error strings and wrong interpretation of errors by
00284      *  applications.
00285      */
00286
00287
00288     // Add new error codes before this one
00289     phnErrLAST_1
00290   };

enum PHNErrorCodeRange_2

NOTE: The last error code allowed in Phone library error class #1 is 0x40FF. We reserve a second error base to allow for more error codes below. hsPhoneLibErrorClass_2 is 0x7300.

Enumerator:
phnErrorClass_2
phnErrSaveNV | 0x7301 CDMA Error : Fail to save params to Modem's NV.
phnErrReadNV | 0x7302 CDMA Error : Fail to read params from Modem's NV.
phnErrFiller4 | 0x7303 Filler -- you can use this error but dont remove.
phnErrFiller5 | 0x7304 Filler -- you can use this error but dont remove.
phnErrDuplicatePlaceHoldler | 0x7305 *************************************************
phnErrFiller6 | 0x7306 Filler -- you can use this error but dont remove.
phnErrBatteryLowAlert | 0x7307 CDMA Error : Phone battery is under the first low alert level.
phnErrBatteryCharging | 0x7308 CDMA Error : Phone battery is being charged.
phnErrBadCRC | 0x7309 CDMA Error : bad CRC observed
phnErrNoAppRegistered | 0x730a CDMA Error : Need to have at least an app to register for the corresponding service.
phnErrSndDelClass | SOUND Management Errors 0x730b CDMA Error : Should never send this value!!!
phnErrSndDelInvalidRingerID | 0x730c CDMA Error : The ringer index is not a valid ringer ID index
phnErrSndDelUnusedRingerID | 0x730d CDMA Error : The ringer index does not contain an active ringer idx to delete
phnErrSndDelUndeletableRingerID | 0x730e CDMA Error : The ringer index is a perminent ringer index
phnErrSndDelInternalMdmError | 0x730f CDMA Error : An internal modem error occurred when attempting to delete the file.
phnErrSndSaveClass | 0x7310 CDMA Error : Should never send this value!!!
phnErrSndSaveFileNameInvalid | 0x7311 CDMA Error : The null terminated string was not found as the file name.
phnErrSndSaveBadDataLen | 0x7312 CDMA Error : The file data length and/or the block data length is invalid.
phnErrSndSaveBadRingerID | 0x7313 CDMA Error : The ringer index specified is invalid (not a write-able index or out of range)
phnErrSndSaveBadSoundType | 0x7314 CDMA Error : The file type is invalid or not currently supported
phnErrSndSaveOutOfMem | 0x7315 CDMA Error : First block of file could not be written due to limited memory
phnErrSndSaveInternalModem | 0x7316 CDMA Error : An internal modem error occurred when attempting to download this block of the file (file is discarded).
phnErrSndSaveBadRsp | 0x7317 CDMA Error : Modem thinks that the file is downloaded completely, but the host still has not sent all or vice versa.
phnErrSndSaveContClass | 0x7318 CDMA Error : Should never use this value
phnErrSndSaveContBadDataLen | 0x7319 CDMA Error : The block data length of the file data in this block is invalid.
phnErrSndSaveContSeqNum | 0x731a CDMA Error : The sequence number is not in series with previous file download command.
phnErrSndSaveContOutOfMem | 0x731b CDMA Error : Next block of file could not be written due to limited memory.
phnErrSndSaveContInternalModem | 0x731c CDMA Error : An internal modem error occurred when attempting to download this block of the file.
phnErrModemBusy | 0x731d
phnErrModemOffline | 0x731e
phnErrIOTACommitFailed | IOTA errors 0x731f CDMA Error : IOTA commit failed
phnErrIOTACommitInProgress | 0x7320 CDMA Error : IOTA commit is in progress
phnErrIS683ProtRevNotSupported | 0x7321 CDMA Error : The IOTA protocol revision is not supported
phnErrInvalidNAM | 0x7322 CDMA Error : The NAM selected is invalid
phnErrNAMMismatched | 0x7323 CDMA Error : The NAM selected is not the same as the NAM currently used in the current session
phnErrIOTASessionActive | 0x7324 CDMA Error : An IOTA session is active
phnErrIOTANoSession | 0x7325 CDMA Error : No IOTA session currently
phnErrNVUnInitialized | 0x7326 CDMA Error : Uninitialized NV item
phnErrNvBadItem | 0x7327 CDMA Error : Bad or restricted NV item
phnErrPoweringDown | 0x7328 Error: The radio is currently powering down and we can not do anything
phnErrDenied | 0x7329 Request denied
phnErrNotYetSupported | 0x732A Feature not yet supported
phnErrSMSMemoryFull | 0x732B No more memory to receive incoming SMS
phnErrSMSMemoryOK | 0x732C There is now enough memory to receive incoming SMS
phnErrCauseCode16 | 0x732D GSM04.08: Cause code 16
phnErrMissingCarKitDriver | 0x732E The wired car kit driver is missing
phnErrHCIMismatch
phnErrLAST_2

Definition at line 298 of file HsPhoneErrors.h.

00299   {
00300     phnErrorClass_2 = hsPhoneLibErrorClass_2,
00301
00302     // NOTE: phnErrSaveNV was assigned an incorrect value of 0x4150 on Treo300.
00303     // This placed it and all subsequent error codes in Phone Library into
00304     // the error class 0x4100.  We're not allowed to use the error class 0x4100
00305     // because it belongs to PalmSource.  Per approval of Arun Mathias, and
00306     // Kiran Prasad we're redefining these error codes to start at the error
00307     // base hsPhoneLibErrorClass_2, which belongs to Handspring.  According to Arun, the
00308     // error codes which were defined starting with 0x4150 were low-level
00309     // error codes that were only used internally.
00310     //
00311     phnErrSaveNV,           /**< 0x7301 CDMA Error : Fail to save params to Modem's NV. */
00312     phnErrReadNV,                       /**< 0x7302 CDMA Error : Fail to read params from Modem's NV. */
00313     phnErrFiller4,                      /**< 0x7303 Filler -- you can use this error but dont remove. */
00314     phnErrFiller5,                      /**< 0x7304 Filler -- you can use this error but dont remove. */
00315 //    phnErrCmdCannotBeActioned,        /**< was 0x4154 CDMA Error : Fail to send command to modem. */
00316 // ***** DUPLICATE *****
00317     phnErrDuplicatePlaceHoldler,    /**< 0x7305 ************************************************* */
00318     phnErrFiller6,                      /**< 0x7306 Filler -- you can use this error but dont remove. */
00319     phnErrBatteryLowAlert,          /**< 0x7307 CDMA Error : Phone battery is under the first low alert level. */
00320     phnErrBatteryCharging,              /**< 0x7308 CDMA Error : Phone battery is being charged. */
00321     phnErrBadCRC,           /**< 0x7309 CDMA Error : bad CRC observed */
00322     phnErrNoAppRegistered,              /**< 0x730a CDMA Error : Need to have at least an app to register for the corresponding service. */
00323
00324     /** SOUND Management Errors */
00325     phnErrSndDelClass,                  /**< 0x730b CDMA Error : Should never send this value!!! */
00326     phnErrSndDelInvalidRingerID,        /**< 0x730c CDMA Error : The ringer index is not a valid ringer ID index */
00327     phnErrSndDelUnusedRingerID,         /**< 0x730d CDMA Error : The ringer index does not contain an active ringer idx to delete */
00328     phnErrSndDelUndeletableRingerID,    /**< 0x730e CDMA Error : The ringer index is a perminent ringer index */
00329     phnErrSndDelInternalMdmError,       /**< 0x730f CDMA Error : An internal modem error occurred when attempting to delete the file. */
00330     phnErrSndSaveClass,                 /**< 0x7310 CDMA Error : Should never send this value!!! */
00331     phnErrSndSaveFileNameInvalid,       /**< 0x7311 CDMA Error : The null terminated string was not found as the file name. */
00332     phnErrSndSaveBadDataLen,            /**< 0x7312 CDMA Error : The file data length and/or the block data length is invalid. */
00333     phnErrSndSaveBadRingerID,           /**< 0x7313 CDMA Error : The ringer index specified is invalid (not a write-able index or out of range) */
00334     phnErrSndSaveBadSoundType,          /**< 0x7314 CDMA Error : The file type is invalid or not currently supported */
00335     phnErrSndSaveOutOfMem,              /**< 0x7315 CDMA Error : First block of file could not be written due to limited memory */
00336     phnErrSndSaveInternalModem,         /**< 0x7316 CDMA Error : An internal modem error occurred when attempting to download this */
00337                                         /**< block of the file (file is discarded). */
00338     phnErrSndSaveBadRsp,                /**< 0x7317 CDMA Error : Modem thinks that the file is downloaded completely, but the host still */
00339                                         /**< has not sent all or vice versa. */
00340     phnErrSndSaveContClass,             /**< 0x7318 CDMA Error : Should never use this value */
00341     phnErrSndSaveContBadDataLen,        /**< 0x7319 CDMA Error : The block data length of the file data in this block is invalid. */
00342     phnErrSndSaveContSeqNum,            /**< 0x731a CDMA Error : The sequence number is not in series with previous file download command. */
00343     phnErrSndSaveContOutOfMem,          /**< 0x731b CDMA Error : Next block of file could not be written due to limited memory. */
00344     phnErrSndSaveContInternalModem,     /**< 0x731c CDMA Error : An internal modem error occurred when attempting to download this block of the file. */
00345
00346     phnErrModemBusy,            /**< 0x731d */
00347     phnErrModemOffline,         /**< 0x731e */
00348     /** IOTA errors */
00349     phnErrIOTACommitFailed,             /**< 0x731f CDMA Error : IOTA commit failed */
00350     phnErrIOTACommitInProgress,         /**< 0x7320 CDMA Error : IOTA commit is in progress */
00351     phnErrIS683ProtRevNotSupported,     /**< 0x7321 CDMA Error : The IOTA protocol revision is not supported */
00352     phnErrInvalidNAM,                   /**< 0x7322 CDMA Error : The NAM selected is invalid */
00353     phnErrNAMMismatched,                /**< 0x7323 CDMA Error : The NAM selected is not the same as the NAM currently used in the current session */
00354     phnErrIOTASessionActive,            /**< 0x7324 CDMA Error : An IOTA session is active */
00355     phnErrIOTANoSession,                /**< 0x7325 CDMA Error : No IOTA session currently */
00356     phnErrNVUnInitialized,      /**< 0x7326 CDMA Error : Uninitialized NV item */
00357     phnErrNvBadItem,        /**< 0x7327 CDMA Error : Bad or restricted NV item */
00358
00359
00360     phnErrPoweringDown,     /**< 0x7328 Error: The radio is currently */
00361                 /**< powering down and we can not do anything */
00362     phnErrDenied,           /**< 0x7329 Request denied */
00363     phnErrNotYetSupported,          /**< 0x732A Feature not yet supported */
00364     phnErrSMSMemoryFull,        /**< 0x732B No more memory to receive incoming SMS */
00365     phnErrSMSMemoryOK,      /**< 0x732C There is now enough memory to receive incoming SMS */
00366     phnErrCauseCode16,      /**< 0x732D GSM04.08: Cause code 16 */
00367     phnErrMissingCarKitDriver, /**< 0x732E The wired car kit driver is missing */
00368
00369     phnErrHCIMismatch,
00370     // Add new error codes before this one
00371     phnErrLAST_2
00372   };

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:07:15 2008 for Palm API Guide


Header Files » Incs » common » libraries » telephony

HsPhoneEvent.h File Reference

Detailed Description

Header file for the phone library (CDMA or GSM).

NOTES: Header file for the phone library (CDMA or GSM)

This file defines the Notification Events between the Phone Library (either GSM or CDMA) and applications. These events allow applications to react to changes of state in the Phone Library.

Applications wishing to receive notification events from the Phone Library must register using the PhnLibRegister call. The services parameter to PhnLibRegister is a bitmap identifying the classes of events that are of interest. To unregister for notifications the app can call PhnLibRegister with the services parameter set to zero.

Notifications are sent to applications based on their unique creatorID. Confusion may occur if multiple versions of a single app exist with the same creatorID. In this case notifications will be sent to the latest version of the app (even if this app was not the one that registered). In general, you should try to avoid this situation where possible.

Each notification event is identified by a unique event code (see PhnEventCode). The event code then determines the contents of the remainder of the event.

There are three styles of notifications from the Phone Library:

(1) universal broadcast notifications are sent to all registrants for a given service. (for example, a change in the network registration status)

(2) exclusive broadcast notifications are sent to registrations one at a time. The first app that acknowledges the notification by setting the acknowedge flag will be presumed to own that notification. Only this app should handle and respond to the notification. For example, an incoming call or incoming SMS message will be acknowleged by an app that wants to answer the call or process the SMS message.

(3) direct notifications are sent directly to a specific app with a known interest in some occurence in the phone library. These are typically used after an application has taken ownership of a particular call, message, or dialog. By sending notifications directly to the owning app we avoid confusion with multiple apps sending competing instructions.

Definition in file HsPhoneEvent.h.

Include dependency graph for HsPhoneEvent.h:

Go to the source code of this file.

Data Structures

  • struct PhnDisconnectEventType
  • struct PhnSubscriberAddrInfo
  • struct PhnConferenceDesc
  • struct PhnError
  • struct PhnSMSParams
  • struct PhnKeyPressedParams
  • struct PhnRegistrationType
  • struct PhnPowerEventType
  • struct PhnIndicationType
  • struct PhnPasswordEventType
  • struct PhnProgressEventType
  • struct PhnMovedMsgDescType
  • struct PhnMovedMsgsParamsType
  • struct PhnUSSDEventType
  • struct PhnSATEventType
  • struct PhnSATEventDisplayText
  • struct PhnSATEventGetInkey
  • struct PhnSATEventHeader
  • struct PhnSATEventGetInput
  • struct PhnSATEventSetupCall
  • struct PhnSATEventPlayTone
  • struct PhnSATEventMenuRec
  • struct PhnSATEventMenu
  • struct PhnSATEventSendSMS
  • struct PhnSATEventRefresh
  • struct PhnSATEventLaunchBrowser
  • struct PhnSATEventIdleModeText
  • struct PhnSATEventRunAT
  • struct PhnSATEventDataSvc
  • struct PhnSATEventSendDTMF
  • struct PhnPhoneEquipmentMode
  • struct PhnMiscDbgRptType
  • struct PhnOnexMipRRQType
  • struct WUNotificationEventType
  • struct UPNotificationEventType
  • struct WAPNotificationEventType
  • struct PhnEventType
  • union PhnEventType::Data

Defines

  • #define phnAddressDigitsMax 32
  • #define phnUserDataMax 255
  • #define phnNotifySubscriber 'CLIP'
  • #define phnNotifyEquipMode 'Heqp'
  • #define phnLibLaunchCmdEvent 0xabad
  • #define phnLibLaunchCmdRegister 0xabae
  • #define isValidPhnIndicationKind(i) ((i >= indicationSIMReady) && (i <= indicationSIMChanged))
  • #define isValidPhnEventCode(e) ((e >= phnEvtCardInsertion) && (e < kMaxPhnEvtSupported))
  • #define PhnSMSParamsVersion 2
  • #define isValidPhnModuleButtonType(m) (m < phnButtonLast)
  • #define isValidPhnProgressType(p) (p <= kShowSegment)
  • #define isValidPhnOpenDialogType(o) (o <= kDialogSendUSSD)
  • #define isValidPhnMiscDbgUpdateKind(x) ((x >= eDbgUpdateNone) && (x <= eDbgUpdateQuit))
  • #define isValidPhnMsgIDType(m) ((m >= kMsgIdReserved) && (m <= kMsgIdUserAck))
  • #define isValidPhnDataChannelType(x) ((x == phnDataAvailable) || (x == phnDataNotAvailable))
  • #define WAPNotificationTypeVersion 3
  • #define PhnEventRecord PhnEventType
Palm Notifications
  • #define NAITextLength 72
  • #define NAITextSize (NAITextLength + 1)
  • #define PasswordLength 16
  • #define PasswordSize (PasswordLength + 1)
WAP defines
Text Header elements

  • #define phnWAPEvent 'Hwap'
  • #define WAPMsgLength 160
  • #define WAPMsgSize (WAPMsgLength + 1)
WakeUp notification
  • #define WUHeaderEscapeSeq "//"
  • #define WUTextHeader "//WU"
  • #define WUTextHeaderLength 4
  • #define WUFieldDelimiter ';'
  • #define phnWUEvent 'Hwak'
UP stuff
Text Header elements

  • #define UPHeaderEscapeSeq "//"
  • #define UPTextHeader "//UP"
  • #define UPTextHeaderLength 4
  • #define phnUPEvent 'Hsup'
  • #define UPDataSize 160

Typedefs

  • typedef UInt8 PhnSMSType
  • typedef UInt8 PhnSMSClass
  • typedef Err(*) ContinuePowerOnOffCallback (UInt16 refNum)
  • typedef char PhnPassword [maxPasswordLen+2]
  • typedef PhnSATEventHeader PhnSATEventHeader
  • typedef struct PhnOnexMipRRQType * PhnOnexMipRRQPtr
  • typedef WUNotificationEventType WUNotificationEventType
  • typedef UPNotificationEventType UPNotificationEventType
  • typedef UInt8 PhnWAPPushContent
  • typedef UInt16 PhnWAPPushAppId
  • typedef WAPNotificationEventType WAPNotificationEventType
  • typedef struct PhnEventType * PhnEventPtr

Enumerations

  • enum PhnIndicationKind {
    indicationSIMReady,
    indicationSIMMessages,
    indicationNetworkSearch,
    indicationPasswordAccepted,
    indicationNetworkAvailable,
    indicationStartingRadio,
    indicationPoweringOffRadio,
    indicationResettingRadio,
    indicationAuthFailure,
    indicationSIMChanged,
    indicationInitComplete,
    indicationOtaspMsg
    }
  • enum PhnEventCode {
    phnEvtCardInsertion,
    phnEvtRegistration,
    phnEvtError,
    phnEvtKeyPress,
    phnEvtPower,
    phnEvtPassword,
    phnEvtProgress,
    phnEvtIndication,
    phnEvtConnectInd,
    phnEvtConnectConf,
    phnEvtSubscriber,
    phnEvtDisconnectInd,
    phnEvtDisconnectConf,
    phnEvtBusy,
    phnEvtUpdate,
    phnEvtConference,
    phnEvtVoiceMail,
    phnEvtMessageInd,
    phnEvtSegmentInd,
    phnEvtMessageStat,
    phnEvtMessageDel,
    phnEvtMessageMoved,
    phnEvtSATNotification,
    phnEvtUSSDInd,
    phnEvtPhoneEquipmentMode,
    phnEvtGPRSRegistration,
    phnEvtMMSInd,
    phnEvtMemoryFull,
    phnEvtMemoryOK,
    phnEvtWAPInd,
    phnEvtDebugReport,
    phnEvtSSModeChanged,
    phnEvtPDDataChanged,
    phnEvtOneXStatus,
    phnEvtMIPFailed,
    phnEvtIOTAStatus,
    phnEvtDataChannel,
    phnEvtOneXMipRRQInd,
    phnEvtOneXDataFail,
    phnEvtStartDial,
    phnEvtStartIncomingCall,
    phnEvtAlertingPreConnected,
    phnEvtAlerting,
    phnEvtPreConnected,
    phnEvtDataSessionStatus,
    phnEvtDataSessionDisconnected,
    phnEvtNetworkTime,
    kMaxPhnEvtSupported
    }
  • enum PhnSMSTypeEnum {
    defaultType = 0,
    discardType0 = 0x40,
    replaceType1 = 0x41,
    replaceType2 = 0x42,
    replaceType3 = 0x43,
    replaceType4 = 0x44,
    replaceType5 = 0x45,
    replaceType6 = 0x46,
    replaceType7 = 0x47
    }
  • enum PhnSMSClassEnum {
    classUnknown = 0,
    class0,
    class1,
    class2,
    class3
    }
  • enum PhnModuleButtonType {
    phnButtonHeadset,
    phnButtonRedial,
    phnButtonAnswerCall,
    phnButtonRejectCall,
    phnButtonIgnoreCall,
    phnButtonHoldCall,
    phnButtonConferenceCall,
    phnButtonLast
    }
  • enum PhnProgressType {
    kOpenDialog,
    kCloseDialog,
    kSetText,
    kSetRecipient,
    kShowSegment
    }
  • enum PhnOpenDialogType {
    kDialogSetBarring,
    kDialogGetBarring,
    kDialogSetForwarding,
    kDialogGetForwarding,
    kDialogSetCallWaiting,
    kDialogGetCallWaiting,
    kDialogGetOperatorList,
    kDialogSetOperator,
    kDialogOperatorSelection,
    kDialogImmediateSend,
    kDialogDeferredSend,
    kDialogSendUSSD
    }
  • enum PhnMiscDbgUpdateKind {
    eDbgUpdateNone,
    eDbgUpdateYes,
    eDbgUpdateQuit
    }
  • enum PhnMsgIDType {
    kMsgIdReserved,
    kMsgIdDeliverMT,
    kMsgIdSubmitMO,
    kMsgIdcancelMO,
    kMsgIdDeliveryMTAck,
    kMsgIdUserAck
    }
  • enum PhnDataChannelType {
    phnDataAvailable,
    phnDataNotAvailable
    }
  • enum PhnWAPPushContentType {
    kWAPContentTypeUnknown = 0,
    kWAPContentTypeIOTA,
    kWAPContentTypeMMS,
    kWAPContentTypeMMSText,
    kWAPContentTypeServiceLoad,
    kWAPContentTypeServiceLoadText,
    kWAPContentTypeServiceIndicator,
    kWAPContentTypeServiceIndicatorText
    }
  • enum PhnWAPPushAppIdType {
    kWAPAnyApp = 0x00,
    kWAPPushSIA = 0x01,
    kWAPWmlUa = 0x02,
    kWAPWtaUa = 0x03,
    kWAPMmsUa = 0x04,
    kWAPPushSyncml = 0x05,
    kWAPLocUa = 0x06,
    kWAPSyncmlDm = 0x07,
    kWAPDrmUa = 0x08,
    kWAPEmnUa = 0x09,
    kWAPWvUa = 0x0A,
    kWAPMsLocalcontentUa = 0x8000,
    kWAPMsIMclientUa = 0x8001,
    kWAPdocomoImodeMailUa = 0x8002,
    kWAPdocomoImodeMrUa = 0x8003,
    kWAPdocomoImodeMfUa = 0x8004,
    kWAPMotorolaLocationUa = 0x8005,
    kWAPMotorolaNowUa = 0x8006,
    kWAPMotorolaOtaprovUa = 0x8007,
    kWAPMotorolaBrowserUa = 0x8008,
    kWAPMotorolaSplashUa = 0x8009,
    kWAPUnused = 0x800A,
    kWAPNaiMvswCommand = 0x800B,
    kWAPopenwaveIotaUa = 0x8010
    }

Define Documentation

#define isValidPhnDataChannelType ( x ) ((x == phnDataAvailable) || (x == phnDataNotAvailable))

Definition at line 1215 of file HsPhoneEvent.h.

#define isValidPhnEventCode ( e ) ((e >= phnEvtCardInsertion) && (e < kMaxPhnEvtSupported))

Definition at line 632 of file HsPhoneEvent.h.

#define isValidPhnIndicationKind ( i ) ((i >= indicationSIMReady) && (i <= indicationSIMChanged))

Definition at line 110 of file HsPhoneEvent.h.

#define isValidPhnMiscDbgUpdateKind ( x ) ((x >= eDbgUpdateNone) && (x <= eDbgUpdateQuit))

Definition at line 1176 of file HsPhoneEvent.h.

#define isValidPhnModuleButtonType ( m ) (m < phnButtonLast)

Definition at line 791 of file HsPhoneEvent.h.

#define isValidPhnMsgIDType ( m ) ((m >= kMsgIdReserved) && (m <= kMsgIdUserAck))

Definition at line 1202 of file HsPhoneEvent.h.

#define isValidPhnOpenDialogType ( o ) (o <= kDialogSendUSSD)

Definition at line 911 of file HsPhoneEvent.h.

#define isValidPhnProgressType ( p ) (p <= kShowSegment)

Definition at line 890 of file HsPhoneEvent.h.

#define NAITextLength 72

Definition at line 1236 of file HsPhoneEvent.h.

#define NAITextSize (NAITextLength + 1)

Definition at line 1237 of file HsPhoneEvent.h.

#define PasswordLength 16

Definition at line 1238 of file HsPhoneEvent.h.

#define PasswordSize (PasswordLength + 1)

Definition at line 1239 of file HsPhoneEvent.h.

#define phnAddressDigitsMax 32

Definition at line 75 of file HsPhoneEvent.h.

#define PhnEventRecord PhnEventType

Definition at line 1483 of file HsPhoneEvent.h.

#define phnLibLaunchCmdEvent 0xabad

Phone Event notification. Used to be 0x2bad, which is less than Palm's custom base. Have to get Palm to allow that.

Definition at line 83 of file HsPhoneEvent.h.

#define phnLibLaunchCmdRegister 0xabae

Sent to application to register with GSM library

Definition at line 88 of file HsPhoneEvent.h.

#define phnNotifyEquipMode 'Heqp'

GSM notificaiton for equip mode change

Definition at line 80 of file HsPhoneEvent.h.

#define phnNotifySubscriber 'CLIP'

GSM notification with caller ID

Definition at line 79 of file HsPhoneEvent.h.

#define PhnSMSParamsVersion 2

Definition at line 773 of file HsPhoneEvent.h.

#define phnUPEvent 'Hsup'

Definition at line 1277 of file HsPhoneEvent.h.

#define phnUserDataMax 255

Definition at line 76 of file HsPhoneEvent.h.

#define phnWAPEvent 'Hwap'

Definition at line 1248 of file HsPhoneEvent.h.

#define phnWUEvent 'Hwak'

Definition at line 1265 of file HsPhoneEvent.h.

#define UPDataSize 160

maximum size of the data sent from this message

Definition at line 1279 of file HsPhoneEvent.h.

#define UPHeaderEscapeSeq "//"

start sequence of the header

Definition at line 1273 of file HsPhoneEvent.h.

#define UPTextHeader "//UP"

beginning of an UP header

Definition at line 1274 of file HsPhoneEvent.h.

#define UPTextHeaderLength 4

length of the header

Definition at line 1275 of file HsPhoneEvent.h.

#define WAPMsgLength 160

Definition at line 1250 of file HsPhoneEvent.h.

#define WAPMsgSize (WAPMsgLength + 1)

Definition at line 1251 of file HsPhoneEvent.h.

#define WAPNotificationTypeVersion 3

Structure passed to the callbacks registered for WAP notifications

Definition at line 1414 of file HsPhoneEvent.h.

#define WUFieldDelimiter ';'

wakeup message fields are separated by a semi-colon

Definition at line 1263 of file HsPhoneEvent.h.

#define WUHeaderEscapeSeq "//"

start sequence of the header

Definition at line 1259 of file HsPhoneEvent.h.

#define WUTextHeader "//WU"

beginning of an wakeup header

Definition at line 1260 of file HsPhoneEvent.h.

#define WUTextHeaderLength 4

length of the header

Definition at line 1261 of file HsPhoneEvent.h.

Typedef Documentation

typedef Err(* ) ContinuePowerOnOffCallback(UInt16 refNum)

Definition at line 821 of file HsPhoneEvent.h.

typedef struct PhnEventType * PhnEventPtr

typedef struct PhnOnexMipRRQType * PhnOnexMipRRQPtr

typedef char PhnPassword[maxPasswordLen+2]

Definition at line 865 of file HsPhoneEvent.h.

typedef struct PhnSATEventHeader PhnSATEventHeader

Definition at line 987 of file HsPhoneEvent.h.

typedef UInt8 PhnSMSClass

SMS Class types

Definition at line 706 of file HsPhoneEvent.h.

typedef UInt8 PhnSMSType

SMS Replacement types

Definition at line 688 of file HsPhoneEvent.h.

typedef UInt16 PhnWAPPushAppId

Definition at line 1409 of file HsPhoneEvent.h.

typedef UInt8 PhnWAPPushContent

Definition at line 1372 of file HsPhoneEvent.h.

typedef struct UPNotificationEventType UPNotificationEventType

Definition at line 1352 of file HsPhoneEvent.h.

typedef struct WAPNotificationEventType WAPNotificationEventType

Definition at line 1434 of file HsPhoneEvent.h.

typedef struct WUNotificationEventType WUNotificationEventType

Definition at line 1318 of file HsPhoneEvent.h.

Enumeration Type Documentation

enum PhnDataChannelType

Enumerator:
phnDataAvailable
phnDataNotAvailable Used by apps that need to know when they can use the data channel

Definition at line 1208 of file HsPhoneEvent.h.

01209   {
01210     phnDataAvailable,       /**<        */
01211     phnDataNotAvailable     /**< Used by apps that need to know when they can use the data channel */
01212   }

enum PhnEventCode

PhnEventCode is unique identifier for notifications between the Phone Library and applications. It is used in the eventType field in the header of notification events (PhnEventType).

Enumerator:
phnEvtCardInsertion | 0x0000 < NOT USED. OBSOLETE
phnEvtRegistration Network Registration has changed.

The Phone Library is responsible for registering the device to the carrier network, including handling roaming and losses of service. This notification occurs when the network registration state has changed. See PhnRegistrationStatus for possible state values.

This notification will be universally broadcast to applications registered for any service. 0x0001 < Phone able to find service

phnEvtError Error detected

This notification occurs on various error scenarios in the Phone Library. These may occur when unexpected errors are reported from the radio, or when an operation in progress has failed.

This notification is universally broadcast to applications in the service area where the error was detected (e.g. Voice, SMS, ...). 0x0002 < indicator of something important happens to the phone that needs to bring up alert

phnEvtKeyPress phone-related keypress has occured on device

This notification occurs when the user presses a phone-related key on the device. Currently the only supported key is the headset button that can be used for basic call control. In general, buttons available will be device dependent.

This notification is exclusively broadcast to all applications registered for the Voice Service. 0x0003 < Headset button pressed.

phnEvtPower change in power state of radio

This notification occurs when the power state of the radio is changing. Applications may want to change their state, and take action based on the expected availability of the radio.

This notification is universally broadcast to all registered applications. 0x0004

phnEvtPassword Password Dialog Control

This notification helps an application control the entry of a PIN on a device that is locked.

This notification is exclusively broadcast to all registered applications. Application that acknowledges the notification is presumed to own handling the password situation. 0x0005

phnEvtProgress outgoing call progress dialog

This notification is sent to help applications display the progress of an oubound call operation.

This notification is exclusively broadcast to all registered applications. Application that acknowledges the notification is presumed to be the only one to take any action on the outgoing call. 0x0006

phnEvtIndication indication of various changes of state in Phone Library

This notification is sent on various changes of state in the Phone Library. Most of these are related to activation and registration with the carrier network. Applications that display gauges with state info will often need to be updated after this notification.

Indications are often used to direct GUI interactions in applications that interact with the user. For example, the Network Search notification might cause an app to put up a special Network Search dialog.

See PhnIndicationKind for list of available indications.

The broadcast rules for indications vary depending on the type of indication. 0x0007

phnEvtConnectInd incoming call received

This notification is exclusively broadcast to applications registered for the Voice Service. First application to acknowledge the notification will be presumed to control the call. Normally application would answer the call, or forward it to another destination. 0x0008

phnEvtConnectConf call has connected

Despite the name, this event is used BOTH when a call goes into connected state (e.g. is answered), and when a call joins a conference.

This notification is exclusively broadcast to applications registered for the Voice Service. First application to acknowledge the notification will be presumed to control the call or conference. 0x0009

phnEvtSubscriber Number/name of call has changed

This notification is universally broadcast to all applications registered for the Voice Service. 0x000A

phnEvtDisconnectInd call has disconnected

This notification occurs when the remote party of an active voice call disconnects. Note that if the call is in conference (or 3-way calling) mode, then a different phnEvtDisconnectConf notification will be sent instead (see below).

This notification is universally broadcast to all applications registered for the Voice or Data Services. 0x000B

phnEvtDisconnectConf call in conference (or 3-way calling) mode has disconnected

This notification occurs when a conference call is in progress, and one of the remote parties disconnects.

This notification is universally broadcast to all applications registered for the Voice Service. 0x000C An ACK for a disconnection command on a specific connection ID is received

phnEvtBusy Outbound call attempt failed because remote party (or network) reported busy

This notification is universally broadcast to all applications registered for the Voice Service. 0x000D

phnEvtUpdate Change in Call Status; Application may need to update its state

This notification is sent on various changes in call state in the Phone Library. An application receiving this notification should poll for the connection status of any calls of interest, and update its own state as needed.

This notification is universally broadcast to all applications registered for the Voice Service. 0x000E

phnEvtConference 3-way call mode

This notification occurs when a call goes into conferrence (or 3-way calling) mode.

This notification is universally broadcast to all applications registered for the Voice Service. 0x000F

phnEvtVoiceMail Incoming VoiceMail Message

This notification occurs when the Phone Library detects that there are pending VoiceMail messages available.

This notification is universally broadcast to all applications registered for the Voice Service. 0x0010

phnEvtMessageInd Incoming SMS message received

This notification occurs when the Phone Library receives an incoming SMS (Simple Message Service) message.

This notification will be exclusively broadcast to applications registered for the SMS service. The Application that acknowledges the notification is assumed to own the message, and should take any appropriate actions. 0x0011

phnEvtSegmentInd Incoming segment of SMS Message received

This notification occurs when the Phone Library receives a segment of a multi-segment SMS (Simple Message Service) message. Single segment SMS messages will generate a MessageInd notification (see above).

This notification will be exclusively broadcast to applications registered for the SMS service. The Application that acknowledges the notification is assumed to own the segment, and should take any appropriate actions. 0x0012

phnEvtMessageStat Status of outgoing SMS message has changed

This notification occurs when the status of a particular SMS message has changed. For example, an SMS message might move from the pending queue to the sent queue after being successfully delivered.

This notification will be sent directly to the application that created the message, and is NOT broadcast based on app registrations. 0x0013

phnEvtMessageDel SMS message deleted from local DB on device

This notification occurs when an SMS message is deleted from the local Database on the device.

This notification will be sent directly to the application that created the message, and is NOT broadcast based on app registrations. 0x0014

phnEvtMessageMoved SIM Contains SMS Messages

This notification indicates that the SIM (Subscriber Information Module) on a GSM phone contains SMS (Simple Messaging Service) messages. This is not an indication of new messages, just that messages are stored. This notification is typically sent during Phone Library activation. In many cases, the application may want to move the SMS messages to a local DB on the device, freeing memory for future incoming messages.

This notification will use exclusive broadcast to applications registered for the SMS service. The application that acknowledges the notification is responsible for taking any action on moving the SMS messages on the SIM (if desired). 0x0015

phnEvtSATNotification SIM Application Toolkit (SAT) event

The SIM Application Toolkit allows for simple applications that can be placed on the SIM (Subscriber Identity Module) in a GSM phone. This notification will be sent when a SAT application is requesting input/output to/from the user.

This notification will use exclusive broadcast to applications registered for the SIM Toolkit Service. The Application that first acknowedges the notification will be presumed to own the SAT session, and should handle needed user dialog as appropriate. 0x0016

phnEvtUSSDInd USSD input/output requested from network

USSD (Unstructured Supplementary Services Data) is a supplementary service to GSM networks that allows simple text dialogs with applications based in the network. This notification is sent when the network is requesting USSD input/output to/from the user. (see +CUSD event in radio documentation for more details)

This notification will use exclusive broadcast to applications registered for the Voice Service. The Application that first acknowledges the notification will be presumed to own the USSD session. Typically, that app will want to display any USSD message to the user, and handle any response from the user back to the network. 0x0017

phnEvtPhoneEquipmentMode Phone Equipment state has changed

On communicator devices there are pieces of equipment that directly impact how the radio is used. Examples of equipment include headset jacks, car kits, lids, etc. The equipment modes available will vary with the model of communicator being used. This notification will be sent when ever the Phone Library detects that an available equipment mode has changed. See the type PhnEquipmentMode for the available set of mode values.

This notification will be universally broadcast to all applications registered for any service. 0x0018

phnEvtGPRSRegistration GPRS Attach Registration has changed. (GSM/GPRS systems only)

GPRS (General Packet Radio Services) is an extension to the GSM wireless network that provides higher speed, always on data connections. The radio must attach to the GPRS network before any GPRS sessions can be established. This notification will be sent when ever the status of the GPRS attach registration changes. See type PhnRegistrationStatus for available registration states.

This notification will be universally broadcast to applications registered for any service. 0x0019

phnEvtMMSInd incoming MMS message available

This notification will be sent when the Phone Library receives an incoming MMS (Multi-media Message Service) message.

This notification will use exclusive broadcast to applications registered for the MMS service. Application that first acknowledges the notification will be presumed to own the message. Typically, that app will want to notify the user that there is a message available, and move the message into a system DB, freeing memory for future messages. 0x001A

phnEvtMemoryFull SMS Memory Full

This notification indicates that memory for SMS messages is currently full, and no new SMS messages can be received until some memory is freed. A phnEvtMemoryOK notification will be sent when memory becomes available.

CURRENTLY USED BY CDMA PHONE LIBRARY ONLY 0x001B

phnEvtMemoryOK SMS Memory no longer full

This notification indicates that memory for SMS messages is no longer full, and new SMS messages can be received.

CURRENTLY USED BY CDMA PHONE LIBRARY ONLY 0x001C - < Memory is not full anymore, can receive messages Description

phnEvtWAPInd WAP Message received via SMS (WAP in IS-637 standard)

NOT CURRENTLY USED (WAP notifications use standard Palm notifications) 0x001D

phnEvtDebugReport Radio Debug Info

Periodically sent from Phone Library to Activation App when in debug mode.

CURRENTLY USED BY CDMA PHONE LIBRARY ONLY 0x001E

phnEvtSSModeChanged System Selection mode has changed

Radio mode has changed (e.g. to PCS mode)

CURRENTLY USED BY CDMA PHONE LIBRARY ONLY 0x001F

phnEvtPDDataChanged Position Info has changed

indication of change in physical location of device. This may be determined by GPS, network triangulation (AFLT), or some other technique.

- rename this event & some of its data structures to be cleaner.

CURRENTLY USED BY CDMA PHONE LIBRARY ONLY 0x0020

phnEvtOneXStatus 1XRTT Status has changed

1XRTT is a high speed data protocol used in CDMA radios. This notification indicates that the status of the 1XRTT connection has changed.

CURRENTLY USED BY CDMA PHONE LIBRARY ONLY 0x0021

phnEvtMIPFailed Mobile IP connection failed

Mobile IP is a flavor of the TCP/IP protocol for use on mobile devices. It allows applications to use a single IP address while in motion. This notification occurs when a Mobile IP session fails to be established.

CURRENTLY USED BY CDMA PHONE LIBRARY ONLY 0x0022

phnEvtIOTAStatus IOTA Status has changed

Internet Over The Air (IOTA) is a protocol for a network to update the radio using an internet connection (as opposed to Over The Air (OTA)). This notification occurs as an IOTA session changes (e.g. is established, committed, ended, etc).

CURRENTLY GENERATED BY CDMA PHONE LIBRARY ONLY 0x0023

phnEvtDataChannel Data Channel availability has changed

This notification occurs if there is a change in the ability for an application to send/receive data using the radio. For example on Class B radios, data is not available when a voice call is in progress.

- this notification should be generated by GSM Phone Library too.

CURRENTLY GENERATED BY CDMA PHONE LIBRARY ONLY 0x0024

phnEvtOneXMipRRQInd Mobile IP Registration successful

Mobile IP is a flavor of the TCP/IP protocol for use on mobile devices. It allows applications to use a single IP address while in motion. This notification occurs when a Mobile IP session is successfully established. The notification phnEvtMIPFailed will occur if the session fails.

CURRENTLY GENERATED BY CDMA PHONE LIBRARY ONLY 0x0025

phnEvtOneXDataFail 1XRTT Session has failed (mid-session)

1XRTT is a high speed data protocol used in CDMA radios. This notification indicates that the 1XRTT session has failed, and is not available. Note that 1XRTT session may be left in Dormant state.

CURRENTLY GENERATED BY CDMA PHONE LIBRARY ONLY 0x0026

phnEvtStartDial Start Dialing of Outbound Call

This notification is sent when an outbound call begins dialing before the call is connected. This notification is universally broadcast to all applications registered for the Voice service. Notification uses same notification data as Connect indication. 0x0027

phnEvtStartIncomingCall Start of incoming call

This notification is sent when an incoming call if first detected. This notification is used to perform special pre-call processing like turning off of MMS playback before a call. Any processing on this notification must be very quick (less than a few hundred miliseconds) as it could potentially delay an incoming call from being answered.

APPLICATIONS MUST NOT ANSWER THE CALL OR DO ANY CALL CONTROL BASED ON THIS NOTIFICATION. A separate phnEvtConnectInd notification will be follow for this purpose. The phnEvtConnectInd notification is normally processed by the Phone App, and uses exclusive broadcast. Thus it may not be received by all applications. The phnEvtStartIncomingCall notification is sent to all applications registered for Voice Service using Universal Broadcast. The acknowledgement flag is NOT used. 0x0028

phnEvtAlertingPreConnected Alerting/Preconnected of Outbound Call

This notification is sent when an outbound call is alerting or preconnected. This notification is universally broadcast to all applications registered for the Voice service. Notification uses same notification data as Connect indication. 0x0029

phnEvtAlerting Alerting of Outbound Call (NOT USED, for future implementation)

NOT USED This notification is sent when an outbound call is alerting. This notification is universally broadcast to all applications registered for the Voice service. Notification uses same notification data as Connect indication. 0x002A

phnEvtPreConnected Preconnected of Outbound Call (NOT USED, for future implementation)

NOT USED This notification is sent when an outbound call is preconnected. This notification is universally broadcast to all applications registered for the Voice service. Notification uses same notification data as Connect indication. 0x002B

phnEvtDataSessionStatus | Data session status change This should replace the OneXStatus, as this will encompass more info than OneXStatus 0x002C
phnEvtDataSessionDisconnected | Data session disconnected This is sent up when the data call is disconnected. We can't use the phnEvtDisconnectInd because the structure uses the Err class. 0x002D
phnEvtNetworkTime | Returns the network time and DST obtained from network to date time panel 0x002E
kMaxPhnEvtSupported | Must be at last position

Definition at line 117 of file HsPhoneEvent.h.

00118   {
00119   phnEvtCardInsertion,      /**< 0x0000 < NOT USED.  OBSOLETE */
00120
00121   /** Network Registration has changed.
00122    *
00123    *  The Phone Library is responsible for registering the device to
00124    *  the carrier network, including handling roaming and losses of service.
00125    *  This notification occurs when the network registration state has changed.
00126    *  See PhnRegistrationStatus for possible state values.
00127    *
00128    *  This notification will be universally broadcast to applications
00129    * registered for any service.
00130    */
00131   phnEvtRegistration,       /**< 0x0001 < Phone able to find service  */
00132
00133   /** Error detected
00134    *
00135    *  This notification occurs on various error scenarios in the Phone Library.
00136    *  These may occur when unexpected errors are reported from the radio, or when
00137    *  an operation in progress has failed.
00138    *
00139    *  This notification is universally broadcast to applications in the
00140    *  service area where the error was detected (e.g. Voice, SMS, ...).
00141    */
00142   phnEvtError,              /**< 0x0002 < indicator of something important happens to the phone that needs to bring up alert */
00143
00144   /** phone-related keypress has occured on device
00145    *
00146    *  This notification occurs when the user presses a phone-related key on the device.
00147    *  Currently the only supported key is the headset button that can be used for
00148    *  basic call control.  In general, buttons available will be device dependent.
00149    *
00150    *  This notification is exclusively broadcast to all applications registered for the
00151    *  Voice Service.
00152    */
00153   phnEvtKeyPress,           /**< 0x0003 < Headset button pressed. */
00154
00155   /** change in power state of radio
00156    *
00157    *  This notification occurs when the power state of the radio is changing.  Applications
00158    *  may want to change their state, and take action based on the expected availability
00159    *  of the radio.
00160    *
00161    *  This notification is universally broadcast to all registered applications.
00162    */
00163   phnEvtPower,              /**< 0x0004  */
00164
00165   /** Password Dialog Control
00166    *
00167    *  This notification helps an application control the entry of a PIN on a
00168    *  device that is locked.
00169    *
00170    *  This notification is exclusively broadcast to all registered applications.
00171    *  Application that acknowledges the notification is presumed to own handling
00172    *  the password situation.
00173    */
00174   phnEvtPassword,           /**< 0x0005  */
00175
00176   /** outgoing call progress dialog
00177    *
00178    *  This notification is sent to help applications display the progress of an
00179    *  oubound call operation.
00180    *
00181    *  This notification is exclusively broadcast to all registered applications.
00182    *  Application that acknowledges the notification is presumed to be the only one
00183    *  to take any action on the outgoing call.
00184    */
00185   phnEvtProgress,           /**< 0x0006  */
00186
00187   /** indication of various changes of state in Phone Library
00188    *
00189    *  This notification is sent on various changes of state in the Phone Library.
00190    *  Most of these are related to activation and registration with the carrier
00191    *  network.  Applications that display gauges with state info will often need
00192    *  to be updated after this notification.
00193    *
00194    *  Indications are often used to direct GUI interactions in applications
00195    *  that interact with the user.  For example, the Network Search notification
00196    *  might cause an app to put up a special Network Search dialog.
00197    *
00198    *  See PhnIndicationKind for list of available indications.
00199    *
00200    *  The broadcast rules for indications vary depending on the type of indication.
00201    */
00202   phnEvtIndication,         /**< 0x0007  */
00203
00204   /** incoming call received
00205    *
00206    *  This notification is exclusively broadcast to applications registered for
00207    *  the Voice Service.  First application to acknowledge the notification will
00208    *  be presumed to control the call.  Normally application would answer the call,
00209    *  or forward it to another destination.
00210    *
00211    */
00212   phnEvtConnectInd,         /**< 0x0008  */
00213
00214   /** call has connected
00215    *
00216    *  Despite the name, this event is used BOTH when a call goes into
00217    *  connected state (e.g. is answered), and when a call joins a conference.
00218    *
00219    *  This notification is exclusively broadcast to applications registered for
00220    *  the Voice Service.  First application to acknowledge the notification will
00221    *  be presumed to control the call or conference.
00222    */
00223   phnEvtConnectConf,        /**< 0x0009  */
00224
00225   /** Number/name of call has changed
00226    *
00227    *  This notification is universally broadcast to all applications registered for
00228    *  the Voice Service.
00229    */
00230   phnEvtSubscriber,         /**< 0x000A  */
00231
00232   /** call has disconnected
00233    *
00234    *  This notification occurs when the remote party of an active voice call
00235    *  disconnects.  Note that if the call is in conference (or 3-way calling) mode, then
00236    *  a different phnEvtDisconnectConf notification will be sent instead (see below).
00237    *
00238    *  This notification is universally broadcast to all applications registered for
00239    *  the Voice or Data Services.
00240    */
00241   phnEvtDisconnectInd,      /**< 0x000B  */
00242
00243   /** call in conference (or 3-way calling) mode has disconnected
00244    *
00245    *  This notification occurs when a conference call is in progress, and one of the
00246    *  remote parties disconnects.
00247    *
00248    *  This notification is universally broadcast to all applications registered for
00249    *  the Voice Service.
00250    */
00251   phnEvtDisconnectConf,     /**< 0x000C An ACK for a disconnection command on a specific connection ID is received */
00252
00253   /** Outbound call attempt failed because remote party (or network) reported busy
00254    *
00255    *  This notification is universally broadcast to all applications registered for
00256    *  the Voice Service.
00257    */
00258   phnEvtBusy,               /**< 0x000D  */
00259
00260   /** Change in Call Status;  Application may need to update its state
00261    *
00262    *  This notification is sent on various changes in call state in the Phone Library.
00263    *  An application receiving this notification should poll for the connection status
00264    *  of any calls of interest, and update its own state as needed.
00265    *
00266    *  This notification is universally broadcast to all applications registered
00267    *  for the Voice Service.
00268    *********************************************************************/
00269   phnEvtUpdate,             /**< 0x000E  */
00270
00271   /** 3-way call mode
00272    *
00273    *  This notification occurs when a call goes into conferrence (or 3-way calling) mode.
00274    *
00275    *  This notification is universally broadcast to all applications registered
00276    *  for the Voice Service.
00277    */
00278   phnEvtConference,         /**< 0x000F  */
00279
00280   /** Incoming VoiceMail Message
00281    *
00282    *  This notification occurs when the Phone Library detects that there are
00283    *  pending VoiceMail messages available.
00284    *
00285    *  This notification is universally broadcast to all applications registered
00286    *  for the Voice Service.
00287    */
00288   phnEvtVoiceMail,          /**< 0x0010  */
00289
00290   /** Incoming SMS message received
00291    *
00292    * This notification occurs when the Phone Library receives an
00293    * incoming SMS (Simple Message Service) message.
00294    *
00295    * This notification will be exclusively broadcast to applications
00296    * registered for the SMS service.  The Application that acknowledges
00297    * the notification is assumed to own the message, and should take
00298    * any appropriate actions.
00299    */
00300   phnEvtMessageInd,         /**< 0x0011  */
00301
00302   /** Incoming segment of SMS Message received
00303    *
00304    * This notification occurs when the Phone Library receives a segment
00305    * of a multi-segment SMS (Simple Message Service) message.  Single
00306    * segment SMS messages will generate a MessageInd notification (see
00307    * above).
00308    *
00309    * This notification will be exclusively broadcast to applications
00310    * registered for the SMS service.  The Application that acknowledges
00311    * the notification is assumed to own the segment, and should take
00312    * any appropriate actions.
00313    */
00314   phnEvtSegmentInd,         /**< 0x0012  */
00315
00316   /** Status of outgoing SMS message has changed
00317    *
00318    * This notification occurs when the status of a particular SMS
00319    * message has changed.  For example, an SMS message might move from
00320    * the pending queue to the sent queue after being successfully
00321    * delivered.
00322    *
00323    * This notification will be sent directly to the application that
00324    * created the message, and is NOT broadcast based on app registrations.
00325    */
00326   phnEvtMessageStat,        /**< 0x0013  */
00327
00328   /** SMS message deleted from local DB on device
00329    *
00330    * This notification occurs when an SMS message is deleted from the
00331    * local Database on the device.
00332    *
00333    * This notification will be sent directly to the application that
00334    * created the message, and is NOT broadcast based on app registrations.
00335    */
00336   phnEvtMessageDel,         /**< 0x0014  */
00337
00338   /** SIM Contains SMS Messages
00339    *
00340    *  This notification indicates that the SIM (Subscriber Information
00341    *  Module) on a GSM phone contains SMS (Simple Messaging Service)
00342    *  messages.  This is not an indication of new messages, just that
00343    *  messages are stored.  This notification is typically sent during
00344    *  Phone Library activation.  In many cases, the application may want
00345    *  to move the SMS messages to a local DB on the device, freeing memory
00346    *  for future incoming messages.
00347    *
00348    *  This notification will use exclusive broadcast to applications
00349    *  registered for the SMS service.  The application that acknowledges
00350    *  the notification is responsible for taking any action on moving
00351    *  the SMS messages on the SIM (if desired).
00352    */
00353   phnEvtMessageMoved,       /**< 0x0015  */
00354
00355   /** SIM Application Toolkit (SAT) event
00356    *
00357    * The SIM Application Toolkit allows for simple applications that
00358    * can be placed on the SIM (Subscriber Identity Module) in a GSM
00359    * phone.  This notification will be sent when a SAT application is
00360    * requesting input/output to/from the user.
00361    *
00362    * This notification will use exclusive broadcast to applications
00363    * registered for the SIM Toolkit Service.  The Application that first
00364    * acknowedges the notification will be presumed to own the SAT session,
00365    * and should handle needed user dialog as appropriate.
00366    */
00367   phnEvtSATNotification,    /**< 0x0016  */
00368
00369   /** USSD input/output requested from network
00370    *
00371    * USSD (Unstructured Supplementary Services Data) is a supplementary
00372    * service to GSM networks that allows simple text dialogs
00373    * with applications based in the network.  This notification
00374    * is sent when the network is requesting USSD input/output to/from the user.
00375    * (see +CUSD event in radio documentation for more details)
00376    *
00377    * This notification will use exclusive broadcast to applications
00378    * registered for the Voice Service.  The Application that first
00379    * acknowledges the notification will be presumed to own the USSD session.
00380    * Typically, that app will want to display any USSD message to the user,
00381    * and handle any response from the user back to the network.
00382    */
00383   phnEvtUSSDInd,            /**< 0x0017  */
00384
00385   /** Phone Equipment state has changed
00386    *
00387    * On communicator devices there are pieces of equipment that directly
00388    * impact how the radio is used.  Examples of equipment include headset
00389    * jacks, car kits, lids, etc.  The equipment modes available will vary
00390    * with the model of communicator being used.  This notification will be
00391    * sent when ever the Phone Library detects that an available equipment
00392    * mode has changed.  See the type PhnEquipmentMode for the available
00393    * set of mode values.
00394    *
00395    * This notification will be universally broadcast to all applications
00396    * registered for any service.
00397    */
00398   phnEvtPhoneEquipmentMode, /**< 0x0018  */
00399
00400   /** GPRS Attach Registration has changed. (GSM/GPRS systems only)
00401    *
00402    *  GPRS (General Packet Radio Services) is an extension to the GSM
00403    *  wireless network that provides higher speed, always on data connections.
00404    *  The radio must attach to the GPRS network before any GPRS sessions
00405    *  can be established.  This notification will be sent when ever the
00406    *  status of the GPRS attach registration changes.   See type
00407    *  PhnRegistrationStatus for available registration states.
00408    *
00409    *  This notification will be universally broadcast to applications
00410    * registered for any service.
00411    */
00412   phnEvtGPRSRegistration,   /**< 0x0019  */
00413
00414   /** incoming MMS message available
00415    *
00416    *  This notification will be sent when the Phone Library receives an
00417    *  incoming MMS (Multi-media Message Service) message.
00418    *
00419    *  This notification will use exclusive broadcast to applications registered
00420    *  for the MMS service.  Application that first acknowledges the notification
00421    *  will be presumed to own the message.  Typically, that app will want
00422    *  to notify the user that there is a message available, and move the
00423    *  message into a system DB, freeing memory for future messages.
00424    */
00425   phnEvtMMSInd,             /**< 0x001A  */
00426
00427   /************************************************************
00428   * CDMA Events
00429   *************************************************************/
00430
00431
00432   /** SMS Memory Full
00433    *
00434    *  This notification indicates that memory for SMS messages is
00435    *  currently full, and no new SMS messages can be received until
00436    *  some memory is freed.  A phnEvtMemoryOK notification will be sent
00437    *  when memory becomes available.
00438    *
00439    *  CURRENTLY USED BY CDMA PHONE LIBRARY ONLY
00440    */
00441   phnEvtMemoryFull,         /**< 0x001B  */
00442
00443   /** SMS Memory no longer full
00444    *
00445    *  This notification indicates that memory for SMS messages is
00446    *  no longer full, and new SMS messages can be received.
00447    *
00448    *  CURRENTLY USED BY CDMA PHONE LIBRARY ONLY
00449    */
00450   phnEvtMemoryOK,           /**< 0x001C - < Memory is not full anymore, can receive messages Description  */
00451
00452   /** WAP Message received via SMS (WAP in IS-637 standard)
00453    *
00454    *  NOT CURRENTLY USED (WAP notifications use standard Palm notifications)
00455    */
00456   phnEvtWAPInd,             /**< 0x001D  */
00457
00458   /** Radio Debug Info
00459    *
00460    *  Periodically sent from Phone Library to Activation App when
00461    *  in debug mode.
00462    *
00463    *  CURRENTLY USED BY CDMA PHONE LIBRARY ONLY
00464    */
00465   phnEvtDebugReport,        /**< 0x001E  */
00466
00467   /** System Selection mode has changed
00468    *
00469    *  Radio mode has changed (e.g. to PCS mode)
00470    *
00471    *  CURRENTLY USED BY CDMA PHONE LIBRARY ONLY
00472    */
00473   phnEvtSSModeChanged,      /**< 0x001F  */
00474
00475   /** Position Info has changed
00476    *
00477    *  indication of change in physical location of device.  This may
00478    *  be determined by GPS, network triangulation (AFLT), or some other
00479    *  technique.
00480    *
00481    *  \TODO - rename this event & some of its data structures to be cleaner.
00482    *
00483    *  CURRENTLY USED BY CDMA PHONE LIBRARY ONLY
00484    */
00485   phnEvtPDDataChanged,      /**< 0x0020  */
00486
00487   /** 1XRTT Status has changed
00488    *
00489    *  1XRTT is a high speed data protocol used in CDMA radios.  This
00490    *  notification indicates that the status of the 1XRTT connection
00491    *  has changed.
00492    *
00493    *  CURRENTLY USED BY CDMA PHONE LIBRARY ONLY
00494    */
00495   phnEvtOneXStatus,         /**< 0x0021  */
00496
00497   /** Mobile IP connection failed
00498    *
00499    *  Mobile IP is a flavor of the TCP/IP protocol for use on mobile
00500    *  devices.  It allows applications to use a single IP address while
00501    *  in motion.  This notification occurs when a Mobile IP session
00502    *  fails to be established.
00503    *
00504    *  CURRENTLY USED BY CDMA PHONE LIBRARY ONLY
00505    */
00506   phnEvtMIPFailed,          /**< 0x0022  */
00507
00508   /** IOTA Status has changed
00509    *
00510    *  Internet Over The Air (IOTA) is a protocol for a network to
00511    *  update the radio using an internet connection (as opposed to
00512    *  Over The Air (OTA)).  This notification occurs as an IOTA
00513    *  session changes (e.g. is established, committed, ended, etc).
00514    *
00515    *  CURRENTLY GENERATED BY CDMA PHONE LIBRARY ONLY
00516    */
00517   phnEvtIOTAStatus,         /**< 0x0023  */
00518
00519   /** Data Channel availability has changed
00520    *
00521    *  This notification occurs if there is a change in the ability
00522    *  for an application to send/receive data using the radio.  For
00523    *  example on Class B radios, data is not available when a voice
00524    *  call is in progress.
00525    *
00526    * \TODO - this notification should be generated by GSM Phone Library too.
00527    *
00528    *  CURRENTLY GENERATED BY CDMA PHONE LIBRARY ONLY
00529    */
00530   phnEvtDataChannel,        /**< 0x0024  */
00531
00532   /** Mobile IP Registration successful
00533    *
00534    *  Mobile IP is a flavor of the TCP/IP protocol for use on mobile
00535    *  devices.  It allows applications to use a single IP address while
00536    *  in motion.  This notification occurs when a Mobile IP session
00537    *  is successfully established.  The notification phnEvtMIPFailed
00538    *  will occur if the session fails.
00539    *
00540    *  CURRENTLY GENERATED BY CDMA PHONE LIBRARY ONLY
00541    */
00542   phnEvtOneXMipRRQInd,      /**< 0x0025  */
00543
00544   /** 1XRTT Session has failed (mid-session)
00545    *
00546    *  1XRTT is a high speed data protocol used in CDMA radios.  This
00547    *  notification indicates that the 1XRTT session has failed, and
00548    *  is not available.  Note that 1XRTT session may be left in Dormant
00549    *  state.
00550    *
00551    *  CURRENTLY GENERATED BY CDMA PHONE LIBRARY ONLY
00552    */
00553   phnEvtOneXDataFail,       /**< 0x0026  */
00554
00555   /** Start Dialing of Outbound Call
00556    *
00557    *   This notification is sent when an outbound call begins dialing before
00558    *   the call is connected.  This notification is universally broadcast to
00559    *   all applications registered for the Voice service.  Notification
00560    *   uses same notification data as Connect indication.
00561    */
00562   phnEvtStartDial,          /**< 0x0027  */
00563
00564   /** Start of incoming call
00565    *
00566    *   This notification is sent when an incoming call if first detected.
00567    *   This notification is used to perform special pre-call processing
00568    *   like turning off of MMS playback before a call.  Any processing on
00569    *   this notification must be very quick (less than a few hundred miliseconds)
00570    *   as it could potentially delay an incoming call from being answered.
00571    *
00572    *   APPLICATIONS MUST NOT ANSWER THE CALL OR DO ANY CALL CONTROL BASED
00573    *   ON THIS NOTIFICATION.  A separate phnEvtConnectInd notification will
00574    *   be follow for this purpose.  The phnEvtConnectInd notification is normally
00575    *   processed by the Phone App, and uses exclusive broadcast.  Thus it may
00576    *   not be received by all applications.  The phnEvtStartIncomingCall
00577    *   notification is sent to all applications registered for Voice Service
00578    *   using Universal Broadcast.  The acknowledgement flag is NOT used.
00579    */
00580   phnEvtStartIncomingCall,  /**< 0x0028  */
00581
00582   /** Alerting/Preconnected of Outbound Call
00583    *
00584    *   This notification is sent when an outbound call is alerting or
00585    *   preconnected.  This notification is universally broadcast to
00586    *   all applications registered for the Voice service.  Notification
00587    *   uses same notification data as Connect indication.
00588    */
00589   phnEvtAlertingPreConnected,   /**< 0x0029  */
00590
00591   /** Alerting of Outbound Call (NOT USED, for future implementation)
00592    *
00593    *   NOT USED
00594    *   This notification is sent when an outbound call is alerting.
00595    *   This notification is universally broadcast to
00596    *   all applications registered for the Voice service.  Notification
00597    *   uses same notification data as Connect indication.
00598    */
00599   phnEvtAlerting,               /**< 0x002A  */
00600
00601   /** Preconnected of Outbound Call (NOT USED, for future implementation)
00602    *
00603    *   NOT USED
00604    *   This notification is sent when an outbound call is preconnected.
00605    *   This notification is universally broadcast to
00606    *   all applications registered for the Voice service.  Notification
00607    *   uses same notification data as Connect indication.
00608    */
00609   phnEvtPreConnected,           /**< 0x002B  */
00610
00611   /** Data session status change
00612    *  This should replace the OneXStatus, as this will encompass more info
00613    *  than OneXStatus
00614    */
00615   phnEvtDataSessionStatus,           /**< 0x002C   */
00616
00617   /** Data session disconnected
00618    *  This is sent up when the data call is disconnected.
00619    *  We can't use the phnEvtDisconnectInd because the structure uses the
00620    *  Err class.
00621    */
00622   phnEvtDataSessionDisconnected,     /**< 0x002D   */
00623
00624   /** Returns the network time and DST obtained from network to date time panel
00625    */
00626
00627   phnEvtNetworkTime, /**< 0x002E   */
00628
00629   kMaxPhnEvtSupported  /**< Must be at last position*/
00630 } PhnEventCode;

enum PhnIndicationKind

unique identifier for Indication notification. This value will be contained in PhnEventType notification events of phnEvtIndication type.

Enumerator:
indicationSIMReady
indicationSIMMessages
indicationNetworkSearch | to display Network search banner
indicationPasswordAccepted
indicationNetworkAvailable
indicationStartingRadio | to update UI from radio being off
indicationPoweringOffRadio | notify app that the radio is turning off.
indicationResettingRadio | tell the app that the radio is resetting.
indicationAuthFailure | notify app that network authentication failed.
indicationSIMChanged | sent when the GSM library detects that the IMSI value has changed
indicationInitComplete | sent when the GSM library is done with it initialization when the radio is powered on
indicationOtaspMsg | sent otasp msg from network

Definition at line 95 of file HsPhoneEvent.h.

00095              {
00096     indicationSIMReady,         /**<        */
00097     indicationSIMMessages,      /**<        */
00098     indicationNetworkSearch,        /**< to display Network search banner */
00099     indicationPasswordAccepted, /**<        */
00100     indicationNetworkAvailable, /**<        */
00101     indicationStartingRadio,        /**< to update UI from radio being off */
00102     indicationPoweringOffRadio,     /**< notify app that the radio is turning off. */
00103     indicationResettingRadio,       /**< tell the app that the radio is resetting. */
00104     indicationAuthFailure,      /**< notify app that network authentication failed. */
00105     indicationSIMChanged,       /**< sent when the GSM library detects that the IMSI value has changed */
00106     indicationInitComplete,     /**< sent when the GSM library is done with it initialization when the radio is powered on */
00107   indicationOtaspMsg            /**< sent otasp msg from network */
00108 } PhnIndicationKind;

enum PhnMiscDbgUpdateKind

Enumerator:
eDbgUpdateNone
eDbgUpdateYes
eDbgUpdateQuit

Definition at line 1168 of file HsPhoneEvent.h.

01169   {
01170     eDbgUpdateNone,     /**<        */
01171     eDbgUpdateYes,      /**<        */
01172     eDbgUpdateQuit      /**<        */
01173   }

enum PhnModuleButtonType

Phone buttons

Enumerator:
phnButtonHeadset
phnButtonRedial
phnButtonAnswerCall
phnButtonRejectCall
phnButtonIgnoreCall
phnButtonHoldCall
phnButtonConferenceCall
phnButtonLast

Definition at line 780 of file HsPhoneEvent.h.

00780               {
00781     phnButtonHeadset,       /**<        */
00782     phnButtonRedial,        /**<        */
00783     phnButtonAnswerCall,        /**<        */
00784     phnButtonRejectCall,        /**<        */
00785     phnButtonIgnoreCall,        /**<        */
00786     phnButtonHoldCall,      /**<        */
00787     phnButtonConferenceCall,    /**<        */
00788     phnButtonLast           /**<        */
00789 } PhnModuleButtonType;

enum PhnMsgIDType

Enumerator:
kMsgIdReserved
kMsgIdDeliverMT
kMsgIdSubmitMO
kMsgIdcancelMO
kMsgIdDeliveryMTAck
kMsgIdUserAck

Definition at line 1191 of file HsPhoneEvent.h.

01192   {
01193     kMsgIdReserved,     /**<        */
01194     kMsgIdDeliverMT,        /**<        */
01195     kMsgIdSubmitMO,     /**<        */
01196     kMsgIdcancelMO,     /**<        */
01197     kMsgIdDeliveryMTAck,    /**<        */
01198     kMsgIdUserAck       /**<        */
01199   }

enum PhnOpenDialogType

Enumerator:
kDialogSetBarring
kDialogGetBarring
kDialogSetForwarding
kDialogGetForwarding
kDialogSetCallWaiting
kDialogGetCallWaiting
kDialogGetOperatorList
kDialogSetOperator
kDialogOperatorSelection
kDialogImmediateSend
kDialogDeferredSend
kDialogSendUSSD

Definition at line 896 of file HsPhoneEvent.h.

00896               {
00897     kDialogSetBarring,      /**<        */
00898     kDialogGetBarring,      /**<        */
00899     kDialogSetForwarding,       /**<        */
00900     kDialogGetForwarding,       /**<        */
00901     kDialogSetCallWaiting,      /**<        */
00902     kDialogGetCallWaiting,      /**<        */
00903     kDialogGetOperatorList,     /**<        */
00904     kDialogSetOperator,     /**<        */
00905     kDialogOperatorSelection,   /**<        */
00906     kDialogImmediateSend,       /**<        */
00907     kDialogDeferredSend,        /**<        */
00908     kDialogSendUSSD         /**<        */
00909 } PhnOpenDialogType;

enum PhnProgressType

Enumerator:
kOpenDialog
kCloseDialog
kSetText
kSetRecipient
kShowSegment

Definition at line 882 of file HsPhoneEvent.h.

00882               {
00883     kOpenDialog,        /**<        */
00884     kCloseDialog,       /**<        */
00885     kSetText,       /**<        */
00886     kSetRecipient,      /**<        */
00887     kShowSegment        /**<        */
00888 } PhnProgressType;

enum PhnSMSClassEnum

Enumerator:
classUnknown
class0 immediate display
class1
class2
class3

Definition at line 707 of file HsPhoneEvent.h.

00708 {
00709   classUnknown = 0, /**<        */
00710   class0,           /**< immediate display */
00711   class1,           /**<        */
00712   class2,       /**<        */
00713   class3        /**<        */
00714 } PhnSMSClassEnum;

enum PhnSMSTypeEnum

Enumerator:
defaultType
discardType0 | Type 0 messages should be discarded.
replaceType1 | Replace Short Message Type 1.
replaceType2 | Replace Short Message Type 2.
replaceType3 | Replace Short Message Type 3.
replaceType4 | Replace Short Message Type 4.
replaceType5 | Replace Short Message Type 5.
replaceType6 | Replace Short Message Type 6.
replaceType7 | Replace Short Message Type 7.

Definition at line 689 of file HsPhoneEvent.h.

00690 {
00691   defaultType = 0,
00692   discardType0 = 0x40,          /**< Type 0 messages should be discarded. */
00693     replaceType1 = 0x41,        /**< Replace Short Message Type 1. */
00694     replaceType2 = 0x42,        /**< Replace Short Message Type 2. */
00695     replaceType3 = 0x43,        /**< Replace Short Message Type 3. */
00696     replaceType4 = 0x44,        /**< Replace Short Message Type 4. */
00697     replaceType5 = 0x45,        /**< Replace Short Message Type 5. */
00698     replaceType6 = 0x46,        /**< Replace Short Message Type 6. */
00699     replaceType7 = 0x47     /**< Replace Short Message Type 7. */
00700
00701 } PhnSMSTypeEnum;

enum PhnWAPPushAppIdType

WAP push message - message type http://www.wapforum.org/wina/push-app-id.htm

Enumerator:
kWAPAnyApp | Any Application
kWAPPushSIA | WAP Push SIA
kWAPWmlUa | WML User Agent
kWAPWtaUa | WTA User Agent
kWAPMmsUa | This ID will used for application dispatching to MMS User Agent in the handling of MMS notfication using WAP Push. See WAP-206-MMSCTR for more detail.
kWAPPushSyncml | SyncML PUSH Application ID: used to push a SyncML Alert from a SyncML server side. The SyncML Alert is an indication for starting a SyncML session e.g., for data synchronization. Requested by the WAP WAG Synchronisation Drafting Committee.
kWAPLocUa | This ID is used for application dispatching to Location User Agent in the handling of Location Invocation document. See WAP-257-LOCPROT for details. Requested by the WAP WAG Location Drafting Committee.
kWAPSyncmlDm | This ID is used for SyncML Device Management. Requested by the SyncML Device Management Expert Group.
kWAPDrmUa | This ID is used for DRM User Agent. Requested by the WAP WAG Download DC.
kWAPEmnUa | This ID is used for Email Notification (EMN) User Agent. Requested by the WAP WAG PUSH DC.
kWAPWvUa | This ID is used for Wireless Village (EMN) User Agent. Requested by Wireless Village.
kWAPMsLocalcontentUa | An application to receive pages to be stored and access locally. These are not wta channels. Usually the pages will be downloaded as multi-part mime.
kWAPMsIMclientUa | An application which will act as an instant messaging client on a phone.
kWAPdocomoImodeMailUa | Used to identify the i-mode mail application user agent on a mobile device.
kWAPdocomoImodeMrUa | Used to identify the i-mode message request application user agent on a mobile device.
kWAPdocomoImodeMfUa | Used to identify the i-mode message free application user agent on a mobile device.
kWAPMotorolaLocationUa | An application that receives message notifications from the location server.
kWAPMotorolaNowUa | An application that presents personalized information to the user.
kWAPMotorolaOtaprovUa | An application that receives provisioning messages from the server.
kWAPMotorolaBrowserUa | A web browsing application.
kWAPMotorolaSplashUa | An application that receives splash screen content from the server.
kWAPUnused
kWAPNaiMvswCommand | Used by administrators to issue commands to individual devices.
kWAPopenwaveIotaUa | Used for application dispatching to the IP-based OTA Provisioning Service Agent in the handling of IOTA notfications using WAP Push.

Definition at line 1377 of file HsPhoneEvent.h.

01377              {
01378   //URN                   //Number  //  Description
01379   kWAPAnyApp              = 0x00,   /**< Any Application */
01380   kWAPPushSIA             = 0x01,   /**< WAP Push SIA  */
01381   kWAPWmlUa               = 0x02,   /**< WML User Agent  */
01382   kWAPWtaUa               = 0x03,   /**< WTA User Agent  */
01383   kWAPMmsUa               = 0x04,   /**< This ID will used for application dispatching  to MMS User Agent in the handling of MMS notfication using WAP Push. See WAP-206-MMSCTR for more detail.  */
01384   kWAPPushSyncml          = 0x05,   /**< SyncML PUSH Application ID: used to push a SyncML Alert from a SyncML server side. The SyncML Alert is an indication for starting a SyncML session e.g., for data synchronization. Requested by the WAP WAG Synchronisation Drafting Committee.  */
01385   kWAPLocUa               = 0x06,   /**< This ID is used for application dispatching to Location User Agent in the handling of Location Invocation document. See WAP-257-LOCPROT for details. Requested by the WAP WAG Location Drafting Committee.   */
01386   kWAPSyncmlDm            = 0x07,   /**< This ID is used for SyncML Device Management. Requested by the SyncML Device Management Expert Group.   */
01387   kWAPDrmUa               = 0x08,   /**< This ID is used for DRM User Agent. Requested by the WAP WAG Download DC.   */
01388   kWAPEmnUa               = 0x09,   /**< This ID is used for Email Notification (EMN) User Agent. Requested by the WAP WAG PUSH DC.   */
01389   kWAPWvUa                = 0x0A,   /**< This ID is used for Wireless Village (EMN) User Agent. Requested by Wireless Village.   */
01390
01391   // Registered Values -----------------------------
01392   kWAPMsLocalcontentUa    = 0x8000, /**< An application to receive pages to be stored and access locally. These are not wta channels. Usually the pages will be downloaded as multi-part mime.   */
01393   kWAPMsIMclientUa        = 0x8001, /**< An application which will act as an instant messaging client on a phone.   */
01394   kWAPdocomoImodeMailUa   = 0x8002, /**< Used to identify the i-mode mail application user agent on a mobile device.   */
01395   kWAPdocomoImodeMrUa     = 0x8003, /**< Used to identify the i-mode message request application user agent on a mobile device.   */
01396   kWAPdocomoImodeMfUa     = 0x8004, /**< Used to identify the i-mode message free application user agent on a mobile device.   */
01397   kWAPMotorolaLocationUa  = 0x8005, /**< An application that receives message notifications from the location server.   */
01398   kWAPMotorolaNowUa       = 0x8006, /**< An application that presents personalized information to the user.   */
01399   kWAPMotorolaOtaprovUa   = 0x8007, /**< An application that receives provisioning messages from the server.   */
01400   kWAPMotorolaBrowserUa   = 0x8008, /**< A web browsing application.   */
01401   kWAPMotorolaSplashUa    = 0x8009, /**< An application that receives splash screen content from the server.   */
01402   kWAPUnused              = 0x800A, /**<        */
01403   kWAPNaiMvswCommand      = 0x800B, /**< Used by administrators to issue commands to individual devices.   */
01404   // unused  0x800C through 0x800F  /**<        */
01405   kWAPopenwaveIotaUa      = 0x8010  /**< Used for application dispatching to the IP-based OTA Provisioning Service Agent in the handling of IOTA notfications using WAP Push.   */
01406 } PhnWAPPushAppIdType;

enum PhnWAPPushContentType

WAP push message - message content type

Enumerator:
kWAPContentTypeUnknown
kWAPContentTypeIOTA
kWAPContentTypeMMS
kWAPContentTypeMMSText
kWAPContentTypeServiceLoad
kWAPContentTypeServiceLoadText
kWAPContentTypeServiceIndicator
kWAPContentTypeServiceIndicatorText

Definition at line 1361 of file HsPhoneEvent.h.

01361              {
01362   kWAPContentTypeUnknown = 0,       /**<        */
01363   kWAPContentTypeIOTA,          /**<        */
01364   kWAPContentTypeMMS,           /**<        */
01365   kWAPContentTypeMMSText,       /**<        */
01366   kWAPContentTypeServiceLoad,       /**<        */
01367   kWAPContentTypeServiceLoadText,   /**<        */
01368   kWAPContentTypeServiceIndicator,  /**<        */
01369   kWAPContentTypeServiceIndicatorText   /**<        */
01370 } PhnWAPPushContentType;

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:07:17 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » telephony

HsPhoneGSM.h File Reference

Detailed Description

Header File for Phone Library API ---- GSM CATEGORY.

Notes: All implementations of the Handspring Phone Library support a common API. This API is broken up into various categories for easier management. This file defines the SMS category. These API calls are used for features that only apply to GSM networks.

Definition in file HsPhoneGSM.h.

Include dependency graph for HsPhoneGSM.h:

Go to the source code of this file.

Functions

  • Err PhnLibSetActiveLine (UInt16 refNum, Int16 line)
    Sets the active line number.
  • Err PhnLibGetFDNList (UInt16 refNum, PhnAddressList *aList, PhnPhoneBookInfoPtr info)
    Retrieve the Fixed Dialing Numbers from the SIM.
  • Err PhnLibSetFDNEntry (UInt16 refnum, UInt16 index, char *name, char *number)
    Set entry in the Fix Dialing field on the SIM.
  • Err PhnLibGetPhoneBook (UInt16 refNum, PhnAddressList *numbers, PhnPhoneBookInfoPtr info)
    This routine reads the PhoneBook of phone numbers from your SIM (GSM only). This command can take several seconds if the PhoneBook is large.
  • Err PhnLibSetPhoneBook (UInt16 refnum, PhnAddressList numbers)
    This routine writes the PhoneBook of phone numbers from your SIM (GSM only). This command can take several seconds if the PhoneBook is large.
  • Err PhnLibSetPhoneBookEntry (UInt16 refnum, UInt16 index, char *name, char *number)
    Set entry in SIM Phone Book.
  • UInt32 PhnLibGetPhoneBookIndex (UInt16, PhnAddressHandle address)
    This routine gets the index of the given PhoneBook address on your SIM (GSM only).
  • Err PhnLibGetSDNList (UInt16 refNum, PhnAddressList *aList, PhnPhoneBookInfoPtr info)
    Parameters:
    refNum,: IN:

  • Err PhnLibSendUSSD (UInt16 refNum, CharPtr cmd)
    Send USSD value to radio.
  • Err PhnLibSATGetMainMenu (UInt16 refNum, MemHandle *menuHandlePtr)
    Retrieve SAT main menu.
  • Err PhnLibSATSendRequest (UInt16 refNum, SATRequestType request, SATDecisionType decision, UInt32 data, UInt32 length)
    Send application’s request to firmware.
  • Err PhnLibSATEndSession (UInt16 refNum)
    Terminate an active SAT session.
  • Boolean PhnLibSIMInfo (UInt16 refNum, CharPtr *imsi)
    This routine reads the IMSI number from the SIM (Subscriber Information Module) on your GSM device. IMSI stands for International Mobile Subscriber Identify, and is used to uniquely identify a user to the wireless network.
  • GSMSIMStatus PhnLibGetSIMStatus (UInt16 refNum)
    This routine returns status of the SIM (Subscriber Information Module) on your GSM device. The SIM is managed by the radio module on the handset. The SIM must be present and active before the radio is allowed to make phone calls (other than emergency calls). The SIM also stores various user information and settings.
  • Boolean PhnLibGPRSAttached (UInt16 refNum)
    Check if we are currently attached to the GPRS Network.
  • Err PhnLibGPRSPDPContextDefine (UInt16 refNum, UInt16 contextId, PhnGPRSPDPType pdpType, const char *apn, UInt16 apnLen, const char *pdpAddr, UInt16 pdpAddrLen, UInt16 pdpDataCompression, UInt16 pdpHdrCompression)
    This function will store the given settings as a profile in the radios flash memory. The profile id will be the same as the context id that you pass with valid values between 1 and 32.
  • Err PhnLibGPRSPDPContextListConstruct (UInt16 refNum, struct PhnGPRSPDPContextListNodeType **listHeadPP)
    Get a linked list of pdp contexts currently stored on the device. It is necessary to call the Destruct after use of the list to free the memory.
  • Err PhnLibGPRSPDPContextListDestruct (UInt16 refNum, struct PhnGPRSPDPContextListNodeType **headNodePP)
    Function that cleans up the list of pdp contexts created by the construct functions.
  • Err PhnLibGPRSQualityOfServiceGet (UInt16 refNum, PhnGPRSQOSType qosType, UInt16 contextId, UInt16 *precedence, UInt16 *delay, UInt16 *reliability, UInt16 *peakThroughput, UInt16 *meanThroughput)
    Set either the Required or Minimum QOS service parameters. If 0 is passed for the parameter, the network will decide the settings. Valid settings are listed below.
  • Err PhnLibGPRSQualityOfServiceSet (UInt16 refNum, PhnGPRSQOSType qosType, UInt16 contextId, UInt16 precedence, UInt16 delay, UInt16 reliability, UInt16 peakThroughput, UInt16 meanThroughput)
    Set either the Required or Minimum QOS service parameters. If 0 is passed for the parameter, the network will decide the settings. Valid settings are listed below.
  • Err PhnLibSendLongDTMF (UInt refNum, Char digit, PhnAudioSendMode sendMode, Boolean on)
    Parameters:
    refNum,: IN:

  • Err PhnLibGetICCID (UInt refNum, CharPtr *iccid)
    Parameters:
    refNum,: IN:

  • Err PhnLibGetGSMCellInfo (UInt refNum, UInt32 *pLac, UInt32 *pCellId)
    Retreives currrent/camped Location Area Code (LAC) and Cell ID.
  • Err PhnLibGetSpn (UInt refNum, CharPtr *spn)
    Parameters:
    refNum,: IN: Library reference number obtained from SysLibLoad

Function Documentation

Err PhnLibGetFDNList | ( | UInt16 | refNum,
 |  | PhnAddressList * | aList,
 |  | PhnPhoneBookInfoPtr | info
 | ) |  |

Retrieve the Fixed Dialing Numbers from the SIM.

Parameters:
refNum,: IN: Library reference number obtained from SysLibLoad.
aList,: IN: Returned with the list of numbers
info,: IN:
Return values:
0 for success; otherwise failed and returned an error code as defined in “Phone Library Error Codes.”

Err PhnLibGetGSMCellInfo | ( | UInt | refNum,
 |  | UInt32 * | pLac,
 |  | UInt32 * | pCellId
 | ) |  |

Retreives currrent/camped Location Area Code (LAC) and Cell ID.

Parameters:
refNum,: IN: Library reference number obtained from SysLibLoad.
pLac | : IN: Pointer to UInt32 thats populated with LAC upon successful return.
pCellId | : IN: Pointer to UInt32 thats populated with Cell ID upon successful return.
Return values:
Err Error code as defined in HsPhoneErrors.h

Err PhnLibGetICCID | ( | UInt | refNum,
 |  | CharPtr * | iccid
 | ) |  |

Parameters:
refNum,: IN:

Parameters:
iccid,: IN:
Return values:
Err Error code.

Err PhnLibGetPhoneBook | ( | UInt16 | refNum,
 |  | PhnAddressList * | numbers,
 |  | PhnPhoneBookInfoPtr | info
 | ) |  |

This routine reads the PhoneBook of phone numbers from your SIM (GSM only). This command can take several seconds if the PhoneBook is large.

Parameters:
refNum,: IN: Library reference number obtained from SysLibLoad.
numbers,: IN:
info,: IN:
Return values:
0 for success; otherwise failed and returned an error code as defined in “Phone Library Error Codes.”

UInt32 PhnLibGetPhoneBookIndex | ( | UInt16 | ,
 |  | PhnAddressHandle | address
 | ) |  |

This routine gets the index of the given PhoneBook address on your SIM (GSM only).

Parameters:
unused,: IN: for the future, set to 0.
address,:
Return values:
Index number.

Err PhnLibGetSDNList | ( | UInt16 | refNum,
 |  | PhnAddressList * | aList,
 |  | PhnPhoneBookInfoPtr | info
 | ) |  |

Parameters:
refNum,: IN:

Parameters:
aList,: IN:
info,: IN:
Return values:
Err Error code.

GSMSIMStatus PhnLibGetSIMStatus ( UInt16 refNum )

This routine returns status of the SIM (Subscriber Information Module) on your GSM device. The SIM is managed by the radio module on the handset. The SIM must be present and active before the radio is allowed to make phone calls (other than emergency calls). The SIM also stores various user information and settings.

Parameters:
refNum,: IN: Library reference number obtained from SysLibLoad.
Return values:
Sim Status

Err PhnLibGetSpn | ( | UInt | refNum,
 |  | CharPtr * | spn
 | ) |  |

Parameters:
refNum,: IN: Library reference number obtained from SysLibLoad

Parameters:
spn,: IN: Service Provider Name from SIM
Return values:
Err Error code.

Boolean PhnLibGPRSAttached ( UInt16 refNum )

Check if we are currently attached to the GPRS Network.

Parameters:
refNum,: IN: Library reference number obtained from SysLibLoad.
Return values:
True if we are attached

Err PhnLibGPRSPDPContextDefine | ( | UInt16 | refNum,
 |  | UInt16 | contextId,
 |  | PhnGPRSPDPType | pdpType,
 |  | const char * | apn,
 |  | UInt16 | apnLen,
 |  | const char * | pdpAddr,
 |  | UInt16 | pdpAddrLen,
 |  | UInt16 | pdpDataCompression,
 |  | UInt16 | pdpHdrCompression
 | ) |  |

This function will store the given settings as a profile in the radios flash memory. The profile id will be the same as the context id that you pass with valid values between 1 and 32.

Parameters:
refNum,: IN: Library reference number obtained from SysLibLoad.
contextId,: IN:
pdpType,: IN:
*apn,: IN:
apnLen,: IN:
*pdpAddr,: IN:
pdpAddrLen,: IN:
pdpDataCompression,: IN:
pdpHdrCompression,: IN:
Return values:
0 for success; otherwise failed and returned an error code as defined in “Phone Library Error Codes.”

Err PhnLibGPRSPDPContextListConstruct | ( | UInt16 | refNum,
 |  | struct PhnGPRSPDPContextListNodeType ** | listHeadPP
 | ) |  |

Get a linked list of pdp contexts currently stored on the device. It is necessary to call the Destruct after use of the list to free the memory.

Parameters:
refNum,: IN: Library reference number obtained from SysLibLoad.
listHeadPP,: IN: Pointer to a pointer where the head of the linked list will be stored.
Return values:
0 for success; otherwise failed and returned an error code as defined in “Phone Library Error Codes.”

Err PhnLibGPRSPDPContextListDestruct | ( | UInt16 | refNum,
 |  | struct PhnGPRSPDPContextListNodeType ** | headNodePP
 | ) |  |

Function that cleans up the list of pdp contexts created by the construct functions.

Parameters:
refNum,: IN: Library reference number obtained from SysLibLoad.
headNodePP,: IN: Pointer to a pointer to the head of the list.
Return values:
0 for success; otherwise failed and returned an error code as defined in “Phone Library Error Codes.”

Err PhnLibGPRSQualityOfServiceGet | ( | UInt16 | refNum,
 |  | PhnGPRSQOSType | qosType,
 |  | UInt16 | contextId,
 |  | UInt16 * | precedence,
 |  | UInt16 * | delay,
 |  | UInt16 * | reliability,
 |  | UInt16 * | peakThroughput,
 |  | UInt16 * | meanThroughput
 | ) |  |

Set either the Required or Minimum QOS service parameters. If 0 is passed for the parameter, the network will decide the settings. Valid settings are listed below.

Parameters:
refNum,: IN: Library reference number obtained from SysLibLoad.
qosType,: IN: Required or Minimum.
contextId,: IN: id of the profile that you are setting with these QOS Values.
precedence,: IN: (1-3) 1 being highest priority
delay,: IN: (1-3) Predictive 4 - Best Effort
reliability,: IN: (1-5) - Unknown
peakThroughput,: IN: (1-9) 1 is the lowest and 9 the highest
meanThroughput,: IN: (1-9) 1 is the lowest and 9 the highest
Return values:
0 for success; otherwise failed and returned an error code as defined in “Phone Library Error Codes.”

Err PhnLibGPRSQualityOfServiceSet | ( | UInt16 | refNum,
 |  | PhnGPRSQOSType | qosType,
 |  | UInt16 | contextId,
 |  | UInt16 | precedence,
 |  | UInt16 | delay,
 |  | UInt16 | reliability,
 |  | UInt16 | peakThroughput,
 |  | UInt16 | meanThroughput
 | ) |  |

Set either the Required or Minimum QOS service parameters. If 0 is passed for the parameter, the network will decide the settings. Valid settings are listed below.

Parameters:
refNum,: IN: Library reference number obtained from SysLibLoad.
qosType,: IN: Required or Minimum.
contextId,: IN: id of the profile that you are setting with these QOS Values.
precedence,: IN: (1-3) 1 being highest priority
delay,: IN: (1-3) Predictive 4 - Best Effort
reliability,: IN: (1-5) - Unknown
peakThroughput,: IN: (1-9) 1 is the lowest and 9 the highest
meanThroughput,: IN: (1-9) 1 is the lowest and 9 the highest
Return values:
0 for success; otherwise failed and returned an error code as defined in “Phone Library Error Codes.”

Err PhnLibSATEndSession ( UInt16 refNum )

Terminate an active SAT session.

Parameters:
refNum,: IN: Library reference number obtained from SysLibLoad.
Return values:
0 if succeeded or an error from PhnLibSATSendRequest() session

Err PhnLibSATGetMainMenu | ( | UInt16 | refNum,
 |  | MemHandle * | menuHandlePtr
 | ) |  |

Retrieve SAT main menu.

Parameters:
refNum,: IN: Library reference number obtained from SysLibLoad.
menuHandlePtr,: IN: Pointer to a GSMSATEventMenuPtr.
Return values:
0 for success; otherwise failed and returned an error code as defined in “Phone Library Error Codes.” And the pointer is filled with a pointer to a main menu or phnErrSATUnavailable if there is no active session.

Err PhnLibSATSendRequest | ( | UInt16 | refNum,
 |  | SATRequestType | request,
 |  | SATDecisionType | decision,
 |  | UInt32 | data,
 |  | UInt32 | length
 | ) |  |

Send application’s request to firmware.

Parameters:
refNum,: IN: Library reference number obtained from SysLibLoad.
request,: IN: Request type
decision,: IN: Decision Type
data,: IN: Data to send
length,: IN: Length of data to send (only for Input)
Return values:
0 if succeed phnErrIllegalCondition:unrecognized parameters or an unneeded param is not zero. phnErrSATUnavailable:SAT is not available phnErrSATInactive : no active SAT session; must call PhnLibSATGetMainMenu() before calling this function().

Err PhnLibSendLongDTMF | ( | UInt | refNum,
 |  | Char | digit,
 |  | PhnAudioSendMode | sendMode,
 |  | Boolean | on
 | ) |  |

Parameters:
refNum,: IN:

Parameters:
digit,: IN:
sendMode,: IN:
on,: IN:
Return values:
Err Error code.

Err PhnLibSendUSSD | ( | UInt16 | refNum,
 |  | CharPtr | cmd
 | ) |  |

Send USSD value to radio.

Parameters:
refNum,: IN: Library reference number obtained from SysLibLoad.
cmd,: IN: USSD value to be sent
Return values:
0 for success; otherwise failed and returned an error code as defined in “Phone Library Error Codes.”

Err PhnLibSetActiveLine | ( | UInt16 | refNum,
 |  | Int16 | line
 | ) |  |

Sets the active line number.

Parameters:
refNum,: IN: Library reference number obtained from SysLibLoad.
line,: IN: Line number to be set to active.
Return values:
0 for success; otherwise failed and returned an error code as defined in “Phone Library Error Codes.”

Err PhnLibSetFDNEntry | ( | UInt16 | refnum,
 |  | UInt16 | index,
 |  | char * | name,
 |  | char * | number
 | ) |  |

Set entry in the Fix Dialing field on the SIM.

Parameters:
refNum,: IN: Library reference number obtained from SysLibLoad.
index,: IN: index into SIM
name,: IN: name value for SIM entry
number,: IN: phone number for SIM entry
Return values:
0 for success; otherwise failed and returned an error code as defined in “Phone Library Error Codes.”

Err PhnLibSetPhoneBook | ( | UInt16 | refnum,
 |  | PhnAddressList | numbers
 | ) |  |

This routine writes the PhoneBook of phone numbers from your SIM (GSM only). This command can take several seconds if the PhoneBook is large.

Parameters:
refNum,: IN: Library reference number obtained from SysLibLoad.
numbers,: IN:
Return values:
0 for success; otherwise failed and returned an error code as defined in “Phone Library Error Codes.”

Err PhnLibSetPhoneBookEntry | ( | UInt16 | refnum,
 |  | UInt16 | index,
 |  | char * | name,
 |  | char * | number
 | ) |  |

Set entry in SIM Phone Book.

Parameters:
refNum,: IN: Library reference number obtained from SysLibLoad.
index,: IN: index into SIM Phone Book
name,: IN: name value for SIM Phone Book entry
number,: IN: phone number for SIM Phone Book entry
Return values:
0 for success; otherwise failed and returned an error code as defined in “Phone Library Error Codes.”

Boolean PhnLibSIMInfo | ( | UInt16 | refNum,
 |  | CharPtr * | imsi
 | ) |  |

This routine reads the IMSI number from the SIM (Subscriber Information Module) on your GSM device. IMSI stands for International Mobile Subscriber Identify, and is used to uniquely identify a user to the wireless network.

Parameters:
refNum,: IN: Library reference number obtained from SysLibLoad.
imsi,: IN: imsi number is a string pointer.
Return values:
Boolean

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:07:18 2008 for Palm API Guide


Header Files » Incs » common » libraries » telephony

HsPhoneGSMTypes.h File Reference

Detailed Description

Header File for Phone Library API ---- NETWORK CATEGORY.

NOTES: All implementations of the Handspring Phone Library support a common API. This API is broken up into various categories for easier management. This file defines the GSM category. These API calls are used to interact with the wireless network.

Definition in file HsPhoneGSMTypes.h.

Include dependency graph for HsPhoneGSMTypes.h:

Go to the source code of this file.

Data Structures

  • struct PhnPhoneBookInfoType
  • struct PhnGPRSPDPContextType
  • struct PhnGPRSPDPContextListNodeType

Defines

  • #define isValidSATNotificationType(s)
  • #define isValidPhnGPRSPDPType(t) ((t >= phnGPRSPDPTypeIP) && (t <= phnGPRSPDPTypePPP))
  • #define isValidPhnGPRSQOSType(t) ((t >= kGPRSQOSTypeRequired) && (t <= kGPRSQOSTypeMinimum))
  • #define isValidGSMSIMMessagesDialogKind(d) ((d >= gsmMessagesConfirmMove) && (d <= gsmMessagesCantReceive))
  • #define isValidGSMSATEventToneTypeEnum(x) (((x >= phnSATEventToneTypeDial) && (x <= phnSATEventToneTypeNegativeBeep)) || (x == phnSATEventToneTypeNoneSpecified))
  • #define isValidGSMSATEventSetupCallCallTypeEnum(x) ((x >= phnSATEventSetupCallCallTypeVoice) && (x <= phnSATEventSetupCallCallTypeFax))
  • #define GSMLockSelectorOperatorLock ('PN')
  • #define GSMLockSelectorProviderLock ('PP')
  • #define phnNetPrefGPRSPDPContextID 1
  • #define GSMLibRingsDbName "System Ring Tones"
  • #define kLineNumberUnknown 0
Special response values for PhnSATEventGetInkey (besides a single character)
  • #define phnSATInkeyResponseValueYes ((UInt32)'YES_')
  • #define phnSATInkeyResponseValueNo ((UInt32)'NO__')

Typedefs

  • typedef struct PhnPhoneBookInfoType * PhnPhoneBookInfoPtr
  • typedef UInt8 SATRequestType
  • typedef UInt8 SATDecisionType
  • typedef UInt8 SATNotificationType
  • typedef UInt16 SATSetupCallType
  • typedef UInt32 SATRefreshFile
  • typedef UInt16 SATRefreshType
  • typedef UInt8 PhnGPRSPDPType
  • typedef UInt8 PhnGPRSQOSType
  • typedef UInt8 GSMSIMMessagesDialogKind
  • typedef UInt8 GSMSATEventMenuFlag
  • typedef UInt8 GSMSATEventInputFormatEnum
  • typedef UInt8 GSMATEventInputEchoModeEnum
  • typedef UInt8 GSMSATEventToneTimeUnitEnum
  • typedef UInt16 GSMSATEventToneTypeEnum
  • typedef UInt8 GSMSATEventSetupCallCallTypeEnum
  • typedef UInt8 GSMSATDataSvcType

Enumerations

  • enum _SATRequestType {
    kSATSelectMainMenuItem,
    kSATClearText,
    kSATSetInkey,
    kSATSetInput,
    kSATMakeCall,
    kSATSelectItem = 6,
    kSATReqLaunchBrowser,
    kSATReqIdleModeText,
    kSATReqDataSrv,
    kSATReqPlayTone,
    kSATReqRefresh,
    kSATCancel = 95,
    kSATUnknownNotification,
    kSATApplicationBusy,
    kSATUserNotResponse,
    kSATEndSession,
    kSATReqSendDTMF
    }
  • enum _SATDecisionType {
    kSATSessionAborted,
    kSATItemSelected,
    kSATHelpRequested,
    kSATNavigateBack
    }
  • enum _SATNotificationType {
    kSATMainMenuAvailable,
    kSATDisplayText,
    kSATGetInkey,
    kSATGetInput,
    kSATSetupCall,
    kSATPlayTone,
    kSATDisplaySubmenus,
    kSATRefresh,
    kSATSendSS,
    kSATSendSMS,
    kSATSendUSSD,
    kSATLaunchBrowser,
    kSATIdleModeText,
    kSATRunAT,
    kSATDataSvc,
    kSATSendDTMF,
    kSATTimeout = 98,
    kSATSessionEnd = 99
    }
  • enum _SATSetupCallType {
    kSATSetupCallModeNotBusy,
    kSATSetupCallWithRedialModeNotBusy,
    kSATSetupCallHoldOtherCalls,
    kSATSetupCallWithRedialHoldOtherCalls,
    kSATSetupCallDisconnectOtherCalls,
    kSATSetupCallWithRedialDisconnectOtherCalls,
    kSATSetupCallMax
    }
  • enum _SATRefreshFile { kSATEFSimPhoneBook = 0x00000001 }
  • enum _SATRefreshType {
    kSATInitWithFullFileChange,
    kSATFileChange,
    kSATInitWithFileChange,
    kSATInit,
    kSATSIMReset,
    kSATMax
    }
  • enum _PhnGPRSPDPType {
    phnGPRSPDPTypeIP = 1,
    phnGPRSPDPTypePPP = 2
    }
  • enum _PhnGPRSQOSType {
    kGPRSQOSTypeRequired = 1,
    kGPRSQOSTypeMinimum = 2
    }
  • enum _GSMSIMMessagesDialogKind {
    gsmMessagesConfirmMove,
    gsmMessagesCantReceive
    }
  • enum _GSMSATEventMenuFlag {
    phnSATEventMenuFlagHelp = 1,
    phnSATEventMenuFlagNextAct = 2
    }
  • enum _GSMSATEventInputFormatEnum {
    phnSATEventInputFormatDigit = 0,
    phnSATEventInputFormatSMSChar = 1,
    phnSATEventInputFormatUCS2 = 2,
    phnSATEventInputFormatUnpacked = 3,
    phnSATEventInputFormatPacked = 4,
    phnSATEventInputFormatYesNo = 5,
    phnSATEventInputFormatUnknown = 255
    }
  • enum _GSMATEventInputEchoModeEnum {
    phnSATEventInputEchoModeShowInput = 0,
    phnSATEventInputEchoModeHideInput = 1
    }
  • enum _GSMSATEventToneTimeUnitEnum {
    phnSATEventToneTimeUnitMinutes = 0,
    phnSATEventToneTimeUnitSeconds = 1,
    phnSATEventToneTimeUnitDeciSeconds = 2
    }
  • enum _GSMSATEventToneTypeEnum {
    phnSATEventToneTypeNoneSpecified = 0xFFFF,
    phnSATEventToneTypeDial = 0,
    phnSATEventToneTypeBusy = 1,
    phnSATEventToneTypeCongestion = 2,
    phnSATEventToneTypeRadioAck = 3,
    phnSATEventToneTypeDropped = 4,
    phnSATEventToneTypeError = 5,
    phnSATEventToneTypeCallWaiting = 6,
    phnSATEventToneTypeRinging = 7,
    phnSATEventToneTypeGeneralBeep = 8,
    phnSATEventToneTypePositiveBeep = 9,
    phnSATEventToneTypeNegativeBeep = 10
    }
  • enum _GSMSATEventSetupCallCallTypeEnum {
    phnSATEventSetupCallCallTypeVoice = 0,
    phnSATEventSetupCallCallTypeData = 1,
    phnSATEventSetupCallCallTypeFax = 2
    }
  • enum _GSMSATDataSvcTypeEnum {
    phnSATEventDataSvcTypeOpenChannel = 1,
    phnSATEventDataSvcTypeSendData = 2,
    phnSATEventDataSvcTypeRcvData = 3,
    phnSATEventDataSvcTypeCloseChannel = 4
    }

Define Documentation

#define GSMLibRingsDbName "System Ring Tones"

Name of GSM RingTone DB

Definition at line 63 of file HsPhoneGSMTypes.h.

#define GSMLockSelectorOperatorLock ('PN')

Definition at line 41 of file HsPhoneGSMTypes.h.

#define GSMLockSelectorProviderLock ('PP')

Definition at line 42 of file HsPhoneGSMTypes.h.

#define isValidGSMSATEventSetupCallCallTypeEnum ( x ) ((x >= phnSATEventSetupCallCallTypeVoice) && (x <= phnSATEventSetupCallCallTypeFax))

Definition at line 357 of file HsPhoneGSMTypes.h.

#define isValidGSMSATEventToneTypeEnum ( x ) (((x >= phnSATEventToneTypeDial) && (x <= phnSATEventToneTypeNegativeBeep)) || (x == phnSATEventToneTypeNoneSpecified))

Definition at line 332 of file HsPhoneGSMTypes.h.

#define isValidGSMSIMMessagesDialogKind ( d ) ((d >= gsmMessagesConfirmMove) && (d <= gsmMessagesCantReceive))

Definition at line 248 of file HsPhoneGSMTypes.h.

#define isValidPhnGPRSPDPType ( t ) ((t >= phnGPRSPDPTypeIP) && (t <= phnGPRSPDPTypePPP))

Definition at line 199 of file HsPhoneGSMTypes.h.

#define isValidPhnGPRSQOSType ( t ) ((t >= kGPRSQOSTypeRequired) && (t <= kGPRSQOSTypeMinimum))

Definition at line 212 of file HsPhoneGSMTypes.h.

#define isValidSATNotificationType ( s )

Value:

(((s >= kSATMainMenuAvailable) && (s <= kSATSendUSSD)) \
              || (s == kSATTimeout) || (s == kSATSessionEnd))

Definition at line 164 of file HsPhoneGSMTypes.h.

#define kLineNumberUnknown 0

Definition at line 67 of file HsPhoneGSMTypes.h.

#define phnNetPrefGPRSPDPContextID 1

Definition at line 52 of file HsPhoneGSMTypes.h.

#define phnSATInkeyResponseValueNo ((UInt32)'NO__')

Definition at line 297 of file HsPhoneGSMTypes.h.

#define phnSATInkeyResponseValueYes ((UInt32)'YES_')

Definition at line 296 of file HsPhoneGSMTypes.h.

Typedef Documentation

typedef UInt8 GSMATEventInputEchoModeEnum

Definition at line 289 of file HsPhoneGSMTypes.h.

typedef UInt8 GSMSATDataSvcType

Definition at line 355 of file HsPhoneGSMTypes.h.

typedef UInt8 GSMSATEventInputFormatEnum

Definition at line 280 of file HsPhoneGSMTypes.h.

typedef UInt8 GSMSATEventMenuFlag

Definition at line 258 of file HsPhoneGSMTypes.h.

typedef UInt8 GSMSATEventSetupCallCallTypeEnum

Definition at line 344 of file HsPhoneGSMTypes.h.

typedef UInt8 GSMSATEventToneTimeUnitEnum

Definition at line 310 of file HsPhoneGSMTypes.h.

typedef UInt16 GSMSATEventToneTypeEnum

Definition at line 330 of file HsPhoneGSMTypes.h.

typedef UInt8 GSMSIMMessagesDialogKind

Definition at line 246 of file HsPhoneGSMTypes.h.

typedef UInt8 PhnGPRSPDPType

Definition at line 197 of file HsPhoneGSMTypes.h.

typedef UInt8 PhnGPRSQOSType

Definition at line 210 of file HsPhoneGSMTypes.h.

typedef struct PhnPhoneBookInfoType * PhnPhoneBookInfoPtr

typedef UInt8 SATDecisionType

Definition at line 118 of file HsPhoneGSMTypes.h.

typedef UInt8 SATNotificationType

Definition at line 144 of file HsPhoneGSMTypes.h.

typedef UInt32 SATRefreshFile

Definition at line 174 of file HsPhoneGSMTypes.h.

typedef UInt16 SATRefreshType

Definition at line 186 of file HsPhoneGSMTypes.h.

typedef UInt8 SATRequestType

Definition at line 106 of file HsPhoneGSMTypes.h.

typedef UInt16 SATSetupCallType

Definition at line 162 of file HsPhoneGSMTypes.h.

Enumeration Type Documentation

enum _GSMATEventInputEchoModeEnum

Enumerator:
phnSATEventInputEchoModeShowInput | Show input as entered
phnSATEventInputEchoModeHideInput | Display bullets or boxes instead of entered characters

Definition at line 285 of file HsPhoneGSMTypes.h.

00294    {*/

enum _GSMSATDataSvcTypeEnum

Possible values of serviceType for PhnSATEventDataSvc

Enumerator:
phnSATEventDataSvcTypeOpenChannel
phnSATEventDataSvcTypeSendData
phnSATEventDataSvcTypeRcvData
phnSATEventDataSvcTypeCloseChannel

Definition at line 349 of file HsPhoneGSMTypes.h.

enum _GSMSATEventInputFormatEnum

Possible values of format for PhnSATEventGetInkey and PhnSATEventGetInput

Enumerator:
phnSATEventInputFormatDigit | Get Inkey or Get Input 0-9, #, *, or +
phnSATEventInputFormatSMSChar | Get Inkey or Get Input SMS character set
phnSATEventInputFormatUCS2 | Get Inkey or Get Input
phnSATEventInputFormatUnpacked | Get Input only
phnSATEventInputFormatPacked | Get Input only
phnSATEventInputFormatYesNo | Get Inkey or Get Input
phnSATEventInputFormatUnknown | KEEP THIS ONE AT THE END

Definition at line 264 of file HsPhoneGSMTypes.h.

00284                                   {

enum _GSMSATEventMenuFlag

Enumerator:
phnSATEventMenuFlagHelp | help is available
phnSATEventMenuFlagNextAct | nextAction is valid

Definition at line 253 of file HsPhoneGSMTypes.h.

00263                                  {

enum _GSMSATEventSetupCallCallTypeEnum

Possible values of callType for PhnSATEventSetupCall

Enumerator:
phnSATEventSetupCallCallTypeVoice | SIM wants to set up a voice call
phnSATEventSetupCallCallTypeData | SIM wants to set up a data call
phnSATEventSetupCallCallTypeFax | SIM wants to set up a fax

Definition at line 338 of file HsPhoneGSMTypes.h.

00348                             {

enum _GSMSATEventToneTimeUnitEnum

Possible values of timeUnit for PhnSATEventPlayTone

Enumerator:
phnSATEventToneTimeUnitMinutes | Duration specified in minutes
phnSATEventToneTimeUnitSeconds | Duration specified in seconds
phnSATEventToneTimeUnitDeciSeconds | Duration specified in 1/10 seconds

Definition at line 304 of file HsPhoneGSMTypes.h.

00314                               {

enum _GSMSATEventToneTypeEnum

Possible values of toneType for PhnSATEventPlayTone

Enumerator:
phnSATEventToneTypeNoneSpecified Means just do a normal beep...
phnSATEventToneTypeDial
phnSATEventToneTypeBusy
phnSATEventToneTypeCongestion
phnSATEventToneTypeRadioAck
phnSATEventToneTypeDropped
phnSATEventToneTypeError
phnSATEventToneTypeCallWaiting
phnSATEventToneTypeRinging
phnSATEventToneTypeGeneralBeep
phnSATEventToneTypePositiveBeep
phnSATEventToneTypeNegativeBeep

Definition at line 315 of file HsPhoneGSMTypes.h.

00337                                        {

enum _GSMSIMMessagesDialogKind

Enumerator:
gsmMessagesConfirmMove
gsmMessagesCantReceive

Definition at line 242 of file HsPhoneGSMTypes.h.

00252                           {

enum _PhnGPRSPDPType

Enumerator:
phnGPRSPDPTypeIP
phnGPRSPDPTypePPP

Definition at line 191 of file HsPhoneGSMTypes.h.

00191 {
00192   phnGPRSPDPTypeIP = 1,         /**<        */
00193   phnGPRSPDPTypePPP = 2         /**<        */
00194 } _PhnGPRSPDPType;
00195

enum _PhnGPRSQOSType

Enumerator:
kGPRSQOSTypeRequired
kGPRSQOSTypeMinimum

Definition at line 204 of file HsPhoneGSMTypes.h.

00204 {
00205   kGPRSQOSTypeRequired = 1,     /**<        */
00206   kGPRSQOSTypeMinimum = 2       /**<        */
00207 } _PhnGPRSQOSType;
00208

enum _SATDecisionType

decision we are sending to SIM

Enumerator:
kSATSessionAborted
kSATItemSelected
kSATHelpRequested
kSATNavigateBack

Definition at line 111 of file HsPhoneGSMTypes.h.

00111              {
00112     kSATSessionAborted,     /**<        */
00113     kSATItemSelected,       /**<        */
00114     kSATHelpRequested,      /**<        */
00115     kSATNavigateBack        /**<        */
00116 } _SATDecisionType;

enum _SATNotificationType

type of notification sent by SAT

Enumerator:
kSATMainMenuAvailable
kSATDisplayText
kSATGetInkey
kSATGetInput
kSATSetupCall
kSATPlayTone
kSATDisplaySubmenus
kSATRefresh application do not get this notification
kSATSendSS
kSATSendSMS
kSATSendUSSD
kSATLaunchBrowser
kSATIdleModeText
kSATRunAT
kSATDataSvc
kSATSendDTMF
kSATTimeout
kSATSessionEnd

Definition at line 123 of file HsPhoneGSMTypes.h.

00123              {
00124     kSATMainMenuAvailable,      /**<        */
00125     kSATDisplayText,        /**<        */
00126     kSATGetInkey,           /**<        */
00127     kSATGetInput,           /**<        */
00128     kSATSetupCall,          /**<        */
00129     kSATPlayTone,           /**<        */
00130     kSATDisplaySubmenus,        /**<        */
00131     kSATRefresh,            /**< application do not get this notification */
00132     kSATSendSS,         /**<        */
00133     kSATSendSMS,            /**<        */
00134     kSATSendUSSD,           /**<        */
00135     kSATLaunchBrowser,          /**<        */
00136     kSATIdleModeText,           /**<        */
00137     kSATRunAT,          /**<        */
00138     kSATDataSvc,            /**<        */
00139     kSATSendDTMF,           /**<        */
00140     kSATTimeout     = 98,   /**<        */
00141     kSATSessionEnd  = 99        /**<        */
00142 } _SATNotificationType;

enum _SATRefreshFile

Enumerator:
kSATEFSimPhoneBook

Definition at line 168 of file HsPhoneGSMTypes.h.

00168 {
00169   kSATEFSimPhoneBook = 0x00000001
00170
00171 }_SATRefreshFile;
00172

enum _SATRefreshType

Enumerator:
kSATInitWithFullFileChange
kSATFileChange
kSATInitWithFileChange
kSATInit
kSATSIMReset
kSATMax

Definition at line 176 of file HsPhoneGSMTypes.h.

00176 {
00177   kSATInitWithFullFileChange,
00178   kSATFileChange,
00179   kSATInitWithFileChange,
00180   kSATInit,
00181   kSATSIMReset,
00182   kSATMax
00183 }_SATRefreshType;
00184

enum _SATRequestType

SIM Application Toolkit's data types type of request/respond we are sending

Enumerator:
kSATSelectMainMenuItem
kSATClearText
kSATSetInkey
kSATSetInput
kSATMakeCall
kSATSelectItem
kSATReqLaunchBrowser
kSATReqIdleModeText
kSATReqDataSrv
kSATReqPlayTone
kSATReqRefresh
kSATCancel
kSATUnknownNotification
kSATApplicationBusy
kSATUserNotResponse
kSATEndSession
kSATReqSendDTMF

Definition at line 86 of file HsPhoneGSMTypes.h.

00086              {
00087     kSATSelectMainMenuItem,     /**<        */
00088     kSATClearText,          /**<        */
00089     kSATSetInkey,           /**<        */
00090     kSATSetInput,           /**<        */
00091     kSATMakeCall,           /**<        */
00092     kSATSelectItem = 6,     /**<        */
00093     kSATReqLaunchBrowser,       /**<        */
00094     kSATReqIdleModeText,
00095     kSATReqDataSrv,
00096     kSATReqPlayTone,            /**<        */
00097     kSATReqRefresh,         /**<        */
00098     kSATCancel     = 95,    /**<        */
00099     kSATUnknownNotification,    /**<        */
00100     kSATApplicationBusy,        /**<        */
00101     kSATUserNotResponse,        /**<        */
00102     kSATEndSession,         /**<        */
00103     kSATReqSendDTMF         /**<        */
00104 } _SATRequestType;

enum _SATSetupCallType

Enumerator:
kSATSetupCallModeNotBusy
kSATSetupCallWithRedialModeNotBusy
kSATSetupCallHoldOtherCalls
kSATSetupCallWithRedialHoldOtherCalls
kSATSetupCallDisconnectOtherCalls
kSATSetupCallWithRedialDisconnectOtherCalls
kSATSetupCallMax

Definition at line 150 of file HsPhoneGSMTypes.h.

00151 {
00152   kSATSetupCallModeNotBusy,
00153   kSATSetupCallWithRedialModeNotBusy,
00154   kSATSetupCallHoldOtherCalls,
00155   kSATSetupCallWithRedialHoldOtherCalls,
00156   kSATSetupCallDisconnectOtherCalls,
00157   kSATSetupCallWithRedialDisconnectOtherCalls,
00158
00159   kSATSetupCallMax// do not use
00160 }_SATSetupCallType;

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:07:19 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » telephony

HsPhoneIOTA.h File Reference

Detailed Description

Header File for Phone Library API ---- IOTA CATEGORY.

Notes: All implementations of the Handspring Phone Library support a common API. This API is broken up into various categories for easier management. This file defines the IOTA category. These API calls are used for features specific to IOTA operation on CDMA networks.

Definition in file HsPhoneIOTA.h.

Include dependency graph for HsPhoneIOTA.h:

Go to the source code of this file.

Defines

  • #define isValidPhnIOTAStatus(i) ((i >= phnIOTAUnknown) && (i <= phnIOTANAMSelect))

Define Documentation

#define isValidPhnIOTAStatus ( i ) ((i >= phnIOTAUnknown) && (i <= phnIOTANAMSelect))

error codes returned by phone library functions No definition.

Definition at line 38 of file HsPhoneIOTA.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:07:19 2008 for Palm API Guide


Header Files » Incs » common » libraries » telephony

HsPhoneIOTATypes.h File Reference

Detailed Description

Header File for Phone Library API ---- IOTA CATEGORY.

NOTES: All implementations of the Handspring Phone Library support a common API. This API is broken up into various categories for easier management. This file defines the IOTA category. These API calls are used for features specific to IOTA operation on CDMA networks.

Definition in file HsPhoneIOTATypes.h.

Include dependency graph for HsPhoneIOTATypes.h:

Go to the source code of this file.

Data Structures

  • struct PhnIOTAReportType
  • struct PhnIOTAPhnTlsRcUrlType
  • struct PhnIOTAPhnNAISIPEdgeProxyType
  • struct PhnIOTAPhnProxyAddrWdpType
  • struct PhnIOTAPhnNAISIPCfgSvr
  • struct PhnIOTAPhnNAIPPGType
  • struct PhnIOTAPhnNAIIMStore
  • struct PhnIOTAPhnNAISIPDataxchType
  • struct PhnIOTAPhnNAISIPDatagwyType
  • struct PhnIOTAPhnSIPRetryTimerType
  • struct PhnIOTAPhnSIPRetryCntType
  • struct PhnIOTAPhnDlsLockType
    Holds lock state of user's ability to change the download server URL address. More...
  • struct PhnIOTAPhnHomepagetype
  • struct PhnIOTAPhnTrustedDomainType
  • struct tagIOTANotificationEventType

Defines

  • #define phnIOTAEvent 'Hita'
  • #define isValidPhnIOTAItemType(i) ((i >= phnIOTAPhnBootNAIUrl) && (i <phnLibIOTAItemLast))
  • #define kIOTACertMaxBlocks 132
  • #define kIOTACertMaxBlockLen 127
  • #define kIOTAProxyADDRMaxLen 20
  • #define kIOTANaiSipEdgePxyMaxBlocks 4
  • #define kIOTAPxyAddrWdpMaxBlocks 4
  • #define kIOTAUrlMaxLen 128
  • #define kIOTAUrlArrayMaxLen 65
  • #define kIOTASipCfgBlocks 4
  • #define kIOTANaiPpgMaxBlocks 4
  • #define kIOTANaiIMStoreMaxBlocks 8
  • #define kIOTANaiSipDataxchMaxBlocks 8
  • #define kIOTANaiSipDdatgwyMaxBlocks 8
  • #define kIOTAPhnSipRetryTimerMaxLen 9
  • #define kIOTAPhnSipRetryTimerMaxBloacks 4
  • #define kIOTAPhnSipRetryCntMaxLen 9
  • #define kIOTAPhnSipRetryCntMaxBlocks 4
  • #define kIOTATrustedDomainMaxLen 64
Text Header elements
  • #define IOTAHeaderEscapeSeq "X-Wap-Application-Id: "
  • #define IOTATextHeader "X-Wap-Application-Id: x-wap-application:iota.ua"
  • #define IOTATextHeaderLength 47
  • #define IOTATextHeaderTerminator '\n'

Typedefs

  • typedef UInt8 PhnIOTAItemType
  • typedef tagIOTANotificationEventType IOTANotificationEventType

Enumerations

  • enum PhnIOTAStatus {
    phnIOTAUnknown = 0,
    phnIOTAStart,
    phnIOTAEnd,
    phnIOTACommit,
    phnIOTANAMSelect
    }
  • enum PhnIOTAItemEnum {
    phnIOTAItemBootURL = 0x00,
    phnIOTAItemBootNAIURL = 0x01,
    phnIOTAItemTrustedDomain = 0x02,
    phnIOTAItemHomepageURL = 0x03,
    phnIOTAItemVendingURL = 0x04,
    phnIOTAItemDownloadServerURL = 0x05,
    phnIOTAItemDownloadServerLock = 0x06,
    phnIOTAItemConnectionTimeout = 0x07,
    phnIOTAItemPriWAPPushProxyGatewayURL = 0x08,
    phnIOTAItemSecWAPPushProxyGatewayURL = 0x09,
    phnIOTAItemPriProxyWDPAddress = 0x0A,
    phnIOTAItemSecProxyWDPAddress = 0x0B,
    phnIOTAItemPriSIPConfigServer = 0x0C,
    phnIOTAItemSecSIPConfigServer = 0x0D,
    phnIOTAItemPriSIPEdgeProxyGateway = 0x0E,
    phnIOTAItemSecSIPEdgeProxyGateway = 0x0F,
    phnIOTAItemPriDataExchangeURL = 0x10,
    phnIOTAItemSecDataExchangeURL = 0x11,
    phnIOTAItemPriDataGatewayURL = 0x12,
    phnIOTAItemSecDataGatewayURL = 0x13,
    phnIOTAItemPriSIPRetryTimer = 0x14,
    phnIOTAItemSecSIPRetryTimer = 0x15,
    phnIOTAItemPriSIPRetryCount = 0x16,
    phnIOTAItemSecSIPRetryCount = 0x17,
    phnIOTAItemPriIMMessageStore = 0x18,
    phnIOTAItemSecIMMessageStore = 0x19,
    phnIOTAItemRootCertificate1 = 0x40,
    phnIOTAItemRootCertificate2 = 0x41,
    phnIOTAItemRootCertificate3 = 0x42,
    phnIOTAItemRootCertificate4 = 0x43,
    phnIOTAItemPRLStorageSize = 0x50,
    phnIOTAItemSIPUsername = 0x51,
    phnIOTAItemSIPPassword = 0x52,
    phnIOTAItemLastNVItem = 0x60,
    phnIOTAItemUnknown = 0xFF
    }

Define Documentation

#define IOTAHeaderEscapeSeq "X-Wap-Application-Id: "

start sequence of the header

Definition at line 76 of file HsPhoneIOTATypes.h.

#define IOTATextHeader "X-Wap-Application-Id: x-wap-application:iota.ua"

beginning of an IOTA header

Definition at line 77 of file HsPhoneIOTATypes.h.

#define IOTATextHeaderLength 47

length of the header

Definition at line 78 of file HsPhoneIOTATypes.h.

#define IOTATextHeaderTerminator '\n'

IOTA headers terminate at the line feed

Definition at line 80 of file HsPhoneIOTATypes.h.

#define isValidPhnIOTAItemType ( i ) ((i >= phnIOTAPhnBootNAIUrl) && (i <phnLibIOTAItemLast))

Definition at line 148 of file HsPhoneIOTATypes.h.

#define kIOTACertMaxBlockLen 127

Definition at line 154 of file HsPhoneIOTATypes.h.

#define kIOTACertMaxBlocks 132

Index should be < 12, starting from 0

Definition at line 153 of file HsPhoneIOTATypes.h.

#define kIOTANaiIMStoreMaxBlocks 8

Definition at line 218 of file HsPhoneIOTATypes.h.

#define kIOTANaiPpgMaxBlocks 4

Definition at line 206 of file HsPhoneIOTATypes.h.

#define kIOTANaiSipDataxchMaxBlocks 8

Definition at line 230 of file HsPhoneIOTATypes.h.

#define kIOTANaiSipDdatgwyMaxBlocks 8

Definition at line 242 of file HsPhoneIOTATypes.h.

#define kIOTANaiSipEdgePxyMaxBlocks 4

Definition at line 167 of file HsPhoneIOTATypes.h.

#define kIOTAPhnSipRetryCntMaxBlocks 4

Definition at line 270 of file HsPhoneIOTATypes.h.

#define kIOTAPhnSipRetryCntMaxLen 9

Definition at line 269 of file HsPhoneIOTATypes.h.

#define kIOTAPhnSipRetryTimerMaxBloacks 4

Definition at line 256 of file HsPhoneIOTATypes.h.

#define kIOTAPhnSipRetryTimerMaxLen 9

Definition at line 255 of file HsPhoneIOTATypes.h.

#define kIOTAProxyADDRMaxLen 20

Definition at line 166 of file HsPhoneIOTATypes.h.

#define kIOTAPxyAddrWdpMaxBlocks 4

Definition at line 179 of file HsPhoneIOTATypes.h.

#define kIOTASipCfgBlocks 4

Definition at line 194 of file HsPhoneIOTATypes.h.

#define kIOTATrustedDomainMaxLen 64

Definition at line 302 of file HsPhoneIOTATypes.h.

#define kIOTAUrlArrayMaxLen 65

Definition at line 192 of file HsPhoneIOTATypes.h.

#define kIOTAUrlMaxLen 128

Definition at line 191 of file HsPhoneIOTATypes.h.

#define phnIOTAEvent 'Hita'

Definition at line 83 of file HsPhoneIOTATypes.h.

Typedef Documentation

typedef struct tagIOTANotificationEventType IOTANotificationEventType

Structure passed to the callbacks registered for incoming IOTA notifications

typedef UInt8 PhnIOTAItemType

let's hope it never gets beyond 256 items

Definition at line 86 of file HsPhoneIOTATypes.h.

Enumeration Type Documentation

enum PhnIOTAItemEnum

Items stored in the radio NV (mostly for Sprint support). Some of these items may be used for other carriers in the future. Most of these items will be match the initial TIL implementation since we are focusing on Sprint support. We may be able to leverage the NVFlash support in the future and get away from the radio NV for most of these (unless we need UPST support).

Enumerator:
phnIOTAItemBootURL | provisioning URL
phnIOTAItemBootNAIURL | provisioning URL
phnIOTAItemTrustedDomain | trusted domain for provisioning. All URLs must come from this
phnIOTAItemHomepageURL | default browser homepage
phnIOTAItemVendingURL | vending URL
phnIOTAItemDownloadServerURL | download server URL
phnIOTAItemDownloadServerLock | state of items downloaded from the download server (locked or not)
phnIOTAItemConnectionTimeout | timeout for IOTA connections
phnIOTAItemPriWAPPushProxyGatewayURL | Primary WAP push gateway
phnIOTAItemSecWAPPushProxyGatewayURL | Secondary WAP push gateway
phnIOTAItemPriProxyWDPAddress | WDP address. Translate to the NGG for profile 1
phnIOTAItemSecProxyWDPAddress | WDP address. Translate to the NGG for profile 1
phnIOTAItemPriSIPConfigServer | Primary Config server
phnIOTAItemSecSIPConfigServer | Secondary Config server
phnIOTAItemPriSIPEdgeProxyGateway | Primary SIP Proxy Edge gateway
phnIOTAItemSecSIPEdgeProxyGateway | Secondary SIP Proxy Edge gateway
phnIOTAItemPriDataExchangeURL | Primary Data Exchange URL
phnIOTAItemSecDataExchangeURL | Secondary Data Exchange URL
phnIOTAItemPriDataGatewayURL | Primary Data Gateway URL
phnIOTAItemSecDataGatewayURL | Secondary Data Gateway URL
phnIOTAItemPriSIPRetryTimer | Primary SIP Retry timer
phnIOTAItemSecSIPRetryTimer | Secondary SIP Retry timer
phnIOTAItemPriSIPRetryCount | Primary SIP Retry count
phnIOTAItemSecSIPRetryCount | Secondary SIP Retry count
phnIOTAItemPriIMMessageStore | Primary IM Message store
phnIOTAItemSecIMMessageStore | Secondary IM Message store
phnIOTAItemRootCertificate1 | Root certificate #1
phnIOTAItemRootCertificate2 | Root certificate #2
phnIOTAItemRootCertificate3 | Root certificate #3
phnIOTAItemRootCertificate4 | Root certificate #4
phnIOTAItemPRLStorageSize | max PRL size radio supports
phnIOTAItemSIPUsername | Username for SIP accounts
phnIOTAItemSIPPassword | password for SIP accounts
phnIOTAItemLastNVItem | last IOTA NV Item
phnIOTAItemUnknown | unknown item

Definition at line 95 of file HsPhoneIOTATypes.h.

00096 {
00097   phnIOTAItemBootURL                    = 0x00, /**< provisioning URL */
00098   phnIOTAItemBootNAIURL                 = 0x01, /**< provisioning URL */
00099   phnIOTAItemTrustedDomain              = 0x02, /**< trusted domain for provisioning.  All URLs must come from this */
00100   phnIOTAItemHomepageURL                = 0x03, /**< default browser homepage */
00101   phnIOTAItemVendingURL                 = 0x04, /**< vending URL */
00102   phnIOTAItemDownloadServerURL          = 0x05, /**< download server URL */
00103   phnIOTAItemDownloadServerLock         = 0x06, /**< state of items downloaded from the download server (locked or not) */
00104   phnIOTAItemConnectionTimeout          = 0x07, /**< timeout for IOTA connections */
00105   phnIOTAItemPriWAPPushProxyGatewayURL  = 0x08, /**< Primary WAP push gateway */
00106   phnIOTAItemSecWAPPushProxyGatewayURL  = 0x09, /**< Secondary WAP push gateway */
00107
00108   // The following items are indexed for each PDP profile
00109   // Sprint has 2 profiles, so these are indexed 0..1
00110   phnIOTAItemPriProxyWDPAddress         = 0x0A, /**< WDP address. Translate to the NGG for profile 1 */
00111   phnIOTAItemSecProxyWDPAddress         = 0x0B, /**< WDP address. Translate to the NGG for profile 1 */
00112   phnIOTAItemPriSIPConfigServer         = 0x0C, /**< Primary Config server */
00113   phnIOTAItemSecSIPConfigServer         = 0x0D, /**< Secondary Config server */
00114   phnIOTAItemPriSIPEdgeProxyGateway     = 0x0E, /**< Primary SIP Proxy Edge gateway */
00115   phnIOTAItemSecSIPEdgeProxyGateway     = 0x0F, /**< Secondary SIP Proxy Edge gateway */
00116   phnIOTAItemPriDataExchangeURL         = 0x10, /**< Primary Data Exchange URL */
00117   phnIOTAItemSecDataExchangeURL         = 0x11, /**< Secondary Data Exchange URL */
00118   phnIOTAItemPriDataGatewayURL          = 0x12, /**< Primary Data Gateway URL */
00119   phnIOTAItemSecDataGatewayURL          = 0x13, /**< Secondary Data Gateway URL */
00120   phnIOTAItemPriSIPRetryTimer           = 0x14, /**< Primary SIP Retry timer */
00121   phnIOTAItemSecSIPRetryTimer           = 0x15, /**< Secondary SIP Retry timer */
00122   phnIOTAItemPriSIPRetryCount           = 0x16, /**< Primary SIP Retry count */
00123   phnIOTAItemSecSIPRetryCount           = 0x17, /**< Secondary SIP Retry count */
00124   phnIOTAItemPriIMMessageStore          = 0x18, /**< Primary IM Message store */
00125   phnIOTAItemSecIMMessageStore          = 0x19, /**< Secondary IM Message store */
00126
00127
00128   phnIOTAItemRootCertificate1           = 0x40, /**< Root certificate #1 */
00129   phnIOTAItemRootCertificate2           = 0x41, /**< Root certificate #2 */
00130   phnIOTAItemRootCertificate3           = 0x42, /**< Root certificate #3 */
00131   phnIOTAItemRootCertificate4           = 0x43, /**< Root certificate #4 */
00132
00133   // Sprint items that used to be hard-coded in the IOTA app but now
00134   // moved here, since different radios may possibly support different values.
00135   phnIOTAItemPRLStorageSize             = 0x50, /**< max PRL size radio supports */
00136
00137   // items that are listed as Verizon requirements
00138   phnIOTAItemSIPUsername                = 0x51, /**< Username for SIP accounts */
00139   phnIOTAItemSIPPassword                = 0x52, /**< password for SIP accounts */
00140
00141   // last item
00142   phnIOTAItemLastNVItem                 = 0x60, /**< last IOTA NV Item */
00143
00144   phnIOTAItemUnknown                    = 0xFF  /**< unknown item */
00145 }

enum PhnIOTAStatus

Enumerator:
phnIOTAUnknown
phnIOTAStart
phnIOTAEnd
phnIOTACommit
phnIOTANAMSelect

Definition at line 45 of file HsPhoneIOTATypes.h.

00046 {
00047   phnIOTAUnknown = 0,       /**<        */
00048     phnIOTAStart,       /**<        */
00049     phnIOTAEnd,     /**<        */
00050     phnIOTACommit,      /**<        */
00051     phnIOTANAMSelect    /**<        */
00052 }

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:07:20 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » telephony

HsPhoneLibrary.h File Reference

Detailed Description

Header File for Phone Library API ---- LIBRARY CATEGORY.

Notes: All implementations of the Handspring Phone Library support a common API. This API is broken up into various categories for easier management. This file defines the LIBRARY category. These API calls are used for basic Palm Library operation.

Definition in file HsPhoneLibrary.h.

Include dependency graph for HsPhoneLibrary.h:

Go to the source code of this file.

Functions

  • Err PhnLibOpen (UInt16 refNum)
    Open the phone library. Global space has been created on SysLibLoad already. This function just manages the openCount.
  • Err PhnLibClose (UInt16 refNum)
    Closes up a phone library. This function does not free global space. It just manages the openCount.
  • Err PhnLibSleep (UInt16 refNum)
    (For System Use Only)
  • Err PhnLibWake (UInt16 refNum)
    (For System Use Only)
  • Err PhnLibGetLibAPIVersion (UInt16 refNum, UInt32 *dwVerP)
    This function is used to indicate the version number of the current Phone Library.
  • void PhnLibUninstall (UInt16 refNum)
    This is an unsupported function starting with Treo 600.
  • Err PhnLibRegister (UInt16 refNum, DWord creator, UInt16 services)
    Register or unregister (when services == 0) an application so that notifications from the Phone Library (Chapter 13) can be broadcasted to registered applications.

Function Documentation

Err PhnLibClose ( UInt16 refNum )

Closes up a phone library. This function does not free global space. It just manages the openCount.

Parameters:
refNum,: IN: Library reference number returned by HsGetPhoneLibrary().
Return values:
Err Error code.

Err PhnLibGetLibAPIVersion | ( | UInt16 | refNum,
 |  | UInt32 * | dwVerP
 | ) |  |

This function is used to indicate the version number of the current Phone Library.

Parameters:
refNum,: IN: Library reference number returned by HsGetPhoneLibrary().
dwVerP,: IN: Version number
Return values:
Err Error code.

Err PhnLibOpen ( UInt16 refNum )

Open the phone library. Global space has been created on SysLibLoad already. This function just manages the openCount.

Parameters:
refNum,: IN: Library reference number returned by HsGetPhoneLibrary().
Return values:
Err Error code.

Err PhnLibRegister | ( | UInt16 | refNum,
 |  | DWord | creator,
 |  | UInt16 | services
 | ) |  |

Register or unregister (when services == 0) an application so that notifications from the Phone Library (Chapter 13) can be broadcasted to registered applications.

Parameters:
refNum,: IN: Library reference number obtained from SysLibLoad.
creator,: IN: Creator ID of application registering for notifications
services,: IN: Bitfield of services for which notifications are desired. See PhnServiceClassType for bit definitions. Register with a value of 0 to unregister for notifications.
Return values:
0 for success; otherwise failed

Err PhnLibSleep ( UInt16 refNum )

(For System Use Only)

Parameters:
refNum,: IN:
Return values:
Err Error code.

void PhnLibUninstall ( UInt16 refNum )

This is an unsupported function starting with Treo 600.

Parameters:
refNum,: IN: Library reference number returned by HsGetPhoneLibrary().
Return values:
Nothing

Err PhnLibWake ( UInt16 refNum )

(For System Use Only)

Parameters:
refNum,: IN:
Return values:
Err Error code.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:07:20 2008 for Palm API Guide


Header Files » Incs » common » libraries » telephony

hsPhoneLocationTypes.h File Reference

Detailed Description

File contains Phone Location data types.

Definition in file hsPhoneLocationTypes.h.

Include dependency graph for hsPhoneLocationTypes.h:

Go to the source code of this file.

Typedefs

  • typedef UInt8 PhnPDSessionConfigParamType

Enumerations

  • enum _PhnPDSessionConfigParamType {
    PhnPDConfigIPAddr = 1,
    PhnPDConfigPortID,
    PhnPDConfigGPSLock,
    PhnPDConfigPTLMMode
    }

Typedef Documentation

typedef UInt8 PhnPDSessionConfigParamType

error codes returned by phone library functions

Definition at line 38 of file hsPhoneLocationTypes.h.

Enumeration Type Documentation

enum _PhnPDSessionConfigParamType

Enumerator:
PhnPDConfigIPAddr | Binary value of the Position Determination Entity (PDE) IP Address
PhnPDConfigPortID | Binary value of the PDE Port ID.
PhnPDConfigGPSLock | Level of GPS lock set in the modem.
PhnPDConfigPTLMMode | The protocol transport layer mechanism to be used to talk to the PDE.

Definition at line 44 of file hsPhoneLocationTypes.h.

00045   {
00046     PhnPDConfigIPAddr = 1,  /**< Binary value of the Position Determination Entity (PDE) IP Address */
00047     PhnPDConfigPortID,      /**< Binary value of the PDE Port ID. */
00048     PhnPDConfigGPSLock,     /**< Level of GPS lock set in the modem. */
00049     PhnPDConfigPTLMMode     /**< The protocol transport layer mechanism to be used to talk to the PDE. */
00050   }_PhnPDSessionConfigParamType;

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:07:20 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » telephony

HsPhoneMisc.h File Reference

Detailed Description

Header File for Phone Library API ---- MISC CATEGORY.

Notes: All implementations of the Handspring Phone Library support a common API. This API is broken up into various categories for easier management. This file defines the Miscellaneous category. These API calls are Miscellaneous calls that don't fit into any other category. Many of them are device control.

Definition in file HsPhoneMisc.h.

Include dependency graph for HsPhoneMisc.h:

Go to the source code of this file.

Functions

  • Err PhnLibGetLineState (UInt16 refNum, UInt16 line, PhnLineStatePtr lineState)
    Retrieve the Line state.
  • Err PhnLibGetRadioState (UInt16 refNum, PhnRadioStatePtr radioState)
    Retrieve state information about the radio.
  • Boolean PhnLibCardInfo (UInt16 refNum, CharPtr *manufacturer, CharPtr *model, CharPtr *version, CharPtr *serial)
    Parameters:
    refNum,: IN:

  • Err PhnLibConnectionAvailable (UInt16 refNum, PhnConnectionEnum connection, Boolean *pAvailable)
    Checks to see if a connection can be made.
  • Err PhnLibStartVibrate (UInt16 refNum, Boolean pulse, Boolean repeat)
    This API have been deprecated. Please use “HsIndicatorState.”.
  • Err PhnLibStopVibrate (UInt16 refNum)
    This API have been deprecated. Please use “HsIndicatorState.”.
  • Err PhnLibErrorRate (UInt16 refNum, WordPtr errorRate)
    Parameters:
    refNum,: IN:

  • void PhnLibGetErrorText (UInt16 refNum, Err error, CharPtr buffer, UInt16 bufferLen)
    Parameters:
    refNum,: IN:

  • UInt16 PhnLibGetCallCountByService (UInt16 refNum, PhoneServiceClassType service)
    Locate the call item that has the specified service if such item exists return the total number of call items that has the same service.
  • Err PhnLibGetEchoCancellation (UInt16 refNum, Boolean *echoCancellationOn)
    Parameters:
    refNum,: IN:

  • Err PhnLibSetEchoCancellation (UInt16 refNum, Boolean echoCancellationOn)
    Parameters:
    refNum,: IN:

  • Err PhnLibGetEquipmentMode (UInt16 refNum, PhnEquipmentMode *equipmentMode)
    Parameters:
    refNum,: IN:

  • Err PhnLibSetEquipmentMode (UInt16 refNum, PhnEquipmentMode equipmentMode)
    Parameters:
    refNum,: IN:

  • Err PhnLibGetHeadsetConnectedInfo (UInt16 refNum, Boolean *headsetConnected)
    Parameters:
    refNum,: IN:

  • Err PhnLibGetMicrophone (UInt16 refNum, Int16 *gain)
    Parameters:
    refNum,: IN:

  • Err PhnLibSetMicrophone (UInt16 refNum, Int16 gain)
    Parameters:
    refNum,: IN:

  • Boolean PhnLibCardInfoEx (UInt16 refNum, CharPtr *manufacturer, CharPtr *model, CharPtr *modemSWRev, CharPtr *esn, CharPtr *prlRev, CharPtr *hostSWRev, CharPtr *modemHWRev, CharPtr *priChecksum, Word *eriVer, Boolean *isEriSet)
    Parameters:
    refNum,: IN:

  • Err PhnLibGetPhoneCallStatus (UInt16 refNum, UInt32 *phnFlags)
    Parameters:
    refNum,: IN:

  • Err PhnLibMute (UInt16 refNum, Boolean toMute)
    Parameters:
    refNum,: IN:

  • Err PhnLibIsCallMuted (UInt16 refNum, Boolean *isMute)
    Parameters:
    refNum,: IN:

  • Boolean PhnLibIsPhoneActivated (UInt16 refNum)
    Parameters:
    refNum,: IN:

  • Err PhnLibMiscDebugInfo (UInt16 refNum, Boolean bSet, VoidPtr debugInfoP, UInt16 infoLen)
    Parameters:
    refNum,: IN:

  • Err PhnLibAttrGet (UInt16 refNum, UInt16 attr, UInt32 flags, void *dataP)
    Parameters:
    refNum,: IN:

  • Err PhnLibAttrSet (UInt16 refNum, UInt16 attr, UInt32 flags, void *dataP)
    Parameters:
    refNum,: IN:

  • Err PhnLibGetDeviceID (UInt16 refNum, CharPtr *deviceId)
    Parameters:
    refNum,: IN:

  • Err PhnLibGetNoiseCancellation (UInt16 refNum, Boolean *noiseCancellationP)
    Parameters:
    refNum,: IN:

  • Err PhnLibSetNoiseCancellation (UInt16 refNum, Boolean noiseCancellation)
    Parameters:
    refNum,: IN:

  • Err PhnLibGetMEID (UInt16 refNum, CharPtr *bufferP)
    Parameters:
    refNum,: IN:

  • Err PhnLibGetBaseStationIdInfo (UInt16 refNum, UInt16 *base_id, UInt16 *sid, UInt16 *nid)
    Parameters:
    pointer to base_id, sid, nid storage IN:

  • Err PhnLibGetMMSUAString (UInt16 refNum, char *pUaStr, UInt32 buf_len)
    Parameters:
    pointer to buffer of char IN: pUaStr and length of the buffer provided OUT: pUaStr : param pointer to buffer containing values

Function Documentation

Err PhnLibAttrGet | ( | UInt16 | refNum,
 |  | UInt16 | attr,
 |  | UInt32 | flags,
 |  | void * | dataP
 | ) |  |

Parameters:
refNum,: IN:

Parameters:
attr,: IN:
flags,: IN:
dataP,: IN:
Return values:
Err Error code.

Err PhnLibAttrSet | ( | UInt16 | refNum,
 |  | UInt16 | attr,
 |  | UInt32 | flags,
 |  | void * | dataP
 | ) |  |

Parameters:
refNum,: IN:

Parameters:
attr,: IN:
flags,: IN:
dataP,: IN:
Return values:
Err Error code.

Boolean PhnLibCardInfo | ( | UInt16 | refNum,
 |  | CharPtr * | manufacturer,
 |  | CharPtr * | model,
 |  | CharPtr * | version,
 |  | CharPtr * | serial
 | ) |  |

Parameters:
refNum,: IN:

Parameters:
manufacturer,: IN:
model,: IN:
version,: IN:
serial IN:
Return values:
Err Error code.

Boolean PhnLibCardInfoEx | ( | UInt16 | refNum,
 |  | CharPtr * | manufacturer,
 |  | CharPtr * | model,
 |  | CharPtr * | modemSWRev,
 |  | CharPtr * | esn,
 |  | CharPtr * | prlRev,
 |  | CharPtr * | hostSWRev,
 |  | CharPtr * | modemHWRev,
 |  | CharPtr * | priChecksum,
 |  | Word * | eriVer,
 |  | Boolean * | isEriSet
 | ) |  |

Parameters:
refNum,: IN:

Parameters:
manufacturer,: IN:
model,: IN:
modemSWRev,: IN:
esn,: IN:
prlRev,: IN:
hostSWRev,: IN:
modemHWRev,: IN:
priChecksum,: IN:
*eriver,: IN:
*isEriSet,: IN:
Return values:
Err Error code.

Err PhnLibConnectionAvailable | ( | UInt16 | refNum,
 |  | PhnConnectionEnum | connection,
 |  | Boolean * | pAvailable
 | ) |  |

Checks to see if a connection can be made.

Parameters:
refNum,: IN: Library reference number obtained from SysLibLoad.
connection,: IN: Type of connection to be made.
pAvailable,: IN: Result indicating if a connection is available.
Return values:
0 for success; otherwise failed and returned an error code as defined in “Phone Library Error Codes.”

Err PhnLibErrorRate | ( | UInt16 | refNum,
 |  | WordPtr | errorRate
 | ) |  |

Parameters:
refNum,: IN:

Parameters:
errorRate,: IN:
Return values:
Err Error code.

Err PhnLibGetBaseStationIdInfo | ( | UInt16 | refNum,
 |  | UInt16 * | base_id,
 |  | UInt16 * | sid,
 |  | UInt16 * | nid
 | ) |  |

Parameters:
pointer to base_id, sid, nid storage IN:

Parameters:
base_id,sid,nid OUT: contains the values
Return values:
Err Error code.

UInt16 PhnLibGetCallCountByService | ( | UInt16 | refNum,
 |  | PhoneServiceClassType | service
 | ) |  |

Locate the call item that has the specified service if such item exists return the total number of call items that has the same service.

Parameters:
refNum,: IN: Library reference number obtained from SysLibLoad.
service,: IN: The specified connection service (can OR bit combination)
Return values:
Number of call items that has the same status.

Err PhnLibGetDeviceID | ( | UInt16 | refNum,
 |  | CharPtr * | deviceId
 | ) |  |

Parameters:
refNum,: IN:

Parameters:
deviceId,: IN:
Return values:
Err Error code.

Err PhnLibGetEchoCancellation | ( | UInt16 | refNum,
 |  | Boolean * | echoCancellationOn
 | ) |  |

Parameters:
refNum,: IN:

Parameters:
echoCancellationOn,: IN:
Return values:
Err Error code.

Err PhnLibGetEquipmentMode | ( | UInt16 | refNum,
 |  | PhnEquipmentMode * | equipmentMode
 | ) |  |

Parameters:
refNum,: IN:

Parameters:
equipmentMode,: IN:
Return values:
Err Error code.

void PhnLibGetErrorText | ( | UInt16 | refNum,
 |  | Err | error,
 |  | CharPtr | buffer,
 |  | UInt16 | bufferLen
 | ) |  |

Parameters:
refNum,: IN:

Parameters:
error,: IN:
buffer,: IN:
bufferLen,: IN:
Return values:
Err Error code.

Err PhnLibGetHeadsetConnectedInfo | ( | UInt16 | refNum,
 |  | Boolean * | headsetConnected
 | ) |  |

Parameters:
refNum,: IN:

Parameters:
headsetConnected,: IN:
Return values:
0 for success; otherwise failed and returned an error code as defined in “Phone Library Error Codes.”

Err PhnLibGetLineState | ( | UInt16 | refNum,
 |  | UInt16 | line,
 |  | PhnLineStatePtr | lineState
 | ) |  |

Retrieve the Line state.

Parameters:
refNum,: IN: Library reference number obtained from SysLibLoad.
line,: IN: Line to query for
lineState,: IN: State of the Line
Return values:
0 for success; otherwise failed and returned an error code as defined in “Phone Library Error Codes.”

Err PhnLibGetMEID | ( | UInt16 | refNum,
 |  | CharPtr * | bufferP
 | ) |  |

Parameters:
refNum,: IN:

Parameters:
bufferP,: OUT: contains MEID or ESN (for non-MEID devices)
Return values:
Err Error code.

Err PhnLibGetMicrophone | ( | UInt16 | refNum,
 |  | Int16 * | gain
 | ) |  |

Parameters:
refNum,: IN:

Parameters:
gain,: IN:
Return values:
Err Error code.

Err PhnLibGetMMSUAString | ( | UInt16 | refNum,
 |  | char * | pUaStr,
 |  | UInt32 | buf_len
 | ) |  |

Parameters:
pointer to buffer of char IN: pUaStr and length of the buffer provided OUT: pUaStr : param pointer to buffer containing values

Return values:
Err Error code.

Err PhnLibGetNoiseCancellation | ( | UInt16 | refNum,
 |  | Boolean * | noiseCancellationP
 | ) |  |

Parameters:
refNum,: IN:

Parameters:
noiseCancellationP,: IN:
Return values:
Err Error code.

Err PhnLibGetPhoneCallStatus | ( | UInt16 | refNum,
 |  | UInt32 * | phnFlags
 | ) |  |

Parameters:
refNum,: IN:

Parameters:
phnFlags,: IN:
Return values:
Err Error code.

Err PhnLibGetRadioState | ( | UInt16 | refNum,
 |  | PhnRadioStatePtr | radioState
 | ) |  |

Retrieve state information about the radio.

Parameters:
refNum,: IN: Library reference number obtained from SysLibLoad.
radioState,: IN: State of the Radio
Return values:
0 for success; otherwise failed and returned an error code as defined in “Phone Library Error Codes.”

Err PhnLibIsCallMuted | ( | UInt16 | refNum,
 |  | Boolean * | isMute
 | ) |  |

Parameters:
refNum,: IN:

Parameters:
isMute,: IN:
Return values:
Err Error code.

Boolean PhnLibIsPhoneActivated ( UInt16 refNum )

Parameters:
refNum,: IN:

Return values:
Err Error code.

Err PhnLibMiscDebugInfo | ( | UInt16 | refNum,
 |  | Boolean | bSet,
 |  | VoidPtr | debugInfoP,
 |  | UInt16 | infoLen
 | ) |  |

Parameters:
refNum,: IN:

Parameters:
bSet,: IN:
debugInfoP IN:
infoLen,: IN:
Return values:
Err Error code.

Err PhnLibMute | ( | UInt16 | refNum,
 |  | Boolean | toMute
 | ) |  |

Parameters:
refNum,: IN:

Parameters:
toMute,: IN:
Return values:
Err Error code.

Err PhnLibSetEchoCancellation | ( | UInt16 | refNum,
 |  | Boolean | echoCancellationOn
 | ) |  |

Parameters:
refNum,: IN:

Parameters:
echoCancellationOn,: IN:
Return values:
Err Error code.

Err PhnLibSetEquipmentMode | ( | UInt16 | refNum,
 |  | PhnEquipmentMode | equipmentMode
 | ) |  |

Parameters:
refNum,: IN:

Parameters:
equipmentMode,: IN:
Return values:
Err Error code.

Err PhnLibSetMicrophone | ( | UInt16 | refNum,
 |  | Int16 | gain
 | ) |  |

Parameters:
refNum,: IN:

Parameters:
gain,: IN:
Return values:
Err Error code.

Err PhnLibSetNoiseCancellation | ( | UInt16 | refNum,
 |  | Boolean | noiseCancellation
 | ) |  |

Parameters:
refNum,: IN:

Parameters:
noiseCancellation,: IN:
Return values:
Err Error code.

Err PhnLibStartVibrate | ( | UInt16 | refNum,
 |  | Boolean | pulse,
 |  | Boolean | repeat
 | ) |  |

This API have been deprecated. Please use “HsIndicatorState.”.

Parameters:
refNum,: IN:
pulse,: IN:
repeat,: IN:
Return values:
Err Error code.

Err PhnLibStopVibrate ( UInt16 refNum )

This API have been deprecated. Please use “HsIndicatorState.”.

Parameters:
refNum,: IN:
Return values:
Err Error code.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:07:21 2008 for Palm API Guide


Header Files » Incs » common » libraries » telephony

HsPhoneMiscTypes.h File Reference

Detailed Description

Header File for Phone Library API ---- NETWORK CATEGORY.

NOTES: All implementations of the Handspring Phone Library support a common API. This API is broken up into various categories for easier management. This file defines the SMS category. These API calls are used to interact with the wireless network.

Definition in file HsPhoneMiscTypes.h.

Include dependency graph for HsPhoneMiscTypes.h:

Go to the source code of this file.

Data Structures

  • struct PhnRadioStateType
  • struct PhnLineStateType
  • struct PhnCdmaSystemInfoType

Defines

  • #define isValidPhnVibrateType(t) ((t >= phnVibrateOff) && (t <= phnVibrateOn))
  • #define isValidPhnConnectionEnum(e) ((e >= voiceConnection) && (e <= oneXConnection))
  • #define isValidPhnEquipmentMode(m) (m <= phnEquipmentModeLast)
  • #define kRadioStateVersion 1
  • #define kLineStateVersion 1

Typedefs

  • typedef struct PhnRadioStateType * PhnRadioStatePtr
  • typedef struct PhnLineStateType * PhnLineStatePtr
  • typedef UInt8 PhnLibAttrType
  • typedef UInt8 * PhnLibAttrPtr
  • typedef UInt8 PhnOprtModeType
  • typedef struct PhnCdmaSystemInfoType * PhnCdmaSystemInfoPtr

Enumerations

  • enum PhnVibrateType {
    phnVibrateOff,
    phnVibrateOn
    }
  • enum PhnConnectionEnum {
    voiceConnection = 1,
    csdConnection = 2,
    gprsConnection = 3,
    oneXConnection = 4
    }
  • enum PhnEquipmentMode {
    phnHandsetMode,
    phnHeadsetMode,
    phnSpeakerPhoneMode,
    phnCarKitMode,
    phnHandsetLidCloseMode,
    phnAutoMode,
    phnBluetoothHeadsetMode,
    phnBluetoothHandsfreeMode,
    phnInvalidEquipmentMode,
    phnEquipmentModeLast
    }
  • enum _PhnLibAttrType {
    phnGsmAttrFirst = 0,
    phnGsmNoFWVersionCompatibilityCheck,
    phnGsmSimBookSimMaxEntries,
    phnGsmSimBookSimUsedEntries,
    phnGsmRadioAudioSet,
    phnGsmFWControlLED,
    phnGsmAttrLast
    }
  • enum _PhnOprtModeType {
    phnOprtModeNone = -1,
    phnOprtModePwroff,
    phnOprtModeOffline,
    phnOprtModeOfflineA,
    phnOprtModeOnline,
    phnOprtModeLPM,
    phnOprtModeReset,
    phnOprtModeMax
    }

Define Documentation

#define isValidPhnConnectionEnum ( e ) ((e >= voiceConnection) && (e <= oneXConnection))

Definition at line 60 of file HsPhoneMiscTypes.h.

#define isValidPhnEquipmentMode ( m ) (m <= phnEquipmentModeLast)

Definition at line 80 of file HsPhoneMiscTypes.h.

#define isValidPhnVibrateType ( t ) ((t >= phnVibrateOff) && (t <= phnVibrateOn))

Definition at line 47 of file HsPhoneMiscTypes.h.

#define kLineStateVersion 1

Definition at line 110 of file HsPhoneMiscTypes.h.

#define kRadioStateVersion 1

Definition at line 96 of file HsPhoneMiscTypes.h.

Typedef Documentation

typedef struct PhnCdmaSystemInfoType * PhnCdmaSystemInfoPtr

typedef UInt8* PhnLibAttrPtr

Definition at line 128 of file HsPhoneMiscTypes.h.

typedef UInt8 PhnLibAttrType

Definition at line 127 of file HsPhoneMiscTypes.h.

typedef struct PhnLineStateType * PhnLineStatePtr

typedef UInt8 PhnOprtModeType

Definition at line 144 of file HsPhoneMiscTypes.h.

typedef struct PhnRadioStateType* PhnRadioStatePtr

Enumeration Type Documentation

enum _PhnLibAttrType

Phone Library Attributes

Enumerator:
phnGsmAttrFirst
phnGsmNoFWVersionCompatibilityCheck
phnGsmSimBookSimMaxEntries
phnGsmSimBookSimUsedEntries
phnGsmRadioAudioSet
phnGsmFWControlLED
phnGsmAttrLast

Definition at line 116 of file HsPhoneMiscTypes.h.

00117   {
00118     phnGsmAttrFirst = 0,            /**<        */
00119     phnGsmNoFWVersionCompatibilityCheck,    /**<        */
00120     phnGsmSimBookSimMaxEntries,         /**<        */
00121     phnGsmSimBookSimUsedEntries,        /**<        */
00122     phnGsmRadioAudioSet,            /**<        */
00123         phnGsmFWControlLED,
00124
00125     phnGsmAttrLast
00126   }_PhnLibAttrType;

enum _PhnOprtModeType

Enumerator:
phnOprtModeNone | FOR INTERNAL USE OF CM ONLY!
phnOprtModePwroff | phone is powering off
phnOprtModeOffline | phone is offline Digital
phnOprtModeOfflineA | phone is offline analog
phnOprtModeOnline | phone is online
phnOprtModeLPM | phone is in LPM - Low Power Mode
phnOprtModeReset | phone is resetting - i.e. power-cycling
phnOprtModeMax

Definition at line 130 of file HsPhoneMiscTypes.h.

00131 {
00132     phnOprtModeNone =-1,   /**< FOR INTERNAL USE OF CM ONLY! */
00133     phnOprtModePwroff,    /**< phone is powering off */
00134     phnOprtModeOffline,   /**< phone is offline Digital*/
00135     phnOprtModeOfflineA, /**< phone is offline analog */
00136     phnOprtModeOnline,    /**< phone is online */
00137     phnOprtModeLPM,       /**< phone is in LPM - Low Power Mode */
00138     phnOprtModeReset,     /**< phone is resetting - i.e. power-cycling */
00139
00140     phnOprtModeMax
00141
00142 } _PhnOprtModeType;

enum PhnConnectionEnum

Phone Connection Type

Enumerator:
voiceConnection
csdConnection
gprsConnection
oneXConnection

Definition at line 53 of file HsPhoneMiscTypes.h.

00053              {
00054   voiceConnection   = 1,    /**<        */
00055   csdConnection     = 2,    /**<        */
00056   gprsConnection    = 3,    /**<        */
00057   oneXConnection    = 4     /**<        */
00058 } PhnConnectionEnum;

enum PhnEquipmentMode

Enumerator:
phnHandsetMode | sets default mode to handset mode
phnHeadsetMode | sets default mode to headdset mode
phnSpeakerPhoneMode | sets default mode to speaker phone mode
phnCarKitMode | set carkit mode
phnHandsetLidCloseMode
phnAutoMode | automatic mode where modem internaly decides the mode
phnBluetoothHeadsetMode
phnBluetoothHandsfreeMode
phnInvalidEquipmentMode | Used to flag an invalid mode
phnEquipmentModeLast

Definition at line 65 of file HsPhoneMiscTypes.h.

00066 {
00067   phnHandsetMode,             /**< sets default mode to handset mode */
00068   phnHeadsetMode,             /**< sets default mode to headdset mode */
00069   phnSpeakerPhoneMode,        /**< sets default mode to speaker phone mode */
00070   phnCarKitMode,              /**< set carkit mode */
00071   phnHandsetLidCloseMode,     /**<        */
00072   phnAutoMode,                /**< automatic mode where modem internaly decides the mode */
00073   phnBluetoothHeadsetMode,    /**<        */
00074   phnBluetoothHandsfreeMode,  /**<        */
00075   phnInvalidEquipmentMode,    /**< Used to flag an invalid mode */
00076   phnEquipmentModeLast        /**<        */
00077
00078 }PhnEquipmentMode;

enum PhnVibrateType

Vibrate mode while ringing.

Enumerator:
phnVibrateOff
phnVibrateOn

Definition at line 40 of file HsPhoneMiscTypes.h.

00041   {
00042     phnVibrateOff,      /**<        */
00043     phnVibrateOn        /**<        */
00044   }

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:07:21 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » telephony

HsPhoneNetwork.h File Reference

Detailed Description

Header File for Phone Library API ---- NETWORK CATEGORY.

Notes: All implementations of the Handspring Phone Library support a common API. This API is broken up into various categories for easier management. This file defines the Network category. These API calls are used to interact with the wireless network.

Definition in file HsPhoneNetwork.h.

Include dependency graph for HsPhoneNetwork.h:

Go to the source code of this file.

Functions

  • Err PhnLibBoxInformation (UInt16 refNum, PhnMsgBoxDataType *data)
    Gets information on a specific voicemail box as specified in the data argument.
  • Err PhnLibBoxInformationEx (UInt16 refNum, PhnMsgBoxDataType *data, Boolean bGetInfo)
    Gets or Set information on a specific voicemail box as specified in the data argument.
  • Err PhnLibGetBoxNumber (UInt16 refNum, PhnMsgBoxType type, UInt16 line, CharPtr *number)
    Return the number of the voice box of the given type for the given line as it is stored on the SIM.
  • Err PhnLibHomeOperatorID (UInt16 refNum, char *buffer, Int16 *bufferSizeP)
    Get value for home network’s operator ID (MCC+MNC) string.
  • Err PhnLibCurrentOperatorID (UInt16 refNum, char *buffer, Int16 *bufferSizeP)
    Get value for current network’s operator ID (MCC+MNC) string.
  • Err PhnLibCurrentOperator (UInt16 refNum, PhnOperatorID *id, CharPtr *name, GSMRegistrationMode *mode)
    Get value for current network’s operator string.
  • Err PhnLibSetOperator (UInt16 refNum, PhnOperatorType *op, GSMRegistrationMode regMode)
    Set value of operator for radio to register to.
  • Err PhnLibRoaming (UInt16 refNum, PhnRoamStatus *roamStatus)
    Return the roaming status.
  • Boolean PhnLibRegistered (UInt16 refNum)
    Checks if the phone found any network cellular service.
  • Err PhnLibSignalQuality (UInt16 refNum, UInt16 *quality)
    Return the signal strength.
  • Err PhnLibSignalQualityEx (UInt16 refNum, UInt16 *quality, Boolean *bEcio, UInt16 *ecioLvl)
    Get the signal quality and ecio level information.
  • Err PhnLibCurrentProvider (UInt16 refNum, char **name)
    Get value for current network’s provider.
  • Err PhnLibGetOperatorList (UInt16 refNum, PhnOperatorListPtr *list)
    Get list of operators available to radio.
  • Err PhnLibGetOwnNumbers (UInt16 refNum, PhnAddressList *ownNumbers)
    Return a list of phone numbers from the device. These numbers could be voicemail box, data line or fax line (if supported).
  • Err PhnLibSetOwnNumbers (UInt16 refnum, PhnAddressList ownNumbers)

  • Err PhnLibSetCallWaiting (UInt16 refNum, Boolean enabled)
    Enable/disable call waiting for phone calls on radio.
  • Err PhnLibGetCallWaiting (UInt16 refNum, BooleanPtr enabled)
    Get call waiting setting for phone calls on radio.
  • Err PhnLibSetCLIP (UInt16 refNum, Boolean enable)
    Parameters:
    refNum,: IN: Library reference number returned by HsGetPhoneLibrary().

  • Err PhnLibGetCLIP (UInt16 refNum, Boolean *enabled)
    (TBC)
  • Err PhnLibGetForwarding (UInt16 refNum, PhnForwardType condition, PhnAddressHandle *destination)
    Returns the forwarded number stored in smartphone radio.
  • Err PhnLibSetCLIR (UInt16 refNum, GSMDialCLIRMode mode)
    Parameters:
    refNum,: IN: Library reference number returned by HsGetPhoneLibrary().

  • Err PhnLibGetCLIR (UInt16 refNum, GSMDialCLIRMode *mode, PhnCLIRStatus *status)
    (TBC)
  • Err PhnLibSetBarring (UInt16 refNum, PhnBarFacilityType facility, CharPtr password)
    Used to Activate a Barring Service.
  • Err PhnLibGetBarring (UInt16 refNum, PhnBarFacilityType facility, Boolean *enabled)
    Get Barring Service state for given facility.
  • Err PhnLibDeactivateBarring (UInt16 refNum, PhnBarFacilityType facility, CharPtr password)
    Used to Deactivate a Barring Service.
  • Err PhnLibGetEnhancedRoamIndicator (UInt16 refNum, char *roamTxt, PhnRoamIconState *iconState)
    Retrieves the roaming indicator text that needs to be displayed if the phone is in enhanced roaming mode.
  • Err PhnLibGetRoamPrefMode (UInt16 refNum, PhnRoamPrefSelectionType *roamPrefP)
    (TBD)
  • Err PhnLibSetRoamPrefMode (UInt16 refNum, PhnRoamPrefSelectionType roamPref)
    Set the roaming mode. This API is the same as used when the user checks or unchecks the “Enable Digital roaming” in the Phone Preference on Treo 600. If set, then digital roaming will be allowed.
  • Err PhnLibSetRoamPrefInfo (UInt16 refNum, PhnRoamPrefInfoPtr pInfo)
    Parameters:
    refNum,: IN:

  • Err PhnLibGetOperatorLock (UInt16 refNum, UInt16 facilityType, Boolean *enabled)
    This function indicate if the Operator has locked the phone to its network (i.e. it can’t be used on other network).
  • Boolean PhnLibNetworkAvailable (UInt16 refNum)
    (TBD)
  • Err PhnLibSetForwarding (UInt16 refNum, PhnForwardType condition, PhnForwardModeType mode, PhnAddressHandle destination)
    Set call forwarding settings.
  • Err PhnLibUsableSignalStrengthThreshold (UInt16 refNum, WordPtr threshold)
    This function gives the threshold level of signal quality at which the radio is capable of sending data.
  • Err PhnLibGetDataSessionInfo (UInt16 refNum, PhnDataSessionStateType *dataSessionStateP)
    Returns the current state of the data session as well as the available data session type currently available on the network.

Function Documentation

Err PhnLibBoxInformation | ( | UInt16 | refNum,
 |  | PhnMsgBoxDataType * | data
 | ) |  |

Gets information on a specific voicemail box as specified in the data argument.

Parameters:
refNum,: IN: Library reference number returned by HsGetPhoneLibrary().
data,: IN: See “PhnMsgBoxDataType” for details
Return values:
0 for success; otherwise failed.

Err PhnLibBoxInformationEx | ( | UInt16 | refNum,
 |  | PhnMsgBoxDataType * | data,
 |  | Boolean | bGetInfo
 | ) |  |

Gets or Set information on a specific voicemail box as specified in the data argument.

Parameters:
refNum,: IN: Library reference number returned by HsGetPhoneLibrary().
data,: IN: See “PhnMsgBoxDataType” for details
bGetInfo,: IN: Indicates whether the operation is a get (True) or set (False).
Return values:
0 for success; otherwise failed.

Err PhnLibCurrentOperator | ( | UInt16 | refNum,
 |  | PhnOperatorID * | id,
 |  | CharPtr * | name,
 |  | GSMRegistrationMode * | mode
 | ) |  |

Get value for current network’s operator string.

Parameters:
refNum,: IN: Library reference number returned by HsGetPhoneLibrary().
id,: IN: returned operator ID value
name,: IN: returned operator name string
mode,: IN: returned registration mode for current operator
Return values:
0 for success; otherwise failed

Err PhnLibCurrentOperatorID | ( | UInt16 | refNum,
 |  | char * | buffer,
 |  | Int16 * | bufferSizeP
 | ) |  |

Get value for current network’s operator ID (MCC+MNC) string.

Parameters:
refNum,: IN: Library reference number returned by HsGetPhoneLibrary().
*buffer,: IN: buffer to hold returned string
bufferSizeP,: IN:
Return values:
0 for success; otherwise failed

Err PhnLibCurrentProvider | ( | UInt16 | refNum,
 |  | char ** | name
 | ) |  |

Get value for current network’s provider.

Parameters:
refNum,: IN: Library reference number returned by HsGetPhoneLibrary().
name,: IN: returned provider name string
Return values:
0 for success; otherwise failed

Err PhnLibDeactivateBarring | ( | UInt16 | refNum,
 |  | PhnBarFacilityType | facility,
 |  | CharPtr | password
 | ) |  |

Used to Deactivate a Barring Service.

Parameters:
refNum,: IN: Library reference number returned by HsGetPhoneLibrary().
facility,: IN: barring condition to be deactivated
password,: IN:
Return values:
0 for success; otherwise failed

Err PhnLibGetBarring | ( | UInt16 | refNum,
 |  | PhnBarFacilityType | facility,
 |  | Boolean * | enabled
 | ) |  |

Get Barring Service state for given facility.

Parameters:
refNum,: IN: Library reference number returned by HsGetPhoneLibrary().
facility,: IN: barring condition to get state for
enabled,: IN: returned state of given barring service; true = activated.
Return values:
0 for success; otherwise failed

Err PhnLibGetBoxNumber | ( | UInt16 | refNum,
 |  | PhnMsgBoxType | type,
 |  | UInt16 | line,
 |  | CharPtr * | number
 | ) |  |

Return the number of the voice box of the given type for the given line as it is stored on the SIM.

Parameters:
refNum,: IN: Library reference number returned by HsGetPhoneLibrary().
type,: IN: See “PhnMsgBoxType” for details. On Treo™ 600 smartphone by palmOne, only the kBoxVoice type is supported
line,: IN: On a GSM/GPRS device, line can be either “1” or “2”. This is dependant on if the subscriber account supports 1 or 2 line(s) (on GSM, this is called Alternative Line Service). On the CDMA device, it is currently not used.
number,: IN: Returns the number as a string.
Return values:
PhnLibGetBoxNumber returns 0 if the number could be determined without encountering an error.

Err PhnLibGetCallWaiting | ( | UInt16 | refNum,
 |  | BooleanPtr | enabled
 | ) |  |

Get call waiting setting for phone calls on radio.

Parameters:
refNum,: IN: Library reference number returned by HsGetPhoneLibrary().
enabled,: IN: return value of call waiting service on radio. true if call waiting is enabled false if call waiting is disabled value is undefined if return value of function is not 0 (ERROR)
Return values:
0 for success; otherwise failed

Err PhnLibGetCLIP | ( | UInt16 | refNum,
 |  | Boolean * | enabled
 | ) |  |

(TBC)

Parameters:
refNum,: IN: Library reference number returned by HsGetPhoneLibrary().
enabled,: IN:
Return values:
Err Error code.

Err PhnLibGetCLIR | ( | UInt16 | refNum,
 |  | GSMDialCLIRMode * | mode,
 |  | PhnCLIRStatus * | status
 | ) |  |

(TBC)

Parameters:
refNum,: IN: Library reference number returned by HsGetPhoneLibrary().
mode,: IN:
status,: IN:
Return values:
Err Error code.

Err PhnLibGetDataSessionInfo | ( | UInt16 | refNum,
 |  | PhnDataSessionStateType * | dataSessionStateP
 | ) |  |

Returns the current state of the data session as well as the available data session type currently available on the network.

Parameters:
refNum,: IN: Library reference number returned by HsGetPhoneLibrary().
dataSessionStateP,: OUT: data structure to be filled out. version field must be set
Return values:
0 for success; otherwise failed

Err PhnLibGetEnhancedRoamIndicator | ( | UInt16 | refNum,
 |  | char * | roamTxt,
 |  | PhnRoamIconState * | iconState
 | ) |  |

Retrieves the roaming indicator text that needs to be displayed if the phone is in enhanced roaming mode.

Parameters:
refNum,: IN: Library reference number returned by HsGetPhoneLibrary().
roamTxt,: IN: Pointer to a char of “PhnEnhancedRoamIndMaxLength” maximum length.
*iconState,: IN:
Return values:
phnErrNotAllowed if called when the phone is not in enhanced roaming.

Err PhnLibGetForwarding | ( | UInt16 | refNum,
 |  | PhnForwardType | condition,
 |  | PhnAddressHandle * | destination
 | ) |  |

Returns the forwarded number stored in smartphone radio.

Parameters:
refNum,: IN: Library reference number returned by HsGetPhoneLibrary().
condition,: IN: forwarding condition to get values for. Currently CDMA only supports “phnForwardUnconditional” as defined in “PhnForwardType”.
destination,: IN: returned forwarding address for given forwarding condition
Return values:
Err 0 for success; otherwise failed

Err PhnLibGetOperatorList | ( | UInt16 | refNum,
 |  | PhnOperatorListPtr * | list
 | ) |  |

Get list of operators available to radio.

Parameters:
refNum,: IN: Library reference number returned by HsGetPhoneLibrary().
list,: IN: container for returned list of operator values
Return values:
0 for success; otherwise failed

Err PhnLibGetOperatorLock | ( | UInt16 | refNum,
 |  | UInt16 | facilityType,
 |  | Boolean * | enabled
 | ) |  |

This function indicate if the Operator has locked the phone to its network (i.e. it can’t be used on other network).

Parameters:
refNum,: IN: Library reference number returned by HsGetPhoneLibrary().
facilityType,: IN: optional facility type, or 0 (TBC)
enabled,: IN: pointer to output value
Return values:
True if a network was found even if we are unable to register to it. False if no network can be found.

Err PhnLibGetOwnNumbers | ( | UInt16 | refNum,
 |  | PhnAddressList * | ownNumbers
 | ) |  |

Return a list of phone numbers from the device. These numbers could be voicemail box, data line or fax line (if supported).

Parameters:
refNum,: IN: Library reference number returned by HsGetPhoneLibrary().
ownNumbers,: IN: Pointer to the list of phone box number of the device.
Return values:
0 for success; otherwise failed

Err PhnLibGetRoamPrefMode | ( | UInt16 | refNum,
 |  | PhnRoamPrefSelectionType * | roamPrefP
 | ) |  |

(TBD)

Parameters:
refNum,: IN: Library reference number returned by HsGetPhoneLibrary().
Mode,: IN: see PhnRoamPrefSelectionType
Return values:
Err Error code.

Err PhnLibHomeOperatorID | ( | UInt16 | refNum,
 |  | char * | buffer,
 |  | Int16 * | bufferSizeP
 | ) |  |

Get value for home network’s operator ID (MCC+MNC) string.

Parameters:
refNum,: IN: Library reference number returned by HsGetPhoneLibrary().
*buffer,: IN: Buffer to hold returned string
bufferSizeP,: IN:
Return values:
0 for success; otherwise failed

Boolean PhnLibNetworkAvailable ( UInt16 refNum )

(TBD)

Parameters:
refNum,: IN: Library reference number returned by HsGetPhoneLibrary().
Return values:
Err Error code.

Boolean PhnLibRegistered ( UInt16 refNum )

Checks if the phone found any network cellular service.

Parameters:
refNum,: IN: Library reference number returned by HsGetPhoneLibrary().
Return values:
true if service is found. false if no service

Err PhnLibRoaming | ( | UInt16 | refNum,
 |  | PhnRoamStatus * | roamStatus
 | ) |  |

Return the roaming status.

Parameters:
refNum,: IN: Library reference number returned by HsGetPhoneLibrary().
roamStatus,: IN: PhnLibRoaming returns the roaming status.
Return values:
0 if no error; error code otherwise

Err PhnLibSetBarring | ( | UInt16 | refNum,
 |  | PhnBarFacilityType | facility,
 |  | CharPtr | password
 | ) |  |

Used to Activate a Barring Service.

Parameters:
refNum,: IN: Library reference number returned by HsGetPhoneLibrary().
facility,: IN: Barring condition to be set
password,: IN: Password to set Barring. This will be used when changing barring option.
Return values:
0 for success; otherwise failed

Err PhnLibSetCallWaiting | ( | UInt16 | refNum,
 |  | Boolean | enabled
 | ) |  |

Enable/disable call waiting for phone calls on radio.

Parameters:
refNum,: IN: Library reference number returned by HsGetPhoneLibrary().
enabled,: IN: flag to enable/disable call waiting
Return values:
0 for success; otherwise failed

Err PhnLibSetCLIP | ( | UInt16 | refNum,
 |  | Boolean | enable
 | ) |  |

Parameters:
refNum,: IN: Library reference number returned by HsGetPhoneLibrary().

Parameters:
enable,: IN: True to enable CLIP. False to disable it.
Return values:
Err Error code.

Err PhnLibSetCLIR | ( | UInt16 | refNum,
 |  | GSMDialCLIRMode | mode
 | ) |  |

Parameters:
refNum,: IN: Library reference number returned by HsGetPhoneLibrary().

Parameters:
mode,: IN: (TBC)
Return values:
0 for success; otherwise failed.

Err PhnLibSetForwarding | ( | UInt16 | refNum,
 |  | PhnForwardType | condition,
 |  | PhnForwardModeType | mode,
 |  | PhnAddressHandle | destination
 | ) |  |

Set call forwarding settings.

Parameters:
refNum,: IN: Library reference number returned by HsGetPhoneLibrary().
condition,: IN: forwarding condition to be set
mode,: IN: forwarding condition value to be set
destination,: IN: forwarding address value
Return values:
Err 0 for success; otherwise failed

Err PhnLibSetOperator | ( | UInt16 | refNum,
 |  | PhnOperatorType * | op,
 |  | GSMRegistrationMode | regMode
 | ) |  |

Set value of operator for radio to register to.

Parameters:
refNum,: IN: Library reference number returned by HsGetPhoneLibrary().
op,: IN: operator to register to
regMode,: IN: type of registration to make
Return values:
0 for success; otherwise failed

Err PhnLibSetOwnNumbers | ( | UInt16 | refnum,
 |  | PhnAddressList | ownNumbers
 | ) |  |

Parameters:
refNum,: IN: Library reference number returned by HsGetPhoneLibrary().
ownNumbers,: IN:
Return values:
0 for success; otherwise failed

Err PhnLibSetRoamPrefInfo | ( | UInt16 | refNum,
 |  | PhnRoamPrefInfoPtr | pInfo
 | ) |  |

Parameters:
refNum,: IN:

Parameters:
pInfo,: IN:
Return values:
Err Error code.

Err PhnLibSetRoamPrefMode | ( | UInt16 | refNum,
 |  | PhnRoamPrefSelectionType | roamPref
 | ) |  |

Set the roaming mode. This API is the same as used when the user checks or unchecks the “Enable Digital roaming” in the Phone Preference on Treo 600. If set, then digital roaming will be allowed.

Parameters:
refNum,: IN: Library reference number returned by HsGetPhoneLibrary().
Mode,: IN: see PhnRoamPrefSelectionType
Return values:
Error status

Err PhnLibSignalQuality | ( | UInt16 | refNum,
 |  | UInt16 * | quality
 | ) |  |

Return the signal strength.

Parameters:
refNum,: IN: Library reference number returned by HsGetPhoneLibrary().
quality,: IN: Phone signal strength in dBm
Return values:
0 if no error

Err PhnLibSignalQualityEx | ( | UInt16 | refNum,
 |  | UInt16 * | quality,
 |  | Boolean * | bEcio,
 |  | UInt16 * | ecioLvl
 | ) |  |

Get the signal quality and ecio level information.

Parameters:
refNum,: IN: Library reference number returned by HsGetPhoneLibrary().
quality,: IN: Phone signal strength in dBm
*bEcio,: IN:
*ecioLvl,: IN:
Return values:
0 for success; otherwise failed

Err PhnLibUsableSignalStrengthThreshold | ( | UInt16 | refNum,
 |  | WordPtr | threshold
 | ) |  |

This function gives the threshold level of signal quality at which the radio is capable of sending data.

Parameters:
refNum,: IN: Library reference number returned by HsGetPhoneLibrary().
threshold,: IN: (TBC)
Return values:
0 for success; otherwise failed

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:07:22 2008 for Palm API Guide


Header Files » Incs » common » libraries » telephony

HsPhoneNetworkTypes.h File Reference

Detailed Description

Header File for Phone Library API ---- NETWORK CATEGORY.

NOTES: All implementations of the Handspring Phone Library support a common API. This API is broken up into various categories for easier management. This file defines the SMS category. These API calls are used to interact with the wireless network.

Definition in file HsPhoneNetworkTypes.h.

Include dependency graph for HsPhoneNetworkTypes.h:

Go to the source code of this file.

Data Structures

  • struct PhnMsgBoxDataType
  • struct PhnOperatorType
  • struct PhnOperatorListType
  • struct PhnRoamPrefInfoType
  • struct PhnMMIEntryType
    MMI Decode struct. More...
  • struct PhnMMIResultType
    MMI result struct. More...
  • struct PhnOneXStatus
  • struct PhnDataSessionStateType
  • struct PhnNetworkTime

Defines

  • #define kMaxPhoneNumberLen 16
  • #define minPasswordLen 4
  • #define maxPasswordLen 8
  • #define maxPasswordLenCDMA 4
  • #define phnEnhancedRoamIndMaxLength 40
  • #define isValidPhnCLIRStatus(s) ((s >= clirNotProvisioned) && (s <= clirTemporaryAllowed))
  • #define isValidGSMDialClirStatus(d) ((d >= gsmDialCLIRNotProvisioned) && (d <= gsmDialCLIRTemporaryAllowed))
  • #define isValidPhnOperatorStatus(s) ((s >= phnOpUnknown) && (s <= phnOpForbidden))
  • #define isValidPhnMsgBoxType(n) (n < PhnMsgBoxTypeMAX)
  • #define MAX_LONGOPERATORNAME_LENGTH 24
  • #define MAX_SHORTOPERATORNAME_LENGTH 16
  • #define isValidGSMRegistrationMode(r) (r <= gsmRegModeManualAutomatic)
  • #define isValidPhnForwardType(f) (f < phnForwardLast)
  • #define isValidPhnBarFacilityType(b) (b <= phnBarAll)
  • #define isValidPhnRegistrationStatus(r) (r <= registrationRoaming)
  • #define isValidPhnForwardModeType(f) (f <= phnForwardModeErasure)
  • #define kMaxMMISequenceLen 64
  • #define kMaxImeiLen 24
  • #define isValidPhnBandSelection(f) (f <= band1900_850)
  • #define isValidRoamMode(x) (x < phnRoamPrefLast)
  • #define isValidPhnOneXProtRevType(p) (p <= phnOneXStatusPRev7)
  • #define isValidPhnPacketDataSessionType(p) (p <= phnPacketDataSessionActive)
  • #define isValidPhnMIPSessionType(m) (m <= phnMIPSession)
  • #define isValidDataService(x) (x < phnDataServiceLast)
  • #define isValidPacketDataEndStatus(x) (x < phnPacketDataEndStatusLast)
  • #define PhnDataSessionStateTypeMajorVersion 0x0001L
  • #define PhnDataSessionStateTypeMinorVersion 0x0000L
  • #define PhnDataSessionStateTypeVersion (((UInt32)PhnDataSessionStateTypeMajorVersion << 16) | PhnDataSessionStateTypeMinorVersion)

Typedefs

  • typedef UInt8 PhnMsgBoxType
  • typedef UInt8 PhnMsgBoxPriorityType
  • typedef struct PhnOperatorListType * PhnOperatorListPtr
  • typedef UInt8 PhnRoamStatus
  • typedef UInt8 PhnForwardType
  • typedef UInt8 PhnBarFacilityType
  • typedef UInt8 * PhnBarFacilityPtr
  • typedef struct PhnRoamPrefInfoType * PhnRoamPrefInfoPtr
  • typedef UInt8 PhnForwardModeType
  • typedef UInt8 PhnMMIActionCode
  • typedef UInt8 PhnMMIServiceCode
  • typedef UInt8 PhnCallControlType
  • typedef struct PhnMMIEntryType * PhnMMIEntryPtr
  • typedef struct PhnMMIResultType * PhnMMIResultPtr
  • typedef UInt8 PhnBandSelection
  • typedef UInt8 PhnRoamPrefSelectionType
  • typedef UInt8 PhnOneXProtRevType
  • typedef UInt8 PhnPacketDataSessionType
  • typedef UInt8 PhnMIPSessionType
  • typedef UInt16 PhnDataServiceType
  • typedef UInt16 PhnPacketDataEndStatusType

Enumerations

  • enum GSMCLIPStatus {
    gsmCLIPNotProvisioned,
    gsmCLIPProvisioned,
    gsmCLIPUnknown
    }
  • enum PhnCLIRStatus {
    clirNotProvisioned,
    clirProvisioned,
    clirUnknown,
    clirTemporaryRestricted,
    clirTemporaryAllowed
    }
  • enum GSMCLIRDisplayStatus {
    gsmCLIRSubscription,
    gsmCLIRInvocation,
    gsmCLIRSuppression
    }
  • enum PhnOperatorStatus {
    phnOpUnknown,
    phnOpAvailable,
    phnOpCurrent,
    phnOpForbidden
    }
  • enum PhnMsgBoxEnum {
    kBoxVoice,
    kBoxTelefax,
    kBoxEMail,
    kBoxOther,
    kBoxData,
    PhnMsgBoxTypeMAX
    }
  • enum PhnMsgBoxPriorityEnum {
    kSmsPriorityNormal,
    kSmsPriorityInteractive,
    kSmsPriorityUrgent,
    kSmsPriorityEmergency,
    kSmsPriorityLast
    }
  • enum GSMRegistrationMode {
    gsmRegModeAutomatic,
    gsmRegModeManual,
    gsmRegModeDeregister,
    gsmRegModeFormat,
    gsmRegModeManualAutomatic
    }
  • enum PhnRoamStatusEnum {
    PhnRoamStatusOff,
    PhnRoamStatusOn,
    PhnRoamStatusBlink,
    PhnRoamStatusEnhancedIndicator
    }
  • enum PhnForwardEnum {
    phnForwardUnconditional,
    phnForwardOnBusy,
    phnForwardOnNoReplay,
    phnForwardOnNotReachable,
    phnForwardTelefax,
    phnForwardData,
    phnForwardCancelAll,
    phnForwardConditionalAll,
    phnForwardLast
    }
  • enum PhnBarFacilityTypeEnum {
    phnBarOutNone,
    phnBarOutAll,
    phnBarOutInternational,
    phnBarOutInternationalExceptHome,
    phnBarInNone,
    phnBarInAll,
    phnBarInWhenRoaming,
    phnBarAll
    }
  • enum PhnRegistrationStatus {
    registrationNone,
    registrationHome,
    registrationSearch,
    registrationDenied,
    registrationUnknown,
    registrationRoaming
    }
  • enum PhnForwardModeEnum {
    phnForwardModeDisable,
    phnForwardModeEnable,
    phnForwardModeInterrogate,
    phnForwardModeRegistration,
    phnForwardModeErasure
    }
  • enum PhnMMIActionCodeEnum {
    mmiActionNoAction = 0,
    mmiActionActivate = 0x01,
    mmiActionDeactivate = 0x02,
    mmiActionInterrogate = 0x04,
    mmiActionRegister = 0x08,
    mmiActionErasure = 0x10,
    mmiActionUnlock = 0x20,
    mmiActionHandspring = 0x40
    }
  • enum PhnMMIServiceCodeEnum {
    mmiServiceInvalid = 0,
    mmiServiceChangePIN,
    mmiServiceChangePIN2,
    mmiServiceUnlockPIN,
    mmiServiceUnlockPIN2,
    mmiServiceIMEI,
    mmiServiceCallerId,
    mmiServiceNumberSent,
    mmiServiceCOLP,
    mmiServiceCOLR,
    mmiServiceCallWaiting,
    mmiServiceForwardUnconditional,
    mmiServiceForwardBusy,
    mmiServiceForwardNoReply,
    mmiServiceForwardNotReachable,
    mmiServiceForwardAll,
    mmiServiceForwardConditionalAll,
    mmiServiceBAOC,
    mmiServiceBAOIC,
    mmiServiceBAOICX,
    mmiServiceBAIC,
    mmiServiceBAICR,
    mmiServiceAllBarringServ,
    mmiServiceAllOutBarringServ,
    mmiServiceAllInBarringServ,
    mmiServiceChangeBarPwd,
    mmiServiceUSSD,
    mmiServicePhoneNumber,
    mmiServiceCallControl,
    mmiServiceSelectorOperatorLock,
    mmiServiceSelectorProviderLock,
    mmiServiceNNN,
    mmiServiceUnimplemented
    }
  • enum PhnCallControlTypeEnum {
    mmiControlReleaseAllHeld = 0,
    mmiControlReleaseAllActive,
    mmiControlReleaseCallx,
    mmiControlSwap,
    mmiControlActivateCallx,
    mmiControlConference,
    mmiControlTransfer
    }
  • enum PhnRoamIconState {
    PhnRoamIconOn,
    PhnRoamIconOff,
    PhnRoamIconFlash
    }
  • enum PhnTeleserviceType {
    phnTeleserviceUnknown = 0,
    phnTeleserviceVoice = 1,
    phnTeleserviceData = 2,
    phnTeleserviceFax = 4,
    phnTeleserviceDefault = 7,
    phnTeleserviceSMS = 8,
    phnTeleserviceDataCircSync = 16,
    phnTeleserviceDataCircAsync = 32,
    phnTeleserviceDedicatedPack = 64,
    phnTeleserviceDedicatedPAD = 128
    }
  • enum PhnTeleserviceMmiCodeType {
    phnTeleserviceUnknownMmiCode = 0,
    phnTeleserviceVoiceMmiCode = 11,
    phnTeleserviceAllMmiCode = 12,
    phnTeleserviceFaxMmiCode = 13,
    phnTeleserviceSMSMmiCode = 16,
    phnTeleserviceAllExceptSMSCode = 19,
    phnTeleserviceDataCircSyncMmiCode = 24,
    phnTeleserviceDataCircAsyncMmiCode = 25,
    phnTeleserviceDedicatedPackMmiCode = 26,
    phnTeleserviceDedicatedPADMmiCode = 27
    }
  • enum _PhnBandSelection {
    bandGSM_EGSM = 0,
    band1800,
    band900_1800,
    band1900,
    bandAuto,
    band850,
    band1900_850
    }
  • enum _PhnRoamPrefSelectionTypeEnum {
    phnRoamPrefHomeOnly,
    phnRoamPrefAny,
    phnRoamPrefRoamOnly,
    phnRoamPrefLast
    }
  • enum _PhnOneXProtRevType {
    phnOneXStatusPRevNoSvc,
    phnOneXStatusPRev1,
    phnOneXStatusPRev3,
    phnOneXStatusPRev4,
    phnOneXStatusPRev6,
    phnOneXStatusPRev7
    }
  • enum _PhnPacketDataSessionType {
    phnPacketDataSessionNone,
    phnPacketDataSessionDormant,
    phnPacketDataSessionActive
    }
  • enum _PhnMIPSessionType {
    phnMIPSessionNone,
    phnMIPSession
    }
  • enum _PhnDataServiceType {
    phnDataServiceNone,
    phnDataServiceCSD,
    phnDataService1xRTT,
    phnDataService1xEVDO,
    phnDataServiceGPRS,
    phnDataServiceEdge,
    phnDataServiceLast
    }
  • enum _PhnPacketDataEndStatusEnum {
    phnPacketDataEndStatusUnknown,
    phnPacketDataEndStatusNormal,
    phnPacketDataEndStatusReorder,
    phnPacketDataEndStatusRetry,
    phnPacketDataEndStatusTimeout,
    phnPacketDataEndStatusIntercept,
    phnPacketDataEndStatusReject,
    phnPacketDataEndStatusNoReason,
    phnPacketDataEndStatusAuthFailed,
    phnPacketDataEndStatusDropped,
    phnPacketDataEndStatusLast
    }

Define Documentation

#define isValidDataService ( x ) (x < phnDataServiceLast)

Definition at line 601 of file HsPhoneNetworkTypes.h.

#define isValidGSMDialClirStatus ( d ) ((d >= gsmDialCLIRNotProvisioned) && (d <= gsmDialCLIRTemporaryAllowed))

Definition at line 79 of file HsPhoneNetworkTypes.h.

#define isValidGSMRegistrationMode ( r ) (r <= gsmRegModeManualAutomatic)

Definition at line 177 of file HsPhoneNetworkTypes.h.

#define isValidPacketDataEndStatus ( x ) (x < phnPacketDataEndStatusLast)

Definition at line 623 of file HsPhoneNetworkTypes.h.

#define isValidPhnBandSelection ( f ) (f <= band1900_850)

Definition at line 507 of file HsPhoneNetworkTypes.h.

#define isValidPhnBarFacilityType ( b ) (b <= phnBarAll)

Definition at line 228 of file HsPhoneNetworkTypes.h.

#define isValidPhnCLIRStatus ( s ) ((s >= clirNotProvisioned) && (s <= clirTemporaryAllowed))

Definition at line 67 of file HsPhoneNetworkTypes.h.

#define isValidPhnForwardModeType ( f ) (f <= phnForwardModeErasure)

Definition at line 268 of file HsPhoneNetworkTypes.h.

#define isValidPhnForwardType ( f ) (f < phnForwardLast)

Definition at line 209 of file HsPhoneNetworkTypes.h.

#define isValidPhnMIPSessionType ( m ) (m <= phnMIPSession)

Definition at line 569 of file HsPhoneNetworkTypes.h.

#define isValidPhnMsgBoxType ( n ) (n < PhnMsgBoxTypeMAX)

Definition at line 112 of file HsPhoneNetworkTypes.h.

#define isValidPhnOneXProtRevType ( p ) (p <= phnOneXStatusPRev7)

Definition at line 541 of file HsPhoneNetworkTypes.h.

#define isValidPhnOperatorStatus ( s ) ((s >= phnOpUnknown) && (s <= phnOpForbidden))

Definition at line 91 of file HsPhoneNetworkTypes.h.

#define isValidPhnPacketDataSessionType ( p ) (p <= phnPacketDataSessionActive)

Definition at line 555 of file HsPhoneNetworkTypes.h.

#define isValidPhnRegistrationStatus ( r ) (r <= registrationRoaming)

Definition at line 253 of file HsPhoneNetworkTypes.h.

#define isValidRoamMode ( x ) (x < phnRoamPrefLast)

Definition at line 522 of file HsPhoneNetworkTypes.h.

#define kMaxImeiLen 24

Definition at line 441 of file HsPhoneNetworkTypes.h.

#define kMaxMMISequenceLen 64

Definition at line 356 of file HsPhoneNetworkTypes.h.

#define kMaxPhoneNumberLen 16

workaround for differing header files in sdk-3.5 and sdk-internal Max length of phone number

Definition at line 38 of file HsPhoneNetworkTypes.h.

#define MAX_LONGOPERATORNAME_LENGTH 24

Operator info

Definition at line 144 of file HsPhoneNetworkTypes.h.

#define MAX_SHORTOPERATORNAME_LENGTH 16

Definition at line 145 of file HsPhoneNetworkTypes.h.

#define maxPasswordLen 8

Phone password/PIN maximum length

Definition at line 41 of file HsPhoneNetworkTypes.h.

#define maxPasswordLenCDMA 4

Definition at line 42 of file HsPhoneNetworkTypes.h.

#define minPasswordLen 4

Phone password/PIN minimum length

Definition at line 40 of file HsPhoneNetworkTypes.h.

#define PhnDataSessionStateTypeMajorVersion 0x0001L

Definition at line 625 of file HsPhoneNetworkTypes.h.

#define PhnDataSessionStateTypeMinorVersion 0x0000L

Definition at line 626 of file HsPhoneNetworkTypes.h.

#define PhnDataSessionStateTypeVersion (((UInt32)PhnDataSessionStateTypeMajorVersion << 16) | PhnDataSessionStateTypeMinorVersion)

Definition at line 627 of file HsPhoneNetworkTypes.h.

#define phnEnhancedRoamIndMaxLength 40

Definition at line 44 of file HsPhoneNetworkTypes.h.

Typedef Documentation

typedef UInt8 PhnBandSelection

Definition at line 506 of file HsPhoneNetworkTypes.h.

typedef UInt8* PhnBarFacilityPtr

Definition at line 227 of file HsPhoneNetworkTypes.h.

typedef UInt8 PhnBarFacilityType

Definition at line 226 of file HsPhoneNetworkTypes.h.

typedef UInt8 PhnCallControlType

Definition at line 342 of file HsPhoneNetworkTypes.h.

typedef UInt16 PhnDataServiceType

Definition at line 600 of file HsPhoneNetworkTypes.h.

typedef UInt8 PhnForwardModeType

Phone call forwarding mode

Definition at line 259 of file HsPhoneNetworkTypes.h.

typedef UInt8 PhnForwardType

Phone call forwarding reason set a type for this enumeration

Definition at line 196 of file HsPhoneNetworkTypes.h.

typedef UInt8 PhnMIPSessionType

Definition at line 568 of file HsPhoneNetworkTypes.h.

typedef UInt8 PhnMMIActionCode

Definition at line 284 of file HsPhoneNetworkTypes.h.

typedef struct PhnMMIEntryType * PhnMMIEntryPtr

typedef struct PhnMMIResultType * PhnMMIResultPtr

typedef UInt8 PhnMMIServiceCode

Definition at line 327 of file HsPhoneNetworkTypes.h.

typedef UInt8 PhnMsgBoxPriorityType

Definition at line 114 of file HsPhoneNetworkTypes.h.

typedef UInt8 PhnMsgBoxType

Definition at line 99 of file HsPhoneNetworkTypes.h.

typedef UInt8 PhnOneXProtRevType

Definition at line 540 of file HsPhoneNetworkTypes.h.

typedef struct PhnOperatorListType* PhnOperatorListPtr

typedef UInt16 PhnPacketDataEndStatusType

Definition at line 622 of file HsPhoneNetworkTypes.h.

typedef UInt8 PhnPacketDataSessionType

Definition at line 554 of file HsPhoneNetworkTypes.h.

typedef struct PhnRoamPrefInfoType* PhnRoamPrefInfoPtr

typedef UInt8 PhnRoamPrefSelectionType

Definition at line 521 of file HsPhoneNetworkTypes.h.

typedef UInt8 PhnRoamStatus

Possible roaming status' GSM devices only use first two set a type for this enumeration

Definition at line 183 of file HsPhoneNetworkTypes.h.

Enumeration Type Documentation

enum _PhnBandSelection

Enumerator:
bandGSM_EGSM
band1800
band900_1800
band1900
bandAuto
band850
band1900_850

Definition at line 495 of file HsPhoneNetworkTypes.h.

00496 {
00497   bandGSM_EGSM = 0,
00498   band1800,
00499   band900_1800,
00500   band1900,
00501   bandAuto,
00502   band850,
00503   band1900_850
00504 } _PhnBandSelection;

enum _PhnDataServiceType

This defines the different data service types.

Enumerator:
phnDataServiceNone
phnDataServiceCSD
phnDataService1xRTT
phnDataService1xEVDO
phnDataServiceGPRS
phnDataServiceEdge
phnDataServiceLast

Definition at line 589 of file HsPhoneNetworkTypes.h.

00590 {
00591   phnDataServiceNone,
00592   phnDataServiceCSD,
00593   phnDataService1xRTT,
00594   phnDataService1xEVDO,
00595   phnDataServiceGPRS,
00596   phnDataServiceEdge,
00597   phnDataServiceLast
00598 }

enum _PhnMIPSessionType

This is now deprecated. It is only implemented to maintain backwards compatibility Currently, the only user is NetMaster

Enumerator:
phnMIPSessionNone
phnMIPSession A Mobile IP session exists.

Definition at line 562 of file HsPhoneNetworkTypes.h.

00563 {
00564     phnMIPSessionNone,      /**<        */
00565     phnMIPSession           /**< A Mobile IP session exists. */
00566 }

enum _PhnOneXProtRevType

This is now deprecated. It is only implemented to maintain backwards compatibility Currently, the only user is NetMaster

Enumerator:
phnOneXStatusPRevNoSvc | Service is not available.
phnOneXStatusPRev1 | J-STD-008 service is in use.
phnOneXStatusPRev3 | IS-95A service is in use.
phnOneXStatusPRev4 | IS-95B service is in use.
phnOneXStatusPRev6 | IS-2000 release 0 service is in use.
phnOneXStatusPRev7 | IS-2000 release A service is in use.

Definition at line 530 of file HsPhoneNetworkTypes.h.

00531 {
00532     phnOneXStatusPRevNoSvc,     /**< Service is not available. */
00533     phnOneXStatusPRev1,         /**< J-STD-008 service is in use. */
00534     phnOneXStatusPRev3,         /**< IS-95A service is in use. */
00535     phnOneXStatusPRev4,         /**< IS-95B service is in use. */
00536     phnOneXStatusPRev6,         /**< IS-2000 release 0 service is in use. */
00537     phnOneXStatusPRev7      /**< IS-2000 release A service is in use. */
00538 }

enum _PhnPacketDataEndStatusEnum

List of errors on why a data call was disconnected.

Enumerator:
phnPacketDataEndStatusUnknown | Unknown end status
phnPacketDataEndStatusNormal | Normal
phnPacketDataEndStatusReorder | reoder
phnPacketDataEndStatusRetry | retry
phnPacketDataEndStatusTimeout | call
phnPacketDataEndStatusIntercept | Intercept
phnPacketDataEndStatusReject | Service Option rejected
phnPacketDataEndStatusNoReason | No reason given
phnPacketDataEndStatusAuthFailed | authentication failed
phnPacketDataEndStatusDropped | dropped call
phnPacketDataEndStatusLast | place holder for last

Definition at line 607 of file HsPhoneNetworkTypes.h.

00608 {
00609   phnPacketDataEndStatusUnknown,       /**< Unknown end status      */
00610   phnPacketDataEndStatusNormal,        /**< Normal                  */
00611   phnPacketDataEndStatusReorder,       /**< reoder                  */
00612   phnPacketDataEndStatusRetry,         /**< retry                   */
00613   phnPacketDataEndStatusTimeout,       /**< call                    */
00614   phnPacketDataEndStatusIntercept,     /**< Intercept               */
00615   phnPacketDataEndStatusReject,        /**< Service Option rejected */
00616   phnPacketDataEndStatusNoReason,      /**< No reason given         */
00617   phnPacketDataEndStatusAuthFailed,    /**< authentication failed   */
00618   phnPacketDataEndStatusDropped,       /**< dropped call            */
00619   phnPacketDataEndStatusLast           /**< place holder for last   */
00620 }

enum _PhnPacketDataSessionType

Describes the current packet data session state. Currently there are 3 states. Active, dormant, or none.

Enumerator:
phnPacketDataSessionNone | No packet data session exists.
phnPacketDataSessionDormant | Packet data session dormant
phnPacketDataSessionActive | Packet data session active

Definition at line 547 of file HsPhoneNetworkTypes.h.

00548 {
00549   phnPacketDataSessionNone,         /**< No packet data session exists. */
00550   phnPacketDataSessionDormant,      /**< Packet data session dormant    */
00551   phnPacketDataSessionActive        /**< Packet data session active     */
00552 }

enum _PhnRoamPrefSelectionTypeEnum

This defines the roaming mode of the radio.

Enumerator:
phnRoamPrefHomeOnly | Home network only (no roaming)
phnRoamPrefAny | Any network (roaming allowed)
phnRoamPrefRoamOnly | Roam network only (roaming only)
phnRoamPrefLast | end of list enum

Definition at line 513 of file HsPhoneNetworkTypes.h.

00514 {
00515   phnRoamPrefHomeOnly,   /**< Home network only (no roaming)      */
00516   phnRoamPrefAny,        /**< Any network       (roaming allowed) */
00517   phnRoamPrefRoamOnly,   /**< Roam network only (roaming only)    */
00518   phnRoamPrefLast        /**< end of list enum                    */
00519 }

enum GSMCLIPStatus

GSM CLIP Subscription Status

Enumerator:
gsmCLIPNotProvisioned
gsmCLIPProvisioned
gsmCLIPUnknown

Definition at line 49 of file HsPhoneNetworkTypes.h.

00049              {
00050     gsmCLIPNotProvisioned,      /**<        */
00051     gsmCLIPProvisioned,     /**<        */
00052     gsmCLIPUnknown          /**<        */
00053 } GSMCLIPStatus;

enum GSMCLIRDisplayStatus

GSM CLIR Display Status

Enumerator:
gsmCLIRSubscription presentation indicator is used according to the subscription of the CLIR service
gsmCLIRInvocation
gsmCLIRSuppression

Definition at line 73 of file HsPhoneNetworkTypes.h.

00073              {
00074   gsmCLIRSubscription,      /**< presentation indicator is used according to the subscription of the CLIR service */
00075   gsmCLIRInvocation,        /**<        */
00076   gsmCLIRSuppression        /**<        */
00077 } GSMCLIRDisplayStatus;

enum GSMRegistrationMode

Enumerator:
gsmRegModeAutomatic
gsmRegModeManual
gsmRegModeDeregister
gsmRegModeFormat
gsmRegModeManualAutomatic

Definition at line 169 of file HsPhoneNetworkTypes.h.

00169              {
00170     gsmRegModeAutomatic,        /**<        */
00171     gsmRegModeManual,       /**<        */
00172     gsmRegModeDeregister,       /**<        */
00173     gsmRegModeFormat,       /**<        */
00174     gsmRegModeManualAutomatic   /**<        */
00175 } GSMRegistrationMode;

enum PhnBarFacilityTypeEnum

Phone call barring options

Enumerator:
phnBarOutNone
phnBarOutAll
phnBarOutInternational
phnBarOutInternationalExceptHome
phnBarInNone
phnBarInAll
phnBarInWhenRoaming
phnBarAll

Definition at line 214 of file HsPhoneNetworkTypes.h.

00214              {
00215     phnBarOutNone,              /**<        */
00216     phnBarOutAll,               /**<        */
00217     phnBarOutInternational,         /**<        */
00218     phnBarOutInternationalExceptHome,   /**<        */
00219
00220     phnBarInNone,               /**<        */
00221     phnBarInAll,                /**<        */
00222     phnBarInWhenRoaming,            /**<        */
00223     phnBarAll               /**<        */
00224
00225 } PhnBarFacilityTypeEnum;

enum PhnCallControlTypeEnum

Call Control Codes

Enumerator:
mmiControlReleaseAllHeld
mmiControlReleaseAllActive
mmiControlReleaseCallx
mmiControlSwap
mmiControlActivateCallx
mmiControlConference
mmiControlTransfer

Definition at line 332 of file HsPhoneNetworkTypes.h.

00332              {
00333   mmiControlReleaseAllHeld = 0,     /**<        */
00334   mmiControlReleaseAllActive,       /**<        */
00335   mmiControlReleaseCallx,       /**<        */
00336   mmiControlSwap,           /**<        */
00337   mmiControlActivateCallx,      /**<        */
00338   mmiControlConference,         /**<        */
00339   mmiControlTransfer            /**<        */
00340 }PhnCallControlTypeEnum;

enum PhnCLIRStatus

Enumerator:
clirNotProvisioned | sent: restricted presentation of the calling line
clirProvisioned | not sent: don't restrict presentation of the calling line
clirUnknown | status not available
clirTemporaryRestricted | not sent, override allowed
clirTemporaryAllowed | sent: override allowed

Definition at line 59 of file HsPhoneNetworkTypes.h.

00059              {
00060     clirNotProvisioned,         /**< sent: restricted presentation of the calling line */
00061     clirProvisioned,            /**< not sent: don't restrict presentation of the calling line */
00062     clirUnknown,                /**< status not available */
00063     clirTemporaryRestricted,        /**< not sent, override allowed */
00064     clirTemporaryAllowed            /**< sent: override allowed */
00065 } PhnCLIRStatus;

enum PhnForwardEnum

Enumerator:
phnForwardUnconditional
phnForwardOnBusy
phnForwardOnNoReplay
phnForwardOnNotReachable
phnForwardTelefax
phnForwardData
phnForwardCancelAll
phnForwardConditionalAll
phnForwardLast

Definition at line 197 of file HsPhoneNetworkTypes.h.

00197              {
00198     phnForwardUnconditional,    /**<        */
00199     phnForwardOnBusy,       /**<        */
00200     phnForwardOnNoReplay,       /**<        */
00201     phnForwardOnNotReachable,   /**<        */
00202     phnForwardTelefax,      /**<        */
00203     phnForwardData,         /**<        */
00204     phnForwardCancelAll,        /**<        */
00205     phnForwardConditionalAll,   /**<        */
00206     phnForwardLast          /**<        */
00207 } PhnForwardEnum;

enum PhnForwardModeEnum

Enumerator:
phnForwardModeDisable
phnForwardModeEnable
phnForwardModeInterrogate
phnForwardModeRegistration
phnForwardModeErasure

Definition at line 260 of file HsPhoneNetworkTypes.h.

00260              {
00261     phnForwardModeDisable,      /**<        */
00262     phnForwardModeEnable,       /**<        */
00263     phnForwardModeInterrogate,  /**<        */
00264     phnForwardModeRegistration, /**<        */
00265     phnForwardModeErasure       /**<        */
00266 } PhnForwardModeEnum;

enum PhnMMIActionCodeEnum

MMI Action Code

Enumerator:
mmiActionNoAction
mmiActionActivate
mmiActionDeactivate
mmiActionInterrogate
mmiActionRegister
mmiActionErasure
mmiActionUnlock
mmiActionHandspring

Definition at line 272 of file HsPhoneNetworkTypes.h.

00273 {
00274   mmiActionNoAction     = 0,        /**<        */
00275   mmiActionActivate     = 0x01,     /**<        */
00276   mmiActionDeactivate   = 0x02,     /**<        */
00277   mmiActionInterrogate  = 0x04,     /**<        */
00278   mmiActionRegister     = 0x08,     /**<        */
00279   mmiActionErasure      = 0x10,     /**<        */
00280   mmiActionUnlock       = 0x20,     /**<        */
00281   mmiActionHandspring   = 0x40      /**<        */
00282 }

enum PhnMMIServiceCodeEnum

MMI Service Code

Enumerator:
mmiServiceInvalid
mmiServiceChangePIN
mmiServiceChangePIN2
mmiServiceUnlockPIN
mmiServiceUnlockPIN2
mmiServiceIMEI
mmiServiceCallerId
mmiServiceNumberSent
mmiServiceCOLP
mmiServiceCOLR
mmiServiceCallWaiting
mmiServiceForwardUnconditional
mmiServiceForwardBusy
mmiServiceForwardNoReply
mmiServiceForwardNotReachable
mmiServiceForwardAll
mmiServiceForwardConditionalAll
mmiServiceBAOC | bar all outging calls
mmiServiceBAOIC | bar all outging international calls
mmiServiceBAOICX | bar all outging international calls expect home
mmiServiceBAIC | bar all incoming calls
mmiServiceBAICR | bar all incoming calls while roaming
mmiServiceAllBarringServ | bar all services
mmiServiceAllOutBarringServ | bar all outgoing services
mmiServiceAllInBarringServ | bar all incoming services
mmiServiceChangeBarPwd | Change barring password
mmiServiceUSSD
mmiServicePhoneNumber
mmiServiceCallControl
mmiServiceSelectorOperatorLock
mmiServiceSelectorProviderLock
mmiServiceNNN
mmiServiceUnimplemented | defined by GSM standard but not implemented in our phone

Definition at line 290 of file HsPhoneNetworkTypes.h.

00291 {
00292     mmiServiceInvalid = 0,      /**<        */
00293     mmiServiceChangePIN,        /**<        */
00294     mmiServiceChangePIN2,       /**<        */
00295     mmiServiceUnlockPIN,        /**<        */
00296     mmiServiceUnlockPIN2,       /**<        */
00297     mmiServiceIMEI,         /**<        */
00298     mmiServiceCallerId,     /**<        */
00299     mmiServiceNumberSent,       /**<        */
00300     mmiServiceCOLP,         /**<        */
00301     mmiServiceCOLR,         /**<        */
00302     mmiServiceCallWaiting,      /**<        */
00303     mmiServiceForwardUnconditional, /**<        */
00304     mmiServiceForwardBusy,      /**<        */
00305     mmiServiceForwardNoReply,   /**<        */
00306     mmiServiceForwardNotReachable,  /**<        */
00307     mmiServiceForwardAll,       /**<        */
00308     mmiServiceForwardConditionalAll,/**<        */
00309     mmiServiceBAOC,         /**< bar all outging calls */
00310     mmiServiceBAOIC,        /**< bar all outging international calls */
00311     mmiServiceBAOICX,       /**< bar all outging international calls expect home */
00312     mmiServiceBAIC,         /**< bar all incoming calls */
00313     mmiServiceBAICR,        /**< bar all incoming calls while roaming */
00314     mmiServiceAllBarringServ,   /**< bar all services */
00315     mmiServiceAllOutBarringServ,    /**< bar all outgoing services */
00316     mmiServiceAllInBarringServ,     /**< bar all incoming services */
00317     mmiServiceChangeBarPwd,     /**< Change barring password */
00318     mmiServiceUSSD,         /**<        */
00319     mmiServicePhoneNumber,      /**<        */
00320     mmiServiceCallControl,      /**<        */
00321     mmiServiceSelectorOperatorLock, /**<        */
00322     mmiServiceSelectorProviderLock, /**<        */
00323     mmiServiceNNN,          /**<        */
00324     mmiServiceUnimplemented     /**< defined by GSM standard but not implemented in our phone */
00325 }

enum PhnMsgBoxEnum

Enumerator:
kBoxVoice
kBoxTelefax
kBoxEMail
kBoxOther
kBoxData
PhnMsgBoxTypeMAX THIS MUST BE LAST ENTRY.... NOT A VALID VALUE

Definition at line 100 of file HsPhoneNetworkTypes.h.

00101   {
00102     kBoxVoice,          /**<        */
00103     kBoxTelefax,        /**<        */
00104     kBoxEMail,          /**<        */
00105     kBoxOther,          /**<        */
00106     kBoxData,           /**<        */
00107     PhnMsgBoxTypeMAX        /**< THIS MUST BE LAST ENTRY.... NOT A VALID VALUE */
00108     // other values reserved for future expansion
00109   }

enum PhnMsgBoxPriorityEnum

Enumerator:
kSmsPriorityNormal
kSmsPriorityInteractive
kSmsPriorityUrgent
kSmsPriorityEmergency
kSmsPriorityLast

Definition at line 115 of file HsPhoneNetworkTypes.h.

00116 {
00117   kSmsPriorityNormal,
00118   kSmsPriorityInteractive,
00119   kSmsPriorityUrgent,
00120   kSmsPriorityEmergency,
00121   kSmsPriorityLast
00122 }

enum PhnOperatorStatus

Phone operator status

Enumerator:
phnOpUnknown
phnOpAvailable
phnOpCurrent
phnOpForbidden

Definition at line 84 of file HsPhoneNetworkTypes.h.

00084              {
00085     phnOpUnknown,       /**<        */
00086     phnOpAvailable,     /**<        */
00087     phnOpCurrent,       /**<        */
00088     phnOpForbidden      /**<        */
00089 } PhnOperatorStatus;

enum PhnRegistrationStatus

Enumerator:
registrationNone
registrationHome
registrationSearch
registrationDenied
registrationUnknown
registrationRoaming

Definition at line 244 of file HsPhoneNetworkTypes.h.

00244               {
00245     registrationNone,       /**<        */
00246     registrationHome,       /**<        */
00247     registrationSearch,         /**<        */
00248     registrationDenied,     /**<        */
00249     registrationUnknown,        /**<        */
00250     registrationRoaming     /**<        */
00251 } PhnRegistrationStatus;

enum PhnRoamIconState

Enumerator:
PhnRoamIconOn
PhnRoamIconOff
PhnRoamIconFlash

Definition at line 345 of file HsPhoneNetworkTypes.h.

00346 {
00347   PhnRoamIconOn,            /**<        */
00348   PhnRoamIconOff,           /**<        */
00349   PhnRoamIconFlash          /**<        */
00350 }

enum PhnRoamStatusEnum

Enumerator:
PhnRoamStatusOff
PhnRoamStatusOn
PhnRoamStatusBlink
PhnRoamStatusEnhancedIndicator If this is the roaming status, call PhnLibGetEnhancedRoamIndicator

Definition at line 184 of file HsPhoneNetworkTypes.h.

00185   {
00186     PhnRoamStatusOff,           /**<        */
00187     PhnRoamStatusOn,            /**<        */
00188     PhnRoamStatusBlink,         /**<        */
00189     PhnRoamStatusEnhancedIndicator      /**< If this is the roaming status, call PhnLibGetEnhancedRoamIndicator  */
00190   }

enum PhnTeleserviceMmiCodeType

Telephone Service MMI code Types

Enumerator:
phnTeleserviceUnknownMmiCode
phnTeleserviceVoiceMmiCode
phnTeleserviceAllMmiCode
phnTeleserviceFaxMmiCode
phnTeleserviceSMSMmiCode
phnTeleserviceAllExceptSMSCode
phnTeleserviceDataCircSyncMmiCode
phnTeleserviceDataCircAsyncMmiCode
phnTeleserviceDedicatedPackMmiCode
phnTeleserviceDedicatedPADMmiCode

Definition at line 378 of file HsPhoneNetworkTypes.h.

00378              {
00379   phnTeleserviceUnknownMmiCode        = 0,  /**<        */
00380   phnTeleserviceVoiceMmiCode          = 11, /**<        */
00381   phnTeleserviceAllMmiCode            = 12, /**<        */
00382   phnTeleserviceFaxMmiCode            = 13, /**<        */
00383   phnTeleserviceSMSMmiCode            = 16, /**<        */
00384   phnTeleserviceAllExceptSMSCode      = 19, /**<        */
00385   phnTeleserviceDataCircSyncMmiCode   = 24, /**<        */
00386   phnTeleserviceDataCircAsyncMmiCode  = 25, /**<        */
00387   phnTeleserviceDedicatedPackMmiCode  = 26, /**<        */
00388   phnTeleserviceDedicatedPADMmiCode   = 27  /**<        */
00389 } PhnTeleserviceMmiCodeType;

enum PhnTeleserviceType

Telephone Service Types

Enumerator:
phnTeleserviceUnknown
phnTeleserviceVoice
phnTeleserviceData
phnTeleserviceFax
phnTeleserviceDefault Voice + Data + Fax
phnTeleserviceSMS
phnTeleserviceDataCircSync
phnTeleserviceDataCircAsync
phnTeleserviceDedicatedPack
phnTeleserviceDedicatedPAD

Definition at line 361 of file HsPhoneNetworkTypes.h.

00361              {
00362   phnTeleserviceUnknown = 0,        /**<        */
00363   phnTeleserviceVoice = 1,      /**<        */
00364   phnTeleserviceData = 2,       /**<        */
00365   phnTeleserviceFax = 4,        /**<        */
00366   phnTeleserviceDefault = 7,        /**<  Voice + Data + Fax */
00367   phnTeleserviceSMS = 8,        /**<        */
00368   phnTeleserviceDataCircSync = 16,  /**<        */
00369   phnTeleserviceDataCircAsync = 32, /**<        */
00370   phnTeleserviceDedicatedPack = 64, /**<        */
00371   phnTeleserviceDedicatedPAD = 128  /**<        */
00372 } PhnTeleserviceType;

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:07:24 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » telephony

HsPhonePower.h File Reference

Detailed Description

Header File for Phone Library API ---- POWER CATEGORY.

Notes: All implementations of the Handspring Phone Library support a common API. This API is broken up into various categories for easier management. This file defines the POWER category. This category provides routines to query & manage the radio power.

Definition in file HsPhonePower.h.

Include dependency graph for HsPhonePower.h:

Go to the source code of this file.

Functions

  • Err PhnLibSetModulePower (UInt16 refNum, Boolean on)
    Parameters:
    refNum,: IN:

  • PhnPowerType PhnLibModulePowered (UInt16 refNum)
    Parameters:
    refNum,: IN:

  • Err PhnLibContinuePhonePowerOn (UInt16 refNum)
    Parameters:
    refNum,: IN:

  • Err PhnLibContinuePhonePowerOff (UInt16 refNum)
    Parameters:
    refNum,: IN:

Function Documentation

Err PhnLibContinuePhonePowerOff ( UInt16 refNum )

Parameters:
refNum,: IN:

Return values:
Err Error code.

Err PhnLibContinuePhonePowerOn ( UInt16 refNum )

Parameters:
refNum,: IN:

Return values:
Err Error code.

PhnPowerType PhnLibModulePowered ( UInt16 refNum )

Parameters:
refNum,: IN:

Return values:
Err Error code.

Err PhnLibSetModulePower | ( | UInt16 | refNum,
 |  | Boolean | on
 | ) |  |

Parameters:
refNum,: IN:

Parameters:
on,: IN:
Return values:
Err Error code.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:07:25 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » telephony

HsPhoneSecurity.h File Reference

Detailed Description

Header File for Phone Library API ---- SECURITY CATEGORY.

Notes: All implementations of the Handspring Phone Library support a common API. This API is broken up into various categories for easier management. This file defines the public portion of the Security category. These API calls are used to protect access to device and phone features.

Definition in file HsPhoneSecurity.h.

Include dependency graph for HsPhoneSecurity.h:

Go to the source code of this file.

Functions

  • Err PhnLibGetPhoneLock (UInt16 refNum, Boolean *lock, Boolean *autoLockCheckBoxState)
    Parameters:
    refNum,: IN:

  • Err PhnLibSetPhoneLock (UInt16 refNum, Boolean enable, PhnLockMode lockMode, CharPtr password)
  • Err PhnLibSetOperatorLock (UInt16 refNum, UInt16 facilityType, Boolean enable, CharPtr password)
  • Err PhnLibGetRemainingPasswordTries (UInt16 refNum, Int16 *pinTries, Int16 *pin2Tries, Int16 *pukTries, Int16 *puk2Tries)
  • Err PhnLibCRSM (UInt16 refNum, UInt16 command, UInt32 fileId, UInt16 p1, UInt16 p2, UInt16 p3, UInt8 *data, UInt16 dataSize, UInt16 *sw1, UInt16 *sw2, char **response, UInt16 *responseSize)

Function Documentation

Err PhnLibCRSM | ( | UInt16 | refNum,
 |  | UInt16 | command,
 |  | UInt32 | fileId,
 |  | UInt16 | p1,
 |  | UInt16 | p2,
 |  | UInt16 | p3,
 |  | UInt8 * | data,
 |  | UInt16 | dataSize,
 |  | UInt16 * | sw1,
 |  | UInt16 * | sw2,
 |  | char ** | response,
 |  | UInt16 * | responseSize
 | ) |  |

Err PhnLibGetPhoneLock | ( | UInt16 | refNum,
 |  | Boolean * | lock,
 |  | Boolean * | autoLockCheckBoxState
 | ) |  |

Parameters:
refNum,: IN:

Parameters:
lock,: IN:
autoLockCheckBoxState,: IN:
Return values:
Err Error code.

Err PhnLibGetRemainingPasswordTries | ( | UInt16 | refNum,
 |  | Int16 * | pinTries,
 |  | Int16 * | pin2Tries,
 |  | Int16 * | pukTries,
 |  | Int16 * | puk2Tries
 | ) |  |

Err PhnLibSetOperatorLock | ( | UInt16 | refNum,
 |  | UInt16 | facilityType,
 |  | Boolean | enable,
 |  | CharPtr | password
 | ) |  |

Err PhnLibSetPhoneLock | ( | UInt16 | refNum,
 |  | Boolean | enable,
 |  | PhnLockMode | lockMode,
 |  | CharPtr | password
 | ) |  |

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:07:25 2008 for Palm API Guide


Header Files » Incs » common » libraries » telephony

HsPhoneSecurityTypes.h File Reference

Detailed Description

Header File for Phone Library API ---- NETWORK CATEGORY.

NOTES: All implementations of the Handspring Phone Library support a common API. This API is broken up into various categories for easier management. This file defines the Security category. These API calls are used to interact with the wireless network.

Definition in file HsPhoneSecurityTypes.h.

Include dependency graph for HsPhoneSecurityTypes.h:

Go to the source code of this file.

Defines

  • #define isValidPhnPasswordType(p) (p <= phnPasswordBarrAC)

Typedefs

  • typedef UInt8 PhnPasswordType

Enumerations

  • enum PhnPasswordTypeEnum {
    phnPasswordUnknown,
    phnPasswordNone,
    phnPasswordSIMPIN,
    phnPasswordSIMPUK,
    phnPasswordPhSIMPIN,
    phnPasswordPh1SIMPIN,
    phnPasswordPh1SIMPUK,
    phnPasswordSIMPIN2,
    phnPasswordSIMPUK2,
    phnPasswordNetworkPIN,
    phnPasswordNetworkPUK,
    phnPasswordNetworkSubsetPIN,
    phnPasswordNetworkSubsetPUK,
    phnPasswordServiceProviderPIN,
    phnPasswordServiceProviderPUK,
    phnPasswordCorporatePIN,
    phnPasswordCorporatePUK,
    phnPasswordBarrAO,
    phnPasswordBarrOI,
    phnPasswordBarrOX,
    phnPasswordBarrAI,
    phnPasswordBarrIR,
    phnPasswordBarrAB,
    phnPasswordBarrAG,
    phnPasswordBarrAC
    }

Define Documentation

#define isValidPhnPasswordType ( p ) (p <= phnPasswordBarrAC)

workaround for differing header files in sdk-3.5 and sdk-internal

Definition at line 37 of file HsPhoneSecurityTypes.h.

Typedef Documentation

typedef UInt8 PhnPasswordType

Definition at line 84 of file HsPhoneSecurityTypes.h.

Enumeration Type Documentation

enum PhnPasswordTypeEnum

Phone password types See GSM 07.07, section 8.3 for a list of passwords. The following list is based on on version 6.2.0 of the recommendation.

It is assumed that all PINs and PUKs below are network-based PINS and PUKs. Function Change() uses a different timeout for such PINs and/or PUKs.

Enumerator:
phnPasswordUnknown | FAULT or none of the strings below
phnPasswordNone | READY
phnPasswordSIMPIN | SIM PIN
phnPasswordSIMPUK | SIM PUK
phnPasswordPhSIMPIN | PH-SIM PIN
phnPasswordPh1SIMPIN | PH-FSIM PIN
phnPasswordPh1SIMPUK | PH-FSIM PUK
phnPasswordSIMPIN2 | SIM PIN2
phnPasswordSIMPUK2 | SIM PUK2
phnPasswordNetworkPIN | PH-NET PIN
phnPasswordNetworkPUK | PH-NET PUK
phnPasswordNetworkSubsetPIN | PH-NETSUB PIN
phnPasswordNetworkSubsetPUK | PH-NETSUB PUK
phnPasswordServiceProviderPIN | PH-SP PIN
phnPasswordServiceProviderPUK | PH-SP PUK
phnPasswordCorporatePIN | PH-CORP PIN
phnPasswordCorporatePUK | PH-CORP PUK
phnPasswordBarrAO | all outgoing call
phnPasswordBarrOI | outgoing intÕl calls
phnPasswordBarrOX | outgoing intÕl calls except to home country
phnPasswordBarrAI | all incoming calls
phnPasswordBarrIR | incoming calls when roaming outside home country
phnPasswordBarrAB | all barring services
phnPasswordBarrAG | all outgoing barring services
phnPasswordBarrAC | all incoming barring services

Definition at line 50 of file HsPhoneSecurityTypes.h.

00050              {
00051     phnPasswordUnknown,     /**< FAULT or none of the strings below */
00052
00053     phnPasswordNone,        /**< READY */
00054     phnPasswordSIMPIN,      /**< SIM PIN */
00055     phnPasswordSIMPUK,      /**< SIM PUK */
00056     phnPasswordPhSIMPIN,        /**< PH-SIM PIN */
00057     phnPasswordPh1SIMPIN,       /**< PH-FSIM PIN */
00058     phnPasswordPh1SIMPUK,       /**< PH-FSIM PUK */
00059     phnPasswordSIMPIN2,     /**< SIM PIN2 */
00060     phnPasswordSIMPUK2,     /**< SIM PUK2 */
00061
00062     phnPasswordNetworkPIN,      /**< PH-NET PIN */
00063     phnPasswordNetworkPUK,      /**< PH-NET PUK */
00064     phnPasswordNetworkSubsetPIN,    /**< PH-NETSUB PIN */
00065     phnPasswordNetworkSubsetPUK,    /**< PH-NETSUB PUK */
00066     phnPasswordServiceProviderPIN,  /**< PH-SP PIN */
00067     phnPasswordServiceProviderPUK,  /**< PH-SP PUK */
00068     phnPasswordCorporatePIN,    /**< PH-CORP PIN */
00069     phnPasswordCorporatePUK,    /**< PH-CORP PUK */
00070
00071         // The passwords below are supported by the +CPWD command. See GSM 07.07
00072     // section 7.4 and 7.5 for a list of facility-specific passwords.
00073
00074     phnPasswordBarrAO,      /**< all outgoing call */
00075     phnPasswordBarrOI,      /**< outgoing intÕl calls */
00076     phnPasswordBarrOX,      /**< outgoing intÕl calls except to home country */
00077     phnPasswordBarrAI,      /**< all incoming calls */
00078     phnPasswordBarrIR,      /**< incoming calls when roaming outside home country */
00079     phnPasswordBarrAB,      /**< all barring services */
00080     phnPasswordBarrAG,      /**< all outgoing barring services */
00081     phnPasswordBarrAC       /**< all incoming barring services */
00082 } PhnPasswordTypeEnum;

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:07:25 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » telephony

HsPhoneSMS.h File Reference

Detailed Description

Header File for Phone Library API ---- SMS CATEGORY.

Notes: All implementations of the Handspring Phone Library support a common API. This API is broken up into various categories for easier management. This file defines the SMS category. These API calls are used to send/receive Short Message Service (SMS) messages.

Definition in file HsPhoneSMS.h.

Include dependency graph for HsPhoneSMS.h:

Go to the source code of this file.

Functions

  • PhnAddressHandle PhnLibNewAddress (UInt16 refNum, const CharPtr number, PhnDatabaseID id)
    Parameters:
    refNum,: IN:

  • CharPtr PhnLibGetField (UInt16 refNum, PhnAddressHandle address, PhnAddressField field)
    This function returns the field’s value for a given address in a newly allocated block. This function returns 0 if there was an error while retrieving the data.
  • PhnDatabaseID PhnLibGetID (UInt16 refNum, PhnAddressHandle address)
    Parameters:
    refNum,: IN:

  • Err PhnLibSetField (UInt16 refNum, PhnAddressHandle address, PhnAddressField field, const char *data)
    This function lets the specified field of address to the given data. This function returns 0 if the field was modified without an error.
  • Err PhnLibSetNumber (UInt16 refNum, PhnAddressHandle address, const char *number)
    Parameters:
    refNum,: IN:

  • Err PhnLibSetID (UInt16 refNum, PhnAddressHandle address, PhnDatabaseID id)
    Parameters:
    refNum,: IN:

  • char * PhnLibAddressToText (UInt16 refNum, PhnAddressHandle address, SMSAddressFormat format)
    Parameters:
    refNum,: IN:

  • Boolean PhnLibHasName (UInt16 refNum, PhnAddressHandle address)
    Parameters:
    refNum,: IN:

  • Boolean PhnLibEqual (UInt16 refNum, PhnAddressHandle a, PhnAddressHandle b)
    Parameters:
    refNum,: IN:

  • DmOpenRef PhnLibGetDBRef (UInt16 refNum)
    Parameters:
    refNum,: IN:

  • Err PhnLibReleaseDBRef (UInt16 refNum, DmOpenRef db)
    Parameters:
    refNum,: IN:

  • PhnDatabaseID PhnLibNewMessage (UInt16 refNum, SMSMessageType type)
    Create a new message of the given message type and return the ID of the new record in the message database. All fields are either empty (e.g. message’s text) or contain default values (e.g. sending options).
  • Err PhnLibDeleteMessage (UInt16 refNum, PhnDatabaseID msgID, Boolean archive)
    This function deletes the message with the given msgID from the message database.
  • Err PhnLibSendMessage (UInt16 refNum, PhnDatabaseID msgID, Boolean progress)
    This function sends the message to all the recipients.
  • Err PhnLibSendPendingMessages (UInt16 refNum)
    Parameters:
    refNum,: IN:

  • Err PhnLibSetText (UInt16 refNum, PhnDatabaseID msgID, const char *data, Int16 size)
    This function sets the text of the message to the given text.
  • Err PhnLibSetDate (UInt16 refNum, PhnDatabaseID msgID, UInt32 date)
    This function sets the date of the given message. The date must be given in Palm OS format (as returned by TimGetSeconds).
  • Err PhnLibSetOptions (UInt16 refNum, PhnDatabaseID msgID, const SMSSendOptions *options)
    This function updates the sending options for the given message.
  • Err PhnLibSetAddresses (UInt16 refNum, PhnDatabaseID msgID, const PhnAddressList list)
    This function updates the list of addresses with the given list of addresses.
  • Err PhnLibSetStatus (UInt16 refNum, PhnDatabaseID msgID, SMSMessageStatus status)
    This function sets the status of the given message.
  • Err PhnLibSetFlags (UInt16 refNum, PhnDatabaseID msgID, UInt32 flags)
    This function updates a message’s flags.
  • Err PhnLibSetOwner (UInt16 refNum, PhnDatabaseID msgID, UInt32 owner)
    This function updates the given message’s owner.
  • Err PhnLibGetText (UInt16 refNum, PhnDatabaseID msgID, MemHandle *data)
    This function copies the text of the message into a new block of memory that must be disposed of by the caller.
  • Err PhnLibGetDate (UInt16 refNum, PhnDatabaseID msgID, UInt32 *date)
    This function returns the date of the given message in Palm OS format.
  • Err PhnLibGetOptions (UInt16 refNum, PhnDatabaseID msgID, SMSSendOptions *options)
    This function returns the sending options for the given message.
  • Err PhnLibGetAddresses (UInt16 refNum, PhnDatabaseID msgID, PhnAddressList *list)
    This function returns the list of addresses for the given message.
  • Err PhnLibGetStatus (UInt16 refNum, PhnDatabaseID msgID, SMSMessageStatus *status)
    This function returns the status field of the message.
  • Err PhnLibGetFlags (UInt16 refNum, PhnDatabaseID msgID, UInt32 *flags)
    This function returns the message’s flags.
  • Err PhnLibGetOwner (UInt16 refNum, PhnDatabaseID msgID, UInt32 *owner)
    This function returns the message’s owner.
  • Err PhnLibGetType (UInt16 refNum, PhnDatabaseID msgID, SMSMessageType *type)
    This function returns the message’s type. A client application typically uses the type to map messages to categories.
  • Boolean PhnLibIsLegalCharacter (UInt16 refNum, char c)
    This function returns true if the given Palm OS character is a legal GSM character. If this function returns false, the given character does not exist within the GSM alphabet.
  • char PhnLibMapCharacter (UInt16 refNum, char c)
    This function maps the given Palm OS character to its equivalent in the GSM alphabet.
  • Err PhnLibSetServiceCentreAddress (UInt16 refNum, const PhnAddressHandle address)
    This function sets the number of the service center to be used for sending the SMS messages.
  • Err PhnLibGetServiceCentreAddress (UInt16 refNum, PhnAddressHandle *address)
    This function returns the number of the service center currently used for sending messages in a newly allocated address.
  • Int16 PhnLibLength (UInt16 refNum, const char *text, Boolean inMessages, Boolean substitution)
    This function returns the length of the given text in characters or messages.
  • Err PhnLibGetLengthDetails (UInt16 refNum, const char *text, const char *address, PhnLibLengthInfoType *info)
    Parameters:
    refNum,: IN:

  • const char * PhnLibGetSubstitution (UInt16 refNum, char c)
    This function returns the substitution string for a given GSM character.
  • PhnAddressList PhnLibNewAddressList (UInt16 refNum)
    This function returns a new address list. The list is initially empty and must be disposed of by the caller using PhnLibDisposeAddressList() or MemHandleFree().
  • Err PhnLibDisposeAddressList (UInt16 refNum, PhnAddressList list)
    This function disposes of the memory used by the given address list. It should be called after your done with PhnLibNewAddressList().
  • Err PhnLibAddAddress (UInt16 refNum, PhnAddressList list, const PhnAddressHandle address)
    This function adds a copy of address to the end of list. The address is not disposed of.
  • Err PhnLibGetNth (UInt16 refNum, const PhnAddressList list, Int16 index, PhnAddressHandle *address)
    This function retrieves an item with the given index from list and returns it as a new block on the heap specified by address.
  • Err PhnLibSetNth (UInt16 refNum, PhnAddressList list, Int16 index, const PhnAddressHandle address)
    This function replaces the data of the item with the given index from list by the given address.
  • Err PhnLibCount (UInt16 refNum, PhnAddressList list, UInt16 *count)
    This function returns the length of the given list. If list is 0, this function returns phnErrParam.
  • Err PhnLibGetSMSRingInfo (UInt16 refNum, PhnRingingInfoPtr info)
    Parameters:
    refNum,: IN:

  • Err PhnLibSetSMSRingInfo (UInt16 refNum, PhnRingingInfoPtr info)
    Parameters:
    refNum,: IN:

  • Err PhnLibGetSMSGateway (UInt16 refNum, char **smsGateway)
    Parameters:
    refNum,: IN:

  • Err PhnLibGetSMSPreference (UInt16 refNum, PhnSMSPrefPtr prefP)
    Parameters:
    refNum,: IN:

  • Err PhnLibSetSMSPreference (UInt16 refNum, PhnSMSPrefPtr prefP)
    Parameters:
    refNum,: IN:

  • Err PhnLibAPGetNth (UInt16 refNum, PhnAddressList list, Int16 index, PhnAddressHandle *address)
    Parameters:
    refNum,: IN:

  • Err PhnLibSendSMSMTAck (UInt16 refNum, UInt8 transactionId, Boolean ack)
    Parameters:
    refNum,: IN:

  • Err PhnLibQuerySMSMT (UInt16 refNum)
    Parameters:
    refNum,: IN:

  • Err PhnLibSetSMSCallbackNumber (UInt16 refNum, const CharPtr number, PhnDatabaseID msgID)
    Parameters:
    refNum,: IN:

Function Documentation

Err PhnLibAddAddress | ( | UInt16 | refNum,
 |  | PhnAddressList | list,
 |  | const PhnAddressHandle | address
 | ) |  |

This function adds a copy of address to the end of list. The address is not disposed of.

Parameters:
refNum,: IN:
list,: IN:
address,: IN:
Return values:
Err Error code.

char* PhnLibAddressToText | ( | UInt16 | refNum,
 |  | PhnAddressHandle | address,
 |  | SMSAddressFormat | format
 | ) |  |

Parameters:
refNum,: IN:

Parameters:
address,: IN:
format,: IN:
Return values:
Char

Err PhnLibAPGetNth | ( | UInt16 | refNum,
 |  | PhnAddressList | list,
 |  | Int16 | index,
 |  | PhnAddressHandle * | address
 | ) |  |

Parameters:
refNum,: IN:

Parameters:
list,: IN:
index,: IN:
Return values:
Err Error code.

Err PhnLibCount | ( | UInt16 | refNum,
 |  | PhnAddressList | list,
 |  | UInt16 * | count
 | ) |  |

This function returns the length of the given list. If list is 0, this function returns phnErrParam.

Parameters:
refNum,: IN:
list,: IN:
count,: IN:
Return values:
Err Error code.

Err PhnLibDeleteMessage | ( | UInt16 | refNum,
 |  | PhnDatabaseID | msgID,
 |  | Boolean | archive
 | ) |  |

This function deletes the message with the given msgID from the message database.

Parameters:
refNum,: IN:
msgID,: IN:
archive,: IN:
Return values:
This function returns 0 if there was no error during the deletion of the record. If there is no message with the given id, this function returns phnErrUnknownID.

Err PhnLibDisposeAddressList | ( | UInt16 | refNum,
 |  | PhnAddressList | list
 | ) |  |

This function disposes of the memory used by the given address list. It should be called after your done with PhnLibNewAddressList().

Parameters:
refNum,: IN:
list,: IN:
Return values:
Err Error code.

Boolean PhnLibEqual | ( | UInt16 | refNum,
 |  | PhnAddressHandle | a,
 |  | PhnAddressHandle | b
 | ) |  |

Parameters:
refNum,: IN:

Parameters:
a,: IN:
b,: IN:
Return values:
Boolean

Err PhnLibGetAddresses | ( | UInt16 | refNum,
 |  | PhnDatabaseID | msgID,
 |  | PhnAddressList * | list
 | ) |  |

This function returns the list of addresses for the given message.

Parameters:
refNum,: IN:
msgID,: IN:
list,: IN:
Return values:
Err Error code.

Err PhnLibGetDate | ( | UInt16 | refNum,
 |  | PhnDatabaseID | msgID,
 |  | UInt32 * | date
 | ) |  |

This function returns the date of the given message in Palm OS format.

Parameters:
refNum,: IN:
msgID,: IN:
date,: IN:
Return values:
Err Error code.

DmOpenRef PhnLibGetDBRef ( UInt16 refNum )

Parameters:
refNum,: IN:

Return values:
DmOpenRef

CharPtr PhnLibGetField | ( | UInt16 | refNum,
 |  | PhnAddressHandle | address,
 |  | PhnAddressField | field
 | ) |  |

This function returns the field’s value for a given address in a newly allocated block. This function returns 0 if there was an error while retrieving the data.

Parameters:
refNum,: IN:
address,: IN:
fied,: IN:
Return values:
CharPtr

Err PhnLibGetFlags | ( | UInt16 | refNum,
 |  | PhnDatabaseID | msgID,
 |  | UInt32 * | flags
 | ) |  |

This function returns the message’s flags.

Parameters:
refNum,: IN: Library reference number returned by HsGetPhoneLibrary().
msgID,: IN:
flags,: IN:
Return values:
Err Error code.

PhnDatabaseID PhnLibGetID | ( | UInt16 | refNum,
 |  | PhnAddressHandle | address
 | ) |  |

Parameters:
refNum,: IN:

Parameters:
address,: IN:
Return values:
PhnDatabaseID

Err PhnLibGetLengthDetails | ( | UInt16 | refNum,
 |  | const char * | text,
 |  | const char * | address,
 |  | PhnLibLengthInfoType * | info
 | ) |  |

Parameters:
refNum,: IN:

Parameters:
text,: IN:
address,: IN:
info,: IN:
Return values:
Err Error code.

Err PhnLibGetNth | ( | UInt16 | refNum,
 |  | const PhnAddressList | list,
 |  | Int16 | index,
 |  | PhnAddressHandle * | address
 | ) |  |

This function retrieves an item with the given index from list and returns it as a new block on the heap specified by address.

Parameters:
refNum,: IN:
list,: IN:
index,: IN:
address,: IN:
Return values:
Err Error code.

Err PhnLibGetOptions | ( | UInt16 | refNum,
 |  | PhnDatabaseID | msgID,
 |  | SMSSendOptions * | options
 | ) |  |

This function returns the sending options for the given message.

Parameters:
refNum,: IN:
msgID,: IN:
options,: IN:
Return values:
Err Error code.

Err PhnLibGetOwner | ( | UInt16 | refNum,
 |  | PhnDatabaseID | msgID,
 |  | UInt32 * | owner
 | ) |  |

This function returns the message’s owner.

Parameters:
refNum,: IN: Library reference number returned by HsGetPhoneLibrary().
msgID,: IN:
owner,: IN:
Return values:
Error code.

Err PhnLibGetServiceCentreAddress | ( | UInt16 | refNum,
 |  | PhnAddressHandle * | address
 | ) |  |

This function returns the number of the service center currently used for sending messages in a newly allocated address.

Parameters:
refNum,: IN:
address,: IN:
Return values:
Error code.

Err PhnLibGetSMSGateway | ( | UInt16 | refNum,
 |  | char ** | smsGateway
 | ) |  |

Parameters:
refNum,: IN:

Parameters:
smsGateway,: IN:
Return values:
Err Error code.

Err PhnLibGetSMSPreference | ( | UInt16 | refNum,
 |  | PhnSMSPrefPtr | prefP
 | ) |  |

Parameters:
refNum,: IN:

Parameters:
prefP,: IN:
Return values:
Err Error code.

Err PhnLibGetSMSRingInfo | ( | UInt16 | refNum,
 |  | PhnRingingInfoPtr | info
 | ) |  |

Parameters:
refNum,: IN:

Parameters:
info,: IN:
Return values:
Err Error code.

Err PhnLibGetStatus | ( | UInt16 | refNum,
 |  | PhnDatabaseID | msgID,
 |  | SMSMessageStatus * | status
 | ) |  |

This function returns the status field of the message.

Parameters:
refNum,: IN:
msgID,: IN:
status,: IN:
Return values:
Err Error code.

const char* PhnLibGetSubstitution | ( | UInt16 | refNum,
 |  | char | c
 | ) |  |

This function returns the substitution string for a given GSM character.

Parameters:
refNum,: IN:
c,: IN:
Return values:
const

Err PhnLibGetText | ( | UInt16 | refNum,
 |  | PhnDatabaseID | msgID,
 |  | MemHandle * | data
 | ) |  |

This function copies the text of the message into a new block of memory that must be disposed of by the caller.

Parameters:
refNum,: IN:
msgID,: IN:
data,: IN:
Return values:
Err Error code.

Err PhnLibGetType | ( | UInt16 | refNum,
 |  | PhnDatabaseID | msgID,
 |  | SMSMessageType * | type
 | ) |  |

This function returns the message’s type. A client application typically uses the type to map messages to categories.

Parameters:
refNum,: IN:
msgID,: IN:
type,: IN:
Return values:
Err Error code.

Boolean PhnLibHasName | ( | UInt16 | refNum,
 |  | PhnAddressHandle | address
 | ) |  |

Parameters:
refNum,: IN:

Parameters:
address,: IN:
Return values:
Boolean

Boolean PhnLibIsLegalCharacter | ( | UInt16 | refNum,
 |  | char | c
 | ) |  |

This function returns true if the given Palm OS character is a legal GSM character. If this function returns false, the given character does not exist within the GSM alphabet.

Parameters:
refNum,: IN:
c,: IN:
Return values:
Boolean

Int16 PhnLibLength | ( | UInt16 | refNum,
 |  | const char * | text,
 |  | Boolean | inMessages,
 |  | Boolean | substitution
 | ) |  |

This function returns the length of the given text in characters or messages.

Parameters:
refNum,: IN:
text,: IN:
inMessages,: IN:
substitution,: IN:
Return values:
Int16

char PhnLibMapCharacter | ( | UInt16 | refNum,
 |  | char | c
 | ) |  |

This function maps the given Palm OS character to its equivalent in the GSM alphabet.

Parameters:
refNum,: IN:
c,: IN:
Return values:
char

PhnAddressHandle PhnLibNewAddress | ( | UInt16 | refNum,
 |  | const CharPtr | number,
 |  | PhnDatabaseID | id
 | ) |  |

Parameters:
refNum,: IN:

Parameters:
number,: IN:
id,: IN:
Return values:
PhnAddressHandle

PhnAddressList PhnLibNewAddressList ( UInt16 refNum )

This function returns a new address list. The list is initially empty and must be disposed of by the caller using PhnLibDisposeAddressList() or MemHandleFree().

Parameters:
refNum,: IN:
Return values:
PhnAddressList

PhnDatabaseID PhnLibNewMessage | ( | UInt16 | refNum,
 |  | SMSMessageType | type
 | ) |  |

Create a new message of the given message type and return the ID of the new record in the message database. All fields are either empty (e.g. message’s text) or contain default values (e.g. sending options).

Parameters:
refNum,: IN:
type,: IN: Incoming or Outcoming message. See SMSMessageType for more details.
Return values:
Returns either the ID of the new message record or phnErrUnknownID if there was not sufficient memory to allocate a new message.

Err PhnLibQuerySMSMT ( UInt16 refNum )

Parameters:
refNum,: IN:

Return values:
Err Error code.

Err PhnLibReleaseDBRef | ( | UInt16 | refNum,
 |  | DmOpenRef | db
 | ) |  |

Parameters:
refNum,: IN:

Parameters:
db,: IN:
Return values:
Err Error code.

Err PhnLibSendMessage | ( | UInt16 | refNum,
 |  | PhnDatabaseID | msgID,
 |  | Boolean | progress
 | ) |  |

This function sends the message to all the recipients.

Parameters:
refNum,: IN:
msgID,: IN:
progress,: IN:
Return values:
phnErrUnknownID,: If there is no message with the given ID. phnErrIllegalStatus: If the message’s status is not kNone or kPending phnErrNotAllowed: If the error flag is set. It is not permitted to send messages when the error flag is set.

Err PhnLibSendPendingMessages ( UInt16 refNum )

Parameters:
refNum,: IN:

Return values:
Err Error code.

Err PhnLibSendSMSMTAck | ( | UInt16 | refNum,
 |  | UInt8 | transactionId,
 |  | Boolean | ack
 | ) |  |

Parameters:
refNum,: IN:

Parameters:
transactionID,: IN:
acK,: IN:
Return values:
Err Error code.

Err PhnLibSetAddresses | ( | UInt16 | refNum,
 |  | PhnDatabaseID | msgID,
 |  | const PhnAddressList | list
 | ) |  |

This function updates the list of addresses with the given list of addresses.

Parameters:
refNum,: IN:
msgID,: IN:
list,: IN:
Return values:
Err Error code.

Err PhnLibSetDate | ( | UInt16 | refNum,
 |  | PhnDatabaseID | msgID,
 |  | UInt32 | date
 | ) |  |

This function sets the date of the given message. The date must be given in Palm OS format (as returned by TimGetSeconds).

Parameters:
refNum,: IN:
msgID,: IN:
date,: IN:
Return values:
Err Error code.

Err PhnLibSetField | ( | UInt16 | refNum,
 |  | PhnAddressHandle | address,
 |  | PhnAddressField | field,
 |  | const char * | data
 | ) |  |

This function lets the specified field of address to the given data. This function returns 0 if the field was modified without an error.

Parameters:
refNum,: IN:
address,: IN:
field,: IN:
data,: IN:
Return values:
Err Error Code.

Err PhnLibSetFlags | ( | UInt16 | refNum,
 |  | PhnDatabaseID | msgID,
 |  | UInt32 | flags
 | ) |  |

This function updates a message’s flags.

Parameters:
refNum,: IN:
msgID,: IN:
flags,: IN:
Return values:
Err Error code.

Err PhnLibSetID | ( | UInt16 | refNum,
 |  | PhnAddressHandle | address,
 |  | PhnDatabaseID | id
 | ) |  |

Parameters:
refNum,: IN:

Parameters:
address,: IN:
id,: IN:
Return values:
Err Error code.

Err PhnLibSetNth | ( | UInt16 | refNum,
 |  | PhnAddressList | list,
 |  | Int16 | index,
 |  | const PhnAddressHandle | address
 | ) |  |

This function replaces the data of the item with the given index from list by the given address.

Parameters:
refNum,: IN:
list,: IN:
index,: IN:
address,: IN:
Return values:
Err Error code.

Err PhnLibSetNumber | ( | UInt16 | refNum,
 |  | PhnAddressHandle | address,
 |  | const char * | number
 | ) |  |

Parameters:
refNum,: IN:

Parameters:
address,: IN:
number,: IN:
Return values:
Err Error Code.

Err PhnLibSetOptions | ( | UInt16 | refNum,
 |  | PhnDatabaseID | msgID,
 |  | const SMSSendOptions * | options
 | ) |  |

This function updates the sending options for the given message.

Parameters:
refNum,: IN:
msgID,: IN:
options,: IN:
Return values:
Err Error code.

Err PhnLibSetOwner | ( | UInt16 | refNum,
 |  | PhnDatabaseID | msgID,
 |  | UInt32 | owner
 | ) |  |

This function updates the given message’s owner.

Parameters:
refNum,: IN:
msgID,: IN:
owner,: IN
Return values:
Err Error code.

Err PhnLibSetServiceCentreAddress | ( | UInt16 | refNum,
 |  | const PhnAddressHandle | address
 | ) |  |

This function sets the number of the service center to be used for sending the SMS messages.

Parameters:
refNum,: IN:
address,: IN:
Return values:
Err Error code.

Err PhnLibSetSMSCallbackNumber | ( | UInt16 | refNum,
 |  | const CharPtr | number,
 |  | PhnDatabaseID | msgID
 | ) |  |

Parameters:
refNum,: IN:

Parameters:
number,: IN:
msgID,: IN:
Return values:
Err Error code.

Err PhnLibSetSMSPreference | ( | UInt16 | refNum,
 |  | PhnSMSPrefPtr | prefP
 | ) |  |

Parameters:
refNum,: IN:

Parameters:
prefP,: IN:
Return values:
Err Error code.

Err PhnLibSetSMSRingInfo | ( | UInt16 | refNum,
 |  | PhnRingingInfoPtr | info
 | ) |  |

Parameters:
refNum,: IN:

Parameters:
info,: IN:
Return values:
Err Error code.

Err PhnLibSetStatus | ( | UInt16 | refNum,
 |  | PhnDatabaseID | msgID,
 |  | SMSMessageStatus | status
 | ) |  |

This function sets the status of the given message.

Parameters:
refNum,: IN:
msgID,: IN:
status,: IN:
Return values:
Err Error code.

Err PhnLibSetText | ( | UInt16 | refNum,
 |  | PhnDatabaseID | msgID,
 |  | const char * | data,
 |  | Int16 | size
 | ) |  |

This function sets the text of the message to the given text.

Parameters:
refNum,: IN:
msgID,: IN:
data,: IN:
size,: IN:
Return values:
0,: if the text was updated successfully. phnErrIllegalChars: If the text contains illegal characters

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:07:26 2008 for Palm API Guide


Header Files » Incs » common » libraries » telephony

HsPhoneSMSTypes.h File Reference

Detailed Description

Header File for Phone Library API ---- NETWORK CATEGORY.

NOTES: All implementations of the Handspring Phone Library support a common API. This API is broken up into various categories for easier management. This file defines the SMS category. These API calls are used to interact with the wireless network.

Definition in file HsPhoneSMSTypes.h.

Include dependency graph for HsPhoneSMSTypes.h:

Go to the source code of this file.

Data Structures

  • struct Address
  • struct AddrDescriptor
  • struct AddressType
  • struct AddressAppRecordHeader
  • struct AddressAppRecord
  • struct PhnSMSPrefType
  • struct SMSSendOptions
  • struct SmsHeader
  • struct NBSNotificationEventType
  • struct PhnLibLengthInfoType
  • struct _PhnLibMMSServerInfo

Defines

  • #define isValidAddressAppRecordFieldEnum(x) ((x >= kName) && (x < kRecordFieldEnumCount))
  • #define TextHeaderTerminator ' '
  • #define phnNBSEvent 'Hnbs'
  • #define isValidSMSMessageType(m) ((m >= kMTIncoming) && (m <= kMTOutgoing))
  • #define isValidSMSMessageStatus(m) ((m >= kNone) && (m <= kSent))
  • #define kMMSStringMaxLen 128
  • #define kMMSPixPlaceMaxLen 20
  • #define PhnLibMMSServerInfoSettingsMajorVersion 0x0001
  • #define PhnLibMMSServerInfoSettingsMinorVersion 0x0000
  • #define PhnLibMMSServerInfoVersion (((UInt32)PhnLibMMSServerInfoSettingsMajorVersion << 16) | PhnLibMMSServerInfoSettingsMinorVersion)
Identifier elements definitions
  • #define NBSHeaderID 0x00
  • #define NBSHeaderIDLen 0x03
  • #define Addressing8bitID 0x04
  • #define Addressing8bitIDLen 0x02
  • #define Addressing16bitID 0x05
  • #define Addressing16bitIDLen 0x04
Text Header elements
  • #define NBSHeaderEscapeSeq "//"
  • #define NBSTextHeader "//SCK"
  • #define NBSTextHeaderLength 5
8bit addressing text header lengths, not including the //SCK
  • #define Full8bitTextHeader 0x0A
  • #define Minimum8bitTextHeader 0x02
16bit addressing text header lengths, not including the //SCKL
  • #define Full16bitTextHeader 0x0F
  • #define Minimum16bitTextHeader 0x05
NBS Port Numbers (Nokia Smart Messaging Spec)
  • #define NBSPort_MimeVCard 0xE2
  • #define NBSPort_MimeVCalendar 0xE4

Typedefs

  • typedef enum AddressAppRecordFieldEnum AddressAppRecordFieldEnum
  • typedef UInt8 AddressAppPhoneLabelType
  • typedef Address Address
  • typedef AddrDescriptor AddrDescriptor
  • typedef AddressType AddressType
  • typedef AddressAppRecordHeader AddressAppRecordHeader
  • typedef struct PhnSMSPrefType * PhnSMSPrefPtr
  • typedef NBSNotificationEventType NBSNotificationEventType
  • typedef UInt32 SmsCauseCode
  • typedef UInt8 SmsErrorCode
  • typedef _PhnLibMMSServerInfo PhnLibMMSServerInfoType

Enumerations

  • enum AddressAppRecordFieldEnum {
    kName,
    kFirstName,
    kCompany,
    kPhone1,
    kPhone2,
    kPhone3,
    kPhone4,
    kPhone5,
    kAddress,
    kCity,
    kState,
    kZipCode,
    kCountry,
    kTitle,
    kCustom1,
    kCustom2,
    kCustom3,
    kCustom4,
    kNote,
    kRecordFieldEnumCount
    }
  • enum AddressAppPhoneLabel {
    addrWorkLabel,
    addrHomeLabel,
    addrFaxLabel,
    addrOtherLabel,
    addrEmailLabel,
    addrMainLabel,
    addrPagerLabel,
    addrMobileLabel,
    addrNoLabel
    }
  • enum SMSMessageType {
    kMTIncoming,
    kMTOutgoing
    }
  • enum SMSMessageStatus {
    kNone,
    kReceiving,
    kReceived,
    kPending,
    kSending,
    kSent
    }
  • enum SMSMessageFlags {
    kGreekSymbols = 1L << 0,
    kMissingPart = 1L << 1,
    kAutoDelete = 1L << 2,
    kNotification = 1L << 3,
    kDontEncode = 1L << 4,
    kSubstitution = 1L << 5,
    kFailed = 1L << 6,
    kStatusReport = 1L << 7,
    kFreeReply = 1L << 8,
    kInternetEMail = 1L << 9,
    kTextSegments = 1L << 10,
    kSMSErrorType1 = 1L << 11,
    kSMSErrorType2 = 1L << 12,
    kSMSErrorType3 = 1L << 13,
    kSMSHighPriority = 1L << 14,
    kSMSLowPriority = 1L << 15,
    kRead = 1L << 16,
    kDeferredDelivery = 1L << 17,
    kWAPMsg = 1L << 18
    }
  • enum SMSAddressFormat {
    smsFmtIgnoreKind = 0,
    smsFmtMatchKind = 8,
    smsFmtExceptKind = 16,
    smsFmtAllKinds = 24,
    smsFmtLastNameFirst = 32,
    smsFmtShortLabel = 64
    }
  • enum {
    kParseError = -1,
    kDoneParsing = 0,
    kParseInformationID,
    kParseInformationLength,
    kParseInformationData
    }
  • enum _SmsCauseCode {
    SmsCauseAddressVacant = 0,
    SmsCauseAddressTranslationFailure,
    SmsCauseNetworkResourceShortage,
    SmsCauseNetworkFailure,
    SmsCauseInvalidTeleserviceId,
    SmsCauseOtherNetworkProblem,
    SmsCauseOtherNetworkProblemMoreFirst = 6,
    SmsCauseOtherNetworkProblemMoreLast = 31,
    SmsCauseNoPageResponse = 32,
    SmsCauseDestinationBusy,
    SmsCauseNoAck,
    SmsCauseDestinationResourceShortage,
    SmsCauseSmsDeliveryPostponed,
    SmsCauseDestinationOutOfService,
    SmsCauseDestinationNoLongerAtThisAddress,
    SmsCauseOtherTerminalProblem,
    smsCauseOtherTerminalProblemMoreFirst = 40,
    SmsCauseOtherTerminalProblemMoreLast = 47,
    SmsCauseSmsDeliveryPostponedMoreFirst = 48,
    SmsCauseSmsDeliveryPostponedMoreLast = 63,
    SmsCauseRadioIfResourceShortage = 64,
    SmsCauseRadioIfIncompatible,
    SmsCauseOtherRadioIfProblem,
    SmsCauseOtherRadioIfProblemMoreFirst = 67,
    SmsCauseOtherRadioIfProblemMoreLast = 95,
    SmsCauseUnexpected_Parm_Size = 96,
    SmsCauseSmsOriginationDenied,
    SmsCauseSmsTerminationDenied,
    SmsCauseSupplServiceNotSupported,
    SmsCauseSmsNotSupported,
    SmsCauseReserved101,
    SmsCauseMissingExpectedParm,
    SmsCauseMissingMandatoryParm,
    SmsCauseUnrecognizedParmValue,
    SmsCauseUnexpectedParmValue,
    SmsCauseUserDataSizeError,
    SmsCauseOtherGeneralProblems,
    SmsCauseOtherGeneralProblemsMoreFirst = 108,
    SmsCauseOtherGeneralProblemsMoreLast = 255
    }
  • enum _SmsErrorCode {
    SmsErrorNone,
    SmsErrorReserved,
    SmsErrorTemporary,
    SmsErrorPermanent
    }

Define Documentation

#define Addressing16bitID 0x05

16-bit address information identifier

Definition at line 177 of file HsPhoneSMSTypes.h.

#define Addressing16bitIDLen 0x04

4 bytes... src port(2), dest port(2)

Definition at line 178 of file HsPhoneSMSTypes.h.

#define Addressing8bitID 0x04

8-bit address information identifier

Definition at line 174 of file HsPhoneSMSTypes.h.

#define Addressing8bitIDLen 0x02

2 bytes... src port(1), dest port(1)

Definition at line 175 of file HsPhoneSMSTypes.h.

#define Full16bitTextHeader 0x0F

length for full header with 16-bit addressing //SCKLddddoooorrttnn

Definition at line 205 of file HsPhoneSMSTypes.h.

#define Full8bitTextHeader 0x0A

length for full header with 8-bit addressing //SCKddoorrttnn

Definition at line 196 of file HsPhoneSMSTypes.h.

#define isValidAddressAppRecordFieldEnum ( x ) ((x >= kName) && (x < kRecordFieldEnumCount))

Definition at line 72 of file HsPhoneSMSTypes.h.

#define isValidSMSMessageStatus ( m ) ((m >= kNone) && (m <= kSent))

Definition at line 240 of file HsPhoneSMSTypes.h.

#define isValidSMSMessageType ( m ) ((m >= kMTIncoming) && (m <= kMTOutgoing))

Definition at line 229 of file HsPhoneSMSTypes.h.

#define kMMSPixPlaceMaxLen 20

pix place address

Definition at line 478 of file HsPhoneSMSTypes.h.

#define kMMSStringMaxLen 128

MMS info structure. URL, MML, and user agent

Definition at line 477 of file HsPhoneSMSTypes.h.

#define Minimum16bitTextHeader 0x05

length for minimum header with 16-bit addressing //SCKLdddd

Definition at line 206 of file HsPhoneSMSTypes.h.

#define Minimum8bitTextHeader 0x02

length for minimum header with 8-bit addressing //SCKdd

Definition at line 197 of file HsPhoneSMSTypes.h.

#define NBSHeaderEscapeSeq "//"

start sequence of the header

Definition at line 186 of file HsPhoneSMSTypes.h.

#define NBSHeaderID 0x00

NBS fragment header information identifier

Definition at line 171 of file HsPhoneSMSTypes.h.

#define NBSHeaderIDLen 0x03

three bytes

Definition at line 172 of file HsPhoneSMSTypes.h.

#define NBSPort_MimeVCalendar 0xE4

Definition at line 219 of file HsPhoneSMSTypes.h.

#define NBSPort_MimeVCard 0xE2

Definition at line 218 of file HsPhoneSMSTypes.h.

#define NBSTextHeader "//SCK"

beginning of an NBS text header

Definition at line 187 of file HsPhoneSMSTypes.h.

#define NBSTextHeaderLength 5

length of the header

Definition at line 188 of file HsPhoneSMSTypes.h.

#define PhnLibMMSServerInfoSettingsMajorVersion 0x0001

Definition at line 479 of file HsPhoneSMSTypes.h.

#define PhnLibMMSServerInfoSettingsMinorVersion 0x0000

Definition at line 480 of file HsPhoneSMSTypes.h.

#define PhnLibMMSServerInfoVersion (((UInt32)PhnLibMMSServerInfoSettingsMajorVersion << 16) | PhnLibMMSServerInfoSettingsMinorVersion)

Definition at line 481 of file HsPhoneSMSTypes.h.

#define phnNBSEvent 'Hnbs'

Definition at line 211 of file HsPhoneSMSTypes.h.

#define TextHeaderTerminator ' '

text based headers terminate at the next space

Definition at line 209 of file HsPhoneSMSTypes.h.

Typedef Documentation

typedef struct AddrDescriptor AddrDescriptor

Definition at line 115 of file HsPhoneSMSTypes.h.

typedef struct Address Address

Definition at line 114 of file HsPhoneSMSTypes.h.

typedef UInt8 AddressAppPhoneLabelType

Definition at line 89 of file HsPhoneSMSTypes.h.

typedef enum AddressAppRecordFieldEnum AddressAppRecordFieldEnum

Definition at line 68 of file HsPhoneSMSTypes.h.

typedef struct AddressAppRecordHeader AddressAppRecordHeader

Definition at line 142 of file HsPhoneSMSTypes.h.

typedef struct AddressType AddressType

Definition at line 128 of file HsPhoneSMSTypes.h.

typedef struct NBSNotificationEventType NBSNotificationEventType

Definition at line 362 of file HsPhoneSMSTypes.h.

typedef struct _PhnLibMMSServerInfo PhnLibMMSServerInfoType

typedef struct PhnSMSPrefType* PhnSMSPrefPtr

typedef UInt32 SmsCauseCode

Definition at line 458 of file HsPhoneSMSTypes.h.

typedef UInt8 SmsErrorCode

Definition at line 472 of file HsPhoneSMSTypes.h.

Enumeration Type Documentation

anonymous enum

NBS

Enumerator:
kParseError
kDoneParsing
kParseInformationID
kParseInformationLength
kParseInformationData

Definition at line 368 of file HsPhoneSMSTypes.h.

00368 { kParseError = -1, kDoneParsing=0, kParseInformationID, kParseInformationLength, kParseInformationData };

enum _SmsCauseCode

SMS error codes obtained from the network in CDMA The first half of the enums are from IS-41D SMS cause codes with the exact binary values as in IS-41D. They are in the range of 0x00 to 0xFF. This does not have the cause codes from the range 0x80000 upwards as the radio doesnt support them

Enumerator:
SmsCauseAddressVacant
SmsCauseAddressTranslationFailure
SmsCauseNetworkResourceShortage
SmsCauseNetworkFailure
SmsCauseInvalidTeleserviceId
SmsCauseOtherNetworkProblem
SmsCauseOtherNetworkProblemMoreFirst
SmsCauseOtherNetworkProblemMoreLast
SmsCauseNoPageResponse
SmsCauseDestinationBusy
SmsCauseNoAck
SmsCauseDestinationResourceShortage
SmsCauseSmsDeliveryPostponed
SmsCauseDestinationOutOfService
SmsCauseDestinationNoLongerAtThisAddress
SmsCauseOtherTerminalProblem
smsCauseOtherTerminalProblemMoreFirst
SmsCauseOtherTerminalProblemMoreLast
SmsCauseSmsDeliveryPostponedMoreFirst
SmsCauseSmsDeliveryPostponedMoreLast
SmsCauseRadioIfResourceShortage
SmsCauseRadioIfIncompatible
SmsCauseOtherRadioIfProblem
SmsCauseOtherRadioIfProblemMoreFirst
SmsCauseOtherRadioIfProblemMoreLast
SmsCauseUnexpected_Parm_Size
SmsCauseSmsOriginationDenied
SmsCauseSmsTerminationDenied
SmsCauseSupplServiceNotSupported
SmsCauseSmsNotSupported
SmsCauseReserved101
SmsCauseMissingExpectedParm
SmsCauseMissingMandatoryParm
SmsCauseUnrecognizedParmValue
SmsCauseUnexpectedParmValue
SmsCauseUserDataSizeError
SmsCauseOtherGeneralProblems
SmsCauseOtherGeneralProblemsMoreFirst
SmsCauseOtherGeneralProblemsMoreLast

Definition at line 393 of file HsPhoneSMSTypes.h.

00393               {
00394   /* A. Network Problems:
00395   */
00396   SmsCauseAddressVacant                     = 0,
00397   SmsCauseAddressTranslationFailure,
00398   SmsCauseNetworkResourceShortage,
00399   SmsCauseNetworkFailure,
00400   SmsCauseInvalidTeleserviceId,
00401   SmsCauseOtherNetworkProblem,
00402   SmsCauseOtherNetworkProblemMoreFirst   = 6,
00403   /* all values within this range are treated as
00404      OtherNetworkProblem
00405   */
00406   SmsCauseOtherNetworkProblemMoreLast    = 31,
00407
00408   /* B. Terminal Problems:
00409   */
00410   SmsCauseNoPageResponse                   = 32,
00411   SmsCauseDestinationBusy,
00412   SmsCauseNoAck,
00413   SmsCauseDestinationResourceShortage,
00414   SmsCauseSmsDeliveryPostponed,
00415   SmsCauseDestinationOutOfService,
00416   SmsCauseDestinationNoLongerAtThisAddress,
00417   SmsCauseOtherTerminalProblem,
00418   smsCauseOtherTerminalProblemMoreFirst  = 40,
00419   /* all values within this range are treated as
00420      OtherTerminalProblem
00421   */
00422   SmsCauseOtherTerminalProblemMoreLast   = 47,
00423   SmsCauseSmsDeliveryPostponedMoreFirst  = 48,
00424   SmsCauseSmsDeliveryPostponedMoreLast   = 63,
00425
00426   /* C. Radio Interface Problems:
00427   */
00428   SmsCauseRadioIfResourceShortage         = 64,
00429   SmsCauseRadioIfIncompatible,
00430   SmsCauseOtherRadioIfProblem,
00431   SmsCauseOtherRadioIfProblemMoreFirst  = 67,
00432   /* all values within this range are treated as
00433      OtherRadioIfProblem
00434   */
00435   SmsCauseOtherRadioIfProblemMoreLast   = 95,
00436
00437   /* D. General Problems:
00438   */
00439   SmsCauseUnexpected_Parm_Size               = 96,
00440   SmsCauseSmsOriginationDenied,
00441   SmsCauseSmsTerminationDenied,
00442   SmsCauseSupplServiceNotSupported,
00443   SmsCauseSmsNotSupported,
00444   SmsCauseReserved101,
00445   SmsCauseMissingExpectedParm,
00446   SmsCauseMissingMandatoryParm,
00447   SmsCauseUnrecognizedParmValue,
00448   SmsCauseUnexpectedParmValue,
00449   SmsCauseUserDataSizeError,
00450   SmsCauseOtherGeneralProblems,
00451   SmsCauseOtherGeneralProblemsMoreFirst  = 108,
00452   /* all values within this range are treated as
00453      OtherGeneralProblems
00454   */
00455   SmsCauseOtherGeneralProblemsMoreLast   = 255
00456 }_SmsCauseCode;

enum _SmsErrorCode

SMS error codes types

Enumerator:
SmsErrorNone
SmsErrorReserved
SmsErrorTemporary
SmsErrorPermanent

Definition at line 464 of file HsPhoneSMSTypes.h.

00465 {
00466   SmsErrorNone,
00467   SmsErrorReserved,
00468   SmsErrorTemporary,
00469   SmsErrorPermanent
00470 }_SmsErrorCode;

enum AddressAppPhoneLabel

Item description here

Enumerator:
addrWorkLabel
addrHomeLabel
addrFaxLabel
addrOtherLabel
addrEmailLabel
addrMainLabel
addrPagerLabel
addrMobileLabel
addrNoLabel

Definition at line 77 of file HsPhoneSMSTypes.h.

00077               {
00078     addrWorkLabel,      /**<        */
00079     addrHomeLabel,      /**<        */
00080     addrFaxLabel,       /**<        */
00081     addrOtherLabel,     /**<        */
00082     addrEmailLabel,     /**<        */
00083     addrMainLabel,      /**<        */
00084     addrPagerLabel,     /**<        */
00085     addrMobileLabel,    /**<        */
00086     addrNoLabel     /**<        */
00087 }AddressAppPhoneLabel;

enum AddressAppRecordFieldEnum

Palm OS address book functions

Enumerator:
kName
kFirstName
kCompany
kPhone1
kPhone2
kPhone3
kPhone4
kPhone5
kAddress
kCity
kState
kZipCode
kCountry
kTitle
kCustom1
kCustom2
kCustom3
kCustom4
kNote
kRecordFieldEnumCount must be the last field

Definition at line 44 of file HsPhoneSMSTypes.h.

00044                                {
00045     kName,          /**<        */
00046     kFirstName,         /**<        */
00047     kCompany,       /**<        */
00048     kPhone1,        /**<        */
00049     kPhone2,        /**<        */
00050     kPhone3,        /**<        */
00051     kPhone4,        /**<        */
00052     kPhone5,        /**<        */
00053     kAddress,       /**<        */
00054     kCity,          /**<        */
00055     kState,         /**<        */
00056     kZipCode,       /**<        */
00057     kCountry,       /**<        */
00058     kTitle,         /**<        */
00059     kCustom1,       /**<        */
00060     kCustom2,       /**<        */
00061     kCustom3,       /**<        */
00062     kCustom4,       /**<        */
00063     kNote,          /**<        */
00064     kRecordFieldEnumCount /**< must be the last field */
00065 };

enum SMSAddressFormat

Enumerator:
smsFmtIgnoreKind
smsFmtMatchKind
smsFmtExceptKind
smsFmtAllKinds
smsFmtLastNameFirst
smsFmtShortLabel

Definition at line 283 of file HsPhoneSMSTypes.h.

00283               {
00284   smsFmtIgnoreKind = 0,     /**<        */
00285   smsFmtMatchKind = 8,      /**<        */
00286   smsFmtExceptKind = 16,    /**<        */
00287   smsFmtAllKinds = 24,      /**<        */
00288   smsFmtLastNameFirst = 32, /**<        */
00289   smsFmtShortLabel = 64     /**<        */
00290 }SMSAddressFormat;

enum SMSMessageFlags

Enumerator:
kGreekSymbols
kMissingPart
kAutoDelete
kNotification
kDontEncode
kSubstitution
kFailed
kStatusReport
kFreeReply
kInternetEMail
kTextSegments
kSMSErrorType1
kSMSErrorType2
kSMSErrorType3
kSMSHighPriority
kSMSLowPriority
kRead
kDeferredDelivery
kWAPMsg

Definition at line 257 of file HsPhoneSMSTypes.h.

00257               {
00258   kGreekSymbols = 1L << 0,      /**<        */
00259   kMissingPart =    1L << 1,    /**<        */
00260   kAutoDelete = 1L << 2,        /**<        */
00261   kNotification = 1L << 3,      /**<        */
00262   kDontEncode = 1L << 4,        /**<        */
00263   kSubstitution = 1L << 5,      /**<        */
00264   kFailed =     1L << 6,    /**<        */
00265   kStatusReport = 1L << 7,      /**<        */
00266   kFreeReply =  1L << 8,        /**<        */
00267   kInternetEMail =1L << 9,      /**<        */
00268   kTextSegments =   1L << 10,   /**<        */
00269   kSMSErrorType1 = 1L << 11,        /**<        */
00270   kSMSErrorType2 = 1L << 12,        /**<        */
00271   kSMSErrorType3 = 1L << 13,        /**<        */
00272   kSMSHighPriority = 1L << 14,      /**<        */
00273   kSMSLowPriority = 1L << 15,       /**<        */
00274         // application-level flags
00275   kRead = 1L << 16,         /**<        */
00276   kDeferredDelivery = 1L << 17,     /**<        */
00277   kWAPMsg = 1L << 18            /**<        */
00278 }SMSMessageFlags;

enum SMSMessageStatus

Item description here

Enumerator:
kNone
kReceiving
kReceived
kPending
kSending
kSent

Definition at line 234 of file HsPhoneSMSTypes.h.

00234               {
00235   kNone,            /**<        */
00236   kReceiving, kReceived,    /**<        */
00237   kPending, kSending, kSent /**<        */
00238 }SMSMessageStatus;

enum SMSMessageType

SMS stuff

Enumerator:
kMTIncoming
kMTOutgoing

Definition at line 225 of file HsPhoneSMSTypes.h.

00225              {
00226   kMTIncoming, kMTOutgoing      /**<        */
00227 } SMSMessageType;

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:07:27 2008 for Palm API Guide


Header Files » Incs » common » libraries » telephony

HsPhoneTrace.h File Reference

Detailed Description

Trace constants, types, and definitions for Phone Library.

Definition in file HsPhoneTrace.h.

Go to the source code of this file.

Defines

Trace Subcomponent IDs. These are used in TraceContext to identify area of Phone Library providing
a particular trace/error entry. These are helpful to allow useful filtering of trace log data.

  • #define PHN_SUBCOMPONENTID_LIB 'LIB!'
  • #define PHN_SUBCOMPONENTID_SMS 'SMS!'
  • #define PHN_SUBCOMPONENTID_NOT 'NOT!'
  • #define PHN_SUBCOMPONENTID_RDO 'RDO!'
  • #define PHN_SUBCOMPONENTID_READ 'READ'
  • #define PHN_SUBCOMPONENTID_WRIT 'WRIT'
  • #define PHN_SUBCOMPONENTID_SIM 'SIM!'
  • #define PHN_SUBCOMPONENTID_STK 'STK!'

Define Documentation

#define PHN_SUBCOMPONENTID_LIB 'LIB!'

general Phone Library (library activation/shutdown, API, etc)

Definition at line 31 of file HsPhoneTrace.h.

#define PHN_SUBCOMPONENTID_NOT 'NOT!'

Phone Notification Mgr

Definition at line 33 of file HsPhoneTrace.h.

#define PHN_SUBCOMPONENTID_RDO 'RDO!'

Radio operation

Definition at line 34 of file HsPhoneTrace.h.

#define PHN_SUBCOMPONENTID_READ 'READ'

low level communication with radio - read

Definition at line 35 of file HsPhoneTrace.h.

#define PHN_SUBCOMPONENTID_SIM 'SIM!'

sim operation

Definition at line 37 of file HsPhoneTrace.h.

#define PHN_SUBCOMPONENTID_SMS 'SMS!'

SMS Messaging

Definition at line 32 of file HsPhoneTrace.h.

#define PHN_SUBCOMPONENTID_STK 'STK!'

sim toolkit

Definition at line 38 of file HsPhoneTrace.h.

#define PHN_SUBCOMPONENTID_WRIT 'WRIT'

low level communication with radio - write

Definition at line 36 of file HsPhoneTrace.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:07:28 2008 for Palm API Guide


Header Files » Incs » common » libraries » telephony

HsPhoneTraps.h File Reference

Detailed Description

Traps of all functions exported by the Phone Library.

NOTES:

Definition in file HsPhoneTraps.h.

Go to the source code of this file.

Defines

  • #define PHN_LIB_TRAP(trapNum) SYS_TRAP(trapNum)
  • #define PhnLibTrapGetLibAPIVersion (0+sysLibTrapCustom)
  • #define PhnLibTrapUninstall (1+sysLibTrapCustom)
  • #define PhnLibTrapRegister (2+sysLibTrapCustom)
  • #define PhnLibTrapFirstAppForService (3+sysLibTrapCustom)
  • #define PhnLibTrapNewAddress (4+sysLibTrapCustom)
  • #define PhnLibTrapGetField (5+sysLibTrapCustom)
  • #define PhnLibTrapGetID (6+sysLibTrapCustom)
  • #define PhnLibTrapSetField (7+sysLibTrapCustom)
  • #define PhnLibTrapSetNumber (8+sysLibTrapCustom)
  • #define PhnLibTrapSetID (9+sysLibTrapCustom)
  • #define PhnLibTrapAddressToText (10+sysLibTrapCustom)
  • #define PhnLibTrapHasName (11+sysLibTrapCustom)
  • #define PhnLibTrapEqual (12+sysLibTrapCustom)
  • #define PhnLibTrapDial (13+sysLibTrapCustom)
  • #define PhnLibTrapSendDTMF (14+sysLibTrapCustom)
  • #define PhnLibTrapDisconnect (15+sysLibTrapCustom)
  • #define PhnLibTrapActivate (16+sysLibTrapCustom)
  • #define PhnLibTrapConference (17+sysLibTrapCustom)
  • #define PhnLibTrapHold (18+sysLibTrapCustom)
  • #define PhnLibTrapGetConnectionInfo (19+sysLibTrapCustom)
  • #define PhnLibTrapSetBarring (20+sysLibTrapCustom)
  • #define PhnLibTrapGetBarring (21+sysLibTrapCustom)
  • #define PhnLibTrapSetForwarding (22+sysLibTrapCustom)
  • #define PhnLibTrapGetForwarding (23+sysLibTrapCustom)
  • #define PhnLibTrapSetCallWaiting (24+sysLibTrapCustom)
  • #define PhnLibTrapGetCallWaiting (25+sysLibTrapCustom)
  • #define PhnLibTrapSetPhoneLock (26+sysLibTrapCustom)
  • #define PhnLibTrapGetPhoneLock (27+sysLibTrapCustom)
  • #define PhnLibTrapSetCLIP (28+sysLibTrapCustom)
  • #define PhnLibTrapGetCLIP (29+sysLibTrapCustom)
  • #define PhnLibTrapSetOperatorLock (30+sysLibTrapCustom)
  • #define PhnLibTrapGetOperatorLock (31+sysLibTrapCustom)
  • #define PhnLibTrapChangePassword (32+sysLibTrapCustom)
  • #define PhnLibTrapPasswordDialog (33+sysLibTrapCustom)
  • #define PhnLibTrapCurrentOperator (34+sysLibTrapCustom)
  • #define PhnLibTrapCurrentProvider (35+sysLibTrapCustom)
  • #define PhnLibTrapGetOperatorList (36+sysLibTrapCustom)
  • #define PhnLibTrapSetOperator (37+sysLibTrapCustom)
  • #define PhnLibTrapGetOwnNumbers (38+sysLibTrapCustom)
  • #define PhnLibTrapSetOwnNumbers (39+sysLibTrapCustom)
  • #define PhnLibTrapGetRingingInfo (40+sysLibTrapCustom)
  • #define PhnLibTrapSetRingingInfo (41+sysLibTrapCustom)
  • #define PhnLibTrapGetToneIDs (42+sysLibTrapCustom)
  • #define PhnLibTrapGetToneName (43+sysLibTrapCustom)
  • #define PhnLibTrapPlayTone (44+sysLibTrapCustom)
  • #define PhnLibTrapStopTone (45+sysLibTrapCustom)
  • #define PhnLibTrapFindEntry (46+sysLibTrapCustom)
  • #define PhnLibTrapSelectAddress (47+sysLibTrapCustom)
  • #define PhnLibTrapGetMicrophone (48+sysLibTrapCustom)
  • #define PhnLibTrapSetMicrophone (49+sysLibTrapCustom)
  • #define PhnLibTrapGetVolume (50+sysLibTrapCustom)
  • #define PhnLibTrapSetVolume (51+sysLibTrapCustom)
  • #define PhnLibTrapRegistered (52+sysLibTrapCustom)
  • #define PhnLibTrapRoaming (53+sysLibTrapCustom)
  • #define PhnLibTrapSignalQuality (54+sysLibTrapCustom)
  • #define PhnLibTrapErrorRate (55+sysLibTrapCustom)
  • #define PhnLibTrapBattery (56+sysLibTrapCustom)
  • #define PhnLibTrapCardInfo (57+sysLibTrapCustom)
  • #define PhnLibTrapSIMInfo (58+sysLibTrapCustom)
  • #define PhnLibTrapGetSIMStatus (59+sysLibTrapCustom)
  • #define PhnLibTrapParamText (60+sysLibTrapCustom)
  • #define PhnLibTrapGetErrorText (61+sysLibTrapCustom)
  • #define PhnLibTrapGetDBRef (62+sysLibTrapCustom)
  • #define PhnLibTrapReleaseDBRef (63+sysLibTrapCustom)
  • #define PhnLibTrapNewMessage (64+sysLibTrapCustom)
  • #define PhnLibTrapDeleteMessage (65+sysLibTrapCustom)
  • #define PhnLibTrapSendMessage (66+sysLibTrapCustom)
  • #define PhnLibTrapSetText (67+sysLibTrapCustom)
  • #define PhnLibTrapSetDate (68+sysLibTrapCustom)
  • #define PhnLibTrapSetOptions (69+sysLibTrapCustom)
  • #define PhnLibTrapSetAddresses (70+sysLibTrapCustom)
  • #define PhnLibTrapSetStatus (71+sysLibTrapCustom)
  • #define PhnLibTrapSetFlags (72+sysLibTrapCustom)
  • #define PhnLibTrapSetOwner (73+sysLibTrapCustom)
  • #define PhnLibTrapGetText (74+sysLibTrapCustom)
  • #define PhnLibTrapGetDate (75+sysLibTrapCustom)
  • #define PhnLibTrapGetOptions (76+sysLibTrapCustom)
  • #define PhnLibTrapGetAddresses (77+sysLibTrapCustom)
  • #define PhnLibTrapGetStatus (78+sysLibTrapCustom)
  • #define PhnLibTrapGetFlags (79+sysLibTrapCustom)
  • #define PhnLibTrapGetOwner (80+sysLibTrapCustom)
  • #define PhnLibTrapGetType (81+sysLibTrapCustom)
  • #define PhnLibTrapIsLegalCharacter (82+sysLibTrapCustom)
  • #define PhnLibTrapMapCharacter (83+sysLibTrapCustom)
  • #define PhnLibTrapSetServiceCentreAddress (84+sysLibTrapCustom)
  • #define PhnLibTrapGetServiceCentreAddress (85+sysLibTrapCustom)
  • #define PhnLibTrapLength (86+sysLibTrapCustom)
  • #define PhnLibTrapGetSubstitution (87+sysLibTrapCustom)
  • #define PhnLibTrapNewAddressList (88+sysLibTrapCustom)
  • #define PhnLibTrapDisposeAddressList (89+sysLibTrapCustom)
  • #define PhnLibTrapAddAddress (90+sysLibTrapCustom)
  • #define PhnLibTrapGetNth (91+sysLibTrapCustom)
  • #define PhnLibTrapSetNth (92+sysLibTrapCustom)
  • #define PhnLibTrapCount (93+sysLibTrapCustom)
  • #define PhnLibTrapSetModulePower (94+sysLibTrapCustom)
  • #define PhnLibTrapModulePowered (95+sysLibTrapCustom)
  • #define PhnLibTrapModuleButtonDown (96+sysLibTrapCustom)
  • #define PhnLibTrapBoxInformation (97+sysLibTrapCustom)
  • #define PhnLibTrapGetBoxNumber (98+sysLibTrapCustom)
  • #define PhnLibTrapGetDataApplication (99+sysLibTrapCustom)
  • #define PhnLibTrapSetDataApplication (100+sysLibTrapCustom)
  • #define PhnLibTrapDebug (101+sysLibTrapCustom)
  • #define PhnLibTrapGetPhoneBook (102+sysLibTrapCustom)
  • #define PhnLibTrapSetPhoneBook (103+sysLibTrapCustom)
  • #define PhnLibTrapSetPhoneBookEntry (104+sysLibTrapCustom)
  • #define PhnLibTrapGetPhoneBookIndex (105+sysLibTrapCustom)
  • #define PhnLibTrapBatteryCharge (106+sysLibTrapCustom)
  • #define PhnLibTrapGetEchoCancellation (107+sysLibTrapCustom)
  • #define PhnLibTrapSetEchoCancellation (108+sysLibTrapCustom)
  • #define PhnLibTrapGetEquipmentMode (109+sysLibTrapCustom)
  • #define PhnLibTrapSetEquipmentMode (110+sysLibTrapCustom)
  • #define PhnLibTrapGetSMSRingInfo (111+sysLibTrapCustom)
  • #define PhnLibTrapSetSMSRingInfo (112+sysLibTrapCustom)
  • #define PhnLibTrapPlayDTMF (113+sysLibTrapCustom)
  • #define PhnLibTrapStartVibrate (114+sysLibTrapCustom)
  • #define PhnLibTrapStopVibrate (115+sysLibTrapCustom)
  • #define PhnLibTrapSendUSSD (116+sysLibTrapCustom)
  • #define PhnLibTrapSATGetMainMenu (117+sysLibTrapCustom)
  • #define PhnLibTrapSATSendRequest (118+sysLibTrapCustom)
  • #define PhnLibTrapSATEndSession (119+sysLibTrapCustom)
  • #define PhnLibTrapHomeOperatorID (120+sysLibTrapCustom)
  • #define PhnLibTrapCurrentOperatorID (121+sysLibTrapCustom)
  • #define PhnLibTrapUsableSignalStrengthThreshold (122+sysLibTrapCustom)
  • #define PhnLibTrapConnectionAvailable (123+sysLibTrapCustom)
  • #define PhnLibTrapGetPhoneCallStatus (124+sysLibTrapCustom)
  • #define PhnLibTrapSendSilentDTMF (125+sysLibTrapCustom)
  • #define PhnLibTrapSetCLIR (126+sysLibTrapCustom)
  • #define PhnLibTrapGetCLIR (127+sysLibTrapCustom)
  • #define PhnLibTrapMute (128+sysLibTrapCustom)
  • #define PhnLibTrapIsCallMuted (129+sysLibTrapCustom)
  • #define PhnLibTrapGetSMSGateway (130+sysLibTrapCustom)
  • #define PhnLibTrapDeactivateBarring (131+sysLibTrapCustom)
  • #define PhnLibTrapGPRSAttached (132+sysLibTrapCustom)
  • #define PhnLibTrapGPRSPDPContextDefine (133+sysLibTrapCustom)
  • #define PhnLibTrapGPRSPDPContextListConstruct (134+sysLibTrapCustom)
  • #define PhnLibTrapGPRSPDPContextListDestruct (135+sysLibTrapCustom)
  • #define PhnLibTrapGetRemainingPasswordTries (136+sysLibTrapCustom)
  • #define PhnLibTrapGPRSQualityOfServiceGet (137+sysLibTrapCustom)
  • #define PhnLibTrapGPRSQualityOfServiceSet (138+sysLibTrapCustom)
  • #define PhnLibTrapSetBoxNumber (139+sysLibTrapCustom)
  • #define PhnLibTrapGetBinary (140+sysLibTrapCustom)
  • #define PhnLibTrapNetworkAvailable (141+sysLibTrapCustom)
  • #define PhnLibTrapSetFDNEntry (142+sysLibTrapCustom)
  • #define PhnLibTrapGetFDNList (143+sysLibTrapCustom)
  • #define PhnLibTrapDecodeMMI (144+sysLibTrapCustom)
  • #define PhnLibTrapExecuteMMI (145+sysLibTrapCustom)
  • #define PhnLibTrapSetActiveLine (146+sysLibTrapCustom)
  • #define PhnLibTrapSetBand (147+sysLibTrapCustom)
  • #define PhnLibTrapGetBand (148+sysLibTrapCustom)
  • #define PhnLibTrapGetCustomServiceProfile (149+sysLibTrapCustom)
  • #define PhnLibTrapIsEmergencyNumber (150+sysLibTrapCustom)
  • #define PhnLibTrapAttrGet (151+sysLibTrapCustom)
  • #define PhnLibTrapAttrSet (152+sysLibTrapCustom)
  • #define PhnLibTrapGetSDNList (153+sysLibTrapCustom)
  • #define PhnLibTrapSendLongDTMF (154+sysLibTrapCustom)
  • #define PhnLibTrapGetICCID (155+sysLibTrapCustom)
  • #define PhnLibTrapGetSpn (156+sysLibTrapCustom)
  • #define PhnLibTrapGPRSAttachRequest (157+sysLibTrapCustom)
  • #define PhnLibTrapSetNoiseCancellation (158+sysLibTrapCustom)
  • #define PhnLibTrapGetNoiseCancellation (159+sysLibTrapCustom)
  • #define PhnLibTrapCRSM (160+sysLibTrapCustom)
  • #define PhnLibTrapGetDedicatedDataMode (161+sysLibTrapCustom)
  • #define PhnLibTrapSetDedicatedDataMode (162+sysLibTrapCustom)
  • #define PhnLibTrapGetMVNOName (163+sysLibTrapCustom)
  • #define PhnLibTrapGetGSMCellInfo (164+sysLibTrapCustom)
  • #define GSMReserved8 (165+sysLibTrapCustom)
  • #define GSMReserved9 (166+sysLibTrapCustom)
  • #define GSMReserved10 (167+sysLibTrapCustom)
  • #define GSMReserved11 (168+sysLibTrapCustom)
  • #define GSMReserved12 (169+sysLibTrapCustom)
  • #define GSMReserved13 (170+sysLibTrapCustom)
  • #define GSMReserved14 (171+sysLibTrapCustom)
  • #define GSMReserved15 (172+sysLibTrapCustom)
  • #define GSMReserved16 (173+sysLibTrapCustom)
  • #define GSMReserved17 (174+sysLibTrapCustom)
  • #define GSMReserved18 (175+sysLibTrapCustom)
  • #define GSMReserved19 (176+sysLibTrapCustom)
  • #define GSMReserved20 (177+sysLibTrapCustom)
  • #define GSMReserved21 (178+sysLibTrapCustom)
  • #define GSMReserved22 (179+sysLibTrapCustom)
  • #define PhnLibTrapAPGetNth (180+sysLibTrapCustom)
  • #define PhnLibTrapGetMSID (181+sysLibTrapCustom)
  • #define PhnLibTrapGetPhnOprtMode (182+sysLibTrapCustom)
  • #define PhnLibTrapSetPhnOprtMode (183+sysLibTrapCustom)
  • #define PhnLibTrapSendSMSMTAck (184+sysLibTrapCustom)
  • #define PhnLibTrapQuerySMSMT (185+sysLibTrapCustom)
  • #define PhnLibTrapIsPhoneActivated (186+sysLibTrapCustom)
  • #define PhnLibTrapUpdateMessageCount (187+sysLibTrapCustom)
  • #define PhnLibTrapGetSMSPreference (188+sysLibTrapCustom)
  • #define PhnLibTrapSetSMSPreference (189+sysLibTrapCustom)
  • #define PhnLibTrapGetSpMode (190+sysLibTrapCustom)
  • #define PhnLibTrapLedAlert (191+sysLibTrapCustom)
  • #define PhnLibTrapExit911Mode (192+sysLibTrapCustom)
  • #define PhnLibTrapMiscDebugInfo (193+sysLibTrapCustom)
  • #define PhnLibTrapGetHeadsetConnectedInfo (194+sysLibTrapCustom)
  • #define PhnLibTrapExitPowerSaveMode (195+sysLibTrapCustom)
  • #define PhnLibTrapGetToneLength (196+sysLibTrapCustom)
  • #define PhnLibTrapSetToneLength (197+sysLibTrapCustom)
  • #define PhnLibTrapUnlockPhoneLock (198+sysLibTrapCustom)
  • #define PhnLibTrapLoadCDMATime (199+sysLibTrapCustom)
  • #define PhnLibTrapGetCallCountByService (200+sysLibTrapCustom)
  • #define PhnLibTrapGetDefaultDataApps (201+sysLibTrapCustom)
  • #define PhnLibTrapModemIssueResetInfo (202+sysLibTrapCustom)
  • #define PhnLibTrapGetRoamPrefMode (203+sysLibTrapCustom)
  • #define PhnLibTrapSetRoamPrefMode (204+sysLibTrapCustom)
  • #define PhnLibTrapGetRoamPrefInfo (205+sysLibTrapCustom)
  • #define PhnLibTrapSetRoamPrefInfo (206+sysLibTrapCustom)
  • #define PhnLibTrapIsSpecialNumber (207+sysLibTrapCustom)
  • #define PhnLibTrapSetSpecialNumbers (208+sysLibTrapCustom)
  • #define PhnLibTrapGetSpecialNumbers (209+sysLibTrapCustom)
  • #define PhnLibTrapGetDTMFburstMode (210+sysLibTrapCustom)
  • #define PhnLibTrapSetDTMFburstMode (211+sysLibTrapCustom)
  • #define PhnLibTrapSetupDataConfig (212+sysLibTrapCustom)
  • #define PhnLibTrapGetTotalDataTxBytes (213+sysLibTrapCustom)
  • #define PhnLibTrapGetTotalDataRxBytes (214+sysLibTrapCustom)
  • #define PrvPhnLibTrapCheckPowerSync (215+sysLibTrapCustom)
  • #define PhnLibTrapSetPhoneSSMode (216+sysLibTrapCustom)
  • #define PhnLibTrapEnableDM (217+sysLibTrapCustom)
  • #define PhnLibTrapPowerSaveDisable (218+sysLibTrapCustom)
  • #define PhnLibTrapCloseNetIF (219+sysLibTrapCustom)
  • #define PhnLibTrapGetMdmPosition (220+sysLibTrapCustom)
  • #define PhnLibTrapGetPDSessionConfigParam (221+sysLibTrapCustom)
  • #define PhnLibTrapSetPDSessionConfigParam (222+sysLibTrapCustom)
  • #define PhnLibTrapStopPDSession (223+sysLibTrapCustom)
  • #define PhnLibTrapSndSave (224+sysLibTrapCustom)
  • #define PhnLibTrapSndDelete (225+sysLibTrapCustom)
  • #define PhnLibTrapListPDP (226+sysLibTrapCustom)
  • #define PhnLibTrapSetPDP (227+sysLibTrapCustom)
  • #define PhnLibTrapGetPDP (228+sysLibTrapCustom)
  • #define PhnLibTrapCopyPDP (229+sysLibTrapCustom)
  • #define PhnLibTrapDeletePDP (230+sysLibTrapCustom)
  • #define PhnLibTrapReplacePDPPassword (231+sysLibTrapCustom)
  • #define PhnLibTrapGetTotalPDPs (232+sysLibTrapCustom)
  • #define PhnLibTrapGetOneXStatus (233+sysLibTrapCustom)
  • #define PhnLibTrapUpdateCustomizedNV (234+sysLibTrapCustom)
  • #define PhnLibTrapSetMdmAutoMsgMask (235+sysLibTrapCustom)
  • #define PhnLibTrapGetPhoneSSMode (236+sysLibTrapCustom)
  • #define PhnLibTrapGetPDPIndexRange (237+sysLibTrapCustom)
  • #define PhnLibTrapGetCktSwitchProfile (238+sysLibTrapCustom)
  • #define PhnLibTrapStartIOTASession (239+sysLibTrapCustom)
  • #define PhnLibTrapEndIOTASession (240+sysLibTrapCustom)
  • #define PhnLibTrapTunnelIS683ReqMsg (241+sysLibTrapCustom)
  • #define PhnLibTrapSelectNAM (242+sysLibTrapCustom)
  • #define PhnLibTrapGetNAMInUse (243+sysLibTrapCustom)
  • #define PhnLibTrapCommitIOTAParams (244+sysLibTrapCustom)
  • #define PhnLibTrapReadIOTAItem (245+sysLibTrapCustom)
  • #define PhnLibTrapWriteIOTAItem (246+sysLibTrapCustom)
  • #define PhnLibTrapGetIOTAStatus (247+sysLibTrapCustom)
  • #define PhnLibTrapSetCurrentUsageHandler (248+sysLibTrapCustom)
  • #define PhnLibTrapSendDTMFBurst (249+sysLibTrapCustom)
  • #define PhnLibTrapAPNewAddress (250+sysLibTrapCustom)
  • #define PhnLibTrapAPGetField (251+sysLibTrapCustom)
  • #define Reserved2 (252+sysLibTrapCustom)
  • #define PhnLibTrapCardInfoEx (253+sysLibTrapCustom)
  • #define PhnLibTrapBoxInformationEx (254+sysLibTrapCustom)
  • #define PhnLibTrapSignalQualityEx (255+sysLibTrapCustom)
  • #define PhnLibTrapReplacePDPNAI (256+sysLibTrapCustom)
  • #define PhnLibTrapReplacePDPSvcString (257+sysLibTrapCustom)
  • #define PhnLibTrapPDPLockUnlock (258+sysLibTrapCustom)
  • #define PhnLibTrapPhoneRestore (259+sysLibTrapCustom)
  • #define PhnLibTrapVerifyICDVer (260+sysLibTrapCustom)
  • #define PhnLibTrapGetToneIDsEx (261+sysLibTrapCustom)
  • #define PhnLibTrapPlayToneEx (262+sysLibTrapCustom)
  • #define PhnLibTrapEnhancedRoamIndicator (263+sysLibTrapCustom)
  • #define PhnLibTrapNewMOMessage (264+sysLibTrapCustom)
  • #define PhnLibTrapGetTTYSetting (265+sysLibTrapCustom)
  • #define PhnLibTrapSetTTYSetting (266+sysLibTrapCustom)
  • #define PhnLibTrapGetRadioState (267+sysLibTrapCustom)
  • #define PhnLibTrapGetLineState (268+sysLibTrapCustom)
  • #define PhnLibTrapGetLengthDetails (269+sysLibTrapCustom)
  • #define PhnLibTrapGetPicturesToken (270+sysLibTrapCustom)
  • #define PhnLibTrapSetPicturesToken (271+sysLibTrapCustom)
  • #define PhnLibTrapGetPicturesServerInfo (272+sysLibTrapCustom)
  • #define PhnLibTrapSendPendingMessages (273+sysLibTrapCustom)
  • #define PhnLibTrapForceDataDormant (274+sysLibTrapCustom)
  • #define PhnLibTrapGetSysPrefMode (275+sysLibTrapCustom)
  • #define PhnLibTrapSetSysPrefMode (276+sysLibTrapCustom)
  • #define PhnLibTrapGetLifeTimer (277+sysLibTrapCustom)
  • #define PhnLibTrapGetVoicePrivacyMode (278+sysLibTrapCustom)
  • #define PhnLibTrapSetVoicePrivacyMode (279+sysLibTrapCustom)
  • #define PhnLibTrapGetMMSServerInfo (280+sysLibTrapCustom)
  • #define PhnLibTrapGetSMSSegmentInfo (281+sysLibTrapCustom)
  • #define PhnLibTrapDebugHook (282+sysLibTrapCustom)
  • #define PhnLibTrapContinuePhonePowerOn (283+sysLibTrapCustom)
  • #define PhnLibTrapContinuePhonePowerOff (284+sysLibTrapCustom)
  • #define PhnLibTrapSetSMSCallbackNumber (285+sysLibTrapCustom)
  • #define PhnLibTrapGetDeviceId (286+sysLibTrapCustom)
  • #define PhnLibTrapSendFlash (287+sysLibTrapCustom)
  • #define PhnLibTrapGetCDMASystemInfo (288+sysLibTrapCustom)
  • #define PhnLibTrapGetHomepageFromRadio (289+sysLibTrapCustom)
  • #define PhnLibTrapGetProxyInfo (290+sysLibTrapCustom)
  • #define PhnLibTrapIsRadioGenericCDMA (291+sysLibTrapCustom)
  • #define PhnLibTrapGetGenericCDMAPreference (292+sysLibTrapCustom)
  • #define PhnLibTrapIsCarrierDefinedEmergencyNumber (293+sysLibTrapCustom)
  • #define PhnLibTrapGetDialPrefix (294+sysLibTrapCustom)
  • #define PhnLibTrapSetDialPrefix (295+sysLibTrapCustom)
  • #define PhnLibTrapGetDataSessionInfo (296+sysLibTrapCustom)
  • #define PhnLibTrapGetMediaTVSettings (297+sysLibTrapCustom)
  • #define PhnLibTrapOffHold (298+sysLibTrapCustom)
  • #define PhnLibTrapGetMMSServerInfoEx (299+sysLibTrapCustom)
  • #define PhnLibTrapGetDataLife (300+sysLibTrapCustom)
  • #define PhnLibTrapHACSetting (301+sysLibTrapCustom)
  • #define PhnLibTrapGetMEID (302+sysLibTrapCustom)
  • #define PhnLibTrapGetBaseStationIdInfo (303+sysLibTrapCustom)
  • #define PhnLibTrapGetMMSUAString (304+sysLibTrapCustom)
  • #define PhnLibTrapLast (304+sysLibTrapCustom)

Define Documentation

#define GSMReserved10 (167+sysLibTrapCustom)

0xA8AC

Definition at line 200 of file HsPhoneTraps.h.

#define GSMReserved11 (168+sysLibTrapCustom)

0xA8AD

Definition at line 201 of file HsPhoneTraps.h.

#define GSMReserved12 (169+sysLibTrapCustom)

0xA8AE

Definition at line 202 of file HsPhoneTraps.h.

#define GSMReserved13 (170+sysLibTrapCustom)

0xA8AF

Definition at line 203 of file HsPhoneTraps.h.

#define GSMReserved14 (171+sysLibTrapCustom)

0xA8B0

Definition at line 204 of file HsPhoneTraps.h.

#define GSMReserved15 (172+sysLibTrapCustom)

0xA8B1

Definition at line 205 of file HsPhoneTraps.h.

#define GSMReserved16 (173+sysLibTrapCustom)

0xA8B2

Definition at line 206 of file HsPhoneTraps.h.

#define GSMReserved17 (174+sysLibTrapCustom)

0xA8B3

Definition at line 207 of file HsPhoneTraps.h.

#define GSMReserved18 (175+sysLibTrapCustom)

0xA8B4

Definition at line 208 of file HsPhoneTraps.h.

#define GSMReserved19 (176+sysLibTrapCustom)

0xA8B5

Definition at line 209 of file HsPhoneTraps.h.

#define GSMReserved20 (177+sysLibTrapCustom)

0xA8B6

Definition at line 210 of file HsPhoneTraps.h.

#define GSMReserved21 (178+sysLibTrapCustom)

0xA8B7

Definition at line 211 of file HsPhoneTraps.h.

#define GSMReserved22 (179+sysLibTrapCustom)

0xA8B8

Definition at line 212 of file HsPhoneTraps.h.

#define GSMReserved8 (165+sysLibTrapCustom)

0xA8AA

Definition at line 198 of file HsPhoneTraps.h.

#define GSMReserved9 (166+sysLibTrapCustom)

0xA8AB

Definition at line 199 of file HsPhoneTraps.h.

#define PHN_LIB_TRAP ( trapNum ) SYS_TRAP(trapNum)

Definition at line 25 of file HsPhoneTraps.h.

#define PhnLibTrapActivate (16+sysLibTrapCustom)

0xA815

Definition at line 45 of file HsPhoneTraps.h.

#define PhnLibTrapAddAddress (90+sysLibTrapCustom)

0xA85F

Definition at line 119 of file HsPhoneTraps.h.

#define PhnLibTrapAddressToText (10+sysLibTrapCustom)

0xA80F

Definition at line 39 of file HsPhoneTraps.h.

#define PhnLibTrapAPGetField (251+sysLibTrapCustom)

0xA900 CDMA Only

Definition at line 286 of file HsPhoneTraps.h.

#define PhnLibTrapAPGetNth (180+sysLibTrapCustom)

0xA8B9 CDMA Only

Definition at line 215 of file HsPhoneTraps.h.

#define PhnLibTrapAPNewAddress (250+sysLibTrapCustom)

0xA8FF CDMA Only

Definition at line 285 of file HsPhoneTraps.h.

#define PhnLibTrapAttrGet (151+sysLibTrapCustom)

0xA89C GSM Only

Definition at line 180 of file HsPhoneTraps.h.

#define PhnLibTrapAttrSet (152+sysLibTrapCustom)

0xA89D GSM Only

Definition at line 181 of file HsPhoneTraps.h.

#define PhnLibTrapBattery (56+sysLibTrapCustom)

0xA83D

Definition at line 85 of file HsPhoneTraps.h.

#define PhnLibTrapBatteryCharge (106+sysLibTrapCustom)

0xA86F GSM Only

Definition at line 135 of file HsPhoneTraps.h.

#define PhnLibTrapBoxInformation (97+sysLibTrapCustom)

0xA866

Definition at line 126 of file HsPhoneTraps.h.

#define PhnLibTrapBoxInformationEx (254+sysLibTrapCustom)

0xA903 CDMA Only

Definition at line 289 of file HsPhoneTraps.h.

#define PhnLibTrapCardInfo (57+sysLibTrapCustom)

0xA83E

Definition at line 86 of file HsPhoneTraps.h.

#define PhnLibTrapCardInfoEx (253+sysLibTrapCustom)

0xA902 CDMA Only

Definition at line 288 of file HsPhoneTraps.h.

#define PhnLibTrapChangePassword (32+sysLibTrapCustom)

0xA825

Definition at line 61 of file HsPhoneTraps.h.

#define PhnLibTrapCloseNetIF (219+sysLibTrapCustom)

0xA8E0 CDMA Only

Definition at line 254 of file HsPhoneTraps.h.

#define PhnLibTrapCommitIOTAParams (244+sysLibTrapCustom)

0xA8F9 CDMA Only

Definition at line 279 of file HsPhoneTraps.h.

#define PhnLibTrapConference (17+sysLibTrapCustom)

0xA816

Definition at line 46 of file HsPhoneTraps.h.

#define PhnLibTrapConnectionAvailable (123+sysLibTrapCustom)

0xA880 GSM Only

Definition at line 152 of file HsPhoneTraps.h.

#define PhnLibTrapContinuePhonePowerOff (284+sysLibTrapCustom)

0xA921

Definition at line 319 of file HsPhoneTraps.h.

#define PhnLibTrapContinuePhonePowerOn (283+sysLibTrapCustom)

0xA920

Definition at line 318 of file HsPhoneTraps.h.

#define PhnLibTrapCopyPDP (229+sysLibTrapCustom)

0xA8EA CDMA Only

Definition at line 264 of file HsPhoneTraps.h.

#define PhnLibTrapCount (93+sysLibTrapCustom)

0xA862

Definition at line 122 of file HsPhoneTraps.h.

#define PhnLibTrapCRSM (160+sysLibTrapCustom)

0xA8A5

Definition at line 193 of file HsPhoneTraps.h.

#define PhnLibTrapCurrentOperator (34+sysLibTrapCustom)

0xA827

Definition at line 63 of file HsPhoneTraps.h.

#define PhnLibTrapCurrentOperatorID (121+sysLibTrapCustom)

0xA87E GSM Only

Definition at line 150 of file HsPhoneTraps.h.

#define PhnLibTrapCurrentProvider (35+sysLibTrapCustom)

0xA828 GSM Only

Definition at line 64 of file HsPhoneTraps.h.

#define PhnLibTrapDeactivateBarring (131+sysLibTrapCustom)

0xA888 GSM Only

Definition at line 160 of file HsPhoneTraps.h.

#define PhnLibTrapDebug (101+sysLibTrapCustom)

0xA86A GSM Only

Definition at line 130 of file HsPhoneTraps.h.

#define PhnLibTrapDebugHook (282+sysLibTrapCustom)

0xA91F

Definition at line 317 of file HsPhoneTraps.h.

#define PhnLibTrapDecodeMMI (144+sysLibTrapCustom)

0xA895 GSM Only

Definition at line 173 of file HsPhoneTraps.h.

#define PhnLibTrapDeleteMessage (65+sysLibTrapCustom)

0xA846

Definition at line 94 of file HsPhoneTraps.h.

#define PhnLibTrapDeletePDP (230+sysLibTrapCustom)

0xA8EB CDMA Only

Definition at line 265 of file HsPhoneTraps.h.

#define PhnLibTrapDial (13+sysLibTrapCustom)

0xA812

Definition at line 42 of file HsPhoneTraps.h.

#define PhnLibTrapDisconnect (15+sysLibTrapCustom)

0xA814

Definition at line 44 of file HsPhoneTraps.h.

#define PhnLibTrapDisposeAddressList (89+sysLibTrapCustom)

0xA85E

Definition at line 118 of file HsPhoneTraps.h.

#define PhnLibTrapEnableDM (217+sysLibTrapCustom)

0xA8DE CDMA Only

Definition at line 252 of file HsPhoneTraps.h.

#define PhnLibTrapEndIOTASession (240+sysLibTrapCustom)

0xA8F5 CDMA Only

Definition at line 275 of file HsPhoneTraps.h.

#define PhnLibTrapEnhancedRoamIndicator (263+sysLibTrapCustom)

0xA90C CDMA only

Definition at line 298 of file HsPhoneTraps.h.

#define PhnLibTrapEqual (12+sysLibTrapCustom)

0xA811

Definition at line 41 of file HsPhoneTraps.h.

#define PhnLibTrapErrorRate (55+sysLibTrapCustom)

0xA83C GSM Only

Definition at line 84 of file HsPhoneTraps.h.

#define PhnLibTrapExecuteMMI (145+sysLibTrapCustom)

0xA896 GSM Only

Definition at line 174 of file HsPhoneTraps.h.

#define PhnLibTrapExit911Mode (192+sysLibTrapCustom)

0xA8C5 CDMA Only

Definition at line 227 of file HsPhoneTraps.h.

#define PhnLibTrapExitPowerSaveMode (195+sysLibTrapCustom)

0xA8C8 CDMA Only

Definition at line 230 of file HsPhoneTraps.h.

#define PhnLibTrapFindEntry (46+sysLibTrapCustom)

0xA833 GSM Only

Definition at line 75 of file HsPhoneTraps.h.

#define PhnLibTrapFirstAppForService (3+sysLibTrapCustom)

0xA808 GSM Only

Definition at line 32 of file HsPhoneTraps.h.

#define PhnLibTrapForceDataDormant (274+sysLibTrapCustom)

0xA917 CDMA Only

Definition at line 309 of file HsPhoneTraps.h.

#define PhnLibTrapGetAddresses (77+sysLibTrapCustom)

0xA852

Definition at line 106 of file HsPhoneTraps.h.

#define PhnLibTrapGetBand (148+sysLibTrapCustom)

0xA899 GSM Only

Definition at line 177 of file HsPhoneTraps.h.

#define PhnLibTrapGetBarring (21+sysLibTrapCustom)

0xA81A GSM Only

Definition at line 50 of file HsPhoneTraps.h.

#define PhnLibTrapGetBaseStationIdInfo (303+sysLibTrapCustom)

0xA934 CDMA ONLY

Definition at line 338 of file HsPhoneTraps.h.

#define PhnLibTrapGetBinary (140+sysLibTrapCustom)

0xA891 GSM Only

Definition at line 169 of file HsPhoneTraps.h.

#define PhnLibTrapGetBoxNumber (98+sysLibTrapCustom)

0xA867

Definition at line 127 of file HsPhoneTraps.h.

#define PhnLibTrapGetCallCountByService (200+sysLibTrapCustom)

0xA8CD

Definition at line 235 of file HsPhoneTraps.h.

#define PhnLibTrapGetCallWaiting (25+sysLibTrapCustom)

0xA81E

Definition at line 54 of file HsPhoneTraps.h.

#define PhnLibTrapGetCDMASystemInfo (288+sysLibTrapCustom)

0xA925 CDMA ONLY

Definition at line 323 of file HsPhoneTraps.h.

#define PhnLibTrapGetCktSwitchProfile (238+sysLibTrapCustom)

0xA8F3 CDMA Only

Definition at line 273 of file HsPhoneTraps.h.

#define PhnLibTrapGetCLIP (29+sysLibTrapCustom)

0xA822 GSM Only

Definition at line 58 of file HsPhoneTraps.h.

#define PhnLibTrapGetCLIR (127+sysLibTrapCustom)

0xA884 GSM Only

Definition at line 156 of file HsPhoneTraps.h.

#define PhnLibTrapGetConnectionInfo (19+sysLibTrapCustom)

0xA818

Definition at line 48 of file HsPhoneTraps.h.

#define PhnLibTrapGetCustomServiceProfile (149+sysLibTrapCustom)

0xA89A GSM Only

Definition at line 178 of file HsPhoneTraps.h.

#define PhnLibTrapGetDataApplication (99+sysLibTrapCustom)

0xA868 GSM Only

Definition at line 128 of file HsPhoneTraps.h.

#define PhnLibTrapGetDataLife (300+sysLibTrapCustom)

0xA931 CDMA ONLY

Definition at line 335 of file HsPhoneTraps.h.

#define PhnLibTrapGetDataSessionInfo (296+sysLibTrapCustom)

0xA92D

Definition at line 331 of file HsPhoneTraps.h.

#define PhnLibTrapGetDate (75+sysLibTrapCustom)

0xA850

Definition at line 104 of file HsPhoneTraps.h.

#define PhnLibTrapGetDBRef (62+sysLibTrapCustom)

0xA843

Definition at line 91 of file HsPhoneTraps.h.

#define PhnLibTrapGetDedicatedDataMode (161+sysLibTrapCustom)

0xA8A6

Definition at line 194 of file HsPhoneTraps.h.

#define PhnLibTrapGetDefaultDataApps (201+sysLibTrapCustom)

0xA8CE CDMA Only

Definition at line 236 of file HsPhoneTraps.h.

#define PhnLibTrapGetDeviceId (286+sysLibTrapCustom)

0xA923

Definition at line 321 of file HsPhoneTraps.h.

#define PhnLibTrapGetDialPrefix (294+sysLibTrapCustom)

0xA92B CDMA ONLY

Definition at line 329 of file HsPhoneTraps.h.

#define PhnLibTrapGetDTMFburstMode (210+sysLibTrapCustom)

0xA8D7 CDMA Only

Definition at line 245 of file HsPhoneTraps.h.

#define PhnLibTrapGetEchoCancellation (107+sysLibTrapCustom)

0xA870 GSM Only

Definition at line 136 of file HsPhoneTraps.h.

#define PhnLibTrapGetEquipmentMode (109+sysLibTrapCustom)

0xA872

Definition at line 138 of file HsPhoneTraps.h.

#define PhnLibTrapGetErrorText (61+sysLibTrapCustom)

0xA842

Definition at line 90 of file HsPhoneTraps.h.

#define PhnLibTrapGetFDNList (143+sysLibTrapCustom)

0xA894 GSM Only

Definition at line 172 of file HsPhoneTraps.h.

#define PhnLibTrapGetField (5+sysLibTrapCustom)

0xA80A

Definition at line 34 of file HsPhoneTraps.h.

#define PhnLibTrapGetFlags (79+sysLibTrapCustom)

0xA854

Definition at line 108 of file HsPhoneTraps.h.

#define PhnLibTrapGetForwarding (23+sysLibTrapCustom)

0xA81C

Definition at line 52 of file HsPhoneTraps.h.

#define PhnLibTrapGetGenericCDMAPreference (292+sysLibTrapCustom)

0xA929 CDMA ONLY

Definition at line 327 of file HsPhoneTraps.h.

#define PhnLibTrapGetGSMCellInfo (164+sysLibTrapCustom)

0xA8A9

Definition at line 197 of file HsPhoneTraps.h.

#define PhnLibTrapGetHeadsetConnectedInfo (194+sysLibTrapCustom)

0xA8C7 CDMA Only

Definition at line 229 of file HsPhoneTraps.h.

#define PhnLibTrapGetHomepageFromRadio (289+sysLibTrapCustom)

0xA926 CDMA ONLY

Definition at line 324 of file HsPhoneTraps.h.

#define PhnLibTrapGetICCID (155+sysLibTrapCustom)

0xA8A0 GSM Only

Definition at line 184 of file HsPhoneTraps.h.

#define PhnLibTrapGetID (6+sysLibTrapCustom)

0xA80B

Definition at line 35 of file HsPhoneTraps.h.

#define PhnLibTrapGetIOTAStatus (247+sysLibTrapCustom)

0xA8FC CDMA Only

Definition at line 282 of file HsPhoneTraps.h.

#define PhnLibTrapGetLengthDetails (269+sysLibTrapCustom)

0xA912

Definition at line 304 of file HsPhoneTraps.h.

#define PhnLibTrapGetLibAPIVersion (0+sysLibTrapCustom)

0xA805

Definition at line 29 of file HsPhoneTraps.h.

#define PhnLibTrapGetLifeTimer (277+sysLibTrapCustom)

0xA91A

Definition at line 312 of file HsPhoneTraps.h.

#define PhnLibTrapGetLineState (268+sysLibTrapCustom)

0xA911

Definition at line 303 of file HsPhoneTraps.h.

#define PhnLibTrapGetMdmPosition (220+sysLibTrapCustom)

0xA8E1 CDMA Only

Definition at line 255 of file HsPhoneTraps.h.

#define PhnLibTrapGetMediaTVSettings (297+sysLibTrapCustom)

0xA92E CDMA ONLY

Definition at line 332 of file HsPhoneTraps.h.

#define PhnLibTrapGetMEID (302+sysLibTrapCustom)

0xA933

Definition at line 337 of file HsPhoneTraps.h.

#define PhnLibTrapGetMicrophone (48+sysLibTrapCustom)

0xA835 GSM Only

Definition at line 77 of file HsPhoneTraps.h.

#define PhnLibTrapGetMMSServerInfo (280+sysLibTrapCustom)

0xA91D CDMA Only

Definition at line 315 of file HsPhoneTraps.h.

#define PhnLibTrapGetMMSServerInfoEx (299+sysLibTrapCustom)

0xA930 CDMA ONLY

Definition at line 334 of file HsPhoneTraps.h.

#define PhnLibTrapGetMMSUAString (304+sysLibTrapCustom)

0xA935 VZ CDMA ONLY

Definition at line 339 of file HsPhoneTraps.h.

#define PhnLibTrapGetMSID (181+sysLibTrapCustom)

0xA8BA CDMA Only

Definition at line 216 of file HsPhoneTraps.h.

#define PhnLibTrapGetMVNOName (163+sysLibTrapCustom)

0xA8A8

Definition at line 196 of file HsPhoneTraps.h.

#define PhnLibTrapGetNAMInUse (243+sysLibTrapCustom)

0xA8F8 CDMA Only

Definition at line 278 of file HsPhoneTraps.h.

#define PhnLibTrapGetNoiseCancellation (159+sysLibTrapCustom)

0xA8A4

Definition at line 192 of file HsPhoneTraps.h.

#define PhnLibTrapGetNth (91+sysLibTrapCustom)

0xA860

Definition at line 120 of file HsPhoneTraps.h.

#define PhnLibTrapGetOneXStatus (233+sysLibTrapCustom)

0xA8EE CDMA Only

Definition at line 268 of file HsPhoneTraps.h.

#define PhnLibTrapGetOperatorList (36+sysLibTrapCustom)

0xA829

Definition at line 65 of file HsPhoneTraps.h.

#define PhnLibTrapGetOperatorLock (31+sysLibTrapCustom)

0xA824 GSM Only

Definition at line 60 of file HsPhoneTraps.h.

#define PhnLibTrapGetOptions (76+sysLibTrapCustom)

0xA851

Definition at line 105 of file HsPhoneTraps.h.

#define PhnLibTrapGetOwner (80+sysLibTrapCustom)

0xA855

Definition at line 109 of file HsPhoneTraps.h.

#define PhnLibTrapGetOwnNumbers (38+sysLibTrapCustom)

0xA82B

Definition at line 67 of file HsPhoneTraps.h.

#define PhnLibTrapGetPDP (228+sysLibTrapCustom)

0xA8E9 CDMA Only

Definition at line 263 of file HsPhoneTraps.h.

#define PhnLibTrapGetPDPIndexRange (237+sysLibTrapCustom)

0xA8F2 CDMA Only

Definition at line 272 of file HsPhoneTraps.h.

#define PhnLibTrapGetPDSessionConfigParam (221+sysLibTrapCustom)

0xA8E2 CDMA Only

Definition at line 256 of file HsPhoneTraps.h.

#define PhnLibTrapGetPhnOprtMode (182+sysLibTrapCustom)

0xA8BB CDMA Only

Definition at line 217 of file HsPhoneTraps.h.

#define PhnLibTrapGetPhoneBook (102+sysLibTrapCustom)

0xA86B GSM Only

Definition at line 131 of file HsPhoneTraps.h.

#define PhnLibTrapGetPhoneBookIndex (105+sysLibTrapCustom)

0xA86E GSM Only

Definition at line 134 of file HsPhoneTraps.h.

#define PhnLibTrapGetPhoneCallStatus (124+sysLibTrapCustom)

0xA881

Definition at line 153 of file HsPhoneTraps.h.

#define PhnLibTrapGetPhoneLock (27+sysLibTrapCustom)

0xA820

Definition at line 56 of file HsPhoneTraps.h.

#define PhnLibTrapGetPhoneSSMode (236+sysLibTrapCustom)

0xA8F1 CDMA Only

Definition at line 271 of file HsPhoneTraps.h.

#define PhnLibTrapGetPicturesServerInfo (272+sysLibTrapCustom)

0xA915 CDMA Only

Definition at line 307 of file HsPhoneTraps.h.

#define PhnLibTrapGetPicturesToken (270+sysLibTrapCustom)

0xA913 CDMA Only

Definition at line 305 of file HsPhoneTraps.h.

#define PhnLibTrapGetProxyInfo (290+sysLibTrapCustom)

0xA927 CDMA ONLY

Definition at line 325 of file HsPhoneTraps.h.

#define PhnLibTrapGetRadioState (267+sysLibTrapCustom)

0xA910

Definition at line 302 of file HsPhoneTraps.h.

#define PhnLibTrapGetRemainingPasswordTries (136+sysLibTrapCustom)

0xA88D GSM Only

Definition at line 165 of file HsPhoneTraps.h.

#define PhnLibTrapGetRingingInfo (40+sysLibTrapCustom)

0xA82D

Definition at line 69 of file HsPhoneTraps.h.

#define PhnLibTrapGetRoamPrefInfo (205+sysLibTrapCustom)

0xA8D2 CDMA Only

Definition at line 240 of file HsPhoneTraps.h.

#define PhnLibTrapGetRoamPrefMode (203+sysLibTrapCustom)

0xA8D0 CDMA Only

Definition at line 238 of file HsPhoneTraps.h.

#define PhnLibTrapGetSDNList (153+sysLibTrapCustom)

0xA89E GSM Only

Definition at line 182 of file HsPhoneTraps.h.

#define PhnLibTrapGetServiceCentreAddress (85+sysLibTrapCustom)

0xA85A

Definition at line 114 of file HsPhoneTraps.h.

#define PhnLibTrapGetSIMStatus (59+sysLibTrapCustom)

0xA840 GSM Only

Definition at line 88 of file HsPhoneTraps.h.

#define PhnLibTrapGetSMSGateway (130+sysLibTrapCustom)

0xA887 GSM Only

Definition at line 159 of file HsPhoneTraps.h.

#define PhnLibTrapGetSMSPreference (188+sysLibTrapCustom)

0xA8C1 CDMA Only

Definition at line 223 of file HsPhoneTraps.h.

#define PhnLibTrapGetSMSRingInfo (111+sysLibTrapCustom)

0xA874 GSM Only

Definition at line 140 of file HsPhoneTraps.h.

#define PhnLibTrapGetSMSSegmentInfo (281+sysLibTrapCustom)

0xA91E CDMA Only

Definition at line 316 of file HsPhoneTraps.h.

#define PhnLibTrapGetSpecialNumbers (209+sysLibTrapCustom)

0xA8D6 CDMA Only

Definition at line 244 of file HsPhoneTraps.h.

#define PhnLibTrapGetSpMode (190+sysLibTrapCustom)

0xA8C3 CDMA Only

Definition at line 225 of file HsPhoneTraps.h.

#define PhnLibTrapGetSpn (156+sysLibTrapCustom)

0xA8A1 GSM Only

Definition at line 185 of file HsPhoneTraps.h.

#define PhnLibTrapGetStatus (78+sysLibTrapCustom)

0xA853

Definition at line 107 of file HsPhoneTraps.h.

#define PhnLibTrapGetSubstitution (87+sysLibTrapCustom)

0xA85C

Definition at line 116 of file HsPhoneTraps.h.

#define PhnLibTrapGetSysPrefMode (275+sysLibTrapCustom)

0xA918 CDMA Only

Definition at line 310 of file HsPhoneTraps.h.

#define PhnLibTrapGetText (74+sysLibTrapCustom)

0xA84F

Definition at line 103 of file HsPhoneTraps.h.

#define PhnLibTrapGetToneIDs (42+sysLibTrapCustom)

0xA82F

Definition at line 71 of file HsPhoneTraps.h.

#define PhnLibTrapGetToneIDsEx (261+sysLibTrapCustom)

0xA90A CDMA only

Definition at line 296 of file HsPhoneTraps.h.

#define PhnLibTrapGetToneLength (196+sysLibTrapCustom)

0xA8C9 CDMA Only

Definition at line 231 of file HsPhoneTraps.h.

#define PhnLibTrapGetToneName (43+sysLibTrapCustom)

0xA830

Definition at line 72 of file HsPhoneTraps.h.

#define PhnLibTrapGetTotalDataRxBytes (214+sysLibTrapCustom)

0xA8DB CDMA Only

Definition at line 249 of file HsPhoneTraps.h.

#define PhnLibTrapGetTotalDataTxBytes (213+sysLibTrapCustom)

0xA8DA CDMA Only

Definition at line 248 of file HsPhoneTraps.h.

#define PhnLibTrapGetTotalPDPs (232+sysLibTrapCustom)

0xA8ED CDMA Only

Definition at line 267 of file HsPhoneTraps.h.

#define PhnLibTrapGetTTYSetting (265+sysLibTrapCustom)

0xA90E

Definition at line 300 of file HsPhoneTraps.h.

#define PhnLibTrapGetType (81+sysLibTrapCustom)

0xA856

Definition at line 110 of file HsPhoneTraps.h.

#define PhnLibTrapGetVoicePrivacyMode (278+sysLibTrapCustom)

0xA91B CDMA Only

Definition at line 313 of file HsPhoneTraps.h.

#define PhnLibTrapGetVolume (50+sysLibTrapCustom)

0xA837

Definition at line 79 of file HsPhoneTraps.h.

#define PhnLibTrapGPRSAttached (132+sysLibTrapCustom)

0xA889 GSM Only

Definition at line 161 of file HsPhoneTraps.h.

#define PhnLibTrapGPRSAttachRequest (157+sysLibTrapCustom)

0xA8A2 GSM Only

Definition at line 186 of file HsPhoneTraps.h.

#define PhnLibTrapGPRSPDPContextDefine (133+sysLibTrapCustom)

0xA88A GSM Only

Definition at line 162 of file HsPhoneTraps.h.

#define PhnLibTrapGPRSPDPContextListConstruct (134+sysLibTrapCustom)

0xA88B GSM Only

Definition at line 163 of file HsPhoneTraps.h.

#define PhnLibTrapGPRSPDPContextListDestruct (135+sysLibTrapCustom)

0xA88C GSM Only

Definition at line 164 of file HsPhoneTraps.h.

#define PhnLibTrapGPRSQualityOfServiceGet (137+sysLibTrapCustom)

0xA88E GSM Only

Definition at line 166 of file HsPhoneTraps.h.

#define PhnLibTrapGPRSQualityOfServiceSet (138+sysLibTrapCustom)

0xA88F GSM Only

Definition at line 167 of file HsPhoneTraps.h.

#define PhnLibTrapHACSetting (301+sysLibTrapCustom)

0xA932

Definition at line 336 of file HsPhoneTraps.h.

#define PhnLibTrapHasName (11+sysLibTrapCustom)

0xA810

Definition at line 40 of file HsPhoneTraps.h.

#define PhnLibTrapHold (18+sysLibTrapCustom)

0xA817

Definition at line 47 of file HsPhoneTraps.h.

#define PhnLibTrapHomeOperatorID (120+sysLibTrapCustom)

0xA87D GSM Only

Definition at line 149 of file HsPhoneTraps.h.

#define PhnLibTrapIsCallMuted (129+sysLibTrapCustom)

0xA886

Definition at line 158 of file HsPhoneTraps.h.

#define PhnLibTrapIsCarrierDefinedEmergencyNumber (293+sysLibTrapCustom)

0xA92A CDMA ONLY

Definition at line 328 of file HsPhoneTraps.h.

#define PhnLibTrapIsEmergencyNumber (150+sysLibTrapCustom)

0xA89B GSM Only

Definition at line 179 of file HsPhoneTraps.h.

#define PhnLibTrapIsLegalCharacter (82+sysLibTrapCustom)

0xA857

Definition at line 111 of file HsPhoneTraps.h.

#define PhnLibTrapIsPhoneActivated (186+sysLibTrapCustom)

0xA8BF CDMA Only

Definition at line 221 of file HsPhoneTraps.h.

#define PhnLibTrapIsRadioGenericCDMA (291+sysLibTrapCustom)

0xA928 CDMA ONLY

Definition at line 326 of file HsPhoneTraps.h.

#define PhnLibTrapIsSpecialNumber (207+sysLibTrapCustom)

0xA8D4 CDMA Only

Definition at line 242 of file HsPhoneTraps.h.

#define PhnLibTrapLast (304+sysLibTrapCustom)

0xA935

Definition at line 340 of file HsPhoneTraps.h.

#define PhnLibTrapLedAlert (191+sysLibTrapCustom)

0xA8C4 CDMA Only

Definition at line 226 of file HsPhoneTraps.h.

#define PhnLibTrapLength (86+sysLibTrapCustom)

0xA85B

Definition at line 115 of file HsPhoneTraps.h.

#define PhnLibTrapListPDP (226+sysLibTrapCustom)

0xA8E7 CDMA Only

Definition at line 261 of file HsPhoneTraps.h.

#define PhnLibTrapLoadCDMATime (199+sysLibTrapCustom)

0xA8CC CDMA Only

Definition at line 234 of file HsPhoneTraps.h.

#define PhnLibTrapMapCharacter (83+sysLibTrapCustom)

0xA858

Definition at line 112 of file HsPhoneTraps.h.

#define PhnLibTrapMiscDebugInfo (193+sysLibTrapCustom)

0xA8C6 CDMA Only

Definition at line 228 of file HsPhoneTraps.h.

#define PhnLibTrapModemIssueResetInfo (202+sysLibTrapCustom)

0xA8CF CDMA Only

Definition at line 237 of file HsPhoneTraps.h.

#define PhnLibTrapModuleButtonDown (96+sysLibTrapCustom)

0xA865

Definition at line 125 of file HsPhoneTraps.h.

#define PhnLibTrapModulePowered (95+sysLibTrapCustom)

0xA864

Definition at line 124 of file HsPhoneTraps.h.

#define PhnLibTrapMute (128+sysLibTrapCustom)

0xA885

Definition at line 157 of file HsPhoneTraps.h.

#define PhnLibTrapNetworkAvailable (141+sysLibTrapCustom)

0xA892 GSM Only

Definition at line 170 of file HsPhoneTraps.h.

#define PhnLibTrapNewAddress (4+sysLibTrapCustom)

0xA809

Definition at line 33 of file HsPhoneTraps.h.

#define PhnLibTrapNewAddressList (88+sysLibTrapCustom)

0xA85D

Definition at line 117 of file HsPhoneTraps.h.

#define PhnLibTrapNewMessage (64+sysLibTrapCustom)

0xA845

Definition at line 93 of file HsPhoneTraps.h.

#define PhnLibTrapNewMOMessage (264+sysLibTrapCustom)

0xA90D CDMA only

Definition at line 299 of file HsPhoneTraps.h.

#define PhnLibTrapOffHold (298+sysLibTrapCustom)

0xA92F

Definition at line 333 of file HsPhoneTraps.h.

#define PhnLibTrapParamText (60+sysLibTrapCustom)

0xA841 GSM Only

Definition at line 89 of file HsPhoneTraps.h.

#define PhnLibTrapPasswordDialog (33+sysLibTrapCustom)

0xA826 GSM Only

Definition at line 62 of file HsPhoneTraps.h.

#define PhnLibTrapPDPLockUnlock (258+sysLibTrapCustom)

0xA907 CDMA Only

Definition at line 293 of file HsPhoneTraps.h.

#define PhnLibTrapPhoneRestore (259+sysLibTrapCustom)

0xA908 CDMA Only

Definition at line 294 of file HsPhoneTraps.h.

#define PhnLibTrapPlayDTMF (113+sysLibTrapCustom)

0xA876

Definition at line 142 of file HsPhoneTraps.h.

#define PhnLibTrapPlayTone (44+sysLibTrapCustom)

0xA831

Definition at line 73 of file HsPhoneTraps.h.

#define PhnLibTrapPlayToneEx (262+sysLibTrapCustom)

0xA90B CDMA only

Definition at line 297 of file HsPhoneTraps.h.

#define PhnLibTrapPowerSaveDisable (218+sysLibTrapCustom)

0xA8DF CDMA Only

Definition at line 253 of file HsPhoneTraps.h.

#define PhnLibTrapQuerySMSMT (185+sysLibTrapCustom)

0xA8BE CDMA Only

Definition at line 220 of file HsPhoneTraps.h.

#define PhnLibTrapReadIOTAItem (245+sysLibTrapCustom)

0xA8FA CDMA Only

Definition at line 280 of file HsPhoneTraps.h.

#define PhnLibTrapRegister (2+sysLibTrapCustom)

0xA807

Definition at line 31 of file HsPhoneTraps.h.

#define PhnLibTrapRegistered (52+sysLibTrapCustom)

0xA839

Definition at line 81 of file HsPhoneTraps.h.

#define PhnLibTrapReleaseDBRef (63+sysLibTrapCustom)

0xA844

Definition at line 92 of file HsPhoneTraps.h.

#define PhnLibTrapReplacePDPNAI (256+sysLibTrapCustom)

0xA905 CDMA Only

Definition at line 291 of file HsPhoneTraps.h.

#define PhnLibTrapReplacePDPPassword (231+sysLibTrapCustom)

0xA8EC CDMA Only

Definition at line 266 of file HsPhoneTraps.h.

#define PhnLibTrapReplacePDPSvcString (257+sysLibTrapCustom)

0xA906 CDMA Only

Definition at line 292 of file HsPhoneTraps.h.

#define PhnLibTrapRoaming (53+sysLibTrapCustom)

0xA83A

Definition at line 82 of file HsPhoneTraps.h.

#define PhnLibTrapSATEndSession (119+sysLibTrapCustom)

0xA87C GSM Only

Definition at line 148 of file HsPhoneTraps.h.

#define PhnLibTrapSATGetMainMenu (117+sysLibTrapCustom)

0xA87A GSM Only

Definition at line 146 of file HsPhoneTraps.h.

#define PhnLibTrapSATSendRequest (118+sysLibTrapCustom)

0xA87B GSM Only

Definition at line 147 of file HsPhoneTraps.h.

#define PhnLibTrapSelectAddress (47+sysLibTrapCustom)

0xA834 GSM Only

Definition at line 76 of file HsPhoneTraps.h.

#define PhnLibTrapSelectNAM (242+sysLibTrapCustom)

0xA8F7 CDMA Only

Definition at line 277 of file HsPhoneTraps.h.

#define PhnLibTrapSendDTMF (14+sysLibTrapCustom)

0xA813

Definition at line 43 of file HsPhoneTraps.h.

#define PhnLibTrapSendDTMFBurst (249+sysLibTrapCustom)

0xA8FE CDMA Only

Definition at line 284 of file HsPhoneTraps.h.

#define PhnLibTrapSendFlash (287+sysLibTrapCustom)

0xA924 CDMA ONLY

Definition at line 322 of file HsPhoneTraps.h.

#define PhnLibTrapSendLongDTMF (154+sysLibTrapCustom)

0xA89F GSM Only

Definition at line 183 of file HsPhoneTraps.h.

#define PhnLibTrapSendMessage (66+sysLibTrapCustom)

0xA847

Definition at line 95 of file HsPhoneTraps.h.

#define PhnLibTrapSendPendingMessages (273+sysLibTrapCustom)

0xA916

Definition at line 308 of file HsPhoneTraps.h.

#define PhnLibTrapSendSilentDTMF (125+sysLibTrapCustom)

0xA882

Definition at line 154 of file HsPhoneTraps.h.

#define PhnLibTrapSendSMSMTAck (184+sysLibTrapCustom)

0xA8BD CDMA Only

Definition at line 219 of file HsPhoneTraps.h.

#define PhnLibTrapSendUSSD (116+sysLibTrapCustom)

0xA879 GSM Only

Definition at line 145 of file HsPhoneTraps.h.

#define PhnLibTrapSetActiveLine (146+sysLibTrapCustom)

0xA897 GSM Only

Definition at line 175 of file HsPhoneTraps.h.

#define PhnLibTrapSetAddresses (70+sysLibTrapCustom)

0xA84B

Definition at line 99 of file HsPhoneTraps.h.

#define PhnLibTrapSetBand (147+sysLibTrapCustom)

0xA898 GSM Only

Definition at line 176 of file HsPhoneTraps.h.

#define PhnLibTrapSetBarring (20+sysLibTrapCustom)

0xA819 GSM Only

Definition at line 49 of file HsPhoneTraps.h.

#define PhnLibTrapSetBoxNumber (139+sysLibTrapCustom)

0xA890 GSM Only

Definition at line 168 of file HsPhoneTraps.h.

#define PhnLibTrapSetCallWaiting (24+sysLibTrapCustom)

0xA81D

Definition at line 53 of file HsPhoneTraps.h.

#define PhnLibTrapSetCLIP (28+sysLibTrapCustom)

0xA821 GSM Only

Definition at line 57 of file HsPhoneTraps.h.

#define PhnLibTrapSetCLIR (126+sysLibTrapCustom)

0xA883 GSM Only

Definition at line 155 of file HsPhoneTraps.h.

#define PhnLibTrapSetCurrentUsageHandler (248+sysLibTrapCustom)

0xA8FD CDMA Only

Definition at line 283 of file HsPhoneTraps.h.

#define PhnLibTrapSetDataApplication (100+sysLibTrapCustom)

0xA869 GSM Only

Definition at line 129 of file HsPhoneTraps.h.

#define PhnLibTrapSetDate (68+sysLibTrapCustom)

0xA849

Definition at line 97 of file HsPhoneTraps.h.

#define PhnLibTrapSetDedicatedDataMode (162+sysLibTrapCustom)

0xA8A7

Definition at line 195 of file HsPhoneTraps.h.

#define PhnLibTrapSetDialPrefix (295+sysLibTrapCustom)

0xA92C CDMA ONLY

Definition at line 330 of file HsPhoneTraps.h.

#define PhnLibTrapSetDTMFburstMode (211+sysLibTrapCustom)

0xA8D8 CDMA Only

Definition at line 246 of file HsPhoneTraps.h.

#define PhnLibTrapSetEchoCancellation (108+sysLibTrapCustom)

0xA871 GSM Only

Definition at line 137 of file HsPhoneTraps.h.

#define PhnLibTrapSetEquipmentMode (110+sysLibTrapCustom)

0xA873

Definition at line 139 of file HsPhoneTraps.h.

#define PhnLibTrapSetFDNEntry (142+sysLibTrapCustom)

0xA893 GSM Only

Definition at line 171 of file HsPhoneTraps.h.

#define PhnLibTrapSetField (7+sysLibTrapCustom)

0xA80C

Definition at line 36 of file HsPhoneTraps.h.

#define PhnLibTrapSetFlags (72+sysLibTrapCustom)

0xA84D

Definition at line 101 of file HsPhoneTraps.h.

#define PhnLibTrapSetForwarding (22+sysLibTrapCustom)

0xA81B

Definition at line 51 of file HsPhoneTraps.h.

#define PhnLibTrapSetID (9+sysLibTrapCustom)

0xA80E

Definition at line 38 of file HsPhoneTraps.h.

#define PhnLibTrapSetMdmAutoMsgMask (235+sysLibTrapCustom)

0xA8F0 CDMA Only

Definition at line 270 of file HsPhoneTraps.h.

#define PhnLibTrapSetMicrophone (49+sysLibTrapCustom)

0xA836 GSM Only

Definition at line 78 of file HsPhoneTraps.h.

#define PhnLibTrapSetModulePower (94+sysLibTrapCustom)

0xA863

Definition at line 123 of file HsPhoneTraps.h.

#define PhnLibTrapSetNoiseCancellation (158+sysLibTrapCustom)

0xA8A3

Definition at line 191 of file HsPhoneTraps.h.

#define PhnLibTrapSetNth (92+sysLibTrapCustom)

0xA861

Definition at line 121 of file HsPhoneTraps.h.

#define PhnLibTrapSetNumber (8+sysLibTrapCustom)

0xA80D

Definition at line 37 of file HsPhoneTraps.h.

#define PhnLibTrapSetOperator (37+sysLibTrapCustom)

0xA82A

Definition at line 66 of file HsPhoneTraps.h.

#define PhnLibTrapSetOperatorLock (30+sysLibTrapCustom)

0xA823

Definition at line 59 of file HsPhoneTraps.h.

#define PhnLibTrapSetOptions (69+sysLibTrapCustom)

0xA84A

Definition at line 98 of file HsPhoneTraps.h.

#define PhnLibTrapSetOwner (73+sysLibTrapCustom)

0xA84E

Definition at line 102 of file HsPhoneTraps.h.

#define PhnLibTrapSetOwnNumbers (39+sysLibTrapCustom)

0xA82C GSM Only

Definition at line 68 of file HsPhoneTraps.h.

#define PhnLibTrapSetPDP (227+sysLibTrapCustom)

0xA8E8 CDMA Only

Definition at line 262 of file HsPhoneTraps.h.

#define PhnLibTrapSetPDSessionConfigParam (222+sysLibTrapCustom)

0xA8E3 CDMA Only

Definition at line 257 of file HsPhoneTraps.h.

#define PhnLibTrapSetPhnOprtMode (183+sysLibTrapCustom)

0xA8BC CDMA Only

Definition at line 218 of file HsPhoneTraps.h.

#define PhnLibTrapSetPhoneBook (103+sysLibTrapCustom)

0xA86C GSM Only

Definition at line 132 of file HsPhoneTraps.h.

#define PhnLibTrapSetPhoneBookEntry (104+sysLibTrapCustom)

0xA86D GSM Only

Definition at line 133 of file HsPhoneTraps.h.

#define PhnLibTrapSetPhoneLock (26+sysLibTrapCustom)

0xA81F

Definition at line 55 of file HsPhoneTraps.h.

#define PhnLibTrapSetPhoneSSMode (216+sysLibTrapCustom)

0xA8DD CDMA Only

Definition at line 251 of file HsPhoneTraps.h.

#define PhnLibTrapSetPicturesToken (271+sysLibTrapCustom)

0xA914 CDMA Only

Definition at line 306 of file HsPhoneTraps.h.

#define PhnLibTrapSetRingingInfo (41+sysLibTrapCustom)

0xA82E

Definition at line 70 of file HsPhoneTraps.h.

#define PhnLibTrapSetRoamPrefInfo (206+sysLibTrapCustom)

0xA8D3 CDMA Only

Definition at line 241 of file HsPhoneTraps.h.

#define PhnLibTrapSetRoamPrefMode (204+sysLibTrapCustom)

0xA8D1 CDMA Only

Definition at line 239 of file HsPhoneTraps.h.

#define PhnLibTrapSetServiceCentreAddress (84+sysLibTrapCustom)

0xA859

Definition at line 113 of file HsPhoneTraps.h.

#define PhnLibTrapSetSMSCallbackNumber (285+sysLibTrapCustom)

0xA922

Definition at line 320 of file HsPhoneTraps.h.

#define PhnLibTrapSetSMSPreference (189+sysLibTrapCustom)

0xA8C2 CDMA Only

Definition at line 224 of file HsPhoneTraps.h.

#define PhnLibTrapSetSMSRingInfo (112+sysLibTrapCustom)

0xA875 GSM Only

Definition at line 141 of file HsPhoneTraps.h.

#define PhnLibTrapSetSpecialNumbers (208+sysLibTrapCustom)

0xA8D5 CDMA Only

Definition at line 243 of file HsPhoneTraps.h.

#define PhnLibTrapSetStatus (71+sysLibTrapCustom)

0xA84C

Definition at line 100 of file HsPhoneTraps.h.

#define PhnLibTrapSetSysPrefMode (276+sysLibTrapCustom)

0xA919 CDMA Only

Definition at line 311 of file HsPhoneTraps.h.

#define PhnLibTrapSetText (67+sysLibTrapCustom)

0xA848

Definition at line 96 of file HsPhoneTraps.h.

#define PhnLibTrapSetToneLength (197+sysLibTrapCustom)

0xA8CA CDMA Only

Definition at line 232 of file HsPhoneTraps.h.

#define PhnLibTrapSetTTYSetting (266+sysLibTrapCustom)

0xA90F

Definition at line 301 of file HsPhoneTraps.h.

#define PhnLibTrapSetupDataConfig (212+sysLibTrapCustom)

0xA8D9 CDMA Only

Definition at line 247 of file HsPhoneTraps.h.

#define PhnLibTrapSetVoicePrivacyMode (279+sysLibTrapCustom)

0xA91C CDMA Only

Definition at line 314 of file HsPhoneTraps.h.

#define PhnLibTrapSetVolume (51+sysLibTrapCustom)

0xA838

Definition at line 80 of file HsPhoneTraps.h.

#define PhnLibTrapSignalQuality (54+sysLibTrapCustom)

0xA83B

Definition at line 83 of file HsPhoneTraps.h.

#define PhnLibTrapSignalQualityEx (255+sysLibTrapCustom)

0xA904 CDMA Only

Definition at line 290 of file HsPhoneTraps.h.

#define PhnLibTrapSIMInfo (58+sysLibTrapCustom)

0xA83F

Definition at line 87 of file HsPhoneTraps.h.

#define PhnLibTrapSndDelete (225+sysLibTrapCustom)

0xA8E6 CDMA Only

Definition at line 260 of file HsPhoneTraps.h.

#define PhnLibTrapSndSave (224+sysLibTrapCustom)

0xA8E5 CDMA Only

Definition at line 259 of file HsPhoneTraps.h.

#define PhnLibTrapStartIOTASession (239+sysLibTrapCustom)

0xA8F4 CDMA Only

Definition at line 274 of file HsPhoneTraps.h.

#define PhnLibTrapStartVibrate (114+sysLibTrapCustom)

0xA877

Definition at line 143 of file HsPhoneTraps.h.

#define PhnLibTrapStopPDSession (223+sysLibTrapCustom)

0xA8E4 CDMA Only

Definition at line 258 of file HsPhoneTraps.h.

#define PhnLibTrapStopTone (45+sysLibTrapCustom)

0xA832

Definition at line 74 of file HsPhoneTraps.h.

#define PhnLibTrapStopVibrate (115+sysLibTrapCustom)

0xA878

Definition at line 144 of file HsPhoneTraps.h.

#define PhnLibTrapTunnelIS683ReqMsg (241+sysLibTrapCustom)

0xA8F6 CDMA Only

Definition at line 276 of file HsPhoneTraps.h.

#define PhnLibTrapUninstall (1+sysLibTrapCustom)

0xA806

Definition at line 30 of file HsPhoneTraps.h.

#define PhnLibTrapUnlockPhoneLock (198+sysLibTrapCustom)

0xA8CB CDMA Only

Definition at line 233 of file HsPhoneTraps.h.

#define PhnLibTrapUpdateCustomizedNV (234+sysLibTrapCustom)

0xA8EF CDMA Only

Definition at line 269 of file HsPhoneTraps.h.

#define PhnLibTrapUpdateMessageCount (187+sysLibTrapCustom)

0xA8C0 CDMA Only

Definition at line 222 of file HsPhoneTraps.h.

#define PhnLibTrapUsableSignalStrengthThreshold (122+sysLibTrapCustom)

0xA87F GSM Only

Definition at line 151 of file HsPhoneTraps.h.

#define PhnLibTrapVerifyICDVer (260+sysLibTrapCustom)

0xA909 CDMA Only

Definition at line 295 of file HsPhoneTraps.h.

#define PhnLibTrapWriteIOTAItem (246+sysLibTrapCustom)

0xA8FB CDMA Only

Definition at line 281 of file HsPhoneTraps.h.

#define PrvPhnLibTrapCheckPowerSync (215+sysLibTrapCustom)

0xA8DC CDMA Only

Definition at line 250 of file HsPhoneTraps.h.

#define Reserved2 (252+sysLibTrapCustom)

0xA901 CDMA Only

Definition at line 287 of file HsPhoneTraps.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:07:30 2008 for Palm API Guide


Header Files » Incs » common » libraries » telephony

HsPhoneTypes.h File Reference

Detailed Description

Telephony data types that are common between ARM and 68K.

Definition in file HsPhoneTypes.h.

Include dependency graph for HsPhoneTypes.h:

Go to the source code of this file.

Defines

  • #define isValidPhoneServiceClassType(s) ((s & phnServiceAll) != 0)
  • #define isValidPhnAddressField(a) ((a >= phnAddrFldPhone) && (a <= phnAddrFldLastName))
  • #define isValidGSMDialCLIRMode(d) ((d >= gsmDialCLIRDefault) && (d <= gsmDialCLIRTemporarySuppression))
  • #define isValidPhnPowerType(p) (p <= phnPowerSave)
  • #define isValidPhnLockMode(m) ((m >= autoLockMode) && (m <= immediateLockMode))
Type and creator of CDMA and GSM phone libraries.
  • #define phnLibDbType 'libr'
  • #define phnLibCDMADbCreator 'PIL!'
  • #define phnLibCDMAName "Phone Library"
  • #define phnLibOldCDMADbCreator hsFileCCDMAPhoneLib
  • #define phnLibOldCDMAName "PhoneLib.prc"
  • #define phnLibGSMDbCreator hsFileCGSMPhoneLib
  • #define phnLibGSMDbName "Phone Library"
  • #define phnLibGSMName "GSMLibrary.lib"
  • #define phnVoiceCall1Active 0x0001
  • #define phnVoiceCall2Active 0x0002
  • #define phnCSDCallActive 0x0004
  • #define phnGPRSCallActive 0x0008
  • #define phnPacketDataCallActive 0x0008
  • #define phnPacketDataCallDormant 0x0010
  • #define phnCall1StatusActive 0x0020
  • #define phnCall2StatusActive 0x0040
  • #define phnCall1StatusDialing 0x0080
  • #define phnCall2StatusDialing 0x0100
  • #define phnCall1StatusIncoming 0x0200
  • #define phnCall2StatusIncoming 0x0400
  • #define phnCall1StatusAlerting 0x0800
  • #define phnCall2StatusAlerting 0x1000
CDMA Threshold level for signal bar (based on Generic Handset requirement)
  • #define maxDBm4signalLevel0 105
  • #define maxDBm4signalLevel1 95
  • #define maxDBm4signalLevel2 85
  • #define maxDBm4signalLevel3 75
  • #define maxDB4ecioLevel0 15
  • #define maxDB4ecioLevel1 13
  • #define maxDB4ecioLevel2 11
  • #define maxDB4ecioLevel3 9
Volume
  • #define phnVolumeMin 0
  • #define phnVolumeMax 7
Enumerations and Typedefs
  • #define phnLibUnknownID 0xff000000
  • #define phnLibNoLookupNeededID 0xff000001
  • #define phnLibFtrNumResetFlag 10
  • #define phnLibFtrNumBottomBRate 11
  • #define phnLibFtrNumBlockATCmd 12
  • #define phnLibFtrValBlockATCmd 'noAT'

Typedefs

  • typedef UInt16 PhnConnectionID
  • typedef UInt32 PhnDatabaseID
  • typedef VoidHand PhnAddressHandle
  • typedef VoidHand PhnAddressList
  • typedef UInt32 PhnOperatorID
  • typedef UInt16 PhoneServiceClassType
  • typedef UInt8 PhnAddressField
  • typedef UInt8 GSMDialCLIRMode
  • typedef UInt8 PhnPowerType
  • typedef UInt8 GSMSIMStatus
  • typedef UInt8 PhnLifeTimer
  • typedef UInt8 PhnLockMode

Enumerations

  • enum _PhoneServiceClassType {
    phnServiceVoice = 1,
    phnServiceSMS = 2,
    phnServiceActivation = 4,
    phnServiceData = 8,
    phnServiceIOTA = 16,
    phnServiceSIMToolkit = 32,
    phnServiceAFLT = 64,
    phnServiceMisc = 128,
    phnServiceEssentials = 256,
    phnServiceMMS = 512,
    phnServiceWAP = 1024,
    phnServiceAll,
    phnServiceMax = 0xFFFF
    }
  • enum _PhnAddressField {
    phnAddrFldPhone,
    phnAddrFldFirstName,
    phnAddrFldLastName
    }
  • enum _GSMDialCLIRMode {
    gsmDialCLIRDefault,
    gsmDialCLIRTemporaryInvocation,
    gsmDialCLIRTemporarySuppression
    }
  • enum _PhnPowerType {
    phnPowerOff,
    phnPowerOn,
    phnPowerStartCharging,
    phnPowerStopCharging,
    phnPowerLow,
    phnPowerSave
    }
  • enum _GSMSIMStatus {
    simMissing,
    simFailure,
    simWrong,
    simNotReady,
    simReady,
    simUnknown,
    simPresent
    }
  • enum {
    lifeTimeVoice,
    lifeTimeData
    }
  • enum PhnLockModeEnum {
    autoLockMode,
    immediateLockMode
    }

Define Documentation

#define isValidGSMDialCLIRMode ( d ) ((d >= gsmDialCLIRDefault) && (d <= gsmDialCLIRTemporarySuppression))

Definition at line 173 of file HsPhoneTypes.h.

#define isValidPhnAddressField ( a ) ((a >= phnAddrFldPhone) && (a <= phnAddrFldLastName))

Definition at line 159 of file HsPhoneTypes.h.

#define isValidPhnLockMode ( m ) ((m >= autoLockMode) && (m <= immediateLockMode))

Definition at line 246 of file HsPhoneTypes.h.

#define isValidPhnPowerType ( p ) (p <= phnPowerSave)

Definition at line 194 of file HsPhoneTypes.h.

#define isValidPhoneServiceClassType ( s ) ((s & phnServiceAll) != 0)

Definition at line 148 of file HsPhoneTypes.h.

#define maxDB4ecioLevel0 15

if below maxDBm4signalLevel3 then display 4 bars, mid percent = 90 Threshold ecio level for signal bar (based on Generic Handset requirement) will display no bar

Definition at line 85 of file HsPhoneTypes.h.

#define maxDB4ecioLevel1 13

will display 1 bar

Definition at line 86 of file HsPhoneTypes.h.

#define maxDB4ecioLevel2 11

will display 2 bars

Definition at line 87 of file HsPhoneTypes.h.

#define maxDB4ecioLevel3 9

will display 3 bars

Definition at line 88 of file HsPhoneTypes.h.

#define maxDBm4signalLevel0 105

will display no bar, mid percent = 10

Definition at line 73 of file HsPhoneTypes.h.

#define maxDBm4signalLevel1 95

will display 1 bar, mid percent = 30

Definition at line 74 of file HsPhoneTypes.h.

#define maxDBm4signalLevel2 85

will display 2 bars, mid percent = 50

Definition at line 75 of file HsPhoneTypes.h.

#define maxDBm4signalLevel3 75

will display 3 bars, mid percent = 70

Definition at line 76 of file HsPhoneTypes.h.

#define phnCall1StatusActive 0x0020

The first call's status is phnConnectionActive

Definition at line 58 of file HsPhoneTypes.h.

#define phnCall1StatusAlerting 0x0800

The first call's status is phnConnectionIncoming

Definition at line 64 of file HsPhoneTypes.h.

#define phnCall1StatusDialing 0x0080

The first call's status is phnConnectionDialing

Definition at line 60 of file HsPhoneTypes.h.

#define phnCall1StatusIncoming 0x0200

The first call's status is phnConnectionIncoming

Definition at line 62 of file HsPhoneTypes.h.

#define phnCall2StatusActive 0x0040

The second call's status is phnConnectionActive

Definition at line 59 of file HsPhoneTypes.h.

#define phnCall2StatusAlerting 0x1000

The second call's status is phnConnectionIncoming

Definition at line 65 of file HsPhoneTypes.h.

#define phnCall2StatusDialing 0x0100

The second call's status is phnConnectionDialing

Definition at line 61 of file HsPhoneTypes.h.

#define phnCall2StatusIncoming 0x0400

The second call's status is phnConnectionIncoming

Definition at line 63 of file HsPhoneTypes.h.

#define phnCSDCallActive 0x0004

There is a data call currently active

Definition at line 50 of file HsPhoneTypes.h.

#define phnGPRSCallActive 0x0008

There is a GPRS (GSM) session active

Definition at line 54 of file HsPhoneTypes.h.

#define phnLibCDMADbCreator 'PIL!'

CDMA Library creator

Definition at line 36 of file HsPhoneTypes.h.

#define phnLibCDMAName "Phone Library"

CDMA Library name

Definition at line 37 of file HsPhoneTypes.h.

#define phnLibDbType 'libr'

Phone Library type

Definition at line 34 of file HsPhoneTypes.h.

#define phnLibFtrNumBlockATCmd 12

Definition at line 110 of file HsPhoneTypes.h.

#define phnLibFtrNumBottomBRate 11

Definition at line 109 of file HsPhoneTypes.h.

#define phnLibFtrNumResetFlag 10

Definition at line 108 of file HsPhoneTypes.h.

#define phnLibFtrValBlockATCmd 'noAT'

Definition at line 111 of file HsPhoneTypes.h.

#define phnLibGSMDbCreator hsFileCGSMPhoneLib

GSM Library creator

Definition at line 43 of file HsPhoneTypes.h.

#define phnLibGSMDbName "Phone Library"

GSM Library database name

Definition at line 44 of file HsPhoneTypes.h.

#define phnLibGSMName "GSMLibrary.lib"

GSM Library name

Definition at line 45 of file HsPhoneTypes.h.

#define phnLibNoLookupNeededID 0xff000001

Definition at line 107 of file HsPhoneTypes.h.

#define phnLibOldCDMADbCreator hsFileCCDMAPhoneLib

Old CDMA Library creator

Definition at line 39 of file HsPhoneTypes.h.

#define phnLibOldCDMAName "PhoneLib.prc"

Old CDMA Library name

Definition at line 40 of file HsPhoneTypes.h.

#define phnLibUnknownID 0xff000000

Definition at line 106 of file HsPhoneTypes.h.

#define phnPacketDataCallActive 0x0008

There is an active 1X (CDMA) call

Definition at line 55 of file HsPhoneTypes.h.

#define phnPacketDataCallDormant 0x0010

There is a dormany 1X (CDMA) call

Definition at line 56 of file HsPhoneTypes.h.

#define phnVoiceCall1Active 0x0001

There is a voice call active on line1

Definition at line 48 of file HsPhoneTypes.h.

#define phnVoiceCall2Active 0x0002

There is a voice call active on line2

Definition at line 49 of file HsPhoneTypes.h.

#define phnVolumeMax 7

Maximum volume level

Definition at line 97 of file HsPhoneTypes.h.

#define phnVolumeMin 0

Minimum volume level

Definition at line 96 of file HsPhoneTypes.h.

Typedef Documentation

typedef UInt8 GSMDialCLIRMode

Definition at line 176 of file HsPhoneTypes.h.

typedef UInt8 GSMSIMStatus

Definition at line 211 of file HsPhoneTypes.h.

typedef UInt8 PhnAddressField

Definition at line 162 of file HsPhoneTypes.h.

typedef VoidHand PhnAddressHandle

Definition at line 116 of file HsPhoneTypes.h.

typedef VoidHand PhnAddressList

Definition at line 117 of file HsPhoneTypes.h.

typedef UInt16 PhnConnectionID

Connection ID

Definition at line 114 of file HsPhoneTypes.h.

typedef UInt32 PhnDatabaseID

Database ID

Definition at line 115 of file HsPhoneTypes.h.

typedef UInt8 PhnLifeTimer

Definition at line 223 of file HsPhoneTypes.h.

typedef UInt8 PhnLockMode

Definition at line 245 of file HsPhoneTypes.h.

typedef UInt32 PhnOperatorID

Definition at line 118 of file HsPhoneTypes.h.

typedef UInt8 PhnPowerType

Definition at line 192 of file HsPhoneTypes.h.

typedef UInt16 PhoneServiceClassType

Definition at line 146 of file HsPhoneTypes.h.

Enumeration Type Documentation

anonymous enum

LifeTimer Enums

Enumerator:
lifeTimeVoice
lifeTimeData

Definition at line 217 of file HsPhoneTypes.h.

00218 {
00219   lifeTimeVoice,    /**<        */
00220   lifeTimeData      /**<        */
00221 };

enum _GSMDialCLIRMode

GSM CLIR Mode

Enumerator:
gsmDialCLIRDefault
gsmDialCLIRTemporaryInvocation
gsmDialCLIRTemporarySuppression

Definition at line 167 of file HsPhoneTypes.h.

00167               {
00168     gsmDialCLIRDefault,             /**<        */
00169     gsmDialCLIRTemporaryInvocation,     /**<        */
00170     gsmDialCLIRTemporarySuppression     /**<        */
00171 } _GSMDialCLIRMode;

enum _GSMSIMStatus

Status of the SIM on GSM radio only

Enumerator:
simMissing
simFailure
simWrong
simNotReady
simReady
simUnknown
simPresent

Definition at line 200 of file HsPhoneTypes.h.

00200                    {
00201     simMissing,         /**<        */
00202     simFailure,         /**<        */
00203     simWrong,       /**<        */
00204     simNotReady,        /**<        */
00205     simReady,       /**<        */
00206     simUnknown,         /**<        */
00207     simPresent      /**<        */
00208     // <chg 05-05-2002 TRS> bug # 13072
00209 };

enum _PhnAddressField

Phone address fields

Enumerator:
phnAddrFldPhone
phnAddrFldFirstName
phnAddrFldLastName

Definition at line 153 of file HsPhoneTypes.h.

00153              {
00154     phnAddrFldPhone,        /**<        */
00155     phnAddrFldFirstName,        /**<        */
00156     phnAddrFldLastName      /**<        */
00157 } _PhnAddressField;

enum _PhnPowerType

Power state of the radio

Enumerator:
phnPowerOff
phnPowerOn
phnPowerStartCharging
phnPowerStopCharging
phnPowerLow
phnPowerSave Modem goes to deep sleep after failing to search for service

Definition at line 182 of file HsPhoneTypes.h.

00183   {
00184     phnPowerOff,        /**<        */
00185     phnPowerOn,         /**<        */
00186     phnPowerStartCharging,  /**<        */
00187     phnPowerStopCharging,   /**<        */
00188     phnPowerLow,        /**<        */
00189     phnPowerSave                /**< Modem goes to deep sleep after failing to search for service */
00190   };

enum _PhoneServiceClassType

Classes of service for which applications can register

Enumerator:
phnServiceVoice | 0x0001
phnServiceSMS | 0x0002
phnServiceActivation | 0x0004
phnServiceData | 0x0008
phnServiceIOTA | 0x0010
phnServiceSIMToolkit | 0x0020
phnServiceAFLT | 0x0040
phnServiceMisc | 0x0080
phnServiceEssentials | 0x0100
phnServiceMMS | 0x200
phnServiceWAP | 0x400
phnServiceAll
phnServiceMax | Reserved.

Definition at line 127 of file HsPhoneTypes.h.

00128   {
00129     phnServiceVoice = 1,        /**< 0x0001 */
00130     phnServiceSMS = 2,          /**< 0x0002 */
00131     phnServiceActivation = 4,       /**< 0x0004 */
00132     phnServiceData = 8,         /**< 0x0008 */
00133     phnServiceIOTA = 16,        /**< 0x0010 */
00134     phnServiceSIMToolkit = 32,  /**< 0x0020 */
00135     phnServiceAFLT = 64,        /**< 0x0040 */
00136     phnServiceMisc = 128,       /**< 0x0080 */
00137     phnServiceEssentials = 256, /**< 0x0100 */
00138     phnServiceMMS = 512,            /**< 0x200 */
00139     phnServiceWAP = 1024,           /**< 0x400 */
00140     phnServiceAll = phnServiceVoice | phnServiceSMS | phnServiceAFLT |
00141                     phnServiceData | phnServiceActivation | phnServiceMisc | phnServiceIOTA |
00142                     phnServiceEssentials | phnServiceSIMToolkit | phnServiceMMS | phnServiceWAP,
00143     phnServiceMax = 0xFFFF          /**< Reserved. */
00144   };

enum PhnLockModeEnum

Enumerator:
autoLockMode | option Lock Phone on Power Down is chosen
immediateLockMode | option Lock Phone immediately is chosen

Definition at line 239 of file HsPhoneTypes.h.

00240   {
00241     autoLockMode,               /**< option Lock Phone on Power Down is chosen */
00242     immediateLockMode           /**< option Lock Phone immediately is chosen */
00243   }

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:07:31 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » hssoundlib

HsSoundLib.h File Reference

Detailed Description

Public 68K include file for main sound support for Treo 600 and Treo 650 smartphones.

This header file and associated header files support the specific sound functionality of the Treo smartphones. You should use the Palm OS Sound Manager APIs for most of your work.

Notes: The calling application should always load this library with SysLibLoad() before use, even if it is already open by another application(ie, SysLibFind() returns a valid refnum). When the application is done with the library, it should be unloaded with SysLibRemove(). We do this because there is no good way to synchronize loading and unloading of libraries among multiple applications. It also greatly simplifies internal synchronization.

Definition in file HsSoundLib.h.

Include dependency graph for HsSoundLib.h:

Go to the source code of this file.

Defines

Preference Macros
  • #define PmSndSetPreference(libRef, prefID, prefValue) HsSndSwitchSetPort( libRef, pmSndSwitchID_Preferences, (HsSndPortID) (prefValue), (HsSndPortClass) (prefID) );
  • #define PmSndGetPreference(libRef, prefID, prefValuePtr) HsSndSwitchGetPort( libRef, pmSndSwitchID_Preferences, (HsSndPortID *) (prefValuePtr), (HsSndPortClass) (prefID) );
Special Function Macros
  • #define PmSndStreamSetAttackEnvID(libRef, stream, attackEnvID) HsSndFormatPlay( libRef, (HsSndFormatType) pmSndFormatSetAttackEnvID, (HsSndCmdType) attackEnvID, (void*)0, (UInt32) stream )
  • #define PmSndStreamPause(libRef, stream) HsSndFormatPlay( libRef, (HsSndFormatType) pmSndFormatPauseStream, (HsSndCmdType) 0, (void*) 0, (UInt32) stream )
  • #define PmSndStreamResume(libRef, stream) HsSndFormatPlay( libRef, (HsSndFormatType) pmSndFormatResumeStream, (HsSndCmdType) 0, (void*) 0, (UInt32) stream )
  • #define PmSndStreamStoppable(libRef, stream) HsSndFormatPlay( libRef, (HsSndFormatType) pmSndFormatSetStoppable, (HsSndCmdType) 0, (void*) 0, (UInt32) stream )

Functions

  • Err HsSndOpen (UInt16 libRef)
  • Err HsSndClose (UInt16 libRef)
  • UInt32 HsSndGetVersion (UInt16 libRef)
  • Err HsSndPortGetInfo (UInt16 libRef, HsSndPortID portID, HsSndPortInfo *portInfoP)
  • Err HsSndPortSetParam (UInt16 libRef, HsSndPortID portID, HsSndParam paramSel, Int16 value, Int16 *returnValue)
  • Err HsSndSwitchGetPort (UInt16 libRef, HsSndSwitchID switchID, HsSndPortID *portIDP, HsSndPortClass portClass)
  • Err HsSndSwitchSetPort (UInt16 libRef, HsSndSwitchID switchID, HsSndPortID portID, HsSndPortClass portClass)
  • Err HsSndTonePlay (UInt16 libRef, UInt32 freq, UInt16 amp, UInt32 duration, UInt32 toneType)
  • Err HsSndToneStop (UInt16 libRef)
  • Err HsSndFormatPlay (UInt16 libRef, HsSndFormatType format, HsSndCmdType command, void *commandData, UInt32 commandFlags)
  • Err HsSndFormatRecord (UInt16 libRef, HsSndFormatType format, HsSndCmdType command, void *commandData, UInt32 commandFlags)
  • Err HsSndGetUserVolume (UInt16 libRef, HsSndMode mode, Int16 *volumeP)
  • Err HsSndSetUserVolume (UInt16 libRef, HsSndMode mode, Int16 volume)
  • Err PmSndClkGetTicksPerSecond (UInt16 libRef, PmClkTickRef clkRef, UInt32 *ticksPerSecondP)
  • Err PmSndClkGetTickCount (UInt16 libRef, PmClkTickRef clkRef, PmSndU64 *clockTicksP)
  • Err PmSndGetPosition (UInt16 libRef, SndStreamRef streamRef, PmSndU64 *sampleNumberP, PmClkTickRef clkRef, PmSndU64 *clockTicksP)

Define Documentation

#define PmSndGetPreference | ( | libRef,
 |  | prefID,
 |  | prefValuePtr | ) | HsSndSwitchGetPort( libRef, pmSndSwitchID_Preferences, (HsSndPortID *) (prefValuePtr), (HsSndPortClass) (prefID) );

Definition at line 52 of file HsSoundLib.h.

#define PmSndSetPreference | ( | libRef,
 |  | prefID,
 |  | prefValue | ) | HsSndSwitchSetPort( libRef, pmSndSwitchID_Preferences, (HsSndPortID) (prefValue), (HsSndPortClass) (prefID) );

Definition at line 49 of file HsSoundLib.h.

#define PmSndStreamPause | ( | libRef,
 |  | stream | ) | HsSndFormatPlay( libRef, (HsSndFormatType) pmSndFormatPauseStream, (HsSndCmdType) 0, (void*) 0, (UInt32) stream )

Definition at line 62 of file HsSoundLib.h.

#define PmSndStreamResume | ( | libRef,
 |  | stream | ) | HsSndFormatPlay( libRef, (HsSndFormatType) pmSndFormatResumeStream, (HsSndCmdType) 0, (void*) 0, (UInt32) stream )

Definition at line 63 of file HsSoundLib.h.

#define PmSndStreamSetAttackEnvID | ( | libRef,
 |  | stream,
 |  | attackEnvID | ) | HsSndFormatPlay( libRef, (HsSndFormatType) pmSndFormatSetAttackEnvID, (HsSndCmdType) attackEnvID, (void*)0, (UInt32) stream )

Definition at line 61 of file HsSoundLib.h.

#define PmSndStreamStoppable | ( | libRef,
 |  | stream | ) | HsSndFormatPlay( libRef, (HsSndFormatType) pmSndFormatSetStoppable, (HsSndCmdType) 0, (void*) 0, (UInt32) stream )

Definition at line 64 of file HsSoundLib.h.

Function Documentation

Err HsSndClose ( UInt16 libRef )

Close the Sound library instance.

Parameters:
libRef,: IN: Library reference number (from SysLibLoad)
Returns:
Library error code.

Err HsSndFormatPlay | ( | UInt16 | libRef,
 |  | HsSndFormatType | format,
 |  | HsSndCmdType | command,
 |  | void * | commandData,
 |  | UInt32 | commandFlags
 | ) |  |

Play formatted audio data, such as MIDI, AMR, and so forth.

Parameters:
libRef,: IN: Library reference number (from SysLibLoad).
format,: IN: Audio format to be played.
command,: IN: Command to execute. Should be set to hsSndCmdPlay.
commandData,: IN: Command to the sound buffer structure HsSndBufferData
commandFlags,: IN: Command flags for the play command.
Returns:
Library error code.

Err HsSndFormatRecord | ( | UInt16 | libRef,
 |  | HsSndFormatType | format,
 |  | HsSndCmdType | command,
 |  | void * | commandData,
 |  | UInt32 | commandFlags
 | ) |  |

Records formatted audio data, such as MIDI, AMR, and so forth. (Currently a stub and not implemented yet).

Parameters:
libRef,: IN: Library reference number (from SysLibLoad).
format,: IN: Audio format to be recorded.
command,: IN: Command to execute. Should be set to hsSndCmdPlay.
commandData,: IN: Pointer to the sound buffer structure HsSndBufferData.
commandFlags,: IN: The command flags for the record command.
Returns:
Library error code.

Err HsSndGetUserVolume | ( | UInt16 | libRef,
 |  | HsSndMode | mode,
 |  | Int16 * | volumeP
 | ) |  |

Get the user volume setting for the specified sound mode.

Parameters:
libRef,: IN: Library reference number (from SysLibLoad).
mode,: IN: The audio configuration mode.
volumeP,: IN: The sound level.
Returns:
Library error code.

UInt32 HsSndGetVersion ( UInt16 libRef )

Returns the library version number.

Parameters:
libRef,: IN: Library reference number (from SysLibLoad)
Returns:
Library error code.

Err HsSndOpen ( UInt16 libRef )

Open and initialize the Sound library instance.

Parameters:
libRef,: IN: Library reference number (from SysLibLoad)
Returns:
Library error code.

Err HsSndPortGetInfo | ( | UInt16 | libRef,
 |  | HsSndPortID | portID,
 |  | HsSndPortInfo * | portInfoP
 | ) |  |

Returns information about the sound port.

Parameters:
libRef,: IN: Library reference number
portID,: IN: Sound port ID.
*portInfoP,: IN: Pointer to an HsSndPortInfo structure provided by the caller.
Returns:
Library error code.

Err HsSndPortSetParam | ( | UInt16 | libRef,
 |  | HsSndPortID | portID,
 |  | HsSndParam | paramSel,
 |  | Int16 | value,
 |  | Int16 * | returnValue
 | ) |  |

Set a sound port's audio parameter.

Parameters:
libRef,: IN: Library reference number (from SysLibLoad)
portID,: IN: Sound port ID.
paramSel,: IN: Parameter selector.
value,: IN: Value to set.
returnValue,: OUT: Pointer to the updated value.
Returns:
Library error code.

Err HsSndSetUserVolume | ( | UInt16 | libRef,
 |  | HsSndMode | mode,
 |  | Int16 | volume
 | ) |  |

Set the user volume for the specified sound mode.

Parameters:
libRef,: IN: Library reference number (from SysLibLoad).
mode,: IN: The audio configuration mode.
volume,: IN: The sound level.
Returns:
Library error code.

Err HsSndSwitchGetPort | ( | UInt16 | libRef,
 |  | HsSndSwitchID | switchID,
 |  | HsSndPortID * | portIDP,
 |  | HsSndPortClass | portClass
 | ) |  |

Get the current sound port for a particular switch.

Parameters:
libRef,: IN: Library reference number (from SysLibLoad)
switchID,: IN: Switch ID.
portIDP,: OUT: Port ID returned to the caller.
portClass,: IN: Port class selector.
Returns:
Library error code.

Err HsSndSwitchSetPort | ( | UInt16 | libRef,
 |  | HsSndSwitchID | switchID,
 |  | HsSndPortID | portID,
 |  | HsSndPortClass | portClass
 | ) |  |

Set the current sound port for a particular switch.

Parameters:
libRef,: IN: Library reference number (from SysLibLoad)
switchID,: IN: Switch ID.
portID,: IN: The new port ID for the audio switch.
portClass,: IN: Port class selector.
Returns:
Library error code.

Err HsSndTonePlay | ( | UInt16 | libRef,
 |  | UInt32 | freq,
 |  | UInt16 | amp,
 |  | UInt32 | duration,
 |  | UInt32 | toneType
 | ) |  |

Play a sound.

Parameters:
libRef,: IN: Library reference number (from SysLibLoad).
freq,: IN: Frequency of the tone.
amp,: IN: Amplitude of the tone.
duration,: IN: Duration of the tone.
toneType,: IN: Type of tone to play.
Returns:
Library error code.

Err HsSndToneStop ( UInt16 libRef )

Stop playing a sound that was started with HsSndTonePlay().

Parameters:
libRef,: IN: Library reference number (from SysLibLoad).
Returns:
Library error code.

Err PmSndClkGetTickCount | ( | UInt16 | libRef,
 |  | PmClkTickRef | clkRef,
 |  | PmSndU64 * | clockTicksP
 | ) |  |

Get current clock tick count.

Parameters:
libRef,: IN: Library reference number (from SysLibLoad).
clkRef,: IN: Clock reference number (see HsSoundLibCommon.h).
clockTicksP OUT: Returns the current clock tick count.
Returns:
Library error code.

Err PmSndClkGetTicksPerSecond | ( | UInt16 | libRef,
 |  | PmClkTickRef | clkRef,
 |  | UInt32 * | ticksPerSecondP
 | ) |  |

Get the number of clock ticks per second

Parameters:
libRef,: IN: Library reference number (from SysLibLoad).
clkRef,: IN: Clock reference number (see HsSoundLibCommon.h).
ticksPerSecondP OUT: Returns the tick per second
Returns:
Library error code.

Err PmSndGetPosition | ( | UInt16 | libRef,
 |  | SndStreamRef | streamRef,
 |  | PmSndU64 * | sampleNumberP,
 |  | PmClkTickRef | clkRef,
 |  | PmSndU64 * | clockTicksP
 | ) |  |

Get current stream sample position and current clock tick count.

Parameters:
libRef,: IN: Library reference number (from SysLibLoad).
streamRef | IN: Sound stream channel reference id.
sampleNumberP,: OUT: Returns the current sample number for the stream.
clkRef,: IN: Clock reference number (see HsSoundLibCommon.h).
clockTicksP | OUT: Returns the current clock tick count.
Returns:
Library error code.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:07:31 2008 for Palm API Guide


Header Files » Incs » common » libraries » hssoundlib

HsSoundLibCommon.h File Reference

Detailed Description

Public 68K/Arm common header file for sound support for Treo 600, Treo 650, and Treo 700p smartphones and later models.

This file contains the common constants and structures to be used with the sound library.

Definition in file HsSoundLibCommon.h.

Include dependency graph for HsSoundLibCommon.h:

Go to the source code of this file.

Data Structures

  • struct HsSndPortInfo
    Holds sound port information. More...
  • struct HsSndBufferData
    Holds sound buffer information. More...
  • struct HsSndMidiProgressMsg

Gain Envelope Definitions

Used as attackEnvID parameter to function PmSndStreamSetAttackEnvID.
  • #define pmSndAttackEnvIDRings (hsSndBufFlags_attackEnvRings)
  • #define pmSndAttackEnvIDVibeRing (hsSndBufFlags_attackEnvVibeRings)
  • #define pmSndAttackEnvIDRings2 (hsSndBufFlags_attackEnvRings2)
  • #define pmSndAttackEnvIDVibeRing2 (hsSndBufFlags_attackEnvVibeRings2)
  • #define pmSndBayID_AUDP 0x0F000000
  • #define PM_AUDP_CLASS_MASK 0x4000
  • #define PM_AUDP_CLASS(n) ((n) | PM_AUDP_CLASS_MASK)
  • #define pmSndPrefID_AppsGroupHoldType PM_AUDP_CLASS(0x0001)
  • #define pmSndPrefID_JackOutIfMicUnused PM_AUDP_CLASS(0x0002)
  • #define pmSndPrefID_PhoneRxGainLimit PM_AUDP_CLASS(0x0003)
  • #define pmSndPrefID_WakeOnAnswerBtn PM_AUDP_CLASS(0x0004)
  • #define pmSndPrefID_AudioTable PM_AUDP_CLASS(0x0005)
  • #define pmSndPrefID_GsmMccArray PM_AUDP_CLASS(0x0006)
  • #define pmSndPrefID_AthenaActive PM_AUDP_CLASS(0x0007)
  • #define pmSndPrefID_SleepMode PM_AUDP_CLASS(0x0008)
  • #define pmSndPrefID_AGCEvent PM_AUDP_CLASS(0x0009)
  • #define pmSndPrefID_AthenaAudio PM_AUDP_CLASS(0x000A)
  • #define pmSndPref_WakeOnAnswerBtn_Disable (0)
  • #define pmSndPref_WakeOnAnswerBtn_Enable (1)
  • #define pmSndPref_AthenaActive_No (0)
  • #define pmSndPref_AthenaActive_Yes (1)
  • #define pmSndPref_AthenaAudio_NoRouting (0)
  • #define pmSndPref_AthenaAudio_IfMicPresent (16)
  • #define pmSndPref_AthenaAudio_Unconditional (32)
  • #define PM_AUDP(n) ((n) | pmSndBayID_AUDP)
  • #define pmSndSwitchID_Preferences PM_AUDP(0x00400000)
  • #define pmAudioClkTickRef ((PmClkTickRef) 0x00000001)
  • typedef UInt16 PmSndPrefID
  • typedef UInt32 PmClkTickRef

Defines

  • #define hsSndBayID_AC97 0x01000000
  • #define hsSndMidiMsg_SetVolume 1
  • #define hsSndMidiProgressMsg_Signature 'MidP'
  • #define hsSndPortInfo_Signature 'SPRT'
  • #define hsSndBufferData_Signature 'SBDA'
HsSoundLib information
  • #define hsSndLibVersion 0x010D0000
  • #define hsSoundLibCreatorID hsFileSoundLib
  • #define hsSoundLibTypeID sysFileTLibrary
  • #define hsSoundLibName "HsSoundLib"
Sound library event notifications
Note: Each one of these notifications are reserved as Creator IDs with PalmSource

  • #define hsSndNotify hsFileSoundLib
  • #define hsSndNotifyUnplugged 'hOff'
  • #define hsSndNotifyHeadset 'hSet'
  • #define hsSndNotifyHeadphones 'hPho'
  • #define hsSndNotifyHybrid 'hHyb'
  • #define hsSndNotifyNotHybrid 'hNoH'
  • #define hsSndNotifyAnswerButton 'hAns'
  • #define hsSndNotifyAnswerHold 'hHol'
  • #define hsSndNotifyAnswerRelease 'hRel'
  • #define hsSndNotifyRingerSwitchOn 'hROn'
  • #define hsSndNotifyRingerSwitchOff 'hROf'
  • #define hsSndNotifyHighPriority 'hHPr'
  • #define hsSndNotifyAlert 'hAlr'
  • #define hsSndNotifyCarkitActive 'hCar'
  • #define hsSndNotifyCarkitInactive 'hCOf'
  • #define hsSndNotifyAthenaAudio 'hAta'
Sound library resource types
  • #define hsSndRsrcAudioTableType 'hTbl'
  • #define hsSndRsrcAudioTableID 25000
Sound library error codes
  • #define hsSndErrBase hsSoundLibErrorClass
  • #define HS_SND_ERR(x) ((Err)((x) + hsSndErrBase))
  • #define hsSndErr_Failed (HS_SND_ERR(1))
  • #define hsSndErr_NotSupported (HS_SND_ERR(2))
  • #define hsSndErr_InvalidPort (HS_SND_ERR(3))
  • #define hsSndErr_PortCannotMute (HS_SND_ERR(4))
  • #define hsSndErr_PortCannotVolume (HS_SND_ERR(5))
  • #define hsSndErr_PortCannotBoost (HS_SND_ERR(6))
  • #define hsSndErr_PortCannotPan (HS_SND_ERR(7))
  • #define hsSndErr_InvalidSwitch (HS_SND_ERR(8))
  • #define hsSndErr_UnknownSndParam (HS_SND_ERR(9))
  • #define hsSndErr_UnknownPortClass (HS_SND_ERR(10))
  • #define hsSndErr_PortIDNotInClass (HS_SND_ERR(11))
  • #define hsSndErr_PortMuteLocked (HS_SND_ERR(12))
  • #define hsSndErr_PortVolumeLocked (HS_SND_ERR(13))
  • #define hsSndErr_PortBoostLocked (HS_SND_ERR(14))
  • #define hsSndErr_PortPanLocked (HS_SND_ERR(15))
  • #define hsSndErr_DoMidiProgressMsg (HS_SND_ERR(16))
  • #define hsSndErr_UnknownClkRef (HS_SND_ERR(17))
  • #define hsSndErr_InvalidPrefValue (HS_SND_ERR(18))
  • #define hsSndErr_LastPublicError (HS_SND_ERR(63))
Sound mode volume controls
Use with HsSndGetUserVolume and HsSndSetUserVolume.

  • #define hsSndMode_Current ((HsSndMode) 0x0000)
  • #define hsSndMode_Receiver ((HsSndMode) 0x0001)
  • #define hsSndMode_Speakerphone ((HsSndMode) 0x0002)
  • #define hsSndMode_SpeakerHost ((HsSndMode) 0x0003)
  • #define hsSndMode_Headset ((HsSndMode) 0x0004)
  • #define hsSndMode_Headphones ((HsSndMode) 0x0005)
  • #define hsSndMode_HeadphonesHost ((HsSndMode) 0x0006)
  • #define hsSndMode_Carkit ((HsSndMode) 0x0007)
  • #define hsSndMode_Reserved ((HsSndMode) 0x0008)
Tone type parameter
  • #define hsSndToneType_Square 0
Utility Macros - I
  • #define HS_AC97(n) ((n) | hsSndBayID_AC97)
  • #define HS_RDIO(n) ((n) | hsSndBayID_Radio)
  • #define HsSndParamValue_SetWithLock(v) (((v) & ~hsSndParamMode_Mask) | hsSndParamMode_LockParam)
  • #define HsSndParamValue_SetWithUnlock(v) (((v) & ~hsSndParamMode_Mask) | hsSndParamMode_UnlockParam)
  • #define HsSndParamValue_RemoveMode(v) (((v) & 0x8000)? (v) | hsSndParamMode_Mask : (v) & ~hsSndParamMode_Mask)
Sound switch configuration types
Used with HsSndSwitchID.

  • #define hsSndSwitchID_InRadioSpkr HS_AC97(0x00010000)
  • #define hsSndSwitchID_OutRadioMic HS_AC97(0x00020000)
  • #define hsSndSwitchID_InMic HS_AC97(0x00030000)
  • #define hsSndSwitchID_InHostPlay HS_AC97(0x00040000)
  • #define hsSndSwitchID_OutHostRec HS_AC97(0x00050000)
Sound port configuration types
Used with HsSndPortID.

  • #define hsSndPortID_Off 0x00000000
  • #define hsSndPortID_Current HS_AC97(0x00000000)
  • #define hsSndPortID_OutReceiver HS_AC97(0x00000001)
  • #define hsSndPortID_OutSpeaker HS_AC97(0x00000002)
  • #define hsSndPortID_OutHeadset HS_AC97(0x00000003)
  • #define hsSndPortID_OutHeadphones HS_AC97(0x00000004)
  • #define hsSndPortID_OutSpeakerAuto HS_AC97(0x00000005)
  • #define hsSndPortID_InLineRec HS_AC97(0x00000006)
  • #define hsSndPortID_InBaseMic HS_AC97(0x00000007)
  • #define hsSndPortID_InHeadsetMic HS_AC97(0x00000008)
  • #define hsSndPortID_InMicAuto HS_AC97(0x00000009)
  • #define hsSndPortID_OutRadioMic HS_AC97(0x0000000A)
  • #define hsSndPortID_InRadioSpkr HS_AC97(0x0000000B)
  • #define hsSndPortID_OutHostRec HS_AC97(0x0000000C)
  • #define hsSndPortID_InHostPlay HS_AC97(0x0000000D)
  • #define hsSndPortID_OutBtHeadset HS_AC97(0x0000000E)
  • #define hsSndPortID_OutBtHandsfree HS_AC97(0x0000000F)
  • #define hsSndPortID_InHostBaseMic HS_AC97(0x00000010)
  • #define hsSndPortID_InHostHeadsetMic HS_AC97(0x00000011)
  • #define hsSndPortID_InHostPhone HS_AC97(0x00000012)
  • #define hsSndPortID_InCarkit HS_AC97(0x00000013)
  • #define hsSndPortID_OutCarkit HS_AC97(0x00000014)
  • #define hsSndPortID_InBtHeadset HS_AC97(0x00000015)
  • #define hsSndPortID_InBtHandsfree HS_AC97(0x00000016)
  • #define hsSndPortID_LastPort HS_AC97(0x00000016)
RadioBayID
  • #define hsSndBayID_Radio 0x02000000
Sound switch configuration type for Radio patch bay
Used with HsSndSwitchID.

  • #define hsSndSwitchID_RadioCall HS_RDIO(0x00010000)
Sound port configuration type for hsSndSwitchID_RadioCall
hsSndPortID_Off is already defined for all patch bays. Use it to turn off the switch indicating no radio call connected.

  • #define hsSndPortID_ConnectCall HS_RDIO(0x00000020)
Sound port classes
Used when passing a HsSndPortClass parameter in HsSndSwitchGetPort and HsSndSwitchSetPort functions.

  • #define hsSndPortClass_Virtual ((UInt16) 0)
  • #define hsSndPortClass_Real ((UInt16) 1)
  • #define hsSndPortClass_BaseDefault ((UInt16) 2)
  • #define hsSndPortClass_Anchor ((UInt16) 3)
Sound parameters
Used when passing a parameter of type HsSndParam.

  • #define hsSndParam_Volume ((UInt16) 1)
  • #define hsSndParam_Mute ((UInt16) 2)
  • #define hsSndParam_Boost ((UInt16) 3)
  • #define hsSndParam_Pan ((UInt16) 4)
Sound parameter expansion macros
Used to add sound parameter values for additional sound parameter control. For example, muteState = HsSndParamValue_SetWithLock(hsSndMute_Enable);.

  • #define hsSndParamMode_Mask 0x7000
  • #define hsSndParamMode_Normal 0x0000
  • #define hsSndParamMode_LockParam 0x4000
  • #define hsSndParamMode_UnlockParam 0x2000
Mute parameters
Used to enable or disable a hsSndParam_Mute parameter.

  • #define hsSndMute_Enable 1
  • #define hsSndMute_Disable 0
Boost parameters
Used to enable or disable a hsSndParam_Boost parameter.

  • #define hsSndBoost_Enable 1
  • #define hsSndBoost_Disable 0
Pan parameters
Used as special hsSndParam_Pan parameters otherwise use actual Pan value.

  • #define hsSndPan_Middle ((Int16) 0x0000)
  • #define hsSndPan_Right ((Int16) 0x7FFF)
  • #define hsSndPan_Left ((Int16) 0x8000)
  • #define hsSndPan_RightNormal ((Int16) 0x07FF)
  • #define hsSndPan_LeftNormal ((Int16) 0x0800)
Sound port flag settings
Used with the "flags" variable in HsSndPortInfo structure.

  • #define hsSndPortFlags_Enabled 0x00000001
  • #define hsSndPortFlags_Disabled 0x00000000
  • #define hsSndPortFlags_EnableMask 0x00000001
  • #define hsSndPortFlags_MuteOn 0x00000002
  • #define hsSndPortFlags_MuteOff 0x00000000
  • #define hsSndPortFlags_MuteMask 0x00000002
  • #define hsSndPortFlags_TypeDigital 0x00000004
  • #define hsSndPortFlags_TypeAnalog 0x00000000
  • #define hsSndPortFlags_TypeMask 0x00000004
  • #define hsSndPortFlags_BoostOn 0x00000008
  • #define hsSndPortFlags_BoostOff 0x00000000
  • #define hsSndPortFlags_BoostMask 0x00000008
  • #define hsSndPortFlags_CanInputOnly 0x00000000
  • #define hsSndPortFlags_CanOutputOnly 0x00000010
  • #define hsSndPortFlags_CanIOSelect 0x00000020
  • #define hsSndPortFlags_CanIOBothways 0x00000030
  • #define hsSndPortFlags_CanIOMask 0x00000030
  • #define hsSndPortFlags_InputOn 0x00000040
  • #define hsSndPortFlags_InputOff 0x00000000
  • #define hsSndPortFlags_InputMask 0x00000040
  • #define hsSndPortFlags_OutputOn 0x00000080
  • #define hsSndPortFlags_OutputOff 0x00000000
  • #define hsSndPortFlags_OutputMask 0x00000080
  • #define hsSndPortFlags_CanMute_Yes 0x00000100
  • #define hsSndPortFlags_CanMute_No 0x00000000
  • #define hsSndPortFlags_CanMuteMask 0x00000100
  • #define hsSndPortFlags_CanBoost_Yes 0x00000200
  • #define hsSndPortFlags_CanBoost_No 0x00000000
  • #define hsSndPortFlags_CanBoostMask 0x00000200
  • #define hsSndPortFlags_CanPan_Yes 0x00000400
  • #define hsSndPortFlags_CanPan_No 0x00000000
  • #define hsSndPortFlags_CanPanMask 0x00000400
  • #define hsSndPortFlags_CanVol_Yes 0x00000800
  • #define hsSndPortFlags_CanVol_No 0x00000000
  • #define hsSndPortFlags_CanVolMask 0x00000800
  • #define hsSndPortFlags_Mute_Locked 0x00001000
  • #define hsSndPortFlags_Mute_Unlocked 0x00000000
  • #define hsSndPortFlags_Mute_LockMask 0x00001000
  • #define hsSndPortFlags_Boost_Locked 0x00002000
  • #define hsSndPortFlags_Boost_Unlocked 0x00000000
  • #define hsSndPortFlags_Boost_LockMask 0x00002000
  • #define hsSndPortFlags_Pan_Locked 0x00004000
  • #define hsSndPortFlags_Pan_Unlocked 0x00000000
  • #define hsSndPortFlags_Pan_LockMask 0x00004000
  • #define hsSndPortFlags_Vol_Locked 0x00008000
  • #define hsSndPortFlags_Vol_Unlocked 0x00000000
  • #define hsSndPortFlags_Vol_LockMask 0x00008000
Command flag settings
Used with the "Commandflags" parameter in HsSndFormatPlay function.

  • #define hsSndCmdFlags_noWait 0x00000001
  • #define hsSndCmdFlags_yesWait 0x00000000
  • #define hsSndCmdFlags_waitMask 0x00000001
Sound buffer flag settings
Used with the "flags" parameter in HsSndBufferData.

  • #define hsSndBufFlags_canInterrupt 0x0001
  • #define hsSndBufFlags_cannotInterrupt 0x0000
  • #define hsSndBufFlags_interruptMask 0x0001
  • #define hsSndBufFlags_yesRepeat 0x0002
  • #define hsSndBufFlags_noRepeat 0x0000
  • #define hsSndBufFlags_repeatMask 0x0002
  • #define hsSndBufFlags_yesEndDelay 0x0004
  • #define hsSndBufFlags_noEndDelay 0x0000
  • #define hsSndBufFlags_endDelayMask 0x0004
  • #define hsSndBufFlags_attackEnvNone 0x0000
  • #define hsSndBufFlags_attackEnvRings 0x0010
  • #define hsSndBufFlags_attackEnvVibeNone 0x0020
  • #define hsSndBufFlags_attackEnvVibeRings 0x0030
  • #define hsSndBufFlags_attackEnvRings2 0x0040
  • #define hsSndBufFlags_attackEnvReserved1 0x0050
  • #define hsSndBufFlags_attackEnvVibeRings2 0x0060
  • #define hsSndBufFlags_attackEnvReserved2 0x0070
  • #define hsSndBufFlags_attackEnvMask 0x00F0
  • #define hsSndBufFlags_interruptDefault 0x0000
  • #define hsSndBufFlags_interruptPhone 0x0100
  • #define hsSndBufFlags_interruptModeMask 0x0300
Buffer amplitude settings
Used with HsSndBufferData.amplitude field.

  • #define hsSndAmplitude_silent ((UInt32) 0)
  • #define hsSndAmplitude_unity ((UInt32) 1024)
Buffer control macros
Use these macros to set or get the proper control in HsSndBufferData.controls field.

  • #define HsSndBufControl_SetRepeat(controls, value) (controls = ((controls & 0xFFFFFF00) | (((UInt32) value) & 0xFF) ))
  • #define HsSndBufControl_GetRepeat(controls) (controls & 0x000000FF)
  • #define HsSndBufControl_SetEndDelay(controls, value) (controls = ((controls & 0xFFFF00FF) | ((((UInt32) value) & 0xFF) << 8)))
  • #define HsSndBufControl_GetEndDelay(controls) ((controls & 0x0000FF00) >> 8)
  • #define hsSndBufControl_repeatForever (0xFF)

Typedefs

  • typedef unsigned long long PmSndU64
  • typedef UInt8 hsSndSysBeepType
  • typedef Int16 HsSndMode
  • typedef UInt16 HsSndCmdType
  • typedef UInt32 HsSndPortID
  • typedef UInt32 HsSndSwitchID
  • typedef UInt16 HsSndParam
  • typedef UInt16 HsSndPortClass
  • typedef UInt16 HsSndFormatType
  • typedef struct HsSndPortInfo * HsSndPortInfoPtr
  • typedef Err(*) HsSndBufferProc (void *userdata, UInt32 flags, void *buffer, UInt32 bytesUsed, UInt32 time)
    Callback function used under various conditions with sound.

Enumerations

  • enum hsSndSysBeepTag {
    hsSndCardInsert = 64,
    hsSndCardRemove,
    hsSndSyncStart,
    hsSndSyncStop,
    hsSndChargerAttach,
    hsSndChargerDetach,
    hsSndRadioOn,
    hsSndRadioOff,
    hsSndBatFull,
    hsSndBatLow,
    hsSndBatShutdown,
    hsSndDeepWake,
    hsSndDeepSleep,
    hsSndRadioInServiceArea,
    hsSndRadioOutServiceArea
    }
  • enum HsSndCmdEnumTag {
    hsSndCmdPlay = 1,
    hsSndCmdStop
    }
  • enum HsSndFormatEnumTag {
    hsSndFormatMidi = 2,
    hsSndFormatAmr,
    pmSndFormatSetAttackEnvID,
    pmSndFormatPauseStream,
    pmSndFormatResumeStream,
    pmSndFormatSetStoppable
    }

Define Documentation

#define HS_AC97 ( n ) ((n) | hsSndBayID_AC97)

Associates the AC97 Bay ID with other element IDs

Definition at line 219 of file HsSoundLibCommon.h.

#define HS_RDIO ( n ) ((n) | hsSndBayID_Radio)

Associates the Radio Bay ID (hsSndBayID_Radio) with other element IDs

Definition at line 220 of file HsSoundLibCommon.h.

#define HS_SND_ERR ( x ) ((Err)((x) + hsSndErrBase))

Definition at line 103 of file HsSoundLibCommon.h.

#define hsSndAmplitude_silent ((UInt32) 0)

Minimum volume value used to silent a port

Definition at line 521 of file HsSoundLibCommon.h.

#define hsSndAmplitude_unity ((UInt32) 1024)

Volume value used to pass through sound without amplification or attenuation.

Definition at line 522 of file HsSoundLibCommon.h.

#define hsSndBayID_AC97 0x01000000

An AC97 compatible chip is supported as the analog sound patch bay.

Definition at line 212 of file HsSoundLibCommon.h.

#define hsSndBayID_Radio 0x02000000

A defined patch bay for Telephony use.

Definition at line 276 of file HsSoundLibCommon.h.

#define hsSndBoost_Disable 0

Disables boost on a port.

Definition at line 350 of file HsSoundLibCommon.h.

#define hsSndBoost_Enable 1

Activates boost on a port.

Definition at line 349 of file HsSoundLibCommon.h.

#define HsSndBufControl_GetEndDelay ( controls ) ((controls & 0x0000FF00) >> 8)

Definition at line 625 of file HsSoundLibCommon.h.

#define HsSndBufControl_GetRepeat ( controls ) (controls & 0x000000FF)

Definition at line 623 of file HsSoundLibCommon.h.

#define hsSndBufControl_repeatForever (0xFF)

Definition at line 626 of file HsSoundLibCommon.h.

#define HsSndBufControl_SetEndDelay | ( | controls,
 |  | value | ) | (controls = ((controls & 0xFFFF00FF) | ((((UInt32) value) & 0xFF) << 8)))

Definition at line 624 of file HsSoundLibCommon.h.

#define HsSndBufControl_SetRepeat | ( | controls,
 |  | value | ) | (controls = ((controls & 0xFFFFFF00) | (((UInt32) value) & 0xFF) ))

Definition at line 622 of file HsSoundLibCommon.h.

#define hsSndBufferData_Signature 'SBDA'

Definition at line 610 of file HsSoundLibCommon.h.

#define hsSndBufFlags_attackEnvMask 0x00F0

Mask reserves up to 16 different envelope IDs.

Definition at line 508 of file HsSoundLibCommon.h.

#define hsSndBufFlags_attackEnvNone 0x0000

(Default) No attack envelope to be used.

Definition at line 500 of file HsSoundLibCommon.h.

#define hsSndBufFlags_attackEnvReserved1 0x0050

Reserved for future use. Do Not use

Definition at line 505 of file HsSoundLibCommon.h.

#define hsSndBufFlags_attackEnvReserved2 0x0070

Reserved for future use. Do Not use

Definition at line 507 of file HsSoundLibCommon.h.

#define hsSndBufFlags_attackEnvRings 0x0010

Use special attack envelope style suitable for call ringtones.

Definition at line 501 of file HsSoundLibCommon.h.

#define hsSndBufFlags_attackEnvRings2 0x0040

Use type 2 attack envelope suitable for call ringtones (stright ramp up)

Definition at line 504 of file HsSoundLibCommon.h.

#define hsSndBufFlags_attackEnvVibeNone 0x0020

Use special attack envelope with initial vibration before envelope

Definition at line 502 of file HsSoundLibCommon.h.

#define hsSndBufFlags_attackEnvVibeRings 0x0030

Use special attack envelope for ringtones with initial vibration before envelope

Definition at line 503 of file HsSoundLibCommon.h.

#define hsSndBufFlags_attackEnvVibeRings2 0x0060

Use type 2 attack enveloper with initial vibration before envelope

Definition at line 506 of file HsSoundLibCommon.h.

#define hsSndBufFlags_canInterrupt 0x0001

Playback can be interrupted by user events.

Definition at line 488 of file HsSoundLibCommon.h.

#define hsSndBufFlags_cannotInterrupt 0x0000

(Default) Playback cannot be interrupted by user events.

Definition at line 489 of file HsSoundLibCommon.h.

#define hsSndBufFlags_endDelayMask 0x0004

No definition.

Definition at line 498 of file HsSoundLibCommon.h.

#define hsSndBufFlags_interruptDefault 0x0000

(Default) interrupt sound on most user events if hsSndBufFlags_canInterrupt flag is set.

Definition at line 510 of file HsSoundLibCommon.h.

#define hsSndBufFlags_interruptMask 0x0001

No definition.

Definition at line 490 of file HsSoundLibCommon.h.

#define hsSndBufFlags_interruptModeMask 0x0300

Mask reserves 2 bits for up to 4 different interrupt modes.

Definition at line 512 of file HsSoundLibCommon.h.

#define hsSndBufFlags_interruptPhone 0x0100

interrupt on user events (except Touch, Navigation arrows and pens down).

Definition at line 511 of file HsSoundLibCommon.h.

#define hsSndBufFlags_noEndDelay 0x0000

(Default) No delay after last batch of audio data processed.

Definition at line 497 of file HsSoundLibCommon.h.

#define hsSndBufFlags_noRepeat 0x0000

(Default) Buffer used only once.

Definition at line 493 of file HsSoundLibCommon.h.

#define hsSndBufFlags_repeatMask 0x0002

No definition.

Definition at line 494 of file HsSoundLibCommon.h.

#define hsSndBufFlags_yesEndDelay 0x0004

Delay completion of playback using the "delay" count in HsSndBufferData.controls.

Definition at line 496 of file HsSoundLibCommon.h.

#define hsSndBufFlags_yesRepeat 0x0002

Repeat the buffer using the "repeat" count in HsSndBufferData.controls.

Definition at line 492 of file HsSoundLibCommon.h.

#define hsSndCmdFlags_noWait 0x00000001

Use wait period for the play command.

Definition at line 462 of file HsSoundLibCommon.h.

#define hsSndCmdFlags_waitMask 0x00000001

No definition.

Definition at line 464 of file HsSoundLibCommon.h.

#define hsSndCmdFlags_yesWait 0x00000000

No wait period for the play command.

Definition at line 463 of file HsSoundLibCommon.h.

#define hsSndErr_DoMidiProgressMsg (HS_SND_ERR(16))

Special message returned by Midi progress callback to request a dynamic volume change.

Definition at line 119 of file HsSoundLibCommon.h.

#define hsSndErr_Failed (HS_SND_ERR(1))

The operation or request failed.

Definition at line 104 of file HsSoundLibCommon.h.

#define hsSndErr_InvalidPort (HS_SND_ERR(3))

An invalid port was passed to a function. Operation failed.

Definition at line 106 of file HsSoundLibCommon.h.

#define hsSndErr_InvalidPrefValue (HS_SND_ERR(18))

Unsupported or invalid audio preference value

Definition at line 121 of file HsSoundLibCommon.h.

#define hsSndErr_InvalidSwitch (HS_SND_ERR(8))

An invalid switch was passed to a function. Operation failed.

Definition at line 111 of file HsSoundLibCommon.h.

#define hsSndErr_LastPublicError (HS_SND_ERR(63))

just a marker for last public library error code, private sound error codes start at 64

Definition at line 122 of file HsSoundLibCommon.h.

#define hsSndErr_NotSupported (HS_SND_ERR(2))

Attempt to use functionality that is not supported in this version.

Definition at line 105 of file HsSoundLibCommon.h.

#define hsSndErr_PortBoostLocked (HS_SND_ERR(14))

Unable to change boost state when hsSndParamMode_Normal is the default.

Definition at line 117 of file HsSoundLibCommon.h.

#define hsSndErr_PortCannotBoost (HS_SND_ERR(6))

Unable to change boost state on a port that does not have boost capabilities.

Definition at line 109 of file HsSoundLibCommon.h.

#define hsSndErr_PortCannotMute (HS_SND_ERR(4))

Unable to change mute state on a port that does not have mute capabilities.

Definition at line 107 of file HsSoundLibCommon.h.

#define hsSndErr_PortCannotPan (HS_SND_ERR(7))

Unable to change pan settings on a port that does not have panning capabilities.

Definition at line 110 of file HsSoundLibCommon.h.

#define hsSndErr_PortCannotVolume (HS_SND_ERR(5))

Unable to change volume gains on a port that does not have volume capabilities.

Definition at line 108 of file HsSoundLibCommon.h.

#define hsSndErr_PortIDNotInClass (HS_SND_ERR(11))

The portID/portClass combination is not supported.

Definition at line 114 of file HsSoundLibCommon.h.

#define hsSndErr_PortMuteLocked (HS_SND_ERR(12))

Unable to change mute state when hsSndParamMode_Normal is the default.

Definition at line 115 of file HsSoundLibCommon.h.

#define hsSndErr_PortPanLocked (HS_SND_ERR(15))

Unable to change pan value when hsSndParamMode_Normal is the default.

Definition at line 118 of file HsSoundLibCommon.h.

#define hsSndErr_PortVolumeLocked (HS_SND_ERR(13))

Unable to change volume parameter when hsSndParamMode_Normal is the default.

Definition at line 116 of file HsSoundLibCommon.h.

#define hsSndErr_UnknownClkRef (HS_SND_ERR(17))

Unknown clock reference passed to synchronization clock utility

Definition at line 120 of file HsSoundLibCommon.h.

#define hsSndErr_UnknownPortClass (HS_SND_ERR(10))

An unknown HsSndPortClass value was passed to a function call.

Definition at line 113 of file HsSoundLibCommon.h.

#define hsSndErr_UnknownSndParam (HS_SND_ERR(9))

An unknown HsSndParam selector was passed to a function call.

Definition at line 112 of file HsSoundLibCommon.h.

#define hsSndErrBase hsSoundLibErrorClass

Definition at line 102 of file HsSoundLibCommon.h.

#define hsSndLibVersion 0x010D0000

Version of the sound library.

Definition at line 59 of file HsSoundLibCommon.h.

#define hsSndMidiMsg_SetVolume 1

Definition at line 585 of file HsSoundLibCommon.h.

#define hsSndMidiProgressMsg_Signature 'MidP'

Definition at line 589 of file HsSoundLibCommon.h.

#define hsSndMode_Carkit ((HsSndMode) 0x0007)

Mode when wired carkit is attached and active to the device.

Definition at line 166 of file HsSoundLibCommon.h.

#define hsSndMode_Current ((HsSndMode) 0x0000)

Pass to spefify the currently active sound mode.

Definition at line 159 of file HsSoundLibCommon.h.

#define hsSndMode_Headphones ((HsSndMode) 0x0005)

Mode when any audio goes to stereo headphones.

Definition at line 164 of file HsSoundLibCommon.h.

#define hsSndMode_HeadphonesHost ((HsSndMode) 0x0006)

Mode when radio is off and headphones used exclusively by system and third party audio.

Definition at line 165 of file HsSoundLibCommon.h.

#define hsSndMode_Headset ((HsSndMode) 0x0004)

Mode when any audio goes to a mono headphones.

Definition at line 163 of file HsSoundLibCommon.h.

#define hsSndMode_Receiver ((HsSndMode) 0x0001)

Mode when Radio audio goes to receiver speaker.

Definition at line 160 of file HsSoundLibCommon.h.

#define hsSndMode_Reserved ((HsSndMode) 0x0008)

Reserved for future definition. Do not use.

Definition at line 167 of file HsSoundLibCommon.h.

#define hsSndMode_SpeakerHost ((HsSndMode) 0x0003)

Mode when radio is off and speaker used exclusively by system and third party audio.

Definition at line 162 of file HsSoundLibCommon.h.

#define hsSndMode_Speakerphone ((HsSndMode) 0x0002)

Mode when Radio audio goes to loud speaker (speaker phone)

Definition at line 161 of file HsSoundLibCommon.h.

#define hsSndMute_Disable 0

Disables mute on a port.

Definition at line 340 of file HsSoundLibCommon.h.

#define hsSndMute_Enable 1

Activates mute on a port.

Definition at line 339 of file HsSoundLibCommon.h.

#define hsSndNotify hsFileSoundLib

HsSoundLib broadcaster's ID

Definition at line 71 of file HsSoundLibCommon.h.

#define hsSndNotifyAlert 'hAlr'

An alert sound is about to start playing.

Definition at line 83 of file HsSoundLibCommon.h.

#define hsSndNotifyAnswerButton 'hAns'

While a headset or hybrid was connected, the answer-button event was detected.

Definition at line 77 of file HsSoundLibCommon.h.

#define hsSndNotifyAnswerHold 'hHol'

After hsSndNotifyAnswerButton notification, this event is sent if answer-button is still held down for some time.

Definition at line 78 of file HsSoundLibCommon.h.

#define hsSndNotifyAnswerRelease 'hRel'

After hsSndNotifyAnswerButton notification, this event is sent when answer-button released.

Definition at line 79 of file HsSoundLibCommon.h.

#define hsSndNotifyAthenaAudio 'hAta'

Automatic audio switches will route to Athena connector from now on (Treo-650 and later).

Definition at line 86 of file HsSoundLibCommon.h.

#define hsSndNotifyCarkitActive 'hCar'

Wired carkit has been activated, audio goes to carkit path.

Definition at line 84 of file HsSoundLibCommon.h.

#define hsSndNotifyCarkitInactive 'hCOf'

Wired carkit is no longer active, audio routes normally.

Definition at line 85 of file HsSoundLibCommon.h.

#define hsSndNotifyHeadphones 'hPho'

Headset jack connected and configured for stereo headphones.

Definition at line 74 of file HsSoundLibCommon.h.

#define hsSndNotifyHeadset 'hSet'

Headset jack connected and configured for mono headset with microphone.

Definition at line 73 of file HsSoundLibCommon.h.

#define hsSndNotifyHighPriority 'hHPr'

A high priority sound is about to start playing.

Definition at line 82 of file HsSoundLibCommon.h.

#define hsSndNotifyHybrid 'hHyb'

A hybrid headset/headphone is currently attached to the headset jack.

Definition at line 75 of file HsSoundLibCommon.h.

#define hsSndNotifyNotHybrid 'hNoH'

Currently attached peripheral on headset jack is Not a hybrid headset (see hsSndNotifyHybrid).

Definition at line 76 of file HsSoundLibCommon.h.

#define hsSndNotifyRingerSwitchOff 'hROf'

Notifies that ringer switch is in the silent (no sounds to back speaker) position.

Definition at line 81 of file HsSoundLibCommon.h.

#define hsSndNotifyRingerSwitchOn 'hROn'

Notifies that ringer switch is in the on (play sounds to back speaker) position.

Definition at line 80 of file HsSoundLibCommon.h.

#define hsSndNotifyUnplugged 'hOff'

No accesory is currently attached to the headset jack.

Definition at line 72 of file HsSoundLibCommon.h.

#define hsSndPan_Left ((Int16) 0x8000)

Pan all the way to the left. Cannot use with hsSndParamMode (defaults to Normal mode).

Definition at line 361 of file HsSoundLibCommon.h.

#define hsSndPan_LeftNormal ((Int16) 0x0800)

Pan all the way to the left. Can use with any hsSndParamMode.

Definition at line 363 of file HsSoundLibCommon.h.

#define hsSndPan_Middle ((Int16) 0x0000)

Pan at midpoint between left and right.

Definition at line 359 of file HsSoundLibCommon.h.

#define hsSndPan_Right ((Int16) 0x7FFF)

Pan all the way to the right. Cannot use with hsSndParamMode (defaults to Normal mode).

Definition at line 360 of file HsSoundLibCommon.h.

#define hsSndPan_RightNormal ((Int16) 0x07FF)

Pan all the way to the right. Can use with any hsSndParamMode.

Definition at line 362 of file HsSoundLibCommon.h.

#define hsSndParam_Boost ((UInt16) 3)

Changes the boost state of a port.

Definition at line 317 of file HsSoundLibCommon.h.

#define hsSndParam_Mute ((UInt16) 2)

Change the mute state of a port.

Definition at line 316 of file HsSoundLibCommon.h.

#define hsSndParam_Pan ((UInt16) 4)

Change the panning value of a port.

Definition at line 318 of file HsSoundLibCommon.h.

#define hsSndParam_Volume ((UInt16) 1)

Changes the volume of a port

Definition at line 315 of file HsSoundLibCommon.h.

#define hsSndParamMode_LockParam 0x4000

Limits parameter so it can only be changed with hsSndParamMode_LockParam or hsSndParamMode_UnlockParam.

Definition at line 329 of file HsSoundLibCommon.h.

#define hsSndParamMode_Mask 0x7000

The 3 upper bits after the sign bit in parameter values are reserved for the parameter mode.

Definition at line 327 of file HsSoundLibCommon.h.

#define hsSndParamMode_Normal 0x0000

Default parameter mode allowing parameter to be changed with any other hsSndParamMode.

Definition at line 328 of file HsSoundLibCommon.h.

#define hsSndParamMode_UnlockParam 0x2000

Removes hsSndParamMode_LockParam so it can be changed with any other hsSndParamMode.

Definition at line 330 of file HsSoundLibCommon.h.

#define HsSndParamValue_RemoveMode ( v ) (((v) & 0x8000)? (v) | hsSndParamMode_Mask : (v) & ~hsSndParamMode_Mask)

Removes LockParam or UnLockParam from parameter value.

Definition at line 223 of file HsSoundLibCommon.h.

#define HsSndParamValue_SetWithLock ( v ) (((v) & ~hsSndParamMode_Mask) | hsSndParamMode_LockParam)

Adds LockParam to parameter value.

Definition at line 221 of file HsSoundLibCommon.h.

#define HsSndParamValue_SetWithUnlock ( v ) (((v) & ~hsSndParamMode_Mask) | hsSndParamMode_UnlockParam)

Adds UnLockParam to parameter value.

Definition at line 222 of file HsSoundLibCommon.h.

#define hsSndPortClass_Anchor ((UInt16) 3)

Use to obtain the fixed port in a switch that doesn't change--the port that is patched to other ports. Valid only with HsSndSwitchGetPort.

Definition at line 306 of file HsSoundLibCommon.h.

#define hsSndPortClass_BaseDefault ((UInt16) 2)

Default port to use when restoring a Built-In port (For example, user unplugged headset while "auto" port was enabled.)

Definition at line 305 of file HsSoundLibCommon.h.

#define hsSndPortClass_Real ((UInt16) 1)

Current physical port. Use to change port parameters. Applies only to actual ports, not "auto" ports.

Definition at line 304 of file HsSoundLibCommon.h.

#define hsSndPortClass_Virtual ((UInt16) 0)

Symbolic port definition that applies to any port. Use for portID save and restore operations.

Definition at line 303 of file HsSoundLibCommon.h.

#define hsSndPortFlags_Boost_Locked 0x00002000

If locked, can only be changed with lock/unlock boost parameter changes/

Definition at line 422 of file HsSoundLibCommon.h.

#define hsSndPortFlags_Boost_LockMask 0x00002000

No definition.

Definition at line 424 of file HsSoundLibCommon.h.

#define hsSndPortFlags_Boost_Unlocked 0x00000000

Boost can be changed with any type of boost parameters.

Definition at line 423 of file HsSoundLibCommon.h.

#define hsSndPortFlags_BoostMask 0x00000008

No definition.

Definition at line 386 of file HsSoundLibCommon.h.

#define hsSndPortFlags_BoostOff 0x00000000

Boost control on port is inactive.

Definition at line 385 of file HsSoundLibCommon.h.

#define hsSndPortFlags_BoostOn 0x00000008

Boost control on port is active.

Definition at line 384 of file HsSoundLibCommon.h.

#define hsSndPortFlags_CanBoost_No 0x00000000

Port has no boost control.

Definition at line 407 of file HsSoundLibCommon.h.

#define hsSndPortFlags_CanBoost_Yes 0x00000200

Port has boost control available.

Definition at line 406 of file HsSoundLibCommon.h.

#define hsSndPortFlags_CanBoostMask 0x00000200

No definition.

Definition at line 408 of file HsSoundLibCommon.h.

#define hsSndPortFlags_CanInputOnly 0x00000000

Port is for sound input exclusively.

Definition at line 388 of file HsSoundLibCommon.h.

#define hsSndPortFlags_CanIOBothways 0x00000030

Port can be for sound input and output simultaneously.

Definition at line 391 of file HsSoundLibCommon.h.

#define hsSndPortFlags_CanIOMask 0x00000030

No definition.

Definition at line 392 of file HsSoundLibCommon.h.

#define hsSndPortFlags_CanIOSelect 0x00000020

Port can switch between being for sound input or output.

Definition at line 390 of file HsSoundLibCommon.h.

#define hsSndPortFlags_CanMute_No 0x00000000

Port has no mute control.

Definition at line 403 of file HsSoundLibCommon.h.

#define hsSndPortFlags_CanMute_Yes 0x00000100

Port has mute control available.

Definition at line 402 of file HsSoundLibCommon.h.

#define hsSndPortFlags_CanMuteMask 0x00000100

No definition.

Definition at line 404 of file HsSoundLibCommon.h.

#define hsSndPortFlags_CanOutputOnly 0x00000010

Port is for sound output exclusively.

Definition at line 389 of file HsSoundLibCommon.h.

#define hsSndPortFlags_CanPan_No 0x00000000

Port has No pan control.

Definition at line 411 of file HsSoundLibCommon.h.

#define hsSndPortFlags_CanPan_Yes 0x00000400

Port has pan control available.

Definition at line 410 of file HsSoundLibCommon.h.

#define hsSndPortFlags_CanPanMask 0x00000400

No definition.

Definition at line 412 of file HsSoundLibCommon.h.

#define hsSndPortFlags_CanVol_No 0x00000000

Port has No volume control.

Definition at line 415 of file HsSoundLibCommon.h.

#define hsSndPortFlags_CanVol_Yes 0x00000800

Port has volume control available.

Definition at line 414 of file HsSoundLibCommon.h.

#define hsSndPortFlags_CanVolMask 0x00000800

No definition.

Definition at line 416 of file HsSoundLibCommon.h.

#define hsSndPortFlags_Disabled 0x00000000

Port is disabled.

Definition at line 373 of file HsSoundLibCommon.h.

#define hsSndPortFlags_Enabled 0x00000001

Port is enabled and in use.

Definition at line 372 of file HsSoundLibCommon.h.

#define hsSndPortFlags_EnableMask 0x00000001

No definition.

Definition at line 374 of file HsSoundLibCommon.h.

#define hsSndPortFlags_InputMask 0x00000040

No definition.

Definition at line 396 of file HsSoundLibCommon.h.

#define hsSndPortFlags_InputOff 0x00000000

Port as sound input is disabled.

Definition at line 395 of file HsSoundLibCommon.h.

#define hsSndPortFlags_InputOn 0x00000040

Port as sound input is enabled.

Definition at line 394 of file HsSoundLibCommon.h.

#define hsSndPortFlags_Mute_Locked 0x00001000

If locked, can only be changed with lock/unlock mute parameter changes.

Definition at line 418 of file HsSoundLibCommon.h.

#define hsSndPortFlags_Mute_LockMask 0x00001000

No definition.

Definition at line 420 of file HsSoundLibCommon.h.

#define hsSndPortFlags_Mute_Unlocked 0x00000000

Mute can be changed with any type of mute parameters.

Definition at line 419 of file HsSoundLibCommon.h.

#define hsSndPortFlags_MuteMask 0x00000002

No definition.

Definition at line 378 of file HsSoundLibCommon.h.

#define hsSndPortFlags_MuteOff 0x00000000

Volume is as specified. (Not muted).

Definition at line 377 of file HsSoundLibCommon.h.

#define hsSndPortFlags_MuteOn 0x00000002

Volume is muted.

Definition at line 376 of file HsSoundLibCommon.h.

#define hsSndPortFlags_OutputMask 0x00000080

No definition.

Definition at line 400 of file HsSoundLibCommon.h.

#define hsSndPortFlags_OutputOff 0x00000000

Port as sound output is disabled.

Definition at line 399 of file HsSoundLibCommon.h.

#define hsSndPortFlags_OutputOn 0x00000080

Port as sound output is enabled.

Definition at line 398 of file HsSoundLibCommon.h.

#define hsSndPortFlags_Pan_Locked 0x00004000

If locked, can only be changed with lock/unlock pan parameter changes.

Definition at line 426 of file HsSoundLibCommon.h.

#define hsSndPortFlags_Pan_LockMask 0x00004000

No definition.

Definition at line 428 of file HsSoundLibCommon.h.

#define hsSndPortFlags_Pan_Unlocked 0x00000000

Pan can be changed with any type of pan parameters.

Definition at line 427 of file HsSoundLibCommon.h.

#define hsSndPortFlags_TypeAnalog 0x00000000

Sound data through port is analog.

Definition at line 381 of file HsSoundLibCommon.h.

#define hsSndPortFlags_TypeDigital 0x00000004

Sound data through port is digital.

Definition at line 380 of file HsSoundLibCommon.h.

#define hsSndPortFlags_TypeMask 0x00000004

No definition.

Definition at line 382 of file HsSoundLibCommon.h.

#define hsSndPortFlags_Vol_Locked 0x00008000

If locked, can only be changed with lock/unlock volume parameter changes.

Definition at line 430 of file HsSoundLibCommon.h.

#define hsSndPortFlags_Vol_LockMask 0x00008000

No definition.

Definition at line 432 of file HsSoundLibCommon.h.

#define hsSndPortFlags_Vol_Unlocked 0x00000000

Volume can be changed with any type of volume parameters.

Definition at line 431 of file HsSoundLibCommon.h.

#define hsSndPortID_ConnectCall HS_RDIO(0x00000020)

Virtual port to indicate a radio call is now connected.

Definition at line 294 of file HsSoundLibCommon.h.

#define hsSndPortID_Current HS_AC97(0x00000000)

Special meta port ID used to specify currently active user port.

Definition at line 246 of file HsSoundLibCommon.h.

#define hsSndPortID_InBaseMic HS_AC97(0x00000007)

Microphone at the base of the smartphone body.

Definition at line 253 of file HsSoundLibCommon.h.

#define hsSndPortID_InBtHandsfree HS_AC97(0x00000016)

Input port used by OutRadioMic switch to get uplink audio from BT handsfree mode.

Definition at line 268 of file HsSoundLibCommon.h.

#define hsSndPortID_InBtHeadset HS_AC97(0x00000015)

Input port used by OutRadioMic switch to get uplink audio from BT headset.

Definition at line 267 of file HsSoundLibCommon.h.

#define hsSndPortID_InCarkit HS_AC97(0x00000013)

Input port used when wired carkit is activated.

Definition at line 265 of file HsSoundLibCommon.h.

#define hsSndPortID_InHeadsetMic HS_AC97(0x00000008)

Microphone on a mono headset. Ccomes from left channel as input.

Definition at line 254 of file HsSoundLibCommon.h.

#define hsSndPortID_InHostBaseMic HS_AC97(0x00000010)

Input port that controls source base port for host recording.

Definition at line 262 of file HsSoundLibCommon.h.

#define hsSndPortID_InHostHeadsetMic HS_AC97(0x00000011)

Input port controlling source headset port for host recording.

Definition at line 263 of file HsSoundLibCommon.h.

#define hsSndPortID_InHostPhone HS_AC97(0x00000012)

Input port used by host if phone or TTY is active.

Definition at line 264 of file HsSoundLibCommon.h.

#define hsSndPortID_InHostPlay HS_AC97(0x0000000D)

Input from the Host converted to analog for output to speakers.

Definition at line 259 of file HsSoundLibCommon.h.

#define hsSndPortID_InLineRec HS_AC97(0x00000006)

Configures headset jack as input, precluding headset use (special port for test purposes).

Definition at line 252 of file HsSoundLibCommon.h.

#define hsSndPortID_InMicAuto HS_AC97(0x00000009)

Atomatic port, according to headset insertion. Use with hsSndSwitchID_OutRadioMic.

Definition at line 255 of file HsSoundLibCommon.h.

#define hsSndPortID_InRadioSpkr HS_AC97(0x0000000B)

Input from the Radio speaker output.

Definition at line 257 of file HsSoundLibCommon.h.

#define hsSndPortID_LastPort HS_AC97(0x00000016)

Update at end. Same ID as last defined port in sequence.

Definition at line 269 of file HsSoundLibCommon.h.

#define hsSndPortID_Off 0x00000000

Special meta port ID used to turn off a sound switch.

Definition at line 245 of file HsSoundLibCommon.h.

#define hsSndPortID_OutBtHandsfree HS_AC97(0x0000000F)

Output port used by InRadioSpkr switch to put Call in bluetooth handsfree mode.

Definition at line 261 of file HsSoundLibCommon.h.

#define hsSndPortID_OutBtHeadset HS_AC97(0x0000000E)

Output port used by InRadioSpkr switch to put Call in bluetooth headset mode.

Definition at line 260 of file HsSoundLibCommon.h.

#define hsSndPortID_OutCarkit HS_AC97(0x00000014)

Output port used when wired carkit is activated.

Definition at line 266 of file HsSoundLibCommon.h.

#define hsSndPortID_OutHeadphones HS_AC97(0x00000004)

Configures the headset port for full left and right stereo output, no inputs.

Definition at line 250 of file HsSoundLibCommon.h.

#define hsSndPortID_OutHeadset HS_AC97(0x00000003)

Audio output to mono headset (right channel output). Left can be used as input.

Definition at line 249 of file HsSoundLibCommon.h.

#define hsSndPortID_OutHostRec HS_AC97(0x0000000C)

Output to the Host digitized recording input.

Definition at line 258 of file HsSoundLibCommon.h.

#define hsSndPortID_OutRadioMic HS_AC97(0x0000000A)

Output connected to the Radio microphone input.

Definition at line 256 of file HsSoundLibCommon.h.

#define hsSndPortID_OutReceiver HS_AC97(0x00000001)

Receiver speaker.

Definition at line 247 of file HsSoundLibCommon.h.

#define hsSndPortID_OutSpeaker HS_AC97(0x00000002)

Back speaker for system audio and speakerphone functions,

Definition at line 248 of file HsSoundLibCommon.h.

#define hsSndPortID_OutSpeakerAuto HS_AC97(0x00000005)

Automatic port, according to headset insertion. Use with hsSndSwitchID_InRadioSpkr.

Definition at line 251 of file HsSoundLibCommon.h.

#define hsSndPortInfo_Signature 'SPRT'

Definition at line 604 of file HsSoundLibCommon.h.

#define hsSndRsrcAudioTableID 25000

Default audio table ID which can be loaded automatically during reset.

Definition at line 95 of file HsSoundLibCommon.h.

#define hsSndRsrcAudioTableType 'hTbl'

Resource contains audio table that can be loaded to audio driver.

Definition at line 94 of file HsSoundLibCommon.h.

#define hsSndSwitchID_InHostPlay HS_AC97(0x00040000)

Controls which speaker to direct PalmOS audio to.

Definition at line 235 of file HsSoundLibCommon.h.

#define hsSndSwitchID_InMic HS_AC97(0x00030000)

Test control for Mfg to directly connect Mic input into any destination speaker.

Definition at line 234 of file HsSoundLibCommon.h.

#define hsSndSwitchID_InRadioSpkr HS_AC97(0x00010000)

Controls the destination port for data coming from the Radio.

Definition at line 232 of file HsSoundLibCommon.h.

#define hsSndSwitchID_OutHostRec HS_AC97(0x00050000)

Controls from which port to digitize and send to PalmOS for recording.

Definition at line 236 of file HsSoundLibCommon.h.

#define hsSndSwitchID_OutRadioMic HS_AC97(0x00020000)

Controls the source microphone to connect to the Radio.

Definition at line 233 of file HsSoundLibCommon.h.

#define hsSndSwitchID_RadioCall HS_RDIO(0x00010000)

Keeps track of the audio connection of a Radio call.

Definition at line 285 of file HsSoundLibCommon.h.

#define hsSndToneType_Square 0

Used when calling HsSndTonePlay.

Definition at line 178 of file HsSoundLibCommon.h.

#define hsSoundLibCreatorID hsFileSoundLib

Creator ID of the sound library.

Definition at line 60 of file HsSoundLibCommon.h.

#define hsSoundLibName "HsSoundLib"

Name of the sound library.

Definition at line 62 of file HsSoundLibCommon.h.

#define hsSoundLibTypeID sysFileTLibrary

Type of the sound library.

Definition at line 61 of file HsSoundLibCommon.h.

#define PM_AUDP ( n ) ((n) | pmSndBayID_AUDP)

utility to associate the Preference Bay ID with other element ID

Definition at line 681 of file HsSoundLibCommon.h.

#define PM_AUDP_CLASS ( n ) ((n) | PM_AUDP_CLASS_MASK)

utility to associate preferences class marker to prefIDs

Definition at line 652 of file HsSoundLibCommon.h.

#define PM_AUDP_CLASS_MASK 0x4000

The ringtone attack envelope ramp-up to low volume initially, and to full volume after about 4 seconds

Definition at line 650 of file HsSoundLibCommon.h.

#define pmAudioClkTickRef ((PmClkTickRef) 0x00000001)

use as PmClkTickRef when requiring audio tick clock

Definition at line 692 of file HsSoundLibCommon.h.

#define pmSndAttackEnvIDRings (hsSndBufFlags_attackEnvRings)

The ringtone attack envelope ramp-up to low volume initially, and to full volume after about 4 seconds

Definition at line 639 of file HsSoundLibCommon.h.

#define pmSndAttackEnvIDRings2 (hsSndBufFlags_attackEnvRings2)

The ringtone attack envelope ramp-up in about 1 second

Definition at line 641 of file HsSoundLibCommon.h.

#define pmSndAttackEnvIDVibeRing (hsSndBufFlags_attackEnvVibeRings)

Vibrate for 4 seconds, then behave as pmSndAttackEnvIDRings

Definition at line 640 of file HsSoundLibCommon.h.

#define pmSndAttackEnvIDVibeRing2 (hsSndBufFlags_attackEnvVibeRings2)

Vibrate for 4 seconds, then behave as pmSndAttackEnvIDRings2

Definition at line 642 of file HsSoundLibCommon.h.

#define pmSndBayID_AUDP 0x0F000000

we are reserving SndBayID 15 for audio preference purposes

Definition at line 648 of file HsSoundLibCommon.h.

#define pmSndPref_AthenaActive_No (0)

disable routing to Athena path for automatic switches

Definition at line 672 of file HsSoundLibCommon.h.

#define pmSndPref_AthenaActive_Yes (1)

enable routing to Athena path for automatic switches

Definition at line 673 of file HsSoundLibCommon.h.

#define pmSndPref_AthenaAudio_IfMicPresent (16)

when Athena audio class detected, only route if Mic is also present

Definition at line 677 of file HsSoundLibCommon.h.

#define pmSndPref_AthenaAudio_NoRouting (0)

no athena audio routing when Athena audio connection detected. Handled elsewhere or through pmSndPrefID_AthenaActive

Definition at line 676 of file HsSoundLibCommon.h.

#define pmSndPref_AthenaAudio_Unconditional (32)

cause unconditional audio routing if Athena audio class detected

Definition at line 678 of file HsSoundLibCommon.h.

#define pmSndPref_WakeOnAnswerBtn_Disable (0)

disable wake up on answer button feature

Definition at line 668 of file HsSoundLibCommon.h.

#define pmSndPref_WakeOnAnswerBtn_Enable (1)

enable wake up on answer button feature

Definition at line 669 of file HsSoundLibCommon.h.

#define pmSndPrefID_AGCEvent PM_AUDP_CLASS(0x0009)

set to temporarily activate AGC if required (only useful when AGC has been disabled before hand)

Definition at line 662 of file HsSoundLibCommon.h.

#define pmSndPrefID_AppsGroupHoldType PM_AUDP_CLASS(0x0001)

specify how to hold application audio (mute/pause)

Definition at line 654 of file HsSoundLibCommon.h.

#define pmSndPrefID_AthenaActive PM_AUDP_CLASS(0x0007)

set to activate audio paths to multi-connector, clear to return to normal (used for wired carkit mode)

Definition at line 660 of file HsSoundLibCommon.h.

#define pmSndPrefID_AthenaAudio PM_AUDP_CLASS(0x000A)

set to activate or deactivate automatic routing of audio to Athena connector

Definition at line 663 of file HsSoundLibCommon.h.

#define pmSndPrefID_AudioTable PM_AUDP_CLASS(0x0005)

pass pointer to PmSndGain8Table to load for use, pass zero to return to default

Definition at line 658 of file HsSoundLibCommon.h.

#define pmSndPrefID_GsmMccArray PM_AUDP_CLASS(0x0006)

pass pointer to PmSndGsmMccArray to load for use, pass zero to return to default

Definition at line 659 of file HsSoundLibCommon.h.

#define pmSndPrefID_JackOutIfMicUnused PM_AUDP_CLASS(0x0002)

shall we force jack out to stereo if Mic not in use?

Definition at line 655 of file HsSoundLibCommon.h.

#define pmSndPrefID_PhoneRxGainLimit PM_AUDP_CLASS(0x0003)

set if gain-limit phone Rx to receiver speaker

Definition at line 656 of file HsSoundLibCommon.h.

#define pmSndPrefID_SleepMode PM_AUDP_CLASS(0x0008)

set to zero for normal sleep, other values for partial audio sleep modes (for internal use only)

Definition at line 661 of file HsSoundLibCommon.h.

#define pmSndPrefID_WakeOnAnswerBtn PM_AUDP_CLASS(0x0004)

set to be able to wake device when headset answer button is pressed

Definition at line 657 of file HsSoundLibCommon.h.

#define pmSndSwitchID_Preferences PM_AUDP(0x00400000)

used with the HsSoundLib Switch calls to set and get sound preference data

Definition at line 684 of file HsSoundLibCommon.h.

Typedef Documentation

typedef Err(*) HsSndBufferProc(void *userdata, UInt32 flags, void *buffer, UInt32 bytesUsed, UInt32 time)

Callback function used under various conditions with sound.

Parameters:
userdata | IN Userdata passed when setting the callback routine
flags | IN Copy of the HsSndBufferData flags field
buffer | IN Pointer originally passed in HsSndBufferData
bytesUsed | OUT How many bytes have been consumed from the buffer
time | OUT Number of milliseconds available for callback processing
Returns:
Error code.

Definition at line 539 of file HsSoundLibCommon.h.

typedef UInt16 HsSndCmdType

Holds sound command type

Definition at line 195 of file HsSoundLibCommon.h.

typedef UInt16 HsSndFormatType

Holds sound format type

Definition at line 210 of file HsSoundLibCommon.h.

typedef Int16 HsSndMode

Holds audio mode type

Definition at line 171 of file HsSoundLibCommon.h.

typedef UInt16 HsSndParam

Used as a parameter to HsSndPortSetParam function.

Definition at line 204 of file HsSoundLibCommon.h.

typedef UInt16 HsSndPortClass

Used as a parameter to HsSndSwitchGetParam function.

Definition at line 207 of file HsSoundLibCommon.h.

typedef UInt32 HsSndPortID

Holds sound port ID information.

Definition at line 198 of file HsSoundLibCommon.h.

typedef struct HsSndPortInfo * HsSndPortInfoPtr

typedef UInt32 HsSndSwitchID

Holds sound switch ID information.

Definition at line 201 of file HsSoundLibCommon.h.

typedef UInt8 hsSndSysBeepType

Holds beep tone type.

See also:
hsSndSysBeepTag

Definition at line 151 of file HsSoundLibCommon.h.

typedef UInt32 PmClkTickRef

The ringtone attack envelope ramp-up to low volume initially, and to full volume after about 4 seconds

Definition at line 690 of file HsSoundLibCommon.h.

typedef UInt16 PmSndPrefID

The ringtone attack envelope ramp-up to low volume initially, and to full volume after about 4 seconds

Definition at line 665 of file HsSoundLibCommon.h.

typedef unsigned long long PmSndU64

Definition at line 47 of file HsSoundLibCommon.h.

Enumeration Type Documentation

enum HsSndCmdEnumTag

Sound command values

The HsSndCmdType is used as the first parameter to the function HsSndFormatPlay. Use these command values.

Enumerator:
hsSndCmdPlay | Use to initiate a playback session.
hsSndCmdStop | Use to terminate the current playback session.

Definition at line 187 of file HsSoundLibCommon.h.

00188 {
00189     hsSndCmdPlay = 1,   /**<Use to initiate a playback session. */
00190     hsSndCmdStop        /**<Use to terminate the current playback session. */
00191
00192 };

enum HsSndFormatEnumTag

Sound formats

Enumerator:
hsSndFormatMidi | Midi format.
hsSndFormatAmr | Obsolete. Use Codec Plug-in Manager or streaming component.
pmSndFormatSetAttackEnvID | For internal use only (escape code used by PmSndStreamSetAttackEnvID macro function).
pmSndFormatPauseStream | For internal use only (escape code used by PmSndStreamPause macro function).
pmSndFormatResumeStream | For internal use only (escape code used by PmSndStreamResume macro function).
pmSndFormatSetStoppable | For internal use only (escape code used by PmSndStreamStoppable macro function).

Definition at line 471 of file HsSoundLibCommon.h.

00472 {
00473     hsSndFormatMidi = 2, /**<Midi format. */
00474     hsSndFormatAmr, /**<Obsolete.  Use Codec Plug-in Manager or streaming component. */
00475     pmSndFormatSetAttackEnvID, /**<For internal use only (escape code used by PmSndStreamSetAttackEnvID macro function). */
00476     pmSndFormatPauseStream, /**<For internal use only (escape code used by PmSndStreamPause macro function). */
00477     pmSndFormatResumeStream, /**<For internal use only (escape code used by PmSndStreamResume macro function). */
00478     pmSndFormatSetStoppable /**<For internal use only (escape code used by PmSndStreamStoppable macro function). */
00479 };

enum hsSndSysBeepTag

Beeps

Provides additional system sounds for PalmOS SndPlaySystemSound.

Enumerator:
hsSndCardInsert | No definition.
hsSndCardRemove | No definition.
hsSndSyncStart | No definition.
hsSndSyncStop | No definition.
hsSndChargerAttach | No definition.
hsSndChargerDetach | No definition.
hsSndRadioOn | No definition.
hsSndRadioOff | No definition.
hsSndBatFull | No definition.
hsSndBatLow | No definition.
hsSndBatShutdown | No definition.
hsSndDeepWake | No definition.
hsSndDeepSleep | No definition.
hsSndRadioInServiceArea | No definition.
hsSndRadioOutServiceArea | No definition.

Definition at line 130 of file HsSoundLibCommon.h.

00131 {
00132     hsSndCardInsert = 64, /**<No definition. */
00133     hsSndCardRemove, /**<No definition. */
00134     hsSndSyncStart, /**<No definition. */
00135     hsSndSyncStop, /**<No definition. */
00136     hsSndChargerAttach, /**<No definition. */
00137     hsSndChargerDetach, /**<No definition. */
00138     hsSndRadioOn, /**<No definition. */
00139     hsSndRadioOff, /**<No definition. */
00140     hsSndBatFull, /**<No definition. */
00141     hsSndBatLow, /**<No definition. */
00142     hsSndBatShutdown, /**<No definition. */
00143     hsSndDeepWake, /**<No definition. */
00144     hsSndDeepSleep, /**<No definition. */
00145     hsSndRadioInServiceArea, /**<No definition. */
00146     hsSndRadioOutServiceArea /**<No definition. */
00147
00148 };

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:07:33 2008 for Palm API Guide


Header Files » Incs » common » libraries » hssoundlib

HsSoundLibTraps.h File Reference

Include dependency graph for HsSoundLibTraps.h:

Go to the source code of this file.

Defines

Function Traps
  • #define kHsSoundLibTrapOpen (sysLibTrapOpen)
  • #define kHsSoundLibTrapClose (sysLibTrapClose)
  • #define kHsSoundLibTrapGetVersion (sysLibTrapCustom + 0)
  • #define kHsSoundLibTrapPortGetInfo (sysLibTrapCustom + 1)
  • #define kHsSoundLibTrapPortSetParam (sysLibTrapCustom + 2)
  • #define kHsSoundLibTrapSwitchGetPort (sysLibTrapCustom + 3)
  • #define kHsSoundLibTrapSwitchSetPort (sysLibTrapCustom + 4)
  • #define kHsSoundLibTrapTonePlay (sysLibTrapCustom + 5)
  • #define kHsSoundLibTrapToneStop (sysLibTrapCustom + 6)
  • #define kHsSoundLibTrapFormatPlay (sysLibTrapCustom + 7)
  • #define kHsSoundLibTrapFormatRecord (sysLibTrapCustom + 8)
  • #define kHsSoundLibTrapGetUserVolume (sysLibTrapCustom + 9)
  • #define kHsSoundLibTrapSetUserVolume (sysLibTrapCustom + 10)
  • #define kPmSoundLibTrapClkGetTicksPerSecond (sysLibTrapCustom + 11)
  • #define kPmSoundLibTrapClkGetTickCount (sysLibTrapCustom + 12)
  • #define kPmSoundLibTrapGetPosition (sysLibTrapCustom + 13)
  • #define kPmSoundLibTrapReserved (sysLibTrapCustom + 14)

Define Documentation

#define kHsSoundLibTrapClose (sysLibTrapClose)

No definition.

Definition at line 34 of file HsSoundLibTraps.h.

#define kHsSoundLibTrapFormatPlay (sysLibTrapCustom + 7)

No definition.

Definition at line 43 of file HsSoundLibTraps.h.

#define kHsSoundLibTrapFormatRecord (sysLibTrapCustom + 8)

No definition.

Definition at line 44 of file HsSoundLibTraps.h.

#define kHsSoundLibTrapGetUserVolume (sysLibTrapCustom + 9)

No definition.

Definition at line 45 of file HsSoundLibTraps.h.

#define kHsSoundLibTrapGetVersion (sysLibTrapCustom + 0)

No definition.

Definition at line 36 of file HsSoundLibTraps.h.

#define kHsSoundLibTrapOpen (sysLibTrapOpen)

No definition.

Definition at line 33 of file HsSoundLibTraps.h.

#define kHsSoundLibTrapPortGetInfo (sysLibTrapCustom + 1)

No definition.

Definition at line 37 of file HsSoundLibTraps.h.

#define kHsSoundLibTrapPortSetParam (sysLibTrapCustom + 2)

No definition.

Definition at line 38 of file HsSoundLibTraps.h.

#define kHsSoundLibTrapSetUserVolume (sysLibTrapCustom + 10)

No definition.

Definition at line 46 of file HsSoundLibTraps.h.

#define kHsSoundLibTrapSwitchGetPort (sysLibTrapCustom + 3)

No definition.

Definition at line 39 of file HsSoundLibTraps.h.

#define kHsSoundLibTrapSwitchSetPort (sysLibTrapCustom + 4)

No definition.

Definition at line 40 of file HsSoundLibTraps.h.

#define kHsSoundLibTrapTonePlay (sysLibTrapCustom + 5)

No definition.

Definition at line 41 of file HsSoundLibTraps.h.

#define kHsSoundLibTrapToneStop (sysLibTrapCustom + 6)

No definition.

Definition at line 42 of file HsSoundLibTraps.h.

#define kPmSoundLibTrapClkGetTickCount (sysLibTrapCustom + 12)

No definition.

Definition at line 48 of file HsSoundLibTraps.h.

#define kPmSoundLibTrapClkGetTicksPerSecond (sysLibTrapCustom + 11)

No definition.

Definition at line 47 of file HsSoundLibTraps.h.

#define kPmSoundLibTrapGetPosition (sysLibTrapCustom + 13)

No definition.

Definition at line 49 of file HsSoundLibTraps.h.

#define kPmSoundLibTrapReserved (sysLibTrapCustom + 14)

No definition.

Definition at line 50 of file HsSoundLibTraps.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:07:33 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » htmllib

HtmlLib68K.h File Reference

Detailed Description

Public 68K include file for HTML shared library.

Definition in file HtmlLib68K.h.

Include dependency graph for HtmlLib68K.h:

Go to the source code of this file.

Data Structures

  • struct HtmlLibFormWidgetProc
    The following are necessary form widget creation/deletion routines that need to get set using HtmlLibSetFormWidgetProc. Please see sample code after looking at HtmlLibSetFormWidgetProc. More...
  • struct HtmlLibFocusTargetInfo

Typedef

  • #define htmlTargetImage 0x01
  • #define htmlTargetEmbed 0x02
  • #define htmlTargetIFrame 0x03
  • #define htmlTargetElement 0x04
  • #define htmlTargetInputText 0x05
  • #define htmlTargetInputPassword 0x06
  • #define htmlTargetInputCheckbox 0x07
  • #define htmlTargetInputRadio 0x08
  • #define htmlTargetInputSubmit 0x09
  • #define htmlTargetInputReset 0x0a
  • #define htmlTargetInputFile 0x0b
  • #define htmlTargetInputButton 0x0c
  • #define htmlTargetInputTextarea 0x0d
  • #define htmlTargetInputSelect 0x0e
  • typedef UInt8 HtmlDisplayMode
  • typedef UInt16 HtmlProgressStatus
  • typedef UInt32 HtmlSubmitFormMethod
  • typedef Int8 HtmlScrollDirection
  • typedef Int8 HtmlScrollbarMode
  • typedef UInt16 HtmlFocusTargetType

Defines

  • #define htmlErrorClass (appErrorClass)
  • #define htmlLibProgressEvent (0x7000)
  • #define HtmlLibID 'AsHL'
  • #define HtmlLibDBType 'libr'
  • #define HtmlLibName "HtmlLibrary"
HtmlLib error codes
  • #define htmlErrInUse (htmlErrorClass | 1)
  • #define htmlErrOutOfMemory (htmlErrorClass | 2)
  • #define htmlErrInvalidParam (htmlErrorClass | 3)
  • #define htmlErrNotFound (htmlErrorClass | 4)
  • #define htmlErrNotInitialized (htmlErrorClass | 5)
  • #define htmlErrCantOpen (htmlErrorClass | 6)
HtmlDisplayMode

  • #define htmlHandheldDisplayMode 0x01
  • #define htmlFaithfulDisplayMode 0x02
HtmlProgressStatus

  • #define htmlProgressDone 0x0001
  • #define htmlProgressBusy 0x0002
  • #define htmlProgressOutOfMemory 0x0003
  • #define htmlProgressError 0x0004
HtmlSubmitFormMethod

  • #define htmlHttpMethodGet 0x00000001
  • #define htmlHttpMethodPost 0x00000002
HtmlDirections

  • #define htmlDirLeft 0x01
  • #define htmlDirRight 0x02
  • #define htmlDirUp 0x03
  • #define htmlDirDown 0x04
HtmlScrollMode

  • #define htmlNormalScrollbarMode 0x01
  • #define htmlNoPageScrollbarMode 0x02

Typedefs

Callback Functions
  • typedef void HtmlLibLinkSelCallback (MemHandle htmlLibH, Char *url, void *cbData)
  • typedef Boolean HtmlLibScanPhoneNumberCallback (MemHandle htmlLibH, Char *buffer, Int32 length, Int32 *patternStart, Int32 *patternEnd)
  • typedef void HtmlLibInclusionCallback (MemHandle htmlLibH, Char *url, void *cbData)
  • typedef void HtmlLibSubmitFormCallback (MemHandle htmlLibH, Char *url, HtmlSubmitFormMethod method, Char *query, void *cbData)
  • typedef Boolean NewControlProc (UInt16 id, UInt16 style, const Char *textP, Coord x, Coord y, Coord width, Coord height, UInt16 font, UInt8 group, Boolean leftAnchor)
  • typedef Err NewListProc (UInt16 id, Coord x, Coord y, Coord width, Coord height, UInt16 font, Int16 visibleItems, Int16 triggerId)
  • typedef Boolean NewFieldProc (UInt16 id, Coord x, Coord y, Coord width, Coord height, UInt16 font, UInt32 maxChars, UInt16 editable, UInt16 underlined, UInt16 singleLine, UInt16 dynamicSize, UInt16 justification, UInt16 autoShift, UInt16 hasScrollBar, UInt16 numeric)
  • typedef void DeleteObjectProc (UInt16 index)

Functions

  • Err HtmlLibOpen (UInt16 refnum)
  • Err HtmlLibClose (UInt16 refnum)
  • Err HtmlLibSleep (UInt16 refnum)
  • Err HtmlLibWake (UInt16 refnum)
  • MemHandle HtmlLibInitialize (UInt16 refnum, RectangleType bounds, Err *errP)
  • MemHandle HtmlLibInitializeWithHeapSize (UInt16 refnum, RectangleType bounds, Err *errP, UInt32 heapMinSize, UInt32 heapDesiredSize, UInt32 *heapActualSizeP)
  • void HtmlLibFinalize (UInt16 refnum, MemHandle htmllibH)
  • void HtmlLibResizeScreen (UInt16 refnum, MemHandle htmlLibH, RectangleType newBounds)
  • void HtmlLibSetDisplayMode (UInt16 refnum, MemHandle htmlLibH, HtmlDisplayMode mode)
  • void HtmlLibSetLinkSelectionCallback (UInt16 refnum, MemHandle htmlLibH, HtmlLibLinkSelCallback *callback, void *cbData)
  • void HtmlLibSetScanPhoneNumberCallback (UInt16 refnum, MemHandle htmlLibH, HtmlLibScanPhoneNumberCallback *callback)
  • void HtmlLibSetInclusionCallback (UInt16 refnum, MemHandle htmlLibH, HtmlLibInclusionCallback *callback, void *cbData)
  • void HtmlLibSetSubmitFormCallback (UInt16 refnum, MemHandle htmlLibH, HtmlLibSubmitFormCallback *callback, void *cbData)
  • UInt16 HtmlLibProgress (UInt16 refnum, MemHandle htmlLibH, Int32 stayTime)
  • Boolean HtmlLibNotifyUIEvent (UInt16 refnum, MemHandle htmlLibH, EventType *eventP)
  • Err HtmlLibFindText (UInt16 refnum, MemHandle htmlLibH, Char *searchString, Boolean wrapSearch)
  • Boolean HtmlLibGetTextSelection (UInt16 refnum, MemHandle htmlLibH, Char **selectedText)
  • void HtmlLibClearScreen (UInt16 refnum, MemHandle htmlLibH)
  • void HtmlLibAbortRenderData (UInt16 refnum, MemHandle htmlLibH)
  • MemHandle HtmlLibCreateContentObject (UInt16 refnum, MemHandle htmlLibH)
  • void HtmlLibDestroyContentObject (UInt16 refnum, MemHandle contentH)
  • Err HtmlLibAddTextData (UInt16 refnum, MemHandle contentH, Char *url, Char *mimeType, Char *charset, void *data, Int32 dataLen)
  • Err HtmlLibAddImageData (UInt16 refnum, MemHandle contentH, Char *url, Char *mimeType, void *data, Int32 dataLen)
  • void HtmlLibRenderData (UInt16 refnum, MemHandle contentH)
  • void HtmlLibRedrawScreen (UInt16 refnum, MemHandle htmlLibH)
  • void HtmlLibSetScrollbars (UInt16 refnum, MemHandle htmlLibH, UInt16 *scrollbars, UInt16 size)
  • Err HtmlLibGetVScrollPosition (UInt16 refnum, MemHandle htmlLibH, Int16 *valueP)
  • Err HtmlLibSetVScrollPosition (UInt16 refnum, MemHandle htmlLibH, Int16 newPosition)
  • Boolean HtmlLibCanScroll (UInt16 refnum, MemHandle htmlLibH, HtmlScrollDirection direction)
  • Err HtmlLibSetScrollbarMode (UInt16 refnum, MemHandle htmlLibH, HtmlScrollbarMode mode)
  • Err HtmlLibSetBiggerFont (UInt16 refnum, MemHandle htmlLibH, Boolean value)
  • Boolean HtmlLibResetFocusInfo (UInt16 refnum, MemHandle htmlLibH)
  • void HtmlLibSetFocusStatus (UInt16 refnum, MemHandle htmlLibH, Boolean flag, Boolean reset_focus)
  • void HtmlLibSetFormWidgetProc (UInt16 refnum, MemHandle htmlLibH, HtmlLibFormWidgetProc *proc)
  • Boolean HtmlLibGetTargetInfo (UInt16 refnum, MemHandle htmlLibH, HtmlLibFocusTargetInfo *htmlTargetInfo)
  • Err HtmlLibSetImageMemoryLimit (UInt16 renum, MemHandle htmlLibH, Int32 limit)

Define Documentation

#define htmlDirDown 0x04

Definition at line 215 of file HtmlLib68K.h.

#define htmlDirLeft 0x01

Definition at line 212 of file HtmlLib68K.h.

#define htmlDirRight 0x02

Definition at line 213 of file HtmlLib68K.h.

#define htmlDirUp 0x03

Definition at line 214 of file HtmlLib68K.h.

#define htmlErrCantOpen (htmlErrorClass | 6)

Definition at line 54 of file HtmlLib68K.h.

#define htmlErrInUse (htmlErrorClass | 1)

Definition at line 49 of file HtmlLib68K.h.

#define htmlErrInvalidParam (htmlErrorClass | 3)

Definition at line 51 of file HtmlLib68K.h.

#define htmlErrNotFound (htmlErrorClass | 4)

Definition at line 52 of file HtmlLib68K.h.

#define htmlErrNotInitialized (htmlErrorClass | 5)

Definition at line 53 of file HtmlLib68K.h.

#define htmlErrorClass (appErrorClass)

Definition at line 39 of file HtmlLib68K.h.

#define htmlErrOutOfMemory (htmlErrorClass | 2)

Definition at line 50 of file HtmlLib68K.h.

#define htmlFaithfulDisplayMode 0x02

Definition at line 187 of file HtmlLib68K.h.

#define htmlHandheldDisplayMode 0x01

Definition at line 186 of file HtmlLib68K.h.

#define htmlHttpMethodGet 0x00000001

Definition at line 204 of file HtmlLib68K.h.

#define htmlHttpMethodPost 0x00000002

Definition at line 205 of file HtmlLib68K.h.

#define HtmlLibDBType 'libr'

Definition at line 64 of file HtmlLib68K.h.

#define HtmlLibID 'AsHL'

Definition at line 63 of file HtmlLib68K.h.

#define HtmlLibName "HtmlLibrary"

Definition at line 65 of file HtmlLib68K.h.

#define htmlLibProgressEvent (0x7000)

Definition at line 57 of file HtmlLib68K.h.

#define htmlNoPageScrollbarMode 0x02

Definition at line 223 of file HtmlLib68K.h.

#define htmlNormalScrollbarMode 0x01

Definition at line 222 of file HtmlLib68K.h.

#define htmlProgressBusy 0x0002

Definition at line 195 of file HtmlLib68K.h.

#define htmlProgressDone 0x0001

Definition at line 194 of file HtmlLib68K.h.

#define htmlProgressError 0x0004

Definition at line 197 of file HtmlLib68K.h.

#define htmlProgressOutOfMemory 0x0003

Definition at line 196 of file HtmlLib68K.h.

#define htmlTargetElement 0x04

Definition at line 87 of file HtmlLib68K.h.

#define htmlTargetEmbed 0x02

Definition at line 85 of file HtmlLib68K.h.

#define htmlTargetIFrame 0x03

Definition at line 86 of file HtmlLib68K.h.

#define htmlTargetImage 0x01

Definition at line 84 of file HtmlLib68K.h.

#define htmlTargetInputButton 0x0c

Definition at line 95 of file HtmlLib68K.h.

#define htmlTargetInputCheckbox 0x07

Definition at line 90 of file HtmlLib68K.h.

#define htmlTargetInputFile 0x0b

Definition at line 94 of file HtmlLib68K.h.

#define htmlTargetInputPassword 0x06

Definition at line 89 of file HtmlLib68K.h.

#define htmlTargetInputRadio 0x08

Definition at line 91 of file HtmlLib68K.h.

#define htmlTargetInputReset 0x0a

Definition at line 93 of file HtmlLib68K.h.

#define htmlTargetInputSelect 0x0e

Definition at line 97 of file HtmlLib68K.h.

#define htmlTargetInputSubmit 0x09

Definition at line 92 of file HtmlLib68K.h.

#define htmlTargetInputText 0x05

Definition at line 88 of file HtmlLib68K.h.

#define htmlTargetInputTextarea 0x0d

Definition at line 96 of file HtmlLib68K.h.

Typedef Documentation

typedef void DeleteObjectProc(UInt16 index)

See also:
HtmlLibFormWidgetProc

Definition at line 161 of file HtmlLib68K.h.

typedef UInt8 HtmlDisplayMode

Definition at line 76 of file HtmlLib68K.h.

typedef UInt16 HtmlFocusTargetType

Definition at line 99 of file HtmlLib68K.h.

typedef void HtmlLibInclusionCallback(MemHandle htmlLibH, Char *url, void *cbData)

Should be defined and set as the function to be called when rendering a page requires additional content.

HtmlLib calls this callback function with the appropriate arguments (where the url is the url of the additional content the library requires).

Definition at line 124 of file HtmlLib68K.h.

typedef void HtmlLibLinkSelCallback(MemHandle htmlLibH, Char *url, void *cbData)

Should be defined (to handle a link selection) and set as the function to be called when a link (url) is selected.

Definition at line 110 of file HtmlLib68K.h.

typedef Boolean HtmlLibScanPhoneNumberCallback(MemHandle htmlLibH, Char *buffer, Int32 length, Int32 *patternStart, Int32 *patternEnd)

Should be defined and set as the function to be called when it's necessary to determine if a string of numbers contains a phone number.

Here, buffer contains the string of numbers that are being checked, and this is passed in by the library when the library calls this function. Length is the buffer's length, also passed in by the library. The last two arguments (patternStart and patternEnd) should get set in this callback function if the string of numbers passed in is determined to be a phone number (and thus the return value of the function is to be true). Now, patternStart is the place in the buffer that the phone number starts, and patternEnd is the place in the buffer that the pattern ends. For example, if the entire contents of the buffer passed in happened to be a phone number, then the start would be 0 and the end would be "length - 1", and the return value would be true. However, if what was passed in was not determined to be a phone number, then the return value of the callback function should be false, and the last two arguments do not need to be set.

Definition at line 117 of file HtmlLib68K.h.

typedef void HtmlLibSubmitFormCallback(MemHandle htmlLibH, Char *url, HtmlSubmitFormMethod method, Char *query, void *cbData)

Note:
Forms are not supported; thus, use this at your own risk.
Should be defined and set as the function to be called when a submit is activated.

HtmlLib calls this callback function with the appropriate arguments. The following is an example (included in the sample code):

 void HtmlSubmitFormCallback(MemHandle htmlLibH, Char *url, HtmlSubmitFormMethod method, Char *query, void *cbData)
 {
     FrmCustomAlert(SubmitFormAlert, url,
        (method == htmlHttpMethodPost ? "Post" : "Get"), query);
 }

Definition at line 144 of file HtmlLib68K.h.

typedef UInt16 HtmlProgressStatus

Definition at line 77 of file HtmlLib68K.h.

typedef Int8 HtmlScrollbarMode

Definition at line 80 of file HtmlLib68K.h.

typedef Int8 HtmlScrollDirection

Definition at line 79 of file HtmlLib68K.h.

typedef UInt32 HtmlSubmitFormMethod

Definition at line 78 of file HtmlLib68K.h.

typedef Boolean NewControlProc(UInt16 id, UInt16 style, const Char *textP, Coord x, Coord y, Coord width, Coord height, UInt16 font, UInt8 group, Boolean leftAnchor)

See also:
HtmlLibFormWidgetProc

Definition at line 146 of file HtmlLib68K.h.

typedef Boolean NewFieldProc(UInt16 id, Coord x, Coord y, Coord width, Coord height, UInt16 font, UInt32 maxChars, UInt16 editable, UInt16 underlined, UInt16 singleLine, UInt16 dynamicSize, UInt16 justification, UInt16 autoShift, UInt16 hasScrollBar, UInt16 numeric)

See also:
HtmlLibFormWidgetProc

Definition at line 155 of file HtmlLib68K.h.

typedef Err NewListProc(UInt16 id, Coord x, Coord y, Coord width, Coord height, UInt16 font, Int16 visibleItems, Int16 triggerId)

See also:
HtmlLibFormWidgetProc

Definition at line 151 of file HtmlLib68K.h.

Function Documentation

void HtmlLibAbortRenderData | ( | UInt16 | refnum,
 |  | MemHandle | htmlLibH
 | ) |  |

This function aborts rendering of the current content.

Parameters:
refNum | IN: the library reference number
contentH | IN: Memory Handle of the current content, returned by HtmlLibCreateContentObject

Err HtmlLibAddImageData | ( | UInt16 | refnum,
 |  | MemHandle | contentH,
 |  | Char * | url,
 |  | Char * | mimeType,
 |  | void * | data,
 |  | Int32 | dataLen
 | ) |  |

This function adds images to HtmlLib. (You can use this to respond to Inclusion callback - please see section 2.1 Image Rendering).

Parameters:
refNum | IN: the library reference number
contentH | IN: Memory Handle returned by HtmlLibCreateContentObject
url | IN: url of the image
mimeType | IN: mime type of the image (for example, "image/jpeg")
data | IN: image data
dataLen | IN: image data size
Returns:
Error code.

Err HtmlLibAddTextData | ( | UInt16 | refnum,
 |  | MemHandle | contentH,
 |  | Char * | url,
 |  | Char * | mimeType,
 |  | Char * | charset,
 |  | void * | data,
 |  | Int32 | dataLen
 | ) |  |

This function adds text data to the content data object created by HtmlLibCreateContentObject. Application should call HtmlLibRenderData when it has finished adding text data, for the data to be rendered.

Note:
There is a limit of 64K of text data per content object (and not just per call of HtmlLibAddTextData).
Parameters:
refNum | IN: the library reference number
contentH | IN: Memory Handle returned by HtmlLibCreateContentObject
url | IN: url of the page you are adding to (unique, to make sure nothing is written over)
mimeType | IN: mime type of the text (such as "text/plain", "text/html")
charset | IN: the character set (such as "us-ascii")
data | IN: a reference to the text data to be added
dataLen | IN: length of the data
Returns:
This function returns an error code (returns errNone if successful).

Boolean HtmlLibCanScroll | ( | UInt16 | refnum,
 |  | MemHandle | htmlLibH,
 |  | HtmlScrollDirection | direction
 | ) |  |

This function lets you know whether scrolling is possible in the indicated direction.

Parameters:
refNum | IN: the library reference number
htmlLibH | IN: the memory handle returned by HtmlLibInitialize
direction | IN: htmlDirLeft, htmlDirRight, htmlDirUp, htmlDirDown
Returns:
Function outputs true if scrolling in the indicated direction is possible.

void HtmlLibClearScreen | ( | UInt16 | refnum,
 |  | MemHandle | htmlLibH
 | ) |  |

This function clears the rendering screen. It must be called before content object is destroyed.

Parameters:
refNum | IN: the library reference number
htmlLibH | IN: the memory handle returned by HtmlLibInitialize

Err HtmlLibClose ( UInt16 refnum )

Standard library close routine.

Parameters:
refun IN: the library reference number
Returns:
Error code.

MemHandle HtmlLibCreateContentObject | ( | UInt16 | refnum,
 |  | MemHandle | htmlLibH
 | ) |  |

Creates a content object (structure in memory that contains content to be rendered).

Parameters:
refNum | IN: the library reference number
htmlLibH | IN: the memory handle returned by HtmlLibInitialize
Returns:
This function returns the memory handle of a content data object.

void HtmlLibDestroyContentObject | ( | UInt16 | refnum,
 |  | MemHandle | contentH
 | ) |  |

This function destroys the content data object created by HtmlLibCreateContentObject.

Note:
Be cautious when destroying a content object - make sure it is not busy doing something else, like rendering data. You can use HtmlLibProgress to check for the status (busy or not), or you can call HtmlLibAbortRenderData first.
Parameters:
refNum | IN: the library reference number
contentH | IN: Memory Handle returned by HtmlLibCreateContentObject

void HtmlLibFinalize | ( | UInt16 | refnum,
 |  | MemHandle | htmllibH
 | ) |  |

Finalizes the library when you are done using it

Note:
If you need to use the library again after it has been finalized, you will need to re-initialize it.
Parameters:
refNum | IN: the library reference number
htmlLibH | IN: the memory handle returned by HtmlLibInitialize

Err HtmlLibFindText | ( | UInt16 | refnum,
 |  | MemHandle | htmlLibH,
 |  | Char * | searchString,
 |  | Boolean | wrapSearch
 | ) |  |

Applications should call this function to find a given text string on the page. Page will automatically scroll to show search result.

Parameters:
refNum | IN: the library reference number
htmlLibH | IN: the memory handle returned by HtmlLibInitialize
searchString | IN: the given text string we are looking for on the page
wrapSearch | IN: true if you would like to wrap search
Returns:
Error code (errNone, htmlErrNotFound).

Boolean HtmlLibGetTargetInfo | ( | UInt16 | refnum,
 |  | MemHandle | htmlLibH,
 |  | HtmlLibFocusTargetInfo * | htmlTargetInfo
 | ) |  |

Boolean HtmlLibGetTextSelection | ( | UInt16 | refnum,
 |  | MemHandle | htmlLibH,
 |  | Char ** | selectedText
 | ) |  |

Applications should use this function to retrieve the current selected text. Caller application must free the pointer returned in selectedText using MemPtrFree.

Parameters:
refNum | IN: the library reference number
htmlLibH | IN: the memory handle returned by HtmlLibInitialize
selectedText | IN: the selected text that we are retrieving
Returns:
This function returns false if no current selection, otherwise returns true.

Err HtmlLibGetVScrollPosition | ( | UInt16 | refnum,
 |  | MemHandle | htmlLibH,
 |  | Int16 * | valueP
 | ) |  |

This function obtains the current scroll position in pixels from the top of the page.

Parameters:
refNum | IN: the library reference number
htmlLibH | IN: the memory handle returned by HtmlLibInitialize
valueP | IN: at function's return, this contains the position in pixels from the top of the page
Returns:
Error code.

MemHandle HtmlLibInitialize | ( | UInt16 | refnum,
 |  | RectangleType | bounds,
 |  | Err * | errP
 | ) |  |

Html Library initialization function. Initializes the library, after the library has been loaded.

Parameters:
refNum | IN: the library reference number
bounds | IN: the screen area the library will draw the rendered content (bounds within 160 x 160 grid)
errP | IN: error code if library fails to initialize. The error code can be one of (htmlErrInUse, htmlErrOutOfMemory, htmlErrInvalidParam, htmlErrInUse, htmlErrCantOpen)
Returns:
A memory handle to the HTML library context.

MemHandle HtmlLibInitializeWithHeapSize | ( | UInt16 | refnum,
 |  | RectangleType | bounds,
 |  | Err * | errP,
 |  | UInt32 | heapMinSize,
 |  | UInt32 | heapDesiredSize,
 |  | UInt32 * | heapActualSizeP
 | ) |  |

Boolean HtmlLibNotifyUIEvent | ( | UInt16 | refnum,
 |  | MemHandle | htmlLibH,
 |  | EventType * | eventP
 | ) |  |

Applications should call this function to notify HTML library of a UI event (any event that your application gets that the library should handle, such as a screen tap, or a key press). It is worth noting that you may create your own events and call this function for the library to handle it. By the same token, you can filter which events to pass to this function - you do not have to pass through every event.

Parameters:
refNum | IN: the library reference number
htmlLibH | IN: the memory handle returned by HtmlLibInitialize
eventP | IN: the event you would like the library to handle
Returns:
True if the library considers this event handled.

Err HtmlLibOpen ( UInt16 refnum )

Standard library open routine.

Parameters:
refun IN: the library reference number
Returns:
Error code.

UInt16 HtmlLibProgress | ( | UInt16 | refnum,
 |  | MemHandle | htmlLibH,
 |  | Int32 | stayTime
 | ) |  |

Applications should call this function to allow HTML library to process content and draw to screen.

Note:
The Html Library will run only if you call this!
Parameters:
refNum | IN: the library reference number
htmlLibH | IN: the memory handle returned by HtmlLibInitialize
stayTime | IN: maximum time (in milliseconds) for HTML library to do processing. (At least 1300 is recommend.)
Returns:
Status - htmlProgressDone, htmlProgressBusy, htmlProgressOutOfMemory, and other error codes.

void HtmlLibRedrawScreen | ( | UInt16 | refnum,
 |  | MemHandle | htmlLibH
 | ) |  |

This redraws the HtmlLib rendering screen (for example, when application receives a frmUpdate event).

Parameters:
refNum | IN: the library reference number
htmlLibH | IN: the memory handle returned by HtmlLibInitialize

void HtmlLibRenderData | ( | UInt16 | refnum,
 |  | MemHandle | contentH
 | ) |  |

Applications should call this function after adding text data by HtmlLibAddTextData (or image data by HtmlLibAddImageData, see section 2.1 Image Rendering) to have HTML library start rendering the content.

Parameters:
refNum | IN: the library reference number
contentH | IN: Memory Handle returned by HtmlLibCreateContentObject that contains the text data to be rendered

Boolean HtmlLibResetFocusInfo | ( | UInt16 | refnum,
 |  | MemHandle | htmlLibH
 | ) |  |

This function reinitializes the focus to point to nothing.

Parameters:
refNum | IN: the library reference number
htmlLibH | IN: htmlLib handle
Returns:
True if the focus was reset to point to nothing.

void HtmlLibResizeScreen | ( | UInt16 | refnum,
 |  | MemHandle | htmlLibH,
 |  | RectangleType | newBounds
 | ) |  |

Resize the screen area.

Parameters:
refNum | IN: the library reference number
htmlLibH | IN: the memory handle returned by HtmlLibInitialize
newBounds | IN: the new bounds of the screen area (bounds within 160 x 160 grid)
Returns:
errNone if resize is successful, otherwise returns an error code (errInvalidParam)

Err HtmlLibSetBiggerFont | ( | UInt16 | refnum,
 |  | MemHandle | htmlLibH,
 |  | Boolean | value
 | ) |  |

This function will control the size of the font used by HtmlLib.

Parameters:
refNum | IN: the library reference number
htmlLibH | IN: htmlLib handle
value | IN: true if you would like bigger font (bigger font corresponds to the Large font option in Blazer), and false otherwise (false would correspond to the Small font option in Blazer).
Returns:
Error code.

void HtmlLibSetDisplayMode | ( | UInt16 | refnum,
 |  | MemHandle | htmlLibH,
 |  | HtmlDisplayMode | mode
 | ) |  |

Sets the display mode (faithful rendering, which corresponds to Blazer's Wide Page Mode, or handheld wrapped, which corresponds to Blazer's Optimized Mode).

Parameters:
refNum | IN: the library reference number
htmlLibH | IN: the memory handle returned by HtmlLibInitialize
mode | IN: display mode (htmlFaithfulDisplayMode or htmlHandheldDisplayMode)

void HtmlLibSetFocusStatus | ( | UInt16 | refnum,
 |  | MemHandle | htmlLibH,
 |  | Boolean | flag,
 |  | Boolean | reset_focus
 | ) |  |

This function sets the focus according to the condition flags passed in.

Parameters:
refNum | IN: the library reference number
htmlLibH | IN: htmlLib handle
flag | - Enables (true) or Disables (false) focus handling
reset_focus | - if flag is true: if reset_focus is true, then the code tries to set the next focus onto the next target in the event focus walk chain. If false, it again sets the focus to the current event target.

void HtmlLibSetFormWidgetProc | ( | UInt16 | refnum,
 |  | MemHandle | htmlLibH,
 |  | HtmlLibFormWidgetProc * | proc
 | ) |  |

This function sets the function pointers of some necessary form widget creation/deletion routines. The following is sufficient for most purposes (and included in the sample application):

  static HtmlLibFormWidgetProc *widgetProc = NULL;

    widgetProc = MemPtrNew(sizeof(HtmlLibFormWidgetProc));
    if (widgetProc) {
      //functions defined in sample code
        widgetProc->newControlProc = RendererNewControlProc;
        widgetProc->newFieldProc = RendererNewFieldProc;
        widgetProc->newListProc = RendererNewListProc;
        widgetProc->deleteObjectProc = RendererDeleteObjectProc;
    }

    HtmlLibSetFormWidgetProc(refNum, htmlLibH, widgetProc);

A standard example of the necessary form widget creation/deletion routines are provided below, and can be found in the sample code.

 static Boolean
 RendererNewControlProc(UInt16 ID,
       UInt16 style, const Char *textP,
       Coord x, Coord y, Coord width, Coord height,
       UInt16 font, UInt8 group, Boolean leftAnchor)

  {
       ControlType *ctlP;
       FormType *formP = FrmGetActiveForm();
       ctlP = CtlNewControl((void**)&formP, ID, style, textP, x, y, width, height, font, group, leftAnchor);
       if (ctlP) {
           return true;
       }
       return false;
  }

  static Boolean
  RendererNewFieldProc(UInt16 id,
       Coord x, Coord y, Coord width, Coord height,
       UInt16 font, UInt32 maxChars, UInt16 editable, UInt16 underlined,
       UInt16 singleLine, UInt16 dynamicSize, UInt16 justification,
       UInt16 autoShift, UInt16 hasScrollBar, UInt16 numeric)

  {
       FieldType *fieldP;
       FormType *formP = FrmGetActiveForm();
       fieldP = FldNewField((void**)&formP, id, x, y, width, height, (FontID)font,
                       maxChars, (Boolean)editable, (Boolean)underlined, (Boolean)singleLine,
                       (Boolean)dynamicSize, (JustificationType)justification, (Boolean)autoShift,
                       (Boolean)hasScrollBar, (Boolean)numeric);
       if (fieldP) {
           return true;
       }
       return false;
  }

  static Err
  RendererNewListProc(UInt16 id,
       Coord x, Coord y, Coord width, Coord height,
       UInt16 font, Int16 visibleItems, Int16 triggerId)
  {
       FormType *formP = FrmGetActiveForm();
       return LstNewList((void**)&formP, id, x, y, width, height, font,
                           visibleItems, triggerId);
  }

  static void
  RendererDeleteObjectProc(UInt16 index)
  {
       FormType *formP = FrmGetActiveForm();
       FrmRemoveObject(&formP, index);
  }

Parameters:
refNum | IN: HTML library reference number
htmlLibH | IN: htmlLib handle
proc | IN: function pointers of form widget creation/deletion routines.

Err HtmlLibSetImageMemoryLimit | ( | UInt16 | renum,
 |  | MemHandle | htmlLibH,
 |  | Int32 | limit
 | ) |  |

void HtmlLibSetInclusionCallback | ( | UInt16 | refnum,
 |  | MemHandle | htmlLibH,
 |  | HtmlLibInclusionCallback * | callback,
 |  | void * | cbData
 | ) |  |

Specify the function that you want the library to call when rendering a page requires additional content (an image that hasn't been added, an external style sheet, etc).

Parameters:
refNum | IN: the library reference number
htmlLibH | IN: the memory handle returned by HtmlLibInitialize
callback | IN: a pointer to the function you want called when rendering a page that requires additional content.
cbData | I/O: the library does nothing with this parameter except pass it on as one of the arguments to your callback function. To not take advantage of this feature, just pass in NULL.
Note:
: The callback function should be in the following form: void HtmlLibInclusionCallback(MemHandle htmlLibH, Char *url, void *cbData);
HtmlLib calls this callback function with the appropriate arguments (where the url is the url of the additional content the library requires).

See also:
HtmlLibInclusionCallback

void HtmlLibSetLinkSelectionCallback | ( | UInt16 | refnum,
 |  | MemHandle | htmlLibH,
 |  | HtmlLibLinkSelCallback * | callback,
 |  | void * | cbData
 | ) |  |

Specify the function that you want the library to call when a link is followed.

Parameters:
refNum | IN: the library reference number
htmlLibH | IN: the memory handle returned by HtmlLibInitialize
callback | IN: a pointer to the function you want called when a link is followed.
cbData | I/O: the library does nothing with this parameter except pass it on as one of the arguments to your callback function. To not take advantage of this feature, just pass in NULL.
Note:
The callback function should be in the following form: void HtmlLinkSelCallback(MemHandle htmlLibH, Char *url, void *cbData); The library will call this function, supplying the appropriate arguments (where the url is the url of the link which was selected).
See also:
HtmlLibLinkSelCallback

void HtmlLibSetScanPhoneNumberCallback | ( | UInt16 | refnum,
 |  | MemHandle | htmlLibH,
 |  | HtmlLibScanPhoneNumberCallback * | callback
 | ) |  |

Specify the function that you want the library to call to determine whether some string of numbers contains a phone number.

Parameters:
refNum | IN: the library reference number
htmlLibH | IN: the memory handle returned by HtmlLibInitialize
callback | IN: a pointer to the function that HtmlLib will call to determine whether a string of numbers is a phone number, and should be handled as such.
Note:
The callback function should be in the following form: Boolean HtmlLibScanPhoneNumberCallback(MemHandle htmlLibH, Char *buffer, Int32 length, Int32 *patternStart, Int32 *patternEnd);
See also:
HtmlLibScanPhoneNumberCallback

Err HtmlLibSetScrollbarMode | ( | UInt16 | refnum,
 |  | MemHandle | htmlLibH,
 |  | HtmlScrollbarMode | mode
 | ) |  |

This function sets the page's scrollbar mode, without affecting the scrollbars of a textarea. A reason to use htmlNoPageScrollbarMode and not htmlNormalScrollbarMode is if you would like to use your own scrollbars, and use HtmlLib(Set/Get)VScrollPosition to do so.

Parameters:
refNum | IN: the library reference number
htmlLibH | IN: the memory handle returned by HtmlLibInitialize
mode | IN: scrollbar mode (htmlNormalScrollbarMode to enable scrolling or htmlNoPageScrollbarMode for no scrolling)
Returns:
Error code. (htmlErrNotInitialized, htmlErrInUse)

void HtmlLibSetScrollbars | ( | UInt16 | refnum,
 |  | MemHandle | htmlLibH,
 |  | UInt16 * | scrollbars,
 |  | UInt16 | size
 | ) |  |

This function passes an array of scrollbars to HtmlLib. Html library will not display any scrollbar if application does not call this function (scrollbars cannot be added dynamically). Application is recommended to pass no less than 4 (or at the very least 2) scrollbars, and up to 9 scrollbars. For example (after defining RenderScroll0ScrollBar and RenderScroll1ScrollBar):

  UInt16 scrollbars[2] = {RenderScroll0ScrollBar, RenderScroll1ScrollBar};
  HtmlLibSetScrollbars(gRefNum, gHtmlLibH, scrollbars, 2);

Parameters:
refNum | IN: the library reference number
htmlLibH | IN: the memory handle returned by HtmlLibInitialize
scrollbars | IN: array of scrollbars
size | IN: size of the array of scrollbars

void HtmlLibSetSubmitFormCallback | ( | UInt16 | refnum,
 |  | MemHandle | htmlLibH,
 |  | HtmlLibSubmitFormCallback * | callback,
 |  | void * | cbData
 | ) |  |

Note:
: Forms are not supported; thus, use this at your own risk.
This functions lets you specify the function that you want the library to call when a "submit" is activated.

Parameters:
refNum | IN: the library reference number
htmlLibH | IN: the memory handle returned by HtmlLibInitialize
callback | IN: a pointer to the function you want called when a "submit" is activated
cbData | I/O: the library does nothing with this parameter except pass it on as one of the arguments to your callback function. To not take advantage of this feature, just pass in NULL.
Note:
The callback function should be in the following form:
HtmlLibSubmitFormCallback(MemHandle htmlLibH, Char *url, HtmlSubmitFormMethod method, Char *query, void *cbData);

HtmlLib calls this callback function with the appropriate arguments.

See also:
HtmlLibSubmitFormCallback

Err HtmlLibSetVScrollPosition | ( | UInt16 | refnum,
 |  | MemHandle | htmlLibH,
 |  | Int16 | newPosition
 | ) |  |

This function sets the current scroll position in pixels from the top of the page. If the total page height of the current page is less than this, this scrolls the page to the bottom.

Parameters:
refNum | IN: the library reference number
htmlLibH | IN: the memory handle returned by HtmlLibInitialize
newPosition | IN: the position in pixels from the top of the page
Returns:
Error code.

Err HtmlLibSleep ( UInt16 refnum )

Standard library sleep routine.

Parameters:
refun IN: the library reference number
Returns:
Error code.

Err HtmlLibWake ( UInt16 refnum )

Standard library wake routine.

Parameters:
refun IN: the library reference number
Returns:
Error code.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:07:34 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » htmllib

HtmlLibTrap.h File Reference

Include dependency graph for HtmlLibTrap.h:

Go to the source code of this file.

Defines

  • #define kHtmlLibTrapOpen sysLibTrapOpen
  • #define kHtmlLibTrapClose sysLibTrapClose
  • #define kHtmlLibTrapSleep sysLibTrapSleep
  • #define kHtmlLibTrapWake sysLibTrapWake
  • #define kHtmlLibTrapInitialize (sysLibTrapCustom + 0)
  • #define kHtmlLibTrapFinalize (sysLibTrapCustom + 1)
  • #define kHtmlLibTrapResizeScreen (sysLibTrapCustom + 2)
  • #define kHtmlLibTrapSetDisplayMode (sysLibTrapCustom + 3)
  • #define kHtmlLibTrapSetLinkSelectionCallback (sysLibTrapCustom + 4)
  • #define kHtmlLibTrapSetScanPhoneNumberCallback (sysLibTrapCustom + 5)
  • #define kHtmlLibTrapSetInclusionCallback (sysLibTrapCustom + 6)
  • #define kHtmlLibTrapSetSubmitFormCallback (sysLibTrapCustom + 7)
  • #define kHtmlLibTrapProgress (sysLibTrapCustom + 8)
  • #define kHtmlLibTrapNotifyUIEvent (sysLibTrapCustom + 9)
  • #define kHtmlLibTrapFindText (sysLibTrapCustom + 10)
  • #define kHtmlLibTrapGetTextSelection (sysLibTrapCustom + 11)
  • #define kHtmlLibTrapClearScreen (sysLibTrapCustom + 12)
  • #define kHtmlLibTrapAbortRenderData (sysLibTrapCustom + 13)
  • #define kHtmlLibTrapCreateContentObject (sysLibTrapCustom + 14)
  • #define kHtmlLibTrapDestroyContentObject (sysLibTrapCustom + 15)
  • #define kHtmlLibTrapAddTextData (sysLibTrapCustom + 16)
  • #define kHtmlLibTrapRenderData (sysLibTrapCustom + 17)
  • #define kHtmlLibTrapRedrawScreen (sysLibTrapCustom + 18)
  • #define kHtmlLibTrapSetScrollbars (sysLibTrapCustom + 19)
  • #define kHtmlLibTrapGetVScrollPosition (sysLibTrapCustom + 20)
  • #define kHtmlLibTrapSetVScrollPosition (sysLibTrapCustom + 21)
  • #define kHtmlLibTrapCanScroll (sysLibTrapCustom + 22)
  • #define kHtmlLibTrapSetScrollbarMode (sysLibTrapCustom + 23)
  • #define kHtmlLibTrapAddImageData (sysLibTrapCustom + 24)
  • #define kHtmlLibTrapSetBiggerFont (sysLibTrapCustom + 25)
  • #define kHtmlLibTrapSetFormWidgetProc (sysLibTrapCustom + 26)
  • #define kHtmlLibTrapGetTargetInfo (sysLibTrapCustom + 27)
  • #define kHtmlLibTrapInitializeWithHeapSize (sysLibTrapCustom + 28)
  • #define kHtmlLibTrapSetImageMemoryLimit (sysLibTrapCustom + 29)
  • #define kHtmlLibTrapResetFocusInfo (sysLibTrapCustom + 30)
  • #define kHtmlLibTrapSetFocusStatus (sysLibTrapCustom + 31)

Define Documentation

#define kHtmlLibTrapAbortRenderData (sysLibTrapCustom + 13)

Definition at line 34 of file HtmlLibTrap.h.

#define kHtmlLibTrapAddImageData (sysLibTrapCustom + 24)

Definition at line 45 of file HtmlLibTrap.h.

#define kHtmlLibTrapAddTextData (sysLibTrapCustom + 16)

Definition at line 37 of file HtmlLibTrap.h.

#define kHtmlLibTrapCanScroll (sysLibTrapCustom + 22)

Definition at line 43 of file HtmlLibTrap.h.

#define kHtmlLibTrapClearScreen (sysLibTrapCustom + 12)

Definition at line 33 of file HtmlLibTrap.h.

#define kHtmlLibTrapClose sysLibTrapClose

Definition at line 18 of file HtmlLibTrap.h.

#define kHtmlLibTrapCreateContentObject (sysLibTrapCustom + 14)

Definition at line 35 of file HtmlLibTrap.h.

#define kHtmlLibTrapDestroyContentObject (sysLibTrapCustom + 15)

Definition at line 36 of file HtmlLibTrap.h.

#define kHtmlLibTrapFinalize (sysLibTrapCustom + 1)

Definition at line 22 of file HtmlLibTrap.h.

#define kHtmlLibTrapFindText (sysLibTrapCustom + 10)

Definition at line 31 of file HtmlLibTrap.h.

#define kHtmlLibTrapGetTargetInfo (sysLibTrapCustom + 27)

Definition at line 48 of file HtmlLibTrap.h.

#define kHtmlLibTrapGetTextSelection (sysLibTrapCustom + 11)

Definition at line 32 of file HtmlLibTrap.h.

#define kHtmlLibTrapGetVScrollPosition (sysLibTrapCustom + 20)

Definition at line 41 of file HtmlLibTrap.h.

#define kHtmlLibTrapInitialize (sysLibTrapCustom + 0)

Definition at line 21 of file HtmlLibTrap.h.

#define kHtmlLibTrapInitializeWithHeapSize (sysLibTrapCustom + 28)

Definition at line 49 of file HtmlLibTrap.h.

#define kHtmlLibTrapNotifyUIEvent (sysLibTrapCustom + 9)

Definition at line 30 of file HtmlLibTrap.h.

#define kHtmlLibTrapOpen sysLibTrapOpen

Definition at line 17 of file HtmlLibTrap.h.

#define kHtmlLibTrapProgress (sysLibTrapCustom + 8)

Definition at line 29 of file HtmlLibTrap.h.

#define kHtmlLibTrapRedrawScreen (sysLibTrapCustom + 18)

Definition at line 39 of file HtmlLibTrap.h.

#define kHtmlLibTrapRenderData (sysLibTrapCustom + 17)

Definition at line 38 of file HtmlLibTrap.h.

#define kHtmlLibTrapResetFocusInfo (sysLibTrapCustom + 30)

Definition at line 51 of file HtmlLibTrap.h.

#define kHtmlLibTrapResizeScreen (sysLibTrapCustom + 2)

Definition at line 23 of file HtmlLibTrap.h.

#define kHtmlLibTrapSetBiggerFont (sysLibTrapCustom + 25)

Definition at line 46 of file HtmlLibTrap.h.

#define kHtmlLibTrapSetDisplayMode (sysLibTrapCustom + 3)

Definition at line 24 of file HtmlLibTrap.h.

#define kHtmlLibTrapSetFocusStatus (sysLibTrapCustom + 31)

Definition at line 52 of file HtmlLibTrap.h.

#define kHtmlLibTrapSetFormWidgetProc (sysLibTrapCustom + 26)

Definition at line 47 of file HtmlLibTrap.h.

#define kHtmlLibTrapSetImageMemoryLimit (sysLibTrapCustom + 29)

Definition at line 50 of file HtmlLibTrap.h.

#define kHtmlLibTrapSetInclusionCallback (sysLibTrapCustom + 6)

Definition at line 27 of file HtmlLibTrap.h.

#define kHtmlLibTrapSetLinkSelectionCallback (sysLibTrapCustom + 4)

Definition at line 25 of file HtmlLibTrap.h.

#define kHtmlLibTrapSetScanPhoneNumberCallback (sysLibTrapCustom + 5)

Definition at line 26 of file HtmlLibTrap.h.

#define kHtmlLibTrapSetScrollbarMode (sysLibTrapCustom + 23)

Definition at line 44 of file HtmlLibTrap.h.

#define kHtmlLibTrapSetScrollbars (sysLibTrapCustom + 19)

Definition at line 40 of file HtmlLibTrap.h.

#define kHtmlLibTrapSetSubmitFormCallback (sysLibTrapCustom + 7)

Definition at line 28 of file HtmlLibTrap.h.

#define kHtmlLibTrapSetVScrollPosition (sysLibTrapCustom + 21)

Definition at line 42 of file HtmlLibTrap.h.

#define kHtmlLibTrapSleep sysLibTrapSleep

Definition at line 19 of file HtmlLibTrap.h.

#define kHtmlLibTrapWake sysLibTrapWake

Definition at line 20 of file HtmlLibTrap.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:07:35 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » imaging

ImageLib.h File Reference

Detailed Description

Public 68k include file for the Imaging Library.

This file contains routines for capturing, storing, iterating, resizing, and manipulating images. The imaging library is a client of both the camera driver and the JPEG library.

Definition in file ImageLib.h.

Include dependency graph for ImageLib.h:

Go to the source code of this file.

Functions

  • Err ImageLibOpen (UInt16 libRef)
  • Err ImageLibClose (UInt16 libRef)
  • Err ImageLibGetVersion (UInt16 libRef, UInt32 *dwVerP)
  • Err ImageLibCameraExists (UInt16 libRef, Boolean *existsP)
  • Err ImageLibImageCapture (UInt16 libRef, Boolean fullsize, Boolean playShutterSound, Boolean drawImmediately, Coord x, Coord y, UInt16 *newRecNoP)
  • Err ImageLibImageSave (UInt16 libRef, UInt16 recIndex, const char *name, UInt16 category)
  • BitmapType * ImageLibPreviewBitmapCreate (UInt16 libRef, Err *errP)
  • Err ImageLibPreviewBitmapFill (UInt16 libRef, BitmapType *imageP)
  • Err ImageLibPreviewDraw (UInt16 libRef, Coord x, Coord y)
  • BitmapType * ImageLibImageBitmapCreate (UInt16 libRef, UInt16 recIndex, Err *errP)
  • Err ImageLibImageBitmapFill (UInt16 libRef, UInt16 recIndex, BitmapType *imageP)
  • Err ImageLibImageDraw (UInt16 libRef, UInt16 recIndex, Coord x, Coord y)
  • BitmapType * ImageLibThumbnailBitmapCreate (UInt16 libRef, UInt16 recIndex, Err *errP)
  • Err ImageLibThumbnailBitmapFill (UInt16 libRef, UInt16 recIndex, BitmapType *imageP)
  • Err ImageLibThumbnailDraw (UInt16 libRef, UInt16 recIndex, Coord x, Coord y)
  • Err ImageLibBitmapDelete (UInt16 libRef, BitmapType *bmp)
  • Err ImageLibDeleteImage (UInt16 libRef, UInt16 recIndex)
  • Err ImageLibResizeImage (UInt16 libRef, UInt16 recIndex)
  • Err ImageLibGetImageDatabases (UInt16 libRef, DmOpenRef *dbMainP, DmOpenRef *dbNoteP, DmOpenRef *dbImageP)
  • Err ImageLibGetImageInfo (UInt16 libRef, UInt16 recIndex, Char *name, Boolean *fullSizeP, UInt32 *createdP, UInt32 *sizeP, UInt16 *categoryP, Char *categoryName, Boolean *lockedP, UInt32 *uidP)
  • Err ImageLibSetImageInfo (UInt16 libRef, UInt16 recIndex, const char *name, UInt16 *categoryP)
  • Err ImageLibCopyImageToVFS (UInt16 libRef, UInt16 recIndex, UInt16 volRefNum, const char *fileName)
  • Err ImageLibCopyImageFromVFS (UInt16 libRef, UInt16 volRefNum, const char *fileName, const char *name, UInt16 category, UInt16 *newRecIndexP)
  • BitmapType * ImageLibImageBitmapCreateFromVFS (UInt16 libRef, UInt16 volRefNum, const char *fileName, Err *errP)
  • Err ImageLibImageBitmapFillFromVFS (UInt16 libRef, UInt16 volRefNum, const char *fileName, BitmapType *imageP)
  • Err ImageLibImageDrawFromVFS (UInt16 libRef, UInt16 volRefNum, const char *fileName, Coord x, Coord y)
  • BitmapType * ImageLibThumbnailBitmapCreateFromVFS (UInt16 libRef, UInt16 volRefNum, const char *fileName, Err *errP)
  • Err ImageLibThumbnailBitmapFillFromVFS (UInt16 libRef, UInt16 volRefNum, const char *fileName, BitmapType *imageP)
  • Err ImageLibThumbnailDrawFromVFS (UInt16 libRef, UInt16 volRefNum, const char *fileName, Coord x, Coord y)
  • Err ImageLibDoAttachImageDialog (UInt16 libRef, UInt16 *recIndexP, UInt16 *volRefNumP, char *fileName, UInt16 initialCategory, Boolean showConfirmation, Boolean internalImagesOnly, const char *dialogTitle, const char *btnTitle)
  • Err ImageLibCopyImageToBuffer (UInt16 libRef, UInt16 recIndex, MemPtr bufP)
  • Err ImageLibCopyImageToFile (UInt16 libRef, UInt16 recIndex, FileHand fileH)
  • Err ImageLibInsertImageFromBuffer (UInt16 libRef, MemPtr bufP, UInt32 size, const char *name, UInt16 category, UInt16 *newRecIndexP)
  • Err ImageLibInsertImageFromFile (UInt16 libRef, FileHand fileH, const char *name, UInt16 category, UInt16 *newRecIndexP)
  • ImageIteratorHandle ImageLibIterateImages (UInt16 libRef, UInt16 category, UInt16 sortType, UInt16 *imageCountP, Err *errP)
  • ImageIteratorHandle ImageLibIterateVFSImages (UInt16 libRef, UInt16 volRefNum, const char *path, Boolean recurseBelow, UInt16 sortType, UInt16 *imageCount, Err *errP)
  • Err ImageLibIterSort (UInt16 libRef, ImageIteratorHandle iter, UInt16 sortType)
  • Err ImageLibIterGetImageInfo (UInt16 libRef, ImageIteratorHandle iter, UInt16 index, char *name, UInt16 nameLen, UInt16 *categoryP, UInt16 *recIndexP, UInt16 *volRefNumP, UInt32 *createdP, UInt32 *sizeP, char *path, UInt16 pathLen, Boolean *lockedP)
  • Err ImagelibIterGetCount (UInt16 libRef, ImageIteratorHandle iter, UInt16 *imageCountP)
  • Err ImageLibIterDeleteImage (UInt16 libRef, ImageIteratorHandle iter, UInt16 index)
  • Err ImageLibIterRemoveImage (UInt16 libRef, ImageIteratorHandle iter, UInt16 index)
  • Err ImageLibIterFree (UInt16 libRef, ImageIteratorHandle iter)
  • Err ImageLibIterDrawImage (UInt16 libRef, ImageIteratorHandle iter, UInt16 index, Coord x, Coord y)
  • Err ImageLibIterDrawThumbnail (UInt16 libRef, ImageIteratorHandle iter, UInt16 index, Coord x, Coord y)
  • Err ImageLibIterSearch (UInt16 libRef, ImageIteratorHandle iterH, const char *name, Boolean partialMatch, UInt16 *index)
  • void ImageLibSetProgressCallback (UInt16 libRef, ImageLibProgressCallbackType callback)
  • Err ImageLibCopyImage (UInt16 libRef, UInt16 recIndex, const char *newName, UInt16 *newRecIndexP)
  • Err ImageLibFindImageByID (UInt16 libRef, UInt32 uniqueID, UInt16 *recIndexP)
  • Err ImageLibPreviewStart (UInt16 libRef, void *windowH, Coord x, Coord y)
  • Err ImageLibPreviewStop (UInt16 libRef)
  • Err ImageLibDrawJPEG (UInt16 libRef, MemPtr jpegDataP, UInt32 jpegSize, Coord left, Coord top, Boolean fitToScreen, Coord width, Coord height)
  • Err ImageLibTurnCameraOff (UInt16 libRef)
  • Err ImageLibSetImageID (UInt16 libRef, UInt16 recIndex, const char *mediaIDP, const char *containerIDP)
  • Err ImageLibGetImageID (UInt16 libRef, UInt16 recIndex, char *mediaIDP, char *containerIDP)
  • Err ImageLibGetDimensions (UInt16 libRef, UInt16 recIndex, Coord *width, Coord *height, Boolean fitToDimensions)
  • Err ImageLibGetDimensionsVFS (UInt16 libRef, UInt16 volRefNum, const char *fileName, Coord *width, Coord *height, Boolean fitToDimensions)
  • Err ImageLibIterGetDimensions (UInt16 libRef, ImageIteratorHandle iter, UInt16 index, Coord *width, Coord *height, Boolean fitToDimensions)
  • Err ImageLibGetDimensionsJPEG (UInt16 libRef, MemPtr jpegDataP, UInt32 jpegSize, Coord *width, Coord *height, Boolean fitToDimensions)
  • Err ImageLibResize (UInt16 libRef, UInt16 recIndex, Coord *widthP, Coord *heightP, Boolean maintainAspectRatio)
  • Err ImageLibResizeVFS (UInt16 libRef, UInt16 volRefNum, const char *fileName, Coord *widthP, Coord *heightP, Boolean maintainAspectRatio)
  • Err ImageLibIterResize (UInt16 libRef, ImageIteratorHandle iter, UInt16 index, Coord *widthP, Coord *heightP, Boolean maintainAspectRatio)
  • Err ImageLibResizeJPEG (UInt16 libRef, MemPtr jpegInputP, UInt32 inputSize, Coord *widthP, Coord *heightP, Boolean maintainAspectRatio, MemPtr *outputPP, UInt32 *outputSizeP)
  • Err ImageLibIterRefresh (UInt16 libRef, ImageIteratorHandle iter, UInt16 index, const char *newVFSName)
  • Err ImageLibSetJPEGQuality (UInt16 libRef, Int32 value)
  • Int32 ImageLibGetJPEGQuality (UInt16 libRef)
  • Err ImageLibLockImage (UInt16 libRef, UInt16 recIndex)
  • Int32 ImageLibGetAveragePictureSize (UInt16 libRef, Boolean fullsize)
  • void ImageLibCheckLockedImages (UInt16 libRef, const Char *phoneNumber)

Function Documentation

Err ImageLibBitmapDelete | ( | UInt16 | libRef,
 |  | BitmapType * | bmp
 | ) |  |

Deletes a bitmap created by the library.

Use ImageLibBitmapDelete to delete any bitmap that was created and returned by the imaging library (ImageLibPreviewBitmapCreate, ImageLibImageBitmapCreate and ImageLibThumbnailBitmapCreate).

Parameters:
libRef,: IN: Library reference number.
bmp,: IN: Bitmap to delete.
Return values:
Err 0 on success, non-zero on error.

Err ImageLibCameraExists | ( | UInt16 | libRef,
 |  | Boolean * | existsP
 | ) |  |

Detects presence of camera driver.

The imaging library loads the camera driver dynamically. If the driver was found and was loaded successfully, ImageLibCameraExists writes true to existsP, otherwise it writes false.

This routine will attempt to load the camera driver if it hasn't already been loaded. The driver will remain loaded until the imaging library is unloaded, or until ImageLibTurnCameraOff is called.

See also:
ImageLibTurnCameraOff
Parameters:
libRef,: IN: Library reference number.
existsP,: OUT: true if camera successfully loaded. Otherwise false.
Return values:
Err 0 on success or error code on failure.

void ImageLibCheckLockedImages | ( | UInt16 | libRef,
 |  | const Char * | phoneNumber
 | ) |  |

Verifies the locked images match the given phone number. If they don't, all locked images are purged from the database.

Parameters:
libRef,: IN: Library reference number.
phoneNumber,: IN: String containing the phone number to verify against.

Err ImageLibClose ( UInt16 libRef )

Library close function for 68k clients of the library. This routine maps to the sysLibTrapClose trap.

This function is an empty stub (see comments for ImageLibOpen). All library cleanup is done from PilotMain.

This function is not available to ARM clients of the library.

See also:
ImageLibOpen
Parameters:
libRef,: IN: Library reference number.
Return values:
Err 0 on success or error code on failure.

Err ImageLibCopyImage | ( | UInt16 | libRef,
 |  | UInt16 | recIndex,
 |  | const char * | newName,
 |  | UInt16 * | newRecIndexP
 | ) |  |

Creates a copy of an image in the database.

Parameters:
libRef,: IN: Library reference number.
recIndex,: IN: Index of the image to copy.
newName,: IN: Name of the newly copied image.
newRecIndexP,: OUT: Index of the newly copied image. Pass NULL if you don't care about this value.
Return values:
Err 0 on success, non-zero on error.

Err ImageLibCopyImageFromVFS | ( | UInt16 | libRef,
 |  | UInt16 | volRefNum,
 |  | const char * | fileName,
 |  | const char * | name,
 |  | UInt16 | category,
 |  | UInt16 * | newRecIndexP
 | ) |  |

Copies an image from a VFS volume to the database.

volRefNum should be obtained via a call to VFSVolumeEnumerate

If a picture with a matching name and category already exists in the database, that image is not overwritten. After the call, there will be two images with the same name and category.

Parameters:
libRef,: IN: Library reference number.
volRefNum,: IN: Ref number of the VFS volume
fileName,: IN: Filename of the image (ie "/DCIM/picture001.jpg")
name,: IN: Name of the image in the database (ie "picture001")
category,: IN: Category that the image should be assigned to
newRecIndexP,: OUT: Record index of the newly stored picture. Pass NULL if you don't care what the new index is.
Return values:
Err 0 on success, non-zero on error.

Err ImageLibCopyImageToBuffer | ( | UInt16 | libRef,
 |  | UInt16 | recIndex,
 |  | MemPtr | bufP
 | ) |  |

Copies a JPEG from the image database to a chunk of memory at bufP. The allocated memory block must be large enough to hold the entire blob of JPEG data. The size of the JPEG can be determined with ImageLibGetImageInfo.

Fullsize images may requires that bufP be larger than 64 kB. Use FtrPtrNew or MemChunkNew to create buffers larger than 64 kB. Otherwise, consider using ImageLibCopyImageToFile instead.

See also:
ImageLibGetImageInfo

ImageLibCopyImageToFile

Parameters:
libRef,: IN: Library reference number.
recIndex,: IN: Index of the picture
bufP,: IN,OUT: Pointer to the block of memory that should receive the image.
Return values:
Err 0 on success, non-zero on error.

Err ImageLibCopyImageToFile | ( | UInt16 | libRef,
 |  | UInt16 | recIndex,
 |  | FileHand | fileH
 | ) |  |

Copies a JPEG from the image database to a Palm OS file stream. The library writes to the file stream at its current postion. When done, the library leaves the file handle pointing to the end of the file. To see the jpeg data, the file handle should be rewound to its original location.

Parameters:
libRef,: IN: Library reference number.
recIndex,: IN: Index of the picture
fileH,: IN: Handle to an open file stream.
Return values:
Err 0 on success, non-zero on error.

Err ImageLibCopyImageToVFS | ( | UInt16 | libRef,
 |  | UInt16 | recIndex,
 |  | UInt16 | volRefNum,
 |  | const char * | fileName
 | ) |  |

Copies an image from the database to a VFS volume.

Copies an image from the database to a VFS volume, overwriting any previous file that existed on the volume with the same name.

volRefNum should be obtained via a call to VFSVolumeEnumerate

Parameters:
libRef,: IN: Library reference number.
recIndex,: IN: Index of the picture
volRefNum,: IN: Ref number of the VFS volume
fileName,: IN: Filename of the image (ie "/DCIM/picture.jpg")
Return values:
Err 0 on success, non-zero on error.

Err ImageLibDeleteImage | ( | UInt16 | libRef,
 |  | UInt16 | recIndex
 | ) |  |

Delete a picture from the database.

This routine deletes an image and its thumbnail from the database.

Deleting a picture invalidates the record indices of all subsequent images in the database. Records are deleted with DmRemoveRecord. They are not archived.

Parameters:
libRef,: IN: Library reference number.
recIndex,: IN: index of image to delete.
Return values:
Err 0 on success, non-zero on error.

Err ImageLibDoAttachImageDialog | ( | UInt16 | libRef,
 |  | UInt16 * | recIndexP,
 |  | UInt16 * | volRefNumP,
 |  | char * | fileName,
 |  | UInt16 | initialCategory,
 |  | Boolean | showConfirmation,
 |  | Boolean | internalImagesOnly,
 |  | const char * | dialogTitle,
 |  | const char * | btnTitle
 | ) |  |

Displays the attach image dialog.

Displays the attach image dialog. Allows to user to select a picture from a list. After choosing an image, the selection is written to the output parameters recIndexP, volRefNum, and filename.

If the user cancels the dialog, the return value is still 0. The values in recIndexP and volRefNumP indicate that the dialog was cancelled.

Parameters:
libRef,: IN: Library reference number.
recIndexP,: OUT: If the user selects an image from the database, recIndexP will contain the index of the image. If the user selects an image from a VFS volume, or they cancel the dialog, or an error occurs, recIndexP will contain kInvalidRecIndex.
volRefNumP,: OUT: If the user selects an image from the VFS system, volRefNumP will contain the volume ref number of the selected image. In all other cases, volRefNumP will contain vfsInvalidVolRef.
fileName,: OUT: If the user selects an image from the VFS system, the full path of the file will be copied into fileNameP. fileName should be capable of holding the largest possible VFS filename. If the user does not select a VFS file, fileName[0] will be NULL.
initialCategory,: IN: The initial category that should be highlighted in the category dropdown. Pass 0 for unfiled. Pass dmAllCategories to show all pictures from the database.
showConfirmation,: IN: If true, a confirmation dialog will be displayed that shows the image in full size. If false, the confirmation dialog is skipped.
internalImagesOnly,: IN: If true, images from VFS volumes are not displayed to the user.
dialogTitle,: IN: The string to display as the title of the dialog. Pass null to display a localized default.
btnTitle,: IN: The string to display as the title of the OK button. Pass null to display a localized default.
Return values:
Err 0 on success, non-zero on error.

Err ImageLibDrawJPEG | ( | UInt16 | libRef,
 |  | MemPtr | jpegDataP,
 |  | UInt32 | jpegSize,
 |  | Coord | left,
 |  | Coord | top,
 |  | Boolean | fitToScreen,
 |  | Coord | width,
 |  | Coord | height
 | ) |  |

Decompresses a blob of JPEG data and draws it to the current draw window. The picture is drawn at left,top, which are relative to the draw window.

If the image needs to be resized, its aspect ratio is maintained. To determine how an image will be resized beforehand, call ImageLibGetDimensionsJPEG.

See also:
ImageLibGetDimensionsJPEG
Parameters:
libRef,: IN: Library reference number.
jpegDataP,: IN: Pointer to a JPEG image in memory.
jpegSize,: IN: Size of the source image in bytes.
left,: IN: x location to draw the image, relative to the current draw window.
top,: IN: y location to draw the image, relative to the current draw window.
fitToScreen,: IN: If true, the JPEG is resized to fit in a box defined by width and height. If false, image is not resized.
width,: IN: Max width of drawn image. Ignored if fitToScreen is false.
height,: IN: Max height of drawn image. Ignored if fitToScreen is false.
Return values:
Err 0 on success, non-zero on error.

Err ImageLibFindImageByID | ( | UInt16 | libRef,
 |  | UInt32 | uniqueID,
 |  | UInt16 * | recIndexP
 | ) |  |

Determines the record index of an image in the database given a unique ID. The image is found by calling DmFindRecordByID on the main database.

If you need to store a permanent reference to a picture in the database, it is best to store its unique ID. You can obtain the unique ID of an image by calling ImageLibGetImageInfo. To access an image by unique ID, call ImageLibFindImageByID to retrieve the record index, and then use the record index to access the picture.

See also:
ImageLibGetImageInfo
Parameters:
libRef,: IN: Library reference number.
uniqueID,: IN: Unique ID of the image to find.
recIndexP,: OUT: Record index of the image.
Return values:
Err 0 on success, non-zero on error.

Int32 ImageLibGetAveragePictureSize | ( | UInt16 | libRef,
 |  | Boolean | fullsize
 | ) |  |

Returns the average size that a picture will be at the current compression factor.

Parameters:
libRef,: IN: Library reference number.
fullsize,: IN: True to return average of last 20 fullsize captures. False to return average of palm size captures.
Return values:
Int32 0 Average size.

Err ImageLibGetDimensions | ( | UInt16 | libRef,
 |  | UInt16 | recIndex,
 |  | Coord * | width,
 |  | Coord * | height,
 |  | Boolean | fitToDimensions
 | ) |  |

Retrieves the dimensions of an image in the database.

This routine allows clients of the library to query the dimensions of an image in the database. If fitToDimensions is false, the routine copies the full dimensions of the image to widthP and heightP. The initial values of widthP and heightP are ignored. If fitToDimensions is true, the routine calculates how big the image will be after it is downsized to fit in a box determined by the initial values of widthP and heightP.

Parameters:
libRef,: IN: Library reference number.
recIndex,: IN: Index of image.
width,: IN,OUT: On output, contains the width of the image. On input, if fitToDimensions is true, determines the max width that the image should be.
height,: IN,OUT: On output, contains the height of the image. On input, if fitToDimensions is true, determines the max height that the image should be.
fitToDimensions,: IN: If true, tells the library to return the dimensions that an image would be if it was forced to draw in a box bounded by widthP and heightP.
Return values:
Err 0 on success, non-zero on error.

Err ImageLibGetDimensionsJPEG | ( | UInt16 | libRef,
 |  | MemPtr | jpegDataP,
 |  | UInt32 | jpegSize,
 |  | Coord * | width,
 |  | Coord * | height,
 |  | Boolean | fitToDimensions
 | ) |  |

Retrieves the dimensions of a blob of JPEG data in memory.

This routine allows clients of the library to query the dimensions of an arbitrary blob of JPEG data. The routine follows the same semantics as ImageLibGetDimensions.

See also:
ImageLibGetDimensions
Parameters:
libRef,: IN: Library reference number.
jpegDataP,: IN: Pointer to a JPEG image in memory.
jpegSize,: IN: Size of the source image in bytes.
width,: IN,OUT: On output, contains the width of the image. On input, if fitToDimensions is true, determines the max width that the image should be.
height,: IN,OUT: On output, contains the height of the image. On input, if fitToDimensions is true, determines the max height that the image should be.
fitToDimensions,: IN: If true, tells the library to return the dimensions that an image would be if it was forced to draw in a box bounded by widthP and heightP.
Return values:
Err 0 on success, non-zero on error.

Err ImageLibGetDimensionsVFS | ( | UInt16 | libRef,
 |  | UInt16 | volRefNum,
 |  | const char * | fileName,
 |  | Coord * | width,
 |  | Coord * | height,
 |  | Boolean | fitToDimensions
 | ) |  |

Retrieves the dimensions of an image on a VFS volume.

This routine allows clients of the library to query the dimensions of an image that resides on a VFS volume. The routine follows the same semantics as ImageLibGetDimensions.

See also:
ImageLibGetDimensions
Parameters:
libRef,: IN: Library reference number.
volRefNum,: IN: Ref number of the VFS volume
fileName,: IN: Filename of the image (ie "/DCIM/picture.jpg")
width,: IN,OUT: On output, contains the width of the image. On input, if fitToDimensions is true, determines the max width that the image should be.
height,: IN,OUT: On output, contains the height of the image. On input, if fitToDimensions is true, determines the max height that the image should be.
fitToDimensions,: IN: If true, tells the library to return the dimensions that an image would be if it was forced to draw in a box bounded by widthP and heightP.
Return values:
Err 0 on success, non-zero on error.

Err ImageLibGetImageDatabases | ( | UInt16 | libRef,
 |  | DmOpenRef * | dbMainP,
 |  | DmOpenRef * | dbNoteP,
 |  | DmOpenRef * | dbImageP
 | ) |  |

Return the references to the database that are used to store pictures.

The image library opens each database when it is loaded, and closes them when it is unloaded. Do not close the database references that are returned by this function because the references are still being used by the imaging library.

The data in each database is stored in little endian format.

The main database contains one record for each image in the database. Each record has a fixed size and contains information about the picture. The image database contains the actual JPEG data for each image. The main database acts as a master table and the images database is a child table.

The notes database is not currently used.

The category of an image is determined by the category of its record in the main database. Categories are not used in the image table.

Parameters:
libRef,: IN: Library reference number.
dbMainP,: OUT: Reference to the main database. Pass NULL for this parameter if you don’t want to retrieve it.
dbNoteP,: OUT: Reference to the note database. Pass NULL for this parameter if you don’t want to retrieve it.
dbImageP,: OUT: Reference to the images database.
Return values:
Err 0 on success, non-zero on error.

Err ImageLibGetImageID | ( | UInt16 | libRef,
 |  | UInt16 | recIndex,
 |  | char * | mediaIDP,
 |  | char * | containerIDP
 | ) |  |

Gets the media and container IDs for an image in the database.

The media ID and container ID should both be at least 21 bytes in size. The library copies 21 bytes to the supplied buffers.

See also:
ImageLibSetImageID
Parameters:
libRef,: IN: Library reference number.
recIndex,: IN: Index of image.
mediaIDP,: IN: Media ID.
containerIDP,: IN: Container ID.
Return values:
Err 0 on success, non-zero on error.

Err ImageLibGetImageInfo | ( | UInt16 | libRef,
 |  | UInt16 | recIndex,
 |  | Char * | name,
 |  | Boolean * | fullSizeP,
 |  | UInt32 * | createdP,
 |  | UInt32 * | sizeP,
 |  | UInt16 * | categoryP,
 |  | Char * | categoryName,
 |  | Boolean * | lockedP,
 |  | UInt32 * | uidP
 | ) |  |

Retrieves information about an image stored in the database.

Parameters:
libRef,: IN: Library reference number.
recIndex,: IN: Index of the picture
name,: OUT: Buffer to receive the name of the image. The buffer should be at least 32 characters long (31 + null terminator). Pass NULL for this parameter if you don't want to retrieve it.
fullSizeP,: OUT: true if image is 640x480, false if palm size. Pass NULL for this parameter if you don't want to retrieve it.
createdP,: OUT: Timestamp when picture was creatd. Pass NULL for this parameter if you don't want to retrieve it.
sizeP,: OUT: Size of the image data in bytes. Pass NULL for this parameter if you don't want to retrieve it.
categoryP,: OUT: Category that that picture is assigned to. Pass NULL for this parameter if you don't want to retrieve it.
categoryName,: OUT: Text description of the picture's category (ie 'Unfiled'). Pass NULL for this parameter if you don't want to retrieve it.
lockedP,: OUT: true if image is locked.
uidP,: OUT: Unique ID of the image.
Return values:
Err 0 on success, non-zero on error.

Int32 ImageLibGetJPEGQuality ( UInt16 libRef )

Returns the compression factor used for JPEG compression operations.

Parameters:
libRef,: IN: Library reference number.
Return values:
Int32 Compression value. [1,99]

Err ImageLibGetVersion | ( | UInt16 | libRef,
 |  | UInt32 * | dwVerP
 | ) |  |

Retrieves the version number of the image library.

Parameters:
libRef,: IN: Library reference number.
dwVerP,: OUT: Pointer to library version variable.
Return values:
Err 0 on success or error code on failure.

BitmapType* ImageLibImageBitmapCreate | ( | UInt16 | libRef,
 |  | UInt16 | recIndex,
 |  | Err * | errP
 | ) |  |

Creates a 16 bit bitmap for holding an image from the database. If recIndex is a valid image index, that image is loaded into the resulting bitmap. Otherwise, the result is an empty picture.

When called from a 68k application, the return value should be treated as opaque. The bitmap can safely be passed to the Palm OS bitmap routines, but 68k applications should not attempt to dereference members of the bitmap structure directly.

Bitmaps created with this function should be disposed of by calling ImageLibBitmapDelete. Do note call BmpDelete or MemPtrFree.

If an error occurs, this function returns NULL and writes an error code to errP. If the function returns a non-NULL bitmap value, then *errP will always be 0.

If recIndex is kInvalidRecIndex, the result is an empty 160x120 bitmap. If recIndex is not kInvalidRecIndex, the result is a bitmap that contains the given image from the database. The returned bitmap will be 160x120 if the image in the database is 160x120, 320x240, 640x480, or any other image larger than 160x120 with a 4:3 aspect ratio. If the image has a non-standard size, it is downsized to fit in a 160x120 box. The aspect ratio of the picture is preserved. Images that are less than 160x120 are not scaled at all.

See also:
ImageLibBitmapDelete

ImageLibPreviewStop

ImageLibPreviewStart

Parameters:
libRef,: IN: Library reference number.
recIndex,: IN: Index of image to fill bitmap with. Use kInvalidRecIndex to create an empty 160x120, 16 bit bitmap.
errP,: OUT: If the function succeeds, 0 is written to errP. Otherwise, a non-zero error code is written. This parameter should not be NULL.
Return values:
BitmapType* On success, the result is a new bitmap with a bit depth of 16. On error, the result is NULL.

BitmapType* ImageLibImageBitmapCreateFromVFS | ( | UInt16 | libRef,
 |  | UInt16 | volRefNum,
 |  | const char * | fileName,
 |  | Err * | errP
 | ) |  |

Creates a 16 bit bitmap for holding an image from a VFS volume. The library decompresses the image from the volume and stores it in the result.

When called from a 68k application, the return value should be treated as opaque. The bitmap can safely be passed to the Palm OS bitmap routines, but 68k applications should not attempt to dereference members of the bitmap structure directly.

Bitmaps created with this function should be disposed of by calling ImageLibBitmapDelete. Do note call BmpDelete or MemPtrFree.

If an error occurs, this function returns NULL and writes an error code to errP. If the function returns a non-NULL bitmap value, then *errP will always be 0.

The picture is always resized to fit in a 160x120 box. If the image needs to be resized, its aspect ratio is maintained.

See also:
ImageLibBitmapDelete
Parameters:
libRef,: IN: Library reference number.
volRefNum,: IN: Ref number of the VFS volume
fileName,: IN: Filename of the image (ie "/DCIM/picture.jpg")
errP,: OUT: If the function succeeds, 0 is written to errP. Otherwise, a non-zero error code is written. This parameter should not be NULL.
Return values:
BitmapType* On success, the result is a new bitmap with a bit depth of 16. On error, the result is NULL.

Err ImageLibImageBitmapFill | ( | UInt16 | libRef,
 |  | UInt16 | recIndex,
 |  | BitmapType * | imageP
 | ) |  |

Fills a bitmap with an image from the database.

The imageP argument should represent a bitmap created with ImageLibImageBitmapCreate.

The image from the database is resampled as necessary to fit the dimensions of imageP. When the image is a jpeg, the DCT scaling features of the IJG library are used to get the image size close to the destination size. From there, the image is resampled with a filter to match the dimensions of imageP. If the aspect ratio of imageP does not match the aspect ratio of the picture, the picture is stretched to fit.

See also:
ImageLibImageBitmapCreate

ImageLibBitmapDelete

Parameters:
libRef,: IN: Library reference number.
recIndex,: IN: index of image to fill bitmap with.
imageP,: IN,OUT: Bitmap to fill.
Return values:
Err 0 on success, non-zero on error.

Err ImageLibImageBitmapFillFromVFS | ( | UInt16 | libRef,
 |  | UInt16 | volRefNum,
 |  | const char * | fileName,
 |  | BitmapType * | imageP
 | ) |  |

Fills a 16 bit bitmap with an image from a VFS volume. The library decompresses the image from the volume and stores it in the supplied bitmap. The image is resized to fit the dimensions of the supplied bitmap.

The imageP argument should represent a bitmap created with ImageLibImageBitmapCreate or ImageLibImageBitmapCreateFromVFS.

The image is resampled as necessary to fit the dimensions of imageP. When the image is a jpeg, the DCT scaling features of the IJG library are used to get the image size close to the destination size. From there, the image is resampled with a filter to match the dimensions of imageP. If the aspect ratio of imageP does not match the aspect ratio of the picture, the picture is stretched to fit.

See also:
ImageLibImageBitmapCreate

ImageLibImageBitmapCreateFromVFS

ImageLibBitmapDelete

Parameters:
libRef,: IN: Library reference number.
volRefNum,: IN: Ref number of the VFS volume
fileName,: IN: Filename of the image (ie "/DCIM/picture001.jpg")
imageP,: IN,OUT: Bitmap to fill.
Return values:
Err 0 on success, non-zero on error.

Err ImageLibImageCapture | ( | UInt16 | libRef,
 |  | Boolean | fullsize,
 |  | Boolean | playShutterSound,
 |  | Boolean | drawImmediately,
 |  | Coord | x,
 |  | Coord | y,
 |  | UInt16 * | newRecNoP
 | ) |  |

Captures an image and stores it in the database.

Images are appended to the end of the database.

The camera driver always captures 640x480 images. If fullSize is false, the data from the camera is downsampled to 160x120 using a filtering algorithm.

Captures are currently done in 16 bit RGB mode. Capturing an image requires at least 600 kB of free space in the dynamic heap (640x480x2).

Captured pictures are stored in uncompressed palmOS bitmap format. To compress an image as a JPEG, call ImageLibImageSave.

See also:
ImageLibImageSave
Parameters:
libRef,: IN: Library reference number.
fullsize,: IN: true capture a 640x480 image. false to capture 160x120
playShutterSound,: IN: true to play a camera shutter sound.
drawImmediately,: IN: true to immediately draw the captured image to the current draw window.
x,: IN: x location to draw the captured image. Relative to the current draw window. Ignored if drawImmediately is false.
y,: IN: y location to draw the captured image. Relative to the current draw window. Ignored if drawImmediately is false.
newRecNoP,: OUT: index of the new image. If the capture fails, kInvalidRecIndex is written to this value. Pass NULL if you don’t care what the new index is.
Return values:
Err 0 on success or error code on failure.

Err ImageLibImageDraw | ( | UInt16 | libRef,
 |  | UInt16 | recIndex,
 |  | Coord | x,
 |  | Coord | y
 | ) |  |

Draws an image from the database to the current draw window.

Draws an image from the database to the current draw window at x,y. x and y are window relative coordinates.

If necessary, the image is downsized to fit in a 160x120 box. The aspect ratio of the picture is preserved.

Parameters:
libRef,: IN: Library reference number.
recIndex,: IN: index of image to draw.
x,: IN: x location to draw the preview image, relative to the current draw window.
y,: IN: y location to draw the preview image, relative to the current draw window.
Return values:
Err 0 on success, non-zero on error.

Err ImageLibImageDrawFromVFS | ( | UInt16 | libRef,
 |  | UInt16 | volRefNum,
 |  | const char * | fileName,
 |  | Coord | x,
 |  | Coord | y
 | ) |  |

Draws an image from from a VFS volume to the current draw window at x,y. x and y are window relative coordinates.

If necessary, the image is downsized to fit in a 160x120 box. The aspect ratio of the picture is preserved.

Parameters:
libRef,: IN: Library reference number.
volRefNum,: IN: Ref number of the VFS volume
fileName,: IN: Filename of the image (ie "/DCIM/picture001.jpg")
x,: IN: x location to draw the image, relative to the current draw window.
y,: IN: y location to draw the image, relative to the current draw window.
Return values:
Err 0 on success, non-zero on error.

Err ImageLibImageSave | ( | UInt16 | libRef,
 |  | UInt16 | recIndex,
 |  | const char * | name,
 |  | UInt16 | category
 | ) |  |

Compresses a captured image to JPEG format.

Compresses a captured image to JPEG, sets the image name, and sets the category of the picture. After saving, the uncompressed bitmap data is discarded and replaced with the JPEG version of the image.

This routine should only be invoke on newly captured images, and it should only be called once per picture.

See also:
ImageLibImageCapture
Parameters:
libRef,: IN: Library reference number.
recIndex,: IN: Index of the image to compress.
name,: IN: Name of the picture
category,: IN: Category to store the image in
Return values:
Err 0 on success or error code on failure.

Err ImageLibInsertImageFromBuffer | ( | UInt16 | libRef,
 |  | MemPtr | bufP,
 |  | UInt32 | size,
 |  | const char * | name,
 |  | UInt16 | category,
 |  | UInt16 * | newRecIndexP
 | ) |  |

Inserts a JPEG blob into the image database, storing it with the supplied name and category.

Parameters:
libRef,: IN: Library reference number.
bufP,: IN: Pointer to a JPEG image in memory.
size,: IN: Size of the source image in bytes.
name,: IN: Name of the new image (ie "Picture001")
category,: IN: The category to store the image in. Pass 0 for unfiled.
newRecIndexP,: OUT: Index of the newly created image. Pass NULL if you don’t care about this value.
Return values:
Err 0 on success, non-zero on error.

Err ImageLibInsertImageFromFile | ( | UInt16 | libRef,
 |  | FileHand | fileH,
 |  | const char * | name,
 |  | UInt16 | category,
 |  | UInt16 * | newRecIndexP
 | ) |  |

Insert an image into the database from a Palm OS file stream. The file stream is read from its current position to the end of the stream. When the routine is finished, it leaves the stream open and performs a FileSeek back to the original position.

Parameters:
libRef,: IN: Library reference number.
fileH,: IN: Handle to an open file stream that contains a JPEG starting at its current position.
name,: IN: Name of the new image (ie "Picture001")
category,: IN: The category to store the image in. Pass 0 for unfiled.
newRecIndexP,: OUT: Index of the newly created image. Pass NULL if you don’t care about this value.
Return values:
Err 0 on success, non-zero on error.

ImageIteratorHandle ImageLibIterateImages | ( | UInt16 | libRef,
 |  | UInt16 | category,
 |  | UInt16 | sortType,
 |  | UInt16 * | imageCountP,
 |  | Err * | errP
 | ) |  |

Creates an iterator for working with a collection of images in the database. When finished, the iterator refers to a data structure that contains images The iterator can be used to step through images, draw images, sort images, and search for images by name.

The returned iterator handle can be passed to other iterator routines that take an iterator handle. The handle should be freed by calling ImageLibIterFree.

See also:
ImageLibIterFree
Parameters:
libRef,: IN: Library reference number.
category,: IN: The category to search. Pass 0 for unfiled. Pass dmAllCategories to iterate through all images in the databse.
sortType,: IN: Initial sort order of the datastructure (kNoSortOrder, kSortByName, or kSortByDate)
imageCountP,: OUT: Number of images in the iterator data structure. Pass NULL if you don't care about this value.
errP,: OUT: 0 on success, non-zero on error. This parameter should not be null.
Return values:
ImageIteratorHandle Opaque iterator handle.

ImageIteratorHandle ImageLibIterateVFSImages | ( | UInt16 | libRef,
 |  | UInt16 | volRefNum,
 |  | const char * | path,
 |  | Boolean | recurseBelow,
 |  | UInt16 | sortType,
 |  | UInt16 * | imageCount,
 |  | Err * | errP
 | ) |  |

Creates an iterator for working with a collection of images on a VFS volume. When finished, the iterator refers to a data structure that contains images. The iterator can be used to step through images, draw images, sort images, and search for images by name.

The returned iterator handle can be passed to other iterator routines that take an iterator handle. The handle should be freed by calling ImageLibIterFree.

See also:
ImageLibIterFree
Parameters:
libRef,: IN: Library reference number.
volRefNum,: IN: VFS volume to search.
path,: IN: Directory to start searching in.
recurseBelow,: IN: true to recurse in all subdirectories of path. false to search in path only.
sortType,: IN: Initial sort order of the datastructure (kNoSortOrder, kSortByName, or kSortByDate)
imageCount,: OUT: Number of images in the iterator data structure. Pass NULL if you don't care about this value.
errP,: OUT: 0 on success, non-zero on error. This parameter should not be null.
Return values:
ImageIteratorHandle Opaque iterator handle.

Err ImageLibIterDeleteImage | ( | UInt16 | libRef,
 |  | ImageIteratorHandle | iter,
 |  | UInt16 | index
 | ) |  |

Deletes an image (either from the database or from a VFS volume)

Permanently deletes an image given a reference to the image in an iterator. Given an iterator and an index to an image in the iterator, this routine determines whether the image resides in the internal database or on a VFS volume. If it resides on a VFS volume, the routine attempts to delete it by calling VFSFileDelete. If it is an internal image, the picture is nuked by calling ImageLibDeleteImage. After the image is deleted, it is removed from the iterator chain. All subsequent images in the iterator data structure move down one spot. The count of images in the iterator chain is decremented by one.

The iterator handle should be created with ImageLibIterateImages or ImageLibIterateVFSImages.

Deleting an image invalidates the iterator index for all subsequent images in the iterator chain. If you need to delete a range of images in an iterator, it is best to loop from back to front.

Parameters:
libRef,: IN: Library reference number.
iter,: IN: Handle to an iterator.
index,: IN: Index of the image to delete. This is an index into the iterator, not an index to the image database.
Return values:
Err 0 on success, non-zero on error.

Err ImageLibIterDrawImage | ( | UInt16 | libRef,
 |  | ImageIteratorHandle | iter,
 |  | UInt16 | index,
 |  | Coord | x,
 |  | Coord | y
 | ) |  |

Draws an image in an iterator chain to the current draw window at x,y. x and y are window relative coordinates.

If the image resides in the internal database, this routine calls ImageLibImageDraw to draw it. If it is a VFS image the call is dispatched to ImageLibImageDrawFromVFS

Parameters:
libRef,: IN: Library reference number.
iter,: IN: Handle to an iterator.
index,: IN: Index of the image to draw. This is an index into the iterator, not an index to the image database.
x,: IN: x location to draw the preview image, relative to the current draw window.
y,: IN: y location to draw the preview image, relative to the current draw window.
Return values:
Err 0 on success, non-zero on error.

Err ImageLibIterDrawThumbnail | ( | UInt16 | libRef,
 |  | ImageIteratorHandle | iter,
 |  | UInt16 | index,
 |  | Coord | x,
 |  | Coord | y
 | ) |  |

Draws a thumbnail for an image in an iterator chain to the current draw window at x,y. x and y are window relative coordinates.

If the image resides in the internal database, this routine calls ImageLibThumbnailDraw to draw it. If it is a VFS image the call is dispatched to ImageLibThumbnailDrawFromVFS

Parameters:
libRef,: IN: Library reference number.
iter,: IN: Handle to an iterator.
index,: IN: Index of the image to draw. This is an index into the iterator, not an index to the image database.
x,: IN: x location to draw the preview image, relative to the current draw window.
y,: IN: y location to draw the preview image, relative to the current draw window.
Return values:
Err 0 on success, non-zero on error.

Err ImageLibIterFree | ( | UInt16 | libRef,
 |  | ImageIteratorHandle | iter
 | ) |  |

Frees the memory associated with an iterator chain.

The iterator handle should be created with ImageLibIterateImages or ImageLibIterateVFSImages.

Once the iterator has been freed, it should not be used anymore.

Parameters:
libRef,: IN: Library reference number.
iter,: IN: Handle to an iterator.
Return values:
Err 0 on success, non-zero on error.

Err ImagelibIterGetCount | ( | UInt16 | libRef,
 |  | ImageIteratorHandle | iter,
 |  | UInt16 * | imageCountP
 | ) |  |

Retrieves the number of images stored in the iterator data structure.

The iterator handle should be created with ImageLibIterateImages or ImageLibIterateVFSImages.

Iterator routines that take an index should ensure that the index is less than the value returned in imageCountP.

See also:
ImageLibIterateImages

ImageLibIterateVFSImages

Parameters:
libRef,: IN: Library reference number.
iter,: IN: Handle to an iterator.
imageCountP,: OUT: Number of images in the iterator data structure.
Return values:
Err 0 on success, non-zero on error.

Err ImageLibIterGetDimensions | ( | UInt16 | libRef,
 |  | ImageIteratorHandle | iter,
 |  | UInt16 | index,
 |  | Coord * | width,
 |  | Coord * | height,
 |  | Boolean | fitToDimensions
 | ) |  |

Retrieves the dimensions of an image in an iterator chain.

This routine allows clients of the library to query the dimensions of an image in an iterator chain. The routine follows the same semantics as ImageLibGetDimensions.

See also:
ImageLibGetDimensions
Parameters:
libRef,: IN: Library reference number.
iter,: IN: Iterator handle
index,: IN: Index of the image in the iterator. [0,imageCount)
width,: IN,OUT: On output, contains the width of the image. On input, if fitToDimensions is true, determines the max width that the image should be.
height,: IN,OUT: On output, contains the height of the image. On input, if fitToDimensions is true, determines the max height that the image should be.
fitToDimensions,: IN: If true, tells the library to return the dimensions that an image would be if it was forced to draw in a box bounded by widthP and heightP.
Return values:
Err 0 on success, non-zero on error.

Err ImageLibIterGetImageInfo | ( | UInt16 | libRef,
 |  | ImageIteratorHandle | iter,
 |  | UInt16 | index,
 |  | char * | name,
 |  | UInt16 | nameLen,
 |  | UInt16 * | categoryP,
 |  | UInt16 * | recIndexP,
 |  | UInt16 * | volRefNumP,
 |  | UInt32 * | createdP,
 |  | UInt32 * | sizeP,
 |  | char * | path,
 |  | UInt16 | pathLen,
 |  | Boolean * | lockedP
 | ) |  |

Retrieves information about a single image in an iterator chain.

The iterator handle should be created with ImageLibIterateImages or ImageLibIterateVFSImages.

Pass NULL for any OUT parameter that you don't care about.

See also:
ImageLibIterateImages

ImageLibIterateVFSImages

Parameters:
libRef,: IN: Library reference number.
iter,: IN: Handle to an iterator.
index,: IN: Index of the image in the iterator. [0,imageCount)
name,: OUT: Buffer to receive the name of the image. For VFS images, this is the full path and filename of the image (ie "/dcim/picture001.jpg"). For internal images, this is the name of the picture (ie "Picture001")
nameLen,: IN: Size in bytes of the name buffer.
categoryP,: OUT: Category of the picture if it is stored in the image database. 0xFF if it is a VFS picture.
recIndexP,: OUT: Record index of the picture if it is stored in the image database. kInvalidRecIndex if it is a VFS picture.
volRefNumP,: OUT: VFS volume ref number of the picture if it is stored on a VFS volume. vfsInvalidVolRef if it is stored in the internal database.
createdP,: OUT: Timestamp when picture was creatd. Pass NULL for this parameter if you don't want to retrieve it.
sizeP,: OUT: Size of the image data in bytes. Pass NULL for this parameter if you don't want to retrieve it.
path,: OUT: Directory that the picture is stored in if it is a VFS image (ie /DCIM). Empty string if it is an internal image.
pathLen,: IN: Size in bytes of the path buffer.
lockedP,: OUT: true if the image is locked. False otherwise. VFS images are never locked.
Return values:
Err 0 on success, non-zero on error.

Err ImageLibIterRefresh | ( | UInt16 | libRef,
 |  | ImageIteratorHandle | iter,
 |  | UInt16 | index,
 |  | const char * | newVFSName
 | ) |  |

Refreshes the information for an image in an iterator chain. If the image is stored in the image database, this routine updates the name, recIndex, category, size, timestamp, and locked status of the image. If it is a VFS picture, this routine updates the timestamp and size of the picture.

Call this function when an iterator refers to an image that has changed since the iterator was created. For example, if you downsize or resize an iternal image, call ImageLibIterRefresh to update the iterator information for that image.

If you rename a VFS picture that is referenced by an iterator chain, you can pass its new name for the newVFSName argument. Pass the full path and filename of the image. If you pass a string for this argument, the name of file in the iterator chain will be updated. Pass NULL for the newVFSName parameter if the iterator image refers to an internal picture or a VFS picture that whose name has not been changed (If you don't know what this is about, pass NULL).

Parameters:
libRef,: IN: Library reference number.
iter,: IN: Handle to an iterator.
index,: IN: Index of the image in the iterator. [0,imageCount)
newVFSName,: IN: If picture is a VFS file, pass its new name for this parameters
Return values:
Err 0 on success, non-zero on error.

Err ImageLibIterRemoveImage | ( | UInt16 | libRef,
 |  | ImageIteratorHandle | iter,
 |  | UInt16 | index
 | ) |  |

Removes an image from an iterator chain without deleting it from its original location.

Removes an image from an iterator chain without deleting it from its original location. Once an image is removed, it can no longer be accessed via the iterator. However, the image is still accessible from its original location (either in the image database or on a VFS card).

The iterator handle should be created with ImageLibIterateImages or ImageLibIterateVFSImages.

Removing an image invalidates the iterator index for all subsequent images in the iterator chain. If you need to remove a range of images in an iterator, it is best to loop from back to front.

Parameters:
libRef,: IN: Library reference number.
iter,: IN: Handle to an iterator.
index,: IN: Index of the image to remove. This is an index into the iterator, not an index to the image database.
Return values:
Err 0 on success, non-zero on error.

Err ImageLibIterResize | ( | UInt16 | libRef,
 |  | ImageIteratorHandle | iter,
 |  | UInt16 | index,
 |  | Coord * | widthP,
 |  | Coord * | heightP,
 |  | Boolean | maintainAspectRatio
 | ) |  |

Resizes an image in an iterator chain.

This routine resizes an image in an iterator chain to any size. The routine follows the same semantics as ImageLibResize.

See also:
ImageLibResize
Parameters:
libRef,: IN: Library reference number.
iter,: IN: Iterator handle
index,: IN: Index of the image in the iterator. [0,imageCount)
widthP,: IN/OUT: On output, contains the new width of the image. On input, if maintainAspectRatio is true, determines the max width that the image should be. If maintainAspectRatio is false, determines the exact width that the image should be after resizing.
heightP,: IN/OUT: On output, contains the new width of the image. On input, if maintainAspectRatio is true, determines the max width that the image should be. If maintainAspectRatio is false, determines the exact width that the image should be after resizing.
maintainAspectRatio,: IN: If true, tells the library to maintain the aspect ratio of the image. In this case, the input values of widthP and heightP serve as maximum guidelines. If false, the image is stretched to fit the input values of widthP and heightP. the dimensions that an image would be if it was forced to draw in a box bounded by widthP and heightP.
Return values:
Err 0 on success, non-zero on error.

Err ImageLibIterSearch | ( | UInt16 | libRef,
 |  | ImageIteratorHandle | iterH,
 |  | const char * | name,
 |  | Boolean | partialMatch,
 |  | UInt16 * | index
 | ) |  |

Searches for an image in an iterator chain by name. To match, a picture's name must the name string starting in the first character. If partical match is true, then the entire string must match. Case is ignored for all comparisons. Pattern matching and wildcards are not supported.

Parameters:
libRef,: IN: Library reference number.
iterH,: IN: Handle to an iterator.
name,: IN: String to search for.
partialMatch,: IN: If true, only the beginning of a picture name must match. If false, the entire name must match.
index,: OUT: Contains the index of the first picture that matches the search string. kInvalidRecIndex if no match found.
Return values:
Err 0 on success, non-zero on error.

Err ImageLibIterSort | ( | UInt16 | libRef,
 |  | ImageIteratorHandle | iter,
 |  | UInt16 | sortType
 | ) |  |

Sorts the images in an iterator chain. Note that this only reorganizes images in the iterator data structure. This does not alter the way images are stored in the database or on a card. images, sort images, and search for images by name.

The iterator handle should be created with ImageLibIterateImages or ImageLibIterateVFSImages.

See also:
ImageLibIterateImages

ImageLibIterateVFSImages

Parameters:
libRef,: IN: Library reference number.
iter,: IN: Handle to an iterator.
sortType,: IN: New sort order of the datastructure (kNoSortOrder, kSortByName, kSortByDate, kSortByNameDesc, or kSortByDateDesc)
Return values:
Err 0 on success, non-zero on error.

Err ImageLibLockImage | ( | UInt16 | libRef,
 |  | UInt16 | recIndex
 | ) |  |

Returns the compression factor used for JPEG compression operations.

Once an image is locked, it is locked forever and can't be unlocked.

Parameters:
libRef,: IN: Library reference number.
recIndex,: IN: Index of the image to compress.
Return values:
Err 0 on success, non-zero on error.

Err ImageLibOpen ( UInt16 libRef )

Library open call for 68k clients of the library. This routine maps to the sysLibTrapOpen trap.

It is customary for shared libraries to provide open and close functions. The open and close functions in ImageLib are empty stubs that exist for the sole purpose of adhering to past convention. This function does nothing and will always return errNone. All library initialization is done from PilotMain.

This function is not available to ARM clients of the library.

Parameters:
libRef,: IN: Library reference number.
Return values:
Err 0 on success or error code on failure.

BitmapType* ImageLibPreviewBitmapCreate | ( | UInt16 | libRef,
 |  | Err * | errP
 | ) |  |

Creates a preview bitmap. If Compresses a captured image to JPEG, sets the image name, and sets the category of the picture. After saving, the uncompressed bitmap data is discarded and replaced with the JPEG version of the image.

When called from a 68k application, the return value should be treated as opaque. The bitmap can safely be passed to the Palm OS bitmap routines, but 68k applications should not attempt to dereference members of the bitmap structure directly.

Bitmaps created with this function should be disposed of by calling ImageLibBitmapDelete. Do note call BmpDelete or MemPtrFree.

If an error occurs, this function returns NULL and writes an error code to errP. If the function returns a non-NULL bitmap value, then *errP will always be 0.

This function does not perform an image preview. The resulting bitmap is empty. To fill the bitmap with a preview image, pass it to ImageLibPreviewBitmapFill.

See also:
ImageLibPreviewBitmapFill

ImageLibBitmapDelete

Parameters:
libRef,: IN: Library reference number.
errP,: OUT: 0 on success, non-zero on error. This parameter should not be null.
Return values:
BitmapType On success, the result is a new 160x120 bitmap whose bit depth matches the bit depth of the screen. On failure, the result is NULL

Err ImageLibPreviewBitmapFill | ( | UInt16 | libRef,
 |  | BitmapType * | imageP
 | ) |  |

Fills a bitmap with a preview image from the camera.

The imageP argument should represent a bitmap created with ImageLibPreviewBitmapCreate.

See also:
ImageLibPreviewBitmapCreate

ImageLibBitmapDelete

ImageLibPreviewStop

ImageLibPreviewStart

Parameters:
libRef,: IN: Library reference number.
imageP,: IN,OUT: Bitmap to fill with a preview.
Return values:
Err 0 on success, non-zero on error.

Err ImageLibPreviewDraw | ( | UInt16 | libRef,
 |  | Coord | x,
 |  | Coord | y
 | ) |  |

Draws a preview image to the current draw window.

Snaps a preview image with the camera driver and then draws it to the current draw window at x,y. x and y are relative coordinates.

See also:
ImageLibPreviewStop

ImageLibPreviewStart

Parameters:
libRef,: IN: Library reference number.
x,: IN: x location to draw the preview image, relative to the current draw window.
y,: IN: y location to draw the preview image, relative to the current draw window.
Return values:
Err 0 on success, non-zero on error.

Err ImageLibPreviewStart | ( | UInt16 | libRef,
 |  | void * | windowH,
 |  | Coord | x,
 |  | Coord | y
 | ) |  |

Turns on the direct draw preview mode of the camera.

This routine serves as a front end to the camera driver's CameraLibPreviewStart function. After being called, the camera will display preview images to the supplied window at the given coordinates.

See also:
ImageLibPreviewStop
Parameters:
libRef,: IN: Library reference number.
windowH,: IN: Window handle where preview images should be drawn. This should generally be a screen window.
x,: IN: x location to draw the preview image. Relative to windowH.
y,: IN: y location to draw the preview image. Relative to windowH.
Return values:
Err 0 on success, non-zero on error.

Err ImageLibPreviewStop ( UInt16 libRef )

Turns off the direct draw preview mode of the camera.

This routine serves as a front end to the camera driver's CameraLibPreviewStop function. It halts previews that were initiated by a call to ImageLibPreviewStart.

See also:
ImageLibPreviewStart
Parameters:
libRef,: IN: Library reference number.
Return values:
Err 0 on success, non-zero on error.

Err ImageLibResize | ( | UInt16 | libRef,
 |  | UInt16 | recIndex,
 |  | Coord * | widthP,
 |  | Coord * | heightP,
 |  | Boolean | maintainAspectRatio
 | ) |  |

Resizes an image in the database to any arbitrary size.

This routine resizes an image in the database to any size. The routine can maintain the existing aspect ratio of the image, or it can stretch it to fit any size.

Parameters:
libRef,: IN: Library reference number.
recIndex,: IN: Index of image.
widthP,: IN,OUT: On output, contains the new width of the image. On input, if maintainAspectRatio is true, determines the max width that the image should be. If maintainAspectRatio is false, determines the exact width that the image should be after resizing.
heightP,: IN,OUT: On output, contains the new width of the image. On input, if maintainAspectRatio is true, determines the max width that the image should be. If maintainAspectRatio is false, determines the exact width that the image should be after resizing.
maintainAspectRatio,: IN: If true, tells the library to maintain the aspect ratio of the image. In this case, the input values of widthP and heightP serve as maximum guidelines. If false, the image is stretched to fit the input values of widthP and heightP. the dimensions that an image would be if it was forced to draw in a box bounded by widthP and heightP.
Return values:
Err 0 on success, non-zero on error.

Err ImageLibResizeImage | ( | UInt16 | libRef,
 |  | UInt16 | recIndex
 | ) |  |

Deprecated:
Resizes a fullsize picture in the database to 160x120 (palm size). The original fullsize image is replaced with the palm size version.

If the original image is a full size 640x480 jpeg, the image is downsampled using the DCT scaling features of the IJG library. This means that the JPEG is decompressed directly to 160x120, and then compressed again and saved back to the database.

If the original image is not a 640x480 jpeg, it is scaled as much as possible using the IJG scaling features. After decompression, the picture is resampled with a filter to get its dimensions to 160x120.

ImageLibResizeImage is deprecated. Use ImageLibResize instead.

Parameters:
libRef,: IN: Library reference number.
recIndex,: IN: index of image to resize.
Return values:
Err 0 on success, non-zero on error.

Err ImageLibResizeJPEG | ( | UInt16 | libRef,
 |  | MemPtr | jpegInputP,
 |  | UInt32 | inputSize,
 |  | Coord * | widthP,
 |  | Coord * | heightP,
 |  | Boolean | maintainAspectRatio,
 |  | MemPtr * | outputPP,
 |  | UInt32 * | outputSizeP
 | ) |  |

Resizes a JPEG in memory.

This routine resizes a JPEG in memory to any size. The routine follows the same semantics as ImageLibResize, except that it creates a new JPEG in memory as a result.

See also:
ImageLibResize
Parameters:
libRef,: IN: Library reference number.
jpegInputP,: IN: Pointer to a JPEG image in memory.
inputSize,: IN: Size of the source image in bytes.
widthP,: IN,OUT: On output, contains the new width of the image. On input, if maintainAspectRatio is true, determines the max width that the image should be. If maintainAspectRatio is false, determines the exact width that the image should be after resizing.
heightP,: IN,OUT: On output, contains the new width of the image. On input, if maintainAspectRatio is true, determines the max width that the image should be. If maintainAspectRatio is false, determines the exact width that the image should be after resizing.
maintainAspectRatio,: IN: If true, tells the library to maintain the aspect ratio of the image. In this case, the input values of widthP and heightP serve as maximum guidelines. If false, the image is stretched to fit the input values of widthP and heightP. the dimensions that an image would be if it was forced to draw in a box bounded by widthP and heightP.
outputPP,: OUT: Pointer to the newly sized JPEG. The caller is responsible for freeing this memory.
outputSizeP,: OUT: Size in bytes of the newly sized JPEG.
Return values:
Err 0 on success, non-zero on error.

Err ImageLibResizeVFS | ( | UInt16 | libRef,
 |  | UInt16 | volRefNum,
 |  | const char * | fileName,
 |  | Coord * | widthP,
 |  | Coord * | heightP,
 |  | Boolean | maintainAspectRatio
 | ) |  |

Resizes an image on a VFS volume to any arbitrary size.

This routine resizes a VFS image to any size. The routine follows the same semantics as ImageLibResize.

See also:
ImageLibResize
Parameters:
libRef,: IN: Library reference number.
volRefNum,: IN: Ref number of the VFS volume
fileName,: IN: Filename of the image (ie "/DCIM/picture.jpg")
widthP,: IN,OUT: On output, contains the new width of the image. On input, if maintainAspectRatio is true, determines the max width that the image should be. If maintainAspectRatio is false, determines the exact width that the image should be after resizing.
heightP,: IN,OUT: On output, contains the new width of the image. On input, if maintainAspectRatio is true, determines the max width that the image should be. If maintainAspectRatio is false, determines the exact width that the image should be after resizing.
maintainAspectRatio,: IN: If true, tells the library to maintain the aspect ratio of the image. In this case, the input values of widthP and heightP serve as maximum guidelines. If false, the image is stretched to fit the input values of widthP and heightP. the dimensions that an image would be if it was forced to draw in a box bounded by widthP and heightP.
Return values:
Err 0 on success, non-zero on error.

Err ImageLibSetImageID | ( | UInt16 | libRef,
 |  | UInt16 | recIndex,
 |  | const char * | mediaIDP,
 |  | const char * | containerIDP
 | ) |  |

Sets the media and container IDs for an image in the database.

The media ID and container ID should both be 21 bytes in size. The image library copies 21 bytes from the supplied buffers into the main record for the image.

See also:
ImageLibGetImageID
Parameters:
libRef,: IN: Library reference number.
recIndex,: IN: Index of image.
mediaIDP,: IN: Media ID.
containerIDP,: IN: Container ID.
Return values:
Err 0 on success, non-zero on error.

Err ImageLibSetImageInfo | ( | UInt16 | libRef,
 |  | UInt16 | recIndex,
 |  | const char * | name,
 |  | UInt16 * | categoryP
 | ) |  |

Assigns information about an image stored in the database.

Parameters:
libRef,: IN: Library reference number.
recIndex,: IN: Index of the picture
name,: IN: Name of the picture. Pass NULL for this parameter if you don't want to set it.
categoryP,: OUT: Category that that picture is assigned to. Pass NULL for this parameter if you don't want to set it.
Return values:
Err 0 on success, non-zero on error.

Err ImageLibSetJPEGQuality | ( | UInt16 | libRef,
 |  | Int32 | value
 | ) |  |

Sets the compression factor for all JPEG compression operations performed by the imaging library. The compression factor shoule be a value in the range of 1-99.

Parameters:
libRef,: IN: Library reference number.
value,: IN: new compression quality.
Return values:
Err 0 on success, non-zero on error.

void ImageLibSetProgressCallback | ( | UInt16 | libRef,
 |  | ImageLibProgressCallbackType | callback
 | ) |  |

Sets a progress callback function. The image library will invoke this routine periodically during long processing, such as compressing or decompressing a jpeg or resizing an image.

All of the APIs that decompress or resize images use the callback mechanism. ImageLibImageSave also invokes it.

max is the total number of operations that must be performed. For a JPEG compression or decompression, this equates to the number of horizontal scan lines in the image. The progress value will range from 0 to max. The imaging library will invoked the callback repeatedly. On each pass, the progress variable will increase by some unspecified amount. The operation argument determines the type of operation being performed. Possible values are kResizeOperation, kJPEGOperation, and kVFSOperation.

The callback function should have the following signature:

 void callback(Int32 progress, Int32 max, Int8 operation);

Parameters:
libRef,: IN: Library reference number.
callback,: IN: Address of the callback function. Pass NULL to reset the callback to nothing.
Return values:
void

BitmapType* ImageLibThumbnailBitmapCreate | ( | UInt16 | libRef,
 |  | UInt16 | recIndex,
 |  | Err * | errP
 | ) |  |

Creates a 16 bit bitmap for holding an thumbnail image . If recIndex is a valid image index, the thumbnail for that image is loaded into the resulting bitmap. Otherwise, the result is an empty bitmap.

When called from a 68k application, the return value should be treated as opaque. The bitmap can safely be passed to the Palm OS bitmap routines, but 68k applications should not attempt to dereference members of the bitmap structure directly.

Bitmaps created with this function should be disposed of by calling ImageLibBitmapDelete. Do note call BmpDelete or MemPtrFree.

If an error occurs, this function returns NULL and writes an error code to errP. If the function returns a non-NULL bitmap value, then *errP will always be 0.

The thumbnail is generated on the fly if the image in the database does not have a thumbnail record.

See also:
ImageLibBitmapDelete
Parameters:
libRef,: IN: Library reference number.
recIndex,: IN: index of image to fill the thumbnail bitmap with. Use kInvalidRecIndex to create an empty 40x30, 16 bit bitmap.
errP,: OUT: If the function succeeds, 0 is written to errP. Otherwise, a non-zero error code is written. This parameter should not be NULL.
Return values:
BitmapType* On success, the result is a new bitmap with a bit depth of 16. On error, the result is NULL.

BitmapType* ImageLibThumbnailBitmapCreateFromVFS | ( | UInt16 | libRef,
 |  | UInt16 | volRefNum,
 |  | const char * | fileName,
 |  | Err * | errP
 | ) |  |

Creates a 16 bit bitmap for holding an thumbnail image for a VFS JPEG.

When called from a 68k application, the return value should be treated as opaque. The bitmap can safely be passed to the Palm OS bitmap routines, but 68k applications should not attempt to dereference members of the bitmap structure directly.

Bitmaps created with this function should be disposed of by calling ImageLibBitmapDelete. Do note call BmpDelete or MemPtrFree.

If an error occurs, this function returns NULL and writes an error code to errP. If the function returns a non-NULL bitmap value, then *errP will always be 0.

The thumbnail is generated on the fly from VFS file. For large images, this operation can be slow.

See also:
ImageLibBitmapDelete
Parameters:
libRef,: IN: Library reference number.
volRefNum,: IN: Ref number of the VFS volume
fileName,: IN: Filename of the image (ie "/DCIM/picture001.jpg")
errP,: OUT: If the function succeeds, 0 is written to errP. Otherwise, a non-zero error code is written. This parameter should not be NULL.
Return values:
BitmapType* On success, the result is a new bitmap with a bit depth of 16. On error, the result is NULL.

Err ImageLibThumbnailBitmapFill | ( | UInt16 | libRef,
 |  | UInt16 | recIndex,
 |  | BitmapType * | imageP
 | ) |  |

Fills a bitmap with an thumbnail image from the database.

The imageP argument should represent a bitmap created with ImageLibThumbnailBitmapCreate.

The image from the database is resampled as necessary to fit the dimensions of imageP. If the aspect ratio of imageP does not match the aspect ratio of the picture, the picture is stretched to fit.

See also:
ImageLibThumbnailBitmapCreate

ImageLibBitmapDelete

Parameters:
libRef,: IN: Library reference number.
recIndex,: IN: index of image
imageP,: IN,OUT: Bitmap to fill.
Return values:
Err 0 on success, non-zero on error.

Err ImageLibThumbnailBitmapFillFromVFS | ( | UInt16 | libRef,
 |  | UInt16 | volRefNum,
 |  | const char * | fileName,
 |  | BitmapType * | imageP
 | ) |  |

Fills a bitmap with a thumbnail image from a VFS volume. *

The imageP argument should represent a bitmap created with ImageLibThumbnailBitmapCreate or ImageLibThumbnailBitmapCreateFromVFS.

The image is resampled as necessary to fit the dimensions of imageP.

See also:
ImageLibThumbnailBitmapCreate

ImageLibThumbnailBitmapCreateFromVFS

ImageLibBitmapDelete

Parameters:
libRef,: IN: Library reference number.
volRefNum,: IN: Ref number of the VFS volume
fileName,: IN: Filename of the image (ie "/DCIM/picture001.jpg")
imageP,: IN,OUT: Bitmap to fill.
Return values:
Err 0 on success, non-zero on error.

Err ImageLibThumbnailDraw | ( | UInt16 | libRef,
 |  | UInt16 | recIndex,
 |  | Coord | x,
 |  | Coord | y
 | ) |  |

Draws an thumbnail image from the database to the current draw window at x,y. x and y * are window relative coordinates.

Parameters:
libRef,: IN: Library reference number.
recIndex,: IN: index of image
x,: IN: x location to draw the preview image, relative to the current draw window.
y,: IN: y location to draw the preview image, relative to the current draw window.
Return values:
Err 0 on success, non-zero on error.

Err ImageLibThumbnailDrawFromVFS | ( | UInt16 | libRef,
 |  | UInt16 | volRefNum,
 |  | const char * | fileName,
 |  | Coord | x,
 |  | Coord | y
 | ) |  |

Draws an thumbnail image from a VFS image to the current draw window at x,y. x and y * are window relative coordinates.

Parameters:
libRef,: IN: Library reference number.
volRefNum,: IN: Ref number of the VFS volume
fileName,: IN: Filename of the image (ie "/DCIM/picture001.jpg")
x,: IN: x location to draw the preview image, relative to the current draw window.
y,: IN: y location to draw the preview image, relative to the current draw window.
Return values:
Err 0 on success, non-zero on error.

Err ImageLibTurnCameraOff ( UInt16 libRef )

Deactivates the camera hardware by unloading the camera driver.

Parameters:
libRef,: IN: Library reference number.
Return values:
Err 0 on success, non-zero on error.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:07:35 2008 for Palm API Guide


Header Files » Incs » common » libraries » imaging

ImageLibCommon.h File Reference

Detailed Description

Public 68k common header file for the Image Library API on Treo 600 devices.

Version:
1.0
This file contains common defines and error codes to be used with Imaging Library API.

Definition in file ImageLibCommon.h.

Include dependency graph for ImageLibCommon.h:

Go to the source code of this file.

Defines

  • #define ImageLibCreatorID 'imgL'
  • #define ImageLibTypeID 'libr'
  • #define ImageLibName "ImageLibrary"
  • #define kInvalidRecIndex ((UInt16)0xFFFF )
  • #define kImageFilenameLength (dmDBNameLength)
Preview Image Dimensions
Preview height and width in standard pixels. On a double density device, the bitmap returned would be twice these dimensions.

  • #define kPalmSizeImageWidth 160
  • #define kPalmSizeImageHeight 120
  • #define kFullSizeImageWidth 640
  • #define kFullSizeImageHeight 480
  • #define kThumbnailImageWidth 40
  • #define kThumbnailImageHeight 30
  • #define kPreviewBitmapWidth (kPalmSizeImageWidth)
  • #define kPreviewBitmapHeight (kPalmSizeImageHeight)
Sort Orders
  • #define kNoSortOrder (0)
  • #define kSortByName (1)
  • #define kSortByDate (2)
  • #define kSortByNameDesc (3)
  • #define kSortByDateDesc (4)
Image Operation Codes
  • #define kResizeOperation (0)
  • #define kJPEGOperation (1)
  • #define kVFSOperation (2)
Error Codes
  • #define imageLibErrorClass (appErrorClass | 0x1000)
  • #define imageLibErrBadParam (imageLibErrorClass)
  • #define imageLibErrNoCamera (imageLibErrorClass + 1)
  • #define imageLibErrInternalFailure (imageLibErrorClass + 2)
  • #define imageLibErrWriteFailure (imageLibErrorClass + 3)
  • #define imageLibErrReadFailure (imageLibErrorClass + 4)
  • #define imageLibErrBadData (imageLibErrorClass + 5)
  • #define imageLibErrBadImageType (imageLibErrorClass + 6)
  • #define imageLibErrBadImageDepth (imageLibErrorClass + 7)
  • #define imageLibErrBadDimensions (imageLibErrorClass + 8)
  • #define imageLibErrInitializationFailed (imageLibErrorClass + 9)
  • #define imageLibErrBadColorspace (imageLibErrorClass + 10)
  • #define imageLibErrBadThumbnailType (imageLibErrorClass + 11)
  • #define imageLibErrThumnailExists (imageLibErrorClass + 12)
  • #define imageLibErrBadScaleFactor (imageLibErrorClass + 13)
  • #define imageLibErrBadBitmapType (imageLibErrorClass + 14)
  • #define imageLibErrImageAlreadyDownsized (imageLibErrorClass + 15)
  • #define imageLibErrImageLocked (imageLibErrorClass + 16)

Typedefs

  • typedef void * ImageIteratorHandle
  • typedef void(*) ImageLibProgressCallbackType (Int32 progress, Int32 max, Int8 operation)

Define Documentation

#define ImageLibCreatorID 'imgL'

Imaging library creator ID

Definition at line 56 of file ImageLibCommon.h.

#define imageLibErrBadBitmapType (imageLibErrorClass + 14)

Definition at line 125 of file ImageLibCommon.h.

#define imageLibErrBadColorspace (imageLibErrorClass + 10)

Definition at line 121 of file ImageLibCommon.h.

#define imageLibErrBadData (imageLibErrorClass + 5)

Definition at line 116 of file ImageLibCommon.h.

#define imageLibErrBadDimensions (imageLibErrorClass + 8)

Definition at line 119 of file ImageLibCommon.h.

#define imageLibErrBadImageDepth (imageLibErrorClass + 7)

Definition at line 118 of file ImageLibCommon.h.

#define imageLibErrBadImageType (imageLibErrorClass + 6)

Definition at line 117 of file ImageLibCommon.h.

#define imageLibErrBadParam (imageLibErrorClass)

Definition at line 111 of file ImageLibCommon.h.

#define imageLibErrBadScaleFactor (imageLibErrorClass + 13)

Definition at line 124 of file ImageLibCommon.h.

#define imageLibErrBadThumbnailType (imageLibErrorClass + 11)

Definition at line 122 of file ImageLibCommon.h.

#define imageLibErrImageAlreadyDownsized (imageLibErrorClass + 15)

Definition at line 126 of file ImageLibCommon.h.

#define imageLibErrImageLocked (imageLibErrorClass + 16)

Definition at line 127 of file ImageLibCommon.h.

#define imageLibErrInitializationFailed (imageLibErrorClass + 9)

Definition at line 120 of file ImageLibCommon.h.

#define imageLibErrInternalFailure (imageLibErrorClass + 2)

Definition at line 113 of file ImageLibCommon.h.

#define imageLibErrNoCamera (imageLibErrorClass + 1)

Definition at line 112 of file ImageLibCommon.h.

#define imageLibErrorClass (appErrorClass | 0x1000)

Definition at line 110 of file ImageLibCommon.h.

#define imageLibErrReadFailure (imageLibErrorClass + 4)

Definition at line 115 of file ImageLibCommon.h.

#define imageLibErrThumnailExists (imageLibErrorClass + 12)

Definition at line 123 of file ImageLibCommon.h.

#define imageLibErrWriteFailure (imageLibErrorClass + 3)

Definition at line 114 of file ImageLibCommon.h.

#define ImageLibName "ImageLibrary"

Imaging library database name

Definition at line 58 of file ImageLibCommon.h.

#define ImageLibTypeID 'libr'

Standard library type

Definition at line 57 of file ImageLibCommon.h.

#define kFullSizeImageHeight 480

Definition at line 69 of file ImageLibCommon.h.

#define kFullSizeImageWidth 640

Definition at line 68 of file ImageLibCommon.h.

#define kImageFilenameLength (dmDBNameLength)

max filename length

Definition at line 78 of file ImageLibCommon.h.

#define kInvalidRecIndex ((UInt16)0xFFFF )

define for invalid record index

Definition at line 76 of file ImageLibCommon.h.

#define kJPEGOperation (1)

Definition at line 96 of file ImageLibCommon.h.

#define kNoSortOrder (0)

Definition at line 84 of file ImageLibCommon.h.

#define kPalmSizeImageHeight 120

Definition at line 67 of file ImageLibCommon.h.

#define kPalmSizeImageWidth 160

Definition at line 66 of file ImageLibCommon.h.

#define kPreviewBitmapHeight (kPalmSizeImageHeight)

Definition at line 73 of file ImageLibCommon.h.

#define kPreviewBitmapWidth (kPalmSizeImageWidth)

Definition at line 72 of file ImageLibCommon.h.

#define kResizeOperation (0)

Definition at line 95 of file ImageLibCommon.h.

#define kSortByDate (2)

Definition at line 86 of file ImageLibCommon.h.

#define kSortByDateDesc (4)

Definition at line 88 of file ImageLibCommon.h.

#define kSortByName (1)

Definition at line 85 of file ImageLibCommon.h.

#define kSortByNameDesc (3)

Definition at line 87 of file ImageLibCommon.h.

#define kThumbnailImageHeight 30

Definition at line 71 of file ImageLibCommon.h.

#define kThumbnailImageWidth 40

Definition at line 70 of file ImageLibCommon.h.

#define kVFSOperation (2)

Definition at line 97 of file ImageLibCommon.h.

Typedef Documentation

typedef void* ImageIteratorHandle

Handle returned by ImageLibIterateImages or ImageLibIterateVFSImages.

Definition at line 101 of file ImageLibCommon.h.

typedef void(*) ImageLibProgressCallbackType(Int32 progress, Int32 max, Int8 operation)

Passed in when calling ImageLibSetProgressCallback

Definition at line 104 of file ImageLibCommon.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:07:35 2008 for Palm API Guide


Header Files » Incs » common » libraries » imaging

ImageLibTraps.h File Reference

Include dependency graph for ImageLibTraps.h:

Go to the source code of this file.

Defines

Function Traps
  • #define kImageLibTrapOpen (sysLibTrapOpen )
  • #define kImageLibTrapClose (sysLibTrapClose )
  • #define kImageLibTrapGetVersion (sysLibTrapCustom )
  • #define kImageLibTrapCameraExists (sysLibTrapCustom + 1)
  • #define kImageLibTrapImageCapture (sysLibTrapCustom + 2)
  • #define kImageLibTrapImageSave (sysLibTrapCustom + 3)
  • #define kImageLibTrapPreviewBitmapCreate (sysLibTrapCustom + 4)
  • #define kImageLibTrapPreviewBitmapFill (sysLibTrapCustom + 5)
  • #define kImageLibTrapPreviewDraw (sysLibTrapCustom + 6)
  • #define kImageLibTrapImageBitmapCreate (sysLibTrapCustom + 7)
  • #define kImageLibTrapImageBitmapFill (sysLibTrapCustom + 8)
  • #define kImageLibTrapImageDraw (sysLibTrapCustom + 9)
  • #define kImageLibTrapThumbnailBitmapCreate (sysLibTrapCustom + 10)
  • #define kImageLibTrapThumbnailBitmapFill (sysLibTrapCustom + 11)
  • #define kImageLibTrapThumbnailDraw (sysLibTrapCustom + 12)
  • #define kImageLibTrapBitmapDelete (sysLibTrapCustom + 13)
  • #define kImageLibTrapDeleteImage (sysLibTrapCustom + 14)
  • #define kImageLibTrapResizeImage (sysLibTrapCustom + 15)
  • #define kImageLibTrapGetImageDatabases (sysLibTrapCustom + 16)
  • #define kImageLibTrapGetImageInfo (sysLibTrapCustom + 17)
  • #define kImageLibTrapSetImageInfo (sysLibTrapCustom + 18)
  • #define kImageLibTrapCopyImageToVFS (sysLibTrapCustom + 19)
  • #define kImageLibTrapCopyImageFromVFS (sysLibTrapCustom + 20)
  • #define kImageLibTrapImageBitmapCreateFromVFS (sysLibTrapCustom + 21)
  • #define kImageLibTrapImageBitmapFillFromVFS (sysLibTrapCustom + 22)
  • #define kImageLibTrapImageDrawFromVFS (sysLibTrapCustom + 23)
  • #define kImageLibTrapThumbnailBitmapCreateFromVFS (sysLibTrapCustom + 24)
  • #define kImageLibTrapThumbnailBitmapFillFromVFS (sysLibTrapCustom + 25)
  • #define kImageLibTrapThumbnailDrawFromVFS (sysLibTrapCustom + 26)
  • #define kImageLibTrapDoInfoDialog (sysLibTrapCustom + 27)
  • #define kImageLibTrapDoAttachImageDialog (sysLibTrapCustom + 28)
  • #define kImageLibTrapSetNoteFont (sysLibTrapCustom + 29)
  • #define kImageLibTrapGetNoteFont (sysLibTrapCustom + 30)
  • #define kImageLibTrapDoNoteDialog (sysLibTrapCustom + 31)
  • #define kImageLibTrapCopyImageToBuffer (sysLibTrapCustom + 32)
  • #define kImageLibTrapCopyImageToFile (sysLibTrapCustom + 33)
  • #define kImageLibTrapInsertImageFromBuffer (sysLibTrapCustom + 34)
  • #define kImageLibTrapInsertImageFromFile (sysLibTrapCustom + 35)
  • #define kImageLibTrapLockImage (sysLibTrapCustom + 36)
  • #define kImageLibTrapIterateImages (sysLibTrapCustom + 37)
  • #define kImageLibTrapIterateVFSImages (sysLibTrapCustom + 38)
  • #define kImageLibTrapIterSort (sysLibTrapCustom + 39)
  • #define kImageLibTrapIterGetImageInfo (sysLibTrapCustom + 40)
  • #define kImagelibTrapIterGetCount (sysLibTrapCustom + 41)
  • #define kImageLibTrapIterDeleteImage (sysLibTrapCustom + 42)
  • #define kImageLibTrapIterRemoveImage (sysLibTrapCustom + 43)
  • #define kImageLibTrapIterFree (sysLibTrapCustom + 44)
  • #define kImageLibTrapIterDrawImage (sysLibTrapCustom + 45)
  • #define kImageLibTrapIterDrawThumbnail (sysLibTrapCustom + 46)
  • #define kImageLibTrapIterSearch (sysLibTrapCustom + 47)
  • #define kImageLibTrapSetProgressCallback (sysLibTrapCustom + 48)
  • #define kImageLibTrapCopyImage (sysLibTrapCustom + 49)
  • #define kImageLibTrapFindImageByID (sysLibTrapCustom + 50)
  • #define kImageLibTrapPreviewStart (sysLibTrapCustom + 51)
  • #define kImageLibTrapPreviewStop (sysLibTrapCustom + 52)
  • #define kImageLibTrapDrawJPEG (sysLibTrapCustom + 53)
  • #define kImageLibTrapTurnCameraOff (sysLibTrapCustom + 54)
  • #define kImageLibTrapSetImageID (sysLibTrapCustom + 55)
  • #define kImageLibTrapGetImageID (sysLibTrapCustom + 56)
  • #define kImageLibTrapGetDimensions (sysLibTrapCustom + 57)
  • #define kImageLibTrapGetDimensionsVFS (sysLibTrapCustom + 58)
  • #define kImageLibTrapIterGetDimensions (sysLibTrapCustom + 59)
  • #define kImageLibTrapGetDimensionsJPEG (sysLibTrapCustom + 60)
  • #define kImageLibTrapResize (sysLibTrapCustom + 61)
  • #define kImageLibTrapResizeVFS (sysLibTrapCustom + 62)
  • #define kImageLibTrapIterResize (sysLibTrapCustom + 63)
  • #define kImageLibTrapResizeJPEG (sysLibTrapCustom + 64)
  • #define kImageLibTrapIterRefresh (sysLibTrapCustom + 65)
  • #define kImageLibTrapSetJPEGQuality (sysLibTrapCustom + 66)
  • #define kImageLibTrapGetJPEGQuality (sysLibTrapCustom + 67)
  • #define kImageLibTrapGetAveragePictureSize (sysLibTrapCustom + 68)
  • #define kImageLibTrapCheckLockedImages (sysLibTrapCustom + 69)

Define Documentation

#define kImageLibTrapBitmapDelete (sysLibTrapCustom + 13)

Definition at line 43 of file ImageLibTraps.h.

#define kImageLibTrapCameraExists (sysLibTrapCustom + 1)

Definition at line 31 of file ImageLibTraps.h.

#define kImageLibTrapCheckLockedImages (sysLibTrapCustom + 69)

Definition at line 106 of file ImageLibTraps.h.

#define kImageLibTrapClose (sysLibTrapClose )

Definition at line 28 of file ImageLibTraps.h.

#define kImageLibTrapCopyImage (sysLibTrapCustom + 49)

Definition at line 83 of file ImageLibTraps.h.

#define kImageLibTrapCopyImageFromVFS (sysLibTrapCustom + 20)

Definition at line 51 of file ImageLibTraps.h.

#define kImageLibTrapCopyImageToBuffer (sysLibTrapCustom + 32)

Definition at line 66 of file ImageLibTraps.h.

#define kImageLibTrapCopyImageToFile (sysLibTrapCustom + 33)

Definition at line 67 of file ImageLibTraps.h.

#define kImageLibTrapCopyImageToVFS (sysLibTrapCustom + 19)

Definition at line 50 of file ImageLibTraps.h.

#define kImageLibTrapDeleteImage (sysLibTrapCustom + 14)

Definition at line 44 of file ImageLibTraps.h.

#define kImageLibTrapDoAttachImageDialog (sysLibTrapCustom + 28)

Definition at line 61 of file ImageLibTraps.h.

#define kImageLibTrapDoInfoDialog (sysLibTrapCustom + 27)

Definition at line 60 of file ImageLibTraps.h.

#define kImageLibTrapDoNoteDialog (sysLibTrapCustom + 31)

Definition at line 64 of file ImageLibTraps.h.

#define kImageLibTrapDrawJPEG (sysLibTrapCustom + 53)

Definition at line 87 of file ImageLibTraps.h.

#define kImageLibTrapFindImageByID (sysLibTrapCustom + 50)

Definition at line 84 of file ImageLibTraps.h.

#define kImageLibTrapGetAveragePictureSize (sysLibTrapCustom + 68)

Definition at line 105 of file ImageLibTraps.h.

#define kImageLibTrapGetDimensions (sysLibTrapCustom + 57)

Definition at line 92 of file ImageLibTraps.h.

#define kImageLibTrapGetDimensionsJPEG (sysLibTrapCustom + 60)

Definition at line 95 of file ImageLibTraps.h.

#define kImageLibTrapGetDimensionsVFS (sysLibTrapCustom + 58)

Definition at line 93 of file ImageLibTraps.h.

#define kImageLibTrapGetImageDatabases (sysLibTrapCustom + 16)

Definition at line 46 of file ImageLibTraps.h.

#define kImageLibTrapGetImageID (sysLibTrapCustom + 56)

Definition at line 90 of file ImageLibTraps.h.

#define kImageLibTrapGetImageInfo (sysLibTrapCustom + 17)

Definition at line 47 of file ImageLibTraps.h.

#define kImageLibTrapGetJPEGQuality (sysLibTrapCustom + 67)

Definition at line 104 of file ImageLibTraps.h.

#define kImageLibTrapGetNoteFont (sysLibTrapCustom + 30)

Definition at line 63 of file ImageLibTraps.h.

#define kImageLibTrapGetVersion (sysLibTrapCustom )

Definition at line 30 of file ImageLibTraps.h.

#define kImageLibTrapImageBitmapCreate (sysLibTrapCustom + 7)

Definition at line 37 of file ImageLibTraps.h.

#define kImageLibTrapImageBitmapCreateFromVFS (sysLibTrapCustom + 21)

Definition at line 52 of file ImageLibTraps.h.

#define kImageLibTrapImageBitmapFill (sysLibTrapCustom + 8)

Definition at line 38 of file ImageLibTraps.h.

#define kImageLibTrapImageBitmapFillFromVFS (sysLibTrapCustom + 22)

Definition at line 53 of file ImageLibTraps.h.

#define kImageLibTrapImageCapture (sysLibTrapCustom + 2)

Definition at line 32 of file ImageLibTraps.h.

#define kImageLibTrapImageDraw (sysLibTrapCustom + 9)

Definition at line 39 of file ImageLibTraps.h.

#define kImageLibTrapImageDrawFromVFS (sysLibTrapCustom + 23)

Definition at line 54 of file ImageLibTraps.h.

#define kImageLibTrapImageSave (sysLibTrapCustom + 3)

Definition at line 33 of file ImageLibTraps.h.

#define kImageLibTrapInsertImageFromBuffer (sysLibTrapCustom + 34)

Definition at line 68 of file ImageLibTraps.h.

#define kImageLibTrapInsertImageFromFile (sysLibTrapCustom + 35)

Definition at line 69 of file ImageLibTraps.h.

#define kImageLibTrapIterateImages (sysLibTrapCustom + 37)

Definition at line 71 of file ImageLibTraps.h.

#define kImageLibTrapIterateVFSImages (sysLibTrapCustom + 38)

Definition at line 72 of file ImageLibTraps.h.

#define kImageLibTrapIterDeleteImage (sysLibTrapCustom + 42)

Definition at line 76 of file ImageLibTraps.h.

#define kImageLibTrapIterDrawImage (sysLibTrapCustom + 45)

Definition at line 79 of file ImageLibTraps.h.

#define kImageLibTrapIterDrawThumbnail (sysLibTrapCustom + 46)

Definition at line 80 of file ImageLibTraps.h.

#define kImageLibTrapIterFree (sysLibTrapCustom + 44)

Definition at line 78 of file ImageLibTraps.h.

#define kImagelibTrapIterGetCount (sysLibTrapCustom + 41)

Definition at line 75 of file ImageLibTraps.h.

#define kImageLibTrapIterGetDimensions (sysLibTrapCustom + 59)

Definition at line 94 of file ImageLibTraps.h.

#define kImageLibTrapIterGetImageInfo (sysLibTrapCustom + 40)

Definition at line 74 of file ImageLibTraps.h.

#define kImageLibTrapIterRefresh (sysLibTrapCustom + 65)

Definition at line 102 of file ImageLibTraps.h.

#define kImageLibTrapIterRemoveImage (sysLibTrapCustom + 43)

Definition at line 77 of file ImageLibTraps.h.

#define kImageLibTrapIterResize (sysLibTrapCustom + 63)

Definition at line 99 of file ImageLibTraps.h.

#define kImageLibTrapIterSearch (sysLibTrapCustom + 47)

Definition at line 81 of file ImageLibTraps.h.

#define kImageLibTrapIterSort (sysLibTrapCustom + 39)

Definition at line 73 of file ImageLibTraps.h.

#define kImageLibTrapLockImage (sysLibTrapCustom + 36)

Definition at line 70 of file ImageLibTraps.h.

#define kImageLibTrapOpen (sysLibTrapOpen )

Definition at line 27 of file ImageLibTraps.h.

#define kImageLibTrapPreviewBitmapCreate (sysLibTrapCustom + 4)

Definition at line 34 of file ImageLibTraps.h.

#define kImageLibTrapPreviewBitmapFill (sysLibTrapCustom + 5)

Definition at line 35 of file ImageLibTraps.h.

#define kImageLibTrapPreviewDraw (sysLibTrapCustom + 6)

Definition at line 36 of file ImageLibTraps.h.

#define kImageLibTrapPreviewStart (sysLibTrapCustom + 51)

Definition at line 85 of file ImageLibTraps.h.

#define kImageLibTrapPreviewStop (sysLibTrapCustom + 52)

Definition at line 86 of file ImageLibTraps.h.

#define kImageLibTrapResize (sysLibTrapCustom + 61)

Definition at line 97 of file ImageLibTraps.h.

#define kImageLibTrapResizeImage (sysLibTrapCustom + 15)

Definition at line 45 of file ImageLibTraps.h.

#define kImageLibTrapResizeJPEG (sysLibTrapCustom + 64)

Definition at line 100 of file ImageLibTraps.h.

#define kImageLibTrapResizeVFS (sysLibTrapCustom + 62)

Definition at line 98 of file ImageLibTraps.h.

#define kImageLibTrapSetImageID (sysLibTrapCustom + 55)

Definition at line 89 of file ImageLibTraps.h.

#define kImageLibTrapSetImageInfo (sysLibTrapCustom + 18)

Definition at line 48 of file ImageLibTraps.h.

#define kImageLibTrapSetJPEGQuality (sysLibTrapCustom + 66)

Definition at line 103 of file ImageLibTraps.h.

#define kImageLibTrapSetNoteFont (sysLibTrapCustom + 29)

Definition at line 62 of file ImageLibTraps.h.

#define kImageLibTrapSetProgressCallback (sysLibTrapCustom + 48)

Definition at line 82 of file ImageLibTraps.h.

#define kImageLibTrapThumbnailBitmapCreate (sysLibTrapCustom + 10)

Definition at line 40 of file ImageLibTraps.h.

#define kImageLibTrapThumbnailBitmapCreateFromVFS (sysLibTrapCustom + 24)

Definition at line 55 of file ImageLibTraps.h.

#define kImageLibTrapThumbnailBitmapFill (sysLibTrapCustom + 11)

Definition at line 41 of file ImageLibTraps.h.

#define kImageLibTrapThumbnailBitmapFillFromVFS (sysLibTrapCustom + 25)

Definition at line 56 of file ImageLibTraps.h.

#define kImageLibTrapThumbnailDraw (sysLibTrapCustom + 12)

Definition at line 42 of file ImageLibTraps.h.

#define kImageLibTrapThumbnailDrawFromVFS (sysLibTrapCustom + 26)

Definition at line 57 of file ImageLibTraps.h.

#define kImageLibTrapTurnCameraOff (sysLibTrapCustom + 54)

Definition at line 88 of file ImageLibTraps.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:07:36 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » locs

LocsLib.h File Reference

Detailed Description

Public 68K include file for location/timezone/DST support on Palm devices.

Definition in file LocsLib.h.

Include dependency graph for LocsLib.h:

Go to the source code of this file.

Functions

  • Err LocsLibOpen (UInt16 iLibRefNum)
  • Err LocsLibClose (UInt16 iLibRefNum)
  • Err LocsLibSleep (UInt16 iLibRefNum)
  • Err LocsLibWake (UInt16 iLibRefNum)
  • Err LocsLibGetVersion (UInt16 iLibRefNum, UInt32 iSDKVersion, UInt32 *oVersionP)
  • Boolean LocsLibLaunchEditListDialogue (UInt16 iLibRefNum, LocsLibSelLocsType *ioSelLocsP)
  • Boolean LocsLibLaunchSelDialogue (UInt16 iLibRefNum, LocsLibSelLocsType *ioSelLocsP)
  • void LocationCopy (UInt16 iLibRefNum, LocationType *thisP, const LocationType *iLocToCopyP)
  • void LocationFinal (UInt16 iLibRefNum, LocationType *thisP)
  • UInt16 LocationGetSize (UInt16 iLibRefNum, const LocationType *thisP)
  • void LocationInit (UInt16 iLibRefNum, LocationType *thisP)
  • Boolean LocationIsDSTPast (UInt16 iLibRefNum, DSTType *iDstDateP)
  • Err LocationMakeGeneric (UInt16 iLibRefNum, LocationType *thisP, CountryType iCountryCode, Int16 iUTC)
  • void LocationSetName (UInt16 iLibRefNum, LocationType *thisP, const Char *iNameP)
  • Err LocDBChangeRecord (UInt16 iLibRefNum, DmOpenRef dbP, UInt16 *ioRecordIndexP, const LocationType *iLocationP)
  • Int16 LocDBCompareRecordsSimple (UInt16 iLibRefNum, LocDBRecordType **iRecord01P, LocDBRecordType **iRecord02P, Int32 iFlags)
  • void LocDBConvertRecord (UInt16 iLibRefNum, LocationType *ioLocationP, const LocDBRecordType *iRecordP)
  • void LocDBCopyLocation (UInt16 iLibRefNum, LocDBRecordType *ioRecordP, const LocationType *iLocationP)
  • Err LocDBDeleteRecord (UInt16 iLibRefNum, DmOpenRef dbP, UInt16 iRecordIndex)
  • LocDBRecordType * LocDBFindCustomRecord (UInt16 iLibRefNum, DmOpenRef iDbP, UInt16 *ioRecordIndex, MemHandle *oRecordH)
  • Err LocDBFindFirst (UInt16 iLibRefNum, DmOpenRef dbP, UInt16 *oRecordIndexP, LocDBRecordType *iMatchValueP)
  • Err LocDBFindFirstByName (UInt16 iLibRefNum, DmOpenRef dbP, UInt16 *oRecordIndexP, const Char *iNameP)
  • Err LocDBFindFirstByUTCCountry (UInt16 iLibRefNum, DmOpenRef dbP, UInt16 *oRecordIndexP, CountryType iCountry, Int16 iUTC)
  • UInt16 LocDBFindFirstInList (UInt16 iLibRefNum, UInt16 iLocsListItemsCount, LocDBRecordType **iLocsListP, const LocationType *iMatchLocationP)
  • MemHandle LocDBGetCustomList (UInt16 iLibRefNum, DmOpenRef iDbP, UInt16 *oListCount)
  • LocDBRecordType ** LocDBGetRecordList (UInt16 iLibRefNum, DmOpenRef iDbP, UInt16 *oListCount, CmpFuncPtr iCompareF, Int32 iCompareFlags)
  • LocDBRecordType * LocDBGetRecord (UInt16 iLibRefNum, DmOpenRef dbP, UInt16 iRecordIndex, MemHandle *oRecordHP)
  • Err LocDBInitDBs (UInt16 iLibRefNum, DmOpenRef *oDefDbPP, DmOpenRef *oCusDbPP)
  • Err LocDBNewRecord (UInt16 iLibRefNum, DmOpenRef dbP, UInt16 *oRecordIndexP, const LocationType *iLocationP)
  • LocalID LocDBOpenCustom (UInt16 iLibRefNum, const LocDBInfoType *iDbInfoP, UInt16 iOpenMode, DmOpenRef *oDbPP, const DmOpenRef iDefDbP)
  • LocalID LocDBOpenDefault (UInt16 iLibRefNum, DmOpenRef *oDbPP)
  • UInt16 LocDBRecordSize (UInt16 iLibRefNum, const LocDBRecordType *iLocRecordP)
  • Err LocDBSetRecordCustom (UInt16 iLibRefNum, LocDBRecordType *ioLocRecordP, UInt8 iValue)
  • Err LocDBSort (UInt16 iLibRefNum, DmOpenRef iDbP, LocDBSortOrderType iSortOrder)
  • void LocsLibDSTAlarmClear (UInt16 iLibRefNum)
  • Boolean LocsLibDSTAlarmIsDST (UInt16 iLibRefNum, const DSTType *iDSTStartP, const DSTType *iDSTEndP, UInt32 iTimeInSecs)
  • UInt32 LocsLibDSTAlarmSet (UInt16 iLibRefNum, const DSTType *iDstStartP, const DSTType *iDstEndP)
  • Err LocDBNewRecordV20 (UInt16 iLibRefNum, DmOpenRef dbP, UInt16 *oRecordIndexP, LocationType *iLocationP)
  • LocationType * LocDBGetRecordV20 (UInt16 iLibRefNum, DmOpenRef dbP, UInt16 iRecordIndex, MemHandle *oRecordHP)
  • void LocDBConvertRecordV20 (UInt16 iLibRefNum, LocationType *destRecordP, const LocationType *srcRecordP)
  • Err LocDBChangeRecordV20 (UInt16 iLibRefNum, DmOpenRef dbP, UInt16 *ioRecordIndexP, LocationType *iLocationP)
  • LocationType ** LocDBGetRecordListV20 (UInt16 iLibRefNum, DmOpenRef iDbP, UInt16 *oListCount, CmpFuncPtr iCompareF, Int32 iCompareFlags)
  • Err LocDBGetNearestLocation (UInt16 iLibRefNum, DmOpenRef iDb1P, DmOpenRef iDb2P, PosType *iPosP, LocationType *oLocP)
  • void LocationInitV20 (UInt16 iLibRefNum, LocationType *thisP)
  • void LocationFinalV20 (UInt16 iLibRefNum, LocationType *thisP)
  • Err LocDBGetVersion (UInt16 iLibRefNum, UInt16 cardNo, const Char *dbNameP, UInt16 *version)
  • void LocationSetNote (UInt16 iLibRefNum, LocationType *thisP, const Char *iNameP)
  • void LocationSetPosition (UInt16 iLibRefNum, LocationType *thisP, const PosType *iPosP)
  • Boolean LocsLibLocationNote (UInt16 iLibRefNum, const Char *iNameP, Boolean noteStatus)
  • UInt16 LocationGetSizeV20 (UInt16 iLibRefNum, LocationType *locationP)
  • void LocationCopyV20 (UInt16 iLibRefNum, LocationType *thisP, const LocationType *iLocToCopyP)
  • LocationType * LocDBFindCustomRecordV20 (UInt16 iLibRefNum, DmOpenRef iDbP, UInt16 *ioRecordIndex, MemHandle *oRecordH)

Function Documentation

void LocationCopy | ( | UInt16 | iLibRefNum,
 |  | LocationType * | thisP,
 |  | const LocationType * | iLocToCopyP
 | ) |  |

Copy from one location data into another

Parameters:
iLibRefNum,: IN: Library reference number
thisP,: IN: Pointer to the location object to copy to
iLocToCopyP IN: Pointer to the location to be copied

void LocationCopyV20 | ( | UInt16 | iLibRefNum,
 |  | LocationType * | thisP,
 |  | const LocationType * | iLocToCopyP
 | ) |  |

Copy from one location data into another

Parameters:
iLibRefNum,: IN: Library reference number
thisP,: IN: Pointer to the location object to copy to
iLocToCopyP IN: Pointer to the location to be copied

void LocationFinal | ( | UInt16 | iLibRefNum,
 |  | LocationType * | thisP
 | ) |  |

Destructor for location objects

Parameters:
iLibRefNum,: IN: Library reference number
thisP,: IN: Pointer to the location object to destroy

void LocationFinalV20 | ( | UInt16 | iLibRefNum,
 |  | LocationType * | thisP
 | ) |  |

Destructor for location objects v 2.0 (support for note)

Parameters:
iLibRefNum,: IN: Library reference number
thisP,: IN: Pointer to the location object to destroy

UInt16 LocationGetSize | ( | UInt16 | iLibRefNum,
 |  | const LocationType * | thisP
 | ) |  |

Calculate the size in bytes of the location object with the name field size included, but without the size of the pointer to the name field.

Parameters:
iLibRefNum,: IN: Library reference number
thisP,: IN: Pointer to the location object to size
Returns:
Size in bytes

UInt16 LocationGetSizeV20 | ( | UInt16 | iLibRefNum,
 |  | LocationType * | locationP
 | ) |  |

Calculate the size in bytes of the location object with the name and note field size included, but without the size of the pointer to the name and note field.

Parameters:
iLibRefNum,: IN: Library reference number
locationP,: IN: Pointer to the location object to size
Returns:
Size in bytes

void LocationInit | ( | UInt16 | iLibRefNum,
 |  | LocationType * | thisP
 | ) |  |

Constructor for location objects; initialize the given location data structure.

Parameters:
iLibRefNum,: IN: Library reference number
thisP,: IN: Pointer to the location object to initialize

void LocationInitV20 | ( | UInt16 | iLibRefNum,
 |  | LocationType * | thisP
 | ) |  |

Constructor for location objects v 2.0 (support for note); initialize the given location data structure.

Parameters:
iLibRefNum,: IN: Library reference number
thisP,: IN: Pointer to the location object to initialize

Boolean LocationIsDSTPast | ( | UInt16 | iLibRefNum,
 |  | DSTType * | iDstDateP
 | ) |  |

Determine if a given DST date is in the past relative to the current time

Parameters:
iLibRefNum,: IN: Library reference number
iDstDateP,: IN: Pointer to a DST date to use for determining if that date is in the past relative to the current time.
Returns:
True if given DST date is in the past.

Err LocationMakeGeneric | ( | UInt16 | iLibRefNum,
 |  | LocationType * | thisP,
 |  | CountryType | iCountryCode,
 |  | Int16 | iUTC
 | ) |  |

Create a generic location using the given country and UTC values.

Parameters:
iLibRefNum,: IN: Library reference number
thisP,: IN: Pointer to the location object to initialize with generic location data
iCountryCode,: IN: Country code for generic location
iUTC,: IN: UTC (timezone is minutes east west of prime meridian) for generic location; also used to create the location name.
Returns:
errNone if success.

void LocationSetName | ( | UInt16 | iLibRefNum,
 |  | LocationType * | thisP,
 |  | const Char * | iNameP
 | ) |  |

Mutator for changing location name value

Parameters:
iLibRefNum,: IN: Library reference number
thisP,: IN: Pointer to the location object to change
iNameP,: IN: Pointer to the new name

void LocationSetNote | ( | UInt16 | iLibRefNum,
 |  | LocationType * | thisP,
 |  | const Char * | iNameP
 | ) |  |

Copy note to location note field

Parameters:
iLibRefNum,: IN: Library reference number
thisP,: IN: Pointer to the location object to change.
iNoteP,: IN: Pointer to the new note.

void LocationSetPosition | ( | UInt16 | iLibRefNum,
 |  | LocationType * | thisP,
 |  | const PosType * | iPosP
 | ) |  |

Initialize position values of location

Parameters:
iLibRefNum,: IN: Library reference number
thisP,: IN: Pointer to the city object to initialize.
iPosP,: IN: Pointer to PosType to set values of location

Err LocDBChangeRecord | ( | UInt16 | iLibRefNum,
 |  | DmOpenRef | dbP,
 |  | UInt16 * | ioRecordIndexP,
 |  | const LocationType * | iLocationP
 | ) |  |

Modify a record and re-sort the db if needed.

Parameters:
iLibRefNum,: IN: Library reference number
dbP,: IN: Pointer to the given location database to be modified.
ioRecordIndexP,: I/O: Pointer to the record index of the location record to be modified. If the record is moved, this value is updated with the new index.
iLocationP,: IN: Pointer to the new location data that is used to update the record.
Returns:
errNone if success.

Err LocDBChangeRecordV20 | ( | UInt16 | iLibRefNum,
 |  | DmOpenRef | dbP,
 |  | UInt16 * | ioRecordIndexP,
 |  | LocationType * | iLocationP
 | ) |  |

Modify a record and re-sort the db if needed.

Parameters:
iLibRefNum,: IN: Library reference number
dbP,: IN: Pointer to the given location database to be modified.
ioRecordIndexP,: I/O: Pointer to the record index of the location record to be modified. If the record is moved, this value is updated with the new index.
iLocationP,: IN: Pointer to the new location data that is used to update the record.
Returns:
errNone if success.

Int16 LocDBCompareRecordsSimple | ( | UInt16 | iLibRefNum,
 |  | LocDBRecordType ** | iRecord01P,
 |  | LocDBRecordType ** | iRecord02P,
 |  | Int32 | iFlags
 | ) |  |

Comparison function to be used with system sort routines.

Note: the system sort functions, like SysQSort, treat the elements of the passed list as is; i.e.: instead of passing the elements to this function, pointers to the elements are passed. Thus, it is necessary to here to use double pointers and dereferencing to to compare the actual records.

Parameters:
iLibRefNum,: IN: Library reference number
iRecord01P,: IN: Pointer to the first location record.
iRecord02P,: IN: Pointer to the second location record.
iFlags IN: Sort order.
Returns:
-n if 1st is lesser, +n if 2nd is lesser, 0 if the two are the same, except for DST data, which isn't compared.

void LocDBConvertRecord | ( | UInt16 | iLibRefNum,
 |  | LocationType * | ioLocationP,
 |  | const LocDBRecordType * | iRecordP
 | ) |  |

This function will format and copy locked record (LocationType) data into another locationType

Parameters:
iLibRefNum,: IN: library reference number
ioLocationP,: I/O: Pointer to the location object that is filled with the converted record data.
iRecordP,: IN: Pointer to the record whose data is converted to the location object format.

void LocDBConvertRecordV20 | ( | UInt16 | iLibRefNum,
 |  | LocationType * | destRecordP,
 |  | const LocationType * | srcRecordP
 | ) |  |

This function will format and copy locked record (LocationType) data into another locationType

Parameters:
iLibRefNum,: IN: library reference number
destRecordP,: IN: Pointer to the location object that is filled with the converted record data.
srcRecordP,: IN: Pointer to the record whose data is converted to the location object format.

void LocDBCopyLocation | ( | UInt16 | iLibRefNum,
 |  | LocDBRecordType * | ioRecordP,
 |  | const LocationType * | iLocationP
 | ) |  |

Copy the data in a given location object into a given location db record format. Note: the caller must allocate enough memory to the record object to hold the location data!

Parameters:
iLibRefNum,: IN: Library reference number
ioRecordP,: I/O: Pointer to a record that is filled with the location object data.
iLocationP,: IN: Pointer to the location object whose data is copied to the record.

Err LocDBDeleteRecord | ( | UInt16 | iLibRefNum,
 |  | DmOpenRef | dbP,
 |  | UInt16 | iRecordIndex
 | ) |  |

Deletes a record from the cities database.

Parameters:
iLibRefNum,: IN: Library reference number
dbP,: IN: Pointer to the database containing the record to delete.
iRecordIndex,: IN: Index of the record to delete.
Returns:
errNone if success.

LocDBRecordType* LocDBFindCustomRecord | ( | UInt16 | iLibRefNum,
 |  | DmOpenRef | iDbP,
 |  | UInt16 * | ioRecordIndex,
 |  | MemHandle * | oRecordH
 | ) |  |

Finds a record having the custom bit set.

Parameters:
iLibRefNum,: IN: Library reference number
iDbP,: IN: Pointer to a locations record database.
ioRecordIndex,: I/O: Index of the record to begin searching from, and index of the found record.
oRecordH,: OUT: Pointer to the record handle; set by this function.
Returns:
Pointer to the record found or NULL. Caller is responsible for freeing record when done.

LocationType* LocDBFindCustomRecordV20 | ( | UInt16 | iLibRefNum,
 |  | DmOpenRef | iDbP,
 |  | UInt16 * | ioRecordIndex,
 |  | MemHandle * | oRecordH
 | ) |  |

Finds a record having the custom bit set.

Parameters:
iLibRefNum,: IN: Library reference number
iDbP,: IN: Pointer to a locations record database.
ioRecordIndex,: I/O: Index of the record to begin searching from, and index of the found record.
oRecordH,: OUT: Pointer to the record handle; set by this function.
Returns:
Pointer to the record found or NULL. Caller is responsible for freeing record when done.

Err LocDBFindFirst | ( | UInt16 | iLibRefNum,
 |  | DmOpenRef | dbP,
 |  | UInt16 * | oRecordIndexP,
 |  | LocDBRecordType * | iMatchValueP
 | ) |  |

Returns the record index for the first record matching the given location data.

Parameters:
iLibRefNum,: IN: Library reference number
dbP,: IN: Pointer to the given cities database to search for a match.
oRecordIndexP,: OUT: Pointer to record index var to store the record index of the matching record found in the search. Set to dmMaxRecordIndex if no match is found.
iMatchLocationP,: IN: Pointer to the location data for which to find the first matching record in the given database.
Returns:
Error code for a failure, or errNone if success. If no match is found, the index value is set to the value dmMaxRecordIndex.

Err LocDBFindFirstByName | ( | UInt16 | iLibRefNum,
 |  | DmOpenRef | dbP,
 |  | UInt16 * | oRecordIndexP,
 |  | const Char * | iNameP
 | ) |  |

Sequential search of the locations database records for a match to the given city name.

Parameters:
iLibRefNum,: IN: Library reference number
dbP,: IN: Pointer to the record db to search.
oRecordIndexP,: OUT: Pointer to an index var to set with the index of the matching record, or dmMaxRecordIndex if no match.
iNameP,: IN: Pointer to the name string for which to find a match.
Returns:
errNone if no problems. No match indicated by oRecordIndexP set to dmMaxRecordIndex.

Err LocDBFindFirstByUTCCountry | ( | UInt16 | iLibRefNum,
 |  | DmOpenRef | dbP,
 |  | UInt16 * | oRecordIndexP,
 |  | CountryType | iCountry,
 |  | Int16 | iUTC
 | ) |  |

Sequential search of the locations database records for the first location matching the given country and UTC values.

Parameters:
iLibRefNum,: IN: Library reference number
dbP,: IN: Pointer to the record db to search.
oRecordIndexP,: OUT: Pointer to an index var to set with the index of the matching record, or dmMaxRecordIndex if no match.
iCountry,: IN: The country code for which to find a match.
iUTC,: IN: The UTC for which to find a match.
Returns:
errNone if no problems. No match indicated by oRecordIndexP set to dmMaxRecordIndex.

UInt16 LocDBFindFirstInList | ( | UInt16 | iLibRefNum,
 |  | UInt16 | iLocsListItemsCount,
 |  | LocDBRecordType ** | iLocsListP,
 |  | const LocationType * | iMatchLocationP
 | ) |  |

Returns the record index for the first record in the given list matching the given location data.

Note: This complements the get list functions, which return a list of pointers to location records in a db.

Parameters:
iLibRefNum,: IN: Library reference number
iLocsListItemsCount,: IN: Number of record items in the list.
iLocsListP,: IN: Pointer to the list of location records.
iMatchLocationP,: IN: Pointer to the location data for which to find the first matching record in the given list.
Returns:
The index of the list item matching the given location, or if no match found, then dmMaxRecordIndex.

MemHandle LocDBGetCustomList | ( | UInt16 | iLibRefNum,
 |  | DmOpenRef | iDbP,
 |  | UInt16 * | oListCount
 | ) |  |

Returns a handle to a list of pointers to location records having the custom bit set. It is the responsibility of the caller to free the memory for the returned list.

Parameters:
iLibRefNum,: IN: Library reference number
iDbP,: IN: Pointer to a locations record database.
oListCount,: OUT: Number of records found with custom bit set.
Returns:
Handle to the list of location record pointers or NULL. Note: Caller is repsonsible for freeing memory associated with the list of pointers to records.

Err LocDBGetNearestLocation | ( | UInt16 | iLibRefNum,
 |  | DmOpenRef | iDb1P,
 |  | DmOpenRef | iDb2P,
 |  | PosType * | iPosP,
 |  | LocationType * | oLocP
 | ) |  |

Get a valid location from the locations DB nearest to the location specified

Parameters:
iLibRefNum,: IN: Library reference number
iDefDb,: IN: Reference to default location database
iCustDb,: IN: Reference to custom location database
iPosP,: IN: Pointer to reference position
oLocP,: OUT: Pointer to location, nearest city will return in this pointer
Returns:
Error if database not found.

LocDBRecordType* LocDBGetRecord | ( | UInt16 | iLibRefNum,
 |  | DmOpenRef | dbP,
 |  | UInt16 | iRecordIndex,
 |  | MemHandle * | oRecordHP
 | ) |  |

Returns a pointer to a locked record chunk in the given db. It is the responsibility of the caller to unlock and release the record when done using the record. It is must to call LocDBCovertRecordV20 to get formated data in another LocationType variable.

Parameters:
iLibRefNum,: IN: library reference number
dbP,: IN: Pointer to a database having the desired record.
iRecordIndex,: IN: Index of the record in the given db.
oRecordHP,: OUT: Pointer to the record handle; set by this function.
Returns:
Pointer to the locked record or NULL; if non-NULL, caller is responsible for unlocking and releasing the record.

LocDBRecordType** LocDBGetRecordList | ( | UInt16 | iLibRefNum,
 |  | DmOpenRef | iDbP,
 |  | UInt16 * | oListCount,
 |  | CmpFuncPtr | iCompareF,
 |  | Int32 | iCompareFlags
 | ) |  |

Get an array of pointers to those records from the the given database.

Parameters:
iLibRefNum,: IN: Library reference number
iDbP,: IN: Pointer to an open locations database.
oListCount,: OUT: Pointer to the list count to be set with the number of items in the locations list.
iCompareF,: IN: Function pointer for the function to use when sorting the list. Pass NULL if the list should not be sorted.
iCompareFlags,: IN: Any flags for comparison/sort behavior.
Returns:
Pointer to the array of location data, or NULL. Note: Caller is responsible for freeing this memory.

LocationType** LocDBGetRecordListV20 | ( | UInt16 | iLibRefNum,
 |  | DmOpenRef | iDbP,
 |  | UInt16 * | oListCount,
 |  | CmpFuncPtr | iCompareF,
 |  | Int32 | iCompareFlags
 | ) |  |

Get an array of pointers to those records from the the given database.

Parameters:
iLibRefNum,: IN: Library reference number
iDbP,: IN: Pointer to an open locations database.
oListCount,: OUT: Pointer to the list count to be set with the number of items in the locations list.
iCompareF,: IN: Function pointer for the function to use when sorting the list. Pass NULL if the list should not be sorted.
iCompareFlags,: IN: Any flags for comparison/sort behavior.
Returns:
Pointer to the array of location data, or NULL. Note: Caller is responsible for freeing this memory.

LocationType* LocDBGetRecordV20 | ( | UInt16 | iLibRefNum,
 |  | DmOpenRef | dbP,
 |  | UInt16 | iRecordIndex,
 |  | MemHandle * | oRecordHP
 | ) |  |

Returns a pointer to a locked record chunk in the given db. It is the responsibility of the caller to unlock and release the record when done using the record. It is must to call LocDBCovertRecordV20 to get formated data in another LocationType variable.

Parameters:
iLibRefNum,: IN: library reference number
dbP,: IN: Pointer to a database having the desired record.
iRecordIndex,: IN: Index of the record in the given db.
oRecordHP,: OUT: Pointer to the record handle; set by this function.
Returns:
Pointer to the locked record or NULL; if non-NULL, caller is responsible for unlocking and releasing the record.

Err LocDBGetVersion | ( | UInt16 | iLibRefNum,
 |  | UInt16 | cardNo,
 |  | const Char * | dbNameP,
 |  | UInt16 * | version
 | ) |  |

Get version of database

Parameters:
iLibRefNum,: IN: Library reference number
cardNo,: IN: cardNo for database
dbNameP,: IN: Pointer to database name to search
versionP,: OUT: Pointer to version, version no will return in this variable
Returns:
Error if database not found.

Err LocDBInitDBs | ( | UInt16 | iLibRefNum,
 |  | DmOpenRef * | oDefDbPP,
 |  | DmOpenRef * | oCusDbPP
 | ) |  |

Open the default db and open and initialize the custom db.

Parameters:
iLibRefNum,: IN: library reference number
oDefDbPP,: OUT: Pointer to the default db pointer to initialize.
oCusDbPP,: OUT: Pointer to the custom db pointer to initialize.
Returns:
On success the default and custom db pointers are initialized.

Err LocDBNewRecord | ( | UInt16 | iLibRefNum,
 |  | DmOpenRef | dbP,
 |  | UInt16 * | oRecordIndexP,
 |  | const LocationType * | iLocationP
 | ) |  |

Generates a new record for the given database.

Parameters:
iLibRefNum,: IN: library reference number
dbP,: IN: Pointer to the given location database into which the location data is to be inserted as a new record.
oRecordIndexP,: OUT: Pointer to the given record index value to be initialized with the new location record's index.
iLocationP,: IN: Pointer to the given location data from which to generate the new location record.
Returns:
errNone if success.

Err LocDBNewRecordV20 | ( | UInt16 | iLibRefNum,
 |  | DmOpenRef | dbP,
 |  | UInt16 * | oRecordIndexP,
 |  | LocationType * | iLocationP
 | ) |  |

Generates a new record for the given database.

Parameters:
iLibRefNum,: IN: library reference number
dbP,: IN: Pointer to the given location database into which the location data is to be inserted as a new record.
oRecordIndexP,: OUT: Pointer to the given record index value to be initialized with the new location record's index.
iLocationP,: IN: Pointer to the given location data from which to generate the new location record.
Returns:
errNone if success.

LocalID LocDBOpenCustom | ( | UInt16 | iLibRefNum,
 |  | const LocDBInfoType * | iDbInfoP,
 |  | UInt16 | iOpenMode,
 |  | DmOpenRef * | oDbPP,
 |  | const DmOpenRef | iDefDbP
 | ) |  |

Open the custom db and return the dbID and an initialized db pointer.

Parameters:
iLibRefNum,: IN: library reference number
iDbInfoP,: IN: Pointer to a database info struct having db name, crid, type, and card number.
iOpenMode,: IN: Read and write mode to open the database for.
oDbPP,: OUT: Pointer to a db reference that is set by this function.
iDefDbP,: IN: Pointer to the default db from which to init the custom db if necessary. Initialization occurs if the custom db must be created, and then any records marked as custom in the given default db are copied into the custom db.
Returns:
Zero (0) on failure the dbP is set to NULL; the database ID is returned on success and the dbP is set to the address of the database.

LocalID LocDBOpenDefault | ( | UInt16 | iLibRefNum,
 |  | DmOpenRef * | oDbPP
 | ) |  |

Open the default db and return the dbID and an initialized db pointer.

Parameters:
iLibRefNum,: IN: library reference number
oDbPP,: OUT: Pointer to a db reference that is set by this function.
Returns:
Error code (errNone if successful). Zero (0) on failure and the dbP is set to NULL; occurs if the default db isn't found and the install from ROM fails. The database ID is returned on success and the dbP is set to the address of the database.

UInt16 LocDBRecordSize | ( | UInt16 | iLibRefNum,
 |  | const LocDBRecordType * | iLocRecordP
 | ) |  |

Determines the size in bytes of a record.

Parameters:
iLibRefNum,: IN: library reference number
iLocRecordP,: IN: Pointer to the record for which to determine the size.
Returns:
Size of the given record in bytes.

Err LocDBSetRecordCustom | ( | UInt16 | iLibRefNum,
 |  | LocDBRecordType * | ioLocRecordP,
 |  | UInt8 | iValue
 | ) |  |

Set the custom field of the record.

Parameters:
iLibRefNum,: IN: library reference number
ioLocRecordP,: I/O: Pointer to the record for which to set the custom field.
iValue,: IN: Value to which the custom field is set.
Returns:
errNone if success.

Err LocDBSort | ( | UInt16 | iLibRefNum,
 |  | DmOpenRef | iDbP,
 |  | LocDBSortOrderType | iSortOrder
 | ) |  |

Sorts the given location data database.

Parameters:
iLibRefNum,: IN: library reference number
iDbP,: IN: Pointer to the location db to sort.
iSortOrder,: IN: Sort order desired.
Returns:
errNone if success.

Err LocsLibClose ( UInt16 iLibRefNum )

Standard library close routine.

Parameters:
iLibRefNum,: IN: Library reference number.
Returns:
Error code.

void LocsLibDSTAlarmClear ( UInt16 iLibRefNum )

Clear an existing DST alert alarm from the system.

Parameters:
iLibRefNum,: IN: library reference number

Boolean LocsLibDSTAlarmIsDST | ( | UInt16 | iLibRefNum,
 |  | const DSTType * | iDSTStartP,
 |  | const DSTType * | iDSTEndP,
 |  | UInt32 | iTimeInSecs
 | ) |  |

Check if the current time is within a daylight saving time range.

Parameters:
iLibRefNum,: IN: library reference number
iDSTStartP,: IN: Pointer to the start DST date.
iDSTEndP,: IN: Pointer to the end DST date.
iTimeInSecs,: IN: The time in seconds against which to check the given DST date range.
Returns:
True if in the DST range.

UInt32 LocsLibDSTAlarmSet | ( | UInt16 | iLibRefNum,
 |  | const DSTType * | iDstStartP,
 |  | const DSTType * | iDstEndP
 | ) |  |

Set the DST alert alarm to the given DST date.

Parameters:
iLibRefNum,: IN: library reference number
iDstP,: IN: Pointer to the DST date data.
Returns:
Time in seconds for which the DST alert was set, or 0 if not set (e.g.: if the given DST date data indicates DST is not observed).

Err LocsLibGetVersion | ( | UInt16 | iLibRefNum,
 |  | UInt32 | iSDKVersion,
 |  | UInt32 * | oVersionP
 | ) |  |

Get the version of the library on the device.

Parameters:
iLibRefNum,: IN: Library reference number.
iSDKVersion,: IN: Currently used library version in the SDK
oVersionP,: OUT: Version of the library on the device.
Returns:
Error code.

Boolean LocsLibLaunchEditListDialogue | ( | UInt16 | iLibRefNum,
 |  | LocsLibSelLocsType * | ioSelLocsP
 | ) |  |

Runs the event loop for handling the Locations dialogues. Note: the preSelect, noEditOnSelect, and sendChangeNotify values of the caller data block don't apply for this API.

Parameters:
iLibRefNum,: IN: Library reference number.
ioSelLocsP,: I/O: Pointer to a selected locations object that contains data on selected locations. e.g.: The Clock 2.0 app displays several selected locations and the associated times. If any of those locations are removed or renamed, the Clock 2.0 app needs to know so it can update the display. This object is updated if any of the selected locations are renamed or removed. Use the dirty bits to determine quickly if any data were changed and if so, which. Pass NULL to ignore.
Returns:
True if changes are made.

Boolean LocsLibLaunchSelDialogue | ( | UInt16 | iLibRefNum,
 |  | LocsLibSelLocsType * | ioSelLocsP
 | ) |  |

Run the location selection dialogue, and then the Edit Location dialogue if the user tapped [OK] in the location selection dialogue and if the caller didn't specify to skip that dialogue.

Parameters:
iLibRefNum,: IN: Library reference number.
ioSelLocsP,: I/O: Pointer to a selected locations object that contains data on selected locations. e.g.: The Clock 2.0 app displays several selected locations and the associated times. If any of those locations are removed or renamed, the Clock 2.0 app needs to know so it can update the display. This object is updated if any of the selected locations are renamed or removed. Use the dirty bits to determine quickly if any data were changed and if so, which. Must not be NULL.
Returns:
True if changes are made.

Boolean LocsLibLocationNote | ( | UInt16 | iLibRefNum,
 |  | const Char * | iNameP,
 |  | Boolean | noteStatus
 | ) |  |

Err LocsLibOpen ( UInt16 iLibRefNum )

Standard library open routine.

Parameters:
iLibRefNum,: IN: Library reference number.
Returns:
Error code.

Err LocsLibSleep ( UInt16 iLibRefNum )

Standard library sleep routine.

Parameters:
iLibRefNum,: IN: Library reference number.
Returns:
Error code.

Err LocsLibWake ( UInt16 iLibRefNum )

Standard library wake routine.

Parameters:
iLibRefNum,: IN: Library reference number.
Returns:
Error code.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:07:37 2008 for Palm API Guide


Header Files » Incs » common » libraries » locs

LocsLibCommon.h File Reference

Detailed Description

Public 68K common header file for locations library.

This file contains the library constants and error codes used in the APIs.

Definition in file LocsLibCommon.h.

Include dependency graph for LocsLibCommon.h:

Go to the source code of this file.

Data Structures

  • struct DSTDataTag
  • struct Coordinate
  • struct PosType
  • struct LocationDataTag
  • struct LocDBInfoTag
  • struct LocDBRecordTag
  • struct LocsLibNotifyLocsDataTag
  • struct LocsLibNotifyDataTag
  • struct LocsLibSelLocsTag

Defines

  • #define kLocsLibName "LocsLib-locL"
  • #define kLocsFileCLocsLib (UInt32)('locL')
  • #define kLocsLibFtrNumRefNum (UInt16)(1)
  • #define kLocNameMaxLength (UInt16)(100)
  • #define kLocNoteMaxLength (UInt16)(4096)
  • #define kLocNoDisplayInCustom (UInt8)(0)
  • #define kLocDisplayInCustom (UInt8)(1)
  • #define kUndefinedPosition (Int16)999
  • #define kLocsLibListUpdateClass 0x0400
  • #define kLocsLibListUpdate (UInt16)(kLocsLibListUpdateClass | 1)
  • #define kLocDBVersion (UInt16)(2)
  • #define kLocDBMaxLocNameLength kLocNameMaxLength
  • #define kLocDBTypeDefault (UInt8)(0)
  • #define kLocDBTypeCustom (UInt8)(1)
  • #define LocationSetUTC(locationP, newUTC) ((locationP)->uTC = newUTC)
  • #define LocationSetDSTStart(locationP, newDstStart) ((locationP)->dSTStart = newDstStart)
  • #define LocationSetDSTEnd(locationP, newDstEnd) ((locationP)->dSTEnd = newDstEnd)
  • #define LocationSetDSTAdj(locationP, newDstAdj) ((locationP)->dSTAdjustmentInMinutes = newDstAdj)
  • #define LocationSetCountry(locationP, newCountry) ((locationP)->country = newCountry)
  • #define LocationSetCustom(locationP, newCustom) ((locationP)->custom = newCustom)
  • #define LocationSetReserved(locationP, newReserved) ((locationP)->reserved = newReserved)
  • #define LocationAreDSTDatesEqual(iDST01P, iDST02P)
Library Versions
  • #define kLocsLibVersion01 sysMakeROMVersion (1, 0, 0, sysROMStageDevelopment, 1)
  • #define kLocsLibVersion0121 sysMakeROMVersion (1, 2, 1, sysROMStageDevelopment, 1)
  • #define kLocsLibVersion013 sysMakeROMVersion (1, 3, 0, sysROMStageDevelopment, 1)
  • #define kLocsLibVersionCurrent kLocsLibVersion013
Error Codes
  • #define locLErrorClass (appErrorClass | 0x0100)
  • #define locLErrNone 0
  • #define locLErrCantFindLocsDB (locLErrorClass | 1)
  • #define locLErrBadParam (locLErrorClass | 2)
  • #define locLErrBadRefNum (locLErrorClass | 3)
  • #define locLErrNoGlobals (locLErrorClass | 4)
  • #define locLErrNoMemForGlobals (locLErrorClass | 5)
  • #define locLErrNoLibSysReference (locLErrorClass | 6)
  • #define locLErrCantOpenLibRsc (locLErrorClass | 7)
  • #define locLErrMemAllocFail (locLErrorClass | 8)
  • #define locLErrBadVersion (locLErrorClass | 9)
  • #define locLErrNotOpen (locLErrorClass | 10)
  • #define locLErrStillOpen (locLErrorClass | 11)
Notifications
  • #define kLocsLibNotifyLocChangeEvent kLocsFileCLocsLib
  • #define kLocsLibNotifyLocEditEvent kLocsLibNotifyLocChangeEvent + 1
  • #define kLocsLibNotifyLocDeleteEvent kLocsLibNotifyLocChangeEvent + 2
  • #define kLocsLibNotifyLocAddEvent kLocsLibNotifyLocChangeEvent + 3
Bit Masks
  • #define kLocsLibSel01 0x00000001
  • #define kLocsLibSel02 0x00000002
  • #define kLocsLibSel03 0x00000004
  • #define kLocsLibSel04 0x00000008
  • #define kLocsLibSel05 0x00000010
  • #define kLocsLibSel06 0x00000020
  • #define kLocsLibSel07 0x00000040
  • #define kLocsLibSel08 0x00000080
  • #define kLocsLibSel09 0x00000100
  • #define kLocsLibSelMax 0x80000000
Database Names and Types
  • #define kLocFileCDatabase (UInt32)('locL')
  • #define kLocFileTDefLocDB (UInt32)('DATA')
  • #define kLocFileTCusLocDB (UInt32)('DATC')
  • #define kLocFileNDefaultDB "locLDefLocationDB"
  • #define kLocFileNCustomDB "locLCusLocationDB"
DST Alarm Constants
  • #define kLocsLibDSTAlert (UInt32)(1)
  • #define kLocsLibDSTStartAlert (UInt32)(2)
  • #define kLocsLibDSTEndAlert (UInt32)(3)
Accessor Macros
  • #define LocationGetUTC(locationP) (locationP)->uTC
  • #define LocationGetDSTStart(locationP) &((locationP)->dSTStart)
  • #define LocationGetDSTEnd(locationP) &((locationP)->dSTEnd)
  • #define LocationGetDSTAdj(locationP) (locationP)->dSTAdjustmentInMinutes
  • #define LocationGetCountry(locationP) (locationP)->country
  • #define LocationGetCustom(locationP) (locationP)->custom
  • #define LocationGetReserved(locationP) (locationP)->reserved
  • #define LocationGetName(locationP) (locationP)->name
Helper Macros
  • #define LocDBCompareUTC(iUTC01, iUTC02) (iUTC01 - iUTC02)
  • #define LocDBCompareCountries(iCountry01, iCountry02) (iCountry01 - iCountry02)
  • #define LocDBCompareNames(iName01, iName02) (StrCompare (iName01, iName02))
  • #define LocDBGetUTC(locRecP) (locRecP)->uTC
  • #define LocDBGetCountry(locRecP) (locRecP)->country
Function Traps
  • #define locsLibTrapGetVersion (sysLibTrapCustom + 0)
  • #define locsLibTrapLaunchEditListDlg (sysLibTrapCustom + 1)
  • #define locsLibTrapLaunchSelDialogue (sysLibTrapCustom + 2)
  • #define locsLibTrapLocCopy (sysLibTrapCustom + 3)
  • #define locsLibTrapLocFinal (sysLibTrapCustom + 4)
  • #define locsLibTrapLocGetSize (sysLibTrapCustom + 5)
  • #define locsLibTrapLocInit (sysLibTrapCustom + 6)
  • #define locsLibTrapLocIsDSTPast (sysLibTrapCustom + 7)
  • #define locsLibTrapLocMakeGeneric (sysLibTrapCustom + 8)
  • #define locsLibTrapLocSetName (sysLibTrapCustom + 9)
  • #define locsLibTrapDBChangeRecord (sysLibTrapCustom + 10)
  • #define locsLibTrapDBCmpRecordsSimple (sysLibTrapCustom + 11)
  • #define locsLibTrapDBConvertRecord (sysLibTrapCustom + 12)
  • #define locsLibTrapDBCopyLocation (sysLibTrapCustom + 13)
  • #define locsLibTrapDBDeleteRecord (sysLibTrapCustom + 14)
  • #define locsLibTrapDBFindCustomRecord (sysLibTrapCustom + 15)
  • #define locsLibTrapDBFindFirst (sysLibTrapCustom + 16)
  • #define locsLibTrapDBFindFirstByName (sysLibTrapCustom + 17)
  • #define locsLibTrapDBFindFirstByUTCCtry (sysLibTrapCustom + 18)
  • #define locsLibTrapDBFindFirstInList (sysLibTrapCustom + 19)
  • #define locsLibTrapDBGetCustomList (sysLibTrapCustom + 20)
  • #define locsLibTrapDBGetRecordList (sysLibTrapCustom + 21)
  • #define locsLibTrapDBGetRecord (sysLibTrapCustom + 22)
  • #define locsLibTrapDBInitDBs (sysLibTrapCustom + 23)
  • #define locsLibTrapDBNewRecord (sysLibTrapCustom + 24)
  • #define locsLibTrapDBOpenCustom (sysLibTrapCustom + 25)
  • #define locsLibTrapDBOpenDefault (sysLibTrapCustom + 26)
  • #define locsLibTrapDBRecordSize (sysLibTrapCustom + 27)
  • #define locsLibTrapDBSetRecordCustom (sysLibTrapCustom + 28)
  • #define locsLibTrapDBSort (sysLibTrapCustom + 29)
  • #define locsLibTrapDSTAlarmClear (sysLibTrapCustom + 30)
  • #define locsLibTrapDSTAlarmIsDST (sysLibTrapCustom + 31)
  • #define locsLibTrapDSTAlarmSet (sysLibTrapCustom + 32)
  • #define locsLibTrapLocDBNewRecordV20 (sysLibTrapCustom + 33)
  • #define locsLibTrapLocDBGetRecordV20 (sysLibTrapCustom + 34)
  • #define locsLibTrapLocDBConvertRecordV20 (sysLibTrapCustom + 35)
  • #define locsLibTrapLocDBChangeRecordV20 (sysLibTrapCustom + 36)
  • #define locsLibTrapLocDBGetRecordListV20 (sysLibTrapCustom + 37)
  • #define locsLibTrapLocDBGetNearestLocation (sysLibTrapCustom + 38)
  • #define locsLibTrapLocationInitV20 (sysLibTrapCustom + 39)
  • #define locsLibTrapLocationFinalV20 (sysLibTrapCustom + 40)
  • #define locsLibTrapLocDBGetVersion (sysLibTrapCustom + 41)
  • #define locsLibTrapLocationSetNote (sysLibTrapCustom + 42)
  • #define locsLibTrapLocationSetPosition (sysLibTrapCustom + 43)
  • #define locsLibTrapLocsLibLocationNote (sysLibTrapCustom + 44)
  • #define locsLibTrapLocationGetSizeV20 (sysLibTrapCustom + 45)
  • #define locsLibTrapLocationCopyV20 (sysLibTrapCustom + 46)
  • #define locsLibTrapLocDBFindCustomRecordV20 (sysLibTrapCustom + 47)

Typedefs

  • typedef UInt8 LocDBSortOrderType
  • typedef DSTDataTag DSTType
  • typedef LocationDataTag LocationType
  • typedef LocDBInfoTag LocDBInfoType
  • typedef LocDBRecordTag LocDBRecordType
  • typedef LocsLibNotifyLocsDataTag LocsLibNotifyLocsDataType
  • typedef LocsLibNotifyDataTag LocsLibNotifyDataType
  • typedef LocsLibSelLocsTag LocsLibSelLocsType

Enumerations

  • enum _LocDBSortOrderType {
    kSortByNameCountryTZ,
    kSortByCountryTZName,
    kSortByCountryCodeTZName
    }

Define Documentation

#define kLocDBMaxLocNameLength kLocNameMaxLength

Max # of bytes for a location name stored.

Definition at line 187 of file LocsLibCommon.h.

#define kLocDBTypeCustom (UInt8)(1)

the location database is custom

Definition at line 202 of file LocsLibCommon.h.

#define kLocDBTypeDefault (UInt8)(0)

the location database is the default one

Definition at line 201 of file LocsLibCommon.h.

#define kLocDBVersion (UInt16)(2)

Current version of the location DB format

Definition at line 186 of file LocsLibCommon.h.

#define kLocDisplayInCustom (UInt8)(1)

display location in custom database

Definition at line 165 of file LocsLibCommon.h.

#define kLocFileCDatabase (UInt32)('locL')

Definition at line 193 of file LocsLibCommon.h.

#define kLocFileNCustomDB "locLCusLocationDB"

Definition at line 197 of file LocsLibCommon.h.

#define kLocFileNDefaultDB "locLDefLocationDB"

Definition at line 196 of file LocsLibCommon.h.

#define kLocFileTCusLocDB (UInt32)('DATC')

Definition at line 195 of file LocsLibCommon.h.

#define kLocFileTDefLocDB (UInt32)('DATA')

Definition at line 194 of file LocsLibCommon.h.

#define kLocNameMaxLength (UInt16)(100)

Definition at line 158 of file LocsLibCommon.h.

#define kLocNoDisplayInCustom (UInt8)(0)

don't display location in custom database

Definition at line 164 of file LocsLibCommon.h.

#define kLocNoteMaxLength (UInt16)(4096)

Definition at line 161 of file LocsLibCommon.h.

#define kLocsFileCLocsLib (UInt32)('locL')

Library creator ID

Definition at line 114 of file LocsLibCommon.h.

#define kLocsLibDSTAlert (UInt32)(1)

Definition at line 222 of file LocsLibCommon.h.

#define kLocsLibDSTEndAlert (UInt32)(3)

Definition at line 224 of file LocsLibCommon.h.

#define kLocsLibDSTStartAlert (UInt32)(2)

Definition at line 223 of file LocsLibCommon.h.

#define kLocsLibFtrNumRefNum (UInt16)(1)

The feature number used to refer to the stored library reference number

Definition at line 117 of file LocsLibCommon.h.

#define kLocsLibListUpdate (UInt16)(kLocsLibListUpdateClass | 1)

Definition at line 177 of file LocsLibCommon.h.

#define kLocsLibListUpdateClass 0x0400

Definition at line 176 of file LocsLibCommon.h.

#define kLocsLibName "LocsLib-locL"

Library name

Definition at line 109 of file LocsLibCommon.h.

#define kLocsLibNotifyLocAddEvent kLocsLibNotifyLocChangeEvent + 3

Definition at line 131 of file LocsLibCommon.h.

#define kLocsLibNotifyLocChangeEvent kLocsFileCLocsLib

Definition at line 128 of file LocsLibCommon.h.

#define kLocsLibNotifyLocDeleteEvent kLocsLibNotifyLocChangeEvent + 2

Definition at line 130 of file LocsLibCommon.h.

#define kLocsLibNotifyLocEditEvent kLocsLibNotifyLocChangeEvent + 1

Definition at line 129 of file LocsLibCommon.h.

#define kLocsLibSel01 0x00000001

Definition at line 139 of file LocsLibCommon.h.

#define kLocsLibSel02 0x00000002

Definition at line 140 of file LocsLibCommon.h.

#define kLocsLibSel03 0x00000004

Definition at line 141 of file LocsLibCommon.h.

#define kLocsLibSel04 0x00000008

Definition at line 142 of file LocsLibCommon.h.

#define kLocsLibSel05 0x00000010

Definition at line 143 of file LocsLibCommon.h.

#define kLocsLibSel06 0x00000020

Definition at line 144 of file LocsLibCommon.h.

#define kLocsLibSel07 0x00000040

Definition at line 145 of file LocsLibCommon.h.

#define kLocsLibSel08 0x00000080

Definition at line 146 of file LocsLibCommon.h.

#define kLocsLibSel09 0x00000100

Definition at line 147 of file LocsLibCommon.h.

#define kLocsLibSelMax 0x80000000

Definition at line 148 of file LocsLibCommon.h.

#define kLocsLibVersion01 sysMakeROMVersion (1, 0, 0, sysROMStageDevelopment, 1)

Definition at line 71 of file LocsLibCommon.h.

#define kLocsLibVersion0121 sysMakeROMVersion (1, 2, 1, sysROMStageDevelopment, 1)

Definition at line 72 of file LocsLibCommon.h.

#define kLocsLibVersion013 sysMakeROMVersion (1, 3, 0, sysROMStageDevelopment, 1)

Definition at line 73 of file LocsLibCommon.h.

#define kLocsLibVersionCurrent kLocsLibVersion013

Definition at line 74 of file LocsLibCommon.h.

#define kUndefinedPosition (Int16)999

flag: position of location in database in undefined

Definition at line 168 of file LocsLibCommon.h.

#define LocationAreDSTDatesEqual | ( | iDST01P,
 |  | iDST02P | )

Value:

(   (iDST01P)->hour    == (iDST02P)->hour    \
                    && (iDST01P)->dayOrd  == (iDST02P)->dayOrd  \
                    && (iDST01P)->weekOrd == (iDST02P)->weekOrd \
                    && (iDST01P)->month   == (iDST02P)->month)

Definition at line 411 of file LocsLibCommon.h.

#define LocationGetCountry ( locationP ) (locationP)->country

Definition at line 383 of file LocsLibCommon.h.

#define LocationGetCustom ( locationP ) (locationP)->custom

Definition at line 384 of file LocsLibCommon.h.

#define LocationGetDSTAdj ( locationP ) (locationP)->dSTAdjustmentInMinutes

Definition at line 382 of file LocsLibCommon.h.

#define LocationGetDSTEnd ( locationP ) &((locationP)->dSTEnd)

Definition at line 381 of file LocsLibCommon.h.

#define LocationGetDSTStart ( locationP ) &((locationP)->dSTStart)

Definition at line 380 of file LocsLibCommon.h.

#define LocationGetName ( locationP ) (locationP)->name

Definition at line 386 of file LocsLibCommon.h.

#define LocationGetReserved ( locationP ) (locationP)->reserved

Definition at line 385 of file LocsLibCommon.h.

#define LocationGetUTC ( locationP ) (locationP)->uTC

Definition at line 379 of file LocsLibCommon.h.

#define LocationSetCountry | ( | locationP,
 |  | newCountry | ) | ((locationP)->country = newCountry)

Definition at line 401 of file LocsLibCommon.h.

#define LocationSetCustom | ( | locationP,
 |  | newCustom | ) | ((locationP)->custom = newCustom)

Definition at line 403 of file LocsLibCommon.h.

#define LocationSetDSTAdj | ( | locationP,
 |  | newDstAdj | ) | ((locationP)->dSTAdjustmentInMinutes = newDstAdj)

Definition at line 399 of file LocsLibCommon.h.

#define LocationSetDSTEnd | ( | locationP,
 |  | newDstEnd | ) | ((locationP)->dSTEnd = newDstEnd)

Definition at line 397 of file LocsLibCommon.h.

#define LocationSetDSTStart | ( | locationP,
 |  | newDstStart | ) | ((locationP)->dSTStart = newDstStart)

Definition at line 395 of file LocsLibCommon.h.

#define LocationSetReserved | ( | locationP,
 |  | newReserved | ) | ((locationP)->reserved = newReserved)

Definition at line 405 of file LocsLibCommon.h.

#define LocationSetUTC | ( | locationP,
 |  | newUTC | ) | ((locationP)->uTC = newUTC)

Definition at line 393 of file LocsLibCommon.h.

#define LocDBCompareCountries | ( | iCountry01,
 |  | iCountry02 | ) | (iCountry01 - iCountry02)

Definition at line 428 of file LocsLibCommon.h.

#define LocDBCompareNames | ( | iName01,
 |  | iName02 | ) | (StrCompare (iName01, iName02))

Definition at line 430 of file LocsLibCommon.h.

#define LocDBCompareUTC | ( | iUTC01,
 |  | iUTC02 | ) | (iUTC01 - iUTC02)

Definition at line 426 of file LocsLibCommon.h.

#define LocDBGetCountry ( locRecP ) (locRecP)->country

Definition at line 434 of file LocsLibCommon.h.

#define LocDBGetUTC ( locRecP ) (locRecP)->uTC

Definition at line 433 of file LocsLibCommon.h.

#define locLErrBadParam (locLErrorClass | 2)

Definition at line 89 of file LocsLibCommon.h.

#define locLErrBadRefNum (locLErrorClass | 3)

Definition at line 90 of file LocsLibCommon.h.

#define locLErrBadVersion (locLErrorClass | 9)

Definition at line 96 of file LocsLibCommon.h.

#define locLErrCantFindLocsDB (locLErrorClass | 1)

Definition at line 88 of file LocsLibCommon.h.

#define locLErrCantOpenLibRsc (locLErrorClass | 7)

Definition at line 94 of file LocsLibCommon.h.

#define locLErrMemAllocFail (locLErrorClass | 8)

Definition at line 95 of file LocsLibCommon.h.

#define locLErrNoGlobals (locLErrorClass | 4)

Definition at line 91 of file LocsLibCommon.h.

#define locLErrNoLibSysReference (locLErrorClass | 6)

Definition at line 93 of file LocsLibCommon.h.

#define locLErrNoMemForGlobals (locLErrorClass | 5)

Definition at line 92 of file LocsLibCommon.h.

#define locLErrNone 0

Definition at line 87 of file LocsLibCommon.h.

#define locLErrNotOpen (locLErrorClass | 10)

Definition at line 97 of file LocsLibCommon.h.

#define locLErrorClass (appErrorClass | 0x0100)

Definition at line 86 of file LocsLibCommon.h.

#define locLErrStillOpen (locLErrorClass | 11)

Definition at line 98 of file LocsLibCommon.h.

#define locsLibTrapDBChangeRecord (sysLibTrapCustom + 10)

Definition at line 461 of file LocsLibCommon.h.

#define locsLibTrapDBCmpRecordsSimple (sysLibTrapCustom + 11)

Definition at line 462 of file LocsLibCommon.h.

#define locsLibTrapDBConvertRecord (sysLibTrapCustom + 12)

Definition at line 463 of file LocsLibCommon.h.

#define locsLibTrapDBCopyLocation (sysLibTrapCustom + 13)

Definition at line 464 of file LocsLibCommon.h.

#define locsLibTrapDBDeleteRecord (sysLibTrapCustom + 14)

Definition at line 465 of file LocsLibCommon.h.

#define locsLibTrapDBFindCustomRecord (sysLibTrapCustom + 15)

Definition at line 466 of file LocsLibCommon.h.

#define locsLibTrapDBFindFirst (sysLibTrapCustom + 16)

Definition at line 467 of file LocsLibCommon.h.

#define locsLibTrapDBFindFirstByName (sysLibTrapCustom + 17)

Definition at line 468 of file LocsLibCommon.h.

#define locsLibTrapDBFindFirstByUTCCtry (sysLibTrapCustom + 18)

Definition at line 469 of file LocsLibCommon.h.

#define locsLibTrapDBFindFirstInList (sysLibTrapCustom + 19)

Definition at line 470 of file LocsLibCommon.h.

#define locsLibTrapDBGetCustomList (sysLibTrapCustom + 20)

Definition at line 471 of file LocsLibCommon.h.

#define locsLibTrapDBGetRecord (sysLibTrapCustom + 22)

Definition at line 473 of file LocsLibCommon.h.

#define locsLibTrapDBGetRecordList (sysLibTrapCustom + 21)

Definition at line 472 of file LocsLibCommon.h.

#define locsLibTrapDBInitDBs (sysLibTrapCustom + 23)

Definition at line 474 of file LocsLibCommon.h.

#define locsLibTrapDBNewRecord (sysLibTrapCustom + 24)

Definition at line 475 of file LocsLibCommon.h.

#define locsLibTrapDBOpenCustom (sysLibTrapCustom + 25)

Definition at line 476 of file LocsLibCommon.h.

#define locsLibTrapDBOpenDefault (sysLibTrapCustom + 26)

Definition at line 477 of file LocsLibCommon.h.

#define locsLibTrapDBRecordSize (sysLibTrapCustom + 27)

Definition at line 478 of file LocsLibCommon.h.

#define locsLibTrapDBSetRecordCustom (sysLibTrapCustom + 28)

Definition at line 479 of file LocsLibCommon.h.

#define locsLibTrapDBSort (sysLibTrapCustom + 29)

Definition at line 480 of file LocsLibCommon.h.

#define locsLibTrapDSTAlarmClear (sysLibTrapCustom + 30)

Definition at line 481 of file LocsLibCommon.h.

#define locsLibTrapDSTAlarmIsDST (sysLibTrapCustom + 31)

Definition at line 482 of file LocsLibCommon.h.

#define locsLibTrapDSTAlarmSet (sysLibTrapCustom + 32)

Definition at line 483 of file LocsLibCommon.h.

#define locsLibTrapGetVersion (sysLibTrapCustom + 0)

Definition at line 451 of file LocsLibCommon.h.

#define locsLibTrapLaunchEditListDlg (sysLibTrapCustom + 1)

Definition at line 452 of file LocsLibCommon.h.

#define locsLibTrapLaunchSelDialogue (sysLibTrapCustom + 2)

Definition at line 453 of file LocsLibCommon.h.

#define locsLibTrapLocationCopyV20 (sysLibTrapCustom + 46)

Definition at line 497 of file LocsLibCommon.h.

#define locsLibTrapLocationFinalV20 (sysLibTrapCustom + 40)

Definition at line 491 of file LocsLibCommon.h.

#define locsLibTrapLocationGetSizeV20 (sysLibTrapCustom + 45)

Definition at line 496 of file LocsLibCommon.h.

#define locsLibTrapLocationInitV20 (sysLibTrapCustom + 39)

Definition at line 490 of file LocsLibCommon.h.

#define locsLibTrapLocationSetNote (sysLibTrapCustom + 42)

Definition at line 493 of file LocsLibCommon.h.

#define locsLibTrapLocationSetPosition (sysLibTrapCustom + 43)

Definition at line 494 of file LocsLibCommon.h.

#define locsLibTrapLocCopy (sysLibTrapCustom + 3)

Definition at line 454 of file LocsLibCommon.h.

#define locsLibTrapLocDBChangeRecordV20 (sysLibTrapCustom + 36)

Definition at line 487 of file LocsLibCommon.h.

#define locsLibTrapLocDBConvertRecordV20 (sysLibTrapCustom + 35)

Definition at line 486 of file LocsLibCommon.h.

#define locsLibTrapLocDBFindCustomRecordV20 (sysLibTrapCustom + 47)

Definition at line 498 of file LocsLibCommon.h.

#define locsLibTrapLocDBGetNearestLocation (sysLibTrapCustom + 38)

Definition at line 489 of file LocsLibCommon.h.

#define locsLibTrapLocDBGetRecordListV20 (sysLibTrapCustom + 37)

Definition at line 488 of file LocsLibCommon.h.

#define locsLibTrapLocDBGetRecordV20 (sysLibTrapCustom + 34)

Definition at line 485 of file LocsLibCommon.h.

#define locsLibTrapLocDBGetVersion (sysLibTrapCustom + 41)

Definition at line 492 of file LocsLibCommon.h.

#define locsLibTrapLocDBNewRecordV20 (sysLibTrapCustom + 33)

Definition at line 484 of file LocsLibCommon.h.

#define locsLibTrapLocFinal (sysLibTrapCustom + 4)

Definition at line 455 of file LocsLibCommon.h.

#define locsLibTrapLocGetSize (sysLibTrapCustom + 5)

Definition at line 456 of file LocsLibCommon.h.

#define locsLibTrapLocInit (sysLibTrapCustom + 6)

Definition at line 457 of file LocsLibCommon.h.

#define locsLibTrapLocIsDSTPast (sysLibTrapCustom + 7)

Definition at line 458 of file LocsLibCommon.h.

#define locsLibTrapLocMakeGeneric (sysLibTrapCustom + 8)

Definition at line 459 of file LocsLibCommon.h.

#define locsLibTrapLocSetName (sysLibTrapCustom + 9)

Definition at line 460 of file LocsLibCommon.h.

#define locsLibTrapLocsLibLocationNote (sysLibTrapCustom + 44)

Definition at line 495 of file LocsLibCommon.h.

Typedef Documentation

typedef struct DSTDataTag DSTType

< Daylight saving time (DST) data format

Definition at line 238 of file LocsLibCommon.h.

typedef struct LocationDataTag LocationType

Definition at line 268 of file LocsLibCommon.h.

typedef struct LocDBInfoTag LocDBInfoType

Definition at line 291 of file LocsLibCommon.h.

typedef struct LocDBRecordTag LocDBRecordType

Definition at line 302 of file LocsLibCommon.h.

typedef UInt8 LocDBSortOrderType

Definition at line 211 of file LocsLibCommon.h.

typedef struct LocsLibNotifyDataTag LocsLibNotifyDataType

Definition at line 332 of file LocsLibCommon.h.

typedef struct LocsLibNotifyLocsDataTag LocsLibNotifyLocsDataType

Definition at line 323 of file LocsLibCommon.h.

typedef struct LocsLibSelLocsTag LocsLibSelLocsType

Definition at line 348 of file LocsLibCommon.h.

Enumeration Type Documentation

enum _LocDBSortOrderType

Location database sort constants

Enumerator:
kSortByNameCountryTZ
kSortByCountryTZName
kSortByCountryCodeTZName

Definition at line 205 of file LocsLibCommon.h.

00205                          {
00206     kSortByNameCountryTZ,
00207     kSortByCountryTZName,
00208     kSortByCountryCodeTZName
00209 };

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:07:37 2008 for Palm API Guide


Header Files » Incs » common » libraries » mms

MmsHelperCommon.h File Reference

Detailed Description

Public 68k common header files to be used with Default Helper Library.

Version:
1.0
This file contains the type and structure parameters for the MMS Helper Service Class. Developers should register to this service using Default Helper library if it wants to handle MMS.

Definition in file MmsHelperCommon.h.

Go to the source code of this file.

Data Structures

  • struct _HelperServiceMMSObjectType
  • struct _HelperServiceMMSDetailsType
    Helpers of this Service Class send an MMS message. More...

Defines

  • #define kHelperServiceClassIDMMS 'mms_'

Typedefs

  • typedef _HelperServiceMMSObjectType HelperServiceMMSObjectType
  • typedef _HelperServiceMMSDetailsType HelperServiceMMSDetailsType
    Helpers of this Service Class send an MMS message.

Define Documentation

#define kHelperServiceClassIDMMS 'mms_'

New helper class registered with PalmSource for sending by MMS

Definition at line 25 of file MmsHelperCommon.h.

Typedef Documentation

typedef struct _HelperServiceMMSDetailsType HelperServiceMMSDetailsType

Helpers of this Service Class send an MMS message.

"To" address(es) are passed in the 'pData' element of the main structure (HelperNotifyExecuteType)

The 'pDetails' struct member may optionally point to HelperServiceMMSDetailsType for this service class.

typedef struct _HelperServiceMMSObjectType HelperServiceMMSObjectType

Structure to hold the MMS object. This structure is part of the linked list which is pointed by the object member of HelperServiceMMSDetailsType

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:07:37 2008 for Palm API Guide


Header Files » Incs » common » libraries » netmaster

NetMasterLibErrors.h File Reference

Detailed Description

This is the error declarations file for the NetMaster Library.

Version:
1.0
Date:
01/31/2002

Definition in file NetMasterLibErrors.h.

Include dependency graph for NetMasterLibErrors.h:

Go to the source code of this file.

Defines

Net Master Error Codes
  • #define netMasterErrClass (hsNetMasterErrorClass)
  • #define netMasterErrMemory (netMasterErrClass + 0x01)
  • #define netMasterErrStorage (netMasterErrClass + 0x02)
  • #define netMasterErrBadArg (netMasterErrClass + 0x03)
  • #define netMasterErrNetNotInstalled (netMasterErrClass + 0x04)
  • #define netMasterErrDispatchTable (netMasterErrClass + 0x05)
  • #define netMasterErrNoNetPrefLib (netMasterErrClass + 0x06)
  • #define netMasterErrConfigNotFound (netMasterErrClass + 0x07)
  • #define netMasterErrConfigFailed (netMasterErrClass + 0x08)
  • #define netMasterErrNo1xService (netMasterErrClass + 0x09)
  • #define netMasterErrMIPFailed (netMasterErrClass + 0x0A)
  • #define netMasterErrBadPort (netMasterErrClass + 0x0B)
MIP Error Codes
Sprint's Mobile-IP (MIP) error codes.

  • #define netMasterErrMIPNoSimBindings (netMasterErrClass + 0x0C)
  • #define netMasterErrMIPReasonUnspecified64 (netMasterErrClass + 0x0D)
  • #define netMasterErrMIPAdminProhibited65 (netMasterErrClass + 0x0E)
  • #define netMasterErrMIPInsufficientResources66 (netMasterErrClass + 0x0F)
  • #define netMasterErrMIPMobileNodeAuth67 (netMasterErrClass + 0x10)
  • #define netMasterErrMIPHomeAgentAuth68 (netMasterErrClass + 0x11)
  • #define netMasterErrMIPReqLifetimeTooLong69 (netMasterErrClass + 0x12)
  • #define netMasterErrMIPPoorlyFormedReq70 (netMasterErrClass + 0x13)
  • #define netMasterErrMIPPoorlyFormedReply71 (netMasterErrClass + 0x14)
  • #define netMasterErrMIPReqedEncapUnavail72 (netMasterErrClass + 0x15)
  • #define netMasterErrMIPReservedNUnavail73 (netMasterErrClass + 0x16)
  • #define netMasterErrMIPCantRevTun74 (netMasterErrClass + 0x17)
  • #define netMasterErrMIPMustRevTun75 (netMasterErrClass + 0x18)
  • #define netMasterErrMIPBadTtl76 (netMasterErrClass + 0x19)
  • #define netMasterErrMIPInvalidCareOfAddr77 (netMasterErrClass + 0x1A)
  • #define netMasterErrMIPRegistration_Timeout78 (netMasterErrClass + 0x1B)
  • #define netMasterErrMIPDelivStyleNotSupported79 (netMasterErrClass + 0x1C)
  • #define netMasterErrMIPHome_Network_Unreachable80 (netMasterErrClass + 0x1D)
  • #define netMasterErrMIPHa_Host_Unreachable81 (netMasterErrClass + 0x1E)
  • #define netMasterErrMIPHa_Port_Unreachable82 (netMasterErrClass + 0x1F)
  • #define netMasterErrMIPHa_Unreachable88 (netMasterErrClass + 0x20)
  • #define netMasterErrMIPNonZeroHaRequested96 (netMasterErrClass + 0x21)
  • #define netMasterErrMIPMissingNai97 (netMasterErrClass + 0x22)
  • #define netMasterErrMIPForeign_Agent98 (netMasterErrClass + 0x23)
  • #define netMasterErrMIPMissingHa99 (netMasterErrClass + 0x24)
  • #define netMasterErrMIPErrorFa1_100 (netMasterErrClass + 0x25)
  • #define netMasterErrMIPErrorFa2_101 (netMasterErrClass + 0x26)
  • #define netMasterErrMIPUnknown_Challenge104 (netMasterErrClass + 0x27)
  • #define netMasterErrMIPMissing_Challenge105 (netMasterErrClass + 0x28)
  • #define netMasterErrMIPStale_Challenge106 (netMasterErrClass + 0x29)
  • #define netMasterErrMIPReasonUnspecified128 (netMasterErrClass + 0x2A)
  • #define netMasterErrMIPAdminProhibited129 (netMasterErrClass + 0x2B)
  • #define netMasterErrMIPInsufficientResources130 (netMasterErrClass + 0x2C)
  • #define netMasterErrMIPMobileNodeAuth131 (netMasterErrClass + 0x2D)
  • #define netMasterErrMIPForeignAgentAuth132 (netMasterErrClass + 0x2E)
  • #define netMasterErrMIPRegIdMismatch133 (netMasterErrClass + 0x2F)
  • #define netMasterErrMIPPoorlyFormedReq134 (netMasterErrClass + 0x30)
  • #define netMasterErrMIPTooManySimMobBindings135 (netMasterErrClass + 0x31)
  • #define netMasterErrMIPUnknownHaAddr136 (netMasterErrClass + 0x32)
  • #define netMasterErrMIPCantRevTun137 (netMasterErrClass + 0x33)
  • #define netMasterErrMIPMustRevTun138 (netMasterErrClass + 0x34)
  • #define netMasterErrMIPReqEncapNotAvail139 (netMasterErrClass + 0x35)
  • #define netMasterErrMIPErrorHa1_140 (netMasterErrClass + 0x36)
  • #define netMasterErrMIPErrorHa2_141 (netMasterErrClass + 0x37)
  • #define netMasterErrMIPUsernameSuspension801 (netMasterErrClass + 0x38)
  • #define netMasterErrMIPReserved2 (netMasterErrClass + 0x39)
  • #define netMasterErrMIPReserved3 (netMasterErrClass + 0x3A)
  • #define netMasterErrMIPReserved4 (netMasterErrClass + 0x3B)
Net Master Error Codes
  • #define netMasterErrAutoLoginNotPossible (netMasterErrClass + 0x3C)
  • #define netMasterErrCDMACarrierNetworkBusy (netMasterErrClass + 0x3D)
  • #define netMasterErrOneXServiceUnavailable (netMasterErrClass + 0x3E)
  • #define netMasterErrAuthReqDuringBGLogin (netMasterErrClass + 0x3F)
  • #define netMasterErrUIRPCTimeout (netMasterErrClass + 0x40)
  • #define netMasterErrInternalConnWouldBeImpossible (netMasterErrClass + 0x41)
  • #define netMasterErrNetGuardReqDuringBGLogin (netMasterErrClass + 0x42)
  • #define netMasterErrGPRSGenLoginErr (netMasterErrClass + 0x43)
  • #define netMasterErrNoOneXServiceWhileRoaming (netMasterErrClass + 0x44)
Reserved for future use
  • #define netMasterErrUnused45 (netMasterErrClass + 0x45)
  • #define netMasterErrUnused46 (netMasterErrClass + 0x46)
  • #define netMasterErrUnused47 (netMasterErrClass + 0x47)
  • #define netMasterErrUnused48 (netMasterErrClass + 0x48)
  • #define netMasterErrUnused49 (netMasterErrClass + 0x49)
  • #define netMasterErrUnused4A (netMasterErrClass + 0x4A)
  • #define netMasterErrUnused4B (netMasterErrClass + 0x4B)
  • #define netMasterErrUnused4C (netMasterErrClass + 0x4C)
  • #define netMasterErrUnused4D (netMasterErrClass + 0x4D)
  • #define netMasterErrUnused4E (netMasterErrClass + 0x4E)
Net Master Error Codes
  • #define netMasterErrOneXServiceNotEnabled (netMasterErrClass + 0x4F)

Define Documentation

#define netMasterErrAuthReqDuringBGLogin (netMasterErrClass + 0x3F)

Authentication UI prompt (such as username/password or script plug-in) was requested during background login -- this is not supported presently.

Definition at line 115 of file NetMasterLibErrors.h.

#define netMasterErrAutoLoginNotPossible (netMasterErrClass + 0x3C)

auto-login did not take place

Definition at line 107 of file NetMasterLibErrors.h.

#define netMasterErrBadArg (netMasterErrClass + 0x03)

invalid argument, unknown ID

Definition at line 34 of file NetMasterLibErrors.h.

#define netMasterErrBadPort (netMasterErrClass + 0x0B)

Invalid port number -- we remap this from serErrBadPort.

Definition at line 42 of file NetMasterLibErrors.h.

#define netMasterErrCDMACarrierNetworkBusy (netMasterErrClass + 0x3D)

"network busy" event was received from the carrier's network.

Definition at line 108 of file NetMasterLibErrors.h.

#define netMasterErrClass (hsNetMasterErrorClass)

hsNetMasterErrorClass is defined in HsErrorClasses.h as 0x7100

Definition at line 31 of file NetMasterLibErrors.h.

#define netMasterErrConfigFailed (netMasterErrClass + 0x08)

Attempt to configure network settings failed

Definition at line 39 of file NetMasterLibErrors.h.

#define netMasterErrConfigNotFound (netMasterErrClass + 0x07)

NetPref config not found

Definition at line 38 of file NetMasterLibErrors.h.

#define netMasterErrDispatchTable (netMasterErrClass + 0x05)

Unrecognized dipatch table format

Definition at line 36 of file NetMasterLibErrors.h.

#define netMasterErrGPRSGenLoginErr (netMasterErrClass + 0x43)

Generic GPRS login error -- returned when we don't have enough specific info about the cause of login failure.

Definition at line 148 of file NetMasterLibErrors.h.

#define netMasterErrInternalConnWouldBeImpossible (netMasterErrClass + 0x41)

auto-login did not take place

Definition at line 136 of file NetMasterLibErrors.h.

#define netMasterErrMemory (netMasterErrClass + 0x01)

runtime memory error

Definition at line 32 of file NetMasterLibErrors.h.

#define netMasterErrMIPAdminProhibited129 (netMasterErrClass + 0x2B)

Definition at line 80 of file NetMasterLibErrors.h.

#define netMasterErrMIPAdminProhibited65 (netMasterErrClass + 0x0E)

Definition at line 51 of file NetMasterLibErrors.h.

#define netMasterErrMIPBadTtl76 (netMasterErrClass + 0x19)

Definition at line 62 of file NetMasterLibErrors.h.

#define netMasterErrMIPCantRevTun137 (netMasterErrClass + 0x33)

Definition at line 88 of file NetMasterLibErrors.h.

#define netMasterErrMIPCantRevTun74 (netMasterErrClass + 0x17)

Definition at line 60 of file NetMasterLibErrors.h.

#define netMasterErrMIPDelivStyleNotSupported79 (netMasterErrClass + 0x1C)

Definition at line 65 of file NetMasterLibErrors.h.

#define netMasterErrMIPErrorFa1_100 (netMasterErrClass + 0x25)

Definition at line 74 of file NetMasterLibErrors.h.

#define netMasterErrMIPErrorFa2_101 (netMasterErrClass + 0x26)

Definition at line 75 of file NetMasterLibErrors.h.

#define netMasterErrMIPErrorHa1_140 (netMasterErrClass + 0x36)

Definition at line 91 of file NetMasterLibErrors.h.

#define netMasterErrMIPErrorHa2_141 (netMasterErrClass + 0x37)

Definition at line 92 of file NetMasterLibErrors.h.

#define netMasterErrMIPFailed (netMasterErrClass + 0x0A)

Generic Mobile-IP failure

Definition at line 41 of file NetMasterLibErrors.h.

#define netMasterErrMIPForeign_Agent98 (netMasterErrClass + 0x23)

Definition at line 72 of file NetMasterLibErrors.h.

#define netMasterErrMIPForeignAgentAuth132 (netMasterErrClass + 0x2E)

Definition at line 83 of file NetMasterLibErrors.h.

#define netMasterErrMIPHa_Host_Unreachable81 (netMasterErrClass + 0x1E)

Definition at line 67 of file NetMasterLibErrors.h.

#define netMasterErrMIPHa_Port_Unreachable82 (netMasterErrClass + 0x1F)

Definition at line 68 of file NetMasterLibErrors.h.

#define netMasterErrMIPHa_Unreachable88 (netMasterErrClass + 0x20)

Definition at line 69 of file NetMasterLibErrors.h.

#define netMasterErrMIPHome_Network_Unreachable80 (netMasterErrClass + 0x1D)

Definition at line 66 of file NetMasterLibErrors.h.

#define netMasterErrMIPHomeAgentAuth68 (netMasterErrClass + 0x11)

Definition at line 54 of file NetMasterLibErrors.h.

#define netMasterErrMIPInsufficientResources130 (netMasterErrClass + 0x2C)

Definition at line 81 of file NetMasterLibErrors.h.

#define netMasterErrMIPInsufficientResources66 (netMasterErrClass + 0x0F)

Definition at line 52 of file NetMasterLibErrors.h.

#define netMasterErrMIPInvalidCareOfAddr77 (netMasterErrClass + 0x1A)

Definition at line 63 of file NetMasterLibErrors.h.

#define netMasterErrMIPMissing_Challenge105 (netMasterErrClass + 0x28)

Definition at line 77 of file NetMasterLibErrors.h.

#define netMasterErrMIPMissingHa99 (netMasterErrClass + 0x24)

Definition at line 73 of file NetMasterLibErrors.h.

#define netMasterErrMIPMissingNai97 (netMasterErrClass + 0x22)

Definition at line 71 of file NetMasterLibErrors.h.

#define netMasterErrMIPMobileNodeAuth131 (netMasterErrClass + 0x2D)

Definition at line 82 of file NetMasterLibErrors.h.

#define netMasterErrMIPMobileNodeAuth67 (netMasterErrClass + 0x10)

Definition at line 53 of file NetMasterLibErrors.h.

#define netMasterErrMIPMustRevTun138 (netMasterErrClass + 0x34)

Definition at line 89 of file NetMasterLibErrors.h.

#define netMasterErrMIPMustRevTun75 (netMasterErrClass + 0x18)

Definition at line 61 of file NetMasterLibErrors.h.

#define netMasterErrMIPNonZeroHaRequested96 (netMasterErrClass + 0x21)

Definition at line 70 of file NetMasterLibErrors.h.

#define netMasterErrMIPNoSimBindings (netMasterErrClass + 0x0C)

Definition at line 49 of file NetMasterLibErrors.h.

#define netMasterErrMIPPoorlyFormedReply71 (netMasterErrClass + 0x14)

Definition at line 57 of file NetMasterLibErrors.h.

#define netMasterErrMIPPoorlyFormedReq134 (netMasterErrClass + 0x30)

Definition at line 85 of file NetMasterLibErrors.h.

#define netMasterErrMIPPoorlyFormedReq70 (netMasterErrClass + 0x13)

Definition at line 56 of file NetMasterLibErrors.h.

#define netMasterErrMIPReasonUnspecified128 (netMasterErrClass + 0x2A)

Definition at line 79 of file NetMasterLibErrors.h.

#define netMasterErrMIPReasonUnspecified64 (netMasterErrClass + 0x0D)

Definition at line 50 of file NetMasterLibErrors.h.

#define netMasterErrMIPRegIdMismatch133 (netMasterErrClass + 0x2F)

Definition at line 84 of file NetMasterLibErrors.h.

#define netMasterErrMIPRegistration_Timeout78 (netMasterErrClass + 0x1B)

Definition at line 64 of file NetMasterLibErrors.h.

#define netMasterErrMIPReqedEncapUnavail72 (netMasterErrClass + 0x15)

Definition at line 58 of file NetMasterLibErrors.h.

#define netMasterErrMIPReqEncapNotAvail139 (netMasterErrClass + 0x35)

Definition at line 90 of file NetMasterLibErrors.h.

#define netMasterErrMIPReqLifetimeTooLong69 (netMasterErrClass + 0x12)

Definition at line 55 of file NetMasterLibErrors.h.

#define netMasterErrMIPReserved2 (netMasterErrClass + 0x39)

Reserved for future use

Definition at line 98 of file NetMasterLibErrors.h.

#define netMasterErrMIPReserved3 (netMasterErrClass + 0x3A)

Reserved for future use

Definition at line 99 of file NetMasterLibErrors.h.

#define netMasterErrMIPReserved4 (netMasterErrClass + 0x3B)

Reserved for future use

Definition at line 100 of file NetMasterLibErrors.h.

#define netMasterErrMIPReservedNUnavail73 (netMasterErrClass + 0x16)

Definition at line 59 of file NetMasterLibErrors.h.

#define netMasterErrMIPStale_Challenge106 (netMasterErrClass + 0x29)

Definition at line 78 of file NetMasterLibErrors.h.

#define netMasterErrMIPTooManySimMobBindings135 (netMasterErrClass + 0x31)

Definition at line 86 of file NetMasterLibErrors.h.

#define netMasterErrMIPUnknown_Challenge104 (netMasterErrClass + 0x27)

Definition at line 76 of file NetMasterLibErrors.h.

#define netMasterErrMIPUnknownHaAddr136 (netMasterErrClass + 0x32)

Definition at line 87 of file NetMasterLibErrors.h.

#define netMasterErrMIPUsernameSuspension801 (netMasterErrClass + 0x38)

801 Username suspension due to repeated incorrect passwords being sent

Definition at line 97 of file NetMasterLibErrors.h.

#define netMasterErrNetGuardReqDuringBGLogin (netMasterErrClass + 0x42)

Net Guard prompt would have been required during background login. Prompting is presently not supported during background login.

Definition at line 142 of file NetMasterLibErrors.h.

#define netMasterErrNetNotInstalled (netMasterErrClass + 0x04)

NetLib has not been installed

Definition at line 35 of file NetMasterLibErrors.h.

#define netMasterErrNo1xService (netMasterErrClass + 0x09)

1xRTT is not available

Definition at line 40 of file NetMasterLibErrors.h.

#define netMasterErrNoNetPrefLib (netMasterErrClass + 0x06)

NetPref library not found

Definition at line 37 of file NetMasterLibErrors.h.

#define netMasterErrNoOneXServiceWhileRoaming (netMasterErrClass + 0x44)

Sprint OneX service is unavailable while roaming

Definition at line 153 of file NetMasterLibErrors.h.

#define netMasterErrOneXServiceNotEnabled (netMasterErrClass + 0x4F)

modem doesn't support requested service

Definition at line 184 of file NetMasterLibErrors.h.

#define netMasterErrOneXServiceUnavailable (netMasterErrClass + 0x3E)

< requested service unavailable

Definition at line 109 of file NetMasterLibErrors.h.

#define netMasterErrStorage (netMasterErrClass + 0x02)

storage memory error

Definition at line 33 of file NetMasterLibErrors.h.

#define netMasterErrUIRPCTimeout (netMasterErrClass + 0x40)

UI RPC timed out during a background-initiated login. This is an internal error that might occur if the current UI app is not processing events for a long time.

Definition at line 121 of file NetMasterLibErrors.h.

#define netMasterErrUnused45 (netMasterErrClass + 0x45)

Definition at line 169 of file NetMasterLibErrors.h.

#define netMasterErrUnused46 (netMasterErrClass + 0x46)

Definition at line 170 of file NetMasterLibErrors.h.

#define netMasterErrUnused47 (netMasterErrClass + 0x47)

Definition at line 171 of file NetMasterLibErrors.h.

#define netMasterErrUnused48 (netMasterErrClass + 0x48)

Definition at line 172 of file NetMasterLibErrors.h.

#define netMasterErrUnused49 (netMasterErrClass + 0x49)

Definition at line 173 of file NetMasterLibErrors.h.

#define netMasterErrUnused4A (netMasterErrClass + 0x4A)

Definition at line 174 of file NetMasterLibErrors.h.

#define netMasterErrUnused4B (netMasterErrClass + 0x4B)

Definition at line 175 of file NetMasterLibErrors.h.

#define netMasterErrUnused4C (netMasterErrClass + 0x4C)

Definition at line 176 of file NetMasterLibErrors.h.

#define netMasterErrUnused4D (netMasterErrClass + 0x4D)

Definition at line 177 of file NetMasterLibErrors.h.

#define netMasterErrUnused4E (netMasterErrClass + 0x4E)

Definition at line 178 of file NetMasterLibErrors.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:07:38 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » netmaster

NetMasterLibrary.h File Reference

Detailed Description

This is the main header file for the NetMaster Library.

Version:
1.0
Date:
01/31/2002
Usage Model

The NetMaster library is preloaded by the system software before the system sends sysAppLaunchCmdSystemReset.

Clients of NetMaster library need to call SysLibFind (netMasterLibName,...) to get a library refNum of NetMaster.

If SysLibFind returns a non-zero error, clients MUST assume that NetMaster was not loaded for a good reason (such as when the user performed a "safe" reset), or is simply not present on the system and fail gracefully.

Clients MUST NOT load NetMaster themselves (such as via SysLibLoad or SysLibInstall) -- keep in mind that if the system didn't load it, there was a good reason for it!

Definition in file NetMasterLibrary.h.

Include dependency graph for NetMasterLibrary.h:

Go to the source code of this file.

Defines

  • #define NETMASTER_LIB_TRAP(trapNum) SYS_TRAP(trapNum)

Functions

  • Err NetMasterLibVersionGet (UInt16 refNum, UInt32 *majorVerP, UInt32 *minorVerP, UInt32 *bugFixVerP)
  • Err NetMasterNetLibOpenWithOptions (UInt16 refNum, NetMasterNetLibOpenOptionsType netLibOpenOptions, UInt16 *netIFErrsP)
  • Err NetMasterAutoLoginSettingGet (UInt16 refNum, NetMasterAutoLoginType *settingsP)
  • Err NetMasterAutoLoginSettingSet (UInt16 refNum, NetMasterAutoLoginType flagsToClear, NetMasterAutoLoginType flagsToSet)
  • Boolean NetMasterNetLibOpenIfFullyUp (UInt16 refNum, UInt16 *netLibRefNumP)
  • Boolean NetMasterNetLibIsFullyUp (UInt16 refNum)
  • Err NetMasterNetInterfacesShutDown (UInt16 refNum, Err reasonErrCode, NetMasterNetIFShutDownOptionsType shutDownOptions)
  • Boolean NetMasterNetLibIsLoggingIn (UInt16 refNum, Boolean *isLogonActiveP, Boolean *isPrgDialogUpP, Boolean *waitingInErrorStateP)
  • Err NetMasterSCNetAttach (UInt16 refNum, UInt32 netPrefRecID, NetMasterNetLibOpenOptionsType netLibOpenOptions, NetMasterLoginPriorityEnum loginPriority, Int32 anchorTimeoutSec, NetMasterDataContextIDType *dataCxtIDP, Boolean *isNetIFErrorP)
  • Err NetMasterSCNetDetach (UInt16 refNum, NetMasterDataContextIDType dataCxtID)
  • Err NetMasterSCContextAnchorTimeoutSet (UInt16 refNum, NetMasterDataContextIDType dataCxtID, Int32 requestedAnchorTimeoutSec, Int32 *oActualAnchorTimeoutSecP)
  • Err NetMasterSCSessionIDGetFromContext (UInt16 refNum, NetMasterDataContextIDType dataCxtID, NetMasterDataSessionIDType *sessionP)
  • Err NetMasterSCSessionCountGet (UInt16 refNum, Int16 *activeSessionCountP)
  • Err NetMasterSCSessionsEnumerate (UInt16 refNum, NetMasterDataSessionIDType sessionIDs[], Int16 maxEntries, Int16 *entriesStoredP)
  • Err NetMasterSCSessionSvcRecIDGet (UInt16 refNum, NetMasterDataSessionIDType sessionID, UInt32 *primaryNetPrefIDP, UInt32 *actualNetPrefIDP)
  • Err NetMasterSCSessionIsActive (UInt16 refNum, NetMasterDataSessionIDType sessionID, Boolean *isActiveP)
  • Err NetMasterSCSessionShutDown (UInt16 refNum, NetMasterDataSessionIDType sessionID, NetMasterNetIFShutDownOptionsType shutDownOptions)

Define Documentation

#define NETMASTER_LIB_TRAP ( trapNum ) SYS_TRAP(trapNum)

Definition at line 58 of file NetMasterLibrary.h.

Function Documentation

Err NetMasterAutoLoginSettingGet | ( | UInt16 | refNum,
 |  | NetMasterAutoLoginType * | settingsP
 | ) |  |

Get the "auto-login" settings

Parameters:
refNum,: IN: NetMasterLib reference number (from SysLibFind).
settingsP,: OUT: Any of the NetMasterAutoLoginType constants bitwise-or’ed together.
Return values:
Err Error code.

Err NetMasterAutoLoginSettingSet | ( | UInt16 | refNum,
 |  | NetMasterAutoLoginType | flagsToClear,
 |  | NetMasterAutoLoginType | flagsToSet
 | ) |  |

NetMasterAutoLoginSettingSet:

set the "auto-login" settings

Parameters:
refNum,: IN: NetMasterLib reference number.
flagsToClear,: IN: Flags to clear -- any of the NetMasterAutoLoginType constants bitwise-or'ed together or netMasterAutoLoginClearAll to clear all flags; the flag clearing operation is performed before the flag setting operation. Pass 0 to skip the clearing operation.
flagsToSet,: IN: Flags to set -- any of the NetMasterAutoLoginType constants bitwise-or'ed together. Pass 0 to skip the setting operation.
Return values:
Err Error code.

Err NetMasterLibVersionGet | ( | UInt16 | refNum,
 |  | UInt32 * | majorVerP,
 |  | UInt32 * | minorVerP,
 |  | UInt32 * | bugFixVerP
 | ) |  |

Get Library API Version number.

Parameters:
refNum,: IN: Library reference number
majorVerP,: OUT: Major version number
minorVerP,: OUT: Minor version number
bugFixVerP,: OUT: Bug fix version number
Return values:
Err NetMaster Library error code

Err NetMasterNetInterfacesShutDown | ( | UInt16 | refNum,
 |  | Err | reasonErrCode,
 |  | NetMasterNetIFShutDownOptionsType | shutDownOptions
 | ) |  |

Shut down NetLib's interfaces, if they are presently up; does nothing if they are presently down; blocking; If NetLib is in the process of logging on to the IP network (Connection progress dialog is up), will simulate the press of the Cancel key and return without waiting for interfaces to shut down.

WARNING: will dead-lock if called from the context of a Notification Manager notification. This is because Notification Manager erroneously grabs the Memory Manager semaphore before sending a notification, and this causes a dead-lock when the TCP/IP stack's background task calls into Memory Manager or Data Manager API as part of the shut-down.

Shut down NetLib’s interfaces, if they are presently up; does nothing if they are presently down.

Parameters:
refNum,: IN: NetMasterLib reference number (from SysLibFind)
reasonErrCode,: IN: Error code that is the reason for this call to NetMasterNetInterfacesShutDown; 0 if not an error, or reason is unknown. Future version of this API may use the error code to display an alert or log a debug trace.
shutDownOptions,: IN: Shutdown options. See NetMasterNetIFShutDownOptionsType.
Return values:
Err Error code.

Boolean NetMasterNetLibIsFullyUp ( UInt16 refNum )

Function: NetMasterNetLibIsFullyUp

Summary: Checks if NetLib is fully up -- i.e. all of its interfaces are up.

Parameters:
refNum,: IN: NetMasterLib reference number (from SysLibFind
Return values:
Boolean True if NetLib is fully up, false if at least one interface is down.

Boolean NetMasterNetLibIsLoggingIn | ( | UInt16 | refNum,
 |  | Boolean * | isLogonActiveP,
 |  | Boolean * | isPrgDialogUpP,
 |  | Boolean * | waitingInErrorStateP
 | ) |  |

Test if NetLib is in the Logging On state. Returns true if some client is presently inside NetLibOpen or NetLibOpenConfig.

Parameters:
refNum,: IN: NetMaster library reference number.
isLogonActiveP,: OUT: True if NetLib is in the middle of logging in and an error has not yet been encountered. This parameter is OPTIONAL -- pass NULL to ignore.
isPrgDialogUpP,: OUT: If NetLib's Service Connection Progress dialog is up, NetMasterIsLoggingIn will set isPrgDialogUpP to true; false otherwise. This parameter is OPTIONAL -- pass NULL to ignore.
waitingInErrorStateP,: OUT: If NetLib's Service Connection Prorgress dialog is in the error acknowledegement state (displaying an error message to the user, waiting for OK), NetMasterIsLoggingIn will set waitingInErrorStateP to true; false otherwise. This parameter is OPTIONAL -- pass NULL to ignore.
Return values:
Boolean True if some client is presently inside NetLibOpen or NetLibOpenConfig.

Boolean NetMasterNetLibOpenIfFullyUp | ( | UInt16 | refNum,
 |  | UInt16 * | netLibRefNumP
 | ) |  |

Function: NetMasterNetLibOpenIfFullyUp

Summary: Open NetLib only if all of its current interfaces are already fully up. If this call succeeds (returns true), it is semantically equivalent to a successful NetLibOpen call, which implies that the caller is responsible for calling NetLibClose to match this call when done with NetLib. If NetMasterNetLibOpenIfFullyUp fails (returns false), the caller *MUST NOT* make a matching call to NetLibClose.

Parameters:
refNum,: IN: NetMasterLib reference number (from SysLibFind or SysLibLoad)
netLibRefNumP,: OUT: NetLib refnum on success, undefined on failure
Return values:
Boolean True if opened, false if not (failure)

Err NetMasterNetLibOpenWithOptions | ( | UInt16 | refNum,
 |  | NetMasterNetLibOpenOptionsType | netLibOpenOptions,
 |  | UInt16 * | netIFErrsP
 | ) |  |

An extension, of sorts, of the NetLibOpen function -- allows the caller to specify special options, such as "auto-dismiss on error". See the definition of NetMasterNetLibOpenOptionsType for more details.

The refNum parameter must be the refnum of NetMaster library (not of NetLib).

IMPORTANT: This call is semantically equivalent to calling NetLibOpen; if this call succeeds (returns 0 error code), the caller is responsible for calling NetLibClose when done with NetLib; if this call fails (non-zero error code returned), the caller must *NOT* make the matching call to NetLibClose.

Parameters:
refNum,: IN: NetMasterLib reference number (from SysLibFind()).
netLibOpenOptions,: IN: See NetMasterNetLibOpenOptionsType.
netIFErrsP OUT: Error returned by the net interface if open failed.
Return values:
Err Error code.

Err NetMasterSCContextAnchorTimeoutSet | ( | UInt16 | refNum,
 |  | NetMasterDataContextIDType | dataCxtID,
 |  | Int32 | requestedAnchorTimeoutSec,
 |  | Int32 * | oActualAnchorTimeoutSecP
 | ) |  |

Changes the data context's session anchor timeout value. The requested anchor timeout value is in seconds. The system will apply internal limits to the value if necessary. The actual value is returned via the optional output arugment oActualAnchorTimeoutSecP (pass NULL to ignore).

IMPORTANT: If the application is in a state where the anchor timeout that it initially requested when calling NetMasterSCNetAttach is now bigger than necessary, the application MUST reduce its anchor timeout to the minimum acceptable value so that other services may be activated more quickly when necessary.

Parameters:
refNum,: IN: NetMasterLib reference number (from SysLibFind).
dataCxtID,: IN: Data context created by NetMasterSCNetAttach.
requestedAnchorTimeoutSec,: IN: Requested anchor timeout in seconds.
oActualAnchorTimeoutSecP,: OUT: Actual anchor timeout that was applied (pass NULL to ignore). Undefined on error.
Return values:
Err Error code.

Err NetMasterSCNetAttach | ( | UInt16 | refNum,
 |  | UInt32 | netPrefRecID,
 |  | NetMasterNetLibOpenOptionsType | netLibOpenOptions,
 |  | NetMasterLoginPriorityEnum | loginPriority,
 |  | Int32 | anchorTimeoutSec,
 |  | NetMasterDataContextIDType * | dataCxtIDP,
 |  | Boolean * | isNetIFErrorP
 | ) |  |

Attach to the network using the specified service; this will call NetLibOpen and execute any required fallback services, as necessary on the caller’s behalf.

Parameters:
refNum,: IN: NetMasterLib reference number (from SysLibFind).
netPrefRecID,: IN: NetPref Record ID of the network profile to attach.
netLibOpenOptions,: IN: Special options, such as “auto-dismiss on error”; 0 = no options.
loginPriority,: IN: Login priority. Most applications should use the netMasterLoginPriorityDefault priority.
anchorTimeoutSec,: IN: It is bigger than maximum allowed for the given device configuration. This value is used by the system to decide when a data session may be considered idle, and may be shut down to make room for a different login request. This value is treated as a hint only, and the system makes no guarantees about the longevity of the data session. The duration is in seconds, which may be 0. For system default, pass netMasterAnchorTimeoutDefault (RECOMMENDED!)
dataCxtIDP,: OUT: Data context on success, undefined on failure.
isNetIFErrorP,: OUT: When non zero error code is returned, this boolean indicates whether the error was from the network interface. For foreground-initiated logins, the implication is that if it *is* an error from the network interface, an error message was most likely already displayed to the user via the standard progress dialog UI. If the error is *not* from the network interface, no error has been displayed to the user. Pass NULL to ignore this parameter.
Return values:
Err Error code.

Err NetMasterSCNetDetach | ( | UInt16 | refNum,
 |  | NetMasterDataContextIDType | dataCxtID
 | ) |  |

Detach from the data session that was successfully established by NetMasterSCNetAttach.

Parameters:
refNum,: IN: NetMasterLib reference number (from SysLibFind).
dataCxtID,: IN: Data context created by NetMasterSCNetAttach.
Return values:
Err Error code.

Err NetMasterSCSessionCountGet | ( | UInt16 | refNum,
 |  | Int16 * | activeSessionCountP
 | ) |  |

Get the current count of network data sessions that are active (believed to be logged in).

Parameters:
refNum,: IN: NetMasterLib reference number (from SysLibFind).
activeSessionCountP,: OUT: Count of active data sessions.
Return values:
Err Error code.

Err NetMasterSCSessionIDGetFromContext | ( | UInt16 | refNum,
 |  | NetMasterDataContextIDType | dataCxtID,
 |  | NetMasterDataSessionIDType * | sessionP
 | ) |  |

Given a data context, get the associated data session ID. 0 or more data contexts may be associated with a data session. A data session represents a single network login instance. i.e., if you had two concurrent network login instances, such as GPRS and 802.11 for example, there would be two network data sessions.

Parameters:
refNum,: IN: NetMasterLib reference number (from SysLibFind).
dataCxtID,: IN: Data context created by NetMasterSCNetAttach.
sessionP,: OUT: Data session ID on success, undefined on failure.
Return values:
Err Error code.

Err NetMasterSCSessionIsActive | ( | UInt16 | refNum,
 |  | NetMasterDataSessionIDType | sessionID,
 |  | Boolean * | isActiveP
 | ) |  |

Checks if the given session is still on the active list (believed to be logged in).

Parameters:
refNum,: IN: NetMasterLib reference number (from SysLibFind).
sessionID,: IN: Data session ID.
isActiveP,: OUT: True if the given session is believed to be logged in, false if it’s not logged in.
Return values:
Err Error code.

Err NetMasterSCSessionsEnumerate | ( | UInt16 | refNum,
 |  | NetMasterDataSessionIDType | sessionIDs[],
 |  | Int16 | maxEntries,
 |  | Int16 * | entriesStoredP
 | ) |  |

Fill an array with session ID's of the currently active data sessions. Initially, only one active data session may be supported, but this may increase with the hardware and system software capabilities.

Parameters:
refNum,: IN: NetMasterLib reference number (from SysLibFind).
sessionIDs,: OUT: Array for returning session IDs on success, contents undefined on failure.
maxEntries,: IN: Max # of session ID’s that may be stored in the caller’s array sessionIDs.
entriesStoredP,: OUT: On success, number of entries that were actually returned in the sessionIDs array, which may be less than maxEntries (possibly 0); undefined on failure.
Err Error code.

Err NetMasterSCSessionShutDown | ( | UInt16 | refNum,
 |  | NetMasterDataSessionIDType | sessionID,
 |  | NetMasterNetIFShutDownOptionsType | shutDownOptions
 | ) |  |

Request shut down of the given network session. This function may block for a significant period of time (typically multiple seconds) while the network interfaces are being brought down.

Parameters:
refNum,: IN: NetMasterLib reference number (from SysLibFind).
sessionID,: IN: data session ID.
shutDownOptions,: IN: shutdown options. See NetMasterNetIFShutDownOptionsType.
Return values:
Err Error code.

Err NetMasterSCSessionSvcRecIDGet | ( | UInt16 | refNum,
 |  | NetMasterDataSessionIDType | sessionID,
 |  | UInt32 * | primaryNetPrefIDP,
 |  | UInt32 * | actualNetPrefIDP
 | ) |  |

Retrieves the unique ID's of the actual and primary NetPref records that were used to establish the data session. The two may be different if the primary record had a fallback, the primary failed, and the fallback record succeeded. In other words, *actualNetPrefIDP indicates the NetPref record ID that succeeded in establishing the connection.

Parameters:
refNum,: IN: NetMasterLib reference number (from SysLibFind).
sessionID,: IN: Data session ID.
primaryNetPrefIDP,: OUT: NetPref record ID of the primary record used in connection establishment.
actualNetPrefIDP,: OUT: NetPref record ID of the actual record with which connection establishment succeeded. This may be the same as the primary record or a fallback of the primary record.
Return values:
Err Error code.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:07:38 2008 for Palm API Guide


Header Files » Incs » common » libraries » netmaster

NetMasterLibTarget.h File Reference

Detailed Description

This is the target parameters file for the NetMaster Library.

Version:
1.0
Date:
01/31/2002
We break out these definitions so that other portable modules could access them without PalmOS-specific definitions

Definition in file NetMasterLibTarget.h.

Go to the source code of this file.

Defines

  • #define netMasterLibCreatorID 'HsNM'
  • #define netMasterLibTypeID 'libr'
  • #define netMasterLibName "HsNetMasterLibrary.lib"

Define Documentation

#define netMasterLibCreatorID 'HsNM'

NetMaster Library database creator

Definition at line 28 of file NetMasterLibTarget.h.

#define netMasterLibName "HsNetMasterLibrary.lib"

Internal library name which can be passed to SysLibFind()

Definition at line 32 of file NetMasterLibTarget.h.

#define netMasterLibTypeID 'libr'

Standard library database type

Definition at line 30 of file NetMasterLibTarget.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:07:38 2008 for Palm API Guide


Header Files » Incs » common » libraries » netmaster

NetMasterLibTraps.h File Reference

Detailed Description

Trap definitions for the NetMaster Library.

Version:
1.0
Date:
01/31/2002

Definition in file NetMasterLibTraps.h.

Go to the source code of this file.

Defines

NetMaster Function Trap Numbers
  • #define netMasterLibTrapLibVersionGet (sysLibTrapCustom + 0)
  • #define netMasterLibTrapSCNetAttach (sysLibTrapCustom + 1)
  • #define netMasterLibTrapLibInit (sysLibTrapCustom + 2)
  • #define netMasterLibTrapAutoLoginSettingGet (sysLibTrapCustom + 3)
  • #define netMasterLibTrapAutoLoginSettingSet (sysLibTrapCustom + 4)
  • #define netMasterLibTrapServiceSetUp (sysLibTrapCustom + 5)
  • #define netMasterLibTrapNetLibOpenIfFullyUp (sysLibTrapCustom + 6)
  • #define netMasterLibTrapNetLibIsFullyUp (sysLibTrapCustom + 7)
  • #define netMasterLibTrapPhoneServiceClassesGet (sysLibTrapCustom + 8)
  • #define netMasterLibTrapHandlePhoneEvent (sysLibTrapCustom + 9)
  • #define netMasterLibTrapControl (sysLibTrapCustom + 10)
  • #define netMasterLibTrapNetInterfacesShutDown (sysLibTrapCustom + 11)
  • #define netMasterLibTrapNetLibIsLoggingIn (sysLibTrapCustom + 12)
  • #define netMasterLibTrapNetLibOpenWithOptions (sysLibTrapCustom + 13)
  • #define netMasterLibTrapImplementNetLibOpenConfig (sysLibTrapCustom + 14)
  • #define netMasterLibTrapImplementNetLibConnectionRefresh (sysLibTrapCustom + 15)
  • #define netMasterLibTrapImplementNetLibHandlePowerOff (sysLibTrapCustom + 16)
  • #define netMasterLibTrapOverrideErrorGetAndClear (sysLibTrapCustom + 17)
  • #define netMasterLibTrapOverrideMdmInitStrGetPtr (sysLibTrapCustom + 18)
  • #define netMasterLibTrapLoginSMFlagsSetAndGet (sysLibTrapCustom + 19)
  • #define netMasterLibTrapDataSessionErrorNotify (sysLibTrapCustom + 20)
  • #define netMasterLibTrapSCNetDetach (sysLibTrapCustom + 21)
  • #define netMasterLibTrapSCSessionIDGetFromContext (sysLibTrapCustom + 22)
  • #define netMasterLibTrapSCSessionCountGet (sysLibTrapCustom + 23)
  • #define netMasterLibTrapSCSessionsEnumerate (sysLibTrapCustom + 24)
  • #define netMasterLibTrapSCSessionSvcRecIDGet (sysLibTrapCustom + 25)
  • #define netMasterLibTrapSCSessionIsActive (sysLibTrapCustom + 26)
  • #define netMasterLibTrapSCSessionShutDown (sysLibTrapCustom + 27)
  • #define netMasterLibTrapLoginExecuteFromUI (sysLibTrapCustom + 28)
  • #define netMasterLibTrapSCContextAnchorTimeoutSet (sysLibTrapCustom + 29)
  • #define netMasterLibTrapPPPPayloadReport (sysLibTrapCustom + 30)
  • #define netMasterLibTrapDataCounterGetAndReset (sysLibTrapCustom + 31)

Define Documentation

#define netMasterLibTrapAutoLoginSettingGet (sysLibTrapCustom + 3)

Definition at line 32 of file NetMasterLibTraps.h.

#define netMasterLibTrapAutoLoginSettingSet (sysLibTrapCustom + 4)

Definition at line 33 of file NetMasterLibTraps.h.

#define netMasterLibTrapControl (sysLibTrapCustom + 10)

Definition at line 39 of file NetMasterLibTraps.h.

#define netMasterLibTrapDataCounterGetAndReset (sysLibTrapCustom + 31)

Definition at line 60 of file NetMasterLibTraps.h.

#define netMasterLibTrapDataSessionErrorNotify (sysLibTrapCustom + 20)

Definition at line 49 of file NetMasterLibTraps.h.

#define netMasterLibTrapHandlePhoneEvent (sysLibTrapCustom + 9)

Definition at line 38 of file NetMasterLibTraps.h.

#define netMasterLibTrapImplementNetLibConnectionRefresh (sysLibTrapCustom + 15)

Definition at line 44 of file NetMasterLibTraps.h.

#define netMasterLibTrapImplementNetLibHandlePowerOff (sysLibTrapCustom + 16)

Definition at line 45 of file NetMasterLibTraps.h.

#define netMasterLibTrapImplementNetLibOpenConfig (sysLibTrapCustom + 14)

Definition at line 43 of file NetMasterLibTraps.h.

#define netMasterLibTrapLibInit (sysLibTrapCustom + 2)

Definition at line 31 of file NetMasterLibTraps.h.

#define netMasterLibTrapLibVersionGet (sysLibTrapCustom + 0)

Definition at line 29 of file NetMasterLibTraps.h.

#define netMasterLibTrapLoginExecuteFromUI (sysLibTrapCustom + 28)

Definition at line 57 of file NetMasterLibTraps.h.

#define netMasterLibTrapLoginSMFlagsSetAndGet (sysLibTrapCustom + 19)

Definition at line 48 of file NetMasterLibTraps.h.

#define netMasterLibTrapNetInterfacesShutDown (sysLibTrapCustom + 11)

Definition at line 40 of file NetMasterLibTraps.h.

#define netMasterLibTrapNetLibIsFullyUp (sysLibTrapCustom + 7)

Definition at line 36 of file NetMasterLibTraps.h.

#define netMasterLibTrapNetLibIsLoggingIn (sysLibTrapCustom + 12)

Definition at line 41 of file NetMasterLibTraps.h.

#define netMasterLibTrapNetLibOpenIfFullyUp (sysLibTrapCustom + 6)

Definition at line 35 of file NetMasterLibTraps.h.

#define netMasterLibTrapNetLibOpenWithOptions (sysLibTrapCustom + 13)

Definition at line 42 of file NetMasterLibTraps.h.

#define netMasterLibTrapOverrideErrorGetAndClear (sysLibTrapCustom + 17)

Definition at line 46 of file NetMasterLibTraps.h.

#define netMasterLibTrapOverrideMdmInitStrGetPtr (sysLibTrapCustom + 18)

Definition at line 47 of file NetMasterLibTraps.h.

#define netMasterLibTrapPhoneServiceClassesGet (sysLibTrapCustom + 8)

Definition at line 37 of file NetMasterLibTraps.h.

#define netMasterLibTrapPPPPayloadReport (sysLibTrapCustom + 30)

Definition at line 59 of file NetMasterLibTraps.h.

#define netMasterLibTrapSCContextAnchorTimeoutSet (sysLibTrapCustom + 29)

Definition at line 58 of file NetMasterLibTraps.h.

#define netMasterLibTrapSCNetAttach (sysLibTrapCustom + 1)

Definition at line 30 of file NetMasterLibTraps.h.

#define netMasterLibTrapSCNetDetach (sysLibTrapCustom + 21)

Definition at line 50 of file NetMasterLibTraps.h.

#define netMasterLibTrapSCSessionCountGet (sysLibTrapCustom + 23)

Definition at line 52 of file NetMasterLibTraps.h.

#define netMasterLibTrapSCSessionIDGetFromContext (sysLibTrapCustom + 22)

Definition at line 51 of file NetMasterLibTraps.h.

#define netMasterLibTrapSCSessionIsActive (sysLibTrapCustom + 26)

Definition at line 55 of file NetMasterLibTraps.h.

#define netMasterLibTrapSCSessionsEnumerate (sysLibTrapCustom + 24)

Definition at line 53 of file NetMasterLibTraps.h.

#define netMasterLibTrapSCSessionShutDown (sysLibTrapCustom + 27)

Definition at line 56 of file NetMasterLibTraps.h.

#define netMasterLibTrapSCSessionSvcRecIDGet (sysLibTrapCustom + 25)

Definition at line 54 of file NetMasterLibTraps.h.

#define netMasterLibTrapServiceSetUp (sysLibTrapCustom + 5)

Definition at line 34 of file NetMasterLibTraps.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:07:39 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » netmaster

NetMasterLibTypes.h File Reference

Detailed Description

This file contains public data types exported by the NetMaster Library.

Version:
1.0
Date:
01/31/2002
For usage model:
See also:
NetMasterLibrary.h

Definition in file NetMasterLibTypes.h.

Go to the source code of this file.

Data Structures

  • struct NetMasterClientEventVPNConnInstallType
    Data block for netMasterClientEventVPNConnInstall. More...
  • struct NetMasterClientEventInfoType
    This structure is passed as the 'detailsP' of the notification. More...

Defines

  • #define netMasterClientEventNotificationTypeID 'HnMe'
  • #define netMasterClientCurrentEventVersion 1
  • #define netMasterAnchorTimeoutDefault (-1)
NetMaster API Version Number
Current library API version number returned by NetMasterLibVersionGet()

  • #define netMasterLibVersionMajor 0
  • #define netMasterLibVersionMinor 4
  • #define netMasterLibVersionBugFix 0

Typedefs

  • typedef UInt32 NetMasterAutoLoginType
  • typedef UInt32 NetMasterNetIFShutDownOptionsType
  • typedef UInt16 NetMasterClientEventEnum
  • typedef UInt32 NetMasterNetLibOpenOptionsType
  • typedef UInt32 NetMasterLoginPriorityEnum
  • typedef UInt32 NetMasterDataContextIDType
  • typedef UInt32 NetMasterDataSessionIDType

Enumerations

  • enum {
    netMasterAutoLoginWhenWirelessOn = 0x00000001UL,
    netMasterLoginNetGuardEnabled = 0x00000002UL,
    netMasterAutoLoginClearAll = 0xFFFFFFFFUL
    }
  • enum {
    netMasterNetIFShutDownOptDismissPrgDialog = 0x00000001UL,
    netMasterNetIFShutDownOptCurrentOnly = 0x00000002UL,
    netMasterNetIFShutDownOptResetNetGuard = 0x00000004UL
    }
  • enum {
    netMasterClientEventUnknown = 0,
    netMasterClientEventVPNConnInstall,
    netMasterClientEventLAST
    }
  • enum {
    netMasterNetLibOpenOptAutoDismiss = 0x00000001UL,
    netMasterNetLibOpenOptBypassNetGuard = 0x00000002UL,
    netMasterNetLibOpenOptPrimaryProfileOnly = 0x00000004UL
    }
  • enum {
    netMasterLoginPriorityDefault = 0,
    netMasterLoginPriorityLow = 1,
    netMasterLoginPriorityHigh = 2
    }

Define Documentation

#define netMasterAnchorTimeoutDefault (-1)

Default value to pass as the anchorTimeoutSec parameter to NetMasterSCNetAttach

Definition at line 309 of file NetMasterLibTypes.h.

#define netMasterClientCurrentEventVersion 1

Increment this version # when adding fields to NetMasterClientEventInfoType, except when just adding a new event data pointer to eventData

Definition at line 193 of file NetMasterLibTypes.h.

#define netMasterClientEventNotificationTypeID 'HnMe'

The application that wishes to receive these notifications registers via Palm OS Notification Manager's SysNotifyRegister() for the event type netMasterClientEventNotificationTypeID to receive the events listed in NetMasterClientEventEnum. See Palm OS Notification Manager documentation for registration and notification handling details.

Definition at line 120 of file NetMasterLibTypes.h.

#define netMasterLibVersionBugFix 0

Definition at line 36 of file NetMasterLibTypes.h.

#define netMasterLibVersionMajor 0

Definition at line 34 of file NetMasterLibTypes.h.

#define netMasterLibVersionMinor 4

Definition at line 35 of file NetMasterLibTypes.h.

Typedef Documentation

typedef UInt32 NetMasterAutoLoginType

TCP/IP Network Auto-login definitions used by NetMasterAutoLoginSettingGet() and NetMasterAutoLoginSettingSet()

Definition at line 50 of file NetMasterLibTypes.h.

typedef UInt16 NetMasterClientEventEnum

NetMaster library client event selector

Definition at line 124 of file NetMasterLibTypes.h.

typedef UInt32 NetMasterDataContextIDType

Data Context type used by NetMasterSCNetAttach, NetMasterSCNetDetach and friends.

Definition at line 317 of file NetMasterLibTypes.h.

typedef UInt32 NetMasterDataSessionIDType

Data Session type used by NetMasterSCSessionIDGetFromContext and friends.

Definition at line 324 of file NetMasterLibTypes.h.

typedef UInt32 NetMasterLoginPriorityEnum

Login priority values that may be passed to NetMasterSCNetAttach

Definition at line 276 of file NetMasterLibTypes.h.

typedef UInt32 NetMasterNetIFShutDownOptionsType

NetLib interface shutdown options for NetMasterNetInterfacesShutDown

Definition at line 74 of file NetMasterLibTypes.h.

typedef UInt32 NetMasterNetLibOpenOptionsType

Special NetLibOpenConfig options passed to NetMasterNetLibOpenWithOptions()

Definition at line 243 of file NetMasterLibTypes.h.

Enumeration Type Documentation

anonymous enum

Enumerator:
netMasterAutoLoginWhenWirelessOn | For CDMA 1xRTT: Automatically log in to the TCP/IP network when the wireless mode is turned on and network is acquired; For GSM GPRS: Attempt to attach when the radio is powered on (ideally a combined attach)
netMasterLoginNetGuardEnabled | Prompt the user before connecting to the Internet; Also known as the "NetGuard" feature.
netMasterAutoLoginClearAll

Definition at line 51 of file NetMasterLibTypes.h.

00052   {
00053     /**
00054      *  For CDMA 1xRTT: Automatically log in to the TCP/IP network when the
00055      *  wireless mode is turned on and network is acquired;
00056      *  For GSM GPRS: Attempt to attach when the radio is powered on (ideally
00057      *  a combined attach)
00058      */
00059     // NOTE: Used by Handspring's Network Panel
00060     netMasterAutoLoginWhenWirelessOn    = 0x00000001UL,
00061
00062     /**
00063      * Prompt the user before connecting to the Internet;
00064      * Also known as the "NetGuard" feature.
00065      */
00066     // NOTE: Used by Handspring's Network Panel
00067     netMasterLoginNetGuardEnabled       = 0x00000002UL,
00068
00069     netMasterAutoLoginClearAll          = 0xFFFFFFFFUL
00070   };

anonymous enum

Enumerator:
netMasterNetIFShutDownOptDismissPrgDialog | If the Progress dialog is up, dismiss it even if it is in the error display state
netMasterNetIFShutDownOptCurrentOnly | If set, and the session being connected at the moment has a fallback, this will allow the fallback to be processed (for example, when aborting GPRS logon, but allowing the fallback, if any, to take place)
netMasterNetIFShutDownOptResetNetGuard If set, will cause the cached NetGuard setting to be cleared: apps that Disconnect the network connection as the result of user request (such as Disconnect button or menu item), MUST set this flag -- this causes the system to put up the NetGuard prompt during a subsequent data network login, if dictated by the netMasterLoginNetGuardEnabled setting.

If *not* set, will cause the cached NetGuard setting to be preserved.

Definition at line 75 of file NetMasterLibTypes.h.

00076   {
00077     /** If the Progress dialog is up, dismiss it even if it is
00078      *  in the error display state
00079      */
00080     netMasterNetIFShutDownOptDismissPrgDialog   = 0x00000001UL,
00081
00082     /** If set, and the session being connected at the moment has
00083      *  a fallback, this will allow the fallback to be processed (for example,
00084      *  when aborting GPRS logon, but allowing the fallback, if any, to
00085      *  take place)
00086      */
00087     netMasterNetIFShutDownOptCurrentOnly        = 0x00000002UL,
00088
00089
00090     /** If set, will cause the cached NetGuard setting to be
00091      *  cleared: apps that Disconnect the network connection as the
00092      *  result of user request (such as Disconnect button or menu item),
00093      *  MUST set this flag -- this causes the system to put up the
00094      *  NetGuard prompt during a subsequent data network login,
00095      *  if dictated by the netMasterLoginNetGuardEnabled setting.
00096      *
00097      *  If *not* set, will cause the cached NetGuard setting to
00098      *  be preserved.
00099      */
00100     netMasterNetIFShutDownOptResetNetGuard      = 0x00000004UL
00101
00102
00103   };

anonymous enum

Enumerator:
netMasterClientEventUnknown
netMasterClientEventVPNConnInstall Queries the VPN vendor to install its own connection profile name, if any; NetMaster library broadcasts this event to all registered clients from the context of the UI task when a client application calls NetLibOpen() or NetLibOpenConfig(). Parameter block: NetMasterClientEventInfoType:NetMasterClientEventVPNConnInstallType
netMasterClientEventLAST

Definition at line 125 of file NetMasterLibTypes.h.

00126   {
00127     netMasterClientEventUnknown     = 0,    // reserve 0
00128
00129     /** Queries the VPN vendor to install its own connection profile name,
00130      *  if any; NetMaster library broadcasts this event to all registered
00131      *  clients from the context of the UI task when a client application
00132      *  calls NetLibOpen() or NetLibOpenConfig().
00133      *  Parameter block:
00134      *  NetMasterClientEventInfoType:NetMasterClientEventVPNConnInstallType
00135      */
00136     netMasterClientEventVPNConnInstall,
00137
00138
00139
00140
00141     netMasterClientEventLAST
00142   };

anonymous enum

Enumerator:
netMasterNetLibOpenOptAutoDismiss netMasterNetLibOpenOptAutoDismiss:

If set, auto-dismiss the progress dialog if error occurs

netMasterNetLibOpenOptBypassNetGuard netMasterNetLibOpenOptBypassNetGuard:

If set, bypass the NetGuard feature -- for use by IOTA service only!!!

IMPORTANT: *not* available on systems before Palm OS 5.0

netMasterNetLibOpenOptPrimaryProfileOnly If this flag is set by the client, then the connection will be attempted only with the requested NetPref record, and the fallback network profile, if any, will be ignored.

IMPORTANT: *not* available on systems before Palm OS 5.0

Definition at line 244 of file NetMasterLibTypes.h.

00245   {
00246     /** netMasterNetLibOpenOptAutoDismiss:
00247      *
00248      *  If set, auto-dismiss the progress dialog if error occurs
00249      */
00250     netMasterNetLibOpenOptAutoDismiss           = 0x00000001UL,
00251
00252
00253     /** netMasterNetLibOpenOptBypassNetGuard:
00254      *
00255      *  If set, bypass the NetGuard feature -- for use by IOTA
00256      *  service only!!!
00257      *
00258      *  IMPORTANT: *not* available on systems before Palm OS 5.0
00259      */
00260     //
00261     // DOLATER \todo -- should this be in "protected" incs?
00262     netMasterNetLibOpenOptBypassNetGuard        = 0x00000002UL,
00263
00264     /** If this flag is set by the client, then the connection will
00265      *  be attempted only with the requested NetPref record, and the
00266      *  fallback network profile, if any, will be ignored.
00267      *
00268      *  IMPORTANT: *not* available on systems before Palm OS 5.0
00269      */
00270     netMasterNetLibOpenOptPrimaryProfileOnly    = 0x00000004UL
00271
00272   };

anonymous enum

Enumerator:
netMasterLoginPriorityDefault | The vast majority of background and foreground applications SHOULD ALWAYS use the Default login priority. This allows Data Session Control system software to optimize end-user experience on the device by following specific data session management rules requested by network operators.
netMasterLoginPriorityLow | The Low login priority is the *least* disruptive to existing data sessions that were established with a different network service profile than the one that you're requesting.
netMasterLoginPriorityHigh | The High login priority is the *most* disruptive to existing data sessions that were established with a different network service profile than the one that you're requesting. This will typically cause even active foreground data sessions to be torn down. This priority is reserved for *internal use only*, and should be avoided by other developers as its usage will typically break the data session management model of the device, resulting in poor end-user experience.

Definition at line 277 of file NetMasterLibTypes.h.

00278   {
00279     /** The vast majority of background and foreground applications SHOULD
00280      *  ALWAYS use the Default login priority.  This allows Data Session
00281      *  Control system software to optimize end-user experience
00282      *  on the device by following specific data session
00283      *  management rules requested by network operators.
00284      */
00285     netMasterLoginPriorityDefault           = 0,
00286
00287     /** The Low login priority is the *least* disruptive to existing data
00288      *  sessions that were established with a different network service
00289      *  profile than the one that you're requesting.
00290      */
00291     netMasterLoginPriorityLow               = 1,
00292
00293     /** The High login priority is the *most* disruptive to existing data
00294      *  sessions that were established with a different network service
00295      *  profile than the one that you're requesting.  This will typically
00296      *  cause even active foreground data sessions to be torn down. This
00297      *  priority is reserved for *internal use only*, and should be avoided
00298      *  by other developers as its usage will typically break the data
00299      *  session management model of the device, resulting in poor end-user
00300      *  experience.
00301      */
00302     netMasterLoginPriorityHigh              = 2
00303
00304   };

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:07:39 2008 for Palm API Guide


Header Files » Incs » common » libraries » netpref

NetPrefLibErrors.h File Reference

Detailed Description

This is the error declarations file for the NetPref Library.

Version:
1.0
Date:
12/12/2001

Definition in file NetPrefLibErrors.h.

Include dependency graph for NetPrefLibErrors.h:

Go to the source code of this file.

Defines

  • #define netPrefErrClass (hsNetPrefLibErrorClass)
  • #define netPrefErrMemory (netPrefErrClass + 0x01)
  • #define netPrefErrStorage (netPrefErrClass + 0x02)
  • #define netPrefErrBadArg (netPrefErrClass + 0x03)
  • #define netPrefErrRecNotSaved (netPrefErrClass + 0x04)
  • #define netPrefErrRecGone (netPrefErrClass + 0x05)
  • #define netPrefErrCCSMIncomplete (netPrefErrClass + 0x06)
  • #define netPrefErrCSDNotAllowed (netPrefErrClass + 0x07)
  • #define netPrefErrNoCCSMSettings (netPrefErrClass + 0x08)
  • #define netPrefErrNVSync (netPrefErrClass + 0x09)
  • #define netPrefErrNVRead (netPrefErrClass + 0x0A)
  • #define netPrefErrCCSMNoCarrierMatch (netPrefErrClass + 0x0B)
  • #define netPrefErrRadioIsOff (netPrefErrClass + 0x0C)
  • #define netPrefErrPhoneLibOpenFailed (netPrefErrClass + 0x0D)
  • #define netPrefErrNVWrite (netPrefErrClass + 0x0E)
  • #define netPrefErrReadOnlyField (netPrefErrClass + 0x0F)
  • #define netPrefErrFieldNotInSet (netPrefErrClass + 0x10)
  • #define netPrefErrNVWritePDPInUse (netPrefErrClass + 0x11)

Define Documentation

#define netPrefErrBadArg (netPrefErrClass + 0x03)

invalid argument, unknown ID

Definition at line 39 of file NetPrefLibErrors.h.

#define netPrefErrCCSMIncomplete (netPrefErrClass + 0x06)

missing or incomplete CCSM table

Definition at line 45 of file NetPrefLibErrors.h.

#define netPrefErrCCSMNoCarrierMatch (netPrefErrClass + 0x0B)

No matching entry in the CCSM Carrier List DB

Definition at line 54 of file NetPrefLibErrors.h.

#define netPrefErrClass (hsNetPrefLibErrorClass)

hsNetMasterErrorClass is defined in HsErrorClasses.h

Definition at line 34 of file NetPrefLibErrors.h.

#define netPrefErrCSDNotAllowed (netPrefErrClass + 0x07)

CSD is not allowed

Definition at line 46 of file NetPrefLibErrors.h.

#define netPrefErrFieldNotInSet (netPrefErrClass + 0x10)

Attempting to modify a field that is not in the record's set.

Definition at line 66 of file NetPrefLibErrors.h.

#define netPrefErrMemory (netPrefErrClass + 0x01)

runtime memory error

Definition at line 37 of file NetPrefLibErrors.h.

#define netPrefErrNoCCSMSettings (netPrefErrClass + 0x08)

settings were not found in the CCSM Carrier Settings DB

Definition at line 47 of file NetPrefLibErrors.h.

#define netPrefErrNVRead (netPrefErrClass + 0x0A)

Error reading setting from the radio's NV storage

Definition at line 51 of file NetPrefLibErrors.h.

#define netPrefErrNVSync (netPrefErrClass + 0x09)

Error synchronizing settings with the radio's NV storage

Definition at line 48 of file NetPrefLibErrors.h.

#define netPrefErrNVWrite (netPrefErrClass + 0x0E)

Error writing setting to the radio's NV storage

Definition at line 60 of file NetPrefLibErrors.h.

#define netPrefErrNVWritePDPInUse (netPrefErrClass + 0x11)

Couldn't save data to PDP in radio's NV because the PDP is in use (logged in most likely).

Definition at line 69 of file NetPrefLibErrors.h.

#define netPrefErrPhoneLibOpenFailed (netPrefErrClass + 0x0D)

Error while opening PhoneLib

Definition at line 58 of file NetPrefLibErrors.h.

#define netPrefErrRadioIsOff (netPrefErrClass + 0x0C)

Operation failed because the radio (wireless mode) is off.

Definition at line 55 of file NetPrefLibErrors.h.

#define netPrefErrReadOnlyField (netPrefErrClass + 0x0F)

Attempting to modify the data of a read-only field.

Definition at line 63 of file NetPrefLibErrors.h.

#define netPrefErrRecGone (netPrefErrClass + 0x05)

record could not be found

Definition at line 44 of file NetPrefLibErrors.h.

#define netPrefErrRecNotSaved (netPrefErrClass + 0x04)

cannot perform the requested operation on the new record until it is saved.

Definition at line 40 of file NetPrefLibErrors.h.

#define netPrefErrStorage (netPrefErrClass + 0x02)

storage memory error

Definition at line 38 of file NetPrefLibErrors.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:07:39 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » netpref

NetPrefLibFieldInfoTable.h File Reference

Detailed Description

This header file contains record field information for NetPref settings.

Version:
1.0
Date:
01/11/2002

Definition in file NetPrefLibFieldInfoTable.h.

Go to the source code of this file.

Functions

  • NetPrefRecFieldInfoPreamble () NetPrefRecFieldInfoFIRST(netPrefRecFieldUnknown
  • NetPrefRecFieldInfoGrpStart (netPrefRecFieldExtendedSTART, 1) NetPrefRecFieldInfoExtended(netPrefRecFieldUInt32Reserved1
  • NetPrefRecFieldInfoExtended (netPrefRecFieldSvcMediumAlias, 3, netPrefFieldTypeUInt16, 0, 0,< 3:medium >, 10) NetPrefRecFieldInfoExtended(netPrefRecFieldBinding
  • < 4:bind > NetPrefRecFieldInfoExtended (netPrefRecFieldBindingIndex, 5, netPrefFieldTypeUInt16, 0, 0,< 5:bindidx >, 11) NetPrefRecFieldInfoExtended(netPrefRecFieldSvcGatewayType
  • < 4:bind >< 6:gtwytyp > NetPrefRecFieldInfoExtended (netPrefRecFieldFallbackID, 7, netPrefFieldTypeUInt32, 0, 0,< 7:fback >, 9) NetPrefRecFieldInfoExtended(netPrefRecFieldAPN
  • < 4:bind >< 6:gtwytyp ><
    8:apn > NetPrefRecFieldInfoExtended (netPrefRecFieldMdmInitStr, 9, netPrefFieldTypeStr, 0, 0,< 9:mdmins >, 10) NetPrefRecFieldInfoExtended(netPrefRecFieldIsMobileIP
  • < 4:bind >< 6:gtwytyp ><
    8:apn >< 10:mip > NetPrefRecFieldInfoExtended (netPrefRecFieldHAAddrPrimary, 11, netPrefFieldTypeUInt32, 0, 0,< 11:ha1 >, 8) NetPrefRecFieldInfoExtended(netPrefRecFieldHAAddrSecondary
  • < 4:bind >< 6:gtwytyp ><
    8:apn >< 10:mip >< 12:ha2 > NetPrefRecFieldInfoExtended (netPrefRecFieldMnHaSS, 13, netPrefFieldTypeBin, 0, 0,< 13:hapsw >, 10) NetPrefRecFieldInfoExtended(netPrefRecField1xRTTTunneling
  • < 4:bind >< 6:gtwytyp ><
    8:apn >< 10:mip >< 12:ha2 >< 14:1xtnl > NetPrefRecFieldInfoExtended (netPrefRecFieldMnHaSpi, 15, netPrefFieldTypeUInt32, 0, 0,< 15:haspi >, 10) NetPrefRecFieldInfoExtended(netPrefRecFieldMnAaaSpi
  • < 4:bind >< 6:gtwytyp ><
    8:apn >< 10:mip >< 12:ha2 >< 14:1xtnl >< 16:aaasp > NetPrefRecFieldInfoExtended (netPrefRecFieldDialStr, 17, netPrefFieldTypeStr, 0, 0,< 17:dials >, 10) NetPrefRecFieldInfoExtended(netPrefRecFieldRecProtection
  • < 4:bind >< 6:gtwytyp ><
    8:apn >< 10:mip >< 12:ha2 >< 14:1xtnl >< 16:aaasp >< 18:protect > NetPrefRecFieldInfoExtended (netPrefRecFieldPDPIndex, 19, netPrefFieldTypeUInt32, 0, 0,< 19:pdpidx >, 11) NetPrefRecFieldInfoExtended(netPrefRecFieldPDPChangeID
  • < 4:bind >< 6:gtwytyp ><
    8:apn >< 10:mip >< 12:ha2 >< 14:1xtnl >< 16:aaasp >< 18:protect >< 20:pdpchg > NetPrefRecFieldInfoExtended (netPrefRecFieldCreatorID, 21, netPrefFieldTypeUInt32, 0, 0,< 21:crid >, 9) NetPrefRecFieldInfoExtended(netPrefRecFieldCreatorData
  • < 4:bind >< 6:gtwytyp ><
    8:apn >< 10:mip >< 12:ha2 >< 14:1xtnl >< 16:aaasp >< 18:protect >< 20:pdpchg >< 22:crdata > NetPrefRecFieldInfoExtended (netPrefRecFieldGPRSQOS, 23, netPrefFieldTypeBin, 0, 0,< 23:gprsqos >, 12) NetPrefRecFieldInfoExtended(netPrefRecField1xRTTQOS
  • < 4:bind >< 6:gtwytyp ><
    8:apn >< 10:mip >< 12:ha2 >< 14:1xtnl >< 16:aaasp >< 18:protect >< 20:pdpchg >< 22:crdata >< 24:1xrttqos > NetPrefRecFieldInfoExtended (netPrefRecFieldBinReserved1, 25, netPrefFieldTypeBin, 0, 0,< 25:binrsvd1 >, 13) NetPrefRecFieldInfoExtended(netPrefRecFieldNaiStr
  • < 4:bind >< 6:gtwytyp ><
    8:apn >< 10:mip >< 12:ha2 >< 14:1xtnl >< 16:aaasp >< 18:protect >< 20:pdpchg >< 22:crdata >< 24:1xrttqos >< 26:nai > NetPrefRecFieldInfoExtended (netPrefRecFieldMnAaaSs, 27, netPrefFieldTypeBin, 0, 0,< 27:mnaaass >, 12) NetPrefRecFieldInfoExtended(netPrefRecFieldVJCompSlots
  • < 4:bind >< 6:gtwytyp ><
    8:apn >< 10:mip >< 12:ha2 >< 14:1xtnl >< 16:aaasp >< 18:protect >< 20:pdpchg >< 22:crdata >< 24:1xrttqos >< 26:nai >< 28:vjslots > NetPrefRecFieldInfoExtended (netPrefRecFieldFallbackInfo, 29, netPrefFieldTypeBin, 0, 0,< 29:fbkinfo >, 12) NetPrefRecFieldInfoExtended(netPrefRecFieldProxyPrimaryHttpServer
  • < 4:bind >< 6:gtwytyp ><
    8:apn >< 10:mip >< 12:ha2 >< 14:1xtnl >< 16:aaasp >< 18:protect >< 20:pdpchg >< 22:crdata >< 24:1xrttqos >< 26:nai >< 28:vjslots >< 30:HttpSv > NetPrefRecFieldInfoExtended (netPrefRecFieldProxyPrimaryHttpPort, 31, netPrefFieldTypeUInt32, 0, 0,< 31:HttpPt >, 11) NetPrefRecFieldInfoExtended(netPrefRecFieldProxyPrimaryHttpsServer
  • < 4:bind >< 6:gtwytyp ><
    8:apn >< 10:mip >< 12:ha2 >< 14:1xtnl >< 16:aaasp >< 18:protect >< 20:pdpchg >< 22:crdata >< 24:1xrttqos >< 26:nai >< 28:vjslots >< 30:HttpSv >< 32:HttpsSv > NetPrefRecFieldInfoExtended (netPrefRecFieldProxyPrimaryHttpsPort, 33, netPrefFieldTypeUInt32, 0, 0,< 33:HttpsPt >, 12) NetPrefRecFieldInfoExtended(netPrefRecFieldProxySecondaryHttpServer
  • < 4:bind >< 6:gtwytyp ><
    8:apn >< 10:mip >< 12:ha2 >< 14:1xtnl >< 16:aaasp >< 18:protect >< 20:pdpchg >< 22:crdata >< 24:1xrttqos >< 26:nai >< 28:vjslots >< 30:HttpSv >< 32:HttpsSv >< 34:HttpS2 > NetPrefRecFieldInfoExtended (netPrefRecFieldProxySecondaryHttpPort, 35, netPrefFieldTypeUInt32, 0, 0,< 35:HttpP2 >, 11) NetPrefRecFieldInfoExtended(netPrefRecFieldProxySecondaryHttpsServer
  • < 4:bind >< 6:gtwytyp ><
    8:apn >< 10:mip >< 12:ha2 >< 14:1xtnl >< 16:aaasp >< 18:protect >< 20:pdpchg >< 22:crdata >< 24:1xrttqos >< 26:nai >< 28:vjslots >< 30:HttpSv >< 32:HttpsSv >< 34:HttpS2 >< 36:HttpsS2 > NetPrefRecFieldInfoExtended (netPrefRecFieldProxySecondaryHttpsPort, 37, netPrefFieldTypeUInt32, 0, 0,< 37:HttpsP2 >, 12) NetPrefRecFieldInfoExtended(netPrefRecFieldProxyExcludedHostsString
  • < 4:bind >< 6:gtwytyp ><
    8:apn >< 10:mip >< 12:ha2 >< 14:1xtnl >< 16:aaasp >< 18:protect >< 20:pdpchg >< 22:crdata >< 24:1xrttqos >< 26:nai >< 28:vjslots >< 30:HttpSv >< 32:HttpsSv >< 34:HttpS2 >< 36:HttpsS2 >< 38:ExclHst > NetPrefRecFieldInfoExtended (netPrefRecFieldProxyUsernameNew, 39, netPrefFieldTypeStr, 0, 0,< 39:User2 >, 10) NetPrefRecFieldInfoExtended(netPrefRecFieldProxyPasswordNew
  • < 4:bind >< 6:gtwytyp ><
    8:apn >< 10:mip >< 12:ha2 >< 14:1xtnl >< 16:aaasp >< 18:protect >< 20:pdpchg >< 22:crdata >< 24:1xrttqos >< 26:nai >< 28:vjslots >< 30:HttpSv >< 32:HttpsSv >< 34:HttpS2 >< 36:HttpsS2 >< 38:ExclHst >< 40:Pass2 > NetPrefRecFieldInfoExtended (netPrefRecFieldProxyReqCustomUaProf, 41, netPrefFieldTypeUInt8, 0, 0,< 41:CustUa >, 11) NetPrefRecFieldInfoExtended(netPrefRecFieldProxyDefaultHomePage
  • < 4:bind >< 6:gtwytyp ><
    8:apn >< 10:mip >< 12:ha2 >< 14:1xtnl >< 16:aaasp >< 18:protect >< 20:pdpchg >< 22:crdata >< 24:1xrttqos >< 26:nai >< 28:vjslots >< 30:HttpSv >< 32:HttpsSv >< 34:HttpS2 >< 36:HttpsS2 >< 38:ExclHst >< 40:Pass2 >< 42:HomePg > NetPrefRecFieldInfoExtended (netPrefRecFieldProxyUaProfHostedOnOwnServers, 43, netPrefFieldTypeUInt8, 0, 0,< 43:UaOwnSv >, 12) NetPrefRecFieldInfoExtended(netPrefRecFieldProxyUrlOfUaProfFile
  • < 4:bind >< 6:gtwytyp ><
    8:apn >< 10:mip >< 12:ha2 >< 14:1xtnl >< 16:aaasp >< 18:protect >< 20:pdpchg >< 22:crdata >< 24:1xrttqos >< 26:nai >< 28:vjslots >< 30:HttpSv >< 32:HttpsSv >< 34:HttpS2 >< 36:HttpsS2 >< 38:ExclHst >< 40:Pass2 >< 42:HomePg >< 44:UrlUa > NetPrefRecFieldInfoExtended (netPrefRecFieldProxyEncryptedMsisdn, 45, netPrefFieldTypeUInt8, 0, 0,< 45:EncrMSI >, 12) NetPrefRecFieldInfoExtended(netPrefRecFieldProxyMsisdnFormat
  • < 4:bind >< 6:gtwytyp ><
    8:apn >< 10:mip >< 12:ha2 >< 14:1xtnl >< 16:aaasp >< 18:protect >< 20:pdpchg >< 22:crdata >< 24:1xrttqos >< 26:nai >< 28:vjslots >< 30:HttpSv >< 32:HttpsSv >< 34:HttpS2 >< 36:HttpsS2 >< 38:ExclHst >< 40:Pass2 >< 42:HomePg >< 44:UrlUa >< 46:MSIfmt > NetPrefRecFieldInfoExtended (netPrefRecFieldProxyMsisdnStaticString, 47, netPrefFieldTypeStr, 0, 0,< 47:MSIStr >, 11) NetPrefRecFieldInfoExtended(netPrefRecFieldProxyReqStaticHeaderString
  • < 4:bind >< 6:gtwytyp ><
    8:apn >< 10:mip >< 12:ha2 >< 14:1xtnl >< 16:aaasp >< 18:protect >< 20:pdpchg >< 22:crdata >< 24:1xrttqos >< 26:nai >< 28:vjslots >< 30:HttpSv >< 32:HttpsSv >< 34:HttpS2 >< 36:HttpsS2 >< 38:ExclHst >< 40:Pass2 >< 42:HomePg >< 44:UrlUa >< 46:MSIfmt >< 48:ReqStat > NetPrefRecFieldInfoExtended (netPrefRecFieldProxyStaticHeaderString, 49, netPrefFieldTypeStr, 0, 0,< 49:StatHStr >, 13) NetPrefRecFieldInfoExtended(netPrefRecFieldDomain01
  • < 4:bind >< 6:gtwytyp ><
    8:apn >< 10:mip >< 12:ha2 >< 14:1xtnl >< 16:aaasp >< 18:protect >< 20:pdpchg >< 22:crdata >< 24:1xrttqos >< 26:nai >< 28:vjslots >< 30:HttpSv >< 32:HttpsSv >< 34:HttpS2 >< 36:HttpsS2 >< 38:ExclHst >< 40:Pass2 >< 42:HomePg >< 44:UrlUa >< 46:MSIfmt >< 48:ReqStat >< 50:domain01 > NetPrefRecFieldInfoExtended (netPrefRecFieldDomain02, 51, netPrefFieldTypeStr, 0, 0,< 51:domain02 >, 13) NetPrefRecFieldInfoExtended(netPrefRecFieldDomain03
  • < 4:bind >< 6:gtwytyp ><
    8:apn >< 10:mip >< 12:ha2 >< 14:1xtnl >< 16:aaasp >< 18:protect >< 20:pdpchg >< 22:crdata >< 24:1xrttqos >< 26:nai >< 28:vjslots >< 30:HttpSv >< 32:HttpsSv >< 34:HttpS2 >< 36:HttpsS2 >< 38:ExclHst >< 40:Pass2 >< 42:HomePg >< 44:UrlUa >< 46:MSIfmt >< 48:ReqStat >< 50:domain01 >< 52:domain03 > NetPrefRecFieldInfoExtended (netPrefRecFieldDomain04, 53, netPrefFieldTypeStr, 0, 0,< 53:domain04 >, 13) NetPrefRecFieldInfoExtended(netPrefRecFieldDomain05
  • < 4:bind >< 6:gtwytyp ><
    8:apn >< 10:mip >< 12:ha2 >< 14:1xtnl >< 16:aaasp >< 18:protect >< 20:pdpchg >< 22:crdata >< 24:1xrttqos >< 26:nai >< 28:vjslots >< 30:HttpSv >< 32:HttpsSv >< 34:HttpS2 >< 36:HttpsS2 >< 38:ExclHst >< 40:Pass2 >< 42:HomePg >< 44:UrlUa >< 46:MSIfmt >< 48:ReqStat >< 50:domain01 >< 52:domain03 >< 54:domain05 > NetPrefRecFieldInfoExtended (netPrefRecFieldDomain06, 55, netPrefFieldTypeStr, 0, 0,< 55:domain06 >, 13) NetPrefRecFieldInfoExtended(netPrefRecFieldDomain07
  • < 4:bind >< 6:gtwytyp ><
    8:apn >< 10:mip >< 12:ha2 >< 14:1xtnl >< 16:aaasp >< 18:protect >< 20:pdpchg >< 22:crdata >< 24:1xrttqos >< 26:nai >< 28:vjslots >< 30:HttpSv >< 32:HttpsSv >< 34:HttpS2 >< 36:HttpsS2 >< 38:ExclHst >< 40:Pass2 >< 42:HomePg >< 44:UrlUa >< 46:MSIfmt >< 48:ReqStat >< 50:domain01 >< 52:domain03 >< 54:domain05 >< 56:domain07 > NetPrefRecFieldInfoExtended (netPrefRecFieldDomain08, 57, netPrefFieldTypeStr, 0, 0,< 57:domain08 >, 13) NetPrefRecFieldInfoExtended(netPrefRecFieldDomain09
  • < 4:bind >< 6:gtwytyp ><
    8:apn >< 10:mip >< 12:ha2 >< 14:1xtnl >< 16:aaasp >< 18:protect >< 20:pdpchg >< 22:crdata >< 24:1xrttqos >< 26:nai >< 28:vjslots >< 30:HttpSv >< 32:HttpsSv >< 34:HttpS2 >< 36:HttpsS2 >< 38:ExclHst >< 40:Pass2 >< 42:HomePg >< 44:UrlUa >< 46:MSIfmt >< 48:ReqStat >< 50:domain01 >< 52:domain03 >< 54:domain05 >< 56:domain07 >< 58:domain09 > NetPrefRecFieldInfoExtended (netPrefRecFieldDomain10, 59, netPrefFieldTypeStr, 0, 0,< 59:domain10 >, 13) NetPrefRecFieldInfoGrpEnd(netPrefRecFieldExtendedEND) NetPrefRecFieldInfoGrpStart(netPrefRecFieldLegacySTART
  • < 4:bind >< 6:gtwytyp ><
    8:apn >< 10:mip >< 12:ha2 >< 14:1xtnl >< 16:aaasp >< 18:protect >< 20:pdpchg >< 22:crdata >< 24:1xrttqos >< 26:nai >< 28:vjslots >< 30:HttpSv >< 32:HttpsSv >< 34:HttpS2 >< 36:HttpsS2 >< 38:ExclHst >< 40:Pass2 >< 42:HomePg >< 44:UrlUa >< 46:MSIfmt >< 48:ReqStat >< 50:domain01 >< 52:domain03 >< 54:domain05 >< 56:domain07 >< 58:domain09 > NetPrefRecFieldInfoLegacy (netPrefRecFieldInterfaceID, 1001, netPrefFieldTypeUInt32, 0, 0,< 1001:ifid >, 11) NetPrefRecFieldInfoLegacy(netPrefRecFieldIPAddrIsDynamic
  • < 4:bind >< 6:gtwytyp ><
    8:apn >< 10:mip >< 12:ha2 >< 14:1xtnl >< 16:aaasp >< 18:protect >< 20:pdpchg >< 22:crdata >< 24:1xrttqos >< 26:nai >< 28:vjslots >< 30:HttpSv >< 32:HttpsSv >< 34:HttpS2 >< 36:HttpsS2 >< 38:ExclHst >< 40:Pass2 >< 42:HomePg >< 44:UrlUa >< 46:MSIfmt >< 48:ReqStat >< 50:domain01 >< 52:domain03 >< 54:domain05 >< 56:domain07 >< 58:domain09 >< 1002:dynip > NetPrefRecFieldInfoLegacy (netPrefRecFieldIPAddr, 1003, netPrefFieldTypeUInt32, 0, 0,< 1003:ipaddr >, 13) NetPrefRecFieldInfoLegacy(netPrefRecFieldDNSAddrIsDynamic
  • < 4:bind >< 6:gtwytyp ><
    8:apn >< 10:mip >< 12:ha2 >< 14:1xtnl >< 16:aaasp >< 18:protect >< 20:pdpchg >< 22:crdata >< 24:1xrttqos >< 26:nai >< 28:vjslots >< 30:HttpSv >< 32:HttpsSv >< 34:HttpS2 >< 36:HttpsS2 >< 38:ExclHst >< 40:Pass2 >< 42:HomePg >< 44:UrlUa >< 46:MSIfmt >< 48:ReqStat >< 50:domain01 >< 52:domain03 >< 54:domain05 >< 56:domain07 >< 58:domain09 >< 1002:dynip >< 1004:dyndns > NetPrefRecFieldInfoLegacy (netPrefRecFieldDNSAddrPrimary, 1005, netPrefFieldTypeUInt32, 0, 0,< 1005:pridns >, 13) NetPrefRecFieldInfoLegacy(netPrefRecFieldDNSAddrSecondary
  • < 4:bind >< 6:gtwytyp ><
    8:apn >< 10:mip >< 12:ha2 >< 14:1xtnl >< 16:aaasp >< 18:protect >< 20:pdpchg >< 22:crdata >< 24:1xrttqos >< 26:nai >< 28:vjslots >< 30:HttpSv >< 32:HttpsSv >< 34:HttpS2 >< 36:HttpsS2 >< 38:ExclHst >< 40:Pass2 >< 42:HomePg >< 44:UrlUa >< 46:MSIfmt >< 48:ReqStat >< 50:domain01 >< 52:domain03 >< 54:domain05 >< 56:domain07 >< 58:domain09 >< 1002:dynip >< 1004:dyndns >< 1006:secdns > NetPrefRecFieldInfoLegacy (netPrefRecFieldCloseWaitTime, 1007, netPrefFieldTypeUInt32, 0, 0,< 1007:cwtm >, 11) NetPrefRecFieldInfoLegacy(netPrefRecFieldInactivityTimer
  • < 4:bind >< 6:gtwytyp ><
    8:apn >< 10:mip >< 12:ha2 >< 14:1xtnl >< 16:aaasp >< 18:protect >< 20:pdpchg >< 22:crdata >< 24:1xrttqos >< 26:nai >< 28:vjslots >< 30:HttpSv >< 32:HttpsSv >< 34:HttpS2 >< 36:HttpsS2 >< 38:ExclHst >< 40:Pass2 >< 42:HomePg >< 44:UrlUa >< 46:MSIfmt >< 48:ReqStat >< 50:domain01 >< 52:domain03 >< 54:domain05 >< 56:domain07 >< 58:domain09 >< 1002:dynip >< 1004:dyndns >< 1006:secdns >< 1008:inactm > NetPrefRecFieldInfoLegacy (netPrefRecFieldEstablishmentTimeout, 1009, netPrefFieldTypeUInt16, 0, 0,< 1009:estbtm >, 13) NetPrefRecFieldInfoLegacy(netPrefRecFieldVJCompEnable
  • < 4:bind >< 6:gtwytyp ><
    8:apn >< 10:mip >< 12:ha2 >< 14:1xtnl >< 16:aaasp >< 18:protect >< 20:pdpchg >< 22:crdata >< 24:1xrttqos >< 26:nai >< 28:vjslots >< 30:HttpSv >< 32:HttpsSv >< 34:HttpS2 >< 36:HttpsS2 >< 38:ExclHst >< 40:Pass2 >< 42:HomePg >< 44:UrlUa >< 46:MSIfmt >< 48:ReqStat >< 50:domain01 >< 52:domain03 >< 54:domain05 >< 56:domain07 >< 58:domain09 >< 1002:dynip >< 1004:dyndns >< 1006:secdns >< 1008:inactm >< 1010:vjcmpr > NetPrefRecFieldInfoLegacy (netPrefRecFieldUseModem, 1011, netPrefFieldTypeUInt8, 0, 0,< 1011:usemdm >, 13) NetPrefRecFieldInfoLegacy(netPrefRecFieldServiceName
  • < 4:bind >< 6:gtwytyp ><
    8:apn >< 10:mip >< 12:ha2 >< 14:1xtnl >< 16:aaasp >< 18:protect >< 20:pdpchg >< 22:crdata >< 24:1xrttqos >< 26:nai >< 28:vjslots >< 30:HttpSv >< 32:HttpsSv >< 34:HttpS2 >< 36:HttpsS2 >< 38:ExclHst >< 40:Pass2 >< 42:HomePg >< 44:UrlUa >< 46:MSIfmt >< 48:ReqStat >< 50:domain01 >< 52:domain03 >< 54:domain05 >< 56:domain07 >< 58:domain09 >< 1002:dynip >< 1004:dyndns >< 1006:secdns >< 1008:inactm >< 1010:vjcmpr >< 1012:svcnam > NetPrefRecFieldInfoLegacy (netPrefRecFieldUsername, 1013, netPrefFieldTypeStr, 0, 0,< 1013:usrnam >, 13) NetPrefRecFieldInfoLegacy(netPrefRecFieldPassword
  • < 4:bind >< 6:gtwytyp ><
    8:apn >< 10:mip >< 12:ha2 >< 14:1xtnl >< 16:aaasp >< 18:protect >< 20:pdpchg >< 22:crdata >< 24:1xrttqos >< 26:nai >< 28:vjslots >< 30:HttpSv >< 32:HttpsSv >< 34:HttpS2 >< 36:HttpsS2 >< 38:ExclHst >< 40:Pass2 >< 42:HomePg >< 44:UrlUa >< 46:MSIfmt >< 48:ReqStat >< 50:domain01 >< 52:domain03 >< 54:domain05 >< 56:domain07 >< 58:domain09 >< 1002:dynip >< 1004:dyndns >< 1006:secdns >< 1008:inactm >< 1010:vjcmpr >< 1012:svcnam >< 1014:usrpsw > NetPrefRecFieldInfoLegacy (netPrefRecFieldDomainName, 1015, netPrefFieldTypeStr, 0, 0,< 1015:domain >, 13) NetPrefRecFieldInfoLegacy(netPrefRecFieldHostTable
  • < 4:bind >< 6:gtwytyp ><
    8:apn >< 10:mip >< 12:ha2 >< 14:1xtnl >< 16:aaasp >< 18:protect >< 20:pdpchg >< 22:crdata >< 24:1xrttqos >< 26:nai >< 28:vjslots >< 30:HttpSv >< 32:HttpsSv >< 34:HttpS2 >< 36:HttpsS2 >< 38:ExclHst >< 40:Pass2 >< 42:HomePg >< 44:UrlUa >< 46:MSIfmt >< 48:ReqStat >< 50:domain01 >< 52:domain03 >< 54:domain05 >< 56:domain07 >< 58:domain09 >< 1002:dynip >< 1004:dyndns >< 1006:secdns >< 1008:inactm >< 1010:vjcmpr >< 1012:svcnam >< 1014:usrpsw >< 1016:hosttab > NetPrefRecFieldInfoLegacy (netPrefRecFieldSMTPHost, 1017, netPrefFieldTypeStr, 0, 0,< 1017:smtphst >, 14) NetPrefRecFieldInfoLegacy(netPrefRecFieldPOPHost
  • < 4:bind >< 6:gtwytyp ><
    8:apn >< 10:mip >< 12:ha2 >< 14:1xtnl >< 16:aaasp >< 18:protect >< 20:pdpchg >< 22:crdata >< 24:1xrttqos >< 26:nai >< 28:vjslots >< 30:HttpSv >< 32:HttpsSv >< 34:HttpS2 >< 36:HttpsS2 >< 38:ExclHst >< 40:Pass2 >< 42:HomePg >< 44:UrlUa >< 46:MSIfmt >< 48:ReqStat >< 50:domain01 >< 52:domain03 >< 54:domain05 >< 56:domain07 >< 58:domain09 >< 1002:dynip >< 1004:dyndns >< 1006:secdns >< 1008:inactm >< 1010:vjcmpr >< 1012:svcnam >< 1014:usrpsw >< 1016:hosttab >< 1018:pophst > NetPrefRecFieldInfoLegacy (netPrefRecFieldNewsServer, 1019, netPrefFieldTypeStr, 0, 0,< 1019:newssrv >, 14) NetPrefRecFieldInfoLegacy(netPrefRecFieldLoginScript
  • < 4:bind >< 6:gtwytyp ><
    8:apn >< 10:mip >< 12:ha2 >< 14:1xtnl >< 16:aaasp >< 18:protect >< 20:pdpchg >< 22:crdata >< 24:1xrttqos >< 26:nai >< 28:vjslots >< 30:HttpSv >< 32:HttpsSv >< 34:HttpS2 >< 36:HttpsS2 >< 38:ExclHst >< 40:Pass2 >< 42:HomePg >< 44:UrlUa >< 46:MSIfmt >< 48:ReqStat >< 50:domain01 >< 52:domain03 >< 54:domain05 >< 56:domain07 >< 58:domain09 >< 1002:dynip >< 1004:dyndns >< 1006:secdns >< 1008:inactm >< 1010:vjcmpr >< 1012:svcnam >< 1014:usrpsw >< 1016:hosttab >< 1018:pophst >< 1020:script > NetPrefRecFieldInfoLegacy (netPrefRecFieldConnection, 1021, netPrefFieldTypeStr, 0, 0,< 1021:connnam >, 14) NetPrefRecFieldInfoLegacy(netPrefRecFieldDialPrefixEnable
  • < 4:bind >< 6:gtwytyp ><
    8:apn >< 10:mip >< 12:ha2 >< 14:1xtnl >< 16:aaasp >< 18:protect >< 20:pdpchg >< 22:crdata >< 24:1xrttqos >< 26:nai >< 28:vjslots >< 30:HttpSv >< 32:HttpsSv >< 34:HttpS2 >< 36:HttpsS2 >< 38:ExclHst >< 40:Pass2 >< 42:HomePg >< 44:UrlUa >< 46:MSIfmt >< 48:ReqStat >< 50:domain01 >< 52:domain03 >< 54:domain05 >< 56:domain07 >< 58:domain09 >< 1002:dynip >< 1004:dyndns >< 1006:secdns >< 1008:inactm >< 1010:vjcmpr >< 1012:svcnam >< 1014:usrpsw >< 1016:hosttab >< 1018:pophst >< 1020:script >< 1022:enprefx > NetPrefRecFieldInfoLegacy (netPrefRecFieldCallWaitingEnable, 1023, netPrefFieldTypeUInt8, 0, 0,< 1023:encalwt >, 14) NetPrefRecFieldInfoLegacy(netPrefRecFieldCallingCardEnable
  • < 4:bind >< 6:gtwytyp ><
    8:apn >< 10:mip >< 12:ha2 >< 14:1xtnl >< 16:aaasp >< 18:protect >< 20:pdpchg >< 22:crdata >< 24:1xrttqos >< 26:nai >< 28:vjslots >< 30:HttpSv >< 32:HttpsSv >< 34:HttpS2 >< 36:HttpsS2 >< 38:ExclHst >< 40:Pass2 >< 42:HomePg >< 44:UrlUa >< 46:MSIfmt >< 48:ReqStat >< 50:domain01 >< 52:domain03 >< 54:domain05 >< 56:domain07 >< 58:domain09 >< 1002:dynip >< 1004:dyndns >< 1006:secdns >< 1008:inactm >< 1010:vjcmpr >< 1012:svcnam >< 1014:usrpsw >< 1016:hosttab >< 1018:pophst >< 1020:script >< 1022:enprefx >< 1024:encalcd > NetPrefRecFieldInfoLegacy (netPrefRecFieldPulseDialEnable, 1025, netPrefFieldTypeUInt8, 0, 0,< 1025:enpulse >, 14) NetPrefRecFieldInfoLegacy(netPrefRecFieldPhoneNumber
  • < 4:bind >< 6:gtwytyp ><
    8:apn >< 10:mip >< 12:ha2 >< 14:1xtnl >< 16:aaasp >< 18:protect >< 20:pdpchg >< 22:crdata >< 24:1xrttqos >< 26:nai >< 28:vjslots >< 30:HttpSv >< 32:HttpsSv >< 34:HttpS2 >< 36:HttpsS2 >< 38:ExclHst >< 40:Pass2 >< 42:HomePg >< 44:UrlUa >< 46:MSIfmt >< 48:ReqStat >< 50:domain01 >< 52:domain03 >< 54:domain05 >< 56:domain07 >< 58:domain09 >< 1002:dynip >< 1004:dyndns >< 1006:secdns >< 1008:inactm >< 1010:vjcmpr >< 1012:svcnam >< 1014:usrpsw >< 1016:hosttab >< 1018:pophst >< 1020:script >< 1022:enprefx >< 1024:encalcd >< 1026:phone > NetPrefRecFieldInfoLegacy (netPrefRecFieldDialPrefix, 1027, netPrefFieldTypeStr, 0, 0,< 1027:dlprefx >, 14) NetPrefRecFieldInfoLegacy(netPrefRecFieldCallWaitingString

Variables

  • netPrefFieldTypeUInt32
  • netPrefFieldTypeUInt16
  • < 4:bind > netPrefFieldTypeUInt32
  • < 4:bind >< 6:gtwytyp > netPrefFieldTypeStr
  • < 4:bind >< 6:gtwytyp ><
    8:apn > netPrefFieldTypeUInt8
  • < 4:bind >< 6:gtwytyp ><
    8:apn >< 10:mip > netPrefFieldTypeUInt32
  • < 4:bind >< 6:gtwytyp ><
    8:apn >< 10:mip >< 12:ha2 > netPrefFieldTypeUInt16
  • < 4:bind >< 6:gtwytyp ><
    8:apn >< 10:mip >< 12:ha2 >< 14:1xtnl > netPrefFieldTypeUInt32
  • < 4:bind >< 6:gtwytyp ><
    8:apn >< 10:mip >< 12:ha2 >< 14:1xtnl >< 16:aaasp > netPrefFieldTypeUInt32
  • < 4:bind >< 6:gtwytyp ><
    8:apn >< 10:mip >< 12:ha2 >< 14:1xtnl >< 16:aaasp >< 18:protect > netPrefFieldTypeBin
  • < 4:bind >< 6:gtwytyp ><
    8:apn >< 10:mip >< 12:ha2 >< 14:1xtnl >< 16:aaasp >< 18:protect >< 20:pdpchg > netPrefFieldTypeBin
  • < 4:bind >< 6:gtwytyp ><
    8:apn >< 10:mip >< 12:ha2 >< 14:1xtnl >< 16:aaasp >< 18:protect >< 20:pdpchg >< 22:crdata > netPrefFieldTypeBin
  • < 4:bind >< 6:gtwytyp ><
    8:apn >< 10:mip >< 12:ha2 >< 14:1xtnl >< 16:aaasp >< 18:protect >< 20:pdpchg >< 22:crdata >< 24:1xrttqos > netPrefFieldTypeStr
  • < 4:bind >< 6:gtwytyp ><
    8:apn >< 10:mip >< 12:ha2 >< 14:1xtnl >< 16:aaasp >< 18:protect >< 20:pdpchg >< 22:crdata >< 24:1xrttqos >< 26:nai > netPrefFieldTypeUInt8
  • < 4:bind >< 6:gtwytyp ><
    8:apn >< 10:mip >< 12:ha2 >< 14:1xtnl >< 16:aaasp >< 18:protect >< 20:pdpchg >< 22:crdata >< 24:1xrttqos >< 26:nai >< 28:vjslots > netPrefFieldTypeStr
  • < 4:bind >< 6:gtwytyp ><
    8:apn >< 10:mip >< 12:ha2 >< 14:1xtnl >< 16:aaasp >< 18:protect >< 20:pdpchg >< 22:crdata >< 24:1xrttqos >< 26:nai >< 28:vjslots >< 30:HttpSv > netPrefFieldTypeStr
  • < 4:bind >< 6:gtwytyp ><
    8:apn >< 10:mip >< 12:ha2 >< 14:1xtnl >< 16:aaasp >< 18:protect >< 20:pdpchg >< 22:crdata >< 24:1xrttqos >< 26:nai >< 28:vjslots >< 30:HttpSv >< 32:HttpsSv > netPrefFieldTypeStr
  • < 4:bind >< 6:gtwytyp ><
    8:apn >< 10:mip >< 12:ha2 >< 14:1xtnl >< 16:aaasp >< 18:protect >< 20:pdpchg >< 22:crdata >< 24:1xrttqos >< 26:nai >< 28:vjslots >< 30:HttpSv >< 32:HttpsSv >< 34:HttpS2 > netPrefFieldTypeStr
  • < 4:bind >< 6:gtwytyp ><
    8:apn >< 10:mip >< 12:ha2 >< 14:1xtnl >< 16:aaasp >< 18:protect >< 20:pdpchg >< 22:crdata >< 24:1xrttqos >< 26:nai >< 28:vjslots >< 30:HttpSv >< 32:HttpsSv >< 34:HttpS2 >< 36:HttpsS2 > netPrefFieldTypeStr
  • < 4:bind >< 6:gtwytyp ><
    8:apn >< 10:mip >< 12:ha2 >< 14:1xtnl >< 16:aaasp >< 18:protect >< 20:pdpchg >< 22:crdata >< 24:1xrttqos >< 26:nai >< 28:vjslots >< 30:HttpSv >< 32:HttpsSv >< 34:HttpS2 >< 36:HttpsS2 >< 38:ExclHst > netPrefFieldTypeStr
  • < 4:bind >< 6:gtwytyp ><
    8:apn >< 10:mip >< 12:ha2 >< 14:1xtnl >< 16:aaasp >< 18:protect >< 20:pdpchg >< 22:crdata >< 24:1xrttqos >< 26:nai >< 28:vjslots >< 30:HttpSv >< 32:HttpsSv >< 34:HttpS2 >< 36:HttpsS2 >< 38:ExclHst >< 40:Pass2 > netPrefFieldTypeStr
  • < 4:bind >< 6:gtwytyp ><
    8:apn >< 10:mip >< 12:ha2 >< 14:1xtnl >< 16:aaasp >< 18:protect >< 20:pdpchg >< 22:crdata >< 24:1xrttqos >< 26:nai >< 28:vjslots >< 30:HttpSv >< 32:HttpsSv >< 34:HttpS2 >< 36:HttpsS2 >< 38:ExclHst >< 40:Pass2 >< 42:HomePg > netPrefFieldTypeStr
  • < 4:bind >< 6:gtwytyp ><
    8:apn >< 10:mip >< 12:ha2 >< 14:1xtnl >< 16:aaasp >< 18:protect >< 20:pdpchg >< 22:crdata >< 24:1xrttqos >< 26:nai >< 28:vjslots >< 30:HttpSv >< 32:HttpsSv >< 34:HttpS2 >< 36:HttpsS2 >< 38:ExclHst >< 40:Pass2 >< 42:HomePg >< 44:UrlUa > netPrefFieldTypeStr
  • < 4:bind >< 6:gtwytyp ><
    8:apn >< 10:mip >< 12:ha2 >< 14:1xtnl >< 16:aaasp >< 18:protect >< 20:pdpchg >< 22:crdata >< 24:1xrttqos >< 26:nai >< 28:vjslots >< 30:HttpSv >< 32:HttpsSv >< 34:HttpS2 >< 36:HttpsS2 >< 38:ExclHst >< 40:Pass2 >< 42:HomePg >< 44:UrlUa >< 46:MSIfmt > netPrefFieldTypeUInt8
  • < 4:bind >< 6:gtwytyp ><
    8:apn >< 10:mip >< 12:ha2 >< 14:1xtnl >< 16:aaasp >< 18:protect >< 20:pdpchg >< 22:crdata >< 24:1xrttqos >< 26:nai >< 28:vjslots >< 30:HttpSv >< 32:HttpsSv >< 34:HttpS2 >< 36:HttpsS2 >< 38:ExclHst >< 40:Pass2 >< 42:HomePg >< 44:UrlUa >< 46:MSIfmt >< 48:ReqStat > netPrefFieldTypeStr
  • < 4:bind >< 6:gtwytyp ><
    8:apn >< 10:mip >< 12:ha2 >< 14:1xtnl >< 16:aaasp >< 18:protect >< 20:pdpchg >< 22:crdata >< 24:1xrttqos >< 26:nai >< 28:vjslots >< 30:HttpSv >< 32:HttpsSv >< 34:HttpS2 >< 36:HttpsS2 >< 38:ExclHst >< 40:Pass2 >< 42:HomePg >< 44:UrlUa >< 46:MSIfmt >< 48:ReqStat >< 50:domain01 > netPrefFieldTypeStr
  • < 4:bind >< 6:gtwytyp ><
    8:apn >< 10:mip >< 12:ha2 >< 14:1xtnl >< 16:aaasp >< 18:protect >< 20:pdpchg >< 22:crdata >< 24:1xrttqos >< 26:nai >< 28:vjslots >< 30:HttpSv >< 32:HttpsSv >< 34:HttpS2 >< 36:HttpsS2 >< 38:ExclHst >< 40:Pass2 >< 42:HomePg >< 44:UrlUa >< 46:MSIfmt >< 48:ReqStat >< 50:domain01 >< 52:domain03 > netPrefFieldTypeStr
  • < 4:bind >< 6:gtwytyp ><
    8:apn >< 10:mip >< 12:ha2 >< 14:1xtnl >< 16:aaasp >< 18:protect >< 20:pdpchg >< 22:crdata >< 24:1xrttqos >< 26:nai >< 28:vjslots >< 30:HttpSv >< 32:HttpsSv >< 34:HttpS2 >< 36:HttpsS2 >< 38:ExclHst >< 40:Pass2 >< 42:HomePg >< 44:UrlUa >< 46:MSIfmt >< 48:ReqStat >< 50:domain01 >< 52:domain03 >< 54:domain05 > netPrefFieldTypeStr
  • < 4:bind >< 6:gtwytyp ><
    8:apn >< 10:mip >< 12:ha2 >< 14:1xtnl >< 16:aaasp >< 18:protect >< 20:pdpchg >< 22:crdata >< 24:1xrttqos >< 26:nai >< 28:vjslots >< 30:HttpSv >< 32:HttpsSv >< 34:HttpS2 >< 36:HttpsS2 >< 38:ExclHst >< 40:Pass2 >< 42:HomePg >< 44:UrlUa >< 46:MSIfmt >< 48:ReqStat >< 50:domain01 >< 52:domain03 >< 54:domain05 >< 56:domain07 > netPrefFieldTypeStr
  • < 4:bind >< 6:gtwytyp ><
    8:apn >< 10:mip >< 12:ha2 >< 14:1xtnl >< 16:aaasp >< 18:protect >< 20:pdpchg >< 22:crdata >< 24:1xrttqos >< 26:nai >< 28:vjslots >< 30:HttpSv >< 32:HttpsSv >< 34:HttpS2 >< 36:HttpsS2 >< 38:ExclHst >< 40:Pass2 >< 42:HomePg >< 44:UrlUa >< 46:MSIfmt >< 48:ReqStat >< 50:domain01 >< 52:domain03 >< 54:domain05 >< 56:domain07 >< 58:domain09 > netPrefFieldTypeUInt8
  • < 4:bind >< 6:gtwytyp ><
    8:apn >< 10:mip >< 12:ha2 >< 14:1xtnl >< 16:aaasp >< 18:protect >< 20:pdpchg >< 22:crdata >< 24:1xrttqos >< 26:nai >< 28:vjslots >< 30:HttpSv >< 32:HttpsSv >< 34:HttpS2 >< 36:HttpsS2 >< 38:ExclHst >< 40:Pass2 >< 42:HomePg >< 44:UrlUa >< 46:MSIfmt >< 48:ReqStat >< 50:domain01 >< 52:domain03 >< 54:domain05 >< 56:domain07 >< 58:domain09 >< 1002:dynip > netPrefFieldTypeUInt8
  • < 4:bind >< 6:gtwytyp ><
    8:apn >< 10:mip >< 12:ha2 >< 14:1xtnl >< 16:aaasp >< 18:protect >< 20:pdpchg >< 22:crdata >< 24:1xrttqos >< 26:nai >< 28:vjslots >< 30:HttpSv >< 32:HttpsSv >< 34:HttpS2 >< 36:HttpsS2 >< 38:ExclHst >< 40:Pass2 >< 42:HomePg >< 44:UrlUa >< 46:MSIfmt >< 48:ReqStat >< 50:domain01 >< 52:domain03 >< 54:domain05 >< 56:domain07 >< 58:domain09 >< 1002:dynip >< 1004:dyndns > netPrefFieldTypeUInt32
  • < 4:bind >< 6:gtwytyp ><
    8:apn >< 10:mip >< 12:ha2 >< 14:1xtnl >< 16:aaasp >< 18:protect >< 20:pdpchg >< 22:crdata >< 24:1xrttqos >< 26:nai >< 28:vjslots >< 30:HttpSv >< 32:HttpsSv >< 34:HttpS2 >< 36:HttpsS2 >< 38:ExclHst >< 40:Pass2 >< 42:HomePg >< 44:UrlUa >< 46:MSIfmt >< 48:ReqStat >< 50:domain01 >< 52:domain03 >< 54:domain05 >< 56:domain07 >< 58:domain09 >< 1002:dynip >< 1004:dyndns >< 1006:secdns > netPrefFieldTypeUInt16
  • < 4:bind >< 6:gtwytyp ><
    8:apn >< 10:mip >< 12:ha2 >< 14:1xtnl >< 16:aaasp >< 18:protect >< 20:pdpchg >< 22:crdata >< 24:1xrttqos >< 26:nai >< 28:vjslots >< 30:HttpSv >< 32:HttpsSv >< 34:HttpS2 >< 36:HttpsS2 >< 38:ExclHst >< 40:Pass2 >< 42:HomePg >< 44:UrlUa >< 46:MSIfmt >< 48:ReqStat >< 50:domain01 >< 52:domain03 >< 54:domain05 >< 56:domain07 >< 58:domain09 >< 1002:dynip >< 1004:dyndns >< 1006:secdns >< 1008:inactm > netPrefFieldTypeUInt8
  • < 4:bind >< 6:gtwytyp ><
    8:apn >< 10:mip >< 12:ha2 >< 14:1xtnl >< 16:aaasp >< 18:protect >< 20:pdpchg >< 22:crdata >< 24:1xrttqos >< 26:nai >< 28:vjslots >< 30:HttpSv >< 32:HttpsSv >< 34:HttpS2 >< 36:HttpsS2 >< 38:ExclHst >< 40:Pass2 >< 42:HomePg >< 44:UrlUa >< 46:MSIfmt >< 48:ReqStat >< 50:domain01 >< 52:domain03 >< 54:domain05 >< 56:domain07 >< 58:domain09 >< 1002:dynip >< 1004:dyndns >< 1006:secdns >< 1008:inactm >< 1010:vjcmpr > netPrefFieldTypeStr
  • < 4:bind >< 6:gtwytyp ><
    8:apn >< 10:mip >< 12:ha2 >< 14:1xtnl >< 16:aaasp >< 18:protect >< 20:pdpchg >< 22:crdata >< 24:1xrttqos >< 26:nai >< 28:vjslots >< 30:HttpSv >< 32:HttpsSv >< 34:HttpS2 >< 36:HttpsS2 >< 38:ExclHst >< 40:Pass2 >< 42:HomePg >< 44:UrlUa >< 46:MSIfmt >< 48:ReqStat >< 50:domain01 >< 52:domain03 >< 54:domain05 >< 56:domain07 >< 58:domain09 >< 1002:dynip >< 1004:dyndns >< 1006:secdns >< 1008:inactm >< 1010:vjcmpr >< 1012:svcnam > netPrefFieldTypeStr
  • < 4:bind >< 6:gtwytyp ><
    8:apn >< 10:mip >< 12:ha2 >< 14:1xtnl >< 16:aaasp >< 18:protect >< 20:pdpchg >< 22:crdata >< 24:1xrttqos >< 26:nai >< 28:vjslots >< 30:HttpSv >< 32:HttpsSv >< 34:HttpS2 >< 36:HttpsS2 >< 38:ExclHst >< 40:Pass2 >< 42:HomePg >< 44:UrlUa >< 46:MSIfmt >< 48:ReqStat >< 50:domain01 >< 52:domain03 >< 54:domain05 >< 56:domain07 >< 58:domain09 >< 1002:dynip >< 1004:dyndns >< 1006:secdns >< 1008:inactm >< 1010:vjcmpr >< 1012:svcnam >< 1014:usrpsw > netPrefFieldTypeStr
  • < 4:bind >< 6:gtwytyp ><
    8:apn >< 10:mip >< 12:ha2 >< 14:1xtnl >< 16:aaasp >< 18:protect >< 20:pdpchg >< 22:crdata >< 24:1xrttqos >< 26:nai >< 28:vjslots >< 30:HttpSv >< 32:HttpsSv >< 34:HttpS2 >< 36:HttpsS2 >< 38:ExclHst >< 40:Pass2 >< 42:HomePg >< 44:UrlUa >< 46:MSIfmt >< 48:ReqStat >< 50:domain01 >< 52:domain03 >< 54:domain05 >< 56:domain07 >< 58:domain09 >< 1002:dynip >< 1004:dyndns >< 1006:secdns >< 1008:inactm >< 1010:vjcmpr >< 1012:svcnam >< 1014:usrpsw >< 1016:hosttab > netPrefFieldTypeStr
  • < 4:bind >< 6:gtwytyp ><
    8:apn >< 10:mip >< 12:ha2 >< 14:1xtnl >< 16:aaasp >< 18:protect >< 20:pdpchg >< 22:crdata >< 24:1xrttqos >< 26:nai >< 28:vjslots >< 30:HttpSv >< 32:HttpsSv >< 34:HttpS2 >< 36:HttpsS2 >< 38:ExclHst >< 40:Pass2 >< 42:HomePg >< 44:UrlUa >< 46:MSIfmt >< 48:ReqStat >< 50:domain01 >< 52:domain03 >< 54:domain05 >< 56:domain07 >< 58:domain09 >< 1002:dynip >< 1004:dyndns >< 1006:secdns >< 1008:inactm >< 1010:vjcmpr >< 1012:svcnam >< 1014:usrpsw >< 1016:hosttab >< 1018:pophst > netPrefFieldTypeZStrList
  • < 4:bind >< 6:gtwytyp ><
    8:apn >< 10:mip >< 12:ha2 >< 14:1xtnl >< 16:aaasp >< 18:protect >< 20:pdpchg >< 22:crdata >< 24:1xrttqos >< 26:nai >< 28:vjslots >< 30:HttpSv >< 32:HttpsSv >< 34:HttpS2 >< 36:HttpsS2 >< 38:ExclHst >< 40:Pass2 >< 42:HomePg >< 44:UrlUa >< 46:MSIfmt >< 48:ReqStat >< 50:domain01 >< 52:domain03 >< 54:domain05 >< 56:domain07 >< 58:domain09 >< 1002:dynip >< 1004:dyndns >< 1006:secdns >< 1008:inactm >< 1010:vjcmpr >< 1012:svcnam >< 1014:usrpsw >< 1016:hosttab >< 1018:pophst >< 1020:script > netPrefFieldTypeUInt8
  • < 4:bind >< 6:gtwytyp ><
    8:apn >< 10:mip >< 12:ha2 >< 14:1xtnl >< 16:aaasp >< 18:protect >< 20:pdpchg >< 22:crdata >< 24:1xrttqos >< 26:nai >< 28:vjslots >< 30:HttpSv >< 32:HttpsSv >< 34:HttpS2 >< 36:HttpsS2 >< 38:ExclHst >< 40:Pass2 >< 42:HomePg >< 44:UrlUa >< 46:MSIfmt >< 48:ReqStat >< 50:domain01 >< 52:domain03 >< 54:domain05 >< 56:domain07 >< 58:domain09 >< 1002:dynip >< 1004:dyndns >< 1006:secdns >< 1008:inactm >< 1010:vjcmpr >< 1012:svcnam >< 1014:usrpsw >< 1016:hosttab >< 1018:pophst >< 1020:script >< 1022:enprefx > netPrefFieldTypeUInt8
  • < 4:bind >< 6:gtwytyp ><
    8:apn >< 10:mip >< 12:ha2 >< 14:1xtnl >< 16:aaasp >< 18:protect >< 20:pdpchg >< 22:crdata >< 24:1xrttqos >< 26:nai >< 28:vjslots >< 30:HttpSv >< 32:HttpsSv >< 34:HttpS2 >< 36:HttpsS2 >< 38:ExclHst >< 40:Pass2 >< 42:HomePg >< 44:UrlUa >< 46:MSIfmt >< 48:ReqStat >< 50:domain01 >< 52:domain03 >< 54:domain05 >< 56:domain07 >< 58:domain09 >< 1002:dynip >< 1004:dyndns >< 1006:secdns >< 1008:inactm >< 1010:vjcmpr >< 1012:svcnam >< 1014:usrpsw >< 1016:hosttab >< 1018:pophst >< 1020:script >< 1022:enprefx >< 1024:encalcd > netPrefFieldTypeStr
  • < 4:bind >< 6:gtwytyp ><
    8:apn >< 10:mip >< 12:ha2 >< 14:1xtnl >< 16:aaasp >< 18:protect >< 20:pdpchg >< 22:crdata >< 24:1xrttqos >< 26:nai >< 28:vjslots >< 30:HttpSv >< 32:HttpsSv >< 34:HttpS2 >< 36:HttpsS2 >< 38:ExclHst >< 40:Pass2 >< 42:HomePg >< 44:UrlUa >< 46:MSIfmt >< 48:ReqStat >< 50:domain01 >< 52:domain03 >< 54:domain05 >< 56:domain07 >< 58:domain09 >< 1002:dynip >< 1004:dyndns >< 1006:secdns >< 1008:inactm >< 1010:vjcmpr >< 1012:svcnam >< 1014:usrpsw >< 1016:hosttab >< 1018:pophst >< 1020:script >< 1022:enprefx >< 1024:encalcd >< 1026:phone > netPrefFieldTypeStr

Function Documentation

<4:bind><6:gtwytyp><8:apn><10:mip><12:ha2><14:1xtnl><16:aaasp><18:protect><20:pdpchg><22:crdata><24:1xrttqos><26:nai><28:vjslots><30:HttpSv><32:HttpsSv><34:HttpS2><36:HttpsS2><38:ExclHst><40:Pass2><42:HomePg><44:UrlUa><46:MSIfmt><48:ReqStat><50:domain01><52:domain03><54:domain05><56:domain07><58:domain09> NetPrefRecFieldInfoExtended | ( | netPrefRecFieldDomain10 | ,
 |  | 59 | ,
 |  | netPrefFieldTypeStr | ,
 |  | 0 | ,
 |  | 0 | ,
 |  | < 59:domain10 > | ,
 |  | 13 |
 | ) |  |

START OF LEGACY FIELDS

<4:bind><6:gtwytyp><8:apn><10:mip><12:ha2><14:1xtnl><16:aaasp><18:protect><20:pdpchg><22:crdata><24:1xrttqos><26:nai><28:vjslots><30:HttpSv><32:HttpsSv><34:HttpS2><36:HttpsS2><38:ExclHst><40:Pass2><42:HomePg><44:UrlUa><46:MSIfmt><48:ReqStat><50:domain01><52:domain03><54:domain05><56:domain07> NetPrefRecFieldInfoExtended | ( | netPrefRecFieldDomain08 | ,
 |  | 57 | ,
 |  | netPrefFieldTypeStr | ,
 |  | 0 | ,
 |  | 0 | ,
 |  | < 57:domain08 > | ,
 |  | 13 |
 | ) |  |

<4:bind><6:gtwytyp><8:apn><10:mip><12:ha2><14:1xtnl><16:aaasp><18:protect><20:pdpchg><22:crdata><24:1xrttqos><26:nai><28:vjslots><30:HttpSv><32:HttpsSv><34:HttpS2><36:HttpsS2><38:ExclHst><40:Pass2><42:HomePg><44:UrlUa><46:MSIfmt><48:ReqStat><50:domain01><52:domain03><54:domain05> NetPrefRecFieldInfoExtended | ( | netPrefRecFieldDomain06 | ,
 |  | 55 | ,
 |  | netPrefFieldTypeStr | ,
 |  | 0 | ,
 |  | 0 | ,
 |  | < 55:domain06 > | ,
 |  | 13 |
 | ) |  |

<4:bind><6:gtwytyp><8:apn><10:mip><12:ha2><14:1xtnl><16:aaasp><18:protect><20:pdpchg><22:crdata><24:1xrttqos><26:nai><28:vjslots><30:HttpSv><32:HttpsSv><34:HttpS2><36:HttpsS2><38:ExclHst><40:Pass2><42:HomePg><44:UrlUa><46:MSIfmt><48:ReqStat><50:domain01><52:domain03> NetPrefRecFieldInfoExtended | ( | netPrefRecFieldDomain04 | ,
 |  | 53 | ,
 |  | netPrefFieldTypeStr | ,
 |  | 0 | ,
 |  | 0 | ,
 |  | < 53:domain04 > | ,
 |  | 13 |
 | ) |  |

<4:bind><6:gtwytyp><8:apn><10:mip><12:ha2><14:1xtnl><16:aaasp><18:protect><20:pdpchg><22:crdata><24:1xrttqos><26:nai><28:vjslots><30:HttpSv><32:HttpsSv><34:HttpS2><36:HttpsS2><38:ExclHst><40:Pass2><42:HomePg><44:UrlUa><46:MSIfmt><48:ReqStat><50:domain01> NetPrefRecFieldInfoExtended | ( | netPrefRecFieldDomain02 | ,
 |  | 51 | ,
 |  | netPrefFieldTypeStr | ,
 |  | 0 | ,
 |  | 0 | ,
 |  | < 51:domain02 > | ,
 |  | 13 |
 | ) |  |

<4:bind><6:gtwytyp><8:apn><10:mip><12:ha2><14:1xtnl><16:aaasp><18:protect><20:pdpchg><22:crdata><24:1xrttqos><26:nai><28:vjslots><30:HttpSv><32:HttpsSv><34:HttpS2><36:HttpsS2><38:ExclHst><40:Pass2><42:HomePg><44:UrlUa><46:MSIfmt><48:ReqStat> NetPrefRecFieldInfoExtended | ( | netPrefRecFieldProxyStaticHeaderString | ,
 |  | 49 | ,
 |  | netPrefFieldTypeStr | ,
 |  | 0 | ,
 |  | 0 | ,
 |  | < 49:StatHStr > | ,
 |  | 13 |
 | ) |  |

<4:bind><6:gtwytyp><8:apn><10:mip><12:ha2><14:1xtnl><16:aaasp><18:protect><20:pdpchg><22:crdata><24:1xrttqos><26:nai><28:vjslots><30:HttpSv><32:HttpsSv><34:HttpS2><36:HttpsS2><38:ExclHst><40:Pass2><42:HomePg><44:UrlUa><46:MSIfmt> NetPrefRecFieldInfoExtended | ( | netPrefRecFieldProxyMsisdnStaticString | ,
 |  | 47 | ,
 |  | netPrefFieldTypeStr | ,
 |  | 0 | ,
 |  | 0 | ,
 |  | < 47:MSIStr > | ,
 |  | 11 |
 | ) |  |

<4:bind><6:gtwytyp><8:apn><10:mip><12:ha2><14:1xtnl><16:aaasp><18:protect><20:pdpchg><22:crdata><24:1xrttqos><26:nai><28:vjslots><30:HttpSv><32:HttpsSv><34:HttpS2><36:HttpsS2><38:ExclHst><40:Pass2><42:HomePg><44:UrlUa> NetPrefRecFieldInfoExtended | ( | netPrefRecFieldProxyEncryptedMsisdn | ,
 |  | 45 | ,
 |  | netPrefFieldTypeUInt8 | ,
 |  | 0 | ,
 |  | 0 | ,
 |  | < 45:EncrMSI > | ,
 |  | 12 |
 | ) |  |

<4:bind><6:gtwytyp><8:apn><10:mip><12:ha2><14:1xtnl><16:aaasp><18:protect><20:pdpchg><22:crdata><24:1xrttqos><26:nai><28:vjslots><30:HttpSv><32:HttpsSv><34:HttpS2><36:HttpsS2><38:ExclHst><40:Pass2><42:HomePg> NetPrefRecFieldInfoExtended | ( | netPrefRecFieldProxyUaProfHostedOnOwnServers | ,
 |  | 43 | ,
 |  | netPrefFieldTypeUInt8 | ,
 |  | 0 | ,
 |  | 0 | ,
 |  | < 43:UaOwnSv > | ,
 |  | 12 |
 | ) |  |

<4:bind><6:gtwytyp><8:apn><10:mip><12:ha2><14:1xtnl><16:aaasp><18:protect><20:pdpchg><22:crdata><24:1xrttqos><26:nai><28:vjslots><30:HttpSv><32:HttpsSv><34:HttpS2><36:HttpsS2><38:ExclHst><40:Pass2> NetPrefRecFieldInfoExtended | ( | netPrefRecFieldProxyReqCustomUaProf | ,
 |  | 41 | ,
 |  | netPrefFieldTypeUInt8 | ,
 |  | 0 | ,
 |  | 0 | ,
 |  | < 41:CustUa > | ,
 |  | 11 |
 | ) |  |

<4:bind><6:gtwytyp><8:apn><10:mip><12:ha2><14:1xtnl><16:aaasp><18:protect><20:pdpchg><22:crdata><24:1xrttqos><26:nai><28:vjslots><30:HttpSv><32:HttpsSv><34:HttpS2><36:HttpsS2><38:ExclHst> NetPrefRecFieldInfoExtended | ( | netPrefRecFieldProxyUsernameNew | ,
 |  | 39 | ,
 |  | netPrefFieldTypeStr | ,
 |  | 0 | ,
 |  | 0 | ,
 |  | < 39:User2 > | ,
 |  | 10 |
 | ) |  |

<4:bind><6:gtwytyp><8:apn><10:mip><12:ha2><14:1xtnl><16:aaasp><18:protect><20:pdpchg><22:crdata><24:1xrttqos><26:nai><28:vjslots><30:HttpSv><32:HttpsSv><34:HttpS2><36:HttpsS2> NetPrefRecFieldInfoExtended | ( | netPrefRecFieldProxySecondaryHttpsPort | ,
 |  | 37 | ,
 |  | netPrefFieldTypeUInt32 | ,
 |  | 0 | ,
 |  | 0 | ,
 |  | < 37:HttpsP2 > | ,
 |  | 12 |
 | ) |  |

<4:bind><6:gtwytyp><8:apn><10:mip><12:ha2><14:1xtnl><16:aaasp><18:protect><20:pdpchg><22:crdata><24:1xrttqos><26:nai><28:vjslots><30:HttpSv><32:HttpsSv><34:HttpS2> NetPrefRecFieldInfoExtended | ( | netPrefRecFieldProxySecondaryHttpPort | ,
 |  | 35 | ,
 |  | netPrefFieldTypeUInt32 | ,
 |  | 0 | ,
 |  | 0 | ,
 |  | < 35:HttpP2 > | ,
 |  | 11 |
 | ) |  |

<4:bind><6:gtwytyp><8:apn><10:mip><12:ha2><14:1xtnl><16:aaasp><18:protect><20:pdpchg><22:crdata><24:1xrttqos><26:nai><28:vjslots><30:HttpSv><32:HttpsSv> NetPrefRecFieldInfoExtended | ( | netPrefRecFieldProxyPrimaryHttpsPort | ,
 |  | 33 | ,
 |  | netPrefFieldTypeUInt32 | ,
 |  | 0 | ,
 |  | 0 | ,
 |  | < 33:HttpsPt > | ,
 |  | 12 |
 | ) |  |

<4:bind><6:gtwytyp><8:apn><10:mip><12:ha2><14:1xtnl><16:aaasp><18:protect><20:pdpchg><22:crdata><24:1xrttqos><26:nai><28:vjslots><30:HttpSv> NetPrefRecFieldInfoExtended | ( | netPrefRecFieldProxyPrimaryHttpPort | ,
 |  | 31 | ,
 |  | netPrefFieldTypeUInt32 | ,
 |  | 0 | ,
 |  | 0 | ,
 |  | < 31:HttpPt > | ,
 |  | 11 |
 | ) |  |

<4:bind><6:gtwytyp><8:apn><10:mip><12:ha2><14:1xtnl><16:aaasp><18:protect><20:pdpchg><22:crdata><24:1xrttqos><26:nai><28:vjslots> NetPrefRecFieldInfoExtended | ( | netPrefRecFieldFallbackInfo | ,
 |  | 29 | ,
 |  | netPrefFieldTypeBin | ,
 |  | 0 | ,
 |  | 0 | ,
 |  | < 29:fbkinfo > | ,
 |  | 12 |
 | ) |  |

<chg 2006-01-18 kos> Feature for Camino|Microwave: Per-APN proxy settings (9.1.2) deprecates the old "browser settings" normally stored in the carrier record

<4:bind><6:gtwytyp><8:apn><10:mip><12:ha2><14:1xtnl><16:aaasp><18:protect><20:pdpchg><22:crdata><24:1xrttqos><26:nai> NetPrefRecFieldInfoExtended | ( | netPrefRecFieldMnAaaSs | ,
 |  | 27 | ,
 |  | netPrefFieldTypeBin | ,
 |  | 0 | ,
 |  | 0 | ,
 |  | < 27:mnaaass > | ,
 |  | 12 |
 | ) |  |

UInt8, -- initial number of VJ Compression slots if VJ compression is enabled; used to set NetLib's netIFSettingVJCompSlots setting (see also netPrefRecFieldVJCompEnable).

<4:bind><6:gtwytyp><8:apn><10:mip><12:ha2><14:1xtnl><16:aaasp><18:protect><20:pdpchg><22:crdata><24:1xrttqos> NetPrefRecFieldInfoExtended | ( | netPrefRecFieldBinReserved1 | ,
 |  | 25 | ,
 |  | netPrefFieldTypeBin | ,
 |  | 0 | ,
 |  | 0 | ,
 |  | < 25:binrsvd1 > | ,
 |  | 13 |
 | ) |  |

char*, 1xRTT NAI field (CDMA/1xRTT)

<4:bind><6:gtwytyp><8:apn><10:mip><12:ha2><14:1xtnl><16:aaasp><18:protect><20:pdpchg><22:crdata> NetPrefRecFieldInfoExtended | ( | netPrefRecFieldGPRSQOS | ,
 |  | 23 | ,
 |  | netPrefFieldTypeBin | ,
 |  | 0 | ,
 |  | 0 | ,
 |  | < 23:gprsqos > | ,
 |  | 12 |
 | ) |  |

NetPref1xRTTQOSType -- 1xRTT Quality of Service parameters. UNDEFINED/RESERVED BY HANDSPRING

<4:bind><6:gtwytyp><8:apn><10:mip><12:ha2><14:1xtnl><16:aaasp><18:protect><20:pdpchg> NetPrefRecFieldInfoExtended | ( | netPrefRecFieldCreatorID | ,
 |  | 21 | ,
 |  | netPrefFieldTypeUInt32 | ,
 |  | 0 | ,
 |  | 0 | ,
 |  | < 21:crid > | ,
 |  | 9 |
 | ) |  |

void*, Creator-specific binary data field; applications that set the netPrefRecFieldCreatorID field may also save application-specific data inside this field. see also netPrefRecFieldCreatorID.

<4:bind><6:gtwytyp><8:apn><10:mip><12:ha2><14:1xtnl><16:aaasp><18:protect> NetPrefRecFieldInfoExtended | ( | netPrefRecFieldPDPIndex | ,
 |  | 19 | ,
 |  | netPrefFieldTypeUInt32 | ,
 |  | 0 | ,
 |  | 0 | ,
 |  | < 19:pdpidx > | ,
 |  | 11 |
 | ) |  |

void*, -- Unique ID/Change number of the PDP slot in radio's NV table. Presently used for CDMA/1xRTT IOTA-bound profiles. For internal use only!

<4:bind><6:gtwytyp><8:apn><10:mip><12:ha2><14:1xtnl><16:aaasp> NetPrefRecFieldInfoExtended | ( | netPrefRecFieldDialStr | ,
 |  | 17 | ,
 |  | netPrefFieldTypeStr | ,
 |  | 0 | ,
 |  | 0 | ,
 |  | < 17:dials > | ,
 |  | 10 |
 | ) |  |

UInt32, NetPrefRecProtectionType -- record protection options

<4:bind><6:gtwytyp><8:apn><10:mip><12:ha2><14:1xtnl> NetPrefRecFieldInfoExtended | ( | netPrefRecFieldMnHaSpi | ,
 |  | 15 | ,
 |  | netPrefFieldTypeUInt32 | ,
 |  | 0 | ,
 |  | 0 | ,
 |  | < 15:haspi > | ,
 |  | 10 |
 | ) |  |

UInt32, SPI for MN-AAA authentication, if Mobile-IP (CDMA/1xRTT)

<4:bind><6:gtwytyp><8:apn><10:mip><12:ha2> NetPrefRecFieldInfoExtended | ( | netPrefRecFieldMnHaSS | ,
 |  | 13 | ,
 |  | netPrefFieldTypeBin | ,
 |  | 0 | ,
 |  | 0 | ,
 |  | < 13:hapsw > | ,
 |  | 10 |
 | ) |  |

UInt16, NetPref1xRTTTunnelingEnum; Tunneling, if Mobile-IP (CDMA/1xRTT)

<4:bind><6:gtwytyp><8:apn><10:mip> NetPrefRecFieldInfoExtended | ( | netPrefRecFieldHAAddrPrimary | ,
 |  | 11 | ,
 |  | netPrefFieldTypeUInt32 | ,
 |  | 0 | ,
 |  | 0 | ,
 |  | < 11:ha1 > | ,
 |  | 8 |
 | ) |  |

UInt32, Secondary HA Address, if Mobile-IP (CDMA/1xRTT)

<4:bind><6:gtwytyp><8:apn> NetPrefRecFieldInfoExtended | ( | netPrefRecFieldMdmInitStr | ,
 |  | 9 | ,
 |  | netPrefFieldTypeStr | ,
 |  | 0 | ,
 |  | 0 | ,
 |  | < 9:mdmins > | ,
 |  | 10 |
 | ) |  |

UInt8; Is Mobile-IP; non-zero=true (0x01), zero=false (CDMA/1xRTT only)

<4:bind><6:gtwytyp> NetPrefRecFieldInfoExtended | ( | netPrefRecFieldFallbackID | ,
 |  | 7 | ,
 |  | netPrefFieldTypeUInt32 | ,
 |  | 0 | ,
 |  | 0 | ,
 |  | < 7:fback > | ,
 |  | 9 |
 | ) |  |

char*, APN name for GPRS services

<4:bind> NetPrefRecFieldInfoExtended | ( | netPrefRecFieldBindingIndex | ,
 |  | 5 | ,
 |  | netPrefFieldTypeUInt16 | ,
 |  | 0 | ,
 |  | 0 | ,
 |  | < 5:bindidx > | ,
 |  | 11 |
 | ) |  |

UInt32, NetPrefSvcGatewayType - Internet, WAP, etc. (1 or more netPrefSvcGateway... constants bitwise-or'ed together; if the field is absent, Internet is implied.

NetPrefRecFieldInfoExtended | ( | netPrefRecFieldSvcMediumAlias | ,
 |  | 3 | ,
 |  | netPrefFieldTypeUInt16 | ,
 |  | 0 | ,
 |  | 0 | ,
 |  | < 3:medium > | ,
 |  | 10 |
 | ) |  |

UInt16, NetPrefSvcBindingEnum; not needed in most cases. Handspring internal use only!

NetPrefRecFieldInfoGrpStart | ( | netPrefRecFieldExtendedSTART | ,
 |  | 1 |
 | ) |  |

UInt32; reserved for internal Handspring use only

<4:bind><6:gtwytyp><8:apn><10:mip><12:ha2><14:1xtnl><16:aaasp><18:protect><20:pdpchg><22:crdata><24:1xrttqos><26:nai><28:vjslots><30:HttpSv><32:HttpsSv><34:HttpS2><36:HttpsS2><38:ExclHst><40:Pass2><42:HomePg><44:UrlUa><46:MSIfmt><48:ReqStat><50:domain01><52:domain03><54:domain05><56:domain07><58:domain09><1002:dynip><1004:dyndns><1006:secdns><1008:inactm><1010:vjcmpr><1012:svcnam><1014:usrpsw><1016:hosttab><1018:pophst><1020:script><1022:enprefx><1024:encalcd><1026:phone> NetPrefRecFieldInfoLegacy | ( | netPrefRecFieldDialPrefix | ,
 |  | 1027 | ,
 |  | netPrefFieldTypeStr | ,
 |  | 0 | ,
 |  | 0 | ,
 |  | < 1027:dlprefx > | ,
 |  | 14 |
 | ) |  |

char*; corresponds to the Call Waiting setting in the Phone Setup dialog.

<4:bind><6:gtwytyp><8:apn><10:mip><12:ha2><14:1xtnl><16:aaasp><18:protect><20:pdpchg><22:crdata><24:1xrttqos><26:nai><28:vjslots><30:HttpSv><32:HttpsSv><34:HttpS2><36:HttpsS2><38:ExclHst><40:Pass2><42:HomePg><44:UrlUa><46:MSIfmt><48:ReqStat><50:domain01><52:domain03><54:domain05><56:domain07><58:domain09><1002:dynip><1004:dyndns><1006:secdns><1008:inactm><1010:vjcmpr><1012:svcnam><1014:usrpsw><1016:hosttab><1018:pophst><1020:script><1022:enprefx><1024:encalcd> NetPrefRecFieldInfoLegacy | ( | netPrefRecFieldPulseDialEnable | ,
 |  | 1025 | ,
 |  | netPrefFieldTypeUInt8 | ,
 |  | 0 | ,
 |  | 0 | ,
 |  | < 1025:enpulse > | ,
 |  | 14 |
 | ) |  |

char*; phone number; corresponds to the Phone # field in the Phone Setup dialog.

<4:bind><6:gtwytyp><8:apn><10:mip><12:ha2><14:1xtnl><16:aaasp><18:protect><20:pdpchg><22:crdata><24:1xrttqos><26:nai><28:vjslots><30:HttpSv><32:HttpsSv><34:HttpS2><36:HttpsS2><38:ExclHst><40:Pass2><42:HomePg><44:UrlUa><46:MSIfmt><48:ReqStat><50:domain01><52:domain03><54:domain05><56:domain07><58:domain09><1002:dynip><1004:dyndns><1006:secdns><1008:inactm><1010:vjcmpr><1012:svcnam><1014:usrpsw><1016:hosttab><1018:pophst><1020:script><1022:enprefx> NetPrefRecFieldInfoLegacy | ( | netPrefRecFieldCallWaitingEnable | ,
 |  | 1023 | ,
 |  | netPrefFieldTypeUInt8 | ,
 |  | 0 | ,
 |  | 0 | ,
 |  | < 1023:encalwt > | ,
 |  | 14 |
 | ) |  |

UInt8; non-zero=true, zero=false; corresponds to the Calling Card setting in the Phone Setup dialog.

<4:bind><6:gtwytyp><8:apn><10:mip><12:ha2><14:1xtnl><16:aaasp><18:protect><20:pdpchg><22:crdata><24:1xrttqos><26:nai><28:vjslots><30:HttpSv><32:HttpsSv><34:HttpS2><36:HttpsS2><38:ExclHst><40:Pass2><42:HomePg><44:UrlUa><46:MSIfmt><48:ReqStat><50:domain01><52:domain03><54:domain05><56:domain07><58:domain09><1002:dynip><1004:dyndns><1006:secdns><1008:inactm><1010:vjcmpr><1012:svcnam><1014:usrpsw><1016:hosttab><1018:pophst><1020:script> NetPrefRecFieldInfoLegacy | ( | netPrefRecFieldConnection | ,
 |  | 1021 | ,
 |  | netPrefFieldTypeStr | ,
 |  | 0 | ,
 |  | 0 | ,
 |  | < 1021:connnam > | ,
 |  | 14 |
 | ) |  |

UInt8; non-zero=true, zero=false; corresponds to the dial prefix setting in the Phone Setup dialog.

<4:bind><6:gtwytyp><8:apn><10:mip><12:ha2><14:1xtnl><16:aaasp><18:protect><20:pdpchg><22:crdata><24:1xrttqos><26:nai><28:vjslots><30:HttpSv><32:HttpsSv><34:HttpS2><36:HttpsS2><38:ExclHst><40:Pass2><42:HomePg><44:UrlUa><46:MSIfmt><48:ReqStat><50:domain01><52:domain03><54:domain05><56:domain07><58:domain09><1002:dynip><1004:dyndns><1006:secdns><1008:inactm><1010:vjcmpr><1012:svcnam><1014:usrpsw><1016:hosttab><1018:pophst> NetPrefRecFieldInfoLegacy | ( | netPrefRecFieldNewsServer | ,
 |  | 1019 | ,
 |  | netPrefFieldTypeStr | ,
 |  | 0 | ,
 |  | 0 | ,
 |  | < 1019:newssrv > | ,
 |  | 14 |
 | ) |  |

char*; loginScript; scripts contain null terminated strings and end with a double null; ***an empty script is represented with a single null (not double null); used to set NetLib's netIFSettingLoginScript setting for dial-up type of profiles. Refer to Palm for login-script format.

<4:bind><6:gtwytyp><8:apn><10:mip><12:ha2><14:1xtnl><16:aaasp><18:protect><20:pdpchg><22:crdata><24:1xrttqos><26:nai><28:vjslots><30:HttpSv><32:HttpsSv><34:HttpS2><36:HttpsS2><38:ExclHst><40:Pass2><42:HomePg><44:UrlUa><46:MSIfmt><48:ReqStat><50:domain01><52:domain03><54:domain05><56:domain07><58:domain09><1002:dynip><1004:dyndns><1006:secdns><1008:inactm><1010:vjcmpr><1012:svcnam><1014:usrpsw><1016:hosttab> NetPrefRecFieldInfoLegacy | ( | netPrefRecFieldSMTPHost | ,
 |  | 1017 | ,
 |  | netPrefFieldTypeStr | ,
 |  | 0 | ,
 |  | 0 | ,
 |  | < 1017:smtphst > | ,
 |  | 14 |
 | ) |  |

char*; presently not used.

<4:bind><6:gtwytyp><8:apn><10:mip><12:ha2><14:1xtnl><16:aaasp><18:protect><20:pdpchg><22:crdata><24:1xrttqos><26:nai><28:vjslots><30:HttpSv><32:HttpsSv><34:HttpS2><36:HttpsS2><38:ExclHst><40:Pass2><42:HomePg><44:UrlUa><46:MSIfmt><48:ReqStat><50:domain01><52:domain03><54:domain05><56:domain07><58:domain09><1002:dynip><1004:dyndns><1006:secdns><1008:inactm><1010:vjcmpr><1012:svcnam><1014:usrpsw> NetPrefRecFieldInfoLegacy | ( | netPrefRecFieldDomainName | ,
 |  | 1015 | ,
 |  | netPrefFieldTypeStr | ,
 |  | 0 | ,
 |  | 0 | ,
 |  | < 1015:domain > | ,
 |  | 13 |
 | ) |  |

char*; callback username, password; used to set NetLib's netSettingHostTbl setting; might not be used by NetLib.

<4:bind><6:gtwytyp><8:apn><10:mip><12:ha2><14:1xtnl><16:aaasp><18:protect><20:pdpchg><22:crdata><24:1xrttqos><26:nai><28:vjslots><30:HttpSv><32:HttpsSv><34:HttpS2><36:HttpsS2><38:ExclHst><40:Pass2><42:HomePg><44:UrlUa><46:MSIfmt><48:ReqStat><50:domain01><52:domain03><54:domain05><56:domain07><58:domain09><1002:dynip><1004:dyndns><1006:secdns><1008:inactm><1010:vjcmpr><1012:svcnam> NetPrefRecFieldInfoLegacy | ( | netPrefRecFieldUsername | ,
 |  | 1013 | ,
 |  | netPrefFieldTypeStr | ,
 |  | 0 | ,
 |  | 0 | ,
 |  | < 1013:usrnam > | ,
 |  | 13 |
 | ) |  |

char*; password

<4:bind><6:gtwytyp><8:apn><10:mip><12:ha2><14:1xtnl><16:aaasp><18:protect><20:pdpchg><22:crdata><24:1xrttqos><26:nai><28:vjslots><30:HttpSv><32:HttpsSv><34:HttpS2><36:HttpsS2><38:ExclHst><40:Pass2><42:HomePg><44:UrlUa><46:MSIfmt><48:ReqStat><50:domain01><52:domain03><54:domain05><56:domain07><58:domain09><1002:dynip><1004:dyndns><1006:secdns><1008:inactm><1010:vjcmpr> NetPrefRecFieldInfoLegacy | ( | netPrefRecFieldUseModem | ,
 |  | 1011 | ,
 |  | netPrefFieldTypeUInt8 | ,
 |  | 0 | ,
 |  | 0 | ,
 |  | < 1011:usemdm > | ,
 |  | 13 |
 | ) |  |

char*; service name

<4:bind><6:gtwytyp><8:apn><10:mip><12:ha2><14:1xtnl><16:aaasp><18:protect><20:pdpchg><22:crdata><24:1xrttqos><26:nai><28:vjslots><30:HttpSv><32:HttpsSv><34:HttpS2><36:HttpsS2><38:ExclHst><40:Pass2><42:HomePg><44:UrlUa><46:MSIfmt><48:ReqStat><50:domain01><52:domain03><54:domain05><56:domain07><58:domain09><1002:dynip><1004:dyndns><1006:secdns><1008:inactm> NetPrefRecFieldInfoLegacy | ( | netPrefRecFieldEstablishmentTimeout | ,
 |  | 1009 | ,
 |  | netPrefFieldTypeUInt16 | ,
 |  | 0 | ,
 |  | 0 | ,
 |  | < 1009:estbtm > | ,
 |  | 13 |
 | ) |  |

UInt8; non-zero=true, zero=false; used to set NetLib's netIFSettingVJCompEnable setting. See also netPrefRecFieldVJCompSlots.

<4:bind><6:gtwytyp><8:apn><10:mip><12:ha2><14:1xtnl><16:aaasp><18:protect><20:pdpchg><22:crdata><24:1xrttqos><26:nai><28:vjslots><30:HttpSv><32:HttpsSv><34:HttpS2><36:HttpsS2><38:ExclHst><40:Pass2><42:HomePg><44:UrlUa><46:MSIfmt><48:ReqStat><50:domain01><52:domain03><54:domain05><56:domain07><58:domain09><1002:dynip><1004:dyndns><1006:secdns> NetPrefRecFieldInfoLegacy | ( | netPrefRecFieldCloseWaitTime | ,
 |  | 1007 | ,
 |  | netPrefFieldTypeUInt32 | ,
 |  | 0 | ,
 |  | 0 | ,
 |  | < 1007:cwtm > | ,
 |  | 11 |
 | ) |  |

UInt16; expressed in seconds; see NetPrefNetIdleTimeoutEnum for special values; used to set NetLib interface's netIFSettingInactivityTimeout setting (also known as "idle timeout"). IMPORTANT: This setting is enforced beginning with Palm OS 5.0 and must be used to configure the idle timeout of the TCP/IP stack.

<4:bind><6:gtwytyp><8:apn><10:mip><12:ha2><14:1xtnl><16:aaasp><18:protect><20:pdpchg><22:crdata><24:1xrttqos><26:nai><28:vjslots><30:HttpSv><32:HttpsSv><34:HttpS2><36:HttpsS2><38:ExclHst><40:Pass2><42:HomePg><44:UrlUa><46:MSIfmt><48:ReqStat><50:domain01><52:domain03><54:domain05><56:domain07><58:domain09><1002:dynip><1004:dyndns> NetPrefRecFieldInfoLegacy | ( | netPrefRecFieldDNSAddrPrimary | ,
 |  | 1005 | ,
 |  | netPrefFieldTypeUInt32 | ,
 |  | 0 | ,
 |  | 0 | ,
 |  | < 1005:pridns > | ,
 |  | 13 |
 | ) |  |

UInt32; secondary DNS address if not dynamic

<4:bind><6:gtwytyp><8:apn><10:mip><12:ha2><14:1xtnl><16:aaasp><18:protect><20:pdpchg><22:crdata><24:1xrttqos><26:nai><28:vjslots><30:HttpSv><32:HttpsSv><34:HttpS2><36:HttpsS2><38:ExclHst><40:Pass2><42:HomePg><44:UrlUa><46:MSIfmt><48:ReqStat><50:domain01><52:domain03><54:domain05><56:domain07><58:domain09><1002:dynip> NetPrefRecFieldInfoLegacy | ( | netPrefRecFieldIPAddr | ,
 |  | 1003 | ,
 |  | netPrefFieldTypeUInt32 | ,
 |  | 0 | ,
 |  | 0 | ,
 |  | < 1003:ipaddr > | ,
 |  | 13 |
 | ) |  |

UInt8; non-zero=true (0x01), zero=false

<4:bind><6:gtwytyp><8:apn><10:mip><12:ha2><14:1xtnl><16:aaasp><18:protect><20:pdpchg><22:crdata><24:1xrttqos><26:nai><28:vjslots><30:HttpSv><32:HttpsSv><34:HttpS2><36:HttpsS2><38:ExclHst><40:Pass2><42:HomePg><44:UrlUa><46:MSIfmt><48:ReqStat><50:domain01><52:domain03><54:domain05><56:domain07><58:domain09> NetPrefRecFieldInfoLegacy | ( | netPrefRecFieldInterfaceID | ,
 |  | 1001 | ,
 |  | netPrefFieldTypeUInt32 | ,
 |  | 0 | ,
 |  | 0 | ,
 |  | < 1001:ifid > | ,
 |  | 11 |
 | ) |  |

UInt8; non-zero=true, zero=false

NetPrefRecFieldInfoPreamble ( )

reserve 0

Variable Documentation

<4:bind><6:gtwytyp><8:apn><10:mip><12:ha2><14:1xtnl><16:aaasp><18:protect><20:pdpchg><22:crdata> netPrefFieldTypeBin

Definition at line 214 of file NetPrefLibFieldInfoTable.h.

<4:bind><6:gtwytyp><8:apn><10:mip><12:ha2><14:1xtnl><16:aaasp><18:protect><20:pdpchg> netPrefFieldTypeBin

Definition at line 204 of file NetPrefLibFieldInfoTable.h.

<4:bind><6:gtwytyp><8:apn><10:mip><12:ha2><14:1xtnl><16:aaasp><18:protect> netPrefFieldTypeBin

Definition at line 187 of file NetPrefLibFieldInfoTable.h.

<4:bind><6:gtwytyp><8:apn><10:mip><12:ha2><14:1xtnl><16:aaasp><18:protect><20:pdpchg><22:crdata><24:1xrttqos><26:nai><28:vjslots><30:HttpSv><32:HttpsSv><34:HttpS2><36:HttpsS2><38:ExclHst><40:Pass2><42:HomePg><44:UrlUa><46:MSIfmt><48:ReqStat><50:domain01><52:domain03><54:domain05><56:domain07><58:domain09><1002:dynip><1004:dyndns><1006:secdns><1008:inactm><1010:vjcmpr><1012:svcnam><1014:usrpsw><1016:hosttab><1018:pophst><1020:script><1022:enprefx><1024:encalcd><1026:phone> netPrefFieldTypeStr

Definition at line 538 of file NetPrefLibFieldInfoTable.h.

<4:bind><6:gtwytyp><8:apn><10:mip><12:ha2><14:1xtnl><16:aaasp><18:protect><20:pdpchg><22:crdata><24:1xrttqos><26:nai><28:vjslots><30:HttpSv><32:HttpsSv><34:HttpS2><36:HttpsS2><38:ExclHst><40:Pass2><42:HomePg><44:UrlUa><46:MSIfmt><48:ReqStat><50:domain01><52:domain03><54:domain05><56:domain07><58:domain09><1002:dynip><1004:dyndns><1006:secdns><1008:inactm><1010:vjcmpr><1012:svcnam><1014:usrpsw><1016:hosttab><1018:pophst><1020:script><1022:enprefx><1024:encalcd> netPrefFieldTypeStr

Definition at line 530 of file NetPrefLibFieldInfoTable.h.

<4:bind><6:gtwytyp><8:apn><10:mip><12:ha2><14:1xtnl><16:aaasp><18:protect><20:pdpchg><22:crdata><24:1xrttqos><26:nai><28:vjslots><30:HttpSv><32:HttpsSv><34:HttpS2><36:HttpsS2><38:ExclHst><40:Pass2><42:HomePg><44:UrlUa><46:MSIfmt><48:ReqStat><50:domain01><52:domain03><54:domain05><56:domain07><58:domain09><1002:dynip><1004:dyndns><1006:secdns><1008:inactm><1010:vjcmpr><1012:svcnam><1014:usrpsw><1016:hosttab> netPrefFieldTypeStr

Definition at line 483 of file NetPrefLibFieldInfoTable.h.

<4:bind><6:gtwytyp><8:apn><10:mip><12:ha2><14:1xtnl><16:aaasp><18:protect><20:pdpchg><22:crdata><24:1xrttqos><26:nai><28:vjslots><30:HttpSv><32:HttpsSv><34:HttpS2><36:HttpsS2><38:ExclHst><40:Pass2><42:HomePg><44:UrlUa><46:MSIfmt><48:ReqStat><50:domain01><52:domain03><54:domain05><56:domain07><58:domain09><1002:dynip><1004:dyndns><1006:secdns><1008:inactm><1010:vjcmpr><1012:svcnam><1014:usrpsw> netPrefFieldTypeStr

Definition at line 472 of file NetPrefLibFieldInfoTable.h.

<4:bind><6:gtwytyp><8:apn><10:mip><12:ha2><14:1xtnl><16:aaasp><18:protect><20:pdpchg><22:crdata><24:1xrttqos><26:nai><28:vjslots><30:HttpSv><32:HttpsSv><34:HttpS2><36:HttpsS2><38:ExclHst><40:Pass2><42:HomePg><44:UrlUa><46:MSIfmt><48:ReqStat><50:domain01><52:domain03><54:domain05><56:domain07><58:domain09><1002:dynip><1004:dyndns><1006:secdns><1008:inactm><1010:vjcmpr><1012:svcnam> netPrefFieldTypeStr

Definition at line 460 of file NetPrefLibFieldInfoTable.h.

<4:bind><6:gtwytyp><8:apn><10:mip><12:ha2><14:1xtnl><16:aaasp><18:protect><20:pdpchg><22:crdata><24:1xrttqos><26:nai><28:vjslots><30:HttpSv><32:HttpsSv><34:HttpS2><36:HttpsS2><38:ExclHst><40:Pass2><42:HomePg><44:UrlUa><46:MSIfmt><48:ReqStat><50:domain01><52:domain03><54:domain05><56:domain07><58:domain09><1002:dynip><1004:dyndns><1006:secdns><1008:inactm><1010:vjcmpr> netPrefFieldTypeStr

Definition at line 449 of file NetPrefLibFieldInfoTable.h.

<4:bind><6:gtwytyp><8:apn><10:mip><12:ha2><14:1xtnl><16:aaasp><18:protect><20:pdpchg><22:crdata><24:1xrttqos><26:nai><28:vjslots><30:HttpSv><32:HttpsSv><34:HttpS2><36:HttpsS2><38:ExclHst><40:Pass2><42:HomePg><44:UrlUa><46:MSIfmt><48:ReqStat><50:domain01><52:domain03><54:domain05><56:domain07> netPrefFieldTypeStr

Definition at line 364 of file NetPrefLibFieldInfoTable.h.

<4:bind><6:gtwytyp><8:apn><10:mip><12:ha2><14:1xtnl><16:aaasp><18:protect><20:pdpchg><22:crdata><24:1xrttqos><26:nai><28:vjslots><30:HttpSv><32:HttpsSv><34:HttpS2><36:HttpsS2><38:ExclHst><40:Pass2><42:HomePg><44:UrlUa><46:MSIfmt><48:ReqStat><50:domain01><52:domain03><54:domain05> netPrefFieldTypeStr

Definition at line 354 of file NetPrefLibFieldInfoTable.h.

<4:bind><6:gtwytyp><8:apn><10:mip><12:ha2><14:1xtnl><16:aaasp><18:protect><20:pdpchg><22:crdata><24:1xrttqos><26:nai><28:vjslots><30:HttpSv><32:HttpsSv><34:HttpS2><36:HttpsS2><38:ExclHst><40:Pass2><42:HomePg><44:UrlUa><46:MSIfmt><48:ReqStat><50:domain01><52:domain03> netPrefFieldTypeStr

Definition at line 344 of file NetPrefLibFieldInfoTable.h.

<4:bind><6:gtwytyp><8:apn><10:mip><12:ha2><14:1xtnl><16:aaasp><18:protect><20:pdpchg><22:crdata><24:1xrttqos><26:nai><28:vjslots><30:HttpSv><32:HttpsSv><34:HttpS2><36:HttpsS2><38:ExclHst><40:Pass2><42:HomePg><44:UrlUa><46:MSIfmt><48:ReqStat><50:domain01> netPrefFieldTypeStr

Definition at line 334 of file NetPrefLibFieldInfoTable.h.

<4:bind><6:gtwytyp><8:apn><10:mip><12:ha2><14:1xtnl><16:aaasp><18:protect><20:pdpchg><22:crdata><24:1xrttqos><26:nai><28:vjslots><30:HttpSv><32:HttpsSv><34:HttpS2><36:HttpsS2><38:ExclHst><40:Pass2><42:HomePg><44:UrlUa><46:MSIfmt><48:ReqStat> netPrefFieldTypeStr

Definition at line 324 of file NetPrefLibFieldInfoTable.h.

<4:bind><6:gtwytyp><8:apn><10:mip><12:ha2><14:1xtnl><16:aaasp><18:protect><20:pdpchg><22:crdata><24:1xrttqos><26:nai><28:vjslots><30:HttpSv><32:HttpsSv><34:HttpS2><36:HttpsS2><38:ExclHst><40:Pass2><42:HomePg><44:UrlUa> netPrefFieldTypeStr

Definition at line 310 of file NetPrefLibFieldInfoTable.h.

<4:bind><6:gtwytyp><8:apn><10:mip><12:ha2><14:1xtnl><16:aaasp><18:protect><20:pdpchg><22:crdata><24:1xrttqos><26:nai><28:vjslots><30:HttpSv><32:HttpsSv><34:HttpS2><36:HttpsS2><38:ExclHst><40:Pass2><42:HomePg> netPrefFieldTypeStr

Definition at line 304 of file NetPrefLibFieldInfoTable.h.

<4:bind><6:gtwytyp><8:apn><10:mip><12:ha2><14:1xtnl><16:aaasp><18:protect><20:pdpchg><22:crdata><24:1xrttqos><26:nai><28:vjslots><30:HttpSv><32:HttpsSv><34:HttpS2><36:HttpsS2><38:ExclHst><40:Pass2> netPrefFieldTypeStr

Definition at line 298 of file NetPrefLibFieldInfoTable.h.

<4:bind><6:gtwytyp><8:apn><10:mip><12:ha2><14:1xtnl><16:aaasp><18:protect><20:pdpchg><22:crdata><24:1xrttqos><26:nai><28:vjslots><30:HttpSv><32:HttpsSv><34:HttpS2><36:HttpsS2><38:ExclHst> netPrefFieldTypeStr

Definition at line 292 of file NetPrefLibFieldInfoTable.h.

<4:bind><6:gtwytyp><8:apn><10:mip><12:ha2><14:1xtnl><16:aaasp><18:protect><20:pdpchg><22:crdata><24:1xrttqos><26:nai><28:vjslots><30:HttpSv><32:HttpsSv><34:HttpS2><36:HttpsS2> netPrefFieldTypeStr

Definition at line 286 of file NetPrefLibFieldInfoTable.h.

<4:bind><6:gtwytyp><8:apn><10:mip><12:ha2><14:1xtnl><16:aaasp><18:protect><20:pdpchg><22:crdata><24:1xrttqos><26:nai><28:vjslots><30:HttpSv><32:HttpsSv><34:HttpS2> netPrefFieldTypeStr

Definition at line 280 of file NetPrefLibFieldInfoTable.h.

<4:bind><6:gtwytyp><8:apn><10:mip><12:ha2><14:1xtnl><16:aaasp><18:protect><20:pdpchg><22:crdata><24:1xrttqos><26:nai><28:vjslots><30:HttpSv><32:HttpsSv> netPrefFieldTypeStr

Definition at line 274 of file NetPrefLibFieldInfoTable.h.

<4:bind><6:gtwytyp><8:apn><10:mip><12:ha2><14:1xtnl><16:aaasp><18:protect><20:pdpchg><22:crdata><24:1xrttqos><26:nai><28:vjslots><30:HttpSv> netPrefFieldTypeStr

Definition at line 268 of file NetPrefLibFieldInfoTable.h.

<4:bind><6:gtwytyp><8:apn><10:mip><12:ha2><14:1xtnl><16:aaasp><18:protect><20:pdpchg><22:crdata><24:1xrttqos><26:nai><28:vjslots> netPrefFieldTypeStr

Definition at line 262 of file NetPrefLibFieldInfoTable.h.

<4:bind><6:gtwytyp><8:apn><10:mip><12:ha2><14:1xtnl><16:aaasp><18:protect><20:pdpchg><22:crdata><24:1xrttqos> netPrefFieldTypeStr

Definition at line 222 of file NetPrefLibFieldInfoTable.h.

<4:bind><6:gtwytyp> netPrefFieldTypeStr

Definition at line 127 of file NetPrefLibFieldInfoTable.h.

<4:bind><6:gtwytyp><8:apn><10:mip><12:ha2><14:1xtnl><16:aaasp><18:protect><20:pdpchg><22:crdata><24:1xrttqos><26:nai><28:vjslots><30:HttpSv><32:HttpsSv><34:HttpS2><36:HttpsS2><38:ExclHst><40:Pass2><42:HomePg><44:UrlUa><46:MSIfmt><48:ReqStat><50:domain01><52:domain03><54:domain05><56:domain07><58:domain09><1002:dynip><1004:dyndns><1006:secdns> netPrefFieldTypeUInt16

Definition at line 429 of file NetPrefLibFieldInfoTable.h.

<4:bind><6:gtwytyp><8:apn><10:mip><12:ha2> netPrefFieldTypeUInt16

Definition at line 155 of file NetPrefLibFieldInfoTable.h.

netPrefFieldTypeUInt16

Definition at line 101 of file NetPrefLibFieldInfoTable.h.

<4:bind><6:gtwytyp><8:apn><10:mip><12:ha2><14:1xtnl><16:aaasp><18:protect><20:pdpchg><22:crdata><24:1xrttqos><26:nai><28:vjslots><30:HttpSv><32:HttpsSv><34:HttpS2><36:HttpsS2><38:ExclHst><40:Pass2><42:HomePg><44:UrlUa><46:MSIfmt><48:ReqStat><50:domain01><52:domain03><54:domain05><56:domain07><58:domain09><1002:dynip><1004:dyndns> netPrefFieldTypeUInt32

Definition at line 410 of file NetPrefLibFieldInfoTable.h.

<4:bind><6:gtwytyp><8:apn><10:mip><12:ha2><14:1xtnl><16:aaasp> netPrefFieldTypeUInt32

Definition at line 175 of file NetPrefLibFieldInfoTable.h.

<4:bind><6:gtwytyp><8:apn><10:mip><12:ha2><14:1xtnl> netPrefFieldTypeUInt32

Definition at line 163 of file NetPrefLibFieldInfoTable.h.

<4:bind><6:gtwytyp><8:apn><10:mip> netPrefFieldTypeUInt32

Definition at line 147 of file NetPrefLibFieldInfoTable.h.

<4:bind> netPrefFieldTypeUInt32

Definition at line 116 of file NetPrefLibFieldInfoTable.h.

netPrefFieldTypeUInt32

Definition at line 87 of file NetPrefLibFieldInfoTable.h.

<4:bind><6:gtwytyp><8:apn><10:mip><12:ha2><14:1xtnl><16:aaasp><18:protect><20:pdpchg><22:crdata><24:1xrttqos><26:nai><28:vjslots><30:HttpSv><32:HttpsSv><34:HttpS2><36:HttpsS2><38:ExclHst><40:Pass2><42:HomePg><44:UrlUa><46:MSIfmt><48:ReqStat><50:domain01><52:domain03><54:domain05><56:domain07><58:domain09><1002:dynip><1004:dyndns><1006:secdns><1008:inactm><1010:vjcmpr><1012:svcnam><1014:usrpsw><1016:hosttab><1018:pophst><1020:script><1022:enprefx> netPrefFieldTypeUInt8

Definition at line 522 of file NetPrefLibFieldInfoTable.h.

<4:bind><6:gtwytyp><8:apn><10:mip><12:ha2><14:1xtnl><16:aaasp><18:protect><20:pdpchg><22:crdata><24:1xrttqos><26:nai><28:vjslots><30:HttpSv><32:HttpsSv><34:HttpS2><36:HttpsS2><38:ExclHst><40:Pass2><42:HomePg><44:UrlUa><46:MSIfmt><48:ReqStat><50:domain01><52:domain03><54:domain05><56:domain07><58:domain09><1002:dynip><1004:dyndns><1006:secdns><1008:inactm><1010:vjcmpr><1012:svcnam><1014:usrpsw><1016:hosttab><1018:pophst><1020:script> netPrefFieldTypeUInt8

Definition at line 510 of file NetPrefLibFieldInfoTable.h.

<4:bind><6:gtwytyp><8:apn><10:mip><12:ha2><14:1xtnl><16:aaasp><18:protect><20:pdpchg><22:crdata><24:1xrttqos><26:nai><28:vjslots><30:HttpSv><32:HttpsSv><34:HttpS2><36:HttpsS2><38:ExclHst><40:Pass2><42:HomePg><44:UrlUa><46:MSIfmt><48:ReqStat><50:domain01><52:domain03><54:domain05><56:domain07><58:domain09><1002:dynip><1004:dyndns><1006:secdns><1008:inactm> netPrefFieldTypeUInt8

Definition at line 441 of file NetPrefLibFieldInfoTable.h.

<4:bind><6:gtwytyp><8:apn><10:mip><12:ha2><14:1xtnl><16:aaasp><18:protect><20:pdpchg><22:crdata><24:1xrttqos><26:nai><28:vjslots><30:HttpSv><32:HttpsSv><34:HttpS2><36:HttpsS2><38:ExclHst><40:Pass2><42:HomePg><44:UrlUa><46:MSIfmt><48:ReqStat><50:domain01><52:domain03><54:domain05><56:domain07><58:domain09><1002:dynip> netPrefFieldTypeUInt8

Definition at line 402 of file NetPrefLibFieldInfoTable.h.

<4:bind><6:gtwytyp><8:apn><10:mip><12:ha2><14:1xtnl><16:aaasp><18:protect><20:pdpchg><22:crdata><24:1xrttqos><26:nai><28:vjslots><30:HttpSv><32:HttpsSv><34:HttpS2><36:HttpsS2><38:ExclHst><40:Pass2><42:HomePg><44:UrlUa><46:MSIfmt><48:ReqStat><50:domain01><52:domain03><54:domain05><56:domain07><58:domain09> netPrefFieldTypeUInt8

Definition at line 394 of file NetPrefLibFieldInfoTable.h.

<4:bind><6:gtwytyp><8:apn><10:mip><12:ha2><14:1xtnl><16:aaasp><18:protect><20:pdpchg><22:crdata><24:1xrttqos><26:nai><28:vjslots><30:HttpSv><32:HttpsSv><34:HttpS2><36:HttpsS2><38:ExclHst><40:Pass2><42:HomePg><44:UrlUa><46:MSIfmt> netPrefFieldTypeUInt8

Definition at line 316 of file NetPrefLibFieldInfoTable.h.

<4:bind><6:gtwytyp><8:apn><10:mip><12:ha2><14:1xtnl><16:aaasp><18:protect><20:pdpchg><22:crdata><24:1xrttqos><26:nai> netPrefFieldTypeUInt8

Definition at line 248 of file NetPrefLibFieldInfoTable.h.

<4:bind><6:gtwytyp><8:apn> netPrefFieldTypeUInt8

Definition at line 139 of file NetPrefLibFieldInfoTable.h.

<4:bind><6:gtwytyp><8:apn><10:mip><12:ha2><14:1xtnl><16:aaasp><18:protect><20:pdpchg><22:crdata><24:1xrttqos><26:nai><28:vjslots><30:HttpSv><32:HttpsSv><34:HttpS2><36:HttpsS2><38:ExclHst><40:Pass2><42:HomePg><44:UrlUa><46:MSIfmt><48:ReqStat><50:domain01><52:domain03><54:domain05><56:domain07><58:domain09><1002:dynip><1004:dyndns><1006:secdns><1008:inactm><1010:vjcmpr><1012:svcnam><1014:usrpsw><1016:hosttab><1018:pophst> netPrefFieldTypeZStrList

Definition at line 496 of file NetPrefLibFieldInfoTable.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:07:39 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » netpref

NetPrefLibrary.h File Reference

Detailed Description

This is the main header file for the NetPref Library.

Version:
1.0
Date:
06/24/2002
USAGE MODEL: The model for using the NetPref library is that you "link" it in when needed and "unlink" it as you're done -- i.e. we don't leave it permanently installed as we do with some other libraries. This helps us avoid some unpleasant HotSync issues (such as trying to install over a protected database). For examples of linking and unlinking, grep for calls to NetPrefUtilNetPrefLibLink and NetPrefUtilNetPrefLibUnlink in NetworkPanel.c (Network panel src folder). NetPrefUtilNetPrefLibLink and NetPrefUtilNetPrefLibUnlink are defined in Viewer\Libraries\NetPref\Public\Util\NetPrefUtils.c/h -- you may include the .c file with your code, or just copy and paste out of those functions.

Definition in file NetPrefLibrary.h.

Include dependency graph for NetPrefLibrary.h:

Go to the source code of this file.

Defines

  • #define NETPREF_LIB_TRAP(trapNum) SYS_TRAP(trapNum)
  • #define NetPrefUtilLoginScriptLen(refNum, cxtP, scriptP)

Functions

  • Err NetPrefLibOpen (UInt16 refNum, struct NetPrefContextTypeTag **cxtPP)
  • Err NetPrefLibClose (UInt16 refNum, struct NetPrefContextTypeTag *cxtP)
  • Err NetPrefLibSleep (UInt16 refNum)
  • Err NetPrefLibWake (UInt16 refNum)
  • Err NetPrefLibVersionGet (UInt16 refNum, UInt32 *majorVerP, UInt32 *minorVerP, UInt32 *bugFixVerP)
  • Err NetPrefRecCountGet (UInt16 refNum, struct NetPrefContextTypeTag *cxtP, UInt16 *countP)
  • Err NetPrefRecIDGetByIndex (UInt16 refNum, struct NetPrefContextTypeTag *cxtP, UInt16 recIndex, UInt32 *recIDP)
  • Err NetPrefRecIndexGetByID (UInt16 refNum, struct NetPrefContextTypeTag *cxtP, UInt32 recID, UInt16 *recIndexP)
  • Err NetPrefRecNew (UInt16 refNum, struct NetPrefContextTypeTag *cxtP, UInt32 dupRecID, struct NetPrefRecordTypeTag **recPP)
  • Err NetPrefRecLoad (UInt16 refNum, struct NetPrefContextTypeTag *cxtP, UInt32 recID, struct NetPrefRecordTypeTag **recPP)
  • Err NetPrefRecBindingErrorGet (UInt16 refNum, struct NetPrefContextTypeTag *cxtP, struct NetPrefRecordTypeTag *recP)
  • Err NetPrefRecRelease (UInt16 refNum, struct NetPrefContextTypeTag *cxtP, struct NetPrefRecordTypeTag **recPP)
  • Err NetPrefRecSave (UInt16 refNum, struct NetPrefContextTypeTag *cxtP, struct NetPrefRecordTypeTag *recP)
  • Boolean NetPrefRecIsAttached (UInt16 refNum, struct NetPrefContextTypeTag *cxtP, struct NetPrefRecordTypeTag *recP)
  • Err NetPrefRecObjAlloc (UInt16 refNum, struct NetPrefContextTypeTag *cxtP, struct NetPrefRecordTypeTag **recPP)
  • Err NetPrefRecObjCopy (UInt16 refNum, struct NetPrefContextTypeTag *cxtP, struct NetPrefRecordTypeTag *srcRecP, struct NetPrefRecordTypeTag *dstRecP)
  • Err NetPrefRecIDGet (UInt16 refNum, struct NetPrefContextTypeTag *cxtP, struct NetPrefRecordTypeTag *recP, UInt32 *recIDP)
  • Err NetPrefRecIndexGet (UInt16 refNum, struct NetPrefContextTypeTag *cxtP, struct NetPrefRecordTypeTag *recP, UInt16 *recIndexP)
  • Err NetPrefRecDelete (UInt16 refNum, struct NetPrefContextTypeTag *cxtP, UInt32 recID)
  • Err NetPrefRecFieldGet (UInt16 refNum, struct NetPrefContextTypeTag *cxtP, struct NetPrefRecordTypeTag *recP, NetPrefRecFieldEnum recFieldID, void **fieldValuePP, UInt32 *fieldLenP, NetPrefRecFieldViewType *viewFlagsP)
  • Err NetPrefRecFieldAttrsGet (UInt16 refNum, struct NetPrefContextTypeTag *cxtP, struct NetPrefRecordTypeTag *recP, NetPrefRecFieldEnum recFieldID, NetPrefRecFieldAttrType *fieldAttrsP)
  • Err NetPrefRecFieldSet (UInt16 refNum, struct NetPrefContextTypeTag *cxtP, struct NetPrefRecordTypeTag *recP, NetPrefRecFieldEnum recFieldID, void *fieldValueP, UInt32 fieldLen)
  • Err NetPrefRecFieldViewSet (UInt16 refNum, struct NetPrefContextTypeTag *cxtP, struct NetPrefRecordTypeTag *recP, NetPrefRecFieldEnum recFieldID, NetPrefRecFieldViewType flagsToClear, NetPrefRecFieldViewType flagsToSet)
  • void NetPrefRecReadOnlyOverrideStart (UInt16 refNum, struct NetPrefContextTypeTag *cxtP, struct NetPrefRecordTypeTag *recP)
  • void NetPrefRecReadOnlyOverrideEnd (UInt16 refNum, struct NetPrefContextTypeTag *cxtP, struct NetPrefRecordTypeTag *recP)
  • Err NetPrefRecFieldSetDefine (UInt16 refNum, struct NetPrefContextTypeTag *cxtP, struct NetPrefRecordTypeTag *recP, NetPrefRecFieldEnum *recFieldIDArrayP, UInt16 newNumFields, NetPrefRecFieldViewType *initialViewFlagsP, NetPrefFieldSetDefineOptionsType options)
  • Err NetPrefRecFieldAddToSet (UInt16 refNum, struct NetPrefContextTypeTag *cxtP, struct NetPrefRecordTypeTag *recP, NetPrefRecFieldEnum recFieldID, NetPrefRecFieldViewType *initialViewFlagsP)
  • Err NetPrefRecFieldSetDefineStd (UInt16 refNum, struct NetPrefContextTypeTag *cxtP, struct NetPrefRecordTypeTag *recP, NetPrefSvcMediumEnum svcMedium, NetPrefRecFieldViewType *initialViewFlagsP, NetPrefFieldSetDefineOptionsType options)
  • Err NetPrefRecFieldSetGet (UInt16 refNum, struct NetPrefContextTypeTag *cxtP, struct NetPrefRecordTypeTag *recP, NetPrefRecFieldEnum *recFieldIDArrayP, UInt16 numEntriesAvailable, UInt16 *numFieldsInSetP)
  • Err NetPrefRecIsDirty (UInt16 refNum, struct NetPrefContextTypeTag *cxtP, struct NetPrefRecordTypeTag *recP, UInt8 *isDirtyP)
  • void NetPrefRecDirtyFlagsReset (UInt16 refNum, struct NetPrefContextTypeTag *cxtP, struct NetPrefRecordTypeTag *recP)
  • void NetPrefRecMarkDirty (UInt16 refNum, struct NetPrefContextTypeTag *cxtP, struct NetPrefRecordTypeTag *recP)
  • Err NetPrefDefaultTargetGet (UInt16 refNum, struct NetPrefContextTypeTag *cxtP, NetPrefSvcTargetEnum svcTarget, UInt32 *recIDP)
  • Err NetPrefDefaultTargetSet (UInt16 refNum, struct NetPrefContextTypeTag *cxtP, NetPrefSvcTargetEnum svcTarget, UInt32 recID)
  • Err NetPrefUpdateFromRadioNV (UInt16 refNum, struct NetPrefContextTypeTag *cxtP, Boolean force)
  • Err NetPrefHandleHotSyncNotify (UInt16 refNum, struct NetPrefContextTypeTag *cxtP, UInt16 cmd, void *cmdPBP)
  • Boolean NetPrefRecLongFieldGet (UInt16 refNum, struct NetPrefContextTypeTag *cxtP, struct NetPrefRecordTypeTag *recP, NetPrefRecFieldEnum recFieldID, UInt32 *resultP, NetPrefRecFieldViewType *viewFlagsP)
  • Boolean NetPrefRecShortFieldGet (UInt16 refNum, struct NetPrefContextTypeTag *cxtP, struct NetPrefRecordTypeTag *recP, NetPrefRecFieldEnum recFieldID, UInt16 *resultP, NetPrefRecFieldViewType *viewFlagsP)
  • Boolean NetPrefRecByteFieldGet (UInt16 refNum, struct NetPrefContextTypeTag *cxtP, struct NetPrefRecordTypeTag *recP, NetPrefRecFieldEnum recFieldID, UInt8 *resultP, NetPrefRecFieldViewType *viewFlagsP)
  • NetPrefRecFieldViewType NetPrefRecFieldViewGet (UInt16 refNum, struct NetPrefContextTypeTag *cxtP, struct NetPrefRecordTypeTag *recP, NetPrefRecFieldEnum recFieldID)
  • Err NetPrefRecLongFieldSetAsFlags (UInt16 refNum, struct NetPrefContextTypeTag *cxtP, struct NetPrefRecordTypeTag *recP, NetPrefRecFieldEnum recFieldID, UInt32 flagsToClear, UInt32 flagsToSet)
  • Err NetPrefRecFieldSetFromBinHandle (UInt16 refNum, struct NetPrefContextTypeTag *cxtP, struct NetPrefRecordTypeTag *recP, NetPrefRecFieldEnum recFieldID, MemHandle dataH)
  • Err NetPrefRecFieldSetFromStrHandle (UInt16 refNum, struct NetPrefContextTypeTag *cxtP, struct NetPrefRecordTypeTag *recP, NetPrefRecFieldEnum recFieldID, MemHandle dataH)
  • Err NetPrefRecFieldSetFromStrPtr (UInt16 refNum, struct NetPrefContextTypeTag *cxtP, struct NetPrefRecordTypeTag *recP, NetPrefRecFieldEnum recFieldID, char *strP)
  • Boolean NetPrefRecConnectionInfoGet (UInt16 refNum, struct NetPrefContextTypeTag *cxtP, struct NetPrefRecordTypeTag *recP, UInt32 *portCreatorIDP, Boolean *isModemP)
  • NetPrefSvcMediumEnum NetPrefRecMediumDerive (UInt16 refNum, struct NetPrefContextTypeTag *cxtP, struct NetPrefRecordTypeTag *recP, UInt32 defWirelessDriverID)
  • Err NetPrefRecIPAddrFieldSet (UInt16 refNum, struct NetPrefContextTypeTag *cxtP, struct NetPrefRecordTypeTag *recP, NetPrefRecFieldEnum recFieldID, UInt32 ipAddr)
  • UInt32 NetPrefUtilZStringListSizeGet (UInt16 refNum, struct NetPrefContextTypeTag *cxtP, char *zStrListP)
  • void NetPrefRecPhoneStringCompose (UInt16 refNum, struct NetPrefContextTypeTag *cxtP, struct NetPrefRecordTypeTag *recP, Char *destP, UInt16 maxLen)
  • NetPrefPlatformEnum NetPrefUtilPlatformIDGet (UInt16 refNum, struct NetPrefContextTypeTag *cxtP)
  • UInt32 NetPrefUtilDefWirelessDriverIDGet (UInt16 refNum, struct NetPrefContextTypeTag *cxtP, NetPrefPlatformEnum platform)

Define Documentation

#define NETPREF_LIB_TRAP ( trapNum ) SYS_TRAP(trapNum)

Definition at line 55 of file NetPrefLibrary.h.

#define NetPrefUtilLoginScriptLen | ( | refNum,
 |  | cxtP,
 |  | scriptP | )

Value:

NetPrefUtilZStringListSizeGet ((refNum), (cxtP), \
                                               (scriptP))

Definition at line 828 of file NetPrefLibrary.h.

Function Documentation

Err NetPrefDefaultTargetGet | ( | UInt16 | refNum,
 |  | struct NetPrefContextTypeTag * | cxtP,
 |  | NetPrefSvcTargetEnum | svcTarget,
 |  | UInt32 * | recIDP
 | ) |  |

Get the default service ID for the given target

Err NetPrefDefaultTargetSet | ( | UInt16 | refNum,
 |  | struct NetPrefContextTypeTag * | cxtP,
 |  | NetPrefSvcTargetEnum | svcTarget,
 |  | UInt32 | recID
 | ) |  |

Set the given service as the default service for the given target type; Set recID to 0 (zero) to clear the default for that target type. (WAP, Internet, all, etc.)

Err NetPrefHandleHotSyncNotify | ( | UInt16 | refNum,
 |  | struct NetPrefContextTypeTag * | cxtP,
 |  | UInt16 | cmd,
 |  | void * | cmdPBP
 | ) |  |

Called by the Network prefs. panel when it receives the sysAppLaunchCmdSyncNotify action code from HotSync or IR stack. This happens whenever the network preferences database NetworkDB or the Network panel are HotSynced or IR-beamed to the device.

NOTE: this may be called from a background task with a rather small runtime stack (as in the case of HotSync).

Err NetPrefLibClose | ( | UInt16 | refNum,
 |  | struct NetPrefContextTypeTag * | cxtP
 | ) |  |

Standard library close routine.

Parameters:
refnum,: IN: Library reference number
Return values:
Err Library error code

Err NetPrefLibOpen | ( | UInt16 | refNum,
 |  | struct NetPrefContextTypeTag ** | cxtPP
 | ) |  |

Standard library open routine.

Parameters:
refnum,: IN: Library reference number
Return values:
Err Library error code

Err NetPrefLibSleep ( UInt16 refNum )

Standard library sleep routine.

Parameters:
refnum,: IN: Library reference number
Return values:
Err Library error code

Err NetPrefLibVersionGet | ( | UInt16 | refNum,
 |  | UInt32 * | majorVerP,
 |  | UInt32 * | minorVerP,
 |  | UInt32 * | bugFixVerP
 | ) |  |

Get Library API Version number.

Parameters:
refnum,: IN: Library reference number
majorVerP,: OUT: Major version number
minorVerP,: OUT: Minor version number
bugFixVerP,: OUT: Bug fix version number
Return values:
Err NetPref Library error code

Err NetPrefLibWake ( UInt16 refNum )

Standard library wake routine.

Parameters:
refnum,: IN: Library reference number
Return values:
Err Library error code

Err NetPrefRecBindingErrorGet | ( | UInt16 | refNum,
 |  | struct NetPrefContextTypeTag * | cxtP,
 |  | struct NetPrefRecordTypeTag * | recP
 | ) |  |

Call this to check if there was an error from application of a binding (such as CCSM) to the record.

Boolean NetPrefRecByteFieldGet | ( | UInt16 | refNum,
 |  | struct NetPrefContextTypeTag * | cxtP,
 |  | struct NetPrefRecordTypeTag * | recP,
 |  | NetPrefRecFieldEnum | recFieldID,
 |  | UInt8 * | resultP,
 |  | NetPrefRecFieldViewType * | viewFlagsP
 | ) |  |

Boolean NetPrefRecConnectionInfoGet | ( | UInt16 | refNum,
 |  | struct NetPrefContextTypeTag * | cxtP,
 |  | struct NetPrefRecordTypeTag * | recP,
 |  | UInt32 * | portCreatorIDP,
 |  | Boolean * | isModemP
 | ) |  |

Err NetPrefRecCountGet | ( | UInt16 | refNum,
 |  | struct NetPrefContextTypeTag * | cxtP,
 |  | UInt16 * | countP
 | ) |  |

Retrieve the count of records in the NetPref database

Err NetPrefRecDelete | ( | UInt16 | refNum,
 |  | struct NetPrefContextTypeTag * | cxtP,
 |  | UInt32 | recID
 | ) |  |

Delete the given record from the database; if the record is bound to another, such as that stored in non-volatile memory of the radio module, will delete the primary record as well. If the client has a memory object representing the record being deleted, the client is still responsible for releasing it via NetPrefRecRelease().

void NetPrefRecDirtyFlagsReset | ( | UInt16 | refNum,
 |  | struct NetPrefContextTypeTag * | cxtP,
 |  | struct NetPrefRecordTypeTag * | recP
 | ) |  |

Reset all of the record's "dirty" flags. NOTE: NetPrefRecSave will not save a record that is not marked as "dirty"

Err NetPrefRecFieldAddToSet | ( | UInt16 | refNum,
 |  | struct NetPrefContextTypeTag * | cxtP,
 |  | struct NetPrefRecordTypeTag * | recP,
 |  | NetPrefRecFieldEnum | recFieldID,
 |  | NetPrefRecFieldViewType * | initialViewFlagsP
 | ) |  |

Add a field to the Field-set of a given record and, optionally, set its view flags (set initialViewFlagsP to NULL to leave the field's view flags alone).

NOTE: If the field was already part of the record's field-set, the field's data will be preserved. However, the field's view flags will be overwritten with those supplied via initialViewFlagsP if initialViewFlagsP is not NULL.

Err NetPrefRecFieldAttrsGet | ( | UInt16 | refNum,
 |  | struct NetPrefContextTypeTag * | cxtP,
 |  | struct NetPrefRecordTypeTag * | recP,
 |  | NetPrefRecFieldEnum | recFieldID,
 |  | NetPrefRecFieldAttrType * | fieldAttrsP
 | ) |  |

Get the attributes of a field

Err NetPrefRecFieldGet | ( | UInt16 | refNum,
 |  | struct NetPrefContextTypeTag * | cxtP,
 |  | struct NetPrefRecordTypeTag * | recP,
 |  | NetPrefRecFieldEnum | recFieldID,
 |  | void ** | fieldValuePP,
 |  | UInt32 * | fieldLenP,
 |  | NetPrefRecFieldViewType * | viewFlagsP
 | ) |  |

Get a pointer to a given record field; upon successful return, the value of the field is to be interpreted as follows:

NULL -- field value is not assigned non-NULL -- field value has been assigned, the value must be treated as read-only! Field view depends on the Medium and Binding of the record

Err NetPrefRecFieldSet | ( | UInt16 | refNum,
 |  | struct NetPrefContextTypeTag * | cxtP,
 |  | struct NetPrefRecordTypeTag * | recP,
 |  | NetPrefRecFieldEnum | recFieldID,
 |  | void * | fieldValueP,
 |  | UInt32 | fieldLen
 | ) |  |

NetPrefRecFieldSet: Set the value of the field. The library will duplicate the value passed in fieldValueP. Set fieldValueP to NULL to delete the field's data. NOTE: setting a field invalidates any cached pointer that you may already have to the field's value.

NOTES: 1) Field must be in record's field-set before you can set its data or view flags.

2) String field values MUST be zero-terminated and the fieldLen MUST include the zero-terminator.

3) If a change results, the record object will be marked as dirty

Err NetPrefRecFieldSetDefine | ( | UInt16 | refNum,
 |  | struct NetPrefContextTypeTag * | cxtP,
 |  | struct NetPrefRecordTypeTag * | recP,
 |  | NetPrefRecFieldEnum * | recFieldIDArrayP,
 |  | UInt16 | newNumFields,
 |  | NetPrefRecFieldViewType * | initialViewFlagsP,
 |  | NetPrefFieldSetDefineOptionsType | options
 | ) |  |

Define the field set associated with the record; fields that are not in the new field will be removed from the record object. For fields in the new field set, existing data will be left alone.

You may pass a pointer to new NetPrefRecFieldViewType in initialViewFlagsP to set those view flags in all the fields in the new field set (or pass NULL to ignore this parameter and leave field view flags at their old values).

To remove all fields from the field set, set newNumFields to 0 and recFieldIDArrayP to NULL;

Err NetPrefRecFieldSetDefineStd | ( | UInt16 | refNum,
 |  | struct NetPrefContextTypeTag * | cxtP,
 |  | struct NetPrefRecordTypeTag * | recP,
 |  | NetPrefSvcMediumEnum | svcMedium,
 |  | NetPrefRecFieldViewType * | initialViewFlagsP,
 |  | NetPrefFieldSetDefineOptionsType | options
 | ) |  |

Define a "standard" field set based on Service Medium value -- basically, this is what the New Network Preference panel uses when it creates new services.

You may pass a pointer to new NetPrefRecFieldViewType in initialViewFlagsP to set the view flags of all the fields in the new field set (or pass NULL for default flags).

Err NetPrefRecFieldSetFromBinHandle | ( | UInt16 | refNum,
 |  | struct NetPrefContextTypeTag * | cxtP,
 |  | struct NetPrefRecordTypeTag * | recP,
 |  | NetPrefRecFieldEnum | recFieldID,
 |  | MemHandle | dataH
 | ) |  |

Err NetPrefRecFieldSetFromStrHandle | ( | UInt16 | refNum,
 |  | struct NetPrefContextTypeTag * | cxtP,
 |  | struct NetPrefRecordTypeTag * | recP,
 |  | NetPrefRecFieldEnum | recFieldID,
 |  | MemHandle | dataH
 | ) |  |

Err NetPrefRecFieldSetFromStrPtr | ( | UInt16 | refNum,
 |  | struct NetPrefContextTypeTag * | cxtP,
 |  | struct NetPrefRecordTypeTag * | recP,
 |  | NetPrefRecFieldEnum | recFieldID,
 |  | char * | strP
 | ) |  |

Err NetPrefRecFieldSetGet | ( | UInt16 | refNum,
 |  | struct NetPrefContextTypeTag * | cxtP,
 |  | struct NetPrefRecordTypeTag * | recP,
 |  | NetPrefRecFieldEnum * | recFieldIDArrayP,
 |  | UInt16 | numEntriesAvailable,
 |  | UInt16 * | numFieldsInSetP
 | ) |  |

Get the current field set of the record object. The array recFieldIDArrayP MUST have enough entries (numEntriesAvailable) to receive the field ID's of all fields in the field set. The actual count of fields in the field set is returned in *numFieldsInSetP. To simply get the count of fields in the field set, without returning the actual field ID's, set numEntriesAvailable to 0 and recFieldIDArrayP to NULL;

NetPrefRecFieldViewType NetPrefRecFieldViewGet | ( | UInt16 | refNum,
 |  | struct NetPrefContextTypeTag * | cxtP,
 |  | struct NetPrefRecordTypeTag * | recP,
 |  | NetPrefRecFieldEnum | recFieldID
 | ) |  |

Err NetPrefRecFieldViewSet | ( | UInt16 | refNum,
 |  | struct NetPrefContextTypeTag * | cxtP,
 |  | struct NetPrefRecordTypeTag * | recP,
 |  | NetPrefRecFieldEnum | recFieldID,
 |  | NetPrefRecFieldViewType | flagsToClear,
 |  | NetPrefRecFieldViewType | flagsToSet
 | ) |  |

Set the view flags of the field. If a change results, the record object will be marked as dirty.

NOTES: 1) Field must be in record's field-set before you can set its data or view flags.

2) If a change results, the record object will be marked as dirty

Err NetPrefRecIDGet | ( | UInt16 | refNum,
 |  | struct NetPrefContextTypeTag * | cxtP,
 |  | struct NetPrefRecordTypeTag * | recP,
 |  | UInt32 * | recIDP
 | ) |  |

Get the unique record ID of the record's entry in the database.

WARNING: It is an error to call NetPrefRecIDGet on records that have not been attached to the database -- see NetPrefRecIsAttached().

Err NetPrefRecIDGetByIndex | ( | UInt16 | refNum,
 |  | struct NetPrefContextTypeTag * | cxtP,
 |  | UInt16 | recIndex,
 |  | UInt32 * | recIDP
 | ) |  |

Get record ID given the 0-based record index, which must be in range of 0..NetPrefRecCountGet()-1. The record's index may change following the NetPrefRecSave opeation.

Err NetPrefRecIndexGet | ( | UInt16 | refNum,
 |  | struct NetPrefContextTypeTag * | cxtP,
 |  | struct NetPrefRecordTypeTag * | recP,
 |  | UInt16 * | recIndexP
 | ) |  |

Get the 0-based index of the record's entry in the database. The record's index may change following the NetPrefRecSave opeation.

WARNING: It is an error to call NetPrefRecIndexGet on records that have not been attached to the database -- see NetPrefRecIsAttached().

Err NetPrefRecIndexGetByID | ( | UInt16 | refNum,
 |  | struct NetPrefContextTypeTag * | cxtP,
 |  | UInt32 | recID,
 |  | UInt16 * | recIndexP
 | ) |  |

Get record index given the unique record ID, which must be non-zero. The record's index may change following the NetPrefRecSave opeation.

Err NetPrefRecIPAddrFieldSet | ( | UInt16 | refNum,
 |  | struct NetPrefContextTypeTag * | cxtP,
 |  | struct NetPrefRecordTypeTag * | recP,
 |  | NetPrefRecFieldEnum | recFieldID,
 |  | UInt32 | ipAddr
 | ) |  |

Boolean NetPrefRecIsAttached | ( | UInt16 | refNum,
 |  | struct NetPrefContextTypeTag * | cxtP,
 |  | struct NetPrefRecordTypeTag * | recP
 | ) |  |

Check if this record object is "attached" to the database. A record that has been created via NetPrefRecObjAlloc and never saved is not "attached" to the database.

Err NetPrefRecIsDirty | ( | UInt16 | refNum,
 |  | struct NetPrefContextTypeTag * | cxtP,
 |  | struct NetPrefRecordTypeTag * | recP,
 |  | UInt8 * | isDirtyP
 | ) |  |

Check if the record is dirty (has been modified by the client)

Err NetPrefRecLoad | ( | UInt16 | refNum,
 |  | struct NetPrefContextTypeTag * | cxtP,
 |  | UInt32 | recID,
 |  | struct NetPrefRecordTypeTag ** | recPP
 | ) |  |

Load an existing record into memory; the caller is responsible for calling NetPrefRecRelease() to dispose of the temporary resources associated with the loaded record.

Boolean NetPrefRecLongFieldGet | ( | UInt16 | refNum,
 |  | struct NetPrefContextTypeTag * | cxtP,
 |  | struct NetPrefRecordTypeTag * | recP,
 |  | NetPrefRecFieldEnum | recFieldID,
 |  | UInt32 * | resultP,
 |  | NetPrefRecFieldViewType * | viewFlagsP
 | ) |  |

Err NetPrefRecLongFieldSetAsFlags | ( | UInt16 | refNum,
 |  | struct NetPrefContextTypeTag * | cxtP,
 |  | struct NetPrefRecordTypeTag * | recP,
 |  | NetPrefRecFieldEnum | recFieldID,
 |  | UInt32 | flagsToClear,
 |  | UInt32 | flagsToSet
 | ) |  |

void NetPrefRecMarkDirty | ( | UInt16 | refNum,
 |  | struct NetPrefContextTypeTag * | cxtP,
 |  | struct NetPrefRecordTypeTag * | recP
 | ) |  |

Mark a record as "dirty" so it would be saved by NetPrefRecSave.

NetPrefSvcMediumEnum NetPrefRecMediumDerive | ( | UInt16 | refNum,
 |  | struct NetPrefContextTypeTag * | cxtP,
 |  | struct NetPrefRecordTypeTag * | recP,
 |  | UInt32 | defWirelessDriverID
 | ) |  |

Err NetPrefRecNew | ( | UInt16 | refNum,
 |  | struct NetPrefContextTypeTag * | cxtP,
 |  | UInt32 | dupRecID,
 |  | struct NetPrefRecordTypeTag ** | recPP
 | ) |  |

Create a new record object. Pass a non-zero dupRecID to duplicate an existing record. The caller is responsible for calling NetPrefRecRelease() to dispose of the temporary resources associated with the loaded record

Err NetPrefRecObjAlloc | ( | UInt16 | refNum,
 |  | struct NetPrefContextTypeTag * | cxtP,
 |  | struct NetPrefRecordTypeTag ** | recPP
 | ) |  |

Allocate a "blank slate" record object. This record will not be "attached" to the database until saved via NetPrefRecSave. Intended for use with NetPrefRecObjCopy, and by internal code.

Err NetPrefRecObjCopy | ( | UInt16 | refNum,
 |  | struct NetPrefContextTypeTag * | cxtP,
 |  | struct NetPrefRecordTypeTag * | srcRecP,
 |  | struct NetPrefRecordTypeTag * | dstRecP
 | ) |  |

Copy the contents of the source record object to the destination record object. This is useful for implementing revert functionality.

void NetPrefRecPhoneStringCompose | ( | UInt16 | refNum,
 |  | struct NetPrefContextTypeTag * | cxtP,
 |  | struct NetPrefRecordTypeTag * | recP,
 |  | Char * | destP,
 |  | UInt16 | maxLen
 | ) |  |

void NetPrefRecReadOnlyOverrideEnd | ( | UInt16 | refNum,
 |  | struct NetPrefContextTypeTag * | cxtP,
 |  | struct NetPrefRecordTypeTag * | recP
 | ) |  |

void NetPrefRecReadOnlyOverrideStart | ( | UInt16 | refNum,
 |  | struct NetPrefContextTypeTag * | cxtP,
 |  | struct NetPrefRecordTypeTag * | recP
 | ) |  |

NetPrefRecReadOnlyOverrideStart/End: Increment/decrement the record object's readOnlyOverrideCount variable. The two function calls must be balanced -- i.e., ...End must be called exactly as many times as ...Start regardless of other events, such as errors. If greater than zero, NetPrefRecFieldSet will allow the field to be set regardless of the record's read-only status. This permits internal record "loaders" to initialize record fields regardless of the read-only status of the fields being loaded.

Err NetPrefRecRelease | ( | UInt16 | refNum,
 |  | struct NetPrefContextTypeTag * | cxtP,
 |  | struct NetPrefRecordTypeTag ** | recPP
 | ) |  |

Dispose of the temporary resources associated with a record that was created or loaded via NetPrefRecNew or NetPrefRecLoad. It's the library client's (application's) responsibility to call this function to free up the memory. Resets *recPP to NULL.

Err NetPrefRecSave | ( | UInt16 | refNum,
 |  | struct NetPrefContextTypeTag * | cxtP,
 |  | struct NetPrefRecordTypeTag * | recP
 | ) |  |

Save the record to the database, moving it to a new sorted position if necessary. For existing records, if any fields have been changed, you must call NetPrefRecSave in order to get an accurate record index.

Boolean NetPrefRecShortFieldGet | ( | UInt16 | refNum,
 |  | struct NetPrefContextTypeTag * | cxtP,
 |  | struct NetPrefRecordTypeTag * | recP,
 |  | NetPrefRecFieldEnum | recFieldID,
 |  | UInt16 * | resultP,
 |  | NetPrefRecFieldViewType * | viewFlagsP
 | ) |  |

Err NetPrefUpdateFromRadioNV | ( | UInt16 | refNum,
 |  | struct NetPrefContextTypeTag * | cxtP,
 |  | Boolean | force
 | ) |  |

Update the NetPref database from the Non-Volatile storage of the radio, if any. This should be called by the IOTA application after provisioning, as well as when the wireless mode is turned on. This function is optimized to quickly determine if synchronization is necessary, and skip it if not. Set "force" to true to skip optimization and force synchronization.

UInt32 NetPrefUtilDefWirelessDriverIDGet | ( | UInt16 | refNum,
 |  | struct NetPrefContextTypeTag * | cxtP,
 |  | NetPrefPlatformEnum | platform
 | ) |  |

NetPrefPlatformEnum NetPrefUtilPlatformIDGet | ( | UInt16 | refNum,
 |  | struct NetPrefContextTypeTag * | cxtP
 | ) |  |

UInt32 NetPrefUtilZStringListSizeGet | ( | UInt16 | refNum,
 |  | struct NetPrefContextTypeTag * | cxtP,
 |  | char * | zStrListP
 | ) |  |

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:07:40 2008 for Palm API Guide


Header Files » Incs » common » libraries » netpref

NetPrefLibTarget.h File Reference

Detailed Description

This is the target parameters file for the NetPref Library.

Version:
1.0
Date:
12/12/2001
We break out these definitions so that other portable modules could access them without PalmOS-specific definishions

Definition in file NetPrefLibTarget.h.

Go to the source code of this file.

Defines

  • #define netPrefLibCreatorID 'HsNP'
  • #define netPrefLibTypeID 'libr'
  • #define netPrefLibName "HsNetPrefLibrary.lib"

Define Documentation

#define netPrefLibCreatorID 'HsNP'

NetPref Library database creator

Definition at line 33 of file NetPrefLibTarget.h.

#define netPrefLibName "HsNetPrefLibrary.lib"

Internal library name which can be passed to SysLibFind()

Definition at line 37 of file NetPrefLibTarget.h.

#define netPrefLibTypeID 'libr'

Standard library database type

Definition at line 35 of file NetPrefLibTarget.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:07:40 2008 for Palm API Guide


Header Files » Incs » common » libraries » netpref

NetPrefLibTraps.h File Reference

Detailed Description

Trap definitions for the NetPref Library.

Version:
1.0
Date:
12/12/2001

Definition in file NetPrefLibTraps.h.

Go to the source code of this file.

Defines

Trap IDs
Trap IDs for the NetPref Library's public functions.

The order of the traps must be the same as the routines are listed in NetPrefLibDispatchTable.c.

  • #define netPrefLibTrapVersionGet (sysLibTrapCustom + 0)
  • #define netPrefLibTrapRecCountGet (sysLibTrapCustom + 1)
  • #define netPrefLibTrapRecIDGetByIndex (sysLibTrapCustom + 2)
  • #define netPrefLibTrapRecNew (sysLibTrapCustom + 3)
  • #define netPrefLibTrapRecLoad (sysLibTrapCustom + 4)
  • #define netPrefLibTrapRecRelease (sysLibTrapCustom + 5)
  • #define netPrefLibTrapRecSave (sysLibTrapCustom + 6)
  • #define netPrefLibTrapRecIDGet (sysLibTrapCustom + 7)
  • #define netPrefLibTrapRecIndexGet (sysLibTrapCustom + 8)
  • #define netPrefLibTrapRecDelete (sysLibTrapCustom + 9)
  • #define netPrefLibTrapRecFieldGet (sysLibTrapCustom + 10)
  • #define netPrefLibTrapRecFieldSet (sysLibTrapCustom + 11)
  • #define netPrefLibTrapDefaultTargetGet (sysLibTrapCustom + 12)
  • #define netPrefLibTrapDefaultTargetSet (sysLibTrapCustom + 13)
  • #define netPrefLibTrapRecObjCopy (sysLibTrapCustom + 14)
  • #define netPrefLibTrapRecIsDirty (sysLibTrapCustom + 15)
  • #define netPrefLibTrapRecIndexGetByID (sysLibTrapCustom + 16)
  • #define netPrefLibTrapRecFieldViewSet (sysLibTrapCustom + 17)
  • #define netPrefLibTrapRecFieldAttrsGet (sysLibTrapCustom + 18)
  • #define netPrefLibTrapUpdateFromRadioNV (sysLibTrapCustom + 19)
  • #define netPrefLibTrapRecFieldSetDefine (sysLibTrapCustom + 20)
  • #define netPrefLibTrapRecFieldSetGet (sysLibTrapCustom + 21)
  • #define netPrefLibTrapRecFieldSetDefineStd (sysLibTrapCustom + 22)
  • #define netPrefLibTrapRecFieldAddToSet (sysLibTrapCustom + 23)
  • #define netPrefLibTrapRecReadOnlyOverrideStart (sysLibTrapCustom + 24)
  • #define netPrefLibTrapRecReadOnlyOverrideEnd (sysLibTrapCustom + 25)
  • #define netPrefLibTrapRecDirtyFlagsReset (sysLibTrapCustom + 26)
  • #define netPrefLibTrapRecMarkDirty (sysLibTrapCustom + 27)
  • #define netPrefLibTrapRecObjAlloc (sysLibTrapCustom + 28)
  • #define netPrefLibTrapRecIsAttached (sysLibTrapCustom + 29)
  • #define netPrefLibTrapRecBindingErrorGet (sysLibTrapCustom + 30)
  • #define netPrefLibTrapHandleHotSyncNotify (sysLibTrapCustom + 31)
  • #define netPrefLibTrapRecShortFieldGet (sysLibTrapCustom + 32)
  • #define netPrefLibTrapRecByteFieldGet (sysLibTrapCustom + 33)
  • #define netPrefLibTrapRecFieldViewGet (sysLibTrapCustom + 34)
  • #define netPrefLibTrapRecLongFieldSetAsFlags (sysLibTrapCustom + 35)
  • #define netPrefLibTrapRecFieldSetFromBinHandle (sysLibTrapCustom + 36)
  • #define netPrefLibTrapRecFieldSetFromStrHandle (sysLibTrapCustom + 37)
  • #define netPrefLibTrapRecFieldSetFromStrPtr (sysLibTrapCustom + 38)
  • #define netPrefLibTrapRecConnectionInfoGet (sysLibTrapCustom + 39)
  • #define netPrefLibTrapRecMediumDerive (sysLibTrapCustom + 40)
  • #define netPrefLibTrapRecIPAddrFieldSet (sysLibTrapCustom + 41)
  • #define netPrefLibTrapUtilZStringListSizeGet (sysLibTrapCustom + 42)
  • #define netPrefLibTrapRecPhoneStringCompose (sysLibTrapCustom + 43)
  • #define netPrefLibTrapUtilPlatformIDGet (sysLibTrapCustom + 44)
  • #define netPrefLibTrapUtilDefWirelessDriverIDGet (sysLibTrapCustom + 45)
  • #define netPrefLibTrapRecLongFieldGet (sysLibTrapCustom + 46)

Define Documentation

#define netPrefLibTrapDefaultTargetGet (sysLibTrapCustom + 12)

Definition at line 48 of file NetPrefLibTraps.h.

#define netPrefLibTrapDefaultTargetSet (sysLibTrapCustom + 13)

Definition at line 49 of file NetPrefLibTraps.h.

#define netPrefLibTrapHandleHotSyncNotify (sysLibTrapCustom + 31)

Definition at line 69 of file NetPrefLibTraps.h.

#define netPrefLibTrapRecBindingErrorGet (sysLibTrapCustom + 30)

Definition at line 68 of file NetPrefLibTraps.h.

#define netPrefLibTrapRecByteFieldGet (sysLibTrapCustom + 33)

Definition at line 72 of file NetPrefLibTraps.h.

#define netPrefLibTrapRecConnectionInfoGet (sysLibTrapCustom + 39)

Definition at line 78 of file NetPrefLibTraps.h.

#define netPrefLibTrapRecCountGet (sysLibTrapCustom + 1)

Definition at line 37 of file NetPrefLibTraps.h.

#define netPrefLibTrapRecDelete (sysLibTrapCustom + 9)

Definition at line 45 of file NetPrefLibTraps.h.

#define netPrefLibTrapRecDirtyFlagsReset (sysLibTrapCustom + 26)

Definition at line 64 of file NetPrefLibTraps.h.

#define netPrefLibTrapRecFieldAddToSet (sysLibTrapCustom + 23)

Definition at line 60 of file NetPrefLibTraps.h.

#define netPrefLibTrapRecFieldAttrsGet (sysLibTrapCustom + 18)

Definition at line 54 of file NetPrefLibTraps.h.

#define netPrefLibTrapRecFieldGet (sysLibTrapCustom + 10)

Definition at line 46 of file NetPrefLibTraps.h.

#define netPrefLibTrapRecFieldSet (sysLibTrapCustom + 11)

Definition at line 47 of file NetPrefLibTraps.h.

#define netPrefLibTrapRecFieldSetDefine (sysLibTrapCustom + 20)

Definition at line 57 of file NetPrefLibTraps.h.

#define netPrefLibTrapRecFieldSetDefineStd (sysLibTrapCustom + 22)

Definition at line 59 of file NetPrefLibTraps.h.

#define netPrefLibTrapRecFieldSetFromBinHandle (sysLibTrapCustom + 36)

Definition at line 75 of file NetPrefLibTraps.h.

#define netPrefLibTrapRecFieldSetFromStrHandle (sysLibTrapCustom + 37)

Definition at line 76 of file NetPrefLibTraps.h.

#define netPrefLibTrapRecFieldSetFromStrPtr (sysLibTrapCustom + 38)

Definition at line 77 of file NetPrefLibTraps.h.

#define netPrefLibTrapRecFieldSetGet (sysLibTrapCustom + 21)

Definition at line 58 of file NetPrefLibTraps.h.

#define netPrefLibTrapRecFieldViewGet (sysLibTrapCustom + 34)

Definition at line 73 of file NetPrefLibTraps.h.

#define netPrefLibTrapRecFieldViewSet (sysLibTrapCustom + 17)

Definition at line 53 of file NetPrefLibTraps.h.

#define netPrefLibTrapRecIDGet (sysLibTrapCustom + 7)

Definition at line 43 of file NetPrefLibTraps.h.

#define netPrefLibTrapRecIDGetByIndex (sysLibTrapCustom + 2)

Definition at line 38 of file NetPrefLibTraps.h.

#define netPrefLibTrapRecIndexGet (sysLibTrapCustom + 8)

Definition at line 44 of file NetPrefLibTraps.h.

#define netPrefLibTrapRecIndexGetByID (sysLibTrapCustom + 16)

Definition at line 52 of file NetPrefLibTraps.h.

#define netPrefLibTrapRecIPAddrFieldSet (sysLibTrapCustom + 41)

Definition at line 80 of file NetPrefLibTraps.h.

#define netPrefLibTrapRecIsAttached (sysLibTrapCustom + 29)

Definition at line 67 of file NetPrefLibTraps.h.

#define netPrefLibTrapRecIsDirty (sysLibTrapCustom + 15)

Definition at line 51 of file NetPrefLibTraps.h.

#define netPrefLibTrapRecLoad (sysLibTrapCustom + 4)

Definition at line 40 of file NetPrefLibTraps.h.

#define netPrefLibTrapRecLongFieldGet (sysLibTrapCustom + 46)

Definition at line 85 of file NetPrefLibTraps.h.

#define netPrefLibTrapRecLongFieldSetAsFlags (sysLibTrapCustom + 35)

Definition at line 74 of file NetPrefLibTraps.h.

#define netPrefLibTrapRecMarkDirty (sysLibTrapCustom + 27)

Definition at line 65 of file NetPrefLibTraps.h.

#define netPrefLibTrapRecMediumDerive (sysLibTrapCustom + 40)

Definition at line 79 of file NetPrefLibTraps.h.

#define netPrefLibTrapRecNew (sysLibTrapCustom + 3)

Definition at line 39 of file NetPrefLibTraps.h.

#define netPrefLibTrapRecObjAlloc (sysLibTrapCustom + 28)

Definition at line 66 of file NetPrefLibTraps.h.

#define netPrefLibTrapRecObjCopy (sysLibTrapCustom + 14)

Definition at line 50 of file NetPrefLibTraps.h.

#define netPrefLibTrapRecPhoneStringCompose (sysLibTrapCustom + 43)

Definition at line 82 of file NetPrefLibTraps.h.

#define netPrefLibTrapRecReadOnlyOverrideEnd (sysLibTrapCustom + 25)

Definition at line 63 of file NetPrefLibTraps.h.

#define netPrefLibTrapRecReadOnlyOverrideStart (sysLibTrapCustom + 24)

Definition at line 62 of file NetPrefLibTraps.h.

#define netPrefLibTrapRecRelease (sysLibTrapCustom + 5)

Definition at line 41 of file NetPrefLibTraps.h.

#define netPrefLibTrapRecSave (sysLibTrapCustom + 6)

Definition at line 42 of file NetPrefLibTraps.h.

#define netPrefLibTrapRecShortFieldGet (sysLibTrapCustom + 32)

Definition at line 71 of file NetPrefLibTraps.h.

#define netPrefLibTrapUpdateFromRadioNV (sysLibTrapCustom + 19)

Definition at line 55 of file NetPrefLibTraps.h.

#define netPrefLibTrapUtilDefWirelessDriverIDGet (sysLibTrapCustom + 45)

Definition at line 84 of file NetPrefLibTraps.h.

#define netPrefLibTrapUtilPlatformIDGet (sysLibTrapCustom + 44)

Definition at line 83 of file NetPrefLibTraps.h.

#define netPrefLibTrapUtilZStringListSizeGet (sysLibTrapCustom + 42)

Definition at line 81 of file NetPrefLibTraps.h.

#define netPrefLibTrapVersionGet (sysLibTrapCustom + 0)

Definition at line 36 of file NetPrefLibTraps.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:07:40 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » netpref

NetPrefLibTypes.h File Reference

Detailed Description

This file contains public data types exported by the NetPref Library.

Version:
1.0
Date:
12/12/2001

Definition in file NetPrefLibTypes.h.

Include dependency graph for NetPrefLibTypes.h:

Go to the source code of this file.

Data Structures

  • struct NetPrefGPRSQOSType
    NetPrefGPRSQOSType -- GPRS Quality Of Service (QOS) info. More...
  • struct NetPrefFallbackInfoType
    Fallback info structure. More...

Defines

  • #define netPref1xRTTTunnelingDefault netPref1xRTTTunnelingReverse
  • #define netPrefRecFieldViewCurrentlyValidFlags
  • #define netPrefRecFieldViewClearAll 0xFFFFFFFFUL
  • #define netPrefMaxPhoneStringSize 80
Current library API version number
Returned by NetPrefLibVersionGet()

  • #define netPrefLibVersionMajor 0
  • #define netPrefLibVersionMinor 2
  • #define netPrefLibVersionBugFix 0
Required Macros for Record Field Identifier
Define the required macros and then include NetPrefLibFieldInfoTable.h in order to define the record field indentifier values (see NetPrefLibFieldInfoTable.h for usage notes and currently defined fieldIDs)

  • #define NetPrefRecFieldInfoPreamble()
  • #define NetPrefRecFieldInfoFIRST(fieldID, idValue) fieldID = idValue,
  • #define NetPrefRecFieldInfoGrpStart(fieldID, idValue) fieldID = idValue,
  • #define NetPrefRecFieldInfoGrpEnd(fieldID) fieldID,
  • #define NetPrefRecFieldInfoExtended(fieldID, idValue, type, maxSize, flags, tagText, tagSize) fieldID = idValue,
  • #define NetPrefRecFieldInfoLegacy(fieldID, idValue, type, maxSize, flags, tagText, tagSize) fieldID = idValue,
  • #define NetPrefRecFieldInfoLAST(fieldID) fieldID
Record File View Attributes

  • #define netPrefRecFieldViewRead 0x00000001UL
  • #define netPrefRecFieldViewWrite 0x00000002UL
  • #define netPrefRecFieldViewVisible 0x00000004UL
  • #define netPrefRecFieldViewEditable 0x00000008UL
  • #define netPrefRecFieldViewExternal 0x00000010UL
  • #define netPrefRecFieldViewCache 0x00000020UL
  • #define netPrefRecFieldViewPrivate 0x00000040UL
Record File Attributes

  • #define netPrefRecFieldAttrInSet 0x10000000UL
  • #define netPrefRecFieldAttrDirty 0x20000000UL

Typedefs

  • typedef UInt16 NetPrefRecFieldEnum
  • typedef UInt32 NetPrefRecIDType
  • typedef UInt16 NetPrefFieldTypeEnum
  • typedef UInt16 NetPrefSvcMediumEnum
  • typedef UInt16 NetPrefSvcBindingEnum
  • typedef UInt16 NetPref1xRTTTunnelingEnum
  • typedef UInt16 NetPrefSvcTargetEnum
  • typedef UInt32 NetPrefRecFieldViewType
  • typedef UInt32 NetPrefRecFieldAttrType
  • typedef UInt32 NetPrefNetCloseWaitEnum
  • typedef UInt16 NetPrefNetIdleTimeoutEnum
  • typedef UInt32 NetPrefRecProtectionType
  • typedef UInt32 NetPrefSvcGatewayType
  • typedef UInt32 NetPrefFieldSetDefineOptionsType
  • typedef UInt8 NetPrefFallbackAlgrorithmEnum
  • typedef UInt8 NetPrefFallbackStatusFlagsType
  • typedef UInt16 NetPrefMutexStickyFBAStatusEnum
  • typedef UInt16 NetPrefPlatformEnum

Enumerations

  • enum
  • enum {
    netPrefFieldTypeStr = 1,
    netPrefFieldTypeUInt8 = 2,
    netPrefFieldTypeUInt16 = 3,
    netPrefFieldTypeUInt32 = 4,
    netPrefFieldTypeBin = 5,
    netPrefFieldTypeZStrList = 6
    }
  • enum {
    netPrefSvcMediumUnknown = 0,
    netPrefSvcMediumDialUp = 1,
    netPrefSvcMediumDirect = 2,
    netPrefSvcMedium1xRTT = 3,
    netPrefSvcMediumGPRS = 4,
    netPrefSvcMediumQNC = 5,
    netPrefSvcMediumGISDN = 6,
    netPrefSvcMediumGCSD = 7,
    netPrefSvcMediumCCSD = 8,
    netPrefSvcMediumOEM = 9,
    netPrefSvcMediumLAST
    }
  • enum {
    netPrefSvcBindingUnknown = 0,
    netPrefSvcBindingIOTA = 1,
    netPrefSvcBindingCCSM = 2,
    netPrefSvcBindingCustom = 3,
    netPrefSvcBindingLAST
    }
  • enum {
    netPref1xRTTTunnelingUnknown = 0,
    netPref1xRTTTunnelingReverse = 1,
    netPref1xRTTTunnelingForward = 2,
    netPref1xRTTTunnelingLAST
    }
  • enum {
    netPrefSvcTargetUnknown = 0,
    netPrefSvcTargetInternet = 1,
    netPrefSvcTargetWAP = 2,
    netPrefSvcTargetReserved1 = 3,
    netPrefSvcTargetMMS = 4,
    netPrefSvcTargetBrowser = 5,
    netPrefSvcTargetMail = 6,
    netPrefSvcTargetIM = 7,
    netPrefSvcTargetDownloads = 8,
    netPrefSvcTargetCorporate = 9,
    netPrefSvcTargetPictureMail = 10,
    netPrefSvcTargetLAST
    }
  • enum {
    netPrefNetCloseWaitEndOnPowerOff = 0xffffffffUL,
    netPrefNetCloseWaitMaintainSession = 0xfffffffeUL,
    netPrefNetCloseWaitCarrierDefault = 0xfffffffdUL
    }
  • enum { netPrefNetIdleTimeoutNever = (UInt16) 0 }
  • enum {
    netPrefRecProtectionDeletionMask = 0x00000007UL,
    netPrefRecProtectionDeletionAfterWarning = 0x0UL,
    netPrefRecProtectionDeletionNotAllowed = 0x1UL,
    netPrefRecProtectionDuplicationMask = (0x7UL << 3),
    netPrefRecProtectionDuplicationAllowed = (0x0UL << 3),
    netPrefRecProtectionDuplicationNotAllowed = (0x1UL << 3),
    netPrefRecProtectionEditingMask = (0x7UL << 6),
    netPrefRecProtectionEditingAllowed = (0x0UL << 6),
    netPrefRecProtectionEditingNotAllowed = (0x1UL << 6),
    netPrefRecProtectionEditingAfterWarning = (0x2UL << 6)
    }
  • enum {
    netPrefSvcGatewayUnknown = 0UL,
    netPrefSvcGatewayInternet = 0x00000001UL,
    netPrefSvcGatewayWAP = 0x00000002UL,
    netPrefSvcGatewayPrivate = 0x00000004UL,
    netPrefSvcGatewayMMS = 0x00000008UL,
    netPrefSvcGatewayBrowser = 0x00000010UL,
    netPrefSvcGatewayMail = 0x00000020UL,
    netPrefSvcGatewayIM = 0x00000040UL,
    netPrefSvcGatewayDownloads = 0x00000080UL,
    netPrefSvcGatewayCorporate = 0x00000100UL,
    netPrefSvcGatewayPictureMail = 0x00000200L,
    netPrefSvcGatewayLAST
    }
  • enum {
    netPrefFieldSetDefineOptionNone = 0,
    netPrefFieldSetDefineOptionKeepData = 0x00000001UL
    }
  • enum {
    netPrefFallbackAlgrorithmBasic = 0,
    netPrefFallbackAlgrorithmMutexSticky = 1,
    netPrefFallbackAlgrorithmLAST
    }
  • enum { netPrefFallbackStatusFlagInitialized = 0x01 }
  • enum {
    netPrefMutexStickyFBAStatusUnknown = 0,
    netPrefMutexStickyFBAStatusFailed = 1,
    netPrefMutexStickyFBAStatusSucceeded = 2
    }
  • enum {
    netPrefPlatformUnknown = 0,
    netPrefPlatformGSM = 1,
    netPrefPlatformCDMA = 2,
    netPrefPlatformLAST
    }

Define Documentation

#define netPref1xRTTTunnelingDefault netPref1xRTTTunnelingReverse

Default 1xRTT Tunneling value

Definition at line 157 of file NetPrefLibTypes.h.

#define netPrefLibVersionBugFix 0

Definition at line 33 of file NetPrefLibTypes.h.

#define netPrefLibVersionMajor 0

Definition at line 31 of file NetPrefLibTypes.h.

#define netPrefLibVersionMinor 2

Definition at line 32 of file NetPrefLibTypes.h.

#define netPrefMaxPhoneStringSize 80

Max size of a phone number, *not including* zero-terminator

Definition at line 492 of file NetPrefLibTypes.h.

#define netPrefRecFieldAttrDirty 0x20000000UL

R/O: set if the field's data or flags have been modified in the current instance of the record object

Definition at line 234 of file NetPrefLibTypes.h.

#define netPrefRecFieldAttrInSet 0x10000000UL

R/O: set if the field's data or flags are part of the record's field set.

Definition at line 228 of file NetPrefLibTypes.h.

#define NetPrefRecFieldInfoExtended | ( | fieldID,
 |  | idValue,
 |  | type,
 |  | maxSize,
 |  | flags,
 |  | tagText,
 |  | tagSize | ) | fieldID = idValue,

Definition at line 70 of file NetPrefLibTypes.h.

#define NetPrefRecFieldInfoFIRST | ( | fieldID,
 |  | idValue | ) | fieldID = idValue,

Definition at line 64 of file NetPrefLibTypes.h.

#define NetPrefRecFieldInfoGrpEnd ( fieldID ) fieldID,

Definition at line 68 of file NetPrefLibTypes.h.

#define NetPrefRecFieldInfoGrpStart | ( | fieldID,
 |  | idValue | ) | fieldID = idValue,

Definition at line 66 of file NetPrefLibTypes.h.

#define NetPrefRecFieldInfoLAST ( fieldID ) fieldID

Definition at line 76 of file NetPrefLibTypes.h.

#define NetPrefRecFieldInfoLegacy | ( | fieldID,
 |  | idValue,
 |  | type,
 |  | maxSize,
 |  | flags,
 |  | tagText,
 |  | tagSize | ) | fieldID = idValue,

Definition at line 73 of file NetPrefLibTypes.h.

#define NetPrefRecFieldInfoPreamble ( )

Definition at line 62 of file NetPrefLibTypes.h.

#define netPrefRecFieldViewCache 0x00000020UL

the external field value is cached locally

Definition at line 201 of file NetPrefLibTypes.h.

#define netPrefRecFieldViewClearAll 0xFFFFFFFFUL

Special value to pass in the flagsToClear parameter to NetPrefRecFieldViewSet in order to clear all field view flags

Definition at line 217 of file NetPrefLibTypes.h.

#define netPrefRecFieldViewCurrentlyValidFlags

Value:

(   netPrefRecFieldViewRead     \
                      | netPrefRecFieldViewWrite    \
                      | netPrefRecFieldViewVisible  \
                      | netPrefRecFieldViewEditable \
                      | netPrefRecFieldViewExternal \
                      | netPrefRecFieldViewCache    \
                      | netPrefRecFieldViewPrivate)

Definition at line 207 of file NetPrefLibTypes.h.

#define netPrefRecFieldViewEditable 0x00000008UL

field value is user-editable

Definition at line 196 of file NetPrefLibTypes.h.

#define netPrefRecFieldViewExternal 0x00000010UL

Field value is stored exernally -- such as in the CCSM table, radio module's flash memory, etc., i.e. not in the NetPref database

Definition at line 200 of file NetPrefLibTypes.h.

#define netPrefRecFieldViewPrivate 0x00000040UL

PRESENTLY NOT RESPECTED; If set, do not display the actual value to the user

Definition at line 202 of file NetPrefLibTypes.h.

#define netPrefRecFieldViewRead 0x00000001UL

read allowed by application

Definition at line 193 of file NetPrefLibTypes.h.

#define netPrefRecFieldViewVisible 0x00000004UL

field value is user-visible

Definition at line 195 of file NetPrefLibTypes.h.

#define netPrefRecFieldViewWrite 0x00000002UL

write allowed by application

Definition at line 194 of file NetPrefLibTypes.h.

Typedef Documentation

typedef UInt16 NetPref1xRTTTunnelingEnum

1xRTT Tunneling identifiers (use with netPrefRecField1xRTTTunneling)

Definition at line 147 of file NetPrefLibTypes.h.

typedef UInt8 NetPrefFallbackAlgrorithmEnum

Fallback algorithm

Definition at line 390 of file NetPrefLibTypes.h.

typedef UInt8 NetPrefFallbackStatusFlagsType

Definition at line 415 of file NetPrefLibTypes.h.

typedef UInt32 NetPrefFieldSetDefineOptionsType

Options for NetPrefRecFieldSetDefineStd and NetPrefRecFieldSetDefine

Definition at line 365 of file NetPrefLibTypes.h.

typedef UInt16 NetPrefFieldTypeEnum

Field type identifiers

Definition at line 106 of file NetPrefLibTypes.h.

typedef UInt16 NetPrefMutexStickyFBAStatusEnum

Flags used in the "Mutex Sticky" fallback algoritm status structure.

Definition at line 426 of file NetPrefLibTypes.h.

typedef UInt32 NetPrefNetCloseWaitEnum

Special values used with netPrefRecFieldCloseWaitTime. Other, standard, values are expressed in milliseconds. IMPORTANT: Beginning with Palm OS 5.0, netPrefRecFieldInactivityTimer must be used to configure the idle timeout of the TCP/IP stack. The "CloseWait" settting is used to control NetLib's CloseWait behavior only

Definition at line 244 of file NetPrefLibTypes.h.

typedef UInt16 NetPrefNetIdleTimeoutEnum

Special values used with netPrefRecFieldInactivityTimer. Other, standard, values are expressed in seconds.

Definition at line 267 of file NetPrefLibTypes.h.

typedef UInt16 NetPrefPlatformEnum

Definition at line 476 of file NetPrefLibTypes.h.

typedef UInt32 NetPrefRecFieldAttrType

Record field attributes (retrieved via NetPrefRecFieldAttrsGet)

Definition at line 220 of file NetPrefLibTypes.h.

typedef UInt16 NetPrefRecFieldEnum

Record field identifiers

Definition at line 48 of file NetPrefLibTypes.h.

typedef UInt32 NetPrefRecFieldViewType

Record field view attributes bitwise-or'ed together

Definition at line 189 of file NetPrefLibTypes.h.

typedef UInt32 NetPrefRecIDType

NetPref Record ID type

Definition at line 101 of file NetPrefLibTypes.h.

typedef UInt32 NetPrefRecProtectionType

Record protection settings -- used with netPrefRecFieldRecProtection

Definition at line 276 of file NetPrefLibTypes.h.

typedef UInt16 NetPrefSvcBindingEnum

Service Binding identifiers (use with netPrefRecFieldBinding);

Definition at line 135 of file NetPrefLibTypes.h.

typedef UInt32 NetPrefSvcGatewayType

Record Service gateway type -- used with netPrefRecFieldSvcGatewayType; 1 or more values can be bitwise or'ed together to mark a record as supporting those gateway types; absense of any service type falgs implies Internet.

NOTE: These values need to correlate with NetPrefSvcTargetEnum.

IMPORTANT: These settings are to be used for carrier-provisioned services only, and are applied by the system's configurator app!!! Others MUST treat these settings as read-only!

Definition at line 313 of file NetPrefLibTypes.h.

typedef UInt16 NetPrefSvcMediumEnum

Service Medium identifiers (used with netPrefRecFieldSvcMediumAlias)

Definition at line 118 of file NetPrefLibTypes.h.

typedef UInt16 NetPrefSvcTargetEnum

Service Target identifiers used with NetPrefDefaultTargetGet() and NetPrefDefaultTargetSet().

NOTE: These values need to correlate with NetPrefSvcGatewayType.

IMPORTANT: These settings are to be used for carrier-provisioned services only, and are applied by the system's configurator app!!! Others MUST treat these settings as read-only!

Definition at line 171 of file NetPrefLibTypes.h.

Enumeration Type Documentation

anonymous enum

Definition at line 79 of file NetPrefLibTypes.h.

00080   {
00081     // undefine this to insure the #include is always processed
00082     #ifdef __NETPREFLIBFIELDINFOTABLE_H__
00083         #undef __NETPREFLIBFIELDINFOTABLE_H__
00084     #endif
00085
00086     // See NetPrefLibFieldInfoTable.h for usage notes
00087     #include <NetPrefLibFieldInfoTable.h>
00088
00089     // In performing the following error check, we take advantage of
00090     // our inside knowledge that NetPrefLibFieldInfoTable.h undefines
00091     // the macros that we defined above
00092     #ifdef NetPrefRecFieldInfoLAST
00093       #error inclusion of NetPrefLibFieldInfoTable.h failed
00094     #endif
00095
00096   };

anonymous enum

Enumerator:
netPrefFieldTypeStr | ascii string -- size must include zero - terminator
netPrefFieldTypeUInt8
netPrefFieldTypeUInt16
netPrefFieldTypeUInt32
netPrefFieldTypeBin | binary
netPrefFieldTypeZStrList | string list: list of zero-terminated strings terminated by empty string. Size must include zero-terminator

Definition at line 107 of file NetPrefLibTypes.h.

00108   {
00109     netPrefFieldTypeStr     = 1,  /**< ascii string -- size must include zero - terminator*/
00110     netPrefFieldTypeUInt8   = 2,
00111     netPrefFieldTypeUInt16  = 3,
00112     netPrefFieldTypeUInt32  = 4,
00113     netPrefFieldTypeBin     = 5,  /**< binary*/
00114     netPrefFieldTypeZStrList= 6   /**< string list: list of zero-terminated strings terminated by empty string. Size must include zero-terminator*/
00115   };

anonymous enum

Enumerator:
netPrefSvcMediumUnknown | reserve 0
netPrefSvcMediumDialUp | basic dial-up - communication driver selection determines service attributes [DEFAULT]
netPrefSvcMediumDirect | basic, non-modem type of connection
netPrefSvcMedium1xRTT | CDMA 3G PDP service
netPrefSvcMediumGPRS | GSM 2.5G PDP service
netPrefSvcMediumQNC | CDMA Quick Net Connect
netPrefSvcMediumGISDN | GSM ISDN over CSD service
netPrefSvcMediumGCSD | GSM circuit switched data service (AKA wireless dial-up)
netPrefSvcMediumCCSD | CDMA circuit switched data service (AKA wireless dial-up)
netPrefSvcMediumOEM | This service is a place-holder for an external OEM plugin
netPrefSvcMediumLAST | ALWAYS KEEP THIS ENTRY AT THE END!!!

Definition at line 119 of file NetPrefLibTypes.h.

00120   {
00121     netPrefSvcMediumUnknown = 0,    /**< reserve 0*/
00122     netPrefSvcMediumDialUp  = 1,    /**< basic dial-up - communication driver selection determines service attributes [DEFAULT]*/
00123     netPrefSvcMediumDirect  = 2,    /**< basic, non-modem type of connection*/
00124     netPrefSvcMedium1xRTT   = 3,    /**< CDMA 3G PDP service*/
00125     netPrefSvcMediumGPRS    = 4,    /**< GSM 2.5G PDP service*/
00126     netPrefSvcMediumQNC     = 5,    /**< CDMA Quick Net Connect*/
00127     netPrefSvcMediumGISDN   = 6,    /**< GSM ISDN over CSD service*/
00128     netPrefSvcMediumGCSD    = 7,    /**< GSM circuit switched data service (AKA wireless dial-up)*/
00129     netPrefSvcMediumCCSD    = 8,    /**< CDMA circuit switched data service (AKA wireless dial-up)*/
00130     netPrefSvcMediumOEM     = 9,    /**< This service is a place-holder for an external OEM plugin*/
00131     netPrefSvcMediumLAST            /**< ALWAYS KEEP THIS ENTRY AT THE END!!!*/
00132   };

anonymous enum

Enumerator:
netPrefSvcBindingUnknown | reserve 0
netPrefSvcBindingIOTA | Provisioned via IOTA
netPrefSvcBindingCCSM | Default Wireless profile based on the CCSM tables
netPrefSvcBindingCustom | Created by user or "user agent" on behalf of the user [DEFAULT]
netPrefSvcBindingLAST | ALWAYS KEEP THIS ENTRY AT THE END!!!

Definition at line 136 of file NetPrefLibTypes.h.

00137   {
00138     netPrefSvcBindingUnknown  = 0,  /**< reserve 0*/
00139     netPrefSvcBindingIOTA     = 1,  /**< Provisioned via IOTA*/
00140     netPrefSvcBindingCCSM     = 2,  /**< Default Wireless profile based on the CCSM tables */
00141     netPrefSvcBindingCustom   = 3,  /**< Created by user or "user agent" on behalf of the user [DEFAULT]*/
00142     netPrefSvcBindingLAST           /**< ALWAYS KEEP THIS ENTRY AT THE END!!!*/
00143   };

anonymous enum

Enumerator:
netPref1xRTTTunnelingUnknown | reserve 0
netPref1xRTTTunnelingReverse | reverse tunneling
netPref1xRTTTunnelingForward | forward tunneling
netPref1xRTTTunnelingLAST | ALWAYS KEEP THIS ENTRY AT THE END!!!

Definition at line 148 of file NetPrefLibTypes.h.

00149   {
00150     netPref1xRTTTunnelingUnknown = 0,   /**< reserve 0*/
00151     netPref1xRTTTunnelingReverse = 1,   /**< reverse tunneling*/
00152     netPref1xRTTTunnelingForward = 2,   /**< forward tunneling*/
00153     netPref1xRTTTunnelingLAST           /**< ALWAYS KEEP THIS ENTRY AT THE END!!!*/
00154   };

anonymous enum

Enumerator:
netPrefSvcTargetUnknown | reserve 0
netPrefSvcTargetInternet | provides access to the Internet
netPrefSvcTargetWAP | provides access to WAP
netPrefSvcTargetReserved1 | reserved
netPrefSvcTargetMMS | provides access to MMS
netPrefSvcTargetBrowser | provides access to Web via web browser
netPrefSvcTargetMail | provides access to e-mail
netPrefSvcTargetIM | provides access to Instant Messaging
netPrefSvcTargetDownloads | provides access to Downloads
netPrefSvcTargetCorporate | provides access to Corporate network
netPrefSvcTargetPictureMail | provides access to Picture Mail
netPrefSvcTargetLAST | ALWAYS KEEP THIS ENTRY AT THE END!!!

Definition at line 172 of file NetPrefLibTypes.h.

00173   {
00174     netPrefSvcTargetUnknown   = 0,  /**< reserve 0*/
00175     netPrefSvcTargetInternet  = 1,  /**< provides access to the Internet*/
00176     netPrefSvcTargetWAP       = 2,  /**< provides access to WAP*/
00177     netPrefSvcTargetReserved1 = 3,  /**< reserved*/
00178     netPrefSvcTargetMMS       = 4,  /**< provides access to MMS*/
00179     netPrefSvcTargetBrowser   = 5,  /**< provides access to Web via web browser*/
00180     netPrefSvcTargetMail      = 6,  /**< provides access to e-mail*/
00181     netPrefSvcTargetIM        = 7,  /**< provides access to Instant Messaging*/
00182     netPrefSvcTargetDownloads = 8,  /**< provides access to Downloads*/
00183     netPrefSvcTargetCorporate = 9,  /**< provides access to Corporate network*/
00184     netPrefSvcTargetPictureMail = 10, /**< provides access to Picture Mail*/
00185     netPrefSvcTargetLAST            /**< ALWAYS KEEP THIS ENTRY AT THE END!!!*/
00186   };

anonymous enum

Enumerator:
netPrefNetCloseWaitEndOnPowerOff | Use this value to configure the network interface to be shut down when the device (i.e. LCD screen) powers off.
netPrefNetCloseWaitMaintainSession | Use this value to configure the network interface to *not* be shut down when the device (i.e. LCD screen) powers off.
netPrefNetCloseWaitCarrierDefault | Use this value to configure the CloseWait behavior with the carrier- default value.

Definition at line 245 of file NetPrefLibTypes.h.

00246   {
00247     /** Use this value to configure the network interface to be shut down
00248      * when the device (i.e. LCD screen) powers off.
00249      */
00250     netPrefNetCloseWaitEndOnPowerOff    = 0xffffffffUL, // was netPrefNetTimeoutOnPowerOff
00251
00252     /** Use this value to configure the network interface to *not* be shut down
00253      * when the device (i.e. LCD screen) powers off.
00254      */
00255     netPrefNetCloseWaitMaintainSession  = 0xfffffffeUL, // was netPrefNetTimeoutOnWirelessOff
00256
00257     /** Use this value to configure the CloseWait behavior with the carrier-
00258      * default value.
00259      */
00260     netPrefNetCloseWaitCarrierDefault   = 0xfffffffdUL  // was netPrefNetTimeoutCarrierDefault
00261   };

anonymous enum

Enumerator:
netPrefNetIdleTimeoutNever Never time out due to data idleness

Definition at line 268 of file NetPrefLibTypes.h.

00269   {
00270     netPrefNetIdleTimeoutNever          = (UInt16) 0    /**< Never time out due to data idleness*/
00271   };

anonymous enum

Enumerator:
netPrefRecProtectionDeletionMask | Record deletion options
netPrefRecProtectionDeletionAfterWarning
netPrefRecProtectionDeletionNotAllowed
netPrefRecProtectionDuplicationMask | Duplication options
netPrefRecProtectionDuplicationAllowed
netPrefRecProtectionDuplicationNotAllowed
netPrefRecProtectionEditingMask | Editing options
netPrefRecProtectionEditingAllowed
netPrefRecProtectionEditingNotAllowed
netPrefRecProtectionEditingAfterWarning

Definition at line 277 of file NetPrefLibTypes.h.

00278   {
00279     /** Record deletion options*/
00280     netPrefRecProtectionDeletionMask                  = 0x00000007UL,
00281     netPrefRecProtectionDeletionAfterWarning          = 0x0UL,
00282     netPrefRecProtectionDeletionNotAllowed            = 0x1UL,
00283
00284
00285     /** Duplication options*/
00286     netPrefRecProtectionDuplicationMask               = (0x7UL << 3),
00287     netPrefRecProtectionDuplicationAllowed            = (0x0UL << 3),
00288     netPrefRecProtectionDuplicationNotAllowed         = (0x1UL << 3),
00289
00290
00291     /** Editing options*/
00292     netPrefRecProtectionEditingMask                   = (0x7UL << 6),
00293     netPrefRecProtectionEditingAllowed                = (0x0UL << 6),
00294     netPrefRecProtectionEditingNotAllowed             = (0x1UL << 6),
00295     netPrefRecProtectionEditingAfterWarning           = (0x2UL << 6)
00296   };

anonymous enum

Enumerator:
netPrefSvcGatewayUnknown | reserved
netPrefSvcGatewayInternet | Generic Internet "gateway"
netPrefSvcGatewayWAP | Generic WAP gateway
netPrefSvcGatewayPrivate | Application-specific "gateway"
netPrefSvcGatewayMMS | Generic MMS "gateway"
netPrefSvcGatewayBrowser | Web via web browser
netPrefSvcGatewayMail | e-mail
netPrefSvcGatewayIM | Instant Messaging
netPrefSvcGatewayDownloads | Downloads
netPrefSvcGatewayCorporate | Corporate network
netPrefSvcGatewayPictureMail | Picture Mail
netPrefSvcGatewayLAST | ALWAYS KEEP THIS ENTRY AT THE END!!!

Definition at line 314 of file NetPrefLibTypes.h.

00315   {
00316     netPrefSvcGatewayUnknown        = 0UL,          /**< reserved*/
00317     netPrefSvcGatewayInternet       = 0x00000001UL, /**< Generic Internet "gateway"*/
00318     netPrefSvcGatewayWAP            = 0x00000002UL, /**< Generic WAP gateway*/
00319     netPrefSvcGatewayPrivate        = 0x00000004UL, /**< Application-specific "gateway"*/
00320     netPrefSvcGatewayMMS            = 0x00000008UL, /**< Generic MMS "gateway"*/
00321     netPrefSvcGatewayBrowser        = 0x00000010UL, /**< Web via web browser*/
00322     netPrefSvcGatewayMail           = 0x00000020UL, /**< e-mail*/
00323     netPrefSvcGatewayIM             = 0x00000040UL, /**< Instant Messaging*/
00324     netPrefSvcGatewayDownloads      = 0x00000080UL, /**< Downloads*/
00325     netPrefSvcGatewayCorporate      = 0x00000100UL, /**< Corporate network*/
00326     netPrefSvcGatewayPictureMail    = 0x00000200L,  /**< Picture Mail*/
00327
00328     netPrefSvcGatewayLAST             /**< ALWAYS KEEP THIS ENTRY AT THE END!!!*/
00329   };

anonymous enum

Enumerator:
netPrefFieldSetDefineOptionNone Pass this value for "no options"
netPrefFieldSetDefineOptionKeepData

Definition at line 366 of file NetPrefLibTypes.h.

00367   {
00368     netPrefFieldSetDefineOptionNone = 0,        /**< Pass this value for "no options"*/
00369
00370     // If set, NetPrefRecFieldSetDefineStd and NetPrefRecFieldSetDefine
00371     // will temporarily keep around the data of out-of-set fields; however,
00372     // it will not save such data when saving the field; this feature
00373     // is a convenience for the Network panel that allows the user to
00374     // experiment with different connection mediuma (dial-up, direct, 3G, etc.)
00375     // without losing the data that is in one service medium's field set,
00376     // but not in another.
00377     netPrefFieldSetDefineOptionKeepData = 0x00000001UL
00378   };

anonymous enum

Enumerator:
netPrefFallbackAlgrorithmBasic | Basic algorithm: each time: try primary; if fails, try fallback;
netPrefFallbackAlgrorithmMutexSticky | Mutually exclusive, sticky algorithm: The primary and fallback record MUST be cross-linked -- each MUST specify the other as its fallback; both records MUST also be tagged with this algorithm. Regardless of which of the cross-linked services is requested during login (unless "primary only" is requested -- see NetMaster API), the algorithm will attempt to connect with the one that succeeded last time. The first time or if both failed last time, it will try the requested service first. If the attempt fails, it will try the one specified as its fallback.
netPrefFallbackAlgrorithmLAST

Definition at line 391 of file NetPrefLibTypes.h.

00392   {
00393     /**  Basic algorithm: each time: try primary; if fails, try fallback; */
00394     netPrefFallbackAlgrorithmBasic = 0,
00395
00396     /**
00397      * Mutually exclusive, sticky algorithm: The primary and fallback record
00398      * MUST be cross-linked -- each MUST specify the other as its fallback;
00399      * both records MUST also be tagged with this algorithm.  Regardless of
00400      * which of the cross-linked services is requested during login (unless
00401      * "primary only" is requested -- see NetMaster API), the algorithm will
00402      * attempt to connect with the one that succeeded last time. The first time
00403      * or if both failed last time, it will try the requested service first. If
00404      * the attempt fails, it will try the one specified as its fallback.
00405      */
00406     netPrefFallbackAlgrorithmMutexSticky = 1,
00407
00408
00409
00410     // ADD NEW VALUES *BEFORE* THIS ONE
00411     netPrefFallbackAlgrorithmLAST
00412   };

anonymous enum

Enumerator:
netPrefFallbackStatusFlagInitialized

Definition at line 416 of file NetPrefLibTypes.h.

00417   {
00418     // If set, inidicates that NetPrefFallbackInfoType.status has
00419     // been initialized.
00420     netPrefFallbackStatusFlagInitialized = 0x01
00421
00422   };

anonymous enum

Enumerator:
netPrefMutexStickyFBAStatusUnknown | Indicates that the last login status of the corresponding network service is unknown.
netPrefMutexStickyFBAStatusFailed | Indicates that the last login attempt using the corresponding network service failed.
netPrefMutexStickyFBAStatusSucceeded | Indicates that the last login attempt using the corresponding network service succeeded.

Definition at line 427 of file NetPrefLibTypes.h.

00428   {
00429     netPrefMutexStickyFBAStatusUnknown      = 0, /**< Indicates that the last login status of the corresponding network service is unknown.*/
00430
00431     netPrefMutexStickyFBAStatusFailed       = 1, /**< Indicates that the last login attempt using the corresponding network service failed.*/
00432
00433     netPrefMutexStickyFBAStatusSucceeded    = 2  /**< Indicates that the last login attempt using the corresponding network service succeeded.*/
00434   };

anonymous enum

Enumerator:
netPrefPlatformUnknown
netPrefPlatformGSM
netPrefPlatformCDMA
netPrefPlatformLAST

Definition at line 477 of file NetPrefLibTypes.h.

00478   {
00479     netPrefPlatformUnknown    = 0,
00480
00481     netPrefPlatformGSM        = 1,
00482     netPrefPlatformCDMA       = 2,
00483
00484     netPrefPlatformLAST
00485   };

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:07:41 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » audio

PalmAudioPlayback.h File Reference

Detailed Description

Public 68K include file that supports the stopping of audio playback on Treo 600 and Treo 650 smartphones.

This header file and associated header files support the specific sound functionality of the Treo smartphones. You should use the Palm OS Sound Manager APIs for most of your work.

Notes: This header contains a notification to call for stopping any existing background audio playback.

Any application ( usually video capture ) that needs to stop and eventually resume audio playback should use this header. Stopping or resuming playback is done by throwing a notification.

Audio playback applications should register for this notification and stop playback when they get the stop action code. They can optionally resume action when they get a notification with a resume action code. However resume is not a mandatory feature neither for the calling application nor for the audio application. In other words, the audio application may never get a resume after a stop action code.

Usage for any application requesting stop of audio playback:

PalmAudioPlaybackRequestStop('cccc'); // to stop background playback PalmAudioPlaybackRequestResume('cccc'); // to resume background playback

The calling application should always load this library with SysLibLoad() before use, even if it is already open by another application(ie, SysLibFind() returns a valid refnum). When the application is done with the library, it should be unloaded with SysLibRemove(). We do this because there is no good way to synchronize loading and unloading of libraries among multiple applications. It also greatly simplifies internal synchronization.

Definition in file PalmAudioPlayback.h.

Include dependency graph for PalmAudioPlayback.h:

Go to the source code of this file.

Data Structures

  • struct PalmAudioPlaybackNotifyEventTypeTag

Defines

PalmAudioPlayback information and notification
  • #define kPalmAudioPlaybackNotify1 sysMakeROMVersion(1, 0, 0, sysROMStageRelease, 0)
  • #define kPalmAudioPlaybackNotifyVersion kPalmAudioPlaybackNotify1
  • #define kPalmAudioPlaybackCreator 'apbP'
  • #define kPalmAudioPlaybackNotifyEvent kPalmAudioPlaybackCreator
Audio playback action codes
  • #define kPalmAudioPlaybackActionCodeRequestStop ((PalmAudioPlaybackActionCodeType)1)
  • #define kPalmAudioPlaybackActionCodeRequestResume ((PalmAudioPlaybackActionCodeType)2)
Audio playback helper macros
  • #define PalmAudioPlaybackRequestStop(creator)
  • #define PalmAudioPlaybackRequestResume(creator)
  • #define PalmAudioPlaybackSendRequest(requestP, creator)

Typedefs

  • typedef UInt16 PalmAudioPlaybackActionCodeType
  • typedef PalmAudioPlaybackNotifyEventTypeTag PalmAudioPlaybackNotifyEventType

Define Documentation

#define kPalmAudioPlaybackActionCodeRequestResume ((PalmAudioPlaybackActionCodeType)2)

Playback resume action code.

Definition at line 97 of file PalmAudioPlayback.h.

#define kPalmAudioPlaybackActionCodeRequestStop ((PalmAudioPlaybackActionCodeType)1)

Playback stop action code.

Definition at line 94 of file PalmAudioPlayback.h.

#define kPalmAudioPlaybackCreator 'apbP'

PalmAudioPlayback creator ID.

Definition at line 74 of file PalmAudioPlayback.h.

#define kPalmAudioPlaybackNotify1 sysMakeROMVersion(1, 0, 0, sysROMStageRelease, 0)

Definition at line 68 of file PalmAudioPlayback.h.

#define kPalmAudioPlaybackNotifyEvent kPalmAudioPlaybackCreator

Playback notification event ID.

Applications playing audio should register for this notification and stop or optionally resume playback depending on the action code the application receives.

Definition at line 81 of file PalmAudioPlayback.h.

#define kPalmAudioPlaybackNotifyVersion kPalmAudioPlaybackNotify1

Version of the PalmAudioPlayback library.

Definition at line 71 of file PalmAudioPlayback.h.

#define PalmAudioPlaybackRequestResume ( creator )

Value:

{ \
        PalmAudioPlaybackNotifyEventType request = \
        { \
            kPalmAudioPlaybackNotifyVersion, \
            kPalmAudioPlaybackActionCodeRequestResume, \
            0 \
        }; \
        PalmAudioPlaybackSendRequest(&request, creator); \
    }
Request to resume playback. Any application that needs to request that audio playback be resumed should use this macro. "creator" is the creator id of the calling function.

Definition at line 141 of file PalmAudioPlayback.h.

#define PalmAudioPlaybackRequestStop ( creator )

Value:

{ \
        PalmAudioPlaybackNotifyEventType request = \
        { \
            kPalmAudioPlaybackNotifyVersion, \
            kPalmAudioPlaybackActionCodeRequestStop, \
            0 \
        }; \
        PalmAudioPlaybackSendRequest(&request, creator); \
    }
Request to stop playback. Any application that needs to request a stop of audio playback should use this macro. "creator" is the creator id of the calling function.

Definition at line 117 of file PalmAudioPlayback.h.

#define PalmAudioPlaybackSendRequest | ( | requestP,
 |  | creator | )

Value:

{ \
        SysNotifyParamType      notify; \
        MemSet(&notify, sizeof(SysNotifyParamType), 0); \
        notify.notifyType       = kPalmAudioPlaybackNotifyEvent; \
        notify.broadcaster      = creator; \
        notify.notifyDetailsP   = (void*)requestP; \
        SysNotifyBroadcast(&notify); \
    }
Actual broadcast of kPalmAudioPlaybackNotifyEvent notification. Used by Stop and Resume macros.

Definition at line 165 of file PalmAudioPlayback.h.

Typedef Documentation

typedef UInt16 PalmAudioPlaybackActionCodeType

Holds action codes for the kPalmAudioPlaybackNotifyEvent broadcast.

Definition at line 85 of file PalmAudioPlayback.h.

typedef struct PalmAudioPlaybackNotifyEventTypeTag PalmAudioPlaybackNotifyEventType

Audio playback notification structure.

Structure that is sent as part of notifyDetailsP when a kPalmAudioPlaybackNotifyEvent is thrown.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:07:41 2008 for Palm API Guide


Header Files » Incs » 68k » system

PalmBGService.h File Reference

Detailed Description

Public 68K header file for palmOne Background Network Service Library.

Version:
1.0
This file contains the function prototypes and structures for the Background Service which lets users make a background network connection.

Definition in file PalmBGService.h.

Include dependency graph for PalmBGService.h:

Go to the source code of this file.

Data Structures

  • struct BGResult
    Structure containing Result of response for a protocol request. More...

Defines

Function Traps
  • #define bgTrapAPIVersion (sysLibTrapCustom+0)
  • #define bgTrapCancelRqst (sysLibTrapCustom+1)
  • #define bgTrapINetLibRqst (sysLibTrapCustom+3)
  • #define bgTrapNetLibRqst (sysLibTrapCustom+4)
Library Constants
  • #define bgServiceLibName "BGService.Lib"
  • #define bgServiceCreatorID 'asc9'
  • #define bgServiceType 'appl'
Error Codes
  • #define IBG_SUCCESS 0
  • #define IBG_ERRNOTPOSSIBLE 2
  • #define IBG_ERRTIMEOUT 3
  • #define IBG_ERRREQUEST 4
  • #define IBG_ERRRSPTOOBIG 6
  • #define IBG_ERRSHUTDOWN 7
  • #define IBG_ERRRQSTDONE 8
  • #define IBG_MAXBUFSZ 100

Typedefs

  • typedef UInt32(*) BGRecvResponseFP (UInt32 rqstId, BGResult *presult, MemHandle *responseH, UInt32 respSz, UInt32 *opaque)
    Background Request's Response Callback function.

Functions

  • Err BGServiceOpen (UInt16 libRefNum)
    Opens the Background Service library. This function should be called prior to calling the other Background Service functions.
  • Err BGServiceClose (UInt16 libRefNum)
    Closes the Background Service library. This function should be called after your application has finished with the Background Service library.
  • Err BGServiceVersion (UInt16 libRefNum, UInt32 *pversion)
    Returns the version number of Background Service.
  • Err BGServiceCancelRqst (UInt16 libRefNum, UInt32 rqstId)
    Cancels a current request identified by the Request id.
  • Err BGServiceINetRqst (UInt16 libRefNum, char *purl, char *ppostBuf, BGRecvResponseFP precvFunc, UInt32 opaque, MemHandle respH, UInt32 *prqstId)
    Perform a INetLib request via the HTTP POST command.
  • Err BGServiceNetRqst (UInt16 libRefNum, char *notUsed, char *pserver, UInt16 port, char *prqst, char *pterm, BGRecvResponseFP precvFunc, UInt32 opaque, UInt8 reserved, MemHandle respH, UInt32 *prqstId)
    Perform a NetLib request on the default network connection ( for now ).

Define Documentation

#define bgServiceCreatorID 'asc9'

Background services Creator ID.

Definition at line 59 of file PalmBGService.h.

#define bgServiceLibName "BGService.Lib"

Background services library name.

Definition at line 58 of file PalmBGService.h.

#define bgServiceType 'appl'

Background services Type.

Definition at line 60 of file PalmBGService.h.

#define bgTrapAPIVersion (sysLibTrapCustom+0)

Definition at line 47 of file PalmBGService.h.

#define bgTrapCancelRqst (sysLibTrapCustom+1)

Definition at line 48 of file PalmBGService.h.

#define bgTrapINetLibRqst (sysLibTrapCustom+3)

Definition at line 49 of file PalmBGService.h.

#define bgTrapNetLibRqst (sysLibTrapCustom+4)

Definition at line 50 of file PalmBGService.h.

#define IBG_ERRNOTPOSSIBLE 2

Return Value indicating on i705 that radio is NOT on or WebClipping is NOT configured in i705 Wireless panel.

Definition at line 72 of file PalmBGService.h.

#define IBG_ERRREQUEST 4

Return Value indicating an error occurred processing the request. If a network error occurred, look at the protocolErr and protocolErrString members in the returned BGResult value for details.

Definition at line 82 of file PalmBGService.h.

#define IBG_ERRRQSTDONE 8

Return Value indicating a request cannot be cancelled with BGServiceCancelRqst() because the request was already started.

Definition at line 99 of file PalmBGService.h.

#define IBG_ERRRSPTOOBIG 6

Return Value indicating the response handle passed with the request is not large enough to contain the response gotten from the server. In this case a partial response may be contained in the response handle, but it is truncated.

Definition at line 89 of file PalmBGService.h.

#define IBG_ERRSHUTDOWN 7

Return Value indicating the BGService cannot process the request due to a HotSync or systen reset occurring

Definition at line 95 of file PalmBGService.h.

#define IBG_ERRTIMEOUT 3

Return Value indicating the request made could not be completed because of a network timeout, or request took longer than 20 minutes to complete for BGServiceNetRqst() or greater than 2 minutes for BGServiceINetRqst().

Definition at line 76 of file PalmBGService.h.

#define IBG_MAXBUFSZ 100

Maximum size of protocolErrString.

Definition at line 103 of file PalmBGService.h.

#define IBG_SUCCESS 0

Return Value indicating success.

Definition at line 69 of file PalmBGService.h.

Typedef Documentation

typedef UInt32( * ) BGRecvResponseFP(UInt32 rqstId, BGResult *presult, MemHandle *responseH, UInt32 respSz, UInt32 *opaque)

Background Request's Response Callback function.

Parameters:
rqstId | IN: Request id that identifies a particular request the response is for
presult | IN: Contains the response protocol error message if any.
responseH | IN: Handle to the response string.
respSz | IN: Size of response
opaque | IN: Opaque value passed back to the callback, can be used for userdata
Returns:
One of the IBG_xxx return codes defined above. Currently any return value is ignored.

Definition at line 202 of file PalmBGService.h.

Function Documentation

Err BGServiceCancelRqst | ( | UInt16 | libRefNum,
 |  | UInt32 | rqstId
 | ) |  |

Cancels a current request identified by the Request id.

Parameters:
libRefNum,: IN: Reference number of the library.
rqstId,: IN: Request ID of the BgRequest to be cancelled.
Returns:
IBG_SUCCESS on success, otherwise IBG_ERRRQSTDONE if request was not found or has begun already.

Err BGServiceClose ( UInt16 libRefNum )

Closes the Background Service library. This function should be called after your application has finished with the Background Service library.

Parameters:
libRefNum,: IN: Reference number of the Background Service library.
Returns:
The error code returned from the library. If this is errNone, the function was sucessful.
 err = BGServiceClose(bgServiceLibRefNum);

See also:
BGServiceOpen

Err BGServiceINetRqst | ( | UInt16 | libRefNum,
 |  | char * | purl,
 |  | char * | ppostBuf,
 |  | BGRecvResponseFP | precvFunc,
 |  | UInt32 | opaque,
 |  | MemHandle | respH,
 |  | UInt32 * | prqstId
 | ) |  |

Perform a INetLib request via the HTTP POST command.

Parameters:
libRefNum,: IN: Reference number of the library.
purl,: IN: Url of server to issue request to. Formatted for INetLibURLCrack command
ppostBuf,: IN: Any post data for request, formatted for INetLibSockHTTPReqSend command - No additional formatting is performed.
precvFunc,: IN: Response callback function
opaque,: IN: Opaque value passed back to callback routine when called
respH,: IN: Pre-allocated memory handle to hold response. Must be big enough to hold largest response ( for INet typically less than 10K )
prqstId,: IN: Returned id given to request for later identification or canceling
Returns:
IBG_SUCCESS if accepted, otherwise another error code defined above

Err BGServiceNetRqst | ( | UInt16 | libRefNum,
 |  | char * | notUsed,
 |  | char * | pserver,
 |  | UInt16 | port,
 |  | char * | prqst,
 |  | char * | pterm,
 |  | BGRecvResponseFP | precvFunc,
 |  | UInt32 | opaque,
 |  | UInt8 | reserved,
 |  | MemHandle | respH,
 |  | UInt32 * | prqstId
 | ) |  |

Perform a NetLib request on the default network connection ( for now ).

Parameters:
libRefNum,: IN: Reference number of the library.
notUsed,: IN: Always pass NULL.
pserver,: IN: Server to issue request to. Hostnames are looked up via DNS calls, although slows down requests. Better to use IP addresses if possible.
port,: IN: Port to make call on
prqst,: IN: Protocol specific string to make once connection is made to server.
pterm,: IN: Server response terminator to look for to know have gotten complete response from server, or 0 if don't have a terminator. Of course using a terminator greatly speeds up receiving response.
precvFunc,: IN: Response callback function
opaque,: IN: Opaque value passed back to callback routine when called
reserved,: IN: Reserved for future use, must always be 0
respH,: IN: Pre-allocated memory handle to hold response. Must be big enough to hold largest response ( for INet typically less than 10K )
prqstId,: IN: Returned id given to request for later identification or canceling
Returns:
IBG_SUCCESS if accepted, otherwise another error code defined above

Err BGServiceOpen ( UInt16 libRefNum )

Opens the Background Service library. This function should be called prior to calling the other Background Service functions.

Parameters:
libRefNum,: IN: Reference number of the Background Service library.
Returns:
The error code returned from the library. If this is errNone, the function was sucessful.
 UInt16 bgServiceLibRefNum = 0;
 err = SysLibFind(bgServiceLibName, &bgServiceLibRefNum);
 if( err == sysErrLibNotFound )
 {
     err = SysLibLoad(bgServiceType, bgServiceCreatorID, &bgServiceLibRefNum);
         if( !err ) {
             err = BGServiceOpen(bgServiceLibRefNum);
         }
 }

See also:
BGServiceClose

Err BGServiceVersion | ( | UInt16 | libRefNum,
 |  | UInt32 * | pversion
 | ) |  |

Returns the version number of Background Service.

Parameters:
libRefNum,: IN: Reference number of the library.
pversion,: IN: Pointer to version number returned
Returns:
Always IBG_SUCCESS

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:07:41 2008 for Palm API Guide


Header Files » Incs » common » system

PalmCreators.h File Reference

Detailed Description

Contains Palm-specific creator codes.

Version:
1.0
Date:
02/29/2002
Temporary shim to the new filename and location.

Definition in file PalmCreators.h.

Include dependency graph for PalmCreators.h:

Go to the source code of this file.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:07:41 2008 for Palm API Guide


Header Files » Incs » 68k » system

PalmDisplayExtent.h File Reference

Detailed Description

Public API for the Display Extent Library.

Version:
1.0

Definition in file PalmDisplayExtent.h.

Include dependency graph for PalmDisplayExtent.h:

Go to the source code of this file.

Defines

Library type and creator
  • #define dexLibName "rotmgr"
  • #define dexLibCreator 'rotM'
  • #define dexLibType sysFileTLibrary
  • #define dexFtrNumVersion (0)
Library Traps
  • #define kDexLibTrapOpen sysLibTrapOpen
  • #define kDexLibTrapClose sysLibTrapClose
  • #define kDexLibTrapDexGetDisplayAddress (sysLibTrapCustom + 4)
  • #define kDexLibTrapDexGetDisplayDimensions (sysLibTrapCustom + 5)

Functions

  • void * DexGetDisplayAddress (UInt16 refnum)
    Get the physical screen buffer (Display Address).
  • void DexGetDisplayDimensions (UInt16 refnum, Coord *width, Coord *height, UInt16 *rowBytes)
    Get the physical screen width, height, and rowbytes.

Define Documentation

#define dexFtrNumVersion (0)

PalmDisplayExtent feature number.

Definition at line 41 of file PalmDisplayExtent.h.

#define dexLibCreator 'rotM'

PalmDisplayExtent Creator ID.

Definition at line 39 of file PalmDisplayExtent.h.

#define dexLibName "rotmgr"

PalmDisplayExtent library name.

Definition at line 38 of file PalmDisplayExtent.h.

#define dexLibType sysFileTLibrary

PalmDisplayExtent type.

Definition at line 40 of file PalmDisplayExtent.h.

#define kDexLibTrapClose sysLibTrapClose

Definition at line 51 of file PalmDisplayExtent.h.

#define kDexLibTrapDexGetDisplayAddress (sysLibTrapCustom + 4)

Definition at line 54 of file PalmDisplayExtent.h.

#define kDexLibTrapDexGetDisplayDimensions (sysLibTrapCustom + 5)

Definition at line 55 of file PalmDisplayExtent.h.

#define kDexLibTrapOpen sysLibTrapOpen

Definition at line 50 of file PalmDisplayExtent.h.

Function Documentation

void* DexGetDisplayAddress ( UInt16 refnum )

Get the physical screen buffer (Display Address).

Parameters:
refnum,: IN: Reference number of the Display Extent Manager library.
Return values:
Returns a pointer to the physical screen buffer.
Remarks:
You should only use this function if direct screen access is required. This function returns a pointer to the physical display. If you need to do direct screen access in 90, 180, and 270 rotation, use this function. If you use the regular APIs (eg something like BmpGetBits(WinGetBimatp(WinDisplay()))) you would get a back buffer pointer instead and would not see anything until you force a screen copy of this back buffer. Note that the address points to the top-left corner of the device in potrait mode always.
      // this code draws 6400 red pixels in the screen.

        RGBColorType color = { 0, 255, 0, 0 };
        IndexedColorType index = WinRGBToIndex(&color);
        UInt8 *bufferP = (UInt8*)DexGetDisplayAddress(gDexLibRefNum);
        UInt32 x = 0;

        for( x = 0; x < 6400; x++)
             bufferP[x] = index;
 *

void DexGetDisplayDimensions | ( | UInt16 | refnum,
 |  | Coord * | width,
 |  | Coord * | height,
 |  | UInt16 * | rowBytes
 | ) |  |

Get the physical screen width, height, and rowbytes.

Parameters:
refnum,: IN: Reference number of the Display Extent Manager library.
width | IN: Pointer to the width of the screen.
height | IN: Pointer to the height of the screen.
rowBytes | IN: Pointer to the rowbytes of the screen.
Return values:
Nothing

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:07:42 2008 for Palm API Guide


Header Files » Incs » 68k » system

PalmErrorBase.h File Reference

Detailed Description

Include file for Error Management.

Version:
1.0

Definition in file PalmErrorBase.h.

Include dependency graph for PalmErrorBase.h:

Go to the source code of this file.

Defines

  • #define oemErrorClass 0x7000
Error Classes for OEM components
  • #define softGraffitErrorClass (oemErrorClass | 200)
  • #define statusBarErrorClass (oemErrorClass | 300)

Define Documentation

#define oemErrorClass 0x7000

OEM/Licensee errors (0x7000-0x7EFF shared among ALL partners)

Definition at line 33 of file PalmErrorBase.h.

#define softGraffitErrorClass (oemErrorClass | 200)

Definition at line 41 of file PalmErrorBase.h.

#define statusBarErrorClass (oemErrorClass | 300)

Definition at line 42 of file PalmErrorBase.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:07:42 2008 for Palm API Guide


Header Files » Incs » common » system

PalmFeatures.h File Reference

Detailed Description

Contains Palm-specific feature definitions.

Version:
1.0
Date:
02/29/2002
Temporary shim to the new filename and location.

Definition in file PalmFeatures.h.

Include dependency graph for PalmFeatures.h:

Go to the source code of this file.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:07:42 2008 for Palm API Guide


Header Files » Incs » 68k » system

PalmGoLCD.h File Reference

Detailed Description

Public include header file for the GoLCD Library.

Version:
1.1
You can use the functions in this API to enable or disable fullscreen writing, enable and disable the Graffiti 2 shift indicator (GSI) as a control for full-screen writing, enable and disable Graffiti 2 inking, and even change the colors of Graffiti 2 inking and the GSI.

You can check whether the GoLCD Manager is installed by examining its feature set. Call FtrGet as follows:

 err = FtrGet (goLcdCreator, goLcdFtrNumVersion, &value);

Definition in file PalmGoLCD.h.

Include dependency graph for PalmGoLCD.h:

Go to the source code of this file.

Functions

  • Err GoLcdLibOpen (UInt16 libRefNum)
    Opens the GoLCD library. This function should be called prior to calling the other GoLCD functions.
  • Err GoLcdLibClose (UInt16 libRefNum)
    Closes the GoLCD library. This function should be called after your application has finished with the GoLCD library.
  • GoLcdStatusType GoLcdGetStatus (UInt16 libRefNum)
    Returns whether the GoLCD functionality is enabled, disabled, or not available on this device.
  • GoLcdStatusType GoLcdSetStatus (UInt16 libRefNum, GoLcdStatusType status)
    Enables or disables the GoLCD functionality.
  • void GoLcdGetInkState (UInt16 libRefNum, GoLcdInkStateType *stateP, GoLcdColorModeType *colorModeP, RGBColorType *rgbP)
    Returns the current state of GoLCD inking.
  • void GoLcdSetInkState (UInt16 libRefNum, GoLcdInkStateType state, GoLcdColorModeType colorMode, RGBColorType *rgbP)
    Sets the state of GoLCD inking.
  • void GoLcdGetGsiState (UInt16 libRefNum, GoLcdGsiStateType *stateP, GoLcdColorModeType *colorModeP, RGBColorType *rgbP)
    Returns the GSI state associated with GoLCD.
  • void GoLcdSetGsiState (UInt16 libRefNum, GoLcdGsiStateType state, GoLcdColorModeType colorMode, RGBColorType *rgbP)
    Sets the GSI state associated with GoLCD.
  • UInt32 GoLcdGetTimeout (UInt16 libRefNum, GoLcdModeType mode)
    Returns the length, in system ticks, of the time-out value of GoLCD.
  • UInt32 GoLcdSetTimeout (UInt16 libRefNum, GoLcdModeType mode, UInt32 ticks)
    Sets the length, in system ticks, of the time-out value of GoLCD.
  • void GoLcdGetBounds (UInt16 libRefNum, RectangleType *rectP)
    Returns the current bounds defined for use with GoLCD.
  • void GoLcdSetBounds (UInt16 libRefNum, RectangleType *rectP)
    Sets the bounds defined for use with GoLCD.

Function Documentation

void GoLcdGetBounds | ( | UInt16 | libRefNum,
 |  | RectangleType * | rectP
 | ) |  |

Returns the current bounds defined for use with GoLCD.

Parameters:
libRefNum,: IN: Reference number of the GoLCD library.
rectP,: IN: Points to the returned rectangle.
Remarks:
GoLCD ignores any succession of pen events (a series of penDownEvents followed by a penUpEvent) if the initial penDownEvent occurs outside its bounds. By default, its bounds are the entire display and users can start drawing full-screen writing characters anywhere except for the right-most scroll bar and the menu bar area.
 RectangleType gCurrentBounds;
 GoLcdGetBounds(gGoLcdLibRefNum, &gCurrentBounds);

See also:
GoLcdSetBounds

void GoLcdGetGsiState | ( | UInt16 | libRefNum,
 |  | GoLcdGsiStateType * | stateP,
 |  | GoLcdColorModeType * | colorModeP,
 |  | RGBColorType * | rgbP
 | ) |  |

Returns the GSI state associated with GoLCD.

Parameters:
libRefNum,: IN: Reference number of the GoLCD library.
stateP,: IN: Points to the returned GoLCD GSI state.
colorModeP,: IN: Points to the returned GoLCD color mode for GSI.
rgbP,: IN: Valid only if colorMode is set to goLcdColorOverride. Points to an RGB color value corresponding to the current color used for inking. (The RGBColorType is defined in the header file Bitmap.h.)
Remarks:
In normal operation, the GSI is drawn in the lower-right portion of the screen when the user enters the shift keystroke. The functionality of the GSI can be changed into an enable and disable control for GoLCD. This function returns the current state of the GSI.
 GoLcdGsiStateType gCurrentGoLcdGsiState = goLcdGsiNormal;
 GoLcdColorModeType gCurrentGoLcdColorMode = goLcdColorDefault;
 RGBColorType gCurrentColor;
 GoLcdGetGsiState(gGoLcdLibRefNum, &gCurrentGoLcdGsiState, &gCurrentGoLcdColorMode, &gCurrentColor);

See also:
GoLcdSetGsiState

void GoLcdGetInkState | ( | UInt16 | libRefNum,
 |  | GoLcdInkStateType * | stateP,
 |  | GoLcdColorModeType * | colorModeP,
 |  | RGBColorType * | rgbP
 | ) |  |

Returns the current state of GoLCD inking.

Parameters:
libRefNum,: IN: Reference number of the GoLCD library.
stateP,: IN: Points to the returned GoLCD ink state.
colorModeP,: IN: Points to the returned GoLCD color mode for ink.
rgbP,: IN: Valid only if colorMode is set to goLcdColorOverride. Points to an RGB color value corresponding to the current color used for inking. (The RGBColorType is defined in the header file Bitmap.h.)
 GoLcdInkStateType gCurrentGoLcdInkState = goLcdInkDisabled;
 GoLcdColorModeType gCurrentGoLcdColorMode = goLcdColorDefault;
 RGBColorType gCurrentColor;
 GoLcdGetInkState(gGoLcdLibRefNum, &gCurrentGoLcdInkState, &gCurrentGoLcdColorMode, &gCurrentColor);

See also:
GoLcdSetInkState

GoLcdStatusType GoLcdGetStatus ( UInt16 libRefNum )

Returns whether the GoLCD functionality is enabled, disabled, or not available on this device.

Parameters:
libRefNum,: IN: Reference number of the GoLCD library.
Return values:
GoLcdStatusType Returns the current GoLCD status.
See also:
GoLcdStatusType
 GoLcdStatusType gCurrentGoLcdStatus = goLcdNotAvailable;
 gCurrentGoLcdStatus = GoLcdGetStatus(gGoLcdLibRefNum);
 switch(gCurrentGoLcdStatus) {
     case goLcdDisabled:
         // GoLcd is disabled
         break;
     case goLcdEnabled:
         // GoLcd is Enabled
         break;
     case goLcdNotAvailable:
     default:
         // Not available
         break;
 }

See also:
GoLcdSetStatus

UInt32 GoLcdGetTimeout | ( | UInt16 | libRefNum,
 |  | GoLcdModeType | mode
 | ) |  |

Returns the length, in system ticks, of the time-out value of GoLCD.

Parameters:
libRefNum,: IN: Reference number of the GoLCD library.
mode,: IN: Specifies the GoLCD mode.
Return values:
UInt32 Returns the length (in system ticks) of the time-out value.
Remarks:
GoLCD starts in goLcdPenTapMode. When a penDownEvent is received, a timer is started. If a penUpEvent is received before the timer reaches the time-out value for this mode, the pen events are passed on to the event handler for the application control. Otherwise, if the pen events exceed the time-out value and the x, y coordinates change significantly, GoLCD enters goLcdGraffitiMode and treats the pen events as a Graffiti 2 stroke.
The default time-out value for goLcdPenTapMode is 15 system ticks, or 150 milliseconds.
When it enters goLcdGraffitiMode, GoLCD continuously interprets all pen events as Graffiti 2 strokes. There is a time-out value associated with goLcdGraffitiMode, however. If it does not receive a new pen event within the allotted time, it returns to goLcdPenTapMode.
The default time-out value for goLcdGraffitiMode is 150 system ticks, or 1500 milliseconds.
 UInt32 gCurrentTimeout = GoLcdGetTimeout(gGoLcdLibRefNum, goLcdPenTapMode);

See also:
GoLcdSetTimeout

Err GoLcdLibClose ( UInt16 libRefNum )

Closes the GoLCD library. This function should be called after your application has finished with the GoLCD library.

Parameters:
libRefNum,: IN: Reference number of the GoLCD library.
Return values:
Err The error code returned from the library. If this is errNone, the function was sucessful.
 err = GoLcdLibClose(gGoLcdLibRefNum);
 if( err == errNone )
     err = SysLibRemove(gGoLcdLibRefNum);

See also:
GoLcdLibOpen

Err GoLcdLibOpen ( UInt16 libRefNum )

Opens the GoLCD library. This function should be called prior to calling the other GoLCD functions.

Parameters:
libRefNum,: IN: Reference number of the GoLCD library.
Return values:
Err The error code returned from the library. If this is errNone, the function was sucessful.
 UInt16 gGoLcdLibRefNum = 0;
 err = SysLibFind(goLcdLibName, &gGoLcdLibRefNum);
 if( err == sysErrLibNotFound )
 {
     err = SysLibLoad(goLcdLibType, goLcdLibCreator, &gGoLcdLibRefNum);
         if( !err ) {
             err = GoLcdLibOpen(gGoLcdLibRefNum);
         }
 }

See also:
GoLcdLibClose

void GoLcdSetBounds | ( | UInt16 | libRefNum,
 |  | RectangleType * | rectP
 | ) |  |

Sets the bounds defined for use with GoLCD.

Parameters:
libRefNum,: IN: Reference number of the GoLCD library.
rectP,: IN: Points to the rectangle value to set.
Remarks:
GoLCD ignores any succession of pen events (a series of penDownEvents followed by a penUpEvent) if the initial penDownEvent occurs outside its bounds. By default, its bounds are the entire display and users can start drawing full-screen writing characters anywhere except for the right-most scroll bar and the menu bar area.
 RectangleType gNewBounds = { { 0, 0 } , { 50, 50 } };
 GoLcdGetBounds(gGoLcdLibRefNum, &gNewBounds);

See also:
GoLcdGetBounds

void GoLcdSetGsiState | ( | UInt16 | libRefNum,
 |  | GoLcdGsiStateType | state,
 |  | GoLcdColorModeType | colorMode,
 |  | RGBColorType * | rgbP
 | ) |  |

Sets the GSI state associated with GoLCD.

Parameters:
libRefNum,: IN: Reference number of the GoLCD library.
state,: IN: Sets the GoLCD GSI state.
colorMode,: IN: Sets the GoLCD color mode for GSI.
rgbP,: IN: Valid only if colorMode is set to goLcdColorOverride. Points to an RGB color value corresponding to the current color used for inking. (The RGBColorType is defined in the header file Bitmap.h.)
Remarks:
In normal operation, the GSI is drawn in the lower-right portion of the screen when the user enters the shift keystroke. The functionality of the GSI can be changed into an enable and disable control for GoLCD. This function determines whether the GSI is converted into a GoLCD control. This setting will apply to all GSIs in any active form.
 RGBColorType gNewColor = { 0, 255, 0, 0}; // Red
 GoLcdSetGsiState(gGoLcdLibRefNum, goLcdGsiOverride, goLcdColorOverride, &gNewColor);

See also:
GoLcdGetGsiState

void GoLcdSetInkState | ( | UInt16 | libRefNum,
 |  | GoLcdInkStateType | state,
 |  | GoLcdColorModeType | colorMode,
 |  | RGBColorType * | rgbP
 | ) |  |

Sets the state of GoLCD inking.

Parameters:
libRefNum,: IN: Reference number of the GoLCD library.
state,: IN: Sets the new GoLCD ink state.
colorMode,: IN: Sets the new GoLCD color mode for ink.
rgbP,: IN: Valid only if colorMode is set to goLcdColorOverride. Points to an RGB color value corresponding to the current color used for inking. (The RGBColorType is defined in the header file Bitmap.h.)
Remarks:
Inking, also known as echoing, refers to the drawing of Graffiti 2 strokes in the application area of the display.
 RGBColorType gNewColor = { 0, 255, 0, 0}; // Red
 GoLcdSetInkState(gGoLcdLibRefNum, goLcdInkEnabled, goLcdColorOverride, &gNewColor);

See also:
GoLcdGetInkState

GoLcdStatusType GoLcdSetStatus | ( | UInt16 | libRefNum,
 |  | GoLcdStatusType | status
 | ) |  |

Enables or disables the GoLCD functionality.

Parameters:
libRefNum,: IN: Reference number of the GoLCD library.
status IN: Sets the new GoLCD status.
Return values:
GoLcdStatusType Returns the previous GoLCD status.
 GoLcdStatusType gPreviousGoLcdStatus = goLcdNotAvailable;
 gPreviousGoLcdStatus = GoLcdSetStatus(gGoLcdLibRefNum, goLcdEnabled);

See also:
GoLcdGetStatus

UInt32 GoLcdSetTimeout | ( | UInt16 | libRefNum,
 |  | GoLcdModeType | mode,
 |  | UInt32 | ticks
 | ) |  |

Sets the length, in system ticks, of the time-out value of GoLCD.

Parameters:
libRefNum,: IN: Reference number of the GoLCD library.
mode,: IN: Specifies the GoLCD mode.
ticks,: IN: The new time-out length in system ticks.
Return values:
UInt32 Returns the length (in system ticks) of the previous time-out value.
Remarks:
GoLCD starts in goLcdPenTapMode. When a penDownEvent is received, a timer is started. If a penUpEvent is received before the timer reaches the time-out value for this mode, the pen events are passed on to the event handler for the application control. Otherwise, if the pen events exceed the time-out value and the x, y coordinates change significantly, GoLCD enters goLcdGraffitiMode and treats the pen events as a Graffiti 2 stroke.
The default time-out value for goLcdPenTapMode is 15 system ticks, or 150 milliseconds.
When it enters goLcdGraffitiMode, GoLCD continuously interprets all pen events as Graffiti 2 strokes. There is a time-out value associated with goLcdGraffitiMode, however. If it does not receive a new pen event within the allotted time, it returns to goLcdPenTapMode.
The default time-out value for goLcdGraffitiMode is 150 system ticks, or 1500 milliseconds.
 UInt32 gPreviousTimeout = GoLcdSetTimeout(gGoLcdLibRefNum, goLcdPenTapMode, 100);

See also:
GoLcdGetTimeout

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:07:42 2008 for Palm API Guide


Header Files » Incs » common » system

PalmGoLCDCommon.h File Reference

Detailed Description

Public common header file for the GoLCD Library.

Version:
1.0
This file contains the library constants and structures that hold different states of the fullscreen feature, graffiti indicators, inking and the colors.

Definition in file PalmGoLCDCommon.h.

Include dependency graph for PalmGoLCDCommon.h:

Go to the source code of this file.

Defines

  • #define goLcdCreator 'GAny'
  • #define goLcdFtrNumVersion 0
  • #define goLcdNotifyStatusEvent 'GAny'
  • #define goLcdGraffitiMode 0
  • #define goLcdPenTapMode 1
  • #define goLcdModeCount 2
  • #define goLcdGsiNormal 0
  • #define goLcdGsiOverride 1
  • #define goLcdColorDefault 0
  • #define goLcdColorOverride 1
  • #define goLcdColorInverted 2
  • #define GoLcdLibAPIVersion (sysMakeROMVersion(3, 6, 0, sysROMStageBeta, 0))
Library Constants
  • #define goLcdLibName "GoLcdLib"
  • #define goLcdLibType 'libr'
  • #define goLcdLibCreator 'GAny'
  • #define goLcdLibFtrNum 0
Feature Status
  • #define goLcdNotAvailable -1
  • #define goLcdDisabled 0
  • #define goLcdEnabled 1
Ink States
  • #define goLcdInkDisabled 0
  • #define goLcdInkEnabled 1
Function Traps
  • #define kGoLcdLibTrapOpen sysLibTrapOpen
  • #define kGoLcdLibTrapClose sysLibTrapClose
  • #define kGoLcdLibTrapGetStatus (sysLibTrapCustom)
  • #define kGoLcdLibTrapSetStatus (sysLibTrapCustom+1)
  • #define kGoLcdLibTrapGetInkState (sysLibTrapCustom+2)
  • #define kGoLcdLibTrapSetInkState (sysLibTrapCustom+3)
  • #define kGoLcdLibTrapGetTimeout (sysLibTrapCustom+4)
  • #define kGoLcdLibTrapSetTimeout (sysLibTrapCustom+5)
  • #define kGoLcdLibTrapGetBounds (sysLibTrapCustom+6)
  • #define kGoLcdLibTrapSetBounds (sysLibTrapCustom+7)
  • #define kGoLcdLibTrapGetGsiState (sysLibTrapCustom+8)
  • #define kGoLcdLibTrapSetGsiState (sysLibTrapCustom+9)

Typedefs

  • typedef Int32 GoLcdStatusType
  • typedef Int32 GoLcdInkStateType
  • typedef UInt32 GoLcdModeType
  • typedef UInt32 GoLcdGsiStateType
  • typedef UInt32 GoLcdColorModeType

Define Documentation

#define goLcdColorDefault 0

Use the default color scheme.

Definition at line 145 of file PalmGoLCDCommon.h.

#define goLcdColorInverted 2

Use only with ink color. Inverts the color of the display area beneath the Graffiti 2 stroke.

Definition at line 147 of file PalmGoLCDCommon.h.

#define goLcdColorOverride 1

Use the specified color (passed in as a separate argument).

Definition at line 146 of file PalmGoLCDCommon.h.

#define goLcdCreator 'GAny'

Feature creator ID

Definition at line 53 of file PalmGoLCDCommon.h.

#define goLcdDisabled 0

GoLCD functionality is disabled.

Definition at line 74 of file PalmGoLCDCommon.h.

#define goLcdEnabled 1

GoLCD functionality is enabled.

Definition at line 75 of file PalmGoLCDCommon.h.

#define goLcdFtrNumVersion 0

Current version of the supported features

Definition at line 54 of file PalmGoLCDCommon.h.

#define goLcdGraffitiMode 0

When it enters goLcdGraffitiMode, GoLCD continuously interprets all pen events as Graffiti 2 strokes. There is a timeout value associated with goLcdGraffitiMode, however. If it does not receive a new pen event within the allotted time, it returns to goLcdPenTapMode.
The default time-out value for goLcdGraffitiMode is 150 system ticks, or 1500 milliseconds.

Definition at line 108 of file PalmGoLCDCommon.h.

#define goLcdGsiNormal 0

GSI is handled as normal.

Definition at line 135 of file PalmGoLCDCommon.h.

#define goLcdGsiOverride 1

GoLCD overrides the GSI with its own control.

Definition at line 136 of file PalmGoLCDCommon.h.

#define goLcdInkDisabled 0

GoLCD inking is disabled.

Definition at line 88 of file PalmGoLCDCommon.h.

#define goLcdInkEnabled 1

GoLCD inking is enabled.

Definition at line 89 of file PalmGoLCDCommon.h.

#define GoLcdLibAPIVersion (sysMakeROMVersion(3, 6, 0, sysROMStageBeta, 0))

Current library version

Definition at line 170 of file PalmGoLCDCommon.h.

#define goLcdLibCreator 'GAny'

GoLCD creator ID.

Definition at line 49 of file PalmGoLCDCommon.h.

#define goLcdLibFtrNum 0

GoLCd feature number.

Definition at line 50 of file PalmGoLCDCommon.h.

#define goLcdLibName "GoLcdLib"

GoLCD library name.

Definition at line 47 of file PalmGoLCDCommon.h.

#define goLcdLibType 'libr'

GoLCD library type.

Definition at line 48 of file PalmGoLCDCommon.h.

#define goLcdModeCount 2

Two modes are currently supported

Definition at line 126 of file PalmGoLCDCommon.h.

#define goLcdNotAvailable -1

GoLCD not available on this device.

Definition at line 73 of file PalmGoLCDCommon.h.

#define goLcdNotifyStatusEvent 'GAny'

Notification code that applications can register for when the status of Full Screen Writing (GoLCD) is changed.

Definition at line 60 of file PalmGoLCDCommon.h.

#define goLcdPenTapMode 1

GoLCD starts in goLcdPenTapMode. When a penDownEvent is received, a timer is started. If a penUpEvent is received before the timer reaches the time-out value for this mode, the pen events are passed on to the event-handler for the application control. Otherwise, if the pen events exceed the time-out value and the x, y coordinates change significantly, GoLCD enters goLcdGraffitiMode and treats the pen events as a Graffiti 2 stroke.
The default time-out value for goLcdPenTapMode is 15 system ticks, or 150 milliseconds.

Definition at line 123 of file PalmGoLCDCommon.h.

#define kGoLcdLibTrapClose sysLibTrapClose

Definition at line 155 of file PalmGoLCDCommon.h.

#define kGoLcdLibTrapGetBounds (sysLibTrapCustom+6)

Definition at line 163 of file PalmGoLCDCommon.h.

#define kGoLcdLibTrapGetGsiState (sysLibTrapCustom+8)

Definition at line 165 of file PalmGoLCDCommon.h.

#define kGoLcdLibTrapGetInkState (sysLibTrapCustom+2)

Definition at line 159 of file PalmGoLCDCommon.h.

#define kGoLcdLibTrapGetStatus (sysLibTrapCustom)

Definition at line 157 of file PalmGoLCDCommon.h.

#define kGoLcdLibTrapGetTimeout (sysLibTrapCustom+4)

Definition at line 161 of file PalmGoLCDCommon.h.

#define kGoLcdLibTrapOpen sysLibTrapOpen

Definition at line 154 of file PalmGoLCDCommon.h.

#define kGoLcdLibTrapSetBounds (sysLibTrapCustom+7)

Definition at line 164 of file PalmGoLCDCommon.h.

#define kGoLcdLibTrapSetGsiState (sysLibTrapCustom+9)

Definition at line 166 of file PalmGoLCDCommon.h.

#define kGoLcdLibTrapSetInkState (sysLibTrapCustom+3)

Definition at line 160 of file PalmGoLCDCommon.h.

#define kGoLcdLibTrapSetStatus (sysLibTrapCustom+1)

Definition at line 158 of file PalmGoLCDCommon.h.

#define kGoLcdLibTrapSetTimeout (sysLibTrapCustom+5)

Definition at line 162 of file PalmGoLCDCommon.h.

Typedef Documentation

typedef UInt32 GoLcdColorModeType

GoLCD Color Mode. One of the following: goLcdColorDefault, goLcdColorOverride, goLcdColorInverted

Definition at line 143 of file PalmGoLCDCommon.h.

typedef UInt32 GoLcdGsiStateType

GoLCD GSI State. One of the following: goLcdGsiNormal, goLcdGsiOverride

Definition at line 133 of file PalmGoLCDCommon.h.

typedef Int32 GoLcdInkStateType

GoLCD Ink State. One of the following: goLcdInkDisabled, goLcdInkEnabled

Definition at line 82 of file PalmGoLCDCommon.h.

typedef UInt32 GoLcdModeType

GoLCD Timeout Mode. One of the following: goLcdGraffitiMode, goLcdPenTapMode

Definition at line 96 of file PalmGoLCDCommon.h.

typedef Int32 GoLcdStatusType

GoLCD Status. One of the following: goLcdNotAvailable, goLcdDisabled, goLcdEnabled

Definition at line 67 of file PalmGoLCDCommon.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:07:42 2008 for Palm API Guide


Header Files » Incs » 68k » system

PalmHiResTime.h File Reference

Detailed Description

Exported High Resolution timer definitions.

Version:
1.0

Definition in file PalmHiResTime.h.

Include dependency graph for PalmHiResTime.h:

Go to the source code of this file.

Defines

  • #define CAM_LIB_TRAP(trapNum) SYS_TRAP(trapNum)
  • #define kHiResTimeLibName "HRTimer-Lib"
  • #define kHiResTimeErrorClass (oemErrorClass + 0x100)
Type and creator of the Library
  • #define kHiResTimeLibType 'libr'
  • #define kHiResTimeLibCreator 'pHRT'
Library versionning
  • #define kHiResTimeLibVersion1 sysMakeROMVersion(1, 0, 0, sysROMStageRelease, 0)
  • #define kHiResTimeLibVersion kCamLibVersion1
Library trap
  • #define kHRLibTrapTimerTicksPerSecond (sysLibTrapCustom)
  • #define kHRLibTrapTimerGetTime (sysLibTrapCustom+1)

Functions

  • Err HRTimeLibOpen (UInt16 refNum)
    Standard library open function.
  • Err HRTimeLibClose (UInt16 refNum)
    Standard library close function.
  • Err HRTimeLibTicksPerSecond (UInt16 refNum, UInt32 *ticksP)
    Custom library API functions.
  • Err HRTimeLibGetTime (UInt16 refNum, UInt32 *ticksP, UInt32 *rolloverP)
    Parameters:
    refNum,: IN:

Define Documentation

#define CAM_LIB_TRAP ( trapNum ) SYS_TRAP(trapNum)

Definition at line 36 of file PalmHiResTime.h.

#define kHiResTimeErrorClass (oemErrorClass + 0x100)

HiRes Timer result codes

Definition at line 61 of file PalmHiResTime.h.

#define kHiResTimeLibCreator 'pHRT'

database creator

Definition at line 45 of file PalmHiResTime.h.

#define kHiResTimeLibName "HRTimer-Lib"

Internal library name which can be passed to SysLibFind()

Definition at line 49 of file PalmHiResTime.h.

#define kHiResTimeLibType 'libr'

database type

Definition at line 44 of file PalmHiResTime.h.

#define kHiResTimeLibVersion kCamLibVersion1

Definition at line 57 of file PalmHiResTime.h.

#define kHiResTimeLibVersion1 sysMakeROMVersion(1, 0, 0, sysROMStageRelease, 0)

Definition at line 56 of file PalmHiResTime.h.

#define kHRLibTrapTimerGetTime (sysLibTrapCustom+1)

Definition at line 69 of file PalmHiResTime.h.

#define kHRLibTrapTimerTicksPerSecond (sysLibTrapCustom)

Definition at line 68 of file PalmHiResTime.h.

Function Documentation

Err HRTimeLibClose ( UInt16 refNum )

Standard library close function.

Parameters:
refNum,: IN:
Return values:
Err error code.

Err HRTimeLibGetTime | ( | UInt16 | refNum,
 |  | UInt32 * | ticksP,
 |  | UInt32 * | rolloverP
 | ) |  |

Parameters:
refNum,: IN:

Parameters:
*ticksP,: IN:
*rolloverP,: IN:
Return values:
Err error code.

Err HRTimeLibOpen ( UInt16 refNum )

Standard library open function.

Parameters:
refNum,: IN:
Return values:
Err error code.

Err HRTimeLibTicksPerSecond | ( | UInt16 | refNum,
 |  | UInt32 * | ticksP
 | ) |  |

Custom library API functions.

Parameters:
refNum,: IN:
*ticksP,: IN:
Return values:
Err error code.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:07:42 2008 for Palm API Guide


Header Files » Incs » 68k » system

PalmLaunchCodes.h File Reference

Detailed Description

Device specific launch codes.

Version:
1.0
Date:
03/20/2003

Definition in file PalmLaunchCodes.h.

Include dependency graph for PalmLaunchCodes.h:

Go to the source code of this file.

Data Structures

  • struct DevAppLaunchCmdGenericCallType
    For devAppLaunchCmdGenericCall. More...

Defines

Launch commands
  • #define devAppLaunchCmdCustomBase (sysAppLaunchCmdCustomBase + 1)
  • #define devAppLaunchCmdGenericCall (devAppLaunchCmdCustomBase + 1)
  • #define devAppLaunchCmdIncomingCall (devAppLaunchCmdCustomBase + 2)
  • #define devAppLaunchCmdCallerId (devAppLaunchCmdCustomBase + 3)
  • #define devAppLaunchCmdTelPowerOn (devAppLaunchCmdCustomBase + 4)
  • #define devAppLaunchMyFavorite (devAppLaunchCmdCustomBase + 4)
  • #define devAppLaunchCmdIncomingCallTest (devAppLaunchCmdCustomBase + 5)
  • #define devAppLaunchCmdSliderOpened (devAppLaunchCmdCustomBase + 6)
  • #define devAppLaunchCmdSliderClosed (devAppLaunchCmdCustomBase + 7)
  • #define devAppLaunchLauncherDUBegin (devAppLaunchCmdCustomBase + 8)
  • #define devAppLaunchLauncherDUEnd (devAppLaunchCmdCustomBase + 9)
  • #define devAppLaunchLPCM_DUBegin (devAppLaunchCmdCustomBase + 10)
  • #define devAppLaunchLPCM_DUEnd (devAppLaunchCmdCustomBase + 11)
  • #define devAppLaunchWithCodeCheck (devAppLaunchCmdCustomBase + 12)
  • #define sysAppLaunchCmdFromSetupApp (devAppLaunchCmdCustomBase + 13)
Applicable operation code values:
  • #define devAppLaunchGenericCallOpSubcall ((UInt8)1)
  • #define devAppLaunchGenericCallOpExit ((UInt8)2)
  • #define devAppLaunchGenericCallOpReturn ((UInt8)3)
  • #define devAppLaunchGenericCallOpCustomBase ((UInt8)0x80)
Applicable response code values:
  • #define devAppLaunchGenericCallRetAccepted ((UInt8)1)
  • #define devAppLaunchGenericCallRetRejected ((UInt8)2)

Define Documentation

#define devAppLaunchCmdCallerId (devAppLaunchCmdCustomBase + 3)

Definition at line 40 of file PalmLaunchCodes.h.

#define devAppLaunchCmdCustomBase (sysAppLaunchCmdCustomBase + 1)

Custom action code base

Definition at line 36 of file PalmLaunchCodes.h.

#define devAppLaunchCmdGenericCall (devAppLaunchCmdCustomBase + 1)

Used when an application wants to launch another application, then to be re-launched when the service is finished

Definition at line 38 of file PalmLaunchCodes.h.

#define devAppLaunchCmdIncomingCall (devAppLaunchCmdCustomBase + 2)

Definition at line 39 of file PalmLaunchCodes.h.

#define devAppLaunchCmdIncomingCallTest (devAppLaunchCmdCustomBase + 5)

Definition at line 43 of file PalmLaunchCodes.h.

#define devAppLaunchCmdSliderClosed (devAppLaunchCmdCustomBase + 7)

Definition at line 45 of file PalmLaunchCodes.h.

#define devAppLaunchCmdSliderOpened (devAppLaunchCmdCustomBase + 6)

Definition at line 44 of file PalmLaunchCodes.h.

#define devAppLaunchCmdTelPowerOn (devAppLaunchCmdCustomBase + 4)

Definition at line 41 of file PalmLaunchCodes.h.

#define devAppLaunchGenericCallOpCustomBase ((UInt8)0x80)

custom operation code base (custom codes begin at this value)

Definition at line 77 of file PalmLaunchCodes.h.

#define devAppLaunchGenericCallOpExit ((UInt8)2)

the launched code resource replies that it won't launch the caller back

Definition at line 75 of file PalmLaunchCodes.h.

#define devAppLaunchGenericCallOpReturn ((UInt8)3)

the sub-call is finished, the launched code resource is ready to launch the caller back

Definition at line 76 of file PalmLaunchCodes.h.

#define devAppLaunchGenericCallOpSubcall ((UInt8)1)

the sender wishes to launch the handler

Definition at line 74 of file PalmLaunchCodes.h.

#define devAppLaunchGenericCallRetAccepted ((UInt8)1)

request accepted by the handler

Definition at line 85 of file PalmLaunchCodes.h.

#define devAppLaunchGenericCallRetRejected ((UInt8)2)

request rejected by the handler

Definition at line 86 of file PalmLaunchCodes.h.

#define devAppLaunchLauncherDUBegin (devAppLaunchCmdCustomBase + 8)

Definition at line 46 of file PalmLaunchCodes.h.

#define devAppLaunchLauncherDUEnd (devAppLaunchCmdCustomBase + 9)

Definition at line 47 of file PalmLaunchCodes.h.

#define devAppLaunchLPCM_DUBegin (devAppLaunchCmdCustomBase + 10)

Definition at line 48 of file PalmLaunchCodes.h.

#define devAppLaunchLPCM_DUEnd (devAppLaunchCmdCustomBase + 11)

Definition at line 49 of file PalmLaunchCodes.h.

#define devAppLaunchMyFavorite (devAppLaunchCmdCustomBase + 4)

Definition at line 42 of file PalmLaunchCodes.h.

#define devAppLaunchWithCodeCheck (devAppLaunchCmdCustomBase + 12)

Definition at line 50 of file PalmLaunchCodes.h.

#define sysAppLaunchCmdFromSetupApp (devAppLaunchCmdCustomBase + 13)

Used to lock a Panel (panel cannot stop except with Done)

Definition at line 51 of file PalmLaunchCodes.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:07:43 2008 for Palm API Guide


Header Files » Incs » 68k » system

PalmLcdOverlay.h File Reference

Detailed Description

Exported LCD Overlay functions.

Version:
1.0

Definition in file PalmLcdOverlay.h.

Include dependency graph for PalmLcdOverlay.h:

Go to the source code of this file.

Data Structures

  • struct LcdOverlayLibSettingTag
    Generic settings For settings without manual values, only type is used. More...

Defines

To Define when building the library
  • #define OVLY_LIB_TRAP(trapNum) SYS_TRAP(trapNum)
Type and creator of the Library
  • #define kLcdOverlayLibType 'libr'
  • #define kLcdOverlayLibCreator 'Povl'
Internal library name which can be passed to SysLibFind()
  • #define kLcdOverlayLibName "LcdOverlayManager"
Library versionning
  • #define kLcdOverlayLibVersion1 sysMakeROMVersion(1, 0, 0, sysROMStageRelease, 0)
  • #define kLcdOverlayLibVersion kLcdOverlayLibVersion1
LCD Overlay result codes
(appErrorClass is reserved for 3rd party apps/libraries. It is defined in SystemMgr.h)

  • #define kLcdOverlayLibErrorClass (oemErrorClass + 0x200)
  • #define kLcdOverlayLibErrBadParam (kLcdOverlayLibErrorClass | 0x01)
  • #define kLcdOverlayLibErrNoMemory (kLcdOverlayLibErrorClass | 0x02)
  • #define kLcdOverlayLibErrNotOpen (kLcdOverlayLibErrorClass | 0x03)
  • #define kLcdOverlayLibErrStillOpen (kLcdOverlayLibErrorClass | 0x04)
  • #define kLcdOverlayLibErrInternal (kLcdOverlayLibErrorClass | 0x05)
  • #define kLcdOverlayLibErrNotSupported (kLcdOverlayLibErrorClass | 0x06)
  • #define kLcdOverlayLibErrNotCompatible (kLcdOverlayLibErrorClass | 0x07)
Command definition
  • #define kLcdOverlayLibCtrlFormatSet 0x01
  • #define kLcdOverlayLibCtrlFormatGet 0x02
  • #define kLcdOverlayLibCtrlFormatQuery 0x03
  • #define kLcdOverlayLibCtrlRectSet 0x04
  • #define kLcdOverlayLibCtrlRectGet 0x05
  • #define kLcdOverlayLibCtrlStart 0x06
  • #define kLcdOverlayLibCtrlDraw 0x07
  • #define kLcdOverlayLibCtrlStop 0x08
Overlay data format
  • #define kLcdOverlayLibDataFormatYCbCr444 0x02
  • #define kLcdOverlayLibDataFormatYCbCr422 0x04
  • #define kLcdOverlayLibDataFormatYCbCr420 0x08
  • #define kLcdOverlayLibDataFormatYCbCr444Planar 0x10
  • #define kLcdOverlayLibDataFormatYCbCr422Planar 0x20
  • #define kLcdOverlayLibDataFormatYCbCr420Planar 0x40
  • #define kLcdOverlayLibDataFormatRGB565 0x80
Library trap
  • #define kLcdOverlayLibTrapGetVersion (sysLibTrapCustom + 0)
  • #define kLcdOverlayLibTrapControl (sysLibTrapCustom + 1)

Typedefs

  • typedef UInt16 LcdOverlayLibControlType
  • typedef LcdOverlayLibSettingTag LcdOverlayLibSettingType
    Generic settings For settings without manual values, only type is used.
  • typedef LcdOverlayLibSettingTag LcdOverlayLibFormatType

Functions

  • Err LcdOverlayLibOpen (UInt16 refNum)
    Standard library open function.
  • Err LcdOverlayLibClose (UInt16 refNum)
    Standard library close function.
  • Err LcdOverlayLibSleep (UInt16 refNum)
    Parameters:
    refNum,: IN:

  • Err LcdOverlayLibWake (UInt16 refNum)
    Parameters:
    refNum,: IN:

  • Err LcdOverlayLibGetVersion (UInt16 refNum, UInt32 sdkVersion, UInt32 *libVersionP)
    Custom library API functions.
  • Err LcdOverlayLibControl (UInt16 refNum, LcdOverlayLibControlType cmdId, void *parameterP)
    Parameters:
    refNum,: IN:

Define Documentation

#define kLcdOverlayLibCreator 'Povl'

database creator

Definition at line 51 of file PalmLcdOverlay.h.

#define kLcdOverlayLibCtrlDraw 0x07

Parameter as void*

Definition at line 105 of file PalmLcdOverlay.h.

#define kLcdOverlayLibCtrlFormatGet 0x02

Parameter as LcdOverlayLibFormatType*

Definition at line 98 of file PalmLcdOverlay.h.

#define kLcdOverlayLibCtrlFormatQuery 0x03

Parameter as LcdOverlayLibFormatType*

Definition at line 99 of file PalmLcdOverlay.h.

#define kLcdOverlayLibCtrlFormatSet 0x01

Parameter as LcdOverlayLibFormatType*

Definition at line 97 of file PalmLcdOverlay.h.

#define kLcdOverlayLibCtrlRectGet 0x05

Parameter as RectangleType* (low res coords)

Definition at line 102 of file PalmLcdOverlay.h.

#define kLcdOverlayLibCtrlRectSet 0x04

Parameter as RectangleType* (low res coords)

Definition at line 101 of file PalmLcdOverlay.h.

#define kLcdOverlayLibCtrlStart 0x06

No parameter

Definition at line 104 of file PalmLcdOverlay.h.

#define kLcdOverlayLibCtrlStop 0x08

No parameter

Definition at line 106 of file PalmLcdOverlay.h.

#define kLcdOverlayLibDataFormatRGB565 0x80

Definition at line 140 of file PalmLcdOverlay.h.

#define kLcdOverlayLibDataFormatYCbCr420 0x08

Definition at line 134 of file PalmLcdOverlay.h.

#define kLcdOverlayLibDataFormatYCbCr420Planar 0x40

Definition at line 138 of file PalmLcdOverlay.h.

#define kLcdOverlayLibDataFormatYCbCr422 0x04

Definition at line 133 of file PalmLcdOverlay.h.

#define kLcdOverlayLibDataFormatYCbCr422Planar 0x20

Definition at line 137 of file PalmLcdOverlay.h.

#define kLcdOverlayLibDataFormatYCbCr444 0x02

Definition at line 132 of file PalmLcdOverlay.h.

#define kLcdOverlayLibDataFormatYCbCr444Planar 0x10

Definition at line 136 of file PalmLcdOverlay.h.

#define kLcdOverlayLibErrBadParam (kLcdOverlayLibErrorClass | 0x01)

invalid parameter

Definition at line 79 of file PalmLcdOverlay.h.

#define kLcdOverlayLibErrInternal (kLcdOverlayLibErrorClass | 0x05)

Internal error

Definition at line 83 of file PalmLcdOverlay.h.

#define kLcdOverlayLibErrNoMemory (kLcdOverlayLibErrorClass | 0x02)

Memory error

Definition at line 80 of file PalmLcdOverlay.h.

#define kLcdOverlayLibErrNotCompatible (kLcdOverlayLibErrorClass | 0x07)

Bad Version

Definition at line 85 of file PalmLcdOverlay.h.

#define kLcdOverlayLibErrNotOpen (kLcdOverlayLibErrorClass | 0x03)

library is not open

Definition at line 81 of file PalmLcdOverlay.h.

#define kLcdOverlayLibErrNotSupported (kLcdOverlayLibErrorClass | 0x06)

Unsupported function

Definition at line 84 of file PalmLcdOverlay.h.

#define kLcdOverlayLibErrorClass (oemErrorClass + 0x200)

Definition at line 78 of file PalmLcdOverlay.h.

#define kLcdOverlayLibErrStillOpen (kLcdOverlayLibErrorClass | 0x04)

returned from LcdOverlayLibClose() if the library is still open

Definition at line 82 of file PalmLcdOverlay.h.

#define kLcdOverlayLibName "LcdOverlayManager"

Definition at line 59 of file PalmLcdOverlay.h.

#define kLcdOverlayLibTrapControl (sysLibTrapCustom + 1)

Definition at line 151 of file PalmLcdOverlay.h.

#define kLcdOverlayLibTrapGetVersion (sysLibTrapCustom + 0)

Definition at line 150 of file PalmLcdOverlay.h.

#define kLcdOverlayLibType 'libr'

database type

Definition at line 50 of file PalmLcdOverlay.h.

#define kLcdOverlayLibVersion kLcdOverlayLibVersion1

Definition at line 68 of file PalmLcdOverlay.h.

#define kLcdOverlayLibVersion1 sysMakeROMVersion(1, 0, 0, sysROMStageRelease, 0)

Definition at line 67 of file PalmLcdOverlay.h.

#define OVLY_LIB_TRAP ( trapNum ) SYS_TRAP(trapNum)

Definition at line 40 of file PalmLcdOverlay.h.

Typedef Documentation

typedef UInt16 LcdOverlayLibControlType

Definition at line 109 of file PalmLcdOverlay.h.

typedef struct LcdOverlayLibSettingTag LcdOverlayLibFormatType

Definition at line 143 of file PalmLcdOverlay.h.

typedef struct LcdOverlayLibSettingTag LcdOverlayLibSettingType

Generic settings For settings without manual values, only type is used.

Function Documentation

Err LcdOverlayLibClose ( UInt16 refNum )

Standard library close function.

Parameters:
refNum,: IN:
Return values:
Err error code.

Err LcdOverlayLibControl | ( | UInt16 | refNum,
 |  | LcdOverlayLibControlType | cmdId,
 |  | void * | parameterP
 | ) |  |

Parameters:
refNum,: IN:

Parameters:
cmdId,: IN:
parameterP,: IN:
Return values:
Err error code.

Err LcdOverlayLibGetVersion | ( | UInt16 | refNum,
 |  | UInt32 | sdkVersion,
 |  | UInt32 * | libVersionP
 | ) |  |

Custom library API functions.

Parameters:
refNum,: IN:
sdkVersion,: IN:
libVersionP,: IN:
Return values:
Err error code.

Err LcdOverlayLibOpen ( UInt16 refNum )

Standard library open function.

Parameters:
refNum,: IN:
Return values:
Err error code.

Err LcdOverlayLibSleep ( UInt16 refNum )

Parameters:
refNum,: IN:

Return values:
Err error code.

Err LcdOverlayLibWake ( UInt16 refNum )

Parameters:
refNum,: IN:

Return values:
Err error code.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:07:43 2008 for Palm API Guide


Header Files » Incs » 68k » system

PalmLED.h File Reference

Detailed Description

Palm's Generic LED dirver.

Version:
1.0
Pledlib.prc, version 1.0 This file contains the Generic LED driver defines. This driver is a standard libr driver that supports the BT notificaiton led. the interface follows the standard palm unser notification interface.

Future drivers will support multiple Led's.

NOTE: Make sure to check the version number for this driver implementation.

Definition in file PalmLED.h.

Include dependency graph for PalmLED.h:

Go to the source code of this file.

Defines

Type and creator of the Library
  • #define kPalmLedName "PalmLed"
  • #define kPalmLedType sysFileTLibrary
  • #define kPalmLedCreator 'Pled'
  • #define kPalmLedModule 195
Library version
  • #define kPalmLedVersion1 sysMakeROMVersion(1, 0, 0, sysROMStageRelease, 0)
  • #define kPalmLedVersion kPalmLedVersion1
Standard library functions
  • #define kPalmLedTrapGetAttributes (sysLibTrapCustom+0)
  • #define kPalmLedTrapSetAttributes (sysLibTrapCustom+1)
Get/Set Attribute
  • #define kHALLEDPropertyUnderSleep 10
  • #define kHALLEDPropertySleepOn 1
  • #define kHALLEDPropertySleepPattern 2
  • #define kHALLEDPropertySleepReserve 4
  • #define kHALLEDPropertySleepColorRed 8
  • #define kHALLEDPropertySleepColorGreen 0x10
  • #define kHALLEDPropertySleepColorBlue 0x20
  • #define kHALLEDPropertySleepColorAmberWhite 0x40
  • #define kHALLEDCapcityUnderSleep 11
  • #define kHALLEDCapcitySleepOn 1
  • #define kHALLEDCapcitySleepPattern 2
  • #define kHALLEDCapcitySleepPatternSetting 4
  • #define kHALLEDCapcitySleepMultiColor 8

Functions

  • Err PalmLedOpen (UInt16 refnum)
    Standard library function.
  • Err PalmLedClose (UInt16 refnum)
    Standard library function.
  • Err PalmLedSleep (UInt16 refnum)
    Standard library function.
  • Err PalmLedWake (UInt16 refnum)
    Standard library function.
  • Err HALAttnGetPalmLedAttributes (UInt16 refnum, UInt32 attr, void *dataP)
    Standard library function.
  • Err HALAttnSetPalmLedAttributes (UInt16 refnum, UInt32 attr, void *dataP)
    Standard library function.

Define Documentation

#define kHALLEDCapcitySleepMultiColor 8

bit 3 multi-color available bit 4-31 reserved

Definition at line 104 of file PalmLED.h.

#define kHALLEDCapcitySleepOn 1

dataP points to a UInt32 that indicates how flexible the LED during Sleep is, as follows: bit 0 ON during Sleep available

Definition at line 101 of file PalmLED.h.

#define kHALLEDCapcitySleepPattern 2

bit 1 pattern when sleep available.

Definition at line 102 of file PalmLED.h.

#define kHALLEDCapcitySleepPatternSetting 4

bit 2 pattern setting available

Definition at line 103 of file PalmLED.h.

#define kHALLEDCapcityUnderSleep 11

Definition at line 97 of file PalmLED.h.

#define kHALLEDPropertySleepColorAmberWhite 0x40

bit 6 - amber/white bit 7-31 reserved

Definition at line 94 of file PalmLED.h.

#define kHALLEDPropertySleepColorBlue 0x20

bit 5 - blue

Definition at line 93 of file PalmLED.h.

#define kHALLEDPropertySleepColorGreen 0x10

bit 4 - green

Definition at line 92 of file PalmLED.h.

#define kHALLEDPropertySleepColorRed 8

bit 3 - red

Definition at line 91 of file PalmLED.h.

#define kHALLEDPropertySleepOn 1

dataP points to a UInt32 that indicates how flexible the LED during Sleep is, as follows: bit 0 - ON during sleep

Definition at line 88 of file PalmLED.h.

#define kHALLEDPropertySleepPattern 2

bit 1 - pattern on

Definition at line 89 of file PalmLED.h.

#define kHALLEDPropertySleepReserve 4

bit 2 - reserve

Definition at line 90 of file PalmLED.h.

#define kHALLEDPropertyUnderSleep 10

Definition at line 84 of file PalmLED.h.

#define kPalmLedCreator 'Pled'

Definition at line 56 of file PalmLED.h.

#define kPalmLedModule 195

Definition at line 57 of file PalmLED.h.

#define kPalmLedName "PalmLed"

Definition at line 54 of file PalmLED.h.

#define kPalmLedTrapGetAttributes (sysLibTrapCustom+0)

Definition at line 74 of file PalmLED.h.

#define kPalmLedTrapSetAttributes (sysLibTrapCustom+1)

Definition at line 75 of file PalmLED.h.

#define kPalmLedType sysFileTLibrary

Definition at line 55 of file PalmLED.h.

#define kPalmLedVersion kPalmLedVersion1

Definition at line 66 of file PalmLED.h.

#define kPalmLedVersion1 sysMakeROMVersion(1, 0, 0, sysROMStageRelease, 0)

Definition at line 65 of file PalmLED.h.

Function Documentation

Err HALAttnGetPalmLedAttributes | ( | UInt16 | refnum,
 |  | UInt32 | attr,
 |  | void * | dataP
 | ) |  |

Standard library function.

Parameters:
refnum,: IN:
attr,: IN:
dataP,: IN:
Return values:
Err error code.

Err HALAttnSetPalmLedAttributes | ( | UInt16 | refnum,
 |  | UInt32 | attr,
 |  | void * | dataP
 | ) |  |

Standard library function.

Parameters:
refnum,: IN:
attr,: IN:
dataP,: IN:
Return values:
Err error code.

Err PalmLedClose ( UInt16 refnum )

Standard library function.

Parameters:
refnum,: IN:
Return values:
Err error code.

Err PalmLedOpen ( UInt16 refnum )

Standard library function.

Parameters:
refnum,: IN:
Return values:
Err error code.

Err PalmLedSleep ( UInt16 refnum )

Standard library function.

Parameters:
refnum,: IN:
Return values:
Err error code.

Err PalmLedWake ( UInt16 refnum )

Standard library function.

Parameters:
refnum,: IN:
Return values:
Err error code.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:07:43 2008 for Palm API Guide


Header Files » Incs » 68k » system

PalmNative.h File Reference

Detailed Description

Functions and macros to help building ARM code.

Version:
1.0
Date:
10/28/2002

Definition in file PalmNative.h.

Go to the source code of this file.

Defines

  • #define NATIVE_CODE
  • #define INLINE inline
  • #define NULL 0
  • #define false 0
  • #define true 1

Typedefs

  • typedef unsigned char UInt8
  • typedef unsigned short UInt16
  • typedef unsigned long UInt32
  • typedef signed char Int8
  • typedef signed short Int16
  • typedef signed long Int32
  • typedef signed char Char
  • typedef unsigned char Boolean
  • typedef UInt16 Err

Define Documentation

#define false 0

Definition at line 42 of file PalmNative.h.

#define INLINE inline

Definition at line 31 of file PalmNative.h.

#define NATIVE_CODE

Definition at line 30 of file PalmNative.h.

#define NULL 0

Definition at line 47 of file PalmNative.h.

#define true 1

Definition at line 43 of file PalmNative.h.

Typedef Documentation

typedef unsigned char Boolean

Definition at line 59 of file PalmNative.h.

typedef signed char Char

Definition at line 57 of file PalmNative.h.

typedef UInt16 Err

Definition at line 60 of file PalmNative.h.

typedef signed short Int16

Definition at line 55 of file PalmNative.h.

typedef signed long Int32

Definition at line 56 of file PalmNative.h.

typedef signed char Int8

Definition at line 54 of file PalmNative.h.

typedef unsigned short UInt16

Definition at line 51 of file PalmNative.h.

typedef unsigned long UInt32

Definition at line 52 of file PalmNative.h.

typedef unsigned char UInt8

Definition at line 50 of file PalmNative.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:07:43 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » network

PalmNetServices.h File Reference

Detailed Description

NetServices provides a set of API to access 802.11.

Version:
1.0

Definition in file PalmNetServices.h.

Go to the source code of this file.

Data Structures

  • struct Net80211DeviceInfo
    Device information concerning Hardware and Firmware information for the "adapter". More...
  • struct NetServicesProfileInfo
    Data returned from NetServicesProfileGetInfo. More...
  • struct NetServicesProfile
    Profile entries for SmartConnect. More...
  • struct NetServicesProfileV1
    Profile entries version 1. More...
  • struct NetServicesProfileOrder
    Priority order to smart connect. More...

Defines

  • #define ShlLibName "NetServLib"
  • #define ShlCreatorID 'NETs'
  • #define ShlLibType 'libr'
  • #define kNetDriverDateLength 16
  • #define kNetFWNameLength 16
  • #define kNetSerialNumberLength 16
  • #define MAX_ACTIVE_PROFILES 32
  • #define END_OF_LIST 0xFFFF
  • #define PRIORITY_LIST_SIZE (sizeof(UInt16) * (MAX_ACTIVE_PROFILES + 1))
  • #define INVALID_INDEX 0xFFFF
Function Trap Numbers
  • #define NetServicesLibTrapGetHWAddr (sysLibTrapCustom+0)
  • #define NetServicesLibTrapStartScan (sysLibTrapCustom+1)
  • #define NetServicesLibTrapGetScanResults (sysLibTrapCustom+2)
  • #define NetServicesLibTrapGetChannel (sysLibTrapCustom+3)
  • #define NetServicesLibTrapGetPowerState (sysLibTrapCustom+4)
  • #define NetServicesLibTrapGetCommsQuality (sysLibTrapCustom+5)
  • #define NetServicesLibTrapSetRadioState (sysLibTrapCustom+6)
  • #define NetServicesLibTrapGetRadioState (sysLibTrapCustom+7)
  • #define NetServicesLibTrapGetDeviceInfo (sysLibTrapCustom+10)
  • #define NetServicesLibTrapGetChannelList (sysLibTrapCustom+11)
  • #define NetServicesLibTrapProfileGetInfo (sysLibTrapCustom+0x10)
  • #define NetServicesLibTrapProfileRead (sysLibTrapCustom+0x11)
  • #define NetServicesLibTrapProfileWrite (sysLibTrapCustom+0x12)
  • #define NetServicesLibTrapProfileAdd (sysLibTrapCustom+0x13)
  • #define NetServicesLibTrapProfileDelete (sysLibTrapCustom+0x14)
  • #define NetServicesLibTrapProfileSetOrder (sysLibTrapCustom+0x15)
  • #define NetServicesLibTrapProfileGetOrder (sysLibTrapCustom+0x16)
  • #define NetServicesLibTrapProfileFind (sysLibTrapCustom+0x17)

Typedefs

  • typedef Net80211DeviceInfo * Net80211DeviceInfoP
    Device information concerning Hardware and Firmware information for the "adapter".
  • typedef NetServicesProfileInfo * NetServicesProfileInfoP
    Data returned from NetServicesProfileGetInfo.
  • typedef NetServicesProfile * NetServicesProfileP
    Profile entries for SmartConnect.
  • typedef NetServicesProfileV1 * NetServicesProfileV1P
    Profile entries version 1.
  • typedef NetServicesProfileOrder * NetServicesProfileOrderP
    Priority order to smart connect.

Functions

  • Err NetServicesGetHWAddr (UInt16 refnum, UInt8 *hwAddrP)
  • Err NetServicesStartScan (UInt16 refnum)
  • Err NetServicesGetScanResults (UInt16 refnum, UInt8 *scanResultsP, UInt32 *scanBufSizeP)
  • Err NetServicesGetChannel (UInt16 refnum, UInt16 *channelP)
  • Err NetServicesGetPowerState (UInt16 refnum, UInt16 *modeP)
  • Err NetServicesGetCommsQuality (UInt16 refNum, UInt8 *strengthP, UInt8 *qualityP)
  • Err NetServicesSetRadioState (UInt16 refNum, UInt32 enable)
  • Err NetServicesGetRadioState (UInt16 libRef, UInt32 *radioStateP)
  • Err NetServicesGetDeviceInfo (UInt16 refNum, Net80211DeviceInfoP storageP)
  • Err NetServicesGetChannelList (UInt16 refNum, UInt16 *channelP)
  • Err NetServicesProfileGetInfo (UInt16 libRef, NetServicesProfileInfoP infoP)
  • Err NetServicesProfileRead (UInt16 libRef, UInt16 profIndex, NetServicesProfileP profileP)
  • Err NetServicesProfileWrite (UInt16 libRef, UInt16 profIndex, NetServicesProfileP profileP)
  • Err NetServicesProfileDelete (UInt16 libRef, UInt16 profIndex)
  • Err NetServicesProfileAdd (UInt16 libRef, NetServicesProfileP profileP)
  • Err NetServicesProfileSetOrder (UInt16 libRef, NetServicesProfileOrderP orderP)
  • Err NetServicesProfileGetOrder (UInt16 libRef, NetServicesProfileOrderP orderP)
  • UInt16 NetServicesProfileFind (UInt16 libRef, Char *profNameP)

Define Documentation

#define END_OF_LIST 0xFFFF

End of list marker.

Definition at line 164 of file PalmNetServices.h.

#define INVALID_INDEX 0xFFFF

Invalid index tag.

Definition at line 166 of file PalmNetServices.h.

#define kNetDriverDateLength 16

Length for the driver date info string.

Definition at line 76 of file PalmNetServices.h.

#define kNetFWNameLength 16

Length for the firmware name info string.

Definition at line 77 of file PalmNetServices.h.

#define kNetSerialNumberLength 16

Length for the serial number info string.

Definition at line 78 of file PalmNetServices.h.

#define MAX_ACTIVE_PROFILES 32

Maximum number of profiles.

Definition at line 163 of file PalmNetServices.h.

#define NetServicesLibTrapGetChannel (sysLibTrapCustom+3)

Definition at line 42 of file PalmNetServices.h.

#define NetServicesLibTrapGetChannelList (sysLibTrapCustom+11)

Definition at line 48 of file PalmNetServices.h.

#define NetServicesLibTrapGetCommsQuality (sysLibTrapCustom+5)

Definition at line 44 of file PalmNetServices.h.

#define NetServicesLibTrapGetDeviceInfo (sysLibTrapCustom+10)

Definition at line 47 of file PalmNetServices.h.

#define NetServicesLibTrapGetHWAddr (sysLibTrapCustom+0)

Definition at line 39 of file PalmNetServices.h.

#define NetServicesLibTrapGetPowerState (sysLibTrapCustom+4)

Definition at line 43 of file PalmNetServices.h.

#define NetServicesLibTrapGetRadioState (sysLibTrapCustom+7)

Definition at line 46 of file PalmNetServices.h.

#define NetServicesLibTrapGetScanResults (sysLibTrapCustom+2)

Definition at line 41 of file PalmNetServices.h.

#define NetServicesLibTrapProfileAdd (sysLibTrapCustom+0x13)

Definition at line 53 of file PalmNetServices.h.

#define NetServicesLibTrapProfileDelete (sysLibTrapCustom+0x14)

Definition at line 54 of file PalmNetServices.h.

#define NetServicesLibTrapProfileFind (sysLibTrapCustom+0x17)

Definition at line 57 of file PalmNetServices.h.

#define NetServicesLibTrapProfileGetInfo (sysLibTrapCustom+0x10)

Definition at line 50 of file PalmNetServices.h.

#define NetServicesLibTrapProfileGetOrder (sysLibTrapCustom+0x16)

Definition at line 56 of file PalmNetServices.h.

#define NetServicesLibTrapProfileRead (sysLibTrapCustom+0x11)

Definition at line 51 of file PalmNetServices.h.

#define NetServicesLibTrapProfileSetOrder (sysLibTrapCustom+0x15)

Definition at line 55 of file PalmNetServices.h.

#define NetServicesLibTrapProfileWrite (sysLibTrapCustom+0x12)

Definition at line 52 of file PalmNetServices.h.

#define NetServicesLibTrapSetRadioState (sysLibTrapCustom+6)

Definition at line 45 of file PalmNetServices.h.

#define NetServicesLibTrapStartScan (sysLibTrapCustom+1)

Definition at line 40 of file PalmNetServices.h.

#define PRIORITY_LIST_SIZE (sizeof(UInt16) * (MAX_ACTIVE_PROFILES + 1))

Priority list size.

Definition at line 165 of file PalmNetServices.h.

#define ShlCreatorID 'NETs'

PalmNetServices creator ID.

Definition at line 67 of file PalmNetServices.h.

#define ShlLibName "NetServLib"

PalmNetServices library name.

Definition at line 66 of file PalmNetServices.h.

#define ShlLibType 'libr'

PalmNetServices library type.

Definition at line 68 of file PalmNetServices.h.

Typedef Documentation

typedef struct Net80211DeviceInfo * Net80211DeviceInfoP

Device information concerning Hardware and Firmware information for the "adapter".

Revision information and product name data is returned.

typedef struct NetServicesProfileInfo * NetServicesProfileInfoP

Data returned from NetServicesProfileGetInfo.

typedef struct NetServicesProfileOrder * NetServicesProfileOrderP

Priority order to smart connect.

Provided for ease of reference.

typedef struct NetServicesProfile * NetServicesProfileP

Profile entries for SmartConnect.

typedef struct NetServicesProfileV1 * NetServicesProfileV1P

Profile entries version 1.

Function Documentation

Err NetServicesGetChannel | ( | UInt16 | refnum,
 |  | UInt16 * | channelP
 | ) |  |

Err NetServicesGetChannelList | ( | UInt16 | refNum,
 |  | UInt16 * | channelP
 | ) |  |

Err NetServicesGetCommsQuality | ( | UInt16 | refNum,
 |  | UInt8 * | strengthP,
 |  | UInt8 * | qualityP
 | ) |  |

Err NetServicesGetDeviceInfo | ( | UInt16 | refNum,
 |  | Net80211DeviceInfoP | storageP
 | ) |  |

Err NetServicesGetHWAddr | ( | UInt16 | refnum,
 |  | UInt8 * | hwAddrP
 | ) |  |

Err NetServicesGetPowerState | ( | UInt16 | refnum,
 |  | UInt16 * | modeP
 | ) |  |

Err NetServicesGetRadioState | ( | UInt16 | libRef,
 |  | UInt32 * | radioStateP
 | ) |  |

Err NetServicesGetScanResults | ( | UInt16 | refnum,
 |  | UInt8 * | scanResultsP,
 |  | UInt32 * | scanBufSizeP
 | ) |  |

Err NetServicesProfileAdd | ( | UInt16 | libRef,
 |  | NetServicesProfileP | profileP
 | ) |  |

Err NetServicesProfileDelete | ( | UInt16 | libRef,
 |  | UInt16 | profIndex
 | ) |  |

UInt16 NetServicesProfileFind | ( | UInt16 | libRef,
 |  | Char * | profNameP
 | ) |  |

Err NetServicesProfileGetInfo | ( | UInt16 | libRef,
 |  | NetServicesProfileInfoP | infoP
 | ) |  |

Err NetServicesProfileGetOrder | ( | UInt16 | libRef,
 |  | NetServicesProfileOrderP | orderP
 | ) |  |

Err NetServicesProfileRead | ( | UInt16 | libRef,
 |  | UInt16 | profIndex,
 |  | NetServicesProfileP | profileP
 | ) |  |

Err NetServicesProfileSetOrder | ( | UInt16 | libRef,
 |  | NetServicesProfileOrderP | orderP
 | ) |  |

Err NetServicesProfileWrite | ( | UInt16 | libRef,
 |  | UInt16 | profIndex,
 |  | NetServicesProfileP | profileP
 | ) |  |

Err NetServicesSetRadioState | ( | UInt16 | refNum,
 |  | UInt32 | enable
 | ) |  |

Err NetServicesStartScan ( UInt16 refnum )

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:07:44 2008 for Palm API Guide


Header Files » Incs

Incs/palmOne_68K.h File Reference

Include dependency graph for Incs/palmOne_68K.h:

Go to the source code of this file.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:07:44 2008 for Palm API Guide


Header Files

palmOne_68K.h File Reference

Include dependency graph for palmOne_68K.h:

Go to the source code of this file.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:07:45 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » cameramgr

palmOneCamera.h File Reference

Detailed Description

Public 68K include file for camera support for Treo 650 devices. This version of the library adds functionality for Zire72, and Treo 650.

Version:
3.0
Notes: The calling application should always load this library with SysLibLoad() before use, even if it is already open by another application(ie, SysLibFind() returns a valid refnum). When the application is done with the library, it should be unloaded with SysLibRemove(). We do this because there is no good way to synchronize loading and unloading of libraries among multiple applications. It also greatly simplifies internal synchronization.

Definition in file palmOneCamera.h.

Include dependency graph for palmOneCamera.h:

Go to the source code of this file.

Defines

  • #define CAM_LIB_TRAP(trapNum) SYS_TRAP(trapNum)

Functions

  • Err CamLibOpen (UInt16 refNum)
  • Err CamLibClose (UInt16 refNum)
  • Err CamLibSleep (UInt16 refNum)
  • Err CamLibWake (UInt16 refNum)
  • Err CamLibGetVersion (UInt16 refNum, UInt32 sdkVersion, UInt32 *libVersionP)
  • Err CamLibControl (UInt16 refNum, CamLibControlType cmdId, void *parameterP)

Define Documentation

#define CAM_LIB_TRAP ( trapNum ) SYS_TRAP(trapNum)

Definition at line 38 of file palmOneCamera.h.

Function Documentation

Err CamLibClose ( UInt16 refNum )

Closes the Camera Manager.

Library should always be unloaded with SysLibRemove() after CamLibClose() is called. See note at top of file.

Parameters:
refNum,: IN: Library reference number.
Return values:
Err Error code.

Err CamLibControl | ( | UInt16 | refNum,
 |  | CamLibControlType | cmdId,
 |  | void * | parameterP
 | ) |  |

Check or set a Camera property.

Parameters:
refNum,: IN: Library reference number.
cmdId,: IN: The control command used to check or set the camera property.
parameterP,: IN: Pointer to a parameter based on the control command type.
Return values:
Err Error code.

Err CamLibGetVersion | ( | UInt16 | refNum,
 |  | UInt32 | sdkVersion,
 |  | UInt32 * | libVersionP
 | ) |  |

Checks the version of the Camera Manager Library.

Parameters:
refNum,: IN: Library reference number.
sdkVersion,: IN: The version the application expects.
libVersionP,: OUT: The actual version of the library.
Return values:
Err Error code.

Err CamLibOpen ( UInt16 refNum )

Standard library open routine.

Library should always be loaded with SysLibLoad()(not SysLibFind()) before calling CamLibOpen(). See note at top of file.

Parameters:
refNum,: IN: Library reference number.
Return values:
Err Error code.

Err CamLibSleep ( UInt16 refNum )

Standard library sleep function.

Parameters:
refNum,: IN: Library reference number.
Return values:
Err Error code.

Err CamLibWake ( UInt16 refNum )

Standard library wake function.

Parameters:
refNum,: IN: Library reference number.
Return values:
Err Error code.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:07:45 2008 for Palm API Guide


Header Files » Incs » common » libraries » cameramgr

palmOneCameraCommon.h File Reference

Detailed Description

Public 68K common header file for camera support for Zire 72 and Treo 650 devices.

Version:
3.0
This file contains the library constants and error codes used in the APIs.

Definition in file palmOneCameraCommon.h.

Go to the source code of this file.

Data Structures

  • struct CamLibStatusTag
    Container for the camera status kCamLibStatus*. More...
  • struct CamLibBitmapInfoTag
    Bitmap info structure for every format except PalmBMPV4. Data starts after the parameters. More...
  • struct CamLibCaptureTag
    Capture settings structure. The callback is called with userDataP passed. More...
  • struct CamLibStreamTag
    Video stream structure. Used for capturing a video stream. More...
  • struct CamLibSettingTag
    Settings Capabilities structure. For settings without manual values, only type is used. More...
  • struct CamLibColorSpaceTag
    Color Space structure. More...

Defines

  • #define kCamLibType 'libr'
  • #define kCamLibCreator 'camL'
  • #define kCamLibName "CameraLib-camL"
  • #define kCamLibBufNumManual 0x01
Library Versions
  • #define kCamLibVersion1 sysMakeROMVersion(1, 0, 0, sysROMStageRelease, 0)
  • #define kCamLibVersion2 sysMakeROMVersion(2, 0, 0, sysROMStageRelease, 0)
  • #define kCamLibVersion3 sysMakeROMVersion(3, 0, 0, sysROMStageRelease, 0)
  • #define kCamLibVersion kCamLibVersion3
Features
  • #define kCamLibFtrCaptureVersion 0
  • #define kCamLibCaptureHwrVersion 0x10
  • #define kCamLibFtrVersionNum 0
Error Codes
  • #define kCamLibErrorClass (oemErrorClass + 0x100)
  • #define kCamLibErrBadParam (kCamLibErrorClass | 0x01)
  • #define kCamLibErrNoMemory (kCamLibErrorClass | 0x02)
  • #define kCamLibErrNotOpen (kCamLibErrorClass | 0x03)
  • #define kCamLibErrStillOpen (kCamLibErrorClass | 0x04)
  • #define kCamLibErrInternal (kCamLibErrorClass | 0x05)
  • #define kCamLibErrNotSupported (kCamLibErrorClass | 0x06)
  • #define kCamLibErrNotCompatible (kCamLibErrorClass | 0x07)
  • #define kCamLibErrNoPower (kCamLibErrorClass | 0x08)
  • #define kCamLibErrAllFramesLocked (kCamLibErrorClass | 0x09)
Control Commands
  • #define kCamLibCtrlPowerOn 0x01
  • #define kCamLibCtrlPowerOff 0x02
  • #define kCamLibCtrlHardwareSettingsDlg 0x03
  • #define kCamLibCtrlPreviewStart 0x04
  • #define kCamLibCtrlPreviewStop 0x05
  • #define kCamLibCtrlCaptureGetBitmapInfo 0x06
  • #define kCamLibCtrlCapture 0x07
  • #define kCamLibCtrlStatusGet 0x08
  • #define kCamLibCtrlStatusQuery 0x09
  • #define kCamLibCtrlCaptureFormatSet 0x10
  • #define kCamLibCtrlCaptureFormatGet 0x11
  • #define kCamLibCtrlCaptureFormatQuery 0x12
  • #define kCamLibCtrlCaptureSizeSet 0x13
  • #define kCamLibCtrlCaptureSizeGet 0x14
  • #define kCamLibCtrlCaptureSizeQuery 0x15
  • #define kCamLibCtrlCaptureAreaSet 0x16
  • #define kCamLibCtrlCaptureAreaGet 0x17
  • #define kCamLibCtrlPreviewSizeSet 0x20
  • #define kCamLibCtrlPreviewSizeGet 0x21
  • #define kCamLibCtrlPreviewSizeQuery 0x22
  • #define kCamLibCtrlPreviewRectSet 0x23
  • #define kCamLibCtrlPreviewRectGet 0x24
  • #define kCamLibCtrlPreviewAreaSet 0x26
  • #define kCamLibCtrlPreviewAreaGet 0x27
  • #define kCamLibCtrlWhiteBalanceSet 0x30
  • #define kCamLibCtrlWhiteBalanceGet 0x31
  • #define kCamLibCtrlWhiteBalanceQuery 0x32
  • #define kCamLibCtrlLightingSet 0x33
  • #define kCamLibCtrlLightingGet 0x34
  • #define kCamLibCtrlLightingQuery 0x35
  • #define kCamLibCtrlZoomSet 0x36
  • #define kCamLibCtrlZoomGet 0x37
  • #define kCamLibCtrlZoomQuery 0x38
  • #define kCamLibCtrlEffectsSet 0x39
  • #define kCamLibCtrlEffectsGet 0x3A
  • #define kCamLibCtrlEffectsQuery 0x3B
  • #define kCamLibCtrlSaturationSet 0x3C
  • #define kCamLibCtrlSaturationGet 0x3D
  • #define kCamLibCtrlSaturationQuery 0x3E
  • #define kCamLibCtrlExposureSet 0x40
  • #define kCamLibCtrlExposureGet 0x41
  • #define kCamLibCtrlExposureQuery 0x42
  • #define kCamLibCtrlContrastSet 0x43
  • #define kCamLibCtrlContrastGet 0x44
  • #define kCamLibCtrlContrastQuery 0x45
  • #define kCamLibCtrlSharpnessSet 0x46
  • #define kCamLibCtrlSharpnessGet 0x47
  • #define kCamLibCtrlSharpnessQuery 0x48
  • #define kCamLibCtrlStreamFormatSet 0x50
  • #define kCamLibCtrlStreamFormatGet 0x51
  • #define kCamLibCtrlStreamFormatQuery 0x52
  • #define kCamLibCtrlStreamSizeSet 0x53
  • #define kCamLibCtrlStreamSizeGet 0x54
  • #define kCamLibCtrlStreamSizeQuery 0x55
  • #define kCamLibCtrlStreamStart 0x56
  • #define kCamLibCtrlStreamStop 0x57
  • #define kCamLibCtrlStreamWaitForFrame 0x58
  • #define kCamLibCtrlStreamUnlockFrame 0x59
  • #define kCamLibCtrlStreamBufNumSet 0x60
  • #define kCamLibCtrlStreamBufNumGet 0x61
  • #define kCamLibCtrlStreamBufNumQuery 0x62
  • #define kCamLibCtrlStreamPreviewSet 0x63
  • #define kCamLibCtrlStreamPreviewGet 0x64
  • #define kCamLibCtrlStreamPreviewQuery 0x65
  • #define kCamLibCtrlColorSpaceSet 0x66
  • #define kCamLibCtrlColorSpaceGet 0x67
  • #define kCamLibCtrlColorSpaceQuery 0x68
  • #define kCamLibCtrlShutterSpeedSet 0x69
  • #define kCamLibCtrlShutterSpeedGet 0x6A
  • #define kCamLibCtrlShutterSpeedQuery 0x6B
  • #define kCamLibCtrlApertureValueSet 0x6C
  • #define kCamLibCtrlApertureValueGet 0x6D
  • #define kCamLibCtrlApertureValueQuery 0x6E
Camera Status
  • #define kCamLibStatusPoweredOn 0x01
  • #define kCamLibStatusInPreview 0x02
  • #define kCamLibStatusInStillCapture 0x04
  • #define kCamLibStatusInVideoCapture 0x08
Capture Formats
  • #define kCamLibCaptureDataFormatRGB565 0x0002
  • #define kCamLibCaptureDataFormatYUV422 0x0004
  • #define kCamLibCaptureDataFormatYCbCr422 0x0008
  • #define kCamLibCaptureDataFormatYUV422Planar 0x0010
  • #define kCamLibCaptureDataFormatYCbCr422Planar 0x0020
  • #define kCamLibCaptureDataFormatYUV420 0x0040
  • #define kCamLibCaptureDataFormatYCbCr420 0x0080
  • #define kCamLibCaptureDataFormatYUV420Planar 0x0100
  • #define kCamLibCaptureDataFormatYCbCr420Planar 0x0200
Image Resolution
  • #define kCamLibImageSizeQQVGA 0x02
  • #define kCamLibImageSizeQVGA 0x04
  • #define kCamLibImageSizeVGA 0x08
  • #define kCamLibImageSizeSXGA 0x10
  • #define kCamLibImageSizeQCIF 0x20
  • #define kCamLibImageSizeCIF 0x40
  • #define kCamLibImageSizeSXGA960 0x10
  • #define kCamLibImageSizeSXGA1024 0x80
White Balance Settings
  • #define kCamLibWhiteBalanceAuto 0x02
  • #define kCamLibWhiteBalanceIndoor 0x04
  • #define kCamLibWhiteBalanceIncandescent 0x04
  • #define kCamLibWhiteBalanceOutdoor 0x08
  • #define kCamLibWhiteBalanceSunny 0x08
  • #define kCamLibWhiteBalanceExtra 0x10
  • #define kCamLibWhiteBalanceFluorescent 0x10
  • #define kCamLibWhiteBalanceCloudy 0x20
  • #define kCamLibWhiteBalanceShade 0x40
  • #define kCamLibWhiteBalanceTwilight 0x80
Exposure Level Settings
  • #define kCamLibExposureManual 0x01
  • #define kCamLibExposureAuto 0x02
Contrast Setting
  • #define kCamLibContrastManual 0x01
Zoom Setting
  • #define kCamLibZoomManual 0x01
Lighting Settings
  • #define kCamLibLightingNormal 0x02
  • #define kCamLibLightingLow 0x04
Special Effects
  • #define kCamLibEffectsNormal 0x02
  • #define kCamLibEffectsBlackWhite 0x04
  • #define kCamLibEffectsSepia 0x08
  • #define kCamLibEffectsBluish 0x10
  • #define kCamLibEffectsNegative 0x20
Saturation Level
  • #define kCamLibSaturationManual 0x01
Sharpness Level
  • #define kCamLibSharpnessManual 0x01
Stream Preview Settings
  • #define kCamLibStreamPreviewOn 0x01
  • #define kCamLibStreamPreviewOff 0x02
Color Space Settings
  • #define kCamLibColorSpace_sRGB 0x02
  • #define kCamLibColorSpaceUncalibrated 0x04
Shutter Speed Settings
  • #define kCamLibShutterSpeedManual 0x01
  • #define kCamLibShutterSpeedAuto 0x02
Aperture Value Settings
  • #define kCamLibApertureValueManual 0x01
  • #define kCamLibApertureValueAuto 0x02
Function Traps
  • #define kCamLibTrapGetVersion (sysLibTrapCustom + 0)
  • #define kCamLibTrapControl (sysLibTrapCustom + 1)

Typedefs

  • typedef UInt16 CamLibControlType
  • typedef CamLibStatusTag CamLibStatusType
    Container for the camera status kCamLibStatus*.
  • typedef CamLibBitmapInfoTag CamLibBitmapInfoType
    Bitmap info structure for every format except PalmBMPV4. Data starts after the parameters.
  • typedef Err CamLibCaptureCallbackFunc (void *bufP, UInt32 size, void *userDataP)
    Image capture callback function pointer.
  • typedef CamLibCaptureTag CamLibCaptureType
    Capture settings structure. The callback is called with userDataP passed.
  • typedef CamLibStreamTag CamLibStreamType
    Video stream structure. Used for capturing a video stream.
  • typedef CamLibSettingTag CamLibBufNumType
  • typedef CamLibSettingTag CamLibSettingType
    Settings Capabilities structure. For settings without manual values, only type is used.
  • typedef CamLibColorSpaceTag CamLibColorSpaceType
    Color Space structure.
  • typedef CamLibSettingTag CamLibCaptureFormatType
  • typedef CamLibSettingTag CamLibImageSizeType
  • typedef CamLibSettingTag CamLibWhiteBalanceType
  • typedef CamLibSettingTag CamLibExposureType
  • typedef CamLibSettingTag CamLibContrastType
  • typedef CamLibSettingTag CamLibZoomType
  • typedef CamLibSettingTag CamLibLightingType
  • typedef CamLibSettingTag CamLibEffectsType
  • typedef CamLibSettingTag CamLibSaturationType
  • typedef CamLibSettingTag CamLibSharpnessType
  • typedef CamLibSettingTag CamLibStreamPreviewType
  • typedef CamLibSettingTag CamLibShutterSpeedType
  • typedef CamLibSettingTag CamLibApertureValueType

Define Documentation

#define kCamLibApertureValueAuto 0x02

Sets the aperture value automatically.

Definition at line 430 of file palmOneCameraCommon.h.

#define kCamLibApertureValueManual 0x01

Sets the aperture value manually through an additional passed parameter with kCamLibCtrlApertureValueSet.For manual values, all values are x1000 of real aperture value i.e. ap val 1.4 is 1400.

Definition at line 426 of file palmOneCameraCommon.h.

#define kCamLibBufNumManual 0x01

Video Stream Capture buffers

Definition at line 222 of file palmOneCameraCommon.h.

#define kCamLibCaptureDataFormatRGB565 0x0002

Capture format in 16-bit RGB.

Definition at line 254 of file palmOneCameraCommon.h.

#define kCamLibCaptureDataFormatYCbCr420 0x0080

Capture format in 16-bit YCbCr420.

Definition at line 260 of file palmOneCameraCommon.h.

#define kCamLibCaptureDataFormatYCbCr420Planar 0x0200

Capture format in 16-bit YCbCr420 Planar.

Definition at line 262 of file palmOneCameraCommon.h.

#define kCamLibCaptureDataFormatYCbCr422 0x0008

Capture format in 16-bit YCbCr422.

Definition at line 256 of file palmOneCameraCommon.h.

#define kCamLibCaptureDataFormatYCbCr422Planar 0x0020

Capture format in 16-bit YCbCr422 Planar.

Definition at line 258 of file palmOneCameraCommon.h.

#define kCamLibCaptureDataFormatYUV420 0x0040

Capture format in 16-bit YUV420.

Definition at line 259 of file palmOneCameraCommon.h.

#define kCamLibCaptureDataFormatYUV420Planar 0x0100

Capture format in 16-bit YUV420 Planar.

Definition at line 261 of file palmOneCameraCommon.h.

#define kCamLibCaptureDataFormatYUV422 0x0004

Capture format in 16-bit YUV422.

Definition at line 255 of file palmOneCameraCommon.h.

#define kCamLibCaptureDataFormatYUV422Planar 0x0010

Capture format in 16-bit YUV422 Planar.

Definition at line 257 of file palmOneCameraCommon.h.

#define kCamLibCaptureHwrVersion 0x10

Feature value if capture h/w present.

Definition at line 54 of file palmOneCameraCommon.h.

#define kCamLibColorSpace_sRGB 0x02

color space sRGB.

Definition at line 406 of file palmOneCameraCommon.h.

#define kCamLibColorSpaceUncalibrated 0x04

color space uncalibrated.

Definition at line 407 of file palmOneCameraCommon.h.

#define kCamLibContrastManual 0x01

Sets the contrast value manually. Use kCamLibCtrlContrastGet to determine the minimum and maximum values allowed and the unit of measurement.

Definition at line 327 of file palmOneCameraCommon.h.

#define kCamLibCreator 'camL'

Camera Manager library creator ID

Definition at line 34 of file palmOneCameraCommon.h.

#define kCamLibCtrlApertureValueGet 0x6D

Gets the Aperture Value. Parameter is CamLibApertureValueType*.

Definition at line 151 of file palmOneCameraCommon.h.

#define kCamLibCtrlApertureValueQuery 0x6E

Queries for the Aperture Value. Parameter is CamLibApertureValueType*.

Definition at line 152 of file palmOneCameraCommon.h.

#define kCamLibCtrlApertureValueSet 0x6C

Sets the Aperture Value. Parameter is CamLibApertureValueType*.

Definition at line 150 of file palmOneCameraCommon.h.

#define kCamLibCtrlCapture 0x07

Captures the current image. Parameter is CamLibCaptureType*.

Definition at line 86 of file palmOneCameraCommon.h.

#define kCamLibCtrlCaptureAreaGet 0x17

Gets the capture area. Parameter is RectangleType*. Low-res value.

Definition at line 96 of file palmOneCameraCommon.h.

#define kCamLibCtrlCaptureAreaSet 0x16

Sets the capture area. Parameter is RectangleType*. Low-res value.

Definition at line 95 of file palmOneCameraCommon.h.

#define kCamLibCtrlCaptureFormatGet 0x11

Gets the current capture format. Parameter is CamLibCaptureFormatType*.

Definition at line 90 of file palmOneCameraCommon.h.

#define kCamLibCtrlCaptureFormatQuery 0x12

Queries the capture formats available. Parameter is CamLibCaptureFormatType*.

Definition at line 91 of file palmOneCameraCommon.h.

#define kCamLibCtrlCaptureFormatSet 0x10

Sets the capture format. Parameter is CamLibCaptureFormatType*.

Definition at line 89 of file palmOneCameraCommon.h.

#define kCamLibCtrlCaptureGetBitmapInfo 0x06

Used to determine the captured image properties. Parameter is CamLibBitmapInfoType*.

Definition at line 85 of file palmOneCameraCommon.h.

#define kCamLibCtrlCaptureSizeGet 0x14

Gets the current capture size. Parameter is CamLibImageSizeType*.

Definition at line 93 of file palmOneCameraCommon.h.

#define kCamLibCtrlCaptureSizeQuery 0x15

Queries the capture sizes available. Parameter is CamLibImageSizeType*.

Definition at line 94 of file palmOneCameraCommon.h.

#define kCamLibCtrlCaptureSizeSet 0x13

Sets the capture size. Parameter is CamLibImageSizeType*.

Definition at line 92 of file palmOneCameraCommon.h.

#define kCamLibCtrlColorSpaceGet 0x67

Gets the Color Space. Parameter is CamLibColorSpaceType*.

Definition at line 145 of file palmOneCameraCommon.h.

#define kCamLibCtrlColorSpaceQuery 0x68

Queries for the Color Space. Parameter is CamLibColorSpaceType*.

Definition at line 146 of file palmOneCameraCommon.h.

#define kCamLibCtrlColorSpaceSet 0x66

Sets the Color Space. Parameter is CamLibColorSpaceType*.

Definition at line 144 of file palmOneCameraCommon.h.

#define kCamLibCtrlContrastGet 0x44

Gets the current contrast. Parameter is CamLibContrastType*.

Definition at line 123 of file palmOneCameraCommon.h.

#define kCamLibCtrlContrastQuery 0x45

Checks the contrast values available. Parameter is CamLibContrastType*.

Definition at line 124 of file palmOneCameraCommon.h.

#define kCamLibCtrlContrastSet 0x43

Sets the contrast. Parameter is CamLibContrastType*.

Definition at line 122 of file palmOneCameraCommon.h.

#define kCamLibCtrlEffectsGet 0x3A

Gets the current camera effect. Parameter is CamLibEffectsType*.

Definition at line 114 of file palmOneCameraCommon.h.

#define kCamLibCtrlEffectsQuery 0x3B

Queries the camera effects available. Parameter is CamLibEffectsType*.

Definition at line 115 of file palmOneCameraCommon.h.

#define kCamLibCtrlEffectsSet 0x39

Sets the camera effect. Parameter is CamLibEffectsType*.

Definition at line 113 of file palmOneCameraCommon.h.

#define kCamLibCtrlExposureGet 0x41

Gets the exposure. Parameter is CamLibExposureType*.

Definition at line 120 of file palmOneCameraCommon.h.

#define kCamLibCtrlExposureQuery 0x42

Checks the exposure values available. Parameter is CamLibExposureType*.

Definition at line 121 of file palmOneCameraCommon.h.

#define kCamLibCtrlExposureSet 0x40

Sets the exposure. Parameter is CamLibExposureType*.

Definition at line 119 of file palmOneCameraCommon.h.

#define kCamLibCtrlHardwareSettingsDlg 0x03

Displays the hardware camera settings dialog. No parameter.

Definition at line 82 of file palmOneCameraCommon.h.

#define kCamLibCtrlLightingGet 0x34

Gets the current lighting setting. Parameter is CamLibLightingType*.

Definition at line 108 of file palmOneCameraCommon.h.

#define kCamLibCtrlLightingQuery 0x35

Queries the lighting settings available. Parameter is CamLibLightingType*.

Definition at line 109 of file palmOneCameraCommon.h.

#define kCamLibCtrlLightingSet 0x33

Sets the lighting setting. Parameter is CamLibLightingType*.

Definition at line 107 of file palmOneCameraCommon.h.

#define kCamLibCtrlPowerOff 0x02

Powers off the camera module. No parameter.

Definition at line 81 of file palmOneCameraCommon.h.

#define kCamLibCtrlPowerOn 0x01

Powers on and initialize the camera module. No parameter.

Definition at line 80 of file palmOneCameraCommon.h.

#define kCamLibCtrlPreviewAreaGet 0x27

Gets the preview area. Parameter is RectangleType*. Low-res value.

Definition at line 103 of file palmOneCameraCommon.h.

#define kCamLibCtrlPreviewAreaSet 0x26

Sets the preview area. Parameter is RectangleType*. Low-res value.

Definition at line 102 of file palmOneCameraCommon.h.

#define kCamLibCtrlPreviewRectGet 0x24

Gets the preview rectangle. Parameter is RectangleType*. Low-res value.

Definition at line 101 of file palmOneCameraCommon.h.

#define kCamLibCtrlPreviewRectSet 0x23

Sets the preview rectangle. Parameter is RectangleType*. Low-res value.

Definition at line 100 of file palmOneCameraCommon.h.

#define kCamLibCtrlPreviewSizeGet 0x21

Gets the preview size. Parameter is CamLibImageSizeType*.

Definition at line 98 of file palmOneCameraCommon.h.

#define kCamLibCtrlPreviewSizeQuery 0x22

Queries the preview sizes available. Parameter is CamLibImageSizeType*.

Definition at line 99 of file palmOneCameraCommon.h.

#define kCamLibCtrlPreviewSizeSet 0x20

Sets the preview size. Parameter is CamLibImageSizeType*.

Definition at line 97 of file palmOneCameraCommon.h.

#define kCamLibCtrlPreviewStart 0x04

Starts the camera preview mode. No parameter.

Definition at line 83 of file palmOneCameraCommon.h.

#define kCamLibCtrlPreviewStop 0x05

Stops the camera preview mode. No parameter.

Definition at line 84 of file palmOneCameraCommon.h.

#define kCamLibCtrlSaturationGet 0x3D

Gets the current saturation level. Parameter is CamLibSaturationType*.

Definition at line 117 of file palmOneCameraCommon.h.

#define kCamLibCtrlSaturationQuery 0x3E

Queries the saturation range. Parameter is CamLibSaturationType*.

Definition at line 118 of file palmOneCameraCommon.h.

#define kCamLibCtrlSaturationSet 0x3C

Sets the saturation level. Parameter is CamLibSaturationType*.

Definition at line 116 of file palmOneCameraCommon.h.

#define kCamLibCtrlSharpnessGet 0x47

Gets the sharpness. Parameter is CamLibSharpnessType*.

Definition at line 126 of file palmOneCameraCommon.h.

#define kCamLibCtrlSharpnessQuery 0x48

Queries the sharpness range. Parameter is CamLibSharpnessType*.

Definition at line 127 of file palmOneCameraCommon.h.

#define kCamLibCtrlSharpnessSet 0x46

Sets the sharpness. Parameter is CamLibSharpnessType*.

Definition at line 125 of file palmOneCameraCommon.h.

#define kCamLibCtrlShutterSpeedGet 0x6A

Gets the Shutter Speed. Parameter is CamLibShutterSpeedType*.

Definition at line 148 of file palmOneCameraCommon.h.

#define kCamLibCtrlShutterSpeedQuery 0x6B

Queries for the Shutter Speed. Parameter is CamLibShutterSpeedType*.

Definition at line 149 of file palmOneCameraCommon.h.

#define kCamLibCtrlShutterSpeedSet 0x69

Sets the Shutter Speed. Parameter is CamLibShutterSpeedType*.

Definition at line 147 of file palmOneCameraCommon.h.

#define kCamLibCtrlStatusGet 0x08

Used to determine if a certain camera status is currently in effect. Parameter is CamLibStatusType*.

Definition at line 87 of file palmOneCameraCommon.h.

#define kCamLibCtrlStatusQuery 0x09

Used to determine if a certain camera status is available. Parameter is CamLibStatusType*.

Definition at line 88 of file palmOneCameraCommon.h.

#define kCamLibCtrlStreamBufNumGet 0x61

Gets the number of video frame buffers. Parameter is CamLibBufNumType*.

Definition at line 139 of file palmOneCameraCommon.h.

#define kCamLibCtrlStreamBufNumQuery 0x62

Queries the number of video frame buffer range. Parameter is CamLibBufNumType*.

Definition at line 140 of file palmOneCameraCommon.h.

#define kCamLibCtrlStreamBufNumSet 0x60

Sets the number of video frame buffers. Parameter is CamLibBufNumType*.

Definition at line 138 of file palmOneCameraCommon.h.

#define kCamLibCtrlStreamFormatGet 0x51

Gets the video stream format. Parameter is CamLibCaptureFormatType*.

Definition at line 129 of file palmOneCameraCommon.h.

#define kCamLibCtrlStreamFormatQuery 0x52

Queries the video stream formats available. Parameter is CamLibCaptureFormatType*.

Definition at line 130 of file palmOneCameraCommon.h.

#define kCamLibCtrlStreamFormatSet 0x50

Sets the video stream format. Parameter is CamLibCaptureFormatType*.

Definition at line 128 of file palmOneCameraCommon.h.

#define kCamLibCtrlStreamPreviewGet 0x64

Gets the stream preview status (on or off). Parameter is CamLibStreamPreviewType*.

Definition at line 142 of file palmOneCameraCommon.h.

#define kCamLibCtrlStreamPreviewQuery 0x65

Queries the stream preview available. Parameter is CamLibStreamPreviewType*.

Definition at line 143 of file palmOneCameraCommon.h.

#define kCamLibCtrlStreamPreviewSet 0x63

Sets the stream preview on or off. Parameter is CamLibStreamPreviewType*.

Definition at line 141 of file palmOneCameraCommon.h.

#define kCamLibCtrlStreamSizeGet 0x54

Gets the video stream size. Parameter is CamLibCaptureSizeType*.

Definition at line 132 of file palmOneCameraCommon.h.

#define kCamLibCtrlStreamSizeQuery 0x55

Queries the video stream sizes available. Parameter is CamLibCaptureSizeType*.

Definition at line 133 of file palmOneCameraCommon.h.

#define kCamLibCtrlStreamSizeSet 0x53

Sets the video stream size. Parameter is CamLibCaptureSizeType*.

Definition at line 131 of file palmOneCameraCommon.h.

#define kCamLibCtrlStreamStart 0x56

Starts the video stream capture. Parameter is CamLibStreamType*.

Definition at line 134 of file palmOneCameraCommon.h.

#define kCamLibCtrlStreamStop 0x57

Stops the video stream capture. Parameter is CamLibStreamType*.

Definition at line 135 of file palmOneCameraCommon.h.

#define kCamLibCtrlStreamUnlockFrame 0x59

Unlocks a video frame. Parameter is CamLibStreamType*.

Definition at line 137 of file palmOneCameraCommon.h.

#define kCamLibCtrlStreamWaitForFrame 0x58

Waits and locks a video frame. Parameter is CamLibStreamType*.

Definition at line 136 of file palmOneCameraCommon.h.

#define kCamLibCtrlWhiteBalanceGet 0x31

Gets the current white balance. Parameter is CamLibWhiteBalanceType*.

Definition at line 105 of file palmOneCameraCommon.h.

#define kCamLibCtrlWhiteBalanceQuery 0x32

Queries the white balances available. Parameter is CamLibWhiteBalanceType*.

Definition at line 106 of file palmOneCameraCommon.h.

#define kCamLibCtrlWhiteBalanceSet 0x30

Sets the white balance. Parameter is CamLibWhiteBalanceType*.

Definition at line 104 of file palmOneCameraCommon.h.

#define kCamLibCtrlZoomGet 0x37

Gets the current zoom value. Parameter is CamLibZoomType*.

Definition at line 111 of file palmOneCameraCommon.h.

#define kCamLibCtrlZoomQuery 0x38

Queries the zoom range. Parameter is CamLibZoomType*.

Definition at line 112 of file palmOneCameraCommon.h.

#define kCamLibCtrlZoomSet 0x36

Sets the zoom value. Parameter is CamLibZoomType*.

Definition at line 110 of file palmOneCameraCommon.h.

#define kCamLibEffectsBlackWhite 0x04

Balck & white effect

Definition at line 362 of file palmOneCameraCommon.h.

#define kCamLibEffectsBluish 0x10

Bluish effect

Definition at line 364 of file palmOneCameraCommon.h.

#define kCamLibEffectsNegative 0x20

Negative effect

Definition at line 365 of file palmOneCameraCommon.h.

#define kCamLibEffectsNormal 0x02

No special effects

Definition at line 361 of file palmOneCameraCommon.h.

#define kCamLibEffectsSepia 0x08

Sepia effect

Definition at line 363 of file palmOneCameraCommon.h.

#define kCamLibErrAllFramesLocked (kCamLibErrorClass | 0x09)

All video frames are locked.

Definition at line 72 of file palmOneCameraCommon.h.

#define kCamLibErrBadParam (kCamLibErrorClass | 0x01)

Invalid parameter.

Definition at line 64 of file palmOneCameraCommon.h.

#define kCamLibErrInternal (kCamLibErrorClass | 0x05)

Internal error.

Definition at line 68 of file palmOneCameraCommon.h.

#define kCamLibErrNoMemory (kCamLibErrorClass | 0x02)

Memory error.

Definition at line 65 of file palmOneCameraCommon.h.

#define kCamLibErrNoPower (kCamLibErrorClass | 0x08)

Camera not powered.

Definition at line 71 of file palmOneCameraCommon.h.

#define kCamLibErrNotCompatible (kCamLibErrorClass | 0x07)

Bad Version.

Definition at line 70 of file palmOneCameraCommon.h.

#define kCamLibErrNotOpen (kCamLibErrorClass | 0x03)

Library is not open.

Definition at line 66 of file palmOneCameraCommon.h.

#define kCamLibErrNotSupported (kCamLibErrorClass | 0x06)

Unsupported function.

Definition at line 69 of file palmOneCameraCommon.h.

#define kCamLibErrorClass (oemErrorClass + 0x100)

Definition at line 63 of file palmOneCameraCommon.h.

#define kCamLibErrStillOpen (kCamLibErrorClass | 0x04)

Returned from CamLibClose() if the library is still open.

Definition at line 67 of file palmOneCameraCommon.h.

#define kCamLibExposureAuto 0x02

Sets the exposure level automatically.

Definition at line 317 of file palmOneCameraCommon.h.

#define kCamLibExposureManual 0x01

Sets the exposure level manually through an additional passed parameter with kCamLibCtrlExposureSet. For manual values, all values are x1000 of real exposure i.e. exp 1.5 is 1500.

Definition at line 314 of file palmOneCameraCommon.h.

#define kCamLibFtrCaptureVersion 0

Feature id for capture h/w.

Definition at line 53 of file palmOneCameraCommon.h.

#define kCamLibFtrVersionNum 0

Feature version if camera is present.

Definition at line 55 of file palmOneCameraCommon.h.

#define kCamLibImageSizeCIF 0x40

354 x 288 High Resolution.

Definition at line 277 of file palmOneCameraCommon.h.

#define kCamLibImageSizeQCIF 0x20

177 x 144 High Resolution.

Definition at line 276 of file palmOneCameraCommon.h.

#define kCamLibImageSizeQQVGA 0x02

160 x 120 High Resolution.

Definition at line 272 of file palmOneCameraCommon.h.

#define kCamLibImageSizeQVGA 0x04

320 x 240 High Resolution.

Definition at line 273 of file palmOneCameraCommon.h.

#define kCamLibImageSizeSXGA 0x10

1280x 960 High Resolution.

Definition at line 275 of file palmOneCameraCommon.h.

#define kCamLibImageSizeSXGA1024 0x80

1280x 1024 High Resolution.

Definition at line 285 of file palmOneCameraCommon.h.

#define kCamLibImageSizeSXGA960 0x10

1280x 960 High Resolution.

Definition at line 284 of file palmOneCameraCommon.h.

#define kCamLibImageSizeVGA 0x08

640 x 480 High Resolution.

Definition at line 274 of file palmOneCameraCommon.h.

#define kCamLibLightingLow 0x04

The camera is set for low light.

Definition at line 351 of file palmOneCameraCommon.h.

#define kCamLibLightingNormal 0x02

The camera is set for normal light.

Definition at line 350 of file palmOneCameraCommon.h.

#define kCamLibName "CameraLib-camL"

Camera Manager library name

Definition at line 35 of file palmOneCameraCommon.h.

#define kCamLibSaturationManual 0x01

Sets the saturation level manually

Definition at line 375 of file palmOneCameraCommon.h.

#define kCamLibSharpnessManual 0x01

Sets the sharpness level manually.

Definition at line 385 of file palmOneCameraCommon.h.

#define kCamLibShutterSpeedAuto 0x02

Sets the shutter speed automatically.

Definition at line 416 of file palmOneCameraCommon.h.

#define kCamLibShutterSpeedManual 0x01

Sets the shutter speed manually through an additional passed parameter with kCamLibCtrlShutterSpeedSet.

Definition at line 414 of file palmOneCameraCommon.h.

#define kCamLibStatusInPreview 0x02

Is the camera in preview mode?

Definition at line 163 of file palmOneCameraCommon.h.

#define kCamLibStatusInStillCapture 0x04

Is the camera in still capture?

Definition at line 164 of file palmOneCameraCommon.h.

#define kCamLibStatusInVideoCapture 0x08

Is the camera in video capture?

Definition at line 165 of file palmOneCameraCommon.h.

#define kCamLibStatusPoweredOn 0x01

Is the camera powered on?

Definition at line 162 of file palmOneCameraCommon.h.

#define kCamLibStreamPreviewOff 0x02

Stream preview off.

Definition at line 396 of file palmOneCameraCommon.h.

#define kCamLibStreamPreviewOn 0x01

Stream preview on.

Definition at line 395 of file palmOneCameraCommon.h.

#define kCamLibTrapControl (sysLibTrapCustom + 1)

Definition at line 441 of file palmOneCameraCommon.h.

#define kCamLibTrapGetVersion (sysLibTrapCustom + 0)

Definition at line 440 of file palmOneCameraCommon.h.

#define kCamLibType 'libr'

Default library type

Definition at line 33 of file palmOneCameraCommon.h.

#define kCamLibVersion kCamLibVersion3

Definition at line 45 of file palmOneCameraCommon.h.

#define kCamLibVersion1 sysMakeROMVersion(1, 0, 0, sysROMStageRelease, 0)

Definition at line 42 of file palmOneCameraCommon.h.

#define kCamLibVersion2 sysMakeROMVersion(2, 0, 0, sysROMStageRelease, 0)

Definition at line 43 of file palmOneCameraCommon.h.

#define kCamLibVersion3 sysMakeROMVersion(3, 0, 0, sysROMStageRelease, 0)

Definition at line 44 of file palmOneCameraCommon.h.

#define kCamLibWhiteBalanceAuto 0x02

Automatically determines the correct white balance for capturing and previewing images.

Definition at line 295 of file palmOneCameraCommon.h.

#define kCamLibWhiteBalanceCloudy 0x20

Sets the white balance for cloudy lighting during capture and preview of images

Definition at line 302 of file palmOneCameraCommon.h.

#define kCamLibWhiteBalanceExtra 0x10

Sets the white balance for flourescent indoor capturing and previewing of images

Definition at line 300 of file palmOneCameraCommon.h.

#define kCamLibWhiteBalanceFluorescent 0x10

Sets the white balance for flourescent indoor capturing and previewing of images

Definition at line 301 of file palmOneCameraCommon.h.

#define kCamLibWhiteBalanceIncandescent 0x04

Sets the white balance for indoor capturing and previewing of images

Definition at line 297 of file palmOneCameraCommon.h.

#define kCamLibWhiteBalanceIndoor 0x04

Sets the white balance for indoor capturing and previewing of images

Definition at line 296 of file palmOneCameraCommon.h.

#define kCamLibWhiteBalanceOutdoor 0x08

Sets the white balance for outdoor capturing and previewing of images

Definition at line 298 of file palmOneCameraCommon.h.

#define kCamLibWhiteBalanceShade 0x40

Sets the white balance for shady lighting during capture and preview of images

Definition at line 303 of file palmOneCameraCommon.h.

#define kCamLibWhiteBalanceSunny 0x08

Sets the white balance for outdoor capturing and previewing of images

Definition at line 299 of file palmOneCameraCommon.h.

#define kCamLibWhiteBalanceTwilight 0x80

Sets the white balance for twilight lighting during capture and preview of images

Definition at line 304 of file palmOneCameraCommon.h.

#define kCamLibZoomManual 0x01

Sets the zoom value manually. All values here are x1000 of real zoom i.e. x2 is 2000.

Definition at line 339 of file palmOneCameraCommon.h.

Typedef Documentation

typedef struct CamLibSettingTag CamLibApertureValueType

See also:
CamLibSettingTag

Definition at line 434 of file palmOneCameraCommon.h.

typedef struct CamLibBitmapInfoTag CamLibBitmapInfoType

Bitmap info structure for every format except PalmBMPV4. Data starts after the parameters.

typedef struct CamLibSettingTag CamLibBufNumType

See also:
CamLibSettingTag

Definition at line 225 of file palmOneCameraCommon.h.

typedef Err CamLibCaptureCallbackFunc(void *bufP, UInt32 size, void *userDataP)

Image capture callback function pointer.

Parameters:
bufP | I/O Pointer to the image buffer
size | IN Size of the buffer
userDataP | OUT Pointer to the user data
Returns:
Error code or zero if no error occurs

Definition at line 197 of file palmOneCameraCommon.h.

typedef struct CamLibSettingTag CamLibCaptureFormatType

See also:
CamLibSettingTag

Definition at line 266 of file palmOneCameraCommon.h.

typedef struct CamLibCaptureTag CamLibCaptureType

Capture settings structure. The callback is called with userDataP passed.

typedef struct CamLibColorSpaceTag CamLibColorSpaceType

Color Space structure.

typedef struct CamLibSettingTag CamLibContrastType

See also:
CamLibSettingTag

Definition at line 333 of file palmOneCameraCommon.h.

typedef UInt16 CamLibControlType

Camera Manager library control structure

Definition at line 156 of file palmOneCameraCommon.h.

typedef struct CamLibSettingTag CamLibEffectsType

See also:
CamLibSettingTag

Definition at line 369 of file palmOneCameraCommon.h.

typedef struct CamLibSettingTag CamLibExposureType

See also:
CamLibSettingTag

Definition at line 321 of file palmOneCameraCommon.h.

typedef struct CamLibSettingTag CamLibImageSizeType

See also:
CamLibSettingTag

Definition at line 289 of file palmOneCameraCommon.h.

typedef struct CamLibSettingTag CamLibLightingType

See also:
CamLibSettingTag

Definition at line 355 of file palmOneCameraCommon.h.

typedef struct CamLibSettingTag CamLibSaturationType

See also:
CamLibSettingTag

Definition at line 379 of file palmOneCameraCommon.h.

typedef struct CamLibSettingTag CamLibSettingType

Settings Capabilities structure. For settings without manual values, only type is used.

typedef struct CamLibSettingTag CamLibSharpnessType

See also:
CamLibSettingTag

Definition at line 389 of file palmOneCameraCommon.h.

typedef struct CamLibSettingTag CamLibShutterSpeedType

See also:
CamLibSettingTag

Definition at line 420 of file palmOneCameraCommon.h.

typedef struct CamLibStatusTag CamLibStatusType

Container for the camera status kCamLibStatus*.

typedef struct CamLibSettingTag CamLibStreamPreviewType

See also:
CamLibSettingTag

Definition at line 400 of file palmOneCameraCommon.h.

typedef struct CamLibStreamTag CamLibStreamType

Video stream structure. Used for capturing a video stream.

When used with WaitfForFram, bufP will contain the full frame buffer.

typedef struct CamLibSettingTag CamLibWhiteBalanceType

See also:
CamLibSettingTag

Definition at line 308 of file palmOneCameraCommon.h.

typedef struct CamLibSettingTag CamLibZoomType

See also:
CamLibSettingTag

Definition at line 344 of file palmOneCameraCommon.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:07:46 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » cameramgr

palmOneCameraSlider.h File Reference

Detailed Description

Public 68K file for camera slider notification for Zire 71 devices.

Version:
1.0
Contains the Slider notification and status information.

Any application can register to the notification to be nofity when the slider is opened or closed. Any application can also get the status of the slider by checking the feature. This is specific to the camera slider. The notifyDetailsP param in SysNotifyParamType is null in the notification. Application should check the status of the slider by using the Feature.

Definition in file palmOneCameraSlider.h.

Include dependency graph for palmOneCameraSlider.h:

Go to the source code of this file.

Defines

  • #define kCamSliderVersion1 sysMakeROMVersion(1, 0, 0, sysROMStageDevelopment, 0)
  • #define kCamSliderVersion kCamSliderVersion1
  • #define kCamSliderFlagsOpened 0x00000001
  • #define kCamSliderCreator 'cslP'
  • #define kCamSliderNotifyEvent kCamSliderCreator
  • #define kCamSliderFtrVersionNum 0
  • #define kCamSliderFtrFlagsNum 1

Define Documentation

#define kCamSliderCreator 'cslP'

Camera Slider creator ID.

Definition at line 49 of file palmOneCameraSlider.h.

#define kCamSliderFlagsOpened 0x00000001

Feature for testing if the slider is open.

Definition at line 46 of file palmOneCameraSlider.h.

#define kCamSliderFtrFlagsNum 1

Feature value should be kCamSliderFlagsOpened or 0.

Definition at line 58 of file palmOneCameraSlider.h.

#define kCamSliderFtrVersionNum 0

Feature value should be kCamSliderVersion.

Definition at line 55 of file palmOneCameraSlider.h.

#define kCamSliderNotifyEvent kCamSliderCreator

Notification creator.

Definition at line 52 of file palmOneCameraSlider.h.

#define kCamSliderVersion kCamSliderVersion1

Version information for the camera slider.

Definition at line 43 of file palmOneCameraSlider.h.

#define kCamSliderVersion1 sysMakeROMVersion(1, 0, 0, sysROMStageDevelopment, 0)

Version information for the camera slider.

Definition at line 40 of file palmOneCameraSlider.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:07:46 2008 for Palm API Guide


Header Files » Incs » 68k » system

68k/system/palmOneChars.h File Reference

Include dependency graph for 68k/system/palmOneChars.h:

Go to the source code of this file.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:07:46 2008 for Palm API Guide


Header Files » Incs » common » system

common/system/palmOneChars.h File Reference

Include dependency graph for common/system/palmOneChars.h:

Go to the source code of this file.

Defines

  • #define vchrHard5 0x0214
  • #define vchrHard6 0x0215
  • #define keyBitHard5 0x2000
  • #define vchrRockerSelect vchrRockerCenter
  • #define vchrSilkClock (vchrPalmMin + 0)
  • #define vchrClock (vchrPalmMin + 1)
  • #define vchrPopupBrightness (vchrPalmMin + 2)
  • #define vchrNavChange (vchrPalmMin + 3)
  • #define vchrCameraShutter (vchrPalmMin + 8)
  • #define vchrHardRecord (vchrHard5)
The following group of characters are specific for Tungsten W
  • #define vchrDeviceSpecificChar (vchrPalmMin+20)
  • #define vchrHard3Down (vchrDeviceSpecificChar + 0)
  • #define vchrHard4Down (vchrDeviceSpecificChar + 1)
  • #define vchrDeviceIncomingCall (vchrDeviceSpecificChar + 2)
  • #define vchrTelDevicePowerOn (vchrDeviceSpecificChar + 3)
  • #define vchrMyFavoriteApplication (vchrDeviceSpecificChar + 4)
  • #define vchrTelDevicePowerFinished (vchrDeviceSpecificChar + 5)
  • #define vchrBacklightToggled (vchrDeviceSpecificChar + 6)
  • #define vchrKeyboardSymbol (vchrDeviceSpecificChar + 9)
  • #define vchrReplaceLastChar (vchrDeviceSpecificChar + 10)
  • #define vchrFunctionFiveWay (vchrDeviceSpecificChar + 11)
  • #define vchrEmergencyCall (vchrDeviceSpecificChar + 12)
  • #define vchrPowerOnPhone (vchrDeviceSpecificChar + 14)
Character codes for thumb-wheel keys
  • #define vchrThumbWheelUp 0x012E
  • #define vchrThumbWheelDown 0x012F
  • #define vchrThumbWheelPush 0x0130
  • #define vchrThumbWheelBack 0x0131
Character codes for rocker keys
  • #define vchrRockerUp 0x0132
  • #define vchrRockerDown 0x0133
  • #define vchrRockerLeft 0x0134
  • #define vchrRockerRight 0x0135
  • #define vchrRockerCenter 0x0136

Define Documentation

#define keyBitHard5 0x2000

The keyBit mask used for polling the 5th hard key.

Definition at line 44 of file common/system/palmOneChars.h.

#define vchrBacklightToggled (vchrDeviceSpecificChar + 6)

Tungsten W virtual character. < This character indicates that the backlight has been toggled.

Definition at line 110 of file common/system/palmOneChars.h.

#define vchrCameraShutter (vchrPalmMin + 8)

Camera shutter virtual character. < Generated by the camera shutter button. Currently only available on Zire71.

Definition at line 68 of file common/system/palmOneChars.h.

#define vchrClock (vchrPalmMin + 1)

Clock virtual character. < When handled by the system, it will launch the clock pop-up dialog.

Definition at line 56 of file common/system/palmOneChars.h.

#define vchrDeviceIncomingCall (vchrDeviceSpecificChar + 2)

Tungsten W virtual character. < This character indicates that there is an incoming call.

Definition at line 93 of file common/system/palmOneChars.h.

#define vchrDeviceSpecificChar (vchrPalmMin+20)

Definition at line 83 of file common/system/palmOneChars.h.

#define vchrEmergencyCall (vchrDeviceSpecificChar + 12)

Tungsten W virtual character. < This character indicates that an emergency call is being placed. < This occurs when the 4 hard keys are all pressed at once.

Definition at line 127 of file common/system/palmOneChars.h.

#define vchrFunctionFiveWay (vchrDeviceSpecificChar + 11)

Tungsten W virtual character. < This character indicates that a 5-way event has been triggered.

Definition at line 123 of file common/system/palmOneChars.h.

#define vchrHard3Down (vchrDeviceSpecificChar + 0)

Tungsten W virtual character. < This character indicates that 3rd Hard key is down. Used to check for press and hold event.

Definition at line 85 of file common/system/palmOneChars.h.

#define vchrHard4Down (vchrDeviceSpecificChar + 1)

Tungsten W virtual character. < This character indicates that 4th Hard key is down. Used to check for press and hold event.

Definition at line 89 of file common/system/palmOneChars.h.

#define vchrHard5 0x0214

To match PalmOS 5.1 definition in Chars.h.

Definition at line 36 of file common/system/palmOneChars.h.

#define vchrHard6 0x0215

Definition at line 40 of file common/system/palmOneChars.h.

#define vchrHardRecord (vchrHard5)

Record button virtual character. < On Tungsten T, this button is located below the microphone. On Tungsten W < and Tungsten C, the button is generally placed on the headset.

Definition at line 72 of file common/system/palmOneChars.h.

#define vchrKeyboardSymbol (vchrDeviceSpecificChar + 9)

Tungsten W virtual character. < This character indicates that the space key has been pressed with the function key.

Definition at line 114 of file common/system/palmOneChars.h.

#define vchrMyFavoriteApplication (vchrDeviceSpecificChar + 4)

Tungsten W virtual character. < This character indicates that the Favorite Application button has been pressed. < The button is UP at this point.

Definition at line 101 of file common/system/palmOneChars.h.

#define vchrNavChange (vchrPalmMin + 3)

Five way navigation virtual character. < This character indicates that the five way navigation states have changed.

Definition at line 64 of file common/system/palmOneChars.h.

#define vchrPopupBrightness (vchrPalmMin + 2)

Pop-up brightness virtual character. < When handled by the system, it will launch the brightness pop-up dialog.

Definition at line 60 of file common/system/palmOneChars.h.

#define vchrPowerOnPhone (vchrDeviceSpecificChar + 14)

Tungsten W virtual character. < This character indicates that a request to toggle the phone on or off has been made.

Definition at line 132 of file common/system/palmOneChars.h.

#define vchrReplaceLastChar (vchrDeviceSpecificChar + 10)

Tungsten W virtual character. < This character indicates that a replace last char event has been triggered. < This occurs when an alpha numeric key is pressed and held.

Definition at line 118 of file common/system/palmOneChars.h.

#define vchrRockerCenter 0x0136

5-way rocker center/press

Definition at line 170 of file common/system/palmOneChars.h.

#define vchrRockerDown 0x0133

5-way rocker down

Definition at line 167 of file common/system/palmOneChars.h.

#define vchrRockerLeft 0x0134

5-way rocker left

Definition at line 168 of file common/system/palmOneChars.h.

#define vchrRockerRight 0x0135

5-way rocker right

Definition at line 169 of file common/system/palmOneChars.h.

#define vchrRockerSelect vchrRockerCenter

Definition at line 176 of file common/system/palmOneChars.h.

#define vchrRockerUp 0x0132

5-way rocker up

Definition at line 166 of file common/system/palmOneChars.h.

#define vchrSilkClock (vchrPalmMin + 0)

Silk screen clock button virtual character. < When handled by the system, it will launch the clock pop-up dialog.

Definition at line 52 of file common/system/palmOneChars.h.

#define vchrTelDevicePowerFinished (vchrDeviceSpecificChar + 5)

Tungsten W virtual character. < This character indicates that the backlight has been toggled.

Definition at line 106 of file common/system/palmOneChars.h.

#define vchrTelDevicePowerOn (vchrDeviceSpecificChar + 3)

Tungsten W virtual character. < This character indicates that the phone has been powered on

Definition at line 97 of file common/system/palmOneChars.h.

#define vchrThumbWheelBack 0x0131

optional thumb-wheel cluster back

Definition at line 155 of file common/system/palmOneChars.h.

#define vchrThumbWheelDown 0x012F

optional thumb-wheel down

Definition at line 153 of file common/system/palmOneChars.h.

#define vchrThumbWheelPush 0x0130

optional thumb-wheel press/center

Definition at line 154 of file common/system/palmOneChars.h.

#define vchrThumbWheelUp 0x012E

optional thumb-wheel up

Definition at line 152 of file common/system/palmOneChars.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:07:46 2008 for Palm API Guide


Header Files » Incs » common » libraries » codecpluginmgr

palmOneCodecFormat.h File Reference

Detailed Description

Public 68K common header file for Codec Plugin Manager API - Codec Formats.

Version:
1.0
This file contains the list of known codecs. The codecs listed below may not be implemented yet. Each format is identified with a 4-byte ID as an attempt to avoid collision and be human readable.

Definition in file palmOneCodecFormat.h.

Include dependency graph for palmOneCodecFormat.h:

Go to the source code of this file.

Data Structures

  • struct PalmImageParamType
    RAW image format parameters. More...
  • struct PalmImagePlanarType
    Planar image structure, passed during EncodeDecode. More...
  • struct PalmAudioPCMParamType
    PCM format parameters. More...
  • struct PalmAudioADPCMParamType
    IMA-ADPCM format parameters. More...
  • struct PalmAudioAACParamType
    AAC format parameters. More...
  • struct PalmAudioAACDecParamType
    AAC decoding parameters. More...
  • struct AacFileRef
  • struct PalmAudioAMRParamType
  • struct PalmAudioQCELPParamType
  • struct PalmAudioQCELPDecParamType
  • struct PalmAudioMP2ParamType
    MPEG-1 audio decoding parameters. More...
  • struct PalmFileFormatParamType
    File format parameters. More...
  • struct PalmImageBMPParamType
    BMP format parameters. More...
  • struct PalmImageJPEGEncodeParamType
    JPEG format encoding parameters. More...
  • struct PalmImageGIFFrameParamType
    GIF frame parameters. More...
  • struct PalmImageINDEXParamType
    Index image parameters. More...
  • struct PalmVideoMPEG1DecodeParamType
    MPEG-1 video decoding parameters. More...
  • struct PalmVideoMPEG4EncodeParamType
    MPEG-4 video format encoding parameters. More...
  • struct PalmVideoMPEG4DecodeParamType
    MPEG-4 video format decoding parameters. More...
  • struct PalmVideoAVCDecodeParamType
    AVC/H264 video format decoding parameters. More...
  • struct PalmVideoAVCCustomGetInfoType
    AVC/H264 Custom Control API structure for GetInfo about frame. More...
  • struct PalmVideoAVCCustomGetDecodedFrameType
    AVC/H264 Custom Control API structure for getting a decoded frame. More...
  • struct PalmVideoAVCCustomSetCropModeType
    AVC/H264 Custom Control API structure for getting a decoded frame. More...
  • struct PalmVideoAVCOutputBufferType
    AVC/H264 video format decoding parameters. More...

Defines

  • #define palmCodecImageBase 'IM00'
  • #define MAX_PLANE_COUNT 5
Audio Codecs
  • #define palmCodecAudioPCM 'PCM1'
  • #define palmCodecAudioAAC 'DAAC'
  • #define palmCodecAudioMP1 'MPG1'
  • #define palmCodecAudioMP2 'MPG2'
  • #define palmCodecAudioMP3 'MPG3'
  • #define palmCodecAudioVORBIS 'OGGV'
  • #define palmCodecAudioIMA_ADPCM 'APCM'
  • #define palmCodecAudioDVI_ADPCM 'DPCM'
  • #define palmCodecAudioALAW 'ALAW'
  • #define palmCodecAudioULAW 'ULAW'
Speech Codecs
  • #define palmCodecAudioAMR 'AMRS'
  • #define palmCodecAudioQCELP 'QCLP'
  • #define palmCodecAudioG711 'G711'
  • #define palmCodecAudioG722 'G722'
  • #define palmCodecAudioG726 'G726'
  • #define palmCodecAudioG728 'G728'
Video Codecs
  • #define palmCodecVideoMPEG4 'MPG4'
  • #define palmCodecVideoMPEG1 'Mpg1'
  • #define palmCodecVideoMPEG2 'Mpg2'
  • #define palmCodecVideoH263 'H263'
  • #define palmCodecVideoMJPEG 'MJPG'
  • #define palmCodecVideoDIVX 'DivX'
  • #define palmCodecVideoXVID 'XviD'
  • #define palmCodecVideoAVC 'AVCd'
Text Codecs
  • #define palmCodecText3G '3GTX'
Still Images Codecs
  • #define palmCodecImageJPEG 'JPEG'
  • #define palmCodecImageGIF87a 'GIF7'
  • #define palmCodecImageGIF89a 'GIF9'
  • #define palmCodecImagePNG 'PNGI'
  • #define palmCodecImageWBMP 'WBMP'
  • #define palmCodecImageTIFF 'TIFF'
Image File Formats
  • #define palmCodecImageJPEGFile 'JPEF'
  • #define palmCodecImageGIF87aFile 'GI7F'
  • #define palmCodecImageGIF89aFile 'GI9F'
  • #define palmCodecImagePNGFile 'PNGF'
  • #define palmCodecImageWBMPFile 'WBMF'
  • #define palmCodecImageTIFFFile 'TFFF'

Typedefs

  • typedef struct AacFileRef * AacFileRefPtr

Enumerations

  • enum {
    palmCodecImageARGB32 = palmCodecImageBase,
    palmCodecImageRGBA32,
    palmCodecImageRGB32,
    palmCodecImageRGB888,
    palmCodecImageRGB888Planar,
    palmCodecImageRGB565,
    palmCodecImageRGB555,
    palmCodecImageBGRA32,
    palmCodecImageBGR32,
    palmCodecImageBGR888,
    palmCodecImageBGR565,
    palmCodecImageBGR555,
    palmCodecImageYUV444,
    palmCodecImageYUV422,
    palmCodecImageYUV420,
    palmCodecImageYUV411,
    palmCodecImageYUV211,
    palmCodecImageYUV444Planar,
    palmCodecImageYUV422Planar,
    palmCodecImageYUV420Planar,
    palmCodecImageYUV411Planar,
    palmCodecImageYUV211Planar,
    palmCodecImageYCbCr444,
    palmCodecImageYCbCr422,
    palmCodecImageYCbCr420,
    palmCodecImageYCbCr411,
    palmCodecImageYCbCr211,
    palmCodecImageYCbCr444Planar,
    palmCodecImageYCbCr422Planar,
    palmCodecImageYCbCr420Planar,
    palmCodecImageYCbCr411Planar,
    palmCodecImageYCbCr211Planar,
    palmCodecImageRGBIndex16,
    palmCodecImageRGBIndex8,
    palmCodecImageRGBIndex4,
    palmCodecImageRGBIndex2,
    palmCodecImageRGBIndex1,
    palmCodecImageRGBIndex,
    palmCodecImageGRAY8,
    palmCodecImageGRAY4,
    palmCodecImageGRAY2,
    palmCodecImageGRAY1,
    palmCodecImageGIFFrame,
    palmCodecImageCMY,
    palmCodecImageCMYK,
    palmCodecImageHSL,
    palmCodecImageHSI,
    palmCodecImageHSV,
    palmCodecImageHCI
    }
  • enum PalmAudioChannelType {
    palmCodecMONO = 0x01,
    palmCodecSTEREO
    }
  • enum PalmBasicType {
    palmCodecINT8 = 0x01,
    palmCodecUINT8 = 0x11,
    palmCodecINT16Big = 0x02,
    palmCodecINT16Little = 0x12,
    palmCodecINT32Big = 0x04,
    palmCodecINT32Little = 0x14,
    palmCodecFloatBig = 0x24,
    palmCodecFloatLittle = 0x34,
    palmCodecUINT16Big,
    palmCodecUINT16Little,
    palmCodecINT24,
    palmCodecUINT24,
    palmCodecUINT32Big,
    palmCodecUINT32Little
    }
  • enum PalmEndianType {
    palmCodecBIG_ENDIAN,
    palmCodecLITTLE_ENDIAN
    }
  • enum PalmFileType {
    palmCodecVFSFile,
    palmCodecStreamFile
    }
  • enum PalmBMPCompressionType {
    palmCodecBMP_None,
    palmCodecBMP_RLE4,
    palmCodecBMP_RLE8
    }
  • enum PalmAACProfileType {
    palmCodecAACMainProfile,
    palmCodecAACLowComplexity,
    palmCodecAACScaleableSamplingRate
    }
  • enum PalmAMRMode {
    palmCodecAMR475,
    palmCodecAMR515,
    palmCodecAMR59,
    palmCodecAMRM67,
    palmCodecAMR74,
    palmCodecAMR795,
    palmCodecAMR102,
    palmCodecAMR122
    }
  • enum PalmAMRDtxMode {
    palmCodecAMRDtxDisable,
    palmCodecAMRDtxEnable
    }
  • enum PalmQCELPRate {
    palmCodecQCELPSilent,
    palmCodecQCELPEighth,
    palmCodecQCELPQuarter,
    palmCodecQCELPHalf,
    palmCodecQCELPFull
    }
  • enum PalmQCELPReducedRate {
    palmCodecQCELPReducedDisabled,
    palmCodecQCELPReducedEnabled
    }
  • enum AACHeaderType {
    palmCodecAAC_RAW,
    palmCodecAAC_ADIF,
    palmCodecAAC_ADTS,
    palmCodecAAC_MP4A,
    palmCodecAAC_LATM
    }
  • enum AACObjectType {
    MAIN = 1,
    LC,
    SSR,
    LTP,
    HE_AAC,
    ER_LC = 17,
    ER_LTP = 19,
    LD = 23,
    DRM_ER_LC = 27
    }
  • enum FileFlag {
    VFS = 1,
    FileStream = 2
    }
  • enum PalmMPEG4Algorithm {
    palmCodecMPEG4MVFAST,
    palmCodecMPEG4SEA
    }
  • enum PalmCodecControlType {
    palmCodecCtlGetVersion,
    palmCodecCtlGetAuthor,
    palmCodecCtlGetDate,
    palmCodecCtlGetComments,
    palmCodecCtlLastBuffer,
    palmCodecCtlCustomBase = 0x80000000,
    palmCodecCtlAVCGetInfo,
    palmCodecCtlAVCGetDecodedFrame,
    palmCodecCtlAVCSetCropMode,
    palmCodecCtlPutSeed,
    palmCodecCtlGetKey,
    palmCodecCtlPutKey,
    palmCodecCtlAACGetInfo
    }

Define Documentation

#define MAX_PLANE_COUNT 5

Maximum number of image planes

Definition at line 364 of file palmOneCodecFormat.h.

#define palmCodecAudioAAC 'DAAC'

AAC Audio Format.

Definition at line 33 of file palmOneCodecFormat.h.

#define palmCodecAudioALAW 'ALAW'

A-Law Audio Format.

Definition at line 40 of file palmOneCodecFormat.h.

#define palmCodecAudioAMR 'AMRS'

GSM-AMR Speech Format.

Definition at line 48 of file palmOneCodecFormat.h.

#define palmCodecAudioDVI_ADPCM 'DPCM'

Intel/MS/DVI ADPCM.

Definition at line 39 of file palmOneCodecFormat.h.

#define palmCodecAudioG711 'G711'

G.711 Speech Format.

Definition at line 50 of file palmOneCodecFormat.h.

#define palmCodecAudioG722 'G722'

G.722 Speech Format.

Definition at line 51 of file palmOneCodecFormat.h.

#define palmCodecAudioG726 'G726'

G.726 Speech Format.

Definition at line 52 of file palmOneCodecFormat.h.

#define palmCodecAudioG728 'G728'

G.728 Speech Format.

Definition at line 53 of file palmOneCodecFormat.h.

#define palmCodecAudioIMA_ADPCM 'APCM'

IMA ADPCM Audio Format.

Definition at line 38 of file palmOneCodecFormat.h.

#define palmCodecAudioMP1 'MPG1'

MPEG Layer 1 Audio Format.

Definition at line 34 of file palmOneCodecFormat.h.

#define palmCodecAudioMP2 'MPG2'

MPEG Layer 2 Audio Format.

Definition at line 35 of file palmOneCodecFormat.h.

#define palmCodecAudioMP3 'MPG3'

MPEG Layer 3 Audio Format.

Definition at line 36 of file palmOneCodecFormat.h.

#define palmCodecAudioPCM 'PCM1'

Raw PCM Audio Format.

Definition at line 32 of file palmOneCodecFormat.h.

#define palmCodecAudioQCELP 'QCLP'

CDMA-QCELP Speech Format.

Definition at line 49 of file palmOneCodecFormat.h.

#define palmCodecAudioULAW 'ULAW'

U-Law Audio Format.

Definition at line 41 of file palmOneCodecFormat.h.

#define palmCodecAudioVORBIS 'OGGV'

OGG Vorbis Audio Format.

Definition at line 37 of file palmOneCodecFormat.h.

#define palmCodecImageBase 'IM00'

Base code for Image formats.

Definition at line 102 of file palmOneCodecFormat.h.

#define palmCodecImageGIF87a 'GIF7'

GIF87a Image Format.

Definition at line 83 of file palmOneCodecFormat.h.

#define palmCodecImageGIF87aFile 'GI7F'

GIF87a Image File Format.

Definition at line 95 of file palmOneCodecFormat.h.

#define palmCodecImageGIF89a 'GIF9'

GIF89a Image Format.

Definition at line 84 of file palmOneCodecFormat.h.

#define palmCodecImageGIF89aFile 'GI9F'

GIF89a Image Format.

Definition at line 96 of file palmOneCodecFormat.h.

#define palmCodecImageJPEG 'JPEG'

JPEG Image Format.

Definition at line 82 of file palmOneCodecFormat.h.

#define palmCodecImageJPEGFile 'JPEF'

JPEG Image File Format.

Definition at line 94 of file palmOneCodecFormat.h.

#define palmCodecImagePNG 'PNGI'

Portable Network Graphics Image Format.

Definition at line 85 of file palmOneCodecFormat.h.

#define palmCodecImagePNGFile 'PNGF'

Portable Network Graphics Image File Format.

Definition at line 97 of file palmOneCodecFormat.h.

#define palmCodecImageTIFF 'TIFF'

TIFF Image Format.

Definition at line 87 of file palmOneCodecFormat.h.

#define palmCodecImageTIFFFile 'TFFF'

TIFF Image File Format.

Definition at line 99 of file palmOneCodecFormat.h.

#define palmCodecImageWBMP 'WBMP'

Windows Bitmap Image Format.

Definition at line 86 of file palmOneCodecFormat.h.

#define palmCodecImageWBMPFile 'WBMF'

Windows Bitmap Image File Format.

Definition at line 98 of file palmOneCodecFormat.h.

#define palmCodecText3G '3GTX'

3G Text Format.

Definition at line 75 of file palmOneCodecFormat.h.

#define palmCodecVideoAVC 'AVCd'

AVC(H.264) Video Format.

Definition at line 67 of file palmOneCodecFormat.h.

#define palmCodecVideoDIVX 'DivX'

DivX Video Format.

Definition at line 65 of file palmOneCodecFormat.h.

#define palmCodecVideoH263 'H263'

H263 Video Format.

Definition at line 63 of file palmOneCodecFormat.h.

#define palmCodecVideoMJPEG 'MJPG'

Motion JPEG Video Format.

Definition at line 64 of file palmOneCodecFormat.h.

#define palmCodecVideoMPEG1 'Mpg1'

MPEG-1 Video Format.

Definition at line 61 of file palmOneCodecFormat.h.

#define palmCodecVideoMPEG2 'Mpg2'

MPEG-2 Video Format.

Definition at line 62 of file palmOneCodecFormat.h.

#define palmCodecVideoMPEG4 'MPG4'

MPEG-4 Video Format.

Definition at line 60 of file palmOneCodecFormat.h.

#define palmCodecVideoXVID 'XviD'

XviD Video Format.

Definition at line 66 of file palmOneCodecFormat.h.

Typedef Documentation

typedef struct AacFileRef * AacFileRefPtr

Enumeration Type Documentation

anonymous enum

Image Formats

Enumerator:
palmCodecImageARGB32 | 32 bit color with alpha channel.
palmCodecImageRGBA32 | ('IM01') 32 bit color with alpha channel.
palmCodecImageRGB32 | ('IM02') 32 bit RGB color without alpha channel.
palmCodecImageRGB888 | ('IM03') 24 bit RGB color.
palmCodecImageRGB888Planar | ('IM04') 24 bit RGB Planar color.
palmCodecImageRGB565 | ('IM05') 16 bit RGB color.
palmCodecImageRGB555 | ('IM06') 16 bit RGB color + don't care.
palmCodecImageBGRA32 | ('IM07') 32 bit BGR color with alpha channel.
palmCodecImageBGR32 | ('IM08') 32 bit BGR color without alpha channel.
palmCodecImageBGR888 | ('IM09') 24 bit BGR color.
palmCodecImageBGR565 | ('IM0:') 16 bit BGR color.
palmCodecImageBGR555 | ('IM0;') 16 bit BGR color + don't care.
palmCodecImageYUV444 | ('IM0<') 4:4:4 YUV format.
palmCodecImageYUV422 | ('IM0=') 4:2:2 YUV format.
palmCodecImageYUV420 | ('IM0>') 4:2:0 YUV format.
palmCodecImageYUV411 | ('IM0?') 4:1:1 YUV format.
palmCodecImageYUV211 | ('IM0@') 2:1:1 YUV format.
palmCodecImageYUV444Planar | ('IM0A') 4:4:4 Planar YUV format.
palmCodecImageYUV422Planar | ('IM0B') 4:2:2 Planar YUV format.
palmCodecImageYUV420Planar | ('IM0C') 4:2:0 Planar YUV format.
palmCodecImageYUV411Planar | ('IM0D') 4:1:1 Planar YUV format.
palmCodecImageYUV211Planar | ('IM0E') 2:1:1 Planar YUV format.
palmCodecImageYCbCr444 | ('IM0F') 4:4:4 YCbCr format.
palmCodecImageYCbCr422 | ('IM0G') 4:2:2 YCbCr format.
palmCodecImageYCbCr420 | ('IM0H') 4:2:0 YCbCr format.
palmCodecImageYCbCr411 | ('IM0I') 4:1:1 YCbCr format.
palmCodecImageYCbCr211 | ('IM0J') 2:1:1 YCbCr format.
palmCodecImageYCbCr444Planar | ('IM0K') 4:4:4 Planar YCbCr format.
palmCodecImageYCbCr422Planar | ('IM0L') 4:2:2 Planar YCbCr format.
palmCodecImageYCbCr420Planar | ('IM0M') 4:2:0 Planar YCbCr format.
palmCodecImageYCbCr411Planar | ('IM0N') 4:1:1 Planar YCbCr format.
palmCodecImageYCbCr211Planar | ('IM0O') 2:1:1 Planar YCbCr format.
palmCodecImageRGBIndex16 | ('IM0P') Palettized 16 bit RGB.
palmCodecImageRGBIndex8 | ('IM0Q') Palettized 8 bit RGB.
palmCodecImageRGBIndex4 | ('IM0R') Palettized 4 bit RGB.
palmCodecImageRGBIndex2 | ('IM0S') Palettized 2 bit RGB.
palmCodecImageRGBIndex1 | ('IM0T') Palettized 1 bit RGB.
palmCodecImageRGBIndex | ('IM0U') Palettized RGB (unknowm index size).
palmCodecImageGRAY8 | ('IM0V') Gray color 8 bit.
palmCodecImageGRAY4 | ('IM0W') Gray color 4 bit.
palmCodecImageGRAY2 | ('IM0X') Gray color 2 bit.
palmCodecImageGRAY1 | ('IM0Y') Gray color 1 bit.
palmCodecImageGIFFrame | ('IM0Z') GIF Frame format.
palmCodecImageCMY | ('IM0[') Cyan Magenta Yellow format.
palmCodecImageCMYK | ('IM0\') Cyan Magenta Yellow BlacK format.
palmCodecImageHSL | ('IM0]') Hue Saturation Lightness format.
palmCodecImageHSI | ('IM0^') Hue Saturation Intensity format.
palmCodecImageHSV | ('IM0_') Hue Saturation Value format.
palmCodecImageHCI | ('IM0`') Hue Chroma Intensity format.

Definition at line 107 of file palmOneCodecFormat.h.

00108 {
00109     palmCodecImageARGB32 = palmCodecImageBase, /**< 32 bit color with alpha channel. */
00110     palmCodecImageRGBA32,           /**< ('IM01') 32 bit color with alpha channel. */
00111     palmCodecImageRGB32,            /**< ('IM02') 32 bit RGB color without alpha channel. */
00112     palmCodecImageRGB888,           /**< ('IM03') 24 bit RGB color. */
00113     palmCodecImageRGB888Planar,     /**< ('IM04') 24 bit RGB Planar color. */
00114     palmCodecImageRGB565,           /**< ('IM05') 16 bit RGB color. */
00115     palmCodecImageRGB555,           /**< ('IM06') 16 bit RGB color + don't care. */
00116     palmCodecImageBGRA32,           /**< ('IM07') 32 bit BGR color with alpha channel. */
00117     palmCodecImageBGR32,            /**< ('IM08') 32 bit BGR color without alpha channel. */
00118     palmCodecImageBGR888,           /**< ('IM09') 24 bit BGR color. */
00119     palmCodecImageBGR565,           /**< ('IM0:') 16 bit BGR color. */
00120     palmCodecImageBGR555,           /**< ('IM0;') 16 bit BGR color + don't care. */
00121     palmCodecImageYUV444,           /**< ('IM0<') 4:4:4 YUV format. */
00122     palmCodecImageYUV422,           /**< ('IM0=') 4:2:2 YUV format. */
00123     palmCodecImageYUV420,           /**< ('IM0>') 4:2:0 YUV format. */
00124     palmCodecImageYUV411,           /**< ('IM0?') 4:1:1 YUV format. */
00125     palmCodecImageYUV211,           /**< ('IM0@') 2:1:1 YUV format. */
00126     palmCodecImageYUV444Planar,     /**< ('IM0A') 4:4:4 Planar YUV format. */
00127     palmCodecImageYUV422Planar,     /**< ('IM0B') 4:2:2 Planar YUV format. */
00128     palmCodecImageYUV420Planar,     /**< ('IM0C') 4:2:0 Planar YUV format. */
00129     palmCodecImageYUV411Planar,     /**< ('IM0D') 4:1:1 Planar YUV format. */
00130     palmCodecImageYUV211Planar,     /**< ('IM0E') 2:1:1 Planar YUV format. */
00131     palmCodecImageYCbCr444,         /**< ('IM0F') 4:4:4 YCbCr format. */
00132     palmCodecImageYCbCr422,         /**< ('IM0G') 4:2:2 YCbCr format. */
00133     palmCodecImageYCbCr420,         /**< ('IM0H') 4:2:0 YCbCr format. */
00134     palmCodecImageYCbCr411,         /**< ('IM0I') 4:1:1 YCbCr format. */
00135     palmCodecImageYCbCr211,         /**< ('IM0J') 2:1:1 YCbCr format. */
00136     palmCodecImageYCbCr444Planar,   /**< ('IM0K') 4:4:4 Planar YCbCr format. */
00137     palmCodecImageYCbCr422Planar,   /**< ('IM0L') 4:2:2 Planar YCbCr format. */
00138     palmCodecImageYCbCr420Planar,   /**< ('IM0M') 4:2:0 Planar YCbCr format. */
00139     palmCodecImageYCbCr411Planar,   /**< ('IM0N') 4:1:1 Planar YCbCr format. */
00140     palmCodecImageYCbCr211Planar,   /**< ('IM0O') 2:1:1 Planar YCbCr format. */
00141     palmCodecImageRGBIndex16,       /**< ('IM0P') Palettized 16 bit RGB. */
00142     palmCodecImageRGBIndex8,        /**< ('IM0Q') Palettized 8 bit RGB. */
00143     palmCodecImageRGBIndex4,        /**< ('IM0R') Palettized 4 bit RGB. */
00144     palmCodecImageRGBIndex2,        /**< ('IM0S') Palettized 2 bit RGB. */
00145     palmCodecImageRGBIndex1,        /**< ('IM0T') Palettized 1 bit RGB. */
00146     palmCodecImageRGBIndex,         /**< ('IM0U') Palettized RGB (unknowm index size). */
00147     palmCodecImageGRAY8,            /**< ('IM0V') Gray color 8 bit. */
00148     palmCodecImageGRAY4,            /**< ('IM0W') Gray color 4 bit. */
00149     palmCodecImageGRAY2,            /**< ('IM0X') Gray color 2 bit. */
00150     palmCodecImageGRAY1,            /**< ('IM0Y') Gray color 1 bit. */
00151     palmCodecImageGIFFrame,         /**< ('IM0Z') GIF Frame format. */
00152     palmCodecImageCMY,              /**< ('IM0[') Cyan Magenta Yellow format. */
00153     palmCodecImageCMYK,             /**< ('IM0\') Cyan Magenta Yellow BlacK format. */
00154     palmCodecImageHSL,              /**< ('IM0]') Hue Saturation Lightness format. */
00155     palmCodecImageHSI,              /**< ('IM0^') Hue Saturation Intensity format. */
00156     palmCodecImageHSV,              /**< ('IM0_') Hue Saturation Value format. */
00157     palmCodecImageHCI               /**< ('IM0`') Hue Chroma Intensity format. */
00158 };

enum AACHeaderType

AAC file formats

Enumerator:
palmCodecAAC_RAW | RAW format.
palmCodecAAC_ADIF | ADIF format.
palmCodecAAC_ADTS | ADTS format.
palmCodecAAC_MP4A | MP4A format.
palmCodecAAC_LATM | LATM format.

Definition at line 282 of file palmOneCodecFormat.h.

00282              {
00283     palmCodecAAC_RAW,   /**<  RAW format.  */
00284     palmCodecAAC_ADIF,  /**<  ADIF format. */
00285     palmCodecAAC_ADTS,  /**<  ADTS format. */
00286     palmCodecAAC_MP4A,  /**<  MP4A format. */
00287     palmCodecAAC_LATM   /**<  LATM format. */
00288
00289 } AACHeaderType;

enum AACObjectType

AAC object type

Enumerator:
MAIN
LC
SSR
LTP
HE_AAC
ER_LC
ER_LTP
LD
DRM_ER_LC

Definition at line 294 of file palmOneCodecFormat.h.

00294              {
00295     MAIN        = 1,
00296     LC,
00297     SSR,
00298     LTP,
00299     HE_AAC,
00300     ER_LC       = 17,
00301     ER_LTP      = 19,
00302     LD          = 23,
00303     DRM_ER_LC   = 27
00304
00305 } AACObjectType;

enum FileFlag

File flags

Enumerator:
VFS | VFS.
FileStream | FileStream.

Definition at line 310 of file palmOneCodecFormat.h.

00310              {
00311     VFS = 1,        /**<  VFS.  */
00312     FileStream = 2  /**<  FileStream. */
00313
00314 } FileFlag;

enum PalmAACProfileType

AAC profiles

Enumerator:
palmCodecAACMainProfile | Main Profile
palmCodecAACLowComplexity | Low Complexity Profile
palmCodecAACScaleableSamplingRate | SSR Profile

Definition at line 227 of file palmOneCodecFormat.h.

00227              {
00228     palmCodecAACMainProfile,  /**< Main Profile */
00229     palmCodecAACLowComplexity, /**< Low Complexity Profile */
00230     palmCodecAACScaleableSamplingRate /**< SSR Profile*/
00231
00232 } PalmAACProfileType;

enum PalmAMRDtxMode

AMR transmission settings

Enumerator:
palmCodecAMRDtxDisable | Disable discontinuous transmission mode.
palmCodecAMRDtxEnable | Enable discontinuous transmission mode.

Definition at line 252 of file palmOneCodecFormat.h.

00252              {
00253     palmCodecAMRDtxDisable, /**< Disable discontinuous transmission mode. */
00254     palmCodecAMRDtxEnable   /**< Enable discontinuous transmission mode. */
00255
00256 } PalmAMRDtxMode;

enum PalmAMRMode

AMR modes

Enumerator:
palmCodecAMR475 | 4.75 kBits/second.
palmCodecAMR515 | 5.15 kBits/second.
palmCodecAMR59 | 5.9 kBits/second.
palmCodecAMRM67 | 6.7 kBits/second.
palmCodecAMR74 | 7.4 kBits/second.
palmCodecAMR795 | 7.95 kBits/second.
palmCodecAMR102 | 10.2 kBits/second.
palmCodecAMR122 | 12.2 kBits/second.

Definition at line 237 of file palmOneCodecFormat.h.

00237              {
00238     palmCodecAMR475,        /**<  4.75 kBits/second. */
00239     palmCodecAMR515,        /**<  5.15 kBits/second. */
00240     palmCodecAMR59,         /**<  5.9  kBits/second. */
00241     palmCodecAMRM67,        /**<  6.7  kBits/second. */
00242     palmCodecAMR74,         /**<  7.4  kBits/second. */
00243     palmCodecAMR795,        /**<  7.95 kBits/second. */
00244     palmCodecAMR102,        /**< 10.2  kBits/second. */
00245     palmCodecAMR122         /**< 12.2  kBits/second. */
00246
00247 } PalmAMRMode;

enum PalmAudioChannelType

Audio channels

Enumerator:
palmCodecMONO | One channel.
palmCodecSTEREO | Two channels.

Definition at line 164 of file palmOneCodecFormat.h.

00164              {
00165     palmCodecMONO   = 0x01, /**< One channel. */
00166     palmCodecSTEREO         /**< Two channels. */
00167
00168 } PalmAudioChannelType;

enum PalmBasicType

Basic data types

Enumerator:
palmCodecINT8 | Signed 8-bit.
palmCodecUINT8 | Unsigned 8-bit.
palmCodecINT16Big | Signed 16-bit big-endian.
palmCodecINT16Little | Signed 16-bit little-endian.
palmCodecINT32Big | Signed 32-bit big-endian.
palmCodecINT32Little | Signed 32-bit little-endian.
palmCodecFloatBig | Float big-endian.
palmCodecFloatLittle | Float little-endian.
palmCodecUINT16Big | Unsigned 16-bit big-endian.
palmCodecUINT16Little | Unsigned 16-bit little-endian.
palmCodecINT24 | Signed 24-bit.
palmCodecUINT24 | Unsigned 24-bit.
palmCodecUINT32Big | Unsigned 32-bit big-endian.
palmCodecUINT32Little | Unsigned 32-bit little-endian.

Definition at line 173 of file palmOneCodecFormat.h.

00173              {
00174
00175     // Compatibility layer for sound manager
00176     palmCodecINT8           = 0x01, /**< Signed 8-bit. */
00177     palmCodecUINT8          = 0x11, /**< Unsigned 8-bit. */
00178     palmCodecINT16Big       = 0x02, /**< Signed 16-bit big-endian. */
00179     palmCodecINT16Little    = 0x12, /**< Signed 16-bit little-endian. */
00180     palmCodecINT32Big       = 0x04, /**< Signed 32-bit big-endian. */
00181     palmCodecINT32Little    = 0x14, /**< Signed 32-bit little-endian. */
00182     palmCodecFloatBig       = 0x24, /**< Float big-endian. */
00183     palmCodecFloatLittle    = 0x34, /**< Float little-endian. */
00184
00185     // Extra types
00186     palmCodecUINT16Big,             /**< Unsigned 16-bit big-endian. */
00187     palmCodecUINT16Little,          /**< Unsigned 16-bit little-endian. */
00188     palmCodecINT24,                 /**< Signed 24-bit. */
00189     palmCodecUINT24,                /**< Unsigned 24-bit. */
00190     palmCodecUINT32Big,             /**< Unsigned 32-bit big-endian. */
00191     palmCodecUINT32Little           /**< Unsigned 32-bit little-endian. */
00192
00193 } PalmBasicType;

enum PalmBMPCompressionType

BMP compression

Enumerator:
palmCodecBMP_None | No compression.
palmCodecBMP_RLE4 | RLE 4bit compression.
palmCodecBMP_RLE8 | RLE 8bit compression.

Definition at line 217 of file palmOneCodecFormat.h.

00217              {
00218     palmCodecBMP_None,      /**< No compression. */
00219     palmCodecBMP_RLE4,      /**< RLE 4bit compression. */
00220     palmCodecBMP_RLE8       /**< RLE 8bit compression. */
00221
00222 } PalmBMPCompressionType;

enum PalmCodecControlType

Custom controls / API selectors

Enumerator:
palmCodecCtlGetVersion | Get the codec version. (UInt32 in SysMakeROM style)
palmCodecCtlGetAuthor | Get the codec author. (Char[64])
palmCodecCtlGetDate | Get the codec date. (Char[10] like "09/02/2003")
palmCodecCtlGetComments | Get comments about the codec. (Char[512])
palmCodecCtlLastBuffer | Next EncodeDecode call will get the last buffer.
palmCodecCtlCustomBase | Custom custom control base.
palmCodecCtlAVCGetInfo | Get the video frame width/ht info.
palmCodecCtlAVCGetDecodedFrame | Get the decoded frame.
palmCodecCtlAVCSetCropMode | Set the crop mode.
palmCodecCtlPutSeed | Give the codec a random number.
palmCodecCtlGetKey | Get the encoded key from the codec.
palmCodecCtlPutKey | Give the re-encoded key to the codec.
palmCodecCtlAACGetInfo | Get the audio frame freq/chan info.

Definition at line 329 of file palmOneCodecFormat.h.

00329              {
00330     palmCodecCtlGetVersion,                 /**< Get the codec version. (UInt32 in SysMakeROM style) */
00331     palmCodecCtlGetAuthor,                  /**< Get the codec author. (Char[64]) */
00332     palmCodecCtlGetDate,                    /**< Get the codec date. (Char[10] like "09/02/2003") */
00333     palmCodecCtlGetComments,                /**< Get comments about the codec. (Char[512]) */
00334     palmCodecCtlLastBuffer,                 /**< Next EncodeDecode call will get the last buffer. */
00335     palmCodecCtlCustomBase  = 0x80000000,   /**< Custom custom control base. */
00336
00337     // AVC specific API
00338     palmCodecCtlAVCGetInfo,                 /**< Get the video frame width/ht info. */
00339     palmCodecCtlAVCGetDecodedFrame,         /**< Get the decoded frame. */
00340     palmCodecCtlAVCSetCropMode,             /**< Set the crop mode. */
00341
00342     // Secure access to particular codec
00343     palmCodecCtlPutSeed,                    /**< Give the codec a random number. */
00344     palmCodecCtlGetKey,                     /**< Get the encoded key from the codec. */
00345     palmCodecCtlPutKey,                     /**< Give the re-encoded key to the codec. */
00346
00347     // AAC specific API
00348     palmCodecCtlAACGetInfo                  /**< Get the audio frame freq/chan info. */
00349
00350 } PalmCodecControlType;

enum PalmEndianType

Endianess

Enumerator:
palmCodecBIG_ENDIAN | Big endian.
palmCodecLITTLE_ENDIAN | Little endian.

Definition at line 198 of file palmOneCodecFormat.h.

00198              {
00199     palmCodecBIG_ENDIAN,    /**< Big endian. */
00200     palmCodecLITTLE_ENDIAN  /**< Little endian. */
00201
00202 } PalmEndianType;

enum PalmFileType

File types

Enumerator:
palmCodecVFSFile | VFS File.
palmCodecStreamFile | Stream File.

Definition at line 208 of file palmOneCodecFormat.h.

00208              {
00209     palmCodecVFSFile,       /**< VFS File. */
00210     palmCodecStreamFile     /**< Stream File. */
00211
00212 } PalmFileType;

enum PalmMPEG4Algorithm

MPEG4 encoding algorithm

Enumerator:
palmCodecMPEG4MVFAST | Motion Vector Field Adaptation Search Technique.
palmCodecMPEG4SEA | Successive Elimination Algorithm.

Definition at line 319 of file palmOneCodecFormat.h.

00319              {
00320     palmCodecMPEG4MVFAST,   /**< Motion Vector Field Adaptation Search Technique. */
00321     palmCodecMPEG4SEA       /**< Successive Elimination Algorithm. */
00322
00323 } PalmMPEG4Algorithm;

enum PalmQCELPRate

QCELP rates

Enumerator:
palmCodecQCELPSilent | 0 Bits per packet.
palmCodecQCELPEighth | 20 Bits per packet.
palmCodecQCELPQuarter | 54 Bits per packet.
palmCodecQCELPHalf | 124 Bits per packet.
palmCodecQCELPFull | 266 Bits per packet.

Definition at line 261 of file palmOneCodecFormat.h.

00261              {
00262     palmCodecQCELPSilent,   /**<   0 Bits per packet. */
00263     palmCodecQCELPEighth,   /**<  20 Bits per packet. */
00264     palmCodecQCELPQuarter,  /**<  54 Bits per packet. */
00265     palmCodecQCELPHalf,     /**< 124 Bits per packet. */
00266     palmCodecQCELPFull      /**< 266 Bits per packet. */
00267
00268 } PalmQCELPRate;

enum PalmQCELPReducedRate

QCELP encoder settings

Enumerator:
palmCodecQCELPReducedDisabled | Disable reduced rate encoding.
palmCodecQCELPReducedEnabled | Enable reduced rate encoding.

Definition at line 273 of file palmOneCodecFormat.h.

00273              {
00274     palmCodecQCELPReducedDisabled,  /**<  Disable reduced rate encoding. */
00275     palmCodecQCELPReducedEnabled    /**<  Enable reduced rate encoding. */
00276
00277 } PalmQCELPReducedRate;

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:07:48 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » codecpluginmgr

palmOneCodecPluginMgr.h File Reference

Detailed Description

The Codec Plugin Manager is used to unify all different type of codecs that are available for PalmOne devices and provide a generic API for developers to access these codecs.

Version:
3.0
A typical application would use the library the following way:
  • Check is an input/output format pair is supported [optional]
  • Create a CodecSession with parameters that match the formats
  • Call EncodeDecode()
  • ...
  • Delete the session.

Definition in file palmOneCodecPluginMgr.h.

Include dependency graph for palmOneCodecPluginMgr.h:

Go to the source code of this file.

Functions

  • Err CodecMgrOpen (UInt16 refNum)
  • Err CodecMgrClose (UInt16 refNum)
  • Err CodecMgrSleep (UInt16 refNum)
  • Err CodecMgrWake (UInt16 refNum)
  • Err CodecMgrLibAPIVersion (UInt16 refNum, UInt32 codecMgrAPIVersion, UInt32 *codecMgrLibAPIVersionP)
  • Err CodecMgrCreateSession (UInt16 refNum, PalmCodecFormat inputFormat, void *inputParamP, PalmCodecFormat outputFormat, void *outputParamP, PalmCodecSession *sessionP)
  • Err CodecMgrCreateSessionByID (UInt16 refNum, PalmCodecFormat inputFormat, void *inputParamP, PalmCodecFormat outputFormat, void *outputParamP, UInt32 creatorID, UInt32 codecID, PalmCodecSession *sessionP)
  • Err CodecMgrDeleteSession (UInt16 refNum, PalmCodecSession *sessionP)
  • Err CodecMgrResetSession (UInt16 refNum, PalmCodecSession session)
  • Err CodecMgrGetMaxDestBufferSize (UInt16 refNum, PalmCodecSession session, void *srcBufferP, UInt32 srcBufferSize, UInt32 *destBufferSizeP)
  • Err CodecMgrEncodeDecode (UInt16 refNum, PalmCodecSession session, void *srcBufferP, UInt32 *srcBufferSizeP, void *destBufferP, UInt32 *destBufferSizeP)
  • Err CodecMgrCustomControl (UInt16 refNum, PalmCodecSession session, UInt32 apiCreator, UInt32 apiSelector, void *valueP, UInt32 *valueLenP)
  • Err CodecMgrEnumerateFormats (UInt16 refNum, UInt32 *formatIteratorP, PalmCodecFormat *inputFormatP, PalmCodecFormat *outputFormatP, UInt32 *creatorIDP, UInt32 *codecIDP)
  • Boolean CodecMgrIsFormatSupported (UInt16 refNum, PalmCodecFormat inputFormat, PalmCodecFormat outputFormat, UInt32 creatorID, UInt32 codecID)
  • Err CodecMgrGetSessionInfo (UInt16 refNum, PalmCodecSession session, PalmCodecFormat *inputFormatP, PalmCodecFormat *outputFormatP, UInt32 *creatorIDP, UInt32 *codecIDP)

Function Documentation

Err CodecMgrClose ( UInt16 refNum )

Closes the Codec Plugin Manager library.

Parameters:
refNum,: IN: Reference number of the CodecPluginMgr library.
Return values:
Err The library is closed and errNone is returned. If another application is still using the library, a kCodecMgrLibStillOpen error is returned.

Err CodecMgrCreateSession | ( | UInt16 | refNum,
 |  | PalmCodecFormat | inputFormat,
 |  | void * | inputParamP,
 |  | PalmCodecFormat | outputFormat,
 |  | void * | outputParamP,
 |  | PalmCodecSession * | sessionP
 | ) |  |

Create a Codec Session. A session is Codec dependent, which means it is up to a Codec to define the structure (if any) pointed by the Session. This function is called by the CodecPluginMgr. At this stage, the CPM has already selected a known format pair from its codec list. The input and output parameters have to match the format they represent. E.g. palmCodecImageJPEG as input uses PalmJPEGEncodeType palmCodecImageJPEG as output uses PalmJPEGDecodeType etc.

Parameters:
refNum,: IN: Reference number of the CodecPluginMgr library.
inputFormat,: IN: Input format for this session.
inputParamP,: IN: Parameter associated with the input format. NULL if not needed.
outputFormat,: IN: Output format for this session.
outputParamP,: IN: Parameter associated with the output format. NULL if not needed.
sessionP OUT: Receives the reference to the newly created session. This reference is passed into all future calls for this session.
Return values:
Err errNone if no error.

Err CodecMgrCreateSessionByID | ( | UInt16 | refNum,
 |  | PalmCodecFormat | inputFormat,
 |  | void * | inputParamP,
 |  | PalmCodecFormat | outputFormat,
 |  | void * | outputParamP,
 |  | UInt32 | creatorID,
 |  | UInt32 | codecID,
 |  | PalmCodecSession * | sessionP
 | ) |  |

Create a Codec Session using Creator and Codec ID. A session is Codec dependent, which means it is up to a Codec to define the structure (if any) pointed by the Session. This function is called by the CodecPluginMgr. At this stage, the CPM has already selected a known format pair from its codec list. The input and output parameters have to match the format they represent. E.g. palmCodecImageJPEG as input uses PalmJPEGEncodeType palmCodecImageJPEG as output uses PalmJPEGDecodeType etc.

This function is used to create a session when a multiple codecs using the same input and output format are available.

Parameters:
refNum,: IN: Reference number of the CodecPluginMgr library.
inputFormat,: IN: Input format for this session.
inputParamP,: IN: Parameter associated with the input format. NULL if not needed.
outputFormat,: IN: Output format for this session.
outputParamP,: IN: Parameter associated with the output format. NULL if not needed.
creatorID,: IN: Creator ID of the module containing the codec.
codecID,: IN: Codec ID for a specific codec.
sessionP,: OUT: Receives the reference to the newly created session. This reference is passed into all future calls for this session.
Returns:
errNone if no error.

Err CodecMgrCustomControl | ( | UInt16 | refNum,
 |  | PalmCodecSession | session,
 |  | UInt32 | apiCreator,
 |  | UInt32 | apiSelector,
 |  | void * | valueP,
 |  | UInt32 * | valueLenP
 | ) |  |

Handle a custom call.

The codec identifies the call and its API by a registered creator code and a selector. This allows codec developers to extend the API by defining selectors for their creator code. It also allows driver developers to support selectors (and custom calls) defined by other driver developers.

Parameters:
refNum,: IN: Reference number of the CodecPluginMgr library.
session,: IN: Codec session reference received from CodecCreateSession.
apiCreator,: IN: Registered creator code.
apiSelector,: IN: Custom operation to perform.
valueP,: IN: Buffer containing data specific to the operation.
valueLenP,: IN,OUT: Size of the valueP buffer on entry, size of data written to valueP on exit. If NULL, valueP is ignored.
Return values:
Err errNone if no error, kCodecMgrLibNotSupported if not supported.

Err CodecMgrDeleteSession | ( | UInt16 | refNum,
 |  | PalmCodecSession * | sessionP
 | ) |  |

Delete a session. This function has to delete any allocated memory and set the session reference to NULL.

Parameters:
refNum,: IN: Reference number of the CodecPluginMgr library.
sessionP,: IN: Pointer to the Codec session reference received from CodecCreateSession.
Return values:
Err errNone if no error.

Err CodecMgrEncodeDecode | ( | UInt16 | refNum,
 |  | PalmCodecSession | session,
 |  | void * | srcBufferP,
 |  | UInt32 * | srcBufferSizeP,
 |  | void * | destBufferP,
 |  | UInt32 * | destBufferSizeP
 | ) |  |

Encode or decode a block of data. The format of the source and destination buffers are set in a preceding call to CodecCreateSession and possibly calls to CodecCustomControl. Is is legal for this function to not encode/decode the whole source buffer. For example, if the source buffer contains a non-round number of encoded blocks, and the encoding format requires whole blocks, this call should encode/decode the even number of blocks, and set srcBufferP appropriately to indicate how much of the source data was actually encoded. The caller should then pass the un-encoded piece of the last chunk in on the next call to this function with the next chunk of data appended to the end of it.

Parameters:
refNum,: IN: Reference number of the CodecPluginMgr library.
session,: IN: Codec session reference received from CodecCreateSession.
srcBufferP,: IN: The source buffer to be processed.
srcBufferSizeP,: IN,OUT: On input, the size of srcBufferP in bytes. If the whole buffer is not processed, on output srcBufferP is set to the amount of source data that was processed.
destBufferP,: OUT: The destination buffer which receives the encoded/decoded data.
destBufferSizeP,: IN,OUT: On input, the size of destBufferP in bytes, on output the number of bytes of data written.
Return values:
Err errNone if no error

Err CodecMgrEnumerateFormats | ( | UInt16 | refNum,
 |  | UInt32 * | formatIteratorP,
 |  | PalmCodecFormat * | inputFormatP,
 |  | PalmCodecFormat * | outputFormatP,
 |  | UInt32 * | creatorIDP,
 |  | UInt32 * | codecIDP
 | ) |  |

Enumerate all supported input and output format pairs. A pair describes what input format is expected and what output format will come out of the Codec. Codecs can accept multiple format pairs. For example, an MP3 Codec might be able to decode only MP3, MP2, and MP1. In this case, the pairs are: [in: MP3 out: PCM codecID: 0] [in: MP2 out: PCM codecID: 0] [in: MP1 out: PCM codecID: 0]

The Codec ID is used if multiple codecs within the same PRC have the exact same input and output formats. For example, a DSP filter bank might specify PCM as both the input and output for every codec. Codec ID helps differentiate between these Codecs (Low-Pass, High-Pass, Band-Pass...). A Codec ID set to 0 (palmNULLCodecID) means that there is no need to look for a particular codec (for example, if there is only one codec in the PRC).

Pass a formatIteratorP of palmCodecIteratorStart to get the first pair. formatIteratorP will be updated to the next item. When returning the last format pair, the formatIteratorP will be set to palmCodecIteratorStop.

Sample:

PalmCodecFormat inputFormat, outputFormat; UInt32 codecID; UInt32 formatIterator = palmCodecIteratorStart; while (formatIterator != palmCodecIteratorStop) { if ((err = CodecEnumerateSupportedFormats(&formatIterator, &inputFormat, &outputFormat, &codecID)) != errNone) { // Do something with the format pair } else { // handle error... possibly by breaking out of the loop } }

Parameters:
refNum,: IN: Reference number of the CodecPluginMgr library.
formatIteratorP,: IN,OUT: Reference to the last entry enumerated Pass palmCodecIteratorStart to get the first entry. This is updated on return to reference the next entry or set to palmCodecIteratorStop if last directory entry.
inputFormatP,: IN: Receives the input format entry specified with formatIteratorP.
outputFormatP,: IN: Receives the output format entry specified with formatIteratorP.
creatorIDP,: IN: Pointer to the location where the creator ID associated with the current formatIteratorP entry is stored. Pass NULL to ignore this value for each codec.
codecIDP,: IN: Pointer to the location where the codec ID associated with the current formatIteratorP entry is stored. Pass NULL to ignore this value for each codec.
Return values:
Err errNone or kCodecErrBadParam

Err CodecMgrGetMaxDestBufferSize | ( | UInt16 | refNum,
 |  | PalmCodecSession | session,
 |  | void * | srcBufferP,
 |  | UInt32 | srcBufferSize,
 |  | UInt32 * | destBufferSizeP
 | ) |  |

Returns the output buffer size required given an input buffer. This function is not required, but rather is provided to try to help the caller allocate the appropriate amount of memory for a call to CodecEncodeDecode that takes the same parameters. It is recommended that you always return a number equal to or larger then the buffer that will be required to hold the output of the CodecEncodeDecode call.

Parameters:
refNum,: IN: Reference number of the CodecPluginMgr library.
session,: IN: Codec session reference received from CodecCreateSession.
srcBufferP,: IN: Input buffer.
srcBufferSize,: IN: Size of the input buffer in bytes.
destBufferSizeP,: OUT: Receives that maximum buffer size.
Return values:
Err errNone if no error, kCodecMgrLibNotSupported if no implemented.

Err CodecMgrGetSessionInfo | ( | UInt16 | refNum,
 |  | PalmCodecSession | session,
 |  | PalmCodecFormat * | inputFormatP,
 |  | PalmCodecFormat * | outputFormatP,
 |  | UInt32 * | creatorIDP,
 |  | UInt32 * | codecIDP
 | ) |  |

Get information about a session.

Parameters:
refNum,: IN: Reference number of the CodecPluginMgr library.
session,: IN: Session to reset.
inputFormatP,: OUT: Receives the input format entry specified with formatIteratorP.
outputFormatP,: OUT: Receives the output format entry specified with formatIteratorP.
creatorIDP,: OUT: Pointer to the location where the creator ID of the session is returned.
codecIDP,: OUT: Pointer to the location where the codec ID of the session is returned.
Return values:
Err errNone if no error.

Boolean CodecMgrIsFormatSupported | ( | UInt16 | refNum,
 |  | PalmCodecFormat | inputFormat,
 |  | PalmCodecFormat | outputFormat,
 |  | UInt32 | creatorID,
 |  | UInt32 | codecID
 | ) |  |

Checks whether an input and output format pair is supported by any codec or by a particular codec.

Parameters:
refNum,: IN: Reference number of the CodecPluginMgr library.
inputFormat,: IN: Input format for this session.
outputFormat,: IN: Output format for this session.
creatorID,: IN: Creator ID of the codec checked. Pass palmCodecNullID to ignore this parameter and check whether any available codec supports the given input and output format pair.
codecID,: IN: Codec ID of the codec checked. Pass palmCodecNullID to ignore this parameter and check whether any available codec supports the given input and output format pair.
Return values:
Boolean true if the format is supported by a codec or the specified codec, false if the format pair is not supported by a codec or the specified codec.

Err CodecMgrLibAPIVersion | ( | UInt16 | refNum,
 |  | UInt32 | codecMgrAPIVersion,
 |  | UInt32 * | codecMgrLibAPIVersionP
 | ) |  |

Return the version of the Codec Plugin Manager library API to which this Codec was written. The API version of the manager that is loading this plugin is passed in, so that the plugin can either handle older managers, or return kCodecMgrLibNotSupported.

Parameters:
refNum,: IN: Reference number of the CodecPluginMgr library.
codecMgrAPIVersion,: IN: The largest version of the codec API supported
codecMgrLibAPIVersionP,: IN: Receives the API version to which this plugin was written. If the plugin supports multiple API versions, this should be set to the same version as codecMgrAPIVersion.
Return values:
Err errNone if no error, kCodecMgrLibNotSupported if the manager is too old to handle this plugin

Err CodecMgrOpen ( UInt16 refNum )

Opens the Codec Plugin Manager library.

Parameters:
refNum,: IN: Reference number of the CodecPluginMgr library.
Return values:
Err errNone if no error

Err CodecMgrResetSession | ( | UInt16 | refNum,
 |  | PalmCodecSession | session
 | ) |  |

Reset a session.

Parameters:
refNum,: IN: Reference number of the CodecPluginMgr library.
session,: IN: Session to reset.
Return values:
Err errNone if no error.

Err CodecMgrSleep ( UInt16 refNum )

Standard Sleep function.

Parameters:
refNum,: IN: Reference number of the CodecPluginMgr library.
Return values:
Err errNone if no error

Err CodecMgrWake ( UInt16 refNum )

Standard Wake function.

Parameters:
refNum,: IN: Reference number of the CodecPluginMgr library.
Return values:
Err errNone if no error

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:07:49 2008 for Palm API Guide


Header Files » Incs » common » libraries » codecpluginmgr

palmOneCodecPluginMgrCommon.h File Reference

Detailed Description

Public 68K common header file for Codec Plugin Manager API - Library Definitions.

Version:
3.0
This file contains the library constants and error codes used in the APIs.

Definition in file palmOneCodecPluginMgrCommon.h.

Include dependency graph for palmOneCodecPluginMgrCommon.h:

Go to the source code of this file.

Defines

  • #define kCodecMgrLibName "CodecPluginMgr"
  • #define kCodecMgrLibType 'aext'
  • #define kCodecMgrLibCreator 'CdMg'
  • #define kCodecMgrLibErrorClass (oemErrorClass + 0x100)
  • #define kCodecPluginErrorClass (oemErrorClass + 0x300)
  • #define palmCodecNullID (0)
  • #define palmCodecInvalidSession (NULL)
Library Versions
  • #define kCodecMgrLibVersion3 sysMakeROMVersion(3, 0, 0, sysROMStageRelease, 0)
  • #define kCodecMgrLibVersion kCodecMgrLibVersion3
Library Error Codes
  • #define kCodecMgrLibErrStillOpen (kCodecMgrLibErrorClass | 0x01)
  • #define kCodecMgrLibErrInternal (kCodecMgrLibErrorClass | 0x02)
  • #define kCodecMgrLibErrBadParam (kCodecMgrLibErrorClass | 0x03)
  • #define kCodecMgrLibNotSupported (kCodecMgrLibErrorClass | 0x04)
  • #define kCodecMgrLibBadVersion (kCodecMgrLibErrorClass | 0x05)
  • #define kCodecMgrLibNoCodec (kCodecMgrLibErrorClass | 0x06)
Codec Session Error Codes
  • #define kCodecErrBadParam (kCodecPluginErrorClass | 0x01)
  • #define kCodecErrBufferOverrun (kCodecPluginErrorClass | 0x02)
  • #define kCodecErrBufferUnderrun (kCodecPluginErrorClass | 0x03)
  • #define kCodecErrFrameError (kCodecPluginErrorClass | 0x04)
  • #define kCodecErrInvalidHeader (kCodecPluginErrorClass | 0x05)
  • #define kCodecSyncNotFound (kCodecPluginErrorClass | 0x06)
  • #define kCodecErrInvalidState (kCodecPluginErrorClass | 0x07)
  • #define kCodecErrAlignment (kCodecPluginErrorClass | 0x08)
  • #define kCodecErrParsing (kCodecPluginErrorClass | 0x09)
  • #define kCodecErrNoMemory (kCodecPluginErrorClass | 0x10)
  • #define kCodecErrUnAuthorized (kCodecPluginErrorClass | 0x11)
  • #define kCodecErrUnknown (kCodecPluginErrorClass | 0xFF)
CodecSupportedFormatEnumerate Iterator
  • #define palmCodecIteratorStart (0xfffffffeL)
  • #define palmCodecIteratorStop (0xffffffffL)
Function Traps
  • #define kCodecMgrLibTrapLibAPIVersion (sysLibTrapCustom + 0)
  • #define kCodecMgrLibTrapCreateSession (sysLibTrapCustom + 1)
  • #define kCodecMgrLibTrapCreateSessionByID (sysLibTrapCustom + 2)
  • #define kCodecMgrLibTrapDeleteSession (sysLibTrapCustom + 3)
  • #define kCodecMgrLibTrapResetSession (sysLibTrapCustom + 4)
  • #define kCodecMgrLibTrapGetMaxDestBufferSize (sysLibTrapCustom + 5)
  • #define kCodecMgrLibTrapEncodeDecode (sysLibTrapCustom + 6)
  • #define kCodecMgrLibTrapCustomControl (sysLibTrapCustom + 7)
  • #define kCodecMgrLibTrapEnumerateFormats (sysLibTrapCustom + 8)
  • #define kCodecMgrLibTrapIsFormatSupported (sysLibTrapCustom + 9)
  • #define kCodecMgrLibTrapGetSessionInfo (sysLibTrapCustom + 10)

Typedefs

  • typedef void * PalmCodecSession
  • typedef UInt32 PalmCodecFormat

Define Documentation

#define kCodecErrAlignment (kCodecPluginErrorClass | 0x08)

Alignment error.

Definition at line 116 of file palmOneCodecPluginMgrCommon.h.

#define kCodecErrBadParam (kCodecPluginErrorClass | 0x01)

Codec Plug-In Bad parameters.

Definition at line 102 of file palmOneCodecPluginMgrCommon.h.

#define kCodecErrBufferOverrun (kCodecPluginErrorClass | 0x02)

Buffer Over-run.

Definition at line 104 of file palmOneCodecPluginMgrCommon.h.

#define kCodecErrBufferUnderrun (kCodecPluginErrorClass | 0x03)

Buffer Under-run.

Definition at line 106 of file palmOneCodecPluginMgrCommon.h.

#define kCodecErrFrameError (kCodecPluginErrorClass | 0x04)

Frame Error.

Definition at line 108 of file palmOneCodecPluginMgrCommon.h.

#define kCodecErrInvalidHeader (kCodecPluginErrorClass | 0x05)

Invalid Header.

Definition at line 110 of file palmOneCodecPluginMgrCommon.h.

#define kCodecErrInvalidState (kCodecPluginErrorClass | 0x07)

Invalide decoding/encoding state.

Definition at line 114 of file palmOneCodecPluginMgrCommon.h.

#define kCodecErrNoMemory (kCodecPluginErrorClass | 0x10)

Out of memory.

Definition at line 120 of file palmOneCodecPluginMgrCommon.h.

#define kCodecErrParsing (kCodecPluginErrorClass | 0x09)

Parsing error.

Definition at line 118 of file palmOneCodecPluginMgrCommon.h.

#define kCodecErrUnAuthorized (kCodecPluginErrorClass | 0x11)

Not being authorized.

Definition at line 122 of file palmOneCodecPluginMgrCommon.h.

#define kCodecErrUnknown (kCodecPluginErrorClass | 0xFF)

Unknown error.

Definition at line 124 of file palmOneCodecPluginMgrCommon.h.

#define kCodecMgrLibBadVersion (kCodecMgrLibErrorClass | 0x05)

Bad Codec Manager version.

Definition at line 89 of file palmOneCodecPluginMgrCommon.h.

#define kCodecMgrLibCreator 'CdMg'

CodecPluginMgr creator ID.

Definition at line 54 of file palmOneCodecPluginMgrCommon.h.

#define kCodecMgrLibErrBadParam (kCodecMgrLibErrorClass | 0x03)

Bad parameters.

Definition at line 85 of file palmOneCodecPluginMgrCommon.h.

#define kCodecMgrLibErrInternal (kCodecMgrLibErrorClass | 0x02)

Internal error.

Definition at line 83 of file palmOneCodecPluginMgrCommon.h.

#define kCodecMgrLibErrorClass (oemErrorClass + 0x100)

Codec Plug-In Manager error codes.

Definition at line 74 of file palmOneCodecPluginMgrCommon.h.

#define kCodecMgrLibErrStillOpen (kCodecMgrLibErrorClass | 0x01)

Returned from CodecMgrLibClose() if the library is still open.

Definition at line 81 of file palmOneCodecPluginMgrCommon.h.

#define kCodecMgrLibName "CodecPluginMgr"

CodecPluginMgr library name.

Definition at line 52 of file palmOneCodecPluginMgrCommon.h.

#define kCodecMgrLibNoCodec (kCodecMgrLibErrorClass | 0x06)

No codec available.

Definition at line 91 of file palmOneCodecPluginMgrCommon.h.

#define kCodecMgrLibNotSupported (kCodecMgrLibErrorClass | 0x04)

API or Codec not supported.

Definition at line 87 of file palmOneCodecPluginMgrCommon.h.

#define kCodecMgrLibTrapCreateSession (sysLibTrapCustom + 1)

Definition at line 157 of file palmOneCodecPluginMgrCommon.h.

#define kCodecMgrLibTrapCreateSessionByID (sysLibTrapCustom + 2)

Definition at line 158 of file palmOneCodecPluginMgrCommon.h.

#define kCodecMgrLibTrapCustomControl (sysLibTrapCustom + 7)

Definition at line 163 of file palmOneCodecPluginMgrCommon.h.

#define kCodecMgrLibTrapDeleteSession (sysLibTrapCustom + 3)

Definition at line 159 of file palmOneCodecPluginMgrCommon.h.

#define kCodecMgrLibTrapEncodeDecode (sysLibTrapCustom + 6)

Definition at line 162 of file palmOneCodecPluginMgrCommon.h.

#define kCodecMgrLibTrapEnumerateFormats (sysLibTrapCustom + 8)

Definition at line 164 of file palmOneCodecPluginMgrCommon.h.

#define kCodecMgrLibTrapGetMaxDestBufferSize (sysLibTrapCustom + 5)

Definition at line 161 of file palmOneCodecPluginMgrCommon.h.

#define kCodecMgrLibTrapGetSessionInfo (sysLibTrapCustom + 10)

Definition at line 166 of file palmOneCodecPluginMgrCommon.h.

#define kCodecMgrLibTrapIsFormatSupported (sysLibTrapCustom + 9)

Definition at line 165 of file palmOneCodecPluginMgrCommon.h.

#define kCodecMgrLibTrapLibAPIVersion (sysLibTrapCustom + 0)

Definition at line 156 of file palmOneCodecPluginMgrCommon.h.

#define kCodecMgrLibTrapResetSession (sysLibTrapCustom + 4)

Definition at line 160 of file palmOneCodecPluginMgrCommon.h.

#define kCodecMgrLibType 'aext'

CodecPluginMgr library type.

Definition at line 53 of file palmOneCodecPluginMgrCommon.h.

#define kCodecMgrLibVersion kCodecMgrLibVersion3

Definition at line 66 of file palmOneCodecPluginMgrCommon.h.

#define kCodecMgrLibVersion3 sysMakeROMVersion(3, 0, 0, sysROMStageRelease, 0)

Definition at line 65 of file palmOneCodecPluginMgrCommon.h.

#define kCodecPluginErrorClass (oemErrorClass + 0x300)

Codec Plugins error codes.

Definition at line 95 of file palmOneCodecPluginMgrCommon.h.

#define kCodecSyncNotFound (kCodecPluginErrorClass | 0x06)

Sync not found.

Definition at line 112 of file palmOneCodecPluginMgrCommon.h.

#define palmCodecInvalidSession (NULL)

Invalid session.

Definition at line 140 of file palmOneCodecPluginMgrCommon.h.

#define palmCodecIteratorStart (0xfffffffeL)

Start iterator.

Definition at line 135 of file palmOneCodecPluginMgrCommon.h.

#define palmCodecIteratorStop (0xffffffffL)

Stop iterator.

Definition at line 136 of file palmOneCodecPluginMgrCommon.h.

#define palmCodecNullID (0)

Null ID.

Definition at line 139 of file palmOneCodecPluginMgrCommon.h.

Typedef Documentation

typedef UInt32 PalmCodecFormat

Palm Codec Format.

Definition at line 146 of file palmOneCodecPluginMgrCommon.h.

typedef void* PalmCodecSession

Palm Codec Session.

Definition at line 143 of file palmOneCodecPluginMgrCommon.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:07:49 2008 for Palm API Guide


Header Files » Incs » common » system

palmOneCreators.h File Reference

Detailed Description

Contains Palm-specific creator codes.

Version:
1.0
Date:
02/29/2002

Definition in file palmOneCreators.h.

Include dependency graph for palmOneCreators.h:

Go to the source code of this file.

Defines

  • #define expMediaType_HD 'HDSK'
  • #define sysFileCTelMgrLibOem 'toem'
  • #define sysFileCSimATDriverOem 'sims'
  • #define sysFileCSimOfficer 'sats'
  • #define sysFileCSimWatcherLib 'simw'
  • #define sysFileCProvisioning 'prov'
  • #define sysFileCMobileServices 'msvc'
  • #define sysFileCMyFavorite 'myfv'
  • #define sysFileCNotePad 'npad'
  • #define sysFileCMobileApp 'mobi'
  • #define kPalmCreatorIDNetSlipHack 'PNHk'
  • #define kPalmOneCreatorIDContacts 'PAdd'
  • #define kPalmOneCreatorIDCalendar 'PDat'
  • #define kPalmOneCreatorIDMemos 'PMem'
  • #define kPalmOneCreatorIDNotePad 'npad'
  • #define kPalmOneCreatorIDTasks 'PTod'
  • #define kPalmOneCreatorIDVoiceMemo 'Vpad'
  • #define kPalmOneCreatorIDFavorites 'Fave'
  • #define kPalmOneCreatorIDFileBrowser 'PFil'
  • #define kPalmCreatorIDLcdState 'PmLo'

Define Documentation

#define expMediaType_HD 'HDSK'

Media types

Media types for different media used on palmOne devices. Media type for the Hard Disk

Definition at line 67 of file palmOneCreators.h.

#define kPalmCreatorIDLcdState 'PmLo'

Creator ID for the lcd broadcast of lcd on/off

Definition at line 57 of file palmOneCreators.h.

#define kPalmCreatorIDNetSlipHack 'PNHk'

Creator ID for the bluetooth slip app panel hack

Definition at line 41 of file palmOneCreators.h.

#define kPalmOneCreatorIDCalendar 'PDat'

Definition at line 50 of file palmOneCreators.h.

#define kPalmOneCreatorIDContacts 'PAdd'

Definition at line 49 of file palmOneCreators.h.

#define kPalmOneCreatorIDFavorites 'Fave'

Definition at line 55 of file palmOneCreators.h.

#define kPalmOneCreatorIDFileBrowser 'PFil'

Definition at line 56 of file palmOneCreators.h.

#define kPalmOneCreatorIDMemos 'PMem'

Definition at line 51 of file palmOneCreators.h.

#define kPalmOneCreatorIDNotePad 'npad'

Definition at line 52 of file palmOneCreators.h.

#define kPalmOneCreatorIDTasks 'PTod'

Definition at line 53 of file palmOneCreators.h.

#define kPalmOneCreatorIDVoiceMemo 'Vpad'

Definition at line 54 of file palmOneCreators.h.

#define sysFileCMobileApp 'mobi'

Creator ID for the Mobile application

Definition at line 40 of file palmOneCreators.h.

#define sysFileCMobileServices 'msvc'

Creator ID for the Mobile Service Library.

Definition at line 37 of file palmOneCreators.h.

#define sysFileCMyFavorite 'myfv'

Creator ID for the MyFavorite App.

Definition at line 38 of file palmOneCreators.h.

#define sysFileCNotePad 'npad'

Creator ID for the Notepad app.

Definition at line 39 of file palmOneCreators.h.

#define sysFileCProvisioning 'prov'

Creator ID for the provisioning application.

Definition at line 36 of file palmOneCreators.h.

#define sysFileCSimATDriverOem 'sims'

Creator ID for the SIM AT Driver.

Definition at line 33 of file palmOneCreators.h.

#define sysFileCSimOfficer 'sats'

Creator ID for the SIM Application Toolkit client application.

Definition at line 34 of file palmOneCreators.h.

#define sysFileCSimWatcherLib 'simw'

Creator ID for the SIM Watcher library.

Definition at line 35 of file palmOneCreators.h.

#define sysFileCTelMgrLibOem 'toem'

Creator ID for the Telephony Manager Extension shared library.

Definition at line 32 of file palmOneCreators.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:07:49 2008 for Palm API Guide


Header Files » Incs » common » system

palmOneFeatures.h File Reference

Detailed Description

Contains Palm-specific feature definitions.

Version:
1.0
Date:
02/29/2002

Definition in file palmOneFeatures.h.

Go to the source code of this file.

Defines

  • #define densityFtrCreator 'dnsT'
  • #define densityFtrVersion 0
  • #define sysNotifyHardDiskSpinup 'HSPU'
  • #define sysNotifyExternalDialogOpenedEvent 'edgO'
  • #define sysNotifyExternalDialogClosedEvent 'edgC'
  • #define screenFtrCreator 'scnP'
  • #define dpiFtrValue 1
Headset feature
  • #define headsetFtrCreator 'hseT'
  • #define headsetFtrVersion 0
  • #define sysExternalHeadsetInsertEvent 'hsiN'
  • #define sysExternalHeadsetRemoveEvent 'hsrM'
USB features
These features provide information on the USB capabilities of the device.

  • #define pmUsbFtrCreator 'pUSB'
  • #define pmUsbFtrVersion 0
  • #define USBFeatureCreator 'fUSB'
  • #define USBFeatureVersion 0
  • #define kUSBMTP 0x0001
  • #define kUSBTransfer 0x0002
  • #define kUSBHotSync 0x0004
  • #define kUSBDriveMode 0x0008
  • #define kUSBConsole 0x0010
  • #define kUSBDUN 0x0020
  • #define kUSBLogging 0x0040
  • #define USBSpeedCreator 'sUSB'
  • #define USBSpeedVersion 0
  • #define kUSBFSClient 0x0001
  • #define kUSBHSClient 0x0002
  • #define kUSBFSOnTheGo 0x0004
  • #define kUSBHSOnTheGo 0x0008
  • #define kUSBFSOnTheGoMultiDevice 0x0010
  • #define kUSBHSOnTheGoMultiDevice 0x0020
  • #define USBChargeCreator 'cUSB'
  • #define USBChargeVersion 0
  • #define kUSB500mACharge 0x0001
  • #define USBHwrCreator 'hUSB'
  • #define USBHwrVersion 0
  • #define kUSBMiniConnector 0x0001
  • #define kUSBMultiConnector 0x0002
  • #define irFtrVersionNumber 1
  • #define irFtrLowBatteryLevel 1

Define Documentation

#define densityFtrCreator 'dnsT'

The following feature should be defined on all devices that support hi-res screens & include NotePad 2.0 or higher. As the OS does not yet provide a method for the desktop SW/conduits to query the handheld in order to determine the density capabilities of the device, this feature has been added. By testing the presence/content of this feature, the device can properly convert any old lo-density RLE data to be hi-density PNG data on the first hotsync to the device rather than have to do a note-by-note conversion at run time on the handheld the first time each old note has been opened.

Definition at line 34 of file palmOneFeatures.h.

#define densityFtrVersion 0

Definition at line 35 of file palmOneFeatures.h.

#define dpiFtrValue 1

Screen DPI feature

Definition at line 47 of file palmOneFeatures.h.

#define headsetFtrCreator 'hseT'

Definition at line 55 of file palmOneFeatures.h.

#define headsetFtrVersion 0

Definition at line 56 of file palmOneFeatures.h.

#define irFtrLowBatteryLevel 1

Creator for USB feature

Definition at line 146 of file palmOneFeatures.h.

#define irFtrVersionNumber 1

Creator for USB feature

Definition at line 145 of file palmOneFeatures.h.

#define kUSB500mACharge 0x0001

Creator for USB feature

Definition at line 137 of file palmOneFeatures.h.

#define kUSBConsole 0x0010

Creator for USB feature

Definition at line 120 of file palmOneFeatures.h.

#define kUSBDriveMode 0x0008

Creator for USB feature

Definition at line 119 of file palmOneFeatures.h.

#define kUSBDUN 0x0020

Creator for USB feature

Definition at line 121 of file palmOneFeatures.h.

#define kUSBFSClient 0x0001

Creator for USB feature

Definition at line 127 of file palmOneFeatures.h.

#define kUSBFSOnTheGo 0x0004

Creator for USB feature

Definition at line 129 of file palmOneFeatures.h.

#define kUSBFSOnTheGoMultiDevice 0x0010

Creator for USB feature

Definition at line 131 of file palmOneFeatures.h.

#define kUSBHotSync 0x0004

Creator for USB feature

Definition at line 118 of file palmOneFeatures.h.

#define kUSBHSClient 0x0002

Creator for USB feature

Definition at line 128 of file palmOneFeatures.h.

#define kUSBHSOnTheGo 0x0008

Creator for USB feature

Definition at line 130 of file palmOneFeatures.h.

#define kUSBHSOnTheGoMultiDevice 0x0020

Creator for USB feature

Definition at line 132 of file palmOneFeatures.h.

#define kUSBLogging 0x0040

Creator for USB feature

Definition at line 122 of file palmOneFeatures.h.

#define kUSBMiniConnector 0x0001

Creator for USB feature

Definition at line 142 of file palmOneFeatures.h.

#define kUSBMTP 0x0001

Creator for USB feature

Definition at line 116 of file palmOneFeatures.h.

#define kUSBMultiConnector 0x0002

Creator for USB feature

Definition at line 143 of file palmOneFeatures.h.

#define kUSBTransfer 0x0002

Creator for USB feature

Definition at line 117 of file palmOneFeatures.h.

#define pmUsbFtrCreator 'pUSB'

Creator for USB feature

Definition at line 109 of file palmOneFeatures.h.

#define pmUsbFtrVersion 0

USB feature number

Definition at line 110 of file palmOneFeatures.h.

#define screenFtrCreator 'scnP'

Creator for screen feature

Definition at line 46 of file palmOneFeatures.h.

#define sysExternalHeadsetInsertEvent 'hsiN'

Broadcast when headset is inserted

Definition at line 64 of file palmOneFeatures.h.

#define sysExternalHeadsetRemoveEvent 'hsrM'

Broadcast when headset is removed

Definition at line 65 of file palmOneFeatures.h.

#define sysNotifyExternalDialogClosedEvent 'edgC'

Broadcast after closing the dialog

Definition at line 98 of file palmOneFeatures.h.

#define sysNotifyExternalDialogOpenedEvent 'edgO'

External dialog open/close from backgound task notification

These notifications should be sent by a background task if it wants to open a new/close a dialog. This notification should be used in conjunction with checking the SysUIBusy flag. The logic to be used is as follows: if (!SysUIBusy) display dialog else call SysNotifyBroadcast with sysNotifyExternalDialogOpenedEvent if (!SysUIBusy) display dialog

The foreground application should also be prepared to handle this event especially if it is using the LCD overlay. It should be prepared to receive more than one such notification by keeping a count of open dialog event. This count should be decremented for every sysNotifyExternalDialogClosedEvent. Only when this count becomes zero should the application restart using the display (LCD overlay). Broadcast before opening a dialog

Definition at line 97 of file palmOneFeatures.h.

#define sysNotifyHardDiskSpinup 'HSPU'

Hard Disk Spinup notification

Notification sent by the hard disk slot driver that the disk has spun up

Definition at line 74 of file palmOneFeatures.h.

#define USBChargeCreator 'cUSB'

Creator for USB feature

Definition at line 134 of file palmOneFeatures.h.

#define USBChargeVersion 0

Creator for USB feature

Definition at line 135 of file palmOneFeatures.h.

#define USBFeatureCreator 'fUSB'

Creator for USB feature

Definition at line 113 of file palmOneFeatures.h.

#define USBFeatureVersion 0

Creator for USB feature

Definition at line 114 of file palmOneFeatures.h.

#define USBHwrCreator 'hUSB'

Creator for USB feature

Definition at line 139 of file palmOneFeatures.h.

#define USBHwrVersion 0

Creator for USB feature

Definition at line 140 of file palmOneFeatures.h.

#define USBSpeedCreator 'sUSB'

Creator for USB feature

Definition at line 124 of file palmOneFeatures.h.

#define USBSpeedVersion 0

Creator for USB feature

Definition at line 125 of file palmOneFeatures.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:07:50 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » hirestimerlib

palmOneHiResTimer.h File Reference

Detailed Description

Public 68k include file for Hi-Resolution timer for Palm OS.

Version:
1.0

Definition in file palmOneHiResTimer.h.

Include dependency graph for palmOneHiResTimer.h:

Go to the source code of this file.

Functions

  • Err HRTimeLibOpen (UInt16 refNum)
  • Err HRTimeLibClose (UInt16 refNum)
  • Err HRTimeLibTicksPerSecond (UInt16 refNum, UInt32 *ticksP)
  • Err HRTimeLibGetTime (UInt16 refNum, UInt32 *ticksP, UInt32 *rolloverP)

Function Documentation

Err HRTimeLibClose ( UInt16 refNum )

Closes the Hi-Res Timer library.

Parameters:
refNum,: IN: Library reference number.
Return values:
Err Error code.

Err HRTimeLibGetTime | ( | UInt16 | refNum,
 |  | UInt32 * | ticksP,
 |  | UInt32 * | rolloverP
 | ) |  |

Get the current ticks for Hi-Resolution Timer.

Parameters:
refNum,: IN: Library reference number.
ticksP,: OUT: Current ticks.
rolloverP,: OUT: Number of rollover since the timer started.
Return values:
Err Error code.

Err HRTimeLibOpen ( UInt16 refNum )

Opens the Hi-Res Timer library.

Parameters:
refNum,: IN: Library reference number.
Return values:
Err Error code.

Err HRTimeLibTicksPerSecond | ( | UInt16 | refNum,
 |  | UInt32 * | ticksP
 | ) |  |

Get the frequency of the Hi-Resolution Timer.

Parameters:
refNum,: IN: Library reference number.
ticksP,: OUT: Frequency of the timer.
Return values:
Err Error code.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:07:50 2008 for Palm API Guide


Header Files » Incs » common » libraries » hirestimerlib

palmOneHiResTimerCommon.h File Reference

Detailed Description

Public 68k common header file for Hi-Resolution Timer API.

Version:
1.0
This file contains the common library constants and error codes.

Definition in file palmOneHiResTimerCommon.h.

Include dependency graph for palmOneHiResTimerCommon.h:

Go to the source code of this file.

Defines

  • #define kHiResTimeLibType 'libr'
  • #define kHiResTimeLibCreator 'pHRT'
  • #define kHiResTimeLibName "HRTimer-Lib"
Library Versions
  • #define kHiResTimeLibVersion1 sysMakeROMVersion(1, 0, 0, sysROMStageRelease, 0)
  • #define kHiResTimeLibVersion2 sysMakeROMVersion(2, 0, 0, sysROMStageRelease, 0)
  • #define kHiResTimeLibVersion kCamLibVersion2
Error Codes
  • #define kHiResTimeErrorClass (oemErrorClass + 0x100)
  • #define kHiResTimeLibErrBadParam (kHiResTimeErrorClass | 0x01)
  • #define kHiResTimeLibErrNotOpen (kHiResTimeErrorClass | 0x02)
  • #define kHiResTimeLibErrStillOpen (kHiResTimeErrorClass | 0x03)
  • #define kHiResTimeLibErrNotAvailable (kHiResTimeErrorClass | 0x04)
Function Traps
  • #define kHRLibTrapTimerTicksPerSecond (sysLibTrapCustom)
  • #define kHRLibTrapTimerGetTime (sysLibTrapCustom+1)

Define Documentation

#define kHiResTimeErrorClass (oemErrorClass + 0x100)

Hi-Res timer base error number

Definition at line 72 of file palmOneHiResTimerCommon.h.

#define kHiResTimeLibCreator 'pHRT'

Hi-Res timer library database creator

Definition at line 42 of file palmOneHiResTimerCommon.h.

#define kHiResTimeLibErrBadParam (kHiResTimeErrorClass | 0x01)

Bad Parameter

Definition at line 74 of file palmOneHiResTimerCommon.h.

#define kHiResTimeLibErrNotAvailable (kHiResTimeErrorClass | 0x04)

Fucntion not availabe - If returned by HRTimeLibOpen, there is no HiRes Timer available.

Definition at line 80 of file palmOneHiResTimerCommon.h.

#define kHiResTimeLibErrNotOpen (kHiResTimeErrorClass | 0x02)

Library is not open

Definition at line 76 of file palmOneHiResTimerCommon.h.

#define kHiResTimeLibErrStillOpen (kHiResTimeErrorClass | 0x03)

Returned from HRTimeLibClose() if the library is still open

Definition at line 78 of file palmOneHiResTimerCommon.h.

#define kHiResTimeLibName "HRTimer-Lib"

Hi-Res timer library name

Definition at line 48 of file palmOneHiResTimerCommon.h.

#define kHiResTimeLibType 'libr'

Hi-Res timer library database type

Definition at line 41 of file palmOneHiResTimerCommon.h.

#define kHiResTimeLibVersion kCamLibVersion2

Hi-Res timer library version 2

Definition at line 60 of file palmOneHiResTimerCommon.h.

#define kHiResTimeLibVersion1 sysMakeROMVersion(1, 0, 0, sysROMStageRelease, 0)

Hi-Res timer library version 1

Definition at line 58 of file palmOneHiResTimerCommon.h.

#define kHiResTimeLibVersion2 sysMakeROMVersion(2, 0, 0, sysROMStageRelease, 0)

Hi-Res timer library version 2

Definition at line 59 of file palmOneHiResTimerCommon.h.

#define kHRLibTrapTimerGetTime (sysLibTrapCustom+1)

Definition at line 92 of file palmOneHiResTimerCommon.h.

#define kHRLibTrapTimerTicksPerSecond (sysLibTrapCustom)

Definition at line 91 of file palmOneHiResTimerCommon.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:07:50 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » lcdoverlaylib

palmOneLcdOverlay.h File Reference

Detailed Description

Public 68k include file for LCDOverlay API that can be used to display YCbCr images directly on the screen.

Version:
1.0

Definition in file palmOneLcdOverlay.h.

Include dependency graph for palmOneLcdOverlay.h:

Go to the source code of this file.

Functions

  • Err LcdOverlayLibOpen (UInt16 refNum)
  • Err LcdOverlayLibClose (UInt16 refNum)
  • Err LcdOverlayLibGetVersion (UInt16 refNum, UInt32 sdkVersion, UInt32 *libVersionP)
  • Err LcdOverlayLibControl (UInt16 refNum, LcdOverlayLibControlType cmdId, void *parameterP)

Function Documentation

Err LcdOverlayLibClose ( UInt16 refNum )

Closes LcdOverlay library.

Parameters:
refNum,: IN: Reference number of the LcdOverlay library.
Returns:
Err The error code returned from the library. If this is errNone, the function was sucessful.

Err LcdOverlayLibControl | ( | UInt16 | refNum,
 |  | LcdOverlayLibControlType | cmdId,
 |  | void * | parameterP
 | ) |  |

Control the setting of the LcdOverlay Library.

Parameters:
refNum,: IN: Reference number of the LcdOverlay library.
cmdId,: IN: The commandId. One of the above stated control commands.
parameterP,: OUT: Parameter associated with a command.
Return values:
Err The error code returned from the library. If this is errNone, the function was sucessful.

Err LcdOverlayLibGetVersion | ( | UInt16 | refNum,
 |  | UInt32 | sdkVersion,
 |  | UInt32 * | libVersionP
 | ) |  |

Returns version of the LcdOverlay Library.

Parameters:
refNum,: IN: Reference number of the LcdOverlay library.
sdkVersion,: IN: Expected version number.
libVersionP,: OUT: Pointer to version number returned.
Return values:
Err The error code returned from the library. If this is errNone, the function was sucessful.

Err LcdOverlayLibOpen ( UInt16 refNum )

Opens LcdOverlay library.

This function should be called prior to calling the other LcdOverlay functions.

Parameters:
refNum,: IN: Reference number of the LcdOverlay library.
Return values:
Err The error code returned from the library. If this is errNone, the function was sucessful.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:07:51 2008 for Palm API Guide


Header Files » Incs » common » libraries » lcdoverlaylib

palmOneLcdOverlayCommon.h File Reference

Detailed Description

Public 68k common header file for LCDOverlay API.

Version:
1.0
This file contains the common constants and error codes for the LCDOverlay library.

Definition in file palmOneLcdOverlayCommon.h.

Include dependency graph for palmOneLcdOverlayCommon.h:

Go to the source code of this file.

Data Structures

  • struct LcdOverlayLibSettingTag
    Generic settings For settings without manual values, only type is used. More...

Defines

  • #define kLcdOverlayLibName "LcdOverlayManager"
  • #define kLcdOverlayLibType 'libr'
  • #define kLcdOverlayLibCreator 'Povl'
  • #define kLcdOverlayLibVersion1 sysMakeROMVersion(1, 0, 0, sysROMStageRelease, 0)
  • #define kLcdOverlayLibVersion kLcdOverlayLibVersion1
Function Traps
  • #define kLcdOverlayLibTrapGetVersion (sysLibTrapCustom + 0)
  • #define kLcdOverlayLibTrapControl (sysLibTrapCustom + 1)
Error Codes
  • #define kLcdOverlayLibErrorClass (oemErrorClass + 0x200)
  • #define kLcdOverlayLibErrBadParam (kLcdOverlayLibErrorClass | 0x01)
  • #define kLcdOverlayLibErrNoMemory (kLcdOverlayLibErrorClass | 0x02)
  • #define kLcdOverlayLibErrNotOpen (kLcdOverlayLibErrorClass | 0x03)
  • #define kLcdOverlayLibErrStillOpen (kLcdOverlayLibErrorClass | 0x04)
  • #define kLcdOverlayLibErrInternal (kLcdOverlayLibErrorClass | 0x05)
  • #define kLcdOverlayLibErrNotSupported (kLcdOverlayLibErrorClass | 0x06)
  • #define kLcdOverlayLibErrNotCompatible (kLcdOverlayLibErrorClass | 0x07)
Control Commands
  • #define kLcdOverlayLibCtrlFormatSet 0x01
  • #define kLcdOverlayLibCtrlFormatGet 0x02
  • #define kLcdOverlayLibCtrlFormatQuery 0x03
  • #define kLcdOverlayLibCtrlRectSet 0x04
  • #define kLcdOverlayLibCtrlRectGet 0x05
  • #define kLcdOverlayLibCtrlStart 0x06
  • #define kLcdOverlayLibCtrlDraw 0x07
  • #define kLcdOverlayLibCtrlStop 0x08
Data Formats
Format types for overlay.

Not all of the formats may be supported, please do a query to find the supported formats.

  • #define kLcdOverlayLibDataFormatYCbCr444 0x02
  • #define kLcdOverlayLibDataFormatYCbCr422 0x04
  • #define kLcdOverlayLibDataFormatYCbCr420 0x08
  • #define kLcdOverlayLibDataFormatYCbCr444Planar 0x10
  • #define kLcdOverlayLibDataFormatYCbCr422Planar 0x20
  • #define kLcdOverlayLibDataFormatYCbCr420Planar 0x40
  • #define kLcdOverlayLibDataFormatRGB565 0x80

Typedefs

  • typedef UInt16 LcdOverlayLibControlType
  • typedef LcdOverlayLibSettingTag LcdOverlayLibSettingType
    Structure used in LcdOverlayLibControl() for setting parameters Currently only type is used to specify the format type (seelist below) when used with kLcdOverlayLibCtrlFormatSet/Get/Query.
  • typedef LcdOverlayLibSettingTag LcdOverlayLibFormatType
    Struct used in LcdOverlayLibControl() calls.

Define Documentation

#define kLcdOverlayLibCreator 'Povl'

LcdOverlay Creator ID.

Definition at line 53 of file palmOneLcdOverlayCommon.h.

#define kLcdOverlayLibCtrlDraw 0x07

Draw picture using Overlay lib. void* pointer to image data

Definition at line 107 of file palmOneLcdOverlayCommon.h.

#define kLcdOverlayLibCtrlFormatGet 0x02

Parameter is LcdOverlayLibFormatType*. Get the format type of the overlay.

Definition at line 97 of file palmOneLcdOverlayCommon.h.

#define kLcdOverlayLibCtrlFormatQuery 0x03

Parameter is LcdOverlayLibFormatType*. Query the type of format types supported.

Definition at line 99 of file palmOneLcdOverlayCommon.h.

#define kLcdOverlayLibCtrlFormatSet 0x01

Parameter is LcdOverlayLibFormatType*. Set the format type of the overlay.

Definition at line 95 of file palmOneLcdOverlayCommon.h.

#define kLcdOverlayLibCtrlRectGet 0x05

Parameter is RectangleType* (low res coords). Get the overlay draw rectangle size

Definition at line 103 of file palmOneLcdOverlayCommon.h.

#define kLcdOverlayLibCtrlRectSet 0x04

Parameter is RectangleType* (low res coords). Set the overlay draw rectangle size

Definition at line 101 of file palmOneLcdOverlayCommon.h.

#define kLcdOverlayLibCtrlStart 0x06

Turn Overlay on before you do a draw. Takes no parameters

Definition at line 105 of file palmOneLcdOverlayCommon.h.

#define kLcdOverlayLibCtrlStop 0x08

Turn Overlay off usually after drawing is done. Takes no parameters

Definition at line 109 of file palmOneLcdOverlayCommon.h.

#define kLcdOverlayLibDataFormatRGB565 0x80

This is actually RGB555 with 1 bit for transperancy, may change in future

Definition at line 151 of file palmOneLcdOverlayCommon.h.

#define kLcdOverlayLibDataFormatYCbCr420 0x08

Definition at line 147 of file palmOneLcdOverlayCommon.h.

#define kLcdOverlayLibDataFormatYCbCr420Planar 0x40

Definition at line 150 of file palmOneLcdOverlayCommon.h.

#define kLcdOverlayLibDataFormatYCbCr422 0x04

Definition at line 146 of file palmOneLcdOverlayCommon.h.

#define kLcdOverlayLibDataFormatYCbCr422Planar 0x20

Definition at line 149 of file palmOneLcdOverlayCommon.h.

#define kLcdOverlayLibDataFormatYCbCr444 0x02

Definition at line 145 of file palmOneLcdOverlayCommon.h.

#define kLcdOverlayLibDataFormatYCbCr444Planar 0x10

Definition at line 148 of file palmOneLcdOverlayCommon.h.

#define kLcdOverlayLibErrBadParam (kLcdOverlayLibErrorClass | 0x01)

invalid parameter

Definition at line 72 of file palmOneLcdOverlayCommon.h.

#define kLcdOverlayLibErrInternal (kLcdOverlayLibErrorClass | 0x05)

Internal error

Definition at line 80 of file palmOneLcdOverlayCommon.h.

#define kLcdOverlayLibErrNoMemory (kLcdOverlayLibErrorClass | 0x02)

Memory error

Definition at line 74 of file palmOneLcdOverlayCommon.h.

#define kLcdOverlayLibErrNotCompatible (kLcdOverlayLibErrorClass | 0x07)

Bad Version

Definition at line 84 of file palmOneLcdOverlayCommon.h.

#define kLcdOverlayLibErrNotOpen (kLcdOverlayLibErrorClass | 0x03)

library is not open

Definition at line 76 of file palmOneLcdOverlayCommon.h.

#define kLcdOverlayLibErrNotSupported (kLcdOverlayLibErrorClass | 0x06)

Unsupported function

Definition at line 82 of file palmOneLcdOverlayCommon.h.

#define kLcdOverlayLibErrorClass (oemErrorClass + 0x200)

Lcd Overlay error base number

Definition at line 70 of file palmOneLcdOverlayCommon.h.

#define kLcdOverlayLibErrStillOpen (kLcdOverlayLibErrorClass | 0x04)

returned from LcdOverlayLibClose() if the library is still open

Definition at line 78 of file palmOneLcdOverlayCommon.h.

#define kLcdOverlayLibName "LcdOverlayManager"

LcdOverlay library name.

Definition at line 51 of file palmOneLcdOverlayCommon.h.

#define kLcdOverlayLibTrapControl (sysLibTrapCustom + 1)

Definition at line 44 of file palmOneLcdOverlayCommon.h.

#define kLcdOverlayLibTrapGetVersion (sysLibTrapCustom + 0)

Definition at line 43 of file palmOneLcdOverlayCommon.h.

#define kLcdOverlayLibType 'libr'

LcdOverlay Type.

Definition at line 52 of file palmOneLcdOverlayCommon.h.

#define kLcdOverlayLibVersion kLcdOverlayLibVersion1

LcdOverlay lib version

Definition at line 60 of file palmOneLcdOverlayCommon.h.

#define kLcdOverlayLibVersion1 sysMakeROMVersion(1, 0, 0, sysROMStageRelease, 0)

LcdOverlay lib version

Definition at line 59 of file palmOneLcdOverlayCommon.h.

Typedef Documentation

typedef UInt16 LcdOverlayLibControlType

Used with the kLcdOverlayLibCtrl defines

Definition at line 111 of file palmOneLcdOverlayCommon.h.

typedef struct LcdOverlayLibSettingTag LcdOverlayLibFormatType

Struct used in LcdOverlayLibControl() calls.

See also:
LcdOverlayLibSettingTag

Definition at line 135 of file palmOneLcdOverlayCommon.h.

typedef struct LcdOverlayLibSettingTag LcdOverlayLibSettingType

Structure used in LcdOverlayLibControl() for setting parameters Currently only type is used to specify the format type (seelist below) when used with kLcdOverlayLibCtrlFormatSet/Get/Query.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:07:51 2008 for Palm API Guide


Header Files » Incs » 68k » system

68k/system/palmOneNavigator.h File Reference

Include dependency graph for 68k/system/palmOneNavigator.h:

Go to the source code of this file.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:07:51 2008 for Palm API Guide


Header Files » Incs » common » system

common/system/palmOneNavigator.h File Reference

Include dependency graph for common/system/palmOneNavigator.h:

Go to the source code of this file.

Defines

  • #define IsFiveWayNavPalmEvent(eventP)
  • #define IsFiveWayNavEvent(eventP)
  • #define NavSelectHSPressed(eventP)
  • #define NavSelectPalmPressed(eventP)
  • #define NavSelectPressed(eventP)
  • #define NavDirectionHSPressed(eventP, nav)
  • #define NavDirectionPalmPressed(eventP, nav)
  • #define NavDirectionPressed(eventP, nav)
  • #define NavKeyPressed(eventP, nav)
  • #define navFtrCreator 'fway'
  • #define navFtrVersion 0
  • #define navVersion 0x00010000
  • #define keyBitNavLeft 0x01000000
  • #define keyBitNavRight 0x02000000
  • #define keyBitNavSelect 0x04000000
  • #define keyBitNavLRS 0x07000000
  • #define navBitUp 0x0001
  • #define navBitDown 0x0002
  • #define navBitLeft 0x0004
  • #define navBitRight 0x0008
  • #define navBitSelect 0x0010
  • #define navBitsAll 0x001F
  • #define navChangeUp 0x0100
  • #define navChangeDown 0x0200
  • #define navChangeLeft 0x0400
  • #define navChangeRight 0x0800
  • #define navChangeSelect 0x1000
  • #define navChangeBitsAll 0x1F00

Define Documentation

#define IsFiveWayNavEvent ( eventP )

Value:

(                                                                                           \
    IsFiveWayNavPalmEvent(eventP)                                                           \
||  TxtCharIsRockerKey((eventP)->data.keyDown.modifiers, (eventP)->data.keyDown.chr)        \
)
A macro to use for apps that support navigation using the 5-way. This macro will let you test whether an event was generated by the 5-way. For applications that treat up and down hard buttons differently than up and down on the 5-way, this macro can be used to determine which action to take if NavKeyPressed returns true for Up or Down.

 if (IsFiveWayNavEvent(eventP)) {
        // Handle five way events here
 }

Definition at line 167 of file common/system/palmOneNavigator.h.

#define IsFiveWayNavPalmEvent ( eventP )

Value:

(                                                                                           \
    (   ((eventP)->data.keyDown.chr == vchrPageUp)                                          \
     || ((eventP)->data.keyDown.chr == vchrPageDown)                                        \
     || ((eventP)->data.keyDown.chr == vchrNavChange) )                                     \
&&  (((eventP)->data.keyDown.keyCode & (navBitsAll | navChangeBitsAll)) != 0)               \
)
A macro to use for apps that support navigation using the Palm style 5-way. This macro will let you test whether an event was generated by the 5-way. For applications that treat up and down hard buttons differently than up and down on the 5-way, this macro can be used to determine which action to take if NavKeyPressed returns true for Up or Down.

Remarks:
Our 5-way events generate lots of detail about what state changed and what didn't. Events are generated even when a button is released, which is a nice bonus. So, to figure out what happened, you have to look at the bits in the keyCode. Because we only use 10 of the bits in the keyCode, and because we may use the remaining bits at some later date, we mask out these 10 bits before doing the test.
((eventP)->data.keyDown.keyCode & (navBitsAll | navChangeBitsAll)) != 0 will be true if any of the 5 buttons is held down, pressed, or released.

((eventP)->data.keyDown.keyCode & navChangeBitsAll) != 0 will be true if any of the 5 buttons is pressed or released.

The situation where these would differ is holding down one or more of the 5 buttons until it generates a repeat event. In that case, none of the navChangeBits will be set.

Unfortunately, on the Treo 600, the vchrPageUp/Down is accompanied by a keyCode that has some nav bits set. Thus, we will not be able to distinguish the HandSpring nav event from the Palm nav event here in such cases, and this macro will return true. Then, when using NavDirectionPressed, via NavKeyPressed e.g., the nav direction palm and HS macros will return false, as this case matches neither, and the vchrPageUp/Down will incorrectly be returned as not a 5-way nav event for our purposes of supporting non-5-way devices. That can be avoided by ensuring the focus state on HandSpring devices is set to object mode for the given form, thus ensuring vchrRockerUp/Down chrs are sent instead of vcrhPageUp/Down chrs, while also ensuring this continues to work as expected on palmOne devices.

 if (IsFiveWayNavPalmEvent(eventP)) {
        // Handle five way events here
 }

Definition at line 124 of file common/system/palmOneNavigator.h.

#define keyBitNavLeft 0x01000000

Key state mask to check the five way navigation LEFT button.

Definition at line 47 of file common/system/palmOneNavigator.h.

#define keyBitNavLRS 0x07000000

Key state mask to check the five way navigation LEFT, RIGHT and SELECT buttons.

Definition at line 50 of file common/system/palmOneNavigator.h.

#define keyBitNavRight 0x02000000

Key state mask to check the five way navigation RIGHT button.

Definition at line 48 of file common/system/palmOneNavigator.h.

#define keyBitNavSelect 0x04000000

Key state mask to check the five way navigation SELECT button.

Definition at line 49 of file common/system/palmOneNavigator.h.

#define navBitDown 0x0002

Key mask for the five way navigation DOWN button.

Definition at line 59 of file common/system/palmOneNavigator.h.

#define navBitLeft 0x0004

Key mask for the five way navigation LEFT button.

Definition at line 60 of file common/system/palmOneNavigator.h.

#define navBitRight 0x0008

Key mask for the five way navigation RIGHT button.

Definition at line 61 of file common/system/palmOneNavigator.h.

#define navBitsAll 0x001F

Key mask for all five way navigation buttons.

Definition at line 63 of file common/system/palmOneNavigator.h.

#define navBitSelect 0x0010

Key mask for the five way navigation SELECT button.

Definition at line 62 of file common/system/palmOneNavigator.h.

#define navBitUp 0x0001

Key mask for the five way navigation UP button.

Definition at line 58 of file common/system/palmOneNavigator.h.

#define navChangeBitsAll 0x1F00

Key mask for all five way navigation buttons state change.

Definition at line 76 of file common/system/palmOneNavigator.h.

#define navChangeDown 0x0200

Key mask for the five way navigation DOWN button state change.

Definition at line 72 of file common/system/palmOneNavigator.h.

#define navChangeLeft 0x0400

Key mask for the five way navigation LEFT button state change.

Definition at line 73 of file common/system/palmOneNavigator.h.

#define navChangeRight 0x0800

Key mask for the five way navigation RIGHT button state change.

Definition at line 74 of file common/system/palmOneNavigator.h.

#define navChangeSelect 0x1000

Key mask for the five way navigation SELECT button state change.

Definition at line 75 of file common/system/palmOneNavigator.h.

#define navChangeUp 0x0100

Key mask for the five way navigation UP button state change.

Definition at line 71 of file common/system/palmOneNavigator.h.

#define NavDirectionHSPressed | ( | eventP,
 |  | nav | )

Value:

(                                                                                       \
        ((vchrRocker ## nav) != vchrRockerCenter)                                       \
     && (   (   (((eventP)->data.keyDown.modifiers & commandKeyMask) != 0)              \
             && ((eventP)->data.keyDown.chr == (vchrRocker ## nav))))                   \
)
A macro to use for apps that support navigation using the HandSpring 5-way. By using this macro, we have consistent behavior in all our apps when it comes to how it handles multiple simultaneous button presses. You can use this macro even if the device does not have a 5-way controller.

Remarks:
Determine if the key down event indicates the HandSpring nav direction type.
 if (NavDirectionHSPressed(eventP, Left))
 if (NavDirectionHSPressed(eventP, Right))
 if (NavDirectionHSPressed(eventP, Up))       - also works without 5-way
 if (NavDirectionHSPressed(eventP, Down))     - also works without 5-way

Definition at line 267 of file common/system/palmOneNavigator.h.

#define NavDirectionPalmPressed | ( | eventP,
 |  | nav | )

Value:

(                                                                                       \
    ((eventP)->data.keyDown.modifiers & autoRepeatKeyMask)                              \
        ? (((eventP)->data.keyDown.keyCode & (navBitsAll | navChangeBitsAll)) ==        \
            (navBit ## nav))                                                            \
        : (((eventP)->data.keyDown.keyCode & (navBitsAll | navChangeBitsAll)) ==        \
            (navBit ## nav | navChange ## nav))                                         \
)
A macro to use for apps that support navigation using the Palm 5-way. By using this macro, we have consistent behavior in all our apps when it comes to how it handles multiple simultaneous button presses. You can use this macro even if the device does not have a 5-way controller.

Remarks:
Determine if the key down event indicates the palmOne nav direction type.
 if (NavDirectionPalmPressed(eventP, Left))
 if (NavDirectionPalmPressed(eventP, Right))
 if (NavDirectionPalmPressed(eventP, Up))     - also works without 5-way
 if (NavDirectionPalmPressed(eventP, Down))   - also works without 5-way

Definition at line 292 of file common/system/palmOneNavigator.h.

#define NavDirectionPressed | ( | eventP,
 |  | nav | )

Value:

(                                                                                       \
    IsFiveWayNavEvent(eventP)                                                           \
        ? (   NavDirectionPalmPressed(eventP, nav)                                      \
           || NavDirectionHSPressed(eventP, nav))                                       \
        : (   ((eventP)->data.keyDown.chr == vchrPageUp && (navBit ## nav) == navBitUp)      \
           || ((eventP)->data.keyDown.chr == vchrPageDown && (navBit ## nav) == navBitDown)) \
)
A macro to use for apps that support navigation using the 5-way. By using this macro, we have consistent behavior in all our apps when it comes to how it handles multiple simultaneous button presses. You can use this macro even if the device does not have a 5-way controller.

Remarks:
Act only when one direction is pressed without any other direction (or select) being down at the time. Repeat if the button is held down, but not if other buttons are pressed.
 if (NavDirectionPressed(eventP, Left))
 if (NavDirectionPressed(eventP, Right))
 if (NavDirectionPressed(eventP, Up))       - also works without 5-way
 if (NavDirectionPressed(eventP, Down)) - also works without 5-way

Definition at line 321 of file common/system/palmOneNavigator.h.

#define navFtrCreator 'fway'

Creator ID for 5-Way navigator.

Definition at line 37 of file common/system/palmOneNavigator.h.

#define navFtrVersion 0

Feature id for 5-Way.

Definition at line 38 of file common/system/palmOneNavigator.h.

#define NavKeyPressed | ( | eventP,
 |  | nav | )

Value:

(                                                                                       \
    (navBit ## nav == navBitSelect)                                                     \
        ? NavSelectPressed(eventP)                                                      \
        : NavDirectionPressed(eventP, nav)                                              \
)
A macro to use for apps that support navigation using the 5-way. By using this macro, we have consistent behavior in all our apps when it comes to how it handles multiple simultaneous button presses. You can use this macro even if the device does not have a 5-way controller.

 if (NavKeyPressed(eventP, Select))
 if (NavKeyPressed(eventP, Left))
 if (NavKeyPressed(eventP, Right))
 if (NavKeyPressed(eventP, Up))     - also works without 5-way
 if (NavKeyPressed(eventP, Down))       - also works without 5-way

Definition at line 345 of file common/system/palmOneNavigator.h.

#define NavSelectHSPressed ( eventP )

Value:

(                                                                                       \
       (((eventP)->data.keyDown.modifiers & commandKeyMask) != 0)                       \
    && ((eventP)->data.keyDown.chr == vchrRockerCenter)                                 \
)
A macro to use for apps that support navigation using the HandSpring 5-way. By using this macro, we have consistent behavior in all our apps when it comes to how it handles multiple simultaneous button presses.

Remarks:
Checks if it the key down event is of the HandSpring "select" key type.
 if (NavSelectHSPressed(eventP)) {
        // Select was pressed
 }

Definition at line 188 of file common/system/palmOneNavigator.h.

#define NavSelectPalmPressed ( eventP )

Value:

(                                                                                       \
       (((eventP)->data.keyDown.modifiers & autoRepeatKeyMask) == 0)                    \
    && ((eventP)->data.keyDown.chr == vchrNavChange)                                    \
    && (((eventP)->data.keyDown.keyCode & (navBitsAll | navChangeBitsAll)) ==           \
                                                                     navChangeSelect)   \
)
A macro to use for apps that support navigation using the Palm 5-way. By using this macro, we have consistent behavior in all our apps when it comes to how it handles multiple simultaneous button presses.

Remarks:
Checks if it the key down event is of the Palm "select" key type. Note the redundant check of the keyDown.chr. This is necessary to prevent a false positive, because the modified DAL code for the new 5-way still generates the same keyCodes (it was easier that way), but doesn't generate the same keyDown.chr (new vchrRocker instead). This redundancy avoids a double-press behavior.
 if (NavSelectPalmPressed(eventP)) {
        // Select was pressed
 }

Definition at line 214 of file common/system/palmOneNavigator.h.

#define NavSelectPressed ( eventP )

Value:

(                                                                                       \
    IsFiveWayNavEvent(eventP)                                                           \
&&  (   NavSelectPalmPressed(eventP)                                                    \
     || NavSelectHSPressed(eventP))                                                     \
)
A macro to use for apps that support navigation using the 5-way. By using this macro, we have consistent behavior in all our apps when it comes to how it handles multiple simultaneous button presses.

Remarks:
Only act when the select button is released, and only if none of the direction buttons are down (or being released) at the time, and only if the select button has not been held down long enough to start repeating. By ignoring repeat events for the select button, we ensure that the launcher will be run if the select button is held down. By waiting until the button is released, we ensure that the select action is not taken before the launcher is run.
 if (NavSelectPressed(eventP)) {
        // Select was pressed
 }

Definition at line 242 of file common/system/palmOneNavigator.h.

#define navVersion 0x00010000

Version for 5-Way.

Definition at line 39 of file common/system/palmOneNavigator.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:07:52 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » imaging

palmOnePhoto.h File Reference

Detailed Description

Palm Photos API: This API is used to access Palm Photos database and manipulate images.

Version:
3.0
The database API provides users with the ability to:
  • Get the list of albums.
  • Create, delete and rename albums.
  • Get the list of photos in each album.
  • Add photos to albums.

The image manipulation API provides users with the ability to:

  • Create and capture images and video clips.
  • Read and write image data.
  • Convert images to different formats.
  • Display images.
  • Scale, rotate and crop images.

Update to be compliant with DCF

  • The notion of Unfiled folder has been removed
  • In PalmPhotoDeleteAlbum() setting the parameter moveToUnfiled moves the photos in the deleted album to DCIM/Palm instead of the Unfiled folder which was DCIM.

Definition in file palmOnePhoto.h.

Include dependency graph for palmOnePhoto.h:

Go to the source code of this file.

Data Structures

  • struct _PalmPhotoSelectionParam
    Photo selection dialog parameters. More...
  • struct _PalmPhotoReadWriteParam
    Photo image manipulation param. More...
  • struct _PalmPhotoDisplayParam
    Photo image display parameters. More...
  • struct _PalmPhotoCreateParam
    Photo image create parameters. More...
  • struct _PalmPhotoCaptureParamV2
    Photo/video image capture parameters. More...

Typedefs

  • typedef Err(*) PalmPhotoReadWriteCallback (void *bufferP, UInt32 *sizeP, void *userDataP)
  • typedef Boolean(*) PalmPhotoFilterCallback (PalmPhotoHandle imageH, void *userDataP)
  • typedef Boolean(*) PalmPhotoDisplayCallback (void *userDataP)
  • typedef Boolean(*) PalmPhotoCaptureCallbackV2 (void *userDataP)
  • typedef _PalmPhotoSelectionParam PalmPhotoSelectionParam
    Photo selection dialog parameters.
  • typedef _PalmPhotoReadWriteParam PalmPhotoReadWriteParam
    Photo image manipulation param.
  • typedef _PalmPhotoDisplayParam PalmPhotoDisplayParam
    Photo image display parameters.
  • typedef _PalmPhotoCreateParam PalmPhotoCreateParam
    Photo image create parameters.
  • typedef _PalmPhotoCaptureParamV2 PalmPhotoCaptureParamV2
    Photo/video image capture parameters.

Functions

  • Err PalmPhotoLibOpen (UInt16 refNum)
  • Err PalmPhotoLibClose (UInt16 refNum)
  • Err PalmPhotoLibSleep (UInt16 refNum)
  • Err PalmPhotoLibWake (UInt16 refNum)
  • UInt16 PalmPhotoAlbumCount (UInt16 refNum)
  • UInt16 PalmPhotoGetAlbumID (UInt16 refNum, UInt16 index)
  • Err PalmPhotoGetAlbumName (UInt16 refNum, UInt16 albumID, Char *nameP, UInt16 bufSize)
  • UInt16 PalmPhotoNewAlbum (UInt16 refNum, const Char *nameP, Err *errP)
  • Err PalmPhotoDeleteAlbum (UInt16 refNum, UInt16 albumID, Boolean moveToUnfiled)
  • Err PalmPhotoRenameAlbum (UInt16 refNum, UInt16 albumID, const Char *nameP)
  • UInt16 PalmPhotoImageCount (UInt16 refNum, UInt16 albumID)
  • Err PalmPhotoSelectImages (UInt16 refNum, PalmPhotoSelectionParam *photoSelectionP)
  • Err PalmPhotoSelectDlg (UInt16 refNum, PalmPhotoSelectionParam *photoSelectionP, PalmPhotoDlgType dlgType, Boolean handleCard)
  • void PalmPhotoFreeSelections (UInt16 refNum, PalmPhotoSelectionParam *photoSelectionP)
  • PalmPhotoHandle PalmPhotoCreateImage (UInt16 refNum, const PalmPhotoCreateParam *createParamP, Err *errP)
  • PalmPhotoHandle PalmPhotoOpenImage (UInt16 refNum, const PalmPhotoFileLocation *photoFileP, Err *errP)
  • void PalmPhotoCloseImage (UInt16 refNum, PalmPhotoHandle imageH)
  • Err PalmPhotoGetImageInfo (UInt16 refNum, PalmPhotoHandle imageH, PalmPhotoImageInfo *infoP)
  • UInt32 PalmPhotoGetImageExtraInfoSize (UInt16 refNum, PalmPhotoHandle imageH, PalmPhotoExtraInfoType infoType)
  • Err PalmPhotoGetImageExtraInfo (UInt16 refNum, PalmPhotoHandle imageH, PalmPhotoExtraInfoParam *extraInfoP)
  • Err PalmPhotoSetImageExtraInfo (UInt16 refNum, PalmPhotoHandle imageH, const PalmPhotoExtraInfoParam *extraInfoP)
  • Err PalmPhotoAddImage (UInt16 refNum, UInt16 albumID, PalmPhotoHandle imageH, PalmPhotoHandle *addedImageH, PalmPhotoQualityType imageQuality)
  • Err PalmPhotoDeleteImage (UInt16 refNum, PalmPhotoHandle imageH)
  • Err PalmPhotoReadImage (UInt16 refNum, PalmPhotoHandle imageH, const PalmPhotoReadWriteParam *readParamP)
  • Err PalmPhotoWriteImage (UInt16 refNum, PalmPhotoHandle imageH, const PalmPhotoReadWriteParam *writeParamP)
  • Err PalmPhotoDisplayImage (UInt16 refNum, PalmPhotoHandle imageH, const PalmPhotoDisplayParam *displayParamP)
  • Err PalmPhotoGetThumbSize (UInt16 refNum, PalmPhotoHandle imageH, UInt16 *widthP, UInt16 *heightP)
  • Err PalmPhotoLibGetVersion (UInt16 refNum, UInt32 sdkVersion, UInt32 *libVersionP)
  • Err PalmPhotoScaleImageV2 (UInt16 refNum, PalmPhotoHandle imageH, PalmPhotoHandle *scaledImageHP, UInt32 width, UInt32 height)
  • Err PalmPhotoRotateImageV2 (UInt16 refNum, PalmPhotoHandle imageH, PalmPhotoHandle *rotatedImageHP, Int16 rotation)
  • Err PalmPhotoCropImageV2 (UInt16 refNum, PalmPhotoHandle imageH, PalmPhotoHandle *croppedImageHP, RectangleType *cropRectP)
  • Err PalmPhotoConvertImageV2 (UInt16 refNum, PalmPhotoHandle imageH, PalmPhotoHandle *convertedImageHP, const PalmPhotoCreateParam *createParamP)
  • Err PalmPhotoGetLastErrV2 (UInt16 refNum)
  • UInt16 PalmPhotoAlbumCountV2 (UInt16 refNum, UInt16 volumeRef)
  • UInt16 PalmPhotoGetAlbumIDV2 (UInt16 refNum, UInt16 volumeRef, UInt16 index)
  • UInt16 PalmPhotoNewAlbumV2 (UInt16 refNum, UInt16 volumeRef, const Char *nameP)
  • Err PalmPhotoFreeSelectionsV2 (UInt16 refNum, PalmPhotoSelectionParam *photoSelectionP)
  • PalmPhotoHandle PalmPhotoCreateImageV2 (UInt16 refNum, const PalmPhotoCreateParam *createParamP)
  • PalmPhotoHandle PalmPhotoCaptureImageV2 (UInt16 refNum, const PalmPhotoCaptureParamV2 *captureParamP)
  • PalmPhotoHandle PalmPhotoOpenImageV2 (UInt16 refNum, const PalmPhotoFileLocation *photoFileP)
  • Err PalmPhotoCloseImageV2 (UInt16 refNum, PalmPhotoHandle imageH)
  • Err PalmPhotoAddImageV2 (UInt16 refNum, UInt16 albumID, PalmPhotoHandle imageH, PalmPhotoHandle *addedImageH)
  • Boolean PalmPhotoIsCameraAvailableV3 (UInt16 refNum)
  • PalmPhotoCaptureResolution PalmPhotoGetSupportedCaptureResolutionsV3 (UInt16 refNum, PalmPhotoMediaType mediaType)
  • Err PalmPhotoSelectDlgV3 (UInt16 refNum, PalmPhotoSelectionParam *photoSelectionP, const PalmPhotoCaptureParamV2 *captureParamP, PalmPhotoDlgType dlgType, PalmPhotoMediaType mediaType, Boolean handleCard)
  • Err PalmPhotoDisplayImageToSizeV3 (UInt16 refNum, PalmPhotoHandle imageH, const PalmPhotoDisplayParam *displayParamP)
  • Err PalmPhotoDisplayThumbnailV3 (UInt16 refNum, PalmPhotoHandle imageH, const PalmPhotoDisplayParam *displayParamP)

Typedef Documentation

typedef Boolean(*) PalmPhotoCaptureCallbackV2(void *userDataP)

Capture callback. This function is called during capture image if provided as a parameter. If the function returns false, the capture process will be canceled. New in v2.0.

Parameters:
userDataP,: IN: Pointer to user data set in PalmPhotoCaptureParamV2.
Return values:
Boolean True if the capture process should continue, false otherwise.

Definition at line 113 of file palmOnePhoto.h.

typedef struct _PalmPhotoCaptureParamV2 PalmPhotoCaptureParamV2

Photo/video image capture parameters.

The callback function allows the calling application to cancel the image capture operation. The user may cancel the operation by interacting with the capture application. New in v2.0.

typedef struct _PalmPhotoCreateParam PalmPhotoCreateParam

Photo image create parameters.

Set imageInfo can determines the type of the file. To create a JPEG image, set imageInfo.fileFormat to palmPhotoJPEGFileFormat.

typedef Boolean(*) PalmPhotoDisplayCallback(void *userDataP)

Display callback. This function is called during display image if provided as a parameter. If the function returns false, the display process will be canceled.

Parameters:
userDataP,: IN: Pointer to user data set in PalmPhotoDisplayParam.
Return values:
Boolean True if the display process should continue, false otherwise.

Definition at line 99 of file palmOnePhoto.h.

typedef struct _PalmPhotoDisplayParam PalmPhotoDisplayParam

Photo image display parameters.

The bounds might be ignored by the application. New in v2.0: If playing a video, winH and rect are ignored.

typedef Boolean(*) PalmPhotoFilterCallback(PalmPhotoHandle imageH, void *userDataP)

Selection filter callback. This function is called during a selection if provided as a parameter. Given an image handle, the filter decides whether or not and image should be selected. For example, a user might want to select only JPEG images.

Parameters:
imageH,: IN: Handle of the image to filter.
userDataP,: IN: Pointer to user data set in PalmPhotoSelectionParam.
Return values:
Boolean True if ok to select image, false otherwise.

Definition at line 85 of file palmOnePhoto.h.

typedef Err(*) PalmPhotoReadWriteCallback(void *bufferP, UInt32 *sizeP, void *userDataP)

File streaming callback. During read operations, *sizeP contains the size of the buffer passed to the callback. Setting sizeP before returning in this case is simply ingored. If the user doesn't read all the data in the buffer, the data left will be lost. During write operations, *sizeP contains the max size of the buffer used for writing. sizeP is set to the amount of data to write before the callback returns. Setting sizeP to 0 means no more data to write and the write process should stop. The read/write calllback can be stopped at any time by the callback returning the error code palmPhotoLibErrAbortReadWrite.

Parameters:
bufferP,: IN: Pointer to the buffer containing image data.
sizeP,: IN: Size of the buffer.
userDataP,: IN: Pointer to user data set in PalmPhotoReadWriteParam.
Return values:
Err Error code.

Definition at line 68 of file palmOnePhoto.h.

typedef struct _PalmPhotoReadWriteParam PalmPhotoReadWriteParam

Photo image manipulation param.

This parameter is used to set the callback for reading and writing data of an image. The imageFormat provides the user a way to convert images. For example, reading a JPEG image and setting imageFormat to RGB565 should convert the JPEG to RGB565.

typedef struct _PalmPhotoSelectionParam PalmPhotoSelectionParam

Photo selection dialog parameters.

This structure is used for the selection dialog and direct image selection. When using the PMPSelectImages API, selectionCount contains the maximum number of images that can be selected. If selectionCount is set to PALM_PHOTO_SELECT_ALL, the range would be [offset, end]. If albumID is set to PALM_PHOTO_ALBUM_ALL, all images can be selected.

NOTE: The API allocates memory inside of selectedImages. It is the caller's responsibility to free that memory via PalmPhotoFreeSelections().

Function Documentation

Err PalmPhotoAddImage | ( | UInt16 | refNum,
 |  | UInt16 | albumID,
 |  | PalmPhotoHandle | imageH,
 |  | PalmPhotoHandle * | addedImageH,
 |  | PalmPhotoQualityType | imageQuality
 | ) |  |

Add an image to a Palm Photos album. A new image is created and added to the Photos database, in the specified album. The image will be re-encoded in JPEG format at the specified quality. If album doesn't exist, the image will be added to the album named "Palm". In the previous versions if the album did not exist, the image was added to the "Unfiled" album. Passing albumID of PALM_PHOTO_ALBUM_ALL results in the image being added to the "Palm" album. In the previous versions passing albumID of PALM_PHOTO_ALBUM_ALL resulted in the image being added to the "Unfiled" album. For compatibility only; new development should use the V2 version.

Parameters:
refNum,: IN: Library reference number.
albumID,: IN: Album ID for the image.
imageH,: IN: Image handle.
addedImageH,: OUT: The new image added to the album.
imageQuality,: IN: Image quality.
Return values:
Err Error code.

Err PalmPhotoAddImageV2 | ( | UInt16 | refNum,
 |  | UInt16 | albumID,
 |  | PalmPhotoHandle | imageH,
 |  | PalmPhotoHandle * | addedImageH
 | ) |  |

Add an image to a Palm Photos album. The image is added to the indicated Photos album. If the album resides on a different volume than imageH, then the image is copied into the new volume. A handle to the image in the designated album is returned in addedImageH. No image conversion takes place. The content of the image in the album is identical to that of the original image. If album doesn't exist, the image will be added to the "Unfiled" album. Passing albumID of PALM_PHOTO_ALBUM_ALL results in the image being added to the "Unfiled" album.

Parameters:
refNum,: IN: Library reference number.
albumID,: IN: Album ID for the image.
imageH,: IN: Image handle.
addedImageH,: OUT: The new image added to the album.
Return values:
Err Error code.

UInt16 PalmPhotoAlbumCount ( UInt16 refNum )

Get the number of albums in Palm Photos. For compatibility only; new development should use the V2 version.

Parameters:
refNum,: IN: Library reference number.
Return values:
UInt16 Album count.

UInt16 PalmPhotoAlbumCountV2 | ( | UInt16 | refNum,
 |  | UInt16 | volumeRef
 | ) |  |

Get the number of albums in Palm Photos residing on the specified volume. If volumeRef is 0, then the location is on the handheld. Otherwise, it is in VFS.

Parameters:
refNum,: IN: Library reference number.
volumeRef,: IN: Volume to search for photo albums.
Return values:
UInt16 Album count.

PalmPhotoHandle PalmPhotoCaptureImageV2 | ( | UInt16 | refNum,
 |  | const PalmPhotoCaptureParamV2 * | captureParamP
 | ) |  |

Capture a new still image or video clip using the built-in camera.

New functionality added in 3.0: Can capture video as well as still images. (For video, height and width in captureParam.imageInfo must match a supported resolution as returned by PalmPhotoGetSupportedCaptureResolutionsV3. Location in captureParam.fileLocation must be a VFSFile.) Can limit size (in bytes) of captured media. (Set captureParam.imageInfo.fileSize to the desired limit. If fileSize = 0, no constraint s placed on ithe file size.)

Parameters:
refNum,: IN: Library reference number.
captureParamP,: IN: Palm Photo capture parameter.
Return values:
PalmPhotoHandle The newly created photo handle or NULL if unsuccessful.

void PalmPhotoCloseImage | ( | UInt16 | refNum,
 |  | PalmPhotoHandle | imageH
 | ) |  |

Close an image. For compatibility only; new development should use the V2 version.

Parameters:
refNum,: IN: Library reference number.
imageH,: IN: Image handle.

Err PalmPhotoCloseImageV2 | ( | UInt16 | refNum,
 |  | PalmPhotoHandle | imageH
 | ) |  |

Close an image.

Parameters:
refNum,: IN: Library reference number.
imageH,: IN: Image handle.
Return values:
Err Error code.

Err PalmPhotoConvertImageV2 | ( | UInt16 | refNum,
 |  | PalmPhotoHandle | imageH,
 |  | PalmPhotoHandle * | convertedImageHP,
 |  | const PalmPhotoCreateParam * | createParamP
 | ) |  |

Convert an image. New in v2.0.

Parameters:
refNum,: IN: Library reference number.
imageH,: IN: Image handle.
convertedImageHP,: OUT: The new image converted.
createParamP,: IN: File information and location for the new image.
Return values:
Err Error code.

PalmPhotoHandle PalmPhotoCreateImage | ( | UInt16 | refNum,
 |  | const PalmPhotoCreateParam * | createParamP,
 |  | Err * | errP
 | ) |  |

Create a new image. For compatibility only; new development should use the V2 version.

Parameters:
refNum,: IN: Library reference number.
createParamP,: IN: Palm Photo create parameter.
errP,: OUT: Error code.
Return values:
PalmPhotoHandle The newly created photo handle or NULL if unsuccessful.

PalmPhotoHandle PalmPhotoCreateImageV2 | ( | UInt16 | refNum,
 |  | const PalmPhotoCreateParam * | createParamP
 | ) |  |

Create a new image.

Parameters:
refNum,: IN: Library reference number.
createParamP,: IN: Palm Photo create parameter.
Return values:
PalmPhotoHandle The newly created photo handle or NULL if unsuccessful.

Err PalmPhotoCropImageV2 | ( | UInt16 | refNum,
 |  | PalmPhotoHandle | imageH,
 |  | PalmPhotoHandle * | croppedImageHP,
 |  | RectangleType * | cropRectP
 | ) |  |

Return a cropped image. New in v2.0.

Parameters:
refNum,: IN: Library reference number.
imageH,: IN: Image handle.
croppedImageHP,: OUT: The new image cropped.
cropRectP,: IN: Cropping rectangle.
Return values:
Err Error code.

Err PalmPhotoDeleteAlbum | ( | UInt16 | refNum,
 |  | UInt16 | albumID,
 |  | Boolean | moveToUnfiled
 | ) |  |

Delete an album by album ID.

Parameters:
refNum,: IN: Library reference number.
albumID,: IN: ID of the Album to delete.
moveToUnfiled,: IN: If true, photos from the deleted album are moved to /DCIM/Palm folder. Otherwise, they are deleted. In previous versions the Unfiled album was mapped to the /DCIM folder.
Return values:
Err Error code.

Err PalmPhotoDeleteImage | ( | UInt16 | refNum,
 |  | PalmPhotoHandle | imageH
 | ) |  |

Delete an image.

Parameters:
refNum,: IN: Library reference number.
imageH,: IN: Image handle.
Return values:
Err Error code.

Err PalmPhotoDisplayImage | ( | UInt16 | refNum,
 |  | PalmPhotoHandle | imageH,
 |  | const PalmPhotoDisplayParam * | displayParamP
 | ) |  |

Display an image or play a video. A still image referenced by imageH will be drawn in the window and rectangle specified within *displayParamP. If the window handle is NULL, the current draw window is used. A video referenced by imageH will be played in the video player, and the window and rectangle will be ignored.

The image is displayed "shrink to fit" mode, where 100% of the image is represented on the handheld display. (See also PalmPhotoDisplayImageToSizeV3 for "best fit" scaling.)

If the callback function returns false, the Photo API will halt the draw or play operation.

Parameters:
refNum,: IN: Library reference number.
imageH,: IN: Image handle.
displayParamP,: IN: Display parameter.
Return values:
Err Error code.

Err PalmPhotoDisplayImageToSizeV3 | ( | UInt16 | refNum,
 |  | PalmPhotoHandle | imageH,
 |  | const PalmPhotoDisplayParam * | displayParamP
 | ) |  |

Display an image or play a video. A still image referenced by imageH will be drawn in the window and rectangle specified within *displayParamP. If the window handle is NULL, the current draw window is used. A video referenced by imageH will be played in the video player, and the window and rectangle will be ignored.

The image is displayed in "best fit" mode, scaled exactly so that the rectangle is completely filled, then cropping anything outside the rectangle. (See also PalmPhotoDisplayImage for shrink-to-fit scaling.)

If the callback function returns false, the Photo API will halt the draw or play operation.

New in v3.0.

Parameters:
refNum,: IN: Library reference number.
imageH,: IN: Image handle.
displayParamP,: IN: Display parameter.
Return values:
Err Error code.

Err PalmPhotoDisplayThumbnailV3 | ( | UInt16 | refNum,
 |  | PalmPhotoHandle | imageH,
 |  | const PalmPhotoDisplayParam * | displayParamP
 | ) |  |

Display thumbnail for still image or video.

Thumbnail for the image or video referenced by imageH will be drawn in the window and rectangle specified within *displayParamP. (In the case of video, displays the first frame.) Use PalmPhotoGetThumbSize() first to get the thumbnail size. If the window handle is NULL, the current draw window is used.

If the callback function returns false, the Photo API will halt the draw or play operation.

New in v3.0.

Parameters:
refNum,: IN: Library reference number.
imageH,: IN: Image handle.
displayParamP,: IN: Display parameter.
Return values:
Err Error code.

void PalmPhotoFreeSelections | ( | UInt16 | refNum,
 |  | PalmPhotoSelectionParam * | photoSelectionP
 | ) |  |

Free memory allocated during the photos selection. For compatibility only; new development should use the V2 version.

Parameters:
refNum,: IN: Library reference number.
photoSelectionP,: IN,OUT: Palm Photo selection parameter.

Err PalmPhotoFreeSelectionsV2 | ( | UInt16 | refNum,
 |  | PalmPhotoSelectionParam * | photoSelectionP
 | ) |  |

Free memory allocated during the photos selection.

Parameters:
refNum,: IN: Library reference number.
photoSelectionP,: IN,OUT: Palm Photo selection parameter.
Return values:
Err Error code.

UInt16 PalmPhotoGetAlbumID | ( | UInt16 | refNum,
 |  | UInt16 | index
 | ) |  |

Get an album ID given the album index. For compatibility only; new development should use the V2 version.

Parameters:
refNum,: IN: Library reference number.
index,: IN: Album index.
Return values:
UInt16 Album ID. If album doesn't exist, return PALM_PHOTO_ALBUM_ALL.

UInt16 PalmPhotoGetAlbumIDV2 | ( | UInt16 | refNum,
 |  | UInt16 | volumeRef,
 |  | UInt16 | index
 | ) |  |

Get an album ID given the album index and volume. If volumeRef is 0, then the location is on the handheld. Otherwise, it is in VFS.

Parameters:
refNum,: IN: Library reference number.
volumeRef,: IN: Volume to search for photo album.
index,: IN: Album index.
Return values:
UInt16 Album ID. If album doesn't exist, return PALM_PHOTO_ALBUM_ALL.

Err PalmPhotoGetAlbumName | ( | UInt16 | refNum,
 |  | UInt16 | albumID,
 |  | Char * | nameP,
 |  | UInt16 | bufSize
 | ) |  |

Get an album name given the album ID. The buffer that will hold the album name is allocated by the user.

Parameters:
refNum,: IN: Library reference number.
albumID,: IN: Album ID
nameP,: OUT: Buffer that will contain the name of the album.
bufSize,: IN: Size of the buffer pointed by nameP.
Return values:
Err Error code.

Err PalmPhotoGetImageExtraInfo | ( | UInt16 | refNum,
 |  | PalmPhotoHandle | imageH,
 |  | PalmPhotoExtraInfoParam * | extraInfoP
 | ) |  |

Get an image extra information.

Note: new info types (palmPhotoExtraInfoSound and palmPhotoExtraInfoUID) added in 3.0.

Parameters:
refNum,: IN: Library reference number.
imageH,: IN: Image handle.
extraInfoP,: OUT: Structure that will hold the extra info requested.
Return values:
Err Error code.

UInt32 PalmPhotoGetImageExtraInfoSize | ( | UInt16 | refNum,
 |  | PalmPhotoHandle | imageH,
 |  | PalmPhotoExtraInfoType | infoType
 | ) |  |

Get an image extra information size.

Parameters:
refNum,: IN: Library reference number.
imageH,: IN: Image handle.
infoType,: IN: Extra info type to retrieve the size from.
Return values:
UInt32 The size of the extra information of the specified type.

Err PalmPhotoGetImageInfo | ( | UInt16 | refNum,
 |  | PalmPhotoHandle | imageH,
 |  | PalmPhotoImageInfo * | infoP
 | ) |  |

Get an image information.

Parameters:
refNum,: IN: Library reference number.
imageH,: IN: Image handle.
infoP,: OUT: Image info structure.
Return values:
Err Error code.

Err PalmPhotoGetLastErrV2 ( UInt16 refNum )

Get the error code from the last Photo API function that executed. Sets the Photo API error code to errNone, if the library is open. If the library is not open, it does not set the error code and returns palmPhotoLibErrNotOpen. New in v2.0.

Parameters:
refNum,: IN: Library reference number.
Return values:
Err Error code.

PalmPhotoCaptureResolution PalmPhotoGetSupportedCaptureResolutionsV3 | ( | UInt16 | refNum,
 |  | PalmPhotoMediaType | mediaType
 | ) |  |

Returns resolutions that are supported by the still or video camera. Returns zero (palmPhotoCaptureResNone) if no camera, or camera disabled.

Parameters:
refNum,: IN: Library reference number.
mediaType,: IN: palmPhotoMediaTypePhoto or palmPhotoMediaTypeVideo
Return values:
PalmPhotoCaptureResolution Flags (bit is set for each resolution that camera supports).

Err PalmPhotoGetThumbSize | ( | UInt16 | refNum,
 |  | PalmPhotoHandle | imageH,
 |  | UInt16 * | widthP,
 |  | UInt16 * | heightP
 | ) |  |

Get an image thumbnail size.

Parameters:
refNum,: IN: Library reference number.
imageH,: IN: Image handle.
widthP,: OUT: Width of the thumbnail.
heightP,: OUT: Height of the thumbnail.
Return values:
Err Error code.

UInt16 PalmPhotoImageCount | ( | UInt16 | refNum,
 |  | UInt16 | albumID
 | ) |  |

Get image count for an album.

Parameters:
refNum,: IN: Library reference number.
albumID,: IN: ID of the Album to retrieve information from.
Return values:
Err Error code.

Boolean PalmPhotoIsCameraAvailableV3 ( UInt16 refNum )

Check for presence of an enabled camera.

Parameters:
refNum,: IN: Library reference number.
Return values:
Boolean false if no camera or camera is disabled.

Err PalmPhotoLibClose ( UInt16 refNum )

Standard library close function

Parameters:
refNum,: IN: library reference number
Return values:
Err Error code.

Err PalmPhotoLibGetVersion | ( | UInt16 | refNum,
 |  | UInt32 | sdkVersion,
 |  | UInt32 * | libVersionP
 | ) |  |

Checks the version of the Palm Photo Library.

Parameters:
refNum,: IN: Library reference number.
sdkVersion,: IN: The version the application expects.
libVersionP,: OUT: The actual version of the library.
Return values:
Err Error code.

Err PalmPhotoLibOpen ( UInt16 refNum )

Standard library open function

Parameters:
refNum,: IN: library reference number
Return values:
Err Error code.

Err PalmPhotoLibSleep ( UInt16 refNum )

Standard library sleep function

Parameters:
refNum,: IN: library reference number
Return values:
Err Error code.

Err PalmPhotoLibWake ( UInt16 refNum )

Standard library wake function

Parameters:
refNum,: IN: library reference number
Return values:
Err Error code.

UInt16 PalmPhotoNewAlbum | ( | UInt16 | refNum,
 |  | const Char * | nameP,
 |  | Err * | errP
 | ) |  |

Create a new album. For compatibility only; new development should use the V2 version.

Parameters:
refNum,: IN: Library reference number.
nameP,: IN: String that contains the name of the new album.
errP,: OUT: Error code.
Return values:
UInt16 If successful, returns the ID of the newly created album. Otherwise, returns PALM_PHOTO_ALBUM_ALL.

UInt16 PalmPhotoNewAlbumV2 | ( | UInt16 | refNum,
 |  | UInt16 | volumeRef,
 |  | const Char * | nameP
 | ) |  |

Create a new album in the selected volume. If volumeRef is 0, then the location is on the handheld. Otherwise, it is in VFS.

Parameters:
refNum,: IN: Library reference number.
volumeRef,: IN: Volume to search for photo album.
nameP,: IN: String that contains the name of the new album.
Return values:
UInt16 If successful, returns the ID of the newly created album. Otherwise, returns PALM_PHOTO_ALBUM_ALL.

PalmPhotoHandle PalmPhotoOpenImage | ( | UInt16 | refNum,
 |  | const PalmPhotoFileLocation * | photoFileP,
 |  | Err * | errP
 | ) |  |

Open an existing image. For compatibility only; new development should use the V2 version.

Parameters:
refNum,: IN: Library reference number.
photoFileP,: IN: Palm Photo file location.
errP,: OUT: Error code.
Return values:
PalmPhotoHandle The opened photo handle or NULL if unsuccessful.

PalmPhotoHandle PalmPhotoOpenImageV2 | ( | UInt16 | refNum,
 |  | const PalmPhotoFileLocation * | photoFileP
 | ) |  |

Open an existing image.

Parameters:
refNum,: IN: Library reference number.
photoFileP,: IN: Palm Photo file location.
Return values:
PalmPhotoHandle The opened photo handle or NULL if unsuccessful.

Err PalmPhotoReadImage | ( | UInt16 | refNum,
 |  | PalmPhotoHandle | imageH,
 |  | const PalmPhotoReadWriteParam * | readParamP
 | ) |  |

Read image data given an image handle. The image format specifies what type of buffer the user expects to copy read data into. For example, to convert a JPEG image to RBG565 data, open a JPEG image, and set readParamP->imageFormat to palmPhotoRGB565FileFormat. The callback function should copy the image data from *bufferP into a buffer referenced within readParamP->userDataP.

Parameters:
refNum,: IN: Library reference number.
imageH,: IN: Image handle.
readParamP,: IN,OUT: Read parameters.
Return values:
Err Error code.

Err PalmPhotoRenameAlbum | ( | UInt16 | refNum,
 |  | UInt16 | albumID,
 |  | const Char * | nameP
 | ) |  |

Rename an album. If Photos has "Camera" album, it also can't be renamed.

Parameters:
refNum,: IN: Library reference number.
albumID,: IN: ID of the Album to delete.
nameP,: IN: New album name.
Return values:
Err Error code.

Err PalmPhotoRotateImageV2 | ( | UInt16 | refNum,
 |  | PalmPhotoHandle | imageH,
 |  | PalmPhotoHandle * | rotatedImageHP,
 |  | Int16 | rotation
 | ) |  |

Return a rotated image. New in v2.0.

Parameters:
refNum,: IN: Library reference number.
imageH,: IN: Image handle.
rotatedImageHP,: OUT: The new image rotated.
rotation,: IN: Rotation angle (rotation is counter-clockwise).
Return values:
Err Error code.

Err PalmPhotoScaleImageV2 | ( | UInt16 | refNum,
 |  | PalmPhotoHandle | imageH,
 |  | PalmPhotoHandle * | scaledImageHP,
 |  | UInt32 | width,
 |  | UInt32 | height
 | ) |  |

Return a scaled image. New in v2.0.

Parameters:
refNum,: IN: Library reference number.
imageH,: IN: Image handle.
scaledImageHP,: OUT: The new image scaled.
width,: IN: New image width (must be <= existing width).
height,: IN: New image height (must be <= existing height).
Return values:
Err Error code.

Err PalmPhotoSelectDlg | ( | UInt16 | refNum,
 |  | PalmPhotoSelectionParam * | photoSelectionP,
 |  | PalmPhotoDlgType | dlgType,
 |  | Boolean | handleCard
 | ) |  |

Select images using the Media Selection/Deletion dialog. The selected images are passed in the selection parameter. To free the memory allocated, use the PalmPhotoFreeSelections() function.

Parameters:
refNum,: IN: Library reference number.
photoSelectionP,: IN,OUT: Palm Photo selection parameter. Contains array of selections on return.
dlgType,: IN: Selection dialog type (eg palmPhotoDlgSelection...)
handleCard,: IN: If true, the dialog with intercept card notifications.
Return values:
Err Error code.

Err PalmPhotoSelectDlgV3 | ( | UInt16 | refNum,
 |  | PalmPhotoSelectionParam * | photoSelectionP,
 |  | const PalmPhotoCaptureParamV2 * | captureParamP,
 |  | PalmPhotoDlgType | dlgType,
 |  | PalmPhotoMediaType | mediaType,
 |  | Boolean | handleCard
 | ) |  |

Select images using the Photo Selection/Deletion dialog, with optional camera support. The selected images are passed in the selection parameter. To free the memory allocated, use the PalmPhotoFreeSelections() function.

Parameters:
refNum,: IN:Library reference number.
photoSelectionP,: IN,OUT: Palm Photo selection parameter. Contains array of selections on return.
captureParamP,: IN: Palm Photo capture parameter. Set to null to suppress the camera. Camera only supported for single select dialog type. Camera only supported when media type is photo OR video (not all)
dlgType,: IN: Selection dialog type (eg palmPhotoDlgSelection...)
mediaType,: IN: Dialog displays only photos, only videos, or all media types.
handleCard,: IN: If true, the dialog with intercept card notifications.
Return values:
Err Error code.

Err PalmPhotoSelectImages | ( | UInt16 | refNum,
 |  | PalmPhotoSelectionParam * | photoSelectionP
 | ) |  |

Select images within a specific range. The selected images are passed in the selection parameter. To free the memory allocated, use the PalmPhotoFreeSelections() function.

Parameters:
refNum,: IN: Library reference number.
photoSelectionP,: IN,OUT: Palm Photo selection parameter. Contains array of selections on return.
Return values:
Err Error code.

Err PalmPhotoSetImageExtraInfo | ( | UInt16 | refNum,
 |  | PalmPhotoHandle | imageH,
 |  | const PalmPhotoExtraInfoParam * | extraInfoP
 | ) |  |

Set an image extra information. When user set palmPhotoExtraInfoLocation, if the file name contains illegal characters, the function will remove them. If the file name has an incorrect file extension, the function will add the correct one. For example, if the format is Jpeg, "*22.j" will be converted to "22.jpg".

Parameters:
refNum,: IN: Library reference number.
imageH,: IN: Image handle.
extraInfoP,: IN: Structure that the extra info the extra info to set.
Return values:
Err Error code.

Err PalmPhotoWriteImage | ( | UInt16 | refNum,
 |  | PalmPhotoHandle | imageH,
 |  | const PalmPhotoReadWriteParam * | writeParamP
 | ) |  |

Write image data given an image handle. The writeParamP->imageFormat parameter specifies the source format the calling application is providing to the API to write into storage. The only valid source formats are RGB565 and RGB888. For example, to convert an RGB565 image to a JPEG, you would create a JPEG image and pass its handle in imageH; then you would set writeParamP->imageFormat to palmPhotoRGB565FileFormat. The actual RGB image data would be referenced by a pointer inside writeParamP->userDataP. The callback function will pass the RGB data to the API by copying it into *bufferP.

Parameters:
refNum,: IN: Library reference number.
imageH,: IN,OUT: Image handle.
writeParamP,: IN: Write parameters.
Return values:
Err Error code.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:07:53 2008 for Palm API Guide


Header Files » Incs » common » libraries » imaging

palmOnePhotoCommon.h File Reference

Detailed Description

Palm Photos API: This file contains all the defines, enumerations, structures needed by PalmPhoto.h.

Version:
3.0

Definition in file palmOnePhotoCommon.h.

Include dependency graph for palmOnePhotoCommon.h:

Go to the source code of this file.

Data Structures

  • struct _PalmPhotoFileLocation
    Photo file location. More...
  • struct _PalmPhotoImageInfo
    Photo information. More...
  • struct _PalmPhotoExtraInfo
    Photo image extra info parameters. More...
  • struct _PalmPhotoSelections
    Photo selections. More...

Defines

  • #define PMP_LIB_TRAP(trapNum) SYS_TRAP(trapNum)
  • #define PalmPhotoLibCreatorID 'PMPL'
  • #define PalmPhotoLibTypeID sysFileTLibrary
  • #define PalmPhotoLibName "PalmPhotoLib"
  • #define palmPhotoJPEGFileFormat (0x0001)
  • #define palmPhotoRGB888FileFormat (0x0002)
  • #define palmPhotoRGB565FileFormat (0x0003)
  • #define palmPhotoGIFFileFormat (0x0004)
  • #define palmPhotoBMPFileFormat (0x0005)
  • #define palmPhotoTIFFFileFormat (0x0006)
  • #define palmPhotoPNGFileFormat (0x0007)
  • #define palmPhotoWBMPFileFormat (0x0008)
  • #define palmPhotoMJPEGFileFormat (0x1001)
  • #define palmPhotoMPEG1FileFormat (0x1002)
  • #define palmPhotoMPEG4FileFormat (0x1003)
  • #define palmPhotoFormat_AVI_ADPCM_MPEG4 (0x1113)
  • #define palmPhotoFormat_AVI_MP3_MPEG4 (0x1123)
  • #define palmPhotoFormat_ASF_ADPCM_MPEG4 (0x1213)
  • #define palmPhotoFormat_ASF_MP3_MPEG4 (0x1223)
  • #define palmPhotoFormat_3GP_AMR_MPEG4 (0x1333)
  • #define palmPhotoFormat_3GP_AMR_H263 (0x1334)
  • #define palmPhotoFormat_3G2_QCELP_MPEG4 (0x1443)
  • #define palmPhotoFormat_3G2_QCELP_H263 (0x1444)
  • #define palmPhotoPreferredImageFormat (0xFFFD)
  • #define palmPhotoPreferredVideoFormat (0xFFFE)
  • #define palmPhotoUnsupportedFormat (0xFFFF)
  • #define palmPhotoCaptureResSUBQCIF (0x00000001)
  • #define palmPhotoCaptureResQQVGA (0x00000002)
  • #define palmPhotoCaptureResQCIF (0x00000004)
  • #define palmPhotoCaptureResQVGA (0x00000008)
  • #define palmPhotoCaptureResCIF (0x00000010)
  • #define palmPhotoCaptureResVGA (0x00000020)
  • #define palmPhotoCaptureResSVGA (0x00000040)
  • #define palmPhotoCaptureResXVGA (0x00000080)
  • #define palmPhotoCaptureResSXGA (0x00000100)
  • #define palmPhotoCaptureResSXGA960 (0x00000100)
  • #define palmPhotoCaptureResSXGA1024 (0x00000200)
  • #define palmPhotoCaptureResOther (0x80000000)
  • #define palmPhotoCaptureResNone (0x00000000)
  • #define palmPhotoStreamLocation (0x0000)
  • #define palmPhotoVFSLocation (0x0001)
  • #define palmPhotoMemoryLocation (0x0002)
  • #define palmPhotoExtraInfoLocation (0x0000)
  • #define palmPhotoExtraInfoDate (0x0001)
  • #define palmPhotoExtraInfoAlbum (0x0002)
  • #define palmPhotoExtraInfoNotes (0x0003)
  • #define palmPhotoExtraInfoSound (0x0004)
  • #define palmPhotoExtraInfoImageUID (0x0005)
  • #define palmPhotoExtraInfoSoundUID (0x0006)
  • #define palmPhotoExtraInfoCompositeUID (0x0007)
  • #define palmPhotoDlgSelection (0x0000)
  • #define palmPhotoDlgSingleSelection (0x0001)
  • #define palmPhotoDlgDeletion (0x0002)
  • #define palmPhotoMediaTypePhoto (0x0001)
  • #define palmPhotoMediaTypeVideo (0x0002)
  • #define palmPhotoMediaTypeAll (0xFFFF)
  • #define palmPhotoHighestQuality (0xFFFF)
  • #define palmPhotoHighQuality (0xFFFE)
  • #define palmPhotoMediumQuality (0xFFFD)
  • #define palmPhotoLowQuality (0xFFFC)
  • #define palmPhotoLowestQuality (0xFFFB)
  • #define PALM_PHOTO_MAX_PATH (255)
  • #define PALM_PHOTO_SELECT_ALL ((Int32)0xFFFFFFFF)
  • #define PALM_PHOTO_ALBUM_ALL ((UInt16)0xFFFF)
  • #define PALM_PHOTO_ALBUM_ALL_HANDHELD ((UInt16)0xFFFF)
  • #define PALM_PHOTO_ALBUM_ALL_VFS ((UInt16)0xFFFE)
  • #define PALM_PHOTO_ALBUM_MAX_NAME (255)
Library Versions
  • #define kPalmPhotoLibVersion1 sysMakeROMVersion(1, 0, 0, sysROMStageRelease, 0)
  • #define kPalmPhotoLibVersion2 sysMakeROMVersion(2, 0, 0, sysROMStageRelease, 0)
  • #define kPalmPhotoLibVersion3 sysMakeROMVersion(3, 0, 0, sysROMStageRelease, 1)
  • #define kPalmPhotoLibVersion kPalmPhotoLibVersion3
Error Codes
  • #define palmPhotoLibErrParam (oemErrorClass + 0x100)
  • #define palmPhotoLibErrNotOpen (palmPhotoLibErrParam | 1)
  • #define palmPhotoLibErrStillOpen (palmPhotoLibErrParam | 2)
  • #define palmPhotoLibErrNotPhotos (palmPhotoLibErrParam | 3)
  • #define palmPhotoLibErrNotOpenPhotos (palmPhotoLibErrParam | 4)
  • #define palmPhotoLibErrAlbumExist (palmPhotoLibErrParam | 5)
  • #define palmPhotoLibErrAlbumNotExist (palmPhotoLibErrParam | 6)
  • #define palmPhotoLibErrAlbumFull (palmPhotoLibErrParam | 7)
  • #define palmPhotoLibErrAlbumNameTooLong (palmPhotoLibErrParam | 8)
  • #define palmPhotoLibErrAlbumReadOnly (palmPhotoLibErrParam | 9)
  • #define palmPhotoLibErrLowHeap (palmPhotoLibErrParam | 10)
  • #define palmPhotoLibErrLowMemory (palmPhotoLibErrParam | 11)
  • #define palmPhotoLibErrImageExist (palmPhotoLibErrParam | 12)
  • #define palmPhotoLibErrImageNotFound (palmPhotoLibErrParam | 13)
  • #define palmPhotoLibErrFormatNotSupported (palmPhotoLibErrParam | 14)
  • #define palmPhotoLibErrImageNotInPhotos (palmPhotoLibErrParam | 15)
  • #define palmPhotoLibErrImageInvalidPath (palmPhotoLibErrParam | 16)
  • #define palmPhotoLibErrUserCancel (palmPhotoLibErrParam | 17)
  • #define palmPhotoLibErrScreenDepth (palmPhotoLibErrParam | 18)
  • #define palmPhotoLibErrSmallBuffer (palmPhotoLibErrParam | 19)
  • #define palmPhotoLibErrUnknown (palmPhotoLibErrParam | 20)
  • #define palmPhotoLibErrNoThumbnail (palmPhotoLibErrParam | 21)
  • #define palmPhotoLibErrAbortReadWrite (palmPhotoLibErrParam | 22)
  • #define palmPhotoLibErrUnsupportedRotation (palmPhotoLibErrParam | 23)
  • #define palmPhotoLibErrInvalidVolume (palmPhotoLibErrParam | 24)
  • #define palmPhotoLibErrNoCamera (palmPhotoLibErrParam | 25)
  • #define palmPhotoLibErrOldVersion (palmPhotoLibErrParam | 26)
  • #define palmPhotoLibErrProtectedMedia (palmPhotoLibErrParam | 27)
  • #define palmPhotoLibErrLowPower (palmPhotoLibErrParam | 28)
Old Constant Names

  • #define palmPhotoAVIM4AFileFormat palmPhotoFormat_AVI_ADPCM_MPEG4
  • #define palmPhotoAVIM43FileFormat palmPhotoFormat_AVI_MP3_MPEG4
  • #define palmPhotoASFM4AFileFormat palmPhotoFormat_ASF_ADPCM_MPEG4
  • #define palmPhotoASFM43FileFormat palmPhotoFormat_ASF_MP3_MPEG4

Typedefs

  • typedef UInt16 PalmPhotoFileFormat
  • typedef UInt32 PalmPhotoCaptureResolution
  • typedef UInt16 PalmPhotoLocationType
  • typedef UInt8 PalmPhotoUID [21]
  • typedef UInt16 PalmPhotoExtraInfoType
  • typedef UInt16 PalmPhotoDlgType
  • typedef UInt16 PalmPhotoMediaType
  • typedef UInt16 PalmPhotoQualityType
  • typedef _PalmPhotoFileLocation PalmPhotoFileLocation
    Photo file location.
  • typedef _PalmPhotoImageInfo PalmPhotoImageInfo
    Photo information.
  • typedef _PalmPhotoExtraInfo PalmPhotoExtraInfoParam
    Photo image extra info parameters.
  • typedef _PalmPhotoType * PalmPhotoHandle
  • typedef _PalmPhotoSelections PalmPhotoSelections
    Photo selections.

Define Documentation

#define kPalmPhotoLibVersion kPalmPhotoLibVersion3

Definition at line 57 of file palmOnePhotoCommon.h.

#define kPalmPhotoLibVersion1 sysMakeROMVersion(1, 0, 0, sysROMStageRelease, 0)

Definition at line 54 of file palmOnePhotoCommon.h.

#define kPalmPhotoLibVersion2 sysMakeROMVersion(2, 0, 0, sysROMStageRelease, 0)

Definition at line 55 of file palmOnePhotoCommon.h.

#define kPalmPhotoLibVersion3 sysMakeROMVersion(3, 0, 0, sysROMStageRelease, 1)

Definition at line 56 of file palmOnePhotoCommon.h.

#define PALM_PHOTO_ALBUM_ALL ((UInt16)0xFFFF)

Used to select all the albums at once.

Definition at line 306 of file palmOnePhotoCommon.h.

#define PALM_PHOTO_ALBUM_ALL_HANDHELD ((UInt16)0xFFFF)

Used to select all the albums on the handheld at once.

Definition at line 308 of file palmOnePhotoCommon.h.

#define PALM_PHOTO_ALBUM_ALL_VFS ((UInt16)0xFFFE)

Used to select all the albums on the VFS card at once.

Definition at line 310 of file palmOnePhotoCommon.h.

#define PALM_PHOTO_ALBUM_MAX_NAME (255)

Maximum album name length on device. (Increased for v3.0.)

Definition at line 312 of file palmOnePhotoCommon.h.

#define PALM_PHOTO_MAX_PATH (255)

Maximum file path length.

Definition at line 302 of file palmOnePhotoCommon.h.

#define PALM_PHOTO_SELECT_ALL ((Int32)0xFFFFFFFF)

Used during selection to select maximum number of photos.

Definition at line 304 of file palmOnePhotoCommon.h.

#define palmPhotoASFM43FileFormat palmPhotoFormat_ASF_MP3_MPEG4

Old (2.0) constant names for compatibility

Definition at line 188 of file palmOnePhotoCommon.h.

#define palmPhotoASFM4AFileFormat palmPhotoFormat_ASF_ADPCM_MPEG4

Old (2.0) constant names for compatibility

Definition at line 187 of file palmOnePhotoCommon.h.

#define palmPhotoAVIM43FileFormat palmPhotoFormat_AVI_MP3_MPEG4

Old (2.0) constant names for compatibility

Definition at line 186 of file palmOnePhotoCommon.h.

#define palmPhotoAVIM4AFileFormat palmPhotoFormat_AVI_ADPCM_MPEG4

Old (2.0) constant names for compatibility

Definition at line 185 of file palmOnePhotoCommon.h.

#define palmPhotoBMPFileFormat (0x0005)

BMP bitmap format New in v2.0.

Definition at line 143 of file palmOnePhotoCommon.h.

#define palmPhotoCaptureResCIF (0x00000010)

CIF (352x288) New in v3.0.

Definition at line 207 of file palmOnePhotoCommon.h.

#define palmPhotoCaptureResNone (0x00000000)

None (no camera or camera disabled)

Definition at line 225 of file palmOnePhotoCommon.h.

#define palmPhotoCaptureResOther (0x80000000)

Unknown dimensions (caller must use CameraManager)

Definition at line 222 of file palmOnePhotoCommon.h.

#define palmPhotoCaptureResQCIF (0x00000004)

QCIF (176x144) New in v3.0.

Definition at line 203 of file palmOnePhotoCommon.h.

#define palmPhotoCaptureResQQVGA (0x00000002)

QQVGA (160x120) New in v3.0.

Definition at line 201 of file palmOnePhotoCommon.h.

#define palmPhotoCaptureResQVGA (0x00000008)

QVGA (320x240) New in v3.0.

Definition at line 205 of file palmOnePhotoCommon.h.

#define palmPhotoCaptureResSUBQCIF (0x00000001)

SUBQCIF (128x96) New in v3.0.

Definition at line 199 of file palmOnePhotoCommon.h.

#define palmPhotoCaptureResSVGA (0x00000040)

SVGA (800x600) New in v3.0.

Definition at line 211 of file palmOnePhotoCommon.h.

#define palmPhotoCaptureResSXGA (0x00000100)

SXGA (1280x960) New in v3.0.

Definition at line 215 of file palmOnePhotoCommon.h.

#define palmPhotoCaptureResSXGA1024 (0x00000200)

SXGA (1280x1024) New in v3.0.

Definition at line 219 of file palmOnePhotoCommon.h.

#define palmPhotoCaptureResSXGA960 (0x00000100)

SXGA (1280x960) New in v3.0.

Definition at line 217 of file palmOnePhotoCommon.h.

#define palmPhotoCaptureResVGA (0x00000020)

VGA (640x480) New in v3.0.

Definition at line 209 of file palmOnePhotoCommon.h.

#define palmPhotoCaptureResXVGA (0x00000080)

XVGA (1024x768) New in v3.0.

Definition at line 213 of file palmOnePhotoCommon.h.

#define palmPhotoDlgDeletion (0x0002)

Deletion dialog.

Definition at line 269 of file palmOnePhotoCommon.h.

#define palmPhotoDlgSelection (0x0000)

Mutiple selection dialog.

Definition at line 265 of file palmOnePhotoCommon.h.

#define palmPhotoDlgSingleSelection (0x0001)

Single selection dialog.

Definition at line 267 of file palmOnePhotoCommon.h.

#define palmPhotoExtraInfoAlbum (0x0002)

Album.infoP points to a (Char *).

Definition at line 248 of file palmOnePhotoCommon.h.

#define palmPhotoExtraInfoCompositeUID (0x0007)

Notes.infoP points to a PalmPhotoUID. New in v3.0.

Definition at line 258 of file palmOnePhotoCommon.h.

#define palmPhotoExtraInfoDate (0x0001)

Date.infoP points to a DateType.

Definition at line 246 of file palmOnePhotoCommon.h.

#define palmPhotoExtraInfoImageUID (0x0005)

Notes.infoP points to a PalmPhotoUID. New in v3.0.

Definition at line 254 of file palmOnePhotoCommon.h.

#define palmPhotoExtraInfoLocation (0x0000)

File location.infoP points to a PalmPhotoFileLocation.

Definition at line 244 of file palmOnePhotoCommon.h.

#define palmPhotoExtraInfoNotes (0x0003)

Notes.infoP points to a (Char *).

Definition at line 250 of file palmOnePhotoCommon.h.

#define palmPhotoExtraInfoSound (0x0004)

Notes.infoP points to a PalmPhotoFileLocation. New in v3.0.

Definition at line 252 of file palmOnePhotoCommon.h.

#define palmPhotoExtraInfoSoundUID (0x0006)

Notes.infoP points to a PalmPhotoUID. New in v3.0.

Definition at line 256 of file palmOnePhotoCommon.h.

#define palmPhotoFormat_3G2_QCELP_H263 (0x1444)

3G2 file with QCELP audio + H.263 video New in v3.0.

Definition at line 172 of file palmOnePhotoCommon.h.

#define palmPhotoFormat_3G2_QCELP_MPEG4 (0x1443)

3G2 file with QCELP audio + MPEG4 video New in v3.0.

Definition at line 170 of file palmOnePhotoCommon.h.

#define palmPhotoFormat_3GP_AMR_H263 (0x1334)

3GP file with AMR audio + H.263 video New in v3.0.

Definition at line 168 of file palmOnePhotoCommon.h.

#define palmPhotoFormat_3GP_AMR_MPEG4 (0x1333)

3GP file with AMR audio + MPEG4 video New in v3.0.

Definition at line 166 of file palmOnePhotoCommon.h.

#define palmPhotoFormat_ASF_ADPCM_MPEG4 (0x1213)

ASF file with ADPCM audio + MPEG4 video New in v2.0.

Definition at line 162 of file palmOnePhotoCommon.h.

#define palmPhotoFormat_ASF_MP3_MPEG4 (0x1223)

ASF file with MP3 audio + MPEG4 video New in v2.0.

Definition at line 164 of file palmOnePhotoCommon.h.

#define palmPhotoFormat_AVI_ADPCM_MPEG4 (0x1113)

AVI file with ADPCM audio + MPEG4 video New in v2.0.

Definition at line 158 of file palmOnePhotoCommon.h.

#define palmPhotoFormat_AVI_MP3_MPEG4 (0x1123)

AVI file with MP3 audio + MPEG4 video New in v2.0.

Definition at line 160 of file palmOnePhotoCommon.h.

#define palmPhotoGIFFileFormat (0x0004)

GIF 8-bit indexed color format New in v2.0.

Definition at line 141 of file palmOnePhotoCommon.h.

#define palmPhotoHighestQuality (0xFFFF)

Highest quality compressed image.

Definition at line 287 of file palmOnePhotoCommon.h.

#define palmPhotoHighQuality (0xFFFE)

High quality compressed image.

Definition at line 289 of file palmOnePhotoCommon.h.

#define palmPhotoJPEGFileFormat (0x0001)

JPEG file format.

Definition at line 135 of file palmOnePhotoCommon.h.

#define PalmPhotoLibCreatorID 'PMPL'

Palm Photo Library creator id

Definition at line 37 of file palmOnePhotoCommon.h.

#define palmPhotoLibErrAbortReadWrite (palmPhotoLibErrParam | 22)

Abort a read or write operation. New in v2.0.

Definition at line 113 of file palmOnePhotoCommon.h.

#define palmPhotoLibErrAlbumExist (palmPhotoLibErrParam | 5)

The album already exists.

Definition at line 79 of file palmOnePhotoCommon.h.

#define palmPhotoLibErrAlbumFull (palmPhotoLibErrParam | 7)

The album is full.

Definition at line 83 of file palmOnePhotoCommon.h.

#define palmPhotoLibErrAlbumNameTooLong (palmPhotoLibErrParam | 8)

The album name is too long.

Definition at line 85 of file palmOnePhotoCommon.h.

#define palmPhotoLibErrAlbumNotExist (palmPhotoLibErrParam | 6)

The selected album does not exist.

Definition at line 81 of file palmOnePhotoCommon.h.

#define palmPhotoLibErrAlbumReadOnly (palmPhotoLibErrParam | 9)

The album cannot be renamed or deleted.

Definition at line 87 of file palmOnePhotoCommon.h.

#define palmPhotoLibErrFormatNotSupported (palmPhotoLibErrParam | 14)

Image format not supported for the attempted operation.

Definition at line 97 of file palmOnePhotoCommon.h.

#define palmPhotoLibErrImageExist (palmPhotoLibErrParam | 12)

An image with that name already exists.

Definition at line 93 of file palmOnePhotoCommon.h.

#define palmPhotoLibErrImageInvalidPath (palmPhotoLibErrParam | 16)

Invalid path/image name.

Definition at line 101 of file palmOnePhotoCommon.h.

#define palmPhotoLibErrImageNotFound (palmPhotoLibErrParam | 13)

Specified image does not exist.

Definition at line 95 of file palmOnePhotoCommon.h.

#define palmPhotoLibErrImageNotInPhotos (palmPhotoLibErrParam | 15)

Image is not in the Photos database.

Definition at line 99 of file palmOnePhotoCommon.h.

#define palmPhotoLibErrInvalidVolume (palmPhotoLibErrParam | 24)

Invalid volume for operation. New in v2.0.

Definition at line 117 of file palmOnePhotoCommon.h.

#define palmPhotoLibErrLowHeap (palmPhotoLibErrParam | 10)

Insufficient free space in dynamic heap.

Definition at line 89 of file palmOnePhotoCommon.h.

#define palmPhotoLibErrLowMemory (palmPhotoLibErrParam | 11)

Insufficient free space in storage heap.

Definition at line 91 of file palmOnePhotoCommon.h.

#define palmPhotoLibErrLowPower (palmPhotoLibErrParam | 28)

The Power too lower

Definition at line 125 of file palmOnePhotoCommon.h.

#define palmPhotoLibErrNoCamera (palmPhotoLibErrParam | 25)

Device has no camera. New in v2.0.

Definition at line 119 of file palmOnePhotoCommon.h.

#define palmPhotoLibErrNoThumbnail (palmPhotoLibErrParam | 21)

Image has no thumbnail.

Definition at line 111 of file palmOnePhotoCommon.h.

#define palmPhotoLibErrNotOpen (palmPhotoLibErrParam | 1)

Library not open.

Definition at line 71 of file palmOnePhotoCommon.h.

#define palmPhotoLibErrNotOpenPhotos (palmPhotoLibErrParam | 4)

Could not open Photos database.

Definition at line 77 of file palmOnePhotoCommon.h.

#define palmPhotoLibErrNotPhotos (palmPhotoLibErrParam | 3)

Photos database does not exist on device.

Definition at line 75 of file palmOnePhotoCommon.h.

#define palmPhotoLibErrOldVersion (palmPhotoLibErrParam | 26)

Library version is too old.

Definition at line 121 of file palmOnePhotoCommon.h.

#define palmPhotoLibErrParam (oemErrorClass + 0x100)

Invalid parameter.

Definition at line 69 of file palmOnePhotoCommon.h.

#define palmPhotoLibErrProtectedMedia (palmPhotoLibErrParam | 27)

Invalid operation for media protected by DRM

Definition at line 123 of file palmOnePhotoCommon.h.

#define palmPhotoLibErrScreenDepth (palmPhotoLibErrParam | 18)

Unsupported handheld screen color depth.

Definition at line 105 of file palmOnePhotoCommon.h.

#define palmPhotoLibErrSmallBuffer (palmPhotoLibErrParam | 19)

Buffer is too small.

Definition at line 107 of file palmOnePhotoCommon.h.

#define palmPhotoLibErrStillOpen (palmPhotoLibErrParam | 2)

Library is still open.

Definition at line 73 of file palmOnePhotoCommon.h.

#define palmPhotoLibErrUnknown (palmPhotoLibErrParam | 20)

Unknown or unclassifiable error.

Definition at line 109 of file palmOnePhotoCommon.h.

#define palmPhotoLibErrUnsupportedRotation (palmPhotoLibErrParam | 23)

Rotation angle not supported. New in v2.0.

Definition at line 115 of file palmOnePhotoCommon.h.

#define palmPhotoLibErrUserCancel (palmPhotoLibErrParam | 17)

User canceled operation.

Definition at line 103 of file palmOnePhotoCommon.h.

#define PalmPhotoLibName "PalmPhotoLib"

Palm Photo Library database name

Definition at line 44 of file palmOnePhotoCommon.h.

#define PalmPhotoLibTypeID sysFileTLibrary

Standard library type

Definition at line 38 of file palmOnePhotoCommon.h.

#define palmPhotoLowestQuality (0xFFFB)

Lowest quality compressed image.

Definition at line 295 of file palmOnePhotoCommon.h.

#define palmPhotoLowQuality (0xFFFC)

Low quality compressed image.

Definition at line 293 of file palmOnePhotoCommon.h.

#define palmPhotoMediaTypeAll (0xFFFF)

All media types (in 3.0, limited to photos and video).

Definition at line 280 of file palmOnePhotoCommon.h.

#define palmPhotoMediaTypePhoto (0x0001)

Select still image types

Definition at line 276 of file palmOnePhotoCommon.h.

#define palmPhotoMediaTypeVideo (0x0002)

Select video types

Definition at line 278 of file palmOnePhotoCommon.h.

#define palmPhotoMediumQuality (0xFFFD)

Normal quality compressed image.

Definition at line 291 of file palmOnePhotoCommon.h.

#define palmPhotoMemoryLocation (0x0002)

Memory file. Read-Only images.

Definition at line 235 of file palmOnePhotoCommon.h.

#define palmPhotoMJPEGFileFormat (0x1001)

M-JPEG video format New in v2.0.

Definition at line 151 of file palmOnePhotoCommon.h.

#define palmPhotoMPEG1FileFormat (0x1002)

MPEG1 video format New in v2.0.

Definition at line 153 of file palmOnePhotoCommon.h.

#define palmPhotoMPEG4FileFormat (0x1003)

MPEG4 video format New in v2.0.

Definition at line 155 of file palmOnePhotoCommon.h.

#define palmPhotoPNGFileFormat (0x0007)

PNG bitmap format New in v2.0.

Definition at line 147 of file palmOnePhotoCommon.h.

#define palmPhotoPreferredImageFormat (0xFFFD)

Default still capture format. New in v3.0.

Definition at line 175 of file palmOnePhotoCommon.h.

#define palmPhotoPreferredVideoFormat (0xFFFE)

Default video capture format. New in v3.0.

Definition at line 177 of file palmOnePhotoCommon.h.

#define palmPhotoRGB565FileFormat (0x0003)

Raw RGB 565 file format.

Definition at line 139 of file palmOnePhotoCommon.h.

#define palmPhotoRGB888FileFormat (0x0002)

Raw RGB 888 file format.

Definition at line 137 of file palmOnePhotoCommon.h.

#define palmPhotoStreamLocation (0x0000)

File stream on the device.

Definition at line 231 of file palmOnePhotoCommon.h.

#define palmPhotoTIFFFileFormat (0x0006)

TIFF bitmap format New in v2.0.

Definition at line 145 of file palmOnePhotoCommon.h.

#define palmPhotoUnsupportedFormat (0xFFFF)

Unsupported file format.

Definition at line 180 of file palmOnePhotoCommon.h.

#define palmPhotoVFSLocation (0x0001)

VFS file.

Definition at line 233 of file palmOnePhotoCommon.h.

#define palmPhotoWBMPFileFormat (0x0008)

WBMP bitmap format New in v2.0.

Definition at line 149 of file palmOnePhotoCommon.h.

#define PMP_LIB_TRAP ( trapNum ) SYS_TRAP(trapNum)

Definition at line 30 of file palmOnePhotoCommon.h.

Typedef Documentation

typedef UInt32 PalmPhotoCaptureResolution

Used with palmPhotoCaptureRes defines

Definition at line 228 of file palmOnePhotoCommon.h.

typedef UInt16 PalmPhotoDlgType

Palm Photo dialog type.

Definition at line 272 of file palmOnePhotoCommon.h.

typedef struct _PalmPhotoExtraInfo PalmPhotoExtraInfoParam

Photo image extra info parameters.

Gets extra information on an image.

typedef UInt16 PalmPhotoExtraInfoType

Palm Photo extra information type.

Definition at line 261 of file palmOnePhotoCommon.h.

typedef UInt16 PalmPhotoFileFormat

Palm Photo file format.

Definition at line 192 of file palmOnePhotoCommon.h.

typedef struct _PalmPhotoFileLocation PalmPhotoFileLocation

Photo file location.

This structure is used to open, create and query location information of an image.

typedef struct _PalmPhotoType* PalmPhotoHandle

Palm Photo handle.

See also:
_PalmPhotoType

Definition at line 382 of file palmOnePhotoCommon.h.

typedef struct _PalmPhotoImageInfo PalmPhotoImageInfo

Photo information.

This structure contains the basic image information.

typedef UInt16 PalmPhotoLocationType

Palm Photo file location type.

Definition at line 238 of file palmOnePhotoCommon.h.

typedef UInt16 PalmPhotoMediaType

Palm Photo media type (used in PalmPhotoSelectDlgV3).

Definition at line 283 of file palmOnePhotoCommon.h.

typedef UInt16 PalmPhotoQualityType

Palm Photo image quality type.

Definition at line 298 of file palmOnePhotoCommon.h.

typedef struct _PalmPhotoSelections PalmPhotoSelections

Photo selections.

This strucutre is used during image selections, either by using the PalmPhotoSelectDlg() function of the PalmPhotoSelect() function.

typedef UInt8 PalmPhotoUID[21]

Unique ID

Definition at line 241 of file palmOnePhotoCommon.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:07:54 2008 for Palm API Guide


Header Files » Incs » common » system

palmOneResources.h File Reference

Detailed Description

Palm-specific system types and resources.

Version:
1.0
Date:
02/29/2002

Definition in file palmOneResources.h.

Go to the source code of this file.

Defines

Company ID - registered creator
  • #define kPalmCompanyIDPalm 'Palm'
  • #define kPalmCompanyIDHandspring 'hspr'
  • #define kPalmCompanyIDOldPalm 'palm'
Device ID - registered creator
  • #define kPalmOneDeviceIDZire 'Cubs'
  • #define kPalmOneDeviceIDTungstenT 'Frg1'
  • #define kPalmOneDeviceIDTungstenW 'atlc'
  • #define kPalmOneDeviceIDTungstenC 'MT64'
  • #define kPalmOneDeviceIDZire71 'Zpth'
  • #define kPalmOneDeviceIDTungstenT2 'Frg2'
  • #define kPalmOneDeviceIDTungstenT3 'Arz1'
  • #define kPalmOneDeviceIDTungstenTE 'Cct1'
  • #define kPalmOneDeviceIDZire21 'Zi21'
  • #define kPalmOneDeviceIDTreo600 'H101'
  • #define kPalmOneDeviceIDTreo600Sim 'H201'
  • #define kPalmOneDeviceIDZire31 'Zi22'
  • #define kPalmOneDeviceIDZire72 'Zi72'
  • #define kPalmOneDeviceIDAngus 'TnT5'
  • #define kPalmOneDeviceIDTungstenT5 kPalmOneDeviceIDAngus
  • #define kPalmOneDeviceIDTreo650 'H102'
  • #define kPalmOneDeviceIDTreo650Sim 'H202'
  • #define kPalmOneDeviceIDTungstenE2 'Zir4'
  • #define kPalmOneDeviceIDTungstenX 'TunX'
  • #define kPalmDeviceIDTX 'D050'
  • #define kPalmDeviceIDZ22 'D051'
  • #define kPalmOneDeviceIDDevice3 'H103'
  • #define kPalmOneDeviceIDDevice4 'H104'
  • #define kPalmOneDeviceIDDevice5 'H105'
  • #define kPalmOneDeviceIDDevice6 'H106'
  • #define kPalmOneDeviceIDDevice7 'H107'
  • #define kPalmOneDeviceIDDevice8 'H108'
  • #define kPalmOneDeviceIDDevice9 'H109'
  • #define kPalmOneDeviceIDDeviceA 'H10A'
  • #define kPalmOneDeviceIDVentura 'D052'
  • #define kPalmOneDeviceIDLowrider 'D053'
  • #define kPalmOneDeviceIDTorino 'D060'
  • #define kPalmOneDeviceIDGnome 'D061'
  • #define kPalmOneDeviceIDGandalf 'D062'

Define Documentation

#define kPalmCompanyIDHandspring 'hspr'

Handspring company ID to be used with past products

Definition at line 30 of file palmOneResources.h.

#define kPalmCompanyIDOldPalm 'palm'

Old company ID. For Tungsten|W.

Definition at line 31 of file palmOneResources.h.

#define kPalmCompanyIDPalm 'Palm'

Company ID.

Definition at line 29 of file palmOneResources.h.

#define kPalmDeviceIDTX 'D050'

Device ID for Palm T|X

Definition at line 60 of file palmOneResources.h.

#define kPalmDeviceIDZ22 'D051'

Device ID for Palm Z22

Definition at line 61 of file palmOneResources.h.

#define kPalmOneDeviceIDAngus 'TnT5'

Device ID for Tungsten|T5.

Definition at line 54 of file palmOneResources.h.

#define kPalmOneDeviceIDDevice3 'H103'

Device ID reserved for future use.

Definition at line 62 of file palmOneResources.h.

#define kPalmOneDeviceIDDevice4 'H104'

Device ID reserved for future use.

Definition at line 63 of file palmOneResources.h.

#define kPalmOneDeviceIDDevice5 'H105'

Device ID reserved for future use.

Definition at line 64 of file palmOneResources.h.

#define kPalmOneDeviceIDDevice6 'H106'

Device ID reserved for future use.

Definition at line 65 of file palmOneResources.h.

#define kPalmOneDeviceIDDevice7 'H107'

Device ID reserved for future use.

Definition at line 66 of file palmOneResources.h.

#define kPalmOneDeviceIDDevice8 'H108'

Device ID reserved for future use.

Definition at line 67 of file palmOneResources.h.

#define kPalmOneDeviceIDDevice9 'H109'

Device ID reserved for future use.

Definition at line 68 of file palmOneResources.h.

#define kPalmOneDeviceIDDeviceA 'H10A'

Device ID reserved for future use.

Definition at line 69 of file palmOneResources.h.

#define kPalmOneDeviceIDGandalf 'D062'

Device ID for Gandalf.

Definition at line 74 of file palmOneResources.h.

#define kPalmOneDeviceIDGnome 'D061'

Device ID for Gnome.

Definition at line 73 of file palmOneResources.h.

#define kPalmOneDeviceIDLowrider 'D053'

Device ID for Lowrider.

Definition at line 71 of file palmOneResources.h.

#define kPalmOneDeviceIDTorino 'D060'

Device ID for Torino.

Definition at line 72 of file palmOneResources.h.

#define kPalmOneDeviceIDTreo600 'H101'

Device ID for Treo600.

Definition at line 50 of file palmOneResources.h.

#define kPalmOneDeviceIDTreo600Sim 'H201'

Device ID for Treo600 Simulator.

Definition at line 51 of file palmOneResources.h.

#define kPalmOneDeviceIDTreo650 'H102'

Device ID for Treo650.

Definition at line 56 of file palmOneResources.h.

#define kPalmOneDeviceIDTreo650Sim 'H202'

Device ID for Treo650 Simulator.

Definition at line 57 of file palmOneResources.h.

#define kPalmOneDeviceIDTungstenC 'MT64'

Device ID for Tungsten|C.

Definition at line 44 of file palmOneResources.h.

#define kPalmOneDeviceIDTungstenE2 'Zir4'

Device ID for Tungsten E2.

Definition at line 58 of file palmOneResources.h.

#define kPalmOneDeviceIDTungstenT 'Frg1'

Device ID for Tungsten|T.

Definition at line 42 of file palmOneResources.h.

#define kPalmOneDeviceIDTungstenT2 'Frg2'

Device ID for Tungsten|T2.

Definition at line 46 of file palmOneResources.h.

#define kPalmOneDeviceIDTungstenT3 'Arz1'

Device ID for Tungsten|T3.

Definition at line 47 of file palmOneResources.h.

#define kPalmOneDeviceIDTungstenT5 kPalmOneDeviceIDAngus

Device ID for Tungsten|T5.

Definition at line 55 of file palmOneResources.h.

#define kPalmOneDeviceIDTungstenTE 'Cct1'

Device ID for Tungsten|E.

Definition at line 48 of file palmOneResources.h.

#define kPalmOneDeviceIDTungstenW 'atlc'

Device ID for Tungsten|W.

Definition at line 43 of file palmOneResources.h.

#define kPalmOneDeviceIDTungstenX 'TunX'

Device ID for LifeDrive

Definition at line 59 of file palmOneResources.h.

#define kPalmOneDeviceIDVentura 'D052'

Device ID for Ventura.

Definition at line 70 of file palmOneResources.h.

#define kPalmOneDeviceIDZire 'Cubs'

Device ID for Zire.

Definition at line 41 of file palmOneResources.h.

#define kPalmOneDeviceIDZire21 'Zi21'

Device ID for Zire21.

Definition at line 49 of file palmOneResources.h.

#define kPalmOneDeviceIDZire31 'Zi22'

Device ID for Zire31.

Definition at line 52 of file palmOneResources.h.

#define kPalmOneDeviceIDZire71 'Zpth'

Device ID for Zire71.

Definition at line 45 of file palmOneResources.h.

#define kPalmOneDeviceIDZire72 'Zi72'

Device ID for Zire72.

Definition at line 53 of file palmOneResources.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:07:54 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » sndfilestream

palmOneSndFileStream.h File Reference

Detailed Description

Public 68K include file for sound files stream support for Treo 600 and Treo 650 smartphones.

This header file and associated header files support the specific sound functionality of the Treo smartphones. You should use the Palm OS Sound Manager APIs for most of your work.

Notes: The calling application should always load this library with SysLibLoad() before use, even if it is already open by another application(ie, SysLibFind() returns a valid refnum). When the application is done with the library, it should be unloaded with SysLibRemove(). We do this because there is no good way to synchronize loading and unloading of libraries among multiple applications. It also greatly simplifies internal synchronization.

Definition in file palmOneSndFileStream.h.

Include dependency graph for palmOneSndFileStream.h:

Go to the source code of this file.

Data Structures

  • struct tagSndFileStreamData
    Holds data about a sound file stream. More...
  • struct tagSndFileStreamFileSpec
    Descriptions of the stream file. More...
  • struct tagSndFileStreamHsSoundCommandParam
    SndFileStreamDeviceControl param when cmd == hsSoundLibCreatorID. More...

Defines

  • #define SNDFILESTREAM_TRAP(x) SYS_TRAP( x )
Type and creator of the Sound File Stream library
Used with FtrGet.

  • #define kSndFileStreamLibType sysFileTLibrary
  • #define kSndFileStreamLibCreator 'sfsL'
  • #define kSndFileStreamLibName "SndFileStream-sfsL"
  • #define kSndFileStreamLibVersion sysMakeROMVersion(1, 4, 0, sysROMStageRelease, 20)
Utility macros
These macros take care of opening and closing the sound file stream library in various situations.

  • #define SndFileStreamOpenLibrary(refNum, err)
  • #define SndFileStreamCloseLibrary(refNum, err)
Error codes
These macros take care of opening and closing the sound file stream library in various situations.

  • #define kSndFileStreamLibErrNone errNone
  • #define kSndFileStreamLibErrAlreadyOpen 1
  • #define kSndFileStreamLibErrNotOpen 2
  • #define kSndFileStreamLibErrStillOpen 3
  • #define kSndFileStreamLibErrOutOfMemory 4
  • #define kSndFileStreamLibErrCantOpenFile 5
  • #define kSndFileStreamLibErrUnsupportedFile 6
  • #define kSndFileStreamLibErrCancel 7
  • #define kSndFileStreamLibErrOperationNotSupported 8
Play back sound file stream
Use for playbackCount parameter of tagSndFileStreamData to play back a stream indefinitely.

  • #define kSndFileStreamLibPlaybackForever 0xFFFF
  • #define sndFileStreamNotifyStreamComplete 'StrC'
  • #define sndFileStreamNotifyRecComplete 'RecC'
File Flags
  • #define kSndFileStreamFileSpecFlagVFS (0x0001)
  • #define kSndFileStreamFileSpecFlagFileStream (0x0002)
File stream database types
File stream databases opened using kSndFileStreamFileSpecFlagFileStream.

  • #define kSndFileTypeWAV 'WAVf'
  • #define kSndFileTypeQCP 'QCPf'
  • #define kSndFileTypeAMR 'AMRf'
  • #define kSndFileTypeMP3 'MP3f'
  • #define kSndFileTypeAAC 'AACf'
Library traps
  • #define kSndFileStreamLibTrapVersion (sysLibTrapCustom + 0)
  • #define kSndFileStreamLibTrapCreate (sysLibTrapCustom + 1)
  • #define kSndFileStreamLibTrapOpen (sysLibTrapCustom + 2)
  • #define kSndFileStreamLibTrapClose (sysLibTrapCustom + 3)
  • #define kSndFileStreamLibTrapStart (sysLibTrapCustom + 4)
  • #define kSndFileStreamLibTrapPause (sysLibTrapCustom + 5)
  • #define kSndFileStreamLibTrapStop (sysLibTrapCustom + 6)
  • #define kSndFileStreamLibTrapSeek (sysLibTrapCustom + 7)
  • #define kSndFileStreamLibTrapGetCurrentStreamData (sysLibTrapCustom + 8)
  • #define kSndFileStreamLibTrapDeviceControl (sysLibTrapCustom + 9)
  • #define kSndFileStreamLibTrapSetVolume (sysLibTrapCustom + 10)
  • #define kSndFileStreamLibTrapGetVolume (sysLibTrapCustom + 11)
  • #define kSndFileStreamLibTrapSetPan (sysLibTrapCustom + 12)
  • #define kSndFileStreamLibTrapGetPan (sysLibTrapCustom + 13)
  • #define kSndFileStreamLibTrapUIPlay (sysLibTrapCustom + 14)
  • #define kSndFileStreamLibTrapUIRecord (sysLibTrapCustom + 15)

Typedefs

  • typedef enum tagSndFileFormatEnum SndFileFormatType
  • typedef void * SndFileStreamRef
  • typedef tagSndFileStreamData SndFileStreamData
    Holds data about a sound file stream.
  • typedef tagSndFileStreamData * SndFileStreamDataPtr
    Holds data about a sound file stream.
  • typedef Err(*) SndFileStreamCallbackPtr (SndFileStreamRef stream, SndFileStreamDataPtr streamDataP, Boolean *customDataModified)
  • typedef tagSndFileStreamFileSpec SndFileStreamFileSpec
    Descriptions of the stream file.
  • typedef tagSndFileStreamFileSpec * SndFileStreamFileSpecPtr
    Descriptions of the stream file.
  • typedef tagSndFileStreamHsSoundCommandParam SndFileStreamHsSoundCommandParam
    SndFileStreamDeviceControl param when cmd == hsSoundLibCreatorID.
  • typedef tagSndFileStreamHsSoundCommandParam * SndFileStreamHsSoundCommandParamPtr
    SndFileStreamDeviceControl param when cmd == hsSoundLibCreatorID.

Enumerations

  • enum tagSndFileFormatEnum {
    kSndFileFormatRaw = 0,
    kSndFileFormatWAV,
    kSndFileFormatTreoQCP,
    kSndFileFormatTreoAMR,
    kSndFileFormatMP3,
    kSndFileFormatAAC
    }

Functions

  • Err SndFileStreamLibOpen (UInt16 libRefNum)(sysLibTrapOpen)
  • Err SndFileStreamLibClose (UInt16 libRefNum)(sysLibTrapClose)
  • Err SndFileStreamLibSleep (UInt16 libRefNum)(sysLibTrapSleep)
  • Err SndFileStreamLibWake (UInt16 libRefNum)(sysLibTrapWake)
  • Err SndFileStreamLibVersion (UInt16 libRefNum, UInt32 *versionP)(kSndFileStreamLibTrapVersion)
  • Err SndFileStreamCreate (UInt16 libRefNum, SndFileStreamRef *streamP, SndFileStreamDataPtr streamDataP, SndFileStreamFileSpecPtr fileSpecP, SndFileStreamCallbackPtr callbackP)(kSndFileStreamLibTrapCreate)
  • Err SndFileStreamOpen (UInt16 libRefNum, SndFileStreamRef *streamP, SndFileStreamDataPtr streamDataP, SndFileStreamFileSpecPtr fileSpecP, SndFileStreamCallbackPtr callbackP)(kSndFileStreamLibTrapOpen)
  • Err SndFileStreamClose (UInt16 libRefNum, SndFileStreamRef stream)(kSndFileStreamLibTrapClose)
  • Err SndFileStreamStart (UInt16 libRefNum, SndFileStreamRef stream)(kSndFileStreamLibTrapStart)
  • Err SndFileStreamPause (UInt16 libRefNum, SndFileStreamRef stream, Boolean pause)(kSndFileStreamLibTrapPause)
  • Err SndFileStreamStop (UInt16 libRefNum, SndFileStreamRef stream)(kSndFileStreamLibTrapStop)
  • Err SndFileStreamSeek (UInt16 libRefNum, SndFileStreamRef stream, UInt32 seekMilliseconds)(kSndFileStreamLibTrapSeek)
  • Err SndFileStreamGetCurrentStreamData (UInt16 libRefNum, SndFileStreamRef stream, SndFileStreamDataPtr streamDataP)(kSndFileStreamLibTrapGetCurrentStreamData)
  • Err SndFileStreamDeviceControl (UInt16 libRefNum, SndFileStreamRef stream, Int32 cmd, void *param, Int32 size)(kSndFileStreamLibTrapDeviceControl)
  • Err SndFileStreamSetVolume (UInt16 libRefNum, SndFileStreamRef stream, Int32 volume)(kSndFileStreamLibTrapSetVolume)
  • Err SndFileStreamGetVolume (UInt16 libRefNum, SndFileStreamRef stream, Int32 *volumeP)(kSndFileStreamLibTrapGetVolume)
  • Err SndFileStreamSetPan (UInt16 libRefNum, SndFileStreamRef stream, Int32 panPosition)(kSndFileStreamLibTrapSetPan)
  • Err SndFileStreamGetPan (UInt16 libRefNum, SndFileStreamRef stream, Int32 *panPositionP)(kSndFileStreamLibTrapGetPan)
  • Err SndFileStreamUIPlay (UInt16 libRefNum, SndFileStreamFileSpecPtr fileSpecP, Boolean allowRerecord)(kSndFileStreamLibTrapUIPlay)
  • Err SndFileStreamUIRecord (UInt16 libRefNum, SndFileStreamDataPtr streamDataP, SndFileStreamFileSpecPtr fileSpecP, Boolean allowRerecord)(kSndFileStreamLibTrapUIRecord)

Define Documentation

#define kSndFileStreamFileSpecFlagFileStream (0x0002)

File stream

Definition at line 280 of file palmOneSndFileStream.h.

#define kSndFileStreamFileSpecFlagVFS (0x0001)

VFS file

Definition at line 279 of file palmOneSndFileStream.h.

#define kSndFileStreamLibCreator 'sfsL'

Creator ID of the sound file stream library.

Definition at line 60 of file palmOneSndFileStream.h.

#define kSndFileStreamLibErrAlreadyOpen 1

Definition at line 146 of file palmOneSndFileStream.h.

#define kSndFileStreamLibErrCancel 7

Definition at line 152 of file palmOneSndFileStream.h.

#define kSndFileStreamLibErrCantOpenFile 5

Definition at line 150 of file palmOneSndFileStream.h.

#define kSndFileStreamLibErrNone errNone

Definition at line 145 of file palmOneSndFileStream.h.

#define kSndFileStreamLibErrNotOpen 2

Definition at line 147 of file palmOneSndFileStream.h.

#define kSndFileStreamLibErrOperationNotSupported 8

Definition at line 153 of file palmOneSndFileStream.h.

#define kSndFileStreamLibErrOutOfMemory 4

Definition at line 149 of file palmOneSndFileStream.h.

#define kSndFileStreamLibErrStillOpen 3

Definition at line 148 of file palmOneSndFileStream.h.

#define kSndFileStreamLibErrUnsupportedFile 6

Definition at line 151 of file palmOneSndFileStream.h.

#define kSndFileStreamLibName "SndFileStream-sfsL"

Name of the sound file stream library.

Definition at line 61 of file palmOneSndFileStream.h.

#define kSndFileStreamLibPlaybackForever 0xFFFF

Definition at line 163 of file palmOneSndFileStream.h.

#define kSndFileStreamLibTrapClose (sysLibTrapCustom + 3)

Definition at line 317 of file palmOneSndFileStream.h.

#define kSndFileStreamLibTrapCreate (sysLibTrapCustom + 1)

Definition at line 315 of file palmOneSndFileStream.h.

#define kSndFileStreamLibTrapDeviceControl (sysLibTrapCustom + 9)

Definition at line 323 of file palmOneSndFileStream.h.

#define kSndFileStreamLibTrapGetCurrentStreamData (sysLibTrapCustom + 8)

Definition at line 322 of file palmOneSndFileStream.h.

#define kSndFileStreamLibTrapGetPan (sysLibTrapCustom + 13)

Definition at line 327 of file palmOneSndFileStream.h.

#define kSndFileStreamLibTrapGetVolume (sysLibTrapCustom + 11)

Definition at line 325 of file palmOneSndFileStream.h.

#define kSndFileStreamLibTrapOpen (sysLibTrapCustom + 2)

Definition at line 316 of file palmOneSndFileStream.h.

#define kSndFileStreamLibTrapPause (sysLibTrapCustom + 5)

Definition at line 319 of file palmOneSndFileStream.h.

#define kSndFileStreamLibTrapSeek (sysLibTrapCustom + 7)

Definition at line 321 of file palmOneSndFileStream.h.

#define kSndFileStreamLibTrapSetPan (sysLibTrapCustom + 12)

Definition at line 326 of file palmOneSndFileStream.h.

#define kSndFileStreamLibTrapSetVolume (sysLibTrapCustom + 10)

Definition at line 324 of file palmOneSndFileStream.h.

#define kSndFileStreamLibTrapStart (sysLibTrapCustom + 4)

Definition at line 318 of file palmOneSndFileStream.h.

#define kSndFileStreamLibTrapStop (sysLibTrapCustom + 6)

Definition at line 320 of file palmOneSndFileStream.h.

#define kSndFileStreamLibTrapUIPlay (sysLibTrapCustom + 14)

Definition at line 328 of file palmOneSndFileStream.h.

#define kSndFileStreamLibTrapUIRecord (sysLibTrapCustom + 15)

Definition at line 329 of file palmOneSndFileStream.h.

#define kSndFileStreamLibTrapVersion (sysLibTrapCustom + 0)

Definition at line 314 of file palmOneSndFileStream.h.

#define kSndFileStreamLibType sysFileTLibrary

Type of the sound file stream library.

Definition at line 59 of file palmOneSndFileStream.h.

#define kSndFileStreamLibVersion sysMakeROMVersion(1, 4, 0, sysROMStageRelease, 20)

Version of the sound file stream library.

Definition at line 62 of file palmOneSndFileStream.h.

#define kSndFileTypeAAC 'AACf'

AAC file -> kSndFileFormatAAC

Definition at line 294 of file palmOneSndFileStream.h.

#define kSndFileTypeAMR 'AMRf'

AMR file -> kSndFileFormatTreoAMR.

Definition at line 292 of file palmOneSndFileStream.h.

#define kSndFileTypeMP3 'MP3f'

MP3 file -> kSndFileFormatMP3

Definition at line 293 of file palmOneSndFileStream.h.

#define kSndFileTypeQCP 'QCPf'

QCELP file -> kSndFileFormatTreoQCP.

Definition at line 291 of file palmOneSndFileStream.h.

#define kSndFileTypeWAV 'WAVf'

WAV file -> kSndFileFormatWAV .

Definition at line 290 of file palmOneSndFileStream.h.

#define SNDFILESTREAM_TRAP ( x ) SYS_TRAP( x )

Helper macro.

Definition at line 46 of file palmOneSndFileStream.h.

#define SndFileStreamCloseLibrary | ( | refNum,
 |  | err | )

Value:

{                                                           \
        if ( sysInvalidRefNum == (refNum) )                     \
        {                                                       \
            (err) = sysErrParamErr;                             \
        }                                                       \
        else                                                    \
        {                                                       \
            (err) = SndFileStreamLibClose( (refNum) );          \
            if ( errNone == (err) )                             \
            {                                                   \
                (err) = SysLibRemove( (refNum) );               \
                (refNum) = sysInvalidRefNum;                    \
            }                                                   \
            else if ( kSndFileStreamLibErrStillOpen == (err) )  \
            {                                                   \
                (err) = errNone;                                \
            }                                                   \
        }                                                       \
    }

Definition at line 115 of file palmOneSndFileStream.h.

#define sndFileStreamNotifyRecComplete 'RecC'

Notification broadcast by SndFileStream when it exceeds the recording limit. Currently this notification is handled by the libary itself, for example, stop the recording stream. The application should NOT expect to recieve this notification even it register it. Instead it should expect sndFileStreamNotifyStreamComplete notification to indicate that the recording limit has been reached.

Definition at line 186 of file palmOneSndFileStream.h.

#define sndFileStreamNotifyStreamComplete 'StrC'

Notification broadcast by SndFileStream when it has completed playing a stream. This is an alternative to using callbacks in the case where SndFileStream is used by an ARM app (eg. Blazer) or by a 68K app.

In playback mode, it means that the file has completely played. In recording mode, it means that it reaches the recording limit.

Definition at line 175 of file palmOneSndFileStream.h.

#define SndFileStreamOpenLibrary | ( | refNum,
 |  | err | )

Value:

{                                                           \
        Boolean loaded;                                         \
                                                                \
        loaded = false;                                         \
        (err) = SysLibFind( kSndFileStreamLibName, &(refNum) ); \
        if ( sysErrLibNotFound == (err) )                       \
        {                                                       \
            (err) = SysLibLoad( kSndFileStreamLibType,          \
                kSndFileStreamLibCreator, &(refNum) );          \
            loaded = true;                                      \
        }                                                       \
                                                                \
        if ( errNone == (err) )                                 \
        {                                                       \
            (err) = SndFileStreamLibOpen( (refNum) );           \
            if ( errNone != (err) )                             \
            {                                                   \
                if ( loaded )                                   \
                {                                               \
                    SysLibRemove( (refNum) );                   \
                }                                               \
                                                                \
                (refNum) = sysInvalidRefNum;                    \
            }                                                   \
        }                                                       \
        else                                                    \
        {                                                       \
            (refNum) = sysInvalidRefNum;                        \
        }                                                       \
    }

Definition at line 84 of file palmOneSndFileStream.h.

Typedef Documentation

typedef enum tagSndFileFormatEnum SndFileFormatType

Sound file format

The sound file format of the stream.

typedef Err(*) SndFileStreamCallbackPtr(SndFileStreamRef stream, SndFileStreamDataPtr streamDataP, Boolean *customDataModified)

Callback function passed when calling SndFileStreamCreate() and SndFileStreamOpen(). It will be called during playback and recording.

Parameters:
stream,: IN: Reference to stream returned by SndFileStreamCreate()/SndFileStreamOpen().
streamDataP,: IN:
See also:
SndFileStreamData
Parameters:
customDataModified,: OUT: If true, custom data has been modified.
Return values:
Err Error code.

Definition at line 253 of file palmOneSndFileStream.h.

typedef struct tagSndFileStreamData SndFileStreamData

Holds data about a sound file stream.

typedef struct tagSndFileStreamData * SndFileStreamDataPtr

Holds data about a sound file stream.

typedef struct tagSndFileStreamFileSpec SndFileStreamFileSpec

Descriptions of the stream file.

Used with SndFileStreamCreate()/SndFileStreamOpen()

typedef struct tagSndFileStreamFileSpec * SndFileStreamFileSpecPtr

Descriptions of the stream file.

Used with SndFileStreamCreate()/SndFileStreamOpen()

typedef struct tagSndFileStreamHsSoundCommandParam SndFileStreamHsSoundCommandParam

SndFileStreamDeviceControl param when cmd == hsSoundLibCreatorID.

Contains hsFormat/hsCmd pair to be used with PmSndStream() calls.

typedef struct tagSndFileStreamHsSoundCommandParam * SndFileStreamHsSoundCommandParamPtr

SndFileStreamDeviceControl param when cmd == hsSoundLibCreatorID.

Contains hsFormat/hsCmd pair to be used with PmSndStream() calls.

typedef void* SndFileStreamRef

Reference to sound file stream returned by SndFileStreamCreate()/Open()

Definition at line 206 of file palmOneSndFileStream.h.

Enumeration Type Documentation

enum tagSndFileFormatEnum

Sound file format

The sound file format of the stream.

Enumerator:
kSndFileFormatRaw | Raw bytes.
kSndFileFormatWAV | RIFF-WAVE.
kSndFileFormatTreoQCP | RIFF-QLCM.
kSndFileFormatTreoAMR | Raw RTP packets.
kSndFileFormatMP3 | MP3 format
kSndFileFormatAAC | AAC format

Definition at line 194 of file palmOneSndFileStream.h.

00195 {
00196     kSndFileFormatRaw = 0,  /**<Raw bytes. */
00197     kSndFileFormatWAV,      /**<RIFF-WAVE. */
00198     kSndFileFormatTreoQCP,  /**<RIFF-QLCM. */
00199     kSndFileFormatTreoAMR,  /**<Raw RTP packets. */
00200     kSndFileFormatMP3,      /**<MP3 format */
00201     kSndFileFormatAAC       /**<AAC format */
00202 }

Function Documentation

Err SndFileStreamClose | ( | UInt16 | libRefNum,
 |  | SndFileStreamRef | stream
 | ) |  |

Close the reference to the file stream.

Parameters:
libRefNum,: IN: Library reference number
stream,: IN: Reference to the sound stream, returned when creating/opening file stream.
Return values:
Err Error code.

Err SndFileStreamCreate | ( | UInt16 | libRefNum,
 |  | SndFileStreamRef * | streamP,
 |  | SndFileStreamDataPtr | streamDataP,
 |  | SndFileStreamFileSpecPtr | fileSpecP,
 |  | SndFileStreamCallbackPtr | callbackP
 | ) |  |

Create a new sound file stream.

Parameters:
libRefNum,: IN: Library reference number
streamP,: OUT: Reference to the created sound stream
streamDataP,: IN:
See also:
SndFileStreamData
Parameters:
fileSpecP,: IN: Description of the file to be created
callbackP,: IN: User defined callback function, to be called on playback/recording.
Return values:
Err Error code.

Err SndFileStreamDeviceControl | ( | UInt16 | libRefNum,
 |  | SndFileStreamRef | stream,
 |  | Int32 | cmd,
 |  | void * | param,
 |  | Int32 | size
 | ) |  |

Control device when streaming.

Parameters:
libRefNum,: IN: Library reference number
stream,: IN: Reference to the sound stream, returned when creating/opening stream.
cmd,: IN: No definition.
param,: IN: No definition.
size,: IN: No definition.
Return values:
Err Error code.

Err SndFileStreamGetCurrentStreamData | ( | UInt16 | libRefNum,
 |  | SndFileStreamRef | stream,
 |  | SndFileStreamDataPtr | streamDataP
 | ) |  |

Get streaming data.

Parameters:
libRefNum,: IN: Library reference number
stream,: IN: Reference to the sound stream, returned when creating/opening stream.
streamDataP,: OUT:
See also:
SndFileStreamData
Return values:
Err Error code.

Err SndFileStreamGetPan | ( | UInt16 | libRefNum,
 |  | SndFileStreamRef | stream,
 |  | Int32 * | panPositionP
 | ) |  |

Get stereo balance. See SndStreamGetPan() documented under Palm OS Sound Manager API.

Parameters:
libRefNum,: IN: Library reference number
stream,: IN: Reference to the sound stream.
panPositionP,: OUT: Range [-1024, 1024]
Return values:
Err Error code.

Err SndFileStreamGetVolume | ( | UInt16 | libRefNum,
 |  | SndFileStreamRef | stream,
 |  | Int32 * | volumeP
 | ) |  |

See SndStreamGetVolume() documented under Palm OS Sound Manager API.

Parameters:
libRefNum,: IN: Library reference number
stream,: IN: Reference to the sound stream, returned when creating/opening stream.
volumeP,: OUT: Range 0 - 32k. See Palm OS SoundMgr API documentation for more details.
Return values:
Err Error code.

Err SndFileStreamLibClose ( UInt16 libRefNum )

Closes the Sound File Stream library.

Parameters:
libRefNum,: IN: Library reference number
Return values:
Err Error code.

Err SndFileStreamLibOpen ( UInt16 libRefNum )

Opens the Sound File Stream library.

Parameters:
libRefNum,: IN: Library reference number
Return values:
Err Error code.

Err SndFileStreamLibSleep ( UInt16 libRefNum )

Standard library sleep routine.

Parameters:
libRefNum,: IN: Library reference number
Return values:
Err Error code.

Err SndFileStreamLibVersion | ( | UInt16 | libRefNum,
 |  | UInt32 * | versionP
 | ) |  |

Retrieve the library version number.

Parameters:
libRefNum,: IN: Library reference number
*versionP,: OUT: Library version number.
Return values:
Err Error code.

Err SndFileStreamLibWake ( UInt16 libRefNum )

Standard library wake routine.

Parameters:
libRefNum,: IN: Library reference number
Return values:
Err Error code.

Err SndFileStreamOpen | ( | UInt16 | libRefNum,
 |  | SndFileStreamRef * | streamP,
 |  | SndFileStreamDataPtr | streamDataP,
 |  | SndFileStreamFileSpecPtr | fileSpecP,
 |  | SndFileStreamCallbackPtr | callbackP
 | ) |  |

Open an already existing sound file stream.

Parameters:
libRefNum,: IN: Library reference number
streamP,: OUT: Reference to the opened sound stream.
streamDataP,: IN:
See also:
SndFileStreamData
Parameters:
fileSpecP,: IN: Description of the file to be opened.
callbackP,: IN: User defined callback function, to be called on playback/recording.
Return values:
Err Error code.

Err SndFileStreamPause | ( | UInt16 | libRefNum,
 |  | SndFileStreamRef | stream,
 |  | Boolean | pause
 | ) |  |

Pause sound streaming.

Parameters:
libRefNum,: IN: Library reference number
stream,: IN: Reference to the sound stream, returned when creating/opening stream.
pause,: IN: If true, pause. Otherwise, resume.
Return values:
Err Error code.

Err SndFileStreamSeek | ( | UInt16 | libRefNum,
 |  | SndFileStreamRef | stream,
 |  | UInt32 | seekMilliseconds
 | ) |  |

Move the pointer to the stream to a user-defined offset.

Parameters:
libRefNum,: IN: Library reference number
stream,: IN: Reference to the sound stream, returned when creating/opening stream.
seekMilliseconds IN: Offset in milliseconds.
Return values:
Err Error code.

Err SndFileStreamSetPan | ( | UInt16 | libRefNum,
 |  | SndFileStreamRef | stream,
 |  | Int32 | panPosition
 | ) |  |

Set stereo balance. See SndStreamSetPan() documented under Palm OS Sound Manager API.

Parameters:
libRefNum,: IN: Library reference number
stream,: IN: Reference to the sound stream.
panPosition,: IN: Range [-1024, 1024]
Return values:
Err Error code.

Err SndFileStreamSetVolume | ( | UInt16 | libRefNum,
 |  | SndFileStreamRef | stream,
 |  | Int32 | volume
 | ) |  |

See SndStreamSetVolume() documented under Palm OS Sound Manager API.

Parameters:
libRefNum,: IN: Library reference number
stream,: IN: Reference to the sound stream, returned when creating/opening stream.
volume,: IN: No definition.
Return values:
Err Error code.

Err SndFileStreamStart | ( | UInt16 | libRefNum,
 |  | SndFileStreamRef | stream
 | ) |  |

Start streaming sound into file.

Parameters:
libRefNum,: IN: Library reference number
stream,: IN: Reference to the sound stream, returned when creating/opening stream.
Return values:
Err Error code.

Err SndFileStreamStop | ( | UInt16 | libRefNum,
 |  | SndFileStreamRef | stream
 | ) |  |

Stop sound streaming.

Parameters:
libRefNum,: IN: Library reference number
stream,: IN: Reference to the sound stream, returned when creating/opening stream.
Return values:
Err Error code.

Err SndFileStreamUIPlay | ( | UInt16 | libRefNum,
 |  | SndFileStreamFileSpecPtr | fileSpecP,
 |  | Boolean | allowRerecord
 | ) |  |

Play sound stream with UI

Parameters:
libRefNum,: IN: Library reference number
fileSpecP,: IN: Pointer to the sound file to be played.
allowRerecord,: IN: No definition.
Return values:
Err Error code.

Err SndFileStreamUIRecord | ( | UInt16 | libRefNum,
 |  | SndFileStreamDataPtr | streamDataP,
 |  | SndFileStreamFileSpecPtr | fileSpecP,
 |  | Boolean | allowRerecord
 | ) |  |

Record sound stream with UI

Parameters:
libRefNum,: IN: Library reference number
streamDataP,: IN: Stream data to be used for recording.
fileSpecP,: IN: Pointer to the sound file to be recorded.
allowRerecord,: IN: No definition.
Return values:
Err Error code.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:07:55 2008 for Palm API Guide


Header Files » Incs » 68k » system

palmOneStatusBar.h File Reference

Detailed Description

Public common header file for palmOne defined Status Bar library.

Version:
1.0
This file contains the function prototypes and constants for the palmOne Status Bar Library

Definition in file palmOneStatusBar.h.

Include dependency graph for palmOneStatusBar.h:

Go to the source code of this file.

Defines

Library Constants
  • #define palmOneStatusBarLibName "StatusBarMgrLib"
  • #define palmOneStatusBarLibCreator 'sBar'
  • #define palmOneStatusBarLibType sysFileTLibrary
  • #define palmOneStatusBarFtrNumVersion (0)
Error Codes
  • #define palmOneStatusBarErrorClass (appErrorClass | 0x0900)
  • #define palmOneStatusBarErrNoStatusBar (palmOneStatusBarErrorClass | 1)
  • #define palmOneStatusBarErrInvalidSelector (palmOneStatusBarErrorClass | 2)
  • #define palmOneStatusBarErrInputWindowOpen (palmOneStatusBarErrorClass | 3)
  • #define palmOneStatusBarErrBadParam (palmOneStatusBarErrorClass | 101)
  • #define palmOneStatusBarErrInvalidState (palmOneStatusBarErrorClass | 102)
Function Traps
  • #define kPalmOneStatusBarMgrLibTrapOpen sysLibTrapOpen
  • #define kPalmOneStatusBarMgrLibTrapClose sysLibTrapClose
  • #define kPalmOneStatusBarMgrLibGetAttribute (sysLibTrapCustom)
  • #define kPalmOneStatusBarMgrLibHide (sysLibTrapCustom + 1)
  • #define kPalmOneStatusBarMgrLibShow (sysLibTrapCustom + 2)

Typedefs

  • typedef enum PalmOneStatAttrTypeTag PalmOneStatAttrType

Enumerations

  • enum PalmOneStatAttrTypeTag {
    palmOneStatusBarAttrExists = 0,
    palmOneStatusBarAttrBarVisible,
    palmOneStatusBarAttrDimension
    }

Functions

  • Err PalmOneStatusBarLibOpen (UInt16 refnum)
    Standard open library routine.
  • Err PalmOneStatusBarLibClose (UInt16 refnum)
    Standard close library routine.
  • Err PalmOneStatusBarGetAttribute (UInt16 refnum, PalmOneStatAttrType selector, UInt32 *dataP)
    Retrieve the current state of the status bar.
  • Err PalmOneStatusBarHide (UInt16 refnum)
    Hide the status bar from the bottom of the screen.
  • Err PalmOneStatusBarShow (UInt16 refnum)
    Unhide/show the status bar at the bottom of the screen.

Define Documentation

#define kPalmOneStatusBarMgrLibGetAttribute (sysLibTrapCustom)

Definition at line 84 of file palmOneStatusBar.h.

#define kPalmOneStatusBarMgrLibHide (sysLibTrapCustom + 1)

Definition at line 85 of file palmOneStatusBar.h.

#define kPalmOneStatusBarMgrLibShow (sysLibTrapCustom + 2)

Definition at line 86 of file palmOneStatusBar.h.

#define kPalmOneStatusBarMgrLibTrapClose sysLibTrapClose

Definition at line 83 of file palmOneStatusBar.h.

#define kPalmOneStatusBarMgrLibTrapOpen sysLibTrapOpen

Definition at line 82 of file palmOneStatusBar.h.

#define palmOneStatusBarErrBadParam (palmOneStatusBarErrorClass | 101)

Definition at line 62 of file palmOneStatusBar.h.

#define palmOneStatusBarErrInputWindowOpen (palmOneStatusBarErrorClass | 3)

Definition at line 61 of file palmOneStatusBar.h.

#define palmOneStatusBarErrInvalidSelector (palmOneStatusBarErrorClass | 2)

Definition at line 60 of file palmOneStatusBar.h.

#define palmOneStatusBarErrInvalidState (palmOneStatusBarErrorClass | 102)

Definition at line 63 of file palmOneStatusBar.h.

#define palmOneStatusBarErrNoStatusBar (palmOneStatusBarErrorClass | 1)

Definition at line 59 of file palmOneStatusBar.h.

#define palmOneStatusBarErrorClass (appErrorClass | 0x0900)

Definition at line 58 of file palmOneStatusBar.h.

#define palmOneStatusBarFtrNumVersion (0)

Version of the currently supported features

Definition at line 50 of file palmOneStatusBar.h.

#define palmOneStatusBarLibCreator 'sBar'

StatusBar library creator ID

Definition at line 48 of file palmOneStatusBar.h.

#define palmOneStatusBarLibName "StatusBarMgrLib"

StatusBar library name

Definition at line 47 of file palmOneStatusBar.h.

#define palmOneStatusBarLibType sysFileTLibrary

Default library type

Definition at line 49 of file palmOneStatusBar.h.

Typedef Documentation

typedef enum PalmOneStatAttrTypeTag PalmOneStatAttrType

Status Bar Attributes

Enumeration Type Documentation

enum PalmOneStatAttrTypeTag

Status Bar Attributes

Enumerator:
palmOneStatusBarAttrExists | device supports the status bar
palmOneStatusBarAttrBarVisible | status bar is visible
palmOneStatusBarAttrDimension | bounds of status bar window

Definition at line 69 of file palmOneStatusBar.h.

00070 {
00071     palmOneStatusBarAttrExists     = 0,         /**< device supports the status bar */
00072     palmOneStatusBarAttrBarVisible,             /**< status bar is visible */
00073     palmOneStatusBarAttrDimension               /**< bounds of status bar window */
00074 } PalmOneStatAttrType;

Function Documentation

Err PalmOneStatusBarGetAttribute | ( | UInt16 | refnum,
 |  | PalmOneStatAttrType | selector,
 |  | UInt32 * | dataP
 | ) |  |

Retrieve the current state of the status bar.

Parameters:
refnum,: IN: Library reference number
selector,: IN: Attribute selector (dimension or status)
*dataP,: IN: Pointer to the returned attribute value.
Returns:
Error code.

Err PalmOneStatusBarHide ( UInt16 refnum )

Hide the status bar from the bottom of the screen.

Parameters:
refnum,: IN: Library reference number
Returns:
Error code.

Err PalmOneStatusBarLibClose ( UInt16 refnum )

Standard close library routine.

Parameters:
refnum,: IN: Library reference number
Returns:
Error code.

Err PalmOneStatusBarLibOpen ( UInt16 refnum )

Standard open library routine.

Parameters:
refnum,: IN: Library reference number
Returns:
Error code.

Err PalmOneStatusBarShow ( UInt16 refnum )

Unhide/show the status bar at the bottom of the screen.

Parameters:
refnum,: IN: Library reference number
Returns:
Error code.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:07:55 2008 for Palm API Guide


Header Files » Incs » common » system

palmOneSystemCommon.h File Reference

Detailed Description

This is the common public header for palmOne system definitions.

Definition in file palmOneSystemCommon.h.

Go to the source code of this file.

Defines

  • #define sysMakeLibAPIVersion(major, minor)
  • #define sysGetLibAPIVersionMajor(libVer) (((UInt16)((libVer) >> 16)) & 0x0FFFF)
  • #define sysGetLibAPIVersionMinor(libVer) (((UInt16)(libVer)) & 0x0FFFF)

Define Documentation

#define sysGetLibAPIVersionMajor ( libVer ) (((UInt16)((libVer) >> 16)) & 0x0FFFF)

Definition at line 34 of file palmOneSystemCommon.h.

#define sysGetLibAPIVersionMinor ( libVer ) (((UInt16)(libVer)) & 0x0FFFF)

Definition at line 35 of file palmOneSystemCommon.h.

#define sysMakeLibAPIVersion | ( | major,
 |  | minor | )

Value:

(                                                   \
        (((UInt32)((UInt16)(major) & 0x0FFFF)) << 16) |     \
        (((UInt32)((UInt16)(minor) & 0x0FFFF)))             \
        )

Definition at line 24 of file palmOneSystemCommon.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:07:55 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » vmfont

palmOneVMFontLib.h File Reference

Detailed Description

Defines APIs and structures for the Palm VersaMail Font Picker / Font Manager Service which lets users get / set font characteristics.

Version:
1.0

Definition in file palmOneVMFontLib.h.

Include dependency graph for palmOneVMFontLib.h:

Go to the source code of this file.

Defines

  • #define VMFONTLIB_TRAP(trapNum) SYS_TRAP( trapNum )

Functions

  • Err VMFontOpen (UInt16 libRefNum, UInt32 *clientContextP)
    This function should be called prior to calling the other Font Picker functions.
  • Err VMFontClose (UInt16 libRefNum, UInt32 clientContext)
    This function should be called after your application has finished with the Font Picker library.
  • Err VMFontVersion (UInt16 libRefNum, UInt32 *versionP)
  • UInt8 VMFontGetFont (UInt16 libRefNum, const VMFontPtr fontP)
  • UInt8 VMFontGetFontByID (UInt16 libRefNum, VMFontPtr targetP, UInt8 fontID)
  • Boolean VMFontExists (UInt16 libRefNum, const VMFontPtr fontP)
  • void VMFontToString (UInt16 libRefNum, const VMFontPtr fontP, char *stringP)
  • void VMFontCountStyleAndSize (UInt16 libRefNum, VMFontFace face, Int8 *sizeP, Int8 *styleP)
  • void InitFontUI (UInt16 libRefNum)
  • Boolean DoFontDialog (UInt16 libRefNum, UInt8 *fontIDP, UInt8 oldFontID)
  • void VMFontClearCache (UInt16 libRefNum)
  • void SetFontUIRules (UInt16 libRefNum, VMFontUIRules fontRules)
    Currently the only controllable UI components are.

Define Documentation

#define VMFONTLIB_TRAP ( trapNum ) SYS_TRAP( trapNum )

Definition at line 29 of file palmOneVMFontLib.h.

Function Documentation

Boolean DoFontDialog | ( | UInt16 | libRefNum,
 |  | UInt8 * | fontIDP,
 |  | UInt8 | oldFontID
 | ) |  |

Popup the font picker dialog, and let the user pick a font from the list. Once the user taps OK, the selected font id will be copied into the target parameter.

Parameters:
libRefNum,: IN: Reference number of the Font Picker library.
fontIDP,: OUT: fontID that user has selected.
oldFontID : IN: The font picker will use this font to pre populate the font list. This is very useful when you have a previously saved font in the preference that you want to use when popping up the dialog. If no saved preference is used, then you can always pass in stdFont as the argument.
Return values:
Boolean True if user tapped OK false if user selected cancel

void InitFontUI ( UInt16 libRefNum )

Initialize the font picker UI internal data structure. Please note that it is very important that this function is called before any Font picker specific functions are called.

Parameters:
libRefNum,: IN: Reference number of the Font Picker library.
Return values:
Nothing

void SetFontUIRules | ( | UInt16 | libRefNum,
 |  | VMFontUIRules | fontRules
 | ) |  |

Currently the only controllable UI components are.

Define the UI rules, e.g.: hide style picker, do not show the style picker, show only small fonts, etc.

Components visibility controls

  • Font face picker: true/false
  • Font style picker: true/false
  • Font size picker: true/false List items controls
  • Font Size: allSize, smallFonts, largeFonts
  • Font Style: allStyle, plainOnly

Parameters:
libRefNum,: IN:Reference number of the Font Picker library.
fontRules,: IN:fontRules that need to be applied
Return values:
Nothing
 VMFontUIRules rules;
 UInt8 myFontID;
 UInt8 oldFontID;

 // let's hide style drop down list, and only display small fonts
 //(size 6 if available and size 9 fonts)
 rules.fontFaceVisible = true;
 rules.fontSizeVisible = true;
 rules.fontStyleVisible = true;
 rules.sizeRule = smallFonts;
 rules.styleRule = allStyle;

 InitFontUI( libRefNum );
 SetFontUIRules( libRefNum, rules ); // apply the rules
 if  (DoFontDialog( libRefNum, &myFontID, oldFontID ))
 {
    // do something with the font
 }
 else
 {
    // handle the case when user cancels out of the font picker UI
 }

void VMFontClearCache ( UInt16 libRefNum )

Clear the interal cache of the font library

Parameters:
libRefNum,: IN: library reference number.

Err VMFontClose | ( | UInt16 | libRefNum,
 |  | UInt32 | clientContext
 | ) |  |

This function should be called after your application has finished with the Font Picker library.

Closes the Font Picker library and perform cleanup.

Parameters:
libRefNum,: IN: Reference number of the Font Picker library.
clientContext,: IN: Library's client context number got during open.
Return values:
Err The error code returned from the library. If this is errNone, the function was sucessful.
 err = VMFontClose(fontPickerLibRefNum, context);

See also:
VMFontOpen

void VMFontCountStyleAndSize | ( | UInt16 | libRefNum,
 |  | VMFontFace | face,
 |  | Int8 * | sizeP,
 |  | Int8 * | styleP
 | ) |  |

Given a font face, find out how many size/styles were associated with it.

Parameters:
libRefNum,: IN: Reference number of the Font Picker library.
face,: IN: the font face we need details about.
sizeP,: OUT: contains total sizes for the font face
styleP,: OUT: contains total styles for the font face
Return values:
Nothing

Boolean VMFontExists | ( | UInt16 | libRefNum,
 |  | const VMFontPtr | fontP
 | ) |  |

Check to see if the specified font exists in the database.

Parameters:
libRefNum,: IN: Reference number of the Font Picker library.
fontP,: IN: the font characteristics we want to check.
Return values:
Boolean True if the font exists in the database, false otherwise.
 MemHandle handle;
 VMFontPtr fontP;
 Boolean exists = false;

 handle = MemHandleNew(sizeof( VMFontType ));
 fontP = (VMFontPtr) MemHandleLock(handle);

 fontP->face = segoe;
 fontP->size = size6;
 fontP->style = bold;

 exists = VMFontExists( gRefNum, fontP );

 MemHandleUnlock(handle);
 MemHandleFree(handle);

See also:
VMFontGetFont

UInt8 VMFontGetFont | ( | UInt16 | libRefNum,
 |  | const VMFontPtr | fontP
 | ) |  |

Get the font ID based on the given font characteristics. The returned font ID is NOT guaranteed to be always available. Therefore to avoid any error, please make sure that VMFontExists is used whenever a font is needed.

Parameters:
libRefNum,: IN: Reference number of the Font Picker library.
fontP,: IN: the font characteristics.
Return values:
UInt8 The defined font ID
 // get the font ID for gill Sans MT 9 pt Italic
 VMFontPtr fontP = (VMFontPtr) MemPtrNew (sizeof (VMFontType));
 fontP->face = gillSans;
 fontP->size = size6;
 fontP->style = italic;
 UInt8 myFontID = stdFont;
 if (VMFontExists( theRefNum, fontP ))
    {    myFontID = VMFontGetFont( theRefNum, fontP );   }

See also:
VMFontExists

UInt8 VMFontGetFontByID | ( | UInt16 | libRefNum,
 |  | VMFontPtr | targetP,
 |  | UInt8 | fontID
 | ) |  |

Get the Font characteristics based on a saved FontID

Parameters:
libRefNum,: IN: Reference number of the Font Picker library.
targetP,: IN: the font characteristics.
fontID,: IN: the font ID passed in.
Return values:
UInt8 The defined font ID
 UInt8 myOldID;
 UInt8 myFontID;
 MemHandle handle;
 VMFontPtr fontP;

 handle = MemHandleNew(sizeof(VMFontType));
 fontP = (VMFontPtr) MemHandleLock(handle);

 myOldID = GetFontIDFromPrefs(); // assume that we have a funct to get the old ID
 myFontID = VMFontGetFontByID( gRefNum, fontP, myOldID );

Err VMFontOpen | ( | UInt16 | libRefNum,
 |  | UInt32 * | clientContextP
 | ) |  |

This function should be called prior to calling the other Font Picker functions.

Opens the Font Picker library. Does Initialization of library.

Parameters:
libRefNum,: IN: Reference number of the Font Picker library.
clientContextP,: OUT: pointer to variable for returning client context. The client context is used to maintain client-specific data for multiple client support.The value returned here will be used as a parameter for other library functions which require a client context.
Return values:
Err The error code returned from the library. If this is errNone, the function was sucessful.
 UInt16 fontPickerLibRefNum = 0;
 UInt32 context;
 err = SysLibFind(fontPickerLibName, &fontPickerLibRefNum);
 if( err == sysErrLibNotFound )
 {
     err = SysLibLoad(fontPickerType, fontPickerCreatorID, &fontPickerLibRefNum);
         if( !err ) {
             err = VMFontOpen(fontPickerLibRefNum, &context);
         }
 }

See also:
VMFontClose

void VMFontToString | ( | UInt16 | libRefNum,
 |  | const VMFontPtr | fontP,
 |  | char * | stringP
 | ) |  |

Given a font characteristics (defined as VMFontPtr), get the human-readable font description of that font in the form of "<NAME> <SIZE> <STYLE>", e.g. "Gill Sans MT 9 Bold".

Parameters:
libRefNum,: IN: Reference number of the Font Picker library.
fontP,: IN: the font characteristics we want to check.
stringP,: OUT: Pointer to output string buffer.
Return values:
Nothing

Err VMFontVersion | ( | UInt16 | libRefNum,
 |  | UInt32 * | versionP
 | ) |  |

Get the Font Library Version

Parameters:
libRefNum,: IN: Reference number of the Font Picker library.
versionP,: OUT: Pointer to the version number
Return values:
Err Always errNone

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:07:56 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » imaging

PalmPhoto.h File Reference

Include dependency graph for PalmPhoto.h:

Go to the source code of this file.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:07:56 2008 for Palm API Guide


Header Files » Incs » 68k » system

PalmPin.h File Reference

Detailed Description

Public API for the Pen Input Manager Library.

Version:
1.0

Definition in file PalmPin.h.

Include dependency graph for PalmPin.h:

Go to the source code of this file.

Data Structures

  • struct AiaExtentChangedEventDataType

Defines

  • #define aiaExtentChangedData(eventP) ((AiaExtentChangedEventDataType *)(&((eventP)->data.generic)))
Library type and creator
  • #define pinLibType sysFileTLibrary
  • #define pinLibCreator 'pinM'
  • #define pinLibName "PinLib"
  • #define pinFtrNumVersion 0
Pinlet IDs
  • #define pinClassic "Classic"
  • #define pinTriCell "Tri Cell"
  • #define pinStdKeyboard "StdKB"
  • #define pinletStdKbNum "StdKBNum"
  • #define pinletStdKbIntl "StdKBIntl"
PIN Manager Errors
  • #define pinErrorClass (appErrorClass | 0x0A00)
  • #define pinErrInvalidState (pinErrorClass + 1)
  • #define pinErrUnknownID (pinErrorClass + 2)
  • #define pinErrInvalidInputMode (pinErrorClass + 3)
Input area states
  • #define pinInputAreaNone 0
  • #define pinInputAreaShow 1
  • #define pinInputAreaHide 2
  • #define pinInputAreaLegacyMode 3
  • #define pinInputAreaFullScreen 4
Input Modes
  • #define pinInputModeNormal 0
  • #define pinInputModeShift 1
  • #define pinInputModeCapsLock 2
  • #define pinInputModePunctuation 3
  • #define pinInputModeNumeric 4
  • #define pinInputModeExtended 5
  • #define pinInputModeHiragana 6
  • #define pinInputModeKatakana 7
AIA event and notification
  • #define sysNotifyAiaEvent 'Aian'
  • #define AiaExtentChangedEvent 0x5000
Library Traps
  • #define kPinLibTrapOpen sysLibTrapOpen
  • #define kPinLibTrapClose sysLibTrapClose
  • #define kPinLibTrapPinGetInputAreaState (sysLibTrapCustom + 17)
  • #define kPinLibTrapPinSetInputAreaState (sysLibTrapCustom + 18)
  • #define kPinLibTrapPinResetInputState (sysLibTrapCustom + 24)
  • #define kPinLibTrapPinGetCurrentPinletID (sysLibTrapCustom + 20)
  • #define kPinLibTrapPinSwitchToPinlet (sysLibTrapCustom + 21)
  • #define kPinLibTrapPinGetInputMode (sysLibTrapCustom + 23)
  • #define kPinLibTrapPinSetInputMode (sysLibTrapCustom + 22)
  • #define kPinLibTrapPINShowReferenceDialog (sysLibTrapCustom + 25)

Functions

  • Err PinLibOpen (UInt16 refnum)
    Parameters:
    refnum,: IN:

  • Err PinLibClose (UInt16 refnum)
    Parameters:
    refnum,: IN:

  • UInt16 PinGetInputAreaState (UInt16 refnum)
    Parameters:
    refnum,: IN:

  • Err PinSetInputAreaState (UInt16 refnum, UInt16 state)
    Parameters:
    refnum,: IN:

  • void PinResetInputState (UInt16 refnum)
    Parameters:
    refnum,: IN:

  • const char * PinGetCurrentPinletID (UInt16 refnum)
    Parameters:
    refnum,: IN:

  • Err PinSwitchToPinlet (UInt16 refnum, const char *pinletID, UInt16 initialInputMode)
    Parameters:
    refnum,: IN:

  • UInt16 PinGetInputMode (UInt16 refnum)
    Parameters:
    refnum,: IN:

  • void PinSetInputMode (UInt16 refnum, UInt16 inputMode)
    Parameters:
    refnum,: IN:

Define Documentation

#define aiaExtentChangedData ( eventP ) ((AiaExtentChangedEventDataType *)(&((eventP)->data.generic)))

Macro to simplify getting the data out of the event structure.

Example: yDiff = AiaExtentChangedData(eventP)->newDim->extent.y - aiaExtentChangedData(eventP)->oldDim->extent.y;

Definition at line 116 of file PalmPin.h.

#define AiaExtentChangedEvent 0x5000

Definition at line 100 of file PalmPin.h.

#define kPinLibTrapClose sysLibTrapClose

Definition at line 125 of file PalmPin.h.

#define kPinLibTrapOpen sysLibTrapOpen

Definition at line 124 of file PalmPin.h.

#define kPinLibTrapPinGetCurrentPinletID (sysLibTrapCustom + 20)

Definition at line 129 of file PalmPin.h.

#define kPinLibTrapPinGetInputAreaState (sysLibTrapCustom + 17)

Definition at line 126 of file PalmPin.h.

#define kPinLibTrapPinGetInputMode (sysLibTrapCustom + 23)

Definition at line 131 of file PalmPin.h.

#define kPinLibTrapPinResetInputState (sysLibTrapCustom + 24)

Definition at line 128 of file PalmPin.h.

#define kPinLibTrapPinSetInputAreaState (sysLibTrapCustom + 18)

Definition at line 127 of file PalmPin.h.

#define kPinLibTrapPinSetInputMode (sysLibTrapCustom + 22)

Definition at line 132 of file PalmPin.h.

#define kPinLibTrapPINShowReferenceDialog (sysLibTrapCustom + 25)

Definition at line 133 of file PalmPin.h.

#define kPinLibTrapPinSwitchToPinlet (sysLibTrapCustom + 21)

Definition at line 130 of file PalmPin.h.

#define pinClassic "Classic"

Definition at line 49 of file PalmPin.h.

#define pinErrInvalidInputMode (pinErrorClass + 3)

Definition at line 64 of file PalmPin.h.

#define pinErrInvalidState (pinErrorClass + 1)

Definition at line 62 of file PalmPin.h.

#define pinErrorClass (appErrorClass | 0x0A00)

Definition at line 61 of file PalmPin.h.

#define pinErrUnknownID (pinErrorClass + 2)

Definition at line 63 of file PalmPin.h.

#define pinFtrNumVersion 0

Definition at line 41 of file PalmPin.h.

#define pinInputAreaFullScreen 4

Definition at line 76 of file PalmPin.h.

#define pinInputAreaHide 2

Definition at line 74 of file PalmPin.h.

#define pinInputAreaLegacyMode 3

Definition at line 75 of file PalmPin.h.

#define pinInputAreaNone 0

Definition at line 72 of file PalmPin.h.

#define pinInputAreaShow 1

Definition at line 73 of file PalmPin.h.

#define pinInputModeCapsLock 2

Definition at line 86 of file PalmPin.h.

#define pinInputModeExtended 5

Definition at line 89 of file PalmPin.h.

#define pinInputModeHiragana 6

Definition at line 90 of file PalmPin.h.

#define pinInputModeKatakana 7

Definition at line 91 of file PalmPin.h.

#define pinInputModeNormal 0

Definition at line 84 of file PalmPin.h.

#define pinInputModeNumeric 4

Definition at line 88 of file PalmPin.h.

#define pinInputModePunctuation 3

Definition at line 87 of file PalmPin.h.

#define pinInputModeShift 1

Definition at line 85 of file PalmPin.h.

#define pinletStdKbIntl "StdKBIntl"

Definition at line 53 of file PalmPin.h.

#define pinletStdKbNum "StdKBNum"

Definition at line 52 of file PalmPin.h.

#define pinLibCreator 'pinM'

Definition at line 39 of file PalmPin.h.

#define pinLibName "PinLib"

Definition at line 40 of file PalmPin.h.

#define pinLibType sysFileTLibrary

Definition at line 38 of file PalmPin.h.

#define pinStdKeyboard "StdKB"

Definition at line 51 of file PalmPin.h.

#define pinTriCell "Tri Cell"

Definition at line 50 of file PalmPin.h.

#define sysNotifyAiaEvent 'Aian'

Definition at line 99 of file PalmPin.h.

Function Documentation

const char* PinGetCurrentPinletID ( UInt16 refnum )

Parameters:
refnum,: IN:

Return values:
Err error code.

UInt16 PinGetInputAreaState ( UInt16 refnum )

Parameters:
refnum,: IN:

Return values:
Err error code.

UInt16 PinGetInputMode ( UInt16 refnum )

Parameters:
refnum,: IN:

Return values:
Err error code.

Err PinLibClose ( UInt16 refnum )

Parameters:
refnum,: IN:

Return values:
Err error code.

Err PinLibOpen ( UInt16 refnum )

Parameters:
refnum,: IN:

Return values:
Err error code.

void PinResetInputState ( UInt16 refnum )

Parameters:
refnum,: IN:

Return values:
Err error code.

Err PinSetInputAreaState | ( | UInt16 | refnum,
 |  | UInt16 | state
 | ) |  |

Parameters:
refnum,: IN:

Parameters:
state,: IN:
Return values:
Err error code.

void PinSetInputMode | ( | UInt16 | refnum,
 |  | UInt16 | inputMode
 | ) |  |

Parameters:
refnum,: IN:

Parameters:
inputMode,: IN:
Return values:
Err error code.

Err PinSwitchToPinlet | ( | UInt16 | refnum,
 |  | const char * | pinletID,
 |  | UInt16 | initialInputMode
 | ) |  |

Parameters:
refnum,: IN:

Parameters:
pinletID,: IN:
initialInputMode,: IN:
Return values:
Err error code.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:07:56 2008 for Palm API Guide


Header Files » Incs » 68k » system

PalmPower.h File Reference

Detailed Description

Battery notification.

Version:
1.0
This contains the Battery state notification Any application can register for the notification to be notified when the of the various battery states

Definition in file PalmPower.h.

Go to the source code of this file.

Defines

Battery state notification
  • #define kPwrBatteryStateBroadcaster 'bsbc'
  • #define kPwrBatteryStateNotifyEvent 'bsnt'

Define Documentation

#define kPwrBatteryStateBroadcaster 'bsbc'

Battery notification broadcaster.

Definition at line 35 of file PalmPower.h.

#define kPwrBatteryStateNotifyEvent 'bsnt'

Battery notification notifyType

Definition at line 36 of file PalmPower.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:07:56 2008 for Palm API Guide


Header Files » Incs » 68k » system

PalmResources.h File Reference

Include dependency graph for PalmResources.h:

Go to the source code of this file.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:07:57 2008 for Palm API Guide


Header Files » Incs » common » system

PalmShimSettings.h File Reference

Detailed Description

Shim settings for NetIFSettingGet()/Set().

Version:
1.0
Date:
10/28/2002

Definition in file PalmShimSettings.h.

Go to the source code of this file.

Data Structures

  • struct vpnNotifyVPNLibTag

Defines

  • #define vpnLibEventNotification 'pVPN'

Typedefs

  • typedef UInt8 VPNLibEventNotificationTypeEnum
  • typedef vpnNotifyVPNLibTag VPNNotifyEventType

Enumerations

  • enum NetIFSettingShimEnum {
    netIFSettingShimUp = 0xA000,
    netIFSettingShimHideProgress,
    netIFSettingShimConfig,
    netIFSettingShimLog,
    netIFSettingShimCreator,
    netIFSettingShimVersion,
    netIFSettingShimLibVersion,
    netIFSettingShimVPNStart,
    netIFSettingShimVPNStop
    }
  • enum VPNLibEventNotificationTypeEnum_ {
    vpnConnectionUp = 1,
    vpnConnectionDown
    }

Define Documentation

#define vpnLibEventNotification 'pVPN'

Definition at line 40 of file PalmShimSettings.h.

Typedef Documentation

typedef UInt8 VPNLibEventNotificationTypeEnum

Definition at line 51 of file PalmShimSettings.h.

typedef struct vpnNotifyVPNLibTag VPNNotifyEventType

Notification structure sent in vpnLibEventNotification

Enumeration Type Documentation

enum NetIFSettingShimEnum

NetIFSettings for the shim. Used by NetIFSettingGet()/Set().

Enumerator:
netIFSettingShimUp | True if shim is up; read-only.
netIFSettingShimHideProgress | Defaults to false.
netIFSettingShimConfig | Mechanism for passing data between app & proto tasks.
netIFSettingShimLog | Copy the shim log; read-only.
netIFSettingShimCreator | Creator ID of shim; UInt32; read-only.
netIFSettingShimVersion | Version of the shim; Char[32]; read-only.
netIFSettingShimLibVersion | Version of the shim library; UInt32; little-endian; read-only; see sysMakeROMVersion() macro
netIFSettingShimVPNStart | Connect VPN
netIFSettingShimVPNStop | Disconnect VPN

Definition at line 27 of file PalmShimSettings.h.

00027              {
00028
00029   netIFSettingShimUp = 0xA000,    /**< True if shim is up; read-only. */
00030   netIFSettingShimHideProgress,   /**< Defaults to false. */
00031   netIFSettingShimConfig,         /**< Mechanism for passing data between app & proto tasks. */
00032   netIFSettingShimLog,            /**< Copy the shim log; read-only. */
00033   netIFSettingShimCreator,        /**< Creator ID of shim; UInt32; read-only. */
00034   netIFSettingShimVersion,        /**< Version of the shim; Char[32]; read-only. */
00035   netIFSettingShimLibVersion,     /**< Version of the shim library; UInt32; little-endian; read-only; see sysMakeROMVersion() macro */
00036   netIFSettingShimVPNStart,       /**< Connect VPN */
00037   netIFSettingShimVPNStop         /**< Disconnect VPN */
00038 } NetIFSettingShimEnum;

enum VPNLibEventNotificationTypeEnum_

IFMediaEvent notifications types

Enumerator:
vpnConnectionUp
vpnConnectionDown

Definition at line 45 of file PalmShimSettings.h.

00046   {
00047     vpnConnectionUp = 1,            /**<        */
00048     vpnConnectionDown           /**<        */
00049   };

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:07:57 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » audio

PalmSoundCustomCtrl.h File Reference

Detailed Description

Public 68K include file for the Sound Manager custom controls for the IMA_ADPCM codec for Treo 600 and Treo 650 smartphones.

This header file and associated header files support the specific sound functionality of the Treo smartphones. You should use the Palm OS Sound Manager APIs for most of your work.

Notes: How to use the IMA_ADPCM code custom control:

When you create a stream, make sure you set the format to sndFormatIMA_ADPCM and that the type is set to 0.

Then use the custom control to set the block align paramter:

SndCodecCustomControlType ct; UInt16 blockAlign= Swap16(blockAlign); // This needs to be in little endian ct.apiCreator = Swap32(codecDriverIMAADPCM); ct.apiSelector = Swap32(codecIMAADPCMSetBlockSize); ct.valueP = (void*)Swap32(&blockAlign); ct.valueLenP = NULL; err = SndStreamDeviceControl(streamRef, sndControlCodecCustomControl, &ct, sizeof(ct));

The calling application should always load this library with SysLibLoad() before use, even if it is already open by another application(ie, SysLibFind() returns a valid refnum). When the application is done with the library, it should be unloaded with SysLibRemove(). We do this because there is no good way to synchronize loading and unloading of libraries among multiple applications. It also greatly simplifies internal synchronization.

Definition in file PalmSoundCustomCtrl.h.

Go to the source code of this file.

Data Structures

  • struct SndCodecCustomControlType
    Holds Custom Control type information for the Extended Sound Manager. More...

Defines

Custom Control for the IMA_ADPCM codec
  • #define codecDriverIMAADPCM 'APCM'
  • #define codecIMAADPCMSetBlockSize 0x0001

Enumerations

  • enum { sndControlCodecCustomControl = 12 }

Define Documentation

#define codecDriverIMAADPCM 'APCM'

IMA ADPCM codec driver.

Definition at line 55 of file PalmSoundCustomCtrl.h.

#define codecIMAADPCMSetBlockSize 0x0001

IMA ADPCM block size set command.

Definition at line 56 of file PalmSoundCustomCtrl.h.

Enumeration Type Documentation

anonymous enum

IMA_ADPCM codec Custom Control type

Enumerator:
sndControlCodecCustomControl Param is a SndCodecCustomControlType*.

Definition at line 63 of file PalmSoundCustomCtrl.h.

00063      {
00064     sndControlCodecCustomControl = 12   /**< Param is a SndCodecCustomControlType*. */
00065 };

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:07:57 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » audio

PalmSoundMgrExt.h File Reference

Detailed Description

Public 68K include file for the Extended Sound Manager.

Notes: You should check to see if you are using a version of Palm OS SDK that implements the Extended Sound API. For lack of a better check, look for the earlier of the system traps and hope that the rest is likewise defined.

The calling application should always load this library with SysLibLoad() before use, even if it is already open by another application(ie, SysLibFind() returns a valid refnum). When the application is done with the library, it should be unloaded with SysLibRemove(). We do this because there is no good way to synchronize loading and unloading of libraries among multiple applications. It also greatly simplifies internal synchronization.

Definition in file PalmSoundMgrExt.h.

Include dependency graph for PalmSoundMgrExt.h:

Go to the source code of this file.

Defines

Extended Sound library traps
  • #define sysTrapSndStreamCreateExtended 0xA466
  • #define sysTrapSndStreamDeviceControl 0xA467

Typedefs

  • typedef UInt32 SndFormatType
  • typedef Err(*) SndStreamVariableBufferCallback (void *userDataP, SndStreamRef streamRef, void *bufferP, UInt32 *bufferSizeP)

Enumerations

  • enum {
    sndFormatPCM = 0,
    sndFormatIMA_ADPCM = 'APCM',
    sndFormatDVI_ADPCM = 'DPCM',
    sndFormatMP3 = 'MPG3',
    sndFormatAAC = 'DAAC',
    sndFormatOGG = 'OGGV'
    }

Functions

  • Err SndStreamCreateExtended (SndStreamRef *streamP, SndStreamMode mode, SndFormatType format, UInt32 sampleRate, SndSampleType sampleType, SndStreamWidth width, SndStreamVariableBufferCallback sndCallback, void *userDataP, UInt32 bufferSize, Boolean armNative)
  • Err SndStreamDeviceControl (SndStreamRef stream, Int32 cmd, void *paramP, Int32 size)

Define Documentation

#define sysTrapSndStreamCreateExtended 0xA466

Definition at line 48 of file PalmSoundMgrExt.h.

#define sysTrapSndStreamDeviceControl 0xA467

Definition at line 52 of file PalmSoundMgrExt.h.

Typedef Documentation

typedef UInt32 SndFormatType

Holds sound format type.

Definition at line 69 of file PalmSoundMgrExt.h.

typedef Err(*) SndStreamVariableBufferCallback(void *userDataP, SndStreamRef streamRef, void *bufferP, UInt32 *bufferSizeP)

Extended Sound Manager callback.

Parameters:
userDataP,: IN: Pointer to the user data passed in SndStreamCreateExtended.
streamRef,: IN: Opaque reference to the stream returned by SndStreamCreateExtended.
bufferP,: IN: Data buffer.
bufferSizeP,: IN: Pointer to the buffer size in bytes. This MUST be set before returning to the number of bytes read or written.
Return values:
Err Error code.

Definition at line 79 of file PalmSoundMgrExt.h.

Enumeration Type Documentation

anonymous enum

Sound format type

Enumerator:
sndFormatPCM | Raw PCM (Pulse Code Modulation), (attributes defined by type parameter).
sndFormatIMA_ADPCM | IMA ADPCM (Interactive Multimedia Association Adaptive Differential PCM).
sndFormatDVI_ADPCM | Intel/MS/DVI ADPCM.
sndFormatMP3 | Moving Picture Experts Group, Audio Layer III (MPEG-1 and MPEG-2 depending on bit-rate).
sndFormatAAC | Dolby Advanced Audio Coding.
sndFormatOGG | Ogg Vorbis.

Definition at line 59 of file PalmSoundMgrExt.h.

00059      {
00060     sndFormatPCM        = 0,            /**<Raw PCM (Pulse Code Modulation), (attributes defined by type parameter). */
00061     sndFormatIMA_ADPCM  = 'APCM',       /**<IMA ADPCM (Interactive Multimedia Association Adaptive Differential PCM). */
00062     sndFormatDVI_ADPCM  = 'DPCM',       /**<Intel/MS/DVI ADPCM. */
00063     sndFormatMP3        = 'MPG3',       /**<Moving Picture Experts Group, Audio Layer III (MPEG-1 and MPEG-2 depending on bit-rate). */
00064     sndFormatAAC        = 'DAAC',       /**<Dolby Advanced Audio Coding. */
00065     sndFormatOGG        = 'OGGV'        /**<Ogg Vorbis. */
00066 };

Function Documentation

Err SndStreamCreateExtended | ( | SndStreamRef * | streamP,
 |  | SndStreamMode | mode,
 |  | SndFormatType | format,
 |  | UInt32 | sampleRate,
 |  | SndSampleType | sampleType,
 |  | SndStreamWidth | width,
 |  | SndStreamVariableBufferCallback | sndCallback,
 |  | void * | userDataP,
 |  | UInt32 | bufferSize,
 |  | Boolean | armNative
 | ) |  |

Creates a sound stream using the Extended Sound API.

Parameters:
streamP,: IN: Receives the opaque reference to the stream.
mode,: IN: Direction of the sream, either sndInput or sndOutput.
format,: IN: Sound format. (sndFormatPCM...)
sampleRate,: IN: Sampling rate, in frames-per-second. (8000, 44100,...)
sampleType,: IN: Sample size and endianness of the data. (sndInt16...)
width,: IN: The number of channels: sndMono for one channel, sndStrereo for two.
sndCallback,: IN: A callback function that gets called when another buffer for sound is needed.
userDataP,: IN: Caller-defined data that gets passed to SndStreamVariableBufferCallback.
bufferSize,: IN: Preferred size in bytes for the buffers that are passed to sndCallback.
armNative,: IN: Pass true if the callback function is written in ARM-native code. If it’s 68K, pass false.
Return values:
Err Error code.

Err SndStreamDeviceControl | ( | SndStreamRef | stream,
 |  | Int32 | cmd,
 |  | void * | paramP,
 |  | Int32 | size
 | ) |  |

An extended function to handle new or device specific custom sound controls.

Parameters:
stream,: IN: Opaque reference to the stream returned by SndStreamCreateExtended.
cmd,: IN: One of the defined custom control enums, such as sndControlCodecCustomControl.
paramP,: IN: Pointer to data specific to the specific custom control defined by cmd.
size,: IN: Size in bytes of the structure passed in paramP.
Return values:
Err Error code.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:07:57 2008 for Palm API Guide


Header Files » Incs » 68k » system

PalmStatusBar.h File Reference

Include dependency graph for PalmStatusBar.h:

Go to the source code of this file.

Defines

Library type and creator
Public API for the Status Bar Library

  • #define statLibName "StatusBarMgrLib"
  • #define statLibCreator 'sBar'
  • #define statLibType sysFileTLibrary
  • #define statFtrNumVersion (0)
Status Bar Errors
  • #define statErrorClass (appErrorClass | 0x0900)
  • #define statErrNoStatusBar (statErrorClass | 1)
  • #define statErrInvalidSelector (statErrorClass | 2)
  • #define statErrInputWindowOpen (statErrorClass | 3)
  • #define statErrBadParam (statErrorClass | 101)
  • #define statErrInvalidState (statErrorClass | 102)
Library Traps
  • #define kStatusBarMgrLibTrapOpen sysLibTrapOpen
  • #define kStatusBarMgrLibTrapClose sysLibTrapClose
  • #define kStatusBarMgrLibGetAttribute (sysLibTrapCustom)
  • #define kStatusBarMgrLibHide (sysLibTrapCustom + 1)
  • #define kStatusBarMgrLibShow (sysLibTrapCustom + 2)

Typedefs

  • typedef enum StatAttrTypeTag StatAttrType

Enumerations

  • enum StatAttrTypeTag {
    statAttrExists = 0,
    statAttrBarVisible,
    statAttrDimension
    }

Functions

  • Err StatLibOpen (UInt16 refnum)
    Parameters:
    refnum,: IN:

  • Err StatLibClose (UInt16 refnum)
    Parameters:
    refnum,: IN:

  • Err StatGetAttribute (UInt16 refnum, StatAttrType selector, UInt32 *dataP)
    Parameters:
    refnum,: IN:

  • Err StatHide (UInt16 refnum)
    Parameters:
    refnum,: IN:

  • Err StatShow (UInt16 refnum)
    Parameters:
    refnum,: IN:

Define Documentation

#define kStatusBarMgrLibGetAttribute (sysLibTrapCustom)

Definition at line 69 of file PalmStatusBar.h.

#define kStatusBarMgrLibHide (sysLibTrapCustom + 1)

Definition at line 70 of file PalmStatusBar.h.

#define kStatusBarMgrLibShow (sysLibTrapCustom + 2)

Definition at line 71 of file PalmStatusBar.h.

#define kStatusBarMgrLibTrapClose sysLibTrapClose

Definition at line 68 of file PalmStatusBar.h.

#define kStatusBarMgrLibTrapOpen sysLibTrapOpen

Definition at line 67 of file PalmStatusBar.h.

#define statErrBadParam (statErrorClass | 101)

Definition at line 48 of file PalmStatusBar.h.

#define statErrInputWindowOpen (statErrorClass | 3)

Definition at line 47 of file PalmStatusBar.h.

#define statErrInvalidSelector (statErrorClass | 2)

Definition at line 46 of file PalmStatusBar.h.

#define statErrInvalidState (statErrorClass | 102)

Definition at line 49 of file PalmStatusBar.h.

#define statErrNoStatusBar (statErrorClass | 1)

Definition at line 45 of file PalmStatusBar.h.

#define statErrorClass (appErrorClass | 0x0900)

Definition at line 44 of file PalmStatusBar.h.

#define statFtrNumVersion (0)

Definition at line 36 of file PalmStatusBar.h.

#define statLibCreator 'sBar'

Definition at line 34 of file PalmStatusBar.h.

#define statLibName "StatusBarMgrLib"

Definition at line 33 of file PalmStatusBar.h.

#define statLibType sysFileTLibrary

Definition at line 35 of file PalmStatusBar.h.

Typedef Documentation

typedef enum StatAttrTypeTag StatAttrType

Status Bar Attributes

Enumeration Type Documentation

enum StatAttrTypeTag

Status Bar Attributes

Enumerator:
statAttrExists | device supports the status bar
statAttrBarVisible | status bar is visible
statAttrDimension | bounds of status bar window

Definition at line 55 of file PalmStatusBar.h.

00056 {
00057     statAttrExists     = 0,         /**< device supports the status bar */
00058     statAttrBarVisible,             /**< status bar is visible */
00059     statAttrDimension               /**< bounds of status bar window */
00060 } StatAttrType;

Function Documentation

Err StatGetAttribute | ( | UInt16 | refnum,
 |  | StatAttrType | selector,
 |  | UInt32 * | dataP
 | ) |  |

Parameters:
refnum,: IN:

Parameters:
selector,: IN:
*dataP,: IN:
Return values:
Err error code.

Err StatHide ( UInt16 refnum )

Parameters:
refnum,: IN:

Return values:
Err error code.

Err StatLibClose ( UInt16 refnum )

Parameters:
refnum,: IN:

Return values:
Err error code.

Err StatLibOpen ( UInt16 refnum )

Parameters:
refnum,: IN:

Return values:
Err error code.

Err StatShow ( UInt16 refnum )

Parameters:
refnum,: IN:

Return values:
Err error code.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:07:57 2008 for Palm API Guide


Header Files » Incs » 68k » system

PalmVMLaunch.h File Reference

Detailed Description

Defines APIs and structures for launching VersaMail to add a new message from an application.

Version:
1.0

Definition in file PalmVMLaunch.h.

Include dependency graph for PalmVMLaunch.h:

Go to the source code of this file.

Data Structures

  • struct MMProAttachStruct
    Structure for adding attachments in MMProLaunchStruct. More...
  • struct MMProLaunchStruct
    Structure to add a message + attachment passed with MMPRO_LAUNCH_CODE. More...
  • struct MMProAttachDataLinks
    Data links used in an attachment, used in MMProAttachStruct2. More...
  • struct MMProAttachStruct2
    Structure for adding attachments in MMProLaunchStruct2. More...
  • struct MMProLaunchStruct2
    Structure to add a message + attachment passed with MMPRO_LAUNCH_CODE. More...
  • struct MailAddRecordAttachment
    Structure to add attachment in MailAddRecordParamsTypePlus. More...
  • struct MailAddRecordParamsTypePlus
    Structure to add a message + attachment passed with MMPRO_ADD_MESSAGE_WITH_ATTACHMENT Categories & MailAddRecordParamsType are defined in AppLaunchCmd.h. More...

Defines

Launch Codes
  • #define MMPRO_LAUNCH_CODE (sysAppLaunchCmdCustomBase + 2)
  • #define MMPRO_ADD_MESSAGE_WITH_ATTACHMENT (sysAppLaunchCmdCustomBase + 16)
  • #define MM_MAX_ATTACHMENTS 10

Define Documentation

#define MM_MAX_ATTACHMENTS 10

Maximum no. of attach

Definition at line 47 of file PalmVMLaunch.h.

#define MMPRO_ADD_MESSAGE_WITH_ATTACHMENT (sysAppLaunchCmdCustomBase + 16)

Launch for adding a message to VersaMail with attachments, more powerful than sysAppLaunchCmdAddRecord

Definition at line 35 of file PalmVMLaunch.h.

#define MMPRO_LAUNCH_CODE (sysAppLaunchCmdCustomBase + 2)

Launch code for launching VersaMail through SysUIAppSwitch.

Definition at line 34 of file PalmVMLaunch.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:07:57 2008 for Palm API Guide


Header Files » Incs » 68k » system

PalmVMPlugin.h File Reference

Detailed Description

Defines APIs and structures for the VersaMail Plugin Service which lets users write plugins to view/send attachments.

Version:
1.0

Definition in file PalmVMPlugin.h.

Include dependency graph for PalmVMPlugin.h:

Go to the source code of this file.

Data Structures

  • struct _pluginGetInfoParams
    Structure used for launch code MMPRO_PLUGIN_GET_INFO_LAUNCHCODE. More...
  • struct _dataLinks
    Structure used for datalinks while sending /rcving data. More...
  • struct _pluginParams
    Structure used for launch code MMPRO_PLUGIN_RECEIVE_LAUNCHCODE. More...
  • struct _pluginQueryParams
    Structure used for launch code MMPRO_PLUGIN_QUERY_LAUNCHCODE. More...
  • struct _pluginSendParams
    Structure used for launch code MMPRO_PLUGIN_SEND_LAUNCHCODE. More...
  • struct _pluginExtendedQueryParams
    Structure used for launch code MMPRO_PLUGIN_EXTENDED_QUERY_LAUNCHCODE. More...

Defines

  • #define ATTYPE_MAX_NAME_LEN 32
Application Launch Codes
  • #define MMPRO_PLUGIN_LAUNCHCODE (sysAppLaunchCmdCustomBase + 2)
  • #define MMPRO_PLUGIN_RECEIVE_LAUNCHCODE MMPRO_PLUGIN_LAUNCHCODE
  • #define MMPRO_PLUGIN_QUERY_LAUNCHCODE (sysAppLaunchCmdCustomBase + 3)
  • #define MMPRO_PLUGIN_SEND_LAUNCHCODE (sysAppLaunchCmdCustomBase + 4)
  • #define MMPRO_PLUGIN_EXTENDED_QUERY_LAUNCHCODE (sysAppLaunchCmdCustomBase + 5)
  • #define MMPRO_PLUGIN_GET_INFO_LAUNCHCODE (sysAppLaunchCmdCustomBase + 8)

Typedefs

  • typedef _pluginGetInfoParams pluginGetInfoParams
    Structure used for launch code MMPRO_PLUGIN_GET_INFO_LAUNCHCODE.
  • typedef _dataLinks dataLinks
    Structure used for datalinks while sending /rcving data.
  • typedef _pluginParams pluginParams
    Structure used for launch code MMPRO_PLUGIN_RECEIVE_LAUNCHCODE.
  • typedef _pluginQueryParams pluginQueryParams
    Structure used for launch code MMPRO_PLUGIN_QUERY_LAUNCHCODE.
  • typedef _pluginSendParams pluginSendParams
    Structure used for launch code MMPRO_PLUGIN_SEND_LAUNCHCODE.
  • typedef _pluginExtendedQueryParams pluginExtendedQueryParams
    Structure used for launch code MMPRO_PLUGIN_EXTENDED_QUERY_LAUNCHCODE.

Enumerations

  • enum PluginInfo {
    plugin_sendInfo,
    plugin_receiveInfo,
    plugin_allInfo
    }
    PluginInfo is specifies what plugin information is needed. More...

Define Documentation

#define ATTYPE_MAX_NAME_LEN 32

Maximum array size for name of an attachment in listSendNames pointer

Definition at line 45 of file PalmVMPlugin.h.

#define MMPRO_PLUGIN_EXTENDED_QUERY_LAUNCHCODE (sysAppLaunchCmdCustomBase + 5)

Plugin should support selection of attachment and should return

Definition at line 39 of file PalmVMPlugin.h.

#define MMPRO_PLUGIN_GET_INFO_LAUNCHCODE (sysAppLaunchCmdCustomBase + 8)

VersaMail queries the plugin to get the details of Plugin information

Definition at line 40 of file PalmVMPlugin.h.

#define MMPRO_PLUGIN_LAUNCHCODE (sysAppLaunchCmdCustomBase + 2)

Plugin receives data from VersaMail and do whatever it deems appropriate with it.

Definition at line 34 of file PalmVMPlugin.h.

#define MMPRO_PLUGIN_QUERY_LAUNCHCODE (sysAppLaunchCmdCustomBase + 3)

Plugin should return a list of attachments for the user to select from.

Definition at line 37 of file PalmVMPlugin.h.

#define MMPRO_PLUGIN_RECEIVE_LAUNCHCODE MMPRO_PLUGIN_LAUNCHCODE

Definition at line 35 of file PalmVMPlugin.h.

#define MMPRO_PLUGIN_SEND_LAUNCHCODE (sysAppLaunchCmdCustomBase + 4)

The plugin should return the name of ? selected attachment for sending

Definition at line 38 of file PalmVMPlugin.h.

Typedef Documentation

typedef struct _dataLinks dataLinks

Structure used for datalinks while sending /rcving data.

typedef struct _pluginExtendedQueryParams pluginExtendedQueryParams

Structure used for launch code MMPRO_PLUGIN_EXTENDED_QUERY_LAUNCHCODE.

typedef struct _pluginGetInfoParams pluginGetInfoParams

Structure used for launch code MMPRO_PLUGIN_GET_INFO_LAUNCHCODE.

typedef struct _pluginParams pluginParams

Structure used for launch code MMPRO_PLUGIN_RECEIVE_LAUNCHCODE.

typedef struct _pluginQueryParams pluginQueryParams

Structure used for launch code MMPRO_PLUGIN_QUERY_LAUNCHCODE.

typedef struct _pluginSendParams pluginSendParams

Structure used for launch code MMPRO_PLUGIN_SEND_LAUNCHCODE.

Enumeration Type Documentation

enum PluginInfo

PluginInfo is specifies what plugin information is needed.

Enumerator:
plugin_sendInfo | Provides info about what can be passed as an email attachment.
plugin_receiveInfo | Provides info about what file types can be viewed.
plugin_allInfo | Provides sendInfo and receiveInfo.

Definition at line 52 of file PalmVMPlugin.h.

00052              {
00053
00054     plugin_sendInfo,    /**< Provides info about what can be passed as an email attachment. */
00055     plugin_receiveInfo,     /**< Provides info about what file types can be viewed. */
00056     plugin_allInfo      /**< Provides sendInfo and receiveInfo. */
00057
00058 } PluginInfo;

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:07:58 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » network

PalmVPPI.h File Reference

Detailed Description

This is the API for VPN panel plug-ins (VPPIs).

Version:
1.0
The VPN panel allows the user to manage their VPN accounts. Each plug-in provides support for a specific VPN protocol such as PPTP or IPSec. A VPPI provides access to the user interface of a VPN client. An NPPI (Network panel plug-in) provides the underlying implementation as well as an alternate user interface.

Definition in file PalmVPPI.h.

Go to the source code of this file.

Data Structures

  • struct VPNAccountType
    VPN Account structure. More...
  • struct SysVPPILaunchCmdGetAccountsType
    Structure used by the VPN Panel to query the account from a VPPI. More...
  • struct SysVPPILaunchCmdEditAccountType
    Structure used by the VPN Panel to edit an account. More...
  • struct SysVPPILaunchCmdDeleteAccountType
    Structure used by the VPN Panel to delete an account. More...
  • struct SysVPPILaunchCmdSetCurrentAccountType
    Structure used by the VPN Panel to set the current account. More...
  • struct SysVPPILaunchCmdPromptAndConfigureType
    Structure used by the VPN Panel to request the VPPI to display a dialog. More...
  • struct SysVPPILaunchCmdProgressPaintType
    Structure used by the VPN Panel to show the progess dialog. More...
  • struct SysVPPILaunchCmdErrorDialogType
    Structure used by the VPN Panel to show the error dialog. More...
  • struct SysVPPILaunchCmdClearPWCacheType
    Structure used by the VPN Panel to clear the password cache. More...
  • struct SysVPPILaunchCmdWillPWPromptType
    Structure used by the VPN Panel to determine is the VPPI will prompt for password. More...

Defines

  • #define sysFileTVPNPanelPlugin 'Vppi'
  • #define kMaxVPNAccountNameLength 31
  • #define sysVPPILaunchCmdGetAccounts sysAppLaunchCmdCustomBase
  • #define sysVPPILaunchCmdEditAccount (sysAppLaunchCmdCustomBase + 1)
  • #define sysVPPILaunchCmdDeleteAccount (sysAppLaunchCmdCustomBase + 2)
  • #define sysVPPILaunchCmdSetCurrentAccount (sysAppLaunchCmdCustomBase + 3)
  • #define sysVPPILaunchCmdPromptAndConfigure (sysAppLaunchCmdCustomBase + 4)
  • #define sysVPPILaunchCmdProgressPaint (sysAppLaunchCmdCustomBase + 5)
  • #define sysVPPILaunchCmdErrorDialog (sysAppLaunchCmdCustomBase + 6)
  • #define sysVPPILaunchCmdClearPWCache (sysAppLaunchCmdCustomBase + 7)
  • #define sysVPPILaunchCmdWillPWPrompt (sysAppLaunchCmdCustomBase + 8)

Define Documentation

#define kMaxVPNAccountNameLength 31

Account name maximum length.

Definition at line 30 of file PalmVPPI.h.

#define sysFileTVPNPanelPlugin 'Vppi'

Database type for VPN panel plug-ins.

Definition at line 27 of file PalmVPPI.h.

#define sysVPPILaunchCmdClearPWCache (sysAppLaunchCmdCustomBase + 7)

Launch code used by the VPN Panel to clear the password cache.

Definition at line 125 of file PalmVPPI.h.

#define sysVPPILaunchCmdDeleteAccount (sysAppLaunchCmdCustomBase + 2)

Launch code used by the VPN Panel to delete an account.

Definition at line 68 of file PalmVPPI.h.

#define sysVPPILaunchCmdEditAccount (sysAppLaunchCmdCustomBase + 1)

Launch code used by the VPN Panel to edit an account.

Definition at line 54 of file PalmVPPI.h.

#define sysVPPILaunchCmdErrorDialog (sysAppLaunchCmdCustomBase + 6)

Launch code used by the VPN Panel to show the error dialog.

Definition at line 114 of file PalmVPPI.h.

#define sysVPPILaunchCmdGetAccounts sysAppLaunchCmdCustomBase

Launch code used by the VPN Panel to get the account list.

Definition at line 42 of file PalmVPPI.h.

#define sysVPPILaunchCmdProgressPaint (sysAppLaunchCmdCustomBase + 5)

Launch code used by the VPN Panel to show the progess dialog.

Definition at line 102 of file PalmVPPI.h.

#define sysVPPILaunchCmdPromptAndConfigure (sysAppLaunchCmdCustomBase + 4)

Launch code used by the VPN Panel to request the VPPI to display a dialog.

Definition at line 90 of file PalmVPPI.h.

#define sysVPPILaunchCmdSetCurrentAccount (sysAppLaunchCmdCustomBase + 3)

Launch code used by the VPN Panel to set the current account.

Definition at line 79 of file PalmVPPI.h.

#define sysVPPILaunchCmdWillPWPrompt (sysAppLaunchCmdCustomBase + 8)

Launch code used by the VPN Panel to determine is the VPPI will prompt for password.

Definition at line 135 of file PalmVPPI.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:07:58 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » network

PalmWiFiCommon.h File Reference

Detailed Description

Constants and structures common to the wifi network panel and driver.

Version:
1.0

Definition in file PalmWiFiCommon.h.

Include dependency graph for PalmWiFiCommon.h:

Go to the source code of this file.

Data Structures

  • struct NetBssInfoType
    Structure to hold BSS Info data. More...
  • struct NetworkDeviceQueryData
    Structure to hold network query data. More...
  • struct BSSListStruct
    BSS list. More...
  • struct NetSSID
    Structure used to get and set the current SSID for the driver (not the Network interface). More...
  • struct NetWepKey
    Structure used to set the wep keys. More...

Defines

  • #define WIFI_MIN_OS_VERSION sysMakeROMVersion(3,0,0,sysROMStageDevelopment,0)
  • #define PALM_OS_20_VERSION sysMakeROMVersion(2,0,0,sysROMStageDevelopment,0)
  • #define WIFI_CREATOR_ID 'WiFi'
  • #define WIFI_CONFIG_NAME "WiFi Config"
  • #define WIFI_DB_TYPE 'DATA'
  • #define WIFI_DB_NAME "WiFiDB"
  • #define WIFI_DRIVER_PREFIX "wi"
  • #define WIFI_DRIVER_NAME "WiFi Prism3"
  • #define ESS 1
  • #define IBSS 4
  • #define net80211ResetWepPasscode 0x41149339
  • #define netMediaDisconnected 0
  • #define netMediaConnected 1
  • #define netMacAddrLength 6
  • #define netSSIDMaxLength 32
  • #define netNum80211Rates 8
  • #define BSSINFO_SIZE (BSSINFO_ANL_OFFSET + BSSINFO_ANL_SIZE)
Event Notifications
Event notifications from the WiFi -- can be used for SysNotifyRegister

  • #define WIFI_ASSOCIATED_EVENT 'WiAs'
  • #define WIFI_DISASSOCIATED_EVENT 'WiDi'
  • #define WIFI_SCAN_COMPLETE_EVENT 'WiSc'
  • #define WIFI_IF_UP_EVENT 'WiUp'
  • #define WIFI_IF_DOWN_EVENT 'WiDn'
Encryption Algorithm
  • #define AUTHENTICATION_ALGORITHM_OPEN_SYSTEM 1
  • #define AUTHENTICATION_ALGORITHM_SHARED_KEY 2
  • #define AUTHENTICATION_ALGORITHM_SHARED_KEY_128 3
ESS TX power mode.

  • #define AUTO_TX_POWER 0
  • #define ENHANCED_TX_POWER 1
AdHoc power modes.

  • #define FULL_TX_POWER 0
  • #define _30_MW_TX_POWER 1
  • #define _15_MW_TX_POWER 2
  • #define _5_MW_TX_POWER 3
  • #define _1_MW_TX_POWER 4
AP density constants.
Referred as netIFSetting80211Environment in configuration.

  • #define AP_DENSITY_LOW 0
  • #define AP_DENSITY_MED 1
  • #define AP_DENSITY_HIGH 2
Adapter Preamble

  • #define LONG_PREAMBLE 0
  • #define SHORT_PREAMBLE 1
  • #define AUTO_PREAMBLE 2
Network Device Driver Interface Error Codes

  • #define errNetQueryBufTooSmall 11
  • #define errNetOutOfMemory 12
  • #define errNetLibMissing 13
  • #define errNetInterfaceNotFound 14
  • #define BSSINFO_VFLAG 0
  • #define BSSINFO_VFLAG_SIZE 4
  • #define BSSINFO_MAC_ADDR_OFFSET (BSSINFO_VFLAG + BSSINFO_VFLAG_SIZE)
  • #define BSSINFO_MAC_ADDR_SIZE 8
  • #define BSSINFO_MAC_ADDR_VFLAG 0x00000001L
  • #define BSSINFO_SSIDLENGTH_OFFSET (BSSINFO_MAC_ADDR_OFFSET + BSSINFO_MAC_ADDR_SIZE)
  • #define BSSINFO_SSIDLENGTH_SIZE 4
  • #define BSSINFO_SSIDLENGTH_VFLAG 0x00000002L
  • #define BSSINFO_SSID_OFFSET (BSSINFO_SSIDLENGTH_OFFSET + BSSINFO_SSIDLENGTH_SIZE)
  • #define BSSINFO_SSID_SIZE netSSIDMaxLength
  • #define BSSINFO_SSID_VFLAG 0x00000004L
  • #define BSSINFO_WEP_OFFSET (BSSINFO_SSID_OFFSET + BSSINFO_SSID_SIZE)
  • #define BSSINFO_WEP_SIZE 4
  • #define BSSINFO_WEP_VFLAG 0x00000008L
  • #define BSSINFO_RSSI_OFFSET (BSSINFO_WEP_OFFSET + BSSINFO_WEP_SIZE)
  • #define BSSINFO_RSSI_SIZE 4
  • #define BSSINFO_RSSI_VFLAG 0x00000010L
  • #define BSSINFO_NETWORK_TYPE_OFFSET (BSSINFO_RSSI_OFFSET + BSSINFO_RSSI_SIZE)
  • #define BSSINFO_NETWORK_TYPE_SIZE 4
  • #define BSSINFO_NETWORK_TYPE_VFLAG 0x00000020L
  • #define BSSINFO_BEACON_PERIOD_OFFSET (BSSINFO_NETWORK_TYPE_OFFSET + BSSINFO_NETWORK_TYPE_SIZE)
  • #define BSSINFO_BEACON_PERIOD_SIZE 4
  • #define BSSINFO_BEACON_PERIOD_VFLAG 0x00000040L
  • #define BSSINFO_ATIM_WINDOW_OFFSET (BSSINFO_BEACON_PERIOD_OFFSET + BSSINFO_BEACON_PERIOD_SIZE)
  • #define BSSINFO_ATIM_WINDOW_SIZE 4
  • #define BSSINFO_ATIM_WINDOW_VFLAG 0x00000080L
  • #define BSSINFO_DSFREQ_OFFSET (BSSINFO_ATIM_WINDOW_OFFSET + BSSINFO_ATIM_WINDOW_SIZE)
  • #define BSSINFO_DSFREQ_SIZE 4
  • #define BSSINFO_DSFREQ_VFLAG 0x00000100L
  • #define BSSINFO_HOPPATTERN_OFFSET (BSSINFO_DSFREQ_OFFSET + BSSINFO_DSFREQ_SIZE)
  • #define BSSINFO_HOPPATTERN_SIZE 4
  • #define BSSINFO_HOPPATTERN_VFLAG 0x00000200L
  • #define BSSINFO_HOPSET_OFFSET (BSSINFO_HOPPATTERN_OFFSET + BSSINFO_HOPPATTERN_SIZE)
  • #define BSSINFO_HOPSET_SIZE 4
  • #define BSSINFO_HOPSET_VFLAG 0x00000400L
  • #define BSSINFO_HOPDWELL_OFFSET (BSSINFO_HOPSET_OFFSET + BSSINFO_HOPSET_SIZE)
  • #define BSSINFO_HOPDWELL_SIZE 4
  • #define BSSINFO_HOPDWELL_VFLAG 0x00000800L
  • #define BSSINFO_NETWORK_MODE_OFFSET (BSSINFO_HOPDWELL_OFFSET + BSSINFO_HOPDWELL_SIZE)
  • #define BSSINFO_NETWORK_MODE_SIZE 4
  • #define BSSINFO_NETWORK_MODE_VFLAG 0x00001000L
  • #define BSSINFO_SUPPORTED_RATES_OFFSET (BSSINFO_NETWORK_MODE_OFFSET + BSSINFO_NETWORK_MODE_SIZE)
  • #define BSSINFO_SUPPORTED_RATES_SIZE 8
  • #define BSSINFO_SUPPORTED_RATES_VFLAG 0x00002000L
  • #define BSSINFO_CHID_OFFSET (BSSINFO_SUPPORTED_RATES_OFFSET + BSSINFO_SUPPORTED_RATES_SIZE)
  • #define BSSINFO_CHID_SIZE 4
  • #define BSSINFO_CHID_VFLAG 0x00004000L
  • #define BSSINFO_ANL_OFFSET (BSSINFO_CHID_OFFSET + BSSINFO_CHID_SIZE)
  • #define BSSINFO_ANL_SIZE 4
  • #define BSSINFO_ANL_VFLAG 0x00008000L
Macros for accessing individual fields
  • #define BssInfoMacAddr(infoP, destP) MemMove( destP, &((UInt8 *) infoP)[BSSINFO_MAC_ADDR_OFFSET], BSSINFO_MAC_ADDR_SIZE )
  • #define BssInfoSsidLength(infoP, destP) MemMove( destP, &((UInt8 *) infoP)[BSSINFO_SSIDLENGTH_OFFSET], BSSINFO_SSIDLENGTH_SIZE )
  • #define BssInfoSsid(infoP, destP) MemMove( destP, &((UInt8 *) infoP)[BSSINFO_SSID_OFFSET], BSSINFO_SSID_SIZE )
  • #define BssInfoWep(infoP, destP) MemMove( destP, &((UInt8 *) infoP)[BSSINFO_WEP_OFFSET], BSSINFO_WEP_SIZE )
  • #define BssInfoRssi(infoP, destP) MemMove( destP, &((UInt8 *) infoP)[BSSINFO_RSSI_OFFSET], BSSINFO_RSSI_SIZE )
  • #define BssInfoNetworkType(infoP, destP) MemMove( destP, &((UInt8 *) infoP)[BSSINFO_NETWORK_TYPE_OFFSET], BSSINFO_NETWORK_TYPE_SIZE )
  • #define BssInfoBeaconPeriod(infoP, destP) MemMove( destP, &((UInt8 *) infoP)[BSSINFO_BEACON_PERIOD_OFFSET], BSSINFO_BEACON_PERIOD_SIZE )
  • #define BssInfoAtimWindow(infoP, destP) MemMove( destP, &((UInt8 *) infoP)[BSSINFO_ATIM_WINDOW_OFFSET], BSSINFO_ATIM_WINDOW_SIZE )
  • #define BssInfoDSFreq(infoP, destP) MemMove( destP, &((UInt8 *) infoP)[BSSINFO_DSFREQ_OFFSET], BSSINFO_DSFREQ_SIZE )
  • #define BssInfoHopPattern(infoP, destP) MemMove( destP, &((UInt8 *) infoP)[BSSINFO_HOPPATTERN_OFFSET], BSSINFO_HOPPATTERN_SIZE )
  • #define BssInfoHopSet(infoP, destP) MemMove( destP, &((UInt8 *) infoP)[BSSINFO_HOPSET_OFFSET], BSSINFO_HOPSET_SIZE )
  • #define BssInfoHopDwell(infoP, destP) MemMove( destP, &((UInt8 *) infoP)[BSSINFO_HOPDWELL_OFFSET], BSSINFO_HOPDWELL_SIZE )
  • #define BssInfoNetworkMode(infoP, destP) MemMove( destP, &((UInt8 *) infoP)[BSSINFO_NETWORK_MODE_OFFSET], BSSINFO_NETWORK_MODE_SIZE )
  • #define BssInfoSupportedRates(infoP, destP) MemMove( destP, &((UInt8 *) infoP)[BSSINFO_SUPPORTED_RATES_OFFSET], BSSINFO_SUPPORTED_RATES_SIZE )
  • #define BssInfoChannelId(infoP, destP) MemMove( destP, &((UInt8 *) infoP)[BSSINFO_CHID_OFFSET], BSSINFO_CHID_SIZE )
  • #define BssInfoANL(infoP, destP) MemMove( destP, &((UInt8 *) infoP)[BSSINFO_ANL_OFFSET], BSSINFO_ANL_SIZE )

Typedefs

  • typedef NetBssInfoType * NetBssInfoTypeP
    Structure to hold BSS Info data.
  • typedef NetworkDeviceQueryData NetQueryType
    Structure to hold network query data.
  • typedef NetworkDeviceQueryData * NetQueryTypeP
    Structure to hold network query data.
  • typedef enum _80211NetworkTypeEnum Net80211NetworkType
  • typedef enum _80211InfrastructureEnum Net80211InfrastructureModeType
  • typedef BSSListStruct NetBssListType
    BSS list.
  • typedef NetSSID * NetSSIDP
    Structure used to get and set the current SSID for the driver (not the Network interface).
  • typedef NetWepKey * NetWepKeyP
    Structure used to set the wep keys.

Enumerations

  • enum NetQueryId {
    netQuery80211SignalStrength = 0x100,
    netQuery80211SignalQuality,
    netQuery80211AuthenticationMode,
    netQuery80211BssScan,
    netQuery80211BssScanList,
    netQuery80211Channel,
    netQuery80211PowerState,
    netQuery80211RadioState,
    netQuery80211SSID,
    netQuery80211Key,
    netQuery80211KeyIndex,
    netQuery80211ResetKeys,
    netQuery80211OperatingMode,
    netQuery80211WepStatus,
    netQuery80211FirmwareVersion,
    netQuery80211SerialNumber,
    netQuery80211FWName,
    netQuery80211DriverDate,
    netQuery80211WEPRequired,
    netQuery80211ChannelList,
    netQuery80211BSSID,
    netQueryCancel,
    netQuery80211MediaState,
    netQuery80211SecurityMode,
    netQuery80211StartConnection,
    netQuery80211Last
    }
  • enum IPAllocType {
    IPAllocType_DHCP = 0,
    IPAllocType_APIPA = 1,
    IPAllocType_STATIC = 2
    }
  • enum SecurityModeType {
    SecurityModeOpenSystem = 0,
    SecurityModeWEP,
    SecurityModeWPAPSK,
    SecurityModeLast
    }
  • enum WiFiCustomIFSettings {
    netIFSetting80211PowerMode = netIFSettingCustom,
    netIFSetting80211Diversity,
    netIFSetting80211Channel,
    netIFSetting80211EncryptionKey1,
    netIFSetting80211EncryptionKey2,
    netIFSetting80211EncryptionKey3,
    netIFSetting80211EncryptionKey4,
    netIFSetting80211EncryptionKeyID,
    netIFSetting80211MandatoryBSSId,
    netIFSetting80211MUEncryptionAlgorithm,
    netIFSetting80211PortType,
    netIFSetting80211EssTxPower,
    netIFSetting80211AdhocTxPower,
    netIFSetting80211StationName,
    netIFSetting80211Environment,
    netIFSetting80211LongPreamble,
    netIFSetting80211Gateway,
    netIFSettingPrimaryDNS,
    netIFSettingSecondaryDNS,
    netIFSettingDHCPRequestDNS,
    netIFSettingIPAllocType,
    netIFSetting80211SmartConnect,
    netIFSettingUIProgHoldOff,
    netIFSettingWiFiHideProgress,
    netIFSettingAutoPowerDownOnClose,
    netIFSettingInterfaceQSize,
    netIFSettingDriverQSize,
    netIFSetting8021x,
    netIFSetting80211MediaDisconnectLingerTime,
    netIFSetting80211MobileIP,
    netIFSetting80211Last
    }
  • enum NetWepStatus {
    netWEPEnabled,
    netWEPDisabled,
    netWEPKeyAbsent,
    netWEPNotSupported
    }
  • enum _80211NetworkTypeEnum {
    net80211_FH,
    net80211_DS,
    net80211_Max
    }
  • enum _80211InfrastructureEnum {
    net80211Bss,
    net80211Infrastructure,
    net80211AutoUnknown,
    net80211InfrastructureMax
    }

Define Documentation

#define _15_MW_TX_POWER 2

Definition at line 125 of file PalmWiFiCommon.h.

#define _1_MW_TX_POWER 4

Definition at line 127 of file PalmWiFiCommon.h.

#define _30_MW_TX_POWER 1

Definition at line 124 of file PalmWiFiCommon.h.

#define _5_MW_TX_POWER 3

Definition at line 126 of file PalmWiFiCommon.h.

#define AP_DENSITY_HIGH 2

Definition at line 136 of file PalmWiFiCommon.h.

#define AP_DENSITY_LOW 0

Definition at line 134 of file PalmWiFiCommon.h.

#define AP_DENSITY_MED 1

Definition at line 135 of file PalmWiFiCommon.h.

#define AUTHENTICATION_ALGORITHM_OPEN_SYSTEM 1

Definition at line 103 of file PalmWiFiCommon.h.

#define AUTHENTICATION_ALGORITHM_SHARED_KEY 2

Definition at line 104 of file PalmWiFiCommon.h.

#define AUTHENTICATION_ALGORITHM_SHARED_KEY_128 3

Definition at line 105 of file PalmWiFiCommon.h.

#define AUTO_PREAMBLE 2

Definition at line 143 of file PalmWiFiCommon.h.

#define AUTO_TX_POWER 0

Definition at line 117 of file PalmWiFiCommon.h.

#define BSSINFO_ANL_OFFSET (BSSINFO_CHID_OFFSET + BSSINFO_CHID_SIZE)

Offset = 96 (0x60). Channel ID

Definition at line 337 of file PalmWiFiCommon.h.

#define BSSINFO_ANL_SIZE 4

Offset = 96 (0x60). Channel ID

Definition at line 338 of file PalmWiFiCommon.h.

#define BSSINFO_ANL_VFLAG 0x00008000L

Offset = 96 (0x60). Channel ID

Definition at line 339 of file PalmWiFiCommon.h.

#define BSSINFO_ATIM_WINDOW_OFFSET (BSSINFO_BEACON_PERIOD_OFFSET + BSSINFO_BEACON_PERIOD_SIZE)

Offset = 64 (0x40). ATim window (in KuSec)

Definition at line 281 of file PalmWiFiCommon.h.

#define BSSINFO_ATIM_WINDOW_SIZE 4

Offset = 64 (0x40). ATim window (in KuSec)

Definition at line 282 of file PalmWiFiCommon.h.

#define BSSINFO_ATIM_WINDOW_VFLAG 0x00000080L

Offset = 64 (0x40). ATim window (in KuSec)

Definition at line 283 of file PalmWiFiCommon.h.

#define BSSINFO_BEACON_PERIOD_OFFSET (BSSINFO_NETWORK_TYPE_OFFSET + BSSINFO_NETWORK_TYPE_SIZE)

Offset = 60 (0x3C). Beacon period (in KuSec)

Definition at line 274 of file PalmWiFiCommon.h.

#define BSSINFO_BEACON_PERIOD_SIZE 4

Offset = 60 (0x3C). Beacon period (in KuSec)

Definition at line 275 of file PalmWiFiCommon.h.

#define BSSINFO_BEACON_PERIOD_VFLAG 0x00000040L

Offset = 60 (0x3C). Beacon period (in KuSec)

Definition at line 276 of file PalmWiFiCommon.h.

#define BSSINFO_CHID_OFFSET (BSSINFO_SUPPORTED_RATES_OFFSET + BSSINFO_SUPPORTED_RATES_SIZE)

Offset = 96 (0x60). Channel ID

Definition at line 330 of file PalmWiFiCommon.h.

#define BSSINFO_CHID_SIZE 4

Offset = 96 (0x60). Channel ID

Definition at line 331 of file PalmWiFiCommon.h.

#define BSSINFO_CHID_VFLAG 0x00004000L

Offset = 96 (0x60). Channel ID

Definition at line 332 of file PalmWiFiCommon.h.

#define BSSINFO_DSFREQ_OFFSET (BSSINFO_ATIM_WINDOW_OFFSET + BSSINFO_ATIM_WINDOW_SIZE)

Offset = 68 (0x44). DS frequency (in kHz)

Definition at line 288 of file PalmWiFiCommon.h.

#define BSSINFO_DSFREQ_SIZE 4

Offset = 68 (0x44). DS frequency (in kHz)

Definition at line 289 of file PalmWiFiCommon.h.

#define BSSINFO_DSFREQ_VFLAG 0x00000100L

Offset = 68 (0x44). DS frequency (in kHz)

Definition at line 290 of file PalmWiFiCommon.h.

#define BSSINFO_HOPDWELL_OFFSET (BSSINFO_HOPSET_OFFSET + BSSINFO_HOPSET_SIZE)

Offset = 80 (0x50). Frequency hopping dwell time

Definition at line 309 of file PalmWiFiCommon.h.

#define BSSINFO_HOPDWELL_SIZE 4

Offset = 80 (0x50). Frequency hopping dwell time

Definition at line 310 of file PalmWiFiCommon.h.

#define BSSINFO_HOPDWELL_VFLAG 0x00000800L

Offset = 80 (0x50). Frequency hopping dwell time

Definition at line 311 of file PalmWiFiCommon.h.

#define BSSINFO_HOPPATTERN_OFFSET (BSSINFO_DSFREQ_OFFSET + BSSINFO_DSFREQ_SIZE)

Offset = 72 (0x48). Frequency hopping pattern

Definition at line 295 of file PalmWiFiCommon.h.

#define BSSINFO_HOPPATTERN_SIZE 4

Offset = 72 (0x48). Frequency hopping pattern

Definition at line 296 of file PalmWiFiCommon.h.

#define BSSINFO_HOPPATTERN_VFLAG 0x00000200L

Offset = 72 (0x48). Frequency hopping pattern

Definition at line 297 of file PalmWiFiCommon.h.

#define BSSINFO_HOPSET_OFFSET (BSSINFO_HOPPATTERN_OFFSET + BSSINFO_HOPPATTERN_SIZE)

Offset = 76 (0x4C). Frequency hopping set

Definition at line 302 of file PalmWiFiCommon.h.

#define BSSINFO_HOPSET_SIZE 4

Offset = 76 (0x4C). Frequency hopping set

Definition at line 303 of file PalmWiFiCommon.h.

#define BSSINFO_HOPSET_VFLAG 0x00000400L

Offset = 76 (0x4C). Frequency hopping set

Definition at line 304 of file PalmWiFiCommon.h.

#define BSSINFO_MAC_ADDR_OFFSET (BSSINFO_VFLAG + BSSINFO_VFLAG_SIZE)

Offset = 4. MAC/HW Address for device.

Definition at line 232 of file PalmWiFiCommon.h.

#define BSSINFO_MAC_ADDR_SIZE 8

Offset = 4. MAC/HW Address for device.

Definition at line 233 of file PalmWiFiCommon.h.

#define BSSINFO_MAC_ADDR_VFLAG 0x00000001L

Offset = 4. MAC/HW Address for device.

Definition at line 234 of file PalmWiFiCommon.h.

#define BSSINFO_NETWORK_MODE_OFFSET (BSSINFO_HOPDWELL_OFFSET + BSSINFO_HOPDWELL_SIZE)

Offset = 84 (0x54). 802.11 network mode

Definition at line 316 of file PalmWiFiCommon.h.

#define BSSINFO_NETWORK_MODE_SIZE 4

Offset = 84 (0x54). 802.11 network mode

Definition at line 317 of file PalmWiFiCommon.h.

#define BSSINFO_NETWORK_MODE_VFLAG 0x00001000L

Offset = 84 (0x54). 802.11 network mode

Definition at line 318 of file PalmWiFiCommon.h.

#define BSSINFO_NETWORK_TYPE_OFFSET (BSSINFO_RSSI_OFFSET + BSSINFO_RSSI_SIZE)

Offset = 56 (0x38). Network type in use (Freq. hopping, DSS)

Definition at line 267 of file PalmWiFiCommon.h.

#define BSSINFO_NETWORK_TYPE_SIZE 4

Offset = 56 (0x38). Network type in use (Freq. hopping, DSS)

Definition at line 268 of file PalmWiFiCommon.h.

#define BSSINFO_NETWORK_TYPE_VFLAG 0x00000020L

Offset = 56 (0x38). Network type in use (Freq. hopping, DSS)

Definition at line 269 of file PalmWiFiCommon.h.

#define BSSINFO_RSSI_OFFSET (BSSINFO_WEP_OFFSET + BSSINFO_WEP_SIZE)

Offset = 52 (0x34). Received Signal Strength

Definition at line 260 of file PalmWiFiCommon.h.

#define BSSINFO_RSSI_SIZE 4

Offset = 52 (0x34). Received Signal Strength

Definition at line 261 of file PalmWiFiCommon.h.

#define BSSINFO_RSSI_VFLAG 0x00000010L

Offset = 52 (0x34). Received Signal Strength

Definition at line 262 of file PalmWiFiCommon.h.

#define BSSINFO_SIZE (BSSINFO_ANL_OFFSET + BSSINFO_ANL_SIZE)

Total size of the BSS info supplied.

Definition at line 343 of file PalmWiFiCommon.h.

#define BSSINFO_SSID_OFFSET (BSSINFO_SSIDLENGTH_OFFSET + BSSINFO_SSIDLENGTH_SIZE)

Offset = 16 (0x10). SSID

Definition at line 246 of file PalmWiFiCommon.h.

#define BSSINFO_SSID_SIZE netSSIDMaxLength

Offset = 16 (0x10). SSID

Definition at line 247 of file PalmWiFiCommon.h.

#define BSSINFO_SSID_VFLAG 0x00000004L

Offset = 16 (0x10). SSID

Definition at line 248 of file PalmWiFiCommon.h.

#define BSSINFO_SSIDLENGTH_OFFSET (BSSINFO_MAC_ADDR_OFFSET + BSSINFO_MAC_ADDR_SIZE)

Offset = 12. Length of the following SSID

Definition at line 239 of file PalmWiFiCommon.h.

#define BSSINFO_SSIDLENGTH_SIZE 4

Offset = 12. Length of the following SSID

Definition at line 240 of file PalmWiFiCommon.h.

#define BSSINFO_SSIDLENGTH_VFLAG 0x00000002L

Offset = 12. Length of the following SSID

Definition at line 241 of file PalmWiFiCommon.h.

#define BSSINFO_SUPPORTED_RATES_OFFSET (BSSINFO_NETWORK_MODE_OFFSET + BSSINFO_NETWORK_MODE_SIZE)

Offset = 88 (0x58). Supported rates on interface.

Definition at line 323 of file PalmWiFiCommon.h.

#define BSSINFO_SUPPORTED_RATES_SIZE 8

Offset = 88 (0x58). Supported rates on interface.

Definition at line 324 of file PalmWiFiCommon.h.

#define BSSINFO_SUPPORTED_RATES_VFLAG 0x00002000L

Offset = 88 (0x58). Supported rates on interface.

Definition at line 325 of file PalmWiFiCommon.h.

#define BSSINFO_VFLAG 0

Offset = 0. Present/validity flags for each of the entities defined below

Definition at line 226 of file PalmWiFiCommon.h.

#define BSSINFO_VFLAG_SIZE 4

Offset = 0. Present/validity flags for each of the entities defined below

Definition at line 227 of file PalmWiFiCommon.h.

#define BSSINFO_WEP_OFFSET (BSSINFO_SSID_OFFSET + BSSINFO_SSID_SIZE)

Offset = 48 (0x30). WEP enabled boolean

Definition at line 253 of file PalmWiFiCommon.h.

#define BSSINFO_WEP_SIZE 4

Offset = 48 (0x30). WEP enabled boolean

Definition at line 254 of file PalmWiFiCommon.h.

#define BSSINFO_WEP_VFLAG 0x00000008L

Offset = 48 (0x30). WEP enabled boolean

Definition at line 255 of file PalmWiFiCommon.h.

#define BssInfoANL | ( | infoP,
 |  | destP | ) | MemMove( destP, &((UInt8 *) infoP)[BSSINFO_ANL_OFFSET], BSSINFO_ANL_SIZE )

Definition at line 362 of file PalmWiFiCommon.h.

#define BssInfoAtimWindow | ( | infoP,
 |  | destP | ) | MemMove( destP, &((UInt8 *) infoP)[BSSINFO_ATIM_WINDOW_OFFSET], BSSINFO_ATIM_WINDOW_SIZE )

Definition at line 354 of file PalmWiFiCommon.h.

#define BssInfoBeaconPeriod | ( | infoP,
 |  | destP | ) | MemMove( destP, &((UInt8 *) infoP)[BSSINFO_BEACON_PERIOD_OFFSET], BSSINFO_BEACON_PERIOD_SIZE )

Definition at line 353 of file PalmWiFiCommon.h.

#define BssInfoChannelId | ( | infoP,
 |  | destP | ) | MemMove( destP, &((UInt8 *) infoP)[BSSINFO_CHID_OFFSET], BSSINFO_CHID_SIZE )

Definition at line 361 of file PalmWiFiCommon.h.

#define BssInfoDSFreq | ( | infoP,
 |  | destP | ) | MemMove( destP, &((UInt8 *) infoP)[BSSINFO_DSFREQ_OFFSET], BSSINFO_DSFREQ_SIZE )

Definition at line 355 of file PalmWiFiCommon.h.

#define BssInfoHopDwell | ( | infoP,
 |  | destP | ) | MemMove( destP, &((UInt8 *) infoP)[BSSINFO_HOPDWELL_OFFSET], BSSINFO_HOPDWELL_SIZE )

Definition at line 358 of file PalmWiFiCommon.h.

#define BssInfoHopPattern | ( | infoP,
 |  | destP | ) | MemMove( destP, &((UInt8 *) infoP)[BSSINFO_HOPPATTERN_OFFSET], BSSINFO_HOPPATTERN_SIZE )

Definition at line 356 of file PalmWiFiCommon.h.

#define BssInfoHopSet | ( | infoP,
 |  | destP | ) | MemMove( destP, &((UInt8 *) infoP)[BSSINFO_HOPSET_OFFSET], BSSINFO_HOPSET_SIZE )

Definition at line 357 of file PalmWiFiCommon.h.

#define BssInfoMacAddr | ( | infoP,
 |  | destP | ) | MemMove( destP, &((UInt8 *) infoP)[BSSINFO_MAC_ADDR_OFFSET], BSSINFO_MAC_ADDR_SIZE )

Definition at line 347 of file PalmWiFiCommon.h.

#define BssInfoNetworkMode | ( | infoP,
 |  | destP | ) | MemMove( destP, &((UInt8 *) infoP)[BSSINFO_NETWORK_MODE_OFFSET], BSSINFO_NETWORK_MODE_SIZE )

Definition at line 359 of file PalmWiFiCommon.h.

#define BssInfoNetworkType | ( | infoP,
 |  | destP | ) | MemMove( destP, &((UInt8 *) infoP)[BSSINFO_NETWORK_TYPE_OFFSET], BSSINFO_NETWORK_TYPE_SIZE )

Definition at line 352 of file PalmWiFiCommon.h.

#define BssInfoRssi | ( | infoP,
 |  | destP | ) | MemMove( destP, &((UInt8 *) infoP)[BSSINFO_RSSI_OFFSET], BSSINFO_RSSI_SIZE )

Definition at line 351 of file PalmWiFiCommon.h.

#define BssInfoSsid | ( | infoP,
 |  | destP | ) | MemMove( destP, &((UInt8 *) infoP)[BSSINFO_SSID_OFFSET], BSSINFO_SSID_SIZE )

Definition at line 349 of file PalmWiFiCommon.h.

#define BssInfoSsidLength | ( | infoP,
 |  | destP | ) | MemMove( destP, &((UInt8 *) infoP)[BSSINFO_SSIDLENGTH_OFFSET], BSSINFO_SSIDLENGTH_SIZE )

Definition at line 348 of file PalmWiFiCommon.h.

#define BssInfoSupportedRates | ( | infoP,
 |  | destP | ) | MemMove( destP, &((UInt8 *) infoP)[BSSINFO_SUPPORTED_RATES_OFFSET], BSSINFO_SUPPORTED_RATES_SIZE )

Definition at line 360 of file PalmWiFiCommon.h.

#define BssInfoWep | ( | infoP,
 |  | destP | ) | MemMove( destP, &((UInt8 *) infoP)[BSSINFO_WEP_OFFSET], BSSINFO_WEP_SIZE )

Definition at line 350 of file PalmWiFiCommon.h.

#define ENHANCED_TX_POWER 1

Definition at line 118 of file PalmWiFiCommon.h.

#define errNetInterfaceNotFound 14

Definition at line 214 of file PalmWiFiCommon.h.

#define errNetLibMissing 13

Definition at line 213 of file PalmWiFiCommon.h.

#define errNetOutOfMemory 12

Definition at line 212 of file PalmWiFiCommon.h.

#define errNetQueryBufTooSmall 11

Definition at line 211 of file PalmWiFiCommon.h.

#define ESS 1

Operating mode, referred to as port type in the configuration.

Definition at line 109 of file PalmWiFiCommon.h.

#define FULL_TX_POWER 0

Definition at line 123 of file PalmWiFiCommon.h.

#define IBSS 4

Definition at line 113 of file PalmWiFiCommon.h.

#define LONG_PREAMBLE 0

Definition at line 141 of file PalmWiFiCommon.h.

#define net80211ResetWepPasscode 0x41149339

Special code required to be passed to reset wep keys

Definition at line 147 of file PalmWiFiCommon.h.

#define netMacAddrLength 6

max length MAC address

Definition at line 196 of file PalmWiFiCommon.h.

#define netMediaConnected 1

Definitions of media states returned from netQuery80211MediaState

Definition at line 152 of file PalmWiFiCommon.h.

#define netMediaDisconnected 0

Definitions of media states returned from netQuery80211MediaState

Definition at line 150 of file PalmWiFiCommon.h.

#define netNum80211Rates 8

no definition

Definition at line 198 of file PalmWiFiCommon.h.

#define netSSIDMaxLength 32

max length SSID

Definition at line 197 of file PalmWiFiCommon.h.

#define PALM_OS_20_VERSION sysMakeROMVersion(2,0,0,sysROMStageDevelopment,0)

Define the appropriate minimum OS version we support

Definition at line 25 of file PalmWiFiCommon.h.

#define SHORT_PREAMBLE 1

Definition at line 142 of file PalmWiFiCommon.h.

#define WIFI_ASSOCIATED_EVENT 'WiAs'

Definition at line 45 of file PalmWiFiCommon.h.

#define WIFI_CONFIG_NAME "WiFi Config"

WiFi configuration name

Definition at line 30 of file PalmWiFiCommon.h.

#define WIFI_CREATOR_ID 'WiFi'

WiFi creator ID.

Definition at line 28 of file PalmWiFiCommon.h.

#define WIFI_DB_NAME "WiFiDB"

WiFi database name

Definition at line 35 of file PalmWiFiCommon.h.

#define WIFI_DB_TYPE 'DATA'

WiFi database type

Definition at line 33 of file PalmWiFiCommon.h.

#define WIFI_DISASSOCIATED_EVENT 'WiDi'

Definition at line 46 of file PalmWiFiCommon.h.

#define WIFI_DRIVER_NAME "WiFi Prism3"

WiFi driver name

Definition at line 40 of file PalmWiFiCommon.h.

#define WIFI_DRIVER_PREFIX "wi"

WiFi driver prefix

Definition at line 38 of file PalmWiFiCommon.h.

#define WIFI_IF_DOWN_EVENT 'WiDn'

Definition at line 49 of file PalmWiFiCommon.h.

#define WIFI_IF_UP_EVENT 'WiUp'

Definition at line 48 of file PalmWiFiCommon.h.

#define WIFI_MIN_OS_VERSION sysMakeROMVersion(3,0,0,sysROMStageDevelopment,0)

Define the appropriate minimum OS version we support

Definition at line 23 of file PalmWiFiCommon.h.

#define WIFI_SCAN_COMPLETE_EVENT 'WiSc'

Definition at line 47 of file PalmWiFiCommon.h.

Typedef Documentation

typedef enum _80211InfrastructureEnum Net80211InfrastructureModeType

Infrastructure mode info returned from a BSS scan

typedef enum _80211NetworkTypeEnum Net80211NetworkType

typedef struct NetBssInfoType * NetBssInfoTypeP

Structure to hold BSS Info data.

Accessing the BSS scan info returned via the network interface via the following structure needs to be verified for each specific toolchain and compiler. It has been verified with the combination of ADS V1.2 and CW 8.3. The data format has been done to be as toolchain/architecture/alignment independent as possible, however, if a different combination other than the one listed is used, the format must be verified. The macro's defined above can also be used to access the individual entities of the returned BSS scan data.

typedef struct BSSListStruct NetBssListType

BSS list.

This data structure is returned from a BSS scan. The count field indicates how many BSS structures are provide.

typedef struct NetworkDeviceQueryData NetQueryType

Structure to hold network query data.

typedef struct NetworkDeviceQueryData * NetQueryTypeP

Structure to hold network query data.

typedef struct NetSSID * NetSSIDP

Structure used to get and set the current SSID for the driver (not the Network interface).

typedef struct NetWepKey * NetWepKeyP

Structure used to set the wep keys.

The API's do not return the wep keys via a query.

Enumeration Type Documentation

enum _80211InfrastructureEnum

Infrastructure mode info returned from a BSS scan

Enumerator:
net80211Bss
net80211Infrastructure
net80211AutoUnknown
net80211InfrastructureMax

Definition at line 425 of file PalmWiFiCommon.h.

00426 {
00427     net80211Bss,
00428     net80211Infrastructure,
00429     net80211AutoUnknown,
00430     net80211InfrastructureMax           // Never returned from scan.  Can be used for bounds checking.
00431 } Net80211InfrastructureModeType;

enum _80211NetworkTypeEnum

Enumerator:
net80211_FH
net80211_DS
net80211_Max

Definition at line 417 of file PalmWiFiCommon.h.

00418 {
00419     net80211_FH,
00420     net80211_DS,
00421     net80211_Max            // Never returned from scan.  Can be used for bounds checking
00422 } Net80211NetworkType;

enum IPAllocType

IP address allocation strategies

Enumerator:
IPAllocType_DHCP
IPAllocType_APIPA
IPAllocType_STATIC

Definition at line 86 of file PalmWiFiCommon.h.

00087 {
00088     IPAllocType_DHCP   = 0,
00089     IPAllocType_APIPA  = 1,
00090     IPAllocType_STATIC = 2
00091 };

enum NetQueryId

Supported Query requests for WiFi driver.

Enumerator:
netQuery80211SignalStrength
netQuery80211SignalQuality
netQuery80211AuthenticationMode
netQuery80211BssScan
netQuery80211BssScanList
netQuery80211Channel
netQuery80211PowerState
netQuery80211RadioState
netQuery80211SSID
netQuery80211Key
netQuery80211KeyIndex
netQuery80211ResetKeys
netQuery80211OperatingMode
netQuery80211WepStatus
netQuery80211FirmwareVersion
netQuery80211SerialNumber
netQuery80211FWName
netQuery80211DriverDate
netQuery80211WEPRequired
netQuery80211ChannelList
netQuery80211BSSID
netQueryCancel
netQuery80211MediaState
netQuery80211SecurityMode
netQuery80211StartConnection
netQuery80211Last

Definition at line 54 of file PalmWiFiCommon.h.

00055 {
00056     netQuery80211SignalStrength = 0x100,
00057     netQuery80211SignalQuality,
00058     netQuery80211AuthenticationMode,
00059     netQuery80211BssScan,
00060     netQuery80211BssScanList,
00061     netQuery80211Channel,
00062     netQuery80211PowerState,
00063     netQuery80211RadioState,
00064     netQuery80211SSID,
00065     netQuery80211Key,
00066     netQuery80211KeyIndex,
00067     netQuery80211ResetKeys,
00068     netQuery80211OperatingMode,
00069     netQuery80211WepStatus,
00070     netQuery80211FirmwareVersion,
00071     netQuery80211SerialNumber,
00072     netQuery80211FWName,
00073     netQuery80211DriverDate,
00074     netQuery80211WEPRequired,
00075     netQuery80211ChannelList,
00076     netQuery80211BSSID,
00077     netQueryCancel,
00078     netQuery80211MediaState,
00079     netQuery80211SecurityMode, // use security mode #defines
00080     netQuery80211StartConnection,
00081     netQuery80211Last
00082 } NetQueryId;

enum NetWepStatus

Wep status codes

Enumerator:
netWEPEnabled
netWEPDisabled
netWEPKeyAbsent
netWEPNotSupported

Definition at line 201 of file PalmWiFiCommon.h.

00202 {
00203     netWEPEnabled,
00204     netWEPDisabled,
00205     netWEPKeyAbsent,
00206     netWEPNotSupported
00207 };

enum SecurityModeType

Enumerator:
SecurityModeOpenSystem
SecurityModeWEP
SecurityModeWPAPSK
SecurityModeLast

Definition at line 93 of file PalmWiFiCommon.h.

00094 {
00095     SecurityModeOpenSystem = 0,
00096     SecurityModeWEP,
00097     SecurityModeWPAPSK,
00098     SecurityModeLast
00099 };

enum WiFiCustomIFSettings

Enumerator:
netIFSetting80211PowerMode
netIFSetting80211Diversity
netIFSetting80211Channel
netIFSetting80211EncryptionKey1
netIFSetting80211EncryptionKey2
netIFSetting80211EncryptionKey3
netIFSetting80211EncryptionKey4
netIFSetting80211EncryptionKeyID
netIFSetting80211MandatoryBSSId
netIFSetting80211MUEncryptionAlgorithm
netIFSetting80211PortType
netIFSetting80211EssTxPower
netIFSetting80211AdhocTxPower
netIFSetting80211StationName
netIFSetting80211Environment
netIFSetting80211LongPreamble
netIFSetting80211Gateway
netIFSettingPrimaryDNS
netIFSettingSecondaryDNS
netIFSettingDHCPRequestDNS
netIFSettingIPAllocType
netIFSetting80211SmartConnect
netIFSettingUIProgHoldOff
netIFSettingWiFiHideProgress
netIFSettingAutoPowerDownOnClose
netIFSettingInterfaceQSize
netIFSettingDriverQSize
netIFSetting8021x
netIFSetting80211MediaDisconnectLingerTime
netIFSetting80211MobileIP
netIFSetting80211Last

Definition at line 154 of file PalmWiFiCommon.h.

00155 {
00156     netIFSetting80211PowerMode = netIFSettingCustom,
00157     netIFSetting80211Diversity,
00158     netIFSetting80211Channel,
00159     netIFSetting80211EncryptionKey1,
00160     netIFSetting80211EncryptionKey2,
00161     netIFSetting80211EncryptionKey3,
00162     netIFSetting80211EncryptionKey4,
00163     netIFSetting80211EncryptionKeyID,
00164     netIFSetting80211MandatoryBSSId,
00165     netIFSetting80211MUEncryptionAlgorithm,
00166     netIFSetting80211PortType,  // ESS, PsIBBS, IBSS
00167     netIFSetting80211EssTxPower,
00168     netIFSetting80211AdhocTxPower,
00169     netIFSetting80211StationName,
00170     netIFSetting80211Environment,
00171     netIFSetting80211LongPreamble,
00172     netIFSetting80211Gateway,
00173     netIFSettingPrimaryDNS,
00174     netIFSettingSecondaryDNS,
00175     netIFSettingDHCPRequestDNS,
00176     netIFSettingIPAllocType, // 0,1,2=DHCP,APIPA,STATIC
00177     netIFSetting80211SmartConnect,
00178     netIFSettingUIProgHoldOff,
00179     netIFSettingWiFiHideProgress,
00180     netIFSettingAutoPowerDownOnClose,
00181     netIFSettingInterfaceQSize,
00182     netIFSettingDriverQSize,
00183     netIFSetting8021x,
00184     netIFSetting80211MediaDisconnectLingerTime,
00185     netIFSetting80211MobileIP,
00186
00187 #ifdef WIFI_DOT1X_SUPPORT
00188     netIFSettingDot1XWPPICreator,
00189     netIFSettingDot1XAuthenticationMethodID,
00190     netIFSettingDot1XAuthenticationCookie,
00191 #endif // WIFI_DOT1X_SUPPORT
00192
00193     netIFSetting80211Last
00194 };

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:00 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » network

PalmWPPI.h File Reference

Detailed Description

This is the API for Wi-Fi panel plug-ins (WPPIs).

Version:
1.0
Date:
05/16/2003
The Wi-Fi panel allows the user to manage their network profiles. Each profile includes a plugin, an authentication method, and a cookie used to identify the user's credentials. Each plugin provides support for one or more authentication methods; e.g., LEAP, PEAP, etc. A WPPI provides access to the user interface of an 802.1x client.

Definition in file PalmWPPI.h.

Go to the source code of this file.

Data Structures

  • struct WiFiAuthenticationMethodType
  • struct SysWPPILaunchCmdGetAuthenticationMethodsType
  • struct SysWPPILaunchCmdType
  • struct SysWPPILaunchCmdGetDescriptionType
  • struct SysWPPILaunchCmdPromptAndConfigureType
  • struct SysWPPILaunchCmdErrorDialogType
  • struct SysWPPILaunchCmdClearPWCache

Defines

  • #define sysFileTWiFiPanelPlugin 'Wppi'
  • #define sysWPPILaunchCmdGetAuthenticationMethods sysAppLaunchCmdCustomBase
  • #define kMaxWiFiAuthenticationMethodNameLength 31
  • #define kMaxWiFiCredentialsLabelLength 31
  • #define kMaxWiFiCredentialsSelectorTriggerLength 31
  • #define sysWPPILaunchCmdOpen sysAppLaunchCmdCustomBase + 1
  • #define sysWPPILaunchCmdClose sysAppLaunchCmdCustomBase + 2
  • #define sysWPPILaunchCmdDialog sysAppLaunchCmdCustomBase + 3
  • #define sysWPPILaunchCmdDelete sysAppLaunchCmdCustomBase + 4
  • #define sysWPPILaunchCmdGetDescription sysAppLaunchCmdCustomBase + 5
  • #define sysWPPILaunchCmdPromptAndConfigure (sysAppLaunchCmdCustomBase + 6)
  • #define sysWPPILaunchCmdErrorDialog (sysAppLaunchCmdCustomBase + 7)
  • #define sysWPPILaunchCmdClearPWCache (sysAppLaunchCmdCustomBase + 8)

Define Documentation

#define kMaxWiFiAuthenticationMethodNameLength 31

Definition at line 57 of file PalmWPPI.h.

#define kMaxWiFiCredentialsLabelLength 31

Definition at line 102 of file PalmWPPI.h.

#define kMaxWiFiCredentialsSelectorTriggerLength 31

Definition at line 103 of file PalmWPPI.h.

#define sysFileTWiFiPanelPlugin 'Wppi'

database type for Wi-Fi panel plug-ins

Definition at line 32 of file PalmWPPI.h.

#define sysWPPILaunchCmdClearPWCache (sysAppLaunchCmdCustomBase + 8)

This is invoked to request a password cache clear. Removes temporary passwords from all accounts managed by the WPPI.

Definition at line 208 of file PalmWPPI.h.

#define sysWPPILaunchCmdClose sysAppLaunchCmdCustomBase + 2

If a non-zero cookie is passed in, we're editing an existing network with existing credentials. The WPPI should find the credentials in its database and put them in a temporary location. If a zero cookie is passed in, we're either creating a new network, editing an existing network that didn't previous have credentials, or switching authentication methods. The WPPI should set the credentialsLabel and credentialsSelectorTrigger. Typically, the credentialsLabel is "Credentials:" and the credentialsSelectorTrigger is "-Assigned-" or "-Unassigned-". Every call to sysWPPILaunchCmdOpen is matched with a call to sysWPPILaunchCmdClose.

Definition at line 128 of file PalmWPPI.h.

#define sysWPPILaunchCmdDelete sysAppLaunchCmdCustomBase + 4

The WPPI should open its dialog and allow the user to edit the credentials. It should read from the temporary location to initialize the username and password fields or other UI elements as appropriate. It should write to the temporary location when the user taps OK. It shouldn't access its database. Whether the user tapped Cancel should be stored in the cancel flag in the command parameter block. If the user taps OK and this changes the current credentials state (typically assigned/unassigned), the credentialsSelectorTrigger field should be updated by the WPPI. Note that the user may delete his credentials causing the state to change from assigned to unassigned.

Definition at line 147 of file PalmWPPI.h.

#define sysWPPILaunchCmdDialog sysAppLaunchCmdCustomBase + 3

If the save flag is set, the WPPI should write the user's credentials to its database. If the cookie is zero, it should create a new record and save its unique ID in the cookie field of the command parameter block. If the cookie is non-zero, it should overwrite the old record.

Definition at line 135 of file PalmWPPI.h.

#define sysWPPILaunchCmdErrorDialog (sysAppLaunchCmdCustomBase + 7)

This is invoked to put up an error dialog.

Definition at line 196 of file PalmWPPI.h.

#define sysWPPILaunchCmdGetAuthenticationMethods sysAppLaunchCmdCustomBase

Definition at line 55 of file PalmWPPI.h.

#define sysWPPILaunchCmdGetDescription sysAppLaunchCmdCustomBase + 5

Finally, the Wi-Fi Setup wizard displays a detailed description of the selected authentication method. To do this, it sublaunches the WPPI with the following launch code and command parameter block.

Definition at line 160 of file PalmWPPI.h.

#define sysWPPILaunchCmdOpen sysAppLaunchCmdCustomBase + 1

Definition at line 117 of file PalmWPPI.h.

#define sysWPPILaunchCmdPromptAndConfigure (sysAppLaunchCmdCustomBase + 6)

This is invoked to bring up the prompt dialog (WPPI decides if prompt is necessary) or pass any kind of data to the WPPI. Optionally, before exiting, a WPPI can set the netIFSettingDot1XConfig setting to pass information back to the 802.1X plugin.

Definition at line 183 of file PalmWPPI.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:00 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » pmconnectorlib

PmConnectorLib.h File Reference

Detailed Description

palmOne library that exports multi-connector related APIs.

Definition in file PmConnectorLib.h.

Include dependency graph for PmConnectorLib.h:

Go to the source code of this file.

Defines

  • #define PMCONNECTOR_LIB_TRAP(trapNum) SYS_TRAP(trapNum)

Functions

  • Err PmConnectorLibOpen (UInt16 refNum)(kPmConnectorLibTrapOpen)
    Standard library open routine.
  • Err PmConnectorLibClose (UInt16 refNum)(kPmConnectorLibTrapClose)
    Standard library close routine.
  • Err PmConnectorLibSleep (UInt16 refNum)(kPmConnectorLibTrapSleep)
    Standard library sleep routine.
  • Err PmConnectorLibWake (UInt16 refNum)(kPmConnectorLibTrapWake)
    Standard library wake routine.
  • Err PmConnectorLibGetVersion (UInt16 refNum, UInt32 sdkVersion, UInt32 *LibVersionP)(kPmConnectorLibTrapGetVersion)
    Checks the version of the library present on the device.
  • Err PmConnectorLibControl (UInt16 refNum, UInt16 cmdId, void *parmP)(kPmConnectorLibTrapControl)
    Controls the pins on the connector. Currently supports power on and off.
  • Err PmConnectorLibSetAudioOutput (UInt16 refNum, PmConnectorAudioOutputSettingType outputSetting)(kPmConnectorLibTrapSetAudioOutput)
    Targets audio output to different audio peripherals.
  • Err PmConnectorLibSetAudioInput (UInt16 refNum, PmConnectorAudioInputSettingType inputSetting)(kPmConnectorLibTrapSetAudioInput)
    Targets audio input from different audio peripherals.

Define Documentation

#define PMCONNECTOR_LIB_TRAP ( trapNum ) SYS_TRAP(trapNum)

Definition at line 26 of file PmConnectorLib.h.

Function Documentation

Err PmConnectorLibClose ( UInt16 refNum )

Standard library close routine.

Parameters:
refNum,: IN: library reference number
Return values:
Err Error code.

Err PmConnectorLibControl | ( | UInt16 | refNum,
 |  | UInt16 | cmdId,
 |  | void * | parmP
 | ) |  |

Controls the pins on the connector. Currently supports power on and off.

Parameters:
refNum,: IN: library reference number
cmdId,: IN: type of control.
See also:
PmConnectorLibControlType
Parameters:
parmP,: IN: contains the value needed depending on type of control
Return values:
Err Error code.

Err PmConnectorLibGetVersion | ( | UInt16 | refNum,
 |  | UInt32 | sdkVersion,
 |  | UInt32 * | LibVersionP
 | ) |  |

Checks the version of the library present on the device.

Parameters:
refNum,: IN: library reference number
sdkVersion,: IN: sdkVersion defined in the common header file
LibVersionP,: IN: version of the library on the device
Return values:
Err Error code. Function returns error when it finds incompatible library

Err PmConnectorLibOpen ( UInt16 refNum )

Standard library open routine.

Parameters:
refNum,: IN: library reference number
Return values:
Err Error code.

Err PmConnectorLibSetAudioInput | ( | UInt16 | refNum,
 |  | PmConnectorAudioInputSettingType | inputSetting
 | ) |  |

Targets audio input from different audio peripherals.

Parameters:
refNum IN: library reference number
inputSetting,: IN: audio capabilities (headset etc)
Return values:
Err Error code.

Err PmConnectorLibSetAudioOutput | ( | UInt16 | refNum,
 |  | PmConnectorAudioOutputSettingType | outputSetting
 | ) |  |

Targets audio output to different audio peripherals.

Parameters:
refNum IN: library reference number
outputSetting,: IN: audio capabilities (headphone, speaker, etc)
Return values:
Err Error code.

Err PmConnectorLibSleep ( UInt16 refNum )

Standard library sleep routine.

Parameters:
refNum,: IN: library reference number
Return values:
Err Error code.

Err PmConnectorLibWake ( UInt16 refNum )

Standard library wake routine.

Parameters:
refNum,: IN: library reference number
Return values:
Err Error code.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:00 2008 for Palm API Guide


Header Files » Incs » common » libraries » pmconnectorlib

PmConnectorLibCommon.h File Reference

Detailed Description

Public 68k common header file for Multi-Connector Library for palmOne devices that use multi-connector.

This file contains common structures, types and defines for palmOne library that exports multi-connector related APIs.

Definition in file PmConnectorLibCommon.h.

Include dependency graph for PmConnectorLibCommon.h:

Go to the source code of this file.

Data Structures

  • struct PmConnectorNotifyDataType
    Container for the notification details. More...

Defines

  • #define kPmConnectorLibType sysFileTLibrary
  • #define kPmConnectorLibCreator 'PmAt'
  • #define kPmConnectorLibName "PmConnector"
  • #define kPmConnectorNotifyType 'PmCo'
  • #define kPmConnectorNotifySysAttach sysExternalConnectorAttachEvent
  • #define kPmConnectorNotifySysDetach sysExternalConnectorDetachEvent
  • #define kPmDockStatusCharging 0x08
  • #define kPmDockStatusUSBCradle 0x10
  • #define kPmDockStatusSerialPeripheral 0x40
  • #define kPmConnectorLibVersion sysMakeROMVersion(1, 3, 2, sysROMStageRelease, 0)
Function Traps
  • #define kPmConnectorLibTrapOpen sysLibTrapOpen
  • #define kPmConnectorLibTrapClose sysLibTrapClose
  • #define kPmConnectorLibTrapSleep sysLibTrapSleep
  • #define kPmConnectorLibTrapWake sysLibTrapWake
  • #define kPmConnectorLibTrapGetVersion (sysLibTrapCustom + 0)
  • #define kPmConnectorLibTrapControl (sysLibTrapCustom + 1)
  • #define kPmConnectorLibTrapSetAudioOutput (sysLibTrapCustom + 2)
  • #define kPmConnectorLibTrapSetAudioInput (sysLibTrapCustom + 3)
Error Codes
  • #define kPmConnectorLibErrorClass (oemErrorClass + 0x100)
  • #define kPmConnectorLibErrBadParam (kPmConnectorLibErrorClass | 0x01)
  • #define kPmConnectorLibErrNoMemory (kPmConnectorLibErrorClass | 0x02)
  • #define kPmConnectorLibErrNotOpen (kPmConnectorLibErrorClass | 0x03)
  • #define kPmConnectorLibErrStillOpen (kPmConnectorLibErrorClass | 0x04)
  • #define kPmConnectorLibErrInternal (kPmConnectorLibErrorClass | 0x05)
  • #define kPmConnectorLibErrNotSupported (kPmConnectorLibErrorClass | 0x06)
  • #define kPmConnectorLibErrNotCompatible (kPmConnectorLibErrorClass | 0x07)
Control commands for Connector
  • #define kPmConnectorLibCtrlPowerOn 0x01
  • #define kPmConnectorLibCtrlPowerOff 0x02
  • #define kPmConnectorLibCtrlGetDeviceClass 0x03
Notification Constants
  • #define kPmConnectorClassAudioWHeadset 0x05
  • #define kPmConnectorClassAudioNoHeadset 0x00
  • #define kPmConnectorClassCarkit 0x01
  • #define kPmConnectorClassGenericSerial 0x03
  • #define kPmConnectorClassSmartSerial 0x07
  • #define kPmConnectorClassSerial 0x10
  • #define kPmConnectorClassUSB 0xf0
  • #define kPmConnectorClassUnknown 0x00ff
  • #define kPmConnectorClassNoDevice 0x0fff
  • #define kPmConnectorClassMask 0x0fff

Typedefs

  • typedef UInt16 PmConnectorStateType
  • typedef enum tagAudioOutputSetting ePmConnectorAudioOutputSettingsType
    Audio Output Routings.
  • typedef UInt16 PmConnectorAudioOutputSettingType
  • typedef enum tagAudioInputSetting ePmConnectorAudioInputSettingsType
  • typedef UInt16 PmConnectorAudioInputSettingType
  • typedef UInt16 PmConnectorLibControlType

Enumerations

  • enum ePmConnectorDeviceState {
    kPmConnectorDeviceAttach = 0x8000,
    kPmConnectorDeviceDetach = 0x4000
    }
    State of the connector. More...
  • enum tagAudioOutputSetting {
    kAudioOutputSettingDefault = 0,
    kAudioOutputSettingHeadphone,
    kAudioOutputSettingAthena,
    kAudioOutputSettingSpeaker
    }
    Audio Output Routings. More...
  • enum tagAudioInputSetting {
    kAudioInputDefault = 0,
    kAudioInputExternalMic,
    kAudioInputInternalMic
    }

Define Documentation

#define kPmConnectorClassAudioNoHeadset 0x00

Definition at line 121 of file PmConnectorLibCommon.h.

#define kPmConnectorClassAudioWHeadset 0x05

Definition at line 120 of file PmConnectorLibCommon.h.

#define kPmConnectorClassCarkit 0x01

Definition at line 122 of file PmConnectorLibCommon.h.

#define kPmConnectorClassGenericSerial 0x03

Definition at line 123 of file PmConnectorLibCommon.h.

#define kPmConnectorClassMask 0x0fff

Definition at line 129 of file PmConnectorLibCommon.h.

#define kPmConnectorClassNoDevice 0x0fff

Definition at line 128 of file PmConnectorLibCommon.h.

#define kPmConnectorClassSerial 0x10

Definition at line 125 of file PmConnectorLibCommon.h.

#define kPmConnectorClassSmartSerial 0x07

Definition at line 124 of file PmConnectorLibCommon.h.

#define kPmConnectorClassUnknown 0x00ff

Definition at line 127 of file PmConnectorLibCommon.h.

#define kPmConnectorClassUSB 0xf0

Definition at line 126 of file PmConnectorLibCommon.h.

#define kPmConnectorLibCreator 'PmAt'

Definition at line 39 of file PmConnectorLibCommon.h.

#define kPmConnectorLibCtrlGetDeviceClass 0x03

Definition at line 109 of file PmConnectorLibCommon.h.

#define kPmConnectorLibCtrlPowerOff 0x02

Definition at line 108 of file PmConnectorLibCommon.h.

#define kPmConnectorLibCtrlPowerOn 0x01

Definition at line 107 of file PmConnectorLibCommon.h.

#define kPmConnectorLibErrBadParam (kPmConnectorLibErrorClass | 0x01)

Definition at line 84 of file PmConnectorLibCommon.h.

#define kPmConnectorLibErrInternal (kPmConnectorLibErrorClass | 0x05)

Definition at line 92 of file PmConnectorLibCommon.h.

#define kPmConnectorLibErrNoMemory (kPmConnectorLibErrorClass | 0x02)

Definition at line 86 of file PmConnectorLibCommon.h.

#define kPmConnectorLibErrNotCompatible (kPmConnectorLibErrorClass | 0x07)

Definition at line 96 of file PmConnectorLibCommon.h.

#define kPmConnectorLibErrNotOpen (kPmConnectorLibErrorClass | 0x03)

Definition at line 88 of file PmConnectorLibCommon.h.

#define kPmConnectorLibErrNotSupported (kPmConnectorLibErrorClass | 0x06)

Definition at line 94 of file PmConnectorLibCommon.h.

#define kPmConnectorLibErrorClass (oemErrorClass + 0x100)

Definition at line 82 of file PmConnectorLibCommon.h.

#define kPmConnectorLibErrStillOpen (kPmConnectorLibErrorClass | 0x04)

Definition at line 90 of file PmConnectorLibCommon.h.

#define kPmConnectorLibName "PmConnector"

Definition at line 40 of file PmConnectorLibCommon.h.

#define kPmConnectorLibTrapClose sysLibTrapClose

Definition at line 58 of file PmConnectorLibCommon.h.

#define kPmConnectorLibTrapControl (sysLibTrapCustom + 1)

Definition at line 62 of file PmConnectorLibCommon.h.

#define kPmConnectorLibTrapGetVersion (sysLibTrapCustom + 0)

Definition at line 61 of file PmConnectorLibCommon.h.

#define kPmConnectorLibTrapOpen sysLibTrapOpen

Definition at line 57 of file PmConnectorLibCommon.h.

#define kPmConnectorLibTrapSetAudioInput (sysLibTrapCustom + 3)

Definition at line 64 of file PmConnectorLibCommon.h.

#define kPmConnectorLibTrapSetAudioOutput (sysLibTrapCustom + 2)

Definition at line 63 of file PmConnectorLibCommon.h.

#define kPmConnectorLibTrapSleep sysLibTrapSleep

Definition at line 59 of file PmConnectorLibCommon.h.

#define kPmConnectorLibTrapWake sysLibTrapWake

Definition at line 60 of file PmConnectorLibCommon.h.

#define kPmConnectorLibType sysFileTLibrary

Definition at line 38 of file PmConnectorLibCommon.h.

#define kPmConnectorLibVersion sysMakeROMVersion(1, 3, 2, sysROMStageRelease, 0)

Definition at line 70 of file PmConnectorLibCommon.h.

#define kPmConnectorNotifySysAttach sysExternalConnectorAttachEvent

Definition at line 42 of file PmConnectorLibCommon.h.

#define kPmConnectorNotifySysDetach sysExternalConnectorDetachEvent

Definition at line 43 of file PmConnectorLibCommon.h.

#define kPmConnectorNotifyType 'PmCo'

Definition at line 41 of file PmConnectorLibCommon.h.

#define kPmDockStatusCharging 0x08

Definition at line 46 of file PmConnectorLibCommon.h.

#define kPmDockStatusSerialPeripheral 0x40

Definition at line 48 of file PmConnectorLibCommon.h.

#define kPmDockStatusUSBCradle 0x10

Definition at line 47 of file PmConnectorLibCommon.h.

Typedef Documentation

typedef enum tagAudioInputSetting ePmConnectorAudioInputSettingsType

typedef enum tagAudioOutputSetting ePmConnectorAudioOutputSettingsType

Audio Output Routings.

typedef UInt16 PmConnectorAudioInputSettingType

Definition at line 171 of file PmConnectorLibCommon.h.

typedef UInt16 PmConnectorAudioOutputSettingType

Audio Output setting type

Definition at line 162 of file PmConnectorLibCommon.h.

typedef UInt16 PmConnectorLibControlType

Library control type

Definition at line 175 of file PmConnectorLibCommon.h.

typedef UInt16 PmConnectorStateType

Definition at line 139 of file PmConnectorLibCommon.h.

Enumeration Type Documentation

enum ePmConnectorDeviceState

State of the connector.

Enumerator:
kPmConnectorDeviceAttach | is currently attached
kPmConnectorDeviceDetach | is currently detached

Definition at line 134 of file PmConnectorLibCommon.h.

00134              {
00135     kPmConnectorDeviceAttach = 0x8000,  /**< is currently attached */
00136     kPmConnectorDeviceDetach = 0x4000   /**< is currently detached */
00137 } ePmConnectorDeviceState;

enum tagAudioInputSetting

Enumerator:
kAudioInputDefault
kAudioInputExternalMic
kAudioInputInternalMic

Definition at line 164 of file PmConnectorLibCommon.h.

00165 {
00166     kAudioInputDefault = 0,  //device should do something reaasonable based on its current capabilities
00167     kAudioInputExternalMic,
00168     kAudioInputInternalMic
00169 } ePmConnectorAudioInputSettingsType;

enum tagAudioOutputSetting

Audio Output Routings.

Enumerator:
kAudioOutputSettingDefault
kAudioOutputSettingHeadphone
kAudioOutputSettingAthena
kAudioOutputSettingSpeaker

Definition at line 153 of file PmConnectorLibCommon.h.

00154 {
00155     kAudioOutputSettingDefault = 0,  //device should do something reaasonable based on its current capabilities
00156     kAudioOutputSettingHeadphone,
00157     kAudioOutputSettingAthena,
00158     kAudioOutputSettingSpeaker
00159 } ePmConnectorAudioOutputSettingsType;

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:00 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » pmkeylib

PmKeyLib.h File Reference

Detailed Description

System Library that exports key-related APIs.

This library is based on key APIs from HsExtensions and was broken apart from HsExtensions so the APIs could be ported to other platforms.

Definition in file PmKeyLib.h.

Include dependency graph for PmKeyLib.h:

Go to the source code of this file.

Functions

  • Err PmKeyLibOpen (UInt16 refNum)
  • Err PmKeyLibClose (UInt16 refNum)
  • UInt16 PmKeyKeysPressed (UInt16 refNum, UInt16 count, const UInt16 keyCodes[], Boolean pressed[])
  • Err PmKeyStop (UInt16 refNum, UInt16 keyCode)
  • Boolean PmKeyEnableKey (UInt16 refNum, UInt16 keyCode, Boolean enabled)
  • UInt16 PmKeyChrCodeToKeyCode (UInt16 refNum, UInt16 chrCode)
  • void PmKeyKeyCodeToChrCode (UInt16 refNum, UInt16 keyCode, UInt16 modifiersIn, UInt16 *chrP, UInt16 *modifiersOutP)
  • Boolean PmKeyEventIsFromKeyboard (UInt16 refNum, EventPtr eventP)
  • Err PmKeyAttrGet (UInt16 refNum, UInt16 attr, UInt32 flags, UInt32 *valueP)
  • Err PmKeyAttrSet (UInt16 refNum, UInt16 attr, UInt32 flags, UInt32 value)

Function Documentation

Err PmKeyAttrGet | ( | UInt16 | refNum,
 |  | UInt16 | attr,
 |  | UInt32 | flags,
 |  | UInt32 * | valueP
 | ) |  |

Get any palmOne specific key attributes that aren't appropriate to be accessed through a feature. (e.g. dynamic information about device state)

The following code sample retrieves the keyguard state (active or inactive) and disables it accordingly.

     UInt32 keyguard;
     PmKeyAttrGet (pmKeyAttrKeyboardLocked, 0, &keyguard);
     if (keyguard)
     {
         keyguard = 0;
         PmKeyAttrSet (pmKeyAttrKeyboardLocked, 0, &keyguard);
     }

Note that there are new attributes added for version 3 of the PmKeyAttrGet() function, so it is highly recommended that any application that calls this function does one or both of the following:

Check the return code. If its hsErrNotSupported, then the attribute that the function is looking for is NOT SUPPORTED using that particular version of the library!

  • OR -

Check the version number of the PmKeyLib. To do this, load the PmKeyLib and then get the feature with creator = kPmKeyLibCreator and featureNum = kPmKeyLibFtrValAPIVersion. Note that if the feature does not exist (and the library successfully loaded), they can assume that it's version 1.0 of PmKeyLib. If the feature does exist, then perform a check similar to the following:

   if (sysGetLibAPIVersionMajor(pmKeyLibVersion) >= 3)
   {
    PmKeyAttrGet ( Version3Attribute, 0 , &value );
   }
    else
    {
      // PmKeyLib is version 2, use ONLY version 2 attributes for PmKeyAttrGet
    PmKeyAttrGet ( Version2Attribute, 0 , &value );
    }

Parameters:
refNum,: IN: library reference number (returned by SysLibFind() / SysLibLoad() )
attr,: IN: the attribute being retrieved
See also:
PmKeyAttrEnum
Parameters:
flags,: IN: depends on attr (currently implemented attributes only take 0 for this argument)
valueP,: OUT: cast depending on attr (refer to PmKeyAttrEnum for data type this argument should point to)
Return values:
Err error code. 0 if no error, hsErrNotSupported otherwise.

Err PmKeyAttrSet | ( | UInt16 | refNum,
 |  | UInt16 | attr,
 |  | UInt32 | flags,
 |  | UInt32 | value
 | ) |  |

Set palmOne specific attributes

Parameters:
attr,: IN: the attribute being set
flags,: IN: depends on attr (currently implemented attributes only take 0 for this argument)
value,: IN: cast depending on attr (refert to PmKeyAttrEnum for data type this argument should point to)
Return values:
Err error code. 0 if no error, hsErrNotSupported otherwise.

UInt16 PmKeyChrCodeToKeyCode | ( | UInt16 | refNum,
 |  | UInt16 | chrCode
 | ) |  |

Determine which key generates a certain character This is the complement of HALKeyKeyCodeToChrCode()

Parameters:
refNum,: IN: library reference number (returned by SysLibFind() / SysLibLoad() )
chrCode,: IN: the character to search for
Return values:
UInt16 the keycode returned.

Boolean PmKeyEnableKey | ( | UInt16 | refNum,
 |  | UInt16 | keyCode,
 |  | Boolean | enabled
 | ) |  |

Enable/disable a key from generating key events. This extends HALKeySetMask().

Parameters:
refNum,: IN: library reference number (returned by SysLibFind() / SysLibLoad() )
keyCode,: IN: the key to enable/disable
enabled,: IN: true to enable, false to disable
Return values:
Boolean true if previously enabled

Boolean PmKeyEventIsFromKeyboard | ( | UInt16 | refNum,
 |  | EventPtr | eventP
 | ) |  |

Determine if an event came from the physical keyboard

Parameters:
refNum,: IN: library reference number (returned by SysLibFind() / SysLibLoad() )
eventP,: IN: the event to check
Return values:
Boolean true if the event came from the keyboard

void PmKeyKeyCodeToChrCode | ( | UInt16 | refNum,
 |  | UInt16 | keyCode,
 |  | UInt16 | modifiersIn,
 |  | UInt16 * | chrP,
 |  | UInt16 * | modifiersOutP
 | ) |  |

Translate a key code to the character generated by that key. Each key can generate several different characters, depending on which modifier keys are held when it is pressed. The caller needs to specify which modified state of the key should be used to select the appropriate character. This is the complement of HALKeyChrCodeToKeyCode().

Parameters:
refNum,: IN: library reference number (returned by SysLibFind() / SysLibLoad() )
keyCode,: IN: the key to lookup
modifiersIn,: IN: Modifier mask indicating which character should be returned
chrP,: OUT: The character produced by the key
modifiersOutP,: OUT: The keyMask bits that must be set if a keyDown event is formed with the character. (Not including the bits set in modifiersIn)
Return values:
None.

UInt16 PmKeyKeysPressed | ( | UInt16 | refNum,
 |  | UInt16 | count,
 |  | const UInt16 | keyCodes[],
 |  | Boolean | pressed[]
 | ) |  |

Get the current state of specified keys

Parameters:
refNum,: IN: library reference number (returned by SysLibFind() / SysLibLoad() )
count,: IN: number of elements in keyCodes[] and pressed[]
keyCodes,: IN: array of keyCodes to test
pressed,: OUT: Each element is set to true if the key specified by the corresponding element in keyCodes[] is pressed, and set to false if it is not pressed. It is acceptable to pass NULL if only the return value is of interest.
Return values:
UInt16 count of keys that are pressed.

Err PmKeyLibClose ( UInt16 refNum )

Standard close library function

Parameters:
refNum,: IN: library reference number (returned by SysLibFind() / SysLibLoad() )
Return values:
Err error code.

Err PmKeyLibOpen ( UInt16 refNum )

Standard open library function

Parameters:
refNum,: IN: library reference number (returned by SysLibFind() / SysLibLoad() )
Return values:
Err error code.

Err PmKeyStop | ( | UInt16 | refNum,
 |  | UInt16 | keyCode
 | ) |  |

Stop a key from sending any more auto repeat events until it is released.

Parameters:
refNum,: IN: library reference number (returned by SysLibFind() / SysLibLoad() )
keyCode,: IN: key to stop
Return values:
Err errNone if the keyCode is the last key pressed and it is still held.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:01 2008 for Palm API Guide


Header Files » Incs » common » libraries » pmkeylib

PmKeyLibCommon.h File Reference

Detailed Description

Public 68k common header file for system library that exports key-related APIs.

This library is based on key APIs from HsExtensions and was broken apart from HsExtensions so the APIs could be ported to other platforms.

Definition in file PmKeyLibCommon.h.

Include dependency graph for PmKeyLibCommon.h:

Go to the source code of this file.

Defines

  • #define kPmKeyLibType sysFileTLibrary
  • #define kPmKeyLibCreator pmFileCKeyLib
  • #define kPmKeyLibName "PmKeyLib-PmKe"
  • #define kPmKeyLibAPIMajorVersion 3
  • #define kPmKeyLibAPIMinorVersion 0
  • #define kPmKeyLibAPIVersion sysMakeLibAPIVersion(kPmKeyLibAPIMajorVersion, kPmKeyLibAPIMinorVersion)
Feature values
  • #define kPmKeyLibFtrValAPIVersion 0
Function Traps
  • #define kPmKeyLibTrapOpen sysLibTrapOpen
  • #define kPmKeyLibTrapClose sysLibTrapClose
  • #define kPmKeyLibTrapKeysPressed (sysLibTrapCustom)
  • #define kPmKeyLibTrapStop (sysLibTrapCustom+1)
  • #define kPmKeyLibTrapEnableKey (sysLibTrapCustom+2)
  • #define kPmKeyLibTrapChrCodeToKeyCode (sysLibTrapCustom+3)
  • #define kPmKeyLibTrapKeyCodeToChrCode (sysLibTrapCustom+4)
  • #define kPmKeyLibTrapEventIsFromKeyboard (sysLibTrapCustom+5)
  • #define kPmKeyLibTrapAttrGet (sysLibTrapCustom+6)
  • #define kPmKeyLibTrapAttrSet (sysLibTrapCustom+7)

Typedefs

  • typedef UInt16 PmKeyAttrEnum

Enumerations

  • enum PmKeyAttrEnumTag {
    pmKeyAttrPagingMode,
    pmKeyAttrGetLauncherKeyCode,
    pmKeyAttrGetMenuKeyCode,
    pmKeyAttrGetSendKeyCode,
    pmKeyAttrGetEndKeyCode,
    pmKeyAttrGetPhoneKeyCode
    }

Define Documentation

#define kPmKeyLibAPIMajorVersion 3

Major version incremented when API changes

Definition at line 41 of file PmKeyLibCommon.h.

#define kPmKeyLibAPIMinorVersion 0

Minor version incremented with each release of library that doesn't change the API

Definition at line 43 of file PmKeyLibCommon.h.

#define kPmKeyLibAPIVersion sysMakeLibAPIVersion(kPmKeyLibAPIMajorVersion, kPmKeyLibAPIMinorVersion)

Definition at line 46 of file PmKeyLibCommon.h.

#define kPmKeyLibCreator pmFileCKeyLib

PmKeyLib creator ID

Definition at line 39 of file PmKeyLibCommon.h.

#define kPmKeyLibFtrValAPIVersion 0

Feature value used to get/set library API version (kPmKeyLibAPIVersion). Note that the first release of the library did not set this feature. Therefore, if the library does exist but the feature does not, you can assume the major version of the library is 1. Note also that the feature is not set until library is loaded so you must load PmKeyLib before getting the feature

Definition at line 53 of file PmKeyLibCommon.h.

#define kPmKeyLibName "PmKeyLib-PmKe"

PmKeyLib database name

Definition at line 40 of file PmKeyLibCommon.h.

#define kPmKeyLibTrapAttrGet (sysLibTrapCustom+6)

Definition at line 118 of file PmKeyLibCommon.h.

#define kPmKeyLibTrapAttrSet (sysLibTrapCustom+7)

Definition at line 119 of file PmKeyLibCommon.h.

#define kPmKeyLibTrapChrCodeToKeyCode (sysLibTrapCustom+3)

Definition at line 115 of file PmKeyLibCommon.h.

#define kPmKeyLibTrapClose sysLibTrapClose

Definition at line 111 of file PmKeyLibCommon.h.

#define kPmKeyLibTrapEnableKey (sysLibTrapCustom+2)

Definition at line 114 of file PmKeyLibCommon.h.

#define kPmKeyLibTrapEventIsFromKeyboard (sysLibTrapCustom+5)

Definition at line 117 of file PmKeyLibCommon.h.

#define kPmKeyLibTrapKeyCodeToChrCode (sysLibTrapCustom+4)

Definition at line 116 of file PmKeyLibCommon.h.

#define kPmKeyLibTrapKeysPressed (sysLibTrapCustom)

Definition at line 112 of file PmKeyLibCommon.h.

#define kPmKeyLibTrapOpen sysLibTrapOpen

Definition at line 110 of file PmKeyLibCommon.h.

#define kPmKeyLibTrapStop (sysLibTrapCustom+1)

Definition at line 113 of file PmKeyLibCommon.h.

#define kPmKeyLibType sysFileTLibrary

standard library type

Definition at line 38 of file PmKeyLibCommon.h.

Typedef Documentation

typedef UInt16 PmKeyAttrEnum

Definition at line 100 of file PmKeyLibCommon.h.

Enumeration Type Documentation

enum PmKeyAttrEnumTag

Enumerator:
pmKeyAttrPagingMode | Whether currently pressed key is in page mode
pmKeyAttrGetLauncherKeyCode | Returns the key code for the Launcher key
pmKeyAttrGetMenuKeyCode | Returns the key code for the Menu key
pmKeyAttrGetSendKeyCode | Returns the key code for the Send key
pmKeyAttrGetEndKeyCode | Returns the key code for the End key
pmKeyAttrGetPhoneKeyCode | Returns the key code for the Phone key

Definition at line 71 of file PmKeyLibCommon.h.

00072 {
00073   /*
00074    * End of enums in API version 1 (no enums defined in version 1)
00075    */
00076
00077
00078   pmKeyAttrPagingMode,          /**< Whether currently pressed key is in page mode */
00079
00080   /*
00081    * End of enums in API version 2
00082    */
00083
00084   pmKeyAttrGetLauncherKeyCode,  /**< Returns the key code for the Launcher key */
00085   pmKeyAttrGetMenuKeyCode,      /**< Returns the key code for the Menu key */
00086   pmKeyAttrGetSendKeyCode,      /**< Returns the key code for the Send key */
00087   pmKeyAttrGetEndKeyCode,       /**< Returns the key code for the End key */
00088   pmKeyAttrGetPhoneKeyCode      /**< Returns the key code for the Phone key */
00089
00090   /*
00091    * End of enums in API version 3
00092    */
00093
00094
00095   /*
00096    * Attributes greater than 0x9000 are defined for internal use
00097    * in Prv/PmPrvKeyLibCommon.h
00098    */
00099 };

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:01 2008 for Palm API Guide


Header Files » Incs » common » libraries

PmLibErrors.h File Reference

Detailed Description

Errors common to all our portable Pm Libraries.

Definition in file PmLibErrors.h.

Include dependency graph for PmLibErrors.h:

Go to the source code of this file.

Defines

  • #define pmErrNotSupported (pmLibErrorClass | 0x01)

Define Documentation

#define pmErrNotSupported (pmLibErrorClass | 0x01)

Definition at line 30 of file PmLibErrors.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:01 2008 for Palm API Guide


Header Files » Incs » 68k » system

PmPalmOSNVFS.h File Reference

Detailed Description

Public 68k header file containing the definitions and API for NVFS devices.

Definition in file PmPalmOSNVFS.h.

Go to the source code of this file.

Defines

  • #define sysFtrNumDmAutoBackup 31
  • #define vfsVolumeAttrNonRemovable (0x00000008UL)
  • #define expCapabilityNonRemovable 0x00000008
  • #define expCapabilityHidden 0x00000010
  • #define sysTrapDmSyncDatabase 0xA476
  • #define vfsIncludePrivateVolumes 0x80000000
  • #define expIncludePrivateSlots 0x80000000
  • #define dbCacheFlag 0x8000

Functions

  • Err DmSyncDatabase (DmOpenRef dbRef)
    Commit changes in the database to the non-volatile memory.

Define Documentation

#define dbCacheFlag 0x8000

Flag is used in query the DbCache size when ORd with Storage heap id

Definition at line 29 of file PmPalmOSNVFS.h.

#define expCapabilityHidden 0x00000010

card is hidden

Definition at line 25 of file PmPalmOSNVFS.h.

#define expCapabilityNonRemovable 0x00000008

card is non-removable

Definition at line 24 of file PmPalmOSNVFS.h.

#define expIncludePrivateSlots 0x80000000

Use this flag to show hidden expansion slots if the device supports hidden slots

Definition at line 28 of file PmPalmOSNVFS.h.

#define sysFtrNumDmAutoBackup 31

Is Data Manager Auto Backup supported?

Definition at line 22 of file PmPalmOSNVFS.h.

#define sysTrapDmSyncDatabase 0xA476

Definition at line 26 of file PmPalmOSNVFS.h.

#define vfsIncludePrivateVolumes 0x80000000

Use this flag to show hidden volumes if the device supports hidden volumes

Definition at line 27 of file PmPalmOSNVFS.h.

#define vfsVolumeAttrNonRemovable (0x00000008UL)

media is non-removable

Definition at line 23 of file PmPalmOSNVFS.h.

Function Documentation

Err DmSyncDatabase ( DmOpenRef dbRef )

Commit changes in the database to the non-volatile memory.

Parameters:
dbRef,: IN: Reference to the opened database to be synced/committed
Return values:
Err error code.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:01 2008 for Palm API Guide


Header Files » Incs » common » libraries » hssoundlib

PmSoundLibAudioGroup.h File Reference

Detailed Description

Public 68K header file used to associate sound channels with Audio groups on Treo 600 and Treo 650 smartphones.

We define the concept of Audio Groups to classify sounds depending on the relative importance to the user:

pmAudioGroupApp Audio normally generated by user applications such as games, MP3 players, and others. This is the default classification even if no audio group is assigned.

pmAudioGroupSystem Typical audio events generated by the system to give audible feedback to the user about system events. Most of the sounds produced through SndPlaySystemSound are classified internally as System.

pmAudioGroupAlert Alerts, Alarms, and Ringtones should be given this classification. If you depend on the Attention Manager to make a sound, it will also use this classification. The constant sndAlarm when calling SndPlaySystemSound is classified as an Alert.

pmAudioGroupHighPriority Sounds of great importance to the user and that are routed with the highest priority. We currently define hsSndBatLow and hsSndBatShutdown constants, when calling SndPlaySystemSound, as high priority sounds.

If you depend on PalmOS Attention Manager for audio alerts, or use PalmOS SndPlaySystemSound, then the audio group is automatically assigned, and there is nothing else you need to do.

However, if you directly play audio events using other PalmOS APIs such as SndPlayResource, or SndStreamCreate, for example, then you may want to assign the audio group, unless the default pmAudioGroupApp is sufficient for your purposes.

To assign an audio group we attach that additional information to the PalmOS volume parameter associated with many of the Sound Manager API calls. We have found this is the most effective way to associate the audio group to a sound channel, and have that information filter down, through PalmOS, to our Audio Driver in the Hardware Abstraction Layer (HAL). In this way, there is no need to modify PalmOS, and we can allow a variety of components and applications to take advantage of the behavior and custom routing we assign to the different audio group classifications.

The drawback is that when the audio group is attached to the volume parameter, then the volume is limited to a maximum of 8K - 1, in steps of 8 (which represents 128 levels to unity). In contrast PalmOS 5.x volume parameter is defined with a maximum of 32K - 1, in steps of 1 (which represents 1024 levels to unity). Our constrain is generally acceptable, since it represents granularity of about 1 dB step changes, with up to 8X amplification We currently use less precise granularity of > 10 db step changes, and a maximum of 6X amplification for the case of QCELP/AMR playback.

There is a risk that an existing application using the PalmOS API may apply a volume parameter that could be mistaken for a volume plus audio group designation, but this risk is fairly minimal as explained next.

The Audio Group uses a mark in the upper 3-bits of the volume parameter. If this mark is binary '011' which means a positive number >= 24K, then we will interpret the lower three bits as the audio group. The risk of mistaken interpretation from existing PalmOS applications will happen when the application request amplifications of 24X to 32X. In our experience we have Not seen any application going beyond the range of 2X to 8X amplification. In case such extremely rare condition do occurs, the effect would be that the range 24X to 32X will be treated as the lower range of 0X to 8X, and there is a chance the sound will be routed/treated as other than application audio.

One more thing to note is that PalmOS allows negative numbers in the volume parameter to mean one of the usual volume parameters the user may adjust through the preferences panel: system volume, game volume, and alarm volume. In our current implementation we do NOT change these values, and we do NOT assign any audio group designation to these preferences driven volume settings. In other words, they will be treated as application audio group.

The use of Audio Group in a device will be present when the feature is registered with the PalmOS Feature Manager. This feature will be available when:

FtrGet( pmSoundLibCreatorID, pmSoundLibAudioGroupFtr, &value );

return no error, and the UInt32 value is NOT:

pmSoundLibAudioGroupFtr_Off

It is important to always check for this feature, since this is a custom enhancement which could be turned off for some future device, or platform.

To assign an audio group to your volume parameter you will invoke the function PmSndAddAudioGroupToVolume (currently implemented as a macro for simplicity). Here is an example on how to use this:

      // Includes
      #include <FeatureMgr.h>
      #include <Common/Libraries/HsSoundLib/PmSoundLibAudioGroup.h>

      // Declarations
      UInt32 value  = 0;    // temporary variable for FtrGet
      Int32  volume = 1024; // default max amplitude in PalmOS 5.x, can also use sndMaxAmp with earlier PalmOS

      // Code Snippet
      if (   ( !FtrGet( pmSoundLibCreatorID, pmSoundLibAudioGroupFtr, &value ) ) // is the Audio Group feature supported?
          && ( value != pmSoundLibAudioGroupFtr_Off ) ) // is the Audio Group feature active?
      {
          volume = PmSndAddAudioGroupToVolume( volume, pmAudioGroupAlert ); // then, mark this sound as an alert
      }
      SndPlayResource( mySound, volume, sndFlagNormal );

Definition in file PmSoundLibAudioGroup.h.

Include dependency graph for PmSoundLibAudioGroup.h:

Go to the source code of this file.

Defines

  • #define PM_AUDIOGROUP_MASK 0xE007
PmSoundLibAudioGroup information
  • #define pmSoundLibCreatorID hsSoundLibCreatorID
  • #define pmSoundLibAudioGroupFtr 0x0001
  • #define pmSoundLibAudioGroupFtr_Off 0
  • #define pmSoundLibAudioGroupFtr_On 1
Audio Group API functions
Implemented as macros.

  • #define PmSndAddAudioGroupToVolume(volume, audioGroup) (Int32) (((!audioGroup) || (((Int32)(volume)) <= -1))? (volume) : ((((((volume) & 0xE000) == 0x6000)? (volume):(volume)+7) & ~PM_AUDIOGROUP_MASK) | (audioGroup)))
  • #define PmSndRemoveAudioGroupFromVolume(volume) (Int32) ((((Int32)(volume)) < 0x6000)? (volume) : ((volume) & ~PM_AUDIOGROUP_MASK ))
  • #define PmSndGetAudioGroupFromVolume(volume) (PmAudioGroup)((((Int32)(volume)) < 0x6000)? (pmAudioGroupNone) : ((volume) & PM_AUDIOGROUP_MASK))

Typedefs

  • typedef UInt16 PmAudioGroup

Enumerations

  • enum PmAudioGroupEnum {
    pmAudioGroupNone = 0x0000,
    pmAudioGroupApp = 0x6000,
    pmAudioGroupSystem = 0x6001,
    pmAudioGroupAlert = 0x6002,
    pmAudioGroupHighPriority = 0x6003,
    pmAudioGroupInteractive = 0x6004,
    pmAudioGroupStreaming = 0x6005,
    pmAudioGroupCall = 0x6006,
    pmAudioGroupAlertRingOff = 0x6007
    }

Define Documentation

#define PM_AUDIOGROUP_MASK 0xE007

No definition.

Definition at line 149 of file PmSoundLibAudioGroup.h.

#define PmSndAddAudioGroupToVolume | ( | volume,
 |  | audioGroup | ) | (Int32) (((!audioGroup) || (((Int32)(volume)) <= -1))? (volume) : ((((((volume) & 0xE000) == 0x6000)? (volume):(volume)+7) & ~PM_AUDIOGROUP_MASK) | (audioGroup)))

Attaches an audio group designation to a PalmOS volume parameter.

Use this macro if you want your sound channel to be designated differently than application sound.

If this macro were implemented as a function, the prototype would be:

Int32 //returned volume // PmSndAddAudioGroupToVolume ( Int32 volume, PmAudioGroup audioGroup );

Definition at line 179 of file PmSoundLibAudioGroup.h.

#define PmSndGetAudioGroupFromVolume ( volume ) (PmAudioGroup)((((Int32)(volume)) < 0x6000)? (pmAudioGroupNone) : ((volume) & PM_AUDIOGROUP_MASK))

Removes the volume component of a PalmOS volume parameter, leaving a pure audio group component.

Use this if you have already attached the audio group to a volume parameter and need to identify the audio group designation.

If this macro were implemented as a function, the prototype would be:

PmAudioGroup PmSndGetAudioGroupFromVolume ( Int32 volume );

Definition at line 201 of file PmSoundLibAudioGroup.h.

#define PmSndRemoveAudioGroupFromVolume ( volume ) (Int32) ((((Int32)(volume)) < 0x6000)? (volume) : ((volume) & ~PM_AUDIOGROUP_MASK ))

Removes the audio group designation from a PalmOS volume parameter.

Use this if you previously attached a sound group designation and retrieve that volume again using PalmOS APIs. Or if you need to manipulate the overloaded volume parameter, as a volume only value.

If this macro were implemented as a function, the prototype would be:

Int32 //returned volume // PmSndRemoveAudioGroupFromVolume ( Int32 volume );

Definition at line 188 of file PmSoundLibAudioGroup.h.

#define pmSoundLibAudioGroupFtr 0x0001

Use this as the featureNum passed to FtrGet.

Definition at line 144 of file PmSoundLibAudioGroup.h.

#define pmSoundLibAudioGroupFtr_Off 0

Value returned in *valueP of FtrGet when Audio Group is disabled.

Definition at line 145 of file PmSoundLibAudioGroup.h.

#define pmSoundLibAudioGroupFtr_On 1

Value returned in *valueP of FtrGet when Audio Group is enabled

Definition at line 146 of file PmSoundLibAudioGroup.h.

#define pmSoundLibCreatorID hsSoundLibCreatorID

Pass this as the creator ID used in FtrGet.

Definition at line 143 of file PmSoundLibAudioGroup.h.

Typedef Documentation

typedef UInt16 PmAudioGroup

See also:
PmAudioGroupEnum

Definition at line 170 of file PmSoundLibAudioGroup.h.

Enumeration Type Documentation

enum PmAudioGroupEnum

Holds audio group information.

Enumerator:
pmAudioGroupNone | Default audio group when volume is less than 24K.
pmAudioGroupApp | Application audio, treated as pmAudioGroupNone, but group type saved.
pmAudioGroupSystem | System audio (as in SndPlaySystemSound).
pmAudioGroupAlert | Alert, alarms, ringtones that notify user of an event.
pmAudioGroupHighPriority | Extremely important event such as low battery shutdown.
pmAudioGroupInteractive | Application audio to be used for interactive playback (eg: games).
pmAudioGroupStreaming | Application audio to be used for streaming (eg: MP3, video, broadcast).
pmAudioGroupCall | Intended for digital phone call audio only. Used for internal purposes.
pmAudioGroupAlertRingOff | Same as pmAudioGroupAlert, but ignores Ringer switch position

Definition at line 154 of file PmSoundLibAudioGroup.h.

00155 {
00156     pmAudioGroupNone         = 0x0000, /**<Default audio group when volume is less than 24K. */
00157     pmAudioGroupApp          = 0x6000, /**<Application audio, treated as pmAudioGroupNone, but group type saved. */
00158     pmAudioGroupSystem       = 0x6001, /**<System audio (as in SndPlaySystemSound). */
00159     pmAudioGroupAlert        = 0x6002, /**<Alert, alarms, ringtones that notify user of an event. */
00160     pmAudioGroupHighPriority = 0x6003, /**<Extremely important event such as low battery shutdown. */
00161
00162     pmAudioGroupInteractive  = 0x6004, /**<Application audio to be used for interactive playback (eg: games). */
00163     pmAudioGroupStreaming    = 0x6005, /**<Application audio to be used for streaming (eg: MP3, video, broadcast). */
00164     pmAudioGroupCall         = 0x6006, /**<Intended for digital phone call audio only. Used for internal purposes. */
00165     pmAudioGroupAlertRingOff = 0x6007  /**<Same as pmAudioGroupAlert, but ignores Ringer switch position */
00166
00167 } PmAudioGroupEnum;

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:02 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » pmsysgadgetlib

PmSysGadgetLib.h File Reference

Detailed Description

System Library that exports status-related APIs.

Version:
1.0
This library is based on status gadgets APIs from HsExtensions and was broken apart from HsExtensions so the APIs could be ported to other platforms.

Definition in file PmSysGadgetLib.h.

Include dependency graph for PmSysGadgetLib.h:

Go to the source code of this file.

Functions

  • Err PmSysGadgetLibOpen (UInt16 refNum)
    Standard library open routine.
  • Err PmSysGadgetLibClose (UInt16 refNum)
    Standard library close routine.
  • Err PmSysGadgetStatusGadgetTypeSet (UInt16 refNum, void *frmP, UInt16 gadgetID, UInt16type)
    Tell the system that a gadget on the form is a certain type of status gadget so that the system can properly draw and update it.
  • void PmSysGadgetStatusGadgetsUpdate (UInt16 refNum)
    Explicitly update all status gadgets on the current form.
  • Err PmSysGadgetBbutInstallFromResource (UInt16 refNum, FormType *frmP)
  • void PmSysGadgetBbutInstallNewButton (UInt16 refNum, FormType *frmP, UInt16 gadgetID, const Char *textP, FontID font, UInt8 flags)
  • void PmSysGadgetBbutSetLabel (UInt16 refNum, FormType *frmP, UInt16 gadgetID, const Char *newLabel)
  • void PmSysGadgetBbutSetBitmap (UInt16 refNum, FormType *frmP, UInt16 gadgetID, const BitmapPtr bitmapP)
  • void PmSysGadgetBbutHitBigButton (UInt16 refNum, FormType *frmP, UInt16 gadgetIndex)

Function Documentation

void PmSysGadgetBbutHitBigButton | ( | UInt16 | refNum,
 |  | FormType * | frmP,
 |  | UInt16 | gadgetIndex
 | ) |  |

Like CtlHitControl, but for big buttons.

Notes: Due to the fact that PalmOS lacks accessors for gadgets directly, this function (and any others that refer to a big button's gadget) takes a form pointer and an index instead of a FormGadgetType*.

Parameters:
frmP,: IN: The form containing the big button's gadget.
gadgetIndex,: IN: The index of the big button's gadget.
Return values:
None.

Err PmSysGadgetBbutInstallFromResource | ( | UInt16 | refNum,
 |  | FormType * | frmP
 | ) |  |

Installs big buttons on the given form based on a 'bBut' resource with the same ID. A 'bBut' resource is basically just an array of HsBigButtonMappingType.

Once installed, the gadget will get events from PalmOS and will sent a 'gadgetMisc' event with the selector bbutGadgetMiscSelectSelector when selected.

IMPORTANT: The form must not be visible when you install the buttons, since we don't draw them (it turns out to be impossible to check whether the gadget is visible without peeking into its data structure, which we can only do from the event handler).

Parameters:
refNum,: IN: Library reference number
frmP,: IN: The form to install the big buttons on.
Return values:
Err Error code.

void PmSysGadgetBbutInstallNewButton | ( | UInt16 | refNum,
 |  | FormType * | frmP,
 |  | UInt16 | gadgetID,
 |  | const Char * | textP,
 |  | FontID | font,
 |  | UInt8 | flags
 | ) |  |

Set big button on a form.

Parameters:
refNum,: IN: Library reference number
frmP,: IN: The form to set the big button's gadget on.
gadgetID,: IN: The ID of the big button's gadget.
textP,: IN: Pointer to string to set on the gadget.
font,: IN: Font ID to be used for the text.
flags,: IN: Flags associated to the gadget.
Return values:
None.

void PmSysGadgetBbutSetBitmap | ( | UInt16 | refNum,
 |  | FormType * | frmP,
 |  | UInt16 | gadgetID,
 |  | const BitmapPtr | bitmapP
 | ) |  |

Set bitmap image on a big button gadget.

Parameters:
refNum,: IN: Library reference number
frmP,: IN: The form containing the big button's gadget.
gadgetID,: IN: The ID of the big button's gadget.
bitmapP,: IN: Pointer to the bitmap to set on the gadget.
Return values:
None.

void PmSysGadgetBbutSetLabel | ( | UInt16 | refNum,
 |  | FormType * | frmP,
 |  | UInt16 | gadgetID,
 |  | const Char * | newLabel
 | ) |  |

Set label on a big button gadget.

Parameters:
refNum,: IN: Library reference number
frmP,: IN: The form containing the big button's gadget.
gadgetID,: IN: The ID of the big button's gadget.
newLabel,: IN: Pointer to label string to set on the gadget.
Return values:
None.

Err PmSysGadgetLibClose ( UInt16 refNum )

Standard library close routine.

Parameters:
refNum,: IN: Library reference number
Return values:
Err Error Code

Err PmSysGadgetLibOpen ( UInt16 refNum )

Standard library open routine.

Parameters:
refNum,: IN: Library reference number
Return values:
Err Error Code

void PmSysGadgetStatusGadgetsUpdate ( UInt16 refNum )

Explicitly update all status gadgets on the current form.

Parameters:
refNum,: IN: Library reference number
Return values:
Nothing

Err PmSysGadgetStatusGadgetTypeSet | ( | UInt16 | refNum,
 |  | void * | frmP,
 |  | UInt16 | gadgetID,
 |  | UInt16type |
 | ) |  |

Tell the system that a gadget on the form is a certain type of status gadget so that the system can properly draw and update it.

Tell the system that a gadget on the form is a certain type of status gadget so that the system can properly draw and update it. A form can only have one gadget for each status type. If more than one gadget is set to a certain type, only the last one set will be recorded. This function can also be used to erase and release a gadget whose type has already been set. To do this, type should be set to 0.

Parameters:
refNum,: IN: Library reference number
frmP,: IN: Form to draw gadget on
gadgetID,: IN: Gadget resource ID
type,: IN: Gadget type (battery, signal, bluetooth, etc)
Return values:
Err Error code

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:02 2008 for Palm API Guide


Header Files » Incs » common » libraries » pmsysgadgetlib

PmSysGadgetLibBbutRscCommon.h File Reference

Go to the source code of this file.

Defines

  • #define __PM_SYS_GADGET_BBUT_RSC__H__ 1
  • #define kPmSysGadgetBbutMappingVersion0 0
  • #define kPmSysGadgetBbutFlagNone 0x00
  • #define kPmSysGadgetBbutFlagNoBorder 0x01
  • #define kPmSysGadgetBbutFlagNoBackground 0x02
  • #define kPmSysGadgetBbutFlagNoBorderOrBackground 0x03
  • #define kPmSysGadgetBbutFontStd 0
  • #define kPmSysGadgetBbutFontBold 1
  • #define kPmSysGadgetBbutFontLarge 2
  • #define kPmSysGadgetBbutFontSymbol 3
  • #define kPmSysGadgetBbutFontSymbol11 4
  • #define kPmSysGadgetBbutFontSymbol7 5
  • #define kPmSysGadgetBbutFontLed 6
  • #define kPmSysGadgetBbutFontLargeBold 7

Define Documentation

#define __PM_SYS_GADGET_BBUT_RSC__H__ 1

Definition at line 26 of file PmSysGadgetLibBbutRscCommon.h.

#define kPmSysGadgetBbutFlagNoBackground 0x02

Definition at line 37 of file PmSysGadgetLibBbutRscCommon.h.

#define kPmSysGadgetBbutFlagNoBorder 0x01

Definition at line 36 of file PmSysGadgetLibBbutRscCommon.h.

#define kPmSysGadgetBbutFlagNoBorderOrBackground 0x03

Definition at line 38 of file PmSysGadgetLibBbutRscCommon.h.

#define kPmSysGadgetBbutFlagNone 0x00

Definition at line 35 of file PmSysGadgetLibBbutRscCommon.h.

#define kPmSysGadgetBbutFontBold 1

Definition at line 44 of file PmSysGadgetLibBbutRscCommon.h.

#define kPmSysGadgetBbutFontLarge 2

Definition at line 45 of file PmSysGadgetLibBbutRscCommon.h.

#define kPmSysGadgetBbutFontLargeBold 7

Definition at line 50 of file PmSysGadgetLibBbutRscCommon.h.

#define kPmSysGadgetBbutFontLed 6

Definition at line 49 of file PmSysGadgetLibBbutRscCommon.h.

#define kPmSysGadgetBbutFontStd 0

Definition at line 43 of file PmSysGadgetLibBbutRscCommon.h.

#define kPmSysGadgetBbutFontSymbol 3

Definition at line 46 of file PmSysGadgetLibBbutRscCommon.h.

#define kPmSysGadgetBbutFontSymbol11 4

Definition at line 47 of file PmSysGadgetLibBbutRscCommon.h.

#define kPmSysGadgetBbutFontSymbol7 5

Definition at line 48 of file PmSysGadgetLibBbutRscCommon.h.

#define kPmSysGadgetBbutMappingVersion0 0

Definition at line 30 of file PmSysGadgetLibBbutRscCommon.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:02 2008 for Palm API Guide


Header Files » Incs » common » libraries » pmsysgadgetlib

PmSysGadgetLibCommon.h File Reference

Detailed Description

Public 68k header file for system Library that exports system gadget related APIs.

This file contains the common definitions and structures for the gadget-related APIs.

Definition in file PmSysGadgetLibCommon.h.

Go to the source code of this file.

Data Structures

  • struct PmSysGadgetBbutMappingType
    This is the structure of a single big button mapping... More...
  • struct PmSysGadgetBbutResourceType
    This is the structure of a big button resource... More...
  • struct PmSysGadgetPttNotificationType
    This is the structure used by the PTT notification event. More...

Defines

  • #define kPmSysGadgetLibType sysFileTLibrary
  • #define kPmSysGadgetLibCreator pmFileCSysGadgetLib
  • #define kPmSysGadgetLibName "PmSysGadgetLib-PmSg"
  • #define kPmSysGadgetBbutGadgetMiscSelectSelector 7014
  • #define kPmSysGadgetBbutGadgetMiscSelectData ((void*)0xBADC0DE1)
  • #define kPmSysGadgetBbutRscType 'bBut'
  • #define kPttNotificationEvent 'pPTT'
  • #define kPttNotificationStatusOffset (0xF00)
  • #define kPmSysGadgetFtrIDStatusGadgetRev 1
  • #define kPmSysGadgetFtrValStatusGadgetRev1 0x0001
Function Traps
  • #define kPmSysGadgetLibTrapOpen sysLibTrapOpen
  • #define kPmSysGadgetLibTrapClose sysLibTrapClose
  • #define kPmSysGadgetLibTrapStatusGadgetTypeSet (sysLibTrapCustom)
  • #define kPmSysGadgetLibTrapStatusGadgetsUpdate (sysLibTrapCustom+1)
  • #define kPmSysGadgetLibTrapBbutInstallFromResource (sysLibTrapCustom+2)
  • #define kPmSysGadgetLibTrapBbutInstallNewButton (sysLibTrapCustom+3)
  • #define kPmSysGadgetLibTrapBbutSetLabel (sysLibTrapCustom+4)
  • #define kPmSysGadgetLibTrapBbutSetBitmap (sysLibTrapCustom+5)
  • #define kPmSysGadgetLibTrapBbutHitBigButton (sysLibTrapCustom+6)

Enumerations

  • enum PmSysGadgetStatusGadgetTypeEnum {
    pmSysGadgetStatusGadgetNone = 0,
    pmSysGadgetStatusGadgetBattery = 1,
    pmSysGadgetStatusGadgetSignal = 2,
    pmSysGadgetStatusGadgetBt = 3,
    pmSysGadgetStatusGadgetEvdo = 4,
    pmSysGadgetStatusGadgetLine = 5,
    pmSysGadgetStatusGadgetRoaming = 6,
    pmSysGadgetStatusGadgetCallFwd = 7,
    pmSysGadgetStatusGadgetVm = 8,
    pmSysGadgetStatusGadgetOperator = 9,
    pmSysGadgetStatusGadgetPhoneCall = 10,
    pmSysGadgetStatusGadgetTty = 11,
    pmSysGadgetStatusGadgetPtt = 12
    }
  • enum PmSysGadgetBtStatusTypeEnum {
    kIndicatorBtOff = 0x0700,
    kIndicatorBtOn,
    kIndicatorBtConnectHeadset,
    kIndicatorBtConnectOther,
    kIndicatorBtDUN,
    kIndicatorBtConnectAudio,
    kIndicatorBtConnectStereo
    }

Define Documentation

#define kPmSysGadgetBbutGadgetMiscSelectData ((void*)0xBADC0DE1)

Magic # to make conflicts even less likely for detecting big button presses.

Definition at line 53 of file PmSysGadgetLibCommon.h.

#define kPmSysGadgetBbutGadgetMiscSelectSelector 7014

This selector gets sent with a frmGadgetMiscEvent to let you know that the gadget has been selected. The numbers are picked semi-randomly so that generic code (like PmUIUtilFrmDoDialogWithCallback()) can tell that this is actually a button press without doing the wrong thing for other people's gadget events.

Note that in most code, you shouldn't need to worry about checking the data, since you know exactly what gadgets are on your form and what kind of events they send. Randomish number so people can easily detect big button presses

Definition at line 51 of file PmSysGadgetLibCommon.h.

#define kPmSysGadgetBbutRscType 'bBut'

This is the type of big button resources. The ID should match the ID of the form... Registered: yes

Definition at line 61 of file PmSysGadgetLibCommon.h.

#define kPmSysGadgetFtrIDStatusGadgetRev 1

Feature that says that status gadget API exists and what revision it is

Definition at line 67 of file PmSysGadgetLibCommon.h.

#define kPmSysGadgetFtrValStatusGadgetRev1 0x0001

Feature that says that status gadget API exists and what revision it is

Definition at line 68 of file PmSysGadgetLibCommon.h.

#define kPmSysGadgetLibCreator pmFileCSysGadgetLib

Library creator ID

Definition at line 38 of file PmSysGadgetLibCommon.h.

#define kPmSysGadgetLibName "PmSysGadgetLib-PmSg"

Library name

Definition at line 39 of file PmSysGadgetLibCommon.h.

#define kPmSysGadgetLibTrapBbutHitBigButton (sysLibTrapCustom+6)

Definition at line 169 of file PmSysGadgetLibCommon.h.

#define kPmSysGadgetLibTrapBbutInstallFromResource (sysLibTrapCustom+2)

Definition at line 165 of file PmSysGadgetLibCommon.h.

#define kPmSysGadgetLibTrapBbutInstallNewButton (sysLibTrapCustom+3)

Definition at line 166 of file PmSysGadgetLibCommon.h.

#define kPmSysGadgetLibTrapBbutSetBitmap (sysLibTrapCustom+5)

Definition at line 168 of file PmSysGadgetLibCommon.h.

#define kPmSysGadgetLibTrapBbutSetLabel (sysLibTrapCustom+4)

Definition at line 167 of file PmSysGadgetLibCommon.h.

#define kPmSysGadgetLibTrapClose sysLibTrapClose

Definition at line 162 of file PmSysGadgetLibCommon.h.

#define kPmSysGadgetLibTrapOpen sysLibTrapOpen

Definition at line 161 of file PmSysGadgetLibCommon.h.

#define kPmSysGadgetLibTrapStatusGadgetsUpdate (sysLibTrapCustom+1)

Definition at line 164 of file PmSysGadgetLibCommon.h.

#define kPmSysGadgetLibTrapStatusGadgetTypeSet (sysLibTrapCustom)

Definition at line 163 of file PmSysGadgetLibCommon.h.

#define kPmSysGadgetLibType sysFileTLibrary

Library type

Definition at line 37 of file PmSysGadgetLibCommon.h.

#define kPttNotificationEvent 'pPTT'

Constants added for PTT Notification

Definition at line 74 of file PmSysGadgetLibCommon.h.

#define kPttNotificationStatusOffset (0xF00)

Definition at line 75 of file PmSysGadgetLibCommon.h.

Enumeration Type Documentation

enum PmSysGadgetBtStatusTypeEnum

Bluetooth radio status

Enumerator:
kIndicatorBtOff | Bt Radio turned off
kIndicatorBtOn | Bt radio turned on
kIndicatorBtConnectHeadset | Connected to Headset
kIndicatorBtConnectOther | Connected to other Bt devices
kIndicatorBtDUN | Connected to DUN
kIndicatorBtConnectAudio | Connected audio
kIndicatorBtConnectStereo | Connected stereo

Definition at line 101 of file PmSysGadgetLibCommon.h.

00102   {
00103     kIndicatorBtOff       = 0x0700, /**< Bt Radio turned off */
00104     kIndicatorBtOn,                 /**< Bt radio turned on */
00105     kIndicatorBtConnectHeadset,     /**< Connected to Headset */
00106     kIndicatorBtConnectOther,       /**< Connected to other Bt devices */
00107     kIndicatorBtDUN,                /**< Connected to DUN */
00108     kIndicatorBtConnectAudio,       /**< Connected audio **/
00109     kIndicatorBtConnectStereo       /**< Connected stereo **/
00110   } PmSysGadgetBtStatusTypeEnum;

enum PmSysGadgetStatusGadgetTypeEnum

Equates for supporting system handled status gadgets

Enumerator:
pmSysGadgetStatusGadgetNone | No type specified for status gadget
pmSysGadgetStatusGadgetBattery | Status gadget is a battery meter
pmSysGadgetStatusGadgetSignal | Status gadget is a signal strength indicator
pmSysGadgetStatusGadgetBt | Status gadget is a Bluetooth status indicator
pmSysGadgetStatusGadgetEvdo | Status gadget is an EVDO status indicator
pmSysGadgetStatusGadgetLine | Status gadget is an Active line status indicator
pmSysGadgetStatusGadgetRoaming | Status gadget is a Roaming status indicator
pmSysGadgetStatusGadgetCallFwd | Status gadget is a Call Forwarding status indicator
pmSysGadgetStatusGadgetVm | Status gadget is a Voicemail status indicator
pmSysGadgetStatusGadgetOperator | Status gadget is an Operator status indicator
pmSysGadgetStatusGadgetPhoneCall | Status gadget is an Operator status indicator
pmSysGadgetStatusGadgetTty | Status gadget is a TTY status indicator
pmSysGadgetStatusGadgetPtt | Status gadget is a PTT status indicator, RJS added 22May06

Definition at line 83 of file PmSysGadgetLibCommon.h.

00084   {
00085     pmSysGadgetStatusGadgetNone = 0,       /**< No type specified for status gadget */
00086     pmSysGadgetStatusGadgetBattery = 1,    /**< Status gadget is a battery meter */
00087     pmSysGadgetStatusGadgetSignal = 2,     /**< Status gadget is a signal strength indicator */
00088     pmSysGadgetStatusGadgetBt = 3,         /**< Status gadget is a Bluetooth status indicator */
00089     pmSysGadgetStatusGadgetEvdo = 4,       /**< Status gadget is an EVDO status indicator */
00090     pmSysGadgetStatusGadgetLine = 5,       /**< Status gadget is an Active line status indicator */
00091     pmSysGadgetStatusGadgetRoaming = 6,    /**< Status gadget is a Roaming status indicator */
00092     pmSysGadgetStatusGadgetCallFwd = 7,    /**< Status gadget is a Call Forwarding status indicator */
00093     pmSysGadgetStatusGadgetVm = 8,         /**< Status gadget is a Voicemail status indicator */
00094     pmSysGadgetStatusGadgetOperator = 9,   /**< Status gadget is an Operator status indicator */
00095     pmSysGadgetStatusGadgetPhoneCall = 10, /**< Status gadget is an Operator status indicator */
00096     pmSysGadgetStatusGadgetTty = 11,       /**< Status gadget is a TTY status indicator */
00097     pmSysGadgetStatusGadgetPtt = 12        /**< Status gadget is a PTT status indicator, RJS added 22May06 */
00098   } PmSysGadgetStatusGadgetTypeEnum;

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:02 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » pmuiutillib

PmUIUtilLib.h File Reference

Detailed Description

This is the public header for PmUIUtil library.

This library contains general utility functions that supplement OS functionality. That is, it contains functions that are general enough to be useful to many applications but weren't included in the OS utility functions for whatever reason.

Definition in file PmUIUtilLib.h.

Include dependency graph for PmUIUtilLib.h:

Go to the source code of this file.

Functions

  • Err PmUIUtilLibOpen (UInt16 refNum)
    Standard library open routine.
  • Err PmUIUtilLibClose (UInt16 refNum)
    Standard library close routine.
  • void PmUIUtilLstSetTempSelection (UInt16 refNum, const FormType *formP, UInt16 listID, Int16 itemNum)
  • Int16 PmUIUtilLstGetTempSelection (UInt16 refNum, const FormType *formP, UInt16 listID)
  • Err PmUIUtilAttrGet (UInt16 refNum, UInt16attr, UInt32 flags, UInt32 *valueP)
  • Err PmUIUtilAttrSet (UInt16 refNum, UInt16attr, UInt32 flags, UInt32 value)
  • void PmUIUtilNavGetFocusColor (UInt16 refNum, HsNavFocusColorEnum color, RGBColorType *rgbColorP)
  • void PmUIUtilNavSetFocusColor (UInt16 refNum, HsNavFocusColorEnum color, RGBColorType *rgbColorP, RGBColorType *oldRgbColorP)

Function Documentation

Err PmUIUtilAttrGet | ( | UInt16 | refNum,
 |  | UInt16attr | ,
 |  | UInt32 | flags,
 |  | UInt32 * | valueP
 | ) |  |

Err PmUIUtilAttrSet | ( | UInt16 | refNum,
 |  | UInt16attr | ,
 |  | UInt32 | flags,
 |  | UInt32 | value
 | ) |  |

Err PmUIUtilLibClose ( UInt16 refNum )

Standard library close routine.

Parameters:
refNum,: IN: Library reference number
Return values:
Err Error code

Err PmUIUtilLibOpen ( UInt16 refNum )

Standard library open routine.

Parameters:
refNum,: IN: Library reference number
Return values:
Err Error code

Int16 PmUIUtilLstGetTempSelection | ( | UInt16 | refNum,
 |  | const FormType * | formP,
 |  | UInt16 | listID
 | ) |  |

void PmUIUtilLstSetTempSelection | ( | UInt16 | refNum,
 |  | const FormType * | formP,
 |  | UInt16 | listID,
 |  | Int16 | itemNum
 | ) |  |

void PmUIUtilNavGetFocusColor | ( | UInt16 | refNum,
 |  | HsNavFocusColorEnum | color,
 |  | RGBColorType * | rgbColorP
 | ) |  |

void PmUIUtilNavSetFocusColor | ( | UInt16 | refNum,
 |  | HsNavFocusColorEnum | color,
 |  | RGBColorType * | rgbColorP,
 |  | RGBColorType * | oldRgbColorP
 | ) |  |

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:03 2008 for Palm API Guide


Header Files » Incs » common » libraries » pmuiutillib

PmUIUtilLibCommon.h File Reference

Detailed Description

Public 68k common header file for system Library that exports UI utility API functions.

This file contains the constants and definitions for the system UI-Util library.

Definition in file PmUIUtilLibCommon.h.

Include dependency graph for PmUIUtilLibCommon.h:

Go to the source code of this file.

Defines

  • #define kPmUIUtilLibType sysFileTLibrary
  • #define kPmUIUtilLibCreator pmFileCUIUtilLib
  • #define kPmUIUtilLibName "PmUIUtilLib-PmUU"
  • #define kPmUIUtilLibAPIMajorVersion 2
  • #define kPmUIUtilLibAPIMinorVersion 0
  • #define kPmUIUtilLibAPIVersion sysMakeLibAPIVersion(kPmUIUtilLibAPIMajorVersion, kPmUIUtilLibAPIMinorVersion)
Feature values
  • #define kPmUIUtilLibFtrValAPIVersion 0
Function Traps
  • #define kPmUIUtilLibTrapOpen sysLibTrapOpen
  • #define kPmUIUtilLibTrapClose sysLibTrapClose
  • #define kPmUIUtilLibTrapGetObjectUsable (sysLibTrapCustom)
  • #define kPmUIUtilLibTrapPutObjectAfterTitle (sysLibTrapCustom+1)
  • #define kPmUIUtilLibTrapFrmDoDialogWithCallback (sysLibTrapCustom+2)
  • #define kPmUIUtilLibTrapFrmDoDialog (sysLibTrapCustom+3)
  • #define kPmUIUtilLibTrapFrmDoTimedDialogEx (sysLibTrapCustom+4)
  • #define kPmUIUtilLibTrapFrmSetHelpID (sysLibTrapCustom+5)
  • #define kPmUIUtilLibTrapFrmSetLabel (sysLibTrapCustom+6)
  • #define kPmUIUtilLibTrapFrmSetLabelFont (sysLibTrapCustom+7)
  • #define kPmUIUtilLibTrapFrmGetDefaultButtonID (sysLibTrapCustom+8)
  • #define kPmUIUtilLibTrapFrmGetEventHandler (sysLibTrapCustom+9)
  • #define kPmUIUtilLibTrapCtlGetStyle (sysLibTrapCustom+10)
  • #define kPmUIUtilLibTrapCtlGetFont (sysLibTrapCustom+11)
  • #define kPmUIUtilLibTrapLstGetItemsText (sysLibTrapCustom+12)
  • #define kPmUIUtilLibTrapLstGetTopItem (sysLibTrapCustom+13)
  • #define kPmUIUtilLibTrapLstPopupListExt (sysLibTrapCustom+14)
  • #define kPmUIUtilLibTrapSclUpdateScrollBar (sysLibTrapCustom+15)
  • #define kPmUIUtilLibTrapSclScroll (sysLibTrapCustom+16)
  • #define kPmUIUtilLibTrapSclScrollPage (sysLibTrapCustom+17)
  • #define kPmUIUtilLibTrapSliHandleKeyDown (sysLibTrapCustom+18)
  • #define kPmUIUtilLibTrapWinGetMaxDepth (sysLibTrapCustom+19)
  • #define kPmUIUtilLibTrapAttnNagInfo (sysLibTrapCustom+20)
  • #define kPmUIUtilLibTrapAttnEnable (sysLibTrapCustom+21)
  • #define kPmUIUtilLibTrapAttnIndicatorAllow (sysLibTrapCustom+22)
  • #define kPmUIUtilLibTrapAttnGetAttentionExt (sysLibTrapCustom+23)
  • #define kPmUIUtilLibTrapAttnUpdateExt (sysLibTrapCustom+24)
  • #define kPmUIUtilLibTrapAttrGet (sysLibTrapCustom+25)
  • #define kPmUIUtilLibTrapAttrSet (sysLibTrapCustom+26)
  • #define kPmUIUtilLibTrapLstSetTempSelection (sysLibTrapCustom+27)
  • #define kPmUIUtilLibTrapLstGetTempSelection (sysLibTrapCustom+28)
  • #define kPmUIUtilLibTrapNavGetFocusColor (sysLibTrapCustom+29)
  • #define kPmUIUtilLibTrapNavSetFocusColor (sysLibTrapCustom+30)
  • #define kPmUIUtilLibTrapAttnDiagIsVisible (sysLibTrapCustom+31)

Typedefs

  • typedef UInt16 PmUIUtilAttrEnum

Enumerations

  • enum PmUIUtilAttrEnumTag { pmUIUtilAttrAutoSnoozeAttns }

Define Documentation

#define kPmUIUtilLibAPIMajorVersion 2

Major version incremented when API changes

Definition at line 41 of file PmUIUtilLibCommon.h.

#define kPmUIUtilLibAPIMinorVersion 0

Minor version incremented with each release of library that doesn't change the API

Definition at line 43 of file PmUIUtilLibCommon.h.

#define kPmUIUtilLibAPIVersion sysMakeLibAPIVersion(kPmUIUtilLibAPIMajorVersion, kPmUIUtilLibAPIMinorVersion)

Definition at line 46 of file PmUIUtilLibCommon.h.

#define kPmUIUtilLibCreator pmFileCUIUtilLib

Library creator ID

Definition at line 39 of file PmUIUtilLibCommon.h.

#define kPmUIUtilLibFtrValAPIVersion 0

Feature value used to get/set library version (kPmUIUtilLibAPIVersion). Note that the first release of the library did not set this feature. Therefore, if the library does exist but the feature does not, you can assume the major version of the library is 1. Note also that the feature is not set until library is loaded so you must load PmUIUtil before getting the feature

Definition at line 53 of file PmUIUtilLibCommon.h.

#define kPmUIUtilLibName "PmUIUtilLib-PmUU"

Library name

Definition at line 40 of file PmUIUtilLibCommon.h.

#define kPmUIUtilLibTrapAttnDiagIsVisible (sysLibTrapCustom+31)

Definition at line 127 of file PmUIUtilLibCommon.h.

#define kPmUIUtilLibTrapAttnEnable (sysLibTrapCustom+21)

Definition at line 117 of file PmUIUtilLibCommon.h.

#define kPmUIUtilLibTrapAttnGetAttentionExt (sysLibTrapCustom+23)

Definition at line 119 of file PmUIUtilLibCommon.h.

#define kPmUIUtilLibTrapAttnIndicatorAllow (sysLibTrapCustom+22)

Definition at line 118 of file PmUIUtilLibCommon.h.

#define kPmUIUtilLibTrapAttnNagInfo (sysLibTrapCustom+20)

Definition at line 116 of file PmUIUtilLibCommon.h.

#define kPmUIUtilLibTrapAttnUpdateExt (sysLibTrapCustom+24)

Definition at line 120 of file PmUIUtilLibCommon.h.

#define kPmUIUtilLibTrapAttrGet (sysLibTrapCustom+25)

Definition at line 121 of file PmUIUtilLibCommon.h.

#define kPmUIUtilLibTrapAttrSet (sysLibTrapCustom+26)

Definition at line 122 of file PmUIUtilLibCommon.h.

#define kPmUIUtilLibTrapClose sysLibTrapClose

Definition at line 95 of file PmUIUtilLibCommon.h.

#define kPmUIUtilLibTrapCtlGetFont (sysLibTrapCustom+11)

Definition at line 107 of file PmUIUtilLibCommon.h.

#define kPmUIUtilLibTrapCtlGetStyle (sysLibTrapCustom+10)

Definition at line 106 of file PmUIUtilLibCommon.h.

#define kPmUIUtilLibTrapFrmDoDialog (sysLibTrapCustom+3)

Definition at line 99 of file PmUIUtilLibCommon.h.

#define kPmUIUtilLibTrapFrmDoDialogWithCallback (sysLibTrapCustom+2)

Definition at line 98 of file PmUIUtilLibCommon.h.

#define kPmUIUtilLibTrapFrmDoTimedDialogEx (sysLibTrapCustom+4)

Definition at line 100 of file PmUIUtilLibCommon.h.

#define kPmUIUtilLibTrapFrmGetDefaultButtonID (sysLibTrapCustom+8)

Definition at line 104 of file PmUIUtilLibCommon.h.

#define kPmUIUtilLibTrapFrmGetEventHandler (sysLibTrapCustom+9)

Definition at line 105 of file PmUIUtilLibCommon.h.

#define kPmUIUtilLibTrapFrmSetHelpID (sysLibTrapCustom+5)

Definition at line 101 of file PmUIUtilLibCommon.h.

#define kPmUIUtilLibTrapFrmSetLabel (sysLibTrapCustom+6)

Definition at line 102 of file PmUIUtilLibCommon.h.

#define kPmUIUtilLibTrapFrmSetLabelFont (sysLibTrapCustom+7)

Definition at line 103 of file PmUIUtilLibCommon.h.

#define kPmUIUtilLibTrapGetObjectUsable (sysLibTrapCustom)

Definition at line 96 of file PmUIUtilLibCommon.h.

#define kPmUIUtilLibTrapLstGetItemsText (sysLibTrapCustom+12)

Definition at line 108 of file PmUIUtilLibCommon.h.

#define kPmUIUtilLibTrapLstGetTempSelection (sysLibTrapCustom+28)

Definition at line 124 of file PmUIUtilLibCommon.h.

#define kPmUIUtilLibTrapLstGetTopItem (sysLibTrapCustom+13)

Definition at line 109 of file PmUIUtilLibCommon.h.

#define kPmUIUtilLibTrapLstPopupListExt (sysLibTrapCustom+14)

Definition at line 110 of file PmUIUtilLibCommon.h.

#define kPmUIUtilLibTrapLstSetTempSelection (sysLibTrapCustom+27)

Definition at line 123 of file PmUIUtilLibCommon.h.

#define kPmUIUtilLibTrapNavGetFocusColor (sysLibTrapCustom+29)

Definition at line 125 of file PmUIUtilLibCommon.h.

#define kPmUIUtilLibTrapNavSetFocusColor (sysLibTrapCustom+30)

Definition at line 126 of file PmUIUtilLibCommon.h.

#define kPmUIUtilLibTrapOpen sysLibTrapOpen

Definition at line 94 of file PmUIUtilLibCommon.h.

#define kPmUIUtilLibTrapPutObjectAfterTitle (sysLibTrapCustom+1)

Definition at line 97 of file PmUIUtilLibCommon.h.

#define kPmUIUtilLibTrapSclScroll (sysLibTrapCustom+16)

Definition at line 112 of file PmUIUtilLibCommon.h.

#define kPmUIUtilLibTrapSclScrollPage (sysLibTrapCustom+17)

Definition at line 113 of file PmUIUtilLibCommon.h.

#define kPmUIUtilLibTrapSclUpdateScrollBar (sysLibTrapCustom+15)

Definition at line 111 of file PmUIUtilLibCommon.h.

#define kPmUIUtilLibTrapSliHandleKeyDown (sysLibTrapCustom+18)

Definition at line 114 of file PmUIUtilLibCommon.h.

#define kPmUIUtilLibTrapWinGetMaxDepth (sysLibTrapCustom+19)

Definition at line 115 of file PmUIUtilLibCommon.h.

#define kPmUIUtilLibType sysFileTLibrary

Library type

Definition at line 38 of file PmUIUtilLibCommon.h.

Typedef Documentation

typedef UInt16 PmUIUtilAttrEnum

See also:
PmUIUtilAttrEnumTag

Definition at line 83 of file PmUIUtilLibCommon.h.

Enumeration Type Documentation

enum PmUIUtilAttrEnumTag

Enumerator:
pmUIUtilAttrAutoSnoozeAttns whether we want to auto snooze the current instance of the attn dialog

Definition at line 68 of file PmUIUtilLibCommon.h.

00069 {
00070   pmUIUtilAttrAutoSnoozeAttns       /**< whether we want to auto snooze the current instance of the attn dialog */
00071
00072   /*
00073    * End of enums in API version 1
00074    */
00075
00076   /*
00077    * Attributes greater than 0x9000 are defined for internal use
00078    * in Prv/PmPrvKeyLibCommon.h
00079    */
00080 };

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:03 2008 for Palm API Guide


Header Files » Incs » 68k » system

Slider.h File Reference

Detailed Description

Version:
1.0
Date:
04/03/2002
Header file for all Palm Devices Contains constants & structs necessary to access slider saved pref.

Author:
George Puckett

Definition in file Slider.h.

Include dependency graph for Slider.h:

Go to the source code of this file.

Data Structures

  • struct PowerPanelAppPrefs

Defines

  • #define sysFileCPower 'Powr'
  • #define SLIDER_PREF_CHANGED_NOTIFY_TYPE 'spcn'
  • #define appPrefsVersion 0
  • #define appPrefsID 1

Define Documentation

#define appPrefsID 1

Definition at line 40 of file Slider.h.

#define appPrefsVersion 0

App preferences

Definition at line 39 of file Slider.h.

#define SLIDER_PREF_CHANGED_NOTIFY_TYPE 'spcn'

notification sent to inform HAL that the preferences need to be updated

Definition at line 35 of file Slider.h.

#define sysFileCPower 'Powr'

Creator type for Power Panel

Definition at line 29 of file Slider.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:03 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » smarttextengine

SmartTextEngine.h File Reference

Detailed Description

Public 68K include file for Smart Text Engine shared library.

The Smart Text Engine (STE) Library can be used to enable hyperlink in your application and display icon as defined in the Resource Header file.

It will enable user to tap on:

  • Phone number to dial using the phone application
  • URL to browse
  • Email to send an email by launching the default email application

The calling application should always load this library with SysLibLoad() before use, even if it is already open by another application(ie, SysLibFind() returns a valid refnum). When the application is done with the library, it should be unloaded with SysLibRemove(). We do this because there is no good way to synchronize loading and unloading of libraries among multiple applications. It also greatly simplifies internal synchronization.

    Err LoadSmartTextEngine(UInt16* refNumP, Boolean* libLoadedP)
        {
        Err error = 0;

        // Routine is pointless without this parameter
        if (!refNumP)
            return memErrInvalidParam;

        // always load the library, so we have our own instance of the engine
        error = SysLibLoad(sysFileTLibrary, hsFileCSmartTextEngine, refNumP);
        if (error)
            return error;
        *libLoadedP = true;

        return error;
        }

Definition in file SmartTextEngine.h.

Include dependency graph for SmartTextEngine.h:

Go to the source code of this file.

Functions

  • STEErr STEOpen (UInt16 refNum)
  • STEErr STEClose (UInt16 refNum)
  • STEErr STEGetAPIVersion (UInt16 refNum, UInt32 *majVerP, UInt32 *minVerP)
  • STEErr STEInitializeEngine (UInt16 refNum, UInt16 *engineRefNum, RectangleType *listBounds, UInt16 scrollBarID, UInt32 flags, UInt8 phoneNumberColor, UInt8 urlColor, UInt8 emailColor)
  • STEErr STEResetEngine (UInt16 refNum, UInt16 engineRefNum)
  • STEErr STEReinitializeEngine (UInt16 refNum, UInt16 engineRefNum)
  • void STEAppendTextToEngine (UInt16 refNum, UInt16 engineRefNum, Char *textP, Boolean renderImmediate)
  • void STERemoveLastRecordFromEngine (UInt16 refNum, UInt16 engineRefNum)
  • void STERenderList (UInt16 refNum, UInt16 engineRefNum)
  • void STERerenderList (UInt16 refNum, UInt16 engineRefNum)
  • Boolean STEHandleEvent (UInt16 refNum, UInt16 engineRefNum, EventPtr eventP)
  • Boolean STEHandleSclRepeatEvent (UInt16 refNum, UInt16 engineRefNum, EventPtr eventP)
  • Boolean STEHandlePenDownEvent (UInt16 refNum, UInt16 engineRefNum, EventPtr eventP)
  • Boolean STEHandlePenMoveEvent (UInt16 refNum, UInt16 engineRefNum, EventPtr eventP)
  • Boolean STEHandlePenUpEvent (UInt16 refNum, UInt16 engineRefNum, EventPtr eventP)
  • Boolean STEHandleKeyDownEvent (UInt16 refNum, UInt16 engineRefNum, EventPtr eventP)
  • UInt16 STEGetScroll (UInt16 refNum, UInt16 engineRefNum)
  • void STESetScroll (UInt16 refNum, UInt16 engineRefNum, UInt16 scrollValue)
  • UInt16 STEGetScrollPct (UInt16 refNum, UInt16 engineRefNum)
  • void STESetScrollPct (UInt16 refNum, UInt16 engineRefNum, UInt16 scrollPct)
  • void STESetScrollToRecordNum (UInt16 refNum, UInt16 engineRefNum, UInt16 recordNum)
  • void STESetFlags (UInt16 refNum, UInt16 engineRefNum, UInt32 flagsToSet, UInt32 flagsToClear)
  • UInt32 STEGetFlags (UInt16 refNum, UInt16 engineRefNum)
  • UInt16 STEGetNumLines (UInt16 refNum, UInt16 engineRefNum)
  • UInt16 STEGetNumRecords (UInt16 refNum, UInt16 engineRefNum)
  • Boolean STEHasHotRectSelection (UInt16 refNum, UInt16 engineRefNum)
  • Boolean STEHasMessageSelection (UInt16 refNum, UInt16 engineRefNum)
  • Boolean STEHasTextSelection (UInt16 refNum, UInt16 engineRefNum)
  • void STEClearCurrentSelection (UInt16 refNum, UInt16 engineRefNum)
  • UInt16 STESetCurrentTextSelection (UInt16 refNum, UInt16 engineRefNum, UInt16 messageNumber, UInt32 startLocation, UInt32 selectionLength)
  • void STEGetCurrentTextSelection (UInt16 refNum, UInt16 engineRefNum, UInt16 *messageNumber, UInt16 *startLocation, UInt16 *selectionLength)
  • Char * STEGetSelectedText (UInt16 refNum, UInt16 engineRefNum)
  • void STECopySelectionToClipboard (UInt16 refNum, UInt16 engineRefNum)
  • void STEGetLastTapInfo (UInt16 refNum, UInt16 engineRefNum, UInt16 *messageNumber, UInt16 *tapLocation)
  • void STESetCustomHyperlinkCallback (UInt16 refNum, UInt16 engineRefNum, STECallbackType callback, Boolean armCallback)
  • void STEQuickRender (UInt16 refNum, RectangleType *listBounds, UInt32 flags, UInt8 phoneNumberColor, UInt8 urlColor, UInt8 emailColor, Char *msgP)
  • ParsedInfoList * STEGetParsedInformation (UInt16 refNum, Char *textP, UInt16 msgNumber, Boolean replaceLineFeeds, UInt32 flags)
  • void STEAppendParsedInfo (UInt16 refNum, MemHandle destParsedInfoH, ParsedInfoList *sourceParsedInfoP)

Function Documentation

void STEAppendParsedInfo | ( | UInt16 | refNum,
 |  | MemHandle | destParsedInfoH,
 |  | ParsedInfoList * | sourceParsedInfoP
 | ) |  |

This routine append a ParsedInfoList to another ParsedInfoList.

This does NOT require the STE to be initialized. This is used internally by the STE. You probably will not use this function.

Parameters:
refNum,: IN: The STE refNum
destParsedInfoH,: IN: A handle to the destination parsed info list
sourceParsedInfoP,: IN: The source parsed info list.
Return values:
-

void STEAppendTextToEngine | ( | UInt16 | refNum,
 |  | UInt16 | engineRefNum,
 |  | Char * | textP,
 |  | Boolean | renderImmediate
 | ) |  |

Function that is used to add text to the STE. Each text string that is appended is called a record. Record numbers are 1 based, meaning the first record is record 1.

Parameters:
refNum,: IN: The STE refNum
engineRefNum,: IN: The STE engine refNum
textP,: IN: The text to append to the STE, including any STE delimiters
renderImmediate,: IN: If true, the text will be displayed immediately. If false, it will not be displayed until STERenderList is called.
Return values:
-

void STEClearCurrentSelection | ( | UInt16 | refNum,
 |  | UInt16 | engineRefNum
 | ) |  |

This routine clears any currently selected text or hot rect.

Parameters:
refNum,: IN: The STE refNum
engineRefNum,: IN: The STE engine refNum
Return values:
-

STEErr STEClose ( UInt16 refNum )

Standard library close routine. Library should always be unloaded with SysLibRemove() after STEClose() is called. See note at top of file.

Parameters:
refNum,: IN: Library reference number
Return values:
STEErr Error Code or zero if no error occurs

void STECopySelectionToClipboard | ( | UInt16 | refNum,
 |  | UInt16 | engineRefNum
 | ) |  |

This routine copies the selected text to the system's clipboard.

Parameters:
refNum,: IN: The STE refNum
engineRefNum,: IN: The STE engine refNum
Return values:
-

STEErr STEGetAPIVersion | ( | UInt16 | refNum,
 |  | UInt32 * | majVerP,
 |  | UInt32 * | minVerP
 | ) |  |

Get Library API Version number.

Parameters:
refNum,: IN: Library reference number
majVerP,: OUT: Major version number
minVerP,: OUT: Minor version number
Return values:
STEErr Error Code or zero if no error occurs

void STEGetCurrentTextSelection | ( | UInt16 | refNum,
 |  | UInt16 | engineRefNum,
 |  | UInt16 * | messageNumber,
 |  | UInt16 * | startLocation,
 |  | UInt16 * | selectionLength
 | ) |  |

This routine will select the specified text selection. The display will be updated to show the selected text as highlighted.

Parameters:
refNum,: IN: The STE refNum
engineRefNum,: IN: The STE engine refNum
messageNumber,: OUT: The record number of the start the selection
startLocation,: OUT: The byte offset of the start the text selection
selectionLength,: OUT: The number of bytes in the text selection
Return values:
-

UInt32 STEGetFlags | ( | UInt16 | refNum,
 |  | UInt16 | engineRefNum
 | ) |  |

This routine returns the current STE flags

Parameters:
refNum,: IN: The STE refNum
engineRefNum,: IN: The STE engine refNum
Return values:
UInt32 The STE flags

void STEGetLastTapInfo | ( | UInt16 | refNum,
 |  | UInt16 | engineRefNum,
 |  | UInt16 * | messageNumber,
 |  | UInt16 * | tapLocation
 | ) |  |

This routine returns the location of the last tap. If the user drags the stylus, it is not a tap.

Parameters:
refNum,: IN: The STE refNum
engineRefNum,: IN: The STE engine refNum
messageNumber,: OUT: The record number of the text that was tapped
tapLocation,: OUT: The number of bytes offset from the start of the text to the location tapped
Return values:
-

UInt16 STEGetNumLines | ( | UInt16 | refNum,
 |  | UInt16 | engineRefNum
 | ) |  |

This routine returns the number of lines in the STE.

Parameters:
refNum,: IN: The STE refNum
engineRefNum,: IN: The STE engine refNum
Return values:
UInt16 Number of lines in the STE

UInt16 STEGetNumRecords | ( | UInt16 | refNum,
 |  | UInt16 | engineRefNum
 | ) |  |

This routine returns the number of records in the STE.

Parameters:
refNum,: IN: The STE refNum
engineRefNum,: IN: The STE engine refNum
Return values:
UInt16 Number of records in the STE

ParsedInfoList* STEGetParsedInformation | ( | UInt16 | refNum,
 |  | Char * | textP,
 |  | UInt16 | msgNumber,
 |  | Boolean | replaceLineFeeds,
 |  | UInt32 | flags
 | ) |  |

This routine will parse the text string for URLs, email addresses, and/or phone numbers.

This does NOT require the STE to be initialized.

Parameters:
refNum,: IN: The STE refNum
textP,: IN: The text string to parse
msgNumber,: IN: The message number of this text string (Used internally by the STE)
replaceLineFeeds,: IN: If true, any line feed will be replaced with a space, but a parsed item will be create that specifies a line feed to be at that location
flags,: IN: The flags indicating what type of item to parse out
Return values:
ParsedInfoList* A parsed info list that has each of the parsed items found in the text string.

UInt16 STEGetScroll | ( | UInt16 | refNum,
 |  | UInt16 | engineRefNum
 | ) |  |

This routine returns the current scroll position of the STE's scroll bar.

Parameters:
refNum,: IN: The STE refNum
engineRefNum,: IN: The STE engine refNum
Return values:
UInt16 The position of the scroll bar.

UInt16 STEGetScrollPct | ( | UInt16 | refNum,
 |  | UInt16 | engineRefNum
 | ) |  |

This routine returns the current scroll position of the STE's scroll bar as a percentage of the entire scroll bar.

Parameters:
refNum,: IN: The STE refNum
engineRefNum,: IN: The STE engine refNum
Return values:
UInt16 The position of the scroll bar in percentage.

Char* STEGetSelectedText | ( | UInt16 | refNum,
 |  | UInt16 | engineRefNum
 | ) |  |

This routine returns a copy of the actual text that is currently selected.

Parameters:
refNum,: IN: The STE refNum
engineRefNum,: IN: The STE engine refNum
Return values:
Char* Returns a copy of the current text selection. This must be freed by the caller.

Boolean STEHandleEvent | ( | UInt16 | refNum,
 |  | UInt16 | engineRefNum,
 |  | EventPtr | eventP
 | ) |  |

This routine should be called in the form's event handler. If there is no special handling of events, then this routine can be used to handle all the different events that can affect the STE.

Parameters:
refNum,: IN: The STE refNum
engineRefNum,: IN: The STE engine refNum
eventP,: IN: A pointer to the event record.
Return values:
Boolean True if handled, False if not handled

Boolean STEHandleKeyDownEvent | ( | UInt16 | refNum,
 |  | UInt16 | engineRefNum,
 |  | EventPtr | eventP
 | ) |  |

This routine handles only the keyDown event. This routine should be used if there is special handling of the events by the application before (or after) the STE handles the event.

Parameters:
refNum,: IN: The STE refNum
engineRefNum,: IN: The STE engine refNum
eventP,: IN: A pointer to the event record.
Return values:
Boolean True if handled, False if not handled

Boolean STEHandlePenDownEvent | ( | UInt16 | refNum,
 |  | UInt16 | engineRefNum,
 |  | EventPtr | eventP
 | ) |  |

This routine handles only the penDown event. This routine should be used if there is special handling of the events by the application before (or after) the STE handles the event.

Parameters:
refNum,: IN: The STE refNum
engineRefNum,: IN: The STE engine refNum
eventP,: IN: A pointer to the event record.
Return values:
Boolean True if handled, False if not handled

Boolean STEHandlePenMoveEvent | ( | UInt16 | refNum,
 |  | UInt16 | engineRefNum,
 |  | EventPtr | eventP
 | ) |  |

This routine handles only the penMove event. This routine should be used if there is special handling of the events by the application before (or after) the STE handles the event.

Parameters:
refNum,: IN: The STE refNum
engineRefNum,: IN: The STE engine refNum
eventP,: IN: A pointer to the event record.
Return values:
Boolean True if handled, False if not handled

Boolean STEHandlePenUpEvent | ( | UInt16 | refNum,
 |  | UInt16 | engineRefNum,
 |  | EventPtr | eventP
 | ) |  |

This routine handles only the penUp event. This routine should be used if there is special handling of the events by the application before (or after) the STE handles the event.

Parameters:
refNum,: IN: The STE refNum
engineRefNum,: IN: The STE engine refNum
eventP,: IN: A pointer to the event record.
Return values:
Boolean True if handled, False if not handled

Boolean STEHandleSclRepeatEvent | ( | UInt16 | refNum,
 |  | UInt16 | engineRefNum,
 |  | EventPtr | eventP
 | ) |  |

This routine handles only the sclRepeat event. This routine should be used if there is special handling of the events by the application before (or after) the STE handles the event.

Parameters:
refNum,: IN: The STE refNum
engineRefNum,: IN: The STE engine refNum
eventP,: IN: A pointer to the event record.
Return values:
Boolean True if handled, False if not handled

Boolean STEHasHotRectSelection | ( | UInt16 | refNum,
 |  | UInt16 | engineRefNum
 | ) |  |

This routine checks if there is a current hot rect selection. A hot rect is a hyperlink that has been selected with the keyboard.

Parameters:
refNum,: IN: The STE refNum
engineRefNum,: IN: The STE engine refNum
Return values:
Boolean True if there is a current hot rect selected

Boolean STEHasMessageSelection | ( | UInt16 | refNum,
 |  | UInt16 | engineRefNum
 | ) |  |

This routine checks if there is a current message selected.

Parameters:
refNum,: IN: The STE refNum
engineRefNum,: IN: The STE engine refNum
Return values:
Boolean True if there is a current message selected

Boolean STEHasTextSelection | ( | UInt16 | refNum,
 |  | UInt16 | engineRefNum
 | ) |  |

This routine checks if there is any text currently selected.

Parameters:
refNum,: IN: The STE refNum
engineRefNum,: IN: The STE engine refNum
Return values:
Boolean True if there is any text selected

STEErr STEInitializeEngine | ( | UInt16 | refNum,
 |  | UInt16 * | engineRefNum,
 |  | RectangleType * | listBounds,
 |  | UInt16 | scrollBarID,
 |  | UInt32 | flags,
 |  | UInt8 | phoneNumberColor,
 |  | UInt8 | urlColor,
 |  | UInt8 | emailColor
 | ) |  |

Styled Text Engine initialization function Before most of the STE can be used, it must be initialized. This function will return an engineRefNum which is to be used in the STE functions that require the STE to be initialized.

There are some functions that do not require the STE to be initialized. They are noted below.

Parameters:
refNum,: IN: The STE refNum
engineRefNum,: OUT: The STE engine refNum to be used in subsequent calls to the STE
listBounds,: IN: The bounds of the STE list that will be displayed
scrollBarID,: IN: The ID of the scroll used by the STE list. If this is 0, the list will not scroll. If there is more text than can be displayed, an ellipsis will be appended to the end.
flags,: IN: The flags for the STE
phoneNumberColor,: IN: The color of the phone number hyperlinks
urlColor,: IN: The color of the URL hyperlinks
emailColor,: IN: The color of the email hyperlinks
Return values:
STEErr Error Code or zero if no error occurs

STEErr STEOpen ( UInt16 refNum )

Standard library open routine. Library should always be loaded with SysLibLoad()(not SysLibFind()) before calling STEOpen(). See note at top of file.

Parameters:
refNum,: IN: Library reference number
Return values:
STEErr Error Code or zero if no error occurs

void STEQuickRender | ( | UInt16 | refNum,
 |  | RectangleType * | listBounds,
 |  | UInt32 | flags,
 |  | UInt8 | phoneNumberColor,
 |  | UInt8 | urlColor,
 |  | UInt8 | emailColor,
 |  | Char * | msgP
 | ) |  |

This routine will render the specified text as a "one shot deal". The text will not respond to any events, and hyperlinks do not work. This can be used to display rich text with graphics easily in your application.

This does NOT require the STE to be initialized.

Parameters:
refNum,: IN: The STE refNum
listBounds,: IN: The bounds of the STE list that will be displayed
flags,: IN: The flags for the STE
phoneNumberColor,: IN: The color of the phone number hyperlinks
urlColor,: IN: The color of the URL hyperlinks
emailColor,: IN: The color of the email hyperlinks
msgP,: IN: The text to display
Return values:
-

STEErr STEReinitializeEngine | ( | UInt16 | refNum,
 |  | UInt16 | engineRefNum
 | ) |  |

Initializes the STE to the initial state right after initializing it. This frees up any text that has been entered into the STE.

Parameters:
refNum,: IN: The STE refNum
engineRefNum,: IN: The STE engine refNum
Return values:
STEErr Error Code or zero if no error occurs

void STERemoveLastRecordFromEngine | ( | UInt16 | refNum,
 |  | UInt16 | engineRefNum
 | ) |  |

Removes the last text that was appended to the engine. You must call STERenderList to update the display after removing the text.

Parameters:
refNum,: IN: The STE refNum
engineRefNum,: IN: The STE engine refNum
Return values:
-

void STERenderList | ( | UInt16 | refNum,
 |  | UInt16 | engineRefNum
 | ) |  |

Renders the text that is currently in the STE.

Parameters:
refNum,: IN: The STE refNum
engineRefNum,: IN: The STE engine refNum
Return values:
-

void STERerenderList | ( | UInt16 | refNum,
 |  | UInt16 | engineRefNum
 | ) |  |

Rerenders the text that is currently in the STE. This routine should be used if a change is made that can change the formatting (i.e. font size).

Parameters:
refNum,: IN: The STE refNum
engineRefNum,: IN: The STE engine refNum
Return values:
-

STEErr STEResetEngine | ( | UInt16 | refNum,
 |  | UInt16 | engineRefNum
 | ) |  |

Frees up the STE engine refNum. For each STEInitializeEngine, there must be a corresponding STEResetEngine.

Parameters:
refNum,: IN: The STE refNum
engineRefNum,: IN: The STE engine refNum
Return values:
STEErr Error Code or zero if no error occurs

UInt16 STESetCurrentTextSelection | ( | UInt16 | refNum,
 |  | UInt16 | engineRefNum,
 |  | UInt16 | messageNumber,
 |  | UInt32 | startLocation,
 |  | UInt32 | selectionLength
 | ) |  |

This routine will select the specified text selection. The display will be updated to show the selected text as highlighted.

Parameters:
refNum,: IN: The STE refNum
engineRefNum,: IN: The STE engine refNum
messageNumber,: IN: The record number to start the selection
startLocation,: IN: The byte offset to start the text selection
selectionLength,: IN: The number of bytes in the text selection
Return values:
UInt16 Returns the line number of the topmost line of the selection

void STESetCustomHyperlinkCallback | ( | UInt16 | refNum,
 |  | UInt16 | engineRefNum,
 |  | STECallbackType | callback,
 |  | Boolean | armCallback
 | ) |  |

This routine sets the procedure to call as a result of tapping a custom hyperlink

Parameters:
refNum,: IN: The STE refNum
engineRefNum,: IN: The STE engine refNum
callback,: IN: The routine to call
armCallback,: IN: True if the callback routine is ARM code, false if it is 68K code
Return values:
-

void STESetFlags | ( | UInt16 | refNum,
 |  | UInt16 | engineRefNum,
 |  | UInt32 | flagsToSet,
 |  | UInt32 | flagsToClear
 | ) |  |

This routine sets the STE flags

Parameters:
refNum,: IN: The STE refNum
engineRefNum,: IN: The STE engine refNum
flagsToSet,: IN: Bitmap representing the flags to set
flagsToClear,: IN: Bitmap representing the flags to clear
Return values:
-

void STESetScroll | ( | UInt16 | refNum,
 |  | UInt16 | engineRefNum,
 |  | UInt16 | scrollValue
 | ) |  |

This routine sets the current scroll position of the STE's scroll bar.

Parameters:
refNum,: IN: The STE refNum
engineRefNum,: IN: The STE engine refNum
scrollValue,: IN: The position to set the scroll bar
Return values:
-

void STESetScrollPct | ( | UInt16 | refNum,
 |  | UInt16 | engineRefNum,
 |  | UInt16 | scrollPct
 | ) |  |

This routine sets the current scroll position percentage of the STE's scroll bar.

Parameters:
refNum,: IN: The STE refNum
engineRefNum,: IN: The STE engine refNum
scrollPct,: IN: The position to set the scroll bar in percentage
Return values:
-

void STESetScrollToRecordNum | ( | UInt16 | refNum,
 |  | UInt16 | engineRefNum,
 |  | UInt16 | recordNum
 | ) |  |

This routine sets the current scroll bar position so that the specified record appears at the top of the list.

Parameters:
refNum,: IN: The STE refNum
engineRefNum,: IN: The STE engine refNum
recordNum,: IN: The record number to display at the top of the list.
Return values:
-

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:04 2008 for Palm API Guide


Header Files » Incs » common » libraries » smarttextengine

SmartTextEngineDef.h File Reference

Detailed Description

Public include file for Smart Text Engine shared library.

The calling application should always load this library with SysLibLoad() before use, even if it is already open by another application(ie, SysLibFind() returns a valid refnum). When the application is done with the library, it should be unloaded with SysLibRemove(). We do this because there is no good way to synchronize loading and unloading of libraries among multiple applications. It also greatly simplifies internal

Definition in file SmartTextEngineDef.h.

Include dependency graph for SmartTextEngineDef.h:

Go to the source code of this file.

Data Structures

  • struct ParsedInfo
    Holds parsed item information. More...
  • struct ParsedInfoList
    Holds the list of parsed item information. More...

Defines

  • #define steLibName "SmartTextEngine.lib"
  • #define steLibDBName "Smart Text Engine"
  • #define kSmartTextBit 0x4000
  • #define steBitmap "//STEBITMAP="
  • #define steHyperlink "//STEHYPERLINK="
  • #define kScrollToEnd 0xFFFF
Parsed types
  • #define kParsedPhoneNumber 1
  • #define kParsedURL 2
  • #define kParsedEmail 3
  • #define kParsedDeviceURL 4
  • #define kParsedRtspURL 5
Font types
  • #define kSTEStdFont (kSmartTextBit | 0x00)
  • #define kSTEBoldFont (kSmartTextBit | 0x01)
Font colors
  • #define kSTECurrentFont (kSmartTextBit | 0x10)
  • #define kSTEBlackFont (kSmartTextBit | 0x11)
  • #define kSTEBlueFont (kSmartTextBit | 0x12)
  • #define kSTERedFont (kSmartTextBit | 0x13)
  • #define kSTEGreenFont (kSmartTextBit | 0x14)
  • #define kSTEYellowFont (kSmartTextBit | 0x15)
  • #define kSTEPurpleFont (kSmartTextBit | 0x16)
  • #define kSTEOrangeFont (kSmartTextBit | 0x17)
  • #define kSTEGrayFont (kSmartTextBit | 0x18)
Formating
  • #define kSTELineBreak (kSmartTextBit | 0x50)
  • #define kSTELeftIndent (kSmartTextBit | 0x51)
  • #define kSTERightAlign (kSmartTextBit | 0x52)
  • #define kSTECenterAlign (kSmartTextBit | 0x53)
  • #define kSTEHorizontalLine (kSmartTextBit | 0x60)
  • #define kSTEBitmap (kSmartTextBit | 0x70)
  • #define kSTESmileyBitmap (kSmartTextBit | 0x71)
  • #define kSTECharacterBitmap (kSmartTextBit | 0x72)
  • #define kSTEHyperlink (kSmartTextBit | 0x80)
Emoticons
  • #define kSmileSmiley (((UInt32)LargeSmiley00BitMap << 16) | Smiley00BitMap)
  • #define kWinkSmiley (((UInt32)LargeSmiley01BitMap << 16) | Smiley01BitMap)
  • #define kFrownSmiley (((UInt32)LargeSmiley02BitMap << 16) | Smiley02BitMap)
  • #define kBigTeethSmiley (((UInt32)LargeSmiley03BitMap << 16) | Smiley03BitMap)
  • #define kTongueSmiley (((UInt32)LargeSmiley04BitMap << 16) | Smiley04BitMap)
  • #define kDevilSmiley (((UInt32)LargeSmiley05BitMap << 16) | Smiley05BitMap)
  • #define kOMouthSmiley (((UInt32)LargeSmiley06BitMap << 16) | Smiley06BitMap)
  • #define kBigTongueSmiley (((UInt32)LargeSmiley07BitMap << 16) | Smiley07BitMap)
  • #define kHeartSmiley (((UInt32)LargeSmiley08BitMap << 16) | Smiley08BitMap)
  • #define kBigFrownSmiley (((UInt32)LargeSmiley09BitMap << 16) | Smiley09BitMap)
  • #define kQuestionSmiley (((UInt32)LargeSmiley10BitMap << 16) | Smiley10BitMap)
  • #define kPukeSmiley (((UInt32)LargeSmiley11BitMap << 16) | Smiley11BitMap)
  • #define kBigSmileSmiley (((UInt32)LargeSmiley12BitMap << 16) | Smiley12BitMap)
  • #define kBlushSmiley (((UInt32)LargeSmiley13BitMap << 16) | Smiley13BitMap)
  • #define kSmirkSmiley (((UInt32)LargeSmiley14BitMap << 16) | Smiley14BitMap)
  • #define kClownSmiley (((UInt32)LargeSmiley15BitMap << 16) | Smiley15BitMap)
  • #define kStraightMouthSmiley (((UInt32)LargeSmiley16BitMap << 16) | Smiley16BitMap)
  • #define kYinYangSmiley (((UInt32)LargeSmiley17BitMap << 16) | Smiley17BitMap)
  • #define kAngelSmiley (((UInt32)LargeSmiley18BitMap << 16) | Smiley18BitMap)
  • #define kCigarSmiley (((UInt32)LargeSmiley19BitMap << 16) | Smiley19BitMap)
  • #define kFlipSmiley (((UInt32)LargeSmiley20BitMap << 16) | Smiley20BitMap)
  • #define kUFlipSmiley (((UInt32)LargeSmiley21BitMap << 16) | Smiley21BitMap)
  • #define kLFlipSmiley (((UInt32)LargeSmiley22BitMap << 16) | Smiley22BitMap)
  • #define kRFlipSmiley (((UInt32)LargeSmiley23BitMap << 16) | Smiley23BitMap)
  • #define kDeltaCharacter (((UInt32)Delta14BitMap << 16) | Delta11BitMap)
  • #define kPhiCharacter (((UInt32)Phi14BitMap << 16) | Phi11BitMap)
  • #define kGammaCharacter (((UInt32)Gamma14BitMap << 16) | Gamma11BitMap)
  • #define kLambdaCharacter (((UInt32)Lambda14BitMap << 16) | Lambda11BitMap)
  • #define kOmegaCharacter (((UInt32)Omega14BitMap << 16) | Omega11BitMap)
  • #define kPiCharacter (((UInt32)Pi14BitMap << 16) | Pi11BitMap)
  • #define kPsiCharacter (((UInt32)Psi14BitMap << 16) | Psi11BitMap)
  • #define kSigmaCharacter (((UInt32)Sigma14BitMap << 16) | Sigma11BitMap)
  • #define kThetaCharacter (((UInt32)Theta14BitMap << 16) | Theta11BitMap)
  • #define kXiCharacter (((UInt32)Xi14BitMap << 16) | Xi11BitMap)
Link colors (from the CLUT)
  • #define kSTECurrent 254
  • #define kSTEBlack 255
  • #define kSTEBlue 95
  • #define kSTERed 125
  • #define kSTEGreen 210
  • #define kSTEYellow 120
  • #define kSTEPurple 23
  • #define kSTEOrange 116
  • #define kSTEGray 220
Inverse Color
  • #define kSTEBlackInverse 0
  • #define kSTEBlueInverse 114
  • #define kSTERedInverse 8
  • #define kSTEGreenInverse 18
  • #define kSTEYellowInverse 6
  • #define kSTEPurpleInverse 1
  • #define kSTEOrangeInverse 30
  • #define kSTEGrayInverse 25
Use standard or bold font
  • #define steStdFont "//STESTDFONT//"
  • #define steBoldFont "//STEBOLDFONT//"
Font colors
  • #define steCurrentFont "//STECURRENTFONT//"
  • #define steBlackFont "//STEBLACKFONT//"
  • #define steBlueFont "//STEBLUEFONT//"
  • #define steRedFont "//STEREDFONT//"
  • #define steGreenFont "//STEGREENFONT//"
  • #define steYellowFont "//STEYELLOWFONT//"
  • #define stePurpleFont "//STEPURPLEFONT//"
  • #define steOrangeFont "//STEORANGEFONT//"
  • #define steGrayFont "//STEGRAYFONT//"
Used for formatting
  • #define steLeftIndent "//STELEFTINDENT="
  • #define steRightAlign "//STERIGHTALIGN="
  • #define steCenterAlign "//STECENTERALIGN//"
Miscellaneous
  • #define steHorizontalLine "//STEHORIZONTALLINE//"
  • #define steLineBreak "//STELINEBREAK//"
Text Selection
  • #define kSelectUntilEndOfRecord 0xFFFFFFFE
  • #define kSelectUntilEnd 0xFFFFFFFF
Initializing the Smart Text Engine
  • #define steParsePhoneNumbers 0x00000001
  • #define steParseURLs 0x00000002
  • #define steParseEmail 0x00000004
  • #define steParseEmoticons 0x00000008
  • #define steLargeFont 0x00000010
  • #define steCannotSelectText 0x00000020
  • #define steParseMoreEmoticons 0x00000040
  • #define steScrollWalksLinks 0x00000080
  • #define steInvertHighlighting 0x00000100
  • #define steNoLinksBeforeColon 0x00000200
  • #define steAcceleratedScrolling 0x00000400
  • #define steAllowShortPhoneNumbers 0x00000800
  • #define steParseGSMGreekChars 0x00001000
  • #define steDoNotCenterVertically 0x00002000
  • #define steScrollWalksMessages 0x00004000
  • #define steTextMustBeVisible 0x00008000
  • #define steAllowPhoneNumberWords 0x00010000

Typedefs

  • typedef void(*) STECallbackType (UInt32 refNum)

Define Documentation

#define kAngelSmiley (((UInt32)LargeSmiley18BitMap << 16) | Smiley18BitMap)

Angel Smily

Definition at line 124 of file SmartTextEngineDef.h.

#define kBigFrownSmiley (((UInt32)LargeSmiley09BitMap << 16) | Smiley09BitMap)

Big Frown Smily

Definition at line 115 of file SmartTextEngineDef.h.

#define kBigSmileSmiley (((UInt32)LargeSmiley12BitMap << 16) | Smiley12BitMap)

Big Smile Smily

Definition at line 118 of file SmartTextEngineDef.h.

#define kBigTeethSmiley (((UInt32)LargeSmiley03BitMap << 16) | Smiley03BitMap)

Big Teeth Smily

Definition at line 109 of file SmartTextEngineDef.h.

#define kBigTongueSmiley (((UInt32)LargeSmiley07BitMap << 16) | Smiley07BitMap)

Big Tongue Smily

Definition at line 113 of file SmartTextEngineDef.h.

#define kBlushSmiley (((UInt32)LargeSmiley13BitMap << 16) | Smiley13BitMap)

Blush Smily

Definition at line 119 of file SmartTextEngineDef.h.

#define kCigarSmiley (((UInt32)LargeSmiley19BitMap << 16) | Smiley19BitMap)

Cigar Smily

Definition at line 125 of file SmartTextEngineDef.h.

#define kClownSmiley (((UInt32)LargeSmiley15BitMap << 16) | Smiley15BitMap)

Clown Smily

Definition at line 121 of file SmartTextEngineDef.h.

#define kDeltaCharacter (((UInt32)Delta14BitMap << 16) | Delta11BitMap)

Delta Character

Definition at line 132 of file SmartTextEngineDef.h.

#define kDevilSmiley (((UInt32)LargeSmiley05BitMap << 16) | Smiley05BitMap)

Devil Smily

Definition at line 111 of file SmartTextEngineDef.h.

#define kFlipSmiley (((UInt32)LargeSmiley20BitMap << 16) | Smiley20BitMap)

Flip Smily

Definition at line 126 of file SmartTextEngineDef.h.

#define kFrownSmiley (((UInt32)LargeSmiley02BitMap << 16) | Smiley02BitMap)

Frowning Smily

Definition at line 108 of file SmartTextEngineDef.h.

#define kGammaCharacter (((UInt32)Gamma14BitMap << 16) | Gamma11BitMap)

Gamma Character

Definition at line 134 of file SmartTextEngineDef.h.

#define kHeartSmiley (((UInt32)LargeSmiley08BitMap << 16) | Smiley08BitMap)

Heart Smily

Definition at line 114 of file SmartTextEngineDef.h.

#define kLambdaCharacter (((UInt32)Lambda14BitMap << 16) | Lambda11BitMap)

Lambda Character

Definition at line 135 of file SmartTextEngineDef.h.

#define kLFlipSmiley (((UInt32)LargeSmiley22BitMap << 16) | Smiley22BitMap)

Left Flip Smily

Definition at line 128 of file SmartTextEngineDef.h.

#define kOmegaCharacter (((UInt32)Omega14BitMap << 16) | Omega11BitMap)

Omega Character

Definition at line 136 of file SmartTextEngineDef.h.

#define kOMouthSmiley (((UInt32)LargeSmiley06BitMap << 16) | Smiley06BitMap)

O-mouth Smily

Definition at line 112 of file SmartTextEngineDef.h.

#define kParsedDeviceURL 4

Definition at line 51 of file SmartTextEngineDef.h.

#define kParsedEmail 3

Definition at line 50 of file SmartTextEngineDef.h.

#define kParsedPhoneNumber 1

Definition at line 48 of file SmartTextEngineDef.h.

#define kParsedRtspURL 5

Definition at line 52 of file SmartTextEngineDef.h.

#define kParsedURL 2

Definition at line 49 of file SmartTextEngineDef.h.

#define kPhiCharacter (((UInt32)Phi14BitMap << 16) | Phi11BitMap)

Phi Character

Definition at line 133 of file SmartTextEngineDef.h.

#define kPiCharacter (((UInt32)Pi14BitMap << 16) | Pi11BitMap)

Pi Character

Definition at line 137 of file SmartTextEngineDef.h.

#define kPsiCharacter (((UInt32)Psi14BitMap << 16) | Psi11BitMap)

Psi Character

Definition at line 138 of file SmartTextEngineDef.h.

#define kPukeSmiley (((UInt32)LargeSmiley11BitMap << 16) | Smiley11BitMap)

Puke Smily

Definition at line 117 of file SmartTextEngineDef.h.

#define kQuestionSmiley (((UInt32)LargeSmiley10BitMap << 16) | Smiley10BitMap)

Question Smily

Definition at line 116 of file SmartTextEngineDef.h.

#define kRFlipSmiley (((UInt32)LargeSmiley23BitMap << 16) | Smiley23BitMap)

Right Flip Smily

Definition at line 129 of file SmartTextEngineDef.h.

#define kScrollToEnd 0xFFFF

Used to scroll to end

Definition at line 228 of file SmartTextEngineDef.h.

#define kSelectUntilEnd 0xFFFFFFFF

Select until End

Definition at line 236 of file SmartTextEngineDef.h.

#define kSelectUntilEndOfRecord 0xFFFFFFFE

Select till end of record

Definition at line 235 of file SmartTextEngineDef.h.

#define kSigmaCharacter (((UInt32)Sigma14BitMap << 16) | Sigma11BitMap)

Sigma Character

Definition at line 139 of file SmartTextEngineDef.h.

#define kSmartTextBit 0x4000

No definition

Definition at line 55 of file SmartTextEngineDef.h.

#define kSmileSmiley (((UInt32)LargeSmiley00BitMap << 16) | Smiley00BitMap)

Smiling Smily

Definition at line 106 of file SmartTextEngineDef.h.

#define kSmirkSmiley (((UInt32)LargeSmiley14BitMap << 16) | Smiley14BitMap)

Smirk Smily

Definition at line 120 of file SmartTextEngineDef.h.

#define kSTEBitmap (kSmartTextBit | 0x70)

Bitmap

Definition at line 94 of file SmartTextEngineDef.h.

#define kSTEBlack 255

Black

Definition at line 150 of file SmartTextEngineDef.h.

#define kSTEBlackFont (kSmartTextBit | 0x11)

Black font color

Definition at line 72 of file SmartTextEngineDef.h.

#define kSTEBlackInverse 0

Black Inverse

Definition at line 165 of file SmartTextEngineDef.h.

#define kSTEBlue 95

Blue

Definition at line 151 of file SmartTextEngineDef.h.

#define kSTEBlueFont (kSmartTextBit | 0x12)

Blue font color

Definition at line 73 of file SmartTextEngineDef.h.

#define kSTEBlueInverse 114

Blue Inverse

Definition at line 166 of file SmartTextEngineDef.h.

#define kSTEBoldFont (kSmartTextBit | 0x01)

Definition at line 63 of file SmartTextEngineDef.h.

#define kSTECenterAlign (kSmartTextBit | 0x53)

Center Alignment

Definition at line 90 of file SmartTextEngineDef.h.

#define kSTECharacterBitmap (kSmartTextBit | 0x72)

Character Bitmap

Definition at line 96 of file SmartTextEngineDef.h.

#define kSTECurrent 254

Definition at line 149 of file SmartTextEngineDef.h.

#define kSTECurrentFont (kSmartTextBit | 0x10)

Current font color

Definition at line 71 of file SmartTextEngineDef.h.

#define kSTEGray 220

Gray

Definition at line 157 of file SmartTextEngineDef.h.

#define kSTEGrayFont (kSmartTextBit | 0x18)

Gray font color

Definition at line 79 of file SmartTextEngineDef.h.

#define kSTEGrayInverse 25

Gray Inverse

Definition at line 172 of file SmartTextEngineDef.h.

#define kSTEGreen 210

Green

Definition at line 153 of file SmartTextEngineDef.h.

#define kSTEGreenFont (kSmartTextBit | 0x14)

Green font color

Definition at line 75 of file SmartTextEngineDef.h.

#define kSTEGreenInverse 18

Green Inverse

Definition at line 168 of file SmartTextEngineDef.h.

#define kSTEHorizontalLine (kSmartTextBit | 0x60)

Horizontal Line

Definition at line 92 of file SmartTextEngineDef.h.

#define kSTEHyperlink (kSmartTextBit | 0x80)

Hyperlink

Definition at line 98 of file SmartTextEngineDef.h.

#define kSTELeftIndent (kSmartTextBit | 0x51)

Left Indentation

Definition at line 88 of file SmartTextEngineDef.h.

#define kSTELineBreak (kSmartTextBit | 0x50)

Line Break

Definition at line 87 of file SmartTextEngineDef.h.

#define kSTEOrange 116

Orange

Definition at line 156 of file SmartTextEngineDef.h.

#define kSTEOrangeFont (kSmartTextBit | 0x17)

Orange font color

Definition at line 78 of file SmartTextEngineDef.h.

#define kSTEOrangeInverse 30

Orange Inverse

Definition at line 171 of file SmartTextEngineDef.h.

#define kSTEPurple 23

Purple

Definition at line 155 of file SmartTextEngineDef.h.

#define kSTEPurpleFont (kSmartTextBit | 0x16)

Purple font color

Definition at line 77 of file SmartTextEngineDef.h.

#define kSTEPurpleInverse 1

Purple Inverse

Definition at line 170 of file SmartTextEngineDef.h.

#define kSTERed 125

Red

Definition at line 152 of file SmartTextEngineDef.h.

#define kSTERedFont (kSmartTextBit | 0x13)

Red font color

Definition at line 74 of file SmartTextEngineDef.h.

#define kSTERedInverse 8

Red Inverse

Definition at line 167 of file SmartTextEngineDef.h.

#define kSTERightAlign (kSmartTextBit | 0x52)

Right Alignment

Definition at line 89 of file SmartTextEngineDef.h.

#define kSTESmileyBitmap (kSmartTextBit | 0x71)

Smiley Bitmap

Definition at line 95 of file SmartTextEngineDef.h.

#define kSTEStdFont (kSmartTextBit | 0x00)

Definition at line 62 of file SmartTextEngineDef.h.

#define kSTEYellow 120

Yellow

Definition at line 154 of file SmartTextEngineDef.h.

#define kSTEYellowFont (kSmartTextBit | 0x15)

Yellow font color

Definition at line 76 of file SmartTextEngineDef.h.

#define kSTEYellowInverse 6

Yellow Inverse

Definition at line 169 of file SmartTextEngineDef.h.

#define kStraightMouthSmiley (((UInt32)LargeSmiley16BitMap << 16) | Smiley16BitMap)

Straight Mouth Smily

Definition at line 122 of file SmartTextEngineDef.h.

#define kThetaCharacter (((UInt32)Theta14BitMap << 16) | Theta11BitMap)

Theta Character

Definition at line 140 of file SmartTextEngineDef.h.

#define kTongueSmiley (((UInt32)LargeSmiley04BitMap << 16) | Smiley04BitMap)

Tongue Smily

Definition at line 110 of file SmartTextEngineDef.h.

#define kUFlipSmiley (((UInt32)LargeSmiley21BitMap << 16) | Smiley21BitMap)

Up Flip Smily

Definition at line 127 of file SmartTextEngineDef.h.

#define kWinkSmiley (((UInt32)LargeSmiley01BitMap << 16) | Smiley01BitMap)

Winking Smily

Definition at line 107 of file SmartTextEngineDef.h.

#define kXiCharacter (((UInt32)Xi14BitMap << 16) | Xi11BitMap)

Xi Character

Definition at line 141 of file SmartTextEngineDef.h.

#define kYinYangSmiley (((UInt32)LargeSmiley17BitMap << 16) | Smiley17BitMap)

Yin Yang Smily

Definition at line 123 of file SmartTextEngineDef.h.

#define steAcceleratedScrolling 0x00000400

No Accelerated Scrolling

Definition at line 254 of file SmartTextEngineDef.h.

#define steAllowPhoneNumberWords 0x00010000

If true, then the phone number parser will allow numbers like 1-800-TESTING

Definition at line 260 of file SmartTextEngineDef.h.

#define steAllowShortPhoneNumbers 0x00000800

Allow Short Phone Numbers

Definition at line 255 of file SmartTextEngineDef.h.

#define steBitmap "//STEBITMAP="

Graphics support

Definition at line 213 of file SmartTextEngineDef.h.

#define steBlackFont "//STEBLACKFONT//"

Black font color

Definition at line 193 of file SmartTextEngineDef.h.

#define steBlueFont "//STEBLUEFONT//"

Blue font color

Definition at line 194 of file SmartTextEngineDef.h.

#define steBoldFont "//STEBOLDFONT//"

Bold Font

Definition at line 184 of file SmartTextEngineDef.h.

#define steCannotSelectText 0x00000020

Cannot Select Text

Definition at line 249 of file SmartTextEngineDef.h.

#define steCenterAlign "//STECENTERALIGN//"

Center Alignment

Definition at line 210 of file SmartTextEngineDef.h.

#define steCurrentFont "//STECURRENTFONT//"

Current font color

Definition at line 192 of file SmartTextEngineDef.h.

#define steDoNotCenterVertically 0x00002000

Do not center vertically

Definition at line 257 of file SmartTextEngineDef.h.

#define steGrayFont "//STEGRAYFONT//"

Gray font color

Definition at line 200 of file SmartTextEngineDef.h.

#define steGreenFont "//STEGREENFONT//"

Green font color

Definition at line 196 of file SmartTextEngineDef.h.

#define steHorizontalLine "//STEHORIZONTALLINE//"

Horizontal Line

Definition at line 220 of file SmartTextEngineDef.h.

#define steHyperlink "//STEHYPERLINK="

Hyperlink

Definition at line 225 of file SmartTextEngineDef.h.

#define steInvertHighlighting 0x00000100

Invert highlighting

Definition at line 252 of file SmartTextEngineDef.h.

#define steLargeFont 0x00000010

Large Font

Definition at line 248 of file SmartTextEngineDef.h.

#define steLeftIndent "//STELEFTINDENT="

Left Indentation

Definition at line 208 of file SmartTextEngineDef.h.

#define steLibDBName "Smart Text Engine"

Name used for DmFindDatabase

Definition at line 40 of file SmartTextEngineDef.h.

#define steLibName "SmartTextEngine.lib"

Internal library name which can(but shouldn't) be passed to SysLibFind()

Definition at line 39 of file SmartTextEngineDef.h.

#define steLineBreak "//STELINEBREAK//"

Line Break

Definition at line 221 of file SmartTextEngineDef.h.

#define steNoLinksBeforeColon 0x00000200

No links before colon

Definition at line 253 of file SmartTextEngineDef.h.

#define steOrangeFont "//STEORANGEFONT//"

Orange font color

Definition at line 199 of file SmartTextEngineDef.h.

#define steParseEmail 0x00000004

parse Email

Definition at line 246 of file SmartTextEngineDef.h.

#define steParseEmoticons 0x00000008

parse Emotions

Definition at line 247 of file SmartTextEngineDef.h.

#define steParseGSMGreekChars 0x00001000

Parse GSM Greek Characters

Definition at line 256 of file SmartTextEngineDef.h.

#define steParseMoreEmoticons 0x00000040

Parse More Emoticons

Definition at line 250 of file SmartTextEngineDef.h.

#define steParsePhoneNumbers 0x00000001

Parse Phone Numbers

Definition at line 244 of file SmartTextEngineDef.h.

#define steParseURLs 0x00000002

Parse URLs

Definition at line 245 of file SmartTextEngineDef.h.

#define stePurpleFont "//STEPURPLEFONT//"

Purple font color

Definition at line 198 of file SmartTextEngineDef.h.

#define steRedFont "//STEREDFONT//"

Red font color

Definition at line 195 of file SmartTextEngineDef.h.

#define steRightAlign "//STERIGHTALIGN="

Right Indentation

Definition at line 209 of file SmartTextEngineDef.h.

#define steScrollWalksLinks 0x00000080

Scroll Walks links

Definition at line 251 of file SmartTextEngineDef.h.

#define steScrollWalksMessages 0x00004000

Scroll walks messages

Definition at line 258 of file SmartTextEngineDef.h.

#define steStdFont "//STESTDFONT//"

Standard Font

Definition at line 183 of file SmartTextEngineDef.h.

#define steTextMustBeVisible 0x00008000

If true, then any routine that returns selected text must verify the text is visible first

Definition at line 259 of file SmartTextEngineDef.h.

#define steYellowFont "//STEYELLOWFONT//"

Yellow font color

Definition at line 197 of file SmartTextEngineDef.h.

Typedef Documentation

typedef void(*) STECallbackType(UInt32 refNum)

Used for custom hyperlinks

Definition at line 264 of file SmartTextEngineDef.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:05 2008 for Palm API Guide


Header Files » Incs » common » libraries » smarttextengine

SmartTextEngineErrors.h File Reference

Detailed Description

Error codes for Smart Text Engine shared library.

Definition in file SmartTextEngineErrors.h.

Go to the source code of this file.

Defines

  • #define steErrBase hsSTEErrorClass
  • #define steErrUnimplemented (steErrBase + 1)
  • #define steErrInternal (steErrBase + 2)
  • #define steErrDynamicMemory (steErrBase + 3)
  • #define steErrStorageMemory (steErrBase + 4)
  • #define steErrOperationNotAllowed (steErrBase + 5)
  • #define steErrInvalidArguments (steErrBase + 6)
  • #define steErrSTEInit (steErrBase + 7)

Typedefs

  • typedef UInt32 STEErr

Define Documentation

#define steErrBase hsSTEErrorClass

Error Code starting base

Definition at line 24 of file SmartTextEngineErrors.h.

#define steErrDynamicMemory (steErrBase + 3)

Dynamic memory allocation failed

Definition at line 27 of file SmartTextEngineErrors.h.

#define steErrInternal (steErrBase + 2)

Unspecified internal error

Definition at line 26 of file SmartTextEngineErrors.h.

#define steErrInvalidArguments (steErrBase + 6)

Bad arguments

Definition at line 30 of file SmartTextEngineErrors.h.

#define steErrOperationNotAllowed (steErrBase + 5)

Operation cannot be performed at this time

Definition at line 29 of file SmartTextEngineErrors.h.

#define steErrSTEInit (steErrBase + 7)

STE initialization failed

Definition at line 31 of file SmartTextEngineErrors.h.

#define steErrStorageMemory (steErrBase + 4)

Storage memory allocation failed

Definition at line 28 of file SmartTextEngineErrors.h.

#define steErrUnimplemented (steErrBase + 1)

Functionality not currently implemented

Definition at line 25 of file SmartTextEngineErrors.h.

Typedef Documentation

typedef UInt32 STEErr

Common define for Smart Text Engine Error Code return value

Definition at line 20 of file SmartTextEngineErrors.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:05 2008 for Palm API Guide


Header Files » Incs » common » libraries » smarttextengine

SmartTextEngineRsc.h File Reference

Go to the source code of this file.

Defines

  • #define __SMART_TEXT_ENGINE_RSC_H__ 1
  • #define Delta11BitMap 9800
  • #define Gamma11BitMap 9801
  • #define Lambda11BitMap 9802
  • #define Omega11BitMap 9803
  • #define Phi11BitMap 9804
  • #define Pi11BitMap 9805
  • #define Psi11BitMap 9806
  • #define Sigma11BitMap 9807
  • #define Theta11BitMap 9808
  • #define Xi11BitMap 9809
  • #define Delta14BitMap 9850
  • #define Gamma14BitMap 9851
  • #define Lambda14BitMap 9852
  • #define Omega14BitMap 9853
  • #define Phi14BitMap 9854
  • #define Pi14BitMap 9855
  • #define Psi14BitMap 9856
  • #define Sigma14BitMap 9857
  • #define Theta14BitMap 9858
  • #define Xi14BitMap 9859
  • #define SmileyBitMapBaseID 9900
  • #define Smiley00BitMap 9900
  • #define Smiley01BitMap 9901
  • #define Smiley02BitMap 9902
  • #define Smiley03BitMap 9903
  • #define Smiley04BitMap 9904
  • #define Smiley05BitMap 9905
  • #define Smiley06BitMap 9906
  • #define Smiley07BitMap 9907
  • #define Smiley08BitMap 9908
  • #define Smiley09BitMap 9909
  • #define Smiley10BitMap 9910
  • #define Smiley11BitMap 9911
  • #define Smiley12BitMap 9912
  • #define Smiley13BitMap 9913
  • #define Smiley14BitMap 9914
  • #define Smiley15BitMap 9915
  • #define Smiley16BitMap 9916
  • #define Smiley17BitMap 9917
  • #define Smiley18BitMap 9918
  • #define Smiley19BitMap 9919
  • #define Smiley20BitMap 9920
  • #define Smiley21BitMap 9921
  • #define Smiley22BitMap 9922
  • #define Smiley23BitMap 9923
  • #define LargeSmileyBitMapBaseID 9950
  • #define LargeSmiley00BitMap 9950
  • #define LargeSmiley01BitMap 9951
  • #define LargeSmiley02BitMap 9952
  • #define LargeSmiley03BitMap 9953
  • #define LargeSmiley04BitMap 9954
  • #define LargeSmiley05BitMap 9955
  • #define LargeSmiley06BitMap 9956
  • #define LargeSmiley07BitMap 9957
  • #define LargeSmiley08BitMap 9958
  • #define LargeSmiley09BitMap 9959
  • #define LargeSmiley10BitMap 9960
  • #define LargeSmiley11BitMap 9961
  • #define LargeSmiley12BitMap 9962
  • #define LargeSmiley13BitMap 9963
  • #define LargeSmiley14BitMap 9964
  • #define LargeSmiley15BitMap 9965
  • #define LargeSmiley16BitMap 9966
  • #define LargeSmiley17BitMap 9967
  • #define LargeSmiley18BitMap 9968
  • #define LargeSmiley19BitMap 9969
  • #define LargeSmiley20BitMap 9970
  • #define LargeSmiley21BitMap 9971
  • #define LargeSmiley22BitMap 9972
  • #define LargeSmiley23BitMap 9973

Define Documentation

#define __SMART_TEXT_ENGINE_RSC_H__ 1

Definition at line 20 of file SmartTextEngineRsc.h.

#define Delta11BitMap 9800

Definition at line 25 of file SmartTextEngineRsc.h.

#define Delta14BitMap 9850

Definition at line 36 of file SmartTextEngineRsc.h.

#define Gamma11BitMap 9801

Definition at line 26 of file SmartTextEngineRsc.h.

#define Gamma14BitMap 9851

Definition at line 37 of file SmartTextEngineRsc.h.

#define Lambda11BitMap 9802

Definition at line 27 of file SmartTextEngineRsc.h.

#define Lambda14BitMap 9852

Definition at line 38 of file SmartTextEngineRsc.h.

#define LargeSmiley00BitMap 9950

Definition at line 84 of file SmartTextEngineRsc.h.

#define LargeSmiley01BitMap 9951

Definition at line 85 of file SmartTextEngineRsc.h.

#define LargeSmiley02BitMap 9952

Definition at line 86 of file SmartTextEngineRsc.h.

#define LargeSmiley03BitMap 9953

Definition at line 87 of file SmartTextEngineRsc.h.

#define LargeSmiley04BitMap 9954

Definition at line 88 of file SmartTextEngineRsc.h.

#define LargeSmiley05BitMap 9955

Definition at line 89 of file SmartTextEngineRsc.h.

#define LargeSmiley06BitMap 9956

Definition at line 90 of file SmartTextEngineRsc.h.

#define LargeSmiley07BitMap 9957

Definition at line 91 of file SmartTextEngineRsc.h.

#define LargeSmiley08BitMap 9958

Definition at line 92 of file SmartTextEngineRsc.h.

#define LargeSmiley09BitMap 9959

Definition at line 93 of file SmartTextEngineRsc.h.

#define LargeSmiley10BitMap 9960

Definition at line 94 of file SmartTextEngineRsc.h.

#define LargeSmiley11BitMap 9961

Definition at line 95 of file SmartTextEngineRsc.h.

#define LargeSmiley12BitMap 9962

Definition at line 96 of file SmartTextEngineRsc.h.

#define LargeSmiley13BitMap 9963

Definition at line 97 of file SmartTextEngineRsc.h.

#define LargeSmiley14BitMap 9964

Definition at line 98 of file SmartTextEngineRsc.h.

#define LargeSmiley15BitMap 9965

Definition at line 99 of file SmartTextEngineRsc.h.

#define LargeSmiley16BitMap 9966

Definition at line 100 of file SmartTextEngineRsc.h.

#define LargeSmiley17BitMap 9967

Definition at line 101 of file SmartTextEngineRsc.h.

#define LargeSmiley18BitMap 9968

Definition at line 102 of file SmartTextEngineRsc.h.

#define LargeSmiley19BitMap 9969

Definition at line 103 of file SmartTextEngineRsc.h.

#define LargeSmiley20BitMap 9970

Definition at line 104 of file SmartTextEngineRsc.h.

#define LargeSmiley21BitMap 9971

Definition at line 105 of file SmartTextEngineRsc.h.

#define LargeSmiley22BitMap 9972

Definition at line 106 of file SmartTextEngineRsc.h.

#define LargeSmiley23BitMap 9973

Definition at line 107 of file SmartTextEngineRsc.h.

#define LargeSmileyBitMapBaseID 9950

Definition at line 83 of file SmartTextEngineRsc.h.

#define Omega11BitMap 9803

Definition at line 28 of file SmartTextEngineRsc.h.

#define Omega14BitMap 9853

Definition at line 39 of file SmartTextEngineRsc.h.

#define Phi11BitMap 9804

Definition at line 29 of file SmartTextEngineRsc.h.

#define Phi14BitMap 9854

Definition at line 40 of file SmartTextEngineRsc.h.

#define Pi11BitMap 9805

Definition at line 30 of file SmartTextEngineRsc.h.

#define Pi14BitMap 9855

Definition at line 41 of file SmartTextEngineRsc.h.

#define Psi11BitMap 9806

Definition at line 31 of file SmartTextEngineRsc.h.

#define Psi14BitMap 9856

Definition at line 42 of file SmartTextEngineRsc.h.

#define Sigma11BitMap 9807

Definition at line 32 of file SmartTextEngineRsc.h.

#define Sigma14BitMap 9857

Definition at line 43 of file SmartTextEngineRsc.h.

#define Smiley00BitMap 9900

Definition at line 53 of file SmartTextEngineRsc.h.

#define Smiley01BitMap 9901

Definition at line 54 of file SmartTextEngineRsc.h.

#define Smiley02BitMap 9902

Definition at line 55 of file SmartTextEngineRsc.h.

#define Smiley03BitMap 9903

Definition at line 56 of file SmartTextEngineRsc.h.

#define Smiley04BitMap 9904

Definition at line 57 of file SmartTextEngineRsc.h.

#define Smiley05BitMap 9905

Definition at line 58 of file SmartTextEngineRsc.h.

#define Smiley06BitMap 9906

Definition at line 59 of file SmartTextEngineRsc.h.

#define Smiley07BitMap 9907

Definition at line 60 of file SmartTextEngineRsc.h.

#define Smiley08BitMap 9908

Definition at line 61 of file SmartTextEngineRsc.h.

#define Smiley09BitMap 9909

Definition at line 62 of file SmartTextEngineRsc.h.

#define Smiley10BitMap 9910

Definition at line 63 of file SmartTextEngineRsc.h.

#define Smiley11BitMap 9911

Definition at line 64 of file SmartTextEngineRsc.h.

#define Smiley12BitMap 9912

Definition at line 65 of file SmartTextEngineRsc.h.

#define Smiley13BitMap 9913

Definition at line 66 of file SmartTextEngineRsc.h.

#define Smiley14BitMap 9914

Definition at line 67 of file SmartTextEngineRsc.h.

#define Smiley15BitMap 9915

Definition at line 68 of file SmartTextEngineRsc.h.

#define Smiley16BitMap 9916

Definition at line 69 of file SmartTextEngineRsc.h.

#define Smiley17BitMap 9917

Definition at line 70 of file SmartTextEngineRsc.h.

#define Smiley18BitMap 9918

Definition at line 71 of file SmartTextEngineRsc.h.

#define Smiley19BitMap 9919

Definition at line 72 of file SmartTextEngineRsc.h.

#define Smiley20BitMap 9920

Definition at line 73 of file SmartTextEngineRsc.h.

#define Smiley21BitMap 9921

Definition at line 74 of file SmartTextEngineRsc.h.

#define Smiley22BitMap 9922

Definition at line 75 of file SmartTextEngineRsc.h.

#define Smiley23BitMap 9923

Definition at line 76 of file SmartTextEngineRsc.h.

#define SmileyBitMapBaseID 9900

Definition at line 52 of file SmartTextEngineRsc.h.

#define Theta11BitMap 9808

Definition at line 33 of file SmartTextEngineRsc.h.

#define Theta14BitMap 9858

Definition at line 44 of file SmartTextEngineRsc.h.

#define Xi11BitMap 9809

Definition at line 34 of file SmartTextEngineRsc.h.

#define Xi14BitMap 9859

Definition at line 45 of file SmartTextEngineRsc.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:06 2008 for Palm API Guide


Header Files » Incs » common » libraries » smarttextengine

SmartTextEngineTraps.h File Reference

Detailed Description

Trap definitions for the Smart Text Engine shared library.

Definition in file SmartTextEngineTraps.h.

Go to the source code of this file.

Defines

  • #define STETrapOpen sysLibTrapOpen
  • #define STETrapClose sysLibTrapClose
  • #define STETrapGetAPIVersion (sysLibTrapCustom + 0)
  • #define STETrapInitializeEngine (sysLibTrapCustom + 1)
  • #define STETrapResetEngine (sysLibTrapCustom + 2)
  • #define STETrapReinitializeEngine (sysLibTrapCustom + 3)
  • #define STETrapAppendTextToEngine (sysLibTrapCustom + 4)
  • #define STETrapRemoveLastRecordFromEngine (sysLibTrapCustom + 5)
  • #define STETrapRenderList (sysLibTrapCustom + 6)
  • #define STETrapRerenderList (sysLibTrapCustom + 7)
  • #define STETrapHandleEvent (sysLibTrapCustom + 8)
  • #define STETrapHandleSclRepeatEvent (sysLibTrapCustom + 9)
  • #define STETrapHandlePenDownEvent (sysLibTrapCustom + 10)
  • #define STETrapHandlePenMoveEvent (sysLibTrapCustom + 11)
  • #define STETrapHandlePenUpEvent (sysLibTrapCustom + 12)
  • #define STETrapHandleKeyDownEvent (sysLibTrapCustom + 13)
  • #define STETrapGetScroll (sysLibTrapCustom + 14)
  • #define STETrapSetScroll (sysLibTrapCustom + 15)
  • #define STETrapGetScrollPct (sysLibTrapCustom + 16)
  • #define STETrapSetScrollPct (sysLibTrapCustom + 17)
  • #define STETrapSetScrollToRecordNum (sysLibTrapCustom + 18)
  • #define STETrapSetFlags (sysLibTrapCustom + 19)
  • #define STETrapGetNumLines (sysLibTrapCustom + 20)
  • #define STETrapGetNumRecords (sysLibTrapCustom + 21)
  • #define STETrapHasHotRectSelection (sysLibTrapCustom + 22)
  • #define STETrapHasTextSelection (sysLibTrapCustom + 23)
  • #define STETrapClearCurrentSelection (sysLibTrapCustom + 24)
  • #define STETrapSetCurrentTextSelection (sysLibTrapCustom + 25)
  • #define STETrapGetCurrentTextSelection (sysLibTrapCustom + 26)
  • #define STETrapGetSelectedText (sysLibTrapCustom + 27)
  • #define STETrapCopySelectionToClipboard (sysLibTrapCustom + 28)
  • #define STETrapGetLastTapInfo (sysLibTrapCustom + 29)
  • #define STETrapSetCustomHyperlinkCallback (sysLibTrapCustom + 30)
  • #define STETrapGetFlags (sysLibTrapCustom + 31)
  • #define STETrapHasMessageSelection (sysLibTrapCustom + 32)
  • #define STETrapGetParsedInformation (sysLibTrapCustom + 33)
  • #define STETrapAppendParsedInfo (sysLibTrapCustom + 34)
  • #define STEDepracated5 (sysLibTrapCustom + 35)
  • #define STETrapQuickRender (sysLibTrapCustom + 36)

Define Documentation

#define STEDepracated5 (sysLibTrapCustom + 35)

Trap ID for Depracated5

Definition at line 64 of file SmartTextEngineTraps.h.

#define STETrapAppendParsedInfo (sysLibTrapCustom + 34)

Trap ID for Append parsed info

Definition at line 63 of file SmartTextEngineTraps.h.

#define STETrapAppendTextToEngine (sysLibTrapCustom + 4)

Trap ID for Append Text to Engine

Definition at line 33 of file SmartTextEngineTraps.h.

#define STETrapClearCurrentSelection (sysLibTrapCustom + 24)

Trap ID for Clear current selection

Definition at line 53 of file SmartTextEngineTraps.h.

#define STETrapClose sysLibTrapClose

Close Trap

Definition at line 27 of file SmartTextEngineTraps.h.

#define STETrapCopySelectionToClipboard (sysLibTrapCustom + 28)

Trap ID for Copy selection clipboard

Definition at line 57 of file SmartTextEngineTraps.h.

#define STETrapGetAPIVersion (sysLibTrapCustom + 0)

Trap ID for Get API function

Definition at line 29 of file SmartTextEngineTraps.h.

#define STETrapGetCurrentTextSelection (sysLibTrapCustom + 26)

Trap ID for Get current selection

Definition at line 55 of file SmartTextEngineTraps.h.

#define STETrapGetFlags (sysLibTrapCustom + 31)

Trap ID for Get flags

Definition at line 60 of file SmartTextEngineTraps.h.

#define STETrapGetLastTapInfo (sysLibTrapCustom + 29)

Trap ID for Last Tap info

Definition at line 58 of file SmartTextEngineTraps.h.

#define STETrapGetNumLines (sysLibTrapCustom + 20)

Trap ID for Get num lines

Definition at line 49 of file SmartTextEngineTraps.h.

#define STETrapGetNumRecords (sysLibTrapCustom + 21)

Trap ID for Get num records

Definition at line 50 of file SmartTextEngineTraps.h.

#define STETrapGetParsedInformation (sysLibTrapCustom + 33)

Trap ID for Get parsed information

Definition at line 62 of file SmartTextEngineTraps.h.

#define STETrapGetScroll (sysLibTrapCustom + 14)

Trap ID for Get scroll

Definition at line 43 of file SmartTextEngineTraps.h.

#define STETrapGetScrollPct (sysLibTrapCustom + 16)

Trap ID for Get scroll pct

Definition at line 45 of file SmartTextEngineTraps.h.

#define STETrapGetSelectedText (sysLibTrapCustom + 27)

Trap ID for Get selected text

Definition at line 56 of file SmartTextEngineTraps.h.

#define STETrapHandleEvent (sysLibTrapCustom + 8)

Trap ID for Handle Event

Definition at line 37 of file SmartTextEngineTraps.h.

#define STETrapHandleKeyDownEvent (sysLibTrapCustom + 13)

Trap ID for Handle key down event

Definition at line 42 of file SmartTextEngineTraps.h.

#define STETrapHandlePenDownEvent (sysLibTrapCustom + 10)

Trap ID for Handle pen down event

Definition at line 39 of file SmartTextEngineTraps.h.

#define STETrapHandlePenMoveEvent (sysLibTrapCustom + 11)

Trap ID for Handle pen move event

Definition at line 40 of file SmartTextEngineTraps.h.

#define STETrapHandlePenUpEvent (sysLibTrapCustom + 12)

Trap ID for Handle pen up event

Definition at line 41 of file SmartTextEngineTraps.h.

#define STETrapHandleSclRepeatEvent (sysLibTrapCustom + 9)

Trap ID for Handle Scl repeat event

Definition at line 38 of file SmartTextEngineTraps.h.

#define STETrapHasHotRectSelection (sysLibTrapCustom + 22)

Trap ID for Has hot rect selection

Definition at line 51 of file SmartTextEngineTraps.h.

#define STETrapHasMessageSelection (sysLibTrapCustom + 32)

Trap ID for Has message selection

Definition at line 61 of file SmartTextEngineTraps.h.

#define STETrapHasTextSelection (sysLibTrapCustom + 23)

Trap ID for Has text selection

Definition at line 52 of file SmartTextEngineTraps.h.

#define STETrapInitializeEngine (sysLibTrapCustom + 1)

Trap ID for Initialize Engine function

Definition at line 30 of file SmartTextEngineTraps.h.

#define STETrapOpen sysLibTrapOpen

Open Trap

Definition at line 26 of file SmartTextEngineTraps.h.

#define STETrapQuickRender (sysLibTrapCustom + 36)

Trap ID for Quick Render

Definition at line 65 of file SmartTextEngineTraps.h.

#define STETrapReinitializeEngine (sysLibTrapCustom + 3)

Trap ID for Reinitialize Engine function

Definition at line 32 of file SmartTextEngineTraps.h.

#define STETrapRemoveLastRecordFromEngine (sysLibTrapCustom + 5)

Trap ID for Remove last record from engine

Definition at line 34 of file SmartTextEngineTraps.h.

#define STETrapRenderList (sysLibTrapCustom + 6)

Trap ID for render list

Definition at line 35 of file SmartTextEngineTraps.h.

#define STETrapRerenderList (sysLibTrapCustom + 7)

Trap ID for Rerender list

Definition at line 36 of file SmartTextEngineTraps.h.

#define STETrapResetEngine (sysLibTrapCustom + 2)

Trap ID for Reset Engine function

Definition at line 31 of file SmartTextEngineTraps.h.

#define STETrapSetCurrentTextSelection (sysLibTrapCustom + 25)

Trap ID for Set current text selection

Definition at line 54 of file SmartTextEngineTraps.h.

#define STETrapSetCustomHyperlinkCallback (sysLibTrapCustom + 30)

Trap ID for Set custom hyperlink callback

Definition at line 59 of file SmartTextEngineTraps.h.

#define STETrapSetFlags (sysLibTrapCustom + 19)

Trap ID for Set Flags

Definition at line 48 of file SmartTextEngineTraps.h.

#define STETrapSetScroll (sysLibTrapCustom + 15)

Trap ID for Set scroll

Definition at line 44 of file SmartTextEngineTraps.h.

#define STETrapSetScrollPct (sysLibTrapCustom + 17)

Trap ID for Set scroll pct

Definition at line 46 of file SmartTextEngineTraps.h.

#define STETrapSetScrollToRecordNum (sysLibTrapCustom + 18)

Trap ID for Set scroll to record num

Definition at line 47 of file SmartTextEngineTraps.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:06 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » toneslibrary

TonesLib.h File Reference

Detailed Description

Public 68K include file that controls the MIDI tones on a device.

Notes:

The calling application should always load this library with SysLibLoad() before use, even if it is already open by another application(ie, SysLibFind() returns a valid refnum). When the application is done with the library, it should be unloaded with SysLibRemove(). We do this because there is no good way to synchronize loading and unloading of libraries among multiple applications. It also greatly simplifies internal synchronization.

Definition in file TonesLib.h.

Go to the source code of this file.

Defines

  • #define kTonesLibVersionEscalation 10

Functions

  • Err TonesLibOpen (UInt16 refNum)
  • Err TonesLibClose (UInt16 refNum)
  • Err TonesLibWake (UInt16 refNum)
  • Err TonesLibSleep (UInt16 refNum)
  • Err TonesLibGetToneList (UInt16 refNum, ToneItemPtr *list, UInt16 *listLength)
  • Err TonesLibGetToneIDs (UInt16 refNum, ToneIdentifier **list, UInt16 *listLength)
  • Err TonesLibGetToneName (UInt16 refNum, ToneIdentifier toneId, CharPtr name, UInt16 maxLength)
  • Err TonesLibGetToneSize (UInt16 refNum, ToneIdentifier toneId, UInt32 *sizeP)
  • Err TonesLibPlayTone (UInt16 refNum, ToneIdentifier toneId, UInt16 playCount, ToneVolume volume, ToneVibrateType vibrate, Boolean blocking)
  • Err TonesLibAddMidiTone (UInt16 refNum, MemHandle midiTone, CharPtr toneName, Boolean protectedTone)
  • Err TonesLibToneCreate (UInt16 refNum, UInt32 *streamP, ToneType toneType, CharPtr toneName, Boolean protectedTone)
  • Err TonesLibToneWrite (UInt16 refNum, UInt32 stream, const void *dataP, Int32 size)
  • Err TonesLibToneClose (UInt16 refNum, UInt32 stream)
  • Err TonesLibManageTones (UInt16 refNum)
  • Err TonesLibDeleteTone (UInt16 refNum, ToneIdentifier toneId)
  • Err TonesLibInitTonesDB (UInt16 refNum)
  • Err TonesLibGetSoundPrefs (UInt16 refNum, SoundPrefType soundType, SoundPreference *soundPrefs)
  • Err TonesLibSetSoundPrefs (UInt16 refNum, SoundPrefType soundType, SoundPreference *soundPrefs)
  • Err TonesLibPickTone (UInt16 refNum, ToneType *toneType, MemHandle *toneH, Char *name)
  • Err TonesLibStopTone (UInt16 refNum)
  • Err TonesLibGetSoundOnVolume (UInt16 refNum, SoundPrefType soundType, ToneVolume *soundOnVolumeP)
  • Err TonesLibSetSoundOnVolume (UInt16 refNum, SoundPrefType soundType, ToneVolume soundOnVolume)
  • Err TonesLibDoDialog (UInt16 refNum, UInt32 flags)
  • Err TonesLibRecordTone (UInt16 refNum)
  • Err TonesLibEscalateRingTones (UInt16 refNum, Boolean set, Boolean *value)
  • Err TonesLibPlayRingTone (UInt16 refNum, ToneIdentifier toneId, UInt16 playCount, ToneVolume volume, ToneVibrateType vibrate, Boolean blocking)
  • Err TonesLibSaveUndeletableTones (UInt16 refNum)
  • Err TonesLibCopyBackUndeletableTones (UInt16 refNum)

Define Documentation

#define kTonesLibVersionEscalation 10

Minimum db version of TonesLibrary database that implements escalation Done this way since we have no GetLibVersion() API.

Definition at line 35 of file TonesLib.h.

Function Documentation

Err TonesLibAddMidiTone | ( | UInt16 | refNum,
 |  | MemHandle | midiTone,
 |  | CharPtr | toneName,
 |  | Boolean | protectedTone
 | ) |  |

Add a MIDI tone to the system tone database.

Parameters:
refNum,: IN: Library reference number from SysLibLoad.
midiTone,: IN: The data buffer handle where the midi tone data is located.
toneName,: IN: Name of the tone.
protectedTone,: IN: Save tone as protected record in the tone database.
Returns:
Library error code.

Err TonesLibClose ( UInt16 refNum )

Close the Tones library instance.

Parameters:
refNum,: IN: Library reference number from SysLibLoad.
Returns:
Library error code.

Err TonesLibCopyBackUndeletableTones ( UInt16 refNum )

Err TonesLibDeleteTone | ( | UInt16 | refNum,
 |  | ToneIdentifier | toneId
 | ) |  |

Delete a tone given its ID.

Parameters:
refNum,: IN: Library reference number from SysLibLoad.
toneId,: IN: ID of the tone to be deleted.
Returns:
Library error code.

Err TonesLibDoDialog | ( | UInt16 | refNum,
 |  | UInt32 | flags
 | ) |  |

Display the UI to create and/or manages tones.

Parameters:
refNum,: IN: Library reference number from SysLibLoad.
flags,: IN: Set to kTonesDialogFlagNonModal to hide the Done button from the dialog.
Returns:
Library error code.

Err TonesLibEscalateRingTones | ( | UInt16 | refNum,
 |  | Boolean | set,
 |  | Boolean * | value
 | ) |  |

Query or toggle whether ring tones are escalated in volume when played.

Parameters:
refNum,: IN: Library reference number from SysLibLoad.
set,: IN: true if setting, false if querying.
value,: IN: Value to set if setting, queried value if querying.
Returns:
Library error code.

Err TonesLibGetSoundOnVolume | ( | UInt16 | refNum,
 |  | SoundPrefType | soundType,
 |  | ToneVolume * | soundOnVolumeP
 | ) |  |

Get the sound-on volume of a sound type.

Parameters:
refNum,: IN: Library reference number from SysLibLoad.
soundType,: IN: Type of (application) sound.
soundOnVolumeP,: OUT: Volume of the sound.
Returns:
Library error code.

Err TonesLibGetSoundPrefs | ( | UInt16 | refNum,
 |  | SoundPrefType | soundType,
 |  | SoundPreference * | soundPrefs
 | ) |  |

Get the sound preference for a type of (application) sound.

Parameters:
refNum,: IN: Library reference number from SysLibLoad.
soundType,: IN: Type of (application: email, SMS, phone call, etc) sound.
soundPrefs,: OUT: Preference settings for a type of sound.
Returns:
Library error code.

Err TonesLibGetToneIDs | ( | UInt16 | refNum,
 |  | ToneIdentifier ** | list,
 |  | UInt16 * | listLength
 | ) |  |

Get the list of tone IDs.

Parameters:
refNum,: IN: Library reference number from SysLibLoad.
list,: IN: Pointer to the list of tone IDs to return.
listLength,: OUT: Count of how many tone IDs are in the list.
Returns:
Library error code.

Err TonesLibGetToneList | ( | UInt16 | refNum,
 |  | ToneItemPtr * | list,
 |  | UInt16 * | listLength
 | ) |  |

Get the list of tone names.

Parameters:
refNum,: IN: Library reference number from SysLibLoad.
list,: IN: Pointer to the list of tone names to return.
listLength,: OUT: Count of how many tone names are in the list.
Returns:
Library error code.

Err TonesLibGetToneName | ( | UInt16 | refNum,
 |  | ToneIdentifier | toneId,
 |  | CharPtr | name,
 |  | UInt16 | maxLength
 | ) |  |

Get the name of a certain tone given its ID.

Parameters:
refNum,: IN: Library reference number from SysLibLoad.
toneId,: IN: Tone ID of the tone name to get.
name,: I/O: Pointer to the returned tone name.
maxLength,: IN: Size of the name buffer in bytes.
Returns:
Library error code.

Err TonesLibGetToneSize | ( | UInt16 | refNum,
 |  | ToneIdentifier | toneId,
 |  | UInt32 * | sizeP
 | ) |  |

Get the tone data size given its ID.

Parameters:
refNum,: IN: Library reference number from SysLibLoad.
toneId,: IN: ID number of the tone.
sizeP,: OUT: Size of the specified tone.
Returns:
Library error code.

Err TonesLibInitTonesDB ( UInt16 refNum )

Create the default tone database if it does not exist, and verify that all the tones in a database are resident on the device.

Parameters:
refNum,: IN: Library reference number from SysLibLoad.
Returns:
Library error code.

Err TonesLibManageTones ( UInt16 refNum )

Display UI to manage tones. Users can delete, play, or send a tone from this UI.

Parameters:
refNum,: IN: Library reference number from SysLibLoad.
Returns:
Library error code.

Err TonesLibOpen ( UInt16 refNum )

Open and initialize the Tones library instance.

Parameters:
refNum,: IN: Library reference number from SysLibLoad.
Returns:
Library error code.

Err TonesLibPickTone | ( | UInt16 | refNum,
 |  | ToneType * | toneType,
 |  | MemHandle * | toneH,
 |  | Char * | name
 | ) |  |

Display the UI to select tones and return the tone type, tone name, and handle to the tone data.

Parameters:
refNum,: IN: Library reference number from SysLibLoad.
toneType,: OUT: Type of tone.
toneH,: OUT: Handle to the tone selected. Must be freed by the caller.
name,: OUT: Name of the tone.
Returns:
Library error code.

Err TonesLibPlayRingTone | ( | UInt16 | refNum,
 |  | ToneIdentifier | toneId,
 |  | UInt16 | playCount,
 |  | ToneVolume | volume,
 |  | ToneVibrateType | vibrate,
 |  | Boolean | blocking
 | ) |  |

Play a ring tone given its ID. The difference between this and PlayTone is that tones played this way are affected by TonesLibEscalateRingTones().

Parameters:
refNum,: IN: Library reference number from SysLibLoad.
toneId,: IN: ID of the tone to play.
playCount,: IN: Number of times you want the tone repeated.
volume,: IN: Volume level at which you want the tone played.
vibrate,: IN: Vibrate mode to use when playing the tone.
blocking,: IN: Controls whether the tone play is a blocking call or play in the background and return immediately.
Returns:
Library error code.

Err TonesLibPlayTone | ( | UInt16 | refNum,
 |  | ToneIdentifier | toneId,
 |  | UInt16 | playCount,
 |  | ToneVolume | volume,
 |  | ToneVibrateType | vibrate,
 |  | Boolean | blocking
 | ) |  |

Play a tone given its ID.

Parameters:
refNum,: IN: Library reference number from SysLibLoad.
toneId,: IN: ID of the tone to play.
playCount,: IN: Number of times you want the tone repeated.
volume,: IN: Volume level at which you want the tone played.
vibrate,: IN: Vibrate mode to use when playing the tone.
blocking,: IN: Controls whether the tone play is a blocking call or play in the background and return immediately.
Returns:
Library error code.

Err TonesLibRecordTone ( UInt16 refNum )

No definition.

Parameters:
refNum,: IN: Library reference number from SysLibLoad.
Returns:
Library error code.

Err TonesLibSaveUndeletableTones ( UInt16 refNum )

Err TonesLibSetSoundOnVolume | ( | UInt16 | refNum,
 |  | SoundPrefType | soundType,
 |  | ToneVolume | soundOnVolume
 | ) |  |

Set the sound-on volume of a sound type.

Parameters:
refNum,: IN: Library reference number from SysLibLoad.
soundType,: IN: Type of (application) sound.
soundOnVolume,: IN: Volume of the tone.
Returns:
Library error code.

Err TonesLibSetSoundPrefs | ( | UInt16 | refNum,
 |  | SoundPrefType | soundType,
 |  | SoundPreference * | soundPrefs
 | ) |  |

Set the sound preference for a type of (application) sound.

Parameters:
refNum,: IN: Library reference number from SysLibLoad.
soundType,: IN: Type of (application) sound.
soundPrefs,: IN: Preference settings for the type of sound.
Returns:
Library error code.

Err TonesLibSleep ( UInt16 refNum )

Standard function to receive Palm OS sleep notification.

Parameters:
refNum,: IN: Library reference number from SysLibLoad.
Returns:
Library error code.

Err TonesLibStopTone ( UInt16 refNum )

Stop the playback of the current tone.

Parameters:
refNum,: IN: Library reference number from SysLibLoad.
Returns:
Library error code.

Err TonesLibToneClose | ( | UInt16 | refNum,
 |  | UInt32 | stream
 | ) |  |

Close the reference to the tone stream.

Parameters:
refNum,: IN: Library reference number from SysLibLoad.
stream,: IN: Reference to the steam returned by TonesLibToneCreate().
Returns:
Library error code.

Err TonesLibToneCreate | ( | UInt16 | refNum,
 |  | UInt32 * | streamP,
 |  | ToneType | toneType,
 |  | CharPtr | toneName,
 |  | Boolean | protectedTone
 | ) |  |

Create new tone and return the pointer to the start of the sound stream.

Parameters:
refNum,: IN: Library reference number from SysLibLoad.
streamP,: OUT: Pointer to the sound stream of the new tone.
toneType,: IN: Type of the tone.
See also:
ToneType.
Parameters:
toneName,: IN: Name of the tone.
protectedTone,: IN: Save tone as protected record in the tone database.
Returns:
Library error code.

Err TonesLibToneWrite | ( | UInt16 | refNum,
 |  | UInt32 | stream,
 |  | const void * | dataP,
 |  | Int32 | size
 | ) |  |

Write sound data to the stream returned by TonesLibToneCreate().

Parameters:
refNum,: IN: Library reference number from SysLibLoad.
stream,: IN: Reference to the steam returned by TonesLibToneCreate().
dataP,: IN: Pointer to the Tone(Sound) data.
size,: IN: Size of the data to be written.
Returns:
Library error code.

Err TonesLibWake ( UInt16 refNum )

Standard function to receive Palm OS wake up notification.

Parameters:
refNum,: IN: Library reference number from SysLibLoad.
Returns:
Library error code.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:07 2008 for Palm API Guide


Header Files » Incs » common » libraries » toneslibrary

TonesLibTypes.h File Reference

Detailed Description

Public 68K header file for the Ring Tone library on Treo devices.

This file contains the common constants for the tones and also the structure that contains the ring-tone related sound preferences.

Definition in file TonesLibTypes.h.

Go to the source code of this file.

Data Structures

  • struct ToneIdentifier
    No definition. More...
  • struct ToneItemType
    Tone characteristics. More...
  • struct SoundPreferenceIM
    Structure for IM Sound Pref. More...
  • struct SoundPreferencePhone
    Structure for Phone Sound Pref. More...
  • struct SoundPreferenceEmail
    Structure for Email Sound Pref. More...
  • struct SoundPreferenceCalendar
    Structure for Calendar Sound Pref. More...
  • struct SoundPreferenceSMS
    Structure for SMS Sound Pref. More...
  • struct SoundPreferenceMMS
    Structure for MMS Sound Pref. More...
  • struct SoundPreferenceNetworkSounds
    Structure for network related sounds. More...
  • struct SoundPreference
    Structure containing all the Sound Preference data. More...
  • union SoundPreference::_tonePrefs

Defines

  • #define tonesLibName "Tones Library"
  • #define tonesLibCreator hsFileCTonesLib
  • #define tonesLibType sysFileTLibrary
  • #define kMaxTonesNameSize 32
  • #define tonesLibPlayForever 0xFFFF
  • #define toneInterruptMask 0x00C0
  • #define kTonesDialogFlagNonModal 0x00000001
Error Codes
  • #define tonesLibErrClass 0x9000
  • #define tonesLibErrCreateDBFailed tonesLibErrClass | 1
  • #define tonesLibErrNoMemory tonesLibErrClass | 2
  • #define tonesLibErrNoTone tonesLibErrClass | 3
  • #define tonesLibErrDBNotFound tonesLibErrClass | 4
  • #define tonesLibErrDBWriteFailed tonesLibErrClass | 5
  • #define tonesLibErrUserCancel tonesLibErrClass | 6
  • #define tonesLibErrBadParams tonesLibErrClass | 7
  • #define tonesLibErrUnknown tonesLibErrClass | 8
  • #define tonesLibErrNotAllowed tonesLibErrClass | 9
  • #define tonesLibErrAlreadyPlaying tonesLibErrClass | 10
Utility Macros
  • #define CompareToneIdentifiers(tone1, tone2) (tone1.id == tone2.id && tone1.toneType == tone2.toneType)
  • #define CopyToneIdentifier(destP, src)
  • #define CopyMIDIToneIdentifier(destP, src)
Function Traps
  • #define tonesLibTrapGetToneList sysLibTrapCustom
  • #define tonesLibTrapGetToneIDs sysLibTrapCustom+1
  • #define tonesLibTrapGetToneName sysLibTrapCustom+2
  • #define tonesLibTrapPlayTone sysLibTrapCustom+3
  • #define tonesLibTrapAddMidiTone sysLibTrapCustom+4
  • #define tonesLibTrapManageTones sysLibTrapCustom+5
  • #define tonesLibTrapDeleteTone sysLibTrapCustom+6
  • #define tonesLibTrapGetSoundPrefs sysLibTrapCustom+7
  • #define tonesLibTrapSetSoundPrefs sysLibTrapCustom+8
  • #define tonesLibTrapInitTonesDB sysLibTrapCustom+9
  • #define tonesLibTrapPickTone sysLibTrapCustom+10
  • #define tonesLibTrapStopTone sysLibTrapCustom+11
  • #define tonesLibTrapGetSoundOnVolume sysLibTrapCustom+12
  • #define tonesLibTrapSetSoundOnVolume sysLibTrapCustom+13
  • #define tonesLibTrapDoDialog sysLibTrapCustom+14
  • #define tonesLibTrapGetToneSize sysLibTrapCustom+15
  • #define tonesLibTrapToneCreate sysLibTrapCustom+16
  • #define tonesLibTrapToneWrite sysLibTrapCustom+17
  • #define tonesLibTrapToneClose sysLibTrapCustom+18
  • #define tonesLibTrapToneRecord sysLibTrapCustom+19
  • #define tonesLibTrapEscalateRingTones sysLibTrapCustom+20
  • #define tonesLibTrapPlayRingTone sysLibTrapCustom+21
  • #define tonesLibTrapSaveUndeletableTones sysLibTrapCustom+22
  • #define tonesLibTrapCopyBackUndeletableTones sysLibTrapCustom+23

Typedefs

  • typedef UInt16 ToneType
  • typedef UInt16 SoundPrefType
  • typedef UInt16 ToneVolume
  • typedef UInt8 TonePlayNumberTimes
  • typedef UInt8 ToneRepeatInterval
  • typedef UInt8 ToneTimeUnit
  • typedef UInt8 ToneVibrateType
  • typedef struct ToneItemType * ToneItemPtr

Enumerations

  • enum _ToneType {
    toneTypeMIDI,
    toneTypeWAV,
    toneTypeAMR,
    toneTypeSystemSound,
    toneTypeQCELP,
    toneTypeMP3,
    toneTypeAAC
    }
  • enum _SoundPrefType {
    soundPrefTypePhone,
    soundPrefTypeEmail,
    soundPrefTypeCalendar,
    soundPrefTypeIM,
    soundPrefTypeMMS,
    soundPrefTypeSMS,
    soundPrefTypeNetworkSounds,
    soundPrefTypeLast
    }
  • enum _ToneVolume {
    toneVolumeOff,
    toneVolume1,
    toneVolume2,
    toneVolume3,
    toneVolume4,
    toneVolume5,
    toneVolume6,
    toneVolume7
    }
  • enum _TonePlayNumberTimes {
    tonePlayOnce,
    tonePlayTwice,
    tonePlay3Times,
    tonePlay5Times,
    tonePlay10Times,
    tonePlay100Times
    }
  • enum _ToneRepeatInterval {
    toneRepeatEveryMinute,
    toneRepeatEvery5Minutes,
    toneRepeatEvery10Minutes,
    toneRepeatEvery30Minutes
    }
  • enum _ToneTimeUnit {
    toneTimeUnitMinutes,
    toneTimeUnitHours,
    toneTimeUnitDays
    }
  • enum _ToneVibrateType {
    toneVibrateNone,
    toneVibrateRing,
    toneVibrateAlert,
    toneVibrateMail,
    toneVibrateCalender,
    toneVibrateSMS,
    toneVibrateVoicemail,
    toneVibrateThenRing,
    toneInterruptPhone = 64,
    toneInterruptMode2 = 128,
    toneInterruptMode3 = 192
    }

Define Documentation

#define CompareToneIdentifiers | ( | tone1,
 |  | tone2 | ) | (tone1.id == tone2.id && tone1.toneType == tone2.toneType)

No definition.

Definition at line 73 of file TonesLibTypes.h.

#define CopyMIDIToneIdentifier | ( | destP,
 |  | src | )

Value:

destP->id = src; \
             destP->toneType = toneTypeMIDI
No definition.

Definition at line 81 of file TonesLibTypes.h.

#define CopyToneIdentifier | ( | destP,
 |  | src | )

Value:

destP->id = src.id; \
             destP->toneType = src.toneType
No definition.

Definition at line 76 of file TonesLibTypes.h.

#define kMaxTonesNameSize 32

Maximum size of a tone name.

Definition at line 47 of file TonesLibTypes.h.

#define kTonesDialogFlagNonModal 0x00000001

Hides the Done button from the play tone dialog.

Definition at line 317 of file TonesLibTypes.h.

#define toneInterruptMask 0x00C0

Definition at line 204 of file TonesLibTypes.h.

#define tonesLibCreator hsFileCTonesLib

Creator ID of the Tone Types library.

Definition at line 44 of file TonesLibTypes.h.

#define tonesLibErrAlreadyPlaying tonesLibErrClass | 10

No definition.

Definition at line 65 of file TonesLibTypes.h.

#define tonesLibErrBadParams tonesLibErrClass | 7

No definition.

Definition at line 62 of file TonesLibTypes.h.

#define tonesLibErrClass 0x9000

No definition.

Definition at line 55 of file TonesLibTypes.h.

#define tonesLibErrCreateDBFailed tonesLibErrClass | 1

No definition.

Definition at line 56 of file TonesLibTypes.h.

#define tonesLibErrDBNotFound tonesLibErrClass | 4

No definition.

Definition at line 59 of file TonesLibTypes.h.

#define tonesLibErrDBWriteFailed tonesLibErrClass | 5

No definition.

Definition at line 60 of file TonesLibTypes.h.

#define tonesLibErrNoMemory tonesLibErrClass | 2

No definition.

Definition at line 57 of file TonesLibTypes.h.

#define tonesLibErrNotAllowed tonesLibErrClass | 9

No definition.

Definition at line 64 of file TonesLibTypes.h.

#define tonesLibErrNoTone tonesLibErrClass | 3

No definition.

Definition at line 58 of file TonesLibTypes.h.

#define tonesLibErrUnknown tonesLibErrClass | 8

No definition.

Definition at line 63 of file TonesLibTypes.h.

#define tonesLibErrUserCancel tonesLibErrClass | 6

No definition.

Definition at line 61 of file TonesLibTypes.h.

#define tonesLibName "Tones Library"

Name of the Tone Types library.

Definition at line 43 of file TonesLibTypes.h.

#define tonesLibPlayForever 0xFFFF

Used to play a tone over and over indefinitely.

Definition at line 48 of file TonesLibTypes.h.

#define tonesLibTrapAddMidiTone sysLibTrapCustom+4

Trap ID for the function to add a MIDI tone. Note: This used to be tonesLibTrapAddTone. Leaving this trap number maintains binary compatability with existing applications. Recompiling older source code will fail since the new version of TonesLibAddTone takes toneType as an additional parameter.

Definition at line 328 of file TonesLibTypes.h.

#define tonesLibTrapCopyBackUndeletableTones sysLibTrapCustom+23

Trap ID for function to copy undeletable tones back.

Definition at line 352 of file TonesLibTypes.h.

#define tonesLibTrapDeleteTone sysLibTrapCustom+6

Trap ID for function to delete a tone.

Definition at line 335 of file TonesLibTypes.h.

#define tonesLibTrapDoDialog sysLibTrapCustom+14

Trap ID for function to display the tones list.

Definition at line 343 of file TonesLibTypes.h.

#define tonesLibTrapEscalateRingTones sysLibTrapCustom+20

Trap ID for function to set/query ringtone escalation.

Definition at line 349 of file TonesLibTypes.h.

#define tonesLibTrapGetSoundOnVolume sysLibTrapCustom+12

Trap ID for function to get the on volume of a sound type.

Definition at line 341 of file TonesLibTypes.h.

#define tonesLibTrapGetSoundPrefs sysLibTrapCustom+7

Trap ID for function to get a sound preference.

Definition at line 336 of file TonesLibTypes.h.

#define tonesLibTrapGetToneIDs sysLibTrapCustom+1

Trap ID for the function that gets the list of tone ids.

Definition at line 325 of file TonesLibTypes.h.

#define tonesLibTrapGetToneList sysLibTrapCustom

Trap ID for the function that gets the tone list.

Definition at line 324 of file TonesLibTypes.h.

#define tonesLibTrapGetToneName sysLibTrapCustom+2

Trap ID for the function that gets the name of a tone.

Definition at line 326 of file TonesLibTypes.h.

#define tonesLibTrapGetToneSize sysLibTrapCustom+15

Trap ID for function to get the size of a tone.

Definition at line 344 of file TonesLibTypes.h.

#define tonesLibTrapInitTonesDB sysLibTrapCustom+9

Trap ID for function to initialize the Tones database.

Definition at line 338 of file TonesLibTypes.h.

#define tonesLibTrapManageTones sysLibTrapCustom+5

Trap ID for function to manage tones.

Definition at line 334 of file TonesLibTypes.h.

#define tonesLibTrapPickTone sysLibTrapCustom+10

Trap ID for function to pick a tone to attach.

Definition at line 339 of file TonesLibTypes.h.

#define tonesLibTrapPlayRingTone sysLibTrapCustom+21

Trap ID for function to play a ringtone.

Definition at line 350 of file TonesLibTypes.h.

#define tonesLibTrapPlayTone sysLibTrapCustom+3

Trap ID for the function that plays a tone.

Definition at line 327 of file TonesLibTypes.h.

#define tonesLibTrapSaveUndeletableTones sysLibTrapCustom+22

Trap ID for function to create backup db.

Definition at line 351 of file TonesLibTypes.h.

#define tonesLibTrapSetSoundOnVolume sysLibTrapCustom+13

Trap ID for function to set the on volume of a sound type.

Definition at line 342 of file TonesLibTypes.h.

#define tonesLibTrapSetSoundPrefs sysLibTrapCustom+8

Trap ID for function to set a sound preference.

Definition at line 337 of file TonesLibTypes.h.

#define tonesLibTrapStopTone sysLibTrapCustom+11

Trap ID for function to stop the playback of the current tone.

Definition at line 340 of file TonesLibTypes.h.

#define tonesLibTrapToneClose sysLibTrapCustom+18

Trap ID for function to finish adding a new tone.

Definition at line 347 of file TonesLibTypes.h.

#define tonesLibTrapToneCreate sysLibTrapCustom+16

Trap ID for function to begin adding a new tone.

Definition at line 345 of file TonesLibTypes.h.

#define tonesLibTrapToneRecord sysLibTrapCustom+19

Trap ID for function to record a new tone.

Definition at line 348 of file TonesLibTypes.h.

#define tonesLibTrapToneWrite sysLibTrapCustom+17

Trap ID for function to write data to a new tone.

Definition at line 346 of file TonesLibTypes.h.

#define tonesLibType sysFileTLibrary

Type of the Tone Types library.

Definition at line 45 of file TonesLibTypes.h.

Typedef Documentation

typedef UInt16 SoundPrefType

Holds sound preference type value

Definition at line 120 of file TonesLibTypes.h.

typedef struct ToneItemType * ToneItemPtr

typedef UInt8 TonePlayNumberTimes

Holds number of times to play a tone value

Definition at line 154 of file TonesLibTypes.h.

typedef UInt8 ToneRepeatInterval

Holds the tone repeat interval value

Definition at line 168 of file TonesLibTypes.h.

typedef UInt8 ToneTimeUnit

Holds the tone time unit value

Definition at line 182 of file TonesLibTypes.h.

typedef UInt16 ToneType

Holds tone type value

Definition at line 102 of file TonesLibTypes.h.

typedef UInt8 ToneVibrateType

Holds the tone vibrate type value

Definition at line 207 of file TonesLibTypes.h.

typedef UInt16 ToneVolume

Holds tone volume value

Definition at line 138 of file TonesLibTypes.h.

Enumeration Type Documentation

enum _SoundPrefType

Sound preferences type

Enumerator:
soundPrefTypePhone | Tone pref for phone.
soundPrefTypeEmail | Tone pref for email.
soundPrefTypeCalendar | Tone pref for Calendar.
soundPrefTypeIM | Tone pref for IM.
soundPrefTypeMMS | Tone pref for MMS.
soundPrefTypeSMS | Tone pref for SMS.
soundPrefTypeNetworkSounds | Tone pref for SMS.
soundPrefTypeLast | Last item in enum. Please keep it as last item.

Definition at line 107 of file TonesLibTypes.h.

00121 {

enum _TonePlayNumberTimes

Number of times to play tone

Enumerator:
tonePlayOnce | Play once.
tonePlayTwice | Play twice.
tonePlay3Times | Play three times.
tonePlay5Times | Play five times.
tonePlay10Times | Play ten times.
tonePlay100Times | Play one hundred times.

Definition at line 143 of file TonesLibTypes.h.

00155 {

enum _ToneRepeatInterval

Tone repeat interval

Enumerator:
toneRepeatEveryMinute | Repeat every minute.
toneRepeatEvery5Minutes | Repeat every 5 minutes.
toneRepeatEvery10Minutes | Repeat every 10 minutes.
toneRepeatEvery30Minutes | Repeat every 30 minutes.

Definition at line 159 of file TonesLibTypes.h.

00169 {

enum _ToneTimeUnit

Tone time unit

Enumerator:
toneTimeUnitMinutes | Minutes
toneTimeUnitHours | Hours
toneTimeUnitDays | Days

Definition at line 173 of file TonesLibTypes.h.

00183 {

enum _ToneType

Tone types

Enumerator:
toneTypeMIDI | Record in MIDI Ring Tones DB.
toneTypeWAV | WAV in a SndFileStream.
toneTypeAMR | AMR in a SndFIleStream.
toneTypeSystemSound | Unused.
toneTypeQCELP | QCELP in a SndFileStream.
toneTypeMP3 | MP3 in a SndFileStream
toneTypeAAC | AAC in a SndFileStream

Definition at line 91 of file TonesLibTypes.h.

00103 {

enum _ToneVibrateType

Tone vibrate type

Enumerator:
toneVibrateNone | None
toneVibrateRing | Phone ring event
toneVibrateAlert | Alert event
toneVibrateMail | New mail
toneVibrateCalender | Calendar event
toneVibrateSMS | New SMS
toneVibrateVoicemail | New Voicemail
toneVibrateThenRing | Phone vibrate-then-ring event
toneInterruptPhone | Interrupt mode for phone '01' in upper two bits
toneInterruptMode2 | Reserved interrupt mode '10' in upper two bits
toneInterruptMode3 | Reserved interrupt mode '11' in upper two bits

Definition at line 187 of file TonesLibTypes.h.

00207                {

enum _ToneVolume

Tone volume

Enumerator:
toneVolumeOff | Volume off
toneVolume1 | Volume level 1
toneVolume2 | Volume level 2
toneVolume3 | Volume level 3
toneVolume4 | Volume level 4
toneVolume5 | Volume level 5
toneVolume6 | Volume level 6
toneVolume7 | Volume level 7

Definition at line 125 of file TonesLibTypes.h.

00139 {

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:08 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » transparencylibrary

TransparencyLib.h File Reference

Detailed Description

Transparency Library that couples a Ccp channel and a serial port.

This library can be used to couple data between a Ccp channel and a serial port. It is meant to be used for diagnostics and tethered mode. Since it is a library, it can work without being in a certain application.

Definition in file TransparencyLib.h.

Go to the source code of this file.

Functions

  • Err TransLibOpenConnection (UInt16 refNum, CcpChannelType portAChannel, UInt32 portB)
  • Err TransLibCloseConnection (UInt16 refNum)

Function Documentation

Err TransLibCloseConnection ( UInt16 refNum )

Close the Transparency Library previously open and set the radio module in the correct state.

Parameters:
refNum,: IN: Library Reference Number.
Return values:
Err Error code.

Err TransLibOpenConnection | ( | UInt16 | refNum,
 |  | CcpChannelType | portAChannel,
 |  | UInt32 | portB
 | ) |  |

Open the Transparency Library and connect the radio modem directly with a known port.

Parameters:
refNum,: IN: Library Reference Number.
portAChannel,: IN: CcpChannelType of radio port.
portB,: IN: Port ID of the second port. This is the serial or USB port.
Return values:
Err Error code.
 err = SysLibFind (transLibName, &refNum);
 if (!err)
     err=TransLibOpenConnection(refNum,kCcpChannelTypeModem, 0x8000);

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:08 2008 for Palm API Guide


Header Files » Incs » common » libraries » transparencylibrary

TransparencyLibTypes.h File Reference

Detailed Description

Public common header file for the Transparency Library on Treo devices.

This file contains the common types of the Transparency Library.

Definition in file TransparencyLibTypes.h.

Go to the source code of this file.

Defines

  • #define transLibName "Transparency Library"
  • #define transLibCreator hsFileCTransparencyLib
  • #define transLibType sysFileTLibrary
Function Traps
  • #define transLibTrapOpenConnection sysLibTrapCustom
  • #define transLibTrapCloseConnection sysLibTrapCustom+1
Error Codes
  • #define transLibErrorClass 0x5000
  • #define transLibErrUnknown (transLibErrorClass | 1)
  • #define transLibErrNotOpen (transLibErrorClass | 2)
  • #define transLibErrAlreadyOpen (transLibErrorClass | 3)
  • #define transLibErrDockNotAttached (transLibErrorClass | 4)

Define Documentation

#define transLibCreator hsFileCTransparencyLib

Creator ID of Transparency Library - 'HsTL'

Definition at line 40 of file TransparencyLibTypes.h.

#define transLibErrAlreadyOpen (transLibErrorClass | 3)

Transparency library already open

Definition at line 79 of file TransparencyLibTypes.h.

#define transLibErrDockNotAttached (transLibErrorClass | 4)

Transparency library error when there is cradle not attached to the bottom port

Definition at line 84 of file TransparencyLibTypes.h.

#define transLibErrNotOpen (transLibErrorClass | 2)

No connection is open.

Definition at line 74 of file TransparencyLibTypes.h.

#define transLibErrorClass 0x5000

Error class for the transparency library

Definition at line 63 of file TransparencyLibTypes.h.

#define transLibErrUnknown (transLibErrorClass | 1)

Unkown command requested. For example, an unknown channel type was passed as a port.

Definition at line 69 of file TransparencyLibTypes.h.

#define transLibName "Transparency Library"

Transparency library names

Definition at line 35 of file TransparencyLibTypes.h.

#define transLibTrapCloseConnection sysLibTrapCustom+1

Definition at line 52 of file TransparencyLibTypes.h.

#define transLibTrapOpenConnection sysLibTrapCustom

Definition at line 51 of file TransparencyLibTypes.h.

#define transLibType sysFileTLibrary

Type ID of transparency library

Definition at line 45 of file TransparencyLibTypes.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:08 2008 for Palm API Guide


Header Files » Incs » common » libraries » vmfont

VMFontLibCommon.h File Reference

Detailed Description

Public common header file for the Versamail Font Library.

Version:
1.0
This file contains the constants and structures for the palmOne VersaMail Font Picker / Font Manager Service.

Definition in file VMFontLibCommon.h.

Include dependency graph for VMFontLibCommon.h:

Go to the source code of this file.

Data Structures

  • struct VMFontUIRules
    Font UI rules structure used for the font picker setting. More...
  • struct VMFontType
    Font characteristics structure used to describe a font. More...

Defines

  • #define fontPickerLibName "PalmSGFontLib.Lib"
  • #define fontPickerType 'appl'
  • #define fontPickerCreatorID 'MA10'
  • #define VMFontErrParam (appErrorClass | 1)
  • #define VMFontErrNotOpen (appErrorClass | 2)
  • #define VMFontErrStillOpen (appErrorClass | 3)
Function Traps
  • #define flTrapAPIVersion (sysLibTrapCustom + 0)
  • #define flTrapAPIGetFont (sysLibTrapCustom + 1)
  • #define flTrapAPIGetFontByID (sysLibTrapCustom + 2)
  • #define flTrapAPIFontExists (sysLibTrapCustom + 3)
  • #define flTrapAPIFontToString (sysLibTrapCustom + 4)
  • #define flTrapAPIFontCountStyleAndSize (sysLibTrapCustom + 5)
  • #define flTrapAPISetFontUIRules (sysLibTrapCustom + 6)
  • #define flTrapAPIInitFontUI (sysLibTrapCustom + 7)
  • #define flTrapAPIDoFontDialog (sysLibTrapCustom + 8)
  • #define flTrapAPIClearCache (sysLibTrapCustom + 9)

Typedefs

  • typedef UInt8 VMFontFace
  • typedef UInt8 VMFontSize
  • typedef UInt8 VMFontStyle
  • typedef UInt8 VMFontSizeRule
  • typedef UInt8 VMFontStyleRule
  • typedef VMFontUIRules * VMFontUIRulesPtr
  • typedef VMFontType * VMFontPtr

Enumerations

  • enum _VMFontFace {
    gillSans = 0,
    sabon,
    palm
    }
  • enum _VMFontSize {
    size6 = 0,
    size9 = 1,
    size12 = 2
    }
  • enum _VMFontStyle {
    normal = 0,
    bold = 1,
    italic = 2
    }
  • enum _VMFontSizeRule {
    allSize,
    smallFonts,
    largeFonts
    }
  • enum _VMFontStyleRule {
    allStyle,
    plainOnly
    }

Define Documentation

#define flTrapAPIClearCache (sysLibTrapCustom + 9)

Definition at line 55 of file VMFontLibCommon.h.

#define flTrapAPIDoFontDialog (sysLibTrapCustom + 8)

Definition at line 54 of file VMFontLibCommon.h.

#define flTrapAPIFontCountStyleAndSize (sysLibTrapCustom + 5)

Definition at line 51 of file VMFontLibCommon.h.

#define flTrapAPIFontExists (sysLibTrapCustom + 3)

Definition at line 49 of file VMFontLibCommon.h.

#define flTrapAPIFontToString (sysLibTrapCustom + 4)

Definition at line 50 of file VMFontLibCommon.h.

#define flTrapAPIGetFont (sysLibTrapCustom + 1)

Definition at line 47 of file VMFontLibCommon.h.

#define flTrapAPIGetFontByID (sysLibTrapCustom + 2)

Definition at line 48 of file VMFontLibCommon.h.

#define flTrapAPIInitFontUI (sysLibTrapCustom + 7)

Definition at line 53 of file VMFontLibCommon.h.

#define flTrapAPISetFontUIRules (sysLibTrapCustom + 6)

Definition at line 52 of file VMFontLibCommon.h.

#define flTrapAPIVersion (sysLibTrapCustom + 0)

Definition at line 46 of file VMFontLibCommon.h.

#define fontPickerCreatorID 'MA10'

Font library Creator ID.

Definition at line 64 of file VMFontLibCommon.h.

#define fontPickerLibName "PalmSGFontLib.Lib"

Font library name.

Definition at line 62 of file VMFontLibCommon.h.

#define fontPickerType 'appl'

Font library Type.

Definition at line 63 of file VMFontLibCommon.h.

#define VMFontErrNotOpen (appErrorClass | 2)

Error meaning that the library is not open

Definition at line 75 of file VMFontLibCommon.h.

#define VMFontErrParam (appErrorClass | 1)

A parameter passed was Invalid

Definition at line 72 of file VMFontLibCommon.h.

#define VMFontErrStillOpen (appErrorClass | 3)

Error returned from VMFontClose() if the library is still open

Definition at line 78 of file VMFontLibCommon.h.

Typedef Documentation

typedef UInt8 VMFontFace

Used with _VMFontFace

Definition at line 92 of file VMFontLibCommon.h.

typedef VMFontType* VMFontPtr

Definition at line 163 of file VMFontLibCommon.h.

typedef UInt8 VMFontSize

Used with _VMFontSize

Definition at line 104 of file VMFontLibCommon.h.

typedef UInt8 VMFontSizeRule

Used with _VMFontSizeRule

Definition at line 128 of file VMFontLibCommon.h.

typedef UInt8 VMFontStyle

Used with _VMFontStyle

Definition at line 116 of file VMFontLibCommon.h.

typedef UInt8 VMFontStyleRule

Used with _VMFontStyleRule

Definition at line 139 of file VMFontLibCommon.h.

typedef VMFontUIRules* VMFontUIRulesPtr

Definition at line 152 of file VMFontLibCommon.h.

Enumeration Type Documentation

enum _VMFontFace

Font Face

Enumerator:
gillSans | Gill Sans MT Font
sabon | Sabon MT Font
palm | Palm

Definition at line 84 of file VMFontLibCommon.h.

00084                  {
00085     gillSans  = 0,          /**< Gill Sans MT Font  */
00086     sabon,                  /**< Sabon MT Font  */
00087     //segoe,                /**< Segoe MT Font  */
00088     //thorndale,            /**< ThornDale MT Font  */
00089     palm                    /**< Palm  */
00090 };

enum _VMFontSize

Font Size

Enumerator:
size6 | Size = 6
size9 | Size = 9
size12 | Size = 12

Definition at line 98 of file VMFontLibCommon.h.

00098                  {
00099     size6  = 0,         /**< Size = 6  */
00100     size9  = 1,         /**< Size = 9  */
00101     size12 = 2          /**< Size = 12  */
00102 };

enum _VMFontSizeRule

Font Size Rule

Enumerator:
allSize | Both small and large fonts
smallFonts | Only Small fonts
largeFonts | Only large fonts

Definition at line 122 of file VMFontLibCommon.h.

00122                      {
00123     allSize,            /**< Both small and large fonts  */
00124     smallFonts,         /**< Only Small fonts  */
00125     largeFonts          /**< Only large fonts  */
00126 };

enum _VMFontStyle

Font Style

Enumerator:
normal | Normal Fonts
bold | Bold Fonts
italic | Italic Fonts

Definition at line 110 of file VMFontLibCommon.h.

00110                   {
00111     normal = 0,         /**< Normal Fonts */
00112     bold   = 1,         /**< Bold Fonts */
00113     italic = 2          /**< Italic Fonts */
00114 };

enum _VMFontStyleRule

Font Style Rule

Enumerator:
allStyle | All font Styles supported
plainOnly | Only Normal Fonts

Definition at line 134 of file VMFontLibCommon.h.

00134                       {
00135     allStyle,           /**< All font Styles supported */
00136     plainOnly           /**< Only Normal Fonts */
00137 };

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:08 2008 for Palm API Guide


Palm API Guide Directories

This directory hierarchy is sorted roughly, but not completely, alphabetically:
  • Header Files
    • Incs
      • 68k
        • libraries
          • address
            • 2.0
              • pub
          • audio
          • camera
          • cameramgr
          • carriercustomlib
          • codecpluginmgr
          • defaulthelperlibrary
          • favoritesdblibrary
          • filebrowser
          • hirestimerlib
          • hssoundlib
          • htmllib
          • http
          • imaging
          • lcdoverlaylib
          • locs
          • netmaster
          • netpref
          • network
          • pmconnectorlib
          • pmkeylib
          • pmsysgadgetlib
          • pmuiutillib
          • smarttextengine
          • sndfilestream
          • telephony
          • toneslibrary
          • transparencylibrary
          • vmfont
        • system
      • common
        • libraries
          • camera
          • cameramgr
          • codecpluginmgr
          • datebook
          • defaulthelperlibrary
          • favoritesdblibrary
          • filebrowser
          • hirestimerlib
          • hssoundlib
          • http
          • imaging
          • lcdoverlaylib
          • locs
          • mms
          • netmaster
          • netpref
          • pmconnectorlib
          • pmkeylib
          • pmsysgadgetlib
          • pmuiutillib
          • smarttextengine
          • telephony
          • toneslibrary
          • transparencylibrary
          • vmfont
        • system
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:37 2008 for Palm API Guide


Header Files

Header Files Directory Reference

Directories

  • directory Incs

Files

  • file palmOne_68K.h [code]
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:34 2008 for Palm API Guide


Header Files » Incs

Incs Directory Reference

Directories

  • directory 68k
  • directory common

Files

  • file Incs/palmOne_68K.h [code]
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:35 2008 for Palm API Guide


Header Files » Incs » 68k

68k Directory Reference

Directories

  • directory libraries
  • directory system

Files

  • file Hs.h [code]
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:33 2008 for Palm API Guide


Header Files » Incs » 68k » libraries

libraries Directory Reference

Directories

  • directory address
  • directory audio
  • directory camera
  • directory cameramgr
  • directory carriercustomlib
  • directory codecpluginmgr
  • directory defaulthelperlibrary
  • directory favoritesdblibrary
  • directory filebrowser
  • directory hirestimerlib
  • directory hssoundlib
  • directory htmllib
  • directory http
  • directory imaging
  • directory lcdoverlaylib
  • directory locs
  • directory netmaster
  • directory netpref
  • directory network
  • directory pmconnectorlib
  • directory pmkeylib
  • directory pmsysgadgetlib
  • directory pmuiutillib
  • directory smarttextengine
  • directory sndfilestream
  • directory telephony
  • directory toneslibrary
  • directory transparencylibrary
  • directory vmfont
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:35 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » address

address Directory Reference

Directories

  • directory 2.0
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:33 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » address » 2.0

2.0 Directory Reference

Directories

  • directory pub
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:33 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » address » 2.0 » pub

pub Directory Reference

Files

  • file Contacts.h [code]
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:37 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » audio

audio Directory Reference

Files

  • file PalmAudioPlayback.h [code]
    Public 68K include file that supports the stopping of audio playback on Treo 600 and Treo 650 smartphones.

  • file PalmSoundCustomCtrl.h [code]
    Public 68K include file for the Sound Manager custom controls for the IMA_ADPCM codec for Treo 600 and Treo 650 smartphones.

  • file PalmSoundMgrExt.h [code]
    Public 68K include file for the Extended Sound Manager.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:33 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » camera

camera Directory Reference

Files

  • file CameraLib.h [code]
    Public 68K include file for camera support for Treo 600 devices.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:33 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » cameramgr

cameramgr Directory Reference

Files

  • file palmOneCamera.h [code]
    Public 68K include file for camera support for Treo 650 devices. This version of the library adds functionality for Zire72, and Treo 650.

  • file palmOneCameraSlider.h [code]
    Public 68K file for camera slider notification for Zire 71 devices.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:33 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » carriercustomlib

carriercustomlib Directory Reference

Files

  • file CarrierCustomLib.h [code]
    This is the main header file for the Carrier Customization Library.

  • file CarrierCustomLibErr.h [code]
    This file contains the error codes for the Carrier Customization Library.

  • file CarrierCustomLibTraps.h [code]
    This file contains the trap for the Carrier Customization Library.

  • file CarrierCustomLibTypes.h [code]
    This file contains public data types exported by the Carrier Customization Library.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:34 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » codecpluginmgr

codecpluginmgr Directory Reference

Files

  • file palmOneCodecPluginMgr.h [code]
    The Codec Plugin Manager is used to unify all different type of codecs that are available for PalmOne devices and provide a generic API for developers to access these codecs.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:34 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » defaulthelperlibrary

defaulthelperlibrary Directory Reference

Files

  • file DefaultHelperLib.h [code]
    Default Helper library owns control over the Default Helpers database.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:34 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » favoritesdblibrary

favoritesdblibrary Directory Reference

Files

  • file FavoritesDBLib.h [code]
    Contains the API to control the Favorites DB.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:34 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » filebrowser

filebrowser Directory Reference

Files

  • file FileBrowserLib68K.h [code]
    This file contains the FileBrowser Library APIs.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:34 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » hirestimerlib

hirestimerlib Directory Reference

Files

  • file palmOneHiResTimer.h [code]
    Public 68k include file for Hi-Resolution timer for Palm OS.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:34 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » hssoundlib

hssoundlib Directory Reference

Files

  • file HsSoundLib.h [code]
    Public 68K include file for main sound support for Treo 600 and Treo 650 smartphones.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:35 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » htmllib

htmllib Directory Reference

Files

  • file HtmlLib68K.h [code]
    Public 68K include file for HTML shared library.

  • file HtmlLibTrap.h [code]
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:35 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » http

http Directory Reference

Files

  • file HS_HTTPLib68K.h [code]
    Public 68k include file for the HTTP Library.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:35 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » imaging

imaging Directory Reference

Files

  • file ImageLib.h [code]
    Public 68k include file for the Imaging Library.

  • file palmOnePhoto.h [code]
    Palm Photos API: This API is used to access Palm Photos database and manipulate images.

  • file PalmPhoto.h [code]
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:35 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » lcdoverlaylib

lcdoverlaylib Directory Reference

Files

  • file palmOneLcdOverlay.h [code]
    Public 68k include file for LCDOverlay API that can be used to display YCbCr images directly on the screen.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:35 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » locs

locs Directory Reference

Files

  • file LocsLib.h [code]
    Public 68K include file for location/timezone/DST support on Palm devices.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:36 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » netmaster

netmaster Directory Reference

Files

  • file NetMasterLibrary.h [code]
    This is the main header file for the NetMaster Library.

  • file NetMasterLibTypes.h [code]
    This file contains public data types exported by the NetMaster Library.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:36 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » netpref

netpref Directory Reference

Files

  • file NetPrefLibFieldInfoTable.h [code]
    This header file contains record field information for NetPref settings.

  • file NetPrefLibrary.h [code]
    This is the main header file for the NetPref Library.

  • file NetPrefLibTypes.h [code]
    This file contains public data types exported by the NetPref Library.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:36 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » network

network Directory Reference

Files

  • file PalmNetServices.h [code]
    NetServices provides a set of API to access 802.11.

  • file PalmVPPI.h [code]
    This is the API for VPN panel plug-ins (VPPIs).

  • file PalmWiFiCommon.h [code]
    Constants and structures common to the wifi network panel and driver.

  • file PalmWPPI.h [code]
    This is the API for Wi-Fi panel plug-ins (WPPIs).

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:36 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » pmconnectorlib

pmconnectorlib Directory Reference

Files

  • file PmConnectorLib.h [code]
    palmOne library that exports multi-connector related APIs.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:36 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » pmkeylib

pmkeylib Directory Reference

Files

  • file PmKeyLib.h [code]
    System Library that exports key-related APIs.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:36 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » pmsysgadgetlib

pmsysgadgetlib Directory Reference

Files

  • file PmSysGadgetLib.h [code]
    System Library that exports status-related APIs.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:36 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » pmuiutillib

pmuiutillib Directory Reference

Files

  • file PmUIUtilLib.h [code]
    This is the public header for PmUIUtil library.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:36 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » smarttextengine

smarttextengine Directory Reference

Files

  • file SmartTextEngine.h [code]
    Public 68K include file for Smart Text Engine shared library.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:37 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » sndfilestream

sndfilestream Directory Reference

Files

  • file palmOneSndFileStream.h [code]
    Public 68K include file for sound files stream support for Treo 600 and Treo 650 smartphones.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:37 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » telephony

telephony Directory Reference

Files

  • file HsPhone.h [code]
    Header file for the phone library (CDMA or GSM).

  • file HsPhoneAudio.h [code]
    Header File for Phone Library API ---- AUDIO CATEGORY.

  • file HsPhoneCDMA.h [code]
    Header File for Phone Library API ---- CDMA CATEGORY.

  • file HsPhoneGSM.h [code]
    Header File for Phone Library API ---- GSM CATEGORY.

  • file HsPhoneIOTA.h [code]
    Header File for Phone Library API ---- IOTA CATEGORY.

  • file HsPhoneLibrary.h [code]
    Header File for Phone Library API ---- LIBRARY CATEGORY.

  • file HsPhoneMisc.h [code]
    Header File for Phone Library API ---- MISC CATEGORY.

  • file HsPhoneNetwork.h [code]
    Header File for Phone Library API ---- NETWORK CATEGORY.

  • file HsPhonePower.h [code]
    Header File for Phone Library API ---- POWER CATEGORY.

  • file HsPhoneSecurity.h [code]
    Header File for Phone Library API ---- SECURITY CATEGORY.

  • file HsPhoneSMS.h [code]
    Header File for Phone Library API ---- SMS CATEGORY.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:37 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » toneslibrary

toneslibrary Directory Reference

Files

  • file TonesLib.h [code]
    Public 68K include file that controls the MIDI tones on a device.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:37 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » transparencylibrary

transparencylibrary Directory Reference

Files

  • file TransparencyLib.h [code]
    Transparency Library that couples a Ccp channel and a serial port.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:37 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » vmfont

vmfont Directory Reference

Files

  • file palmOneVMFontLib.h [code]
    Defines APIs and structures for the Palm VersaMail Font Picker / Font Manager Service which lets users get / set font characteristics.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:37 2008 for Palm API Guide


Header Files » Incs » 68k » system

system Directory Reference

Files

  • file FarCall.h [code]
  • file HardwareUtils68K.h [code]
    Public common header file to the Hardware Utilities Library used by 68K applications.

  • file HsExgMgr.h [code]
    Extensions to the Exchange Manager.

  • file HsExt.h [code]
    Header file that 68K programs include to access Handspring Extensions functionality.

  • file HsExtKbdUtils.h [code]
  • file HsExtTraps.h [code]
    Definitions of selectors used for the 68K trap based calls to HsExtensions.

  • file HsExtUtilBigButton.h [code]
  • file HsHelper.h [code]
  • file HsNav.h [code]
    Header file that 68K programs include to access HsNav functionality.

  • file PalmBGService.h [code]
    Public 68K header file for palmOne Background Network Service Library.

  • file PalmDisplayExtent.h [code]
    Public API for the Display Extent Library.

  • file PalmErrorBase.h [code]
    Include file for Error Management.

  • file PalmGoLCD.h [code]
    Public include header file for the GoLCD Library.

  • file PalmHiResTime.h [code]
    Exported High Resolution timer definitions.

  • file PalmLaunchCodes.h [code]
    Device specific launch codes.

  • file PalmLcdOverlay.h [code]
    Exported LCD Overlay functions.

  • file PalmLED.h [code]
    Palm's Generic LED dirver.

  • file PalmNative.h [code]
    Functions and macros to help building ARM code.

  • file 68k/system/palmOneChars.h [code]
  • file 68k/system/palmOneNavigator.h [code]
  • file palmOneStatusBar.h [code]
    Public common header file for palmOne defined Status Bar library.

  • file PalmPin.h [code]
    Public API for the Pen Input Manager Library.

  • file PalmPower.h [code]
    Battery notification.

  • file PalmResources.h [code]
  • file PalmStatusBar.h [code]
  • file PalmVMLaunch.h [code]
    Defines APIs and structures for launching VersaMail to add a new message from an application.

  • file PalmVMPlugin.h [code]
    Defines APIs and structures for the VersaMail Plugin Service which lets users write plugins to view/send attachments.

  • file PmPalmOSNVFS.h [code]
    Public 68k header file containing the definitions and API for NVFS devices.

  • file Slider.h [code]
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:37 2008 for Palm API Guide


Header Files » Incs » common

common Directory Reference

Directories

  • directory libraries
  • directory system

Files

  • file HsCommon.h [code]
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:34 2008 for Palm API Guide


Header Files » Incs » common » libraries

libraries Directory Reference

Directories

  • directory camera
  • directory cameramgr
  • directory codecpluginmgr
  • directory datebook
  • directory defaulthelperlibrary
  • directory favoritesdblibrary
  • directory filebrowser
  • directory hirestimerlib
  • directory hssoundlib
  • directory http
  • directory imaging
  • directory lcdoverlaylib
  • directory locs
  • directory mms
  • directory netmaster
  • directory netpref
  • directory pmconnectorlib
  • directory pmkeylib
  • directory pmsysgadgetlib
  • directory pmuiutillib
  • directory smarttextengine
  • directory telephony
  • directory toneslibrary
  • directory transparencylibrary
  • directory vmfont

Files

  • file PmLibErrors.h [code]
    Errors common to all our portable Pm Libraries.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:35 2008 for Palm API Guide


Header Files » Incs » common » libraries » camera

camera Directory Reference

Files

  • file CameraLibCommon.h [code]
    Public 68K common header file for camera support for Treo 600 devices.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:33 2008 for Palm API Guide


Header Files » Incs » common » libraries » cameramgr

cameramgr Directory Reference

Files

  • file palmOneCameraCommon.h [code]
    Public 68K common header file for camera support for Zire 72 and Treo 650 devices.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:33 2008 for Palm API Guide


Header Files » Incs » common » libraries » codecpluginmgr

codecpluginmgr Directory Reference

Files

  • file palmOneCodecFormat.h [code]
    Public 68K common header file for Codec Plugin Manager API - Codec Formats.

  • file palmOneCodecPluginMgrCommon.h [code]
    Public 68K common header file for Codec Plugin Manager API - Library Definitions.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:34 2008 for Palm API Guide


Header Files » Incs » common » libraries » datebook

datebook Directory Reference

Files

  • file DatebookLibCommon.h [code]
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:34 2008 for Palm API Guide


Header Files » Incs » common » libraries » defaulthelperlibrary

defaulthelperlibrary Directory Reference

Files

  • file DefaultHelperLibTypes.h [code]
    Public 68K common header file for Default Helper Library API.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:34 2008 for Palm API Guide


Header Files » Incs » common » libraries » favoritesdblibrary

favoritesdblibrary Directory Reference

Files

  • file FavoritesDBLibTypes.h [code]
    Public 68K common header file for FavoritesDB library API.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:34 2008 for Palm API Guide


Header Files » Incs » common » libraries » filebrowser

filebrowser Directory Reference

Files

  • file FileBrowserLibCommon.h [code]
    Public 68K common header file for File Browser library API.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:34 2008 for Palm API Guide


Header Files » Incs » common » libraries » hirestimerlib

hirestimerlib Directory Reference

Files

  • file palmOneHiResTimerCommon.h [code]
    Public 68k common header file for Hi-Resolution Timer API.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:34 2008 for Palm API Guide


Header Files » Incs » common » libraries » hssoundlib

hssoundlib Directory Reference

Files

  • file HsSoundLibCommon.h [code]
    Public 68K/Arm common header file for sound support for Treo 600, Treo 650, and Treo 700p smartphones and later models.

  • file HsSoundLibTraps.h [code]
  • file PmSoundLibAudioGroup.h [code]
    Public 68K header file used to associate sound channels with Audio groups on Treo 600 and Treo 650 smartphones.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:35 2008 for Palm API Guide


Header Files » Incs » common » libraries » http

http Directory Reference

Files

  • file HS_HTTPLibApp.h [code]
  • file HS_HTTPLibConst.h [code]
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:35 2008 for Palm API Guide


Header Files » Incs » common » libraries » imaging

imaging Directory Reference

Files

  • file ImageLibCommon.h [code]
    Public 68k common header file for the Image Library API on Treo 600 devices.

  • file ImageLibTraps.h [code]
  • file palmOnePhotoCommon.h [code]
    Palm Photos API: This file contains all the defines, enumerations, structures needed by PalmPhoto.h.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:35 2008 for Palm API Guide


Header Files » Incs » common » libraries » lcdoverlaylib

lcdoverlaylib Directory Reference

Files

  • file palmOneLcdOverlayCommon.h [code]
    Public 68k common header file for LCDOverlay API.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:35 2008 for Palm API Guide


Header Files » Incs » common » libraries » locs

locs Directory Reference

Files

  • file LocsLibCommon.h [code]
    Public 68K common header file for locations library.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:36 2008 for Palm API Guide


Header Files » Incs » common » libraries » mms

mms Directory Reference

Files

  • file MmsHelperCommon.h [code]
    Public 68k common header files to be used with Default Helper Library.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:36 2008 for Palm API Guide


Header Files » Incs » common » libraries » netmaster

netmaster Directory Reference

Files

  • file NetMasterLibErrors.h [code]
    This is the error declarations file for the NetMaster Library.

  • file NetMasterLibTarget.h [code]
    This is the target parameters file for the NetMaster Library.

  • file NetMasterLibTraps.h [code]
    Trap definitions for the NetMaster Library.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:36 2008 for Palm API Guide


Header Files » Incs » common » libraries » netpref

netpref Directory Reference

Files

  • file NetPrefLibErrors.h [code]
    This is the error declarations file for the NetPref Library.

  • file NetPrefLibTarget.h [code]
    This is the target parameters file for the NetPref Library.

  • file NetPrefLibTraps.h [code]
    Trap definitions for the NetPref Library.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:36 2008 for Palm API Guide


Header Files » Incs » common » libraries » pmconnectorlib

pmconnectorlib Directory Reference

Files

  • file PmConnectorLibCommon.h [code]
    Public 68k common header file for Multi-Connector Library for palmOne devices that use multi-connector.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:36 2008 for Palm API Guide


Header Files » Incs » common » libraries » pmkeylib

pmkeylib Directory Reference

Files

  • file PmKeyLibCommon.h [code]
    Public 68k common header file for system library that exports key-related APIs.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:36 2008 for Palm API Guide


Header Files » Incs » common » libraries » pmsysgadgetlib

pmsysgadgetlib Directory Reference

Files

  • file PmSysGadgetLibBbutRscCommon.h [code]
  • file PmSysGadgetLibCommon.h [code]
    Public 68k header file for system Library that exports system gadget related APIs.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:36 2008 for Palm API Guide


Header Files » Incs » common » libraries » pmuiutillib

pmuiutillib Directory Reference

Files

  • file PmUIUtilLibCommon.h [code]
    Public 68k common header file for system Library that exports UI utility API functions.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:36 2008 for Palm API Guide


Header Files » Incs » common » libraries » smarttextengine

smarttextengine Directory Reference

Files

  • file SmartTextEngineDef.h [code]
    Public include file for Smart Text Engine shared library.

  • file SmartTextEngineErrors.h [code]
    Error codes for Smart Text Engine shared library.

  • file SmartTextEngineRsc.h [code]
  • file SmartTextEngineTraps.h [code]
    Trap definitions for the Smart Text Engine shared library.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:37 2008 for Palm API Guide


Header Files » Incs » common » libraries » telephony

telephony Directory Reference

Files

  • file HsPhoneAudioTypes.h [code]
    File contains Phone Audio data types.

  • file HsPhoneCallControlTypes.h [code]
    Types for Phone Library call control functionality.

  • file HsPhoneCDMATypes.h [code]
    Header File for Phone Library API ---- NETWORK CATEGORY.

  • file HsPhoneErrors.h [code]
    Errors returned by API function in GSM/CDMA Library.

  • file HsPhoneEvent.h [code]
    Header file for the phone library (CDMA or GSM).

  • file HsPhoneGSMTypes.h [code]
    Header File for Phone Library API ---- NETWORK CATEGORY.

  • file HsPhoneIOTATypes.h [code]
    Header File for Phone Library API ---- IOTA CATEGORY.

  • file hsPhoneLocationTypes.h [code]
    File contains Phone Location data types.

  • file HsPhoneMiscTypes.h [code]
    Header File for Phone Library API ---- NETWORK CATEGORY.

  • file HsPhoneNetworkTypes.h [code]
    Header File for Phone Library API ---- NETWORK CATEGORY.

  • file HsPhoneSecurityTypes.h [code]
    Header File for Phone Library API ---- NETWORK CATEGORY.

  • file HsPhoneSMSTypes.h [code]
    Header File for Phone Library API ---- NETWORK CATEGORY.

  • file HsPhoneTrace.h [code]
    Trace constants, types, and definitions for Phone Library.

  • file HsPhoneTraps.h [code]
    Traps of all functions exported by the Phone Library.

  • file HsPhoneTypes.h [code]
    Telephony data types that are common between ARM and 68K.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:37 2008 for Palm API Guide


Header Files » Incs » common » libraries » toneslibrary

toneslibrary Directory Reference

Files

  • file TonesLibTypes.h [code]
    Public 68K header file for the Ring Tone library on Treo devices.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:37 2008 for Palm API Guide


Header Files » Incs » common » libraries » transparencylibrary

transparencylibrary Directory Reference

Files

  • file TransparencyLibTypes.h [code]
    Public common header file for the Transparency Library on Treo devices.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:37 2008 for Palm API Guide


Header Files » Incs » common » libraries » vmfont

vmfont Directory Reference

Files

  • file VMFontLibCommon.h [code]
    Public common header file for the Versamail Font Library.

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:37 2008 for Palm API Guide


Header Files » Incs » common » system

system Directory Reference

Files

  • file HsAppLaunchCmd.h [code]
    Public header file akin to Palm's AppLaunchCmd.h.

  • file HsChars.h [code]
  • file HsCreators.h [code]
    Public header file for the creator IDs used by Handspring.

  • file HsErrorClasses.h [code]
  • file HsErrors.h [code]
  • file HsExgMgrCommon.h [code]
  • file HsExtCommon.h [code]
    Common defines shared between HsExt.h (include for 68K programs) and HsExtArm.h (include for ARM programs).

  • file HsExtUtilBigButtonCommon.h [code]
  • file HsExtUtilBigButtonRsc.h [code]
  • file HsKeyCodes.h [code]
  • file HsKeyCommon.h [code]
    Header file with additional keyboard related definitions.

  • file HsKeyTypes.h [code]
    palmOne's key constant definitions shared by DAL and Palm OS (see Palm OS' CmnKeyTypes.h)

  • file HsNavCommon.h [code]
    Public common header file for 5-way navigation support on Treo 600.

  • file PalmCreators.h [code]
    Contains Palm-specific creator codes.

  • file PalmFeatures.h [code]
    Contains Palm-specific feature definitions.

  • file PalmGoLCDCommon.h [code]
    Public common header file for the GoLCD Library.

  • file common/system/palmOneChars.h [code]
  • file palmOneCreators.h [code]
    Contains Palm-specific creator codes.

  • file palmOneFeatures.h [code]
    Contains Palm-specific feature definitions.

  • file common/system/palmOneNavigator.h [code]
  • file palmOneResources.h [code]
    Palm-specific system types and resources.

  • file palmOneSystemCommon.h [code]
    This is the common public header for palmOne system definitions.

  • file PalmShimSettings.h [code]
    Shim settings for NetIFSettingGet()/Set().

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:37 2008 for Palm API Guide


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- _ -

  • _15_MW_TX_POWER : PalmWiFiCommon.h
  • _1_MW_TX_POWER : PalmWiFiCommon.h
  • _30_MW_TX_POWER : PalmWiFiCommon.h
  • _5_MW_TX_POWER : PalmWiFiCommon.h
  • _80211InfrastructureEnum : PalmWiFiCommon.h
  • _80211NetworkTypeEnum : PalmWiFiCommon.h
  • __HS_EXT_UTIL_BIG_BUTTON_RSC__H__ : HsExtUtilBigButtonRsc.h
  • __PM_SYS_GADGET_BBUT_RSC__H__ : PmSysGadgetLibBbutRscCommon.h
  • __SMART_TEXT_ENGINE_RSC_H__ : SmartTextEngineRsc.h
  • _GSMATEventInputEchoModeEnum : HsPhoneGSMTypes.h
  • _GSMDialCLIRMode : HsPhoneTypes.h
  • _GSMSATDataSvcTypeEnum : HsPhoneGSMTypes.h
  • _GSMSATEventInputFormatEnum : HsPhoneGSMTypes.h
  • _GSMSATEventMenuFlag : HsPhoneGSMTypes.h
  • _GSMSATEventSetupCallCallTypeEnum : HsPhoneGSMTypes.h
  • _GSMSATEventToneTimeUnitEnum : HsPhoneGSMTypes.h
  • _GSMSATEventToneTypeEnum : HsPhoneGSMTypes.h
  • _GSMSIMMessagesDialogKind : HsPhoneGSMTypes.h
  • _GSMSIMStatus : HsPhoneTypes.h
  • _LocDBSortOrderType : LocsLibCommon.h
  • _P1clActionType : DatebookLibCommon.h
  • _P1clAlarmUnitType : DatebookLibCommon.h
  • _P1clApptStatusType : DatebookLibCommon.h
  • _P1clAttachType : DatebookLibCommon.h
  • _P1clAttendeeFieldType : DatebookLibCommon.h
  • _P1clAttendeeRoleType : DatebookLibCommon.h
  • _P1clDeleteType : DatebookLibCommon.h
  • _P1clFieldsTypes : DatebookLibCommon.h
  • _P1clListFieldType : DatebookLibCommon.h
  • _P1clRepeatTypes : DatebookLibCommon.h
  • _P1clTimeZoneType : DatebookLibCommon.h
  • _P1clTxnEntry : DatebookLibCommon.h
  • _PhnAddressField : HsPhoneTypes.h
  • _PhnAudioSendMode : HsPhoneAudioTypes.h
  • _PhnBandSelection : HsPhoneNetworkTypes.h
  • _PhnCDMAFirmwareType : HsPhoneCDMATypes.h
  • _PhnCDMAVoicemailType : HsPhoneCDMATypes.h
  • _PhnConnectStateType : HsPhoneCallControlTypes.h
  • _PhnDataServiceType : HsPhoneNetworkTypes.h
  • _PhnGenericCDMAPreference : HsPhoneCDMATypes.h
  • _PhnGenericCDMASMSEncodingType : HsPhoneCDMATypes.h
  • _PhnGPRSPDPType : HsPhoneGSMTypes.h
  • _PhnGPRSQOSType : HsPhoneGSMTypes.h
  • _PhnLibAttrType : HsPhoneMiscTypes.h
  • _PhnMIPSessionType : HsPhoneNetworkTypes.h
  • _PhnOneXProtRevType : HsPhoneNetworkTypes.h
  • _PhnOprtModeType : HsPhoneMiscTypes.h
  • _PhnPacketDataEndStatusEnum : HsPhoneNetworkTypes.h
  • _PhnPacketDataSessionType : HsPhoneNetworkTypes.h
  • _PhnPDPConnectionType : HsPhoneCDMATypes.h
  • _PhnPDPCopyAck : HsPhoneCDMATypes.h
  • _PhnPDPDeleteAck : HsPhoneCDMATypes.h
  • _PhnPDPIndexType : HsPhoneCDMATypes.h
  • _PhnPDPReplaceAck : HsPhoneCDMATypes.h
  • _PhnPDPService : HsPhoneCDMATypes.h
  • _PhnPDSessionConfigParamType : hsPhoneLocationTypes.h
  • _PhnPowerType : HsPhoneTypes.h
  • _PhnRoamPrefSelectionTypeEnum : HsPhoneNetworkTypes.h
  • _PhnSysPrefSetting : HsPhoneCDMATypes.h
  • _PhnTTYSetting : HsPhoneAudioTypes.h
  • _PhoneServiceClassType : HsPhoneTypes.h
  • _SATDecisionType : HsPhoneGSMTypes.h
  • _SATNotificationType : HsPhoneGSMTypes.h
  • _SATRefreshFile : HsPhoneGSMTypes.h
  • _SATRefreshType : HsPhoneGSMTypes.h
  • _SATRequestType : HsPhoneGSMTypes.h
  • _SATSetupCallType : HsPhoneGSMTypes.h
  • _SmsCauseCode : HsPhoneSMSTypes.h
  • _SmsErrorCode : HsPhoneSMSTypes.h
  • _SoundPrefType : TonesLibTypes.h
  • _TonePlayNumberTimes : TonesLibTypes.h
  • _ToneRepeatInterval : TonesLibTypes.h
  • _ToneTimeUnit : TonesLibTypes.h
  • _ToneType : TonesLibTypes.h
  • _ToneVibrateType : TonesLibTypes.h
  • _ToneVolume : TonesLibTypes.h
  • _VMFontFace : VMFontLibCommon.h
  • _VMFontSize : VMFontLibCommon.h
  • _VMFontSizeRule : VMFontLibCommon.h
  • _VMFontStyle : VMFontLibCommon.h
  • _VMFontStyleRule : VMFontLibCommon.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:37 2008 for Palm API Guide


Palm API Guide Related Pages

Here is a list of all related documentation pages:
  • Deprecated List
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:38 2008 for Palm API Guide


Deprecated List

Global ImageLibResizeImage

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:08 2008 for Palm API Guide


Header Files » Incs » 68k » system

68k/system/palmOneChars.h

Go to the documentation of this file.
00001 /******************************************************************************
00002  * Copyright (c) 2005 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  *****************************************************************************/
00005 /**
00006  *@ingroup System
00007  *
00008  */
00009
00010 /**
00011  * @file    palmOneChars.h
00012  * @version 1.0
00013  * @date    03/03/2004
00014  *
00015  * @brief Contains palmOne-specific virtual characters.
00016  *    Temporary shim to the new filename and location.
00017  *
00018  *
00019  * <hr>
00020  */
00021
00022
00023 #ifndef __PALMONECHARS68K_H__
00024 #define __PALMONECHARS68K_H__
00025
00026 #include <Common/System/palmOneChars.h>
00027
00028
00029
00030 #endif // __PALMONECHARS68K_H__
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:54 2008 for Palm API Guide


Header Files » Incs » 68k » system

68k/system/palmOneNavigator.h

Go to the documentation of this file.
00001 /******************************************************************************
00002  * Copyright (c) 2005 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  *****************************************************************************/
00005 /**
00006  *@ingroup System
00007  *
00008  */
00009
00010 /**
00011  * @file    palmOneNavigator.h
00012  * @version 1.0
00013  * @date    03/03/2004
00014  *
00015  * @brief Contains 5-way navigator-specific definitions.
00016  *    Temporary shim to the new filename and location.
00017  *
00018  *
00019  * <hr>
00020  */
00021
00022
00023 #ifndef __PALMONENAVIGATOR68K_H__
00024 #define __PALMONENAVIGATOR68K_H__
00025
00026 #include <Common/System/palmOneNavigator.h>
00027
00028
00029 #endif // __PALMONENAVIGATOR68K_H__
00030
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:54 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » camera

CameraLib.h

Go to the documentation of this file.
00001 /******************************************************************************
00002  * Copyright (c) 2004 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  *****************************************************************************/
00005 /**
00006  * @ingroup Camera
00007  *
00008  */
00009
00010 /**
00011  * @file    CameraLib.h
00012  *
00013  * @brief   Public 68K include file for camera support for Treo 600 devices.
00014  *
00015  * Notes:
00016  * The calling application should always load this library with
00017  * SysLibLoad() before use, even if it is already open by another
00018  * application(ie, SysLibFind() returns a valid refnum). When
00019  * the application is done with the library, it should be
00020  * unloaded with SysLibRemove(). We do this because there is
00021  * no good way to synchronize loading and unloading of libraries
00022  * among multiple applications. It also greatly simplifies internal
00023  * synchronization.
00024  */
00025
00026 #ifndef __CAMERALIB68K_H__
00027 #define __CAMERALIB68K_H__
00028
00029 #include <PalmTypes.h>
00030 #include <LibTraps.h>
00031 #include <Common/HsCommon.h>
00032
00033
00034 /********************************************************************
00035  * Prototypes
00036  ********************************************************************/
00037 #ifdef __cplusplus
00038 extern "C" {
00039 #endif
00040
00041 /// Standard library open routine.
00042 /// Library should always be loaded with SysLibLoad()(not SysLibFind())
00043 /// before calling CameraLibOpen(). See note at top of file.
00044 ///
00045 /// @param refnum:  IN: Library reference number.
00046 /// @retval Err Error code.
00047 Err CameraLibOpen(UInt16 refnum)
00048             SYS_TRAP(kCameraLibTrapOpen);
00049
00050 /// Closes the Camera library.
00051 /// Library should always be unloaded with SysLibRemove() after
00052 /// CameraLibClose() is called. See note at top of file.
00053 ///
00054 /// @param refnum:  IN: Library reference number.
00055 /// @retval Err Error code.
00056 Err CameraLibClose(UInt16 refnum)
00057             SYS_TRAP(kCameraLibTrapClose);
00058
00059 /// Standard library sleep function.
00060 ///
00061 /// @param refnum:  IN: Library reference number.
00062 /// @retval Err Error code.
00063 Err CameraLibSleep (UInt16 refnum)
00064             SYS_TRAP(kCameraLibTrapSleep);
00065
00066 /// Standard library wake function.
00067 ///
00068 /// @param refnum:  IN: Library reference number.
00069 /// @retval Err Error code.
00070 Err CameraLibWake (UInt16 refnum)
00071             SYS_TRAP(kCameraLibTrapWake);
00072
00073
00074 /// Returns a full image (640X480) in the specified color space.
00075 /// This function is not really necessary, since CameraLibPreview could be used instead. This function might be deprecated in the future.
00076 ///
00077 /// @param refnum:  IN: Library reference number.
00078 /// @param buffer:  IN: Buffer to hold the image.
00079 /// @param format:  IN: Format of the image you want returned.
00080 /// @retval Err Error code.
00081 Err CameraLibCapture (UInt16 refnum, void * buffer, UInt16 format)
00082             SYS_TRAP(kCameraLibTrapCameraLibCapture);
00083
00084 /// Returns an image using the window width and height (pixels) you specify.
00085 /// If the width and height are less the dimensions of a full camera
00086 /// image (640x480) a simple pixel sub-sampling algorithm is used to decimate
00087 /// the image.
00088 ///
00089 /// @param refnum:  IN: Library reference number.
00090 /// @param buffer:  IN: Buffer to hold the image.
00091 /// @param format:  IN: Format of the image you want returned.
00092 /// @param width:   IN: The width in pixels of the image you want captured.
00093 /// @param height:  IN: The height in pixels of the image you want captured.
00094 /// @retval Err Error code.
00095 Err CameraLibPreview (UInt16 refnum, void * buffer, UInt16 format, UInt32 width, UInt32 height)
00096             SYS_TRAP(kCameraLibTrapCameraLibPreview);
00097
00098 /// Puts the camera library in preview mode and establishes a preview window.
00099 /// While in this mode, QQVGA images are continuously copied to the LCD
00100 /// screen of the device. Call CameraLibPreviewStop to exit preview mode.
00101 ///
00102 /// @param refnum:  IN: Library reference number.
00103 /// @param windowH: IN: Window handle of the PalmOS window that the image
00104 ///                     is to be displayed in.
00105 /// @param x:       IN: Window-relative coordinate of the left edge of the image.
00106 /// @param y:       IN: Window-relative coordinate of the top edge of the image.
00107 /// @retval Err Error code.
00108 Err CameraLibPreviewStart (UInt16 refnum, WinHandle windowH, UInt32 x, UInt32 y)
00109             SYS_TRAP(kCameraLibTrapCameraLibPreviewStart);
00110
00111 /// Stops preview mode.
00112 /// @see CameraLibPreviewStart.
00113 ///
00114 /// @param refnum:  IN: Library reference number.
00115 /// @retval Err Error code.
00116 Err CameraLibPreviewStop (UInt16 refnum)
00117             SYS_TRAP(kCameraLibTrapCameraLibPreviewStop);
00118
00119 /// Gets the current setting of the camera register.
00120 ///
00121 /// @param refnum:  IN: Library reference number.
00122 /// @param reg:     IN: Register number.
00123 /// @param valueP:  OUT: Pointer to where register data will be stored.
00124 /// @retval Err Error code.
00125 Err CameraLibRegisterGet (UInt16 refnum, UInt32 reg, UInt32 * valueP)
00126             SYS_TRAP(kCameraLibTrapCameraLibRegisterGet);
00127
00128 /// Sets the value of the camera register.
00129 ///
00130 /// @param refnum:  IN: Library reference number.
00131 /// @param reg:     IN: Register number.
00132 /// @param value:   IN: The data value you want to set the register to.
00133 /// @retval Err Error code.
00134 Err CameraLibRegisterSet (UInt16 refnum, UInt32 reg, UInt32 value)
00135             SYS_TRAP(kCameraLibTrapCameraLibRegisterSet);
00136
00137
00138 #ifdef __cplusplus
00139 }
00140 #endif
00141
00142 #endif  //__CAMERALIB68K_H__
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:52 2008 for Palm API Guide


Header Files » Incs » common » libraries » camera

CameraLibCommon.h

Go to the documentation of this file.
00001 /*******************************************************************************
00002  * Copyright (c) 2004-2005 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  ******************************************************************************/
00005 /**
00006  *@ingroup Camera
00007  */
00008
00009 /**
00010  * @file    CameraLibCommon.h
00011  * @brief   Public 68K common header file for camera support for Treo 600 devices.
00012  *
00013  * This file contains the library constants and error codes used in the APIs.
00014  * <hr>
00015  */
00016
00017 #ifndef CAMERA_LIB_COMMON_H
00018 #define CAMERA_LIB_COMMON_H
00019
00020 #define kCameraLibType      sysFileTLibrary /**< Default library type */
00021 #define kCameraLibCreator   'HsCa'          /**< Camera library creator ID */
00022 #define kCameraLibName      "CameraLib"     /**< Camera library database name */
00023
00024
00025 /**
00026  * @name Image Format
00027  */
00028 /*@{*/
00029 #define kCameraImageFormatRGB1        1 /**<Whatever RGB1 Format is*/
00030 #define kCameraImageFormatRGB4        2 /**<Whatever RGB4 Format is*/
00031 #define kCameraImageFormatRGB8        3 /**<Whatever RGB8 Format is*/
00032 #define kCameraImageFormatRGB16       4 /**<Whatever RGB16 Format is*/
00033 #define kCameraImageFormatRGB24       5 /**<Whatever RGB24 Format is*/
00034 #define kCameraImageFormatRGB32       6 /**<Whatever RGB32 Format is*/
00035 #define kCameraImageFormatYCrCb       7 /**<Whatever RGBYCrCb Format is*/
00036 #define kCameraImageLittleEndian      0x8000 /**<Whatever LittleEndian Format is*/
00037 #define kCameraImageFormatYCbCr       kCameraImageFormatYCrCb /**< not used */
00038 /*@}*/
00039
00040 /**
00041  * @name Error Codes
00042  */
00043 /*@{*/
00044 #define errCam                        0xaf00
00045 #define errCamNoFrame                 (errCam + 0)
00046 #define errInPreviewMode              (errCam + 1)
00047 #define errCamOverflow                (errCam + 2)
00048 #define errInvalidAddress             (errCam + 3)
00049 #define errCamWriteFailed             (errCam + 4)
00050 /*@}*/
00051
00052 /**
00053  * @name Function Traps
00054  */
00055 /*@{*/
00056 #define kCameraLibTrapOpen                  sysLibTrapOpen
00057 #define kCameraLibTrapClose                 sysLibTrapClose
00058 #define kCameraLibTrapSleep                 sysLibTrapSleep
00059 #define kCameraLibTrapWake                  sysLibTrapWake
00060 #define kCameraLibTrapCameraLibCapture      (sysLibTrapCustom)
00061 #define kCameraLibTrapCameraLibPreview      (sysLibTrapCustom+1)
00062 #define kCameraLibTrapCameraLibPreviewStart (sysLibTrapCustom+2)
00063 #define kCameraLibTrapCameraLibPreviewStop  (sysLibTrapCustom+3)
00064 #define kCameraLibTrapCameraLibRegisterGet  (sysLibTrapCustom+4)
00065 #define kCameraLibTrapCameraLibRegisterSet  (sysLibTrapCustom+5)
00066 /*@}*/
00067
00068 #endif
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:52 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » carriercustomlib

CarrierCustomLib.h

Go to the documentation of this file.
00001 /******************************************************************************
00002  * Copyright (c) 2004 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  *****************************************************************************/
00005 /**
00006  * @defgroup Carrier Carrier Customization Library
00007  *
00008  * @{
00009  * @}
00010  */
00011
00012 /**
00013  * @file CarrierCustomLib.h
00014  * @version 1.0
00015  * @date 12/01/2002
00016  *
00017  * @brief This is the main header file for the Carrier Customization
00018  * Library.
00019  *
00020  * This includes all the other required headers, so there is no need
00021  * to include Traps, Errors, and Types if this is included.
00022  *
00023  * Usage Model:
00024  *
00025  * This library is automatically loaded at boot time by HsExtensions.
00026  * Apps that call this library should only have to call
00027  * SysLibFind.  They should never have to load the library.
00028  * LibOpen and LibClose should not be called either.
00029  *
00030  */
00031
00032 /*
00033  * @author       dla
00034  *
00035  * $Id: //depot/Components/Libraries/PmCarrierCustomizationLib/1.2C/Incs/IncsPublic/68K/Libraries/PmCarrierCustomizationLib/CarrierCustomLib.h#1 $
00036  *
00037  */
00038
00039 #ifndef __CARRIER_CUSTOMIZATION_LIBRARY_H__
00040 #define __CARRIER_CUSTOMIZATION_LIBRARY_H__
00041
00042
00043 #include <CarrierCustomLibTraps.h>
00044 #include <CarrierCustomLibErr.h>
00045 #include <CarrierCustomLibTypes.h>
00046
00047 #define ENCRYPTED_DATABASE true /**< internal */
00048
00049 #define MVNONAME_LENGTH 10  /* length for MVNO name stored in carrier DB*/
00050
00051 #ifdef BUILDING_CARRIER_CUSTOMIZATION_PREF_LIB_DISPATCH_TABLE
00052   #define CCUSTOM_LIB_TRAP(trapNum)
00053 #else
00054   #define CCUSTOM_LIB_TRAP(trapNum) SYS_TRAP(trapNum)
00055 #endif
00056
00057 #if 0
00058 #pragma mark -------- Constants --------
00059 #endif
00060
00061 #if 0
00062 #pragma mark -------- Structs --------
00063 #endif
00064
00065
00066 #if 0
00067 #pragma mark -------- Exported Globals --------
00068 #endif
00069
00070
00071 #if 0
00072 #pragma mark -------- Exported Functions --------
00073 #endif
00074
00075
00076 #ifdef __cplusplus
00077 extern "C" {
00078 #endif
00079
00080 /**
00081  * Open the library, initialize library globals
00082  * Initializes the library globals, based on the last known carrier.
00083  * This should never be called by an application, as it is automatically
00084  * loaded by the system and opened.
00085  *
00086  * @param refNum:  IN:  CCustomLib reference number (from SysLibFind
00087  *                      or SysLibLoad)
00088  *
00089  * @retval Err Error Code.
00090  */
00091 extern Err
00092 CCustomLibOpen(UInt16 refNum)
00093     CCUSTOM_LIB_TRAP(sysLibTrapOpen);
00094
00095
00096 /**
00097  * Closes library and frees up allocated resources
00098  * Close the library and decrements the reference count.
00099  * This should never be called by an application.
00100  *
00101  * @param refNum:  IN:  CCustomLib reference number (from SysLibFind
00102  *                      or SysLibLoad)
00103  *
00104  * @retval Err Error Code.
00105  */
00106 extern Err
00107 CCustomLibClose(UInt16 refNum)
00108     CCUSTOM_LIB_TRAP(sysLibTrapClose);
00109
00110
00111 /**
00112  * Standard library sleep routine
00113  *
00114  * @param refNum:  IN:  CCustomLib reference number (from SysLibFind
00115  *                      or SysLibLoad)
00116  *
00117  * @retval Err Error code.
00118  */
00119 extern Err
00120 CCustomLibSleep(UInt16 refNum)
00121     CCUSTOM_LIB_TRAP(sysLibTrapSleep);
00122
00123
00124 /**
00125  * Standard library wake routine
00126  *
00127  * @param refNum:  IN:  CCustomLib reference number (from SysLibFind
00128  *                      or SysLibLoad)
00129  *
00130  * @retval Err Error code.
00131  */
00132 extern Err
00133 CCustomLibWake(UInt16 refNum)
00134     CCUSTOM_LIB_TRAP(sysLibTrapWake);
00135
00136
00137 /** Get Library API Version number.
00138  *
00139  *  @param refNum:          IN:  Library reference number
00140  *  @param majorVerP:       OUT: Major version number
00141  *  @param minorVerP:       OUT: Minor version number
00142  *  @param bugFixVerP:      OUT: Bug fix version number
00143  *  @retval Err             Customization Library error code
00144  */
00145 extern Err
00146 CCustomLibVersionGet(UInt16 refNum, UInt32* majorVerP, UInt32* minorVerP, UInt32* bugFixVerP)
00147   CCUSTOM_LIB_TRAP(CCustomLibTrapVersionGet);
00148
00149
00150 /**
00151  * Returns the specified setting.
00152  * Returns the carrier settings for the given field.
00153  * Any memory allocation must be freed by the calling application.
00154  * Currently, only string types are allocated.
00155  *
00156  * @param refNum:        IN:     CCustomLib reference number (from SysLibFind
00157  *                               or SysLibLoad)
00158  * @param settingsType:  IN:     object type specified by settingsTypeEnum
00159  * @param dataP:         IN,OUT: allocated object containing data, undefined on err
00160  *
00161  * @retval Err Error code.
00162  */
00163 extern Err
00164 CCustomLibGetCarrierSetting(UInt16 refNum, CCSMSettingsType settingsType, void *dataP)
00165   CCUSTOM_LIB_TRAP(CCustomLibTrapGetCarrierSetting);
00166
00167
00168 /**
00169  * Returns the carrier ID from the SIM.
00170  * Makes a copy of MMC/MNC code and returns it.
00171  *
00172  * @param refNum:           IN:      CCustomLib reference number (from SysLibFind
00173  *                                   or SysLibLoad)
00174  * @param length:           IN,OUT:  length of buffer passed in, length of buffer
00175  *                                   used/needed (not including terminator)
00176  * @param dataP:            OUT:     pointer to store the value
00177  * @retval Err Error code.
00178  */
00179 extern Err
00180 CCustomLibGetCarrierCode(UInt16 refNum, UInt8 *length, char **dataP)
00181   CCUSTOM_LIB_TRAP(CCustomLibTrapGetCarrierCode);
00182
00183
00184 /**
00185  * Returns the actual length of the carrier ID.
00186  * If no carrier code is passed it, returns the length of the current carrier ID.
00187  * This length is usually 6 for North American countries and 5 for others.
00188  *
00189  * @param refNum:            IN:       CCustomLib reference number (from SysLibFind
00190  *                                     or SysLibLoad)
00191  * @param lengthP:           IN,OUT:   length of carrier code.
00192  *                                     Uses the current carrier if no carrier code is passed in
00193  * @param carrierCodeP:      IN:       optional carrier code
00194  * @retval Err Error code.
00195  */
00196 extern Err
00197 CCustomLibGetCarrierCodeLength(UInt16 refNum, UInt8 *lengthP, char *carrierCodeP)
00198   CCUSTOM_LIB_TRAP(CCustomLibTrapGetCarrierCodeLength);
00199
00200
00201 #ifdef __cplusplus
00202 }
00203 #endif
00204
00205
00206 #endif // __CARRIER_CUSTOMIZATION_LIBRARY_H__
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:52 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » carriercustomlib

CarrierCustomLibErr.h

Go to the documentation of this file.
00001 /******************************************************************************
00002  * Copyright (c) 2004 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  *****************************************************************************/
00005 /**
00006  * @ingroup Carrier
00007  */
00008
00009 /**
00010  * @file    CarrierCustomLibErr.h
00011  * @version 1.0
00012  * @date    12/17/2002
00013  *
00014  * @brief This file contains the error codes for the Carrier Customization
00015  *        Library.
00016  *
00017  */
00018
00019 /*
00020  * @author    dla
00021  */
00022
00023 #ifndef __CARRIER_CUSTOMIZATION_LIBRARY_ERRORS_H__
00024 #define __CARRIER_CUSTOMIZATION_LIBRARY_ERRORS_H__
00025
00026
00027 #define ccsmErrClass      0x9000  /**< 0x9000 Carrier customization library error base number */
00028
00029 #define ccsmErrUnknownCarrier       ccsmErrClass + 0x01  /**< 0x9001 carrier code on SIM card not recognized */
00030 #define ccsmErrMemory               ccsmErrClass + 0x02  /**< 0x9002 memory error */
00031 #define ccsmErrPhoneLibLoad         ccsmErrClass + 0x03  /**< 0x9003 phone library not loaded */
00032 #define ccsmErrPhoneNotPowered      ccsmErrClass + 0x04  /**< 0x9004 phone is not powered */
00033 #define ccsmErrInvalidArg           ccsmErrClass + 0x05  /**< 0x9005 invalid arguement error */
00034 #define ccsmErrUnknownSetting       ccsmErrClass + 0x06  /**< 0x9006 unknown setting requested error */
00035 #define ccsmErrBufferTooSmall       ccsmErrClass + 0x07  /**< 0x9007 need more space in buffer */
00036 #define ccsmErrNotRegistered        ccsmErrClass + 0x08  /**< 0x9008 radio is not registered */
00037 #define ccsmErrUnknownField         ccsmErrClass + 0x09  /**< 0x9009 requested field not in database record */
00038 #define ccsmErrLibUninitialized     ccsmErrClass + 0x0A  /**< 0x900A library was not initialized */
00039 #define ccsmErrUndefinedField       ccsmErrClass + 0x0B  /**< 0x900B the field did not have a value specified */
00040
00041 #define ccsmErrProfileUnspecified   ccsmErrClass + 0x50  /**< 0x9050 requested profile is not specified */
00042 #define ccsmErrUnspecified          ccsmErrClass + 0x51  /**< 0x9051 settings is not specified for carrier */
00043 #define ccsmErrUnimplemented        ccsmErrClass + 0xA5  /**< 0x90F5 Unimplemented feature */
00044
00045 #endif // __CARRIER_CUSTOMIZATION_LIBRARY_ERRORS_H__
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:52 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » carriercustomlib

CarrierCustomLibTraps.h

Go to the documentation of this file.
00001 /******************************************************************************
00002  * Copyright (c) 2004 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  *****************************************************************************/
00005 /**
00006  * @ingroup Carrier
00007  */
00008
00009 /**
00010  * @file    CarrierCustomLibTraps.h
00011  * @version 1.0
00012  * @date    12/11/2002
00013  *
00014  * @brief This file contains the trap for the Carrier Customization
00015  *        Library.
00016  *
00017  */
00018
00019 /*
00020  * @author    dla
00021  */
00022
00023
00024 #ifndef __CARRIER_CUSTOMIZATION_LIBRARY_TRAPS_H__
00025 #define __CARRIER_CUSTOMIZATION_LIBRARY_TRAPS_H__
00026
00027
00028 /**
00029  * @name Function Trap Numbers
00030  * @brief Trap IDs for the Carrier Customization Library's public functions. The order of the traps
00031  *        must be the same as the routines are listed in NetPrefLibDispatchTable.c.
00032  */
00033 /*@{*/
00034 #define CCustomLibTrapVersionGet                   (sysLibTrapCustom + 0)
00035 #define CCustomLibTrapGetCarrierSetting            (sysLibTrapCustom + 1)
00036 #define CCustomLibTrapGetProfileSetting            (sysLibTrapCustom + 2)
00037 #define CCustomLibTrapGetCarrierProfile            (sysLibTrapCustom + 3)
00038 #define CCustomLibTrapReleaseCarrierProfile        (sysLibTrapCustom + 4)
00039 #define CCustomLibTrapGetCarrierCode               (sysLibTrapCustom + 5)
00040 #define CCustomLibTrapGetCarrierCodeLength         (sysLibTrapCustom + 6)
00041 #define CCustomLibTrapRefresh                      (sysLibTrapCustom + 7)
00042 #define CCustomLibTrapRetrieveNVSetting            (sysLibTrapCustom + 8)
00043 /*@}*/
00044 #endif // __CARRIER_CUSTOMIZATION_LIBRARY_TRAPS_H__
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:52 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » carriercustomlib

CarrierCustomLibTypes.h

Go to the documentation of this file.
00001 /******************************************************************************
00002  * Copyright (c) 2004 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  *****************************************************************************/
00005 /**
00006  * @ingroup Carrier
00007  */
00008
00009 /**
00010  * @file    CarrierCustomLibTypes.h
00011  * @version 1.0
00012  * @date    12/16/2002
00013  *
00014  * @brief This file contains public data types exported by the
00015  * Carrier Customization Library
00016  *
00017  */
00018
00019 /*
00020  * @author    dla
00021  *  History:
00022  *    11-Dec-2002   dla     Created
00023  *    16-Dec-2003   dla     Numerous additions for CDMA carrier support
00024  *
00025  *
00026  * <hr>
00027  */
00028
00029
00030 #ifndef __CARRIER_CUSTOMIZATION_LIBRARY_TYPES_H__
00031 #define __CARRIER_CUSTOMIZATION_LIBRARY_TYPES_H__
00032
00033
00034 #if 0
00035 #pragma mark -------- Constants --------
00036 #endif
00037
00038 #define kCCLibType                    'libr'                        /**< Standard library type */
00039 #define kCarrierCustomizationCLibName "CarrierCustomization.lib"    /**< Carrier Customization Library name */
00040 #define kCarrierListDBName            "CarrierProfiles2"            /**< Name of carrier list database */
00041 #define kNetworkListDBName            "NetworkProfiles2"            /**< Name of network list database */
00042
00043
00044 /**
00045  * @name API Version numbers
00046  * @brief Current library API version number. Returned by NetPrefLibVersionGet()
00047  */
00048 /*@{*/
00049 #define CCSMVersionMajor      0
00050 #define CCSMVersionMinor      6
00051 #define CCSMVersionBugFix     0
00052 /*@}*/
00053
00054 /**
00055  * @name Carrier codes
00056  */
00057 /*@{*/
00058 #define kSprintMCCMNC         "310000"
00059 #define kVerizonMCCMNC        "310555"
00060 #define kBellMobilityMCCMNC   "310505"
00061 #define kGenericMCCMNC        "310999"
00062 /*@}*/
00063
00064 typedef void *CCSMCarrierHandle;  /**< pointer type to hold the carrier object */
00065
00066 /**
00067  * Enumeration for the type of carrier settings.
00068  * The following are applicable to CDMA as well.
00069  *
00070  *
00071  * We want to keep the groups together.
00072  * This helps keep track of which structure the setting resides in.
00073  */
00074 enum
00075 {
00076   kCCSMSettingsSystemReserved,         /**< system settings place holder */
00077
00078   //                                         <Data type returned> description
00079   // phone settings
00080   kCCSMSettingsShowNetworkSelect,      /**< <Boolean> enable/disable network select */
00081   kCCSMSettingsIndicateRoaming,        /**< <Boolean> enable/disable roaming indicator */
00082   kCCSMSettingsEditableMSISDN,         /**< <Boolean> User editable MSISDN */
00083   kCCSMSettingsShowEmergencyMode,      /**< <Boolean> enable/disable emergency mode indicator */
00084   kCCSMSettingsCarrierMSISDN,          /**< <char *>  carrier MSISDN */
00085   kCCSMSettingsRadioBand,              /**< <UInt32>  radio band to start search with */
00086   kCCSMSettingsVoiceMailNumber,        /**< <char *>  carriers voice mail number */
00087
00088   // Messaging settings
00089   kCCSMSettingsPOP3Server,             /**< <char *>  pop3 server -- will be deprecated */
00090   kCCSMSettingsSMTPServer,             /**< <char *>  smtp server -- will be deprecated */
00091   kCCSMSettingsSMSCNumber,             /**< <char *>  smsc number */
00092   kCCSMSettingsSMSEmailGateway,        /**< <char *>  sms email gateway */
00093   kCCSMSettingsMMSURL,                 /**< <char *>  MMS URL */
00094   kCCSMSettingsMMSWAPGateway,          /**< <char *>  MMS WAP gateway */
00095   kCCSMSettingsMMSPort,                /**< <UInt32>  MMS port number */
00096   kCCSMSettingsMMSMaxMsgSize,          /**< <UInt32> max MMS message size (kbytes) */
00097
00098   // Browser settings
00099   kCCSMSettingsPrimaryProxyServer,          /**< <char *>  Proxy server */
00100   kCCSMSettingsPrimaryProxyPort,            /**< <UInt32>  Proxy port */
00101   kCCSMSettingsPrimarySecureProxyServer,    /**< <char *>  Secure proxy server */
00102   kCCSMSettingsPrimarySecureProxyPort,      /**< <UInt32>  Secure proxy port */
00103   kCCSMSettingsSecondaryProxyServer,        /**< <char *>  Proxy server */
00104   kCCSMSettingsSecondaryProxyPort,          /**< <UInt32>  Proxy port */
00105   kCCSMSettingsSecondarySecureProxyServer,  /**< <char *>  Secure proxy server */
00106   kCCSMSettingsSecondarySecureProxyPort,    /**< <UInt32>  Secure proxy port */
00107   kCCMSSettingsPrimaryTrustedDomain,        /**< <char *>  GSM:  Primary trusted domain */
00108                                             /**< <char *>  CDMA: phone:downloadserver.url */
00109
00110   kCCMSSettingsSecondaryTrustedDomain,      /**< <char *>  GSM Only: Secondary trusted domain */
00111   kCCMSSettingsUAProfilingURL,              /**< <char *>  UA Profiling URL */
00112   kCCSMSettingsHTTPHeaders,                 /**< <char *>  carrier specific HTTP headers to send */
00113   kCCSMSettingsNAIHeaderFormat,             /**< <char *>  header format to send NAI (see sprintf format) */
00114   kCCSMSettingsMSISDNHeaderFormat,          /**< <char *>  header format to send MSISDN (see sprintf format) */
00115   kCCSMSettingsEncryptMSISDN,               /**< <Boolean> encrypt MSISDN header */
00116   kCCSMSettingsHomepageURL,                 /**< <char *> home page string */
00117
00118   // network settings
00119   kCCSMSettingsGPRSAutoAttach,              /**< <Boolean> flag whether or not to display the GPRS attached icon  */
00120
00121   // NVRAM settings.
00122   kCCSMSettingsNAI,                         /**< <char *> Slot 1 username.  CDMA only */
00123
00124   // new items
00125   kCCSMSettingsBrowserFlags,                /**< <UInt32> flags that controls browser behaviour */
00126   kCCSMSettingsBrowserProxyFlags,           /**< <UInt32> flags that controls browser behaviour */
00127
00128   kCCSMSettingsProxyUsername,               /**< <char *> proxy username */
00129   kCCSMSettingsProxyPassword,               /**< <char *> password for the proxy */
00130   kCCSMSettingsMessagingFlags,              /**< <UInt32> messaging flags */
00131   kCCSMSettingsSMSMaxMsgSize,               /**< <UInt32> max SMS message size (bytes) */
00132   kCCSMSettingsSMSValidityPeriod,           /**< <UInt32> SMS validity period network specific value */
00133   kCCSMSettingsE911Timeout,                 /**< <UInt32> E911 timeout value (seconds) */
00134
00135   // MMS Settings
00136   kCCSMSettingsMMSUAProf,                   /**< <char *> UA Prof */
00137   kCCSMSettingsMMSUAString,                 /**< <char *> UA Prof string*/
00138   kCCSMSettingsMMSMaxVideoSize,             /**< <Int32> MMS maximum video size */
00139   kCCSMSettingsMMSVersionNumber,            /**< <Int32> MMS version (11 = 1.1) */
00140
00141   // Email settings
00142   kCCSMSettingsEmailSMTPServer,             /**< <char *> SMTP Server */
00143
00144   // extra phone settings
00145   kCCSMSettingsSPNSupported,                /**< <Boolean> flag if SPN is supported */
00146
00147   kCCSMSettingsWapSupportLevel,             /**< <UInt16> WAP level supported. */
00148
00149   kCCSMSettingsSMSSupportDeliveryReceipt,   /**< <Boolean> WAP level supported. */
00150
00151   kCCSMSettingsCSDDisable,                  /**< <Boolean> CSD disable or not */
00152
00153   kCCSMSettingsReserved = 0x8000      /**< reserved */
00154 };
00155 typedef UInt16 CCSMSettingsType;  /**< used with the settingsTypeEnum */
00156
00157
00158 /** system settings
00159  *
00160  */
00161 typedef enum
00162 {
00163   kCCSMSystemSettingReserved  = 0x00000000  /**< reserved setting */
00164 }
00165 CCSMSystemFlagsEnum;
00166 typedef UInt32 CCSMSystemFlagsType; /**< Used with CCSMSystemFlagsEnum */
00167
00168 /** enumeration for the phone settings flags
00169  *
00170  */
00171 typedef enum
00172 {
00173   kCCSMPhoneSettingsReserved          = 0x00000000,  /**< reserved setting */
00174   kCCSMPhoneSettingsNetworkSelect     = 0x00000001,  /**< Network Select disable/enable */
00175   kCCSMPhoneSettingsRoamingIndicator  = 0x00000002,  /**< Roaming indicator yes/no */
00176   kCCSMPhoneSettingsEditMSISDN        = 0x00000004,  /**< Editable MSISDN */
00177   kCCSMPhoneSettingsShowEmergencyMode = 0x00000008,  /**< use Emergency mode */
00178   kCCSMPhoneSettingsEnableTTY         = 0x00000010,  /**< enable TTY */
00179   kCCSMPhoneSettingsUseEFSPN          = 0x00000020   /**< Use EF SPN if any */
00180 }
00181 CCSMPhoneFlagsEnum;
00182 typedef UInt32 CCSMPhoneFlagsType; /**< used with CCSMPhoneFlagsEnum */
00183
00184 /** enumeration for the radio band
00185  *  Used to optimize which band the radio starts scanning on.
00186  */
00187 typedef enum
00188 {
00189   kCCSMRadioBandUnknown,        /**< unknown radio band */
00190   kCCSMRadioBandEurope,         /**< european radio */
00191   kCCSMRadioBandNorthAmerica    /**< north american radio */
00192 }
00193 CCSMRadioBandEnum;
00194 typedef UInt32 CCSMRadioBandType; /**< used with CCSMRadioBandEnum */
00195
00196 /** enumeration for the messaging settings flags
00197  *
00198  */
00199 typedef enum
00200 {
00201   kCCSMMessagingSettingsReserved              = 0x00000000,  /**< reserved setting */
00202   kCCSMMessagingSettingsStripPhonePlus        = 0x00000001,  /**< does the network require the phone number to be stripped */
00203   kCCSMMessagingSettings11DigitRecipient      = 0x00000002,  /**< flag if a number requires 10 or 11 digits (I assume US only) */
00204   kCCSMMessagingSettingsNormaliseMMSAddress   = 0x00000004,  /**< Flag if MMS address should be normalised or not */
00205   kCCSMMessagingSettingsWAPProtocol20         = 0x00000008,  /**< *internal* Use WAP 2.0 for MMS? */
00206   kCCSMMessagingSettingsDisableMMSFallback    = 0x00000010   /**< Flag to disable the fallback account when connecting */
00207
00208   //  kCCSMMessagingSettingsCameraProtocol        = 0x00000020,  /**< *internal* Use lightsurf or not */
00209 }
00210 CCSMMessagingSettingsEnum;
00211 typedef UInt32 CCSMMessagingFlagsType; /**< Used with CCSMMessagingSettingsEnum */
00212
00213
00214 /** enumeration for the browser settings flags
00215  *
00216  */
00217 typedef enum
00218 {
00219   kCCSMBrowserSettingsReserved              = 0x00000000,  /**< reserved setting */
00220   kCCSMBrowserSettingsEncryptMSISDN         = 0x00000001,  /**< send encrypted MSISDN */
00221   kCCSMBrowserSettingsCSDDisconnectOnExit   = 0x00000002,  /**< disconnect on exit for CSD connections */
00222   kCCSMBrowserSettingsPDataDisconnectOnExit = 0x00000004,  /**< disconnect on exit for packet data connections */
00223   kCCSMBrowserSettingsDormantOnExit         = 0x00000008,  /**< force dormancy on exit */
00224
00225   kCCSMBrowserSettingsHideDisconnect        = 0x00000010,  /**< hide disconnect button */
00226   kCCSMBrowserSettingsVersionInWAPProfile   = 0x00000020,  /**< Add version in WAP profile header */
00227
00228
00229
00230   kCCSMPrimaryProxyAuthenticate             = 0x00000001,  /**< proxy properties */
00231   kCCSMPrimaryProxyLocked                   = 0x00000002,  /**< proxy properties */
00232   kCCSMPrimaryProxyHide                     = 0x00000004,  /**< proxy properties */
00233
00234   kCCSMSecondaryProxyAuthenticate           = 0x00010000,  /**< proxy properties */
00235   kCCSMSecondaryProxyLocked                 = 0x00020000,  /**< proxy properties */
00236   kCCSMSecondaryProxyHide                   = 0x00040000   /**< proxy properties */
00237 }
00238 CCSMBrowserSettingsEnum;
00239 typedef UInt32 CCSMBrowserFlagsType; /**< Used with CCSMBrowserSettingsEnum */
00240
00241 struct CCSMContextTypeTag;
00242
00243 #endif // __CARRIER_CUSTOMIZATION_LIBRARY_TYPES_H__
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:52 2008 for Palm API Guide


Palm API Guide Data Structure Index

A | B | C | D | F | H | L | M | N | P | S | T | U | V | W | _

A
AacFileRef
AddrAddToRecordParamsType
AddrCallerIDParamsType
AddrCreateNewRecordParamsType
AddrDescriptor
Address
AddressAppRecord
AddressAppRecordHeader
AddressType
AddrHsLookupUserDataType
AddrHsLookupUserDataV2Type
AddrListLookupTypeGetParamsType
AddrPhonebookAppParamsType
AddrPhotoCallerIDParamsType
AiaExtentChangedEventDataType
ApptTimeZoneType
B
BGResult
BSSListStruct
C
CamLibBitmapInfoTag
CamLibCaptureTag
CamLibColorSpaceTag
CamLibSettingTag
CamLibStatusTag
CamLibStreamTag
Coordinate
D
DevAppLaunchCmdGenericCallType
DialPnlDispatchDialParamsType
DialPnlIsDialingAvailableParamsType
DSTDataTag
F
FrmNavHeaderTag
FrmNavOrderEntryTag
H
HS_HTTPLibAppinfo_
HS_HTTPLibAuthInfo_
HS_HTTPLibIPAddr_
HS_HTTPLibNetLibInfo_
HS_HTTPLibOpaque_
HS_HTTPLibPeer_
HS_HTTPLibSplit_
HS_HTTPLibTime_
HsBigButtonMappingType
HsBigButtonReourceType
HsDialPrefsUSDialingRulesType
HsSndBufferData
HsSndMidiProgressMsg
HsSndPortInfo
HtmlLibFocusTargetInfo
HtmlLibFormWidgetProc
HttpUASelectionRule
L
LcdOverlayLibSettingTag
LocationDataTag
LocDBInfoTag
LocDBRecordTag
LocsLibNotifyDataTag
LocsLibNotifyLocsDataTag
LocsLibSelLocsTag
M
MailAddRecordAttachment
MailAddRecordParamsTypePlus
MMProAttachDataLinks
MMProAttachStruct
MMProAttachStruct2
MMProLaunchStruct
MMProLaunchStruct2
N
NBSNotificationEventType
Net80211DeviceInfo
NetBssInfoType
NetMasterClientEventInfoType
NetMasterClientEventVPNConnInstallType
NetPrefFallbackInfoType
NetPrefGPRSQOSType
NetServicesProfile
NetServicesProfileInfo
NetServicesProfileOrder
NetServicesProfileV1
NetSSID
NetWepKey
NetworkDeviceQueryData
P
P1clRecordDetails
PalmAudioAACDecParamType
PalmAudioAACParamType
PalmAudioADPCMParamType
PalmAudioAMRParamType
PalmAudioMP2ParamType
PalmAudioPCMParamType
PalmAudioPlaybackNotifyEventTypeTag
PalmAudioQCELPDecParamType
PalmAudioQCELPParamType
PalmFileFormatParamType
PalmImageBMPParamType
PalmImageGIFFrameParamType
PalmImageINDEXParamType
PalmImageJPEGEncodeParamType
PalmImageParamType
PalmImagePlanarType
PalmVideoAVCCustomGetDecodedFrameType
PalmVideoAVCCustomGetInfoType
PalmVideoAVCCustomSetCropModeType
PalmVideoAVCDecodeParamType
PalmVideoAVCOutputBufferType
PalmVideoMPEG1DecodeParamType
PalmVideoMPEG4DecodeParamType
PalmVideoMPEG4EncodeParamType
ParsedInfo
ParsedInfoList
PhnCdmaSystemInfoType
PhnConferenceDesc
PhnConnectionType
PhnDataSessionStateType
PhnDisconnectEventType
PhnError
PhnEventType
PhnEventType::Data
PhnGPRSPDPContextListNodeType
PhnGPRSPDPContextType
PhnIndicationType
PhnIOTAPhnDlsLockType
PhnIOTAPhnHomepagetype
PhnIOTAPhnNAIIMStore
PhnIOTAPhnNAIPPGType
PhnIOTAPhnNAISIPCfgSvr
PhnIOTAPhnNAISIPDatagwyType
PhnIOTAPhnNAISIPDataxchType
PhnIOTAPhnNAISIPEdgeProxyType
PhnIOTAPhnProxyAddrWdpType
PhnIOTAPhnSIPRetryCntType
PhnIOTAPhnSIPRetryTimerType
PhnIOTAPhnTlsRcUrlType
PhnIOTAPhnTrustedDomainType
PhnIOTAReportType
PhnKeyPressedParams
PhnLibLengthInfoType
PhnLineStateType
PhnMiscDbgRptType
PhnMMIEntryType
PhnMMIResultType
PhnMovedMsgDescType
PhnMovedMsgsParamsType
PhnMsgBoxDataType
PhnNetworkTime
PhnOnexMipRRQType
PhnOneXStatus
PhnOperatorListType
PhnOperatorType
PhnPasswordEventType
PhnPDDataType
PhnPDPList
PhnPDPPayload
PhnPDPWrite
PhnPhoneBookInfoType
PhnPhoneEquipmentMode
PhnPowerEventType
PhnProgressEventType
PhnRadioStateType
PhnRegistrationType
PhnRingingInfoType
PhnRingingProfileType
PhnRoamPrefInfoType
PhnSATEventDataSvc
PhnSATEventDisplayText
PhnSATEventGetInkey
PhnSATEventGetInput
PhnSATEventHeader
PhnSATEventIdleModeText
PhnSATEventLaunchBrowser
PhnSATEventMenu
PhnSATEventMenuRec
PhnSATEventPlayTone
PhnSATEventRefresh
PhnSATEventRunAT
PhnSATEventSendDTMF
PhnSATEventSendSMS
PhnSATEventSetupCall
PhnSATEventType
PhnSMSParams
PhnSMSPrefType
PhnSubscriberAddrInfo
PhnUSSDEventType
PhoneAppLaunchCmdCallerIDLookupType
PhoneAppLaunchCmdDialType
PhoneAppLaunchCmdGetALSLineNumberType
PhoneAppLaunchCmdGetDialPrefFlagType
PhoneAppLaunchCmdSendDTMFToneType
PhoneAppLaunchCmdSetWallpaperType
PmBroadcastNewMsgCountNotifyParamType
PmConnectorNotifyDataType
PmGetNewMsgCountNotifyParamType
PmSysGadgetBbutMappingType
PmSysGadgetBbutResourceType
PmSysGadgetPttNotificationType
PosType
PowerPanelAppPrefs
S
SmsHeader
SMSSendOptions
SndCodecCustomControlType
SoundPreference
SoundPreference::_tonePrefs
SoundPreferenceCalendar
SoundPreferenceEmail
SoundPreferenceIM
SoundPreferenceMMS
SoundPreferenceNetworkSounds
SoundPreferencePhone
SoundPreferenceSMS
SoundPrefsLaunchCmdParamType
SysVPPILaunchCmdClearPWCacheType
SysVPPILaunchCmdDeleteAccountType
SysVPPILaunchCmdEditAccountType
SysVPPILaunchCmdErrorDialogType
SysVPPILaunchCmdGetAccountsType
SysVPPILaunchCmdProgressPaintType
SysVPPILaunchCmdPromptAndConfigureType
SysVPPILaunchCmdSetCurrentAccountType
SysVPPILaunchCmdWillPWPromptType
SysWPPILaunchCmdClearPWCache
SysWPPILaunchCmdErrorDialogType
SysWPPILaunchCmdGetAuthenticationMethodsType
SysWPPILaunchCmdGetDescriptionType
SysWPPILaunchCmdPromptAndConfigureType
SysWPPILaunchCmdType
T
tagIOTANotificationEventType
tagSndFileStreamData
tagSndFileStreamFileSpec
tagSndFileStreamHsSoundCommandParam
ToneIdentifier
ToneItemType
U
UPNotificationEventType
V
VMFontType
VMFontUIRules
VPNAccountType
vpnNotifyVPNLibTag
W
WAPNotificationEventType
webBrowserMinimalModeLaunchInfo
webBrowserURLWithSvcIDLaunchInfo
WiFiAuthenticationMethodType
WUNotificationEventType
_
_dataLinks
_HelperServiceMMSDetailsType
_HelperServiceMMSObjectType
_PalmPhotoCaptureParamV2
_PalmPhotoCreateParam
_PalmPhotoDisplayParam
_PalmPhotoExtraInfo
_PalmPhotoFileLocation
_PalmPhotoImageInfo
_PalmPhotoReadWriteParam
_PalmPhotoSelectionParam
_PalmPhotoSelections
_PhnCDMAMediaTVSettings
_PhnLibMMSServerInfo
_pluginExtendedQueryParams
_pluginGetInfoParams
_pluginParams
_pluginQueryParams
_pluginSendParams

A | B | C | D | F | H | L | M | N | P | S | T | U | V | W | _

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:08 2008 for Palm API Guide


Header Files » Incs » common » system

common/system/palmOneChars.h

Go to the documentation of this file.
00001 /******************************************************************************
00002  * Copyright (c) 2005 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  *****************************************************************************/
00005 /**
00006  *@ingroup System
00007  *
00008  */
00009
00010 /**
00011  * @file    palmOneChars.h
00012  * @version 1.0
00013  * @date    03/03/2004
00014  *
00015  * @brief Contains palmOne-specific virtual characters.
00016  *
00017  *    Five-way navigation macros and values for key states are included
00018  *    in this file.
00019  *
00020  * <hr>
00021  */
00022
00023
00024 #ifndef __PALMONECHARS_H__
00025 #define __PALMONECHARS_H__
00026
00027 #include <Chars.h>
00028
00029
00030
00031 #if (vchrPalmMin != 0x0500) || (vchrPalmMax != 0x05FF)
00032 #error "please check Palm vchr range or update the above assertion"
00033 #endif
00034
00035 #ifndef vchrHard5
00036 #define vchrHard5               0x0214      /**< To match PalmOS 5.1 definition in Chars.h. */
00037 #endif
00038
00039 #ifndef vchrHard6
00040 #define vchrHard6                   0x0215
00041 #endif
00042
00043 #ifndef keyBitHard5
00044 #define keyBitHard5             0x2000      /**< The keyBit mask used for polling the 5th hard key. */
00045 #endif
00046
00047 /**
00048  * @name
00049  *
00050  */
00051 /*@{*/
00052 #define vchrSilkClock               (vchrPalmMin + 0)   /**< Silk screen clock button virtual character.
00053                                   *< When handled by the system, it will launch the clock pop-up dialog.
00054                                                                   */
00055
00056 #define vchrClock                   (vchrPalmMin + 1)   /**< Clock virtual character.
00057                                   *< When handled by the system, it will launch the clock pop-up dialog.
00058                                                                   */
00059
00060 #define vchrPopupBrightness         (vchrPalmMin + 2)   /**< Pop-up brightness virtual character.
00061                                   *< When handled by the system, it will launch the brightness pop-up dialog.
00062                                                                   */
00063
00064 #define vchrNavChange               (vchrPalmMin + 3)   /**< Five way navigation virtual character.
00065                                   *< This character indicates that the five way navigation states have changed.
00066                                                                   */
00067
00068 #define vchrCameraShutter       (vchrPalmMin + 8)   /**< Camera shutter virtual character.
00069                                   *< Generated by the camera shutter button. Currently only available on Zire71.
00070                                                                   */
00071
00072 #define vchrHardRecord              (vchrHard5) /**< Record button virtual character.
00073                                   *< On Tungsten T, this button is located below the microphone. On Tungsten W
00074                                   *< and Tungsten C, the button is generally placed on the headset.
00075                                                                   */
00076 /*@}*/
00077
00078 /**
00079  * @name The following group of characters are specific for Tungsten W
00080  *
00081  */
00082 /*@{*/
00083 #define vchrDeviceSpecificChar      (vchrPalmMin+20)            /**<        */
00084
00085 #define vchrHard3Down           (vchrDeviceSpecificChar + 0)        /**< Tungsten W virtual character.
00086                                           *< This character indicates that 3rd Hard key is down.  Used to check for press and hold event.
00087                                                                                   */
00088
00089 #define vchrHard4Down           (vchrDeviceSpecificChar + 1)        /**< Tungsten W virtual character.
00090                                           *< This character indicates that 4th Hard key is down.  Used to check for press and hold event.
00091                                                                                   */
00092
00093 #define vchrDeviceIncomingCall      (vchrDeviceSpecificChar + 2)        /**< Tungsten W virtual character.
00094                                           *< This character indicates that there is an incoming call.
00095                                                                                   */
00096
00097 #define vchrTelDevicePowerOn        (vchrDeviceSpecificChar + 3)        /**< Tungsten W virtual character.
00098                                           *< This character indicates that the phone has been powered on
00099                                                                                   */
00100
00101 #define vchrMyFavoriteApplication       (vchrDeviceSpecificChar + 4)            /**< Tungsten W virtual character.
00102                                           *< This character indicates that the Favorite Application button has been pressed.
00103                                           *< The button is UP at this point.
00104                                                                                   */
00105
00106 #define vchrTelDevicePowerFinished  (vchrDeviceSpecificChar + 5)        /**< Tungsten W virtual character.
00107                                           *< This character indicates that the backlight has been toggled.
00108                                                                                   */
00109
00110 #define vchrBacklightToggled            (vchrDeviceSpecificChar + 6)        /**< Tungsten W virtual character.
00111                                           *< This character indicates that the backlight has been toggled.
00112                                                                                   */
00113
00114 #define vchrKeyboardSymbol      (vchrDeviceSpecificChar + 9)        /**< Tungsten W virtual character.
00115                                           *< This character indicates that the space key has been pressed with the function key.
00116                                                                                   */
00117
00118 #define vchrReplaceLastChar     (vchrDeviceSpecificChar + 10)       /**< Tungsten W virtual character.
00119                                           *< This character indicates that a replace last char event has been triggered.
00120                                           *< This occurs when an alpha numeric key is pressed and held.
00121                                                                                   */
00122
00123 #define vchrFunctionFiveWay     (vchrDeviceSpecificChar + 11)       /**< Tungsten W virtual character.
00124                                           *< This character indicates that a 5-way event has been triggered.
00125                                                                                   */
00126
00127 #define vchrEmergencyCall       (vchrDeviceSpecificChar + 12)       /**< Tungsten W virtual character.
00128                                           *< This character indicates that an emergency call is being placed.
00129                                           *< This occurs when the 4 hard keys are all pressed at once.
00130                                                                                   */
00131
00132 #define vchrPowerOnPhone        (vchrDeviceSpecificChar + 14)       /**< Tungsten W virtual character.
00133                                           *< This character indicates that a request to toggle the phone on or off has been made.
00134                                                                                   */
00135 /*@}*/
00136
00137 /**
00138  * From Handspring ARM SDK, System/HsKey.h
00139  * Most of these will be moved into the PalmSource SDK as of R3 and later,
00140  * but we still need to compile on earlier SDKs, so here are guarded definitions.
00141  *
00142  * The following vchrThumbWheel/Rocker values exist to allow all hardware
00143  * that has these (optional) control clusters to emit the same key codes.
00144  **/
00145
00146 #ifndef vchrThumbWheelUp
00147 /**
00148  * @name Character codes for thumb-wheel keys
00149  *
00150  */
00151 /*@{*/
00152 #define vchrThumbWheelUp            0x012E      /**< optional thumb-wheel up */
00153 #define vchrThumbWheelDown          0x012F      /**< optional thumb-wheel down */
00154 #define vchrThumbWheelPush          0x0130      /**< optional thumb-wheel press/center */
00155 #define vchrThumbWheelBack          0x0131      /**< optional thumb-wheel cluster back */
00156 /*@}*/
00157 #endif // ndef vchrThumbWheelUp
00158
00159
00160 #ifndef vchrRockerUp
00161 /**
00162  * @name Character codes for rocker keys
00163  *
00164  */
00165 /*@{*/
00166 #define vchrRockerUp                0x0132      /**< 5-way rocker up */
00167 #define vchrRockerDown              0x0133      /**< 5-way rocker down */
00168 #define vchrRockerLeft              0x0134      /**< 5-way rocker left */
00169 #define vchrRockerRight             0x0135      /**< 5-way rocker right */
00170 #define vchrRockerCenter            0x0136      /**< 5-way rocker center/press */
00171 /*@}*/
00172 #endif // ndef vchrRockerUp
00173
00174 // End from Handspring ARM SDK, System/HsKey.h
00175
00176 #define vchrRockerSelect            vchrRockerCenter
00177
00178 #endif // __PALMONECHARS_H__
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:54 2008 for Palm API Guide


Header Files » Incs » common » system

common/system/palmOneNavigator.h

Go to the documentation of this file.
00001 /******************************************************************************
00002  * Copyright (c) 2005 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  *****************************************************************************/
00005 /**
00006  *@ingroup System
00007  *
00008  */
00009
00010 /**
00011  * @file    palmOneNavigator.h
00012  * @version 1.0
00013  * @date    03/03/2004
00014  *
00015  * @brief Contains 5-way navigator-specific definitions.
00016  *
00017  *    Five-way navigation macros and values for key states are included
00018  *    in this file.
00019  *
00020  * <hr>
00021  */
00022
00023 #ifndef __PALMONENAVIGATOR_H__
00024 #define __PALMONENAVIGATOR_H__
00025
00026 // palmOne includes:
00027 #include <Common/System/palmOneChars.h>
00028
00029 // Handspring includes:
00030 #include <HsNavCommon.h>
00031
00032 /**
00033  * @name
00034  *
00035  */
00036 /*@{*/
00037 #define navFtrCreator               'fway'      /**< Creator ID for 5-Way navigator. */
00038 #define navFtrVersion               0       /**< Feature id for 5-Way. */
00039 #define navVersion                  0x00010000  /**< Version for 5-Way. */
00040 /*@}*/
00041
00042 /**
00043  * @name
00044  *
00045  */
00046 /*@{*/
00047 #define keyBitNavLeft           0x01000000  /**< Key state mask to check the five way navigation LEFT button. */
00048 #define keyBitNavRight          0x02000000  /**< Key state mask to check the five way navigation RIGHT button. */
00049 #define keyBitNavSelect         0x04000000  /**< Key state mask to check the five way navigation SELECT button. */
00050 #define keyBitNavLRS            0x07000000  /**< Key state mask to check the five way navigation LEFT, RIGHT and SELECT buttons. */
00051 /*@}*/
00052
00053 /**
00054  * @name
00055  *
00056  */
00057 /*@{*/
00058 #define navBitUp            0x0001      /**< Key mask for the five way navigation UP button. */
00059 #define navBitDown          0x0002      /**< Key mask for the five way navigation DOWN button. */
00060 #define navBitLeft          0x0004      /**< Key mask for the five way navigation LEFT button. */
00061 #define navBitRight         0x0008      /**< Key mask for the five way navigation RIGHT button. */
00062 #define navBitSelect            0x0010      /**< Key mask for the five way navigation SELECT button. */
00063 #define navBitsAll          0x001F      /**< Key mask for all five way navigation buttons. */
00064 /*@}*/
00065
00066 /**
00067  * @name
00068  *
00069  */
00070 /*@{*/
00071 #define navChangeUp         0x0100      /**< Key mask for the five way navigation UP button state change. */
00072 #define navChangeDown           0x0200      /**< Key mask for the five way navigation DOWN button state change. */
00073 #define navChangeLeft           0x0400      /**< Key mask for the five way navigation LEFT button state change. */
00074 #define navChangeRight          0x0800      /**< Key mask for the five way navigation RIGHT button state change. */
00075 #define navChangeSelect         0x1000      /**< Key mask for the five way navigation SELECT button state change. */
00076 #define navChangeBitsAll        0x1F00      /**< Key mask for all five way navigation buttons state change. */
00077 /*@}*/
00078
00079 /**
00080  * @def IsFiveWayNavPalmEvent(eventP)
00081  *
00082  * A macro to use for apps that support navigation using the Palm style 5-way.
00083  * This macro will let you test whether an event was generated by the 5-way.
00084  * For applications that treat up and down hard buttons differently than up and
00085  * down on the 5-way, this macro can be used to determine which action to take
00086  * if NavKeyPressed returns true for Up or Down.
00087  *
00088  * @remark
00089  * Our 5-way events generate lots of detail about what state changed and what
00090  * didn't. Events are generated even when a button is released, which is a
00091  * nice bonus. So, to figure out what happened, you have to look at the bits
00092  * in the keyCode. Because we only use 10 of the bits in the keyCode, and
00093  * because we may use the remaining bits at some later date, we
00094  * mask out these 10 bits before doing the test.
00095  *
00096  *  ((eventP)->data.keyDown.keyCode & (navBitsAll | navChangeBitsAll)) != 0
00097  * will be true if any of the 5 buttons is held down, pressed, or released.
00098  *
00099  *  ((eventP)->data.keyDown.keyCode & navChangeBitsAll) != 0
00100  * will be true if any of the 5 buttons is pressed or released.
00101  *
00102  * The situation where these would differ is holding down one or more of the
00103  * 5 buttons until it generates a repeat event. In that case, none of the
00104  * navChangeBits will be set.
00105  *
00106  * Unfortunately, on the Treo 600, the vchrPageUp/Down is accompanied
00107  * by a keyCode that has some nav bits set.  Thus, we will not be able to
00108  * distinguish the HandSpring nav event from the Palm nav event here in such
00109  * cases, and this macro will return true.  Then, when using NavDirectionPressed,
00110  * via NavKeyPressed e.g., the nav direction palm and HS macros will return
00111  * false, as this case matches neither, and the vchrPageUp/Down will incorrectly
00112  * be returned as not a 5-way nav event for our purposes of supporting non-5-way
00113  * devices.
00114  * That can be avoided by ensuring the focus state on HandSpring devices is
00115  * set to object mode for the given form, thus ensuring vchrRockerUp/Down chrs are
00116  * sent instead of vcrhPageUp/Down chrs, while also ensuring this continues
00117  * to work as expected on palmOne devices.
00118  *
00119  * @sample
00120  * @code if (IsFiveWayNavPalmEvent(eventP)) {
00121  *      // Handle five way events here
00122  * } @endcode
00123  */
00124 #define IsFiveWayNavPalmEvent(eventP)                                                       \
00125 (                                                                                           \
00126     (   ((eventP)->data.keyDown.chr == vchrPageUp)                                          \
00127      || ((eventP)->data.keyDown.chr == vchrPageDown)                                        \
00128      || ((eventP)->data.keyDown.chr == vchrNavChange) )                                     \
00129 &&  (((eventP)->data.keyDown.keyCode & (navBitsAll | navChangeBitsAll)) != 0)               \
00130 )
00131
00132 /*
00133 #define IsFiveWayNavPalmEvent(eventP)                                                       \
00134 (   ((eventP)->data.keyDown.chr == vchrNavChange)                                           \
00135 ||                                                                                          \
00136     (   (   ((eventP)->data.keyDown.chr == vchrPageUp)                                      \
00137          || ((eventP)->data.keyDown.chr == vchrPageDown) )                                  \
00138      && (   (((eventP)->data.keyDown.keyCode & navChangeBitsAll) != 0)                      \
00139          || (((eventP)->data.keyDown.modifiers & autoRepeatKeyMask) != 0)))                 \
00140 )
00141 */
00142
00143 /*
00144 #define IsFiveWayNavPalmEvent(eventP)                                                       \
00145 (   ((eventP)->data.keyDown.chr == vchrNavChange)                                           \
00146 ||  (   ((eventP)->data.keyDown.chr == vchrPageUp)                                          \
00147      && (((eventP)->data.keyDown.keyCode & (navBitUp | navChangeUp)) != 0) )                \
00148 ||  (   ((eventP)->data.keyDown.chr == vchrPageDown)                                        \
00149      && (((eventP)->data.keyDown.keyCode & (navBitDown | navChangeDown)) != 0) )            \
00150 )
00151 */
00152
00153 /**
00154  * @def IsFiveWayNavEvent(eventP)
00155  *
00156  * A macro to use for apps that support navigation using the 5-way.
00157  * This macro will let you test whether an event was generated by the 5-way.
00158  * For applications that treat up and down hard buttons differently than up and
00159  * down on the 5-way, this macro can be used to determine which action to take
00160  * if NavKeyPressed returns true for Up or Down.
00161  *
00162  * @sample
00163  * @code if (IsFiveWayNavEvent(eventP)) {
00164  *      // Handle five way events here
00165  * } @endcode
00166  */
00167 #define IsFiveWayNavEvent(eventP)                                                           \
00168 (                                                                                           \
00169     IsFiveWayNavPalmEvent(eventP)                                                           \
00170 ||  TxtCharIsRockerKey((eventP)->data.keyDown.modifiers, (eventP)->data.keyDown.chr)        \
00171 )
00172
00173
00174 /**
00175  * A macro to use for apps that support navigation using the HandSpring 5-way.
00176  * By using this macro, we have consistent behavior in all our apps
00177  * when it comes to how it handles multiple simultaneous button presses.
00178  *
00179  * @remark
00180  * Checks if it the key down event is of the HandSpring "select" key type.
00181  *
00182  * @sample
00183  * @code if (NavSelectHSPressed(eventP)) {
00184  *      // Select was pressed
00185  * } @endcode
00186  *
00187  */
00188 #define NavSelectHSPressed(eventP)                                                      \
00189 (                                                                                       \
00190        (((eventP)->data.keyDown.modifiers & commandKeyMask) != 0)                       \
00191     && ((eventP)->data.keyDown.chr == vchrRockerCenter)                                 \
00192 )
00193
00194
00195 /**
00196  * A macro to use for apps that support navigation using the Palm 5-way.
00197  * By using this macro, we have consistent behavior in all our apps
00198  * when it comes to how it handles multiple simultaneous button presses.
00199  *
00200  * @remark
00201  * Checks if it the key down event is of the Palm "select" key type.
00202  * Note the redundant check of the keyDown.chr.  This is necessary to
00203  * prevent a false positive, because the modified DAL code for the
00204  * new 5-way still generates the same keyCodes (it was easier that way),
00205  * but doesn't generate the same keyDown.chr (new vchrRocker instead).
00206  * This redundancy avoids a double-press behavior.
00207  *
00208  * @sample
00209  * @code if (NavSelectPalmPressed(eventP)) {
00210  *      // Select was pressed
00211  * } @endcode
00212  *
00213  */
00214 #define NavSelectPalmPressed(eventP)                                                    \
00215 (                                                                                       \
00216        (((eventP)->data.keyDown.modifiers & autoRepeatKeyMask) == 0)                    \
00217     && ((eventP)->data.keyDown.chr == vchrNavChange)                                    \
00218     && (((eventP)->data.keyDown.keyCode & (navBitsAll | navChangeBitsAll)) ==           \
00219                                                                      navChangeSelect)   \
00220 )
00221
00222
00223 /**
00224  * A macro to use for apps that support navigation using the 5-way.
00225  * By using this macro, we have consistent behavior in all our apps
00226  * when it comes to how it handles multiple simultaneous button presses.
00227  *
00228  * @remark
00229  * Only act when the select button is released, and only if none of the
00230  * direction buttons are down (or being released) at the time, and only if the select
00231  * button has not been held down long enough to start repeating. By ignoring repeat
00232  * events for the select button, we ensure that the launcher will be run if the select
00233  * button is held down. By waiting until the button is released, we ensure that the
00234  * select action is not taken before the launcher is run.
00235  *
00236  * @sample
00237  * @code if (NavSelectPressed(eventP)) {
00238  *      // Select was pressed
00239  * } @endcode
00240  *
00241  */
00242 #define NavSelectPressed(eventP)                                                        \
00243 (                                                                                       \
00244     IsFiveWayNavEvent(eventP)                                                           \
00245 &&  (   NavSelectPalmPressed(eventP)                                                    \
00246      || NavSelectHSPressed(eventP))                                                     \
00247 )
00248
00249
00250 /**
00251  * A macro to use for apps that support navigation using the HandSpring 5-way.
00252  * By using this macro, we have consistent behavior in all our apps
00253  * when it comes to how it handles multiple simultaneous button presses.
00254  * You can use this macro even if the device does not have a 5-way controller.
00255  *
00256  * @remark
00257  * Determine if the key down event indicates the HandSpring nav direction type.
00258  *
00259  * @sample
00260  * @code
00261  * if (NavDirectionHSPressed(eventP, Left))
00262  * if (NavDirectionHSPressed(eventP, Right))
00263  * if (NavDirectionHSPressed(eventP, Up))       - also works without 5-way
00264  * if (NavDirectionHSPressed(eventP, Down))     - also works without 5-way @endcode
00265  *
00266  */
00267 #define NavDirectionHSPressed(eventP, nav)                                              \
00268 (                                                                                       \
00269         ((vchrRocker ## nav) != vchrRockerCenter)                                       \
00270      && (   (   (((eventP)->data.keyDown.modifiers & commandKeyMask) != 0)              \
00271              && ((eventP)->data.keyDown.chr == (vchrRocker ## nav))))                   \
00272 )
00273
00274
00275 /**
00276  * A macro to use for apps that support navigation using the Palm 5-way.
00277  * By using this macro, we have consistent behavior in all our apps
00278  * when it comes to how it handles multiple simultaneous button presses.
00279  * You can use this macro even if the device does not have a 5-way controller.
00280  *
00281  * @remark
00282  * Determine if the key down event indicates the palmOne nav direction type.
00283  *
00284  * @sample
00285  * @code
00286  * if (NavDirectionPalmPressed(eventP, Left))
00287  * if (NavDirectionPalmPressed(eventP, Right))
00288  * if (NavDirectionPalmPressed(eventP, Up))     - also works without 5-way
00289  * if (NavDirectionPalmPressed(eventP, Down))   - also works without 5-way @endcode
00290  *
00291  */
00292 #define NavDirectionPalmPressed(eventP, nav)                                            \
00293 (                                                                                       \
00294     ((eventP)->data.keyDown.modifiers & autoRepeatKeyMask)                              \
00295         ? (((eventP)->data.keyDown.keyCode & (navBitsAll | navChangeBitsAll)) ==        \
00296             (navBit ## nav))                                                            \
00297         : (((eventP)->data.keyDown.keyCode & (navBitsAll | navChangeBitsAll)) ==        \
00298             (navBit ## nav | navChange ## nav))                                         \
00299 )
00300
00301
00302 /**
00303  * A macro to use for apps that support navigation using the 5-way.
00304  * By using this macro, we have consistent behavior in all our apps
00305  * when it comes to how it handles multiple simultaneous button presses.
00306  * You can use this macro even if the device does not have a 5-way controller.
00307  *
00308  * @remark
00309  * Act only when one direction is pressed without any other direction (or select) being
00310  * down at the time. Repeat if the button is held down, but not if other buttons are
00311  * pressed.
00312  *
00313  * @sample
00314  * @code
00315  * if (NavDirectionPressed(eventP, Left))
00316  * if (NavDirectionPressed(eventP, Right))
00317  * if (NavDirectionPressed(eventP, Up))     - also works without 5-way
00318  * if (NavDirectionPressed(eventP, Down))   - also works without 5-way @endcode
00319  *
00320  */
00321 #define NavDirectionPressed(eventP, nav)                                                \
00322 (                                                                                       \
00323     IsFiveWayNavEvent(eventP)                                                           \
00324         ? (   NavDirectionPalmPressed(eventP, nav)                                      \
00325            || NavDirectionHSPressed(eventP, nav))                                       \
00326         : (   ((eventP)->data.keyDown.chr == vchrPageUp && (navBit ## nav) == navBitUp)      \
00327            || ((eventP)->data.keyDown.chr == vchrPageDown && (navBit ## nav) == navBitDown)) \
00328 )
00329
00330
00331 /**
00332  * A macro to use for apps that support navigation using the 5-way.
00333  * By using this macro, we have consistent behavior in all our apps
00334  * when it comes to how it handles multiple simultaneous button presses.
00335  * You can use this macro even if the device does not have a 5-way controller.
00336  *
00337  * @sample
00338  * @code
00339  * if (NavKeyPressed(eventP, Select))
00340  * if (NavKeyPressed(eventP, Left))
00341  * if (NavKeyPressed(eventP, Right))
00342  * if (NavKeyPressed(eventP, Up))       - also works without 5-way
00343  * if (NavKeyPressed(eventP, Down))     - also works without 5-way @endcode
00344  */
00345 #define NavKeyPressed(eventP, nav)                                                      \
00346 (                                                                                       \
00347     (navBit ## nav == navBitSelect)                                                     \
00348         ? NavSelectPressed(eventP)                                                      \
00349         : NavDirectionPressed(eventP, nav)                                              \
00350 )
00351
00352 #endif // __PALMONENAVIGATOR_H__
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:54 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » address » 2.0 » pub

Contacts.h

Go to the documentation of this file.
00001 /*
00002  * Contacts.h
00003  *
00004  * public header for shared library
00005  *
00006  * Copyright (c) 2005 palmOne, Inc. or its subsidiaries.
00007  * All rights reserved.
00008  */
00009  /******************************************************************************
00010  *
00011  * Copyright (c) 2005 Palm, Inc. or its subsidiaries.
00012  * All rights reserved.
00013  *
00014  * File: Contacts.h
00015  *
00016  * Release: TBD
00017  *
00018  * Description:
00019  *      This header file contains the public routines used to add/update
00020  *      contacts and manage the data contained in the database for
00021  *      the built-in Contacts application.
00022  *
00023  * History:
00024  *      December 23, 2004   Created by Scott Silverman
00025  *
00026  *          Name        Date            Description
00027  *          ----        ----            -----------
00028  *          SDS         5/31/05         Creation.
00029  *
00030  *****************************************************************************/
00031
00032 #ifndef CONTACTS_H_
00033 #define CONTACTS_H_
00034
00035 /* Palm OS common definitions */
00036 #include <SystemMgr.h>
00037
00038 #define CONTACTS_LIB_TRAP   SYS_TRAP
00039
00040 /*********************************************************************
00041  * Type and creator of Sample Library database
00042  *********************************************************************/
00043 #define     ContactsLibCreatorID        'P1CT'
00044 #define     ContactsLibTypeID           sysFileTLibrary
00045
00046 /*********************************************************************
00047  * Internal library name which can be passed to SysLibFind()
00048  *********************************************************************/
00049 #define     ContactsLibName             "ContactsLib-P1CT"
00050
00051 /*********************************************************************
00052  * ContactsLog result codes
00053  *********************************************************************/
00054 #define ContactsLibErrorClass                   (appErrorClass | 0x7300)
00055 #define ContactsLibErrTooManyClients            (ContactsLibErrorClass | 1) // No More client can open the lib
00056 #define ContactsLibErrInvalidHandle             (ContactsLibErrorClass | 2)
00057 #define ContactsLibErrInvalidParam              (ContactsLibErrorClass | 3)
00058 #define ContactsLibErrUIdNotFound               (ContactsLibErrorClass | 4)
00059 #define ContactsLibErrCategoryNotFound          (ContactsLibErrorClass | 5)
00060 #define ContactsLibErrLibAlreadyInUse           (ContactsLibErrorClass | 6)
00061 #define ContactsLibErrVerNotSupported           (ContactsLibErrorClass | 7)
00062 #define ContactsLibErrOutOfMemory               (ContactsLibErrorClass | 8)
00063 #define ContactsLibErrSizeParamOverFlow         (ContactsLibErrorClass | 9)
00064 #define ContactsLibErrEmptyContact              (ContactsLibErrorClass | 10)
00065 #define ContactsLibErrInvalidReference          (ContactsLibErrorClass | 11)
00066 #define ContactsLibErrContactNotFound           (ContactsLibErrorClass | 12)
00067 #define ContactsLibErrAttachAlreadyExist        (ContactsLibErrorClass | 13)    // Attachment cannot be added it already exist in the record.
00068 #define ContactsLibErrAttachNotExist            (ContactsLibErrorClass | 14)
00069 #define ContactsLibErrAttachOverFlow            (ContactsLibErrorClass | 15)
00070 #define ContactsLibErrRecordNotFound            (ContactsLibErrorClass | 16)
00071 #define ContactsLibErrAttachOverflow            (ContactsLibErrorClass | 17)
00072 #define ContactsLibErrInvalidField              (ContactsLibErrorClass | 18)
00073 #define ContactsLibErrTooManySession            (ContactsLibErrorClass | 19)
00074 #define ContactsLibErrAlreadyInWriteMode        (ContactsLibErrorClass | 20)    // User have requested to create Session in ReadWriteMode but it is already open.
00075 #define ContactsLibErrInvalidSessionHandle      (ContactsLibErrorClass | 21)
00076 #define ContactsLibErrFieldNotFound             (ContactsLibErrorClass | 23)
00077 #define ContactsLibErrStringNotFound            (ContactsLibErrorClass | 24)
00078 #define ContactsLibErrInvalidAppInfoBlock       (ContactsLibErrorClass | 25)
00079 #define ContactsLibErrAppInfoIsMising           (ContactsLibErrorClass | 26)
00080 #define ContactsLibErrReadOnlySession           (ContactsLibErrorClass | 27)
00081 #define ContactsLibErrUIdExist                  (ContactsLibErrorClass | 28)
00082 #define ContactsLibErrMaxLimitReached           (ContactsLibErrorClass | 29)
00083 #define ContactsLibErrListNotExist              (ContactsLibErrorClass | 30)
00084 #define ContactsLibErrContactNotLocked          (ContactsLibErrorClass | 31)
00085 #define ContactsLibErrLibStillOpen              (ContactsLibErrorClass | 32)
00086
00087
00088 #define PALM_OS
00089 #ifdef PALM_OS
00090     typedef MemHandle                       ContactsContHandle;
00091     typedef MemHandle                       ContactsSession;
00092
00093     #define ContactsNumCategories           dmRecNumCategories
00094     #define ContactsAllCategories           dmAllCategories
00095     #define ContactsUnfiledCategory         dmUnfiledCategory
00096     #define ContactsSeekForward             dmSeekForward
00097     #define ContactsSeekBackward            dmSeekBackward
00098
00099     typedef DateType                        ContactsDateType;
00100 #endif
00101
00102 #define ContactsLabelLength             16
00103 typedef char                            ContactsLabel[ContactsLabelLength];
00104
00105 /* Contact Field Labels */
00106 typedef enum
00107 {
00108     contactsNoType,
00109     contactsWorkPhone,      // applicable to Phone1-7 fields
00110     contactsHomePhone,      // applicable to Phone1-7 fields
00111     contactsFaxPhone,       // applicable to Phone1-7 fields
00112     contactsOtherPhone,     // applicable to Phone1-7 fields
00113     contactsEmailPhone,     // applicable to Phone1-7 fields
00114     contactsMainPhone,      // applicable to Phone1-7 fields
00115     contactsPagerPhone,     // applicable to Phone1-7 fields
00116     contactsMobilePhone,    // applicable to Phone1-7 fields
00117     contactsOtherChat,      // applicable to Chat1 & Chat2 fields
00118     contactsAimChat,        // applicable to Chat1 & Chat2 fields
00119     contactsMsnChat,        // applicable to Chat1 & Chat2 fields
00120     contactsYahooChat,      // applicable to Chat1 & Chat2 fields
00121     contactsIcqChat,        // applicable to Chat1 & Chat2 fields
00122     contactsWorkAddress,    // applicable to Address1-3 fields
00123     contactsHomeAddress,    // applicable to Address1-3 fields
00124     contactsOtherAddress    // applicable to Address1-3 fields
00125 }   ContactsLibFieldLabels;
00126
00127 /* Contacts record fields */
00128 typedef enum
00129 {
00130     contactsLastName,
00131     contactsFirstName,
00132     contactsCompany,
00133     contactsTitle,
00134
00135     contactsPhone1,
00136     contactsPhone2,
00137     contactsPhone3,
00138     contactsPhone4,
00139     contactsPhone5,
00140     contactsPhone6,
00141     contactsPhone7,
00142
00143     contactsChat1,
00144     contactsChat2,
00145
00146     contactsWebpage,
00147
00148     contactsCustom1,
00149     contactsCustom2,
00150     contactsCustom3,
00151     contactsCustom4,
00152     contactsCustom5,
00153     contactsCustom6,
00154     contactsCustom7,
00155     contactsCustom8,
00156     contactsCustom9,
00157
00158     contactsAddress1,
00159     contactsCity1,
00160     contactsState1,
00161     contactsZipCode1,
00162     contactsCountry1,
00163     contactsAddress2,
00164     contactsCity2,
00165     contactsState2,
00166     contactsZipCode2,
00167     contactsCountry2,
00168     contactsAddress3,
00169     contactsCity3,
00170     contactsState3,
00171     contactsZipCode3,
00172     contactsCountry3,
00173
00174     contactsNote,
00175
00176     contactsBirthdate,
00177     contactsBirthdayMask,
00178     contactsBirthdayPreset,
00179     contactsPicture,
00180     contactsUniqueID        = contactsPicture + 2,
00181     contactsIndex,
00182     contactsCategoryID,
00183     contactsPrivate         = contactsCategoryID + 2,
00184     contactsBusy,
00185     contactsDirty,
00186     contactsRingtoneInfo    = contactsDirty + 4,
00187     contactsAnniversaryDate,
00188     contactsAnniversaryMask,
00189     contactsAnniversaryPreset,
00190     contactsNumFields
00191 } ContactsLibAllFields;
00192
00193 typedef enum
00194 {
00195     contactsStrLastName,
00196     contactsStrFirstName,
00197     contactsStrCompany,
00198     contactsStrTitle,
00199
00200     contactsStrPhone1,          // phone fields, all can accept a label
00201     contactsStrPhone2,
00202     contactsStrPhone3,
00203     contactsStrPhone4,
00204     contactsStrPhone5,
00205     contactsStrPhone6,
00206     contactsStrPhone7,
00207
00208     contactsStrChat1,           // instant message id and service, both can accept a label
00209     contactsStrChat2,
00210
00211     contactsStrWebpage,
00212
00213     contactsStrCustom1,         // custom fields
00214     contactsStrCustom2,
00215     contactsStrCustom3,
00216     contactsStrCustom4,
00217     contactsStrCustom5,
00218     contactsStrCustom6,
00219     contactsStrCustom7,
00220     contactsStrCustom8,
00221     contactsStrCustom9,
00222
00223     contactsStrAddress1,        // first set of address fields, Address1 can accept a label
00224     contactsStrCity1,
00225     contactsStrState1,
00226     contactsStrZipCode1,
00227     contactsStrCountry1,
00228     contactsStrAddress2,        // second set of address fields, Address2 can accept a label
00229     contactsStrCity2,
00230     contactsStrState2,
00231     contactsStrZipCode2,
00232     contactsStrCountry2,
00233     contactsStrAddress3,        // third set of address fields, Address3 can accept a label
00234     contactsStrCity3,
00235     contactsStrState3,
00236     contactsStrZipCode3,
00237     contactsStrCountry3,
00238
00239     contactsStrNote             // This field is assumed to be < 32K
00240 } ContactsLibStrFields;
00241
00242 typedef enum
00243 {
00244     contactsCustomCustom1   = contactsCustom1,
00245     contactsCustomCustom2,
00246     contactsCustomCustom3,
00247     contactsCustomCustom4,
00248     contactsCustomCustom5,
00249     contactsCustomCustom6,
00250     contactsCustomCustom7,
00251     contactsCustomCustom8,
00252     contactsCustomCustom9
00253 } ContactsLibCustomFields;
00254
00255 typedef enum
00256 {
00257     contactsWithLabelPhone1         = contactsPhone1,
00258     contactsWithLabelPhone2,
00259     contactsWithLabelPhone3,
00260     contactsWithLabelPhone4,
00261     contactsWithLabelPhone5,
00262     contactsWithLabelPhone6,
00263     contactsWithLabelPhone7,
00264     contactsWithLabelChat1,
00265     contactsWithLabelChat2,
00266     contactsWithLabelAddress1       = contactsAddress1,
00267     contactsWithLabelAddress2       = contactsAddress2,
00268     contactsWithLabelAddress3       = contactsAddress3
00269 } ContactsLibWithLabelFields;
00270
00271 typedef enum ContactsLabelTypes
00272 {
00273     ContactsChatLabel,
00274     ContactsAddressLabel,
00275     ContactsPhoneLabel
00276 } ContactsLabelType;
00277
00278 typedef enum
00279 {
00280     contactsDateBirthdate               = contactsBirthdate,
00281     contactsDateAnniversary             = contactsAnniversaryDate
00282 } ContactsLibDateFields;
00283
00284 typedef enum
00285 {
00286     contactsUInt16Index                 = contactsIndex,
00287     contactsUInt16Category              = contactsCategoryID
00288 } ContactsLibUInt16Fields;
00289
00290 typedef enum
00291 {
00292     contactsUInt32UniqueID              = contactsUniqueID
00293 } ContactsLibUInt32Fields;
00294
00295 typedef enum
00296 {
00297     contactsUInt8Private                = contactsPrivate,
00298     contactsUInt8Busy,
00299     contactsUInt8Dirty,
00300     contactsUInt8BirthdayMask           = contactsBirthdayMask,
00301     contactsUInt8BirthdayPreset,
00302     contactsUInt8AnniversaryMask        = contactsAnniversaryMask,
00303     contactsUInt8AnniversaryPreset
00304 } ContactsLibUInt8Fields;
00305
00306 typedef enum
00307 {
00308     contactsBinaryPictureData           = contactsPicture,
00309     contactsBinaryRingtoneIdentifier    = contactsRingtoneInfo
00310 } ContactsLibBinaryFields;
00311
00312 typedef enum
00313 {
00314     ContactsLibSessionModeReadOnly  = 0x0001,
00315     ContactsLibSessionModeReadWrite = 0x0003
00316 } SessionMode;
00317
00318
00319 #define ContactsLibTrapGetVersion                   (sysLibTrapCustom)
00320
00321 #define ContactsLibTrapOpenSession                  (sysLibTrapCustom + 23)
00322 #define ContactsLibTrapCloseSession                 (sysLibTrapCustom + 24)
00323
00324 #define ContactsLibTrapCreateHandle                 (sysLibTrapCustom + 90)
00325 #define ContactsLibTrapReleaseHandle                (sysLibTrapCustom + 4)
00326
00327 #define ContactsLibTrapAddContact                   (sysLibTrapCustom + 8)
00328 #define ContactsLibTrapUpdateContact                (sysLibTrapCustom + 7)
00329 #define ContactsLibTrapDeleteContact                (sysLibTrapCustom + 9)
00330
00331 #define ContactsLibTrapGetContact                   (sysLibTrapCustom + 12)
00332 #define ContactsLibTrapGetNumOfRecord               (sysLibTrapCustom + 28)
00333 #define ContactsLibTrapSeekRecord                   (sysLibTrapCustom + 35)
00334 #define ContactsLibTrapGetFirstContact              (sysLibTrapCustom + 10)
00335 #define ContactsLibTrapGetNextContact               (sysLibTrapCustom + 11)
00336
00337
00338 #define ContactsLibTrapDoesFieldExist               (sysLibTrapCustom + 36)
00339 #define ContactsLibTrapIsEmptyContact               (sysLibTrapCustom + 30)
00340
00341 #define ContactsLibTrapSetUInt8Field                (sysLibTrapCustom + 51)
00342 #define ContactsLibTrapSetUInt16Field               (sysLibTrapCustom + 53)
00343 #define ContactsLibTrapSetDateField                 (sysLibTrapCustom + 55)
00344 #define ContactsLibTrapSetStringField               (sysLibTrapCustom + 57)
00345 #define ContactsLibTrapSetBinaryField               (sysLibTrapCustom + 59)
00346
00347
00348 #define ContactsLibTrapGetUInt8Field                (sysLibTrapCustom + 50)
00349 #define ContactsLibTrapGetUInt16Field               (sysLibTrapCustom + 52)
00350 #define ContactsLibTrapGetUInt32Field               (sysLibTrapCustom + 63)
00351 #define ContactsLibTrapGetDateField                 (sysLibTrapCustom + 54)
00352 #define ContactsLibTrapGetStringField               (sysLibTrapCustom + 56)
00353 #define ContactsLibTrapGetBinaryField               (sysLibTrapCustom + 58)
00354
00355 #define ContactsLibTrapGetFieldLabel                (sysLibTrapCustom + 31)
00356 #define ContactsLibTrapSetFieldLabel                (sysLibTrapCustom + 32)
00357 #define ContactsLibTrapGetLabelText                 (sysLibTrapCustom + 82)
00358
00359 #define ContactsLibTrapRenameCustomLabel            (sysLibTrapCustom + 33)
00360
00361 #define ContactsLibTrapGetCategoryList              (sysLibTrapCustom + 2)
00362 #define ContactsLibTrapGetNextCategory              (sysLibTrapCustom + 37)
00363 #define ContactsLibTrapGetCategoryName              (sysLibTrapCustom + 27)
00364 #define ContactsLibTrapSetCategoryName              (sysLibTrapCustom + 38)
00365 #define ContactsLibTrapCategoryFind                 (sysLibTrapCustom + 39)
00366 #define ContactsLibTrapPosInCategory                (sysLibTrapCustom + 48)
00367
00368 #define ContactsLibTrapGetRingtoneForCategory       (sysLibTrapCustom + 91)
00369
00370 #define ContactsLibTrapLookUpString                 (sysLibTrapCustom + 40)
00371
00372 #define ContactsLibGetLastErr                       (sysLibTrapCustom + 64)
00373
00374 /*
00375  * FUNCTION: ContactsLib_OpenLibrary
00376  *
00377  * DESCRIPTION:
00378  *
00379  * User-level call to open the library.  This inline function
00380  * handles the messy task of finding or loading the library
00381  * and calling its open function, including handling cleanup
00382  * if the library could not be opened.
00383  *
00384  * PARAMETERS:
00385  *
00386  * refNumP
00387  *      Pointer to UInt16 variable that will hold the new
00388  *      library reference number for use in later calls
00389  *
00390  * CALLED BY: System
00391  *
00392  * RETURNS:
00393  *      errNone
00394  *      memErrNotEnoughSpace
00395  *      sysErrLibNotFound
00396  *      sysErrNoFreeRAM
00397  *      sysErrNoFreeLibSlots
00398  *
00399  */
00400 __inline Err ContactsLib_OpenLibrary(UInt16 *refNumP)
00401 {
00402     Err error;
00403     Boolean loaded = false;
00404
00405     /* first try to find the library */
00406     error = SysLibFind(ContactsLibName, refNumP);
00407
00408     /* If not found, load the library instead */
00409     if (error == sysErrLibNotFound)
00410     {
00411         error = SysLibLoad(ContactsLibTypeID, ContactsLibCreatorID, refNumP);
00412         loaded = true;
00413     }
00414
00415     if (error == errNone)
00416     {
00417         error = ContactsLibOpen(*refNumP);
00418         if (error != errNone)
00419         {
00420             if (loaded)
00421             {
00422                 SysLibRemove(*refNumP);
00423             }
00424
00425             *refNumP = sysInvalidRefNum;
00426         }
00427     }
00428
00429     return error;
00430 }
00431
00432 /*
00433  * FUNCTION: ContactsLib_CloseLibrary
00434  *
00435  * DESCRIPTION:
00436  *
00437  * User-level call to closes the shared library.  This handles removal
00438  * of the library from system if there are no users remaining.
00439  *
00440  * PARAMETERS:
00441  *
00442  * refNum
00443  *      Pointer Library reference number obtained from ContactsLib_OpenLibrary().
00444  *      Upon successful close, contents will be invalidated.
00445  *
00446  * CALLED BY: Whoever wants to close the library
00447  *
00448  * RETURNS:
00449  *      errNone
00450  *      sysErrParamErr
00451  */
00452 __inline Err ContactsLib_CloseLibrary(UInt16 *refNumP)
00453 {
00454     Err error;
00455
00456     if (*refNumP == sysInvalidRefNum)
00457     {
00458         return sysErrParamErr;
00459     }
00460
00461     error = ContactsLibClose(*refNumP);
00462
00463     if (error == errNone)
00464     {
00465         /* no users left, so unload library */
00466         SysLibRemove(*refNumP);
00467
00468         *refNumP = sysInvalidRefNum;    // invalidate so caller cannot use any longer.
00469     }
00470     else if (error == ContactsLibErrLibStillOpen)
00471     {
00472         /* don't unload library, but mask "still open" from caller  */
00473         error = errNone;
00474     }
00475
00476     return error;
00477 }
00478
00479
00480 #endif /* CONTACTSLIB_H_ */
00481
00482
00483 /*********************************************************************
00484  * API Prototypes
00485  *********************************************************************/
00486
00487 #ifdef __cplusplus
00488 extern "C" {
00489 #endif
00490
00491
00492 /*
00493  * FUNCTION: ContactsLibGetVersion
00494  *
00495  * DESCRIPTION:
00496  *
00497  * Returns the version number of the Contacts Library
00498  *
00499  * PARAMETERS:
00500  *
00501  * libRefnum
00502  *      Library reference number obtained from ContactsLib_OpenLibrary().
00503  *
00504  * RETURNS:
00505  *      Version number in the form where only the two low bytes are used.
00506  *      Of those two bytes, the high byte is the major version and
00507  *      the low byte is the minor version
00508  *      (i.e. the value 0x00000201 represents version 2.01).
00509  */
00510 extern  UInt32      ContactsGetVersion(UInt16 libRefnum)    CONTACTS_LIB_TRAP(ContactsLibTrapGetVersion);
00511
00512 /*
00513  * FUNCTION: ContactsOpenSession
00514  *
00515  * DESCRIPTION:
00516  *
00517  * Returns the session handle to be passed to other Contacts Lib routines
00518  * One can either specify a new session to be read only or read/write.
00519  *
00520  * PARAMETERS:
00521  *
00522  * libRefnum
00523  *      Library reference number obtained from ContactsLib_OpenLibrary().
00524  *
00525  * mode
00526  *      This is the mode in which you want to open a session.  Must be one of the
00527  *      valid SessionMode types.
00528  *
00529  * RETURNS:
00530  *      a ContactsSession
00531  *      NULL (unsuccessful)
00532  *
00533  * USAGE:
00534  *      Typical usage is to always first open a session and retain the session handle returned.
00535  *      Then subsequent routines to add a new contact for instance will use the internal data
00536  *      stored in the session handle to access the underlying contacts database.
00537  * NOTES:
00538  *      It is important to always close the session with a call to CloseSession
00539  *      after you are finished with the session.  Doing so will free system memory used internally
00540  *      by the library and also free a spot for other users to open sessions.
00541  *      With this version of the library, there is a limit of 4 open sessions.
00542  */
00543 extern  ContactsSession     ContactsOpenSession(UInt16 libRefnum, SessionMode mode) CONTACTS_LIB_TRAP(ContactsLibTrapOpenSession);
00544
00545 /*
00546  * FUNCTION: ContactsCloseSession
00547  *
00548  * DESCRIPTION:
00549  *
00550  * Nullifies the open session handle and frees any internal memory used by the library for this session.
00551  *
00552  * PARAMETERS:
00553  *
00554  * libRefnum
00555  *      Library reference number obtained from ContactsLib_OpenLibrary().
00556  *
00557  * hSession
00558  *      This is any valid session handle that was obtain from a call to OpenSession.
00559  *
00560  * RETURNS:
00561  *      errNone
00562  *      ContactsLibErrInvalidSessionHandle
00563  *
00564  * USAGE:
00565  *      This must be called after a session is no longer needed.  It will prevent memory leaks
00566  *      of any memory allocated by the OpenSession call.  It also will make available the
00567  *      session for another caller.
00568  * NOTES:
00569  *      It is important to always close the session with a call to ContactsCloseSession
00570  *      after you are finished with the session.  Doing so will free system memory used internally
00571  *      by the library and also free a spot for other users to open sessions.
00572  *      With this version of the library, there is a limit to a total of 4 open sessions.
00573  */
00574 extern  Err     ContactsCloseSession(UInt16 libRefnum, ContactsSession hCurSession) CONTACTS_LIB_TRAP(ContactsLibTrapCloseSession);
00575
00576 /*
00577  * FUNCTION: ContactsCreateHandle
00578  *
00579  * DESCRIPTION:
00580  *
00581  * Returns a brand new ContactsContHandle..
00582  *
00583  * PARAMETERS:
00584  *
00585  * libRefnum
00586  *      Library reference number obtained from ContactsLib_OpenLibrary().
00587  *
00588  * hSession
00589  *      This is any valid read/write session handle that was obtain from a call to OpenSession.
00590  *
00591  * RETURNS:
00592  *      a valid ContHandle
00593  *      NULL (only possible way this could fail is if out of memory)
00594  *
00595  * USAGE:
00596  *      This is called to create a new handle which is then used to set a series of fields.
00597  *      One would create the handle, do a series of 'sets' and then add the new handle by calling
00598  *      AddContact.
00599  * NOTES:
00600  *      It is critical that after the handle is finished being used, a call to
00601  *      ReleaseHandle is called.
00602  */
00603 extern  ContactsContHandle      ContactsCreateHandle(UInt16 libRefnum, ContactsSession hSession)    CONTACTS_LIB_TRAP(ContactsLibTrapCreateHandle);
00604
00605 /*
00606  * FUNCTION: ContactsReleaseHandle
00607  *
00608  * DESCRIPTION:
00609  *
00610  * Used to release the memory used by ANY valid ContactsContHandle.
00611  *
00612  * PARAMETERS:
00613  *
00614  * libRefnum
00615  *      Library reference number obtained from ContactsLib_OpenLibrary().
00616  *
00617  * RETURNS:
00618  *      errNone
00619  *      P1ctErrInvalidHandle
00620  *
00621  * USAGE:
00622  *      Once a handle has been obtained, either from a call to CreateHandle or GetContact,
00623  *      It is critical that the ReleaseHandle routine is called.
00624  */
00625 extern  Err     ContactsReleaseHandle(UInt16 libRefnum, ContactsContHandle hContact)    CONTACTS_LIB_TRAP(ContactsLibTrapReleaseHandle);
00626
00627 /*
00628  * FUNCTION: ContactsAddContact
00629  *
00630  * DESCRIPTION:
00631  *
00632  * Used to add the contact described by a ContHandle to the database.
00633  *
00634  * PARAMETERS:
00635  *
00636  * libRefnum
00637  *      Library reference number obtained from ContactsLib_OpenLibrary().
00638  *
00639  * hSession
00640  *      This is any valid read/write session handle that was obtain from a call to OpenSession.
00641  *
00642  * hContact
00643  *      The contact handle returned by CreateContact.
00644  *
00645  * RETURNS:
00646  *      errNone
00647  *      ContactsLibErrInvalidSessionHandle
00648  *      P1ctErrReadOnlySession
00649  *
00650  * USAGE:
00651  *      Once a handle has been obtained from CreateHandle,
00652  *      the user will follow with a series of calls to "Set" routines that will set the fields values.
00653  *      Once all of the calls to the "set" routines have been made, it is necessary to call
00654  *      the AddContact routine to write the data to the database.
00655  *      The final step is to call ReleaseHandle on the ContHandle.
00656  */
00657 extern  Err     ContactsAddContact(UInt16 libRefnum, ContactsSession hSession, ContactsContHandle hContact) CONTACTS_LIB_TRAP(ContactsLibTrapAddContact);
00658
00659 /*
00660  * FUNCTION: ContactsUpdateContact
00661  *
00662  * DESCRIPTION:
00663  *
00664  * Writes the entry to the database.
00665  *
00666  * PARAMETERS:
00667  *
00668  * libRefnum
00669  *      Library reference number obtained from ContactsLib_OpenLibrary().
00670  *
00671  * hSession
00672  *      This is any valid read/write session handle that was obtain from a call to ContactsOpenSession.
00673  *
00674  * hContact
00675  *      This is any valid ContHandle that was returned by one of the routines that returns a ContHandle.
00676  *
00677  * RETURNS:
00678  *      errNone
00679  *      P1ctErrInvalidHandle
00680  *
00681  * USAGE:
00682  *      Once a ContHandle has been obtained, the user can modify the entry by doing one or more "Set" calls.
00683  *      Once all of the set routines have been made, a call to UpdateContact must be made to save the changes.
00684  *
00685  * NOTES:
00686  *      There are several routines that will return a valid ContHandle (ie GetContact, GetFirstContact, GetNextContact).
00687  *      Although a call to UpdateContact is not required, if any changes have been made by calling any of the set
00688  *      routines, UpdateContact must be called to save those changes to the database.
00689  *      Remember, it IS required to call ReleaseHandle for any ContHandle obtained.
00690  */
00691 extern  Err     ContactsUpdateContact(UInt16 libRefnum, ContactsSession hSession, ContactsContHandle hContact)  CONTACTS_LIB_TRAP(ContactsLibTrapUpdateContact);
00692
00693 /*
00694  * FUNCTION: ContactsDeleteContact
00695  *
00696  * DESCRIPTION:
00697  *
00698  * Immeditely deletes the contact from the Contacts database.
00699  *
00700  * PARAMETERS:
00701  *
00702  * libRefnum
00703  *      Library reference number obtained from ContactsLib_OpenLibrary().
00704  *
00705  * hSession
00706  *      This is any valid read/write session handle that was obtain from a call to OpenSession.
00707  *
00708  * hContact
00709  *      This is the valid ContHandle that was returned by one of the routines that returns a ContHandle.
00710  *
00711  * archive
00712  *      Pass true if you want the entry to be archived on PC.
00713  *
00714  * RETURNS:
00715  *      errNone
00716  *      P1ctErrReadOnlySession
00717  *
00718  * USAGE:
00719  *      Once a ContHandle has been obtained from any of the routines that return a ContHandle (except CreateHandle),
00720  *      calling this routine will delete this entry.
00721  *
00722  * NOTES:
00723  *      Remember, it STILL is required to call ReleaseHandle for the ContHandle after calling DeleteContact.
00724  */
00725 extern  Err     ContactsDeleteContact(UInt16 libRefnum, ContactsSession hSession, ContactsContHandle hContact, Boolean archive) CONTACTS_LIB_TRAP(ContactsLibTrapDeleteContact);
00726
00727 /*
00728  * FUNCTION: ContactsGetContact
00729  *
00730  * DESCRIPTION:
00731  *
00732  * Gets a ContHandle by either index (0 based) or by uniqueID.
00733  *
00734  * PARAMETERS:
00735  *
00736  * libRefnum
00737  *      Library reference number obtained from ContactsLib_OpenLibrary().
00738  *
00739  * hSession
00740  *      This is any valid session handle that was obtain from a call to OpenSession.
00741  *
00742  * indexP
00743  *      pass either a UInt16* containing a 0 based index or NULL.
00744  *
00745  * uniqueIDP
00746  *      Pass either a UInt32* containing a valid uniqueID or NULL.
00747  *
00748  * RETURNS:
00749  *      a valid ContHandle
00750  *      NULL
00751  *
00752  * USAGE:
00753  *      The routine first checks to see if uniqueIDP is not NULL, if not, a search of the database will be commenced
00754  *      using the uniqueID stored in that pointer.
00755  *      IF uniqueIDP is NULL, it will expect a non-NULL indexP which its contents will be used to get the
00756  *      ContHandle at that index location.
00757  *
00758  * NOTES:
00759  *      Remember to call ReleaseHandle for the ContHandle after finish using it.
00760  *      IF NULL is returned, the error causing the failure can be obtained call GetLastErr.
00761  */
00762 extern  ContactsContHandle      ContactsGetContact(UInt16 libRefnum, ContactsSession hSession, UInt16* indexP, UInt32 *uniqueIDP, Boolean ignored) CONTACTS_LIB_TRAP(ContactsLibTrapGetContact);
00763
00764 /*
00765  * FUNCTION: ContactsGetNumRecords
00766  *
00767  * DESCRIPTION:
00768  *
00769  * returns the number of records in any given category.
00770  *
00771  * PARAMETERS:
00772  *
00773  * libRefnum
00774  *      Library reference number obtained from ContactsLib_OpenLibrary().
00775  *
00776  * hSession
00777  *      This any valid session handle that was obtain from a call to ContactsOpenSession.
00778  *
00779  * category
00780  *      either the category index of the category you wish use OR ContactsAllCategories to specify all categories.
00781  *      To specify "Unfiled," use ContactsUnfiledCategory for the category.
00782  *
00783  * RETURNS:
00784  *      the number of contacts in the specified category.
00785  *
00786  * NOTE:
00787  *      To get the category for an existing record call ContactsGetUInt16Field for that record.
00788  */
00789 extern  UInt16      ContactsGetNumRecords(UInt16 libRefnum, ContactsSession hSession, UInt16 category)  CONTACTS_LIB_TRAP(ContactsLibTrapGetNumOfRecord);
00790
00791 /* FUNCTION: ContactsPosInCategory
00792  *
00793  * DESCRIPTION:
00794  *
00795  * Returns the position of a given record in a given category.
00796  *
00797  * PARAMETERS:
00798  *
00799  * libRefnum
00800  *      Library reference number obtained from ContactsLib_OpenLibrary().
00801  *
00802  * hSession
00803  *      This any valid session handle that was obtain from a call to OpenSession.
00804  *
00805  * hContact
00806  *      ContHandle of a given contact record.
00807  *
00808  * pIndex
00809  *      on return, contains the index of the record.
00810  *
00811  * category
00812  *      category in which the entry is contained.
00813  *
00814  * RETURNS:
00815  *      position of the record within a given category (0 based).
00816  *
00817  * NOTE:
00818  *      this routine is useful when only a given category is being displayed and for scrolling purposes,
00819  *      one needs to determine a record's position in that category.
00820  *      It is important that GetLastError is called and that noError is returned.
00821  *      This function can return 0 in a valid case but also will return 0 in an error case so
00822  *      GetLastError should be checked for noError.
00823  */
00824 extern  UInt16      ContactsPosInCategory(UInt16 libRefnum, ContactsSession hSession, ContactsContHandle hContact, UInt16 *pIndex, UInt16 category) CONTACTS_LIB_TRAP(ContactsLibTrapPosInCategory);
00825
00826 /*
00827  * FUNCTION: ContactsSeekRecord
00828  *
00829  * DESCRIPTION:
00830  *
00831  * Returns a ContHandle specified by the seek criteria passed.
00832  *
00833  * PARAMETERS:
00834  *
00835  * libRefnum
00836  *      Library reference number obtained from ContactsLib_OpenLibrary().
00837  *
00838  * hSession
00839  *      This is any valid session handle that was obtain from a call to ContactsOpenSession.
00840  *
00841  * indexP
00842  *      This is a pointer that contains the initial index in which to seek from.
00843  *
00844  * offset
00845  *      The number of entries to seek to past the intial position.
00846  *
00847  * direction
00848  *      Specifies to either seek forward or backward from the initial index ( ContactsSeekForward or ContactsSeekBackward)
00849  *
00850  * category
00851  *      Specifies the category in which to seek in.
00852  *
00853  * RETURNS:
00854  *      true    - a valid index has been found.
00855  *      false   - no index matching the seek criteria has been found.
00856  *
00857  *      indexP  - contains the valid index if the routine returned true.
00858  */
00859 extern  Boolean     ContactsSeekRecord(UInt16 libRefnum, ContactsSession hSession, UInt16 *indexP, UInt16 offset, Int16 direction, UInt16 category) CONTACTS_LIB_TRAP(ContactsLibTrapSeekRecord);
00860
00861 /* FUNCTION: ContactsGetFirstContact
00862  *
00863  * DESCRIPTION:
00864  *
00865  * Gets the very first ContHandle in a given category
00866  *
00867  * PARAMETERS:
00868  *
00869  * libRefnum
00870  *      Library reference number obtained from ContactsLib_OpenLibrary().
00871  *
00872  * hSession
00873  *      This any valid session handle that was obtain from a call to OpenSession.
00874  *
00875  * category
00876  *      either specify a category or pass ContactsAllCategories to indicate the very first contact in all the categories.
00877  *
00878  * RETURNS:
00879  *      a valid ContHandle
00880  *      NULL
00881  *
00882  * NOTES:
00883  *      Remember to call ReleaseHandle for the ContHandle after finish using it.
00884  *      If a NULL is returned, the exact error causing the failure can be obtained from GetLastErr.
00885  */
00886 extern  ContactsContHandle      ContactsGetFirstContact(UInt16 libRefnum, ContactsSession hSession, UInt16 category)    CONTACTS_LIB_TRAP(ContactsLibTrapGetFirstContact);
00887
00888 /* FUNCTION: ContactsGetNextContact
00889  *
00890  * DESCRIPTION:
00891  *
00892  * Gets the next ContHandle after a specified handle in a category
00893  *
00894  * PARAMETERS:
00895  *
00896  * libRefnum
00897  *      Library reference number obtained from ContactsLib_OpenLibrary().
00898  *
00899  * Category
00900  *      This is the category in which you wish to search.
00901  *
00902  * hSourceContact
00903  *      This is the contact to be used as the reference for the search.
00904  *
00905  * RETURNS:
00906  *      a valid ContHandle
00907  *      NULL
00908  *
00909  * NOTES:
00910  *      The specified hSourceContact does not have to be part of the specified category for the routine
00911  *      to succeed but it is logical that it would be.
00912  *      If a ContHandle is returned, remember to call ReleaseHandle for afer done using it.
00913  */
00914 extern  ContactsContHandle      ContactsGetNextContact(UInt16 libRefnum, ContactsSession hSession, ContactsContHandle hSourceContact, UInt16 Category)  CONTACTS_LIB_TRAP(ContactsLibTrapGetNextContact);
00915
00916 /*
00917  * FUNCTION: ContactsDoesFieldExist
00918  *
00919  * DESCRIPTION:
00920  *
00921  * Returns true if the field has been populated in the sepcified record.
00922  *
00923  * PARAMETERS:
00924  *
00925  * libRefnum
00926  *      Library reference number obtained from ContactsLib_OpenLibrary().
00927  *
00928  * hContact
00929  *      This is the valid ContHandle that was returned by one of the routines that returns a ContHandle.
00930  *
00931  * NameOfField
00932  *      any valid fieldName (any one of the ContactsLibAllFields fields).
00933  *
00934  * RETURNS:
00935  *      true - if the field contains data.
00936  *      false - if the specified field is empty in the specified record.
00937  *
00938  * USAGE:
00939  *      This routine is most handy for the picture field to see if a picture exists prior to getting
00940  *      the data.  However, this routine can be used for any of the fields.
00941  */
00942 extern  Boolean     ContactsDoesFieldExist(UInt16 libRefnum, ContactsContHandle hContact, ContactsLibAllFields NameOfField) CONTACTS_LIB_TRAP(ContactsLibTrapDoesFieldExist);
00943
00944 /* FUNCTION: ContactsIsEmptyContact
00945  *
00946  * DESCRIPTION:
00947  *
00948  * Will return true if ALL of the fields of a given record are empty.
00949  *
00950  * PARAMETERS:
00951  *
00952  * libRefnum
00953  *      Library reference number obtained from ContactsLib_OpenLibrary().
00954  *
00955  * hSession
00956  *      This any valid session handle that was obtain from a call to ContactsOpenSession.
00957  *
00958  * hContact
00959  *      The contact you which to know is empty or not.
00960  *
00961  * RETURNS:
00962  *      true    - record is completely empty.
00963  *      false   - there is at least one field that contains data in the specified record.
00964  */
00965 extern  Boolean     ContactsIsEmptyContact (UInt16 libRefnum,  ContactsSession hSession, ContactsContHandle hCont, UInt16 *Index, UInt32 *UniqueID) CONTACTS_LIB_TRAP(ContactsLibTrapIsEmptyContact);
00966
00967
00968 /* FUNCTION: ContactsSetUInt8Field
00969  *
00970  * DESCRIPTION:
00971  *
00972  * Set the value of the specified UInt8 field.
00973  *
00974  * PARAMETERS:
00975  *
00976  * libRefnum
00977  *      Library reference number obtained from ContactsLib_OpenLibrary().
00978  *
00979  * hContact
00980  *      This any valid read/write session handle that was obtain from a call to OpenSession.
00981  *
00982  * nameOfField
00983  *      This is the field of size UInt8 in which you want to set (ContactsLibUInt8Fields).
00984  *
00985  * fieldValue
00986  *      value you wish to assign to that field.
00987  *
00988  * RETURNS:
00989  *      noErr.
00990  *      P1ctErrInvalidParam
00991  *      ContactsLibErrInvalidHandle.
00992  */
00993 extern  Err     ContactsSetUInt8Field(UInt16 libRefnum, ContactsContHandle hContact, ContactsLibUInt8Fields nameOfField, UInt8 fieldValue)  CONTACTS_LIB_TRAP(ContactsLibTrapSetUInt8Field);
00994
00995 /* FUNCTION: ContactsSetUInt16Field
00996  *
00997  * DESCRIPTION:
00998  *
00999  * Set the value of the specified UInt16 field.
01000  *
01001  * PARAMETERS:
01002  *
01003  * libRefnum
01004  *      Library reference number obtained from ContactsLib_OpenLibrary().
01005  *
01006  * hContact
01007  *      This any valid session handle that was obtain from a call to OpenSession.
01008  *
01009  * NameOfField
01010  *      This is the field of size UInt16 in which you want to set (ContactsLibUInt16Fields).
01011  *
01012  * FieldValue
01013  *      value you wish to set field with.
01014  *
01015  * RETURNS:
01016  *      noErr.
01017  *      P1ctErrInvalidParam
01018  *      ContactsLibErrInvalidHandle.
01019  */
01020 extern  Err     ContactsSetUInt16Field(UInt16 libRefnum, ContactsContHandle hContact, ContactsLibUInt16Fields NameOfField, UInt16 FieldValue)   CONTACTS_LIB_TRAP(ContactsLibTrapSetUInt16Field);
01021
01022 /* FUNCTION: ContactsSetDateField
01023  *
01024  * DESCRIPTION:
01025  *
01026  * Set the value of the specified Date field.
01027  *
01028  * PARAMETERS:
01029  *
01030  * libRefnum
01031  *      Library reference number obtained from ContactsLib_OpenLibrary().
01032  *
01033  * hContact
01034  *      This any valid session handle that was obtain from a call to ContactsOpenSession.
01035  *
01036  * nameOfField
01037  *      This is the field of type ContactsDateType in which you want to set (ContactsLibDateFields).
01038  *
01039  * fieldValue
01040  *      value you wish to set field with.
01041  *
01042  * RETURNS:
01043  *      noErr.
01044  *      P1ctErrInvalidParam
01045  *      ContactsLibErrInvalidHandle.
01046  */
01047 extern  Err     ContactsSetDateField(UInt16 libRefnum, ContactsContHandle hContact, ContactsLibDateFields nameOfField, ContactsDateType fieldValue) CONTACTS_LIB_TRAP(ContactsLibTrapSetDateField);
01048
01049 /* FUNCTION: ContactsSetStringField
01050  *
01051  * DESCRIPTION:
01052  *
01053  * Set the value of the specified String field.
01054  *
01055  * PARAMETERS:
01056  *
01057  * libRefnum
01058  *      Library reference number obtained from ContactsLib_OpenLibrary().
01059  *
01060  * hContact
01061  *      This any valid read/write session handle that was obtain from a call to OpenSession.
01062  *
01063  * nameOfField
01064  *      This is the field of type Char * in which you want to set (ContactsLibStrFields).
01065  *
01066  * FieldValue
01067  *      value you wish to set field with.
01068  *
01069  * RETURNS:
01070  *      noErr.
01071  *      ContactsLibErrInvalidHandle.
01072  */
01073 extern  Err     ContactsSetStringField(UInt16 libRefnum, ContactsContHandle hContact, ContactsLibStrFields nameOfField, char *FieldValue)   CONTACTS_LIB_TRAP(ContactsLibTrapSetStringField);
01074
01075 /* FUNCTION: ContactsSetBinaryField
01076  *
01077  * DESCRIPTION:
01078  *
01079  * Set the value of the specified Binary field.
01080  *
01081  * PARAMETERS:
01082  *
01083  * libRefnum
01084  *      Library reference number obtained from ContactsLib_OpenLibrary().
01085  *
01086  * hContact
01087  *      This any valid session handle that was obtain from a call to OpenSession.
01088  *
01089  * NameOfField
01090  *      This is the field of type Binary in which you want to set (ContactsLibBinaryFields).
01091  *
01092  * FieldValue
01093  *      value you wish to set field with.
01094  *
01095  * DataSize
01096  *      Length in bytes of the data you wish to set.
01097  *
01098  * RETURNS:
01099  *      noErr.
01100  *      ContactsLibErrInvalidHandle.
01101  */
01102 extern  Err     ContactsSetBinaryField(UInt16 libRefnum, ContactsContHandle hContact, ContactsLibBinaryFields NameOfField, void *pFieldData, UInt16 DataSize)   CONTACTS_LIB_TRAP(ContactsLibTrapSetBinaryField);
01103
01104 /* FUNCTION: ContactsGetUInt8Field
01105  *
01106  * DESCRIPTION:
01107  *
01108  * Fetches the UInt8 value of the specified field from the specified record.
01109  *
01110  * PARAMETERS:
01111  *
01112  * libRefnum
01113  *      Library reference number obtained from ContactsLib_OpenLibrary().
01114  * hContact
01115  *      This any valid session handle that was obtain from a call to ContactsOpenSession.
01116  * NameOfField
01117  *      This is the field of type UInt8 in which you want to set (ContactsLibUInt8Fields).
01118  * pFieldValue
01119  *      pointer to the UInt8 in which the fetched value will be placed.
01120  * RETURNS:
01121  *      noErr.
01122  *      ContactsLibErrInvalidHandle.
01123  */
01124 extern  Err                     ContactsGetUInt8Field(UInt16 libRefnum, ContactsContHandle hContact, ContactsLibUInt8Fields NameOfField, UInt8 *pFieldValue)    CONTACTS_LIB_TRAP(ContactsLibTrapGetUInt8Field);
01125
01126 /* FUNCTION: ContactsGetUInt16Field
01127  *
01128  * DESCRIPTION:
01129  *
01130  * Fetches the UInt16 value of the specified field from the specified record.
01131  *
01132  * PARAMETERS:
01133  *
01134  * libRefnum
01135  *      Library reference number obtained from ContactsLib_OpenLibrary().
01136  * hContact
01137  *      This any valid session handle that was obtain from a call to ContactsOpenSession.
01138  * NameOfField
01139  *      This is the field of type UInt16 in which you want to set (ContactsLibUInt16Fields).
01140  * pFieldValue
01141  *      pointer to the UInt16 in which the fetched value will be placed.
01142  * RETURNS:
01143  *      noErr.
01144  *      ContactsLibErrInvalidHandle.
01145  */
01146 extern  Err                     ContactsGetUInt16Field(UInt16 libRefnum, ContactsContHandle hContact, ContactsLibUInt16Fields NameOfField, UInt16 *pFieldValue) CONTACTS_LIB_TRAP(ContactsLibTrapGetUInt16Field);
01147
01148 /* FUNCTION: ContactsGetUInt32Field
01149  *
01150  * DESCRIPTION:
01151  *
01152  * Fetches the UInt32 value of the specified field from the specified record.
01153  *
01154  * PARAMETERS:
01155  *
01156  * libRefnum
01157  *      Library reference number obtained from ContactsLib_OpenLibrary().
01158  * hContact
01159  *      This any valid session handle that was obtain from a call to ContactsOpenSession.
01160  * NameOfField
01161  *      This is the field of type UInt32 in which you want to set (ContactsLibUInt32Fields).
01162  * pFieldValue
01163  *      pointer to the UInt32 in which the fetched value will be placed.
01164  * RETURNS:
01165  *      noErr.
01166  *      ContactsLibErrInvalidHandle.
01167  */
01168 extern  Err                     ContactsGetUInt32Field(UInt16 libRefnum, ContactsContHandle hContact, ContactsLibUInt32Fields NameOfField, UInt32 *pFieldValue) CONTACTS_LIB_TRAP(ContactsLibTrapGetUInt32Field);
01169
01170 /* FUNCTION: ContactsGetDateField
01171  *
01172  * DESCRIPTION:
01173  *
01174  * Fetches the Date value of the specified field from the specified record.
01175  *
01176  * PARAMETERS:
01177  *
01178  * libRefnum
01179  *      Library reference number obtained from ContactsLib_OpenLibrary().
01180  * hContact
01181  *      This any valid ContHandle that was obtain from a call to ContactsOpenSession.
01182  * NameOfField
01183  *      This is the field of type DateType in which you want to set (ContactsLibDateFields).
01184  * pFieldValue
01185  *      pointer to the Date in which the fetched value will be placed.
01186  * RETURNS:
01187  *      noErr.
01188  *      ContactsLibErrInvalidHandle.
01189  */
01190 extern  Err                     ContactsGetDateField(UInt16 libRefnum, ContactsContHandle hContact, ContactsLibDateFields NameOfField, DateType *pFieldValue)   CONTACTS_LIB_TRAP(ContactsLibTrapGetDateField);
01191
01192 /* FUNCTION: ContactsGetStringField
01193  *
01194  * DESCRIPTION:
01195  *
01196  * Fetches the String value of the specified field from the specified record.
01197  *
01198  * PARAMETERS:
01199  *
01200  * libRefnum
01201  *      Library reference number obtained from ContactsLib_OpenLibrary().
01202  * hContact
01203  *      This any valid ContHandle that was obtain from a call to ContactsOpenSession.
01204  * NameOfField
01205  *      This is the field of type String in which you want to set (ContactsLibStrFields).
01206  * pFieldValue
01207  *      pointer to the String in which the fetched value will be placed.
01208  * RETURNS:
01209  *      noErr.
01210  *      ContactsLibErrInvalidHandle.
01211  */
01212 extern  Err                     ContactsGetStringField(UInt16 libRefnum, ContactsContHandle hContact, ContactsLibStrFields NameOfField, char **pFieldValue) CONTACTS_LIB_TRAP(ContactsLibTrapGetStringField);
01213
01214 /* FUNCTION: ContactsGetBinaryField
01215  *
01216  * DESCRIPTION:
01217  *
01218  * Fetches the binary value of the specified field from the specified record.
01219  *
01220  * PARAMETERS:
01221  *
01222  * libRefnum
01223  *      Library reference number obtained from ContactsLib_OpenLibrary().
01224  * hContact
01225  *      This any valid ContHandle that was obtain from a call to ContactsOpenSession.
01226  * NameOfField
01227  *      This is the field of type binary in which you want to set (ContactsLibBinaryFields).
01228  * pFieldValue
01229  *      pointer to the binary in which the fetched value will be placed.
01230  * RETURNS:
01231  *      noErr.
01232  *      ContactsLibErrInvalidHandle.
01233  * NOTES:
01234  *      There are two possible fields that contain binary data, pictureField & ringtoneIdentifier.
01235  *      pictureField will return a pointer to a string of data of the picture (JPEG).
01236  *      ringtoneIdentifier returns a pointer to a 6 byte structure of type ToneIdentifier (described in ToneLibTypes.h)
01237  */
01238 extern  void*                   ContactsGetBinaryField(UInt16 libRefnum, ContactsContHandle hContact, ContactsLibBinaryFields NameOfField, UInt16 *pDataSize)   CONTACTS_LIB_TRAP(ContactsLibTrapGetBinaryField);
01239
01240 /* FUNCTION: ContactsGetRingtoneForCategory
01241  *
01242  * DESCRIPTION:
01243  *
01244  * Gets the ToneIdentifier for a given category.
01245  *
01246  * PARAMETERS:
01247  *
01248  * libRefnum
01249  *      Library reference number obtained from ContactsLib_OpenLibrary().
01250  * categoryID
01251  *      The index of the category.
01252  * tone
01253  *      This is a pointer to a struct of type ToneIdentifier which contains the toneType (UInt16) and toneID (UInt32).
01254  * RETURNS:
01255  *      noErr.
01256  */
01257 extern  Err                     ContactsGetRingtoneForCategory(UInt16 libRefnum, UInt16 categoryID, void *tone) CONTACTS_LIB_TRAP(ContactsLibTrapGetRingtoneForCategory);
01258
01259 /* FUNCTION: ContactsGetFieldLabel
01260  *
01261  * DESCRIPTION:
01262  *
01263  * Gets the field label index of a field containing a label.
01264  *
01265  * PARAMETERS:
01266  *
01267  * libRefnum
01268  *      Library reference number obtained from ContactsLib_OpenLibrary().
01269  * hContact
01270  *      This any valid ContHandle.
01271  * FieldNum
01272  *      This is the field value of type (ContactsLibWithLabelFields).
01273  * RETURNS:
01274  *      Index of the label assigned to that field.
01275  * NOTES:
01276  *      In addition to a field have a field value, it can also have a field label.
01277  *      For example, the Address field can also have a label describing if it is a Home, Work, etc.
01278  *      This routine returns the index of the label which can then be used to get the actual label text
01279  *      using GetLabelText or GetLabelList.
01280  */
01281 extern  Int16                   ContactsGetFieldLabel(UInt16 libRefnum, ContactsContHandle hContact, ContactsLibWithLabelFields FieldNum)   CONTACTS_LIB_TRAP(ContactsLibTrapGetFieldLabel);
01282
01283 /* FUNCTION: ContactsSetFieldLabel
01284  *
01285  * DESCRIPTION:
01286  *
01287  * Sets the field label index of a field containing a label.
01288  *
01289  * PARAMETERS:
01290  *
01291  * libRefnum
01292  *      Library reference number obtained from ContactsLib_OpenLibrary().
01293  * hContact
01294  *      This any valid ContHandle.
01295  * FieldNum
01296  *      This is the field value of type (ContactsLibWithLabelFields).
01297  * LabelIndex
01298  *      This is the 0 based index of the label to which the field should be assigned.
01299  * RETURNS:
01300  *      Nothing.
01301  */
01302 extern  void                    ContactsSetFieldLabel(UInt16 libRefnum, ContactsContHandle hToCont, ContactsLibWithLabelFields FieldNum, Int16 LabelIndex)  CONTACTS_LIB_TRAP(ContactsLibTrapSetFieldLabel);
01303
01304 /* FUNCTION: ContactsGetLabelText
01305  *
01306  * DESCRIPTION:
01307  *
01308  * Gets a particular label for a field based on its index.
01309  *
01310  * PARAMETERS:
01311  *
01312  * libRefnum
01313  *      Library reference number obtained from ContactsLib_OpenLibrary().
01314  * hSession
01315  *      This any valid session handle that was obtain from a call to ContactsOpenSession.
01316  * type
01317  *      This is type of the field label you wish to get (ContactsLabelType).
01318  * labelNum
01319  *      This is index within the label list.
01320  * RETURNS:
01321  *      String containing the label name.
01322  *      pSizeOfBuffer
01323  *          contains the size of the allocated buffer returned.
01324  * NOTES:
01325  *      This routine allocates memory and the string pointer returned must be freed by the caller.
01326  */
01327 extern  char*                   ContactsGetLabelText(UInt16 libRefnum, ContactsSession hSession, ContactsLabelType type, UInt16 labelNum, UInt16 *pSizeOfBuffer)    CONTACTS_LIB_TRAP(ContactsLibTrapGetLabelText);
01328
01329 /* FUNCTION: ContactsRenameCustomLabel
01330  *
01331  * DESCRIPTION:
01332  *
01333  * Sets one of the Custom Labels to a specified string.
01334  *
01335  * PARAMETERS:
01336  *
01337  * libRefnum
01338  *      Library reference number obtained from ContactsLib_OpenLibrary().
01339  * hSession
01340  *      This any valid session handle that was obtain from a call to ContactsOpenSession.
01341  * fieldNum
01342  *      This is field number of any one of the custom fields (ContactsLibCustomFields).
01343  * fieldLabel
01344  *      This is the string pointer in which you want the custom field's name to be assigned.
01345  *      (the maximum length of a field label is ContactsLabelLength (includes null byte))
01346  * RETURNS:
01347  *      noErr.
01348  * NOTES:
01349  *      This routine allocates memory and the string pointer returned must be freed by the caller.
01350  */
01351 extern  Err                     ContactsRenameCustomLabel(UInt16 libRefnum, ContactsSession hSession, ContactsLibCustomFields fieldNum, Char* fieldLabel)   CONTACTS_LIB_TRAP(ContactsLibTrapRenameCustomLabel);
01352
01353 /* FUNCTION: ContactsGetCategoryList
01354  *
01355  * DESCRIPTION:
01356  *
01357  * Returns the current list of categories for the Contacts application.
01358  *
01359  * PARAMETERS:
01360  *
01361  * libRefnum
01362  *      Library reference number obtained from ContactsLib_OpenLibrary().
01363  * hSession
01364  *      This any valid session handle that was obtain from a call to ContactsOpenSession.
01365  * pCategoryList
01366  *      A pointer to an array of string pointers.
01367  * RETURNS:
01368  *      Each of the locations in the pCategoryList will cotain a string pointer.  If the category
01369  *      does not exist, the string will be of length of zero.
01370  * NOTES:
01371  *      This routine allocates a string pointer for EVERY location in pCategoryList (even if
01372  *      no category exists at that location).
01373  */
01374 extern  void                    ContactsGetCategoryList(UInt16 libRefnum, ContactsSession hSession, char *pCategoryList[ContactsNumCategories]) CONTACTS_LIB_TRAP(ContactsLibTrapGetCategoryList);
01375
01376 /* FUNCTION: ContactsGetNextCategory
01377  *
01378  * DESCRIPTION:
01379  *
01380  * Returns the current list of categories for the Contacts application.
01381  *
01382  * PARAMETERS:
01383  *
01384  * libRefnum
01385  *      Library reference number obtained from ContactsLib_OpenLibrary().
01386  * hSession
01387  *      This any valid session handle that was obtain from a call to ContactsOpenSession.
01388  * currentCategory
01389  *      The index of a category to be used as a reference to seek to the next category.
01390  *      Passing ContactsAllCategories as the current Category is legal and can be used
01391  *      to initiat a search of all the available categories.
01392  * RETURNS:
01393  *      The index of the next category.
01394  */
01395 extern  UInt16                  ContactsGetNextCategory(UInt16  libRefnum, ContactsSession hSession, UInt16 currentCategory)    CONTACTS_LIB_TRAP(ContactsLibTrapGetNextCategory);
01396
01397 /* FUNCTION: ContactsGetCategoryName
01398  *
01399  * DESCRIPTION:
01400  *
01401  * Returns the name of a category for a specified category index.
01402  *
01403  * PARAMETERS:
01404  *
01405  * libRefnum
01406  *      Library reference number obtained from ContactsLib_OpenLibrary().
01407  * hSession
01408  *      This any valid session handle that was obtain from a call to ContactsOpenSession.
01409  * categoryIndex
01410  *      The index of a category to be used as a reference to seek to the next category.
01411  *      Passing ContactsAllCategories as the current Category is legal and can be used
01412  *      to get the name of the "All" category label.
01413  * RETURNS:
01414  *      A string pointer to the category name.
01415  * NOTE:
01416  *      This routine returns a string pointer which must be freed.
01417  */
01418 extern  Char*                   ContactsGetCategoryName(UInt16 libRefnum, ContactsSession hSession, UInt16 categoryIndex)   CONTACTS_LIB_TRAP(ContactsLibTrapGetCategoryName);
01419
01420 /* FUNCTION: ContactsSetCategoryName
01421  *
01422  * DESCRIPTION:
01423  *
01424  * Returns the name of a category for a specified category index.
01425  *
01426  * PARAMETERS:
01427  *
01428  * libRefnum
01429  *      Library reference number obtained from ContactsLib_OpenLibrary().
01430  * hSession
01431  *      This any valid session handle that was obtain from a call to ContactsOpenSession.
01432  * categoryIndex
01433  *      The index of a category in which to assign the new label.
01434  * pCategoryName
01435  *      A string pointer in which to assign the category label.
01436  * RETURNS:
01437  *      none.
01438  * NOTE:
01439  *      To clear out a particular category, simply pass NULL for the pCategoryName.
01440  */
01441 extern  void                    ContactsSetCategoryName(UInt16 libRefnum, ContactsSession hSession, UInt16 categoryIndex, const Char *pCatName) CONTACTS_LIB_TRAP(ContactsLibTrapGetCategoryName);
01442
01443 /* FUNCTION: ContactsCategoryFind
01444  *
01445  * DESCRIPTION:
01446  *
01447  * Returns the category index given a specified category name.
01448  *
01449  * PARAMETERS:
01450  *
01451  * libRefnum
01452  *      Library reference number obtained from ContactsLib_OpenLibrary().
01453  * hSession
01454  *      This any valid session handle that was obtain from a call to ContactsOpenSession.
01455  * pCatName
01456  *      Name of the label in which to locate its index..
01457  * RETURNS:
01458  *      index of the category name specified.
01459  */
01460 extern  UInt16                  ContactsCategoryFind(UInt16 libRefnum, ContactsSession hSession, const Char *pCatName)  CONTACTS_LIB_TRAP(ContactsLibTrapCategoryFind);
01461
01462 /* FUNCTION: ContactsGetRingtoneForCategory
01463  *
01464  * DESCRIPTION:
01465  *
01466  * Returns ringtone for a given category.
01467  *
01468  * PARAMETERS:
01469  *
01470  * libRefnum
01471  *      Library reference number obtained from ContactsLib_OpenLibrary().
01472  * categoryID
01473  *      This is the index for any given category.
01474  * pTone
01475  *      a pointer to a ToneIdentifier structure.
01476  * RETURNS:
01477  *      Populates the pTone structure with a valid ToneIdentifier.
01478  */
01479 extern  Err                     ContactsGetRingtoneForCategory(UInt16 libRefnum, UInt16 categoryID, void *pTone)    CONTACTS_LIB_TRAP(ContactsLibTrapGetRingtoneForCategory);
01480
01481 /* FUNCTION: ContactsLookUpString
01482  *
01483  * DESCRIPTION:
01484  *
01485  * Searchs the contact database for the first match based on the specified key.
01486  *
01487  * PARAMETERS:
01488  *
01489  * libRefnum
01490  *      Library reference number obtained from ContactsLib_OpenLibrary().
01491  * hSession
01492  *      This any valid session handle that was obtain from a call to ContactsOpenSession.
01493  * key
01494  *      This is the string pointer to the key to be used for the search.
01495  * sortByCompany
01496  *      specifies how the db is sorted for this search.
01497  * category
01498  *      category to search within.
01499  * completeMatch
01500  *      contains true upon return if the key was completely matched.
01501  * pNumMatchingChars
01502  *      returns the number of matching characters upon return.  Pass NULL if dont care.
01503  * masked
01504  *      pass true if to include masked records in the search.
01505  * RETURNS:
01506  *      If a match is found, returns the ContHandle of the entry.
01507  * NOTE:
01508  *      Remember, a call to ReleaseHandle must be made if this routine returns a non-NULL value.
01509  */
01510 extern  ContactsContHandle      ContactsLookUpString(UInt16 libRefnum, ContactsSession hSession, Char* key, Boolean sortByCompany, UInt16 category,
01511                                                         Boolean* completeMatch, UInt16* pNumMatchingChars, Boolean masked)  CONTACTS_LIB_TRAP(ContactsLibTrapLookUpString);
01512
01513 /* FUNCTION: ContactsGetLastError
01514  *
01515  * DESCRIPTION:
01516  *
01517  * Returns ringtone for a given category.
01518  *
01519  * PARAMETERS:
01520  *
01521  * libRefnum
01522  *      Library reference number obtained from ContactsLib_OpenLibrary().
01523  * RETURNS:
01524  *      the last error code stored by the library.
01525  * NOTE:
01526  *      Some routines do not return error codes but store them internally.  The last error code store dinternally
01527  *      can be obtained by calling this routine.
01528  */
01529 extern  Err                     ContactsGetLastError(UInt16 libRefnum)  CONTACTS_LIB_TRAP(ContactsLibGetLastErr);
01530
01531 #ifdef __cplusplus
01532 }
01533 #endif
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:52 2008 for Palm API Guide


Header Files » Incs » common » libraries » datebook

DatebookLibCommon.h

Go to the documentation of this file.
00001 /*****************************************************************************
00002  *
00003  * Copyright (c) 2005 Palm, Inc. or its subsidiaries.
00004  * All rights reserved.
00005  *
00006  * File:            DateBookLibCommon.h
00007  *
00008  * Description:
00009  *
00010  * History:         08/02/2005  Created by Scott Silverman
00011  *
00012  *   Name    Date        Description
00013  *
00014  *****************************************************************************/
00015
00016 #ifndef DATEBOOK_LIB_COMMON_H
00017 #define DATEBOOK_LIB_COMMON_H
00018
00019 #include <PalmTypes.h>
00020 #include <Form.h>
00021 #include <Find.h>
00022 #include <PdiLib.h>
00023
00024 #include <Common/Libraries/locs/LocsLibCommon.h>
00025 //#include <palmOne_68KInt.h>
00026
00027
00028 // Type and creator of P1cl Library
00029 #define P1clLibCreatorID                'P1CL'
00030 #define P1clTypeID                      sysFileTLibrary
00031 #define P1clLibName                     "CalendarLib-P1CL"
00032
00033
00034 //  SDS -   First initial release           0x0100
00035 //  SDS -   Bug Fix release for 2005.1      0x0101
00036 //  SDS -
00037 #define     P1cl_CURRENT_VERSION            0x0200
00038
00039
00040 #define apptMaxTimeZoneNameLen              kLocNameMaxLength
00041 #define SysNotifyPIMRecordChange            'pmdb'      // notifyType that one of the PIM dbs changed
00042
00043
00044 /********************************************************************
00045  * Error codes
00046  ********************************************************************/
00047 #define P1clErrorClass                  (appErrorClass |0x7000)
00048 #define P1clErrTooManyClients           (P1clErrorClass | 1)    //No More client can open the lib
00049 #define P1clErrInvalidHandle            (P1clErrorClass | 2)
00050 #define P1clErrInvalidParam             (P1clErrorClass | 3)
00051 #define P1clErrUIdNotFound              (P1clErrorClass | 4)
00052 #define P1clErrCategoryNotFound         (P1clErrorClass | 5)
00053 #define P1clErrAlreadyInUse             (P1clErrorClass | 6)
00054 #define P1clErrVerNotSupported          (P1clErrorClass | 7)
00055 #define P1clErrOutOfMemory              (P1clErrorClass | 8)
00056 #define P1clErrSizeParamOverFlow        (P1clErrorClass | 9)
00057 #define P1clErrEmptyDateBook            (P1clErrorClass | 10)
00058 #define P1clErrAlarmDoesNotExist        (P1clErrorClass | 11)
00059 #define P1clErrRepeatInfoDoesNotExist   (P1clErrorClass | 12)
00060 #define P1clErrDescDoesNotExist         (P1clErrorClass | 13)
00061 #define P1clErrNoteDoesNotExist         (P1clErrorClass | 14)
00062 #define P1clErrInvalidReference         (P1clErrorClass | 15)
00063 #define P1clErrApptNotFound             (P1clErrorClass | 16)
00064 #define P1clErrAttachAlreadyExist       (P1clErrorClass | 17)       //Attachment cannot be added it already exist in the record.
00065 #define P1clErrAttachNotExist           (P1clErrorClass | 18)
00066 #define P1clErrAttachOverFlow           (P1clErrorClass | 19)
00067 #define P1clErrRecordNotFound           (P1clErrorClass | 21)
00068 #define P1clErrAttachOverflow           (P1clErrorClass | 22)
00069 #define P1clErrInvalidField             (P1clErrorClass | 23)
00070 #define P1clErrNoDateTime               (P1clErrorClass | 24)
00071 #define P1clErrLibAlreadyInUse          (P1clErrorClass | 25)
00072 #define P1clErrTooManySession           (P1clErrorClass | 26)
00073 #define P1clErrAlreadyInWriteMode       (P1clErrorClass | 27)   //User have requested to create Session in ReadWriteMode but it is already open.
00074 #define P1clErrInvalidSession           (P1clErrorClass | 28)
00075 #define P1clErrInvalidAtrib             (P1clErrorClass | 29)
00076 #define P1clErrFieldNotFound            (P1clErrorClass | 30)
00077 #define P1clErrStringNotFound           (P1clErrorClass | 31)
00078 #define P1clErrInvalidAppInfoBlock      (P1clErrorClass | 32)
00079 #define P1clErrAppInfoIsMising          (P1clErrorClass | 33)
00080 #define P1clErrReadOnlySession          (P1clErrorClass | 34)
00081 #define P1clErrUIdExist                 (P1clErrorClass | 35)
00082 #define P1clErrMaxLimitReached          (P1clErrorClass | 36)
00083 #define P1clErrListNotExist             (P1clErrorClass | 37)
00084 #define P1clErrApptNotLocked            (P1clErrorClass | 38)
00085 #define P1clErrApptBusy                 (P1clErrorClass | 39)
00086 #define P1clErrEmptyAppt                (P1clErrorClass | 40)
00087 #define P1clErrFieldNotExist            (P1clErrorClass | 41)
00088 #define P1clErrRepeatTypeDoesNotExist   (P1clErrorClass | 42)
00089 #define P1clErrAttendeeNotFound         (P1clErrorClass | 43)
00090 #define P1clErrAttendeeOutofLimit       (P1clErrorClass | 44)
00091 #define P1clErrLibStillOpen             (P1clErrorClass | 45)
00092 #define P1clErrFailedToEmptyDatabase    (P1clErrorClass | 46)
00093
00094
00095 typedef struct
00096 {
00097     UInt8       Action;                     //Action can be ADD/Delete/Update
00098     UInt32      RecordUId;                  //UID of the Record that is effected
00099     UInt16      RecordIndex;                //Index of the record after that all the records are effeced.
00100     UInt32      CreatorId;                  //Creator Id of the caller application.
00101 }   P1clRecordDetails;
00102
00103 typedef P1clRecordDetails * P1clRecordDetailsPtr;
00104
00105
00106 enum _P1clListFieldType
00107 {
00108     P1clListStartTime,
00109     P1clListEndTime,
00110     P1clListStartSec,
00111     P1clListEndSec,
00112     P1clListStartedDayBefore,
00113     P1clListContinuesOnNextDay,
00114     P1clListRepeatsDaily,
00115     P1clListIsFirstOccurrence,
00116     P1clListIsLastOccurrence,
00117     P1clListUId,
00118     P1clListIndex
00119 };
00120
00121 typedef UInt8 P1clListFieldType;
00122
00123
00124 enum _P1clTimeZoneType
00125 {
00126     P1clDeviceTimeZone,     //Current Time Zone of the Device
00127     P1clEventTimeZone       //Time zone of the Event. I.e. Time zone of the event when it was created/updated.
00128 };
00129
00130 typedef UInt8 P1clTimeZoneType;
00131
00132
00133 enum _P1clActionType
00134 {
00135     P1clAdd,
00136     P1clUpdate,
00137     P1clDelete
00138 };
00139
00140 typedef UInt8 P1clActionType;
00141
00142
00143 enum _P1clAlarmUnitType
00144 {
00145     P1clMinutes,
00146     P1clHours,
00147     P1clDays
00148 };
00149
00150 typedef UInt8 P1clAlarmUnitType;
00151
00152
00153 enum _P1clRepeatTypes
00154 {
00155     P1clrepeatNone,
00156     P1clrepeatDaily,
00157     P1clrepeatWeekly,
00158     P1clrepeatMonthlyByDay,
00159     P1clrepeatMonthlyByDate,
00160     P1clrepeatYearly
00161 };
00162
00163 typedef UInt8 P1clRepeatTypes;
00164
00165
00166 enum _P1clFieldsTypes
00167 {
00168     P1clStartTime,
00169     P1clEndTime,
00170     P1clDateOfAppt,
00171     P1clrepeatEndDate,
00172     P1clrepeatFreq,
00173     P1clrepeatOn,
00174     P1clrepeatStartofWeek,
00175     P1clrepeatType,
00176     P1clalarmAdvance,
00177     P1clalarmUnit,
00178     P1clNote,
00179     P1clDescription,
00180     P1clLocation,
00181     P1clExceptionDate,
00182     P1clNumOfAttendee,
00183     P1clStartDateTimeOfAppt,                    //Date and time of the appointment in Sec elapsed from 12:00AM Jan 1, 1904
00184     P1clUID,                            //Place for the attributes These will be after P1ctaddressFieldsCount
00185     P1clIndex,
00186     P1clCategory,
00187     P1clColor,
00188     P1clPrivate,
00189     P1clBusy,
00190     P1clDirty,
00191     P1clTzuTC,
00192     P1clTzdSTStart,
00193     P1clTzdSTEnd,
00194     P1clTzdSTAdjustmentInMinutes,
00195     P1clTzCountry,
00196     P1clTzcustom,
00197     P1clTzLocName,
00198     P1clApptStatus,
00199     P1clMaxCategoryLength,
00200     P1clNumFields
00201 };
00202
00203 typedef UInt8 P1clFieldTypes;
00204
00205
00206 enum _P1clDeleteType
00207 {
00208     P1clNoType,                     //This will be true if the Appointment is non Repeat event
00209     P1clDeleteCurrent,              //This will indicate delete of the event for the current date(Date passed as param to the P1clDeleteAppt)
00210     P1clDeleteCurrentFuture,        //It will indicate the delete of all the future event of the Repeating event
00211     P1clDeleteAll,                  //It will indicate the delete of all the event of the Repeating event
00212     P1clRemoveAll                   //It will Remove the record from the DB same as DmRemoveRecord ()
00213
00214 };
00215
00216 typedef UInt8 P1clDeleteType;
00217
00218
00219 enum _P1clAttachType
00220 {
00221     P1clCreatorIDType,
00222     P1clBlobSizeType,
00223     P1clDataBlobType
00224 };
00225
00226 typedef UInt8 AttachType;
00227
00228
00229 enum _P1clAttendeeRoleType
00230 {
00231     P1cloriginator,                 // The person who set up the meeting.
00232     P1clrequiredAttendee,           // An attendee that the originator feels is required.
00233     P1cloptionalAttendee
00234 };
00235
00236 typedef UInt8 P1clAttendeeRoleType;
00237
00238
00239 enum _P1clAttendeeFieldType
00240 {
00241     P1clAttendeeRole,           // The person who set up the meeting.
00242     P1clAttendeeName,           // An attendee that the originator feels is required.
00243     P1clAttendeeEmail
00244 };
00245
00246 typedef UInt8 P1clAttendeeFieldType;
00247
00248
00249 enum _P1clTxnEntry
00250 {
00251     P1clNewEntry,
00252     P1clModifyEntry,
00253     P1clDeleteEntry
00254  };
00255
00256 typedef UInt8 P1clTxnEntry;
00257
00258
00259 // P1clApptStatus values set/getable via P1clSetUInt8Field() or P1clGetUInt8Field
00260 enum  _P1clApptStatusType
00261 {
00262     P1clShowAsBusy,                 // (default) Show as busy to strongly discourage conflicts.
00263     P1clShowAsFree,                 // Allow others to schedule meetings that conflict with this one.
00264     P1clShowAsTentative,            // Show as tentative to discourage conflicts.
00265     P1clShowAsOutOfOffice           // Show as out of office to even more strongly discourage conflicts.
00266 };
00267
00268 typedef UInt8 P1clApptStatusType;
00269
00270
00271 // Data from the time zone blob.
00272 // Event time zones are similar to locations library locations.
00273 // If no time zone blob is present, name will be NULL. Typically only some events will have a time zone blob.
00274 // If no time zone blob is present, the event is treated as being in the current device time zone.
00275 typedef struct {
00276     Int16               uTC;                                    // Offset from UTC in minutes.
00277     DSTType             dSTStart;                               // When daylight saving time starts (if observed).
00278     DSTType             dSTEnd;                                 // When daylight saving time ends (if observed).
00279     Int16               dSTAdjustmentInMinutes;                 // 0 = DST not observed, 60 = observed.
00280     CountryType         country;                                // Which country this region is in.
00281     UInt8               custom   : 1,                           // Whether this location was created by the user.
00282                         reserved : 7;                           // Usused.
00283     Char                name[apptMaxTimeZoneNameLen + 1];           // Name of location (typically city). Not a pointer!
00284 } ApptTimeZoneType;
00285
00286 /* *********************** Field Types
00287 P1clListStartTime           TimeType            Start time of the event. This time may be different than the event Start time if the device is in different time zone than the event.
00288
00289 P1clListEndTime             TimeType            End time of the event. This time may be different than the event End Time if the device is in different time zone than the event.
00290 P1clListStartSec            UInt32              Start Sec after Since 1904.
00291 P1clListEndSec              UInt32              End Sec after Since 1904.
00292 P1clListStartedDayBefore    UInt16              Spans midnight at start of day.
00293 P1clListContinuesOnNextDay  UInt16              Spans or ends at midnight end of day.
00294 P1clListRepeatsDaily        UInt16              Part of a daily repeating event.
00295 P1clListIsFirstOccurrence   UInt16              Part or first occurrence of repeating event.
00296 P1clListIsLastOccurrence    UInt16              Part of last occurrence of repeating event.
00297 P1clListUId                 UInt32              UId of the Event
00298 P1clListIndex               UInt16              Index of the Event
00299 P1clStartTime               TimeType            Start time of the event. This time may be different than the event Start time if the device is in different time zone than the event.
00300 P1clEndTime                 TimeType            End time of the event. This time may be different than the event End Time if the device is in different time zone than the event.   TimeType
00301 P1clDateOfAppt              DateType            Date of the Event.
00302 P1clrepeatEndDate           DateType            Repeating End Date of the Event.
00303 P1clrepeatFreq              UInt8               Frequency of the Repeating event.
00304 P1clrepeatOn                UInt8               This is valid for monthly by day and repeat Weekly.
00305 P1clrepeatStartofWeek       UInt8               Part of a daily repeating event.
00306 P1clrepeatType              UInt8               Part or first occurrence of repeating event.
00307 P1clalarmAdvance            Int8                Alarm advance the value will be -1 if no alarm is set.
00308 P1clalarmUnit               UInt8               Unit of the alarm Minute, hours, day
00309 P1clNote                    String(char*)       Notes attached to the event.
00310 P1clDescription             String(char*)       Description of the event.
00311 P1clLocation                String(char*)       Location of the event.
00312 P1clExceptionDate           Date                Which date in the repeating event is exception.
00313 P1clNumOfAttendee           UInt16              Number of attendee included in the event
00314 P1clStartDateTimeOfAppt     UInt32              Date and time of the appointment in Sec elapsed from 12:00AM Jan 1, 1904
00315 P1clUID                     UInt32              UId of the Event in Calendar DB.
00316 P1clIndex                   UInt16              Index of the Event in Calendar DB.
00317 P1clCategory                UInt16              Category of the Event.
00318 P1clColor                   UInt16              Color of the Event.
00319 P1clPrivate                 UInt8               Private attribute of the Event
00320 P1clBusy                    UInt8               Event is Busy or not. This refer to the busy in Data Manger term.   UInt8
00321 P1clDirty                   UInt8               Event is Dirty or not. This refer to the busy in Data Manger term.  UInt8
00322 P1clTzuTC                   Int16               Offset from UTC in minutes.
00323 P1clTzdSTStart              DSTType             When daylight saving time starts (if observed).
00324 P1clTzdSTEnd                DSTType             When daylight saving time ends (if observed).
00325 P1clTzdSTAdjustmentInMinutes    Int16           0 = DST not observed, 60 = observed.
00326 P1clTzCountry               CountryType         Which country this region is in.
00327 P1clTzcustom                UInt8               Whether this location was created by the user.
00328 P1clTzLocName               Char*               Name of location (typically city).
00329
00330
00331 */
00332
00333 typedef MemHandle       P1clApptHandle;
00334 typedef MemHandle       P1clAttachHandle;
00335 typedef MemHandle       P1clApptListHandle;
00336 typedef MemHandle       P1clSession;
00337 typedef MemHandle       P1clAttendeeHandle;         //Store info about the Attendee
00338 typedef MemHandle       P1clTxnIterator;
00339 typedef UInt32          P1clSyncSource;
00340 typedef UInt32          P1clPersistentID;
00341
00342 /*
00343     Unique id that represents a data source Id. Each SAM and SAS will need to provide a unique id for
00344     the data source that it is syncing with. Note that in the case where a SAM and SAS are
00345     syncing to the same data source (i.e. the same exchange server) they must use the same Data source id.
00346     For HotSyncing with Palm Desktops the data source id equates to the PCID used by HotSync
00347 */
00348 typedef UInt32      IDatSyncSource;             //Data Source Id
00349
00350 typedef Boolean (* DateBookCompAttachFucPtr) (void* pSource, void *SearchString);
00351
00352
00353     #define P1clTrapGetVersion                      (sysLibTrapCustom)
00354     #define P1clTrapCheckVersion                    (sysLibTrapCustom + 1)
00355     #define P1clTrapOpenSession                     (sysLibTrapCustom + 2)
00356     #define P1clTrapCloseSession                    (sysLibTrapCustom + 3)
00357     #define P1clTrapCreateHandle                    (sysLibTrapCustom + 4)
00358     #define P1clTrapReleaseHandle                   (sysLibTrapCustom + 5)
00359     #define P1clTrapGetAppt                         (sysLibTrapCustom + 6)
00360     #define P1clTrapGetFirstAppt                    (sysLibTrapCustom + 7)
00361     #define P1clTrapGetNextAppt                     (sysLibTrapCustom + 8)
00362     #define P1clTrapIsEmptyAppt                     (sysLibTrapCustom + 9)
00363     #define P1clTrapSplitRepeatingEvent             (sysLibTrapCustom + 10)
00364     #define P1clTrapApptFindNextRepeat              (sysLibTrapCustom + 11)
00365     #define P1clTrapApptRepeatsOnDate               (sysLibTrapCustom + 12)
00366     #define P1clTrapHasMultipleOccurences           (sysLibTrapCustom + 13)
00367     #define P1clTrapGetApptList                     (sysLibTrapCustom + 14)
00368     #define P1clTrapGetUInt16FromListHandle         (sysLibTrapCustom + 15)
00369     #define P1clTrapGetTimeFromListHandle           (sysLibTrapCustom + 16)
00370     #define P1clTrapGetUInt32FromListHandle         (sysLibTrapCustom + 17)
00371     #define P1clTrapGetBooleanFromListHandle        (sysLibTrapCustom + 18)
00372     #define P1clTrapGetApptFromListHandle           (sysLibTrapCustom + 19)
00373     #define P1clTrapUpdateAppt                      (sysLibTrapCustom + 20)
00374     #define P1clTrapAddAppt                         (sysLibTrapCustom + 21)
00375     #define P1clTrapDeleteAppt                      (sysLibTrapCustom + 22)
00376     #define P1clTrapFindNextAlarm                   (sysLibTrapCustom + 23)
00377     #define P1clTrapSortCalendar                    (sysLibTrapCustom + 24)
00378     #define P1clTrapFindSaveMatch                   (sysLibTrapCustom + 25)
00379     #define P1clTrapPurgeAppts                      (sysLibTrapCustom + 26)
00380     #define P1clTrapAttnForgetIt                    (sysLibTrapCustom + 27)
00381     #define P1clTrapApptPostTriggeredAlarms         (sysLibTrapCustom + 28)
00382     #define P1clTrapGetCalendarDBInfo               (sysLibTrapCustom + 29)
00383     #define P1clTrapCreateException                 (sysLibTrapCustom + 30)
00384     #define P1clTrapDeleteExceptionList             (sysLibTrapCustom + 31)
00385     #define P1clTrapFindConflict                    (sysLibTrapCustom + 32)
00386     #define P1clTrapGetStringField                  (sysLibTrapCustom + 33)
00387     #define P1clTrapSetStringField                  (sysLibTrapCustom + 34)
00388     #define P1clTrapGetUInt8Field                   (sysLibTrapCustom + 35)
00389     #define P1clTrapSetUInt8Field                   (sysLibTrapCustom + 36)
00390     #define P1clTrapGetInt8Field                    (sysLibTrapCustom + 37)
00391     #define P1clTrapSetInt8Field                    (sysLibTrapCustom + 38)
00392     #define P1clTrapGetUInt16Field                  (sysLibTrapCustom + 39)
00393     #define P1clTrapSetUInt16Field                  (sysLibTrapCustom + 40)
00394     #define P1clTrapGetInt16Field                   (sysLibTrapCustom + 41)
00395     #define P1clTrapSetInt16Field                   (sysLibTrapCustom + 42)
00396     #define P1clTrapGetUInt32Field                  (sysLibTrapCustom + 43)
00397     #define P1clTrapSetUInt32Field                  (sysLibTrapCustom + 44)
00398     #define P1clTrapGetDateTimeField                (sysLibTrapCustom + 45)
00399     #define P1clTrapSetDateTimeField                (sysLibTrapCustom + 46)
00400     #define P1clTrapGetTimeField                    (sysLibTrapCustom + 47)
00401     #define P1clTrapSetTimeField                    (sysLibTrapCustom + 48)
00402     #define P1clTrapGetDateField                    (sysLibTrapCustom + 49)
00403     #define P1clTrapSetDateField                    (sysLibTrapCustom + 50)
00404     #define P1clTrapGetDSTField                     (sysLibTrapCustom + 51)
00405     #define P1clTrapSetDSTField                     (sysLibTrapCustom + 52)
00406     #define P1clTrapGetNumOfException               (sysLibTrapCustom + 53)
00407     #define P1clTrapIsException                     (sysLibTrapCustom + 54)
00408     #define P1clTrapAddExceptionDate                (sysLibTrapCustom + 55)
00409     #define P1clTrapCreateAttendeeHandle            (sysLibTrapCustom + 56)
00410     #define P1clTrapReleaseAttendeeHandle           (sysLibTrapCustom + 57)
00411     #define P1clTrapGetFirstAttendee                (sysLibTrapCustom + 58)
00412     #define P1clTrapGetNextAttendee                 (sysLibTrapCustom + 59)
00413     #define P1clTrapGetAttendee                     (sysLibTrapCustom + 60)
00414     #define P1clTrapAddAttendee                     (sysLibTrapCustom + 61)
00415     #define P1clTrapUpdateAttendee                  (sysLibTrapCustom + 62)
00416     #define P1clTrapDeleteAttendee                  (sysLibTrapCustom + 63)
00417     #define P1clTrapGetAttendeeUInt8Field           (sysLibTrapCustom + 64)
00418     #define P1clTrapSetAttendeeUInt8Field           (sysLibTrapCustom + 65)
00419     #define P1clTrapGetAttendeeStringField          (sysLibTrapCustom + 66)
00420     #define P1clTrapSetAttendeeStringField          (sysLibTrapCustom + 67)
00421     #define P1clTrapCreateBlobHandle                (sysLibTrapCustom + 68)
00422     #define P1clTrapReleaseBlobHandle               (sysLibTrapCustom + 69)
00423     #define P1clTrapGetBlob                         (sysLibTrapCustom + 70)
00424     #define P1clTrapSetBlob                         (sysLibTrapCustom + 71)
00425     #define P1clTrapDeleteBlob                      (sysLibTrapCustom + 72)
00426     #define P1clTrapGetBlobData                     (sysLibTrapCustom + 73)
00427     #define P1clTrapSetBlobData                     (sysLibTrapCustom + 74)
00428     #define P1clTrapGetBlobCreatorId                (sysLibTrapCustom + 75)
00429     #define P1clTrapSetBlobCreatorId                (sysLibTrapCustom + 76)
00430     #define P1clTrapGetLastError                    (sysLibTrapCustom + 77)
00431     #define P1clTrapTxnPrepareSync                  (sysLibTrapCustom + 78)
00432     #define P1clTrapTxnGetChange                    (sysLibTrapCustom + 79)
00433     #define P1clTrapTxnGetNumChanges                (sysLibTrapCustom + 80)
00434     #define P1clTrapLogMarkAllCompleted             (sysLibTrapCustom + 81)
00435     #define P1clTrapTxnLogMarkCompleted             (sysLibTrapCustom + 82)
00436     #define P1clTrapTxnSyncComplete                 (sysLibTrapCustom + 83)
00437     #define P1clTrapDeleteServerId                  (sysLibTrapCustom + 84)
00438     #define P1clTrapGetApptFromServerId             (sysLibTrapCustom + 85)
00439     #define P1clTrapSetServerId                     (sysLibTrapCustom + 86)
00440     #define P1clTrapCategoryTruncateName            (sysLibTrapCustom + 87)
00441     #define P1clTrapCategorySetTriggerLabel         (sysLibTrapCustom + 88)
00442     #define P1clTrapCategoryGetNext                 (sysLibTrapCustom + 89)
00443     #define P1clTrapCategoryPopupList               (sysLibTrapCustom + 90)
00444     #define P1clTrapCategorySelect                  (sysLibTrapCustom + 91)
00445     #define P1clTrapCategoryEdit                    (sysLibTrapCustom + 92)
00446     #define P1clTrapCategoryDrawBullet              (sysLibTrapCustom + 93)
00447     #define P1clTrapCategorySetColor                (sysLibTrapCustom + 94)
00448     #define P1clTrapCategoryGetRGBColor             (sysLibTrapCustom + 95)
00449     #define P1clTrapCategoryGetColor                (sysLibTrapCustom + 96)
00450     #define P1clTrapCategoryGetUnusedColor          (sysLibTrapCustom + 97)
00451     #define P1clTrapCategorySetName                 (sysLibTrapCustom + 98)
00452     #define P1clTrapCategoryGetName                 (sysLibTrapCustom + 99)
00453     #define P1clTrapCategoryFind                    (sysLibTrapCustom + 100)
00454     #define P1clTrapCategoryFreeList                (sysLibTrapCustom + 101)
00455     #define P1clTrapCategoryCreateList              (sysLibTrapCustom + 102)
00456     #define P1clTrapCategoryGetVersion              (sysLibTrapCustom + 103)
00457     #define P1clTrapGiveAllTimedEventsTimeZones     (sysLibTrapCustom + 104)
00458     #define P1clTrapConvertFromDeviceTimeZone       (sysLibTrapCustom + 105)
00459     #define P1clTrapConvertToDeviceTimeZone         (sysLibTrapCustom + 106)
00460     #define P1clTrapCountryForTimeZoneAbbreviation  (sysLibTrapCustom + 107)
00461     #define P1clTrapApptTimeZoneAbbreviation        (sysLibTrapCustom + 108)
00462     #define P1clTrapApptTimeZoneCompare             (sysLibTrapCustom + 109)
00463     #define P1clTrapGetExtendedDescription          (sysLibTrapCustom + 110)
00464     #define P1clTrapHasExtendedDescription          (sysLibTrapCustom + 111)
00465     #define P1clTrapApptGetFirstOccurrence          (sysLibTrapCustom + 112)
00466     #define P1clTrapUpdateEventsWithDeletedTimeZone (sysLibTrapCustom + 113)
00467     #define P1clTrapUpdateEventsWithEditedTimeZone  (sysLibTrapCustom + 114)
00468     #define P1clTrapCopyStringField                 (sysLibTrapCustom + 115)
00469     #define P1clTrapDateExportVCal                  (sysLibTrapCustom + 116)
00470     #define P1clTrapNumRecordsInCategory            (sysLibTrapCustom + 117)
00471     #define P1clTrapSeekRecordInCategory            (sysLibTrapCustom + 118)
00472     #define P1clTrapDateSetGoToParams               (sysLibTrapCustom + 119)
00473     #define P1clTrapGetSessionInfo                  (sysLibTrapCustom + 120)
00474     #define P1clTrapCopyRepeatDescription           (sysLibTrapCustom + 121)
00475     #define P1clTrapGetConflict                     (sysLibTrapCustom + 122)
00476     #define P1clTrapGetDefaultTimeZone              (sysLibTrapCustom + 123)
00477     #define P1clTrapSetRepeateEndDate               (sysLibTrapCustom + 124)
00478     #define P1clTrapAddMultiDayEvent                (sysLibTrapCustom + 125)
00479     #define P1clTrapAddAllToTransactionLog          (sysLibTrapCustom + 126)
00480     #define P1clTrapSetExceptionExt                 (sysLibTrapCustom + 127)
00481     #define P1clTrapAddExceptionExt                 (sysLibTrapCustom + 128)
00482     #define P1clTrapGetExceptionDate                (sysLibTrapCustom + 129)
00483     #define P1clTrapDeleteRepeatInfo                (sysLibTrapCustom + 130)
00484     #define P1clTrapDeleteAlarmInfo                 (sysLibTrapCustom + 131)
00485     #define P1clTrapAccountReset                    (sysLibTrapCustom + 132)
00486     #define P1clTrapAddMultiDayEvent2               (sysLibTrapCustom + 133)
00487     #define P1clTrapTxnGetChange2                   (sysLibTrapCustom + 134)
00488     #define P1clTrapPurgeAllAppts                   (sysLibTrapCustom + 135)
00489     #define P1clTrapDeleteOldAndDuplicates          (sysLibTrapCustom + 136)
00490     #define P1clTrapAccountResetServerId            (sysLibTrapCustom + 137)
00491     #define P1clTrapAddLocalToTransactionLog        (sysLibTrapCustom + 138)
00492     #define P1clTrapSortCalendarSpecial             (sysLibTrapCustom + 139)
00493     #define P1clTrapTxnIsKnownDataSource            (sysLibTrapCustom + 140)
00494     #define P1clTrapSetServerIdByUniqueID           (sysLibTrapCustom + 141)
00495     #define P1clTrapPerformPostSyncFunctions        (sysLibTrapCustom + 142)
00496
00497 #endif
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:52 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » defaulthelperlibrary

DefaultHelperLib.h

Go to the documentation of this file.
00001 /******************************************************************************
00002  * Copyright (c) 2004 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  *****************************************************************************/
00005 /**
00006  * @ingroup Helper
00007  */
00008
00009 /**
00010  * @file  DefaultHelperLib.h
00011  * @brief Default Helper library owns control over the Default Helpers database.
00012  */
00013
00014 #ifndef __DEFAULTHELPERLIB__H__
00015 #define __DEFAULTHELPERLIB__H__
00016
00017 #ifdef __cplusplus
00018 extern "C" {
00019 #endif
00020
00021 #if defined( BUILDING_DEFAULTHELPERLIB ) || defined( BUILDING_ARM_LIB )
00022 #define DEFAULTHELPERLIB_TRAP( x ) /**<Helper macro */
00023 #else
00024 #define DEFAULTHELPERLIB_TRAP( x )  SYS_TRAP( x ) /**<Helper macro. */
00025 #endif
00026
00027 /// Standard library open function
00028 ///
00029 /// @param refNum: IN: Default helper library reference number (from SysLibFind()/SysLibLoad())
00030 /// @retval Err Error code.
00031 extern Err DefaultHelperLibOpen (UInt16 refNum)
00032                  DEFAULTHELPERLIB_TRAP (sysLibTrapOpen);
00033
00034 /// Standard library close function
00035 ///
00036 /// @param refNum: IN: Default helper library reference number (from SysLibFind()/SysLibLoad())
00037 /// @retval Err Error code.
00038 extern Err DefaultHelperLibClose (UInt16 refNum)
00039                  DEFAULTHELPERLIB_TRAP (sysLibTrapClose);
00040
00041 /// Standard library wake function
00042 ///
00043 /// @param refNum: IN: Default helper library reference number (from SysLibFind()/SysLibLoad())
00044 /// @retval Err Error code.
00045 extern Err DefaultHelperLibWake (UInt16 refNum)
00046                  DEFAULTHELPERLIB_TRAP (sysLibTrapWake);
00047
00048 /// Standard library sleep function
00049 ///
00050 /// @param refNum: IN: Default helper library reference number (from SysLibFind()/SysLibLoad())
00051 /// @retval Err Error code.
00052 extern Err DefaultHelperLibSleep (UInt16 refNum)
00053                  DEFAULTHELPERLIB_TRAP (sysLibTrapSleep);
00054
00055 /// Given a specified serviceID, return the creator type of the default helper
00056 /// application.
00057 ///
00058 /// @param refNum:              IN:  Default helper library reference number (from SysLibFind()/SysLibLoad())
00059 /// @param serviceID:           IN:  Type of service to get info from.
00060 /// @param defaultAppCreatorP   OUT: Upon return of the function, a pointer to the creator type of the default
00061 ///                                  application for the specified serviceID.
00062 /// @retval Err Error code.
00063 extern Err DefaultHelperLibGetDefaultHelper (UInt16 refNum,
00064                                       UInt32 serviceID,
00065                                       UInt32* defaultAppCreatorP)
00066                  DEFAULTHELPERLIB_TRAP (defaultHelperLibTrapGetDefaultHelper);
00067
00068 /// Given a specified serviceID, set the creator type of the default helper application.
00069 ///
00070 /// @param refNum:               IN: Default helper library reference number (from SysLibFind()/SysLibLoad())
00071 /// @param serviceID:            IN: Type of service to get info from.
00072 /// @param defaultAppCreator:    IN: Creator type of the application to be set as the default application for the
00073 ///                                  specified serviceID. If 0, then remove the helper service from the Default Apps
00074 ///                                  database.
00075 /// @retval Err Error code.
00076 extern Err DefaultHelperLibSetDefaultHelper (UInt16 refNum,
00077                                       UInt32 serviceID,
00078                                       UInt32 defaultAppCreator)
00079                  DEFAULTHELPERLIB_TRAP (defaultHelperLibTrapSetDefaultHelper);
00080
00081 #ifdef __cplusplus
00082 }
00083 #endif
00084
00085 #endif // __DEFAULTHELPERLIB__H__
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:52 2008 for Palm API Guide


Header Files » Incs » common » libraries » defaulthelperlibrary

DefaultHelperLibTypes.h

Go to the documentation of this file.
00001 /*******************************************************************************
00002  * Copyright (c) 2004-2005 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  ******************************************************************************/
00005 /**
00006  * @defgroup    Helper Default Helper Library
00007  * @brief       This library is used to provide support for applications to be
00008  *              the default handler for certain services on the device.
00009  *
00010  * This library is used in conjunction with Helper API from the Palm OS SDK.
00011  * Typically, an application which wants to be a default app to handle certain
00012  * services (SMS, Email, etc) will register itself in the following way:
00013  * - Check if the application is already the default handler for a particular
00014  *   service
00015  * - Call DefaultHelperLibSetDefaultHelper() if it's not already the default app.
00016  *   Please refer to Palm OS Helper API Service Class ID Constants for service ID.
00017  *
00018  * @{
00019  * @}
00020  */
00021 /**
00022  * @ingroup Helper
00023  */
00024
00025 /**
00026  * @file    DefaultHelperLibTypes.h
00027  * @version 1.0
00028  * @brief   Public 68K common header file for Default Helper Library API.
00029  *
00030  * This file contains the type information and constants for Default Helper Library.
00031  * <hr>
00032  */
00033
00034 #ifndef DEFAULT_HELPER_LIB_TYPES__H__
00035 #define DEFAULT_HELPER_LIB_TYPES__H__
00036
00037 #define      defaultHelperLibName               "DefaultHelper-HsDh"     /**< Default Helper Library name */
00038 #define      defaultHelperLibCreator            'HsDh'                   /**< Default Helper Library creator ID */
00039 #define      defaultHelperLibType               sysFileTLibrary          /**< Standard library type */
00040
00041 /**
00042  * @name Error Codes
00043  */
00044 /*@{*/
00045 #define      defaultHelperLibErrClass           0x9000
00046 #define      defaultHelperLibErrCreateDBFailed  (defaultHelperLibErrClass | 1)
00047 #define      defaultHelperLibErrNoMemory        (defaultHelperLibErrClass | 2)
00048 #define      defaultHelperLibErrNoHelperApp     (defaultHelperLibErrClass | 3)
00049 #define      defaultHelperLibErrDBNotFound      (defaultHelperLibErrClass | 4)
00050 #define      defaultHelperLibErrDBWriteFailed   (defaultHelperLibErrClass | 5)
00051 #define      defaultHelperLibErrUserCancel      (defaultHelperLibErrClass | 6)
00052 #define      defaultHelperLibErrBadParams       (defaultHelperLibErrClass | 7)
00053 /*@}*/
00054
00055 /**
00056  * @name Function Traps
00057  */
00058 /*@{*/
00059 #define       defaultHelperLibTrapGetDefaultHelper      sysLibTrapCustom
00060 #define       defaultHelperLibTrapSetDefaultHelper      sysLibTrapCustom+1
00061 /*@}*/
00062
00063 #endif  // DEFAULT_HELPER_LIB_TYPES__H__
00064
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:52 2008 for Palm API Guide


Header Files » Incs » 68k

68k → common Relation

File in Header Files » Incs » 68k | Includes file in Header Files » Incs » common
system / HsExt.h | system / HsExtCommon.h
system / HsExt.h | system / HsNavCommon.h
system / HsNav.h | system / HsNavCommon.h
libraries / telephony / HsPhone.h | libraries / telephony / HsPhoneAudioTypes.h
libraries / telephony / HsPhone.h | libraries / telephony / HsPhoneCallControlTypes.h
libraries / telephony / HsPhone.h | libraries / telephony / HsPhoneCDMATypes.h
libraries / telephony / HsPhone.h | libraries / telephony / HsPhoneErrors.h
libraries / telephony / HsPhone.h | libraries / telephony / HsPhoneEvent.h
libraries / telephony / HsPhone.h | libraries / telephony / HsPhoneGSMTypes.h
libraries / telephony / HsPhone.h | libraries / telephony / HsPhoneIOTATypes.h
libraries / telephony / HsPhone.h | libraries / telephony / HsPhoneMiscTypes.h
libraries / telephony / HsPhone.h | libraries / telephony / HsPhoneNetworkTypes.h
libraries / telephony / HsPhone.h | libraries / telephony / HsPhoneSecurityTypes.h
libraries / telephony / HsPhone.h | libraries / telephony / HsPhoneSMSTypes.h
libraries / telephony / HsPhone.h | libraries / telephony / HsPhoneTraps.h
libraries / telephony / HsPhone.h | libraries / telephony / HsPhoneTypes.h
libraries / telephony / HsPhoneCDMA.h | libraries / telephony / HsPhoneErrors.h
libraries / telephony / HsPhoneCDMA.h | libraries / telephony / HsPhoneTraps.h
libraries / telephony / HsPhoneCDMA.h | libraries / telephony / HsPhoneTypes.h
libraries / telephony / HsPhoneGSM.h | libraries / telephony / HsPhoneErrors.h
libraries / telephony / HsPhoneGSM.h | libraries / telephony / HsPhoneTraps.h
libraries / telephony / HsPhoneGSM.h | libraries / telephony / HsPhoneTypes.h
libraries / telephony / HsPhoneIOTA.h | libraries / telephony / HsPhoneErrors.h
libraries / telephony / HsPhoneIOTA.h | libraries / telephony / HsPhoneTraps.h
libraries / telephony / HsPhoneIOTA.h | libraries / telephony / HsPhoneTypes.h
libraries / telephony / HsPhoneLibrary.h | libraries / telephony / HsPhoneErrors.h
libraries / telephony / HsPhoneLibrary.h | libraries / telephony / HsPhoneTraps.h
libraries / telephony / HsPhoneLibrary.h | libraries / telephony / HsPhoneTypes.h
libraries / telephony / HsPhoneMisc.h | libraries / telephony / HsPhoneErrors.h
libraries / telephony / HsPhoneMisc.h | libraries / telephony / HsPhoneTraps.h
libraries / telephony / HsPhoneMisc.h | libraries / telephony / HsPhoneTypes.h
libraries / telephony / HsPhoneNetwork.h | libraries / telephony / HsPhoneErrors.h
libraries / telephony / HsPhoneNetwork.h | libraries / telephony / HsPhoneTraps.h
libraries / telephony / HsPhoneNetwork.h | libraries / telephony / HsPhoneTypes.h
libraries / telephony / HsPhonePower.h | libraries / telephony / HsPhoneErrors.h
libraries / telephony / HsPhonePower.h | libraries / telephony / HsPhoneTraps.h
libraries / telephony / HsPhonePower.h | libraries / telephony / HsPhoneTypes.h
libraries / telephony / HsPhoneSecurity.h | libraries / telephony / HsPhoneErrors.h
libraries / telephony / HsPhoneSecurity.h | libraries / telephony / HsPhoneTraps.h
libraries / telephony / HsPhoneSecurity.h | libraries / telephony / HsPhoneTypes.h
libraries / telephony / HsPhoneSMS.h | libraries / telephony / HsPhoneErrors.h
libraries / telephony / HsPhoneSMS.h | libraries / telephony / HsPhoneTraps.h
libraries / telephony / HsPhoneSMS.h | libraries / telephony / HsPhoneTypes.h
libraries / hssoundlib / HsSoundLib.h | libraries / hssoundlib / HsSoundLibCommon.h
libraries / netmaster / NetMasterLibrary.h | libraries / netmaster / NetMasterLibErrors.h
libraries / netmaster / NetMasterLibrary.h | libraries / netmaster / NetMasterLibTarget.h
libraries / netmaster / NetMasterLibrary.h | libraries / netmaster / NetMasterLibTraps.h
libraries / netpref / NetPrefLibrary.h | libraries / netpref / NetPrefLibErrors.h
libraries / netpref / NetPrefLibrary.h | libraries / netpref / NetPrefLibTarget.h
libraries / netpref / NetPrefLibrary.h | libraries / netpref / NetPrefLibTraps.h
libraries / codecpluginmgr / palmOneCodecPluginMgr.h | libraries / codecpluginmgr / palmOneCodecPluginMgrCommon.h
libraries / hirestimerlib / palmOneHiResTimer.h | libraries / hirestimerlib / palmOneHiResTimerCommon.h
libraries / pmkeylib / PmKeyLib.h | libraries / pmkeylib / PmKeyLibCommon.h
libraries / pmsysgadgetlib / PmSysGadgetLib.h | libraries / pmsysgadgetlib / PmSysGadgetLibCommon.h
libraries / pmuiutillib / PmUIUtilLib.h | system / HsNavCommon.h
libraries / pmuiutillib / PmUIUtilLib.h | libraries / pmuiutillib / PmUIUtilLibCommon.h
libraries / smarttextengine / SmartTextEngine.h | libraries / smarttextengine / SmartTextEngineDef.h
libraries / smarttextengine / SmartTextEngine.h | libraries / smarttextengine / SmartTextEngineErrors.h
libraries / smarttextengine / SmartTextEngine.h | libraries / smarttextengine / SmartTextEngineTraps.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:37 2008 for Palm API Guide


Header Files » Incs » 68k » libraries

libraries → common Relation

File in Header Files » Incs » 68k » libraries | Includes file in Header Files » Incs » common
telephony / HsPhone.h | libraries / telephony / HsPhoneAudioTypes.h
telephony / HsPhone.h | libraries / telephony / HsPhoneCallControlTypes.h
telephony / HsPhone.h | libraries / telephony / HsPhoneCDMATypes.h
telephony / HsPhone.h | libraries / telephony / HsPhoneErrors.h
telephony / HsPhone.h | libraries / telephony / HsPhoneEvent.h
telephony / HsPhone.h | libraries / telephony / HsPhoneGSMTypes.h
telephony / HsPhone.h | libraries / telephony / HsPhoneIOTATypes.h
telephony / HsPhone.h | libraries / telephony / HsPhoneMiscTypes.h
telephony / HsPhone.h | libraries / telephony / HsPhoneNetworkTypes.h
telephony / HsPhone.h | libraries / telephony / HsPhoneSecurityTypes.h
telephony / HsPhone.h | libraries / telephony / HsPhoneSMSTypes.h
telephony / HsPhone.h | libraries / telephony / HsPhoneTraps.h
telephony / HsPhone.h | libraries / telephony / HsPhoneTypes.h
telephony / HsPhoneCDMA.h | libraries / telephony / HsPhoneErrors.h
telephony / HsPhoneCDMA.h | libraries / telephony / HsPhoneTraps.h
telephony / HsPhoneCDMA.h | libraries / telephony / HsPhoneTypes.h
telephony / HsPhoneGSM.h | libraries / telephony / HsPhoneErrors.h
telephony / HsPhoneGSM.h | libraries / telephony / HsPhoneTraps.h
telephony / HsPhoneGSM.h | libraries / telephony / HsPhoneTypes.h
telephony / HsPhoneIOTA.h | libraries / telephony / HsPhoneErrors.h
telephony / HsPhoneIOTA.h | libraries / telephony / HsPhoneTraps.h
telephony / HsPhoneIOTA.h | libraries / telephony / HsPhoneTypes.h
telephony / HsPhoneLibrary.h | libraries / telephony / HsPhoneErrors.h
telephony / HsPhoneLibrary.h | libraries / telephony / HsPhoneTraps.h
telephony / HsPhoneLibrary.h | libraries / telephony / HsPhoneTypes.h
telephony / HsPhoneMisc.h | libraries / telephony / HsPhoneErrors.h
telephony / HsPhoneMisc.h | libraries / telephony / HsPhoneTraps.h
telephony / HsPhoneMisc.h | libraries / telephony / HsPhoneTypes.h
telephony / HsPhoneNetwork.h | libraries / telephony / HsPhoneErrors.h
telephony / HsPhoneNetwork.h | libraries / telephony / HsPhoneTraps.h
telephony / HsPhoneNetwork.h | libraries / telephony / HsPhoneTypes.h
telephony / HsPhonePower.h | libraries / telephony / HsPhoneErrors.h
telephony / HsPhonePower.h | libraries / telephony / HsPhoneTraps.h
telephony / HsPhonePower.h | libraries / telephony / HsPhoneTypes.h
telephony / HsPhoneSecurity.h | libraries / telephony / HsPhoneErrors.h
telephony / HsPhoneSecurity.h | libraries / telephony / HsPhoneTraps.h
telephony / HsPhoneSecurity.h | libraries / telephony / HsPhoneTypes.h
telephony / HsPhoneSMS.h | libraries / telephony / HsPhoneErrors.h
telephony / HsPhoneSMS.h | libraries / telephony / HsPhoneTraps.h
telephony / HsPhoneSMS.h | libraries / telephony / HsPhoneTypes.h
hssoundlib / HsSoundLib.h | libraries / hssoundlib / HsSoundLibCommon.h
netmaster / NetMasterLibrary.h | libraries / netmaster / NetMasterLibErrors.h
netmaster / NetMasterLibrary.h | libraries / netmaster / NetMasterLibTarget.h
netmaster / NetMasterLibrary.h | libraries / netmaster / NetMasterLibTraps.h
netpref / NetPrefLibrary.h | libraries / netpref / NetPrefLibErrors.h
netpref / NetPrefLibrary.h | libraries / netpref / NetPrefLibTarget.h
netpref / NetPrefLibrary.h | libraries / netpref / NetPrefLibTraps.h
codecpluginmgr / palmOneCodecPluginMgr.h | libraries / codecpluginmgr / palmOneCodecPluginMgrCommon.h
hirestimerlib / palmOneHiResTimer.h | libraries / hirestimerlib / palmOneHiResTimerCommon.h
pmkeylib / PmKeyLib.h | libraries / pmkeylib / PmKeyLibCommon.h
pmsysgadgetlib / PmSysGadgetLib.h | libraries / pmsysgadgetlib / PmSysGadgetLibCommon.h
pmuiutillib / PmUIUtilLib.h | system / HsNavCommon.h
pmuiutillib / PmUIUtilLib.h | libraries / pmuiutillib / PmUIUtilLibCommon.h
smarttextengine / SmartTextEngine.h | libraries / smarttextengine / SmartTextEngineDef.h
smarttextengine / SmartTextEngine.h | libraries / smarttextengine / SmartTextEngineErrors.h
smarttextengine / SmartTextEngine.h | libraries / smarttextengine / SmartTextEngineTraps.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:37 2008 for Palm API Guide


Header Files » Incs » common » libraries

libraries → system Relation

File in Header Files » Incs » common » libraries | Includes file in Header Files » Incs » common » system
telephony / HsPhoneErrors.h | HsErrorClasses.h
netmaster / NetMasterLibErrors.h | HsErrorClasses.h
pmkeylib / PmKeyLibCommon.h | palmOneSystemCommon.h
pmuiutillib / PmUIUtilLibCommon.h | palmOneSystemCommon.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:37 2008 for Palm API Guide


Header Files » Incs » 68k » system

system → common Relation

File in Header Files » Incs » 68k » system | Includes file in Header Files » Incs » common
HsExt.h | system / HsExtCommon.h
HsExt.h | system / HsNavCommon.h
HsNav.h | system / HsNavCommon.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:37 2008 for Palm API Guide


Header Files » Incs » common » system

system → libraries Relation

File in Header Files » Incs » common » system | Includes file in Header Files » Incs » common » libraries
HsAppLaunchCmd.h | telephony / HsPhoneCDMATypes.h
HsAppLaunchCmd.h | telephony / HsPhoneEvent.h
HsAppLaunchCmd.h | telephony / HsPhoneGSMTypes.h
HsAppLaunchCmd.h | telephony / HsPhoneIOTATypes.h
HsAppLaunchCmd.h | telephony / HsPhoneNetworkTypes.h
HsAppLaunchCmd.h | telephony / HsPhoneSecurityTypes.h
HsAppLaunchCmd.h | telephony / HsPhoneTypes.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:37 2008 for Palm API Guide


Header Files » Incs » common » system

system → telephony Relation

File in Header Files » Incs » common » system | Includes file in Header Files » Incs » common » libraries » telephony
HsAppLaunchCmd.h | HsPhoneCDMATypes.h
HsAppLaunchCmd.h | HsPhoneEvent.h
HsAppLaunchCmd.h | HsPhoneGSMTypes.h
HsAppLaunchCmd.h | HsPhoneIOTATypes.h
HsAppLaunchCmd.h | HsPhoneNetworkTypes.h
HsAppLaunchCmd.h | HsPhoneSecurityTypes.h
HsAppLaunchCmd.h | HsPhoneTypes.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:37 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » telephony

telephony → common Relation

File in Header Files » Incs » 68k » libraries » telephony | Includes file in Header Files » Incs » common
HsPhone.h | libraries / telephony / HsPhoneAudioTypes.h
HsPhone.h | libraries / telephony / HsPhoneCallControlTypes.h
HsPhone.h | libraries / telephony / HsPhoneCDMATypes.h
HsPhone.h | libraries / telephony / HsPhoneErrors.h
HsPhone.h | libraries / telephony / HsPhoneEvent.h
HsPhone.h | libraries / telephony / HsPhoneGSMTypes.h
HsPhone.h | libraries / telephony / HsPhoneIOTATypes.h
HsPhone.h | libraries / telephony / HsPhoneMiscTypes.h
HsPhone.h | libraries / telephony / HsPhoneNetworkTypes.h
HsPhone.h | libraries / telephony / HsPhoneSecurityTypes.h
HsPhone.h | libraries / telephony / HsPhoneSMSTypes.h
HsPhone.h | libraries / telephony / HsPhoneTraps.h
HsPhone.h | libraries / telephony / HsPhoneTypes.h
HsPhoneCDMA.h | libraries / telephony / HsPhoneErrors.h
HsPhoneCDMA.h | libraries / telephony / HsPhoneTraps.h
HsPhoneCDMA.h | libraries / telephony / HsPhoneTypes.h
HsPhoneGSM.h | libraries / telephony / HsPhoneErrors.h
HsPhoneGSM.h | libraries / telephony / HsPhoneTraps.h
HsPhoneGSM.h | libraries / telephony / HsPhoneTypes.h
HsPhoneIOTA.h | libraries / telephony / HsPhoneErrors.h
HsPhoneIOTA.h | libraries / telephony / HsPhoneTraps.h
HsPhoneIOTA.h | libraries / telephony / HsPhoneTypes.h
HsPhoneLibrary.h | libraries / telephony / HsPhoneErrors.h
HsPhoneLibrary.h | libraries / telephony / HsPhoneTraps.h
HsPhoneLibrary.h | libraries / telephony / HsPhoneTypes.h
HsPhoneMisc.h | libraries / telephony / HsPhoneErrors.h
HsPhoneMisc.h | libraries / telephony / HsPhoneTraps.h
HsPhoneMisc.h | libraries / telephony / HsPhoneTypes.h
HsPhoneNetwork.h | libraries / telephony / HsPhoneErrors.h
HsPhoneNetwork.h | libraries / telephony / HsPhoneTraps.h
HsPhoneNetwork.h | libraries / telephony / HsPhoneTypes.h
HsPhonePower.h | libraries / telephony / HsPhoneErrors.h
HsPhonePower.h | libraries / telephony / HsPhoneTraps.h
HsPhonePower.h | libraries / telephony / HsPhoneTypes.h
HsPhoneSecurity.h | libraries / telephony / HsPhoneErrors.h
HsPhoneSecurity.h | libraries / telephony / HsPhoneTraps.h
HsPhoneSecurity.h | libraries / telephony / HsPhoneTypes.h
HsPhoneSMS.h | libraries / telephony / HsPhoneErrors.h
HsPhoneSMS.h | libraries / telephony / HsPhoneTraps.h
HsPhoneSMS.h | libraries / telephony / HsPhoneTypes.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:37 2008 for Palm API Guide


Header Files » Incs » common » libraries » telephony

telephony → system Relation

File in Header Files » Incs » common » libraries » telephony | Includes file in Header Files » Incs » common » system
HsPhoneErrors.h | HsErrorClasses.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:37 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » hssoundlib

hssoundlib → common Relation

File in Header Files » Incs » 68k » libraries » hssoundlib | Includes file in Header Files » Incs » common
HsSoundLib.h | libraries / hssoundlib / HsSoundLibCommon.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:37 2008 for Palm API Guide


Header Files » Incs » common » libraries » netmaster

netmaster → system Relation

File in Header Files » Incs » common » libraries » netmaster | Includes file in Header Files » Incs » common » system
NetMasterLibErrors.h | HsErrorClasses.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:37 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » netmaster

netmaster → common Relation

File in Header Files » Incs » 68k » libraries » netmaster | Includes file in Header Files » Incs » common
NetMasterLibrary.h | libraries / netmaster / NetMasterLibErrors.h
NetMasterLibrary.h | libraries / netmaster / NetMasterLibTarget.h
NetMasterLibrary.h | libraries / netmaster / NetMasterLibTraps.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:37 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » netpref

netpref → common Relation

File in Header Files » Incs » 68k » libraries » netpref | Includes file in Header Files » Incs » common
NetPrefLibrary.h | libraries / netpref / NetPrefLibErrors.h
NetPrefLibrary.h | libraries / netpref / NetPrefLibTarget.h
NetPrefLibrary.h | libraries / netpref / NetPrefLibTraps.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:37 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » codecpluginmgr

codecpluginmgr → common Relation

File in Header Files » Incs » 68k » libraries » codecpluginmgr | Includes file in Header Files » Incs » common
palmOneCodecPluginMgr.h | libraries / codecpluginmgr / palmOneCodecPluginMgrCommon.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:37 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » hirestimerlib

hirestimerlib → common Relation

File in Header Files » Incs » 68k » libraries » hirestimerlib | Includes file in Header Files » Incs » common
palmOneHiResTimer.h | libraries / hirestimerlib / palmOneHiResTimerCommon.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:37 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » pmkeylib

pmkeylib → common Relation

File in Header Files » Incs » 68k » libraries » pmkeylib | Includes file in Header Files » Incs » common
PmKeyLib.h | libraries / pmkeylib / PmKeyLibCommon.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:37 2008 for Palm API Guide


Header Files » Incs » common » libraries » pmkeylib

pmkeylib → system Relation

File in Header Files » Incs » common » libraries » pmkeylib | Includes file in Header Files » Incs » common » system
PmKeyLibCommon.h | palmOneSystemCommon.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:37 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » pmsysgadgetlib

pmsysgadgetlib → common Relation

File in Header Files » Incs » 68k » libraries » pmsysgadgetlib | Includes file in Header Files » Incs » common
PmSysGadgetLib.h | libraries / pmsysgadgetlib / PmSysGadgetLibCommon.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:37 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » pmuiutillib

pmuiutillib → common Relation

File in Header Files » Incs » 68k » libraries » pmuiutillib | Includes file in Header Files » Incs » common
PmUIUtilLib.h | system / HsNavCommon.h
PmUIUtilLib.h | libraries / pmuiutillib / PmUIUtilLibCommon.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:37 2008 for Palm API Guide


Header Files » Incs » common » libraries » pmuiutillib

pmuiutillib → system Relation

File in Header Files » Incs » common » libraries » pmuiutillib | Includes file in Header Files » Incs » common » system
PmUIUtilLibCommon.h | palmOneSystemCommon.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:37 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » smarttextengine

smarttextengine → common Relation

File in Header Files » Incs » 68k » libraries » smarttextengine | Includes file in Header Files » Incs » common
SmartTextEngine.h | libraries / smarttextengine / SmartTextEngineDef.h
SmartTextEngine.h | libraries / smarttextengine / SmartTextEngineErrors.h
SmartTextEngine.h | libraries / smarttextengine / SmartTextEngineTraps.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:37 2008 for Palm API Guide


Header Files » Incs » 68k » system

FarCall.h

Go to the documentation of this file.
00001 /******************************************************************************
00002  *   Copyright :
00003  *    This is free software; you can redistribute it and/or modify
00004  *    it as you like.
00005  *
00006  *    This program is distributed in the hope that it will be useful,
00007  *    but WITHOUT ANY WARRANTY; without even the implied warranty of
00008  *    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
00009  ***************************************************************************/
00010
00011 /**
00012  * file     FarCall.h
00013  * @version 1.0
00014  * @date    06/06/2000
00015  *
00016  * Macros for declaring a function that will be located more than
00017  * 32K away from its caller.  This is trickier than it sounds, since
00018  * the branch instructions in the 68K don't support greater than 16-bit
00019  * jumps.
00020  *
00021  *  History:
00022  *  22-feb-2000  dia  Initial version
00023  *   08-mar-2000  dia  Fixed off-by-two error (don't know why it worked
00024  *                     before).
00025  *   06-Apr-2000  BP   Added support for gcc 2.95 and new callseq attribute
00026  *   11-Apr-2000  BP   Added FAR_PTR for function pointers
00027  *   06-jun-2000  dia  Fixed FAR_PTR--it wasn't loading right.
00028
00029  * <hr>
00030  */
00031
00032 #ifndef __FAR_CALL_H__
00033 #define __FAR_CALL_H__
00034
00035         // The following macro can be used to declare a function as a
00036         // FAR_CALL to another, normal function.
00037         //
00038         // Sample usage:
00039         //     Err AddrGetDatabase (DmOpenRef *addrPP, UInt16 mode);
00040         //     Err FarAddrGetDatabase (DmOpenRef *addrPP, UInt16 mode)
00041         //       FAR_CALL (AddrGetDatabase);
00042         //
00043         // Preferred usage (saves typing and enforces naming):
00044         //     typedef Err AddrGetDatabaseFnType (DmOpenRef *addrPP,
00045         //                                        UInt16 mode);
00046         //     FAR_DECLARE (AddrGetDatabase);
00047         //
00048         //
00049         // The way the code works is as follows:
00050         // 1. LEA     (funcName - .).L, A0
00051         //    Load the distance from the current PC to the function
00052         //    into A0.  This works because LEA allows you to specify a
00053         //    full 32-bit address.
00054         //    ...note that in order to force this to work as absolute
00055         //    and not as PC-relative, we can't use a standard LEA, so
00056         //    we need to hand-assemble the correct LEA and then use a
00057         //    DC.L to get the address.  Also note that the DC.Led
00058         //    address is 2 further than it would be if we just had
00059         //    an instruction (since the "." is the next instruction).
00060         // 2. JSR     -6(PC, A0.L)    ; aka -4(PC, A0.L) if your
00061         //                            ; assembler thinks differently.
00062         //    Do the actual jump. Note that the -6 is needed because
00063         //    the "." in instruction #1 is 6 bytes before the current
00064         //    PC in this instruction (remember, the PC to start the
00065         //    jump at is 2 bytes past the current instruction's start).
00066         //
00067         // This can also be looked at in assembly as:
00068         // 1. DC.W 0x41F9; DC.L (funcName - .)
00069         // 2. DC.W 0x4EBB; DC.W 0x88FA
00070
00071     #if (defined __GNUC__) && (EMULATION_LEVEL == EMULATION_NONE)
00072       #if __GNUC__ > 2 || (__GNUC__ == 2 && __GNUC_MINOR__ >= 95)
00073
00074         #define FAR_CALL(funcName)                        \
00075             __attribute__ (( __callseq__ (                \
00076                     "DC.W 0x41F9; "                       \
00077                     "DC.L " #funcName " - .; "            \
00078                     "JSR -6(%%PC, %%A0.L)") ))
00079
00080       #else         // GNUC < 2.95
00081
00082         #define FAR_CALL(funcName)                                       \
00083             __attribute__ (( inline (0x41F9, "DC.L " #funcName " - .",   \
00084                                      "JSR    -6(%%PC, %%A0.L)"     ) ))
00085
00086       #endif        // GNUC < 2.95
00087
00088       #define FAR_DECLARE(funcName)                               \
00089           funcName##FnType funcName;                              \
00090           funcName##FnType Far##funcName FAR_CALL (funcName)
00091
00092       // FAR_PTR:
00093       //   This macro can be used to reference a function
00094       //   pointer greater than 32k away from the current code.
00095       //   The assembly code is functionally similar to FAR_CALL.
00096       //
00097       // Sample Usage:
00098       //       void* far_start;
00099       //       FAR_PTR (&far_start, start);
00100       //
00101       //   where start() is a function within the current scope.
00102       //
00103       #define FAR_PTR(outPtr, funcPtr)               \
00104                   asm ("DC.W 0x41F9;"                \
00105                        "DC.L " #funcPtr " - .;"      \
00106                        "LEA -6(%%PC, %%A0.L), %0"    \
00107                          : "=a" (*(outPtr))          \
00108                          :                           \
00109                          : "a0" );
00110
00111     #else       // not GCC
00112
00113         // UNTESTED:
00114
00115         // In Metrowerks, just make it so that the macro evaluates to nothing
00116         // this will simply declare the far function but not do anything...
00117         #define FAR_CALL(funcName)
00118
00119         // UNTESTED:
00120
00121         // Declare the function, and make the far version just a #define...
00122         #define FAR_DECLARE(funcName)                               \
00123             funcName##FnType funcName;                              \
00124             static funcName##FnType * const Far##funcName = funcName                       \
00125             // blank line to absorb ";"
00126
00127         #define FAR_PTR(outPtr, funcPtr) \
00128             do { *(outPtr) = (funcPtr); } while (0)
00129
00130     #endif      // not GCC
00131
00132 #endif  // __FAR_CALL_H__
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:52 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » favoritesdblibrary

FavoritesDBLib.h

Go to the documentation of this file.
00001 /******************************************************************************
00002  * Copyright (c) 2004 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  *****************************************************************************/
00005 /**
00006  * @ingroup Favorites
00007  */
00008
00009 /**
00010  * @file  FavoritesDBLib.h
00011  * @brief Contains the API to control the Favorites DB.
00012  *
00013  */
00014
00015 #ifndef FAVORITESDB_LIB__H__
00016 #define FAVORITESDB_LIB__H__
00017
00018 /** List of different views in the phone applications. */
00019 typedef enum
00020 {
00021   favDBLibPhoneViewCallLog = 0, /**< call log view */
00022   favDBLibPhoneViewDialPad,     /**< dial pad view */
00023   favDBLibPhoneViewContacts     /**< contacts view */
00024 } FavDBLibPhoneViewEnum;
00025
00026 #ifdef __cplusplus
00027 extern "C" {
00028 #endif
00029
00030 /// Standard library open function
00031 ///
00032 /// @param refNum: IN: Favorites DB library reference number (from SysLibFind()/SysLibLoad())
00033 /// @retval Err Error code.
00034 Err FavDBLibOpen (UInt16 refNum)
00035                  SYS_TRAP (sysLibTrapOpen);
00036
00037 /// Standard library close function
00038 ///
00039 /// @param refNum: IN: Favorites DB library reference number (from SysLibFind()/SysLibLoad())
00040 /// @retval Err Error code.
00041 Err FavDBLibClose (UInt16 refNum)
00042                  SYS_TRAP (sysLibTrapClose);
00043
00044 /// Standard library wake function
00045 ///
00046 /// @param refNum: IN: Favorites DB library reference number (from SysLibFind()/SysLibLoad())
00047 /// @retval Err Error code.
00048 Err FavDBLibWake (UInt16 refNum)
00049                  SYS_TRAP (sysLibTrapWake);
00050
00051 /// Standard library sleep function
00052 ///
00053 /// @param refNum: IN: Favorites DB library reference number (from SysLibFind()/SysLibLoad())
00054 /// @retval Err Error code.
00055 Err FavDBLibSleep (UInt16 refNum)
00056                  SYS_TRAP (sysLibTrapSleep);
00057
00058 /// Create a new favorite application entry.
00059 ///
00060 /// @param refNum:      IN:  library reference number.
00061 /// @param position:    IN:  position of the new favorite app in the entries.
00062 /// @param labelP:      IN:  pointer to the label of the newly created entry.
00063 /// @param quickKey:    IN:  shortcut used to start favorite app.
00064 /// @param flags        IN:  no definition.
00065 /// @param appCreator   IN:  Creator ID of the new favorite app.
00066 /// @param indexP       OUT: index of the new entry in the DB.
00067 /// @retval Err Error code.
00068 Err FavDBLibNewAppFavorite (UInt16 refNum,
00069                             Word position,
00070                             CharPtr labelP,
00071                             WChar quickKey,
00072                             Word flags,
00073                             UInt32 appCreator,
00074                             WordPtr indexP)
00075                  SYS_TRAP (favoritesDBLibTrapNewAppFavorite);
00076
00077 /// Create a new favorite phone number.
00078 ///
00079 /// @param refNum:              IN:  library reference number.
00080 /// @param position:            IN:  position of the new favorite phone number in the entries.
00081 /// @param labelP:              IN:  pointer to the label of the newly created entry.
00082 /// @param quickKey:            IN:  shortcut used to call the number.
00083 /// @param flags:               IN:  no definition.
00084 /// @param numberP:             IN:  New favorite phone number in string.
00085 /// @param extraDigitsP:        IN:  Extra digits.
00086 /// @param autoDialExtraDigits: IN:  Always include extra digit when dialing if true.
00087 /// @param ringID:              IN:  Ring tone ID for this number.
00088 /// @param ringToneType:        IN:  Ring tone type for this number.
00089 /// @param indexP:              OUT: index of the new entry in the DB.
00090 /// @retval Err Error code.
00091 Err FavDBLibNewPhoneFavorite (UInt16 refNum,
00092                               Word position,
00093                               CharPtr labelP,
00094                               WChar quickKey,
00095                               Word flags,
00096                               CharPtr numberP,
00097                               CharPtr extraDigitsP,
00098                               Boolean autoDialExtraDigits,
00099                               UInt32 ringID,
00100                               UInt16 ringToneType,
00101                               WordPtr indexP)
00102                  SYS_TRAP (favoritesDBLibTrapNewPhoneFavorite);
00103
00104 /// Create a new favorite messaging destination.
00105 ///
00106 /// @param refNum:      IN:  library reference number.
00107 /// @param position:    IN:  position of the new favorite contact in the entries.
00108 /// @param labelP:      IN:  pointer to the label of the newly created entry.
00109 /// @param quickKey:    IN:  shortcut used to start composing message to the contact.
00110 /// @param flags:       IN:  No definition.
00111 /// @param contactIdP   IN:  Mobile number/ Email address of the new favorites messaging contact.
00112 /// @param indexP       OUT: index of the new entry in the DB.
00113 /// @retval Err Error code.
00114 Err FavDBLibNewMsgFavorite (UInt16 refNum,
00115                             Word position,
00116                             CharPtr labelP,
00117                             WChar quickKey,
00118                             Word flags,
00119                             CharPtr contactIdP,
00120                             WordPtr indexP)
00121                  SYS_TRAP (favoritesDBLibTrapNewMsgFavorite);
00122
00123 /// Create a new favorite URL.
00124 ///
00125 /// @param refNum:      IN:  library reference number.
00126 /// @param position:    IN:  position of the new favorite URL.
00127 /// @param labelP:      IN:  pointer to the label of the newly created entry.
00128 /// @param quickKey:    IN:  shortcut used to launch the URL.
00129 /// @param flags:       IN:  no definition.
00130 /// @param urlP:        IN:  the URL in string.
00131 /// @param indexP:      OUT: index of the new entry in the DB.
00132 /// @retval Err Error code.
00133 Err FavDBLibNewWebFavorite (UInt16 refNum,
00134                             Word position,
00135                             CharPtr labelP,
00136                             WChar quickKey,
00137                             Word flags,
00138                             CharPtr urlP,
00139                             WordPtr indexP)
00140                  SYS_TRAP (favoritesDBLibTrapNewWebFavorite);
00141
00142 /// Create a new favorite email entry.
00143 ///
00144 /// @param refNum:      IN:  library reference number.
00145 /// @param position:    IN:  position of the new favorite email in the entries.
00146 /// @param labelP:      IN:  pointer to the label of the newly created entry.
00147 /// @param quickKey:    IN:  shortcut used to start sending email to the new favorite .
00148 /// @param flags:       IN:  no definition.
00149 /// @param contactIdP:  IN:  Email address in string.
00150 /// @param indexP:      OUT: index of the new entry in the DB.
00151 /// @retval Err Error code.
00152 Err FavDBLibNewEmailFavorite (UInt16 refNum,
00153                               Word position,
00154                               CharPtr labelP,
00155                               WChar quickKey,
00156                               Word flags,
00157                               CharPtr contactIdP,
00158                               WordPtr indexP)
00159                  SYS_TRAP (favoritesDBLibTrapNewEmailFavorite);
00160
00161 /// Create a new favorite phone app view.
00162 ///
00163 /// @param refNum:          IN:  library reference number.
00164 /// @param position:        IN:  position of the new favorite in the entries.
00165 /// @param labelP:          IN:  pointer to the label of the newly created entry.
00166 /// @param quickKey:        IN:  shortcut used to launch phone app in the favorite view.
00167 /// @param flags:           IN:  no definition.
00168 /// @param phoneView:       IN:  See FavDBLibPhoneViewEnum for values.
00169 /// @param indexP:          OUT: index of the new entry in the DB.
00170 /// @retval Err Error code.
00171 Err
00172 FavDBLibNewPhoneViewFavorite (UInt16 refNum,
00173                               Word position,
00174                               CharPtr labelP,
00175                               WChar quickKey,
00176                               Word flags,
00177                               UInt16 phoneView,
00178                               WordPtr indexP)
00179                   SYS_TRAP (favoritesDBLibTrapNewPhoneViewFavorite);
00180
00181 /// No definition.
00182 ///
00183 /// @param refNum:      IN: library reference number.
00184 /// @param addressP:    IN: pointer to the address string to be resolved.
00185 /// @param kind:        IN: no definition.
00186 /// @retval CharPtr no definition.
00187 CharPtr
00188 FavDBLibResolveAddress (UInt16 refNum,
00189                         CharPtr addressP,
00190                         Word kind)
00191                   SYS_TRAP (favoritesDBLibTrapResolveAddress);
00192
00193 /// No definition.
00194 ///
00195 /// @param refNum:      IN: library reference number.
00196 /// @param indexP:      IN,OUT: no definition.
00197 /// @param offset:      IN: offset in the DB record indeces to start search from.
00198 /// @param direction:   IN: Forward/backward search from offset.
00199 /// @retval Boolean     True if found. Otherwise, false.
00200 Boolean
00201 FavDBLibSeekSpeedDialRecord(UInt16 refNum,
00202                             UInt16 * indexP,
00203                             Int16 offset,
00204                             Int16 direction)
00205                   SYS_TRAP (favoritesDBLibTrapSeekSpeedDialRecord);
00206
00207 /// Get the label from the favorite item given the record index.
00208 ///
00209 /// @param refNum:      IN:  library reference number.
00210 /// @param index:       IN:  index of the record to get label from.
00211 /// @param labelPP:     OUT: pointer to the label string.
00212 /// @retval Boolean True if found. Otherwise, false.
00213 Boolean
00214 FavDBLibGetRecordLabel (UInt16 refNum,
00215                            UInt16 index,
00216                            CharPtr *labelPP)
00217                   SYS_TRAP (favoritesDBLibTrapGetRecordLabel);
00218
00219 /// Get the unique ID of an entry given the record index in the Favorites DB.
00220 ///
00221 /// @param refNum:      IN:  library reference number.
00222 /// @param index:       IN:  index of the record to get unique id from.
00223 /// @param uniqueIdP:   OUT: unique ID of the record.
00224 /// @retval Err Error code.
00225 Err
00226 FavDBLibGetRecordId (UInt16 refNum,
00227                      UInt16 index,
00228                      UInt32 *uniqueIdP)
00229                   SYS_TRAP (favoritesDBLibTrapGetRecordId);
00230
00231 /// Determine whether item with keyId is in the favorites DB.
00232 ///
00233 /// @param refNum:      IN:  library reference number.
00234 /// @param keyId:       IN:  unique id of the item whose info is to be obtained.
00235 /// @param existsP:     OUT: true if item is found among favorites.
00236 /// @retval Err Error code.
00237 Err
00238 FavDBLibIsFavoriteWithId(UInt16 refNum,
00239                          UInt32 keyId,
00240                          BooleanPtr existsP)
00241                   SYS_TRAP (favoritesDBLibIsFavoriteWithId);
00242
00243 /// Get full info about the favorite phone number given the record index.
00244 ///
00245 /// @param refNum:              IN:  library reference number.
00246 /// @param index:               IN:  index of the item in the DB.
00247 /// @param numberPP:            OUT: pointer to the speed dial phone number.
00248 /// @param extraDigitsPP:       OUT: pointer to the extra digits in the phone number.
00249 /// @param autoExtraDigitsP:    OUT: if true, extra digits are auto-dialed.
00250 /// @param isVoicemailP:        OUT: if true, phone number is a voicemail number.
00251 /// @retval Boolean True if found.
00252 Boolean
00253 FavDBLibGetSpeedDialInfo (UInt16 refNum,
00254                            UInt16  index,
00255                            CharPtr *numberPP,
00256                            CharPtr *extraDigitsPP,
00257                            BooleanPtr autoExtraDigitsP,
00258                            BooleanPtr isVoicemailP)
00259                   SYS_TRAP (favoritesDBLibTrapGetSpeedDialInfo);
00260
00261 /// no definition.
00262 ///
00263 /// @param refNum:  IN:  library reference number.
00264 /// @param keyP:    IN:  no definition.
00265 /// @param nameP:   OUT: no definition.
00266 /// @retval Boolean True if found.
00267 Boolean
00268 FavDBLibLookupInSpeedDialDB (UInt16 refNum,
00269                              CharPtr keyP,
00270                              CharPtr *nameP)
00271                   SYS_TRAP (favoritesDBLibTrapLookupInSpeedDialDB);
00272
00273 #ifdef __cplusplus
00274 }
00275 #endif
00276
00277 #endif  // FAVORITESDB_LIB__H__
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:52 2008 for Palm API Guide


Header Files » Incs » common » libraries » favoritesdblibrary

FavoritesDBLibTypes.h

Go to the documentation of this file.
00001 /*******************************************************************************
00002  * Copyright (c) 2004-2005 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  ******************************************************************************/
00005 /**
00006  * @defgroup    Favorites Favorites Database Library
00007  * @brief       This library is used to provide support for applications to
00008  *              insert new entries to the Phone Favorites view on Treo 650
00009  *              devices.
00010  *
00011  * An application which wants to insert a new entry to the Phone application
00012  * Favorites view programmatically can call the appropriate FavDBNew*() API
00013  * depending on the favority type. Currently, this library supports adding
00014  * new application, phone number, sms destination, web url, email address,
00015  * and phone view.
00016  *
00017  * @{
00018  * @}
00019  */
00020 /**
00021  * @ingroup Favorites
00022  *
00023  */
00024
00025 /**
00026  * @file FavoritesDBLibTypes.h
00027  * @brief   Public 68K common header file for FavoritesDB library API.
00028  *
00029  * This file contains the FavoritesDB library constants and error codes.
00030  */
00031
00032 #ifndef FAVORITESDB_LIB_TYPES__H__
00033 #define FAVORITESDB_LIB_TYPES__H__
00034
00035 #define      favoritesDBLibName             "FavoritesDBLibrary" /**< Favorites DB library name */
00036 #define      favoritesDBLibCreator          'HsFD'               /**< Favorites DB library creator ID */
00037 #define      favoritesDBLibType             sysFileTLibrary      /**< Standard library type */
00038
00039 /**
00040  * @name Error Codes
00041  */
00042 /*@{*/
00043 #define      favoritesDBLibErrClass         0x9000
00044 #define      favoritesDBLibErrCreateDBFailed  (favoritesDBLibErrClass | 1)
00045 #define      favoritesDBLibErrNoMemory        (favoritesDBLibErrClass | 2)
00046 #define      favoritesDBLibErrDBNotFound      (favoritesDBLibErrClass | 4)
00047 #define      favoritesDBLibErrDBWriteFailed   (favoritesDBLibErrClass | 5)
00048 #define      favoritesDBLibErrUserCancel      (favoritesDBLibErrClass | 6)
00049 #define      favoritesDBLibErrBadParams       (favoritesDBLibErrClass | 7)
00050 /*@}*/
00051
00052 /**
00053  * @name Function Traps
00054  */
00055 /*@{*/
00056 #define       favoritesDBLibTrapNewAppFavorite        sysLibTrapCustom
00057 #define       favoritesDBLibTrapNewPhoneFavorite      sysLibTrapCustom+1
00058 #define       favoritesDBLibTrapNewMsgFavorite        sysLibTrapCustom+2
00059 #define       favoritesDBLibTrapNewWebFavorite        sysLibTrapCustom+3
00060 #define       favoritesDBLibTrapNewEmailFavorite      sysLibTrapCustom+4
00061 #define       favoritesDBLibTrapNewPhoneViewFavorite  sysLibTrapCustom+5
00062 #define       favoritesDBLibTrapResolveAddress        sysLibTrapCustom+6
00063 #define       favoritesDBLibTrapSeekSpeedDialRecord   sysLibTrapCustom+7
00064 #define       favoritesDBLibTrapGetRecordLabel        sysLibTrapCustom+8
00065 #define       favoritesDBLibTrapGetRecordId           sysLibTrapCustom+9
00066 #define       favoritesDBLibIsFavoriteWithId          sysLibTrapCustom+10
00067 #define       favoritesDBLibTrapGetSpeedDialInfo      sysLibTrapCustom+11
00068 #define       favoritesDBLibTrapLookupInSpeedDialDB   sysLibTrapCustom+12
00069 /*@}*/
00070
00071 #endif  // FAVORITESDB_LIB_TYPES__H__
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:52 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » filebrowser

FileBrowserLib68K.h

Go to the documentation of this file.
00001 /******************************************************************************
00002  * Copyright (c) 2004 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  *****************************************************************************/
00005 /**
00006  * @ingroup FileBrowser
00007  */
00008
00009 /**
00010  * @file    FileBrowserLib68K.h
00011  * @version 1.0
00012  * @brief This file contains the FileBrowser Library APIs
00013  *
00014  */
00015
00016
00017
00018 #ifndef __FILE_BROWSER_LIB_68K_H__
00019 #define __FILE_BROWSER_LIB_68K_H__
00020
00021
00022 /***********************************************************************
00023  *
00024  *   Functions
00025  *
00026  ***********************************************************************/
00027
00028 #ifdef NO_FILE_BROWSER_TRAPS
00029     #define FILE_BROWSER_LIB_TRAP(trapNum)
00030 #else
00031     #define FILE_BROWSER_LIB_TRAP(trapNum)  SYS_TRAP(trapNum)
00032 #endif
00033
00034 /// Standard File Browser library open function
00035 ///
00036 /// @param refNum: IN: library reference number
00037 /// @retval Err Error code
00038 Err FileBrowserLibOpen(UInt16 refNum)
00039     FILE_BROWSER_LIB_TRAP(sysLibTrapOpen);
00040     // Call this before any other entry points.
00041
00042 /// Standard File Browser library close function
00043 ///
00044 /// @param refNum: IN: library reference number
00045 /// @retval Err Error code
00046 Err FileBrowserLibClose(UInt16 refNum)
00047     FILE_BROWSER_LIB_TRAP(sysLibTrapClose);
00048     // Call this when you're done.
00049
00050 /// Standard File Browser library sleep function
00051 ///
00052 /// @param refNum: IN: library reference number
00053 /// @retval Err Error code
00054 Err FileBrowserLibSleep(UInt16 refNum)
00055     FILE_BROWSER_LIB_TRAP(sysLibTrapSleep);
00056     // Called automatically when the device turns off.
00057
00058 /// Standard File Browser library wake function
00059 ///
00060 /// @param refNum: IN: library reference number
00061 /// @retval Err Error code
00062 Err FileBrowserLibWake(UInt16 refNum)
00063     FILE_BROWSER_LIB_TRAP(sysLibTrapWake);
00064     // Called automatically when the device turns on.
00065
00066 /// Entry point to handle an event
00067 ///
00068 /// @param refNum: IN: library reference number
00069 /// @param eventP: IN: the event to handle
00070 /// @retval Boolean True if the event was handled and should not be passed
00071 ///                 to a higher level handler.
00072 Boolean FileBrowserLibHandleEvent(UInt16 refNum, EventType *eventP)
00073     FILE_BROWSER_LIB_TRAP(exgLibTrapHandleEvent);
00074
00075 /// Entry point to establish an exchange connection
00076 ///
00077 /// @param refNum:  IN: library reference number
00078 /// @param socketP: IN: the exchange socket
00079 /// @retval Err Error code.
00080 Err FileBrowserLibConnect(UInt16 refNum, ExgSocketType *socketP)
00081     FILE_BROWSER_LIB_TRAP(exgLibTrapConnect);
00082
00083 /// Entry point to accept an incoming connection
00084 ///
00085 /// @param refNum:  IN: library reference number
00086 /// @param socketP: IN: the exchange socket
00087 /// @retval Err Error code.
00088 Err FileBrowserLibAccept(UInt16 refNum, ExgSocketType *socketP)
00089     FILE_BROWSER_LIB_TRAP(exgLibTrapAccept);
00090
00091 /// Entry point to disconnect an outgoing or incoming
00092 /// connection and clean up afterwards.
00093 ///
00094 /// @param refNum:  IN: library reference number
00095 /// @param socketP: IN: the exchange socket
00096 /// @param err:     IN: OS error code to report to user
00097 /// @retval Err Error code.
00098 Err FileBrowserLibDisconnect(UInt16 refNum, ExgSocketType *socketP,
00099     Err err)
00100     FILE_BROWSER_LIB_TRAP(exgLibTrapDisconnect);
00101
00102 /// Entry point to start a Put operation. Creates a
00103 /// connection if one doesn't already exist.
00104 ///
00105 /// @param refNum:  IN: library reference number
00106 /// @param socketP: IN: the exchange socket
00107 /// @retval Err Error code.
00108 Err FileBrowserLibPut(UInt16 refNum, ExgSocketType *socketP)
00109     FILE_BROWSER_LIB_TRAP(exgLibTrapPut);
00110
00111 /// Entry point to start a Get operation
00112 ///
00113 /// @param refNum:  IN: library reference number
00114 /// @param socketP: IN: the exchange socket
00115 /// @retval Err Error code.
00116 Err FileBrowserLibGet(UInt16 refNum, ExgSocketType *socketP)
00117     FILE_BROWSER_LIB_TRAP(exgLibTrapGet);
00118
00119 /// Entry point to send data for an object
00120 ///
00121 /// @param refNum:  IN: library reference number
00122 /// @param socketP: IN: the exchange socket
00123 /// @param bufP:    IN: the buffer containing data to send
00124 /// @param bufLen:  IN: bytes to send
00125 /// @param errP:    OUT: passed back error code
00126 /// @retval UInt32 number of bytes sent.
00127 UInt32 FileBrowserLibSend(UInt16 refNum, ExgSocketType *socketP,
00128     const void *bufP, UInt32 bufLen, Err *errP)
00129     FILE_BROWSER_LIB_TRAP(exgLibTrapSend);
00130
00131 /// Entry point to receive data for an object
00132 ///
00133 /// @param refNum:  IN:  the library reference number
00134 /// @param socketP: IN:  the exchange socket
00135 /// @param bufP:    OUT: buffer to store received data
00136 /// @param bufSize: IN:  size of buffer
00137 /// @param errP:    OUT: passed back error code
00138 /// @retval UInt32 number of bytes received.
00139 UInt32 FileBrowserLibReceive(UInt16 refNum, ExgSocketType *socketP,
00140     void *bufP, UInt32 bufSize, Err *errP)
00141     FILE_BROWSER_LIB_TRAP(exgLibTrapReceive);
00142
00143 /// Entry point to execute various commands.
00144 ///
00145 /// @param refNum:      IN: the library reference number
00146 /// @param op:          IN: command to execute
00147 /// @param valueP:      IN,OUT: buffer with incoming or outgoing data
00148 /// @param valueLenP:   IN,OUT: size of buffer and size of result (not used for some operations)
00149 /// @retval Err Error code.
00150 Err FileBrowserLibControl(UInt16 refNum, UInt16 op, void *valueP,
00151     UInt16 *valueLenP)
00152     FILE_BROWSER_LIB_TRAP(exgLibTrapControl);
00153
00154 /// Entry point to do a Request operation (Unimplemented)
00155 ///
00156 /// @param refNum:  IN: the library reference number
00157 /// @param socketP: IN: the exchange socket
00158 /// @retval Err Error code.
00159 Err FileBrowserLibRequest(UInt16 refNum, ExgSocketType *socketP)
00160     FILE_BROWSER_LIB_TRAP(exgLibTrapRequest);
00161
00162 /// Pop up an Open dialog
00163 ///
00164 /// @param refNum:          IN: library reference number
00165 /// @param volRefNumP:      IN: the default volume and the result
00166 /// @param path:            IN: the default path and the result (must be
00167 ///                             at least kFileBrowserLibPathBufferSize bytes).
00168 /// @param numExtensions:   IN: number of extensions to display
00169 /// @param extensions:      IN: compatible extensions to display
00170 /// @param fileType:        IN: optional MIME type or extension to get
00171 ///                             default directory on each volume
00172 /// @param title:           IN: open dialog title
00173 /// @param flags:           IN: any combo of kOpenFlag* flags
00174 /// @retval Boolean True if a file is selected
00175 Boolean FileBrowserLibShowOpenDialog(UInt16 refNum,
00176     UInt16 *volRefNumP, Char *path, UInt16 numExtensions,
00177     const Char **extensions, const Char *fileType, const Char *title,
00178     UInt32 flags)
00179     FILE_BROWSER_LIB_TRAP(kFileBrowserLibTrapShowOpenDialog);
00180
00181 /// Pop up a Save dialog
00182 ///
00183 /// @param refNum:          IN: library reference number
00184 /// @param volRefNumP:      IN: the default volume and the result
00185 /// @param path:            IN: the default path and the result (must be at least
00186 ///                             kFileBrowserLibPathBufferSize bytes)
00187 /// @param numExtensions:   IN: number of extensions to display
00188 /// @param extensions:      IN: valid extensions to display
00189 /// @param defaultExtension     IN: default extension to display initially
00190 /// @param fileType:        IN: optional MIME type or extension to get
00191 ///                             default directory on each volume
00192 /// @param title:           IN: open dialog title
00193 /// @param flags:           IN: any combo of kSaveAsFlag* flags
00194 /// @retval Boolean True if a file is saved
00195 Boolean FileBrowserLibShowSaveAsDialog(UInt16 refNum, UInt16 *volRefNumP,
00196     Char *path, UInt16 numExtensions, const Char **extensions,
00197     const Char *defaultExtension, const Char *fileType,
00198     const Char *title, UInt32 flags)
00199     FILE_BROWSER_LIB_TRAP(kFileBrowserLibTrapShowSaveAsDialog);
00200
00201 /// Entry point to parse a URL (file:) received in a
00202 /// sysAppLaunchCmdExgReceiveData launch resulting from the
00203 /// open dialog.  Pass NULL for unwanted results. Caller must
00204 /// free the others.
00205 ///
00206 /// @param refNum:      IN:  library reference number
00207 /// @param urlP:        IN:  URL to be parsed
00208 /// @param volRefNumP:  OUT: pass back the file's volume's volRefNum
00209 /// @param filePathP:   OUT: pass back the file's path
00210 /// @retval Err Error code
00211 Err FileBrowserLibParseFileURL(UInt16 refNum,
00212     const Char *urlP, UInt16 *volRefNumP, Char **filePathP)
00213     FILE_BROWSER_LIB_TRAP(kFileBrowserLibTrapParseFileURL);
00214
00215 /// Entry point to pop up a dialog in which multiple files can be selected
00216 ///
00217 /// @param refNum:          IN: library reference number
00218 /// @param volRefNumP:      IN: the default volume and the result
00219 /// @param path:            IN: the default path
00220 /// @param numFilesP        OUT: number of files selected
00221 /// @param maxFiles         IN: maximum number of files allowed to select
00222 /// @param filenames        OUT: names of files selected
00223 /// @param numExtensions:   IN: number of extensions to display
00224 /// @param extensions:      IN: compatible extensions to display
00225 /// @param fileType:        IN: optional MIME type or extension to get
00226 ///                             default directory on each volume
00227 /// @param title:           IN: open dialog title
00228 /// @param flags:           IN: any combo of kOpenFlag* flags
00229 /// @retval Boolean True if one or more files are selected
00230 Boolean FileBrowserLibShowMultiselectDialog(UInt16 refNum,
00231     UInt16 *volRefNumP, Char *path, UInt16 *numFilesP,
00232     UInt16 maxFiles, Char **filenames, UInt16 numExtensions,
00233     const Char **extensions, const Char *fileType,
00234     const Char *title, UInt32 flags)
00235     FILE_BROWSER_LIB_TRAP(kFileBrowserLibTrapShowMultiselectDialog);
00236
00237 #undef FILE_BROWSER_LIB_TRAP
00238
00239 #endif // __FILE_BROWSER_LIB_68K_H__
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:52 2008 for Palm API Guide


Header Files » Incs » common » libraries » filebrowser

FileBrowserLibCommon.h

Go to the documentation of this file.
00001 /*******************************************************************************
00002  * Copyright (c) 2004-2005 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  ******************************************************************************/
00005 /**
00006  * @defgroup    FileBrowser File Browser Library
00007  * @brief       This library is used to provide support for Files application
00008  *              integration.
00009  *
00010  * Applications which want to utilize the File Browser UI or register itself with
00011  * the Files application on Tungsten devices should use this library to do so.
00012  * Registration with the Files app has to be done in addition to registration with
00013  * the Exchange Library.
00014  *
00015  * Registering with the Files application is also done using Exchange Library but
00016  * with palmOne defined registration IDs (exgRegEditCreatorID, etc). This will enable
00017  * the application to be launched automatically when a certain file type or extension
00018  * is selected on the Files app. Developers can also use the APIs available in this
00019  * library to present File Browser UI in their own application to the user (open and
00020  * save dialogs).
00021  *
00022  * @{
00023  * @}
00024  */
00025 /**
00026  * @ingroup FileBrowser
00027  */
00028
00029 /**
00030  * @file    FileBrowserLibCommon.h
00031  * @version 1.0
00032  * @brief   Public 68K common header file for File Browser library API.
00033  *
00034  * This file contains the File Browser Library common definitions and error codes.
00035  * <hr>
00036  */
00037
00038
00039 #ifndef __FILE_BROWSER_LIB_COMMON_H__
00040 #define __FILE_BROWSER_LIB_COMMON_H__
00041
00042 #include <ExgLib.h>
00043
00044 /**
00045  * Use SysLibFind to find this library. There is no need to load it.
00046  * This must match the database name since this is an Exchange
00047  * Library In Application (ELIA).
00048  */
00049 #define kFileBrowserLibName        "FileBrowser-PFil"
00050
00051 #define kFileBrowserLibFlagOneVolume        0x00000001UL  /**< Flags for Open and Save As dialogs*/
00052
00053 /** @name Flags for Open dialog */
00054 /*@{*/
00055 #define kFileBrowserLibFlagNoFiles          0x00000002UL  /**< no files; only folders */
00056 #define kFileBrowserLibFlagNoFolders        0x00000004UL  /**< no folders; only files */
00057 /*@}*/
00058
00059 /** @name Flags for Save As dialog */
00060 /*@{*/
00061 #define kFileBrowserLibFlagPromptOverwrite  0x00000008UL  /**< warn before replacing */
00062 #define kFileBrowserLibFlagRequireExtension 0x00000010UL  /**< only given extensions */
00063 #define kFileBrowserLibFlagNoNewFolder      0x00000020UL  /**< no New Folder button */
00064 /*@}*/
00065
00066 /** @name Flags for Open & Save As dialog */
00067 /*@{*/
00068 #define kFileBrowserLibFlagNoDirChange      0x00000040UL  /**< stay within tree */
00069 #define kFileBrowserLibFlagNoSubDir         0x00000080UL  /**< stay within folder */
00070 /*@}*/
00071
00072 // Buffer sizes
00073 #define kFileBrowserLibMaxPathLength        2047  // room for most paths
00074 #define kFileBrowserLibPathBufferSize       (kFileBrowserLibMaxPathLength + 1)
00075
00076 // Exchange Manager registry enums
00077 //<><> Remove when PalmSource adds these to their SDK
00078 #define exgRegEditCreatorID                 0xff7b  // creator ID registry
00079 #define exgRegEditExtensionID               0xff7d  // filename extension registry
00080 #define exgRegEditTypeID                    0xff7e  // MIME type registry
00081
00082 // ExgControl opcodes
00083 #define kFileBrowserLibCtlGetVersion        exgLibCtlSpecificOp  // API version
00084
00085 // File Browser library API versions
00086 #define kFileBrowserLibAPIVersion0          0  // original version on Tungsten T5
00087 #define kFileBrowserLibAPIVersion1          1  // version with multiselect
00088
00089 /** @name Error Codes */
00090 /*@{*/
00091 #define kFileBrowserLibErrorClass       (oemErrorClass + 0x0400)
00092 #define kFileBrowserLibErrStillOpen     (kFileBrowserLibErrorClass | 0x01)
00093 #define kFileBrowserLibErrPathTooLong   (kFileBrowserLibErrorClass | 0x02)
00094 #define kFileBrowserLibErrMemError      (kFileBrowserLibErrorClass | 0x03)
00095 #define kFileBrowserLibErrCantFind      (kFileBrowserLibErrorClass | 0x04)
00096 #define kFileBrowserLibErrInternal      (kFileBrowserLibErrorClass | 0x05)
00097 #define kFileBrowserLibErrCantOpen      (kFileBrowserLibErrorClass | 0x06)
00098 #define kFileBrowserLibErrCantParse     (kFileBrowserLibErrorClass | 0x07)
00099 /*@}*/
00100
00101 /** @name Function Traps */
00102 /*@{*/
00103 #define kFileBrowserLibTrapShowOpenDialog           (exgLibTrapLast)
00104 #define kFileBrowserLibTrapShowSaveAsDialog         (exgLibTrapLast + 1)
00105 #define kFileBrowserLibTrapParseFileURL             (exgLibTrapLast + 2)
00106 #define kFileBrowserLibTrapShowMultiselectDialog    (exgLibTrapLast + 3)
00107 /*@}*/
00108
00109 #endif // __FILE_BROWSER_LIB_COMMON_H__
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:52 2008 for Palm API Guide


  • All
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- j -

  • JPEGMode : PalmImageJPEGEncodeParamType
  • jumpToObjectIDHint : FrmNavHeaderTag
  • justSend : _HelperServiceMMSDetailsType
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:08 2008 for Palm API Guide


  • All
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- k -

  • key : NetWepKey , PhnKeyPressedParams
  • keyFrame : PalmVideoMPEG4EncodeParamType
  • keyIndex : NetServicesProfile , NetServicesProfileV1 , NetWepKey
  • keyLength : NetWepKey
  • keyPressed : PhnEventType::Data
  • kind : PhnIndicationType , Address
  • knownCallerTone : SoundPreferencePhone
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:08 2008 for Palm API Guide


  • All
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- l -

  • labelOffset : PhnSATEventMenuRec
  • lastByte : tagSndFileStreamData
  • lastEntry : PhnPhoneBookInfoType
  • lat : PhnPDDataType
  • latitude : PosType
  • launchCode : PhnEventType
  • launchParams : PhnEventType
  • launchUrl : webBrowserMinimalModeLaunchInfo , webBrowserURLWithSvcIDLaunchInfo
  • launchView : SoundPrefsLaunchCmdParamType
  • leftPosition : PalmImageGIFFrameParamType
  • len : HS_HTTPLibSplit_
  • length : WAPNotificationEventType , PhnLibLengthInfoType
  • life_timer : PhnOnexMipRRQType
  • lineNumber : PhnConnectionType , PhnMsgBoxDataType , PhoneAppLaunchCmdGetALSLineNumberType , PhnSubscriberAddrInfo
  • linkP : NetworkDeviceQueryData
  • list : PhnMovedMsgsParamsType
  • listElementSizeInBytes : FrmNavHeaderTag
  • listItems : _pluginQueryParams
  • listMaxSizeExt : _pluginGetInfoParams
  • listMaxSizeMime : _pluginGetInfoParams
  • listNames : _pluginExtendedQueryParams
  • listPtrs : _pluginExtendedQueryParams
  • listReceiveFileExt : _pluginGetInfoParams
  • listReceiveMIMEtypes : _pluginGetInfoParams
  • listSendFileExt : _pluginGetInfoParams
  • listSendMIMEtypes : _pluginGetInfoParams
  • listSendNames : _pluginGetInfoParams
  • loc_uncertainty_a : PhnPDDataType
  • loc_uncertainty_ang : PhnPDDataType
  • loc_uncertainty_p : PhnPDDataType
  • loc_uncertainty_v : PhnPDDataType
  • localColorBits : PalmImageGIFFrameParamType
  • localColorTable : PalmImageGIFFrameParamType
  • locationData : LocsLibNotifyDataTag
  • locationDataNew : LocsLibNotifyLocsDataTag
  • locationNameOldP : LocsLibNotifyLocsDataTag
  • locationP : LocsLibSelLocsTag
  • lock : CamLibStreamTag
  • loginNeeded : PhnSATEventDataSvc
  • lon : PhnPDDataType
  • longitude : PosType
  • longname : PhnOperatorType
  • lookup : AddrPhonebookAppParamsType
  • lookupString : AddrCallerIDParamsType
  • lookupStrP : AddrPhonebookAppParamsType
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:08 2008 for Palm API Guide


  • All
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- m -

  • mainParams : MailAddRecordParamsTypePlus
  • majorResult : BGResult
  • mapArr : PmSysGadgetBbutResourceType , HsBigButtonReourceType
  • matchFound : AddrHsLookupUserDataType , AddrHsLookupUserDataV2Type
  • max_message_size : _PhnLibMMSServerInfo
  • maxConnections : PhnRadioStateType
  • maximumBytes : tagSndFileStreamData
  • maximumMilliseconds : tagSndFileStreamData
  • maxNameLength : PhnPhoneBookInfoType
  • maxNum : NBSNotificationEventType
  • maxNumberLength : PhnPhoneBookInfoType
  • maxRate : PalmAudioQCELPParamType
  • maxRetries : _PhnLibMMSServerInfo
  • maxSize : ParsedInfoList , PhnSATEventGetInput
  • maxSockets : HS_HTTPLibAppinfo_
  • maxValue : LcdOverlayLibSettingTag , CamLibSettingTag
  • maxVol : HsSndPortInfo
  • mData : AddressAppRecord
  • MemoryFile : _PalmPhotoFileLocation
  • message : _HelperServiceMMSDetailsType
  • messageCount : PhnMsgBoxDataType
  • messageTone : SoundPreferenceIM , SoundPreferenceSMS , SoundPreferenceMMS
  • mHeader : AddressAppRecord
  • mID : AddressAppRecord
  • MIMEtype : _pluginExtendedQueryParams , _pluginParams , _pluginQueryParams
  • mimeType : _HelperServiceMMSObjectType
  • MIMEtype : _pluginSendParams
  • minRate : PalmAudioQCELPParamType
  • minSize : PhnSATEventGetInput
  • minute : Coordinate
  • minValue : CamLibSettingTag , LcdOverlayLibSettingTag
  • minVol : HsSndPortInfo
  • mipSessionFailReason : PhnEventType::Data
  • mipSessionType : PhnOneXStatus
  • miscData : ParsedInfo
  • miscDbgRpt : PhnEventType::Data
  • miscUpdate : PhnMiscDbgRptType
  • mLocked : AddressAppRecord
  • mmiBarring : PhnMMIEntryType , PhnMMIResultType
  • mmiCallControl : PhnMMIEntryType
  • mmiCallerID : PhnMMIResultType
  • mmiCallWaiting : PhnMMIEntryType , PhnMMIResultType
  • mmiColp : PhnMMIResultType
  • mmiColr : PhnMMIResultType
  • mmiForwarding : PhnMMIEntryType , PhnMMIResultType
  • mmiIMEI : PhnMMIResultType
  • mmiNumberSent : PhnMMIResultType
  • mmiPassword : PhnMMIEntryType
  • mmiPhoneNumber : PhnMMIEntryType
  • mml_server_name : _PhnLibMMSServerInfo
  • mms_server_name : _PhnLibMMSServerInfo
  • mmsSoundPrefs : SoundPreference::_tonePrefs
  • mn_aaa_spi : PhnPDPPayload , PhnPDPWrite
  • mn_aaa_ss : PhnPDPWrite , PhnPDPPayload
  • mn_aaa_ss_length : PhnPDPPayload , PhnPDPWrite
  • mn_ha_spi : PhnPDPWrite , PhnPDPPayload
  • mn_ha_ss : PhnPDPWrite , PhnPDPPayload
  • mn_ha_ss_length : PhnPDPPayload , PhnPDPWrite
  • mode : PhnMMIEntryType , PalmAudioAMRParamType , PhnPhoneEquipmentMode
  • modifiers : PhnKeyPressedParams
  • month : DSTDataTag
  • moreData : _pluginParams , _pluginSendParams , MMProAttachStruct2
  • moved : PhnEventType::Data
  • moveMessages : PhnIndicationType
  • moveRequested : PhnSMSParams
  • msec : HS_HTTPLibTime_
  • msgAlert : SoundPreferenceSMS , PhnRingingProfileType
  • msgBox : PhnEventType::Data
  • msgClass : PhnSMSParams
  • msgCount : PmBroadcastNewMsgCountNotifyParamType
  • msgID : WUNotificationEventType , UPNotificationEventType , tagIOTANotificationEventType , PhnMovedMsgDescType , NBSNotificationEventType
  • msgInd : PhnSMSParams
  • msgNumber : ParsedInfo
  • msgOwner : PhnMovedMsgDescType
  • msgType : PhnSMSParams , HsSndMidiProgressMsg
  • mSIMMessagesAcknowledge : PhnIndicationType
  • multiparty : PhnConnectionType
  • mutexSticky : NetPrefFallbackInfoType
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:08 2008 for Palm API Guide


  • All
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- n -

  • nai : PhnPDPWrite , PhnPDPPayload
  • NAI : WUNotificationEventType
  • nai_length : PhnPDPWrite , PhnPDPPayload
  • NALUnit : PalmVideoAVCDecodeParamType
  • NALUnitSize : PalmVideoAVCDecodeParamType
  • name : PhnMMIEntryType , ToneItemType , _HelperServiceMMSObjectType , PhoneAppLaunchCmdDialType , _pluginSendParams , ApptTimeZoneType , _PalmPhotoFileLocation , LocDBRecordTag , LocationDataTag
  • nameLength : ParsedInfo
  • nameP : PhoneAppLaunchCmdCallerIDLookupType
  • namInUse : PhnIOTAReportType
  • navFlags : FrmNavHeaderTag
  • NBSdatagram : NBSNotificationEventType
  • needSelLoc : LocsLibSelLocsTag
  • netTimeStamp : WUNotificationEventType
  • networkAvailable : PhnIndicationType
  • networkError : PhnError
  • networkMsgId : PhnSMSParams
  • networkSoundPrefs : SoundPreference::_tonePrefs
  • networkTime : PhnEventType::Data
  • newControlProc : HtmlLibFormWidgetProc
  • newDim : AiaExtentChangedEventDataType
  • newFieldProc : HtmlLibFormWidgetProc
  • newListProc : HtmlLibFormWidgetProc
  • newMailAlert : SoundPreferenceEmail
  • newPhoneNum : AddrPhonebookAppParamsType
  • newPwd : PhnMMIEntryType
  • newStatus : PhnSMSParams
  • nextAction : PhnSATEventMenuRec
  • nextP : _HelperServiceMMSObjectType , PhnGPRSPDPContextListNodeType
  • nid : PhnCdmaSystemInfoType
  • noAddToCustomDB : LocsLibSelLocsTag
  • noEditOnSelect : LocsLibSelLocsTag
  • note : LocationDataTag
  • notificationType : PhnSATEventIdleModeText , PhnSATEventRefresh , PhnSATEventSetupCall , PhnSATEventDataSvc , PhnSATEventType , PhnSATEventDisplayText , PhnSATEventGetInkey , PhnSATEventHeader , PhnSATEventGetInput , PhnSATEventPlayTone , PhnSATEventMenu , PhnSATEventSendDTMF , PhnSATEventSendSMS , PhnSATEventLaunchBrowser , PhnSATEventRunAT
  • notifyType : LocsLibNotifyDataTag
  • num_def_pdp_idxs : PhnPDPList
  • num_stand_pdp_idxs : PhnPDPList
  • num_tmp_pdp_idxs : PhnPDPList
  • numAccounts : SysVPPILaunchCmdGetAccountsType
  • numAttach : MMProLaunchStruct , MMProLaunchStruct2
  • numAttachments : MailAddRecordParamsTypePlus
  • numAuthenticationMethods : SysWPPILaunchCmdGetAuthenticationMethodsType
  • number : PhnMMIResultType , PhoneAppLaunchCmdDialType , PhnMMIEntryType
  • numberOffset : PhnSATEventSetupCall
  • numberOfObjects : FrmNavHeaderTag
  • numberP : PhoneAppLaunchCmdCallerIDLookupType
  • numBytes : CamLibBitmapInfoTag
  • numDataLinks : _pluginSendParams , MMProAttachStruct2 , _pluginParams
  • numItems : _pluginExtendedQueryParams , _pluginQueryParams
  • numProfiles : NetServicesProfileInfo
  • numReceiveTypes : _pluginGetInfoParams
  • numSelLocs : LocsLibSelLocsTag
  • numSendTypes : _pluginGetInfoParams
  • numServices : DialPnlIsDialingAvailableParamsType
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:08 2008 for Palm API Guide


  • All
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- o -

  • object : _HelperServiceMMSDetailsType
  • objectFlags : FrmNavOrderEntryTag
  • objectID : FrmNavOrderEntryTag
  • offlineProc : HS_HTTPLibNetLibInfo_
  • offset : _PalmPhotoSelectionParam
  • oldDim : AiaExtentChangedEventDataType
  • oldPwd : PhnMMIEntryType
  • oldStatus : PhnSMSParams
  • oneXFailReason : PhnEventType::Data
  • oneXStatus : PhnEventType::Data
  • oneXStatusPRev : PhnOneXStatus
  • onlineProc : HS_HTTPLibNetLibInfo_
  • opData : PhnOperatorListType
  • openProc : HS_HTTPLibNetLibInfo_
  • operation : DevAppLaunchCmdGenericCallType
  • opMode : NetServicesProfile , NetServicesProfileV1
  • options : AddressAppRecordHeader
  • order : NetServicesProfileOrder
  • origCreator : SysVPPILaunchCmdPromptAndConfigureType
  • origInstance : SysVPPILaunchCmdPromptAndConfigureType
  • otaspMsg : PhnIndicationType
  • owner : SmsHeader , PhnConnectionType
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:08 2008 for Palm API Guide


  • All
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- a -

  • aboveObjectID : FrmNavOrderEntryTag
  • account : SysVPPILaunchCmdEditAccountType , SysVPPILaunchCmdDeleteAccountType , SysVPPILaunchCmdSetCurrentAccountType
  • accountID : VPNAccountType
  • accountName : VPNAccountType
  • accounts : SysVPPILaunchCmdGetAccountsType
  • acknowledge : PhnEventType
  • action : PhnMMIEntryType
  • Action : P1clRecordDetails
  • action : PhnSATEventLaunchBrowser
  • actionCode : PalmAudioPlaybackNotifyEventTypeTag , PhnMMIEntryType
  • activate : PhnSMSParams
  • active_idx : PhnPDPList
  • active_idx_set : PhnPDPList
  • activeCall : AddrPhonebookAppParamsType
  • activeLine : PhnLineStateType
  • activeLineNumber : PhnRadioStateType
  • add1BeforeAreaCode : HsDialPrefsUSDialingRulesType
  • addr : HS_HTTPLibIPAddr_ , PhnIOTAPhnNAISIPEdgeProxyType , PhnIOTAPhnProxyAddrWdpType
  • address : AddressType , PhnConnectionType
  • addressSize : AddressType
  • alarmPreset : SoundPreferenceCalendar
  • alarmTone : SoundPreferenceCalendar
  • albumID : _PalmPhotoSelectionParam
  • alertTone : SoundPreferenceEmail
  • algorithm : PalmVideoMPEG4EncodeParamType , NetPrefFallbackInfoType
  • alphaIdOffset : PhnSATEventSendDTMF , PhnSATEventLaunchBrowser , PhnSATEventIdleModeText , PhnSATEventRunAT , PhnSATEventDataSvc
  • alsSupported : PhnRadioStateType
  • altitude : PhnPDDataType
  • amplitude : HsSndBufferData
  • apiCreator : SndCodecCustomControlType
  • apiSelector : SndCodecCustomControlType
  • apn : PhnGPRSPDPContextType
  • appCreator : HS_HTTPLibAppinfo_
  • appId : WAPNotificationEventType
  • areaCodeCtl : HsDialPrefsUSDialingRulesType
  • ascP : PalmAudioAACDecParamType
  • aSize : MMProAttachStruct2 , MMProAttachStruct
  • assigned : SysWPPILaunchCmdType
  • athenaDeviceCreatorCode : PmConnectorNotifyDataType
  • attachData : MailAddRecordAttachment
  • attachDBID : MailAddRecordAttachment
  • attachDescription : MailAddRecordAttachment
  • attachFileName : MailAddRecordAttachment
  • attachment : MMProAttachStruct , MMProAttachStruct2
  • attachments : MMProLaunchStruct2 , MailAddRecordParamsTypePlus , MMProLaunchStruct
  • attachName : MMProAttachStruct2 , MMProAttachStruct
  • attachSize : MailAddRecordAttachment
  • attachType : MailAddRecordAttachment
  • audioAlertEnable : PhnSMSPrefType
  • authentication : NetServicesProfile , NetServicesProfileV1
  • authenticationMethodID : SysWPPILaunchCmdGetDescriptionType , WiFiAuthenticationMethodType , SysWPPILaunchCmdType
  • authenticationMethodName : WiFiAuthenticationMethodType
  • authenticationMethods : SysWPPILaunchCmdGetAuthenticationMethodsType
  • auto4DigitPrefix : HsDialPrefsUSDialingRulesType
  • auto5DigitPrefix : HsDialPrefsUSDialingRulesType
  • auto6DigitPrefix : HsDialPrefsUSDialingRulesType
  • autoAreaCode : HsDialPrefsUSDialingRulesType
  • autoOffWhenClosed : PowerPanelAppPrefs
  • autoOnWhenOpened : PowerPanelAppPrefs
  • availableService : PhnDataSessionStateType
  • avgBytesPerSec : PalmAudioMP2ParamType
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:08 2008 for Palm API Guide


  • All
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- b -

  • bandClass : PhnCdmaSystemInfoType
  • bcc : MMProLaunchStruct , _HelperServiceMMSDetailsType , MMProLaunchStruct2
  • bCroppedMode : PalmVideoAVCCustomSetCropModeType
  • bearerOffset : PhnSATEventLaunchBrowser
  • belowObjectID : FrmNavOrderEntryTag
  • binary : NBSNotificationEventType
  • bitmapID : PmSysGadgetBbutMappingType , HsBigButtonMappingType
  • bitRate : PalmAudioAACParamType , PalmVideoMPEG4EncodeParamType
  • bitsPerPixel : _PalmPhotoImageInfo , CamLibBitmapInfoTag
  • bitsPerSample : PalmAudioMP2ParamType
  • blockSize : PalmAudioADPCMParamType
  • body : MMProLaunchStruct , MMProLaunchStruct2
  • boostDB : HsSndPortInfo
  • bottomLeftObjectIDHint : FrmNavHeaderTag
  • bounds : HtmlLibFocusTargetInfo
  • BSS : BSSListStruct
  • bssANL : NetBssInfoType
  • bssAtimWindow : NetBssInfoType
  • bssBeaconPeriod : NetBssInfoType
  • bssChannelId : NetBssInfoType
  • bssDSFreq : NetBssInfoType
  • bssHopDwell : NetBssInfoType
  • bssHopPattern : NetBssInfoType
  • bssHopSet : NetBssInfoType
  • bssMacAddr : NetBssInfoType
  • bssNetworkMode : NetBssInfoType
  • bssNetworkType : NetBssInfoType
  • bssRssi : NetBssInfoType
  • bssSsid : NetBssInfoType
  • bssSsidLength : NetBssInfoType
  • bssSupportedRates : NetBssInfoType
  • bssWepEnabled : NetBssInfoType
  • buffer : HsSndBufferData
  • bufferLen : _HelperServiceMMSObjectType
  • bufferP : _PalmPhotoFileLocation , _HelperServiceMMSObjectType
  • bufferSize : _PalmPhotoFileLocation , HsSndBufferData
  • bufP : CamLibStreamTag
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:08 2008 for Palm API Guide


  • All
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- c -

  • calendarSoundPrefs : SoundPreference::_tonePrefs
  • call1ID : PhnConferenceDesc
  • call2ID : PhnConferenceDesc
  • callback : AddrCallerIDParamsType
  • callbackAddress : PhnSMSParams
  • callbackP : CamLibCaptureTag
  • caller : PhnSubscriberAddrInfo
  • callType : PhnSATEventSetupCall
  • cancel : SysWPPILaunchCmdType
  • captureCallback : _PalmPhotoCaptureParamV2
  • category : MailAddRecordParamsTypePlus
  • cc : MMProLaunchStruct , _HelperServiceMMSDetailsType , MMProLaunchStruct2
  • cert : PhnIOTAPhnTlsRcUrlType
  • certDBName : HS_HTTPLibAppinfo_
  • certDBType : HS_HTTPLibAppinfo_
  • certDBVersion : HS_HTTPLibAppinfo_
  • chanId : PhnSATEventDataSvc
  • channel : NetServicesProfile , NetServicesProfileV1
  • channels : PalmAudioMP2ParamType
  • chatTone : SoundPreferenceIM
  • chNum : PhnCdmaSystemInfoType
  • chromaFormat : PalmVideoAVCCustomGetInfoType
  • clearMode : PhnSATEventDisplayText
  • clientRect : SysVPPILaunchCmdProgressPaintType
  • closeProc : HS_HTTPLibNetLibInfo_
  • cnt : PhnIOTAPhnSIPRetryCntType
  • code : PhnDisconnectEventType , PhnError
  • color : ParsedInfo
  • colorBits : PalmImageINDEXParamType
  • colorImportant : PalmImageBMPParamType
  • colorTable : PalmImageINDEXParamType
  • colorUsed : PalmImageBMPParamType
  • companyOffset : AddressAppRecordHeader
  • completion_callback : HsSndBufferData
  • completion_userdata : HsSndBufferData
  • compositionTime : PalmVideoAVCDecodeParamType , PalmVideoAVCCustomGetDecodedFrameType
  • compositionTimestamp : PalmVideoAVCDecodeParamType , PalmVideoAVCCustomGetDecodedFrameType
  • compression : PalmImageBMPParamType
  • conference : PhnEventType::Data
  • conferenceID : PhnConferenceDesc
  • confirm : PhoneAppLaunchCmdDialType
  • confirmDeletion : PhnSMSPrefType
  • connection_type : PhnPDPWrite , PhnPDPPayload
  • connectionID : PhnEventType
  • contentType : WAPNotificationEventType
  • contextId : PhnGPRSPDPContextType
  • continuePowerOnOff : PhnIndicationType
  • controls : HsSndBufferData
  • cookie : SysWPPILaunchCmdType
  • cookieDBCreator : HS_HTTPLibAppinfo_
  • cookieDBName : HS_HTTPLibAppinfo_
  • cookieDBType : HS_HTTPLibAppinfo_
  • cookieDBVersion : HS_HTTPLibAppinfo_
  • cookieMaxJarSize : HS_HTTPLibAppinfo_
  • count : PhnMovedMsgsParamsType , Address , PhnOperatorListType , BSSListStruct , AddrDescriptor
  • country : LocationDataTag , LocDBRecordTag , ApptTimeZoneType
  • creator : _PalmPhotoFileLocation , AacFileRef
  • creatorId : PmSysGadgetPttNotificationType
  • CreatorId : P1clRecordDetails
  • credentialsLabel : SysWPPILaunchCmdType
  • credentialsSelectorTrigger : SysWPPILaunchCmdType
  • currentMillisecond : tagSndFileStreamData
  • currentPan : HsSndPortInfo
  • currentVol : HsSndPortInfo
  • custom : LocationDataTag , ApptTimeZoneType , LocDBRecordTag
  • customDataP : tagSndFileStreamData
  • customDataSize : tagSndFileStreamData
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:08 2008 for Palm API Guide


  • All
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- d -

  • data : MMProAttachDataLinks , _dataLinks , _pluginParams , PhnMMIEntryType , PhnMMIResultType , AddressAppRecordHeader , AddrCreateNewRecordParamsType , AddrAddToRecordParamsType , MailAddRecordAttachment , PhnIndicationType , PhnProgressEventType , PhnEventType
  • dataChannelAvailability : PhnEventType::Data
  • dataDuration : tagSndFileStreamData
  • dataH : PhnSATEventType
  • dataLen : tagIOTANotificationEventType , NBSNotificationEventType
  • dataP : tagIOTANotificationEventType , NBSNotificationEventType , DialPnlDispatchDialParamsType , PalmAudioPlaybackNotifyEventTypeTag
  • dataSesstionStatus : PhnEventType::Data
  • dataSize : tagSndFileStreamData
  • date : SmsHeader
  • datetime : tagIOTANotificationEventType , NBSNotificationEventType , WUNotificationEventType , UPNotificationEventType , WAPNotificationEventType
  • day : HS_HTTPLibTime_
  • daylightSavings : PhnNetworkTime
  • daylightSavingsHour : PhnNetworkTime
  • dayOrd : DSTDataTag
  • db : _pluginParams , _pluginQueryParams , _pluginSendParams , _pluginExtendedQueryParams
  • dbCardNum : LocDBInfoTag
  • dbCreatorID : LocDBInfoTag
  • dbName : LocDBInfoTag
  • dbType : LocDBInfoTag
  • defaultConnProfileName : NetMasterClientEventVPNConnInstallType
  • defaultItem : PhnSATEventMenu
  • defaultOffset : PhnSATEventGetInput
  • degree : Coordinate
  • delayTime : PalmImageGIFFrameParamType
  • deleteObjectProc : HtmlLibFormWidgetProc
  • deliveryAck : _PhnLibMMSServerInfo
  • description : SysWPPILaunchCmdGetDescriptionType
  • descriptionSize : SysWPPILaunchCmdGetDescriptionType
  • descriptionStr : DialPnlDispatchDialParamsType
  • destPort : PhnSMSParams
  • deviceClass : PmConnectorNotifyDataType
  • dhcpRequestDNS : NetServicesProfileV1 , NetServicesProfile
  • dial_str : PhnPDPWrite , PhnPDPPayload
  • dial_str_length : PhnPDPWrite , PhnPDPPayload
  • dialMethod : PhoneAppLaunchCmdDialType
  • dialog : PhnIndicationType , PhnProgressEventType
  • dirtyBit : SysVPPILaunchCmdEditAccountType
  • dirtySelections : LocsLibSelLocsTag
  • disconnect : PhnEventType::Data
  • disconnectStatus : PhnDataSessionStateType
  • displayCallback : _PalmPhotoDisplayParam
  • displayDialPrefs : PhoneAppLaunchCmdGetDialPrefFlagType
  • displaySIMbook : AddrHsLookupUserDataV2Type
  • displayStatus : PhnMMIResultType
  • disposalMethod : PalmImageGIFFrameParamType
  • divertIndicator : PhnLineStateType
  • dns_server_assigned : PhnPDPPayload , PhnPDPWrite
  • doneButtonLabel : webBrowserMinimalModeLaunchInfo
  • driverDate : Net80211DeviceInfo
  • dSTAdjustmentInMinutes : LocationDataTag , LocDBRecordTag , ApptTimeZoneType
  • dSTEnd : LocDBRecordTag , ApptTimeZoneType , LocationDataTag
  • dstPort : NBSNotificationEventType
  • dSTStart : LocationDataTag , ApptTimeZoneType , LocDBRecordTag
  • dtmfChar : PhnSATEventSendDTMF
  • dtxMode : PalmAudioAMRParamType
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:08 2008 for Palm API Guide


  • All
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- e -

  • echoMode : PhnSATEventGetInput
  • EFList : PhnSATEventRefresh
  • emailSoundPrefs : SoundPreference::_tonePrefs
  • enabled : PhnMMIResultType
  • endianess : PalmImageINDEXParamType , PalmImageParamType
  • eriStatusTone : SoundPreferenceNetworkSounds
  • err : DialPnlDispatchDialParamsType , SysVPPILaunchCmdGetAccountsType , SysVPPILaunchCmdDeleteAccountType , SysVPPILaunchCmdEditAccountType , SysVPPILaunchCmdSetCurrentAccountType , SysWPPILaunchCmdGetAuthenticationMethodsType , SysWPPILaunchCmdType , SysWPPILaunchCmdGetDescriptionType
  • error : SysWPPILaunchCmdErrorDialogType , SysVPPILaunchCmdErrorDialogType , PhnIOTAReportType , PhnPasswordEventType , PhnMovedMsgDescType , PhnEventType::Data
  • errOut : SysWPPILaunchCmdClearPWCache , SysVPPILaunchCmdClearPWCacheType , SysWPPILaunchCmdPromptAndConfigureType , SysVPPILaunchCmdProgressPaintType , SysVPPILaunchCmdErrorDialogType , SysVPPILaunchCmdPromptAndConfigureType , SysVPPILaunchCmdWillPWPromptType , SysWPPILaunchCmdErrorDialogType
  • esdsP : PalmAudioAACDecParamType
  • eType : vpnNotifyVPNLibTag
  • event : PhnMovedMsgDescType
  • eventData : NetMasterClientEventInfoType
  • eventID : NetMasterClientEventInfoType
  • eventType : PhnEventType
  • extraDigits : PhoneAppLaunchCmdDialType
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:08 2008 for Palm API Guide


  • All
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- f -

  • face : VMFontType
  • failLaunchCode : PhoneAppLaunchCmdDialType
  • failLaunchCreator : PhoneAppLaunchCmdDialType
  • failLaunchParams : PhoneAppLaunchCmdDialType
  • fbStatusFlags : NetPrefFallbackInfoType
  • fChallenge : HS_HTTPLibAuthInfo_
  • fDummy : HS_HTTPLibOpaque_
  • features : PhnSATEventMenuRec
  • field : AddrCreateNewRecordParamsType , AddrAddToRecordParamsType
  • file : AacFileRef , _PalmPhotoFileLocation
  • fileCreator : tagSndFileStreamFileSpec
  • fileExt : _pluginParams , _pluginQueryParams , _pluginSendParams , _pluginExtendedQueryParams
  • fileFormat : tagSndFileStreamData , _PalmPhotoImageInfo , PalmAudioAACDecParamType
  • fileH : AacFileRef
  • fileLocation : _PalmPhotoCaptureParamV2 , _PalmPhotoCreateParam
  • fileLocationType : PalmFileFormatParamType , _PalmPhotoFileLocation
  • fileNameP : tagSndFileStreamFileSpec
  • fileRef : AacFileRef
  • filesize : _PalmPhotoImageInfo
  • fileType : tagSndFileStreamFileSpec
  • filler : PhnIndicationType , Address
  • filterCallback : _PalmPhotoSelectionParam
  • first_def_pdp_idx : PhnPDPList
  • first_stand_pdp_idx : PhnPDPList
  • first_tmp_pdp_idx : PhnPDPList
  • firstEntry : PhnPhoneBookInfoType
  • fix_t : PhnPDDataType
  • flags : AacFileRef , AddressAppRecordHeader , SmsHeader , AddrCallerIDParamsType , tagSndFileStreamFileSpec , HsBigButtonMappingType , HsSndPortInfo , HsSndBufferData , PmSysGadgetBbutMappingType
  • fMatchString : HttpUASelectionRule
  • fname : _pluginParams
  • fNC : HS_HTTPLibAuthInfo_
  • fNextNonce : HS_HTTPLibAuthInfo_
  • font : HsBigButtonMappingType , PmSysGadgetBbutMappingType
  • fontFaceVisible : VMFontUIRules
  • fontSizeVisible : VMFontUIRules
  • fontStyleVisible : VMFontUIRules
  • format : PhnSATEventGetInkey , PhnSATEventGetInput
  • formatString : AddrCallerIDParamsType
  • formObjectID : HtmlLibFocusTargetInfo
  • fPass : HS_HTTPLibAuthInfo_
  • frameHeight : PalmVideoAVCCustomGetInfoType
  • frameHeightCropped : PalmVideoAVCCustomGetInfoType
  • frameNum : CamLibStreamTag
  • frameP : PalmAudioAACDecParamType
  • frameRate : PalmVideoMPEG4EncodeParamType
  • frameSize : PalmAudioAACDecParamType
  • framesReady : PalmVideoAVCCustomGetDecodedFrameType , PalmVideoAVCOutputBufferType
  • frameTime : CamLibStreamTag
  • frameWidth : PalmVideoAVCCustomGetInfoType
  • frameWidthCropped : PalmVideoAVCCustomGetInfoType
  • fRealm : HS_HTTPLibAuthInfo_
  • freeReply : SMSSendOptions
  • freeTempFile : _HelperServiceMMSObjectType
  • fType : HttpUASelectionRule
  • fUser : HS_HTTPLibAuthInfo_
  • fUserAgent : HttpUASelectionRule
  • fwName : Net80211DeviceInfo
  • fwRev : Net80211DeviceInfo
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:08 2008 for Palm API Guide


  • All
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- g -

  • gadgetID : PmSysGadgetBbutMappingType , HsBigButtonMappingType
  • gatewayProxyOffset : PhnSATEventLaunchBrowser
  • genericEventDataP : NetMasterClientEventInfoType
  • getInfo : _pluginGetInfoParams
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:08 2008 for Palm API Guide


  • All
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- h -

  • handled : DialPnlDispatchDialParamsType
  • hasLocalColorTable : PalmImageGIFFrameParamType
  • hasTransparentColor : PalmImageGIFFrameParamType
  • headerLen : tagIOTANotificationEventType , UPNotificationEventType , NBSNotificationEventType , WUNotificationEventType
  • headerP : UPNotificationEventType , tagIOTANotificationEventType , NBSNotificationEventType , PalmAudioQCELPDecParamType , WUNotificationEventType
  • headerSize : PalmAudioQCELPDecParamType
  • headerSizeInBytes : FrmNavHeaderTag
  • heading : PhnPDDataType
  • height : CamLibBitmapInfoTag , _PalmPhotoImageInfo , PalmVideoMPEG1DecodeParamType , PalmImageParamType , PalmImageINDEXParamType , PalmImagePlanarType
  • helperServiceClass : PmGetNewMsgCountNotifyParamType , PmBroadcastNewMsgCountNotifyParamType
  • helpInfo : PhnSATEventGetInkey , PhnSATEventGetInput
  • home_addr : PhnPDPPayload , PhnPDPWrite
  • homePage : _PhnCDMAMediaTVSettings
  • horizontalOffset : PalmVideoAVCCustomGetInfoType
  • hour : DSTDataTag
  • HS_HTTPLibPeerTCPCanReadWrite : HS_HTTPLibPeer_
  • HS_HTTPLibPeerTCPClose : HS_HTTPLibPeer_
  • HS_HTTPLibPeerTCPConnect : HS_HTTPLibPeer_
  • HS_HTTPLibPeerTCPIsConnected : HS_HTTPLibPeer_
  • HS_HTTPLibPeerTCPOpen : HS_HTTPLibPeer_
  • HS_HTTPLibPeerTCPRead : HS_HTTPLibPeer_
  • HS_HTTPLibPeerTCPWrite : HS_HTTPLibPeer_
  • hsCmd : tagSndFileStreamHsSoundCommandParam
  • hsFormat : tagSndFileStreamHsSoundCommandParam
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:08 2008 for Palm API Guide


  • All
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- i -

  • id : PhnConnectionType , PhnError , PhnSMSParams , PhnSATEventMenuRec , WAPNotificationEventType , PhnOperatorType , PhnMMIEntryType , ToneIdentifier
  • identifier : ToneItemType
  • idx : PhnPDPWrite
  • idx0_set : PhnPDPList
  • idx0_uid : PhnPDPList
  • idx1_set : PhnPDPList
  • idx1_uid : PhnPDPList
  • idx2_set : PhnPDPList
  • idx2_uid : PhnPDPList
  • idx3_set : PhnPDPList
  • idx3_uid : PhnPDPList
  • idx4_set : PhnPDPList
  • idx4_uid : PhnPDPList
  • idx5_set : PhnPDPList
  • idx5_uid : PhnPDPList
  • idx6_set : PhnPDPList
  • idx6_uid : PhnPDPList
  • idx7_set : PhnPDPList
  • idx7_uid : PhnPDPList
  • idx_RSVD8_set : PhnPDPList
  • idx_rsvd8_uid : PhnPDPList
  • idx_RSVD9_set : PhnPDPList
  • idx_rsvd9_uid : PhnPDPList
  • ifCreator : SysWPPILaunchCmdPromptAndConfigureType , vpnNotifyVPNLibTag
  • ifInstance : SysWPPILaunchCmdPromptAndConfigureType , vpnNotifyVPNLibTag
  • imageBits : AddrPhotoCallerIDParamsType
  • imageCount : _PalmPhotoSelections
  • imageDataP : PalmImageINDEXParamType , PalmImageGIFFrameParamType
  • imageDataSize : PalmImageGIFFrameParamType
  • imageFormat : _PalmPhotoReadWriteParam
  • imageH : _PalmPhotoSelections
  • imageHeight : PalmImageGIFFrameParamType
  • imageInfo : _PalmPhotoCreateParam , _PalmPhotoCaptureParamV2
  • imageQuality : _PalmPhotoImageInfo
  • imageWidth : PalmImageGIFFrameParamType
  • imei : PhnMMIResultType
  • imSoundPrefs : SoundPreference::_tonePrefs
  • incoming : PhnConnectionType
  • index : PhnIOTAPhnTlsRcUrlType , PhnIOTAPhnNAISIPEdgeProxyType , PhnIOTAPhnProxyAddrWdpType , PhnIOTAPhnNAISIPCfgSvr , PhnIOTAPhnNAIPPGType , PhnIOTAPhnNAISIPDataxchType , PhnIOTAPhnNAISIPDatagwyType , PhnIOTAPhnSIPRetryTimerType , PhnIOTAPhnNAIIMStore , PhnIOTAPhnSIPRetryCntType
  • indication : PhnEventType::Data
  • indicationCode : PhnIndicationType
  • indicator : PhnSMSParams
  • indicatorOn : PhnMsgBoxDataType
  • indType : PhnSMSParams
  • info : PhnEventType::Data , ParsedInfoList
  • InfoBuffer : NetworkDeviceQueryData
  • InfoBufferLength : NetworkDeviceQueryData
  • infoP : _PalmPhotoExtraInfo
  • infoSize : _PalmPhotoExtraInfo
  • InfoSize : NetworkDeviceQueryData
  • InfoSizeRequired : NetworkDeviceQueryData
  • infoType : _PalmPhotoExtraInfo
  • init_rrq : PhnOnexMipRRQType
  • initialObjectIDHint : FrmNavHeaderTag
  • inReserved1 : NetMasterClientEventVPNConnInstallType , NetMasterClientEventInfoType
  • inReserved2 : NetMasterClientEventVPNConnInstallType , NetMasterClientEventInfoType
  • inReserved3 : NetMasterClientEventInfoType
  • inReserved4 : NetMasterClientEventInfoType
  • interactive : MMProLaunchStruct , MMProLaunchStruct2
  • iota_ph_dls_lock : PhnIOTAPhnDlsLockType
  • iotaInfo : PhnEventType::Data
  • ipAllocType : NetServicesProfile , NetServicesProfileV1
  • ipGateway : NetServicesProfile , NetServicesProfileV1
  • ipMask : NetServicesProfileV1 , NetServicesProfile
  • ipPrimaryDNS : NetServicesProfileV1 , NetServicesProfile
  • ipSecondaryDNS : NetServicesProfileV1 , NetServicesProfile
  • isForeground : HS_HTTPLibAppinfo_
  • isInterlaced : PalmImageGIFFrameParamType
  • isRoaming : PhnOperatorType
  • isVFSFileName : _HelperServiceMMSObjectType
  • item : _pluginSendParams
  • itemDescriptors : _pluginQueryParams
  • itemLength : ParsedInfo
  • itemSizes : _pluginQueryParams
  • IVOPQuantization : PalmVideoMPEG4EncodeParamType
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:08 2008 for Palm API Guide


  • All
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- p -

  • pad : PhnSATEventGetInput , PhnSATEventPlayTone , PhnSATEventRefresh
  • padding1 : FrmNavHeaderTag , vpnNotifyVPNLibTag
  • padding2 : vpnNotifyVPNLibTag
  • padding3 : vpnNotifyVPNLibTag
  • pageNum : _HelperServiceMMSObjectType
  • param1 : HsSndMidiProgressMsg
  • param2 : HsSndMidiProgressMsg
  • params : PhnEventType::Data
  • parsedType : ParsedInfo
  • passwdNeeded : PhnSATEventDataSvc
  • password : WUNotificationEventType , PhnEventType::Data
  • passwordAccepted : PhnIndicationType
  • PDDataInfo : PhnEventType::Data
  • pdp_services : PhnPDPWrite , PhnPDPPayload
  • pdpAddr : PhnGPRSPDPContextType
  • pdpDataCompression : PhnGPRSPDPContextType , NetPrefGPRSQOSType
  • pdpHdrCompression : PhnGPRSPDPContextType
  • pdpHeaderCompression : NetPrefGPRSQOSType
  • pdpType : PhnGPRSPDPContextType
  • pdSessionStatus : PhnOneXStatus
  • phn_pd_svc_mask : PhnPDDataType
  • PhnOnxMipRRQ : PhnEventType::Data
  • phoneBookIndex : Address
  • phoneEquipmentMode : PhnEventType::Data
  • phoneSoundPrefs : SoundPreference::_tonePrefs
  • picHeight : PalmVideoAVCCustomGetDecodedFrameType
  • picHeightCropped : PalmVideoAVCCustomGetDecodedFrameType
  • picWidth : PalmVideoAVCCustomGetDecodedFrameType
  • picWidthCropped : PalmVideoAVCCustomGetDecodedFrameType
  • pin : PhnPasswordEventType
  • pix_place_server : _PhnLibMMSServerInfo
  • planarData : PalmVideoAVCCustomGetDecodedFrameType
  • planeCount : PalmImagePlanarType
  • planeP : PalmImagePlanarType
  • planeWidth : PalmImagePlanarType
  • playbackCount : tagSndFileStreamData
  • playSoundTimes : SoundPreferenceCalendar
  • portID : HsSndPortInfo
  • position : LocationDataTag
  • power : PhnEventType::Data
  • powerOnOffContinueCallback : PhnIndicationType
  • preambleType : NetServicesProfileV1 , NetServicesProfile
  • prefix4DigitCtl : HsDialPrefsUSDialingRulesType
  • prefix5DigitCtl : HsDialPrefsUSDialingRulesType
  • prefix6DigitCtl : HsDialPrefsUSDialingRulesType
  • preSelect : LocsLibSelLocsTag
  • presetTime : SoundPreferenceCalendar
  • presetTimeUnit : SoundPreferenceCalendar
  • prevType : PhnPasswordEventType
  • prim_dns_addr : PhnPDPWrite , PhnPDPPayload
  • prim_ha_addr : PhnPDPWrite , PhnPDPPayload
  • priority : PhnMsgBoxDataType , PhnSMSParams , PhnSATEventDisplayText
  • privacy : PhnSMSParams , SoundPreferenceSMS
  • profile : PalmAudioAACParamType , PalmVideoMPEG4EncodeParamType , PalmVideoMPEG4DecodeParamType
  • profileEntrySize : NetServicesProfileInfo
  • profileName : NetServicesProfile , NetServicesProfileV1
  • profileRev : NetServicesProfileInfo
  • profiles : PhnRingingInfoType
  • progress : PhnProgressEventType , PhnEventType::Data
  • progress_callback : HsSndBufferData
  • progress_userdata : HsSndBufferData
  • promptOffset : PhnSATEventSetupCall
  • protectedTone : ToneItemType
  • protocolErr : BGResult
  • protocolErrString : BGResult
  • provOffset : PhnSATEventLaunchBrowser
  • proxyAddr : _PhnCDMAMediaTVSettings
  • proxyPort : _PhnCDMAMediaTVSettings
  • ptr : _pluginSendParams
  • puk : PhnPasswordEventType
  • pwd : PhnMMIEntryType
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:08 2008 for Palm API Guide


  • All
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- q -

  • qid : NetworkDeviceQueryData
  • qnc_set : PhnPDPList
  • qnc_uid : PhnPDPList
  • qosMinDelayClass : NetPrefGPRSQOSType
  • qosMinMeanThruClass : NetPrefGPRSQOSType
  • qosMinPeakThruClass : NetPrefGPRSQOSType
  • qosMinPrecedenceClass : NetPrefGPRSQOSType
  • qosMinReliabilityClass : NetPrefGPRSQOSType
  • qosReqDelayClass : NetPrefGPRSQOSType
  • qosReqMeanThruClass : NetPrefGPRSQOSType
  • qosReqPeakThruClass : NetPrefGPRSQOSType
  • qosReqPrecedenceClass : NetPrefGPRSQOSType
  • qosReqReliabilityClass : NetPrefGPRSQOSType
  • quality : PalmImageJPEGEncodeParamType
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:08 2008 for Palm API Guide


  • All
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- r -

  • rcptAlert : SoundPreferenceSMS
  • reasonCode : WUNotificationEventType
  • record : PhnSATEventMenu
  • recordCount : PhnSATEventMenu
  • RecordIndex : P1clRecordDetails
  • recordNum : AddrCallerIDParamsType , AddrPhotoCallerIDParamsType
  • RecordUId : P1clRecordDetails
  • rect : _PalmPhotoDisplayParam
  • recvBufferSize : HS_HTTPLibAppinfo_
  • reducedRate : PalmAudioQCELPParamType
  • ref : AddrCallerIDParamsType
  • refNum : NBSNotificationEventType , HS_HTTPLibNetLibInfo_
  • refreshType : PhnSATEventRefresh
  • registration : PhnEventType::Data
  • reminderTone : SoundPreferenceCalendar
  • repeatAlarmTimes : SoundPreferenceCalendar
  • repeated : PhoneAppLaunchCmdSendDTMFToneType
  • repeatInterval : SoundPreferenceCalendar
  • repeatNewPwd : PhnMMIEntryType
  • reqIP : NetServicesProfile , NetServicesProfileV1
  • requestSmsInfo : PhnLibLengthInfoType
  • reserved : _PalmPhotoSelectionParam , LocDBRecordTag , LocsLibSelLocsTag , _PalmPhotoReadWriteParam , NetPrefGPRSQOSType , ApptTimeZoneType , _PalmPhotoFileLocation , _PalmPhotoExtraInfo , LocationDataTag
  • reserved0 : NBSNotificationEventType , CamLibBitmapInfoTag
  • reserved1 : PmConnectorNotifyDataType , AddressAppRecord , PhnPDPWrite , NBSNotificationEventType , HsSndPortInfo , HsSndBufferData , CamLibBitmapInfoTag
  • reserved1a : NBSNotificationEventType
  • reserved2 : UPNotificationEventType , tagIOTANotificationEventType , PmConnectorNotifyDataType , PhnPDPWrite , HsSndPortInfo , NBSNotificationEventType , HsSndBufferData , WUNotificationEventType
  • reserved3 : tagIOTANotificationEventType , NBSNotificationEventType , PhnPDPWrite , WUNotificationEventType , UPNotificationEventType
  • reserved4 : PhnPDPWrite
  • reserved5 : PhnPDPWrite
  • reserved6 : PhnPDPWrite
  • response : DevAppLaunchCmdGenericCallType
  • restartInterval : PalmImageJPEGEncodeParamType
  • restrict_ha_addr : PhnPDPPayload
  • restrict_home_addr : PhnPDPPayload
  • restrict_mn_aaa_spi : PhnPDPPayload
  • restrict_mn_aaa_ss : PhnPDPPayload
  • restrict_mn_ha_spi : PhnPDPPayload
  • restrict_mn_ha_ss : PhnPDPPayload
  • restrict_nai : PhnPDPPayload
  • restrict_rev_tunnel_pref : PhnPDPPayload
  • result : DialPnlIsDialingAvailableParamsType , PhnUSSDEventType
  • resultString : AddrCallerIDParamsType
  • ret : _pluginGetInfoParams , _pluginExtendedQueryParams , _pluginSendParams , _pluginQueryParams , _pluginParams
  • rev_tunnel_pref : PhnPDPWrite , PhnPDPPayload
  • ringerID : PhnRingingProfileType
  • roamCallGuardEnable : PhnRoamPrefInfoType
  • roamingTone : SoundPreferencePhone
  • roamRingerEnable : PhnRoamPrefInfoType
  • roamRingerID : PhnRoamPrefInfoType
  • rowByte : PalmImageParamType , PalmImageINDEXParamType
  • rrq_timer : PhnOnexMipRRQType
  • rulesEnabled : HsDialPrefsUSDialingRulesType
  • rwCallback : _PalmPhotoReadWriteParam
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:08 2008 for Palm API Guide


  • All
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- s -

  • s : HS_HTTPLibSplit_
  • sampleBlockAlign : tagSndFileStreamData
  • sampleFormat : tagSndFileStreamData
  • sampleRate : tagSndFileStreamData , PalmAudioPCMParamType , PalmAudioADPCMParamType , PalmAudioAACParamType , PalmAudioAACDecParamType , PalmAudioMP2ParamType
  • sampleType : PalmAudioPCMParamType , tagSndFileStreamData
  • sampleWidth : PalmAudioPCMParamType , PalmAudioADPCMParamType , PalmAudioAACParamType , tagSndFileStreamData
  • sat : PhnEventType::Data
  • save : SysWPPILaunchCmdType
  • searchRange : PalmVideoMPEG4EncodeParamType
  • sec_dns_addr : PhnPDPWrite , PhnPDPPayload
  • sec_ha_addr : PhnPDPWrite , PhnPDPPayload
  • secsFromNow : SysVPPILaunchCmdWillPWPromptType
  • segmentCount : PhnLibLengthInfoType
  • segments : SmsHeader
  • selectedDescriptor : _pluginSendParams
  • selectedImages : _PalmPhotoSelectionParam
  • selectedItem : _pluginSendParams
  • selectionCount : _PalmPhotoSelectionParam
  • selLocsListP : LocsLibSelLocsTag
  • sendChangeNotify : LocsLibSelLocsTag
  • senderCreatorId : DevAppLaunchCmdGenericCallType
  • senderNumber : PhnSMSParams
  • senderP : NBSNotificationEventType
  • sendHit : PhnMMIEntryType
  • seqNum : NBSNotificationEventType
  • serialNumber : Net80211DeviceInfo
  • serialNumberSize : Net80211DeviceInfo
  • serialPortId : PmConnectorNotifyDataType
  • service : PhnConnectionType , PhnDisconnectEventType , PhnSubscriberAddrInfo
  • serviceCenterNumber : PhnSMSParams
  • serviceCode : PhnMMIResultType , PhnMMIEntryType
  • serviceID : DialPnlDispatchDialParamsType
  • serviceIDsP : DialPnlIsDialingAvailableParamsType
  • serviceTone : SoundPreferencePhone
  • serviceType : PhnSATEventDataSvc
  • sessionStatus : PhnDataSessionStateType
  • sessionType : PhnDataSessionStateType
  • set_mn_aaa_spi : PhnPDPWrite , PhnPDPPayload
  • set_mn_ha_spi : PhnPDPWrite , PhnPDPPayload
  • shortname : PhnOperatorType
  • showWaitDialogue : LocsLibNotifyDataTag
  • sid : PhnCdmaSystemInfoType
  • signalFadedTone : SoundPreferenceNetworkSounds
  • signature : PhnSATEventLaunchBrowser , PhnSATEventPlayTone , PhnSATEventDataSvc , PhnSATEventDisplayText , PhnSATEventGetInkey , PhnSATEventHeader , PhnSATEventGetInput , PhnSATEventSetupCall , PhnSATEventMenu , PhnSATEventSendSMS , PhnSATEventRefresh , HsSndPortInfo , PhnSATEventRunAT , PhnSATEventIdleModeText , HsSndBufferData , PhnSATEventSendDTMF , HsSndMidiProgressMsg
  • simMessages : PhnIndicationType
  • simReady : PhnIndicationType
  • size : _pluginParams , SmsHeader , ParsedInfoList , _dataLinks , _pluginSendParams , CamLibStreamTag , PhnMMIResultType , VMFontType , PhnSMSParams , _pluginExtendedQueryParams , PhnLibLengthInfoType , MMProAttachDataLinks , PhnRadioStateType , PhnLineStateType , PhnMMIEntryType
  • sizeRule : VMFontUIRules
  • skipBFrames : PalmVideoMPEG1DecodeParamType
  • smsSoundPrefs : SoundPreference::_tonePrefs
  • soundOffVibrate : SoundPreference
  • soundOnVibrate : SoundPreference
  • soundOnVolume : SoundPreference
  • sourcePort : PhnSMSParams
  • srcPort : NBSNotificationEventType
  • SSID : NetServicesProfile
  • ssid : NetSSID
  • SSID : NetServicesProfileV1
  • ssidLength : NetServicesProfileV1 , NetServicesProfile , NetSSID
  • stage : SysVPPILaunchCmdProgressPaintType
  • startLocation : ParsedInfo
  • state : PhnPowerEventType , PhnConnectionType , PhnIndicationType
  • status : PhnOperatorType , PhnIOTAReportType , SmsHeader , CamLibStatusTag , PhnRegistrationType , NetPrefFallbackInfoType
  • statusID : NetPrefFallbackInfoType
  • statusReport : SMSSendOptions
  • stepDB : HsSndPortInfo
  • stepVol : HsSndPortInfo
  • store : PhnSMSParams
  • store_mn_aaa_ss : PhnPDPWrite
  • stored_mn_aaa_ss : PhnPDPPayload
  • stream : AacFileRef
  • streamBufferSize : _PhnCDMAMediaTVSettings
  • streamComplete : tagSndFileStreamData
  • StreamFile : _PalmPhotoFileLocation
  • streamFileHandle : PalmFileFormatParamType
  • streamFlags : tagSndFileStreamData
  • streamMode : tagSndFileStreamData
  • streamRefCon : tagSndFileStreamData
  • streamTimeout : _PhnCDMAMediaTVSettings
  • stride : PalmVideoAVCCustomGetDecodedFrameType
  • string : PhnUSSDEventType
  • stringID : HsBigButtonMappingType , PmSysGadgetBbutMappingType
  • style : VMFontType
  • styleRule : VMFontUIRules
  • subject : MMProLaunchStruct2 , MMProLaunchStruct , _HelperServiceMMSDetailsType
  • subSampling : PalmImageJPEGEncodeParamType
  • subscriptionStatus : PhnMMIResultType
  • substitution : PhnLibLengthInfoType
  • supported : _pluginExtendedQueryParams
  • supportsReceiving : _pluginGetInfoParams
  • supportsSending : _pluginGetInfoParams
  • svc_str : PhnPDPWrite , PhnPDPPayload
  • svc_str_length : PhnPDPWrite , PhnPDPPayload
  • svcAlert : PhnRingingProfileType
  • svcID : webBrowserURLWithSvcIDLaunchInfo
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:08 2008 for Palm API Guide


  • All
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- t -

  • tempFileName : _HelperServiceMMSObjectType
  • text : PhnMMIEntryType
  • textOffset : PhnSATEventDisplayText , PhnSATEventGetInkey , PhnSATEventGetInput , PhnSATEventPlayTone , PhnSATEventSendSMS
  • time : PhnMMIEntryType , PhnMMIResultType
  • time_stamp : PhnPDDataType
  • timeInSecs : PhnNetworkTime
  • timeInterval : PhnSATEventPlayTone
  • timeout : _PhnLibMMSServerInfo
  • timer : PhnIOTAPhnSIPRetryTimerType
  • timeStamp : PhnSMSParams
  • timeUnit : PhnSATEventPlayTone
  • timeZone : PhnNetworkTime
  • titleOffset : PhnSATEventMenu
  • to : MMProLaunchStruct , MMProLaunchStruct2
  • tone : PhoneAppLaunchCmdSendDTMFToneType
  • tonePrefs : SoundPreference
  • toneType : ToneIdentifier , PhnSATEventPlayTone
  • topPosition : PalmImageGIFFrameParamType
  • traffic_ck_delay_timer : PhnOnexMipRRQType
  • transparentColorIndex : PalmImageGIFFrameParamType
  • trasactionID : PhnSMSParams
  • type : HtmlLibFocusTargetInfo , AacFileRef , PhnSATEventSetupCall , PhnMMIEntryType , CamLibSettingTag , HS_HTTPLibIPAddr_ , PhnPasswordEventType , PhnIndicationType , PhnGPRSPDPContextListNodeType , SmsHeader , MMProAttachStruct2 , MMProAttachStruct , PhnMsgBoxDataType , _pluginExtendedQueryParams , _PalmPhotoFileLocation , AddrListLookupTypeGetParamsType , LcdOverlayLibSettingTag , PhnMMIResultType
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:08 2008 for Palm API Guide


  • All
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- u -

  • u : PalmAudioAACDecParamType , AacFileRef
  • uBitmapId : PmSysGadgetPttNotificationType
  • uid : PhnPDPPayload
  • uniqueID : Address , AddrCallerIDParamsType , AddrAddToRecordParamsType
  • unityVol : HsSndPortInfo
  • unknownCallerTone : SoundPreferencePhone
  • Unused : _pluginParams , _pluginQueryParams , _pluginSendParams , _pluginGetInfoParams , _pluginExtendedQueryParams
  • UPData : UPNotificationEventType
  • url : PhnIOTAPhnNAISIPCfgSvr , PhnIOTAPhnNAISIPDatagwyType , PhnIOTAPhnNAIPPGType , PhnIOTAPhnNAIIMStore , PhnIOTAPhnNAISIPDataxchType , PhnIOTAPhnHomepagetype , PhnIOTAPhnTrustedDomainType
  • urlOffset : PhnSATEventLaunchBrowser
  • use_default_dial_str : PhnPDPWrite
  • use_default_svc_str : PhnPDPWrite
  • use_existing_dial_str : PhnPDPWrite
  • use_existing_dns_server : PhnPDPWrite
  • use_existing_ha_addr : PhnPDPWrite
  • use_existing_home_addr : PhnPDPWrite
  • use_existing_mn_aaa_spi : PhnPDPWrite
  • use_existing_mn_aaa_ss : PhnPDPWrite
  • use_existing_mn_ha_spi : PhnPDPWrite
  • use_existing_mn_ha_ss : PhnPDPWrite
  • use_existing_nai : PhnPDPWrite
  • use_existing_rev_tunnel_pref : PhnPDPWrite
  • use_existing_svc_str : PhnPDPWrite
  • useMultiFilter : AddrHsLookupUserDataType , AddrHsLookupUserDataV2Type
  • user_agent : _PhnLibMMSServerInfo
  • userDataP : _PalmPhotoDisplayParam , _PalmPhotoSelectionParam , _PalmPhotoReadWriteParam , CamLibCaptureTag , _PalmPhotoCaptureParamV2 , DevAppLaunchCmdGenericCallType
  • useSavedAccount : SysVPPILaunchCmdEditAccountType
  • useWizardUI : SysVPPILaunchCmdEditAccountType
  • ussd : PhnEventType::Data
  • uStatus : PmSysGadgetPttNotificationType
  • uTC : ApptTimeZoneType , LocationDataTag , LocDBRecordTag
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:08 2008 for Palm API Guide


  • All
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- v -

  • validFlag : NetBssInfoType
  • validFlags : Net80211DeviceInfo
  • validity : SMSSendOptions , SmsHeader
  • value : LcdOverlayLibSettingTag , CamLibSettingTag , CamLibColorSpaceTag
  • valueLenP : SndCodecCustomControlType
  • valueP : SndCodecCustomControlType
  • velocity_hor : PhnPDDataType
  • velocity_ver : PhnPDDataType
  • version : PalmAudioPlaybackNotifyEventTypeTag , _PhnCDMAMediaTVSettings , PhnSMSParams , PhnLineStateType , WUNotificationEventType , UPNotificationEventType , WAPNotificationEventType , tagIOTANotificationEventType , PhnRadioStateType , HsBigButtonReourceType , FrmNavHeaderTag , PhnDataSessionStateType , NetMasterClientEventInfoType , NBSNotificationEventType , AddrListLookupTypeGetParamsType , PmSysGadgetBbutResourceType , _HelperServiceMMSDetailsType , PhoneAppLaunchCmdDialType , _pluginGetInfoParams , AddrHsLookupUserDataType , AddrHsLookupUserDataV2Type , _pluginParams , _PhnLibMMSServerInfo
  • verticalOffset : PalmVideoAVCCustomGetInfoType
  • VFSFile : _PalmPhotoFileLocation
  • vfsFileRef : PalmFileFormatParamType
  • vibrate : PhnRingingProfileType
  • voiceMailIndicator : PhnLineStateType
  • voicemailTone : SoundPreferencePhone
  • volHeight : PalmVideoMPEG4EncodeParamType , PalmVideoMPEG4DecodeParamType
  • volRefNum : tagSndFileStreamFileSpec , AacFileRef
  • volume : PhnRingingProfileType
  • volumeRef : _PalmPhotoFileLocation
  • volWidth : PalmVideoMPEG4DecodeParamType , PalmVideoMPEG4EncodeParamType
  • VOVOLVersionID : PalmVideoMPEG4EncodeParamType
  • vpnConnInstallP : NetMasterClientEventInfoType
  • vpnConnProfileOverrideName : NetMasterClientEventVPNConnInstallType
  • vppiCreator : VPNAccountType
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:09 2008 for Palm API Guide


  • All
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- w -

  • wallpaperLocation : PhoneAppLaunchCmdSetWallpaperType
  • wallpaperUID : PhoneAppLaunchCmdSetWallpaperType
  • wapEvtParams : PhnEventType::Data
  • wapMsg : WAPNotificationEventType
  • warnIfLocExists : LocsLibSelLocsTag
  • weekOrd : DSTDataTag
  • wep : NetServicesProfile , NetServicesProfileV1
  • width : PalmImageINDEXParamType , PalmVideoMPEG1DecodeParamType , CamLibBitmapInfoTag , PalmImagePlanarType , PalmImageParamType , _PalmPhotoImageInfo
  • winH : _PalmPhotoDisplayParam
  • wppiCreator : WiFiAuthenticationMethodType
  • wsCode : PhnCdmaSystemInfoType
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:09 2008 for Palm API Guide


  • All
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- x -

  • xExtent : AddrPhotoCallerIDParamsType
  • xPixelsPerMeter : PalmImageBMPParamType
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:09 2008 for Palm API Guide


  • All
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- y -

  • yExtent : AddrPhotoCallerIDParamsType
  • yPixelsPerMeter : PalmImageBMPParamType
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:09 2008 for Palm API Guide


  • All
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- _ -

  • _filler100_ : UPNotificationEventType
  • _filler1_ : WUNotificationEventType , WAPNotificationEventType
  • _filler2_ : WUNotificationEventType
  • _filler3_ : WUNotificationEventType
  • _reserved0 : DialPnlIsDialingAvailableParamsType , HsDialPrefsUSDialingRulesType
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:09 2008 for Palm API Guide


  • All
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- j -

  • JPEGMode : PalmImageJPEGEncodeParamType
  • jumpToObjectIDHint : FrmNavHeaderTag
  • justSend : _HelperServiceMMSDetailsType
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:09 2008 for Palm API Guide


  • All
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- k -

  • key : NetWepKey , PhnKeyPressedParams
  • keyFrame : PalmVideoMPEG4EncodeParamType
  • keyIndex : NetServicesProfile , NetServicesProfileV1 , NetWepKey
  • keyLength : NetWepKey
  • keyPressed : PhnEventType::Data
  • kind : PhnIndicationType , Address
  • knownCallerTone : SoundPreferencePhone
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:09 2008 for Palm API Guide


  • All
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- l -

  • labelOffset : PhnSATEventMenuRec
  • lastByte : tagSndFileStreamData
  • lastEntry : PhnPhoneBookInfoType
  • lat : PhnPDDataType
  • latitude : PosType
  • launchCode : PhnEventType
  • launchParams : PhnEventType
  • launchUrl : webBrowserMinimalModeLaunchInfo , webBrowserURLWithSvcIDLaunchInfo
  • launchView : SoundPrefsLaunchCmdParamType
  • leftPosition : PalmImageGIFFrameParamType
  • len : HS_HTTPLibSplit_
  • length : WAPNotificationEventType , PhnLibLengthInfoType
  • life_timer : PhnOnexMipRRQType
  • lineNumber : PhnConnectionType , PhnMsgBoxDataType , PhoneAppLaunchCmdGetALSLineNumberType , PhnSubscriberAddrInfo
  • linkP : NetworkDeviceQueryData
  • list : PhnMovedMsgsParamsType
  • listElementSizeInBytes : FrmNavHeaderTag
  • listItems : _pluginQueryParams
  • listMaxSizeExt : _pluginGetInfoParams
  • listMaxSizeMime : _pluginGetInfoParams
  • listNames : _pluginExtendedQueryParams
  • listPtrs : _pluginExtendedQueryParams
  • listReceiveFileExt : _pluginGetInfoParams
  • listReceiveMIMEtypes : _pluginGetInfoParams
  • listSendFileExt : _pluginGetInfoParams
  • listSendMIMEtypes : _pluginGetInfoParams
  • listSendNames : _pluginGetInfoParams
  • loc_uncertainty_a : PhnPDDataType
  • loc_uncertainty_ang : PhnPDDataType
  • loc_uncertainty_p : PhnPDDataType
  • loc_uncertainty_v : PhnPDDataType
  • localColorBits : PalmImageGIFFrameParamType
  • localColorTable : PalmImageGIFFrameParamType
  • locationData : LocsLibNotifyDataTag
  • locationDataNew : LocsLibNotifyLocsDataTag
  • locationNameOldP : LocsLibNotifyLocsDataTag
  • locationP : LocsLibSelLocsTag
  • lock : CamLibStreamTag
  • loginNeeded : PhnSATEventDataSvc
  • lon : PhnPDDataType
  • longitude : PosType
  • longname : PhnOperatorType
  • lookup : AddrPhonebookAppParamsType
  • lookupString : AddrCallerIDParamsType
  • lookupStrP : AddrPhonebookAppParamsType
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:09 2008 for Palm API Guide


  • All
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- m -

  • mainParams : MailAddRecordParamsTypePlus
  • majorResult : BGResult
  • mapArr : PmSysGadgetBbutResourceType , HsBigButtonReourceType
  • matchFound : AddrHsLookupUserDataType , AddrHsLookupUserDataV2Type
  • max_message_size : _PhnLibMMSServerInfo
  • maxConnections : PhnRadioStateType
  • maximumBytes : tagSndFileStreamData
  • maximumMilliseconds : tagSndFileStreamData
  • maxNameLength : PhnPhoneBookInfoType
  • maxNum : NBSNotificationEventType
  • maxNumberLength : PhnPhoneBookInfoType
  • maxRate : PalmAudioQCELPParamType
  • maxRetries : _PhnLibMMSServerInfo
  • maxSize : ParsedInfoList , PhnSATEventGetInput
  • maxSockets : HS_HTTPLibAppinfo_
  • maxValue : LcdOverlayLibSettingTag , CamLibSettingTag
  • maxVol : HsSndPortInfo
  • mData : AddressAppRecord
  • MemoryFile : _PalmPhotoFileLocation
  • message : _HelperServiceMMSDetailsType
  • messageCount : PhnMsgBoxDataType
  • messageTone : SoundPreferenceIM , SoundPreferenceSMS , SoundPreferenceMMS
  • mHeader : AddressAppRecord
  • mID : AddressAppRecord
  • MIMEtype : _pluginExtendedQueryParams , _pluginParams , _pluginQueryParams
  • mimeType : _HelperServiceMMSObjectType
  • MIMEtype : _pluginSendParams
  • minRate : PalmAudioQCELPParamType
  • minSize : PhnSATEventGetInput
  • minute : Coordinate
  • minValue : CamLibSettingTag , LcdOverlayLibSettingTag
  • minVol : HsSndPortInfo
  • mipSessionFailReason : PhnEventType::Data
  • mipSessionType : PhnOneXStatus
  • miscData : ParsedInfo
  • miscDbgRpt : PhnEventType::Data
  • miscUpdate : PhnMiscDbgRptType
  • mLocked : AddressAppRecord
  • mmiBarring : PhnMMIEntryType , PhnMMIResultType
  • mmiCallControl : PhnMMIEntryType
  • mmiCallerID : PhnMMIResultType
  • mmiCallWaiting : PhnMMIEntryType , PhnMMIResultType
  • mmiColp : PhnMMIResultType
  • mmiColr : PhnMMIResultType
  • mmiForwarding : PhnMMIEntryType , PhnMMIResultType
  • mmiIMEI : PhnMMIResultType
  • mmiNumberSent : PhnMMIResultType
  • mmiPassword : PhnMMIEntryType
  • mmiPhoneNumber : PhnMMIEntryType
  • mml_server_name : _PhnLibMMSServerInfo
  • mms_server_name : _PhnLibMMSServerInfo
  • mmsSoundPrefs : SoundPreference::_tonePrefs
  • mn_aaa_spi : PhnPDPPayload , PhnPDPWrite
  • mn_aaa_ss : PhnPDPWrite , PhnPDPPayload
  • mn_aaa_ss_length : PhnPDPPayload , PhnPDPWrite
  • mn_ha_spi : PhnPDPWrite , PhnPDPPayload
  • mn_ha_ss : PhnPDPWrite , PhnPDPPayload
  • mn_ha_ss_length : PhnPDPPayload , PhnPDPWrite
  • mode : PhnMMIEntryType , PalmAudioAMRParamType , PhnPhoneEquipmentMode
  • modifiers : PhnKeyPressedParams
  • month : DSTDataTag
  • moreData : _pluginParams , _pluginSendParams , MMProAttachStruct2
  • moved : PhnEventType::Data
  • moveMessages : PhnIndicationType
  • moveRequested : PhnSMSParams
  • msec : HS_HTTPLibTime_
  • msgAlert : SoundPreferenceSMS , PhnRingingProfileType
  • msgBox : PhnEventType::Data
  • msgClass : PhnSMSParams
  • msgCount : PmBroadcastNewMsgCountNotifyParamType
  • msgID : WUNotificationEventType , UPNotificationEventType , tagIOTANotificationEventType , PhnMovedMsgDescType , NBSNotificationEventType
  • msgInd : PhnSMSParams
  • msgNumber : ParsedInfo
  • msgOwner : PhnMovedMsgDescType
  • msgType : PhnSMSParams , HsSndMidiProgressMsg
  • mSIMMessagesAcknowledge : PhnIndicationType
  • multiparty : PhnConnectionType
  • mutexSticky : NetPrefFallbackInfoType
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:09 2008 for Palm API Guide


  • All
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- n -

  • nai : PhnPDPWrite , PhnPDPPayload
  • NAI : WUNotificationEventType
  • nai_length : PhnPDPWrite , PhnPDPPayload
  • NALUnit : PalmVideoAVCDecodeParamType
  • NALUnitSize : PalmVideoAVCDecodeParamType
  • name : PhnMMIEntryType , ToneItemType , _HelperServiceMMSObjectType , PhoneAppLaunchCmdDialType , _pluginSendParams , ApptTimeZoneType , _PalmPhotoFileLocation , LocDBRecordTag , LocationDataTag
  • nameLength : ParsedInfo
  • nameP : PhoneAppLaunchCmdCallerIDLookupType
  • namInUse : PhnIOTAReportType
  • navFlags : FrmNavHeaderTag
  • NBSdatagram : NBSNotificationEventType
  • needSelLoc : LocsLibSelLocsTag
  • netTimeStamp : WUNotificationEventType
  • networkAvailable : PhnIndicationType
  • networkError : PhnError
  • networkMsgId : PhnSMSParams
  • networkSoundPrefs : SoundPreference::_tonePrefs
  • networkTime : PhnEventType::Data
  • newControlProc : HtmlLibFormWidgetProc
  • newDim : AiaExtentChangedEventDataType
  • newFieldProc : HtmlLibFormWidgetProc
  • newListProc : HtmlLibFormWidgetProc
  • newMailAlert : SoundPreferenceEmail
  • newPhoneNum : AddrPhonebookAppParamsType
  • newPwd : PhnMMIEntryType
  • newStatus : PhnSMSParams
  • nextAction : PhnSATEventMenuRec
  • nextP : _HelperServiceMMSObjectType , PhnGPRSPDPContextListNodeType
  • nid : PhnCdmaSystemInfoType
  • noAddToCustomDB : LocsLibSelLocsTag
  • noEditOnSelect : LocsLibSelLocsTag
  • note : LocationDataTag
  • notificationType : PhnSATEventIdleModeText , PhnSATEventRefresh , PhnSATEventSetupCall , PhnSATEventDataSvc , PhnSATEventType , PhnSATEventDisplayText , PhnSATEventGetInkey , PhnSATEventHeader , PhnSATEventGetInput , PhnSATEventPlayTone , PhnSATEventMenu , PhnSATEventSendDTMF , PhnSATEventSendSMS , PhnSATEventLaunchBrowser , PhnSATEventRunAT
  • notifyType : LocsLibNotifyDataTag
  • num_def_pdp_idxs : PhnPDPList
  • num_stand_pdp_idxs : PhnPDPList
  • num_tmp_pdp_idxs : PhnPDPList
  • numAccounts : SysVPPILaunchCmdGetAccountsType
  • numAttach : MMProLaunchStruct , MMProLaunchStruct2
  • numAttachments : MailAddRecordParamsTypePlus
  • numAuthenticationMethods : SysWPPILaunchCmdGetAuthenticationMethodsType
  • number : PhnMMIResultType , PhoneAppLaunchCmdDialType , PhnMMIEntryType
  • numberOffset : PhnSATEventSetupCall
  • numberOfObjects : FrmNavHeaderTag
  • numberP : PhoneAppLaunchCmdCallerIDLookupType
  • numBytes : CamLibBitmapInfoTag
  • numDataLinks : _pluginSendParams , MMProAttachStruct2 , _pluginParams
  • numItems : _pluginExtendedQueryParams , _pluginQueryParams
  • numProfiles : NetServicesProfileInfo
  • numReceiveTypes : _pluginGetInfoParams
  • numSelLocs : LocsLibSelLocsTag
  • numSendTypes : _pluginGetInfoParams
  • numServices : DialPnlIsDialingAvailableParamsType
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:09 2008 for Palm API Guide


  • All
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- o -

  • object : _HelperServiceMMSDetailsType
  • objectFlags : FrmNavOrderEntryTag
  • objectID : FrmNavOrderEntryTag
  • offlineProc : HS_HTTPLibNetLibInfo_
  • offset : _PalmPhotoSelectionParam
  • oldDim : AiaExtentChangedEventDataType
  • oldPwd : PhnMMIEntryType
  • oldStatus : PhnSMSParams
  • oneXFailReason : PhnEventType::Data
  • oneXStatus : PhnEventType::Data
  • oneXStatusPRev : PhnOneXStatus
  • onlineProc : HS_HTTPLibNetLibInfo_
  • opData : PhnOperatorListType
  • openProc : HS_HTTPLibNetLibInfo_
  • operation : DevAppLaunchCmdGenericCallType
  • opMode : NetServicesProfile , NetServicesProfileV1
  • options : AddressAppRecordHeader
  • order : NetServicesProfileOrder
  • origCreator : SysVPPILaunchCmdPromptAndConfigureType
  • origInstance : SysVPPILaunchCmdPromptAndConfigureType
  • otaspMsg : PhnIndicationType
  • owner : SmsHeader , PhnConnectionType
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:09 2008 for Palm API Guide


  • All
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- a -

  • aboveObjectID : FrmNavOrderEntryTag
  • account : SysVPPILaunchCmdEditAccountType , SysVPPILaunchCmdDeleteAccountType , SysVPPILaunchCmdSetCurrentAccountType
  • accountID : VPNAccountType
  • accountName : VPNAccountType
  • accounts : SysVPPILaunchCmdGetAccountsType
  • acknowledge : PhnEventType
  • action : PhnMMIEntryType
  • Action : P1clRecordDetails
  • action : PhnSATEventLaunchBrowser
  • actionCode : PalmAudioPlaybackNotifyEventTypeTag , PhnMMIEntryType
  • activate : PhnSMSParams
  • active_idx : PhnPDPList
  • active_idx_set : PhnPDPList
  • activeCall : AddrPhonebookAppParamsType
  • activeLine : PhnLineStateType
  • activeLineNumber : PhnRadioStateType
  • add1BeforeAreaCode : HsDialPrefsUSDialingRulesType
  • addr : HS_HTTPLibIPAddr_ , PhnIOTAPhnNAISIPEdgeProxyType , PhnIOTAPhnProxyAddrWdpType
  • address : AddressType , PhnConnectionType
  • addressSize : AddressType
  • alarmPreset : SoundPreferenceCalendar
  • alarmTone : SoundPreferenceCalendar
  • albumID : _PalmPhotoSelectionParam
  • alertTone : SoundPreferenceEmail
  • algorithm : PalmVideoMPEG4EncodeParamType , NetPrefFallbackInfoType
  • alphaIdOffset : PhnSATEventSendDTMF , PhnSATEventLaunchBrowser , PhnSATEventIdleModeText , PhnSATEventRunAT , PhnSATEventDataSvc
  • alsSupported : PhnRadioStateType
  • altitude : PhnPDDataType
  • amplitude : HsSndBufferData
  • apiCreator : SndCodecCustomControlType
  • apiSelector : SndCodecCustomControlType
  • apn : PhnGPRSPDPContextType
  • appCreator : HS_HTTPLibAppinfo_
  • appId : WAPNotificationEventType
  • areaCodeCtl : HsDialPrefsUSDialingRulesType
  • ascP : PalmAudioAACDecParamType
  • aSize : MMProAttachStruct2 , MMProAttachStruct
  • assigned : SysWPPILaunchCmdType
  • athenaDeviceCreatorCode : PmConnectorNotifyDataType
  • attachData : MailAddRecordAttachment
  • attachDBID : MailAddRecordAttachment
  • attachDescription : MailAddRecordAttachment
  • attachFileName : MailAddRecordAttachment
  • attachment : MMProAttachStruct , MMProAttachStruct2
  • attachments : MMProLaunchStruct2 , MailAddRecordParamsTypePlus , MMProLaunchStruct
  • attachName : MMProAttachStruct2 , MMProAttachStruct
  • attachSize : MailAddRecordAttachment
  • attachType : MailAddRecordAttachment
  • audioAlertEnable : PhnSMSPrefType
  • authentication : NetServicesProfile , NetServicesProfileV1
  • authenticationMethodID : SysWPPILaunchCmdGetDescriptionType , WiFiAuthenticationMethodType , SysWPPILaunchCmdType
  • authenticationMethodName : WiFiAuthenticationMethodType
  • authenticationMethods : SysWPPILaunchCmdGetAuthenticationMethodsType
  • auto4DigitPrefix : HsDialPrefsUSDialingRulesType
  • auto5DigitPrefix : HsDialPrefsUSDialingRulesType
  • auto6DigitPrefix : HsDialPrefsUSDialingRulesType
  • autoAreaCode : HsDialPrefsUSDialingRulesType
  • autoOffWhenClosed : PowerPanelAppPrefs
  • autoOnWhenOpened : PowerPanelAppPrefs
  • availableService : PhnDataSessionStateType
  • avgBytesPerSec : PalmAudioMP2ParamType
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:09 2008 for Palm API Guide


  • All
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- b -

  • bandClass : PhnCdmaSystemInfoType
  • bcc : MMProLaunchStruct , _HelperServiceMMSDetailsType , MMProLaunchStruct2
  • bCroppedMode : PalmVideoAVCCustomSetCropModeType
  • bearerOffset : PhnSATEventLaunchBrowser
  • belowObjectID : FrmNavOrderEntryTag
  • binary : NBSNotificationEventType
  • bitmapID : PmSysGadgetBbutMappingType , HsBigButtonMappingType
  • bitRate : PalmAudioAACParamType , PalmVideoMPEG4EncodeParamType
  • bitsPerPixel : _PalmPhotoImageInfo , CamLibBitmapInfoTag
  • bitsPerSample : PalmAudioMP2ParamType
  • blockSize : PalmAudioADPCMParamType
  • body : MMProLaunchStruct , MMProLaunchStruct2
  • boostDB : HsSndPortInfo
  • bottomLeftObjectIDHint : FrmNavHeaderTag
  • bounds : HtmlLibFocusTargetInfo
  • BSS : BSSListStruct
  • bssANL : NetBssInfoType
  • bssAtimWindow : NetBssInfoType
  • bssBeaconPeriod : NetBssInfoType
  • bssChannelId : NetBssInfoType
  • bssDSFreq : NetBssInfoType
  • bssHopDwell : NetBssInfoType
  • bssHopPattern : NetBssInfoType
  • bssHopSet : NetBssInfoType
  • bssMacAddr : NetBssInfoType
  • bssNetworkMode : NetBssInfoType
  • bssNetworkType : NetBssInfoType
  • bssRssi : NetBssInfoType
  • bssSsid : NetBssInfoType
  • bssSsidLength : NetBssInfoType
  • bssSupportedRates : NetBssInfoType
  • bssWepEnabled : NetBssInfoType
  • buffer : HsSndBufferData
  • bufferLen : _HelperServiceMMSObjectType
  • bufferP : _PalmPhotoFileLocation , _HelperServiceMMSObjectType
  • bufferSize : _PalmPhotoFileLocation , HsSndBufferData
  • bufP : CamLibStreamTag
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:09 2008 for Palm API Guide


  • All
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- c -

  • calendarSoundPrefs : SoundPreference::_tonePrefs
  • call1ID : PhnConferenceDesc
  • call2ID : PhnConferenceDesc
  • callback : AddrCallerIDParamsType
  • callbackAddress : PhnSMSParams
  • callbackP : CamLibCaptureTag
  • caller : PhnSubscriberAddrInfo
  • callType : PhnSATEventSetupCall
  • cancel : SysWPPILaunchCmdType
  • captureCallback : _PalmPhotoCaptureParamV2
  • category : MailAddRecordParamsTypePlus
  • cc : MMProLaunchStruct , _HelperServiceMMSDetailsType , MMProLaunchStruct2
  • cert : PhnIOTAPhnTlsRcUrlType
  • certDBName : HS_HTTPLibAppinfo_
  • certDBType : HS_HTTPLibAppinfo_
  • certDBVersion : HS_HTTPLibAppinfo_
  • chanId : PhnSATEventDataSvc
  • channel : NetServicesProfile , NetServicesProfileV1
  • channels : PalmAudioMP2ParamType
  • chatTone : SoundPreferenceIM
  • chNum : PhnCdmaSystemInfoType
  • chromaFormat : PalmVideoAVCCustomGetInfoType
  • clearMode : PhnSATEventDisplayText
  • clientRect : SysVPPILaunchCmdProgressPaintType
  • closeProc : HS_HTTPLibNetLibInfo_
  • cnt : PhnIOTAPhnSIPRetryCntType
  • code : PhnDisconnectEventType , PhnError
  • color : ParsedInfo
  • colorBits : PalmImageINDEXParamType
  • colorImportant : PalmImageBMPParamType
  • colorTable : PalmImageINDEXParamType
  • colorUsed : PalmImageBMPParamType
  • companyOffset : AddressAppRecordHeader
  • completion_callback : HsSndBufferData
  • completion_userdata : HsSndBufferData
  • compositionTime : PalmVideoAVCDecodeParamType , PalmVideoAVCCustomGetDecodedFrameType
  • compositionTimestamp : PalmVideoAVCDecodeParamType , PalmVideoAVCCustomGetDecodedFrameType
  • compression : PalmImageBMPParamType
  • conference : PhnEventType::Data
  • conferenceID : PhnConferenceDesc
  • confirm : PhoneAppLaunchCmdDialType
  • confirmDeletion : PhnSMSPrefType
  • connection_type : PhnPDPWrite , PhnPDPPayload
  • connectionID : PhnEventType
  • contentType : WAPNotificationEventType
  • contextId : PhnGPRSPDPContextType
  • continuePowerOnOff : PhnIndicationType
  • controls : HsSndBufferData
  • cookie : SysWPPILaunchCmdType
  • cookieDBCreator : HS_HTTPLibAppinfo_
  • cookieDBName : HS_HTTPLibAppinfo_
  • cookieDBType : HS_HTTPLibAppinfo_
  • cookieDBVersion : HS_HTTPLibAppinfo_
  • cookieMaxJarSize : HS_HTTPLibAppinfo_
  • count : PhnMovedMsgsParamsType , Address , PhnOperatorListType , BSSListStruct , AddrDescriptor
  • country : LocationDataTag , LocDBRecordTag , ApptTimeZoneType
  • creator : _PalmPhotoFileLocation , AacFileRef
  • creatorId : PmSysGadgetPttNotificationType
  • CreatorId : P1clRecordDetails
  • credentialsLabel : SysWPPILaunchCmdType
  • credentialsSelectorTrigger : SysWPPILaunchCmdType
  • currentMillisecond : tagSndFileStreamData
  • currentPan : HsSndPortInfo
  • currentVol : HsSndPortInfo
  • custom : LocationDataTag , ApptTimeZoneType , LocDBRecordTag
  • customDataP : tagSndFileStreamData
  • customDataSize : tagSndFileStreamData
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:09 2008 for Palm API Guide


  • All
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- d -

  • data : MMProAttachDataLinks , _dataLinks , _pluginParams , PhnMMIEntryType , PhnMMIResultType , AddressAppRecordHeader , AddrCreateNewRecordParamsType , AddrAddToRecordParamsType , MailAddRecordAttachment , PhnIndicationType , PhnProgressEventType , PhnEventType
  • dataChannelAvailability : PhnEventType::Data
  • dataDuration : tagSndFileStreamData
  • dataH : PhnSATEventType
  • dataLen : tagIOTANotificationEventType , NBSNotificationEventType
  • dataP : tagIOTANotificationEventType , NBSNotificationEventType , DialPnlDispatchDialParamsType , PalmAudioPlaybackNotifyEventTypeTag
  • dataSesstionStatus : PhnEventType::Data
  • dataSize : tagSndFileStreamData
  • date : SmsHeader
  • datetime : tagIOTANotificationEventType , NBSNotificationEventType , WUNotificationEventType , UPNotificationEventType , WAPNotificationEventType
  • day : HS_HTTPLibTime_
  • daylightSavings : PhnNetworkTime
  • daylightSavingsHour : PhnNetworkTime
  • dayOrd : DSTDataTag
  • db : _pluginParams , _pluginQueryParams , _pluginSendParams , _pluginExtendedQueryParams
  • dbCardNum : LocDBInfoTag
  • dbCreatorID : LocDBInfoTag
  • dbName : LocDBInfoTag
  • dbType : LocDBInfoTag
  • defaultConnProfileName : NetMasterClientEventVPNConnInstallType
  • defaultItem : PhnSATEventMenu
  • defaultOffset : PhnSATEventGetInput
  • degree : Coordinate
  • delayTime : PalmImageGIFFrameParamType
  • deleteObjectProc : HtmlLibFormWidgetProc
  • deliveryAck : _PhnLibMMSServerInfo
  • description : SysWPPILaunchCmdGetDescriptionType
  • descriptionSize : SysWPPILaunchCmdGetDescriptionType
  • descriptionStr : DialPnlDispatchDialParamsType
  • destPort : PhnSMSParams
  • deviceClass : PmConnectorNotifyDataType
  • dhcpRequestDNS : NetServicesProfileV1 , NetServicesProfile
  • dial_str : PhnPDPWrite , PhnPDPPayload
  • dial_str_length : PhnPDPWrite , PhnPDPPayload
  • dialMethod : PhoneAppLaunchCmdDialType
  • dialog : PhnIndicationType , PhnProgressEventType
  • dirtyBit : SysVPPILaunchCmdEditAccountType
  • dirtySelections : LocsLibSelLocsTag
  • disconnect : PhnEventType::Data
  • disconnectStatus : PhnDataSessionStateType
  • displayCallback : _PalmPhotoDisplayParam
  • displayDialPrefs : PhoneAppLaunchCmdGetDialPrefFlagType
  • displaySIMbook : AddrHsLookupUserDataV2Type
  • displayStatus : PhnMMIResultType
  • disposalMethod : PalmImageGIFFrameParamType
  • divertIndicator : PhnLineStateType
  • dns_server_assigned : PhnPDPPayload , PhnPDPWrite
  • doneButtonLabel : webBrowserMinimalModeLaunchInfo
  • driverDate : Net80211DeviceInfo
  • dSTAdjustmentInMinutes : LocationDataTag , LocDBRecordTag , ApptTimeZoneType
  • dSTEnd : LocDBRecordTag , ApptTimeZoneType , LocationDataTag
  • dstPort : NBSNotificationEventType
  • dSTStart : LocationDataTag , ApptTimeZoneType , LocDBRecordTag
  • dtmfChar : PhnSATEventSendDTMF
  • dtxMode : PalmAudioAMRParamType
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:09 2008 for Palm API Guide


  • All
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- e -

  • echoMode : PhnSATEventGetInput
  • EFList : PhnSATEventRefresh
  • emailSoundPrefs : SoundPreference::_tonePrefs
  • enabled : PhnMMIResultType
  • endianess : PalmImageINDEXParamType , PalmImageParamType
  • eriStatusTone : SoundPreferenceNetworkSounds
  • err : DialPnlDispatchDialParamsType , SysVPPILaunchCmdGetAccountsType , SysVPPILaunchCmdDeleteAccountType , SysVPPILaunchCmdEditAccountType , SysVPPILaunchCmdSetCurrentAccountType , SysWPPILaunchCmdGetAuthenticationMethodsType , SysWPPILaunchCmdType , SysWPPILaunchCmdGetDescriptionType
  • error : SysWPPILaunchCmdErrorDialogType , SysVPPILaunchCmdErrorDialogType , PhnIOTAReportType , PhnPasswordEventType , PhnMovedMsgDescType , PhnEventType::Data
  • errOut : SysWPPILaunchCmdClearPWCache , SysVPPILaunchCmdClearPWCacheType , SysWPPILaunchCmdPromptAndConfigureType , SysVPPILaunchCmdProgressPaintType , SysVPPILaunchCmdErrorDialogType , SysVPPILaunchCmdPromptAndConfigureType , SysVPPILaunchCmdWillPWPromptType , SysWPPILaunchCmdErrorDialogType
  • esdsP : PalmAudioAACDecParamType
  • eType : vpnNotifyVPNLibTag
  • event : PhnMovedMsgDescType
  • eventData : NetMasterClientEventInfoType
  • eventID : NetMasterClientEventInfoType
  • eventType : PhnEventType
  • extraDigits : PhoneAppLaunchCmdDialType
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:09 2008 for Palm API Guide


  • All
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- f -

  • face : VMFontType
  • failLaunchCode : PhoneAppLaunchCmdDialType
  • failLaunchCreator : PhoneAppLaunchCmdDialType
  • failLaunchParams : PhoneAppLaunchCmdDialType
  • fbStatusFlags : NetPrefFallbackInfoType
  • fChallenge : HS_HTTPLibAuthInfo_
  • fDummy : HS_HTTPLibOpaque_
  • features : PhnSATEventMenuRec
  • field : AddrCreateNewRecordParamsType , AddrAddToRecordParamsType
  • file : AacFileRef , _PalmPhotoFileLocation
  • fileCreator : tagSndFileStreamFileSpec
  • fileExt : _pluginParams , _pluginQueryParams , _pluginSendParams , _pluginExtendedQueryParams
  • fileFormat : tagSndFileStreamData , _PalmPhotoImageInfo , PalmAudioAACDecParamType
  • fileH : AacFileRef
  • fileLocation : _PalmPhotoCaptureParamV2 , _PalmPhotoCreateParam
  • fileLocationType : PalmFileFormatParamType , _PalmPhotoFileLocation
  • fileNameP : tagSndFileStreamFileSpec
  • fileRef : AacFileRef
  • filesize : _PalmPhotoImageInfo
  • fileType : tagSndFileStreamFileSpec
  • filler : PhnIndicationType , Address
  • filterCallback : _PalmPhotoSelectionParam
  • first_def_pdp_idx : PhnPDPList
  • first_stand_pdp_idx : PhnPDPList
  • first_tmp_pdp_idx : PhnPDPList
  • firstEntry : PhnPhoneBookInfoType
  • fix_t : PhnPDDataType
  • flags : AacFileRef , AddressAppRecordHeader , SmsHeader , AddrCallerIDParamsType , tagSndFileStreamFileSpec , HsBigButtonMappingType , HsSndPortInfo , HsSndBufferData , PmSysGadgetBbutMappingType
  • fMatchString : HttpUASelectionRule
  • fname : _pluginParams
  • fNC : HS_HTTPLibAuthInfo_
  • fNextNonce : HS_HTTPLibAuthInfo_
  • font : HsBigButtonMappingType , PmSysGadgetBbutMappingType
  • fontFaceVisible : VMFontUIRules
  • fontSizeVisible : VMFontUIRules
  • fontStyleVisible : VMFontUIRules
  • format : PhnSATEventGetInkey , PhnSATEventGetInput
  • formatString : AddrCallerIDParamsType
  • formObjectID : HtmlLibFocusTargetInfo
  • fPass : HS_HTTPLibAuthInfo_
  • frameHeight : PalmVideoAVCCustomGetInfoType
  • frameHeightCropped : PalmVideoAVCCustomGetInfoType
  • frameNum : CamLibStreamTag
  • frameP : PalmAudioAACDecParamType
  • frameRate : PalmVideoMPEG4EncodeParamType
  • frameSize : PalmAudioAACDecParamType
  • framesReady : PalmVideoAVCCustomGetDecodedFrameType , PalmVideoAVCOutputBufferType
  • frameTime : CamLibStreamTag
  • frameWidth : PalmVideoAVCCustomGetInfoType
  • frameWidthCropped : PalmVideoAVCCustomGetInfoType
  • fRealm : HS_HTTPLibAuthInfo_
  • freeReply : SMSSendOptions
  • freeTempFile : _HelperServiceMMSObjectType
  • fType : HttpUASelectionRule
  • fUser : HS_HTTPLibAuthInfo_
  • fUserAgent : HttpUASelectionRule
  • fwName : Net80211DeviceInfo
  • fwRev : Net80211DeviceInfo
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:09 2008 for Palm API Guide


  • All
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- g -

  • gadgetID : PmSysGadgetBbutMappingType , HsBigButtonMappingType
  • gatewayProxyOffset : PhnSATEventLaunchBrowser
  • genericEventDataP : NetMasterClientEventInfoType
  • getInfo : _pluginGetInfoParams
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:09 2008 for Palm API Guide


  • All
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- h -

  • handled : DialPnlDispatchDialParamsType
  • hasLocalColorTable : PalmImageGIFFrameParamType
  • hasTransparentColor : PalmImageGIFFrameParamType
  • headerLen : tagIOTANotificationEventType , UPNotificationEventType , NBSNotificationEventType , WUNotificationEventType
  • headerP : UPNotificationEventType , tagIOTANotificationEventType , NBSNotificationEventType , PalmAudioQCELPDecParamType , WUNotificationEventType
  • headerSize : PalmAudioQCELPDecParamType
  • headerSizeInBytes : FrmNavHeaderTag
  • heading : PhnPDDataType
  • height : CamLibBitmapInfoTag , _PalmPhotoImageInfo , PalmVideoMPEG1DecodeParamType , PalmImageParamType , PalmImageINDEXParamType , PalmImagePlanarType
  • helperServiceClass : PmGetNewMsgCountNotifyParamType , PmBroadcastNewMsgCountNotifyParamType
  • helpInfo : PhnSATEventGetInkey , PhnSATEventGetInput
  • home_addr : PhnPDPPayload , PhnPDPWrite
  • homePage : _PhnCDMAMediaTVSettings
  • horizontalOffset : PalmVideoAVCCustomGetInfoType
  • hour : DSTDataTag
  • HS_HTTPLibPeerTCPCanReadWrite : HS_HTTPLibPeer_
  • HS_HTTPLibPeerTCPClose : HS_HTTPLibPeer_
  • HS_HTTPLibPeerTCPConnect : HS_HTTPLibPeer_
  • HS_HTTPLibPeerTCPIsConnected : HS_HTTPLibPeer_
  • HS_HTTPLibPeerTCPOpen : HS_HTTPLibPeer_
  • HS_HTTPLibPeerTCPRead : HS_HTTPLibPeer_
  • HS_HTTPLibPeerTCPWrite : HS_HTTPLibPeer_
  • hsCmd : tagSndFileStreamHsSoundCommandParam
  • hsFormat : tagSndFileStreamHsSoundCommandParam
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:09 2008 for Palm API Guide


  • All
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- i -

  • id : PhnConnectionType , PhnError , PhnSMSParams , PhnSATEventMenuRec , WAPNotificationEventType , PhnOperatorType , PhnMMIEntryType , ToneIdentifier
  • identifier : ToneItemType
  • idx : PhnPDPWrite
  • idx0_set : PhnPDPList
  • idx0_uid : PhnPDPList
  • idx1_set : PhnPDPList
  • idx1_uid : PhnPDPList
  • idx2_set : PhnPDPList
  • idx2_uid : PhnPDPList
  • idx3_set : PhnPDPList
  • idx3_uid : PhnPDPList
  • idx4_set : PhnPDPList
  • idx4_uid : PhnPDPList
  • idx5_set : PhnPDPList
  • idx5_uid : PhnPDPList
  • idx6_set : PhnPDPList
  • idx6_uid : PhnPDPList
  • idx7_set : PhnPDPList
  • idx7_uid : PhnPDPList
  • idx_RSVD8_set : PhnPDPList
  • idx_rsvd8_uid : PhnPDPList
  • idx_RSVD9_set : PhnPDPList
  • idx_rsvd9_uid : PhnPDPList
  • ifCreator : SysWPPILaunchCmdPromptAndConfigureType , vpnNotifyVPNLibTag
  • ifInstance : SysWPPILaunchCmdPromptAndConfigureType , vpnNotifyVPNLibTag
  • imageBits : AddrPhotoCallerIDParamsType
  • imageCount : _PalmPhotoSelections
  • imageDataP : PalmImageINDEXParamType , PalmImageGIFFrameParamType
  • imageDataSize : PalmImageGIFFrameParamType
  • imageFormat : _PalmPhotoReadWriteParam
  • imageH : _PalmPhotoSelections
  • imageHeight : PalmImageGIFFrameParamType
  • imageInfo : _PalmPhotoCreateParam , _PalmPhotoCaptureParamV2
  • imageQuality : _PalmPhotoImageInfo
  • imageWidth : PalmImageGIFFrameParamType
  • imei : PhnMMIResultType
  • imSoundPrefs : SoundPreference::_tonePrefs
  • incoming : PhnConnectionType
  • index : PhnIOTAPhnTlsRcUrlType , PhnIOTAPhnNAISIPEdgeProxyType , PhnIOTAPhnProxyAddrWdpType , PhnIOTAPhnNAISIPCfgSvr , PhnIOTAPhnNAIPPGType , PhnIOTAPhnNAISIPDataxchType , PhnIOTAPhnNAISIPDatagwyType , PhnIOTAPhnSIPRetryTimerType , PhnIOTAPhnNAIIMStore , PhnIOTAPhnSIPRetryCntType
  • indication : PhnEventType::Data
  • indicationCode : PhnIndicationType
  • indicator : PhnSMSParams
  • indicatorOn : PhnMsgBoxDataType
  • indType : PhnSMSParams
  • info : PhnEventType::Data , ParsedInfoList
  • InfoBuffer : NetworkDeviceQueryData
  • InfoBufferLength : NetworkDeviceQueryData
  • infoP : _PalmPhotoExtraInfo
  • infoSize : _PalmPhotoExtraInfo
  • InfoSize : NetworkDeviceQueryData
  • InfoSizeRequired : NetworkDeviceQueryData
  • infoType : _PalmPhotoExtraInfo
  • init_rrq : PhnOnexMipRRQType
  • initialObjectIDHint : FrmNavHeaderTag
  • inReserved1 : NetMasterClientEventVPNConnInstallType , NetMasterClientEventInfoType
  • inReserved2 : NetMasterClientEventVPNConnInstallType , NetMasterClientEventInfoType
  • inReserved3 : NetMasterClientEventInfoType
  • inReserved4 : NetMasterClientEventInfoType
  • interactive : MMProLaunchStruct , MMProLaunchStruct2
  • iota_ph_dls_lock : PhnIOTAPhnDlsLockType
  • iotaInfo : PhnEventType::Data
  • ipAllocType : NetServicesProfile , NetServicesProfileV1
  • ipGateway : NetServicesProfile , NetServicesProfileV1
  • ipMask : NetServicesProfileV1 , NetServicesProfile
  • ipPrimaryDNS : NetServicesProfileV1 , NetServicesProfile
  • ipSecondaryDNS : NetServicesProfileV1 , NetServicesProfile
  • isForeground : HS_HTTPLibAppinfo_
  • isInterlaced : PalmImageGIFFrameParamType
  • isRoaming : PhnOperatorType
  • isVFSFileName : _HelperServiceMMSObjectType
  • item : _pluginSendParams
  • itemDescriptors : _pluginQueryParams
  • itemLength : ParsedInfo
  • itemSizes : _pluginQueryParams
  • IVOPQuantization : PalmVideoMPEG4EncodeParamType
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:09 2008 for Palm API Guide


  • All
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- p -

  • pad : PhnSATEventGetInput , PhnSATEventPlayTone , PhnSATEventRefresh
  • padding1 : FrmNavHeaderTag , vpnNotifyVPNLibTag
  • padding2 : vpnNotifyVPNLibTag
  • padding3 : vpnNotifyVPNLibTag
  • pageNum : _HelperServiceMMSObjectType
  • param1 : HsSndMidiProgressMsg
  • param2 : HsSndMidiProgressMsg
  • params : PhnEventType::Data
  • parsedType : ParsedInfo
  • passwdNeeded : PhnSATEventDataSvc
  • password : WUNotificationEventType , PhnEventType::Data
  • passwordAccepted : PhnIndicationType
  • PDDataInfo : PhnEventType::Data
  • pdp_services : PhnPDPWrite , PhnPDPPayload
  • pdpAddr : PhnGPRSPDPContextType
  • pdpDataCompression : PhnGPRSPDPContextType , NetPrefGPRSQOSType
  • pdpHdrCompression : PhnGPRSPDPContextType
  • pdpHeaderCompression : NetPrefGPRSQOSType
  • pdpType : PhnGPRSPDPContextType
  • pdSessionStatus : PhnOneXStatus
  • phn_pd_svc_mask : PhnPDDataType
  • PhnOnxMipRRQ : PhnEventType::Data
  • phoneBookIndex : Address
  • phoneEquipmentMode : PhnEventType::Data
  • phoneSoundPrefs : SoundPreference::_tonePrefs
  • picHeight : PalmVideoAVCCustomGetDecodedFrameType
  • picHeightCropped : PalmVideoAVCCustomGetDecodedFrameType
  • picWidth : PalmVideoAVCCustomGetDecodedFrameType
  • picWidthCropped : PalmVideoAVCCustomGetDecodedFrameType
  • pin : PhnPasswordEventType
  • pix_place_server : _PhnLibMMSServerInfo
  • planarData : PalmVideoAVCCustomGetDecodedFrameType
  • planeCount : PalmImagePlanarType
  • planeP : PalmImagePlanarType
  • planeWidth : PalmImagePlanarType
  • playbackCount : tagSndFileStreamData
  • playSoundTimes : SoundPreferenceCalendar
  • portID : HsSndPortInfo
  • position : LocationDataTag
  • power : PhnEventType::Data
  • powerOnOffContinueCallback : PhnIndicationType
  • preambleType : NetServicesProfileV1 , NetServicesProfile
  • prefix4DigitCtl : HsDialPrefsUSDialingRulesType
  • prefix5DigitCtl : HsDialPrefsUSDialingRulesType
  • prefix6DigitCtl : HsDialPrefsUSDialingRulesType
  • preSelect : LocsLibSelLocsTag
  • presetTime : SoundPreferenceCalendar
  • presetTimeUnit : SoundPreferenceCalendar
  • prevType : PhnPasswordEventType
  • prim_dns_addr : PhnPDPWrite , PhnPDPPayload
  • prim_ha_addr : PhnPDPWrite , PhnPDPPayload
  • priority : PhnMsgBoxDataType , PhnSMSParams , PhnSATEventDisplayText
  • privacy : PhnSMSParams , SoundPreferenceSMS
  • profile : PalmAudioAACParamType , PalmVideoMPEG4EncodeParamType , PalmVideoMPEG4DecodeParamType
  • profileEntrySize : NetServicesProfileInfo
  • profileName : NetServicesProfile , NetServicesProfileV1
  • profileRev : NetServicesProfileInfo
  • profiles : PhnRingingInfoType
  • progress : PhnProgressEventType , PhnEventType::Data
  • progress_callback : HsSndBufferData
  • progress_userdata : HsSndBufferData
  • promptOffset : PhnSATEventSetupCall
  • protectedTone : ToneItemType
  • protocolErr : BGResult
  • protocolErrString : BGResult
  • provOffset : PhnSATEventLaunchBrowser
  • proxyAddr : _PhnCDMAMediaTVSettings
  • proxyPort : _PhnCDMAMediaTVSettings
  • ptr : _pluginSendParams
  • puk : PhnPasswordEventType
  • pwd : PhnMMIEntryType
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:09 2008 for Palm API Guide


  • All
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- q -

  • qid : NetworkDeviceQueryData
  • qnc_set : PhnPDPList
  • qnc_uid : PhnPDPList
  • qosMinDelayClass : NetPrefGPRSQOSType
  • qosMinMeanThruClass : NetPrefGPRSQOSType
  • qosMinPeakThruClass : NetPrefGPRSQOSType
  • qosMinPrecedenceClass : NetPrefGPRSQOSType
  • qosMinReliabilityClass : NetPrefGPRSQOSType
  • qosReqDelayClass : NetPrefGPRSQOSType
  • qosReqMeanThruClass : NetPrefGPRSQOSType
  • qosReqPeakThruClass : NetPrefGPRSQOSType
  • qosReqPrecedenceClass : NetPrefGPRSQOSType
  • qosReqReliabilityClass : NetPrefGPRSQOSType
  • quality : PalmImageJPEGEncodeParamType
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:09 2008 for Palm API Guide


  • All
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- r -

  • rcptAlert : SoundPreferenceSMS
  • reasonCode : WUNotificationEventType
  • record : PhnSATEventMenu
  • recordCount : PhnSATEventMenu
  • RecordIndex : P1clRecordDetails
  • recordNum : AddrCallerIDParamsType , AddrPhotoCallerIDParamsType
  • RecordUId : P1clRecordDetails
  • rect : _PalmPhotoDisplayParam
  • recvBufferSize : HS_HTTPLibAppinfo_
  • reducedRate : PalmAudioQCELPParamType
  • ref : AddrCallerIDParamsType
  • refNum : NBSNotificationEventType , HS_HTTPLibNetLibInfo_
  • refreshType : PhnSATEventRefresh
  • registration : PhnEventType::Data
  • reminderTone : SoundPreferenceCalendar
  • repeatAlarmTimes : SoundPreferenceCalendar
  • repeated : PhoneAppLaunchCmdSendDTMFToneType
  • repeatInterval : SoundPreferenceCalendar
  • repeatNewPwd : PhnMMIEntryType
  • reqIP : NetServicesProfile , NetServicesProfileV1
  • requestSmsInfo : PhnLibLengthInfoType
  • reserved : _PalmPhotoSelectionParam , LocDBRecordTag , LocsLibSelLocsTag , _PalmPhotoReadWriteParam , NetPrefGPRSQOSType , ApptTimeZoneType , _PalmPhotoFileLocation , _PalmPhotoExtraInfo , LocationDataTag
  • reserved0 : NBSNotificationEventType , CamLibBitmapInfoTag
  • reserved1 : PmConnectorNotifyDataType , AddressAppRecord , PhnPDPWrite , NBSNotificationEventType , HsSndPortInfo , HsSndBufferData , CamLibBitmapInfoTag
  • reserved1a : NBSNotificationEventType
  • reserved2 : UPNotificationEventType , tagIOTANotificationEventType , PmConnectorNotifyDataType , PhnPDPWrite , HsSndPortInfo , NBSNotificationEventType , HsSndBufferData , WUNotificationEventType
  • reserved3 : tagIOTANotificationEventType , NBSNotificationEventType , PhnPDPWrite , WUNotificationEventType , UPNotificationEventType
  • reserved4 : PhnPDPWrite
  • reserved5 : PhnPDPWrite
  • reserved6 : PhnPDPWrite
  • response : DevAppLaunchCmdGenericCallType
  • restartInterval : PalmImageJPEGEncodeParamType
  • restrict_ha_addr : PhnPDPPayload
  • restrict_home_addr : PhnPDPPayload
  • restrict_mn_aaa_spi : PhnPDPPayload
  • restrict_mn_aaa_ss : PhnPDPPayload
  • restrict_mn_ha_spi : PhnPDPPayload
  • restrict_mn_ha_ss : PhnPDPPayload
  • restrict_nai : PhnPDPPayload
  • restrict_rev_tunnel_pref : PhnPDPPayload
  • result : DialPnlIsDialingAvailableParamsType , PhnUSSDEventType
  • resultString : AddrCallerIDParamsType
  • ret : _pluginGetInfoParams , _pluginExtendedQueryParams , _pluginSendParams , _pluginQueryParams , _pluginParams
  • rev_tunnel_pref : PhnPDPWrite , PhnPDPPayload
  • ringerID : PhnRingingProfileType
  • roamCallGuardEnable : PhnRoamPrefInfoType
  • roamingTone : SoundPreferencePhone
  • roamRingerEnable : PhnRoamPrefInfoType
  • roamRingerID : PhnRoamPrefInfoType
  • rowByte : PalmImageParamType , PalmImageINDEXParamType
  • rrq_timer : PhnOnexMipRRQType
  • rulesEnabled : HsDialPrefsUSDialingRulesType
  • rwCallback : _PalmPhotoReadWriteParam
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:09 2008 for Palm API Guide


  • All
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- s -

  • s : HS_HTTPLibSplit_
  • sampleBlockAlign : tagSndFileStreamData
  • sampleFormat : tagSndFileStreamData
  • sampleRate : tagSndFileStreamData , PalmAudioPCMParamType , PalmAudioADPCMParamType , PalmAudioAACParamType , PalmAudioAACDecParamType , PalmAudioMP2ParamType
  • sampleType : PalmAudioPCMParamType , tagSndFileStreamData
  • sampleWidth : PalmAudioPCMParamType , PalmAudioADPCMParamType , PalmAudioAACParamType , tagSndFileStreamData
  • sat : PhnEventType::Data
  • save : SysWPPILaunchCmdType
  • searchRange : PalmVideoMPEG4EncodeParamType
  • sec_dns_addr : PhnPDPWrite , PhnPDPPayload
  • sec_ha_addr : PhnPDPWrite , PhnPDPPayload
  • secsFromNow : SysVPPILaunchCmdWillPWPromptType
  • segmentCount : PhnLibLengthInfoType
  • segments : SmsHeader
  • selectedDescriptor : _pluginSendParams
  • selectedImages : _PalmPhotoSelectionParam
  • selectedItem : _pluginSendParams
  • selectionCount : _PalmPhotoSelectionParam
  • selLocsListP : LocsLibSelLocsTag
  • sendChangeNotify : LocsLibSelLocsTag
  • senderCreatorId : DevAppLaunchCmdGenericCallType
  • senderNumber : PhnSMSParams
  • senderP : NBSNotificationEventType
  • sendHit : PhnMMIEntryType
  • seqNum : NBSNotificationEventType
  • serialNumber : Net80211DeviceInfo
  • serialNumberSize : Net80211DeviceInfo
  • serialPortId : PmConnectorNotifyDataType
  • service : PhnConnectionType , PhnDisconnectEventType , PhnSubscriberAddrInfo
  • serviceCenterNumber : PhnSMSParams
  • serviceCode : PhnMMIResultType , PhnMMIEntryType
  • serviceID : DialPnlDispatchDialParamsType
  • serviceIDsP : DialPnlIsDialingAvailableParamsType
  • serviceTone : SoundPreferencePhone
  • serviceType : PhnSATEventDataSvc
  • sessionStatus : PhnDataSessionStateType
  • sessionType : PhnDataSessionStateType
  • set_mn_aaa_spi : PhnPDPWrite , PhnPDPPayload
  • set_mn_ha_spi : PhnPDPWrite , PhnPDPPayload
  • shortname : PhnOperatorType
  • showWaitDialogue : LocsLibNotifyDataTag
  • sid : PhnCdmaSystemInfoType
  • signalFadedTone : SoundPreferenceNetworkSounds
  • signature : PhnSATEventLaunchBrowser , PhnSATEventPlayTone , PhnSATEventDataSvc , PhnSATEventDisplayText , PhnSATEventGetInkey , PhnSATEventHeader , PhnSATEventGetInput , PhnSATEventSetupCall , PhnSATEventMenu , PhnSATEventSendSMS , PhnSATEventRefresh , HsSndPortInfo , PhnSATEventRunAT , PhnSATEventIdleModeText , HsSndBufferData , PhnSATEventSendDTMF , HsSndMidiProgressMsg
  • simMessages : PhnIndicationType
  • simReady : PhnIndicationType
  • size : _pluginParams , SmsHeader , ParsedInfoList , _dataLinks , _pluginSendParams , CamLibStreamTag , PhnMMIResultType , VMFontType , PhnSMSParams , _pluginExtendedQueryParams , PhnLibLengthInfoType , MMProAttachDataLinks , PhnRadioStateType , PhnLineStateType , PhnMMIEntryType
  • sizeRule : VMFontUIRules
  • skipBFrames : PalmVideoMPEG1DecodeParamType
  • smsSoundPrefs : SoundPreference::_tonePrefs
  • soundOffVibrate : SoundPreference
  • soundOnVibrate : SoundPreference
  • soundOnVolume : SoundPreference
  • sourcePort : PhnSMSParams
  • srcPort : NBSNotificationEventType
  • SSID : NetServicesProfile
  • ssid : NetSSID
  • SSID : NetServicesProfileV1
  • ssidLength : NetServicesProfileV1 , NetServicesProfile , NetSSID
  • stage : SysVPPILaunchCmdProgressPaintType
  • startLocation : ParsedInfo
  • state : PhnPowerEventType , PhnConnectionType , PhnIndicationType
  • status : PhnOperatorType , PhnIOTAReportType , SmsHeader , CamLibStatusTag , PhnRegistrationType , NetPrefFallbackInfoType
  • statusID : NetPrefFallbackInfoType
  • statusReport : SMSSendOptions
  • stepDB : HsSndPortInfo
  • stepVol : HsSndPortInfo
  • store : PhnSMSParams
  • store_mn_aaa_ss : PhnPDPWrite
  • stored_mn_aaa_ss : PhnPDPPayload
  • stream : AacFileRef
  • streamBufferSize : _PhnCDMAMediaTVSettings
  • streamComplete : tagSndFileStreamData
  • StreamFile : _PalmPhotoFileLocation
  • streamFileHandle : PalmFileFormatParamType
  • streamFlags : tagSndFileStreamData
  • streamMode : tagSndFileStreamData
  • streamRefCon : tagSndFileStreamData
  • streamTimeout : _PhnCDMAMediaTVSettings
  • stride : PalmVideoAVCCustomGetDecodedFrameType
  • string : PhnUSSDEventType
  • stringID : HsBigButtonMappingType , PmSysGadgetBbutMappingType
  • style : VMFontType
  • styleRule : VMFontUIRules
  • subject : MMProLaunchStruct2 , MMProLaunchStruct , _HelperServiceMMSDetailsType
  • subSampling : PalmImageJPEGEncodeParamType
  • subscriptionStatus : PhnMMIResultType
  • substitution : PhnLibLengthInfoType
  • supported : _pluginExtendedQueryParams
  • supportsReceiving : _pluginGetInfoParams
  • supportsSending : _pluginGetInfoParams
  • svc_str : PhnPDPWrite , PhnPDPPayload
  • svc_str_length : PhnPDPWrite , PhnPDPPayload
  • svcAlert : PhnRingingProfileType
  • svcID : webBrowserURLWithSvcIDLaunchInfo
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:09 2008 for Palm API Guide


  • All
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- t -

  • tempFileName : _HelperServiceMMSObjectType
  • text : PhnMMIEntryType
  • textOffset : PhnSATEventDisplayText , PhnSATEventGetInkey , PhnSATEventGetInput , PhnSATEventPlayTone , PhnSATEventSendSMS
  • time : PhnMMIEntryType , PhnMMIResultType
  • time_stamp : PhnPDDataType
  • timeInSecs : PhnNetworkTime
  • timeInterval : PhnSATEventPlayTone
  • timeout : _PhnLibMMSServerInfo
  • timer : PhnIOTAPhnSIPRetryTimerType
  • timeStamp : PhnSMSParams
  • timeUnit : PhnSATEventPlayTone
  • timeZone : PhnNetworkTime
  • titleOffset : PhnSATEventMenu
  • to : MMProLaunchStruct , MMProLaunchStruct2
  • tone : PhoneAppLaunchCmdSendDTMFToneType
  • tonePrefs : SoundPreference
  • toneType : ToneIdentifier , PhnSATEventPlayTone
  • topPosition : PalmImageGIFFrameParamType
  • traffic_ck_delay_timer : PhnOnexMipRRQType
  • transparentColorIndex : PalmImageGIFFrameParamType
  • trasactionID : PhnSMSParams
  • type : HtmlLibFocusTargetInfo , AacFileRef , PhnSATEventSetupCall , PhnMMIEntryType , CamLibSettingTag , HS_HTTPLibIPAddr_ , PhnPasswordEventType , PhnIndicationType , PhnGPRSPDPContextListNodeType , SmsHeader , MMProAttachStruct2 , MMProAttachStruct , PhnMsgBoxDataType , _pluginExtendedQueryParams , _PalmPhotoFileLocation , AddrListLookupTypeGetParamsType , LcdOverlayLibSettingTag , PhnMMIResultType
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:09 2008 for Palm API Guide


  • All
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- u -

  • u : PalmAudioAACDecParamType , AacFileRef
  • uBitmapId : PmSysGadgetPttNotificationType
  • uid : PhnPDPPayload
  • uniqueID : Address , AddrCallerIDParamsType , AddrAddToRecordParamsType
  • unityVol : HsSndPortInfo
  • unknownCallerTone : SoundPreferencePhone
  • Unused : _pluginParams , _pluginQueryParams , _pluginSendParams , _pluginGetInfoParams , _pluginExtendedQueryParams
  • UPData : UPNotificationEventType
  • url : PhnIOTAPhnNAISIPCfgSvr , PhnIOTAPhnNAISIPDatagwyType , PhnIOTAPhnNAIPPGType , PhnIOTAPhnNAIIMStore , PhnIOTAPhnNAISIPDataxchType , PhnIOTAPhnHomepagetype , PhnIOTAPhnTrustedDomainType
  • urlOffset : PhnSATEventLaunchBrowser
  • use_default_dial_str : PhnPDPWrite
  • use_default_svc_str : PhnPDPWrite
  • use_existing_dial_str : PhnPDPWrite
  • use_existing_dns_server : PhnPDPWrite
  • use_existing_ha_addr : PhnPDPWrite
  • use_existing_home_addr : PhnPDPWrite
  • use_existing_mn_aaa_spi : PhnPDPWrite
  • use_existing_mn_aaa_ss : PhnPDPWrite
  • use_existing_mn_ha_spi : PhnPDPWrite
  • use_existing_mn_ha_ss : PhnPDPWrite
  • use_existing_nai : PhnPDPWrite
  • use_existing_rev_tunnel_pref : PhnPDPWrite
  • use_existing_svc_str : PhnPDPWrite
  • useMultiFilter : AddrHsLookupUserDataType , AddrHsLookupUserDataV2Type
  • user_agent : _PhnLibMMSServerInfo
  • userDataP : _PalmPhotoDisplayParam , _PalmPhotoSelectionParam , _PalmPhotoReadWriteParam , CamLibCaptureTag , _PalmPhotoCaptureParamV2 , DevAppLaunchCmdGenericCallType
  • useSavedAccount : SysVPPILaunchCmdEditAccountType
  • useWizardUI : SysVPPILaunchCmdEditAccountType
  • ussd : PhnEventType::Data
  • uStatus : PmSysGadgetPttNotificationType
  • uTC : ApptTimeZoneType , LocationDataTag , LocDBRecordTag
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:09 2008 for Palm API Guide


  • All
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- v -

  • validFlag : NetBssInfoType
  • validFlags : Net80211DeviceInfo
  • validity : SMSSendOptions , SmsHeader
  • value : LcdOverlayLibSettingTag , CamLibSettingTag , CamLibColorSpaceTag
  • valueLenP : SndCodecCustomControlType
  • valueP : SndCodecCustomControlType
  • velocity_hor : PhnPDDataType
  • velocity_ver : PhnPDDataType
  • version : PalmAudioPlaybackNotifyEventTypeTag , _PhnCDMAMediaTVSettings , PhnSMSParams , PhnLineStateType , WUNotificationEventType , UPNotificationEventType , WAPNotificationEventType , tagIOTANotificationEventType , PhnRadioStateType , HsBigButtonReourceType , FrmNavHeaderTag , PhnDataSessionStateType , NetMasterClientEventInfoType , NBSNotificationEventType , AddrListLookupTypeGetParamsType , PmSysGadgetBbutResourceType , _HelperServiceMMSDetailsType , PhoneAppLaunchCmdDialType , _pluginGetInfoParams , AddrHsLookupUserDataType , AddrHsLookupUserDataV2Type , _pluginParams , _PhnLibMMSServerInfo
  • verticalOffset : PalmVideoAVCCustomGetInfoType
  • VFSFile : _PalmPhotoFileLocation
  • vfsFileRef : PalmFileFormatParamType
  • vibrate : PhnRingingProfileType
  • voiceMailIndicator : PhnLineStateType
  • voicemailTone : SoundPreferencePhone
  • volHeight : PalmVideoMPEG4EncodeParamType , PalmVideoMPEG4DecodeParamType
  • volRefNum : tagSndFileStreamFileSpec , AacFileRef
  • volume : PhnRingingProfileType
  • volumeRef : _PalmPhotoFileLocation
  • volWidth : PalmVideoMPEG4DecodeParamType , PalmVideoMPEG4EncodeParamType
  • VOVOLVersionID : PalmVideoMPEG4EncodeParamType
  • vpnConnInstallP : NetMasterClientEventInfoType
  • vpnConnProfileOverrideName : NetMasterClientEventVPNConnInstallType
  • vppiCreator : VPNAccountType
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:09 2008 for Palm API Guide


  • All
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- w -

  • wallpaperLocation : PhoneAppLaunchCmdSetWallpaperType
  • wallpaperUID : PhoneAppLaunchCmdSetWallpaperType
  • wapEvtParams : PhnEventType::Data
  • wapMsg : WAPNotificationEventType
  • warnIfLocExists : LocsLibSelLocsTag
  • weekOrd : DSTDataTag
  • wep : NetServicesProfile , NetServicesProfileV1
  • width : PalmImageINDEXParamType , PalmVideoMPEG1DecodeParamType , CamLibBitmapInfoTag , PalmImagePlanarType , PalmImageParamType , _PalmPhotoImageInfo
  • winH : _PalmPhotoDisplayParam
  • wppiCreator : WiFiAuthenticationMethodType
  • wsCode : PhnCdmaSystemInfoType
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:09 2008 for Palm API Guide


  • All
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- x -

  • xExtent : AddrPhotoCallerIDParamsType
  • xPixelsPerMeter : PalmImageBMPParamType
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:09 2008 for Palm API Guide


  • All
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- y -

  • yExtent : AddrPhotoCallerIDParamsType
  • yPixelsPerMeter : PalmImageBMPParamType
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:09 2008 for Palm API Guide


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- k -

  • kAddress : HsPhoneSMSTypes.h
  • kAngelSmiley : SmartTextEngineDef.h
  • kAudioInputDefault : PmConnectorLibCommon.h
  • kAudioInputExternalMic : PmConnectorLibCommon.h
  • kAudioInputInternalMic : PmConnectorLibCommon.h
  • kAudioOutputSettingAthena : PmConnectorLibCommon.h
  • kAudioOutputSettingDefault : PmConnectorLibCommon.h
  • kAudioOutputSettingHeadphone : PmConnectorLibCommon.h
  • kAudioOutputSettingSpeaker : PmConnectorLibCommon.h
  • kAutoDelete : HsPhoneSMSTypes.h
  • kBellMobilityMCCMNC : CarrierCustomLibTypes.h
  • kBigFrownSmiley : SmartTextEngineDef.h
  • kBigSmileSmiley : SmartTextEngineDef.h
  • kBigTeethSmiley : SmartTextEngineDef.h
  • kBigTongueSmiley : SmartTextEngineDef.h
  • kBlushSmiley : SmartTextEngineDef.h
  • kBoxData : HsPhoneNetworkTypes.h
  • kBoxEMail : HsPhoneNetworkTypes.h
  • kBoxOther : HsPhoneNetworkTypes.h
  • kBoxTelefax : HsPhoneNetworkTypes.h
  • kBoxVoice : HsPhoneNetworkTypes.h
  • kCameraImageFormatRGB1 : CameraLibCommon.h
  • kCameraImageFormatRGB16 : CameraLibCommon.h
  • kCameraImageFormatRGB24 : CameraLibCommon.h
  • kCameraImageFormatRGB32 : CameraLibCommon.h
  • kCameraImageFormatRGB4 : CameraLibCommon.h
  • kCameraImageFormatRGB8 : CameraLibCommon.h
  • kCameraImageFormatYCbCr : CameraLibCommon.h
  • kCameraImageFormatYCrCb : CameraLibCommon.h
  • kCameraImageLittleEndian : CameraLibCommon.h
  • kCameraLibCreator : CameraLibCommon.h
  • kCameraLibName : CameraLibCommon.h
  • kCameraLibTrapCameraLibCapture : CameraLibCommon.h
  • kCameraLibTrapCameraLibPreview : CameraLibCommon.h
  • kCameraLibTrapCameraLibPreviewStart : CameraLibCommon.h
  • kCameraLibTrapCameraLibPreviewStop : CameraLibCommon.h
  • kCameraLibTrapCameraLibRegisterGet : CameraLibCommon.h
  • kCameraLibTrapCameraLibRegisterSet : CameraLibCommon.h
  • kCameraLibTrapClose : CameraLibCommon.h
  • kCameraLibTrapOpen : CameraLibCommon.h
  • kCameraLibTrapSleep : CameraLibCommon.h
  • kCameraLibTrapWake : CameraLibCommon.h
  • kCameraLibType : CameraLibCommon.h
  • kCamLibApertureValueAuto : palmOneCameraCommon.h
  • kCamLibApertureValueManual : palmOneCameraCommon.h
  • kCamLibBufNumManual : palmOneCameraCommon.h
  • kCamLibCaptureDataFormatRGB565 : palmOneCameraCommon.h
  • kCamLibCaptureDataFormatYCbCr420 : palmOneCameraCommon.h
  • kCamLibCaptureDataFormatYCbCr420Planar : palmOneCameraCommon.h
  • kCamLibCaptureDataFormatYCbCr422 : palmOneCameraCommon.h
  • kCamLibCaptureDataFormatYCbCr422Planar : palmOneCameraCommon.h
  • kCamLibCaptureDataFormatYUV420 : palmOneCameraCommon.h
  • kCamLibCaptureDataFormatYUV420Planar : palmOneCameraCommon.h
  • kCamLibCaptureDataFormatYUV422 : palmOneCameraCommon.h
  • kCamLibCaptureDataFormatYUV422Planar : palmOneCameraCommon.h
  • kCamLibCaptureHwrVersion : palmOneCameraCommon.h
  • kCamLibColorSpace_sRGB : palmOneCameraCommon.h
  • kCamLibColorSpaceUncalibrated : palmOneCameraCommon.h
  • kCamLibContrastManual : palmOneCameraCommon.h
  • kCamLibCreator : palmOneCameraCommon.h
  • kCamLibCtrlApertureValueGet : palmOneCameraCommon.h
  • kCamLibCtrlApertureValueQuery : palmOneCameraCommon.h
  • kCamLibCtrlApertureValueSet : palmOneCameraCommon.h
  • kCamLibCtrlCapture : palmOneCameraCommon.h
  • kCamLibCtrlCaptureAreaGet : palmOneCameraCommon.h
  • kCamLibCtrlCaptureAreaSet : palmOneCameraCommon.h
  • kCamLibCtrlCaptureFormatGet : palmOneCameraCommon.h
  • kCamLibCtrlCaptureFormatQuery : palmOneCameraCommon.h
  • kCamLibCtrlCaptureFormatSet : palmOneCameraCommon.h
  • kCamLibCtrlCaptureGetBitmapInfo : palmOneCameraCommon.h
  • kCamLibCtrlCaptureSizeGet : palmOneCameraCommon.h
  • kCamLibCtrlCaptureSizeQuery : palmOneCameraCommon.h
  • kCamLibCtrlCaptureSizeSet : palmOneCameraCommon.h
  • kCamLibCtrlColorSpaceGet : palmOneCameraCommon.h
  • kCamLibCtrlColorSpaceQuery : palmOneCameraCommon.h
  • kCamLibCtrlColorSpaceSet : palmOneCameraCommon.h
  • kCamLibCtrlContrastGet : palmOneCameraCommon.h
  • kCamLibCtrlContrastQuery : palmOneCameraCommon.h
  • kCamLibCtrlContrastSet : palmOneCameraCommon.h
  • kCamLibCtrlEffectsGet : palmOneCameraCommon.h
  • kCamLibCtrlEffectsQuery : palmOneCameraCommon.h
  • kCamLibCtrlEffectsSet : palmOneCameraCommon.h
  • kCamLibCtrlExposureGet : palmOneCameraCommon.h
  • kCamLibCtrlExposureQuery : palmOneCameraCommon.h
  • kCamLibCtrlExposureSet : palmOneCameraCommon.h
  • kCamLibCtrlHardwareSettingsDlg : palmOneCameraCommon.h
  • kCamLibCtrlLightingGet : palmOneCameraCommon.h
  • kCamLibCtrlLightingQuery : palmOneCameraCommon.h
  • kCamLibCtrlLightingSet : palmOneCameraCommon.h
  • kCamLibCtrlPowerOff : palmOneCameraCommon.h
  • kCamLibCtrlPowerOn : palmOneCameraCommon.h
  • kCamLibCtrlPreviewAreaGet : palmOneCameraCommon.h
  • kCamLibCtrlPreviewAreaSet : palmOneCameraCommon.h
  • kCamLibCtrlPreviewRectGet : palmOneCameraCommon.h
  • kCamLibCtrlPreviewRectSet : palmOneCameraCommon.h
  • kCamLibCtrlPreviewSizeGet : palmOneCameraCommon.h
  • kCamLibCtrlPreviewSizeQuery : palmOneCameraCommon.h
  • kCamLibCtrlPreviewSizeSet : palmOneCameraCommon.h
  • kCamLibCtrlPreviewStart : palmOneCameraCommon.h
  • kCamLibCtrlPreviewStop : palmOneCameraCommon.h
  • kCamLibCtrlSaturationGet : palmOneCameraCommon.h
  • kCamLibCtrlSaturationQuery : palmOneCameraCommon.h
  • kCamLibCtrlSaturationSet : palmOneCameraCommon.h
  • kCamLibCtrlSharpnessGet : palmOneCameraCommon.h
  • kCamLibCtrlSharpnessQuery : palmOneCameraCommon.h
  • kCamLibCtrlSharpnessSet : palmOneCameraCommon.h
  • kCamLibCtrlShutterSpeedGet : palmOneCameraCommon.h
  • kCamLibCtrlShutterSpeedQuery : palmOneCameraCommon.h
  • kCamLibCtrlShutterSpeedSet : palmOneCameraCommon.h
  • kCamLibCtrlStatusGet : palmOneCameraCommon.h
  • kCamLibCtrlStatusQuery : palmOneCameraCommon.h
  • kCamLibCtrlStreamBufNumGet : palmOneCameraCommon.h
  • kCamLibCtrlStreamBufNumQuery : palmOneCameraCommon.h
  • kCamLibCtrlStreamBufNumSet : palmOneCameraCommon.h
  • kCamLibCtrlStreamFormatGet : palmOneCameraCommon.h
  • kCamLibCtrlStreamFormatQuery : palmOneCameraCommon.h
  • kCamLibCtrlStreamFormatSet : palmOneCameraCommon.h
  • kCamLibCtrlStreamPreviewGet : palmOneCameraCommon.h
  • kCamLibCtrlStreamPreviewQuery : palmOneCameraCommon.h
  • kCamLibCtrlStreamPreviewSet : palmOneCameraCommon.h
  • kCamLibCtrlStreamSizeGet : palmOneCameraCommon.h
  • kCamLibCtrlStreamSizeQuery : palmOneCameraCommon.h
  • kCamLibCtrlStreamSizeSet : palmOneCameraCommon.h
  • kCamLibCtrlStreamStart : palmOneCameraCommon.h
  • kCamLibCtrlStreamStop : palmOneCameraCommon.h
  • kCamLibCtrlStreamUnlockFrame : palmOneCameraCommon.h
  • kCamLibCtrlStreamWaitForFrame : palmOneCameraCommon.h
  • kCamLibCtrlWhiteBalanceGet : palmOneCameraCommon.h
  • kCamLibCtrlWhiteBalanceQuery : palmOneCameraCommon.h
  • kCamLibCtrlWhiteBalanceSet : palmOneCameraCommon.h
  • kCamLibCtrlZoomGet : palmOneCameraCommon.h
  • kCamLibCtrlZoomQuery : palmOneCameraCommon.h
  • kCamLibCtrlZoomSet : palmOneCameraCommon.h
  • kCamLibEffectsBlackWhite : palmOneCameraCommon.h
  • kCamLibEffectsBluish : palmOneCameraCommon.h
  • kCamLibEffectsNegative : palmOneCameraCommon.h
  • kCamLibEffectsNormal : palmOneCameraCommon.h
  • kCamLibEffectsSepia : palmOneCameraCommon.h
  • kCamLibErrAllFramesLocked : palmOneCameraCommon.h
  • kCamLibErrBadParam : palmOneCameraCommon.h
  • kCamLibErrInternal : palmOneCameraCommon.h
  • kCamLibErrNoMemory : palmOneCameraCommon.h
  • kCamLibErrNoPower : palmOneCameraCommon.h
  • kCamLibErrNotCompatible : palmOneCameraCommon.h
  • kCamLibErrNotOpen : palmOneCameraCommon.h
  • kCamLibErrNotSupported : palmOneCameraCommon.h
  • kCamLibErrorClass : palmOneCameraCommon.h
  • kCamLibErrStillOpen : palmOneCameraCommon.h
  • kCamLibExposureAuto : palmOneCameraCommon.h
  • kCamLibExposureManual : palmOneCameraCommon.h
  • kCamLibFtrCaptureVersion : palmOneCameraCommon.h
  • kCamLibFtrVersionNum : palmOneCameraCommon.h
  • kCamLibImageSizeCIF : palmOneCameraCommon.h
  • kCamLibImageSizeQCIF : palmOneCameraCommon.h
  • kCamLibImageSizeQQVGA : palmOneCameraCommon.h
  • kCamLibImageSizeQVGA : palmOneCameraCommon.h
  • kCamLibImageSizeSXGA : palmOneCameraCommon.h
  • kCamLibImageSizeSXGA1024 : palmOneCameraCommon.h
  • kCamLibImageSizeSXGA960 : palmOneCameraCommon.h
  • kCamLibImageSizeVGA : palmOneCameraCommon.h
  • kCamLibLightingLow : palmOneCameraCommon.h
  • kCamLibLightingNormal : palmOneCameraCommon.h
  • kCamLibName : palmOneCameraCommon.h
  • kCamLibSaturationManual : palmOneCameraCommon.h
  • kCamLibSharpnessManual : palmOneCameraCommon.h
  • kCamLibShutterSpeedAuto : palmOneCameraCommon.h
  • kCamLibShutterSpeedManual : palmOneCameraCommon.h
  • kCamLibStatusInPreview : palmOneCameraCommon.h
  • kCamLibStatusInStillCapture : palmOneCameraCommon.h
  • kCamLibStatusInVideoCapture : palmOneCameraCommon.h
  • kCamLibStatusPoweredOn : palmOneCameraCommon.h
  • kCamLibStreamPreviewOff : palmOneCameraCommon.h
  • kCamLibStreamPreviewOn : palmOneCameraCommon.h
  • kCamLibTrapControl : palmOneCameraCommon.h
  • kCamLibTrapGetVersion : palmOneCameraCommon.h
  • kCamLibType : palmOneCameraCommon.h
  • kCamLibVersion : palmOneCameraCommon.h
  • kCamLibVersion1 : palmOneCameraCommon.h
  • kCamLibVersion2 : palmOneCameraCommon.h
  • kCamLibVersion3 : palmOneCameraCommon.h
  • kCamLibWhiteBalanceAuto : palmOneCameraCommon.h
  • kCamLibWhiteBalanceCloudy : palmOneCameraCommon.h
  • kCamLibWhiteBalanceExtra : palmOneCameraCommon.h
  • kCamLibWhiteBalanceFluorescent : palmOneCameraCommon.h
  • kCamLibWhiteBalanceIncandescent : palmOneCameraCommon.h
  • kCamLibWhiteBalanceIndoor : palmOneCameraCommon.h
  • kCamLibWhiteBalanceOutdoor : palmOneCameraCommon.h
  • kCamLibWhiteBalanceShade : palmOneCameraCommon.h
  • kCamLibWhiteBalanceSunny : palmOneCameraCommon.h
  • kCamLibWhiteBalanceTwilight : palmOneCameraCommon.h
  • kCamLibZoomManual : palmOneCameraCommon.h
  • kCamSliderCreator : palmOneCameraSlider.h
  • kCamSliderFlagsOpened : palmOneCameraSlider.h
  • kCamSliderFtrFlagsNum : palmOneCameraSlider.h
  • kCamSliderFtrVersionNum : palmOneCameraSlider.h
  • kCamSliderNotifyEvent : palmOneCameraSlider.h
  • kCamSliderVersion : palmOneCameraSlider.h
  • kCamSliderVersion1 : palmOneCameraSlider.h
  • kCarrierCustomizationCLibName : CarrierCustomLibTypes.h
  • kCarrierListDBName : CarrierCustomLibTypes.h
  • kCCLibType : CarrierCustomLibTypes.h
  • kCCMSSettingsPrimaryTrustedDomain : CarrierCustomLibTypes.h
  • kCCMSSettingsSecondaryTrustedDomain : CarrierCustomLibTypes.h
  • kCCMSSettingsUAProfilingURL : CarrierCustomLibTypes.h
  • kCCSMBrowserSettingsCSDDisconnectOnExit : CarrierCustomLibTypes.h
  • kCCSMBrowserSettingsDormantOnExit : CarrierCustomLibTypes.h
  • kCCSMBrowserSettingsEncryptMSISDN : CarrierCustomLibTypes.h
  • kCCSMBrowserSettingsHideDisconnect : CarrierCustomLibTypes.h
  • kCCSMBrowserSettingsPDataDisconnectOnExit : CarrierCustomLibTypes.h
  • kCCSMBrowserSettingsReserved : CarrierCustomLibTypes.h
  • kCCSMBrowserSettingsVersionInWAPProfile : CarrierCustomLibTypes.h
  • kCCSMMessagingSettings11DigitRecipient : CarrierCustomLibTypes.h
  • kCCSMMessagingSettingsDisableMMSFallback : CarrierCustomLibTypes.h
  • kCCSMMessagingSettingsNormaliseMMSAddress : CarrierCustomLibTypes.h
  • kCCSMMessagingSettingsReserved : CarrierCustomLibTypes.h
  • kCCSMMessagingSettingsStripPhonePlus : CarrierCustomLibTypes.h
  • kCCSMMessagingSettingsWAPProtocol20 : CarrierCustomLibTypes.h
  • kCCSMPhoneSettingsEditMSISDN : CarrierCustomLibTypes.h
  • kCCSMPhoneSettingsEnableTTY : CarrierCustomLibTypes.h
  • kCCSMPhoneSettingsNetworkSelect : CarrierCustomLibTypes.h
  • kCCSMPhoneSettingsReserved : CarrierCustomLibTypes.h
  • kCCSMPhoneSettingsRoamingIndicator : CarrierCustomLibTypes.h
  • kCCSMPhoneSettingsShowEmergencyMode : CarrierCustomLibTypes.h
  • kCCSMPhoneSettingsUseEFSPN : CarrierCustomLibTypes.h
  • kCCSMPrimaryProxyAuthenticate : CarrierCustomLibTypes.h
  • kCCSMPrimaryProxyHide : CarrierCustomLibTypes.h
  • kCCSMPrimaryProxyLocked : CarrierCustomLibTypes.h
  • kCCSMRadioBandEurope : CarrierCustomLibTypes.h
  • kCCSMRadioBandNorthAmerica : CarrierCustomLibTypes.h
  • kCCSMRadioBandUnknown : CarrierCustomLibTypes.h
  • kCCSMSecondaryProxyAuthenticate : CarrierCustomLibTypes.h
  • kCCSMSecondaryProxyHide : CarrierCustomLibTypes.h
  • kCCSMSecondaryProxyLocked : CarrierCustomLibTypes.h
  • kCCSMSettingsBrowserFlags : CarrierCustomLibTypes.h
  • kCCSMSettingsBrowserProxyFlags : CarrierCustomLibTypes.h
  • kCCSMSettingsCarrierMSISDN : CarrierCustomLibTypes.h
  • kCCSMSettingsCSDDisable : CarrierCustomLibTypes.h
  • kCCSMSettingsE911Timeout : CarrierCustomLibTypes.h
  • kCCSMSettingsEditableMSISDN : CarrierCustomLibTypes.h
  • kCCSMSettingsEmailSMTPServer : CarrierCustomLibTypes.h
  • kCCSMSettingsEncryptMSISDN : CarrierCustomLibTypes.h
  • kCCSMSettingsGPRSAutoAttach : CarrierCustomLibTypes.h
  • kCCSMSettingsHomepageURL : CarrierCustomLibTypes.h
  • kCCSMSettingsHTTPHeaders : CarrierCustomLibTypes.h
  • kCCSMSettingsIndicateRoaming : CarrierCustomLibTypes.h
  • kCCSMSettingsMessagingFlags : CarrierCustomLibTypes.h
  • kCCSMSettingsMMSMaxMsgSize : CarrierCustomLibTypes.h
  • kCCSMSettingsMMSMaxVideoSize : CarrierCustomLibTypes.h
  • kCCSMSettingsMMSPort : CarrierCustomLibTypes.h
  • kCCSMSettingsMMSUAProf : CarrierCustomLibTypes.h
  • kCCSMSettingsMMSUAString : CarrierCustomLibTypes.h
  • kCCSMSettingsMMSURL : CarrierCustomLibTypes.h
  • kCCSMSettingsMMSVersionNumber : CarrierCustomLibTypes.h
  • kCCSMSettingsMMSWAPGateway : CarrierCustomLibTypes.h
  • kCCSMSettingsMSISDNHeaderFormat : CarrierCustomLibTypes.h
  • kCCSMSettingsNAI : CarrierCustomLibTypes.h
  • kCCSMSettingsNAIHeaderFormat : CarrierCustomLibTypes.h
  • kCCSMSettingsPOP3Server : CarrierCustomLibTypes.h
  • kCCSMSettingsPrimaryProxyPort : CarrierCustomLibTypes.h
  • kCCSMSettingsPrimaryProxyServer : CarrierCustomLibTypes.h
  • kCCSMSettingsPrimarySecureProxyPort : CarrierCustomLibTypes.h
  • kCCSMSettingsPrimarySecureProxyServer : CarrierCustomLibTypes.h
  • kCCSMSettingsProxyPassword : CarrierCustomLibTypes.h
  • kCCSMSettingsProxyUsername : CarrierCustomLibTypes.h
  • kCCSMSettingsRadioBand : CarrierCustomLibTypes.h
  • kCCSMSettingsReserved : CarrierCustomLibTypes.h
  • kCCSMSettingsSecondaryProxyPort : CarrierCustomLibTypes.h
  • kCCSMSettingsSecondaryProxyServer : CarrierCustomLibTypes.h
  • kCCSMSettingsSecondarySecureProxyPort : CarrierCustomLibTypes.h
  • kCCSMSettingsSecondarySecureProxyServer : CarrierCustomLibTypes.h
  • kCCSMSettingsShowEmergencyMode : CarrierCustomLibTypes.h
  • kCCSMSettingsShowNetworkSelect : CarrierCustomLibTypes.h
  • kCCSMSettingsSMSCNumber : CarrierCustomLibTypes.h
  • kCCSMSettingsSMSEmailGateway : CarrierCustomLibTypes.h
  • kCCSMSettingsSMSMaxMsgSize : CarrierCustomLibTypes.h
  • kCCSMSettingsSMSSupportDeliveryReceipt : CarrierCustomLibTypes.h
  • kCCSMSettingsSMSValidityPeriod : CarrierCustomLibTypes.h
  • kCCSMSettingsSMTPServer : CarrierCustomLibTypes.h
  • kCCSMSettingsSPNSupported : CarrierCustomLibTypes.h
  • kCCSMSettingsSystemReserved : CarrierCustomLibTypes.h
  • kCCSMSettingsVoiceMailNumber : CarrierCustomLibTypes.h
  • kCCSMSettingsWapSupportLevel : CarrierCustomLibTypes.h
  • kCCSMSystemSettingReserved : CarrierCustomLibTypes.h
  • kCigarSmiley : SmartTextEngineDef.h
  • kCity : HsPhoneSMSTypes.h
  • kCloseDialog : HsPhoneEvent.h
  • kClownSmiley : SmartTextEngineDef.h
  • kCodecErrAlignment : palmOneCodecPluginMgrCommon.h
  • kCodecErrBadParam : palmOneCodecPluginMgrCommon.h
  • kCodecErrBufferOverrun : palmOneCodecPluginMgrCommon.h
  • kCodecErrBufferUnderrun : palmOneCodecPluginMgrCommon.h
  • kCodecErrFrameError : palmOneCodecPluginMgrCommon.h
  • kCodecErrInvalidHeader : palmOneCodecPluginMgrCommon.h
  • kCodecErrInvalidState : palmOneCodecPluginMgrCommon.h
  • kCodecErrNoMemory : palmOneCodecPluginMgrCommon.h
  • kCodecErrParsing : palmOneCodecPluginMgrCommon.h
  • kCodecErrUnAuthorized : palmOneCodecPluginMgrCommon.h
  • kCodecErrUnknown : palmOneCodecPluginMgrCommon.h
  • kCodecMgrLibBadVersion : palmOneCodecPluginMgrCommon.h
  • kCodecMgrLibCreator : palmOneCodecPluginMgrCommon.h
  • kCodecMgrLibErrBadParam : palmOneCodecPluginMgrCommon.h
  • kCodecMgrLibErrInternal : palmOneCodecPluginMgrCommon.h
  • kCodecMgrLibErrorClass : palmOneCodecPluginMgrCommon.h
  • kCodecMgrLibErrStillOpen : palmOneCodecPluginMgrCommon.h
  • kCodecMgrLibName : palmOneCodecPluginMgrCommon.h
  • kCodecMgrLibNoCodec : palmOneCodecPluginMgrCommon.h
  • kCodecMgrLibNotSupported : palmOneCodecPluginMgrCommon.h
  • kCodecMgrLibTrapCreateSession : palmOneCodecPluginMgrCommon.h
  • kCodecMgrLibTrapCreateSessionByID : palmOneCodecPluginMgrCommon.h
  • kCodecMgrLibTrapCustomControl : palmOneCodecPluginMgrCommon.h
  • kCodecMgrLibTrapDeleteSession : palmOneCodecPluginMgrCommon.h
  • kCodecMgrLibTrapEncodeDecode : palmOneCodecPluginMgrCommon.h
  • kCodecMgrLibTrapEnumerateFormats : palmOneCodecPluginMgrCommon.h
  • kCodecMgrLibTrapGetMaxDestBufferSize : palmOneCodecPluginMgrCommon.h
  • kCodecMgrLibTrapGetSessionInfo : palmOneCodecPluginMgrCommon.h
  • kCodecMgrLibTrapIsFormatSupported : palmOneCodecPluginMgrCommon.h
  • kCodecMgrLibTrapLibAPIVersion : palmOneCodecPluginMgrCommon.h
  • kCodecMgrLibTrapResetSession : palmOneCodecPluginMgrCommon.h
  • kCodecMgrLibType : palmOneCodecPluginMgrCommon.h
  • kCodecMgrLibVersion : palmOneCodecPluginMgrCommon.h
  • kCodecMgrLibVersion3 : palmOneCodecPluginMgrCommon.h
  • kCodecPluginErrorClass : palmOneCodecPluginMgrCommon.h
  • kCodecSyncNotFound : palmOneCodecPluginMgrCommon.h
  • kCompany : HsPhoneSMSTypes.h
  • kCountry : HsPhoneSMSTypes.h
  • kCustom1 : HsPhoneSMSTypes.h
  • kCustom2 : HsPhoneSMSTypes.h
  • kCustom3 : HsPhoneSMSTypes.h
  • kCustom4 : HsPhoneSMSTypes.h
  • kDeferredDelivery : HsPhoneSMSTypes.h
  • kDeltaCharacter : SmartTextEngineDef.h
  • kDevilSmiley : SmartTextEngineDef.h
  • kDexLibTrapClose : PalmDisplayExtent.h
  • kDexLibTrapDexGetDisplayAddress : PalmDisplayExtent.h
  • kDexLibTrapDexGetDisplayDimensions : PalmDisplayExtent.h
  • kDexLibTrapOpen : PalmDisplayExtent.h
  • kDialogDeferredSend : HsPhoneEvent.h
  • kDialogGetBarring : HsPhoneEvent.h
  • kDialogGetCallWaiting : HsPhoneEvent.h
  • kDialogGetForwarding : HsPhoneEvent.h
  • kDialogGetOperatorList : HsPhoneEvent.h
  • kDialogImmediateSend : HsPhoneEvent.h
  • kDialogOperatorSelection : HsPhoneEvent.h
  • kDialogSendUSSD : HsPhoneEvent.h
  • kDialogSetBarring : HsPhoneEvent.h
  • kDialogSetCallWaiting : HsPhoneEvent.h
  • kDialogSetForwarding : HsPhoneEvent.h
  • kDialogSetOperator : HsPhoneEvent.h
  • kDoneParsing : HsPhoneSMSTypes.h
  • kDontEncode : HsPhoneSMSTypes.h
  • keyA : HsKeyCodes.h
  • keyAt : HsKeyCodes.h
  • keyB : HsKeyCodes.h
  • keyBack : HsKeyCodes.h
  • keyBackslash : HsKeyCodes.h
  • keyBackspace : HsKeyCodes.h
  • keyBacktick : HsKeyCodes.h
  • keyBitExt1A : HsKeyTypes.h
  • keyBitExt1B : HsKeyTypes.h
  • keyBitExt1Bksp : HsKeyTypes.h
  • keyBitExt1C : HsKeyTypes.h
  • keyBitExt1D : HsKeyTypes.h
  • keyBitExt1E : HsKeyTypes.h
  • keyBitExt1Enter : HsKeyTypes.h
  • keyBitExt1F : HsKeyTypes.h
  • keyBitExt1G : HsKeyTypes.h
  • keyBitExt1H : HsKeyTypes.h
  • keyBitExt1I : HsKeyTypes.h
  • keyBitExt1J : HsKeyTypes.h
  • keyBitExt1K : HsKeyTypes.h
  • keyBitExt1L : HsKeyTypes.h
  • keyBitExt1M : HsKeyTypes.h
  • keyBitExt1N : HsKeyTypes.h
  • keyBitExt1O : HsKeyTypes.h
  • keyBitExt1Opt : HsKeyTypes.h
  • keyBitExt1P : HsKeyTypes.h
  • keyBitExt1Period : HsKeyTypes.h
  • keyBitExt1Q : HsKeyTypes.h
  • keyBitExt1R : HsKeyTypes.h
  • keyBitExt1S : HsKeyTypes.h
  • keyBitExt1Shift : HsKeyTypes.h
  • keyBitExt1Space : HsKeyTypes.h
  • keyBitExt1T : HsKeyTypes.h
  • keyBitExt1U : HsKeyTypes.h
  • keyBitExt1V : HsKeyTypes.h
  • keyBitExt1W : HsKeyTypes.h
  • keyBitExt1X : HsKeyTypes.h
  • keyBitExt1Y : HsKeyTypes.h
  • keyBitExt1Z : HsKeyTypes.h
  • keyBitExt2CmdMenu : HsKeyTypes.h
  • keyBitExt2Hard11 : HsKeyTypes.h
  • keyBitExt2Launcher : HsKeyTypes.h
  • keyBitExt2MfgTest : HsKeyTypes.h
  • keyBitExt2RShift : HsKeyTypes.h
  • keyBitExt2Side : HsKeyTypes.h
  • keyBitExt2Symbol : HsKeyTypes.h
  • keyBitExt2Unused6 : HsKeyTypes.h
  • keyBitExt2VolumeDown : HsKeyTypes.h
  • keyBitExt2VolumeUp : HsKeyTypes.h
  • keyBitExt2Zero : HsKeyTypes.h
  • keyBitHard5 : common/system/palmOneChars.h
  • keyBitNavLeft : common/system/palmOneNavigator.h
  • keyBitNavLRS : common/system/palmOneNavigator.h
  • keyBitNavRight : common/system/palmOneNavigator.h
  • keyBitNavSelect : common/system/palmOneNavigator.h
  • keyBitNumAntenna : HsKeyTypes.h
  • keyBitNumContrast : HsKeyTypes.h
  • keyBitNumCradle : HsKeyTypes.h
  • keyBitNumExt1A : HsKeyTypes.h
  • keyBitNumExt1B : HsKeyTypes.h
  • keyBitNumExt1Bksp : HsKeyTypes.h
  • keyBitNumExt1C : HsKeyTypes.h
  • keyBitNumExt1D : HsKeyTypes.h
  • keyBitNumExt1E : HsKeyTypes.h
  • keyBitNumExt1Enter : HsKeyTypes.h
  • keyBitNumExt1F : HsKeyTypes.h
  • keyBitNumExt1G : HsKeyTypes.h
  • keyBitNumExt1H : HsKeyTypes.h
  • keyBitNumExt1I : HsKeyTypes.h
  • keyBitNumExt1J : HsKeyTypes.h
  • keyBitNumExt1K : HsKeyTypes.h
  • keyBitNumExt1L : HsKeyTypes.h
  • keyBitNumExt1M : HsKeyTypes.h
  • keyBitNumExt1N : HsKeyTypes.h
  • keyBitNumExt1O : HsKeyTypes.h
  • keyBitNumExt1Opt : HsKeyTypes.h
  • keyBitNumExt1P : HsKeyTypes.h
  • keyBitNumExt1Period : HsKeyTypes.h
  • keyBitNumExt1Q : HsKeyTypes.h
  • keyBitNumExt1R : HsKeyTypes.h
  • keyBitNumExt1S : HsKeyTypes.h
  • keyBitNumExt1Shift : HsKeyTypes.h
  • keyBitNumExt1Space : HsKeyTypes.h
  • keyBitNumExt1T : HsKeyTypes.h
  • keyBitNumExt1U : HsKeyTypes.h
  • keyBitNumExt1V : HsKeyTypes.h
  • keyBitNumExt1W : HsKeyTypes.h
  • keyBitNumExt1X : HsKeyTypes.h
  • keyBitNumExt1Y : HsKeyTypes.h
  • keyBitNumExt1Z : HsKeyTypes.h
  • keyBitNumExt2CmdMenu : HsKeyTypes.h
  • keyBitNumExt2Hard11 : HsKeyTypes.h
  • keyBitNumExt2Launcher : HsKeyTypes.h
  • keyBitNumExt2MfgTest : HsKeyTypes.h
  • keyBitNumExt2RShift : HsKeyTypes.h
  • keyBitNumExt2Side : HsKeyTypes.h
  • keyBitNumExt2Symbol : HsKeyTypes.h
  • keyBitNumExt2Unused6 : HsKeyTypes.h
  • keyBitNumExt2VolumeDown : HsKeyTypes.h
  • keyBitNumExt2VolumeUp : HsKeyTypes.h
  • keyBitNumExt2Zero : HsKeyTypes.h
  • keyBitNumHard1 : HsKeyTypes.h
  • keyBitNumHard2 : HsKeyTypes.h
  • keyBitNumHard3 : HsKeyTypes.h
  • keyBitNumHard4 : HsKeyTypes.h
  • keyBitNumJogBack : HsKeyTypes.h
  • keyBitNumJogDown : HsKeyTypes.h
  • keyBitNumJogPress : HsKeyTypes.h
  • keyBitNumJogUp : HsKeyTypes.h
  • keyBitNumPageDown : HsKeyTypes.h
  • keyBitNumPageUp : HsKeyTypes.h
  • keyBitNumPower : HsKeyTypes.h
  • keyBitNumRockerCenter : HsKeyTypes.h
  • keyBitNumRockerDown : HsKeyTypes.h
  • keyBitNumRockerLeft : HsKeyTypes.h
  • keyBitNumRockerRight : HsKeyTypes.h
  • keyBitNumRockerUp : HsKeyTypes.h
  • keyBitNumUnused : HsKeyTypes.h
  • keyBitRockerCenter : HsKeyCommon.h
  • keyBitRockerDown : HsKeyCommon.h
  • keyBitRockerLeft : HsKeyCommon.h
  • keyBitRockerRight : HsKeyCommon.h
  • keyBitRockerUp : HsKeyCommon.h
  • keyBitsAllExt1 : HsKeyTypes.h
  • keyBitsAllExt2 : HsKeyTypes.h
  • keyBitThumbWheelBack : HsKeyCommon.h
  • keyBitThumbWheelDown : HsKeyCommon.h
  • keyBitThumbWheelPress : HsKeyCommon.h
  • keyBitThumbWheelUp : HsKeyCommon.h
  • keyC : HsKeyCodes.h
  • keyCalculator : HsKeyCodes.h
  • keyCapsLock : HsKeyCodes.h
  • keyCloseBracket : HsKeyCodes.h
  • KeyCodeType : HsKeyCodes.h
  • keyComma : HsKeyCodes.h
  • keyD : HsKeyCodes.h
  • keyDash : HsKeyCodes.h
  • keyDelete : HsKeyCodes.h
  • keyDownArrow : HsKeyCodes.h
  • keyE : HsKeyCodes.h
  • keyEight : HsKeyCodes.h
  • keyEject : HsKeyCodes.h
  • keyEnd : HsKeyCodes.h
  • keyEquals : HsKeyCodes.h
  • keyEscape : HsKeyCodes.h
  • keyF : HsKeyCodes.h
  • keyF1 : HsKeyCodes.h
  • keyF10 : HsKeyCodes.h
  • keyF11 : HsKeyCodes.h
  • keyF12 : HsKeyCodes.h
  • keyF13 : HsKeyCodes.h
  • keyF14 : HsKeyCodes.h
  • keyF15 : HsKeyCodes.h
  • keyF2 : HsKeyCodes.h
  • keyF3 : HsKeyCodes.h
  • keyF4 : HsKeyCodes.h
  • keyF5 : HsKeyCodes.h
  • keyF6 : HsKeyCodes.h
  • keyF7 : HsKeyCodes.h
  • keyF8 : HsKeyCodes.h
  • keyF9 : HsKeyCodes.h
  • keyFastForward : HsKeyCodes.h
  • keyFavorites : HsKeyCodes.h
  • keyFind : HsKeyCodes.h
  • keyFive : HsKeyCodes.h
  • keyForward : HsKeyCodes.h
  • keyFour : HsKeyCodes.h
  • keyG : HsKeyCodes.h
  • keyH : HsKeyCodes.h
  • keyHard1 : HsKeyCodes.h
  • keyHard10 : HsKeyCodes.h
  • keyHard11 : HsKeyCodes.h
  • keyHard12 : HsKeyCodes.h
  • keyHard13 : HsKeyCodes.h
  • keyHard14 : HsKeyCodes.h
  • keyHard2 : HsKeyCodes.h
  • keyHard3 : HsKeyCodes.h
  • keyHard4 : HsKeyCodes.h
  • keyHard5 : HsKeyCodes.h
  • keyHard6 : HsKeyCodes.h
  • keyHard7 : HsKeyCodes.h
  • keyHard8 : HsKeyCodes.h
  • keyHard9 : HsKeyCodes.h
  • keyHardAntenna : HsKeyCodes.h
  • keyHardBrightness : HsKeyCodes.h
  • keyHardContrast : HsKeyCodes.h
  • keyHardCradle : HsKeyCodes.h
  • keyHardCradle2 : HsKeyCodes.h
  • keyHardPower : HsKeyCodes.h
  • keyHelp : HsKeyCodes.h
  • keyHome : HsKeyCodes.h
  • keyHomePage : HsKeyCodes.h
  • keyI : HsKeyCodes.h
  • keyInsert : HsKeyCodes.h
  • keyJ : HsKeyCodes.h
  • keyK : HsKeyCodes.h
  • keyL : HsKeyCodes.h
  • keyLaunch : HsKeyCodes.h
  • keyLeftAlt : HsKeyCodes.h
  • keyLeftArrow : HsKeyCodes.h
  • keyLeftCommand : HsKeyCodes.h
  • keyLeftControl : HsKeyCodes.h
  • keyLeftShift : HsKeyCodes.h
  • keyLessThan : HsKeyCodes.h
  • keyLockDevice : HsKeyCodes.h
  • keyLogOff : HsKeyCodes.h
  • keyM : HsKeyCodes.h
  • keyMail : HsKeyCodes.h
  • keyMedia : HsKeyCodes.h
  • keyMenu : HsKeyCodes.h
  • keyMute : HsKeyCodes.h
  • keyMyComputer : HsKeyCodes.h
  • keyMyDocuments : HsKeyCodes.h
  • keyMyMusic : HsKeyCodes.h
  • keyMyPictures : HsKeyCodes.h
  • keyN : HsKeyCodes.h
  • keyNextField : HsKeyCodes.h
  • keyNextTrack : HsKeyCodes.h
  • keyNine : HsKeyCodes.h
  • keyNull : HsKeyCodes.h
  • keyNumericAsterisk : HsKeyCodes.h
  • keyNumericDash : HsKeyCodes.h
  • keyNumericEight : HsKeyCodes.h
  • keyNumericEnter : HsKeyCodes.h
  • keyNumericEquals : HsKeyCodes.h
  • keyNumericFive : HsKeyCodes.h
  • keyNumericFour : HsKeyCodes.h
  • keyNumericNine : HsKeyCodes.h
  • keyNumericOne : HsKeyCodes.h
  • keyNumericPeriod : HsKeyCodes.h
  • keyNumericPlus : HsKeyCodes.h
  • keyNumericSeven : HsKeyCodes.h
  • keyNumericSix : HsKeyCodes.h
  • keyNumericSlash : HsKeyCodes.h
  • keyNumericThree : HsKeyCodes.h
  • keyNumericTwo : HsKeyCodes.h
  • keyNumericZero : HsKeyCodes.h
  • keyNumLock : HsKeyCodes.h
  • keyO : HsKeyCodes.h
  • keyOne : HsKeyCodes.h
  • keyOpenBracket : HsKeyCodes.h
  • keyP : HsKeyCodes.h
  • keyPageDown : HsKeyCodes.h
  • keyPageUp : HsKeyCodes.h
  • keyPause : HsKeyCodes.h
  • keyPauseAudio : HsKeyCodes.h
  • keyPeriod : HsKeyCodes.h
  • keyPlay : HsKeyCodes.h
  • keyPlayPause : HsKeyCodes.h
  • keyPrevField : HsKeyCodes.h
  • keyPrevTrack : HsKeyCodes.h
  • keyPrintScreen : HsKeyCodes.h
  • keyQ : HsKeyCodes.h
  • keyR : HsKeyCodes.h
  • keyRefresh : HsKeyCodes.h
  • keyReturn : HsKeyCodes.h
  • keyRewind : HsKeyCodes.h
  • keyRightAlt : HsKeyCodes.h
  • keyRightArrow : HsKeyCodes.h
  • keyRightCommand : HsKeyCodes.h
  • keyRightControl : HsKeyCodes.h
  • keyRightShift : HsKeyCodes.h
  • keyRockerCenter : HsKeyCodes.h
  • keyRockerDown : HsKeyCodes.h
  • keyRockerLeft : HsKeyCodes.h
  • keyRockerRight : HsKeyCodes.h
  • keyRockerUp : HsKeyCodes.h
  • keyS : HsKeyCodes.h
  • keyScrollLock : HsKeyCodes.h
  • keySearch : HsKeyCodes.h
  • keySemiColon : HsKeyCodes.h
  • keySeven : HsKeyCodes.h
  • keySide : HsKeyCodes.h
  • keySingleQuote : HsKeyCodes.h
  • keySix : HsKeyCodes.h
  • keySlash : HsKeyCodes.h
  • keySpace : HsKeyCodes.h
  • keyStopAudio : HsKeyCodes.h
  • keyStopInternet : HsKeyCodes.h
  • keyT : HsKeyCodes.h
  • keyTab : HsKeyCodes.h
  • keyThree : HsKeyCodes.h
  • keyThumbWheelBack : HsKeyCodes.h
  • keyThumbWheelDown : HsKeyCodes.h
  • keyThumbWheelPush : HsKeyCodes.h
  • keyThumbWheelUp : HsKeyCodes.h
  • keyTwo : HsKeyCodes.h
  • keyU : HsKeyCodes.h
  • keyUpArrow : HsKeyCodes.h
  • keyV : HsKeyCodes.h
  • keyVolumeDown : HsKeyCodes.h
  • keyVolumeUp : HsKeyCodes.h
  • keyW : HsKeyCodes.h
  • keyX : HsKeyCodes.h
  • keyY : HsKeyCodes.h
  • keyZ : HsKeyCodes.h
  • keyZero : HsKeyCodes.h
  • kFailed : HsPhoneSMSTypes.h
  • kFileBrowserLibAPIVersion0 : FileBrowserLibCommon.h
  • kFileBrowserLibAPIVersion1 : FileBrowserLibCommon.h
  • kFileBrowserLibCtlGetVersion : FileBrowserLibCommon.h
  • kFileBrowserLibErrCantFind : FileBrowserLibCommon.h
  • kFileBrowserLibErrCantOpen : FileBrowserLibCommon.h
  • kFileBrowserLibErrCantParse : FileBrowserLibCommon.h
  • kFileBrowserLibErrInternal : FileBrowserLibCommon.h
  • kFileBrowserLibErrMemError : FileBrowserLibCommon.h
  • kFileBrowserLibErrorClass : FileBrowserLibCommon.h
  • kFileBrowserLibErrPathTooLong : FileBrowserLibCommon.h
  • kFileBrowserLibErrStillOpen : FileBrowserLibCommon.h
  • kFileBrowserLibFlagNoDirChange : FileBrowserLibCommon.h
  • kFileBrowserLibFlagNoFiles : FileBrowserLibCommon.h
  • kFileBrowserLibFlagNoFolders : FileBrowserLibCommon.h
  • kFileBrowserLibFlagNoNewFolder : FileBrowserLibCommon.h
  • kFileBrowserLibFlagNoSubDir : FileBrowserLibCommon.h
  • kFileBrowserLibFlagOneVolume : FileBrowserLibCommon.h
  • kFileBrowserLibFlagPromptOverwrite : FileBrowserLibCommon.h
  • kFileBrowserLibFlagRequireExtension : FileBrowserLibCommon.h
  • kFileBrowserLibMaxPathLength : FileBrowserLibCommon.h
  • kFileBrowserLibName : FileBrowserLibCommon.h
  • kFileBrowserLibPathBufferSize : FileBrowserLibCommon.h
  • kFileBrowserLibTrapParseFileURL : FileBrowserLibCommon.h
  • kFileBrowserLibTrapShowMultiselectDialog : FileBrowserLibCommon.h
  • kFileBrowserLibTrapShowOpenDialog : FileBrowserLibCommon.h
  • kFileBrowserLibTrapShowSaveAsDialog : FileBrowserLibCommon.h
  • kFirstName : HsPhoneSMSTypes.h
  • kFlipSmiley : SmartTextEngineDef.h
  • kFreeReply : HsPhoneSMSTypes.h
  • kFrmNavHeaderFlagsAppFocusStartState : HsNavCommon.h
  • kFrmNavHeaderFlagsAppFocusStartStateValue : HsNavCommon.h
  • kFrmNavHeaderFlagsAutoGenerated : HsNavCommon.h
  • kFrmNavHeaderFlagsDefaultStartStateValue : HsNavCommon.h
  • kFrmNavHeaderFlagsInvalidStartStateValue : HsNavCommon.h
  • kFrmNavHeaderFlagsObjectFocusStartState : HsNavCommon.h
  • kFrmNavHeaderFlagsObjectFocusStartStateValue : HsNavCommon.h
  • kFrmNavHeaderFlagsStartStateMask : HsNavCommon.h
  • kFrmNavInfoVersion : HsNavCommon.h
  • kFrmNavObjectFlagsForceInteractionMode : HsNavCommon.h
  • kFrmNavObjectFlagsIsBigButton : HsNavCommon.h
  • kFrmNavObjectFlagsSkip : HsNavCommon.h
  • kFrmNavStateFlagsInteractionMode : HsNavCommon.h
  • kFrmNavStateFlagsObjectFocusMode : HsNavCommon.h
  • kFrownSmiley : SmartTextEngineDef.h
  • kFullSizeImageHeight : ImageLibCommon.h
  • kFullSizeImageWidth : ImageLibCommon.h
  • kGammaCharacter : SmartTextEngineDef.h
  • kGenericMCCMNC : CarrierCustomLibTypes.h
  • kGoLcdLibTrapClose : PalmGoLCDCommon.h
  • kGoLcdLibTrapGetBounds : PalmGoLCDCommon.h
  • kGoLcdLibTrapGetGsiState : PalmGoLCDCommon.h
  • kGoLcdLibTrapGetInkState : PalmGoLCDCommon.h
  • kGoLcdLibTrapGetStatus : PalmGoLCDCommon.h
  • kGoLcdLibTrapGetTimeout : PalmGoLCDCommon.h
  • kGoLcdLibTrapOpen : PalmGoLCDCommon.h
  • kGoLcdLibTrapSetBounds : PalmGoLCDCommon.h
  • kGoLcdLibTrapSetGsiState : PalmGoLCDCommon.h
  • kGoLcdLibTrapSetInkState : PalmGoLCDCommon.h
  • kGoLcdLibTrapSetStatus : PalmGoLCDCommon.h
  • kGoLcdLibTrapSetTimeout : PalmGoLCDCommon.h
  • kGPRSQOSTypeMinimum : HsPhoneGSMTypes.h
  • kGPRSQOSTypeRequired : HsPhoneGSMTypes.h
  • kGreekSymbols : HsPhoneSMSTypes.h
  • kHALLEDCapcitySleepMultiColor : PalmLED.h
  • kHALLEDCapcitySleepOn : PalmLED.h
  • kHALLEDCapcitySleepPattern : PalmLED.h
  • kHALLEDCapcitySleepPatternSetting : PalmLED.h
  • kHALLEDCapcityUnderSleep : PalmLED.h
  • kHALLEDPropertySleepColorAmberWhite : PalmLED.h
  • kHALLEDPropertySleepColorBlue : PalmLED.h
  • kHALLEDPropertySleepColorGreen : PalmLED.h
  • kHALLEDPropertySleepColorRed : PalmLED.h
  • kHALLEDPropertySleepOn : PalmLED.h
  • kHALLEDPropertySleepPattern : PalmLED.h
  • kHALLEDPropertySleepReserve : PalmLED.h
  • kHALLEDPropertyUnderSleep : PalmLED.h
  • kHeartSmiley : SmartTextEngineDef.h
  • kHelperServiceClassIDMMS : MmsHelperCommon.h
  • kHiResTimeErrorClass : palmOneHiResTimerCommon.h , PalmHiResTime.h
  • kHiResTimeLibCreator : palmOneHiResTimerCommon.h , PalmHiResTime.h
  • kHiResTimeLibErrBadParam : palmOneHiResTimerCommon.h
  • kHiResTimeLibErrNotAvailable : palmOneHiResTimerCommon.h
  • kHiResTimeLibErrNotOpen : palmOneHiResTimerCommon.h
  • kHiResTimeLibErrStillOpen : palmOneHiResTimerCommon.h
  • kHiResTimeLibName : palmOneHiResTimerCommon.h , PalmHiResTime.h
  • kHiResTimeLibType : palmOneHiResTimerCommon.h , PalmHiResTime.h
  • kHiResTimeLibVersion : palmOneHiResTimerCommon.h , PalmHiResTime.h
  • kHiResTimeLibVersion1 : palmOneHiResTimerCommon.h , PalmHiResTime.h
  • kHiResTimeLibVersion2 : palmOneHiResTimerCommon.h
  • kHRLibTrapTimerGetTime : palmOneHiResTimerCommon.h , PalmHiResTime.h
  • kHRLibTrapTimerTicksPerSecond : palmOneHiResTimerCommon.h , PalmHiResTime.h
  • kHsSoundLibTrapClose : HsSoundLibTraps.h
  • kHsSoundLibTrapFormatPlay : HsSoundLibTraps.h
  • kHsSoundLibTrapFormatRecord : HsSoundLibTraps.h
  • kHsSoundLibTrapGetUserVolume : HsSoundLibTraps.h
  • kHsSoundLibTrapGetVersion : HsSoundLibTraps.h
  • kHsSoundLibTrapOpen : HsSoundLibTraps.h
  • kHsSoundLibTrapPortGetInfo : HsSoundLibTraps.h
  • kHsSoundLibTrapPortSetParam : HsSoundLibTraps.h
  • kHsSoundLibTrapSetUserVolume : HsSoundLibTraps.h
  • kHsSoundLibTrapSwitchGetPort : HsSoundLibTraps.h
  • kHsSoundLibTrapSwitchSetPort : HsSoundLibTraps.h
  • kHsSoundLibTrapTonePlay : HsSoundLibTraps.h
  • kHsSoundLibTrapToneStop : HsSoundLibTraps.h
  • kHtmlLibTrapAbortRenderData : HtmlLibTrap.h
  • kHtmlLibTrapAddImageData : HtmlLibTrap.h
  • kHtmlLibTrapAddTextData : HtmlLibTrap.h
  • kHtmlLibTrapCanScroll : HtmlLibTrap.h
  • kHtmlLibTrapClearScreen : HtmlLibTrap.h
  • kHtmlLibTrapClose : HtmlLibTrap.h
  • kHtmlLibTrapCreateContentObject : HtmlLibTrap.h
  • kHtmlLibTrapDestroyContentObject : HtmlLibTrap.h
  • kHtmlLibTrapFinalize : HtmlLibTrap.h
  • kHtmlLibTrapFindText : HtmlLibTrap.h
  • kHtmlLibTrapGetTargetInfo : HtmlLibTrap.h
  • kHtmlLibTrapGetTextSelection : HtmlLibTrap.h
  • kHtmlLibTrapGetVScrollPosition : HtmlLibTrap.h
  • kHtmlLibTrapInitialize : HtmlLibTrap.h
  • kHtmlLibTrapInitializeWithHeapSize : HtmlLibTrap.h
  • kHtmlLibTrapNotifyUIEvent : HtmlLibTrap.h
  • kHtmlLibTrapOpen : HtmlLibTrap.h
  • kHtmlLibTrapProgress : HtmlLibTrap.h
  • kHtmlLibTrapRedrawScreen : HtmlLibTrap.h
  • kHtmlLibTrapRenderData : HtmlLibTrap.h
  • kHtmlLibTrapResetFocusInfo : HtmlLibTrap.h
  • kHtmlLibTrapResizeScreen : HtmlLibTrap.h
  • kHtmlLibTrapSetBiggerFont : HtmlLibTrap.h
  • kHtmlLibTrapSetDisplayMode : HtmlLibTrap.h
  • kHtmlLibTrapSetFocusStatus : HtmlLibTrap.h
  • kHtmlLibTrapSetFormWidgetProc : HtmlLibTrap.h
  • kHtmlLibTrapSetImageMemoryLimit : HtmlLibTrap.h
  • kHtmlLibTrapSetInclusionCallback : HtmlLibTrap.h
  • kHtmlLibTrapSetLinkSelectionCallback : HtmlLibTrap.h
  • kHtmlLibTrapSetScanPhoneNumberCallback : HtmlLibTrap.h
  • kHtmlLibTrapSetScrollbarMode : HtmlLibTrap.h
  • kHtmlLibTrapSetScrollbars : HtmlLibTrap.h
  • kHtmlLibTrapSetSubmitFormCallback : HtmlLibTrap.h
  • kHtmlLibTrapSetVScrollPosition : HtmlLibTrap.h
  • kHtmlLibTrapSleep : HtmlLibTrap.h
  • kHtmlLibTrapWake : HtmlLibTrap.h
  • kHTTPLibTrapAuthCacheGetChallengeTokenSS : HS_HTTPLibConst.h
  • kHTTPLibTrapAuthInfoPass : HS_HTTPLibConst.h
  • kHTTPLibTrapAuthInfoRealm : HS_HTTPLibConst.h
  • kHTTPLibTrapAuthInfoTidy : HS_HTTPLibConst.h
  • kHTTPLibTrapAuthInfoUser : HS_HTTPLibConst.h
  • kHTTPLibTrapCert_EndPeekIssuerRDN : HS_HTTPLibConst.h
  • kHTTPLibTrapCert_EndPeekSubjectRDN : HS_HTTPLibConst.h
  • kHTTPLibTrapCert_PeekRSAPublicKeyBits : HS_HTTPLibConst.h
  • kHTTPLibTrapCert_PeekValidityEnd : HS_HTTPLibConst.h
  • kHTTPLibTrapCert_PeekValidityStart : HS_HTTPLibConst.h
  • kHTTPLibTrapCertBeginPeekIssuerRDN : HS_HTTPLibConst.h
  • kHTTPLibTrapCertBeginPeekSubjectRDN : HS_HTTPLibConst.h
  • kHTTPLibTrapCertListBeginDecode : HS_HTTPLibConst.h
  • kHTTPLibTrapCertListClone : HS_HTTPLibConst.h
  • kHTTPLibTrapCertListDelete : HS_HTTPLibConst.h
  • kHTTPLibTrapCertListEndDecode : HS_HTTPLibConst.h
  • kHTTPLibTrapCertListGetCipherInfo : HS_HTTPLibConst.h
  • kHTTPLibTrapCertListImportCert : HS_HTTPLibConst.h
  • kHTTPLibTrapCertListLength : HS_HTTPLibConst.h
  • kHTTPLibTrapCertListLock : HS_HTTPLibConst.h
  • kHTTPLibTrapCertListNew : HS_HTTPLibConst.h
  • kHTTPLibTrapCertListType : HS_HTTPLibConst.h
  • kHTTPLibTrapCertListUnlock : HS_HTTPLibConst.h
  • kHTTPLibTrapCertPeekIssuerRDN : HS_HTTPLibConst.h
  • kHTTPLibTrapCertPeekIssuerRDNStrType : HS_HTTPLibConst.h
  • kHTTPLibTrapCertPeekSerialNumber : HS_HTTPLibConst.h
  • kHTTPLibTrapCertPeekSignAlgo : HS_HTTPLibConst.h
  • kHTTPLibTrapCertPeekSubjectRDN : HS_HTTPLibConst.h
  • kHTTPLibTrapCertPeekSubjectRDNStrType : HS_HTTPLibConst.h
  • kHTTPLibTrapCertPeekVersion : HS_HTTPLibConst.h
  • kHTTPLibTrapClearDNSCache : HS_HTTPLibConst.h
  • kHTTPLibTrapClientCertListClone : HS_HTTPLibConst.h
  • kHTTPLibTrapClientCertListDelete : HS_HTTPLibConst.h
  • kHTTPLibTrapClientCertListIsValid : HS_HTTPLibConst.h
  • kHTTPLibTrapClientCertListLength : HS_HTTPLibConst.h
  • kHTTPLibTrapClientCertListNew : HS_HTTPLibConst.h
  • kHTTPLibTrapClientCertListSetValid : HS_HTTPLibConst.h
  • kHTTPLibTrapClientCertSelect : HS_HTTPLibConst.h
  • kHTTPLibTrapClose : HS_HTTPLibConst.h
  • kHTTPLibTrapCloseAllKeepAlive : HS_HTTPLibConst.h
  • kHTTPLibTrapCookieMakeEmpty : HS_HTTPLibConst.h
  • kHTTPLibTrapDataHandle_Delete : HS_HTTPLibConst.h
  • kHTTPLibTrapDataHandle_Length : HS_HTTPLibConst.h
  • kHTTPLibTrapDataHandle_Lock : HS_HTTPLibConst.h
  • kHTTPLibTrapDataHandle_Unlock : HS_HTTPLibConst.h
  • kHTTPLibTrapFinalize : HS_HTTPLibConst.h
  • kHTTPLibTrapFindAuthCandidate : HS_HTTPLibConst.h
  • kHTTPLibTrapFindAuthInfo : HS_HTTPLibConst.h
  • kHTTPLibTrapFixedString_Delete : HS_HTTPLibConst.h
  • kHTTPLibTrapFixedString_Length : HS_HTTPLibConst.h
  • kHTTPLibTrapFixedString_Lock : HS_HTTPLibConst.h
  • kHTTPLibTrapFixedString_Unlock : HS_HTTPLibConst.h
  • kHTTPLibTrapFixedStringNew : HS_HTTPLibConst.h
  • kHTTPLibTrapHeaderSplitByX : HS_HTTPLibConst.h
  • kHTTPLibTrapInitialize : HS_HTTPLibConst.h
  • kHTTPLibTrapIsHTTP11OverProxy : HS_HTTPLibConst.h
  • kHTTPLibTrapIsSendCookie : HS_HTTPLibConst.h
  • kHTTPLibTrapIsSendReferer : HS_HTTPLibConst.h
  • kHTTPLibTrapIsUseProxy : HS_HTTPLibConst.h
  • kHTTPLibTrapLoadCookiesEntries : HS_HTTPLibConst.h
  • kHTTPLibTrapMakeAuthInfo : HS_HTTPLibConst.h
  • kHTTPLibTrapMakeCertList : HS_HTTPLibConst.h
  • kHTTPLibTrapMakeCookiesString : HS_HTTPLibConst.h
  • kHTTPLibTrapMakeProxy : HS_HTTPLibConst.h
  • kHTTPLibTrapOpen : HS_HTTPLibConst.h
  • kHTTPLibTrapOpenCount : HS_HTTPLibConst.h
  • kHTTPLibTrapRegisterSSLClass : HS_HTTPLibConst.h
  • kHTTPLibTrapSaveCookiesEntries : HS_HTTPLibConst.h
  • kHTTPLibTrapServerCertConfirm : HS_HTTPLibConst.h
  • kHTTPLibTrapSetConnectTimeOut : HS_HTTPLibConst.h
  • kHTTPLibTrapSetCookie : HS_HTTPLibConst.h
  • kHTTPLibTrapSetCookieMax : HS_HTTPLibConst.h
  • kHTTPLibTrapSetCookieMode : HS_HTTPLibConst.h
  • kHTTPLibTrapSetCookieX : HS_HTTPLibConst.h
  • kHTTPLibTrapSetDefaultHeaders : HS_HTTPLibConst.h
  • kHTTPLibTrapSetDNSMaxRetry : HS_HTTPLibConst.h
  • kHTTPLibTrapSetDNSRetryInterval : HS_HTTPLibConst.h
  • kHTTPLibTrapSetHTTP11OverProxy : HS_HTTPLibConst.h
  • kHTTPLibTrapSetHTTPPort : HS_HTTPLibConst.h
  • kHTTPLibTrapSetHTTPSPort : HS_HTTPLibConst.h
  • kHTTPLibTrapSetMaxKeepAliveTimeout : HS_HTTPLibConst.h
  • kHTTPLibTrapSetMaxRequestBody : HS_HTTPLibConst.h
  • kHTTPLibTrapSetMaxRequestHeader : HS_HTTPLibConst.h
  • kHTTPLibTrapSetNetLibProc : HS_HTTPLibConst.h
  • kHTTPLibTrapSetProxy : HS_HTTPLibConst.h
  • kHTTPLibTrapSetReqTimeOut : HS_HTTPLibConst.h
  • kHTTPLibTrapSetRspTimeOut : HS_HTTPLibConst.h
  • kHTTPLibTrapSetSendCookie : HS_HTTPLibConst.h
  • kHTTPLibTrapSetSendProxyKeepAlive : HS_HTTPLibConst.h
  • kHTTPLibTrapSetSendReferer : HS_HTTPLibConst.h
  • kHTTPLibTrapSetSSLClientCertSelectProc : HS_HTTPLibConst.h
  • kHTTPLibTrapSetSSLServerCertConfirmProc : HS_HTTPLibConst.h
  • kHTTPLibTrapSetSSLVersionFlag : HS_HTTPLibConst.h
  • kHTTPLibTrapSetTunnelingCallback : HS_HTTPLibConst.h
  • kHTTPLibTrapSetUseProxy : HS_HTTPLibConst.h
  • kHTTPLibTrapSetUserAgent : HS_HTTPLibConst.h
  • kHTTPLibTrapSetUseragentSelectionRule : HS_HTTPLibConst.h
  • kHTTPLibTrapSetUserPass : HS_HTTPLibConst.h
  • kHTTPLibTrapSetUserPassX : HS_HTTPLibConst.h
  • kHTTPLibTrapSetWakeUpCallback : HS_HTTPLibConst.h
  • kHTTPLibTrapSleep : HS_HTTPLibConst.h
  • kHTTPLibTrapSSLClass : HS_HTTPLibConst.h
  • kHTTPLibTrapSSLCloseCertDB : HS_HTTPLibConst.h
  • kHTTPLibTrapSSLOpenCertDB : HS_HTTPLibConst.h
  • kHTTPLibTrapSSLTimeout : HS_HTTPLibConst.h
  • kHTTPLibTrapStreamAddHeader : HS_HTTPLibConst.h
  • kHTTPLibTrapStreamAddHeaderLine : HS_HTTPLibConst.h
  • kHTTPLibTrapStreamClose : HS_HTTPLibConst.h
  • kHTTPLibTrapStreamCreateRequest : HS_HTTPLibConst.h
  • kHTTPLibTrapStreamCreateRequestWithChunkEncoding : HS_HTTPLibConst.h
  • kHTTPLibTrapStreamDelete : HS_HTTPLibConst.h
  • kHTTPLibTrapStreamGetContentLength : HS_HTTPLibConst.h
  • kHTTPLibTrapStreamGetEntityLength : HS_HTTPLibConst.h
  • kHTTPLibTrapStreamGetFlag : HS_HTTPLibConst.h
  • kHTTPLibTrapStreamGetHeader : HS_HTTPLibConst.h
  • kHTTPLibTrapStreamGetHeaderWithOffset : HS_HTTPLibConst.h
  • kHTTPLibTrapStreamGetRequestSent : HS_HTTPLibConst.h
  • kHTTPLibTrapStreamGetResponseHeader : HS_HTTPLibConst.h
  • kHTTPLibTrapStreamGetResponseHeaderLength : HS_HTTPLibConst.h
  • kHTTPLibTrapStreamGetScheme : HS_HTTPLibConst.h
  • kHTTPLibTrapStreamGetState : HS_HTTPLibConst.h
  • kHTTPLibTrapStreamGetStatusCode : HS_HTTPLibConst.h
  • kHTTPLibTrapStreamIsHeaderReceived : HS_HTTPLibConst.h
  • kHTTPLibTrapStreamNew : HS_HTTPLibConst.h
  • kHTTPLibTrapStreamReceiveResponse : HS_HTTPLibConst.h
  • kHTTPLibTrapStreamResumeTimer : HS_HTTPLibConst.h
  • kHTTPLibTrapStreamSendRequest : HS_HTTPLibConst.h
  • kHTTPLibTrapStreamSendRequestWithChunkEncoding : HS_HTTPLibConst.h
  • kHTTPLibTrapStreamSendRequestWithPostData : HS_HTTPLibConst.h
  • kHTTPLibTrapStreamSetPostData : HS_HTTPLibConst.h
  • kHTTPLibTrapStreamSuspendTimer : HS_HTTPLibConst.h
  • kHTTPLibTrapString_Delete : HS_HTTPLibConst.h
  • kHTTPLibTrapString_Length : HS_HTTPLibConst.h
  • kHTTPLibTrapString_Lock : HS_HTTPLibConst.h
  • kHTTPLibTrapString_Unlock : HS_HTTPLibConst.h
  • kHTTPLibTrapStringNew : HS_HTTPLibConst.h
  • kHTTPLibTrapURLString_Delete : HS_HTTPLibConst.h
  • kHTTPLibTrapURLString_Length : HS_HTTPLibConst.h
  • kHTTPLibTrapURLString_Lock : HS_HTTPLibConst.h
  • kHTTPLibTrapURLString_Unlock : HS_HTTPLibConst.h
  • kHTTPLibTrapURLStringNew : HS_HTTPLibConst.h
  • kHTTPLibTrapVHandle_Delete : HS_HTTPLibConst.h
  • kHTTPLibTrapVHandle_Length : HS_HTTPLibConst.h
  • kHTTPLibTrapVHandle_Lock : HS_HTTPLibConst.h
  • kHTTPLibTrapVHandle_Unlock : HS_HTTPLibConst.h
  • kHTTPLibTrapWake : HS_HTTPLibConst.h
  • kHWUtilsCreator : HardwareUtils68K.h
  • kHWUtilsName : HardwareUtils68K.h
  • kHWUtilsTrapBlinkLED : HardwareUtils68K.h
  • kHWUtilsTrapClose : HardwareUtils68K.h
  • kHWUtilsTrapEnableDisplay : HardwareUtils68K.h
  • kHWUtilsTrapGetDisplayState : HardwareUtils68K.h
  • kHWUtilsTrapOpen : HardwareUtils68K.h
  • kHWUtilsTrapSetBlinkRate : HardwareUtils68K.h
  • kHWUtilsType : HardwareUtils68K.h
  • kImageFilenameLength : ImageLibCommon.h
  • kImageLibTrapBitmapDelete : ImageLibTraps.h
  • kImageLibTrapCameraExists : ImageLibTraps.h
  • kImageLibTrapCheckLockedImages : ImageLibTraps.h
  • kImageLibTrapClose : ImageLibTraps.h
  • kImageLibTrapCopyImage : ImageLibTraps.h
  • kImageLibTrapCopyImageFromVFS : ImageLibTraps.h
  • kImageLibTrapCopyImageToBuffer : ImageLibTraps.h
  • kImageLibTrapCopyImageToFile : ImageLibTraps.h
  • kImageLibTrapCopyImageToVFS : ImageLibTraps.h
  • kImageLibTrapDeleteImage : ImageLibTraps.h
  • kImageLibTrapDoAttachImageDialog : ImageLibTraps.h
  • kImageLibTrapDoInfoDialog : ImageLibTraps.h
  • kImageLibTrapDoNoteDialog : ImageLibTraps.h
  • kImageLibTrapDrawJPEG : ImageLibTraps.h
  • kImageLibTrapFindImageByID : ImageLibTraps.h
  • kImageLibTrapGetAveragePictureSize : ImageLibTraps.h
  • kImageLibTrapGetDimensions : ImageLibTraps.h
  • kImageLibTrapGetDimensionsJPEG : ImageLibTraps.h
  • kImageLibTrapGetDimensionsVFS : ImageLibTraps.h
  • kImageLibTrapGetImageDatabases : ImageLibTraps.h
  • kImageLibTrapGetImageID : ImageLibTraps.h
  • kImageLibTrapGetImageInfo : ImageLibTraps.h
  • kImageLibTrapGetJPEGQuality : ImageLibTraps.h
  • kImageLibTrapGetNoteFont : ImageLibTraps.h
  • kImageLibTrapGetVersion : ImageLibTraps.h
  • kImageLibTrapImageBitmapCreate : ImageLibTraps.h
  • kImageLibTrapImageBitmapCreateFromVFS : ImageLibTraps.h
  • kImageLibTrapImageBitmapFill : ImageLibTraps.h
  • kImageLibTrapImageBitmapFillFromVFS : ImageLibTraps.h
  • kImageLibTrapImageCapture : ImageLibTraps.h
  • kImageLibTrapImageDraw : ImageLibTraps.h
  • kImageLibTrapImageDrawFromVFS : ImageLibTraps.h
  • kImageLibTrapImageSave : ImageLibTraps.h
  • kImageLibTrapInsertImageFromBuffer : ImageLibTraps.h
  • kImageLibTrapInsertImageFromFile : ImageLibTraps.h
  • kImageLibTrapIterateImages : ImageLibTraps.h
  • kImageLibTrapIterateVFSImages : ImageLibTraps.h
  • kImageLibTrapIterDeleteImage : ImageLibTraps.h
  • kImageLibTrapIterDrawImage : ImageLibTraps.h
  • kImageLibTrapIterDrawThumbnail : ImageLibTraps.h
  • kImageLibTrapIterFree : ImageLibTraps.h
  • kImagelibTrapIterGetCount : ImageLibTraps.h
  • kImageLibTrapIterGetDimensions : ImageLibTraps.h
  • kImageLibTrapIterGetImageInfo : ImageLibTraps.h
  • kImageLibTrapIterRefresh : ImageLibTraps.h
  • kImageLibTrapIterRemoveImage : ImageLibTraps.h
  • kImageLibTrapIterResize : ImageLibTraps.h
  • kImageLibTrapIterSearch : ImageLibTraps.h
  • kImageLibTrapIterSort : ImageLibTraps.h
  • kImageLibTrapLockImage : ImageLibTraps.h
  • kImageLibTrapOpen : ImageLibTraps.h
  • kImageLibTrapPreviewBitmapCreate : ImageLibTraps.h
  • kImageLibTrapPreviewBitmapFill : ImageLibTraps.h
  • kImageLibTrapPreviewDraw : ImageLibTraps.h
  • kImageLibTrapPreviewStart : ImageLibTraps.h
  • kImageLibTrapPreviewStop : ImageLibTraps.h
  • kImageLibTrapResize : ImageLibTraps.h
  • kImageLibTrapResizeImage : ImageLibTraps.h
  • kImageLibTrapResizeJPEG : ImageLibTraps.h
  • kImageLibTrapResizeVFS : ImageLibTraps.h
  • kImageLibTrapSetImageID : ImageLibTraps.h
  • kImageLibTrapSetImageInfo : ImageLibTraps.h
  • kImageLibTrapSetJPEGQuality : ImageLibTraps.h
  • kImageLibTrapSetNoteFont : ImageLibTraps.h
  • kImageLibTrapSetProgressCallback : ImageLibTraps.h
  • kImageLibTrapThumbnailBitmapCreate : ImageLibTraps.h
  • kImageLibTrapThumbnailBitmapCreateFromVFS : ImageLibTraps.h
  • kImageLibTrapThumbnailBitmapFill : ImageLibTraps.h
  • kImageLibTrapThumbnailBitmapFillFromVFS : ImageLibTraps.h
  • kImageLibTrapThumbnailDraw : ImageLibTraps.h
  • kImageLibTrapThumbnailDrawFromVFS : ImageLibTraps.h
  • kImageLibTrapTurnCameraOff : ImageLibTraps.h
  • kIndicatorAlertAlert : HsExtCommon.h
  • kIndicatorAlertCalendar : HsExtCommon.h
  • kIndicatorAlertMail : HsExtCommon.h
  • kIndicatorAlertNone : HsExtCommon.h
  • kIndicatorAlertPending : HsExtCommon.h
  • kIndicatorAlertSMS : HsExtCommon.h
  • kIndicatorAlertVoicemail : HsExtCommon.h
  • kIndicatorBattCharge : HsExtCommon.h
  • kIndicatorBattFull : HsExtCommon.h
  • kIndicatorBattLow : HsExtCommon.h
  • kIndicatorBattNone : HsExtCommon.h
  • kIndicatorBattTrickle : HsExtCommon.h
  • kIndicatorBtConnectAudio : PmSysGadgetLibCommon.h
  • kIndicatorBtConnectHeadset : PmSysGadgetLibCommon.h
  • kIndicatorBtConnectOther : PmSysGadgetLibCommon.h
  • kIndicatorBtConnectStereo : PmSysGadgetLibCommon.h
  • kIndicatorBtDUN : PmSysGadgetLibCommon.h
  • kIndicatorBtOff : PmSysGadgetLibCommon.h
  • kIndicatorBtOn : PmSysGadgetLibCommon.h
  • kIndicatorCountForever : HsExtCommon.h
  • kIndicatorCountGetState : HsExtCommon.h
  • kIndicatorForceGreen : HsExtCommon.h
  • kIndicatorForceNone : HsExtCommon.h
  • kIndicatorForceOff : HsExtCommon.h
  • kIndicatorForceOn : HsExtCommon.h
  • kIndicatorForceRed : HsExtCommon.h
  • kIndicatorForceRedGreen : HsExtCommon.h
  • kIndicatorRingActive : HsExtCommon.h
  • kIndicatorRingContact : HsExtCommon.h
  • kIndicatorRingNone : HsExtCommon.h
  • kIndicatorRingRoam : HsExtCommon.h
  • kIndicatorSignalBad : HsExtCommon.h
  • kIndicatorSignalGood : HsExtCommon.h
  • kIndicatorSignalNone : HsExtCommon.h
  • kIndicatorSignalRoam : HsExtCommon.h
  • kIndicatorStateNull : HsExtCommon.h
  • kIndicatorTypeCount : HsExtCommon.h
  • kIndicatorTypeLed : HsExtCommon.h
  • kIndicatorTypeVibrator : HsExtCommon.h
  • kIndicatorUsageDataCall : HsExtCommon.h
  • kIndicatorUsageNone : HsExtCommon.h
  • kIndicatorUsageVoiceCall : HsExtCommon.h
  • kInternetEMail : HsPhoneSMSTypes.h
  • kInvalidRecIndex : ImageLibCommon.h
  • kIOTACertMaxBlockLen : HsPhoneIOTATypes.h
  • kIOTACertMaxBlocks : HsPhoneIOTATypes.h
  • kIOTANaiIMStoreMaxBlocks : HsPhoneIOTATypes.h
  • kIOTANaiPpgMaxBlocks : HsPhoneIOTATypes.h
  • kIOTANaiSipDataxchMaxBlocks : HsPhoneIOTATypes.h
  • kIOTANaiSipDdatgwyMaxBlocks : HsPhoneIOTATypes.h
  • kIOTANaiSipEdgePxyMaxBlocks : HsPhoneIOTATypes.h
  • kIOTAPhnSipRetryCntMaxBlocks : HsPhoneIOTATypes.h
  • kIOTAPhnSipRetryCntMaxLen : HsPhoneIOTATypes.h
  • kIOTAPhnSipRetryTimerMaxBloacks : HsPhoneIOTATypes.h
  • kIOTAPhnSipRetryTimerMaxLen : HsPhoneIOTATypes.h
  • kIOTAProxyADDRMaxLen : HsPhoneIOTATypes.h
  • kIOTAPxyAddrWdpMaxBlocks : HsPhoneIOTATypes.h
  • kIOTASipCfgBlocks : HsPhoneIOTATypes.h
  • kIOTATrustedDomainMaxLen : HsPhoneIOTATypes.h
  • kIOTAUrlArrayMaxLen : HsPhoneIOTATypes.h
  • kIOTAUrlMaxLen : HsPhoneIOTATypes.h
  • kJPEGOperation : ImageLibCommon.h
  • kLambdaCharacter : SmartTextEngineDef.h
  • kLcdOverlayLibCreator : PalmLcdOverlay.h , palmOneLcdOverlayCommon.h
  • kLcdOverlayLibCtrlDraw : palmOneLcdOverlayCommon.h , PalmLcdOverlay.h
  • kLcdOverlayLibCtrlFormatGet : PalmLcdOverlay.h , palmOneLcdOverlayCommon.h
  • kLcdOverlayLibCtrlFormatQuery : PalmLcdOverlay.h , palmOneLcdOverlayCommon.h
  • kLcdOverlayLibCtrlFormatSet : PalmLcdOverlay.h , palmOneLcdOverlayCommon.h
  • kLcdOverlayLibCtrlRectGet : palmOneLcdOverlayCommon.h , PalmLcdOverlay.h
  • kLcdOverlayLibCtrlRectSet : palmOneLcdOverlayCommon.h , PalmLcdOverlay.h
  • kLcdOverlayLibCtrlStart : PalmLcdOverlay.h , palmOneLcdOverlayCommon.h
  • kLcdOverlayLibCtrlStop : PalmLcdOverlay.h , palmOneLcdOverlayCommon.h
  • kLcdOverlayLibDataFormatRGB565 : PalmLcdOverlay.h , palmOneLcdOverlayCommon.h
  • kLcdOverlayLibDataFormatYCbCr420 : PalmLcdOverlay.h , palmOneLcdOverlayCommon.h
  • kLcdOverlayLibDataFormatYCbCr420Planar : PalmLcdOverlay.h , palmOneLcdOverlayCommon.h
  • kLcdOverlayLibDataFormatYCbCr422 : PalmLcdOverlay.h , palmOneLcdOverlayCommon.h
  • kLcdOverlayLibDataFormatYCbCr422Planar : PalmLcdOverlay.h , palmOneLcdOverlayCommon.h
  • kLcdOverlayLibDataFormatYCbCr444 : PalmLcdOverlay.h , palmOneLcdOverlayCommon.h
  • kLcdOverlayLibDataFormatYCbCr444Planar : PalmLcdOverlay.h , palmOneLcdOverlayCommon.h
  • kLcdOverlayLibErrBadParam : PalmLcdOverlay.h , palmOneLcdOverlayCommon.h
  • kLcdOverlayLibErrInternal : PalmLcdOverlay.h , palmOneLcdOverlayCommon.h
  • kLcdOverlayLibErrNoMemory : PalmLcdOverlay.h , palmOneLcdOverlayCommon.h
  • kLcdOverlayLibErrNotCompatible : PalmLcdOverlay.h , palmOneLcdOverlayCommon.h
  • kLcdOverlayLibErrNotOpen : PalmLcdOverlay.h , palmOneLcdOverlayCommon.h
  • kLcdOverlayLibErrNotSupported : PalmLcdOverlay.h , palmOneLcdOverlayCommon.h
  • kLcdOverlayLibErrorClass : PalmLcdOverlay.h , palmOneLcdOverlayCommon.h
  • kLcdOverlayLibErrStillOpen : PalmLcdOverlay.h , palmOneLcdOverlayCommon.h
  • kLcdOverlayLibName : palmOneLcdOverlayCommon.h , PalmLcdOverlay.h
  • kLcdOverlayLibTrapControl : PalmLcdOverlay.h , palmOneLcdOverlayCommon.h
  • kLcdOverlayLibTrapGetVersion : PalmLcdOverlay.h , palmOneLcdOverlayCommon.h
  • kLcdOverlayLibType : palmOneLcdOverlayCommon.h , PalmLcdOverlay.h
  • kLcdOverlayLibVersion : PalmLcdOverlay.h , palmOneLcdOverlayCommon.h
  • kLcdOverlayLibVersion1 : palmOneLcdOverlayCommon.h , PalmLcdOverlay.h
  • kLFlipSmiley : SmartTextEngineDef.h
  • kLineNumberUnknown : HsPhoneGSMTypes.h
  • kLineStateVersion : HsPhoneMiscTypes.h
  • kLocDBMaxLocNameLength : LocsLibCommon.h
  • kLocDBTypeCustom : LocsLibCommon.h
  • kLocDBTypeDefault : LocsLibCommon.h
  • kLocDBVersion : LocsLibCommon.h
  • kLocDisplayInCustom : LocsLibCommon.h
  • kLocFileCDatabase : LocsLibCommon.h
  • kLocFileNCustomDB : LocsLibCommon.h
  • kLocFileNDefaultDB : LocsLibCommon.h
  • kLocFileTCusLocDB : LocsLibCommon.h
  • kLocFileTDefLocDB : LocsLibCommon.h
  • kLocNameMaxLength : LocsLibCommon.h
  • kLocNoDisplayInCustom : LocsLibCommon.h
  • kLocNoteMaxLength : LocsLibCommon.h
  • kLocsFileCLocsLib : LocsLibCommon.h
  • kLocsLibDSTAlert : LocsLibCommon.h
  • kLocsLibDSTEndAlert : LocsLibCommon.h
  • kLocsLibDSTStartAlert : LocsLibCommon.h
  • kLocsLibFtrNumRefNum : LocsLibCommon.h
  • kLocsLibListUpdate : LocsLibCommon.h
  • kLocsLibListUpdateClass : LocsLibCommon.h
  • kLocsLibName : LocsLibCommon.h
  • kLocsLibNotifyLocAddEvent : LocsLibCommon.h
  • kLocsLibNotifyLocChangeEvent : LocsLibCommon.h
  • kLocsLibNotifyLocDeleteEvent : LocsLibCommon.h
  • kLocsLibNotifyLocEditEvent : LocsLibCommon.h
  • kLocsLibSel01 : LocsLibCommon.h
  • kLocsLibSel02 : LocsLibCommon.h
  • kLocsLibSel03 : LocsLibCommon.h
  • kLocsLibSel04 : LocsLibCommon.h
  • kLocsLibSel05 : LocsLibCommon.h
  • kLocsLibSel06 : LocsLibCommon.h
  • kLocsLibSel07 : LocsLibCommon.h
  • kLocsLibSel08 : LocsLibCommon.h
  • kLocsLibSel09 : LocsLibCommon.h
  • kLocsLibSelMax : LocsLibCommon.h
  • kLocsLibVersion01 : LocsLibCommon.h
  • kLocsLibVersion0121 : LocsLibCommon.h
  • kLocsLibVersion013 : LocsLibCommon.h
  • kLocsLibVersionCurrent : LocsLibCommon.h
  • kMaxImeiLen : HsPhoneNetworkTypes.h
  • kMaxMMISequenceLen : HsPhoneNetworkTypes.h
  • kMaxPhnEvtSupported : HsPhoneEvent.h
  • kMaxPhoneNumberLen : HsPhoneNetworkTypes.h
  • kMaxTonesNameSize : TonesLibTypes.h
  • kMaxVPNAccountNameLength : PalmVPPI.h
  • kMaxWiFiAuthenticationMethodNameLength : PalmWPPI.h
  • kMaxWiFiCredentialsLabelLength : PalmWPPI.h
  • kMaxWiFiCredentialsSelectorTriggerLength : PalmWPPI.h
  • kMissingPart : HsPhoneSMSTypes.h
  • kMMSPixPlaceMaxLen : HsPhoneSMSTypes.h
  • kMMSStringMaxLen : HsPhoneSMSTypes.h
  • kMsgIdcancelMO : HsPhoneEvent.h
  • kMsgIdDeliverMT : HsPhoneEvent.h
  • kMsgIdDeliveryMTAck : HsPhoneEvent.h
  • kMsgIdReserved : HsPhoneEvent.h
  • kMsgIdSubmitMO : HsPhoneEvent.h
  • kMsgIdUserAck : HsPhoneEvent.h
  • kMTIncoming : HsPhoneSMSTypes.h
  • kMTOutgoing : HsPhoneSMSTypes.h
  • kName : HsPhoneSMSTypes.h
  • kNetDriverDateLength : PalmNetServices.h
  • kNetFWNameLength : PalmNetServices.h
  • kNetSerialNumberLength : PalmNetServices.h
  • kNetworkListDBName : CarrierCustomLibTypes.h
  • kNone : HsPhoneSMSTypes.h
  • kNoSortOrder : ImageLibCommon.h
  • kNote : HsPhoneSMSTypes.h
  • kNotification : HsPhoneSMSTypes.h
  • kOmegaCharacter : SmartTextEngineDef.h
  • kOMouthSmiley : SmartTextEngineDef.h
  • kOpenDialog : HsPhoneEvent.h
  • kPalmAudioPlaybackActionCodeRequestResume : PalmAudioPlayback.h
  • kPalmAudioPlaybackActionCodeRequestStop : PalmAudioPlayback.h
  • kPalmAudioPlaybackCreator : PalmAudioPlayback.h
  • kPalmAudioPlaybackNotify1 : PalmAudioPlayback.h
  • kPalmAudioPlaybackNotifyEvent : PalmAudioPlayback.h
  • kPalmAudioPlaybackNotifyVersion : PalmAudioPlayback.h
  • kPalmCompanyIDHandspring : palmOneResources.h
  • kPalmCompanyIDOldPalm : palmOneResources.h
  • kPalmCompanyIDPalm : palmOneResources.h
  • kPalmCreatorIDLcdState : palmOneCreators.h
  • kPalmCreatorIDNetSlipHack : palmOneCreators.h
  • kPalmDeviceIDTX : palmOneResources.h
  • kPalmDeviceIDZ22 : palmOneResources.h
  • kPalmLedCreator : PalmLED.h
  • kPalmLedModule : PalmLED.h
  • kPalmLedName : PalmLED.h
  • kPalmLedTrapGetAttributes : PalmLED.h
  • kPalmLedTrapSetAttributes : PalmLED.h
  • kPalmLedType : PalmLED.h
  • kPalmLedVersion : PalmLED.h
  • kPalmLedVersion1 : PalmLED.h
  • kPalmOneCreatorIDCalendar : palmOneCreators.h
  • kPalmOneCreatorIDContacts : palmOneCreators.h
  • kPalmOneCreatorIDFavorites : palmOneCreators.h
  • kPalmOneCreatorIDFileBrowser : palmOneCreators.h
  • kPalmOneCreatorIDMemos : palmOneCreators.h
  • kPalmOneCreatorIDNotePad : palmOneCreators.h
  • kPalmOneCreatorIDTasks : palmOneCreators.h
  • kPalmOneCreatorIDVoiceMemo : palmOneCreators.h
  • kPalmOneDeviceIDAngus : palmOneResources.h
  • kPalmOneDeviceIDDevice3 : palmOneResources.h
  • kPalmOneDeviceIDDevice4 : palmOneResources.h
  • kPalmOneDeviceIDDevice5 : palmOneResources.h
  • kPalmOneDeviceIDDevice6 : palmOneResources.h
  • kPalmOneDeviceIDDevice7 : palmOneResources.h
  • kPalmOneDeviceIDDevice8 : palmOneResources.h
  • kPalmOneDeviceIDDevice9 : palmOneResources.h
  • kPalmOneDeviceIDDeviceA : palmOneResources.h
  • kPalmOneDeviceIDGandalf : palmOneResources.h
  • kPalmOneDeviceIDGnome : palmOneResources.h
  • kPalmOneDeviceIDLowrider : palmOneResources.h
  • kPalmOneDeviceIDTorino : palmOneResources.h
  • kPalmOneDeviceIDTreo600 : palmOneResources.h
  • kPalmOneDeviceIDTreo600Sim : palmOneResources.h
  • kPalmOneDeviceIDTreo650 : palmOneResources.h
  • kPalmOneDeviceIDTreo650Sim : palmOneResources.h
  • kPalmOneDeviceIDTungstenC : palmOneResources.h
  • kPalmOneDeviceIDTungstenE2 : palmOneResources.h
  • kPalmOneDeviceIDTungstenT : palmOneResources.h
  • kPalmOneDeviceIDTungstenT2 : palmOneResources.h
  • kPalmOneDeviceIDTungstenT3 : palmOneResources.h
  • kPalmOneDeviceIDTungstenT5 : palmOneResources.h
  • kPalmOneDeviceIDTungstenTE : palmOneResources.h
  • kPalmOneDeviceIDTungstenW : palmOneResources.h
  • kPalmOneDeviceIDTungstenX : palmOneResources.h
  • kPalmOneDeviceIDVentura : palmOneResources.h
  • kPalmOneDeviceIDZire : palmOneResources.h
  • kPalmOneDeviceIDZire21 : palmOneResources.h
  • kPalmOneDeviceIDZire31 : palmOneResources.h
  • kPalmOneDeviceIDZire71 : palmOneResources.h
  • kPalmOneDeviceIDZire72 : palmOneResources.h
  • kPalmOneStatusBarMgrLibGetAttribute : palmOneStatusBar.h
  • kPalmOneStatusBarMgrLibHide : palmOneStatusBar.h
  • kPalmOneStatusBarMgrLibShow : palmOneStatusBar.h
  • kPalmOneStatusBarMgrLibTrapClose : palmOneStatusBar.h
  • kPalmOneStatusBarMgrLibTrapOpen : palmOneStatusBar.h
  • kPalmPhotoLibVersion : palmOnePhotoCommon.h
  • kPalmPhotoLibVersion1 : palmOnePhotoCommon.h
  • kPalmPhotoLibVersion2 : palmOnePhotoCommon.h
  • kPalmPhotoLibVersion3 : palmOnePhotoCommon.h
  • kPalmSizeImageHeight : ImageLibCommon.h
  • kPalmSizeImageWidth : ImageLibCommon.h
  • kParsedDeviceURL : SmartTextEngineDef.h
  • kParsedEmail : SmartTextEngineDef.h
  • kParsedPhoneNumber : SmartTextEngineDef.h
  • kParsedRtspURL : SmartTextEngineDef.h
  • kParsedURL : SmartTextEngineDef.h
  • kParseError : HsPhoneSMSTypes.h
  • kParseInformationData : HsPhoneSMSTypes.h
  • kParseInformationID : HsPhoneSMSTypes.h
  • kParseInformationLength : HsPhoneSMSTypes.h
  • kPending : HsPhoneSMSTypes.h
  • kPhiCharacter : SmartTextEngineDef.h
  • kPhone1 : HsPhoneSMSTypes.h
  • kPhone2 : HsPhoneSMSTypes.h
  • kPhone3 : HsPhoneSMSTypes.h
  • kPhone4 : HsPhoneSMSTypes.h
  • kPhone5 : HsPhoneSMSTypes.h
  • kPiCharacter : SmartTextEngineDef.h
  • kPinLibTrapClose : PalmPin.h
  • kPinLibTrapOpen : PalmPin.h
  • kPinLibTrapPinGetCurrentPinletID : PalmPin.h
  • kPinLibTrapPinGetInputAreaState : PalmPin.h
  • kPinLibTrapPinGetInputMode : PalmPin.h
  • kPinLibTrapPinResetInputState : PalmPin.h
  • kPinLibTrapPinSetInputAreaState : PalmPin.h
  • kPinLibTrapPinSetInputMode : PalmPin.h
  • kPinLibTrapPINShowReferenceDialog : PalmPin.h
  • kPinLibTrapPinSwitchToPinlet : PalmPin.h
  • kPmConnectorClassAudioNoHeadset : PmConnectorLibCommon.h
  • kPmConnectorClassAudioWHeadset : PmConnectorLibCommon.h
  • kPmConnectorClassCarkit : PmConnectorLibCommon.h
  • kPmConnectorClassGenericSerial : PmConnectorLibCommon.h
  • kPmConnectorClassMask : PmConnectorLibCommon.h
  • kPmConnectorClassNoDevice : PmConnectorLibCommon.h
  • kPmConnectorClassSerial : PmConnectorLibCommon.h
  • kPmConnectorClassSmartSerial : PmConnectorLibCommon.h
  • kPmConnectorClassUnknown : PmConnectorLibCommon.h
  • kPmConnectorClassUSB : PmConnectorLibCommon.h
  • kPmConnectorDeviceAttach : PmConnectorLibCommon.h
  • kPmConnectorDeviceDetach : PmConnectorLibCommon.h
  • kPmConnectorLibCreator : PmConnectorLibCommon.h
  • kPmConnectorLibCtrlGetDeviceClass : PmConnectorLibCommon.h
  • kPmConnectorLibCtrlPowerOff : PmConnectorLibCommon.h
  • kPmConnectorLibCtrlPowerOn : PmConnectorLibCommon.h
  • kPmConnectorLibErrBadParam : PmConnectorLibCommon.h
  • kPmConnectorLibErrInternal : PmConnectorLibCommon.h
  • kPmConnectorLibErrNoMemory : PmConnectorLibCommon.h
  • kPmConnectorLibErrNotCompatible : PmConnectorLibCommon.h
  • kPmConnectorLibErrNotOpen : PmConnectorLibCommon.h
  • kPmConnectorLibErrNotSupported : PmConnectorLibCommon.h
  • kPmConnectorLibErrorClass : PmConnectorLibCommon.h
  • kPmConnectorLibErrStillOpen : PmConnectorLibCommon.h
  • kPmConnectorLibName : PmConnectorLibCommon.h
  • kPmConnectorLibTrapClose : PmConnectorLibCommon.h
  • kPmConnectorLibTrapControl : PmConnectorLibCommon.h
  • kPmConnectorLibTrapGetVersion : PmConnectorLibCommon.h
  • kPmConnectorLibTrapOpen : PmConnectorLibCommon.h
  • kPmConnectorLibTrapSetAudioInput : PmConnectorLibCommon.h
  • kPmConnectorLibTrapSetAudioOutput : PmConnectorLibCommon.h
  • kPmConnectorLibTrapSleep : PmConnectorLibCommon.h
  • kPmConnectorLibTrapWake : PmConnectorLibCommon.h
  • kPmConnectorLibType : PmConnectorLibCommon.h
  • kPmConnectorLibVersion : PmConnectorLibCommon.h
  • kPmConnectorNotifySysAttach : PmConnectorLibCommon.h
  • kPmConnectorNotifySysDetach : PmConnectorLibCommon.h
  • kPmConnectorNotifyType : PmConnectorLibCommon.h
  • kPmDockStatusCharging : PmConnectorLibCommon.h
  • kPmDockStatusSerialPeripheral : PmConnectorLibCommon.h
  • kPmDockStatusUSBCradle : PmConnectorLibCommon.h
  • kPmKeyLibAPIMajorVersion : PmKeyLibCommon.h
  • kPmKeyLibAPIMinorVersion : PmKeyLibCommon.h
  • kPmKeyLibAPIVersion : PmKeyLibCommon.h
  • kPmKeyLibCreator : PmKeyLibCommon.h
  • kPmKeyLibFtrValAPIVersion : PmKeyLibCommon.h
  • kPmKeyLibName : PmKeyLibCommon.h
  • kPmKeyLibTrapAttrGet : PmKeyLibCommon.h
  • kPmKeyLibTrapAttrSet : PmKeyLibCommon.h
  • kPmKeyLibTrapChrCodeToKeyCode : PmKeyLibCommon.h
  • kPmKeyLibTrapClose : PmKeyLibCommon.h
  • kPmKeyLibTrapEnableKey : PmKeyLibCommon.h
  • kPmKeyLibTrapEventIsFromKeyboard : PmKeyLibCommon.h
  • kPmKeyLibTrapKeyCodeToChrCode : PmKeyLibCommon.h
  • kPmKeyLibTrapKeysPressed : PmKeyLibCommon.h
  • kPmKeyLibTrapOpen : PmKeyLibCommon.h
  • kPmKeyLibTrapStop : PmKeyLibCommon.h
  • kPmKeyLibType : PmKeyLibCommon.h
  • kPmSoundLibTrapClkGetTickCount : HsSoundLibTraps.h
  • kPmSoundLibTrapClkGetTicksPerSecond : HsSoundLibTraps.h
  • kPmSoundLibTrapGetPosition : HsSoundLibTraps.h
  • kPmSoundLibTrapReserved : HsSoundLibTraps.h
  • kPmSysGadgetBbutFlagNoBackground : PmSysGadgetLibBbutRscCommon.h
  • kPmSysGadgetBbutFlagNoBorder : PmSysGadgetLibBbutRscCommon.h
  • kPmSysGadgetBbutFlagNoBorderOrBackground : PmSysGadgetLibBbutRscCommon.h
  • kPmSysGadgetBbutFlagNone : PmSysGadgetLibBbutRscCommon.h
  • kPmSysGadgetBbutFontBold : PmSysGadgetLibBbutRscCommon.h
  • kPmSysGadgetBbutFontLarge : PmSysGadgetLibBbutRscCommon.h
  • kPmSysGadgetBbutFontLargeBold : PmSysGadgetLibBbutRscCommon.h
  • kPmSysGadgetBbutFontLed : PmSysGadgetLibBbutRscCommon.h
  • kPmSysGadgetBbutFontStd : PmSysGadgetLibBbutRscCommon.h
  • kPmSysGadgetBbutFontSymbol : PmSysGadgetLibBbutRscCommon.h
  • kPmSysGadgetBbutFontSymbol11 : PmSysGadgetLibBbutRscCommon.h
  • kPmSysGadgetBbutFontSymbol7 : PmSysGadgetLibBbutRscCommon.h
  • kPmSysGadgetBbutGadgetMiscSelectData : PmSysGadgetLibCommon.h
  • kPmSysGadgetBbutGadgetMiscSelectSelector : PmSysGadgetLibCommon.h
  • kPmSysGadgetBbutMappingVersion0 : PmSysGadgetLibBbutRscCommon.h
  • kPmSysGadgetBbutRscType : PmSysGadgetLibCommon.h
  • kPmSysGadgetFtrIDStatusGadgetRev : PmSysGadgetLibCommon.h
  • kPmSysGadgetFtrValStatusGadgetRev1 : PmSysGadgetLibCommon.h
  • kPmSysGadgetLibCreator : PmSysGadgetLibCommon.h
  • kPmSysGadgetLibName : PmSysGadgetLibCommon.h
  • kPmSysGadgetLibTrapBbutHitBigButton : PmSysGadgetLibCommon.h
  • kPmSysGadgetLibTrapBbutInstallFromResource : PmSysGadgetLibCommon.h
  • kPmSysGadgetLibTrapBbutInstallNewButton : PmSysGadgetLibCommon.h
  • kPmSysGadgetLibTrapBbutSetBitmap : PmSysGadgetLibCommon.h
  • kPmSysGadgetLibTrapBbutSetLabel : PmSysGadgetLibCommon.h
  • kPmSysGadgetLibTrapClose : PmSysGadgetLibCommon.h
  • kPmSysGadgetLibTrapOpen : PmSysGadgetLibCommon.h
  • kPmSysGadgetLibTrapStatusGadgetsUpdate : PmSysGadgetLibCommon.h
  • kPmSysGadgetLibTrapStatusGadgetTypeSet : PmSysGadgetLibCommon.h
  • kPmSysGadgetLibType : PmSysGadgetLibCommon.h
  • kPmUIUtilLibAPIMajorVersion : PmUIUtilLibCommon.h
  • kPmUIUtilLibAPIMinorVersion : PmUIUtilLibCommon.h
  • kPmUIUtilLibAPIVersion : PmUIUtilLibCommon.h
  • kPmUIUtilLibCreator : PmUIUtilLibCommon.h
  • kPmUIUtilLibFtrValAPIVersion : PmUIUtilLibCommon.h
  • kPmUIUtilLibName : PmUIUtilLibCommon.h
  • kPmUIUtilLibTrapAttnDiagIsVisible : PmUIUtilLibCommon.h
  • kPmUIUtilLibTrapAttnEnable : PmUIUtilLibCommon.h
  • kPmUIUtilLibTrapAttnGetAttentionExt : PmUIUtilLibCommon.h
  • kPmUIUtilLibTrapAttnIndicatorAllow : PmUIUtilLibCommon.h
  • kPmUIUtilLibTrapAttnNagInfo : PmUIUtilLibCommon.h
  • kPmUIUtilLibTrapAttnUpdateExt : PmUIUtilLibCommon.h
  • kPmUIUtilLibTrapAttrGet : PmUIUtilLibCommon.h
  • kPmUIUtilLibTrapAttrSet : PmUIUtilLibCommon.h
  • kPmUIUtilLibTrapClose : PmUIUtilLibCommon.h
  • kPmUIUtilLibTrapCtlGetFont : PmUIUtilLibCommon.h
  • kPmUIUtilLibTrapCtlGetStyle : PmUIUtilLibCommon.h
  • kPmUIUtilLibTrapFrmDoDialog : PmUIUtilLibCommon.h
  • kPmUIUtilLibTrapFrmDoDialogWithCallback : PmUIUtilLibCommon.h
  • kPmUIUtilLibTrapFrmDoTimedDialogEx : PmUIUtilLibCommon.h
  • kPmUIUtilLibTrapFrmGetDefaultButtonID : PmUIUtilLibCommon.h
  • kPmUIUtilLibTrapFrmGetEventHandler : PmUIUtilLibCommon.h
  • kPmUIUtilLibTrapFrmSetHelpID : PmUIUtilLibCommon.h
  • kPmUIUtilLibTrapFrmSetLabel : PmUIUtilLibCommon.h
  • kPmUIUtilLibTrapFrmSetLabelFont : PmUIUtilLibCommon.h
  • kPmUIUtilLibTrapGetObjectUsable : PmUIUtilLibCommon.h
  • kPmUIUtilLibTrapLstGetItemsText : PmUIUtilLibCommon.h
  • kPmUIUtilLibTrapLstGetTempSelection : PmUIUtilLibCommon.h
  • kPmUIUtilLibTrapLstGetTopItem : PmUIUtilLibCommon.h
  • kPmUIUtilLibTrapLstPopupListExt : PmUIUtilLibCommon.h
  • kPmUIUtilLibTrapLstSetTempSelection : PmUIUtilLibCommon.h
  • kPmUIUtilLibTrapNavGetFocusColor : PmUIUtilLibCommon.h
  • kPmUIUtilLibTrapNavSetFocusColor : PmUIUtilLibCommon.h
  • kPmUIUtilLibTrapOpen : PmUIUtilLibCommon.h
  • kPmUIUtilLibTrapPutObjectAfterTitle : PmUIUtilLibCommon.h
  • kPmUIUtilLibTrapSclScroll : PmUIUtilLibCommon.h
  • kPmUIUtilLibTrapSclScrollPage : PmUIUtilLibCommon.h
  • kPmUIUtilLibTrapSclUpdateScrollBar : PmUIUtilLibCommon.h
  • kPmUIUtilLibTrapSliHandleKeyDown : PmUIUtilLibCommon.h
  • kPmUIUtilLibTrapWinGetMaxDepth : PmUIUtilLibCommon.h
  • kPmUIUtilLibType : PmUIUtilLibCommon.h
  • kPreviewBitmapHeight : ImageLibCommon.h
  • kPreviewBitmapWidth : ImageLibCommon.h
  • kPsiCharacter : SmartTextEngineDef.h
  • kPttNotificationEvent : PmSysGadgetLibCommon.h
  • kPttNotificationStatusOffset : PmSysGadgetLibCommon.h
  • kPukeSmiley : SmartTextEngineDef.h
  • kPwrBatteryStateBroadcaster : PalmPower.h
  • kPwrBatteryStateNotifyEvent : PalmPower.h
  • kQuestionSmiley : SmartTextEngineDef.h
  • kRadioStateVersion : HsPhoneMiscTypes.h
  • kRead : HsPhoneSMSTypes.h
  • kReceived : HsPhoneSMSTypes.h
  • kReceiving : HsPhoneSMSTypes.h
  • kRecordFieldEnumCount : HsPhoneSMSTypes.h
  • kResizeOperation : ImageLibCommon.h
  • kRFlipSmiley : SmartTextEngineDef.h
  • kSATApplicationBusy : HsPhoneGSMTypes.h
  • kSATCancel : HsPhoneGSMTypes.h
  • kSATClearText : HsPhoneGSMTypes.h
  • kSATDataSvc : HsPhoneGSMTypes.h
  • kSATDisplaySubmenus : HsPhoneGSMTypes.h
  • kSATDisplayText : HsPhoneGSMTypes.h
  • kSATEFSimPhoneBook : HsPhoneGSMTypes.h
  • kSATEndSession : HsPhoneGSMTypes.h
  • kSATFileChange : HsPhoneGSMTypes.h
  • kSATGetInkey : HsPhoneGSMTypes.h
  • kSATGetInput : HsPhoneGSMTypes.h
  • kSATHelpRequested : HsPhoneGSMTypes.h
  • kSATIdleModeText : HsPhoneGSMTypes.h
  • kSATInit : HsPhoneGSMTypes.h
  • kSATInitWithFileChange : HsPhoneGSMTypes.h
  • kSATInitWithFullFileChange : HsPhoneGSMTypes.h
  • kSATItemSelected : HsPhoneGSMTypes.h
  • kSATLaunchBrowser : HsPhoneGSMTypes.h
  • kSATMainMenuAvailable : HsPhoneGSMTypes.h
  • kSATMakeCall : HsPhoneGSMTypes.h
  • kSATMax : HsPhoneGSMTypes.h
  • kSATNavigateBack : HsPhoneGSMTypes.h
  • kSATPlayTone : HsPhoneGSMTypes.h
  • kSATRefresh : HsPhoneGSMTypes.h
  • kSATReqDataSrv : HsPhoneGSMTypes.h
  • kSATReqIdleModeText : HsPhoneGSMTypes.h
  • kSATReqLaunchBrowser : HsPhoneGSMTypes.h
  • kSATReqPlayTone : HsPhoneGSMTypes.h
  • kSATReqRefresh : HsPhoneGSMTypes.h
  • kSATReqSendDTMF : HsPhoneGSMTypes.h
  • kSATRunAT : HsPhoneGSMTypes.h
  • kSATSelectItem : HsPhoneGSMTypes.h
  • kSATSelectMainMenuItem : HsPhoneGSMTypes.h
  • kSATSendDTMF : HsPhoneGSMTypes.h
  • kSATSendSMS : HsPhoneGSMTypes.h
  • kSATSendSS : HsPhoneGSMTypes.h
  • kSATSendUSSD : HsPhoneGSMTypes.h
  • kSATSessionAborted : HsPhoneGSMTypes.h
  • kSATSessionEnd : HsPhoneGSMTypes.h
  • kSATSetInkey : HsPhoneGSMTypes.h
  • kSATSetInput : HsPhoneGSMTypes.h
  • kSATSetupCall : HsPhoneGSMTypes.h
  • kSATSetupCallDisconnectOtherCalls : HsPhoneGSMTypes.h
  • kSATSetupCallHoldOtherCalls : HsPhoneGSMTypes.h
  • kSATSetupCallMax : HsPhoneGSMTypes.h
  • kSATSetupCallModeNotBusy : HsPhoneGSMTypes.h
  • kSATSetupCallWithRedialDisconnectOtherCalls : HsPhoneGSMTypes.h
  • kSATSetupCallWithRedialHoldOtherCalls : HsPhoneGSMTypes.h
  • kSATSetupCallWithRedialModeNotBusy : HsPhoneGSMTypes.h
  • kSATSIMReset : HsPhoneGSMTypes.h
  • kSATTimeout : HsPhoneGSMTypes.h
  • kSATUnknownNotification : HsPhoneGSMTypes.h
  • kSATUserNotResponse : HsPhoneGSMTypes.h
  • kScrollToEnd : SmartTextEngineDef.h
  • kSelectUntilEnd : SmartTextEngineDef.h
  • kSelectUntilEndOfRecord : SmartTextEngineDef.h
  • kSending : HsPhoneSMSTypes.h
  • kSent : HsPhoneSMSTypes.h
  • kSetRecipient : HsPhoneEvent.h
  • kSetText : HsPhoneEvent.h
  • kShowSegment : HsPhoneEvent.h
  • kSigmaCharacter : SmartTextEngineDef.h
  • kSliderHigh : HsPhoneAudioTypes.h
  • kSliderLow : HsPhoneAudioTypes.h
  • kSliderPositions : HsPhoneAudioTypes.h
  • kSmartTextBit : SmartTextEngineDef.h
  • kSmileSmiley : SmartTextEngineDef.h
  • kSmirkSmiley : SmartTextEngineDef.h
  • kSMSErrorType1 : HsPhoneSMSTypes.h
  • kSMSErrorType2 : HsPhoneSMSTypes.h
  • kSMSErrorType3 : HsPhoneSMSTypes.h
  • kSMSHighPriority : HsPhoneSMSTypes.h
  • kSMSLowPriority : HsPhoneSMSTypes.h
  • kSmsPriorityEmergency : HsPhoneNetworkTypes.h
  • kSmsPriorityInteractive : HsPhoneNetworkTypes.h
  • kSmsPriorityLast : HsPhoneNetworkTypes.h
  • kSmsPriorityNormal : HsPhoneNetworkTypes.h
  • kSmsPriorityUrgent : HsPhoneNetworkTypes.h
  • kSndFileFormatAAC : palmOneSndFileStream.h
  • kSndFileFormatMP3 : palmOneSndFileStream.h
  • kSndFileFormatRaw : palmOneSndFileStream.h
  • kSndFileFormatTreoAMR : palmOneSndFileStream.h
  • kSndFileFormatTreoQCP : palmOneSndFileStream.h
  • kSndFileFormatWAV : palmOneSndFileStream.h
  • kSndFileStreamFileSpecFlagFileStream : palmOneSndFileStream.h
  • kSndFileStreamFileSpecFlagVFS : palmOneSndFileStream.h
  • kSndFileStreamLibCreator : palmOneSndFileStream.h
  • kSndFileStreamLibErrAlreadyOpen : palmOneSndFileStream.h
  • kSndFileStreamLibErrCancel : palmOneSndFileStream.h
  • kSndFileStreamLibErrCantOpenFile : palmOneSndFileStream.h
  • kSndFileStreamLibErrNone : palmOneSndFileStream.h
  • kSndFileStreamLibErrNotOpen : palmOneSndFileStream.h
  • kSndFileStreamLibErrOperationNotSupported : palmOneSndFileStream.h
  • kSndFileStreamLibErrOutOfMemory : palmOneSndFileStream.h
  • kSndFileStreamLibErrStillOpen : palmOneSndFileStream.h
  • kSndFileStreamLibErrUnsupportedFile : palmOneSndFileStream.h
  • kSndFileStreamLibName : palmOneSndFileStream.h
  • kSndFileStreamLibPlaybackForever : palmOneSndFileStream.h
  • kSndFileStreamLibTrapClose : palmOneSndFileStream.h
  • kSndFileStreamLibTrapCreate : palmOneSndFileStream.h
  • kSndFileStreamLibTrapDeviceControl : palmOneSndFileStream.h
  • kSndFileStreamLibTrapGetCurrentStreamData : palmOneSndFileStream.h
  • kSndFileStreamLibTrapGetPan : palmOneSndFileStream.h
  • kSndFileStreamLibTrapGetVolume : palmOneSndFileStream.h
  • kSndFileStreamLibTrapOpen : palmOneSndFileStream.h
  • kSndFileStreamLibTrapPause : palmOneSndFileStream.h
  • kSndFileStreamLibTrapSeek : palmOneSndFileStream.h
  • kSndFileStreamLibTrapSetPan : palmOneSndFileStream.h
  • kSndFileStreamLibTrapSetVolume : palmOneSndFileStream.h
  • kSndFileStreamLibTrapStart : palmOneSndFileStream.h
  • kSndFileStreamLibTrapStop : palmOneSndFileStream.h
  • kSndFileStreamLibTrapUIPlay : palmOneSndFileStream.h
  • kSndFileStreamLibTrapUIRecord : palmOneSndFileStream.h
  • kSndFileStreamLibTrapVersion : palmOneSndFileStream.h
  • kSndFileStreamLibType : palmOneSndFileStream.h
  • kSndFileStreamLibVersion : palmOneSndFileStream.h
  • kSndFileTypeAAC : palmOneSndFileStream.h
  • kSndFileTypeAMR : palmOneSndFileStream.h
  • kSndFileTypeMP3 : palmOneSndFileStream.h
  • kSndFileTypeQCP : palmOneSndFileStream.h
  • kSndFileTypeWAV : palmOneSndFileStream.h
  • kSortByCountryCodeTZName : LocsLibCommon.h
  • kSortByCountryTZName : LocsLibCommon.h
  • kSortByDate : ImageLibCommon.h
  • kSortByDateDesc : ImageLibCommon.h
  • kSortByName : ImageLibCommon.h
  • kSortByNameCountryTZ : LocsLibCommon.h
  • kSortByNameDesc : ImageLibCommon.h
  • kSprintMCCMNC : CarrierCustomLibTypes.h
  • kState : HsPhoneSMSTypes.h
  • kStatusBarMgrLibGetAttribute : PalmStatusBar.h
  • kStatusBarMgrLibHide : PalmStatusBar.h
  • kStatusBarMgrLibShow : PalmStatusBar.h
  • kStatusBarMgrLibTrapClose : PalmStatusBar.h
  • kStatusBarMgrLibTrapOpen : PalmStatusBar.h
  • kStatusReport : HsPhoneSMSTypes.h
  • kSTEBitmap : SmartTextEngineDef.h
  • kSTEBlack : SmartTextEngineDef.h
  • kSTEBlackFont : SmartTextEngineDef.h
  • kSTEBlackInverse : SmartTextEngineDef.h
  • kSTEBlue : SmartTextEngineDef.h
  • kSTEBlueFont : SmartTextEngineDef.h
  • kSTEBlueInverse : SmartTextEngineDef.h
  • kSTEBoldFont : SmartTextEngineDef.h
  • kSTECenterAlign : SmartTextEngineDef.h
  • kSTECharacterBitmap : SmartTextEngineDef.h
  • kSTECurrent : SmartTextEngineDef.h
  • kSTECurrentFont : SmartTextEngineDef.h
  • kSTEGray : SmartTextEngineDef.h
  • kSTEGrayFont : SmartTextEngineDef.h
  • kSTEGrayInverse : SmartTextEngineDef.h
  • kSTEGreen : SmartTextEngineDef.h
  • kSTEGreenFont : SmartTextEngineDef.h
  • kSTEGreenInverse : SmartTextEngineDef.h
  • kSTEHorizontalLine : SmartTextEngineDef.h
  • kSTEHyperlink : SmartTextEngineDef.h
  • kSTELeftIndent : SmartTextEngineDef.h
  • kSTELineBreak : SmartTextEngineDef.h
  • kSTEOrange : SmartTextEngineDef.h
  • kSTEOrangeFont : SmartTextEngineDef.h
  • kSTEOrangeInverse : SmartTextEngineDef.h
  • kSTEPurple : SmartTextEngineDef.h
  • kSTEPurpleFont : SmartTextEngineDef.h
  • kSTEPurpleInverse : SmartTextEngineDef.h
  • kSTERed : SmartTextEngineDef.h
  • kSTERedFont : SmartTextEngineDef.h
  • kSTERedInverse : SmartTextEngineDef.h
  • kSTERightAlign : SmartTextEngineDef.h
  • kSTESmileyBitmap : SmartTextEngineDef.h
  • kSTEStdFont : SmartTextEngineDef.h
  • kSTEYellow : SmartTextEngineDef.h
  • kSTEYellowFont : SmartTextEngineDef.h
  • kSTEYellowInverse : SmartTextEngineDef.h
  • kStraightMouthSmiley : SmartTextEngineDef.h
  • kSubstitution : HsPhoneSMSTypes.h
  • kTextSegments : HsPhoneSMSTypes.h
  • kThetaCharacter : SmartTextEngineDef.h
  • kThumbnailImageHeight : ImageLibCommon.h
  • kThumbnailImageWidth : ImageLibCommon.h
  • kTitle : HsPhoneSMSTypes.h
  • kTonesDialogFlagNonModal : TonesLibTypes.h
  • kTonesLibVersionEscalation : TonesLib.h
  • kTongueSmiley : SmartTextEngineDef.h
  • kUFlipSmiley : SmartTextEngineDef.h
  • kUndefinedPosition : LocsLibCommon.h
  • kUSB500mACharge : palmOneFeatures.h
  • kUSBConsole : palmOneFeatures.h
  • kUSBDriveMode : palmOneFeatures.h
  • kUSBDUN : palmOneFeatures.h
  • kUSBFSClient : palmOneFeatures.h
  • kUSBFSOnTheGo : palmOneFeatures.h
  • kUSBFSOnTheGoMultiDevice : palmOneFeatures.h
  • kUSBHotSync : palmOneFeatures.h
  • kUSBHSClient : palmOneFeatures.h
  • kUSBHSOnTheGo : palmOneFeatures.h
  • kUSBHSOnTheGoMultiDevice : palmOneFeatures.h
  • kUSBLogging : palmOneFeatures.h
  • kUSBMiniConnector : palmOneFeatures.h
  • kUSBMTP : palmOneFeatures.h
  • kUSBMultiConnector : palmOneFeatures.h
  • kUSBTransfer : palmOneFeatures.h
  • kVerizonMCCMNC : CarrierCustomLibTypes.h
  • kVFSOperation : ImageLibCommon.h
  • kWAPAnyApp : HsPhoneEvent.h
  • kWAPContentTypeIOTA : HsPhoneEvent.h
  • kWAPContentTypeMMS : HsPhoneEvent.h
  • kWAPContentTypeMMSText : HsPhoneEvent.h
  • kWAPContentTypeServiceIndicator : HsPhoneEvent.h
  • kWAPContentTypeServiceIndicatorText : HsPhoneEvent.h
  • kWAPContentTypeServiceLoad : HsPhoneEvent.h
  • kWAPContentTypeServiceLoadText : HsPhoneEvent.h
  • kWAPContentTypeUnknown : HsPhoneEvent.h
  • kWAPdocomoImodeMailUa : HsPhoneEvent.h
  • kWAPdocomoImodeMfUa : HsPhoneEvent.h
  • kWAPdocomoImodeMrUa : HsPhoneEvent.h
  • kWAPDrmUa : HsPhoneEvent.h
  • kWAPEmnUa : HsPhoneEvent.h
  • kWAPLocUa : HsPhoneEvent.h
  • kWAPMmsUa : HsPhoneEvent.h
  • kWAPMotorolaBrowserUa : HsPhoneEvent.h
  • kWAPMotorolaLocationUa : HsPhoneEvent.h
  • kWAPMotorolaNowUa : HsPhoneEvent.h
  • kWAPMotorolaOtaprovUa : HsPhoneEvent.h
  • kWAPMotorolaSplashUa : HsPhoneEvent.h
  • kWAPMsg : HsPhoneSMSTypes.h
  • kWAPMsIMclientUa : HsPhoneEvent.h
  • kWAPMsLocalcontentUa : HsPhoneEvent.h
  • kWAPNaiMvswCommand : HsPhoneEvent.h
  • kWAPopenwaveIotaUa : HsPhoneEvent.h
  • kWAPPushSIA : HsPhoneEvent.h
  • kWAPPushSyncml : HsPhoneEvent.h
  • kWAPSyncmlDm : HsPhoneEvent.h
  • kWAPUnused : HsPhoneEvent.h
  • kWAPWmlUa : HsPhoneEvent.h
  • kWAPWtaUa : HsPhoneEvent.h
  • kWAPWvUa : HsPhoneEvent.h
  • kWinkSmiley : SmartTextEngineDef.h
  • kXiCharacter : SmartTextEngineDef.h
  • kYinYangSmiley : SmartTextEngineDef.h
  • kZipCode : HsPhoneSMSTypes.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:38 2008 for Palm API Guide


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- l -

  • Lambda11BitMap : SmartTextEngineRsc.h
  • Lambda14BitMap : SmartTextEngineRsc.h
  • largeFonts : VMFontLibCommon.h
  • LargeSmiley00BitMap : SmartTextEngineRsc.h
  • LargeSmiley01BitMap : SmartTextEngineRsc.h
  • LargeSmiley02BitMap : SmartTextEngineRsc.h
  • LargeSmiley03BitMap : SmartTextEngineRsc.h
  • LargeSmiley04BitMap : SmartTextEngineRsc.h
  • LargeSmiley05BitMap : SmartTextEngineRsc.h
  • LargeSmiley06BitMap : SmartTextEngineRsc.h
  • LargeSmiley07BitMap : SmartTextEngineRsc.h
  • LargeSmiley08BitMap : SmartTextEngineRsc.h
  • LargeSmiley09BitMap : SmartTextEngineRsc.h
  • LargeSmiley10BitMap : SmartTextEngineRsc.h
  • LargeSmiley11BitMap : SmartTextEngineRsc.h
  • LargeSmiley12BitMap : SmartTextEngineRsc.h
  • LargeSmiley13BitMap : SmartTextEngineRsc.h
  • LargeSmiley14BitMap : SmartTextEngineRsc.h
  • LargeSmiley15BitMap : SmartTextEngineRsc.h
  • LargeSmiley16BitMap : SmartTextEngineRsc.h
  • LargeSmiley17BitMap : SmartTextEngineRsc.h
  • LargeSmiley18BitMap : SmartTextEngineRsc.h
  • LargeSmiley19BitMap : SmartTextEngineRsc.h
  • LargeSmiley20BitMap : SmartTextEngineRsc.h
  • LargeSmiley21BitMap : SmartTextEngineRsc.h
  • LargeSmiley22BitMap : SmartTextEngineRsc.h
  • LargeSmiley23BitMap : SmartTextEngineRsc.h
  • LargeSmileyBitMapBaseID : SmartTextEngineRsc.h
  • LaunchWithCommand : HsAppLaunchCmd.h
  • LC : palmOneCodecFormat.h
  • LcdOverlayLibClose() : palmOneLcdOverlay.h , PalmLcdOverlay.h
  • LcdOverlayLibControl() : palmOneLcdOverlay.h , PalmLcdOverlay.h
  • LcdOverlayLibControlType : PalmLcdOverlay.h , palmOneLcdOverlayCommon.h
  • LcdOverlayLibFormatType : PalmLcdOverlay.h , palmOneLcdOverlayCommon.h
  • LcdOverlayLibGetVersion() : palmOneLcdOverlay.h , PalmLcdOverlay.h
  • LcdOverlayLibOpen() : palmOneLcdOverlay.h , PalmLcdOverlay.h
  • LcdOverlayLibSettingType : PalmLcdOverlay.h , palmOneLcdOverlayCommon.h
  • LcdOverlayLibSleep() : PalmLcdOverlay.h
  • LcdOverlayLibWake() : PalmLcdOverlay.h
  • LD : palmOneCodecFormat.h
  • lifeTimeData : HsPhoneTypes.h
  • lifeTimeVoice : HsPhoneTypes.h
  • LocationAreDSTDatesEqual : LocsLibCommon.h
  • LocationCopy() : LocsLib.h
  • LocationCopyV20() : LocsLib.h
  • LocationFinal() : LocsLib.h
  • LocationFinalV20() : LocsLib.h
  • LocationGetCountry : LocsLibCommon.h
  • LocationGetCustom : LocsLibCommon.h
  • LocationGetDSTAdj : LocsLibCommon.h
  • LocationGetDSTEnd : LocsLibCommon.h
  • LocationGetDSTStart : LocsLibCommon.h
  • LocationGetName : LocsLibCommon.h
  • LocationGetReserved : LocsLibCommon.h
  • LocationGetSize() : LocsLib.h
  • LocationGetSizeV20() : LocsLib.h
  • LocationGetUTC : LocsLibCommon.h
  • LocationInit() : LocsLib.h
  • LocationInitV20() : LocsLib.h
  • LocationIsDSTPast() : LocsLib.h
  • LocationMakeGeneric() : LocsLib.h
  • LocationSetCountry : LocsLibCommon.h
  • LocationSetCustom : LocsLibCommon.h
  • LocationSetDSTAdj : LocsLibCommon.h
  • LocationSetDSTEnd : LocsLibCommon.h
  • LocationSetDSTStart : LocsLibCommon.h
  • LocationSetName() : LocsLib.h
  • LocationSetNote() : LocsLib.h
  • LocationSetPosition() : LocsLib.h
  • LocationSetReserved : LocsLibCommon.h
  • LocationSetUTC : LocsLibCommon.h
  • LocationType : LocsLibCommon.h
  • LocDBChangeRecord() : LocsLib.h
  • LocDBChangeRecordV20() : LocsLib.h
  • LocDBCompareCountries : LocsLibCommon.h
  • LocDBCompareNames : LocsLibCommon.h
  • LocDBCompareRecordsSimple() : LocsLib.h
  • LocDBCompareUTC : LocsLibCommon.h
  • LocDBConvertRecord() : LocsLib.h
  • LocDBConvertRecordV20() : LocsLib.h
  • LocDBCopyLocation() : LocsLib.h
  • LocDBDeleteRecord() : LocsLib.h
  • LocDBFindCustomRecord() : LocsLib.h
  • LocDBFindCustomRecordV20() : LocsLib.h
  • LocDBFindFirst() : LocsLib.h
  • LocDBFindFirstByName() : LocsLib.h
  • LocDBFindFirstByUTCCountry() : LocsLib.h
  • LocDBFindFirstInList() : LocsLib.h
  • LocDBGetCountry : LocsLibCommon.h
  • LocDBGetCustomList() : LocsLib.h
  • LocDBGetNearestLocation() : LocsLib.h
  • LocDBGetRecord() : LocsLib.h
  • LocDBGetRecordList() : LocsLib.h
  • LocDBGetRecordListV20() : LocsLib.h
  • LocDBGetRecordV20() : LocsLib.h
  • LocDBGetUTC : LocsLibCommon.h
  • LocDBGetVersion() : LocsLib.h
  • LocDBInfoType : LocsLibCommon.h
  • LocDBInitDBs() : LocsLib.h
  • LocDBNewRecord() : LocsLib.h
  • LocDBNewRecordV20() : LocsLib.h
  • LocDBOpenCustom() : LocsLib.h
  • LocDBOpenDefault() : LocsLib.h
  • LocDBRecordSize() : LocsLib.h
  • LocDBRecordType : LocsLibCommon.h
  • LocDBSetRecordCustom() : LocsLib.h
  • LocDBSort() : LocsLib.h
  • LocDBSortOrderType : LocsLibCommon.h
  • locLErrBadParam : LocsLibCommon.h
  • locLErrBadRefNum : LocsLibCommon.h
  • locLErrBadVersion : LocsLibCommon.h
  • locLErrCantFindLocsDB : LocsLibCommon.h
  • locLErrCantOpenLibRsc : LocsLibCommon.h
  • locLErrMemAllocFail : LocsLibCommon.h
  • locLErrNoGlobals : LocsLibCommon.h
  • locLErrNoLibSysReference : LocsLibCommon.h
  • locLErrNoMemForGlobals : LocsLibCommon.h
  • locLErrNone : LocsLibCommon.h
  • locLErrNotOpen : LocsLibCommon.h
  • locLErrorClass : LocsLibCommon.h
  • locLErrStillOpen : LocsLibCommon.h
  • LocsLibClose() : LocsLib.h
  • LocsLibDSTAlarmClear() : LocsLib.h
  • LocsLibDSTAlarmIsDST() : LocsLib.h
  • LocsLibDSTAlarmSet() : LocsLib.h
  • LocsLibGetVersion() : LocsLib.h
  • LocsLibLaunchEditListDialogue() : LocsLib.h
  • LocsLibLaunchSelDialogue() : LocsLib.h
  • LocsLibLocationNote() : LocsLib.h
  • LocsLibNotifyDataType : LocsLibCommon.h
  • LocsLibNotifyLocsDataType : LocsLibCommon.h
  • LocsLibOpen() : LocsLib.h
  • LocsLibSelLocsType : LocsLibCommon.h
  • LocsLibSleep() : LocsLib.h
  • locsLibTrapDBChangeRecord : LocsLibCommon.h
  • locsLibTrapDBCmpRecordsSimple : LocsLibCommon.h
  • locsLibTrapDBConvertRecord : LocsLibCommon.h
  • locsLibTrapDBCopyLocation : LocsLibCommon.h
  • locsLibTrapDBDeleteRecord : LocsLibCommon.h
  • locsLibTrapDBFindCustomRecord : LocsLibCommon.h
  • locsLibTrapDBFindFirst : LocsLibCommon.h
  • locsLibTrapDBFindFirstByName : LocsLibCommon.h
  • locsLibTrapDBFindFirstByUTCCtry : LocsLibCommon.h
  • locsLibTrapDBFindFirstInList : LocsLibCommon.h
  • locsLibTrapDBGetCustomList : LocsLibCommon.h
  • locsLibTrapDBGetRecord : LocsLibCommon.h
  • locsLibTrapDBGetRecordList : LocsLibCommon.h
  • locsLibTrapDBInitDBs : LocsLibCommon.h
  • locsLibTrapDBNewRecord : LocsLibCommon.h
  • locsLibTrapDBOpenCustom : LocsLibCommon.h
  • locsLibTrapDBOpenDefault : LocsLibCommon.h
  • locsLibTrapDBRecordSize : LocsLibCommon.h
  • locsLibTrapDBSetRecordCustom : LocsLibCommon.h
  • locsLibTrapDBSort : LocsLibCommon.h
  • locsLibTrapDSTAlarmClear : LocsLibCommon.h
  • locsLibTrapDSTAlarmIsDST : LocsLibCommon.h
  • locsLibTrapDSTAlarmSet : LocsLibCommon.h
  • locsLibTrapGetVersion : LocsLibCommon.h
  • locsLibTrapLaunchEditListDlg : LocsLibCommon.h
  • locsLibTrapLaunchSelDialogue : LocsLibCommon.h
  • locsLibTrapLocationCopyV20 : LocsLibCommon.h
  • locsLibTrapLocationFinalV20 : LocsLibCommon.h
  • locsLibTrapLocationGetSizeV20 : LocsLibCommon.h
  • locsLibTrapLocationInitV20 : LocsLibCommon.h
  • locsLibTrapLocationSetNote : LocsLibCommon.h
  • locsLibTrapLocationSetPosition : LocsLibCommon.h
  • locsLibTrapLocCopy : LocsLibCommon.h
  • locsLibTrapLocDBChangeRecordV20 : LocsLibCommon.h
  • locsLibTrapLocDBConvertRecordV20 : LocsLibCommon.h
  • locsLibTrapLocDBFindCustomRecordV20 : LocsLibCommon.h
  • locsLibTrapLocDBGetNearestLocation : LocsLibCommon.h
  • locsLibTrapLocDBGetRecordListV20 : LocsLibCommon.h
  • locsLibTrapLocDBGetRecordV20 : LocsLibCommon.h
  • locsLibTrapLocDBGetVersion : LocsLibCommon.h
  • locsLibTrapLocDBNewRecordV20 : LocsLibCommon.h
  • locsLibTrapLocFinal : LocsLibCommon.h
  • locsLibTrapLocGetSize : LocsLibCommon.h
  • locsLibTrapLocInit : LocsLibCommon.h
  • locsLibTrapLocIsDSTPast : LocsLibCommon.h
  • locsLibTrapLocMakeGeneric : LocsLibCommon.h
  • locsLibTrapLocSetName : LocsLibCommon.h
  • locsLibTrapLocsLibLocationNote : LocsLibCommon.h
  • LocsLibWake() : LocsLib.h
  • LONG_PREAMBLE : PalmWiFiCommon.h
  • LTP : palmOneCodecFormat.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:38 2008 for Palm API Guide


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- m -

  • MAIN : palmOneCodecFormat.h
  • MAX_ACTIVE_PROFILES : PalmNetServices.h
  • MAX_LONGOPERATORNAME_LENGTH : HsPhoneNetworkTypes.h
  • MAX_PLANE_COUNT : palmOneCodecFormat.h
  • MAX_SHORTOPERATORNAME_LENGTH : HsPhoneNetworkTypes.h
  • maxDB4ecioLevel0 : HsPhoneTypes.h
  • maxDB4ecioLevel1 : HsPhoneTypes.h
  • maxDB4ecioLevel2 : HsPhoneTypes.h
  • maxDB4ecioLevel3 : HsPhoneTypes.h
  • maxDBm4signalLevel0 : HsPhoneTypes.h
  • maxDBm4signalLevel1 : HsPhoneTypes.h
  • maxDBm4signalLevel2 : HsPhoneTypes.h
  • maxDBm4signalLevel3 : HsPhoneTypes.h
  • maxPasswordLen : HsPhoneNetworkTypes.h
  • maxPasswordLenCDMA : HsPhoneNetworkTypes.h
  • Minimum16bitTextHeader : HsPhoneSMSTypes.h
  • Minimum8bitTextHeader : HsPhoneSMSTypes.h
  • minPasswordLen : HsPhoneNetworkTypes.h
  • MM_MAX_ATTACHMENTS : PalmVMLaunch.h
  • mmiActionActivate : HsPhoneNetworkTypes.h
  • mmiActionDeactivate : HsPhoneNetworkTypes.h
  • mmiActionErasure : HsPhoneNetworkTypes.h
  • mmiActionHandspring : HsPhoneNetworkTypes.h
  • mmiActionInterrogate : HsPhoneNetworkTypes.h
  • mmiActionNoAction : HsPhoneNetworkTypes.h
  • mmiActionRegister : HsPhoneNetworkTypes.h
  • mmiActionUnlock : HsPhoneNetworkTypes.h
  • mmiControlActivateCallx : HsPhoneNetworkTypes.h
  • mmiControlConference : HsPhoneNetworkTypes.h
  • mmiControlReleaseAllActive : HsPhoneNetworkTypes.h
  • mmiControlReleaseAllHeld : HsPhoneNetworkTypes.h
  • mmiControlReleaseCallx : HsPhoneNetworkTypes.h
  • mmiControlSwap : HsPhoneNetworkTypes.h
  • mmiControlTransfer : HsPhoneNetworkTypes.h
  • mmiServiceAllBarringServ : HsPhoneNetworkTypes.h
  • mmiServiceAllInBarringServ : HsPhoneNetworkTypes.h
  • mmiServiceAllOutBarringServ : HsPhoneNetworkTypes.h
  • mmiServiceBAIC : HsPhoneNetworkTypes.h
  • mmiServiceBAICR : HsPhoneNetworkTypes.h
  • mmiServiceBAOC : HsPhoneNetworkTypes.h
  • mmiServiceBAOIC : HsPhoneNetworkTypes.h
  • mmiServiceBAOICX : HsPhoneNetworkTypes.h
  • mmiServiceCallControl : HsPhoneNetworkTypes.h
  • mmiServiceCallerId : HsPhoneNetworkTypes.h
  • mmiServiceCallWaiting : HsPhoneNetworkTypes.h
  • mmiServiceChangeBarPwd : HsPhoneNetworkTypes.h
  • mmiServiceChangePIN : HsPhoneNetworkTypes.h
  • mmiServiceChangePIN2 : HsPhoneNetworkTypes.h
  • mmiServiceCOLP : HsPhoneNetworkTypes.h
  • mmiServiceCOLR : HsPhoneNetworkTypes.h
  • mmiServiceForwardAll : HsPhoneNetworkTypes.h
  • mmiServiceForwardBusy : HsPhoneNetworkTypes.h
  • mmiServiceForwardConditionalAll : HsPhoneNetworkTypes.h
  • mmiServiceForwardNoReply : HsPhoneNetworkTypes.h
  • mmiServiceForwardNotReachable : HsPhoneNetworkTypes.h
  • mmiServiceForwardUnconditional : HsPhoneNetworkTypes.h
  • mmiServiceIMEI : HsPhoneNetworkTypes.h
  • mmiServiceInvalid : HsPhoneNetworkTypes.h
  • mmiServiceNNN : HsPhoneNetworkTypes.h
  • mmiServiceNumberSent : HsPhoneNetworkTypes.h
  • mmiServicePhoneNumber : HsPhoneNetworkTypes.h
  • mmiServiceSelectorOperatorLock : HsPhoneNetworkTypes.h
  • mmiServiceSelectorProviderLock : HsPhoneNetworkTypes.h
  • mmiServiceUnimplemented : HsPhoneNetworkTypes.h
  • mmiServiceUnlockPIN : HsPhoneNetworkTypes.h
  • mmiServiceUnlockPIN2 : HsPhoneNetworkTypes.h
  • mmiServiceUSSD : HsPhoneNetworkTypes.h
  • MMPRO_ADD_MESSAGE_WITH_ATTACHMENT : PalmVMLaunch.h
  • MMPRO_LAUNCH_CODE : PalmVMLaunch.h
  • MMPRO_PLUGIN_EXTENDED_QUERY_LAUNCHCODE : PalmVMPlugin.h
  • MMPRO_PLUGIN_GET_INFO_LAUNCHCODE : PalmVMPlugin.h
  • MMPRO_PLUGIN_LAUNCHCODE : PalmVMPlugin.h
  • MMPRO_PLUGIN_QUERY_LAUNCHCODE : PalmVMPlugin.h
  • MMPRO_PLUGIN_RECEIVE_LAUNCHCODE : PalmVMPlugin.h
  • MMPRO_PLUGIN_SEND_LAUNCHCODE : PalmVMPlugin.h
  • MVNONAME_LENGTH : CarrierCustomLib.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:38 2008 for Palm API Guide


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- n -

  • NAITextLength : HsPhoneEvent.h
  • NAITextSize : HsPhoneEvent.h
  • NATIVE_CODE : PalmNative.h
  • navBitDown : common/system/palmOneNavigator.h
  • navBitLeft : common/system/palmOneNavigator.h
  • navBitRight : common/system/palmOneNavigator.h
  • navBitsAll : common/system/palmOneNavigator.h
  • navBitSelect : common/system/palmOneNavigator.h
  • navBitUp : common/system/palmOneNavigator.h
  • navChangeBitsAll : common/system/palmOneNavigator.h
  • navChangeDown : common/system/palmOneNavigator.h
  • navChangeLeft : common/system/palmOneNavigator.h
  • navChangeRight : common/system/palmOneNavigator.h
  • navChangeSelect : common/system/palmOneNavigator.h
  • navChangeUp : common/system/palmOneNavigator.h
  • NavDirectionHSPressed : common/system/palmOneNavigator.h
  • NavDirectionPalmPressed : common/system/palmOneNavigator.h
  • NavDirectionPressed : common/system/palmOneNavigator.h
  • navFtrCreator : common/system/palmOneNavigator.h
  • navFtrVersion : common/system/palmOneNavigator.h
  • NavKeyPressed : common/system/palmOneNavigator.h
  • NavSelectHSPressed : common/system/palmOneNavigator.h
  • NavSelectorFrmCountObjectsInNavOrder : HsNavCommon.h
  • NavSelectorFrmGetNavEntry : HsNavCommon.h
  • NavSelectorFrmGetNavOrder : HsNavCommon.h
  • NavSelectorFrmGetNavState : HsNavCommon.h
  • NavSelectorFrmNavDrawFocusRing : HsNavCommon.h
  • NavSelectorFrmNavGetFocusRingInfo : HsNavCommon.h
  • NavSelectorFrmNavObjectTakeFocus : HsNavCommon.h
  • NavSelectorFrmNavRemoveFocusRing : HsNavCommon.h
  • NavSelectorFrmSetNavEntry : HsNavCommon.h
  • NavSelectorFrmSetNavOrder : HsNavCommon.h
  • NavSelectorFrmSetNavState : HsNavCommon.h
  • NavSelectPalmPressed : common/system/palmOneNavigator.h
  • NavSelectPressed : common/system/palmOneNavigator.h
  • navVersion : common/system/palmOneNavigator.h
  • NBSHeaderEscapeSeq : HsPhoneSMSTypes.h
  • NBSHeaderID : HsPhoneSMSTypes.h
  • NBSHeaderIDLen : HsPhoneSMSTypes.h
  • NBSNotificationEventType : HsPhoneSMSTypes.h
  • NBSPort_MimeVCalendar : HsPhoneSMSTypes.h
  • NBSPort_MimeVCard : HsPhoneSMSTypes.h
  • NBSTextHeader : HsPhoneSMSTypes.h
  • NBSTextHeaderLength : HsPhoneSMSTypes.h
  • net80211_DS : PalmWiFiCommon.h
  • net80211_FH : PalmWiFiCommon.h
  • net80211_Max : PalmWiFiCommon.h
  • net80211AutoUnknown : PalmWiFiCommon.h
  • net80211Bss : PalmWiFiCommon.h
  • Net80211DeviceInfoP : PalmNetServices.h
  • net80211Infrastructure : PalmWiFiCommon.h
  • net80211InfrastructureMax : PalmWiFiCommon.h
  • Net80211InfrastructureModeType : PalmWiFiCommon.h
  • Net80211NetworkType : PalmWiFiCommon.h
  • net80211ResetWepPasscode : PalmWiFiCommon.h
  • NetBssInfoTypeP : PalmWiFiCommon.h
  • NetBssListType : PalmWiFiCommon.h
  • netIFSetting80211AdhocTxPower : PalmWiFiCommon.h
  • netIFSetting80211Channel : PalmWiFiCommon.h
  • netIFSetting80211Diversity : PalmWiFiCommon.h
  • netIFSetting80211EncryptionKey1 : PalmWiFiCommon.h
  • netIFSetting80211EncryptionKey2 : PalmWiFiCommon.h
  • netIFSetting80211EncryptionKey3 : PalmWiFiCommon.h
  • netIFSetting80211EncryptionKey4 : PalmWiFiCommon.h
  • netIFSetting80211EncryptionKeyID : PalmWiFiCommon.h
  • netIFSetting80211Environment : PalmWiFiCommon.h
  • netIFSetting80211EssTxPower : PalmWiFiCommon.h
  • netIFSetting80211Gateway : PalmWiFiCommon.h
  • netIFSetting80211Last : PalmWiFiCommon.h
  • netIFSetting80211LongPreamble : PalmWiFiCommon.h
  • netIFSetting80211MandatoryBSSId : PalmWiFiCommon.h
  • netIFSetting80211MediaDisconnectLingerTime : PalmWiFiCommon.h
  • netIFSetting80211MobileIP : PalmWiFiCommon.h
  • netIFSetting80211MUEncryptionAlgorithm : PalmWiFiCommon.h
  • netIFSetting80211PortType : PalmWiFiCommon.h
  • netIFSetting80211PowerMode : PalmWiFiCommon.h
  • netIFSetting80211SmartConnect : PalmWiFiCommon.h
  • netIFSetting80211StationName : PalmWiFiCommon.h
  • netIFSetting8021x : PalmWiFiCommon.h
  • netIFSettingAutoPowerDownOnClose : PalmWiFiCommon.h
  • netIFSettingDHCPRequestDNS : PalmWiFiCommon.h
  • netIFSettingDriverQSize : PalmWiFiCommon.h
  • netIFSettingInterfaceQSize : PalmWiFiCommon.h
  • netIFSettingIPAllocType : PalmWiFiCommon.h
  • netIFSettingPrimaryDNS : PalmWiFiCommon.h
  • netIFSettingSecondaryDNS : PalmWiFiCommon.h
  • netIFSettingShimConfig : PalmShimSettings.h
  • netIFSettingShimCreator : PalmShimSettings.h
  • NetIFSettingShimEnum : PalmShimSettings.h
  • netIFSettingShimHideProgress : PalmShimSettings.h
  • netIFSettingShimLibVersion : PalmShimSettings.h
  • netIFSettingShimLog : PalmShimSettings.h
  • netIFSettingShimUp : PalmShimSettings.h
  • netIFSettingShimVersion : PalmShimSettings.h
  • netIFSettingShimVPNStart : PalmShimSettings.h
  • netIFSettingShimVPNStop : PalmShimSettings.h
  • netIFSettingUIProgHoldOff : PalmWiFiCommon.h
  • netIFSettingWiFiHideProgress : PalmWiFiCommon.h
  • netMacAddrLength : PalmWiFiCommon.h
  • NETMASTER_LIB_TRAP : NetMasterLibrary.h
  • netMasterAnchorTimeoutDefault : NetMasterLibTypes.h
  • netMasterAutoLoginClearAll : NetMasterLibTypes.h
  • NetMasterAutoLoginSettingGet() : NetMasterLibrary.h
  • NetMasterAutoLoginSettingSet() : NetMasterLibrary.h
  • NetMasterAutoLoginType : NetMasterLibTypes.h
  • netMasterAutoLoginWhenWirelessOn : NetMasterLibTypes.h
  • netMasterClientCurrentEventVersion : NetMasterLibTypes.h
  • NetMasterClientEventEnum : NetMasterLibTypes.h
  • netMasterClientEventLAST : NetMasterLibTypes.h
  • netMasterClientEventNotificationTypeID : NetMasterLibTypes.h
  • netMasterClientEventUnknown : NetMasterLibTypes.h
  • netMasterClientEventVPNConnInstall : NetMasterLibTypes.h
  • NetMasterDataContextIDType : NetMasterLibTypes.h
  • NetMasterDataSessionIDType : NetMasterLibTypes.h
  • netMasterErrAuthReqDuringBGLogin : NetMasterLibErrors.h
  • netMasterErrAutoLoginNotPossible : NetMasterLibErrors.h
  • netMasterErrBadArg : NetMasterLibErrors.h
  • netMasterErrBadPort : NetMasterLibErrors.h
  • netMasterErrCDMACarrierNetworkBusy : NetMasterLibErrors.h
  • netMasterErrClass : NetMasterLibErrors.h
  • netMasterErrConfigFailed : NetMasterLibErrors.h
  • netMasterErrConfigNotFound : NetMasterLibErrors.h
  • netMasterErrDispatchTable : NetMasterLibErrors.h
  • netMasterErrGPRSGenLoginErr : NetMasterLibErrors.h
  • netMasterErrInternalConnWouldBeImpossible : NetMasterLibErrors.h
  • netMasterErrMemory : NetMasterLibErrors.h
  • netMasterErrMIPAdminProhibited129 : NetMasterLibErrors.h
  • netMasterErrMIPAdminProhibited65 : NetMasterLibErrors.h
  • netMasterErrMIPBadTtl76 : NetMasterLibErrors.h
  • netMasterErrMIPCantRevTun137 : NetMasterLibErrors.h
  • netMasterErrMIPCantRevTun74 : NetMasterLibErrors.h
  • netMasterErrMIPDelivStyleNotSupported79 : NetMasterLibErrors.h
  • netMasterErrMIPErrorFa1_100 : NetMasterLibErrors.h
  • netMasterErrMIPErrorFa2_101 : NetMasterLibErrors.h
  • netMasterErrMIPErrorHa1_140 : NetMasterLibErrors.h
  • netMasterErrMIPErrorHa2_141 : NetMasterLibErrors.h
  • netMasterErrMIPFailed : NetMasterLibErrors.h
  • netMasterErrMIPForeign_Agent98 : NetMasterLibErrors.h
  • netMasterErrMIPForeignAgentAuth132 : NetMasterLibErrors.h
  • netMasterErrMIPHa_Host_Unreachable81 : NetMasterLibErrors.h
  • netMasterErrMIPHa_Port_Unreachable82 : NetMasterLibErrors.h
  • netMasterErrMIPHa_Unreachable88 : NetMasterLibErrors.h
  • netMasterErrMIPHome_Network_Unreachable80 : NetMasterLibErrors.h
  • netMasterErrMIPHomeAgentAuth68 : NetMasterLibErrors.h
  • netMasterErrMIPInsufficientResources130 : NetMasterLibErrors.h
  • netMasterErrMIPInsufficientResources66 : NetMasterLibErrors.h
  • netMasterErrMIPInvalidCareOfAddr77 : NetMasterLibErrors.h
  • netMasterErrMIPMissing_Challenge105 : NetMasterLibErrors.h
  • netMasterErrMIPMissingHa99 : NetMasterLibErrors.h
  • netMasterErrMIPMissingNai97 : NetMasterLibErrors.h
  • netMasterErrMIPMobileNodeAuth131 : NetMasterLibErrors.h
  • netMasterErrMIPMobileNodeAuth67 : NetMasterLibErrors.h
  • netMasterErrMIPMustRevTun138 : NetMasterLibErrors.h
  • netMasterErrMIPMustRevTun75 : NetMasterLibErrors.h
  • netMasterErrMIPNonZeroHaRequested96 : NetMasterLibErrors.h
  • netMasterErrMIPNoSimBindings : NetMasterLibErrors.h
  • netMasterErrMIPPoorlyFormedReply71 : NetMasterLibErrors.h
  • netMasterErrMIPPoorlyFormedReq134 : NetMasterLibErrors.h
  • netMasterErrMIPPoorlyFormedReq70 : NetMasterLibErrors.h
  • netMasterErrMIPReasonUnspecified128 : NetMasterLibErrors.h
  • netMasterErrMIPReasonUnspecified64 : NetMasterLibErrors.h
  • netMasterErrMIPRegIdMismatch133 : NetMasterLibErrors.h
  • netMasterErrMIPRegistration_Timeout78 : NetMasterLibErrors.h
  • netMasterErrMIPReqedEncapUnavail72 : NetMasterLibErrors.h
  • netMasterErrMIPReqEncapNotAvail139 : NetMasterLibErrors.h
  • netMasterErrMIPReqLifetimeTooLong69 : NetMasterLibErrors.h
  • netMasterErrMIPReserved2 : NetMasterLibErrors.h
  • netMasterErrMIPReserved3 : NetMasterLibErrors.h
  • netMasterErrMIPReserved4 : NetMasterLibErrors.h
  • netMasterErrMIPReservedNUnavail73 : NetMasterLibErrors.h
  • netMasterErrMIPStale_Challenge106 : NetMasterLibErrors.h
  • netMasterErrMIPTooManySimMobBindings135 : NetMasterLibErrors.h
  • netMasterErrMIPUnknown_Challenge104 : NetMasterLibErrors.h
  • netMasterErrMIPUnknownHaAddr136 : NetMasterLibErrors.h
  • netMasterErrMIPUsernameSuspension801 : NetMasterLibErrors.h
  • netMasterErrNetGuardReqDuringBGLogin : NetMasterLibErrors.h
  • netMasterErrNetNotInstalled : NetMasterLibErrors.h
  • netMasterErrNo1xService : NetMasterLibErrors.h
  • netMasterErrNoNetPrefLib : NetMasterLibErrors.h
  • netMasterErrNoOneXServiceWhileRoaming : NetMasterLibErrors.h
  • netMasterErrOneXServiceNotEnabled : NetMasterLibErrors.h
  • netMasterErrOneXServiceUnavailable : NetMasterLibErrors.h
  • netMasterErrStorage : NetMasterLibErrors.h
  • netMasterErrUIRPCTimeout : NetMasterLibErrors.h
  • netMasterErrUnused45 : NetMasterLibErrors.h
  • netMasterErrUnused46 : NetMasterLibErrors.h
  • netMasterErrUnused47 : NetMasterLibErrors.h
  • netMasterErrUnused48 : NetMasterLibErrors.h
  • netMasterErrUnused49 : NetMasterLibErrors.h
  • netMasterErrUnused4A : NetMasterLibErrors.h
  • netMasterErrUnused4B : NetMasterLibErrors.h
  • netMasterErrUnused4C : NetMasterLibErrors.h
  • netMasterErrUnused4D : NetMasterLibErrors.h
  • netMasterErrUnused4E : NetMasterLibErrors.h
  • netMasterLibCreatorID : NetMasterLibTarget.h
  • netMasterLibName : NetMasterLibTarget.h
  • netMasterLibTrapAutoLoginSettingGet : NetMasterLibTraps.h
  • netMasterLibTrapAutoLoginSettingSet : NetMasterLibTraps.h
  • netMasterLibTrapControl : NetMasterLibTraps.h
  • netMasterLibTrapDataCounterGetAndReset : NetMasterLibTraps.h
  • netMasterLibTrapDataSessionErrorNotify : NetMasterLibTraps.h
  • netMasterLibTrapHandlePhoneEvent : NetMasterLibTraps.h
  • netMasterLibTrapImplementNetLibConnectionRefresh : NetMasterLibTraps.h
  • netMasterLibTrapImplementNetLibHandlePowerOff : NetMasterLibTraps.h
  • netMasterLibTrapImplementNetLibOpenConfig : NetMasterLibTraps.h
  • netMasterLibTrapLibInit : NetMasterLibTraps.h
  • netMasterLibTrapLibVersionGet : NetMasterLibTraps.h
  • netMasterLibTrapLoginExecuteFromUI : NetMasterLibTraps.h
  • netMasterLibTrapLoginSMFlagsSetAndGet : NetMasterLibTraps.h
  • netMasterLibTrapNetInterfacesShutDown : NetMasterLibTraps.h
  • netMasterLibTrapNetLibIsFullyUp : NetMasterLibTraps.h
  • netMasterLibTrapNetLibIsLoggingIn : NetMasterLibTraps.h
  • netMasterLibTrapNetLibOpenIfFullyUp : NetMasterLibTraps.h
  • netMasterLibTrapNetLibOpenWithOptions : NetMasterLibTraps.h
  • netMasterLibTrapOverrideErrorGetAndClear : NetMasterLibTraps.h
  • netMasterLibTrapOverrideMdmInitStrGetPtr : NetMasterLibTraps.h
  • netMasterLibTrapPhoneServiceClassesGet : NetMasterLibTraps.h
  • netMasterLibTrapPPPPayloadReport : NetMasterLibTraps.h
  • netMasterLibTrapSCContextAnchorTimeoutSet : NetMasterLibTraps.h
  • netMasterLibTrapSCNetAttach : NetMasterLibTraps.h
  • netMasterLibTrapSCNetDetach : NetMasterLibTraps.h
  • netMasterLibTrapSCSessionCountGet : NetMasterLibTraps.h
  • netMasterLibTrapSCSessionIDGetFromContext : NetMasterLibTraps.h
  • netMasterLibTrapSCSessionIsActive : NetMasterLibTraps.h
  • netMasterLibTrapSCSessionsEnumerate : NetMasterLibTraps.h
  • netMasterLibTrapSCSessionShutDown : NetMasterLibTraps.h
  • netMasterLibTrapSCSessionSvcRecIDGet : NetMasterLibTraps.h
  • netMasterLibTrapServiceSetUp : NetMasterLibTraps.h
  • netMasterLibTypeID : NetMasterLibTarget.h
  • netMasterLibVersionBugFix : NetMasterLibTypes.h
  • NetMasterLibVersionGet() : NetMasterLibrary.h
  • netMasterLibVersionMajor : NetMasterLibTypes.h
  • netMasterLibVersionMinor : NetMasterLibTypes.h
  • netMasterLoginNetGuardEnabled : NetMasterLibTypes.h
  • netMasterLoginPriorityDefault : NetMasterLibTypes.h
  • NetMasterLoginPriorityEnum : NetMasterLibTypes.h
  • netMasterLoginPriorityHigh : NetMasterLibTypes.h
  • netMasterLoginPriorityLow : NetMasterLibTypes.h
  • netMasterNetIFShutDownOptCurrentOnly : NetMasterLibTypes.h
  • netMasterNetIFShutDownOptDismissPrgDialog : NetMasterLibTypes.h
  • NetMasterNetIFShutDownOptionsType : NetMasterLibTypes.h
  • netMasterNetIFShutDownOptResetNetGuard : NetMasterLibTypes.h
  • NetMasterNetInterfacesShutDown() : NetMasterLibrary.h
  • NetMasterNetLibIsFullyUp() : NetMasterLibrary.h
  • NetMasterNetLibIsLoggingIn() : NetMasterLibrary.h
  • NetMasterNetLibOpenIfFullyUp() : NetMasterLibrary.h
  • netMasterNetLibOpenOptAutoDismiss : NetMasterLibTypes.h
  • netMasterNetLibOpenOptBypassNetGuard : NetMasterLibTypes.h
  • NetMasterNetLibOpenOptionsType : NetMasterLibTypes.h
  • netMasterNetLibOpenOptPrimaryProfileOnly : NetMasterLibTypes.h
  • NetMasterNetLibOpenWithOptions() : NetMasterLibrary.h
  • NetMasterSCContextAnchorTimeoutSet() : NetMasterLibrary.h
  • NetMasterSCNetAttach() : NetMasterLibrary.h
  • NetMasterSCNetDetach() : NetMasterLibrary.h
  • NetMasterSCSessionCountGet() : NetMasterLibrary.h
  • NetMasterSCSessionIDGetFromContext() : NetMasterLibrary.h
  • NetMasterSCSessionIsActive() : NetMasterLibrary.h
  • NetMasterSCSessionsEnumerate() : NetMasterLibrary.h
  • NetMasterSCSessionShutDown() : NetMasterLibrary.h
  • NetMasterSCSessionSvcRecIDGet() : NetMasterLibrary.h
  • netMediaConnected : PalmWiFiCommon.h
  • netMediaDisconnected : PalmWiFiCommon.h
  • netNum80211Rates : PalmWiFiCommon.h
  • netPref1xRTTTunnelingDefault : NetPrefLibTypes.h
  • NetPref1xRTTTunnelingEnum : NetPrefLibTypes.h
  • netPref1xRTTTunnelingForward : NetPrefLibTypes.h
  • netPref1xRTTTunnelingLAST : NetPrefLibTypes.h
  • netPref1xRTTTunnelingReverse : NetPrefLibTypes.h
  • netPref1xRTTTunnelingUnknown : NetPrefLibTypes.h
  • NETPREF_LIB_TRAP : NetPrefLibrary.h
  • NetPrefDefaultTargetGet() : NetPrefLibrary.h
  • NetPrefDefaultTargetSet() : NetPrefLibrary.h
  • netPrefErrBadArg : NetPrefLibErrors.h
  • netPrefErrCCSMIncomplete : NetPrefLibErrors.h
  • netPrefErrCCSMNoCarrierMatch : NetPrefLibErrors.h
  • netPrefErrClass : NetPrefLibErrors.h
  • netPrefErrCSDNotAllowed : NetPrefLibErrors.h
  • netPrefErrFieldNotInSet : NetPrefLibErrors.h
  • netPrefErrMemory : NetPrefLibErrors.h
  • netPrefErrNoCCSMSettings : NetPrefLibErrors.h
  • netPrefErrNVRead : NetPrefLibErrors.h
  • netPrefErrNVSync : NetPrefLibErrors.h
  • netPrefErrNVWrite : NetPrefLibErrors.h
  • netPrefErrNVWritePDPInUse : NetPrefLibErrors.h
  • netPrefErrPhoneLibOpenFailed : NetPrefLibErrors.h
  • netPrefErrRadioIsOff : NetPrefLibErrors.h
  • netPrefErrReadOnlyField : NetPrefLibErrors.h
  • netPrefErrRecGone : NetPrefLibErrors.h
  • netPrefErrRecNotSaved : NetPrefLibErrors.h
  • netPrefErrStorage : NetPrefLibErrors.h
  • netPrefFallbackAlgrorithmBasic : NetPrefLibTypes.h
  • NetPrefFallbackAlgrorithmEnum : NetPrefLibTypes.h
  • netPrefFallbackAlgrorithmLAST : NetPrefLibTypes.h
  • netPrefFallbackAlgrorithmMutexSticky : NetPrefLibTypes.h
  • netPrefFallbackStatusFlagInitialized : NetPrefLibTypes.h
  • NetPrefFallbackStatusFlagsType : NetPrefLibTypes.h
  • netPrefFieldSetDefineOptionKeepData : NetPrefLibTypes.h
  • netPrefFieldSetDefineOptionNone : NetPrefLibTypes.h
  • NetPrefFieldSetDefineOptionsType : NetPrefLibTypes.h
  • netPrefFieldTypeBin : NetPrefLibFieldInfoTable.h , NetPrefLibTypes.h
  • NetPrefFieldTypeEnum : NetPrefLibTypes.h
  • netPrefFieldTypeStr : NetPrefLibFieldInfoTable.h , NetPrefLibTypes.h
  • netPrefFieldTypeUInt16 : NetPrefLibFieldInfoTable.h , NetPrefLibTypes.h , NetPrefLibFieldInfoTable.h
  • netPrefFieldTypeUInt32 : NetPrefLibFieldInfoTable.h , NetPrefLibTypes.h
  • netPrefFieldTypeUInt8 : NetPrefLibFieldInfoTable.h , NetPrefLibTypes.h
  • netPrefFieldTypeZStrList : NetPrefLibFieldInfoTable.h , NetPrefLibTypes.h
  • NetPrefHandleHotSyncNotify() : NetPrefLibrary.h
  • NetPrefLibClose() : NetPrefLibrary.h
  • netPrefLibCreatorID : NetPrefLibTarget.h
  • netPrefLibName : NetPrefLibTarget.h
  • NetPrefLibOpen() : NetPrefLibrary.h
  • NetPrefLibSleep() : NetPrefLibrary.h
  • netPrefLibTrapDefaultTargetGet : NetPrefLibTraps.h
  • netPrefLibTrapDefaultTargetSet : NetPrefLibTraps.h
  • netPrefLibTrapHandleHotSyncNotify : NetPrefLibTraps.h
  • netPrefLibTrapRecBindingErrorGet : NetPrefLibTraps.h
  • netPrefLibTrapRecByteFieldGet : NetPrefLibTraps.h
  • netPrefLibTrapRecConnectionInfoGet : NetPrefLibTraps.h
  • netPrefLibTrapRecCountGet : NetPrefLibTraps.h
  • netPrefLibTrapRecDelete : NetPrefLibTraps.h
  • netPrefLibTrapRecDirtyFlagsReset : NetPrefLibTraps.h
  • netPrefLibTrapRecFieldAddToSet : NetPrefLibTraps.h
  • netPrefLibTrapRecFieldAttrsGet : NetPrefLibTraps.h
  • netPrefLibTrapRecFieldGet : NetPrefLibTraps.h
  • netPrefLibTrapRecFieldSet : NetPrefLibTraps.h
  • netPrefLibTrapRecFieldSetDefine : NetPrefLibTraps.h
  • netPrefLibTrapRecFieldSetDefineStd : NetPrefLibTraps.h
  • netPrefLibTrapRecFieldSetFromBinHandle : NetPrefLibTraps.h
  • netPrefLibTrapRecFieldSetFromStrHandle : NetPrefLibTraps.h
  • netPrefLibTrapRecFieldSetFromStrPtr : NetPrefLibTraps.h
  • netPrefLibTrapRecFieldSetGet : NetPrefLibTraps.h
  • netPrefLibTrapRecFieldViewGet : NetPrefLibTraps.h
  • netPrefLibTrapRecFieldViewSet : NetPrefLibTraps.h
  • netPrefLibTrapRecIDGet : NetPrefLibTraps.h
  • netPrefLibTrapRecIDGetByIndex : NetPrefLibTraps.h
  • netPrefLibTrapRecIndexGet : NetPrefLibTraps.h
  • netPrefLibTrapRecIndexGetByID : NetPrefLibTraps.h
  • netPrefLibTrapRecIPAddrFieldSet : NetPrefLibTraps.h
  • netPrefLibTrapRecIsAttached : NetPrefLibTraps.h
  • netPrefLibTrapRecIsDirty : NetPrefLibTraps.h
  • netPrefLibTrapRecLoad : NetPrefLibTraps.h
  • netPrefLibTrapRecLongFieldGet : NetPrefLibTraps.h
  • netPrefLibTrapRecLongFieldSetAsFlags : NetPrefLibTraps.h
  • netPrefLibTrapRecMarkDirty : NetPrefLibTraps.h
  • netPrefLibTrapRecMediumDerive : NetPrefLibTraps.h
  • netPrefLibTrapRecNew : NetPrefLibTraps.h
  • netPrefLibTrapRecObjAlloc : NetPrefLibTraps.h
  • netPrefLibTrapRecObjCopy : NetPrefLibTraps.h
  • netPrefLibTrapRecPhoneStringCompose : NetPrefLibTraps.h
  • netPrefLibTrapRecReadOnlyOverrideEnd : NetPrefLibTraps.h
  • netPrefLibTrapRecReadOnlyOverrideStart : NetPrefLibTraps.h
  • netPrefLibTrapRecRelease : NetPrefLibTraps.h
  • netPrefLibTrapRecSave : NetPrefLibTraps.h
  • netPrefLibTrapRecShortFieldGet : NetPrefLibTraps.h
  • netPrefLibTrapUpdateFromRadioNV : NetPrefLibTraps.h
  • netPrefLibTrapUtilDefWirelessDriverIDGet : NetPrefLibTraps.h
  • netPrefLibTrapUtilPlatformIDGet : NetPrefLibTraps.h
  • netPrefLibTrapUtilZStringListSizeGet : NetPrefLibTraps.h
  • netPrefLibTrapVersionGet : NetPrefLibTraps.h
  • netPrefLibTypeID : NetPrefLibTarget.h
  • netPrefLibVersionBugFix : NetPrefLibTypes.h
  • NetPrefLibVersionGet() : NetPrefLibrary.h
  • netPrefLibVersionMajor : NetPrefLibTypes.h
  • netPrefLibVersionMinor : NetPrefLibTypes.h
  • NetPrefLibWake() : NetPrefLibrary.h
  • netPrefMaxPhoneStringSize : NetPrefLibTypes.h
  • NetPrefMutexStickyFBAStatusEnum : NetPrefLibTypes.h
  • netPrefMutexStickyFBAStatusFailed : NetPrefLibTypes.h
  • netPrefMutexStickyFBAStatusSucceeded : NetPrefLibTypes.h
  • netPrefMutexStickyFBAStatusUnknown : NetPrefLibTypes.h
  • netPrefNetCloseWaitCarrierDefault : NetPrefLibTypes.h
  • netPrefNetCloseWaitEndOnPowerOff : NetPrefLibTypes.h
  • NetPrefNetCloseWaitEnum : NetPrefLibTypes.h
  • netPrefNetCloseWaitMaintainSession : NetPrefLibTypes.h
  • NetPrefNetIdleTimeoutEnum : NetPrefLibTypes.h
  • netPrefNetIdleTimeoutNever : NetPrefLibTypes.h
  • netPrefPlatformCDMA : NetPrefLibTypes.h
  • NetPrefPlatformEnum : NetPrefLibTypes.h
  • netPrefPlatformGSM : NetPrefLibTypes.h
  • netPrefPlatformLAST : NetPrefLibTypes.h
  • netPrefPlatformUnknown : NetPrefLibTypes.h
  • NetPrefRecBindingErrorGet() : NetPrefLibrary.h
  • NetPrefRecByteFieldGet() : NetPrefLibrary.h
  • NetPrefRecConnectionInfoGet() : NetPrefLibrary.h
  • NetPrefRecCountGet() : NetPrefLibrary.h
  • NetPrefRecDelete() : NetPrefLibrary.h
  • NetPrefRecDirtyFlagsReset() : NetPrefLibrary.h
  • NetPrefRecFieldAddToSet() : NetPrefLibrary.h
  • netPrefRecFieldAttrDirty : NetPrefLibTypes.h
  • netPrefRecFieldAttrInSet : NetPrefLibTypes.h
  • NetPrefRecFieldAttrsGet() : NetPrefLibrary.h
  • NetPrefRecFieldAttrType : NetPrefLibTypes.h
  • NetPrefRecFieldEnum : NetPrefLibTypes.h
  • NetPrefRecFieldGet() : NetPrefLibrary.h
  • NetPrefRecFieldInfoExtended() : NetPrefLibFieldInfoTable.h , NetPrefLibTypes.h , NetPrefLibFieldInfoTable.h
  • NetPrefRecFieldInfoFIRST : NetPrefLibTypes.h
  • NetPrefRecFieldInfoGrpEnd : NetPrefLibTypes.h
  • NetPrefRecFieldInfoGrpStart() : NetPrefLibFieldInfoTable.h , NetPrefLibTypes.h
  • NetPrefRecFieldInfoLAST : NetPrefLibTypes.h
  • NetPrefRecFieldInfoLegacy() : NetPrefLibFieldInfoTable.h , NetPrefLibTypes.h , NetPrefLibFieldInfoTable.h
  • NetPrefRecFieldInfoPreamble : NetPrefLibTypes.h , NetPrefLibFieldInfoTable.h
  • NetPrefRecFieldSet() : NetPrefLibrary.h
  • NetPrefRecFieldSetDefine() : NetPrefLibrary.h
  • NetPrefRecFieldSetDefineStd() : NetPrefLibrary.h
  • NetPrefRecFieldSetFromBinHandle() : NetPrefLibrary.h
  • NetPrefRecFieldSetFromStrHandle() : NetPrefLibrary.h
  • NetPrefRecFieldSetFromStrPtr() : NetPrefLibrary.h
  • NetPrefRecFieldSetGet() : NetPrefLibrary.h
  • netPrefRecFieldViewCache : NetPrefLibTypes.h
  • netPrefRecFieldViewClearAll : NetPrefLibTypes.h
  • netPrefRecFieldViewCurrentlyValidFlags : NetPrefLibTypes.h
  • netPrefRecFieldViewEditable : NetPrefLibTypes.h
  • netPrefRecFieldViewExternal : NetPrefLibTypes.h
  • NetPrefRecFieldViewGet() : NetPrefLibrary.h
  • netPrefRecFieldViewPrivate : NetPrefLibTypes.h
  • netPrefRecFieldViewRead : NetPrefLibTypes.h
  • NetPrefRecFieldViewSet() : NetPrefLibrary.h
  • NetPrefRecFieldViewType : NetPrefLibTypes.h
  • netPrefRecFieldViewVisible : NetPrefLibTypes.h
  • netPrefRecFieldViewWrite : NetPrefLibTypes.h
  • NetPrefRecIDGet() : NetPrefLibrary.h
  • NetPrefRecIDGetByIndex() : NetPrefLibrary.h
  • NetPrefRecIDType : NetPrefLibTypes.h
  • NetPrefRecIndexGet() : NetPrefLibrary.h
  • NetPrefRecIndexGetByID() : NetPrefLibrary.h
  • NetPrefRecIPAddrFieldSet() : NetPrefLibrary.h
  • NetPrefRecIsAttached() : NetPrefLibrary.h
  • NetPrefRecIsDirty() : NetPrefLibrary.h
  • NetPrefRecLoad() : NetPrefLibrary.h
  • NetPrefRecLongFieldGet() : NetPrefLibrary.h
  • NetPrefRecLongFieldSetAsFlags() : NetPrefLibrary.h
  • NetPrefRecMarkDirty() : NetPrefLibrary.h
  • NetPrefRecMediumDerive() : NetPrefLibrary.h
  • NetPrefRecNew() : NetPrefLibrary.h
  • NetPrefRecObjAlloc() : NetPrefLibrary.h
  • NetPrefRecObjCopy() : NetPrefLibrary.h
  • NetPrefRecPhoneStringCompose() : NetPrefLibrary.h
  • netPrefRecProtectionDeletionAfterWarning : NetPrefLibTypes.h
  • netPrefRecProtectionDeletionMask : NetPrefLibTypes.h
  • netPrefRecProtectionDeletionNotAllowed : NetPrefLibTypes.h
  • netPrefRecProtectionDuplicationAllowed : NetPrefLibTypes.h
  • netPrefRecProtectionDuplicationMask : NetPrefLibTypes.h
  • netPrefRecProtectionDuplicationNotAllowed : NetPrefLibTypes.h
  • netPrefRecProtectionEditingAfterWarning : NetPrefLibTypes.h
  • netPrefRecProtectionEditingAllowed : NetPrefLibTypes.h
  • netPrefRecProtectionEditingMask : NetPrefLibTypes.h
  • netPrefRecProtectionEditingNotAllowed : NetPrefLibTypes.h
  • NetPrefRecProtectionType : NetPrefLibTypes.h
  • NetPrefRecReadOnlyOverrideEnd() : NetPrefLibrary.h
  • NetPrefRecReadOnlyOverrideStart() : NetPrefLibrary.h
  • NetPrefRecRelease() : NetPrefLibrary.h
  • NetPrefRecSave() : NetPrefLibrary.h
  • NetPrefRecShortFieldGet() : NetPrefLibrary.h
  • netPrefSvcBindingCCSM : NetPrefLibTypes.h
  • netPrefSvcBindingCustom : NetPrefLibTypes.h
  • NetPrefSvcBindingEnum : NetPrefLibTypes.h
  • netPrefSvcBindingIOTA : NetPrefLibTypes.h
  • netPrefSvcBindingLAST : NetPrefLibTypes.h
  • netPrefSvcBindingUnknown : NetPrefLibTypes.h
  • netPrefSvcGatewayBrowser : NetPrefLibTypes.h
  • netPrefSvcGatewayCorporate : NetPrefLibTypes.h
  • netPrefSvcGatewayDownloads : NetPrefLibTypes.h
  • netPrefSvcGatewayIM : NetPrefLibTypes.h
  • netPrefSvcGatewayInternet : NetPrefLibTypes.h
  • netPrefSvcGatewayLAST : NetPrefLibTypes.h
  • netPrefSvcGatewayMail : NetPrefLibTypes.h
  • netPrefSvcGatewayMMS : NetPrefLibTypes.h
  • netPrefSvcGatewayPictureMail : NetPrefLibTypes.h
  • netPrefSvcGatewayPrivate : NetPrefLibTypes.h
  • NetPrefSvcGatewayType : NetPrefLibTypes.h
  • netPrefSvcGatewayUnknown : NetPrefLibTypes.h
  • netPrefSvcGatewayWAP : NetPrefLibTypes.h
  • netPrefSvcMedium1xRTT : NetPrefLibTypes.h
  • netPrefSvcMediumCCSD : NetPrefLibTypes.h
  • netPrefSvcMediumDialUp : NetPrefLibTypes.h
  • netPrefSvcMediumDirect : NetPrefLibTypes.h
  • NetPrefSvcMediumEnum : NetPrefLibTypes.h
  • netPrefSvcMediumGCSD : NetPrefLibTypes.h
  • netPrefSvcMediumGISDN : NetPrefLibTypes.h
  • netPrefSvcMediumGPRS : NetPrefLibTypes.h
  • netPrefSvcMediumLAST : NetPrefLibTypes.h
  • netPrefSvcMediumOEM : NetPrefLibTypes.h
  • netPrefSvcMediumQNC : NetPrefLibTypes.h
  • netPrefSvcMediumUnknown : NetPrefLibTypes.h
  • netPrefSvcTargetBrowser : NetPrefLibTypes.h
  • netPrefSvcTargetCorporate : NetPrefLibTypes.h
  • netPrefSvcTargetDownloads : NetPrefLibTypes.h
  • NetPrefSvcTargetEnum : NetPrefLibTypes.h
  • netPrefSvcTargetIM : NetPrefLibTypes.h
  • netPrefSvcTargetInternet : NetPrefLibTypes.h
  • netPrefSvcTargetLAST : NetPrefLibTypes.h
  • netPrefSvcTargetMail : NetPrefLibTypes.h
  • netPrefSvcTargetMMS : NetPrefLibTypes.h
  • netPrefSvcTargetPictureMail : NetPrefLibTypes.h
  • netPrefSvcTargetReserved1 : NetPrefLibTypes.h
  • netPrefSvcTargetUnknown : NetPrefLibTypes.h
  • netPrefSvcTargetWAP : NetPrefLibTypes.h
  • NetPrefUpdateFromRadioNV() : NetPrefLibrary.h
  • NetPrefUtilDefWirelessDriverIDGet() : NetPrefLibrary.h
  • NetPrefUtilLoginScriptLen : NetPrefLibrary.h
  • NetPrefUtilPlatformIDGet() : NetPrefLibrary.h
  • NetPrefUtilZStringListSizeGet() : NetPrefLibrary.h
  • netQuery80211AuthenticationMode : PalmWiFiCommon.h
  • netQuery80211BSSID : PalmWiFiCommon.h
  • netQuery80211BssScan : PalmWiFiCommon.h
  • netQuery80211BssScanList : PalmWiFiCommon.h
  • netQuery80211Channel : PalmWiFiCommon.h
  • netQuery80211ChannelList : PalmWiFiCommon.h
  • netQuery80211DriverDate : PalmWiFiCommon.h
  • netQuery80211FirmwareVersion : PalmWiFiCommon.h
  • netQuery80211FWName : PalmWiFiCommon.h
  • netQuery80211Key : PalmWiFiCommon.h
  • netQuery80211KeyIndex : PalmWiFiCommon.h
  • netQuery80211Last : PalmWiFiCommon.h
  • netQuery80211MediaState : PalmWiFiCommon.h
  • netQuery80211OperatingMode : PalmWiFiCommon.h
  • netQuery80211PowerState : PalmWiFiCommon.h
  • netQuery80211RadioState : PalmWiFiCommon.h
  • netQuery80211ResetKeys : PalmWiFiCommon.h
  • netQuery80211SecurityMode : PalmWiFiCommon.h
  • netQuery80211SerialNumber : PalmWiFiCommon.h
  • netQuery80211SignalQuality : PalmWiFiCommon.h
  • netQuery80211SignalStrength : PalmWiFiCommon.h
  • netQuery80211SSID : PalmWiFiCommon.h
  • netQuery80211StartConnection : PalmWiFiCommon.h
  • netQuery80211WEPRequired : PalmWiFiCommon.h
  • netQuery80211WepStatus : PalmWiFiCommon.h
  • netQueryCancel : PalmWiFiCommon.h
  • NetQueryId : PalmWiFiCommon.h
  • NetQueryType : PalmWiFiCommon.h
  • NetQueryTypeP : PalmWiFiCommon.h
  • NetServicesGetChannel() : PalmNetServices.h
  • NetServicesGetChannelList() : PalmNetServices.h
  • NetServicesGetCommsQuality() : PalmNetServices.h
  • NetServicesGetDeviceInfo() : PalmNetServices.h
  • NetServicesGetHWAddr() : PalmNetServices.h
  • NetServicesGetPowerState() : PalmNetServices.h
  • NetServicesGetRadioState() : PalmNetServices.h
  • NetServicesGetScanResults() : PalmNetServices.h
  • NetServicesLibTrapGetChannel : PalmNetServices.h
  • NetServicesLibTrapGetChannelList : PalmNetServices.h
  • NetServicesLibTrapGetCommsQuality : PalmNetServices.h
  • NetServicesLibTrapGetDeviceInfo : PalmNetServices.h
  • NetServicesLibTrapGetHWAddr : PalmNetServices.h
  • NetServicesLibTrapGetPowerState : PalmNetServices.h
  • NetServicesLibTrapGetRadioState : PalmNetServices.h
  • NetServicesLibTrapGetScanResults : PalmNetServices.h
  • NetServicesLibTrapProfileAdd : PalmNetServices.h
  • NetServicesLibTrapProfileDelete : PalmNetServices.h
  • NetServicesLibTrapProfileFind : PalmNetServices.h
  • NetServicesLibTrapProfileGetInfo : PalmNetServices.h
  • NetServicesLibTrapProfileGetOrder : PalmNetServices.h
  • NetServicesLibTrapProfileRead : PalmNetServices.h
  • NetServicesLibTrapProfileSetOrder : PalmNetServices.h
  • NetServicesLibTrapProfileWrite : PalmNetServices.h
  • NetServicesLibTrapSetRadioState : PalmNetServices.h
  • NetServicesLibTrapStartScan : PalmNetServices.h
  • NetServicesProfileAdd() : PalmNetServices.h
  • NetServicesProfileDelete() : PalmNetServices.h
  • NetServicesProfileFind() : PalmNetServices.h
  • NetServicesProfileGetInfo() : PalmNetServices.h
  • NetServicesProfileGetOrder() : PalmNetServices.h
  • NetServicesProfileInfoP : PalmNetServices.h
  • NetServicesProfileOrderP : PalmNetServices.h
  • NetServicesProfileP : PalmNetServices.h
  • NetServicesProfileRead() : PalmNetServices.h
  • NetServicesProfileSetOrder() : PalmNetServices.h
  • NetServicesProfileV1P : PalmNetServices.h
  • NetServicesProfileWrite() : PalmNetServices.h
  • NetServicesSetRadioState() : PalmNetServices.h
  • NetServicesStartScan() : PalmNetServices.h
  • netSSIDMaxLength : PalmWiFiCommon.h
  • NetSSIDP : PalmWiFiCommon.h
  • netWEPDisabled : PalmWiFiCommon.h
  • netWEPEnabled : PalmWiFiCommon.h
  • netWEPKeyAbsent : PalmWiFiCommon.h
  • NetWepKeyP : PalmWiFiCommon.h
  • netWEPNotSupported : PalmWiFiCommon.h
  • NetWepStatus : PalmWiFiCommon.h
  • NewControlProc : HtmlLib68K.h
  • NewFieldProc : HtmlLib68K.h
  • NewListProc : HtmlLib68K.h
  • normal : VMFontLibCommon.h
  • NULL : PalmNative.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:38 2008 for Palm API Guide


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- o -

  • oemErrorClass : PalmErrorBase.h
  • Omega11BitMap : SmartTextEngineRsc.h
  • Omega14BitMap : SmartTextEngineRsc.h
  • oneXConnection : HsPhoneMiscTypes.h
  • OVLY_LIB_TRAP : PalmLcdOverlay.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:38 2008 for Palm API Guide


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- a -

  • AacFileRefPtr : palmOneCodecFormat.h
  • AACHeaderType : palmOneCodecFormat.h
  • AACObjectType : palmOneCodecFormat.h
  • AddrAddToRecordParamsPtr : HsAppLaunchCmd.h
  • addrAppLaunchCmdCallerID : HsAppLaunchCmd.h
  • addrAppLaunchCmdHsLookup : HsAppLaunchCmd.h
  • addrAppNotificationBeamBusinessCard : HsAppLaunchCmd.h
  • addrAppNotificationCmdCallerID : HsAppLaunchCmd.h
  • addrAppNotificationCreateNewRecord : HsAppLaunchCmd.h
  • addrAppNotificationDialPrefs : HsAppLaunchCmd.h
  • addrAppNotificationHsLookup : HsAppLaunchCmd.h
  • addrAppNotificationListLookupTypeGet : HsAppLaunchCmd.h
  • addrAppNotificationPhonebookApp : HsAppLaunchCmd.h
  • addrAppNotificationPhotoCallerID : HsAppLaunchCmd.h
  • AddrCallerIDParamsPtr : HsAppLaunchCmd.h
  • AddrCreateNewRecordParamsPtr : HsAppLaunchCmd.h
  • AddrCustomActionCodes : HsAppLaunchCmd.h
  • AddrCustomNotificationCodes : HsAppLaunchCmd.h
  • AddrDescriptor : HsPhoneSMSTypes.h
  • addrEmailLabel : HsPhoneSMSTypes.h
  • Address : HsPhoneSMSTypes.h
  • AddressAppPhoneLabel : HsPhoneSMSTypes.h
  • AddressAppPhoneLabelType : HsPhoneSMSTypes.h
  • AddressAppRecordFieldEnum : HsPhoneSMSTypes.h
  • AddressAppRecordHeader : HsPhoneSMSTypes.h
  • AddressHsLookupFields : HsAppLaunchCmd.h
  • Addressing16bitID : HsPhoneSMSTypes.h
  • Addressing16bitIDLen : HsPhoneSMSTypes.h
  • Addressing8bitID : HsPhoneSMSTypes.h
  • Addressing8bitIDLen : HsPhoneSMSTypes.h
  • AddressType : HsPhoneSMSTypes.h
  • addrFaxLabel : HsPhoneSMSTypes.h
  • addrHomeLabel : HsPhoneSMSTypes.h
  • AddrHsLookupParamsPtr : HsAppLaunchCmd.h
  • AddrHsLookupParamsType : HsAppLaunchCmd.h
  • AddrHsLookupUserDataPtr : HsAppLaunchCmd.h
  • AddrHsLookupUserDataV2Ptr : HsAppLaunchCmd.h
  • AddrHsLookupUserDataVersion : HsAppLaunchCmd.h
  • AddrHsLookupUserDataVersion2 : HsAppLaunchCmd.h
  • addrListLookupTypeCompany : HsAppLaunchCmd.h
  • AddrListLookupTypeEnum : HsAppLaunchCmd.h
  • addrListLookupTypeFirstName : HsAppLaunchCmd.h
  • addrListLookupTypeIntelligent : HsAppLaunchCmd.h
  • addrListLookupTypeLastName : HsAppLaunchCmd.h
  • addrLookupAnyPhones : HsAppLaunchCmd.h
  • addrLookupNoMinLength : HsAppLaunchCmd.h
  • addrLookupSMSPhones : HsAppLaunchCmd.h
  • addrLookupSMSPhonesNoEmail : HsAppLaunchCmd.h
  • addrLookupVoicePhones : HsAppLaunchCmd.h
  • addrMainLabel : HsPhoneSMSTypes.h
  • addrMobileLabel : HsPhoneSMSTypes.h
  • addrNoLabel : HsPhoneSMSTypes.h
  • addrOtherLabel : HsPhoneSMSTypes.h
  • addrPagerLabel : HsPhoneSMSTypes.h
  • AddrPhonebookAppParamsPtr : HsAppLaunchCmd.h
  • AddrPhotoCallerIDParamsPtr : HsAppLaunchCmd.h
  • addrWorkLabel : HsPhoneSMSTypes.h
  • aiaExtentChangedData : PalmPin.h
  • AiaExtentChangedEvent : PalmPin.h
  • allSize : VMFontLibCommon.h
  • allStyle : VMFontLibCommon.h
  • AP_DENSITY_HIGH : PalmWiFiCommon.h
  • AP_DENSITY_LOW : PalmWiFiCommon.h
  • AP_DENSITY_MED : PalmWiFiCommon.h
  • appPrefsID : Slider.h
  • appPrefsVersion : Slider.h
  • apptMaxTimeZoneNameLen : DatebookLibCommon.h
  • AttachType : DatebookLibCommon.h
  • ATTYPE_MAX_NAME_LEN : PalmVMPlugin.h
  • AUTHENTICATION_ALGORITHM_OPEN_SYSTEM : PalmWiFiCommon.h
  • AUTHENTICATION_ALGORITHM_SHARED_KEY : PalmWiFiCommon.h
  • AUTHENTICATION_ALGORITHM_SHARED_KEY_128 : PalmWiFiCommon.h
  • AUTO_PREAMBLE : PalmWiFiCommon.h
  • AUTO_TX_POWER : PalmWiFiCommon.h
  • autoLockMode : HsPhoneTypes.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:38 2008 for Palm API Guide


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- b -

  • band1800 : HsPhoneNetworkTypes.h
  • band1900 : HsPhoneNetworkTypes.h
  • band1900_850 : HsPhoneNetworkTypes.h
  • band850 : HsPhoneNetworkTypes.h
  • band900_1800 : HsPhoneNetworkTypes.h
  • bandAuto : HsPhoneNetworkTypes.h
  • bandGSM_EGSM : HsPhoneNetworkTypes.h
  • bbutGadgetMiscSelectData : HsExtUtilBigButtonCommon.h
  • bbutGadgetMiscSelectSelector : HsExtUtilBigButtonCommon.h
  • BGRecvResponseFP : PalmBGService.h
  • BGServiceCancelRqst() : PalmBGService.h
  • BGServiceClose() : PalmBGService.h
  • bgServiceCreatorID : PalmBGService.h
  • BGServiceINetRqst() : PalmBGService.h
  • bgServiceLibName : PalmBGService.h
  • BGServiceNetRqst() : PalmBGService.h
  • BGServiceOpen() : PalmBGService.h
  • bgServiceType : PalmBGService.h
  • BGServiceVersion() : PalmBGService.h
  • bgTrapAPIVersion : PalmBGService.h
  • bgTrapCancelRqst : PalmBGService.h
  • bgTrapINetLibRqst : PalmBGService.h
  • bgTrapNetLibRqst : PalmBGService.h
  • bold : VMFontLibCommon.h
  • Boolean : PalmNative.h
  • BSSINFO_ANL_OFFSET : PalmWiFiCommon.h
  • BSSINFO_ANL_SIZE : PalmWiFiCommon.h
  • BSSINFO_ANL_VFLAG : PalmWiFiCommon.h
  • BSSINFO_ATIM_WINDOW_OFFSET : PalmWiFiCommon.h
  • BSSINFO_ATIM_WINDOW_SIZE : PalmWiFiCommon.h
  • BSSINFO_ATIM_WINDOW_VFLAG : PalmWiFiCommon.h
  • BSSINFO_BEACON_PERIOD_OFFSET : PalmWiFiCommon.h
  • BSSINFO_BEACON_PERIOD_SIZE : PalmWiFiCommon.h
  • BSSINFO_BEACON_PERIOD_VFLAG : PalmWiFiCommon.h
  • BSSINFO_CHID_OFFSET : PalmWiFiCommon.h
  • BSSINFO_CHID_SIZE : PalmWiFiCommon.h
  • BSSINFO_CHID_VFLAG : PalmWiFiCommon.h
  • BSSINFO_DSFREQ_OFFSET : PalmWiFiCommon.h
  • BSSINFO_DSFREQ_SIZE : PalmWiFiCommon.h
  • BSSINFO_DSFREQ_VFLAG : PalmWiFiCommon.h
  • BSSINFO_HOPDWELL_OFFSET : PalmWiFiCommon.h
  • BSSINFO_HOPDWELL_SIZE : PalmWiFiCommon.h
  • BSSINFO_HOPDWELL_VFLAG : PalmWiFiCommon.h
  • BSSINFO_HOPPATTERN_OFFSET : PalmWiFiCommon.h
  • BSSINFO_HOPPATTERN_SIZE : PalmWiFiCommon.h
  • BSSINFO_HOPPATTERN_VFLAG : PalmWiFiCommon.h
  • BSSINFO_HOPSET_OFFSET : PalmWiFiCommon.h
  • BSSINFO_HOPSET_SIZE : PalmWiFiCommon.h
  • BSSINFO_HOPSET_VFLAG : PalmWiFiCommon.h
  • BSSINFO_MAC_ADDR_OFFSET : PalmWiFiCommon.h
  • BSSINFO_MAC_ADDR_SIZE : PalmWiFiCommon.h
  • BSSINFO_MAC_ADDR_VFLAG : PalmWiFiCommon.h
  • BSSINFO_NETWORK_MODE_OFFSET : PalmWiFiCommon.h
  • BSSINFO_NETWORK_MODE_SIZE : PalmWiFiCommon.h
  • BSSINFO_NETWORK_MODE_VFLAG : PalmWiFiCommon.h
  • BSSINFO_NETWORK_TYPE_OFFSET : PalmWiFiCommon.h
  • BSSINFO_NETWORK_TYPE_SIZE : PalmWiFiCommon.h
  • BSSINFO_NETWORK_TYPE_VFLAG : PalmWiFiCommon.h
  • BSSINFO_RSSI_OFFSET : PalmWiFiCommon.h
  • BSSINFO_RSSI_SIZE : PalmWiFiCommon.h
  • BSSINFO_RSSI_VFLAG : PalmWiFiCommon.h
  • BSSINFO_SIZE : PalmWiFiCommon.h
  • BSSINFO_SSID_OFFSET : PalmWiFiCommon.h
  • BSSINFO_SSID_SIZE : PalmWiFiCommon.h
  • BSSINFO_SSID_VFLAG : PalmWiFiCommon.h
  • BSSINFO_SSIDLENGTH_OFFSET : PalmWiFiCommon.h
  • BSSINFO_SSIDLENGTH_SIZE : PalmWiFiCommon.h
  • BSSINFO_SSIDLENGTH_VFLAG : PalmWiFiCommon.h
  • BSSINFO_SUPPORTED_RATES_OFFSET : PalmWiFiCommon.h
  • BSSINFO_SUPPORTED_RATES_SIZE : PalmWiFiCommon.h
  • BSSINFO_SUPPORTED_RATES_VFLAG : PalmWiFiCommon.h
  • BSSINFO_VFLAG : PalmWiFiCommon.h
  • BSSINFO_VFLAG_SIZE : PalmWiFiCommon.h
  • BSSINFO_WEP_OFFSET : PalmWiFiCommon.h
  • BSSINFO_WEP_SIZE : PalmWiFiCommon.h
  • BSSINFO_WEP_VFLAG : PalmWiFiCommon.h
  • BssInfoANL : PalmWiFiCommon.h
  • BssInfoAtimWindow : PalmWiFiCommon.h
  • BssInfoBeaconPeriod : PalmWiFiCommon.h
  • BssInfoChannelId : PalmWiFiCommon.h
  • BssInfoDSFreq : PalmWiFiCommon.h
  • BssInfoHopDwell : PalmWiFiCommon.h
  • BssInfoHopPattern : PalmWiFiCommon.h
  • BssInfoHopSet : PalmWiFiCommon.h
  • BssInfoMacAddr : PalmWiFiCommon.h
  • BssInfoNetworkMode : PalmWiFiCommon.h
  • BssInfoNetworkType : PalmWiFiCommon.h
  • BssInfoRssi : PalmWiFiCommon.h
  • BssInfoSsid : PalmWiFiCommon.h
  • BssInfoSsidLength : PalmWiFiCommon.h
  • BssInfoSupportedRates : PalmWiFiCommon.h
  • BssInfoWep : PalmWiFiCommon.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:38 2008 for Palm API Guide


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- c -

  • CallWithCommand : HsAppLaunchCmd.h
  • CAM_LIB_TRAP : palmOneCamera.h , PalmHiResTime.h
  • cameraAppLaunchCmdStopPreview : HsAppLaunchCmd.h
  • CameraLibCapture() : CameraLib.h
  • CameraLibClose() : CameraLib.h
  • CameraLibOpen() : CameraLib.h
  • CameraLibPreview() : CameraLib.h
  • CameraLibPreviewStart() : CameraLib.h
  • CameraLibPreviewStop() : CameraLib.h
  • CameraLibRegisterGet() : CameraLib.h
  • CameraLibRegisterSet() : CameraLib.h
  • CameraLibSleep() : CameraLib.h
  • CameraLibWake() : CameraLib.h
  • CamLibApertureValueType : palmOneCameraCommon.h
  • CamLibBitmapInfoType : palmOneCameraCommon.h
  • CamLibBufNumType : palmOneCameraCommon.h
  • CamLibCaptureCallbackFunc : palmOneCameraCommon.h
  • CamLibCaptureFormatType : palmOneCameraCommon.h
  • CamLibCaptureType : palmOneCameraCommon.h
  • CamLibClose() : palmOneCamera.h
  • CamLibColorSpaceType : palmOneCameraCommon.h
  • CamLibContrastType : palmOneCameraCommon.h
  • CamLibControl() : palmOneCamera.h
  • CamLibControlType : palmOneCameraCommon.h
  • CamLibEffectsType : palmOneCameraCommon.h
  • CamLibExposureType : palmOneCameraCommon.h
  • CamLibGetVersion() : palmOneCamera.h
  • CamLibImageSizeType : palmOneCameraCommon.h
  • CamLibLightingType : palmOneCameraCommon.h
  • CamLibOpen() : palmOneCamera.h
  • CamLibSaturationType : palmOneCameraCommon.h
  • CamLibSettingType : palmOneCameraCommon.h
  • CamLibSharpnessType : palmOneCameraCommon.h
  • CamLibShutterSpeedType : palmOneCameraCommon.h
  • CamLibSleep() : palmOneCamera.h
  • CamLibStatusType : palmOneCameraCommon.h
  • CamLibStreamPreviewType : palmOneCameraCommon.h
  • CamLibStreamType : palmOneCameraCommon.h
  • CamLibWake() : palmOneCamera.h
  • CamLibWhiteBalanceType : palmOneCameraCommon.h
  • CamLibZoomType : palmOneCameraCommon.h
  • CCSMBrowserFlagsType : CarrierCustomLibTypes.h
  • CCSMBrowserSettingsEnum : CarrierCustomLibTypes.h
  • CCSMCarrierHandle : CarrierCustomLibTypes.h
  • ccsmErrBufferTooSmall : CarrierCustomLibErr.h
  • ccsmErrClass : CarrierCustomLibErr.h
  • ccsmErrInvalidArg : CarrierCustomLibErr.h
  • ccsmErrLibUninitialized : CarrierCustomLibErr.h
  • ccsmErrMemory : CarrierCustomLibErr.h
  • ccsmErrNotRegistered : CarrierCustomLibErr.h
  • ccsmErrPhoneLibLoad : CarrierCustomLibErr.h
  • ccsmErrPhoneNotPowered : CarrierCustomLibErr.h
  • ccsmErrProfileUnspecified : CarrierCustomLibErr.h
  • ccsmErrUndefinedField : CarrierCustomLibErr.h
  • ccsmErrUnimplemented : CarrierCustomLibErr.h
  • ccsmErrUnknownCarrier : CarrierCustomLibErr.h
  • ccsmErrUnknownField : CarrierCustomLibErr.h
  • ccsmErrUnknownSetting : CarrierCustomLibErr.h
  • ccsmErrUnspecified : CarrierCustomLibErr.h
  • CCSMMessagingFlagsType : CarrierCustomLibTypes.h
  • CCSMMessagingSettingsEnum : CarrierCustomLibTypes.h
  • CCSMPhoneFlagsEnum : CarrierCustomLibTypes.h
  • CCSMPhoneFlagsType : CarrierCustomLibTypes.h
  • CCSMRadioBandEnum : CarrierCustomLibTypes.h
  • CCSMRadioBandType : CarrierCustomLibTypes.h
  • CCSMSettingsType : CarrierCustomLibTypes.h
  • CCSMSystemFlagsEnum : CarrierCustomLibTypes.h
  • CCSMSystemFlagsType : CarrierCustomLibTypes.h
  • CCSMVersionBugFix : CarrierCustomLibTypes.h
  • CCSMVersionMajor : CarrierCustomLibTypes.h
  • CCSMVersionMinor : CarrierCustomLibTypes.h
  • CCUSTOM_LIB_TRAP : CarrierCustomLib.h
  • CCustomLibClose() : CarrierCustomLib.h
  • CCustomLibGetCarrierCode() : CarrierCustomLib.h
  • CCustomLibGetCarrierCodeLength() : CarrierCustomLib.h
  • CCustomLibGetCarrierSetting() : CarrierCustomLib.h
  • CCustomLibOpen() : CarrierCustomLib.h
  • CCustomLibSleep() : CarrierCustomLib.h
  • CCustomLibTrapGetCarrierCode : CarrierCustomLibTraps.h
  • CCustomLibTrapGetCarrierCodeLength : CarrierCustomLibTraps.h
  • CCustomLibTrapGetCarrierProfile : CarrierCustomLibTraps.h
  • CCustomLibTrapGetCarrierSetting : CarrierCustomLibTraps.h
  • CCustomLibTrapGetProfileSetting : CarrierCustomLibTraps.h
  • CCustomLibTrapRefresh : CarrierCustomLibTraps.h
  • CCustomLibTrapReleaseCarrierProfile : CarrierCustomLibTraps.h
  • CCustomLibTrapRetrieveNVSetting : CarrierCustomLibTraps.h
  • CCustomLibTrapVersionGet : CarrierCustomLibTraps.h
  • CCustomLibVersionGet() : CarrierCustomLib.h
  • CCustomLibWake() : CarrierCustomLib.h
  • Char : PalmNative.h
  • class0 : HsPhoneEvent.h
  • class1 : HsPhoneEvent.h
  • class2 : HsPhoneEvent.h
  • class3 : HsPhoneEvent.h
  • classUnknown : HsPhoneEvent.h
  • clirNotProvisioned : HsPhoneNetworkTypes.h
  • clirProvisioned : HsPhoneNetworkTypes.h
  • clirTemporaryAllowed : HsPhoneNetworkTypes.h
  • clirTemporaryRestricted : HsPhoneNetworkTypes.h
  • clirUnknown : HsPhoneNetworkTypes.h
  • codecDriverIMAADPCM : PalmSoundCustomCtrl.h
  • codecIMAADPCMSetBlockSize : PalmSoundCustomCtrl.h
  • CodecMgrClose() : palmOneCodecPluginMgr.h
  • CodecMgrCreateSession() : palmOneCodecPluginMgr.h
  • CodecMgrCreateSessionByID() : palmOneCodecPluginMgr.h
  • CodecMgrCustomControl() : palmOneCodecPluginMgr.h
  • CodecMgrDeleteSession() : palmOneCodecPluginMgr.h
  • CodecMgrEncodeDecode() : palmOneCodecPluginMgr.h
  • CodecMgrEnumerateFormats() : palmOneCodecPluginMgr.h
  • CodecMgrGetMaxDestBufferSize() : palmOneCodecPluginMgr.h
  • CodecMgrGetSessionInfo() : palmOneCodecPluginMgr.h
  • CodecMgrIsFormatSupported() : palmOneCodecPluginMgr.h
  • CodecMgrLibAPIVersion() : palmOneCodecPluginMgr.h
  • CodecMgrOpen() : palmOneCodecPluginMgr.h
  • CodecMgrResetSession() : palmOneCodecPluginMgr.h
  • CodecMgrSleep() : palmOneCodecPluginMgr.h
  • CodecMgrWake() : palmOneCodecPluginMgr.h
  • CompareToneIdentifiers : TonesLibTypes.h
  • CONTACTS_LIB_TRAP : Contacts.h
  • ContactsAddContact() : Contacts.h
  • contactsAddress1 : Contacts.h
  • contactsAddress2 : Contacts.h
  • contactsAddress3 : Contacts.h
  • ContactsAddressLabel : Contacts.h
  • contactsAimChat : Contacts.h
  • ContactsAllCategories : Contacts.h
  • contactsAnniversaryDate : Contacts.h
  • contactsAnniversaryMask : Contacts.h
  • contactsAnniversaryPreset : Contacts.h
  • contactsBinaryPictureData : Contacts.h
  • contactsBinaryRingtoneIdentifier : Contacts.h
  • contactsBirthdate : Contacts.h
  • contactsBirthdayMask : Contacts.h
  • contactsBirthdayPreset : Contacts.h
  • contactsBusy : Contacts.h
  • ContactsCategoryFind() : Contacts.h
  • contactsCategoryID : Contacts.h
  • contactsChat1 : Contacts.h
  • contactsChat2 : Contacts.h
  • ContactsChatLabel : Contacts.h
  • contactsCity1 : Contacts.h
  • contactsCity2 : Contacts.h
  • contactsCity3 : Contacts.h
  • ContactsCloseSession() : Contacts.h
  • contactsCompany : Contacts.h
  • ContactsContHandle : Contacts.h
  • contactsCountry1 : Contacts.h
  • contactsCountry2 : Contacts.h
  • contactsCountry3 : Contacts.h
  • ContactsCreateHandle() : Contacts.h
  • contactsCustom1 : Contacts.h
  • contactsCustom2 : Contacts.h
  • contactsCustom3 : Contacts.h
  • contactsCustom4 : Contacts.h
  • contactsCustom5 : Contacts.h
  • contactsCustom6 : Contacts.h
  • contactsCustom7 : Contacts.h
  • contactsCustom8 : Contacts.h
  • contactsCustom9 : Contacts.h
  • contactsCustomCustom1 : Contacts.h
  • contactsCustomCustom2 : Contacts.h
  • contactsCustomCustom3 : Contacts.h
  • contactsCustomCustom4 : Contacts.h
  • contactsCustomCustom5 : Contacts.h
  • contactsCustomCustom6 : Contacts.h
  • contactsCustomCustom7 : Contacts.h
  • contactsCustomCustom8 : Contacts.h
  • contactsCustomCustom9 : Contacts.h
  • contactsDateAnniversary : Contacts.h
  • contactsDateBirthdate : Contacts.h
  • ContactsDateType : Contacts.h
  • ContactsDeleteContact() : Contacts.h
  • contactsDirty : Contacts.h
  • ContactsDoesFieldExist() : Contacts.h
  • contactsEmailPhone : Contacts.h
  • contactsFaxPhone : Contacts.h
  • contactsFirstName : Contacts.h
  • ContactsGetBinaryField() : Contacts.h
  • ContactsGetCategoryList() : Contacts.h
  • ContactsGetCategoryName() : Contacts.h
  • ContactsGetContact() : Contacts.h
  • ContactsGetDateField() : Contacts.h
  • ContactsGetFieldLabel() : Contacts.h
  • ContactsGetFirstContact() : Contacts.h
  • ContactsGetLabelText() : Contacts.h
  • ContactsGetLastError() : Contacts.h
  • ContactsGetNextCategory() : Contacts.h
  • ContactsGetNextContact() : Contacts.h
  • ContactsGetNumRecords() : Contacts.h
  • ContactsGetRingtoneForCategory() : Contacts.h
  • ContactsGetStringField() : Contacts.h
  • ContactsGetUInt16Field() : Contacts.h
  • ContactsGetUInt32Field() : Contacts.h
  • ContactsGetUInt8Field() : Contacts.h
  • ContactsGetVersion() : Contacts.h
  • contactsHomeAddress : Contacts.h
  • contactsHomePhone : Contacts.h
  • contactsIcqChat : Contacts.h
  • contactsIndex : Contacts.h
  • ContactsIsEmptyContact() : Contacts.h
  • ContactsLabel : Contacts.h
  • ContactsLabelLength : Contacts.h
  • ContactsLabelType : Contacts.h
  • ContactsLabelTypes : Contacts.h
  • contactsLastName : Contacts.h
  • ContactsLib_CloseLibrary() : Contacts.h
  • ContactsLib_OpenLibrary() : Contacts.h
  • ContactsLibAllFields : Contacts.h
  • ContactsLibBinaryFields : Contacts.h
  • ContactsLibCreatorID : Contacts.h
  • ContactsLibCustomFields : Contacts.h
  • ContactsLibDateFields : Contacts.h
  • ContactsLibErrAlreadyInWriteMode : Contacts.h
  • ContactsLibErrAppInfoIsMising : Contacts.h
  • ContactsLibErrAttachAlreadyExist : Contacts.h
  • ContactsLibErrAttachNotExist : Contacts.h
  • ContactsLibErrAttachOverflow : Contacts.h
  • ContactsLibErrAttachOverFlow : Contacts.h
  • ContactsLibErrCategoryNotFound : Contacts.h
  • ContactsLibErrContactNotFound : Contacts.h
  • ContactsLibErrContactNotLocked : Contacts.h
  • ContactsLibErrEmptyContact : Contacts.h
  • ContactsLibErrFieldNotFound : Contacts.h
  • ContactsLibErrInvalidAppInfoBlock : Contacts.h
  • ContactsLibErrInvalidField : Contacts.h
  • ContactsLibErrInvalidHandle : Contacts.h
  • ContactsLibErrInvalidParam : Contacts.h
  • ContactsLibErrInvalidReference : Contacts.h
  • ContactsLibErrInvalidSessionHandle : Contacts.h
  • ContactsLibErrLibAlreadyInUse : Contacts.h
  • ContactsLibErrLibStillOpen : Contacts.h
  • ContactsLibErrListNotExist : Contacts.h
  • ContactsLibErrMaxLimitReached : Contacts.h
  • ContactsLibErrorClass : Contacts.h
  • ContactsLibErrOutOfMemory : Contacts.h
  • ContactsLibErrReadOnlySession : Contacts.h
  • ContactsLibErrRecordNotFound : Contacts.h
  • ContactsLibErrSizeParamOverFlow : Contacts.h
  • ContactsLibErrStringNotFound : Contacts.h
  • ContactsLibErrTooManyClients : Contacts.h
  • ContactsLibErrTooManySession : Contacts.h
  • ContactsLibErrUIdExist : Contacts.h
  • ContactsLibErrUIdNotFound : Contacts.h
  • ContactsLibErrVerNotSupported : Contacts.h
  • ContactsLibFieldLabels : Contacts.h
  • ContactsLibGetLastErr : Contacts.h
  • ContactsLibName : Contacts.h
  • ContactsLibSessionModeReadOnly : Contacts.h
  • ContactsLibSessionModeReadWrite : Contacts.h
  • ContactsLibStrFields : Contacts.h
  • ContactsLibTrapAddContact : Contacts.h
  • ContactsLibTrapCategoryFind : Contacts.h
  • ContactsLibTrapCloseSession : Contacts.h
  • ContactsLibTrapCreateHandle : Contacts.h
  • ContactsLibTrapDeleteContact : Contacts.h
  • ContactsLibTrapDoesFieldExist : Contacts.h
  • ContactsLibTrapGetBinaryField : Contacts.h
  • ContactsLibTrapGetCategoryList : Contacts.h
  • ContactsLibTrapGetCategoryName : Contacts.h
  • ContactsLibTrapGetContact : Contacts.h
  • ContactsLibTrapGetDateField : Contacts.h
  • ContactsLibTrapGetFieldLabel : Contacts.h
  • ContactsLibTrapGetFirstContact : Contacts.h
  • ContactsLibTrapGetLabelText : Contacts.h
  • ContactsLibTrapGetNextCategory : Contacts.h
  • ContactsLibTrapGetNextContact : Contacts.h
  • ContactsLibTrapGetNumOfRecord : Contacts.h
  • ContactsLibTrapGetRingtoneForCategory : Contacts.h
  • ContactsLibTrapGetStringField : Contacts.h
  • ContactsLibTrapGetUInt16Field : Contacts.h
  • ContactsLibTrapGetUInt32Field : Contacts.h
  • ContactsLibTrapGetUInt8Field : Contacts.h
  • ContactsLibTrapGetVersion : Contacts.h
  • ContactsLibTrapIsEmptyContact : Contacts.h
  • ContactsLibTrapLookUpString : Contacts.h
  • ContactsLibTrapOpenSession : Contacts.h
  • ContactsLibTrapPosInCategory : Contacts.h
  • ContactsLibTrapReleaseHandle : Contacts.h
  • ContactsLibTrapRenameCustomLabel : Contacts.h
  • ContactsLibTrapSeekRecord : Contacts.h
  • ContactsLibTrapSetBinaryField : Contacts.h
  • ContactsLibTrapSetCategoryName : Contacts.h
  • ContactsLibTrapSetDateField : Contacts.h
  • ContactsLibTrapSetFieldLabel : Contacts.h
  • ContactsLibTrapSetStringField : Contacts.h
  • ContactsLibTrapSetUInt16Field : Contacts.h
  • ContactsLibTrapSetUInt8Field : Contacts.h
  • ContactsLibTrapUpdateContact : Contacts.h
  • ContactsLibTypeID : Contacts.h
  • ContactsLibUInt16Fields : Contacts.h
  • ContactsLibUInt32Fields : Contacts.h
  • ContactsLibUInt8Fields : Contacts.h
  • ContactsLibWithLabelFields : Contacts.h
  • ContactsLookUpString() : Contacts.h
  • contactsMainPhone : Contacts.h
  • contactsMobilePhone : Contacts.h
  • contactsMsnChat : Contacts.h
  • contactsNote : Contacts.h
  • contactsNoType : Contacts.h
  • ContactsNumCategories : Contacts.h
  • contactsNumFields : Contacts.h
  • ContactsOpenSession() : Contacts.h
  • contactsOtherAddress : Contacts.h
  • contactsOtherChat : Contacts.h
  • contactsOtherPhone : Contacts.h
  • contactsPagerPhone : Contacts.h
  • contactsPhone1 : Contacts.h
  • contactsPhone2 : Contacts.h
  • contactsPhone3 : Contacts.h
  • contactsPhone4 : Contacts.h
  • contactsPhone5 : Contacts.h
  • contactsPhone6 : Contacts.h
  • contactsPhone7 : Contacts.h
  • ContactsPhoneLabel : Contacts.h
  • contactsPicture : Contacts.h
  • ContactsPosInCategory() : Contacts.h
  • contactsPrivate : Contacts.h
  • ContactsReleaseHandle() : Contacts.h
  • ContactsRenameCustomLabel() : Contacts.h
  • contactsRingtoneInfo : Contacts.h
  • ContactsSeekBackward : Contacts.h
  • ContactsSeekForward : Contacts.h
  • ContactsSeekRecord() : Contacts.h
  • ContactsSession : Contacts.h
  • ContactsSetBinaryField() : Contacts.h
  • ContactsSetCategoryName() : Contacts.h
  • ContactsSetDateField() : Contacts.h
  • ContactsSetFieldLabel() : Contacts.h
  • ContactsSetStringField() : Contacts.h
  • ContactsSetUInt16Field() : Contacts.h
  • ContactsSetUInt8Field() : Contacts.h
  • contactsState1 : Contacts.h
  • contactsState2 : Contacts.h
  • contactsState3 : Contacts.h
  • contactsStrAddress1 : Contacts.h
  • contactsStrAddress2 : Contacts.h
  • contactsStrAddress3 : Contacts.h
  • contactsStrChat1 : Contacts.h
  • contactsStrChat2 : Contacts.h
  • contactsStrCity1 : Contacts.h
  • contactsStrCity2 : Contacts.h
  • contactsStrCity3 : Contacts.h
  • contactsStrCompany : Contacts.h
  • contactsStrCountry1 : Contacts.h
  • contactsStrCountry2 : Contacts.h
  • contactsStrCountry3 : Contacts.h
  • contactsStrCustom1 : Contacts.h
  • contactsStrCustom2 : Contacts.h
  • contactsStrCustom3 : Contacts.h
  • contactsStrCustom4 : Contacts.h
  • contactsStrCustom5 : Contacts.h
  • contactsStrCustom6 : Contacts.h
  • contactsStrCustom7 : Contacts.h
  • contactsStrCustom8 : Contacts.h
  • contactsStrCustom9 : Contacts.h
  • contactsStrFirstName : Contacts.h
  • contactsStrLastName : Contacts.h
  • contactsStrNote : Contacts.h
  • contactsStrPhone1 : Contacts.h
  • contactsStrPhone2 : Contacts.h
  • contactsStrPhone3 : Contacts.h
  • contactsStrPhone4 : Contacts.h
  • contactsStrPhone5 : Contacts.h
  • contactsStrPhone6 : Contacts.h
  • contactsStrPhone7 : Contacts.h
  • contactsStrState1 : Contacts.h
  • contactsStrState2 : Contacts.h
  • contactsStrState3 : Contacts.h
  • contactsStrTitle : Contacts.h
  • contactsStrWebpage : Contacts.h
  • contactsStrZipCode1 : Contacts.h
  • contactsStrZipCode2 : Contacts.h
  • contactsStrZipCode3 : Contacts.h
  • contactsTitle : Contacts.h
  • contactsUInt16Category : Contacts.h
  • contactsUInt16Index : Contacts.h
  • contactsUInt32UniqueID : Contacts.h
  • contactsUInt8AnniversaryMask : Contacts.h
  • contactsUInt8AnniversaryPreset : Contacts.h
  • contactsUInt8BirthdayMask : Contacts.h
  • contactsUInt8BirthdayPreset : Contacts.h
  • contactsUInt8Busy : Contacts.h
  • contactsUInt8Dirty : Contacts.h
  • contactsUInt8Private : Contacts.h
  • ContactsUnfiledCategory : Contacts.h
  • contactsUniqueID : Contacts.h
  • ContactsUpdateContact() : Contacts.h
  • contactsWebpage : Contacts.h
  • contactsWithLabelAddress1 : Contacts.h
  • contactsWithLabelAddress2 : Contacts.h
  • contactsWithLabelAddress3 : Contacts.h
  • contactsWithLabelChat1 : Contacts.h
  • contactsWithLabelChat2 : Contacts.h
  • contactsWithLabelPhone1 : Contacts.h
  • contactsWithLabelPhone2 : Contacts.h
  • contactsWithLabelPhone3 : Contacts.h
  • contactsWithLabelPhone4 : Contacts.h
  • contactsWithLabelPhone5 : Contacts.h
  • contactsWithLabelPhone6 : Contacts.h
  • contactsWithLabelPhone7 : Contacts.h
  • contactsWorkAddress : Contacts.h
  • contactsWorkPhone : Contacts.h
  • contactsYahooChat : Contacts.h
  • contactsZipCode1 : Contacts.h
  • contactsZipCode2 : Contacts.h
  • contactsZipCode3 : Contacts.h
  • ContinuePowerOnOffCallback : HsPhoneEvent.h
  • CopyMIDIToneIdentifier : TonesLibTypes.h
  • CopyToneIdentifier : TonesLibTypes.h
  • csdConnection : HsPhoneMiscTypes.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:38 2008 for Palm API Guide


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- d -

  • dataLinks : PalmVMPlugin.h
  • DateBookCompAttachFucPtr : DatebookLibCommon.h
  • dbCacheFlag : PmPalmOSNVFS.h
  • DEFAULTHELPERLIB_TRAP : DefaultHelperLib.h
  • DefaultHelperLibClose() : DefaultHelperLib.h
  • defaultHelperLibCreator : DefaultHelperLibTypes.h
  • defaultHelperLibErrBadParams : DefaultHelperLibTypes.h
  • defaultHelperLibErrClass : DefaultHelperLibTypes.h
  • defaultHelperLibErrCreateDBFailed : DefaultHelperLibTypes.h
  • defaultHelperLibErrDBNotFound : DefaultHelperLibTypes.h
  • defaultHelperLibErrDBWriteFailed : DefaultHelperLibTypes.h
  • defaultHelperLibErrNoHelperApp : DefaultHelperLibTypes.h
  • defaultHelperLibErrNoMemory : DefaultHelperLibTypes.h
  • defaultHelperLibErrUserCancel : DefaultHelperLibTypes.h
  • DefaultHelperLibGetDefaultHelper() : DefaultHelperLib.h
  • defaultHelperLibName : DefaultHelperLibTypes.h
  • DefaultHelperLibOpen() : DefaultHelperLib.h
  • DefaultHelperLibSetDefaultHelper() : DefaultHelperLib.h
  • DefaultHelperLibSleep() : DefaultHelperLib.h
  • defaultHelperLibTrapGetDefaultHelper : DefaultHelperLibTypes.h
  • defaultHelperLibTrapSetDefaultHelper : DefaultHelperLibTypes.h
  • defaultHelperLibType : DefaultHelperLibTypes.h
  • DefaultHelperLibWake() : DefaultHelperLib.h
  • defaultType : HsPhoneEvent.h
  • DeleteObjectProc : HtmlLib68K.h
  • Delta11BitMap : SmartTextEngineRsc.h
  • Delta14BitMap : SmartTextEngineRsc.h
  • densityFtrCreator : palmOneFeatures.h
  • densityFtrVersion : palmOneFeatures.h
  • devAppLaunchCmdCallerId : PalmLaunchCodes.h
  • devAppLaunchCmdCustomBase : PalmLaunchCodes.h
  • devAppLaunchCmdGenericCall : PalmLaunchCodes.h
  • devAppLaunchCmdIncomingCall : PalmLaunchCodes.h
  • devAppLaunchCmdIncomingCallTest : PalmLaunchCodes.h
  • devAppLaunchCmdSliderClosed : PalmLaunchCodes.h
  • devAppLaunchCmdSliderOpened : PalmLaunchCodes.h
  • devAppLaunchCmdTelPowerOn : PalmLaunchCodes.h
  • devAppLaunchGenericCallOpCustomBase : PalmLaunchCodes.h
  • devAppLaunchGenericCallOpExit : PalmLaunchCodes.h
  • devAppLaunchGenericCallOpReturn : PalmLaunchCodes.h
  • devAppLaunchGenericCallOpSubcall : PalmLaunchCodes.h
  • devAppLaunchGenericCallRetAccepted : PalmLaunchCodes.h
  • devAppLaunchGenericCallRetRejected : PalmLaunchCodes.h
  • devAppLaunchLauncherDUBegin : PalmLaunchCodes.h
  • devAppLaunchLauncherDUEnd : PalmLaunchCodes.h
  • devAppLaunchLPCM_DUBegin : PalmLaunchCodes.h
  • devAppLaunchLPCM_DUEnd : PalmLaunchCodes.h
  • devAppLaunchMyFavorite : PalmLaunchCodes.h
  • devAppLaunchWithCodeCheck : PalmLaunchCodes.h
  • dexFtrNumVersion : PalmDisplayExtent.h
  • DexGetDisplayAddress() : PalmDisplayExtent.h
  • DexGetDisplayDimensions() : PalmDisplayExtent.h
  • dexLibCreator : PalmDisplayExtent.h
  • dexLibName : PalmDisplayExtent.h
  • dexLibType : PalmDisplayExtent.h
  • discardType0 : HsPhoneEvent.h
  • DmSyncDatabase() : PmPalmOSNVFS.h
  • DoFontDialog() : palmOneVMFontLib.h
  • dpiFtrValue : palmOneFeatures.h
  • DRM_ER_LC : palmOneCodecFormat.h
  • DSTType : LocsLibCommon.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:38 2008 for Palm API Guide


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- e -

  • eDbgUpdateNone : HsPhoneEvent.h
  • eDbgUpdateQuit : HsPhoneEvent.h
  • eDbgUpdateYes : HsPhoneEvent.h
  • ENCRYPTED_DATABASE : CarrierCustomLib.h
  • END_OF_LIST : PalmNetServices.h
  • ENHANCED_TX_POWER : PalmWiFiCommon.h
  • ePmConnectorAudioInputSettingsType : PmConnectorLibCommon.h
  • ePmConnectorAudioOutputSettingsType : PmConnectorLibCommon.h
  • ePmConnectorDeviceState : PmConnectorLibCommon.h
  • ER_LC : palmOneCodecFormat.h
  • ER_LTP : palmOneCodecFormat.h
  • Err : PalmNative.h
  • errCam : CameraLibCommon.h
  • errCamNoFrame : CameraLibCommon.h
  • errCamOverflow : CameraLibCommon.h
  • errCamWriteFailed : CameraLibCommon.h
  • errInPreviewMode : CameraLibCommon.h
  • errInvalidAddress : CameraLibCommon.h
  • errNetInterfaceNotFound : PalmWiFiCommon.h
  • errNetLibMissing : PalmWiFiCommon.h
  • errNetOutOfMemory : PalmWiFiCommon.h
  • errNetQueryBufTooSmall : PalmWiFiCommon.h
  • ESS : PalmWiFiCommon.h
  • exFileCArcSoftCamera : HsCreators.h
  • exFileCArcSoftMedia : HsCreators.h
  • exgRegEditCreatorID : FileBrowserLibCommon.h
  • exgRegEditExtensionID : FileBrowserLibCommon.h
  • exgRegEditTypeID : FileBrowserLibCommon.h
  • expCapabilityHidden : PmPalmOSNVFS.h
  • expCapabilityNonRemovable : PmPalmOSNVFS.h
  • expIncludePrivateSlots : PmPalmOSNVFS.h
  • expMediaType_HD : palmOneCreators.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:38 2008 for Palm API Guide


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- f -

  • false : PalmNative.h
  • FAR_CALL : FarCall.h
  • FAR_DECLARE : FarCall.h
  • FAR_PTR : FarCall.h
  • FavDBLibClose() : FavoritesDBLib.h
  • FavDBLibGetRecordId() : FavoritesDBLib.h
  • FavDBLibGetRecordLabel() : FavoritesDBLib.h
  • FavDBLibGetSpeedDialInfo() : FavoritesDBLib.h
  • FavDBLibIsFavoriteWithId() : FavoritesDBLib.h
  • FavDBLibLookupInSpeedDialDB() : FavoritesDBLib.h
  • FavDBLibNewAppFavorite() : FavoritesDBLib.h
  • FavDBLibNewEmailFavorite() : FavoritesDBLib.h
  • FavDBLibNewMsgFavorite() : FavoritesDBLib.h
  • FavDBLibNewPhoneFavorite() : FavoritesDBLib.h
  • FavDBLibNewPhoneViewFavorite() : FavoritesDBLib.h
  • FavDBLibNewWebFavorite() : FavoritesDBLib.h
  • FavDBLibOpen() : FavoritesDBLib.h
  • favDBLibPhoneViewCallLog : FavoritesDBLib.h
  • favDBLibPhoneViewContacts : FavoritesDBLib.h
  • favDBLibPhoneViewDialPad : FavoritesDBLib.h
  • FavDBLibPhoneViewEnum : FavoritesDBLib.h
  • FavDBLibResolveAddress() : FavoritesDBLib.h
  • FavDBLibSeekSpeedDialRecord() : FavoritesDBLib.h
  • FavDBLibSleep() : FavoritesDBLib.h
  • FavDBLibWake() : FavoritesDBLib.h
  • favoritesDBLibCreator : FavoritesDBLibTypes.h
  • favoritesDBLibErrBadParams : FavoritesDBLibTypes.h
  • favoritesDBLibErrClass : FavoritesDBLibTypes.h
  • favoritesDBLibErrCreateDBFailed : FavoritesDBLibTypes.h
  • favoritesDBLibErrDBNotFound : FavoritesDBLibTypes.h
  • favoritesDBLibErrDBWriteFailed : FavoritesDBLibTypes.h
  • favoritesDBLibErrNoMemory : FavoritesDBLibTypes.h
  • favoritesDBLibErrUserCancel : FavoritesDBLibTypes.h
  • favoritesDBLibIsFavoriteWithId : FavoritesDBLibTypes.h
  • favoritesDBLibName : FavoritesDBLibTypes.h
  • favoritesDBLibTrapGetRecordId : FavoritesDBLibTypes.h
  • favoritesDBLibTrapGetRecordLabel : FavoritesDBLibTypes.h
  • favoritesDBLibTrapGetSpeedDialInfo : FavoritesDBLibTypes.h
  • favoritesDBLibTrapLookupInSpeedDialDB : FavoritesDBLibTypes.h
  • favoritesDBLibTrapNewAppFavorite : FavoritesDBLibTypes.h
  • favoritesDBLibTrapNewEmailFavorite : FavoritesDBLibTypes.h
  • favoritesDBLibTrapNewMsgFavorite : FavoritesDBLibTypes.h
  • favoritesDBLibTrapNewPhoneFavorite : FavoritesDBLibTypes.h
  • favoritesDBLibTrapNewPhoneViewFavorite : FavoritesDBLibTypes.h
  • favoritesDBLibTrapNewWebFavorite : FavoritesDBLibTypes.h
  • favoritesDBLibTrapResolveAddress : FavoritesDBLibTypes.h
  • favoritesDBLibTrapSeekSpeedDialRecord : FavoritesDBLibTypes.h
  • favoritesDBLibType : FavoritesDBLibTypes.h
  • FILE_BROWSER_LIB_TRAP : FileBrowserLib68K.h
  • FileBrowserLibAccept() : FileBrowserLib68K.h
  • FileBrowserLibClose() : FileBrowserLib68K.h
  • FileBrowserLibConnect() : FileBrowserLib68K.h
  • FileBrowserLibControl() : FileBrowserLib68K.h
  • FileBrowserLibDisconnect() : FileBrowserLib68K.h
  • FileBrowserLibGet() : FileBrowserLib68K.h
  • FileBrowserLibHandleEvent() : FileBrowserLib68K.h
  • FileBrowserLibOpen() : FileBrowserLib68K.h
  • FileBrowserLibParseFileURL() : FileBrowserLib68K.h
  • FileBrowserLibPut() : FileBrowserLib68K.h
  • FileBrowserLibReceive() : FileBrowserLib68K.h
  • FileBrowserLibRequest() : FileBrowserLib68K.h
  • FileBrowserLibSend() : FileBrowserLib68K.h
  • FileBrowserLibShowMultiselectDialog() : FileBrowserLib68K.h
  • FileBrowserLibShowOpenDialog() : FileBrowserLib68K.h
  • FileBrowserLibShowSaveAsDialog() : FileBrowserLib68K.h
  • FileBrowserLibSleep() : FileBrowserLib68K.h
  • FileBrowserLibWake() : FileBrowserLib68K.h
  • FileFlag : palmOneCodecFormat.h
  • FileStream : palmOneCodecFormat.h
  • flTrapAPIClearCache : VMFontLibCommon.h
  • flTrapAPIDoFontDialog : VMFontLibCommon.h
  • flTrapAPIFontCountStyleAndSize : VMFontLibCommon.h
  • flTrapAPIFontExists : VMFontLibCommon.h
  • flTrapAPIFontToString : VMFontLibCommon.h
  • flTrapAPIGetFont : VMFontLibCommon.h
  • flTrapAPIGetFontByID : VMFontLibCommon.h
  • flTrapAPIInitFontUI : VMFontLibCommon.h
  • flTrapAPISetFontUIRules : VMFontLibCommon.h
  • flTrapAPIVersion : VMFontLibCommon.h
  • fontPickerCreatorID : VMFontLibCommon.h
  • fontPickerLibName : VMFontLibCommon.h
  • fontPickerType : VMFontLibCommon.h
  • formNavRscType : HsNavCommon.h
  • FrmCountObjectsInNavOrder() : HsNav.h
  • FrmGetNavEntry() : HsNav.h
  • FrmGetNavOrder() : HsNav.h
  • FrmGetNavState() : HsNav.h
  • FrmNavDrawFocusRing() : HsNav.h
  • frmNavFocusRingNoExtraInfo : HsNavCommon.h
  • FrmNavFocusRingStyleEnum : HsNavCommon.h
  • FrmNavFocusRingStyleEnumTag : HsNavCommon.h
  • frmNavFocusRingStyleHorizontalBars : HsNavCommon.h
  • frmNavFocusRingStyleInvalid : HsNavCommon.h
  • frmNavFocusRingStyleObjectTypeDefault : HsNavCommon.h
  • frmNavFocusRingStyleRound : HsNavCommon.h
  • frmNavFocusRingStyleSquare : HsNavCommon.h
  • FrmNavGetFocusRingInfo() : HsNav.h
  • FrmNavHeaderFlagsType : HsNavCommon.h
  • FrmNavHeaderType : HsNavCommon.h
  • FrmNavObjectFlagsType : HsNavCommon.h
  • FrmNavObjectTakeFocus() : HsNav.h
  • FrmNavOrderEntryType : HsNavCommon.h
  • FrmNavRemoveFocusRing() : HsNav.h
  • FrmNavStateFlagsType : HsNavCommon.h
  • FrmSetNavEntry() : HsNav.h
  • FrmSetNavOrder() : HsNav.h
  • FrmSetNavState() : HsNav.h
  • Full16bitTextHeader : HsPhoneSMSTypes.h
  • Full8bitTextHeader : HsPhoneSMSTypes.h
  • FULL_TX_POWER : PalmWiFiCommon.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:38 2008 for Palm API Guide


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- g -

  • Gamma11BitMap : SmartTextEngineRsc.h
  • Gamma14BitMap : SmartTextEngineRsc.h
  • gillSans : VMFontLibCommon.h
  • goLcdColorDefault : PalmGoLCDCommon.h
  • goLcdColorInverted : PalmGoLCDCommon.h
  • GoLcdColorModeType : PalmGoLCDCommon.h
  • goLcdColorOverride : PalmGoLCDCommon.h
  • goLcdCreator : PalmGoLCDCommon.h
  • goLcdDisabled : PalmGoLCDCommon.h
  • goLcdEnabled : PalmGoLCDCommon.h
  • goLcdFtrNumVersion : PalmGoLCDCommon.h
  • GoLcdGetBounds() : PalmGoLCD.h
  • GoLcdGetGsiState() : PalmGoLCD.h
  • GoLcdGetInkState() : PalmGoLCD.h
  • GoLcdGetStatus() : PalmGoLCD.h
  • GoLcdGetTimeout() : PalmGoLCD.h
  • goLcdGraffitiMode : PalmGoLCDCommon.h
  • goLcdGsiNormal : PalmGoLCDCommon.h
  • goLcdGsiOverride : PalmGoLCDCommon.h
  • GoLcdGsiStateType : PalmGoLCDCommon.h
  • goLcdInkDisabled : PalmGoLCDCommon.h
  • goLcdInkEnabled : PalmGoLCDCommon.h
  • GoLcdInkStateType : PalmGoLCDCommon.h
  • GoLcdLibAPIVersion : PalmGoLCDCommon.h
  • GoLcdLibClose() : PalmGoLCD.h
  • goLcdLibCreator : PalmGoLCDCommon.h
  • goLcdLibFtrNum : PalmGoLCDCommon.h
  • goLcdLibName : PalmGoLCDCommon.h
  • GoLcdLibOpen() : PalmGoLCD.h
  • goLcdLibType : PalmGoLCDCommon.h
  • goLcdModeCount : PalmGoLCDCommon.h
  • GoLcdModeType : PalmGoLCDCommon.h
  • goLcdNotAvailable : PalmGoLCDCommon.h
  • goLcdNotifyStatusEvent : PalmGoLCDCommon.h
  • goLcdPenTapMode : PalmGoLCDCommon.h
  • GoLcdSetBounds() : PalmGoLCD.h
  • GoLcdSetGsiState() : PalmGoLCD.h
  • GoLcdSetInkState() : PalmGoLCD.h
  • GoLcdSetStatus() : PalmGoLCD.h
  • GoLcdSetTimeout() : PalmGoLCD.h
  • GoLcdStatusType : PalmGoLCDCommon.h
  • gprsConnection : HsPhoneMiscTypes.h
  • GSMATEventInputEchoModeEnum : HsPhoneGSMTypes.h
  • gsmCLIPNotProvisioned : HsPhoneNetworkTypes.h
  • gsmCLIPProvisioned : HsPhoneNetworkTypes.h
  • GSMCLIPStatus : HsPhoneNetworkTypes.h
  • gsmCLIPUnknown : HsPhoneNetworkTypes.h
  • GSMCLIRDisplayStatus : HsPhoneNetworkTypes.h
  • gsmCLIRInvocation : HsPhoneNetworkTypes.h
  • gsmCLIRSubscription : HsPhoneNetworkTypes.h
  • gsmCLIRSuppression : HsPhoneNetworkTypes.h
  • gsmDialCLIRDefault : HsPhoneTypes.h
  • GSMDialCLIRMode : HsPhoneTypes.h
  • gsmDialCLIRTemporaryInvocation : HsPhoneTypes.h
  • gsmDialCLIRTemporarySuppression : HsPhoneTypes.h
  • GSMLibRingsDBCreatorID : HsCreators.h
  • GSMLibRingsDbName : HsPhoneGSMTypes.h
  • GSMLockSelectorOperatorLock : HsPhoneGSMTypes.h
  • GSMLockSelectorProviderLock : HsPhoneGSMTypes.h
  • gsmMessagesCantReceive : HsPhoneGSMTypes.h
  • gsmMessagesConfirmMove : HsPhoneGSMTypes.h
  • GSMRegistrationMode : HsPhoneNetworkTypes.h
  • gsmRegModeAutomatic : HsPhoneNetworkTypes.h
  • gsmRegModeDeregister : HsPhoneNetworkTypes.h
  • gsmRegModeFormat : HsPhoneNetworkTypes.h
  • gsmRegModeManual : HsPhoneNetworkTypes.h
  • gsmRegModeManualAutomatic : HsPhoneNetworkTypes.h
  • GSMReserved10 : HsPhoneTraps.h
  • GSMReserved11 : HsPhoneTraps.h
  • GSMReserved12 : HsPhoneTraps.h
  • GSMReserved13 : HsPhoneTraps.h
  • GSMReserved14 : HsPhoneTraps.h
  • GSMReserved15 : HsPhoneTraps.h
  • GSMReserved16 : HsPhoneTraps.h
  • GSMReserved17 : HsPhoneTraps.h
  • GSMReserved18 : HsPhoneTraps.h
  • GSMReserved19 : HsPhoneTraps.h
  • GSMReserved20 : HsPhoneTraps.h
  • GSMReserved21 : HsPhoneTraps.h
  • GSMReserved22 : HsPhoneTraps.h
  • GSMReserved8 : HsPhoneTraps.h
  • GSMReserved9 : HsPhoneTraps.h
  • GSMSATDataSvcType : HsPhoneGSMTypes.h
  • GSMSATEventInputFormatEnum : HsPhoneGSMTypes.h
  • GSMSATEventMenuFlag : HsPhoneGSMTypes.h
  • GSMSATEventSetupCallCallTypeEnum : HsPhoneGSMTypes.h
  • GSMSATEventToneTimeUnitEnum : HsPhoneGSMTypes.h
  • GSMSATEventToneTypeEnum : HsPhoneGSMTypes.h
  • GSMSIMMessagesDialogKind : HsPhoneGSMTypes.h
  • GSMSIMStatus : HsPhoneTypes.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:38 2008 for Palm API Guide


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- h -

  • HALAttnGetPalmLedAttributes() : PalmLED.h
  • HALAttnSetPalmLedAttributes() : PalmLED.h
  • HE_AAC : palmOneCodecFormat.h
  • headsetFtrCreator : palmOneFeatures.h
  • headsetFtrVersion : palmOneFeatures.h
  • HelperEnumerateEnqueueEntry : HsHelper.h
  • HelperServiceMMSDetailsType : MmsHelperCommon.h
  • HelperServiceMMSObjectType : MmsHelperCommon.h
  • HRTimeLibClose() : palmOneHiResTimer.h , PalmHiResTime.h
  • HRTimeLibGetTime() : palmOneHiResTimer.h , PalmHiResTime.h
  • HRTimeLibOpen() : palmOneHiResTimer.h , PalmHiResTime.h
  • HRTimeLibTicksPerSecond() : palmOneHiResTimer.h , PalmHiResTime.h
  • HS_AC97 : HsSoundLibCommon.h
  • HS_HTTPLibAppInfo : HS_HTTPLibApp.h
  • HS_HTTPLibAuthCacheGetChallengeTokenSS() : HS_HTTPLib68K.h
  • HS_HTTPLibAuthInfo : HS_HTTPLib68K.h
  • HS_HTTPLibAuthInfoPass() : HS_HTTPLib68K.h
  • HS_HTTPLibAuthInfoRealm() : HS_HTTPLib68K.h
  • HS_HTTPLibAuthInfoTidy() : HS_HTTPLib68K.h
  • HS_HTTPLibAuthInfoUser() : HS_HTTPLib68K.h
  • HS_HTTPLibCertBeginPeekIssuerRDN() : HS_HTTPLib68K.h
  • HS_HTTPLibCertBeginPeekSubjectRDN() : HS_HTTPLib68K.h
  • HS_HTTPLibCertEndPeekIssuerRDN() : HS_HTTPLib68K.h
  • HS_HTTPLibCertEndPeekSubjectRDN() : HS_HTTPLib68K.h
  • HS_HTTPLibCertList : HS_HTTPLib68K.h
  • HS_HTTPLibCertListBeginDecode() : HS_HTTPLib68K.h
  • HS_HTTPLibCertListClone() : HS_HTTPLib68K.h
  • HS_HTTPLibCertListDelete() : HS_HTTPLib68K.h
  • HS_HTTPLibCertListEndDecode() : HS_HTTPLib68K.h
  • HS_HTTPLibCertListGetCipherInfo() : HS_HTTPLib68K.h
  • HS_HTTPLibCertListImportCert() : HS_HTTPLib68K.h
  • HS_HTTPLibCertListLength() : HS_HTTPLib68K.h
  • HS_HTTPLibCertListLock() : HS_HTTPLib68K.h
  • HS_HTTPLibCertListNew() : HS_HTTPLib68K.h
  • HS_HTTPLibCertListType() : HS_HTTPLib68K.h
  • HS_HTTPLibCertListUnlock() : HS_HTTPLib68K.h
  • HS_HTTPLibCertPeekIssuerRDN() : HS_HTTPLib68K.h
  • HS_HTTPLibCertPeekIssuerRDNStrType() : HS_HTTPLib68K.h
  • HS_HTTPLibCertPeekRSAPublicKeyBits() : HS_HTTPLib68K.h
  • HS_HTTPLibCertPeekSerialNumber() : HS_HTTPLib68K.h
  • HS_HTTPLibCertPeekSignAlgo() : HS_HTTPLib68K.h
  • HS_HTTPLibCertPeekSubjectRDN() : HS_HTTPLib68K.h
  • HS_HTTPLibCertPeekSubjectRDNStrType() : HS_HTTPLib68K.h
  • HS_HTTPLibCertPeekValidityEnd() : HS_HTTPLib68K.h
  • HS_HTTPLibCertPeekValidityStart() : HS_HTTPLib68K.h
  • HS_HTTPLibCertPeekVersion() : HS_HTTPLib68K.h
  • HS_HTTPLibCertPtr : HS_HTTPLib68K.h
  • HS_HTTPLibClearDNSCache() : HS_HTTPLib68K.h
  • HS_HTTPLibClientCertList : HS_HTTPLib68K.h
  • HS_HTTPLibClientCertListClone() : HS_HTTPLib68K.h
  • HS_HTTPLibClientCertListDelete() : HS_HTTPLib68K.h
  • HS_HTTPLibClientCertListIsValid() : HS_HTTPLib68K.h
  • HS_HTTPLibClientCertListLength() : HS_HTTPLib68K.h
  • HS_HTTPLibClientCertListNew() : HS_HTTPLib68K.h
  • HS_HTTPLibClientCertListSetValid() : HS_HTTPLib68K.h
  • HS_HTTPLibClientCertSelect() : HS_HTTPLib68K.h
  • HS_HTTPLibClientCertSelectProc : HS_HTTPLib68K.h
  • HS_HTTPLibClose() : HS_HTTPLib68K.h
  • HS_HTTPLibCloseAllKeepAlive() : HS_HTTPLib68K.h
  • HS_HTTPLibCookieConfirmProc : HS_HTTPLib68K.h
  • HS_HTTPLibCookieMakeEmpty() : HS_HTTPLib68K.h
  • HS_HTTPLibCookies : HS_HTTPLib68K.h
  • HS_HTTPLibDataHandle : HS_HTTPLib68K.h
  • HS_HTTPLibDataHandle_Delete() : HS_HTTPLib68K.h
  • HS_HTTPLibDataHandle_Length() : HS_HTTPLib68K.h
  • HS_HTTPLibDataHandle_Lock() : HS_HTTPLib68K.h
  • HS_HTTPLibDataHandle_Unlock() : HS_HTTPLib68K.h
  • HS_HTTPLibDBType : HS_HTTPLibApp.h
  • HS_HTTPLibFinalize() : HS_HTTPLib68K.h
  • HS_HTTPLibFindAuthCandidate() : HS_HTTPLib68K.h
  • HS_HTTPLibFindAuthInfo() : HS_HTTPLib68K.h
  • HS_HTTPLibFixedString : HS_HTTPLib68K.h
  • HS_HTTPLibFixedString_Delete() : HS_HTTPLib68K.h
  • HS_HTTPLibFixedString_Length() : HS_HTTPLib68K.h
  • HS_HTTPLibFixedString_Lock() : HS_HTTPLib68K.h
  • HS_HTTPLibFixedString_Unlock() : HS_HTTPLib68K.h
  • HS_HTTPLibFixedStringNew() : HS_HTTPLib68K.h
  • HS_HTTPLibHandle : HS_HTTPLibApp.h
  • HS_HTTPLibHeaderSplitByX() : HS_HTTPLib68K.h
  • HS_HTTPLibID : HS_HTTPLibApp.h
  • HS_HTTPLibInitialize() : HS_HTTPLib68K.h
  • HS_HTTPLibIPAddr : HS_HTTPLibApp.h
  • HS_HTTPLibIsHTTP11OverProxy() : HS_HTTPLib68K.h
  • HS_HTTPLibIsSendCookie() : HS_HTTPLib68K.h
  • HS_HTTPLibIsSendReferer() : HS_HTTPLib68K.h
  • HS_HTTPLibIsUseProxy() : HS_HTTPLib68K.h
  • HS_HTTPLibLoadCookiesEntries() : HS_HTTPLib68K.h
  • HS_HTTPLibMakeAuthInfo() : HS_HTTPLib68K.h
  • HS_HTTPLibMakeCertList() : HS_HTTPLib68K.h
  • HS_HTTPLibMakeCookiesString() : HS_HTTPLib68K.h
  • HS_HTTPLibMakeProxy() : HS_HTTPLib68K.h
  • HS_HTTPLibName : HS_HTTPLibApp.h
  • HS_HTTPLibNetLibCloseProc : HS_HTTPLibApp.h
  • HS_HTTPLibNetLibInfo : HS_HTTPLibApp.h
  • HS_HTTPLibNetLibOfflineProc : HS_HTTPLibApp.h
  • HS_HTTPLibNetLibOnlineProc : HS_HTTPLibApp.h
  • HS_HTTPLibNetLibOpenProc : HS_HTTPLibApp.h
  • HS_HTTPLibOpaque : HS_HTTPLibApp.h
  • HS_HTTPLibOpen() : HS_HTTPLib68K.h
  • HS_HTTPLibOpenCount() : HS_HTTPLib68K.h
  • HS_HTTPLibPeer : HS_HTTPLibApp.h
  • HS_HTTPLibRegisterSSLClass() : HS_HTTPLib68K.h
  • HS_HTTPLibSaveCookiesEntries() : HS_HTTPLib68K.h
  • HS_HTTPLibServerCertConfirm() : HS_HTTPLib68K.h
  • HS_HTTPLibServerCertConfirmProc : HS_HTTPLib68K.h
  • HS_HTTPLibSetConnectTimeOut() : HS_HTTPLib68K.h
  • HS_HTTPLibSetCookie() : HS_HTTPLib68K.h
  • HS_HTTPLibSetCookieMax() : HS_HTTPLib68K.h
  • HS_HTTPLibSetCookieMode() : HS_HTTPLib68K.h
  • HS_HTTPLibSetCookieX() : HS_HTTPLib68K.h
  • HS_HTTPLibSetDefaultHeaders() : HS_HTTPLib68K.h
  • HS_HTTPLibSetDNSMaxRetry() : HS_HTTPLib68K.h
  • HS_HTTPLibSetDNSRetryInterval() : HS_HTTPLib68K.h
  • HS_HTTPLibSetHTTP11OverProxy() : HS_HTTPLib68K.h
  • HS_HTTPLibSetHTTPPort() : HS_HTTPLib68K.h
  • HS_HTTPLibSetHTTPSPort() : HS_HTTPLib68K.h
  • HS_HTTPLibSetMaxKeepAliveTimeout() : HS_HTTPLib68K.h
  • HS_HTTPLibSetMaxRequestBody() : HS_HTTPLib68K.h
  • HS_HTTPLibSetMaxRequestHeader() : HS_HTTPLib68K.h
  • HS_HTTPLibSetNetLibProc() : HS_HTTPLib68K.h
  • HS_HTTPLibSetProxy() : HS_HTTPLib68K.h
  • HS_HTTPLibSetReqTimeOut() : HS_HTTPLib68K.h
  • HS_HTTPLibSetRspTimeOut() : HS_HTTPLib68K.h
  • HS_HTTPLibSetSendCookie() : HS_HTTPLib68K.h
  • HS_HTTPLibSetSendProxyKeepAlive() : HS_HTTPLib68K.h
  • HS_HTTPLibSetSendReferer() : HS_HTTPLib68K.h
  • HS_HTTPLibSetSSLClientCertSelectProc() : HS_HTTPLib68K.h
  • HS_HTTPLibSetSSLServerCertConfirmProc() : HS_HTTPLib68K.h
  • HS_HTTPLibSetSSLVersionFlag() : HS_HTTPLib68K.h
  • HS_HTTPLibSetTunnelingCallback() : HS_HTTPLib68K.h
  • HS_HTTPLibSetUseProxy() : HS_HTTPLib68K.h
  • HS_HTTPLibSetUserAgent() : HS_HTTPLib68K.h
  • HS_HTTPLibSetUseragentSelectionRule() : HS_HTTPLib68K.h
  • HS_HTTPLibSetUserPass() : HS_HTTPLib68K.h
  • HS_HTTPLibSetUserPassX() : HS_HTTPLib68K.h
  • HS_HTTPLibSetWakeUpCallback() : HS_HTTPLib68K.h
  • HS_HTTPLibSleep() : HS_HTTPLib68K.h
  • HS_HTTPLibSplit : HS_HTTPLib68K.h
  • HS_HTTPLibSSL : HS_HTTPLib68K.h
  • HS_HTTPLibSSLClass() : HS_HTTPLib68K.h
  • HS_HTTPLibSSLClassPtr : HS_HTTPLib68K.h
  • HS_HTTPLibSSLCloseCertDB() : HS_HTTPLib68K.h
  • HS_HTTPLibSSLOpenCertDB() : HS_HTTPLib68K.h
  • HS_HTTPLibSSLTimeout() : HS_HTTPLib68K.h
  • HS_HTTPLibStream : HS_HTTPLib68K.h
  • HS_HTTPLibStreamAddHeader() : HS_HTTPLib68K.h
  • HS_HTTPLibStreamAddHeaderLine() : HS_HTTPLib68K.h
  • HS_HTTPLibStreamClose() : HS_HTTPLib68K.h
  • HS_HTTPLibStreamCreateRequest() : HS_HTTPLib68K.h
  • HS_HTTPLibStreamCreateRequestWithChunkEncoding() : HS_HTTPLib68K.h
  • HS_HTTPLibStreamDelete() : HS_HTTPLib68K.h
  • HS_HTTPLibStreamGetContentLength() : HS_HTTPLib68K.h
  • HS_HTTPLibStreamGetEntityLength() : HS_HTTPLib68K.h
  • HS_HTTPLibStreamGetFlag() : HS_HTTPLib68K.h
  • HS_HTTPLibStreamGetHeader() : HS_HTTPLib68K.h
  • HS_HTTPLibStreamGetHeaderWithOffset() : HS_HTTPLib68K.h
  • HS_HTTPLibStreamGetRequestSent() : HS_HTTPLib68K.h
  • HS_HTTPLibStreamGetResponseHeader() : HS_HTTPLib68K.h
  • HS_HTTPLibStreamGetResponseHeaderLength() : HS_HTTPLib68K.h
  • HS_HTTPLibStreamGetScheme() : HS_HTTPLib68K.h
  • HS_HTTPLibStreamGetState() : HS_HTTPLib68K.h
  • HS_HTTPLibStreamGetStatusCode() : HS_HTTPLib68K.h
  • HS_HTTPLibStreamIsHeaderReceived() : HS_HTTPLib68K.h
  • HS_HTTPLibStreamNew() : HS_HTTPLib68K.h
  • HS_HTTPLibStreamReceiveResponse() : HS_HTTPLib68K.h
  • HS_HTTPLibStreamResumeTimer() : HS_HTTPLib68K.h
  • HS_HTTPLibStreamSendRequest() : HS_HTTPLib68K.h
  • HS_HTTPLibStreamSendRequestWithChunkEncoding() : HS_HTTPLib68K.h
  • HS_HTTPLibStreamSendRequestWithPostData() : HS_HTTPLib68K.h
  • HS_HTTPLibStreamSetPostData() : HS_HTTPLib68K.h
  • HS_HTTPLibStreamSuspendTimer() : HS_HTTPLib68K.h
  • HS_HTTPLibString : HS_HTTPLib68K.h
  • HS_HTTPLibString_Delete() : HS_HTTPLib68K.h
  • HS_HTTPLibString_Length() : HS_HTTPLib68K.h
  • HS_HTTPLibString_Lock() : HS_HTTPLib68K.h
  • HS_HTTPLibString_Unlock() : HS_HTTPLib68K.h
  • HS_HTTPLibStringNew() : HS_HTTPLib68K.h
  • HS_HTTPLibTime : HS_HTTPLib68K.h
  • HS_HTTPLibTunnelingCallbackProc : HS_HTTPLib68K.h
  • HS_HTTPLibURLString : HS_HTTPLib68K.h
  • HS_HTTPLibURLString_Delete() : HS_HTTPLib68K.h
  • HS_HTTPLibURLString_Length() : HS_HTTPLib68K.h
  • HS_HTTPLibURLString_Lock() : HS_HTTPLib68K.h
  • HS_HTTPLibURLString_Unlock() : HS_HTTPLib68K.h
  • HS_HTTPLibURLStringNew() : HS_HTTPLib68K.h
  • HS_HTTPLibVHandle : HS_HTTPLib68K.h
  • HS_HTTPLibVHandle_Delete() : HS_HTTPLib68K.h
  • HS_HTTPLibVHandle_Length() : HS_HTTPLib68K.h
  • HS_HTTPLibVHandle_Lock() : HS_HTTPLib68K.h
  • HS_HTTPLibVHandle_Unlock() : HS_HTTPLib68K.h
  • HS_HTTPLibWake() : HS_HTTPLib68K.h
  • HS_HTTPLibWakeUpCallbackProc : HS_HTTPLib68K.h
  • HS_RDIO : HsSoundLibCommon.h
  • HS_SND_ERR : HsSoundLibCommon.h
  • HS_TCPCanReadWritePeer : HS_HTTPLibApp.h
  • HS_TCPClosePeer : HS_HTTPLibApp.h
  • HS_TCPConnectPeer : HS_HTTPLibApp.h
  • HS_TCPIsConnectedPeer : HS_HTTPLibApp.h
  • HS_TCPOpenPeer : HS_HTTPLibApp.h
  • HS_TCPReadPeer : HS_HTTPLibApp.h
  • HS_TCPWritePeer : HS_HTTPLibApp.h
  • HsAboutHandspringApp() : HsExt.h
  • HsAboutHandspringAppWithYearCredId : HsExt.h
  • HsAboutHandspringAppWithYearId : HsExt.h
  • hsAmrDecLib : HsCreators.h
  • hsAmrEncLib : HsCreators.h
  • hsAmrLib : HsCreators.h
  • hsAppErrorClass : HsErrorClasses.h
  • hsAttr68KActiveCalls : HsExtCommon.h
  • hsAttr68KDisplayOn : HsExtCommon.h
  • hsAttr68KKeyboardLocked : HsExtCommon.h
  • hsAttr68KKeyLockNextWakeTicks : HsExtCommon.h
  • hsAttr68KLidOpen : HsExtCommon.h
  • hsAttr68KPhoneType : HsExtCommon.h
  • hsAttr68KPostProcessRsc : HsExtCommon.h
  • hsAttr68KRingSwitch : HsExtCommon.h
  • hsAttr68KSysActive : HsExtCommon.h
  • hsAttr68KSysSleepReason : HsExtCommon.h
  • hsAttrActiveCalls : HsExtCommon.h
  • hsAttrAllKeysWakeFromSleep : HsExtCommon.h
  • hsAttrDigitizerLock : HsExtCommon.h
  • hsAttrDisplayOn : HsExtCommon.h
  • hsAttrDitherSuppress : HsExtCommon.h
  • hsAttrE911Mode : HsExtCommon.h
  • HsAttrEnum : HsExtCommon.h
  • HsAttrGet() : HsExt.h
  • hsAttrHotSyncSuppress : HsExtCommon.h
  • hsAttrKeyboardDB : HsExtCommon.h
  • hsAttrKeyboardLocked : HsExtCommon.h
  • hsAttrKeyguardDialogOn : HsExtCommon.h
  • hsAttrKeyLockNextWakeTicks : HsExtCommon.h
  • hsAttrLidOpen : HsExtCommon.h
  • hsAttrPhoneRadioPowerState : HsExtCommon.h
  • hsAttrPhoneType : HsExtCommon.h
  • hsAttrPhoneTypeCDMA : HsExtCommon.h
  • hsAttrPhoneTypeGSM : HsExtCommon.h
  • hsAttrPostProcessRsc : HsExtCommon.h
  • hsAttrReserved_SDK20_1 : HsExtCommon.h
  • hsAttrReserved_SDK20_2 : HsExtCommon.h
  • hsAttrReserved_SDK20_3 : HsExtCommon.h
  • hsAttrReserved_SDK20_4 : HsExtCommon.h
  • hsAttrReserved_SDK20_5 : HsExtCommon.h
  • hsAttrReserved_SDK20_6 : HsExtCommon.h
  • hsAttrReserved_SDK20_7 : HsExtCommon.h
  • hsAttrRingSwitch : HsExtCommon.h
  • hsAttrRingSwitchLoud : HsExtCommon.h
  • hsAttrRingSwitchMute : HsExtCommon.h
  • HsAttrSet() : HsExt.h
  • hsAttrSysActive : HsExtCommon.h
  • hsAttrSysActiveBeamProgress : HsExtCommon.h
  • hsAttrSysActiveHotSync : HsExtCommon.h
  • hsAttrSysActiveProgress : HsExtCommon.h
  • hsAttrSysSleepReason : HsExtCommon.h
  • hsBigButtonFlagNoBackground : HsExtUtilBigButtonRsc.h
  • hsBigButtonFlagNoBorder : HsExtUtilBigButtonRsc.h
  • hsBigButtonFlagNoBorderOrBackground : HsExtUtilBigButtonRsc.h
  • hsBigButtonFlagNone : HsExtUtilBigButtonRsc.h
  • hsBigButtonFontBold : HsExtUtilBigButtonRsc.h
  • hsBigButtonFontLarge : HsExtUtilBigButtonRsc.h
  • hsBigButtonFontLargeBold : HsExtUtilBigButtonRsc.h
  • hsBigButtonFontLed : HsExtUtilBigButtonRsc.h
  • hsBigButtonFontStd : HsExtUtilBigButtonRsc.h
  • hsBigButtonFontSymbol : HsExtUtilBigButtonRsc.h
  • hsBigButtonFontSymbol11 : HsExtUtilBigButtonRsc.h
  • hsBigButtonFontSymbol7 : HsExtUtilBigButtonRsc.h
  • hsBigButtonMappingVersion0 : HsExtUtilBigButtonRsc.h
  • hsBigButtonRscType : HsExtUtilBigButtonCommon.h
  • hsBluetoothIdToken : HsCreators.h
  • HsBrowseUrl() : HsExt.h
  • hsCcpErrorClass : HsErrorClasses.h
  • hsChrAnswer : HsChars.h
  • hsChrDarkMode : HsChars.h
  • hsChrDeleteWord : HsChars.h
  • hsChrKeyboardLock : HsChars.h
  • hsChrLidStatusChg : HsChars.h
  • hsChrLowBatteryShutdown : HsChars.h
  • hsChrModifierKey : HsChars.h
  • hsChrMuteOff : HsChars.h
  • hsChrMuteOn : HsChars.h
  • hsChrNetMasterUIExecute : HsChars.h
  • hsChrNoop : HsChars.h
  • hsChrOptHard1 : HsChars.h
  • hsChrOptHard11 : HsChars.h
  • hsChrOptHard13 : HsChars.h
  • hsChrOptHard2 : HsChars.h
  • hsChrOptHard3 : HsChars.h
  • hsChrOptHard4 : HsChars.h
  • hsChrOptHardPower : HsChars.h
  • hsChrOptReserved : HsChars.h
  • hsChrPostProcess : HsChars.h
  • hsChrRadioPower : HsChars.h
  • hsChrRangeMax : HsChars.h
  • hsChrRangeMin : HsChars.h
  • hsChrRedialList : HsChars.h
  • hsChrReserved1622 : HsChars.h
  • hsChrShiftPageDown : HsChars.h
  • hsChrShiftPageUp : HsChars.h
  • hsChrShutdownNetlib : HsChars.h
  • hsChrSide : HsChars.h
  • hsChrSymbol : HsChars.h
  • hsChrVolumeDown : HsChars.h
  • hsChrVolumeUp : HsChars.h
  • hsChrWakeup : HsChars.h
  • hsCompressedDbCreatorId : HsCreators.h
  • hsCompressedDbTypeId : HsCreators.h
  • HsCreateNewEmail() : HsExt.h
  • HsCreateNewMessage() : HsExt.h
  • HsCurrentLightCircumstance() : HsExt.h
  • hsDeviceIDOs5Device1 : HsExtCommon.h
  • hsDeviceIDOs5Device1Sim : HsExtCommon.h
  • hsDeviceIDTreo180 : HsExtCommon.h
  • hsDeviceIDTreo270 : HsExtCommon.h
  • hsDeviceIDTreo300 : HsExtCommon.h
  • hsDeviceIDTreo600 : HsExtCommon.h
  • hsDeviceIDTreo600Sim : HsExtCommon.h
  • hsDeviceIDTreo90 : HsExtCommon.h
  • hsDeviceIDVisor : HsExtCommon.h
  • hsDeviceIDVisorEdge : HsExtCommon.h
  • hsDeviceIDVisorNeo : HsExtCommon.h
  • hsDeviceIDVisorPlatinum : HsExtCommon.h
  • hsDeviceIDVisorPrism : HsExtCommon.h
  • hsDeviceIDVisorPro : HsExtCommon.h
  • hsDialPrefs4DigitPrefixLength : HsAppLaunchCmd.h
  • hsDialPrefs5DigitPrefixLength : HsAppLaunchCmd.h
  • hsDialPrefs6DigitPrefixLength : HsAppLaunchCmd.h
  • hsDialPrefsAdd4DigitPrefixNo : HsAppLaunchCmd.h
  • hsDialPrefsAdd4DigitPrefixUnknown : HsAppLaunchCmd.h
  • hsDialPrefsAdd4DigitPrefixYes : HsAppLaunchCmd.h
  • hsDialPrefsAdd5DigitPrefixNo : HsAppLaunchCmd.h
  • hsDialPrefsAdd5DigitPrefixUnknown : HsAppLaunchCmd.h
  • hsDialPrefsAdd5DigitPrefixYes : HsAppLaunchCmd.h
  • hsDialPrefsAdd6DigitPrefixNo : HsAppLaunchCmd.h
  • hsDialPrefsAdd6DigitPrefixUnknown : HsAppLaunchCmd.h
  • hsDialPrefsAdd6DigitPrefixYes : HsAppLaunchCmd.h
  • hsDialPrefsAddAreaCodeNo : HsAppLaunchCmd.h
  • hsDialPrefsAddAreaCodeUnknown : HsAppLaunchCmd.h
  • hsDialPrefsAddAreaCodeYes : HsAppLaunchCmd.h
  • hsDialPrefsAutoAreaCodeLength : HsAppLaunchCmd.h
  • hsDialPrefsMaxDialingPrefixLength : HsAppLaunchCmd.h
  • hsDispFtrCreator : HsExtCommon.h
  • hsDispFtrIDControllerShades : HsExtCommon.h
  • hsDispFtrIDDisplayAttributes : HsExtCommon.h
  • hsDispFtrIDDisplayShades : HsExtCommon.h
  • hsDispFtrValBlueOffset : HsExtCommon.h
  • hsDispFtrValBulverdePxa27X : HsExtCommon.h
  • hsDispFtrValBwStn : HsExtCommon.h
  • hsDispFtrValColorOled : HsExtCommon.h
  • hsDispFtrValColorStn : HsExtCommon.h
  • hsDispFtrValColorTft : HsExtCommon.h
  • hsDispFtrValDragonballVZ : HsExtCommon.h
  • hsDispFtrValGrayOffset : HsExtCommon.h
  • hsDispFtrValGreenOffset : HsExtCommon.h
  • hsDispFtrValLCDControllerTypeMask : HsExtCommon.h
  • hsDispFtrValLCDDisplayTypeMask : HsExtCommon.h
  • hsDispFtrValOmapX10 : HsExtCommon.h
  • hsDispFtrValRedOffset : HsExtCommon.h
  • hsDispFtrValSed1375 : HsExtCommon.h
  • hsDispFtrValSed1376 : HsExtCommon.h
  • hsDispFtrValSed13A3 : HsExtCommon.h
  • hsErrAppStopEvent : HsExtCommon.h
  • hsErrBufferTooSmall : HsExtCommon.h
  • hsErrCardNotInstalled : HsExtCommon.h
  • hsErrCardPatchAlreadyInstalled : HsExtCommon.h
  • hsErrCardPatchNotInstalled : HsExtCommon.h
  • hsErrFixedStorageRequired : HsExtCommon.h
  • hsErrGPRSNotAttached : HsExtCommon.h
  • hsErrIndicatorDisabled : HsExtCommon.h
  • hsErrIndicatorInvalidCap : HsExtCommon.h
  • hsErrIndicatorInvalidSequence : HsExtCommon.h
  • hsErrInUse : HsExtCommon.h
  • hsErrInvalidCardHdr : HsExtCommon.h
  • hsErrInvalidCardNum : HsExtCommon.h
  • hsErrInvalidParam : HsExtCommon.h
  • hsErrInvalidPeriod : HsExtCommon.h
  • hsErrNotEnoughPower : HsExtCommon.h
  • hsErrNotSupported : HsExtCommon.h
  • hsErrOutOfCoverage : HsExtCommon.h
  • hsErrOutOfMemory : HsExtCommon.h
  • hsErrPeriodicAlreadyInstalled : HsExtCommon.h
  • hsErrPeriodicNotInstalled : HsExtCommon.h
  • hsErrPhoneLocked : HsErrors.h
  • hsErrPhoneNotActivated : HsErrors.h
  • hsErrRadioNotRegistered : HsErrors.h
  • hsErrRadioOff : HsErrors.h
  • hsErrReadOnly : HsExtCommon.h
  • hsErrSIMMissing : HsExtCommon.h
  • hsErrSimNotReady : HsErrors.h
  • hsErrTimeOut : HsExtCommon.h
  • hsErrUnderflow : HsExtCommon.h
  • hsErrUserInterrupted : HsExtCommon.h
  • hsErrUserNoRadio : HsExtCommon.h
  • hsErrVoiceCallActive : HsErrors.h
  • HsEvtMetaEvent() : HsExt.h
  • hsExgGetScheme : HsExgMgrCommon.h
  • HsExtDoSaveAsDialog() : HsExt.h
  • hsExtErrorClass : HsErrorClasses.h
  • HsExtExgLocalAccept() : HsExgMgr.h
  • HsExtExgLocalDisconnect() : HsExgMgr.h
  • HsExtExgSelectTarget() : HsExgMgr.h
  • hsFfsErrorClass : HsErrorClasses.h
  • hsFileBrowserCoreLib : HsCreators.h
  • hsFileCAddrBookExtensions : HsCreators.h
  • hsFileCAddrBookOneFingerMode : HsCreators.h
  • hsFileCAddrTester : HsCreators.h
  • hsFileCAdvCalculator : HsCreators.h
  • hsFileCameraLib : HsCreators.h
  • hsFileCARMTelephonyWrapper : HsCreators.h
  • hsFileCAutomaticHelper : HsCreators.h
  • hsFileCBackup : HsCreators.h
  • hsFileCBackupWelcome : HsCreators.h
  • hsFileCBlazer : HsCreators.h
  • hsFileCBlazer3 : HsCreators.h
  • hsFileCBlazer3TipsSharedContent : HsCreators.h
  • hsFileCBlazer3TutorialLauncher : HsCreators.h
  • hsFileCBrightness : HsCreators.h
  • hsFileCBuiltinHsExtToken : HsCreators.h
  • hsFileCButtonPrefsPanel : HsCreators.h
  • hsFileCCamera : HsCreators.h
  • hsFileCCameraTest : HsCreators.h
  • hsFileCCameraTips : HsCreators.h
  • hsFileCCardAccessTime : HsCreators.h
  • hsFileCCardSetup : HsCreators.h
  • hsFileCCardWelcomeAppTypeCreator : HsCreators.h
  • hsFileCCardWelcomeDuringReset : HsCreators.h
  • hsFileCCCLib : HsCreators.h
  • hsFileCCDMAActivation : HsCreators.h
  • hsFileCCDMAMsgLib : HsCreators.h
  • hsFileCCDMAPhoneLib : HsCreators.h
  • hsFileCCDMAUpdater : HsCreators.h
  • hsFileCCityTime : HsCreators.h
  • hsFileCCodecWrapper : HsCreators.h
  • hsFileCComChannelProvider : HsCreators.h
  • hsFileCDataMgrExt : HsCreators.h
  • hsFileCDateBook3H : HsCreators.h
  • hsFileCDebugPrefs : HsCreators.h
  • hsFileCDefaultAppsPanel : HsCreators.h
  • hsFileCDialingPanel : HsCreators.h
  • hsFileCDirectRadioSerLib : HsCreators.h
  • hsFileCDisplayPanel : HsCreators.h
  • hsFileCDuoHack : HsCreators.h
  • hsFileCEmailTipsContent : HsCreators.h
  • hsFileCFacebook : HsCreators.h
  • hsFileCFacebookContactsView : HsCreators.h
  • hsFileCFacebookHomeView : HsCreators.h
  • hsFileCFacebookMessageView : HsCreators.h
  • hsFileCFacebookMeView : HsCreators.h
  • hsFileCFacebookPhotosView : HsCreators.h
  • hsFileCFacebookStub68k : HsCreators.h
  • hsFileCFacebookTips : HsCreators.h
  • hsFileCFakeNetLib : HsCreators.h
  • hsFileCFfsCrType : HsCreators.h
  • hsFileCFfsCSegLib : HsCreators.h
  • hsFileCFFSInfoTok1 : HsCreators.h
  • hsFileCFileInstaller : HsCreators.h
  • hsFileCFileMover : HsCreators.h
  • hsFileCFirmwareUpdater : HsCreators.h
  • hsFileCFlMgr : HsCreators.h
  • hsFileCFluMgr : HsCreators.h
  • hsFileCGasTest : HsCreators.h
  • hsFileCGettingStartedApp : HsCreators.h
  • hsFileCGPRSUpdater : HsCreators.h
  • hsFileCGSMActivation : HsCreators.h
  • hsFileCGSMPhoneLib : HsCreators.h
  • hsFileCHandspringExt : HsCreators.h
  • hsFileCHandspringPalmOSUpdate : HsCreators.h
  • hsFileCHandspringSystemResource : HsCreators.h
  • hsFileCHandTerminal : HsCreators.h
  • hsFileCHsSerWrapperLib : HsCreators.h
  • hsFileCHsSSLLib109a : HsCreators.h
  • hsFileCHwmCSegLib : HsCreators.h
  • hsFileCIM : HsCreators.h
  • hsFileCImagine : HsCreators.h
  • hsFileCIOTA : HsCreators.h
  • hsFileCIsolateMemoryChip : HsCreators.h
  • hsFileCKeyboardDemo : HsCreators.h
  • hsFileCKeyguard : HsCreators.h
  • hsFileCKeyguardPanel : HsCreators.h
  • hsFileCLangSpoofer : HsCreators.h
  • hsFileCLCDAdjustPanel : HsCreators.h
  • hsFileCLdbMgr : HsCreators.h
  • hsFileCMailWrapper : HsCreators.h
  • hsFileCMCLLib : HsCreators.h
  • hsFileCMessageStore : HsCreators.h
  • hsFileCModemMgrExt : HsCreators.h
  • hsFileCModemSerLib : HsCreators.h
  • hsFileCModuleSerLib : HsCreators.h
  • hsFileCMultiChannelRingToneDB : HsCreators.h
  • hsFileCNavExt : HsCreators.h
  • hsFileCNavSample : HsCreators.h
  • hsFileCOldGrfLib : HsCreators.h
  • hsFileCPatchedNetLib : HsCreators.h
  • hsFileCPhone : HsCreators.h
  • hsFileCPhone2 : HsCreators.h
  • hsFileCPhoneActiveCallView : HsCreators.h
  • hsFileCPhoneAppFavoritesLibrary : HsCreators.h
  • hsFileCPhoneCallLogView : HsCreators.h
  • hsFileCPhoneDialPadView : HsCreators.h
  • hsFileCPhoneFavoritesView : HsCreators.h
  • hsFileCPhoneIncomingCallView : HsCreators.h
  • hsFileCPhoneMainView : HsCreators.h
  • hsFileCPhonePeopleView : HsCreators.h
  • hsFileCPhoneRingerPanel : HsCreators.h
  • hsFileCPhoneSecurity : HsCreators.h
  • hsFileCPhoneServicesPanel : HsCreators.h
  • hsFileCPhoneStub68k : HsCreators.h
  • hsFileCPhoneTips : HsCreators.h
  • hsFileCPhoneWizard : HsCreators.h
  • hsFileCPhoneWrapper : HsCreators.h
  • hsFileCPinballGame : HsCreators.h
  • hsFileCPmUIUtilLibTest : HsCreators.h
  • hsFileCPowerKey : HsCreators.h
  • hsFileCProgressMgrExt : HsCreators.h
  • hsFileCRomUpdater : HsCreators.h
  • hsFileCSampleCardWelcome : HsCreators.h
  • hsFileCSampleSerLib : HsCreators.h
  • hsFileCSave2Card : HsCreators.h
  • hsFileCSDLib : HsCreators.h
  • hsFileCSerDrvrAuto : HsCreators.h
  • hsFileCSerDrvrCradle : HsCreators.h
  • hsFileCSerDrvrUSBConsole : HsCreators.h
  • hsFileCSerDrvrUSBDesktop : HsCreators.h
  • hsFileCSerDrvrUSBGeneric : HsCreators.h
  • hsFileCSerDrvrUSBGeneric2 : HsCreators.h
  • hsFileCSerDrvrUSBRemFS : HsCreators.h
  • hsFileCSerialCoupler : HsCreators.h
  • hsFileCSerLib : HsCreators.h
  • hsFileCSetISP : HsCreators.h
  • hsFileCSetMem : HsCreators.h
  • hsFileCSimPhoneBook : HsCreators.h
  • hsFileCSimServices : HsCreators.h
  • hsFileCSmartSmallromToken : HsCreators.h
  • hsFileCSmartTextEngine : HsCreators.h
  • hsFileCSMS : HsCreators.h
  • hsFileCSpringWriter : HsCreators.h
  • hsFileCTaskLib : HsCreators.h
  • hsFileCTelephonyInterfaceLayer : HsCreators.h
  • hsFileCTextEncodingConverterLib : HsCreators.h
  • hsFileCTextEncodingConverterTable : HsCreators.h
  • hsFileCTexter : HsCreators.h
  • hsFileCTonesLib : HsCreators.h
  • hsFileCTraceViewer : HsCreators.h
  • hsFileCTransparencyLib : HsCreators.h
  • hsFileCTutorialContent : HsCreators.h
  • hsFileCUartCoupler : HsCreators.h
  • hsFileCUIExt : HsCreators.h
  • hsFileCUsbLib : HsCreators.h
  • hsFileCUsbResetTest : HsCreators.h
  • hsFileCUsbTester : HsCreators.h
  • hsFileCUseSerial : HsCreators.h
  • hsFileCVirtualGSMSerLib : HsCreators.h
  • hsFileCVirtualModemSerLib : HsCreators.h
  • hsFileMMSPalmTransport : HsCreators.h
  • hsFileMMSTreoTransport : HsCreators.h
  • hsFilePhoneBluetoothConnect : HsCreators.h
  • hsFileSMSExchangeLib : HsCreators.h
  • hsFileSMSPalmTransport : HsCreators.h
  • hsFileSMSTreoTransport : HsCreators.h
  • hsFileSoundLib : HsCreators.h
  • hsFileSPI1SerLib : HsCreators.h
  • hsFileTCardSetup : HsCreators.h
  • hsFileTCardSetupShell : HsCreators.h
  • hsFileTCodeSeg : HsCreators.h
  • hsFileTHandspringHal : HsCreators.h
  • hsFileTHandspringPatch : HsCreators.h
  • hsFileTHandspringUIObj : HsCreators.h
  • hsFileTModemSetupPatch : HsCreators.h
  • hsFileTSndFile : HsCreators.h
  • hsFlashErrorClass : HsErrorClasses.h
  • hsFlmErrorClass : HsErrorClasses.h
  • hsForcePrefAutoOffDurationSecs : HsExtCommon.h
  • hsFtcErrorClass : HsErrorClasses.h
  • hsFtrCreator : HsExtCommon.h
  • hsFtrIDBugsFixed : HsExtCommon.h
  • hsFtrIDCurrentAppOnSleep : HsExtCommon.h
  • hsFtrIDGrfAreaDisabled : HsExtCommon.h
  • hsFtrIDHardwareApiRevision : HsExtCommon.h
  • hsFtrIDKeyboardLayout : HsExtCommon.h
  • hsFtrIDLdbMgrLibRefNum : HsExtCommon.h
  • hsFtrIDModDate : HsExtCommon.h
  • hsFtrIDNavigationSupported : HsExtCommon.h
  • hsFtrIDNoMemSemaphore : HsExtCommon.h
  • hsFtrIDPowerKeyResponse : HsExtCommon.h
  • hsFtrIDRadioAttributes : HsExtCommon.h
  • hsFtrIDStatusGadgetRev : HsExtCommon.h
  • hsFtrIDTestingBootMode : HsExtCommon.h
  • hsFtrIDToneOnLidOpen : HsExtCommon.h
  • hsFtrIDTypeOfKeyboard : HsExtCommon.h
  • hsFtrIDVersion : HsExtCommon.h
  • hsFtrValCurrentAppOnSleepPhoneAppSpeedDialView : HsExtCommon.h
  • hsFtrValKeyboardBasic : HsExtCommon.h
  • hsFtrValKeyboardCommCentric : HsExtCommon.h
  • hsFtrValKeyboardCustomApps : HsExtCommon.h
  • hsFtrValKeyboardJog : HsExtCommon.h
  • hsFtrValKeyboardLayout_deDE : HsExtCommon.h
  • hsFtrValKeyboardLayout_enUS : HsExtCommon.h
  • hsFtrValKeyboardLayout_frFR : HsExtCommon.h
  • hsFtrValKeyboardQwerty : HsExtCommon.h
  • hsFtrValPowerKeyDoubleClkBacklight : HsExtCommon.h
  • hsFtrValPowerKeyHoldRadioPower : HsExtCommon.h
  • hsFtrValPowerKeyTripleClkInvert : HsExtCommon.h
  • hsFtrValRadioAvailable : HsExtCommon.h
  • hsFtrValRadioBuiltin : HsExtCommon.h
  • hsFtrValStatusGadgetRev1 : HsExtCommon.h
  • hsFttErrorClass : HsErrorClasses.h
  • HsGetARMActiveFormPtr() : HsExt.h
  • hsGetCurrentLightCircumstance : HsExtTraps.h
  • HsGetPhoneLibrary() : HsExt.h
  • HsGetTrapAddress() : HsExt.h
  • HsGetVersionString() : HsExt.h
  • hsGlfOptLock : HsKeyTypes.h
  • HsGrfGetStateExt() : HsExt.h
  • HsGrfSetStateExt() : HsExt.h
  • hsGrfTempShiftOpt : HsKeyTypes.h
  • hsGsiOptLock : HsKeyTypes.h
  • hsGsiShiftOpt : HsKeyTypes.h
  • hsHALIDHandspringOs35_40 : HsExtCommon.h
  • hsHALIDHandspringOs5Rev1 : HsExtCommon.h
  • hsHALIDHandspringOs5Rev1Sim : HsExtCommon.h
  • hsHALIDHandspringOs5Rev2 : HsExtCommon.h
  • hsHALIDHandspringOs5Rev2Sim : HsExtCommon.h
  • hsHALIDHandspringOs5Rev3 : HsExtCommon.h
  • hsHALIDHandspringOs5Rev3Sim : HsExtCommon.h
  • hsHALIDHandspringOs5Rev4 : HsExtCommon.h
  • hsHALIDHandspringOs5Rev4Sim : HsExtCommon.h
  • hsHwmErrorClass : HsErrorClasses.h
  • HsIndicatorCountEnum : HsExtCommon.h
  • HsIndicatorState() : HsExt.h
  • HsIndicatorStateEnum : HsExtCommon.h
  • HsIndicatorTypeEnum : HsExtCommon.h
  • HsInfo() : HsExt.h
  • hsInstallSerialWrapper : HsExtTraps.h
  • HsIsHTTPLibraryLoaded() : HsExt.h
  • hsKbdLayoutDbTypeCreator : HsCreators.h
  • HsKeyChrCodeToKeyCode() : HsExt.h
  • HsKeyCurrentStateExt() : HsExt.h
  • HsKeyEnableKey() : HsExt.h
  • HsKeyEventIsFromKeyboard() : HsExt.h
  • hsKeyguardAutoDisabled : HsExtCommon.h
  • hsKeyguardAutoPowerOff : HsExtCommon.h
  • hsKeyguardFlagPowerOnDialog : HsExtCommon.h
  • HsKeyKeyCodeToChrCode() : HsExt.h
  • hsKeyMfgTest : HsKeyCodes.h
  • hsKeyRadioPower : HsKeyCodes.h
  • HsKeySetMaskExt() : HsExt.h
  • HsKeysPressed() : HsExt.h
  • HsKeyStop() : HsExt.h
  • hsKeySymbol : HsKeyCodes.h
  • hsLibAliasConsole : HsExtCommon.h
  • hsLibAliasDefault : HsExtCommon.h
  • hsLibAliasHotSyncLocal : HsExtCommon.h
  • hsLibAliasHotSyncModem : HsExtCommon.h
  • hsLibAliasIrda : HsExtCommon.h
  • hsLibNameBuiltInSerial : HsExtCommon.h
  • HsLightCircumstance() : HsExt.h
  • hsLightCircumstanceAlertWokeDevice : HsExtCommon.h
  • hsLightCircumstanceAlertWokeDeviceFlagBit : HsExtCommon.h
  • HsLightCircumstanceEnum : HsExtCommon.h
  • hsLightCircumstanceFirst : HsExtCommon.h
  • hsLightCircumstanceKeylightOff : HsExtCommon.h
  • hsLightCircumstanceKeylightOffFlagBit : HsExtCommon.h
  • hsLightCircumstanceNumCircumstances : HsExtCommon.h
  • hsLightCircumstanceQuickTyping : HsExtCommon.h
  • hsLightCircumstanceQuickTypingFlagBit : HsExtCommon.h
  • hsLightCircumstanceReserved : HsExtCommon.h
  • hsLightCircumstanceUserNotLooking : HsExtCommon.h
  • hsLightCircumstanceUserNotLookingFlagBit : HsExtCommon.h
  • hsLightCircumstanceUserNotLookingLongTime : HsExtCommon.h
  • hsLightCircumstanceUserNotLookingLongTimeFlagBit : HsExtCommon.h
  • HsLightMode() : HsExt.h
  • HsLightModeEnum : HsExtCommon.h
  • hsLightModeNight : HsExtCommon.h
  • hsLightModeNormal : HsExtCommon.h
  • hsLightModeNumPresets : HsExtCommon.h
  • hsLightModeReserved : HsExtCommon.h
  • hsMaxSaveAsNameSize : HsExtCommon.h
  • hsMSLErrorClass : HsErrorClasses.h
  • hsNavAPIVersion : HsNavCommon.h
  • HsNavDrawFocusRing() : HsExt.h
  • HsNavFocusColorEnum : HsNavCommon.h
  • HsNavFocusColorEnumTag : HsNavCommon.h
  • hsNavFocusColorInsideBottomRightRing : HsNavCommon.h
  • hsNavFocusColorInsideTopLeftRing : HsNavCommon.h
  • hsNavFocusColorMiddleRing : HsNavCommon.h
  • hsNavFocusColorOutsideRing : HsNavCommon.h
  • hsNavFocusColorRing1 : HsNavCommon.h
  • hsNavFocusColorRing2 : HsNavCommon.h
  • hsNavFocusColorRing3 : HsNavCommon.h
  • hsNavFocusColorRing4 : HsNavCommon.h
  • hsNavFocusColorRing5 : HsNavCommon.h
  • hsNavFocusColorRing6 : HsNavCommon.h
  • hsNavFocusColorSecondaryHighlight : HsNavCommon.h
  • hsNavFocusRingNoExtraInfo : HsNavCommon.h
  • HsNavFocusRingStyleEnum : HsNavCommon.h
  • HsNavFocusRingStyleEnumTag : HsNavCommon.h
  • hsNavFocusRingStyleHorizontalBars : HsNavCommon.h
  • hsNavFocusRingStyleInvalid : HsNavCommon.h
  • hsNavFocusRingStyleObjectTypeDefault : HsNavCommon.h
  • hsNavFocusRingStyleRound : HsNavCommon.h
  • hsNavFocusRingStyleSquare : HsNavCommon.h
  • hsNavFocusRingWidth : HsNavCommon.h
  • hsNavFocusRingWidthSingleDensity : HsNavCommon.h
  • HsNavGetFocusColor() : HsExt.h
  • HsNavGetFocusRingInfo() : HsExt.h
  • HsNavLstGetTempSelection() : HsExt.h
  • HsNavLstSetTempSelection() : HsExt.h
  • HsNavObjectTakeFocus() : HsExt.h
  • HsNavRemoveFocusRing() : HsExt.h
  • HsNavSetFocusColor() : HsExt.h
  • hsNetMasterErrorClass : HsErrorClasses.h
  • hsNetPrefLibErrorClass : HsErrorClasses.h
  • HsNetworkDropConnection() : HsExt.h
  • hsNeverUsedBeforeAvailableForUse1 : HsExtTraps.h
  • hsNotifyRemSleepEvent : HsCreators.h
  • hsNotifyRemSleepRequestEvent : HsCreators.h
  • hsNotifySetInitialFldStateEvent : HsCreators.h
  • hsNumSels : HsExtTraps.h
  • hsOEMErrorClass : HsErrorClasses.h
  • hsOEMRadioErrorClass : HsErrorClasses.h
  • hsOLDErrorClass : HsExtCommon.h
  • HsOpenDialNumberDialog() : HsExt.h
  • hsPeriodicPeriodsAvailable : HsExtTraps.h
  • hsPeriodicRegister : HsExtTraps.h
  • hsPeriodicUnregister : HsExtTraps.h
  • hsPhoneLibErrorClass_1 : HsErrorClasses.h
  • hsPhoneLibErrorClass_2 : HsErrorClasses.h
  • HsPostProcessPopupList() : HsExtKbdUtils.h
  • hsPrefBlinkGreenLEDInCoverage : HsExtCommon.h
  • HsPrefEnum : HsExtCommon.h
  • HsPrefGet() : HsExt.h
  • hsPrefHard11CharAppCreator : HsExtCommon.h
  • hsPrefJogScanCharAppCreator : HsExtCommon.h
  • hsPrefKeyguardAutoEnableAutoOffExtraTime : HsExtCommon.h
  • hsPrefKeyguardAutoEnableTime : HsExtCommon.h
  • hsPrefKeyguardFlags : HsExtCommon.h
  • hsPrefLast : HsExtCommon.h
  • hsPrefLCDRefreshRate : HsExtCommon.h
  • hsPrefLidClosedAutoOffSeconds : HsExtCommon.h
  • hsPrefLidStatusChgCharAppCreator : HsExtCommon.h
  • hsPrefNetworkTimeSelected : HsExtCommon.h
  • hsPrefNetworkTZSelected : HsExtCommon.h
  • hsPrefOptHard11CharAppCreator : HsExtCommon.h
  • hsPrefOptHard1CharAppCreator : HsExtCommon.h
  • hsPrefOptHard2CharAppCreator : HsExtCommon.h
  • hsPrefOptHard3CharAppCreator : HsExtCommon.h
  • hsPrefOptHard4CharAppCreator : HsExtCommon.h
  • hsPrefOptHardPowerCharAppCreator : HsExtCommon.h
  • hsPrefOptReservedCharAppCreator : HsExtCommon.h
  • hsPrefPowerOnAppCreator : HsExtCommon.h
  • hsPrefPowerSaveMode : HsExtCommon.h
  • hsPrefSerialLibConsole : HsExtCommon.h
  • hsPrefSerialLibDef : HsExtCommon.h
  • hsPrefSerialLibHotSyncLocal : HsExtCommon.h
  • hsPrefSerialLibHotSyncModem : HsExtCommon.h
  • hsPrefSerialLibIrda : HsExtCommon.h
  • HsPrefSet() : HsExt.h
  • hsPrefShortSideHardCharAppCreator : HsExtCommon.h
  • hsPrefSideHardCharAppCreator : HsExtCommon.h
  • hsPrefTempShiftTimeOut : HsExtCommon.h
  • hsPrefTouchscreenDisableFlags : HsExtCommon.h
  • hsPrefUserNotLookingTime : HsExtCommon.h
  • HsPutObjectAfterTitle() : HsExt.h
  • hsRscKbdChrDataID : HsCreators.h
  • hsRscKbdChrOptDataID : HsCreators.h
  • hsRscKbdChrShiftDataID : HsCreators.h
  • hsRscKbdKeyCodeDataID : HsCreators.h
  • hsRscTextEncodingConverterTable : HsCreators.h
  • hsRscTKbdChrLookupData : HsCreators.h
  • hsRscTKbdKeyCodeLookupData : HsCreators.h
  • hsRscTNavFocusColor : HsCreators.h
  • hsRscTPostProcessLists : HsCreators.h
  • hsRscTutorial : HsCreators.h
  • hsSelAboutHandspringApp : HsExtTraps.h
  • hsSelAppEventHandlerSet : HsExtTraps.h
  • hsSelAppEventPost : HsExtTraps.h
  • hsSelAttnGetAttentionExt : HsExtTraps.h
  • hsSelAttnUpdateExt : HsExtTraps.h
  • hsSelAttrGet : HsExtTraps.h
  • hsSelAttrSet : HsExtTraps.h
  • hsSelBrowseUrl : HsExtTraps.h
  • hsSelCardAttrGet : HsExtTraps.h
  • hsSelCardAttrSet : HsExtTraps.h
  • hsSelCardEventPost : HsExtTraps.h
  • hsSelCardHdrUpdate : HsExtTraps.h
  • hsSelCardPatchInstall : HsExtTraps.h
  • hsSelCardPatchRemove : HsExtTraps.h
  • hsSelCardPower : HsExtTraps.h
  • hsSelCrashLogDisplayLast : HsExtTraps.h
  • hsSelCrashLogGetLast : HsExtTraps.h
  • hsSelCreateNewEmail : HsExtTraps.h
  • hsSelCreateNewMessage : HsExtTraps.h
  • hsSelDatabaseCopy : HsExtTraps.h
  • hsSelDispatchService : HsExtTraps.h
  • hsSelDlkForceSlowSync : HsExtTraps.h
  • hsSelDmCreateDatabasesFromImages : HsExtTraps.h
  • hsSelDmDatabaseDeleted : HsExtTraps.h
  • hsSelDmDatabaseIsOpen : HsExtTraps.h
  • hsSelDmDatabaseIsProtected : HsExtTraps.h
  • hsSelDmDatabaseUniqueIDSeed : HsExtTraps.h
  • hsSelDmGetNextDBByTypeCreator : HsExtTraps.h
  • hsSelDmGetNextDBInit : HsExtTraps.h
  • hsSelDmLockFileSystem : HsExtTraps.h
  • hsSelDoSaveAsDialog : HsExtTraps.h
  • hsSelectorBase : HsExtTraps.h
  • hsSelEvtMetaEvent : HsExtTraps.h
  • hsSelEvtResetAutoOffTimer : HsExtTraps.h
  • hsSelExgLocalAccept : HsExtTraps.h
  • hsSelExgLocalDisconnect : HsExtTraps.h
  • hsSelExgSelectTarget : HsExtTraps.h
  • hsSelExtKeyboardEnable : HsExtTraps.h
  • hsSelGetARMActiveFormPtr : HsExtTraps.h
  • hsSelGetPhoneLibrary : HsExtTraps.h
  • hsSelGetVersionString : HsExtTraps.h
  • hsSelGrfGetStateExt : HsExtTraps.h
  • hsSelGrfSetStateExt : HsExtTraps.h
  • hsSelHsGetTrapAddress : HsExtTraps.h
  • hsSelHsSetTrapAddress : HsExtTraps.h
  • hsSelIndicator : HsExtTraps.h
  • hsSelIndicatorState : HsExtTraps.h
  • hsSelInfo : HsExtTraps.h
  • hsSelIsDbgLockoutSupressed : HsExtTraps.h
  • hsSelIsHTTPLibraryLoaded : HsExtTraps.h
  • hsSelKeyChrCodeToKeyCode : HsExtTraps.h
  • hsSelKeyChrToOptChr : HsExtTraps.h
  • hsSelKeyChrToRegChr : HsExtTraps.h
  • hsSelKeyCurrentStateExt : HsExtTraps.h
  • hsSelKeyEnableKey : HsExtTraps.h
  • hsSelKeyEventIsFromKeyboard : HsExtTraps.h
  • hsSelKeyKeyCodeToChrCode : HsExtTraps.h
  • hsSelKeySetMaskExt : HsExtTraps.h
  • hsSelKeysPressed : HsExtTraps.h
  • hsSelKeyStop : HsExtTraps.h
  • hsSelLast : HsExtTraps.h
  • hsSelLightCircumstance : HsExtTraps.h
  • hsSelLightMode : HsExtTraps.h
  • hsSelLstPopupListExt : HsExtTraps.h
  • hsSelMenuSetCurMenuCurItem : HsExtTraps.h
  • hsSelNavDrawFocusRing : HsExtTraps.h
  • hsSelNavGetFocusColor : HsExtTraps.h
  • hsSelNavGetFocusRingInfo : HsExtTraps.h
  • hsSelNavLstGetTempSelection : HsExtTraps.h
  • hsSelNavLstSetTempSelection : HsExtTraps.h
  • hsSelNavObjectTakeFocus : HsExtTraps.h
  • hsSelNavRemoveFocusRing : HsExtTraps.h
  • hsSelNavSetFocusColor : HsExtTraps.h
  • hsSelNetworkDropConnection : HsExtTraps.h
  • hsSelOpenDialNumberDialog : HsExtTraps.h
  • hsSelOpenDialNumberDialogExt : HsExtTraps.h
  • hsSelPeriodicUnregisterFromSelf : HsExtTraps.h
  • hsSelPostProcessPopupList : HsExtTraps.h
  • hsSelPostProcPopupList : HsExtTraps.h
  • hsSelPrefGet : HsExtTraps.h
  • hsSelPrefGetAppKeyCreator : HsExtTraps.h
  • hsSelPrefSet : HsExtTraps.h
  • hsSelPrvCallSafely : HsExtTraps.h
  • hsSelPrvCallSafelyNewStack : HsExtTraps.h
  • hsSelPrvErrCatchListP : HsExtTraps.h
  • hsSelPrvFindAppFromIDs : HsExtTraps.h
  • hsSelPrvHandleCardChangeEvent : HsExtTraps.h
  • hsSelPrvHandleKeyboardLock : HsExtTraps.h
  • hsSelPrvInit : HsExtTraps.h
  • hsSelPrvInitPostProcess : HsExtTraps.h
  • hsSelPrvKeyHandleEvent : HsExtTraps.h
  • hsSelPrvLaunchCompareFunc : HsExtTraps.h
  • hsSelPrvLaunchDemoApp : HsExtTraps.h
  • hsSelPrvLEDCommand : HsExtTraps.h
  • hsSelPrvSetButtonDefault : HsExtTraps.h
  • hsSelPrvSetupGoToCustomForm : HsExtTraps.h
  • hsSelPrvSetupInstallFormEventHandler : HsExtTraps.h
  • hsSelPrvShowKeyboardLockOnDialog : HsExtTraps.h
  • hsSelPrvUpdateBatteryGadget : HsExtTraps.h
  • hsSelPrvUpdateSignalGadget : HsExtTraps.h
  • hsSelPutObjectAfterTitle : HsExtTraps.h
  • hsSelReserved352H5_54 : HsExtTraps.h
  • hsSelReserved352H5_55 : HsExtTraps.h
  • hsSelReserved352H5_56 : HsExtTraps.h
  • hsSelReserved352H5_57 : HsExtTraps.h
  • hsSelReserved352H5_58 : HsExtTraps.h
  • hsSelReserved352H5_59 : HsExtTraps.h
  • hsSelReserved352H5_5A : HsExtTraps.h
  • hsSelReserved352H5_5B : HsExtTraps.h
  • hsSelReserved352H5_5C : HsExtTraps.h
  • hsSelReserved352H5_5D : HsExtTraps.h
  • hsSelReserved352H6_5E : HsExtTraps.h
  • hsSelReserved352H6_5F : HsExtTraps.h
  • hsSelReserved352H6_60 : HsExtTraps.h
  • hsSelReserved352H6_61 : HsExtTraps.h
  • hsSelReserved352H6_62 : HsExtTraps.h
  • hsSelReserved352H6_63 : HsExtTraps.h
  • hsSelReserved352H6_64 : HsExtTraps.h
  • hsSelReserved352H6_65 : HsExtTraps.h
  • hsSelReserved352H6_66 : HsExtTraps.h
  • hsSelReserved352H6_67 : HsExtTraps.h
  • hsSelReserved352H6_68 : HsExtTraps.h
  • hsSelReserved352H6_69 : HsExtTraps.h
  • hsSelReserved352H6_6A : HsExtTraps.h
  • hsSelReserved41_6E : HsExtTraps.h
  • hsSelReserved41_6F : HsExtTraps.h
  • hsSelReserved41_70 : HsExtTraps.h
  • hsSelReserved41_71 : HsExtTraps.h
  • hsSelReserved41_72 : HsExtTraps.h
  • hsSelReserved5H1_C0 : HsExtTraps.h
  • hsSelReserved5H1_C1 : HsExtTraps.h
  • hsSelReserved5H1_C2 : HsExtTraps.h
  • hsSelReserved5H1_C3 : HsExtTraps.h
  • hsSelShowHighVolAlert : HsExtTraps.h
  • hsSelSpringboardNotSupported : HsExtTraps.h
  • hsSelStartMemoryTracing : HsExtTraps.h
  • hsSelStatusSetGadgetType : HsExtTraps.h
  • hsSelStatusUpdateGadgets : HsExtTraps.h
  • hsSelSupressDbgLockout : HsExtTraps.h
  • hsSelSysKeyboardReferenceDialog : HsExtTraps.h
  • hsSelTrace : HsExtTraps.h
  • hsSelTraceClear : HsExtTraps.h
  • hsSelTraceCloseDB : HsExtTraps.h
  • hsSelTraceContextDelete : HsExtTraps.h
  • hsSelTraceContextInit : HsExtTraps.h
  • hsSelTraceData : HsExtTraps.h
  • hsSelTraceError : HsExtTraps.h
  • hsSelTraceEvent : HsExtTraps.h
  • hsSelTraceFunction : HsExtTraps.h
  • hsSelTraceFunctionError : HsExtTraps.h
  • hsSelTraceGetCommitInterval : HsExtTraps.h
  • hsSelTraceGetMaxRecords : HsExtTraps.h
  • hsSelTraceLevelsGet : HsExtTraps.h
  • hsSelTraceLevelsSet : HsExtTraps.h
  • hsSelTraceOpenDB : HsExtTraps.h
  • hsSelTraceOutputLevelsGet : HsExtTraps.h
  • hsSelTraceOutputLevelsSet : HsExtTraps.h
  • hsSelTraceRecordsDump : HsExtTraps.h
  • hsSelTraceSetCommitInterval : HsExtTraps.h
  • hsSelTraceSetMaxRecords : HsExtTraps.h
  • hsSelTraceText : HsExtTraps.h
  • hsSelTurnRadioOn : HsExtTraps.h
  • hsSelTwoFontSelect : HsExtTraps.h
  • hsSelTxtIsAscii : HsExtTraps.h
  • hsSelTxtNumChars : HsExtTraps.h
  • hsSelTxtPrepFindString : HsExtTraps.h
  • hsSelTxtTruncateString : HsExtTraps.h
  • hsSelUnimplemented : HsExtTraps.h
  • hsSelUsbCommStatePtr : HsExtTraps.h
  • hsSelUtilAttnIndicatorAllow : HsExtTraps.h
  • hsSelUtilAttnNagInfo : HsExtTraps.h
  • hsSelUtilBbutHitBigButton : HsExtTraps.h
  • hsSelUtilBbutInstallFromResource : HsExtTraps.h
  • hsSelUtilBbutInstallNewButton : HsExtTraps.h
  • hsSelUtilBbutSetBitmap : HsExtTraps.h
  • hsSelUtilBbutSetLabel : HsExtTraps.h
  • hsSelUtilCtlGetControlStyle : HsExtTraps.h
  • hsSelUtilCtlGetFont : HsExtTraps.h
  • hsSelUtilEnableAttentionMgr : HsExtTraps.h
  • hsSelUtilFrmDoDialog : HsExtTraps.h
  • hsSelUtilFrmDoDialogWithCallback : HsExtTraps.h
  • hsSelUtilFrmDoTimedDialog : HsExtTraps.h
  • hsSelUtilFrmGetDefaultButtonID : HsExtTraps.h
  • hsSelUtilFrmGetEventHandler : HsExtTraps.h
  • hsSelUtilFrmSetHelpID : HsExtTraps.h
  • hsSelUtilFrmSetLabel : HsExtTraps.h
  • hsSelUtilFrmSetLabelFont : HsExtTraps.h
  • hsSelUtilGetObjectUsable : HsExtTraps.h
  • hsSelUtilLstGetItemsText : HsExtTraps.h
  • hsSelUtilLstGetTopItem : HsExtTraps.h
  • hsSelUtilMutexCreate : HsExtTraps.h
  • hsSelUtilMutexDelete : HsExtTraps.h
  • hsSelUtilMutexRelease : HsExtTraps.h
  • hsSelUtilMutexReserve : HsExtTraps.h
  • hsSelUtilSclScroll : HsExtTraps.h
  • hsSelUtilSclScrollPage : HsExtTraps.h
  • hsSelUtilSclUpdateScrollBar : HsExtTraps.h
  • hsSelUtilSliHandleKeyDown : HsExtTraps.h
  • hsSelUtilStrCSpn : HsExtTraps.h
  • hsSelUtilWinGetMaxDepth : HsExtTraps.h
  • hsSelWaitForGPRSAttach : HsExtTraps.h
  • hsSelWordCorrectInvoke : HsExtTraps.h
  • hsSelWordCorrectUndo : HsExtTraps.h
  • hsSelWriteROMTokens : HsExtTraps.h
  • hsSndAmplitude_silent : HsSoundLibCommon.h
  • hsSndAmplitude_unity : HsSoundLibCommon.h
  • hsSndBatFull : HsSoundLibCommon.h
  • hsSndBatLow : HsSoundLibCommon.h
  • hsSndBatShutdown : HsSoundLibCommon.h
  • hsSndBayID_AC97 : HsSoundLibCommon.h
  • hsSndBayID_Radio : HsSoundLibCommon.h
  • hsSndBoost_Disable : HsSoundLibCommon.h
  • hsSndBoost_Enable : HsSoundLibCommon.h
  • HsSndBufControl_GetEndDelay : HsSoundLibCommon.h
  • HsSndBufControl_GetRepeat : HsSoundLibCommon.h
  • hsSndBufControl_repeatForever : HsSoundLibCommon.h
  • HsSndBufControl_SetEndDelay : HsSoundLibCommon.h
  • HsSndBufControl_SetRepeat : HsSoundLibCommon.h
  • hsSndBufferData_Signature : HsSoundLibCommon.h
  • HsSndBufferProc : HsSoundLibCommon.h
  • hsSndBufFlags_attackEnvMask : HsSoundLibCommon.h
  • hsSndBufFlags_attackEnvNone : HsSoundLibCommon.h
  • hsSndBufFlags_attackEnvReserved1 : HsSoundLibCommon.h
  • hsSndBufFlags_attackEnvReserved2 : HsSoundLibCommon.h
  • hsSndBufFlags_attackEnvRings : HsSoundLibCommon.h
  • hsSndBufFlags_attackEnvRings2 : HsSoundLibCommon.h
  • hsSndBufFlags_attackEnvVibeNone : HsSoundLibCommon.h
  • hsSndBufFlags_attackEnvVibeRings : HsSoundLibCommon.h
  • hsSndBufFlags_attackEnvVibeRings2 : HsSoundLibCommon.h
  • hsSndBufFlags_canInterrupt : HsSoundLibCommon.h
  • hsSndBufFlags_cannotInterrupt : HsSoundLibCommon.h
  • hsSndBufFlags_endDelayMask : HsSoundLibCommon.h
  • hsSndBufFlags_interruptDefault : HsSoundLibCommon.h
  • hsSndBufFlags_interruptMask : HsSoundLibCommon.h
  • hsSndBufFlags_interruptModeMask : HsSoundLibCommon.h
  • hsSndBufFlags_interruptPhone : HsSoundLibCommon.h
  • hsSndBufFlags_noEndDelay : HsSoundLibCommon.h
  • hsSndBufFlags_noRepeat : HsSoundLibCommon.h
  • hsSndBufFlags_repeatMask : HsSoundLibCommon.h
  • hsSndBufFlags_yesEndDelay : HsSoundLibCommon.h
  • hsSndBufFlags_yesRepeat : HsSoundLibCommon.h
  • hsSndCardInsert : HsSoundLibCommon.h
  • hsSndCardRemove : HsSoundLibCommon.h
  • hsSndChargerAttach : HsSoundLibCommon.h
  • hsSndChargerDetach : HsSoundLibCommon.h
  • HsSndClose() : HsSoundLib.h
  • HsSndCmdEnumTag : HsSoundLibCommon.h
  • hsSndCmdFlags_noWait : HsSoundLibCommon.h
  • hsSndCmdFlags_waitMask : HsSoundLibCommon.h
  • hsSndCmdFlags_yesWait : HsSoundLibCommon.h
  • hsSndCmdPlay : HsSoundLibCommon.h
  • hsSndCmdStop : HsSoundLibCommon.h
  • HsSndCmdType : HsSoundLibCommon.h
  • hsSndDeepSleep : HsSoundLibCommon.h
  • hsSndDeepWake : HsSoundLibCommon.h
  • hsSndErr_DoMidiProgressMsg : HsSoundLibCommon.h
  • hsSndErr_Failed : HsSoundLibCommon.h
  • hsSndErr_InvalidPort : HsSoundLibCommon.h
  • hsSndErr_InvalidPrefValue : HsSoundLibCommon.h
  • hsSndErr_InvalidSwitch : HsSoundLibCommon.h
  • hsSndErr_LastPublicError : HsSoundLibCommon.h
  • hsSndErr_NotSupported : HsSoundLibCommon.h
  • hsSndErr_PortBoostLocked : HsSoundLibCommon.h
  • hsSndErr_PortCannotBoost : HsSoundLibCommon.h
  • hsSndErr_PortCannotMute : HsSoundLibCommon.h
  • hsSndErr_PortCannotPan : HsSoundLibCommon.h
  • hsSndErr_PortCannotVolume : HsSoundLibCommon.h
  • hsSndErr_PortIDNotInClass : HsSoundLibCommon.h
  • hsSndErr_PortMuteLocked : HsSoundLibCommon.h
  • hsSndErr_PortPanLocked : HsSoundLibCommon.h
  • hsSndErr_PortVolumeLocked : HsSoundLibCommon.h
  • hsSndErr_UnknownClkRef : HsSoundLibCommon.h
  • hsSndErr_UnknownPortClass : HsSoundLibCommon.h
  • hsSndErr_UnknownSndParam : HsSoundLibCommon.h
  • hsSndErrBase : HsSoundLibCommon.h
  • hsSndFormatAmr : HsSoundLibCommon.h
  • HsSndFormatEnumTag : HsSoundLibCommon.h
  • hsSndFormatMidi : HsSoundLibCommon.h
  • HsSndFormatPlay() : HsSoundLib.h
  • HsSndFormatRecord() : HsSoundLib.h
  • HsSndFormatType : HsSoundLibCommon.h
  • HsSndGetUserVolume() : HsSoundLib.h
  • HsSndGetVersion() : HsSoundLib.h
  • hsSndLibVersion : HsSoundLibCommon.h
  • hsSndMidiMsg_SetVolume : HsSoundLibCommon.h
  • hsSndMidiProgressMsg_Signature : HsSoundLibCommon.h
  • HsSndMode : HsSoundLibCommon.h
  • hsSndMode_Carkit : HsSoundLibCommon.h
  • hsSndMode_Current : HsSoundLibCommon.h
  • hsSndMode_Headphones : HsSoundLibCommon.h
  • hsSndMode_HeadphonesHost : HsSoundLibCommon.h
  • hsSndMode_Headset : HsSoundLibCommon.h
  • hsSndMode_Receiver : HsSoundLibCommon.h
  • hsSndMode_Reserved : HsSoundLibCommon.h
  • hsSndMode_SpeakerHost : HsSoundLibCommon.h
  • hsSndMode_Speakerphone : HsSoundLibCommon.h
  • hsSndMute_Disable : HsSoundLibCommon.h
  • hsSndMute_Enable : HsSoundLibCommon.h
  • hsSndNotify : HsSoundLibCommon.h
  • hsSndNotifyAlert : HsSoundLibCommon.h
  • hsSndNotifyAnswerButton : HsSoundLibCommon.h
  • hsSndNotifyAnswerHold : HsSoundLibCommon.h
  • hsSndNotifyAnswerRelease : HsSoundLibCommon.h
  • hsSndNotifyAthenaAudio : HsSoundLibCommon.h
  • hsSndNotifyCarkitActive : HsSoundLibCommon.h
  • hsSndNotifyCarkitInactive : HsSoundLibCommon.h
  • hsSndNotifyHeadphones : HsSoundLibCommon.h
  • hsSndNotifyHeadset : HsSoundLibCommon.h
  • hsSndNotifyHighPriority : HsSoundLibCommon.h
  • hsSndNotifyHybrid : HsSoundLibCommon.h
  • hsSndNotifyNotHybrid : HsSoundLibCommon.h
  • hsSndNotifyRingerSwitchOff : HsSoundLibCommon.h
  • hsSndNotifyRingerSwitchOn : HsSoundLibCommon.h
  • hsSndNotifyUnplugged : HsSoundLibCommon.h
  • HsSndOpen() : HsSoundLib.h
  • hsSndPan_Left : HsSoundLibCommon.h
  • hsSndPan_LeftNormal : HsSoundLibCommon.h
  • hsSndPan_Middle : HsSoundLibCommon.h
  • hsSndPan_Right : HsSoundLibCommon.h
  • hsSndPan_RightNormal : HsSoundLibCommon.h
  • HsSndParam : HsSoundLibCommon.h
  • hsSndParam_Boost : HsSoundLibCommon.h
  • hsSndParam_Mute : HsSoundLibCommon.h
  • hsSndParam_Pan : HsSoundLibCommon.h
  • hsSndParam_Volume : HsSoundLibCommon.h
  • hsSndParamMode_LockParam : HsSoundLibCommon.h
  • hsSndParamMode_Mask : HsSoundLibCommon.h
  • hsSndParamMode_Normal : HsSoundLibCommon.h
  • hsSndParamMode_UnlockParam : HsSoundLibCommon.h
  • HsSndParamValue_RemoveMode : HsSoundLibCommon.h
  • HsSndParamValue_SetWithLock : HsSoundLibCommon.h
  • HsSndParamValue_SetWithUnlock : HsSoundLibCommon.h
  • HsSndPortClass : HsSoundLibCommon.h
  • hsSndPortClass_Anchor : HsSoundLibCommon.h
  • hsSndPortClass_BaseDefault : HsSoundLibCommon.h
  • hsSndPortClass_Real : HsSoundLibCommon.h
  • hsSndPortClass_Virtual : HsSoundLibCommon.h
  • hsSndPortFlags_Boost_Locked : HsSoundLibCommon.h
  • hsSndPortFlags_Boost_LockMask : HsSoundLibCommon.h
  • hsSndPortFlags_Boost_Unlocked : HsSoundLibCommon.h
  • hsSndPortFlags_BoostMask : HsSoundLibCommon.h
  • hsSndPortFlags_BoostOff : HsSoundLibCommon.h
  • hsSndPortFlags_BoostOn : HsSoundLibCommon.h
  • hsSndPortFlags_CanBoost_No : HsSoundLibCommon.h
  • hsSndPortFlags_CanBoost_Yes : HsSoundLibCommon.h
  • hsSndPortFlags_CanBoostMask : HsSoundLibCommon.h
  • hsSndPortFlags_CanInputOnly : HsSoundLibCommon.h
  • hsSndPortFlags_CanIOBothways : HsSoundLibCommon.h
  • hsSndPortFlags_CanIOMask : HsSoundLibCommon.h
  • hsSndPortFlags_CanIOSelect : HsSoundLibCommon.h
  • hsSndPortFlags_CanMute_No : HsSoundLibCommon.h
  • hsSndPortFlags_CanMute_Yes : HsSoundLibCommon.h
  • hsSndPortFlags_CanMuteMask : HsSoundLibCommon.h
  • hsSndPortFlags_CanOutputOnly : HsSoundLibCommon.h
  • hsSndPortFlags_CanPan_No : HsSoundLibCommon.h
  • hsSndPortFlags_CanPan_Yes : HsSoundLibCommon.h
  • hsSndPortFlags_CanPanMask : HsSoundLibCommon.h
  • hsSndPortFlags_CanVol_No : HsSoundLibCommon.h
  • hsSndPortFlags_CanVol_Yes : HsSoundLibCommon.h
  • hsSndPortFlags_CanVolMask : HsSoundLibCommon.h
  • hsSndPortFlags_Disabled : HsSoundLibCommon.h
  • hsSndPortFlags_Enabled : HsSoundLibCommon.h
  • hsSndPortFlags_EnableMask : HsSoundLibCommon.h
  • hsSndPortFlags_InputMask : HsSoundLibCommon.h
  • hsSndPortFlags_InputOff : HsSoundLibCommon.h
  • hsSndPortFlags_InputOn : HsSoundLibCommon.h
  • hsSndPortFlags_Mute_Locked : HsSoundLibCommon.h
  • hsSndPortFlags_Mute_LockMask : HsSoundLibCommon.h
  • hsSndPortFlags_Mute_Unlocked : HsSoundLibCommon.h
  • hsSndPortFlags_MuteMask : HsSoundLibCommon.h
  • hsSndPortFlags_MuteOff : HsSoundLibCommon.h
  • hsSndPortFlags_MuteOn : HsSoundLibCommon.h
  • hsSndPortFlags_OutputMask : HsSoundLibCommon.h
  • hsSndPortFlags_OutputOff : HsSoundLibCommon.h
  • hsSndPortFlags_OutputOn : HsSoundLibCommon.h
  • hsSndPortFlags_Pan_Locked : HsSoundLibCommon.h
  • hsSndPortFlags_Pan_LockMask : HsSoundLibCommon.h
  • hsSndPortFlags_Pan_Unlocked : HsSoundLibCommon.h
  • hsSndPortFlags_TypeAnalog : HsSoundLibCommon.h
  • hsSndPortFlags_TypeDigital : HsSoundLibCommon.h
  • hsSndPortFlags_TypeMask : HsSoundLibCommon.h
  • hsSndPortFlags_Vol_Locked : HsSoundLibCommon.h
  • hsSndPortFlags_Vol_LockMask : HsSoundLibCommon.h
  • hsSndPortFlags_Vol_Unlocked : HsSoundLibCommon.h
  • HsSndPortGetInfo() : HsSoundLib.h
  • HsSndPortID : HsSoundLibCommon.h
  • hsSndPortID_ConnectCall : HsSoundLibCommon.h
  • hsSndPortID_Current : HsSoundLibCommon.h
  • hsSndPortID_InBaseMic : HsSoundLibCommon.h
  • hsSndPortID_InBtHandsfree : HsSoundLibCommon.h
  • hsSndPortID_InBtHeadset : HsSoundLibCommon.h
  • hsSndPortID_InCarkit : HsSoundLibCommon.h
  • hsSndPortID_InHeadsetMic : HsSoundLibCommon.h
  • hsSndPortID_InHostBaseMic : HsSoundLibCommon.h
  • hsSndPortID_InHostHeadsetMic : HsSoundLibCommon.h
  • hsSndPortID_InHostPhone : HsSoundLibCommon.h
  • hsSndPortID_InHostPlay : HsSoundLibCommon.h
  • hsSndPortID_InLineRec : HsSoundLibCommon.h
  • hsSndPortID_InMicAuto : HsSoundLibCommon.h
  • hsSndPortID_InRadioSpkr : HsSoundLibCommon.h
  • hsSndPortID_LastPort : HsSoundLibCommon.h
  • hsSndPortID_Off : HsSoundLibCommon.h
  • hsSndPortID_OutBtHandsfree : HsSoundLibCommon.h
  • hsSndPortID_OutBtHeadset : HsSoundLibCommon.h
  • hsSndPortID_OutCarkit : HsSoundLibCommon.h
  • hsSndPortID_OutHeadphones : HsSoundLibCommon.h
  • hsSndPortID_OutHeadset : HsSoundLibCommon.h
  • hsSndPortID_OutHostRec : HsSoundLibCommon.h
  • hsSndPortID_OutRadioMic : HsSoundLibCommon.h
  • hsSndPortID_OutReceiver : HsSoundLibCommon.h
  • hsSndPortID_OutSpeaker : HsSoundLibCommon.h
  • hsSndPortID_OutSpeakerAuto : HsSoundLibCommon.h
  • hsSndPortInfo_Signature : HsSoundLibCommon.h
  • HsSndPortInfoPtr : HsSoundLibCommon.h
  • HsSndPortSetParam() : HsSoundLib.h
  • hsSndRadioInServiceArea : HsSoundLibCommon.h
  • hsSndRadioOff : HsSoundLibCommon.h
  • hsSndRadioOn : HsSoundLibCommon.h
  • hsSndRadioOutServiceArea : HsSoundLibCommon.h
  • hsSndRsrcAudioTableID : HsSoundLibCommon.h
  • hsSndRsrcAudioTableType : HsSoundLibCommon.h
  • HsSndSetUserVolume() : HsSoundLib.h
  • HsSndSwitchGetPort() : HsSoundLib.h
  • HsSndSwitchID : HsSoundLibCommon.h
  • hsSndSwitchID_InHostPlay : HsSoundLibCommon.h
  • hsSndSwitchID_InMic : HsSoundLibCommon.h
  • hsSndSwitchID_InRadioSpkr : HsSoundLibCommon.h
  • hsSndSwitchID_OutHostRec : HsSoundLibCommon.h
  • hsSndSwitchID_OutRadioMic : HsSoundLibCommon.h
  • hsSndSwitchID_RadioCall : HsSoundLibCommon.h
  • HsSndSwitchSetPort() : HsSoundLib.h
  • hsSndSyncStart : HsSoundLibCommon.h
  • hsSndSyncStop : HsSoundLibCommon.h
  • hsSndSysBeepTag : HsSoundLibCommon.h
  • hsSndSysBeepType : HsSoundLibCommon.h
  • HsSndTonePlay() : HsSoundLib.h
  • HsSndToneStop() : HsSoundLib.h
  • hsSndToneType_Square : HsSoundLibCommon.h
  • hsSoundLibCreatorID : HsSoundLibCommon.h
  • hsSoundLibErrorClass : HsErrorClasses.h
  • hsSoundLibName : HsSoundLibCommon.h
  • hsSoundLibTypeID : HsSoundLibCommon.h
  • HsSpringboardNotSupported() : HsExt.h
  • hsSrmExtErrorClass : HsErrorClasses.h
  • HsStartMemoryTracing() : HsExt.h
  • hsStatusGadgetBattery : HsExtCommon.h
  • hsStatusGadgetSignal : HsExtCommon.h
  • HsStatusGadgetTypeEnum : HsExtCommon.h
  • HsStatusSetGadgetType() : HsExt.h
  • HsStatusUpdateGadgets() : HsExt.h
  • hsSTEErrorClass : HsErrorClasses.h
  • hsTasLibErrorClass : HsErrorClasses.h
  • hsTetheredTreo : HsCreators.h
  • hsTouchscreenDisableFlagDuringCall : HsExtCommon.h
  • hsTouchscreenDisableFlagIncomingCall : HsExtCommon.h
  • HsTurnRadioOn() : HsExt.h
  • HsTwoFontSelect() : HsExt.h
  • HsTxtIsAscii() : HsExt.h
  • HsTxtNumChars() : HsExt.h
  • HsTxtPrepFindString() : HsExt.h
  • HsTxtTruncateString() : HsExt.h
  • HsUnimplemented() : HsExt.h
  • hsUninstallSerialWrapper : HsExtTraps.h
  • HsUtilBbutHitBigButton() : HsExtUtilBigButton.h
  • HsUtilBbutInstallFromResource() : HsExtUtilBigButton.h
  • HsUtilBbutInstallNewButton() : HsExtUtilBigButton.h
  • HsUtilBbutSetBitmap() : HsExtUtilBigButton.h
  • HsUtilBbutSetLabel() : HsExtUtilBigButton.h
  • hsVersionStringSize : HsExtCommon.h
  • hsVerStrCarrierID : HsExtCommon.h
  • hsVerStrComplete : HsExtCommon.h
  • HsVerStrEnum : HsExtCommon.h
  • hsVerStrFirmwareVer : HsExtCommon.h
  • hsVerStrHardware : HsExtCommon.h
  • hsVerStrLifeTime : HsExtCommon.h
  • hsVerStrPalmOSVer : HsExtCommon.h
  • hsVerStrProductName : HsExtCommon.h
  • hsVerStrProductRev : HsExtCommon.h
  • hsVerStrROMBuild : HsExtCommon.h
  • hsVerStrSerialNo : HsExtCommon.h
  • hsWordCorrectMaxWordLen : HsExtCommon.h
  • htcManufacturingInfoToken : HsCreators.h
  • htmlDirDown : HtmlLib68K.h
  • htmlDirLeft : HtmlLib68K.h
  • htmlDirRight : HtmlLib68K.h
  • htmlDirUp : HtmlLib68K.h
  • HtmlDisplayMode : HtmlLib68K.h
  • htmlErrCantOpen : HtmlLib68K.h
  • htmlErrInUse : HtmlLib68K.h
  • htmlErrInvalidParam : HtmlLib68K.h
  • htmlErrNotFound : HtmlLib68K.h
  • htmlErrNotInitialized : HtmlLib68K.h
  • htmlErrorClass : HtmlLib68K.h
  • htmlErrOutOfMemory : HtmlLib68K.h
  • htmlFaithfulDisplayMode : HtmlLib68K.h
  • HtmlFocusTargetType : HtmlLib68K.h
  • htmlHandheldDisplayMode : HtmlLib68K.h
  • htmlHttpMethodGet : HtmlLib68K.h
  • htmlHttpMethodPost : HtmlLib68K.h
  • HtmlLibAbortRenderData() : HtmlLib68K.h
  • HtmlLibAddImageData() : HtmlLib68K.h
  • HtmlLibAddTextData() : HtmlLib68K.h
  • HtmlLibCanScroll() : HtmlLib68K.h
  • HtmlLibClearScreen() : HtmlLib68K.h
  • HtmlLibClose() : HtmlLib68K.h
  • HtmlLibCreateContentObject() : HtmlLib68K.h
  • HtmlLibDBType : HtmlLib68K.h
  • HtmlLibDestroyContentObject() : HtmlLib68K.h
  • HtmlLibFinalize() : HtmlLib68K.h
  • HtmlLibFindText() : HtmlLib68K.h
  • HtmlLibGetTargetInfo() : HtmlLib68K.h
  • HtmlLibGetTextSelection() : HtmlLib68K.h
  • HtmlLibGetVScrollPosition() : HtmlLib68K.h
  • HtmlLibID : HtmlLib68K.h
  • HtmlLibInclusionCallback : HtmlLib68K.h
  • HtmlLibInitialize() : HtmlLib68K.h
  • HtmlLibInitializeWithHeapSize() : HtmlLib68K.h
  • HtmlLibLinkSelCallback : HtmlLib68K.h
  • HtmlLibName : HtmlLib68K.h
  • HtmlLibNotifyUIEvent() : HtmlLib68K.h
  • HtmlLibOpen() : HtmlLib68K.h
  • HtmlLibProgress() : HtmlLib68K.h
  • htmlLibProgressEvent : HtmlLib68K.h
  • HtmlLibRedrawScreen() : HtmlLib68K.h
  • HtmlLibRenderData() : HtmlLib68K.h
  • HtmlLibResetFocusInfo() : HtmlLib68K.h
  • HtmlLibResizeScreen() : HtmlLib68K.h
  • HtmlLibScanPhoneNumberCallback : HtmlLib68K.h
  • HtmlLibSetBiggerFont() : HtmlLib68K.h
  • HtmlLibSetDisplayMode() : HtmlLib68K.h
  • HtmlLibSetFocusStatus() : HtmlLib68K.h
  • HtmlLibSetFormWidgetProc() : HtmlLib68K.h
  • HtmlLibSetImageMemoryLimit() : HtmlLib68K.h
  • HtmlLibSetInclusionCallback() : HtmlLib68K.h
  • HtmlLibSetLinkSelectionCallback() : HtmlLib68K.h
  • HtmlLibSetScanPhoneNumberCallback() : HtmlLib68K.h
  • HtmlLibSetScrollbarMode() : HtmlLib68K.h
  • HtmlLibSetScrollbars() : HtmlLib68K.h
  • HtmlLibSetSubmitFormCallback() : HtmlLib68K.h
  • HtmlLibSetVScrollPosition() : HtmlLib68K.h
  • HtmlLibSleep() : HtmlLib68K.h
  • HtmlLibSubmitFormCallback : HtmlLib68K.h
  • HtmlLibWake() : HtmlLib68K.h
  • htmlNoPageScrollbarMode : HtmlLib68K.h
  • htmlNormalScrollbarMode : HtmlLib68K.h
  • htmlProgressBusy : HtmlLib68K.h
  • htmlProgressDone : HtmlLib68K.h
  • htmlProgressError : HtmlLib68K.h
  • htmlProgressOutOfMemory : HtmlLib68K.h
  • HtmlProgressStatus : HtmlLib68K.h
  • HtmlScrollbarMode : HtmlLib68K.h
  • HtmlScrollDirection : HtmlLib68K.h
  • HtmlSubmitFormMethod : HtmlLib68K.h
  • htmlTargetElement : HtmlLib68K.h
  • htmlTargetEmbed : HtmlLib68K.h
  • htmlTargetIFrame : HtmlLib68K.h
  • htmlTargetImage : HtmlLib68K.h
  • htmlTargetInputButton : HtmlLib68K.h
  • htmlTargetInputCheckbox : HtmlLib68K.h
  • htmlTargetInputFile : HtmlLib68K.h
  • htmlTargetInputPassword : HtmlLib68K.h
  • htmlTargetInputRadio : HtmlLib68K.h
  • htmlTargetInputReset : HtmlLib68K.h
  • htmlTargetInputSelect : HtmlLib68K.h
  • htmlTargetInputSubmit : HtmlLib68K.h
  • htmlTargetInputText : HtmlLib68K.h
  • htmlTargetInputTextarea : HtmlLib68K.h
  • httpAuthPath_ : HS_HTTPLibConst.h
  • httpAuthPathAncestor : HS_HTTPLibConst.h
  • httpAuthPathCousin : HS_HTTPLibConst.h
  • httpAuthPathDescendant : HS_HTTPLibConst.h
  • httpAuthPathEnum : HS_HTTPLibConst.h
  • httpAuthPathSame : HS_HTTPLibConst.h
  • httpAuthTarget_ : HS_HTTPLibConst.h
  • httpAuthTargetEnum : HS_HTTPLibConst.h
  • httpAuthTargetPage : HS_HTTPLibConst.h
  • httpAuthTargetProxy : HS_HTTPLibConst.h
  • httpAuthTargetTargets : HS_HTTPLibConst.h
  • httpAuthType_ : HS_HTTPLibConst.h
  • httpAuthTypeBasic : HS_HTTPLibConst.h
  • httpAuthTypeDigest : HS_HTTPLibConst.h
  • httpAuthTypeEnum : HS_HTTPLibConst.h
  • httpAuthTypeNone : HS_HTTPLibConst.h
  • httpAuthTypeTypes : HS_HTTPLibConst.h
  • httpCetListTypeBrowser : HS_HTTPLibConst.h
  • httpCetListTypeClient : HS_HTTPLibConst.h
  • httpCetListTypeServer : HS_HTTPLibConst.h
  • httpCetListTypeTypes : HS_HTTPLibConst.h
  • httpCetListTypeUnknown : HS_HTTPLibConst.h
  • httpCookie_ : HS_HTTPLibConst.h
  • httpCookieAlwaysSet : HS_HTTPLibConst.h
  • httpCookieClearAll : HS_HTTPLibConst.h
  • httpCookieClearAtFinalize : HS_HTTPLibConst.h
  • httpCookieClearSessionCookiesOnly : HS_HTTPLibConst.h
  • httpCookieEnum : HS_HTTPLibConst.h
  • httpCookieNeverSet : HS_HTTPLibConst.h
  • httpCookieNotifyBeforeSet : HS_HTTPLibConst.h
  • httpDNSModeIPV4Only : HS_HTTPLibConst.h
  • httpError_ : HS_HTTPLibConst.h
  • httpErrorAuthFormat : HS_HTTPLibConst.h
  • httpErrorAuthNoHeader : HS_HTTPLibConst.h
  • httpErrorAuthUnknown : HS_HTTPLibConst.h
  • httpErrorCacheExpire : HS_HTTPLibConst.h
  • httpErrorCacheNone : HS_HTTPLibConst.h
  • httpErrorDNSInval : HS_HTTPLibConst.h
  • httpErrorDNSNoServer : HS_HTTPLibConst.h
  • httpErrorDNSNotFound : HS_HTTPLibConst.h
  • httpErrorDNSTimedout : HS_HTTPLibConst.h
  • httpErrorEnum : HS_HTTPLibConst.h
  • httpErrorGeneric : HS_HTTPLibConst.h
  • httpErrorInval : HS_HTTPLibConst.h
  • httpErrorIOSleep : HS_HTTPLibConst.h
  • httpErrorNoMem : HS_HTTPLibConst.h
  • httpErrorOK : HS_HTTPLibConst.h
  • httpErrorRedirectCanceled : HS_HTTPLibConst.h
  • httpErrorRedirectFormat : HS_HTTPLibConst.h
  • httpErrorReqBodySizeOver : HS_HTTPLibConst.h
  • httpErrorReqHeaderSizeOver : HS_HTTPLibConst.h
  • httpErrorReqTimedout : HS_HTTPLibConst.h
  • httpErrorReqTooManyContinue : HS_HTTPLibConst.h
  • httpErrorRspHeaderSizeOver : HS_HTTPLibConst.h
  • httpErrorRspTimedout : HS_HTTPLibConst.h
  • httpErrorSSLConnect : HS_HTTPLibConst.h
  • httpErrorSSLHandShake : HS_HTTPLibConst.h
  • httpErrorSSLRead : HS_HTTPLibConst.h
  • httpErrorSSLWrite : HS_HTTPLibConst.h
  • httpErrorTCPConnect : HS_HTTPLibConst.h
  • httpErrorTCPOpen : HS_HTTPLibConst.h
  • httpErrorTCPRead : HS_HTTPLibConst.h
  • httpErrorTCPWrite : HS_HTTPLibConst.h
  • httpErrorTLSIntolerant : HS_HTTPLibConst.h
  • httpErrorWouldBlock : HS_HTTPLibConst.h
  • httpHeaderID_ : HS_HTTPLibConst.h
  • httpHeaderIDAccept : HS_HTTPLibConst.h
  • httpHeaderIDAcceptCharset : HS_HTTPLibConst.h
  • httpHeaderIDAcceptEncoding : HS_HTTPLibConst.h
  • httpHeaderIDAcceptLanguage : HS_HTTPLibConst.h
  • httpHeaderIDAcceptRanges : HS_HTTPLibConst.h
  • httpHeaderIDAge : HS_HTTPLibConst.h
  • httpHeaderIDAllow : HS_HTTPLibConst.h
  • httpHeaderIDAuthenticationInfo : HS_HTTPLibConst.h
  • httpHeaderIDAuthorization : HS_HTTPLibConst.h
  • httpHeaderIDCacheControl : HS_HTTPLibConst.h
  • httpHeaderIDConnection : HS_HTTPLibConst.h
  • httpHeaderIDContentDisposition : HS_HTTPLibConst.h
  • httpHeaderIDContentEncoding : HS_HTTPLibConst.h
  • httpHeaderIDContentLanguage : HS_HTTPLibConst.h
  • httpHeaderIDContentLength : HS_HTTPLibConst.h
  • httpHeaderIDContentLocation : HS_HTTPLibConst.h
  • httpHeaderIDContentMD5 : HS_HTTPLibConst.h
  • httpHeaderIDContentRange : HS_HTTPLibConst.h
  • httpHeaderIDContentType : HS_HTTPLibConst.h
  • httpHeaderIDCookie : HS_HTTPLibConst.h
  • httpHeaderIDDate : HS_HTTPLibConst.h
  • httpHeaderIDEnum : HS_HTTPLibConst.h
  • httpHeaderIDENUMS : HS_HTTPLibConst.h
  • httpHeaderIDETag : HS_HTTPLibConst.h
  • httpHeaderIDExpect : HS_HTTPLibConst.h
  • httpHeaderIDExpires : HS_HTTPLibConst.h
  • httpHeaderIDFrom : HS_HTTPLibConst.h
  • httpHeaderIDHost : HS_HTTPLibConst.h
  • httpHeaderIDIfMatch : HS_HTTPLibConst.h
  • httpHeaderIDIfModifiedSince : HS_HTTPLibConst.h
  • httpHeaderIDIfNoneMatch : HS_HTTPLibConst.h
  • httpHeaderIDIfRange : HS_HTTPLibConst.h
  • httpHeaderIDIfUnmodifiedSince : HS_HTTPLibConst.h
  • httpHeaderIDKeepAlive : HS_HTTPLibConst.h
  • httpHeaderIDLastModified : HS_HTTPLibConst.h
  • httpHeaderIDLocation : HS_HTTPLibConst.h
  • httpHeaderIDMaxForwards : HS_HTTPLibConst.h
  • httpHeaderIDPragma : HS_HTTPLibConst.h
  • httpHeaderIDProxyAuthenticate : HS_HTTPLibConst.h
  • httpHeaderIDProxyAuthenticationInfo : HS_HTTPLibConst.h
  • httpHeaderIDProxyAuthorization : HS_HTTPLibConst.h
  • httpHeaderIDProxyConnection : HS_HTTPLibConst.h
  • httpHeaderIDRange : HS_HTTPLibConst.h
  • httpHeaderIDReferer : HS_HTTPLibConst.h
  • httpHeaderIDRefresh : HS_HTTPLibConst.h
  • httpHeaderIDRetryAfter : HS_HTTPLibConst.h
  • httpHeaderIDServer : HS_HTTPLibConst.h
  • httpHeaderIDSetCookie : HS_HTTPLibConst.h
  • httpHeaderIDTE : HS_HTTPLibConst.h
  • httpHeaderIDTrailer : HS_HTTPLibConst.h
  • httpHeaderIDTransferEncoding : HS_HTTPLibConst.h
  • httpHeaderIDUpgrade : HS_HTTPLibConst.h
  • httpHeaderIDUserAgent : HS_HTTPLibConst.h
  • httpHeaderIDVary : HS_HTTPLibConst.h
  • httpHeaderIDVia : HS_HTTPLibConst.h
  • httpHeaderIDWarning : HS_HTTPLibConst.h
  • httpHeaderIDWWWAuthenticate : HS_HTTPLibConst.h
  • httpHeaderType_ : HS_HTTPLibConst.h
  • httpHeaderTypeEntity : HS_HTTPLibConst.h
  • httpHeaderTypeEnum : HS_HTTPLibConst.h
  • httpHeaderTypeGeneral : HS_HTTPLibConst.h
  • httpHeaderTypeOther : HS_HTTPLibConst.h
  • httpHeaderTypeRequest : HS_HTTPLibConst.h
  • httpHeaderTypeResponse : HS_HTTPLibConst.h
  • httpHeaderTypeTypes : HS_HTTPLibConst.h
  • httpIPAddrLenV4 : HS_HTTPLibApp.h
  • httpIPAddrTypeV4 : HS_HTTPLibApp.h
  • httpMethod_ : HS_HTTPLibConst.h
  • httpMethodCONNECT : HS_HTTPLibConst.h
  • httpMethodDELETE : HS_HTTPLibConst.h
  • httpMethodEnum : HS_HTTPLibConst.h
  • httpMethodGET : HS_HTTPLibConst.h
  • httpMethodHEAD : HS_HTTPLibConst.h
  • httpMethodMethods : HS_HTTPLibConst.h
  • httpMethodOPTIONS : HS_HTTPLibConst.h
  • httpMethodPOST : HS_HTTPLibConst.h
  • httpMethodPUT : HS_HTTPLibConst.h
  • httpMethodTRACE : HS_HTTPLibConst.h
  • httpPostMULTIPART : HS_HTTPLibConst.h
  • httpPostPLAINTEXT : HS_HTTPLibConst.h
  • httpPostURLENCODED : HS_HTTPLibConst.h
  • httpScheme_ : HS_HTTPLibConst.h
  • httpSchemeEnum : HS_HTTPLibConst.h
  • httpSchemeHTTP : HS_HTTPLibConst.h
  • httpSchemeHTTPS : HS_HTTPLibConst.h
  • httpSchemeSchemes : HS_HTTPLibConst.h
  • httpSSLFlagConnTLS : HS_HTTPLibConst.h
  • httpSSLFlagConnV2 : HS_HTTPLibConst.h
  • httpSSLFlagConnV2TLS : HS_HTTPLibConst.h
  • httpSSLFlagConnV2V3 : HS_HTTPLibConst.h
  • httpSSLFlagConnV2V3TLS : HS_HTTPLibConst.h
  • httpSSLFlagConnV3 : HS_HTTPLibConst.h
  • httpSSLFlagConnV3TLS : HS_HTTPLibConst.h
  • httpStatusCode_ : HS_HTTPLibConst.h
  • httpStatusCodeAccepted : HS_HTTPLibConst.h
  • httpStatusCodeBadGateway : HS_HTTPLibConst.h
  • httpStatusCodeBadRequest : HS_HTTPLibConst.h
  • httpStatusCodeConflict : HS_HTTPLibConst.h
  • httpStatusCodeContinue : HS_HTTPLibConst.h
  • httpStatusCodeCreated : HS_HTTPLibConst.h
  • httpStatusCodeEnum : HS_HTTPLibConst.h
  • httpStatusCodeExpectationFailed : HS_HTTPLibConst.h
  • httpStatusCodeForbidden : HS_HTTPLibConst.h
  • httpStatusCodeFound : HS_HTTPLibConst.h
  • httpStatusCodeGatewayTimeout : HS_HTTPLibConst.h
  • httpStatusCodeGone : HS_HTTPLibConst.h
  • httpStatusCodeHTTPVersionNotSupported : HS_HTTPLibConst.h
  • httpStatusCodeInternalServerError : HS_HTTPLibConst.h
  • httpStatusCodeLengthRequired : HS_HTTPLibConst.h
  • httpStatusCodeMethodNotAllowed : HS_HTTPLibConst.h
  • httpStatusCodeMovedPermanently : HS_HTTPLibConst.h
  • httpStatusCodeMultipleChoices : HS_HTTPLibConst.h
  • httpStatusCodeNoContent : HS_HTTPLibConst.h
  • httpStatusCodeNonAuthoritativeInformation : HS_HTTPLibConst.h
  • httpStatusCodeNotAcceptable : HS_HTTPLibConst.h
  • httpStatusCodeNotFound : HS_HTTPLibConst.h
  • httpStatusCodeNotImplemented : HS_HTTPLibConst.h
  • httpStatusCodeNotModified : HS_HTTPLibConst.h
  • httpStatusCodeOK : HS_HTTPLibConst.h
  • httpStatusCodePartialContent : HS_HTTPLibConst.h
  • httpStatusCodePaymentRequired : HS_HTTPLibConst.h
  • httpStatusCodePreconditionFailed : HS_HTTPLibConst.h
  • httpStatusCodeProxyAuthenticationRequired : HS_HTTPLibConst.h
  • httpStatusCodeRequestedRangeNotSatisfiable : HS_HTTPLibConst.h
  • httpStatusCodeRequestEntityTooLarge : HS_HTTPLibConst.h
  • httpStatusCodeRequestTimeout : HS_HTTPLibConst.h
  • httpStatusCodeRequestURITooLarge : HS_HTTPLibConst.h
  • httpStatusCodeResetContent : HS_HTTPLibConst.h
  • httpStatusCodeSeeOther : HS_HTTPLibConst.h
  • httpStatusCodeServiceUnavailable : HS_HTTPLibConst.h
  • httpStatusCodeSwitchingProtocols : HS_HTTPLibConst.h
  • httpStatusCodeTemporaryRedirect : HS_HTTPLibConst.h
  • httpStatusCodeUnauthorized : HS_HTTPLibConst.h
  • httpStatusCodeUnsupportedMediaType : HS_HTTPLibConst.h
  • httpStatusCodeUseProxy : HS_HTTPLibConst.h
  • httpStreamRead : HS_HTTPLibConst.h
  • httpStreamReadWrite : HS_HTTPLibConst.h
  • httpStreamState_ : HS_HTTPLibConst.h
  • httpStreamStateDelete : HS_HTTPLibConst.h
  • httpStreamStateDormant : HS_HTTPLibConst.h
  • httpStreamStateEnum : HS_HTTPLibConst.h
  • httpStreamStateNew : HS_HTTPLibConst.h
  • httpStreamStateObsolete : HS_HTTPLibConst.h
  • httpStreamStateReqConnect : HS_HTTPLibConst.h
  • httpStreamStateReqConnecting : HS_HTTPLibConst.h
  • httpStreamStateReqCreated : HS_HTTPLibConst.h
  • httpStreamStateReqOpen : HS_HTTPLibConst.h
  • httpStreamStateReqProxyConnect : HS_HTTPLibConst.h
  • httpStreamStateReqProxyConnecting : HS_HTTPLibConst.h
  • httpStreamStateReqResolve : HS_HTTPLibConst.h
  • httpStreamStateReqResolving : HS_HTTPLibConst.h
  • httpStreamStateReqSending : HS_HTTPLibConst.h
  • httpStreamStateReqSent : HS_HTTPLibConst.h
  • httpStreamStateReqSSLHandShaked : HS_HTTPLibConst.h
  • httpStreamStateReqSSLHandShaking : HS_HTTPLibConst.h
  • httpStreamStateRspContinue : HS_HTTPLibConst.h
  • httpStreamStateRspEntityReceived : HS_HTTPLibConst.h
  • httpStreamStateRspEntityReceiving : HS_HTTPLibConst.h
  • httpStreamStateRspHeaderReceived : HS_HTTPLibConst.h
  • httpStreamStateRspHeaderReceiving : HS_HTTPLibConst.h
  • httpStreamStateRspHeaderWaiting : HS_HTTPLibConst.h
  • httpStreamStateStates : HS_HTTPLibConst.h
  • httpStreamTextCRCR : HS_HTTPLibConst.h
  • httpStreamTextCRLF : HS_HTTPLibConst.h
  • httpStreamTextCRLFCRLF : HS_HTTPLibConst.h
  • httpStreamTextLFLF : HS_HTTPLibConst.h
  • httpStreamWrite : HS_HTTPLibConst.h
  • httpUASelectTypeHost : HS_HTTPLib68K.h
  • httpUASelectTypePath : HS_HTTPLib68K.h
  • httpVersion_ : HS_HTTPLibConst.h
  • httpVersion_0_9 : HS_HTTPLibConst.h
  • httpVersion_1_0 : HS_HTTPLibConst.h
  • httpVersion_1_1 : HS_HTTPLibConst.h
  • httpVersionEnum : HS_HTTPLibConst.h
  • httpVersionVersions : HS_HTTPLibConst.h
  • HWUBlinkLED() : HardwareUtils68K.h
  • HWUClose() : HardwareUtils68K.h
  • HWUEnableDisplay() : HardwareUtils68K.h
  • HWUGetDisplayState() : HardwareUtils68K.h
  • HWUOpen() : HardwareUtils68K.h
  • HWUSetBlinkRate() : HardwareUtils68K.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:38 2008 for Palm API Guide


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- i -

  • IBG_ERRNOTPOSSIBLE : PalmBGService.h
  • IBG_ERRREQUEST : PalmBGService.h
  • IBG_ERRRQSTDONE : PalmBGService.h
  • IBG_ERRRSPTOOBIG : PalmBGService.h
  • IBG_ERRSHUTDOWN : PalmBGService.h
  • IBG_ERRTIMEOUT : PalmBGService.h
  • IBG_MAXBUFSZ : PalmBGService.h
  • IBG_SUCCESS : PalmBGService.h
  • IBSS : PalmWiFiCommon.h
  • IDatSyncSource : DatebookLibCommon.h
  • ImageIteratorHandle : ImageLibCommon.h
  • ImageLibBitmapDelete() : ImageLib.h
  • ImageLibCameraExists() : ImageLib.h
  • ImageLibCheckLockedImages() : ImageLib.h
  • ImageLibClose() : ImageLib.h
  • ImageLibCopyImage() : ImageLib.h
  • ImageLibCopyImageFromVFS() : ImageLib.h
  • ImageLibCopyImageToBuffer() : ImageLib.h
  • ImageLibCopyImageToFile() : ImageLib.h
  • ImageLibCopyImageToVFS() : ImageLib.h
  • ImageLibCreatorID : ImageLibCommon.h
  • ImageLibDeleteImage() : ImageLib.h
  • ImageLibDoAttachImageDialog() : ImageLib.h
  • ImageLibDrawJPEG() : ImageLib.h
  • imageLibErrBadBitmapType : ImageLibCommon.h
  • imageLibErrBadColorspace : ImageLibCommon.h
  • imageLibErrBadData : ImageLibCommon.h
  • imageLibErrBadDimensions : ImageLibCommon.h
  • imageLibErrBadImageDepth : ImageLibCommon.h
  • imageLibErrBadImageType : ImageLibCommon.h
  • imageLibErrBadParam : ImageLibCommon.h
  • imageLibErrBadScaleFactor : ImageLibCommon.h
  • imageLibErrBadThumbnailType : ImageLibCommon.h
  • imageLibErrImageAlreadyDownsized : ImageLibCommon.h
  • imageLibErrImageLocked : ImageLibCommon.h
  • imageLibErrInitializationFailed : ImageLibCommon.h
  • imageLibErrInternalFailure : ImageLibCommon.h
  • imageLibErrNoCamera : ImageLibCommon.h
  • imageLibErrorClass : ImageLibCommon.h
  • imageLibErrReadFailure : ImageLibCommon.h
  • imageLibErrThumnailExists : ImageLibCommon.h
  • imageLibErrWriteFailure : ImageLibCommon.h
  • ImageLibFindImageByID() : ImageLib.h
  • ImageLibGetAveragePictureSize() : ImageLib.h
  • ImageLibGetDimensions() : ImageLib.h
  • ImageLibGetDimensionsJPEG() : ImageLib.h
  • ImageLibGetDimensionsVFS() : ImageLib.h
  • ImageLibGetImageDatabases() : ImageLib.h
  • ImageLibGetImageID() : ImageLib.h
  • ImageLibGetImageInfo() : ImageLib.h
  • ImageLibGetJPEGQuality() : ImageLib.h
  • ImageLibGetVersion() : ImageLib.h
  • ImageLibImageBitmapCreate() : ImageLib.h
  • ImageLibImageBitmapCreateFromVFS() : ImageLib.h
  • ImageLibImageBitmapFill() : ImageLib.h
  • ImageLibImageBitmapFillFromVFS() : ImageLib.h
  • ImageLibImageCapture() : ImageLib.h
  • ImageLibImageDraw() : ImageLib.h
  • ImageLibImageDrawFromVFS() : ImageLib.h
  • ImageLibImageSave() : ImageLib.h
  • ImageLibInsertImageFromBuffer() : ImageLib.h
  • ImageLibInsertImageFromFile() : ImageLib.h
  • ImageLibIterateImages() : ImageLib.h
  • ImageLibIterateVFSImages() : ImageLib.h
  • ImageLibIterDeleteImage() : ImageLib.h
  • ImageLibIterDrawImage() : ImageLib.h
  • ImageLibIterDrawThumbnail() : ImageLib.h
  • ImageLibIterFree() : ImageLib.h
  • ImagelibIterGetCount() : ImageLib.h
  • ImageLibIterGetDimensions() : ImageLib.h
  • ImageLibIterGetImageInfo() : ImageLib.h
  • ImageLibIterRefresh() : ImageLib.h
  • ImageLibIterRemoveImage() : ImageLib.h
  • ImageLibIterResize() : ImageLib.h
  • ImageLibIterSearch() : ImageLib.h
  • ImageLibIterSort() : ImageLib.h
  • ImageLibLockImage() : ImageLib.h
  • ImageLibName : ImageLibCommon.h
  • ImageLibOpen() : ImageLib.h
  • ImageLibPreviewBitmapCreate() : ImageLib.h
  • ImageLibPreviewBitmapFill() : ImageLib.h
  • ImageLibPreviewDraw() : ImageLib.h
  • ImageLibPreviewStart() : ImageLib.h
  • ImageLibPreviewStop() : ImageLib.h
  • ImageLibProgressCallbackType : ImageLibCommon.h
  • ImageLibResize() : ImageLib.h
  • ImageLibResizeImage() : ImageLib.h
  • ImageLibResizeJPEG() : ImageLib.h
  • ImageLibResizeVFS() : ImageLib.h
  • ImageLibSetImageID() : ImageLib.h
  • ImageLibSetImageInfo() : ImageLib.h
  • ImageLibSetJPEGQuality() : ImageLib.h
  • ImageLibSetProgressCallback() : ImageLib.h
  • ImageLibThumbnailBitmapCreate() : ImageLib.h
  • ImageLibThumbnailBitmapCreateFromVFS() : ImageLib.h
  • ImageLibThumbnailBitmapFill() : ImageLib.h
  • ImageLibThumbnailBitmapFillFromVFS() : ImageLib.h
  • ImageLibThumbnailDraw() : ImageLib.h
  • ImageLibThumbnailDrawFromVFS() : ImageLib.h
  • ImageLibTurnCameraOff() : ImageLib.h
  • ImageLibTypeID : ImageLibCommon.h
  • immediateLockMode : HsPhoneTypes.h
  • indicationAuthFailure : HsPhoneEvent.h
  • indicationInitComplete : HsPhoneEvent.h
  • indicationNetworkAvailable : HsPhoneEvent.h
  • indicationNetworkSearch : HsPhoneEvent.h
  • indicationOtaspMsg : HsPhoneEvent.h
  • indicationPasswordAccepted : HsPhoneEvent.h
  • indicationPoweringOffRadio : HsPhoneEvent.h
  • indicationResettingRadio : HsPhoneEvent.h
  • indicationSIMChanged : HsPhoneEvent.h
  • indicationSIMMessages : HsPhoneEvent.h
  • indicationSIMReady : HsPhoneEvent.h
  • indicationStartingRadio : HsPhoneEvent.h
  • indicatorBlockedCallerIDChar : HsPhoneCDMATypes.h
  • indicatorNoCallerIDChar : HsPhoneCDMATypes.h
  • indicatorRemainingCallerIDChar : HsPhoneCDMATypes.h
  • InitFontUI() : palmOneVMFontLib.h
  • INLINE : PalmNative.h
  • Int16 : PalmNative.h
  • Int32 : PalmNative.h
  • Int8 : PalmNative.h
  • INVALID_INDEX : PalmNetServices.h
  • IOTAHeaderEscapeSeq : HsPhoneIOTATypes.h
  • IOTANotificationEventType : HsPhoneIOTATypes.h
  • IOTATextHeader : HsPhoneIOTATypes.h
  • IOTATextHeaderLength : HsPhoneIOTATypes.h
  • IOTATextHeaderTerminator : HsPhoneIOTATypes.h
  • IPAllocType : PalmWiFiCommon.h
  • IPAllocType_APIPA : PalmWiFiCommon.h
  • IPAllocType_DHCP : PalmWiFiCommon.h
  • IPAllocType_STATIC : PalmWiFiCommon.h
  • irFtrLowBatteryLevel : palmOneFeatures.h
  • irFtrVersionNumber : palmOneFeatures.h
  • IsFiveWayNavEvent : common/system/palmOneNavigator.h
  • IsFiveWayNavPalmEvent : common/system/palmOneNavigator.h
  • isValidAddressAppRecordFieldEnum : HsPhoneSMSTypes.h
  • isValidDataService : HsPhoneNetworkTypes.h
  • isValidGSMDialCLIRMode : HsPhoneTypes.h
  • isValidGSMDialClirStatus : HsPhoneNetworkTypes.h
  • isValidGSMRegistrationMode : HsPhoneNetworkTypes.h
  • isValidGSMSATEventSetupCallCallTypeEnum : HsPhoneGSMTypes.h
  • isValidGSMSATEventToneTypeEnum : HsPhoneGSMTypes.h
  • isValidGSMSIMMessagesDialogKind : HsPhoneGSMTypes.h
  • isValidPacketDataEndStatus : HsPhoneNetworkTypes.h
  • isValidPDPReadAck : HsPhoneCDMATypes.h
  • isValidPhnAddressField : HsPhoneTypes.h
  • isValidPhnBandSelection : HsPhoneNetworkTypes.h
  • isValidPhnBarFacilityType : HsPhoneNetworkTypes.h
  • isValidPhnCLIRStatus : HsPhoneNetworkTypes.h
  • isValidPhnConnectionEnum : HsPhoneMiscTypes.h
  • isValidPhnConnectStateType : HsPhoneCallControlTypes.h
  • isValidPhnDataChannelType : HsPhoneEvent.h
  • isValidPhnEquipmentMode : HsPhoneMiscTypes.h
  • isValidPhnEventCode : HsPhoneEvent.h
  • isValidPhnForwardModeType : HsPhoneNetworkTypes.h
  • isValidPhnForwardType : HsPhoneNetworkTypes.h
  • isValidPhnGPRSPDPType : HsPhoneGSMTypes.h
  • isValidPhnGPRSQOSType : HsPhoneGSMTypes.h
  • isValidPhnIndicationKind : HsPhoneEvent.h
  • isValidPhnIOTAItemType : HsPhoneIOTATypes.h
  • isValidPhnIOTAStatus : HsPhoneIOTA.h
  • isValidPhnLockMode : HsPhoneTypes.h
  • isValidPhnMIPSessionType : HsPhoneNetworkTypes.h
  • isValidPhnMiscDbgUpdateKind : HsPhoneEvent.h
  • isValidPhnModuleButtonType : HsPhoneEvent.h
  • isValidPhnMsgBoxType : HsPhoneNetworkTypes.h
  • isValidPhnMsgIDType : HsPhoneEvent.h
  • isValidPhnOneXDataFailType : HsPhoneCDMATypes.h
  • isValidPhnOneXProtRevType : HsPhoneNetworkTypes.h
  • isValidPhnOpenDialogType : HsPhoneEvent.h
  • isValidPhnOperatorStatus : HsPhoneNetworkTypes.h
  • isValidPhnPacketDataSessionType : HsPhoneNetworkTypes.h
  • isValidPhnPasswordType : HsPhoneSecurityTypes.h
  • isValidPhnPDPCopyAck : HsPhoneCDMATypes.h
  • isValidPhnPDPDeleteAck : HsPhoneCDMATypes.h
  • isValidPhnPDPIndexType : HsPhoneCDMATypes.h
  • isValidPhnPDPReplaceAck : HsPhoneCDMATypes.h
  • isValidPhnPDPWriteAck : HsPhoneCDMATypes.h
  • isValidPhnPowerType : HsPhoneTypes.h
  • isValidPhnProgressType : HsPhoneEvent.h
  • isValidPhnRegistrationStatus : HsPhoneNetworkTypes.h
  • isValidPhnVibrateType : HsPhoneMiscTypes.h
  • isValidPhoneServiceClassType : HsPhoneTypes.h
  • isValidRoamMode : HsPhoneNetworkTypes.h
  • isValidSATNotificationType : HsPhoneGSMTypes.h
  • isValidSMSMessageStatus : HsPhoneSMSTypes.h
  • isValidSMSMessageType : HsPhoneSMSTypes.h
  • italic : VMFontLibCommon.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:38 2008 for Palm API Guide


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- p -

  • P1cl_CURRENT_VERSION : DatebookLibCommon.h
  • P1clActionType : DatebookLibCommon.h
  • P1clAdd : DatebookLibCommon.h
  • P1clalarmAdvance : DatebookLibCommon.h
  • P1clalarmUnit : DatebookLibCommon.h
  • P1clAlarmUnitType : DatebookLibCommon.h
  • P1clApptHandle : DatebookLibCommon.h
  • P1clApptListHandle : DatebookLibCommon.h
  • P1clApptStatus : DatebookLibCommon.h
  • P1clApptStatusType : DatebookLibCommon.h
  • P1clAttachHandle : DatebookLibCommon.h
  • P1clAttendeeEmail : DatebookLibCommon.h
  • P1clAttendeeFieldType : DatebookLibCommon.h
  • P1clAttendeeHandle : DatebookLibCommon.h
  • P1clAttendeeName : DatebookLibCommon.h
  • P1clAttendeeRole : DatebookLibCommon.h
  • P1clAttendeeRoleType : DatebookLibCommon.h
  • P1clBlobSizeType : DatebookLibCommon.h
  • P1clBusy : DatebookLibCommon.h
  • P1clCategory : DatebookLibCommon.h
  • P1clColor : DatebookLibCommon.h
  • P1clCreatorIDType : DatebookLibCommon.h
  • P1clDataBlobType : DatebookLibCommon.h
  • P1clDateOfAppt : DatebookLibCommon.h
  • P1clDays : DatebookLibCommon.h
  • P1clDelete : DatebookLibCommon.h
  • P1clDeleteAll : DatebookLibCommon.h
  • P1clDeleteCurrent : DatebookLibCommon.h
  • P1clDeleteCurrentFuture : DatebookLibCommon.h
  • P1clDeleteEntry : DatebookLibCommon.h
  • P1clDeleteType : DatebookLibCommon.h
  • P1clDescription : DatebookLibCommon.h
  • P1clDeviceTimeZone : DatebookLibCommon.h
  • P1clDirty : DatebookLibCommon.h
  • P1clEndTime : DatebookLibCommon.h
  • P1clErrAlarmDoesNotExist : DatebookLibCommon.h
  • P1clErrAlreadyInUse : DatebookLibCommon.h
  • P1clErrAlreadyInWriteMode : DatebookLibCommon.h
  • P1clErrAppInfoIsMising : DatebookLibCommon.h
  • P1clErrApptBusy : DatebookLibCommon.h
  • P1clErrApptNotFound : DatebookLibCommon.h
  • P1clErrApptNotLocked : DatebookLibCommon.h
  • P1clErrAttachAlreadyExist : DatebookLibCommon.h
  • P1clErrAttachNotExist : DatebookLibCommon.h
  • P1clErrAttachOverFlow : DatebookLibCommon.h
  • P1clErrAttachOverflow : DatebookLibCommon.h
  • P1clErrAttendeeNotFound : DatebookLibCommon.h
  • P1clErrAttendeeOutofLimit : DatebookLibCommon.h
  • P1clErrCategoryNotFound : DatebookLibCommon.h
  • P1clErrDescDoesNotExist : DatebookLibCommon.h
  • P1clErrEmptyAppt : DatebookLibCommon.h
  • P1clErrEmptyDateBook : DatebookLibCommon.h
  • P1clErrFailedToEmptyDatabase : DatebookLibCommon.h
  • P1clErrFieldNotExist : DatebookLibCommon.h
  • P1clErrFieldNotFound : DatebookLibCommon.h
  • P1clErrInvalidAppInfoBlock : DatebookLibCommon.h
  • P1clErrInvalidAtrib : DatebookLibCommon.h
  • P1clErrInvalidField : DatebookLibCommon.h
  • P1clErrInvalidHandle : DatebookLibCommon.h
  • P1clErrInvalidParam : DatebookLibCommon.h
  • P1clErrInvalidReference : DatebookLibCommon.h
  • P1clErrInvalidSession : DatebookLibCommon.h
  • P1clErrLibAlreadyInUse : DatebookLibCommon.h
  • P1clErrLibStillOpen : DatebookLibCommon.h
  • P1clErrListNotExist : DatebookLibCommon.h
  • P1clErrMaxLimitReached : DatebookLibCommon.h
  • P1clErrNoDateTime : DatebookLibCommon.h
  • P1clErrNoteDoesNotExist : DatebookLibCommon.h
  • P1clErrorClass : DatebookLibCommon.h
  • P1clErrOutOfMemory : DatebookLibCommon.h
  • P1clErrReadOnlySession : DatebookLibCommon.h
  • P1clErrRecordNotFound : DatebookLibCommon.h
  • P1clErrRepeatInfoDoesNotExist : DatebookLibCommon.h
  • P1clErrRepeatTypeDoesNotExist : DatebookLibCommon.h
  • P1clErrSizeParamOverFlow : DatebookLibCommon.h
  • P1clErrStringNotFound : DatebookLibCommon.h
  • P1clErrTooManyClients : DatebookLibCommon.h
  • P1clErrTooManySession : DatebookLibCommon.h
  • P1clErrUIdExist : DatebookLibCommon.h
  • P1clErrUIdNotFound : DatebookLibCommon.h
  • P1clErrVerNotSupported : DatebookLibCommon.h
  • P1clEventTimeZone : DatebookLibCommon.h
  • P1clExceptionDate : DatebookLibCommon.h
  • P1clFieldTypes : DatebookLibCommon.h
  • P1clHours : DatebookLibCommon.h
  • P1clIndex : DatebookLibCommon.h
  • P1clLibCreatorID : DatebookLibCommon.h
  • P1clLibName : DatebookLibCommon.h
  • P1clListContinuesOnNextDay : DatebookLibCommon.h
  • P1clListEndSec : DatebookLibCommon.h
  • P1clListEndTime : DatebookLibCommon.h
  • P1clListFieldType : DatebookLibCommon.h
  • P1clListIndex : DatebookLibCommon.h
  • P1clListIsFirstOccurrence : DatebookLibCommon.h
  • P1clListIsLastOccurrence : DatebookLibCommon.h
  • P1clListRepeatsDaily : DatebookLibCommon.h
  • P1clListStartedDayBefore : DatebookLibCommon.h
  • P1clListStartSec : DatebookLibCommon.h
  • P1clListStartTime : DatebookLibCommon.h
  • P1clListUId : DatebookLibCommon.h
  • P1clLocation : DatebookLibCommon.h
  • P1clMaxCategoryLength : DatebookLibCommon.h
  • P1clMinutes : DatebookLibCommon.h
  • P1clModifyEntry : DatebookLibCommon.h
  • P1clNewEntry : DatebookLibCommon.h
  • P1clNote : DatebookLibCommon.h
  • P1clNoType : DatebookLibCommon.h
  • P1clNumFields : DatebookLibCommon.h
  • P1clNumOfAttendee : DatebookLibCommon.h
  • P1cloptionalAttendee : DatebookLibCommon.h
  • P1cloriginator : DatebookLibCommon.h
  • P1clPersistentID : DatebookLibCommon.h
  • P1clPrivate : DatebookLibCommon.h
  • P1clRecordDetailsPtr : DatebookLibCommon.h
  • P1clRemoveAll : DatebookLibCommon.h
  • P1clrepeatDaily : DatebookLibCommon.h
  • P1clrepeatEndDate : DatebookLibCommon.h
  • P1clrepeatFreq : DatebookLibCommon.h
  • P1clrepeatMonthlyByDate : DatebookLibCommon.h
  • P1clrepeatMonthlyByDay : DatebookLibCommon.h
  • P1clrepeatNone : DatebookLibCommon.h
  • P1clrepeatOn : DatebookLibCommon.h
  • P1clrepeatStartofWeek : DatebookLibCommon.h
  • P1clrepeatType : DatebookLibCommon.h
  • P1clRepeatTypes : DatebookLibCommon.h
  • P1clrepeatWeekly : DatebookLibCommon.h
  • P1clrepeatYearly : DatebookLibCommon.h
  • P1clrequiredAttendee : DatebookLibCommon.h
  • P1clSession : DatebookLibCommon.h
  • P1clShowAsBusy : DatebookLibCommon.h
  • P1clShowAsFree : DatebookLibCommon.h
  • P1clShowAsOutOfOffice : DatebookLibCommon.h
  • P1clShowAsTentative : DatebookLibCommon.h
  • P1clStartDateTimeOfAppt : DatebookLibCommon.h
  • P1clStartTime : DatebookLibCommon.h
  • P1clSyncSource : DatebookLibCommon.h
  • P1clTimeZoneType : DatebookLibCommon.h
  • P1clTrapAccountReset : DatebookLibCommon.h
  • P1clTrapAccountResetServerId : DatebookLibCommon.h
  • P1clTrapAddAllToTransactionLog : DatebookLibCommon.h
  • P1clTrapAddAppt : DatebookLibCommon.h
  • P1clTrapAddAttendee : DatebookLibCommon.h
  • P1clTrapAddExceptionDate : DatebookLibCommon.h
  • P1clTrapAddExceptionExt : DatebookLibCommon.h
  • P1clTrapAddLocalToTransactionLog : DatebookLibCommon.h
  • P1clTrapAddMultiDayEvent : DatebookLibCommon.h
  • P1clTrapAddMultiDayEvent2 : DatebookLibCommon.h
  • P1clTrapApptFindNextRepeat : DatebookLibCommon.h
  • P1clTrapApptGetFirstOccurrence : DatebookLibCommon.h
  • P1clTrapApptPostTriggeredAlarms : DatebookLibCommon.h
  • P1clTrapApptRepeatsOnDate : DatebookLibCommon.h
  • P1clTrapApptTimeZoneAbbreviation : DatebookLibCommon.h
  • P1clTrapApptTimeZoneCompare : DatebookLibCommon.h
  • P1clTrapAttnForgetIt : DatebookLibCommon.h
  • P1clTrapCategoryCreateList : DatebookLibCommon.h
  • P1clTrapCategoryDrawBullet : DatebookLibCommon.h
  • P1clTrapCategoryEdit : DatebookLibCommon.h
  • P1clTrapCategoryFind : DatebookLibCommon.h
  • P1clTrapCategoryFreeList : DatebookLibCommon.h
  • P1clTrapCategoryGetColor : DatebookLibCommon.h
  • P1clTrapCategoryGetName : DatebookLibCommon.h
  • P1clTrapCategoryGetNext : DatebookLibCommon.h
  • P1clTrapCategoryGetRGBColor : DatebookLibCommon.h
  • P1clTrapCategoryGetUnusedColor : DatebookLibCommon.h
  • P1clTrapCategoryGetVersion : DatebookLibCommon.h
  • P1clTrapCategoryPopupList : DatebookLibCommon.h
  • P1clTrapCategorySelect : DatebookLibCommon.h
  • P1clTrapCategorySetColor : DatebookLibCommon.h
  • P1clTrapCategorySetName : DatebookLibCommon.h
  • P1clTrapCategorySetTriggerLabel : DatebookLibCommon.h
  • P1clTrapCategoryTruncateName : DatebookLibCommon.h
  • P1clTrapCheckVersion : DatebookLibCommon.h
  • P1clTrapCloseSession : DatebookLibCommon.h
  • P1clTrapConvertFromDeviceTimeZone : DatebookLibCommon.h
  • P1clTrapConvertToDeviceTimeZone : DatebookLibCommon.h
  • P1clTrapCopyRepeatDescription : DatebookLibCommon.h
  • P1clTrapCopyStringField : DatebookLibCommon.h
  • P1clTrapCountryForTimeZoneAbbreviation : DatebookLibCommon.h
  • P1clTrapCreateAttendeeHandle : DatebookLibCommon.h
  • P1clTrapCreateBlobHandle : DatebookLibCommon.h
  • P1clTrapCreateException : DatebookLibCommon.h
  • P1clTrapCreateHandle : DatebookLibCommon.h
  • P1clTrapDateExportVCal : DatebookLibCommon.h
  • P1clTrapDateSetGoToParams : DatebookLibCommon.h
  • P1clTrapDeleteAlarmInfo : DatebookLibCommon.h
  • P1clTrapDeleteAppt : DatebookLibCommon.h
  • P1clTrapDeleteAttendee : DatebookLibCommon.h
  • P1clTrapDeleteBlob : DatebookLibCommon.h
  • P1clTrapDeleteExceptionList : DatebookLibCommon.h
  • P1clTrapDeleteOldAndDuplicates : DatebookLibCommon.h
  • P1clTrapDeleteRepeatInfo : DatebookLibCommon.h
  • P1clTrapDeleteServerId : DatebookLibCommon.h
  • P1clTrapFindConflict : DatebookLibCommon.h
  • P1clTrapFindNextAlarm : DatebookLibCommon.h
  • P1clTrapFindSaveMatch : DatebookLibCommon.h
  • P1clTrapGetAppt : DatebookLibCommon.h
  • P1clTrapGetApptFromListHandle : DatebookLibCommon.h
  • P1clTrapGetApptFromServerId : DatebookLibCommon.h
  • P1clTrapGetApptList : DatebookLibCommon.h
  • P1clTrapGetAttendee : DatebookLibCommon.h
  • P1clTrapGetAttendeeStringField : DatebookLibCommon.h
  • P1clTrapGetAttendeeUInt8Field : DatebookLibCommon.h
  • P1clTrapGetBlob : DatebookLibCommon.h
  • P1clTrapGetBlobCreatorId : DatebookLibCommon.h
  • P1clTrapGetBlobData : DatebookLibCommon.h
  • P1clTrapGetBooleanFromListHandle : DatebookLibCommon.h
  • P1clTrapGetCalendarDBInfo : DatebookLibCommon.h
  • P1clTrapGetConflict : DatebookLibCommon.h
  • P1clTrapGetDateField : DatebookLibCommon.h
  • P1clTrapGetDateTimeField : DatebookLibCommon.h
  • P1clTrapGetDefaultTimeZone : DatebookLibCommon.h
  • P1clTrapGetDSTField : DatebookLibCommon.h
  • P1clTrapGetExceptionDate : DatebookLibCommon.h
  • P1clTrapGetExtendedDescription : DatebookLibCommon.h
  • P1clTrapGetFirstAppt : DatebookLibCommon.h
  • P1clTrapGetFirstAttendee : DatebookLibCommon.h
  • P1clTrapGetInt16Field : DatebookLibCommon.h
  • P1clTrapGetInt8Field : DatebookLibCommon.h
  • P1clTrapGetLastError : DatebookLibCommon.h
  • P1clTrapGetNextAppt : DatebookLibCommon.h
  • P1clTrapGetNextAttendee : DatebookLibCommon.h
  • P1clTrapGetNumOfException : DatebookLibCommon.h
  • P1clTrapGetSessionInfo : DatebookLibCommon.h
  • P1clTrapGetStringField : DatebookLibCommon.h
  • P1clTrapGetTimeField : DatebookLibCommon.h
  • P1clTrapGetTimeFromListHandle : DatebookLibCommon.h
  • P1clTrapGetUInt16Field : DatebookLibCommon.h
  • P1clTrapGetUInt16FromListHandle : DatebookLibCommon.h
  • P1clTrapGetUInt32Field : DatebookLibCommon.h
  • P1clTrapGetUInt32FromListHandle : DatebookLibCommon.h
  • P1clTrapGetUInt8Field : DatebookLibCommon.h
  • P1clTrapGetVersion : DatebookLibCommon.h
  • P1clTrapGiveAllTimedEventsTimeZones : DatebookLibCommon.h
  • P1clTrapHasExtendedDescription : DatebookLibCommon.h
  • P1clTrapHasMultipleOccurences : DatebookLibCommon.h
  • P1clTrapIsEmptyAppt : DatebookLibCommon.h
  • P1clTrapIsException : DatebookLibCommon.h
  • P1clTrapLogMarkAllCompleted : DatebookLibCommon.h
  • P1clTrapNumRecordsInCategory : DatebookLibCommon.h
  • P1clTrapOpenSession : DatebookLibCommon.h
  • P1clTrapPerformPostSyncFunctions : DatebookLibCommon.h
  • P1clTrapPurgeAllAppts : DatebookLibCommon.h
  • P1clTrapPurgeAppts : DatebookLibCommon.h
  • P1clTrapReleaseAttendeeHandle : DatebookLibCommon.h
  • P1clTrapReleaseBlobHandle : DatebookLibCommon.h
  • P1clTrapReleaseHandle : DatebookLibCommon.h
  • P1clTrapSeekRecordInCategory : DatebookLibCommon.h
  • P1clTrapSetAttendeeStringField : DatebookLibCommon.h
  • P1clTrapSetAttendeeUInt8Field : DatebookLibCommon.h
  • P1clTrapSetBlob : DatebookLibCommon.h
  • P1clTrapSetBlobCreatorId : DatebookLibCommon.h
  • P1clTrapSetBlobData : DatebookLibCommon.h
  • P1clTrapSetDateField : DatebookLibCommon.h
  • P1clTrapSetDateTimeField : DatebookLibCommon.h
  • P1clTrapSetDSTField : DatebookLibCommon.h
  • P1clTrapSetExceptionExt : DatebookLibCommon.h
  • P1clTrapSetInt16Field : DatebookLibCommon.h
  • P1clTrapSetInt8Field : DatebookLibCommon.h
  • P1clTrapSetRepeateEndDate : DatebookLibCommon.h
  • P1clTrapSetServerId : DatebookLibCommon.h
  • P1clTrapSetServerIdByUniqueID : DatebookLibCommon.h
  • P1clTrapSetStringField : DatebookLibCommon.h
  • P1clTrapSetTimeField : DatebookLibCommon.h
  • P1clTrapSetUInt16Field : DatebookLibCommon.h
  • P1clTrapSetUInt32Field : DatebookLibCommon.h
  • P1clTrapSetUInt8Field : DatebookLibCommon.h
  • P1clTrapSortCalendar : DatebookLibCommon.h
  • P1clTrapSortCalendarSpecial : DatebookLibCommon.h
  • P1clTrapSplitRepeatingEvent : DatebookLibCommon.h
  • P1clTrapTxnGetChange : DatebookLibCommon.h
  • P1clTrapTxnGetChange2 : DatebookLibCommon.h
  • P1clTrapTxnGetNumChanges : DatebookLibCommon.h
  • P1clTrapTxnIsKnownDataSource : DatebookLibCommon.h
  • P1clTrapTxnLogMarkCompleted : DatebookLibCommon.h
  • P1clTrapTxnPrepareSync : DatebookLibCommon.h
  • P1clTrapTxnSyncComplete : DatebookLibCommon.h
  • P1clTrapUpdateAppt : DatebookLibCommon.h
  • P1clTrapUpdateAttendee : DatebookLibCommon.h
  • P1clTrapUpdateEventsWithDeletedTimeZone : DatebookLibCommon.h
  • P1clTrapUpdateEventsWithEditedTimeZone : DatebookLibCommon.h
  • P1clTxnEntry : DatebookLibCommon.h
  • P1clTxnIterator : DatebookLibCommon.h
  • P1clTypeID : DatebookLibCommon.h
  • P1clTzCountry : DatebookLibCommon.h
  • P1clTzcustom : DatebookLibCommon.h
  • P1clTzdSTAdjustmentInMinutes : DatebookLibCommon.h
  • P1clTzdSTEnd : DatebookLibCommon.h
  • P1clTzdSTStart : DatebookLibCommon.h
  • P1clTzLocName : DatebookLibCommon.h
  • P1clTzuTC : DatebookLibCommon.h
  • P1clUID : DatebookLibCommon.h
  • P1clUpdate : DatebookLibCommon.h
  • palm : VMFontLibCommon.h
  • PALM_OS : Contacts.h
  • PALM_OS_20_VERSION : PalmWiFiCommon.h
  • PALM_PHOTO_ALBUM_ALL : palmOnePhotoCommon.h
  • PALM_PHOTO_ALBUM_ALL_HANDHELD : palmOnePhotoCommon.h
  • PALM_PHOTO_ALBUM_ALL_VFS : palmOnePhotoCommon.h
  • PALM_PHOTO_ALBUM_MAX_NAME : palmOnePhotoCommon.h
  • PALM_PHOTO_MAX_PATH : palmOnePhotoCommon.h
  • PALM_PHOTO_SELECT_ALL : palmOnePhotoCommon.h
  • PalmAACProfileType : palmOneCodecFormat.h
  • PalmAMRDtxMode : palmOneCodecFormat.h
  • PalmAMRMode : palmOneCodecFormat.h
  • PalmAudioChannelType : palmOneCodecFormat.h
  • PalmAudioPlaybackActionCodeType : PalmAudioPlayback.h
  • PalmAudioPlaybackNotifyEventType : PalmAudioPlayback.h
  • PalmAudioPlaybackRequestResume : PalmAudioPlayback.h
  • PalmAudioPlaybackRequestStop : PalmAudioPlayback.h
  • PalmAudioPlaybackSendRequest : PalmAudioPlayback.h
  • PalmBasicType : palmOneCodecFormat.h
  • PalmBMPCompressionType : palmOneCodecFormat.h
  • palmCodecAAC_ADIF : palmOneCodecFormat.h
  • palmCodecAAC_ADTS : palmOneCodecFormat.h
  • palmCodecAAC_LATM : palmOneCodecFormat.h
  • palmCodecAAC_MP4A : palmOneCodecFormat.h
  • palmCodecAAC_RAW : palmOneCodecFormat.h
  • palmCodecAACLowComplexity : palmOneCodecFormat.h
  • palmCodecAACMainProfile : palmOneCodecFormat.h
  • palmCodecAACScaleableSamplingRate : palmOneCodecFormat.h
  • palmCodecAMR102 : palmOneCodecFormat.h
  • palmCodecAMR122 : palmOneCodecFormat.h
  • palmCodecAMR475 : palmOneCodecFormat.h
  • palmCodecAMR515 : palmOneCodecFormat.h
  • palmCodecAMR59 : palmOneCodecFormat.h
  • palmCodecAMR74 : palmOneCodecFormat.h
  • palmCodecAMR795 : palmOneCodecFormat.h
  • palmCodecAMRDtxDisable : palmOneCodecFormat.h
  • palmCodecAMRDtxEnable : palmOneCodecFormat.h
  • palmCodecAMRM67 : palmOneCodecFormat.h
  • palmCodecAudioAAC : palmOneCodecFormat.h
  • palmCodecAudioALAW : palmOneCodecFormat.h
  • palmCodecAudioAMR : palmOneCodecFormat.h
  • palmCodecAudioDVI_ADPCM : palmOneCodecFormat.h
  • palmCodecAudioG711 : palmOneCodecFormat.h
  • palmCodecAudioG722 : palmOneCodecFormat.h
  • palmCodecAudioG726 : palmOneCodecFormat.h
  • palmCodecAudioG728 : palmOneCodecFormat.h
  • palmCodecAudioIMA_ADPCM : palmOneCodecFormat.h
  • palmCodecAudioMP1 : palmOneCodecFormat.h
  • palmCodecAudioMP2 : palmOneCodecFormat.h
  • palmCodecAudioMP3 : palmOneCodecFormat.h
  • palmCodecAudioPCM : palmOneCodecFormat.h
  • palmCodecAudioQCELP : palmOneCodecFormat.h
  • palmCodecAudioULAW : palmOneCodecFormat.h
  • palmCodecAudioVORBIS : palmOneCodecFormat.h
  • palmCodecBIG_ENDIAN : palmOneCodecFormat.h
  • palmCodecBMP_None : palmOneCodecFormat.h
  • palmCodecBMP_RLE4 : palmOneCodecFormat.h
  • palmCodecBMP_RLE8 : palmOneCodecFormat.h
  • PalmCodecControlType : palmOneCodecFormat.h
  • palmCodecCtlAACGetInfo : palmOneCodecFormat.h
  • palmCodecCtlAVCGetDecodedFrame : palmOneCodecFormat.h
  • palmCodecCtlAVCGetInfo : palmOneCodecFormat.h
  • palmCodecCtlAVCSetCropMode : palmOneCodecFormat.h
  • palmCodecCtlCustomBase : palmOneCodecFormat.h
  • palmCodecCtlGetAuthor : palmOneCodecFormat.h
  • palmCodecCtlGetComments : palmOneCodecFormat.h
  • palmCodecCtlGetDate : palmOneCodecFormat.h
  • palmCodecCtlGetKey : palmOneCodecFormat.h
  • palmCodecCtlGetVersion : palmOneCodecFormat.h
  • palmCodecCtlLastBuffer : palmOneCodecFormat.h
  • palmCodecCtlPutKey : palmOneCodecFormat.h
  • palmCodecCtlPutSeed : palmOneCodecFormat.h
  • palmCodecFloatBig : palmOneCodecFormat.h
  • palmCodecFloatLittle : palmOneCodecFormat.h
  • PalmCodecFormat : palmOneCodecPluginMgrCommon.h
  • palmCodecImageARGB32 : palmOneCodecFormat.h
  • palmCodecImageBase : palmOneCodecFormat.h
  • palmCodecImageBGR32 : palmOneCodecFormat.h
  • palmCodecImageBGR555 : palmOneCodecFormat.h
  • palmCodecImageBGR565 : palmOneCodecFormat.h
  • palmCodecImageBGR888 : palmOneCodecFormat.h
  • palmCodecImageBGRA32 : palmOneCodecFormat.h
  • palmCodecImageCMY : palmOneCodecFormat.h
  • palmCodecImageCMYK : palmOneCodecFormat.h
  • palmCodecImageGIF87a : palmOneCodecFormat.h
  • palmCodecImageGIF87aFile : palmOneCodecFormat.h
  • palmCodecImageGIF89a : palmOneCodecFormat.h
  • palmCodecImageGIF89aFile : palmOneCodecFormat.h
  • palmCodecImageGIFFrame : palmOneCodecFormat.h
  • palmCodecImageGRAY1 : palmOneCodecFormat.h
  • palmCodecImageGRAY2 : palmOneCodecFormat.h
  • palmCodecImageGRAY4 : palmOneCodecFormat.h
  • palmCodecImageGRAY8 : palmOneCodecFormat.h
  • palmCodecImageHCI : palmOneCodecFormat.h
  • palmCodecImageHSI : palmOneCodecFormat.h
  • palmCodecImageHSL : palmOneCodecFormat.h
  • palmCodecImageHSV : palmOneCodecFormat.h
  • palmCodecImageJPEG : palmOneCodecFormat.h
  • palmCodecImageJPEGFile : palmOneCodecFormat.h
  • palmCodecImagePNG : palmOneCodecFormat.h
  • palmCodecImagePNGFile : palmOneCodecFormat.h
  • palmCodecImageRGB32 : palmOneCodecFormat.h
  • palmCodecImageRGB555 : palmOneCodecFormat.h
  • palmCodecImageRGB565 : palmOneCodecFormat.h
  • palmCodecImageRGB888 : palmOneCodecFormat.h
  • palmCodecImageRGB888Planar : palmOneCodecFormat.h
  • palmCodecImageRGBA32 : palmOneCodecFormat.h
  • palmCodecImageRGBIndex : palmOneCodecFormat.h
  • palmCodecImageRGBIndex1 : palmOneCodecFormat.h
  • palmCodecImageRGBIndex16 : palmOneCodecFormat.h
  • palmCodecImageRGBIndex2 : palmOneCodecFormat.h
  • palmCodecImageRGBIndex4 : palmOneCodecFormat.h
  • palmCodecImageRGBIndex8 : palmOneCodecFormat.h
  • palmCodecImageTIFF : palmOneCodecFormat.h
  • palmCodecImageTIFFFile : palmOneCodecFormat.h
  • palmCodecImageWBMP : palmOneCodecFormat.h
  • palmCodecImageWBMPFile : palmOneCodecFormat.h
  • palmCodecImageYCbCr211 : palmOneCodecFormat.h
  • palmCodecImageYCbCr211Planar : palmOneCodecFormat.h
  • palmCodecImageYCbCr411 : palmOneCodecFormat.h
  • palmCodecImageYCbCr411Planar : palmOneCodecFormat.h
  • palmCodecImageYCbCr420 : palmOneCodecFormat.h
  • palmCodecImageYCbCr420Planar : palmOneCodecFormat.h
  • palmCodecImageYCbCr422 : palmOneCodecFormat.h
  • palmCodecImageYCbCr422Planar : palmOneCodecFormat.h
  • palmCodecImageYCbCr444 : palmOneCodecFormat.h
  • palmCodecImageYCbCr444Planar : palmOneCodecFormat.h
  • palmCodecImageYUV211 : palmOneCodecFormat.h
  • palmCodecImageYUV211Planar : palmOneCodecFormat.h
  • palmCodecImageYUV411 : palmOneCodecFormat.h
  • palmCodecImageYUV411Planar : palmOneCodecFormat.h
  • palmCodecImageYUV420 : palmOneCodecFormat.h
  • palmCodecImageYUV420Planar : palmOneCodecFormat.h
  • palmCodecImageYUV422 : palmOneCodecFormat.h
  • palmCodecImageYUV422Planar : palmOneCodecFormat.h
  • palmCodecImageYUV444 : palmOneCodecFormat.h
  • palmCodecImageYUV444Planar : palmOneCodecFormat.h
  • palmCodecINT16Big : palmOneCodecFormat.h
  • palmCodecINT16Little : palmOneCodecFormat.h
  • palmCodecINT24 : palmOneCodecFormat.h
  • palmCodecINT32Big : palmOneCodecFormat.h
  • palmCodecINT32Little : palmOneCodecFormat.h
  • palmCodecINT8 : palmOneCodecFormat.h
  • palmCodecInvalidSession : palmOneCodecPluginMgrCommon.h
  • palmCodecIteratorStart : palmOneCodecPluginMgrCommon.h
  • palmCodecIteratorStop : palmOneCodecPluginMgrCommon.h
  • palmCodecLITTLE_ENDIAN : palmOneCodecFormat.h
  • palmCodecMONO : palmOneCodecFormat.h
  • palmCodecMPEG4MVFAST : palmOneCodecFormat.h
  • palmCodecMPEG4SEA : palmOneCodecFormat.h
  • palmCodecNullID : palmOneCodecPluginMgrCommon.h
  • palmCodecQCELPEighth : palmOneCodecFormat.h
  • palmCodecQCELPFull : palmOneCodecFormat.h
  • palmCodecQCELPHalf : palmOneCodecFormat.h
  • palmCodecQCELPQuarter : palmOneCodecFormat.h
  • palmCodecQCELPReducedDisabled : palmOneCodecFormat.h
  • palmCodecQCELPReducedEnabled : palmOneCodecFormat.h
  • palmCodecQCELPSilent : palmOneCodecFormat.h
  • PalmCodecSession : palmOneCodecPluginMgrCommon.h
  • palmCodecSTEREO : palmOneCodecFormat.h
  • palmCodecStreamFile : palmOneCodecFormat.h
  • palmCodecText3G : palmOneCodecFormat.h
  • palmCodecUINT16Big : palmOneCodecFormat.h
  • palmCodecUINT16Little : palmOneCodecFormat.h
  • palmCodecUINT24 : palmOneCodecFormat.h
  • palmCodecUINT32Big : palmOneCodecFormat.h
  • palmCodecUINT32Little : palmOneCodecFormat.h
  • palmCodecUINT8 : palmOneCodecFormat.h
  • palmCodecVFSFile : palmOneCodecFormat.h
  • palmCodecVideoAVC : palmOneCodecFormat.h
  • palmCodecVideoDIVX : palmOneCodecFormat.h
  • palmCodecVideoH263 : palmOneCodecFormat.h
  • palmCodecVideoMJPEG : palmOneCodecFormat.h
  • palmCodecVideoMPEG1 : palmOneCodecFormat.h
  • palmCodecVideoMPEG2 : palmOneCodecFormat.h
  • palmCodecVideoMPEG4 : palmOneCodecFormat.h
  • palmCodecVideoXVID : palmOneCodecFormat.h
  • PalmEndianType : palmOneCodecFormat.h
  • PalmFileType : palmOneCodecFormat.h
  • PalmLedClose() : PalmLED.h
  • PalmLedOpen() : PalmLED.h
  • PalmLedSleep() : PalmLED.h
  • PalmLedWake() : PalmLED.h
  • PalmMPEG4Algorithm : palmOneCodecFormat.h
  • PalmOneStatAttrType : palmOneStatusBar.h
  • PalmOneStatAttrTypeTag : palmOneStatusBar.h
  • palmOneStatusBarAttrBarVisible : palmOneStatusBar.h
  • palmOneStatusBarAttrDimension : palmOneStatusBar.h
  • palmOneStatusBarAttrExists : palmOneStatusBar.h
  • palmOneStatusBarErrBadParam : palmOneStatusBar.h
  • palmOneStatusBarErrInputWindowOpen : palmOneStatusBar.h
  • palmOneStatusBarErrInvalidSelector : palmOneStatusBar.h
  • palmOneStatusBarErrInvalidState : palmOneStatusBar.h
  • palmOneStatusBarErrNoStatusBar : palmOneStatusBar.h
  • palmOneStatusBarErrorClass : palmOneStatusBar.h
  • palmOneStatusBarFtrNumVersion : palmOneStatusBar.h
  • PalmOneStatusBarGetAttribute() : palmOneStatusBar.h
  • PalmOneStatusBarHide() : palmOneStatusBar.h
  • PalmOneStatusBarLibClose() : palmOneStatusBar.h
  • palmOneStatusBarLibCreator : palmOneStatusBar.h
  • palmOneStatusBarLibName : palmOneStatusBar.h
  • PalmOneStatusBarLibOpen() : palmOneStatusBar.h
  • palmOneStatusBarLibType : palmOneStatusBar.h
  • PalmOneStatusBarShow() : palmOneStatusBar.h
  • PalmPhotoAddImage() : palmOnePhoto.h
  • PalmPhotoAddImageV2() : palmOnePhoto.h
  • PalmPhotoAlbumCount() : palmOnePhoto.h
  • PalmPhotoAlbumCountV2() : palmOnePhoto.h
  • palmPhotoASFM43FileFormat : palmOnePhotoCommon.h
  • palmPhotoASFM4AFileFormat : palmOnePhotoCommon.h
  • palmPhotoAVIM43FileFormat : palmOnePhotoCommon.h
  • palmPhotoAVIM4AFileFormat : palmOnePhotoCommon.h
  • palmPhotoBMPFileFormat : palmOnePhotoCommon.h
  • PalmPhotoCaptureCallbackV2 : palmOnePhoto.h
  • PalmPhotoCaptureImageV2() : palmOnePhoto.h
  • PalmPhotoCaptureParamV2 : palmOnePhoto.h
  • palmPhotoCaptureResCIF : palmOnePhotoCommon.h
  • palmPhotoCaptureResNone : palmOnePhotoCommon.h
  • PalmPhotoCaptureResolution : palmOnePhotoCommon.h
  • palmPhotoCaptureResOther : palmOnePhotoCommon.h
  • palmPhotoCaptureResQCIF : palmOnePhotoCommon.h
  • palmPhotoCaptureResQQVGA : palmOnePhotoCommon.h
  • palmPhotoCaptureResQVGA : palmOnePhotoCommon.h
  • palmPhotoCaptureResSUBQCIF : palmOnePhotoCommon.h
  • palmPhotoCaptureResSVGA : palmOnePhotoCommon.h
  • palmPhotoCaptureResSXGA : palmOnePhotoCommon.h
  • palmPhotoCaptureResSXGA1024 : palmOnePhotoCommon.h
  • palmPhotoCaptureResSXGA960 : palmOnePhotoCommon.h
  • palmPhotoCaptureResVGA : palmOnePhotoCommon.h
  • palmPhotoCaptureResXVGA : palmOnePhotoCommon.h
  • PalmPhotoCloseImage() : palmOnePhoto.h
  • PalmPhotoCloseImageV2() : palmOnePhoto.h
  • PalmPhotoConvertImageV2() : palmOnePhoto.h
  • PalmPhotoCreateImage() : palmOnePhoto.h
  • PalmPhotoCreateImageV2() : palmOnePhoto.h
  • PalmPhotoCreateParam : palmOnePhoto.h
  • PalmPhotoCropImageV2() : palmOnePhoto.h
  • PalmPhotoDeleteAlbum() : palmOnePhoto.h
  • PalmPhotoDeleteImage() : palmOnePhoto.h
  • PalmPhotoDisplayCallback : palmOnePhoto.h
  • PalmPhotoDisplayImage() : palmOnePhoto.h
  • PalmPhotoDisplayImageToSizeV3() : palmOnePhoto.h
  • PalmPhotoDisplayParam : palmOnePhoto.h
  • PalmPhotoDisplayThumbnailV3() : palmOnePhoto.h
  • palmPhotoDlgDeletion : palmOnePhotoCommon.h
  • palmPhotoDlgSelection : palmOnePhotoCommon.h
  • palmPhotoDlgSingleSelection : palmOnePhotoCommon.h
  • PalmPhotoDlgType : palmOnePhotoCommon.h
  • palmPhotoExtraInfoAlbum : palmOnePhotoCommon.h
  • palmPhotoExtraInfoCompositeUID : palmOnePhotoCommon.h
  • palmPhotoExtraInfoDate : palmOnePhotoCommon.h
  • palmPhotoExtraInfoImageUID : palmOnePhotoCommon.h
  • palmPhotoExtraInfoLocation : palmOnePhotoCommon.h
  • palmPhotoExtraInfoNotes : palmOnePhotoCommon.h
  • PalmPhotoExtraInfoParam : palmOnePhotoCommon.h
  • palmPhotoExtraInfoSound : palmOnePhotoCommon.h
  • palmPhotoExtraInfoSoundUID : palmOnePhotoCommon.h
  • PalmPhotoExtraInfoType : palmOnePhotoCommon.h
  • PalmPhotoFileFormat : palmOnePhotoCommon.h
  • PalmPhotoFileLocation : palmOnePhotoCommon.h
  • PalmPhotoFilterCallback : palmOnePhoto.h
  • palmPhotoFormat_3G2_QCELP_H263 : palmOnePhotoCommon.h
  • palmPhotoFormat_3G2_QCELP_MPEG4 : palmOnePhotoCommon.h
  • palmPhotoFormat_3GP_AMR_H263 : palmOnePhotoCommon.h
  • palmPhotoFormat_3GP_AMR_MPEG4 : palmOnePhotoCommon.h
  • palmPhotoFormat_ASF_ADPCM_MPEG4 : palmOnePhotoCommon.h
  • palmPhotoFormat_ASF_MP3_MPEG4 : palmOnePhotoCommon.h
  • palmPhotoFormat_AVI_ADPCM_MPEG4 : palmOnePhotoCommon.h
  • palmPhotoFormat_AVI_MP3_MPEG4 : palmOnePhotoCommon.h
  • PalmPhotoFreeSelections() : palmOnePhoto.h
  • PalmPhotoFreeSelectionsV2() : palmOnePhoto.h
  • PalmPhotoGetAlbumID() : palmOnePhoto.h
  • PalmPhotoGetAlbumIDV2() : palmOnePhoto.h
  • PalmPhotoGetAlbumName() : palmOnePhoto.h
  • PalmPhotoGetImageExtraInfo() : palmOnePhoto.h
  • PalmPhotoGetImageExtraInfoSize() : palmOnePhoto.h
  • PalmPhotoGetImageInfo() : palmOnePhoto.h
  • PalmPhotoGetLastErrV2() : palmOnePhoto.h
  • PalmPhotoGetSupportedCaptureResolutionsV3() : palmOnePhoto.h
  • PalmPhotoGetThumbSize() : palmOnePhoto.h
  • palmPhotoGIFFileFormat : palmOnePhotoCommon.h
  • PalmPhotoHandle : palmOnePhotoCommon.h
  • palmPhotoHighestQuality : palmOnePhotoCommon.h
  • palmPhotoHighQuality : palmOnePhotoCommon.h
  • PalmPhotoImageCount() : palmOnePhoto.h
  • PalmPhotoImageInfo : palmOnePhotoCommon.h
  • PalmPhotoIsCameraAvailableV3() : palmOnePhoto.h
  • palmPhotoJPEGFileFormat : palmOnePhotoCommon.h
  • PalmPhotoLibClose() : palmOnePhoto.h
  • PalmPhotoLibCreatorID : palmOnePhotoCommon.h
  • palmPhotoLibErrAbortReadWrite : palmOnePhotoCommon.h
  • palmPhotoLibErrAlbumExist : palmOnePhotoCommon.h
  • palmPhotoLibErrAlbumFull : palmOnePhotoCommon.h
  • palmPhotoLibErrAlbumNameTooLong : palmOnePhotoCommon.h
  • palmPhotoLibErrAlbumNotExist : palmOnePhotoCommon.h
  • palmPhotoLibErrAlbumReadOnly : palmOnePhotoCommon.h
  • palmPhotoLibErrFormatNotSupported : palmOnePhotoCommon.h
  • palmPhotoLibErrImageExist : palmOnePhotoCommon.h
  • palmPhotoLibErrImageInvalidPath : palmOnePhotoCommon.h
  • palmPhotoLibErrImageNotFound : palmOnePhotoCommon.h
  • palmPhotoLibErrImageNotInPhotos : palmOnePhotoCommon.h
  • palmPhotoLibErrInvalidVolume : palmOnePhotoCommon.h
  • palmPhotoLibErrLowHeap : palmOnePhotoCommon.h
  • palmPhotoLibErrLowMemory : palmOnePhotoCommon.h
  • palmPhotoLibErrLowPower : palmOnePhotoCommon.h
  • palmPhotoLibErrNoCamera : palmOnePhotoCommon.h
  • palmPhotoLibErrNoThumbnail : palmOnePhotoCommon.h
  • palmPhotoLibErrNotOpen : palmOnePhotoCommon.h
  • palmPhotoLibErrNotOpenPhotos : palmOnePhotoCommon.h
  • palmPhotoLibErrNotPhotos : palmOnePhotoCommon.h
  • palmPhotoLibErrOldVersion : palmOnePhotoCommon.h
  • palmPhotoLibErrParam : palmOnePhotoCommon.h
  • palmPhotoLibErrProtectedMedia : palmOnePhotoCommon.h
  • palmPhotoLibErrScreenDepth : palmOnePhotoCommon.h
  • palmPhotoLibErrSmallBuffer : palmOnePhotoCommon.h
  • palmPhotoLibErrStillOpen : palmOnePhotoCommon.h
  • palmPhotoLibErrUnknown : palmOnePhotoCommon.h
  • palmPhotoLibErrUnsupportedRotation : palmOnePhotoCommon.h
  • palmPhotoLibErrUserCancel : palmOnePhotoCommon.h
  • PalmPhotoLibGetVersion() : palmOnePhoto.h
  • PalmPhotoLibName : palmOnePhotoCommon.h
  • PalmPhotoLibOpen() : palmOnePhoto.h
  • PalmPhotoLibSleep() : palmOnePhoto.h
  • PalmPhotoLibTypeID : palmOnePhotoCommon.h
  • PalmPhotoLibWake() : palmOnePhoto.h
  • PalmPhotoLocationType : palmOnePhotoCommon.h
  • palmPhotoLowestQuality : palmOnePhotoCommon.h
  • palmPhotoLowQuality : palmOnePhotoCommon.h
  • PalmPhotoMediaType : palmOnePhotoCommon.h
  • palmPhotoMediaTypeAll : palmOnePhotoCommon.h
  • palmPhotoMediaTypePhoto : palmOnePhotoCommon.h
  • palmPhotoMediaTypeVideo : palmOnePhotoCommon.h
  • palmPhotoMediumQuality : palmOnePhotoCommon.h
  • palmPhotoMemoryLocation : palmOnePhotoCommon.h
  • palmPhotoMJPEGFileFormat : palmOnePhotoCommon.h
  • palmPhotoMPEG1FileFormat : palmOnePhotoCommon.h
  • palmPhotoMPEG4FileFormat : palmOnePhotoCommon.h
  • PalmPhotoNewAlbum() : palmOnePhoto.h
  • PalmPhotoNewAlbumV2() : palmOnePhoto.h
  • PalmPhotoOpenImage() : palmOnePhoto.h
  • PalmPhotoOpenImageV2() : palmOnePhoto.h
  • palmPhotoPNGFileFormat : palmOnePhotoCommon.h
  • palmPhotoPreferredImageFormat : palmOnePhotoCommon.h
  • palmPhotoPreferredVideoFormat : palmOnePhotoCommon.h
  • PalmPhotoQualityType : palmOnePhotoCommon.h
  • PalmPhotoReadImage() : palmOnePhoto.h
  • PalmPhotoReadWriteCallback : palmOnePhoto.h
  • PalmPhotoReadWriteParam : palmOnePhoto.h
  • PalmPhotoRenameAlbum() : palmOnePhoto.h
  • palmPhotoRGB565FileFormat : palmOnePhotoCommon.h
  • palmPhotoRGB888FileFormat : palmOnePhotoCommon.h
  • PalmPhotoRotateImageV2() : palmOnePhoto.h
  • PalmPhotoScaleImageV2() : palmOnePhoto.h
  • PalmPhotoSelectDlg() : palmOnePhoto.h
  • PalmPhotoSelectDlgV3() : palmOnePhoto.h
  • PalmPhotoSelectImages() : palmOnePhoto.h
  • PalmPhotoSelectionParam : palmOnePhoto.h
  • PalmPhotoSelections : palmOnePhotoCommon.h
  • PalmPhotoSetImageExtraInfo() : palmOnePhoto.h
  • palmPhotoStreamLocation : palmOnePhotoCommon.h
  • palmPhotoTIFFFileFormat : palmOnePhotoCommon.h
  • PalmPhotoUID : palmOnePhotoCommon.h
  • palmPhotoUnsupportedFormat : palmOnePhotoCommon.h
  • palmPhotoVFSLocation : palmOnePhotoCommon.h
  • palmPhotoWBMPFileFormat : palmOnePhotoCommon.h
  • PalmPhotoWriteImage() : palmOnePhoto.h
  • PalmQCELPRate : palmOneCodecFormat.h
  • PalmQCELPReducedRate : palmOneCodecFormat.h
  • PasswordLength : HsPhoneEvent.h
  • PasswordSize : HsPhoneEvent.h
  • Phi11BitMap : SmartTextEngineRsc.h
  • Phi14BitMap : SmartTextEngineRsc.h
  • PHN_LIB_TRAP : HsPhoneTraps.h
  • PHN_SUBCOMPONENTID_LIB : HsPhoneTrace.h
  • PHN_SUBCOMPONENTID_NOT : HsPhoneTrace.h
  • PHN_SUBCOMPONENTID_RDO : HsPhoneTrace.h
  • PHN_SUBCOMPONENTID_READ : HsPhoneTrace.h
  • PHN_SUBCOMPONENTID_SIM : HsPhoneTrace.h
  • PHN_SUBCOMPONENTID_SMS : HsPhoneTrace.h
  • PHN_SUBCOMPONENTID_STK : HsPhoneTrace.h
  • PHN_SUBCOMPONENTID_WRIT : HsPhoneTrace.h
  • phnAddressDigitsMax : HsPhoneEvent.h
  • PhnAddressField : HsPhoneTypes.h
  • PhnAddressHandle : HsPhoneTypes.h
  • PhnAddressList : HsPhoneTypes.h
  • phnAddrFldFirstName : HsPhoneTypes.h
  • phnAddrFldLastName : HsPhoneTypes.h
  • phnAddrFldPhone : HsPhoneTypes.h
  • phnAudioLocalMode : HsPhoneAudioTypes.h
  • phnAudioNetworkMode : HsPhoneAudioTypes.h
  • PhnAudioSendMode : HsPhoneAudioTypes.h
  • phnAudioSilentMode : HsPhoneAudioTypes.h
  • phnAutoMode : HsPhoneMiscTypes.h
  • PhnBandSelection : HsPhoneNetworkTypes.h
  • phnBarAll : HsPhoneNetworkTypes.h
  • PhnBarFacilityPtr : HsPhoneNetworkTypes.h
  • PhnBarFacilityType : HsPhoneNetworkTypes.h
  • PhnBarFacilityTypeEnum : HsPhoneNetworkTypes.h
  • phnBarInAll : HsPhoneNetworkTypes.h
  • phnBarInNone : HsPhoneNetworkTypes.h
  • phnBarInWhenRoaming : HsPhoneNetworkTypes.h
  • phnBarOutAll : HsPhoneNetworkTypes.h
  • phnBarOutInternational : HsPhoneNetworkTypes.h
  • phnBarOutInternationalExceptHome : HsPhoneNetworkTypes.h
  • phnBarOutNone : HsPhoneNetworkTypes.h
  • phnBluetoothHandsfreeMode : HsPhoneMiscTypes.h
  • phnBluetoothHeadsetMode : HsPhoneMiscTypes.h
  • phnButtonAnswerCall : HsPhoneEvent.h
  • phnButtonConferenceCall : HsPhoneEvent.h
  • phnButtonHeadset : HsPhoneEvent.h
  • phnButtonHoldCall : HsPhoneEvent.h
  • phnButtonIgnoreCall : HsPhoneEvent.h
  • phnButtonLast : HsPhoneEvent.h
  • phnButtonRedial : HsPhoneEvent.h
  • phnButtonRejectCall : HsPhoneEvent.h
  • phnCall1StatusActive : HsPhoneTypes.h
  • phnCall1StatusAlerting : HsPhoneTypes.h
  • phnCall1StatusDialing : HsPhoneTypes.h
  • phnCall1StatusIncoming : HsPhoneTypes.h
  • phnCall2StatusActive : HsPhoneTypes.h
  • phnCall2StatusAlerting : HsPhoneTypes.h
  • phnCall2StatusDialing : HsPhoneTypes.h
  • phnCall2StatusIncoming : HsPhoneTypes.h
  • PhnCallControlType : HsPhoneNetworkTypes.h
  • PhnCallControlTypeEnum : HsPhoneNetworkTypes.h
  • phnCarKitMode : HsPhoneMiscTypes.h
  • phnCDMAFirmwareAlltel : HsPhoneCDMATypes.h
  • phnCDMAFirmwareBellMobility : HsPhoneCDMATypes.h
  • phnCDMAFirmwareCrowdy : HsPhoneCDMATypes.h
  • phnCDMAFirmwareEarthlink : HsPhoneCDMATypes.h
  • phnCDMAFirmwareSprint : HsPhoneCDMATypes.h
  • PhnCDMAFirmwareType : HsPhoneCDMATypes.h
  • phnCDMAFirmwareVerizon : HsPhoneCDMATypes.h
  • PhnCDMAMediaTVSettingsMajorVersion : HsPhoneCDMATypes.h
  • PhnCDMAMediaTVSettingsMinorVersion : HsPhoneCDMATypes.h
  • PhnCDMAMediaTVSettingsType : HsPhoneCDMATypes.h
  • PhnCDMAMediaTVSettingsVersion : HsPhoneCDMATypes.h
  • PhnCdmaSystemInfoPtr : HsPhoneMiscTypes.h
  • phnCDMAVoicemailDigits : HsPhoneCDMATypes.h
  • phnCDMAVoicemailMDN : HsPhoneCDMATypes.h
  • phnCDMAVoicemailMDN1 : HsPhoneCDMATypes.h
  • PhnCDMAVoicemailType : HsPhoneCDMATypes.h
  • PhnCLIRStatus : HsPhoneNetworkTypes.h
  • phnConnectionActive : HsPhoneCallControlTypes.h
  • phnConnectionAlerting : HsPhoneCallControlTypes.h
  • phnConnectionDialing : HsPhoneCallControlTypes.h
  • phnConnectionDormant : HsPhoneCallControlTypes.h
  • PhnConnectionEnum : HsPhoneMiscTypes.h
  • phnConnectionHeld : HsPhoneCallControlTypes.h
  • PhnConnectionID : HsPhoneTypes.h
  • phnConnectionIncoming : HsPhoneCallControlTypes.h
  • PhnConnectionPtr : HsPhoneCallControlTypes.h
  • phnConnectionUnknown : HsPhoneCallControlTypes.h
  • phnConnectionWaiting : HsPhoneCallControlTypes.h
  • PhnConnectStateType : HsPhoneCallControlTypes.h
  • phnCSDCallActive : HsPhoneTypes.h
  • phnDataAvailable : HsPhoneEvent.h
  • PhnDatabaseID : HsPhoneTypes.h
  • PhnDataChannelType : HsPhoneEvent.h
  • phnDataNotAvailable : HsPhoneEvent.h
  • phnDataService1xEVDO : HsPhoneNetworkTypes.h
  • phnDataService1xRTT : HsPhoneNetworkTypes.h
  • phnDataServiceCSD : HsPhoneNetworkTypes.h
  • phnDataServiceEdge : HsPhoneNetworkTypes.h
  • phnDataServiceGPRS : HsPhoneNetworkTypes.h
  • phnDataServiceLast : HsPhoneNetworkTypes.h
  • phnDataServiceNone : HsPhoneNetworkTypes.h
  • PhnDataServiceType : HsPhoneNetworkTypes.h
  • PhnDataSessionStateTypeMajorVersion : HsPhoneNetworkTypes.h
  • PhnDataSessionStateTypeMinorVersion : HsPhoneNetworkTypes.h
  • PhnDataSessionStateTypeVersion : HsPhoneNetworkTypes.h
  • phnEnhancedRoamIndMaxLength : HsPhoneNetworkTypes.h
  • PhnEquipmentMode : HsPhoneMiscTypes.h
  • phnEquipmentModeLast : HsPhoneMiscTypes.h
  • phnErrACMLimitExceeded : HsPhoneErrors.h
  • phnErrAlphabetNotSupported : HsPhoneErrors.h
  • phnErrAuthenticationFailure : HsPhoneErrors.h
  • phnErrBadATCmd : HsPhoneErrors.h
  • phnErrBadATResult : HsPhoneErrors.h
  • phnErrBadCRC : HsPhoneErrors.h
  • phnErrBadServiceCode : HsPhoneErrors.h
  • phnErrBatteryCharging : HsPhoneErrors.h
  • phnErrBatteryLowAlert : HsPhoneErrors.h
  • phnErrBufferTooSmall : HsPhoneErrors.h
  • phnErrCallBarred : HsPhoneErrors.h
  • phnErrCancelled : HsPhoneErrors.h
  • phnErrCannotReplaceMsg : HsPhoneErrors.h
  • phnErrCauseCode16 : HsPhoneErrors.h
  • phnErrCmdCannotBeActioned : HsPhoneErrors.h
  • phnErrCmdUnsupported : HsPhoneErrors.h
  • phnErrCommandInProgress : HsPhoneErrors.h
  • phnErrCongestion : HsPhoneErrors.h
  • phnErrCOPSAbort : HsPhoneErrors.h
  • phnErrCorpPINRequired : HsPhoneErrors.h
  • phnErrCorpPUKRequired : HsPhoneErrors.h
  • phnErrCPError : HsPhoneErrors.h
  • phnErrCSDAccessInfoDiscarded : HsPhoneErrors.h
  • phnErrCSDACMOutOfRange : HsPhoneErrors.h
  • phnErrCSDBearerNotAvailable : HsPhoneErrors.h
  • phnErrCSDBearerNotCapable : HsPhoneErrors.h
  • phnErrCSDBearerNotImplemented : HsPhoneErrors.h
  • phnErrCSDCallBarringIncoming : HsPhoneErrors.h
  • phnErrCSDCallBarringOutgoing : HsPhoneErrors.h
  • phnErrCSDCallImpossible : HsPhoneErrors.h
  • phnErrCSDCallOperationNotAllowed : HsPhoneErrors.h
  • phnErrCSDCallRejected : HsPhoneErrors.h
  • phnErrCSDChannelUnacceptable : HsPhoneErrors.h
  • phnErrCSDDestinationOutOfOrder : HsPhoneErrors.h
  • phnErrCSDFacilityNotImplemented : HsPhoneErrors.h
  • phnErrCSDFacilityNotSubscribed : HsPhoneErrors.h
  • phnErrCSDFacilityRejected : HsPhoneErrors.h
  • phnErrCSDFDNError : HsPhoneErrors.h
  • phnErrCSDIEError : HsPhoneErrors.h
  • phnErrCSDIncomingCallsBarredCUG : HsPhoneErrors.h
  • phnErrCSDIncompatibleDestination : HsPhoneErrors.h
  • phnErrCSDInfoNotImplemented : HsPhoneErrors.h
  • phnErrCSDInvalidMandatoryInfo : HsPhoneErrors.h
  • phnErrCSDInvalidNumberFormat : HsPhoneErrors.h
  • phnErrCSDInvalidTransID : HsPhoneErrors.h
  • phnErrCSDInvalidTransitNetwork : HsPhoneErrors.h
  • phnErrCSDLowerLayerFailure : HsPhoneErrors.h
  • phnErrCSDMessageNotCompatible : HsPhoneErrors.h
  • phnErrCSDMessageTypeNotCompatible : HsPhoneErrors.h
  • phnErrCSDMessageTypeNotImplemented : HsPhoneErrors.h
  • phnErrCSDNetworkOutOfOrder : HsPhoneErrors.h
  • phnErrCSDNoAnswer : HsPhoneErrors.h
  • phnErrCSDNoCircuitAvailable : HsPhoneErrors.h
  • phnErrCSDNoRouteToDestination : HsPhoneErrors.h
  • phnErrCSDNoUserResponse : HsPhoneErrors.h
  • phnErrCSDNumberBusy : HsPhoneErrors.h
  • phnErrCSDNumberChanged : HsPhoneErrors.h
  • phnErrCSDOperatorBarring : HsPhoneErrors.h
  • phnErrCSDProtocolError : HsPhoneErrors.h
  • phnErrCSDQOSNotAvailable : HsPhoneErrors.h
  • phnErrCSDRecoveryOnTimerExpiry : HsPhoneErrors.h
  • phnErrCSDReqCircuitNotAvailable : HsPhoneErrors.h
  • phnErrCSDResourceNotAvailable : HsPhoneErrors.h
  • phnErrCSDRestrictedBearer : HsPhoneErrors.h
  • phnErrCSDSemanticallyIncorrectMessage : HsPhoneErrors.h
  • phnErrCSDServiceNotAvailble : HsPhoneErrors.h
  • phnErrCSDServiceNotImplented : HsPhoneErrors.h
  • phnErrCSDSwitchingCongestion : HsPhoneErrors.h
  • phnErrCSDTempFailure : HsPhoneErrors.h
  • phnErrCSDUnassignedNumber : HsPhoneErrors.h
  • phnErrCSDUserNotMemberCUG : HsPhoneErrors.h
  • phnErrDenied : HsPhoneErrors.h
  • phnErrDestOutOfService : HsPhoneErrors.h
  • phnErrDestSMEBarred : HsPhoneErrors.h
  • phnErrDialStringTooLong : HsPhoneErrors.h
  • phnErrDuplicatePage : HsPhoneErrors.h
  • phnErrDuplicatePlaceHoldler : HsPhoneErrors.h
  • phnErrEmergencyCallsOnly : HsPhoneErrors.h
  • phnErrErrorInMS : HsPhoneErrors.h
  • phnErrFacRejected : HsPhoneErrors.h
  • phnErrFDNMismatch : HsPhoneErrors.h
  • phnErrFiller : HsPhoneErrors.h
  • phnErrFiller2 : HsPhoneErrors.h
  • phnErrFiller3 : HsPhoneErrors.h
  • phnErrFiller4 : HsPhoneErrors.h
  • phnErrFiller5 : HsPhoneErrors.h
  • phnErrFiller6 : HsPhoneErrors.h
  • phnErrFirmwareBootInprogress : HsPhoneErrors.h
  • phnErrFirmwareBootNotInprogress : HsPhoneErrors.h
  • phnErrGPRSAPNMissing : HsPhoneErrors.h
  • phnErrGPRSNetworkRequestDetach : HsPhoneErrors.h
  • phnErrGPRSNetworkRequestPDPDeactivate : HsPhoneErrors.h
  • phnErrGPRSNoAccess : HsPhoneErrors.h
  • phnErrGPRSNoService : HsPhoneErrors.h
  • phnErrGPRSNotAllowed : HsPhoneErrors.h
  • phnErrGPRSPDPActivateFailGMMError : HsPhoneErrors.h
  • phnErrGPRSPDPActivateFailNetReject : HsPhoneErrors.h
  • phnErrGPRSPDPActivateFailNoNSAPI : HsPhoneErrors.h
  • phnErrGPRSPDPActivateFailSMRefuse : HsPhoneErrors.h
  • phnErrGPRSPDPDactivateGMMAbort : HsPhoneErrors.h
  • phnErrGPRSPDPDactivateLCCLinkActivation : HsPhoneErrors.h
  • phnErrGPRSPDPDeactivateNwkRactivate : HsPhoneErrors.h
  • phnErrGPRSPDPDeactivateSNDCPFailure : HsPhoneErrors.h
  • phnErrGPRSRoamingNotAllowed : HsPhoneErrors.h
  • phnErrGPRSServiceRefused : HsPhoneErrors.h
  • phnErrHCIMismatch : HsPhoneErrors.h
  • phnErrHoldError : HsPhoneErrors.h
  • phnErrIllegalChars : HsPhoneErrors.h
  • phnErrIllegalCondition : HsPhoneErrors.h
  • phnErrIllegalFacility : HsPhoneErrors.h
  • phnErrIllegalIndex : HsPhoneErrors.h
  • phnErrIllegalME : HsPhoneErrors.h
  • phnErrIllegalMS : HsPhoneErrors.h
  • phnErrIllegalMsg : HsPhoneErrors.h
  • phnErrIllegalNumber : HsPhoneErrors.h
  • phnErrIllegalStatus : HsPhoneErrors.h
  • phnErrIllegalType : HsPhoneErrors.h
  • phnErrIncorrectPassword : HsPhoneErrors.h
  • phnErrInfoElemNonExistent : HsPhoneErrors.h
  • phnErrIntermediateResult : HsPhoneErrors.h
  • phnErrInterworking : HsPhoneErrors.h
  • phnErrInvalidDialChars : HsPhoneErrors.h
  • phnErrInvalidMandInfo : HsPhoneErrors.h
  • phnErrInvalidMemIndex : HsPhoneErrors.h
  • phnErrInvalidMobileClass : HsPhoneErrors.h
  • phnErrInvalidMsg : HsPhoneErrors.h
  • phnErrInvalidNAM : HsPhoneErrors.h
  • phnErrInvalidParameter : HsPhoneErrors.h
  • phnErrInvalidSMEAddr : HsPhoneErrors.h
  • phnErrInvalidSMSReference : HsPhoneErrors.h
  • phnErrInvalidTextChars : HsPhoneErrors.h
  • phnErrIOTACommitFailed : HsPhoneErrors.h
  • phnErrIOTACommitInProgress : HsPhoneErrors.h
  • phnErrIOTANoSession : HsPhoneErrors.h
  • phnErrIOTASessionActive : HsPhoneErrors.h
  • phnErrIS683ProtRevNotSupported : HsPhoneErrors.h
  • phnErrLAST_1 : HsPhoneErrors.h
  • phnErrLAST_2 : HsPhoneErrors.h
  • phnErrLidClosed : HsPhoneErrors.h
  • phnErrLocAreaNotAllowed : HsPhoneErrors.h
  • phnErrLowerLayer : HsPhoneErrors.h
  • phnErrMEFailure : HsPhoneErrors.h
  • phnErrMemFailure : HsPhoneErrors.h
  • phnErrMemory : HsPhoneErrors.h
  • phnErrMemoryFailure : HsPhoneErrors.h
  • phnErrMemoryFull : HsPhoneErrors.h
  • phnErrMissingCarKitDriver : HsPhoneErrors.h
  • phnErrMMFailed : HsPhoneErrors.h
  • phnErrModemBusy : HsPhoneErrors.h
  • phnErrModemOffline : HsPhoneErrors.h
  • phnErrMsgClassNotSupported : HsPhoneErrors.h
  • phnErrMsgNoCompatible : HsPhoneErrors.h
  • phnErrMsgTypeNonExistent : HsPhoneErrors.h
  • phnErrNAMMismatched : HsPhoneErrors.h
  • phnErrNeedResetModule : HsPhoneErrors.h
  • phnErrNetPINRequired : HsPhoneErrors.h
  • phnErrNetPUKRequired : HsPhoneErrors.h
  • phnErrNetSubPINRequired : HsPhoneErrors.h
  • phnErrNetSubPUKRequired : HsPhoneErrors.h
  • phnErrNetworkNotAllowed : HsPhoneErrors.h
  • phnErrNetworkOutOfOrder : HsPhoneErrors.h
  • phnErrNetworkTimeout : HsPhoneErrors.h
  • phnErrNoAppRegistered : HsPhoneErrors.h
  • phnErrNoCarrier : HsPhoneErrors.h
  • phnErrNoCNMAAckExpected : HsPhoneErrors.h
  • phnErrNoConnection : HsPhoneErrors.h
  • phnErrNoNetwork : HsPhoneErrors.h
  • phnErrNoNetworkService : HsPhoneErrors.h
  • phnErrNoPower : HsPhoneErrors.h
  • phnErrNoRecipient : HsPhoneErrors.h
  • phnErrNoResponse : HsPhoneErrors.h
  • phnErrNoSCSubscription : HsPhoneErrors.h
  • phnErrNoSIM : HsPhoneErrors.h
  • phnErrNoSMSStorage : HsPhoneErrors.h
  • phnErrNotAllowed : HsPhoneErrors.h
  • phnErrNotFound : HsPhoneErrors.h
  • phnErrNotOpen : HsPhoneErrors.h
  • phnErrNotSupported : HsPhoneErrors.h
  • phnErrNotYetSupported : HsPhoneErrors.h
  • phnErrNullParam : HsPhoneErrors.h
  • phnErrNumberBlacklisted : HsPhoneErrors.h
  • phnErrNvBadItem : HsPhoneErrors.h
  • phnErrNVUnInitialized : HsPhoneErrors.h
  • phnErrOperDeterminedBarring : HsPhoneErrors.h
  • phnErrOptionNotSupported : HsPhoneErrors.h
  • phnErrOptionTempOutOfOrder : HsPhoneErrors.h
  • phnErrorClass : HsPhoneErrors.h
  • phnErrorClass_2 : HsPhoneErrors.h
  • PHNErrorCode : HsPhoneErrors.h
  • PHNErrorCodeRange_1 : HsPhoneErrors.h
  • PHNErrorCodeRange_2 : HsPhoneErrors.h
  • phnErrParam : HsPhoneErrors.h
  • phnErrPasswordRequired : HsPhoneErrors.h
  • phnErrPhFPINRequired : HsPhoneErrors.h
  • phnErrPhFPUKRequired : HsPhoneErrors.h
  • phnErrPhoneAdaptorLinkReserved : HsPhoneErrors.h
  • phnErrPhoneFailure : HsPhoneErrors.h
  • phnErrPhoneNotConnected : HsPhoneErrors.h
  • phnErrPhPINRequired : HsPhoneErrors.h
  • phnErrPIN2Required : HsPhoneErrors.h
  • phnErrPINRequired : HsPhoneErrors.h
  • phnErrPLMNNotAllowed : HsPhoneErrors.h
  • phnErrPoweringDown : HsPhoneErrors.h
  • phnErrProtocolError : HsPhoneErrors.h
  • phnErrPUK2Required : HsPhoneErrors.h
  • phnErrPUKRequired : HsPhoneErrors.h
  • phnErrRadioNotAvailable : HsPhoneErrors.h
  • phnErrReadNV : HsPhoneErrors.h
  • phnErrReqFacNotImplemented : HsPhoneErrors.h
  • phnErrReqFacNotSubscribed : HsPhoneErrors.h
  • phnErrReqOptionNotSubscribed : HsPhoneErrors.h
  • phnErrResourcesUnavailable : HsPhoneErrors.h
  • phnErrResponsePending : HsPhoneErrors.h
  • phnErrRoamingNotAllowed : HsPhoneErrors.h
  • phnErrSATInactive : HsPhoneErrors.h
  • phnErrSATNoInd : HsPhoneErrors.h
  • phnErrSATNotSupported : HsPhoneErrors.h
  • phnErrSATUnavailable : HsPhoneErrors.h
  • phnErrSaveNV : HsPhoneErrors.h
  • phnErrSCAddrUnknown : HsPhoneErrors.h
  • phnErrSCBusy : HsPhoneErrors.h
  • phnErrSCSystemFailure : HsPhoneErrors.h
  • phnErrSIMApplToolkitBusy : HsPhoneErrors.h
  • phnErrSIMBusy : HsPhoneErrors.h
  • phnErrSIMDataDownload : HsPhoneErrors.h
  • phnErrSIMFailure : HsPhoneErrors.h
  • phnErrSIMWrong : HsPhoneErrors.h
  • phnErrSMRejectedDuplicate : HsPhoneErrors.h
  • phnErrSMSFDNError : HsPhoneErrors.h
  • phnErrSMSMemoryFull : HsPhoneErrors.h
  • phnErrSMSMemoryOK : HsPhoneErrors.h
  • phnErrSMSServReserved : HsPhoneErrors.h
  • phnErrSMSStorageFull : HsPhoneErrors.h
  • phnErrSMSXferRejected : HsPhoneErrors.h
  • phnErrSMType0NotSupported : HsPhoneErrors.h
  • phnErrSndDelClass : HsPhoneErrors.h
  • phnErrSndDelInternalMdmError : HsPhoneErrors.h
  • phnErrSndDelInvalidRingerID : HsPhoneErrors.h
  • phnErrSndDelUndeletableRingerID : HsPhoneErrors.h
  • phnErrSndDelUnusedRingerID : HsPhoneErrors.h
  • phnErrSndSaveBadDataLen : HsPhoneErrors.h
  • phnErrSndSaveBadRingerID : HsPhoneErrors.h
  • phnErrSndSaveBadRsp : HsPhoneErrors.h
  • phnErrSndSaveBadSoundType : HsPhoneErrors.h
  • phnErrSndSaveClass : HsPhoneErrors.h
  • phnErrSndSaveContBadDataLen : HsPhoneErrors.h
  • phnErrSndSaveContClass : HsPhoneErrors.h
  • phnErrSndSaveContInternalModem : HsPhoneErrors.h
  • phnErrSndSaveContOutOfMem : HsPhoneErrors.h
  • phnErrSndSaveContSeqNum : HsPhoneErrors.h
  • phnErrSndSaveFileNameInvalid : HsPhoneErrors.h
  • phnErrSndSaveInternalModem : HsPhoneErrors.h
  • phnErrSndSaveOutOfMem : HsPhoneErrors.h
  • phnErrSPPINRequired : HsPhoneErrors.h
  • phnErrSPPUKRequired : HsPhoneErrors.h
  • phnErrStillOpen : HsPhoneErrors.h
  • phnErrStringTooLong : HsPhoneErrors.h
  • phnErrTelematicIWNotSupported : HsPhoneErrors.h
  • phnErrTemporaryFailure : HsPhoneErrors.h
  • phnErrTimeout : HsPhoneErrors.h
  • phnErrTPDUNotSupported : HsPhoneErrors.h
  • phnErrTPVPFNotSupported : HsPhoneErrors.h
  • phnErrTPVPNotSupported : HsPhoneErrors.h
  • phnErrUnassignedNumber : HsPhoneErrors.h
  • phnErrUnexpectedResponse : HsPhoneErrors.h
  • phnErrUnidentifedSubscriber : HsPhoneErrors.h
  • phnErrUnknownApp : HsPhoneErrors.h
  • phnErrUnknownError : HsPhoneErrors.h
  • phnErrUnknownID : HsPhoneErrors.h
  • phnErrUnknownNumber : HsPhoneErrors.h
  • phnErrUnknownSubscriber : HsPhoneErrors.h
  • phnErrUnspecifiedGPSRError : HsPhoneErrors.h
  • phnErrUnspecifiedTPCmdError : HsPhoneErrors.h
  • phnErrUnspecifiedTPDCSError : HsPhoneErrors.h
  • phnErrUnspecifiedTPPIDError : HsPhoneErrors.h
  • phnErrUNUSED : HsPhoneErrors.h
  • PhnEventCode : HsPhoneEvent.h
  • PhnEventPtr : HsPhoneEvent.h
  • PhnEventRecord : HsPhoneEvent.h
  • phnEvtAlerting : HsPhoneEvent.h
  • phnEvtAlertingPreConnected : HsPhoneEvent.h
  • phnEvtBusy : HsPhoneEvent.h
  • phnEvtCardInsertion : HsPhoneEvent.h
  • phnEvtConference : HsPhoneEvent.h
  • phnEvtConnectConf : HsPhoneEvent.h
  • phnEvtConnectInd : HsPhoneEvent.h
  • phnEvtDataChannel : HsPhoneEvent.h
  • phnEvtDataSessionDisconnected : HsPhoneEvent.h
  • phnEvtDataSessionStatus : HsPhoneEvent.h
  • phnEvtDebugReport : HsPhoneEvent.h
  • phnEvtDisconnectConf : HsPhoneEvent.h
  • phnEvtDisconnectInd : HsPhoneEvent.h
  • phnEvtError : HsPhoneEvent.h
  • phnEvtGPRSRegistration : HsPhoneEvent.h
  • phnEvtIndication : HsPhoneEvent.h
  • phnEvtIOTAStatus : HsPhoneEvent.h
  • phnEvtKeyPress : HsPhoneEvent.h
  • phnEvtMemoryFull : HsPhoneEvent.h
  • phnEvtMemoryOK : HsPhoneEvent.h
  • phnEvtMessageDel : HsPhoneEvent.h
  • phnEvtMessageInd : HsPhoneEvent.h
  • phnEvtMessageMoved : HsPhoneEvent.h
  • phnEvtMessageStat : HsPhoneEvent.h
  • phnEvtMIPFailed : HsPhoneEvent.h
  • phnEvtMMSInd : HsPhoneEvent.h
  • phnEvtNetworkTime : HsPhoneEvent.h
  • phnEvtOneXDataFail : HsPhoneEvent.h
  • phnEvtOneXMipRRQInd : HsPhoneEvent.h
  • phnEvtOneXStatus : HsPhoneEvent.h
  • phnEvtPassword : HsPhoneEvent.h
  • phnEvtPDDataChanged : HsPhoneEvent.h
  • phnEvtPhoneEquipmentMode : HsPhoneEvent.h
  • phnEvtPower : HsPhoneEvent.h
  • phnEvtPreConnected : HsPhoneEvent.h
  • phnEvtProgress : HsPhoneEvent.h
  • phnEvtRegistration : HsPhoneEvent.h
  • phnEvtSATNotification : HsPhoneEvent.h
  • phnEvtSegmentInd : HsPhoneEvent.h
  • phnEvtSSModeChanged : HsPhoneEvent.h
  • phnEvtStartDial : HsPhoneEvent.h
  • phnEvtStartIncomingCall : HsPhoneEvent.h
  • phnEvtSubscriber : HsPhoneEvent.h
  • phnEvtUpdate : HsPhoneEvent.h
  • phnEvtUSSDInd : HsPhoneEvent.h
  • phnEvtVoiceMail : HsPhoneEvent.h
  • phnEvtWAPInd : HsPhoneEvent.h
  • phnForwardCancelAll : HsPhoneNetworkTypes.h
  • phnForwardConditionalAll : HsPhoneNetworkTypes.h
  • phnForwardData : HsPhoneNetworkTypes.h
  • PhnForwardEnum : HsPhoneNetworkTypes.h
  • phnForwardLast : HsPhoneNetworkTypes.h
  • phnForwardModeDisable : HsPhoneNetworkTypes.h
  • phnForwardModeEnable : HsPhoneNetworkTypes.h
  • PhnForwardModeEnum : HsPhoneNetworkTypes.h
  • phnForwardModeErasure : HsPhoneNetworkTypes.h
  • phnForwardModeInterrogate : HsPhoneNetworkTypes.h
  • phnForwardModeRegistration : HsPhoneNetworkTypes.h
  • PhnForwardModeType : HsPhoneNetworkTypes.h
  • phnForwardOnBusy : HsPhoneNetworkTypes.h
  • phnForwardOnNoReplay : HsPhoneNetworkTypes.h
  • phnForwardOnNotReachable : HsPhoneNetworkTypes.h
  • phnForwardTelefax : HsPhoneNetworkTypes.h
  • PhnForwardType : HsPhoneNetworkTypes.h
  • phnForwardUnconditional : HsPhoneNetworkTypes.h
  • phnGenericCDMAAllowPDPSlotModification : HsPhoneCDMATypes.h
  • PhnGenericCDMAPreference : HsPhoneCDMATypes.h
  • phnGenericCDMASMSEncoding : HsPhoneCDMATypes.h
  • PhnGenericCDMASMSEncodingType : HsPhoneCDMATypes.h
  • phnGenericCDMAVoiceMailNumber : HsPhoneCDMATypes.h
  • phnGenericCDMAVoiceMailOption : HsPhoneCDMATypes.h
  • phnGPRSCallActive : HsPhoneTypes.h
  • PhnGPRSPDPType : HsPhoneGSMTypes.h
  • phnGPRSPDPTypeIP : HsPhoneGSMTypes.h
  • phnGPRSPDPTypePPP : HsPhoneGSMTypes.h
  • PhnGPRSQOSType : HsPhoneGSMTypes.h
  • phnGsmAttrFirst : HsPhoneMiscTypes.h
  • phnGsmAttrLast : HsPhoneMiscTypes.h
  • phnGsmFWControlLED : HsPhoneMiscTypes.h
  • phnGsmNoFWVersionCompatibilityCheck : HsPhoneMiscTypes.h
  • phnGsmRadioAudioSet : HsPhoneMiscTypes.h
  • phnGsmSimBookSimMaxEntries : HsPhoneMiscTypes.h
  • phnGsmSimBookSimUsedEntries : HsPhoneMiscTypes.h
  • PhnHACSetting : HsPhoneAudioTypes.h
  • phnHandsetLidCloseMode : HsPhoneMiscTypes.h
  • phnHandsetMode : HsPhoneMiscTypes.h
  • phnHeadsetMode : HsPhoneMiscTypes.h
  • PhnIndicationKind : HsPhoneEvent.h
  • phnInvalidEquipmentMode : HsPhoneMiscTypes.h
  • phnIOTACommit : HsPhoneIOTATypes.h
  • phnIOTAEnd : HsPhoneIOTATypes.h
  • phnIOTAEvent : HsPhoneIOTATypes.h
  • phnIOTAItemBootNAIURL : HsPhoneIOTATypes.h
  • phnIOTAItemBootURL : HsPhoneIOTATypes.h
  • phnIOTAItemConnectionTimeout : HsPhoneIOTATypes.h
  • phnIOTAItemDownloadServerLock : HsPhoneIOTATypes.h
  • phnIOTAItemDownloadServerURL : HsPhoneIOTATypes.h
  • PhnIOTAItemEnum : HsPhoneIOTATypes.h
  • phnIOTAItemHomepageURL : HsPhoneIOTATypes.h
  • phnIOTAItemLastNVItem : HsPhoneIOTATypes.h
  • phnIOTAItemPriDataExchangeURL : HsPhoneIOTATypes.h
  • phnIOTAItemPriDataGatewayURL : HsPhoneIOTATypes.h
  • phnIOTAItemPriIMMessageStore : HsPhoneIOTATypes.h
  • phnIOTAItemPriProxyWDPAddress : HsPhoneIOTATypes.h
  • phnIOTAItemPriSIPConfigServer : HsPhoneIOTATypes.h
  • phnIOTAItemPriSIPEdgeProxyGateway : HsPhoneIOTATypes.h
  • phnIOTAItemPriSIPRetryCount : HsPhoneIOTATypes.h
  • phnIOTAItemPriSIPRetryTimer : HsPhoneIOTATypes.h
  • phnIOTAItemPriWAPPushProxyGatewayURL : HsPhoneIOTATypes.h
  • phnIOTAItemPRLStorageSize : HsPhoneIOTATypes.h
  • phnIOTAItemRootCertificate1 : HsPhoneIOTATypes.h
  • phnIOTAItemRootCertificate2 : HsPhoneIOTATypes.h
  • phnIOTAItemRootCertificate3 : HsPhoneIOTATypes.h
  • phnIOTAItemRootCertificate4 : HsPhoneIOTATypes.h
  • phnIOTAItemSecDataExchangeURL : HsPhoneIOTATypes.h
  • phnIOTAItemSecDataGatewayURL : HsPhoneIOTATypes.h
  • phnIOTAItemSecIMMessageStore : HsPhoneIOTATypes.h
  • phnIOTAItemSecProxyWDPAddress : HsPhoneIOTATypes.h
  • phnIOTAItemSecSIPConfigServer : HsPhoneIOTATypes.h
  • phnIOTAItemSecSIPEdgeProxyGateway : HsPhoneIOTATypes.h
  • phnIOTAItemSecSIPRetryCount : HsPhoneIOTATypes.h
  • phnIOTAItemSecSIPRetryTimer : HsPhoneIOTATypes.h
  • phnIOTAItemSecWAPPushProxyGatewayURL : HsPhoneIOTATypes.h
  • phnIOTAItemSIPPassword : HsPhoneIOTATypes.h
  • phnIOTAItemSIPUsername : HsPhoneIOTATypes.h
  • phnIOTAItemTrustedDomain : HsPhoneIOTATypes.h
  • PhnIOTAItemType : HsPhoneIOTATypes.h
  • phnIOTAItemUnknown : HsPhoneIOTATypes.h
  • phnIOTAItemVendingURL : HsPhoneIOTATypes.h
  • phnIOTANAMSelect : HsPhoneIOTATypes.h
  • phnIOTAStart : HsPhoneIOTATypes.h
  • PhnIOTAStatus : HsPhoneIOTATypes.h
  • phnIOTAUnknown : HsPhoneIOTATypes.h
  • PhnLibAddAddress() : HsPhoneSMS.h
  • PhnLibAddressToText() : HsPhoneSMS.h
  • PhnLibAPGetField() : HsPhoneCDMA.h
  • PhnLibAPGetNth() : HsPhoneSMS.h
  • PhnLibAttrGet() : HsPhoneMisc.h
  • PhnLibAttrPtr : HsPhoneMiscTypes.h
  • PhnLibAttrSet() : HsPhoneMisc.h
  • PhnLibAttrType : HsPhoneMiscTypes.h
  • PhnLibBoxInformation() : HsPhoneNetwork.h
  • PhnLibBoxInformationEx() : HsPhoneNetwork.h
  • PhnLibCardInfo() : HsPhoneMisc.h
  • PhnLibCardInfoEx() : HsPhoneMisc.h
  • phnLibCDMADbCreator : HsPhoneTypes.h
  • phnLibCDMAName : HsPhoneTypes.h
  • PhnLibClose() : HsPhoneLibrary.h
  • PhnLibConnectionAvailable() : HsPhoneMisc.h
  • PhnLibContinuePhonePowerOff() : HsPhonePower.h
  • PhnLibContinuePhonePowerOn() : HsPhonePower.h
  • PhnLibCount() : HsPhoneSMS.h
  • PhnLibCRSM() : HsPhoneSecurity.h
  • PhnLibCurrentOperator() : HsPhoneNetwork.h
  • PhnLibCurrentOperatorID() : HsPhoneNetwork.h
  • PhnLibCurrentProvider() : HsPhoneNetwork.h
  • phnLibDbType : HsPhoneTypes.h
  • PhnLibDeactivateBarring() : HsPhoneNetwork.h
  • PhnLibDeleteMessage() : HsPhoneSMS.h
  • PhnLibDisposeAddressList() : HsPhoneSMS.h
  • PhnLibEqual() : HsPhoneSMS.h
  • PhnLibErrorRate() : HsPhoneMisc.h
  • phnLibFtrNumBlockATCmd : HsPhoneTypes.h
  • phnLibFtrNumBottomBRate : HsPhoneTypes.h
  • phnLibFtrNumResetFlag : HsPhoneTypes.h
  • phnLibFtrValBlockATCmd : HsPhoneTypes.h
  • PhnLibGetAddresses() : HsPhoneSMS.h
  • PhnLibGetBarring() : HsPhoneNetwork.h
  • PhnLibGetBaseStationIdInfo() : HsPhoneMisc.h
  • PhnLibGetBoxNumber() : HsPhoneNetwork.h
  • PhnLibGetCallCountByService() : HsPhoneMisc.h
  • PhnLibGetCallWaiting() : HsPhoneNetwork.h
  • PhnLibGetCLIP() : HsPhoneNetwork.h
  • PhnLibGetCLIR() : HsPhoneNetwork.h
  • PhnLibGetDataSessionInfo() : HsPhoneNetwork.h
  • PhnLibGetDate() : HsPhoneSMS.h
  • PhnLibGetDBRef() : HsPhoneSMS.h
  • PhnLibGetDeviceID() : HsPhoneMisc.h
  • PhnLibGetEchoCancellation() : HsPhoneMisc.h
  • PhnLibGetEnhancedRoamIndicator() : HsPhoneNetwork.h
  • PhnLibGetEquipmentMode() : HsPhoneMisc.h
  • PhnLibGetErrorText() : HsPhoneMisc.h
  • PhnLibGetFDNList() : HsPhoneGSM.h
  • PhnLibGetField() : HsPhoneSMS.h
  • PhnLibGetFlags() : HsPhoneSMS.h
  • PhnLibGetForwarding() : HsPhoneNetwork.h
  • PhnLibGetGSMCellInfo() : HsPhoneGSM.h
  • PhnLibGetHeadsetConnectedInfo() : HsPhoneMisc.h
  • PhnLibGetICCID() : HsPhoneGSM.h
  • PhnLibGetID() : HsPhoneSMS.h
  • PhnLibGetLengthDetails() : HsPhoneSMS.h
  • PhnLibGetLibAPIVersion() : HsPhoneLibrary.h
  • PhnLibGetLineState() : HsPhoneMisc.h
  • PhnLibGetMEID() : HsPhoneMisc.h
  • PhnLibGetMicrophone() : HsPhoneMisc.h
  • PhnLibGetMMSUAString() : HsPhoneMisc.h
  • PhnLibGetNoiseCancellation() : HsPhoneMisc.h
  • PhnLibGetNth() : HsPhoneSMS.h
  • PhnLibGetOperatorList() : HsPhoneNetwork.h
  • PhnLibGetOperatorLock() : HsPhoneNetwork.h
  • PhnLibGetOptions() : HsPhoneSMS.h
  • PhnLibGetOwner() : HsPhoneSMS.h
  • PhnLibGetOwnNumbers() : HsPhoneNetwork.h
  • PhnLibGetPhoneBook() : HsPhoneGSM.h
  • PhnLibGetPhoneBookIndex() : HsPhoneGSM.h
  • PhnLibGetPhoneCallStatus() : HsPhoneMisc.h
  • PhnLibGetPhoneLock() : HsPhoneSecurity.h
  • PhnLibGetRadioState() : HsPhoneMisc.h
  • PhnLibGetRemainingPasswordTries() : HsPhoneSecurity.h
  • PhnLibGetRoamPrefMode() : HsPhoneNetwork.h
  • PhnLibGetSDNList() : HsPhoneGSM.h
  • PhnLibGetServiceCentreAddress() : HsPhoneSMS.h
  • PhnLibGetSIMStatus() : HsPhoneGSM.h
  • PhnLibGetSMSGateway() : HsPhoneSMS.h
  • PhnLibGetSMSPreference() : HsPhoneSMS.h
  • PhnLibGetSMSRingInfo() : HsPhoneSMS.h
  • PhnLibGetSpn() : HsPhoneGSM.h
  • PhnLibGetStatus() : HsPhoneSMS.h
  • PhnLibGetSubstitution() : HsPhoneSMS.h
  • PhnLibGetText() : HsPhoneSMS.h
  • PhnLibGetType() : HsPhoneSMS.h
  • PhnLibGPRSAttached() : HsPhoneGSM.h
  • PhnLibGPRSPDPContextDefine() : HsPhoneGSM.h
  • PhnLibGPRSPDPContextListConstruct() : HsPhoneGSM.h
  • PhnLibGPRSPDPContextListDestruct() : HsPhoneGSM.h
  • PhnLibGPRSQualityOfServiceGet() : HsPhoneGSM.h
  • PhnLibGPRSQualityOfServiceSet() : HsPhoneGSM.h
  • phnLibGSMDbCreator : HsPhoneTypes.h
  • phnLibGSMDbName : HsPhoneTypes.h
  • phnLibGSMName : HsPhoneTypes.h
  • PhnLibHasName() : HsPhoneSMS.h
  • PhnLibHomeOperatorID() : HsPhoneNetwork.h
  • PhnLibIsCallMuted() : HsPhoneMisc.h
  • PhnLibIsLegalCharacter() : HsPhoneSMS.h
  • PhnLibIsPhoneActivated() : HsPhoneMisc.h
  • phnLibLaunchCmdEvent : HsPhoneEvent.h
  • phnLibLaunchCmdRegister : HsPhoneEvent.h
  • PhnLibLength() : HsPhoneSMS.h
  • PhnLibMapCharacter() : HsPhoneSMS.h
  • PhnLibMiscDebugInfo() : HsPhoneMisc.h
  • PhnLibMMSServerInfoSettingsMajorVersion : HsPhoneSMSTypes.h
  • PhnLibMMSServerInfoSettingsMinorVersion : HsPhoneSMSTypes.h
  • PhnLibMMSServerInfoType : HsPhoneSMSTypes.h
  • PhnLibMMSServerInfoVersion : HsPhoneSMSTypes.h
  • PhnLibModulePowered() : HsPhonePower.h
  • PhnLibMute() : HsPhoneMisc.h
  • PhnLibNetworkAvailable() : HsPhoneNetwork.h
  • PhnLibNewAddress() : HsPhoneSMS.h
  • PhnLibNewAddressList() : HsPhoneSMS.h
  • PhnLibNewMessage() : HsPhoneSMS.h
  • phnLibNoLookupNeededID : HsPhoneTypes.h
  • phnLibOldCDMADbCreator : HsPhoneTypes.h
  • phnLibOldCDMAName : HsPhoneTypes.h
  • PhnLibOpen() : HsPhoneLibrary.h
  • PhnLibQuerySMSMT() : HsPhoneSMS.h
  • PhnLibRegister() : HsPhoneLibrary.h
  • PhnLibRegistered() : HsPhoneNetwork.h
  • PhnLibReleaseDBRef() : HsPhoneSMS.h
  • PhnLibRoaming() : HsPhoneNetwork.h
  • PhnLibSATEndSession() : HsPhoneGSM.h
  • PhnLibSATGetMainMenu() : HsPhoneGSM.h
  • PhnLibSATSendRequest() : HsPhoneGSM.h
  • PhnLibSendLongDTMF() : HsPhoneGSM.h
  • PhnLibSendMessage() : HsPhoneSMS.h
  • PhnLibSendPendingMessages() : HsPhoneSMS.h
  • PhnLibSendSMSMTAck() : HsPhoneSMS.h
  • PhnLibSendUSSD() : HsPhoneGSM.h
  • PhnLibSetActiveLine() : HsPhoneGSM.h
  • PhnLibSetAddresses() : HsPhoneSMS.h
  • PhnLibSetBarring() : HsPhoneNetwork.h
  • PhnLibSetCallWaiting() : HsPhoneNetwork.h
  • PhnLibSetCLIP() : HsPhoneNetwork.h
  • PhnLibSetCLIR() : HsPhoneNetwork.h
  • PhnLibSetDate() : HsPhoneSMS.h
  • PhnLibSetEchoCancellation() : HsPhoneMisc.h
  • PhnLibSetEquipmentMode() : HsPhoneMisc.h
  • PhnLibSetFDNEntry() : HsPhoneGSM.h
  • PhnLibSetField() : HsPhoneSMS.h
  • PhnLibSetFlags() : HsPhoneSMS.h
  • PhnLibSetForwarding() : HsPhoneNetwork.h
  • PhnLibSetID() : HsPhoneSMS.h
  • PhnLibSetMicrophone() : HsPhoneMisc.h
  • PhnLibSetModulePower() : HsPhonePower.h
  • PhnLibSetNoiseCancellation() : HsPhoneMisc.h
  • PhnLibSetNth() : HsPhoneSMS.h
  • PhnLibSetNumber() : HsPhoneSMS.h
  • PhnLibSetOperator() : HsPhoneNetwork.h
  • PhnLibSetOperatorLock() : HsPhoneSecurity.h
  • PhnLibSetOptions() : HsPhoneSMS.h
  • PhnLibSetOwner() : HsPhoneSMS.h
  • PhnLibSetOwnNumbers() : HsPhoneNetwork.h
  • PhnLibSetPhoneBook() : HsPhoneGSM.h
  • PhnLibSetPhoneBookEntry() : HsPhoneGSM.h
  • PhnLibSetPhoneLock() : HsPhoneSecurity.h
  • PhnLibSetRoamPrefInfo() : HsPhoneNetwork.h
  • PhnLibSetRoamPrefMode() : HsPhoneNetwork.h
  • PhnLibSetServiceCentreAddress() : HsPhoneSMS.h
  • PhnLibSetSMSCallbackNumber() : HsPhoneSMS.h
  • PhnLibSetSMSPreference() : HsPhoneSMS.h
  • PhnLibSetSMSRingInfo() : HsPhoneSMS.h
  • PhnLibSetStatus() : HsPhoneSMS.h
  • PhnLibSetText() : HsPhoneSMS.h
  • PhnLibSignalQuality() : HsPhoneNetwork.h
  • PhnLibSignalQualityEx() : HsPhoneNetwork.h
  • PhnLibSIMInfo() : HsPhoneGSM.h
  • PhnLibSleep() : HsPhoneLibrary.h
  • PhnLibStartVibrate() : HsPhoneMisc.h
  • PhnLibStopVibrate() : HsPhoneMisc.h
  • PhnLibTrapActivate : HsPhoneTraps.h
  • PhnLibTrapAddAddress : HsPhoneTraps.h
  • PhnLibTrapAddressToText : HsPhoneTraps.h
  • PhnLibTrapAPGetField : HsPhoneTraps.h
  • PhnLibTrapAPGetNth : HsPhoneTraps.h
  • PhnLibTrapAPNewAddress : HsPhoneTraps.h
  • PhnLibTrapAttrGet : HsPhoneTraps.h
  • PhnLibTrapAttrSet : HsPhoneTraps.h
  • PhnLibTrapBattery : HsPhoneTraps.h
  • PhnLibTrapBatteryCharge : HsPhoneTraps.h
  • PhnLibTrapBoxInformation : HsPhoneTraps.h
  • PhnLibTrapBoxInformationEx : HsPhoneTraps.h
  • PhnLibTrapCardInfo : HsPhoneTraps.h
  • PhnLibTrapCardInfoEx : HsPhoneTraps.h
  • PhnLibTrapChangePassword : HsPhoneTraps.h
  • PhnLibTrapCloseNetIF : HsPhoneTraps.h
  • PhnLibTrapCommitIOTAParams : HsPhoneTraps.h
  • PhnLibTrapConference : HsPhoneTraps.h
  • PhnLibTrapConnectionAvailable : HsPhoneTraps.h
  • PhnLibTrapContinuePhonePowerOff : HsPhoneTraps.h
  • PhnLibTrapContinuePhonePowerOn : HsPhoneTraps.h
  • PhnLibTrapCopyPDP : HsPhoneTraps.h
  • PhnLibTrapCount : HsPhoneTraps.h
  • PhnLibTrapCRSM : HsPhoneTraps.h
  • PhnLibTrapCurrentOperator : HsPhoneTraps.h
  • PhnLibTrapCurrentOperatorID : HsPhoneTraps.h
  • PhnLibTrapCurrentProvider : HsPhoneTraps.h
  • PhnLibTrapDeactivateBarring : HsPhoneTraps.h
  • PhnLibTrapDebug : HsPhoneTraps.h
  • PhnLibTrapDebugHook : HsPhoneTraps.h
  • PhnLibTrapDecodeMMI : HsPhoneTraps.h
  • PhnLibTrapDeleteMessage : HsPhoneTraps.h
  • PhnLibTrapDeletePDP : HsPhoneTraps.h
  • PhnLibTrapDial : HsPhoneTraps.h
  • PhnLibTrapDisconnect : HsPhoneTraps.h
  • PhnLibTrapDisposeAddressList : HsPhoneTraps.h
  • PhnLibTrapEnableDM : HsPhoneTraps.h
  • PhnLibTrapEndIOTASession : HsPhoneTraps.h
  • PhnLibTrapEnhancedRoamIndicator : HsPhoneTraps.h
  • PhnLibTrapEqual : HsPhoneTraps.h
  • PhnLibTrapErrorRate : HsPhoneTraps.h
  • PhnLibTrapExecuteMMI : HsPhoneTraps.h
  • PhnLibTrapExit911Mode : HsPhoneTraps.h
  • PhnLibTrapExitPowerSaveMode : HsPhoneTraps.h
  • PhnLibTrapFindEntry : HsPhoneTraps.h
  • PhnLibTrapFirstAppForService : HsPhoneTraps.h
  • PhnLibTrapForceDataDormant : HsPhoneTraps.h
  • PhnLibTrapGetAddresses : HsPhoneTraps.h
  • PhnLibTrapGetBand : HsPhoneTraps.h
  • PhnLibTrapGetBarring : HsPhoneTraps.h
  • PhnLibTrapGetBaseStationIdInfo : HsPhoneTraps.h
  • PhnLibTrapGetBinary : HsPhoneTraps.h
  • PhnLibTrapGetBoxNumber : HsPhoneTraps.h
  • PhnLibTrapGetCallCountByService : HsPhoneTraps.h
  • PhnLibTrapGetCallWaiting : HsPhoneTraps.h
  • PhnLibTrapGetCDMASystemInfo : HsPhoneTraps.h
  • PhnLibTrapGetCktSwitchProfile : HsPhoneTraps.h
  • PhnLibTrapGetCLIP : HsPhoneTraps.h
  • PhnLibTrapGetCLIR : HsPhoneTraps.h
  • PhnLibTrapGetConnectionInfo : HsPhoneTraps.h
  • PhnLibTrapGetCustomServiceProfile : HsPhoneTraps.h
  • PhnLibTrapGetDataApplication : HsPhoneTraps.h
  • PhnLibTrapGetDataLife : HsPhoneTraps.h
  • PhnLibTrapGetDataSessionInfo : HsPhoneTraps.h
  • PhnLibTrapGetDate : HsPhoneTraps.h
  • PhnLibTrapGetDBRef : HsPhoneTraps.h
  • PhnLibTrapGetDedicatedDataMode : HsPhoneTraps.h
  • PhnLibTrapGetDefaultDataApps : HsPhoneTraps.h
  • PhnLibTrapGetDeviceId : HsPhoneTraps.h
  • PhnLibTrapGetDialPrefix : HsPhoneTraps.h
  • PhnLibTrapGetDTMFburstMode : HsPhoneTraps.h
  • PhnLibTrapGetEchoCancellation : HsPhoneTraps.h
  • PhnLibTrapGetEquipmentMode : HsPhoneTraps.h
  • PhnLibTrapGetErrorText : HsPhoneTraps.h
  • PhnLibTrapGetFDNList : HsPhoneTraps.h
  • PhnLibTrapGetField : HsPhoneTraps.h
  • PhnLibTrapGetFlags : HsPhoneTraps.h
  • PhnLibTrapGetForwarding : HsPhoneTraps.h
  • PhnLibTrapGetGenericCDMAPreference : HsPhoneTraps.h
  • PhnLibTrapGetGSMCellInfo : HsPhoneTraps.h
  • PhnLibTrapGetHeadsetConnectedInfo : HsPhoneTraps.h
  • PhnLibTrapGetHomepageFromRadio : HsPhoneTraps.h
  • PhnLibTrapGetICCID : HsPhoneTraps.h
  • PhnLibTrapGetID : HsPhoneTraps.h
  • PhnLibTrapGetIOTAStatus : HsPhoneTraps.h
  • PhnLibTrapGetLengthDetails : HsPhoneTraps.h
  • PhnLibTrapGetLibAPIVersion : HsPhoneTraps.h
  • PhnLibTrapGetLifeTimer : HsPhoneTraps.h
  • PhnLibTrapGetLineState : HsPhoneTraps.h
  • PhnLibTrapGetMdmPosition : HsPhoneTraps.h
  • PhnLibTrapGetMediaTVSettings : HsPhoneTraps.h
  • PhnLibTrapGetMEID : HsPhoneTraps.h
  • PhnLibTrapGetMicrophone : HsPhoneTraps.h
  • PhnLibTrapGetMMSServerInfo : HsPhoneTraps.h
  • PhnLibTrapGetMMSServerInfoEx : HsPhoneTraps.h
  • PhnLibTrapGetMMSUAString : HsPhoneTraps.h
  • PhnLibTrapGetMSID : HsPhoneTraps.h
  • PhnLibTrapGetMVNOName : HsPhoneTraps.h
  • PhnLibTrapGetNAMInUse : HsPhoneTraps.h
  • PhnLibTrapGetNoiseCancellation : HsPhoneTraps.h
  • PhnLibTrapGetNth : HsPhoneTraps.h
  • PhnLibTrapGetOneXStatus : HsPhoneTraps.h
  • PhnLibTrapGetOperatorList : HsPhoneTraps.h
  • PhnLibTrapGetOperatorLock : HsPhoneTraps.h
  • PhnLibTrapGetOptions : HsPhoneTraps.h
  • PhnLibTrapGetOwner : HsPhoneTraps.h
  • PhnLibTrapGetOwnNumbers : HsPhoneTraps.h
  • PhnLibTrapGetPDP : HsPhoneTraps.h
  • PhnLibTrapGetPDPIndexRange : HsPhoneTraps.h
  • PhnLibTrapGetPDSessionConfigParam : HsPhoneTraps.h
  • PhnLibTrapGetPhnOprtMode : HsPhoneTraps.h
  • PhnLibTrapGetPhoneBook : HsPhoneTraps.h
  • PhnLibTrapGetPhoneBookIndex : HsPhoneTraps.h
  • PhnLibTrapGetPhoneCallStatus : HsPhoneTraps.h
  • PhnLibTrapGetPhoneLock : HsPhoneTraps.h
  • PhnLibTrapGetPhoneSSMode : HsPhoneTraps.h
  • PhnLibTrapGetPicturesServerInfo : HsPhoneTraps.h
  • PhnLibTrapGetPicturesToken : HsPhoneTraps.h
  • PhnLibTrapGetProxyInfo : HsPhoneTraps.h
  • PhnLibTrapGetRadioState : HsPhoneTraps.h
  • PhnLibTrapGetRemainingPasswordTries : HsPhoneTraps.h
  • PhnLibTrapGetRingingInfo : HsPhoneTraps.h
  • PhnLibTrapGetRoamPrefInfo : HsPhoneTraps.h
  • PhnLibTrapGetRoamPrefMode : HsPhoneTraps.h
  • PhnLibTrapGetSDNList : HsPhoneTraps.h
  • PhnLibTrapGetServiceCentreAddress : HsPhoneTraps.h
  • PhnLibTrapGetSIMStatus : HsPhoneTraps.h
  • PhnLibTrapGetSMSGateway : HsPhoneTraps.h
  • PhnLibTrapGetSMSPreference : HsPhoneTraps.h
  • PhnLibTrapGetSMSRingInfo : HsPhoneTraps.h
  • PhnLibTrapGetSMSSegmentInfo : HsPhoneTraps.h
  • PhnLibTrapGetSpecialNumbers : HsPhoneTraps.h
  • PhnLibTrapGetSpMode : HsPhoneTraps.h
  • PhnLibTrapGetSpn : HsPhoneTraps.h
  • PhnLibTrapGetStatus : HsPhoneTraps.h
  • PhnLibTrapGetSubstitution : HsPhoneTraps.h
  • PhnLibTrapGetSysPrefMode : HsPhoneTraps.h
  • PhnLibTrapGetText : HsPhoneTraps.h
  • PhnLibTrapGetToneIDs : HsPhoneTraps.h
  • PhnLibTrapGetToneIDsEx : HsPhoneTraps.h
  • PhnLibTrapGetToneLength : HsPhoneTraps.h
  • PhnLibTrapGetToneName : HsPhoneTraps.h
  • PhnLibTrapGetTotalDataRxBytes : HsPhoneTraps.h
  • PhnLibTrapGetTotalDataTxBytes : HsPhoneTraps.h
  • PhnLibTrapGetTotalPDPs : HsPhoneTraps.h
  • PhnLibTrapGetTTYSetting : HsPhoneTraps.h
  • PhnLibTrapGetType : HsPhoneTraps.h
  • PhnLibTrapGetVoicePrivacyMode : HsPhoneTraps.h
  • PhnLibTrapGetVolume : HsPhoneTraps.h
  • PhnLibTrapGPRSAttached : HsPhoneTraps.h
  • PhnLibTrapGPRSAttachRequest : HsPhoneTraps.h
  • PhnLibTrapGPRSPDPContextDefine : HsPhoneTraps.h
  • PhnLibTrapGPRSPDPContextListConstruct : HsPhoneTraps.h
  • PhnLibTrapGPRSPDPContextListDestruct : HsPhoneTraps.h
  • PhnLibTrapGPRSQualityOfServiceGet : HsPhoneTraps.h
  • PhnLibTrapGPRSQualityOfServiceSet : HsPhoneTraps.h
  • PhnLibTrapHACSetting : HsPhoneTraps.h
  • PhnLibTrapHasName : HsPhoneTraps.h
  • PhnLibTrapHold : HsPhoneTraps.h
  • PhnLibTrapHomeOperatorID : HsPhoneTraps.h
  • PhnLibTrapIsCallMuted : HsPhoneTraps.h
  • PhnLibTrapIsCarrierDefinedEmergencyNumber : HsPhoneTraps.h
  • PhnLibTrapIsEmergencyNumber : HsPhoneTraps.h
  • PhnLibTrapIsLegalCharacter : HsPhoneTraps.h
  • PhnLibTrapIsPhoneActivated : HsPhoneTraps.h
  • PhnLibTrapIsRadioGenericCDMA : HsPhoneTraps.h
  • PhnLibTrapIsSpecialNumber : HsPhoneTraps.h
  • PhnLibTrapLast : HsPhoneTraps.h
  • PhnLibTrapLedAlert : HsPhoneTraps.h
  • PhnLibTrapLength : HsPhoneTraps.h
  • PhnLibTrapListPDP : HsPhoneTraps.h
  • PhnLibTrapLoadCDMATime : HsPhoneTraps.h
  • PhnLibTrapMapCharacter : HsPhoneTraps.h
  • PhnLibTrapMiscDebugInfo : HsPhoneTraps.h
  • PhnLibTrapModemIssueResetInfo : HsPhoneTraps.h
  • PhnLibTrapModuleButtonDown : HsPhoneTraps.h
  • PhnLibTrapModulePowered : HsPhoneTraps.h
  • PhnLibTrapMute : HsPhoneTraps.h
  • PhnLibTrapNetworkAvailable : HsPhoneTraps.h
  • PhnLibTrapNewAddress : HsPhoneTraps.h
  • PhnLibTrapNewAddressList : HsPhoneTraps.h
  • PhnLibTrapNewMessage : HsPhoneTraps.h
  • PhnLibTrapNewMOMessage : HsPhoneTraps.h
  • PhnLibTrapOffHold : HsPhoneTraps.h
  • PhnLibTrapParamText : HsPhoneTraps.h
  • PhnLibTrapPasswordDialog : HsPhoneTraps.h
  • PhnLibTrapPDPLockUnlock : HsPhoneTraps.h
  • PhnLibTrapPhoneRestore : HsPhoneTraps.h
  • PhnLibTrapPlayDTMF : HsPhoneTraps.h
  • PhnLibTrapPlayTone : HsPhoneTraps.h
  • PhnLibTrapPlayToneEx : HsPhoneTraps.h
  • PhnLibTrapPowerSaveDisable : HsPhoneTraps.h
  • PhnLibTrapQuerySMSMT : HsPhoneTraps.h
  • PhnLibTrapReadIOTAItem : HsPhoneTraps.h
  • PhnLibTrapRegister : HsPhoneTraps.h
  • PhnLibTrapRegistered : HsPhoneTraps.h
  • PhnLibTrapReleaseDBRef : HsPhoneTraps.h
  • PhnLibTrapReplacePDPNAI : HsPhoneTraps.h
  • PhnLibTrapReplacePDPPassword : HsPhoneTraps.h
  • PhnLibTrapReplacePDPSvcString : HsPhoneTraps.h
  • PhnLibTrapRoaming : HsPhoneTraps.h
  • PhnLibTrapSATEndSession : HsPhoneTraps.h
  • PhnLibTrapSATGetMainMenu : HsPhoneTraps.h
  • PhnLibTrapSATSendRequest : HsPhoneTraps.h
  • PhnLibTrapSelectAddress : HsPhoneTraps.h
  • PhnLibTrapSelectNAM : HsPhoneTraps.h
  • PhnLibTrapSendDTMF : HsPhoneTraps.h
  • PhnLibTrapSendDTMFBurst : HsPhoneTraps.h
  • PhnLibTrapSendFlash : HsPhoneTraps.h
  • PhnLibTrapSendLongDTMF : HsPhoneTraps.h
  • PhnLibTrapSendMessage : HsPhoneTraps.h
  • PhnLibTrapSendPendingMessages : HsPhoneTraps.h
  • PhnLibTrapSendSilentDTMF : HsPhoneTraps.h
  • PhnLibTrapSendSMSMTAck : HsPhoneTraps.h
  • PhnLibTrapSendUSSD : HsPhoneTraps.h
  • PhnLibTrapSetActiveLine : HsPhoneTraps.h
  • PhnLibTrapSetAddresses : HsPhoneTraps.h
  • PhnLibTrapSetBand : HsPhoneTraps.h
  • PhnLibTrapSetBarring : HsPhoneTraps.h
  • PhnLibTrapSetBoxNumber : HsPhoneTraps.h
  • PhnLibTrapSetCallWaiting : HsPhoneTraps.h
  • PhnLibTrapSetCLIP : HsPhoneTraps.h
  • PhnLibTrapSetCLIR : HsPhoneTraps.h
  • PhnLibTrapSetCurrentUsageHandler : HsPhoneTraps.h
  • PhnLibTrapSetDataApplication : HsPhoneTraps.h
  • PhnLibTrapSetDate : HsPhoneTraps.h
  • PhnLibTrapSetDedicatedDataMode : HsPhoneTraps.h
  • PhnLibTrapSetDialPrefix : HsPhoneTraps.h
  • PhnLibTrapSetDTMFburstMode : HsPhoneTraps.h
  • PhnLibTrapSetEchoCancellation : HsPhoneTraps.h
  • PhnLibTrapSetEquipmentMode : HsPhoneTraps.h
  • PhnLibTrapSetFDNEntry : HsPhoneTraps.h
  • PhnLibTrapSetField : HsPhoneTraps.h
  • PhnLibTrapSetFlags : HsPhoneTraps.h
  • PhnLibTrapSetForwarding : HsPhoneTraps.h
  • PhnLibTrapSetID : HsPhoneTraps.h
  • PhnLibTrapSetMdmAutoMsgMask : HsPhoneTraps.h
  • PhnLibTrapSetMicrophone : HsPhoneTraps.h
  • PhnLibTrapSetModulePower : HsPhoneTraps.h
  • PhnLibTrapSetNoiseCancellation : HsPhoneTraps.h
  • PhnLibTrapSetNth : HsPhoneTraps.h
  • PhnLibTrapSetNumber : HsPhoneTraps.h
  • PhnLibTrapSetOperator : HsPhoneTraps.h
  • PhnLibTrapSetOperatorLock : HsPhoneTraps.h
  • PhnLibTrapSetOptions : HsPhoneTraps.h
  • PhnLibTrapSetOwner : HsPhoneTraps.h
  • PhnLibTrapSetOwnNumbers : HsPhoneTraps.h
  • PhnLibTrapSetPDP : HsPhoneTraps.h
  • PhnLibTrapSetPDSessionConfigParam : HsPhoneTraps.h
  • PhnLibTrapSetPhnOprtMode : HsPhoneTraps.h
  • PhnLibTrapSetPhoneBook : HsPhoneTraps.h
  • PhnLibTrapSetPhoneBookEntry : HsPhoneTraps.h
  • PhnLibTrapSetPhoneLock : HsPhoneTraps.h
  • PhnLibTrapSetPhoneSSMode : HsPhoneTraps.h
  • PhnLibTrapSetPicturesToken : HsPhoneTraps.h
  • PhnLibTrapSetRingingInfo : HsPhoneTraps.h
  • PhnLibTrapSetRoamPrefInfo : HsPhoneTraps.h
  • PhnLibTrapSetRoamPrefMode : HsPhoneTraps.h
  • PhnLibTrapSetServiceCentreAddress : HsPhoneTraps.h
  • PhnLibTrapSetSMSCallbackNumber : HsPhoneTraps.h
  • PhnLibTrapSetSMSPreference : HsPhoneTraps.h
  • PhnLibTrapSetSMSRingInfo : HsPhoneTraps.h
  • PhnLibTrapSetSpecialNumbers : HsPhoneTraps.h
  • PhnLibTrapSetStatus : HsPhoneTraps.h
  • PhnLibTrapSetSysPrefMode : HsPhoneTraps.h
  • PhnLibTrapSetText : HsPhoneTraps.h
  • PhnLibTrapSetToneLength : HsPhoneTraps.h
  • PhnLibTrapSetTTYSetting : HsPhoneTraps.h
  • PhnLibTrapSetupDataConfig : HsPhoneTraps.h
  • PhnLibTrapSetVoicePrivacyMode : HsPhoneTraps.h
  • PhnLibTrapSetVolume : HsPhoneTraps.h
  • PhnLibTrapSignalQuality : HsPhoneTraps.h
  • PhnLibTrapSignalQualityEx : HsPhoneTraps.h
  • PhnLibTrapSIMInfo : HsPhoneTraps.h
  • PhnLibTrapSndDelete : HsPhoneTraps.h
  • PhnLibTrapSndSave : HsPhoneTraps.h
  • PhnLibTrapStartIOTASession : HsPhoneTraps.h
  • PhnLibTrapStartVibrate : HsPhoneTraps.h
  • PhnLibTrapStopPDSession : HsPhoneTraps.h
  • PhnLibTrapStopTone : HsPhoneTraps.h
  • PhnLibTrapStopVibrate : HsPhoneTraps.h
  • PhnLibTrapTunnelIS683ReqMsg : HsPhoneTraps.h
  • PhnLibTrapUninstall : HsPhoneTraps.h
  • PhnLibTrapUnlockPhoneLock : HsPhoneTraps.h
  • PhnLibTrapUpdateCustomizedNV : HsPhoneTraps.h
  • PhnLibTrapUpdateMessageCount : HsPhoneTraps.h
  • PhnLibTrapUsableSignalStrengthThreshold : HsPhoneTraps.h
  • PhnLibTrapVerifyICDVer : HsPhoneTraps.h
  • PhnLibTrapWriteIOTAItem : HsPhoneTraps.h
  • PhnLibUninstall() : HsPhoneLibrary.h
  • phnLibUnknownID : HsPhoneTypes.h
  • PhnLibUsableSignalStrengthThreshold() : HsPhoneNetwork.h
  • PhnLibWake() : HsPhoneLibrary.h
  • PhnLifeTimer : HsPhoneTypes.h
  • PhnLineStatePtr : HsPhoneMiscTypes.h
  • PhnLockMode : HsPhoneTypes.h
  • PhnLockModeEnum : HsPhoneTypes.h
  • phnMaxDialStrLen : HsPhoneCDMATypes.h
  • phnMaxMNAAASharedSecretLen : HsPhoneCDMATypes.h
  • phnMaxMNHASharedSecretLen : HsPhoneCDMATypes.h
  • phnMaxMslLen : HsPhoneCDMATypes.h
  • phnMaxNAILen : HsPhoneCDMATypes.h
  • phnMaxSvcStrLen : HsPhoneCDMATypes.h
  • phnMaxUrlLen : HsPhoneCDMATypes.h
  • phnMIPFaAdminProhibited : HsPhoneCDMATypes.h
  • phnMIPFaBadTtl : HsPhoneCDMATypes.h
  • phnMIPFaCantRevTun : HsPhoneCDMATypes.h
  • PhnMIPFADelvStyleUnsupported : HsPhoneCDMATypes.h
  • PhnMIPFAError1 : HsPhoneCDMATypes.h
  • PhnMIPFAError2 : HsPhoneCDMATypes.h
  • phnMIPFaForeign_Agent : HsPhoneCDMATypes.h
  • phnMIPFaHa_Host_Unreachable : HsPhoneCDMATypes.h
  • phnMIPFaHa_Port_Unreachable : HsPhoneCDMATypes.h
  • phnMIPFaHa_Unreachable : HsPhoneCDMATypes.h
  • phnMIPFaHome_Network_Unreachable : HsPhoneCDMATypes.h
  • phnMIPFaHomeAgentAuth : HsPhoneCDMATypes.h
  • PhnMIPFailType : HsPhoneCDMATypes.h
  • phnMIPFaInsufficientResources : HsPhoneCDMATypes.h
  • phnMIPFaInvalidCareOfAddr : HsPhoneCDMATypes.h
  • phnMIPFaMissing_Challenge : HsPhoneCDMATypes.h
  • PhnMIPFAMissingHomeAddr : HsPhoneCDMATypes.h
  • PhnMIPFAMissingNai : HsPhoneCDMATypes.h
  • phnMIPFaMobileNodeAuth : HsPhoneCDMATypes.h
  • phnMIPFaMustRevTun : HsPhoneCDMATypes.h
  • PhnMIPFANonzeroHomeAddrReq : HsPhoneCDMATypes.h
  • phnMIPFaPoorlyFormedReply : HsPhoneCDMATypes.h
  • phnMIPFaPoorlyFormedReq : HsPhoneCDMATypes.h
  • phnMIPFaReasonUnspecified : HsPhoneCDMATypes.h
  • phnMIPFaRegistration_Timeout : HsPhoneCDMATypes.h
  • phnMIPFaReqedEncapUnavail : HsPhoneCDMATypes.h
  • phnMIPFaReqLifetimeTooLong : HsPhoneCDMATypes.h
  • phnMIPFaReservedNUnavail : HsPhoneCDMATypes.h
  • phnMIPFaStale_Challenge : HsPhoneCDMATypes.h
  • phnMIPFaUnknown_Challenge : HsPhoneCDMATypes.h
  • phnMIPHaAdminProhibited : HsPhoneCDMATypes.h
  • phnMIPHaCantRevTun : HsPhoneCDMATypes.h
  • phnMIPHAError1 : HsPhoneCDMATypes.h
  • phnMIPHAError2 : HsPhoneCDMATypes.h
  • phnMIPHaForeignAgentAuth : HsPhoneCDMATypes.h
  • phnMIPHaInsufficientResources : HsPhoneCDMATypes.h
  • phnMIPHaMobileNodeAuth : HsPhoneCDMATypes.h
  • phnMIPHaMustRevTun : HsPhoneCDMATypes.h
  • phnMIPHaPoorlyFormedReq : HsPhoneCDMATypes.h
  • phnMIPHaReasonUnspecified : HsPhoneCDMATypes.h
  • phnMIPHaRegIdMismatch : HsPhoneCDMATypes.h
  • phnMIPHaReqEncapNotAvail : HsPhoneCDMATypes.h
  • phnMIPHaTooManySimMobBindings : HsPhoneCDMATypes.h
  • phnMIPHaUnknownHaAddr : HsPhoneCDMATypes.h
  • phnMIPNoSimBindings : HsPhoneCDMATypes.h
  • phnMIPSession : HsPhoneNetworkTypes.h
  • phnMIPSessionNone : HsPhoneNetworkTypes.h
  • PhnMIPSessionType : HsPhoneNetworkTypes.h
  • phnMIPSuccess : HsPhoneCDMATypes.h
  • PhnMiscDbgUpdateKind : HsPhoneEvent.h
  • PhnMMIActionCode : HsPhoneNetworkTypes.h
  • PhnMMIActionCodeEnum : HsPhoneNetworkTypes.h
  • PhnMMIEntryPtr : HsPhoneNetworkTypes.h
  • PhnMMIResultPtr : HsPhoneNetworkTypes.h
  • PhnMMIServiceCode : HsPhoneNetworkTypes.h
  • PhnMMIServiceCodeEnum : HsPhoneNetworkTypes.h
  • PhnModuleButtonType : HsPhoneEvent.h
  • PhnMsgBoxEnum : HsPhoneNetworkTypes.h
  • PhnMsgBoxPriorityEnum : HsPhoneNetworkTypes.h
  • PhnMsgBoxPriorityType : HsPhoneNetworkTypes.h
  • PhnMsgBoxType : HsPhoneNetworkTypes.h
  • PhnMsgBoxTypeMAX : HsPhoneNetworkTypes.h
  • PhnMsgIDType : HsPhoneEvent.h
  • phnNBSEvent : HsPhoneSMSTypes.h
  • phnNetPrefGPRSPDPContextID : HsPhoneGSMTypes.h
  • phnNotifyEquipMode : HsPhoneEvent.h
  • phnNotifySubscriber : HsPhoneEvent.h
  • PhnOneXDataFailType : HsPhoneCDMATypes.h
  • phnOneXFailModemSORej : HsPhoneCDMATypes.h
  • phnOneXFailNetworkBusy : HsPhoneCDMATypes.h
  • phnOneXFailNetworkSORej : HsPhoneCDMATypes.h
  • phnOneXFailNoSrv : HsPhoneCDMATypes.h
  • phnOneXFailPrev : HsPhoneCDMATypes.h
  • phnOneXFailUnknown : HsPhoneCDMATypes.h
  • PhnOnexMipRRQPtr : HsPhoneEvent.h
  • PhnOneXProtRevType : HsPhoneNetworkTypes.h
  • phnOneXStatusPRev1 : HsPhoneNetworkTypes.h
  • phnOneXStatusPRev3 : HsPhoneNetworkTypes.h
  • phnOneXStatusPRev4 : HsPhoneNetworkTypes.h
  • phnOneXStatusPRev6 : HsPhoneNetworkTypes.h
  • phnOneXStatusPRev7 : HsPhoneNetworkTypes.h
  • phnOneXStatusPRevNoSvc : HsPhoneNetworkTypes.h
  • phnOpAvailable : HsPhoneNetworkTypes.h
  • phnOpCurrent : HsPhoneNetworkTypes.h
  • PhnOpenDialogType : HsPhoneEvent.h
  • PhnOperatorID : HsPhoneTypes.h
  • PhnOperatorListPtr : HsPhoneNetworkTypes.h
  • PhnOperatorStatus : HsPhoneNetworkTypes.h
  • phnOpForbidden : HsPhoneNetworkTypes.h
  • phnOprtModeLPM : HsPhoneMiscTypes.h
  • phnOprtModeMax : HsPhoneMiscTypes.h
  • phnOprtModeNone : HsPhoneMiscTypes.h
  • phnOprtModeOffline : HsPhoneMiscTypes.h
  • phnOprtModeOfflineA : HsPhoneMiscTypes.h
  • phnOprtModeOnline : HsPhoneMiscTypes.h
  • phnOprtModePwroff : HsPhoneMiscTypes.h
  • phnOprtModeReset : HsPhoneMiscTypes.h
  • PhnOprtModeType : HsPhoneMiscTypes.h
  • phnOpUnknown : HsPhoneNetworkTypes.h
  • phnOtasp3GPDCommitFlag : HsPhoneCDMATypes.h
  • phnOtaspAkeyCommitFlag : HsPhoneCDMATypes.h
  • phnOtaspCommitFlag : HsPhoneCDMATypes.h
  • phnOtaspFTCCommitFlag : HsPhoneCDMATypes.h
  • phnOtaspIMSICommitFlag : HsPhoneCDMATypes.h
  • phnOtaspInitProgReqFlag : HsPhoneCDMATypes.h
  • phnOtaspMIPRetryCommitFlag : HsPhoneCDMATypes.h
  • phnOtaspMIPStatCommitFlag : HsPhoneCDMATypes.h
  • phnOtaspMobdirCommitFlag : HsPhoneCDMATypes.h
  • phnOtaspNamLockCommitFlag : HsPhoneCDMATypes.h
  • phnOtaspProgInProgressFlag : HsPhoneCDMATypes.h
  • phnOtaspRoamListCommitFlag : HsPhoneCDMATypes.h
  • phnOtaspSPCCommitFlag : HsPhoneCDMATypes.h
  • phnOtaspSPCFail : HsPhoneCDMATypes.h
  • phnOtaspSSDCommitFlag : HsPhoneCDMATypes.h
  • phnOtaspSuccessful : HsPhoneCDMATypes.h
  • phnOtaspUnsuccessful : HsPhoneCDMATypes.h
  • phnPacketDataCallActive : HsPhoneTypes.h
  • phnPacketDataCallDormant : HsPhoneTypes.h
  • phnPacketDataEndStatusAuthFailed : HsPhoneNetworkTypes.h
  • phnPacketDataEndStatusDropped : HsPhoneNetworkTypes.h
  • phnPacketDataEndStatusIntercept : HsPhoneNetworkTypes.h
  • phnPacketDataEndStatusLast : HsPhoneNetworkTypes.h
  • phnPacketDataEndStatusNoReason : HsPhoneNetworkTypes.h
  • phnPacketDataEndStatusNormal : HsPhoneNetworkTypes.h
  • phnPacketDataEndStatusReject : HsPhoneNetworkTypes.h
  • phnPacketDataEndStatusReorder : HsPhoneNetworkTypes.h
  • phnPacketDataEndStatusRetry : HsPhoneNetworkTypes.h
  • phnPacketDataEndStatusTimeout : HsPhoneNetworkTypes.h
  • PhnPacketDataEndStatusType : HsPhoneNetworkTypes.h
  • phnPacketDataEndStatusUnknown : HsPhoneNetworkTypes.h
  • phnPacketDataSessionActive : HsPhoneNetworkTypes.h
  • phnPacketDataSessionDormant : HsPhoneNetworkTypes.h
  • phnPacketDataSessionNone : HsPhoneNetworkTypes.h
  • PhnPacketDataSessionType : HsPhoneNetworkTypes.h
  • PhnPassword : HsPhoneEvent.h
  • phnPasswordBarrAB : HsPhoneSecurityTypes.h
  • phnPasswordBarrAC : HsPhoneSecurityTypes.h
  • phnPasswordBarrAG : HsPhoneSecurityTypes.h
  • phnPasswordBarrAI : HsPhoneSecurityTypes.h
  • phnPasswordBarrAO : HsPhoneSecurityTypes.h
  • phnPasswordBarrIR : HsPhoneSecurityTypes.h
  • phnPasswordBarrOI : HsPhoneSecurityTypes.h
  • phnPasswordBarrOX : HsPhoneSecurityTypes.h
  • phnPasswordCorporatePIN : HsPhoneSecurityTypes.h
  • phnPasswordCorporatePUK : HsPhoneSecurityTypes.h
  • phnPasswordNetworkPIN : HsPhoneSecurityTypes.h
  • phnPasswordNetworkPUK : HsPhoneSecurityTypes.h
  • phnPasswordNetworkSubsetPIN : HsPhoneSecurityTypes.h
  • phnPasswordNetworkSubsetPUK : HsPhoneSecurityTypes.h
  • phnPasswordNone : HsPhoneSecurityTypes.h
  • phnPasswordPh1SIMPIN : HsPhoneSecurityTypes.h
  • phnPasswordPh1SIMPUK : HsPhoneSecurityTypes.h
  • phnPasswordPhSIMPIN : HsPhoneSecurityTypes.h
  • phnPasswordServiceProviderPIN : HsPhoneSecurityTypes.h
  • phnPasswordServiceProviderPUK : HsPhoneSecurityTypes.h
  • phnPasswordSIMPIN : HsPhoneSecurityTypes.h
  • phnPasswordSIMPIN2 : HsPhoneSecurityTypes.h
  • phnPasswordSIMPUK : HsPhoneSecurityTypes.h
  • phnPasswordSIMPUK2 : HsPhoneSecurityTypes.h
  • PhnPasswordType : HsPhoneSecurityTypes.h
  • PhnPasswordTypeEnum : HsPhoneSecurityTypes.h
  • phnPasswordUnknown : HsPhoneSecurityTypes.h
  • PhnPDConfigGPSLock : hsPhoneLocationTypes.h
  • PhnPDConfigIPAddr : hsPhoneLocationTypes.h
  • PhnPDConfigPortID : hsPhoneLocationTypes.h
  • PhnPDConfigPTLMMode : hsPhoneLocationTypes.h
  • PhnPDDataPtr : HsPhoneCDMATypes.h
  • PhnPDPAUncert0_5_M : HsPhoneCDMATypes.h
  • PhnPDPAUncert0_75_M : HsPhoneCDMATypes.h
  • PhnPDPAUncert1024_M : HsPhoneCDMATypes.h
  • PhnPDPAUncert12288_M : HsPhoneCDMATypes.h
  • PhnPDPAUncert128_M : HsPhoneCDMATypes.h
  • PhnPDPAUncert12_M : HsPhoneCDMATypes.h
  • PhnPDPAUncert1536_M : HsPhoneCDMATypes.h
  • PhnPDPAUncert16_M : HsPhoneCDMATypes.h
  • PhnPDPAUncert192_M : HsPhoneCDMATypes.h
  • PhnPDPAUncert1_5_M : HsPhoneCDMATypes.h
  • PhnPDPAUncert1_M : HsPhoneCDMATypes.h
  • PhnPDPAUncert2048_M : HsPhoneCDMATypes.h
  • PhnPDPAUncert24_M : HsPhoneCDMATypes.h
  • PhnPDPAUncert256_M : HsPhoneCDMATypes.h
  • PhnPDPAUncert2_M : HsPhoneCDMATypes.h
  • PhnPDPAUncert3072_M : HsPhoneCDMATypes.h
  • PhnPDPAUncert32_M : HsPhoneCDMATypes.h
  • PhnPDPAUncert384_M : HsPhoneCDMATypes.h
  • PhnPDPAUncert3_M : HsPhoneCDMATypes.h
  • PhnPDPAUncert4096_M : HsPhoneCDMATypes.h
  • PhnPDPAUncert48_M : HsPhoneCDMATypes.h
  • PhnPDPAUncert4_M : HsPhoneCDMATypes.h
  • PhnPDPAUncert512_M : HsPhoneCDMATypes.h
  • PhnPDPAUncert6144_M : HsPhoneCDMATypes.h
  • PhnPDPAUncert64_M : HsPhoneCDMATypes.h
  • PhnPDPAUncert6_M : HsPhoneCDMATypes.h
  • PhnPDPAUncert768_M : HsPhoneCDMATypes.h
  • PhnPDPAUncert8192_M : HsPhoneCDMATypes.h
  • PhnPDPAUncert8_M : HsPhoneCDMATypes.h
  • PhnPDPAUncert96_M : HsPhoneCDMATypes.h
  • PhnPDPAUncertGREATER_12288_M : HsPhoneCDMATypes.h
  • PhnPDPAUncertMAX : HsPhoneCDMATypes.h
  • PhnPDPAUncertNOT_COMPUTABLE_M : HsPhoneCDMATypes.h
  • PhnPDPAUncerttype : HsPhoneCDMATypes.h
  • PhnPDPConnectionType : HsPhoneCDMATypes.h
  • phnPDPConnectionTypeInvalid : HsPhoneCDMATypes.h
  • phnPDPConnectionTypeMIP : HsPhoneCDMATypes.h
  • phnPDPConnectionTypeMIPWithSIPFallback : HsPhoneCDMATypes.h
  • phnPDPConnectionTypeSIP : HsPhoneCDMATypes.h
  • PhnPDPCopyAck : HsPhoneCDMATypes.h
  • phnPDPCopyDuplicateNAI : HsPhoneCDMATypes.h
  • phnPDPCopyFromIndexNotActive : HsPhoneCDMATypes.h
  • phnPDPCopyInternalModemErr : HsPhoneCDMATypes.h
  • phnPDPCopyInvalidAAALen : HsPhoneCDMATypes.h
  • phnPDPCopyInvalidFromIndex : HsPhoneCDMATypes.h
  • phnPDPCopyInvalidNAILen : HsPhoneCDMATypes.h
  • phnPDPCopyInvalidNAIName : HsPhoneCDMATypes.h
  • phnPDPCopyInvalidSvcStrLen : HsPhoneCDMATypes.h
  • phnPDPCopyInvalidToIndex : HsPhoneCDMATypes.h
  • phnPDPCopyNotAllowedAtFromIndex : HsPhoneCDMATypes.h
  • phnPDPCopyNotAllowedAtToIndex : HsPhoneCDMATypes.h
  • phnPDPCopyOK : HsPhoneCDMATypes.h
  • phnPDPCopyToIndexInUse : HsPhoneCDMATypes.h
  • phnPDPDefaultIndex : HsPhoneCDMATypes.h
  • PhnPDPDeleteAck : HsPhoneCDMATypes.h
  • phnPDPDeleteIndexActive : HsPhoneCDMATypes.h
  • phnPDPDeleteIndexNotUsed : HsPhoneCDMATypes.h
  • phnPDPDeleteInternalModemErr : HsPhoneCDMATypes.h
  • phnPDPDeleteInvalidIndex : HsPhoneCDMATypes.h
  • phnPDPDeleteNotAllowedAtIndex : HsPhoneCDMATypes.h
  • phnPDPDeleteOK : HsPhoneCDMATypes.h
  • phnPDPGenericIndex : HsPhoneCDMATypes.h
  • PhnPDPIndexType : HsPhoneCDMATypes.h
  • phnPDPInvalidHALen : HsPhoneCDMATypes.h
  • PhnPDPReadAck : HsPhoneCDMATypes.h
  • phnPDPReadIndexNotSet : HsPhoneCDMATypes.h
  • phnPDPReadInternalModemErr : HsPhoneCDMATypes.h
  • phnPDPReadInvalidIndex : HsPhoneCDMATypes.h
  • phnPDPReadNotAllowedAtIndex : HsPhoneCDMATypes.h
  • phnPDPReadOK : HsPhoneCDMATypes.h
  • PhnPDPReplaceAck : HsPhoneCDMATypes.h
  • phnPDPReplaceInternalModemErr : HsPhoneCDMATypes.h
  • phnPDPReplaceInvalidIndex : HsPhoneCDMATypes.h
  • phnPDPReplaceInvalidLen : HsPhoneCDMATypes.h
  • phnPDPReplaceInvalidNotUsed : HsPhoneCDMATypes.h
  • phnPDPReplaceNotAllowedAtIndex : HsPhoneCDMATypes.h
  • phnPDPReplaceOK : HsPhoneCDMATypes.h
  • PhnPDPService : HsPhoneCDMATypes.h
  • phnPDPServiceBrowser : HsPhoneCDMATypes.h
  • phnPDPServiceCorporateGateway : HsPhoneCDMATypes.h
  • phnPDPServiceDownloads : HsPhoneCDMATypes.h
  • phnPDPServiceIM : HsPhoneCDMATypes.h
  • phnPDPServiceInternet : HsPhoneCDMATypes.h
  • phnPDPServiceMail : HsPhoneCDMATypes.h
  • phnPDPServiceMMS : HsPhoneCDMATypes.h
  • phnPDPServicePictureMail : HsPhoneCDMATypes.h
  • phnPDPServicePrivate : HsPhoneCDMATypes.h
  • phnPDPServiceUnknown : HsPhoneCDMATypes.h
  • phnPDPServiceWAP : HsPhoneCDMATypes.h
  • phnPDPTempIndex : HsPhoneCDMATypes.h
  • phnPDPUidLen : HsPhoneCDMATypes.h
  • PhnPDPWriteAck : HsPhoneCDMATypes.h
  • phnPDPWriteDuplicateNAI : HsPhoneCDMATypes.h
  • phnPDPWriteIndexInUse : HsPhoneCDMATypes.h
  • phnPDPWriteIndexNotPrevSet : HsPhoneCDMATypes.h
  • phnPDPWriteInternalModemErr : HsPhoneCDMATypes.h
  • phnPDPWriteInvalidAAALen : HsPhoneCDMATypes.h
  • phnPDPWriteInvalidDialStrLen : HsPhoneCDMATypes.h
  • phnPDPWriteInvalidIndex : HsPhoneCDMATypes.h
  • phnPDPWriteInvalidNAILen : HsPhoneCDMATypes.h
  • phnPDPWriteInvalidNAIName : HsPhoneCDMATypes.h
  • phnPDPWriteInvalidSvcStrLen : HsPhoneCDMATypes.h
  • phnPDPWriteNotAllowedAtIndex : HsPhoneCDMATypes.h
  • phnPDPWriteOK : HsPhoneCDMATypes.h
  • PhnPDSessionConfigParamType : hsPhoneLocationTypes.h
  • PhnPhoneBookInfoPtr : HsPhoneGSMTypes.h
  • phnPowerLow : HsPhoneTypes.h
  • phnPowerOff : HsPhoneTypes.h
  • phnPowerOn : HsPhoneTypes.h
  • phnPowerSave : HsPhoneTypes.h
  • phnPowerStartCharging : HsPhoneTypes.h
  • phnPowerStopCharging : HsPhoneTypes.h
  • PhnPowerType : HsPhoneTypes.h
  • PhnProgressType : HsPhoneEvent.h
  • PhnRadioStatePtr : HsPhoneMiscTypes.h
  • PhnRegistrationStatus : HsPhoneNetworkTypes.h
  • PhnRingingInfoPtr : HsPhoneAudioTypes.h
  • PhnRoamIconFlash : HsPhoneNetworkTypes.h
  • PhnRoamIconOff : HsPhoneNetworkTypes.h
  • PhnRoamIconOn : HsPhoneNetworkTypes.h
  • PhnRoamIconState : HsPhoneNetworkTypes.h
  • phnRoamPrefAny : HsPhoneNetworkTypes.h
  • phnRoamPrefHomeOnly : HsPhoneNetworkTypes.h
  • PhnRoamPrefInfoPtr : HsPhoneNetworkTypes.h
  • phnRoamPrefLast : HsPhoneNetworkTypes.h
  • phnRoamPrefRoamOnly : HsPhoneNetworkTypes.h
  • PhnRoamPrefSelectionType : HsPhoneNetworkTypes.h
  • PhnRoamStatus : HsPhoneNetworkTypes.h
  • PhnRoamStatusBlink : HsPhoneNetworkTypes.h
  • PhnRoamStatusEnhancedIndicator : HsPhoneNetworkTypes.h
  • PhnRoamStatusEnum : HsPhoneNetworkTypes.h
  • PhnRoamStatusOff : HsPhoneNetworkTypes.h
  • PhnRoamStatusOn : HsPhoneNetworkTypes.h
  • phnSATEventDataSvcTypeCloseChannel : HsPhoneGSMTypes.h
  • phnSATEventDataSvcTypeOpenChannel : HsPhoneGSMTypes.h
  • phnSATEventDataSvcTypeRcvData : HsPhoneGSMTypes.h
  • phnSATEventDataSvcTypeSendData : HsPhoneGSMTypes.h
  • PhnSATEventHeader : HsPhoneEvent.h
  • phnSATEventInputEchoModeHideInput : HsPhoneGSMTypes.h
  • phnSATEventInputEchoModeShowInput : HsPhoneGSMTypes.h
  • phnSATEventInputFormatDigit : HsPhoneGSMTypes.h
  • phnSATEventInputFormatPacked : HsPhoneGSMTypes.h
  • phnSATEventInputFormatSMSChar : HsPhoneGSMTypes.h
  • phnSATEventInputFormatUCS2 : HsPhoneGSMTypes.h
  • phnSATEventInputFormatUnknown : HsPhoneGSMTypes.h
  • phnSATEventInputFormatUnpacked : HsPhoneGSMTypes.h
  • phnSATEventInputFormatYesNo : HsPhoneGSMTypes.h
  • phnSATEventMenuFlagHelp : HsPhoneGSMTypes.h
  • phnSATEventMenuFlagNextAct : HsPhoneGSMTypes.h
  • phnSATEventSetupCallCallTypeData : HsPhoneGSMTypes.h
  • phnSATEventSetupCallCallTypeFax : HsPhoneGSMTypes.h
  • phnSATEventSetupCallCallTypeVoice : HsPhoneGSMTypes.h
  • phnSATEventToneTimeUnitDeciSeconds : HsPhoneGSMTypes.h
  • phnSATEventToneTimeUnitMinutes : HsPhoneGSMTypes.h
  • phnSATEventToneTimeUnitSeconds : HsPhoneGSMTypes.h
  • phnSATEventToneTypeBusy : HsPhoneGSMTypes.h
  • phnSATEventToneTypeCallWaiting : HsPhoneGSMTypes.h
  • phnSATEventToneTypeCongestion : HsPhoneGSMTypes.h
  • phnSATEventToneTypeDial : HsPhoneGSMTypes.h
  • phnSATEventToneTypeDropped : HsPhoneGSMTypes.h
  • phnSATEventToneTypeError : HsPhoneGSMTypes.h
  • phnSATEventToneTypeGeneralBeep : HsPhoneGSMTypes.h
  • phnSATEventToneTypeNegativeBeep : HsPhoneGSMTypes.h
  • phnSATEventToneTypeNoneSpecified : HsPhoneGSMTypes.h
  • phnSATEventToneTypePositiveBeep : HsPhoneGSMTypes.h
  • phnSATEventToneTypeRadioAck : HsPhoneGSMTypes.h
  • phnSATEventToneTypeRinging : HsPhoneGSMTypes.h
  • phnSATInkeyResponseValueNo : HsPhoneGSMTypes.h
  • phnSATInkeyResponseValueYes : HsPhoneGSMTypes.h
  • phnServiceActivation : HsPhoneTypes.h
  • phnServiceAFLT : HsPhoneTypes.h
  • phnServiceAll : HsPhoneTypes.h
  • phnServiceData : HsPhoneTypes.h
  • phnServiceEssentials : HsPhoneTypes.h
  • phnServiceIOTA : HsPhoneTypes.h
  • phnServiceMax : HsPhoneTypes.h
  • phnServiceMisc : HsPhoneTypes.h
  • phnServiceMMS : HsPhoneTypes.h
  • phnServiceSIMToolkit : HsPhoneTypes.h
  • phnServiceSMS : HsPhoneTypes.h
  • phnServiceVoice : HsPhoneTypes.h
  • phnServiceWAP : HsPhoneTypes.h
  • PhnSMSClass : HsPhoneEvent.h
  • PhnSMSClassEnum : HsPhoneEvent.h
  • phnSMSEncodingASCII : HsPhoneCDMATypes.h
  • phnSMSEncodingGSM : HsPhoneCDMATypes.h
  • phnSMSEncodingISO8859_1 : HsPhoneCDMATypes.h
  • PhnSMSParamsVersion : HsPhoneEvent.h
  • PhnSMSPrefPtr : HsPhoneSMSTypes.h
  • PhnSMSType : HsPhoneEvent.h
  • PhnSMSTypeEnum : HsPhoneEvent.h
  • phnSpeakerPhoneMode : HsPhoneMiscTypes.h
  • phnSysPrefAOnly : HsPhoneCDMATypes.h
  • phnSysPrefBOnly : HsPhoneCDMATypes.h
  • phnSysPrefHomeOnly : HsPhoneCDMATypes.h
  • PhnSysPrefSetting : HsPhoneCDMATypes.h
  • phnSysPrefStandard : HsPhoneCDMATypes.h
  • phnTeleserviceAllExceptSMSCode : HsPhoneNetworkTypes.h
  • phnTeleserviceAllMmiCode : HsPhoneNetworkTypes.h
  • phnTeleserviceData : HsPhoneNetworkTypes.h
  • phnTeleserviceDataCircAsync : HsPhoneNetworkTypes.h
  • phnTeleserviceDataCircAsyncMmiCode : HsPhoneNetworkTypes.h
  • phnTeleserviceDataCircSync : HsPhoneNetworkTypes.h
  • phnTeleserviceDataCircSyncMmiCode : HsPhoneNetworkTypes.h
  • phnTeleserviceDedicatedPack : HsPhoneNetworkTypes.h
  • phnTeleserviceDedicatedPackMmiCode : HsPhoneNetworkTypes.h
  • phnTeleserviceDedicatedPAD : HsPhoneNetworkTypes.h
  • phnTeleserviceDedicatedPADMmiCode : HsPhoneNetworkTypes.h
  • phnTeleserviceDefault : HsPhoneNetworkTypes.h
  • phnTeleserviceFax : HsPhoneNetworkTypes.h
  • phnTeleserviceFaxMmiCode : HsPhoneNetworkTypes.h
  • PhnTeleserviceMmiCodeType : HsPhoneNetworkTypes.h
  • phnTeleserviceSMS : HsPhoneNetworkTypes.h
  • phnTeleserviceSMSMmiCode : HsPhoneNetworkTypes.h
  • PhnTeleserviceType : HsPhoneNetworkTypes.h
  • phnTeleserviceUnknown : HsPhoneNetworkTypes.h
  • phnTeleserviceUnknownMmiCode : HsPhoneNetworkTypes.h
  • phnTeleserviceVoice : HsPhoneNetworkTypes.h
  • phnTeleserviceVoiceMmiCode : HsPhoneNetworkTypes.h
  • PhnTTYSetting : HsPhoneAudioTypes.h
  • phnTTYSettingAll : HsPhoneAudioTypes.h
  • phnTTYSettingHearCarryOver : HsPhoneAudioTypes.h
  • phnTTYSettingOff : HsPhoneAudioTypes.h
  • phnTTYSettingVoiceCarryOver : HsPhoneAudioTypes.h
  • phnUPEvent : HsPhoneEvent.h
  • phnUserDataMax : HsPhoneEvent.h
  • phnVibrateOff : HsPhoneMiscTypes.h
  • phnVibrateOn : HsPhoneMiscTypes.h
  • PhnVibrateType : HsPhoneMiscTypes.h
  • phnVoiceCall1Active : HsPhoneTypes.h
  • phnVoiceCall2Active : HsPhoneTypes.h
  • phnVolumeMax : HsPhoneTypes.h
  • phnVolumeMin : HsPhoneTypes.h
  • phnWAPEvent : HsPhoneEvent.h
  • PhnWAPPushAppId : HsPhoneEvent.h
  • PhnWAPPushAppIdType : HsPhoneEvent.h
  • PhnWAPPushContent : HsPhoneEvent.h
  • PhnWAPPushContentType : HsPhoneEvent.h
  • phnWUEvent : HsPhoneEvent.h
  • PhoneAppDialMethodEnum : HsAppLaunchCmd.h
  • PhoneAppDialMethodNormal : HsAppLaunchCmd.h
  • PhoneAppDialMethodSATSetupCall : HsAppLaunchCmd.h
  • PhoneAppDialMethodSATSetupCallDisconnectOtherCalls : HsAppLaunchCmd.h
  • PhoneAppDialMethodSATSetupCallHoldOtherCalls : HsAppLaunchCmd.h
  • PhoneAppDialMethodSATSetupCallModeNotBusy : HsAppLaunchCmd.h
  • PhoneAppDialMethodSATSetupCallWithRedialDisconnectOtherCalls : HsAppLaunchCmd.h
  • PhoneAppDialMethodSATSetupCallWithRedialHoldOtherCalls : HsAppLaunchCmd.h
  • PhoneAppDialMethodSATSetupCallWithRedialModeNotBusy : HsAppLaunchCmd.h
  • phoneAppLaunchCmdActivation : HsAppLaunchCmd.h
  • phoneAppLaunchCmdBluetoothDial : HsAppLaunchCmd.h
  • phoneAppLaunchCmdBluetoothDialVoiceMail : HsAppLaunchCmd.h
  • phoneAppLaunchCmdCallerIDLookup : HsAppLaunchCmd.h
  • PhoneAppLaunchCmdCallerIDLookupPtr : HsAppLaunchCmd.h
  • phoneAppLaunchCmdDial : HsAppLaunchCmd.h
  • PhoneAppLaunchCmdDialPtr : HsAppLaunchCmd.h
  • phoneAppLaunchCmdDialSTKSETUPCALL : HsAppLaunchCmd.h
  • phoneAppLaunchCmdDialVoiceMail : HsAppLaunchCmd.h
  • phoneAppLaunchCmdDisplayDialPrefs : HsAppLaunchCmd.h
  • phoneAppLaunchCmdGetALSLineNumber : HsAppLaunchCmd.h
  • PhoneAppLaunchCmdGetALSLineNumberTypePtr : HsAppLaunchCmd.h
  • phoneAppLaunchCmdGetDialPrefFlag : HsAppLaunchCmd.h
  • PhoneAppLaunchCmdGetDialPrefFlagPtr : HsAppLaunchCmd.h
  • phoneAppLaunchCmdGetUSDialingRules : HsAppLaunchCmd.h
  • phoneAppLaunchCmdNetworkSearch : HsAppLaunchCmd.h
  • phoneAppLaunchCmdPowerOn : HsAppLaunchCmd.h
  • phoneAppLaunchCmdRedial : HsAppLaunchCmd.h
  • phoneAppLaunchCmdRegisterAllViews : HsAppLaunchCmd.h
  • phoneAppLaunchCmdSendDTMFTone : HsAppLaunchCmd.h
  • PhoneAppLaunchCmdSendDTMFTonePtr : HsAppLaunchCmd.h
  • phoneAppLaunchCmdSetWallpaper : HsAppLaunchCmd.h
  • PhoneAppLaunchCmdSetWallpaperPtr : HsAppLaunchCmd.h
  • phoneAppLaunchCmdStartNetInitUSSD : HsAppLaunchCmd.h
  • phoneAppLaunchCmdViewCalls : HsAppLaunchCmd.h
  • phoneAppLaunchCmdViewHistory : HsAppLaunchCmd.h
  • phoneAppLaunchCmdViewKeypad : HsAppLaunchCmd.h
  • phoneAppLaunchCmdViewMissedCalls : HsAppLaunchCmd.h
  • phoneAppLaunchCmdViewPhoneHome : HsAppLaunchCmd.h
  • phoneAppLaunchCmdViewSpeed : HsAppLaunchCmd.h
  • phoneAppLaunchOptionsMenu : HsAppLaunchCmd.h
  • PhoneServiceClassType : HsPhoneTypes.h
  • Pi11BitMap : SmartTextEngineRsc.h
  • Pi14BitMap : SmartTextEngineRsc.h
  • pinClassic : PalmPin.h
  • pinErrInvalidInputMode : PalmPin.h
  • pinErrInvalidState : PalmPin.h
  • pinErrorClass : PalmPin.h
  • pinErrUnknownID : PalmPin.h
  • pinFtrNumVersion : PalmPin.h
  • PinGetCurrentPinletID() : PalmPin.h
  • PinGetInputAreaState() : PalmPin.h
  • PinGetInputMode() : PalmPin.h
  • pinInputAreaFullScreen : PalmPin.h
  • pinInputAreaHide : PalmPin.h
  • pinInputAreaLegacyMode : PalmPin.h
  • pinInputAreaNone : PalmPin.h
  • pinInputAreaShow : PalmPin.h
  • pinInputModeCapsLock : PalmPin.h
  • pinInputModeExtended : PalmPin.h
  • pinInputModeHiragana : PalmPin.h
  • pinInputModeKatakana : PalmPin.h
  • pinInputModeNormal : PalmPin.h
  • pinInputModeNumeric : PalmPin.h
  • pinInputModePunctuation : PalmPin.h
  • pinInputModeShift : PalmPin.h
  • pinletStdKbIntl : PalmPin.h
  • pinletStdKbNum : PalmPin.h
  • PinLibClose() : PalmPin.h
  • pinLibCreator : PalmPin.h
  • pinLibName : PalmPin.h
  • PinLibOpen() : PalmPin.h
  • pinLibType : PalmPin.h
  • PinResetInputState() : PalmPin.h
  • PinSetInputAreaState() : PalmPin.h
  • PinSetInputMode() : PalmPin.h
  • pinStdKeyboard : PalmPin.h
  • PinSwitchToPinlet() : PalmPin.h
  • pinTriCell : PalmPin.h
  • plainOnly : VMFontLibCommon.h
  • plugin_allInfo : PalmVMPlugin.h
  • plugin_receiveInfo : PalmVMPlugin.h
  • plugin_sendInfo : PalmVMPlugin.h
  • pluginExtendedQueryParams : PalmVMPlugin.h
  • pluginGetInfoParams : PalmVMPlugin.h
  • PluginInfo : PalmVMPlugin.h
  • pluginParams : PalmVMPlugin.h
  • pluginQueryParams : PalmVMPlugin.h
  • pluginSendParams : PalmVMPlugin.h
  • PM_AUDIOGROUP_MASK : PmSoundLibAudioGroup.h
  • PM_AUDP : HsSoundLibCommon.h
  • PM_AUDP_CLASS : HsSoundLibCommon.h
  • PM_AUDP_CLASS_MASK : HsSoundLibCommon.h
  • pmAudioClkTickRef : HsSoundLibCommon.h
  • PmAudioGroup : PmSoundLibAudioGroup.h
  • pmAudioGroupAlert : PmSoundLibAudioGroup.h
  • pmAudioGroupAlertRingOff : PmSoundLibAudioGroup.h
  • pmAudioGroupApp : PmSoundLibAudioGroup.h
  • pmAudioGroupCall : PmSoundLibAudioGroup.h
  • PmAudioGroupEnum : PmSoundLibAudioGroup.h
  • pmAudioGroupHighPriority : PmSoundLibAudioGroup.h
  • pmAudioGroupInteractive : PmSoundLibAudioGroup.h
  • pmAudioGroupNone : PmSoundLibAudioGroup.h
  • pmAudioGroupStreaming : PmSoundLibAudioGroup.h
  • pmAudioGroupSystem : PmSoundLibAudioGroup.h
  • PmBroadcastNewMsgCountNotifyParamPtr : HsHelper.h
  • PmClkTickRef : HsSoundLibCommon.h
  • PMCONNECTOR_LIB_TRAP : PmConnectorLib.h
  • PmConnectorAudioInputSettingType : PmConnectorLibCommon.h
  • PmConnectorAudioOutputSettingType : PmConnectorLibCommon.h
  • PmConnectorLibClose() : PmConnectorLib.h
  • PmConnectorLibControl() : PmConnectorLib.h
  • PmConnectorLibControlType : PmConnectorLibCommon.h
  • PmConnectorLibGetVersion() : PmConnectorLib.h
  • PmConnectorLibOpen() : PmConnectorLib.h
  • PmConnectorLibSetAudioInput() : PmConnectorLib.h
  • PmConnectorLibSetAudioOutput() : PmConnectorLib.h
  • PmConnectorLibSleep() : PmConnectorLib.h
  • PmConnectorLibWake() : PmConnectorLib.h
  • PmConnectorStateType : PmConnectorLibCommon.h
  • pmDebugLockoutToken : HsCreators.h
  • pmErrNotSupported : PmLibErrors.h
  • pmFileCKeyLib : HsCreators.h
  • pmFileCSysGadgetLib : HsCreators.h
  • pmFileCSystemLib : HsCreators.h
  • pmFileCUIUtilLib : HsCreators.h
  • PmGetNewMsgCountNotifyParamPtr : HsHelper.h
  • pmKbdLayoutToken : HsCreators.h
  • PmKeyAttrEnum : PmKeyLibCommon.h
  • PmKeyAttrEnumTag : PmKeyLibCommon.h
  • PmKeyAttrGet() : PmKeyLib.h
  • pmKeyAttrGetEndKeyCode : PmKeyLibCommon.h
  • pmKeyAttrGetLauncherKeyCode : PmKeyLibCommon.h
  • pmKeyAttrGetMenuKeyCode : PmKeyLibCommon.h
  • pmKeyAttrGetPhoneKeyCode : PmKeyLibCommon.h
  • pmKeyAttrGetSendKeyCode : PmKeyLibCommon.h
  • pmKeyAttrPagingMode : PmKeyLibCommon.h
  • PmKeyAttrSet() : PmKeyLib.h
  • PmKeyChrCodeToKeyCode() : PmKeyLib.h
  • PmKeyEnableKey() : PmKeyLib.h
  • PmKeyEventIsFromKeyboard() : PmKeyLib.h
  • PmKeyKeyCodeToChrCode() : PmKeyLib.h
  • PmKeyKeysPressed() : PmKeyLib.h
  • PmKeyLibClose() : PmKeyLib.h
  • PmKeyLibOpen() : PmKeyLib.h
  • PmKeyStop() : PmKeyLib.h
  • pmLibErrorClass : HsErrorClasses.h
  • pmLimitLocaleToken : HsCreators.h
  • pmNotifyBrightModeKeyEvent : HsCreators.h
  • pmNotifyBroadcastNewMsgCount : HsCreators.h
  • pmNotifyGetNewMsgCountFromHelper : HsCreators.h
  • pmNotifyHighPriorityAudioTask : HsAppLaunchCmd.h
  • pmNotifyHighPriorityUITask : HsAppLaunchCmd.h
  • pmNotifyTraceSettingsChangedEvent : HsCreators.h
  • PMP_LIB_TRAP : palmOnePhotoCommon.h
  • pmPhoneAppNotifyHomeAppEvent : HsAppLaunchCmd.h
  • pmPhoneAppNotifySetWallpaper : HsAppLaunchCmd.h
  • pmROMTokenRead : HsCreators.h
  • pmROMTokenWrite : HsCreators.h
  • pmSlotDriverActivityIndicator : HsCreators.h
  • PmSndAddAudioGroupToVolume : PmSoundLibAudioGroup.h
  • pmSndAttackEnvIDRings : HsSoundLibCommon.h
  • pmSndAttackEnvIDRings2 : HsSoundLibCommon.h
  • pmSndAttackEnvIDVibeRing : HsSoundLibCommon.h
  • pmSndAttackEnvIDVibeRing2 : HsSoundLibCommon.h
  • pmSndBayID_AUDP : HsSoundLibCommon.h
  • PmSndClkGetTickCount() : HsSoundLib.h
  • PmSndClkGetTicksPerSecond() : HsSoundLib.h
  • pmSndFormatPauseStream : HsSoundLibCommon.h
  • pmSndFormatResumeStream : HsSoundLibCommon.h
  • pmSndFormatSetAttackEnvID : HsSoundLibCommon.h
  • pmSndFormatSetStoppable : HsSoundLibCommon.h
  • PmSndGetAudioGroupFromVolume : PmSoundLibAudioGroup.h
  • PmSndGetPosition() : HsSoundLib.h
  • PmSndGetPreference : HsSoundLib.h
  • pmSndPref_AthenaActive_No : HsSoundLibCommon.h
  • pmSndPref_AthenaActive_Yes : HsSoundLibCommon.h
  • pmSndPref_AthenaAudio_IfMicPresent : HsSoundLibCommon.h
  • pmSndPref_AthenaAudio_NoRouting : HsSoundLibCommon.h
  • pmSndPref_AthenaAudio_Unconditional : HsSoundLibCommon.h
  • pmSndPref_WakeOnAnswerBtn_Disable : HsSoundLibCommon.h
  • pmSndPref_WakeOnAnswerBtn_Enable : HsSoundLibCommon.h
  • PmSndPrefID : HsSoundLibCommon.h
  • pmSndPrefID_AGCEvent : HsSoundLibCommon.h
  • pmSndPrefID_AppsGroupHoldType : HsSoundLibCommon.h
  • pmSndPrefID_AthenaActive : HsSoundLibCommon.h
  • pmSndPrefID_AthenaAudio : HsSoundLibCommon.h
  • pmSndPrefID_AudioTable : HsSoundLibCommon.h
  • pmSndPrefID_GsmMccArray : HsSoundLibCommon.h
  • pmSndPrefID_JackOutIfMicUnused : HsSoundLibCommon.h
  • pmSndPrefID_PhoneRxGainLimit : HsSoundLibCommon.h
  • pmSndPrefID_SleepMode : HsSoundLibCommon.h
  • pmSndPrefID_WakeOnAnswerBtn : HsSoundLibCommon.h
  • PmSndRemoveAudioGroupFromVolume : PmSoundLibAudioGroup.h
  • PmSndSetPreference : HsSoundLib.h
  • PmSndStreamPause : HsSoundLib.h
  • PmSndStreamResume : HsSoundLib.h
  • PmSndStreamSetAttackEnvID : HsSoundLib.h
  • PmSndStreamStoppable : HsSoundLib.h
  • pmSndSwitchID_Preferences : HsSoundLibCommon.h
  • PmSndU64 : HsSoundLibCommon.h
  • pmSoundLibAudioGroupFtr : PmSoundLibAudioGroup.h
  • pmSoundLibAudioGroupFtr_Off : PmSoundLibAudioGroup.h
  • pmSoundLibAudioGroupFtr_On : PmSoundLibAudioGroup.h
  • pmSoundLibCreatorID : PmSoundLibAudioGroup.h
  • PmSysGadgetBbutHitBigButton() : PmSysGadgetLib.h
  • PmSysGadgetBbutInstallFromResource() : PmSysGadgetLib.h
  • PmSysGadgetBbutInstallNewButton() : PmSysGadgetLib.h
  • PmSysGadgetBbutSetBitmap() : PmSysGadgetLib.h
  • PmSysGadgetBbutSetLabel() : PmSysGadgetLib.h
  • PmSysGadgetBtStatusTypeEnum : PmSysGadgetLibCommon.h
  • PmSysGadgetLibClose() : PmSysGadgetLib.h
  • PmSysGadgetLibOpen() : PmSysGadgetLib.h
  • pmSysGadgetStatusGadgetBattery : PmSysGadgetLibCommon.h
  • pmSysGadgetStatusGadgetBt : PmSysGadgetLibCommon.h
  • pmSysGadgetStatusGadgetCallFwd : PmSysGadgetLibCommon.h
  • pmSysGadgetStatusGadgetEvdo : PmSysGadgetLibCommon.h
  • pmSysGadgetStatusGadgetLine : PmSysGadgetLibCommon.h
  • pmSysGadgetStatusGadgetNone : PmSysGadgetLibCommon.h
  • pmSysGadgetStatusGadgetOperator : PmSysGadgetLibCommon.h
  • pmSysGadgetStatusGadgetPhoneCall : PmSysGadgetLibCommon.h
  • pmSysGadgetStatusGadgetPtt : PmSysGadgetLibCommon.h
  • pmSysGadgetStatusGadgetRoaming : PmSysGadgetLibCommon.h
  • pmSysGadgetStatusGadgetSignal : PmSysGadgetLibCommon.h
  • PmSysGadgetStatusGadgetsUpdate() : PmSysGadgetLib.h
  • pmSysGadgetStatusGadgetTty : PmSysGadgetLibCommon.h
  • PmSysGadgetStatusGadgetTypeEnum : PmSysGadgetLibCommon.h
  • PmSysGadgetStatusGadgetTypeSet() : PmSysGadgetLib.h
  • pmSysGadgetStatusGadgetVm : PmSysGadgetLibCommon.h
  • pmTSCalToken : HsCreators.h
  • pmTSTokenValidToken : HsCreators.h
  • pmUIUtilAttrAutoSnoozeAttns : PmUIUtilLibCommon.h
  • PmUIUtilAttrEnum : PmUIUtilLibCommon.h
  • PmUIUtilAttrEnumTag : PmUIUtilLibCommon.h
  • PmUIUtilAttrGet() : PmUIUtilLib.h
  • PmUIUtilAttrSet() : PmUIUtilLib.h
  • PmUIUtilLibClose() : PmUIUtilLib.h
  • PmUIUtilLibOpen() : PmUIUtilLib.h
  • PmUIUtilLstGetTempSelection() : PmUIUtilLib.h
  • PmUIUtilLstSetTempSelection() : PmUIUtilLib.h
  • PmUIUtilNavGetFocusColor() : PmUIUtilLib.h
  • PmUIUtilNavSetFocusColor() : PmUIUtilLib.h
  • pmUsbFtrCreator : palmOneFeatures.h
  • pmUsbFtrVersion : palmOneFeatures.h
  • PRIORITY_LIST_SIZE : PalmNetServices.h
  • PrvPhnLibTrapCheckPowerSync : HsPhoneTraps.h
  • Psi11BitMap : SmartTextEngineRsc.h
  • Psi14BitMap : SmartTextEngineRsc.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:38 2008 for Palm API Guide


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- r -

  • registrationDenied : HsPhoneNetworkTypes.h
  • registrationHome : HsPhoneNetworkTypes.h
  • registrationNone : HsPhoneNetworkTypes.h
  • registrationRoaming : HsPhoneNetworkTypes.h
  • registrationSearch : HsPhoneNetworkTypes.h
  • registrationUnknown : HsPhoneNetworkTypes.h
  • replaceType1 : HsPhoneEvent.h
  • replaceType2 : HsPhoneEvent.h
  • replaceType3 : HsPhoneEvent.h
  • replaceType4 : HsPhoneEvent.h
  • replaceType5 : HsPhoneEvent.h
  • replaceType6 : HsPhoneEvent.h
  • replaceType7 : HsPhoneEvent.h
  • Reserved2 : HsPhoneTraps.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:38 2008 for Palm API Guide


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- s -

  • sabon : VMFontLibCommon.h
  • SATDecisionType : HsPhoneGSMTypes.h
  • SATNotificationType : HsPhoneGSMTypes.h
  • SATRefreshFile : HsPhoneGSMTypes.h
  • SATRefreshType : HsPhoneGSMTypes.h
  • SATRequestType : HsPhoneGSMTypes.h
  • SATSetupCallType : HsPhoneGSMTypes.h
  • screenFtrCreator : palmOneFeatures.h
  • SecurityModeLast : PalmWiFiCommon.h
  • SecurityModeOpenSystem : PalmWiFiCommon.h
  • SecurityModeType : PalmWiFiCommon.h
  • SecurityModeWEP : PalmWiFiCommon.h
  • SecurityModeWPAPSK : PalmWiFiCommon.h
  • SessionMode : Contacts.h
  • SetFontUIRules() : palmOneVMFontLib.h
  • ShlCreatorID : PalmNetServices.h
  • ShlLibName : PalmNetServices.h
  • ShlLibType : PalmNetServices.h
  • SHORT_PREAMBLE : PalmWiFiCommon.h
  • Sigma11BitMap : SmartTextEngineRsc.h
  • Sigma14BitMap : SmartTextEngineRsc.h
  • simFailure : HsPhoneTypes.h
  • simMissing : HsPhoneTypes.h
  • simNotReady : HsPhoneTypes.h
  • simPresent : HsPhoneTypes.h
  • simReady : HsPhoneTypes.h
  • simUnknown : HsPhoneTypes.h
  • simWrong : HsPhoneTypes.h
  • size12 : VMFontLibCommon.h
  • size6 : VMFontLibCommon.h
  • size9 : VMFontLibCommon.h
  • SLIDER_PREF_CHANGED_NOTIFY_TYPE : Slider.h
  • smallFonts : VMFontLibCommon.h
  • Smiley00BitMap : SmartTextEngineRsc.h
  • Smiley01BitMap : SmartTextEngineRsc.h
  • Smiley02BitMap : SmartTextEngineRsc.h
  • Smiley03BitMap : SmartTextEngineRsc.h
  • Smiley04BitMap : SmartTextEngineRsc.h
  • Smiley05BitMap : SmartTextEngineRsc.h
  • Smiley06BitMap : SmartTextEngineRsc.h
  • Smiley07BitMap : SmartTextEngineRsc.h
  • Smiley08BitMap : SmartTextEngineRsc.h
  • Smiley09BitMap : SmartTextEngineRsc.h
  • Smiley10BitMap : SmartTextEngineRsc.h
  • Smiley11BitMap : SmartTextEngineRsc.h
  • Smiley12BitMap : SmartTextEngineRsc.h
  • Smiley13BitMap : SmartTextEngineRsc.h
  • Smiley14BitMap : SmartTextEngineRsc.h
  • Smiley15BitMap : SmartTextEngineRsc.h
  • Smiley16BitMap : SmartTextEngineRsc.h
  • Smiley17BitMap : SmartTextEngineRsc.h
  • Smiley18BitMap : SmartTextEngineRsc.h
  • Smiley19BitMap : SmartTextEngineRsc.h
  • Smiley20BitMap : SmartTextEngineRsc.h
  • Smiley21BitMap : SmartTextEngineRsc.h
  • Smiley22BitMap : SmartTextEngineRsc.h
  • Smiley23BitMap : SmartTextEngineRsc.h
  • SmileyBitMapBaseID : SmartTextEngineRsc.h
  • SMSAddressFormat : HsPhoneSMSTypes.h
  • SmsCauseAddressTranslationFailure : HsPhoneSMSTypes.h
  • SmsCauseAddressVacant : HsPhoneSMSTypes.h
  • SmsCauseCode : HsPhoneSMSTypes.h
  • SmsCauseDestinationBusy : HsPhoneSMSTypes.h
  • SmsCauseDestinationNoLongerAtThisAddress : HsPhoneSMSTypes.h
  • SmsCauseDestinationOutOfService : HsPhoneSMSTypes.h
  • SmsCauseDestinationResourceShortage : HsPhoneSMSTypes.h
  • SmsCauseInvalidTeleserviceId : HsPhoneSMSTypes.h
  • SmsCauseMissingExpectedParm : HsPhoneSMSTypes.h
  • SmsCauseMissingMandatoryParm : HsPhoneSMSTypes.h
  • SmsCauseNetworkFailure : HsPhoneSMSTypes.h
  • SmsCauseNetworkResourceShortage : HsPhoneSMSTypes.h
  • SmsCauseNoAck : HsPhoneSMSTypes.h
  • SmsCauseNoPageResponse : HsPhoneSMSTypes.h
  • SmsCauseOtherGeneralProblems : HsPhoneSMSTypes.h
  • SmsCauseOtherGeneralProblemsMoreFirst : HsPhoneSMSTypes.h
  • SmsCauseOtherGeneralProblemsMoreLast : HsPhoneSMSTypes.h
  • SmsCauseOtherNetworkProblem : HsPhoneSMSTypes.h
  • SmsCauseOtherNetworkProblemMoreFirst : HsPhoneSMSTypes.h
  • SmsCauseOtherNetworkProblemMoreLast : HsPhoneSMSTypes.h
  • SmsCauseOtherRadioIfProblem : HsPhoneSMSTypes.h
  • SmsCauseOtherRadioIfProblemMoreFirst : HsPhoneSMSTypes.h
  • SmsCauseOtherRadioIfProblemMoreLast : HsPhoneSMSTypes.h
  • SmsCauseOtherTerminalProblem : HsPhoneSMSTypes.h
  • smsCauseOtherTerminalProblemMoreFirst : HsPhoneSMSTypes.h
  • SmsCauseOtherTerminalProblemMoreLast : HsPhoneSMSTypes.h
  • SmsCauseRadioIfIncompatible : HsPhoneSMSTypes.h
  • SmsCauseRadioIfResourceShortage : HsPhoneSMSTypes.h
  • SmsCauseReserved101 : HsPhoneSMSTypes.h
  • SmsCauseSmsDeliveryPostponed : HsPhoneSMSTypes.h
  • SmsCauseSmsDeliveryPostponedMoreFirst : HsPhoneSMSTypes.h
  • SmsCauseSmsDeliveryPostponedMoreLast : HsPhoneSMSTypes.h
  • SmsCauseSmsNotSupported : HsPhoneSMSTypes.h
  • SmsCauseSmsOriginationDenied : HsPhoneSMSTypes.h
  • SmsCauseSmsTerminationDenied : HsPhoneSMSTypes.h
  • SmsCauseSupplServiceNotSupported : HsPhoneSMSTypes.h
  • SmsCauseUnexpected_Parm_Size : HsPhoneSMSTypes.h
  • SmsCauseUnexpectedParmValue : HsPhoneSMSTypes.h
  • SmsCauseUnrecognizedParmValue : HsPhoneSMSTypes.h
  • SmsCauseUserDataSizeError : HsPhoneSMSTypes.h
  • SmsErrorCode : HsPhoneSMSTypes.h
  • SmsErrorNone : HsPhoneSMSTypes.h
  • SmsErrorPermanent : HsPhoneSMSTypes.h
  • SmsErrorReserved : HsPhoneSMSTypes.h
  • SmsErrorTemporary : HsPhoneSMSTypes.h
  • smsFmtAllKinds : HsPhoneSMSTypes.h
  • smsFmtExceptKind : HsPhoneSMSTypes.h
  • smsFmtIgnoreKind : HsPhoneSMSTypes.h
  • smsFmtLastNameFirst : HsPhoneSMSTypes.h
  • smsFmtMatchKind : HsPhoneSMSTypes.h
  • smsFmtShortLabel : HsPhoneSMSTypes.h
  • SMSMessageFlags : HsPhoneSMSTypes.h
  • SMSMessageStatus : HsPhoneSMSTypes.h
  • SMSMessageType : HsPhoneSMSTypes.h
  • sndControlCodecCustomControl : PalmSoundCustomCtrl.h
  • SndFileFormatType : palmOneSndFileStream.h
  • SNDFILESTREAM_TRAP : palmOneSndFileStream.h
  • SndFileStreamCallbackPtr : palmOneSndFileStream.h
  • SndFileStreamClose() : palmOneSndFileStream.h
  • SndFileStreamCloseLibrary : palmOneSndFileStream.h
  • SndFileStreamCreate() : palmOneSndFileStream.h
  • SndFileStreamData : palmOneSndFileStream.h
  • SndFileStreamDataPtr : palmOneSndFileStream.h
  • SndFileStreamDeviceControl() : palmOneSndFileStream.h
  • SndFileStreamFileSpec : palmOneSndFileStream.h
  • SndFileStreamFileSpecPtr : palmOneSndFileStream.h
  • SndFileStreamGetCurrentStreamData() : palmOneSndFileStream.h
  • SndFileStreamGetPan() : palmOneSndFileStream.h
  • SndFileStreamGetVolume() : palmOneSndFileStream.h
  • SndFileStreamHsSoundCommandParam : palmOneSndFileStream.h
  • SndFileStreamHsSoundCommandParamPtr : palmOneSndFileStream.h
  • SndFileStreamLibClose() : palmOneSndFileStream.h
  • SndFileStreamLibOpen() : palmOneSndFileStream.h
  • SndFileStreamLibSleep() : palmOneSndFileStream.h
  • SndFileStreamLibVersion() : palmOneSndFileStream.h
  • SndFileStreamLibWake() : palmOneSndFileStream.h
  • sndFileStreamNotifyRecComplete : palmOneSndFileStream.h
  • sndFileStreamNotifyStreamComplete : palmOneSndFileStream.h
  • SndFileStreamOpen() : palmOneSndFileStream.h
  • SndFileStreamOpenLibrary : palmOneSndFileStream.h
  • SndFileStreamPause() : palmOneSndFileStream.h
  • SndFileStreamRef : palmOneSndFileStream.h
  • SndFileStreamSeek() : palmOneSndFileStream.h
  • SndFileStreamSetPan() : palmOneSndFileStream.h
  • SndFileStreamSetVolume() : palmOneSndFileStream.h
  • SndFileStreamStart() : palmOneSndFileStream.h
  • SndFileStreamStop() : palmOneSndFileStream.h
  • SndFileStreamUIPlay() : palmOneSndFileStream.h
  • SndFileStreamUIRecord() : palmOneSndFileStream.h
  • sndFormatAAC : PalmSoundMgrExt.h
  • sndFormatDVI_ADPCM : PalmSoundMgrExt.h
  • sndFormatIMA_ADPCM : PalmSoundMgrExt.h
  • sndFormatMP3 : PalmSoundMgrExt.h
  • sndFormatOGG : PalmSoundMgrExt.h
  • sndFormatPCM : PalmSoundMgrExt.h
  • SndFormatType : PalmSoundMgrExt.h
  • SndStreamCreateExtended() : PalmSoundMgrExt.h
  • SndStreamDeviceControl() : PalmSoundMgrExt.h
  • SndStreamVariableBufferCallback : PalmSoundMgrExt.h
  • softGraffitErrorClass : PalmErrorBase.h
  • soundPrefsLaunchCmdCalendar : HsAppLaunchCmd.h
  • soundPrefsLaunchCmdEmail : HsAppLaunchCmd.h
  • soundPrefsLaunchCmdGeneral : HsAppLaunchCmd.h
  • soundPrefsLaunchCmdIM : HsAppLaunchCmd.h
  • soundPrefsLaunchCmdMMS : HsAppLaunchCmd.h
  • SoundPrefsLaunchCmdParamPtr : HsAppLaunchCmd.h
  • soundPrefsLaunchCmdPhone : HsAppLaunchCmd.h
  • soundPrefsLaunchCmdSMS : HsAppLaunchCmd.h
  • SoundPrefsView : HsAppLaunchCmd.h
  • soundPrefsViewTones : HsAppLaunchCmd.h
  • soundPrefsViewVolume : HsAppLaunchCmd.h
  • SoundPrefType : TonesLibTypes.h
  • soundPrefTypeCalendar : TonesLibTypes.h
  • soundPrefTypeEmail : TonesLibTypes.h
  • soundPrefTypeIM : TonesLibTypes.h
  • soundPrefTypeLast : TonesLibTypes.h
  • soundPrefTypeMMS : TonesLibTypes.h
  • soundPrefTypeNetworkSounds : TonesLibTypes.h
  • soundPrefTypePhone : TonesLibTypes.h
  • soundPrefTypeSMS : TonesLibTypes.h
  • specialAvail3KeyMask : HsKeyTypes.h
  • specialAvail4KeyMask : HsKeyTypes.h
  • specialHoldKeyMask : HsKeyTypes.h
  • specialKeyMask : HsKeyTypes.h
  • specialReleaseKeyMask : HsKeyTypes.h
  • SSR : palmOneCodecFormat.h
  • statAttrBarVisible : PalmStatusBar.h
  • statAttrDimension : PalmStatusBar.h
  • statAttrExists : PalmStatusBar.h
  • StatAttrType : PalmStatusBar.h
  • StatAttrTypeTag : PalmStatusBar.h
  • statErrBadParam : PalmStatusBar.h
  • statErrInputWindowOpen : PalmStatusBar.h
  • statErrInvalidSelector : PalmStatusBar.h
  • statErrInvalidState : PalmStatusBar.h
  • statErrNoStatusBar : PalmStatusBar.h
  • statErrorClass : PalmStatusBar.h
  • statFtrNumVersion : PalmStatusBar.h
  • StatGetAttribute() : PalmStatusBar.h
  • StatHide() : PalmStatusBar.h
  • StatLibClose() : PalmStatusBar.h
  • statLibCreator : PalmStatusBar.h
  • statLibName : PalmStatusBar.h
  • StatLibOpen() : PalmStatusBar.h
  • statLibType : PalmStatusBar.h
  • StatShow() : PalmStatusBar.h
  • statusBarErrorClass : PalmErrorBase.h
  • steAcceleratedScrolling : SmartTextEngineDef.h
  • steAllowPhoneNumberWords : SmartTextEngineDef.h
  • steAllowShortPhoneNumbers : SmartTextEngineDef.h
  • STEAppendParsedInfo() : SmartTextEngine.h
  • STEAppendTextToEngine() : SmartTextEngine.h
  • steBitmap : SmartTextEngineDef.h
  • steBlackFont : SmartTextEngineDef.h
  • steBlueFont : SmartTextEngineDef.h
  • steBoldFont : SmartTextEngineDef.h
  • STECallbackType : SmartTextEngineDef.h
  • steCannotSelectText : SmartTextEngineDef.h
  • steCenterAlign : SmartTextEngineDef.h
  • STEClearCurrentSelection() : SmartTextEngine.h
  • STEClose() : SmartTextEngine.h
  • STECopySelectionToClipboard() : SmartTextEngine.h
  • steCurrentFont : SmartTextEngineDef.h
  • STEDepracated5 : SmartTextEngineTraps.h
  • steDoNotCenterVertically : SmartTextEngineDef.h
  • STEErr : SmartTextEngineErrors.h
  • steErrBase : SmartTextEngineErrors.h
  • steErrDynamicMemory : SmartTextEngineErrors.h
  • steErrInternal : SmartTextEngineErrors.h
  • steErrInvalidArguments : SmartTextEngineErrors.h
  • steErrOperationNotAllowed : SmartTextEngineErrors.h
  • steErrSTEInit : SmartTextEngineErrors.h
  • steErrStorageMemory : SmartTextEngineErrors.h
  • steErrUnimplemented : SmartTextEngineErrors.h
  • STEGetAPIVersion() : SmartTextEngine.h
  • STEGetCurrentTextSelection() : SmartTextEngine.h
  • STEGetFlags() : SmartTextEngine.h
  • STEGetLastTapInfo() : SmartTextEngine.h
  • STEGetNumLines() : SmartTextEngine.h
  • STEGetNumRecords() : SmartTextEngine.h
  • STEGetParsedInformation() : SmartTextEngine.h
  • STEGetScroll() : SmartTextEngine.h
  • STEGetScrollPct() : SmartTextEngine.h
  • STEGetSelectedText() : SmartTextEngine.h
  • steGrayFont : SmartTextEngineDef.h
  • steGreenFont : SmartTextEngineDef.h
  • STEHandleEvent() : SmartTextEngine.h
  • STEHandleKeyDownEvent() : SmartTextEngine.h
  • STEHandlePenDownEvent() : SmartTextEngine.h
  • STEHandlePenMoveEvent() : SmartTextEngine.h
  • STEHandlePenUpEvent() : SmartTextEngine.h
  • STEHandleSclRepeatEvent() : SmartTextEngine.h
  • STEHasHotRectSelection() : SmartTextEngine.h
  • STEHasMessageSelection() : SmartTextEngine.h
  • STEHasTextSelection() : SmartTextEngine.h
  • steHorizontalLine : SmartTextEngineDef.h
  • steHyperlink : SmartTextEngineDef.h
  • STEInitializeEngine() : SmartTextEngine.h
  • steInvertHighlighting : SmartTextEngineDef.h
  • steLargeFont : SmartTextEngineDef.h
  • steLeftIndent : SmartTextEngineDef.h
  • steLibDBName : SmartTextEngineDef.h
  • steLibName : SmartTextEngineDef.h
  • steLineBreak : SmartTextEngineDef.h
  • steNoLinksBeforeColon : SmartTextEngineDef.h
  • STEOpen() : SmartTextEngine.h
  • steOrangeFont : SmartTextEngineDef.h
  • steParseEmail : SmartTextEngineDef.h
  • steParseEmoticons : SmartTextEngineDef.h
  • steParseGSMGreekChars : SmartTextEngineDef.h
  • steParseMoreEmoticons : SmartTextEngineDef.h
  • steParsePhoneNumbers : SmartTextEngineDef.h
  • steParseURLs : SmartTextEngineDef.h
  • stePurpleFont : SmartTextEngineDef.h
  • STEQuickRender() : SmartTextEngine.h
  • steRedFont : SmartTextEngineDef.h
  • STEReinitializeEngine() : SmartTextEngine.h
  • STERemoveLastRecordFromEngine() : SmartTextEngine.h
  • STERenderList() : SmartTextEngine.h
  • STERerenderList() : SmartTextEngine.h
  • STEResetEngine() : SmartTextEngine.h
  • steRightAlign : SmartTextEngineDef.h
  • steScrollWalksLinks : SmartTextEngineDef.h
  • steScrollWalksMessages : SmartTextEngineDef.h
  • STESetCurrentTextSelection() : SmartTextEngine.h
  • STESetCustomHyperlinkCallback() : SmartTextEngine.h
  • STESetFlags() : SmartTextEngine.h
  • STESetScroll() : SmartTextEngine.h
  • STESetScrollPct() : SmartTextEngine.h
  • STESetScrollToRecordNum() : SmartTextEngine.h
  • steStdFont : SmartTextEngineDef.h
  • steTextMustBeVisible : SmartTextEngineDef.h
  • STETrapAppendParsedInfo : SmartTextEngineTraps.h
  • STETrapAppendTextToEngine : SmartTextEngineTraps.h
  • STETrapClearCurrentSelection : SmartTextEngineTraps.h
  • STETrapClose : SmartTextEngineTraps.h
  • STETrapCopySelectionToClipboard : SmartTextEngineTraps.h
  • STETrapGetAPIVersion : SmartTextEngineTraps.h
  • STETrapGetCurrentTextSelection : SmartTextEngineTraps.h
  • STETrapGetFlags : SmartTextEngineTraps.h
  • STETrapGetLastTapInfo : SmartTextEngineTraps.h
  • STETrapGetNumLines : SmartTextEngineTraps.h
  • STETrapGetNumRecords : SmartTextEngineTraps.h
  • STETrapGetParsedInformation : SmartTextEngineTraps.h
  • STETrapGetScroll : SmartTextEngineTraps.h
  • STETrapGetScrollPct : SmartTextEngineTraps.h
  • STETrapGetSelectedText : SmartTextEngineTraps.h
  • STETrapHandleEvent : SmartTextEngineTraps.h
  • STETrapHandleKeyDownEvent : SmartTextEngineTraps.h
  • STETrapHandlePenDownEvent : SmartTextEngineTraps.h
  • STETrapHandlePenMoveEvent : SmartTextEngineTraps.h
  • STETrapHandlePenUpEvent : SmartTextEngineTraps.h
  • STETrapHandleSclRepeatEvent : SmartTextEngineTraps.h
  • STETrapHasHotRectSelection : SmartTextEngineTraps.h
  • STETrapHasMessageSelection : SmartTextEngineTraps.h
  • STETrapHasTextSelection : SmartTextEngineTraps.h
  • STETrapInitializeEngine : SmartTextEngineTraps.h
  • STETrapOpen : SmartTextEngineTraps.h
  • STETrapQuickRender : SmartTextEngineTraps.h
  • STETrapReinitializeEngine : SmartTextEngineTraps.h
  • STETrapRemoveLastRecordFromEngine : SmartTextEngineTraps.h
  • STETrapRenderList : SmartTextEngineTraps.h
  • STETrapRerenderList : SmartTextEngineTraps.h
  • STETrapResetEngine : SmartTextEngineTraps.h
  • STETrapSetCurrentTextSelection : SmartTextEngineTraps.h
  • STETrapSetCustomHyperlinkCallback : SmartTextEngineTraps.h
  • STETrapSetFlags : SmartTextEngineTraps.h
  • STETrapSetScroll : SmartTextEngineTraps.h
  • STETrapSetScrollPct : SmartTextEngineTraps.h
  • STETrapSetScrollToRecordNum : SmartTextEngineTraps.h
  • steYellowFont : SmartTextEngineDef.h
  • SYS_SEL_TRAP : HsExt.h
  • sysAppLaunchCmdFromSetupApp : PalmLaunchCodes.h
  • sysAppLaunchWebBrowserAutoCrawl : HsAppLaunchCmd.h
  • sysAppLaunchWebBrowserGetHomePage : HsAppLaunchCmd.h
  • sysAppLaunchWebBrowserLaunchBookmarkDialog : HsAppLaunchCmd.h
  • sysAppLaunchWebBrowserMinimalMode : HsAppLaunchCmd.h
  • sysAppLaunchWebBrowserSetHomePage : HsAppLaunchCmd.h
  • sysAppLaunchWebBrowserTutorialMode : HsAppLaunchCmd.h
  • sysAppLaunchWebBrowserURLWithSvcID : HsAppLaunchCmd.h
  • sysExternalHeadsetInsertEvent : palmOneFeatures.h
  • sysExternalHeadsetRemoveEvent : palmOneFeatures.h
  • sysFileCMobileApp : palmOneCreators.h
  • sysFileCMobileServices : palmOneCreators.h
  • sysFileCMyFavorite : palmOneCreators.h
  • sysFileCNotePad : palmOneCreators.h
  • sysFileCPower : Slider.h
  • sysFileCProvisioning : palmOneCreators.h
  • sysFileCSimATDriverOem : palmOneCreators.h
  • sysFileCSimOfficer : palmOneCreators.h
  • sysFileCSimWatcherLib : palmOneCreators.h
  • sysFileCTelMgrLibOem : palmOneCreators.h
  • sysFileTVPNPanelPlugin : PalmVPPI.h
  • sysFileTWiFiPanelPlugin : PalmWPPI.h
  • sysFtrNumDmAutoBackup : PmPalmOSNVFS.h
  • sysFtrNumFiveWayNavVersion : HsNavCommon.h
  • sysFtrNumUIHardwareFlags : HsKeyCommon.h
  • sysFtrNumUIHardwareHas5Way : HsKeyCommon.h
  • sysFtrNumUIHardwareHasKbd : HsKeyCommon.h
  • sysFtrNumUIHardwareHasThumbWheel : HsKeyCommon.h
  • sysFtrNumUIHardwareHasThumbWheelBack : HsKeyCommon.h
  • sysGetLibAPIVersionMajor : palmOneSystemCommon.h
  • sysGetLibAPIVersionMinor : palmOneSystemCommon.h
  • sysMakeLibAPIVersion : palmOneSystemCommon.h
  • sysNotifyAiaEvent : PalmPin.h
  • sysNotifyExternalDialogClosedEvent : palmOneFeatures.h
  • sysNotifyExternalDialogOpenedEvent : palmOneFeatures.h
  • sysNotifyHardDiskSpinup : palmOneFeatures.h
  • sysNotifyHelperEvent : HsHelper.h
  • SysNotifyPIMRecordChange : DatebookLibCommon.h
  • sysNotifyStopEvent : HS_HTTPLibApp.h
  • sysTrapDmSyncDatabase : PmPalmOSNVFS.h
  • sysTrapHsSelector : HsExtTraps.h
  • sysTrapNavSelector : HsNavCommon.h
  • sysTrapOEMDispatch : HsExtTraps.h
  • sysTrapSndStreamCreateExtended : PalmSoundMgrExt.h
  • sysTrapSndStreamDeviceControl : PalmSoundMgrExt.h
  • sysVPPILaunchCmdClearPWCache : PalmVPPI.h
  • sysVPPILaunchCmdDeleteAccount : PalmVPPI.h
  • sysVPPILaunchCmdEditAccount : PalmVPPI.h
  • sysVPPILaunchCmdErrorDialog : PalmVPPI.h
  • sysVPPILaunchCmdGetAccounts : PalmVPPI.h
  • sysVPPILaunchCmdProgressPaint : PalmVPPI.h
  • sysVPPILaunchCmdPromptAndConfigure : PalmVPPI.h
  • sysVPPILaunchCmdSetCurrentAccount : PalmVPPI.h
  • sysVPPILaunchCmdWillPWPrompt : PalmVPPI.h
  • sysWPPILaunchCmdClearPWCache : PalmWPPI.h
  • sysWPPILaunchCmdClose : PalmWPPI.h
  • sysWPPILaunchCmdDelete : PalmWPPI.h
  • sysWPPILaunchCmdDialog : PalmWPPI.h
  • sysWPPILaunchCmdErrorDialog : PalmWPPI.h
  • sysWPPILaunchCmdGetAuthenticationMethods : PalmWPPI.h
  • sysWPPILaunchCmdGetDescription : PalmWPPI.h
  • sysWPPILaunchCmdOpen : PalmWPPI.h
  • sysWPPILaunchCmdPromptAndConfigure : PalmWPPI.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:38 2008 for Palm API Guide


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- t -

  • tagAudioInputSetting : PmConnectorLibCommon.h
  • tagAudioOutputSetting : PmConnectorLibCommon.h
  • tagSndFileFormatEnum : palmOneSndFileStream.h
  • TextHeaderTerminator : HsPhoneSMSTypes.h
  • Theta11BitMap : SmartTextEngineRsc.h
  • Theta14BitMap : SmartTextEngineRsc.h
  • toneInterruptMask : TonesLibTypes.h
  • toneInterruptMode2 : TonesLibTypes.h
  • toneInterruptMode3 : TonesLibTypes.h
  • toneInterruptPhone : TonesLibTypes.h
  • ToneItemPtr : TonesLibTypes.h
  • tonePlay100Times : TonesLibTypes.h
  • tonePlay10Times : TonesLibTypes.h
  • tonePlay3Times : TonesLibTypes.h
  • tonePlay5Times : TonesLibTypes.h
  • TonePlayNumberTimes : TonesLibTypes.h
  • tonePlayOnce : TonesLibTypes.h
  • tonePlayTwice : TonesLibTypes.h
  • toneRepeatEvery10Minutes : TonesLibTypes.h
  • toneRepeatEvery30Minutes : TonesLibTypes.h
  • toneRepeatEvery5Minutes : TonesLibTypes.h
  • toneRepeatEveryMinute : TonesLibTypes.h
  • ToneRepeatInterval : TonesLibTypes.h
  • TonesLibAddMidiTone() : TonesLib.h
  • TonesLibClose() : TonesLib.h
  • TonesLibCopyBackUndeletableTones() : TonesLib.h
  • tonesLibCreator : TonesLibTypes.h
  • TonesLibDeleteTone() : TonesLib.h
  • TonesLibDoDialog() : TonesLib.h
  • tonesLibErrAlreadyPlaying : TonesLibTypes.h
  • tonesLibErrBadParams : TonesLibTypes.h
  • tonesLibErrClass : TonesLibTypes.h
  • tonesLibErrCreateDBFailed : TonesLibTypes.h
  • tonesLibErrDBNotFound : TonesLibTypes.h
  • tonesLibErrDBWriteFailed : TonesLibTypes.h
  • tonesLibErrNoMemory : TonesLibTypes.h
  • tonesLibErrNotAllowed : TonesLibTypes.h
  • tonesLibErrNoTone : TonesLibTypes.h
  • tonesLibErrUnknown : TonesLibTypes.h
  • tonesLibErrUserCancel : TonesLibTypes.h
  • TonesLibEscalateRingTones() : TonesLib.h
  • TonesLibGetSoundOnVolume() : TonesLib.h
  • TonesLibGetSoundPrefs() : TonesLib.h
  • TonesLibGetToneIDs() : TonesLib.h
  • TonesLibGetToneList() : TonesLib.h
  • TonesLibGetToneName() : TonesLib.h
  • TonesLibGetToneSize() : TonesLib.h
  • TonesLibInitTonesDB() : TonesLib.h
  • TonesLibManageTones() : TonesLib.h
  • tonesLibName : TonesLibTypes.h
  • TonesLibOpen() : TonesLib.h
  • TonesLibPickTone() : TonesLib.h
  • tonesLibPlayForever : TonesLibTypes.h
  • TonesLibPlayRingTone() : TonesLib.h
  • TonesLibPlayTone() : TonesLib.h
  • TonesLibRecordTone() : TonesLib.h
  • TonesLibSaveUndeletableTones() : TonesLib.h
  • TonesLibSetSoundOnVolume() : TonesLib.h
  • TonesLibSetSoundPrefs() : TonesLib.h
  • TonesLibSleep() : TonesLib.h
  • TonesLibStopTone() : TonesLib.h
  • TonesLibToneClose() : TonesLib.h
  • TonesLibToneCreate() : TonesLib.h
  • TonesLibToneWrite() : TonesLib.h
  • tonesLibTrapAddMidiTone : TonesLibTypes.h
  • tonesLibTrapCopyBackUndeletableTones : TonesLibTypes.h
  • tonesLibTrapDeleteTone : TonesLibTypes.h
  • tonesLibTrapDoDialog : TonesLibTypes.h
  • tonesLibTrapEscalateRingTones : TonesLibTypes.h
  • tonesLibTrapGetSoundOnVolume : TonesLibTypes.h
  • tonesLibTrapGetSoundPrefs : TonesLibTypes.h
  • tonesLibTrapGetToneIDs : TonesLibTypes.h
  • tonesLibTrapGetToneList : TonesLibTypes.h
  • tonesLibTrapGetToneName : TonesLibTypes.h
  • tonesLibTrapGetToneSize : TonesLibTypes.h
  • tonesLibTrapInitTonesDB : TonesLibTypes.h
  • tonesLibTrapManageTones : TonesLibTypes.h
  • tonesLibTrapPickTone : TonesLibTypes.h
  • tonesLibTrapPlayRingTone : TonesLibTypes.h
  • tonesLibTrapPlayTone : TonesLibTypes.h
  • tonesLibTrapSaveUndeletableTones : TonesLibTypes.h
  • tonesLibTrapSetSoundOnVolume : TonesLibTypes.h
  • tonesLibTrapSetSoundPrefs : TonesLibTypes.h
  • tonesLibTrapStopTone : TonesLibTypes.h
  • tonesLibTrapToneClose : TonesLibTypes.h
  • tonesLibTrapToneCreate : TonesLibTypes.h
  • tonesLibTrapToneRecord : TonesLibTypes.h
  • tonesLibTrapToneWrite : TonesLibTypes.h
  • tonesLibType : TonesLibTypes.h
  • TonesLibWake() : TonesLib.h
  • ToneTimeUnit : TonesLibTypes.h
  • toneTimeUnitDays : TonesLibTypes.h
  • toneTimeUnitHours : TonesLibTypes.h
  • toneTimeUnitMinutes : TonesLibTypes.h
  • ToneType : TonesLibTypes.h
  • toneTypeAAC : TonesLibTypes.h
  • toneTypeAMR : TonesLibTypes.h
  • toneTypeMIDI : TonesLibTypes.h
  • toneTypeMP3 : TonesLibTypes.h
  • toneTypeQCELP : TonesLibTypes.h
  • toneTypeSystemSound : TonesLibTypes.h
  • toneTypeWAV : TonesLibTypes.h
  • toneVibrateAlert : TonesLibTypes.h
  • toneVibrateCalender : TonesLibTypes.h
  • toneVibrateMail : TonesLibTypes.h
  • toneVibrateNone : TonesLibTypes.h
  • toneVibrateRing : TonesLibTypes.h
  • toneVibrateSMS : TonesLibTypes.h
  • toneVibrateThenRing : TonesLibTypes.h
  • ToneVibrateType : TonesLibTypes.h
  • toneVibrateVoicemail : TonesLibTypes.h
  • ToneVolume : TonesLibTypes.h
  • toneVolume1 : TonesLibTypes.h
  • toneVolume2 : TonesLibTypes.h
  • toneVolume3 : TonesLibTypes.h
  • toneVolume4 : TonesLibTypes.h
  • toneVolume5 : TonesLibTypes.h
  • toneVolume6 : TonesLibTypes.h
  • toneVolume7 : TonesLibTypes.h
  • toneVolumeOff : TonesLibTypes.h
  • TransLibCloseConnection() : TransparencyLib.h
  • transLibCreator : TransparencyLibTypes.h
  • transLibErrAlreadyOpen : TransparencyLibTypes.h
  • transLibErrDockNotAttached : TransparencyLibTypes.h
  • transLibErrNotOpen : TransparencyLibTypes.h
  • transLibErrorClass : TransparencyLibTypes.h
  • transLibErrUnknown : TransparencyLibTypes.h
  • transLibName : TransparencyLibTypes.h
  • TransLibOpenConnection() : TransparencyLib.h
  • transLibTrapCloseConnection : TransparencyLibTypes.h
  • transLibTrapOpenConnection : TransparencyLibTypes.h
  • transLibType : TransparencyLibTypes.h
  • true : PalmNative.h
  • TxtCharIsRockerKey : HsNavCommon.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:38 2008 for Palm API Guide


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- u -

  • uilibErrCurrentFocusInvalid : HsNavCommon.h
  • uilibErrFormDoesNotHaveFocus : HsNavCommon.h
  • uilibErrInvalidFocusObject : HsNavCommon.h
  • uilibErrInvalidParam : HsNavCommon.h
  • uilibErrNoNavInfoForForm : HsNavCommon.h
  • uilibErrObjectFocusModeOff : HsNavCommon.h
  • uilibErrObjectNotFound : HsNavCommon.h
  • uilibErrorClass : HsNavCommon.h
  • UInt16 : PalmNative.h
  • UInt32 : PalmNative.h
  • UInt8 : PalmNative.h
  • UPDataSize : HsPhoneEvent.h
  • UPHeaderEscapeSeq : HsPhoneEvent.h
  • UPNotificationEventType : HsPhoneEvent.h
  • UPTextHeader : HsPhoneEvent.h
  • UPTextHeaderLength : HsPhoneEvent.h
  • USBChargeCreator : palmOneFeatures.h
  • USBChargeVersion : palmOneFeatures.h
  • USBFeatureCreator : palmOneFeatures.h
  • USBFeatureVersion : palmOneFeatures.h
  • USBHwrCreator : palmOneFeatures.h
  • USBHwrVersion : palmOneFeatures.h
  • USBSpeedCreator : palmOneFeatures.h
  • USBSpeedVersion : palmOneFeatures.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:38 2008 for Palm API Guide


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- v -

  • vchrBacklightToggled : common/system/palmOneChars.h
  • vchrCameraShutter : common/system/palmOneChars.h
  • vchrClock : common/system/palmOneChars.h
  • vchrDeviceIncomingCall : common/system/palmOneChars.h
  • vchrDeviceSpecificChar : common/system/palmOneChars.h
  • vchrEmergencyCall : common/system/palmOneChars.h
  • vchrFunctionFiveWay : common/system/palmOneChars.h
  • vchrHard11 : HsChars.h
  • vchrHard12 : HsChars.h
  • vchrHard13 : HsChars.h
  • vchrHard14 : HsChars.h
  • vchrHard3Down : common/system/palmOneChars.h
  • vchrHard4Down : common/system/palmOneChars.h
  • vchrHard5 : common/system/palmOneChars.h
  • vchrHard6 : common/system/palmOneChars.h
  • vchrHardRecord : common/system/palmOneChars.h
  • vchrHardRockerCenter : HsKeyCommon.h
  • vchrKeyboardSymbol : common/system/palmOneChars.h
  • vchrMyFavoriteApplication : common/system/palmOneChars.h
  • vchrNavChange : common/system/palmOneChars.h
  • vchrPopupBrightness : common/system/palmOneChars.h
  • vchrPowerOnPhone : common/system/palmOneChars.h
  • vchrReplaceLastChar : common/system/palmOneChars.h
  • vchrRockerCenter : common/system/palmOneChars.h
  • vchrRockerDown : common/system/palmOneChars.h
  • vchrRockerLeft : common/system/palmOneChars.h
  • vchrRockerRight : common/system/palmOneChars.h
  • vchrRockerSelect : common/system/palmOneChars.h
  • vchrRockerUp : common/system/palmOneChars.h
  • vchrSilkClock : common/system/palmOneChars.h
  • vchrTelDevicePowerFinished : common/system/palmOneChars.h
  • vchrTelDevicePowerOn : common/system/palmOneChars.h
  • vchrThumbWheelBack : common/system/palmOneChars.h
  • vchrThumbWheelDown : common/system/palmOneChars.h
  • vchrThumbWheelPush : common/system/palmOneChars.h
  • vchrThumbWheelUp : common/system/palmOneChars.h
  • VFS : palmOneCodecFormat.h
  • vfsIncludePrivateVolumes : PmPalmOSNVFS.h
  • vfsVolumeAttrNonRemovable : PmPalmOSNVFS.h
  • VMFontClearCache() : palmOneVMFontLib.h
  • VMFontClose() : palmOneVMFontLib.h
  • VMFontCountStyleAndSize() : palmOneVMFontLib.h
  • VMFontErrNotOpen : VMFontLibCommon.h
  • VMFontErrParam : VMFontLibCommon.h
  • VMFontErrStillOpen : VMFontLibCommon.h
  • VMFontExists() : palmOneVMFontLib.h
  • VMFontFace : VMFontLibCommon.h
  • VMFontGetFont() : palmOneVMFontLib.h
  • VMFontGetFontByID() : palmOneVMFontLib.h
  • VMFONTLIB_TRAP : palmOneVMFontLib.h
  • VMFontOpen() : palmOneVMFontLib.h
  • VMFontPtr : VMFontLibCommon.h
  • VMFontSize : VMFontLibCommon.h
  • VMFontSizeRule : VMFontLibCommon.h
  • VMFontStyle : VMFontLibCommon.h
  • VMFontStyleRule : VMFontLibCommon.h
  • VMFontToString() : palmOneVMFontLib.h
  • VMFontUIRulesPtr : VMFontLibCommon.h
  • VMFontVersion() : palmOneVMFontLib.h
  • voiceConnection : HsPhoneMiscTypes.h
  • vpnConnectionDown : PalmShimSettings.h
  • vpnConnectionUp : PalmShimSettings.h
  • vpnLibEventNotification : PalmShimSettings.h
  • VPNLibEventNotificationTypeEnum : PalmShimSettings.h
  • VPNLibEventNotificationTypeEnum_ : PalmShimSettings.h
  • VPNNotifyEventType : PalmShimSettings.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:38 2008 for Palm API Guide


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- w -

  • WAPMsgLength : HsPhoneEvent.h
  • WAPMsgSize : HsPhoneEvent.h
  • WAPNotificationEventType : HsPhoneEvent.h
  • WAPNotificationTypeVersion : HsPhoneEvent.h
  • WIFI_ASSOCIATED_EVENT : PalmWiFiCommon.h
  • WIFI_CONFIG_NAME : PalmWiFiCommon.h
  • WIFI_CREATOR_ID : PalmWiFiCommon.h
  • WIFI_DB_NAME : PalmWiFiCommon.h
  • WIFI_DB_TYPE : PalmWiFiCommon.h
  • WIFI_DISASSOCIATED_EVENT : PalmWiFiCommon.h
  • WIFI_DRIVER_NAME : PalmWiFiCommon.h
  • WIFI_DRIVER_PREFIX : PalmWiFiCommon.h
  • WIFI_IF_DOWN_EVENT : PalmWiFiCommon.h
  • WIFI_IF_UP_EVENT : PalmWiFiCommon.h
  • WIFI_MIN_OS_VERSION : PalmWiFiCommon.h
  • WIFI_SCAN_COMPLETE_EVENT : PalmWiFiCommon.h
  • WiFiCustomIFSettings : PalmWiFiCommon.h
  • willSendUpKeyMask : HsKeyCommon.h
  • WUFieldDelimiter : HsPhoneEvent.h
  • WUHeaderEscapeSeq : HsPhoneEvent.h
  • WUNotificationEventType : HsPhoneEvent.h
  • WUTextHeader : HsPhoneEvent.h
  • WUTextHeaderLength : HsPhoneEvent.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:38 2008 for Palm API Guide


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- x -

  • Xi11BitMap : SmartTextEngineRsc.h
  • Xi14BitMap : SmartTextEngineRsc.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:38 2008 for Palm API Guide


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- _ -

  • _15_MW_TX_POWER : PalmWiFiCommon.h
  • _1_MW_TX_POWER : PalmWiFiCommon.h
  • _30_MW_TX_POWER : PalmWiFiCommon.h
  • _5_MW_TX_POWER : PalmWiFiCommon.h
  • __HS_EXT_UTIL_BIG_BUTTON_RSC__H__ : HsExtUtilBigButtonRsc.h
  • __PM_SYS_GADGET_BBUT_RSC__H__ : PmSysGadgetLibBbutRscCommon.h
  • __SMART_TEXT_ENGINE_RSC_H__ : SmartTextEngineRsc.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:38 2008 for Palm API Guide


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- k -

  • kAngelSmiley : SmartTextEngineDef.h
  • kBellMobilityMCCMNC : CarrierCustomLibTypes.h
  • kBigFrownSmiley : SmartTextEngineDef.h
  • kBigSmileSmiley : SmartTextEngineDef.h
  • kBigTeethSmiley : SmartTextEngineDef.h
  • kBigTongueSmiley : SmartTextEngineDef.h
  • kBlushSmiley : SmartTextEngineDef.h
  • kCameraImageFormatRGB1 : CameraLibCommon.h
  • kCameraImageFormatRGB16 : CameraLibCommon.h
  • kCameraImageFormatRGB24 : CameraLibCommon.h
  • kCameraImageFormatRGB32 : CameraLibCommon.h
  • kCameraImageFormatRGB4 : CameraLibCommon.h
  • kCameraImageFormatRGB8 : CameraLibCommon.h
  • kCameraImageFormatYCbCr : CameraLibCommon.h
  • kCameraImageFormatYCrCb : CameraLibCommon.h
  • kCameraImageLittleEndian : CameraLibCommon.h
  • kCameraLibCreator : CameraLibCommon.h
  • kCameraLibName : CameraLibCommon.h
  • kCameraLibTrapCameraLibCapture : CameraLibCommon.h
  • kCameraLibTrapCameraLibPreview : CameraLibCommon.h
  • kCameraLibTrapCameraLibPreviewStart : CameraLibCommon.h
  • kCameraLibTrapCameraLibPreviewStop : CameraLibCommon.h
  • kCameraLibTrapCameraLibRegisterGet : CameraLibCommon.h
  • kCameraLibTrapCameraLibRegisterSet : CameraLibCommon.h
  • kCameraLibTrapClose : CameraLibCommon.h
  • kCameraLibTrapOpen : CameraLibCommon.h
  • kCameraLibTrapSleep : CameraLibCommon.h
  • kCameraLibTrapWake : CameraLibCommon.h
  • kCameraLibType : CameraLibCommon.h
  • kCamLibApertureValueAuto : palmOneCameraCommon.h
  • kCamLibApertureValueManual : palmOneCameraCommon.h
  • kCamLibBufNumManual : palmOneCameraCommon.h
  • kCamLibCaptureDataFormatRGB565 : palmOneCameraCommon.h
  • kCamLibCaptureDataFormatYCbCr420 : palmOneCameraCommon.h
  • kCamLibCaptureDataFormatYCbCr420Planar : palmOneCameraCommon.h
  • kCamLibCaptureDataFormatYCbCr422 : palmOneCameraCommon.h
  • kCamLibCaptureDataFormatYCbCr422Planar : palmOneCameraCommon.h
  • kCamLibCaptureDataFormatYUV420 : palmOneCameraCommon.h
  • kCamLibCaptureDataFormatYUV420Planar : palmOneCameraCommon.h
  • kCamLibCaptureDataFormatYUV422 : palmOneCameraCommon.h
  • kCamLibCaptureDataFormatYUV422Planar : palmOneCameraCommon.h
  • kCamLibCaptureHwrVersion : palmOneCameraCommon.h
  • kCamLibColorSpace_sRGB : palmOneCameraCommon.h
  • kCamLibColorSpaceUncalibrated : palmOneCameraCommon.h
  • kCamLibContrastManual : palmOneCameraCommon.h
  • kCamLibCreator : palmOneCameraCommon.h
  • kCamLibCtrlApertureValueGet : palmOneCameraCommon.h
  • kCamLibCtrlApertureValueQuery : palmOneCameraCommon.h
  • kCamLibCtrlApertureValueSet : palmOneCameraCommon.h
  • kCamLibCtrlCapture : palmOneCameraCommon.h
  • kCamLibCtrlCaptureAreaGet : palmOneCameraCommon.h
  • kCamLibCtrlCaptureAreaSet : palmOneCameraCommon.h
  • kCamLibCtrlCaptureFormatGet : palmOneCameraCommon.h
  • kCamLibCtrlCaptureFormatQuery : palmOneCameraCommon.h
  • kCamLibCtrlCaptureFormatSet : palmOneCameraCommon.h
  • kCamLibCtrlCaptureGetBitmapInfo : palmOneCameraCommon.h
  • kCamLibCtrlCaptureSizeGet : palmOneCameraCommon.h
  • kCamLibCtrlCaptureSizeQuery : palmOneCameraCommon.h
  • kCamLibCtrlCaptureSizeSet : palmOneCameraCommon.h
  • kCamLibCtrlColorSpaceGet : palmOneCameraCommon.h
  • kCamLibCtrlColorSpaceQuery : palmOneCameraCommon.h
  • kCamLibCtrlColorSpaceSet : palmOneCameraCommon.h
  • kCamLibCtrlContrastGet : palmOneCameraCommon.h
  • kCamLibCtrlContrastQuery : palmOneCameraCommon.h
  • kCamLibCtrlContrastSet : palmOneCameraCommon.h
  • kCamLibCtrlEffectsGet : palmOneCameraCommon.h
  • kCamLibCtrlEffectsQuery : palmOneCameraCommon.h
  • kCamLibCtrlEffectsSet : palmOneCameraCommon.h
  • kCamLibCtrlExposureGet : palmOneCameraCommon.h
  • kCamLibCtrlExposureQuery : palmOneCameraCommon.h
  • kCamLibCtrlExposureSet : palmOneCameraCommon.h
  • kCamLibCtrlHardwareSettingsDlg : palmOneCameraCommon.h
  • kCamLibCtrlLightingGet : palmOneCameraCommon.h
  • kCamLibCtrlLightingQuery : palmOneCameraCommon.h
  • kCamLibCtrlLightingSet : palmOneCameraCommon.h
  • kCamLibCtrlPowerOff : palmOneCameraCommon.h
  • kCamLibCtrlPowerOn : palmOneCameraCommon.h
  • kCamLibCtrlPreviewAreaGet : palmOneCameraCommon.h
  • kCamLibCtrlPreviewAreaSet : palmOneCameraCommon.h
  • kCamLibCtrlPreviewRectGet : palmOneCameraCommon.h
  • kCamLibCtrlPreviewRectSet : palmOneCameraCommon.h
  • kCamLibCtrlPreviewSizeGet : palmOneCameraCommon.h
  • kCamLibCtrlPreviewSizeQuery : palmOneCameraCommon.h
  • kCamLibCtrlPreviewSizeSet : palmOneCameraCommon.h
  • kCamLibCtrlPreviewStart : palmOneCameraCommon.h
  • kCamLibCtrlPreviewStop : palmOneCameraCommon.h
  • kCamLibCtrlSaturationGet : palmOneCameraCommon.h
  • kCamLibCtrlSaturationQuery : palmOneCameraCommon.h
  • kCamLibCtrlSaturationSet : palmOneCameraCommon.h
  • kCamLibCtrlSharpnessGet : palmOneCameraCommon.h
  • kCamLibCtrlSharpnessQuery : palmOneCameraCommon.h
  • kCamLibCtrlSharpnessSet : palmOneCameraCommon.h
  • kCamLibCtrlShutterSpeedGet : palmOneCameraCommon.h
  • kCamLibCtrlShutterSpeedQuery : palmOneCameraCommon.h
  • kCamLibCtrlShutterSpeedSet : palmOneCameraCommon.h
  • kCamLibCtrlStatusGet : palmOneCameraCommon.h
  • kCamLibCtrlStatusQuery : palmOneCameraCommon.h
  • kCamLibCtrlStreamBufNumGet : palmOneCameraCommon.h
  • kCamLibCtrlStreamBufNumQuery : palmOneCameraCommon.h
  • kCamLibCtrlStreamBufNumSet : palmOneCameraCommon.h
  • kCamLibCtrlStreamFormatGet : palmOneCameraCommon.h
  • kCamLibCtrlStreamFormatQuery : palmOneCameraCommon.h
  • kCamLibCtrlStreamFormatSet : palmOneCameraCommon.h
  • kCamLibCtrlStreamPreviewGet : palmOneCameraCommon.h
  • kCamLibCtrlStreamPreviewQuery : palmOneCameraCommon.h
  • kCamLibCtrlStreamPreviewSet : palmOneCameraCommon.h
  • kCamLibCtrlStreamSizeGet : palmOneCameraCommon.h
  • kCamLibCtrlStreamSizeQuery : palmOneCameraCommon.h
  • kCamLibCtrlStreamSizeSet : palmOneCameraCommon.h
  • kCamLibCtrlStreamStart : palmOneCameraCommon.h
  • kCamLibCtrlStreamStop : palmOneCameraCommon.h
  • kCamLibCtrlStreamUnlockFrame : palmOneCameraCommon.h
  • kCamLibCtrlStreamWaitForFrame : palmOneCameraCommon.h
  • kCamLibCtrlWhiteBalanceGet : palmOneCameraCommon.h
  • kCamLibCtrlWhiteBalanceQuery : palmOneCameraCommon.h
  • kCamLibCtrlWhiteBalanceSet : palmOneCameraCommon.h
  • kCamLibCtrlZoomGet : palmOneCameraCommon.h
  • kCamLibCtrlZoomQuery : palmOneCameraCommon.h
  • kCamLibCtrlZoomSet : palmOneCameraCommon.h
  • kCamLibEffectsBlackWhite : palmOneCameraCommon.h
  • kCamLibEffectsBluish : palmOneCameraCommon.h
  • kCamLibEffectsNegative : palmOneCameraCommon.h
  • kCamLibEffectsNormal : palmOneCameraCommon.h
  • kCamLibEffectsSepia : palmOneCameraCommon.h
  • kCamLibErrAllFramesLocked : palmOneCameraCommon.h
  • kCamLibErrBadParam : palmOneCameraCommon.h
  • kCamLibErrInternal : palmOneCameraCommon.h
  • kCamLibErrNoMemory : palmOneCameraCommon.h
  • kCamLibErrNoPower : palmOneCameraCommon.h
  • kCamLibErrNotCompatible : palmOneCameraCommon.h
  • kCamLibErrNotOpen : palmOneCameraCommon.h
  • kCamLibErrNotSupported : palmOneCameraCommon.h
  • kCamLibErrorClass : palmOneCameraCommon.h
  • kCamLibErrStillOpen : palmOneCameraCommon.h
  • kCamLibExposureAuto : palmOneCameraCommon.h
  • kCamLibExposureManual : palmOneCameraCommon.h
  • kCamLibFtrCaptureVersion : palmOneCameraCommon.h
  • kCamLibFtrVersionNum : palmOneCameraCommon.h
  • kCamLibImageSizeCIF : palmOneCameraCommon.h
  • kCamLibImageSizeQCIF : palmOneCameraCommon.h
  • kCamLibImageSizeQQVGA : palmOneCameraCommon.h
  • kCamLibImageSizeQVGA : palmOneCameraCommon.h
  • kCamLibImageSizeSXGA : palmOneCameraCommon.h
  • kCamLibImageSizeSXGA1024 : palmOneCameraCommon.h
  • kCamLibImageSizeSXGA960 : palmOneCameraCommon.h
  • kCamLibImageSizeVGA : palmOneCameraCommon.h
  • kCamLibLightingLow : palmOneCameraCommon.h
  • kCamLibLightingNormal : palmOneCameraCommon.h
  • kCamLibName : palmOneCameraCommon.h
  • kCamLibSaturationManual : palmOneCameraCommon.h
  • kCamLibSharpnessManual : palmOneCameraCommon.h
  • kCamLibShutterSpeedAuto : palmOneCameraCommon.h
  • kCamLibShutterSpeedManual : palmOneCameraCommon.h
  • kCamLibStatusInPreview : palmOneCameraCommon.h
  • kCamLibStatusInStillCapture : palmOneCameraCommon.h
  • kCamLibStatusInVideoCapture : palmOneCameraCommon.h
  • kCamLibStatusPoweredOn : palmOneCameraCommon.h
  • kCamLibStreamPreviewOff : palmOneCameraCommon.h
  • kCamLibStreamPreviewOn : palmOneCameraCommon.h
  • kCamLibTrapControl : palmOneCameraCommon.h
  • kCamLibTrapGetVersion : palmOneCameraCommon.h
  • kCamLibType : palmOneCameraCommon.h
  • kCamLibVersion : palmOneCameraCommon.h
  • kCamLibVersion1 : palmOneCameraCommon.h
  • kCamLibVersion2 : palmOneCameraCommon.h
  • kCamLibVersion3 : palmOneCameraCommon.h
  • kCamLibWhiteBalanceAuto : palmOneCameraCommon.h
  • kCamLibWhiteBalanceCloudy : palmOneCameraCommon.h
  • kCamLibWhiteBalanceExtra : palmOneCameraCommon.h
  • kCamLibWhiteBalanceFluorescent : palmOneCameraCommon.h
  • kCamLibWhiteBalanceIncandescent : palmOneCameraCommon.h
  • kCamLibWhiteBalanceIndoor : palmOneCameraCommon.h
  • kCamLibWhiteBalanceOutdoor : palmOneCameraCommon.h
  • kCamLibWhiteBalanceShade : palmOneCameraCommon.h
  • kCamLibWhiteBalanceSunny : palmOneCameraCommon.h
  • kCamLibWhiteBalanceTwilight : palmOneCameraCommon.h
  • kCamLibZoomManual : palmOneCameraCommon.h
  • kCamSliderCreator : palmOneCameraSlider.h
  • kCamSliderFlagsOpened : palmOneCameraSlider.h
  • kCamSliderFtrFlagsNum : palmOneCameraSlider.h
  • kCamSliderFtrVersionNum : palmOneCameraSlider.h
  • kCamSliderNotifyEvent : palmOneCameraSlider.h
  • kCamSliderVersion : palmOneCameraSlider.h
  • kCamSliderVersion1 : palmOneCameraSlider.h
  • kCarrierCustomizationCLibName : CarrierCustomLibTypes.h
  • kCarrierListDBName : CarrierCustomLibTypes.h
  • kCCLibType : CarrierCustomLibTypes.h
  • kCigarSmiley : SmartTextEngineDef.h
  • kClownSmiley : SmartTextEngineDef.h
  • kCodecErrAlignment : palmOneCodecPluginMgrCommon.h
  • kCodecErrBadParam : palmOneCodecPluginMgrCommon.h
  • kCodecErrBufferOverrun : palmOneCodecPluginMgrCommon.h
  • kCodecErrBufferUnderrun : palmOneCodecPluginMgrCommon.h
  • kCodecErrFrameError : palmOneCodecPluginMgrCommon.h
  • kCodecErrInvalidHeader : palmOneCodecPluginMgrCommon.h
  • kCodecErrInvalidState : palmOneCodecPluginMgrCommon.h
  • kCodecErrNoMemory : palmOneCodecPluginMgrCommon.h
  • kCodecErrParsing : palmOneCodecPluginMgrCommon.h
  • kCodecErrUnAuthorized : palmOneCodecPluginMgrCommon.h
  • kCodecErrUnknown : palmOneCodecPluginMgrCommon.h
  • kCodecMgrLibBadVersion : palmOneCodecPluginMgrCommon.h
  • kCodecMgrLibCreator : palmOneCodecPluginMgrCommon.h
  • kCodecMgrLibErrBadParam : palmOneCodecPluginMgrCommon.h
  • kCodecMgrLibErrInternal : palmOneCodecPluginMgrCommon.h
  • kCodecMgrLibErrorClass : palmOneCodecPluginMgrCommon.h
  • kCodecMgrLibErrStillOpen : palmOneCodecPluginMgrCommon.h
  • kCodecMgrLibName : palmOneCodecPluginMgrCommon.h
  • kCodecMgrLibNoCodec : palmOneCodecPluginMgrCommon.h
  • kCodecMgrLibNotSupported : palmOneCodecPluginMgrCommon.h
  • kCodecMgrLibTrapCreateSession : palmOneCodecPluginMgrCommon.h
  • kCodecMgrLibTrapCreateSessionByID : palmOneCodecPluginMgrCommon.h
  • kCodecMgrLibTrapCustomControl : palmOneCodecPluginMgrCommon.h
  • kCodecMgrLibTrapDeleteSession : palmOneCodecPluginMgrCommon.h
  • kCodecMgrLibTrapEncodeDecode : palmOneCodecPluginMgrCommon.h
  • kCodecMgrLibTrapEnumerateFormats : palmOneCodecPluginMgrCommon.h
  • kCodecMgrLibTrapGetMaxDestBufferSize : palmOneCodecPluginMgrCommon.h
  • kCodecMgrLibTrapGetSessionInfo : palmOneCodecPluginMgrCommon.h
  • kCodecMgrLibTrapIsFormatSupported : palmOneCodecPluginMgrCommon.h
  • kCodecMgrLibTrapLibAPIVersion : palmOneCodecPluginMgrCommon.h
  • kCodecMgrLibTrapResetSession : palmOneCodecPluginMgrCommon.h
  • kCodecMgrLibType : palmOneCodecPluginMgrCommon.h
  • kCodecMgrLibVersion : palmOneCodecPluginMgrCommon.h
  • kCodecMgrLibVersion3 : palmOneCodecPluginMgrCommon.h
  • kCodecPluginErrorClass : palmOneCodecPluginMgrCommon.h
  • kCodecSyncNotFound : palmOneCodecPluginMgrCommon.h
  • kDeltaCharacter : SmartTextEngineDef.h
  • kDevilSmiley : SmartTextEngineDef.h
  • kDexLibTrapClose : PalmDisplayExtent.h
  • kDexLibTrapDexGetDisplayAddress : PalmDisplayExtent.h
  • kDexLibTrapDexGetDisplayDimensions : PalmDisplayExtent.h
  • kDexLibTrapOpen : PalmDisplayExtent.h
  • keyBitExt1A : HsKeyTypes.h
  • keyBitExt1B : HsKeyTypes.h
  • keyBitExt1Bksp : HsKeyTypes.h
  • keyBitExt1C : HsKeyTypes.h
  • keyBitExt1D : HsKeyTypes.h
  • keyBitExt1E : HsKeyTypes.h
  • keyBitExt1Enter : HsKeyTypes.h
  • keyBitExt1F : HsKeyTypes.h
  • keyBitExt1G : HsKeyTypes.h
  • keyBitExt1H : HsKeyTypes.h
  • keyBitExt1I : HsKeyTypes.h
  • keyBitExt1J : HsKeyTypes.h
  • keyBitExt1K : HsKeyTypes.h
  • keyBitExt1L : HsKeyTypes.h
  • keyBitExt1M : HsKeyTypes.h
  • keyBitExt1N : HsKeyTypes.h
  • keyBitExt1O : HsKeyTypes.h
  • keyBitExt1Opt : HsKeyTypes.h
  • keyBitExt1P : HsKeyTypes.h
  • keyBitExt1Period : HsKeyTypes.h
  • keyBitExt1Q : HsKeyTypes.h
  • keyBitExt1R : HsKeyTypes.h
  • keyBitExt1S : HsKeyTypes.h
  • keyBitExt1Shift : HsKeyTypes.h
  • keyBitExt1Space : HsKeyTypes.h
  • keyBitExt1T : HsKeyTypes.h
  • keyBitExt1U : HsKeyTypes.h
  • keyBitExt1V : HsKeyTypes.h
  • keyBitExt1W : HsKeyTypes.h
  • keyBitExt1X : HsKeyTypes.h
  • keyBitExt1Y : HsKeyTypes.h
  • keyBitExt1Z : HsKeyTypes.h
  • keyBitExt2CmdMenu : HsKeyTypes.h
  • keyBitExt2Hard11 : HsKeyTypes.h
  • keyBitExt2Launcher : HsKeyTypes.h
  • keyBitExt2MfgTest : HsKeyTypes.h
  • keyBitExt2RShift : HsKeyTypes.h
  • keyBitExt2Side : HsKeyTypes.h
  • keyBitExt2Symbol : HsKeyTypes.h
  • keyBitExt2Unused6 : HsKeyTypes.h
  • keyBitExt2VolumeDown : HsKeyTypes.h
  • keyBitExt2VolumeUp : HsKeyTypes.h
  • keyBitExt2Zero : HsKeyTypes.h
  • keyBitHard5 : common/system/palmOneChars.h
  • keyBitNavLeft : common/system/palmOneNavigator.h
  • keyBitNavLRS : common/system/palmOneNavigator.h
  • keyBitNavRight : common/system/palmOneNavigator.h
  • keyBitNavSelect : common/system/palmOneNavigator.h
  • keyBitNumAntenna : HsKeyTypes.h
  • keyBitNumContrast : HsKeyTypes.h
  • keyBitNumCradle : HsKeyTypes.h
  • keyBitNumExt1A : HsKeyTypes.h
  • keyBitNumExt1B : HsKeyTypes.h
  • keyBitNumExt1Bksp : HsKeyTypes.h
  • keyBitNumExt1C : HsKeyTypes.h
  • keyBitNumExt1D : HsKeyTypes.h
  • keyBitNumExt1E : HsKeyTypes.h
  • keyBitNumExt1Enter : HsKeyTypes.h
  • keyBitNumExt1F : HsKeyTypes.h
  • keyBitNumExt1G : HsKeyTypes.h
  • keyBitNumExt1H : HsKeyTypes.h
  • keyBitNumExt1I : HsKeyTypes.h
  • keyBitNumExt1J : HsKeyTypes.h
  • keyBitNumExt1K : HsKeyTypes.h
  • keyBitNumExt1L : HsKeyTypes.h
  • keyBitNumExt1M : HsKeyTypes.h
  • keyBitNumExt1N : HsKeyTypes.h
  • keyBitNumExt1O : HsKeyTypes.h
  • keyBitNumExt1Opt : HsKeyTypes.h
  • keyBitNumExt1P : HsKeyTypes.h
  • keyBitNumExt1Period : HsKeyTypes.h
  • keyBitNumExt1Q : HsKeyTypes.h
  • keyBitNumExt1R : HsKeyTypes.h
  • keyBitNumExt1S : HsKeyTypes.h
  • keyBitNumExt1Shift : HsKeyTypes.h
  • keyBitNumExt1Space : HsKeyTypes.h
  • keyBitNumExt1T : HsKeyTypes.h
  • keyBitNumExt1U : HsKeyTypes.h
  • keyBitNumExt1V : HsKeyTypes.h
  • keyBitNumExt1W : HsKeyTypes.h
  • keyBitNumExt1X : HsKeyTypes.h
  • keyBitNumExt1Y : HsKeyTypes.h
  • keyBitNumExt1Z : HsKeyTypes.h
  • keyBitNumExt2CmdMenu : HsKeyTypes.h
  • keyBitNumExt2Hard11 : HsKeyTypes.h
  • keyBitNumExt2Launcher : HsKeyTypes.h
  • keyBitNumExt2MfgTest : HsKeyTypes.h
  • keyBitNumExt2RShift : HsKeyTypes.h
  • keyBitNumExt2Side : HsKeyTypes.h
  • keyBitNumExt2Symbol : HsKeyTypes.h
  • keyBitNumExt2Unused6 : HsKeyTypes.h
  • keyBitNumExt2VolumeDown : HsKeyTypes.h
  • keyBitNumExt2VolumeUp : HsKeyTypes.h
  • keyBitNumExt2Zero : HsKeyTypes.h
  • keyBitNumHard1 : HsKeyTypes.h
  • keyBitNumHard2 : HsKeyTypes.h
  • keyBitNumHard3 : HsKeyTypes.h
  • keyBitNumHard4 : HsKeyTypes.h
  • keyBitNumJogBack : HsKeyTypes.h
  • keyBitNumJogDown : HsKeyTypes.h
  • keyBitNumJogPress : HsKeyTypes.h
  • keyBitNumJogUp : HsKeyTypes.h
  • keyBitNumPageDown : HsKeyTypes.h
  • keyBitNumPageUp : HsKeyTypes.h
  • keyBitNumPower : HsKeyTypes.h
  • keyBitNumRockerCenter : HsKeyTypes.h
  • keyBitNumRockerDown : HsKeyTypes.h
  • keyBitNumRockerLeft : HsKeyTypes.h
  • keyBitNumRockerRight : HsKeyTypes.h
  • keyBitNumRockerUp : HsKeyTypes.h
  • keyBitNumUnused : HsKeyTypes.h
  • keyBitRockerCenter : HsKeyCommon.h
  • keyBitRockerDown : HsKeyCommon.h
  • keyBitRockerLeft : HsKeyCommon.h
  • keyBitRockerRight : HsKeyCommon.h
  • keyBitRockerUp : HsKeyCommon.h
  • keyBitsAllExt1 : HsKeyTypes.h
  • keyBitsAllExt2 : HsKeyTypes.h
  • keyBitThumbWheelBack : HsKeyCommon.h
  • keyBitThumbWheelDown : HsKeyCommon.h
  • keyBitThumbWheelPress : HsKeyCommon.h
  • keyBitThumbWheelUp : HsKeyCommon.h
  • kFileBrowserLibAPIVersion0 : FileBrowserLibCommon.h
  • kFileBrowserLibAPIVersion1 : FileBrowserLibCommon.h
  • kFileBrowserLibCtlGetVersion : FileBrowserLibCommon.h
  • kFileBrowserLibErrCantFind : FileBrowserLibCommon.h
  • kFileBrowserLibErrCantOpen : FileBrowserLibCommon.h
  • kFileBrowserLibErrCantParse : FileBrowserLibCommon.h
  • kFileBrowserLibErrInternal : FileBrowserLibCommon.h
  • kFileBrowserLibErrMemError : FileBrowserLibCommon.h
  • kFileBrowserLibErrorClass : FileBrowserLibCommon.h
  • kFileBrowserLibErrPathTooLong : FileBrowserLibCommon.h
  • kFileBrowserLibErrStillOpen : FileBrowserLibCommon.h
  • kFileBrowserLibFlagNoDirChange : FileBrowserLibCommon.h
  • kFileBrowserLibFlagNoFiles : FileBrowserLibCommon.h
  • kFileBrowserLibFlagNoFolders : FileBrowserLibCommon.h
  • kFileBrowserLibFlagNoNewFolder : FileBrowserLibCommon.h
  • kFileBrowserLibFlagNoSubDir : FileBrowserLibCommon.h
  • kFileBrowserLibFlagOneVolume : FileBrowserLibCommon.h
  • kFileBrowserLibFlagPromptOverwrite : FileBrowserLibCommon.h
  • kFileBrowserLibFlagRequireExtension : FileBrowserLibCommon.h
  • kFileBrowserLibMaxPathLength : FileBrowserLibCommon.h
  • kFileBrowserLibName : FileBrowserLibCommon.h
  • kFileBrowserLibPathBufferSize : FileBrowserLibCommon.h
  • kFileBrowserLibTrapParseFileURL : FileBrowserLibCommon.h
  • kFileBrowserLibTrapShowMultiselectDialog : FileBrowserLibCommon.h
  • kFileBrowserLibTrapShowOpenDialog : FileBrowserLibCommon.h
  • kFileBrowserLibTrapShowSaveAsDialog : FileBrowserLibCommon.h
  • kFlipSmiley : SmartTextEngineDef.h
  • kFrmNavHeaderFlagsAppFocusStartState : HsNavCommon.h
  • kFrmNavHeaderFlagsAppFocusStartStateValue : HsNavCommon.h
  • kFrmNavHeaderFlagsAutoGenerated : HsNavCommon.h
  • kFrmNavHeaderFlagsDefaultStartStateValue : HsNavCommon.h
  • kFrmNavHeaderFlagsInvalidStartStateValue : HsNavCommon.h
  • kFrmNavHeaderFlagsObjectFocusStartState : HsNavCommon.h
  • kFrmNavHeaderFlagsObjectFocusStartStateValue : HsNavCommon.h
  • kFrmNavHeaderFlagsStartStateMask : HsNavCommon.h
  • kFrmNavInfoVersion : HsNavCommon.h
  • kFrmNavObjectFlagsForceInteractionMode : HsNavCommon.h
  • kFrmNavObjectFlagsIsBigButton : HsNavCommon.h
  • kFrmNavObjectFlagsSkip : HsNavCommon.h
  • kFrmNavStateFlagsInteractionMode : HsNavCommon.h
  • kFrmNavStateFlagsObjectFocusMode : HsNavCommon.h
  • kFrownSmiley : SmartTextEngineDef.h
  • kFullSizeImageHeight : ImageLibCommon.h
  • kFullSizeImageWidth : ImageLibCommon.h
  • kGammaCharacter : SmartTextEngineDef.h
  • kGenericMCCMNC : CarrierCustomLibTypes.h
  • kGoLcdLibTrapClose : PalmGoLCDCommon.h
  • kGoLcdLibTrapGetBounds : PalmGoLCDCommon.h
  • kGoLcdLibTrapGetGsiState : PalmGoLCDCommon.h
  • kGoLcdLibTrapGetInkState : PalmGoLCDCommon.h
  • kGoLcdLibTrapGetStatus : PalmGoLCDCommon.h
  • kGoLcdLibTrapGetTimeout : PalmGoLCDCommon.h
  • kGoLcdLibTrapOpen : PalmGoLCDCommon.h
  • kGoLcdLibTrapSetBounds : PalmGoLCDCommon.h
  • kGoLcdLibTrapSetGsiState : PalmGoLCDCommon.h
  • kGoLcdLibTrapSetInkState : PalmGoLCDCommon.h
  • kGoLcdLibTrapSetStatus : PalmGoLCDCommon.h
  • kGoLcdLibTrapSetTimeout : PalmGoLCDCommon.h
  • kHALLEDCapcitySleepMultiColor : PalmLED.h
  • kHALLEDCapcitySleepOn : PalmLED.h
  • kHALLEDCapcitySleepPattern : PalmLED.h
  • kHALLEDCapcitySleepPatternSetting : PalmLED.h
  • kHALLEDCapcityUnderSleep : PalmLED.h
  • kHALLEDPropertySleepColorAmberWhite : PalmLED.h
  • kHALLEDPropertySleepColorBlue : PalmLED.h
  • kHALLEDPropertySleepColorGreen : PalmLED.h
  • kHALLEDPropertySleepColorRed : PalmLED.h
  • kHALLEDPropertySleepOn : PalmLED.h
  • kHALLEDPropertySleepPattern : PalmLED.h
  • kHALLEDPropertySleepReserve : PalmLED.h
  • kHALLEDPropertyUnderSleep : PalmLED.h
  • kHeartSmiley : SmartTextEngineDef.h
  • kHelperServiceClassIDMMS : MmsHelperCommon.h
  • kHiResTimeErrorClass : palmOneHiResTimerCommon.h , PalmHiResTime.h
  • kHiResTimeLibCreator : palmOneHiResTimerCommon.h , PalmHiResTime.h
  • kHiResTimeLibErrBadParam : palmOneHiResTimerCommon.h
  • kHiResTimeLibErrNotAvailable : palmOneHiResTimerCommon.h
  • kHiResTimeLibErrNotOpen : palmOneHiResTimerCommon.h
  • kHiResTimeLibErrStillOpen : palmOneHiResTimerCommon.h
  • kHiResTimeLibName : palmOneHiResTimerCommon.h , PalmHiResTime.h
  • kHiResTimeLibType : palmOneHiResTimerCommon.h , PalmHiResTime.h
  • kHiResTimeLibVersion : palmOneHiResTimerCommon.h , PalmHiResTime.h
  • kHiResTimeLibVersion1 : palmOneHiResTimerCommon.h , PalmHiResTime.h
  • kHiResTimeLibVersion2 : palmOneHiResTimerCommon.h
  • kHRLibTrapTimerGetTime : palmOneHiResTimerCommon.h , PalmHiResTime.h
  • kHRLibTrapTimerTicksPerSecond : palmOneHiResTimerCommon.h , PalmHiResTime.h
  • kHsSoundLibTrapClose : HsSoundLibTraps.h
  • kHsSoundLibTrapFormatPlay : HsSoundLibTraps.h
  • kHsSoundLibTrapFormatRecord : HsSoundLibTraps.h
  • kHsSoundLibTrapGetUserVolume : HsSoundLibTraps.h
  • kHsSoundLibTrapGetVersion : HsSoundLibTraps.h
  • kHsSoundLibTrapOpen : HsSoundLibTraps.h
  • kHsSoundLibTrapPortGetInfo : HsSoundLibTraps.h
  • kHsSoundLibTrapPortSetParam : HsSoundLibTraps.h
  • kHsSoundLibTrapSetUserVolume : HsSoundLibTraps.h
  • kHsSoundLibTrapSwitchGetPort : HsSoundLibTraps.h
  • kHsSoundLibTrapSwitchSetPort : HsSoundLibTraps.h
  • kHsSoundLibTrapTonePlay : HsSoundLibTraps.h
  • kHsSoundLibTrapToneStop : HsSoundLibTraps.h
  • kHtmlLibTrapAbortRenderData : HtmlLibTrap.h
  • kHtmlLibTrapAddImageData : HtmlLibTrap.h
  • kHtmlLibTrapAddTextData : HtmlLibTrap.h
  • kHtmlLibTrapCanScroll : HtmlLibTrap.h
  • kHtmlLibTrapClearScreen : HtmlLibTrap.h
  • kHtmlLibTrapClose : HtmlLibTrap.h
  • kHtmlLibTrapCreateContentObject : HtmlLibTrap.h
  • kHtmlLibTrapDestroyContentObject : HtmlLibTrap.h
  • kHtmlLibTrapFinalize : HtmlLibTrap.h
  • kHtmlLibTrapFindText : HtmlLibTrap.h
  • kHtmlLibTrapGetTargetInfo : HtmlLibTrap.h
  • kHtmlLibTrapGetTextSelection : HtmlLibTrap.h
  • kHtmlLibTrapGetVScrollPosition : HtmlLibTrap.h
  • kHtmlLibTrapInitialize : HtmlLibTrap.h
  • kHtmlLibTrapInitializeWithHeapSize : HtmlLibTrap.h
  • kHtmlLibTrapNotifyUIEvent : HtmlLibTrap.h
  • kHtmlLibTrapOpen : HtmlLibTrap.h
  • kHtmlLibTrapProgress : HtmlLibTrap.h
  • kHtmlLibTrapRedrawScreen : HtmlLibTrap.h
  • kHtmlLibTrapRenderData : HtmlLibTrap.h
  • kHtmlLibTrapResetFocusInfo : HtmlLibTrap.h
  • kHtmlLibTrapResizeScreen : HtmlLibTrap.h
  • kHtmlLibTrapSetBiggerFont : HtmlLibTrap.h
  • kHtmlLibTrapSetDisplayMode : HtmlLibTrap.h
  • kHtmlLibTrapSetFocusStatus : HtmlLibTrap.h
  • kHtmlLibTrapSetFormWidgetProc : HtmlLibTrap.h
  • kHtmlLibTrapSetImageMemoryLimit : HtmlLibTrap.h
  • kHtmlLibTrapSetInclusionCallback : HtmlLibTrap.h
  • kHtmlLibTrapSetLinkSelectionCallback : HtmlLibTrap.h
  • kHtmlLibTrapSetScanPhoneNumberCallback : HtmlLibTrap.h
  • kHtmlLibTrapSetScrollbarMode : HtmlLibTrap.h
  • kHtmlLibTrapSetScrollbars : HtmlLibTrap.h
  • kHtmlLibTrapSetSubmitFormCallback : HtmlLibTrap.h
  • kHtmlLibTrapSetVScrollPosition : HtmlLibTrap.h
  • kHtmlLibTrapSleep : HtmlLibTrap.h
  • kHtmlLibTrapWake : HtmlLibTrap.h
  • kHTTPLibTrapAuthCacheGetChallengeTokenSS : HS_HTTPLibConst.h
  • kHTTPLibTrapAuthInfoPass : HS_HTTPLibConst.h
  • kHTTPLibTrapAuthInfoRealm : HS_HTTPLibConst.h
  • kHTTPLibTrapAuthInfoTidy : HS_HTTPLibConst.h
  • kHTTPLibTrapAuthInfoUser : HS_HTTPLibConst.h
  • kHTTPLibTrapCert_EndPeekIssuerRDN : HS_HTTPLibConst.h
  • kHTTPLibTrapCert_EndPeekSubjectRDN : HS_HTTPLibConst.h
  • kHTTPLibTrapCert_PeekRSAPublicKeyBits : HS_HTTPLibConst.h
  • kHTTPLibTrapCert_PeekValidityEnd : HS_HTTPLibConst.h
  • kHTTPLibTrapCert_PeekValidityStart : HS_HTTPLibConst.h
  • kHTTPLibTrapCertBeginPeekIssuerRDN : HS_HTTPLibConst.h
  • kHTTPLibTrapCertBeginPeekSubjectRDN : HS_HTTPLibConst.h
  • kHTTPLibTrapCertListBeginDecode : HS_HTTPLibConst.h
  • kHTTPLibTrapCertListClone : HS_HTTPLibConst.h
  • kHTTPLibTrapCertListDelete : HS_HTTPLibConst.h
  • kHTTPLibTrapCertListEndDecode : HS_HTTPLibConst.h
  • kHTTPLibTrapCertListGetCipherInfo : HS_HTTPLibConst.h
  • kHTTPLibTrapCertListImportCert : HS_HTTPLibConst.h
  • kHTTPLibTrapCertListLength : HS_HTTPLibConst.h
  • kHTTPLibTrapCertListLock : HS_HTTPLibConst.h
  • kHTTPLibTrapCertListNew : HS_HTTPLibConst.h
  • kHTTPLibTrapCertListType : HS_HTTPLibConst.h
  • kHTTPLibTrapCertListUnlock : HS_HTTPLibConst.h
  • kHTTPLibTrapCertPeekIssuerRDN : HS_HTTPLibConst.h
  • kHTTPLibTrapCertPeekIssuerRDNStrType : HS_HTTPLibConst.h
  • kHTTPLibTrapCertPeekSerialNumber : HS_HTTPLibConst.h
  • kHTTPLibTrapCertPeekSignAlgo : HS_HTTPLibConst.h
  • kHTTPLibTrapCertPeekSubjectRDN : HS_HTTPLibConst.h
  • kHTTPLibTrapCertPeekSubjectRDNStrType : HS_HTTPLibConst.h
  • kHTTPLibTrapCertPeekVersion : HS_HTTPLibConst.h
  • kHTTPLibTrapClearDNSCache : HS_HTTPLibConst.h
  • kHTTPLibTrapClientCertListClone : HS_HTTPLibConst.h
  • kHTTPLibTrapClientCertListDelete : HS_HTTPLibConst.h
  • kHTTPLibTrapClientCertListIsValid : HS_HTTPLibConst.h
  • kHTTPLibTrapClientCertListLength : HS_HTTPLibConst.h
  • kHTTPLibTrapClientCertListNew : HS_HTTPLibConst.h
  • kHTTPLibTrapClientCertListSetValid : HS_HTTPLibConst.h
  • kHTTPLibTrapClientCertSelect : HS_HTTPLibConst.h
  • kHTTPLibTrapClose : HS_HTTPLibConst.h
  • kHTTPLibTrapCloseAllKeepAlive : HS_HTTPLibConst.h
  • kHTTPLibTrapCookieMakeEmpty : HS_HTTPLibConst.h
  • kHTTPLibTrapDataHandle_Delete : HS_HTTPLibConst.h
  • kHTTPLibTrapDataHandle_Length : HS_HTTPLibConst.h
  • kHTTPLibTrapDataHandle_Lock : HS_HTTPLibConst.h
  • kHTTPLibTrapDataHandle_Unlock : HS_HTTPLibConst.h
  • kHTTPLibTrapFinalize : HS_HTTPLibConst.h
  • kHTTPLibTrapFindAuthCandidate : HS_HTTPLibConst.h
  • kHTTPLibTrapFindAuthInfo : HS_HTTPLibConst.h
  • kHTTPLibTrapFixedString_Delete : HS_HTTPLibConst.h
  • kHTTPLibTrapFixedString_Length : HS_HTTPLibConst.h
  • kHTTPLibTrapFixedString_Lock : HS_HTTPLibConst.h
  • kHTTPLibTrapFixedString_Unlock : HS_HTTPLibConst.h
  • kHTTPLibTrapFixedStringNew : HS_HTTPLibConst.h
  • kHTTPLibTrapHeaderSplitByX : HS_HTTPLibConst.h
  • kHTTPLibTrapInitialize : HS_HTTPLibConst.h
  • kHTTPLibTrapIsHTTP11OverProxy : HS_HTTPLibConst.h
  • kHTTPLibTrapIsSendCookie : HS_HTTPLibConst.h
  • kHTTPLibTrapIsSendReferer : HS_HTTPLibConst.h
  • kHTTPLibTrapIsUseProxy : HS_HTTPLibConst.h
  • kHTTPLibTrapLoadCookiesEntries : HS_HTTPLibConst.h
  • kHTTPLibTrapMakeAuthInfo : HS_HTTPLibConst.h
  • kHTTPLibTrapMakeCertList : HS_HTTPLibConst.h
  • kHTTPLibTrapMakeCookiesString : HS_HTTPLibConst.h
  • kHTTPLibTrapMakeProxy : HS_HTTPLibConst.h
  • kHTTPLibTrapOpen : HS_HTTPLibConst.h
  • kHTTPLibTrapOpenCount : HS_HTTPLibConst.h
  • kHTTPLibTrapRegisterSSLClass : HS_HTTPLibConst.h
  • kHTTPLibTrapSaveCookiesEntries : HS_HTTPLibConst.h
  • kHTTPLibTrapServerCertConfirm : HS_HTTPLibConst.h
  • kHTTPLibTrapSetConnectTimeOut : HS_HTTPLibConst.h
  • kHTTPLibTrapSetCookie : HS_HTTPLibConst.h
  • kHTTPLibTrapSetCookieMax : HS_HTTPLibConst.h
  • kHTTPLibTrapSetCookieMode : HS_HTTPLibConst.h
  • kHTTPLibTrapSetCookieX : HS_HTTPLibConst.h
  • kHTTPLibTrapSetDefaultHeaders : HS_HTTPLibConst.h
  • kHTTPLibTrapSetDNSMaxRetry : HS_HTTPLibConst.h
  • kHTTPLibTrapSetDNSRetryInterval : HS_HTTPLibConst.h
  • kHTTPLibTrapSetHTTP11OverProxy : HS_HTTPLibConst.h
  • kHTTPLibTrapSetHTTPPort : HS_HTTPLibConst.h
  • kHTTPLibTrapSetHTTPSPort : HS_HTTPLibConst.h
  • kHTTPLibTrapSetMaxKeepAliveTimeout : HS_HTTPLibConst.h
  • kHTTPLibTrapSetMaxRequestBody : HS_HTTPLibConst.h
  • kHTTPLibTrapSetMaxRequestHeader : HS_HTTPLibConst.h
  • kHTTPLibTrapSetNetLibProc : HS_HTTPLibConst.h
  • kHTTPLibTrapSetProxy : HS_HTTPLibConst.h
  • kHTTPLibTrapSetReqTimeOut : HS_HTTPLibConst.h
  • kHTTPLibTrapSetRspTimeOut : HS_HTTPLibConst.h
  • kHTTPLibTrapSetSendCookie : HS_HTTPLibConst.h
  • kHTTPLibTrapSetSendProxyKeepAlive : HS_HTTPLibConst.h
  • kHTTPLibTrapSetSendReferer : HS_HTTPLibConst.h
  • kHTTPLibTrapSetSSLClientCertSelectProc : HS_HTTPLibConst.h
  • kHTTPLibTrapSetSSLServerCertConfirmProc : HS_HTTPLibConst.h
  • kHTTPLibTrapSetSSLVersionFlag : HS_HTTPLibConst.h
  • kHTTPLibTrapSetTunnelingCallback : HS_HTTPLibConst.h
  • kHTTPLibTrapSetUseProxy : HS_HTTPLibConst.h
  • kHTTPLibTrapSetUserAgent : HS_HTTPLibConst.h
  • kHTTPLibTrapSetUseragentSelectionRule : HS_HTTPLibConst.h
  • kHTTPLibTrapSetUserPass : HS_HTTPLibConst.h
  • kHTTPLibTrapSetUserPassX : HS_HTTPLibConst.h
  • kHTTPLibTrapSetWakeUpCallback : HS_HTTPLibConst.h
  • kHTTPLibTrapSleep : HS_HTTPLibConst.h
  • kHTTPLibTrapSSLClass : HS_HTTPLibConst.h
  • kHTTPLibTrapSSLCloseCertDB : HS_HTTPLibConst.h
  • kHTTPLibTrapSSLOpenCertDB : HS_HTTPLibConst.h
  • kHTTPLibTrapSSLTimeout : HS_HTTPLibConst.h
  • kHTTPLibTrapStreamAddHeader : HS_HTTPLibConst.h
  • kHTTPLibTrapStreamAddHeaderLine : HS_HTTPLibConst.h
  • kHTTPLibTrapStreamClose : HS_HTTPLibConst.h
  • kHTTPLibTrapStreamCreateRequest : HS_HTTPLibConst.h
  • kHTTPLibTrapStreamCreateRequestWithChunkEncoding : HS_HTTPLibConst.h
  • kHTTPLibTrapStreamDelete : HS_HTTPLibConst.h
  • kHTTPLibTrapStreamGetContentLength : HS_HTTPLibConst.h
  • kHTTPLibTrapStreamGetEntityLength : HS_HTTPLibConst.h
  • kHTTPLibTrapStreamGetFlag : HS_HTTPLibConst.h
  • kHTTPLibTrapStreamGetHeader : HS_HTTPLibConst.h
  • kHTTPLibTrapStreamGetHeaderWithOffset : HS_HTTPLibConst.h
  • kHTTPLibTrapStreamGetRequestSent : HS_HTTPLibConst.h
  • kHTTPLibTrapStreamGetResponseHeader : HS_HTTPLibConst.h
  • kHTTPLibTrapStreamGetResponseHeaderLength : HS_HTTPLibConst.h
  • kHTTPLibTrapStreamGetScheme : HS_HTTPLibConst.h
  • kHTTPLibTrapStreamGetState : HS_HTTPLibConst.h
  • kHTTPLibTrapStreamGetStatusCode : HS_HTTPLibConst.h
  • kHTTPLibTrapStreamIsHeaderReceived : HS_HTTPLibConst.h
  • kHTTPLibTrapStreamNew : HS_HTTPLibConst.h
  • kHTTPLibTrapStreamReceiveResponse : HS_HTTPLibConst.h
  • kHTTPLibTrapStreamResumeTimer : HS_HTTPLibConst.h
  • kHTTPLibTrapStreamSendRequest : HS_HTTPLibConst.h
  • kHTTPLibTrapStreamSendRequestWithChunkEncoding : HS_HTTPLibConst.h
  • kHTTPLibTrapStreamSendRequestWithPostData : HS_HTTPLibConst.h
  • kHTTPLibTrapStreamSetPostData : HS_HTTPLibConst.h
  • kHTTPLibTrapStreamSuspendTimer : HS_HTTPLibConst.h
  • kHTTPLibTrapString_Delete : HS_HTTPLibConst.h
  • kHTTPLibTrapString_Length : HS_HTTPLibConst.h
  • kHTTPLibTrapString_Lock : HS_HTTPLibConst.h
  • kHTTPLibTrapString_Unlock : HS_HTTPLibConst.h
  • kHTTPLibTrapStringNew : HS_HTTPLibConst.h
  • kHTTPLibTrapURLString_Delete : HS_HTTPLibConst.h
  • kHTTPLibTrapURLString_Length : HS_HTTPLibConst.h
  • kHTTPLibTrapURLString_Lock : HS_HTTPLibConst.h
  • kHTTPLibTrapURLString_Unlock : HS_HTTPLibConst.h
  • kHTTPLibTrapURLStringNew : HS_HTTPLibConst.h
  • kHTTPLibTrapVHandle_Delete : HS_HTTPLibConst.h
  • kHTTPLibTrapVHandle_Length : HS_HTTPLibConst.h
  • kHTTPLibTrapVHandle_Lock : HS_HTTPLibConst.h
  • kHTTPLibTrapVHandle_Unlock : HS_HTTPLibConst.h
  • kHTTPLibTrapWake : HS_HTTPLibConst.h
  • kHWUtilsCreator : HardwareUtils68K.h
  • kHWUtilsName : HardwareUtils68K.h
  • kHWUtilsTrapBlinkLED : HardwareUtils68K.h
  • kHWUtilsTrapClose : HardwareUtils68K.h
  • kHWUtilsTrapEnableDisplay : HardwareUtils68K.h
  • kHWUtilsTrapGetDisplayState : HardwareUtils68K.h
  • kHWUtilsTrapOpen : HardwareUtils68K.h
  • kHWUtilsTrapSetBlinkRate : HardwareUtils68K.h
  • kHWUtilsType : HardwareUtils68K.h
  • kImageFilenameLength : ImageLibCommon.h
  • kImageLibTrapBitmapDelete : ImageLibTraps.h
  • kImageLibTrapCameraExists : ImageLibTraps.h
  • kImageLibTrapCheckLockedImages : ImageLibTraps.h
  • kImageLibTrapClose : ImageLibTraps.h
  • kImageLibTrapCopyImage : ImageLibTraps.h
  • kImageLibTrapCopyImageFromVFS : ImageLibTraps.h
  • kImageLibTrapCopyImageToBuffer : ImageLibTraps.h
  • kImageLibTrapCopyImageToFile : ImageLibTraps.h
  • kImageLibTrapCopyImageToVFS : ImageLibTraps.h
  • kImageLibTrapDeleteImage : ImageLibTraps.h
  • kImageLibTrapDoAttachImageDialog : ImageLibTraps.h
  • kImageLibTrapDoInfoDialog : ImageLibTraps.h
  • kImageLibTrapDoNoteDialog : ImageLibTraps.h
  • kImageLibTrapDrawJPEG : ImageLibTraps.h
  • kImageLibTrapFindImageByID : ImageLibTraps.h
  • kImageLibTrapGetAveragePictureSize : ImageLibTraps.h
  • kImageLibTrapGetDimensions : ImageLibTraps.h
  • kImageLibTrapGetDimensionsJPEG : ImageLibTraps.h
  • kImageLibTrapGetDimensionsVFS : ImageLibTraps.h
  • kImageLibTrapGetImageDatabases : ImageLibTraps.h
  • kImageLibTrapGetImageID : ImageLibTraps.h
  • kImageLibTrapGetImageInfo : ImageLibTraps.h
  • kImageLibTrapGetJPEGQuality : ImageLibTraps.h
  • kImageLibTrapGetNoteFont : ImageLibTraps.h
  • kImageLibTrapGetVersion : ImageLibTraps.h
  • kImageLibTrapImageBitmapCreate : ImageLibTraps.h
  • kImageLibTrapImageBitmapCreateFromVFS : ImageLibTraps.h
  • kImageLibTrapImageBitmapFill : ImageLibTraps.h
  • kImageLibTrapImageBitmapFillFromVFS : ImageLibTraps.h
  • kImageLibTrapImageCapture : ImageLibTraps.h
  • kImageLibTrapImageDraw : ImageLibTraps.h
  • kImageLibTrapImageDrawFromVFS : ImageLibTraps.h
  • kImageLibTrapImageSave : ImageLibTraps.h
  • kImageLibTrapInsertImageFromBuffer : ImageLibTraps.h
  • kImageLibTrapInsertImageFromFile : ImageLibTraps.h
  • kImageLibTrapIterateImages : ImageLibTraps.h
  • kImageLibTrapIterateVFSImages : ImageLibTraps.h
  • kImageLibTrapIterDeleteImage : ImageLibTraps.h
  • kImageLibTrapIterDrawImage : ImageLibTraps.h
  • kImageLibTrapIterDrawThumbnail : ImageLibTraps.h
  • kImageLibTrapIterFree : ImageLibTraps.h
  • kImagelibTrapIterGetCount : ImageLibTraps.h
  • kImageLibTrapIterGetDimensions : ImageLibTraps.h
  • kImageLibTrapIterGetImageInfo : ImageLibTraps.h
  • kImageLibTrapIterRefresh : ImageLibTraps.h
  • kImageLibTrapIterRemoveImage : ImageLibTraps.h
  • kImageLibTrapIterResize : ImageLibTraps.h
  • kImageLibTrapIterSearch : ImageLibTraps.h
  • kImageLibTrapIterSort : ImageLibTraps.h
  • kImageLibTrapLockImage : ImageLibTraps.h
  • kImageLibTrapOpen : ImageLibTraps.h
  • kImageLibTrapPreviewBitmapCreate : ImageLibTraps.h
  • kImageLibTrapPreviewBitmapFill : ImageLibTraps.h
  • kImageLibTrapPreviewDraw : ImageLibTraps.h
  • kImageLibTrapPreviewStart : ImageLibTraps.h
  • kImageLibTrapPreviewStop : ImageLibTraps.h
  • kImageLibTrapResize : ImageLibTraps.h
  • kImageLibTrapResizeImage : ImageLibTraps.h
  • kImageLibTrapResizeJPEG : ImageLibTraps.h
  • kImageLibTrapResizeVFS : ImageLibTraps.h
  • kImageLibTrapSetImageID : ImageLibTraps.h
  • kImageLibTrapSetImageInfo : ImageLibTraps.h
  • kImageLibTrapSetJPEGQuality : ImageLibTraps.h
  • kImageLibTrapSetNoteFont : ImageLibTraps.h
  • kImageLibTrapSetProgressCallback : ImageLibTraps.h
  • kImageLibTrapThumbnailBitmapCreate : ImageLibTraps.h
  • kImageLibTrapThumbnailBitmapCreateFromVFS : ImageLibTraps.h
  • kImageLibTrapThumbnailBitmapFill : ImageLibTraps.h
  • kImageLibTrapThumbnailBitmapFillFromVFS : ImageLibTraps.h
  • kImageLibTrapThumbnailDraw : ImageLibTraps.h
  • kImageLibTrapThumbnailDrawFromVFS : ImageLibTraps.h
  • kImageLibTrapTurnCameraOff : ImageLibTraps.h
  • kInvalidRecIndex : ImageLibCommon.h
  • kIOTACertMaxBlockLen : HsPhoneIOTATypes.h
  • kIOTACertMaxBlocks : HsPhoneIOTATypes.h
  • kIOTANaiIMStoreMaxBlocks : HsPhoneIOTATypes.h
  • kIOTANaiPpgMaxBlocks : HsPhoneIOTATypes.h
  • kIOTANaiSipDataxchMaxBlocks : HsPhoneIOTATypes.h
  • kIOTANaiSipDdatgwyMaxBlocks : HsPhoneIOTATypes.h
  • kIOTANaiSipEdgePxyMaxBlocks : HsPhoneIOTATypes.h
  • kIOTAPhnSipRetryCntMaxBlocks : HsPhoneIOTATypes.h
  • kIOTAPhnSipRetryCntMaxLen : HsPhoneIOTATypes.h
  • kIOTAPhnSipRetryTimerMaxBloacks : HsPhoneIOTATypes.h
  • kIOTAPhnSipRetryTimerMaxLen : HsPhoneIOTATypes.h
  • kIOTAProxyADDRMaxLen : HsPhoneIOTATypes.h
  • kIOTAPxyAddrWdpMaxBlocks : HsPhoneIOTATypes.h
  • kIOTASipCfgBlocks : HsPhoneIOTATypes.h
  • kIOTATrustedDomainMaxLen : HsPhoneIOTATypes.h
  • kIOTAUrlArrayMaxLen : HsPhoneIOTATypes.h
  • kIOTAUrlMaxLen : HsPhoneIOTATypes.h
  • kJPEGOperation : ImageLibCommon.h
  • kLambdaCharacter : SmartTextEngineDef.h
  • kLcdOverlayLibCreator : palmOneLcdOverlayCommon.h , PalmLcdOverlay.h
  • kLcdOverlayLibCtrlDraw : PalmLcdOverlay.h , palmOneLcdOverlayCommon.h
  • kLcdOverlayLibCtrlFormatGet : palmOneLcdOverlayCommon.h , PalmLcdOverlay.h
  • kLcdOverlayLibCtrlFormatQuery : PalmLcdOverlay.h , palmOneLcdOverlayCommon.h
  • kLcdOverlayLibCtrlFormatSet : PalmLcdOverlay.h , palmOneLcdOverlayCommon.h
  • kLcdOverlayLibCtrlRectGet : PalmLcdOverlay.h , palmOneLcdOverlayCommon.h
  • kLcdOverlayLibCtrlRectSet : palmOneLcdOverlayCommon.h , PalmLcdOverlay.h
  • kLcdOverlayLibCtrlStart : palmOneLcdOverlayCommon.h , PalmLcdOverlay.h
  • kLcdOverlayLibCtrlStop : PalmLcdOverlay.h , palmOneLcdOverlayCommon.h
  • kLcdOverlayLibDataFormatRGB565 : PalmLcdOverlay.h , palmOneLcdOverlayCommon.h
  • kLcdOverlayLibDataFormatYCbCr420 : PalmLcdOverlay.h , palmOneLcdOverlayCommon.h
  • kLcdOverlayLibDataFormatYCbCr420Planar : PalmLcdOverlay.h , palmOneLcdOverlayCommon.h
  • kLcdOverlayLibDataFormatYCbCr422 : PalmLcdOverlay.h , palmOneLcdOverlayCommon.h
  • kLcdOverlayLibDataFormatYCbCr422Planar : PalmLcdOverlay.h , palmOneLcdOverlayCommon.h
  • kLcdOverlayLibDataFormatYCbCr444 : palmOneLcdOverlayCommon.h , PalmLcdOverlay.h
  • kLcdOverlayLibDataFormatYCbCr444Planar : PalmLcdOverlay.h , palmOneLcdOverlayCommon.h
  • kLcdOverlayLibErrBadParam : palmOneLcdOverlayCommon.h , PalmLcdOverlay.h
  • kLcdOverlayLibErrInternal : PalmLcdOverlay.h , palmOneLcdOverlayCommon.h
  • kLcdOverlayLibErrNoMemory : PalmLcdOverlay.h , palmOneLcdOverlayCommon.h
  • kLcdOverlayLibErrNotCompatible : palmOneLcdOverlayCommon.h , PalmLcdOverlay.h
  • kLcdOverlayLibErrNotOpen : palmOneLcdOverlayCommon.h , PalmLcdOverlay.h
  • kLcdOverlayLibErrNotSupported : palmOneLcdOverlayCommon.h , PalmLcdOverlay.h
  • kLcdOverlayLibErrorClass : palmOneLcdOverlayCommon.h , PalmLcdOverlay.h
  • kLcdOverlayLibErrStillOpen : palmOneLcdOverlayCommon.h , PalmLcdOverlay.h
  • kLcdOverlayLibName : palmOneLcdOverlayCommon.h , PalmLcdOverlay.h
  • kLcdOverlayLibTrapControl : PalmLcdOverlay.h , palmOneLcdOverlayCommon.h
  • kLcdOverlayLibTrapGetVersion : PalmLcdOverlay.h , palmOneLcdOverlayCommon.h
  • kLcdOverlayLibType : palmOneLcdOverlayCommon.h , PalmLcdOverlay.h
  • kLcdOverlayLibVersion : palmOneLcdOverlayCommon.h , PalmLcdOverlay.h
  • kLcdOverlayLibVersion1 : PalmLcdOverlay.h , palmOneLcdOverlayCommon.h
  • kLFlipSmiley : SmartTextEngineDef.h
  • kLineNumberUnknown : HsPhoneGSMTypes.h
  • kLineStateVersion : HsPhoneMiscTypes.h
  • kLocDBMaxLocNameLength : LocsLibCommon.h
  • kLocDBTypeCustom : LocsLibCommon.h
  • kLocDBTypeDefault : LocsLibCommon.h
  • kLocDBVersion : LocsLibCommon.h
  • kLocDisplayInCustom : LocsLibCommon.h
  • kLocFileCDatabase : LocsLibCommon.h
  • kLocFileNCustomDB : LocsLibCommon.h
  • kLocFileNDefaultDB : LocsLibCommon.h
  • kLocFileTCusLocDB : LocsLibCommon.h
  • kLocFileTDefLocDB : LocsLibCommon.h
  • kLocNameMaxLength : LocsLibCommon.h
  • kLocNoDisplayInCustom : LocsLibCommon.h
  • kLocNoteMaxLength : LocsLibCommon.h
  • kLocsFileCLocsLib : LocsLibCommon.h
  • kLocsLibDSTAlert : LocsLibCommon.h
  • kLocsLibDSTEndAlert : LocsLibCommon.h
  • kLocsLibDSTStartAlert : LocsLibCommon.h
  • kLocsLibFtrNumRefNum : LocsLibCommon.h
  • kLocsLibListUpdate : LocsLibCommon.h
  • kLocsLibListUpdateClass : LocsLibCommon.h
  • kLocsLibName : LocsLibCommon.h
  • kLocsLibNotifyLocAddEvent : LocsLibCommon.h
  • kLocsLibNotifyLocChangeEvent : LocsLibCommon.h
  • kLocsLibNotifyLocDeleteEvent : LocsLibCommon.h
  • kLocsLibNotifyLocEditEvent : LocsLibCommon.h
  • kLocsLibSel01 : LocsLibCommon.h
  • kLocsLibSel02 : LocsLibCommon.h
  • kLocsLibSel03 : LocsLibCommon.h
  • kLocsLibSel04 : LocsLibCommon.h
  • kLocsLibSel05 : LocsLibCommon.h
  • kLocsLibSel06 : LocsLibCommon.h
  • kLocsLibSel07 : LocsLibCommon.h
  • kLocsLibSel08 : LocsLibCommon.h
  • kLocsLibSel09 : LocsLibCommon.h
  • kLocsLibSelMax : LocsLibCommon.h
  • kLocsLibVersion01 : LocsLibCommon.h
  • kLocsLibVersion0121 : LocsLibCommon.h
  • kLocsLibVersion013 : LocsLibCommon.h
  • kLocsLibVersionCurrent : LocsLibCommon.h
  • kMaxImeiLen : HsPhoneNetworkTypes.h
  • kMaxMMISequenceLen : HsPhoneNetworkTypes.h
  • kMaxPhoneNumberLen : HsPhoneNetworkTypes.h
  • kMaxTonesNameSize : TonesLibTypes.h
  • kMaxVPNAccountNameLength : PalmVPPI.h
  • kMaxWiFiAuthenticationMethodNameLength : PalmWPPI.h
  • kMaxWiFiCredentialsLabelLength : PalmWPPI.h
  • kMaxWiFiCredentialsSelectorTriggerLength : PalmWPPI.h
  • kMMSPixPlaceMaxLen : HsPhoneSMSTypes.h
  • kMMSStringMaxLen : HsPhoneSMSTypes.h
  • kNetDriverDateLength : PalmNetServices.h
  • kNetFWNameLength : PalmNetServices.h
  • kNetSerialNumberLength : PalmNetServices.h
  • kNetworkListDBName : CarrierCustomLibTypes.h
  • kNoSortOrder : ImageLibCommon.h
  • kOmegaCharacter : SmartTextEngineDef.h
  • kOMouthSmiley : SmartTextEngineDef.h
  • kPalmAudioPlaybackActionCodeRequestResume : PalmAudioPlayback.h
  • kPalmAudioPlaybackActionCodeRequestStop : PalmAudioPlayback.h
  • kPalmAudioPlaybackCreator : PalmAudioPlayback.h
  • kPalmAudioPlaybackNotify1 : PalmAudioPlayback.h
  • kPalmAudioPlaybackNotifyEvent : PalmAudioPlayback.h
  • kPalmAudioPlaybackNotifyVersion : PalmAudioPlayback.h
  • kPalmCompanyIDHandspring : palmOneResources.h
  • kPalmCompanyIDOldPalm : palmOneResources.h
  • kPalmCompanyIDPalm : palmOneResources.h
  • kPalmCreatorIDLcdState : palmOneCreators.h
  • kPalmCreatorIDNetSlipHack : palmOneCreators.h
  • kPalmDeviceIDTX : palmOneResources.h
  • kPalmDeviceIDZ22 : palmOneResources.h
  • kPalmLedCreator : PalmLED.h
  • kPalmLedModule : PalmLED.h
  • kPalmLedName : PalmLED.h
  • kPalmLedTrapGetAttributes : PalmLED.h
  • kPalmLedTrapSetAttributes : PalmLED.h
  • kPalmLedType : PalmLED.h
  • kPalmLedVersion : PalmLED.h
  • kPalmLedVersion1 : PalmLED.h
  • kPalmOneCreatorIDCalendar : palmOneCreators.h
  • kPalmOneCreatorIDContacts : palmOneCreators.h
  • kPalmOneCreatorIDFavorites : palmOneCreators.h
  • kPalmOneCreatorIDFileBrowser : palmOneCreators.h
  • kPalmOneCreatorIDMemos : palmOneCreators.h
  • kPalmOneCreatorIDNotePad : palmOneCreators.h
  • kPalmOneCreatorIDTasks : palmOneCreators.h
  • kPalmOneCreatorIDVoiceMemo : palmOneCreators.h
  • kPalmOneDeviceIDAngus : palmOneResources.h
  • kPalmOneDeviceIDDevice3 : palmOneResources.h
  • kPalmOneDeviceIDDevice4 : palmOneResources.h
  • kPalmOneDeviceIDDevice5 : palmOneResources.h
  • kPalmOneDeviceIDDevice6 : palmOneResources.h
  • kPalmOneDeviceIDDevice7 : palmOneResources.h
  • kPalmOneDeviceIDDevice8 : palmOneResources.h
  • kPalmOneDeviceIDDevice9 : palmOneResources.h
  • kPalmOneDeviceIDDeviceA : palmOneResources.h
  • kPalmOneDeviceIDGandalf : palmOneResources.h
  • kPalmOneDeviceIDGnome : palmOneResources.h
  • kPalmOneDeviceIDLowrider : palmOneResources.h
  • kPalmOneDeviceIDTorino : palmOneResources.h
  • kPalmOneDeviceIDTreo600 : palmOneResources.h
  • kPalmOneDeviceIDTreo600Sim : palmOneResources.h
  • kPalmOneDeviceIDTreo650 : palmOneResources.h
  • kPalmOneDeviceIDTreo650Sim : palmOneResources.h
  • kPalmOneDeviceIDTungstenC : palmOneResources.h
  • kPalmOneDeviceIDTungstenE2 : palmOneResources.h
  • kPalmOneDeviceIDTungstenT : palmOneResources.h
  • kPalmOneDeviceIDTungstenT2 : palmOneResources.h
  • kPalmOneDeviceIDTungstenT3 : palmOneResources.h
  • kPalmOneDeviceIDTungstenT5 : palmOneResources.h
  • kPalmOneDeviceIDTungstenTE : palmOneResources.h
  • kPalmOneDeviceIDTungstenW : palmOneResources.h
  • kPalmOneDeviceIDTungstenX : palmOneResources.h
  • kPalmOneDeviceIDVentura : palmOneResources.h
  • kPalmOneDeviceIDZire : palmOneResources.h
  • kPalmOneDeviceIDZire21 : palmOneResources.h
  • kPalmOneDeviceIDZire31 : palmOneResources.h
  • kPalmOneDeviceIDZire71 : palmOneResources.h
  • kPalmOneDeviceIDZire72 : palmOneResources.h
  • kPalmOneStatusBarMgrLibGetAttribute : palmOneStatusBar.h
  • kPalmOneStatusBarMgrLibHide : palmOneStatusBar.h
  • kPalmOneStatusBarMgrLibShow : palmOneStatusBar.h
  • kPalmOneStatusBarMgrLibTrapClose : palmOneStatusBar.h
  • kPalmOneStatusBarMgrLibTrapOpen : palmOneStatusBar.h
  • kPalmPhotoLibVersion : palmOnePhotoCommon.h
  • kPalmPhotoLibVersion1 : palmOnePhotoCommon.h
  • kPalmPhotoLibVersion2 : palmOnePhotoCommon.h
  • kPalmPhotoLibVersion3 : palmOnePhotoCommon.h
  • kPalmSizeImageHeight : ImageLibCommon.h
  • kPalmSizeImageWidth : ImageLibCommon.h
  • kParsedDeviceURL : SmartTextEngineDef.h
  • kParsedEmail : SmartTextEngineDef.h
  • kParsedPhoneNumber : SmartTextEngineDef.h
  • kParsedRtspURL : SmartTextEngineDef.h
  • kParsedURL : SmartTextEngineDef.h
  • kPhiCharacter : SmartTextEngineDef.h
  • kPiCharacter : SmartTextEngineDef.h
  • kPinLibTrapClose : PalmPin.h
  • kPinLibTrapOpen : PalmPin.h
  • kPinLibTrapPinGetCurrentPinletID : PalmPin.h
  • kPinLibTrapPinGetInputAreaState : PalmPin.h
  • kPinLibTrapPinGetInputMode : PalmPin.h
  • kPinLibTrapPinResetInputState : PalmPin.h
  • kPinLibTrapPinSetInputAreaState : PalmPin.h
  • kPinLibTrapPinSetInputMode : PalmPin.h
  • kPinLibTrapPINShowReferenceDialog : PalmPin.h
  • kPinLibTrapPinSwitchToPinlet : PalmPin.h
  • kPmConnectorClassAudioNoHeadset : PmConnectorLibCommon.h
  • kPmConnectorClassAudioWHeadset : PmConnectorLibCommon.h
  • kPmConnectorClassCarkit : PmConnectorLibCommon.h
  • kPmConnectorClassGenericSerial : PmConnectorLibCommon.h
  • kPmConnectorClassMask : PmConnectorLibCommon.h
  • kPmConnectorClassNoDevice : PmConnectorLibCommon.h
  • kPmConnectorClassSerial : PmConnectorLibCommon.h
  • kPmConnectorClassSmartSerial : PmConnectorLibCommon.h
  • kPmConnectorClassUnknown : PmConnectorLibCommon.h
  • kPmConnectorClassUSB : PmConnectorLibCommon.h
  • kPmConnectorLibCreator : PmConnectorLibCommon.h
  • kPmConnectorLibCtrlGetDeviceClass : PmConnectorLibCommon.h
  • kPmConnectorLibCtrlPowerOff : PmConnectorLibCommon.h
  • kPmConnectorLibCtrlPowerOn : PmConnectorLibCommon.h
  • kPmConnectorLibErrBadParam : PmConnectorLibCommon.h
  • kPmConnectorLibErrInternal : PmConnectorLibCommon.h
  • kPmConnectorLibErrNoMemory : PmConnectorLibCommon.h
  • kPmConnectorLibErrNotCompatible : PmConnectorLibCommon.h
  • kPmConnectorLibErrNotOpen : PmConnectorLibCommon.h
  • kPmConnectorLibErrNotSupported : PmConnectorLibCommon.h
  • kPmConnectorLibErrorClass : PmConnectorLibCommon.h
  • kPmConnectorLibErrStillOpen : PmConnectorLibCommon.h
  • kPmConnectorLibName : PmConnectorLibCommon.h
  • kPmConnectorLibTrapClose : PmConnectorLibCommon.h
  • kPmConnectorLibTrapControl : PmConnectorLibCommon.h
  • kPmConnectorLibTrapGetVersion : PmConnectorLibCommon.h
  • kPmConnectorLibTrapOpen : PmConnectorLibCommon.h
  • kPmConnectorLibTrapSetAudioInput : PmConnectorLibCommon.h
  • kPmConnectorLibTrapSetAudioOutput : PmConnectorLibCommon.h
  • kPmConnectorLibTrapSleep : PmConnectorLibCommon.h
  • kPmConnectorLibTrapWake : PmConnectorLibCommon.h
  • kPmConnectorLibType : PmConnectorLibCommon.h
  • kPmConnectorLibVersion : PmConnectorLibCommon.h
  • kPmConnectorNotifySysAttach : PmConnectorLibCommon.h
  • kPmConnectorNotifySysDetach : PmConnectorLibCommon.h
  • kPmConnectorNotifyType : PmConnectorLibCommon.h
  • kPmDockStatusCharging : PmConnectorLibCommon.h
  • kPmDockStatusSerialPeripheral : PmConnectorLibCommon.h
  • kPmDockStatusUSBCradle : PmConnectorLibCommon.h
  • kPmKeyLibAPIMajorVersion : PmKeyLibCommon.h
  • kPmKeyLibAPIMinorVersion : PmKeyLibCommon.h
  • kPmKeyLibAPIVersion : PmKeyLibCommon.h
  • kPmKeyLibCreator : PmKeyLibCommon.h
  • kPmKeyLibFtrValAPIVersion : PmKeyLibCommon.h
  • kPmKeyLibName : PmKeyLibCommon.h
  • kPmKeyLibTrapAttrGet : PmKeyLibCommon.h
  • kPmKeyLibTrapAttrSet : PmKeyLibCommon.h
  • kPmKeyLibTrapChrCodeToKeyCode : PmKeyLibCommon.h
  • kPmKeyLibTrapClose : PmKeyLibCommon.h
  • kPmKeyLibTrapEnableKey : PmKeyLibCommon.h
  • kPmKeyLibTrapEventIsFromKeyboard : PmKeyLibCommon.h
  • kPmKeyLibTrapKeyCodeToChrCode : PmKeyLibCommon.h
  • kPmKeyLibTrapKeysPressed : PmKeyLibCommon.h
  • kPmKeyLibTrapOpen : PmKeyLibCommon.h
  • kPmKeyLibTrapStop : PmKeyLibCommon.h
  • kPmKeyLibType : PmKeyLibCommon.h
  • kPmSoundLibTrapClkGetTickCount : HsSoundLibTraps.h
  • kPmSoundLibTrapClkGetTicksPerSecond : HsSoundLibTraps.h
  • kPmSoundLibTrapGetPosition : HsSoundLibTraps.h
  • kPmSoundLibTrapReserved : HsSoundLibTraps.h
  • kPmSysGadgetBbutFlagNoBackground : PmSysGadgetLibBbutRscCommon.h
  • kPmSysGadgetBbutFlagNoBorder : PmSysGadgetLibBbutRscCommon.h
  • kPmSysGadgetBbutFlagNoBorderOrBackground : PmSysGadgetLibBbutRscCommon.h
  • kPmSysGadgetBbutFlagNone : PmSysGadgetLibBbutRscCommon.h
  • kPmSysGadgetBbutFontBold : PmSysGadgetLibBbutRscCommon.h
  • kPmSysGadgetBbutFontLarge : PmSysGadgetLibBbutRscCommon.h
  • kPmSysGadgetBbutFontLargeBold : PmSysGadgetLibBbutRscCommon.h
  • kPmSysGadgetBbutFontLed : PmSysGadgetLibBbutRscCommon.h
  • kPmSysGadgetBbutFontStd : PmSysGadgetLibBbutRscCommon.h
  • kPmSysGadgetBbutFontSymbol : PmSysGadgetLibBbutRscCommon.h
  • kPmSysGadgetBbutFontSymbol11 : PmSysGadgetLibBbutRscCommon.h
  • kPmSysGadgetBbutFontSymbol7 : PmSysGadgetLibBbutRscCommon.h
  • kPmSysGadgetBbutGadgetMiscSelectData : PmSysGadgetLibCommon.h
  • kPmSysGadgetBbutGadgetMiscSelectSelector : PmSysGadgetLibCommon.h
  • kPmSysGadgetBbutMappingVersion0 : PmSysGadgetLibBbutRscCommon.h
  • kPmSysGadgetBbutRscType : PmSysGadgetLibCommon.h
  • kPmSysGadgetFtrIDStatusGadgetRev : PmSysGadgetLibCommon.h
  • kPmSysGadgetFtrValStatusGadgetRev1 : PmSysGadgetLibCommon.h
  • kPmSysGadgetLibCreator : PmSysGadgetLibCommon.h
  • kPmSysGadgetLibName : PmSysGadgetLibCommon.h
  • kPmSysGadgetLibTrapBbutHitBigButton : PmSysGadgetLibCommon.h
  • kPmSysGadgetLibTrapBbutInstallFromResource : PmSysGadgetLibCommon.h
  • kPmSysGadgetLibTrapBbutInstallNewButton : PmSysGadgetLibCommon.h
  • kPmSysGadgetLibTrapBbutSetBitmap : PmSysGadgetLibCommon.h
  • kPmSysGadgetLibTrapBbutSetLabel : PmSysGadgetLibCommon.h
  • kPmSysGadgetLibTrapClose : PmSysGadgetLibCommon.h
  • kPmSysGadgetLibTrapOpen : PmSysGadgetLibCommon.h
  • kPmSysGadgetLibTrapStatusGadgetsUpdate : PmSysGadgetLibCommon.h
  • kPmSysGadgetLibTrapStatusGadgetTypeSet : PmSysGadgetLibCommon.h
  • kPmSysGadgetLibType : PmSysGadgetLibCommon.h
  • kPmUIUtilLibAPIMajorVersion : PmUIUtilLibCommon.h
  • kPmUIUtilLibAPIMinorVersion : PmUIUtilLibCommon.h
  • kPmUIUtilLibAPIVersion : PmUIUtilLibCommon.h
  • kPmUIUtilLibCreator : PmUIUtilLibCommon.h
  • kPmUIUtilLibFtrValAPIVersion : PmUIUtilLibCommon.h
  • kPmUIUtilLibName : PmUIUtilLibCommon.h
  • kPmUIUtilLibTrapAttnDiagIsVisible : PmUIUtilLibCommon.h
  • kPmUIUtilLibTrapAttnEnable : PmUIUtilLibCommon.h
  • kPmUIUtilLibTrapAttnGetAttentionExt : PmUIUtilLibCommon.h
  • kPmUIUtilLibTrapAttnIndicatorAllow : PmUIUtilLibCommon.h
  • kPmUIUtilLibTrapAttnNagInfo : PmUIUtilLibCommon.h
  • kPmUIUtilLibTrapAttnUpdateExt : PmUIUtilLibCommon.h
  • kPmUIUtilLibTrapAttrGet : PmUIUtilLibCommon.h
  • kPmUIUtilLibTrapAttrSet : PmUIUtilLibCommon.h
  • kPmUIUtilLibTrapClose : PmUIUtilLibCommon.h
  • kPmUIUtilLibTrapCtlGetFont : PmUIUtilLibCommon.h
  • kPmUIUtilLibTrapCtlGetStyle : PmUIUtilLibCommon.h
  • kPmUIUtilLibTrapFrmDoDialog : PmUIUtilLibCommon.h
  • kPmUIUtilLibTrapFrmDoDialogWithCallback : PmUIUtilLibCommon.h
  • kPmUIUtilLibTrapFrmDoTimedDialogEx : PmUIUtilLibCommon.h
  • kPmUIUtilLibTrapFrmGetDefaultButtonID : PmUIUtilLibCommon.h
  • kPmUIUtilLibTrapFrmGetEventHandler : PmUIUtilLibCommon.h
  • kPmUIUtilLibTrapFrmSetHelpID : PmUIUtilLibCommon.h
  • kPmUIUtilLibTrapFrmSetLabel : PmUIUtilLibCommon.h
  • kPmUIUtilLibTrapFrmSetLabelFont : PmUIUtilLibCommon.h
  • kPmUIUtilLibTrapGetObjectUsable : PmUIUtilLibCommon.h
  • kPmUIUtilLibTrapLstGetItemsText : PmUIUtilLibCommon.h
  • kPmUIUtilLibTrapLstGetTempSelection : PmUIUtilLibCommon.h
  • kPmUIUtilLibTrapLstGetTopItem : PmUIUtilLibCommon.h
  • kPmUIUtilLibTrapLstPopupListExt : PmUIUtilLibCommon.h
  • kPmUIUtilLibTrapLstSetTempSelection : PmUIUtilLibCommon.h
  • kPmUIUtilLibTrapNavGetFocusColor : PmUIUtilLibCommon.h
  • kPmUIUtilLibTrapNavSetFocusColor : PmUIUtilLibCommon.h
  • kPmUIUtilLibTrapOpen : PmUIUtilLibCommon.h
  • kPmUIUtilLibTrapPutObjectAfterTitle : PmUIUtilLibCommon.h
  • kPmUIUtilLibTrapSclScroll : PmUIUtilLibCommon.h
  • kPmUIUtilLibTrapSclScrollPage : PmUIUtilLibCommon.h
  • kPmUIUtilLibTrapSclUpdateScrollBar : PmUIUtilLibCommon.h
  • kPmUIUtilLibTrapSliHandleKeyDown : PmUIUtilLibCommon.h
  • kPmUIUtilLibTrapWinGetMaxDepth : PmUIUtilLibCommon.h
  • kPmUIUtilLibType : PmUIUtilLibCommon.h
  • kPreviewBitmapHeight : ImageLibCommon.h
  • kPreviewBitmapWidth : ImageLibCommon.h
  • kPsiCharacter : SmartTextEngineDef.h
  • kPttNotificationEvent : PmSysGadgetLibCommon.h
  • kPttNotificationStatusOffset : PmSysGadgetLibCommon.h
  • kPukeSmiley : SmartTextEngineDef.h
  • kPwrBatteryStateBroadcaster : PalmPower.h
  • kPwrBatteryStateNotifyEvent : PalmPower.h
  • kQuestionSmiley : SmartTextEngineDef.h
  • kRadioStateVersion : HsPhoneMiscTypes.h
  • kResizeOperation : ImageLibCommon.h
  • kRFlipSmiley : SmartTextEngineDef.h
  • kScrollToEnd : SmartTextEngineDef.h
  • kSelectUntilEnd : SmartTextEngineDef.h
  • kSelectUntilEndOfRecord : SmartTextEngineDef.h
  • kSigmaCharacter : SmartTextEngineDef.h
  • kSliderHigh : HsPhoneAudioTypes.h
  • kSliderLow : HsPhoneAudioTypes.h
  • kSliderPositions : HsPhoneAudioTypes.h
  • kSmartTextBit : SmartTextEngineDef.h
  • kSmileSmiley : SmartTextEngineDef.h
  • kSmirkSmiley : SmartTextEngineDef.h
  • kSndFileStreamFileSpecFlagFileStream : palmOneSndFileStream.h
  • kSndFileStreamFileSpecFlagVFS : palmOneSndFileStream.h
  • kSndFileStreamLibCreator : palmOneSndFileStream.h
  • kSndFileStreamLibErrAlreadyOpen : palmOneSndFileStream.h
  • kSndFileStreamLibErrCancel : palmOneSndFileStream.h
  • kSndFileStreamLibErrCantOpenFile : palmOneSndFileStream.h
  • kSndFileStreamLibErrNone : palmOneSndFileStream.h
  • kSndFileStreamLibErrNotOpen : palmOneSndFileStream.h
  • kSndFileStreamLibErrOperationNotSupported : palmOneSndFileStream.h
  • kSndFileStreamLibErrOutOfMemory : palmOneSndFileStream.h
  • kSndFileStreamLibErrStillOpen : palmOneSndFileStream.h
  • kSndFileStreamLibErrUnsupportedFile : palmOneSndFileStream.h
  • kSndFileStreamLibName : palmOneSndFileStream.h
  • kSndFileStreamLibPlaybackForever : palmOneSndFileStream.h
  • kSndFileStreamLibTrapClose : palmOneSndFileStream.h
  • kSndFileStreamLibTrapCreate : palmOneSndFileStream.h
  • kSndFileStreamLibTrapDeviceControl : palmOneSndFileStream.h
  • kSndFileStreamLibTrapGetCurrentStreamData : palmOneSndFileStream.h
  • kSndFileStreamLibTrapGetPan : palmOneSndFileStream.h
  • kSndFileStreamLibTrapGetVolume : palmOneSndFileStream.h
  • kSndFileStreamLibTrapOpen : palmOneSndFileStream.h
  • kSndFileStreamLibTrapPause : palmOneSndFileStream.h
  • kSndFileStreamLibTrapSeek : palmOneSndFileStream.h
  • kSndFileStreamLibTrapSetPan : palmOneSndFileStream.h
  • kSndFileStreamLibTrapSetVolume : palmOneSndFileStream.h
  • kSndFileStreamLibTrapStart : palmOneSndFileStream.h
  • kSndFileStreamLibTrapStop : palmOneSndFileStream.h
  • kSndFileStreamLibTrapUIPlay : palmOneSndFileStream.h
  • kSndFileStreamLibTrapUIRecord : palmOneSndFileStream.h
  • kSndFileStreamLibTrapVersion : palmOneSndFileStream.h
  • kSndFileStreamLibType : palmOneSndFileStream.h
  • kSndFileStreamLibVersion : palmOneSndFileStream.h
  • kSndFileTypeAAC : palmOneSndFileStream.h
  • kSndFileTypeAMR : palmOneSndFileStream.h
  • kSndFileTypeMP3 : palmOneSndFileStream.h
  • kSndFileTypeQCP : palmOneSndFileStream.h
  • kSndFileTypeWAV : palmOneSndFileStream.h
  • kSortByDate : ImageLibCommon.h
  • kSortByDateDesc : ImageLibCommon.h
  • kSortByName : ImageLibCommon.h
  • kSortByNameDesc : ImageLibCommon.h
  • kSprintMCCMNC : CarrierCustomLibTypes.h
  • kStatusBarMgrLibGetAttribute : PalmStatusBar.h
  • kStatusBarMgrLibHide : PalmStatusBar.h
  • kStatusBarMgrLibShow : PalmStatusBar.h
  • kStatusBarMgrLibTrapClose : PalmStatusBar.h
  • kStatusBarMgrLibTrapOpen : PalmStatusBar.h
  • kSTEBitmap : SmartTextEngineDef.h
  • kSTEBlack : SmartTextEngineDef.h
  • kSTEBlackFont : SmartTextEngineDef.h
  • kSTEBlackInverse : SmartTextEngineDef.h
  • kSTEBlue : SmartTextEngineDef.h
  • kSTEBlueFont : SmartTextEngineDef.h
  • kSTEBlueInverse : SmartTextEngineDef.h
  • kSTEBoldFont : SmartTextEngineDef.h
  • kSTECenterAlign : SmartTextEngineDef.h
  • kSTECharacterBitmap : SmartTextEngineDef.h
  • kSTECurrent : SmartTextEngineDef.h
  • kSTECurrentFont : SmartTextEngineDef.h
  • kSTEGray : SmartTextEngineDef.h
  • kSTEGrayFont : SmartTextEngineDef.h
  • kSTEGrayInverse : SmartTextEngineDef.h
  • kSTEGreen : SmartTextEngineDef.h
  • kSTEGreenFont : SmartTextEngineDef.h
  • kSTEGreenInverse : SmartTextEngineDef.h
  • kSTEHorizontalLine : SmartTextEngineDef.h
  • kSTEHyperlink : SmartTextEngineDef.h
  • kSTELeftIndent : SmartTextEngineDef.h
  • kSTELineBreak : SmartTextEngineDef.h
  • kSTEOrange : SmartTextEngineDef.h
  • kSTEOrangeFont : SmartTextEngineDef.h
  • kSTEOrangeInverse : SmartTextEngineDef.h
  • kSTEPurple : SmartTextEngineDef.h
  • kSTEPurpleFont : SmartTextEngineDef.h
  • kSTEPurpleInverse : SmartTextEngineDef.h
  • kSTERed : SmartTextEngineDef.h
  • kSTERedFont : SmartTextEngineDef.h
  • kSTERedInverse : SmartTextEngineDef.h
  • kSTERightAlign : SmartTextEngineDef.h
  • kSTESmileyBitmap : SmartTextEngineDef.h
  • kSTEStdFont : SmartTextEngineDef.h
  • kSTEYellow : SmartTextEngineDef.h
  • kSTEYellowFont : SmartTextEngineDef.h
  • kSTEYellowInverse : SmartTextEngineDef.h
  • kStraightMouthSmiley : SmartTextEngineDef.h
  • kThetaCharacter : SmartTextEngineDef.h
  • kThumbnailImageHeight : ImageLibCommon.h
  • kThumbnailImageWidth : ImageLibCommon.h
  • kTonesDialogFlagNonModal : TonesLibTypes.h
  • kTonesLibVersionEscalation : TonesLib.h
  • kTongueSmiley : SmartTextEngineDef.h
  • kUFlipSmiley : SmartTextEngineDef.h
  • kUndefinedPosition : LocsLibCommon.h
  • kUSB500mACharge : palmOneFeatures.h
  • kUSBConsole : palmOneFeatures.h
  • kUSBDriveMode : palmOneFeatures.h
  • kUSBDUN : palmOneFeatures.h
  • kUSBFSClient : palmOneFeatures.h
  • kUSBFSOnTheGo : palmOneFeatures.h
  • kUSBFSOnTheGoMultiDevice : palmOneFeatures.h
  • kUSBHotSync : palmOneFeatures.h
  • kUSBHSClient : palmOneFeatures.h
  • kUSBHSOnTheGo : palmOneFeatures.h
  • kUSBHSOnTheGoMultiDevice : palmOneFeatures.h
  • kUSBLogging : palmOneFeatures.h
  • kUSBMiniConnector : palmOneFeatures.h
  • kUSBMTP : palmOneFeatures.h
  • kUSBMultiConnector : palmOneFeatures.h
  • kUSBTransfer : palmOneFeatures.h
  • kVerizonMCCMNC : CarrierCustomLibTypes.h
  • kVFSOperation : ImageLibCommon.h
  • kWinkSmiley : SmartTextEngineDef.h
  • kXiCharacter : SmartTextEngineDef.h
  • kYinYangSmiley : SmartTextEngineDef.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:38 2008 for Palm API Guide


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- l -

  • Lambda11BitMap : SmartTextEngineRsc.h
  • Lambda14BitMap : SmartTextEngineRsc.h
  • LargeSmiley00BitMap : SmartTextEngineRsc.h
  • LargeSmiley01BitMap : SmartTextEngineRsc.h
  • LargeSmiley02BitMap : SmartTextEngineRsc.h
  • LargeSmiley03BitMap : SmartTextEngineRsc.h
  • LargeSmiley04BitMap : SmartTextEngineRsc.h
  • LargeSmiley05BitMap : SmartTextEngineRsc.h
  • LargeSmiley06BitMap : SmartTextEngineRsc.h
  • LargeSmiley07BitMap : SmartTextEngineRsc.h
  • LargeSmiley08BitMap : SmartTextEngineRsc.h
  • LargeSmiley09BitMap : SmartTextEngineRsc.h
  • LargeSmiley10BitMap : SmartTextEngineRsc.h
  • LargeSmiley11BitMap : SmartTextEngineRsc.h
  • LargeSmiley12BitMap : SmartTextEngineRsc.h
  • LargeSmiley13BitMap : SmartTextEngineRsc.h
  • LargeSmiley14BitMap : SmartTextEngineRsc.h
  • LargeSmiley15BitMap : SmartTextEngineRsc.h
  • LargeSmiley16BitMap : SmartTextEngineRsc.h
  • LargeSmiley17BitMap : SmartTextEngineRsc.h
  • LargeSmiley18BitMap : SmartTextEngineRsc.h
  • LargeSmiley19BitMap : SmartTextEngineRsc.h
  • LargeSmiley20BitMap : SmartTextEngineRsc.h
  • LargeSmiley21BitMap : SmartTextEngineRsc.h
  • LargeSmiley22BitMap : SmartTextEngineRsc.h
  • LargeSmiley23BitMap : SmartTextEngineRsc.h
  • LargeSmileyBitMapBaseID : SmartTextEngineRsc.h
  • LaunchWithCommand : HsAppLaunchCmd.h
  • LocationAreDSTDatesEqual : LocsLibCommon.h
  • LocationGetCountry : LocsLibCommon.h
  • LocationGetCustom : LocsLibCommon.h
  • LocationGetDSTAdj : LocsLibCommon.h
  • LocationGetDSTEnd : LocsLibCommon.h
  • LocationGetDSTStart : LocsLibCommon.h
  • LocationGetName : LocsLibCommon.h
  • LocationGetReserved : LocsLibCommon.h
  • LocationGetUTC : LocsLibCommon.h
  • LocationSetCountry : LocsLibCommon.h
  • LocationSetCustom : LocsLibCommon.h
  • LocationSetDSTAdj : LocsLibCommon.h
  • LocationSetDSTEnd : LocsLibCommon.h
  • LocationSetDSTStart : LocsLibCommon.h
  • LocationSetReserved : LocsLibCommon.h
  • LocationSetUTC : LocsLibCommon.h
  • LocDBCompareCountries : LocsLibCommon.h
  • LocDBCompareNames : LocsLibCommon.h
  • LocDBCompareUTC : LocsLibCommon.h
  • LocDBGetCountry : LocsLibCommon.h
  • LocDBGetUTC : LocsLibCommon.h
  • locLErrBadParam : LocsLibCommon.h
  • locLErrBadRefNum : LocsLibCommon.h
  • locLErrBadVersion : LocsLibCommon.h
  • locLErrCantFindLocsDB : LocsLibCommon.h
  • locLErrCantOpenLibRsc : LocsLibCommon.h
  • locLErrMemAllocFail : LocsLibCommon.h
  • locLErrNoGlobals : LocsLibCommon.h
  • locLErrNoLibSysReference : LocsLibCommon.h
  • locLErrNoMemForGlobals : LocsLibCommon.h
  • locLErrNone : LocsLibCommon.h
  • locLErrNotOpen : LocsLibCommon.h
  • locLErrorClass : LocsLibCommon.h
  • locLErrStillOpen : LocsLibCommon.h
  • locsLibTrapDBChangeRecord : LocsLibCommon.h
  • locsLibTrapDBCmpRecordsSimple : LocsLibCommon.h
  • locsLibTrapDBConvertRecord : LocsLibCommon.h
  • locsLibTrapDBCopyLocation : LocsLibCommon.h
  • locsLibTrapDBDeleteRecord : LocsLibCommon.h
  • locsLibTrapDBFindCustomRecord : LocsLibCommon.h
  • locsLibTrapDBFindFirst : LocsLibCommon.h
  • locsLibTrapDBFindFirstByName : LocsLibCommon.h
  • locsLibTrapDBFindFirstByUTCCtry : LocsLibCommon.h
  • locsLibTrapDBFindFirstInList : LocsLibCommon.h
  • locsLibTrapDBGetCustomList : LocsLibCommon.h
  • locsLibTrapDBGetRecord : LocsLibCommon.h
  • locsLibTrapDBGetRecordList : LocsLibCommon.h
  • locsLibTrapDBInitDBs : LocsLibCommon.h
  • locsLibTrapDBNewRecord : LocsLibCommon.h
  • locsLibTrapDBOpenCustom : LocsLibCommon.h
  • locsLibTrapDBOpenDefault : LocsLibCommon.h
  • locsLibTrapDBRecordSize : LocsLibCommon.h
  • locsLibTrapDBSetRecordCustom : LocsLibCommon.h
  • locsLibTrapDBSort : LocsLibCommon.h
  • locsLibTrapDSTAlarmClear : LocsLibCommon.h
  • locsLibTrapDSTAlarmIsDST : LocsLibCommon.h
  • locsLibTrapDSTAlarmSet : LocsLibCommon.h
  • locsLibTrapGetVersion : LocsLibCommon.h
  • locsLibTrapLaunchEditListDlg : LocsLibCommon.h
  • locsLibTrapLaunchSelDialogue : LocsLibCommon.h
  • locsLibTrapLocationCopyV20 : LocsLibCommon.h
  • locsLibTrapLocationFinalV20 : LocsLibCommon.h
  • locsLibTrapLocationGetSizeV20 : LocsLibCommon.h
  • locsLibTrapLocationInitV20 : LocsLibCommon.h
  • locsLibTrapLocationSetNote : LocsLibCommon.h
  • locsLibTrapLocationSetPosition : LocsLibCommon.h
  • locsLibTrapLocCopy : LocsLibCommon.h
  • locsLibTrapLocDBChangeRecordV20 : LocsLibCommon.h
  • locsLibTrapLocDBConvertRecordV20 : LocsLibCommon.h
  • locsLibTrapLocDBFindCustomRecordV20 : LocsLibCommon.h
  • locsLibTrapLocDBGetNearestLocation : LocsLibCommon.h
  • locsLibTrapLocDBGetRecordListV20 : LocsLibCommon.h
  • locsLibTrapLocDBGetRecordV20 : LocsLibCommon.h
  • locsLibTrapLocDBGetVersion : LocsLibCommon.h
  • locsLibTrapLocDBNewRecordV20 : LocsLibCommon.h
  • locsLibTrapLocFinal : LocsLibCommon.h
  • locsLibTrapLocGetSize : LocsLibCommon.h
  • locsLibTrapLocInit : LocsLibCommon.h
  • locsLibTrapLocIsDSTPast : LocsLibCommon.h
  • locsLibTrapLocMakeGeneric : LocsLibCommon.h
  • locsLibTrapLocSetName : LocsLibCommon.h
  • locsLibTrapLocsLibLocationNote : LocsLibCommon.h
  • LONG_PREAMBLE : PalmWiFiCommon.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:38 2008 for Palm API Guide


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- m -

  • MAX_ACTIVE_PROFILES : PalmNetServices.h
  • MAX_LONGOPERATORNAME_LENGTH : HsPhoneNetworkTypes.h
  • MAX_PLANE_COUNT : palmOneCodecFormat.h
  • MAX_SHORTOPERATORNAME_LENGTH : HsPhoneNetworkTypes.h
  • maxDB4ecioLevel0 : HsPhoneTypes.h
  • maxDB4ecioLevel1 : HsPhoneTypes.h
  • maxDB4ecioLevel2 : HsPhoneTypes.h
  • maxDB4ecioLevel3 : HsPhoneTypes.h
  • maxDBm4signalLevel0 : HsPhoneTypes.h
  • maxDBm4signalLevel1 : HsPhoneTypes.h
  • maxDBm4signalLevel2 : HsPhoneTypes.h
  • maxDBm4signalLevel3 : HsPhoneTypes.h
  • maxPasswordLen : HsPhoneNetworkTypes.h
  • maxPasswordLenCDMA : HsPhoneNetworkTypes.h
  • Minimum16bitTextHeader : HsPhoneSMSTypes.h
  • Minimum8bitTextHeader : HsPhoneSMSTypes.h
  • minPasswordLen : HsPhoneNetworkTypes.h
  • MM_MAX_ATTACHMENTS : PalmVMLaunch.h
  • MMPRO_ADD_MESSAGE_WITH_ATTACHMENT : PalmVMLaunch.h
  • MMPRO_LAUNCH_CODE : PalmVMLaunch.h
  • MMPRO_PLUGIN_EXTENDED_QUERY_LAUNCHCODE : PalmVMPlugin.h
  • MMPRO_PLUGIN_GET_INFO_LAUNCHCODE : PalmVMPlugin.h
  • MMPRO_PLUGIN_LAUNCHCODE : PalmVMPlugin.h
  • MMPRO_PLUGIN_QUERY_LAUNCHCODE : PalmVMPlugin.h
  • MMPRO_PLUGIN_RECEIVE_LAUNCHCODE : PalmVMPlugin.h
  • MMPRO_PLUGIN_SEND_LAUNCHCODE : PalmVMPlugin.h
  • MVNONAME_LENGTH : CarrierCustomLib.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:38 2008 for Palm API Guide


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- n -

  • NAITextLength : HsPhoneEvent.h
  • NAITextSize : HsPhoneEvent.h
  • NATIVE_CODE : PalmNative.h
  • navBitDown : common/system/palmOneNavigator.h
  • navBitLeft : common/system/palmOneNavigator.h
  • navBitRight : common/system/palmOneNavigator.h
  • navBitsAll : common/system/palmOneNavigator.h
  • navBitSelect : common/system/palmOneNavigator.h
  • navBitUp : common/system/palmOneNavigator.h
  • navChangeBitsAll : common/system/palmOneNavigator.h
  • navChangeDown : common/system/palmOneNavigator.h
  • navChangeLeft : common/system/palmOneNavigator.h
  • navChangeRight : common/system/palmOneNavigator.h
  • navChangeSelect : common/system/palmOneNavigator.h
  • navChangeUp : common/system/palmOneNavigator.h
  • NavDirectionHSPressed : common/system/palmOneNavigator.h
  • NavDirectionPalmPressed : common/system/palmOneNavigator.h
  • NavDirectionPressed : common/system/palmOneNavigator.h
  • navFtrCreator : common/system/palmOneNavigator.h
  • navFtrVersion : common/system/palmOneNavigator.h
  • NavKeyPressed : common/system/palmOneNavigator.h
  • NavSelectHSPressed : common/system/palmOneNavigator.h
  • NavSelectorFrmCountObjectsInNavOrder : HsNavCommon.h
  • NavSelectorFrmGetNavEntry : HsNavCommon.h
  • NavSelectorFrmGetNavOrder : HsNavCommon.h
  • NavSelectorFrmGetNavState : HsNavCommon.h
  • NavSelectorFrmNavDrawFocusRing : HsNavCommon.h
  • NavSelectorFrmNavGetFocusRingInfo : HsNavCommon.h
  • NavSelectorFrmNavObjectTakeFocus : HsNavCommon.h
  • NavSelectorFrmNavRemoveFocusRing : HsNavCommon.h
  • NavSelectorFrmSetNavEntry : HsNavCommon.h
  • NavSelectorFrmSetNavOrder : HsNavCommon.h
  • NavSelectorFrmSetNavState : HsNavCommon.h
  • NavSelectPalmPressed : common/system/palmOneNavigator.h
  • NavSelectPressed : common/system/palmOneNavigator.h
  • navVersion : common/system/palmOneNavigator.h
  • NBSHeaderEscapeSeq : HsPhoneSMSTypes.h
  • NBSHeaderID : HsPhoneSMSTypes.h
  • NBSHeaderIDLen : HsPhoneSMSTypes.h
  • NBSPort_MimeVCalendar : HsPhoneSMSTypes.h
  • NBSPort_MimeVCard : HsPhoneSMSTypes.h
  • NBSTextHeader : HsPhoneSMSTypes.h
  • NBSTextHeaderLength : HsPhoneSMSTypes.h
  • net80211ResetWepPasscode : PalmWiFiCommon.h
  • netMacAddrLength : PalmWiFiCommon.h
  • NETMASTER_LIB_TRAP : NetMasterLibrary.h
  • netMasterAnchorTimeoutDefault : NetMasterLibTypes.h
  • netMasterClientCurrentEventVersion : NetMasterLibTypes.h
  • netMasterClientEventNotificationTypeID : NetMasterLibTypes.h
  • netMasterErrAuthReqDuringBGLogin : NetMasterLibErrors.h
  • netMasterErrAutoLoginNotPossible : NetMasterLibErrors.h
  • netMasterErrBadArg : NetMasterLibErrors.h
  • netMasterErrBadPort : NetMasterLibErrors.h
  • netMasterErrCDMACarrierNetworkBusy : NetMasterLibErrors.h
  • netMasterErrClass : NetMasterLibErrors.h
  • netMasterErrConfigFailed : NetMasterLibErrors.h
  • netMasterErrConfigNotFound : NetMasterLibErrors.h
  • netMasterErrDispatchTable : NetMasterLibErrors.h
  • netMasterErrGPRSGenLoginErr : NetMasterLibErrors.h
  • netMasterErrInternalConnWouldBeImpossible : NetMasterLibErrors.h
  • netMasterErrMemory : NetMasterLibErrors.h
  • netMasterErrMIPAdminProhibited129 : NetMasterLibErrors.h
  • netMasterErrMIPAdminProhibited65 : NetMasterLibErrors.h
  • netMasterErrMIPBadTtl76 : NetMasterLibErrors.h
  • netMasterErrMIPCantRevTun137 : NetMasterLibErrors.h
  • netMasterErrMIPCantRevTun74 : NetMasterLibErrors.h
  • netMasterErrMIPDelivStyleNotSupported79 : NetMasterLibErrors.h
  • netMasterErrMIPErrorFa1_100 : NetMasterLibErrors.h
  • netMasterErrMIPErrorFa2_101 : NetMasterLibErrors.h
  • netMasterErrMIPErrorHa1_140 : NetMasterLibErrors.h
  • netMasterErrMIPErrorHa2_141 : NetMasterLibErrors.h
  • netMasterErrMIPFailed : NetMasterLibErrors.h
  • netMasterErrMIPForeign_Agent98 : NetMasterLibErrors.h
  • netMasterErrMIPForeignAgentAuth132 : NetMasterLibErrors.h
  • netMasterErrMIPHa_Host_Unreachable81 : NetMasterLibErrors.h
  • netMasterErrMIPHa_Port_Unreachable82 : NetMasterLibErrors.h
  • netMasterErrMIPHa_Unreachable88 : NetMasterLibErrors.h
  • netMasterErrMIPHome_Network_Unreachable80 : NetMasterLibErrors.h
  • netMasterErrMIPHomeAgentAuth68 : NetMasterLibErrors.h
  • netMasterErrMIPInsufficientResources130 : NetMasterLibErrors.h
  • netMasterErrMIPInsufficientResources66 : NetMasterLibErrors.h
  • netMasterErrMIPInvalidCareOfAddr77 : NetMasterLibErrors.h
  • netMasterErrMIPMissing_Challenge105 : NetMasterLibErrors.h
  • netMasterErrMIPMissingHa99 : NetMasterLibErrors.h
  • netMasterErrMIPMissingNai97 : NetMasterLibErrors.h
  • netMasterErrMIPMobileNodeAuth131 : NetMasterLibErrors.h
  • netMasterErrMIPMobileNodeAuth67 : NetMasterLibErrors.h
  • netMasterErrMIPMustRevTun138 : NetMasterLibErrors.h
  • netMasterErrMIPMustRevTun75 : NetMasterLibErrors.h
  • netMasterErrMIPNonZeroHaRequested96 : NetMasterLibErrors.h
  • netMasterErrMIPNoSimBindings : NetMasterLibErrors.h
  • netMasterErrMIPPoorlyFormedReply71 : NetMasterLibErrors.h
  • netMasterErrMIPPoorlyFormedReq134 : NetMasterLibErrors.h
  • netMasterErrMIPPoorlyFormedReq70 : NetMasterLibErrors.h
  • netMasterErrMIPReasonUnspecified128 : NetMasterLibErrors.h
  • netMasterErrMIPReasonUnspecified64 : NetMasterLibErrors.h
  • netMasterErrMIPRegIdMismatch133 : NetMasterLibErrors.h
  • netMasterErrMIPRegistration_Timeout78 : NetMasterLibErrors.h
  • netMasterErrMIPReqedEncapUnavail72 : NetMasterLibErrors.h
  • netMasterErrMIPReqEncapNotAvail139 : NetMasterLibErrors.h
  • netMasterErrMIPReqLifetimeTooLong69 : NetMasterLibErrors.h
  • netMasterErrMIPReserved2 : NetMasterLibErrors.h
  • netMasterErrMIPReserved3 : NetMasterLibErrors.h
  • netMasterErrMIPReserved4 : NetMasterLibErrors.h
  • netMasterErrMIPReservedNUnavail73 : NetMasterLibErrors.h
  • netMasterErrMIPStale_Challenge106 : NetMasterLibErrors.h
  • netMasterErrMIPTooManySimMobBindings135 : NetMasterLibErrors.h
  • netMasterErrMIPUnknown_Challenge104 : NetMasterLibErrors.h
  • netMasterErrMIPUnknownHaAddr136 : NetMasterLibErrors.h
  • netMasterErrMIPUsernameSuspension801 : NetMasterLibErrors.h
  • netMasterErrNetGuardReqDuringBGLogin : NetMasterLibErrors.h
  • netMasterErrNetNotInstalled : NetMasterLibErrors.h
  • netMasterErrNo1xService : NetMasterLibErrors.h
  • netMasterErrNoNetPrefLib : NetMasterLibErrors.h
  • netMasterErrNoOneXServiceWhileRoaming : NetMasterLibErrors.h
  • netMasterErrOneXServiceNotEnabled : NetMasterLibErrors.h
  • netMasterErrOneXServiceUnavailable : NetMasterLibErrors.h
  • netMasterErrStorage : NetMasterLibErrors.h
  • netMasterErrUIRPCTimeout : NetMasterLibErrors.h
  • netMasterErrUnused45 : NetMasterLibErrors.h
  • netMasterErrUnused46 : NetMasterLibErrors.h
  • netMasterErrUnused47 : NetMasterLibErrors.h
  • netMasterErrUnused48 : NetMasterLibErrors.h
  • netMasterErrUnused49 : NetMasterLibErrors.h
  • netMasterErrUnused4A : NetMasterLibErrors.h
  • netMasterErrUnused4B : NetMasterLibErrors.h
  • netMasterErrUnused4C : NetMasterLibErrors.h
  • netMasterErrUnused4D : NetMasterLibErrors.h
  • netMasterErrUnused4E : NetMasterLibErrors.h
  • netMasterLibCreatorID : NetMasterLibTarget.h
  • netMasterLibName : NetMasterLibTarget.h
  • netMasterLibTrapAutoLoginSettingGet : NetMasterLibTraps.h
  • netMasterLibTrapAutoLoginSettingSet : NetMasterLibTraps.h
  • netMasterLibTrapControl : NetMasterLibTraps.h
  • netMasterLibTrapDataCounterGetAndReset : NetMasterLibTraps.h
  • netMasterLibTrapDataSessionErrorNotify : NetMasterLibTraps.h
  • netMasterLibTrapHandlePhoneEvent : NetMasterLibTraps.h
  • netMasterLibTrapImplementNetLibConnectionRefresh : NetMasterLibTraps.h
  • netMasterLibTrapImplementNetLibHandlePowerOff : NetMasterLibTraps.h
  • netMasterLibTrapImplementNetLibOpenConfig : NetMasterLibTraps.h
  • netMasterLibTrapLibInit : NetMasterLibTraps.h
  • netMasterLibTrapLibVersionGet : NetMasterLibTraps.h
  • netMasterLibTrapLoginExecuteFromUI : NetMasterLibTraps.h
  • netMasterLibTrapLoginSMFlagsSetAndGet : NetMasterLibTraps.h
  • netMasterLibTrapNetInterfacesShutDown : NetMasterLibTraps.h
  • netMasterLibTrapNetLibIsFullyUp : NetMasterLibTraps.h
  • netMasterLibTrapNetLibIsLoggingIn : NetMasterLibTraps.h
  • netMasterLibTrapNetLibOpenIfFullyUp : NetMasterLibTraps.h
  • netMasterLibTrapNetLibOpenWithOptions : NetMasterLibTraps.h
  • netMasterLibTrapOverrideErrorGetAndClear : NetMasterLibTraps.h
  • netMasterLibTrapOverrideMdmInitStrGetPtr : NetMasterLibTraps.h
  • netMasterLibTrapPhoneServiceClassesGet : NetMasterLibTraps.h
  • netMasterLibTrapPPPPayloadReport : NetMasterLibTraps.h
  • netMasterLibTrapSCContextAnchorTimeoutSet : NetMasterLibTraps.h
  • netMasterLibTrapSCNetAttach : NetMasterLibTraps.h
  • netMasterLibTrapSCNetDetach : NetMasterLibTraps.h
  • netMasterLibTrapSCSessionCountGet : NetMasterLibTraps.h
  • netMasterLibTrapSCSessionIDGetFromContext : NetMasterLibTraps.h
  • netMasterLibTrapSCSessionIsActive : NetMasterLibTraps.h
  • netMasterLibTrapSCSessionsEnumerate : NetMasterLibTraps.h
  • netMasterLibTrapSCSessionShutDown : NetMasterLibTraps.h
  • netMasterLibTrapSCSessionSvcRecIDGet : NetMasterLibTraps.h
  • netMasterLibTrapServiceSetUp : NetMasterLibTraps.h
  • netMasterLibTypeID : NetMasterLibTarget.h
  • netMasterLibVersionBugFix : NetMasterLibTypes.h
  • netMasterLibVersionMajor : NetMasterLibTypes.h
  • netMasterLibVersionMinor : NetMasterLibTypes.h
  • netMediaConnected : PalmWiFiCommon.h
  • netMediaDisconnected : PalmWiFiCommon.h
  • netNum80211Rates : PalmWiFiCommon.h
  • netPref1xRTTTunnelingDefault : NetPrefLibTypes.h
  • NETPREF_LIB_TRAP : NetPrefLibrary.h
  • netPrefErrBadArg : NetPrefLibErrors.h
  • netPrefErrCCSMIncomplete : NetPrefLibErrors.h
  • netPrefErrCCSMNoCarrierMatch : NetPrefLibErrors.h
  • netPrefErrClass : NetPrefLibErrors.h
  • netPrefErrCSDNotAllowed : NetPrefLibErrors.h
  • netPrefErrFieldNotInSet : NetPrefLibErrors.h
  • netPrefErrMemory : NetPrefLibErrors.h
  • netPrefErrNoCCSMSettings : NetPrefLibErrors.h
  • netPrefErrNVRead : NetPrefLibErrors.h
  • netPrefErrNVSync : NetPrefLibErrors.h
  • netPrefErrNVWrite : NetPrefLibErrors.h
  • netPrefErrNVWritePDPInUse : NetPrefLibErrors.h
  • netPrefErrPhoneLibOpenFailed : NetPrefLibErrors.h
  • netPrefErrRadioIsOff : NetPrefLibErrors.h
  • netPrefErrReadOnlyField : NetPrefLibErrors.h
  • netPrefErrRecGone : NetPrefLibErrors.h
  • netPrefErrRecNotSaved : NetPrefLibErrors.h
  • netPrefErrStorage : NetPrefLibErrors.h
  • netPrefLibCreatorID : NetPrefLibTarget.h
  • netPrefLibName : NetPrefLibTarget.h
  • netPrefLibTrapDefaultTargetGet : NetPrefLibTraps.h
  • netPrefLibTrapDefaultTargetSet : NetPrefLibTraps.h
  • netPrefLibTrapHandleHotSyncNotify : NetPrefLibTraps.h
  • netPrefLibTrapRecBindingErrorGet : NetPrefLibTraps.h
  • netPrefLibTrapRecByteFieldGet : NetPrefLibTraps.h
  • netPrefLibTrapRecConnectionInfoGet : NetPrefLibTraps.h
  • netPrefLibTrapRecCountGet : NetPrefLibTraps.h
  • netPrefLibTrapRecDelete : NetPrefLibTraps.h
  • netPrefLibTrapRecDirtyFlagsReset : NetPrefLibTraps.h
  • netPrefLibTrapRecFieldAddToSet : NetPrefLibTraps.h
  • netPrefLibTrapRecFieldAttrsGet : NetPrefLibTraps.h
  • netPrefLibTrapRecFieldGet : NetPrefLibTraps.h
  • netPrefLibTrapRecFieldSet : NetPrefLibTraps.h
  • netPrefLibTrapRecFieldSetDefine : NetPrefLibTraps.h
  • netPrefLibTrapRecFieldSetDefineStd : NetPrefLibTraps.h
  • netPrefLibTrapRecFieldSetFromBinHandle : NetPrefLibTraps.h
  • netPrefLibTrapRecFieldSetFromStrHandle : NetPrefLibTraps.h
  • netPrefLibTrapRecFieldSetFromStrPtr : NetPrefLibTraps.h
  • netPrefLibTrapRecFieldSetGet : NetPrefLibTraps.h
  • netPrefLibTrapRecFieldViewGet : NetPrefLibTraps.h
  • netPrefLibTrapRecFieldViewSet : NetPrefLibTraps.h
  • netPrefLibTrapRecIDGet : NetPrefLibTraps.h
  • netPrefLibTrapRecIDGetByIndex : NetPrefLibTraps.h
  • netPrefLibTrapRecIndexGet : NetPrefLibTraps.h
  • netPrefLibTrapRecIndexGetByID : NetPrefLibTraps.h
  • netPrefLibTrapRecIPAddrFieldSet : NetPrefLibTraps.h
  • netPrefLibTrapRecIsAttached : NetPrefLibTraps.h
  • netPrefLibTrapRecIsDirty : NetPrefLibTraps.h
  • netPrefLibTrapRecLoad : NetPrefLibTraps.h
  • netPrefLibTrapRecLongFieldGet : NetPrefLibTraps.h
  • netPrefLibTrapRecLongFieldSetAsFlags : NetPrefLibTraps.h
  • netPrefLibTrapRecMarkDirty : NetPrefLibTraps.h
  • netPrefLibTrapRecMediumDerive : NetPrefLibTraps.h
  • netPrefLibTrapRecNew : NetPrefLibTraps.h
  • netPrefLibTrapRecObjAlloc : NetPrefLibTraps.h
  • netPrefLibTrapRecObjCopy : NetPrefLibTraps.h
  • netPrefLibTrapRecPhoneStringCompose : NetPrefLibTraps.h
  • netPrefLibTrapRecReadOnlyOverrideEnd : NetPrefLibTraps.h
  • netPrefLibTrapRecReadOnlyOverrideStart : NetPrefLibTraps.h
  • netPrefLibTrapRecRelease : NetPrefLibTraps.h
  • netPrefLibTrapRecSave : NetPrefLibTraps.h
  • netPrefLibTrapRecShortFieldGet : NetPrefLibTraps.h
  • netPrefLibTrapUpdateFromRadioNV : NetPrefLibTraps.h
  • netPrefLibTrapUtilDefWirelessDriverIDGet : NetPrefLibTraps.h
  • netPrefLibTrapUtilPlatformIDGet : NetPrefLibTraps.h
  • netPrefLibTrapUtilZStringListSizeGet : NetPrefLibTraps.h
  • netPrefLibTrapVersionGet : NetPrefLibTraps.h
  • netPrefLibTypeID : NetPrefLibTarget.h
  • netPrefLibVersionBugFix : NetPrefLibTypes.h
  • netPrefLibVersionMajor : NetPrefLibTypes.h
  • netPrefLibVersionMinor : NetPrefLibTypes.h
  • netPrefMaxPhoneStringSize : NetPrefLibTypes.h
  • netPrefRecFieldAttrDirty : NetPrefLibTypes.h
  • netPrefRecFieldAttrInSet : NetPrefLibTypes.h
  • NetPrefRecFieldInfoExtended : NetPrefLibTypes.h
  • NetPrefRecFieldInfoFIRST : NetPrefLibTypes.h
  • NetPrefRecFieldInfoGrpEnd : NetPrefLibTypes.h
  • NetPrefRecFieldInfoGrpStart : NetPrefLibTypes.h
  • NetPrefRecFieldInfoLAST : NetPrefLibTypes.h
  • NetPrefRecFieldInfoLegacy : NetPrefLibTypes.h
  • NetPrefRecFieldInfoPreamble : NetPrefLibTypes.h
  • netPrefRecFieldViewCache : NetPrefLibTypes.h
  • netPrefRecFieldViewClearAll : NetPrefLibTypes.h
  • netPrefRecFieldViewCurrentlyValidFlags : NetPrefLibTypes.h
  • netPrefRecFieldViewEditable : NetPrefLibTypes.h
  • netPrefRecFieldViewExternal : NetPrefLibTypes.h
  • netPrefRecFieldViewPrivate : NetPrefLibTypes.h
  • netPrefRecFieldViewRead : NetPrefLibTypes.h
  • netPrefRecFieldViewVisible : NetPrefLibTypes.h
  • netPrefRecFieldViewWrite : NetPrefLibTypes.h
  • NetPrefUtilLoginScriptLen : NetPrefLibrary.h
  • NetServicesLibTrapGetChannel : PalmNetServices.h
  • NetServicesLibTrapGetChannelList : PalmNetServices.h
  • NetServicesLibTrapGetCommsQuality : PalmNetServices.h
  • NetServicesLibTrapGetDeviceInfo : PalmNetServices.h
  • NetServicesLibTrapGetHWAddr : PalmNetServices.h
  • NetServicesLibTrapGetPowerState : PalmNetServices.h
  • NetServicesLibTrapGetRadioState : PalmNetServices.h
  • NetServicesLibTrapGetScanResults : PalmNetServices.h
  • NetServicesLibTrapProfileAdd : PalmNetServices.h
  • NetServicesLibTrapProfileDelete : PalmNetServices.h
  • NetServicesLibTrapProfileFind : PalmNetServices.h
  • NetServicesLibTrapProfileGetInfo : PalmNetServices.h
  • NetServicesLibTrapProfileGetOrder : PalmNetServices.h
  • NetServicesLibTrapProfileRead : PalmNetServices.h
  • NetServicesLibTrapProfileSetOrder : PalmNetServices.h
  • NetServicesLibTrapProfileWrite : PalmNetServices.h
  • NetServicesLibTrapSetRadioState : PalmNetServices.h
  • NetServicesLibTrapStartScan : PalmNetServices.h
  • netSSIDMaxLength : PalmWiFiCommon.h
  • NULL : PalmNative.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:38 2008 for Palm API Guide


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- o -

  • oemErrorClass : PalmErrorBase.h
  • Omega11BitMap : SmartTextEngineRsc.h
  • Omega14BitMap : SmartTextEngineRsc.h
  • OVLY_LIB_TRAP : PalmLcdOverlay.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:38 2008 for Palm API Guide


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- a -

  • Addressing16bitID : HsPhoneSMSTypes.h
  • Addressing16bitIDLen : HsPhoneSMSTypes.h
  • Addressing8bitID : HsPhoneSMSTypes.h
  • Addressing8bitIDLen : HsPhoneSMSTypes.h
  • AddrHsLookupUserDataVersion : HsAppLaunchCmd.h
  • AddrHsLookupUserDataVersion2 : HsAppLaunchCmd.h
  • addrLookupNoMinLength : HsAppLaunchCmd.h
  • aiaExtentChangedData : PalmPin.h
  • AiaExtentChangedEvent : PalmPin.h
  • AP_DENSITY_HIGH : PalmWiFiCommon.h
  • AP_DENSITY_LOW : PalmWiFiCommon.h
  • AP_DENSITY_MED : PalmWiFiCommon.h
  • appPrefsID : Slider.h
  • appPrefsVersion : Slider.h
  • apptMaxTimeZoneNameLen : DatebookLibCommon.h
  • ATTYPE_MAX_NAME_LEN : PalmVMPlugin.h
  • AUTHENTICATION_ALGORITHM_OPEN_SYSTEM : PalmWiFiCommon.h
  • AUTHENTICATION_ALGORITHM_SHARED_KEY : PalmWiFiCommon.h
  • AUTHENTICATION_ALGORITHM_SHARED_KEY_128 : PalmWiFiCommon.h
  • AUTO_PREAMBLE : PalmWiFiCommon.h
  • AUTO_TX_POWER : PalmWiFiCommon.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:38 2008 for Palm API Guide


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- b -

  • bbutGadgetMiscSelectData : HsExtUtilBigButtonCommon.h
  • bbutGadgetMiscSelectSelector : HsExtUtilBigButtonCommon.h
  • bgServiceCreatorID : PalmBGService.h
  • bgServiceLibName : PalmBGService.h
  • bgServiceType : PalmBGService.h
  • bgTrapAPIVersion : PalmBGService.h
  • bgTrapCancelRqst : PalmBGService.h
  • bgTrapINetLibRqst : PalmBGService.h
  • bgTrapNetLibRqst : PalmBGService.h
  • BSSINFO_ANL_OFFSET : PalmWiFiCommon.h
  • BSSINFO_ANL_SIZE : PalmWiFiCommon.h
  • BSSINFO_ANL_VFLAG : PalmWiFiCommon.h
  • BSSINFO_ATIM_WINDOW_OFFSET : PalmWiFiCommon.h
  • BSSINFO_ATIM_WINDOW_SIZE : PalmWiFiCommon.h
  • BSSINFO_ATIM_WINDOW_VFLAG : PalmWiFiCommon.h
  • BSSINFO_BEACON_PERIOD_OFFSET : PalmWiFiCommon.h
  • BSSINFO_BEACON_PERIOD_SIZE : PalmWiFiCommon.h
  • BSSINFO_BEACON_PERIOD_VFLAG : PalmWiFiCommon.h
  • BSSINFO_CHID_OFFSET : PalmWiFiCommon.h
  • BSSINFO_CHID_SIZE : PalmWiFiCommon.h
  • BSSINFO_CHID_VFLAG : PalmWiFiCommon.h
  • BSSINFO_DSFREQ_OFFSET : PalmWiFiCommon.h
  • BSSINFO_DSFREQ_SIZE : PalmWiFiCommon.h
  • BSSINFO_DSFREQ_VFLAG : PalmWiFiCommon.h
  • BSSINFO_HOPDWELL_OFFSET : PalmWiFiCommon.h
  • BSSINFO_HOPDWELL_SIZE : PalmWiFiCommon.h
  • BSSINFO_HOPDWELL_VFLAG : PalmWiFiCommon.h
  • BSSINFO_HOPPATTERN_OFFSET : PalmWiFiCommon.h
  • BSSINFO_HOPPATTERN_SIZE : PalmWiFiCommon.h
  • BSSINFO_HOPPATTERN_VFLAG : PalmWiFiCommon.h
  • BSSINFO_HOPSET_OFFSET : PalmWiFiCommon.h
  • BSSINFO_HOPSET_SIZE : PalmWiFiCommon.h
  • BSSINFO_HOPSET_VFLAG : PalmWiFiCommon.h
  • BSSINFO_MAC_ADDR_OFFSET : PalmWiFiCommon.h
  • BSSINFO_MAC_ADDR_SIZE : PalmWiFiCommon.h
  • BSSINFO_MAC_ADDR_VFLAG : PalmWiFiCommon.h
  • BSSINFO_NETWORK_MODE_OFFSET : PalmWiFiCommon.h
  • BSSINFO_NETWORK_MODE_SIZE : PalmWiFiCommon.h
  • BSSINFO_NETWORK_MODE_VFLAG : PalmWiFiCommon.h
  • BSSINFO_NETWORK_TYPE_OFFSET : PalmWiFiCommon.h
  • BSSINFO_NETWORK_TYPE_SIZE : PalmWiFiCommon.h
  • BSSINFO_NETWORK_TYPE_VFLAG : PalmWiFiCommon.h
  • BSSINFO_RSSI_OFFSET : PalmWiFiCommon.h
  • BSSINFO_RSSI_SIZE : PalmWiFiCommon.h
  • BSSINFO_RSSI_VFLAG : PalmWiFiCommon.h
  • BSSINFO_SIZE : PalmWiFiCommon.h
  • BSSINFO_SSID_OFFSET : PalmWiFiCommon.h
  • BSSINFO_SSID_SIZE : PalmWiFiCommon.h
  • BSSINFO_SSID_VFLAG : PalmWiFiCommon.h
  • BSSINFO_SSIDLENGTH_OFFSET : PalmWiFiCommon.h
  • BSSINFO_SSIDLENGTH_SIZE : PalmWiFiCommon.h
  • BSSINFO_SSIDLENGTH_VFLAG : PalmWiFiCommon.h
  • BSSINFO_SUPPORTED_RATES_OFFSET : PalmWiFiCommon.h
  • BSSINFO_SUPPORTED_RATES_SIZE : PalmWiFiCommon.h
  • BSSINFO_SUPPORTED_RATES_VFLAG : PalmWiFiCommon.h
  • BSSINFO_VFLAG : PalmWiFiCommon.h
  • BSSINFO_VFLAG_SIZE : PalmWiFiCommon.h
  • BSSINFO_WEP_OFFSET : PalmWiFiCommon.h
  • BSSINFO_WEP_SIZE : PalmWiFiCommon.h
  • BSSINFO_WEP_VFLAG : PalmWiFiCommon.h
  • BssInfoANL : PalmWiFiCommon.h
  • BssInfoAtimWindow : PalmWiFiCommon.h
  • BssInfoBeaconPeriod : PalmWiFiCommon.h
  • BssInfoChannelId : PalmWiFiCommon.h
  • BssInfoDSFreq : PalmWiFiCommon.h
  • BssInfoHopDwell : PalmWiFiCommon.h
  • BssInfoHopPattern : PalmWiFiCommon.h
  • BssInfoHopSet : PalmWiFiCommon.h
  • BssInfoMacAddr : PalmWiFiCommon.h
  • BssInfoNetworkMode : PalmWiFiCommon.h
  • BssInfoNetworkType : PalmWiFiCommon.h
  • BssInfoRssi : PalmWiFiCommon.h
  • BssInfoSsid : PalmWiFiCommon.h
  • BssInfoSsidLength : PalmWiFiCommon.h
  • BssInfoSupportedRates : PalmWiFiCommon.h
  • BssInfoWep : PalmWiFiCommon.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:38 2008 for Palm API Guide


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- c -

  • CallWithCommand : HsAppLaunchCmd.h
  • CAM_LIB_TRAP : palmOneCamera.h , PalmHiResTime.h
  • cameraAppLaunchCmdStopPreview : HsAppLaunchCmd.h
  • ccsmErrBufferTooSmall : CarrierCustomLibErr.h
  • ccsmErrClass : CarrierCustomLibErr.h
  • ccsmErrInvalidArg : CarrierCustomLibErr.h
  • ccsmErrLibUninitialized : CarrierCustomLibErr.h
  • ccsmErrMemory : CarrierCustomLibErr.h
  • ccsmErrNotRegistered : CarrierCustomLibErr.h
  • ccsmErrPhoneLibLoad : CarrierCustomLibErr.h
  • ccsmErrPhoneNotPowered : CarrierCustomLibErr.h
  • ccsmErrProfileUnspecified : CarrierCustomLibErr.h
  • ccsmErrUndefinedField : CarrierCustomLibErr.h
  • ccsmErrUnimplemented : CarrierCustomLibErr.h
  • ccsmErrUnknownCarrier : CarrierCustomLibErr.h
  • ccsmErrUnknownField : CarrierCustomLibErr.h
  • ccsmErrUnknownSetting : CarrierCustomLibErr.h
  • ccsmErrUnspecified : CarrierCustomLibErr.h
  • CCSMVersionBugFix : CarrierCustomLibTypes.h
  • CCSMVersionMajor : CarrierCustomLibTypes.h
  • CCSMVersionMinor : CarrierCustomLibTypes.h
  • CCUSTOM_LIB_TRAP : CarrierCustomLib.h
  • CCustomLibTrapGetCarrierCode : CarrierCustomLibTraps.h
  • CCustomLibTrapGetCarrierCodeLength : CarrierCustomLibTraps.h
  • CCustomLibTrapGetCarrierProfile : CarrierCustomLibTraps.h
  • CCustomLibTrapGetCarrierSetting : CarrierCustomLibTraps.h
  • CCustomLibTrapGetProfileSetting : CarrierCustomLibTraps.h
  • CCustomLibTrapRefresh : CarrierCustomLibTraps.h
  • CCustomLibTrapReleaseCarrierProfile : CarrierCustomLibTraps.h
  • CCustomLibTrapRetrieveNVSetting : CarrierCustomLibTraps.h
  • CCustomLibTrapVersionGet : CarrierCustomLibTraps.h
  • codecDriverIMAADPCM : PalmSoundCustomCtrl.h
  • codecIMAADPCMSetBlockSize : PalmSoundCustomCtrl.h
  • CompareToneIdentifiers : TonesLibTypes.h
  • CONTACTS_LIB_TRAP : Contacts.h
  • ContactsAllCategories : Contacts.h
  • ContactsLabelLength : Contacts.h
  • ContactsLibCreatorID : Contacts.h
  • ContactsLibErrAlreadyInWriteMode : Contacts.h
  • ContactsLibErrAppInfoIsMising : Contacts.h
  • ContactsLibErrAttachAlreadyExist : Contacts.h
  • ContactsLibErrAttachNotExist : Contacts.h
  • ContactsLibErrAttachOverFlow : Contacts.h
  • ContactsLibErrAttachOverflow : Contacts.h
  • ContactsLibErrCategoryNotFound : Contacts.h
  • ContactsLibErrContactNotFound : Contacts.h
  • ContactsLibErrContactNotLocked : Contacts.h
  • ContactsLibErrEmptyContact : Contacts.h
  • ContactsLibErrFieldNotFound : Contacts.h
  • ContactsLibErrInvalidAppInfoBlock : Contacts.h
  • ContactsLibErrInvalidField : Contacts.h
  • ContactsLibErrInvalidHandle : Contacts.h
  • ContactsLibErrInvalidParam : Contacts.h
  • ContactsLibErrInvalidReference : Contacts.h
  • ContactsLibErrInvalidSessionHandle : Contacts.h
  • ContactsLibErrLibAlreadyInUse : Contacts.h
  • ContactsLibErrLibStillOpen : Contacts.h
  • ContactsLibErrListNotExist : Contacts.h
  • ContactsLibErrMaxLimitReached : Contacts.h
  • ContactsLibErrorClass : Contacts.h
  • ContactsLibErrOutOfMemory : Contacts.h
  • ContactsLibErrReadOnlySession : Contacts.h
  • ContactsLibErrRecordNotFound : Contacts.h
  • ContactsLibErrSizeParamOverFlow : Contacts.h
  • ContactsLibErrStringNotFound : Contacts.h
  • ContactsLibErrTooManyClients : Contacts.h
  • ContactsLibErrTooManySession : Contacts.h
  • ContactsLibErrUIdExist : Contacts.h
  • ContactsLibErrUIdNotFound : Contacts.h
  • ContactsLibErrVerNotSupported : Contacts.h
  • ContactsLibGetLastErr : Contacts.h
  • ContactsLibName : Contacts.h
  • ContactsLibTrapAddContact : Contacts.h
  • ContactsLibTrapCategoryFind : Contacts.h
  • ContactsLibTrapCloseSession : Contacts.h
  • ContactsLibTrapCreateHandle : Contacts.h
  • ContactsLibTrapDeleteContact : Contacts.h
  • ContactsLibTrapDoesFieldExist : Contacts.h
  • ContactsLibTrapGetBinaryField : Contacts.h
  • ContactsLibTrapGetCategoryList : Contacts.h
  • ContactsLibTrapGetCategoryName : Contacts.h
  • ContactsLibTrapGetContact : Contacts.h
  • ContactsLibTrapGetDateField : Contacts.h
  • ContactsLibTrapGetFieldLabel : Contacts.h
  • ContactsLibTrapGetFirstContact : Contacts.h
  • ContactsLibTrapGetLabelText : Contacts.h
  • ContactsLibTrapGetNextCategory : Contacts.h
  • ContactsLibTrapGetNextContact : Contacts.h
  • ContactsLibTrapGetNumOfRecord : Contacts.h
  • ContactsLibTrapGetRingtoneForCategory : Contacts.h
  • ContactsLibTrapGetStringField : Contacts.h
  • ContactsLibTrapGetUInt16Field : Contacts.h
  • ContactsLibTrapGetUInt32Field : Contacts.h
  • ContactsLibTrapGetUInt8Field : Contacts.h
  • ContactsLibTrapGetVersion : Contacts.h
  • ContactsLibTrapIsEmptyContact : Contacts.h
  • ContactsLibTrapLookUpString : Contacts.h
  • ContactsLibTrapOpenSession : Contacts.h
  • ContactsLibTrapPosInCategory : Contacts.h
  • ContactsLibTrapReleaseHandle : Contacts.h
  • ContactsLibTrapRenameCustomLabel : Contacts.h
  • ContactsLibTrapSeekRecord : Contacts.h
  • ContactsLibTrapSetBinaryField : Contacts.h
  • ContactsLibTrapSetCategoryName : Contacts.h
  • ContactsLibTrapSetDateField : Contacts.h
  • ContactsLibTrapSetFieldLabel : Contacts.h
  • ContactsLibTrapSetStringField : Contacts.h
  • ContactsLibTrapSetUInt16Field : Contacts.h
  • ContactsLibTrapSetUInt8Field : Contacts.h
  • ContactsLibTrapUpdateContact : Contacts.h
  • ContactsLibTypeID : Contacts.h
  • ContactsNumCategories : Contacts.h
  • ContactsSeekBackward : Contacts.h
  • ContactsSeekForward : Contacts.h
  • ContactsUnfiledCategory : Contacts.h
  • CopyMIDIToneIdentifier : TonesLibTypes.h
  • CopyToneIdentifier : TonesLibTypes.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:38 2008 for Palm API Guide


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- d -

  • dbCacheFlag : PmPalmOSNVFS.h
  • DEFAULTHELPERLIB_TRAP : DefaultHelperLib.h
  • defaultHelperLibCreator : DefaultHelperLibTypes.h
  • defaultHelperLibErrBadParams : DefaultHelperLibTypes.h
  • defaultHelperLibErrClass : DefaultHelperLibTypes.h
  • defaultHelperLibErrCreateDBFailed : DefaultHelperLibTypes.h
  • defaultHelperLibErrDBNotFound : DefaultHelperLibTypes.h
  • defaultHelperLibErrDBWriteFailed : DefaultHelperLibTypes.h
  • defaultHelperLibErrNoHelperApp : DefaultHelperLibTypes.h
  • defaultHelperLibErrNoMemory : DefaultHelperLibTypes.h
  • defaultHelperLibErrUserCancel : DefaultHelperLibTypes.h
  • defaultHelperLibName : DefaultHelperLibTypes.h
  • defaultHelperLibTrapGetDefaultHelper : DefaultHelperLibTypes.h
  • defaultHelperLibTrapSetDefaultHelper : DefaultHelperLibTypes.h
  • defaultHelperLibType : DefaultHelperLibTypes.h
  • Delta11BitMap : SmartTextEngineRsc.h
  • Delta14BitMap : SmartTextEngineRsc.h
  • densityFtrCreator : palmOneFeatures.h
  • densityFtrVersion : palmOneFeatures.h
  • devAppLaunchCmdCallerId : PalmLaunchCodes.h
  • devAppLaunchCmdCustomBase : PalmLaunchCodes.h
  • devAppLaunchCmdGenericCall : PalmLaunchCodes.h
  • devAppLaunchCmdIncomingCall : PalmLaunchCodes.h
  • devAppLaunchCmdIncomingCallTest : PalmLaunchCodes.h
  • devAppLaunchCmdSliderClosed : PalmLaunchCodes.h
  • devAppLaunchCmdSliderOpened : PalmLaunchCodes.h
  • devAppLaunchCmdTelPowerOn : PalmLaunchCodes.h
  • devAppLaunchGenericCallOpCustomBase : PalmLaunchCodes.h
  • devAppLaunchGenericCallOpExit : PalmLaunchCodes.h
  • devAppLaunchGenericCallOpReturn : PalmLaunchCodes.h
  • devAppLaunchGenericCallOpSubcall : PalmLaunchCodes.h
  • devAppLaunchGenericCallRetAccepted : PalmLaunchCodes.h
  • devAppLaunchGenericCallRetRejected : PalmLaunchCodes.h
  • devAppLaunchLauncherDUBegin : PalmLaunchCodes.h
  • devAppLaunchLauncherDUEnd : PalmLaunchCodes.h
  • devAppLaunchLPCM_DUBegin : PalmLaunchCodes.h
  • devAppLaunchLPCM_DUEnd : PalmLaunchCodes.h
  • devAppLaunchMyFavorite : PalmLaunchCodes.h
  • devAppLaunchWithCodeCheck : PalmLaunchCodes.h
  • dexFtrNumVersion : PalmDisplayExtent.h
  • dexLibCreator : PalmDisplayExtent.h
  • dexLibName : PalmDisplayExtent.h
  • dexLibType : PalmDisplayExtent.h
  • dpiFtrValue : palmOneFeatures.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:38 2008 for Palm API Guide


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- e -

  • ENCRYPTED_DATABASE : CarrierCustomLib.h
  • END_OF_LIST : PalmNetServices.h
  • ENHANCED_TX_POWER : PalmWiFiCommon.h
  • errCam : CameraLibCommon.h
  • errCamNoFrame : CameraLibCommon.h
  • errCamOverflow : CameraLibCommon.h
  • errCamWriteFailed : CameraLibCommon.h
  • errInPreviewMode : CameraLibCommon.h
  • errInvalidAddress : CameraLibCommon.h
  • errNetInterfaceNotFound : PalmWiFiCommon.h
  • errNetLibMissing : PalmWiFiCommon.h
  • errNetOutOfMemory : PalmWiFiCommon.h
  • errNetQueryBufTooSmall : PalmWiFiCommon.h
  • ESS : PalmWiFiCommon.h
  • exFileCArcSoftCamera : HsCreators.h
  • exFileCArcSoftMedia : HsCreators.h
  • exgRegEditCreatorID : FileBrowserLibCommon.h
  • exgRegEditExtensionID : FileBrowserLibCommon.h
  • exgRegEditTypeID : FileBrowserLibCommon.h
  • expCapabilityHidden : PmPalmOSNVFS.h
  • expCapabilityNonRemovable : PmPalmOSNVFS.h
  • expIncludePrivateSlots : PmPalmOSNVFS.h
  • expMediaType_HD : palmOneCreators.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:38 2008 for Palm API Guide


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- f -

  • false : PalmNative.h
  • FAR_CALL : FarCall.h
  • FAR_DECLARE : FarCall.h
  • FAR_PTR : FarCall.h
  • favoritesDBLibCreator : FavoritesDBLibTypes.h
  • favoritesDBLibErrBadParams : FavoritesDBLibTypes.h
  • favoritesDBLibErrClass : FavoritesDBLibTypes.h
  • favoritesDBLibErrCreateDBFailed : FavoritesDBLibTypes.h
  • favoritesDBLibErrDBNotFound : FavoritesDBLibTypes.h
  • favoritesDBLibErrDBWriteFailed : FavoritesDBLibTypes.h
  • favoritesDBLibErrNoMemory : FavoritesDBLibTypes.h
  • favoritesDBLibErrUserCancel : FavoritesDBLibTypes.h
  • favoritesDBLibIsFavoriteWithId : FavoritesDBLibTypes.h
  • favoritesDBLibName : FavoritesDBLibTypes.h
  • favoritesDBLibTrapGetRecordId : FavoritesDBLibTypes.h
  • favoritesDBLibTrapGetRecordLabel : FavoritesDBLibTypes.h
  • favoritesDBLibTrapGetSpeedDialInfo : FavoritesDBLibTypes.h
  • favoritesDBLibTrapLookupInSpeedDialDB : FavoritesDBLibTypes.h
  • favoritesDBLibTrapNewAppFavorite : FavoritesDBLibTypes.h
  • favoritesDBLibTrapNewEmailFavorite : FavoritesDBLibTypes.h
  • favoritesDBLibTrapNewMsgFavorite : FavoritesDBLibTypes.h
  • favoritesDBLibTrapNewPhoneFavorite : FavoritesDBLibTypes.h
  • favoritesDBLibTrapNewPhoneViewFavorite : FavoritesDBLibTypes.h
  • favoritesDBLibTrapNewWebFavorite : FavoritesDBLibTypes.h
  • favoritesDBLibTrapResolveAddress : FavoritesDBLibTypes.h
  • favoritesDBLibTrapSeekSpeedDialRecord : FavoritesDBLibTypes.h
  • favoritesDBLibType : FavoritesDBLibTypes.h
  • FILE_BROWSER_LIB_TRAP : FileBrowserLib68K.h
  • flTrapAPIClearCache : VMFontLibCommon.h
  • flTrapAPIDoFontDialog : VMFontLibCommon.h
  • flTrapAPIFontCountStyleAndSize : VMFontLibCommon.h
  • flTrapAPIFontExists : VMFontLibCommon.h
  • flTrapAPIFontToString : VMFontLibCommon.h
  • flTrapAPIGetFont : VMFontLibCommon.h
  • flTrapAPIGetFontByID : VMFontLibCommon.h
  • flTrapAPIInitFontUI : VMFontLibCommon.h
  • flTrapAPISetFontUIRules : VMFontLibCommon.h
  • flTrapAPIVersion : VMFontLibCommon.h
  • fontPickerCreatorID : VMFontLibCommon.h
  • fontPickerLibName : VMFontLibCommon.h
  • fontPickerType : VMFontLibCommon.h
  • formNavRscType : HsNavCommon.h
  • frmNavFocusRingNoExtraInfo : HsNavCommon.h
  • Full16bitTextHeader : HsPhoneSMSTypes.h
  • Full8bitTextHeader : HsPhoneSMSTypes.h
  • FULL_TX_POWER : PalmWiFiCommon.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:38 2008 for Palm API Guide


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- g -

  • Gamma11BitMap : SmartTextEngineRsc.h
  • Gamma14BitMap : SmartTextEngineRsc.h
  • goLcdColorDefault : PalmGoLCDCommon.h
  • goLcdColorInverted : PalmGoLCDCommon.h
  • goLcdColorOverride : PalmGoLCDCommon.h
  • goLcdCreator : PalmGoLCDCommon.h
  • goLcdDisabled : PalmGoLCDCommon.h
  • goLcdEnabled : PalmGoLCDCommon.h
  • goLcdFtrNumVersion : PalmGoLCDCommon.h
  • goLcdGraffitiMode : PalmGoLCDCommon.h
  • goLcdGsiNormal : PalmGoLCDCommon.h
  • goLcdGsiOverride : PalmGoLCDCommon.h
  • goLcdInkDisabled : PalmGoLCDCommon.h
  • goLcdInkEnabled : PalmGoLCDCommon.h
  • GoLcdLibAPIVersion : PalmGoLCDCommon.h
  • goLcdLibCreator : PalmGoLCDCommon.h
  • goLcdLibFtrNum : PalmGoLCDCommon.h
  • goLcdLibName : PalmGoLCDCommon.h
  • goLcdLibType : PalmGoLCDCommon.h
  • goLcdModeCount : PalmGoLCDCommon.h
  • goLcdNotAvailable : PalmGoLCDCommon.h
  • goLcdNotifyStatusEvent : PalmGoLCDCommon.h
  • goLcdPenTapMode : PalmGoLCDCommon.h
  • GSMLibRingsDBCreatorID : HsCreators.h
  • GSMLibRingsDbName : HsPhoneGSMTypes.h
  • GSMLockSelectorOperatorLock : HsPhoneGSMTypes.h
  • GSMLockSelectorProviderLock : HsPhoneGSMTypes.h
  • GSMReserved10 : HsPhoneTraps.h
  • GSMReserved11 : HsPhoneTraps.h
  • GSMReserved12 : HsPhoneTraps.h
  • GSMReserved13 : HsPhoneTraps.h
  • GSMReserved14 : HsPhoneTraps.h
  • GSMReserved15 : HsPhoneTraps.h
  • GSMReserved16 : HsPhoneTraps.h
  • GSMReserved17 : HsPhoneTraps.h
  • GSMReserved18 : HsPhoneTraps.h
  • GSMReserved19 : HsPhoneTraps.h
  • GSMReserved20 : HsPhoneTraps.h
  • GSMReserved21 : HsPhoneTraps.h
  • GSMReserved22 : HsPhoneTraps.h
  • GSMReserved8 : HsPhoneTraps.h
  • GSMReserved9 : HsPhoneTraps.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:38 2008 for Palm API Guide


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- h -

  • headsetFtrCreator : palmOneFeatures.h
  • headsetFtrVersion : palmOneFeatures.h
  • HelperEnumerateEnqueueEntry : HsHelper.h
  • HS_AC97 : HsSoundLibCommon.h
  • HS_HTTPLibDBType : HS_HTTPLibApp.h
  • HS_HTTPLibID : HS_HTTPLibApp.h
  • HS_HTTPLibName : HS_HTTPLibApp.h
  • HS_RDIO : HsSoundLibCommon.h
  • HS_SND_ERR : HsSoundLibCommon.h
  • HsAboutHandspringAppWithYearCredId : HsExt.h
  • HsAboutHandspringAppWithYearId : HsExt.h
  • hsAmrDecLib : HsCreators.h
  • hsAmrEncLib : HsCreators.h
  • hsAmrLib : HsCreators.h
  • hsAppErrorClass : HsErrorClasses.h
  • hsAttrPhoneTypeCDMA : HsExtCommon.h
  • hsAttrPhoneTypeGSM : HsExtCommon.h
  • hsAttrRingSwitchLoud : HsExtCommon.h
  • hsAttrRingSwitchMute : HsExtCommon.h
  • hsAttrSysActiveBeamProgress : HsExtCommon.h
  • hsAttrSysActiveHotSync : HsExtCommon.h
  • hsAttrSysActiveProgress : HsExtCommon.h
  • hsBigButtonFlagNoBackground : HsExtUtilBigButtonRsc.h
  • hsBigButtonFlagNoBorder : HsExtUtilBigButtonRsc.h
  • hsBigButtonFlagNoBorderOrBackground : HsExtUtilBigButtonRsc.h
  • hsBigButtonFlagNone : HsExtUtilBigButtonRsc.h
  • hsBigButtonFontBold : HsExtUtilBigButtonRsc.h
  • hsBigButtonFontLarge : HsExtUtilBigButtonRsc.h
  • hsBigButtonFontLargeBold : HsExtUtilBigButtonRsc.h
  • hsBigButtonFontLed : HsExtUtilBigButtonRsc.h
  • hsBigButtonFontStd : HsExtUtilBigButtonRsc.h
  • hsBigButtonFontSymbol : HsExtUtilBigButtonRsc.h
  • hsBigButtonFontSymbol11 : HsExtUtilBigButtonRsc.h
  • hsBigButtonFontSymbol7 : HsExtUtilBigButtonRsc.h
  • hsBigButtonMappingVersion0 : HsExtUtilBigButtonRsc.h
  • hsBigButtonRscType : HsExtUtilBigButtonCommon.h
  • hsBluetoothIdToken : HsCreators.h
  • hsCcpErrorClass : HsErrorClasses.h
  • hsChrAnswer : HsChars.h
  • hsChrDarkMode : HsChars.h
  • hsChrDeleteWord : HsChars.h
  • hsChrKeyboardLock : HsChars.h
  • hsChrLidStatusChg : HsChars.h
  • hsChrLowBatteryShutdown : HsChars.h
  • hsChrModifierKey : HsChars.h
  • hsChrMuteOff : HsChars.h
  • hsChrMuteOn : HsChars.h
  • hsChrNetMasterUIExecute : HsChars.h
  • hsChrNoop : HsChars.h
  • hsChrOptHard1 : HsChars.h
  • hsChrOptHard11 : HsChars.h
  • hsChrOptHard13 : HsChars.h
  • hsChrOptHard2 : HsChars.h
  • hsChrOptHard3 : HsChars.h
  • hsChrOptHard4 : HsChars.h
  • hsChrOptHardPower : HsChars.h
  • hsChrOptReserved : HsChars.h
  • hsChrPostProcess : HsChars.h
  • hsChrRadioPower : HsChars.h
  • hsChrRangeMax : HsChars.h
  • hsChrRangeMin : HsChars.h
  • hsChrRedialList : HsChars.h
  • hsChrReserved1622 : HsChars.h
  • hsChrShiftPageDown : HsChars.h
  • hsChrShiftPageUp : HsChars.h
  • hsChrShutdownNetlib : HsChars.h
  • hsChrSide : HsChars.h
  • hsChrSymbol : HsChars.h
  • hsChrVolumeDown : HsChars.h
  • hsChrVolumeUp : HsChars.h
  • hsChrWakeup : HsChars.h
  • hsCompressedDbCreatorId : HsCreators.h
  • hsCompressedDbTypeId : HsCreators.h
  • hsDeviceIDOs5Device1 : HsExtCommon.h
  • hsDeviceIDOs5Device1Sim : HsExtCommon.h
  • hsDeviceIDTreo180 : HsExtCommon.h
  • hsDeviceIDTreo270 : HsExtCommon.h
  • hsDeviceIDTreo300 : HsExtCommon.h
  • hsDeviceIDTreo600 : HsExtCommon.h
  • hsDeviceIDTreo600Sim : HsExtCommon.h
  • hsDeviceIDTreo90 : HsExtCommon.h
  • hsDeviceIDVisor : HsExtCommon.h
  • hsDeviceIDVisorEdge : HsExtCommon.h
  • hsDeviceIDVisorNeo : HsExtCommon.h
  • hsDeviceIDVisorPlatinum : HsExtCommon.h
  • hsDeviceIDVisorPrism : HsExtCommon.h
  • hsDeviceIDVisorPro : HsExtCommon.h
  • hsDialPrefs4DigitPrefixLength : HsAppLaunchCmd.h
  • hsDialPrefs5DigitPrefixLength : HsAppLaunchCmd.h
  • hsDialPrefs6DigitPrefixLength : HsAppLaunchCmd.h
  • hsDialPrefsAutoAreaCodeLength : HsAppLaunchCmd.h
  • hsDialPrefsMaxDialingPrefixLength : HsAppLaunchCmd.h
  • hsDispFtrCreator : HsExtCommon.h
  • hsDispFtrIDControllerShades : HsExtCommon.h
  • hsDispFtrIDDisplayAttributes : HsExtCommon.h
  • hsDispFtrIDDisplayShades : HsExtCommon.h
  • hsDispFtrValBlueOffset : HsExtCommon.h
  • hsDispFtrValBulverdePxa27X : HsExtCommon.h
  • hsDispFtrValBwStn : HsExtCommon.h
  • hsDispFtrValColorOled : HsExtCommon.h
  • hsDispFtrValColorStn : HsExtCommon.h
  • hsDispFtrValColorTft : HsExtCommon.h
  • hsDispFtrValDragonballVZ : HsExtCommon.h
  • hsDispFtrValGrayOffset : HsExtCommon.h
  • hsDispFtrValGreenOffset : HsExtCommon.h
  • hsDispFtrValLCDControllerTypeMask : HsExtCommon.h
  • hsDispFtrValLCDDisplayTypeMask : HsExtCommon.h
  • hsDispFtrValOmapX10 : HsExtCommon.h
  • hsDispFtrValRedOffset : HsExtCommon.h
  • hsDispFtrValSed1375 : HsExtCommon.h
  • hsDispFtrValSed1376 : HsExtCommon.h
  • hsDispFtrValSed13A3 : HsExtCommon.h
  • hsErrAppStopEvent : HsExtCommon.h
  • hsErrBufferTooSmall : HsExtCommon.h
  • hsErrCardNotInstalled : HsExtCommon.h
  • hsErrCardPatchAlreadyInstalled : HsExtCommon.h
  • hsErrCardPatchNotInstalled : HsExtCommon.h
  • hsErrFixedStorageRequired : HsExtCommon.h
  • hsErrGPRSNotAttached : HsExtCommon.h
  • hsErrIndicatorDisabled : HsExtCommon.h
  • hsErrIndicatorInvalidCap : HsExtCommon.h
  • hsErrIndicatorInvalidSequence : HsExtCommon.h
  • hsErrInUse : HsExtCommon.h
  • hsErrInvalidCardHdr : HsExtCommon.h
  • hsErrInvalidCardNum : HsExtCommon.h
  • hsErrInvalidParam : HsExtCommon.h
  • hsErrInvalidPeriod : HsExtCommon.h
  • hsErrNotEnoughPower : HsExtCommon.h
  • hsErrNotSupported : HsExtCommon.h
  • hsErrOutOfCoverage : HsExtCommon.h
  • hsErrOutOfMemory : HsExtCommon.h
  • hsErrPeriodicAlreadyInstalled : HsExtCommon.h
  • hsErrPeriodicNotInstalled : HsExtCommon.h
  • hsErrPhoneLocked : HsErrors.h
  • hsErrPhoneNotActivated : HsErrors.h
  • hsErrRadioNotRegistered : HsErrors.h
  • hsErrRadioOff : HsErrors.h
  • hsErrReadOnly : HsExtCommon.h
  • hsErrSIMMissing : HsExtCommon.h
  • hsErrSimNotReady : HsErrors.h
  • hsErrTimeOut : HsExtCommon.h
  • hsErrUnderflow : HsExtCommon.h
  • hsErrUserInterrupted : HsExtCommon.h
  • hsErrUserNoRadio : HsExtCommon.h
  • hsErrVoiceCallActive : HsErrors.h
  • hsExgGetScheme : HsExgMgrCommon.h
  • hsExtErrorClass : HsErrorClasses.h
  • hsFfsErrorClass : HsErrorClasses.h
  • hsFileBrowserCoreLib : HsCreators.h
  • hsFileCAddrBookExtensions : HsCreators.h
  • hsFileCAddrBookOneFingerMode : HsCreators.h
  • hsFileCAddrTester : HsCreators.h
  • hsFileCAdvCalculator : HsCreators.h
  • hsFileCameraLib : HsCreators.h
  • hsFileCARMTelephonyWrapper : HsCreators.h
  • hsFileCAutomaticHelper : HsCreators.h
  • hsFileCBackup : HsCreators.h
  • hsFileCBackupWelcome : HsCreators.h
  • hsFileCBlazer : HsCreators.h
  • hsFileCBlazer3 : HsCreators.h
  • hsFileCBlazer3TipsSharedContent : HsCreators.h
  • hsFileCBlazer3TutorialLauncher : HsCreators.h
  • hsFileCBrightness : HsCreators.h
  • hsFileCBuiltinHsExtToken : HsCreators.h
  • hsFileCButtonPrefsPanel : HsCreators.h
  • hsFileCCamera : HsCreators.h
  • hsFileCCameraTest : HsCreators.h
  • hsFileCCameraTips : HsCreators.h
  • hsFileCCardAccessTime : HsCreators.h
  • hsFileCCardSetup : HsCreators.h
  • hsFileCCardWelcomeAppTypeCreator : HsCreators.h
  • hsFileCCardWelcomeDuringReset : HsCreators.h
  • hsFileCCCLib : HsCreators.h
  • hsFileCCDMAActivation : HsCreators.h
  • hsFileCCDMAMsgLib : HsCreators.h
  • hsFileCCDMAPhoneLib : HsCreators.h
  • hsFileCCDMAUpdater : HsCreators.h
  • hsFileCCityTime : HsCreators.h
  • hsFileCCodecWrapper : HsCreators.h
  • hsFileCComChannelProvider : HsCreators.h
  • hsFileCDataMgrExt : HsCreators.h
  • hsFileCDateBook3H : HsCreators.h
  • hsFileCDebugPrefs : HsCreators.h
  • hsFileCDefaultAppsPanel : HsCreators.h
  • hsFileCDialingPanel : HsCreators.h
  • hsFileCDirectRadioSerLib : HsCreators.h
  • hsFileCDisplayPanel : HsCreators.h
  • hsFileCDuoHack : HsCreators.h
  • hsFileCEmailTipsContent : HsCreators.h
  • hsFileCFacebook : HsCreators.h
  • hsFileCFacebookContactsView : HsCreators.h
  • hsFileCFacebookHomeView : HsCreators.h
  • hsFileCFacebookMessageView : HsCreators.h
  • hsFileCFacebookMeView : HsCreators.h
  • hsFileCFacebookPhotosView : HsCreators.h
  • hsFileCFacebookStub68k : HsCreators.h
  • hsFileCFacebookTips : HsCreators.h
  • hsFileCFakeNetLib : HsCreators.h
  • hsFileCFfsCrType : HsCreators.h
  • hsFileCFfsCSegLib : HsCreators.h
  • hsFileCFFSInfoTok1 : HsCreators.h
  • hsFileCFileInstaller : HsCreators.h
  • hsFileCFileMover : HsCreators.h
  • hsFileCFirmwareUpdater : HsCreators.h
  • hsFileCFlMgr : HsCreators.h
  • hsFileCFluMgr : HsCreators.h
  • hsFileCGasTest : HsCreators.h
  • hsFileCGettingStartedApp : HsCreators.h
  • hsFileCGPRSUpdater : HsCreators.h
  • hsFileCGSMActivation : HsCreators.h
  • hsFileCGSMPhoneLib : HsCreators.h
  • hsFileCHandspringExt : HsCreators.h
  • hsFileCHandspringPalmOSUpdate : HsCreators.h
  • hsFileCHandspringSystemResource : HsCreators.h
  • hsFileCHandTerminal : HsCreators.h
  • hsFileCHsSerWrapperLib : HsCreators.h
  • hsFileCHsSSLLib109a : HsCreators.h
  • hsFileCHwmCSegLib : HsCreators.h
  • hsFileCIM : HsCreators.h
  • hsFileCImagine : HsCreators.h
  • hsFileCIOTA : HsCreators.h
  • hsFileCIsolateMemoryChip : HsCreators.h
  • hsFileCKeyboardDemo : HsCreators.h
  • hsFileCKeyguard : HsCreators.h
  • hsFileCKeyguardPanel : HsCreators.h
  • hsFileCLangSpoofer : HsCreators.h
  • hsFileCLCDAdjustPanel : HsCreators.h
  • hsFileCLdbMgr : HsCreators.h
  • hsFileCMailWrapper : HsCreators.h
  • hsFileCMCLLib : HsCreators.h
  • hsFileCMessageStore : HsCreators.h
  • hsFileCModemMgrExt : HsCreators.h
  • hsFileCModemSerLib : HsCreators.h
  • hsFileCModuleSerLib : HsCreators.h
  • hsFileCMultiChannelRingToneDB : HsCreators.h
  • hsFileCNavExt : HsCreators.h
  • hsFileCNavSample : HsCreators.h
  • hsFileCOldGrfLib : HsCreators.h
  • hsFileCPatchedNetLib : HsCreators.h
  • hsFileCPhone : HsCreators.h
  • hsFileCPhone2 : HsCreators.h
  • hsFileCPhoneActiveCallView : HsCreators.h
  • hsFileCPhoneAppFavoritesLibrary : HsCreators.h
  • hsFileCPhoneCallLogView : HsCreators.h
  • hsFileCPhoneDialPadView : HsCreators.h
  • hsFileCPhoneFavoritesView : HsCreators.h
  • hsFileCPhoneIncomingCallView : HsCreators.h
  • hsFileCPhoneMainView : HsCreators.h
  • hsFileCPhonePeopleView : HsCreators.h
  • hsFileCPhoneRingerPanel : HsCreators.h
  • hsFileCPhoneSecurity : HsCreators.h
  • hsFileCPhoneServicesPanel : HsCreators.h
  • hsFileCPhoneStub68k : HsCreators.h
  • hsFileCPhoneTips : HsCreators.h
  • hsFileCPhoneWizard : HsCreators.h
  • hsFileCPhoneWrapper : HsCreators.h
  • hsFileCPinballGame : HsCreators.h
  • hsFileCPmUIUtilLibTest : HsCreators.h
  • hsFileCPowerKey : HsCreators.h
  • hsFileCProgressMgrExt : HsCreators.h
  • hsFileCRomUpdater : HsCreators.h
  • hsFileCSampleCardWelcome : HsCreators.h
  • hsFileCSampleSerLib : HsCreators.h
  • hsFileCSave2Card : HsCreators.h
  • hsFileCSDLib : HsCreators.h
  • hsFileCSerDrvrAuto : HsCreators.h
  • hsFileCSerDrvrCradle : HsCreators.h
  • hsFileCSerDrvrUSBConsole : HsCreators.h
  • hsFileCSerDrvrUSBDesktop : HsCreators.h
  • hsFileCSerDrvrUSBGeneric : HsCreators.h
  • hsFileCSerDrvrUSBGeneric2 : HsCreators.h
  • hsFileCSerDrvrUSBRemFS : HsCreators.h
  • hsFileCSerialCoupler : HsCreators.h
  • hsFileCSerLib : HsCreators.h
  • hsFileCSetISP : HsCreators.h
  • hsFileCSetMem : HsCreators.h
  • hsFileCSimPhoneBook : HsCreators.h
  • hsFileCSimServices : HsCreators.h
  • hsFileCSmartSmallromToken : HsCreators.h
  • hsFileCSmartTextEngine : HsCreators.h
  • hsFileCSMS : HsCreators.h
  • hsFileCSpringWriter : HsCreators.h
  • hsFileCTaskLib : HsCreators.h
  • hsFileCTelephonyInterfaceLayer : HsCreators.h
  • hsFileCTextEncodingConverterLib : HsCreators.h
  • hsFileCTextEncodingConverterTable : HsCreators.h
  • hsFileCTexter : HsCreators.h
  • hsFileCTonesLib : HsCreators.h
  • hsFileCTraceViewer : HsCreators.h
  • hsFileCTransparencyLib : HsCreators.h
  • hsFileCTutorialContent : HsCreators.h
  • hsFileCUartCoupler : HsCreators.h
  • hsFileCUIExt : HsCreators.h
  • hsFileCUsbLib : HsCreators.h
  • hsFileCUsbResetTest : HsCreators.h
  • hsFileCUsbTester : HsCreators.h
  • hsFileCUseSerial : HsCreators.h
  • hsFileCVirtualGSMSerLib : HsCreators.h
  • hsFileCVirtualModemSerLib : HsCreators.h
  • hsFileMMSPalmTransport : HsCreators.h
  • hsFileMMSTreoTransport : HsCreators.h
  • hsFilePhoneBluetoothConnect : HsCreators.h
  • hsFileSMSExchangeLib : HsCreators.h
  • hsFileSMSPalmTransport : HsCreators.h
  • hsFileSMSTreoTransport : HsCreators.h
  • hsFileSoundLib : HsCreators.h
  • hsFileSPI1SerLib : HsCreators.h
  • hsFileTCardSetup : HsCreators.h
  • hsFileTCardSetupShell : HsCreators.h
  • hsFileTCodeSeg : HsCreators.h
  • hsFileTHandspringHal : HsCreators.h
  • hsFileTHandspringPatch : HsCreators.h
  • hsFileTHandspringUIObj : HsCreators.h
  • hsFileTModemSetupPatch : HsCreators.h
  • hsFileTSndFile : HsCreators.h
  • hsFlashErrorClass : HsErrorClasses.h
  • hsFlmErrorClass : HsErrorClasses.h
  • hsFtcErrorClass : HsErrorClasses.h
  • hsFtrCreator : HsExtCommon.h
  • hsFtrIDBugsFixed : HsExtCommon.h
  • hsFtrIDCurrentAppOnSleep : HsExtCommon.h
  • hsFtrIDGrfAreaDisabled : HsExtCommon.h
  • hsFtrIDHardwareApiRevision : HsExtCommon.h
  • hsFtrIDKeyboardLayout : HsExtCommon.h
  • hsFtrIDLdbMgrLibRefNum : HsExtCommon.h
  • hsFtrIDModDate : HsExtCommon.h
  • hsFtrIDNavigationSupported : HsExtCommon.h
  • hsFtrIDNoMemSemaphore : HsExtCommon.h
  • hsFtrIDPowerKeyResponse : HsExtCommon.h
  • hsFtrIDRadioAttributes : HsExtCommon.h
  • hsFtrIDStatusGadgetRev : HsExtCommon.h
  • hsFtrIDTestingBootMode : HsExtCommon.h
  • hsFtrIDToneOnLidOpen : HsExtCommon.h
  • hsFtrIDTypeOfKeyboard : HsExtCommon.h
  • hsFtrIDVersion : HsExtCommon.h
  • hsFtrValCurrentAppOnSleepPhoneAppSpeedDialView : HsExtCommon.h
  • hsFtrValKeyboardBasic : HsExtCommon.h
  • hsFtrValKeyboardCommCentric : HsExtCommon.h
  • hsFtrValKeyboardCustomApps : HsExtCommon.h
  • hsFtrValKeyboardJog : HsExtCommon.h
  • hsFtrValKeyboardLayout_deDE : HsExtCommon.h
  • hsFtrValKeyboardLayout_enUS : HsExtCommon.h
  • hsFtrValKeyboardLayout_frFR : HsExtCommon.h
  • hsFtrValKeyboardQwerty : HsExtCommon.h
  • hsFtrValPowerKeyDoubleClkBacklight : HsExtCommon.h
  • hsFtrValPowerKeyHoldRadioPower : HsExtCommon.h
  • hsFtrValPowerKeyTripleClkInvert : HsExtCommon.h
  • hsFtrValRadioAvailable : HsExtCommon.h
  • hsFtrValRadioBuiltin : HsExtCommon.h
  • hsFtrValStatusGadgetRev1 : HsExtCommon.h
  • hsFttErrorClass : HsErrorClasses.h
  • hsGetCurrentLightCircumstance : HsExtTraps.h
  • hsGlfOptLock : HsKeyTypes.h
  • hsGrfTempShiftOpt : HsKeyTypes.h
  • hsGsiOptLock : HsKeyTypes.h
  • hsGsiShiftOpt : HsKeyTypes.h
  • hsHALIDHandspringOs35_40 : HsExtCommon.h
  • hsHALIDHandspringOs5Rev1 : HsExtCommon.h
  • hsHALIDHandspringOs5Rev1Sim : HsExtCommon.h
  • hsHALIDHandspringOs5Rev2 : HsExtCommon.h
  • hsHALIDHandspringOs5Rev2Sim : HsExtCommon.h
  • hsHALIDHandspringOs5Rev3 : HsExtCommon.h
  • hsHALIDHandspringOs5Rev3Sim : HsExtCommon.h
  • hsHALIDHandspringOs5Rev4 : HsExtCommon.h
  • hsHALIDHandspringOs5Rev4Sim : HsExtCommon.h
  • hsHwmErrorClass : HsErrorClasses.h
  • hsInstallSerialWrapper : HsExtTraps.h
  • hsKbdLayoutDbTypeCreator : HsCreators.h
  • hsKeyguardAutoDisabled : HsExtCommon.h
  • hsKeyguardAutoPowerOff : HsExtCommon.h
  • hsKeyguardFlagPowerOnDialog : HsExtCommon.h
  • hsLibAliasConsole : HsExtCommon.h
  • hsLibAliasDefault : HsExtCommon.h
  • hsLibAliasHotSyncLocal : HsExtCommon.h
  • hsLibAliasHotSyncModem : HsExtCommon.h
  • hsLibAliasIrda : HsExtCommon.h
  • hsLibNameBuiltInSerial : HsExtCommon.h
  • hsLightCircumstanceAlertWokeDeviceFlagBit : HsExtCommon.h
  • hsLightCircumstanceKeylightOffFlagBit : HsExtCommon.h
  • hsLightCircumstanceQuickTypingFlagBit : HsExtCommon.h
  • hsLightCircumstanceUserNotLookingFlagBit : HsExtCommon.h
  • hsLightCircumstanceUserNotLookingLongTimeFlagBit : HsExtCommon.h
  • hsMaxSaveAsNameSize : HsExtCommon.h
  • hsMSLErrorClass : HsErrorClasses.h
  • hsNavAPIVersion : HsNavCommon.h
  • hsNavFocusRingNoExtraInfo : HsNavCommon.h
  • hsNavFocusRingWidth : HsNavCommon.h
  • hsNavFocusRingWidthSingleDensity : HsNavCommon.h
  • hsNetMasterErrorClass : HsErrorClasses.h
  • hsNetPrefLibErrorClass : HsErrorClasses.h
  • hsNeverUsedBeforeAvailableForUse1 : HsExtTraps.h
  • hsNotifyRemSleepEvent : HsCreators.h
  • hsNotifyRemSleepRequestEvent : HsCreators.h
  • hsNotifySetInitialFldStateEvent : HsCreators.h
  • hsNumSels : HsExtTraps.h
  • hsOEMErrorClass : HsErrorClasses.h
  • hsOEMRadioErrorClass : HsErrorClasses.h
  • hsOLDErrorClass : HsExtCommon.h
  • hsPeriodicPeriodsAvailable : HsExtTraps.h
  • hsPeriodicRegister : HsExtTraps.h
  • hsPeriodicUnregister : HsExtTraps.h
  • hsPhoneLibErrorClass_1 : HsErrorClasses.h
  • hsPhoneLibErrorClass_2 : HsErrorClasses.h
  • hsRscKbdChrDataID : HsCreators.h
  • hsRscKbdChrOptDataID : HsCreators.h
  • hsRscKbdChrShiftDataID : HsCreators.h
  • hsRscKbdKeyCodeDataID : HsCreators.h
  • hsRscTextEncodingConverterTable : HsCreators.h
  • hsRscTKbdChrLookupData : HsCreators.h
  • hsRscTKbdKeyCodeLookupData : HsCreators.h
  • hsRscTNavFocusColor : HsCreators.h
  • hsRscTPostProcessLists : HsCreators.h
  • hsRscTutorial : HsCreators.h
  • hsSelAboutHandspringApp : HsExtTraps.h
  • hsSelAppEventHandlerSet : HsExtTraps.h
  • hsSelAppEventPost : HsExtTraps.h
  • hsSelAttnGetAttentionExt : HsExtTraps.h
  • hsSelAttnUpdateExt : HsExtTraps.h
  • hsSelAttrGet : HsExtTraps.h
  • hsSelAttrSet : HsExtTraps.h
  • hsSelBrowseUrl : HsExtTraps.h
  • hsSelCardAttrGet : HsExtTraps.h
  • hsSelCardAttrSet : HsExtTraps.h
  • hsSelCardEventPost : HsExtTraps.h
  • hsSelCardHdrUpdate : HsExtTraps.h
  • hsSelCardPatchInstall : HsExtTraps.h
  • hsSelCardPatchRemove : HsExtTraps.h
  • hsSelCardPower : HsExtTraps.h
  • hsSelCrashLogDisplayLast : HsExtTraps.h
  • hsSelCrashLogGetLast : HsExtTraps.h
  • hsSelCreateNewEmail : HsExtTraps.h
  • hsSelCreateNewMessage : HsExtTraps.h
  • hsSelDatabaseCopy : HsExtTraps.h
  • hsSelDispatchService : HsExtTraps.h
  • hsSelDlkForceSlowSync : HsExtTraps.h
  • hsSelDmCreateDatabasesFromImages : HsExtTraps.h
  • hsSelDmDatabaseDeleted : HsExtTraps.h
  • hsSelDmDatabaseIsOpen : HsExtTraps.h
  • hsSelDmDatabaseIsProtected : HsExtTraps.h
  • hsSelDmDatabaseUniqueIDSeed : HsExtTraps.h
  • hsSelDmGetNextDBByTypeCreator : HsExtTraps.h
  • hsSelDmGetNextDBInit : HsExtTraps.h
  • hsSelDmLockFileSystem : HsExtTraps.h
  • hsSelDoSaveAsDialog : HsExtTraps.h
  • hsSelectorBase : HsExtTraps.h
  • hsSelEvtMetaEvent : HsExtTraps.h
  • hsSelEvtResetAutoOffTimer : HsExtTraps.h
  • hsSelExgLocalAccept : HsExtTraps.h
  • hsSelExgLocalDisconnect : HsExtTraps.h
  • hsSelExgSelectTarget : HsExtTraps.h
  • hsSelExtKeyboardEnable : HsExtTraps.h
  • hsSelGetARMActiveFormPtr : HsExtTraps.h
  • hsSelGetPhoneLibrary : HsExtTraps.h
  • hsSelGetVersionString : HsExtTraps.h
  • hsSelGrfGetStateExt : HsExtTraps.h
  • hsSelGrfSetStateExt : HsExtTraps.h
  • hsSelHsGetTrapAddress : HsExtTraps.h
  • hsSelHsSetTrapAddress : HsExtTraps.h
  • hsSelIndicator : HsExtTraps.h
  • hsSelIndicatorState : HsExtTraps.h
  • hsSelInfo : HsExtTraps.h
  • hsSelIsDbgLockoutSupressed : HsExtTraps.h
  • hsSelIsHTTPLibraryLoaded : HsExtTraps.h
  • hsSelKeyChrCodeToKeyCode : HsExtTraps.h
  • hsSelKeyChrToOptChr : HsExtTraps.h
  • hsSelKeyChrToRegChr : HsExtTraps.h
  • hsSelKeyCurrentStateExt : HsExtTraps.h
  • hsSelKeyEnableKey : HsExtTraps.h
  • hsSelKeyEventIsFromKeyboard : HsExtTraps.h
  • hsSelKeyKeyCodeToChrCode : HsExtTraps.h
  • hsSelKeySetMaskExt : HsExtTraps.h
  • hsSelKeysPressed : HsExtTraps.h
  • hsSelKeyStop : HsExtTraps.h
  • hsSelLast : HsExtTraps.h
  • hsSelLightCircumstance : HsExtTraps.h
  • hsSelLightMode : HsExtTraps.h
  • hsSelLstPopupListExt : HsExtTraps.h
  • hsSelMenuSetCurMenuCurItem : HsExtTraps.h
  • hsSelNavDrawFocusRing : HsExtTraps.h
  • hsSelNavGetFocusColor : HsExtTraps.h
  • hsSelNavGetFocusRingInfo : HsExtTraps.h
  • hsSelNavLstGetTempSelection : HsExtTraps.h
  • hsSelNavLstSetTempSelection : HsExtTraps.h
  • hsSelNavObjectTakeFocus : HsExtTraps.h
  • hsSelNavRemoveFocusRing : HsExtTraps.h
  • hsSelNavSetFocusColor : HsExtTraps.h
  • hsSelNetworkDropConnection : HsExtTraps.h
  • hsSelOpenDialNumberDialog : HsExtTraps.h
  • hsSelOpenDialNumberDialogExt : HsExtTraps.h
  • hsSelPeriodicUnregisterFromSelf : HsExtTraps.h
  • hsSelPostProcessPopupList : HsExtTraps.h
  • hsSelPostProcPopupList : HsExtTraps.h
  • hsSelPrefGet : HsExtTraps.h
  • hsSelPrefGetAppKeyCreator : HsExtTraps.h
  • hsSelPrefSet : HsExtTraps.h
  • hsSelPrvCallSafely : HsExtTraps.h
  • hsSelPrvCallSafelyNewStack : HsExtTraps.h
  • hsSelPrvErrCatchListP : HsExtTraps.h
  • hsSelPrvFindAppFromIDs : HsExtTraps.h
  • hsSelPrvHandleCardChangeEvent : HsExtTraps.h
  • hsSelPrvHandleKeyboardLock : HsExtTraps.h
  • hsSelPrvInit : HsExtTraps.h
  • hsSelPrvInitPostProcess : HsExtTraps.h
  • hsSelPrvKeyHandleEvent : HsExtTraps.h
  • hsSelPrvLaunchCompareFunc : HsExtTraps.h
  • hsSelPrvLaunchDemoApp : HsExtTraps.h
  • hsSelPrvLEDCommand : HsExtTraps.h
  • hsSelPrvSetButtonDefault : HsExtTraps.h
  • hsSelPrvSetupGoToCustomForm : HsExtTraps.h
  • hsSelPrvSetupInstallFormEventHandler : HsExtTraps.h
  • hsSelPrvShowKeyboardLockOnDialog : HsExtTraps.h
  • hsSelPrvUpdateBatteryGadget : HsExtTraps.h
  • hsSelPrvUpdateSignalGadget : HsExtTraps.h
  • hsSelPutObjectAfterTitle : HsExtTraps.h
  • hsSelReserved352H5_54 : HsExtTraps.h
  • hsSelReserved352H5_55 : HsExtTraps.h
  • hsSelReserved352H5_56 : HsExtTraps.h
  • hsSelReserved352H5_57 : HsExtTraps.h
  • hsSelReserved352H5_58 : HsExtTraps.h
  • hsSelReserved352H5_59 : HsExtTraps.h
  • hsSelReserved352H5_5A : HsExtTraps.h
  • hsSelReserved352H5_5B : HsExtTraps.h
  • hsSelReserved352H5_5C : HsExtTraps.h
  • hsSelReserved352H5_5D : HsExtTraps.h
  • hsSelReserved352H6_5E : HsExtTraps.h
  • hsSelReserved352H6_5F : HsExtTraps.h
  • hsSelReserved352H6_60 : HsExtTraps.h
  • hsSelReserved352H6_61 : HsExtTraps.h
  • hsSelReserved352H6_62 : HsExtTraps.h
  • hsSelReserved352H6_63 : HsExtTraps.h
  • hsSelReserved352H6_64 : HsExtTraps.h
  • hsSelReserved352H6_65 : HsExtTraps.h
  • hsSelReserved352H6_66 : HsExtTraps.h
  • hsSelReserved352H6_67 : HsExtTraps.h
  • hsSelReserved352H6_68 : HsExtTraps.h
  • hsSelReserved352H6_69 : HsExtTraps.h
  • hsSelReserved352H6_6A : HsExtTraps.h
  • hsSelReserved41_6E : HsExtTraps.h
  • hsSelReserved41_6F : HsExtTraps.h
  • hsSelReserved41_70 : HsExtTraps.h
  • hsSelReserved41_71 : HsExtTraps.h
  • hsSelReserved41_72 : HsExtTraps.h
  • hsSelReserved5H1_C0 : HsExtTraps.h
  • hsSelReserved5H1_C1 : HsExtTraps.h
  • hsSelReserved5H1_C2 : HsExtTraps.h
  • hsSelReserved5H1_C3 : HsExtTraps.h
  • hsSelShowHighVolAlert : HsExtTraps.h
  • hsSelSpringboardNotSupported : HsExtTraps.h
  • hsSelStartMemoryTracing : HsExtTraps.h
  • hsSelStatusSetGadgetType : HsExtTraps.h
  • hsSelStatusUpdateGadgets : HsExtTraps.h
  • hsSelSupressDbgLockout : HsExtTraps.h
  • hsSelSysKeyboardReferenceDialog : HsExtTraps.h
  • hsSelTrace : HsExtTraps.h
  • hsSelTraceClear : HsExtTraps.h
  • hsSelTraceCloseDB : HsExtTraps.h
  • hsSelTraceContextDelete : HsExtTraps.h
  • hsSelTraceContextInit : HsExtTraps.h
  • hsSelTraceData : HsExtTraps.h
  • hsSelTraceError : HsExtTraps.h
  • hsSelTraceEvent : HsExtTraps.h
  • hsSelTraceFunction : HsExtTraps.h
  • hsSelTraceFunctionError : HsExtTraps.h
  • hsSelTraceGetCommitInterval : HsExtTraps.h
  • hsSelTraceGetMaxRecords : HsExtTraps.h
  • hsSelTraceLevelsGet : HsExtTraps.h
  • hsSelTraceLevelsSet : HsExtTraps.h
  • hsSelTraceOpenDB : HsExtTraps.h
  • hsSelTraceOutputLevelsGet : HsExtTraps.h
  • hsSelTraceOutputLevelsSet : HsExtTraps.h
  • hsSelTraceRecordsDump : HsExtTraps.h
  • hsSelTraceSetCommitInterval : HsExtTraps.h
  • hsSelTraceSetMaxRecords : HsExtTraps.h
  • hsSelTraceText : HsExtTraps.h
  • hsSelTurnRadioOn : HsExtTraps.h
  • hsSelTwoFontSelect : HsExtTraps.h
  • hsSelTxtIsAscii : HsExtTraps.h
  • hsSelTxtNumChars : HsExtTraps.h
  • hsSelTxtPrepFindString : HsExtTraps.h
  • hsSelTxtTruncateString : HsExtTraps.h
  • hsSelUnimplemented : HsExtTraps.h
  • hsSelUsbCommStatePtr : HsExtTraps.h
  • hsSelUtilAttnIndicatorAllow : HsExtTraps.h
  • hsSelUtilAttnNagInfo : HsExtTraps.h
  • hsSelUtilBbutHitBigButton : HsExtTraps.h
  • hsSelUtilBbutInstallFromResource : HsExtTraps.h
  • hsSelUtilBbutInstallNewButton : HsExtTraps.h
  • hsSelUtilBbutSetBitmap : HsExtTraps.h
  • hsSelUtilBbutSetLabel : HsExtTraps.h
  • hsSelUtilCtlGetControlStyle : HsExtTraps.h
  • hsSelUtilCtlGetFont : HsExtTraps.h
  • hsSelUtilEnableAttentionMgr : HsExtTraps.h
  • hsSelUtilFrmDoDialog : HsExtTraps.h
  • hsSelUtilFrmDoDialogWithCallback : HsExtTraps.h
  • hsSelUtilFrmDoTimedDialog : HsExtTraps.h
  • hsSelUtilFrmGetDefaultButtonID : HsExtTraps.h
  • hsSelUtilFrmGetEventHandler : HsExtTraps.h
  • hsSelUtilFrmSetHelpID : HsExtTraps.h
  • hsSelUtilFrmSetLabel : HsExtTraps.h
  • hsSelUtilFrmSetLabelFont : HsExtTraps.h
  • hsSelUtilGetObjectUsable : HsExtTraps.h
  • hsSelUtilLstGetItemsText : HsExtTraps.h
  • hsSelUtilLstGetTopItem : HsExtTraps.h
  • hsSelUtilMutexCreate : HsExtTraps.h
  • hsSelUtilMutexDelete : HsExtTraps.h
  • hsSelUtilMutexRelease : HsExtTraps.h
  • hsSelUtilMutexReserve : HsExtTraps.h
  • hsSelUtilSclScroll : HsExtTraps.h
  • hsSelUtilSclScrollPage : HsExtTraps.h
  • hsSelUtilSclUpdateScrollBar : HsExtTraps.h
  • hsSelUtilSliHandleKeyDown : HsExtTraps.h
  • hsSelUtilStrCSpn : HsExtTraps.h
  • hsSelUtilWinGetMaxDepth : HsExtTraps.h
  • hsSelWaitForGPRSAttach : HsExtTraps.h
  • hsSelWordCorrectInvoke : HsExtTraps.h
  • hsSelWordCorrectUndo : HsExtTraps.h
  • hsSelWriteROMTokens : HsExtTraps.h
  • hsSndAmplitude_silent : HsSoundLibCommon.h
  • hsSndAmplitude_unity : HsSoundLibCommon.h
  • hsSndBayID_AC97 : HsSoundLibCommon.h
  • hsSndBayID_Radio : HsSoundLibCommon.h
  • hsSndBoost_Disable : HsSoundLibCommon.h
  • hsSndBoost_Enable : HsSoundLibCommon.h
  • HsSndBufControl_GetEndDelay : HsSoundLibCommon.h
  • HsSndBufControl_GetRepeat : HsSoundLibCommon.h
  • hsSndBufControl_repeatForever : HsSoundLibCommon.h
  • HsSndBufControl_SetEndDelay : HsSoundLibCommon.h
  • HsSndBufControl_SetRepeat : HsSoundLibCommon.h
  • hsSndBufferData_Signature : HsSoundLibCommon.h
  • hsSndBufFlags_attackEnvMask : HsSoundLibCommon.h
  • hsSndBufFlags_attackEnvNone : HsSoundLibCommon.h
  • hsSndBufFlags_attackEnvReserved1 : HsSoundLibCommon.h
  • hsSndBufFlags_attackEnvReserved2 : HsSoundLibCommon.h
  • hsSndBufFlags_attackEnvRings : HsSoundLibCommon.h
  • hsSndBufFlags_attackEnvRings2 : HsSoundLibCommon.h
  • hsSndBufFlags_attackEnvVibeNone : HsSoundLibCommon.h
  • hsSndBufFlags_attackEnvVibeRings : HsSoundLibCommon.h
  • hsSndBufFlags_attackEnvVibeRings2 : HsSoundLibCommon.h
  • hsSndBufFlags_canInterrupt : HsSoundLibCommon.h
  • hsSndBufFlags_cannotInterrupt : HsSoundLibCommon.h
  • hsSndBufFlags_endDelayMask : HsSoundLibCommon.h
  • hsSndBufFlags_interruptDefault : HsSoundLibCommon.h
  • hsSndBufFlags_interruptMask : HsSoundLibCommon.h
  • hsSndBufFlags_interruptModeMask : HsSoundLibCommon.h
  • hsSndBufFlags_interruptPhone : HsSoundLibCommon.h
  • hsSndBufFlags_noEndDelay : HsSoundLibCommon.h
  • hsSndBufFlags_noRepeat : HsSoundLibCommon.h
  • hsSndBufFlags_repeatMask : HsSoundLibCommon.h
  • hsSndBufFlags_yesEndDelay : HsSoundLibCommon.h
  • hsSndBufFlags_yesRepeat : HsSoundLibCommon.h
  • hsSndCmdFlags_noWait : HsSoundLibCommon.h
  • hsSndCmdFlags_waitMask : HsSoundLibCommon.h
  • hsSndCmdFlags_yesWait : HsSoundLibCommon.h
  • hsSndErr_DoMidiProgressMsg : HsSoundLibCommon.h
  • hsSndErr_Failed : HsSoundLibCommon.h
  • hsSndErr_InvalidPort : HsSoundLibCommon.h
  • hsSndErr_InvalidPrefValue : HsSoundLibCommon.h
  • hsSndErr_InvalidSwitch : HsSoundLibCommon.h
  • hsSndErr_LastPublicError : HsSoundLibCommon.h
  • hsSndErr_NotSupported : HsSoundLibCommon.h
  • hsSndErr_PortBoostLocked : HsSoundLibCommon.h
  • hsSndErr_PortCannotBoost : HsSoundLibCommon.h
  • hsSndErr_PortCannotMute : HsSoundLibCommon.h
  • hsSndErr_PortCannotPan : HsSoundLibCommon.h
  • hsSndErr_PortCannotVolume : HsSoundLibCommon.h
  • hsSndErr_PortIDNotInClass : HsSoundLibCommon.h
  • hsSndErr_PortMuteLocked : HsSoundLibCommon.h
  • hsSndErr_PortPanLocked : HsSoundLibCommon.h
  • hsSndErr_PortVolumeLocked : HsSoundLibCommon.h
  • hsSndErr_UnknownClkRef : HsSoundLibCommon.h
  • hsSndErr_UnknownPortClass : HsSoundLibCommon.h
  • hsSndErr_UnknownSndParam : HsSoundLibCommon.h
  • hsSndErrBase : HsSoundLibCommon.h
  • hsSndLibVersion : HsSoundLibCommon.h
  • hsSndMidiMsg_SetVolume : HsSoundLibCommon.h
  • hsSndMidiProgressMsg_Signature : HsSoundLibCommon.h
  • hsSndMode_Carkit : HsSoundLibCommon.h
  • hsSndMode_Current : HsSoundLibCommon.h
  • hsSndMode_Headphones : HsSoundLibCommon.h
  • hsSndMode_HeadphonesHost : HsSoundLibCommon.h
  • hsSndMode_Headset : HsSoundLibCommon.h
  • hsSndMode_Receiver : HsSoundLibCommon.h
  • hsSndMode_Reserved : HsSoundLibCommon.h
  • hsSndMode_SpeakerHost : HsSoundLibCommon.h
  • hsSndMode_Speakerphone : HsSoundLibCommon.h
  • hsSndMute_Disable : HsSoundLibCommon.h
  • hsSndMute_Enable : HsSoundLibCommon.h
  • hsSndNotify : HsSoundLibCommon.h
  • hsSndNotifyAlert : HsSoundLibCommon.h
  • hsSndNotifyAnswerButton : HsSoundLibCommon.h
  • hsSndNotifyAnswerHold : HsSoundLibCommon.h
  • hsSndNotifyAnswerRelease : HsSoundLibCommon.h
  • hsSndNotifyAthenaAudio : HsSoundLibCommon.h
  • hsSndNotifyCarkitActive : HsSoundLibCommon.h
  • hsSndNotifyCarkitInactive : HsSoundLibCommon.h
  • hsSndNotifyHeadphones : HsSoundLibCommon.h
  • hsSndNotifyHeadset : HsSoundLibCommon.h
  • hsSndNotifyHighPriority : HsSoundLibCommon.h
  • hsSndNotifyHybrid : HsSoundLibCommon.h
  • hsSndNotifyNotHybrid : HsSoundLibCommon.h
  • hsSndNotifyRingerSwitchOff : HsSoundLibCommon.h
  • hsSndNotifyRingerSwitchOn : HsSoundLibCommon.h
  • hsSndNotifyUnplugged : HsSoundLibCommon.h
  • hsSndPan_Left : HsSoundLibCommon.h
  • hsSndPan_LeftNormal : HsSoundLibCommon.h
  • hsSndPan_Middle : HsSoundLibCommon.h
  • hsSndPan_Right : HsSoundLibCommon.h
  • hsSndPan_RightNormal : HsSoundLibCommon.h
  • hsSndParam_Boost : HsSoundLibCommon.h
  • hsSndParam_Mute : HsSoundLibCommon.h
  • hsSndParam_Pan : HsSoundLibCommon.h
  • hsSndParam_Volume : HsSoundLibCommon.h
  • hsSndParamMode_LockParam : HsSoundLibCommon.h
  • hsSndParamMode_Mask : HsSoundLibCommon.h
  • hsSndParamMode_Normal : HsSoundLibCommon.h
  • hsSndParamMode_UnlockParam : HsSoundLibCommon.h
  • HsSndParamValue_RemoveMode : HsSoundLibCommon.h
  • HsSndParamValue_SetWithLock : HsSoundLibCommon.h
  • HsSndParamValue_SetWithUnlock : HsSoundLibCommon.h
  • hsSndPortClass_Anchor : HsSoundLibCommon.h
  • hsSndPortClass_BaseDefault : HsSoundLibCommon.h
  • hsSndPortClass_Real : HsSoundLibCommon.h
  • hsSndPortClass_Virtual : HsSoundLibCommon.h
  • hsSndPortFlags_Boost_Locked : HsSoundLibCommon.h
  • hsSndPortFlags_Boost_LockMask : HsSoundLibCommon.h
  • hsSndPortFlags_Boost_Unlocked : HsSoundLibCommon.h
  • hsSndPortFlags_BoostMask : HsSoundLibCommon.h
  • hsSndPortFlags_BoostOff : HsSoundLibCommon.h
  • hsSndPortFlags_BoostOn : HsSoundLibCommon.h
  • hsSndPortFlags_CanBoost_No : HsSoundLibCommon.h
  • hsSndPortFlags_CanBoost_Yes : HsSoundLibCommon.h
  • hsSndPortFlags_CanBoostMask : HsSoundLibCommon.h
  • hsSndPortFlags_CanInputOnly : HsSoundLibCommon.h
  • hsSndPortFlags_CanIOBothways : HsSoundLibCommon.h
  • hsSndPortFlags_CanIOMask : HsSoundLibCommon.h
  • hsSndPortFlags_CanIOSelect : HsSoundLibCommon.h
  • hsSndPortFlags_CanMute_No : HsSoundLibCommon.h
  • hsSndPortFlags_CanMute_Yes : HsSoundLibCommon.h
  • hsSndPortFlags_CanMuteMask : HsSoundLibCommon.h
  • hsSndPortFlags_CanOutputOnly : HsSoundLibCommon.h
  • hsSndPortFlags_CanPan_No : HsSoundLibCommon.h
  • hsSndPortFlags_CanPan_Yes : HsSoundLibCommon.h
  • hsSndPortFlags_CanPanMask : HsSoundLibCommon.h
  • hsSndPortFlags_CanVol_No : HsSoundLibCommon.h
  • hsSndPortFlags_CanVol_Yes : HsSoundLibCommon.h
  • hsSndPortFlags_CanVolMask : HsSoundLibCommon.h
  • hsSndPortFlags_Disabled : HsSoundLibCommon.h
  • hsSndPortFlags_Enabled : HsSoundLibCommon.h
  • hsSndPortFlags_EnableMask : HsSoundLibCommon.h
  • hsSndPortFlags_InputMask : HsSoundLibCommon.h
  • hsSndPortFlags_InputOff : HsSoundLibCommon.h
  • hsSndPortFlags_InputOn : HsSoundLibCommon.h
  • hsSndPortFlags_Mute_Locked : HsSoundLibCommon.h
  • hsSndPortFlags_Mute_LockMask : HsSoundLibCommon.h
  • hsSndPortFlags_Mute_Unlocked : HsSoundLibCommon.h
  • hsSndPortFlags_MuteMask : HsSoundLibCommon.h
  • hsSndPortFlags_MuteOff : HsSoundLibCommon.h
  • hsSndPortFlags_MuteOn : HsSoundLibCommon.h
  • hsSndPortFlags_OutputMask : HsSoundLibCommon.h
  • hsSndPortFlags_OutputOff : HsSoundLibCommon.h
  • hsSndPortFlags_OutputOn : HsSoundLibCommon.h
  • hsSndPortFlags_Pan_Locked : HsSoundLibCommon.h
  • hsSndPortFlags_Pan_LockMask : HsSoundLibCommon.h
  • hsSndPortFlags_Pan_Unlocked : HsSoundLibCommon.h
  • hsSndPortFlags_TypeAnalog : HsSoundLibCommon.h
  • hsSndPortFlags_TypeDigital : HsSoundLibCommon.h
  • hsSndPortFlags_TypeMask : HsSoundLibCommon.h
  • hsSndPortFlags_Vol_Locked : HsSoundLibCommon.h
  • hsSndPortFlags_Vol_LockMask : HsSoundLibCommon.h
  • hsSndPortFlags_Vol_Unlocked : HsSoundLibCommon.h
  • hsSndPortID_ConnectCall : HsSoundLibCommon.h
  • hsSndPortID_Current : HsSoundLibCommon.h
  • hsSndPortID_InBaseMic : HsSoundLibCommon.h
  • hsSndPortID_InBtHandsfree : HsSoundLibCommon.h
  • hsSndPortID_InBtHeadset : HsSoundLibCommon.h
  • hsSndPortID_InCarkit : HsSoundLibCommon.h
  • hsSndPortID_InHeadsetMic : HsSoundLibCommon.h
  • hsSndPortID_InHostBaseMic : HsSoundLibCommon.h
  • hsSndPortID_InHostHeadsetMic : HsSoundLibCommon.h
  • hsSndPortID_InHostPhone : HsSoundLibCommon.h
  • hsSndPortID_InHostPlay : HsSoundLibCommon.h
  • hsSndPortID_InLineRec : HsSoundLibCommon.h
  • hsSndPortID_InMicAuto : HsSoundLibCommon.h
  • hsSndPortID_InRadioSpkr : HsSoundLibCommon.h
  • hsSndPortID_LastPort : HsSoundLibCommon.h
  • hsSndPortID_Off : HsSoundLibCommon.h
  • hsSndPortID_OutBtHandsfree : HsSoundLibCommon.h
  • hsSndPortID_OutBtHeadset : HsSoundLibCommon.h
  • hsSndPortID_OutCarkit : HsSoundLibCommon.h
  • hsSndPortID_OutHeadphones : HsSoundLibCommon.h
  • hsSndPortID_OutHeadset : HsSoundLibCommon.h
  • hsSndPortID_OutHostRec : HsSoundLibCommon.h
  • hsSndPortID_OutRadioMic : HsSoundLibCommon.h
  • hsSndPortID_OutReceiver : HsSoundLibCommon.h
  • hsSndPortID_OutSpeaker : HsSoundLibCommon.h
  • hsSndPortID_OutSpeakerAuto : HsSoundLibCommon.h
  • hsSndPortInfo_Signature : HsSoundLibCommon.h
  • hsSndRsrcAudioTableID : HsSoundLibCommon.h
  • hsSndRsrcAudioTableType : HsSoundLibCommon.h
  • hsSndSwitchID_InHostPlay : HsSoundLibCommon.h
  • hsSndSwitchID_InMic : HsSoundLibCommon.h
  • hsSndSwitchID_InRadioSpkr : HsSoundLibCommon.h
  • hsSndSwitchID_OutHostRec : HsSoundLibCommon.h
  • hsSndSwitchID_OutRadioMic : HsSoundLibCommon.h
  • hsSndSwitchID_RadioCall : HsSoundLibCommon.h
  • hsSndToneType_Square : HsSoundLibCommon.h
  • hsSoundLibCreatorID : HsSoundLibCommon.h
  • hsSoundLibErrorClass : HsErrorClasses.h
  • hsSoundLibName : HsSoundLibCommon.h
  • hsSoundLibTypeID : HsSoundLibCommon.h
  • hsSrmExtErrorClass : HsErrorClasses.h
  • hsSTEErrorClass : HsErrorClasses.h
  • hsTasLibErrorClass : HsErrorClasses.h
  • hsTetheredTreo : HsCreators.h
  • hsTouchscreenDisableFlagDuringCall : HsExtCommon.h
  • hsTouchscreenDisableFlagIncomingCall : HsExtCommon.h
  • hsUninstallSerialWrapper : HsExtTraps.h
  • hsVersionStringSize : HsExtCommon.h
  • hsWordCorrectMaxWordLen : HsExtCommon.h
  • htcManufacturingInfoToken : HsCreators.h
  • htmlDirDown : HtmlLib68K.h
  • htmlDirLeft : HtmlLib68K.h
  • htmlDirRight : HtmlLib68K.h
  • htmlDirUp : HtmlLib68K.h
  • htmlErrCantOpen : HtmlLib68K.h
  • htmlErrInUse : HtmlLib68K.h
  • htmlErrInvalidParam : HtmlLib68K.h
  • htmlErrNotFound : HtmlLib68K.h
  • htmlErrNotInitialized : HtmlLib68K.h
  • htmlErrorClass : HtmlLib68K.h
  • htmlErrOutOfMemory : HtmlLib68K.h
  • htmlFaithfulDisplayMode : HtmlLib68K.h
  • htmlHandheldDisplayMode : HtmlLib68K.h
  • htmlHttpMethodGet : HtmlLib68K.h
  • htmlHttpMethodPost : HtmlLib68K.h
  • HtmlLibDBType : HtmlLib68K.h
  • HtmlLibID : HtmlLib68K.h
  • HtmlLibName : HtmlLib68K.h
  • htmlLibProgressEvent : HtmlLib68K.h
  • htmlNoPageScrollbarMode : HtmlLib68K.h
  • htmlNormalScrollbarMode : HtmlLib68K.h
  • htmlProgressBusy : HtmlLib68K.h
  • htmlProgressDone : HtmlLib68K.h
  • htmlProgressError : HtmlLib68K.h
  • htmlProgressOutOfMemory : HtmlLib68K.h
  • htmlTargetElement : HtmlLib68K.h
  • htmlTargetEmbed : HtmlLib68K.h
  • htmlTargetIFrame : HtmlLib68K.h
  • htmlTargetImage : HtmlLib68K.h
  • htmlTargetInputButton : HtmlLib68K.h
  • htmlTargetInputCheckbox : HtmlLib68K.h
  • htmlTargetInputFile : HtmlLib68K.h
  • htmlTargetInputPassword : HtmlLib68K.h
  • htmlTargetInputRadio : HtmlLib68K.h
  • htmlTargetInputReset : HtmlLib68K.h
  • htmlTargetInputSelect : HtmlLib68K.h
  • htmlTargetInputSubmit : HtmlLib68K.h
  • htmlTargetInputText : HtmlLib68K.h
  • htmlTargetInputTextarea : HtmlLib68K.h
  • httpIPAddrLenV4 : HS_HTTPLibApp.h
  • httpIPAddrTypeV4 : HS_HTTPLibApp.h
  • httpPostMULTIPART : HS_HTTPLibConst.h
  • httpPostPLAINTEXT : HS_HTTPLibConst.h
  • httpPostURLENCODED : HS_HTTPLibConst.h
  • httpSSLFlagConnTLS : HS_HTTPLibConst.h
  • httpSSLFlagConnV2 : HS_HTTPLibConst.h
  • httpSSLFlagConnV2TLS : HS_HTTPLibConst.h
  • httpSSLFlagConnV2V3 : HS_HTTPLibConst.h
  • httpSSLFlagConnV2V3TLS : HS_HTTPLibConst.h
  • httpSSLFlagConnV3 : HS_HTTPLibConst.h
  • httpSSLFlagConnV3TLS : HS_HTTPLibConst.h
  • httpStreamRead : HS_HTTPLibConst.h
  • httpStreamReadWrite : HS_HTTPLibConst.h
  • httpStreamTextCRCR : HS_HTTPLibConst.h
  • httpStreamTextCRLF : HS_HTTPLibConst.h
  • httpStreamTextCRLFCRLF : HS_HTTPLibConst.h
  • httpStreamTextLFLF : HS_HTTPLibConst.h
  • httpStreamWrite : HS_HTTPLibConst.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:38 2008 for Palm API Guide


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- i -

  • IBG_ERRNOTPOSSIBLE : PalmBGService.h
  • IBG_ERRREQUEST : PalmBGService.h
  • IBG_ERRRQSTDONE : PalmBGService.h
  • IBG_ERRRSPTOOBIG : PalmBGService.h
  • IBG_ERRSHUTDOWN : PalmBGService.h
  • IBG_ERRTIMEOUT : PalmBGService.h
  • IBG_MAXBUFSZ : PalmBGService.h
  • IBG_SUCCESS : PalmBGService.h
  • IBSS : PalmWiFiCommon.h
  • ImageLibCreatorID : ImageLibCommon.h
  • imageLibErrBadBitmapType : ImageLibCommon.h
  • imageLibErrBadColorspace : ImageLibCommon.h
  • imageLibErrBadData : ImageLibCommon.h
  • imageLibErrBadDimensions : ImageLibCommon.h
  • imageLibErrBadImageDepth : ImageLibCommon.h
  • imageLibErrBadImageType : ImageLibCommon.h
  • imageLibErrBadParam : ImageLibCommon.h
  • imageLibErrBadScaleFactor : ImageLibCommon.h
  • imageLibErrBadThumbnailType : ImageLibCommon.h
  • imageLibErrImageAlreadyDownsized : ImageLibCommon.h
  • imageLibErrImageLocked : ImageLibCommon.h
  • imageLibErrInitializationFailed : ImageLibCommon.h
  • imageLibErrInternalFailure : ImageLibCommon.h
  • imageLibErrNoCamera : ImageLibCommon.h
  • imageLibErrorClass : ImageLibCommon.h
  • imageLibErrReadFailure : ImageLibCommon.h
  • imageLibErrThumnailExists : ImageLibCommon.h
  • imageLibErrWriteFailure : ImageLibCommon.h
  • ImageLibName : ImageLibCommon.h
  • ImageLibTypeID : ImageLibCommon.h
  • indicatorBlockedCallerIDChar : HsPhoneCDMATypes.h
  • indicatorNoCallerIDChar : HsPhoneCDMATypes.h
  • indicatorRemainingCallerIDChar : HsPhoneCDMATypes.h
  • INLINE : PalmNative.h
  • INVALID_INDEX : PalmNetServices.h
  • IOTAHeaderEscapeSeq : HsPhoneIOTATypes.h
  • IOTATextHeader : HsPhoneIOTATypes.h
  • IOTATextHeaderLength : HsPhoneIOTATypes.h
  • IOTATextHeaderTerminator : HsPhoneIOTATypes.h
  • irFtrLowBatteryLevel : palmOneFeatures.h
  • irFtrVersionNumber : palmOneFeatures.h
  • IsFiveWayNavEvent : common/system/palmOneNavigator.h
  • IsFiveWayNavPalmEvent : common/system/palmOneNavigator.h
  • isValidAddressAppRecordFieldEnum : HsPhoneSMSTypes.h
  • isValidDataService : HsPhoneNetworkTypes.h
  • isValidGSMDialCLIRMode : HsPhoneTypes.h
  • isValidGSMDialClirStatus : HsPhoneNetworkTypes.h
  • isValidGSMRegistrationMode : HsPhoneNetworkTypes.h
  • isValidGSMSATEventSetupCallCallTypeEnum : HsPhoneGSMTypes.h
  • isValidGSMSATEventToneTypeEnum : HsPhoneGSMTypes.h
  • isValidGSMSIMMessagesDialogKind : HsPhoneGSMTypes.h
  • isValidPacketDataEndStatus : HsPhoneNetworkTypes.h
  • isValidPDPReadAck : HsPhoneCDMATypes.h
  • isValidPhnAddressField : HsPhoneTypes.h
  • isValidPhnBandSelection : HsPhoneNetworkTypes.h
  • isValidPhnBarFacilityType : HsPhoneNetworkTypes.h
  • isValidPhnCLIRStatus : HsPhoneNetworkTypes.h
  • isValidPhnConnectionEnum : HsPhoneMiscTypes.h
  • isValidPhnConnectStateType : HsPhoneCallControlTypes.h
  • isValidPhnDataChannelType : HsPhoneEvent.h
  • isValidPhnEquipmentMode : HsPhoneMiscTypes.h
  • isValidPhnEventCode : HsPhoneEvent.h
  • isValidPhnForwardModeType : HsPhoneNetworkTypes.h
  • isValidPhnForwardType : HsPhoneNetworkTypes.h
  • isValidPhnGPRSPDPType : HsPhoneGSMTypes.h
  • isValidPhnGPRSQOSType : HsPhoneGSMTypes.h
  • isValidPhnIndicationKind : HsPhoneEvent.h
  • isValidPhnIOTAItemType : HsPhoneIOTATypes.h
  • isValidPhnIOTAStatus : HsPhoneIOTA.h
  • isValidPhnLockMode : HsPhoneTypes.h
  • isValidPhnMIPSessionType : HsPhoneNetworkTypes.h
  • isValidPhnMiscDbgUpdateKind : HsPhoneEvent.h
  • isValidPhnModuleButtonType : HsPhoneEvent.h
  • isValidPhnMsgBoxType : HsPhoneNetworkTypes.h
  • isValidPhnMsgIDType : HsPhoneEvent.h
  • isValidPhnOneXDataFailType : HsPhoneCDMATypes.h
  • isValidPhnOneXProtRevType : HsPhoneNetworkTypes.h
  • isValidPhnOpenDialogType : HsPhoneEvent.h
  • isValidPhnOperatorStatus : HsPhoneNetworkTypes.h
  • isValidPhnPacketDataSessionType : HsPhoneNetworkTypes.h
  • isValidPhnPasswordType : HsPhoneSecurityTypes.h
  • isValidPhnPDPCopyAck : HsPhoneCDMATypes.h
  • isValidPhnPDPDeleteAck : HsPhoneCDMATypes.h
  • isValidPhnPDPIndexType : HsPhoneCDMATypes.h
  • isValidPhnPDPReplaceAck : HsPhoneCDMATypes.h
  • isValidPhnPDPWriteAck : HsPhoneCDMATypes.h
  • isValidPhnPowerType : HsPhoneTypes.h
  • isValidPhnProgressType : HsPhoneEvent.h
  • isValidPhnRegistrationStatus : HsPhoneNetworkTypes.h
  • isValidPhnVibrateType : HsPhoneMiscTypes.h
  • isValidPhoneServiceClassType : HsPhoneTypes.h
  • isValidRoamMode : HsPhoneNetworkTypes.h
  • isValidSATNotificationType : HsPhoneGSMTypes.h
  • isValidSMSMessageStatus : HsPhoneSMSTypes.h
  • isValidSMSMessageType : HsPhoneSMSTypes.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:38 2008 for Palm API Guide


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- p -

  • P1cl_CURRENT_VERSION : DatebookLibCommon.h
  • P1clErrAlarmDoesNotExist : DatebookLibCommon.h
  • P1clErrAlreadyInUse : DatebookLibCommon.h
  • P1clErrAlreadyInWriteMode : DatebookLibCommon.h
  • P1clErrAppInfoIsMising : DatebookLibCommon.h
  • P1clErrApptBusy : DatebookLibCommon.h
  • P1clErrApptNotFound : DatebookLibCommon.h
  • P1clErrApptNotLocked : DatebookLibCommon.h
  • P1clErrAttachAlreadyExist : DatebookLibCommon.h
  • P1clErrAttachNotExist : DatebookLibCommon.h
  • P1clErrAttachOverFlow : DatebookLibCommon.h
  • P1clErrAttachOverflow : DatebookLibCommon.h
  • P1clErrAttendeeNotFound : DatebookLibCommon.h
  • P1clErrAttendeeOutofLimit : DatebookLibCommon.h
  • P1clErrCategoryNotFound : DatebookLibCommon.h
  • P1clErrDescDoesNotExist : DatebookLibCommon.h
  • P1clErrEmptyAppt : DatebookLibCommon.h
  • P1clErrEmptyDateBook : DatebookLibCommon.h
  • P1clErrFailedToEmptyDatabase : DatebookLibCommon.h
  • P1clErrFieldNotExist : DatebookLibCommon.h
  • P1clErrFieldNotFound : DatebookLibCommon.h
  • P1clErrInvalidAppInfoBlock : DatebookLibCommon.h
  • P1clErrInvalidAtrib : DatebookLibCommon.h
  • P1clErrInvalidField : DatebookLibCommon.h
  • P1clErrInvalidHandle : DatebookLibCommon.h
  • P1clErrInvalidParam : DatebookLibCommon.h
  • P1clErrInvalidReference : DatebookLibCommon.h
  • P1clErrInvalidSession : DatebookLibCommon.h
  • P1clErrLibAlreadyInUse : DatebookLibCommon.h
  • P1clErrLibStillOpen : DatebookLibCommon.h
  • P1clErrListNotExist : DatebookLibCommon.h
  • P1clErrMaxLimitReached : DatebookLibCommon.h
  • P1clErrNoDateTime : DatebookLibCommon.h
  • P1clErrNoteDoesNotExist : DatebookLibCommon.h
  • P1clErrorClass : DatebookLibCommon.h
  • P1clErrOutOfMemory : DatebookLibCommon.h
  • P1clErrReadOnlySession : DatebookLibCommon.h
  • P1clErrRecordNotFound : DatebookLibCommon.h
  • P1clErrRepeatInfoDoesNotExist : DatebookLibCommon.h
  • P1clErrRepeatTypeDoesNotExist : DatebookLibCommon.h
  • P1clErrSizeParamOverFlow : DatebookLibCommon.h
  • P1clErrStringNotFound : DatebookLibCommon.h
  • P1clErrTooManyClients : DatebookLibCommon.h
  • P1clErrTooManySession : DatebookLibCommon.h
  • P1clErrUIdExist : DatebookLibCommon.h
  • P1clErrUIdNotFound : DatebookLibCommon.h
  • P1clErrVerNotSupported : DatebookLibCommon.h
  • P1clLibCreatorID : DatebookLibCommon.h
  • P1clLibName : DatebookLibCommon.h
  • P1clTrapAccountReset : DatebookLibCommon.h
  • P1clTrapAccountResetServerId : DatebookLibCommon.h
  • P1clTrapAddAllToTransactionLog : DatebookLibCommon.h
  • P1clTrapAddAppt : DatebookLibCommon.h
  • P1clTrapAddAttendee : DatebookLibCommon.h
  • P1clTrapAddExceptionDate : DatebookLibCommon.h
  • P1clTrapAddExceptionExt : DatebookLibCommon.h
  • P1clTrapAddLocalToTransactionLog : DatebookLibCommon.h
  • P1clTrapAddMultiDayEvent : DatebookLibCommon.h
  • P1clTrapAddMultiDayEvent2 : DatebookLibCommon.h
  • P1clTrapApptFindNextRepeat : DatebookLibCommon.h
  • P1clTrapApptGetFirstOccurrence : DatebookLibCommon.h
  • P1clTrapApptPostTriggeredAlarms : DatebookLibCommon.h
  • P1clTrapApptRepeatsOnDate : DatebookLibCommon.h
  • P1clTrapApptTimeZoneAbbreviation : DatebookLibCommon.h
  • P1clTrapApptTimeZoneCompare : DatebookLibCommon.h
  • P1clTrapAttnForgetIt : DatebookLibCommon.h
  • P1clTrapCategoryCreateList : DatebookLibCommon.h
  • P1clTrapCategoryDrawBullet : DatebookLibCommon.h
  • P1clTrapCategoryEdit : DatebookLibCommon.h
  • P1clTrapCategoryFind : DatebookLibCommon.h
  • P1clTrapCategoryFreeList : DatebookLibCommon.h
  • P1clTrapCategoryGetColor : DatebookLibCommon.h
  • P1clTrapCategoryGetName : DatebookLibCommon.h
  • P1clTrapCategoryGetNext : DatebookLibCommon.h
  • P1clTrapCategoryGetRGBColor : DatebookLibCommon.h
  • P1clTrapCategoryGetUnusedColor : DatebookLibCommon.h
  • P1clTrapCategoryGetVersion : DatebookLibCommon.h
  • P1clTrapCategoryPopupList : DatebookLibCommon.h
  • P1clTrapCategorySelect : DatebookLibCommon.h
  • P1clTrapCategorySetColor : DatebookLibCommon.h
  • P1clTrapCategorySetName : DatebookLibCommon.h
  • P1clTrapCategorySetTriggerLabel : DatebookLibCommon.h
  • P1clTrapCategoryTruncateName : DatebookLibCommon.h
  • P1clTrapCheckVersion : DatebookLibCommon.h
  • P1clTrapCloseSession : DatebookLibCommon.h
  • P1clTrapConvertFromDeviceTimeZone : DatebookLibCommon.h
  • P1clTrapConvertToDeviceTimeZone : DatebookLibCommon.h
  • P1clTrapCopyRepeatDescription : DatebookLibCommon.h
  • P1clTrapCopyStringField : DatebookLibCommon.h
  • P1clTrapCountryForTimeZoneAbbreviation : DatebookLibCommon.h
  • P1clTrapCreateAttendeeHandle : DatebookLibCommon.h
  • P1clTrapCreateBlobHandle : DatebookLibCommon.h
  • P1clTrapCreateException : DatebookLibCommon.h
  • P1clTrapCreateHandle : DatebookLibCommon.h
  • P1clTrapDateExportVCal : DatebookLibCommon.h
  • P1clTrapDateSetGoToParams : DatebookLibCommon.h
  • P1clTrapDeleteAlarmInfo : DatebookLibCommon.h
  • P1clTrapDeleteAppt : DatebookLibCommon.h
  • P1clTrapDeleteAttendee : DatebookLibCommon.h
  • P1clTrapDeleteBlob : DatebookLibCommon.h
  • P1clTrapDeleteExceptionList : DatebookLibCommon.h
  • P1clTrapDeleteOldAndDuplicates : DatebookLibCommon.h
  • P1clTrapDeleteRepeatInfo : DatebookLibCommon.h
  • P1clTrapDeleteServerId : DatebookLibCommon.h
  • P1clTrapFindConflict : DatebookLibCommon.h
  • P1clTrapFindNextAlarm : DatebookLibCommon.h
  • P1clTrapFindSaveMatch : DatebookLibCommon.h
  • P1clTrapGetAppt : DatebookLibCommon.h
  • P1clTrapGetApptFromListHandle : DatebookLibCommon.h
  • P1clTrapGetApptFromServerId : DatebookLibCommon.h
  • P1clTrapGetApptList : DatebookLibCommon.h
  • P1clTrapGetAttendee : DatebookLibCommon.h
  • P1clTrapGetAttendeeStringField : DatebookLibCommon.h
  • P1clTrapGetAttendeeUInt8Field : DatebookLibCommon.h
  • P1clTrapGetBlob : DatebookLibCommon.h
  • P1clTrapGetBlobCreatorId : DatebookLibCommon.h
  • P1clTrapGetBlobData : DatebookLibCommon.h
  • P1clTrapGetBooleanFromListHandle : DatebookLibCommon.h
  • P1clTrapGetCalendarDBInfo : DatebookLibCommon.h
  • P1clTrapGetConflict : DatebookLibCommon.h
  • P1clTrapGetDateField : DatebookLibCommon.h
  • P1clTrapGetDateTimeField : DatebookLibCommon.h
  • P1clTrapGetDefaultTimeZone : DatebookLibCommon.h
  • P1clTrapGetDSTField : DatebookLibCommon.h
  • P1clTrapGetExceptionDate : DatebookLibCommon.h
  • P1clTrapGetExtendedDescription : DatebookLibCommon.h
  • P1clTrapGetFirstAppt : DatebookLibCommon.h
  • P1clTrapGetFirstAttendee : DatebookLibCommon.h
  • P1clTrapGetInt16Field : DatebookLibCommon.h
  • P1clTrapGetInt8Field : DatebookLibCommon.h
  • P1clTrapGetLastError : DatebookLibCommon.h
  • P1clTrapGetNextAppt : DatebookLibCommon.h
  • P1clTrapGetNextAttendee : DatebookLibCommon.h
  • P1clTrapGetNumOfException : DatebookLibCommon.h
  • P1clTrapGetSessionInfo : DatebookLibCommon.h
  • P1clTrapGetStringField : DatebookLibCommon.h
  • P1clTrapGetTimeField : DatebookLibCommon.h
  • P1clTrapGetTimeFromListHandle : DatebookLibCommon.h
  • P1clTrapGetUInt16Field : DatebookLibCommon.h
  • P1clTrapGetUInt16FromListHandle : DatebookLibCommon.h
  • P1clTrapGetUInt32Field : DatebookLibCommon.h
  • P1clTrapGetUInt32FromListHandle : DatebookLibCommon.h
  • P1clTrapGetUInt8Field : DatebookLibCommon.h
  • P1clTrapGetVersion : DatebookLibCommon.h
  • P1clTrapGiveAllTimedEventsTimeZones : DatebookLibCommon.h
  • P1clTrapHasExtendedDescription : DatebookLibCommon.h
  • P1clTrapHasMultipleOccurences : DatebookLibCommon.h
  • P1clTrapIsEmptyAppt : DatebookLibCommon.h
  • P1clTrapIsException : DatebookLibCommon.h
  • P1clTrapLogMarkAllCompleted : DatebookLibCommon.h
  • P1clTrapNumRecordsInCategory : DatebookLibCommon.h
  • P1clTrapOpenSession : DatebookLibCommon.h
  • P1clTrapPerformPostSyncFunctions : DatebookLibCommon.h
  • P1clTrapPurgeAllAppts : DatebookLibCommon.h
  • P1clTrapPurgeAppts : DatebookLibCommon.h
  • P1clTrapReleaseAttendeeHandle : DatebookLibCommon.h
  • P1clTrapReleaseBlobHandle : DatebookLibCommon.h
  • P1clTrapReleaseHandle : DatebookLibCommon.h
  • P1clTrapSeekRecordInCategory : DatebookLibCommon.h
  • P1clTrapSetAttendeeStringField : DatebookLibCommon.h
  • P1clTrapSetAttendeeUInt8Field : DatebookLibCommon.h
  • P1clTrapSetBlob : DatebookLibCommon.h
  • P1clTrapSetBlobCreatorId : DatebookLibCommon.h
  • P1clTrapSetBlobData : DatebookLibCommon.h
  • P1clTrapSetDateField : DatebookLibCommon.h
  • P1clTrapSetDateTimeField : DatebookLibCommon.h
  • P1clTrapSetDSTField : DatebookLibCommon.h
  • P1clTrapSetExceptionExt : DatebookLibCommon.h
  • P1clTrapSetInt16Field : DatebookLibCommon.h
  • P1clTrapSetInt8Field : DatebookLibCommon.h
  • P1clTrapSetRepeateEndDate : DatebookLibCommon.h
  • P1clTrapSetServerId : DatebookLibCommon.h
  • P1clTrapSetServerIdByUniqueID : DatebookLibCommon.h
  • P1clTrapSetStringField : DatebookLibCommon.h
  • P1clTrapSetTimeField : DatebookLibCommon.h
  • P1clTrapSetUInt16Field : DatebookLibCommon.h
  • P1clTrapSetUInt32Field : DatebookLibCommon.h
  • P1clTrapSetUInt8Field : DatebookLibCommon.h
  • P1clTrapSortCalendar : DatebookLibCommon.h
  • P1clTrapSortCalendarSpecial : DatebookLibCommon.h
  • P1clTrapSplitRepeatingEvent : DatebookLibCommon.h
  • P1clTrapTxnGetChange : DatebookLibCommon.h
  • P1clTrapTxnGetChange2 : DatebookLibCommon.h
  • P1clTrapTxnGetNumChanges : DatebookLibCommon.h
  • P1clTrapTxnIsKnownDataSource : DatebookLibCommon.h
  • P1clTrapTxnLogMarkCompleted : DatebookLibCommon.h
  • P1clTrapTxnPrepareSync : DatebookLibCommon.h
  • P1clTrapTxnSyncComplete : DatebookLibCommon.h
  • P1clTrapUpdateAppt : DatebookLibCommon.h
  • P1clTrapUpdateAttendee : DatebookLibCommon.h
  • P1clTrapUpdateEventsWithDeletedTimeZone : DatebookLibCommon.h
  • P1clTrapUpdateEventsWithEditedTimeZone : DatebookLibCommon.h
  • P1clTypeID : DatebookLibCommon.h
  • PALM_OS : Contacts.h
  • PALM_OS_20_VERSION : PalmWiFiCommon.h
  • PALM_PHOTO_ALBUM_ALL : palmOnePhotoCommon.h
  • PALM_PHOTO_ALBUM_ALL_HANDHELD : palmOnePhotoCommon.h
  • PALM_PHOTO_ALBUM_ALL_VFS : palmOnePhotoCommon.h
  • PALM_PHOTO_ALBUM_MAX_NAME : palmOnePhotoCommon.h
  • PALM_PHOTO_MAX_PATH : palmOnePhotoCommon.h
  • PALM_PHOTO_SELECT_ALL : palmOnePhotoCommon.h
  • PalmAudioPlaybackRequestResume : PalmAudioPlayback.h
  • PalmAudioPlaybackRequestStop : PalmAudioPlayback.h
  • PalmAudioPlaybackSendRequest : PalmAudioPlayback.h
  • palmCodecAudioAAC : palmOneCodecFormat.h
  • palmCodecAudioALAW : palmOneCodecFormat.h
  • palmCodecAudioAMR : palmOneCodecFormat.h
  • palmCodecAudioDVI_ADPCM : palmOneCodecFormat.h
  • palmCodecAudioG711 : palmOneCodecFormat.h
  • palmCodecAudioG722 : palmOneCodecFormat.h
  • palmCodecAudioG726 : palmOneCodecFormat.h
  • palmCodecAudioG728 : palmOneCodecFormat.h
  • palmCodecAudioIMA_ADPCM : palmOneCodecFormat.h
  • palmCodecAudioMP1 : palmOneCodecFormat.h
  • palmCodecAudioMP2 : palmOneCodecFormat.h
  • palmCodecAudioMP3 : palmOneCodecFormat.h
  • palmCodecAudioPCM : palmOneCodecFormat.h
  • palmCodecAudioQCELP : palmOneCodecFormat.h
  • palmCodecAudioULAW : palmOneCodecFormat.h
  • palmCodecAudioVORBIS : palmOneCodecFormat.h
  • palmCodecImageBase : palmOneCodecFormat.h
  • palmCodecImageGIF87a : palmOneCodecFormat.h
  • palmCodecImageGIF87aFile : palmOneCodecFormat.h
  • palmCodecImageGIF89a : palmOneCodecFormat.h
  • palmCodecImageGIF89aFile : palmOneCodecFormat.h
  • palmCodecImageJPEG : palmOneCodecFormat.h
  • palmCodecImageJPEGFile : palmOneCodecFormat.h
  • palmCodecImagePNG : palmOneCodecFormat.h
  • palmCodecImagePNGFile : palmOneCodecFormat.h
  • palmCodecImageTIFF : palmOneCodecFormat.h
  • palmCodecImageTIFFFile : palmOneCodecFormat.h
  • palmCodecImageWBMP : palmOneCodecFormat.h
  • palmCodecImageWBMPFile : palmOneCodecFormat.h
  • palmCodecInvalidSession : palmOneCodecPluginMgrCommon.h
  • palmCodecIteratorStart : palmOneCodecPluginMgrCommon.h
  • palmCodecIteratorStop : palmOneCodecPluginMgrCommon.h
  • palmCodecNullID : palmOneCodecPluginMgrCommon.h
  • palmCodecText3G : palmOneCodecFormat.h
  • palmCodecVideoAVC : palmOneCodecFormat.h
  • palmCodecVideoDIVX : palmOneCodecFormat.h
  • palmCodecVideoH263 : palmOneCodecFormat.h
  • palmCodecVideoMJPEG : palmOneCodecFormat.h
  • palmCodecVideoMPEG1 : palmOneCodecFormat.h
  • palmCodecVideoMPEG2 : palmOneCodecFormat.h
  • palmCodecVideoMPEG4 : palmOneCodecFormat.h
  • palmCodecVideoXVID : palmOneCodecFormat.h
  • palmOneStatusBarErrBadParam : palmOneStatusBar.h
  • palmOneStatusBarErrInputWindowOpen : palmOneStatusBar.h
  • palmOneStatusBarErrInvalidSelector : palmOneStatusBar.h
  • palmOneStatusBarErrInvalidState : palmOneStatusBar.h
  • palmOneStatusBarErrNoStatusBar : palmOneStatusBar.h
  • palmOneStatusBarErrorClass : palmOneStatusBar.h
  • palmOneStatusBarFtrNumVersion : palmOneStatusBar.h
  • palmOneStatusBarLibCreator : palmOneStatusBar.h
  • palmOneStatusBarLibName : palmOneStatusBar.h
  • palmOneStatusBarLibType : palmOneStatusBar.h
  • palmPhotoASFM43FileFormat : palmOnePhotoCommon.h
  • palmPhotoASFM4AFileFormat : palmOnePhotoCommon.h
  • palmPhotoAVIM43FileFormat : palmOnePhotoCommon.h
  • palmPhotoAVIM4AFileFormat : palmOnePhotoCommon.h
  • palmPhotoBMPFileFormat : palmOnePhotoCommon.h
  • palmPhotoCaptureResCIF : palmOnePhotoCommon.h
  • palmPhotoCaptureResNone : palmOnePhotoCommon.h
  • palmPhotoCaptureResOther : palmOnePhotoCommon.h
  • palmPhotoCaptureResQCIF : palmOnePhotoCommon.h
  • palmPhotoCaptureResQQVGA : palmOnePhotoCommon.h
  • palmPhotoCaptureResQVGA : palmOnePhotoCommon.h
  • palmPhotoCaptureResSUBQCIF : palmOnePhotoCommon.h
  • palmPhotoCaptureResSVGA : palmOnePhotoCommon.h
  • palmPhotoCaptureResSXGA : palmOnePhotoCommon.h
  • palmPhotoCaptureResSXGA1024 : palmOnePhotoCommon.h
  • palmPhotoCaptureResSXGA960 : palmOnePhotoCommon.h
  • palmPhotoCaptureResVGA : palmOnePhotoCommon.h
  • palmPhotoCaptureResXVGA : palmOnePhotoCommon.h
  • palmPhotoDlgDeletion : palmOnePhotoCommon.h
  • palmPhotoDlgSelection : palmOnePhotoCommon.h
  • palmPhotoDlgSingleSelection : palmOnePhotoCommon.h
  • palmPhotoExtraInfoAlbum : palmOnePhotoCommon.h
  • palmPhotoExtraInfoCompositeUID : palmOnePhotoCommon.h
  • palmPhotoExtraInfoDate : palmOnePhotoCommon.h
  • palmPhotoExtraInfoImageUID : palmOnePhotoCommon.h
  • palmPhotoExtraInfoLocation : palmOnePhotoCommon.h
  • palmPhotoExtraInfoNotes : palmOnePhotoCommon.h
  • palmPhotoExtraInfoSound : palmOnePhotoCommon.h
  • palmPhotoExtraInfoSoundUID : palmOnePhotoCommon.h
  • palmPhotoFormat_3G2_QCELP_H263 : palmOnePhotoCommon.h
  • palmPhotoFormat_3G2_QCELP_MPEG4 : palmOnePhotoCommon.h
  • palmPhotoFormat_3GP_AMR_H263 : palmOnePhotoCommon.h
  • palmPhotoFormat_3GP_AMR_MPEG4 : palmOnePhotoCommon.h
  • palmPhotoFormat_ASF_ADPCM_MPEG4 : palmOnePhotoCommon.h
  • palmPhotoFormat_ASF_MP3_MPEG4 : palmOnePhotoCommon.h
  • palmPhotoFormat_AVI_ADPCM_MPEG4 : palmOnePhotoCommon.h
  • palmPhotoFormat_AVI_MP3_MPEG4 : palmOnePhotoCommon.h
  • palmPhotoGIFFileFormat : palmOnePhotoCommon.h
  • palmPhotoHighestQuality : palmOnePhotoCommon.h
  • palmPhotoHighQuality : palmOnePhotoCommon.h
  • palmPhotoJPEGFileFormat : palmOnePhotoCommon.h
  • PalmPhotoLibCreatorID : palmOnePhotoCommon.h
  • palmPhotoLibErrAbortReadWrite : palmOnePhotoCommon.h
  • palmPhotoLibErrAlbumExist : palmOnePhotoCommon.h
  • palmPhotoLibErrAlbumFull : palmOnePhotoCommon.h
  • palmPhotoLibErrAlbumNameTooLong : palmOnePhotoCommon.h
  • palmPhotoLibErrAlbumNotExist : palmOnePhotoCommon.h
  • palmPhotoLibErrAlbumReadOnly : palmOnePhotoCommon.h
  • palmPhotoLibErrFormatNotSupported : palmOnePhotoCommon.h
  • palmPhotoLibErrImageExist : palmOnePhotoCommon.h
  • palmPhotoLibErrImageInvalidPath : palmOnePhotoCommon.h
  • palmPhotoLibErrImageNotFound : palmOnePhotoCommon.h
  • palmPhotoLibErrImageNotInPhotos : palmOnePhotoCommon.h
  • palmPhotoLibErrInvalidVolume : palmOnePhotoCommon.h
  • palmPhotoLibErrLowHeap : palmOnePhotoCommon.h
  • palmPhotoLibErrLowMemory : palmOnePhotoCommon.h
  • palmPhotoLibErrLowPower : palmOnePhotoCommon.h
  • palmPhotoLibErrNoCamera : palmOnePhotoCommon.h
  • palmPhotoLibErrNoThumbnail : palmOnePhotoCommon.h
  • palmPhotoLibErrNotOpen : palmOnePhotoCommon.h
  • palmPhotoLibErrNotOpenPhotos : palmOnePhotoCommon.h
  • palmPhotoLibErrNotPhotos : palmOnePhotoCommon.h
  • palmPhotoLibErrOldVersion : palmOnePhotoCommon.h
  • palmPhotoLibErrParam : palmOnePhotoCommon.h
  • palmPhotoLibErrProtectedMedia : palmOnePhotoCommon.h
  • palmPhotoLibErrScreenDepth : palmOnePhotoCommon.h
  • palmPhotoLibErrSmallBuffer : palmOnePhotoCommon.h
  • palmPhotoLibErrStillOpen : palmOnePhotoCommon.h
  • palmPhotoLibErrUnknown : palmOnePhotoCommon.h
  • palmPhotoLibErrUnsupportedRotation : palmOnePhotoCommon.h
  • palmPhotoLibErrUserCancel : palmOnePhotoCommon.h
  • PalmPhotoLibName : palmOnePhotoCommon.h
  • PalmPhotoLibTypeID : palmOnePhotoCommon.h
  • palmPhotoLowestQuality : palmOnePhotoCommon.h
  • palmPhotoLowQuality : palmOnePhotoCommon.h
  • palmPhotoMediaTypeAll : palmOnePhotoCommon.h
  • palmPhotoMediaTypePhoto : palmOnePhotoCommon.h
  • palmPhotoMediaTypeVideo : palmOnePhotoCommon.h
  • palmPhotoMediumQuality : palmOnePhotoCommon.h
  • palmPhotoMemoryLocation : palmOnePhotoCommon.h
  • palmPhotoMJPEGFileFormat : palmOnePhotoCommon.h
  • palmPhotoMPEG1FileFormat : palmOnePhotoCommon.h
  • palmPhotoMPEG4FileFormat : palmOnePhotoCommon.h
  • palmPhotoPNGFileFormat : palmOnePhotoCommon.h
  • palmPhotoPreferredImageFormat : palmOnePhotoCommon.h
  • palmPhotoPreferredVideoFormat : palmOnePhotoCommon.h
  • palmPhotoRGB565FileFormat : palmOnePhotoCommon.h
  • palmPhotoRGB888FileFormat : palmOnePhotoCommon.h
  • palmPhotoStreamLocation : palmOnePhotoCommon.h
  • palmPhotoTIFFFileFormat : palmOnePhotoCommon.h
  • palmPhotoUnsupportedFormat : palmOnePhotoCommon.h
  • palmPhotoVFSLocation : palmOnePhotoCommon.h
  • palmPhotoWBMPFileFormat : palmOnePhotoCommon.h
  • PasswordLength : HsPhoneEvent.h
  • PasswordSize : HsPhoneEvent.h
  • Phi11BitMap : SmartTextEngineRsc.h
  • Phi14BitMap : SmartTextEngineRsc.h
  • PHN_LIB_TRAP : HsPhoneTraps.h
  • PHN_SUBCOMPONENTID_LIB : HsPhoneTrace.h
  • PHN_SUBCOMPONENTID_NOT : HsPhoneTrace.h
  • PHN_SUBCOMPONENTID_RDO : HsPhoneTrace.h
  • PHN_SUBCOMPONENTID_READ : HsPhoneTrace.h
  • PHN_SUBCOMPONENTID_SIM : HsPhoneTrace.h
  • PHN_SUBCOMPONENTID_SMS : HsPhoneTrace.h
  • PHN_SUBCOMPONENTID_STK : HsPhoneTrace.h
  • PHN_SUBCOMPONENTID_WRIT : HsPhoneTrace.h
  • phnAddressDigitsMax : HsPhoneEvent.h
  • phnCall1StatusActive : HsPhoneTypes.h
  • phnCall1StatusAlerting : HsPhoneTypes.h
  • phnCall1StatusDialing : HsPhoneTypes.h
  • phnCall1StatusIncoming : HsPhoneTypes.h
  • phnCall2StatusActive : HsPhoneTypes.h
  • phnCall2StatusAlerting : HsPhoneTypes.h
  • phnCall2StatusDialing : HsPhoneTypes.h
  • phnCall2StatusIncoming : HsPhoneTypes.h
  • PhnCDMAMediaTVSettingsMajorVersion : HsPhoneCDMATypes.h
  • PhnCDMAMediaTVSettingsMinorVersion : HsPhoneCDMATypes.h
  • PhnCDMAMediaTVSettingsVersion : HsPhoneCDMATypes.h
  • phnCSDCallActive : HsPhoneTypes.h
  • PhnDataSessionStateTypeMajorVersion : HsPhoneNetworkTypes.h
  • PhnDataSessionStateTypeMinorVersion : HsPhoneNetworkTypes.h
  • PhnDataSessionStateTypeVersion : HsPhoneNetworkTypes.h
  • phnEnhancedRoamIndMaxLength : HsPhoneNetworkTypes.h
  • PhnEventRecord : HsPhoneEvent.h
  • phnGPRSCallActive : HsPhoneTypes.h
  • phnIOTAEvent : HsPhoneIOTATypes.h
  • phnLibCDMADbCreator : HsPhoneTypes.h
  • phnLibCDMAName : HsPhoneTypes.h
  • phnLibDbType : HsPhoneTypes.h
  • phnLibFtrNumBlockATCmd : HsPhoneTypes.h
  • phnLibFtrNumBottomBRate : HsPhoneTypes.h
  • phnLibFtrNumResetFlag : HsPhoneTypes.h
  • phnLibFtrValBlockATCmd : HsPhoneTypes.h
  • phnLibGSMDbCreator : HsPhoneTypes.h
  • phnLibGSMDbName : HsPhoneTypes.h
  • phnLibGSMName : HsPhoneTypes.h
  • phnLibLaunchCmdEvent : HsPhoneEvent.h
  • phnLibLaunchCmdRegister : HsPhoneEvent.h
  • PhnLibMMSServerInfoSettingsMajorVersion : HsPhoneSMSTypes.h
  • PhnLibMMSServerInfoSettingsMinorVersion : HsPhoneSMSTypes.h
  • PhnLibMMSServerInfoVersion : HsPhoneSMSTypes.h
  • phnLibNoLookupNeededID : HsPhoneTypes.h
  • phnLibOldCDMADbCreator : HsPhoneTypes.h
  • phnLibOldCDMAName : HsPhoneTypes.h
  • PhnLibTrapActivate : HsPhoneTraps.h
  • PhnLibTrapAddAddress : HsPhoneTraps.h
  • PhnLibTrapAddressToText : HsPhoneTraps.h
  • PhnLibTrapAPGetField : HsPhoneTraps.h
  • PhnLibTrapAPGetNth : HsPhoneTraps.h
  • PhnLibTrapAPNewAddress : HsPhoneTraps.h
  • PhnLibTrapAttrGet : HsPhoneTraps.h
  • PhnLibTrapAttrSet : HsPhoneTraps.h
  • PhnLibTrapBattery : HsPhoneTraps.h
  • PhnLibTrapBatteryCharge : HsPhoneTraps.h
  • PhnLibTrapBoxInformation : HsPhoneTraps.h
  • PhnLibTrapBoxInformationEx : HsPhoneTraps.h
  • PhnLibTrapCardInfo : HsPhoneTraps.h
  • PhnLibTrapCardInfoEx : HsPhoneTraps.h
  • PhnLibTrapChangePassword : HsPhoneTraps.h
  • PhnLibTrapCloseNetIF : HsPhoneTraps.h
  • PhnLibTrapCommitIOTAParams : HsPhoneTraps.h
  • PhnLibTrapConference : HsPhoneTraps.h
  • PhnLibTrapConnectionAvailable : HsPhoneTraps.h
  • PhnLibTrapContinuePhonePowerOff : HsPhoneTraps.h
  • PhnLibTrapContinuePhonePowerOn : HsPhoneTraps.h
  • PhnLibTrapCopyPDP : HsPhoneTraps.h
  • PhnLibTrapCount : HsPhoneTraps.h
  • PhnLibTrapCRSM : HsPhoneTraps.h
  • PhnLibTrapCurrentOperator : HsPhoneTraps.h
  • PhnLibTrapCurrentOperatorID : HsPhoneTraps.h
  • PhnLibTrapCurrentProvider : HsPhoneTraps.h
  • PhnLibTrapDeactivateBarring : HsPhoneTraps.h
  • PhnLibTrapDebug : HsPhoneTraps.h
  • PhnLibTrapDebugHook : HsPhoneTraps.h
  • PhnLibTrapDecodeMMI : HsPhoneTraps.h
  • PhnLibTrapDeleteMessage : HsPhoneTraps.h
  • PhnLibTrapDeletePDP : HsPhoneTraps.h
  • PhnLibTrapDial : HsPhoneTraps.h
  • PhnLibTrapDisconnect : HsPhoneTraps.h
  • PhnLibTrapDisposeAddressList : HsPhoneTraps.h
  • PhnLibTrapEnableDM : HsPhoneTraps.h
  • PhnLibTrapEndIOTASession : HsPhoneTraps.h
  • PhnLibTrapEnhancedRoamIndicator : HsPhoneTraps.h
  • PhnLibTrapEqual : HsPhoneTraps.h
  • PhnLibTrapErrorRate : HsPhoneTraps.h
  • PhnLibTrapExecuteMMI : HsPhoneTraps.h
  • PhnLibTrapExit911Mode : HsPhoneTraps.h
  • PhnLibTrapExitPowerSaveMode : HsPhoneTraps.h
  • PhnLibTrapFindEntry : HsPhoneTraps.h
  • PhnLibTrapFirstAppForService : HsPhoneTraps.h
  • PhnLibTrapForceDataDormant : HsPhoneTraps.h
  • PhnLibTrapGetAddresses : HsPhoneTraps.h
  • PhnLibTrapGetBand : HsPhoneTraps.h
  • PhnLibTrapGetBarring : HsPhoneTraps.h
  • PhnLibTrapGetBaseStationIdInfo : HsPhoneTraps.h
  • PhnLibTrapGetBinary : HsPhoneTraps.h
  • PhnLibTrapGetBoxNumber : HsPhoneTraps.h
  • PhnLibTrapGetCallCountByService : HsPhoneTraps.h
  • PhnLibTrapGetCallWaiting : HsPhoneTraps.h
  • PhnLibTrapGetCDMASystemInfo : HsPhoneTraps.h
  • PhnLibTrapGetCktSwitchProfile : HsPhoneTraps.h
  • PhnLibTrapGetCLIP : HsPhoneTraps.h
  • PhnLibTrapGetCLIR : HsPhoneTraps.h
  • PhnLibTrapGetConnectionInfo : HsPhoneTraps.h
  • PhnLibTrapGetCustomServiceProfile : HsPhoneTraps.h
  • PhnLibTrapGetDataApplication : HsPhoneTraps.h
  • PhnLibTrapGetDataLife : HsPhoneTraps.h
  • PhnLibTrapGetDataSessionInfo : HsPhoneTraps.h
  • PhnLibTrapGetDate : HsPhoneTraps.h
  • PhnLibTrapGetDBRef : HsPhoneTraps.h
  • PhnLibTrapGetDedicatedDataMode : HsPhoneTraps.h
  • PhnLibTrapGetDefaultDataApps : HsPhoneTraps.h
  • PhnLibTrapGetDeviceId : HsPhoneTraps.h
  • PhnLibTrapGetDialPrefix : HsPhoneTraps.h
  • PhnLibTrapGetDTMFburstMode : HsPhoneTraps.h
  • PhnLibTrapGetEchoCancellation : HsPhoneTraps.h
  • PhnLibTrapGetEquipmentMode : HsPhoneTraps.h
  • PhnLibTrapGetErrorText : HsPhoneTraps.h
  • PhnLibTrapGetFDNList : HsPhoneTraps.h
  • PhnLibTrapGetField : HsPhoneTraps.h
  • PhnLibTrapGetFlags : HsPhoneTraps.h
  • PhnLibTrapGetForwarding : HsPhoneTraps.h
  • PhnLibTrapGetGenericCDMAPreference : HsPhoneTraps.h
  • PhnLibTrapGetGSMCellInfo : HsPhoneTraps.h
  • PhnLibTrapGetHeadsetConnectedInfo : HsPhoneTraps.h
  • PhnLibTrapGetHomepageFromRadio : HsPhoneTraps.h
  • PhnLibTrapGetICCID : HsPhoneTraps.h
  • PhnLibTrapGetID : HsPhoneTraps.h
  • PhnLibTrapGetIOTAStatus : HsPhoneTraps.h
  • PhnLibTrapGetLengthDetails : HsPhoneTraps.h
  • PhnLibTrapGetLibAPIVersion : HsPhoneTraps.h
  • PhnLibTrapGetLifeTimer : HsPhoneTraps.h
  • PhnLibTrapGetLineState : HsPhoneTraps.h
  • PhnLibTrapGetMdmPosition : HsPhoneTraps.h
  • PhnLibTrapGetMediaTVSettings : HsPhoneTraps.h
  • PhnLibTrapGetMEID : HsPhoneTraps.h
  • PhnLibTrapGetMicrophone : HsPhoneTraps.h
  • PhnLibTrapGetMMSServerInfo : HsPhoneTraps.h
  • PhnLibTrapGetMMSServerInfoEx : HsPhoneTraps.h
  • PhnLibTrapGetMMSUAString : HsPhoneTraps.h
  • PhnLibTrapGetMSID : HsPhoneTraps.h
  • PhnLibTrapGetMVNOName : HsPhoneTraps.h
  • PhnLibTrapGetNAMInUse : HsPhoneTraps.h
  • PhnLibTrapGetNoiseCancellation : HsPhoneTraps.h
  • PhnLibTrapGetNth : HsPhoneTraps.h
  • PhnLibTrapGetOneXStatus : HsPhoneTraps.h
  • PhnLibTrapGetOperatorList : HsPhoneTraps.h
  • PhnLibTrapGetOperatorLock : HsPhoneTraps.h
  • PhnLibTrapGetOptions : HsPhoneTraps.h
  • PhnLibTrapGetOwner : HsPhoneTraps.h
  • PhnLibTrapGetOwnNumbers : HsPhoneTraps.h
  • PhnLibTrapGetPDP : HsPhoneTraps.h
  • PhnLibTrapGetPDPIndexRange : HsPhoneTraps.h
  • PhnLibTrapGetPDSessionConfigParam : HsPhoneTraps.h
  • PhnLibTrapGetPhnOprtMode : HsPhoneTraps.h
  • PhnLibTrapGetPhoneBook : HsPhoneTraps.h
  • PhnLibTrapGetPhoneBookIndex : HsPhoneTraps.h
  • PhnLibTrapGetPhoneCallStatus : HsPhoneTraps.h
  • PhnLibTrapGetPhoneLock : HsPhoneTraps.h
  • PhnLibTrapGetPhoneSSMode : HsPhoneTraps.h
  • PhnLibTrapGetPicturesServerInfo : HsPhoneTraps.h
  • PhnLibTrapGetPicturesToken : HsPhoneTraps.h
  • PhnLibTrapGetProxyInfo : HsPhoneTraps.h
  • PhnLibTrapGetRadioState : HsPhoneTraps.h
  • PhnLibTrapGetRemainingPasswordTries : HsPhoneTraps.h
  • PhnLibTrapGetRingingInfo : HsPhoneTraps.h
  • PhnLibTrapGetRoamPrefInfo : HsPhoneTraps.h
  • PhnLibTrapGetRoamPrefMode : HsPhoneTraps.h
  • PhnLibTrapGetSDNList : HsPhoneTraps.h
  • PhnLibTrapGetServiceCentreAddress : HsPhoneTraps.h
  • PhnLibTrapGetSIMStatus : HsPhoneTraps.h
  • PhnLibTrapGetSMSGateway : HsPhoneTraps.h
  • PhnLibTrapGetSMSPreference : HsPhoneTraps.h
  • PhnLibTrapGetSMSRingInfo : HsPhoneTraps.h
  • PhnLibTrapGetSMSSegmentInfo : HsPhoneTraps.h
  • PhnLibTrapGetSpecialNumbers : HsPhoneTraps.h
  • PhnLibTrapGetSpMode : HsPhoneTraps.h
  • PhnLibTrapGetSpn : HsPhoneTraps.h
  • PhnLibTrapGetStatus : HsPhoneTraps.h
  • PhnLibTrapGetSubstitution : HsPhoneTraps.h
  • PhnLibTrapGetSysPrefMode : HsPhoneTraps.h
  • PhnLibTrapGetText : HsPhoneTraps.h
  • PhnLibTrapGetToneIDs : HsPhoneTraps.h
  • PhnLibTrapGetToneIDsEx : HsPhoneTraps.h
  • PhnLibTrapGetToneLength : HsPhoneTraps.h
  • PhnLibTrapGetToneName : HsPhoneTraps.h
  • PhnLibTrapGetTotalDataRxBytes : HsPhoneTraps.h
  • PhnLibTrapGetTotalDataTxBytes : HsPhoneTraps.h
  • PhnLibTrapGetTotalPDPs : HsPhoneTraps.h
  • PhnLibTrapGetTTYSetting : HsPhoneTraps.h
  • PhnLibTrapGetType : HsPhoneTraps.h
  • PhnLibTrapGetVoicePrivacyMode : HsPhoneTraps.h
  • PhnLibTrapGetVolume : HsPhoneTraps.h
  • PhnLibTrapGPRSAttached : HsPhoneTraps.h
  • PhnLibTrapGPRSAttachRequest : HsPhoneTraps.h
  • PhnLibTrapGPRSPDPContextDefine : HsPhoneTraps.h
  • PhnLibTrapGPRSPDPContextListConstruct : HsPhoneTraps.h
  • PhnLibTrapGPRSPDPContextListDestruct : HsPhoneTraps.h
  • PhnLibTrapGPRSQualityOfServiceGet : HsPhoneTraps.h
  • PhnLibTrapGPRSQualityOfServiceSet : HsPhoneTraps.h
  • PhnLibTrapHACSetting : HsPhoneTraps.h
  • PhnLibTrapHasName : HsPhoneTraps.h
  • PhnLibTrapHold : HsPhoneTraps.h
  • PhnLibTrapHomeOperatorID : HsPhoneTraps.h
  • PhnLibTrapIsCallMuted : HsPhoneTraps.h
  • PhnLibTrapIsCarrierDefinedEmergencyNumber : HsPhoneTraps.h
  • PhnLibTrapIsEmergencyNumber : HsPhoneTraps.h
  • PhnLibTrapIsLegalCharacter : HsPhoneTraps.h
  • PhnLibTrapIsPhoneActivated : HsPhoneTraps.h
  • PhnLibTrapIsRadioGenericCDMA : HsPhoneTraps.h
  • PhnLibTrapIsSpecialNumber : HsPhoneTraps.h
  • PhnLibTrapLast : HsPhoneTraps.h
  • PhnLibTrapLedAlert : HsPhoneTraps.h
  • PhnLibTrapLength : HsPhoneTraps.h
  • PhnLibTrapListPDP : HsPhoneTraps.h
  • PhnLibTrapLoadCDMATime : HsPhoneTraps.h
  • PhnLibTrapMapCharacter : HsPhoneTraps.h
  • PhnLibTrapMiscDebugInfo : HsPhoneTraps.h
  • PhnLibTrapModemIssueResetInfo : HsPhoneTraps.h
  • PhnLibTrapModuleButtonDown : HsPhoneTraps.h
  • PhnLibTrapModulePowered : HsPhoneTraps.h
  • PhnLibTrapMute : HsPhoneTraps.h
  • PhnLibTrapNetworkAvailable : HsPhoneTraps.h
  • PhnLibTrapNewAddress : HsPhoneTraps.h
  • PhnLibTrapNewAddressList : HsPhoneTraps.h
  • PhnLibTrapNewMessage : HsPhoneTraps.h
  • PhnLibTrapNewMOMessage : HsPhoneTraps.h
  • PhnLibTrapOffHold : HsPhoneTraps.h
  • PhnLibTrapParamText : HsPhoneTraps.h
  • PhnLibTrapPasswordDialog : HsPhoneTraps.h
  • PhnLibTrapPDPLockUnlock : HsPhoneTraps.h
  • PhnLibTrapPhoneRestore : HsPhoneTraps.h
  • PhnLibTrapPlayDTMF : HsPhoneTraps.h
  • PhnLibTrapPlayTone : HsPhoneTraps.h
  • PhnLibTrapPlayToneEx : HsPhoneTraps.h
  • PhnLibTrapPowerSaveDisable : HsPhoneTraps.h
  • PhnLibTrapQuerySMSMT : HsPhoneTraps.h
  • PhnLibTrapReadIOTAItem : HsPhoneTraps.h
  • PhnLibTrapRegister : HsPhoneTraps.h
  • PhnLibTrapRegistered : HsPhoneTraps.h
  • PhnLibTrapReleaseDBRef : HsPhoneTraps.h
  • PhnLibTrapReplacePDPNAI : HsPhoneTraps.h
  • PhnLibTrapReplacePDPPassword : HsPhoneTraps.h
  • PhnLibTrapReplacePDPSvcString : HsPhoneTraps.h
  • PhnLibTrapRoaming : HsPhoneTraps.h
  • PhnLibTrapSATEndSession : HsPhoneTraps.h
  • PhnLibTrapSATGetMainMenu : HsPhoneTraps.h
  • PhnLibTrapSATSendRequest : HsPhoneTraps.h
  • PhnLibTrapSelectAddress : HsPhoneTraps.h
  • PhnLibTrapSelectNAM : HsPhoneTraps.h
  • PhnLibTrapSendDTMF : HsPhoneTraps.h
  • PhnLibTrapSendDTMFBurst : HsPhoneTraps.h
  • PhnLibTrapSendFlash : HsPhoneTraps.h
  • PhnLibTrapSendLongDTMF : HsPhoneTraps.h
  • PhnLibTrapSendMessage : HsPhoneTraps.h
  • PhnLibTrapSendPendingMessages : HsPhoneTraps.h
  • PhnLibTrapSendSilentDTMF : HsPhoneTraps.h
  • PhnLibTrapSendSMSMTAck : HsPhoneTraps.h
  • PhnLibTrapSendUSSD : HsPhoneTraps.h
  • PhnLibTrapSetActiveLine : HsPhoneTraps.h
  • PhnLibTrapSetAddresses : HsPhoneTraps.h
  • PhnLibTrapSetBand : HsPhoneTraps.h
  • PhnLibTrapSetBarring : HsPhoneTraps.h
  • PhnLibTrapSetBoxNumber : HsPhoneTraps.h
  • PhnLibTrapSetCallWaiting : HsPhoneTraps.h
  • PhnLibTrapSetCLIP : HsPhoneTraps.h
  • PhnLibTrapSetCLIR : HsPhoneTraps.h
  • PhnLibTrapSetCurrentUsageHandler : HsPhoneTraps.h
  • PhnLibTrapSetDataApplication : HsPhoneTraps.h
  • PhnLibTrapSetDate : HsPhoneTraps.h
  • PhnLibTrapSetDedicatedDataMode : HsPhoneTraps.h
  • PhnLibTrapSetDialPrefix : HsPhoneTraps.h
  • PhnLibTrapSetDTMFburstMode : HsPhoneTraps.h
  • PhnLibTrapSetEchoCancellation : HsPhoneTraps.h
  • PhnLibTrapSetEquipmentMode : HsPhoneTraps.h
  • PhnLibTrapSetFDNEntry : HsPhoneTraps.h
  • PhnLibTrapSetField : HsPhoneTraps.h
  • PhnLibTrapSetFlags : HsPhoneTraps.h
  • PhnLibTrapSetForwarding : HsPhoneTraps.h
  • PhnLibTrapSetID : HsPhoneTraps.h
  • PhnLibTrapSetMdmAutoMsgMask : HsPhoneTraps.h
  • PhnLibTrapSetMicrophone : HsPhoneTraps.h
  • PhnLibTrapSetModulePower : HsPhoneTraps.h
  • PhnLibTrapSetNoiseCancellation : HsPhoneTraps.h
  • PhnLibTrapSetNth : HsPhoneTraps.h
  • PhnLibTrapSetNumber : HsPhoneTraps.h
  • PhnLibTrapSetOperator : HsPhoneTraps.h
  • PhnLibTrapSetOperatorLock : HsPhoneTraps.h
  • PhnLibTrapSetOptions : HsPhoneTraps.h
  • PhnLibTrapSetOwner : HsPhoneTraps.h
  • PhnLibTrapSetOwnNumbers : HsPhoneTraps.h
  • PhnLibTrapSetPDP : HsPhoneTraps.h
  • PhnLibTrapSetPDSessionConfigParam : HsPhoneTraps.h
  • PhnLibTrapSetPhnOprtMode : HsPhoneTraps.h
  • PhnLibTrapSetPhoneBook : HsPhoneTraps.h
  • PhnLibTrapSetPhoneBookEntry : HsPhoneTraps.h
  • PhnLibTrapSetPhoneLock : HsPhoneTraps.h
  • PhnLibTrapSetPhoneSSMode : HsPhoneTraps.h
  • PhnLibTrapSetPicturesToken : HsPhoneTraps.h
  • PhnLibTrapSetRingingInfo : HsPhoneTraps.h
  • PhnLibTrapSetRoamPrefInfo : HsPhoneTraps.h
  • PhnLibTrapSetRoamPrefMode : HsPhoneTraps.h
  • PhnLibTrapSetServiceCentreAddress : HsPhoneTraps.h
  • PhnLibTrapSetSMSCallbackNumber : HsPhoneTraps.h
  • PhnLibTrapSetSMSPreference : HsPhoneTraps.h
  • PhnLibTrapSetSMSRingInfo : HsPhoneTraps.h
  • PhnLibTrapSetSpecialNumbers : HsPhoneTraps.h
  • PhnLibTrapSetStatus : HsPhoneTraps.h
  • PhnLibTrapSetSysPrefMode : HsPhoneTraps.h
  • PhnLibTrapSetText : HsPhoneTraps.h
  • PhnLibTrapSetToneLength : HsPhoneTraps.h
  • PhnLibTrapSetTTYSetting : HsPhoneTraps.h
  • PhnLibTrapSetupDataConfig : HsPhoneTraps.h
  • PhnLibTrapSetVoicePrivacyMode : HsPhoneTraps.h
  • PhnLibTrapSetVolume : HsPhoneTraps.h
  • PhnLibTrapSignalQuality : HsPhoneTraps.h
  • PhnLibTrapSignalQualityEx : HsPhoneTraps.h
  • PhnLibTrapSIMInfo : HsPhoneTraps.h
  • PhnLibTrapSndDelete : HsPhoneTraps.h
  • PhnLibTrapSndSave : HsPhoneTraps.h
  • PhnLibTrapStartIOTASession : HsPhoneTraps.h
  • PhnLibTrapStartVibrate : HsPhoneTraps.h
  • PhnLibTrapStopPDSession : HsPhoneTraps.h
  • PhnLibTrapStopTone : HsPhoneTraps.h
  • PhnLibTrapStopVibrate : HsPhoneTraps.h
  • PhnLibTrapTunnelIS683ReqMsg : HsPhoneTraps.h
  • PhnLibTrapUninstall : HsPhoneTraps.h
  • PhnLibTrapUnlockPhoneLock : HsPhoneTraps.h
  • PhnLibTrapUpdateCustomizedNV : HsPhoneTraps.h
  • PhnLibTrapUpdateMessageCount : HsPhoneTraps.h
  • PhnLibTrapUsableSignalStrengthThreshold : HsPhoneTraps.h
  • PhnLibTrapVerifyICDVer : HsPhoneTraps.h
  • PhnLibTrapWriteIOTAItem : HsPhoneTraps.h
  • phnLibUnknownID : HsPhoneTypes.h
  • phnMaxDialStrLen : HsPhoneCDMATypes.h
  • phnMaxMNAAASharedSecretLen : HsPhoneCDMATypes.h
  • phnMaxMNHASharedSecretLen : HsPhoneCDMATypes.h
  • phnMaxMslLen : HsPhoneCDMATypes.h
  • phnMaxNAILen : HsPhoneCDMATypes.h
  • phnMaxSvcStrLen : HsPhoneCDMATypes.h
  • phnMaxUrlLen : HsPhoneCDMATypes.h
  • phnNBSEvent : HsPhoneSMSTypes.h
  • phnNetPrefGPRSPDPContextID : HsPhoneGSMTypes.h
  • phnNotifyEquipMode : HsPhoneEvent.h
  • phnNotifySubscriber : HsPhoneEvent.h
  • phnOtasp3GPDCommitFlag : HsPhoneCDMATypes.h
  • phnOtaspAkeyCommitFlag : HsPhoneCDMATypes.h
  • phnOtaspCommitFlag : HsPhoneCDMATypes.h
  • phnOtaspFTCCommitFlag : HsPhoneCDMATypes.h
  • phnOtaspIMSICommitFlag : HsPhoneCDMATypes.h
  • phnOtaspInitProgReqFlag : HsPhoneCDMATypes.h
  • phnOtaspMIPRetryCommitFlag : HsPhoneCDMATypes.h
  • phnOtaspMIPStatCommitFlag : HsPhoneCDMATypes.h
  • phnOtaspMobdirCommitFlag : HsPhoneCDMATypes.h
  • phnOtaspNamLockCommitFlag : HsPhoneCDMATypes.h
  • phnOtaspProgInProgressFlag : HsPhoneCDMATypes.h
  • phnOtaspRoamListCommitFlag : HsPhoneCDMATypes.h
  • phnOtaspSPCCommitFlag : HsPhoneCDMATypes.h
  • phnOtaspSPCFail : HsPhoneCDMATypes.h
  • phnOtaspSSDCommitFlag : HsPhoneCDMATypes.h
  • phnOtaspSuccessful : HsPhoneCDMATypes.h
  • phnOtaspUnsuccessful : HsPhoneCDMATypes.h
  • phnPacketDataCallActive : HsPhoneTypes.h
  • phnPacketDataCallDormant : HsPhoneTypes.h
  • phnPDPUidLen : HsPhoneCDMATypes.h
  • phnSATInkeyResponseValueNo : HsPhoneGSMTypes.h
  • phnSATInkeyResponseValueYes : HsPhoneGSMTypes.h
  • PhnSMSParamsVersion : HsPhoneEvent.h
  • phnUPEvent : HsPhoneEvent.h
  • phnUserDataMax : HsPhoneEvent.h
  • phnVoiceCall1Active : HsPhoneTypes.h
  • phnVoiceCall2Active : HsPhoneTypes.h
  • phnVolumeMax : HsPhoneTypes.h
  • phnVolumeMin : HsPhoneTypes.h
  • phnWAPEvent : HsPhoneEvent.h
  • phnWUEvent : HsPhoneEvent.h
  • phoneAppLaunchCmdActivation : HsAppLaunchCmd.h
  • phoneAppLaunchCmdBluetoothDial : HsAppLaunchCmd.h
  • phoneAppLaunchCmdBluetoothDialVoiceMail : HsAppLaunchCmd.h
  • phoneAppLaunchCmdCallerIDLookup : HsAppLaunchCmd.h
  • phoneAppLaunchCmdDial : HsAppLaunchCmd.h
  • phoneAppLaunchCmdDialSTKSETUPCALL : HsAppLaunchCmd.h
  • phoneAppLaunchCmdDialVoiceMail : HsAppLaunchCmd.h
  • phoneAppLaunchCmdDisplayDialPrefs : HsAppLaunchCmd.h
  • phoneAppLaunchCmdGetALSLineNumber : HsAppLaunchCmd.h
  • phoneAppLaunchCmdGetDialPrefFlag : HsAppLaunchCmd.h
  • phoneAppLaunchCmdGetUSDialingRules : HsAppLaunchCmd.h
  • phoneAppLaunchCmdNetworkSearch : HsAppLaunchCmd.h
  • phoneAppLaunchCmdPowerOn : HsAppLaunchCmd.h
  • phoneAppLaunchCmdRedial : HsAppLaunchCmd.h
  • phoneAppLaunchCmdRegisterAllViews : HsAppLaunchCmd.h
  • phoneAppLaunchCmdSendDTMFTone : HsAppLaunchCmd.h
  • phoneAppLaunchCmdSetWallpaper : HsAppLaunchCmd.h
  • phoneAppLaunchCmdStartNetInitUSSD : HsAppLaunchCmd.h
  • phoneAppLaunchCmdViewCalls : HsAppLaunchCmd.h
  • phoneAppLaunchCmdViewHistory : HsAppLaunchCmd.h
  • phoneAppLaunchCmdViewKeypad : HsAppLaunchCmd.h
  • phoneAppLaunchCmdViewMissedCalls : HsAppLaunchCmd.h
  • phoneAppLaunchCmdViewPhoneHome : HsAppLaunchCmd.h
  • phoneAppLaunchCmdViewSpeed : HsAppLaunchCmd.h
  • phoneAppLaunchOptionsMenu : HsAppLaunchCmd.h
  • Pi11BitMap : SmartTextEngineRsc.h
  • Pi14BitMap : SmartTextEngineRsc.h
  • pinClassic : PalmPin.h
  • pinErrInvalidInputMode : PalmPin.h
  • pinErrInvalidState : PalmPin.h
  • pinErrorClass : PalmPin.h
  • pinErrUnknownID : PalmPin.h
  • pinFtrNumVersion : PalmPin.h
  • pinInputAreaFullScreen : PalmPin.h
  • pinInputAreaHide : PalmPin.h
  • pinInputAreaLegacyMode : PalmPin.h
  • pinInputAreaNone : PalmPin.h
  • pinInputAreaShow : PalmPin.h
  • pinInputModeCapsLock : PalmPin.h
  • pinInputModeExtended : PalmPin.h
  • pinInputModeHiragana : PalmPin.h
  • pinInputModeKatakana : PalmPin.h
  • pinInputModeNormal : PalmPin.h
  • pinInputModeNumeric : PalmPin.h
  • pinInputModePunctuation : PalmPin.h
  • pinInputModeShift : PalmPin.h
  • pinletStdKbIntl : PalmPin.h
  • pinletStdKbNum : PalmPin.h
  • pinLibCreator : PalmPin.h
  • pinLibName : PalmPin.h
  • pinLibType : PalmPin.h
  • pinStdKeyboard : PalmPin.h
  • pinTriCell : PalmPin.h
  • PM_AUDIOGROUP_MASK : PmSoundLibAudioGroup.h
  • PM_AUDP : HsSoundLibCommon.h
  • PM_AUDP_CLASS : HsSoundLibCommon.h
  • PM_AUDP_CLASS_MASK : HsSoundLibCommon.h
  • pmAudioClkTickRef : HsSoundLibCommon.h
  • PMCONNECTOR_LIB_TRAP : PmConnectorLib.h
  • pmDebugLockoutToken : HsCreators.h
  • pmErrNotSupported : PmLibErrors.h
  • pmFileCKeyLib : HsCreators.h
  • pmFileCSysGadgetLib : HsCreators.h
  • pmFileCSystemLib : HsCreators.h
  • pmFileCUIUtilLib : HsCreators.h
  • pmKbdLayoutToken : HsCreators.h
  • pmLibErrorClass : HsErrorClasses.h
  • pmLimitLocaleToken : HsCreators.h
  • pmNotifyBrightModeKeyEvent : HsCreators.h
  • pmNotifyBroadcastNewMsgCount : HsCreators.h
  • pmNotifyGetNewMsgCountFromHelper : HsCreators.h
  • pmNotifyHighPriorityAudioTask : HsAppLaunchCmd.h
  • pmNotifyHighPriorityUITask : HsAppLaunchCmd.h
  • pmNotifyTraceSettingsChangedEvent : HsCreators.h
  • PMP_LIB_TRAP : palmOnePhotoCommon.h
  • pmPhoneAppNotifyHomeAppEvent : HsAppLaunchCmd.h
  • pmPhoneAppNotifySetWallpaper : HsAppLaunchCmd.h
  • pmROMTokenRead : HsCreators.h
  • pmROMTokenWrite : HsCreators.h
  • pmSlotDriverActivityIndicator : HsCreators.h
  • PmSndAddAudioGroupToVolume : PmSoundLibAudioGroup.h
  • pmSndAttackEnvIDRings : HsSoundLibCommon.h
  • pmSndAttackEnvIDRings2 : HsSoundLibCommon.h
  • pmSndAttackEnvIDVibeRing : HsSoundLibCommon.h
  • pmSndAttackEnvIDVibeRing2 : HsSoundLibCommon.h
  • pmSndBayID_AUDP : HsSoundLibCommon.h
  • PmSndGetAudioGroupFromVolume : PmSoundLibAudioGroup.h
  • PmSndGetPreference : HsSoundLib.h
  • pmSndPref_AthenaActive_No : HsSoundLibCommon.h
  • pmSndPref_AthenaActive_Yes : HsSoundLibCommon.h
  • pmSndPref_AthenaAudio_IfMicPresent : HsSoundLibCommon.h
  • pmSndPref_AthenaAudio_NoRouting : HsSoundLibCommon.h
  • pmSndPref_AthenaAudio_Unconditional : HsSoundLibCommon.h
  • pmSndPref_WakeOnAnswerBtn_Disable : HsSoundLibCommon.h
  • pmSndPref_WakeOnAnswerBtn_Enable : HsSoundLibCommon.h
  • pmSndPrefID_AGCEvent : HsSoundLibCommon.h
  • pmSndPrefID_AppsGroupHoldType : HsSoundLibCommon.h
  • pmSndPrefID_AthenaActive : HsSoundLibCommon.h
  • pmSndPrefID_AthenaAudio : HsSoundLibCommon.h
  • pmSndPrefID_AudioTable : HsSoundLibCommon.h
  • pmSndPrefID_GsmMccArray : HsSoundLibCommon.h
  • pmSndPrefID_JackOutIfMicUnused : HsSoundLibCommon.h
  • pmSndPrefID_PhoneRxGainLimit : HsSoundLibCommon.h
  • pmSndPrefID_SleepMode : HsSoundLibCommon.h
  • pmSndPrefID_WakeOnAnswerBtn : HsSoundLibCommon.h
  • PmSndRemoveAudioGroupFromVolume : PmSoundLibAudioGroup.h
  • PmSndSetPreference : HsSoundLib.h
  • PmSndStreamPause : HsSoundLib.h
  • PmSndStreamResume : HsSoundLib.h
  • PmSndStreamSetAttackEnvID : HsSoundLib.h
  • PmSndStreamStoppable : HsSoundLib.h
  • pmSndSwitchID_Preferences : HsSoundLibCommon.h
  • pmSoundLibAudioGroupFtr : PmSoundLibAudioGroup.h
  • pmSoundLibAudioGroupFtr_Off : PmSoundLibAudioGroup.h
  • pmSoundLibAudioGroupFtr_On : PmSoundLibAudioGroup.h
  • pmSoundLibCreatorID : PmSoundLibAudioGroup.h
  • pmTSCalToken : HsCreators.h
  • pmTSTokenValidToken : HsCreators.h
  • pmUsbFtrCreator : palmOneFeatures.h
  • pmUsbFtrVersion : palmOneFeatures.h
  • PRIORITY_LIST_SIZE : PalmNetServices.h
  • PrvPhnLibTrapCheckPowerSync : HsPhoneTraps.h
  • Psi11BitMap : SmartTextEngineRsc.h
  • Psi14BitMap : SmartTextEngineRsc.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:38 2008 for Palm API Guide


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- r -

  • Reserved2 : HsPhoneTraps.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:38 2008 for Palm API Guide


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- s -

  • screenFtrCreator : palmOneFeatures.h
  • ShlCreatorID : PalmNetServices.h
  • ShlLibName : PalmNetServices.h
  • ShlLibType : PalmNetServices.h
  • SHORT_PREAMBLE : PalmWiFiCommon.h
  • Sigma11BitMap : SmartTextEngineRsc.h
  • Sigma14BitMap : SmartTextEngineRsc.h
  • SLIDER_PREF_CHANGED_NOTIFY_TYPE : Slider.h
  • Smiley00BitMap : SmartTextEngineRsc.h
  • Smiley01BitMap : SmartTextEngineRsc.h
  • Smiley02BitMap : SmartTextEngineRsc.h
  • Smiley03BitMap : SmartTextEngineRsc.h
  • Smiley04BitMap : SmartTextEngineRsc.h
  • Smiley05BitMap : SmartTextEngineRsc.h
  • Smiley06BitMap : SmartTextEngineRsc.h
  • Smiley07BitMap : SmartTextEngineRsc.h
  • Smiley08BitMap : SmartTextEngineRsc.h
  • Smiley09BitMap : SmartTextEngineRsc.h
  • Smiley10BitMap : SmartTextEngineRsc.h
  • Smiley11BitMap : SmartTextEngineRsc.h
  • Smiley12BitMap : SmartTextEngineRsc.h
  • Smiley13BitMap : SmartTextEngineRsc.h
  • Smiley14BitMap : SmartTextEngineRsc.h
  • Smiley15BitMap : SmartTextEngineRsc.h
  • Smiley16BitMap : SmartTextEngineRsc.h
  • Smiley17BitMap : SmartTextEngineRsc.h
  • Smiley18BitMap : SmartTextEngineRsc.h
  • Smiley19BitMap : SmartTextEngineRsc.h
  • Smiley20BitMap : SmartTextEngineRsc.h
  • Smiley21BitMap : SmartTextEngineRsc.h
  • Smiley22BitMap : SmartTextEngineRsc.h
  • Smiley23BitMap : SmartTextEngineRsc.h
  • SmileyBitMapBaseID : SmartTextEngineRsc.h
  • SNDFILESTREAM_TRAP : palmOneSndFileStream.h
  • SndFileStreamCloseLibrary : palmOneSndFileStream.h
  • sndFileStreamNotifyRecComplete : palmOneSndFileStream.h
  • sndFileStreamNotifyStreamComplete : palmOneSndFileStream.h
  • SndFileStreamOpenLibrary : palmOneSndFileStream.h
  • softGraffitErrorClass : PalmErrorBase.h
  • soundPrefsLaunchCmdCalendar : HsAppLaunchCmd.h
  • soundPrefsLaunchCmdEmail : HsAppLaunchCmd.h
  • soundPrefsLaunchCmdGeneral : HsAppLaunchCmd.h
  • soundPrefsLaunchCmdIM : HsAppLaunchCmd.h
  • soundPrefsLaunchCmdMMS : HsAppLaunchCmd.h
  • soundPrefsLaunchCmdPhone : HsAppLaunchCmd.h
  • soundPrefsLaunchCmdSMS : HsAppLaunchCmd.h
  • specialAvail3KeyMask : HsKeyTypes.h
  • specialAvail4KeyMask : HsKeyTypes.h
  • specialHoldKeyMask : HsKeyTypes.h
  • specialKeyMask : HsKeyTypes.h
  • specialReleaseKeyMask : HsKeyTypes.h
  • statErrBadParam : PalmStatusBar.h
  • statErrInputWindowOpen : PalmStatusBar.h
  • statErrInvalidSelector : PalmStatusBar.h
  • statErrInvalidState : PalmStatusBar.h
  • statErrNoStatusBar : PalmStatusBar.h
  • statErrorClass : PalmStatusBar.h
  • statFtrNumVersion : PalmStatusBar.h
  • statLibCreator : PalmStatusBar.h
  • statLibName : PalmStatusBar.h
  • statLibType : PalmStatusBar.h
  • statusBarErrorClass : PalmErrorBase.h
  • steAcceleratedScrolling : SmartTextEngineDef.h
  • steAllowPhoneNumberWords : SmartTextEngineDef.h
  • steAllowShortPhoneNumbers : SmartTextEngineDef.h
  • steBitmap : SmartTextEngineDef.h
  • steBlackFont : SmartTextEngineDef.h
  • steBlueFont : SmartTextEngineDef.h
  • steBoldFont : SmartTextEngineDef.h
  • steCannotSelectText : SmartTextEngineDef.h
  • steCenterAlign : SmartTextEngineDef.h
  • steCurrentFont : SmartTextEngineDef.h
  • STEDepracated5 : SmartTextEngineTraps.h
  • steDoNotCenterVertically : SmartTextEngineDef.h
  • steErrBase : SmartTextEngineErrors.h
  • steErrDynamicMemory : SmartTextEngineErrors.h
  • steErrInternal : SmartTextEngineErrors.h
  • steErrInvalidArguments : SmartTextEngineErrors.h
  • steErrOperationNotAllowed : SmartTextEngineErrors.h
  • steErrSTEInit : SmartTextEngineErrors.h
  • steErrStorageMemory : SmartTextEngineErrors.h
  • steErrUnimplemented : SmartTextEngineErrors.h
  • steGrayFont : SmartTextEngineDef.h
  • steGreenFont : SmartTextEngineDef.h
  • steHorizontalLine : SmartTextEngineDef.h
  • steHyperlink : SmartTextEngineDef.h
  • steInvertHighlighting : SmartTextEngineDef.h
  • steLargeFont : SmartTextEngineDef.h
  • steLeftIndent : SmartTextEngineDef.h
  • steLibDBName : SmartTextEngineDef.h
  • steLibName : SmartTextEngineDef.h
  • steLineBreak : SmartTextEngineDef.h
  • steNoLinksBeforeColon : SmartTextEngineDef.h
  • steOrangeFont : SmartTextEngineDef.h
  • steParseEmail : SmartTextEngineDef.h
  • steParseEmoticons : SmartTextEngineDef.h
  • steParseGSMGreekChars : SmartTextEngineDef.h
  • steParseMoreEmoticons : SmartTextEngineDef.h
  • steParsePhoneNumbers : SmartTextEngineDef.h
  • steParseURLs : SmartTextEngineDef.h
  • stePurpleFont : SmartTextEngineDef.h
  • steRedFont : SmartTextEngineDef.h
  • steRightAlign : SmartTextEngineDef.h
  • steScrollWalksLinks : SmartTextEngineDef.h
  • steScrollWalksMessages : SmartTextEngineDef.h
  • steStdFont : SmartTextEngineDef.h
  • steTextMustBeVisible : SmartTextEngineDef.h
  • STETrapAppendParsedInfo : SmartTextEngineTraps.h
  • STETrapAppendTextToEngine : SmartTextEngineTraps.h
  • STETrapClearCurrentSelection : SmartTextEngineTraps.h
  • STETrapClose : SmartTextEngineTraps.h
  • STETrapCopySelectionToClipboard : SmartTextEngineTraps.h
  • STETrapGetAPIVersion : SmartTextEngineTraps.h
  • STETrapGetCurrentTextSelection : SmartTextEngineTraps.h
  • STETrapGetFlags : SmartTextEngineTraps.h
  • STETrapGetLastTapInfo : SmartTextEngineTraps.h
  • STETrapGetNumLines : SmartTextEngineTraps.h
  • STETrapGetNumRecords : SmartTextEngineTraps.h
  • STETrapGetParsedInformation : SmartTextEngineTraps.h
  • STETrapGetScroll : SmartTextEngineTraps.h
  • STETrapGetScrollPct : SmartTextEngineTraps.h
  • STETrapGetSelectedText : SmartTextEngineTraps.h
  • STETrapHandleEvent : SmartTextEngineTraps.h
  • STETrapHandleKeyDownEvent : SmartTextEngineTraps.h
  • STETrapHandlePenDownEvent : SmartTextEngineTraps.h
  • STETrapHandlePenMoveEvent : SmartTextEngineTraps.h
  • STETrapHandlePenUpEvent : SmartTextEngineTraps.h
  • STETrapHandleSclRepeatEvent : SmartTextEngineTraps.h
  • STETrapHasHotRectSelection : SmartTextEngineTraps.h
  • STETrapHasMessageSelection : SmartTextEngineTraps.h
  • STETrapHasTextSelection : SmartTextEngineTraps.h
  • STETrapInitializeEngine : SmartTextEngineTraps.h
  • STETrapOpen : SmartTextEngineTraps.h
  • STETrapQuickRender : SmartTextEngineTraps.h
  • STETrapReinitializeEngine : SmartTextEngineTraps.h
  • STETrapRemoveLastRecordFromEngine : SmartTextEngineTraps.h
  • STETrapRenderList : SmartTextEngineTraps.h
  • STETrapRerenderList : SmartTextEngineTraps.h
  • STETrapResetEngine : SmartTextEngineTraps.h
  • STETrapSetCurrentTextSelection : SmartTextEngineTraps.h
  • STETrapSetCustomHyperlinkCallback : SmartTextEngineTraps.h
  • STETrapSetFlags : SmartTextEngineTraps.h
  • STETrapSetScroll : SmartTextEngineTraps.h
  • STETrapSetScrollPct : SmartTextEngineTraps.h
  • STETrapSetScrollToRecordNum : SmartTextEngineTraps.h
  • steYellowFont : SmartTextEngineDef.h
  • SYS_SEL_TRAP : HsExt.h
  • sysAppLaunchCmdFromSetupApp : PalmLaunchCodes.h
  • sysAppLaunchWebBrowserAutoCrawl : HsAppLaunchCmd.h
  • sysAppLaunchWebBrowserGetHomePage : HsAppLaunchCmd.h
  • sysAppLaunchWebBrowserLaunchBookmarkDialog : HsAppLaunchCmd.h
  • sysAppLaunchWebBrowserMinimalMode : HsAppLaunchCmd.h
  • sysAppLaunchWebBrowserSetHomePage : HsAppLaunchCmd.h
  • sysAppLaunchWebBrowserTutorialMode : HsAppLaunchCmd.h
  • sysAppLaunchWebBrowserURLWithSvcID : HsAppLaunchCmd.h
  • sysExternalHeadsetInsertEvent : palmOneFeatures.h
  • sysExternalHeadsetRemoveEvent : palmOneFeatures.h
  • sysFileCMobileApp : palmOneCreators.h
  • sysFileCMobileServices : palmOneCreators.h
  • sysFileCMyFavorite : palmOneCreators.h
  • sysFileCNotePad : palmOneCreators.h
  • sysFileCPower : Slider.h
  • sysFileCProvisioning : palmOneCreators.h
  • sysFileCSimATDriverOem : palmOneCreators.h
  • sysFileCSimOfficer : palmOneCreators.h
  • sysFileCSimWatcherLib : palmOneCreators.h
  • sysFileCTelMgrLibOem : palmOneCreators.h
  • sysFileTVPNPanelPlugin : PalmVPPI.h
  • sysFileTWiFiPanelPlugin : PalmWPPI.h
  • sysFtrNumDmAutoBackup : PmPalmOSNVFS.h
  • sysFtrNumFiveWayNavVersion : HsNavCommon.h
  • sysFtrNumUIHardwareFlags : HsKeyCommon.h
  • sysFtrNumUIHardwareHas5Way : HsKeyCommon.h
  • sysFtrNumUIHardwareHasKbd : HsKeyCommon.h
  • sysFtrNumUIHardwareHasThumbWheel : HsKeyCommon.h
  • sysFtrNumUIHardwareHasThumbWheelBack : HsKeyCommon.h
  • sysGetLibAPIVersionMajor : palmOneSystemCommon.h
  • sysGetLibAPIVersionMinor : palmOneSystemCommon.h
  • sysMakeLibAPIVersion : palmOneSystemCommon.h
  • sysNotifyAiaEvent : PalmPin.h
  • sysNotifyExternalDialogClosedEvent : palmOneFeatures.h
  • sysNotifyExternalDialogOpenedEvent : palmOneFeatures.h
  • sysNotifyHardDiskSpinup : palmOneFeatures.h
  • sysNotifyHelperEvent : HsHelper.h
  • SysNotifyPIMRecordChange : DatebookLibCommon.h
  • sysNotifyStopEvent : HS_HTTPLibApp.h
  • sysTrapDmSyncDatabase : PmPalmOSNVFS.h
  • sysTrapHsSelector : HsExtTraps.h
  • sysTrapNavSelector : HsNavCommon.h
  • sysTrapOEMDispatch : HsExtTraps.h
  • sysTrapSndStreamCreateExtended : PalmSoundMgrExt.h
  • sysTrapSndStreamDeviceControl : PalmSoundMgrExt.h
  • sysVPPILaunchCmdClearPWCache : PalmVPPI.h
  • sysVPPILaunchCmdDeleteAccount : PalmVPPI.h
  • sysVPPILaunchCmdEditAccount : PalmVPPI.h
  • sysVPPILaunchCmdErrorDialog : PalmVPPI.h
  • sysVPPILaunchCmdGetAccounts : PalmVPPI.h
  • sysVPPILaunchCmdProgressPaint : PalmVPPI.h
  • sysVPPILaunchCmdPromptAndConfigure : PalmVPPI.h
  • sysVPPILaunchCmdSetCurrentAccount : PalmVPPI.h
  • sysVPPILaunchCmdWillPWPrompt : PalmVPPI.h
  • sysWPPILaunchCmdClearPWCache : PalmWPPI.h
  • sysWPPILaunchCmdClose : PalmWPPI.h
  • sysWPPILaunchCmdDelete : PalmWPPI.h
  • sysWPPILaunchCmdDialog : PalmWPPI.h
  • sysWPPILaunchCmdErrorDialog : PalmWPPI.h
  • sysWPPILaunchCmdGetAuthenticationMethods : PalmWPPI.h
  • sysWPPILaunchCmdGetDescription : PalmWPPI.h
  • sysWPPILaunchCmdOpen : PalmWPPI.h
  • sysWPPILaunchCmdPromptAndConfigure : PalmWPPI.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:38 2008 for Palm API Guide


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- t -

  • TextHeaderTerminator : HsPhoneSMSTypes.h
  • Theta11BitMap : SmartTextEngineRsc.h
  • Theta14BitMap : SmartTextEngineRsc.h
  • toneInterruptMask : TonesLibTypes.h
  • tonesLibCreator : TonesLibTypes.h
  • tonesLibErrAlreadyPlaying : TonesLibTypes.h
  • tonesLibErrBadParams : TonesLibTypes.h
  • tonesLibErrClass : TonesLibTypes.h
  • tonesLibErrCreateDBFailed : TonesLibTypes.h
  • tonesLibErrDBNotFound : TonesLibTypes.h
  • tonesLibErrDBWriteFailed : TonesLibTypes.h
  • tonesLibErrNoMemory : TonesLibTypes.h
  • tonesLibErrNotAllowed : TonesLibTypes.h
  • tonesLibErrNoTone : TonesLibTypes.h
  • tonesLibErrUnknown : TonesLibTypes.h
  • tonesLibErrUserCancel : TonesLibTypes.h
  • tonesLibName : TonesLibTypes.h
  • tonesLibPlayForever : TonesLibTypes.h
  • tonesLibTrapAddMidiTone : TonesLibTypes.h
  • tonesLibTrapCopyBackUndeletableTones : TonesLibTypes.h
  • tonesLibTrapDeleteTone : TonesLibTypes.h
  • tonesLibTrapDoDialog : TonesLibTypes.h
  • tonesLibTrapEscalateRingTones : TonesLibTypes.h
  • tonesLibTrapGetSoundOnVolume : TonesLibTypes.h
  • tonesLibTrapGetSoundPrefs : TonesLibTypes.h
  • tonesLibTrapGetToneIDs : TonesLibTypes.h
  • tonesLibTrapGetToneList : TonesLibTypes.h
  • tonesLibTrapGetToneName : TonesLibTypes.h
  • tonesLibTrapGetToneSize : TonesLibTypes.h
  • tonesLibTrapInitTonesDB : TonesLibTypes.h
  • tonesLibTrapManageTones : TonesLibTypes.h
  • tonesLibTrapPickTone : TonesLibTypes.h
  • tonesLibTrapPlayRingTone : TonesLibTypes.h
  • tonesLibTrapPlayTone : TonesLibTypes.h
  • tonesLibTrapSaveUndeletableTones : TonesLibTypes.h
  • tonesLibTrapSetSoundOnVolume : TonesLibTypes.h
  • tonesLibTrapSetSoundPrefs : TonesLibTypes.h
  • tonesLibTrapStopTone : TonesLibTypes.h
  • tonesLibTrapToneClose : TonesLibTypes.h
  • tonesLibTrapToneCreate : TonesLibTypes.h
  • tonesLibTrapToneRecord : TonesLibTypes.h
  • tonesLibTrapToneWrite : TonesLibTypes.h
  • tonesLibType : TonesLibTypes.h
  • transLibCreator : TransparencyLibTypes.h
  • transLibErrAlreadyOpen : TransparencyLibTypes.h
  • transLibErrDockNotAttached : TransparencyLibTypes.h
  • transLibErrNotOpen : TransparencyLibTypes.h
  • transLibErrorClass : TransparencyLibTypes.h
  • transLibErrUnknown : TransparencyLibTypes.h
  • transLibName : TransparencyLibTypes.h
  • transLibTrapCloseConnection : TransparencyLibTypes.h
  • transLibTrapOpenConnection : TransparencyLibTypes.h
  • transLibType : TransparencyLibTypes.h
  • true : PalmNative.h
  • TxtCharIsRockerKey : HsNavCommon.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:38 2008 for Palm API Guide


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- u -

  • uilibErrCurrentFocusInvalid : HsNavCommon.h
  • uilibErrFormDoesNotHaveFocus : HsNavCommon.h
  • uilibErrInvalidFocusObject : HsNavCommon.h
  • uilibErrInvalidParam : HsNavCommon.h
  • uilibErrNoNavInfoForForm : HsNavCommon.h
  • uilibErrObjectFocusModeOff : HsNavCommon.h
  • uilibErrObjectNotFound : HsNavCommon.h
  • uilibErrorClass : HsNavCommon.h
  • UPDataSize : HsPhoneEvent.h
  • UPHeaderEscapeSeq : HsPhoneEvent.h
  • UPTextHeader : HsPhoneEvent.h
  • UPTextHeaderLength : HsPhoneEvent.h
  • USBChargeCreator : palmOneFeatures.h
  • USBChargeVersion : palmOneFeatures.h
  • USBFeatureCreator : palmOneFeatures.h
  • USBFeatureVersion : palmOneFeatures.h
  • USBHwrCreator : palmOneFeatures.h
  • USBHwrVersion : palmOneFeatures.h
  • USBSpeedCreator : palmOneFeatures.h
  • USBSpeedVersion : palmOneFeatures.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:38 2008 for Palm API Guide


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- v -

  • vchrBacklightToggled : common/system/palmOneChars.h
  • vchrCameraShutter : common/system/palmOneChars.h
  • vchrClock : common/system/palmOneChars.h
  • vchrDeviceIncomingCall : common/system/palmOneChars.h
  • vchrDeviceSpecificChar : common/system/palmOneChars.h
  • vchrEmergencyCall : common/system/palmOneChars.h
  • vchrFunctionFiveWay : common/system/palmOneChars.h
  • vchrHard11 : HsChars.h
  • vchrHard12 : HsChars.h
  • vchrHard13 : HsChars.h
  • vchrHard14 : HsChars.h
  • vchrHard3Down : common/system/palmOneChars.h
  • vchrHard4Down : common/system/palmOneChars.h
  • vchrHard5 : common/system/palmOneChars.h
  • vchrHard6 : common/system/palmOneChars.h
  • vchrHardRecord : common/system/palmOneChars.h
  • vchrHardRockerCenter : HsKeyCommon.h
  • vchrKeyboardSymbol : common/system/palmOneChars.h
  • vchrMyFavoriteApplication : common/system/palmOneChars.h
  • vchrNavChange : common/system/palmOneChars.h
  • vchrPopupBrightness : common/system/palmOneChars.h
  • vchrPowerOnPhone : common/system/palmOneChars.h
  • vchrReplaceLastChar : common/system/palmOneChars.h
  • vchrRockerCenter : common/system/palmOneChars.h
  • vchrRockerDown : common/system/palmOneChars.h
  • vchrRockerLeft : common/system/palmOneChars.h
  • vchrRockerRight : common/system/palmOneChars.h
  • vchrRockerSelect : common/system/palmOneChars.h
  • vchrRockerUp : common/system/palmOneChars.h
  • vchrSilkClock : common/system/palmOneChars.h
  • vchrTelDevicePowerFinished : common/system/palmOneChars.h
  • vchrTelDevicePowerOn : common/system/palmOneChars.h
  • vchrThumbWheelBack : common/system/palmOneChars.h
  • vchrThumbWheelDown : common/system/palmOneChars.h
  • vchrThumbWheelPush : common/system/palmOneChars.h
  • vchrThumbWheelUp : common/system/palmOneChars.h
  • vfsIncludePrivateVolumes : PmPalmOSNVFS.h
  • vfsVolumeAttrNonRemovable : PmPalmOSNVFS.h
  • VMFontErrNotOpen : VMFontLibCommon.h
  • VMFontErrParam : VMFontLibCommon.h
  • VMFontErrStillOpen : VMFontLibCommon.h
  • VMFONTLIB_TRAP : palmOneVMFontLib.h
  • vpnLibEventNotification : PalmShimSettings.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:38 2008 for Palm API Guide


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- w -

  • WAPMsgLength : HsPhoneEvent.h
  • WAPMsgSize : HsPhoneEvent.h
  • WAPNotificationTypeVersion : HsPhoneEvent.h
  • WIFI_ASSOCIATED_EVENT : PalmWiFiCommon.h
  • WIFI_CONFIG_NAME : PalmWiFiCommon.h
  • WIFI_CREATOR_ID : PalmWiFiCommon.h
  • WIFI_DB_NAME : PalmWiFiCommon.h
  • WIFI_DB_TYPE : PalmWiFiCommon.h
  • WIFI_DISASSOCIATED_EVENT : PalmWiFiCommon.h
  • WIFI_DRIVER_NAME : PalmWiFiCommon.h
  • WIFI_DRIVER_PREFIX : PalmWiFiCommon.h
  • WIFI_IF_DOWN_EVENT : PalmWiFiCommon.h
  • WIFI_IF_UP_EVENT : PalmWiFiCommon.h
  • WIFI_MIN_OS_VERSION : PalmWiFiCommon.h
  • WIFI_SCAN_COMPLETE_EVENT : PalmWiFiCommon.h
  • willSendUpKeyMask : HsKeyCommon.h
  • WUFieldDelimiter : HsPhoneEvent.h
  • WUHeaderEscapeSeq : HsPhoneEvent.h
  • WUTextHeader : HsPhoneEvent.h
  • WUTextHeaderLength : HsPhoneEvent.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:38 2008 for Palm API Guide


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- x -

  • Xi11BitMap : SmartTextEngineRsc.h
  • Xi14BitMap : SmartTextEngineRsc.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:38 2008 for Palm API Guide


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • c
  • e
  • f
  • g
  • h
  • i
  • k
  • n
  • p
  • s
  • t
  • v
  • w

- _ -

  • _80211InfrastructureEnum : PalmWiFiCommon.h
  • _80211NetworkTypeEnum : PalmWiFiCommon.h
  • _GSMATEventInputEchoModeEnum : HsPhoneGSMTypes.h
  • _GSMDialCLIRMode : HsPhoneTypes.h
  • _GSMSATDataSvcTypeEnum : HsPhoneGSMTypes.h
  • _GSMSATEventInputFormatEnum : HsPhoneGSMTypes.h
  • _GSMSATEventMenuFlag : HsPhoneGSMTypes.h
  • _GSMSATEventSetupCallCallTypeEnum : HsPhoneGSMTypes.h
  • _GSMSATEventToneTimeUnitEnum : HsPhoneGSMTypes.h
  • _GSMSATEventToneTypeEnum : HsPhoneGSMTypes.h
  • _GSMSIMMessagesDialogKind : HsPhoneGSMTypes.h
  • _GSMSIMStatus : HsPhoneTypes.h
  • _LocDBSortOrderType : LocsLibCommon.h
  • _P1clActionType : DatebookLibCommon.h
  • _P1clAlarmUnitType : DatebookLibCommon.h
  • _P1clApptStatusType : DatebookLibCommon.h
  • _P1clAttachType : DatebookLibCommon.h
  • _P1clAttendeeFieldType : DatebookLibCommon.h
  • _P1clAttendeeRoleType : DatebookLibCommon.h
  • _P1clDeleteType : DatebookLibCommon.h
  • _P1clFieldsTypes : DatebookLibCommon.h
  • _P1clListFieldType : DatebookLibCommon.h
  • _P1clRepeatTypes : DatebookLibCommon.h
  • _P1clTimeZoneType : DatebookLibCommon.h
  • _P1clTxnEntry : DatebookLibCommon.h
  • _PhnAddressField : HsPhoneTypes.h
  • _PhnAudioSendMode : HsPhoneAudioTypes.h
  • _PhnBandSelection : HsPhoneNetworkTypes.h
  • _PhnCDMAFirmwareType : HsPhoneCDMATypes.h
  • _PhnCDMAVoicemailType : HsPhoneCDMATypes.h
  • _PhnConnectStateType : HsPhoneCallControlTypes.h
  • _PhnDataServiceType : HsPhoneNetworkTypes.h
  • _PhnGenericCDMAPreference : HsPhoneCDMATypes.h
  • _PhnGenericCDMASMSEncodingType : HsPhoneCDMATypes.h
  • _PhnGPRSPDPType : HsPhoneGSMTypes.h
  • _PhnGPRSQOSType : HsPhoneGSMTypes.h
  • _PhnLibAttrType : HsPhoneMiscTypes.h
  • _PhnMIPSessionType : HsPhoneNetworkTypes.h
  • _PhnOneXProtRevType : HsPhoneNetworkTypes.h
  • _PhnOprtModeType : HsPhoneMiscTypes.h
  • _PhnPacketDataEndStatusEnum : HsPhoneNetworkTypes.h
  • _PhnPacketDataSessionType : HsPhoneNetworkTypes.h
  • _PhnPDPConnectionType : HsPhoneCDMATypes.h
  • _PhnPDPCopyAck : HsPhoneCDMATypes.h
  • _PhnPDPDeleteAck : HsPhoneCDMATypes.h
  • _PhnPDPIndexType : HsPhoneCDMATypes.h
  • _PhnPDPReplaceAck : HsPhoneCDMATypes.h
  • _PhnPDPService : HsPhoneCDMATypes.h
  • _PhnPDSessionConfigParamType : hsPhoneLocationTypes.h
  • _PhnPowerType : HsPhoneTypes.h
  • _PhnRoamPrefSelectionTypeEnum : HsPhoneNetworkTypes.h
  • _PhnSysPrefSetting : HsPhoneCDMATypes.h
  • _PhnTTYSetting : HsPhoneAudioTypes.h
  • _PhoneServiceClassType : HsPhoneTypes.h
  • _SATDecisionType : HsPhoneGSMTypes.h
  • _SATNotificationType : HsPhoneGSMTypes.h
  • _SATRefreshFile : HsPhoneGSMTypes.h
  • _SATRefreshType : HsPhoneGSMTypes.h
  • _SATRequestType : HsPhoneGSMTypes.h
  • _SATSetupCallType : HsPhoneGSMTypes.h
  • _SmsCauseCode : HsPhoneSMSTypes.h
  • _SmsErrorCode : HsPhoneSMSTypes.h
  • _SoundPrefType : TonesLibTypes.h
  • _TonePlayNumberTimes : TonesLibTypes.h
  • _ToneRepeatInterval : TonesLibTypes.h
  • _ToneTimeUnit : TonesLibTypes.h
  • _ToneType : TonesLibTypes.h
  • _ToneVibrateType : TonesLibTypes.h
  • _ToneVolume : TonesLibTypes.h
  • _VMFontFace : VMFontLibCommon.h
  • _VMFontSize : VMFontLibCommon.h
  • _VMFontSizeRule : VMFontLibCommon.h
  • _VMFontStyle : VMFontLibCommon.h
  • _VMFontStyleRule : VMFontLibCommon.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:38 2008 for Palm API Guide


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • c
  • e
  • f
  • g
  • h
  • i
  • k
  • n
  • p
  • s
  • t
  • v
  • w

- k -

  • KeyCodeType : HsKeyCodes.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:38 2008 for Palm API Guide


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • c
  • e
  • f
  • g
  • h
  • i
  • k
  • n
  • p
  • s
  • t
  • v
  • w

- n -

  • NetIFSettingShimEnum : PalmShimSettings.h
  • NetQueryId : PalmWiFiCommon.h
  • NetWepStatus : PalmWiFiCommon.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:38 2008 for Palm API Guide


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • c
  • e
  • f
  • g
  • h
  • i
  • k
  • n
  • p
  • s
  • t
  • v
  • w

- a -

  • AACHeaderType : palmOneCodecFormat.h
  • AACObjectType : palmOneCodecFormat.h
  • AddrCustomActionCodes : HsAppLaunchCmd.h
  • AddrCustomNotificationCodes : HsAppLaunchCmd.h
  • AddressAppPhoneLabel : HsPhoneSMSTypes.h
  • AddressAppRecordFieldEnum : HsPhoneSMSTypes.h
  • AddressHsLookupFields : HsAppLaunchCmd.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:38 2008 for Palm API Guide


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • c
  • e
  • f
  • g
  • h
  • i
  • k
  • n
  • p
  • s
  • t
  • v
  • w

- c -

  • CCSMBrowserSettingsEnum : CarrierCustomLibTypes.h
  • CCSMMessagingSettingsEnum : CarrierCustomLibTypes.h
  • CCSMPhoneFlagsEnum : CarrierCustomLibTypes.h
  • CCSMRadioBandEnum : CarrierCustomLibTypes.h
  • CCSMSystemFlagsEnum : CarrierCustomLibTypes.h
  • ContactsLabelTypes : Contacts.h
  • ContactsLibAllFields : Contacts.h
  • ContactsLibBinaryFields : Contacts.h
  • ContactsLibCustomFields : Contacts.h
  • ContactsLibDateFields : Contacts.h
  • ContactsLibFieldLabels : Contacts.h
  • ContactsLibStrFields : Contacts.h
  • ContactsLibUInt16Fields : Contacts.h
  • ContactsLibUInt32Fields : Contacts.h
  • ContactsLibUInt8Fields : Contacts.h
  • ContactsLibWithLabelFields : Contacts.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:38 2008 for Palm API Guide


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • c
  • e
  • f
  • g
  • h
  • i
  • k
  • n
  • p
  • s
  • t
  • v
  • w

- e -

  • ePmConnectorDeviceState : PmConnectorLibCommon.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:38 2008 for Palm API Guide


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • c
  • e
  • f
  • g
  • h
  • i
  • k
  • n
  • p
  • s
  • t
  • v
  • w

- f -

  • FavDBLibPhoneViewEnum : FavoritesDBLib.h
  • FileFlag : palmOneCodecFormat.h
  • FrmNavFocusRingStyleEnumTag : HsNavCommon.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:38 2008 for Palm API Guide


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • c
  • e
  • f
  • g
  • h
  • i
  • k
  • n
  • p
  • s
  • t
  • v
  • w

- g -

  • GSMCLIPStatus : HsPhoneNetworkTypes.h
  • GSMCLIRDisplayStatus : HsPhoneNetworkTypes.h
  • GSMRegistrationMode : HsPhoneNetworkTypes.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:38 2008 for Palm API Guide


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • c
  • e
  • f
  • g
  • h
  • i
  • k
  • n
  • p
  • s
  • t
  • v
  • w

- h -

  • HsAttrEnum : HsExtCommon.h
  • HsIndicatorCountEnum : HsExtCommon.h
  • HsIndicatorStateEnum : HsExtCommon.h
  • HsIndicatorTypeEnum : HsExtCommon.h
  • HsLightCircumstanceEnum : HsExtCommon.h
  • HsLightModeEnum : HsExtCommon.h
  • HsNavFocusColorEnumTag : HsNavCommon.h
  • HsNavFocusRingStyleEnumTag : HsNavCommon.h
  • HsPrefEnum : HsExtCommon.h
  • HsSndCmdEnumTag : HsSoundLibCommon.h
  • HsSndFormatEnumTag : HsSoundLibCommon.h
  • hsSndSysBeepTag : HsSoundLibCommon.h
  • HsStatusGadgetTypeEnum : HsExtCommon.h
  • HsVerStrEnum : HsExtCommon.h
  • httpAuthPath_ : HS_HTTPLibConst.h
  • httpAuthTarget_ : HS_HTTPLibConst.h
  • httpAuthType_ : HS_HTTPLibConst.h
  • httpCookie_ : HS_HTTPLibConst.h
  • httpError_ : HS_HTTPLibConst.h
  • httpHeaderID_ : HS_HTTPLibConst.h
  • httpHeaderType_ : HS_HTTPLibConst.h
  • httpMethod_ : HS_HTTPLibConst.h
  • httpScheme_ : HS_HTTPLibConst.h
  • httpStatusCode_ : HS_HTTPLibConst.h
  • httpStreamState_ : HS_HTTPLibConst.h
  • httpVersion_ : HS_HTTPLibConst.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:38 2008 for Palm API Guide


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • c
  • e
  • f
  • g
  • h
  • i
  • k
  • n
  • p
  • s
  • t
  • v
  • w

- i -

  • IPAllocType : PalmWiFiCommon.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:38 2008 for Palm API Guide


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • c
  • e
  • f
  • g
  • h
  • i
  • k
  • n
  • p
  • s
  • t
  • v
  • w

- p -

  • PalmAACProfileType : palmOneCodecFormat.h
  • PalmAMRDtxMode : palmOneCodecFormat.h
  • PalmAMRMode : palmOneCodecFormat.h
  • PalmAudioChannelType : palmOneCodecFormat.h
  • PalmBasicType : palmOneCodecFormat.h
  • PalmBMPCompressionType : palmOneCodecFormat.h
  • PalmCodecControlType : palmOneCodecFormat.h
  • PalmEndianType : palmOneCodecFormat.h
  • PalmFileType : palmOneCodecFormat.h
  • PalmMPEG4Algorithm : palmOneCodecFormat.h
  • PalmOneStatAttrTypeTag : palmOneStatusBar.h
  • PalmQCELPRate : palmOneCodecFormat.h
  • PalmQCELPReducedRate : palmOneCodecFormat.h
  • PhnBarFacilityTypeEnum : HsPhoneNetworkTypes.h
  • PhnCallControlTypeEnum : HsPhoneNetworkTypes.h
  • PhnCLIRStatus : HsPhoneNetworkTypes.h
  • PhnConnectionEnum : HsPhoneMiscTypes.h
  • PhnDataChannelType : HsPhoneEvent.h
  • PhnEquipmentMode : HsPhoneMiscTypes.h
  • PHNErrorCodeRange_1 : HsPhoneErrors.h
  • PHNErrorCodeRange_2 : HsPhoneErrors.h
  • PhnEventCode : HsPhoneEvent.h
  • PhnForwardEnum : HsPhoneNetworkTypes.h
  • PhnForwardModeEnum : HsPhoneNetworkTypes.h
  • PhnIndicationKind : HsPhoneEvent.h
  • PhnIOTAItemEnum : HsPhoneIOTATypes.h
  • PhnIOTAStatus : HsPhoneIOTATypes.h
  • PhnLockModeEnum : HsPhoneTypes.h
  • PhnMIPFailType : HsPhoneCDMATypes.h
  • PhnMiscDbgUpdateKind : HsPhoneEvent.h
  • PhnMMIActionCodeEnum : HsPhoneNetworkTypes.h
  • PhnMMIServiceCodeEnum : HsPhoneNetworkTypes.h
  • PhnModuleButtonType : HsPhoneEvent.h
  • PhnMsgBoxEnum : HsPhoneNetworkTypes.h
  • PhnMsgBoxPriorityEnum : HsPhoneNetworkTypes.h
  • PhnMsgIDType : HsPhoneEvent.h
  • PhnOneXDataFailType : HsPhoneCDMATypes.h
  • PhnOpenDialogType : HsPhoneEvent.h
  • PhnOperatorStatus : HsPhoneNetworkTypes.h
  • PhnPasswordTypeEnum : HsPhoneSecurityTypes.h
  • PhnPDPAUncerttype : HsPhoneCDMATypes.h
  • PhnPDPReadAck : HsPhoneCDMATypes.h
  • PhnPDPWriteAck : HsPhoneCDMATypes.h
  • PhnProgressType : HsPhoneEvent.h
  • PhnRegistrationStatus : HsPhoneNetworkTypes.h
  • PhnRoamIconState : HsPhoneNetworkTypes.h
  • PhnRoamStatusEnum : HsPhoneNetworkTypes.h
  • PhnSMSClassEnum : HsPhoneEvent.h
  • PhnSMSTypeEnum : HsPhoneEvent.h
  • PhnTeleserviceMmiCodeType : HsPhoneNetworkTypes.h
  • PhnTeleserviceType : HsPhoneNetworkTypes.h
  • PhnVibrateType : HsPhoneMiscTypes.h
  • PhnWAPPushAppIdType : HsPhoneEvent.h
  • PhnWAPPushContentType : HsPhoneEvent.h
  • PhoneAppDialMethodEnum : HsAppLaunchCmd.h
  • PluginInfo : PalmVMPlugin.h
  • PmAudioGroupEnum : PmSoundLibAudioGroup.h
  • PmKeyAttrEnumTag : PmKeyLibCommon.h
  • PmSysGadgetBtStatusTypeEnum : PmSysGadgetLibCommon.h
  • PmSysGadgetStatusGadgetTypeEnum : PmSysGadgetLibCommon.h
  • PmUIUtilAttrEnumTag : PmUIUtilLibCommon.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:38 2008 for Palm API Guide


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • c
  • e
  • f
  • g
  • h
  • i
  • k
  • n
  • p
  • s
  • t
  • v
  • w

- s -

  • SecurityModeType : PalmWiFiCommon.h
  • SessionMode : Contacts.h
  • SMSAddressFormat : HsPhoneSMSTypes.h
  • SMSMessageFlags : HsPhoneSMSTypes.h
  • SMSMessageStatus : HsPhoneSMSTypes.h
  • SMSMessageType : HsPhoneSMSTypes.h
  • SoundPrefsView : HsAppLaunchCmd.h
  • StatAttrTypeTag : PalmStatusBar.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:38 2008 for Palm API Guide


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • c
  • e
  • f
  • g
  • h
  • i
  • k
  • n
  • p
  • s
  • t
  • v
  • w

- t -

  • tagAudioInputSetting : PmConnectorLibCommon.h
  • tagAudioOutputSetting : PmConnectorLibCommon.h
  • tagSndFileFormatEnum : palmOneSndFileStream.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:38 2008 for Palm API Guide


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • c
  • e
  • f
  • g
  • h
  • i
  • k
  • n
  • p
  • s
  • t
  • v
  • w

- v -

  • VPNLibEventNotificationTypeEnum_ : PalmShimSettings.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:38 2008 for Palm API Guide


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • c
  • e
  • f
  • g
  • h
  • i
  • k
  • n
  • p
  • s
  • t
  • v
  • w

- w -

  • WiFiCustomIFSettings : PalmWiFiCommon.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:38 2008 for Palm API Guide


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • v

- a -

  • addrAppLaunchCmdCallerID : HsAppLaunchCmd.h
  • addrAppLaunchCmdHsLookup : HsAppLaunchCmd.h
  • addrAppNotificationBeamBusinessCard : HsAppLaunchCmd.h
  • addrAppNotificationCmdCallerID : HsAppLaunchCmd.h
  • addrAppNotificationCreateNewRecord : HsAppLaunchCmd.h
  • addrAppNotificationDialPrefs : HsAppLaunchCmd.h
  • addrAppNotificationHsLookup : HsAppLaunchCmd.h
  • addrAppNotificationListLookupTypeGet : HsAppLaunchCmd.h
  • addrAppNotificationPhonebookApp : HsAppLaunchCmd.h
  • addrAppNotificationPhotoCallerID : HsAppLaunchCmd.h
  • addrEmailLabel : HsPhoneSMSTypes.h
  • addrFaxLabel : HsPhoneSMSTypes.h
  • addrHomeLabel : HsPhoneSMSTypes.h
  • addrListLookupTypeCompany : HsAppLaunchCmd.h
  • addrListLookupTypeFirstName : HsAppLaunchCmd.h
  • addrListLookupTypeIntelligent : HsAppLaunchCmd.h
  • addrListLookupTypeLastName : HsAppLaunchCmd.h
  • addrLookupAnyPhones : HsAppLaunchCmd.h
  • addrLookupSMSPhones : HsAppLaunchCmd.h
  • addrLookupSMSPhonesNoEmail : HsAppLaunchCmd.h
  • addrLookupVoicePhones : HsAppLaunchCmd.h
  • addrMainLabel : HsPhoneSMSTypes.h
  • addrMobileLabel : HsPhoneSMSTypes.h
  • addrNoLabel : HsPhoneSMSTypes.h
  • addrOtherLabel : HsPhoneSMSTypes.h
  • addrPagerLabel : HsPhoneSMSTypes.h
  • addrWorkLabel : HsPhoneSMSTypes.h
  • allSize : VMFontLibCommon.h
  • allStyle : VMFontLibCommon.h
  • autoLockMode : HsPhoneTypes.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:38 2008 for Palm API Guide


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • v

- k -

  • kAddress : HsPhoneSMSTypes.h
  • kAudioInputDefault : PmConnectorLibCommon.h
  • kAudioInputExternalMic : PmConnectorLibCommon.h
  • kAudioInputInternalMic : PmConnectorLibCommon.h
  • kAudioOutputSettingAthena : PmConnectorLibCommon.h
  • kAudioOutputSettingDefault : PmConnectorLibCommon.h
  • kAudioOutputSettingHeadphone : PmConnectorLibCommon.h
  • kAudioOutputSettingSpeaker : PmConnectorLibCommon.h
  • kAutoDelete : HsPhoneSMSTypes.h
  • kBoxData : HsPhoneNetworkTypes.h
  • kBoxEMail : HsPhoneNetworkTypes.h
  • kBoxOther : HsPhoneNetworkTypes.h
  • kBoxTelefax : HsPhoneNetworkTypes.h
  • kBoxVoice : HsPhoneNetworkTypes.h
  • kCCMSSettingsPrimaryTrustedDomain : CarrierCustomLibTypes.h
  • kCCMSSettingsSecondaryTrustedDomain : CarrierCustomLibTypes.h
  • kCCMSSettingsUAProfilingURL : CarrierCustomLibTypes.h
  • kCCSMBrowserSettingsCSDDisconnectOnExit : CarrierCustomLibTypes.h
  • kCCSMBrowserSettingsDormantOnExit : CarrierCustomLibTypes.h
  • kCCSMBrowserSettingsEncryptMSISDN : CarrierCustomLibTypes.h
  • kCCSMBrowserSettingsHideDisconnect : CarrierCustomLibTypes.h
  • kCCSMBrowserSettingsPDataDisconnectOnExit : CarrierCustomLibTypes.h
  • kCCSMBrowserSettingsReserved : CarrierCustomLibTypes.h
  • kCCSMBrowserSettingsVersionInWAPProfile : CarrierCustomLibTypes.h
  • kCCSMMessagingSettings11DigitRecipient : CarrierCustomLibTypes.h
  • kCCSMMessagingSettingsDisableMMSFallback : CarrierCustomLibTypes.h
  • kCCSMMessagingSettingsNormaliseMMSAddress : CarrierCustomLibTypes.h
  • kCCSMMessagingSettingsReserved : CarrierCustomLibTypes.h
  • kCCSMMessagingSettingsStripPhonePlus : CarrierCustomLibTypes.h
  • kCCSMMessagingSettingsWAPProtocol20 : CarrierCustomLibTypes.h
  • kCCSMPhoneSettingsEditMSISDN : CarrierCustomLibTypes.h
  • kCCSMPhoneSettingsEnableTTY : CarrierCustomLibTypes.h
  • kCCSMPhoneSettingsNetworkSelect : CarrierCustomLibTypes.h
  • kCCSMPhoneSettingsReserved : CarrierCustomLibTypes.h
  • kCCSMPhoneSettingsRoamingIndicator : CarrierCustomLibTypes.h
  • kCCSMPhoneSettingsShowEmergencyMode : CarrierCustomLibTypes.h
  • kCCSMPhoneSettingsUseEFSPN : CarrierCustomLibTypes.h
  • kCCSMPrimaryProxyAuthenticate : CarrierCustomLibTypes.h
  • kCCSMPrimaryProxyHide : CarrierCustomLibTypes.h
  • kCCSMPrimaryProxyLocked : CarrierCustomLibTypes.h
  • kCCSMRadioBandEurope : CarrierCustomLibTypes.h
  • kCCSMRadioBandNorthAmerica : CarrierCustomLibTypes.h
  • kCCSMRadioBandUnknown : CarrierCustomLibTypes.h
  • kCCSMSecondaryProxyAuthenticate : CarrierCustomLibTypes.h
  • kCCSMSecondaryProxyHide : CarrierCustomLibTypes.h
  • kCCSMSecondaryProxyLocked : CarrierCustomLibTypes.h
  • kCCSMSettingsBrowserFlags : CarrierCustomLibTypes.h
  • kCCSMSettingsBrowserProxyFlags : CarrierCustomLibTypes.h
  • kCCSMSettingsCarrierMSISDN : CarrierCustomLibTypes.h
  • kCCSMSettingsCSDDisable : CarrierCustomLibTypes.h
  • kCCSMSettingsE911Timeout : CarrierCustomLibTypes.h
  • kCCSMSettingsEditableMSISDN : CarrierCustomLibTypes.h
  • kCCSMSettingsEmailSMTPServer : CarrierCustomLibTypes.h
  • kCCSMSettingsEncryptMSISDN : CarrierCustomLibTypes.h
  • kCCSMSettingsGPRSAutoAttach : CarrierCustomLibTypes.h
  • kCCSMSettingsHomepageURL : CarrierCustomLibTypes.h
  • kCCSMSettingsHTTPHeaders : CarrierCustomLibTypes.h
  • kCCSMSettingsIndicateRoaming : CarrierCustomLibTypes.h
  • kCCSMSettingsMessagingFlags : CarrierCustomLibTypes.h
  • kCCSMSettingsMMSMaxMsgSize : CarrierCustomLibTypes.h
  • kCCSMSettingsMMSMaxVideoSize : CarrierCustomLibTypes.h
  • kCCSMSettingsMMSPort : CarrierCustomLibTypes.h
  • kCCSMSettingsMMSUAProf : CarrierCustomLibTypes.h
  • kCCSMSettingsMMSUAString : CarrierCustomLibTypes.h
  • kCCSMSettingsMMSURL : CarrierCustomLibTypes.h
  • kCCSMSettingsMMSVersionNumber : CarrierCustomLibTypes.h
  • kCCSMSettingsMMSWAPGateway : CarrierCustomLibTypes.h
  • kCCSMSettingsMSISDNHeaderFormat : CarrierCustomLibTypes.h
  • kCCSMSettingsNAI : CarrierCustomLibTypes.h
  • kCCSMSettingsNAIHeaderFormat : CarrierCustomLibTypes.h
  • kCCSMSettingsPOP3Server : CarrierCustomLibTypes.h
  • kCCSMSettingsPrimaryProxyPort : CarrierCustomLibTypes.h
  • kCCSMSettingsPrimaryProxyServer : CarrierCustomLibTypes.h
  • kCCSMSettingsPrimarySecureProxyPort : CarrierCustomLibTypes.h
  • kCCSMSettingsPrimarySecureProxyServer : CarrierCustomLibTypes.h
  • kCCSMSettingsProxyPassword : CarrierCustomLibTypes.h
  • kCCSMSettingsProxyUsername : CarrierCustomLibTypes.h
  • kCCSMSettingsRadioBand : CarrierCustomLibTypes.h
  • kCCSMSettingsReserved : CarrierCustomLibTypes.h
  • kCCSMSettingsSecondaryProxyPort : CarrierCustomLibTypes.h
  • kCCSMSettingsSecondaryProxyServer : CarrierCustomLibTypes.h
  • kCCSMSettingsSecondarySecureProxyPort : CarrierCustomLibTypes.h
  • kCCSMSettingsSecondarySecureProxyServer : CarrierCustomLibTypes.h
  • kCCSMSettingsShowEmergencyMode : CarrierCustomLibTypes.h
  • kCCSMSettingsShowNetworkSelect : CarrierCustomLibTypes.h
  • kCCSMSettingsSMSCNumber : CarrierCustomLibTypes.h
  • kCCSMSettingsSMSEmailGateway : CarrierCustomLibTypes.h
  • kCCSMSettingsSMSMaxMsgSize : CarrierCustomLibTypes.h
  • kCCSMSettingsSMSSupportDeliveryReceipt : CarrierCustomLibTypes.h
  • kCCSMSettingsSMSValidityPeriod : CarrierCustomLibTypes.h
  • kCCSMSettingsSMTPServer : CarrierCustomLibTypes.h
  • kCCSMSettingsSPNSupported : CarrierCustomLibTypes.h
  • kCCSMSettingsSystemReserved : CarrierCustomLibTypes.h
  • kCCSMSettingsVoiceMailNumber : CarrierCustomLibTypes.h
  • kCCSMSettingsWapSupportLevel : CarrierCustomLibTypes.h
  • kCCSMSystemSettingReserved : CarrierCustomLibTypes.h
  • kCity : HsPhoneSMSTypes.h
  • kCloseDialog : HsPhoneEvent.h
  • kCompany : HsPhoneSMSTypes.h
  • kCountry : HsPhoneSMSTypes.h
  • kCustom1 : HsPhoneSMSTypes.h
  • kCustom2 : HsPhoneSMSTypes.h
  • kCustom3 : HsPhoneSMSTypes.h
  • kCustom4 : HsPhoneSMSTypes.h
  • kDeferredDelivery : HsPhoneSMSTypes.h
  • kDialogDeferredSend : HsPhoneEvent.h
  • kDialogGetBarring : HsPhoneEvent.h
  • kDialogGetCallWaiting : HsPhoneEvent.h
  • kDialogGetForwarding : HsPhoneEvent.h
  • kDialogGetOperatorList : HsPhoneEvent.h
  • kDialogImmediateSend : HsPhoneEvent.h
  • kDialogOperatorSelection : HsPhoneEvent.h
  • kDialogSendUSSD : HsPhoneEvent.h
  • kDialogSetBarring : HsPhoneEvent.h
  • kDialogSetCallWaiting : HsPhoneEvent.h
  • kDialogSetForwarding : HsPhoneEvent.h
  • kDialogSetOperator : HsPhoneEvent.h
  • kDoneParsing : HsPhoneSMSTypes.h
  • kDontEncode : HsPhoneSMSTypes.h
  • keyA : HsKeyCodes.h
  • keyAt : HsKeyCodes.h
  • keyB : HsKeyCodes.h
  • keyBack : HsKeyCodes.h
  • keyBackslash : HsKeyCodes.h
  • keyBackspace : HsKeyCodes.h
  • keyBacktick : HsKeyCodes.h
  • keyC : HsKeyCodes.h
  • keyCalculator : HsKeyCodes.h
  • keyCapsLock : HsKeyCodes.h
  • keyCloseBracket : HsKeyCodes.h
  • keyComma : HsKeyCodes.h
  • keyD : HsKeyCodes.h
  • keyDash : HsKeyCodes.h
  • keyDelete : HsKeyCodes.h
  • keyDownArrow : HsKeyCodes.h
  • keyE : HsKeyCodes.h
  • keyEight : HsKeyCodes.h
  • keyEject : HsKeyCodes.h
  • keyEnd : HsKeyCodes.h
  • keyEquals : HsKeyCodes.h
  • keyEscape : HsKeyCodes.h
  • keyF : HsKeyCodes.h
  • keyF1 : HsKeyCodes.h
  • keyF10 : HsKeyCodes.h
  • keyF11 : HsKeyCodes.h
  • keyF12 : HsKeyCodes.h
  • keyF13 : HsKeyCodes.h
  • keyF14 : HsKeyCodes.h
  • keyF15 : HsKeyCodes.h
  • keyF2 : HsKeyCodes.h
  • keyF3 : HsKeyCodes.h
  • keyF4 : HsKeyCodes.h
  • keyF5 : HsKeyCodes.h
  • keyF6 : HsKeyCodes.h
  • keyF7 : HsKeyCodes.h
  • keyF8 : HsKeyCodes.h
  • keyF9 : HsKeyCodes.h
  • keyFastForward : HsKeyCodes.h
  • keyFavorites : HsKeyCodes.h
  • keyFind : HsKeyCodes.h
  • keyFive : HsKeyCodes.h
  • keyForward : HsKeyCodes.h
  • keyFour : HsKeyCodes.h
  • keyG : HsKeyCodes.h
  • keyH : HsKeyCodes.h
  • keyHard1 : HsKeyCodes.h
  • keyHard10 : HsKeyCodes.h
  • keyHard11 : HsKeyCodes.h
  • keyHard12 : HsKeyCodes.h
  • keyHard13 : HsKeyCodes.h
  • keyHard14 : HsKeyCodes.h
  • keyHard2 : HsKeyCodes.h
  • keyHard3 : HsKeyCodes.h
  • keyHard4 : HsKeyCodes.h
  • keyHard5 : HsKeyCodes.h
  • keyHard6 : HsKeyCodes.h
  • keyHard7 : HsKeyCodes.h
  • keyHard8 : HsKeyCodes.h
  • keyHard9 : HsKeyCodes.h
  • keyHardAntenna : HsKeyCodes.h
  • keyHardBrightness : HsKeyCodes.h
  • keyHardContrast : HsKeyCodes.h
  • keyHardCradle : HsKeyCodes.h
  • keyHardCradle2 : HsKeyCodes.h
  • keyHardPower : HsKeyCodes.h
  • keyHelp : HsKeyCodes.h
  • keyHome : HsKeyCodes.h
  • keyHomePage : HsKeyCodes.h
  • keyI : HsKeyCodes.h
  • keyInsert : HsKeyCodes.h
  • keyJ : HsKeyCodes.h
  • keyK : HsKeyCodes.h
  • keyL : HsKeyCodes.h
  • keyLaunch : HsKeyCodes.h
  • keyLeftAlt : HsKeyCodes.h
  • keyLeftArrow : HsKeyCodes.h
  • keyLeftCommand : HsKeyCodes.h
  • keyLeftControl : HsKeyCodes.h
  • keyLeftShift : HsKeyCodes.h
  • keyLessThan : HsKeyCodes.h
  • keyLockDevice : HsKeyCodes.h
  • keyLogOff : HsKeyCodes.h
  • keyM : HsKeyCodes.h
  • keyMail : HsKeyCodes.h
  • keyMedia : HsKeyCodes.h
  • keyMenu : HsKeyCodes.h
  • keyMute : HsKeyCodes.h
  • keyMyComputer : HsKeyCodes.h
  • keyMyDocuments : HsKeyCodes.h
  • keyMyMusic : HsKeyCodes.h
  • keyMyPictures : HsKeyCodes.h
  • keyN : HsKeyCodes.h
  • keyNextField : HsKeyCodes.h
  • keyNextTrack : HsKeyCodes.h
  • keyNine : HsKeyCodes.h
  • keyNull : HsKeyCodes.h
  • keyNumericAsterisk : HsKeyCodes.h
  • keyNumericDash : HsKeyCodes.h
  • keyNumericEight : HsKeyCodes.h
  • keyNumericEnter : HsKeyCodes.h
  • keyNumericEquals : HsKeyCodes.h
  • keyNumericFive : HsKeyCodes.h
  • keyNumericFour : HsKeyCodes.h
  • keyNumericNine : HsKeyCodes.h
  • keyNumericOne : HsKeyCodes.h
  • keyNumericPeriod : HsKeyCodes.h
  • keyNumericPlus : HsKeyCodes.h
  • keyNumericSeven : HsKeyCodes.h
  • keyNumericSix : HsKeyCodes.h
  • keyNumericSlash : HsKeyCodes.h
  • keyNumericThree : HsKeyCodes.h
  • keyNumericTwo : HsKeyCodes.h
  • keyNumericZero : HsKeyCodes.h
  • keyNumLock : HsKeyCodes.h
  • keyO : HsKeyCodes.h
  • keyOne : HsKeyCodes.h
  • keyOpenBracket : HsKeyCodes.h
  • keyP : HsKeyCodes.h
  • keyPageDown : HsKeyCodes.h
  • keyPageUp : HsKeyCodes.h
  • keyPause : HsKeyCodes.h
  • keyPauseAudio : HsKeyCodes.h
  • keyPeriod : HsKeyCodes.h
  • keyPlay : HsKeyCodes.h
  • keyPlayPause : HsKeyCodes.h
  • keyPrevField : HsKeyCodes.h
  • keyPrevTrack : HsKeyCodes.h
  • keyPrintScreen : HsKeyCodes.h
  • keyQ : HsKeyCodes.h
  • keyR : HsKeyCodes.h
  • keyRefresh : HsKeyCodes.h
  • keyReturn : HsKeyCodes.h
  • keyRewind : HsKeyCodes.h
  • keyRightAlt : HsKeyCodes.h
  • keyRightArrow : HsKeyCodes.h
  • keyRightCommand : HsKeyCodes.h
  • keyRightControl : HsKeyCodes.h
  • keyRightShift : HsKeyCodes.h
  • keyRockerCenter : HsKeyCodes.h
  • keyRockerDown : HsKeyCodes.h
  • keyRockerLeft : HsKeyCodes.h
  • keyRockerRight : HsKeyCodes.h
  • keyRockerUp : HsKeyCodes.h
  • keyS : HsKeyCodes.h
  • keyScrollLock : HsKeyCodes.h
  • keySearch : HsKeyCodes.h
  • keySemiColon : HsKeyCodes.h
  • keySeven : HsKeyCodes.h
  • keySide : HsKeyCodes.h
  • keySingleQuote : HsKeyCodes.h
  • keySix : HsKeyCodes.h
  • keySlash : HsKeyCodes.h
  • keySpace : HsKeyCodes.h
  • keyStopAudio : HsKeyCodes.h
  • keyStopInternet : HsKeyCodes.h
  • keyT : HsKeyCodes.h
  • keyTab : HsKeyCodes.h
  • keyThree : HsKeyCodes.h
  • keyThumbWheelBack : HsKeyCodes.h
  • keyThumbWheelDown : HsKeyCodes.h
  • keyThumbWheelPush : HsKeyCodes.h
  • keyThumbWheelUp : HsKeyCodes.h
  • keyTwo : HsKeyCodes.h
  • keyU : HsKeyCodes.h
  • keyUpArrow : HsKeyCodes.h
  • keyV : HsKeyCodes.h
  • keyVolumeDown : HsKeyCodes.h
  • keyVolumeUp : HsKeyCodes.h
  • keyW : HsKeyCodes.h
  • keyX : HsKeyCodes.h
  • keyY : HsKeyCodes.h
  • keyZ : HsKeyCodes.h
  • keyZero : HsKeyCodes.h
  • kFailed : HsPhoneSMSTypes.h
  • kFirstName : HsPhoneSMSTypes.h
  • kFreeReply : HsPhoneSMSTypes.h
  • kGPRSQOSTypeMinimum : HsPhoneGSMTypes.h
  • kGPRSQOSTypeRequired : HsPhoneGSMTypes.h
  • kGreekSymbols : HsPhoneSMSTypes.h
  • kIndicatorAlertAlert : HsExtCommon.h
  • kIndicatorAlertCalendar : HsExtCommon.h
  • kIndicatorAlertMail : HsExtCommon.h
  • kIndicatorAlertNone : HsExtCommon.h
  • kIndicatorAlertPending : HsExtCommon.h
  • kIndicatorAlertSMS : HsExtCommon.h
  • kIndicatorAlertVoicemail : HsExtCommon.h
  • kIndicatorBattCharge : HsExtCommon.h
  • kIndicatorBattFull : HsExtCommon.h
  • kIndicatorBattLow : HsExtCommon.h
  • kIndicatorBattNone : HsExtCommon.h
  • kIndicatorBattTrickle : HsExtCommon.h
  • kIndicatorBtConnectAudio : PmSysGadgetLibCommon.h
  • kIndicatorBtConnectHeadset : PmSysGadgetLibCommon.h
  • kIndicatorBtConnectOther : PmSysGadgetLibCommon.h
  • kIndicatorBtConnectStereo : PmSysGadgetLibCommon.h
  • kIndicatorBtDUN : PmSysGadgetLibCommon.h
  • kIndicatorBtOff : PmSysGadgetLibCommon.h
  • kIndicatorBtOn : PmSysGadgetLibCommon.h
  • kIndicatorCountForever : HsExtCommon.h
  • kIndicatorCountGetState : HsExtCommon.h
  • kIndicatorForceGreen : HsExtCommon.h
  • kIndicatorForceNone : HsExtCommon.h
  • kIndicatorForceOff : HsExtCommon.h
  • kIndicatorForceOn : HsExtCommon.h
  • kIndicatorForceRed : HsExtCommon.h
  • kIndicatorForceRedGreen : HsExtCommon.h
  • kIndicatorRingActive : HsExtCommon.h
  • kIndicatorRingContact : HsExtCommon.h
  • kIndicatorRingNone : HsExtCommon.h
  • kIndicatorRingRoam : HsExtCommon.h
  • kIndicatorSignalBad : HsExtCommon.h
  • kIndicatorSignalGood : HsExtCommon.h
  • kIndicatorSignalNone : HsExtCommon.h
  • kIndicatorSignalRoam : HsExtCommon.h
  • kIndicatorStateNull : HsExtCommon.h
  • kIndicatorTypeCount : HsExtCommon.h
  • kIndicatorTypeLed : HsExtCommon.h
  • kIndicatorTypeVibrator : HsExtCommon.h
  • kIndicatorUsageDataCall : HsExtCommon.h
  • kIndicatorUsageNone : HsExtCommon.h
  • kIndicatorUsageVoiceCall : HsExtCommon.h
  • kInternetEMail : HsPhoneSMSTypes.h
  • kMaxPhnEvtSupported : HsPhoneEvent.h
  • kMissingPart : HsPhoneSMSTypes.h
  • kMsgIdcancelMO : HsPhoneEvent.h
  • kMsgIdDeliverMT : HsPhoneEvent.h
  • kMsgIdDeliveryMTAck : HsPhoneEvent.h
  • kMsgIdReserved : HsPhoneEvent.h
  • kMsgIdSubmitMO : HsPhoneEvent.h
  • kMsgIdUserAck : HsPhoneEvent.h
  • kMTIncoming : HsPhoneSMSTypes.h
  • kMTOutgoing : HsPhoneSMSTypes.h
  • kName : HsPhoneSMSTypes.h
  • kNone : HsPhoneSMSTypes.h
  • kNote : HsPhoneSMSTypes.h
  • kNotification : HsPhoneSMSTypes.h
  • kOpenDialog : HsPhoneEvent.h
  • kParseError : HsPhoneSMSTypes.h
  • kParseInformationData : HsPhoneSMSTypes.h
  • kParseInformationID : HsPhoneSMSTypes.h
  • kParseInformationLength : HsPhoneSMSTypes.h
  • kPending : HsPhoneSMSTypes.h
  • kPhone1 : HsPhoneSMSTypes.h
  • kPhone2 : HsPhoneSMSTypes.h
  • kPhone3 : HsPhoneSMSTypes.h
  • kPhone4 : HsPhoneSMSTypes.h
  • kPhone5 : HsPhoneSMSTypes.h
  • kPmConnectorDeviceAttach : PmConnectorLibCommon.h
  • kPmConnectorDeviceDetach : PmConnectorLibCommon.h
  • kRead : HsPhoneSMSTypes.h
  • kReceived : HsPhoneSMSTypes.h
  • kReceiving : HsPhoneSMSTypes.h
  • kRecordFieldEnumCount : HsPhoneSMSTypes.h
  • kSATApplicationBusy : HsPhoneGSMTypes.h
  • kSATCancel : HsPhoneGSMTypes.h
  • kSATClearText : HsPhoneGSMTypes.h
  • kSATDataSvc : HsPhoneGSMTypes.h
  • kSATDisplaySubmenus : HsPhoneGSMTypes.h
  • kSATDisplayText : HsPhoneGSMTypes.h
  • kSATEFSimPhoneBook : HsPhoneGSMTypes.h
  • kSATEndSession : HsPhoneGSMTypes.h
  • kSATFileChange : HsPhoneGSMTypes.h
  • kSATGetInkey : HsPhoneGSMTypes.h
  • kSATGetInput : HsPhoneGSMTypes.h
  • kSATHelpRequested : HsPhoneGSMTypes.h
  • kSATIdleModeText : HsPhoneGSMTypes.h
  • kSATInit : HsPhoneGSMTypes.h
  • kSATInitWithFileChange : HsPhoneGSMTypes.h
  • kSATInitWithFullFileChange : HsPhoneGSMTypes.h
  • kSATItemSelected : HsPhoneGSMTypes.h
  • kSATLaunchBrowser : HsPhoneGSMTypes.h
  • kSATMainMenuAvailable : HsPhoneGSMTypes.h
  • kSATMakeCall : HsPhoneGSMTypes.h
  • kSATMax : HsPhoneGSMTypes.h
  • kSATNavigateBack : HsPhoneGSMTypes.h
  • kSATPlayTone : HsPhoneGSMTypes.h
  • kSATRefresh : HsPhoneGSMTypes.h
  • kSATReqDataSrv : HsPhoneGSMTypes.h
  • kSATReqIdleModeText : HsPhoneGSMTypes.h
  • kSATReqLaunchBrowser : HsPhoneGSMTypes.h
  • kSATReqPlayTone : HsPhoneGSMTypes.h
  • kSATReqRefresh : HsPhoneGSMTypes.h
  • kSATReqSendDTMF : HsPhoneGSMTypes.h
  • kSATRunAT : HsPhoneGSMTypes.h
  • kSATSelectItem : HsPhoneGSMTypes.h
  • kSATSelectMainMenuItem : HsPhoneGSMTypes.h
  • kSATSendDTMF : HsPhoneGSMTypes.h
  • kSATSendSMS : HsPhoneGSMTypes.h
  • kSATSendSS : HsPhoneGSMTypes.h
  • kSATSendUSSD : HsPhoneGSMTypes.h
  • kSATSessionAborted : HsPhoneGSMTypes.h
  • kSATSessionEnd : HsPhoneGSMTypes.h
  • kSATSetInkey : HsPhoneGSMTypes.h
  • kSATSetInput : HsPhoneGSMTypes.h
  • kSATSetupCall : HsPhoneGSMTypes.h
  • kSATSetupCallDisconnectOtherCalls : HsPhoneGSMTypes.h
  • kSATSetupCallHoldOtherCalls : HsPhoneGSMTypes.h
  • kSATSetupCallMax : HsPhoneGSMTypes.h
  • kSATSetupCallModeNotBusy : HsPhoneGSMTypes.h
  • kSATSetupCallWithRedialDisconnectOtherCalls : HsPhoneGSMTypes.h
  • kSATSetupCallWithRedialHoldOtherCalls : HsPhoneGSMTypes.h
  • kSATSetupCallWithRedialModeNotBusy : HsPhoneGSMTypes.h
  • kSATSIMReset : HsPhoneGSMTypes.h
  • kSATTimeout : HsPhoneGSMTypes.h
  • kSATUnknownNotification : HsPhoneGSMTypes.h
  • kSATUserNotResponse : HsPhoneGSMTypes.h
  • kSending : HsPhoneSMSTypes.h
  • kSent : HsPhoneSMSTypes.h
  • kSetRecipient : HsPhoneEvent.h
  • kSetText : HsPhoneEvent.h
  • kShowSegment : HsPhoneEvent.h
  • kSMSErrorType1 : HsPhoneSMSTypes.h
  • kSMSErrorType2 : HsPhoneSMSTypes.h
  • kSMSErrorType3 : HsPhoneSMSTypes.h
  • kSMSHighPriority : HsPhoneSMSTypes.h
  • kSMSLowPriority : HsPhoneSMSTypes.h
  • kSmsPriorityEmergency : HsPhoneNetworkTypes.h
  • kSmsPriorityInteractive : HsPhoneNetworkTypes.h
  • kSmsPriorityLast : HsPhoneNetworkTypes.h
  • kSmsPriorityNormal : HsPhoneNetworkTypes.h
  • kSmsPriorityUrgent : HsPhoneNetworkTypes.h
  • kSndFileFormatAAC : palmOneSndFileStream.h
  • kSndFileFormatMP3 : palmOneSndFileStream.h
  • kSndFileFormatRaw : palmOneSndFileStream.h
  • kSndFileFormatTreoAMR : palmOneSndFileStream.h
  • kSndFileFormatTreoQCP : palmOneSndFileStream.h
  • kSndFileFormatWAV : palmOneSndFileStream.h
  • kSortByCountryCodeTZName : LocsLibCommon.h
  • kSortByCountryTZName : LocsLibCommon.h
  • kSortByNameCountryTZ : LocsLibCommon.h
  • kState : HsPhoneSMSTypes.h
  • kStatusReport : HsPhoneSMSTypes.h
  • kSubstitution : HsPhoneSMSTypes.h
  • kTextSegments : HsPhoneSMSTypes.h
  • kTitle : HsPhoneSMSTypes.h
  • kWAPAnyApp : HsPhoneEvent.h
  • kWAPContentTypeIOTA : HsPhoneEvent.h
  • kWAPContentTypeMMS : HsPhoneEvent.h
  • kWAPContentTypeMMSText : HsPhoneEvent.h
  • kWAPContentTypeServiceIndicator : HsPhoneEvent.h
  • kWAPContentTypeServiceIndicatorText : HsPhoneEvent.h
  • kWAPContentTypeServiceLoad : HsPhoneEvent.h
  • kWAPContentTypeServiceLoadText : HsPhoneEvent.h
  • kWAPContentTypeUnknown : HsPhoneEvent.h
  • kWAPdocomoImodeMailUa : HsPhoneEvent.h
  • kWAPdocomoImodeMfUa : HsPhoneEvent.h
  • kWAPdocomoImodeMrUa : HsPhoneEvent.h
  • kWAPDrmUa : HsPhoneEvent.h
  • kWAPEmnUa : HsPhoneEvent.h
  • kWAPLocUa : HsPhoneEvent.h
  • kWAPMmsUa : HsPhoneEvent.h
  • kWAPMotorolaBrowserUa : HsPhoneEvent.h
  • kWAPMotorolaLocationUa : HsPhoneEvent.h
  • kWAPMotorolaNowUa : HsPhoneEvent.h
  • kWAPMotorolaOtaprovUa : HsPhoneEvent.h
  • kWAPMotorolaSplashUa : HsPhoneEvent.h
  • kWAPMsg : HsPhoneSMSTypes.h
  • kWAPMsIMclientUa : HsPhoneEvent.h
  • kWAPMsLocalcontentUa : HsPhoneEvent.h
  • kWAPNaiMvswCommand : HsPhoneEvent.h
  • kWAPopenwaveIotaUa : HsPhoneEvent.h
  • kWAPPushSIA : HsPhoneEvent.h
  • kWAPPushSyncml : HsPhoneEvent.h
  • kWAPSyncmlDm : HsPhoneEvent.h
  • kWAPUnused : HsPhoneEvent.h
  • kWAPWmlUa : HsPhoneEvent.h
  • kWAPWtaUa : HsPhoneEvent.h
  • kWAPWvUa : HsPhoneEvent.h
  • kZipCode : HsPhoneSMSTypes.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:38 2008 for Palm API Guide


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • v

- l -

  • largeFonts : VMFontLibCommon.h
  • LC : palmOneCodecFormat.h
  • LD : palmOneCodecFormat.h
  • lifeTimeData : HsPhoneTypes.h
  • lifeTimeVoice : HsPhoneTypes.h
  • LTP : palmOneCodecFormat.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:38 2008 for Palm API Guide


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • v

- m -

  • MAIN : palmOneCodecFormat.h
  • mmiActionActivate : HsPhoneNetworkTypes.h
  • mmiActionDeactivate : HsPhoneNetworkTypes.h
  • mmiActionErasure : HsPhoneNetworkTypes.h
  • mmiActionHandspring : HsPhoneNetworkTypes.h
  • mmiActionInterrogate : HsPhoneNetworkTypes.h
  • mmiActionNoAction : HsPhoneNetworkTypes.h
  • mmiActionRegister : HsPhoneNetworkTypes.h
  • mmiActionUnlock : HsPhoneNetworkTypes.h
  • mmiControlActivateCallx : HsPhoneNetworkTypes.h
  • mmiControlConference : HsPhoneNetworkTypes.h
  • mmiControlReleaseAllActive : HsPhoneNetworkTypes.h
  • mmiControlReleaseAllHeld : HsPhoneNetworkTypes.h
  • mmiControlReleaseCallx : HsPhoneNetworkTypes.h
  • mmiControlSwap : HsPhoneNetworkTypes.h
  • mmiControlTransfer : HsPhoneNetworkTypes.h
  • mmiServiceAllBarringServ : HsPhoneNetworkTypes.h
  • mmiServiceAllInBarringServ : HsPhoneNetworkTypes.h
  • mmiServiceAllOutBarringServ : HsPhoneNetworkTypes.h
  • mmiServiceBAIC : HsPhoneNetworkTypes.h
  • mmiServiceBAICR : HsPhoneNetworkTypes.h
  • mmiServiceBAOC : HsPhoneNetworkTypes.h
  • mmiServiceBAOIC : HsPhoneNetworkTypes.h
  • mmiServiceBAOICX : HsPhoneNetworkTypes.h
  • mmiServiceCallControl : HsPhoneNetworkTypes.h
  • mmiServiceCallerId : HsPhoneNetworkTypes.h
  • mmiServiceCallWaiting : HsPhoneNetworkTypes.h
  • mmiServiceChangeBarPwd : HsPhoneNetworkTypes.h
  • mmiServiceChangePIN : HsPhoneNetworkTypes.h
  • mmiServiceChangePIN2 : HsPhoneNetworkTypes.h
  • mmiServiceCOLP : HsPhoneNetworkTypes.h
  • mmiServiceCOLR : HsPhoneNetworkTypes.h
  • mmiServiceForwardAll : HsPhoneNetworkTypes.h
  • mmiServiceForwardBusy : HsPhoneNetworkTypes.h
  • mmiServiceForwardConditionalAll : HsPhoneNetworkTypes.h
  • mmiServiceForwardNoReply : HsPhoneNetworkTypes.h
  • mmiServiceForwardNotReachable : HsPhoneNetworkTypes.h
  • mmiServiceForwardUnconditional : HsPhoneNetworkTypes.h
  • mmiServiceIMEI : HsPhoneNetworkTypes.h
  • mmiServiceInvalid : HsPhoneNetworkTypes.h
  • mmiServiceNNN : HsPhoneNetworkTypes.h
  • mmiServiceNumberSent : HsPhoneNetworkTypes.h
  • mmiServicePhoneNumber : HsPhoneNetworkTypes.h
  • mmiServiceSelectorOperatorLock : HsPhoneNetworkTypes.h
  • mmiServiceSelectorProviderLock : HsPhoneNetworkTypes.h
  • mmiServiceUnimplemented : HsPhoneNetworkTypes.h
  • mmiServiceUnlockPIN : HsPhoneNetworkTypes.h
  • mmiServiceUnlockPIN2 : HsPhoneNetworkTypes.h
  • mmiServiceUSSD : HsPhoneNetworkTypes.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:38 2008 for Palm API Guide


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • v

- n -

  • net80211_DS : PalmWiFiCommon.h
  • net80211_FH : PalmWiFiCommon.h
  • net80211_Max : PalmWiFiCommon.h
  • net80211AutoUnknown : PalmWiFiCommon.h
  • net80211Bss : PalmWiFiCommon.h
  • net80211Infrastructure : PalmWiFiCommon.h
  • net80211InfrastructureMax : PalmWiFiCommon.h
  • netIFSetting80211AdhocTxPower : PalmWiFiCommon.h
  • netIFSetting80211Channel : PalmWiFiCommon.h
  • netIFSetting80211Diversity : PalmWiFiCommon.h
  • netIFSetting80211EncryptionKey1 : PalmWiFiCommon.h
  • netIFSetting80211EncryptionKey2 : PalmWiFiCommon.h
  • netIFSetting80211EncryptionKey3 : PalmWiFiCommon.h
  • netIFSetting80211EncryptionKey4 : PalmWiFiCommon.h
  • netIFSetting80211EncryptionKeyID : PalmWiFiCommon.h
  • netIFSetting80211Environment : PalmWiFiCommon.h
  • netIFSetting80211EssTxPower : PalmWiFiCommon.h
  • netIFSetting80211Gateway : PalmWiFiCommon.h
  • netIFSetting80211Last : PalmWiFiCommon.h
  • netIFSetting80211LongPreamble : PalmWiFiCommon.h
  • netIFSetting80211MandatoryBSSId : PalmWiFiCommon.h
  • netIFSetting80211MediaDisconnectLingerTime : PalmWiFiCommon.h
  • netIFSetting80211MobileIP : PalmWiFiCommon.h
  • netIFSetting80211MUEncryptionAlgorithm : PalmWiFiCommon.h
  • netIFSetting80211PortType : PalmWiFiCommon.h
  • netIFSetting80211PowerMode : PalmWiFiCommon.h
  • netIFSetting80211SmartConnect : PalmWiFiCommon.h
  • netIFSetting80211StationName : PalmWiFiCommon.h
  • netIFSetting8021x : PalmWiFiCommon.h
  • netIFSettingAutoPowerDownOnClose : PalmWiFiCommon.h
  • netIFSettingDHCPRequestDNS : PalmWiFiCommon.h
  • netIFSettingDriverQSize : PalmWiFiCommon.h
  • netIFSettingInterfaceQSize : PalmWiFiCommon.h
  • netIFSettingIPAllocType : PalmWiFiCommon.h
  • netIFSettingPrimaryDNS : PalmWiFiCommon.h
  • netIFSettingSecondaryDNS : PalmWiFiCommon.h
  • netIFSettingShimConfig : PalmShimSettings.h
  • netIFSettingShimCreator : PalmShimSettings.h
  • netIFSettingShimHideProgress : PalmShimSettings.h
  • netIFSettingShimLibVersion : PalmShimSettings.h
  • netIFSettingShimLog : PalmShimSettings.h
  • netIFSettingShimUp : PalmShimSettings.h
  • netIFSettingShimVersion : PalmShimSettings.h
  • netIFSettingShimVPNStart : PalmShimSettings.h
  • netIFSettingShimVPNStop : PalmShimSettings.h
  • netIFSettingUIProgHoldOff : PalmWiFiCommon.h
  • netIFSettingWiFiHideProgress : PalmWiFiCommon.h
  • netMasterAutoLoginClearAll : NetMasterLibTypes.h
  • netMasterAutoLoginWhenWirelessOn : NetMasterLibTypes.h
  • netMasterClientEventLAST : NetMasterLibTypes.h
  • netMasterClientEventUnknown : NetMasterLibTypes.h
  • netMasterClientEventVPNConnInstall : NetMasterLibTypes.h
  • netMasterLoginNetGuardEnabled : NetMasterLibTypes.h
  • netMasterLoginPriorityDefault : NetMasterLibTypes.h
  • netMasterLoginPriorityHigh : NetMasterLibTypes.h
  • netMasterLoginPriorityLow : NetMasterLibTypes.h
  • netMasterNetIFShutDownOptCurrentOnly : NetMasterLibTypes.h
  • netMasterNetIFShutDownOptDismissPrgDialog : NetMasterLibTypes.h
  • netMasterNetIFShutDownOptResetNetGuard : NetMasterLibTypes.h
  • netMasterNetLibOpenOptAutoDismiss : NetMasterLibTypes.h
  • netMasterNetLibOpenOptBypassNetGuard : NetMasterLibTypes.h
  • netMasterNetLibOpenOptPrimaryProfileOnly : NetMasterLibTypes.h
  • netPref1xRTTTunnelingForward : NetPrefLibTypes.h
  • netPref1xRTTTunnelingLAST : NetPrefLibTypes.h
  • netPref1xRTTTunnelingReverse : NetPrefLibTypes.h
  • netPref1xRTTTunnelingUnknown : NetPrefLibTypes.h
  • netPrefFallbackAlgrorithmBasic : NetPrefLibTypes.h
  • netPrefFallbackAlgrorithmLAST : NetPrefLibTypes.h
  • netPrefFallbackAlgrorithmMutexSticky : NetPrefLibTypes.h
  • netPrefFallbackStatusFlagInitialized : NetPrefLibTypes.h
  • netPrefFieldSetDefineOptionKeepData : NetPrefLibTypes.h
  • netPrefFieldSetDefineOptionNone : NetPrefLibTypes.h
  • netPrefFieldTypeBin : NetPrefLibTypes.h
  • netPrefFieldTypeStr : NetPrefLibTypes.h
  • netPrefFieldTypeUInt16 : NetPrefLibTypes.h
  • netPrefFieldTypeUInt32 : NetPrefLibTypes.h
  • netPrefFieldTypeUInt8 : NetPrefLibTypes.h
  • netPrefFieldTypeZStrList : NetPrefLibTypes.h
  • netPrefMutexStickyFBAStatusFailed : NetPrefLibTypes.h
  • netPrefMutexStickyFBAStatusSucceeded : NetPrefLibTypes.h
  • netPrefMutexStickyFBAStatusUnknown : NetPrefLibTypes.h
  • netPrefNetCloseWaitCarrierDefault : NetPrefLibTypes.h
  • netPrefNetCloseWaitEndOnPowerOff : NetPrefLibTypes.h
  • netPrefNetCloseWaitMaintainSession : NetPrefLibTypes.h
  • netPrefNetIdleTimeoutNever : NetPrefLibTypes.h
  • netPrefPlatformCDMA : NetPrefLibTypes.h
  • netPrefPlatformGSM : NetPrefLibTypes.h
  • netPrefPlatformLAST : NetPrefLibTypes.h
  • netPrefPlatformUnknown : NetPrefLibTypes.h
  • netPrefRecProtectionDeletionAfterWarning : NetPrefLibTypes.h
  • netPrefRecProtectionDeletionMask : NetPrefLibTypes.h
  • netPrefRecProtectionDeletionNotAllowed : NetPrefLibTypes.h
  • netPrefRecProtectionDuplicationAllowed : NetPrefLibTypes.h
  • netPrefRecProtectionDuplicationMask : NetPrefLibTypes.h
  • netPrefRecProtectionDuplicationNotAllowed : NetPrefLibTypes.h
  • netPrefRecProtectionEditingAfterWarning : NetPrefLibTypes.h
  • netPrefRecProtectionEditingAllowed : NetPrefLibTypes.h
  • netPrefRecProtectionEditingMask : NetPrefLibTypes.h
  • netPrefRecProtectionEditingNotAllowed : NetPrefLibTypes.h
  • netPrefSvcBindingCCSM : NetPrefLibTypes.h
  • netPrefSvcBindingCustom : NetPrefLibTypes.h
  • netPrefSvcBindingIOTA : NetPrefLibTypes.h
  • netPrefSvcBindingLAST : NetPrefLibTypes.h
  • netPrefSvcBindingUnknown : NetPrefLibTypes.h
  • netPrefSvcGatewayBrowser : NetPrefLibTypes.h
  • netPrefSvcGatewayCorporate : NetPrefLibTypes.h
  • netPrefSvcGatewayDownloads : NetPrefLibTypes.h
  • netPrefSvcGatewayIM : NetPrefLibTypes.h
  • netPrefSvcGatewayInternet : NetPrefLibTypes.h
  • netPrefSvcGatewayLAST : NetPrefLibTypes.h
  • netPrefSvcGatewayMail : NetPrefLibTypes.h
  • netPrefSvcGatewayMMS : NetPrefLibTypes.h
  • netPrefSvcGatewayPictureMail : NetPrefLibTypes.h
  • netPrefSvcGatewayPrivate : NetPrefLibTypes.h
  • netPrefSvcGatewayUnknown : NetPrefLibTypes.h
  • netPrefSvcGatewayWAP : NetPrefLibTypes.h
  • netPrefSvcMedium1xRTT : NetPrefLibTypes.h
  • netPrefSvcMediumCCSD : NetPrefLibTypes.h
  • netPrefSvcMediumDialUp : NetPrefLibTypes.h
  • netPrefSvcMediumDirect : NetPrefLibTypes.h
  • netPrefSvcMediumGCSD : NetPrefLibTypes.h
  • netPrefSvcMediumGISDN : NetPrefLibTypes.h
  • netPrefSvcMediumGPRS : NetPrefLibTypes.h
  • netPrefSvcMediumLAST : NetPrefLibTypes.h
  • netPrefSvcMediumOEM : NetPrefLibTypes.h
  • netPrefSvcMediumQNC : NetPrefLibTypes.h
  • netPrefSvcMediumUnknown : NetPrefLibTypes.h
  • netPrefSvcTargetBrowser : NetPrefLibTypes.h
  • netPrefSvcTargetCorporate : NetPrefLibTypes.h
  • netPrefSvcTargetDownloads : NetPrefLibTypes.h
  • netPrefSvcTargetIM : NetPrefLibTypes.h
  • netPrefSvcTargetInternet : NetPrefLibTypes.h
  • netPrefSvcTargetLAST : NetPrefLibTypes.h
  • netPrefSvcTargetMail : NetPrefLibTypes.h
  • netPrefSvcTargetMMS : NetPrefLibTypes.h
  • netPrefSvcTargetPictureMail : NetPrefLibTypes.h
  • netPrefSvcTargetReserved1 : NetPrefLibTypes.h
  • netPrefSvcTargetUnknown : NetPrefLibTypes.h
  • netPrefSvcTargetWAP : NetPrefLibTypes.h
  • netQuery80211AuthenticationMode : PalmWiFiCommon.h
  • netQuery80211BSSID : PalmWiFiCommon.h
  • netQuery80211BssScan : PalmWiFiCommon.h
  • netQuery80211BssScanList : PalmWiFiCommon.h
  • netQuery80211Channel : PalmWiFiCommon.h
  • netQuery80211ChannelList : PalmWiFiCommon.h
  • netQuery80211DriverDate : PalmWiFiCommon.h
  • netQuery80211FirmwareVersion : PalmWiFiCommon.h
  • netQuery80211FWName : PalmWiFiCommon.h
  • netQuery80211Key : PalmWiFiCommon.h
  • netQuery80211KeyIndex : PalmWiFiCommon.h
  • netQuery80211Last : PalmWiFiCommon.h
  • netQuery80211MediaState : PalmWiFiCommon.h
  • netQuery80211OperatingMode : PalmWiFiCommon.h
  • netQuery80211PowerState : PalmWiFiCommon.h
  • netQuery80211RadioState : PalmWiFiCommon.h
  • netQuery80211ResetKeys : PalmWiFiCommon.h
  • netQuery80211SecurityMode : PalmWiFiCommon.h
  • netQuery80211SerialNumber : PalmWiFiCommon.h
  • netQuery80211SignalQuality : PalmWiFiCommon.h
  • netQuery80211SignalStrength : PalmWiFiCommon.h
  • netQuery80211SSID : PalmWiFiCommon.h
  • netQuery80211StartConnection : PalmWiFiCommon.h
  • netQuery80211WEPRequired : PalmWiFiCommon.h
  • netQuery80211WepStatus : PalmWiFiCommon.h
  • netQueryCancel : PalmWiFiCommon.h
  • netWEPDisabled : PalmWiFiCommon.h
  • netWEPEnabled : PalmWiFiCommon.h
  • netWEPKeyAbsent : PalmWiFiCommon.h
  • netWEPNotSupported : PalmWiFiCommon.h
  • normal : VMFontLibCommon.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:38 2008 for Palm API Guide


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • v

- o -

  • oneXConnection : HsPhoneMiscTypes.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:38 2008 for Palm API Guide


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • v

- b -

  • band1800 : HsPhoneNetworkTypes.h
  • band1900 : HsPhoneNetworkTypes.h
  • band1900_850 : HsPhoneNetworkTypes.h
  • band850 : HsPhoneNetworkTypes.h
  • band900_1800 : HsPhoneNetworkTypes.h
  • bandAuto : HsPhoneNetworkTypes.h
  • bandGSM_EGSM : HsPhoneNetworkTypes.h
  • bold : VMFontLibCommon.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:38 2008 for Palm API Guide


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • v

- c -

  • class0 : HsPhoneEvent.h
  • class1 : HsPhoneEvent.h
  • class2 : HsPhoneEvent.h
  • class3 : HsPhoneEvent.h
  • classUnknown : HsPhoneEvent.h
  • clirNotProvisioned : HsPhoneNetworkTypes.h
  • clirProvisioned : HsPhoneNetworkTypes.h
  • clirTemporaryAllowed : HsPhoneNetworkTypes.h
  • clirTemporaryRestricted : HsPhoneNetworkTypes.h
  • clirUnknown : HsPhoneNetworkTypes.h
  • contactsAddress1 : Contacts.h
  • contactsAddress2 : Contacts.h
  • contactsAddress3 : Contacts.h
  • ContactsAddressLabel : Contacts.h
  • contactsAimChat : Contacts.h
  • contactsAnniversaryDate : Contacts.h
  • contactsAnniversaryMask : Contacts.h
  • contactsAnniversaryPreset : Contacts.h
  • contactsBinaryPictureData : Contacts.h
  • contactsBinaryRingtoneIdentifier : Contacts.h
  • contactsBirthdate : Contacts.h
  • contactsBirthdayMask : Contacts.h
  • contactsBirthdayPreset : Contacts.h
  • contactsBusy : Contacts.h
  • contactsCategoryID : Contacts.h
  • contactsChat1 : Contacts.h
  • contactsChat2 : Contacts.h
  • ContactsChatLabel : Contacts.h
  • contactsCity1 : Contacts.h
  • contactsCity2 : Contacts.h
  • contactsCity3 : Contacts.h
  • contactsCompany : Contacts.h
  • contactsCountry1 : Contacts.h
  • contactsCountry2 : Contacts.h
  • contactsCountry3 : Contacts.h
  • contactsCustom1 : Contacts.h
  • contactsCustom2 : Contacts.h
  • contactsCustom3 : Contacts.h
  • contactsCustom4 : Contacts.h
  • contactsCustom5 : Contacts.h
  • contactsCustom6 : Contacts.h
  • contactsCustom7 : Contacts.h
  • contactsCustom8 : Contacts.h
  • contactsCustom9 : Contacts.h
  • contactsCustomCustom1 : Contacts.h
  • contactsCustomCustom2 : Contacts.h
  • contactsCustomCustom3 : Contacts.h
  • contactsCustomCustom4 : Contacts.h
  • contactsCustomCustom5 : Contacts.h
  • contactsCustomCustom6 : Contacts.h
  • contactsCustomCustom7 : Contacts.h
  • contactsCustomCustom8 : Contacts.h
  • contactsCustomCustom9 : Contacts.h
  • contactsDateAnniversary : Contacts.h
  • contactsDateBirthdate : Contacts.h
  • contactsDirty : Contacts.h
  • contactsEmailPhone : Contacts.h
  • contactsFaxPhone : Contacts.h
  • contactsFirstName : Contacts.h
  • contactsHomeAddress : Contacts.h
  • contactsHomePhone : Contacts.h
  • contactsIcqChat : Contacts.h
  • contactsIndex : Contacts.h
  • contactsLastName : Contacts.h
  • ContactsLibSessionModeReadOnly : Contacts.h
  • ContactsLibSessionModeReadWrite : Contacts.h
  • contactsMainPhone : Contacts.h
  • contactsMobilePhone : Contacts.h
  • contactsMsnChat : Contacts.h
  • contactsNote : Contacts.h
  • contactsNoType : Contacts.h
  • contactsNumFields : Contacts.h
  • contactsOtherAddress : Contacts.h
  • contactsOtherChat : Contacts.h
  • contactsOtherPhone : Contacts.h
  • contactsPagerPhone : Contacts.h
  • contactsPhone1 : Contacts.h
  • contactsPhone2 : Contacts.h
  • contactsPhone3 : Contacts.h
  • contactsPhone4 : Contacts.h
  • contactsPhone5 : Contacts.h
  • contactsPhone6 : Contacts.h
  • contactsPhone7 : Contacts.h
  • ContactsPhoneLabel : Contacts.h
  • contactsPicture : Contacts.h
  • contactsPrivate : Contacts.h
  • contactsRingtoneInfo : Contacts.h
  • contactsState1 : Contacts.h
  • contactsState2 : Contacts.h
  • contactsState3 : Contacts.h
  • contactsStrAddress1 : Contacts.h
  • contactsStrAddress2 : Contacts.h
  • contactsStrAddress3 : Contacts.h
  • contactsStrChat1 : Contacts.h
  • contactsStrChat2 : Contacts.h
  • contactsStrCity1 : Contacts.h
  • contactsStrCity2 : Contacts.h
  • contactsStrCity3 : Contacts.h
  • contactsStrCompany : Contacts.h
  • contactsStrCountry1 : Contacts.h
  • contactsStrCountry2 : Contacts.h
  • contactsStrCountry3 : Contacts.h
  • contactsStrCustom1 : Contacts.h
  • contactsStrCustom2 : Contacts.h
  • contactsStrCustom3 : Contacts.h
  • contactsStrCustom4 : Contacts.h
  • contactsStrCustom5 : Contacts.h
  • contactsStrCustom6 : Contacts.h
  • contactsStrCustom7 : Contacts.h
  • contactsStrCustom8 : Contacts.h
  • contactsStrCustom9 : Contacts.h
  • contactsStrFirstName : Contacts.h
  • contactsStrLastName : Contacts.h
  • contactsStrNote : Contacts.h
  • contactsStrPhone1 : Contacts.h
  • contactsStrPhone2 : Contacts.h
  • contactsStrPhone3 : Contacts.h
  • contactsStrPhone4 : Contacts.h
  • contactsStrPhone5 : Contacts.h
  • contactsStrPhone6 : Contacts.h
  • contactsStrPhone7 : Contacts.h
  • contactsStrState1 : Contacts.h
  • contactsStrState2 : Contacts.h
  • contactsStrState3 : Contacts.h
  • contactsStrTitle : Contacts.h
  • contactsStrWebpage : Contacts.h
  • contactsStrZipCode1 : Contacts.h
  • contactsStrZipCode2 : Contacts.h
  • contactsStrZipCode3 : Contacts.h
  • contactsTitle : Contacts.h
  • contactsUInt16Category : Contacts.h
  • contactsUInt16Index : Contacts.h
  • contactsUInt32UniqueID : Contacts.h
  • contactsUInt8AnniversaryMask : Contacts.h
  • contactsUInt8AnniversaryPreset : Contacts.h
  • contactsUInt8BirthdayMask : Contacts.h
  • contactsUInt8BirthdayPreset : Contacts.h
  • contactsUInt8Busy : Contacts.h
  • contactsUInt8Dirty : Contacts.h
  • contactsUInt8Private : Contacts.h
  • contactsUniqueID : Contacts.h
  • contactsWebpage : Contacts.h
  • contactsWithLabelAddress1 : Contacts.h
  • contactsWithLabelAddress2 : Contacts.h
  • contactsWithLabelAddress3 : Contacts.h
  • contactsWithLabelChat1 : Contacts.h
  • contactsWithLabelChat2 : Contacts.h
  • contactsWithLabelPhone1 : Contacts.h
  • contactsWithLabelPhone2 : Contacts.h
  • contactsWithLabelPhone3 : Contacts.h
  • contactsWithLabelPhone4 : Contacts.h
  • contactsWithLabelPhone5 : Contacts.h
  • contactsWithLabelPhone6 : Contacts.h
  • contactsWithLabelPhone7 : Contacts.h
  • contactsWorkAddress : Contacts.h
  • contactsWorkPhone : Contacts.h
  • contactsYahooChat : Contacts.h
  • contactsZipCode1 : Contacts.h
  • contactsZipCode2 : Contacts.h
  • contactsZipCode3 : Contacts.h
  • csdConnection : HsPhoneMiscTypes.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:38 2008 for Palm API Guide


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • v

- d -

  • defaultType : HsPhoneEvent.h
  • discardType0 : HsPhoneEvent.h
  • DRM_ER_LC : palmOneCodecFormat.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:38 2008 for Palm API Guide


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • v

- e -

  • eDbgUpdateNone : HsPhoneEvent.h
  • eDbgUpdateQuit : HsPhoneEvent.h
  • eDbgUpdateYes : HsPhoneEvent.h
  • ER_LC : palmOneCodecFormat.h
  • ER_LTP : palmOneCodecFormat.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:38 2008 for Palm API Guide


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • v

- f -

  • favDBLibPhoneViewCallLog : FavoritesDBLib.h
  • favDBLibPhoneViewContacts : FavoritesDBLib.h
  • favDBLibPhoneViewDialPad : FavoritesDBLib.h
  • FileStream : palmOneCodecFormat.h
  • frmNavFocusRingStyleHorizontalBars : HsNavCommon.h
  • frmNavFocusRingStyleInvalid : HsNavCommon.h
  • frmNavFocusRingStyleObjectTypeDefault : HsNavCommon.h
  • frmNavFocusRingStyleRound : HsNavCommon.h
  • frmNavFocusRingStyleSquare : HsNavCommon.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:38 2008 for Palm API Guide


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • v

- g -

  • gillSans : VMFontLibCommon.h
  • gprsConnection : HsPhoneMiscTypes.h
  • gsmCLIPNotProvisioned : HsPhoneNetworkTypes.h
  • gsmCLIPProvisioned : HsPhoneNetworkTypes.h
  • gsmCLIPUnknown : HsPhoneNetworkTypes.h
  • gsmCLIRInvocation : HsPhoneNetworkTypes.h
  • gsmCLIRSubscription : HsPhoneNetworkTypes.h
  • gsmCLIRSuppression : HsPhoneNetworkTypes.h
  • gsmDialCLIRDefault : HsPhoneTypes.h
  • gsmDialCLIRTemporaryInvocation : HsPhoneTypes.h
  • gsmDialCLIRTemporarySuppression : HsPhoneTypes.h
  • gsmMessagesCantReceive : HsPhoneGSMTypes.h
  • gsmMessagesConfirmMove : HsPhoneGSMTypes.h
  • gsmRegModeAutomatic : HsPhoneNetworkTypes.h
  • gsmRegModeDeregister : HsPhoneNetworkTypes.h
  • gsmRegModeFormat : HsPhoneNetworkTypes.h
  • gsmRegModeManual : HsPhoneNetworkTypes.h
  • gsmRegModeManualAutomatic : HsPhoneNetworkTypes.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:38 2008 for Palm API Guide


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • v

- h -

  • HE_AAC : palmOneCodecFormat.h
  • hsAttr68KActiveCalls : HsExtCommon.h
  • hsAttr68KDisplayOn : HsExtCommon.h
  • hsAttr68KKeyboardLocked : HsExtCommon.h
  • hsAttr68KKeyLockNextWakeTicks : HsExtCommon.h
  • hsAttr68KLidOpen : HsExtCommon.h
  • hsAttr68KPhoneType : HsExtCommon.h
  • hsAttr68KPostProcessRsc : HsExtCommon.h
  • hsAttr68KRingSwitch : HsExtCommon.h
  • hsAttr68KSysActive : HsExtCommon.h
  • hsAttr68KSysSleepReason : HsExtCommon.h
  • hsAttrActiveCalls : HsExtCommon.h
  • hsAttrAllKeysWakeFromSleep : HsExtCommon.h
  • hsAttrDigitizerLock : HsExtCommon.h
  • hsAttrDisplayOn : HsExtCommon.h
  • hsAttrDitherSuppress : HsExtCommon.h
  • hsAttrE911Mode : HsExtCommon.h
  • hsAttrHotSyncSuppress : HsExtCommon.h
  • hsAttrKeyboardDB : HsExtCommon.h
  • hsAttrKeyboardLocked : HsExtCommon.h
  • hsAttrKeyguardDialogOn : HsExtCommon.h
  • hsAttrKeyLockNextWakeTicks : HsExtCommon.h
  • hsAttrLidOpen : HsExtCommon.h
  • hsAttrPhoneRadioPowerState : HsExtCommon.h
  • hsAttrPhoneType : HsExtCommon.h
  • hsAttrPostProcessRsc : HsExtCommon.h
  • hsAttrReserved_SDK20_1 : HsExtCommon.h
  • hsAttrReserved_SDK20_2 : HsExtCommon.h
  • hsAttrReserved_SDK20_3 : HsExtCommon.h
  • hsAttrReserved_SDK20_4 : HsExtCommon.h
  • hsAttrReserved_SDK20_5 : HsExtCommon.h
  • hsAttrReserved_SDK20_6 : HsExtCommon.h
  • hsAttrReserved_SDK20_7 : HsExtCommon.h
  • hsAttrRingSwitch : HsExtCommon.h
  • hsAttrSysActive : HsExtCommon.h
  • hsAttrSysSleepReason : HsExtCommon.h
  • hsDialPrefsAdd4DigitPrefixNo : HsAppLaunchCmd.h
  • hsDialPrefsAdd4DigitPrefixUnknown : HsAppLaunchCmd.h
  • hsDialPrefsAdd4DigitPrefixYes : HsAppLaunchCmd.h
  • hsDialPrefsAdd5DigitPrefixNo : HsAppLaunchCmd.h
  • hsDialPrefsAdd5DigitPrefixUnknown : HsAppLaunchCmd.h
  • hsDialPrefsAdd5DigitPrefixYes : HsAppLaunchCmd.h
  • hsDialPrefsAdd6DigitPrefixNo : HsAppLaunchCmd.h
  • hsDialPrefsAdd6DigitPrefixUnknown : HsAppLaunchCmd.h
  • hsDialPrefsAdd6DigitPrefixYes : HsAppLaunchCmd.h
  • hsDialPrefsAddAreaCodeNo : HsAppLaunchCmd.h
  • hsDialPrefsAddAreaCodeUnknown : HsAppLaunchCmd.h
  • hsDialPrefsAddAreaCodeYes : HsAppLaunchCmd.h
  • hsForcePrefAutoOffDurationSecs : HsExtCommon.h
  • hsKeyMfgTest : HsKeyCodes.h
  • hsKeyRadioPower : HsKeyCodes.h
  • hsKeySymbol : HsKeyCodes.h
  • hsLightCircumstanceAlertWokeDevice : HsExtCommon.h
  • hsLightCircumstanceFirst : HsExtCommon.h
  • hsLightCircumstanceKeylightOff : HsExtCommon.h
  • hsLightCircumstanceNumCircumstances : HsExtCommon.h
  • hsLightCircumstanceQuickTyping : HsExtCommon.h
  • hsLightCircumstanceReserved : HsExtCommon.h
  • hsLightCircumstanceUserNotLooking : HsExtCommon.h
  • hsLightCircumstanceUserNotLookingLongTime : HsExtCommon.h
  • hsLightModeNight : HsExtCommon.h
  • hsLightModeNormal : HsExtCommon.h
  • hsLightModeNumPresets : HsExtCommon.h
  • hsLightModeReserved : HsExtCommon.h
  • hsNavFocusColorInsideBottomRightRing : HsNavCommon.h
  • hsNavFocusColorInsideTopLeftRing : HsNavCommon.h
  • hsNavFocusColorMiddleRing : HsNavCommon.h
  • hsNavFocusColorOutsideRing : HsNavCommon.h
  • hsNavFocusColorRing1 : HsNavCommon.h
  • hsNavFocusColorRing2 : HsNavCommon.h
  • hsNavFocusColorRing3 : HsNavCommon.h
  • hsNavFocusColorRing4 : HsNavCommon.h
  • hsNavFocusColorRing5 : HsNavCommon.h
  • hsNavFocusColorRing6 : HsNavCommon.h
  • hsNavFocusColorSecondaryHighlight : HsNavCommon.h
  • hsNavFocusRingStyleHorizontalBars : HsNavCommon.h
  • hsNavFocusRingStyleInvalid : HsNavCommon.h
  • hsNavFocusRingStyleObjectTypeDefault : HsNavCommon.h
  • hsNavFocusRingStyleRound : HsNavCommon.h
  • hsNavFocusRingStyleSquare : HsNavCommon.h
  • hsPrefBlinkGreenLEDInCoverage : HsExtCommon.h
  • hsPrefHard11CharAppCreator : HsExtCommon.h
  • hsPrefJogScanCharAppCreator : HsExtCommon.h
  • hsPrefKeyguardAutoEnableAutoOffExtraTime : HsExtCommon.h
  • hsPrefKeyguardAutoEnableTime : HsExtCommon.h
  • hsPrefKeyguardFlags : HsExtCommon.h
  • hsPrefLast : HsExtCommon.h
  • hsPrefLCDRefreshRate : HsExtCommon.h
  • hsPrefLidClosedAutoOffSeconds : HsExtCommon.h
  • hsPrefLidStatusChgCharAppCreator : HsExtCommon.h
  • hsPrefNetworkTimeSelected : HsExtCommon.h
  • hsPrefNetworkTZSelected : HsExtCommon.h
  • hsPrefOptHard11CharAppCreator : HsExtCommon.h
  • hsPrefOptHard1CharAppCreator : HsExtCommon.h
  • hsPrefOptHard2CharAppCreator : HsExtCommon.h
  • hsPrefOptHard3CharAppCreator : HsExtCommon.h
  • hsPrefOptHard4CharAppCreator : HsExtCommon.h
  • hsPrefOptHardPowerCharAppCreator : HsExtCommon.h
  • hsPrefOptReservedCharAppCreator : HsExtCommon.h
  • hsPrefPowerOnAppCreator : HsExtCommon.h
  • hsPrefPowerSaveMode : HsExtCommon.h
  • hsPrefSerialLibConsole : HsExtCommon.h
  • hsPrefSerialLibDef : HsExtCommon.h
  • hsPrefSerialLibHotSyncLocal : HsExtCommon.h
  • hsPrefSerialLibHotSyncModem : HsExtCommon.h
  • hsPrefSerialLibIrda : HsExtCommon.h
  • hsPrefShortSideHardCharAppCreator : HsExtCommon.h
  • hsPrefSideHardCharAppCreator : HsExtCommon.h
  • hsPrefTempShiftTimeOut : HsExtCommon.h
  • hsPrefTouchscreenDisableFlags : HsExtCommon.h
  • hsPrefUserNotLookingTime : HsExtCommon.h
  • hsSndBatFull : HsSoundLibCommon.h
  • hsSndBatLow : HsSoundLibCommon.h
  • hsSndBatShutdown : HsSoundLibCommon.h
  • hsSndCardInsert : HsSoundLibCommon.h
  • hsSndCardRemove : HsSoundLibCommon.h
  • hsSndChargerAttach : HsSoundLibCommon.h
  • hsSndChargerDetach : HsSoundLibCommon.h
  • hsSndCmdPlay : HsSoundLibCommon.h
  • hsSndCmdStop : HsSoundLibCommon.h
  • hsSndDeepSleep : HsSoundLibCommon.h
  • hsSndDeepWake : HsSoundLibCommon.h
  • hsSndFormatAmr : HsSoundLibCommon.h
  • hsSndFormatMidi : HsSoundLibCommon.h
  • hsSndRadioInServiceArea : HsSoundLibCommon.h
  • hsSndRadioOff : HsSoundLibCommon.h
  • hsSndRadioOn : HsSoundLibCommon.h
  • hsSndRadioOutServiceArea : HsSoundLibCommon.h
  • hsSndSyncStart : HsSoundLibCommon.h
  • hsSndSyncStop : HsSoundLibCommon.h
  • hsStatusGadgetBattery : HsExtCommon.h
  • hsStatusGadgetSignal : HsExtCommon.h
  • hsVerStrCarrierID : HsExtCommon.h
  • hsVerStrComplete : HsExtCommon.h
  • hsVerStrFirmwareVer : HsExtCommon.h
  • hsVerStrHardware : HsExtCommon.h
  • hsVerStrLifeTime : HsExtCommon.h
  • hsVerStrPalmOSVer : HsExtCommon.h
  • hsVerStrProductName : HsExtCommon.h
  • hsVerStrProductRev : HsExtCommon.h
  • hsVerStrROMBuild : HsExtCommon.h
  • hsVerStrSerialNo : HsExtCommon.h
  • httpAuthPathAncestor : HS_HTTPLibConst.h
  • httpAuthPathCousin : HS_HTTPLibConst.h
  • httpAuthPathDescendant : HS_HTTPLibConst.h
  • httpAuthPathSame : HS_HTTPLibConst.h
  • httpAuthTargetPage : HS_HTTPLibConst.h
  • httpAuthTargetProxy : HS_HTTPLibConst.h
  • httpAuthTargetTargets : HS_HTTPLibConst.h
  • httpAuthTypeBasic : HS_HTTPLibConst.h
  • httpAuthTypeDigest : HS_HTTPLibConst.h
  • httpAuthTypeNone : HS_HTTPLibConst.h
  • httpAuthTypeTypes : HS_HTTPLibConst.h
  • httpCetListTypeBrowser : HS_HTTPLibConst.h
  • httpCetListTypeClient : HS_HTTPLibConst.h
  • httpCetListTypeServer : HS_HTTPLibConst.h
  • httpCetListTypeTypes : HS_HTTPLibConst.h
  • httpCetListTypeUnknown : HS_HTTPLibConst.h
  • httpCookieAlwaysSet : HS_HTTPLibConst.h
  • httpCookieClearAll : HS_HTTPLibConst.h
  • httpCookieClearAtFinalize : HS_HTTPLibConst.h
  • httpCookieClearSessionCookiesOnly : HS_HTTPLibConst.h
  • httpCookieNeverSet : HS_HTTPLibConst.h
  • httpCookieNotifyBeforeSet : HS_HTTPLibConst.h
  • httpDNSModeIPV4Only : HS_HTTPLibConst.h
  • httpErrorAuthFormat : HS_HTTPLibConst.h
  • httpErrorAuthNoHeader : HS_HTTPLibConst.h
  • httpErrorAuthUnknown : HS_HTTPLibConst.h
  • httpErrorCacheExpire : HS_HTTPLibConst.h
  • httpErrorCacheNone : HS_HTTPLibConst.h
  • httpErrorDNSInval : HS_HTTPLibConst.h
  • httpErrorDNSNoServer : HS_HTTPLibConst.h
  • httpErrorDNSNotFound : HS_HTTPLibConst.h
  • httpErrorDNSTimedout : HS_HTTPLibConst.h
  • httpErrorGeneric : HS_HTTPLibConst.h
  • httpErrorInval : HS_HTTPLibConst.h
  • httpErrorIOSleep : HS_HTTPLibConst.h
  • httpErrorNoMem : HS_HTTPLibConst.h
  • httpErrorOK : HS_HTTPLibConst.h
  • httpErrorRedirectCanceled : HS_HTTPLibConst.h
  • httpErrorRedirectFormat : HS_HTTPLibConst.h
  • httpErrorReqBodySizeOver : HS_HTTPLibConst.h
  • httpErrorReqHeaderSizeOver : HS_HTTPLibConst.h
  • httpErrorReqTimedout : HS_HTTPLibConst.h
  • httpErrorReqTooManyContinue : HS_HTTPLibConst.h
  • httpErrorRspHeaderSizeOver : HS_HTTPLibConst.h
  • httpErrorRspTimedout : HS_HTTPLibConst.h
  • httpErrorSSLConnect : HS_HTTPLibConst.h
  • httpErrorSSLHandShake : HS_HTTPLibConst.h
  • httpErrorSSLRead : HS_HTTPLibConst.h
  • httpErrorSSLWrite : HS_HTTPLibConst.h
  • httpErrorTCPConnect : HS_HTTPLibConst.h
  • httpErrorTCPOpen : HS_HTTPLibConst.h
  • httpErrorTCPRead : HS_HTTPLibConst.h
  • httpErrorTCPWrite : HS_HTTPLibConst.h
  • httpErrorTLSIntolerant : HS_HTTPLibConst.h
  • httpErrorWouldBlock : HS_HTTPLibConst.h
  • httpHeaderIDAccept : HS_HTTPLibConst.h
  • httpHeaderIDAcceptCharset : HS_HTTPLibConst.h
  • httpHeaderIDAcceptEncoding : HS_HTTPLibConst.h
  • httpHeaderIDAcceptLanguage : HS_HTTPLibConst.h
  • httpHeaderIDAcceptRanges : HS_HTTPLibConst.h
  • httpHeaderIDAge : HS_HTTPLibConst.h
  • httpHeaderIDAllow : HS_HTTPLibConst.h
  • httpHeaderIDAuthenticationInfo : HS_HTTPLibConst.h
  • httpHeaderIDAuthorization : HS_HTTPLibConst.h
  • httpHeaderIDCacheControl : HS_HTTPLibConst.h
  • httpHeaderIDConnection : HS_HTTPLibConst.h
  • httpHeaderIDContentDisposition : HS_HTTPLibConst.h
  • httpHeaderIDContentEncoding : HS_HTTPLibConst.h
  • httpHeaderIDContentLanguage : HS_HTTPLibConst.h
  • httpHeaderIDContentLength : HS_HTTPLibConst.h
  • httpHeaderIDContentLocation : HS_HTTPLibConst.h
  • httpHeaderIDContentMD5 : HS_HTTPLibConst.h
  • httpHeaderIDContentRange : HS_HTTPLibConst.h
  • httpHeaderIDContentType : HS_HTTPLibConst.h
  • httpHeaderIDCookie : HS_HTTPLibConst.h
  • httpHeaderIDDate : HS_HTTPLibConst.h
  • httpHeaderIDENUMS : HS_HTTPLibConst.h
  • httpHeaderIDETag : HS_HTTPLibConst.h
  • httpHeaderIDExpect : HS_HTTPLibConst.h
  • httpHeaderIDExpires : HS_HTTPLibConst.h
  • httpHeaderIDFrom : HS_HTTPLibConst.h
  • httpHeaderIDHost : HS_HTTPLibConst.h
  • httpHeaderIDIfMatch : HS_HTTPLibConst.h
  • httpHeaderIDIfModifiedSince : HS_HTTPLibConst.h
  • httpHeaderIDIfNoneMatch : HS_HTTPLibConst.h
  • httpHeaderIDIfRange : HS_HTTPLibConst.h
  • httpHeaderIDIfUnmodifiedSince : HS_HTTPLibConst.h
  • httpHeaderIDKeepAlive : HS_HTTPLibConst.h
  • httpHeaderIDLastModified : HS_HTTPLibConst.h
  • httpHeaderIDLocation : HS_HTTPLibConst.h
  • httpHeaderIDMaxForwards : HS_HTTPLibConst.h
  • httpHeaderIDPragma : HS_HTTPLibConst.h
  • httpHeaderIDProxyAuthenticate : HS_HTTPLibConst.h
  • httpHeaderIDProxyAuthenticationInfo : HS_HTTPLibConst.h
  • httpHeaderIDProxyAuthorization : HS_HTTPLibConst.h
  • httpHeaderIDProxyConnection : HS_HTTPLibConst.h
  • httpHeaderIDRange : HS_HTTPLibConst.h
  • httpHeaderIDReferer : HS_HTTPLibConst.h
  • httpHeaderIDRefresh : HS_HTTPLibConst.h
  • httpHeaderIDRetryAfter : HS_HTTPLibConst.h
  • httpHeaderIDServer : HS_HTTPLibConst.h
  • httpHeaderIDSetCookie : HS_HTTPLibConst.h
  • httpHeaderIDTE : HS_HTTPLibConst.h
  • httpHeaderIDTrailer : HS_HTTPLibConst.h
  • httpHeaderIDTransferEncoding : HS_HTTPLibConst.h
  • httpHeaderIDUpgrade : HS_HTTPLibConst.h
  • httpHeaderIDUserAgent : HS_HTTPLibConst.h
  • httpHeaderIDVary : HS_HTTPLibConst.h
  • httpHeaderIDVia : HS_HTTPLibConst.h
  • httpHeaderIDWarning : HS_HTTPLibConst.h
  • httpHeaderIDWWWAuthenticate : HS_HTTPLibConst.h
  • httpHeaderTypeEntity : HS_HTTPLibConst.h
  • httpHeaderTypeGeneral : HS_HTTPLibConst.h
  • httpHeaderTypeOther : HS_HTTPLibConst.h
  • httpHeaderTypeRequest : HS_HTTPLibConst.h
  • httpHeaderTypeResponse : HS_HTTPLibConst.h
  • httpHeaderTypeTypes : HS_HTTPLibConst.h
  • httpMethodCONNECT : HS_HTTPLibConst.h
  • httpMethodDELETE : HS_HTTPLibConst.h
  • httpMethodGET : HS_HTTPLibConst.h
  • httpMethodHEAD : HS_HTTPLibConst.h
  • httpMethodMethods : HS_HTTPLibConst.h
  • httpMethodOPTIONS : HS_HTTPLibConst.h
  • httpMethodPOST : HS_HTTPLibConst.h
  • httpMethodPUT : HS_HTTPLibConst.h
  • httpMethodTRACE : HS_HTTPLibConst.h
  • httpSchemeHTTP : HS_HTTPLibConst.h
  • httpSchemeHTTPS : HS_HTTPLibConst.h
  • httpSchemeSchemes : HS_HTTPLibConst.h
  • httpStatusCodeAccepted : HS_HTTPLibConst.h
  • httpStatusCodeBadGateway : HS_HTTPLibConst.h
  • httpStatusCodeBadRequest : HS_HTTPLibConst.h
  • httpStatusCodeConflict : HS_HTTPLibConst.h
  • httpStatusCodeContinue : HS_HTTPLibConst.h
  • httpStatusCodeCreated : HS_HTTPLibConst.h
  • httpStatusCodeExpectationFailed : HS_HTTPLibConst.h
  • httpStatusCodeForbidden : HS_HTTPLibConst.h
  • httpStatusCodeFound : HS_HTTPLibConst.h
  • httpStatusCodeGatewayTimeout : HS_HTTPLibConst.h
  • httpStatusCodeGone : HS_HTTPLibConst.h
  • httpStatusCodeHTTPVersionNotSupported : HS_HTTPLibConst.h
  • httpStatusCodeInternalServerError : HS_HTTPLibConst.h
  • httpStatusCodeLengthRequired : HS_HTTPLibConst.h
  • httpStatusCodeMethodNotAllowed : HS_HTTPLibConst.h
  • httpStatusCodeMovedPermanently : HS_HTTPLibConst.h
  • httpStatusCodeMultipleChoices : HS_HTTPLibConst.h
  • httpStatusCodeNoContent : HS_HTTPLibConst.h
  • httpStatusCodeNonAuthoritativeInformation : HS_HTTPLibConst.h
  • httpStatusCodeNotAcceptable : HS_HTTPLibConst.h
  • httpStatusCodeNotFound : HS_HTTPLibConst.h
  • httpStatusCodeNotImplemented : HS_HTTPLibConst.h
  • httpStatusCodeNotModified : HS_HTTPLibConst.h
  • httpStatusCodeOK : HS_HTTPLibConst.h
  • httpStatusCodePartialContent : HS_HTTPLibConst.h
  • httpStatusCodePaymentRequired : HS_HTTPLibConst.h
  • httpStatusCodePreconditionFailed : HS_HTTPLibConst.h
  • httpStatusCodeProxyAuthenticationRequired : HS_HTTPLibConst.h
  • httpStatusCodeRequestedRangeNotSatisfiable : HS_HTTPLibConst.h
  • httpStatusCodeRequestEntityTooLarge : HS_HTTPLibConst.h
  • httpStatusCodeRequestTimeout : HS_HTTPLibConst.h
  • httpStatusCodeRequestURITooLarge : HS_HTTPLibConst.h
  • httpStatusCodeResetContent : HS_HTTPLibConst.h
  • httpStatusCodeSeeOther : HS_HTTPLibConst.h
  • httpStatusCodeServiceUnavailable : HS_HTTPLibConst.h
  • httpStatusCodeSwitchingProtocols : HS_HTTPLibConst.h
  • httpStatusCodeTemporaryRedirect : HS_HTTPLibConst.h
  • httpStatusCodeUnauthorized : HS_HTTPLibConst.h
  • httpStatusCodeUnsupportedMediaType : HS_HTTPLibConst.h
  • httpStatusCodeUseProxy : HS_HTTPLibConst.h
  • httpStreamStateDelete : HS_HTTPLibConst.h
  • httpStreamStateDormant : HS_HTTPLibConst.h
  • httpStreamStateNew : HS_HTTPLibConst.h
  • httpStreamStateObsolete : HS_HTTPLibConst.h
  • httpStreamStateReqConnect : HS_HTTPLibConst.h
  • httpStreamStateReqConnecting : HS_HTTPLibConst.h
  • httpStreamStateReqCreated : HS_HTTPLibConst.h
  • httpStreamStateReqOpen : HS_HTTPLibConst.h
  • httpStreamStateReqProxyConnect : HS_HTTPLibConst.h
  • httpStreamStateReqProxyConnecting : HS_HTTPLibConst.h
  • httpStreamStateReqResolve : HS_HTTPLibConst.h
  • httpStreamStateReqResolving : HS_HTTPLibConst.h
  • httpStreamStateReqSending : HS_HTTPLibConst.h
  • httpStreamStateReqSent : HS_HTTPLibConst.h
  • httpStreamStateReqSSLHandShaked : HS_HTTPLibConst.h
  • httpStreamStateReqSSLHandShaking : HS_HTTPLibConst.h
  • httpStreamStateRspContinue : HS_HTTPLibConst.h
  • httpStreamStateRspEntityReceived : HS_HTTPLibConst.h
  • httpStreamStateRspEntityReceiving : HS_HTTPLibConst.h
  • httpStreamStateRspHeaderReceived : HS_HTTPLibConst.h
  • httpStreamStateRspHeaderReceiving : HS_HTTPLibConst.h
  • httpStreamStateRspHeaderWaiting : HS_HTTPLibConst.h
  • httpStreamStateStates : HS_HTTPLibConst.h
  • httpUASelectTypeHost : HS_HTTPLib68K.h
  • httpUASelectTypePath : HS_HTTPLib68K.h
  • httpVersion_0_9 : HS_HTTPLibConst.h
  • httpVersion_1_0 : HS_HTTPLibConst.h
  • httpVersion_1_1 : HS_HTTPLibConst.h
  • httpVersionVersions : HS_HTTPLibConst.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:38 2008 for Palm API Guide


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • v

- i -

  • immediateLockMode : HsPhoneTypes.h
  • indicationAuthFailure : HsPhoneEvent.h
  • indicationInitComplete : HsPhoneEvent.h
  • indicationNetworkAvailable : HsPhoneEvent.h
  • indicationNetworkSearch : HsPhoneEvent.h
  • indicationOtaspMsg : HsPhoneEvent.h
  • indicationPasswordAccepted : HsPhoneEvent.h
  • indicationPoweringOffRadio : HsPhoneEvent.h
  • indicationResettingRadio : HsPhoneEvent.h
  • indicationSIMChanged : HsPhoneEvent.h
  • indicationSIMMessages : HsPhoneEvent.h
  • indicationSIMReady : HsPhoneEvent.h
  • indicationStartingRadio : HsPhoneEvent.h
  • IPAllocType_APIPA : PalmWiFiCommon.h
  • IPAllocType_DHCP : PalmWiFiCommon.h
  • IPAllocType_STATIC : PalmWiFiCommon.h
  • italic : VMFontLibCommon.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:38 2008 for Palm API Guide


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • v

- p -

  • P1clAdd : DatebookLibCommon.h
  • P1clalarmAdvance : DatebookLibCommon.h
  • P1clalarmUnit : DatebookLibCommon.h
  • P1clApptStatus : DatebookLibCommon.h
  • P1clAttendeeEmail : DatebookLibCommon.h
  • P1clAttendeeName : DatebookLibCommon.h
  • P1clAttendeeRole : DatebookLibCommon.h
  • P1clBlobSizeType : DatebookLibCommon.h
  • P1clBusy : DatebookLibCommon.h
  • P1clCategory : DatebookLibCommon.h
  • P1clColor : DatebookLibCommon.h
  • P1clCreatorIDType : DatebookLibCommon.h
  • P1clDataBlobType : DatebookLibCommon.h
  • P1clDateOfAppt : DatebookLibCommon.h
  • P1clDays : DatebookLibCommon.h
  • P1clDelete : DatebookLibCommon.h
  • P1clDeleteAll : DatebookLibCommon.h
  • P1clDeleteCurrent : DatebookLibCommon.h
  • P1clDeleteCurrentFuture : DatebookLibCommon.h
  • P1clDeleteEntry : DatebookLibCommon.h
  • P1clDescription : DatebookLibCommon.h
  • P1clDeviceTimeZone : DatebookLibCommon.h
  • P1clDirty : DatebookLibCommon.h
  • P1clEndTime : DatebookLibCommon.h
  • P1clEventTimeZone : DatebookLibCommon.h
  • P1clExceptionDate : DatebookLibCommon.h
  • P1clHours : DatebookLibCommon.h
  • P1clIndex : DatebookLibCommon.h
  • P1clListContinuesOnNextDay : DatebookLibCommon.h
  • P1clListEndSec : DatebookLibCommon.h
  • P1clListEndTime : DatebookLibCommon.h
  • P1clListIndex : DatebookLibCommon.h
  • P1clListIsFirstOccurrence : DatebookLibCommon.h
  • P1clListIsLastOccurrence : DatebookLibCommon.h
  • P1clListRepeatsDaily : DatebookLibCommon.h
  • P1clListStartedDayBefore : DatebookLibCommon.h
  • P1clListStartSec : DatebookLibCommon.h
  • P1clListStartTime : DatebookLibCommon.h
  • P1clListUId : DatebookLibCommon.h
  • P1clLocation : DatebookLibCommon.h
  • P1clMaxCategoryLength : DatebookLibCommon.h
  • P1clMinutes : DatebookLibCommon.h
  • P1clModifyEntry : DatebookLibCommon.h
  • P1clNewEntry : DatebookLibCommon.h
  • P1clNote : DatebookLibCommon.h
  • P1clNoType : DatebookLibCommon.h
  • P1clNumFields : DatebookLibCommon.h
  • P1clNumOfAttendee : DatebookLibCommon.h
  • P1cloptionalAttendee : DatebookLibCommon.h
  • P1cloriginator : DatebookLibCommon.h
  • P1clPrivate : DatebookLibCommon.h
  • P1clRemoveAll : DatebookLibCommon.h
  • P1clrepeatDaily : DatebookLibCommon.h
  • P1clrepeatEndDate : DatebookLibCommon.h
  • P1clrepeatFreq : DatebookLibCommon.h
  • P1clrepeatMonthlyByDate : DatebookLibCommon.h
  • P1clrepeatMonthlyByDay : DatebookLibCommon.h
  • P1clrepeatNone : DatebookLibCommon.h
  • P1clrepeatOn : DatebookLibCommon.h
  • P1clrepeatStartofWeek : DatebookLibCommon.h
  • P1clrepeatType : DatebookLibCommon.h
  • P1clrepeatWeekly : DatebookLibCommon.h
  • P1clrepeatYearly : DatebookLibCommon.h
  • P1clrequiredAttendee : DatebookLibCommon.h
  • P1clShowAsBusy : DatebookLibCommon.h
  • P1clShowAsFree : DatebookLibCommon.h
  • P1clShowAsOutOfOffice : DatebookLibCommon.h
  • P1clShowAsTentative : DatebookLibCommon.h
  • P1clStartDateTimeOfAppt : DatebookLibCommon.h
  • P1clStartTime : DatebookLibCommon.h
  • P1clTzCountry : DatebookLibCommon.h
  • P1clTzcustom : DatebookLibCommon.h
  • P1clTzdSTAdjustmentInMinutes : DatebookLibCommon.h
  • P1clTzdSTEnd : DatebookLibCommon.h
  • P1clTzdSTStart : DatebookLibCommon.h
  • P1clTzLocName : DatebookLibCommon.h
  • P1clTzuTC : DatebookLibCommon.h
  • P1clUID : DatebookLibCommon.h
  • P1clUpdate : DatebookLibCommon.h
  • palm : VMFontLibCommon.h
  • palmCodecAAC_ADIF : palmOneCodecFormat.h
  • palmCodecAAC_ADTS : palmOneCodecFormat.h
  • palmCodecAAC_LATM : palmOneCodecFormat.h
  • palmCodecAAC_MP4A : palmOneCodecFormat.h
  • palmCodecAAC_RAW : palmOneCodecFormat.h
  • palmCodecAACLowComplexity : palmOneCodecFormat.h
  • palmCodecAACMainProfile : palmOneCodecFormat.h
  • palmCodecAACScaleableSamplingRate : palmOneCodecFormat.h
  • palmCodecAMR102 : palmOneCodecFormat.h
  • palmCodecAMR122 : palmOneCodecFormat.h
  • palmCodecAMR475 : palmOneCodecFormat.h
  • palmCodecAMR515 : palmOneCodecFormat.h
  • palmCodecAMR59 : palmOneCodecFormat.h
  • palmCodecAMR74 : palmOneCodecFormat.h
  • palmCodecAMR795 : palmOneCodecFormat.h
  • palmCodecAMRDtxDisable : palmOneCodecFormat.h
  • palmCodecAMRDtxEnable : palmOneCodecFormat.h
  • palmCodecAMRM67 : palmOneCodecFormat.h
  • palmCodecBIG_ENDIAN : palmOneCodecFormat.h
  • palmCodecBMP_None : palmOneCodecFormat.h
  • palmCodecBMP_RLE4 : palmOneCodecFormat.h
  • palmCodecBMP_RLE8 : palmOneCodecFormat.h
  • palmCodecCtlAACGetInfo : palmOneCodecFormat.h
  • palmCodecCtlAVCGetDecodedFrame : palmOneCodecFormat.h
  • palmCodecCtlAVCGetInfo : palmOneCodecFormat.h
  • palmCodecCtlAVCSetCropMode : palmOneCodecFormat.h
  • palmCodecCtlCustomBase : palmOneCodecFormat.h
  • palmCodecCtlGetAuthor : palmOneCodecFormat.h
  • palmCodecCtlGetComments : palmOneCodecFormat.h
  • palmCodecCtlGetDate : palmOneCodecFormat.h
  • palmCodecCtlGetKey : palmOneCodecFormat.h
  • palmCodecCtlGetVersion : palmOneCodecFormat.h
  • palmCodecCtlLastBuffer : palmOneCodecFormat.h
  • palmCodecCtlPutKey : palmOneCodecFormat.h
  • palmCodecCtlPutSeed : palmOneCodecFormat.h
  • palmCodecFloatBig : palmOneCodecFormat.h
  • palmCodecFloatLittle : palmOneCodecFormat.h
  • palmCodecImageARGB32 : palmOneCodecFormat.h
  • palmCodecImageBGR32 : palmOneCodecFormat.h
  • palmCodecImageBGR555 : palmOneCodecFormat.h
  • palmCodecImageBGR565 : palmOneCodecFormat.h
  • palmCodecImageBGR888 : palmOneCodecFormat.h
  • palmCodecImageBGRA32 : palmOneCodecFormat.h
  • palmCodecImageCMY : palmOneCodecFormat.h
  • palmCodecImageCMYK : palmOneCodecFormat.h
  • palmCodecImageGIFFrame : palmOneCodecFormat.h
  • palmCodecImageGRAY1 : palmOneCodecFormat.h
  • palmCodecImageGRAY2 : palmOneCodecFormat.h
  • palmCodecImageGRAY4 : palmOneCodecFormat.h
  • palmCodecImageGRAY8 : palmOneCodecFormat.h
  • palmCodecImageHCI : palmOneCodecFormat.h
  • palmCodecImageHSI : palmOneCodecFormat.h
  • palmCodecImageHSL : palmOneCodecFormat.h
  • palmCodecImageHSV : palmOneCodecFormat.h
  • palmCodecImageRGB32 : palmOneCodecFormat.h
  • palmCodecImageRGB555 : palmOneCodecFormat.h
  • palmCodecImageRGB565 : palmOneCodecFormat.h
  • palmCodecImageRGB888 : palmOneCodecFormat.h
  • palmCodecImageRGB888Planar : palmOneCodecFormat.h
  • palmCodecImageRGBA32 : palmOneCodecFormat.h
  • palmCodecImageRGBIndex : palmOneCodecFormat.h
  • palmCodecImageRGBIndex1 : palmOneCodecFormat.h
  • palmCodecImageRGBIndex16 : palmOneCodecFormat.h
  • palmCodecImageRGBIndex2 : palmOneCodecFormat.h
  • palmCodecImageRGBIndex4 : palmOneCodecFormat.h
  • palmCodecImageRGBIndex8 : palmOneCodecFormat.h
  • palmCodecImageYCbCr211 : palmOneCodecFormat.h
  • palmCodecImageYCbCr211Planar : palmOneCodecFormat.h
  • palmCodecImageYCbCr411 : palmOneCodecFormat.h
  • palmCodecImageYCbCr411Planar : palmOneCodecFormat.h
  • palmCodecImageYCbCr420 : palmOneCodecFormat.h
  • palmCodecImageYCbCr420Planar : palmOneCodecFormat.h
  • palmCodecImageYCbCr422 : palmOneCodecFormat.h
  • palmCodecImageYCbCr422Planar : palmOneCodecFormat.h
  • palmCodecImageYCbCr444 : palmOneCodecFormat.h
  • palmCodecImageYCbCr444Planar : palmOneCodecFormat.h
  • palmCodecImageYUV211 : palmOneCodecFormat.h
  • palmCodecImageYUV211Planar : palmOneCodecFormat.h
  • palmCodecImageYUV411 : palmOneCodecFormat.h
  • palmCodecImageYUV411Planar : palmOneCodecFormat.h
  • palmCodecImageYUV420 : palmOneCodecFormat.h
  • palmCodecImageYUV420Planar : palmOneCodecFormat.h
  • palmCodecImageYUV422 : palmOneCodecFormat.h
  • palmCodecImageYUV422Planar : palmOneCodecFormat.h
  • palmCodecImageYUV444 : palmOneCodecFormat.h
  • palmCodecImageYUV444Planar : palmOneCodecFormat.h
  • palmCodecINT16Big : palmOneCodecFormat.h
  • palmCodecINT16Little : palmOneCodecFormat.h
  • palmCodecINT24 : palmOneCodecFormat.h
  • palmCodecINT32Big : palmOneCodecFormat.h
  • palmCodecINT32Little : palmOneCodecFormat.h
  • palmCodecINT8 : palmOneCodecFormat.h
  • palmCodecLITTLE_ENDIAN : palmOneCodecFormat.h
  • palmCodecMONO : palmOneCodecFormat.h
  • palmCodecMPEG4MVFAST : palmOneCodecFormat.h
  • palmCodecMPEG4SEA : palmOneCodecFormat.h
  • palmCodecQCELPEighth : palmOneCodecFormat.h
  • palmCodecQCELPFull : palmOneCodecFormat.h
  • palmCodecQCELPHalf : palmOneCodecFormat.h
  • palmCodecQCELPQuarter : palmOneCodecFormat.h
  • palmCodecQCELPReducedDisabled : palmOneCodecFormat.h
  • palmCodecQCELPReducedEnabled : palmOneCodecFormat.h
  • palmCodecQCELPSilent : palmOneCodecFormat.h
  • palmCodecSTEREO : palmOneCodecFormat.h
  • palmCodecStreamFile : palmOneCodecFormat.h
  • palmCodecUINT16Big : palmOneCodecFormat.h
  • palmCodecUINT16Little : palmOneCodecFormat.h
  • palmCodecUINT24 : palmOneCodecFormat.h
  • palmCodecUINT32Big : palmOneCodecFormat.h
  • palmCodecUINT32Little : palmOneCodecFormat.h
  • palmCodecUINT8 : palmOneCodecFormat.h
  • palmCodecVFSFile : palmOneCodecFormat.h
  • palmOneStatusBarAttrBarVisible : palmOneStatusBar.h
  • palmOneStatusBarAttrDimension : palmOneStatusBar.h
  • palmOneStatusBarAttrExists : palmOneStatusBar.h
  • phnAddrFldFirstName : HsPhoneTypes.h
  • phnAddrFldLastName : HsPhoneTypes.h
  • phnAddrFldPhone : HsPhoneTypes.h
  • phnAudioLocalMode : HsPhoneAudioTypes.h
  • phnAudioNetworkMode : HsPhoneAudioTypes.h
  • phnAudioSilentMode : HsPhoneAudioTypes.h
  • phnAutoMode : HsPhoneMiscTypes.h
  • phnBarAll : HsPhoneNetworkTypes.h
  • phnBarInAll : HsPhoneNetworkTypes.h
  • phnBarInNone : HsPhoneNetworkTypes.h
  • phnBarInWhenRoaming : HsPhoneNetworkTypes.h
  • phnBarOutAll : HsPhoneNetworkTypes.h
  • phnBarOutInternational : HsPhoneNetworkTypes.h
  • phnBarOutInternationalExceptHome : HsPhoneNetworkTypes.h
  • phnBarOutNone : HsPhoneNetworkTypes.h
  • phnBluetoothHandsfreeMode : HsPhoneMiscTypes.h
  • phnBluetoothHeadsetMode : HsPhoneMiscTypes.h
  • phnButtonAnswerCall : HsPhoneEvent.h
  • phnButtonConferenceCall : HsPhoneEvent.h
  • phnButtonHeadset : HsPhoneEvent.h
  • phnButtonHoldCall : HsPhoneEvent.h
  • phnButtonIgnoreCall : HsPhoneEvent.h
  • phnButtonLast : HsPhoneEvent.h
  • phnButtonRedial : HsPhoneEvent.h
  • phnButtonRejectCall : HsPhoneEvent.h
  • phnCarKitMode : HsPhoneMiscTypes.h
  • phnCDMAFirmwareAlltel : HsPhoneCDMATypes.h
  • phnCDMAFirmwareBellMobility : HsPhoneCDMATypes.h
  • phnCDMAFirmwareCrowdy : HsPhoneCDMATypes.h
  • phnCDMAFirmwareEarthlink : HsPhoneCDMATypes.h
  • phnCDMAFirmwareSprint : HsPhoneCDMATypes.h
  • phnCDMAFirmwareVerizon : HsPhoneCDMATypes.h
  • phnCDMAVoicemailDigits : HsPhoneCDMATypes.h
  • phnCDMAVoicemailMDN : HsPhoneCDMATypes.h
  • phnCDMAVoicemailMDN1 : HsPhoneCDMATypes.h
  • phnConnectionActive : HsPhoneCallControlTypes.h
  • phnConnectionAlerting : HsPhoneCallControlTypes.h
  • phnConnectionDialing : HsPhoneCallControlTypes.h
  • phnConnectionDormant : HsPhoneCallControlTypes.h
  • phnConnectionHeld : HsPhoneCallControlTypes.h
  • phnConnectionIncoming : HsPhoneCallControlTypes.h
  • phnConnectionUnknown : HsPhoneCallControlTypes.h
  • phnConnectionWaiting : HsPhoneCallControlTypes.h
  • phnDataAvailable : HsPhoneEvent.h
  • phnDataNotAvailable : HsPhoneEvent.h
  • phnDataService1xEVDO : HsPhoneNetworkTypes.h
  • phnDataService1xRTT : HsPhoneNetworkTypes.h
  • phnDataServiceCSD : HsPhoneNetworkTypes.h
  • phnDataServiceEdge : HsPhoneNetworkTypes.h
  • phnDataServiceGPRS : HsPhoneNetworkTypes.h
  • phnDataServiceLast : HsPhoneNetworkTypes.h
  • phnDataServiceNone : HsPhoneNetworkTypes.h
  • phnEquipmentModeLast : HsPhoneMiscTypes.h
  • phnErrACMLimitExceeded : HsPhoneErrors.h
  • phnErrAlphabetNotSupported : HsPhoneErrors.h
  • phnErrAuthenticationFailure : HsPhoneErrors.h
  • phnErrBadATCmd : HsPhoneErrors.h
  • phnErrBadATResult : HsPhoneErrors.h
  • phnErrBadCRC : HsPhoneErrors.h
  • phnErrBadServiceCode : HsPhoneErrors.h
  • phnErrBatteryCharging : HsPhoneErrors.h
  • phnErrBatteryLowAlert : HsPhoneErrors.h
  • phnErrBufferTooSmall : HsPhoneErrors.h
  • phnErrCallBarred : HsPhoneErrors.h
  • phnErrCancelled : HsPhoneErrors.h
  • phnErrCannotReplaceMsg : HsPhoneErrors.h
  • phnErrCauseCode16 : HsPhoneErrors.h
  • phnErrCmdCannotBeActioned : HsPhoneErrors.h
  • phnErrCmdUnsupported : HsPhoneErrors.h
  • phnErrCommandInProgress : HsPhoneErrors.h
  • phnErrCongestion : HsPhoneErrors.h
  • phnErrCOPSAbort : HsPhoneErrors.h
  • phnErrCorpPINRequired : HsPhoneErrors.h
  • phnErrCorpPUKRequired : HsPhoneErrors.h
  • phnErrCPError : HsPhoneErrors.h
  • phnErrCSDAccessInfoDiscarded : HsPhoneErrors.h
  • phnErrCSDACMOutOfRange : HsPhoneErrors.h
  • phnErrCSDBearerNotAvailable : HsPhoneErrors.h
  • phnErrCSDBearerNotCapable : HsPhoneErrors.h
  • phnErrCSDBearerNotImplemented : HsPhoneErrors.h
  • phnErrCSDCallBarringIncoming : HsPhoneErrors.h
  • phnErrCSDCallBarringOutgoing : HsPhoneErrors.h
  • phnErrCSDCallImpossible : HsPhoneErrors.h
  • phnErrCSDCallOperationNotAllowed : HsPhoneErrors.h
  • phnErrCSDCallRejected : HsPhoneErrors.h
  • phnErrCSDChannelUnacceptable : HsPhoneErrors.h
  • phnErrCSDDestinationOutOfOrder : HsPhoneErrors.h
  • phnErrCSDFacilityNotImplemented : HsPhoneErrors.h
  • phnErrCSDFacilityNotSubscribed : HsPhoneErrors.h
  • phnErrCSDFacilityRejected : HsPhoneErrors.h
  • phnErrCSDFDNError : HsPhoneErrors.h
  • phnErrCSDIEError : HsPhoneErrors.h
  • phnErrCSDIncomingCallsBarredCUG : HsPhoneErrors.h
  • phnErrCSDIncompatibleDestination : HsPhoneErrors.h
  • phnErrCSDInfoNotImplemented : HsPhoneErrors.h
  • phnErrCSDInvalidMandatoryInfo : HsPhoneErrors.h
  • phnErrCSDInvalidNumberFormat : HsPhoneErrors.h
  • phnErrCSDInvalidTransID : HsPhoneErrors.h
  • phnErrCSDInvalidTransitNetwork : HsPhoneErrors.h
  • phnErrCSDLowerLayerFailure : HsPhoneErrors.h
  • phnErrCSDMessageNotCompatible : HsPhoneErrors.h
  • phnErrCSDMessageTypeNotCompatible : HsPhoneErrors.h
  • phnErrCSDMessageTypeNotImplemented : HsPhoneErrors.h
  • phnErrCSDNetworkOutOfOrder : HsPhoneErrors.h
  • phnErrCSDNoAnswer : HsPhoneErrors.h
  • phnErrCSDNoCircuitAvailable : HsPhoneErrors.h
  • phnErrCSDNoRouteToDestination : HsPhoneErrors.h
  • phnErrCSDNoUserResponse : HsPhoneErrors.h
  • phnErrCSDNumberBusy : HsPhoneErrors.h
  • phnErrCSDNumberChanged : HsPhoneErrors.h
  • phnErrCSDOperatorBarring : HsPhoneErrors.h
  • phnErrCSDProtocolError : HsPhoneErrors.h
  • phnErrCSDQOSNotAvailable : HsPhoneErrors.h
  • phnErrCSDRecoveryOnTimerExpiry : HsPhoneErrors.h
  • phnErrCSDReqCircuitNotAvailable : HsPhoneErrors.h
  • phnErrCSDResourceNotAvailable : HsPhoneErrors.h
  • phnErrCSDRestrictedBearer : HsPhoneErrors.h
  • phnErrCSDSemanticallyIncorrectMessage : HsPhoneErrors.h
  • phnErrCSDServiceNotAvailble : HsPhoneErrors.h
  • phnErrCSDServiceNotImplented : HsPhoneErrors.h
  • phnErrCSDSwitchingCongestion : HsPhoneErrors.h
  • phnErrCSDTempFailure : HsPhoneErrors.h
  • phnErrCSDUnassignedNumber : HsPhoneErrors.h
  • phnErrCSDUserNotMemberCUG : HsPhoneErrors.h
  • phnErrDenied : HsPhoneErrors.h
  • phnErrDestOutOfService : HsPhoneErrors.h
  • phnErrDestSMEBarred : HsPhoneErrors.h
  • phnErrDialStringTooLong : HsPhoneErrors.h
  • phnErrDuplicatePage : HsPhoneErrors.h
  • phnErrDuplicatePlaceHoldler : HsPhoneErrors.h
  • phnErrEmergencyCallsOnly : HsPhoneErrors.h
  • phnErrErrorInMS : HsPhoneErrors.h
  • phnErrFacRejected : HsPhoneErrors.h
  • phnErrFDNMismatch : HsPhoneErrors.h
  • phnErrFiller : HsPhoneErrors.h
  • phnErrFiller2 : HsPhoneErrors.h
  • phnErrFiller3 : HsPhoneErrors.h
  • phnErrFiller4 : HsPhoneErrors.h
  • phnErrFiller5 : HsPhoneErrors.h
  • phnErrFiller6 : HsPhoneErrors.h
  • phnErrFirmwareBootInprogress : HsPhoneErrors.h
  • phnErrFirmwareBootNotInprogress : HsPhoneErrors.h
  • phnErrGPRSAPNMissing : HsPhoneErrors.h
  • phnErrGPRSNetworkRequestDetach : HsPhoneErrors.h
  • phnErrGPRSNetworkRequestPDPDeactivate : HsPhoneErrors.h
  • phnErrGPRSNoAccess : HsPhoneErrors.h
  • phnErrGPRSNoService : HsPhoneErrors.h
  • phnErrGPRSNotAllowed : HsPhoneErrors.h
  • phnErrGPRSPDPActivateFailGMMError : HsPhoneErrors.h
  • phnErrGPRSPDPActivateFailNetReject : HsPhoneErrors.h
  • phnErrGPRSPDPActivateFailNoNSAPI : HsPhoneErrors.h
  • phnErrGPRSPDPActivateFailSMRefuse : HsPhoneErrors.h
  • phnErrGPRSPDPDactivateGMMAbort : HsPhoneErrors.h
  • phnErrGPRSPDPDactivateLCCLinkActivation : HsPhoneErrors.h
  • phnErrGPRSPDPDeactivateNwkRactivate : HsPhoneErrors.h
  • phnErrGPRSPDPDeactivateSNDCPFailure : HsPhoneErrors.h
  • phnErrGPRSRoamingNotAllowed : HsPhoneErrors.h
  • phnErrGPRSServiceRefused : HsPhoneErrors.h
  • phnErrHCIMismatch : HsPhoneErrors.h
  • phnErrHoldError : HsPhoneErrors.h
  • phnErrIllegalChars : HsPhoneErrors.h
  • phnErrIllegalCondition : HsPhoneErrors.h
  • phnErrIllegalFacility : HsPhoneErrors.h
  • phnErrIllegalIndex : HsPhoneErrors.h
  • phnErrIllegalME : HsPhoneErrors.h
  • phnErrIllegalMS : HsPhoneErrors.h
  • phnErrIllegalMsg : HsPhoneErrors.h
  • phnErrIllegalNumber : HsPhoneErrors.h
  • phnErrIllegalStatus : HsPhoneErrors.h
  • phnErrIllegalType : HsPhoneErrors.h
  • phnErrIncorrectPassword : HsPhoneErrors.h
  • phnErrInfoElemNonExistent : HsPhoneErrors.h
  • phnErrIntermediateResult : HsPhoneErrors.h
  • phnErrInterworking : HsPhoneErrors.h
  • phnErrInvalidDialChars : HsPhoneErrors.h
  • phnErrInvalidMandInfo : HsPhoneErrors.h
  • phnErrInvalidMemIndex : HsPhoneErrors.h
  • phnErrInvalidMobileClass : HsPhoneErrors.h
  • phnErrInvalidMsg : HsPhoneErrors.h
  • phnErrInvalidNAM : HsPhoneErrors.h
  • phnErrInvalidParameter : HsPhoneErrors.h
  • phnErrInvalidSMEAddr : HsPhoneErrors.h
  • phnErrInvalidSMSReference : HsPhoneErrors.h
  • phnErrInvalidTextChars : HsPhoneErrors.h
  • phnErrIOTACommitFailed : HsPhoneErrors.h
  • phnErrIOTACommitInProgress : HsPhoneErrors.h
  • phnErrIOTANoSession : HsPhoneErrors.h
  • phnErrIOTASessionActive : HsPhoneErrors.h
  • phnErrIS683ProtRevNotSupported : HsPhoneErrors.h
  • phnErrLAST_1 : HsPhoneErrors.h
  • phnErrLAST_2 : HsPhoneErrors.h
  • phnErrLidClosed : HsPhoneErrors.h
  • phnErrLocAreaNotAllowed : HsPhoneErrors.h
  • phnErrLowerLayer : HsPhoneErrors.h
  • phnErrMEFailure : HsPhoneErrors.h
  • phnErrMemFailure : HsPhoneErrors.h
  • phnErrMemory : HsPhoneErrors.h
  • phnErrMemoryFailure : HsPhoneErrors.h
  • phnErrMemoryFull : HsPhoneErrors.h
  • phnErrMissingCarKitDriver : HsPhoneErrors.h
  • phnErrMMFailed : HsPhoneErrors.h
  • phnErrModemBusy : HsPhoneErrors.h
  • phnErrModemOffline : HsPhoneErrors.h
  • phnErrMsgClassNotSupported : HsPhoneErrors.h
  • phnErrMsgNoCompatible : HsPhoneErrors.h
  • phnErrMsgTypeNonExistent : HsPhoneErrors.h
  • phnErrNAMMismatched : HsPhoneErrors.h
  • phnErrNeedResetModule : HsPhoneErrors.h
  • phnErrNetPINRequired : HsPhoneErrors.h
  • phnErrNetPUKRequired : HsPhoneErrors.h
  • phnErrNetSubPINRequired : HsPhoneErrors.h
  • phnErrNetSubPUKRequired : HsPhoneErrors.h
  • phnErrNetworkNotAllowed : HsPhoneErrors.h
  • phnErrNetworkOutOfOrder : HsPhoneErrors.h
  • phnErrNetworkTimeout : HsPhoneErrors.h
  • phnErrNoAppRegistered : HsPhoneErrors.h
  • phnErrNoCarrier : HsPhoneErrors.h
  • phnErrNoCNMAAckExpected : HsPhoneErrors.h
  • phnErrNoConnection : HsPhoneErrors.h
  • phnErrNoNetwork : HsPhoneErrors.h
  • phnErrNoNetworkService : HsPhoneErrors.h
  • phnErrNoPower : HsPhoneErrors.h
  • phnErrNoRecipient : HsPhoneErrors.h
  • phnErrNoResponse : HsPhoneErrors.h
  • phnErrNoSCSubscription : HsPhoneErrors.h
  • phnErrNoSIM : HsPhoneErrors.h
  • phnErrNoSMSStorage : HsPhoneErrors.h
  • phnErrNotAllowed : HsPhoneErrors.h
  • phnErrNotFound : HsPhoneErrors.h
  • phnErrNotOpen : HsPhoneErrors.h
  • phnErrNotSupported : HsPhoneErrors.h
  • phnErrNotYetSupported : HsPhoneErrors.h
  • phnErrNullParam : HsPhoneErrors.h
  • phnErrNumberBlacklisted : HsPhoneErrors.h
  • phnErrNvBadItem : HsPhoneErrors.h
  • phnErrNVUnInitialized : HsPhoneErrors.h
  • phnErrOperDeterminedBarring : HsPhoneErrors.h
  • phnErrOptionNotSupported : HsPhoneErrors.h
  • phnErrOptionTempOutOfOrder : HsPhoneErrors.h
  • phnErrorClass : HsPhoneErrors.h
  • phnErrorClass_2 : HsPhoneErrors.h
  • phnErrParam : HsPhoneErrors.h
  • phnErrPasswordRequired : HsPhoneErrors.h
  • phnErrPhFPINRequired : HsPhoneErrors.h
  • phnErrPhFPUKRequired : HsPhoneErrors.h
  • phnErrPhoneAdaptorLinkReserved : HsPhoneErrors.h
  • phnErrPhoneFailure : HsPhoneErrors.h
  • phnErrPhoneNotConnected : HsPhoneErrors.h
  • phnErrPhPINRequired : HsPhoneErrors.h
  • phnErrPIN2Required : HsPhoneErrors.h
  • phnErrPINRequired : HsPhoneErrors.h
  • phnErrPLMNNotAllowed : HsPhoneErrors.h
  • phnErrPoweringDown : HsPhoneErrors.h
  • phnErrProtocolError : HsPhoneErrors.h
  • phnErrPUK2Required : HsPhoneErrors.h
  • phnErrPUKRequired : HsPhoneErrors.h
  • phnErrRadioNotAvailable : HsPhoneErrors.h
  • phnErrReadNV : HsPhoneErrors.h
  • phnErrReqFacNotImplemented : HsPhoneErrors.h
  • phnErrReqFacNotSubscribed : HsPhoneErrors.h
  • phnErrReqOptionNotSubscribed : HsPhoneErrors.h
  • phnErrResourcesUnavailable : HsPhoneErrors.h
  • phnErrResponsePending : HsPhoneErrors.h
  • phnErrRoamingNotAllowed : HsPhoneErrors.h
  • phnErrSATInactive : HsPhoneErrors.h
  • phnErrSATNoInd : HsPhoneErrors.h
  • phnErrSATNotSupported : HsPhoneErrors.h
  • phnErrSATUnavailable : HsPhoneErrors.h
  • phnErrSaveNV : HsPhoneErrors.h
  • phnErrSCAddrUnknown : HsPhoneErrors.h
  • phnErrSCBusy : HsPhoneErrors.h
  • phnErrSCSystemFailure : HsPhoneErrors.h
  • phnErrSIMApplToolkitBusy : HsPhoneErrors.h
  • phnErrSIMBusy : HsPhoneErrors.h
  • phnErrSIMDataDownload : HsPhoneErrors.h
  • phnErrSIMFailure : HsPhoneErrors.h
  • phnErrSIMWrong : HsPhoneErrors.h
  • phnErrSMRejectedDuplicate : HsPhoneErrors.h
  • phnErrSMSFDNError : HsPhoneErrors.h
  • phnErrSMSMemoryFull : HsPhoneErrors.h
  • phnErrSMSMemoryOK : HsPhoneErrors.h
  • phnErrSMSServReserved : HsPhoneErrors.h
  • phnErrSMSStorageFull : HsPhoneErrors.h
  • phnErrSMSXferRejected : HsPhoneErrors.h
  • phnErrSMType0NotSupported : HsPhoneErrors.h
  • phnErrSndDelClass : HsPhoneErrors.h
  • phnErrSndDelInternalMdmError : HsPhoneErrors.h
  • phnErrSndDelInvalidRingerID : HsPhoneErrors.h
  • phnErrSndDelUndeletableRingerID : HsPhoneErrors.h
  • phnErrSndDelUnusedRingerID : HsPhoneErrors.h
  • phnErrSndSaveBadDataLen : HsPhoneErrors.h
  • phnErrSndSaveBadRingerID : HsPhoneErrors.h
  • phnErrSndSaveBadRsp : HsPhoneErrors.h
  • phnErrSndSaveBadSoundType : HsPhoneErrors.h
  • phnErrSndSaveClass : HsPhoneErrors.h
  • phnErrSndSaveContBadDataLen : HsPhoneErrors.h
  • phnErrSndSaveContClass : HsPhoneErrors.h
  • phnErrSndSaveContInternalModem : HsPhoneErrors.h
  • phnErrSndSaveContOutOfMem : HsPhoneErrors.h
  • phnErrSndSaveContSeqNum : HsPhoneErrors.h
  • phnErrSndSaveFileNameInvalid : HsPhoneErrors.h
  • phnErrSndSaveInternalModem : HsPhoneErrors.h
  • phnErrSndSaveOutOfMem : HsPhoneErrors.h
  • phnErrSPPINRequired : HsPhoneErrors.h
  • phnErrSPPUKRequired : HsPhoneErrors.h
  • phnErrStillOpen : HsPhoneErrors.h
  • phnErrStringTooLong : HsPhoneErrors.h
  • phnErrTelematicIWNotSupported : HsPhoneErrors.h
  • phnErrTemporaryFailure : HsPhoneErrors.h
  • phnErrTimeout : HsPhoneErrors.h
  • phnErrTPDUNotSupported : HsPhoneErrors.h
  • phnErrTPVPFNotSupported : HsPhoneErrors.h
  • phnErrTPVPNotSupported : HsPhoneErrors.h
  • phnErrUnassignedNumber : HsPhoneErrors.h
  • phnErrUnexpectedResponse : HsPhoneErrors.h
  • phnErrUnidentifedSubscriber : HsPhoneErrors.h
  • phnErrUnknownApp : HsPhoneErrors.h
  • phnErrUnknownError : HsPhoneErrors.h
  • phnErrUnknownID : HsPhoneErrors.h
  • phnErrUnknownNumber : HsPhoneErrors.h
  • phnErrUnknownSubscriber : HsPhoneErrors.h
  • phnErrUnspecifiedGPSRError : HsPhoneErrors.h
  • phnErrUnspecifiedTPCmdError : HsPhoneErrors.h
  • phnErrUnspecifiedTPDCSError : HsPhoneErrors.h
  • phnErrUnspecifiedTPPIDError : HsPhoneErrors.h
  • phnErrUNUSED : HsPhoneErrors.h
  • phnEvtAlerting : HsPhoneEvent.h
  • phnEvtAlertingPreConnected : HsPhoneEvent.h
  • phnEvtBusy : HsPhoneEvent.h
  • phnEvtCardInsertion : HsPhoneEvent.h
  • phnEvtConference : HsPhoneEvent.h
  • phnEvtConnectConf : HsPhoneEvent.h
  • phnEvtConnectInd : HsPhoneEvent.h
  • phnEvtDataChannel : HsPhoneEvent.h
  • phnEvtDataSessionDisconnected : HsPhoneEvent.h
  • phnEvtDataSessionStatus : HsPhoneEvent.h
  • phnEvtDebugReport : HsPhoneEvent.h
  • phnEvtDisconnectConf : HsPhoneEvent.h
  • phnEvtDisconnectInd : HsPhoneEvent.h
  • phnEvtError : HsPhoneEvent.h
  • phnEvtGPRSRegistration : HsPhoneEvent.h
  • phnEvtIndication : HsPhoneEvent.h
  • phnEvtIOTAStatus : HsPhoneEvent.h
  • phnEvtKeyPress : HsPhoneEvent.h
  • phnEvtMemoryFull : HsPhoneEvent.h
  • phnEvtMemoryOK : HsPhoneEvent.h
  • phnEvtMessageDel : HsPhoneEvent.h
  • phnEvtMessageInd : HsPhoneEvent.h
  • phnEvtMessageMoved : HsPhoneEvent.h
  • phnEvtMessageStat : HsPhoneEvent.h
  • phnEvtMIPFailed : HsPhoneEvent.h
  • phnEvtMMSInd : HsPhoneEvent.h
  • phnEvtNetworkTime : HsPhoneEvent.h
  • phnEvtOneXDataFail : HsPhoneEvent.h
  • phnEvtOneXMipRRQInd : HsPhoneEvent.h
  • phnEvtOneXStatus : HsPhoneEvent.h
  • phnEvtPassword : HsPhoneEvent.h
  • phnEvtPDDataChanged : HsPhoneEvent.h
  • phnEvtPhoneEquipmentMode : HsPhoneEvent.h
  • phnEvtPower : HsPhoneEvent.h
  • phnEvtPreConnected : HsPhoneEvent.h
  • phnEvtProgress : HsPhoneEvent.h
  • phnEvtRegistration : HsPhoneEvent.h
  • phnEvtSATNotification : HsPhoneEvent.h
  • phnEvtSegmentInd : HsPhoneEvent.h
  • phnEvtSSModeChanged : HsPhoneEvent.h
  • phnEvtStartDial : HsPhoneEvent.h
  • phnEvtStartIncomingCall : HsPhoneEvent.h
  • phnEvtSubscriber : HsPhoneEvent.h
  • phnEvtUpdate : HsPhoneEvent.h
  • phnEvtUSSDInd : HsPhoneEvent.h
  • phnEvtVoiceMail : HsPhoneEvent.h
  • phnEvtWAPInd : HsPhoneEvent.h
  • phnForwardCancelAll : HsPhoneNetworkTypes.h
  • phnForwardConditionalAll : HsPhoneNetworkTypes.h
  • phnForwardData : HsPhoneNetworkTypes.h
  • phnForwardLast : HsPhoneNetworkTypes.h
  • phnForwardModeDisable : HsPhoneNetworkTypes.h
  • phnForwardModeEnable : HsPhoneNetworkTypes.h
  • phnForwardModeErasure : HsPhoneNetworkTypes.h
  • phnForwardModeInterrogate : HsPhoneNetworkTypes.h
  • phnForwardModeRegistration : HsPhoneNetworkTypes.h
  • phnForwardOnBusy : HsPhoneNetworkTypes.h
  • phnForwardOnNoReplay : HsPhoneNetworkTypes.h
  • phnForwardOnNotReachable : HsPhoneNetworkTypes.h
  • phnForwardTelefax : HsPhoneNetworkTypes.h
  • phnForwardUnconditional : HsPhoneNetworkTypes.h
  • phnGenericCDMAAllowPDPSlotModification : HsPhoneCDMATypes.h
  • phnGenericCDMASMSEncoding : HsPhoneCDMATypes.h
  • phnGenericCDMAVoiceMailNumber : HsPhoneCDMATypes.h
  • phnGenericCDMAVoiceMailOption : HsPhoneCDMATypes.h
  • phnGPRSPDPTypeIP : HsPhoneGSMTypes.h
  • phnGPRSPDPTypePPP : HsPhoneGSMTypes.h
  • phnGsmAttrFirst : HsPhoneMiscTypes.h
  • phnGsmAttrLast : HsPhoneMiscTypes.h
  • phnGsmFWControlLED : HsPhoneMiscTypes.h
  • phnGsmNoFWVersionCompatibilityCheck : HsPhoneMiscTypes.h
  • phnGsmRadioAudioSet : HsPhoneMiscTypes.h
  • phnGsmSimBookSimMaxEntries : HsPhoneMiscTypes.h
  • phnGsmSimBookSimUsedEntries : HsPhoneMiscTypes.h
  • phnHandsetLidCloseMode : HsPhoneMiscTypes.h
  • phnHandsetMode : HsPhoneMiscTypes.h
  • phnHeadsetMode : HsPhoneMiscTypes.h
  • phnInvalidEquipmentMode : HsPhoneMiscTypes.h
  • phnIOTACommit : HsPhoneIOTATypes.h
  • phnIOTAEnd : HsPhoneIOTATypes.h
  • phnIOTAItemBootNAIURL : HsPhoneIOTATypes.h
  • phnIOTAItemBootURL : HsPhoneIOTATypes.h
  • phnIOTAItemConnectionTimeout : HsPhoneIOTATypes.h
  • phnIOTAItemDownloadServerLock : HsPhoneIOTATypes.h
  • phnIOTAItemDownloadServerURL : HsPhoneIOTATypes.h
  • phnIOTAItemHomepageURL : HsPhoneIOTATypes.h
  • phnIOTAItemLastNVItem : HsPhoneIOTATypes.h
  • phnIOTAItemPriDataExchangeURL : HsPhoneIOTATypes.h
  • phnIOTAItemPriDataGatewayURL : HsPhoneIOTATypes.h
  • phnIOTAItemPriIMMessageStore : HsPhoneIOTATypes.h
  • phnIOTAItemPriProxyWDPAddress : HsPhoneIOTATypes.h
  • phnIOTAItemPriSIPConfigServer : HsPhoneIOTATypes.h
  • phnIOTAItemPriSIPEdgeProxyGateway : HsPhoneIOTATypes.h
  • phnIOTAItemPriSIPRetryCount : HsPhoneIOTATypes.h
  • phnIOTAItemPriSIPRetryTimer : HsPhoneIOTATypes.h
  • phnIOTAItemPriWAPPushProxyGatewayURL : HsPhoneIOTATypes.h
  • phnIOTAItemPRLStorageSize : HsPhoneIOTATypes.h
  • phnIOTAItemRootCertificate1 : HsPhoneIOTATypes.h
  • phnIOTAItemRootCertificate2 : HsPhoneIOTATypes.h
  • phnIOTAItemRootCertificate3 : HsPhoneIOTATypes.h
  • phnIOTAItemRootCertificate4 : HsPhoneIOTATypes.h
  • phnIOTAItemSecDataExchangeURL : HsPhoneIOTATypes.h
  • phnIOTAItemSecDataGatewayURL : HsPhoneIOTATypes.h
  • phnIOTAItemSecIMMessageStore : HsPhoneIOTATypes.h
  • phnIOTAItemSecProxyWDPAddress : HsPhoneIOTATypes.h
  • phnIOTAItemSecSIPConfigServer : HsPhoneIOTATypes.h
  • phnIOTAItemSecSIPEdgeProxyGateway : HsPhoneIOTATypes.h
  • phnIOTAItemSecSIPRetryCount : HsPhoneIOTATypes.h
  • phnIOTAItemSecSIPRetryTimer : HsPhoneIOTATypes.h
  • phnIOTAItemSecWAPPushProxyGatewayURL : HsPhoneIOTATypes.h
  • phnIOTAItemSIPPassword : HsPhoneIOTATypes.h
  • phnIOTAItemSIPUsername : HsPhoneIOTATypes.h
  • phnIOTAItemTrustedDomain : HsPhoneIOTATypes.h
  • phnIOTAItemUnknown : HsPhoneIOTATypes.h
  • phnIOTAItemVendingURL : HsPhoneIOTATypes.h
  • phnIOTANAMSelect : HsPhoneIOTATypes.h
  • phnIOTAStart : HsPhoneIOTATypes.h
  • phnIOTAUnknown : HsPhoneIOTATypes.h
  • phnMIPFaAdminProhibited : HsPhoneCDMATypes.h
  • phnMIPFaBadTtl : HsPhoneCDMATypes.h
  • phnMIPFaCantRevTun : HsPhoneCDMATypes.h
  • PhnMIPFADelvStyleUnsupported : HsPhoneCDMATypes.h
  • PhnMIPFAError1 : HsPhoneCDMATypes.h
  • PhnMIPFAError2 : HsPhoneCDMATypes.h
  • phnMIPFaForeign_Agent : HsPhoneCDMATypes.h
  • phnMIPFaHa_Host_Unreachable : HsPhoneCDMATypes.h
  • phnMIPFaHa_Port_Unreachable : HsPhoneCDMATypes.h
  • phnMIPFaHa_Unreachable : HsPhoneCDMATypes.h
  • phnMIPFaHome_Network_Unreachable : HsPhoneCDMATypes.h
  • phnMIPFaHomeAgentAuth : HsPhoneCDMATypes.h
  • phnMIPFaInsufficientResources : HsPhoneCDMATypes.h
  • phnMIPFaInvalidCareOfAddr : HsPhoneCDMATypes.h
  • phnMIPFaMissing_Challenge : HsPhoneCDMATypes.h
  • PhnMIPFAMissingHomeAddr : HsPhoneCDMATypes.h
  • PhnMIPFAMissingNai : HsPhoneCDMATypes.h
  • phnMIPFaMobileNodeAuth : HsPhoneCDMATypes.h
  • phnMIPFaMustRevTun : HsPhoneCDMATypes.h
  • PhnMIPFANonzeroHomeAddrReq : HsPhoneCDMATypes.h
  • phnMIPFaPoorlyFormedReply : HsPhoneCDMATypes.h
  • phnMIPFaPoorlyFormedReq : HsPhoneCDMATypes.h
  • phnMIPFaReasonUnspecified : HsPhoneCDMATypes.h
  • phnMIPFaRegistration_Timeout : HsPhoneCDMATypes.h
  • phnMIPFaReqedEncapUnavail : HsPhoneCDMATypes.h
  • phnMIPFaReqLifetimeTooLong : HsPhoneCDMATypes.h
  • phnMIPFaReservedNUnavail : HsPhoneCDMATypes.h
  • phnMIPFaStale_Challenge : HsPhoneCDMATypes.h
  • phnMIPFaUnknown_Challenge : HsPhoneCDMATypes.h
  • phnMIPHaAdminProhibited : HsPhoneCDMATypes.h
  • phnMIPHaCantRevTun : HsPhoneCDMATypes.h
  • phnMIPHAError1 : HsPhoneCDMATypes.h
  • phnMIPHAError2 : HsPhoneCDMATypes.h
  • phnMIPHaForeignAgentAuth : HsPhoneCDMATypes.h
  • phnMIPHaInsufficientResources : HsPhoneCDMATypes.h
  • phnMIPHaMobileNodeAuth : HsPhoneCDMATypes.h
  • phnMIPHaMustRevTun : HsPhoneCDMATypes.h
  • phnMIPHaPoorlyFormedReq : HsPhoneCDMATypes.h
  • phnMIPHaReasonUnspecified : HsPhoneCDMATypes.h
  • phnMIPHaRegIdMismatch : HsPhoneCDMATypes.h
  • phnMIPHaReqEncapNotAvail : HsPhoneCDMATypes.h
  • phnMIPHaTooManySimMobBindings : HsPhoneCDMATypes.h
  • phnMIPHaUnknownHaAddr : HsPhoneCDMATypes.h
  • phnMIPNoSimBindings : HsPhoneCDMATypes.h
  • phnMIPSession : HsPhoneNetworkTypes.h
  • phnMIPSessionNone : HsPhoneNetworkTypes.h
  • phnMIPSuccess : HsPhoneCDMATypes.h
  • PhnMsgBoxTypeMAX : HsPhoneNetworkTypes.h
  • phnOneXFailModemSORej : HsPhoneCDMATypes.h
  • phnOneXFailNetworkBusy : HsPhoneCDMATypes.h
  • phnOneXFailNetworkSORej : HsPhoneCDMATypes.h
  • phnOneXFailNoSrv : HsPhoneCDMATypes.h
  • phnOneXFailPrev : HsPhoneCDMATypes.h
  • phnOneXFailUnknown : HsPhoneCDMATypes.h
  • phnOneXStatusPRev1 : HsPhoneNetworkTypes.h
  • phnOneXStatusPRev3 : HsPhoneNetworkTypes.h
  • phnOneXStatusPRev4 : HsPhoneNetworkTypes.h
  • phnOneXStatusPRev6 : HsPhoneNetworkTypes.h
  • phnOneXStatusPRev7 : HsPhoneNetworkTypes.h
  • phnOneXStatusPRevNoSvc : HsPhoneNetworkTypes.h
  • phnOpAvailable : HsPhoneNetworkTypes.h
  • phnOpCurrent : HsPhoneNetworkTypes.h
  • phnOpForbidden : HsPhoneNetworkTypes.h
  • phnOprtModeLPM : HsPhoneMiscTypes.h
  • phnOprtModeMax : HsPhoneMiscTypes.h
  • phnOprtModeNone : HsPhoneMiscTypes.h
  • phnOprtModeOffline : HsPhoneMiscTypes.h
  • phnOprtModeOfflineA : HsPhoneMiscTypes.h
  • phnOprtModeOnline : HsPhoneMiscTypes.h
  • phnOprtModePwroff : HsPhoneMiscTypes.h
  • phnOprtModeReset : HsPhoneMiscTypes.h
  • phnOpUnknown : HsPhoneNetworkTypes.h
  • phnPacketDataEndStatusAuthFailed : HsPhoneNetworkTypes.h
  • phnPacketDataEndStatusDropped : HsPhoneNetworkTypes.h
  • phnPacketDataEndStatusIntercept : HsPhoneNetworkTypes.h
  • phnPacketDataEndStatusLast : HsPhoneNetworkTypes.h
  • phnPacketDataEndStatusNoReason : HsPhoneNetworkTypes.h
  • phnPacketDataEndStatusNormal : HsPhoneNetworkTypes.h
  • phnPacketDataEndStatusReject : HsPhoneNetworkTypes.h
  • phnPacketDataEndStatusReorder : HsPhoneNetworkTypes.h
  • phnPacketDataEndStatusRetry : HsPhoneNetworkTypes.h
  • phnPacketDataEndStatusTimeout : HsPhoneNetworkTypes.h
  • phnPacketDataEndStatusUnknown : HsPhoneNetworkTypes.h
  • phnPacketDataSessionActive : HsPhoneNetworkTypes.h
  • phnPacketDataSessionDormant : HsPhoneNetworkTypes.h
  • phnPacketDataSessionNone : HsPhoneNetworkTypes.h
  • phnPasswordBarrAB : HsPhoneSecurityTypes.h
  • phnPasswordBarrAC : HsPhoneSecurityTypes.h
  • phnPasswordBarrAG : HsPhoneSecurityTypes.h
  • phnPasswordBarrAI : HsPhoneSecurityTypes.h
  • phnPasswordBarrAO : HsPhoneSecurityTypes.h
  • phnPasswordBarrIR : HsPhoneSecurityTypes.h
  • phnPasswordBarrOI : HsPhoneSecurityTypes.h
  • phnPasswordBarrOX : HsPhoneSecurityTypes.h
  • phnPasswordCorporatePIN : HsPhoneSecurityTypes.h
  • phnPasswordCorporatePUK : HsPhoneSecurityTypes.h
  • phnPasswordNetworkPIN : HsPhoneSecurityTypes.h
  • phnPasswordNetworkPUK : HsPhoneSecurityTypes.h
  • phnPasswordNetworkSubsetPIN : HsPhoneSecurityTypes.h
  • phnPasswordNetworkSubsetPUK : HsPhoneSecurityTypes.h
  • phnPasswordNone : HsPhoneSecurityTypes.h
  • phnPasswordPh1SIMPIN : HsPhoneSecurityTypes.h
  • phnPasswordPh1SIMPUK : HsPhoneSecurityTypes.h
  • phnPasswordPhSIMPIN : HsPhoneSecurityTypes.h
  • phnPasswordServiceProviderPIN : HsPhoneSecurityTypes.h
  • phnPasswordServiceProviderPUK : HsPhoneSecurityTypes.h
  • phnPasswordSIMPIN : HsPhoneSecurityTypes.h
  • phnPasswordSIMPIN2 : HsPhoneSecurityTypes.h
  • phnPasswordSIMPUK : HsPhoneSecurityTypes.h
  • phnPasswordSIMPUK2 : HsPhoneSecurityTypes.h
  • phnPasswordUnknown : HsPhoneSecurityTypes.h
  • PhnPDConfigGPSLock : hsPhoneLocationTypes.h
  • PhnPDConfigIPAddr : hsPhoneLocationTypes.h
  • PhnPDConfigPortID : hsPhoneLocationTypes.h
  • PhnPDConfigPTLMMode : hsPhoneLocationTypes.h
  • PhnPDPAUncert0_5_M : HsPhoneCDMATypes.h
  • PhnPDPAUncert0_75_M : HsPhoneCDMATypes.h
  • PhnPDPAUncert1024_M : HsPhoneCDMATypes.h
  • PhnPDPAUncert12288_M : HsPhoneCDMATypes.h
  • PhnPDPAUncert128_M : HsPhoneCDMATypes.h
  • PhnPDPAUncert12_M : HsPhoneCDMATypes.h
  • PhnPDPAUncert1536_M : HsPhoneCDMATypes.h
  • PhnPDPAUncert16_M : HsPhoneCDMATypes.h
  • PhnPDPAUncert192_M : HsPhoneCDMATypes.h
  • PhnPDPAUncert1_5_M : HsPhoneCDMATypes.h
  • PhnPDPAUncert1_M : HsPhoneCDMATypes.h
  • PhnPDPAUncert2048_M : HsPhoneCDMATypes.h
  • PhnPDPAUncert24_M : HsPhoneCDMATypes.h
  • PhnPDPAUncert256_M : HsPhoneCDMATypes.h
  • PhnPDPAUncert2_M : HsPhoneCDMATypes.h
  • PhnPDPAUncert3072_M : HsPhoneCDMATypes.h
  • PhnPDPAUncert32_M : HsPhoneCDMATypes.h
  • PhnPDPAUncert384_M : HsPhoneCDMATypes.h
  • PhnPDPAUncert3_M : HsPhoneCDMATypes.h
  • PhnPDPAUncert4096_M : HsPhoneCDMATypes.h
  • PhnPDPAUncert48_M : HsPhoneCDMATypes.h
  • PhnPDPAUncert4_M : HsPhoneCDMATypes.h
  • PhnPDPAUncert512_M : HsPhoneCDMATypes.h
  • PhnPDPAUncert6144_M : HsPhoneCDMATypes.h
  • PhnPDPAUncert64_M : HsPhoneCDMATypes.h
  • PhnPDPAUncert6_M : HsPhoneCDMATypes.h
  • PhnPDPAUncert768_M : HsPhoneCDMATypes.h
  • PhnPDPAUncert8192_M : HsPhoneCDMATypes.h
  • PhnPDPAUncert8_M : HsPhoneCDMATypes.h
  • PhnPDPAUncert96_M : HsPhoneCDMATypes.h
  • PhnPDPAUncertGREATER_12288_M : HsPhoneCDMATypes.h
  • PhnPDPAUncertMAX : HsPhoneCDMATypes.h
  • PhnPDPAUncertNOT_COMPUTABLE_M : HsPhoneCDMATypes.h
  • phnPDPConnectionTypeInvalid : HsPhoneCDMATypes.h
  • phnPDPConnectionTypeMIP : HsPhoneCDMATypes.h
  • phnPDPConnectionTypeMIPWithSIPFallback : HsPhoneCDMATypes.h
  • phnPDPConnectionTypeSIP : HsPhoneCDMATypes.h
  • phnPDPCopyDuplicateNAI : HsPhoneCDMATypes.h
  • phnPDPCopyFromIndexNotActive : HsPhoneCDMATypes.h
  • phnPDPCopyInternalModemErr : HsPhoneCDMATypes.h
  • phnPDPCopyInvalidAAALen : HsPhoneCDMATypes.h
  • phnPDPCopyInvalidFromIndex : HsPhoneCDMATypes.h
  • phnPDPCopyInvalidNAILen : HsPhoneCDMATypes.h
  • phnPDPCopyInvalidNAIName : HsPhoneCDMATypes.h
  • phnPDPCopyInvalidSvcStrLen : HsPhoneCDMATypes.h
  • phnPDPCopyInvalidToIndex : HsPhoneCDMATypes.h
  • phnPDPCopyNotAllowedAtFromIndex : HsPhoneCDMATypes.h
  • phnPDPCopyNotAllowedAtToIndex : HsPhoneCDMATypes.h
  • phnPDPCopyOK : HsPhoneCDMATypes.h
  • phnPDPCopyToIndexInUse : HsPhoneCDMATypes.h
  • phnPDPDefaultIndex : HsPhoneCDMATypes.h
  • phnPDPDeleteIndexActive : HsPhoneCDMATypes.h
  • phnPDPDeleteIndexNotUsed : HsPhoneCDMATypes.h
  • phnPDPDeleteInternalModemErr : HsPhoneCDMATypes.h
  • phnPDPDeleteInvalidIndex : HsPhoneCDMATypes.h
  • phnPDPDeleteNotAllowedAtIndex : HsPhoneCDMATypes.h
  • phnPDPDeleteOK : HsPhoneCDMATypes.h
  • phnPDPGenericIndex : HsPhoneCDMATypes.h
  • phnPDPInvalidHALen : HsPhoneCDMATypes.h
  • phnPDPReadIndexNotSet : HsPhoneCDMATypes.h
  • phnPDPReadInternalModemErr : HsPhoneCDMATypes.h
  • phnPDPReadInvalidIndex : HsPhoneCDMATypes.h
  • phnPDPReadNotAllowedAtIndex : HsPhoneCDMATypes.h
  • phnPDPReadOK : HsPhoneCDMATypes.h
  • phnPDPReplaceInternalModemErr : HsPhoneCDMATypes.h
  • phnPDPReplaceInvalidIndex : HsPhoneCDMATypes.h
  • phnPDPReplaceInvalidLen : HsPhoneCDMATypes.h
  • phnPDPReplaceInvalidNotUsed : HsPhoneCDMATypes.h
  • phnPDPReplaceNotAllowedAtIndex : HsPhoneCDMATypes.h
  • phnPDPReplaceOK : HsPhoneCDMATypes.h
  • phnPDPServiceBrowser : HsPhoneCDMATypes.h
  • phnPDPServiceCorporateGateway : HsPhoneCDMATypes.h
  • phnPDPServiceDownloads : HsPhoneCDMATypes.h
  • phnPDPServiceIM : HsPhoneCDMATypes.h
  • phnPDPServiceInternet : HsPhoneCDMATypes.h
  • phnPDPServiceMail : HsPhoneCDMATypes.h
  • phnPDPServiceMMS : HsPhoneCDMATypes.h
  • phnPDPServicePictureMail : HsPhoneCDMATypes.h
  • phnPDPServicePrivate : HsPhoneCDMATypes.h
  • phnPDPServiceUnknown : HsPhoneCDMATypes.h
  • phnPDPServiceWAP : HsPhoneCDMATypes.h
  • phnPDPTempIndex : HsPhoneCDMATypes.h
  • phnPDPWriteDuplicateNAI : HsPhoneCDMATypes.h
  • phnPDPWriteIndexInUse : HsPhoneCDMATypes.h
  • phnPDPWriteIndexNotPrevSet : HsPhoneCDMATypes.h
  • phnPDPWriteInternalModemErr : HsPhoneCDMATypes.h
  • phnPDPWriteInvalidAAALen : HsPhoneCDMATypes.h
  • phnPDPWriteInvalidDialStrLen : HsPhoneCDMATypes.h
  • phnPDPWriteInvalidIndex : HsPhoneCDMATypes.h
  • phnPDPWriteInvalidNAILen : HsPhoneCDMATypes.h
  • phnPDPWriteInvalidNAIName : HsPhoneCDMATypes.h
  • phnPDPWriteInvalidSvcStrLen : HsPhoneCDMATypes.h
  • phnPDPWriteNotAllowedAtIndex : HsPhoneCDMATypes.h
  • phnPDPWriteOK : HsPhoneCDMATypes.h
  • phnPowerLow : HsPhoneTypes.h
  • phnPowerOff : HsPhoneTypes.h
  • phnPowerOn : HsPhoneTypes.h
  • phnPowerSave : HsPhoneTypes.h
  • phnPowerStartCharging : HsPhoneTypes.h
  • phnPowerStopCharging : HsPhoneTypes.h
  • PhnRoamIconFlash : HsPhoneNetworkTypes.h
  • PhnRoamIconOff : HsPhoneNetworkTypes.h
  • PhnRoamIconOn : HsPhoneNetworkTypes.h
  • phnRoamPrefAny : HsPhoneNetworkTypes.h
  • phnRoamPrefHomeOnly : HsPhoneNetworkTypes.h
  • phnRoamPrefLast : HsPhoneNetworkTypes.h
  • phnRoamPrefRoamOnly : HsPhoneNetworkTypes.h
  • PhnRoamStatusBlink : HsPhoneNetworkTypes.h
  • PhnRoamStatusEnhancedIndicator : HsPhoneNetworkTypes.h
  • PhnRoamStatusOff : HsPhoneNetworkTypes.h
  • PhnRoamStatusOn : HsPhoneNetworkTypes.h
  • phnSATEventDataSvcTypeCloseChannel : HsPhoneGSMTypes.h
  • phnSATEventDataSvcTypeOpenChannel : HsPhoneGSMTypes.h
  • phnSATEventDataSvcTypeRcvData : HsPhoneGSMTypes.h
  • phnSATEventDataSvcTypeSendData : HsPhoneGSMTypes.h
  • phnSATEventInputEchoModeHideInput : HsPhoneGSMTypes.h
  • phnSATEventInputEchoModeShowInput : HsPhoneGSMTypes.h
  • phnSATEventInputFormatDigit : HsPhoneGSMTypes.h
  • phnSATEventInputFormatPacked : HsPhoneGSMTypes.h
  • phnSATEventInputFormatSMSChar : HsPhoneGSMTypes.h
  • phnSATEventInputFormatUCS2 : HsPhoneGSMTypes.h
  • phnSATEventInputFormatUnknown : HsPhoneGSMTypes.h
  • phnSATEventInputFormatUnpacked : HsPhoneGSMTypes.h
  • phnSATEventInputFormatYesNo : HsPhoneGSMTypes.h
  • phnSATEventMenuFlagHelp : HsPhoneGSMTypes.h
  • phnSATEventMenuFlagNextAct : HsPhoneGSMTypes.h
  • phnSATEventSetupCallCallTypeData : HsPhoneGSMTypes.h
  • phnSATEventSetupCallCallTypeFax : HsPhoneGSMTypes.h
  • phnSATEventSetupCallCallTypeVoice : HsPhoneGSMTypes.h
  • phnSATEventToneTimeUnitDeciSeconds : HsPhoneGSMTypes.h
  • phnSATEventToneTimeUnitMinutes : HsPhoneGSMTypes.h
  • phnSATEventToneTimeUnitSeconds : HsPhoneGSMTypes.h
  • phnSATEventToneTypeBusy : HsPhoneGSMTypes.h
  • phnSATEventToneTypeCallWaiting : HsPhoneGSMTypes.h
  • phnSATEventToneTypeCongestion : HsPhoneGSMTypes.h
  • phnSATEventToneTypeDial : HsPhoneGSMTypes.h
  • phnSATEventToneTypeDropped : HsPhoneGSMTypes.h
  • phnSATEventToneTypeError : HsPhoneGSMTypes.h
  • phnSATEventToneTypeGeneralBeep : HsPhoneGSMTypes.h
  • phnSATEventToneTypeNegativeBeep : HsPhoneGSMTypes.h
  • phnSATEventToneTypeNoneSpecified : HsPhoneGSMTypes.h
  • phnSATEventToneTypePositiveBeep : HsPhoneGSMTypes.h
  • phnSATEventToneTypeRadioAck : HsPhoneGSMTypes.h
  • phnSATEventToneTypeRinging : HsPhoneGSMTypes.h
  • phnServiceActivation : HsPhoneTypes.h
  • phnServiceAFLT : HsPhoneTypes.h
  • phnServiceAll : HsPhoneTypes.h
  • phnServiceData : HsPhoneTypes.h
  • phnServiceEssentials : HsPhoneTypes.h
  • phnServiceIOTA : HsPhoneTypes.h
  • phnServiceMax : HsPhoneTypes.h
  • phnServiceMisc : HsPhoneTypes.h
  • phnServiceMMS : HsPhoneTypes.h
  • phnServiceSIMToolkit : HsPhoneTypes.h
  • phnServiceSMS : HsPhoneTypes.h
  • phnServiceVoice : HsPhoneTypes.h
  • phnServiceWAP : HsPhoneTypes.h
  • phnSMSEncodingASCII : HsPhoneCDMATypes.h
  • phnSMSEncodingGSM : HsPhoneCDMATypes.h
  • phnSMSEncodingISO8859_1 : HsPhoneCDMATypes.h
  • phnSpeakerPhoneMode : HsPhoneMiscTypes.h
  • phnSysPrefAOnly : HsPhoneCDMATypes.h
  • phnSysPrefBOnly : HsPhoneCDMATypes.h
  • phnSysPrefHomeOnly : HsPhoneCDMATypes.h
  • phnSysPrefStandard : HsPhoneCDMATypes.h
  • phnTeleserviceAllExceptSMSCode : HsPhoneNetworkTypes.h
  • phnTeleserviceAllMmiCode : HsPhoneNetworkTypes.h
  • phnTeleserviceData : HsPhoneNetworkTypes.h
  • phnTeleserviceDataCircAsync : HsPhoneNetworkTypes.h
  • phnTeleserviceDataCircAsyncMmiCode : HsPhoneNetworkTypes.h
  • phnTeleserviceDataCircSync : HsPhoneNetworkTypes.h
  • phnTeleserviceDataCircSyncMmiCode : HsPhoneNetworkTypes.h
  • phnTeleserviceDedicatedPack : HsPhoneNetworkTypes.h
  • phnTeleserviceDedicatedPackMmiCode : HsPhoneNetworkTypes.h
  • phnTeleserviceDedicatedPAD : HsPhoneNetworkTypes.h
  • phnTeleserviceDedicatedPADMmiCode : HsPhoneNetworkTypes.h
  • phnTeleserviceDefault : HsPhoneNetworkTypes.h
  • phnTeleserviceFax : HsPhoneNetworkTypes.h
  • phnTeleserviceFaxMmiCode : HsPhoneNetworkTypes.h
  • phnTeleserviceSMS : HsPhoneNetworkTypes.h
  • phnTeleserviceSMSMmiCode : HsPhoneNetworkTypes.h
  • phnTeleserviceUnknown : HsPhoneNetworkTypes.h
  • phnTeleserviceUnknownMmiCode : HsPhoneNetworkTypes.h
  • phnTeleserviceVoice : HsPhoneNetworkTypes.h
  • phnTeleserviceVoiceMmiCode : HsPhoneNetworkTypes.h
  • phnTTYSettingAll : HsPhoneAudioTypes.h
  • phnTTYSettingHearCarryOver : HsPhoneAudioTypes.h
  • phnTTYSettingOff : HsPhoneAudioTypes.h
  • phnTTYSettingVoiceCarryOver : HsPhoneAudioTypes.h
  • phnVibrateOff : HsPhoneMiscTypes.h
  • phnVibrateOn : HsPhoneMiscTypes.h
  • PhoneAppDialMethodNormal : HsAppLaunchCmd.h
  • PhoneAppDialMethodSATSetupCall : HsAppLaunchCmd.h
  • PhoneAppDialMethodSATSetupCallDisconnectOtherCalls : HsAppLaunchCmd.h
  • PhoneAppDialMethodSATSetupCallHoldOtherCalls : HsAppLaunchCmd.h
  • PhoneAppDialMethodSATSetupCallModeNotBusy : HsAppLaunchCmd.h
  • PhoneAppDialMethodSATSetupCallWithRedialDisconnectOtherCalls : HsAppLaunchCmd.h
  • PhoneAppDialMethodSATSetupCallWithRedialHoldOtherCalls : HsAppLaunchCmd.h
  • PhoneAppDialMethodSATSetupCallWithRedialModeNotBusy : HsAppLaunchCmd.h
  • plainOnly : VMFontLibCommon.h
  • plugin_allInfo : PalmVMPlugin.h
  • plugin_receiveInfo : PalmVMPlugin.h
  • plugin_sendInfo : PalmVMPlugin.h
  • pmAudioGroupAlert : PmSoundLibAudioGroup.h
  • pmAudioGroupAlertRingOff : PmSoundLibAudioGroup.h
  • pmAudioGroupApp : PmSoundLibAudioGroup.h
  • pmAudioGroupCall : PmSoundLibAudioGroup.h
  • pmAudioGroupHighPriority : PmSoundLibAudioGroup.h
  • pmAudioGroupInteractive : PmSoundLibAudioGroup.h
  • pmAudioGroupNone : PmSoundLibAudioGroup.h
  • pmAudioGroupStreaming : PmSoundLibAudioGroup.h
  • pmAudioGroupSystem : PmSoundLibAudioGroup.h
  • pmKeyAttrGetEndKeyCode : PmKeyLibCommon.h
  • pmKeyAttrGetLauncherKeyCode : PmKeyLibCommon.h
  • pmKeyAttrGetMenuKeyCode : PmKeyLibCommon.h
  • pmKeyAttrGetPhoneKeyCode : PmKeyLibCommon.h
  • pmKeyAttrGetSendKeyCode : PmKeyLibCommon.h
  • pmKeyAttrPagingMode : PmKeyLibCommon.h
  • pmSndFormatPauseStream : HsSoundLibCommon.h
  • pmSndFormatResumeStream : HsSoundLibCommon.h
  • pmSndFormatSetAttackEnvID : HsSoundLibCommon.h
  • pmSndFormatSetStoppable : HsSoundLibCommon.h
  • pmSysGadgetStatusGadgetBattery : PmSysGadgetLibCommon.h
  • pmSysGadgetStatusGadgetBt : PmSysGadgetLibCommon.h
  • pmSysGadgetStatusGadgetCallFwd : PmSysGadgetLibCommon.h
  • pmSysGadgetStatusGadgetEvdo : PmSysGadgetLibCommon.h
  • pmSysGadgetStatusGadgetLine : PmSysGadgetLibCommon.h
  • pmSysGadgetStatusGadgetNone : PmSysGadgetLibCommon.h
  • pmSysGadgetStatusGadgetOperator : PmSysGadgetLibCommon.h
  • pmSysGadgetStatusGadgetPhoneCall : PmSysGadgetLibCommon.h
  • pmSysGadgetStatusGadgetPtt : PmSysGadgetLibCommon.h
  • pmSysGadgetStatusGadgetRoaming : PmSysGadgetLibCommon.h
  • pmSysGadgetStatusGadgetSignal : PmSysGadgetLibCommon.h
  • pmSysGadgetStatusGadgetTty : PmSysGadgetLibCommon.h
  • pmSysGadgetStatusGadgetVm : PmSysGadgetLibCommon.h
  • pmUIUtilAttrAutoSnoozeAttns : PmUIUtilLibCommon.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:38 2008 for Palm API Guide


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • v

- r -

  • registrationDenied : HsPhoneNetworkTypes.h
  • registrationHome : HsPhoneNetworkTypes.h
  • registrationNone : HsPhoneNetworkTypes.h
  • registrationRoaming : HsPhoneNetworkTypes.h
  • registrationSearch : HsPhoneNetworkTypes.h
  • registrationUnknown : HsPhoneNetworkTypes.h
  • replaceType1 : HsPhoneEvent.h
  • replaceType2 : HsPhoneEvent.h
  • replaceType3 : HsPhoneEvent.h
  • replaceType4 : HsPhoneEvent.h
  • replaceType5 : HsPhoneEvent.h
  • replaceType6 : HsPhoneEvent.h
  • replaceType7 : HsPhoneEvent.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:38 2008 for Palm API Guide


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • v

- s -

  • sabon : VMFontLibCommon.h
  • SecurityModeLast : PalmWiFiCommon.h
  • SecurityModeOpenSystem : PalmWiFiCommon.h
  • SecurityModeWEP : PalmWiFiCommon.h
  • SecurityModeWPAPSK : PalmWiFiCommon.h
  • simFailure : HsPhoneTypes.h
  • simMissing : HsPhoneTypes.h
  • simNotReady : HsPhoneTypes.h
  • simPresent : HsPhoneTypes.h
  • simReady : HsPhoneTypes.h
  • simUnknown : HsPhoneTypes.h
  • simWrong : HsPhoneTypes.h
  • size12 : VMFontLibCommon.h
  • size6 : VMFontLibCommon.h
  • size9 : VMFontLibCommon.h
  • smallFonts : VMFontLibCommon.h
  • SmsCauseAddressTranslationFailure : HsPhoneSMSTypes.h
  • SmsCauseAddressVacant : HsPhoneSMSTypes.h
  • SmsCauseDestinationBusy : HsPhoneSMSTypes.h
  • SmsCauseDestinationNoLongerAtThisAddress : HsPhoneSMSTypes.h
  • SmsCauseDestinationOutOfService : HsPhoneSMSTypes.h
  • SmsCauseDestinationResourceShortage : HsPhoneSMSTypes.h
  • SmsCauseInvalidTeleserviceId : HsPhoneSMSTypes.h
  • SmsCauseMissingExpectedParm : HsPhoneSMSTypes.h
  • SmsCauseMissingMandatoryParm : HsPhoneSMSTypes.h
  • SmsCauseNetworkFailure : HsPhoneSMSTypes.h
  • SmsCauseNetworkResourceShortage : HsPhoneSMSTypes.h
  • SmsCauseNoAck : HsPhoneSMSTypes.h
  • SmsCauseNoPageResponse : HsPhoneSMSTypes.h
  • SmsCauseOtherGeneralProblems : HsPhoneSMSTypes.h
  • SmsCauseOtherGeneralProblemsMoreFirst : HsPhoneSMSTypes.h
  • SmsCauseOtherGeneralProblemsMoreLast : HsPhoneSMSTypes.h
  • SmsCauseOtherNetworkProblem : HsPhoneSMSTypes.h
  • SmsCauseOtherNetworkProblemMoreFirst : HsPhoneSMSTypes.h
  • SmsCauseOtherNetworkProblemMoreLast : HsPhoneSMSTypes.h
  • SmsCauseOtherRadioIfProblem : HsPhoneSMSTypes.h
  • SmsCauseOtherRadioIfProblemMoreFirst : HsPhoneSMSTypes.h
  • SmsCauseOtherRadioIfProblemMoreLast : HsPhoneSMSTypes.h
  • SmsCauseOtherTerminalProblem : HsPhoneSMSTypes.h
  • smsCauseOtherTerminalProblemMoreFirst : HsPhoneSMSTypes.h
  • SmsCauseOtherTerminalProblemMoreLast : HsPhoneSMSTypes.h
  • SmsCauseRadioIfIncompatible : HsPhoneSMSTypes.h
  • SmsCauseRadioIfResourceShortage : HsPhoneSMSTypes.h
  • SmsCauseReserved101 : HsPhoneSMSTypes.h
  • SmsCauseSmsDeliveryPostponed : HsPhoneSMSTypes.h
  • SmsCauseSmsDeliveryPostponedMoreFirst : HsPhoneSMSTypes.h
  • SmsCauseSmsDeliveryPostponedMoreLast : HsPhoneSMSTypes.h
  • SmsCauseSmsNotSupported : HsPhoneSMSTypes.h
  • SmsCauseSmsOriginationDenied : HsPhoneSMSTypes.h
  • SmsCauseSmsTerminationDenied : HsPhoneSMSTypes.h
  • SmsCauseSupplServiceNotSupported : HsPhoneSMSTypes.h
  • SmsCauseUnexpected_Parm_Size : HsPhoneSMSTypes.h
  • SmsCauseUnexpectedParmValue : HsPhoneSMSTypes.h
  • SmsCauseUnrecognizedParmValue : HsPhoneSMSTypes.h
  • SmsCauseUserDataSizeError : HsPhoneSMSTypes.h
  • SmsErrorNone : HsPhoneSMSTypes.h
  • SmsErrorPermanent : HsPhoneSMSTypes.h
  • SmsErrorReserved : HsPhoneSMSTypes.h
  • SmsErrorTemporary : HsPhoneSMSTypes.h
  • smsFmtAllKinds : HsPhoneSMSTypes.h
  • smsFmtExceptKind : HsPhoneSMSTypes.h
  • smsFmtIgnoreKind : HsPhoneSMSTypes.h
  • smsFmtLastNameFirst : HsPhoneSMSTypes.h
  • smsFmtMatchKind : HsPhoneSMSTypes.h
  • smsFmtShortLabel : HsPhoneSMSTypes.h
  • sndControlCodecCustomControl : PalmSoundCustomCtrl.h
  • sndFormatAAC : PalmSoundMgrExt.h
  • sndFormatDVI_ADPCM : PalmSoundMgrExt.h
  • sndFormatIMA_ADPCM : PalmSoundMgrExt.h
  • sndFormatMP3 : PalmSoundMgrExt.h
  • sndFormatOGG : PalmSoundMgrExt.h
  • sndFormatPCM : PalmSoundMgrExt.h
  • soundPrefsViewTones : HsAppLaunchCmd.h
  • soundPrefsViewVolume : HsAppLaunchCmd.h
  • soundPrefTypeCalendar : TonesLibTypes.h
  • soundPrefTypeEmail : TonesLibTypes.h
  • soundPrefTypeIM : TonesLibTypes.h
  • soundPrefTypeLast : TonesLibTypes.h
  • soundPrefTypeMMS : TonesLibTypes.h
  • soundPrefTypeNetworkSounds : TonesLibTypes.h
  • soundPrefTypePhone : TonesLibTypes.h
  • soundPrefTypeSMS : TonesLibTypes.h
  • SSR : palmOneCodecFormat.h
  • statAttrBarVisible : PalmStatusBar.h
  • statAttrDimension : PalmStatusBar.h
  • statAttrExists : PalmStatusBar.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:38 2008 for Palm API Guide


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • v

- t -

  • toneInterruptMode2 : TonesLibTypes.h
  • toneInterruptMode3 : TonesLibTypes.h
  • toneInterruptPhone : TonesLibTypes.h
  • tonePlay100Times : TonesLibTypes.h
  • tonePlay10Times : TonesLibTypes.h
  • tonePlay3Times : TonesLibTypes.h
  • tonePlay5Times : TonesLibTypes.h
  • tonePlayOnce : TonesLibTypes.h
  • tonePlayTwice : TonesLibTypes.h
  • toneRepeatEvery10Minutes : TonesLibTypes.h
  • toneRepeatEvery30Minutes : TonesLibTypes.h
  • toneRepeatEvery5Minutes : TonesLibTypes.h
  • toneRepeatEveryMinute : TonesLibTypes.h
  • toneTimeUnitDays : TonesLibTypes.h
  • toneTimeUnitHours : TonesLibTypes.h
  • toneTimeUnitMinutes : TonesLibTypes.h
  • toneTypeAAC : TonesLibTypes.h
  • toneTypeAMR : TonesLibTypes.h
  • toneTypeMIDI : TonesLibTypes.h
  • toneTypeMP3 : TonesLibTypes.h
  • toneTypeQCELP : TonesLibTypes.h
  • toneTypeSystemSound : TonesLibTypes.h
  • toneTypeWAV : TonesLibTypes.h
  • toneVibrateAlert : TonesLibTypes.h
  • toneVibrateCalender : TonesLibTypes.h
  • toneVibrateMail : TonesLibTypes.h
  • toneVibrateNone : TonesLibTypes.h
  • toneVibrateRing : TonesLibTypes.h
  • toneVibrateSMS : TonesLibTypes.h
  • toneVibrateThenRing : TonesLibTypes.h
  • toneVibrateVoicemail : TonesLibTypes.h
  • toneVolume1 : TonesLibTypes.h
  • toneVolume2 : TonesLibTypes.h
  • toneVolume3 : TonesLibTypes.h
  • toneVolume4 : TonesLibTypes.h
  • toneVolume5 : TonesLibTypes.h
  • toneVolume6 : TonesLibTypes.h
  • toneVolume7 : TonesLibTypes.h
  • toneVolumeOff : TonesLibTypes.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:38 2008 for Palm API Guide


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • v

- v -

  • VFS : palmOneCodecFormat.h
  • voiceConnection : HsPhoneMiscTypes.h
  • vpnConnectionDown : PalmShimSettings.h
  • vpnConnectionUp : PalmShimSettings.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:38 2008 for Palm API Guide


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • b
  • c
  • d
  • f
  • g
  • h
  • i
  • l
  • n
  • p
  • s
  • t
  • v

- b -

  • BGServiceCancelRqst() : PalmBGService.h
  • BGServiceClose() : PalmBGService.h
  • BGServiceINetRqst() : PalmBGService.h
  • BGServiceNetRqst() : PalmBGService.h
  • BGServiceOpen() : PalmBGService.h
  • BGServiceVersion() : PalmBGService.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:38 2008 for Palm API Guide


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • b
  • c
  • d
  • f
  • g
  • h
  • i
  • l
  • n
  • p
  • s
  • t
  • v

- l -

  • LcdOverlayLibClose() : palmOneLcdOverlay.h , PalmLcdOverlay.h
  • LcdOverlayLibControl() : palmOneLcdOverlay.h , PalmLcdOverlay.h
  • LcdOverlayLibGetVersion() : palmOneLcdOverlay.h , PalmLcdOverlay.h
  • LcdOverlayLibOpen() : palmOneLcdOverlay.h , PalmLcdOverlay.h
  • LcdOverlayLibSleep() : PalmLcdOverlay.h
  • LcdOverlayLibWake() : PalmLcdOverlay.h
  • LocationCopy() : LocsLib.h
  • LocationCopyV20() : LocsLib.h
  • LocationFinal() : LocsLib.h
  • LocationFinalV20() : LocsLib.h
  • LocationGetSize() : LocsLib.h
  • LocationGetSizeV20() : LocsLib.h
  • LocationInit() : LocsLib.h
  • LocationInitV20() : LocsLib.h
  • LocationIsDSTPast() : LocsLib.h
  • LocationMakeGeneric() : LocsLib.h
  • LocationSetName() : LocsLib.h
  • LocationSetNote() : LocsLib.h
  • LocationSetPosition() : LocsLib.h
  • LocDBChangeRecord() : LocsLib.h
  • LocDBChangeRecordV20() : LocsLib.h
  • LocDBCompareRecordsSimple() : LocsLib.h
  • LocDBConvertRecord() : LocsLib.h
  • LocDBConvertRecordV20() : LocsLib.h
  • LocDBCopyLocation() : LocsLib.h
  • LocDBDeleteRecord() : LocsLib.h
  • LocDBFindCustomRecord() : LocsLib.h
  • LocDBFindCustomRecordV20() : LocsLib.h
  • LocDBFindFirst() : LocsLib.h
  • LocDBFindFirstByName() : LocsLib.h
  • LocDBFindFirstByUTCCountry() : LocsLib.h
  • LocDBFindFirstInList() : LocsLib.h
  • LocDBGetCustomList() : LocsLib.h
  • LocDBGetNearestLocation() : LocsLib.h
  • LocDBGetRecord() : LocsLib.h
  • LocDBGetRecordList() : LocsLib.h
  • LocDBGetRecordListV20() : LocsLib.h
  • LocDBGetRecordV20() : LocsLib.h
  • LocDBGetVersion() : LocsLib.h
  • LocDBInitDBs() : LocsLib.h
  • LocDBNewRecord() : LocsLib.h
  • LocDBNewRecordV20() : LocsLib.h
  • LocDBOpenCustom() : LocsLib.h
  • LocDBOpenDefault() : LocsLib.h
  • LocDBRecordSize() : LocsLib.h
  • LocDBSetRecordCustom() : LocsLib.h
  • LocDBSort() : LocsLib.h
  • LocsLibClose() : LocsLib.h
  • LocsLibDSTAlarmClear() : LocsLib.h
  • LocsLibDSTAlarmIsDST() : LocsLib.h
  • LocsLibDSTAlarmSet() : LocsLib.h
  • LocsLibGetVersion() : LocsLib.h
  • LocsLibLaunchEditListDialogue() : LocsLib.h
  • LocsLibLaunchSelDialogue() : LocsLib.h
  • LocsLibLocationNote() : LocsLib.h
  • LocsLibOpen() : LocsLib.h
  • LocsLibSleep() : LocsLib.h
  • LocsLibWake() : LocsLib.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:38 2008 for Palm API Guide


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • b
  • c
  • d
  • f
  • g
  • h
  • i
  • l
  • n
  • p
  • s
  • t
  • v

- n -

  • NetMasterAutoLoginSettingGet() : NetMasterLibrary.h
  • NetMasterAutoLoginSettingSet() : NetMasterLibrary.h
  • NetMasterLibVersionGet() : NetMasterLibrary.h
  • NetMasterNetInterfacesShutDown() : NetMasterLibrary.h
  • NetMasterNetLibIsFullyUp() : NetMasterLibrary.h
  • NetMasterNetLibIsLoggingIn() : NetMasterLibrary.h
  • NetMasterNetLibOpenIfFullyUp() : NetMasterLibrary.h
  • NetMasterNetLibOpenWithOptions() : NetMasterLibrary.h
  • NetMasterSCContextAnchorTimeoutSet() : NetMasterLibrary.h
  • NetMasterSCNetAttach() : NetMasterLibrary.h
  • NetMasterSCNetDetach() : NetMasterLibrary.h
  • NetMasterSCSessionCountGet() : NetMasterLibrary.h
  • NetMasterSCSessionIDGetFromContext() : NetMasterLibrary.h
  • NetMasterSCSessionIsActive() : NetMasterLibrary.h
  • NetMasterSCSessionsEnumerate() : NetMasterLibrary.h
  • NetMasterSCSessionShutDown() : NetMasterLibrary.h
  • NetMasterSCSessionSvcRecIDGet() : NetMasterLibrary.h
  • NetPrefDefaultTargetGet() : NetPrefLibrary.h
  • NetPrefDefaultTargetSet() : NetPrefLibrary.h
  • NetPrefHandleHotSyncNotify() : NetPrefLibrary.h
  • NetPrefLibClose() : NetPrefLibrary.h
  • NetPrefLibOpen() : NetPrefLibrary.h
  • NetPrefLibSleep() : NetPrefLibrary.h
  • NetPrefLibVersionGet() : NetPrefLibrary.h
  • NetPrefLibWake() : NetPrefLibrary.h
  • NetPrefRecBindingErrorGet() : NetPrefLibrary.h
  • NetPrefRecByteFieldGet() : NetPrefLibrary.h
  • NetPrefRecConnectionInfoGet() : NetPrefLibrary.h
  • NetPrefRecCountGet() : NetPrefLibrary.h
  • NetPrefRecDelete() : NetPrefLibrary.h
  • NetPrefRecDirtyFlagsReset() : NetPrefLibrary.h
  • NetPrefRecFieldAddToSet() : NetPrefLibrary.h
  • NetPrefRecFieldAttrsGet() : NetPrefLibrary.h
  • NetPrefRecFieldGet() : NetPrefLibrary.h
  • NetPrefRecFieldInfoExtended() : NetPrefLibFieldInfoTable.h
  • NetPrefRecFieldInfoGrpStart() : NetPrefLibFieldInfoTable.h
  • NetPrefRecFieldInfoLegacy() : NetPrefLibFieldInfoTable.h
  • NetPrefRecFieldInfoPreamble() : NetPrefLibFieldInfoTable.h
  • NetPrefRecFieldSet() : NetPrefLibrary.h
  • NetPrefRecFieldSetDefine() : NetPrefLibrary.h
  • NetPrefRecFieldSetDefineStd() : NetPrefLibrary.h
  • NetPrefRecFieldSetFromBinHandle() : NetPrefLibrary.h
  • NetPrefRecFieldSetFromStrHandle() : NetPrefLibrary.h
  • NetPrefRecFieldSetFromStrPtr() : NetPrefLibrary.h
  • NetPrefRecFieldSetGet() : NetPrefLibrary.h
  • NetPrefRecFieldViewGet() : NetPrefLibrary.h
  • NetPrefRecFieldViewSet() : NetPrefLibrary.h
  • NetPrefRecIDGet() : NetPrefLibrary.h
  • NetPrefRecIDGetByIndex() : NetPrefLibrary.h
  • NetPrefRecIndexGet() : NetPrefLibrary.h
  • NetPrefRecIndexGetByID() : NetPrefLibrary.h
  • NetPrefRecIPAddrFieldSet() : NetPrefLibrary.h
  • NetPrefRecIsAttached() : NetPrefLibrary.h
  • NetPrefRecIsDirty() : NetPrefLibrary.h
  • NetPrefRecLoad() : NetPrefLibrary.h
  • NetPrefRecLongFieldGet() : NetPrefLibrary.h
  • NetPrefRecLongFieldSetAsFlags() : NetPrefLibrary.h
  • NetPrefRecMarkDirty() : NetPrefLibrary.h
  • NetPrefRecMediumDerive() : NetPrefLibrary.h
  • NetPrefRecNew() : NetPrefLibrary.h
  • NetPrefRecObjAlloc() : NetPrefLibrary.h
  • NetPrefRecObjCopy() : NetPrefLibrary.h
  • NetPrefRecPhoneStringCompose() : NetPrefLibrary.h
  • NetPrefRecReadOnlyOverrideEnd() : NetPrefLibrary.h
  • NetPrefRecReadOnlyOverrideStart() : NetPrefLibrary.h
  • NetPrefRecRelease() : NetPrefLibrary.h
  • NetPrefRecSave() : NetPrefLibrary.h
  • NetPrefRecShortFieldGet() : NetPrefLibrary.h
  • NetPrefUpdateFromRadioNV() : NetPrefLibrary.h
  • NetPrefUtilDefWirelessDriverIDGet() : NetPrefLibrary.h
  • NetPrefUtilPlatformIDGet() : NetPrefLibrary.h
  • NetPrefUtilZStringListSizeGet() : NetPrefLibrary.h
  • NetServicesGetChannel() : PalmNetServices.h
  • NetServicesGetChannelList() : PalmNetServices.h
  • NetServicesGetCommsQuality() : PalmNetServices.h
  • NetServicesGetDeviceInfo() : PalmNetServices.h
  • NetServicesGetHWAddr() : PalmNetServices.h
  • NetServicesGetPowerState() : PalmNetServices.h
  • NetServicesGetRadioState() : PalmNetServices.h
  • NetServicesGetScanResults() : PalmNetServices.h
  • NetServicesProfileAdd() : PalmNetServices.h
  • NetServicesProfileDelete() : PalmNetServices.h
  • NetServicesProfileFind() : PalmNetServices.h
  • NetServicesProfileGetInfo() : PalmNetServices.h
  • NetServicesProfileGetOrder() : PalmNetServices.h
  • NetServicesProfileRead() : PalmNetServices.h
  • NetServicesProfileSetOrder() : PalmNetServices.h
  • NetServicesProfileWrite() : PalmNetServices.h
  • NetServicesSetRadioState() : PalmNetServices.h
  • NetServicesStartScan() : PalmNetServices.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:38 2008 for Palm API Guide


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • b
  • c
  • d
  • f
  • g
  • h
  • i
  • l
  • n
  • p
  • s
  • t
  • v

- c -

  • CameraLibCapture() : CameraLib.h
  • CameraLibClose() : CameraLib.h
  • CameraLibOpen() : CameraLib.h
  • CameraLibPreview() : CameraLib.h
  • CameraLibPreviewStart() : CameraLib.h
  • CameraLibPreviewStop() : CameraLib.h
  • CameraLibRegisterGet() : CameraLib.h
  • CameraLibRegisterSet() : CameraLib.h
  • CameraLibSleep() : CameraLib.h
  • CameraLibWake() : CameraLib.h
  • CamLibClose() : palmOneCamera.h
  • CamLibControl() : palmOneCamera.h
  • CamLibGetVersion() : palmOneCamera.h
  • CamLibOpen() : palmOneCamera.h
  • CamLibSleep() : palmOneCamera.h
  • CamLibWake() : palmOneCamera.h
  • CCustomLibClose() : CarrierCustomLib.h
  • CCustomLibGetCarrierCode() : CarrierCustomLib.h
  • CCustomLibGetCarrierCodeLength() : CarrierCustomLib.h
  • CCustomLibGetCarrierSetting() : CarrierCustomLib.h
  • CCustomLibOpen() : CarrierCustomLib.h
  • CCustomLibSleep() : CarrierCustomLib.h
  • CCustomLibVersionGet() : CarrierCustomLib.h
  • CCustomLibWake() : CarrierCustomLib.h
  • CodecMgrClose() : palmOneCodecPluginMgr.h
  • CodecMgrCreateSession() : palmOneCodecPluginMgr.h
  • CodecMgrCreateSessionByID() : palmOneCodecPluginMgr.h
  • CodecMgrCustomControl() : palmOneCodecPluginMgr.h
  • CodecMgrDeleteSession() : palmOneCodecPluginMgr.h
  • CodecMgrEncodeDecode() : palmOneCodecPluginMgr.h
  • CodecMgrEnumerateFormats() : palmOneCodecPluginMgr.h
  • CodecMgrGetMaxDestBufferSize() : palmOneCodecPluginMgr.h
  • CodecMgrGetSessionInfo() : palmOneCodecPluginMgr.h
  • CodecMgrIsFormatSupported() : palmOneCodecPluginMgr.h
  • CodecMgrLibAPIVersion() : palmOneCodecPluginMgr.h
  • CodecMgrOpen() : palmOneCodecPluginMgr.h
  • CodecMgrResetSession() : palmOneCodecPluginMgr.h
  • CodecMgrSleep() : palmOneCodecPluginMgr.h
  • CodecMgrWake() : palmOneCodecPluginMgr.h
  • ContactsAddContact() : Contacts.h
  • ContactsCategoryFind() : Contacts.h
  • ContactsCloseSession() : Contacts.h
  • ContactsCreateHandle() : Contacts.h
  • ContactsDeleteContact() : Contacts.h
  • ContactsDoesFieldExist() : Contacts.h
  • ContactsGetBinaryField() : Contacts.h
  • ContactsGetCategoryList() : Contacts.h
  • ContactsGetCategoryName() : Contacts.h
  • ContactsGetContact() : Contacts.h
  • ContactsGetDateField() : Contacts.h
  • ContactsGetFieldLabel() : Contacts.h
  • ContactsGetFirstContact() : Contacts.h
  • ContactsGetLabelText() : Contacts.h
  • ContactsGetLastError() : Contacts.h
  • ContactsGetNextCategory() : Contacts.h
  • ContactsGetNextContact() : Contacts.h
  • ContactsGetNumRecords() : Contacts.h
  • ContactsGetRingtoneForCategory() : Contacts.h
  • ContactsGetStringField() : Contacts.h
  • ContactsGetUInt16Field() : Contacts.h
  • ContactsGetUInt32Field() : Contacts.h
  • ContactsGetUInt8Field() : Contacts.h
  • ContactsGetVersion() : Contacts.h
  • ContactsIsEmptyContact() : Contacts.h
  • ContactsLib_CloseLibrary() : Contacts.h
  • ContactsLib_OpenLibrary() : Contacts.h
  • ContactsLookUpString() : Contacts.h
  • ContactsOpenSession() : Contacts.h
  • ContactsPosInCategory() : Contacts.h
  • ContactsReleaseHandle() : Contacts.h
  • ContactsRenameCustomLabel() : Contacts.h
  • ContactsSeekRecord() : Contacts.h
  • ContactsSetBinaryField() : Contacts.h
  • ContactsSetCategoryName() : Contacts.h
  • ContactsSetDateField() : Contacts.h
  • ContactsSetFieldLabel() : Contacts.h
  • ContactsSetStringField() : Contacts.h
  • ContactsSetUInt16Field() : Contacts.h
  • ContactsSetUInt8Field() : Contacts.h
  • ContactsUpdateContact() : Contacts.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:38 2008 for Palm API Guide


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • b
  • c
  • d
  • f
  • g
  • h
  • i
  • l
  • n
  • p
  • s
  • t
  • v

- d -

  • DefaultHelperLibClose() : DefaultHelperLib.h
  • DefaultHelperLibGetDefaultHelper() : DefaultHelperLib.h
  • DefaultHelperLibOpen() : DefaultHelperLib.h
  • DefaultHelperLibSetDefaultHelper() : DefaultHelperLib.h
  • DefaultHelperLibSleep() : DefaultHelperLib.h
  • DefaultHelperLibWake() : DefaultHelperLib.h
  • DexGetDisplayAddress() : PalmDisplayExtent.h
  • DexGetDisplayDimensions() : PalmDisplayExtent.h
  • DmSyncDatabase() : PmPalmOSNVFS.h
  • DoFontDialog() : palmOneVMFontLib.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:38 2008 for Palm API Guide


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • b
  • c
  • d
  • f
  • g
  • h
  • i
  • l
  • n
  • p
  • s
  • t
  • v

- f -

  • FavDBLibClose() : FavoritesDBLib.h
  • FavDBLibGetRecordId() : FavoritesDBLib.h
  • FavDBLibGetRecordLabel() : FavoritesDBLib.h
  • FavDBLibGetSpeedDialInfo() : FavoritesDBLib.h
  • FavDBLibIsFavoriteWithId() : FavoritesDBLib.h
  • FavDBLibLookupInSpeedDialDB() : FavoritesDBLib.h
  • FavDBLibNewAppFavorite() : FavoritesDBLib.h
  • FavDBLibNewEmailFavorite() : FavoritesDBLib.h
  • FavDBLibNewMsgFavorite() : FavoritesDBLib.h
  • FavDBLibNewPhoneFavorite() : FavoritesDBLib.h
  • FavDBLibNewPhoneViewFavorite() : FavoritesDBLib.h
  • FavDBLibNewWebFavorite() : FavoritesDBLib.h
  • FavDBLibOpen() : FavoritesDBLib.h
  • FavDBLibResolveAddress() : FavoritesDBLib.h
  • FavDBLibSeekSpeedDialRecord() : FavoritesDBLib.h
  • FavDBLibSleep() : FavoritesDBLib.h
  • FavDBLibWake() : FavoritesDBLib.h
  • FileBrowserLibAccept() : FileBrowserLib68K.h
  • FileBrowserLibClose() : FileBrowserLib68K.h
  • FileBrowserLibConnect() : FileBrowserLib68K.h
  • FileBrowserLibControl() : FileBrowserLib68K.h
  • FileBrowserLibDisconnect() : FileBrowserLib68K.h
  • FileBrowserLibGet() : FileBrowserLib68K.h
  • FileBrowserLibHandleEvent() : FileBrowserLib68K.h
  • FileBrowserLibOpen() : FileBrowserLib68K.h
  • FileBrowserLibParseFileURL() : FileBrowserLib68K.h
  • FileBrowserLibPut() : FileBrowserLib68K.h
  • FileBrowserLibReceive() : FileBrowserLib68K.h
  • FileBrowserLibRequest() : FileBrowserLib68K.h
  • FileBrowserLibSend() : FileBrowserLib68K.h
  • FileBrowserLibShowMultiselectDialog() : FileBrowserLib68K.h
  • FileBrowserLibShowOpenDialog() : FileBrowserLib68K.h
  • FileBrowserLibShowSaveAsDialog() : FileBrowserLib68K.h
  • FileBrowserLibSleep() : FileBrowserLib68K.h
  • FileBrowserLibWake() : FileBrowserLib68K.h
  • FrmCountObjectsInNavOrder() : HsNav.h
  • FrmGetNavEntry() : HsNav.h
  • FrmGetNavOrder() : HsNav.h
  • FrmGetNavState() : HsNav.h
  • FrmNavDrawFocusRing() : HsNav.h
  • FrmNavGetFocusRingInfo() : HsNav.h
  • FrmNavObjectTakeFocus() : HsNav.h
  • FrmNavRemoveFocusRing() : HsNav.h
  • FrmSetNavEntry() : HsNav.h
  • FrmSetNavOrder() : HsNav.h
  • FrmSetNavState() : HsNav.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:38 2008 for Palm API Guide


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • b
  • c
  • d
  • f
  • g
  • h
  • i
  • l
  • n
  • p
  • s
  • t
  • v

- g -

  • GoLcdGetBounds() : PalmGoLCD.h
  • GoLcdGetGsiState() : PalmGoLCD.h
  • GoLcdGetInkState() : PalmGoLCD.h
  • GoLcdGetStatus() : PalmGoLCD.h
  • GoLcdGetTimeout() : PalmGoLCD.h
  • GoLcdLibClose() : PalmGoLCD.h
  • GoLcdLibOpen() : PalmGoLCD.h
  • GoLcdSetBounds() : PalmGoLCD.h
  • GoLcdSetGsiState() : PalmGoLCD.h
  • GoLcdSetInkState() : PalmGoLCD.h
  • GoLcdSetStatus() : PalmGoLCD.h
  • GoLcdSetTimeout() : PalmGoLCD.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:38 2008 for Palm API Guide


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • b
  • c
  • d
  • f
  • g
  • h
  • i
  • l
  • n
  • p
  • s
  • t
  • v

- h -

  • HALAttnGetPalmLedAttributes() : PalmLED.h
  • HALAttnSetPalmLedAttributes() : PalmLED.h
  • HRTimeLibClose() : palmOneHiResTimer.h , PalmHiResTime.h
  • HRTimeLibGetTime() : PalmHiResTime.h , palmOneHiResTimer.h
  • HRTimeLibOpen() : palmOneHiResTimer.h , PalmHiResTime.h
  • HRTimeLibTicksPerSecond() : PalmHiResTime.h , palmOneHiResTimer.h
  • HS_HTTPLibAuthCacheGetChallengeTokenSS() : HS_HTTPLib68K.h
  • HS_HTTPLibAuthInfoPass() : HS_HTTPLib68K.h
  • HS_HTTPLibAuthInfoRealm() : HS_HTTPLib68K.h
  • HS_HTTPLibAuthInfoTidy() : HS_HTTPLib68K.h
  • HS_HTTPLibAuthInfoUser() : HS_HTTPLib68K.h
  • HS_HTTPLibCertBeginPeekIssuerRDN() : HS_HTTPLib68K.h
  • HS_HTTPLibCertBeginPeekSubjectRDN() : HS_HTTPLib68K.h
  • HS_HTTPLibCertEndPeekIssuerRDN() : HS_HTTPLib68K.h
  • HS_HTTPLibCertEndPeekSubjectRDN() : HS_HTTPLib68K.h
  • HS_HTTPLibCertListBeginDecode() : HS_HTTPLib68K.h
  • HS_HTTPLibCertListClone() : HS_HTTPLib68K.h
  • HS_HTTPLibCertListDelete() : HS_HTTPLib68K.h
  • HS_HTTPLibCertListEndDecode() : HS_HTTPLib68K.h
  • HS_HTTPLibCertListGetCipherInfo() : HS_HTTPLib68K.h
  • HS_HTTPLibCertListImportCert() : HS_HTTPLib68K.h
  • HS_HTTPLibCertListLength() : HS_HTTPLib68K.h
  • HS_HTTPLibCertListLock() : HS_HTTPLib68K.h
  • HS_HTTPLibCertListNew() : HS_HTTPLib68K.h
  • HS_HTTPLibCertListType() : HS_HTTPLib68K.h
  • HS_HTTPLibCertListUnlock() : HS_HTTPLib68K.h
  • HS_HTTPLibCertPeekIssuerRDN() : HS_HTTPLib68K.h
  • HS_HTTPLibCertPeekIssuerRDNStrType() : HS_HTTPLib68K.h
  • HS_HTTPLibCertPeekRSAPublicKeyBits() : HS_HTTPLib68K.h
  • HS_HTTPLibCertPeekSerialNumber() : HS_HTTPLib68K.h
  • HS_HTTPLibCertPeekSignAlgo() : HS_HTTPLib68K.h
  • HS_HTTPLibCertPeekSubjectRDN() : HS_HTTPLib68K.h
  • HS_HTTPLibCertPeekSubjectRDNStrType() : HS_HTTPLib68K.h
  • HS_HTTPLibCertPeekValidityEnd() : HS_HTTPLib68K.h
  • HS_HTTPLibCertPeekValidityStart() : HS_HTTPLib68K.h
  • HS_HTTPLibCertPeekVersion() : HS_HTTPLib68K.h
  • HS_HTTPLibClearDNSCache() : HS_HTTPLib68K.h
  • HS_HTTPLibClientCertListClone() : HS_HTTPLib68K.h
  • HS_HTTPLibClientCertListDelete() : HS_HTTPLib68K.h
  • HS_HTTPLibClientCertListIsValid() : HS_HTTPLib68K.h
  • HS_HTTPLibClientCertListLength() : HS_HTTPLib68K.h
  • HS_HTTPLibClientCertListNew() : HS_HTTPLib68K.h
  • HS_HTTPLibClientCertListSetValid() : HS_HTTPLib68K.h
  • HS_HTTPLibClientCertSelect() : HS_HTTPLib68K.h
  • HS_HTTPLibClose() : HS_HTTPLib68K.h
  • HS_HTTPLibCloseAllKeepAlive() : HS_HTTPLib68K.h
  • HS_HTTPLibCookieMakeEmpty() : HS_HTTPLib68K.h
  • HS_HTTPLibDataHandle_Delete() : HS_HTTPLib68K.h
  • HS_HTTPLibDataHandle_Length() : HS_HTTPLib68K.h
  • HS_HTTPLibDataHandle_Lock() : HS_HTTPLib68K.h
  • HS_HTTPLibDataHandle_Unlock() : HS_HTTPLib68K.h
  • HS_HTTPLibFinalize() : HS_HTTPLib68K.h
  • HS_HTTPLibFindAuthCandidate() : HS_HTTPLib68K.h
  • HS_HTTPLibFindAuthInfo() : HS_HTTPLib68K.h
  • HS_HTTPLibFixedString_Delete() : HS_HTTPLib68K.h
  • HS_HTTPLibFixedString_Length() : HS_HTTPLib68K.h
  • HS_HTTPLibFixedString_Lock() : HS_HTTPLib68K.h
  • HS_HTTPLibFixedString_Unlock() : HS_HTTPLib68K.h
  • HS_HTTPLibFixedStringNew() : HS_HTTPLib68K.h
  • HS_HTTPLibHeaderSplitByX() : HS_HTTPLib68K.h
  • HS_HTTPLibInitialize() : HS_HTTPLib68K.h
  • HS_HTTPLibIsHTTP11OverProxy() : HS_HTTPLib68K.h
  • HS_HTTPLibIsSendCookie() : HS_HTTPLib68K.h
  • HS_HTTPLibIsSendReferer() : HS_HTTPLib68K.h
  • HS_HTTPLibIsUseProxy() : HS_HTTPLib68K.h
  • HS_HTTPLibLoadCookiesEntries() : HS_HTTPLib68K.h
  • HS_HTTPLibMakeAuthInfo() : HS_HTTPLib68K.h
  • HS_HTTPLibMakeCertList() : HS_HTTPLib68K.h
  • HS_HTTPLibMakeCookiesString() : HS_HTTPLib68K.h
  • HS_HTTPLibMakeProxy() : HS_HTTPLib68K.h
  • HS_HTTPLibOpen() : HS_HTTPLib68K.h
  • HS_HTTPLibOpenCount() : HS_HTTPLib68K.h
  • HS_HTTPLibRegisterSSLClass() : HS_HTTPLib68K.h
  • HS_HTTPLibSaveCookiesEntries() : HS_HTTPLib68K.h
  • HS_HTTPLibServerCertConfirm() : HS_HTTPLib68K.h
  • HS_HTTPLibSetConnectTimeOut() : HS_HTTPLib68K.h
  • HS_HTTPLibSetCookie() : HS_HTTPLib68K.h
  • HS_HTTPLibSetCookieMax() : HS_HTTPLib68K.h
  • HS_HTTPLibSetCookieMode() : HS_HTTPLib68K.h
  • HS_HTTPLibSetCookieX() : HS_HTTPLib68K.h
  • HS_HTTPLibSetDefaultHeaders() : HS_HTTPLib68K.h
  • HS_HTTPLibSetDNSMaxRetry() : HS_HTTPLib68K.h
  • HS_HTTPLibSetDNSRetryInterval() : HS_HTTPLib68K.h
  • HS_HTTPLibSetHTTP11OverProxy() : HS_HTTPLib68K.h
  • HS_HTTPLibSetHTTPPort() : HS_HTTPLib68K.h
  • HS_HTTPLibSetHTTPSPort() : HS_HTTPLib68K.h
  • HS_HTTPLibSetMaxKeepAliveTimeout() : HS_HTTPLib68K.h
  • HS_HTTPLibSetMaxRequestBody() : HS_HTTPLib68K.h
  • HS_HTTPLibSetMaxRequestHeader() : HS_HTTPLib68K.h
  • HS_HTTPLibSetNetLibProc() : HS_HTTPLib68K.h
  • HS_HTTPLibSetProxy() : HS_HTTPLib68K.h
  • HS_HTTPLibSetReqTimeOut() : HS_HTTPLib68K.h
  • HS_HTTPLibSetRspTimeOut() : HS_HTTPLib68K.h
  • HS_HTTPLibSetSendCookie() : HS_HTTPLib68K.h
  • HS_HTTPLibSetSendProxyKeepAlive() : HS_HTTPLib68K.h
  • HS_HTTPLibSetSendReferer() : HS_HTTPLib68K.h
  • HS_HTTPLibSetSSLClientCertSelectProc() : HS_HTTPLib68K.h
  • HS_HTTPLibSetSSLServerCertConfirmProc() : HS_HTTPLib68K.h
  • HS_HTTPLibSetSSLVersionFlag() : HS_HTTPLib68K.h
  • HS_HTTPLibSetTunnelingCallback() : HS_HTTPLib68K.h
  • HS_HTTPLibSetUseProxy() : HS_HTTPLib68K.h
  • HS_HTTPLibSetUserAgent() : HS_HTTPLib68K.h
  • HS_HTTPLibSetUseragentSelectionRule() : HS_HTTPLib68K.h
  • HS_HTTPLibSetUserPass() : HS_HTTPLib68K.h
  • HS_HTTPLibSetUserPassX() : HS_HTTPLib68K.h
  • HS_HTTPLibSetWakeUpCallback() : HS_HTTPLib68K.h
  • HS_HTTPLibSleep() : HS_HTTPLib68K.h
  • HS_HTTPLibSSLClass() : HS_HTTPLib68K.h
  • HS_HTTPLibSSLCloseCertDB() : HS_HTTPLib68K.h
  • HS_HTTPLibSSLOpenCertDB() : HS_HTTPLib68K.h
  • HS_HTTPLibSSLTimeout() : HS_HTTPLib68K.h
  • HS_HTTPLibStreamAddHeader() : HS_HTTPLib68K.h
  • HS_HTTPLibStreamAddHeaderLine() : HS_HTTPLib68K.h
  • HS_HTTPLibStreamClose() : HS_HTTPLib68K.h
  • HS_HTTPLibStreamCreateRequest() : HS_HTTPLib68K.h
  • HS_HTTPLibStreamCreateRequestWithChunkEncoding() : HS_HTTPLib68K.h
  • HS_HTTPLibStreamDelete() : HS_HTTPLib68K.h
  • HS_HTTPLibStreamGetContentLength() : HS_HTTPLib68K.h
  • HS_HTTPLibStreamGetEntityLength() : HS_HTTPLib68K.h
  • HS_HTTPLibStreamGetFlag() : HS_HTTPLib68K.h
  • HS_HTTPLibStreamGetHeader() : HS_HTTPLib68K.h
  • HS_HTTPLibStreamGetHeaderWithOffset() : HS_HTTPLib68K.h
  • HS_HTTPLibStreamGetRequestSent() : HS_HTTPLib68K.h
  • HS_HTTPLibStreamGetResponseHeader() : HS_HTTPLib68K.h
  • HS_HTTPLibStreamGetResponseHeaderLength() : HS_HTTPLib68K.h
  • HS_HTTPLibStreamGetScheme() : HS_HTTPLib68K.h
  • HS_HTTPLibStreamGetState() : HS_HTTPLib68K.h
  • HS_HTTPLibStreamGetStatusCode() : HS_HTTPLib68K.h
  • HS_HTTPLibStreamIsHeaderReceived() : HS_HTTPLib68K.h
  • HS_HTTPLibStreamNew() : HS_HTTPLib68K.h
  • HS_HTTPLibStreamReceiveResponse() : HS_HTTPLib68K.h
  • HS_HTTPLibStreamResumeTimer() : HS_HTTPLib68K.h
  • HS_HTTPLibStreamSendRequest() : HS_HTTPLib68K.h
  • HS_HTTPLibStreamSendRequestWithChunkEncoding() : HS_HTTPLib68K.h
  • HS_HTTPLibStreamSendRequestWithPostData() : HS_HTTPLib68K.h
  • HS_HTTPLibStreamSetPostData() : HS_HTTPLib68K.h
  • HS_HTTPLibStreamSuspendTimer() : HS_HTTPLib68K.h
  • HS_HTTPLibString_Delete() : HS_HTTPLib68K.h
  • HS_HTTPLibString_Length() : HS_HTTPLib68K.h
  • HS_HTTPLibString_Lock() : HS_HTTPLib68K.h
  • HS_HTTPLibString_Unlock() : HS_HTTPLib68K.h
  • HS_HTTPLibStringNew() : HS_HTTPLib68K.h
  • HS_HTTPLibURLString_Delete() : HS_HTTPLib68K.h
  • HS_HTTPLibURLString_Length() : HS_HTTPLib68K.h
  • HS_HTTPLibURLString_Lock() : HS_HTTPLib68K.h
  • HS_HTTPLibURLString_Unlock() : HS_HTTPLib68K.h
  • HS_HTTPLibURLStringNew() : HS_HTTPLib68K.h
  • HS_HTTPLibVHandle_Delete() : HS_HTTPLib68K.h
  • HS_HTTPLibVHandle_Length() : HS_HTTPLib68K.h
  • HS_HTTPLibVHandle_Lock() : HS_HTTPLib68K.h
  • HS_HTTPLibVHandle_Unlock() : HS_HTTPLib68K.h
  • HS_HTTPLibWake() : HS_HTTPLib68K.h
  • HsAboutHandspringApp() : HsExt.h
  • HsAttrGet() : HsExt.h
  • HsAttrSet() : HsExt.h
  • HsBrowseUrl() : HsExt.h
  • HsCreateNewEmail() : HsExt.h
  • HsCreateNewMessage() : HsExt.h
  • HsCurrentLightCircumstance() : HsExt.h
  • HsEvtMetaEvent() : HsExt.h
  • HsExtDoSaveAsDialog() : HsExt.h
  • HsExtExgLocalAccept() : HsExgMgr.h
  • HsExtExgLocalDisconnect() : HsExgMgr.h
  • HsExtExgSelectTarget() : HsExgMgr.h
  • HsGetARMActiveFormPtr() : HsExt.h
  • HsGetPhoneLibrary() : HsExt.h
  • HsGetTrapAddress() : HsExt.h
  • HsGetVersionString() : HsExt.h
  • HsGrfGetStateExt() : HsExt.h
  • HsGrfSetStateExt() : HsExt.h
  • HsIndicatorState() : HsExt.h
  • HsInfo() : HsExt.h
  • HsIsHTTPLibraryLoaded() : HsExt.h
  • HsKeyChrCodeToKeyCode() : HsExt.h
  • HsKeyCurrentStateExt() : HsExt.h
  • HsKeyEnableKey() : HsExt.h
  • HsKeyEventIsFromKeyboard() : HsExt.h
  • HsKeyKeyCodeToChrCode() : HsExt.h
  • HsKeySetMaskExt() : HsExt.h
  • HsKeysPressed() : HsExt.h
  • HsKeyStop() : HsExt.h
  • HsLightCircumstance() : HsExt.h
  • HsLightMode() : HsExt.h
  • HsNavDrawFocusRing() : HsExt.h
  • HsNavGetFocusColor() : HsExt.h
  • HsNavGetFocusRingInfo() : HsExt.h
  • HsNavLstGetTempSelection() : HsExt.h
  • HsNavLstSetTempSelection() : HsExt.h
  • HsNavObjectTakeFocus() : HsExt.h
  • HsNavRemoveFocusRing() : HsExt.h
  • HsNavSetFocusColor() : HsExt.h
  • HsNetworkDropConnection() : HsExt.h
  • HsOpenDialNumberDialog() : HsExt.h
  • HsPostProcessPopupList() : HsExtKbdUtils.h
  • HsPrefGet() : HsExt.h
  • HsPrefSet() : HsExt.h
  • HsPutObjectAfterTitle() : HsExt.h
  • HsSndClose() : HsSoundLib.h
  • HsSndFormatPlay() : HsSoundLib.h
  • HsSndFormatRecord() : HsSoundLib.h
  • HsSndGetUserVolume() : HsSoundLib.h
  • HsSndGetVersion() : HsSoundLib.h
  • HsSndOpen() : HsSoundLib.h
  • HsSndPortGetInfo() : HsSoundLib.h
  • HsSndPortSetParam() : HsSoundLib.h
  • HsSndSetUserVolume() : HsSoundLib.h
  • HsSndSwitchGetPort() : HsSoundLib.h
  • HsSndSwitchSetPort() : HsSoundLib.h
  • HsSndTonePlay() : HsSoundLib.h
  • HsSndToneStop() : HsSoundLib.h
  • HsSpringboardNotSupported() : HsExt.h
  • HsStartMemoryTracing() : HsExt.h
  • HsStatusSetGadgetType() : HsExt.h
  • HsStatusUpdateGadgets() : HsExt.h
  • HsTurnRadioOn() : HsExt.h
  • HsTwoFontSelect() : HsExt.h
  • HsTxtIsAscii() : HsExt.h
  • HsTxtNumChars() : HsExt.h
  • HsTxtPrepFindString() : HsExt.h
  • HsTxtTruncateString() : HsExt.h
  • HsUnimplemented() : HsExt.h
  • HsUtilBbutHitBigButton() : HsExtUtilBigButton.h
  • HsUtilBbutInstallFromResource() : HsExtUtilBigButton.h
  • HsUtilBbutInstallNewButton() : HsExtUtilBigButton.h
  • HsUtilBbutSetBitmap() : HsExtUtilBigButton.h
  • HsUtilBbutSetLabel() : HsExtUtilBigButton.h
  • HtmlLibAbortRenderData() : HtmlLib68K.h
  • HtmlLibAddImageData() : HtmlLib68K.h
  • HtmlLibAddTextData() : HtmlLib68K.h
  • HtmlLibCanScroll() : HtmlLib68K.h
  • HtmlLibClearScreen() : HtmlLib68K.h
  • HtmlLibClose() : HtmlLib68K.h
  • HtmlLibCreateContentObject() : HtmlLib68K.h
  • HtmlLibDestroyContentObject() : HtmlLib68K.h
  • HtmlLibFinalize() : HtmlLib68K.h
  • HtmlLibFindText() : HtmlLib68K.h
  • HtmlLibGetTargetInfo() : HtmlLib68K.h
  • HtmlLibGetTextSelection() : HtmlLib68K.h
  • HtmlLibGetVScrollPosition() : HtmlLib68K.h
  • HtmlLibInitialize() : HtmlLib68K.h
  • HtmlLibInitializeWithHeapSize() : HtmlLib68K.h
  • HtmlLibNotifyUIEvent() : HtmlLib68K.h
  • HtmlLibOpen() : HtmlLib68K.h
  • HtmlLibProgress() : HtmlLib68K.h
  • HtmlLibRedrawScreen() : HtmlLib68K.h
  • HtmlLibRenderData() : HtmlLib68K.h
  • HtmlLibResetFocusInfo() : HtmlLib68K.h
  • HtmlLibResizeScreen() : HtmlLib68K.h
  • HtmlLibSetBiggerFont() : HtmlLib68K.h
  • HtmlLibSetDisplayMode() : HtmlLib68K.h
  • HtmlLibSetFocusStatus() : HtmlLib68K.h
  • HtmlLibSetFormWidgetProc() : HtmlLib68K.h
  • HtmlLibSetImageMemoryLimit() : HtmlLib68K.h
  • HtmlLibSetInclusionCallback() : HtmlLib68K.h
  • HtmlLibSetLinkSelectionCallback() : HtmlLib68K.h
  • HtmlLibSetScanPhoneNumberCallback() : HtmlLib68K.h
  • HtmlLibSetScrollbarMode() : HtmlLib68K.h
  • HtmlLibSetScrollbars() : HtmlLib68K.h
  • HtmlLibSetSubmitFormCallback() : HtmlLib68K.h
  • HtmlLibSetVScrollPosition() : HtmlLib68K.h
  • HtmlLibSleep() : HtmlLib68K.h
  • HtmlLibWake() : HtmlLib68K.h
  • HWUBlinkLED() : HardwareUtils68K.h
  • HWUClose() : HardwareUtils68K.h
  • HWUEnableDisplay() : HardwareUtils68K.h
  • HWUGetDisplayState() : HardwareUtils68K.h
  • HWUOpen() : HardwareUtils68K.h
  • HWUSetBlinkRate() : HardwareUtils68K.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:38 2008 for Palm API Guide


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • b
  • c
  • d
  • f
  • g
  • h
  • i
  • l
  • n
  • p
  • s
  • t
  • v

- i -

  • ImageLibBitmapDelete() : ImageLib.h
  • ImageLibCameraExists() : ImageLib.h
  • ImageLibCheckLockedImages() : ImageLib.h
  • ImageLibClose() : ImageLib.h
  • ImageLibCopyImage() : ImageLib.h
  • ImageLibCopyImageFromVFS() : ImageLib.h
  • ImageLibCopyImageToBuffer() : ImageLib.h
  • ImageLibCopyImageToFile() : ImageLib.h
  • ImageLibCopyImageToVFS() : ImageLib.h
  • ImageLibDeleteImage() : ImageLib.h
  • ImageLibDoAttachImageDialog() : ImageLib.h
  • ImageLibDrawJPEG() : ImageLib.h
  • ImageLibFindImageByID() : ImageLib.h
  • ImageLibGetAveragePictureSize() : ImageLib.h
  • ImageLibGetDimensions() : ImageLib.h
  • ImageLibGetDimensionsJPEG() : ImageLib.h
  • ImageLibGetDimensionsVFS() : ImageLib.h
  • ImageLibGetImageDatabases() : ImageLib.h
  • ImageLibGetImageID() : ImageLib.h
  • ImageLibGetImageInfo() : ImageLib.h
  • ImageLibGetJPEGQuality() : ImageLib.h
  • ImageLibGetVersion() : ImageLib.h
  • ImageLibImageBitmapCreate() : ImageLib.h
  • ImageLibImageBitmapCreateFromVFS() : ImageLib.h
  • ImageLibImageBitmapFill() : ImageLib.h
  • ImageLibImageBitmapFillFromVFS() : ImageLib.h
  • ImageLibImageCapture() : ImageLib.h
  • ImageLibImageDraw() : ImageLib.h
  • ImageLibImageDrawFromVFS() : ImageLib.h
  • ImageLibImageSave() : ImageLib.h
  • ImageLibInsertImageFromBuffer() : ImageLib.h
  • ImageLibInsertImageFromFile() : ImageLib.h
  • ImageLibIterateImages() : ImageLib.h
  • ImageLibIterateVFSImages() : ImageLib.h
  • ImageLibIterDeleteImage() : ImageLib.h
  • ImageLibIterDrawImage() : ImageLib.h
  • ImageLibIterDrawThumbnail() : ImageLib.h
  • ImageLibIterFree() : ImageLib.h
  • ImagelibIterGetCount() : ImageLib.h
  • ImageLibIterGetDimensions() : ImageLib.h
  • ImageLibIterGetImageInfo() : ImageLib.h
  • ImageLibIterRefresh() : ImageLib.h
  • ImageLibIterRemoveImage() : ImageLib.h
  • ImageLibIterResize() : ImageLib.h
  • ImageLibIterSearch() : ImageLib.h
  • ImageLibIterSort() : ImageLib.h
  • ImageLibLockImage() : ImageLib.h
  • ImageLibOpen() : ImageLib.h
  • ImageLibPreviewBitmapCreate() : ImageLib.h
  • ImageLibPreviewBitmapFill() : ImageLib.h
  • ImageLibPreviewDraw() : ImageLib.h
  • ImageLibPreviewStart() : ImageLib.h
  • ImageLibPreviewStop() : ImageLib.h
  • ImageLibResize() : ImageLib.h
  • ImageLibResizeImage() : ImageLib.h
  • ImageLibResizeJPEG() : ImageLib.h
  • ImageLibResizeVFS() : ImageLib.h
  • ImageLibSetImageID() : ImageLib.h
  • ImageLibSetImageInfo() : ImageLib.h
  • ImageLibSetJPEGQuality() : ImageLib.h
  • ImageLibSetProgressCallback() : ImageLib.h
  • ImageLibThumbnailBitmapCreate() : ImageLib.h
  • ImageLibThumbnailBitmapCreateFromVFS() : ImageLib.h
  • ImageLibThumbnailBitmapFill() : ImageLib.h
  • ImageLibThumbnailBitmapFillFromVFS() : ImageLib.h
  • ImageLibThumbnailDraw() : ImageLib.h
  • ImageLibThumbnailDrawFromVFS() : ImageLib.h
  • ImageLibTurnCameraOff() : ImageLib.h
  • InitFontUI() : palmOneVMFontLib.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:38 2008 for Palm API Guide


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • b
  • c
  • d
  • f
  • g
  • h
  • i
  • l
  • n
  • p
  • s
  • t
  • v

- p -

  • PalmLedClose() : PalmLED.h
  • PalmLedOpen() : PalmLED.h
  • PalmLedSleep() : PalmLED.h
  • PalmLedWake() : PalmLED.h
  • PalmOneStatusBarGetAttribute() : palmOneStatusBar.h
  • PalmOneStatusBarHide() : palmOneStatusBar.h
  • PalmOneStatusBarLibClose() : palmOneStatusBar.h
  • PalmOneStatusBarLibOpen() : palmOneStatusBar.h
  • PalmOneStatusBarShow() : palmOneStatusBar.h
  • PalmPhotoAddImage() : palmOnePhoto.h
  • PalmPhotoAddImageV2() : palmOnePhoto.h
  • PalmPhotoAlbumCount() : palmOnePhoto.h
  • PalmPhotoAlbumCountV2() : palmOnePhoto.h
  • PalmPhotoCaptureImageV2() : palmOnePhoto.h
  • PalmPhotoCloseImage() : palmOnePhoto.h
  • PalmPhotoCloseImageV2() : palmOnePhoto.h
  • PalmPhotoConvertImageV2() : palmOnePhoto.h
  • PalmPhotoCreateImage() : palmOnePhoto.h
  • PalmPhotoCreateImageV2() : palmOnePhoto.h
  • PalmPhotoCropImageV2() : palmOnePhoto.h
  • PalmPhotoDeleteAlbum() : palmOnePhoto.h
  • PalmPhotoDeleteImage() : palmOnePhoto.h
  • PalmPhotoDisplayImage() : palmOnePhoto.h
  • PalmPhotoDisplayImageToSizeV3() : palmOnePhoto.h
  • PalmPhotoDisplayThumbnailV3() : palmOnePhoto.h
  • PalmPhotoFreeSelections() : palmOnePhoto.h
  • PalmPhotoFreeSelectionsV2() : palmOnePhoto.h
  • PalmPhotoGetAlbumID() : palmOnePhoto.h
  • PalmPhotoGetAlbumIDV2() : palmOnePhoto.h
  • PalmPhotoGetAlbumName() : palmOnePhoto.h
  • PalmPhotoGetImageExtraInfo() : palmOnePhoto.h
  • PalmPhotoGetImageExtraInfoSize() : palmOnePhoto.h
  • PalmPhotoGetImageInfo() : palmOnePhoto.h
  • PalmPhotoGetLastErrV2() : palmOnePhoto.h
  • PalmPhotoGetSupportedCaptureResolutionsV3() : palmOnePhoto.h
  • PalmPhotoGetThumbSize() : palmOnePhoto.h
  • PalmPhotoImageCount() : palmOnePhoto.h
  • PalmPhotoIsCameraAvailableV3() : palmOnePhoto.h
  • PalmPhotoLibClose() : palmOnePhoto.h
  • PalmPhotoLibGetVersion() : palmOnePhoto.h
  • PalmPhotoLibOpen() : palmOnePhoto.h
  • PalmPhotoLibSleep() : palmOnePhoto.h
  • PalmPhotoLibWake() : palmOnePhoto.h
  • PalmPhotoNewAlbum() : palmOnePhoto.h
  • PalmPhotoNewAlbumV2() : palmOnePhoto.h
  • PalmPhotoOpenImage() : palmOnePhoto.h
  • PalmPhotoOpenImageV2() : palmOnePhoto.h
  • PalmPhotoReadImage() : palmOnePhoto.h
  • PalmPhotoRenameAlbum() : palmOnePhoto.h
  • PalmPhotoRotateImageV2() : palmOnePhoto.h
  • PalmPhotoScaleImageV2() : palmOnePhoto.h
  • PalmPhotoSelectDlg() : palmOnePhoto.h
  • PalmPhotoSelectDlgV3() : palmOnePhoto.h
  • PalmPhotoSelectImages() : palmOnePhoto.h
  • PalmPhotoSetImageExtraInfo() : palmOnePhoto.h
  • PalmPhotoWriteImage() : palmOnePhoto.h
  • PhnLibAddAddress() : HsPhoneSMS.h
  • PhnLibAddressToText() : HsPhoneSMS.h
  • PhnLibAPGetField() : HsPhoneCDMA.h
  • PhnLibAPGetNth() : HsPhoneSMS.h
  • PhnLibAttrGet() : HsPhoneMisc.h
  • PhnLibAttrSet() : HsPhoneMisc.h
  • PhnLibBoxInformation() : HsPhoneNetwork.h
  • PhnLibBoxInformationEx() : HsPhoneNetwork.h
  • PhnLibCardInfo() : HsPhoneMisc.h
  • PhnLibCardInfoEx() : HsPhoneMisc.h
  • PhnLibClose() : HsPhoneLibrary.h
  • PhnLibConnectionAvailable() : HsPhoneMisc.h
  • PhnLibContinuePhonePowerOff() : HsPhonePower.h
  • PhnLibContinuePhonePowerOn() : HsPhonePower.h
  • PhnLibCount() : HsPhoneSMS.h
  • PhnLibCRSM() : HsPhoneSecurity.h
  • PhnLibCurrentOperator() : HsPhoneNetwork.h
  • PhnLibCurrentOperatorID() : HsPhoneNetwork.h
  • PhnLibCurrentProvider() : HsPhoneNetwork.h
  • PhnLibDeactivateBarring() : HsPhoneNetwork.h
  • PhnLibDeleteMessage() : HsPhoneSMS.h
  • PhnLibDisposeAddressList() : HsPhoneSMS.h
  • PhnLibEqual() : HsPhoneSMS.h
  • PhnLibErrorRate() : HsPhoneMisc.h
  • PhnLibGetAddresses() : HsPhoneSMS.h
  • PhnLibGetBarring() : HsPhoneNetwork.h
  • PhnLibGetBaseStationIdInfo() : HsPhoneMisc.h
  • PhnLibGetBoxNumber() : HsPhoneNetwork.h
  • PhnLibGetCallCountByService() : HsPhoneMisc.h
  • PhnLibGetCallWaiting() : HsPhoneNetwork.h
  • PhnLibGetCLIP() : HsPhoneNetwork.h
  • PhnLibGetCLIR() : HsPhoneNetwork.h
  • PhnLibGetDataSessionInfo() : HsPhoneNetwork.h
  • PhnLibGetDate() : HsPhoneSMS.h
  • PhnLibGetDBRef() : HsPhoneSMS.h
  • PhnLibGetDeviceID() : HsPhoneMisc.h
  • PhnLibGetEchoCancellation() : HsPhoneMisc.h
  • PhnLibGetEnhancedRoamIndicator() : HsPhoneNetwork.h
  • PhnLibGetEquipmentMode() : HsPhoneMisc.h
  • PhnLibGetErrorText() : HsPhoneMisc.h
  • PhnLibGetFDNList() : HsPhoneGSM.h
  • PhnLibGetField() : HsPhoneSMS.h
  • PhnLibGetFlags() : HsPhoneSMS.h
  • PhnLibGetForwarding() : HsPhoneNetwork.h
  • PhnLibGetGSMCellInfo() : HsPhoneGSM.h
  • PhnLibGetHeadsetConnectedInfo() : HsPhoneMisc.h
  • PhnLibGetICCID() : HsPhoneGSM.h
  • PhnLibGetID() : HsPhoneSMS.h
  • PhnLibGetLengthDetails() : HsPhoneSMS.h
  • PhnLibGetLibAPIVersion() : HsPhoneLibrary.h
  • PhnLibGetLineState() : HsPhoneMisc.h
  • PhnLibGetMEID() : HsPhoneMisc.h
  • PhnLibGetMicrophone() : HsPhoneMisc.h
  • PhnLibGetMMSUAString() : HsPhoneMisc.h
  • PhnLibGetNoiseCancellation() : HsPhoneMisc.h
  • PhnLibGetNth() : HsPhoneSMS.h
  • PhnLibGetOperatorList() : HsPhoneNetwork.h
  • PhnLibGetOperatorLock() : HsPhoneNetwork.h
  • PhnLibGetOptions() : HsPhoneSMS.h
  • PhnLibGetOwner() : HsPhoneSMS.h
  • PhnLibGetOwnNumbers() : HsPhoneNetwork.h
  • PhnLibGetPhoneBook() : HsPhoneGSM.h
  • PhnLibGetPhoneBookIndex() : HsPhoneGSM.h
  • PhnLibGetPhoneCallStatus() : HsPhoneMisc.h
  • PhnLibGetPhoneLock() : HsPhoneSecurity.h
  • PhnLibGetRadioState() : HsPhoneMisc.h
  • PhnLibGetRemainingPasswordTries() : HsPhoneSecurity.h
  • PhnLibGetRoamPrefMode() : HsPhoneNetwork.h
  • PhnLibGetSDNList() : HsPhoneGSM.h
  • PhnLibGetServiceCentreAddress() : HsPhoneSMS.h
  • PhnLibGetSIMStatus() : HsPhoneGSM.h
  • PhnLibGetSMSGateway() : HsPhoneSMS.h
  • PhnLibGetSMSPreference() : HsPhoneSMS.h
  • PhnLibGetSMSRingInfo() : HsPhoneSMS.h
  • PhnLibGetSpn() : HsPhoneGSM.h
  • PhnLibGetStatus() : HsPhoneSMS.h
  • PhnLibGetSubstitution() : HsPhoneSMS.h
  • PhnLibGetText() : HsPhoneSMS.h
  • PhnLibGetType() : HsPhoneSMS.h
  • PhnLibGPRSAttached() : HsPhoneGSM.h
  • PhnLibGPRSPDPContextDefine() : HsPhoneGSM.h
  • PhnLibGPRSPDPContextListConstruct() : HsPhoneGSM.h
  • PhnLibGPRSPDPContextListDestruct() : HsPhoneGSM.h
  • PhnLibGPRSQualityOfServiceGet() : HsPhoneGSM.h
  • PhnLibGPRSQualityOfServiceSet() : HsPhoneGSM.h
  • PhnLibHasName() : HsPhoneSMS.h
  • PhnLibHomeOperatorID() : HsPhoneNetwork.h
  • PhnLibIsCallMuted() : HsPhoneMisc.h
  • PhnLibIsLegalCharacter() : HsPhoneSMS.h
  • PhnLibIsPhoneActivated() : HsPhoneMisc.h
  • PhnLibLength() : HsPhoneSMS.h
  • PhnLibMapCharacter() : HsPhoneSMS.h
  • PhnLibMiscDebugInfo() : HsPhoneMisc.h
  • PhnLibModulePowered() : HsPhonePower.h
  • PhnLibMute() : HsPhoneMisc.h
  • PhnLibNetworkAvailable() : HsPhoneNetwork.h
  • PhnLibNewAddress() : HsPhoneSMS.h
  • PhnLibNewAddressList() : HsPhoneSMS.h
  • PhnLibNewMessage() : HsPhoneSMS.h
  • PhnLibOpen() : HsPhoneLibrary.h
  • PhnLibQuerySMSMT() : HsPhoneSMS.h
  • PhnLibRegister() : HsPhoneLibrary.h
  • PhnLibRegistered() : HsPhoneNetwork.h
  • PhnLibReleaseDBRef() : HsPhoneSMS.h
  • PhnLibRoaming() : HsPhoneNetwork.h
  • PhnLibSATEndSession() : HsPhoneGSM.h
  • PhnLibSATGetMainMenu() : HsPhoneGSM.h
  • PhnLibSATSendRequest() : HsPhoneGSM.h
  • PhnLibSendLongDTMF() : HsPhoneGSM.h
  • PhnLibSendMessage() : HsPhoneSMS.h
  • PhnLibSendPendingMessages() : HsPhoneSMS.h
  • PhnLibSendSMSMTAck() : HsPhoneSMS.h
  • PhnLibSendUSSD() : HsPhoneGSM.h
  • PhnLibSetActiveLine() : HsPhoneGSM.h
  • PhnLibSetAddresses() : HsPhoneSMS.h
  • PhnLibSetBarring() : HsPhoneNetwork.h
  • PhnLibSetCallWaiting() : HsPhoneNetwork.h
  • PhnLibSetCLIP() : HsPhoneNetwork.h
  • PhnLibSetCLIR() : HsPhoneNetwork.h
  • PhnLibSetDate() : HsPhoneSMS.h
  • PhnLibSetEchoCancellation() : HsPhoneMisc.h
  • PhnLibSetEquipmentMode() : HsPhoneMisc.h
  • PhnLibSetFDNEntry() : HsPhoneGSM.h
  • PhnLibSetField() : HsPhoneSMS.h
  • PhnLibSetFlags() : HsPhoneSMS.h
  • PhnLibSetForwarding() : HsPhoneNetwork.h
  • PhnLibSetID() : HsPhoneSMS.h
  • PhnLibSetMicrophone() : HsPhoneMisc.h
  • PhnLibSetModulePower() : HsPhonePower.h
  • PhnLibSetNoiseCancellation() : HsPhoneMisc.h
  • PhnLibSetNth() : HsPhoneSMS.h
  • PhnLibSetNumber() : HsPhoneSMS.h
  • PhnLibSetOperator() : HsPhoneNetwork.h
  • PhnLibSetOperatorLock() : HsPhoneSecurity.h
  • PhnLibSetOptions() : HsPhoneSMS.h
  • PhnLibSetOwner() : HsPhoneSMS.h
  • PhnLibSetOwnNumbers() : HsPhoneNetwork.h
  • PhnLibSetPhoneBook() : HsPhoneGSM.h
  • PhnLibSetPhoneBookEntry() : HsPhoneGSM.h
  • PhnLibSetPhoneLock() : HsPhoneSecurity.h
  • PhnLibSetRoamPrefInfo() : HsPhoneNetwork.h
  • PhnLibSetRoamPrefMode() : HsPhoneNetwork.h
  • PhnLibSetServiceCentreAddress() : HsPhoneSMS.h
  • PhnLibSetSMSCallbackNumber() : HsPhoneSMS.h
  • PhnLibSetSMSPreference() : HsPhoneSMS.h
  • PhnLibSetSMSRingInfo() : HsPhoneSMS.h
  • PhnLibSetStatus() : HsPhoneSMS.h
  • PhnLibSetText() : HsPhoneSMS.h
  • PhnLibSignalQuality() : HsPhoneNetwork.h
  • PhnLibSignalQualityEx() : HsPhoneNetwork.h
  • PhnLibSIMInfo() : HsPhoneGSM.h
  • PhnLibSleep() : HsPhoneLibrary.h
  • PhnLibStartVibrate() : HsPhoneMisc.h
  • PhnLibStopVibrate() : HsPhoneMisc.h
  • PhnLibUninstall() : HsPhoneLibrary.h
  • PhnLibUsableSignalStrengthThreshold() : HsPhoneNetwork.h
  • PhnLibWake() : HsPhoneLibrary.h
  • PinGetCurrentPinletID() : PalmPin.h
  • PinGetInputAreaState() : PalmPin.h
  • PinGetInputMode() : PalmPin.h
  • PinLibClose() : PalmPin.h
  • PinLibOpen() : PalmPin.h
  • PinResetInputState() : PalmPin.h
  • PinSetInputAreaState() : PalmPin.h
  • PinSetInputMode() : PalmPin.h
  • PinSwitchToPinlet() : PalmPin.h
  • PmConnectorLibClose() : PmConnectorLib.h
  • PmConnectorLibControl() : PmConnectorLib.h
  • PmConnectorLibGetVersion() : PmConnectorLib.h
  • PmConnectorLibOpen() : PmConnectorLib.h
  • PmConnectorLibSetAudioInput() : PmConnectorLib.h
  • PmConnectorLibSetAudioOutput() : PmConnectorLib.h
  • PmConnectorLibSleep() : PmConnectorLib.h
  • PmConnectorLibWake() : PmConnectorLib.h
  • PmKeyAttrGet() : PmKeyLib.h
  • PmKeyAttrSet() : PmKeyLib.h
  • PmKeyChrCodeToKeyCode() : PmKeyLib.h
  • PmKeyEnableKey() : PmKeyLib.h
  • PmKeyEventIsFromKeyboard() : PmKeyLib.h
  • PmKeyKeyCodeToChrCode() : PmKeyLib.h
  • PmKeyKeysPressed() : PmKeyLib.h
  • PmKeyLibClose() : PmKeyLib.h
  • PmKeyLibOpen() : PmKeyLib.h
  • PmKeyStop() : PmKeyLib.h
  • PmSndClkGetTickCount() : HsSoundLib.h
  • PmSndClkGetTicksPerSecond() : HsSoundLib.h
  • PmSndGetPosition() : HsSoundLib.h
  • PmSysGadgetBbutHitBigButton() : PmSysGadgetLib.h
  • PmSysGadgetBbutInstallFromResource() : PmSysGadgetLib.h
  • PmSysGadgetBbutInstallNewButton() : PmSysGadgetLib.h
  • PmSysGadgetBbutSetBitmap() : PmSysGadgetLib.h
  • PmSysGadgetBbutSetLabel() : PmSysGadgetLib.h
  • PmSysGadgetLibClose() : PmSysGadgetLib.h
  • PmSysGadgetLibOpen() : PmSysGadgetLib.h
  • PmSysGadgetStatusGadgetsUpdate() : PmSysGadgetLib.h
  • PmSysGadgetStatusGadgetTypeSet() : PmSysGadgetLib.h
  • PmUIUtilAttrGet() : PmUIUtilLib.h
  • PmUIUtilAttrSet() : PmUIUtilLib.h
  • PmUIUtilLibClose() : PmUIUtilLib.h
  • PmUIUtilLibOpen() : PmUIUtilLib.h
  • PmUIUtilLstGetTempSelection() : PmUIUtilLib.h
  • PmUIUtilLstSetTempSelection() : PmUIUtilLib.h
  • PmUIUtilNavGetFocusColor() : PmUIUtilLib.h
  • PmUIUtilNavSetFocusColor() : PmUIUtilLib.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:38 2008 for Palm API Guide


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • b
  • c
  • d
  • f
  • g
  • h
  • i
  • l
  • n
  • p
  • s
  • t
  • v

- s -

  • SetFontUIRules() : palmOneVMFontLib.h
  • SndFileStreamClose() : palmOneSndFileStream.h
  • SndFileStreamCreate() : palmOneSndFileStream.h
  • SndFileStreamDeviceControl() : palmOneSndFileStream.h
  • SndFileStreamGetCurrentStreamData() : palmOneSndFileStream.h
  • SndFileStreamGetPan() : palmOneSndFileStream.h
  • SndFileStreamGetVolume() : palmOneSndFileStream.h
  • SndFileStreamLibClose() : palmOneSndFileStream.h
  • SndFileStreamLibOpen() : palmOneSndFileStream.h
  • SndFileStreamLibSleep() : palmOneSndFileStream.h
  • SndFileStreamLibVersion() : palmOneSndFileStream.h
  • SndFileStreamLibWake() : palmOneSndFileStream.h
  • SndFileStreamOpen() : palmOneSndFileStream.h
  • SndFileStreamPause() : palmOneSndFileStream.h
  • SndFileStreamSeek() : palmOneSndFileStream.h
  • SndFileStreamSetPan() : palmOneSndFileStream.h
  • SndFileStreamSetVolume() : palmOneSndFileStream.h
  • SndFileStreamStart() : palmOneSndFileStream.h
  • SndFileStreamStop() : palmOneSndFileStream.h
  • SndFileStreamUIPlay() : palmOneSndFileStream.h
  • SndFileStreamUIRecord() : palmOneSndFileStream.h
  • SndStreamCreateExtended() : PalmSoundMgrExt.h
  • SndStreamDeviceControl() : PalmSoundMgrExt.h
  • StatGetAttribute() : PalmStatusBar.h
  • StatHide() : PalmStatusBar.h
  • StatLibClose() : PalmStatusBar.h
  • StatLibOpen() : PalmStatusBar.h
  • StatShow() : PalmStatusBar.h
  • STEAppendParsedInfo() : SmartTextEngine.h
  • STEAppendTextToEngine() : SmartTextEngine.h
  • STEClearCurrentSelection() : SmartTextEngine.h
  • STEClose() : SmartTextEngine.h
  • STECopySelectionToClipboard() : SmartTextEngine.h
  • STEGetAPIVersion() : SmartTextEngine.h
  • STEGetCurrentTextSelection() : SmartTextEngine.h
  • STEGetFlags() : SmartTextEngine.h
  • STEGetLastTapInfo() : SmartTextEngine.h
  • STEGetNumLines() : SmartTextEngine.h
  • STEGetNumRecords() : SmartTextEngine.h
  • STEGetParsedInformation() : SmartTextEngine.h
  • STEGetScroll() : SmartTextEngine.h
  • STEGetScrollPct() : SmartTextEngine.h
  • STEGetSelectedText() : SmartTextEngine.h
  • STEHandleEvent() : SmartTextEngine.h
  • STEHandleKeyDownEvent() : SmartTextEngine.h
  • STEHandlePenDownEvent() : SmartTextEngine.h
  • STEHandlePenMoveEvent() : SmartTextEngine.h
  • STEHandlePenUpEvent() : SmartTextEngine.h
  • STEHandleSclRepeatEvent() : SmartTextEngine.h
  • STEHasHotRectSelection() : SmartTextEngine.h
  • STEHasMessageSelection() : SmartTextEngine.h
  • STEHasTextSelection() : SmartTextEngine.h
  • STEInitializeEngine() : SmartTextEngine.h
  • STEOpen() : SmartTextEngine.h
  • STEQuickRender() : SmartTextEngine.h
  • STEReinitializeEngine() : SmartTextEngine.h
  • STERemoveLastRecordFromEngine() : SmartTextEngine.h
  • STERenderList() : SmartTextEngine.h
  • STERerenderList() : SmartTextEngine.h
  • STEResetEngine() : SmartTextEngine.h
  • STESetCurrentTextSelection() : SmartTextEngine.h
  • STESetCustomHyperlinkCallback() : SmartTextEngine.h
  • STESetFlags() : SmartTextEngine.h
  • STESetScroll() : SmartTextEngine.h
  • STESetScrollPct() : SmartTextEngine.h
  • STESetScrollToRecordNum() : SmartTextEngine.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:38 2008 for Palm API Guide


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • b
  • c
  • d
  • f
  • g
  • h
  • i
  • l
  • n
  • p
  • s
  • t
  • v

- t -

  • TonesLibAddMidiTone() : TonesLib.h
  • TonesLibClose() : TonesLib.h
  • TonesLibCopyBackUndeletableTones() : TonesLib.h
  • TonesLibDeleteTone() : TonesLib.h
  • TonesLibDoDialog() : TonesLib.h
  • TonesLibEscalateRingTones() : TonesLib.h
  • TonesLibGetSoundOnVolume() : TonesLib.h
  • TonesLibGetSoundPrefs() : TonesLib.h
  • TonesLibGetToneIDs() : TonesLib.h
  • TonesLibGetToneList() : TonesLib.h
  • TonesLibGetToneName() : TonesLib.h
  • TonesLibGetToneSize() : TonesLib.h
  • TonesLibInitTonesDB() : TonesLib.h
  • TonesLibManageTones() : TonesLib.h
  • TonesLibOpen() : TonesLib.h
  • TonesLibPickTone() : TonesLib.h
  • TonesLibPlayRingTone() : TonesLib.h
  • TonesLibPlayTone() : TonesLib.h
  • TonesLibRecordTone() : TonesLib.h
  • TonesLibSaveUndeletableTones() : TonesLib.h
  • TonesLibSetSoundOnVolume() : TonesLib.h
  • TonesLibSetSoundPrefs() : TonesLib.h
  • TonesLibSleep() : TonesLib.h
  • TonesLibStopTone() : TonesLib.h
  • TonesLibToneClose() : TonesLib.h
  • TonesLibToneCreate() : TonesLib.h
  • TonesLibToneWrite() : TonesLib.h
  • TonesLibWake() : TonesLib.h
  • TransLibCloseConnection() : TransparencyLib.h
  • TransLibOpenConnection() : TransparencyLib.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:38 2008 for Palm API Guide


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • b
  • c
  • d
  • f
  • g
  • h
  • i
  • l
  • n
  • p
  • s
  • t
  • v

- v -

  • VMFontClearCache() : palmOneVMFontLib.h
  • VMFontClose() : palmOneVMFontLib.h
  • VMFontCountStyleAndSize() : palmOneVMFontLib.h
  • VMFontExists() : palmOneVMFontLib.h
  • VMFontGetFont() : palmOneVMFontLib.h
  • VMFontGetFontByID() : palmOneVMFontLib.h
  • VMFontOpen() : palmOneVMFontLib.h
  • VMFontToString() : palmOneVMFontLib.h
  • VMFontVersion() : palmOneVMFontLib.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:38 2008 for Palm API Guide


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • n
  • p
  • s
  • t
  • u
  • v
  • w

- a -

  • AacFileRefPtr : palmOneCodecFormat.h
  • AddrAddToRecordParamsPtr : HsAppLaunchCmd.h
  • AddrCallerIDParamsPtr : HsAppLaunchCmd.h
  • AddrCreateNewRecordParamsPtr : HsAppLaunchCmd.h
  • AddrDescriptor : HsPhoneSMSTypes.h
  • Address : HsPhoneSMSTypes.h
  • AddressAppPhoneLabelType : HsPhoneSMSTypes.h
  • AddressAppRecordFieldEnum : HsPhoneSMSTypes.h
  • AddressAppRecordHeader : HsPhoneSMSTypes.h
  • AddressType : HsPhoneSMSTypes.h
  • AddrHsLookupParamsPtr : HsAppLaunchCmd.h
  • AddrHsLookupParamsType : HsAppLaunchCmd.h
  • AddrHsLookupUserDataPtr : HsAppLaunchCmd.h
  • AddrHsLookupUserDataV2Ptr : HsAppLaunchCmd.h
  • AddrListLookupTypeEnum : HsAppLaunchCmd.h
  • AddrPhonebookAppParamsPtr : HsAppLaunchCmd.h
  • AddrPhotoCallerIDParamsPtr : HsAppLaunchCmd.h
  • AttachType : DatebookLibCommon.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:38 2008 for Palm API Guide


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • n
  • p
  • s
  • t
  • u
  • v
  • w

- l -

  • LcdOverlayLibControlType : PalmLcdOverlay.h , palmOneLcdOverlayCommon.h
  • LcdOverlayLibFormatType : PalmLcdOverlay.h , palmOneLcdOverlayCommon.h
  • LcdOverlayLibSettingType : PalmLcdOverlay.h , palmOneLcdOverlayCommon.h
  • LocationType : LocsLibCommon.h
  • LocDBInfoType : LocsLibCommon.h
  • LocDBRecordType : LocsLibCommon.h
  • LocDBSortOrderType : LocsLibCommon.h
  • LocsLibNotifyDataType : LocsLibCommon.h
  • LocsLibNotifyLocsDataType : LocsLibCommon.h
  • LocsLibSelLocsType : LocsLibCommon.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:38 2008 for Palm API Guide


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • n
  • p
  • s
  • t
  • u
  • v
  • w

- n -

  • NBSNotificationEventType : HsPhoneSMSTypes.h
  • Net80211DeviceInfoP : PalmNetServices.h
  • Net80211InfrastructureModeType : PalmWiFiCommon.h
  • Net80211NetworkType : PalmWiFiCommon.h
  • NetBssInfoTypeP : PalmWiFiCommon.h
  • NetBssListType : PalmWiFiCommon.h
  • NetMasterAutoLoginType : NetMasterLibTypes.h
  • NetMasterClientEventEnum : NetMasterLibTypes.h
  • NetMasterDataContextIDType : NetMasterLibTypes.h
  • NetMasterDataSessionIDType : NetMasterLibTypes.h
  • NetMasterLoginPriorityEnum : NetMasterLibTypes.h
  • NetMasterNetIFShutDownOptionsType : NetMasterLibTypes.h
  • NetMasterNetLibOpenOptionsType : NetMasterLibTypes.h
  • NetPref1xRTTTunnelingEnum : NetPrefLibTypes.h
  • NetPrefFallbackAlgrorithmEnum : NetPrefLibTypes.h
  • NetPrefFallbackStatusFlagsType : NetPrefLibTypes.h
  • NetPrefFieldSetDefineOptionsType : NetPrefLibTypes.h
  • NetPrefFieldTypeEnum : NetPrefLibTypes.h
  • NetPrefMutexStickyFBAStatusEnum : NetPrefLibTypes.h
  • NetPrefNetCloseWaitEnum : NetPrefLibTypes.h
  • NetPrefNetIdleTimeoutEnum : NetPrefLibTypes.h
  • NetPrefPlatformEnum : NetPrefLibTypes.h
  • NetPrefRecFieldAttrType : NetPrefLibTypes.h
  • NetPrefRecFieldEnum : NetPrefLibTypes.h
  • NetPrefRecFieldViewType : NetPrefLibTypes.h
  • NetPrefRecIDType : NetPrefLibTypes.h
  • NetPrefRecProtectionType : NetPrefLibTypes.h
  • NetPrefSvcBindingEnum : NetPrefLibTypes.h
  • NetPrefSvcGatewayType : NetPrefLibTypes.h
  • NetPrefSvcMediumEnum : NetPrefLibTypes.h
  • NetPrefSvcTargetEnum : NetPrefLibTypes.h
  • NetQueryType : PalmWiFiCommon.h
  • NetQueryTypeP : PalmWiFiCommon.h
  • NetServicesProfileInfoP : PalmNetServices.h
  • NetServicesProfileOrderP : PalmNetServices.h
  • NetServicesProfileP : PalmNetServices.h
  • NetServicesProfileV1P : PalmNetServices.h
  • NetSSIDP : PalmWiFiCommon.h
  • NetWepKeyP : PalmWiFiCommon.h
  • NewControlProc : HtmlLib68K.h
  • NewFieldProc : HtmlLib68K.h
  • NewListProc : HtmlLib68K.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:38 2008 for Palm API Guide


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • n
  • p
  • s
  • t
  • u
  • v
  • w

- b -

  • BGRecvResponseFP : PalmBGService.h
  • Boolean : PalmNative.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:38 2008 for Palm API Guide


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • n
  • p
  • s
  • t
  • u
  • v
  • w

- c -

  • CamLibApertureValueType : palmOneCameraCommon.h
  • CamLibBitmapInfoType : palmOneCameraCommon.h
  • CamLibBufNumType : palmOneCameraCommon.h
  • CamLibCaptureCallbackFunc : palmOneCameraCommon.h
  • CamLibCaptureFormatType : palmOneCameraCommon.h
  • CamLibCaptureType : palmOneCameraCommon.h
  • CamLibColorSpaceType : palmOneCameraCommon.h
  • CamLibContrastType : palmOneCameraCommon.h
  • CamLibControlType : palmOneCameraCommon.h
  • CamLibEffectsType : palmOneCameraCommon.h
  • CamLibExposureType : palmOneCameraCommon.h
  • CamLibImageSizeType : palmOneCameraCommon.h
  • CamLibLightingType : palmOneCameraCommon.h
  • CamLibSaturationType : palmOneCameraCommon.h
  • CamLibSettingType : palmOneCameraCommon.h
  • CamLibSharpnessType : palmOneCameraCommon.h
  • CamLibShutterSpeedType : palmOneCameraCommon.h
  • CamLibStatusType : palmOneCameraCommon.h
  • CamLibStreamPreviewType : palmOneCameraCommon.h
  • CamLibStreamType : palmOneCameraCommon.h
  • CamLibWhiteBalanceType : palmOneCameraCommon.h
  • CamLibZoomType : palmOneCameraCommon.h
  • CCSMBrowserFlagsType : CarrierCustomLibTypes.h
  • CCSMCarrierHandle : CarrierCustomLibTypes.h
  • CCSMMessagingFlagsType : CarrierCustomLibTypes.h
  • CCSMPhoneFlagsType : CarrierCustomLibTypes.h
  • CCSMRadioBandType : CarrierCustomLibTypes.h
  • CCSMSettingsType : CarrierCustomLibTypes.h
  • CCSMSystemFlagsType : CarrierCustomLibTypes.h
  • Char : PalmNative.h
  • ContactsContHandle : Contacts.h
  • ContactsDateType : Contacts.h
  • ContactsLabel : Contacts.h
  • ContactsLabelType : Contacts.h
  • ContactsSession : Contacts.h
  • ContinuePowerOnOffCallback : HsPhoneEvent.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:38 2008 for Palm API Guide


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • n
  • p
  • s
  • t
  • u
  • v
  • w

- d -

  • dataLinks : PalmVMPlugin.h
  • DateBookCompAttachFucPtr : DatebookLibCommon.h
  • DeleteObjectProc : HtmlLib68K.h
  • DSTType : LocsLibCommon.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:38 2008 for Palm API Guide


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • n
  • p
  • s
  • t
  • u
  • v
  • w

- e -

  • ePmConnectorAudioInputSettingsType : PmConnectorLibCommon.h
  • ePmConnectorAudioOutputSettingsType : PmConnectorLibCommon.h
  • Err : PalmNative.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:38 2008 for Palm API Guide


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • n
  • p
  • s
  • t
  • u
  • v
  • w

- f -

  • FrmNavFocusRingStyleEnum : HsNavCommon.h
  • FrmNavHeaderFlagsType : HsNavCommon.h
  • FrmNavHeaderType : HsNavCommon.h
  • FrmNavObjectFlagsType : HsNavCommon.h
  • FrmNavOrderEntryType : HsNavCommon.h
  • FrmNavStateFlagsType : HsNavCommon.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:38 2008 for Palm API Guide


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • n
  • p
  • s
  • t
  • u
  • v
  • w

- g -

  • GoLcdColorModeType : PalmGoLCDCommon.h
  • GoLcdGsiStateType : PalmGoLCDCommon.h
  • GoLcdInkStateType : PalmGoLCDCommon.h
  • GoLcdModeType : PalmGoLCDCommon.h
  • GoLcdStatusType : PalmGoLCDCommon.h
  • GSMATEventInputEchoModeEnum : HsPhoneGSMTypes.h
  • GSMDialCLIRMode : HsPhoneTypes.h
  • GSMSATDataSvcType : HsPhoneGSMTypes.h
  • GSMSATEventInputFormatEnum : HsPhoneGSMTypes.h
  • GSMSATEventMenuFlag : HsPhoneGSMTypes.h
  • GSMSATEventSetupCallCallTypeEnum : HsPhoneGSMTypes.h
  • GSMSATEventToneTimeUnitEnum : HsPhoneGSMTypes.h
  • GSMSATEventToneTypeEnum : HsPhoneGSMTypes.h
  • GSMSIMMessagesDialogKind : HsPhoneGSMTypes.h
  • GSMSIMStatus : HsPhoneTypes.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:38 2008 for Palm API Guide


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • n
  • p
  • s
  • t
  • u
  • v
  • w

- h -

  • HelperServiceMMSDetailsType : MmsHelperCommon.h
  • HelperServiceMMSObjectType : MmsHelperCommon.h
  • HS_HTTPLibAppInfo : HS_HTTPLibApp.h
  • HS_HTTPLibAuthInfo : HS_HTTPLib68K.h
  • HS_HTTPLibCertList : HS_HTTPLib68K.h
  • HS_HTTPLibCertPtr : HS_HTTPLib68K.h
  • HS_HTTPLibClientCertList : HS_HTTPLib68K.h
  • HS_HTTPLibClientCertSelectProc : HS_HTTPLib68K.h
  • HS_HTTPLibCookieConfirmProc : HS_HTTPLib68K.h
  • HS_HTTPLibCookies : HS_HTTPLib68K.h
  • HS_HTTPLibDataHandle : HS_HTTPLib68K.h
  • HS_HTTPLibFixedString : HS_HTTPLib68K.h
  • HS_HTTPLibHandle : HS_HTTPLibApp.h
  • HS_HTTPLibIPAddr : HS_HTTPLibApp.h
  • HS_HTTPLibNetLibCloseProc : HS_HTTPLibApp.h
  • HS_HTTPLibNetLibInfo : HS_HTTPLibApp.h
  • HS_HTTPLibNetLibOfflineProc : HS_HTTPLibApp.h
  • HS_HTTPLibNetLibOnlineProc : HS_HTTPLibApp.h
  • HS_HTTPLibNetLibOpenProc : HS_HTTPLibApp.h
  • HS_HTTPLibOpaque : HS_HTTPLibApp.h
  • HS_HTTPLibPeer : HS_HTTPLibApp.h
  • HS_HTTPLibServerCertConfirmProc : HS_HTTPLib68K.h
  • HS_HTTPLibSplit : HS_HTTPLib68K.h
  • HS_HTTPLibSSL : HS_HTTPLib68K.h
  • HS_HTTPLibSSLClassPtr : HS_HTTPLib68K.h
  • HS_HTTPLibStream : HS_HTTPLib68K.h
  • HS_HTTPLibString : HS_HTTPLib68K.h
  • HS_HTTPLibTime : HS_HTTPLib68K.h
  • HS_HTTPLibTunnelingCallbackProc : HS_HTTPLib68K.h
  • HS_HTTPLibURLString : HS_HTTPLib68K.h
  • HS_HTTPLibVHandle : HS_HTTPLib68K.h
  • HS_HTTPLibWakeUpCallbackProc : HS_HTTPLib68K.h
  • HS_TCPCanReadWritePeer : HS_HTTPLibApp.h
  • HS_TCPClosePeer : HS_HTTPLibApp.h
  • HS_TCPConnectPeer : HS_HTTPLibApp.h
  • HS_TCPIsConnectedPeer : HS_HTTPLibApp.h
  • HS_TCPOpenPeer : HS_HTTPLibApp.h
  • HS_TCPReadPeer : HS_HTTPLibApp.h
  • HS_TCPWritePeer : HS_HTTPLibApp.h
  • HsNavFocusColorEnum : HsNavCommon.h
  • HsNavFocusRingStyleEnum : HsNavCommon.h
  • HsSndBufferProc : HsSoundLibCommon.h
  • HsSndCmdType : HsSoundLibCommon.h
  • HsSndFormatType : HsSoundLibCommon.h
  • HsSndMode : HsSoundLibCommon.h
  • HsSndParam : HsSoundLibCommon.h
  • HsSndPortClass : HsSoundLibCommon.h
  • HsSndPortID : HsSoundLibCommon.h
  • HsSndPortInfoPtr : HsSoundLibCommon.h
  • HsSndSwitchID : HsSoundLibCommon.h
  • hsSndSysBeepType : HsSoundLibCommon.h
  • HtmlDisplayMode : HtmlLib68K.h
  • HtmlFocusTargetType : HtmlLib68K.h
  • HtmlLibInclusionCallback : HtmlLib68K.h
  • HtmlLibLinkSelCallback : HtmlLib68K.h
  • HtmlLibScanPhoneNumberCallback : HtmlLib68K.h
  • HtmlLibSubmitFormCallback : HtmlLib68K.h
  • HtmlProgressStatus : HtmlLib68K.h
  • HtmlScrollbarMode : HtmlLib68K.h
  • HtmlScrollDirection : HtmlLib68K.h
  • HtmlSubmitFormMethod : HtmlLib68K.h
  • httpAuthPathEnum : HS_HTTPLibConst.h
  • httpAuthTargetEnum : HS_HTTPLibConst.h
  • httpAuthTypeEnum : HS_HTTPLibConst.h
  • httpCookieEnum : HS_HTTPLibConst.h
  • httpErrorEnum : HS_HTTPLibConst.h
  • httpHeaderIDEnum : HS_HTTPLibConst.h
  • httpHeaderTypeEnum : HS_HTTPLibConst.h
  • httpMethodEnum : HS_HTTPLibConst.h
  • httpSchemeEnum : HS_HTTPLibConst.h
  • httpStatusCodeEnum : HS_HTTPLibConst.h
  • httpStreamStateEnum : HS_HTTPLibConst.h
  • httpVersionEnum : HS_HTTPLibConst.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:38 2008 for Palm API Guide


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • n
  • p
  • s
  • t
  • u
  • v
  • w

- i -

  • IDatSyncSource : DatebookLibCommon.h
  • ImageIteratorHandle : ImageLibCommon.h
  • ImageLibProgressCallbackType : ImageLibCommon.h
  • Int16 : PalmNative.h
  • Int32 : PalmNative.h
  • Int8 : PalmNative.h
  • IOTANotificationEventType : HsPhoneIOTATypes.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:38 2008 for Palm API Guide


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • n
  • p
  • s
  • t
  • u
  • v
  • w

- p -

  • P1clActionType : DatebookLibCommon.h
  • P1clAlarmUnitType : DatebookLibCommon.h
  • P1clApptHandle : DatebookLibCommon.h
  • P1clApptListHandle : DatebookLibCommon.h
  • P1clApptStatusType : DatebookLibCommon.h
  • P1clAttachHandle : DatebookLibCommon.h
  • P1clAttendeeFieldType : DatebookLibCommon.h
  • P1clAttendeeHandle : DatebookLibCommon.h
  • P1clAttendeeRoleType : DatebookLibCommon.h
  • P1clDeleteType : DatebookLibCommon.h
  • P1clFieldTypes : DatebookLibCommon.h
  • P1clListFieldType : DatebookLibCommon.h
  • P1clPersistentID : DatebookLibCommon.h
  • P1clRecordDetailsPtr : DatebookLibCommon.h
  • P1clRepeatTypes : DatebookLibCommon.h
  • P1clSession : DatebookLibCommon.h
  • P1clSyncSource : DatebookLibCommon.h
  • P1clTimeZoneType : DatebookLibCommon.h
  • P1clTxnEntry : DatebookLibCommon.h
  • P1clTxnIterator : DatebookLibCommon.h
  • PalmAudioPlaybackActionCodeType : PalmAudioPlayback.h
  • PalmAudioPlaybackNotifyEventType : PalmAudioPlayback.h
  • PalmCodecFormat : palmOneCodecPluginMgrCommon.h
  • PalmCodecSession : palmOneCodecPluginMgrCommon.h
  • PalmOneStatAttrType : palmOneStatusBar.h
  • PalmPhotoCaptureCallbackV2 : palmOnePhoto.h
  • PalmPhotoCaptureParamV2 : palmOnePhoto.h
  • PalmPhotoCaptureResolution : palmOnePhotoCommon.h
  • PalmPhotoCreateParam : palmOnePhoto.h
  • PalmPhotoDisplayCallback : palmOnePhoto.h
  • PalmPhotoDisplayParam : palmOnePhoto.h
  • PalmPhotoDlgType : palmOnePhotoCommon.h
  • PalmPhotoExtraInfoParam : palmOnePhotoCommon.h
  • PalmPhotoExtraInfoType : palmOnePhotoCommon.h
  • PalmPhotoFileFormat : palmOnePhotoCommon.h
  • PalmPhotoFileLocation : palmOnePhotoCommon.h
  • PalmPhotoFilterCallback : palmOnePhoto.h
  • PalmPhotoHandle : palmOnePhotoCommon.h
  • PalmPhotoImageInfo : palmOnePhotoCommon.h
  • PalmPhotoLocationType : palmOnePhotoCommon.h
  • PalmPhotoMediaType : palmOnePhotoCommon.h
  • PalmPhotoQualityType : palmOnePhotoCommon.h
  • PalmPhotoReadWriteCallback : palmOnePhoto.h
  • PalmPhotoReadWriteParam : palmOnePhoto.h
  • PalmPhotoSelectionParam : palmOnePhoto.h
  • PalmPhotoSelections : palmOnePhotoCommon.h
  • PalmPhotoUID : palmOnePhotoCommon.h
  • PhnAddressField : HsPhoneTypes.h
  • PhnAddressHandle : HsPhoneTypes.h
  • PhnAddressList : HsPhoneTypes.h
  • PhnAudioSendMode : HsPhoneAudioTypes.h
  • PhnBandSelection : HsPhoneNetworkTypes.h
  • PhnBarFacilityPtr : HsPhoneNetworkTypes.h
  • PhnBarFacilityType : HsPhoneNetworkTypes.h
  • PhnCallControlType : HsPhoneNetworkTypes.h
  • PhnCDMAFirmwareType : HsPhoneCDMATypes.h
  • PhnCDMAMediaTVSettingsType : HsPhoneCDMATypes.h
  • PhnCdmaSystemInfoPtr : HsPhoneMiscTypes.h
  • PhnCDMAVoicemailType : HsPhoneCDMATypes.h
  • PhnConnectionID : HsPhoneTypes.h
  • PhnConnectionPtr : HsPhoneCallControlTypes.h
  • PhnConnectStateType : HsPhoneCallControlTypes.h
  • PhnDatabaseID : HsPhoneTypes.h
  • PhnDataServiceType : HsPhoneNetworkTypes.h
  • PHNErrorCode : HsPhoneErrors.h
  • PhnEventPtr : HsPhoneEvent.h
  • PhnForwardModeType : HsPhoneNetworkTypes.h
  • PhnForwardType : HsPhoneNetworkTypes.h
  • PhnGenericCDMAPreference : HsPhoneCDMATypes.h
  • PhnGenericCDMASMSEncodingType : HsPhoneCDMATypes.h
  • PhnGPRSPDPType : HsPhoneGSMTypes.h
  • PhnGPRSQOSType : HsPhoneGSMTypes.h
  • PhnHACSetting : HsPhoneAudioTypes.h
  • PhnIOTAItemType : HsPhoneIOTATypes.h
  • PhnLibAttrPtr : HsPhoneMiscTypes.h
  • PhnLibAttrType : HsPhoneMiscTypes.h
  • PhnLibMMSServerInfoType : HsPhoneSMSTypes.h
  • PhnLifeTimer : HsPhoneTypes.h
  • PhnLineStatePtr : HsPhoneMiscTypes.h
  • PhnLockMode : HsPhoneTypes.h
  • PhnMIPSessionType : HsPhoneNetworkTypes.h
  • PhnMMIActionCode : HsPhoneNetworkTypes.h
  • PhnMMIEntryPtr : HsPhoneNetworkTypes.h
  • PhnMMIResultPtr : HsPhoneNetworkTypes.h
  • PhnMMIServiceCode : HsPhoneNetworkTypes.h
  • PhnMsgBoxPriorityType : HsPhoneNetworkTypes.h
  • PhnMsgBoxType : HsPhoneNetworkTypes.h
  • PhnOnexMipRRQPtr : HsPhoneEvent.h
  • PhnOneXProtRevType : HsPhoneNetworkTypes.h
  • PhnOperatorID : HsPhoneTypes.h
  • PhnOperatorListPtr : HsPhoneNetworkTypes.h
  • PhnOprtModeType : HsPhoneMiscTypes.h
  • PhnPacketDataEndStatusType : HsPhoneNetworkTypes.h
  • PhnPacketDataSessionType : HsPhoneNetworkTypes.h
  • PhnPassword : HsPhoneEvent.h
  • PhnPasswordType : HsPhoneSecurityTypes.h
  • PhnPDDataPtr : HsPhoneCDMATypes.h
  • PhnPDPConnectionType : HsPhoneCDMATypes.h
  • PhnPDPCopyAck : HsPhoneCDMATypes.h
  • PhnPDPDeleteAck : HsPhoneCDMATypes.h
  • PhnPDPIndexType : HsPhoneCDMATypes.h
  • PhnPDPReplaceAck : HsPhoneCDMATypes.h
  • PhnPDPService : HsPhoneCDMATypes.h
  • PhnPDSessionConfigParamType : hsPhoneLocationTypes.h
  • PhnPhoneBookInfoPtr : HsPhoneGSMTypes.h
  • PhnPowerType : HsPhoneTypes.h
  • PhnRadioStatePtr : HsPhoneMiscTypes.h
  • PhnRingingInfoPtr : HsPhoneAudioTypes.h
  • PhnRoamPrefInfoPtr : HsPhoneNetworkTypes.h
  • PhnRoamPrefSelectionType : HsPhoneNetworkTypes.h
  • PhnRoamStatus : HsPhoneNetworkTypes.h
  • PhnSATEventHeader : HsPhoneEvent.h
  • PhnSMSClass : HsPhoneEvent.h
  • PhnSMSPrefPtr : HsPhoneSMSTypes.h
  • PhnSMSType : HsPhoneEvent.h
  • PhnSysPrefSetting : HsPhoneCDMATypes.h
  • PhnTTYSetting : HsPhoneAudioTypes.h
  • PhnWAPPushAppId : HsPhoneEvent.h
  • PhnWAPPushContent : HsPhoneEvent.h
  • PhoneAppLaunchCmdCallerIDLookupPtr : HsAppLaunchCmd.h
  • PhoneAppLaunchCmdDialPtr : HsAppLaunchCmd.h
  • PhoneAppLaunchCmdGetALSLineNumberTypePtr : HsAppLaunchCmd.h
  • PhoneAppLaunchCmdGetDialPrefFlagPtr : HsAppLaunchCmd.h
  • PhoneAppLaunchCmdSendDTMFTonePtr : HsAppLaunchCmd.h
  • PhoneAppLaunchCmdSetWallpaperPtr : HsAppLaunchCmd.h
  • PhoneServiceClassType : HsPhoneTypes.h
  • pluginExtendedQueryParams : PalmVMPlugin.h
  • pluginGetInfoParams : PalmVMPlugin.h
  • pluginParams : PalmVMPlugin.h
  • pluginQueryParams : PalmVMPlugin.h
  • pluginSendParams : PalmVMPlugin.h
  • PmAudioGroup : PmSoundLibAudioGroup.h
  • PmBroadcastNewMsgCountNotifyParamPtr : HsHelper.h
  • PmClkTickRef : HsSoundLibCommon.h
  • PmConnectorAudioInputSettingType : PmConnectorLibCommon.h
  • PmConnectorAudioOutputSettingType : PmConnectorLibCommon.h
  • PmConnectorLibControlType : PmConnectorLibCommon.h
  • PmConnectorStateType : PmConnectorLibCommon.h
  • PmGetNewMsgCountNotifyParamPtr : HsHelper.h
  • PmKeyAttrEnum : PmKeyLibCommon.h
  • PmSndPrefID : HsSoundLibCommon.h
  • PmSndU64 : HsSoundLibCommon.h
  • PmUIUtilAttrEnum : PmUIUtilLibCommon.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:38 2008 for Palm API Guide


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • n
  • p
  • s
  • t
  • u
  • v
  • w

- s -

  • SATDecisionType : HsPhoneGSMTypes.h
  • SATNotificationType : HsPhoneGSMTypes.h
  • SATRefreshFile : HsPhoneGSMTypes.h
  • SATRefreshType : HsPhoneGSMTypes.h
  • SATRequestType : HsPhoneGSMTypes.h
  • SATSetupCallType : HsPhoneGSMTypes.h
  • SmsCauseCode : HsPhoneSMSTypes.h
  • SmsErrorCode : HsPhoneSMSTypes.h
  • SndFileFormatType : palmOneSndFileStream.h
  • SndFileStreamCallbackPtr : palmOneSndFileStream.h
  • SndFileStreamData : palmOneSndFileStream.h
  • SndFileStreamDataPtr : palmOneSndFileStream.h
  • SndFileStreamFileSpec : palmOneSndFileStream.h
  • SndFileStreamFileSpecPtr : palmOneSndFileStream.h
  • SndFileStreamHsSoundCommandParam : palmOneSndFileStream.h
  • SndFileStreamHsSoundCommandParamPtr : palmOneSndFileStream.h
  • SndFileStreamRef : palmOneSndFileStream.h
  • SndFormatType : PalmSoundMgrExt.h
  • SndStreamVariableBufferCallback : PalmSoundMgrExt.h
  • SoundPrefsLaunchCmdParamPtr : HsAppLaunchCmd.h
  • SoundPrefType : TonesLibTypes.h
  • StatAttrType : PalmStatusBar.h
  • STECallbackType : SmartTextEngineDef.h
  • STEErr : SmartTextEngineErrors.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:38 2008 for Palm API Guide


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • n
  • p
  • s
  • t
  • u
  • v
  • w

- t -

  • ToneItemPtr : TonesLibTypes.h
  • TonePlayNumberTimes : TonesLibTypes.h
  • ToneRepeatInterval : TonesLibTypes.h
  • ToneTimeUnit : TonesLibTypes.h
  • ToneType : TonesLibTypes.h
  • ToneVibrateType : TonesLibTypes.h
  • ToneVolume : TonesLibTypes.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:38 2008 for Palm API Guide


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • n
  • p
  • s
  • t
  • u
  • v
  • w

- u -

  • UInt16 : PalmNative.h
  • UInt32 : PalmNative.h
  • UInt8 : PalmNative.h
  • UPNotificationEventType : HsPhoneEvent.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:38 2008 for Palm API Guide


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • n
  • p
  • s
  • t
  • u
  • v
  • w

- v -

  • VMFontFace : VMFontLibCommon.h
  • VMFontPtr : VMFontLibCommon.h
  • VMFontSize : VMFontLibCommon.h
  • VMFontSizeRule : VMFontLibCommon.h
  • VMFontStyle : VMFontLibCommon.h
  • VMFontStyleRule : VMFontLibCommon.h
  • VMFontUIRulesPtr : VMFontLibCommon.h
  • VPNLibEventNotificationTypeEnum : PalmShimSettings.h
  • VPNNotifyEventType : PalmShimSettings.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:38 2008 for Palm API Guide


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • n
  • p
  • s
  • t
  • u
  • v
  • w

- w -

  • WAPNotificationEventType : HsPhoneEvent.h
  • WUNotificationEventType : HsPhoneEvent.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:38 2008 for Palm API Guide


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • n

- n -

  • netPrefFieldTypeBin : NetPrefLibFieldInfoTable.h
  • netPrefFieldTypeStr : NetPrefLibFieldInfoTable.h
  • netPrefFieldTypeUInt16 : NetPrefLibFieldInfoTable.h
  • netPrefFieldTypeUInt32 : NetPrefLibFieldInfoTable.h
  • netPrefFieldTypeUInt8 : NetPrefLibFieldInfoTable.h
  • netPrefFieldTypeZStrList : NetPrefLibFieldInfoTable.h
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:38 2008 for Palm API Guide


Graph Legend

This page explains how to interpret the graphs that are generated by doxygen.

Consider the following example:

/*! Invisible class because of truncation */
class Invisible { };

/*! Truncated class, inheritance relation is hidden */
class Truncated : public Invisible { };

/* Class not documented with doxygen comments */
class Undocumented { };

/*! Class that is inherited using public inheritance */
class PublicBase : public Truncated { };

/*! A template class */
template<class T> class Templ { };

/*! Class that is inherited using protected inheritance */
class ProtectedBase { };

/*! Class that is inherited using private inheritance */
class PrivateBase { };

/*! Class that is used by the Inherited class */
class Used { };

/*! Super class that inherits a number of other classes */
class Inherited : public PublicBase,
                  protected ProtectedBase,
                  private PrivateBase,
                  public Undocumented
                  public Templ<int>
{
  private:
    Used *m_usedClass;
};
If the MAX_DOT_GRAPH_HEIGHT tag in the configuration file is set to 240 this will result in the following graph:

The boxes in the above graph have the following meaning:

  • A filled black box represents the struct or class for which the graph is generated.
  • A box with a black border denotes a documented struct or class.
  • A box with a grey border denotes an undocumented struct or class.
  • A box with a red border denotes a documented struct or class forwhich not all inheritance/containment relations are shown. A graph is truncated if it does not fit within the specified boundaries.
The arrows have the following meaning:
  • A dark blue arrow is used to visualize a public inheritance relation between two classes.
  • A dark green arrow is used for protected inheritance.
  • A dark red arrow is used for private inheritance.
  • A purple dashed arrow is used if a class is contained or used by another class. The arrow is labeled with the variable(s) through which the pointed class or struct is accessible.
  • A yellow dashed arrow denotes a relation between a template instance and the template class it was instantiated from. The arrow is labeled with the template parameters of the instance.
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:08:33 2008 for Palm API Guide


Header Files » Incs » 68k » system

HardwareUtils68K.h

Go to the documentation of this file.
00001 /*******************************************************************************
00002  * Copyright (c) 2004-2005 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  ******************************************************************************/
00005 /**
00006  *  @defgroup   HWUtil Hardware Utility Library
00007  *  @brief      This library provides support for applications to control the state
00008  *              of certain pieces of hardware on the device.
00009  *
00010  *  This library currently allows the application to programmatically turn the
00011  *  display on/off as well as controling the behavior of the LED light if available.
00012  *
00013  *  @{
00014  *  @}
00015  */
00016 /**
00017  * @ingroup HWUtil
00018  */
00019
00020 /**
00021  * @file    HardwareUtils68K.h
00022  * @version 1.0
00023  * @brief   Public common header file to the Hardware Utilities Library used by 68K applications.
00024  *
00025  * This file contains the library constants and function prototypes for the library.
00026  * <hr>
00027  */
00028
00029 #ifndef __HWUTILS68K_H__
00030 #define __HWUTILS68K_H__
00031
00032 #include <PalmTypes.h>
00033 #include <LibTraps.h>
00034
00035 /**
00036  * @name Library Constants
00037  *
00038  */
00039 /*@{*/
00040 #define kHWUtilsType                    sysFileTLibrary     /**<        */
00041 #define kHWUtilsCreator                 'HWut'          /**<        */
00042 #define kHWUtilsName                    "HardwareUtils"     /**<        */
00043 /*@}*/
00044
00045 /**
00046  * @name Function Traps
00047  */
00048 /*@{*/
00049 #define kHWUtilsTrapOpen                sysLibTrapOpen
00050 #define kHWUtilsTrapClose               sysLibTrapClose
00051 #define kHWUtilsTrapBlinkLED            (sysLibTrapCustom + 0)
00052 #define kHWUtilsTrapSetBlinkRate        (sysLibTrapCustom + 1)
00053 #define kHWUtilsTrapEnableDisplay       (sysLibTrapCustom + 2)
00054 #define kHWUtilsTrapGetDisplayState     (sysLibTrapCustom + 3)
00055 /*@}*/
00056
00057 #ifdef __cplusplus
00058 extern "C" {
00059 #endif
00060
00061 /**
00062  *  @brief Standard library open routine
00063  *
00064  *  @param refnum:  IN: Library reference number
00065  *  @return Error code.
00066  **/
00067 Err HWUOpen(UInt16 refnum)
00068             SYS_TRAP(kHWUtilsTrapOpen);
00069
00070 /**
00071  *  @brief Standard library close routine
00072  *
00073  *  @param refnum:  IN: Library reference number
00074  *  @return Error code.
00075  **/
00076 Err HWUClose(UInt16 refnum)
00077             SYS_TRAP(kHWUtilsTrapClose);
00078
00079 /**
00080  *  @brief Set the LED blink state
00081  *
00082  *  @param refnum:  IN: Library reference number
00083  *  @param b:       IN: True if LED should be blinking. False otherwise.
00084  *  @return Error code
00085  **/
00086 Err HWUBlinkLED(UInt16 refnum, Boolean b)
00087             SYS_TRAP(kHWUtilsTrapBlinkLED);
00088
00089 /**
00090  *  @brief Set the blink rate of the LED light
00091  *
00092  *  @param refnum:  IN: Library reference number
00093  *  @param rate:    IN: The rate at which the LED should blink.
00094  *  @return Error code.
00095  **/
00096 Err HWUSetBlinkRate(UInt16 refnum, UInt16 rate)
00097             SYS_TRAP(kHWUtilsTrapSetBlinkRate);
00098
00099 /**
00100  *  @brief Set the state of the display
00101  *
00102  *  @param refnum:  IN: Library reference number
00103  *  @param on:      IN: True to enable display. False otherwise.
00104  *  @return Error code.
00105  **/
00106 Err HWUEnableDisplay(UInt16 refnum, Boolean on)
00107             SYS_TRAP(kHWUtilsTrapEnableDisplay);
00108
00109 /**
00110  *  @brief Retrieve the current state of the display
00111  *
00112  *  @param refnum:  IN: Library reference number
00113  *  @return True if the display is on. False otherwise.
00114  **/
00115 Boolean HWUGetDisplayState(UInt16 refnum)
00116             SYS_TRAP(kHWUtilsTrapGetDisplayState);
00117
00118 #ifdef __cplusplus
00119 }
00120 #endif
00121
00122 #endif  //__HWUTILS68K_H__
00123
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:52 2008 for Palm API Guide


Header Files » Incs » 68k

Hs.h

Go to the documentation of this file.
00001 /**
00002  * \file 68K/Hs.h
00003  *  Main Handspring Palm OS API Header file
00004  *
00005  * This is the main header file that all third party developers. A developer
00006  * would include if they wanted to use any of the handspring components. This
00007  * includes all the extentions, libraries and any app compoennts. This file is
00008  * for api calls that will work only in  code. This file automatically includes
00009  * the Common/HsCommon.h file so there is no need for a developer to include that file
00010  * seperately. This is the ONLY file that should be needed for any of the
00011  * handspring specific components. This file includes all the other header files
00012  * for the 68K space relative to this directory. It has to stay at the top of
00013  * the Handspring/68K tree.
00014  *
00015  * \license
00016  *
00017  *    Copyright (c) 2002 Handspring Inc., All Rights Reserved
00018  *
00019  * \author Kiran Prasad
00020  *
00021  * $Id: //device/handheld/dev/sdk/2.2.2/incs/68k/Hs.h#1 $
00022  *
00023  *****************************************************************************/
00024
00025 #ifndef __HS_68K_H__
00026
00027 #define __HS_68K_H__
00028
00029
00030 #include <Common/HsCommon.h>
00031
00032 #include <68K/System/FarCall.h>
00033 #include <68K/System/HsHelper.h>
00034 #include <68K/System/HsExgMgr.h>
00035
00036 #include <68K/Libraries/FavoritesDBLibrary/FavoritesDBLib.h>
00037
00038 #include <68K/Libraries/Imaging/ImageLib.h>
00039 #include <68K/Libraries/Camera/CameraLib.h>
00040
00041 #include <68K/Libraries/HTTP/HS_HTTPLib68K.h>
00042
00043 #include <68K/Libraries/VMFont/palmOneVMFontLib.h>
00044
00045 #endif /* __HS_68K_H__ */
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:52 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » http

HS_HTTPLib68K.h

Go to the documentation of this file.
00001 /*
00002     HS_HTTPLib68K.h
00003     Copyright(c) 1996-2002 ACCESS CO., LTD.
00004     All rights are reserved by ACCESS CO., LTD., whether the whole or
00005     part of the source code including any modifications.
00006 */
00007 /**
00008  * @defgroup HTTP HTTP Library
00009  *
00010  * @{
00011  * @}
00012  */
00013 /**
00014  *
00015  * @ingroup HTTP
00016  *
00017 */
00018
00019 /**
00020  * @file    HS_HTTPLib68K.h
00021  * @version 2.0
00022  * @date
00023  *
00024  * @brief Public 68k include file for the HTTP Library.
00025  *
00026  *
00027  */
00028
00029
00030
00031 #ifndef HS_HTTPLIB68K_H__
00032 #define HS_HTTPLIB68K_H__
00033
00034 #include <PalmTypes.h>
00035 #include <LibTraps.h>
00036
00037 /**
00038  * Make sure to move the HS_inc folder in front of the following headers when merging
00039  * new Access code drops.
00040  **/
00041 #include <Common/Libraries/HTTP/HS_HTTPLibApp.h>
00042 #include <Common/Libraries/HTTP/HS_HTTPLibConst.h>
00043
00044 /* struct */
00045
00046 /**
00047  * structure for glueing
00048  **/
00049
00050 struct HS_HTTPLibSplit_ {
00051     Char *s;        /**<        */
00052     Int32 len;      /**<        */
00053 };
00054 typedef struct HS_HTTPLibSplit_ HS_HTTPLibSplit;
00055
00056 struct HS_HTTPLibTime_ {
00057     Int32 day;      /**< days (either backward or forward) since 01 January, 1970 UTC */
00058     Int32 msec;     /**< milliseconds since midnight [0-86399999] */
00059 };
00060 typedef struct HS_HTTPLibTime_ HS_HTTPLibTime;
00061
00062 typedef void *HS_HTTPLibDataHandle; /**<        */
00063 typedef void *HS_HTTPLibVHandle;    /**<        */
00064 typedef void *HS_HTTPLibString;     /**<        */
00065 typedef void *HS_HTTPLibFixedString;    /**<        */
00066 typedef void *HS_HTTPLibURLString;  /**<        */
00067
00068 /**
00069  *
00070  **/
00071 struct HS_HTTPLibAuthInfo_ {
00072     HS_HTTPLibString fUser;     /**<        */
00073     HS_HTTPLibString fPass;     /**<        */
00074     HS_HTTPLibString fRealm;    /**<        */
00075     HS_HTTPLibString fChallenge;    /**<        */
00076     HS_HTTPLibString fNextNonce;    /**<        */
00077     Int32 fNC;          /**<        */
00078 };
00079 typedef struct HS_HTTPLibAuthInfo_ HS_HTTPLibAuthInfo;
00080
00081 /**
00082  * This sets the rules for HttpLib to use to select useragent for each request.
00083  * The rule should be set as little as possible so that it does not slow down
00084  * browser performance.
00085  **/
00086 enum {
00087     httpUASelectTypeHost,       /**<        */
00088     httpUASelectTypePath        /**<        */
00089 };
00090
00091 /**
00092  *
00093  **/
00094 typedef struct {
00095     Int32 fType;        /**<        */
00096     Char *fMatchString;     /**< substring to be matched */
00097     Char *fUserAgent;   /**<        */
00098 } HttpUASelectionRule;
00099
00100
00101 typedef void *HS_HTTPLibStream;         /**<        */
00102 typedef void *HS_HTTPLibSSL;            /**<        */
00103 typedef void *HS_HTTPLibCookies;        /**<        */
00104 typedef void *HS_HTTPLibCertPtr;        /**<        */
00105 typedef void *HS_HTTPLibCertList;       /**<        */
00106 typedef void *HS_HTTPLibClientCertList;     /**<        */
00107 typedef void *HS_HTTPLibSSLClassPtr;        /**<        */
00108
00109 typedef Int32 (*HS_HTTPLibCookieConfirmProc)(HS_HTTPLibCookies in_cookie, HS_HTTPLibURLString in_url, Char *in_header, Int32 in_header_len, HS_HTTPLibOpaque in_aux);   /**<        */
00110 typedef Int32 (*HS_HTTPLibServerCertConfirmProc)(HS_HTTPLibSSL in_ssl, Int32 in_verify_result, HS_HTTPLibCertList in_list, HS_HTTPLibOpaque in_aux);    /**<        */
00111 typedef Int32 (*HS_HTTPLibClientCertSelectProc)(HS_HTTPLibSSL in_ssl, HS_HTTPLibClientCertList in_list, HS_HTTPLibOpaque in_aux);   /**<        */
00112 typedef Int32 (*HS_HTTPLibTunnelingCallbackProc)(HS_HTTPLibStream stream, Char* buf, Int32 len, void *in_aux);      /**<        */
00113 typedef void (*HS_HTTPLibWakeUpCallbackProc)(HS_HTTPLibOpaque in_aux);      /**<        */
00114
00115 /* const */
00116
00117 /* API */
00118
00119 /**
00120  *  @brief This function opens the HTTP library and increments the open count. This
00121  *     function will create and initialize the library’s common data at first opening.
00122  *
00123  *  @param refnum:  IN:  Library reference number
00124  *  @return Error code.
00125  **/
00126 Err HS_HTTPLibOpen(UInt16 refnum)
00127         SYS_TRAP(kHTTPLibTrapOpen);
00128
00129 /**
00130  *  @brief This function decrements open count and finalizes the library’s common data at
00131  *     the last close.
00132  *
00133  *  @param refnum:  IN:  Library reference number
00134  *  @param usecountP:   OUT: Open count
00135  *  @return Error code.
00136  **/
00137 Err HS_HTTPLibClose(UInt16 refnum, UInt16* usecountP)
00138         SYS_TRAP(kHTTPLibTrapClose);
00139
00140 /**
00141  *  @brief Standard library sleep function.
00142  *
00143  *  @param refnum:  IN:  Library reference number
00144  *  @return Error code.
00145  **/
00146 Err HS_HTTPLibSleep(UInt16 refnum)
00147         SYS_TRAP(kHTTPLibTrapSleep);
00148
00149 /**
00150  *  @brief Standard library wake function.
00151  *
00152  *  @param refnum:  IN:  Library reference number
00153  *  @return Error code.
00154  **/
00155 Err HS_HTTPLibWake(UInt16 refnum)
00156         SYS_TRAP(kHTTPLibTrapWake);
00157
00158 /**
00159  *  @brief This function returns the open count of this library.
00160  *
00161  *  @param refnum:  IN:  Library reference number
00162  *  @return Open count.
00163  **/
00164 UInt16 HS_HTTPLibOpenCount(UInt16 refnum)
00165         SYS_TRAP(kHTTPLibTrapOpenCount);
00166
00167 /**
00168  *  @brief This function initializes the library instance and sets application dependent
00169  *         information in the global variables. The return value is the handle of library
00170  *     instance. If an error occurs during the initialization, the return value is NULL.
00171  *
00172  *  This call should be made after the application has called HS_HTTPLibOpen and
00173  *  assigned the HS_HTTPLibAppInfo, HS_HTTPLibNetLibInfo, and
00174  *  HS_HTTPLibPeer global variables with the application’s parameters. A reciprocal
00175  *  call to HS_HTTPLibFinalize should be made when the application is finished
00176  *  using the library.
00177  *
00178  *  @param refnum:  IN:  Library reference number
00179  *  @param *appInfoP:   IN:
00180  *  @param *netLibInfoP:    IN:
00181  *  @param *peerP:  IN:
00182  *  @retval HS_HTTPLibHandle
00183  *      non NULL if successful. NULL if failed
00184  **/
00185 HS_HTTPLibHandle HS_HTTPLibInitialize(UInt16 refnum, HS_HTTPLibAppInfo *appInfoP, HS_HTTPLibNetLibInfo *netLibInfoP, HS_HTTPLibPeer *peerP)
00186         SYS_TRAP(kHTTPLibTrapInitialize);
00187
00188 /**
00189  *  @brief This function finalizes the library instance.
00190  *
00191  *  This call should be made when the application is finished using the library.
00192  *
00193  *  @param refnum:  IN:  Library reference number
00194  *  @param libH:    IN:  The handle of HTTP library instance
00195  *  @return None.
00196  **/
00197 void HS_HTTPLibFinalize(UInt16 refnum, HS_HTTPLibHandle libH)
00198         SYS_TRAP(kHTTPLibTrapFinalize);
00199
00200 /**
00201  *  @brief
00202  *
00203  *  @param refnum:  IN:
00204  *  @param libH:    IN:
00205  *  @retval Err error code.
00206  **/
00207 HS_HTTPLibSSLClassPtr HS_HTTPLibSSLClass(UInt16 refnum, HS_HTTPLibHandle libH)
00208         SYS_TRAP(kHTTPLibTrapSSLClass);
00209
00210 /**
00211  *  @brief
00212  *
00213  *  @param refnum:  IN:
00214  *  @param libH:    IN:
00215  *  @param sslClassP:   IN:
00216  *  @retval Err error code.
00217  **/
00218 void HS_HTTPLibRegisterSSLClass(UInt16 refnum, HS_HTTPLibHandle libH, HS_HTTPLibSSLClassPtr sslClassP)
00219         SYS_TRAP(kHTTPLibTrapRegisterSSLClass);
00220
00221 /**
00222  *  @brief This function clears the DNS cache information.
00223  *
00224  *  @param refnum:  IN:  Library reference number
00225  *  @param libH:    IN:  The handle of HTTP library instance
00226  *  @return None.
00227  **/
00228 void HS_HTTPLibClearDNSCache(UInt16 refnum, HS_HTTPLibHandle libH)
00229         SYS_TRAP(kHTTPLibTrapClearDNSCache);
00230
00231 /**
00232  *  @brief This function closes the all idle keep alive sockets relating this application. Nonidle
00233  *     sockets are not closed by this function.
00234  *
00235  *  This call should be made at library finalization if keep-alive sockets are active.
00236  *
00237  *  @param refnum:  IN:  Library reference number
00238  *  @param libH:    IN:  The handle of HTTP library instance
00239  *  @return None.
00240  **/
00241 void HS_HTTPLibCloseAllKeepAlive(UInt16 refnum, HS_HTTPLibHandle libH)
00242         SYS_TRAP(kHTTPLibTrapCloseAllKeepAlive);
00243
00244 /**
00245  *  @brief Set the proxy information of this application to out_proxy_host,
00246  *     out_proxy_http_port, out_proxy_https_port, out_no_proxy_hosts.
00247  *     If out_proxy_host is NULL, the value of *out_proxy_http_port,
00248  *     *out_proxy_https_port, *out_no_proxy_hosts are not set, otherwise the values of
00249  *     *out_proxy_http_port, *out_proxy_https are set.
00250  *     If out_no_proxy_hosts is NULL, *out_no_proxy_hosts is not set.
00251  *     The format of out_no_proxy_hosts is the list separated by “,”.
00252  *     The responsibility of delete *out_proxy_host, *out_no_proxy_hosts is caller.
00253  *
00254  *  @param refnum:  IN:  Library reference number
00255  *  @param libH:    IN:  The handle of HTTP library instance
00256  *  @param *out_proxy_host: OUT:  The pointer to handle of proxy host string
00257  *  @param *out_proxy_http_port:    OUT:  The pointer to HTTP port number
00258  *  @param *out_proxy_https_port:   OUT:  The pointer to HTTPS port number
00259  *  @param *out_no_proxy_hosts: OUT:  The pointer to handle of the list string of hosts connect without using proxy server.
00260  *  @return None.
00261  **/
00262 void HS_HTTPLibMakeProxy(UInt16 refnum, HS_HTTPLibHandle libH, HS_HTTPLibFixedString *out_proxy_host, Int32 *out_proxy_http_port, Int32 *out_proxy_https_port, HS_HTTPLibString *out_no_proxy_hosts)
00263         SYS_TRAP(kHTTPLibTrapMakeProxy);
00264
00265 /**
00266  *  @brief This function sets the default HTTP port number. If there is no indication in URL,
00267  *     this port number is used for TCP connection.
00268  *
00269  *  @param refnum:  IN:  Library reference number
00270  *  @param libH:    IN:  The handle of HTTP library instance
00271  *  @param in_port:     IN:  The HTTP port number
00272  *  @return None.
00273  **/
00274 void HS_HTTPLibSetHTTPPort(UInt16 refnum, HS_HTTPLibHandle libH, Int32 in_port)
00275         SYS_TRAP(kHTTPLibTrapSetHTTPPort);
00276
00277 /**
00278  *  @brief This function sets the default HTTPS port number. If there is no indication in https
00279  *     URL, this port number is used for TCP connection.
00280  *
00281  *  @param refnum:  IN:  Library reference number
00282  *  @param libH:    IN:  The handle of HTTP library instance
00283  *  @param in_port:     IN:  The HTTPS port number
00284  *  @return None.
00285  **/
00286 void HS_HTTPLibSetHTTPSPort(UInt16 refnum, HS_HTTPLibHandle libH, Int32 in_port)
00287         SYS_TRAP(kHTTPLibTrapSetHTTPSPort);
00288
00289 /**
00290  *  @brief This function sets the maximal size of Request-Line. If in_size is -1, the maximal
00291  *     size is unlimited. Note that this function does not set the maximal size of Request-
00292  *     Header. See RFC2616 for the definitions of Request-Line and Request-Header.
00293  *
00294  *  @param refnum:  IN:  Library reference number
00295  *  @param libH:    IN:  The handle of HTTP library instance
00296  *  @param in_size:     IN:  The maximal size (byte)
00297  *  @return None.
00298  **/
00299 void HS_HTTPLibSetMaxRequestHeader(UInt16 refnum, HS_HTTPLibHandle libH, Int32 in_size)
00300         SYS_TRAP(kHTTPLibTrapSetMaxRequestHeader);
00301
00302 /**
00303  *  @brief This function sets the maximal size of Request-Body. If in_size is -1, the maximal
00304  *     size is unlimited.
00305  *
00306  *  @param refnum:  IN:  Library reference number
00307  *  @param libH:    IN:  The handle of HTTP library instance
00308  *  @param in_size:     IN:  The maximal size (byte)
00309  *  @return None.
00310  **/
00311 void HS_HTTPLibSetMaxRequestBody(UInt16 refnum, HS_HTTPLibHandle libH, Int32 in_size)
00312         SYS_TRAP(kHTTPLibTrapSetMaxRequestBody);
00313
00314 /**
00315  *  @brief This function sets the proxy server setting for this application. If in_proxy_host is
00316  *     NULL, in_proxy_host, in_proxy_http_port, in_proxy_https_port are not set.
00317  *     If in_no_proxy_hosts is NULL, in_no_proxy_hosts is not set. The format of
00318  *     in_no_proxy_hosts is comma (“,”) separated list.
00319  *
00320  *  This call can be grouped with other proxy setting calls if the application is making
00321  *  the same type of request for all the requests.
00322  *
00323  *  @param refnum:  IN:  Library reference number
00324  *  @param libH:    IN:  The handle of HTTP library instance
00325  *  @param *in_proxy_host:  IN:  The proxy host name
00326  *  @param in_proxy_host_len:   IN:  The length of in_proxy_host string
00327  *  @param in_proxy_http_port:  IN:  The HTTP port of proxy server
00328  *  @param in_proxy_https_port: IN:  The HTTPS port of proxy server
00329  *  @param *in_no_proxy_hosts:  IN:  The list of hosts not using proxy
00330  *  @param in_no_proxy_hosts_len:   IN:  The length of in_no_proxy_hosts
00331  *  @return
00332  *      True if setting is succeed.
00333  *      False if failed.(the main reason is memory shortage)
00334  **/
00335 Boolean HS_HTTPLibSetProxy(UInt16 refnum, HS_HTTPLibHandle libH, Char *in_proxy_host, Int32 in_proxy_host_len, Int32 in_proxy_http_port, Int32 in_proxy_https_port, Char *in_no_proxy_hosts, Int32 in_no_proxy_hosts_len)
00336         SYS_TRAP(kHTTPLibTrapSetProxy);
00337
00338 /**
00339  *  @brief This function sets the UserAgent string for the application. If in_useragent is
00340  *     NULL, setting is cleared.
00341  *
00342  *  This call allows the application to set the user agent identfication in the requests.
00343  *
00344  *  @param refnum:  IN:  Library reference number
00345  *  @param libH:    IN:  The handle of HTTP library instance
00346  *  @param *in_useragent:   IN:  The string of User Agent
00347  *  @param in_useragent_len:    IN:  The length of in_useragent
00348  *  @return
00349  *      True if setting is successful.
00350  *      False if failed.(The main reason is memory shortage.)
00351  **/
00352 Boolean HS_HTTPLibSetUserAgent(UInt16 refnum, HS_HTTPLibHandle libH, Char *in_useragent, Int32 in_useragent_len)
00353         SYS_TRAP(kHTTPLibTrapSetUserAgent);
00354
00355 /**
00356  *  @brief This function sets the default header, i.e. this string is added to the Request-header
00357  *     of the Request created at HS_HTTPLibStreamCreateRequest. If in_default_headers
00358  *     is NULL, the setting is cleared.
00359  *
00360  *  This call allows the application to set the application defined standard headers
00361  *  without having the populate each request with HS_HTTPLibStreamAddHeader.
00362  *
00363  *  @param refnum:  IN:  Library reference number
00364  *  @param libH:    IN:  The handle of HTTP library instance
00365  *  @param *in_default_headers:     IN:  The string of default header
00366  *  @param in_default_headers_len:  IN:  The length of in_default_headers
00367  *  @return
00368  *      True if setting is successful.
00369  *      False if failed. (The main reason is memory shortage.)
00370  **/
00371 Boolean HS_HTTPLibSetDefaultHeaders(UInt16 refnum, HS_HTTPLibHandle libH, Char *in_default_headers, Int32 in_default_headers_len)
00372         SYS_TRAP(kHTTPLibTrapSetDefaultHeaders);
00373
00374 /**
00375  *  @brief This function sets whether this application uses proxy server.
00376  *
00377  *  @param refnum:  IN:  Library reference number
00378  *  @param libH:    IN:  The handle of HTTP library instance
00379  *  @param in_bool:     IN:  True if using proxy server.
00380  *               False if not using proxy server.
00381  *  @return None.
00382  **/
00383 void HS_HTTPLibSetUseProxy(UInt16 refnum, HS_HTTPLibHandle libH, Boolean in_bool)
00384         SYS_TRAP(kHTTPLibTrapSetUseProxy);
00385
00386 /**
00387  *  @brief This function sets whether this application permits HTTP1.1 over proxy server. If
00388  *     false is set, the application use HTTP/1.0.
00389  *
00390  *  @param refnum:  IN:  Library reference number
00391  *  @param libH:    IN:  The handle of HTTP library instance
00392  *  @param in_bool:     IN:  True if permitting HTTP/1.1 over proxy server
00393  *               False if not permitting HTTP/1.1 over proxy server
00394  *  @return None.
00395  **/
00396 void HS_HTTPLibSetHTTP11OverProxy(UInt16 refnum, HS_HTTPLibHandle libH, Boolean in_bool)
00397         SYS_TRAP(kHTTPLibTrapSetHTTP11OverProxy);
00398
00399 /**
00400  *  @brief
00401  *
00402  *  @param refnum:  IN:
00403  *  @param libH:    IN:
00404  *  @param in_bool:     IN:
00405  *  @retval Err error code.
00406  **/
00407 void HS_HTTPLibSetSendReferer(UInt16 refnum, HS_HTTPLibHandle libH, Boolean in_bool)
00408         SYS_TRAP(kHTTPLibTrapSetSendReferer);
00409
00410 /**
00411  *  @brief
00412  *
00413  *  @param refnum:  IN:
00414  *  @param libH:    IN:
00415  *  @param in_bool:     IN:
00416  *  @retval Err error code.
00417  **/
00418 void HS_HTTPLibSetSendProxyKeepAlive(UInt16 refnum, HS_HTTPLibHandle libH, Boolean in_bool)
00419         SYS_TRAP(kHTTPLibTrapSetSendProxyKeepAlive);
00420
00421 /**
00422  *  @brief This function sets whether this application sends Cookie.
00423  *
00424  *  @param refnum:  IN:  Library reference number
00425  *  @param libH:    IN:  The handle of HTTP library instance
00426  *  @param in_bool:     IN:  True if sending Cookie
00427  *               False if not sending Cookie
00428  *  @return None.
00429  **/
00430 void HS_HTTPLibSetSendCookie(UInt16 refnum, HS_HTTPLibHandle libH, Boolean in_bool)
00431         SYS_TRAP(kHTTPLibTrapSetSendCookie);
00432
00433 /**
00434  *  @brief This function sets the limit of Connection timeout. If in_msec is -1, no timeout is
00435  *     set. The condition of timeout is in_msec has passed from TCP connect without
00436  *     HTTP connection established.
00437  *
00438  *  With this function the different connection timeouts can be set at library
00439  *  initialization.
00440  *
00441  *  @param refnum:  IN:  Library reference number
00442  *  @param libH:    IN:  The handle of HTTP library instance
00443  *  @param in_msec:     IN:  Time Limit (msec)
00444  *  @retval Nothing
00445  **/
00446 void HS_HTTPLibSetConnectTimeOut(UInt16 refnum, HS_HTTPLibHandle libH, Int32 in_msec)
00447         SYS_TRAP(kHTTPLibTrapSetConnectTimeOut);
00448
00449 /**
00450  *  @brief This function sets the limit of sending Request timeout. If in_msec is -1, no timeout
00451  *     is set. The condition of timeout is in_msec has passed from the start of Request
00452  *     sending without sending done.
00453  *
00454  *  @param refnum:  IN:  Library reference number
00455  *  @param libH:    IN:  The handle of HTTP library instance
00456  *  @param in_msec:     IN:  Time Limit (msec)
00457  *  @return None.
00458  **/
00459 void HS_HTTPLibSetReqTimeOut(UInt16 refnum, HS_HTTPLibHandle libH, Int32 in_msec)
00460         SYS_TRAP(kHTTPLibTrapSetReqTimeOut);
00461
00462 /**
00463  *  @brief This function sets the limit of receiving Response timeout. If in_msec is -1, no
00464  *     timeout is set. The condition of timeout is in_msec has passed from the end of
00465  *     sending request without receiving Response. Or in_msec has passed from the last
00466  *     receiving a part of Response without receiving any part of Response.
00467  *
00468  *  @param refnum:  IN:  Library reference number
00469  *  @param libH:    IN:  The handle of HTTP library instance
00470  *  @param in_msec:     IN:  Time Limit (msec)
00471  *  @retval Nothing
00472  **/
00473 void HS_HTTPLibSetRspTimeOut(UInt16 refnum, HS_HTTPLibHandle libH, Int32 in_msec)
00474         SYS_TRAP(kHTTPLibTrapSetRspTimeOut);
00475
00476 /**
00477  *  @brief
00478  *
00479  *  @param refnum:  IN:
00480  *  @param libH:    IN:
00481  *  @param in_cb:   IN:
00482  *  @param *in_aux: IN:
00483  *  @retval Err error code.
00484  **/
00485 void HS_HTTPLibSetTunnelingCallback(UInt16 refnum, HS_HTTPLibHandle libH, HS_HTTPLibTunnelingCallbackProc in_cb, void *in_aux)
00486         SYS_TRAP(kHTTPLibTrapSetTunnelingCallback);
00487
00488 /**
00489  *  @brief This function returns whether this application uses proxy.
00490  *
00491  *  @param refnum:  IN:  Library reference number
00492  *  @param libH:    IN:  The handle of HTTP library instance
00493  *  @return
00494  *      True if this application uses proxy.
00495  *      False if this application does not uses proxy.
00496  **/
00497 Boolean HS_HTTPLibIsUseProxy(UInt16 refnum, HS_HTTPLibHandle libH)
00498         SYS_TRAP(kHTTPLibTrapIsUseProxy);
00499
00500 /**
00501  *  @brief This function returns whether this application permits HTTP/1.1 over proxy.
00502  *
00503  *  @param refnum:  IN:  Library reference number
00504  *  @param libH:    IN:  The handle of HTTP library instance
00505  *  @return
00506  *      True if this application permits HTTP/1.1 over proxy.
00507  *      False if this application does not permit HTTP/1.1 over proxy.
00508  **/
00509 Boolean HS_HTTPLibIsHTTP11OverProxy(UInt16 refnum, HS_HTTPLibHandle libH)
00510         SYS_TRAP(kHTTPLibTrapIsHTTP11OverProxy);
00511
00512 /**
00513  *  @brief
00514  *
00515  *  @param refnum:  IN:
00516  *  @param libH:    IN:
00517  *  @retval Err error code.
00518  **/
00519 Boolean HS_HTTPLibIsSendReferer(UInt16 refnum, HS_HTTPLibHandle libH)
00520         SYS_TRAP(kHTTPLibTrapIsSendReferer);
00521
00522 /**
00523  *  @brief This function returns whether this application sends Cookie.
00524  *
00525  *  @param refnum:  IN:  Library reference number
00526  *  @param libH:    IN:  The handle of HTTP library instance
00527  *  @return
00528  *      True if this application sends Cookie.
00529  *      False if this application does not send Cookie.
00530  **/
00531 Boolean HS_HTTPLibIsSendCookie(UInt16 refnum, HS_HTTPLibHandle libH)
00532         SYS_TRAP(kHTTPLibTrapIsSendCookie);
00533 /**
00534  *  @brief This function creates a new stream and returns the handle of stream instance. At
00535  *     this time, TCP/SSL socket is not opened.
00536  *
00537  *  @param refnum:  IN:  Library reference number
00538  *  @param libH:    IN:  The handle of HTTP library instance
00539  *  @return
00540  *      non NULL if successful.
00541  *      NULL if failed (the main reason is memory shortage).
00542  **/
00543 HS_HTTPLibStream HS_HTTPLibStreamNew(UInt16 refnum, HS_HTTPLibHandle libH)
00544         SYS_TRAP(kHTTPLibTrapStreamNew);
00545
00546 /**
00547  *  @brief This function deletes the stream instance. If this function is called without calling
00548  *     HS_HTTPLibStreamClose, this function closes the TCP/SSL socket by calling
00549  *     HS_HTTPLibStreamClose, however if the socket is in keep-alive, it is not closed.
00550  *
00551  *  @param refnum:  IN:  Library reference number
00552  *  @param stream:  IN:  The handle of stream instance.
00553  *  @return None.
00554  **/
00555 void HS_HTTPLibStreamDelete(UInt16 refnum, HS_HTTPLibStream stream)
00556         SYS_TRAP(kHTTPLibTrapStreamDelete);
00557
00558 /**
00559  *  @brief This function creates a request. If using proxy and SSL connection, CONNECT
00560  *     request message is made. If there are cached authenticate informations, add
00561  *     authenticate header. Add default headers and in_header to Request-Header.
00562  *
00563  *  @param refnum:  IN:  Library reference number.
00564  *  @param stream:  IN:  The handle of stream instance.
00565  *  @param in_method:   IN:  The HTTP method
00566  *               httpMethodGET GET
00567  *               httpMethodPOST POST
00568  *  @param *in_url: IN:  The URL string.
00569  *  @param in_url_len:  IN:  The length of in_url.
00570  *  @param *in_header:  IN:  The header string to add the Request-Header.
00571  *               Each line is terminated by <CR><LF>.
00572  *  @param in_header_len:   IN:  The length of in_header.
00573  *  @param *in_referer: IN:  The referer string.
00574  *  @param in_referer_len:  IN:  The length of in_referer.
00575  *  @param in_version:  IN:  The version
00576  *               httpVersion_0_9 HTTP/0.9
00577  *               httpVersion_1_0 HTTP/1.0
00578  *               httpVersion_1_1 HTTP/1.1
00579  *  @param in_no_cache: IN:  True if no-cache is added to the header
00580  *               False if no-cache is not added to the header
00581  *  @param in_pipeline: IN:  True if doing pipeline
00582  *               False if not doing pipeline
00583  *  @param in_ssl_flag: IN:  The flag sent to SSL instance.
00584  *               httpSSLFlagConnV2 connect by v2 protocol
00585  *               httpSSLFlagConnV3 connect by v3 protocol
00586  *               httpSSLFlagConnTLS connect by TLS(v3.1) protocol
00587  *               httpSSLFlagConnV2V3 autoselect within v2,v3
00588  *               httpSSLFlagConnV2TLS autoselect within v2,tls
00589  *               httpSSLFlagConnV3TLS autoselect within v3,tls
00590  *               httpSSLFlagConnV2V3TLS autoselect within v2,v3,tls
00591  *  @return
00592  *      httpErrorOK succeed
00593  *      httpErrorNoMem memory shortage
00594  *      httpErrorReqHeaderSizeOver if Request header size is over the maximal
00595  *      setting. If the Request-Line size is set to unlimited, httpErrorReqHeaderSizeOver
00596  *      is not returned.
00597  **/
00598 Int32 HS_HTTPLibStreamCreateRequest(UInt16 refnum, HS_HTTPLibStream stream, Int32 in_method, Char *in_url, UInt32 in_url_len,Char *in_header, UInt32 in_header_len,Char *in_referer, UInt32 in_referer_len, Int32 in_version, Boolean in_no_cache,Boolean in_pipeline, Int32 in_ssl_flag)
00599         SYS_TRAP(kHTTPLibTrapStreamCreateRequest);
00600
00601 /**
00602  *  @brief This function creates request for chunk-encoding post. If using proxy and SSL
00603  *     connection, CONNECT request message is made. If there are cached authenticate
00604  *     informations, add authenticate header. Add default headers and in_header to
00605  *     Request-Header.
00606  *     Do not use this API unless you want to create chunk-encoding request. Transfer-
00607  *     Encoding: chunked is added to the request header.
00608  *
00609  *  @param refnum:  IN:  Library reference number.
00610  *  @param stream:  IN:  The handle of stream instance.
00611  *  @param in_method:   IN:  The HTTP method
00612  *               httpMethodGET GET
00613  *               httpMethodPOST POST
00614  *  @param *in_url: IN:  The URL string.
00615  *  @param in_url_len:  IN:  The length of in_url.
00616  *  @param *in_header:  IN:  The header string to add the Request-Header.
00617  *               Each line is terminated by <CR><LF>.
00618  *  @param in_header_len:   IN:  The length of in_header.
00619  *  @param *in_referer: IN:  The referer string.
00620  *  @param in_referer_len:  IN:  The length of in_referer.
00621  *  @param in_version:  IN:  The version
00622  *               httpVersion_0_9 HTTP/0.9
00623  *               httpVersion_1_0 HTTP/1.0
00624  *               httpVersion_1_1 HTTP/1.1
00625  *  @param in_no_cache: IN:  True if no-cache is added to the header
00626  *               False if no-cache is not added to the header
00627  *  @param in_pipeline: IN:  True if doing pipeline
00628  *               False if not doing pipeline
00629  *  @param in_ssl_flag: IN:  The flag sent to SSL instance.
00630  *               httpSSLFlagConnV2 connect by v2 protocol
00631  *               httpSSLFlagConnV3 connect by v3 protocol
00632  *               httpSSLFlagConnTLS connect by TLS(v3.1) protocol
00633  *               httpSSLFlagConnV2V3 autoselect within v2,v3
00634  *               httpSSLFlagConnV2TLS autoselect within v2,tls
00635  *               httpSSLFlagConnV3TLS autoselect within v3,tls
00636  *               httpSSLFlagConnV2V3TLS autoselect within v2,v3,tls
00637  *  @return
00638  *      httpErrorOK succeed
00639  *      httpErrorNoMem memory shortage
00640  *      httpErrorReqHeaderSizeOver if the Request header size is over the maximal
00641  *      setting. If the Request-Line size is set to unlimited, httpErrorReqHeaderSizeOver
00642  *      is not returned.
00643  **/
00644 Int32 HS_HTTPLibStreamCreateRequestWithChunkEncoding(UInt16 refnum, HS_HTTPLibStream stream, Int32 in_method, Char *in_url, UInt32 in_url_len,Char *in_header, UInt32 in_header_len,Char *in_referer, UInt32 in_referer_len, Int32 in_version, Boolean in_no_cache,Boolean in_pipeline, Int32 in_ssl_flag)
00645         SYS_TRAP(kHTTPLibTrapStreamCreateRequestWithChunkEncoding);
00646
00647 /**
00648  *  @brief This function sends the request. This call opens and connects a TCP connection if
00649  *     not already established. It automatically retries at where pipeline stalled if pipeline
00650  *     is enable.
00651  *
00652  *  Because the data streaming could block and resume at where the pipeline was
00653  *  stalled, the application can call this function in a loop until the sending is finished.
00654  *
00655  *  @param refnum:  IN:  Library reference number.
00656  *  @param stream:  IN:  The handle of stream instance.
00657  *  @param *out_sleep:  OUT:  The time of the application can sleep (msec).
00658  *               This value is not used for application.
00659  *  @return
00660  *      httpErrorOK sending done
00661  *      httpErrorWouldBlock application can call this function consecutively
00662  *      httpErrorIOSleep application can sleep
00663  *      httpErrorNoMem memory shortage
00664  *          httpErrorDNSInval DNS message invalid
00665  *      httpErrorDNSNoServer DNS server is not found
00666  *      httpErrorDNSTimedout Timeout at DNS resolve
00667  *      httpErrorDNSNotFound DNS server can not find the name
00668  *      httpErrorTCPOpen cannot open TCP
00669  *      httpErrorTCPConnec cannot connect TCP
00670  *      httpErrorTCPRead cannot read TCP
00671  *      httpErrorTCPWrite cannot write TCP
00672  *      httpErrorSSLConnect cannot Proxy Tunneling
00673  *      httpErrorSSLHandShake cannot SSL handshake
00674  *      httpErrorSSLRead cannot SSL read
00675  *      httpErrorSSLWrite cannot SSL write
00676  *      httpErrorReqTimedout request timeout
00677  *      httpErrorRspTimedout response timeout at Proxy Tunneling (SSL only)
00678  **/
00679 Int32 HS_HTTPLibStreamSendRequest(UInt16 refnum, HS_HTTPLibStream stream,Int32 *out_sleep)
00680         SYS_TRAP(kHTTPLibTrapStreamSendRequest);
00681
00682 /**
00683  *  @brief This function sends the POST request. This call opens and connects a TCP
00684  *     connection if not already established. It automatically retries at where pipeline
00685  *     stalled if pipeline is enable.
00686  *
00687  *  Because the data streaming could block and resume at where the pipeline was
00688  *  stalled, the application can call this function in a loop until the sending is finished.
00689  *
00690  *  @param refnum:  IN:  Library reference number.
00691  *  @param stream:  IN:  The handle of stream instance.
00692  *  @param *in_buf: IN:  The pointer to POST data.
00693  *  @param in_len:  IN:  The length of in_buf.
00694  *  @param *out_len:    OUT:  The size of sending data at this time (byte).
00695  *  @param *out_sleep:  OUT:  The time of the application can sleep (msec)
00696  *               This value is not used for application.
00697  *  @return
00698  *      httpErrorOK sending done
00699  *      httpErrorWouldBlock application can call this function consecutively
00700  *      httpErrorIOSleep application can sleep
00701  *      httpErrorNoMem memory shortage
00702  *      httpErrorDNSInval DNS message invalid
00703  **/
00704 Int32 HS_HTTPLibStreamSendRequestWithPostData(UInt16 refnum, HS_HTTPLibStream stream, Char *in_buf, Int32 in_len, Int32 *out_len, Int32 *out_sleep)
00705         SYS_TRAP(kHTTPLibTrapStreamSendRequestWithPostData);
00706
00707 /**
00708  *  @brief This function sends chunk encoding data. This call opens and connects a TCP
00709  *     connection if not already established. It automatically retries at where pipeline
00710  *     stalled if pipeline is enable.
00711  *     The sequence of chunked data sending is
00712  *     1. call HS_HTTPLibStreamCreateRequestWithChunkEncoding()
00713  *     2. call HS_HTTPLibStreamSendRequestWithChunkEncoding() while return
00714  *     value is not httpErrorOK or error.
00715  *     3. If there remains data, goto 2.
00716  *     4. end
00717  *     If only one chunked data is sent, this API returns httpErrorOK.
00718  *     The address of data for one chunk is in_buf + in_offset, this value should not be
00719  *     changed while sending only one chunked data.
00720  *     isFinish is used to indicate the chunked data is the last chunk.
00721  *
00722  *  @param refnum:  IN:  Library reference number
00723  *  @param stream:  IN:  The handle of stream instance.
00724  *  @param *in_buf:     IN:  The pointer to POST data.
00725  *  @param in_offset:   IN:  The offset to POST data.
00726  *  @param in_len:  IN:  The length of in_buf.
00727  *  @param isFinish:    IN:  True if the send data is the last chunk.
00728  *               False if send data is not the last chunk.
00729  *  @param *out_len:    OUT:  The size of sending data at this time (byte).
00730  *  @param *out_sleep:  OUT:  The time of the application can sleep (msec)
00731  *               This value is not used for application.
00732  *  @return
00733  *      httpErrorOK sending done
00734  *      httpErrorWouldBlock application can call this function consecutively
00735  *      httpErrorIOSleep application can sleep
00736  *      httpErrorNoMem memory shortage
00737  *      httpErrorDNSInval DNS message invalid
00738  *      httpErrorDNSNoServer DNS server is not found
00739  *      httpErrorDNSTimedout Timeout at DNS resolve
00740  *      httpErrorDNSNotFound DNS server can not find the name
00741  *      httpErrorTCPOpen cannot open TCP
00742  *      httpErrorTCPConnec cannot connect TCP
00743  *      httpErrorTCPRead cannot read TCP
00744  *      httpErrorTCPWrite cannot write TCP
00745  *      httpErrorSSLConnect cannot Proxy Tunneling
00746  *      httpErrorSSLHandShake cannot SSL handshake
00747  *      httpErrorSSLRead cannot read SSL
00748  *      httpErrorSSLWrite cannot write SSL
00749  *      httpErrorReqTimedout request timeout
00750  *      httpErrorRspTimedout response timeout at Proxy Tunneling (SSL only)
00751  **/
00752 Int32 HS_HTTPLibStreamSendRequestWithChunkEncoding(UInt16 refnum, HS_HTTPLibStream stream, Char *in_buf, Int32 in_offset, Int32 in_len, Boolean isFinish, Int32 *out_len, Int32 *out_sleep)
00753         SYS_TRAP(kHTTPLibTrapStreamSendRequestWithChunkEncoding);
00754
00755 /**
00756  *  @brief This function receives response. It automatically retries at where pipeline stalled if
00757  *     pipeline is enable.
00758  *
00759  *  Because the data streaming could block and resume at where the pipeline was
00760  *  stalled, the application can call this function in a loop until the receiving is finished.
00761  *
00762  *  @param refnum:  IN:  Library reference number.
00763  *  @param stream:  IN:  The handle of stream instance.
00764  *  @param *out_buf:    OUT:  The pointer to the receive buffer.
00765  *  @param in_len:  IN:  The size of the receive buffer (byte).
00766  *  @param *out_len:    OUT:  The received size (byte).
00767  *  @param *out_sleep:  OUT:  The time of the application can sleep (msec)
00768  *                This value is not used for application.
00769  *  @return
00770  *      httpErrorOK receiving done
00771  *      httpErrorWouldBlock application can call this function
00772  *      consecutively
00773  *      httpErrorIOSleep application can sleep
00774  *      httpErrorNoMem memory shortage
00775  *      httpErrorTCPRead cannot read TCP
00776  *      httpErrorTCPWrite cannot write TCP
00777  *      httpErrorSSLHandShake cannot SSL handshake
00778  *      httpErrorSSLRead cannot read SSL
00779  *      httpErrorSSLWrite cannot write SSL
00780  *      httpErrorReqTimedout request timeout
00781  *      httpErrorRspTimedout response timeout
00782  *      httpErrorAuthUnknown unknown authentication type
00783  *      httpErrorAuthNoHeader authentication request without
00784  *      authentication header
00785  *      httpErrorAuthFormat wrong format of authentication header
00786  *      httpErrorRedirectFormat wrong format of redirect header
00787  *      httpErrorRedirectCanceled redirect is canceled by user
00788  *      httpErrorRspHeaderSizeOver size over of response header
00789  *      httpErrorReqTooManyContinue it exceeds the limit times of Continue
00790  **/
00791 Int32 HS_HTTPLibStreamReceiveResponse(UInt16 refnum, HS_HTTPLibStream stream, Char *out_buf, Int32 in_len, Int32 *out_len, Int32 *out_sleep)
00792         SYS_TRAP(kHTTPLibTrapStreamReceiveResponse);
00793
00794 /**
00795  *  @brief
00796  *
00797  *  @param refnum:  IN:
00798  *  @param stream:  IN:
00799  *  @retval Err error code.
00800  **/
00801 Int32 HS_HTTPLibStreamGetFlag(UInt16 refnum, HS_HTTPLibStream stream)
00802         SYS_TRAP(kHTTPLibTrapStreamGetFlag);
00803
00804 /**
00805  *  @brief
00806  *
00807  *  @param refnum:  IN:
00808  *  @param stream:  IN:
00809  *  @retval Err error code.
00810  **/
00811 void HS_HTTPLibStreamSuspendTimer(UInt16 refnum, HS_HTTPLibStream stream)
00812         SYS_TRAP(kHTTPLibTrapStreamSuspendTimer);
00813 /**
00814  *  @brief
00815  *
00816  *  @param refnum:  IN:
00817  *  @param stream:  IN:
00818  *  @retval Err error code.
00819  **/
00820 void HS_HTTPLibStreamResumeTimer(UInt16 refnum, HS_HTTPLibStream stream)
00821         SYS_TRAP(kHTTPLibTrapStreamResumeTimer);
00822
00823 /**
00824  *  @brief This function closes the HTTP stream. If the TCP/SSL socket is in keep-alive, it is
00825  *     not closed.
00826  *
00827  *  @param refnum:  IN:  Library reference number
00828  *  @param stream:  IN:  The handle of stream instance.
00829  *  @return None.
00830  **/
00831 void HS_HTTPLibStreamClose(UInt16 refnum, HS_HTTPLibStream stream)
00832         SYS_TRAP(kHTTPLibTrapStreamClose);
00833
00834 /**
00835  *  @brief This function returns whether the response header is completely received.
00836  *
00837  *  This function is typically called after HS_HTTPLibStreamReceiveResponse when
00838  *  receiving the response header.
00839  *
00840  *  @param refnum:  IN:  Library reference number.
00841  *  @param stream:  IN:  The handle of stream instance.
00842  *  @return
00843  *      True if header is completely received.
00844  *      False if header is not received.
00845  **/
00846 Boolean HS_HTTPLibStreamIsHeaderReceived(UInt16 refnum, HS_HTTPLibStream stream)
00847         SYS_TRAP(kHTTPLibTrapStreamIsHeaderReceived);
00848
00849 /**
00850  *  @brief This function sets the POST data.
00851  *
00852  *  @param refnum:  IN:  Library reference number.
00853  *  @param stream:  IN:  The handle of stream instance.
00854  *  @param in_encoding: IN:  The type of encoding.
00855  *               httpPostURLENCODED URL encoding
00856  *               httpPostPLAINTEXT plain text (non encoding)
00857  *               httpPostMULTIPART multi-part encoding
00858  *  @param *in_data:    IN:  The pointer to the POST data.
00859  *  @param in_len:  IN:  The length of in_data.
00860  *  @return
00861  *      httpErrorOK setting done
00862  *      httpErrorNoMem memory shortage
00863  *      httpErrorReqBodySizeOver the size of request body exceeds limit. If the
00864  *      application does not set the limit by
00865  *      HS_HTTPLibSetMaxRequestBody,
00866  *      httpErrorReqBodySizeOver is not returned.
00867  **/
00868 Int32 HS_HTTPLibStreamSetPostData(UInt16 refnum, HS_HTTPLibStream stream, Int32 in_encoding, Char *in_data, Int32 in_len)
00869         SYS_TRAP(kHTTPLibTrapStreamSetPostData);
00870
00871 /**
00872  *  @brief This function returns the scheme given at the HS_HTTPLibStreamCreateRequest.
00873  *
00874  *  @param refnum:  IN:  Library reference number.
00875  *  @param stream:  IN:  The handle of stream instance.
00876  *  @return
00877  *      httpSchemeHTTP HTTP
00878  *      httpSchemeHTTPS HTTPS
00879  **/
00880 Int32 HS_HTTPLibStreamGetScheme(UInt16 refnum, HS_HTTPLibStream stream)
00881         SYS_TRAP(kHTTPLibTrapStreamGetScheme);
00882
00883 /**
00884  *  @brief This function returns the state of the stream. The state changes follow the below
00885  *     sequence (but skipping the states that are not relevant to the current request).
00886  *
00887  *  @param refnum:  IN:  Library reference number.
00888  *  @param stream:  IN:  The handle of stream instance.
00889  *  @return
00890  *      httpStreamStateNew The instance is created
00891  *      httpStreamStateDormant The instance is dormant
00892  *      httpStreamStateReqCreated The request is created
00893  *      httpStreamStateReqResolve Name resolve begins
00894  *      httpStreamStateReqResolving Name resolving
00895  *      httpStreamStateReqOpen TCP/SSL open
00896  *      httpStreamStateReqConnect TCP connect begins
00897  *      httpStreamStateReqConnecting TCP connecting
00898  *      httpStreamStateReqProxyConnect Proxy Tunneling begins
00899  *      httpStreamStateReqProxyConnecting Proxy Tunneling
00900  *      httpStreamStateReqSSLHandShaking SSL HandShaking
00901  *      httpStreamStateReqSSLHandShaked SSL handShake done
00902  *      httpStreamStateReqSending Sending the request
00903  *      httpStreamStateReqSent Sending the request done
00904  *      httpStreamStateRspHeaderWaiting Waiting the response header
00905  *      httpStreamStateRspContinue Waiting response receiving done for
00906  *      Status-Code 100
00907  *      httpStreamStateRspHeaderReceiving Receiving the response header
00908  *      httpStreamStateRspHeaderReceived Receiving the response header done
00909  *      httpStreamStateRspEntityReceiving Receiving the response body
00910  **/
00911 Int32 HS_HTTPLibStreamGetState(UInt16 refnum, HS_HTTPLibStream stream)
00912         SYS_TRAP(kHTTPLibTrapStreamGetState);
00913
00914 /**
00915  *  @brief This function returns the Status Code.
00916  *
00917  *  @param refnum:  IN:  Library reference number.
00918  *  @param stream:  IN:  The handle of stream instance.
00919  *  @return
00920  *      httpStatusCodeContinue 100
00921  *      httpStatusCodeSwitchingProtocols 101
00922  *      httpStatusCodeOK 200
00923  *      httpStatusCodeCreated 201
00924  *      httpStatusCodeAccepted 202
00925  *      httpStatusCodeNonAuthoritativeInformation 203
00926  *      httpStatusCodeNoContent 204
00927  *      httpStatusCodeResetContent 205
00928  *      httpStatusCodePartialContent 206
00929  *      httpStatusCodeMultipleChoices 300
00930  *      httpStatusCodeMovedPermanently 301
00931  *      httpStatusCodeFound 302
00932  *      httpStatusCodeSeeOther 303
00933  *      httpStatusCodeNotModified 304
00934  *      httpStatusCodeUseProxy 305
00935  *      httpStatusCodeTemporaryRedirect 307
00936  *      httpStatusCodeBadRequest 400
00937  **/
00938 Int32 HS_HTTPLibStreamGetStatusCode(UInt16 refnum, HS_HTTPLibStream stream)
00939         SYS_TRAP(kHTTPLibTrapStreamGetStatusCode);
00940
00941 /**
00942  *  @brief This function returns the size of the response header.
00943  *
00944  *  @param refnum:  IN:  Library reference number.
00945  *  @param stream:  IN:  The handle of stream instance.
00946  *  @return
00947  *      header size (byte)
00948  *      -1 if not received
00949  **/
00950 Int32 HS_HTTPLibStreamGetResponseHeaderLength(UInt16 refnum, HS_HTTPLibStream stream)
00951         SYS_TRAP(kHTTPLibTrapStreamGetResponseHeaderLength);
00952
00953 /**
00954  *  @brief This function returns the handle of the response header. The responsibility to
00955  *     delete the handle is library, the application can not delete this return value.
00956  *     To lock/unlock the handle, the application should use the APIs,
00957  *
00958  *  @param refnum:  IN:  Library reference number.
00959  *  @param stream:  IN:  The handle of stream instance.
00960  *  @return
00961  *      non NULL the handle of header
00962  *      NULL if not received
00963  **/
00964 HS_HTTPLibVHandle HS_HTTPLibStreamGetResponseHeader(UInt16 refnum, HS_HTTPLibStream stream)
00965         SYS_TRAP(kHTTPLibTrapStreamGetResponseHeader);
00966
00967 /**
00968  *  @brief This function returns the content’s size (byte).
00969  *
00970  *  @param refnum:  IN:  Library reference number.
00971  *  @param stream:  IN:  The handle of stream instance.
00972  *  @return
00973  *      The Content-Length (byte)
00974  *      -1 if not received
00975  **/
00976 Int32 HS_HTTPLibStreamGetContentLength(UInt16 refnum, HS_HTTPLibStream stream)
00977         SYS_TRAP(kHTTPLibTrapStreamGetContentLength);
00978
00979 /**
00980  *  @brief This function returns the size of response body (byte).
00981  *
00982  *  @param refnum:  IN:  Library reference number.
00983  *  @param stream:  IN:  The handle of stream instance.
00984  *  @return
00985  *      The size of response body (byte)
00986  *      -1 if not received
00987  **/
00988 Int32 HS_HTTPLibStreamGetEntityLength(UInt16 refnum, HS_HTTPLibStream stream)
00989         SYS_TRAP(kHTTPLibTrapStreamGetEntityLength);
00990
00991 /**
00992  *  @brief This function adds the line to the Request header. If there is already the same kind
00993  *          of header line, old one is deleted.
00994  *
00995  *  @param refnum:  IN:  Library reference number.
00996  *  @param stream:  IN:  The handle of stream instance.
00997  *  @param *in_str: IN:  The pointer to the header strong to add.
00998  *  @param in_len:  IN:  The length of in_str.
00999  *  @return
01000  *      True if successful.
01001  *      False failed (memory shortage)
01002  **/
01003 Boolean HS_HTTPLibStreamAddHeaderLine(UInt16 refnum, HS_HTTPLibStream stream, Char *in_str, Int32 in_len)
01004         SYS_TRAP(kHTTPLibTrapStreamAddHeaderLine);
01005
01006 /**
01007  *  @brief This function sets the value of corresponding header. If there is already the same
01008  *         kind of header line, old one is deleted.
01009  *
01010  *  @param refnum:  IN:  Library reference number.
01011  *  @param stream:  IN:  The handle of stream instance.
01012  *  @param in_type: IN:  The type of header (See httpHeaderIDEnum).
01013  *  @param *in_str: IN:  The pointer to the header value string.
01014  *  @param in_len:  IN:  The length of in_str.
01015  *  @return
01016  *      True if successful
01017  *      False failed (memory shortage)
01018  **/
01019 Boolean HS_HTTPLibStreamAddHeader(UInt16 refnum, HS_HTTPLibStream stream, Int32 in_type, Char *in_str, Int32 in_len)
01020         SYS_TRAP(kHTTPLibTrapStreamAddHeader);
01021
01022 /**
01023  *  @brief This function returns the offset and length of corresponding header value.
01024  *
01025  *  @param refnum:  IN:  Library reference number.
01026  *  @param stream:  IN:  The handle of stream instance.
01027  *  @param in_type: IN:  The type of header (See httpHeaderIDEnum).
01028  *  @param *out_off:    IN:  The offset to the header value.
01029  *  @param *out_len:    IN:  The length of corresponding header value.
01030  *  @return
01031  *      True if successful
01032  *      False there is no corresponding header
01033  **/
01034 Boolean HS_HTTPLibStreamGetHeader(UInt16 refnum, HS_HTTPLibStream stream, Int32 in_type, Int32 *out_off, Int32 *out_len)
01035         SYS_TRAP(kHTTPLibTrapStreamGetHeader);
01036
01037 /**
01038  *  @brief This function returns the Server certification used for SSL. The responsibility to
01039  *     delete the return handle is the application. To delete the return value, the
01040  *     application should use HS_HTTPLibCertListDelete.
01041  *
01042  *  @param refnum:  IN:  Library reference number.
01043  *  @param stream:  IN:  The handle of stream instance.
01044  *  @return
01045  *      The handle of SSL server certification chain.
01046  *      NULL if no server certification or memory shortage.
01047  **/
01048 HS_HTTPLibCertList HS_HTTPLibMakeCertList(UInt16 refnum, HS_HTTPLibStream stream)
01049         SYS_TRAP(kHTTPLibTrapMakeCertList);
01050
01051 /**
01052  *  @brief
01053  *
01054  *  @param refnum:  IN:
01055  *  @param *inout_ss:   IN:
01056  *  @param in_id:   IN:
01057  *  @param *in_cs:  IN:
01058  *  @retval Err error code.
01059  **/
01060 Boolean HS_HTTPLibHeaderSplitByX(UInt16 refnum, HS_HTTPLibSplit *inout_ss, Int32 in_id, Char *in_cs)
01061         SYS_TRAP(kHTTPLibTrapHeaderSplitByX);
01062
01063 /**
01064  *  @brief This function initialize/finalize the HS_HTTPLibAuthInfo struct. The application
01065  *      should call this function setting in_new = true before using HS_HTTPLibAuthInfo.
01066  *      The application should call this function setting in_new = false after using
01067  *      HS_HTTPLibAuthInfo.
01068  *
01069  *  @param refnum:  IN:  Library reference number.
01070  *  @param *in_info:    IN:  The pointer to the authenticate information struct.
01071  *  @param in_new:  IN:  True if initialize the member.
01072  *               False if initialize the member after deleting.
01073  *  @return None.
01074  **/
01075 void HS_HTTPLibAuthInfoTidy(UInt16 refnum, HS_HTTPLibAuthInfo *in_info, Boolean in_new)
01076         SYS_TRAP(kHTTPLibTrapAuthInfoTidy);
01077
01078 /**
01079  *  @brief This function sets the authentication information.
01080  *
01081  *  @param refnum:  IN:  Library reference number.
01082  *  @param libH:    IN:  The handle of HTTP library instance.
01083  *  @param in_type: IN:  The authentication type.
01084  *               httpAuthTypeBasic      Basic authentication
01085  *                   httpAuthTypeDigest     Digest Authentication
01086  *  @param in_target:   IN:  The authentication target.
01087  *               httpAuthTargetPage     Authentication Information for Page
01088  *               httpAuthTargetProxy    Authentication Information for Proxy
01089  *  @param *in_challenge:   IN:  The challenge.
01090  *  @param *in_realm:   IN:  The realm.
01091  *  @param *in_user:    IN:  The pointer to the User ID.
01092  *  @param in_user_len: IN:  The length of in_user.
01093  *  @param *in_pass:    IN:  The pointer to the Password.
01094  *  @param in_pass_len: IN:  The length of in_pass.
01095  *  @param *in_url: IN:  The pointer to the URL (httpAuthTargetPage only).
01096  *  @param in_url_len:  IN:  The length of in_url.
01097  *  @param *in_host:    IN:  The pointer to the proxy host name (httpAuthTargetProxy only).
01098  *  @param in_host_len: IN:  The length of in_host.
01099  *  @param in_port: IN:  The port of proxy (httpAuthTargetProxy only).
01100  *  @return
01101  *      True if setting successful.
01102  *      False if failed (memory shortage).
01103  **/
01104 Boolean HS_HTTPLibSetUserPass(UInt16 refnum, HS_HTTPLibHandle libH, Int32 in_type, Int32 in_target, HS_HTTPLibSplit *in_challenge, HS_HTTPLibSplit *in_realm, Char *in_user, Int32 in_user_len, Char *in_pass, Int32 in_pass_len, Char *in_url, Int32 in_url_len, Char *in_host, Int32 in_host_len, Int32 in_port)
01105         SYS_TRAP(kHTTPLibTrapSetUserPass);
01106
01107 /**
01108  *  @brief
01109  *
01110  *  @param refnum:  IN:
01111  *  @param libH:    IN:
01112  *  @param in_target:   IN:
01113  *  @param *in_url: IN:
01114  *  @param in_url_len:  IN:
01115  *  @param *in_host:    IN:
01116  *  @param in_host_len: IN:
01117  *  @param in_port: IN:
01118  *  @param *in_realm:   IN:
01119  *  @param *out_info:   IN:
01120  *  @retval Err error code.
01121  **/
01122 Boolean HS_HTTPLibFindAuthInfo(UInt16 refnum, HS_HTTPLibHandle libH, Int32 in_target, Char *in_url, Int32 in_url_len, Char *in_host, Int32 in_host_len, Int32 in_port, HS_HTTPLibSplit *in_realm, HS_HTTPLibAuthInfo *out_info)
01123         SYS_TRAP(kHTTPLibTrapFindAuthInfo);
01124
01125 /**
01126  *  @brief This function returns the authentication information to the out_info. Before calling
01127  *     this API, the application should intialize HS_HTTPLibAuthInfo by
01128  *     HS_HTTPLibAuthInfoTidy(out_info, true).
01129  *
01130  *     After using the authentication information, the application should finalize
01131  *     HS_HTTPLibAuthInfoTidy by HS_HTTPLibAuthInfoTidy(out_info, false).
01132  *
01133  *  @param refnum:  IN:  Library reference number.
01134  *  @param libH:    IN:  The handle of HTTP library instance.
01135  *  @param in_target:   IN:  The authentication target.
01136  *               httpAuthTargetPage     Authentication Information for Page
01137  *               httpAuthTargetProxy    Authentication Information for Proxy
01138  *  @param *in_url: IN:  The pointer to the URL (httpAuthTargetPage only).
01139  *  @param in_url_len:  IN:  The length of in_url.
01140  *  @param *in_host:    IN:  The pointer to the proxy host name (httpAuthTargetProxy only).
01141  *  @param in_host_len: IN:  The length of in_host.
01142  *  @param in_port: IN:  The port of proxy (httpAuthTargetProxy only).
01143  *  @param *in_realm:   IN:  The realm.
01144  *  @param *out_info:   OUT:  The pointer to the authentication information.
01145  *  @return
01146  *      True if setting successful.
01147  *      False if failed (no information in cache or memory shortage).
01148  **/
01149 Boolean HS_HTTPLibMakeAuthInfo(UInt16 refnum, HS_HTTPLibHandle libH, Int32 in_target, Char *in_url, Int32 in_url_len, Char *in_host, Int32 in_host_len, Int32 in_port, HS_HTTPLibSplit *in_realm, HS_HTTPLibAuthInfo *out_info)
01150         SYS_TRAP(kHTTPLibTrapMakeAuthInfo);
01151
01152 /**
01153  *  @brief This function returns the User Name. The application should not delete this return value.
01154  *
01155  *  @param refnum:  IN:  Library reference number.
01156  *  @param *in_info:    IN:  The pointer to the authentication information.
01157  *  @return The handle of User Name.
01158  **/
01159 HS_HTTPLibString HS_HTTPLibAuthInfoUser(UInt16 refnum, HS_HTTPLibAuthInfo *in_info)
01160         SYS_TRAP(kHTTPLibTrapAuthInfoUser);
01161
01162 /**
01163  *  @brief This function returns the Password. The application should not delete this return value.
01164  *
01165  *  @param refnum:  IN:  Library reference number.
01166  *  @param *in_info:    IN:  The pointer to the authentication information.
01167  *  @return The handle of password.
01168  **/
01169 HS_HTTPLibString HS_HTTPLibAuthInfoPass(UInt16 refnum, HS_HTTPLibAuthInfo *in_info)
01170         SYS_TRAP(kHTTPLibTrapAuthInfoPass);
01171
01172 /**
01173  *  @brief This function returns the Realm. The application should not delete this return value.
01174  *
01175  *  @param refnum:  IN:  Library reference number.
01176  *  @param *in_info:    IN:  The pointer to the authentication information.
01177  *  @return
01178  *      The handle of Realm.
01179  **/
01180 HS_HTTPLibString HS_HTTPLibAuthInfoRealm(UInt16 refnum, HS_HTTPLibAuthInfo *in_info)
01181         SYS_TRAP(kHTTPLibTrapAuthInfoRealm);
01182
01183 /**
01184  *  @brief
01185  *
01186  *  @param refnum:  IN:
01187  *  @param *in_challenge_ss:    IN:
01188  *  @param *in_token:   IN:
01189  *  @param *out_ss: IN:
01190  *  @retval Err error code.
01191  **/
01192 Boolean HS_HTTPLibAuthCacheGetChallengeTokenSS(UInt16 refnum, HS_HTTPLibSplit *in_challenge_ss, Char *in_token, HS_HTTPLibSplit *out_ss)
01193         SYS_TRAP(kHTTPLibTrapAuthCacheGetChallengeTokenSS);
01194
01195 /**
01196  *  @brief This function sets the Cookie mode.
01197  *
01198  *  @param refnum:  IN:  Library reference number.
01199  *  @param libH:    IN:  The handle of HTTP library instance.
01200  *  @param in_mode:     IN:  The mode of receiving Cookie.
01201  *               httpCookieNotifyBeforeSet  Confirm before Cookie set
01202  *               httpCookieAlwaysSet    Cookie is always set
01203  *               httpCookieNeverSet     Cookie is not set
01204  *  @param in_cb:   IN:  The confirm callback function.
01205  *  @param in_opaque::  IN:  The opaque which is given to the callback function.
01206  *  @return None.
01207  **/
01208 void HS_HTTPLibSetCookieMode(UInt16 refnum, HS_HTTPLibHandle libH, Int32 in_mode, HS_HTTPLibCookieConfirmProc in_cb, HS_HTTPLibOpaque in_opaque)
01209         SYS_TRAP(kHTTPLibTrapSetCookieMode);
01210
01211 /**
01212  *  @brief This function sets the max size of Cookie entries.
01213  *
01214  *  @param refnum:  IN:  Library reference number.
01215  *  @param libH:    IN:  The handle of HTTP library instance.
01216  *  @param in_max_total_cookies:    IN:  The size of max Cookie entries.
01217  *  @param in_max_cookies_per_domain:   IN:  The size of Cookie entries per one domain.
01218  *  @param in_max_len_per_cookie:   IN:  The max size of one Cookie.
01219  *  @return None.
01220  **/
01221 void HS_HTTPLibSetCookieMax(UInt16 refnum, HS_HTTPLibHandle libH, Int32 in_max_total_cookies, Int32 in_max_cookies_per_domain, Int32 in_max_len_per_cookie)
01222         SYS_TRAP(kHTTPLibTrapSetCookieMax);
01223
01224 /**
01225  *  @brief This function sets the Cookie abiding with the confirmation mode set by
01226  *     HS_HTTPLibSetCookieMode. The application should not use this API in callback
01227  *     function. The API HS_HTTPLibSetCookieX is designed for use in callback.
01228  *
01229  *  @param refnum:  IN:  Library reference number.
01230  *  @param libH:    IN:  The handle of HTTP library instance.
01231  *  @param in_url:  IN:  The handle of URL.
01232  *  @param *in_header:  IN:  The pointer to the header string.
01233  *  @param in_header_len:   IN:  The length of in_header.
01234  *  @return
01235  *      httpErrorOK     Cookie is set.
01236  *      httpErrorNoMem  memory shortage
01237  *      httpErrorInval  failed by other reason
01238  **/
01239 Int32 HS_HTTPLibSetCookie(UInt16 refnum, HS_HTTPLibHandle libH, HS_HTTPLibURLString in_url, Char *in_header, Int32 in_header_len)
01240         SYS_TRAP(kHTTPLibTrapSetCookie);
01241
01242 /**
01243  *  @brief This function sets the Cookie. This function is designed for callback confirm function.
01244  *
01245  *  @param refnum:  IN:  Library reference number.
01246  *  @param libH:    IN:  The handle of HTTP library instance.
01247  *  @param in_url:  IN:  The handle of URL.
01248  *  @param *in_header:  IN:  The pointer to the header string.
01249  *  @param in_header_len:   IN:  The length of in_header.
01250  *  @return
01251  *      httpErrorOK     Cookie is set.
01252  *      httpErrorNoMem  memory shortage
01253  *      httpErrorInval  failed by other reason
01254  **/
01255 Int32 HS_HTTPLibSetCookieX(UInt16 refnum, HS_HTTPLibHandle libH, HS_HTTPLibURLString in_url, Char *in_header, Int32 in_header_len)
01256         SYS_TRAP(kHTTPLibTrapSetCookieX);
01257
01258 /**
01259  *  @brief
01260  *
01261  *  @param refnum:  IN:
01262  *  @param libH:    IN:
01263  *  @param *in_url:     IN:
01264  *  @param in_urllen:   IN:
01265  *  @param in_secure:   IN:
01266  *  @param *out_len:    IN:
01267  *  @retval Err error code.
01268  **/
01269 HS_HTTPLibString HS_HTTPLibMakeCookiesString(UInt16 refnum, HS_HTTPLibHandle libH, Char *in_url, Int32 in_urllen, Boolean in_secure, Int32 *out_len)
01270         SYS_TRAP(kHTTPLibTrapMakeCookiesString);
01271
01272 /**
01273  *  @brief
01274  *
01275  *  @param refnum:  IN:
01276  *  @param libH:    IN:
01277  *  @param *out_len:    IN:
01278  *  @retval Err error code.
01279  **/
01280 HS_HTTPLibString HS_HTTPLibSaveCookiesEntries(UInt16 refnum, HS_HTTPLibHandle libH, Int32 *out_len)
01281         SYS_TRAP(kHTTPLibTrapSaveCookiesEntries);
01282
01283 /**
01284  *  @brief
01285  *
01286  *  @param refnum:  IN:
01287  *  @param libH:    IN:
01288  *  @param *in_s:   IN:
01289  *  @param in_slen: IN:
01290  *  @retval Err error code.
01291  **/
01292 Boolean HS_HTTPLibLoadCookiesEntries(UInt16 refnum, HS_HTTPLibHandle libH, Char *in_s, Int32 in_slen)
01293         SYS_TRAP(kHTTPLibTrapLoadCookiesEntries);
01294
01295 /**
01296  *  @brief This function clears Cookies.
01297  *
01298  *  @param refnum:  IN:  Library reference number.
01299  *  @param libH:    IN:  The handle of HTTP library instance.
01300  *  @param in_flag:     IN:  httpCookieClearAll         clear all Cookies
01301  *               httpCookieClearSessionCookiesOnly  clear session Cookies only
01302  *  @return None.
01303  **/
01304 void HS_HTTPLibCookieMakeEmpty(UInt16 refnum, HS_HTTPLibHandle libH, Int32 in_flag)
01305         SYS_TRAP(kHTTPLibTrapCookieMakeEmpty);
01306
01307 /**
01308  *  @brief
01309  *
01310  *  @param refnum:  IN:
01311  *  @param libH:    IN:
01312  *  @param in_retry:    IN:
01313  *  @retval Err error code.
01314  **/
01315 void HS_HTTPLibSetDNSMaxRetry(UInt16 refnum, HS_HTTPLibHandle libH, Int32 in_retry)
01316         SYS_TRAP(kHTTPLibTrapSetDNSMaxRetry);
01317
01318 /**
01319  *  @brief
01320  *
01321  *  @param refnum:  IN:
01322  *  @param libH:    IN:
01323  *  @param in_interval:     IN:
01324  *  @retval Err error code.
01325  **/
01326 void HS_HTTPLibSetDNSRetryInterval(UInt16 refnum, HS_HTTPLibHandle libH, Int32 in_interval)
01327         SYS_TRAP(kHTTPLibTrapSetDNSRetryInterval);
01328
01329 /**
01330  *  @brief Set the SSL version.
01331  *
01332  *  @param refnum:  IN:  Library reference number.
01333  *  @param libH:    IN:  The handle of HTTP library instance.
01334  *  @param in_flag: IN:  -
01335  *  @param in_on:   IN:  -
01336  *  @return None.
01337  **/
01338 void HS_HTTPLibSetSSLVersionFlag(UInt16 refnum, HS_HTTPLibHandle libH, Int32 in_flag, Boolean in_on)
01339         SYS_TRAP(kHTTPLibTrapSetSSLVersionFlag);
01340
01341 /**
01342  *  @brief Set the timeout period for SSL use.
01343  *
01344  *  @param refnum:  IN:  Library reference number.
01345  *  @param libH:    IN:  The handle of HTTP library instance.
01346  *  @return Timeout.
01347  **/
01348 Int32 HS_HTTPLibSSLTimeout(UInt16 refnum, HS_HTTPLibHandle libH)
01349         SYS_TRAP(kHTTPLibTrapSSLTimeout);
01350
01351 /**
01352  *  @brief TBD
01353  *
01354  *  @param refnum:  IN:  Library reference number.
01355  *  @param libH:    IN:  The handle of HTTP library instance.
01356  *  @param *out_list:   OUT:  -
01357  *  @retval Int32
01358  **/
01359 Int32 HS_HTTPLibSSLOpenCertDB(UInt16 refnum, HS_HTTPLibHandle libH, HS_HTTPLibCertList *out_list)
01360         SYS_TRAP(kHTTPLibTrapSSLOpenCertDB);
01361
01362 /**
01363  *  @brief TBD
01364  *
01365  *  @param refnum:  IN:  Library reference number.
01366  *  @param libH:    IN:  The handle of HTTP library instance.
01367  *  @return None.
01368  **/
01369 void HS_HTTPLibSSLCloseCertDB(UInt16 refnum, HS_HTTPLibHandle libH)
01370         SYS_TRAP(kHTTPLibTrapSSLCloseCertDB);
01371
01372 /**
01373  *  @brief
01374  *
01375  *  @param refnum:  IN:
01376  *  @param in_type: IN:
01377  *  @return
01378  **/
01379 HS_HTTPLibCertList HS_HTTPLibCertListNew(UInt16 refnum, Int32 in_type)
01380         SYS_TRAP(kHTTPLibTrapCertListNew);
01381
01382 /**
01383  *  @brief TBD
01384  *
01385  *  @param refnum:  IN:  Library reference number.
01386  *  @param in_list: IN:  The handle of the server’s certification list.
01387  *  @return None.
01388  **/
01389 void HS_HTTPLibCertListDelete(UInt16 refnum, HS_HTTPLibCertList in_list)
01390         SYS_TRAP(kHTTPLibTrapCertListDelete);
01391
01392 /**
01393  *  @brief TBD
01394  *
01395  *  @param refnum:  IN:  Library reference number.
01396  *  @param in_list: IN:  The handle of the server’s certification list.
01397  *  @return Handle to the clone of the certification list.
01398  **/
01399 HS_HTTPLibCertList HS_HTTPLibCertListClone(UInt16 refnum, HS_HTTPLibCertList in_list)
01400         SYS_TRAP(kHTTPLibTrapCertListClone);
01401
01402 /**
01403  *  @brief Lock the certificate list and return its pointer.
01404  *
01405  *  @param refnum:  IN:  Library reference number.
01406  *  @param in_list: IN:  The handle of the server's certification list.
01407  *  @return Pointer to the certificate list.
01408  **/
01409 void *HS_HTTPLibCertListLock(UInt16 refnum, HS_HTTPLibCertList in_list)
01410         SYS_TRAP(kHTTPLibTrapCertListLock);
01411
01412 /**
01413  *  @brief Unlock the certificate list
01414  *
01415  *  @param refnum:  IN:  Library reference number.
01416  *  @param in_list: IN:  The handle of the server’s certification list.
01417  *  @return None.
01418  **/
01419 void HS_HTTPLibCertListUnlock(UInt16 refnum, HS_HTTPLibCertList in_list)
01420         SYS_TRAP(kHTTPLibTrapCertListUnlock);
01421
01422 /**
01423  *  @brief TBD
01424  *
01425  *  @param refnum:  IN:  Library reference number.
01426  *  @param in_list: IN:  The handle of the server’s certification list.
01427  *  @retval Int32
01428  **/
01429 Int32 HS_HTTPLibCertListType(UInt16 refnum, HS_HTTPLibCertList in_list)
01430         SYS_TRAP(kHTTPLibTrapCertListType);
01431
01432 /**
01433  *  @brief TBD
01434  *
01435  *  @param refnum:  IN:  Library reference number.
01436  *  @param in_list: IN:  The handle of the server’s certification list.
01437  *  @retval Int32
01438  **/
01439 Int32 HS_HTTPLibCertListLength(UInt16 refnum, HS_HTTPLibCertList in_list)
01440         SYS_TRAP(kHTTPLibTrapCertListLength);
01441
01442 /**
01443  *  @brief TBD
01444  *
01445  *  @param refnum:  IN:  Library reference number.
01446  *  @param in_list: IN:  The handle of the server’s certification list.
01447  *  @param in_index:    IN:  -
01448  *  @param *out_cert:   OUT: -
01449  *  @retval Int32
01450  **/
01451 Int32 HS_HTTPLibCertListBeginDecode(UInt16 refnum, HS_HTTPLibCertList in_list, Int32 in_index, HS_HTTPLibCertPtr *out_cert)
01452         SYS_TRAP(kHTTPLibTrapCertListBeginDecode);
01453
01454 /**
01455  *  @brief TBD
01456  *
01457  *  @param refnum:  IN:  Library reference number.
01458  *  @param in_list: IN:  The handle of the server’s certification list.
01459  *  @param in_cert:     IN:  -
01460  *  @return None.
01461  **/
01462 void HS_HTTPLibCertListEndDecode(UInt16 refnum, HS_HTTPLibCertList in_list, HS_HTTPLibCertPtr in_cert)
01463         SYS_TRAP(kHTTPLibTrapCertListEndDecode);
01464
01465 /**
01466  *  @brief TBD
01467  *
01468  *  @param refnum:  IN:  Library reference number.
01469  *  @param in_list: IN:  The handle of the server’s certification list.
01470  *  @param *in_info:    IN:  -
01471  *  @param in_over_write:   IN:  -
01472  *  @retval Int32
01473  **/
01474 Int32 HS_HTTPLibCertListImportCert(UInt16 refnum, HS_HTTPLibCertList in_list, void *in_info, Boolean in_over_write)
01475         SYS_TRAP(kHTTPLibTrapCertListImportCert);
01476
01477 /**
01478  *  @brief
01479  *
01480  *  @param refnum:  IN:
01481  *  @param in_cert: IN:
01482  *  @retval Err error code.
01483  **/
01484 Int32 HS_HTTPLibCertPeekVersion(UInt16 refnum, HS_HTTPLibCertPtr in_cert)
01485         SYS_TRAP(kHTTPLibTrapCertPeekVersion);
01486
01487 /**
01488  *  @brief
01489  *
01490  *  @param refnum:  IN:
01491  *  @param in_cert: IN:
01492  *  @param **out_str:   IN:
01493  *  @retval Err error code.
01494  **/
01495 Int32 HS_HTTPLibCertPeekSerialNumber(UInt16 refnum, HS_HTTPLibCertPtr in_cert, Char **out_str)
01496         SYS_TRAP(kHTTPLibTrapCertPeekSerialNumber);
01497
01498 /**
01499  *  @brief
01500  *
01501  *  @param refnum:  IN:
01502  *  @param in_cert: IN:
01503  *  @retval Err error code.
01504  **/
01505 Int32 HS_HTTPLibCertPeekSignAlgo(UInt16 refnum, HS_HTTPLibCertPtr in_cert)
01506         SYS_TRAP(kHTTPLibTrapCertPeekSignAlgo);
01507
01508 /**
01509  *  @brief
01510  *
01511  *  @param refnum:  IN:
01512  *  @param in_cert: IN:
01513  *  @param in_attr:     IN:
01514  *  @retval Err error code.
01515  **/
01516 Boolean HS_HTTPLibCertBeginPeekIssuerRDN(UInt16 refnum, HS_HTTPLibCertPtr in_cert, Int32 in_attr)
01517         SYS_TRAP(kHTTPLibTrapCertBeginPeekIssuerRDN);
01518
01519 /**
01520  *  @brief
01521  *
01522  *  @param refnum:  IN:
01523  *  @param in_cert: IN:
01524  *  @param **out_str:   IN:
01525  *  @retval Err error code.
01526  **/
01527 Int32 HS_HTTPLibCertPeekIssuerRDN(UInt16 refnum, HS_HTTPLibCertPtr in_cert, Char **out_str)
01528         SYS_TRAP(kHTTPLibTrapCertPeekIssuerRDN);
01529
01530 /**
01531  *  @brief
01532  *
01533  *  @param refnum:  IN:
01534  *  @param in_cert: IN:
01535  *  @retval Err error code.
01536  **/
01537 Int32 HS_HTTPLibCertPeekIssuerRDNStrType(UInt16 refnum, HS_HTTPLibCertPtr in_cert)
01538         SYS_TRAP(kHTTPLibTrapCertPeekIssuerRDNStrType);
01539
01540 /**
01541  *  @brief
01542  *
01543  *  @param refnum:  IN:
01544  *  @param in_cert: IN:
01545  *  @retval Err error code.
01546  **/
01547 void HS_HTTPLibCertEndPeekIssuerRDN(UInt16 refnum, HS_HTTPLibCertPtr in_cert)
01548         SYS_TRAP(kHTTPLibTrapCert_EndPeekIssuerRDN);
01549
01550 /**
01551  *  @brief
01552  *
01553  *  @param refnum:  IN:
01554  *  @param in_cert: IN:
01555  *  @param in_attr:     IN:
01556  *  @retval Err error code.
01557  **/
01558 Boolean HS_HTTPLibCertBeginPeekSubjectRDN(UInt16 refnum, HS_HTTPLibCertPtr in_cert, Int32 in_attr)
01559         SYS_TRAP(kHTTPLibTrapCertBeginPeekSubjectRDN);
01560
01561 /**
01562  *  @brief
01563  *
01564  *  @param refnum:  IN:
01565  *  @param in_cert: IN:
01566  *  @param **out_str:   IN:
01567  *  @retval Err error code.
01568  **/
01569 Int32 HS_HTTPLibCertPeekSubjectRDN(UInt16 refnum, HS_HTTPLibCertPtr in_cert, Char **out_str)
01570         SYS_TRAP(kHTTPLibTrapCertPeekSubjectRDN);
01571
01572 /**
01573  *  @brief
01574  *
01575  *  @param refnum:  IN:
01576  *  @param in_cert: IN:
01577  *  @retval Err error code.
01578  **/
01579 Int32 HS_HTTPLibCertPeekSubjectRDNStrType(UInt16 refnum, HS_HTTPLibCertPtr in_cert)
01580         SYS_TRAP(kHTTPLibTrapCertPeekSubjectRDNStrType);
01581
01582 /**
01583  *  @brief
01584  *
01585  *  @param refnum:  IN:
01586  *  @param in_cert: IN:
01587  *  @retval Err error code.
01588  **/
01589 void HS_HTTPLibCertEndPeekSubjectRDN(UInt16 refnum, HS_HTTPLibCertPtr in_cert)
01590         SYS_TRAP(kHTTPLibTrapCert_EndPeekSubjectRDN);
01591
01592 /**
01593  *  @brief
01594  *
01595  *  @param refnum:  IN:
01596  *  @param in_cert: IN:
01597  *  @param *in_time:    IN:
01598  *  @retval Err error code.
01599  **/
01600 void HS_HTTPLibCertPeekValidityStart(UInt16 refnum, HS_HTTPLibCertPtr in_cert, HS_HTTPLibTime *in_time)
01601         SYS_TRAP(kHTTPLibTrapCert_PeekValidityStart);
01602
01603 /**
01604  *  @brief
01605  *
01606  *  @param refnum:  IN:
01607  *  @param in_cert: IN:
01608  *  @param *in_time:    IN:
01609  *  @retval Err error code.
01610  **/
01611 void HS_HTTPLibCertPeekValidityEnd(UInt16 refnum, HS_HTTPLibCertPtr in_cert, HS_HTTPLibTime *in_time)
01612         SYS_TRAP(kHTTPLibTrapCert_PeekValidityEnd);
01613
01614 /**
01615  *  @brief
01616  *
01617  *  @param refnum:  IN:
01618  *  @param in_cert: IN:
01619  *  @retval Err error code.
01620  **/
01621 Int32 HS_HTTPLibCertPeekRSAPublicKeyBits(UInt16 refnum, HS_HTTPLibCertPtr in_cert)
01622         SYS_TRAP(kHTTPLibTrapCert_PeekRSAPublicKeyBits);
01623
01624 /**
01625  *  @brief
01626  *
01627  *  @param refnum:  IN:
01628  *  @retval Err error code.
01629  **/
01630 HS_HTTPLibClientCertList HS_HTTPLibClientCertListNew(UInt16 refnum)
01631         SYS_TRAP(kHTTPLibTrapClientCertListNew);
01632
01633 /**
01634  *  @brief TBD
01635  *
01636  *  @param refnum:  IN:
01637  *  @param in_list: IN:
01638  *  @retval HS_HTTPLibClientCertList
01639  **/
01640 HS_HTTPLibClientCertList HS_HTTPLibClientCertListClone(UInt16 refnum, HS_HTTPLibClientCertList in_list)
01641         SYS_TRAP(kHTTPLibTrapClientCertListClone);
01642
01643 /**
01644  *  @brief
01645  *
01646  *  @param refnum:  IN:
01647  *  @param in_list: IN:
01648  *  @retval nothing
01649  **/
01650 void HS_HTTPLibClientCertListDelete(UInt16 refnum, HS_HTTPLibClientCertList in_list)
01651         SYS_TRAP(kHTTPLibTrapClientCertListDelete);
01652
01653 /**
01654  *  @brief TBD
01655  *
01656  *  @param refnum:  IN:
01657  *  @param in_list: IN:
01658  *  @retval Nothing
01659  **/
01660 Int32 HS_HTTPLibClientCertListLength(UInt16 refnum, HS_HTTPLibClientCertList in_list)
01661         SYS_TRAP(kHTTPLibTrapClientCertListLength);
01662
01663 /**
01664  *  @brief TBD
01665  *
01666  *  @param refnum:  IN:
01667  *  @param in_list: IN:
01668  *  @param in_index:    IN:
01669  *  @retval Boolean
01670  **/
01671 Boolean HS_HTTPLibClientCertListIsValid(UInt16 refnum, HS_HTTPLibClientCertList in_list, Int32 in_index)
01672         SYS_TRAP(kHTTPLibTrapClientCertListIsValid);
01673
01674 /**
01675  *  @brief TBD
01676  *
01677  *  @param refnum:  IN:
01678  *  @param in_list: IN:
01679  *  @param in_index:    IN:
01680  *  @param in_valid:    IN:
01681  *  @retval Nothing
01682  **/
01683 void HS_HTTPLibClientCertListSetValid(UInt16 refnum, HS_HTTPLibClientCertList in_list, Int32 in_index, Boolean in_valid)
01684         SYS_TRAP(kHTTPLibTrapClientCertListSetValid);
01685
01686 /**
01687  *  @brief This function sets the server certificate callback function for this application.
01688  *
01689  *  @param refnum:  IN:  Library reference number.
01690  *  @param libH:    IN:  -
01691  *  @param in_cb:   IN:  -
01692  *  @param in_opaque:   IN:  -
01693  *  @return Nothing
01694  **/
01695 void HS_HTTPLibSetSSLServerCertConfirmProc(UInt16 refnum, HS_HTTPLibHandle libH, HS_HTTPLibServerCertConfirmProc in_cb, HS_HTTPLibOpaque in_opaque)
01696         SYS_TRAP(kHTTPLibTrapSetSSLServerCertConfirmProc);
01697
01698 /**
01699  *  @brief This function sets the result of confirmation. This function should be called in the
01700  *     callback function.
01701  *
01702  *  @param refnum:  IN:  Library reference number.
01703  *  @param in_ssl:  IN:  -
01704  *  @param in_verify_result:    IN:  -
01705  *  @param in_confirm:  IN:  -
01706  *  @return None.
01707  **/
01708 void HS_HTTPLibServerCertConfirm(UInt16 refnum, HS_HTTPLibSSL in_ssl, Int32 in_verify_result, Boolean in_confirm)
01709         SYS_TRAP(kHTTPLibTrapServerCertConfirm);
01710
01711 /**
01712  *  @brief This function sets the client certification select callback function.For now, there is
01713  *     no corresponding function in SSL library, the callback will not be called.
01714  *
01715  *  @param refnum:  IN:  Library reference number.
01716  *  @param libH:    IN:  -
01717  *  @param in_cb:   IN:  -
01718  *  @param in_opaque:   IN:  -
01719  *  @return None.
01720  **/
01721 void HS_HTTPLibSetSSLClientCertSelectProc(UInt16 refnum, HS_HTTPLibHandle libH, HS_HTTPLibClientCertSelectProc in_cb, HS_HTTPLibOpaque in_opaque)
01722         SYS_TRAP(kHTTPLibTrapSetSSLClientCertSelectProc);
01723
01724 /**
01725  *  @brief This function sets the selected certification. For now, there is no corresponding
01726  *     function in SSL library, the callback will not be called.
01727  *
01728  *  @param refnum:  IN:  Library reference number.
01729  *  @param in_ssl:  IN:  -
01730  *  @param in_index:    IN:  -
01731  *  @return None.
01732  **/
01733 void HS_HTTPLibClientCertSelect(UInt16 refnum, HS_HTTPLibSSL in_ssl, Int32 in_index)
01734         SYS_TRAP(kHTTPLibTrapClientCertSelect);
01735
01736 /**
01737  *  @brief This function sets the callback functions concerning NetLib. But for now, there is
01738  *     no call to callback functions from Peer layer.
01739  *
01740  *  @param refnum:  IN:  Library reference number.
01741  *  @param libH:    IN:
01742  *  @param netLibRefnum:    IN:
01743  *  @param in_open: IN:
01744  *  @param in_close:    IN:
01745  *  @param in_online:   IN:
01746  *  @param in_offline:  IN:
01747  *  @return None.
01748  **/
01749 void HS_HTTPLibSetNetLibProc(UInt16 refnum, HS_HTTPLibHandle libH, UInt16 netLibRefnum, HS_HTTPLibNetLibOpenProc in_open, HS_HTTPLibNetLibCloseProc in_close, HS_HTTPLibNetLibOnlineProc in_online, HS_HTTPLibNetLibOfflineProc in_offline)
01750         SYS_TRAP(kHTTPLibTrapSetNetLibProc);
01751
01752 /**
01753  *  @brief
01754  *
01755  *  @param refnum:  IN:
01756  *  @param in_handle:   IN:
01757  *  @retval Err error code.
01758  **/
01759 Int32 HS_HTTPLibDataHandle_Length(UInt16 refnum, HS_HTTPLibDataHandle in_handle)
01760         SYS_TRAP(kHTTPLibTrapDataHandle_Length);
01761
01762 /**
01763  *  @brief
01764  *
01765  *  @param refnum:  IN:
01766  *  @param in_handle:   IN:
01767  *  @retval Err error code.
01768  **/
01769 void *HS_HTTPLibDataHandle_Lock(UInt16 refnum, HS_HTTPLibDataHandle in_handle)
01770         SYS_TRAP(kHTTPLibTrapDataHandle_Lock);
01771
01772 /**
01773  *  @brief
01774  *
01775  *  @param refnum:  IN:
01776  *  @param in_handle:   IN:
01777  *  @retval Err error code.
01778  **/
01779 void HS_HTTPLibDataHandle_Unlock(UInt16 refnum, HS_HTTPLibDataHandle in_handle)
01780         SYS_TRAP(kHTTPLibTrapDataHandle_Unlock);
01781
01782 /**
01783  *  @brief
01784  *
01785  *  @param refnum:  IN:
01786  *  @param in_handle:   IN:
01787  *  @retval Err error code.
01788  **/
01789 void HS_HTTPLibDataHandle_Delete(UInt16 refnum, HS_HTTPLibDataHandle in_handle)
01790         SYS_TRAP(kHTTPLibTrapDataHandle_Delete);
01791
01792 /**
01793  *  @brief This function returns the length of the handle (byte).
01794  *
01795  *  @param refnum:  IN:  Library reference number.
01796  *  @param in_vhandle:  IN:  The handle.
01797  *  @retval Int32
01798  **/
01799 Int32 HS_HTTPLibVHandle_Length(UInt16 refnum, HS_HTTPLibVHandle in_vhandle)
01800         SYS_TRAP(kHTTPLibTrapVHandle_Length);
01801
01802 /**
01803  *  @brief This function locks the handle of type HS_HTTPLibVHandle.
01804  *
01805  *  @param refnum:  IN:  Library reference number.
01806  *  @param in_vhandle:  IN:  The handle.
01807  *  @retval void *
01808  **/
01809 void *HS_HTTPLibVHandle_Lock(UInt16 refnum, HS_HTTPLibVHandle in_vhandle)
01810         SYS_TRAP(kHTTPLibTrapVHandle_Lock);
01811
01812 /**
01813  *  @brief This function unlocks the handle of type HS_HTTPLibVHandle.
01814  *
01815  *  @param refnum:  IN:  Library reference number.
01816  *  @param in_vhandle:  IN:  The handle.
01817  *  @retval Nothing
01818  **/
01819 void HS_HTTPLibVHandle_Unlock(UInt16 refnum, HS_HTTPLibVHandle in_vhandle)
01820         SYS_TRAP(kHTTPLibTrapVHandle_Unlock);
01821
01822 /**
01823  *  @brief This function deletes the handle of type HS_HTTPLibVHandle.
01824  *
01825  *  @param refnum:  IN:  Library reference number.
01826  *  @param in_vhandle:  IN:  The handle.
01827  *  @retval Nothing
01828  **/
01829 void HS_HTTPLibVHandle_Delete(UInt16 refnum, HS_HTTPLibVHandle in_vhandle)
01830         SYS_TRAP(kHTTPLibTrapVHandle_Delete);
01831
01832 /**
01833  *  @brief This function returns the length of the handle (byte).
01834  *
01835  *  @param refnum:  IN: Library reference number.
01836  *  @param in_str:  IN: The handle.
01837  *  @retval Int32
01838  **/
01839 Int32 HS_HTTPLibString_Length(UInt16 refnum, HS_HTTPLibString in_str)
01840         SYS_TRAP(kHTTPLibTrapString_Length);
01841
01842 /**
01843  *  @brief This function creates a new handle of type HS_HTTPLibString.
01844  *
01845  *  @param refnum:  IN:  Library reference number.
01846  *  @param *in_str: IN:  The pointer to the string.
01847  *  @param in_len:  IN:  The length of in_str.
01848  *  @retval HS_HTTPLibString
01849  **/
01850 HS_HTTPLibString HS_HTTPLibStringNew(UInt16 refnum, Char *in_str, Int32 in_len)
01851         SYS_TRAP(kHTTPLibTrapStringNew);
01852
01853 /**
01854  *  @brief This function locks the handle of type HS_HTTPLibString.
01855  *
01856  *  @param refnum:  IN:  Library reference number.
01857  *  @param in_str:  IN:  The handle.
01858  *  @retval void *
01859  **/
01860 void *HS_HTTPLibString_Lock(UInt16 refnum, HS_HTTPLibString in_str)
01861         SYS_TRAP(kHTTPLibTrapString_Lock);
01862
01863 /**
01864  *  @brief This function unlocks the handle of type HS_HTTPLibString.
01865  *
01866  *  @param refnum:  IN:  Library reference number.
01867  *  @param in_str:  IN:  The handle.
01868  *  @retval Nothing
01869  **/
01870 void HS_HTTPLibString_Unlock(UInt16 refnum, HS_HTTPLibString in_str)
01871         SYS_TRAP(kHTTPLibTrapString_Unlock);
01872 /**
01873  *  @brief This function deletes the handle of type HS_HTTPLibString.
01874  *
01875  *  @param refnum:  IN:  Library reference number.
01876  *  @param in_str:  IN:  The handle.
01877  *  @retval Nothing
01878  **/
01879 void HS_HTTPLibString_Delete(UInt16 refnum, HS_HTTPLibString in_str)
01880         SYS_TRAP(kHTTPLibTrapString_Delete);
01881
01882 /**
01883  *  @brief This function returns the length of the handle (byte).
01884  *
01885  *  @param refnum:  IN:  Library reference number.
01886  *  @param in_str:  IN:  The handle.
01887  *  @retval Int32
01888  **/
01889 Int32 HS_HTTPLibFixedString_Length(UInt16 refnum, HS_HTTPLibFixedString in_str)
01890         SYS_TRAP(kHTTPLibTrapFixedString_Length);
01891
01892 /**
01893  *  @brief This function creates a new handle of type HS_HTTPLibFixedString.
01894  *
01895  *  @param refnum:  IN:  Library reference number.
01896  *  @param *in_str: IN:  The pointer to the string.
01897  *  @param in_len:  IN:  The length of in_str.
01898  *  @retval HS_HTTPLibFixedString
01899  **/
01900 HS_HTTPLibFixedString HS_HTTPLibFixedStringNew(UInt16 refnum, Char *in_str, Int32 in_len)
01901         SYS_TRAP(kHTTPLibTrapFixedStringNew);
01902
01903 /**
01904  *  @brief This function locks the handle of type HS_HTTPLibFixedString.
01905  *
01906  *  @param refnum:  IN:  Library reference number.
01907  *  @param in_str:  IN:  The handle.
01908  *  @retval void *
01909  **/
01910 void *HS_HTTPLibFixedString_Lock(UInt16 refnum, HS_HTTPLibFixedString in_str)
01911         SYS_TRAP(kHTTPLibTrapFixedString_Lock);
01912
01913 /**
01914  *  @brief This function unlocks the handle of type HS_HTTPLibFixedString.
01915  *
01916  *  @param refnum:  IN:  Library reference number.
01917  *  @param in_str:  IN:  The handle.
01918  *  @retval nothing
01919  **/
01920 void HS_HTTPLibFixedString_Unlock(UInt16 refnum, HS_HTTPLibFixedString in_str)
01921         SYS_TRAP(kHTTPLibTrapFixedString_Unlock);
01922
01923 /**
01924  *  @brief This function deletes the handle of type HS_HTTPLibFixedString.
01925  *
01926  *  @param refnum:  IN:  Library reference number.
01927  *  @param in_str:  IN:  The handle.
01928  *  @retval nothing
01929  **/
01930 void HS_HTTPLibFixedString_Delete(UInt16 refnum, HS_HTTPLibFixedString in_str)
01931         SYS_TRAP(kHTTPLibTrapFixedString_Delete);
01932
01933 /**
01934  *  @brief This function returns the length of the handle (byte).
01935  *
01936  *  @param refnum:  IN:  Library reference number.
01937  *  @param in_str:  IN:  The handle.
01938  *  @retval Int32
01939  **/
01940 Int32 HS_HTTPLibURLString_Length(UInt16 refnum, HS_HTTPLibURLString in_str)
01941         SYS_TRAP(kHTTPLibTrapURLString_Length);
01942
01943 /**
01944  *  @brief This function creates a new handle of type HS_HTTPLibURLString.
01945  *
01946  *  @param refnum:  IN:  Library reference number.
01947  *  @param *in_str: IN:  The pointer to the string.
01948  *  @param in_len:  IN:  The length of in_str.
01949  *  @retval HS_HTTPLibURLString
01950  **/
01951 HS_HTTPLibURLString HS_HTTPLibURLStringNew(UInt16 refnum, Char *in_str, Int32 in_len)
01952         SYS_TRAP(kHTTPLibTrapURLStringNew);
01953
01954 /**
01955  *  @brief This function locks the handle of type HS_HTTPLibURLString.
01956  *
01957  *  @param refnum:  IN:  Library reference number.
01958  *  @param in_str:  IN:  The handle.
01959  *  @retval void *
01960  **/
01961 void *HS_HTTPLibURLString_Lock(UInt16 refnum, HS_HTTPLibURLString in_str)
01962         SYS_TRAP(kHTTPLibTrapURLString_Lock);
01963
01964 /**
01965  *  @brief This function unlocks the handle of type HS_HTTPLibURLString.
01966  *
01967  *  @param refnum:  IN:  Library reference number.
01968  *  @param in_str:  IN:  The handle.
01969  *  @retval nothing
01970  **/
01971 void HS_HTTPLibURLString_Unlock(UInt16 refnum, HS_HTTPLibURLString in_str)
01972         SYS_TRAP(kHTTPLibTrapURLString_Unlock);
01973
01974 /**
01975  *  @brief This function deletes the handle of type HS_HTTPLibURLString.
01976  *
01977  *  @param refnum:  IN:  Library reference number.
01978  *  @param in_str:  IN:  The handle.
01979  *  @retval nothing
01980  **/
01981 void HS_HTTPLibURLString_Delete(UInt16 refnum, HS_HTTPLibURLString in_str)
01982         SYS_TRAP(kHTTPLibTrapURLString_Delete);
01983
01984 /**
01985  *  @brief This returns the cipher info.
01986  *     SslCipherSuiteInfo is the structure defined in SslLib.h
01987  *
01988  *     The implementation of this API in ARM native version is mere macro.
01989  *
01990  *  @param refnum:  IN:  Library reference number.
01991  *  @param *iself:  IN:  -
01992  *  @retval nothing
01993  **/
01994 void *HS_HTTPLibCertListGetCipherInfo(UInt16 refnum, void *iself)
01995         SYS_TRAP(kHTTPLibTrapCertListGetCipherInfo);
01996
01997 /**
01998  *  @brief
01999  *
02000  *  @param refnum:  IN:
02001  *  @param libH:    IN:
02002  *  @param in_msec::    IN:
02003  *  @retval Err error code.
02004  **/
02005 void HS_HTTPLibSetMaxKeepAliveTimeout(UInt16 refnum, HS_HTTPLibHandle libH, Int32 in_msec)
02006         SYS_TRAP(kHTTPLibTrapSetMaxKeepAliveTimeout);
02007
02008 /**
02009  *  @brief
02010  *
02011  *  @param refnum:  IN:
02012  *  @param stream:  IN:
02013  *  @param *out_total:  IN:
02014  *  @param *out_sent:   IN:
02015  *  @retval Err error code.
02016  **/
02017 void HS_HTTPLibStreamGetRequestSent(UInt16 refnum, HS_HTTPLibStream stream, Int32 *out_total, Int32 *out_sent)
02018         SYS_TRAP(kHTTPLibTrapStreamGetRequestSent);
02019
02020 /**
02021  *  @brief
02022  *
02023  *  @param refnum:  IN:
02024  *  @param stream:  IN:
02025  *  @param in_type  IN:
02026  *  @param in_ofs:  IN:
02027  *  @param *out_off:    IN:
02028  *  @param *out_len:    IN:
02029  *  @retval Err error code.
02030  **/
02031 Boolean HS_HTTPLibStreamGetHeaderWithOffset(UInt16 refnum, HS_HTTPLibStream stream, Int32 in_type, Int32 in_ofs, Int32 *out_off, Int32 *out_len)
02032         SYS_TRAP(kHTTPLibTrapStreamGetHeaderWithOffset);
02033
02034 /**
02035  *  @brief
02036  *
02037  *  @param refnum:  IN:
02038  *  @param libH:    IN:
02039  *  @param in_type:     IN:
02040  *  @param in_target:   IN:
02041  *  @param *in_challenge:   IN:
02042  *  @param *in_realm:   IN:
02043  *  @param *in_user:    IN:
02044  *  @param in_user_len: IN:
02045  *  @param *in_pass:    IN:
02046  *  @param in_pass_len: IN:
02047  *  @param *in_url: IN:
02048  *  @param in_url_len:  IN:
02049  *  @param *in_host:    IN:
02050  *  @param in_host_len: IN:
02051  *  @param in_port: IN:
02052  *  @param in_keep_user:    IN:
02053  *  @param in_keep_pass:    IN:
02054  *  @retval Err error code.
02055  **/
02056 Boolean HS_HTTPLibSetUserPassX(UInt16 refnum, HS_HTTPLibHandle libH, Int32 in_type, Int32 in_target, HS_HTTPLibSplit *in_challenge, HS_HTTPLibSplit *in_realm, Char *in_user, Int32 in_user_len, Char *in_pass, Int32 in_pass_len, Char *in_url, Int32 in_url_len, Char *in_host, Int32 in_host_len, Int32 in_port, Boolean in_keep_user, Boolean in_keep_pass)
02057         SYS_TRAP(kHTTPLibTrapSetUserPassX);
02058
02059 /**
02060  *  @brief
02061  *
02062  *  @param refnum:  IN:
02063  *  @param libH:    IN:
02064  *  @param in_target:   IN:
02065  *  @param *in_url: IN:
02066  *  @param in_url_len:  IN:
02067  *  @param *in_host:    IN:
02068  *  @param in_host_len: IN:
02069  *  @param in_port: IN:
02070  *  @param *in_realm:   IN:
02071  *  @param in_realm_len:    IN:
02072  *  @param *out_user:   IN:
02073  *  @param *out_pass:   IN:
02074  *  @param *out_keep_user:  IN:
02075  *  @param *out_keep_pass:  IN:
02076  *  @param libH:    IN:
02077  *  @retval Err error code.
02078  **/
02079 void HS_HTTPLibFindAuthCandidate(UInt16 refnum, HS_HTTPLibHandle libH, Int32 in_target, Char *in_url, Int32 in_url_len, Char *in_host, Int32 in_host_len, Int32 in_port, Char *in_realm, Int32 in_realm_len, HS_HTTPLibString *out_user, HS_HTTPLibString *out_pass, Boolean *out_keep_user, Boolean *out_keep_pass)
02080         SYS_TRAP(kHTTPLibTrapFindAuthCandidate);
02081
02082 /**
02083  *  @brief
02084  *
02085  *  @param refnum:  IN:
02086  *  @param libH:    IN:
02087  *  @param in_proc:     IN:
02088  *  @param in_opaque:   IN:
02089  *  @retval Err error code.
02090  **/
02091 void HS_HTTPLibSetWakeUpCallback(UInt16 refnum, HS_HTTPLibHandle libH, HS_HTTPLibWakeUpCallbackProc in_proc, HS_HTTPLibOpaque in_opaque)
02092         SYS_TRAP(kHTTPLibTrapSetWakeUpCallback);
02093
02094 /**
02095  *  @brief
02096  *
02097  *  @param refnum:  IN:
02098  *  @param libH:    IN:
02099  *  @param *rules:  IN:
02100  *  @param len:     IN:
02101  *  @retval Err error code.
02102  **/
02103 Boolean HS_HTTPLibSetUseragentSelectionRule(UInt16 refnum, HS_HTTPLibHandle libH, HttpUASelectionRule *rules, Int32 len)
02104         SYS_TRAP(kHTTPLibTrapSetUseragentSelectionRule);
02105
02106
02107
02108 #endif /* HS_HTTPLIB68K_H__ */
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:53 2008 for Palm API Guide


Header Files » Incs » common » libraries » http

HS_HTTPLibApp.h

Go to the documentation of this file.
00001 /*
00002     HS_HTTPLibApp.h
00003     Copyright(c) 1996-2002 ACCESS CO., LTD.
00004     All rights are reserved by ACCESS CO., LTD., whether the whole or
00005     part of the source code including any modifications.
00006 */
00007 #ifndef HS_HTTPLIBAPP_H__
00008 #define HS_HTTPLIBAPP_H__
00009
00010
00011 #define HS_HTTPLibID        'AsHT'
00012 #define HS_HTTPLibDBType    'libr'
00013 #define HS_HTTPLibName      "HTTPLibrary"
00014
00015 #define sysNotifyStopEvent 'test'
00016
00017 /* structure for application */
00018
00019 typedef MemHandle HS_HTTPLibHandle;
00020 struct HS_HTTPLibOpaque_ {
00021     Int32 fDummy;
00022 };
00023 typedef struct HS_HTTPLibOpaque_ *HS_HTTPLibOpaque;
00024
00025 struct HS_HTTPLibIPAddr_ {
00026     Int32 type;
00027     Char addr[16];
00028 };
00029 typedef struct HS_HTTPLibIPAddr_ HS_HTTPLibIPAddr;
00030
00031 #define httpIPAddrTypeV4 4
00032 #define httpIPAddrLenV4 4
00033
00034
00035 /* cookie info */
00036
00037
00038
00039 struct HS_HTTPLibAppinfo_ {
00040     UInt32 appCreator;
00041     Int32 maxSockets;
00042     Int32 isForeground;
00043     UInt32 recvBufferSize;
00044     /* cookie DB */
00045     Char *cookieDBName;
00046     UInt32 cookieDBCreator;
00047     UInt32 cookieDBType;
00048     UInt16 cookieDBVersion;
00049     Int32 cookieMaxJarSize;
00050     /* certDB */
00051     Char *certDBName;
00052     UInt32 certDBType;
00053     UInt16 certDBVersion;
00054 };
00055 typedef struct HS_HTTPLibAppinfo_ HS_HTTPLibAppInfo;
00056
00057 typedef Boolean (*HS_HTTPLibNetLibOpenProc)(HS_HTTPLibHandle in_libH, HS_HTTPLibOpaque in_aux);
00058 typedef Boolean (*HS_HTTPLibNetLibCloseProc)(HS_HTTPLibHandle in_libH, HS_HTTPLibOpaque in_aux);
00059 typedef Boolean (*HS_HTTPLibNetLibOnlineProc)(HS_HTTPLibHandle in_libH, HS_HTTPLibOpaque in_aux);
00060 typedef Boolean (*HS_HTTPLibNetLibOfflineProc)(HS_HTTPLibHandle in_libH, HS_HTTPLibOpaque in_aux);
00061
00062 struct HS_HTTPLibNetLibInfo_
00063 {
00064     UInt16 refNum;
00065     HS_HTTPLibNetLibOpenProc openProc;
00066     HS_HTTPLibNetLibCloseProc closeProc;
00067     HS_HTTPLibNetLibOnlineProc onlineProc;
00068     HS_HTTPLibNetLibOfflineProc offlineProc;
00069 };
00070 typedef struct HS_HTTPLibNetLibInfo_ HS_HTTPLibNetLibInfo;
00071
00072
00073 /* peer functions */
00074 typedef Int32 (*HS_TCPOpenPeer)(Int32 in_domain, HS_HTTPLibOpaque in_aux);
00075 typedef void (*HS_TCPClosePeer)(Int32 in_desc, HS_HTTPLibOpaque in_aux);
00076 typedef Int32 (*HS_TCPIsConnectedPeer)(Int32 in_desc, HS_HTTPLibOpaque in_aux);
00077 typedef Int32 (*HS_TCPConnectPeer)(Int32 in_desc, HS_HTTPLibIPAddr *in_addr, Int32 in_port, HS_HTTPLibOpaque in_aux);
00078 typedef Int32 (*HS_TCPReadPeer)(Int32 in_desc, Char *out_buf, Int32 in_len, HS_HTTPLibOpaque in_aux);
00079 typedef Int32 (*HS_TCPWritePeer)(Int32 in_desc, Char *in_buf, Int32 in_len, HS_HTTPLibOpaque in_aux);
00080 typedef Int32 (*HS_TCPCanReadWritePeer)(Int32 in_desc, Int32 in_rw, HS_HTTPLibOpaque in_aux);
00081
00082 struct HS_HTTPLibPeer_
00083 {
00084     /* method ptr */
00085     Int32 (*HS_HTTPLibPeerTCPOpen)(Int32 in_domain, HS_HTTPLibOpaque in_aux);                                       /* Open method func         */
00086     void (*HS_HTTPLibPeerTCPClose)(Int32 in_desc, HS_HTTPLibOpaque in_aux);                                         /* Close method func        */
00087     Int32 (*HS_HTTPLibPeerTCPIsConnected)(Int32 in_desc, HS_HTTPLibOpaque in_aux);                                  /* IsConnected method func  */
00088     Int32 (*HS_HTTPLibPeerTCPConnect)(Int32 in_desc, HS_HTTPLibIPAddr *in_addr, Int32 in_port, HS_HTTPLibOpaque in_aux);/* Connect method func  */
00089     Int32 (*HS_HTTPLibPeerTCPRead)(Int32 in_desc, Char *out_buf, Int32 in_len, HS_HTTPLibOpaque in_aux);    /* Read method func         */
00090     Int32 (*HS_HTTPLibPeerTCPWrite)(Int32 in_desc, Char *in_buf, Int32 in_len, HS_HTTPLibOpaque in_aux);    /* Write method func        */
00091     Int32 (*HS_HTTPLibPeerTCPCanReadWrite)(Int32 in_desc, Int32 in_rw, HS_HTTPLibOpaque in_aux);
00092 };
00093 typedef struct HS_HTTPLibPeer_ HS_HTTPLibPeer;
00094
00095 #endif /* HS_HTTPLIBAPP_H_ */
00096
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:53 2008 for Palm API Guide


Header Files » Incs » common » libraries » http

HS_HTTPLibConst.h

Go to the documentation of this file.
00001 /*
00002     HS_HTTPLibConst.h
00003     Copyright(c) 1996-2002 ACCESS CO., LTD.
00004     All rights are reserved by ACCESS CO., LTD., whether the whole or
00005     part of the source code including any modifications.
00006 */
00007 #ifndef HS_HTTPLIBCONST_H__
00008 #define HS_HTTPLIBCONST_H__
00009
00010 /* constants */
00011
00012 /* const */
00013 #define kHTTPLibTrapOpen sysLibTrapOpen
00014 #define kHTTPLibTrapClose sysLibTrapClose
00015 #define kHTTPLibTrapSleep sysLibTrapSleep
00016 #define kHTTPLibTrapWake sysLibTrapWake
00017 #define kHTTPLibTrapOpenCount  (sysLibTrapCustom + 0)
00018 #define kHTTPLibTrapInitialize  (sysLibTrapCustom + 1)
00019 #define kHTTPLibTrapFinalize  (sysLibTrapCustom + 2)
00020 #define kHTTPLibTrapSSLClass  (sysLibTrapCustom + 3)
00021 #define kHTTPLibTrapRegisterSSLClass  (sysLibTrapCustom + 4)
00022 #define kHTTPLibTrapClearDNSCache  (sysLibTrapCustom + 5)
00023 #define kHTTPLibTrapCloseAllKeepAlive  (sysLibTrapCustom + 6)
00024 #define kHTTPLibTrapMakeProxy  (sysLibTrapCustom + 7)
00025 #define kHTTPLibTrapSetHTTPPort  (sysLibTrapCustom + 8)
00026 #define kHTTPLibTrapSetHTTPSPort  (sysLibTrapCustom + 9)
00027 #define kHTTPLibTrapSetMaxRequestHeader  (sysLibTrapCustom + 10)
00028 #define kHTTPLibTrapSetMaxRequestBody  (sysLibTrapCustom + 11)
00029 #define kHTTPLibTrapSetProxy  (sysLibTrapCustom + 12)
00030 #define kHTTPLibTrapSetUserAgent  (sysLibTrapCustom + 13)
00031 #define kHTTPLibTrapSetDefaultHeaders  (sysLibTrapCustom + 14)
00032 #define kHTTPLibTrapSetUseProxy  (sysLibTrapCustom + 15)
00033 #define kHTTPLibTrapSetHTTP11OverProxy  (sysLibTrapCustom + 16)
00034 #define kHTTPLibTrapSetSendReferer  (sysLibTrapCustom + 17)
00035 #define kHTTPLibTrapSetSendProxyKeepAlive  (sysLibTrapCustom + 18)
00036 #define kHTTPLibTrapSetSendCookie  (sysLibTrapCustom + 19)
00037 #define kHTTPLibTrapSetConnectTimeOut  (sysLibTrapCustom + 20)
00038 #define kHTTPLibTrapSetReqTimeOut  (sysLibTrapCustom + 21)
00039 #define kHTTPLibTrapSetRspTimeOut  (sysLibTrapCustom + 22)
00040 #define kHTTPLibTrapIsUseProxy  (sysLibTrapCustom + 23)
00041 #define kHTTPLibTrapIsHTTP11OverProxy  (sysLibTrapCustom + 24)
00042 #define kHTTPLibTrapIsSendReferer  (sysLibTrapCustom + 25)
00043 #define kHTTPLibTrapIsSendCookie  (sysLibTrapCustom + 26)
00044 #define kHTTPLibTrapStreamNew  (sysLibTrapCustom + 27)
00045 #define kHTTPLibTrapStreamDelete  (sysLibTrapCustom + 28)
00046 #define kHTTPLibTrapStreamCreateRequest  (sysLibTrapCustom + 29)
00047 #define kHTTPLibTrapStreamCreateRequestWithChunkEncoding  (sysLibTrapCustom + 30)
00048 #define kHTTPLibTrapStreamSendRequest  (sysLibTrapCustom + 31)
00049 #define kHTTPLibTrapStreamSendRequestWithPostData  (sysLibTrapCustom + 32)
00050 #define kHTTPLibTrapStreamSendRequestWithChunkEncoding  (sysLibTrapCustom + 33)
00051 #define kHTTPLibTrapStreamReceiveResponse  (sysLibTrapCustom + 34)
00052 #define kHTTPLibTrapStreamGetFlag  (sysLibTrapCustom + 35)
00053 #define kHTTPLibTrapStreamClose  (sysLibTrapCustom + 36)
00054 #define kHTTPLibTrapStreamIsHeaderReceived  (sysLibTrapCustom + 37)
00055 #define kHTTPLibTrapStreamSetPostData  (sysLibTrapCustom + 38)
00056 #define kHTTPLibTrapStreamGetScheme  (sysLibTrapCustom + 39)
00057 #define kHTTPLibTrapStreamGetState  (sysLibTrapCustom + 40)
00058 #define kHTTPLibTrapStreamGetStatusCode  (sysLibTrapCustom + 41)
00059 #define kHTTPLibTrapStreamGetResponseHeaderLength  (sysLibTrapCustom + 42)
00060 #define kHTTPLibTrapStreamGetResponseHeader  (sysLibTrapCustom + 43)
00061 #define kHTTPLibTrapStreamGetContentLength  (sysLibTrapCustom + 44)
00062 #define kHTTPLibTrapStreamGetEntityLength  (sysLibTrapCustom + 45)
00063 #define kHTTPLibTrapStreamAddHeaderLine  (sysLibTrapCustom + 46)
00064 #define kHTTPLibTrapStreamAddHeader  (sysLibTrapCustom + 47)
00065 #define kHTTPLibTrapStreamGetHeader  (sysLibTrapCustom + 48)
00066 #define kHTTPLibTrapMakeCertList  (sysLibTrapCustom + 49)
00067 #define kHTTPLibTrapHeaderSplitByX  (sysLibTrapCustom + 50)
00068 #define kHTTPLibTrapAuthInfoTidy  (sysLibTrapCustom + 51)
00069 #define kHTTPLibTrapSetUserPass  (sysLibTrapCustom + 52)
00070 #define kHTTPLibTrapFindAuthInfo  (sysLibTrapCustom + 53)
00071 #define kHTTPLibTrapMakeAuthInfo  (sysLibTrapCustom + 54)
00072 #define kHTTPLibTrapAuthInfoUser  (sysLibTrapCustom + 55)
00073 #define kHTTPLibTrapAuthInfoPass  (sysLibTrapCustom + 56)
00074 #define kHTTPLibTrapAuthInfoRealm  (sysLibTrapCustom + 57)
00075 #define kHTTPLibTrapAuthCacheGetChallengeTokenSS  (sysLibTrapCustom + 58)
00076 #define kHTTPLibTrapSetCookieMode  (sysLibTrapCustom + 59)
00077 #define kHTTPLibTrapSetCookieMax  (sysLibTrapCustom + 60)
00078 #define kHTTPLibTrapSetCookie  (sysLibTrapCustom + 61)
00079 #define kHTTPLibTrapMakeCookiesString  (sysLibTrapCustom + 62)
00080 #define kHTTPLibTrapSaveCookiesEntries  (sysLibTrapCustom + 63)
00081 #define kHTTPLibTrapLoadCookiesEntries  (sysLibTrapCustom + 64)
00082 #define kHTTPLibTrapCookieMakeEmpty  (sysLibTrapCustom + 65)
00083 #define kHTTPLibTrapSetDNSMaxRetry  (sysLibTrapCustom + 66)
00084 #define kHTTPLibTrapSetDNSRetryInterval  (sysLibTrapCustom + 67)
00085 #define kHTTPLibTrapSetSSLVersionFlag  (sysLibTrapCustom + 68)
00086 #define kHTTPLibTrapSSLTimeout  (sysLibTrapCustom + 69)
00087 #define kHTTPLibTrapSSLOpenCertDB  (sysLibTrapCustom + 70)
00088 #define kHTTPLibTrapSSLCloseCertDB  (sysLibTrapCustom + 71)
00089 #define kHTTPLibTrapCertListNew  (sysLibTrapCustom + 72)
00090 #define kHTTPLibTrapCertListDelete  (sysLibTrapCustom + 73)
00091 #define kHTTPLibTrapCertListClone  (sysLibTrapCustom + 74)
00092 #define kHTTPLibTrapCertListLock  (sysLibTrapCustom + 75)
00093 #define kHTTPLibTrapCertListUnlock  (sysLibTrapCustom + 76)
00094 #define kHTTPLibTrapCertListType  (sysLibTrapCustom + 77)
00095 #define kHTTPLibTrapCertListLength  (sysLibTrapCustom + 78)
00096 #define kHTTPLibTrapCertListBeginDecode  (sysLibTrapCustom + 79)
00097 #define kHTTPLibTrapCertListEndDecode  (sysLibTrapCustom + 80)
00098 #define kHTTPLibTrapCertListImportCert  (sysLibTrapCustom + 81)
00099 #define kHTTPLibTrapCertPeekVersion  (sysLibTrapCustom + 82)
00100 #define kHTTPLibTrapCertPeekSerialNumber  (sysLibTrapCustom + 83)
00101 #define kHTTPLibTrapCertPeekSignAlgo  (sysLibTrapCustom + 84)
00102 #define kHTTPLibTrapCertBeginPeekIssuerRDN  (sysLibTrapCustom + 85)
00103 #define kHTTPLibTrapCertPeekIssuerRDN  (sysLibTrapCustom + 86)
00104 #define kHTTPLibTrapCertPeekIssuerRDNStrType  (sysLibTrapCustom + 87)
00105 #define kHTTPLibTrapCert_EndPeekIssuerRDN  (sysLibTrapCustom + 88)
00106 #define kHTTPLibTrapCertBeginPeekSubjectRDN  (sysLibTrapCustom + 89)
00107 #define kHTTPLibTrapCertPeekSubjectRDN  (sysLibTrapCustom + 90)
00108 #define kHTTPLibTrapCertPeekSubjectRDNStrType  (sysLibTrapCustom + 91)
00109 #define kHTTPLibTrapCert_EndPeekSubjectRDN  (sysLibTrapCustom + 92)
00110 #define kHTTPLibTrapCert_PeekValidityStart  (sysLibTrapCustom + 93)
00111 #define kHTTPLibTrapCert_PeekValidityEnd  (sysLibTrapCustom + 94)
00112 #define kHTTPLibTrapCert_PeekRSAPublicKeyBits  (sysLibTrapCustom + 95)
00113 #define kHTTPLibTrapClientCertListNew  (sysLibTrapCustom + 96)
00114 #define kHTTPLibTrapClientCertListClone  (sysLibTrapCustom + 97)
00115 #define kHTTPLibTrapClientCertListDelete  (sysLibTrapCustom + 98)
00116 #define kHTTPLibTrapClientCertListLength  (sysLibTrapCustom + 99)
00117 #define kHTTPLibTrapClientCertListIsValid  (sysLibTrapCustom + 100)
00118 #define kHTTPLibTrapClientCertListSetValid  (sysLibTrapCustom + 101)
00119 #define kHTTPLibTrapSetSSLServerCertConfirmProc  (sysLibTrapCustom + 102)
00120 #define kHTTPLibTrapServerCertConfirm  (sysLibTrapCustom + 103)
00121 #define kHTTPLibTrapSetSSLClientCertSelectProc  (sysLibTrapCustom + 104)
00122 #define kHTTPLibTrapClientCertSelect  (sysLibTrapCustom + 105)
00123 #define kHTTPLibTrapSetNetLibProc  (sysLibTrapCustom + 106)
00124 #define kHTTPLibTrapDataHandle_Length  (sysLibTrapCustom + 107)
00125 #define kHTTPLibTrapDataHandle_Lock  (sysLibTrapCustom + 108)
00126 #define kHTTPLibTrapDataHandle_Unlock  (sysLibTrapCustom + 109)
00127 #define kHTTPLibTrapDataHandle_Delete  (sysLibTrapCustom + 110)
00128 #define kHTTPLibTrapVHandle_Length  (sysLibTrapCustom + 111)
00129 #define kHTTPLibTrapVHandle_Lock  (sysLibTrapCustom + 112)
00130 #define kHTTPLibTrapVHandle_Unlock  (sysLibTrapCustom + 113)
00131 #define kHTTPLibTrapVHandle_Delete  (sysLibTrapCustom + 114)
00132 #define kHTTPLibTrapString_Length  (sysLibTrapCustom + 115)
00133 #define kHTTPLibTrapStringNew  (sysLibTrapCustom + 116)
00134 #define kHTTPLibTrapString_Lock  (sysLibTrapCustom + 117)
00135 #define kHTTPLibTrapString_Unlock  (sysLibTrapCustom + 118)
00136 #define kHTTPLibTrapString_Delete  (sysLibTrapCustom + 119)
00137 #define kHTTPLibTrapFixedString_Length  (sysLibTrapCustom + 120)
00138 #define kHTTPLibTrapFixedStringNew  (sysLibTrapCustom + 121)
00139 #define kHTTPLibTrapFixedString_Lock  (sysLibTrapCustom + 122)
00140 #define kHTTPLibTrapFixedString_Unlock  (sysLibTrapCustom + 123)
00141 #define kHTTPLibTrapFixedString_Delete  (sysLibTrapCustom + 124)
00142 #define kHTTPLibTrapURLString_Length  (sysLibTrapCustom + 125)
00143 #define kHTTPLibTrapURLStringNew  (sysLibTrapCustom + 126)
00144 #define kHTTPLibTrapURLString_Lock  (sysLibTrapCustom + 127)
00145 #define kHTTPLibTrapURLString_Unlock  (sysLibTrapCustom + 128)
00146 #define kHTTPLibTrapURLString_Delete  (sysLibTrapCustom + 129)
00147 #define kHTTPLibTrapCertListGetCipherInfo  (sysLibTrapCustom + 130)
00148 #define kHTTPLibTrapSetCookieX  (sysLibTrapCustom + 131)
00149 #define kHTTPLibTrapSetTunnelingCallback (sysLibTrapCustom + 132)
00150 #define kHTTPLibTrapSetMaxKeepAliveTimeout (sysLibTrapCustom + 133)
00151 #define kHTTPLibTrapStreamResumeTimer (sysLibTrapCustom + 134)
00152 #define kHTTPLibTrapStreamSuspendTimer (sysLibTrapCustom + 135)
00153 #define kHTTPLibTrapStreamGetRequestSent (sysLibTrapCustom + 136)
00154 #define kHTTPLibTrapStreamGetHeaderWithOffset (sysLibTrapCustom + 137)
00155 #define kHTTPLibTrapSetUserPassX (sysLibTrapCustom + 138)
00156 #define kHTTPLibTrapFindAuthCandidate (sysLibTrapCustom + 139)
00157 #define kHTTPLibTrapSetWakeUpCallback (sysLibTrapCustom + 140)
00158 #define kHTTPLibTrapSetUseragentSelectionRule (sysLibTrapCustom + 141)
00159
00160
00161 #define httpStreamRead      0x00000001
00162 #define httpStreamWrite     0x00000002
00163 #define httpStreamReadWrite (httpStreamRead|httpStreamWrite)
00164
00165 enum httpAuthType_ {
00166     httpAuthTypeNone = -1,
00167     httpAuthTypeBasic = 0,
00168     httpAuthTypeDigest,
00169     httpAuthTypeTypes
00170 };
00171 typedef enum httpAuthType_ httpAuthTypeEnum;
00172
00173 enum httpAuthTarget_ {
00174     httpAuthTargetPage = 0,
00175     httpAuthTargetProxy,
00176     httpAuthTargetTargets
00177 };
00178 typedef enum httpAuthTarget_ httpAuthTargetEnum;
00179
00180 enum httpAuthPath_ {
00181     httpAuthPathSame,
00182     httpAuthPathAncestor,
00183     httpAuthPathDescendant,
00184     httpAuthPathCousin
00185 };
00186 typedef enum httpAuthPath_ httpAuthPathEnum;
00187
00188 #define httpStreamTextCRLF              "\015\012"
00189 #define httpStreamTextCRLFCRLF          "\015\012\015\012"
00190 #define httpStreamTextCRCR              "\015\015"
00191 #define httpStreamTextLFLF              "\012\012"
00192
00193 /* errors */
00194 enum httpError_ {
00195
00196     httpErrorOK             = 0,
00197     httpErrorGeneric        = -1,
00198     httpErrorWouldBlock     = -2,
00199     httpErrorIOSleep        = -3,
00200     httpErrorNoMem          = -6,
00201     httpErrorInval          = -8,
00202
00203     httpErrorDNSInval       = -200,
00204     httpErrorDNSNoServer,
00205     httpErrorDNSTimedout,
00206     httpErrorDNSNotFound,
00207     httpErrorTCPOpen,
00208     httpErrorTCPConnect,
00209     httpErrorTCPRead,
00210     httpErrorTCPWrite,
00211     httpErrorSSLConnect,
00212     httpErrorSSLHandShake,
00213     httpErrorSSLRead,
00214     httpErrorSSLWrite,
00215     httpErrorReqTimedout,
00216     httpErrorRspTimedout,
00217     httpErrorCacheNone,
00218     httpErrorCacheExpire,
00219     httpErrorAuthUnknown,
00220     httpErrorAuthNoHeader,
00221     httpErrorAuthFormat,
00222     httpErrorRedirectFormat,
00223     httpErrorRedirectCanceled,
00224     httpErrorReqHeaderSizeOver, /* method GET */
00225     httpErrorReqBodySizeOver, /* method POST */
00226     httpErrorRspHeaderSizeOver,
00227     httpErrorReqTooManyContinue,
00228     httpErrorTLSIntolerant
00229 };
00230 typedef enum httpError_ httpErrorEnum;
00231
00232 /* header type */
00233 enum httpHeaderType_ {
00234     httpHeaderTypeGeneral = 0,
00235     httpHeaderTypeRequest,
00236     httpHeaderTypeResponse,
00237     httpHeaderTypeEntity,
00238     httpHeaderTypeOther,
00239     httpHeaderTypeTypes
00240 };
00241 typedef enum httpHeaderType_ httpHeaderTypeEnum;
00242
00243 /* constant for http stream state */
00244 enum httpStreamState_ {
00245     httpStreamStateNew = 0,
00246     httpStreamStateDormant,
00247     httpStreamStateReqCreated,
00248     httpStreamStateReqResolve,
00249     httpStreamStateReqResolving,
00250     httpStreamStateReqOpen,
00251     httpStreamStateReqConnect,
00252     httpStreamStateReqConnecting,
00253     httpStreamStateReqProxyConnect,
00254     httpStreamStateReqProxyConnecting,
00255     httpStreamStateReqSSLHandShaking,
00256     httpStreamStateReqSSLHandShaked,
00257     httpStreamStateReqSending,
00258     httpStreamStateReqSent,
00259     httpStreamStateRspHeaderWaiting,
00260     httpStreamStateRspContinue,
00261     httpStreamStateRspHeaderReceiving,
00262     httpStreamStateRspHeaderReceived,
00263     httpStreamStateRspEntityReceiving,
00264     httpStreamStateRspEntityReceived,
00265     httpStreamStateObsolete,
00266     httpStreamStateDelete,
00267     httpStreamStateStates
00268 };
00269 typedef enum httpStreamState_ httpStreamStateEnum;
00270
00271 /* constant for http stream protocol scheme */
00272 enum httpScheme_ {
00273     httpSchemeHTTP = 0,
00274     httpSchemeHTTPS,
00275     httpSchemeSchemes
00276 };
00277 typedef enum httpScheme_ httpSchemeEnum;
00278
00279 /* constant for http method */
00280 enum httpMethod_ {
00281     httpMethodOPTIONS = 0,
00282     httpMethodGET,
00283     httpMethodHEAD,
00284     httpMethodPOST,
00285     httpMethodPUT,
00286     httpMethodDELETE,
00287     httpMethodTRACE,
00288     httpMethodCONNECT,
00289     httpMethodMethods
00290 };
00291 typedef enum httpMethod_ httpMethodEnum;
00292
00293 /* constant for http version */
00294 enum httpVersion_ {
00295     httpVersion_0_9 = 0,
00296     httpVersion_1_0,
00297     httpVersion_1_1,
00298     httpVersionVersions
00299 };
00300 typedef enum httpVersion_ httpVersionEnum;
00301
00302 /* constant for http status code */
00303 enum httpStatusCode_ {
00304     httpStatusCodeContinue                          = 100,
00305     httpStatusCodeSwitchingProtocols                = 101,
00306     httpStatusCodeOK                                = 200,
00307     httpStatusCodeCreated                           = 201,
00308     httpStatusCodeAccepted                          = 202,
00309     httpStatusCodeNonAuthoritativeInformation       = 203,
00310     httpStatusCodeNoContent                         = 204,
00311     httpStatusCodeResetContent                      = 205,
00312     httpStatusCodePartialContent                    = 206,
00313     httpStatusCodeMultipleChoices                   = 300,
00314     httpStatusCodeMovedPermanently                  = 301,
00315     httpStatusCodeFound                             = 302,
00316     httpStatusCodeSeeOther                          = 303,
00317     httpStatusCodeNotModified                       = 304,
00318     httpStatusCodeUseProxy                          = 305,
00319     httpStatusCodeTemporaryRedirect                 = 307,
00320     httpStatusCodeBadRequest                        = 400,
00321     httpStatusCodeUnauthorized                      = 401,
00322     httpStatusCodePaymentRequired                   = 402,
00323     httpStatusCodeForbidden                         = 403,
00324     httpStatusCodeNotFound                          = 404,
00325     httpStatusCodeMethodNotAllowed                  = 405,
00326     httpStatusCodeNotAcceptable                     = 406,
00327     httpStatusCodeProxyAuthenticationRequired       = 407,
00328     httpStatusCodeRequestTimeout                    = 408,
00329     httpStatusCodeConflict                          = 409,
00330     httpStatusCodeGone                              = 410,
00331     httpStatusCodeLengthRequired                    = 411,
00332     httpStatusCodePreconditionFailed                = 412,
00333     httpStatusCodeRequestEntityTooLarge             = 413,
00334     httpStatusCodeRequestURITooLarge                = 414,
00335     httpStatusCodeUnsupportedMediaType              = 415,
00336     httpStatusCodeRequestedRangeNotSatisfiable      = 416,
00337     httpStatusCodeExpectationFailed                 = 417,
00338     httpStatusCodeInternalServerError               = 500,
00339     httpStatusCodeNotImplemented                    = 501,
00340     httpStatusCodeBadGateway                        = 502,
00341     httpStatusCodeServiceUnavailable                = 503,
00342     httpStatusCodeGatewayTimeout                    = 504,
00343     httpStatusCodeHTTPVersionNotSupported           = 505
00344 };
00345 typedef enum httpStatusCode_ httpStatusCodeEnum;
00346
00347 /* constant for cookie mode */
00348 enum httpCookie_ {
00349     httpCookieNotifyBeforeSet = 0,
00350     httpCookieAlwaysSet,
00351     httpCookieNeverSet
00352 };
00353 typedef enum httpCookie_ httpCookieEnum;
00354
00355 /* string encoding in post */
00356 #define httpPostURLENCODED      0x00000001
00357 #define httpPostPLAINTEXT       0x00000002
00358 #define httpPostMULTIPART       0x00000004
00359
00360 enum httpHeaderID_ {
00361     httpHeaderIDCacheControl,
00362     httpHeaderIDConnection,
00363     httpHeaderIDDate,
00364     httpHeaderIDPragma,
00365     httpHeaderIDTrailer,
00366     httpHeaderIDTransferEncoding,
00367     httpHeaderIDUpgrade,
00368     httpHeaderIDVia,
00369     httpHeaderIDWarning,
00370     httpHeaderIDKeepAlive,
00371     httpHeaderIDProxyConnection,
00372     httpHeaderIDAccept,
00373     httpHeaderIDAcceptCharset,
00374     httpHeaderIDAcceptEncoding,
00375     httpHeaderIDAcceptLanguage,
00376     httpHeaderIDAuthorization,
00377     httpHeaderIDExpect,
00378     httpHeaderIDFrom,
00379     httpHeaderIDHost,
00380     httpHeaderIDIfMatch,
00381     httpHeaderIDIfModifiedSince,
00382     httpHeaderIDIfNoneMatch,
00383     httpHeaderIDIfRange,
00384     httpHeaderIDIfUnmodifiedSince,
00385     httpHeaderIDMaxForwards,
00386     httpHeaderIDProxyAuthorization,
00387     httpHeaderIDRange,
00388     httpHeaderIDReferer,
00389     httpHeaderIDTE,
00390     httpHeaderIDUserAgent,
00391     httpHeaderIDCookie,
00392     httpHeaderIDAcceptRanges,
00393     httpHeaderIDAge,
00394     httpHeaderIDETag,
00395     httpHeaderIDLocation,
00396     httpHeaderIDProxyAuthenticate,
00397     httpHeaderIDRetryAfter,
00398     httpHeaderIDServer,
00399     httpHeaderIDVary,
00400     httpHeaderIDWWWAuthenticate,
00401     httpHeaderIDSetCookie,
00402     httpHeaderIDAuthenticationInfo,
00403     httpHeaderIDProxyAuthenticationInfo,
00404     httpHeaderIDAllow,
00405     httpHeaderIDContentEncoding,
00406     httpHeaderIDContentDisposition,
00407     httpHeaderIDContentLanguage,
00408     httpHeaderIDContentLength,
00409     httpHeaderIDContentLocation,
00410     httpHeaderIDContentMD5,
00411     httpHeaderIDContentRange,
00412     httpHeaderIDContentType,
00413     httpHeaderIDExpires,
00414     httpHeaderIDLastModified,
00415     httpHeaderIDRefresh,
00416     httpHeaderIDENUMS
00417 };
00418 typedef enum httpHeaderID_ httpHeaderIDEnum;
00419
00420
00421 /* SSL Version */
00422 #define httpSSLFlagConnV2                   0x00000001  /* connect by v2 protocol */
00423 #define httpSSLFlagConnV3                   0x00000002  /* connect by v3 protocol */
00424 #define httpSSLFlagConnTLS                  0x00000004  /* connect by TLS(v3.1) protocol */
00425 #define httpSSLFlagConnV2V3                 (httpSSLFlagConnV2 | httpSSLFlagConnV3)
00426 #define httpSSLFlagConnV2TLS                (httpSSLFlagConnV2 | httpSSLFlagConnTLS)
00427 #define httpSSLFlagConnV3TLS                (httpSSLFlagConnV3 | httpSSLFlagConnTLS)
00428 #define httpSSLFlagConnV2V3TLS              (httpSSLFlagConnV2 | httpSSLFlagConnV3 | httpSSLFlagConnTLS)
00429
00430 enum
00431 {
00432     httpCookieClearAtFinalize,
00433     httpCookieClearAll,
00434     httpCookieClearSessionCookiesOnly
00435 };
00436
00437 enum {
00438     httpDNSModeIPV4Only = 0
00439 };
00440
00441 enum {
00442     httpCetListTypeUnknown = 0,
00443     httpCetListTypeServer,
00444     httpCetListTypeClient,
00445     httpCetListTypeBrowser,
00446     httpCetListTypeTypes
00447 };
00448
00449 #endif /* HS_HTTPLIBCONST_H__ */
00450
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:53 2008 for Palm API Guide


Header Files » Incs » common » system

HsAppLaunchCmd.h

Go to the documentation of this file.
00001 /******************************************************************************
00002  * Copyright (c) 2004 PalmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  *****************************************************************************/
00005 /**
00006  *
00007  * @ingroup SystemDef
00008  *
00009  */
00010
00011 /**
00012  * @file    HsAppLaunchCmd.h
00013  * @version 1.0
00014  * @date    04/20/2000
00015  *
00016  * @brief Public header file akin to Palm's AppLaunchCmd.h
00017  *
00018  */
00019
00020 /**
00021  * @author   dia
00022  *
00023  * History:8
00024  *  12-oct-1999 dia - Created by Douglas Anderson
00025  *   20-apr-2000 dia - New APIs for dialing.
00026  *
00027  * <hr>
00028  */
00029
00030 #ifndef   __HSAPPLAUNCHCMD_H__
00031 #define   __HSAPPLAUNCHCMD_H__
00032
00033 //#include <CoreCompatibility.h>
00034 #include <AppLaunchCmd.h>
00035 #include <Common/Libraries/Imaging/palmOnePhotoCommon.h>
00036
00037 #include <HsPhoneTypes.h>
00038 #include <HsPhoneNetworkTypes.h>
00039 #include <HsPhoneGSMTypes.h>
00040 #include <HsPhoneSecurityTypes.h>
00041 #include <HsPhoneCDMATypes.h>
00042 #include <HsPhoneIOTATypes.h>
00043 #include <HsPhoneEvent.h>
00044
00045 //=============================================================================
00046 // Useful macros...
00047 //=============================================================================
00048
00049 // <chg 07-mar-00 dia>
00050 // The LaunchWithCommand() macro was added in the OS 3.2 headers, so we
00051 // only define this macro if we're compiling with old headers.
00052
00053 #ifndef LaunchWithCommand
00054   #define LaunchWithCommand(type, creator, command, commandParams) \
00055   { \
00056     UInt16              cardNo; \
00057     LocalID             dbID; \
00058     DmSearchStateType   searchState; \
00059     Err                     err; \
00060     DmGetNextDatabaseByTypeCreator(true, &searchState, type, \
00061         creator, true,  &cardNo, &dbID); \
00062     ErrNonFatalDisplayIf(!dbID, "Could not find db"); \
00063     if (dbID) \
00064       { \
00065         err = SysUIAppSwitch(cardNo, dbID, command, (Ptr) commandParams); \
00066         ErrNonFatalDisplayIf(err, "Could not launch db"); \
00067       } \
00068   }
00069 #endif // def(LaunchWithCommand)
00070
00071
00072 // <chg 07-mar-00 dia>
00073 // Unfortunately, CallWithCmmand() was never defined (I should have known
00074 // better).  Still, just in case Palm ever does define it, I'll couch
00075 // it in ifdefs.  Hopefully, they follow the other macro and it will look
00076 // just like this.
00077
00078 #ifndef CallWithCommand
00079   /** internal */
00080   #define CallWithCommand(type, creator, command, commandParams) \
00081   { \
00082     UInt16              cardNo; \
00083     LocalID             dbID; \
00084     DmSearchStateType   searchState; \
00085     UInt32 result; \
00086     Err err; \
00087     DmGetNextDatabaseByTypeCreator(true, &searchState, type, \
00088         creator, true,  &cardNo, &dbID); \
00089     ErrNonFatalDisplayIf(!dbID, "Could not find db"); \
00090     if (dbID) \
00091       { \
00092         err = SysAppLaunch(cardNo, dbID, 0, command, (Ptr) commandParams, &result); \
00093         ErrNonFatalDisplayIf(err, "Could not launch db"); \
00094       } \
00095   }
00096 #endif // def(CallWithCommand)
00097
00098
00099 //=============================================================================
00100 // Handspring-modified address book
00101 //=============================================================================
00102
00103 //-------------------------------------------------------------------
00104 // Extra launch codes
00105 //-------------------------------------------------------------------
00106
00107 /** Launch codes start at customBase + 0x2300 so that hopefully there won't be any conflict with
00108   * any launch codes that PalmSource or others add to the address book.
00109   * IMPORTANT: See also AddrCustomNotificationCodes . */
00110 typedef enum
00111   {
00112     addrAppLaunchCmdHsLookup= sysAppLaunchCmdCustomBase + 0x2300,   /**< Launch Contacts for lookup */
00113     addrAppLaunchCmdCallerID                                        /**< Launch Contacts for callerID lookup */
00114   }
00115 AddrCustomActionCodes;
00116
00117 /** Switch to using notifications rather than launch codes to avoid potential
00118   * conflicts if PalmSource modifies the address book app. */
00119 typedef enum
00120   {
00121         // NOTE:
00122         // Shouldn't be using these values!  Notification types are
00123         // supposed to be 4-character creator IDs that are registered in Palm's
00124         // Creator database!  Guess it's a little late now, since these codes are
00125         // out in the field.
00126         addrAppNotificationHsLookup = sysAppLaunchCmdCustomBase + 0x2300,
00127         addrAppNotificationCmdCallerID,
00128         addrAppNotificationPhonebookApp,
00129
00130         // DON'T ADD ANY MORE based on 2300:  See above NOTE
00131
00132         addrAppNotificationListLookupTypeGet = 'HsLL',      // Registered 2001-09-12 w/ Creator DB
00133         addrAppNotificationCreateNewRecord = 'HsNR',        // Registered 2002-07-30 w/ Creator DB
00134         addrAppNotificationDialPrefs = 'HsDP',              // Registered 2003-01-29 w/ Creator DB
00135         addrAppNotificationBeamBusinessCard = 'HsBB',       // Registered 2003-02-14 w/ Creator DB
00136         addrAppNotificationPhotoCallerID = 'HsPC'
00137   }
00138 AddrCustomNotificationCodes;
00139
00140 //-------------------------------------------------------------------
00141 // Support for addrAppLaunchCmdHsLookup
00142 //-------------------------------------------------------------------
00143
00144 /** Parameter block is the same as OS 3.1's block for sysAppLaunchCmdLookup */
00145 typedef AddrLookupParamsType AddrHsLookupParamsType;
00146
00147 /** Parameter block is the same as OS 3.1's block for sysAppLaunchCmdLookup */
00148 typedef AddrHsLookupParamsType * AddrHsLookupParamsPtr;
00149
00150 // We support all of the lookup fields that defined in the AddressLookupFields
00151 // enum for the OS 3.1 headers, plus these two.  The string versions of these
00152 // (for the formatstring paramter) are "voicephone" and "anyphone".
00153 // ...start at 0x70 so hopefully we get no conflicts.
00154
00155 /** Expansion to the Palm OS AddressLookupFields. */
00156 typedef enum {
00157     addrLookupVoicePhones=0x70,     /**< All phone fields except fax and email. */
00158     addrLookupAnyPhones ,           /**< All phone fields (including email) */
00159     addrLookupSMSPhones ,           /**< Mobile, other and email fields */
00160     addrLookupSMSPhonesNoEmail      /**< Mobile and other fields */
00161 } AddressHsLookupFields;
00162
00163
00164 //-------------------------------------------------------------------
00165 // Support for addrAppLaunchCmdCallerID
00166 //-------------------------------------------------------------------
00167
00168 /** Flag definitions for AddrCallerIDParamsType flags field
00169   * If this flag is set, we match numbers that are
00170   * shorter than the usual minimum required length.
00171   * We match the *entire* string, not substrings. */
00172 #define addrLookupNoMinLength       1
00173
00174
00175 /** Parameter block for addrAppLaunchCmdCallerID. */
00176 typedef struct
00177   {
00178     Char* lookupString;   /**< Must be only digits and include country code.
00179                                Example: 14085551212 */
00180     Char* formatString;   /**< Format of the output string like AddrLookupParamsPtr->formatString
00181                                Example ^name ( ^phonetypelabel ) might result
00182                                in "David ( work )" */
00183
00184     Char* resultString; /**<  Returned heap allocated string resultStringH; */
00185     Boolean (*callback)(void*); /**< Call back; Returns true to stop execution */
00186     void* ref;  /**< Reference that gets passed to callbackFunc */
00187     UInt32 uniqueID; /**< Unique ID of the matching record 0 if no match */
00188     UInt16 flags; /**< Flags associated with the called ID */
00189     UInt16 recordNum; /**<record number of the matching record. */
00190
00191   }
00192 AddrCallerIDParamsType, * AddrCallerIDParamsPtr;
00193
00194
00195 //-------------------------------------------------------------------
00196 // Support for addrAppNotificationListLookupTypeGet
00197 //-------------------------------------------------------------------
00198
00199 /** Various address book lookup methods. */
00200 enum
00201   {
00202     addrListLookupTypeLastName,           /**< phone lookup will be by last name... */
00203     addrListLookupTypeFirstName,          /**< phone lookup will be by first name... */
00204     addrListLookupTypeCompany,            /**< phone lookup will be by company (currently unused)... */
00205     addrListLookupTypeIntelligent         /**< phone lookup will be intelligent (either name or
00206                                                some other matching) (currently unused)...  */
00207   };
00208 typedef UInt16 AddrListLookupTypeEnum;    /**< AddrListLookupTypeEnum -> UInt16 */
00209
00210 /** Contains data used when launching address book for contact lookup. */
00211 typedef struct
00212   {
00213     UInt16                  version;      /**< IN/OUT: Should always be 0... */
00214     AddrListLookupTypeEnum  type;         /**< OUT: The type of phone lookup that
00215                                                     will occur if you do a lookup by
00216                                                     listName. */
00217   }
00218 AddrListLookupTypeGetParamsType;
00219
00220
00221 //-------------------------------------------------------------------
00222 // Support for addrAppLaunchCmdHsPhonebook
00223 //-------------------------------------------------------------------
00224 /** Parameter block for addrAppLaunchCmdHsPhonebook. */
00225 typedef struct
00226   {
00227     Char*     lookupStrP; /**< The lookup string that should be
00228                                preloaded in the lookup field */
00229     Boolean   activeCall; /**< Whether the active call icon should be
00230                                usable or not... could change in a sublaunch
00231                                when a call is dropped */
00232     Boolean   lookup;     /**< True if this notification is for a lookup
00233                                false if it is for a new contact */
00234     Char *    newPhoneNum;/**< Phone number of the new contact. */
00235   }
00236 AddrPhonebookAppParamsType, * AddrPhonebookAppParamsPtr;
00237
00238
00239 // <chg 2002-08-05 knm>
00240 // This is used to send a new contact data to AddressApp. Currently
00241 // SMSApp's "Save to Contacts" feature uses this.
00242 //-------------------------------------------------------------------
00243 // Support for addrAppNotificationCreateNewRecord
00244 //-------------------------------------------------------------------
00245
00246 /** Contains data when launching phone book with create new record view. */
00247 typedef struct
00248   {
00249     Char*   data;   /**< Data to save (Null terminated string) */
00250     UInt8   field;  /**< Phone number, URL, or email address field number.
00251                           *  They are defined in ViewForm.c as follows:
00252                           *  #define kAddrDBRecMobileFld 5   // phone3
00253                           *  #define kAddrDBRecEMailFld  7   // phone5
00254                           *  #define kAddrDBRecURLFld    14  // custom1
00255                           *  The values are based on the field definition in AddressDB.h. */
00256   }
00257 AddrCreateNewRecordParamsType, * AddrCreateNewRecordParamsPtr;
00258
00259 // <chg 2006-06-07 ericw>
00260 // This is used to add a number to an existing contact in PhoneApp. Currently
00261 // the post call number store uses this
00262 //-------------------------------------------------------------------
00263 // Support for addrAppNotificationAddToRecord
00264 //-------------------------------------------------------------------
00265
00266 /** Contains data when launching phone book with create new record view. */
00267 typedef struct
00268   {
00269     Char*   data;     /**< Data to save (Null terminated string) */
00270     UInt32  uniqueID; /**< The UID of the contact to save the phone number to */
00271     UInt8   field;    /**< Phone number, URL, or email address field number.
00272                           *  They are defined in ViewForm.c as follows:
00273                           *  #define kAddrDBRecMobileFld 5   // phone3
00274                           *  #define kAddrDBRecEMailFld  7   // phone5
00275                           *  #define kAddrDBRecURLFld    14  // custom1
00276                           *  The values are based on the field definition in AddressDB.h. */
00277   }
00278 AddrAddToRecordParamsType, * AddrAddToRecordParamsPtr;
00279 //-------------------------------------------------------------------
00280 // Support for addrAppNotificationHsLookup
00281 //-------------------------------------------------------------------
00282 #define AddrHsLookupUserDataVersion     0 /**< Version number of the addrAppNotificationHsLookup command and structures */
00283
00284 /** Structure that contains the data used for looking up user info in address book app */
00285 typedef struct
00286   {
00287     UInt16                  version;        /**< IN: Version of the userData structure */
00288     Boolean                 matchFound;     /**< OUT: TRUE if ANY match was found.
00289                                                       (i.e. 1 or more matches were
00290                                                       found)
00291                                                       FALSE if NO match was found. */
00292     Boolean                 useMultiFilter; /**< IN: TRUE if lookup should use multifilter.
00293                                                      FALSE if lookup should NOT use multifilter. */
00294   }
00295 AddrHsLookupUserDataType, *AddrHsLookupUserDataPtr;
00296
00297 #define AddrHsLookupUserDataVersion2        1 /**< Version number of the addrAppNotificationHsLookup command for the V2 structure */
00298
00299 typedef struct
00300   {
00301     UInt16                  version;        /**< IN: Version of the userData structure */
00302     Boolean                 matchFound;     /**< OUT: TRUE if ANY match was found.
00303                                                       (i.e. 1 or more matches were
00304                                                       found)
00305                                                       FALSE if NO match was found. */
00306     Boolean                 useMultiFilter; /**< IN: TRUE if lookup should use multifilter.
00307                                                      FALSE if lookup should NOT use multifilter. */
00308     Boolean                 displaySIMbook; /**< IN: TRUE if lookup should display Simbook entries.
00309                                                      FALSE if lookup should NOT display Simbook entries. */
00310   }
00311 AddrHsLookupUserDataV2Type, *AddrHsLookupUserDataV2Ptr;
00312
00313 //-------------------------------------------------------------------
00314 // Support for addrAppNotificationPhotoCallerID
00315 //-------------------------------------------------------------------
00316 /** Support for addrAppNotificationPhotoCallerID */
00317 typedef struct
00318 {
00319     UInt16      recordNum;  /**< Record for which we want to get the picture id */
00320     Coord       xExtent;    /**< Dimension of the photo required. Pass 0 to get max size. */
00321     Coord       yExtent;    /**< Dimension of the photo required. Pass 0 to get max size. */
00322     void        *imageBits; /**< Bits that represent the caller id image. image size returned in xExtent & yExtent */
00323 }
00324 AddrPhotoCallerIDParamsType, *AddrPhotoCallerIDParamsPtr;
00325
00326 //-------------------------------------------------------------------
00327 // Support for dialPnlLaunchCmd... commands
00328 //-------------------------------------------------------------------
00329
00330 // Boolean IsDialingAvailable (UInt32 serviceFlags)
00331 // ------------------------------------------------
00332
00333 /** Support for dialPnlLaunchCmd... commands */
00334 typedef struct
00335   {
00336     Boolean result;             /**< OUT: Space for result... */
00337     UInt8 _reserved0;           /**< IN:  Reserved byte--MUST BE 0. */
00338
00339     const UInt32* serviceIDsP;  /**< IN:  Array of services to check... */
00340     UInt16 numServices;         /**< IN:  Num elements in service IDs array. */
00341   }
00342 DialPnlIsDialingAvailableParamsType;
00343
00344
00345 // void DispatchDial (UInt16 service, void* paramP)
00346 // ------------------------------------------------
00347
00348 /** Use with the function DispatchDial (UInt16 service, void* paramP) */
00349 typedef struct
00350   {
00351     UInt32  serviceID;      /**< IN:  The service type to dial... */
00352     void*   dataP;          /**< IN:  Basic Data to send to the helper... */
00353     Char*   descriptionStr; /**< IN:  Description of data to dial... */
00354     UInt8   handled;        /**< OUT: Non-zero if handled */
00355     Err     err;            /**< OUT: Err code returned... */
00356   }
00357 DialPnlDispatchDialParamsType;
00358
00359
00360 //=============================================================================
00361 // Handspring phone application
00362 //=============================================================================
00363
00364 // DOLATER: Some of these may be obsolete now...
00365
00366 //------------------------------------------------------------------------
00367 // Phone application's custom launch codes
00368 //------------------------------------------------------------------------
00369
00370 /** Launch the phone application and dial the passed number */
00371 #define phoneAppLaunchCmdDial           (sysAppLaunchCmdCustomBase)
00372
00373 /** Launch the phone application and dial the last number dialed. */
00374 #define phoneAppLaunchCmdRedial         (sysAppLaunchCmdCustomBase+1)
00375
00376 /** Launch the phone application and display the active calls view. */
00377 #define phoneAppLaunchCmdViewCalls      (sysAppLaunchCmdCustomBase+2)
00378
00379 /** Launch the phone application and prompt to power on the phone */
00380 #define phoneAppLaunchCmdPowerOn        (sysAppLaunchCmdCustomBase+3)
00381
00382 /** Launch the phone application and dial a number */
00383 #define phoneAppLaunchCmdDialVoiceMail  (sysAppLaunchCmdCustomBase+4)
00384
00385 /** Launch the phone application and display the call history view. */
00386 #define phoneAppLaunchCmdViewHistory    (sysAppLaunchCmdCustomBase+5)
00387
00388 /** Launch the phone application and display the speed dial view. */
00389 #define phoneAppLaunchCmdViewSpeed      (sysAppLaunchCmdCustomBase+6)
00390
00391 /** Launch the phone application and display the keypad view. */
00392 #define phoneAppLaunchCmdViewKeypad     (sysAppLaunchCmdCustomBase+7)
00393
00394 /** Launch the phone application and display the Phone Home view */
00395 #define phoneAppLaunchCmdViewPhoneHome  (sysAppLaunchCmdCustomBase+8)
00396
00397 /** Launch the ## Application */
00398 #define phoneAppLaunchCmdActivation     (sysAppLaunchCmdCustomBase+10)
00399
00400 /** Set the Wallpaper */
00401 #define phoneAppLaunchCmdSetWallpaper   (sysAppLaunchCmdCustomBase+11)
00402
00403 /** Start the Network-initiated USSD */
00404 #define phoneAppLaunchCmdStartNetInitUSSD   (sysAppLaunchCmdCustomBase+12)
00405
00406 /** Launch the phone application and dial the passed number for SATK SETUP CALL */
00407 #define phoneAppLaunchCmdDialSTKSETUPCALL   (sysAppLaunchCmdCustomBase+13)
00408
00409 /** Launch the phone application to display the UI to ask the user if they
00410   * would like to search again. */
00411
00412 #define phoneAppLaunchCmdNetworkSearch  (sysAppLaunchCmdCustomBase+14)
00413
00414 /** Launch the phone application and send DTMF tone to the network */
00415 #define phoneAppLaunchCmdSendDTMFTone   (sysAppLaunchCmdCustomBase+15)
00416
00417 /** Launch the phone application and display missed calls in the call history view. */
00418 #define phoneAppLaunchCmdViewMissedCalls  (sysAppLaunchCmdCustomBase+16)
00419
00420 /** Display Dial Prefs */
00421 #define phoneAppLaunchCmdDisplayDialPrefs (sysAppLaunchCmdCustomBase+17)
00422
00423 /** Query for the carrier flag to determine if Dial Prefs menu option should be displyed */
00424 #define phoneAppLaunchCmdGetDialPrefFlag  (sysAppLaunchCmdCustomBase+18)
00425
00426 /** Query for the carrier flag to determine if Dial Prefs menu option should be displyed */
00427 #define phoneAppLaunchCmdGetUSDialingRules  (sysAppLaunchCmdCustomBase+19)
00428
00429 /** Launch the phone application and display the Options menu */
00430 #define phoneAppLaunchOptionsMenu         (sysAppLaunchCmdCustomBase+20)
00431
00432 /** Launch the phone application and display the Options menu */
00433 #define phoneAppLaunchCmdGetALSLineNumber     (sysAppLaunchCmdCustomBase+21)
00434
00435 // Launch the phone application if dialed from bt handsfree
00436 #define phoneAppLaunchCmdBluetoothDial (sysAppLaunchCmdCustomBase+22)
00437
00438 // Launch the phone application if dialed from bt handsfree
00439 #define phoneAppLaunchCmdBluetoothDialVoiceMail (sysAppLaunchCmdCustomBase+23)
00440
00441 // Query the phone application for the caller id for a given number
00442 #define phoneAppLaunchCmdCallerIDLookup (sysAppLaunchCmdCustomBase+25)
00443
00444 // Re-register all the Phone App views
00445 #define phoneAppLaunchCmdRegisterAllViews (sysAppLaunchCmdCustomBase+27)
00446
00447 //------------------------------------------------------------------------
00448 // Data send this request to dial a number (phoneAppLaunchCmdDial).
00449 //------------------------------------------------------------------------
00450
00451 /** Phone application dial methods. */
00452 typedef enum
00453   {
00454     PhoneAppDialMethodNormal = 0,     /**< Normal PhnLibDial() */
00455     PhoneAppDialMethodSATSetupCall,   /**< Use SIM Toolkit and respond
00456                                             affirmative to the SIM's request
00457                                             to set up a call. */
00458         // The below codes are added to allow passing of the call setup
00459         // options
00460         PhoneAppDialMethodSATSetupCallModeNotBusy,
00461         PhoneAppDialMethodSATSetupCallWithRedialModeNotBusy,
00462         PhoneAppDialMethodSATSetupCallHoldOtherCalls,
00463         PhoneAppDialMethodSATSetupCallWithRedialHoldOtherCalls,
00464         PhoneAppDialMethodSATSetupCallDisconnectOtherCalls,
00465         PhoneAppDialMethodSATSetupCallWithRedialDisconnectOtherCalls,
00466   }
00467 PhoneAppDialMethodEnum;
00468
00469 /** Contains the data used by Phone app launch command dial. */
00470 typedef struct
00471     {
00472     UInt8                   version;            /**< version number, set to one */
00473     Boolean                 confirm;            /**< confirm before dialing. */
00474     Char*                   name;               /**< optional */
00475     Char*                   number;             /**< optional */
00476     Char*                   extraDigits;        /**< optional */
00477     // Version 1
00478     UInt32                  failLaunchCreator;  /**< app to relaunch if dialling fails */
00479     UInt16                  failLaunchCode;     /**< launch code to use when relaunching */
00480     void*                   failLaunchParams;   /**< params to use when relaunching */
00481     UInt16                  dialMethod;         /**< Method to use to dial the phone number
00482                                                      See PhoneAppDialMethodEnum. */
00483     }
00484 PhoneAppLaunchCmdDialType, * PhoneAppLaunchCmdDialPtr;
00485
00486 /** Contains data used by PhoneAppLaunchCmdSetWallpaper. */
00487 typedef struct
00488   {
00489     UInt32                  wallpaperUID;       /**< OBSOLETE */
00490     // Version 2
00491     PalmPhotoFileLocation   wallpaperLocation;  /**< path to image */
00492   }
00493 PhoneAppLaunchCmdSetWallpaperType, *PhoneAppLaunchCmdSetWallpaperPtr;
00494
00495 /** Contains data used by PhoneAppLaunchCmdSendDTMFTone. */
00496 typedef struct
00497   {
00498     char                tone;       /**< the key that was pressed to trigger the launch cmd */
00499     Boolean             repeated;   /**< true if the character was on autoRepeat */
00500   }
00501 PhoneAppLaunchCmdSendDTMFToneType, *PhoneAppLaunchCmdSendDTMFTonePtr;
00502
00503 /** Contains data used by PhoneAppLaunchCmdGetDialPref */
00504 typedef struct
00505 {
00506   Boolean               displayDialPrefs; /**< If true Dial Preferences option is made available */
00507 }
00508 PhoneAppLaunchCmdGetDialPrefFlagType, *PhoneAppLaunchCmdGetDialPrefFlagPtr;
00509
00510 /** Data structure that goes with phoneAppLaunchCmdGetALSLineNumber launch cmd */
00511 typedef struct
00512 {
00513   UInt8     lineNumber; /**<ALS Line number */
00514 }
00515 PhoneAppLaunchCmdGetALSLineNumberType, *PhoneAppLaunchCmdGetALSLineNumberTypePtr;
00516
00517 /** Data structure that goes with phoneAppLaunchCmdGetUSDialingRules launch cmd */
00518 enum
00519   {
00520     hsDialPrefsAddAreaCodeUnknown = 0,    /**< we don't know yet, so prompt when appropriate */
00521     hsDialPrefsAddAreaCodeNo,             /**< no auto-area code */
00522     hsDialPrefsAddAreaCodeYes,            /**< add area code automatically before dialing */
00523
00524     hsDialPrefsAdd4DigitPrefixUnknown, //For 6 digit dialing
00525     hsDialPrefsAdd4DigitPrefixNo,
00526     hsDialPrefsAdd4DigitPrefixYes,
00527
00528     hsDialPrefsAdd5DigitPrefixUnknown,
00529     hsDialPrefsAdd5DigitPrefixNo,
00530     hsDialPrefsAdd5DigitPrefixYes,
00531
00532     hsDialPrefsAdd6DigitPrefixUnknown,
00533     hsDialPrefsAdd6DigitPrefixNo,
00534     hsDialPrefsAdd6DigitPrefixYes
00535   };
00536
00537 /** MAX Length of the dialing prefixes for 7,6,5 and 4 digit numbers
00538  * respectively, including zero-terminator. */
00539 #define hsDialPrefsAutoAreaCodeLength     11
00540 #define hsDialPrefs6DigitPrefixLength   11
00541 #define hsDialPrefs5DigitPrefixLength   11
00542 #define hsDialPrefs4DigitPrefixLength   11
00543
00544 #define hsDialPrefsMaxDialingPrefixLength 11
00545
00546 /** HsDialPrefsUSDialingRulesType */
00547 typedef struct
00548   {
00549     UInt8  rulesEnabled;        /**< [OUT] if non-zero, then these should be
00550                                            be applied; if zero -- don't apply. */
00551     UInt8  _reserved0;          /**< caller must set to 0 (zero) -- for byte alignment, and reserved for
00552                                      future use by the DialPrefs API */
00553
00554     UInt8  areaCodeCtl;         /**< [OUT] one of hsDialPrefsAddAreaCodeUnknown,
00555                                            hsDialPrefsAddAreaCodeNo, or
00556                                            hsDialPrefsAddAreaCodeYes;
00557                                            default is hsDialPrefsAddAreaCodeUnknown */
00558
00559     UInt8  add1BeforeAreaCode;  /**< [OUT] if non-zero, automatically add "1" in front
00560                                            of the area code of US/Canada numbers;
00561                                            if zero -- don't.  Default is to add the "1"
00562                                            in front of US/Canada area codes. */
00563
00564     char  autoAreaCode[hsDialPrefsAutoAreaCodeLength];
00565                                 /**< [OUT] the "auto" area code digits to add to 7-digit
00566                                            numbers if areaCodeCtl is hsDialPrefsAddAreaCodeYes; ignore otherwise; */
00567
00568     UInt8  prefix6DigitCtl; //Dialing prefix for 6-digit dialed numbers
00569                                                     // one of hsDialPrefsAdd6DigitPrefixUnknown,
00570                                                     //hsDialPrefsAdd6DigitPrefixNo,
00571                                                     //hsDialPrefsAdd6DigitPrefixYes
00572     UInt8  prefix5DigitCtl; //Dialing prefix for 5-digit dialed numbers
00573                                                     // one of hsDialPrefsAdd5DigitPrefixUnknown,
00574                                                     //hsDialPrefsAdd5DigitPrefixNo,
00575                                                     //hsDialPrefsAdd5DigitPrefixYes
00576     UInt8  prefix4DigitCtl; //Dialing prefix for 4-digit dialed numbers
00577                                                     // one of hsDialPrefsAdd4DigitPrefixUnknown,
00578                                                     //hsDialPrefsAdd4DigitPrefixNo,
00579                                                     //hsDialPrefsAdd4DigitPrefixYes
00580
00581
00582     char auto6DigitPrefix[hsDialPrefs6DigitPrefixLength];
00583     char auto5DigitPrefix[hsDialPrefs5DigitPrefixLength];
00584     char auto4DigitPrefix[hsDialPrefs4DigitPrefixLength];
00585   }
00586 HsDialPrefsUSDialingRulesType;
00587
00588 /** Contains data used by phoneAppLaunchCmdCallerIDLookup */
00589 typedef struct
00590   {
00591     Char*   numberP;            /**< the view type to display                                          be applied; if zero -- don't apply. */
00592     Char*   nameP;              /**< if not NULL, the view manager will pass this data block to the view
00593                                      once the view has been opened */
00594   }
00595 PhoneAppLaunchCmdCallerIDLookupType, PhoneAppLaunchCmdCallerIDLookupPtr;
00596
00597 //------------------------------------------------------------------------
00598 // Phone application's custom notification codes
00599 //------------------------------------------------------------------------
00600
00601 /** This notification is broadcast by the Phone application */
00602 #define pmPhoneAppNotifyHomeAppEvent        'pEvt'    // Registered with PalmSource Creator ID DB
00603
00604 /** The parameter for pmPhoneAppNotifyHomeAppEvent notification is
00605   * of type PhnEventPtr(as defined in HsPhoneEvent.h */
00606 #define pmPhoneAppNotifySetWallpaper        'pWlp'    // Registered with PalmSource Creator ID DB
00607
00608 // Parameter structure for pmPhoneAppNotifySetWallpaper notification
00609 // See PhoneAppLaunchCmdSetWallpaperType
00610
00611 // -----------------------------------------------------------------------------
00612 // Sound Prefs custom launch codes.
00613 // -----------------------------------------------------------------------------
00614
00615 /** Launch sounds Prefs in Phone Prefs view */
00616 #define soundPrefsLaunchCmdPhone            (sysAppLaunchCmdCustomBase)
00617
00618 /** Launch Sound Prefs in SMS Prefs view */
00619 #define soundPrefsLaunchCmdSMS              (sysAppLaunchCmdCustomBase+1)
00620
00621 /** Launch Sound Prefs in IM Prefs view */
00622 #define soundPrefsLaunchCmdIM               (sysAppLaunchCmdCustomBase+2)
00623
00624 /** Launch Sound Prefs in Email Prefs view */
00625 #define soundPrefsLaunchCmdEmail            (sysAppLaunchCmdCustomBase+3)
00626
00627 /** Launch Sound Prefs in Calendar Prefs view */
00628 #define soundPrefsLaunchCmdCalendar         (sysAppLaunchCmdCustomBase+4)
00629
00630 /** Launch Sound Prefs in the MMS Prefs view */
00631 #define soundPrefsLaunchCmdMMS              (sysAppLaunchCmdCustomBase+5)
00632
00633 /** Launch Sound Prefs in the General Prefs view */
00634 #define soundPrefsLaunchCmdGeneral              (sysAppLaunchCmdCustomBase+6)
00635
00636 /** Different sound pref dialog views. */
00637 typedef enum
00638 {
00639   soundPrefsViewTones,
00640   soundPrefsViewVolume
00641 } SoundPrefsView;
00642
00643 /** Contains data used by SoundPrefsLaunchCmd. */
00644 typedef struct
00645 {
00646   SoundPrefsView launchView;            /**< Launch to the tones/volume view. */
00647 }
00648
00649 SoundPrefsLaunchCmdParamType, * SoundPrefsLaunchCmdParamPtr;
00650
00651 // -----------------------------------------------------------------------------
00652 // Handspring Web browser custom launch codes
00653 // -----------------------------------------------------------------------------
00654
00655 /** Launch the browser in the bookmark dialog */
00656 #define     sysAppLaunchWebBrowserLaunchBookmarkDialog      (sysAppLaunchCmdCustomBase)
00657
00658 /** Retrieve the browser's home page */
00659 #define     sysAppLaunchWebBrowserGetHomePage                     (sysAppLaunchCmdCustomBase + 1)
00660
00661 /** Set the browser's home page */
00662 #define     sysAppLaunchWebBrowserSetHomePage                     (sysAppLaunchCmdCustomBase + 2)
00663
00664 /** Launch the browser in autocrawl mode */
00665 #define   sysAppLaunchWebBrowserAutoCrawl               (sysAppLaunchCmdCustomBase + 3)
00666
00667 /** Launch the browser in tips/tutorial mode */
00668 #define   sysAppLaunchWebBrowserTutorialMode            (sysAppLaunchCmdCustomBase + 4)
00669
00670 /** Launch the browser in minimal mode */
00671 #define   sysAppLaunchWebBrowserMinimalMode             (sysAppLaunchCmdCustomBase + 5)
00672
00673 /** Contains data used when launching web browser in minimal mode. */
00674 typedef struct {
00675   Char*                    launchUrl;           /**< URL to browse when launching */
00676   Char*                    doneButtonLabel;     /**< Label on the Done button */
00677 } webBrowserMinimalModeLaunchInfo;
00678
00679 /* Launch the browser with a specific network service ID */
00680 #define   sysAppLaunchWebBrowserURLWithSvcID             (sysAppLaunchCmdCustomBase + 6)
00681
00682 /** Contains data used when launching web browser with a specific SvcID. */
00683 typedef struct {
00684   UInt32                   svcID;               /**< Network SvcID from NetPref */
00685   Char*                    launchUrl;           /**< URL to browse when launching */
00686 } webBrowserURLWithSvcIDLaunchInfo;
00687
00688
00689 //=============================================================================
00690 // Handspring Camera application
00691 //=============================================================================
00692
00693 /** Stop any active Camera preview */
00694 #define   cameraAppLaunchCmdStopPreview                   (sysAppLaunchCmdCustomBase)
00695
00696 /**Notification to request stop/pause video preview/playback.
00697   *In the event of high priority UI action like an incoming phone call,
00698   *if the responsible application does not take action the sender of this
00699   *notification may take appropriate action in order to handle the high priority task */
00700 #define pmNotifyHighPriorityUITask      'pmUT'
00701
00702 /**Notification to request stop/pause audio preview/playback.
00703   *In the event of high priority UI action like an incoming phone call,
00704   *if the responsible application does not take action the sender of this
00705   *notification may take appropriate action in order to handle the high priority task */
00706 #define pmNotifyHighPriorityAudioTask   'pmAT'
00707
00708 #endif // __HSAPPLAUNCHCMD_H__
00709
00710
00711
00712
00713
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:53 2008 for Palm API Guide


Header Files » Incs » common » system

HsChars.h

Go to the documentation of this file.
00001 /** @ingroup System
00002  *
00003  */
00004 /**
00005  * @file HsChars.h
00006  *
00007  * Definitions of Handspring's character codes.
00008  * (see Palm's Chars.h)
00009  *
00010  * \license
00011  *
00012  * Copyright (c) 2002 Handspring Inc., All Rights Reserved
00013  *
00014  * $Id: //device/handheld/dev/sdk/2.2.2/incs/common/system/HsChars.h#3 $
00015  *
00016  ****************************************************************/
00017
00018 #ifndef __HSCHAR_H__
00019 #define __HSCHAR_H__
00020
00021 // ------------------------------------------------------------------------------
00022 //  Key codes and events
00023 // ------------------------------------------------------------------------------
00024
00025 // Keycode range assigned to us from Palm
00026 #define hsChrRangeMin                 0x1600  // vchrSlinkyMin
00027 #define hsChrRangeMax                 0x16FF  // vchrSlinkyMax
00028
00029
00030 // OBSOLETE - No more graffiti area so no more "dots"
00031 // key codes for the "dot" soft icons
00032 //#define hsChrMidLeftDot             0x1600
00033 //#define hsChrMidRightDot            0x1601
00034 //#define hsChrBotLeftDot             0x1602
00035 //#define hsChrBotRightDot            0x1603
00036
00037 // OBSOLETE - we no longer detect the serial cradle
00038 // The virtual cradle 2 character for notification of serial connection
00039 //#define   hsChrCradle2OnChr         0x1604      // dock input level asserted
00040 //#define   hsChrCradle2OffChr        0x1605      // dock input level de-asserted
00041
00042 // OBSOLETE - No more springboard
00043 // card removed or inserted
00044 //#define   hsChrCardStatusChg        0x1606
00045
00046 // DOLATER: OBSOLETE? - PhonePrefs checks it, but nobody enqueues it.
00047 // no-op key event that is used to interrupt apps that are
00048 // interrupted by key events...
00049 #define hsChrNoop                     0x1607
00050
00051 // OBSOLETE - Replaced by Palm's vchrJogPush
00052 // jog-in key
00053 //#define hsChrJogScan                0x1608
00054
00055 // key that invokes ListType
00056 #define hsChrSymbol                   0x1609
00057 #define hsChrPostProcess              hsChrSymbol
00058
00059 // answer incoming call
00060 #define hsChrAnswer                   0x160A
00061
00062 // the lid was either opened or closed
00063 #define hsChrLidStatusChg             0x160B
00064
00065 // toggle the radio power
00066 #define hsChrRadioPower               0x160C
00067
00068 // shift, option, or control (menu) - update the graffiti state indicator
00069 #define hsChrModifierKey              0x160D    // was hsChrUpdateGrfIndicator
00070
00071 // shift + page-up
00072 #define hsChrShiftPageUp              0x160E
00073
00074 // shift + page-down
00075 #define hsChrShiftPageDown            0x160F
00076
00077 // please shut down netlib
00078 #define hsChrShutdownNetlib           0x1610
00079
00080 // mute switch on or off
00081 #define hsChrMuteOn                   0x1611
00082 #define hsChrMuteOff                  0x1612
00083
00084
00085 // 5-way rocker (see "Chars.h" section of HsNavCommon.h)
00086 //#define vchrRockerUp                  0x0132      // 5-way rocker up
00087 //#define vchrRockerDown                0x0133      // 5-way rocker down
00088 //#define vchrRockerLeft                0x0134      // 5-way rocker left
00089 //#define vchrRockerRight               0x0135      // 5-way rocker right
00090 //#define vchrRockerCenter              0x0136      // 5-way rocker center/press
00091
00092 // opt + app
00093 #define hsChrOptHard1                 vchrHard5
00094 #define hsChrOptHard2                 vchrHard6
00095 #define hsChrOptHard3                 vchrHard7
00096 #define hsChrOptHard4                 vchrHard8
00097 #define hsChrOptHardPower             vchrHard9
00098 #define hsChrOptReserved              vchrHard10    // for future use
00099 #define hsChrOptHard11                vchrHard12
00100 #define hsChrOptHard13                vchrHard14
00101
00102 // AVAILABLE
00103 //#define hsChrAvailable13            0x1613
00104 //#define hsChrAvailable14            0x1614
00105 //#define hsChrAvailable15            0x1615
00106 //#define hsChrAvailable16            0x1616
00107 //#define hsChrAvailable17            0x1617
00108
00109 // enqueued after the display is turned on
00110 // (the display is usually still off for Palm's late wakeup)
00111 #define hsChrWakeup                   0x1618
00112
00113 // causes the keyguard dialog to be displayed
00114 // for internal use only... use hsAttrKeyboardLocked to programmatically enable/disable it
00115 #define hsChrKeyboardLock             0x1619
00116
00117 // delete the word at the cursor in a text edit field
00118 #define hsChrDeleteWord               0x161A
00119
00120 // we now define these audio volume up and down key events (original Treo used vchrJogUp and vchrJogDown)
00121 #define hsChrVolumeUp                 0x161B
00122 #define hsChrVolumeDown               0x161C
00123
00124 // this character is enqueued by NetMaster library when it needs to execute
00125 // code from the UI task's context while handling a background login request
00126 #define hsChrNetMasterUIExecute       0x161D
00127
00128 // This character is enqueued by our patch to EvtGetEvent when the device needs
00129 //  to shutdown because the battery is too low.  If the battery countdown
00130 //  dialog is able to handle the shutdown itself, then it will clear the
00131 //  system's shutdown time and the system will not shutdown the device.  If the
00132 //  battery countdown dialog is not able to handle the shutdown itself, the
00133 //  system will handle the shutdown the next time EvtGetEvent is called.
00134 #define hsChrLowBatteryShutdown       0x161E
00135
00136 // side button (below volume keys on Treo650)
00137 #define hsChrSide                     0x161F
00138
00139 // Opt + RightShift == "dark mode" on Treo650
00140 #define hsChrDarkMode                                     0x1620
00141
00142 // Used to rebroadcast the Send key to invoke the redial list
00143 #define hsChrRedialList                                   0x1621
00144
00145 // Used in bug 217045
00146 #define hsChrReserved1622                                    0x1622
00147
00148 // Characters in PSI's "hard-key" range.  We've received PSI's permission for these definitions.  PSI
00149 //  will include these definitions in their next 5.x SDK release so we surround these definitions with
00150 //  macros.
00151
00152 #ifndef vchrHard11
00153 #define vchrHard11                  0x021A
00154 #endif // vchrHard11
00155
00156 #ifndef vchrHard12
00157 #define vchrHard12                  0x021B  // Alternative vchrHard11 action
00158 #endif // vchrHard12
00159
00160 #ifndef vchrHard13
00161 #define vchrHard13                  0x021C
00162 #endif // vchrHard13
00163
00164 #ifndef vchrHard14
00165 #define vchrHard14                  0x021D  // Alternative vchrHard14 action
00166 #endif // vchrHard14
00167
00168 #endif  // __HSCHAR_H__
00169
00170
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:53 2008 for Palm API Guide


Header Files » Incs » common

HsCommon.h

Go to the documentation of this file.
00001 /******************************************************************************
00002  * Copyright (c) 2004 PalmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  *****************************************************************************/
00005
00006 /**
00007  * @file    HsCommon.h
00008  * @version 1.0
00009  * @date
00010  *
00011  * Main Handspring Palm OS API Header file
00012  *
00013  *  Most functions or API's are specific to either the 68K environment or the
00014  *  ARM environment but both of them sometimes share the same structures, types,
00015  *  constants etc.. The common header files are for those shared components that
00016  *  are used by both the 68K and ARM parts of a library, extention etc. In
00017  *  general, a developer would never have to include this file seperataely. It
00018  *  is already included in both the 68K/Hs.h and the ARM/Hs.h.
00019  *
00020  *  Note: (11-Feb-2008) ARM include files are not in the general release.
00021  *
00022  * @author Kiran Prasad
00023  * <hr>
00024  */
00025
00026
00027 #ifndef __HS_COMMON_H__
00028
00029 #define __HS_COMMON_H__
00030
00031 #include <PalmTypes.h>
00032 #include <PalmCompatibility.h>
00033 #include <PalmOS.h>
00034
00035 #include <Common/System/HsAppLaunchCmd.h>
00036 #include <Common/System/HsCreators.h>
00037 #include <Common/System/HsChars.h>
00038 #include <Common/System/HsErrorClasses.h>
00039 #include <Common/System/HsExgMgrCommon.h>
00040 #include <Common/System/HsErrors.h>
00041
00042
00043 #include <Common/Libraries/FavoritesDBLibrary/FavoritesDBLibTypes.h>
00044
00045 #include <Common/Libraries/Imaging/ImageLibCommon.h>
00046 #include <Common/Libraries/Imaging/ImageLibTraps.h>
00047
00048 #include <Common/Libraries/Camera/CameraLibCommon.h>
00049
00050 #include <Common/Libraries/HTTP/HS_HTTPLibApp.h>
00051 #include <Common/Libraries/HTTP/HS_HTTPLibConst.h>
00052 #include <Common/Libraries/MMS/MmsHelperCommon.h>
00053
00054 #endif /* __HS_COMMON_H__ */
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:53 2008 for Palm API Guide


Header Files » Incs » common » system

HsCreators.h

Go to the documentation of this file.
00001 /******************************************************************************
00002  * Copyright (c) 2004 PalmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  *****************************************************************************/
00005 /** @ingroup System
00006  *
00007  */
00008
00009 /**
00010  * @file    HsCreators.h
00011  * @version 1.0
00012  * @date    01/08/2000
00013  *
00014  * @brief Public header file for the creator IDs used by Handspring
00015  */
00016
00017 /*
00018  * @author   dia
00019  *
00020  *  History:
00021  *  4-May-1999 VMK - Created by Vitaly Kruglikov
00022  *  8-Jan-2000 DOC - Added resource type and id for character lookup table
00023  *                    used by Manhattan's keyboard driver
00024  */
00025
00026 #ifndef   __HS_CREATORS_H__
00027 #define   __HS_CREATORS_H__
00028
00029
00030
00031 //-----------------------------------------------------------
00032 // Note from Palm Computing's SystemMgr.rh:
00033 //................................................................
00034 // File types and creators
00035 //
00036 //  Each database shall have a creator ID and a type.
00037 //
00038 //  The creator ID shall establish which application, patch, or extension
00039 //  a particular database is associated with.  The creator ID should identify
00040 //  the application/patch/extension, NOT who created it.
00041 //
00042 //  The type will determine which part of an application,
00043 //  patch, or extension a particular database is.
00044 //
00045 //  There can be only one database per application, patch, or extension
00046 //  which has type 'application', 'patch', or 'extension'.
00047 //
00048 //  Creators:
00049 //
00050 //  ROM-based applications created by Palm Computing have all-lower case
00051 //  creator ID's.  Third-party applications have creator ID's which
00052 //  are either all caps, or mixed case.  The same requirements go for
00053 //  system patches and extensions.
00054 //
00055 //  All applications, system patches and extensions shall have unique creator
00056 //  ID's.
00057 //
00058 //  Types:
00059 //
00060 //  'Application', 'Extension', and 'Patch' file/database types for ROM-based
00061 //  apps shall be all-lower case.  Other file/database types must be mixed-case,
00062 //  or all caps.  These other types are internal to the applications, and
00063 //  therefore the system is unconcerned with their exact values.
00064 //................................................................
00065
00066 //  All Creators with "Yes" in the Reg column have been registered into
00067 //  Palm's Creator database using the web page at
00068 //  http://dev.palmos.com/creatorid/
00069
00070
00071 // ------------------------------------------------------------------
00072 // Apps                                           // Reg : Comment
00073 // ------------------------------------------------------------------
00074 /**
00075  * @name Misc. App Creator IDs
00076  */
00077 /*@{*/
00078 #define hsFileCAdvCalculator            'HsPr'    // Yes : Advanced Calculator application
00079 #define hsFileCCardSetup                'HsCd'    // Yes : ALL card setup utilities have
00080                                                   //      this creator
00081
00082 #define hsFileCSampleCardWelcome        'CWel'    // Yes : Sample card welcome app
00083 #define hsFileCHandTerminal             'HTrm'    // Yes : HandTerminal application sample code
00084
00085 #define hsFileCFileMover                'FlMv'    // Yes : FileMover application (for flash cards)
00086
00087 #define hsFileCFileInstaller            'FlIn'    // Yes : FileInstaller application (for flash cards)
00088
00089 #define hsFileCDateBook3H               'HsDB'    // Yes : Handspring's version of Datebk3.
00090
00091 #define hsFileCBackup                   'HsBk'    // Yes : Serial Flash Backup application
00092 #define hsFileCBackupWelcome            'HsBw'    // Yes : Not used
00093 /*@}*/
00094
00095 /**
00096  * @name Phone App Creator IDs
00097  */
00098 /*@{*/
00099 #define hsFileCPhone                    'HsPh'    // Yes : Phone core application
00100 #define hsFileCPhone2                   'HsP2'    // Yes : Phone core application version 3.0
00101 #define hsFileCPhoneStub68k             'Pm68'    // Yes : Phone 68k stub app for calling 68k libraries that do UI
00102 #define hsFileCPhoneMainView                'PmPm'    // Yes : Phone Main view
00103 #define hsFileCPhoneDialPadView             'PmPd'    // Yes : Phone Dial Pad view
00104 #define hsFileCPhonePeopleView              'PmPp'    // Yes : Phone People view
00105 #define hsFileCPhoneFavoritesView           'PmPf'    // Yes : Phone Favorites view
00106 #define hsFileCPhoneCallLogView             'PmPl'    // Yes : Phone Call Log view
00107 #define hsFileCPhoneActiveCallView          'PmPa'    // Yes : Phone Active Call view
00108 #define hsFileCPhoneIncomingCallView            'PmPi'    // Yes : Phone Incoming Call view
00109 #define hsFileCPhoneAppFavoritesLibrary     'PmPF'      // Yes: Phone Application Favorites library
00110 #define hsFileCPhoneTips                'PhTp'    // Yes : Phone tips
00111 #define hsFileCPhoneSecurity            'HsSE'    // Yes : Phone Security application
00112 #define hsFileCPhoneWizard              'HsPw'    // Yes : Phone wizard application
00113 #define hsFileCPhoneRingerPanel         'HsRN'    // Yes : Ringer Panel
00114 #define hsFileCDisplayPanel             'HsDs'    // Yes:  Display Panel
00115 #define hsFileCKeyguardPanel            'HsKg'    // Yes:  Keyguard prefs Panel
00116 //#define hsFileCSMS                        'SMSa'    // No  : Phone SMS app (Short Message Service)
00117 #define hsFileCSMS                      'SMSh'    // Yes : Phone SMS app (Short Message Service)
00118 #define hsFileCSimPhoneBook             'HsPB'    // Yes : Phone - Sim PhoneBook app
00119 #define hsFileCSimServices              'HsSS'    // Yes : Phone - Sim Services app
00120 #define hsFileCIM                       'HsIM'    // Yes : Phone - IM (Instant Messaging) app
00121 //#define hsFileCSmartTextEngine            'HsRT'    // Yes : Smart Text Engine shared library (68K)
00122 #define hsFileCSmartTextEngine          'HsST'    // Yes : Smart Text Engine shared library (ARM)
00123 #define hsFileCTexter                   'HsCh'    // Yes : Texter, aka SMS
00124
00125 #define hsFileCMessageStore             'HsMS'    // Yes : Message Store (used by NeXTer)
00126 #define hsFileSMSTreoTransport          'Trn0'    // Yes
00127 #define hsFileMMSTreoTransport          'Trn1'    // Yes
00128 #define hsFileSMSPalmTransport          'Trn2'    // Yes
00129 #define hsFileMMSPalmTransport          'Trn3'    // Yes
00130 #define hsFilePhoneBluetoothConnect     'PhBt'    // Yes : Phone - Bluetooth (Connect headset)
00131 /*@}*/
00132
00133 /**
00134  * @name Misc. App Creator IDs
00135  */
00136 /*@{*/
00137 #define hsFileCImagine                  'HsIm'    // Yes : Imagine (imaging app)
00138
00139 #define hsFileCAddrBookExtensions       'HsAX'    // Yes : Handspring address book extensions
00140 #define hsFileCDialingPanel             'HsDi'    // Yes : Dialing Panel...
00141 #define hsFileCAddrBookOneFingerMode    'HsAl'    // Yes : Address book modifications - one finger mode
00142
00143 #define hsFileCPinballGame              'HsPg'    // Yes : Pinball color game
00144 #define hsFileCSetISP                   'HsJS'    // Yes : SetISP application -Sitti 2001-05-17 for Hydra project.
00145 /*@}*/
00146
00147 /**
00148  * @name Web Browser Creator IDs
00149  */
00150 /*@{*/
00151 #define hsFileCBlazer                   'BLZ1'    // Yes : Bluelark Blazer browser
00152 #define hsFileCBlazer3                  'BLZ5'    // Yes : Blazer 3 browser (OS 5)
00153 #define hsFileCBlazer3TutorialLauncher  'HsTM'    // Yes : Blazer 3 Tutorial mode launcher & device tutorial content
00154 #define hsFileCBlazer3TipsSharedContent 'HsSC'    // Yes : Blazer 3 Shared tutorial/tips content
00155 /*@}*/
00156
00157 /**
00158  * @name Misc. App Creator IDs
00159  */
00160 /*@{*/
00161 #define hsFileCCityTime                 'CiAa'    // No  : CityTime app - creator belongs
00162                                                   //        to original author, Darren Beck
00163
00164 #define hsFileCKeyboardDemo             'kDem'    // Yes : Keyboard Demo
00165
00166 #define hsFileCFirmwareUpdater          'HsFU'    // Yes : Wismo Firmware updater
00167 #define hsFileCGPRSUpdater              'HsGU'    // Yes : GPRS Updater for the Liberty project
00168 #define hsFileCRomUpdater               'hROM'    // Yes : ROM updater
00169 #define hsFileCCDMAUpdater              'HsCU'    // Yes : CDMA Firmware Updater
00170
00171 #define hsFileCCDMAActivation           'HsAc'    // Yes : ## Application
00172
00173 #define hsFileCGSMActivation            'HsGA'    // Yes : ## Application
00174
00175 #define hsFileCIOTA                     'Iota'    // Yes : IOTA Application (Sprint)
00176 #define hsTetheredTreo                  'HsTt'    // Yes : Tethering application for Treos
00177
00178 #define hsFileCDebugPrefs               'hsCn'    // Yes : Debug Prefs application
00179
00180 #define hsFileCCamera                   'Bcam'    // yes : Camera app
00181 #define hsFileCCameraTips               'BcTp'    // yes : Camera Tips
00182 #define hsFileCDuoHack                  'DuHk'    // yes : Duo Hack
00183 #define hsFileCTutorialContent          'TMTp'    // yes : Duo tutorial content
00184 #define hsFileCEmailTipsContent         'HsTC'    // yes : Email tips content
00185 #define hsFileCNavSample                'HsNS'    // yes : Sample navigation app
00186 #define hsFileCSave2Card                'HsSD'    // yes : Save Exchange manager file to VFS card
00187 #define hsFileCBrightness                               'brtP'    // yes : brightness popup app for Treo 650
00188 #define hsFileCGettingStartedApp                        'GSGa'    // yes : app for launching Getting Starged Guide (GSG)
00189 /*@}*/
00190
00191
00192 // Testing apps...
00193 #define hsFileCLangSpoofer              'HsLS'    // Yes : Language spoofer
00194 #define hsFileCAddrTester               'HsAT'    // Yes : Address Tester
00195 #define hsFileCMailWrapper              'HsMW'    // Yes : Mail Wrapper...
00196 #define hsFileCUsbTester                'HsU2'    // No  : Usb tester...
00197 #define hsFileCPhoneWrapper             'HsPW'    // Yes : Phone Wrapper
00198 #define hsFileCSetMem                   'Hssm'    // Yes : Handspring Set Mem App
00199 #define hsFileCSerialCoupler            'Hssc'    // Yes : Handspring serial coupler app
00200 #define hsFileCUartCoupler              'Hsuc'    // Yes : Handspring uart coupler app
00201 #define hsFileCSpringWriter             'Hss1'    // Yes : Not used (feel free to take)
00202 #define hsFileCUsbResetTest             'Hsur'    // Yes : USB reset tester.
00203 #define hsFileCGasTest                  'Hsgt'    // Yes : Gas Guage testing application
00204 #define hsFileCIsolateMemoryChip        'Isom'    // Yes : Isolate a failing memory chip
00205 #define hsFileCCameraTest               'HsZZ'    // Yes : Camera test application
00206
00207 #define hsFileCUseSerial                'HSUS'    // Yes : App to signal FlashPrep for serial use
00208 #define hsFileCTraceViewer              'HsTV'    // Yes : Trace Viewer App
00209 #define hsFileCPmUIUtilLibTest          'PmUT'    // Yes : PmUIUtilLibTest App
00210
00211 // ------- Types
00212 #define hsFileTCardSetup                'HsSU'    // N/A : ALL card setup utilities have this
00213                                                   //        type
00214 #define hsFileTCardSetupShell           'HApp'    // N/A : Card Setup Shell application type
00215
00216 #define hsFileTSndFile                  'SndF'    // Yes : Unused... was for FileStream databases holding
00217                                                   // sampled sound that can be played with SndFileStream
00218
00219
00220 // Creators for things other than apps...
00221 #define hsFileCAutomaticHelper          'Auto'    // Yes : Apps that handle the "automatic"
00222                                                   //       choice for dialing.
00223
00224 // ------------------------------------------------------------------
00225 // Panels                                             // Reg : Comment
00226 // ------------------------------------------------------------------
00227
00228 #define hsFileCPhoneServicesPanel       'hsPS'    // No: Phone preference panel
00229
00230 #define hsFileCLCDAdjustPanel           'HsLA'    // Yes: LCD Adjustment preference panel
00231
00232 #define hsFileCMultiChannelRingToneDB   'MCnl'    // Yes: Database that has multi-channel ring tones
00233
00234 #define hsFileCDefaultAppsPanel         'HsDH'    // Yes: Default Helper Apps panel
00235
00236 #define hsFileCButtonPrefsPanel         'HsBt'    // Yes: Buttons Prefs Panel
00237 // ------------------------------------------------------------------
00238 // Patches
00239 // ------------------------------------------------------------------
00240 //#define hsFileC....
00241
00242 // ------- Others
00243 #define hsFileCHandspringPalmOSUpdate   'Hspt'    // Yes : Creator of PalmOS 3.5 patches
00244                                                   //       sanctioned by Handspring.  Type
00245                                                   //       of these files should be 'ptch'.
00246 #define hsFileCHandspringSystemResource 'HsSr'    // Yes: Creator of database that overrides
00247                                                   //      palm system resources.
00248
00249
00250 // ------- Types
00251 #define hsFileTHandspringHal            'HwAl'    // N/A : File type of HAL.prc
00252 #define hsFileTHandspringPatch          'HsPt'    // N/A  : File type of HsExtensions.prc
00253
00254 #define hsFileTHandspringUIObj          'HsUi'    // N/A  : File type of HsExtUIRsc.prc
00255
00256
00257
00258 // ------------------------------------------------------------------
00259 // Extensions
00260 // ------------------------------------------------------------------
00261 #define hsFileCHandspringExt          'HsEx'      // Yes : Handspring system extensions
00262 #define hsFileCNavExt                 'HsEp'    // Yes : Handspring NAV extensions
00263 #define hsFileCModemMgrExt            'HsMM'    // Yes : Handspring ModemMgr extensions
00264 #define hsFileCDataMgrExt             'HsDM'    // Yes : Handspring DataMgr extensions
00265 // 'HsPM' has been registed with PalmSource on March 24, 2003 at 3:10pm PST
00266 #define hsFileCProgressMgrExt         'HsPM'    // Yes : Handspring Progress Manager patch extensions
00267 #define hsFileCUIExt                  'HsUI'    // Yes: Handspring UI extensions
00268
00269 // ------------------------------------------------------------------
00270 // Libraries
00271 // ------------------------------------------------------------------
00272
00273 /**
00274  * @name Library Creator IDs
00275  */
00276 /*@{*/
00277 #define hsFileCSampleSerLib             'HsCs'    // Yes : Sample Serial 16650 library
00278
00279 #define hsFileCTaskLib                  'HsTS'    // Yes: Task library
00280
00281 #define hsFileCFfsCSegLib               'FfMg'    // Yes : Flash File System code segment
00282                                                   //        library
00283
00284 #define hsFileCLdbMgr                   'HsLm'    // Yes : Launcher Database Manager library
00285
00286
00287 #define hsFileCModemSerLib              'HsMs'    // Yes : Modem Module Serial library
00288
00289 #define hsFileCFlMgr                    'FLMG'    // Yes : Flash Manager
00290
00291 #define hsFileCFluMgr                   'FlMg'    // Yes : Arm based Flash Utility Library
00292
00293 #define hsFileCHwmCSegLib               'Hhwm'    // Yes : Phone HAL
00294
00295 #define hsFileCCDMAPhoneLib             'HsCL'    // Yes : CDMA Phone Library
00296
00297 #define hsFileCCDMAMsgLib               'HsMg'    // Yes : CDMA Message Library
00298
00299 #define hsFileCGSMPhoneLib              'GSM!'    // Yes : GSM Phone Library
00300
00301 #define GSMLibRingsDBCreatorID          'GSMr'    // Yes : moved from gsmlibrary.h <chg 09-12-2002 TRS> DUO CLEANUP
00302
00303 #define hsFileCTransparencyLib          'HsTL'    // No : Transparency Library creator
00304
00305 #define hsFileCComChannelProvider       'HsCP'    // No : Com Channel Provider creator
00306
00307 #define hsFileSMSExchangeLib            'HsSX'    // No : SMS Exchange Library
00308
00309 #define hsFileCFakeNetLib               'netl'    // Same as the real NetLib used to be, so our
00310                                                   //  "fake" NetLib library will be called by
00311                                                   //  clients instead of the "true" NetLib.
00312 #define hsFileCPatchedNetLib            'netb'    // We change the creator id of the "true" NetLib in 5.x
00313                                                   //  to this value to make sure that our "fake" NetLib
00314                                                   //  wrapper will be called instead.
00315
00316 #define hsFileCameraLib                 'HsCa'    // No : Camera Library
00317
00318 #define hsFileCARMTelephonyWrapper      'PIL!'    // Yes : ARM Telephony Wrapper
00319 #define hsFileCTelephonyInterfaceLayer  'TIL!'    // Yes : Telephony Interface Layer
00320 #define hsFileCCodecWrapper             'CdWr'    // Yes : CPM Codec Wrapper
00321
00322 #define hsFileBrowserCoreLib            'AcBC'    // Yes : Blazer browser core library
00323
00324 #define hsFileSoundLib                  'HsAu'    // Yes : HsSoundLib
00325 #define hsAmrLib                        'AMRL'    // No: Amr library used by AmrEncLib (below)
00326 #define hsAmrEncLib                     'AENL'    // No: AmrEncLib audio speech encoder
00327 #define hsAmrDecLib                     'ADEL'    // No: AmrDecLib audio speech decoder
00328
00329 #define hsFileCMCLLib                   'MCLL'    // No : MCL Library
00330
00331 #define pmFileCKeyLib                   'PmKe'    // Yes : Key Library
00332
00333 #define pmFileCUIUtilLib                'PmUU'    // Yes : UI Utility Library
00334
00335 #define pmFileCSystemLib                'PmSy'    // Yes : System Library
00336
00337 #define pmFileCSysGadgetLib             'PmSg'    // Yes : System Gadget Library
00338
00339 // Driver database creator and driver creator for the built-in Serial driver
00340 // IMPORTANT: There is a "feature" in the Connection Panel that makes it
00341 //  always pick the first serial driver as the default method when creating
00342 //  a new connection and assuming the first method supports modems.
00343 // So... we make sure the creator of the built-in serial comes first in
00344 //  the directory listing by giving it a creator ID that sorts before
00345 //  all the other serial driver creator IDs (hsFileCUsbLib, hsFileCSerDrvrAuto,
00346 //  sysFileCVirtIrComm).
00347 #define hsFileCSerLib                   'A8xZ'    // Yes  : SerialHWMgr driver ID
00348
00349 #define hsFileCModuleSerLib             'HsSs'    // Yes  : Serial lib for UART2 (goes to springboard)
00350                                                   //        ...only present on some devices like Belle...
00351
00352 #define hsFileCVirtualModemSerLib       'FakM'    // Yes  : Virtual Modem
00353
00354 #define hsFileCVirtualGSMSerLib         'VGSM'    // Yes  : Virtual GSM
00355
00356 #define hsFileCDirectRadioSerLib        'DirR'    // Yes  : Direct Radio access SdrvDirectRadio
00357
00358 #define hsFileCHsSerWrapperLib          'Hssw'    // Yes  : Old-style library used to wrap new drivers.
00359
00360 #define hsFileSPI1SerLib                'HsSp'    // Yes  : SPI1-Serial library
00361
00362 #define hsFileCHsSSLLib109a             'hSSL'    // Yes  : Handspring version of SSLPlus 1.0.9a.
00363                                                   //        ...also defined as PalmHsSSLPLUS109aLibCreatorID
00364
00365 // Driver database creator for the USB drivers
00366 #define hsFileCUsbLib                   'HsUs'    // Yes : USB Library database creator
00367   // These driver ID's are installed by the USB database
00368   #define   hsFileCSerDrvrUSBConsole    'HsUc'    // Yes : SerialHWMgr driver ID
00369   #define   hsFileCSerDrvrUSBDesktop    'HsUd'    // Yes : SerialHWMgr driver ID
00370   #define   hsFileCSerDrvrUSBRemFS      'HsUr'    // Yes : SerialHWMgr driver ID
00371   #define   hsFileCSerDrvrUSBGeneric    'HsUg'    // Yes : SerialHWMgr driver ID
00372   #define   hsFileCSerDrvrUSBGeneric2   'HsUh'    // Yes : SerialHWMgr driver ID
00373
00374
00375 // Driver database creator and driver creator for the auto-select virtual driver
00376 // ...this one is able to be set by springboard modules; by default it maps to
00377 // the cradle...
00378 #define hsFileCSerDrvrAuto              'HsSA'    // Yes  : SerialHWMgr driver ID
00379
00380 #define hsFileCSerDrvrCradle            'HsCS'    // Yes  : SerialHWMgr driver ID
00381
00382 #define hsFileCSDLib                    'Hssd'    // Yes  : SD Library ID
00383
00384 #define hsFileCCCLib              'CCLb'  // Yes : Carrier Customization Library
00385
00386 #define hsFileCOldGrfLib                'HsGf'    // Yes  : Creator ID given to PalmOS's Graffiti Lib
00387
00388 #define hsFileCTonesLib                 'HsTo'    // Yes  : Ringtones library
00389 /*@}*/
00390
00391 // ------- Types
00392 #define hsFileTCodeSeg                  'CSeg'    // N/A  : Code segment library
00393
00394
00395 // ------------------------------------------------------------------
00396 // ROM tokens
00397 // ------------------------------------------------------------------
00398 #define hsFileCFFSInfoTok1              'Ffs1'    // Yes : Flash file system info
00399                                                   //        ROM Token string; see
00400                                                   //        FfsMgrPrv.h for format
00401                                                   //        details (FOR HANDSPRING, INC.
00402                                                   //        USE ONLY!)
00403
00404 #define hsFileCFfsCrType                'Ffs2'    // Yes : ascii string of colon-separated
00405                 // creator and type of the module's Flash File System Manager. This value
00406                 // MUST be unique for each Flash File System Manager implementation. This
00407                 // token provides a level of indirction that allows applications to locate
00408                 // the provider of FfsMgr services on any module that supports this
00409                 // architecture and is fully compatible with the Handspring, Inc.'s FfsMgr
00410                 // API. The format is "CCCC:TTTT", where CCCC is the unique 4-character
00411                 // creator ID of your FfsMgr registred with Palm Computing, and TTTT is the
00412                 // 4-character type id of your FfsMgr (must be mixed case ascii). (for example,
00413                 // the reserved value used by Handspring, Inc. implementation is "FfMg:CSeg")
00414
00415
00416 #define hsFileCCardAccessTime           'HsAT'    // Yes : ascii decimal string of
00417                                                   //        access time in nano-seconds
00418
00419 #define hsFileCCardWelcomeDuringReset   'HsWR'    // Yes : actual value ignored. Presence
00420                                                   //        means launch welcome app during reset
00421
00422 #define hsFileCCardWelcomeAppTypeCreator 'HsWT'   // Yes : type & creator of card welcome app
00423                                                   // ONLY AVAILABLE IN VERSION 3.5 AND LATER
00424                                                   //       Ex:  -tokStr "HsWT" "applMYAP"
00425
00426 #define hsFileCSmartSmallromToken       'HsSR'    // Yes: defines that the given smallrom is
00427                                                   //      smart about running from RAM--it will
00428                                                   //      auto-drop into the appropriate debugger.
00429
00430 #define hsFileCBuiltinHsExtToken        'HsHX'    // Yes: defines what version of HSExtension is
00431                                                   //      builtin to the ROM.
00432                                                   // ONLY AVAILABLE IN HSEXT 3.5 VERSION 1.2 AND LATER
00433
00434 #define hsBluetoothIdToken              'BTid'    // Yes: this is the 6 byte Bluetooth ID stored in the ROM token area
00435                                                   //   first available in the Treo 650 project.
00436
00437 #define htcManufacturingInfoToken       'HTCM'    // yes - HTC's manufacturing info token ID as specified
00438                                                   // 6/4/04 by Kim Horng, HTC MFG Test Engineering II Dep.,
00439                                                   // Tel : (03)3753252  ext : 5455, Mail : Kim_Horng@htc.com.tw
00440 #define pmLimitLocaleToken              'LLid'    // yes : Set this token to a certain locale to keep the
00441                                                   //       language picker from extracting other locales...
00442 #define pmDebugLockoutToken             'Dblk'    // ??? : This token is used by the DAL to tell if debugging
00443                                                   //       is locked out (in other words, a password is set).
00444 // <chg 2005-NOV-10 Monte Benaresh> Added next define
00445 #define pmTSCalToken                    'TScb'  //  Yes: Token used to store
00446                                                 // the touchscreen calibration.
00447                                                 // Used by Welcome App
00448                                                 // (SetupPhone) starting with
00449                                                 // Ventura/Camino
00450 // <chg 2005-NOV-14 Monte Benaresh> Added next define
00451 #define pmKbdLayoutToken                'KBlo'  // Yes: Token to store the keyboard
00452                                                 // layout. Used by Welcome App
00453                                                 // (SetupPhone) starting with
00454                                                 // Ventura/Camino
00455
00456 // <chg 2006-MAR-31 Monte Benaresh> Added next define - bug 154466
00457 #define pmTSTokenValidToken             'TStv'  // Yes: Token whose presence
00458                                                 // indicates that the TScb token
00459                                                 // should be used (see above).
00460                                                 // Used by Welcome App
00461                                                 // (SetupPhone) starting with
00462                                                 // Ventura/Camino. Size = 2 bytes
00463
00464 //................................................................
00465 // Miscellaneous database types
00466 //................................................................
00467
00468 #define hsFileTModemSetupPatch          'HsMp'    // N/A  : The Patch for the Modem Module's
00469                                                   //         CardSetup app has this type and
00470                                                   //         the same creator as the Modem
00471                                                   //         Module's serial library (hsFileCModemSerLib)
00472
00473
00474 #define hsCompressedDbCreatorId         'Lz7C'    // Yes: Creator and type id's of the compressed
00475 #define hsCompressedDbTypeId            'Lz7C'    //      databases
00476
00477 #define hsKbdLayoutDbTypeCreator        'KbLy'    // Yes: Type and creator of database containing
00478                                                   //      keyboard layout resources
00479
00480 #define hsFileCTextEncodingConverterLib 'TecL'    // Yes: TextEncodingConverter database creator
00481 #define hsFileCTextEncodingConverterTable 'TecD'  // Yes: TextEncodingConverter conversion table database type
00482 #define hsRscTextEncodingConverterTable 'TecT'    // Yes: TextEncodingConverter conversion table resource type
00483
00484 #define hsFileCPowerKey                 '000P'    // Yes: Virtual app that can be mapped to an
00485                                                   //      app key to make it act like the power key
00486
00487 #define hsFileCKeyguard                 'kLoc'    // No:  Virtual app that can be mapped to an
00488                                                   //      app key to make it lock the keyboard
00489
00490 #define pmSlotDriverActivityIndicator   'PmAI'    // Yes: Use this ID for the TFFS slot driver Custom Control
00491                                                   //      API to turn the activity indicator on or off.
00492
00493 #define pmROMTokenWrite                 'TOKw'    // Yes: Use this ID for the TFFS slot driver Custom Control
00494                                                   //      API to write ROM Tokens
00495
00496 #define pmROMTokenRead                  'TOKr'    // Yes: Use this ID for the TFFS slot driver Custom Control
00497                                                   //      API to read ROM Tokens
00498
00499 //................................................................
00500 // Notification types
00501 //................................................................
00502 #define hsNotifyRemSleepRequestEvent      'REMq'  // Yes: Notification sent after sysNotifySleepRequestEvent
00503                                                   //      to determine if anyone needs to continue processing
00504                                                   //      with the screen turned off. The details parameter
00505                                                   //      is SleepEventParamType, in which deferSleep should
00506                                                   //      be incremented if REM sleep is required.
00507
00508 #define hsNotifyRemSleepEvent             'REMs'  // Yes: Notification sent to indicate that REM sleep is starting
00509                                                   //      (because hsNotifyRemSleepRequestEvent was deferred).
00510                                                   //      The screen is already turned off and the autooff timer has
00511                                                   //      been primed to expire soon. That will cause the cycle to
00512                                                   //      restart with sysNotifySleepRequestEvent and
00513                                                   //      hsNotifyRemSleepRequestEvent both being sent again.
00514
00515 #define hsNotifySetInitialFldStateEvent   'HsFg'  // Yes: Notification sent so app can set the initial shift state
00516                                                   //      of a field that just received the focus.
00517
00518 #define pmNotifyGetNewMsgCountFromHelper  'gMgC'  // Yes: Notification sent by an application to prompt messaging
00519                                                   //      apps registered for this notification to broadcast their
00520                                                   //      new/unread message counts.  The details parameter is
00521                                                   //      PmGetMsgCountNotifyParamType (defined in DefaultHelperLibTypes.h).
00522
00523 #define pmNotifyBroadcastNewMsgCount      'bMgC'  // Yes: Notification sent by an application in response to
00524                                                   //      a pmNotifyGetNewMsgCountFromHelper notification.
00525                                                   //      The details parameter is PmBroadcastNewMsgCountNotifyParamType
00526                                                   //       (defined in DefaultHelperLibTypes.h).
00527
00528 #define pmNotifyBrightModeKeyEvent        'PmBM'  // Yes: Notification sent by HsExtensions when the key event it receives
00529                                                   //      will kick the device out of dark mode and into bright mode.
00530                                                   //      HsExtensions will eat-up this key to prevent further processing
00531                                                   //      unless this notification is set as handled.
00532
00533 #define pmNotifyTraceSettingsChangedEvent (hsFileCTraceViewer)
00534                                                   // Yes: Notification sent by Trace Viewer app (or another client that
00535                                                   //      changes trace settings) to let interested parties know
00536                                                   //      that trace settings *may* have changed.  No parameter
00537                                                   //      is presently defined, so notification detailsP will
00538                                                   //      be NULL for now, but may be non-NULL in the future.
00539
00540 //................................................................
00541 // System Resource types and IDs
00542 //................................................................
00543 #define hsRscTKbdChrLookupData          'HsKb'    // Yes: type of a HEX resource that is a table
00544                                                   //      used by the keyboard driver for looking up the
00545                                                   //      character and modifier of a key.
00546
00547 // Note: These resource ID's have changed for OS5 based products
00548 // since there is now a 'shift' table in addition to the normal
00549 // and 'option' tables, and there are minor differences in the
00550 // definition of the data.
00551
00552 //#define hsRscKbdChrDataID             1000
00553 //#define hsRscKbdChrOptDataID          1001
00554
00555 #define hsRscKbdChrDataID               2000      // ID of resource containing regular character lookup
00556                                                   //  table
00557
00558 #define hsRscKbdChrShiftDataID          2001      // ID of resource containing shift character lookup
00559                                                   //  table
00560
00561 #define hsRscKbdChrOptDataID            2002      // ID of resource containing option character lookup
00562                                                   //  table
00563
00564
00565 #define hsRscTKbdKeyCodeLookupData      'HsKc'    // Yes: type of a HEX resource that is a table
00566                                                   //      used by the keyboard driver for looking up the
00567                                                   //      keyCode of a key.
00568 #define hsRscKbdKeyCodeDataID           2000      // ID of resource containing keyCodes
00569
00570 // OptLock resources are depricated... now there's logic to exclude
00571 // command keys from being generated from opt-lock
00572 //#define   hsRscTOptLockKeys               'HsLk'    // Yes: type of a HEX resource that specifies which
00573                                                   //  keys are affected by option lock state
00574
00575 //#define hsRscOptLockKeysID                1000      // ID of resource that specifies which keys respect
00576                                                   //  option lock
00577
00578 //#define hsRscOptLockKeysExt1ID            1001      // ID of resource that specifies which keys of 1st
00579                                                   //  extension group respect option lock
00580
00581 //#define hsRscOptLockKeysExt2ID            1002      // ID of resource that specifies which keys of 2nd
00582                                                   //  extension group respect option lock
00583
00584 #define hsRscTPostProcessLists          'HsPp'    // Yes: type of a HEX resource that defines lists
00585                                                   //      used by a post-processing mechanism to
00586                                                   //      convert an entered character into a related
00587                                                   //      character or string.
00588
00589 //#define hsRscPostProcessList          19000     // Using a Palm reserved ID (an ID > 10000) to prevent
00590                                                   //  resource conflicts.  Since we've registered
00591                                                   //  the HsPp id with Palm, we should not have resource
00592                                                   //  conflicts with Palm.
00593                                                   //  OBSOLETE: Now that we have a reserved handspring
00594                                                   //  range, using number in this range (defined in
00595                                                   //  HsResourceIDs.h)
00596
00597 //#define hsRscTWordCorrectionData      'HsWc'    // Yes: type of a HEX resource that defines the words
00598                                                   //      used by the word correction feature.
00599                                                   //      OBSOLETE: using string list instead
00600
00601 //#define hsRscWordCorrectionDataID     19000     // Using a Palm reserved ID (an ID > 10000) to prevent
00602                                                   //  resource conflicts.  Since we've registered
00603                                                   //  the HsWc id with Palm, we should not have resource
00604                                                   //  conflicts with Palm.
00605                                                   //  OBSOLETE: Now that we have a reserved handspring
00606                                                   //  range, using number in this range (defined in
00607                                                   //  HsResourceIDs.h)
00608
00609 //#define hsRscTButtonMappingData       'HsBm'    // Yes: type of a HEX resource that defines the strings
00610                                                   //  used to map keyboard buttons to UI buttons.  This
00611                                                   //  OBSOLETE: using string list instead
00612
00613 #define hsRscTNavFocusColor             'HsFc'    // Yes: type of a HEX resource that defines the focus
00614                                                   //  border colors.
00615
00616 #define hsRscTutorial             'HsTM'
00617
00618 #if 0 // DOLATER... THESE ARE LEGACY DEFINITIONS THAT NO LONGER MAKE SENSE IN PALM OS 5.X. DELETE ONCE
00619       // BUILD IS VERIFIED.
00620
00621 // Note: The following must match the types/IDs in the HAL makefile
00622
00623 #define hsRscTHalDriver                 'HwDv'    // N/A: type of code resource containing a Hal driver
00624
00625 #define hsRscFirstHalDriverID           19001     // The ID at which HAL starts loading sequentially
00626                                                   //  numbered drivers
00627
00628 #define hsRscHalKbdDriverID             19001     // Using a Palm reserved ID (an ID > 10000) which
00629                                                   //  sequentially follows the main HAL boot resource.
00630
00631 #define hsRscTHsExPatchModule           'HsPt'    // Yes: type of code resource containing HsExtensions
00632                                                   //  patch. Deliberately the same as hsFileTHandspringPatch
00633
00634 #define hsRscFirstHsExModuleID          19000     // Using a Palm reserved ID (an ID > 10000) which
00635                                                   //  sequentially follows the main HAL boot resource.
00636
00637 #endif
00638
00639 //................................................................
00640 // 3rd party applications
00641 //................................................................
00642 // These are external applications that are included in the ROM.  They are not written or
00643 // compiled internally, but are included here so they can be referenced by internal
00644 // applications/libraries.
00645
00646 #define exFileCArcSoftCamera            'CmLo'    // The ArcSoft Camera application
00647
00648 #define exFileCArcSoftMedia             'Foto'    // The ArcSoft Media viewer application
00649
00650 /**
00651  * @name facebook Creator IDs
00652  */
00653 /*@{*/
00654 #define hsFileCFacebook                     'FcBk'    // Yes : Facebook core application
00655 #define hsFileCFacebookStub68k              'Fc68'    // Yes : Facebook 68k stub app for calling 68k libraries that do UI
00656 #define hsFileCFacebookHomeView             'PmFh'    // Yes : Facebook Home view
00657 #define hsFileCFacebookPhotosView           'PmFp'    // Yes : Facebook Photos view
00658 #define hsFileCFacebookContactsView         'PmFc'    // Yes : Facebook Contacts view
00659 #define hsFileCFacebookMeView               'PmFm'    // Yes : Facebook Me view
00660 #define hsFileCFacebookMessageView          'PmFM'    // Yes : Facebook Message view
00661 #define hsFileCFacebookTips                 'FbTp'    // Yes : Facebook Tips
00662
00663 /*@}*/
00664
00665 //................................................................
00666 // ATTENTION:
00667 // ARM Module IDs are now located in Incs/Handspring/ARM/System/Prv
00668 //................................................................
00669
00670 #endif    // __HS_CREATORS_H__ -- include once
00671
00672
00673
00674
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:53 2008 for Palm API Guide


Header Files » Incs » common » system

HsErrorClasses.h

Go to the documentation of this file.
00001 /******************************************************************************
00002  * Copyright (c) 2004 PalmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  *****************************************************************************/
00005
00006 /**
00007  * @file    HsErrorClasses.h
00008  * @version 1.0
00009  * @date    06/17/1999
00010  * @author  Vitaly Kruglikov
00011  *
00012  *  Public header file for the error classes used by Handspring
00013  *  viewer modules.
00014  *
00015  * <hr>
00016  */
00017
00018 #ifndef   __HS_ERROR_CLASSES_H__
00019 #define   __HS_ERROR_CLASSES_H__
00020
00021
00022 #include <SystemMgr.h>    // for appErrorClass
00023
00024
00025 /************************************************************
00026  * Error Classes for each manager
00027  *************************************************************/
00028
00029 // IMPORTANT!!!: DON'T DEFINE ERROR CODES BASED ON appErrorClass BELOW
00030 // SINCE THEY COLLIDE WITH APPLICATION-DEFINED ERROR CODE NUMBER SPACE.
00031 // IN PARTICULAR, SINCE OUR SYSTEM CODE RUNS IN THE SAME CONTEXT
00032 // AS APPLICATION CODE, THESE COLLISIONS CAN RESULT IN THE WRONG ERROR
00033 // STRING BEING REPORTED TO THE USER WHEN OUR ERROR STRING TABLE ID
00034 // COLLIDES WITH THE APP'S.  Base your system error code on OEM Error
00035 // Classes instead (see below).
00036
00037 #define hsAppErrorClass     appErrorClass               // For top-level applications
00038 #define hsFfsErrorClass     (appErrorClass | 0x0100)    // Flash file system manager
00039 #define hsFlmErrorClass     (appErrorClass | 0x0200)    // Flash manager
00040 #define hsFlashErrorClass   (appErrorClass | 0x0300)    // Flash driver
00041 #define hsFttErrorClass     (appErrorClass | 0x0400)    // File Transfer Transport driver
00042                                                         //  (used by the File Installer app)
00043 #define hsFtcErrorClass     (appErrorClass | 0x0500)    // File Transfer Command driver
00044                                                         //  (used by the File Installer app)
00045
00046 #define hsTasLibErrorClass  (appErrorClass | 0x0600)    // Task manager.
00047
00048 #define hsHwmErrorClass     (appErrorClass | 0x0800)    // Phone HAL
00049
00050 #define hsSrmExtErrorClass  (appErrorClass | 0x0A00)    // Srm Extensions
00051 #define hsSTEErrorClass     (appErrorClass | 0x0C00)    // Smart Text Engine
00052
00053 // IMPORTANT: SEE IMPORTANT COMMENT ABOVE!!!
00054
00055
00056 /************************************************************
00057  * OEM Error Classes
00058  *************************************************************/
00059
00060 // IMPORTANT: THERE ARE *VERY FEW* OEM ERROR CLASSES RESERVED BY THE SYSTEM,
00061 // SO USE THEM VERY CAREFULLY. IF YOUR ERROR CODES WILL NOT BE SEEN
00062 // BY THE SYSTEM OUTSIDE YOUR CONTROL, CONSIDER USEING SOME OTHER ERROR
00063 // BASE.  THE RESERVED RANGE IS 0x7000 - 0x7F00 -- ONLY 16 ERROR CLASSES
00064 // ARE RESERVED. CONSIDER SHARING AN ERROR CLASS AMONG RELATED MODULES.
00065
00066 #define hsOEMErrorClass             oemErrorClass
00067
00068 #define hsOEMRadioErrorClass        (hsOEMErrorClass)   // Radio Errors
00069
00070 // NetMaster library error class
00071 #define hsNetMasterErrorClass       (hsOEMErrorClass + 0x0100)  // 0x7100
00072
00073 // NetPref library error class
00074 #define hsNetPrefLibErrorClass      (hsOEMErrorClass + 0x0200)  // 0x7200
00075
00076 // Handspring Phone Library error class #2.  We ran out of error codes
00077 // in error class #1 (hsPhoneLibErrorClass_1), so we are reserving a
00078 // second error class for the Phone Library.
00079 #define hsPhoneLibErrorClass_2      (hsOEMErrorClass + 0x0300)  // 0x7300
00080
00081 // Used by the ComChannel Provder. Which is the compoennt that controls the CDMA
00082 // and GSM radios
00083 #define hsCcpErrorClass             (hsOEMErrorClass + 0x0400)  // 0x7400
00084
00085 // Handspring Sound Extensions Library class
00086 #define hsSoundLibErrorClass        (hsOEMErrorClass + 0x0500)  // 0x7500
00087
00088
00089 // Used by Handspring Extensions error codes defined in HsExtCommon.h.
00090 #define hsExtErrorClass             (hsOEMErrorClass + 0x0600)  // 0x7600
00091
00092 // Message Store
00093 #define hsMSLErrorClass             (hsOEMErrorClass + 0x0700)  // 0x7700
00094
00095 // Errors in portable Pm libraries (shared between PmKeyLib, PmSysGadgetLib,
00096 //  PmUIUtilLib, and PmSystemLib)
00097 #define pmLibErrorClass             (hsOEMErrorClass + 0x0800)  // 0x7800
00098
00099
00100 /************************************************************
00101  * Error Class Exceptions
00102  *************************************************************/
00103
00104 // Handspring Phone Library error class #1.  See allso hsPhoneLibErrorClass_2
00105 // for Phone Library error class #2.
00106 // A long time ago, Handspring accidentally used 0x4000 as the error base
00107 // for its Phone Library.  PalmSource reserved this error class for
00108 // Handspring per message from Bob Petersen dated
00109 // Friday, June 06, 2003 11:51 AM (RE: Question following up on LICINFO00574).
00110 //
00111 #define hsPhoneLibErrorClass_1      (0x4000)
00112
00113
00114 // IMPORTANT: THE ERROR CLASSES ABOVE MUST BE LESS THAN 0x7F00!!!
00115
00116
00117 #endif    // __HS_ERROR_CLASSES_H__ -- include once
00118
00119
00120
00121
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:53 2008 for Palm API Guide


Header Files » Incs » common » system

HsErrors.h

Go to the documentation of this file.
00001 /** @ingroup System
00002  *
00003  */
00004 /**
00005  * @file HsErrors.h
00006  * Errors that are not part of any particular component but can be returned by
00007  * many different system components.
00008  *
00009  * \license
00010  *
00011  *    Copyright (c) 2002 Handspring Inc., All Rights Reserved
00012  *
00013  * \author Kiran Prasad
00014  *
00015  * $Id: //device/handheld/dev/sdk/2.2.2/incs/common/system/HsErrors.h#1 $
00016  *
00017  *****************************************************************************/
00018
00019 #ifndef __HS_ERRORS_H__
00020 #define __HS_ERRORS_H__
00021
00022
00023 #if 0
00024 #pragma mark -------- Radio Errors --------
00025 #endif
00026 /**
00027  * The radio is currently off and you can not perform the action requested.
00028  **/
00029 #define hsErrRadioOff                     (hsOEMRadioErrorClass | 0x01)
00030
00031 /**
00032  * The radio is currently not registered and you can not perform the action
00033  * reuqested.
00034  **/
00035 #define hsErrRadioNotRegistered           (hsOEMRadioErrorClass | 0x02)
00036
00037 /**
00038  * The radio is currently on an active voice call and so your request can not be
00039  * handled.
00040  **/
00041 #define hsErrVoiceCallActive              (hsOEMRadioErrorClass | 0x03)
00042
00043 /**
00044  * For GSM Radio Only,
00045  *   Your SIM is not ready to perform this action. This can either mean there is
00046  *   no SIM or it is not fully read yet.
00047  **/
00048 #define hsErrSimNotReady                  (hsOEMRadioErrorClass | 0x04)
00049
00050 /**
00051  * Your Radio is currently locked and therefore we can perform the action
00052  * requested.
00053  **/
00054 #define hsErrPhoneLocked                  (hsOEMRadioErrorClass | 0x05)
00055
00056 /**
00057  * Phone is not activated.
00058  **/
00059 #define hsErrPhoneNotActivated            (hsOEMRadioErrorClass | 0x06)
00060
00061 #endif
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:53 2008 for Palm API Guide


Header Files » Incs » 68k » system

HsExgMgr.h

Go to the documentation of this file.
00001 /******************************************************************************
00002  * Copyright (c) 2004 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  *****************************************************************************/
00005 /**
00006  *
00007  * @ingroup SystemDef
00008  *
00009  */
00010
00011 /**
00012  * @file    HsExgMgr.h
00013  * @version
00014  * @date
00015  *
00016  * @brief   Extensions to the Exchange Manager.
00017  *
00018  *      These functions are not currently supported by Palm, but the plan to
00019  *      in future releases. They gave us these functions in sample code, and
00020  *      we are moving into the system for OS 5 products so applications can
00021  *      take advantage of them.
00022  *
00023  */
00024
00025 /**
00026  * @author   Arun Mathias
00027  *
00028  * <hr>
00029  */
00030
00031
00032
00033 #ifndef HS_EXG_MGR__H
00034 #define HS_EXG_MGR__H
00035
00036
00037 #include "HsExt.h"
00038
00039 /**
00040  *  @brief
00041  *
00042  *  @param id:  IN:
00043  *  @param *dataTypeP:  IN:
00044  *  @param *targetP:    IN:
00045  *  @retval
00046  **/
00047 Err HsExtExgSelectTarget( UInt16 id, const Char *dataTypeP, UInt32 *targetP)
00048                 SYS_SEL_TRAP (sysTrapHsSelector, hsSelExgSelectTarget);
00049
00050 /**
00051  *  @brief
00052  *
00053  *  @param exgSocketP:  IN:
00054  *  @retval
00055  **/
00056 Err HsExtExgLocalAccept(ExgSocketPtr exgSocketP)
00057                 SYS_SEL_TRAP (sysTrapHsSelector, hsSelExgLocalAccept);
00058
00059 /**
00060  *  @brief
00061  *
00062  *  @param exgSocketP:  IN:
00063  *  @param err:     IN:
00064  *  @retval
00065  **/
00066 Err HsExtExgLocalDisconnect(ExgSocketPtr exgSocketP, Err err)
00067                 SYS_SEL_TRAP (sysTrapHsSelector, hsSelExgLocalDisconnect);
00068 #endif
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:53 2008 for Palm API Guide


Header Files » Incs » common » system

HsExgMgrCommon.h

Go to the documentation of this file.
00001 /**
00002  * \file HsExgMgrCommon.h
00003  *
00004  * Extensions to the Exchange Manager.
00005  *
00006  * These defines are not currently supported by Palm, but the plan to
00007  * in future releases. They gave us these in sample code, and
00008  * we are moving into the system for OS 5 products so applications can
00009  * take advantage of them.
00010  *
00011  * \license
00012  *
00013  *    Copyright (c) 2002 Handspring Inc., All Rights Reserved
00014  *
00015  * \author Arun Mathias
00016  *
00017  */
00018
00019 #ifndef HS_EXG_MGR_COMMON__H
00020 #define HS_EXG_MGR_COMMON__H
00021
00022 #define hsExgGetScheme              "_get"  // special scheme for supporting get
00023
00024
00025
00026 #endif
00027
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:53 2008 for Palm API Guide


Header Files » Incs » 68k » system

HsExt.h

Go to the documentation of this file.
00001 /******************************************************************************
00002  * Copyright (c) 2005 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  *****************************************************************************/
00005 /**
00006  *
00007  * @ingroup HSExt
00008  *
00009  */
00010
00011 /**
00012  * @file    HsExt.h
00013  * @brief   Header file that 68K programs include to access
00014  *      Handspring Extensions functionality.
00015  *
00016  *
00017  */
00018
00019
00020
00021 #ifndef   __HS_EXT_68K_H__
00022 #define   __HS_EXT_68K_H__
00023
00024 // Most of the definitions for HsExtensions are now in HsExtCommon.h so that
00025 // they can be shared by both 68K and ARM programs...
00026 #include <HsExtCommon.h>
00027 #include <Common/System/HsCreators.h>
00028 #include <HsNavCommon.h>
00029 #include <HsExtTraps.h>
00030
00031 #if (!(defined NO_HSEXT_TRAPS)) && (defined __GNUC__) && (EMULATION_LEVEL == EMULATION_NONE)
00032   #if __GNUC__ > 2 || (__GNUC__ == 2 && __GNUC_MINOR__ >= 95)
00033
00034     #ifndef _Str
00035     #define _Str(X)  #X
00036     #endif
00037
00038     #define _HS_OS_CALL_WITH_UNPOPPED_16BIT_SELECTOR(table, vector, selector)   \
00039         __attribute__ ((__callseq__ (                                       \
00040             "move.w #" _Str(selector) ",-(%%sp); "                          \
00041             "trap #" _Str(table) "; dc.w " _Str(vector))))
00042
00043     #define SYS_SEL_TRAP(trapNum, selector) \
00044         _HS_OS_CALL_WITH_UNPOPPED_16BIT_SELECTOR(sysDispatchTrapNum, trapNum, selector)
00045
00046
00047   #else // GNUC < 2.95
00048
00049     #define SYS_SEL_TRAP(trapNum, selector) \
00050         __attribute__ ((inline (0x3f3c, selector, m68kTrapInstr+sysDispatchTrapNum,trapNum)))
00051
00052   #endif // GNUC < 2.95
00053
00054 #elif (!(defined NO_HSEXT_TRAPS)) && (defined (__MWERKS__))
00055
00056     #define SYS_SEL_TRAP(trapNum, selector) \
00057         = {0x3f3c, selector, m68kTrapInstr+sysDispatchTrapNum,trapNum}
00058
00059 #else
00060     #define SYS_SEL_TRAP(trapNum, selector)
00061
00062 #endif
00063
00064 /**
00065  *  @brief
00066  *
00067  *  @param appCardNo:   IN:
00068  *  @param appDbId: IN:
00069  *  @param copyrightYearStrP:   IN:
00070  *  @param extraCreditsStrP:    IN:
00071  *  @retval Error code.
00072  **/
00073 void
00074 HsAboutHandspringApp (UInt16 appCardNo, LocalID appDbId,
00075                       Char* copyrightYearStrP, Char* extraCreditsStrP)
00076                 SYS_SEL_TRAP (sysTrapHsSelector, hsSelAboutHandspringApp);
00077
00078 //ported from HsExt.h from the Visor-4.0 tree - VSB
00079 // <chg 30-Jun-99 dia> Defined macros to make about box easier to call.
00080 #define HsAboutHandspringAppWithYearId(yearId)                              \
00081     do                                                                      \
00082       {                                                                     \
00083         UInt16  appCardNo;                                                  \
00084         LocalID appDbId;                                                    \
00085         MemHandle   yearStrH;                                               \
00086         Char*   yearStrP;                                                   \
00087                                                                             \
00088         yearStrH = DmGetResource (strRsc, yearId);                          \
00089         yearStrP = MemHandleLock (yearStrH);                                \
00090         SysCurAppDatabase(&appCardNo, &appDbId);                            \
00091         HsAboutHandspringApp (appCardNo, appDbId, yearStrP, NULL);          \
00092         MemPtrUnlock (yearStrP);                                            \
00093         DmReleaseResource (yearStrH);                                       \
00094       }                                                                     \
00095     while (0)
00096
00097 #define HsAboutHandspringAppWithYearCredId(yearId, creditsId)               \
00098     do                                                                      \
00099       {                                                                     \
00100         UInt16  appCardNo;                                                  \
00101         LocalID appDbId;                                                    \
00102         MemHandle   yearStrH, extraStrH;                                    \
00103         Char*   yearStrP;                                                   \
00104         Char*   extraStrP;                                                  \
00105                                                                             \
00106         yearStrH = DmGetResource (strRsc, yearId);                          \
00107         yearStrP = MemHandleLock (yearStrH);                                \
00108         extraStrH = DmGetResource (strRsc, creditsId);                      \
00109         extraStrP = MemHandleLock (extraStrH);                              \
00110         SysCurAppDatabase(&appCardNo, &appDbId);                            \
00111         HsAboutHandspringApp (appCardNo, appDbId, yearStrP, extraStrP);     \
00112         MemPtrUnlock (extraStrP);                                           \
00113         DmReleaseResource (extraStrH);                                      \
00114         MemPtrUnlock (yearStrP);                                            \
00115         DmReleaseResource (yearStrH);                                       \
00116       }                                                                     \
00117     while (0)
00118
00119 #ifdef __cplusplus
00120 extern "C" {
00121 #endif
00122
00123 /**
00124  *  @brief Retrieve a null terminated version string.
00125  *
00126  *  @param selector:    IN:  Selects which version string to get
00127  *  @param outStrP: IN:  Buffer to receive the NULL terminated version string. The buffer should be
00128  *               large enough to hold hsVersionStringSize bytes
00129  *  @param sizeP:   IN:  If not NULL, returns the number of bytes stored in *outStrP, including the
00130  *               NULL terminator
00131  *  @retval 0 if no error, hsErrNotSupported if error occurs
00132  **/
00133 Err
00134 HsGetVersionString (UInt16 /*HsVerStrEnum*/selector, Char* outStrP,
00135                     UInt16* sizeP)
00136                 SYS_SEL_TRAP (sysTrapHsSelector, hsSelGetVersionString);
00137
00138 /**
00139  *  @brief Get any Handspring specific attributes that aren’t appropriate to be accessed
00140  *         through a feature. (e.g., dynamic information about device state) @see HsAttrEnum
00141  *
00142  *  @param attr:    IN:  Which attribute is being retrieved. Most attributes are defined in
00143  *               “HsExtCommon.h” in the HsAttrEnum enumeration.
00144  *  @param param:   IN:  Meaning depends on ’attr’ (currently implemented attributes only take 0 for
00145  *               this argument).
00146  *  @param valueP:  IN:  Cast depending on attr (refer HsAttrEnum for data type this argument should
00147  *                           point to).
00148  *  @retval Err 0 if no error
00149  **/
00150 Err
00151 HsAttrGet (UInt16 attr /*HsAttrEnum*/, UInt32 param, UInt32* valueP)
00152                 SYS_SEL_TRAP (sysTrapHsSelector, hsSelAttrGet);
00153
00154 /**
00155  *  @brief Set Handspring specific attributes. @see HsAttrEnum
00156  *
00157  *  @param attr:    IN:  Which attribute is being set.
00158  *  @param param:   IN:  Meaning depends on ’attr’ (currently implemented attributes only take 0 for
00159  *                   this argument).
00160  *  @param valueP:  IN:  Cast depending on attr (refer HsAttrEnum for data type this argument should
00161  *               point to).
00162  *  @retval Err 0 if no error hsErrNotSupported otherwise.
00163  **/
00164 Err
00165 HsAttrSet (UInt16 attr /*HsAttrEnum*/, UInt32 param, UInt32* valueP)
00166                 SYS_SEL_TRAP (sysTrapHsSelector, hsSelAttrSet);
00167
00168 /**
00169  *  @brief HsExtensions maintains and utilizes a set of preferences that are not a part of the
00170  *     Palm OS system preferences. They can be retrieved using this function. @see HsPrefEnum
00171  *
00172  *  @param pref:    IN:  IN which preference to retrieve (refer HsPrefEnum)
00173  *  @param bufP:    IN:  IN buffer to store preference (refer HsPrefEnum for the size of the buffer needed).
00174  *  @param prefSizeP:   IN:  IN/OUT on entry, size of bufP on exit, size of stored pref. If larger than size of
00175  *               bufP, then hsErrBufferTooSmall is returned.
00176  *  @retval Err 0 if no err
00177  *          hsErrInvalidParam if pref is invalid
00178  *          hsErrBufferTooSmall if *prefSizeP was smaller than actual pref
00179  **/
00180 Err
00181 HsPrefGet (UInt16 pref /*HsPrefEnum*/, void* bufP,
00182                     UInt32* prefSizeP)
00183                 SYS_SEL_TRAP (sysTrapHsSelector, hsSelPrefGet);
00184
00185 /**
00186  *  @brief HsExtensions maintains and utilizes a set of preferences that are not a part of the
00187  *     Palm OS system preferences. They can be set using this function. @see HsPrefEnum
00188  *
00189  *  @param pref:    IN:  which pref to retrieve, a HsPrefEnum
00190  *  @param bufP:    IN:  buffer to store pref
00191  *  @param prefSize:    IN:  size of pref to store
00192  *  @retval Err 0 if no err
00193  *              hsErrInvalidParam if pref is invalid
00194  **/
00195 Err
00196 HsPrefSet (UInt16 pref /*HsPrefEnum*/, void* bufP,
00197                     UInt32 prefSize)
00198                 SYS_SEL_TRAP (sysTrapHsSelector, hsSelPrefSet);
00199
00200 /**
00201  *  @brief Function that gets the reference number to the phone library. It decides whether it
00202  *     should return the GSM or the CDMA library based on the type of device. If the
00203  *     library is not loaded, it loads the library.
00204  *
00205  *  @param refNum:  IN:  Library reference number to be used in other function.
00206  *  @retval Err 0 if no error.
00207  **/
00208 Err
00209 HsGetPhoneLibrary (UInt16 * refNum)
00210                 SYS_SEL_TRAP (sysTrapHsSelector, hsSelGetPhoneLibrary);
00211
00212 /**
00213  *  @brief Tell the system that a gadget on the form is a certain type of status gadget so that
00214  *     the system can properly draw and update it.
00215  *
00216  *  Tell the system that a gadget on the form is a certain type of status gadget so that
00217  *  the system can properly draw and update it.
00218  *  A form can only have one gadget for each status type. If more than one gadget is
00219  *  set to a certain type, only the last one set will be recorded. This function can also be
00220  *  used to erase and release a gadget whose type has already been set. To do this, type
00221  *  should be set to 0.
00222  *
00223  *  NOTE The gadget dimensions in the current implementation are hardcoded to
00224  *  values of 10 X 12 pixels for the battery gadget and 16 X 12 pixels for signal gadget.
00225  *  Scaling is not supported, so define your gadget resources accordingly.
00226  *
00227  *  @param frmP:    IN:  pointer to the form with the gadget (we will convert to an ID before saving but
00228  *               want a ptr to be passed as a param to ensure that the caller is setting the gadget
00229  *               for a loaded form)
00230  *  @param gadgetID:    IN:  id of the gadget whose type is being specified
00231  *  @param type:    IN:  type of the gadget (pass a member of HsStatusGadgetTypeEnum—defined in
00232  *                   HsExt.h or 0 to erase and release a gadget)
00233  *  @retval Err 0 if no error.
00234  **/
00235 Err
00236 HsStatusSetGadgetType (void* frmP, UInt16 gadgetID,
00237                                    UInt16 type /*HsStatusGadgetTypeEnum*/)
00238                 SYS_SEL_TRAP (sysTrapHsSelector, hsSelStatusSetGadgetType);
00239
00240 /**
00241  *  @brief Explicitly update all status gadgets on the current form.
00242  *
00243  **/
00244 void
00245 HsStatusUpdateGadgets (void)
00246                 SYS_SEL_TRAP (sysTrapHsSelector, hsSelStatusUpdateGadgets);
00247
00248 /**
00249  *  @brief Extended version of GrfSetState to allow setting an option and option lock state.
00250  *
00251  *  The original GrfSetState does not have an autoShift parameter because it always
00252  *  assumed that anyone setting the shift state through the API call wanted an
00253  *  automatic shift. We do not make this assumption.
00254  *  The shift state can be set by calling either HsGrfSetStateExt() or GrfSetState().
00255  *  Either way, we have to make sure that both the keyboard shift state and the Graffiti
00256  *  engine’s shift state get set correctly.
00257  *
00258  *  @param capsLock:    IN:  Set to turn caps lock on
00259  *  @param numLock: IN:  Set to true to turn num lock on
00260  *  @param optLock: IN:  Set to true to turn option lock on
00261  *  @param upperShift:  IN:  Set to true to put into upper shift
00262  *  @param optShift:    IN:  Set to true to put into option shift
00263  *  @param autoShift:   IN:  Valid only if upperShift is true. Set to true if the graffiti engine should consider
00264  *               the upper shift an auto shift.
00265  *  @retval Err Always returns 0.
00266  **/
00267 Err
00268 HsGrfSetStateExt (Boolean capsLock, Boolean numLock, Boolean optLock,
00269                   Boolean upperShift, Boolean optShift, Boolean autoShift)
00270                 SYS_SEL_TRAP (sysTrapHsSelector, hsSelGrfSetStateExt);
00271
00272 /**
00273  *  @brief Extended version of GrfGetState to include detection of option and option lock state.
00274  *
00275  *  @param capsLockP:   IN:  returns true if caps lock on
00276  *  @param numLockP:    IN:  returns true if num lock on
00277  *  @param optLockP:    IN:  returns true if opt lock on
00278  *  @param tempShiftP:  IN:  returns current temporary shift
00279  *  @param autoShiftedP:    IN:  returns TRUE if shift not set by the user but by the system, for example, at the
00280  *                   beginning of a line.
00281  *  @retval Err Always returns 0.
00282  **/
00283 Err
00284 HsGrfGetStateExt (Boolean* capsLockP, Boolean* numLockP, Boolean* optLockP,
00285                   UInt16* tempShiftP, Boolean* autoShiftedP)
00286                 SYS_SEL_TRAP (sysTrapHsSelector, hsSelGrfGetStateExt);
00287
00288 /**
00289  *  @brief Places a UI object to the right of the form title. This function is useful for adjusting
00290  *     object positions for localized titles.
00291  *
00292  *  @param voidFrmP:    IN:  ptr to form containing the object
00293  *  @param objID:   IN:  id of the object being positioned
00294  *  @param titleOffset: IN:  number of pixels between title bar and status gadget
00295  *  @retval Boolean True if the object was moved from it’s original position.
00296  *          False otherwise
00297  **/
00298 Boolean HsPutObjectAfterTitle (void* voidFrmP, UInt16 objID, UInt8 titleOffset)
00299                 SYS_SEL_TRAP (sysTrapHsSelector, hsSelPutObjectAfterTitle);
00300
00301
00302 //HsInfo, HsEvtMetaEvent and HsSpringboardNotSupported are nop functions that are
00303 //included for backwards compatibility
00304 /**
00305  *  @brief This call will return info on a particular attribute of the Handspring extensions.
00306  *
00307  *  This call is designed to return info that won’t fit into a Palm OS feature call (a
00308  *  UInt32).
00309  *
00310  *  @param item:    IN:  which info to return
00311  *  @param paramSize:   IN:  size of paramP block passed in
00312  *  @param paramP:  IN:  info is returned here
00313  *  @retval UInt32 0 if no error
00314  **/
00315 UInt32
00316 HsInfo (UInt16 item, UInt16 paramSize,  void* paramP)
00317                 SYS_SEL_TRAP (sysTrapHsSelector, hsSelInfo);
00318
00319 /**
00320  *  @brief
00321  *
00322  *  @param eventP:  IN:
00323  *  @retval UInt16 Error code.
00324  **/
00325 UInt16
00326 HsEvtMetaEvent (EventPtr eventP)
00327                 SYS_SEL_TRAP (sysTrapHsSelector, hsSelEvtMetaEvent);
00328
00329 /**
00330  *  @brief Used to determine if the device supports the Springboard expansion slot or not.
00331  *
00332  *  On springboard devices, this function is unimplemented. To determine whether
00333  *  the device has a Springboard extension slot or not, use HsGetTrapAddress() to
00334  *  obtain the trap addresses of this function and HsUnimplemented. If they are equal,
00335  *  the device has the Springboard extension slot, otherwise it doesn’t.
00336  *
00337  *  @retval Err All of the Springboard functions return an error on the Treo 600.
00338  **/
00339 Err
00340 HsSpringboardNotSupported (void)
00341                 SYS_SEL_TRAP (sysTrapHsSelector, hsSelSpringboardNotSupported);
00342
00343 /**
00344  *  @brief Works like SysGetTrapAddress, but for Handspring trap numbers.
00345  *
00346  *  For every HsExt function implemented in ARM native, there exists a wrapper 68K
00347  *  function that simply calls the HsExt function in question. This may seem
00348  *  roundabout, but HsGetTrapAddress is retained for backward compatibility.
00349  *
00350  *  @param trapNum: IN:  the address of the trap handler for the given selector.
00351  *  @retval void* If the selector is invalid, returns the address of HsUnimplemented().
00352  **/
00353 void*
00354 HsGetTrapAddress (UInt16 trapNum)
00355                 SYS_SEL_TRAP (sysTrapHsSelector, hsSelHsGetTrapAddress);
00356
00357 // Disconnects all open NetLib connections.  ***IMPORTANT*** This function MUST
00358 //  be called only from the context of the UI task!
00359 /**
00360  *  @brief This function will completely close the currently active TCP/IP network
00361  *     connection. The open count will be 0 after this call is made.
00362  *
00363  *  @retval Err 0 if successful.
00364  **/
00365 Err
00366 HsNetworkDropConnection (void)
00367                 SYS_SEL_TRAP (sysTrapHsSelector, hsSelNetworkDropConnection);
00368
00369
00370 //will display a fatal error message since this trap number will not be handled by
00371 //the trap dispatcher
00372 /**
00373  *  @brief
00374  *
00375  **/
00376 void
00377 HsUnimplemented (void)
00378                 SYS_SEL_TRAP (sysTrapHsSelector, hsSelUnimplemented);
00379
00380
00381 // Returns the pointer to the ARM form. We need this because the 68K
00382 // form might be deleted.
00383 /**
00384  *  @brief
00385  *
00386  **/
00387 void*
00388 HsGetARMActiveFormPtr (void)
00389                 SYS_SEL_TRAP (sysTrapHsSelector, hsSelGetARMActiveFormPtr);
00390
00391 /**
00392  *  @brief Allows the user to select a small or a large font size.
00393  *
00394  *  This is just like the Palm OS routine FontSelect, except it gives the user a choice of
00395  *  only a small and a large font. If the originalFont is not bold, then the two choices
00396  *  are stdFont and largeFont. If the original choice is bold, then the two choices are
00397  *  boldFont and largeBoldFont.
00398  *
00399  *  @param originalFont:    IN:  The original font ID (used to select the current font).
00400  *  @retval FontID The new font ID.
00401  **/
00402 FontID
00403 HsTwoFontSelect(FontID originalFont)
00404                 SYS_SEL_TRAP (sysTrapHsSelector, hsSelTwoFontSelect);
00405
00406 /**
00407  *  @brief Opens a window with the number filled in the address text field.
00408  *
00409  *  This function can be used by any application that wants to dial a phone number,
00410  *  but first give the user the option of editing the number. This functionality
00411  *  originally existed in the STE, but was moved to the system.
00412  *
00413  *  @param numberP: IN:  A pointer to a string that contains the phone number to put into the number field.
00414  *  @param nameP:   IN:  A pointer to a string that contains the name to put into the title of the dialog.
00415  *  @param callerID:    IN:  If this is true, then we will attempt to match the phone number with an entry in
00416  *                   the address book. If a match is found, then the title of the dialog will contain the name.
00417  **/
00418 void
00419 HsOpenDialNumberDialog(char* numberP, char* nameP, Boolean callerID)
00420                 SYS_SEL_TRAP (sysTrapHsSelector, hsSelOpenDialNumberDialog);
00421
00422 /**
00423  *  @brief Turn the radio (cell phone) on if it’s off.
00424  *
00425  *  @retval Err 0 if successful.
00426  **/
00427 Err
00428 HsTurnRadioOn(void)
00429                 SYS_SEL_TRAP (sysTrapHsSelector, hsSelTurnRadioOn);
00430
00431 /**
00432  *  @brief Launches the messaging application (SMS) to the new message form with some
00433  *     fields optionally prefilled with the specified values.
00434  *
00435  *  This function can be used by any application that wants to launch the messaging
00436  *  application and have some of the fields prefilled without using the helper APIs.
00437  *
00438  *  @param addressP:    IN:  A pointer to a string that contains the phone number to put into the To: field. (optional)
00439  *  @param nameP:   IN:  A pointer to a string that contains the name to put above the To: field. (optional)
00440  *  @param msgP:    IN:  A pointer to a string that contains the message text of the new message. (optional)
00441  *  @retval Err 0 on success or the error that occurred.
00442  **/
00443 Err
00444 HsCreateNewMessage(char* addressP, char* nameP, char* msgP)
00445                 SYS_SEL_TRAP (sysTrapHsSelector, hsSelCreateNewMessage);
00446
00447
00448 /**
00449  *  @brief Launches the email application to the new email form with some fields optionally
00450  *     prefilled with the specified values.
00451  *
00452  *  This function can be used by any application that wants to launch the email
00453  *  application and have some of the fields prefilled without using the helper APIs.
00454  *
00455  *  @param addressP:    IN:  A pointer to a string that contains the address to put in the To: field.
00456  *  @param ccP:     IN:  A pointer to a string that contains the address to put in the cc: field. (optional)
00457  *  @param subjectP:    IN:  A pointer to a string that contains the subject of the new email. (optional)
00458  *  @param msgP:    IN:  A pointer to a string that contains the message text of the new email. (optional)
00459  *  @retval Err 0 on success or the error that occurred.
00460  **/
00461 Err
00462 HsCreateNewEmail(char* addressP, char* ccP, char* subjectP, char* msgP)
00463                 SYS_SEL_TRAP (sysTrapHsSelector, hsSelCreateNewEmail);
00464
00465 /**
00466  *  @brief Launches the browser to the specified URL.
00467  *
00468  *  This function can be used by any application that wants to launch the web browser
00469  *  to a specified URL without using the helper APIs.
00470  *
00471  *  @param urlP:    IN:  A pointer to a string that contains the phone number to put into the number field.
00472  *  @retval Err 0 on success or the error that occurred.
00473  **/
00474 Err
00475 HsBrowseUrl(char* urlP)
00476                 SYS_SEL_TRAP (sysTrapHsSelector, hsSelBrowseUrl);
00477
00478 /**
00479  *  @brief If a form has a system drawn focus ring, gets info about the ring
00480  *
00481  *  @param formP:   IN:  Ptr to form whose ring info is to be obtained
00482  *  @param objectIDP:   IN:  If not NULL, on exit will point to the object with the system-drawn focus ring
00483  *  @param extraInfoP:  IN:  If not NULL, on exit will point to any extra info associated with the focus ring.
00484  *               Extra info is any info that the caller wants to associate with a ring.
00485  *               hsNavFocusRingNoExtraInfo (0xFFFF) is used to represent no extra info.
00486  *  @param boundsInsideRingP:   IN:  If not NULL, on exit will point to the bounds inside the system-drawn focus ring
00487  *  @param ringStyleP:  IN:  If not NULL, on exit will point to the style of the focus ring
00488  *  @retval Err Error code.
00489  **/
00490 Err
00491 HsNavGetFocusRingInfo (const FormType* formP, UInt16* objectIDP,
00492                        Int16* extraInfoP, RectangleType* boundsInsideRingP,
00493                        HsNavFocusRingStyleEnum* ringStyleP)
00494                 SYS_SEL_TRAP (sysTrapHsSelector, hsSelNavGetFocusRingInfo);
00495 /**
00496  *  @brief Tells the system to draw a focus ring for an object
00497  *
00498  *  @param formP:   IN:  Form containing object whose ring is being drawn
00499  *  @param objectID:    IN:  ID of object getting the focus ring
00500  *  @param extraInfo:   IN:  Any info that caller wants associated with the focus ring. For example, the
00501  *               system uses this field to store the temporarily-selected item of a focused,
00502  *               embedded list. Caller should pass hsNavFocusRingNoExtraInfo (0xFFFF) if there
00503  *               is no associated info.
00504  *  @param boundsInsideRingP:   IN:  Points to the bounds around which the ring should be drawn
00505  *  @param ringStyle:   IN:  Enumeration value that represents the desired style for the ring.
00506  *               hsNavFocusRingStyleObjectTypeDefault can be passed if caller just wants the
00507  *               default ring style for the object’s type.
00508  *  @param forceRestore:    IN:  If ring is already on the object, whether to force restoration of what’s behind the
00509  *                   ring before redrawing the ring.
00510  *  @retval Err Returns errNone if no error, error code otherwise.
00511  **/
00512 Err
00513 HsNavDrawFocusRing (FormType* formP, UInt16 objectID, Int16 extraInfo,
00514                     RectangleType* boundsInsideRingP,
00515                     HsNavFocusRingStyleEnum ringStyle, Boolean forceRestore)
00516                 SYS_SEL_TRAP (sysTrapHsSelector, hsSelNavDrawFocusRing);
00517
00518 /**
00519  *  @brief Removes system-drawn ring from around currently focused object
00520  *
00521  *  @param formP:   IN:  Ptr to form containing the object with the ring
00522  *  @retval Err Returns errNone if no error, error code otherwise
00523  **/
00524 Err
00525 HsNavRemoveFocusRing (FormType* formP)
00526                 SYS_SEL_TRAP (sysTrapHsSelector, hsSelNavRemoveFocusRing);
00527
00528 /**
00529  *  @brief Sends a frmObjectFocusTake event for an object
00530  *
00531  *  @param formP:   IN:  Ptr to form that contains the object
00532  *  @param objID:   IN:  ID of the object
00533  **/
00534 void
00535 HsNavObjectTakeFocus (const FormType* formP, UInt16 objID)
00536                 SYS_SEL_TRAP (sysTrapHsSelector, hsSelNavObjectTakeFocus);
00537
00538 /**
00539  *  @brief Obtains a focus color
00540  *
00541  *  @param color:   IN:  Enumeration value that specifies which focus color to get
00542  *  @param rgbColorP:   IN:  On exit, points to the focus color
00543  **/
00544 void
00545 HsNavGetFocusColor (HsNavFocusColorEnum color, RGBColorType* rgbColorP)
00546                 SYS_SEL_TRAP (sysTrapHsSelector, hsSelNavGetFocusColor);
00547
00548 /**
00549  *  @brief Sets new focus color
00550  *
00551  *  @param color:   IN:  Enumeration value that specifies which focus color to set
00552  *  @param rgbColorP:   IN:  Points to the new color
00553  *  @param oldRgbColorP:    IN:  If not NULL, on exit it will point to the old focus color
00554  **/
00555 void
00556 HsNavSetFocusColor (HsNavFocusColorEnum color, RGBColorType* rgbColorP,
00557                     RGBColorType* oldRgbColorP)
00558                 SYS_SEL_TRAP (sysTrapHsSelector, hsSelNavSetFocusColor);
00559
00560 /**
00561  *  @brief Set or get the state of the LED or Vibrator.
00562  *
00563  *  @param count:   IN:  Count of how many times to blink or pulse the indicator, or one of the
00564  *               HsIndicatorCountEnum values to either run forever or get the current state.
00565  *  @param indicatorType:   IN:  HsIndicatorTypeEnum (LED or vibrator)
00566  *  @param stateP:  IN:  Pointer to HsIndicatorStateEnum If setting, points to state to set. If getting, as
00567  *               IN param points to “none” state of the source to query (or kIndicatorStateNull
00568  *               to query whatever source has priority). As OUT param, contains the result of
00569  *               the query (kIndicatorStateNull if querying for the active source and there is none)
00570  *  @retval Err 0 if no error
00571  **/
00572 Err
00573 HsIndicatorState (UInt16 count, UInt16 indicatorType, UInt16* stateP)
00574                 SYS_SEL_TRAP (sysTrapHsSelector, hsSelIndicatorState);
00575
00576 /**
00577  *  @brief Get or set the current mode.
00578  *
00579  *  @param set:     IN:  If true, we’ll switch to *modeP; if false we’ll put the current mode in *modeP
00580  *  @param modeP:   IN:  If we’re setting, we’ll switch to this mode (refer HsLightModeEnum). If we’re
00581  *               getting, we’ll put the current mode here.
00582  *  @retval Err An error code; 0 if no error.
00583  **/
00584 Err
00585 HsLightMode (Boolean set, UInt16* modeP)
00586                 SYS_SEL_TRAP (sysTrapHsSelector, hsSelLightMode);
00587
00588 /**
00589  *  @brief Add/remove special lighting circumstances
00590  *
00591  *  This function does reference counting on added circumstances, so be sure to not
00592  *  add a circumstance without eventually removing it (unless you intended that).
00593  *  Note that some circumstances don’t take effect until some point in time later (in
00594  *  SysHandleEvent). That’s because some circumstances only take effect when the
00595  *  device is idle for some amount of time.
00596  *
00597  *  @param add:     IN:  If true, we’re adding a circumstance, If false, we’re removing it.
00598  *  @param circumstance:    IN:  The circumstance we’re adding or taking away (refer
00599  *                       HsLightCircumstanceEnum).
00600  *  @retval Err An error code; 0 if no error
00601  **/
00602 Err
00603 HsLightCircumstance (Boolean add, UInt16 circumstance)
00604                 SYS_SEL_TRAP (sysTrapHsSelector, hsSelLightCircumstance);
00605
00606 /**
00607  *  @brief
00608  *
00609  **/
00610 UInt16 HsCurrentLightCircumstance(void)
00611                 SYS_SEL_TRAP (sysTrapHsSelector, hsGetCurrentLightCircumstance);
00612
00613 /**
00614  *  @brief Converts HsKeysPressed() results into a bitfield.
00615  *
00616  *  This function provides compatibility with earlier Handspring SDKs. The preferred
00617  *  method of querying key states is to call HsKeysPressed().
00618  *
00619  *  @param keys:    IN:  Array of three bitfields representing which keys are depressed.
00620  **/
00621 void
00622 HsKeyCurrentStateExt (UInt32 keys[3])
00623                 SYS_SEL_TRAP (sysTrapHsSelector, hsSelKeyCurrentStateExt);
00624
00625 /**
00626  *  @brief Glue to HsKeyEnabled() based on bitfields.
00627  *
00628  *  This function provides compatibility with earlier Handspring SDKs. The preferred
00629  *  method of enabling keys is to call HsKeyEnableKey().
00630  *
00631  *  @param keyMaskNew:  IN:  new enabled mask
00632  *  @param keyMaskOld:  IN:  previous enabled mask
00633  **/
00634 void
00635 HsKeySetMaskExt (const UInt32 keyMaskNew[3], UInt32 keyMaskOld[3])
00636                 SYS_SEL_TRAP (sysTrapHsSelector, hsSelKeySetMaskExt);
00637
00638 /**
00639  *  @brief Get the current state of specified keys.
00640  *
00641  *  This extends KeyCurrentState().
00642  *
00643  *  @param count:   IN:  number of elements in keyCodes[] and pressed[]
00644  *  @param keyCodes[]:  IN:  Array of keyCodes to test
00645  *  @param pressed[]:   IN:  Each element is set to true if the key specified by the corresponding element in
00646  *               keyCodes[] is pressed, and set to false if it’s not pressed. It is acceptable to pass
00647  *               NULL if only the return value is of interest.
00648  *  @retval UInt16 Count of keys in keyCodes[] that are pressed
00649  **/
00650 UInt16
00651 HsKeysPressed (UInt16 count, const UInt16 keyCodes[], Boolean pressed[])
00652                 SYS_SEL_TRAP (sysTrapHsSelector, hsSelKeysPressed);
00653
00654 /**
00655  *  @brief Stop a key from sending any more autorepeat events until it is released.
00656  *
00657  *  @param keyCode: IN:  key to stop
00658  *  @retval Err errNone if the keyCode is the last key pressed and it’s still held.
00659  **/
00660 Err
00661 HsKeyStop (UInt16 keyCode)
00662                 SYS_SEL_TRAP (sysTrapHsSelector, hsSelKeyStop);
00663
00664 /**
00665  *  @brief Enable/disable a key from generating key events.
00666  *
00667  *  @param keyCode: IN:  which key to enable/disable
00668  *  @param enabled: IN:  true to enable, false to disable
00669  *  @retval Boolean true if previously enabled.
00670  **/
00671 Boolean
00672 HsKeyEnableKey (UInt16 keyCode, Boolean enabled)
00673                 SYS_SEL_TRAP (sysTrapHsSelector, hsSelKeyEnableKey);
00674
00675 /**
00676  *  @brief Determine which key generates a certain character.
00677  *
00678  *  @param chrCode: IN:  the character to search for
00679  *  @retval UInt16 The key code.
00680  **/
00681 UInt16
00682 HsKeyChrCodeToKeyCode (UInt16 chrCode)
00683                 SYS_SEL_TRAP (sysTrapHsSelector, hsSelKeyChrCodeToKeyCode);
00684
00685 /**
00686  *  @brief Translate a key code to the character generated by that key.
00687  *
00688  *  @param keyCode: IN:  The key to lookup
00689  *  @param modifiersIn: IN:  Modifier mask indicating which character should be returned
00690  *  @param chrP:    IN:  The character produced by the key
00691  *  @param modifiersOutP:   IN:  The keyMask bits that must be set if a keyDown event is formed with the
00692  *                   character. (Not including the bits set in modifiersIn)
00693  **/
00694 void
00695 HsKeyKeyCodeToChrCode (UInt16 keyCode, UInt16 modifiersIn,
00696                        UInt16* chrP, UInt16* modifiersOutP)
00697                 SYS_SEL_TRAP (sysTrapHsSelector, hsSelKeyKeyCodeToChrCode);
00698
00699 /**
00700  *  @brief Determine if an event came from the physical keyboard.
00701  *
00702  *  @param eventP:  IN:  The event to check
00703  *  @retval Boolean True if the event came from the keyboard
00704  **/
00705 Boolean
00706 HsKeyEventIsFromKeyboard (EventPtr eventP)
00707                 SYS_SEL_TRAP (sysTrapHsSelector, hsSelKeyEventIsFromKeyboard);
00708
00709 /**
00710  *  @brief Displays a dialog to the user allowing them to confirm the saving of data, and the
00711  *     name that they wish to assign.
00712  *
00713  *  @param name:    IN:  Comes in as the default name and returns the name the user chose
00714  *  @retval Boolean True if the user confirmed that the save should take place.
00715  *      False otherwise.
00716  **/
00717 Boolean
00718 HsExtDoSaveAsDialog (Char * name)
00719                 SYS_SEL_TRAP (sysTrapHsSelector, hsSelDoSaveAsDialog);
00720
00721 /**
00722  *  @brief
00723  *
00724  *  @param inSrcP:  IN:
00725  *  @param inSrcLen:    IN:
00726  *  @param outDstP: IN:
00727  *  @param inDstSize:   IN:
00728  *  @retval UInt16
00729  **/
00730 UInt16
00731 HsTxtPrepFindString(const Char* inSrcP, UInt16 inSrcLen,
00732                         Char* outDstP, UInt16 inDstSize)
00733                 SYS_SEL_TRAP (sysTrapHsSelector, hsSelTxtPrepFindString);
00734
00735 // These are convenient multi-byte friendly text routines
00736 /**
00737  *  @brief
00738  *
00739  *  @param textP:   IN:
00740  *  @retval UInt32
00741  **/
00742 UInt32
00743 HsTxtNumChars(Char const* textP)
00744                 SYS_SEL_TRAP (sysTrapHsSelector, hsSelTxtNumChars);
00745
00746 /**
00747  *  @brief
00748  *
00749  *  @param textP:   IN:
00750  *  @param maxPixels:   IN:
00751  *  @param keepLabel:   IN:
00752  **/
00753 void
00754 HsTxtTruncateString(Char* textP, UInt16 maxPixels, Boolean keepLabel)
00755                 SYS_SEL_TRAP (sysTrapHsSelector, hsSelTxtTruncateString);
00756
00757 /**
00758  *  @brief
00759  *
00760  *  @param textP:   IN:
00761  *  @param textLen: IN:
00762  *  @retval Boolean
00763  **/
00764 Boolean
00765 HsTxtIsAscii(Char* textP, UInt16 textLen)
00766                 SYS_SEL_TRAP (sysTrapHsSelector, hsSelTxtIsAscii);
00767
00768 /**
00769  *  @brief
00770  *  @retval Boolean
00771  **/
00772 Boolean
00773 HsIsHTTPLibraryLoaded (void)
00774                 SYS_SEL_TRAP (sysTrapHsSelector, hsSelIsHTTPLibraryLoaded);
00775
00776 /**
00777  *  @brief Obtains the temporarily selected item of an embedded list
00778  *
00779  *  @param formP:   IN:  Pointer to the form containing the list whose temporary selection is to be obtained
00780  *  @param listID:  IN:  ID of list whose temporary selection is to be obtained
00781  *  @retval Int16 Returns the temporarily selected list item
00782  **/
00783 Int16
00784 HsNavLstGetTempSelection (const FormType* formP, UInt16 listID)
00785                 SYS_SEL_TRAP (sysTrapHsSelector, hsSelNavLstGetTempSelection);
00786
00787 /**
00788  *  @brief Sets the temporarily selected item for an embedded list
00789  *
00790  *  @param formP:   IN:  Pointer to the form containing the list whose temporary selection is to be set
00791  *  @param listID:  IN:  ID of list whose temporary selection is to be set
00792  *  @param itemNum: IN:  Number of the item that should be temporarily selected
00793  **/
00794 void
00795 HsNavLstSetTempSelection (const FormType* formP, UInt16 listID, Int16 itemNum)
00796                 SYS_SEL_TRAP (sysTrapHsSelector, hsSelNavLstSetTempSelection);
00797
00798
00799 /**
00800  *  @brief Starts and stops memory tracing
00801  *
00802  *  @param tarce:   IN:  should tracing be started or stopped
00803  *  if true tracing will be started.
00804  *
00805  *  called from the 68K controling (test) app.
00806  **/
00807 void
00808 HsStartMemoryTracing(Boolean trace)
00809                 SYS_SEL_TRAP (sysTrapHsSelector, hsSelStartMemoryTracing);
00810
00811
00812 #ifdef __cplusplus
00813 }
00814 #endif
00815
00816 #endif    // __HS_EXT_68K_H__
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:53 2008 for Palm API Guide


Header Files » Incs » common » system

HsExtCommon.h

Go to the documentation of this file.
00001 /******************************************************************************
00002  * Copyright (c) 2005 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  *****************************************************************************/
00005 /**
00006  * @defgroup HSExt Handspring Extensions
00007  *
00008  * @{
00009  * @}
00010  */
00011 /**
00012  *
00013  * @ingroup HSExt
00014  *
00015  */
00016
00017 /**
00018  * @file    HsExtCommon.h
00019  * @brief   Common defines shared between HsExt.h (#include for 68K programs)
00020  * and HsExtArm.h (#include for ARM programs).
00021  *
00022  */
00023
00024
00025
00026 #ifndef   __HS_EXT_COMMON_H__
00027 #define   __HS_EXT_COMMON_H__
00028
00029 #if 0
00030 #pragma mark --------  Public Defines   ----------------
00031 #endif
00032
00033
00034 /******************************************************************************
00035  * Public Defines
00036  *****************************************************************************/
00037
00038 ////////////////////////////////////////
00039 #if 0
00040 #pragma mark Version String
00041 #endif
00042 ////////////////////////////////////////
00043
00044 #define hsVersionStringSize       32
00045
00046
00047 ////////////////////////////////////////
00048 #if 0
00049 #pragma mark Attributes
00050 #endif
00051 ////////////////////////////////////////
00052
00053 /**
00054  * Current system activity. Possible bits for hsAttrSysActivity
00055  **/
00056 /*@{*/
00057 #define hsAttrSysActiveHotSync        0x0001    /**< Hot sync in progress  */
00058 #define hsAttrSysActiveProgress       0x0002    /**< Progress dialog is up (any progress dialog) */
00059 #define hsAttrSysActiveBeamProgress   0x0004    /**< Beam Progress dialog is up */
00060 /*@{*/
00061
00062 /**
00063  * Type of phone. Possible values of hsAttrPhoneType
00064  **/
00065 /*@{*/
00066 #define hsAttrPhoneTypeCDMA       0x0001   /**< CDMA Phone  */
00067 #define hsAttrPhoneTypeGSM        0x0002   /**< GSM Phone  */
00068 /*@}*/
00069
00070 /** Possible values of hsAttrRingSwitch
00071  *  For now there are only two values, but it's left open to have a control
00072  *  that works more like a volume control and has a range of settings. The
00073  *  value of the "loud" setting was chosen so that it can be decided later
00074  *  to make this a bit field or a scalar value. */
00075 #define hsAttrRingSwitchMute          0    /**< Silent position*/
00076 #define hsAttrRingSwitchLoud          0x8000 /**< Sounds-on position */
00077
00078
00079 /**
00080  * Max length (in bytes) of a word (corrected or not) in the word
00081  * correction dictionary.  With null, word can be 26 bytes.
00082  **/
00083 #define hsWordCorrectMaxWordLen     25      /**<        */
00084
00085
00086
00087 ////////////////////////////////////////
00088 #if 0
00089 #pragma mark Errors
00090 #endif
00091 ////////////////////////////////////////
00092
00093 /**
00094  * Error codes
00095  **/
00096 /*@{*/
00097 #define hsOLDErrorClass                   (appErrorClass+0x0100)
00098 #define hsErrNotSupported                 (hsOLDErrorClass | 0x01)
00099 #define hsErrInvalidCardNum               (hsOLDErrorClass | 0x02)
00100 #define hsErrReadOnly                     (hsOLDErrorClass | 0x03)
00101 #define hsErrInvalidParam                 (hsOLDErrorClass | 0x04)
00102 #define hsErrBufferTooSmall               (hsOLDErrorClass | 0x05)
00103 #define hsErrInvalidCardHdr               (hsOLDErrorClass | 0x06)
00104 #define hsErrCardPatchAlreadyInstalled    (hsOLDErrorClass | 0x07)
00105 #define hsErrCardPatchNotInstalled        (hsOLDErrorClass | 0x08)
00106 #define hsErrNotEnoughPower               (hsOLDErrorClass | 0x09)
00107 #define hsErrCardNotInstalled             (hsOLDErrorClass | 0x0A)
00108 #define hsErrInvalidPeriod                (hsOLDErrorClass | 0x0B)
00109 #define hsErrPeriodicNotInstalled         (hsOLDErrorClass | 0x0C)
00110 #define hsErrFixedStorageRequired         (hsOLDErrorClass | 0x0D)
00111 #define hsErrPeriodicAlreadyInstalled     (hsOLDErrorClass | 0x0E)
00112 #define hsErrInUse                        (hsOLDErrorClass | 0x0F)
00113 #define hsErrIndicatorInvalidSequence     (hsOLDErrorClass | 0x10)
00114 #define hsErrIndicatorInvalidCap          (hsOLDErrorClass | 0x11)
00115 #define hsErrIndicatorDisabled            (hsOLDErrorClass | 0x12)
00116 // ***DO NOT DEFINE ANY MORE ERRORS IN THIS RANGE*** USE hsExtErrorClass
00117 // BASED DEFINITIONS BELOW FOR NEW ERROR CODES!
00118
00119 // IMPORTANT: THE OLD ERROR CLASS USED FOR HANDSPRING EXTENSIONS ERROR
00120 // CODES WAS IN **APP** ERROR CODE SPACE. ALL NEW CODES MUST BE DEFINED
00121 // IN TERMS OF THE UNIQUE ERROR CLASS hsExtErrorClass
00122
00123 /** Unexpected numerical underflow encountered */
00124 #define hsErrUnderflow                    (hsExtErrorClass | 0x13)
00125
00126 /** The user replied "No" when prompted to turn on wireless mode */
00127 #define hsErrUserNoRadio                  (hsExtErrorClass | 0x14)
00128
00129 /** Failed to register on carrier's network, or timed out while
00130  *  waiting to register. */
00131 #define hsErrOutOfCoverage                (hsExtErrorClass | 0x15)
00132
00133 /** The blocking call was interrupted by AppStop event */
00134 #define hsErrAppStopEvent                 (hsExtErrorClass | 0x16)
00135
00136 /** Request failed because of insufficient memory */
00137 #define hsErrOutOfMemory                  (hsExtErrorClass | 0x17)
00138
00139 /** The SIM is missing, invalid, wrong unlock code, or some other SIM
00140  *  problem detected that prevented network registration from completing. */
00141 #define hsErrSIMMissing                   (hsExtErrorClass | 0x18)
00142
00143 /** Failed to attach GPRS, or timed out while waiting to register */
00144 #define hsErrGPRSNotAttached              (hsExtErrorClass | 0x19)
00145
00146 /** The requiested operation timed out, without completing its objective */
00147 #define hsErrTimeOut                      (hsExtErrorClass | 0x1A)
00148
00149 /** The requiested operation was interrupted or cancelled by user,
00150  *  before completing its objective */
00151 #define hsErrUserInterrupted              (hsExtErrorClass | 0x1B)
00152
00153 /*@}*/
00154
00155
00156 ////////////////////////////////////////
00157 #if 0
00158 #pragma mark Libraries
00159 #endif
00160 ////////////////////////////////////////
00161
00162 /**
00163  * Library alias names that SysLibFind maps to a real library name
00164  *  according to the appropriate hsPrefSerialLibXXX setting.
00165  *
00166  * By Convention, library alias names start with a '*'. The exception
00167  *  is the "Serial Library" name which is mapped in order to
00168  *  be compatible with pre-existing applications that already use it.
00169  **/
00170 /*@{*/
00171 #define hsLibAliasDefault             "Serial Library" /**< hsPrefSerialLibDef */
00172 #define hsLibAliasHotSyncLocal        "*HsLoc  SerLib" /**< hsPrefSerialLibHotSyncLocal */
00173 #define hsLibAliasHotSyncModem        "*HsMdm  SerLib" /**< hsPrefSerialLibHotSyncModem */
00174 #define hsLibAliasIrda                "*Irda   SerLib" /**< hsPrefSerialLibIrda */
00175 #define hsLibAliasConsole             "*Cons   SerLib" /**< hsPrefSerialLibConsole */
00176 /*@{*/
00177
00178 /**
00179  * Actual library name of the Dragonball's built-in serial library.
00180  * This is the default value of the hsPrefDefSerialLib pref setting which
00181  *  SysLibFind uses to map an incoming library name to an actual library
00182  *  name.
00183  **/
00184 #define hsLibNameBuiltInSerial        "BuiltIn SerLib"
00185
00186
00187 ////////////////////////////////////////
00188 #if 0
00189 #pragma mark Features
00190 #endif
00191 ////////////////////////////////////////
00192
00193 /**
00194  * This is the Handspring feature id. Apps can tell if they're on
00195  * a handspring device if they get 0 err back from:
00196  * err = FtrGet (hsFtrCreator, hsFtrIDVersion, &value)
00197  **/
00198 #define hsFtrCreator                 'hsEx'
00199
00200
00201 /**
00202  * Version of Handspring extensions
00203  *  0xMMmfsHHh, where:
00204  *
00205  *   MM.mm.f are the major, minor, and fix revs of PalmOS which is modified
00206  *            by this version of HsExtensions
00207  *
00208  *   s is the release stage (3-release,2-beta,1-alpha,0-development)
00209  *
00210  *   HH.h are the major and minor rev of HsExtensions for the relevant
00211  *            version of PalmOS
00212  **/
00213 #define hsFtrIDVersion                0
00214
00215
00216 #define hsFtrIDModDate                1
00217
00218 /**
00219  * Feature number indicating that the Launcher Database Mgr library is loaded.
00220  *  The value of the feature is the refNum of the loaded library.
00221  *  Call FtrGet (hsFtrCreator, hsFtrIDLdbMgrLibRefNum, ...) to get this feature.
00222  *
00223  * THIS FEATURE IS DEPRICATED
00224  *
00225  **/
00226 #define hsFtrIDLdbMgrLibRefNum        2
00227
00228 /**
00229  * If this feature is present, then we won't use the optimization to grab the
00230  * memory semaphore before doing multiple data manager calls.
00231  **/
00232 #define hsFtrIDNoMemSemaphore         3
00233
00234 /** This features contains boolean flags to let developers know that a bug
00235  * present in older devices has been fixed.
00236  */
00237 #define hsFtrIDBugsFixed              4
00238
00239 /**
00240  * This feature tells what type of hardware keys a device has.
00241  */
00242
00243 /*@{*/
00244 #define hsFtrIDTypeOfKeyboard         5
00245
00246 /**
00247  *  The masks used to interpret the hardware keyboard feature
00248  **/
00249 #define hsFtrValKeyboardBasic       0x0001  /**< Basic keys (pwr/scroll/app) */
00250 #define hsFtrValKeyboardQwerty      0x0002  /**< Qwerty keys (A-Z, Period, Space, Backspace, Enter,
00251                                                   Menu, Option, Shift) */
00252 #define hsFtrValKeyboardJog         0x0004  /**< Jog keys (jog-up, jog-down,jog-scan) */
00253 #define hsFtrValKeyboardCommCentric 0x0008  /**< DEPRICATED - Communicator centric buttons */
00254 #define hsFtrValKeyboardCustomApps  0x0010  /**< Non-standard app keys (Standard is: date/addr/todo/memo)
00255                                                   replaces hsFtrValKeyboardCommCentric */
00256
00257 /*@{*/
00258
00259 /** This feature describes the radio hardware available */
00260 #define hsFtrIDRadioAttributes        6
00261
00262 // The masks used to interpret the radio attributes feature
00263 #define hsFtrValRadioAvailable      0x0001      /**< Radio is present and available for use */
00264 #define hsFtrValRadioBuiltin        0x0002      /**< Radio is part of the base hardware and not on a module */
00265
00266 /**
00267  *  This feature defines how the power putton behaves
00268  *  Note: In HsExtensions 1.0 for PalmOS 5.2.1 this feature is set, but ignored
00269  **/
00270 /*@{*/
00271 #define hsFtrIDPowerKeyResponse       7
00272 #define hsFtrValPowerKeyDoubleClkBacklight  0x0001  /**< Double click for backlight */
00273 #define hsFtrValPowerKeyTripleClkInvert     0x0002  /**< Triple click for invers (requires DblClkBacklight)*/
00274 #define hsFtrValPowerKeyHoldRadioPower      0x0004  /**< Hold for radio power */
00275 /*@{*/
00276
00277 /**
00278  *  This feature indicates the functionality of the status gadgets API
00279  **/
00280 #define hsFtrIDStatusGadgetRev        8
00281
00282 #define hsFtrValStatusGadgetRev1      0x0001    /**< Revision 1 of API */
00283
00284 /**
00285  *  If this feature is set, the graffiti area is disabled
00286  **/
00287 #define hsFtrIDGrfAreaDisabled        9
00288
00289 /**
00290  *  This feature tells which keyboard layout is being used
00291  **/
00292 #define hsFtrIDKeyboardLayout         10
00293
00294 /**
00295  * The values used to interpret the keyboard layout feature
00296  **/
00297 /*@{*/
00298 #define hsFtrValKeyboardLayout_enUS     0x0001  /**< English */
00299 #define hsFtrValKeyboardLayout_deDE     0x0002  /**< German */
00300 #define hsFtrValKeyboardLayout_frFR     0x0003  /**< French */
00301 /*@{*/
00302
00303 /**
00304  * This features contains the DB Id to open and
00305  * play the resource with type 'smfr' with resource id 1
00306  * when the lid opens
00307  *
00308  * THIS FEATURE IS DEPRICATED
00309  **/
00310 #define hsFtrIDToneOnLidOpen          11
00311
00312 /**
00313  * This feature and value (s) is used to see if PhoneApp should be relaunched
00314  * when waking up.
00315  *
00316  * THIS FEATURE IS DEPRICATED
00317  **/
00318 #define hsFtrIDCurrentAppOnSleep      12
00319 #define hsFtrValCurrentAppOnSleepPhoneAppSpeedDialView   0x0001  /**< PhoneApp current view is Speed dial */
00320
00321 /**
00322  * This feature indicates whether the Manufacturing test app is
00323  * present on the device.
00324  **/
00325 #define hsFtrIDTestingBootMode        13
00326
00327 /**
00328  * If this feature exists, then our navigation support exists.  The
00329  *version of the navigation support is stored in the feature's value.
00330  **/
00331 #define hsFtrIDNavigationSupported    14
00332
00333 /**
00334  * This feature can be used to determine the hardware "API" revision.
00335  * It changes when there's a revision of the hardware, but the device
00336  * is otherwise the same.  Very few apps should ever need this.  Drivers
00337  * should generally ask the HAL directly for this info (though HALAttr)
00338  * since that's more efficient.
00339  **/
00340 #define hsFtrIDHardwareApiRevision    15
00341
00342
00343 /**
00344  * Display Attribute Features
00345  */
00346
00347 #define hsDispFtrCreator                      'DisA'
00348
00349 /** Attributes about the display / controller combination... */
00350 #define hsDispFtrIDDisplayAttributes          0
00351
00352 /**
00353  * @name Values for the display attributes, which is a bitfield.
00354  *
00355  */
00356 /*@{*/
00357 #define hsDispFtrValLCDControllerTypeMask     0x000000FF
00358 #define hsDispFtrValDragonballVZ              0x00000000
00359 #define hsDispFtrValSed1375                   0x00000001
00360 #define hsDispFtrValSed1376                   0x00000002
00361 #define hsDispFtrValSed13A3                   0x00000003
00362 #define hsDispFtrValOmapX10             0x00000004  /**< TI OMAP 1510/310 */
00363 #define hsDispFtrValBulverdePxa27X            0x00000005    /**< Intel Bulverde PXA 270, 271, etc. */
00364
00365 #define hsDispFtrValLCDDisplayTypeMask        0x0000FF00        /**<        */
00366 #define hsDispFtrValBwStn                0x00000100 /**< The black and white STN used in black and white Visors and Treos. */
00367 #define hsDispFtrValColorStn                  0x00000200    /**< Color STN */
00368 #define hsDispFtrValColorTft                  0x00000300    /**< Color TFT (used in Prism) */
00369 #define hsDispFtrValColorOled                 0x00000400    /**< Organic LED */
00370 /*@}*/
00371
00372 /**
00373  * @name Available Shades
00374  *   This feature contains the number of shades of gray, red, green, and blue
00375  *   available on this display.  Note that this will _never_ be bigger than
00376  *   the number of shades available on the controller, since the display is
00377  *   fundamentally limited by what you can set the controller to.  See masks
00378  *   below for accessing...
00379  */
00380 /*@{*/
00381 #define hsDispFtrIDDisplayShades              1
00382
00383 /**
00384  * This feature contains the number of shades of gray, red, green, and blue
00385  * available on this controller.  This can be larger than the number of shades
00386  * that the display can show, since the controller can do hardware dithering
00387  * to deal with the fact that the display can't show all the shades.
00388  *
00389  * Software dithering is handled separately.  If there is software dithering, it
00390  * can be suppressed.  See hsAttrDitherSuppress
00391  **/
00392 #define hsDispFtrIDControllerShades           2
00393
00394 /**
00395  * You can use these bitmasks to get the number of shades
00396  * ...note that the actual number of shades is the (value+1).  This is needed
00397  * so in the future we can support displays/controllers that can have 256 shades.
00398  **/
00399 #define hsDispFtrValGrayOffset                24
00400 #define hsDispFtrValRedOffset                 16
00401 #define hsDispFtrValGreenOffset                8
00402 #define hsDispFtrValBlueOffset                 0
00403 /*@}*/
00404
00405
00406 // Sample usage:
00407 //
00408 // UInt32 displayShades;
00409 // UInt16 redShades;
00410 // Err err = 0;
00411 //
00412 // err = FtrGet (hsDispFtrCreator, hsDispFtrIDDisplayShades, &displayShades);
00413 // if (!err)
00414 //   {
00415 //     // Get the number of red shades - 1...
00416 //     redShades = (UInt16) ((UInt8) (displayShades >> hsDispFtrValRedOffset));
00417 //
00418 //     // Account for +1 after doing the conversion to 8-bit...
00419 //     redShades++;
00420 //   }
00421
00422
00423
00424 ////////////////////////////////////////
00425 #if 0
00426 #pragma mark Utilities
00427 #endif
00428 ////////////////////////////////////////
00429
00430 /** This is the buffer size that should be sent to HsExtDoSaveAsDialog() */
00431 #define hsMaxSaveAsNameSize 32
00432
00433
00434
00435 #if 0
00436 #pragma mark --------  Public Enums   ----------------
00437 #endif
00438
00439 /******************************************************************************
00440  * Public Enums
00441  *****************************************************************************/
00442
00443 ////////////////////////////////////////
00444 #if 0
00445 #pragma mark Version String
00446 #endif
00447 ////////////////////////////////////////
00448
00449 typedef enum
00450   {
00451     hsVerStrComplete,       /**< Composite, formatted for display in info dialog */
00452     hsVerStrSerialNo,       /**< Complete serial number (ROM token 'snum' is limited to 12 digits) */
00453     hsVerStrHardware,       /**< Revision of the hardware */
00454     hsVerStrProductName,        /**< Like, "Treo 600" */
00455     hsVerStrCarrierID,      /**< Carrier ID code for carrier branding */
00456     hsVerStrProductRev,     /**< Complete product; covering hardware, radio firmware and software */
00457     hsVerStrROMBuild,       /**< ROM buld number (not the same as the build number in sysFtrNumROMVersion) */
00458     hsVerStrFirmwareVer,        /**< Version of the radio firmware */
00459     hsVerStrPalmOSVer,      /**< See sysFtrNumROMVersion */
00460     hsVerStrLifeTime        /**< Radio life timer */
00461   } HsVerStrEnum;
00462
00463
00464 ////////////////////////////////////////
00465 #if 0
00466 #pragma mark Attributes
00467 #endif
00468 ////////////////////////////////////////
00469
00470 /**
00471  * Parameters to HsAttrGet/Set calls
00472  **/
00473
00474 typedef enum
00475   { /*
00476      *  These attributes with various sizes are defined
00477      *  only for compatability with existing 68K code, and
00478      *  are explicitly marshalled by the 68K/ARM shim for
00479      *  the HsAttrGet() and HsAttrSet() functions.
00480      *
00481      *  Note: The definitions for hsAttrE911Mode in the
00482      *  OS 3.5 headers, and for hsAttrKeyboardLocked in
00483      *  the OS 4.0 headers both had an enum value of 8.
00484      *  Apps using hsAttrE911Mode will probably have to be
00485      *  recompiled anyway so backward compatability has
00486      *  been maintained hsAttrKeyboardLocked.
00487      */
00488     hsAttr68KLidOpen,               /**< UInt16 @see hsAttrLidOpen */
00489     hsAttr68KSysSleepReason,        /**< UInt16 @see hsAttrSysSleepReason */
00490     hsAttr68KDisplayOn,             /**< UInt16  @see hsAttrDisplayOn */
00491     hsAttr68KRingSwitch,            /**< UInt16 @see hsAttrRingSwitch */
00492     hsAttr68KPostProcessRsc,        /**< UInt32 @see hsAttrPostProcessRsc */
00493     hsAttr68KSysActive,             /**< UInt16 @see hsAttrSysActive */
00494     hsAttr68KActiveCalls,           /**< UInt16 @see hsAttrActiveCalls */
00495     hsAttr68KPhoneType,             /**< UInt32 @see hsAttrPhoneType */
00496     hsAttr68KKeyboardLocked,        /**< Boolean @see hsAttrKeyboardLocked */
00497     hsAttr68KKeyLockNextWakeTicks,  /**< UInt32 @see hsAttrKeyLockNextWakeTicks */
00498
00499     /*
00500      * All new 68K and ARM code shall use only the following
00501      * attributes, all of which take a 32-bit value parameter.
00502      */
00503     hsAttrLidOpen = 0x80,       /**< false=lid closed, true=lid open
00504                                     (returns hsErrNotSupported if no lid) */
00505     hsAttrSysSleepReason,       /**< Same as the SleepEventParamType.reason
00506                                        from the last sysNotifySleepRequestEvent
00507                                        unless the real reason is different
00508                                        (e.g. hsSysSleepLid) */
00509     hsAttrDisplayOn,            /**< true = display is on, false = dispay is off */
00510     hsAttrRingSwitch,       /**< State of ring switch, can be either hsAttrRingSwitchMute or hsAttrRingSwitchLoud */
00511     hsAttrPostProcessRsc,       /**< Pointer to resource containing the post-processing lists */
00512     hsAttrSysActive,            /**< Bits representing various system activity. Current
00513                                      implementation sets only the hsAttrSysActiveHotSync
00514                                      bit if the HotSync dialog is active*/
00515     hsAttrActiveCalls,          /**< Number of active voice calls */
00516     hsAttrPhoneType,            /**< returns hsAttrPhoneTypeCDMA if a CDMA phone
00517                                      or hsAttrPhoneTypeGSM if a GSM phone */
00518     hsAttrKeyboardLocked,       /**< true = keyguard active */
00519     hsAttrKeyLockNextWakeTicks, /**< deprecated */
00520     hsAttrKeyboardDB,           /**< DmOpenRef of database containing keyboard layout resources */
00521     hsAttrDigitizerLock,        /**< true = digitizer is locked */
00522     hsAttrE911Mode,             /**< true = phone is in 911 mode */
00523     hsAttrDitherSuppress,       /**< count of requests to supress dithering
00524                                         Set to non-zero to increment, set to zero to decrement */
00525     hsAttrHotSyncSuppress,      /**< count of requests to suppress HotSync
00526                                         Set to non-zero to increment, set to zero to decrement */
00527
00528     hsAttrPhoneRadioPowerState, /**< notifies HsExt that cell phone radio was just powered on
00529                                         or off; non-zero if cell phone radio was powered on, zero if
00530                                         powered down.  Power on does *not* imply completion of SIM
00531                                         detection or registration */
00532
00533     hsAttrAllKeysWakeFromSleep, /**< (Refcount) sets the device in a mode where _all_ keys wake
00534                                         the device from sleep and are processed.  This is intended in
00535                                         special cases where we've powered off the screen to save power
00536                                         (or something similar), but the user still thinks the device of
00537                                         the device as on.  As a side effect, this will stop 'keyboard lock'
00538                                         from starting when the device turns off.
00539                                         Set to non-zero to increment, set to zero to decrement */
00540
00541     hsForcePrefAutoOffDurationSecs, //  Forces the Keyguard dialog to have a timeout period of prefAutoOffDurationSecs
00542     hsAttrKeyguardDialogOn,         //  Denotes if the Keyguard dialog is On or not.
00543
00544     // This section is reserved so that if we need to add adds more attributes in "SDK 2.0"
00545     // products that they won't conflict with attributes added in "SDK 2.1"
00546     hsAttrReserved_SDK20_1,
00547     hsAttrReserved_SDK20_2,
00548     hsAttrReserved_SDK20_3,
00549     hsAttrReserved_SDK20_4,
00550     hsAttrReserved_SDK20_5,
00551     hsAttrReserved_SDK20_6,
00552     hsAttrReserved_SDK20_7
00553
00554     /*
00555      * Attributes greater than 0x9000 are defined for internal use
00556      * in Prv/HsExtAttr.h
00557      */
00558   } HsAttrEnum;
00559
00560
00561 ////////////////////////////////////////
00562 #if 0
00563 #pragma mark Preferences
00564 #endif
00565 ////////////////////////////////////////
00566
00567 /**
00568  * Equates for the HsPrefGet/Set calls
00569  **/
00570 typedef enum
00571   {
00572
00573     // The following are used by SysLibFind() to resolve a virtual library
00574     //  name to an actual one.  They are also used directly by SrmOpen()
00575     //  to figure out whether to override a new-style driver w/ an old-style
00576     //  driver.
00577     hsPrefSerialLibDef,     /**< Char[] : Name of serial library to substitute for hsLibAliasDefault */
00578     hsPrefSerialLibHotSyncLocal,    /**< Char[] : Name of serial library to substitute for hsLibAliasHotSyncLocal */
00579     hsPrefSerialLibHotSyncModem,    /**< Char[] : Name of serial library to substitute for hsLibAliasHotSyncModem */
00580     hsPrefSerialLibIrda,        /**< Char[] : Name of serial library to substitute for hsLibAliasIrda */
00581     hsPrefSerialLibConsole,     /**< Char[] : Name of serial library to substitute for hsLibAliasConsole */
00582
00583     /**** End of prefs recognized by Visor, Visor Deluxe, Platnium, Prism, Edge ****/
00584
00585     // The following are used in SysHandleEvent() to launch apps in response
00586     //  to associated virtual characters.
00587     hsPrefJogScanCharAppCreator,      /**< UInt32 : Creator type of app to launch in response to hsChrJogScan */
00588     hsPrefLidStatusChgCharAppCreator, /**< UInt32 : Creator type of app to launch in response to hsChrLidStatusChg */
00589     hsPrefOptHard1CharAppCreator,     /**< UInt32 : Creator type of app to launch n response to hsChrOptHard1 */
00590     hsPrefOptHard2CharAppCreator,     /**< UInt32 : Creator type of app to launch in response to hsChrOptHard2 */
00591     hsPrefOptHard3CharAppCreator,     /**< UInt32 : Creator type of app to launch in response to hsChrOptHard3 */
00592     hsPrefOptHard4CharAppCreator,     /**< UInt32 : Creator type of app to launch in response to hsChrOptHard4 */
00593
00594     // The following are used to set Key Manager preferences
00595     hsPrefTempShiftTimeOut,           /**< UInt32 : Number of ticks until a temporary
00596                         shift state (upper shift or option shift) times out. */
00597
00598     hsPrefLidClosedAutoOffSeconds,    /**< UInt16 : Number of seconds for auto-off when the lid is closed */
00599
00600     hsPrefLCDRefreshRate,         /**< UInt16 : Type of refresh rate for lighting see HsLCDRefreshRateEnum */
00601
00602     /**** End of prefs recognized by Treo 90, 180, 270, 300 ****/
00603
00604     hsPrefNetworkTimeSelected,    /**< UInt16: used by CDMA devices - should it read the time from the network*/
00605
00606     hsPrefKeyguardAutoEnableTime,     /**< UInt16: How many seconds to wait before enabling keyguard*/
00607
00608
00609     hsPrefKeyguardAutoEnableAutoOffExtraTime, /**< UInt16 : How many seconds to wait before enabling
00610                                                       keyguard when hsPrefKeyguardAutoEnableTime is
00611                                                       set to hsKeyguardAutoPowerOff and the device
00612                                                       powers off due to the auto-off timer */
00613
00614     hsPrefKeyguardFlags,              /**< UInt16 : Flags controlling keyguard's behaviour */
00615
00616     hsPrefTouchscreenDisableFlags,    /**< UInt16: Used by the phone app to determine when to disable touchscreen */
00617
00618     // The following are used in SysHandleEvent() to launch apps in response
00619     //  to associated virtual characters.
00620     hsPrefOptHardPowerCharAppCreator, /**< UInt32 : Creator type of app to launch in response to hsChrOptHardPower */
00621
00622     hsPrefOptReservedCharAppCreator,  /**< UInt32 : Creator type of app to launch in response to hsChrOptReserved (for future use) */
00623
00624     hsPrefPowerOnAppCreator,              /**< UInt32 : Creator type of app to launch
00625                                               instead of the normally mapped app when
00626                                               the app key turned the power on */
00627
00628     /**** End of prefs recognized by Treo 600 ****/
00629
00630     hsPrefSideHardCharAppCreator,       /**< UInt32 : Creator type of app to launch
00631                                               instead of the normally mapped app when
00632                                               the side key is pressed */
00633
00634     hsPrefBlinkGreenLEDInCoverage,      /**< UInt16 : Set to true if we want the green
00635                                               LED to blink when the device is in coverage */
00636
00637     /**** End of prefs recognized by Treo 650 ****/
00638
00639     hsPrefHard11CharAppCreator,       /**< UInt32 : Creator type of app to launch
00640                                               in response to vchrHard11 */
00641
00642     hsPrefOptHard11CharAppCreator,    /**< UInt32 : Creator type of app to launch
00643                                               in response to hsChrOptHard11 */
00644
00645     hsPrefUserNotLookingTime,           /**< Int32 : After this many seconds since the last
00646                                                 action, the user has stopped looking
00647                                                 at the device. (auto display/kbd dim) */
00648
00649     // <chg 2005-DEC-14 Monte Benaresh> Added next pref
00650
00651     hsPrefNetworkTZSelected,            /**< UInt16: used by phones - should it read
00652                                                 the time zone from the network*/
00653
00654     // RJS 22May06 Added next pref for PTT
00655     hsPrefShortSideHardCharAppCreator,      /**< UInt32: Creator ID of app to launch on short press of side button */
00656
00657     // RTS April 06 Added pref for Gnome/Gandalf
00658     hsPrefPowerSaveMode,            /**< Int32 : tied to the hsPrefUserNotLookingTime to turn off the backlight
00659                              rather than just dim it.  LCD remains on.*/
00660
00661     // Leave this one at end!!!
00662     hsPrefLast
00663
00664   } HsPrefEnum;
00665
00666
00667 /**
00668  * @name Special values for hsPrefKeyguardAutoEnableTime
00669  *
00670  */
00671 /*@{*/
00672 #define hsKeyguardAutoDisabled                  0   /**< Never */
00673 #define hsKeyguardAutoPowerOff                  0xFFFF  /**< When device powers off */
00674 /*@}*/
00675
00676 /**
00677  * @name Values for hsPrefKeyguardFlags
00678  *
00679  */
00680 /*@{*/
00681 #define hsKeyguardFlagPowerOnDialog             0x0001  /**< Show keyguard dialog at power-on */
00682 /*@}*/
00683
00684 /**
00685  * @name Bit definitions for hsPrefTouchscreenDisableFlags
00686  *
00687  */
00688 /*@{*/
00689 #define hsTouchscreenDisableFlagIncomingCall    0x0001          /**<        */
00690 #define hsTouchscreenDisableFlagDuringCall      0x0002      /**<        */
00691 /*@}*/
00692
00693 ////////////////////////////////////////
00694 #if 0
00695 #pragma mark Status Gadgets
00696 #endif
00697 ////////////////////////////////////////
00698
00699 /**
00700  * Equates for supporting system handled status gadgets
00701  **/
00702 typedef enum
00703   {
00704     hsStatusGadgetBattery = 1,          /**< Status gadget is a battery meter */
00705     hsStatusGadgetSignal = 2            /**< Status gadget is a signal strength indicator */
00706   } HsStatusGadgetTypeEnum;
00707
00708
00709
00710 ////////////////////////////////////////
00711 #if 0
00712 #pragma mark Light Manager
00713 #endif
00714 ////////////////////////////////////////
00715
00716 /**
00717  * Light manager equates
00718  **/
00719
00720 /**
00721  * These are different modes that can be used to affect the light manager,
00722  * which is in charge of temporary changes in the lighting situation.
00723  **/
00724
00725 typedef enum
00726   {
00727     // Preset modes
00728     // ------------
00729     // These modes have saved values associated with them...
00730     hsLightModeNormal = 0,      /**< Light mode is at normal presets */
00731     hsLightModeNight  = 1,      /**< Light mode is at night-mode presets */
00732
00733     hsLightModeNumPresets,  /**< Num presets.  SUBJECT TO CHANGE. */
00734
00735     /** Reserved mode to force compiler to use 16-bit for enum... */
00736     hsLightModeReserved = 0x7FFF
00737   }
00738 HsLightModeEnum;
00739
00740
00741 /**
00742  *  These circumstances modify the mode and allow us to handle
00743  *  different logical circumstances on devices with different hardware.
00744  *
00745  *  - These are applied in the following order:
00746  *   1. Alert woke device
00747  *   2. keylight off
00748  *   3. Quick typing
00749  *   4. User not looking
00750  *   5. User not looking for a long time
00751  **/
00752 typedef enum
00753   {
00754     hsLightCircumstanceFirst        = 0,    /**<        */
00755     hsLightCircumstanceAlertWokeDevice  = 0,    /**< An important alert woke the  device up from sleep.*/
00756     hsLightCircumstanceQuickTyping      = 1,    /**< We want the user to be able  to access the keyboard easily */
00757     hsLightCircumstanceUserNotLooking   = 2,    /**< We suspect the user isn't looking at the device if they're
00758                                  not actively using the device, so we'll dim the screen (but we don't
00759                                                   actually want to turn it off).*/
00760     hsLightCircumstanceUserNotLookingLongTime = 3,  /**< similar to above, but if the inactivity persists then
00761                                we want to turn the screen off **/
00762
00763     hsLightCircumstanceKeylightOff      = 4,    /* turn keylight off */
00764
00765     hsLightCircumstanceNumCircumstances,        /**< Num circumstances.   SUBJECT TO CHANGE.*/
00766
00767     /**
00768      *  Reserved circumstance to force compiler to use 16-bit for enum...
00769      **/
00770     hsLightCircumstanceReserved = 0x7FFF
00771   }
00772 HsLightCircumstanceEnum;
00773
00774
00775 /**
00776  * @name Bit Flag for Light Circumstances
00777  *
00778  * application may call HsCurrentLightCircumstance() to get current
00779  * enabled light circumstances
00780  *
00781  * test bit to see if light circumstance is enabled or disabled
00782  *
00783  */
00784 /*@{*/
00785 #define hsLightCircumstanceAlertWokeDeviceFlagBit       0x0001      /**<        */
00786 #define hsLightCircumstanceQuickTypingFlagBit           0x0002      /**<        */
00787 #define hsLightCircumstanceUserNotLookingFlagBit        0x0004      /**<        */
00788 #define hsLightCircumstanceUserNotLookingLongTimeFlagBit    0x0008      /**<        */
00789 #define hsLightCircumstanceKeylightOffFlagBit           0x0010      /**<        */
00790 /*@}*/
00791
00792 ////////////////////////////////////////
00793 #if 0
00794 #pragma mark Indicators
00795 #endif
00796 ////////////////////////////////////////
00797
00798 /**
00799  *
00800  **/
00801 typedef enum
00802   {
00803     kIndicatorTypeLed,
00804     kIndicatorTypeVibrator,
00805
00806     // This must be last
00807     kIndicatorTypeCount
00808   }
00809 HsIndicatorTypeEnum;
00810
00811 /**
00812  *  Pass a numeric count or one of these special values to HsIndicatorState()
00813  **/
00814 typedef enum
00815   {
00816     kIndicatorCountGetState = 0,        /**< retrieve the current state */
00817     kIndicatorCountForever  = 0xFFFF    /**< run forever */
00818   }
00819 HsIndicatorCountEnum;
00820
00821
00822 /**
00823  * There are several different sources of turning on the indicator,
00824  * (Charge, Signal, Ring, App) with each source being in exactly one
00825  * state at any moment. The high byte of these enum values indicates
00826  * the source, and the low byte indicates which state that source is
00827  * in. Each source has a hard-coded priority, so only the indication
00828  * of the highest priority source not in its "None" state will appear
00829  * on the indicator. The value of the high byte does not represent
00830  * the priority.
00831
00832  * A virtual state that is used to get the state that is currently
00833  * active on the indicator (the highest priority active source). This
00834  * value is also the result when there is no active source.
00835  * (States with * aren't used at present)
00836  **/
00837 typedef enum
00838   {
00839
00840     kIndicatorStateNull   = 0x0000,
00841
00842     kIndicatorForceNone   = 0x0100,     /**< Don't force anything */
00843     kIndicatorForceOn     = 0x0101,     /**< Force the indicator on */
00844     kIndicatorForceRed    = 0x0101,     /**< Force the red led on */
00845     kIndicatorForceGreen,               /**< Force the green led on */
00846     kIndicatorForceRedGreen,            /**< Force both leds on (orange) */
00847     kIndicatorForceOff    = 0x0180,     /**< Force both leds off */
00848
00849     kIndicatorRingNone    = 0x0200,     /**< Phone not ringing */
00850     kIndicatorRingActive,               /**< Phone ringing */
00851     kIndicatorRingContact,              /**< *Phone ringing, CID recognized */
00852     kIndicatorRingRoam,                 /**< *Phone ringing, roaming */
00853
00854     kIndicatorAlertNone   = 0x0300,     /**< Alert not active */
00855     kIndicatorAlertAlert,               /**< Generic alert */
00856     kIndicatorAlertMail,                /**< Incoming mail */
00857     kIndicatorAlertCalendar,            /**< Datebook alarm */
00858     kIndicatorAlertSMS,                 /**< Incoming SMS */
00859     kIndicatorAlertVoicemail,           /**< Voicemail waiting */
00860     kIndicatorAlertPending,             /**< Attention alert pending */
00861
00862     kIndicatorBattNone    = 0x0400,     /**< Not connected to a charger */
00863     kIndicatorBattCharge,               /**< Battery is charging */
00864     kIndicatorBattTrickle,              /**< Battery is topping off */
00865     kIndicatorBattFull,                 /**< Battery is fully charged */
00866     kIndicatorBattLow,                  /**< *Battery is low (and not on a charger) */
00867
00868     kIndicatorUsageNone   = 0x0600,     /**< Not in use */
00869     kIndicatorUsageVoiceCall,           /**< Phone on an active voice call */
00870     kIndicatorUsageDataCall,            /**< Phone on an active data call */
00871
00872     kIndicatorSignalNone  = 0x0500,         /**< Radio turned off */
00873     kIndicatorSignalBad,                /**< Out of coverage */
00874     kIndicatorSignalGood,               /**< In coverage */
00875     kIndicatorSignalRoam                /**< *In coverage, roaming */
00876   }
00877 HsIndicatorStateEnum;
00878
00879
00880 ////////////////////////////////////////
00881 #if 0
00882 #pragma mark Company / HAL / Device IDs
00883 #endif
00884 ////////////////////////////////////////
00885
00886 // These constants can be used to tell one device from another...
00887 //
00888 // See the following, in Palm's SystemMgr.h:
00889
00890 // #define  sysFtrNumOEMCompanyID           20  // GHwrOEMCompanyID value       (PalmOS 3.5)
00891 // #define  sysFtrNumOEMDeviceID            21  // GHwrOEMDeviceID value        (PalmOS 3.5)
00892 // #define  sysFtrNumOEMHALID               22  // GHwrOEMHALID value           (PalmOS 3.5)
00893
00894
00895 // Company ID
00896 // ----------
00897
00898 // This is defined in HwrMiscFlags.h already...
00899 // #define hwrOEMCompanyIDHandspring    'hspr'  // Devices made by Handspring
00900
00901
00902 /**
00903  * @name HAL IDs
00904  *   Handspring generally doesn't differentiate different HALs and uses the same
00905  *   ID in multiple places...  Use the device ID to figure out which devide you're
00906  *   on.  If you're looking to see which version of HsExtensions is available, see
00907  *   the HsExtensions feature (hsFtrIDVersion)...
00908  */
00909 /*@{*/
00910 #define hsHALIDHandspringOs35_40      'Hs01'    /**< Used by all Handspring OS 3.5 HALs and 4.0 HALs */
00911
00912 #define hsHALIDHandspringOs5Rev1      'H5_1'    /**< Used by Handspring's 5.0 HALs */
00913 #define hsHALIDHandspringOs5Rev1Sim   'H5s1'    /**< Used by Handspring's 5.0 Simulator HALs */
00914
00915 #define hsHALIDHandspringOs5Rev2      'H5_2'    /**< Used by Handspring's 5.2 HALs */
00916 #define hsHALIDHandspringOs5Rev2Sim   'H5s2'    /**< Used by Handspring's 5.2 Simulator HALs */
00917
00918 #define hsHALIDHandspringOs5Rev3      'P052'    /**< Used by Handspring's 5.3 HALs */
00919 #define hsHALIDHandspringOs5Rev3Sim   'S052'    /**< Used by Handspring's 5.3 Simulator HALs */
00920
00921 #define hsHALIDHandspringOs5Rev4      'P053'    /**< Used by Handspring's 5.4 HALs */
00922 #define hsHALIDHandspringOs5Rev4Sim   'S053'    /**< Used by Handspring's 5.4 Simulator HALs */
00923 /*@}*/
00924
00925 /**
00926  * @name Device IDs
00927  *   Older devices don't use 4-character constants; newer devices do.  Sometimes
00928  *   devices will have the same ID if they are extremely similar.  You may need
00929  *   to use alternate means to differentiate between such products.
00930  */
00931 /*@{*/
00932 #define hsDeviceIDVisor           0x00      /**< Visor, Visor Deluxe */
00933 #define hsDeviceIDVisorPlatinum   0x08          /**< Visor Platinum, some Visor Neos */
00934 #define hsDeviceIDVisorEdge       0x09      /**< Visor Edge */
00935 #define hsDeviceIDVisorPrism      0x0A          /**< Visor Prism */
00936 #define hsDeviceIDTreo180         0x0B      /**< Treo 180 */
00937 #define hsDeviceIDTreo270         0x0D      /**< Treo 270 */
00938 #define hsDeviceIDTreo300         0x0E      /**< Treo 300 */
00939 #define hsDeviceIDVisorNeo        0x8A      /**< Visor Neo (some Neos may have 0x08) */
00940 #define hsDeviceIDVisorPro        0x8B      /**< Visor Pro */
00941 #define hsDeviceIDTreo90          0x8C      /**< Treo 90 */
00942 /*@}*/
00943
00944 // kPalmOneDeviceID constants defined in palmOneResources.h.  From now on device IDs should
00945 //  be defined there.
00946
00947 #define hsDeviceIDTreo600         kPalmOneDeviceIDTreo600   /**< Treo 600 */
00948 #define hsDeviceIDTreo600Sim      kPalmOneDeviceIDTreo600Sim        /**< Treo 600 Simulator */
00949
00950 // For backward compatibility
00951 #define hsDeviceIDOs5Device1      kPalmOneDeviceIDTreo600
00952 #define hsDeviceIDOs5Device1Sim   kPalmOneDeviceIDTreo600Sim
00953
00954
00955 // Sample code
00956 // -----------
00957
00958 // To use this to detect Handspring devices, do something like:
00959 //  {
00960 //    UInt32 company = 0, deviceID = 0;
00961 //
00962 //    FtrGet (sysFtrCreator, sysFtrNumOEMCompanyID, &company);
00963 //    FtrGet (sysFtrCreator, sysFtrNumOEMDeviceID, &deviceID);
00964 //
00965 //    if ((company == hwrOEMCompanyIDHandspring) && (deviceID == hsDeviceIDOs5Device1))
00966 //      {
00967 //        ...
00968 //      }
00969 //  }
00970 //
00971 // To check for Handspring devices in general and to get the versions
00972 // of HsExtensions, use something like:
00973 //  {
00974 //    UInt32 version = 0;
00975 //
00976 //    FtrGet (hsFtrCreator, hsFtrIDVersion, &version);
00977 //    if (version >= 0x05000000)
00978 //      {
00979 //        ...
00980 //      }
00981 //  }
00982
00983 #endif    // __HS_EXT_COMMON_H__
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:53 2008 for Palm API Guide


Header Files » Incs » 68k » system

HsExtKbdUtils.h

Go to the documentation of this file.
00001 /******************************************************************************
00002  * Copyright (c) 2004 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  *****************************************************************************/
00005 /**
00006  *
00007  * @ingroup SystemDef
00008  *
00009  */
00010
00011 /**
00012  * @file    HsExtKbdUtils.h
00013  * @version
00014  * @date
00015  *
00016  * @brief
00017  *
00018  */
00019
00020
00021 #ifndef _HS_EXT_KBD_UTILS_H
00022 #define _HS_EXT_KBD_UTILS_H
00023
00024 //#include <Hs.h>
00025 /**
00026  *  @brief
00027  *
00028  *  @param overrideFont:    IN:
00029  *  @param overrideFontID:  IN:
00030  *  @retval Error code.
00031  **/
00032 Int16
00033 HsPostProcessPopupList (Boolean overrideFont, FontID overrideFontID)
00034           SYS_SEL_TRAP (sysTrapHsSelector, hsSelPostProcessPopupList);
00035
00036
00037 #endif // _HS_EXT_KBD_UTILS_H
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:53 2008 for Palm API Guide


Header Files » Incs » 68k » system

HsExtTraps.h

Go to the documentation of this file.
00001 /******************************************************************************
00002  * Copyright (c) 2005 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  *****************************************************************************/
00005 /**
00006  *
00007  * @ingroup SystemDef
00008  *
00009  */
00010
00011 /**
00012  * @file    HsExtTraps.h
00013  * @version
00014  * @date
00015  *
00016  * @brief   Definitions of selectors used for the 68K trap based
00017  *      calls to HsExtensions
00018  *
00019  */
00020
00021
00022
00023 #ifndef   __HS_EXT_TRAPS_H__
00024 #define   __HS_EXT_TRAPS_H__
00025
00026 #ifndef sysTrapOEMDispatch
00027   /// OEM trap in Palm OS 3.0 and later trap table (formerly sysTrapSysReserved4)
00028   #define sysTrapOEMDispatch              0xA349        /**<        */
00029 #endif // !sysTrapOEMDispatch
00030
00031 /**
00032  * @name This is the system trap that we base all HsExt calls off of.
00033  *
00034  */
00035 /*@{*/
00036 #define sysTrapHsSelector                 sysTrapOEMDispatch    /**<        */
00037 /*@}*/
00038
00039
00040 #define hsSelectorBase                    0     /**<        */
00041
00042   #define hsSelInfo                           0x0   /**<        */
00043
00044 #ifndef HS_STRIP_UNIMPLEMENTED  // not implemented on 5.x yet...
00045   #define hsSelPrvInit                    0x1       /**<        */
00046   #define hsSelPrvCallSafely                  0x2       /**<        */
00047   #define hsSelPrvCallSafelyNewStack          0x3           /**<        */
00048
00049   #define hsSelDatabaseCopy                   0x4       /**<        */
00050   #define hsSelExtKeyboardEnable              0x5       /**<        */
00051   #define hsSelCardAttrGet                0x6       /**<        */
00052   #define hsSelCardAttrSet                0x7       /**<        */
00053   #define hsSelCardEventPost                  0x8       /**<        */
00054   #define hsSelPrvErrCatchListP               0x9       /**<        */
00055 #endif
00056
00057 #define hsSelPrefGet                      0xA       /**<        */
00058 #define hsSelPrefSet                      0xB       /**<        */
00059
00060 #ifndef HS_STRIP_UNIMPLEMENTED  // not implemented on 5.x yet...
00061   #define hsSelDmGetNextDBByTypeCreator   0xC               /**<        */
00062   #define hsSelDmGetNextDBInit            0xD           /**<        */
00063
00064   #define hsSelCardHdrUpdate                  0xE       /**<        */
00065
00066   #define hsSelAppEventHandlerSet         0xF           /**<        */
00067   #define hsSelAppEventPost                   0x10      /**<        */
00068
00069   #define hsSelUsbCommStatePtr            0x11          /**<        */
00070
00071   #define hsSelCardPatchInstall               0x12      /**<        */
00072   #define hsSelCardPatchRemove            0x13          /**<        */
00073
00074   #define hsSelEvtResetAutoOffTimer           0x14          /**<        */
00075
00076   #define hsSelDmDatabaseUniqueIDSeed         0x15          /**<        */
00077 #endif
00078
00079 #define hsSelAboutHandspringApp           0x16          /**<        */
00080
00081 #ifndef HS_STRIP_UNIMPLEMENTED  // not implemented on 5.x yet...
00082   #define hsSelDmDatabaseIsOpen               0x17      /**<        */
00083   #define hsSelDmDatabaseIsProtected          0x18          /**<        */
00084
00085   #define hsSelDlkForceSlowSync               0x19      /**<        */
00086
00087   #define hsSelPrvHandleCardChangeEvent   0x1A              /**<        */
00088
00089   // 0x03523000
00090
00091   #define hsSelCardPower                  0x1B      /**<        */
00092
00093   #define   hsSelDmDatabaseDeleted            0x1C      /**<        */
00094
00095   #define   hsSelDmLockFileSystem             0x1D      /**<        */
00096
00097   #define   hsSelPrvLaunchCompareFunc         0x1E      /**<        */
00098
00099   // 0x03523020
00100
00101   #define hsSelPrvLEDCommand                  0x1F      /**<        */
00102
00103   #define hsInstallSerialWrapper              0x20      /**<        */
00104
00105   #define hsUninstallSerialWrapper        0x21          /**<        */
00106
00107   #define hsPeriodicRegister                  0x22      /**<        */
00108   #define hsPeriodicUnregister            0x23          /**<        */
00109   #define hsPeriodicPeriodsAvailable          0x24          /**<        */
00110
00111   // 0x03523030
00112
00113   // No HsExtension calls added
00114
00115   // 0x03523040
00116
00117   // NOTE: Be sure to update 68000Instrs.h if these change
00118   #define hsSelPrvSetButtonDefault        0x25          /**<        */
00119   #define hsSelPrvFindAppFromIDs              0x26      /**<        */
00120 #endif
00121
00122 #define hsSelAttrGet                      0x27      /**<        */
00123 #define hsSelAttrSet                      0x28      /**<        */
00124
00125 #define hsSelKeyCurrentStateExt           0x29          /**<        */
00126 #define hsSelKeySetMaskExt                0x2A      /**<        */
00127
00128 #define hsSelGrfSetStateExt               0x2B      /**<        */
00129 #define hsSelGrfGetStateExt               0x2C      /**<        */
00130
00131 #ifndef HS_STRIP_UNIMPLEMENTED  // not implemented on 5.x yet...
00132   #define hsSelKeyChrToOptChr                 0x2D      /**<        */
00133   #define hsSelKeyChrToRegChr                 0x2E      /**<        */
00134   #define hsSelPrvKeyHandleEvent              0x2F      /**<        */
00135   #define hsSelWordCorrectInvoke              0x30      /**<        */
00136   #define hsSelWordCorrectUndo            0x31          /**<        */
00137   #define hsSelPrvUpdateBatteryGadget         0x32          /**<        */
00138   #define hsSelPrvUpdateSignalGadget          0x33          /**<        */
00139 #endif
00140
00141 #define hsSelStatusSetGadgetType          0x34          /**<        */
00142
00143 #ifndef HS_STRIP_UNIMPLEMENTED  // not implemented on 5.x yet...
00144   #define hsSelSysKeyboardReferenceDialog     0x35          /**<        */
00145 #endif
00146
00147 #define hsSelPutObjectAfterTitle          0x36          /**<        */
00148
00149 #define hsSelEvtMetaEvent                 0x37      /**<        */
00150
00151 #define hsSelStatusUpdateGadgets          0x38          /**<        */
00152
00153 #ifndef HS_STRIP_UNIMPLEMENTED      // not implemented on 5.x yet...
00154   #define hsSelLstPopupListExt            0x39          /**<        */
00155   #define hsSelDmCreateDatabasesFromImages  0x3A            /**< DO NOT CHANGE used in object patch! */
00156   #define hsSelPrvLaunchDemoApp           0x3B          /**< DO NOT CHANGE used in object patch! */
00157   #define hsSelPrefGetAppKeyCreator       0x3C          /**<        */
00158 #endif
00159
00160 #define hsSelUtilFrmDoDialogWithCallback  0x3D              /**<        */
00161
00162   #define hsSelHsGetTrapAddress           0x3E          /**<        */
00163
00164
00165 #ifndef HS_STRIP_UNIMPLEMENTED  // not implemented on 5.x yet...
00166   #define hsSelHsSetTrapAddress           0x3F          /**<        */
00167 #endif
00168
00169   #define hsSelUnimplemented                  0x40      /**<        */
00170
00171 #ifndef HS_STRIP_UNIMPLEMENTED  // not implemented on 5.x yet...
00172   #define hsSelIndicator                      0x41  /**<        */
00173 #endif
00174
00175   #define hsSelUtilSclUpdateScrollBar         0x42          /**<        */
00176   #define hsSelUtilSclScroll                  0x43      /**<        */
00177   #define hsSelUtilSclScrollPage              0x44      /**<        */
00178
00179 #ifndef HS_STRIP_UNIMPLEMENTED  // not implemented on 5.x yet...
00180   #define hsSelPrvInitPostProcess             0x45      /**<        */
00181   #define hsSelPostProcPopupList              0x46      /**<        */
00182
00183   #define hsSelPeriodicUnregisterFromSelf     0x47          /**<        */
00184 #endif
00185
00186   #define hsSelNetworkDropConnection          0x48          /**<        */
00187
00188 #ifndef HS_STRIP_UNIMPLEMENTED  // not implemented on 5.x yet...
00189   #define hsSelPrvSetupGoToCustomForm             0x49      /**< DO NOT CHANGE used in object patch! */
00190   #define hsSelPrvSetupInstallFormEventHandler  0x4A            /**< DO NOT CHANGE used in object patch! */
00191
00192 #endif
00193   #define hsSelUtilSliHandleKeyDown       0x4B          /**<        */
00194   #define hsSelUtilWinGetMaxDepth             0x4C      /**<        */
00195
00196 #define hsSelLightMode                    0x4D      /**<        */
00197 #define hsSelLightCircumstance            0x4E          /**<        */
00198
00199 #define hsSelUtilBbutInstallFromResource  0x4F              /**<        */
00200 #define hsSelUtilBbutHitBigButton         0x50          /**<        */
00201 #define hsSelUtilFrmDoDialog              0x51          /**<        */
00202
00203 #define hsSelUtilStrCSpn                  0x52      /**<        */
00204 #define hsSelUtilFrmDoTimedDialog         0x53              /**<        */
00205
00206 // NOTE: Please use up reserved spaces during
00207 // 3.5H5 development; this will reduce merge
00208 // issues...
00209
00210 #ifndef HS_STRIP_UNIMPLEMENTED  // not implemented on 5.x yet...
00211   #define hsSelReserved352H5_54           0x54          /**<        */
00212   #define hsSelReserved352H5_55           0x55          /**<        */
00213   #define hsSelReserved352H5_56           0x56          /**<        */
00214   #define hsSelReserved352H5_57           0x57          /**<        */
00215   #define hsSelReserved352H5_58           0x58          /**<        */
00216   #define hsSelReserved352H5_59           0x59          /**<        */
00217   #define hsSelReserved352H5_5A           0x5A          /**<        */
00218   #define hsSelReserved352H5_5B           0x5B          /**<        */
00219   #define hsSelReserved352H5_5C           0x5C          /**<        */
00220   #define hsSelReserved352H5_5D           0x5D          /**<        */
00221
00222   // NOTE: Please use up reserved spaces during
00223   // 3.5H6 development; this will reduce merge
00224   // issues...
00225
00226   #define hsSelReserved352H6_5E           0x5E          /**<        */
00227   #define hsSelReserved352H6_5F           0x5F          /**<        */
00228   #define hsSelReserved352H6_60           0x60          /**<        */
00229   #define hsSelReserved352H6_61           0x61          /**<        */
00230   #define hsSelReserved352H6_62           0x62          /**<        */
00231   #define hsSelReserved352H6_63           0x63          /**<        */
00232   #define hsSelReserved352H6_64           0x64          /**<        */
00233   #define hsSelReserved352H6_65           0x65          /**<        */
00234   #define hsSelReserved352H6_66           0x66          /**<        */
00235   #define hsSelReserved352H6_67           0x67          /**<        */
00236   #define hsSelReserved352H6_68           0x68          /**<        */
00237   #define hsSelReserved352H6_69           0x69          /**<        */
00238   #define hsSelReserved352H6_6A           0x6A          /**<        */
00239 #endif
00240
00241 // 0x04103010
00242 #ifndef HS_STRIP_UNIMPLEMENTED  // not implemented on 5.x yet...
00243   #define hsSelPrvShowKeyboardLockOnDialog  0x6B            /**<        */
00244   #define hsSelPrvHandleKeyboardLock          0x6C          /**<        */
00245 #endif
00246
00247   #define hsSelSpringboardNotSupported    0x6D              /**<        */
00248
00249 // Reserve some traps for pre-OS5 development
00250 #ifndef HS_STRIP_UNIMPLEMENTED  // not implemented on 5.x yet...
00251   #define hsSelReserved41_6E                0x6E            /**<        */
00252   #define hsSelReserved41_6F                0x6F            /**<        */
00253   #define hsSelReserved41_70                0x70            /**<        */
00254   #define hsSelReserved41_71                0x71            /**<        */
00255   #define hsSelReserved41_72                0x72            /**<        */
00256 #endif
00257
00258 /**
00259  * @name OS-5
00260  *
00261  */
00262 /*@{*/
00263 #define hsSelUtilGetObjectUsable          0x73              /**<        */
00264 #define hsSelUtilFrmGetDefaultButtonID    0x74              /**<        */
00265 #define hsSelUtilFrmGetEventHandler       0x75              /**<        */
00266 #define hsSelUtilLstGetItemsText          0x76              /**<        */
00267 #define hsSelUtilLstGetTopItem            0x77              /**<        */
00268 #define hsSelUtilCtlGetControlStyle       0x78              /**<        */
00269 /*@}*/
00270
00271 /**
00272  * @name Trace Functions
00273  *
00274  */
00275 /*@{*/
00276 #define hsSelTraceLevelsSet               0x79      /**<        */
00277 #define hsSelTraceLevelsGet               0x7A      /**<        */
00278 #define hsSelTrace                        0x7B  /**<        */
00279 #define hsSelTraceData                    0x7C      /**<        */
00280 #define hsSelTraceRecordsDump             0x7D          /**<        */
00281 #define hsSelTraceClear                   0x7E      /**<        */
00282 #define hsSelTraceOutputLevelsSet         0x7F          /**<        */
00283 #define hsSelTraceOutputLevelsGet         0x80          /**<        */
00284 #define hsSelTraceText                    0x81      /**<        */
00285 #define hsSelTraceFunction                0x82      /**<        */
00286 #define hsSelTraceError                   0x83      /**<        */
00287 #define hsSelTraceFunctionError           0x84          /**<        */
00288 #define hsSelTraceEvent                   0x85      /**<        */
00289 /*@}*/
00290
00291 #define hsSelGetPhoneLibrary              0x86              /**<        */
00292 #define hsSelUtilFrmSetLabel              0x87          /**<        */
00293 #define hsSelUtilCtlGetFont               0x88      /**<        */
00294
00295 /**
00296  * @name Mutex functions -- 68K bridge to ARM-native functions
00297  *
00298  */
00299 /*@{*/
00300 #define hsSelUtilMutexCreate              0x89          /**<        */
00301 #define hsSelUtilMutexDelete              0x8A          /**<        */
00302 #define hsSelUtilMutexReserve             0x8B          /**<        */
00303 #define hsSelUtilMutexRelease             0x8C          /**<        */
00304 /*@}*/
00305
00306 #define hsSelGetARMActiveFormPtr          0x8E              /**<        */
00307
00308 #define hsSelTwoFontSelect                0x8F      /**<        */
00309 #define hsSelOpenDialNumberDialog         0x90          /**<        */
00310 #define hsSelTurnRadioOn                  0x91      /**<        */
00311 #define hsSelCreateNewMessage             0x92          /**<        */
00312 #define hsSelCreateNewEmail               0x93      /**<        */
00313 #define hsSelBrowseUrl                    0x94      /**<        */
00314
00315 #define hsSelNavGetFocusColor             0x95          /**<        */
00316 #define hsSelNavSetFocusColor             0x96          /**<        */
00317 #define hsSelNavGetFocusRingInfo          0x97          /**<        */
00318 #define hsSelNavDrawFocusRing             0x98          /**<        */
00319 #define hsSelNavRemoveFocusRing           0x99          /**<        */
00320 #define hsSelNavLstGetTempSelection       0x9A          /**<        */
00321 #define hsSelNavLstSetTempSelection       0x9B          /**<        */
00322 // Trap defined at the end of the list
00323 //#define hsSelNavObjectTakeFocus             0xB7
00324
00325 #define hsSelIndicatorState               0x9C      /**<        */
00326
00327 #define hsSelKeysPressed                  0x9D      /**<        */
00328 #define hsSelKeyEnableKey                 0x9E      /**<        */
00329 #define hsSelKeyChrCodeToKeyCode          0x9F          /**<        */
00330 #define hsSelKeyKeyCodeToChrCode          0xA0          /**<        */
00331 #define hsSelKeyEventIsFromKeyboard       0xA1          /**<        */
00332
00333 #define hsSelTraceContextInit             0xA2              /**<        */
00334 #define hsSelTraceContextDelete           0xA3              /**<        */
00335
00336 #define hsSelDoSaveAsDialog               0xA4              /**<        */
00337 #define hsSelExgSelectTarget              0xA5              /**<        */
00338 #define hsSelExgLocalAccept               0xA6              /**<        */
00339 #define hsSelExgLocalDisconnect           0xA7              /**<        */
00340
00341 #define hsSelUtilAttnNagInfo              0xA8          /**<        */
00342
00343 #define hsSelCrashLogGetLast              0xA9          /**<        */
00344 #define hsSelCrashLogDisplayLast          0xAA          /**<        */
00345
00346 #define hsSelTxtPrepFindString            0xAB          /**<        */
00347
00348 #define hsSelUtilFrmSetHelpID             0xAC          /**<        */
00349 #define hsSelUtilFrmSetLabelFont          0xAD          /**<        */
00350
00351 // NOTE: This trap selector was never implemented and never used, therefore it is safe to be reassigned
00352 #define hsNeverUsedBeforeAvailableForUse1 0xAE              /**<        */
00353
00354 /**
00355  * @name Additional Trace Utility functions
00356  *
00357  */
00358 /*@{*/
00359 #define hsSelTraceOpenDB                  0xB0              /**<        */
00360 #define hsSelTraceCloseDB                 0xB1              /**<        */
00361 /*@}*/
00362
00363 #define hsSelSupressDbgLockout            0xB2          /**<        */
00364 #define hsSelIsDbgLockoutSupressed        0xB3          /**<        */
00365
00366 #define hsSelKeyStop                      0xB4      /**<        */
00367
00368 #define hsSelGetVersionString             0xB5          /**<        */
00369
00370 #define hsSelUtilEnableAttentionMgr       0xB6          /**<        */
00371
00372 #define hsSelNavObjectTakeFocus           0xB7          /**<        */
00373
00374 #define hsSelPostProcessPopupList         0xB8          /**<        */
00375
00376 #define hsSelTraceSetMaxRecords           0xB9          /**<        */
00377 #define hsSelTraceGetMaxRecords           0xBA          /**<        */
00378
00379 /**
00380  * @name multi-byte friendly Txt routines
00381  *
00382  */
00383 /*@{*/
00384 #define hsSelTxtNumChars                  0xBB      /**<        */
00385 #define hsSelTxtTruncateString            0xBC          /**<        */
00386 #define hsSelTxtIsAscii                   0xBD      /**<        */
00387 /*@}*/
00388
00389 #define hsSelWaitForGPRSAttach            0xBE          /**<        */
00390 #define hsSelIsHTTPLibraryLoaded          0xBF              /**<        */
00391
00392 /**
00393  * @name This range is reserved for last-minute fixes in OS-5H1-C/D/E
00394  *
00395  */
00396 /*@{*/
00397 #define hsSelReserved5H1_C0               0xC0      /**<        */
00398 #define hsSelReserved5H1_C1               0xC1      /**<        */
00399 #define hsSelReserved5H1_C2               0xC2      /**<        */
00400 #define hsSelReserved5H1_C3               0xC3      /**<        */
00401 /*@}*/
00402
00403 /**
00404  * @name New AcDc traps
00405  *
00406  */
00407 /*@{*/
00408 #define hsSelDispatchService              0xC4          /**<        */
00409
00410 #define hsSelOpenDialNumberDialogExt      0xC5              /**<        */
00411
00412 // This trap is technically free.  It was temporarily used during Treo650 development but we never shipped
00413 //  with it.  We continue to define and dispatch it just to be extra safe.  There's a small chance that
00414 //  not all apps were properly transitioned to the PmUIUtil version of this call during Treo650 development.
00415 //  3rd party apps should have never had access to this function because it is defined in a palmOne
00416 //  internal header and apps built with the Treo650 ROM should've always be built against the latest trap
00417 //  definitions.  There's the slight possibility that palmOne apps built as components, however, were
00418 //  never built against the newest trap definitions.
00419 #define hsSelAttnGetAttentionExt          0xC6          /**<        */
00420
00421 #define hsSelUtilBbutInstallNewButton     0xC7              /**<        */
00422
00423 #define hsSelUtilBbutSetLabel             0xC8          /**<        */
00424
00425 // This trap is technically free.  It was temporarily used during Treo650 development but we never shipped
00426 //  with it.  We continue to define and dispatch it just to be extra safe.  There's a small chance that
00427 //  not all apps were properly transitioned to the PmUIUtil version of this call during Treo650 development.
00428 //  3rd party apps should have never had access to this function because it is defined in a palmOne
00429 //  internal header and apps built with the Treo650 ROM should've always be built against the latest trap
00430 //  definitions.  There's the slight possibility that palmOne apps built as components, however, were
00431 //  never built against the newest trap definitions.
00432 #define hsSelAttnUpdateExt                0xC9      /**<        */
00433
00434 #define hsSelUtilAttnIndicatorAllow       0xCA          /**<        */
00435
00436 #define hsSelUtilBbutSetBitmap            0xCB          /**<        */
00437
00438 #define hsSelMenuSetCurMenuCurItem        0xCC          /**<        */
00439
00440 #define hsSelTraceSetCommitInterval       0xCD          /**<        */
00441 #define hsSelTraceGetCommitInterval       0xCE          /**<        */
00442
00443 #define hsSelWriteROMTokens               0xCF              /**<        */
00444 /*@}*/
00445
00446 // for application to get current light circumstance
00447 #define hsGetCurrentLightCircumstance     0xD0              /**<        */
00448
00449 #define hsSelShowHighVolAlert             0xD1
00450
00451 #define hsSelStartMemoryTracing           0xD2
00452 // WARNING! Please do not re-order the trap numbers.
00453 // If you need to add a new trap, add it to the bottom of the list!!
00454
00455 // WARNING!  Leave this one at the end!
00456 // When adding new traps, renumber it
00457 // to one greater than the last trap.
00458 #define hsSelLast                         0xD3          /**<        */
00459
00460
00461
00462 #define hsNumSels    (hsSelLast - hsSelectorBase)           /**<        */
00463
00464
00465 #endif    // __HS_EXT_TRAPS_H__
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:53 2008 for Palm API Guide


Header Files » Incs » 68k » system

HsExtUtilBigButton.h

Go to the documentation of this file.
00001 /******************************************************************************
00002  * Copyright (c) 2004 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  *****************************************************************************/
00005 /**
00006  *
00007  * @ingroup SystemDef
00008  *
00009  */
00010
00011 /**
00012  * @file    HsExtUtilBigButton.h
00013  * @version 3.0
00014  * @date    12/18/2001
00015  *
00016  * Description:
00017  *    This file contains routines for managing 'big' buttons,
00018  *    which are thumbable buttons with a bitmap and some text
00019  *    (common in applications designed to be used for telephony)
00020  *
00021  *
00022  * History:
00023  *    2001-12-18  dia   Creaded by Doug Anderson
00024  *    2002-01-22  dia   Supports \r or \n as line endings now.
00025  *              Note that '\r\n' is not supported (it's
00026  *              treated as two separate line endings)
00027  *
00028  */
00029
00030
00031 #ifndef _HS_EXT_UTIL_BIG_BUTTON_H
00032 #define _HS_EXT_UTIL_BIG_BUTTON_H
00033
00034
00035 // Here's a sample usage:
00036 // HEX "bBut" rscBigYesNoDialogFormID
00037 //    hsBigButtonMappingVersion0.w              // version
00038 //
00039 //    hsBigButtonFlagNone                       // flags
00040 //    hsBigButtonFontStd                        // font
00041 //    rscBigYesNoDialogYesButtonID.w            // gadgetID
00042 //    hsBigButtonGreenCheckBitmapID.w           // bitmapID
00043 //    hsBigButtonYesStringID.w                  // stringID
00044 //
00045 //    hsBigButtonFlagNone                       // flags
00046 //    hsBigButtonFontStd                        // font
00047 //    rscBigYesNoDialogNoButtonID.w             // gadgetID
00048 //    hsBigButtonRedXBitmapID.w                 // bitmapID
00049 //    hsBigButtonNoStringID.w                   // stringID
00050
00051
00052 /***************************************************************
00053  *  Function:    HsUtilBbutInstallFromResource
00054  *
00055  *  Summary:
00056  *    Installs big buttons on the given form based on a 'bBut'
00057  *    resource with the same ID.  A 'bBut' resource is basically
00058  *    just an array of HsBigButtonMappingType.
00059  *
00060  *    Once installed, the gadget will get events from PalmOS and
00061  *    will sent a 'gadgetMisc' event with the selector
00062  *    bbutGadgetMiscSelectSelector when selected.
00063  *
00064  *  IMPORTANT:
00065  *    + The form must not be visible when you install the buttons,
00066  *      since we don't draw them (it turns out to be impossible to
00067  *      check whether the gadget is visible without peeking
00068  *      into its data structure, which we can only do from the
00069  *      event handler).
00070  *
00071  *  Parameters:
00072  *    frmP    IN    The form to install the big buttons on.
00073  *
00074  *  Returns:
00075  *    nothing
00076  *
00077  *  Called By:
00078  *    user
00079  *
00080  *  History:
00081  *    2001-12-17  dia   Created based on PhoneApp's CustomButton
00082  *    2001-12-19  dia   Renamed, adding 'FromResource' just in
00083  *                      case we add more install functions (and
00084  *                      because I changed the resource slightly)
00085  *
00086  ****************************************************************/
00087
00088
00089 /**
00090  *  @brief
00091  *
00092  *  @param frmP:    IN:
00093  *  @retval Error code.
00094  **/
00095 Err
00096 HsUtilBbutInstallFromResource (FormType* frmP)
00097                 SYS_SEL_TRAP (sysTrapHsSelector, hsSelUtilBbutInstallFromResource);
00098
00099 /**
00100  *  @brief
00101  *
00102  *  @param frmP:    IN:
00103  *  @param gadgetID:    IN:
00104  *  @param textP:   IN:
00105  *  @param font:    IN:
00106  *  @param flags:   IN:
00107  *  @retval Error code.
00108  **/
00109 void
00110 HsUtilBbutInstallNewButton (FormType* frmP, UInt16 gadgetID, const Char* textP, FontID font, UInt8 flags)
00111                 SYS_SEL_TRAP (sysTrapHsSelector, hsSelUtilBbutInstallNewButton);
00112 /**
00113  *  @brief
00114  *
00115  *  @param frmP:    IN:
00116  *  @param gadgetID:    IN:
00117  *  @param newLabel:    IN:
00118  *  @retval Error code.
00119  **/
00120 void
00121 HsUtilBbutSetLabel (FormType* frmP, UInt16 gadgetID, const Char* newLabel)
00122                 SYS_SEL_TRAP (sysTrapHsSelector, hsSelUtilBbutSetLabel);
00123
00124
00125 /**
00126  *  @brief
00127  *
00128  *  @param frmP:    IN:
00129  *  @param gadgetID:    IN:
00130  *  @param bitmapP: IN:
00131  *  @retval Error code.
00132  **/
00133 void
00134 HsUtilBbutSetBitmap (FormType* frmP, UInt16 gadgetID, const BitmapPtr bitmapP)
00135                 SYS_SEL_TRAP (sysTrapHsSelector, hsSelUtilBbutSetBitmap);
00136
00137 /***************************************************************
00138  *  Function:    HsUtilBbutHitBigButton
00139  *
00140  *  Summary:
00141  *    Like CtlHitControl, but for big buttons.
00142  *
00143  *  Notes:
00144  *    + Due to the fact that PalmOS lacks accessors for
00145  *      gadgets directly, this function (and any others that
00146  *      refer to a big button's gadget) takes a form pointer
00147  *      and an index instead of a FormGadgetType*.
00148  *
00149  *  Parameters:
00150  *    frmP            IN    The form containing the big button's
00151  *                          gadget.
00152  *    gadgetIndex     IN    The index of the big button's gadget.
00153  *
00154  *  Returns:
00155  *    nothing
00156  *
00157  *  Called By:
00158  *    user
00159  *
00160  *  History:
00161  *    2001-12-19  dia   Created.
00162  *
00163  ****************************************************************/
00164
00165 /**
00166  *  @brief
00167  *
00168  *  @param frmP:    IN:
00169  *  @param gadgetIndex: IN:
00170  *  @retval Error code.
00171  **/
00172 void
00173 HsUtilBbutHitBigButton (FormType* frmP, UInt16 gadgetIndex)
00174                 SYS_SEL_TRAP (sysTrapHsSelector, hsSelUtilBbutHitBigButton);
00175
00176
00177
00178
00179 #endif // _HS_EXT_UTIL_BIG_BUTTON_H
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:53 2008 for Palm API Guide


Header Files » Incs » common » system

HsExtUtilBigButtonCommon.h

Go to the documentation of this file.
00001 /**
00002  * \file HsExtUtilBigButtonCommon.h
00003  *
00004  * <Common code for Big Buttons that can be used by ARM and 68K code.>
00005  *
00006  * <This file contains all defines and enums that are used by Big Buttons.
00007  * There are some structs here too that might need to be moved to 68K/ARM
00008  * specific code. Moved code from HsExtUtilBigButton.h >
00009  *
00010  * \license
00011  *
00012  *    Copyright (c) 2002 Handspring Inc., All Rights Reserved
00013  *
00014  * \author  Arun Mathias
00015  *
00016  * $Id: //depot/Components/Extensions/HsExtensions/1.0E/Incs/IncsPublic/Common/HsExtUtilBigButtonCommon.h#2 $
00017  *
00018  *****************************************************************************/
00019
00020 #ifndef __HS_EXT_UTIL_BIG_BUTTON_COMMON_H__
00021
00022 #define __HS_EXT_UTIL_BIG_BUTTON_COMMON_H__
00023
00024 // *******************************************************************************
00025 // *******************************************************************************
00026 // *                                                                             *
00027 // * !!!!!!!!!!THIS FILE IS DEPRECATED.  DO NOT MAKE CHANGES TO IT!!!!!!!!!!!!!  *
00028 // *                                                                             *
00029 // *******************************************************************************
00030 // *******************************************************************************
00031 // *******************************************************************************
00032 // *                                                                             *
00033 // * All new definitions should go into PmSysGadgetLibCommon.h.  This file       *
00034 // * remains simply to maintain backwards compatibility.                         *
00035 // *                                                                             *
00036 // *******************************************************************************
00037 // *******************************************************************************
00038
00039 /**
00040  * This selector gets sent with a frmGadgetMiscEvent to let you know that the
00041  * gadget has been selected.  The numbers are picked semi-randomly so that generic
00042  * code (like HsUtilFrmDoDialogWithCallback()) can tell that this is actually
00043  * a button press without doing the wrong thing for other people's gadget events.
00044  *
00045  * Note that in most code, you shouldn't need to worry about checking the data,
00046  * since you know exactly what gadgets are on your form and what kind of events
00047  * they send.
00048  **/
00049 #define bbutGadgetMiscSelectSelector  7014                  /**< Randomish number so people can
00050                                                                easily detect big button presses */
00051 #define bbutGadgetMiscSelectData      ((void*)0xBADC0DE1)   /**< Magic # to make conflicts even less
00052                                                                likely for  detecting big  button presses.*/
00053
00054
00055 /**
00056  * This is the type of big button resources.  The ID should match the ID of
00057  * the form...
00058  **/
00059 #define hsBigButtonRscType                  'bBut'         /**< Registered: yes */
00060
00061
00062 /**
00063  * This is the structure of a single big button mapping...
00064  **/
00065 typedef struct
00066   {
00067     UInt8 flags;
00068     UInt8 font;
00069
00070     UInt16 gadgetID;
00071
00072     UInt16 bitmapID;
00073     UInt16 stringID;
00074   }
00075 HsBigButtonMappingType;
00076
00077 /**
00078  * This is the structure of a big button resource...
00079  **/
00080 typedef struct
00081   {
00082     UInt16 version;
00083     HsBigButtonMappingType mapArr[0];
00084   }
00085 HsBigButtonReourceType;
00086
00087 #endif // ifndef __HS_EXT_UTIL_BIG_BUTTON_COMMON_H__
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:53 2008 for Palm API Guide


Header Files » Incs » common » system

HsExtUtilBigButtonRsc.h

Go to the documentation of this file.
00001 //**************************************************************
00002 //
00003 // Project:
00004 //    Handspring PalmOS System Extensions
00005 //
00006 // Copyright info:
00007 //    Copyright 2001 Handspring, Inc. All Rights Reserved.
00008 //
00009 // FileName:
00010 //    HsExtUtilBigButtonRsc.h
00011 //
00012 // Description:
00013 //    This file contains resource #defines for
00014 //    HsExtUtilBigButton.h and is suitable for including in
00015 //    '.rcp' files.
00016 //
00017 // ToDo:
00018 //
00019 // History:
00020 //    2001-12-18  dia   Creaded by Doug Anderson
00021 //    2002-01-03  dia   We now have a reserved range to keep
00022 //                      real bitmaps and strings in the resource
00023 //                      chain, so we don't need the flags to tell
00024 //                      us whether the user wanted ours; moved
00025 //                      resource IDs to HsResourceIDs.h.
00026 //
00027 //***************************************************************/
00028
00029
00030 #ifndef __HS_EXT_UTIL_BIG_BUTTON_RSC__H__
00031
00032 #define __HS_EXT_UTIL_BIG_BUTTON_RSC__H__ 1
00033
00034
00035 // *******************************************************************************
00036 // *******************************************************************************
00037 // *                                                                             *
00038 // * !!!!!!!!!!THIS FILE IS DEPRECATED.  DO NOT MAKE CHANGES TO IT!!!!!!!!!!!!!  *
00039 // *                                                                             *
00040 // *******************************************************************************
00041 // *******************************************************************************
00042 // *******************************************************************************
00043 // *                                                                             *
00044 // * All new definitions should go into PmSysGadgetLibBbutRscCommon.h. This file *
00045 // * remains simply to maintain backwards compatibility.                         *
00046 // *                                                                             *
00047 // *******************************************************************************
00048 // *******************************************************************************
00049
00050
00051 // Here's a sample usage:
00052 // HEX "bBut" rscBigYesNoDialogFormID
00053 //    hsBigButtonMappingVersion0.w              // version
00054 //
00055 //    hsBigButtonFlagNone                       // flags
00056 //    hsBigButtonFontStd                        // font
00057 //    rscBigYesNoDialogYesButtonID.w            // gadgetID
00058 //    hsBigButtonGreenCheckBitmapID.w           // bitmapID
00059 //    hsBigButtonYesStringID.w                  // stringID
00060 //
00061 //    hsBigButtonFlagNone                       // flags
00062 //    hsBigButtonFontStd                        // font
00063 //    rscBigYesNoDialogNoButtonID.w             // gadgetID
00064 //    hsBigButtonRedXBitmapID.w                 // bitmapID
00065 //    hsBigButtonNoStringID.w                   // stringID
00066
00067
00068
00069 // Use this version
00070 // ----------------
00071 #define hsBigButtonMappingVersion0          0
00072
00073
00074 // Use these flags
00075 // ---------------
00076 #define hsBigButtonFlagNone                 0x00
00077 #define hsBigButtonFlagNoBorder             0x01  // Don't draw the border...
00078 #define hsBigButtonFlagNoBackground         0x02  // Don't draw the background of the button
00079 #define hsBigButtonFlagNoBorderOrBackground 0x03  // Combination for Palm-rc...
00080
00081 // Use these fonts
00082 // ---------------
00083 #define hsBigButtonFontStd                  0
00084 #define hsBigButtonFontBold                 1
00085 #define hsBigButtonFontLarge                2
00086 #define hsBigButtonFontSymbol               3
00087 #define hsBigButtonFontSymbol11             4
00088 #define hsBigButtonFontSymbol7              5
00089 #define hsBigButtonFontLed                  6
00090 #define hsBigButtonFontLargeBold            7
00091
00092
00093
00094 #endif // ifndef __HS_EXT_UTIL_BIG_BUTTON_RSC_H__
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:53 2008 for Palm API Guide


Header Files » Incs » 68k » system

HsHelper.h

Go to the documentation of this file.
00001 /******************************************************************************
00002  * Copyright (c) 2004 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  *****************************************************************************/
00005
00006 /**
00007  * @file    HsHelper.h
00008  * @version 1.0
00009  * @date
00010  *  Description:
00011  *  Public header file for the Handspring helper functions
00012  */
00013
00014 #ifndef HSHELPER_H
00015 #define HSHELPER_H
00016
00017 #include <Helper.h>
00018 #define sysNotifyHelperEvent   'hlpr'
00019
00020 /**
00021  * MACRO: HelperEnumerateEnqueueEntry
00022  *
00023  * Enqueues a node of type HelperEvtEnumerateNodeType. Each node
00024  *  must be individually allocated from the heap by the helper.
00025  *
00026  * PROTOTYPE:
00027  *    void HelperEnumNodeEnqueue(HelperNotifyEnumerateType* enumEvtDataP,
00028  *                               HelperNotifyEnumerateListType* entryP);
00029  */
00030 #define HelperEnumerateEnqueueEntry(enumEvtDataP, entryP)     \
00031   do                                                  \
00032     {                                                 \
00033     (entryP)->nextP = (enumEvtDataP)    ;     \
00034     (enumEvtDataP) = (entryP);                \
00035     }                                                 \
00036   while (0)
00037
00038
00039 /**
00040  * @brief Param structure for pmNotifyGetNewMsgCountFromHelper notifications
00041  *
00042  */
00043 typedef struct
00044 {
00045   UInt32 helperServiceClass;            /**<        */
00046 } PmGetNewMsgCountNotifyParamType, * PmGetNewMsgCountNotifyParamPtr;
00047
00048
00049 /**
00050  * @brief Param structure for pmNotifyBroadcastNewMsgCount notifications
00051  *
00052  */
00053 typedef struct
00054 {
00055   UInt32  helperServiceClass;           /**<        */
00056   UInt16  msgCount;             /**<        */
00057 } PmBroadcastNewMsgCountNotifyParamType, * PmBroadcastNewMsgCountNotifyParamPtr;
00058
00059 #endif
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:53 2008 for Palm API Guide


Header Files » Incs » common » system

HsKeyCodes.h

Go to the documentation of this file.
00001 /******************************************************************************
00002  * Copyright (c) 2004 PalmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  *****************************************************************************/
00005
00006 /**
00007  *
00008  * @ingroup PmKeyLib
00009  *
00010  */
00011
00012 /**
00013  * @file    HsKeyCodes.h
00014  * @version 1.0
00015  * @date
00016  *
00017  *        This file defines the key codes.  These match the vchrs for
00018  *        virtual key characters, but vchars are only used in the legacy
00019  *        event loop.  Everywhere else, they are considered deprecated
00020  *        in favor of key now.  These are NOT ascii, unicode or otherwise
00021  *        although, for standard QWERTY US keboards, the key codes for
00022  *        the letters are the same as the lowercase ASCII values, but
00023  *        only so it's easier to determine what you're looking at.
00024  *
00025  * Note:
00026  *        This is a Palm OS 6 header that we got early in order to make
00027  *        the Handspring key driver as close as possible to what it
00028  *        should be in the future. This header will be depricated in
00029  *        favor of Palm's official header once it's in their SDK.
00030  *
00031  */
00032
00033 #ifndef __KEY_CODES_H__
00034 #define __KEY_CODES_H__
00035
00036
00037 /*
00038  *  How are these different from the 5 way jog?
00039  *      chrLeftArrow
00040  *      chrRightArrow
00041  *      chrUpArrow
00042  *      chrDownArrow
00043  */
00044
00045 /*
00046  *  Keys with a "HS" comment are unique to Handspring
00047  */
00048
00049 typedef enum {
00050     keyNull                         = 0x0000,
00051
00052     keyBackspace                    = 0x0008,
00053     keyTab                          = 0x0009,
00054     keyReturn                       = 0x000a,
00055     keyPageUp                       = 0x000b,
00056     keyPageDown                     = 0x000c,
00057     keyNumericEnter                 = 0x000d,
00058
00059     keyEscape                       = 0x001b,
00060
00061     keyLeftArrow                    = 0x001c,
00062     keyRightArrow                   = 0x001d,
00063     keyUpArrow                      = 0x001e,
00064     keyDownArrow                    = 0x001f,
00065
00066     keySpace                        = 0x0020,
00067
00068     keySingleQuote                  = 0x0027,
00069     keyComma                        = 0x002c,
00070     keyDash                         = 0x002d,
00071     keyPeriod                       = 0x002e,
00072     keySlash                        = 0x002f,
00073
00074     keyZero                         = 0x0030,
00075     keyOne                          = 0x0031,
00076     keyTwo                          = 0x0032,
00077     keyThree                        = 0x0033,
00078     keyFour                         = 0x0034,
00079     keyFive                         = 0x0035,
00080     keySix                          = 0x0036,
00081     keySeven                        = 0x0037,
00082     keyEight                        = 0x0038,
00083     keyNine                         = 0x0039,
00084
00085     keySemiColon                    = 0x003b,
00086     keyLessThan                     = 0x003c, // many European keyboards have this key (next to the left shift)
00087     keyEquals                       = 0x003d,
00088     keyAt                           = 0x0040,
00089
00090     keyOpenBracket                  = 0x005b,
00091     keyBackslash                    = 0x005c,
00092     keyCloseBracket                 = 0x005d,
00093     keyBacktick                     = 0x0060,
00094
00095     keyA                            = 0x0061,
00096     keyB                            = 0x0062,
00097     keyC                            = 0x0063,
00098     keyD                            = 0x0064,
00099     keyE                            = 0x0065,
00100     keyF                            = 0x0066,
00101     keyG                            = 0x0067,
00102     keyH                            = 0x0068,
00103     keyI                            = 0x0069,
00104     keyJ                            = 0x006a,
00105     keyK                            = 0x006b,
00106     keyL                            = 0x006c,
00107     keyM                            = 0x006d,
00108     keyN                            = 0x006e,
00109     keyO                            = 0x006f,
00110     keyP                            = 0x0070,
00111     keyQ                            = 0x0071,
00112     keyR                            = 0x0072,
00113     keyS                            = 0x0073,
00114     keyT                            = 0x0074,
00115     keyU                            = 0x0075,
00116     keyV                            = 0x0076,
00117     keyW                            = 0x0077,
00118     keyX                            = 0x0078,
00119     keyY                            = 0x0079,
00120     keyZ                            = 0x007a,
00121
00122     // Some old virtual character codes that can also serve as
00123     // physical key codes for actions.
00124     keyNextField                    = 0x0103,
00125     keyMenu                         = 0x0105,
00126     keyLaunch                       = 0x0108,   // HS
00127     keyFind                         = 0x010A,
00128     keyPrevField                    = 0x010C,
00129     keyLockDevice                   = 0x0112,
00130
00131     keyThumbWheelUp                 = 0x012E,   // (JogUp)
00132     keyThumbWheelDown               = 0x012F,   // (JogDown)
00133     keyThumbWheelPush               = 0x0130,   // (JogPress)
00134     keyThumbWheelBack               = 0x0131,   // (JogBack)
00135
00136     keyRockerUp                     = 0x0132,
00137     keyRockerDown                   = 0x0133,
00138     keyRockerLeft                   = 0x0134,
00139     keyRockerRight                  = 0x0135,
00140     keyRockerCenter                 = 0x0136,
00141
00142     keyHard1                        = 0x0204,
00143     keyHard2                        = 0x0205,
00144     keyHard3                        = 0x0206,
00145     keyHard4                        = 0x0207,
00146
00147     keyHardPower                    = 0x0208,
00148     keyHardCradle                   = 0x0209,
00149     keyHardCradle2                  = 0x020A,
00150     keyHardContrast                 = 0x020B,
00151     keyHardAntenna                  = 0x020C,
00152     keyHardBrightness               = 0x020D,
00153
00154     // keyHard 5-10 are for Licensees & Silicon Partners to use.
00155     // That means that this key code might be something totally different on
00156     // a different device.  Be warned.
00157     // (note that values in this range are necessary due to the way
00158     // TxtCharIsHardKey is defined)
00159     keyHard5                        = 0x0214,
00160     keyHard6                        = 0x0215,
00161     keyHard7                        = 0x0216,
00162     keyHard8                        = 0x0217,
00163     keyHard9                        = 0x0218,
00164     keyHard10                       = 0x0219,
00165     keyHard11                       = 0x021A,
00166     keyHard12                       = 0x021B,
00167     keyHard13                       = 0x021C,
00168     keyHard14                       = 0x021D,
00169
00170     // Handspring specific keys
00171     hsKeyMfgTest                    = 0x1600,   // HS
00172     hsKeySymbol                     = 0x1609,   // HS (Keycap says "Alt")
00173     hsKeyRadioPower                 = 0x160C,   // HS
00174
00175     // These are keys that are found on standard computer keyboards
00176     // that aren't covered above
00177
00178     keyLeftShift                    = 0xe000,   // (Handspring shift key)
00179     keyRightShift                   = 0xe001,
00180     keyLeftControl                  = 0xe002,
00181     keyRightControl                 = 0xe003,
00182     keyLeftCommand                  = 0xe004,
00183     keyRightCommand                 = 0xe005,
00184     keyLeftAlt                      = 0xe006,   // (Handspring option key)
00185     keyRightAlt                     = 0xe007,
00186
00187     keySide                         = 0xe008,   // HS (side button)
00188
00189     keyHelp                         = 0xe009,
00190
00191     keyNumLock                      = 0xe00a,
00192     keyScrollLock                   = 0xe00b,
00193     keyCapsLock                     = 0xe00c,
00194
00195     keyInsert                       = 0xe00d,
00196     keyDelete                       = 0xe00e,
00197     keyHome                         = 0xe00f,
00198     keyEnd                          = 0xe010,
00199
00200     keyPrintScreen                  = 0xe011,
00201     keyPause                        = 0xe012,
00202
00203     keyNumericPeriod                = 0xe013,
00204     keyNumericPlus                  = 0xe014,
00205     keyNumericDash                  = 0xe015,
00206     keyNumericAsterisk              = 0xe016,
00207     keyNumericSlash                 = 0xe017,
00208     keyNumericEquals                = 0xe018,
00209
00210     keyNumericZero                  = 0xe020,
00211     keyNumericOne                   = 0xe021,
00212     keyNumericTwo                   = 0xe022,
00213     keyNumericThree                 = 0xe023,
00214     keyNumericFour                  = 0xe024,
00215     keyNumericFive                  = 0xe025,
00216     keyNumericSix                   = 0xe026,
00217     keyNumericSeven                 = 0xe027,
00218     keyNumericEight                 = 0xe028,
00219     keyNumericNine                  = 0xe029,
00220
00221     keyF1                           = 0xe031,
00222     keyF2                           = 0xe032,
00223     keyF3                           = 0xe033,
00224     keyF4                           = 0xe034,
00225     keyF5                           = 0xe035,
00226     keyF6                           = 0xe036,
00227     keyF7                           = 0xe037,
00228     keyF8                           = 0xe038,
00229     keyF9                           = 0xe039,
00230     keyF10                          = 0xe03a,
00231     keyF11                          = 0xe03b,
00232     keyF12                          = 0xe03c,
00233     keyF13                          = 0xe03d,
00234     keyF14                          = 0xe03e,
00235     keyF15                          = 0xe03f,
00236
00237
00238     // These are multimedia, internet or otherwise interesting buttons
00239     // that are sometimes found on keyboards or devices.
00240
00241     keyBack                         = 0xe050,
00242     keyForward                      = 0xe051,
00243     keyStopInternet                 = 0xe052,
00244     keyRefresh                      = 0xe053,
00245     keySearch                       = 0xe054,
00246     keyFavorites                    = 0xe055,
00247     keyHomePage                     = 0xe056,
00248
00249     keyMail                         = 0xe057,
00250
00251     keyMute                         = 0xe058,
00252     keyVolumeUp                     = 0xe059,
00253     keyVolumeDown                   = 0xe05a,
00254     keyPlay                         = 0xe05b,
00255     keyPauseAudio                   = 0x305c,
00256     keyPlayPause                    = 0xe05d,
00257     keyStopAudio                    = 0xe05e,
00258     keyPrevTrack                    = 0xe05f,
00259     keyNextTrack                    = 0xe060,
00260     keyFastForward                  = 0xe061,
00261     keyRewind                       = 0xe062,
00262     keyEject                        = 0xe063,
00263
00264     keyMedia                        = 0xe064,
00265
00266     keyMyComputer                   = 0xe065,
00267     keyMyDocuments                  = 0xe066,
00268     keyMyMusic                      = 0xe067,
00269     keyMyPictures                   = 0xe068,
00270     keyCalculator                   = 0xe069,
00271
00272     keyLogOff                       = 0xe06a
00273
00274
00275 } KeyCodeType;
00276
00277 #endif  // __KEY_CODES_H__
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:53 2008 for Palm API Guide


Header Files » Incs » common » system

HsKeyCommon.h

Go to the documentation of this file.
00001 /******************************************************************************
00002  * Copyright (c) 2004 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  *****************************************************************************/
00005 /**
00006  *
00007  * @ingroup PmKeyLib
00008  *
00009  */
00010
00011 /**
00012  * @file    HsKeyCommon.h
00013  *
00014  * @brief   Header file with additional keyboard related definitions
00015  *
00016  */
00017
00018 #ifndef   __HS_KEY_COMMON_H__
00019 #define   __HS_KEY_COMMON_H__
00020
00021
00022 #if 0
00023 #pragma mark -------- Incs:Core:System:Chars.h -----------
00024 #endif
00025
00026 #define vchrHardRockerCenter            0x013D  // Character tied directly to rocker-
00027                                                 //  center hardware key.  vchrRockerCenter
00028                                                 //  is associated with select action of
00029                                                 //  rocker-center (which happens on key-up
00030                                                 //  of rocker-center hardware key).
00031
00032 #if 0
00033 #pragma mark -------- Incs:Core:System:KeyMgr.h -----------
00034 #endif
00035
00036 //*********************************************************
00037 // Bit definitions for new hardware keys
00038 //*********************************************************
00039
00040 #define keyBitThumbWheelUp    0x00001000  // Thumb-wheel up
00041 #define keyBitThumbWheelDown  0x00002000  // Thumb-wheel down
00042 #define keyBitThumbWheelPress 0x00004000  // Press/center on thumb-wheel
00043 #define keyBitThumbWheelBack  0x00008000  // Thumb-wheel back button
00044
00045 #define keyBitRockerUp        0x00010000  // 5-way rocker up
00046 #define keyBitRockerDown      0x00020000  // 5-way rocker down
00047 #define keyBitRockerLeft      0x00040000  // 5-way rocker left
00048 #define keyBitRockerRight     0x00080000  // 5-way rocker right
00049 #define keyBitRockerCenter    0x00100000  // 5-way rocker center/press
00050
00051
00052 #if 0
00053 #pragma mark -------- Incs:Core:System:SystemMgr.h ---------
00054 #endif
00055
00056 //*********************************************************
00057 // Feature definitions for publishing what hardware keys
00058 //  are available on a device
00059 //*********************************************************
00060
00061 #define sysFtrNumUIHardwareFlags              27          // Additional User Input Hardware (PalmOS 5.x)
00062 #define sysFtrNumUIHardwareHas5Way            0x00000001  // Device has a 5-way rocker
00063 #define sysFtrNumUIHardwareHasThumbWheel      0x00000002  // Device has a thumb wheel
00064 #define sysFtrNumUIHardwareHasThumbWheelBack  0x00000004  // Device has a thumb wheel with a 'back' button
00065 #define sysFtrNumUIHardwareHasKbd             0x00000008  // Device has a dedicated keyboard
00066
00067
00068 #if 0
00069 #pragma mark -------- Incs:Core:System:SysEvent.h (68K) -------
00070 #pragma mark ------ Incs:Core:Common:CmnKeyTypes.h (ARM) ------
00071 #endif
00072
00073 //*********************************************************
00074 // New modifiers mask for keyDown event
00075 //*********************************************************
00076
00077 #define willSendUpKeyMask  0x0800   // True if a keyUp event will be sent later
00078
00079
00080
00081 #endif    // __HS_KEY_COMMON_H__
00082
00083
00084
00085
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:53 2008 for Palm API Guide


Header Files » Incs » common » system

HsKeyTypes.h

Go to the documentation of this file.
00001 /******************************************************************************
00002  * Copyright (c) 2004 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  *****************************************************************************/
00005 /**
00006  *
00007  * @ingroup PmKeyLib
00008  *
00009  */
00010
00011 /**
00012  * @file    HsKeyTypes.h
00013  *
00014  * @brief   palmOne's key constant definitions shared by DAL and Palm OS
00015  * (see Palm OS' CmnKeyTypes.h)
00016  *
00017  */
00018
00019 #ifndef __HSKEYTYPES_H__
00020 #define __HSKEYTYPES_H__
00021
00022
00023 /********************************************************************
00024  * Definition of the Bit numbers corresponding to Palm's key bits
00025  * (see CmnKeyTypes.h)
00026  ********************************************************************/
00027 /** Power key */
00028 #define keyBitNumPower                   0
00029 /** Page-up */
00030 #define keyBitNumPageUp                  1
00031 /** Page-down */
00032 #define keyBitNumPageDown                2
00033 /** App #1 */
00034 #define keyBitNumHard1                   3
00035 /** App #2 */
00036 #define keyBitNumHard2                   4
00037 /** App #3 */
00038 #define keyBitNumHard3                   5
00039 /** App #4 */
00040 #define keyBitNumHard4                   6
00041 /** Button on cradle */
00042 #define keyBitNumCradle                  7
00043 /** Antenna "key" <chg 3-31-98 RM> */
00044 #define keyBitNumAntenna                 8
00045 /** Contrast key */
00046 #define keyBitNumContrast                9
00047
00048
00049 /** jog wheel up */
00050 #define keyBitNumJogUp                  12
00051 /** jog wheel down */
00052 #define keyBitNumJogDown                13
00053 /** press/center on jog wheel */
00054 #define keyBitNumJogPress               14
00055 /** jog wheel back button */
00056 #define keyBitNumJogBack                15
00057 /** 5-way rocker up */
00058 #define keyBitNumRockerUp               16
00059 /** 5-way rocker down */
00060 #define keyBitNumRockerDown             17
00061 /** 5-way rocker left */
00062 #define keyBitNumRockerLeft             18
00063 /** 5-way rocker right */
00064 #define keyBitNumRockerRight            19
00065 /** 5-way rocker center/press */
00066 #define keyBitNumRockerCenter           20
00067
00068
00069 /** Definition of the 1st extension bit field returned in the bit
00070  *  field array passed into KeyCurrentStateEx.  The following bit
00071  *  names are based on the American keyboard.
00072  */
00073
00074 /** Q key */
00075 #define keyBitExt1Q             0x00000001
00076 #define keyBitNumExt1Q                   0
00077 /** W key */
00078 #define keyBitExt1W             0x00000002
00079 #define keyBitNumExt1W                   1
00080 /** E key */
00081 #define keyBitExt1E             0x00000004
00082 #define keyBitNumExt1E                   2
00083 /** R key */
00084 #define keyBitExt1R             0x00000008
00085 #define keyBitNumExt1R                   3
00086 /** T key */
00087 #define keyBitExt1T             0x00000010
00088 #define keyBitNumExt1T                   4
00089 /** Y key */
00090 #define keyBitExt1Y             0x00000020
00091 #define keyBitNumExt1Y                   5
00092 /** U key */
00093 #define keyBitExt1U             0x00000040
00094 #define keyBitNumExt1U                   6
00095 /** I key */
00096 #define keyBitExt1I             0x00000080
00097 #define keyBitNumExt1I                   7
00098 /** O key */
00099 #define keyBitExt1O             0x00000100
00100 #define keyBitNumExt1O                   8
00101 /** P key */
00102 #define keyBitExt1P             0x00000200
00103 #define keyBitNumExt1P                   9
00104 /** A key */
00105 #define keyBitExt1A             0x00000400
00106 #define keyBitNumExt1A                  10
00107 /** S key */
00108 #define keyBitExt1S             0x00000800
00109 #define keyBitNumExt1S                  11
00110 /** D key */
00111 #define keyBitExt1D             0x00001000
00112 #define keyBitNumExt1D                  12
00113 /** F key */
00114 #define keyBitExt1F             0x00002000
00115 #define keyBitNumExt1F                  13
00116 /** G key */
00117 #define keyBitExt1G             0x00004000
00118 #define keyBitNumExt1G                  14
00119 /** H key */
00120 #define keyBitExt1H             0x00008000
00121 #define keyBitNumExt1H                  15
00122 /** J key */
00123 #define keyBitExt1J             0x00010000
00124 #define keyBitNumExt1J                  16
00125 /** K key */
00126 #define keyBitExt1K             0x00020000
00127 #define keyBitNumExt1K                  17
00128 /** L key */
00129 #define keyBitExt1L             0x00040000
00130 #define keyBitNumExt1L                  18
00131 /** Backspace key */
00132 #define keyBitExt1Bksp          0x00080000
00133 #define keyBitNumExt1Bksp               19
00134 /** Option key */
00135 #define keyBitExt1Opt           0x00100000
00136 #define keyBitNumExt1Opt                20
00137 /** Z key */
00138 #define keyBitExt1Z             0x00200000
00139 #define keyBitNumExt1Z                  21
00140 /** X key */
00141 #define keyBitExt1X             0x00400000
00142 #define keyBitNumExt1X                  22
00143 /** C key */
00144 #define keyBitExt1C             0x00800000
00145 #define keyBitNumExt1C                  23
00146 /** V key */
00147 #define keyBitExt1V             0x01000000
00148 #define keyBitNumExt1V                  24
00149 /** B key */
00150 #define keyBitExt1B             0x02000000
00151 #define keyBitNumExt1B                  25
00152 /** N key */
00153 #define keyBitExt1N             0x04000000
00154 #define keyBitNumExt1N                  26
00155 /** M key */
00156 #define keyBitExt1M             0x08000000
00157 #define keyBitNumExt1M                  27
00158 /** Period key */
00159 #define keyBitExt1Period        0x10000000
00160 #define keyBitNumExt1Period             28
00161 /** Enter key */
00162 #define keyBitExt1Enter         0x20000000
00163 #define keyBitNumExt1Enter              29
00164 /** Shift key */
00165 #define keyBitExt1Shift         0x40000000
00166 #define keyBitNumExt1Shift              30
00167 /** Space key */
00168 #define keyBitExt1Space         0x80000000
00169 #define keyBitNumExt1Space              31
00170 /** All keys */
00171 #define keyBitsAllExt1          0xFFFFFFFF
00172
00173
00174 /** Definition of the 2nd extension bit field returned in the bit
00175  *  field array passed into KeyCurrentStateEx.  The following bit
00176  *  names are based on the American keyboard.
00177  */
00178
00179 /** Symbol (list type) */
00180 #define keyBitExt2Symbol        0x00000001
00181 #define keyBitNumExt2Symbol              0
00182 /** Cmd/menu */
00183 #define keyBitExt2CmdMenu       0x00000002
00184 #define keyBitNumExt2CmdMenu             1
00185 // OBSOLETE: Treo Jog up
00186 // #define keyBitExt2JogUp      0x00000004
00187 // #define keyBitNumExt2JogUp            2
00188 // OBSOLETE: Treo Jog down
00189 // #define keyBitExt2JogDown        0x00000008
00190 // #define keyBitNumExt2JogDown          3
00191 // OBSOLETE: Treo Jog scan
00192 // #define keyBitExt2JogScan        0x00000010
00193 // #define keyBitNumExt2JogScan          4
00194 /** Launcher */
00195 #define keyBitExt2Launcher      0x00000020
00196 #define keyBitNumExt2Launcher            5
00197 /** UNUSED: Available for use (was going to be RadioPower) */
00198 #define keyBitExt2Unused6       0x00000040
00199 #define keyBitNumExt2Unused6             6
00200 /** Manufacturing Test */
00201 #define keyBitExt2MfgTest       0x00000080
00202 #define keyBitNumExt2MfgTest             7
00203 /** Volume Up */
00204 #define keyBitExt2VolumeUp      0x00000100
00205 #define keyBitNumExt2VolumeUp            8
00206 /** Volume Down */
00207 #define keyBitExt2VolumeDown    0x00000200
00208 #define keyBitNumExt2VolumeDown          9
00209 /** Side button */
00210 #define keyBitExt2Side          0x00000400
00211 #define keyBitNumExt2Side               10
00212 /** Zero key */
00213 #define keyBitExt2Zero          0x00000800
00214 #define keyBitNumExt2Zero               11
00215 /** Right Shift key */
00216 #define keyBitExt2RShift        0x00001000
00217 #define keyBitNumExt2RShift             12
00218 /** Our Phone key */
00219 #define keyBitExt2Hard11        0x00002000
00220 #define keyBitNumExt2Hard11             13
00221 /** All keys */
00222 #define keyBitsAllExt2          0xFFFFFFFF
00223
00224
00225 /** This keyBit is guaranteed not to map to any character */
00226 #define keyBitNumUnused         0xFFFF
00227
00228
00229 /********************************************************************
00230  *Special (impossible) combinations of modifiers that we use
00231  * to send special events through the key queue
00232  ********************************************************************/
00233 #define specialHoldKeyMask    (autoRepeatKeyMask | doubleTapKeyMask)
00234 #define specialReleaseKeyMask (autoRepeatKeyMask | poweredOnKeyMask)
00235 #define specialAvail3KeyMask  (doubleTapKeyMask  | poweredOnKeyMask)
00236 #define specialAvail4KeyMask  (autoRepeatKeyMask | doubleTapKeyMask | poweredOnKeyMask)
00237
00238 #define specialKeyMask        (autoRepeatKeyMask | doubleTapKeyMask | poweredOnKeyMask)
00239
00240
00241 /********************************************************************
00242  *Extended shift state values for supporting an option and option lock state
00243  ********************************************************************/
00244 /** Temp shift states (see Graffiti.h) */
00245 #define hsGrfTempShiftOpt       (grfTempShiftLower+1)
00246
00247 /** Local names for shift lock states (see GraffitiShift.h) */
00248 #define hsGlfOptLock            (glfNumLock << 1)
00249
00250 // Treo names (for compatibility)
00251 //#define keyGrfTempShiftOption hsGrfTempShiftOpt
00252 //#define keyGlfOptLock         hsGlfOptLock
00253
00254 /** Internal shift states (extends GsiShiftStateTag) */
00255 #define hsGsiOptLock            0xFE
00256 #define hsGsiShiftOpt           0xFF
00257
00258 #endif  // __HSKEYTYPES_H__
00259
00260
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:53 2008 for Palm API Guide


Header Files » Incs » 68k » system

HsNav.h

Go to the documentation of this file.
00001 /******************************************************************************
00002  * Copyright (c) 2004 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  *****************************************************************************/
00005 /**
00006  *
00007  * @ingroup HsNav
00008  *
00009  */
00010
00011 /**
00012  * @file    HsNav.h
00013  * @version
00014  * @date
00015  *
00016  * @brief   Header file that 68K programs include to access
00017  * HsNav functionality.
00018  *
00019  */
00020
00021
00022 #ifndef   __HS_NAV_68K_H__
00023 #define   __HS_NAV_68K_H__
00024
00025 /**
00026  * Most of the definitions for HsNav are in HsNavCommon.h so that
00027  * they can be shared by both 68K and ARM programs...
00028  **/
00029 #include <HsNavCommon.h>
00030 #include <HsExt.h>  // For SYS_SEL_TRAP
00031 #include <CoreTraps.h>
00032
00033 /**
00034  * SYS_SEL_TRAP technically should be defined here as it is defined at the
00035  *  beginning of HsExt.h.  However, since HsNav.h is always included with
00036  *  HsExt.h (Hs.h and HsInt.h include both), we are fine.  If HsNav.h is ever
00037  *  included without HsExt.h, then we'll have to do something different.
00038  **/
00039
00040 #if PALMOS_SDK_VERSION < 0x0541
00041
00042 #ifdef __cplusplus
00043 extern "C" {
00044 #endif
00045
00046 /**
00047  *  @brief Obtains the number of objects in a form’s navigation tab order.
00048  *
00049  *  @param formP:   IN:  Pointer to the form whose navigation information is to be obtained.
00050  *  @retval UInt16 Returns the number of objects in the navigation tab order.
00051  **/
00052 UInt16
00053 FrmCountObjectsInNavOrder (const FormType * formP)
00054         SYS_SEL_TRAP (sysTrapNavSelector, NavSelectorFrmCountObjectsInNavOrder);
00055
00056 /**
00057  *  @brief Obtains information about the navigation order of a form.
00058  *
00059  *  @param formP:   IN:  Pointer to the form whose focus order is to be obtained
00060  *  @param navHeaderP:  IN:  If not NULL, filled with the header information for the form’s navigation order
00061  *  @param navOrderP:   IN:  If not NULL, will point to an array with info for each object in the navigation order
00062  *  @param numObjectsP: IN:  On entry, the number of entries allocated in the navigation order array. On exit,
00063  *                           the number of entries filled in the navigation order array.
00064  *  @retval Err Returns 0 if no error, error code otherwise.
00065  **/
00066 Err
00067 FrmGetNavOrder (const FormType* formP, FrmNavHeaderType* navHeaderP,
00068                 FrmNavOrderEntryType* navOrderP, UInt16* numObjectsP)
00069         SYS_SEL_TRAP (sysTrapNavSelector, NavSelectorFrmGetNavOrder);
00070
00071 /**
00072  *  @brief Sets the navigation order of a form. If the object with the current focus is removed
00073  *         from the order, the object will be redrawn in its non-focused state and the form will
00074  *         have no current focus. Makes a COPY of all information passed-in.
00075  *
00076  *  @param formP:   IN:  Pointer to the form whose focus order is to being set
00077  *  @param navHeaderP:  IN:  Sets the header information for the form’s navigation order. This parameter
00078  *                           cannot be NULL.
00079  *  @param navOrderP:   IN:  Specifies the new navigation order for the form. The number of entries in the
00080  *                           array must be equal to the header parameter’s numberOfObjects field. Caller can
00081  *                           pass NULL if they do not want to change the form’s navigation order (they just
00082  *                           want to change the header information).
00083  *  @retval Err Returns 0 if no error, error code otherwise
00084  **/
00085 Err
00086 FrmSetNavOrder (FormType* formP, FrmNavHeaderType* navHeaderP,
00087                 FrmNavOrderEntryType* navOrderP)
00088         SYS_SEL_TRAP (sysTrapNavSelector, NavSelectorFrmSetNavOrder);
00089
00090 /**
00091  *  @brief Gets the navigation information for a single object in the form.
00092  *
00093  *  @param formP:       IN:  Pointer to the form whose navigation order is being obtained
00094  *  @param targetObjectID:  IN:  The ID of the object whose navigation information is being obtained
00095  *  @param afterObjectIDP:  IN:  On exit, will point to the ID of the object which is to the left of the target object.
00096  *                                   If the target object is the first one in the tab order, will point to an ID of 0. Caller
00097  *                                   can pass NULL if they do not need this information.
00098  *  @param aboveObjectIDP:  IN:  On exit, will point to the ID of the object that is above the target object. An ID of
00099  *                                   0 means the target object is in the top row of the form. Caller can pass NULL if
00100  *                                   they do not need this information.
00101  *  @param belowObjectIDP:  IN:  On exit, will point to the ID of the object that is below the target object. An ID of
00102  *                                   0 means the target object is in the bottom row of the form. Caller can pass NULL
00103  *                                   if they do not need this information.
00104  *  @param objectFlagsP:    IN:  On exit, will point to the object flags for the target object. Caller can pass NULL
00105  *                                   if they do not need this information.
00106  *  @retval Err Returns 0 if no error, error code otherwise.
00107  **/
00108 Err
00109 FrmGetNavEntry (const FormType* formP, UInt16 targetObjectID,
00110                 UInt16* afterObjectIDP, UInt16* aboveObjectIDP,
00111                 UInt16* belowObjectIDP, FrmNavObjectFlagsType* objectFlagsP)
00112         SYS_SEL_TRAP (sysTrapNavSelector, NavSelectorFrmGetNavEntry);
00113
00114 /**
00115  *  @brief Edits the navigation information for a single object in the form.
00116  *
00117  *  @param formP:       IN:  Pointer to the form whose navigation order is being changed
00118  *  @param targetObjectID:  IN:  The ID of the object which is being edited, added, or removed.
00119  *  @param afterObjectID:   IN:  The ID of the object which will be to the left of the target object. The object that
00120  *                                   is currently to the right of the after object will then be to the right of the target
00121  *                   object. An ID of 0 means the target object should be placed at the beginning of
00122  *                   the order. An ID of 0xFFFF (frmInvalidObjectId) means that the target object
00123  *                   should be completely removed from the navigation order.
00124  *  @param aboveObjectID:   IN:  The ID of the object that will be above the target object. An ID of 0 means the
00125  *                   target object is in the top row of the form.
00126  *  @param belowObjectID:   IN:  The ID of the object that will be below the target object. An ID of 0 means the
00127  *                   target object is in the bottom row of the form.
00128  *  @param objectFlags:     IN:  The new object flags for the target object.
00129  *  @retval Err Returns 0 if no error, error code otherwise.
00130  **/
00131 Err
00132 FrmSetNavEntry (FormType* formP, UInt16 targetObjectID,
00133                 UInt16 afterObjectID, UInt16 aboveObjectID,
00134                 UInt16 belowObjectID, FrmNavObjectFlagsType objectFlags)
00135         SYS_SEL_TRAP (sysTrapNavSelector, NavSelectorFrmSetNavEntry);
00136
00137 /**
00138  *  @brief Gets the current navigation state of a form.
00139  *
00140  *  @param formP:   IN:  Pointer to the form whose navigation state is to be obtained.
00141  *  @param stateFlagsP: IN:  On exit, points to a state flags field that describes the current navigation state
00142  *  @retval Err Returns 0 if no error, error code otherwise
00143  **/
00144 Err
00145 FrmGetNavState (const FormType* formP, FrmNavStateFlagsType* stateFlagsP)
00146         SYS_SEL_TRAP (sysTrapNavSelector, NavSelectorFrmGetNavState);
00147
00148 /**
00149  *  @brief Sets the navigation state of a form
00150  *
00151  *  @param formP:   IN:  Pointer to the form whose navigation state is being set
00152  *  @param stateFlags:  IN:  State flags that describe the new navigation state
00153  *  @retval Err Returns 0 if no error, error code otherwise
00154  **/
00155 Err
00156 FrmSetNavState (FormType* formP, FrmNavStateFlagsType stateFlags)
00157         SYS_SEL_TRAP (sysTrapNavSelector, NavSelectorFrmSetNavState);
00158
00159 /**
00160  *  @brief
00161  *
00162  *  @param formP:   IN:
00163  *  @param objectID:    IN:
00164  *  @param extraInfo:   IN:
00165  *  @param boundsInsideRingP:   IN:
00166  *  @param ringStyle:   IN:
00167  *  @param forceRestore:    IN:
00168  *  @retval Err Error code.
00169  **/
00170 Err
00171 FrmNavDrawFocusRing (FormType* formP, UInt16 objectID, Int16 extraInfo,
00172                      RectangleType* boundsInsideRingP,
00173                      FrmNavFocusRingStyleEnum ringStyle, Boolean forceRestore)
00174         SYS_SEL_TRAP (sysTrapNavSelector, NavSelectorFrmNavDrawFocusRing);
00175
00176 /**
00177  *  @brief
00178  *
00179  *  @param formP:   IN:
00180  *  @retval Err Error code.
00181  **/
00182 Err
00183 FrmNavRemoveFocusRing (FormType* formP)
00184         SYS_SEL_TRAP (sysTrapNavSelector, NavSelectorFrmNavRemoveFocusRing);
00185
00186 /**
00187  *  @brief
00188  *
00189  *  @param formP:   IN:
00190  *  @param objectIDP:   IN:
00191  *  @param extraInfoP:  IN:
00192  *  @param boundsInsideRingP:   IN:
00193  *  @param ringStyleP:  IN:
00194  *  @retval Err Error code.
00195  **/
00196 Err
00197 FrmNavGetFocusRingInfo (const FormType* formP, UInt16* objectIDP,
00198                         Int16* extraInfoP, RectangleType* boundsInsideRingP,
00199                         FrmNavFocusRingStyleEnum* ringStyleP)
00200         SYS_SEL_TRAP (sysTrapNavSelector, NavSelectorFrmNavGetFocusRingInfo);
00201
00202 #endif // PALMOS_SDK_VERSION < 0x0541
00203
00204 /**
00205  *  @brief
00206  *
00207  *  @param formP:   IN:
00208  *  @param objID:   IN:
00209  **/
00210 void
00211 FrmNavObjectTakeFocus (const FormType* formP, UInt16 objID)
00212         SYS_SEL_TRAP (sysTrapNavSelector, NavSelectorFrmNavObjectTakeFocus);
00213
00214 #ifdef __cplusplus
00215 }
00216 #endif
00217
00218
00219 #endif    // __HS_NAV_68K_H__
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:53 2008 for Palm API Guide


Header Files » Incs » common » system

HsNavCommon.h

Go to the documentation of this file.
00001 /*******************************************************************************
00002  * Copyright (c) 2004-2005 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  ******************************************************************************/
00005 /**
00006  * @defgroup    HsNav 5-Way Navigation Library
00007  * @brief       This library provides 5-way navigation support for applications
00008  *              on the Treo 600 devices.
00009  *
00010  * The 5-way navigation features and APIs described here have already existed
00011  * in Palm OS SDK for Palm OS ver. 5.4.1 and above, and applications that are
00012  * developed for newer devices should be using PalmSource's Palm OS definitions
00013  * of these features and APIs. Developers can use palmOne defined features to extend
00014  * support back to Treo 600 devices.
00015  *
00016  * For more information on 5-way navigation support, please refer to palmOne
00017  * Developer Guide and also the Palm OS Documentation.
00018  *
00019  * @{
00020  * @}
00021  */
00022 /**
00023  * @ingroup HsNav
00024  */
00025
00026 /**
00027  * @file    HsNavCommon.h
00028  * @brief   Public common header file for 5-way navigation support on Treo 600.
00029  *
00030  * This file contains the common constant and structures used to support 5-way navigation
00031  * in an application.
00032  *
00033  */
00034
00035 #ifndef   __HS_NAV_COMMON_H__
00036 #define   __HS_NAV_COMMON_H__
00037
00038
00039 #include <Bitmap.h> // for RGBColorType
00040
00041 #if 0
00042 #pragma mark -------- HS-Specific -------------
00043 #endif
00044
00045 //*********************************************************
00046 // The current version of the navigation API (this is the
00047 //  value set for hsFtrIDNavigationSupported feature)
00048 //*********************************************************
00049 #define hsNavAPIVersion     2
00050
00051
00052 //*********************************************************
00053 // Focus treatment definitions
00054 //*********************************************************
00055 #define hsNavFocusRingWidth           6       // Width in double-density coordinates
00056 #define hsNavFocusRingWidthSingleDensity    3   // Width in single-density coordinates
00057 #define hsNavFocusRingNoExtraInfo     ((Int16)0xFFFF)
00058
00059
00060 enum HsNavFocusColorEnumTag
00061 {
00062   hsNavFocusColorInsideBottomRightRing  = 0,  // Deprecated (HsNav version 1 focus treatment)
00063   hsNavFocusColorInsideTopLeftRing = 1,       // Deprecated (HsNav version 1 focus treatment)
00064   hsNavFocusColorMiddleRing = 2,              // Deprecated (HsNav version 1 focus treatment)
00065   hsNavFocusColorOutsideRing = 3,             // Deprecated (HsNav version 1 focus treatment)
00066   hsNavFocusColorSecondaryHighlight = 4,
00067   hsNavFocusColorRing1 = 5,                   // HsNav version 2 focus treatment.  Innermost ring.
00068   hsNavFocusColorRing2 = 6,                   // HsNav version 2 focus treatment.
00069   hsNavFocusColorRing3 = 7,                   // HsNav version 2 focus treatment.
00070   hsNavFocusColorRing4 = 8,                   // HsNav version 2 focus treatment.
00071   hsNavFocusColorRing5 = 9,                   // HsNav version 2 focus treatment.
00072   hsNavFocusColorRing6 = 10                   // HsNav version 2 focus treatment.  Outermost ring.
00073 };
00074 typedef UInt16 HsNavFocusColorEnum;
00075
00076
00077 enum HsNavFocusRingStyleEnumTag
00078 {
00079   hsNavFocusRingStyleObjectTypeDefault = 0,
00080   hsNavFocusRingStyleSquare = 1,
00081   hsNavFocusRingStyleRound = 2,
00082   hsNavFocusRingStyleHorizontalBars = 3,
00083   hsNavFocusRingStyleInvalid = 0xFFFF
00084 };
00085 typedef UInt16 HsNavFocusRingStyleEnum;
00086
00087 #if PALMOS_SDK_VERSION < 0x0541
00088
00089 // FrmNavFocusRingStyleEnum's definition should always be exactly the same as
00090 //  HsNavFocusRingStyleEnum's definition since we want their use to be
00091 //  completely interchangeable.  HsNavFocusRingStyleEnum is what the Treo600
00092 //  SDK used and FrmNavFocusRingStyleEnum is what PSI (and Treo650) will use in
00093 //  their SDK.  PSI originally was not going to take focus ring related API
00094 //  but this changed after Treo600 shipped.
00095 enum FrmNavFocusRingStyleEnumTag
00096 {
00097   frmNavFocusRingStyleObjectTypeDefault = 0,
00098   frmNavFocusRingStyleSquare = 1,
00099   frmNavFocusRingStyleRound = 2,
00100   frmNavFocusRingStyleHorizontalBars = 3,
00101   frmNavFocusRingStyleInvalid = 0xFFFF
00102 };
00103 typedef UInt16 FrmNavFocusRingStyleEnum;
00104 #define frmNavFocusRingNoExtraInfo    ((Int16)0xFFFF)
00105
00106 #endif // PALMOS_SDK_VERSION < 0x0541
00107
00108 #if 0
00109 #pragma mark -------- Incs:Core:UI:UIResources.h -------------
00110 #endif
00111
00112 #define formNavRscType                      'fnav'
00113
00114
00115 #if 0
00116 #pragma mark -------- Incs:Core:System:TextMgr.h ---------------
00117 #endif
00118
00119 //*********************************************************
00120 // Macro for detecting if character is a rocker character
00121 //*********************************************************
00122
00123 // <c> is a rocker key if the event modifier <m> has the command bit set
00124 // and <c> is in the proper range
00125 #define TxtCharIsRockerKey(m, c)    ((((m) & commandKeyMask) != 0) && \
00126                                     ((((c) >= vchrRockerUp) && ((c) <= vchrRockerCenter))))
00127
00128
00129 #if 0
00130 #pragma mark -------- Incs:Core:CoreTraps.h ----------------
00131 #endif
00132
00133 //*********************************************************
00134 // Selector definitions for Navigation API functions
00135 //*********************************************************
00136 #if PALMOS_SDK_VERSION < 0x0541
00137
00138 #define sysTrapNavSelector                      0xA46F
00139
00140 #define NavSelectorFrmCountObjectsInNavOrder    0x0
00141 #define NavSelectorFrmGetNavOrder               0x1
00142 #define NavSelectorFrmSetNavOrder               0x2
00143 #define NavSelectorFrmGetNavEntry               0x3
00144 #define NavSelectorFrmSetNavEntry               0x4
00145 #define NavSelectorFrmGetNavState               0x5
00146 #define NavSelectorFrmSetNavState               0x6
00147 #define NavSelectorFrmNavDrawFocusRing          0x7
00148 #define NavSelectorFrmNavRemoveFocusRing        0x8
00149 #define NavSelectorFrmNavGetFocusRingInfo       0x9
00150
00151 #endif // PALMOS_SDK_VERSION < 0x0541
00152
00153 #define NavSelectorFrmNavObjectTakeFocus        0xA
00154
00155
00156 #if 0
00157 #pragma mark ------- Incs:Core:System:ErrorBase.h --------
00158 #endif
00159
00160 //*********************************************************
00161 // Error class and codes for UI Library
00162 //*********************************************************
00163 #if PALMOS_SDK_VERSION < 0x0541
00164
00165 #define uilibErrorClass             0x3A00  // UI Library (Forms, Controls, etc)
00166
00167 #define uilibErrInvalidParam          (uilibErrorClass | 1)
00168 #define uilibErrCurrentFocusInvalid   (uilibErrorClass | 2)
00169 #define uilibErrObjectFocusModeOff    (uilibErrorClass | 3)
00170 #define uilibErrObjectNotFound        (uilibErrorClass | 4)
00171 #define uilibErrNoNavInfoForForm      (uilibErrorClass | 5)
00172 #define uilibErrInvalidFocusObject    (uilibErrorClass | 6)
00173 #define uilibErrFormDoesNotHaveFocus  (uilibErrorClass | 7)
00174
00175 #endif // PALMOS_SDK_VERSION < 0x0541
00176
00177
00178 #if 0
00179 #pragma mark -------- Incs:Core:UI:Form.h -----------
00180 #endif
00181
00182 //*********************************************************
00183 // Nav Flags (used with navFlags field of FrmNavHeaderType)
00184 //*********************************************************
00185 #if PALMOS_SDK_VERSION < 0x0541
00186
00187 typedef UInt32  FrmNavHeaderFlagsType;
00188
00189 #define kFrmNavHeaderFlagsObjectFocusStartState       0x00000001
00190 #define kFrmNavHeaderFlagsAppFocusStartState          0x00000002
00191 #define kFrmNavHeaderFlagsAutoGenerated               0x80000000
00192
00193 #define kFrmNavHeaderFlagsStartStateMask              0x00000003
00194 #define kFrmNavHeaderFlagsDefaultStartStateValue      0x00000000
00195 #define kFrmNavHeaderFlagsObjectFocusStartStateValue  0x00000001
00196 #define kFrmNavHeaderFlagsAppFocusStartStateValue     0x00000002
00197 #define kFrmNavHeaderFlagsInvalidStartStateValue      0x00000003
00198
00199
00200 //*********************************************************
00201 // Object Flags (used with objectFlags field of
00202 //  FrmNavOrderEntryType)
00203 //*********************************************************
00204 typedef UInt16  FrmNavObjectFlagsType;
00205
00206 #define kFrmNavObjectFlagsSkip                  0x0001
00207 #define kFrmNavObjectFlagsForceInteractionMode  0x0002
00208 #define kFrmNavObjectFlagsIsBigButton           0x8000
00209
00210
00211 //*********************************************************
00212 // Nav State Flags (used with stateFlags parameter of
00213 //  FrmGetNavState and FrmSetNavState API functions)
00214 //*********************************************************
00215 typedef UInt32  FrmNavStateFlagsType;
00216
00217 #define kFrmNavStateFlagsInteractionMode        0x00000001
00218 #define kFrmNavStateFlagsObjectFocusMode        0x00000002
00219
00220
00221 //*********************************************************
00222 // The current version of the navigation structures
00223 //  (FrmNavOrderEntryType and FrmNavHeaderType)
00224 //*********************************************************
00225 #define kFrmNavInfoVersion                      1
00226
00227 #endif // PALMOS_SDK_VERSION < 0x0541
00228
00229
00230 #if 0
00231 #pragma mark -------- Incs:Core:System:SystemMgr.h -----------
00232 #endif
00233
00234 #if PALMOS_SDK_VERSION < 0x0541
00235
00236 #define sysFtrNumFiveWayNavVersion      32          // version of the 5-way nav if any
00237
00238 #endif // PALMOS_SDK_VERSION < 0x0541
00239
00240
00241 #if 0
00242 #pragma mark --------  Public Structures   ----------------
00243 #endif
00244
00245 #if PALMOS_SDK_VERSION < 0x0541
00246
00247 //*********************************************************
00248 // Structures used with Navigation API functions
00249 //*********************************************************
00250
00251 typedef struct FrmNavOrderEntryTag
00252 {
00253     UInt16                objectID;
00254     FrmNavObjectFlagsType objectFlags;
00255     UInt16                aboveObjectID;
00256     UInt16                belowObjectID;
00257 } FrmNavOrderEntryType;
00258
00259
00260 typedef struct FrmNavHeaderTag
00261 {
00262     UInt16                version;                // This is version 1
00263     UInt16                numberOfObjects;
00264     UInt16                headerSizeInBytes;      // 20 for the version 1 structure
00265     UInt16                listElementSizeInBytes; // 8 for the version 1 structure
00266     FrmNavHeaderFlagsType navFlags;
00267     UInt16                initialObjectIDHint;
00268     UInt16                jumpToObjectIDHint;
00269     UInt16                bottomLeftObjectIDHint;
00270     UInt16                padding1;
00271 } FrmNavHeaderType;
00272
00273 #endif // PALMOS_SDK_VERSION < 0x0541
00274
00275 #endif    // __HS_NAV_COMMON_H__
00276
00277
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:53 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » telephony

HsPhone.h

Go to the documentation of this file.
00001 /******************************************************************************
00002  * Copyright (c) 2004 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  *****************************************************************************/
00005 /**
00006  * @defgroup Telephony Telephony Library
00007  *
00008  * @{
00009  * @}
00010  */
00011 /**
00012  * @ingroup Telephony
00013  */
00014
00015
00016 /**
00017  * @file    HsPhone.h
00018  *
00019  * @brief  Header file for the phone library (CDMA or GSM)
00020  *
00021  * Notes:
00022  *  This is the generic header file that should be used by any code that
00023  *  uses the CDMA or GSM phone libraries. If you add a function to this file
00024  *  please makes sure you update both the CDMA and GSM libraries with this
00025  *  function and update the ARM wrapper library if appropriate.
00026  */
00027
00028
00029
00030 #ifndef HS_PHONE_H
00031 #define HS_PHONE_H
00032 #include <PalmOS.h>
00033 #include <PalmTypes.h>
00034 #ifndef __CORE_COMPATIBILITY_H__
00035 #include <PalmCompatibility.h>
00036     /** workaround for differing header files in sdk-3.5 and sdk-internal */
00037     #ifndef __CORE_COMPATIBILITY_H__
00038     #define __CORE_COMPATIBILITY_H__
00039     #endif
00040 #endif
00041 #include <HsPhoneTraps.h>     /**< trap table definition for phone library calls */
00042 #include <HsPhoneErrors.h>    /**< error codes returned by phone library functions */
00043 #include <HsPhoneTypes.h>
00044 /**< including the other type files */
00045 #include <HsPhoneSMSTypes.h>
00046 #include <HsPhoneMiscTypes.h>
00047 #include <HsPhoneNetworkTypes.h>
00048 #include <HsPhoneGSMTypes.h>
00049 #include <HsPhoneCDMATypes.h>
00050 #include <HsPhoneIOTATypes.h>
00051 #include <HsPhoneSecurityTypes.h>
00052 #include <HsPhoneCallControlTypes.h>
00053 #include <HsPhoneAudioTypes.h>
00054 #include <HsPhoneLocationTypes.h>
00055
00056 /**
00057  * Defines
00058  */
00059
00060 #include <HsPhoneLibrary.h>         /**< CATEGORY:  LIBRARY */
00061 #include <HsPhoneMisc.h>            /**< CATEGORY:  MISC */
00062 #include <HsPhoneSMS.h>             /**< CATEGORY:  SMS */
00063 #include <HsPhoneNetwork.h>         /**< CATEGORY:  NETWORK */
00064 #include <HsPhoneGSM.h>             /**< CATEGORY:  GSM */
00065 #include <HsPhoneSecurity.h>        /**< CATEGORY:  SECURITY */
00066 #include <HsPhoneCDMA.h>            /**< CATEGORY:  CDMA */
00067 #include <HsPhoneIOTA.h>            /**< CATEGORY:  IOTA */
00068 #include <HsPhonePower.h>           /**< CATEGORY:  POWER */
00069 #include <HsPhoneEvent.h>           /**< CATEGORY:  NOTIFICATIONS & EVENTS */
00070
00071
00072 #endif
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:53 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » telephony

HsPhoneAudio.h

Go to the documentation of this file.
00001 /******************************************************************************
00002  * Copyright (c) 2004 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  *****************************************************************************/
00005 /** @ingroup Telephony
00006  *
00007  */
00008
00009
00010 /**
00011  *
00012  * @file    HsPhoneAudio.h
00013  *
00014  * @brief  Header File for Phone Library API ---- AUDIO CATEGORY
00015  *
00016  * Notes:
00017  *  All implementations of the Handspring Phone Library support a common API.
00018  *  This API is broken up into various categories for easier management.  This file
00019  *  defines the Audio category.  These API calls are used to play tones and other audio
00020  *  on an active phone connection.
00021  */
00022
00023
00024 #ifndef HS_PHONEAUDIO_H
00025 #define HS_PHONEAUDIO_H
00026
00027 #endif
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:53 2008 for Palm API Guide


Header Files » Incs » common » libraries » telephony

HsPhoneAudioTypes.h

Go to the documentation of this file.
00001 /******************************************************************************
00002  * Copyright (c) 2004 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  *****************************************************************************/
00005 /** @ingroup Telephony
00006  *
00007  */
00008
00009
00010 /**
00011  *
00012  * @file    HsPhoneAudioTypes.h
00013  *
00014  * @brief  File contains Phone Audio data types.
00015  *
00016  *
00017  */
00018
00019
00020 #ifndef __HS_PHONE_AUDIO_TYPES_H__
00021
00022 #define __HS_PHONE_AUDIO_TYPES_H__
00023
00024 #include <PalmTypes.h>
00025
00026 #include <PalmOS.h>
00027 #include <PalmTypes.h>
00028 #ifndef __CORE_COMPATIBILITY_H__
00029 #include <PalmCompatibility.h>
00030     /** workaround for differing header files in sdk-3.5 and sdk-internal */
00031     #ifndef __CORE_COMPATIBILITY_H__
00032     #define __CORE_COMPATIBILITY_H__
00033     #endif
00034 #endif
00035 #include <HsPhoneTraps.h>     /** trap table definition for phone library calls */
00036 #include <HsPhoneErrors.h>    /** error codes returned by phone library functions */
00037 #include <HsPhoneTypes.h>
00038
00039
00040 /**
00041  *  @name Phone slider switch
00042  */
00043 /*@{*/
00044 #define kSliderLow          0   /**<        */
00045 #define kSliderHigh         1   /**<        */
00046 #define kSliderPositions    2       /**<        */
00047 /*@}*/
00048
00049 /**
00050  *
00051  **/
00052 typedef struct
00053   {
00054     UInt8            ringerID;      /**<        */
00055     UInt16            volume;       /**<        */
00056     Boolean         vibrate;        /**<        */
00057     Boolean         msgAlert;       /**<        */
00058     Boolean         svcAlert;       /**<        */
00059   }
00060 PhnRingingProfileType;
00061
00062 /**
00063  *
00064  **/
00065 typedef enum
00066   {
00067     phnTTYSettingAll,                /**< Send/Receive Text  */
00068     phnTTYSettingVoiceCarryOver,     /**< Send Voice/ Receive Text  */
00069     phnTTYSettingHearCarryOver,      /**< Send Text / Receive Voice  */
00070     phnTTYSettingOff            /**< Send/Receive Voice -- NORMAL mode  */
00071   }
00072 _PhnTTYSetting;
00073
00074
00075 typedef UInt8 PhnTTYSetting;        /**<        */
00076
00077 typedef Boolean PhnHACSetting;
00078
00079 /**
00080  * Item description here
00081  **/
00082 typedef struct {
00083     PhnRingingProfileType profiles[kSliderPositions];   /**<        */
00084 } PhnRingingInfoType, * PhnRingingInfoPtr;          /**<        */
00085
00086 /**
00087  *
00088  **/
00089 typedef enum
00090 {
00091   phnAudioLocalMode,        /**<        */
00092   phnAudioSilentMode,       /**<        */
00093   phnAudioNetworkMode       /**<        */
00094 }_PhnAudioSendMode;
00095
00096
00097 typedef UInt8 PhnAudioSendMode;     /**<        */
00098
00099 #endif // __HS_PHONE_AUDIO_TYPES_H__
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:53 2008 for Palm API Guide


Header Files » Incs » common » libraries » telephony

HsPhoneCallControlTypes.h

Go to the documentation of this file.
00001 /******************************************************************************
00002  * Copyright (c) 2004 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  *****************************************************************************/
00005 /** @ingroup Telephony
00006  *
00007  */
00008
00009
00010 /**
00011  *
00012  * @file HsPhoneCallControlTypes.h
00013  *
00014  * @brief  Types for Phone Library call control functionality
00015  *
00016  *
00017  */
00018
00019
00020 #ifndef HS_PHONE_CALL_CONTROL_TYPES__H
00021 #define HS_PHONE_CALL_CONTROL_TYPES__H
00022 /**
00023  * Phone connection state
00024  **/
00025 typedef enum
00026   {
00027     phnConnectionActive,        /**<        */
00028     phnConnectionHeld,          /**<        */
00029     phnConnectionDialing,       /**<        */
00030     phnConnectionAlerting,      /**<        */
00031     phnConnectionIncoming,      /**<        */
00032     phnConnectionWaiting,       /**<        */
00033     phnConnectionUnknown,       /**<        */
00034     phnConnectionDormant
00035   } _PhnConnectStateType;
00036
00037 typedef UInt8       PhnConnectStateType;
00038 #define isValidPhnConnectStateType(c) ((c >= phnConnectionActive) && (c <= phnConnectionDormant))
00039
00040 /**< meaning of feature bits in a GSMSATEventMenuRec */
00041
00042
00043
00044 /**
00045  * Phone connection info
00046  **/
00047 typedef struct
00048   {
00049     PhnConnectionID id;         /**<        */
00050     PhnConnectStateType state;      /**<        */
00051     PhoneServiceClassType service;  /**<        */
00052     Boolean         incoming;       /**<        */
00053     Boolean         multiparty;     /**<        */
00054     PhnAddressHandle address;       /**<        */
00055     DWord           owner;      /**<        */
00056     Int16           lineNumber;     /**<        */
00057   }
00058 PhnConnectionType,* PhnConnectionPtr;
00059 #endif
00060
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:53 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » telephony

HsPhoneCDMA.h

Go to the documentation of this file.
00001 /******************************************************************************
00002  * Copyright (c) 2004 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  *****************************************************************************/
00005 /** @ingroup Telephony
00006  *
00007  */
00008
00009
00010 /**
00011  * @file    HsPhoneCDMA.h
00012  *
00013  * @brief  Header File for Phone Library API ---- CDMA CATEGORY
00014  *
00015  * Notes:
00016  *  All implementations of the Handspring Phone Library support a common API.
00017  *  This API is broken up into various categories for easier management.  This file
00018  *  defines the public portion of the CDMA category.  These API calls are used for features specific to
00019  *  CDMA networks.
00020  */
00021
00022
00023 #ifndef HS_PHONECDMA_H
00024 #define HS_PHONECDMA_H
00025
00026 #include <PalmOS.h>
00027 #include <PalmTypes.h>
00028 #ifndef __CORE_COMPATIBILITY_H__
00029 #include <PalmCompatibility.h>
00030     /** workaround for differing header files in sdk-3.5 and sdk-internal */
00031     #ifndef __CORE_COMPATIBILITY_H__
00032     #define __CORE_COMPATIBILITY_H__
00033     #endif
00034 #endif
00035 #include <HsPhoneTraps.h>     /**< trap table definition for phone library calls */
00036 #include <HsPhoneErrors.h>    /**< error codes returned by phone library functions */
00037 #include <HsPhoneTypes.h>
00038
00039 /**
00040  *  @brief This function returns the field’s value for a given address in a newly allocated
00041  *     block. This function returns 0 if there was an error while retrieving the data.
00042  *
00043  *  @param refNum:  IN:
00044  *  @param address:     IN:
00045  *  @param field:   IN:
00046  *  @retval CharPtr
00047  **/
00048
00049 extern CharPtr  PhnLibAPGetField (UInt16 refNum, PhnAddressHandle address, PhnAddressField field)
00050   PHN_LIB_TRAP (PhnLibTrapAPGetField);
00051
00052 #endif  //HS_PHONECDMA_H
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:53 2008 for Palm API Guide


Header Files » Incs » common » libraries » telephony

HsPhoneCDMATypes.h

Go to the documentation of this file.
00001 /******************************************************************************
00002  * Copyright (c) 2004 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  *****************************************************************************/
00005 /** @ingroup Telephony
00006  *
00007  */
00008
00009
00010 /**
00011  *
00012  * @file    HsPhoneCDMATypes.h
00013  *
00014  * @brief  Header File for Phone Library API ---- NETWORK CATEGORY
00015  *
00016  * NOTES:
00017  *  All implementations of the Handspring Phone Library support a common API.
00018  *  This API is broken up into various categories for easier management.  This file
00019  *  defines the CDMA category.  These API calls are used to interact with the wireless network.
00020  */
00021
00022
00023
00024 #ifndef _HS_PHONE_CDMA_TYPES_H__
00025 #define _HS_PHONE_CDMA_TYPES_H__
00026 #include <PalmOS.h>
00027 #include <PalmTypes.h>
00028 #ifndef __CORE_COMPATIBILITY_H__
00029 #include <PalmCompatibility.h>
00030     /** workaround for differing header files in sdk-3.5 and sdk-internal */
00031     #ifndef __CORE_COMPATIBILITY_H__
00032     #define __CORE_COMPATIBILITY_H__
00033     #endif
00034 #endif
00035
00036
00037 #define indicatorNoCallerIDChar          '?'  /**< CDMA Only -- Means there is no caller ID */
00038 #define indicatorBlockedCallerIDChar     '!'  /**< CDMA Only -- Means the caller ID is blocked  */
00039 #define indicatorRemainingCallerIDChar   '~'  /**< CDMA Only -- Means the caller ID is the remaining caller (3+ calls scenario)  */
00040
00041 /******************************************************************************
00042  * PDP related defines. KEEP THE FOLLOWING DEFINES IN SYNC WITH HIONEX.H !!
00043  ******************************************************************************/
00044
00045 #define phnPDPUidLen                 15   /**< Max PDP UID length   */
00046 #define phnMaxNAILen                 72   /**< Max length of NAI */
00047 #define phnMaxMNHASharedSecretLen    48   /**< HI_ONEX_MAX_MN_HA_SHARED_SECRET_LEN  */
00048 #define phnMaxMNAAASharedSecretLen   48   /**< HI_ONEX_MAX_MN_AAA_SHARED_SECRET_LEN */
00049 #define phnMaxSvcStrLen              22   /**< HI_ONEX_MAX_SVC_STR_LEN */
00050 #define phnMaxDialStrLen             15   /**< HI_ONEX_MAX_DIAL_STR_LEN */
00051 #define phnMaxMslLen                  6   /**< HI_ONEX_MSL_LEN */
00052 #define phnMaxUrlLen                128   /**< Max URL length */
00053
00054
00055 // Fields that were successfully updated with OTASP
00056 #define phnOtaspMobdirCommitFlag    0x0001      /**<        */
00057 #define phnOtaspFTCCommitFlag       0x0002      /**<        */
00058 #define phnOtaspRoamListCommitFlag  0x0004      /**<        */
00059 #define phnOtaspSPCCommitFlag       0x0008      /**<        */
00060 #define phnOtaspIMSICommitFlag      0x0010      /**<        */
00061 #define phnOtaspNamLockCommitFlag   0x0020      /**<        */
00062 #define phnOtaspAkeyCommitFlag      0x0040      /**<        */
00063 #define phnOtasp3GPDCommitFlag      0x0080      /**<        */
00064 #define phnOtaspMIPStatCommitFlag   0x0100      /**<        */
00065 #define phnOtaspMIPRetryCommitFlag  0x0200      /**<        */
00066 #define phnOtaspSPCFail             0x0400      /**<        */
00067 #define phnOtaspCommitFlag          0x0800          /**<        */
00068 #define phnOtaspInitProgReqFlag     0x1000      /**<        */
00069 #define phnOtaspProgInProgressFlag  0x2000      /**<        */
00070 #define phnOtaspSSDCommitFlag       0x4000      /**<        */
00071
00072 #define phnOtaspSuccessful          0x02FF      /**<        */
00073 #define phnOtaspUnsuccessful        0x03FF      /**<        */
00074
00075
00076 /**
00077  *
00078  **/
00079 typedef enum  {
00080     phnOneXFailPrev=0,      /**< current used PREV does not support the type of data call attempted */
00081     phnOneXFailNoSrv=1,     /**< modem did not have service when the data call was attempted */
00082     phnOneXFailNetworkSORej=2,  /**< The network rejected the service option for the data call */
00083     phnOneXFailModemSORej=3,    /**< The modem does not support or restricts the service option for the data call */
00084     phnOneXFailNetworkBusy=4,   /**< The network was busy */
00085     phnOneXFailUnknown=5    /**<        */
00086 } PhnOneXDataFailType;
00087
00088 #define isValidPhnOneXDataFailType(d) ((d >= phnOneXFailPrev) && (d <= phnOneXFailUnknown)) /**<        */
00089
00090
00091 /**
00092  *
00093  **/
00094 typedef enum{
00095     PhnPDPAUncert0_5_M = 0x00,      /**< Standard deviation of 0.5 meters */
00096     PhnPDPAUncert0_75_M,        /**< Standard deviation of 0.75 meters */
00097     PhnPDPAUncert1_M,           /**< Standard deviation of 1 meter */
00098     PhnPDPAUncert1_5_M,         /**< Standard deviation of 1.5 meters */
00099     PhnPDPAUncert2_M,           /**< Standard deviation of 2 meters */
00100     PhnPDPAUncert3_M,               /**< Standard deviation of 3 meters */
00101     PhnPDPAUncert4_M,           /**< Standard deviation of 4 meters */
00102     PhnPDPAUncert6_M,               /**< Standard deviation of 6 meters */
00103     PhnPDPAUncert8_M,           /**< Standard deviation of 8 meters */
00104     PhnPDPAUncert12_M,          /**< Standard deviation of 12 meters */
00105     PhnPDPAUncert16_M,              /**< Standard deviation of 16 meters */
00106     PhnPDPAUncert24_M,          /**< Standard deviation of 24 meters */
00107     PhnPDPAUncert32_M,              /**< Standard deviation of 32 meters */
00108     PhnPDPAUncert48_M,              /**< Standard deviation of 48 meters */
00109     PhnPDPAUncert64_M,          /**< Standard deviation of 64 meters */
00110     PhnPDPAUncert96_M,          /**< Standard deviation of 96 meters */
00111     PhnPDPAUncert128_M,             /**< Standard deviation of 128 meters */
00112     PhnPDPAUncert192_M,             /**< Standard deviation of 192 meters */
00113     PhnPDPAUncert256_M,             /**< Standard deviation of 256 meters */
00114     PhnPDPAUncert384_M,             /**< Standard deviation of 384 meters */
00115     PhnPDPAUncert512_M,             /**< Standard deviation of 512 meters */
00116     PhnPDPAUncert768_M,             /**< Standard deviation of 768 meters */
00117     PhnPDPAUncert1024_M,            /**< Standard deviation of 1,024 meters */
00118     PhnPDPAUncert1536_M,            /**< Standard deviation of 1,536 meters */
00119     PhnPDPAUncert2048_M,            /**< Standard deviation of 2,048 meters */
00120     PhnPDPAUncert3072_M,            /**< Standard deviation of 3,072 meters */
00121     PhnPDPAUncert4096_M,            /**< Standard deviation of 4,096 meters */
00122     PhnPDPAUncert6144_M,            /**< Standard deviation of 6,144 meters */
00123     PhnPDPAUncert8192_M,            /**< Standard deviation of 8,192 meters */
00124     PhnPDPAUncert12288_M,           /**< Standard deviation of 12,2288 meters */
00125     PhnPDPAUncertGREATER_12288_M,       /**< Standard deviation that is greater than 12,288 meters */
00126     PhnPDPAUncertNOT_COMPUTABLE_M,      /**< Standard deviation is not computable */
00127     PhnPDPAUncertMAX
00128 } PhnPDPAUncerttype;
00129
00130
00131 /**
00132  *
00133  **/
00134 typedef enum {
00135
00136     phnMIPSuccess,              /**<        */
00137     phnMIPNoSimBindings,            /**<        */
00138     phnMIPFaReasonUnspecified=64,       /**<        */
00139     phnMIPFaAdminProhibited=65,         /**<        */
00140     phnMIPFaInsufficientResources=66,       /**<        */
00141     phnMIPFaMobileNodeAuth=67,          /**<        */
00142     phnMIPFaHomeAgentAuth=68,           /**<        */
00143     phnMIPFaReqLifetimeTooLong=69,      /**<        */
00144     phnMIPFaPoorlyFormedReq=70,         /**<        */
00145     phnMIPFaPoorlyFormedReply=71,       /**<        */
00146     phnMIPFaReqedEncapUnavail=72,       /**<        */
00147     phnMIPFaReservedNUnavail=73,        /**<        */
00148     phnMIPFaCantRevTun=74,          /**<        */
00149     phnMIPFaMustRevTun=75,          /**<        */
00150     phnMIPFaBadTtl=76,              /**<        */
00151     phnMIPFaInvalidCareOfAddr=77,       /**<        */
00152     phnMIPFaRegistration_Timeout=78,        /**<        */
00153     PhnMIPFADelvStyleUnsupported=79,    /**<        */
00154     phnMIPFaHome_Network_Unreachable=80,    /**<        */
00155     phnMIPFaHa_Host_Unreachable=81,     /**<        */
00156     phnMIPFaHa_Port_Unreachable=82,     /**<        */
00157     phnMIPFaHa_Unreachable=88,          /**<        */
00158     PhnMIPFANonzeroHomeAddrReq=96,      /**<        */
00159     PhnMIPFAMissingNai=97,          /**<        */
00160     phnMIPFaForeign_Agent=98,           /**<        */
00161     PhnMIPFAMissingHomeAddr=99,     /**<        */
00162     PhnMIPFAError1=100,                 /**<        */
00163     PhnMIPFAError2 =101,            /**<        */
00164     phnMIPFaUnknown_Challenge=104,      /**<        */
00165     phnMIPFaMissing_Challenge=105,      /**<        */
00166     phnMIPFaStale_Challenge=106,        /**<        */
00167     phnMIPHaReasonUnspecified=128,      /**<        */
00168     phnMIPHaAdminProhibited=129,        /**<        */
00169     phnMIPHaInsufficientResources=130,      /**<        */
00170     phnMIPHaMobileNodeAuth=131,         /**<        */
00171     phnMIPHaForeignAgentAuth=132,       /**<        */
00172     phnMIPHaRegIdMismatch=133,          /**<        */
00173     phnMIPHaPoorlyFormedReq=134,            /**<        */
00174     phnMIPHaTooManySimMobBindings=135,      /**<        */
00175     phnMIPHaUnknownHaAddr=136,          /**<        */
00176     phnMIPHaCantRevTun=137,             /**<        */
00177     phnMIPHaMustRevTun=138,             /**<        */
00178     phnMIPHaReqEncapNotAvail=139,       /**<        */
00179     phnMIPHAError1=140,         /**<        */
00180     phnMIPHAError2=141          /**<        */
00181
00182 } PhnMIPFailType;
00183
00184
00185 /**
00186  *
00187  **/
00188 typedef enum
00189 {
00190
00191   phnPDPWriteOK,            /**<        */
00192   phnPDPWriteInvalidIndex,      /**<        */
00193   phnPDPWriteIndexInUse,        /**<        */
00194   phnPDPWriteNotAllowedAtIndex,     /**<        */
00195   phnPDPWriteInvalidNAILen,     /**<        */
00196   phnPDPWriteInvalidNAIName,        /**<        */
00197   phnPDPWriteDuplicateNAI,      /**<        */
00198   phnPDPWriteInvalidAAALen,     /**<        */
00199   phnPDPInvalidHALen,           /**<        */
00200   phnPDPWriteInvalidSvcStrLen,      /**<        */
00201   phnPDPWriteInvalidDialStrLen,     /**<        */
00202   phnPDPWriteIndexNotPrevSet,       /**<        */
00203   phnPDPWriteInternalModemErr       /**<        */
00204
00205 }PhnPDPWriteAck;
00206
00207 #define isValidPhnPDPWriteAck(w) ((w >= phnPDPWriteOK) && (w <= phnPDPWriteInternalModemErr))   /**<        */
00208
00209 /**
00210  *
00211  **/
00212 typedef enum
00213 {
00214   phnPDPReadOK,             /**<        */
00215   phnPDPReadInvalidIndex,       /**<        */
00216   phnPDPReadNotAllowedAtIndex,      /**<        */
00217   phnPDPReadIndexNotSet,        /**<        */
00218   phnPDPReadInternalModemErr        /**<        */
00219 }PhnPDPReadAck;
00220
00221 #define isValidPDPReadAck(r) ((r >= phnPDPReadOK) && (r <= phnPDPReadInternalModemErr))     /**<        */
00222
00223 /**
00224  *
00225  **/
00226 typedef enum
00227 {
00228   phnPDPDefaultIndex,       /**<        */
00229   phnPDPTempIndex,      /**<        */
00230   phnPDPGenericIndex        /**<        */
00231
00232 } _PhnPDPIndexType;
00233
00234 typedef UInt8 PhnPDPIndexType;      /**<        */
00235
00236 #define isValidPhnPDPIndexType(t) ((t >= phnPDPDefaultIndex) && (t <= phnPDPGenericIndex))  /**<        */
00237
00238 /**
00239  *
00240  **/
00241 typedef enum
00242 {
00243   phnPDPCopyOK,             /**<        */
00244   phnPDPCopyInvalidFromIndex,       /**<        */
00245   phnPDPCopyFromIndexNotActive,     /**<        */
00246   phnPDPCopyNotAllowedAtFromIndex,  /**<        */
00247   phnPDPCopyInvalidToIndex,     /**<        */
00248   phnPDPCopyToIndexInUse,       /**<        */
00249   phnPDPCopyNotAllowedAtToIndex,    /**<        */
00250   phnPDPCopyInvalidNAILen,      /**<        */
00251   phnPDPCopyInvalidNAIName,     /**<        */
00252   phnPDPCopyDuplicateNAI,       /**<        */
00253   phnPDPCopyInvalidAAALen,      /**<        */
00254   phnPDPCopyInvalidSvcStrLen,       /**<        */
00255   phnPDPCopyInternalModemErr        /**<        */
00256 } _PhnPDPCopyAck;           /**<        */
00257
00258 typedef UInt8 PhnPDPCopyAck;        /**<        */
00259
00260 #define isValidPhnPDPCopyAck(c) ((c >= phnPDPCopyOK) && (c <= phnPDPCopyInternalModemErr))  /**<        */
00261
00262
00263 /**
00264  *
00265  **/
00266 typedef enum
00267 {
00268   phnPDPDeleteOK,           /**<        */
00269   phnPDPDeleteInvalidIndex,     /**<        */
00270   phnPDPDeleteIndexActive,      /**<        */
00271   phnPDPDeleteIndexNotUsed,     /**<        */
00272   phnPDPDeleteNotAllowedAtIndex,    /**<        */
00273   phnPDPDeleteInternalModemErr      /**<        */
00274 } _PhnPDPDeleteAck;
00275
00276 typedef UInt8 PhnPDPDeleteAck;      /**<        */
00277
00278 #define isValidPhnPDPDeleteAck(d) ((d >= phnPDPDeleteOK) && (d <= phnPDPDeleteInternalModemErr))    /**<        */
00279
00280 /**
00281  *
00282  **/
00283 typedef enum
00284 {
00285   phnPDPReplaceOK,          /**<        */
00286   phnPDPReplaceInvalidIndex,        /**<        */
00287   phnPDPReplaceInvalidNotUsed,      /**<        */
00288   phnPDPReplaceNotAllowedAtIndex,   /**<        */
00289   phnPDPReplaceInvalidLen,          /**<        */
00290   phnPDPReplaceInternalModemErr     /**<        */
00291
00292 } _PhnPDPReplaceAck;
00293
00294 typedef UInt8 PhnPDPReplaceAck;     /**<        */
00295
00296 #define isValidPhnPDPReplaceAck(r) ((r >= phnPDPReplaceOK) && (r <= phnPDPReplaceInternalModemErr)) /**<        */
00297
00298
00299
00300 /**
00301  *  Indicates whether the profile is a mobile IP or simple IP profile.
00302  **/
00303
00304 /**
00305  * We changed the ordering of enum to match the TIL type and to keep it consistent with Crowdy NV
00306  * table for the PDP. Previously, this type was only used by NetPref we impact was minimal. The new ordering
00307  * also allows us to overload the NetMaster "isMobileIPValue" record value with this value. This way
00308  * any of 'if (isMobileIPValue)' will return true for both MIP and MIP with fallback. Later we can check the
00309  * specific in Netmaster as needed
00310  **/
00311 typedef enum {
00312   phnPDPConnectionTypeSIP = 0,          /**< PDP contains Simple IP settings  */
00313   phnPDPConnectionTypeMIPWithSIPFallback, /**< PDP contains MobileIP settings. Also allows Simple IP fallback - for Crowdy  */
00314   phnPDPConnectionTypeMIP,          /**< PDP contains Mobile IP settings  */
00315   phnPDPConnectionTypeInvalid
00316
00317 } _PhnPDPConnectionType;
00318
00319 typedef UInt8 PhnPDPConnectionType;     /**<        */
00320
00321 /**
00322  *  Bit mask that identifies the services a given profile should be used for
00323  **/
00324 typedef enum
00325 {
00326   phnPDPServiceUnknown = 0x00000000,        /**<        */
00327   phnPDPServiceInternet = 0x00000001,       /**< Profile to be used for generic internet  */
00328   phnPDPServiceWAP = 0x00000002,            /**< Profile to be used for WAP  */
00329   phnPDPServicePrivate = 0x00000004,        /**< Profile to be used for application specfic gateway  */
00330   phnPDPServiceMMS = 0x00000008,        /**< Profile to be used for MMS  */
00331   phnPDPServiceBrowser = 0x00000010,        /**< Profile to be used for Browser   */
00332   phnPDPServiceMail = 0x00000020,       /**< Profile to be used for email  */
00333   phnPDPServiceIM = 0x00000040,         /**< Profile to be used for IM  */
00334   phnPDPServiceDownloads = 0x00000080,      /**< Profile to be used for downloads  */
00335   phnPDPServiceCorporateGateway = 0x00000100,   /**< Profile to be used for corporate network  */
00336   phnPDPServicePictureMail = 0x00000200     /**< Profile for Picture Mail  */
00337 } _PhnPDPService;
00338
00339 typedef UInt32 PhnPDPService;       /**<        */
00340
00341 /**
00342  * None of the PDP strings (like service string, dial string, passwords etc.)
00343  * require null terminator and no need to count null terminator for the length.
00344  *
00345  * PhnPDPList structure lists status of all the packet data profile slots
00346  **/
00347 typedef struct
00348 {
00349     Boolean                         idx0_set ;
00350       /**< Boolean indicating if index contains a valid PDP in the modem.  */
00351
00352     Boolean                         idx1_set ;
00353       /**< Boolean indicating if index contains a valid PDP in the modem.  */
00354
00355     Boolean                         idx2_set ;
00356       /**< Boolean indicating if index contains a valid PDP in the modem.  */
00357
00358     Boolean                         idx3_set ;
00359       /**< Boolean indicating if index contains a valid PDP in the modem.  */
00360
00361     Boolean                         idx4_set ;
00362       /**< Boolean indicating if index contains a valid PDP in the modem.  */
00363
00364     Boolean                         idx5_set ;
00365       /**< Boolean indicating if index contains a valid PDP in the modem.  */
00366
00367     Boolean                         idx6_set ;
00368       /**< Boolean indicating if index contains a valid PDP in the modem.  */
00369
00370     Boolean                         idx7_set ;
00371       /**< Boolean indicating if index contains a valid PDP in the modem.  */
00372
00373     Boolean                         idx_RSVD8_set ;
00374       /**< Reserved field.  */
00375
00376     Boolean                         idx_RSVD9_set ;
00377       /**< Reserved field.  */
00378
00379     Boolean                         qnc_set ;
00380       /**< Boolean indicating if a valid QNC profile is stored in the modem. */
00381
00382     Boolean                         active_idx_set ;
00383       /**< Boolean indicating if there is currently an active index set in the
00384          modem. */
00385
00386     UInt8                            active_idx ;
00387       /**< Indication of which index is currently the active index in the modem
00388          if ACTIVE_IDX_SET. */
00389
00390     UInt8                            idx0_uid[phnPDPUidLen] ;
00391       /**< The Unique ID for the PDP stored in index if index is set. */
00392
00393     UInt8                            idx1_uid[phnPDPUidLen] ;
00394       /**< The Unique ID for the PDP stored in index if index is set. */
00395
00396     UInt8                            idx2_uid[phnPDPUidLen] ;
00397       /**< The Unique ID for the PDP stored in index if index is set. */
00398
00399     UInt8                            idx3_uid[phnPDPUidLen] ;
00400       /**< The Unique ID for the PDP stored in index if index is set. */
00401
00402     UInt8                            idx4_uid[phnPDPUidLen] ;
00403       /**< The Unique ID for the PDP stored in index if index is set. */
00404
00405     UInt8                            idx5_uid[phnPDPUidLen] ;
00406       /**< The Unique ID for the PDP stored in index if index is set. */
00407
00408     UInt8                            idx6_uid[phnPDPUidLen] ;
00409       /**< The Unique ID for the PDP stored in index if index is set. */
00410
00411     UInt8                            idx7_uid[phnPDPUidLen] ;
00412       /**< The Unique ID for the PDP stored in index if index is set. */
00413
00414     UInt8                          idx_rsvd8_uid[phnPDPUidLen] ;
00415       /**< Reserved field. */
00416
00417     UInt8                          idx_rsvd9_uid[phnPDPUidLen] ;
00418       /**< Reserved field. */
00419
00420     UInt8                            qnc_uid[phnPDPUidLen] ;
00421       /**< The Unique ID for the QNC profile stored in the modem. */
00422
00423     UInt8                            num_stand_pdp_idxs;
00424       /**< The number of standard PDPs in the modem. */
00425
00426     UInt8                            first_stand_pdp_idx;
00427       /**< IF NUM_STAND_PDP_IDXS is greater than zero, indicates the first
00428        standard PDP index (assumes set of all standard PDP indexes are
00429        sequential). */
00430     UInt8                            num_def_pdp_idxs;
00431       /**< The number of default PDPs in the modem that cannot be modified by
00432          an IOTA session. */
00433
00434     UInt8                            first_def_pdp_idx;
00435       /**< IF NUM_DEF_PDP_IDXS is greater than zero, indicates the first default
00436        PDP index (assumes set of all default PDP indexes are sequential). */
00437
00438     UInt8                            num_tmp_pdp_idxs ;
00439       /**< The Unique ID for the QNC profile stored in the modem. */
00440
00441     UInt8                            first_tmp_pdp_idx;
00442       /**< IF NUM_TMP_PDP_IDXS is greater than zero, indicates the first default
00443        PDP index (assumes set of all default PDP indexes are sequential). */
00444
00445 } PhnPDPList;
00446
00447 /**
00448  *
00449  **/
00450 typedef struct{
00451     UInt8                            idx  ;
00452       /**< The index of the PDP to write to in the modem.  The set of valid
00453          indexes that can be written to is dependent on the modem
00454          platform being used. */
00455
00456     Boolean                         use_existing_nai  ;
00457       /**< Boolean indicating if the NAI currently stored in this PDP should
00458          be saved.  If set to FALSE, the following two fields are used for
00459          new NAI value. */
00460
00461     UInt8                            nai_length  ;
00462       /**< The number of characters in the NAI. */
00463
00464     UInt8                            nai[phnMaxNAILen]  ;
00465       /**< The user NAI character string in ASCII representation */
00466
00467     Boolean                         use_existing_mn_aaa_ss  ;
00468       /**< Boolean indicating if the MN-AAA-SS currently stored in this PDP
00469          should be saved.  If set to FALSE, the following three fields are
00470          used for new MN-AAA-SS value. */
00471
00472
00473     Boolean                         store_mn_aaa_ss  ;
00474       /**< Boolean indicating if the MN-AAA shared secret parameter is to be
00475          stored with this PDP profile.  Setting this field to FALSE requires
00476          the host to send a temporary MN-AAA shared secret value to the modem
00477          before using this PDP to connect to a network.*/
00478
00479     UInt8                            mn_aaa_ss_length  ;
00480       /**< Length of the MN-AAA shared secret parameter to store in the modem
00481          for this PDP if the STORE_MN_AAA_SS field is set to TRUE.  */
00482
00483     UInt8  mn_aaa_ss[phnMaxMNAAASharedSecretLen ]  ;
00484       /**< Text/binary string of the MN-AAA shared secret parameter to store in the
00485           modem for this PDP if the STORE_MN_AAA_SS field is set to TRUE. */
00486
00487     Boolean                         use_existing_mn_ha_ss  ;
00488       /**< Boolean indicating if the MN-HA-SS currently stored in this PDP should
00489        be saved.  If set to FALSE, the following three fields are used for
00490        new MN-HA-SS value. */
00491
00492     UInt8                         reserved1 ;
00493       /**< for future use */
00494
00495     UInt8                            mn_ha_ss_length  ;
00496       /**< Length of the MN-HA shared secret parameter to store in the modem for
00497          this PDP */
00498
00499     UInt8  mn_ha_ss[phnMaxMNHASharedSecretLen]  ;
00500       /**< Text/binary string of the MN-HA shared secret parameter to store in the modem
00501          for this PDP */
00502
00503     Boolean                         use_existing_mn_aaa_spi  ;
00504       /**< Boolean indicating if the MN-AAA SPI currently stored in this PDP
00505          should be saved.  If set to FALSE, the following three fields are
00506          used for new MN-AAA SPI value. */
00507
00508     UInt8                         reserved2  ;
00509       /**< for future use */
00510
00511     Boolean                         set_mn_aaa_spi  ;
00512       /**< Boolean indicating if the SPI for MN-AAA authentication is to be set
00513          for this PDP*/
00514
00515     DWord                           mn_aaa_spi  ;
00516       /**< Integer value of the SPI for MN-AAA authentication parameter to store
00517          in the modem for this PDP if the SET_MN_AAA_SPI field is set to TRUE. */
00518
00519     Boolean                         use_existing_mn_ha_spi  ;
00520       /**< Boolean indicating if the MN-HA SPI currently stored in this PDP
00521          should be saved.  If set to FALSE, the following three fields are
00522          used for new MN-HA SPI value. */
00523
00524     UInt8                         reserved3  ;
00525       /**< for future use */
00526
00527     Boolean                         set_mn_ha_spi  ;
00528       /**< Boolean indicating if the SPI for MN-HA authentication is to be set
00529          for this PDP */
00530
00531     DWord                           mn_ha_spi  ;
00532       /**< Integer value of the SPI for MN-HA authentication parameter to store
00533          in the modem for this PDP if the SET_MN_HA_SPI field is set to TRUE. */
00534
00535     Boolean                         use_existing_rev_tunnel_pref  ;
00536       /**< Boolean indicating if the Reverse Tunneling Preference currently
00537          stored in this PDP should be saved.  If set to FALSE, the following
00538          two fields are used for new Reverse Tunneling Preference values. */
00539
00540     UInt8                         reserved4  ;
00541     /**< for future use */
00542
00543     Boolean                         rev_tunnel_pref  ;
00544       /**< Boolean indicating if reverse tunnel is to be used for this PDP. */
00545
00546     Boolean                         use_existing_home_addr  ;
00547       /**< Boolean indicating if the Home Address currently stored in this PDP
00548          should be saved.  If set to FALSE, the following two fields are used
00549          for new Home Address value. */
00550
00551     UInt8                        reserved5;
00552       /**< for future use */
00553
00554     DWord                           home_addr  ;
00555       /**< The home IP address of the modem.  Setting this address to 0.0.0.0
00556          will allow the IP address to be dynamically assigned by the PDSN for
00557          Mobile IP and Simple IP. */
00558
00559     Boolean                         use_existing_ha_addr  ;
00560       /**< Boolean indicating if the Home Agent IP Address currently stored in
00561          this PDP should be saved.  If set to FALSE, the following three
00562          fields are used for new Home Agent IP Address values. */
00563
00564     UInt8                         reserved6;
00565       /**< for future use */
00566
00567     DWord                           prim_ha_addr  ;
00568       /**< The Primary Home Agent IP address for this PDP */
00569
00570     DWord                           sec_ha_addr  ;
00571       /**< The Secondary Home Agent IP address for this PDP */
00572
00573     Boolean                         use_existing_svc_str  ;
00574       /**< Boolean indicating if the Service String currently stored in this
00575          PDP should be saved.  If set to FALSE, the following three fields are
00576          used for new Service String value. */
00577
00578     Boolean                         use_default_svc_str  ;
00579       /**< Boolean indicating if the service string name that the modem would
00580          create for this profile (the carrier name string + user name portion
00581          of NAI) should be stored as the service string for this PDP. */
00582
00583     UInt8                            svc_str_length  ;
00584       /**< The length of the service string to be stored for this PDP if
00585          USE_DEFAULT_SVC_STR is set to FALSE. */
00586
00587     UInt8  svc_str[phnMaxSvcStrLen]  ;
00588       /**< Text string of the service string to be stored for this PDP if
00589          USE_DEFAULT_SVC_STR is set to FALSE. */
00590
00591     Boolean                         use_existing_dial_str  ;
00592       /**< Boolean indicating if the Dial String currently stored in this PDP
00593          should be saved.  If set to FALSE, the following three fields are
00594          used for new Dial String values. */
00595
00596     Boolean                         use_default_dial_str  ;
00597       /**< Boolean indicating if the dial string to associated and stored
00598          with this PDP should be set to the default Packet Data dial string
00599          stored in the modem. */
00600
00601     UInt8                            dial_str_length  ;
00602       /**< The length of the dial string to be associated and stored with this
00603          PDP if USE_DEFAULT_DIAL_STR is FALSE.   */
00604
00605     UInt8  dial_str[phnMaxDialStrLen]  ;
00606       /**< The dial string to be associated and stored with this PDP if
00607          USE_DEFAULT_DIAL_STR is FALSE. */
00608
00609     Boolean                         use_existing_dns_server  ;
00610       /**< Boolean indicating if the DNS Server currently stored in this PDP
00611          should be saved.  If set to FALSE, the following three fields are
00612          used for new DNS Server values. */
00613
00614     Boolean                         dns_server_assigned  ;
00615       /**< Boolean indicating if specific DNS server IP addresses are to be
00616          associated and stored with this PDP. */
00617
00618     DWord                           prim_dns_addr  ;
00619       /**< The Primary DNS server IP address for this PDP if the
00620          DNS_SERVER_ASSIGNED field is set to TRUE. */
00621
00622     DWord                           sec_dns_addr  ;
00623       /**< The Secondary DNS server IP address for this PDP if the
00624          DNS_SERVER_ASSIGNED field is set to TRUE. */
00625
00626     PhnPDPConnectionType            connection_type;
00627       /**< Connection type of the PDP  */
00628
00629     PhnPDPService                   pdp_services;
00630      /**< Services for which this PDP should be used  */
00631 }PhnPDPWrite;
00632
00633 /**
00634  *  Packet data profile payload
00635  **/
00636  typedef struct {
00637     UInt8                            uid[phnPDPUidLen]   ;
00638       /**< The binary UID for this PDP.  */
00639
00640     Boolean                         restrict_nai   ;
00641       /**< Boolean indicating if the NAI field is restricted from being read from
00642          this PDP index.  None of the following NAI fields will contain valid
00643          data if set to TRUE.  */
00644
00645     UInt8                            nai_length   ;
00646       /**< The number of characters in the NAI.   */
00647
00648     UInt8                            nai[phnMaxNAILen]   ;
00649       /**< The user NAI character string in ASCII representation.   */
00650
00651     Boolean                         restrict_mn_aaa_ss   ;
00652       /**< Boolean indicating if the MN-AAA shared secret field is restricted
00653          from being read from this PDP index.  None of the following MN-AAA
00654          shared secret fields will contain valid data if set to TRUE. */
00655
00656     Boolean                         stored_mn_aaa_ss   ;
00657       /**< Boolean indicating if the MN-AAA shared secret parameter is stored
00658          with this PDP profile. */
00659
00660     UInt8                            mn_aaa_ss_length   ;
00661       /**< Length of the MN-AAA shared secret parameter for this PDP if the
00662          STORE_MN_AAA_SS field is set to FALSE. Maximum length shall be 16. */
00663
00664     UInt8  mn_aaa_ss[phnMaxMNAAASharedSecretLen]   ;
00665       /**< Text/binary string of the MN-AAA shared secret parameter stored in the modem
00666          for this PDP. */
00667
00668     Boolean                         restrict_mn_ha_ss   ;
00669       /**< Boolean indicating if the MN-HA shared secret field is restricted from
00670          being read from this PDP index.  None of the following MN-HA shared
00671          secret fields will contain valid data if set to TRUE. */
00672
00673     UInt8                            mn_ha_ss_length   ;
00674       /**< Length of the MN-HA shared secret parameter stored in the modem for
00675          this PDP.  Maximum length shall be 16. */
00676
00677     UInt8  mn_ha_ss[phnMaxMNHASharedSecretLen]   ;
00678       /**< Text/binary string of the MN-HA shared secret parameter stored in the modem
00679          for this PDP. */
00680
00681     Boolean                         restrict_mn_aaa_spi   ;
00682       /**< Boolean indicating if the SPI for MN-AAA authentication field is
00683          restricted from being read from this PDP index.  None of the following
00684          SPI for MN-AAA authentication fields will contain valid data if set to
00685          TRUE. */
00686
00687     Boolean                         set_mn_aaa_spi   ;
00688       /**< Boolean indicating if the SPI for MN-AAA authentication is set for
00689          this PDP */
00690
00691     DWord                           mn_aaa_spi   ;
00692       /**< Integer value of the SPI for MN-AAA authentication for this PDP. */
00693
00694     Boolean                         restrict_mn_ha_spi   ;
00695       /**< Boolean indicating if the SPI for MN-HA authentication field is
00696          restricted from being read from this PDP index.  None of the following
00697          SPI for MN-AAA authentication fields will contain valid data if set to
00698          TRUE. */
00699
00700     Boolean                         set_mn_ha_spi   ;
00701       /**< Boolean indicating if the SPI for MN-HA authentication is set for this
00702          PDP. */
00703
00704     DWord                           mn_ha_spi   ;
00705       /**< Integer value of the SPI for MN-HA authentication parameter for this
00706          PDP. */
00707
00708     Boolean                         restrict_rev_tunnel_pref   ;
00709       /**< Boolean indicating if the reverse tunnel setting is restricted from
00710          being read from this PDP index.  The REV_TUNNEL_PREF field will not
00711          contain valid data if set to TRUE. */
00712
00713     Boolean                         rev_tunnel_pref   ;
00714       /**< Boolean indicating if reverse tunnel is used for this PDP. */
00715
00716     Boolean                         restrict_home_addr   ;
00717       /**< Boolean indicating if the modem's Home Address setting is
00718          restricted from being read from this PDP index.  The HOME_ADDR field
00719          will not contain valid data if set to TRUE. */
00720
00721     DWord                           home_addr   ;
00722       /**< The home IP address of the modem for this PDP.  An address of 0.0.0.0
00723          indicates the IP address will be dynamically assigned by the PDSN for
00724          Mobile IP and Simple IP. */
00725
00726     Boolean                         restrict_ha_addr   ;
00727       /**< Boolean indicating if the Home Agent IP address fields are restricted
00728          from being read from this PDP index.  None of the following Home Agent
00729          IP address fields will contain valid data if set to TRUE. */
00730
00731     DWord                           prim_ha_addr   ;
00732       /**< The Primary Home Agent IP address for this PDP  */
00733
00734     DWord                           sec_ha_addr   ;
00735       /**< The Secondary Home Agent IP address for this PDP  */
00736
00737     UInt8                            svc_str_length   ;
00738       /**< The length of the service string for this PDP. */
00739
00740     UInt8  svc_str[phnMaxSvcStrLen]   ;
00741       /**< Text string of the service string for this PDP. */
00742
00743     UInt8                            dial_str_length   ;
00744       /**< The length of the dial string for this PDP. */
00745
00746     UInt8  dial_str[phnMaxDialStrLen]   ;
00747       /**< The dial string for this PDP. */
00748
00749     Boolean                         dns_server_assigned   ;
00750       /**< Boolean indicating if specific DNS server IP addresses are assigned
00751          for this PDP.  */
00752
00753     DWord                           prim_dns_addr   ;
00754       /**< The Primary DNS server IP address for this PDP if the
00755          DNS_SERVER_ASSIGNED field is set to TRUE. */
00756
00757     DWord                           sec_dns_addr   ;
00758       /**< The Secondary DNS server IP address for this PDP if the
00759          DNS_SERVER_ASSIGNED field is set to TRUE. */
00760
00761     PhnPDPConnectionType            connection_type;
00762       /**< Connection type of the PDP  */
00763
00764     PhnPDPService                   pdp_services;
00765      /**< Services for which this PDP should be used  */
00766
00767 } PhnPDPPayload;
00768
00769 /**
00770  *
00771  **/
00772 typedef struct
00773   {
00774     DWord                       lat;
00775      /**< Two's complement value of the latitude of the modem, in units of
00776          360/2^25 degrees. */
00777
00778     DWord                       lon;
00779      /**< Two's complement value of the longitude of the modem, in units of
00780          360/2^26 degrees. */
00781
00782     DWord                       time_stamp;
00783      /**< CDMA system time, in seconds, at the time the solution was valid. */
00784
00785     UInt8                        loc_uncertainty_ang;
00786      /**< Angle of axis with respect to True North for position uncertainty,
00787          in units of 5.625 degrees, in the range from 0 to 84.375 degrees,
00788          where 0 degrees is True North and the angle increases towards the
00789          East. */
00790
00791     PhnPDPAUncerttype         loc_uncertainty_a;
00792      /**< Standard deviation of axis along angle specified for position
00793          uncertainty. */
00794
00795     PhnPDPAUncerttype         loc_uncertainty_p;
00796      /**< Standard deviation of axis perpendicular to angle specified for
00797          position uncertainty. */
00798
00799     UInt8                        phn_pd_svc_mask;
00800      /**< Bit mask indicating which of the following optional fields contain
00801          valid data. */
00802
00803     UInt16                        altitude;
00804      /**< Height of the modem, in units of 1 meter, in the range from -500 m
00805          to 15883 m, where the binary value of the field conveys the height
00806          plus 500 m.  Valid if OPT_FIELD_MASK field has
00807          PDSM_PD_ALTITUDE_VALID bit set. */
00808
00809     UInt16                        heading;
00810      /**< Direction of the modem, in units of 360/2^10 degrees, in the range
00811          from 0 to 360x(1-2^10) degrees (where 0 degrees is True North and
00812          the angle increases towards the East.  Valid if OPT_FIELD_MASK
00813          field has PDSM_PD_VELOCITY_VALID bit set. */
00814
00815     UInt16                        velocity_hor;
00816      /**< Horizontal component of the velocity of the modem, in units of
00817          0.25 m/s, in the range from 0 to 127.75 m/s.  Valid if
00818          OPT_FIELD_MASK field has PDSM_PD_VELOCITY_VALID bit set. */
00819
00820     Boolean                     fix_t;
00821      /**< Boolean indicating fixed type.  0 means 2D fix and 1 means 3D
00822          fix. */
00823
00824     UInt16                        velocity_ver;
00825      /**< Two's complement value of the vertical component of the velocity of
00826          the modem, in units of 0.5 m/s, in the range from -64m/s to
00827          +63.5m/s.  Valid if OPT_FIELD_MASK field has
00828          PDSM_PD_VELOCITY_VALID bit set and FIX_T is set to TRUE. */
00829
00830     PhnPDPAUncerttype         loc_uncertainty_v;
00831      /**< Standard deviation of vertical error for position uncertainty.
00832          Valid if OPT_FIELD_MASK field has PDSM_PD_VELOCITY_VALID bit
00833          set. */
00834   }
00835 PhnPDDataType, *PhnPDDataPtr;
00836
00837 /**
00838  *
00839  **/
00840 typedef enum
00841 {
00842   phnSysPrefHomeOnly,       /**<        */
00843   phnSysPrefAOnly,      /**<        */
00844   phnSysPrefBOnly,      /**<        */
00845   phnSysPrefStandard        /**<        */
00846
00847 } _PhnSysPrefSetting;
00848
00849 typedef UInt8 PhnSysPrefSetting;        /**<        */
00850
00851 /**
00852  *
00853  **/
00854 typedef enum
00855 {
00856   phnGenericCDMASMSEncoding,        /**<        */
00857   phnGenericCDMAVoiceMailNumber,    /**<        */
00858   phnGenericCDMAVoiceMailOption,
00859   phnGenericCDMAAllowPDPSlotModification
00860 } _PhnGenericCDMAPreference;
00861
00862 typedef UInt32 PhnGenericCDMAPreference;  /**<      */
00863
00864 /**
00865  *
00866  **/
00867 typedef enum
00868 {
00869   phnSMSEncodingGSM = 0,        /**<        */
00870   phnSMSEncodingASCII,          /**<        */
00871   phnSMSEncodingISO8859_1       /**<        */
00872 } _PhnGenericCDMASMSEncodingType;
00873
00874 typedef UInt32 PhnGenericCDMASMSEncodingType;  /**<     */
00875
00876 /**
00877  *
00878  **/
00879 typedef enum
00880 {
00881   phnCDMAFirmwareSprint = 0,        /**<        */
00882   phnCDMAFirmwareVerizon,           /**<        */
00883   phnCDMAFirmwareBellMobility,      /**<        */
00884   phnCDMAFirmwareEarthlink,         /**<        */
00885   phnCDMAFirmwareCrowdy,            /**<CDMA rest of world*/
00886   phnCDMAFirmwareAlltel             /**<        */
00887 } _PhnCDMAFirmwareType;
00888
00889 typedef UInt32 PhnCDMAFirmwareType; /**<        */
00890
00891
00892 typedef enum
00893 {
00894   phnCDMAVoicemailMDN = 0,
00895   phnCDMAVoicemailMDN1,
00896   phnCDMAVoicemailDigits
00897 } _PhnCDMAVoicemailType;
00898
00899 typedef UInt32 PhnCDMAVoicemailType;
00900
00901
00902 #define PhnCDMAMediaTVSettingsMajorVersion 0x0001
00903 #define PhnCDMAMediaTVSettingsMinorVersion 0x0000
00904 #define PhnCDMAMediaTVSettingsVersion  (((UInt32)PhnCDMAMediaTVSettingsMajorVersion << 16) | PhnCDMAMediaTVSettingsMinorVersion)
00905 typedef struct _PhnCDMAMediaTVSettings
00906 {
00907   UInt32 version;                   /**< (1) should be set to the structure version that you are requesting */
00908
00909   char   homePage[phnMaxUrlLen+1];  /**< NULL terminated string */
00910   UInt32 proxyAddr;                 /**< proxy IP address       */
00911   UInt16 proxyPort;                 /**< proxy port             */
00912   UInt32 streamBufferSize;          /**< stream buffer size     */
00913   UInt32 streamTimeout;             /**< streaming timeout      */
00914 }
00915 PhnCDMAMediaTVSettingsType;
00916
00917
00918 #endif // _HS_PHONE_CDMA_TYPES_H__
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:53 2008 for Palm API Guide


Header Files » Incs » common » libraries » telephony

HsPhoneErrors.h

Go to the documentation of this file.
00001 /******************************************************************************
00002  * Copyright (c) 2004 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  *****************************************************************************/
00005 /** @ingroup Telephony
00006  *
00007  */
00008
00009
00010 /**
00011  *
00012  * @file    HsPhoneErrors.h
00013  *
00014  * @brief  Errors returned by API function in GSM/CDMA Library
00015  *
00016  * NOTES:
00017  *  This file is meant to contain all error codes that are returned
00018  *  by an API in the phone library. If the error is not being returned
00019  *  by an API call, please do not add it to this file, but keep it in
00020  *  a private header file in the libraries.
00021  */
00022
00023
00024
00025
00026 #ifndef HS_PHONE_ERRORS_H
00027 #define HS_PHONE_ERRORS_H
00028
00029 #include <HsErrorClasses.h> // For hsPhoneLibErrorClass_1
00030
00031 /**
00032  *  PHN Library result codes
00033  **/
00034 typedef Err PHNErrorCode;       /**<        */
00035
00036 enum PHNErrorCodeRange_1
00037   {
00038     phnErrorClass = hsPhoneLibErrorClass_1,
00039     phnErrParam,                    /**< 0x4001 - invalid [in] params or invalid state machine. */
00040     phnErrUnknownError,             /**< 0x4002 poorly used error code; in GSM library indicates unexpected error code from radio, or various random parameters having unexpected values */
00041     phnErrNoResponse,               /**< 0x4003 Fail to receive event from modem. */
00042     phnErrNotOpen,                  /**< 0x4004 phone library is not loaded for universal function or   PhnLibOpen is not called before the function is called. */
00043     phnErrStillOpen,                /**< 0x4005 opencount of phone lib is > 0 after PhnLibClose is called. */
00044     phnErrMemory,                   /**< 0x4006 insufficient memory to perform the operation */
00045     phnErrUnknownID,                /**< 0x4007 id from list is valid (e.g. from GSM connection list, SMS msg list, address book, etc) */
00046     phnErrNoPower,                  /**< 0x4008 when phone is off. */
00047     phnErrNoNetwork,                /**< 0x4009 No service. */
00048     phnErrNoConnection,             /**< 0x400a NOT USED IN GSM LIBRARY */
00049     phnErrNotAllowed,               /**< 0x400b operation not allowed (WISMO CME ERROR: 3, CMS ERROR: 302) */
00050     phnErrIllegalFacility,              /**< 0x400c invalid GSM barring facility specified when activating/deactivating call barring */
00051     phnErrIllegalCondition,             /**< 0x400d provided condition for operation is invalid (such as GSM call forwarding condition) */
00052     phnErrIllegalStatus,                /**< 0x400e invalid GSM SMS Message Status detected */
00053     phnErrIllegalIndex,             /**< 0x400f index out of range in list (such as SIM PhoneBook or segmented SMS msg) */
00054     phnErrIllegalChars,             /**< 0x4010 character out of GSM valid set in SMS or other text */
00055     phnErrIllegalMsg,               /**< 0x4011 NOT USED IN GSM LIBRARY */
00056     phnErrIllegalType,              /**< 0x4012 unexpected type encountered (for example unexpected SMS message type for operation) */
00057     phnErrIllegalNumber,                /**< 0x4013 unexpected character in DTMF string or GSM phone number */
00058     phnErrTimeout,                  /**< 0x4014 NOT USED IN GSM LIBRARY */
00059     phnErrUnknownApp,               /**< 0x4015 NOT USED IN GSM LIBRARY */
00060     phnErrUnknownNumber,                /**< 0x4016 given GSM phone number not found in address book */
00061     phnErrBufferTooSmall,               /**< 0x4017 NOT USED IN GSM LIBRARY */
00062     phnErrPasswordRequired,             /**< 0x4018 required GSM password or PIN is missing or invalid */
00063     phnErrResponsePending,              /**< 0x4019 operation failed because radio was busy processing another command */
00064     phnErrCancelled,                /**< 0x401a operation cancelled by user (e.g. cancel while entering password) */
00065     phnErrNoRecipient,              /**< 0x401b operation failed because GSM SMS message had no recipients specified */
00066     phnErrPhoneFailure,             /**< 0x401c Error reading/writing value to phone. */
00067     phnErrPhoneNotConnected,                /**< 0x401d WISMO CME ERROR: 1 */
00068     phnErrPhoneAdaptorLinkReserved,         /**< 0x401e WISMO CME ERROR: 2 */
00069     phnErrNotSupported,                     /**< 0x401f Operation not supported (WISMO CME ERROR: 4; CMS ERROR: 303) */
00070     phnErrPhPINRequired,                    /**< 0x4020 WISMO CME ERROR: 5 (PH-SIM PIN required (SIM lock)) */
00071     phnErrPhFPINRequired,                   /**< 0x4021 WISMO CME ERROR: 6 */
00072     phnErrPhFPUKRequired,                   /**< 0x4022 WISMO CME ERROR: 7 */
00073     phnErrNoSIM,                            /**< 0x4023 WISMO CME ERROR: 10 (SIM not inserted) */
00074     phnErrPINRequired,                      /**< 0x4024 WISMO CME ERROR: 11 (SIM PIN required) */
00075     phnErrPUKRequired,                      /**< 0x4025 WISMO CME ERROR: 12 (SIM PUK required) */
00076     phnErrSIMFailure,                       /**< 0x4026 WISMO CME ERROR: 13 (SIM failure) */
00077     phnErrSIMBusy,                          /**< 0x4027 WISMO CME ERROR: 14; CMS ERROR: 314; NOT DOCUMENTED IN WISMO DOC */
00078     phnErrSIMWrong,                         /**< 0x4028 WISMO CME ERROR: 15; CMS ERROR: 315; NOT DOCUMENTED IN WISMO DOC */
00079     phnErrIncorrectPassword,                /**< 0x4029 WISMO CME ERROR: 16 (Incorrect password) */
00080     phnErrPIN2Required,                     /**< 0x402a WISMO CME ERROR: 17 (SIM PIN2 required) */
00081     phnErrPUK2Required,                     /**< 0x402b WISMO CME ERROR: 18 (SIM PUK2 required) */
00082     phnErrMemoryFull,                       /**< 0x402c WISMO CME ERROR: 20 (Memory full ) */
00083     phnErrInvalidMemIndex,                  /**< 0x402d WISMO CME ERROR: 21 (Invalid index) */
00084     phnErrNotFound,                         /**< 0x402e WISMO CME ERROR: 22 (Not found) */
00085     phnErrMemFailure,                       /**< 0x402f WISMO CME ERROR: 23 NOT DOCUMENTED IN WISMO DOC */
00086     phnErrStringTooLong,                    /**< 0x4030 WISMO CME ERROR: 24 (Text string too long) */
00087     phnErrInvalidTextChars,                 /**< 0x4031 WISMO CME ERROR: 25 NOT DOCUMENTED IN WISMO DOC */
00088     phnErrDialStringTooLong,                /**< 0x4032 WISMO CME ERROR: 26 (Dial string too long) */
00089     phnErrInvalidDialChars,                 /**< 0x4033 WISMO CME ERROR: 27 (Invalid characters in dial string) */
00090     phnErrNoNetworkService,                 /**< 0x4034 WISMO CME ERROR: 30 (No network service); signal faded on CDMA */
00091     phnErrNetworkTimeout,                   /**< 0x4035 WISMO CME ERROR: 31; CMS ERROR: 332 NOT DOCUMENTED IN WISMO DOC */
00092     phnErrNetworkNotAllowed,                /**< 0x4036 WISMO CME ERROR: 32 (Network not allowed - emergency calls only) */
00093     phnErrNetPINRequired,                   /**< 0x4037 WISMO CME ERROR: 40 (Network personalisation PIN required (Network lock)) */
00094     phnErrNetPUKRequired,                   /**< 0x4038 WISMO CME ERROR: 41 */
00095     phnErrNetSubPINRequired,                /**< 0x4039 WISMO CME ERROR: 42 */
00096     phnErrNetSubPUKRequired,                /**< 0x403a WISMO CME ERROR: 43 */
00097     phnErrSPPINRequired,                    /**< 0x403b WISMO CME ERROR: 44 */
00098     phnErrSPPUKRequired,                    /**< 0x403c WISMO CME ERROR: 45 */
00099     phnErrCorpPINRequired,                  /**< 0x403d WISMO CME ERROR: 46 */
00100     phnErrCorpPUKRequired,                  /**< 0x403e WISMO CME ERROR: 47 */
00101     phnErrIllegalMS,                        /**< 0x403f WISMO CME ERROR: 103 */
00102     phnErrIllegalME,                        /**< 0x4040 WISMO CME ERROR: 106 */
00103     phnErrGPRSNotAllowed,                   /**< 0x4041 WISMO CME ERROR: 107 */
00104     phnErrPLMNNotAllowed,                   /**< 0x4042 WISMO CME ERROR: 111 */
00105     phnErrLocAreaNotAllowed,                /**< 0x4043 WISMO CME ERROR: 112 */
00106     phnErrRoamingNotAllowed,                /**< 0x4044 WISMO CME ERROR: 113 */
00107     phnErrOptionNotSupported,               /**< 0x4045 WISMO CME ERROR: 132 */
00108     phnErrReqOptionNotSubscribed,           /**< 0x4046 WISMO CME ERROR: 133 */
00109     phnErrOptionTempOutOfOrder,             /**< 0x4047 WISMO CME ERROR: 134 */
00110     phnErrUnspecifiedGPSRError,             /**< 0x4048 WISMO CME ERROR: 148 */
00111     phnErrAuthenticationFailure,            /**< 0x4049 WISMO CME ERROR: 149 */
00112     phnErrInvalidMobileClass,               /**< 0x404a WISMO CME ERROR: 150 */
00113     phnErrUnassignedNumber,                 /**< 0x404b WISMO CMS ERROR: 1 */
00114     phnErrOperDeterminedBarring,            /**< 0x404c WISMO CMS ERROR: 8 */
00115     phnErrCallBarred,                       /**< 0x404d WISMO CMS ERROR: 10 or 18  Call guard option does not allow call */
00116     phnErrSMSXferRejected,                  /**< 0x404e WISMO CMS ERROR: 21 */
00117     phnErrDestOutOfService,                 /**< 0x404f WISMO CMS ERROR: 27 */
00118     phnErrUnidentifedSubscriber,            /**< 0x4050 WISMO CMS ERROR: 28 */
00119     phnErrFacRejected,                      /**< 0x4051 WISMO CMS ERROR: 29 */
00120     phnErrUnknownSubscriber,                /**< 0x4052 WISMO CMS ERROR: 30 */
00121     phnErrNetworkOutOfOrder,                /**< 0x4053 WISMO CMS ERROR: 38 */
00122     phnErrTemporaryFailure,                 /**< 0x4054 WISMO CMS ERROR: 41 */
00123     phnErrCongestion,                       /**< 0x4055 WISMO CMS ERROR: 42, APEX 2,10,16,17  */
00124     phnErrResourcesUnavailable,             /**< 0x4056   No resources/network busy  */
00125     phnErrReqFacNotSubscribed,              /**< 0x4057 GSM Error */
00126     phnErrReqFacNotImplemented,             /**< 0x4058 GSM Error */
00127     phnErrInvalidSMSReference,              /**< 0x4059 GSM Error */
00128     phnErrInvalidMsg,                       /**< 0x405a GSM Error */
00129     phnErrInvalidMandInfo,                  /**< 0x405b GSM Error */
00130     phnErrMsgTypeNonExistent,               /**< 0x405c GSM Error */
00131     phnErrMsgNoCompatible,                  /**< 0x405d GSM Error */
00132     phnErrInfoElemNonExistent,              /**< 0x405e GSM Error */
00133     phnErrProtocolError,                    /**< 0x405f GSM Error */
00134     phnErrInterworking,                     /**< 0x4060 GSM Error */
00135     phnErrTelematicIWNotSupported,          /**< 0x4061 GSM Error */
00136     phnErrSMType0NotSupported,              /**< 0x4062 GSM Error */
00137     phnErrCannotReplaceMsg,                 /**< 0x4063 GSM Error */
00138     phnErrUnspecifiedTPPIDError,            /**< 0x4064 GSM Error */
00139     phnErrAlphabetNotSupported,             /**< 0x4065 GSM Error */
00140     phnErrMsgClassNotSupported,             /**< 0x4066 GSM Error */
00141     phnErrUnspecifiedTPDCSError,            /**< 0x4067 GSM Error */
00142     phnErrCmdCannotBeActioned,              /**< 0x4068 GSM Error */
00143     phnErrCmdUnsupported,                   /**< 0x4069 GSM Error */
00144     phnErrUnspecifiedTPCmdError,            /**< 0x406a GSM Error */
00145     phnErrTPDUNotSupported,                 /**< 0x406b GSM Error */
00146     phnErrSCBusy,                           /**< 0x406c GSM Error */
00147     phnErrNoSCSubscription,                 /**< 0x406d GSM Error */
00148     phnErrSCSystemFailure,                  /**< 0x406e GSM Error */
00149     phnErrInvalidSMEAddr,                   /**< 0x406f GSM Error */
00150     phnErrDestSMEBarred,                    /**< 0x4070 GSM Error */
00151     phnErrSMRejectedDuplicate,              /**< 0x4071 GSM Error */
00152     phnErrTPVPFNotSupported,                /**< 0x4072 GSM Error */
00153     phnErrTPVPNotSupported,                 /**< 0x4073 GSM Error */
00154     phnErrSMSStorageFull,                   /**< 0x4074 GSM Error */
00155     phnErrNoSMSStorage,                     /**< 0x4075 GSM Error */
00156     phnErrErrorInMS,                        /**< 0x4076 GSM Error */
00157     phnErrSIMApplToolkitBusy,               /**< 0x4077 GSM Error */
00158     phnErrMEFailure,                        /**< 0x4078 GSM Error */
00159     phnErrSMSServReserved,                  /**< 0x4079 WISMO CMS ERROR: 301 (SMS service of ME reserved) */
00160     phnErrInvalidParameter,                 /**< 0x407a GSM Error */
00161     phnErrFiller,                           /**< 0x407b GSM Error */
00162     phnErrFiller2,                          /**< 0x407c GSM Error */
00163     phnErrFiller3,                          /**< 0x407d GSM Error */
00164     phnErrMemoryFailure,                    /**< 0x407e Memory access failure */
00165     phnErrSCAddrUnknown,                    /**< 0x407f GSM Error */
00166     phnErrNoCNMAAckExpected,                /**< 0x4080 GSM Error */
00167         /** Errors returned by the firmware (NO CARRIER) */
00168     phnErrFDNMismatch,                      /**< 0x4081  GSM Error */
00169     phnErrEmergencyCallsOnly,               /**< 0x4082  GSM Error */
00170     phnErrACMLimitExceeded,                 /**< 0x4083  GSM Error */
00171     phnErrHoldError,                        /**< 0x4084  GSM Error */
00172     phnErrNumberBlacklisted,                /**< 0x4085  GSM Error */
00173     phnErrLidClosed,                        /**< 0x4086 */
00174     phnErrSATUnavailable,                   /**< 0x4087  GSM Error */
00175     phnErrSATInactive,                      /**< 0x4088  GSM Error */
00176     phnErrUNUSED,                           /**< 0x4089  GSM Error */
00177     phnErrRadioNotAvailable,                /**< 0x408a  GSM Error */
00178     phnErrIntermediateResult,               /**< 0x408b  GSM Error */
00179     phnErrUnexpectedResponse,               /**< 0x408c  GSM Error */
00180     phnErrDuplicatePage,                    /**< 0x408d  GSM Error */
00181     phnErrFirmwareBootNotInprogress,        /**< 0x408e  GSM Error */
00182     phnErrFirmwareBootInprogress,           /**< 0x408f  GSM Error */
00183         /** These error codes map directly to Wismo error
00184             codes, but maybe could be used by other radios? */
00185     phnErrMMFailed,                 /**< 0x4090  GSM Error */
00186     phnErrLowerLayer,               /**< 0x4091  GSM Error */
00187     phnErrCPError,                  /**< 0x4092  GSM Error */
00188     phnErrCommandInProgress,            /**< 0x4093  GSM Error */
00189     phnErrSATNotSupported,              /**< 0x4094  GSM Error */
00190     phnErrSATNoInd,                 /**< 0x4095  GSM Error */
00191     phnErrNeedResetModule,              /**< 0x4096  GSM Error */
00192     phnErrCOPSAbort,                /**< 0x4097  GSM Error */
00193
00194
00195     /** CSD CEER Errors */
00196     phnErrCSDUnassignedNumber,              /**< 0x4098  GSM Error */
00197     phnErrCSDNoRouteToDestination,          /**< 0x4099  GSM Error */
00198     phnErrCSDChannelUnacceptable,           /**< 0x409a  GSM Error */
00199     phnErrCSDOperatorBarring,               /**< 0x409b  GSM Error */
00200     phnErrCSDNumberBusy,                    /**< 0x409c  GSM Error */
00201     phnErrCSDNoUserResponse,                /**< 0x409d  GSM Error */
00202     phnErrCSDNoAnswer,                      /**< 0x409e  GSM Error */
00203     phnErrCSDCallRejected,                  /**< 0x409f  GSM Error */
00204     phnErrCSDNumberChanged,                 /**< 0x40a0  GSM Error */
00205     phnErrCSDDestinationOutOfOrder,         /**< 0x40a1  GSM Error */
00206     phnErrCSDInvalidNumberFormat,           /**< 0x40a2  GSM Error */
00207     phnErrCSDFacilityRejected,              /**< 0x40a3  GSM Error */
00208     phnErrCSDNoCircuitAvailable,            /**< 0x40a4  GSM Error */
00209     phnErrCSDNetworkOutOfOrder,             /**< 0x40a5  GSM Error */
00210     phnErrCSDTempFailure,                   /**< 0x40a6  GSM Error */
00211     phnErrCSDSwitchingCongestion,           /**< 0x40a7  GSM Error */
00212     phnErrCSDAccessInfoDiscarded,           /**< 0x40a8  GSM Error */
00213     phnErrCSDReqCircuitNotAvailable,        /**< 0x40a9  GSM Error */
00214     phnErrCSDResourceNotAvailable,          /**< 0x40aa  GSM Error */
00215     phnErrCSDQOSNotAvailable,               /**< 0x40ab  GSM Error */
00216     phnErrCSDFacilityNotSubscribed,         /**< 0x40ac  GSM Error */
00217     phnErrCSDIncomingCallsBarredCUG,        /**< 0x40ad  GSM Error */
00218     phnErrCSDBearerNotCapable,              /**< 0x40ae  GSM Error */
00219     phnErrCSDBearerNotAvailable,            /**< 0x40af  GSM Error */
00220     phnErrCSDServiceNotAvailble,            /**< 0x40b0  GSM Error */
00221     phnErrCSDBearerNotImplemented,          /**< 0x40b1  GSM Error */
00222     phnErrCSDACMOutOfRange,                 /**< 0x40b2  GSM Error */
00223     phnErrCSDFacilityNotImplemented,        /**< 0x40b3  GSM Error */
00224     phnErrCSDRestrictedBearer,              /**< 0x40b4  GSM Error */
00225     phnErrCSDServiceNotImplented,           /**< 0x40b5  GSM Error */
00226     phnErrCSDInvalidTransID,                /**< 0x40b6  GSM Error */
00227     phnErrCSDUserNotMemberCUG,              /**< 0x40b7  GSM Error */
00228     phnErrCSDIncompatibleDestination,       /**< 0x40b8  GSM Error */
00229     phnErrCSDInvalidTransitNetwork,         /**< 0x40b9  GSM Error */
00230     phnErrCSDSemanticallyIncorrectMessage,      /**< 0x40ba  GSM Error */
00231     phnErrCSDInvalidMandatoryInfo,          /**< 0x40bb  GSM Error */
00232     phnErrCSDMessageTypeNotImplemented,     /**< 0x40bc  GSM Error */
00233     phnErrCSDMessageTypeNotCompatible,      /**< 0x40bd  GSM Error */
00234     phnErrCSDInfoNotImplemented,            /**< 0x40be  GSM Error */
00235     phnErrCSDIEError,                       /**< 0x40bf  GSM Error */
00236     phnErrCSDMessageNotCompatible,          /**< 0x40c0  GSM Error */
00237     phnErrCSDRecoveryOnTimerExpiry,         /**< 0x40c1  GSM Error */
00238     phnErrCSDProtocolError,                 /**< 0x40c2  GSM Error */
00239     /** GPRS CEER Errors */
00240     phnErrGPRSRoamingNotAllowed,            /**< 0x40c3  GSM Error */
00241     phnErrGPRSNetworkRequestDetach,         /**< 0x40c4  GSM Error */
00242     phnErrGPRSNoService,                    /**< 0x40c5  GSM Error */
00243     phnErrGPRSNoAccess,                     /**< 0x40c6  GSM Error */
00244     phnErrGPRSServiceRefused,               /**< 0x40c7  GSM Error */
00245     phnErrGPRSNetworkRequestPDPDeactivate,      /**< 0x40c8  GSM Error */
00246     phnErrGPRSPDPDactivateLCCLinkActivation,    /**< 0x40c9  GSM Error */
00247     phnErrGPRSPDPDeactivateNwkRactivate,        /**< 0x40ca  GSM Error */
00248     phnErrGPRSPDPDactivateGMMAbort,             /**< 0x40cb  GSM Error */
00249     phnErrGPRSPDPDeactivateSNDCPFailure,        /**< 0x40cc  GSM Error */
00250     phnErrGPRSPDPActivateFailGMMError,          /**< 0x40cd  GSM Error */
00251     phnErrGPRSPDPActivateFailNetReject,         /**< 0x40ce  GSM Error */
00252     phnErrGPRSPDPActivateFailNoNSAPI,           /**< 0x40cf  GSM Error */
00253     phnErrGPRSPDPActivateFailSMRefuse,          /**< 0x40d0  GSM Error */
00254     /** MORE CSD Errors */
00255     phnErrCSDFDNError,                          /**< 0x40d1  GSM Error */
00256     phnErrCSDCallOperationNotAllowed,           /**< 0x40d2  GSM Error */
00257     phnErrCSDCallBarringOutgoing,               /**< 0x40d3  GSM Error */
00258     phnErrCSDCallBarringIncoming,               /**< 0x40d4  GSM Error */
00259     phnErrCSDCallImpossible,                    /**< 0x40d5  GSM Error */
00260     phnErrCSDLowerLayerFailure,                 /**< 0x40d6  GSM Error */
00261     /** More GPRS Errors */
00262     phnErrGPRSAPNMissing,                       /**< 0x40d7  GSM Error */
00263     /** More Errors */
00264     phnErrNoCarrier,                            /**< 0x40d8  GSM Error */
00265     phnErrSMSFDNError,              /**< 0x40d9  GSM Error : SMS Fixed Dialing error (CMS ERROR: 531) */
00266     phnErrNullParam,                    /**< 0x40da GSM Error : provided parameter is unexpectedly null */
00267     phnErrBadServiceCode,                   /**< 0x40db GSM Error : intermediate response has unexpected service code */
00268     phnErrBadATResult,                  /**< 0x40dc GSM Error : AT response from radio is missing or invalid */
00269     phnErrBadATCmd,                     /**< 0x40dd GSM Error : AT cmd to radio is missing or invalid */
00270     phnErrSIMDataDownload,              /**< 0x40de GSM Error : SIM Data Download error (CMS ERROR: 213) */
00271
00272     /**
00273      *  0x40df to 0x40FF are reserves for GSM errors in the original Treo's
00274      *  Phone Library
00275      */
00276
00277
00278
00279     /**
00280          *  IMPORTANT: the last valid error code for this error class is 0x40FF.
00281      *  If you exceed this range, you will collide with the next error class
00282      *  that belongs to PalmSource, and will have all kinds of conflicts, such
00283      *  as wrong error strings and wrong interpretation of errors by
00284      *  applications.
00285      */
00286
00287
00288     // Add new error codes before this one
00289     phnErrLAST_1
00290   };
00291
00292
00293 /**
00294  *  NOTE: The last error code allowed in Phone library error class #1 is
00295  *  0x40FF. We reserve a second error base to allow for more error codes
00296  *  below.  hsPhoneLibErrorClass_2 is 0x7300.
00297  */
00298 enum PHNErrorCodeRange_2
00299   {
00300     phnErrorClass_2 = hsPhoneLibErrorClass_2,
00301
00302     // NOTE: phnErrSaveNV was assigned an incorrect value of 0x4150 on Treo300.
00303     // This placed it and all subsequent error codes in Phone Library into
00304     // the error class 0x4100.  We're not allowed to use the error class 0x4100
00305     // because it belongs to PalmSource.  Per approval of Arun Mathias, and
00306     // Kiran Prasad we're redefining these error codes to start at the error
00307     // base hsPhoneLibErrorClass_2, which belongs to Handspring.  According to Arun, the
00308     // error codes which were defined starting with 0x4150 were low-level
00309     // error codes that were only used internally.
00310     //
00311     phnErrSaveNV,           /**< 0x7301 CDMA Error : Fail to save params to Modem's NV. */
00312     phnErrReadNV,                       /**< 0x7302 CDMA Error : Fail to read params from Modem's NV. */
00313     phnErrFiller4,                      /**< 0x7303 Filler -- you can use this error but dont remove. */
00314     phnErrFiller5,                      /**< 0x7304 Filler -- you can use this error but dont remove. */
00315 //    phnErrCmdCannotBeActioned,        /**< was 0x4154 CDMA Error : Fail to send command to modem. */
00316 // ***** DUPLICATE *****
00317     phnErrDuplicatePlaceHoldler,    /**< 0x7305 ************************************************* */
00318     phnErrFiller6,                      /**< 0x7306 Filler -- you can use this error but dont remove. */
00319     phnErrBatteryLowAlert,          /**< 0x7307 CDMA Error : Phone battery is under the first low alert level. */
00320     phnErrBatteryCharging,              /**< 0x7308 CDMA Error : Phone battery is being charged. */
00321     phnErrBadCRC,           /**< 0x7309 CDMA Error : bad CRC observed */
00322     phnErrNoAppRegistered,              /**< 0x730a CDMA Error : Need to have at least an app to register for the corresponding service. */
00323
00324     /** SOUND Management Errors */
00325     phnErrSndDelClass,                  /**< 0x730b CDMA Error : Should never send this value!!! */
00326     phnErrSndDelInvalidRingerID,        /**< 0x730c CDMA Error : The ringer index is not a valid ringer ID index */
00327     phnErrSndDelUnusedRingerID,         /**< 0x730d CDMA Error : The ringer index does not contain an active ringer idx to delete */
00328     phnErrSndDelUndeletableRingerID,    /**< 0x730e CDMA Error : The ringer index is a perminent ringer index */
00329     phnErrSndDelInternalMdmError,       /**< 0x730f CDMA Error : An internal modem error occurred when attempting to delete the file. */
00330     phnErrSndSaveClass,                 /**< 0x7310 CDMA Error : Should never send this value!!! */
00331     phnErrSndSaveFileNameInvalid,       /**< 0x7311 CDMA Error : The null terminated string was not found as the file name. */
00332     phnErrSndSaveBadDataLen,            /**< 0x7312 CDMA Error : The file data length and/or the block data length is invalid. */
00333     phnErrSndSaveBadRingerID,           /**< 0x7313 CDMA Error : The ringer index specified is invalid (not a write-able index or out of range) */
00334     phnErrSndSaveBadSoundType,          /**< 0x7314 CDMA Error : The file type is invalid or not currently supported */
00335     phnErrSndSaveOutOfMem,              /**< 0x7315 CDMA Error : First block of file could not be written due to limited memory */
00336     phnErrSndSaveInternalModem,         /**< 0x7316 CDMA Error : An internal modem error occurred when attempting to download this */
00337                                         /**< block of the file (file is discarded). */
00338     phnErrSndSaveBadRsp,                /**< 0x7317 CDMA Error : Modem thinks that the file is downloaded completely, but the host still */
00339                                         /**< has not sent all or vice versa. */
00340     phnErrSndSaveContClass,             /**< 0x7318 CDMA Error : Should never use this value */
00341     phnErrSndSaveContBadDataLen,        /**< 0x7319 CDMA Error : The block data length of the file data in this block is invalid. */
00342     phnErrSndSaveContSeqNum,            /**< 0x731a CDMA Error : The sequence number is not in series with previous file download command. */
00343     phnErrSndSaveContOutOfMem,          /**< 0x731b CDMA Error : Next block of file could not be written due to limited memory. */
00344     phnErrSndSaveContInternalModem,     /**< 0x731c CDMA Error : An internal modem error occurred when attempting to download this block of the file. */
00345
00346     phnErrModemBusy,            /**< 0x731d */
00347     phnErrModemOffline,         /**< 0x731e */
00348     /** IOTA errors */
00349     phnErrIOTACommitFailed,             /**< 0x731f CDMA Error : IOTA commit failed */
00350     phnErrIOTACommitInProgress,         /**< 0x7320 CDMA Error : IOTA commit is in progress */
00351     phnErrIS683ProtRevNotSupported,     /**< 0x7321 CDMA Error : The IOTA protocol revision is not supported */
00352     phnErrInvalidNAM,                   /**< 0x7322 CDMA Error : The NAM selected is invalid */
00353     phnErrNAMMismatched,                /**< 0x7323 CDMA Error : The NAM selected is not the same as the NAM currently used in the current session */
00354     phnErrIOTASessionActive,            /**< 0x7324 CDMA Error : An IOTA session is active */
00355     phnErrIOTANoSession,                /**< 0x7325 CDMA Error : No IOTA session currently */
00356     phnErrNVUnInitialized,      /**< 0x7326 CDMA Error : Uninitialized NV item */
00357     phnErrNvBadItem,        /**< 0x7327 CDMA Error : Bad or restricted NV item */
00358
00359
00360     phnErrPoweringDown,     /**< 0x7328 Error: The radio is currently */
00361                 /**< powering down and we can not do anything */
00362     phnErrDenied,           /**< 0x7329 Request denied */
00363     phnErrNotYetSupported,          /**< 0x732A Feature not yet supported */
00364     phnErrSMSMemoryFull,        /**< 0x732B No more memory to receive incoming SMS */
00365     phnErrSMSMemoryOK,      /**< 0x732C There is now enough memory to receive incoming SMS */
00366     phnErrCauseCode16,      /**< 0x732D GSM04.08: Cause code 16 */
00367     phnErrMissingCarKitDriver, /**< 0x732E The wired car kit driver is missing */
00368
00369     phnErrHCIMismatch,
00370     // Add new error codes before this one
00371     phnErrLAST_2
00372   };
00373
00374 #endif
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:53 2008 for Palm API Guide


Header Files » Incs » common » libraries » telephony

HsPhoneEvent.h

Go to the documentation of this file.
00001 /******************************************************************************
00002  * Copyright (c) 2004 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  *****************************************************************************/
00005 /** @ingroup Telephony
00006  *
00007  */
00008
00009
00010 /**
00011  *
00012  * @file    HsPhoneEvent.h
00013  *
00014  * @brief  Header file for the phone library (CDMA or GSM)
00015  *
00016  * NOTES:
00017  * Header file for the phone library (CDMA or GSM)
00018  *
00019  * This file defines the Notification Events between the Phone Library
00020  * (either GSM or CDMA) and applications.  These events allow applications
00021  * to react to changes of state in the Phone Library.
00022  *
00023  * Applications wishing to receive notification events from the Phone Library
00024  * must register using the PhnLibRegister call.  The services parameter to
00025  * PhnLibRegister is a bitmap identifying the classes of events that are of
00026  * interest.  To unregister for notifications the app can call PhnLibRegister
00027  * with the services parameter set to zero.
00028  *
00029  * Notifications are sent to applications based on their unique creatorID.
00030  * Confusion may occur if multiple versions of a single app exist with the same
00031  * creatorID.  In this case notifications will be sent to the latest version of
00032  * the app (even if this app was not the one that registered).  In general,
00033  * you should try to avoid this situation where possible.
00034  *
00035  * Each notification event is identified by a unique event code (see PhnEventCode).
00036  * The event code then determines the contents of the remainder of the
00037  * event.
00038  *
00039  * There are three styles of notifications from the Phone Library:
00040  *
00041  *  (1) universal broadcast notifications are sent to all registrants for
00042  *      a given service.  (for example, a change in the network registration
00043  *      status)
00044  *
00045  *  (2) exclusive broadcast notifications are sent to registrations one at a time.
00046  *      The first app that acknowledges the notification by setting the
00047  *      acknowedge flag will be presumed to own that notification.  Only this
00048  *      app should handle and respond to the notification.  For example, an
00049  *      incoming call or incoming SMS message will be acknowleged by an app
00050  *      that wants to answer the call or process the SMS message.
00051  *
00052  *  (3) direct notifications are sent directly to a specific app with a known
00053  *      interest in some occurence in the phone library.  These are typically
00054  *      used after an application has taken ownership of a particular call,
00055  *      message, or dialog.  By sending notifications directly to the owning
00056  *      app we avoid confusion with multiple apps sending competing instructions.
00057  */
00058
00059 #ifndef HS_PHONEEVENT_H
00060 #define HS_PHONEEVENT_H
00061 #include <PalmOS.h>
00062 #include <PalmTypes.h>
00063 #ifndef __CORE_COMPATIBILITY_H__
00064 #include <PalmCompatibility.h>
00065     // workaround for differing header files in sdk-3.5 and sdk-internal
00066     #ifndef __CORE_COMPATIBILITY_H__
00067     #define __CORE_COMPATIBILITY_H__
00068     #endif
00069 #endif
00070
00071 // this is not a good struct
00072 //#define USE_PHNSMSMESSAGETYPE
00073
00074 //Keep it same as defined in HICMSMS.h
00075 #define phnAddressDigitsMax 32
00076 #define phnUserDataMax      255
00077
00078 // Notification Types
00079 #define phnNotifySubscriber 'CLIP'          /**< GSM notification with caller ID  */
00080 #define phnNotifyEquipMode  'Heqp'      /**< GSM notificaiton for equip mode change  */
00081
00082 // Notification of a phone event
00083 #define phnLibLaunchCmdEvent        0xabad  /**< Phone Event notification. Used
00084                              to be 0x2bad, which is less than
00085                              Palm's custom base. Have to get
00086                              Palm to allow that.     */
00087
00088 #define phnLibLaunchCmdRegister     0xabae    /**< Sent to application to register with GSM library  */
00089
00090
00091 /**
00092  * unique identifier for Indication notification.   This value will be
00093  * contained in PhnEventType notification events of phnEvtIndication type.
00094  **/
00095 typedef enum {
00096     indicationSIMReady,         /**<        */
00097     indicationSIMMessages,      /**<        */
00098     indicationNetworkSearch,        /**< to display Network search banner */
00099     indicationPasswordAccepted, /**<        */
00100     indicationNetworkAvailable, /**<        */
00101     indicationStartingRadio,        /**< to update UI from radio being off */
00102     indicationPoweringOffRadio,     /**< notify app that the radio is turning off. */
00103     indicationResettingRadio,       /**< tell the app that the radio is resetting. */
00104     indicationAuthFailure,      /**< notify app that network authentication failed. */
00105     indicationSIMChanged,       /**< sent when the GSM library detects that the IMSI value has changed */
00106     indicationInitComplete,     /**< sent when the GSM library is done with it initialization when the radio is powered on */
00107   indicationOtaspMsg            /**< sent otasp msg from network */
00108 } PhnIndicationKind;
00109
00110 #define isValidPhnIndicationKind(i) ((i >= indicationSIMReady) && (i <= indicationSIMChanged))  /**<        */
00111
00112 /**
00113  * PhnEventCode is unique identifier for notifications between the Phone Library
00114  * and applications.  It is used in the eventType field in the header of notification
00115  * events (PhnEventType).
00116  **/
00117 typedef enum
00118   {
00119   phnEvtCardInsertion,      /**< 0x0000 < NOT USED.  OBSOLETE */
00120
00121   /** Network Registration has changed.
00122    *
00123    *  The Phone Library is responsible for registering the device to
00124    *  the carrier network, including handling roaming and losses of service.
00125    *  This notification occurs when the network registration state has changed.
00126    *  See PhnRegistrationStatus for possible state values.
00127    *
00128    *  This notification will be universally broadcast to applications
00129    * registered for any service.
00130    */
00131   phnEvtRegistration,       /**< 0x0001 < Phone able to find service  */
00132
00133   /** Error detected
00134    *
00135    *  This notification occurs on various error scenarios in the Phone Library.
00136    *  These may occur when unexpected errors are reported from the radio, or when
00137    *  an operation in progress has failed.
00138    *
00139    *  This notification is universally broadcast to applications in the
00140    *  service area where the error was detected (e.g. Voice, SMS, ...).
00141    */
00142   phnEvtError,              /**< 0x0002 < indicator of something important happens to the phone that needs to bring up alert */
00143
00144   /** phone-related keypress has occured on device
00145    *
00146    *  This notification occurs when the user presses a phone-related key on the device.
00147    *  Currently the only supported key is the headset button that can be used for
00148    *  basic call control.  In general, buttons available will be device dependent.
00149    *
00150    *  This notification is exclusively broadcast to all applications registered for the
00151    *  Voice Service.
00152    */
00153   phnEvtKeyPress,           /**< 0x0003 < Headset button pressed. */
00154
00155   /** change in power state of radio
00156    *
00157    *  This notification occurs when the power state of the radio is changing.  Applications
00158    *  may want to change their state, and take action based on the expected availability
00159    *  of the radio.
00160    *
00161    *  This notification is universally broadcast to all registered applications.
00162    */
00163   phnEvtPower,              /**< 0x0004  */
00164
00165   /** Password Dialog Control
00166    *
00167    *  This notification helps an application control the entry of a PIN on a
00168    *  device that is locked.
00169    *
00170    *  This notification is exclusively broadcast to all registered applications.
00171    *  Application that acknowledges the notification is presumed to own handling
00172    *  the password situation.
00173    */
00174   phnEvtPassword,           /**< 0x0005  */
00175
00176   /** outgoing call progress dialog
00177    *
00178    *  This notification is sent to help applications display the progress of an
00179    *  oubound call operation.
00180    *
00181    *  This notification is exclusively broadcast to all registered applications.
00182    *  Application that acknowledges the notification is presumed to be the only one
00183    *  to take any action on the outgoing call.
00184    */
00185   phnEvtProgress,           /**< 0x0006  */
00186
00187   /** indication of various changes of state in Phone Library
00188    *
00189    *  This notification is sent on various changes of state in the Phone Library.
00190    *  Most of these are related to activation and registration with the carrier
00191    *  network.  Applications that display gauges with state info will often need
00192    *  to be updated after this notification.
00193    *
00194    *  Indications are often used to direct GUI interactions in applications
00195    *  that interact with the user.  For example, the Network Search notification
00196    *  might cause an app to put up a special Network Search dialog.
00197    *
00198    *  See PhnIndicationKind for list of available indications.
00199    *
00200    *  The broadcast rules for indications vary depending on the type of indication.
00201    */
00202   phnEvtIndication,         /**< 0x0007  */
00203
00204   /** incoming call received
00205    *
00206    *  This notification is exclusively broadcast to applications registered for
00207    *  the Voice Service.  First application to acknowledge the notification will
00208    *  be presumed to control the call.  Normally application would answer the call,
00209    *  or forward it to another destination.
00210    *
00211    */
00212   phnEvtConnectInd,         /**< 0x0008  */
00213
00214   /** call has connected
00215    *
00216    *  Despite the name, this event is used BOTH when a call goes into
00217    *  connected state (e.g. is answered), and when a call joins a conference.
00218    *
00219    *  This notification is exclusively broadcast to applications registered for
00220    *  the Voice Service.  First application to acknowledge the notification will
00221    *  be presumed to control the call or conference.
00222    */
00223   phnEvtConnectConf,        /**< 0x0009  */
00224
00225   /** Number/name of call has changed
00226    *
00227    *  This notification is universally broadcast to all applications registered for
00228    *  the Voice Service.
00229    */
00230   phnEvtSubscriber,         /**< 0x000A  */
00231
00232   /** call has disconnected
00233    *
00234    *  This notification occurs when the remote party of an active voice call
00235    *  disconnects.  Note that if the call is in conference (or 3-way calling) mode, then
00236    *  a different phnEvtDisconnectConf notification will be sent instead (see below).
00237    *
00238    *  This notification is universally broadcast to all applications registered for
00239    *  the Voice or Data Services.
00240    */
00241   phnEvtDisconnectInd,      /**< 0x000B  */
00242
00243   /** call in conference (or 3-way calling) mode has disconnected
00244    *
00245    *  This notification occurs when a conference call is in progress, and one of the
00246    *  remote parties disconnects.
00247    *
00248    *  This notification is universally broadcast to all applications registered for
00249    *  the Voice Service.
00250    */
00251   phnEvtDisconnectConf,     /**< 0x000C An ACK for a disconnection command on a specific connection ID is received */
00252
00253   /** Outbound call attempt failed because remote party (or network) reported busy
00254    *
00255    *  This notification is universally broadcast to all applications registered for
00256    *  the Voice Service.
00257    */
00258   phnEvtBusy,               /**< 0x000D  */
00259
00260   /** Change in Call Status;  Application may need to update its state
00261    *
00262    *  This notification is sent on various changes in call state in the Phone Library.
00263    *  An application receiving this notification should poll for the connection status
00264    *  of any calls of interest, and update its own state as needed.
00265    *
00266    *  This notification is universally broadcast to all applications registered
00267    *  for the Voice Service.
00268    *********************************************************************/
00269   phnEvtUpdate,             /**< 0x000E  */
00270
00271   /** 3-way call mode
00272    *
00273    *  This notification occurs when a call goes into conferrence (or 3-way calling) mode.
00274    *
00275    *  This notification is universally broadcast to all applications registered
00276    *  for the Voice Service.
00277    */
00278   phnEvtConference,         /**< 0x000F  */
00279
00280   /** Incoming VoiceMail Message
00281    *
00282    *  This notification occurs when the Phone Library detects that there are
00283    *  pending VoiceMail messages available.
00284    *
00285    *  This notification is universally broadcast to all applications registered
00286    *  for the Voice Service.
00287    */
00288   phnEvtVoiceMail,          /**< 0x0010  */
00289
00290   /** Incoming SMS message received
00291    *
00292    * This notification occurs when the Phone Library receives an
00293    * incoming SMS (Simple Message Service) message.
00294    *
00295    * This notification will be exclusively broadcast to applications
00296    * registered for the SMS service.  The Application that acknowledges
00297    * the notification is assumed to own the message, and should take
00298    * any appropriate actions.
00299    */
00300   phnEvtMessageInd,         /**< 0x0011  */
00301
00302   /** Incoming segment of SMS Message received
00303    *
00304    * This notification occurs when the Phone Library receives a segment
00305    * of a multi-segment SMS (Simple Message Service) message.  Single
00306    * segment SMS messages will generate a MessageInd notification (see
00307    * above).
00308    *
00309    * This notification will be exclusively broadcast to applications
00310    * registered for the SMS service.  The Application that acknowledges
00311    * the notification is assumed to own the segment, and should take
00312    * any appropriate actions.
00313    */
00314   phnEvtSegmentInd,         /**< 0x0012  */
00315
00316   /** Status of outgoing SMS message has changed
00317    *
00318    * This notification occurs when the status of a particular SMS
00319    * message has changed.  For example, an SMS message might move from
00320    * the pending queue to the sent queue after being successfully
00321    * delivered.
00322    *
00323    * This notification will be sent directly to the application that
00324    * created the message, and is NOT broadcast based on app registrations.
00325    */
00326   phnEvtMessageStat,        /**< 0x0013  */
00327
00328   /** SMS message deleted from local DB on device
00329    *
00330    * This notification occurs when an SMS message is deleted from the
00331    * local Database on the device.
00332    *
00333    * This notification will be sent directly to the application that
00334    * created the message, and is NOT broadcast based on app registrations.
00335    */
00336   phnEvtMessageDel,         /**< 0x0014  */
00337
00338   /** SIM Contains SMS Messages
00339    *
00340    *  This notification indicates that the SIM (Subscriber Information
00341    *  Module) on a GSM phone contains SMS (Simple Messaging Service)
00342    *  messages.  This is not an indication of new messages, just that
00343    *  messages are stored.  This notification is typically sent during
00344    *  Phone Library activation.  In many cases, the application may want
00345    *  to move the SMS messages to a local DB on the device, freeing memory
00346    *  for future incoming messages.
00347    *
00348    *  This notification will use exclusive broadcast to applications
00349    *  registered for the SMS service.  The application that acknowledges
00350    *  the notification is responsible for taking any action on moving
00351    *  the SMS messages on the SIM (if desired).
00352    */
00353   phnEvtMessageMoved,       /**< 0x0015  */
00354
00355   /** SIM Application Toolkit (SAT) event
00356    *
00357    * The SIM Application Toolkit allows for simple applications that
00358    * can be placed on the SIM (Subscriber Identity Module) in a GSM
00359    * phone.  This notification will be sent when a SAT application is
00360    * requesting input/output to/from the user.
00361    *
00362    * This notification will use exclusive broadcast to applications
00363    * registered for the SIM Toolkit Service.  The Application that first
00364    * acknowedges the notification will be presumed to own the SAT session,
00365    * and should handle needed user dialog as appropriate.
00366    */
00367   phnEvtSATNotification,    /**< 0x0016  */
00368
00369   /** USSD input/output requested from network
00370    *
00371    * USSD (Unstructured Supplementary Services Data) is a supplementary
00372    * service to GSM networks that allows simple text dialogs
00373    * with applications based in the network.  This notification
00374    * is sent when the network is requesting USSD input/output to/from the user.
00375    * (see +CUSD event in radio documentation for more details)
00376    *
00377    * This notification will use exclusive broadcast to applications
00378    * registered for the Voice Service.  The Application that first
00379    * acknowledges the notification will be presumed to own the USSD session.
00380    * Typically, that app will want to display any USSD message to the user,
00381    * and handle any response from the user back to the network.
00382    */
00383   phnEvtUSSDInd,            /**< 0x0017  */
00384
00385   /** Phone Equipment state has changed
00386    *
00387    * On communicator devices there are pieces of equipment that directly
00388    * impact how the radio is used.  Examples of equipment include headset
00389    * jacks, car kits, lids, etc.  The equipment modes available will vary
00390    * with the model of communicator being used.  This notification will be
00391    * sent when ever the Phone Library detects that an available equipment
00392    * mode has changed.  See the type PhnEquipmentMode for the available
00393    * set of mode values.
00394    *
00395    * This notification will be universally broadcast to all applications
00396    * registered for any service.
00397    */
00398   phnEvtPhoneEquipmentMode, /**< 0x0018  */
00399
00400   /** GPRS Attach Registration has changed. (GSM/GPRS systems only)
00401    *
00402    *  GPRS (General Packet Radio Services) is an extension to the GSM
00403    *  wireless network that provides higher speed, always on data connections.
00404    *  The radio must attach to the GPRS network before any GPRS sessions
00405    *  can be established.  This notification will be sent when ever the
00406    *  status of the GPRS attach registration changes.   See type
00407    *  PhnRegistrationStatus for available registration states.
00408    *
00409    *  This notification will be universally broadcast to applications
00410    * registered for any service.
00411    */
00412   phnEvtGPRSRegistration,   /**< 0x0019  */
00413
00414   /** incoming MMS message available
00415    *
00416    *  This notification will be sent when the Phone Library receives an
00417    *  incoming MMS (Multi-media Message Service) message.
00418    *
00419    *  This notification will use exclusive broadcast to applications registered
00420    *  for the MMS service.  Application that first acknowledges the notification
00421    *  will be presumed to own the message.  Typically, that app will want
00422    *  to notify the user that there is a message available, and move the
00423    *  message into a system DB, freeing memory for future messages.
00424    */
00425   phnEvtMMSInd,             /**< 0x001A  */
00426
00427   /************************************************************
00428   * CDMA Events
00429   *************************************************************/
00430
00431
00432   /** SMS Memory Full
00433    *
00434    *  This notification indicates that memory for SMS messages is
00435    *  currently full, and no new SMS messages can be received until
00436    *  some memory is freed.  A phnEvtMemoryOK notification will be sent
00437    *  when memory becomes available.
00438    *
00439    *  CURRENTLY USED BY CDMA PHONE LIBRARY ONLY
00440    */
00441   phnEvtMemoryFull,         /**< 0x001B  */
00442
00443   /** SMS Memory no longer full
00444    *
00445    *  This notification indicates that memory for SMS messages is
00446    *  no longer full, and new SMS messages can be received.
00447    *
00448    *  CURRENTLY USED BY CDMA PHONE LIBRARY ONLY
00449    */
00450   phnEvtMemoryOK,           /**< 0x001C - < Memory is not full anymore, can receive messages Description  */
00451
00452   /** WAP Message received via SMS (WAP in IS-637 standard)
00453    *
00454    *  NOT CURRENTLY USED (WAP notifications use standard Palm notifications)
00455    */
00456   phnEvtWAPInd,             /**< 0x001D  */
00457
00458   /** Radio Debug Info
00459    *
00460    *  Periodically sent from Phone Library to Activation App when
00461    *  in debug mode.
00462    *
00463    *  CURRENTLY USED BY CDMA PHONE LIBRARY ONLY
00464    */
00465   phnEvtDebugReport,        /**< 0x001E  */
00466
00467   /** System Selection mode has changed
00468    *
00469    *  Radio mode has changed (e.g. to PCS mode)
00470    *
00471    *  CURRENTLY USED BY CDMA PHONE LIBRARY ONLY
00472    */
00473   phnEvtSSModeChanged,      /**< 0x001F  */
00474
00475   /** Position Info has changed
00476    *
00477    *  indication of change in physical location of device.  This may
00478    *  be determined by GPS, network triangulation (AFLT), or some other
00479    *  technique.
00480    *
00481    *  \TODO - rename this event & some of its data structures to be cleaner.
00482    *
00483    *  CURRENTLY USED BY CDMA PHONE LIBRARY ONLY
00484    */
00485   phnEvtPDDataChanged,      /**< 0x0020  */
00486
00487   /** 1XRTT Status has changed
00488    *
00489    *  1XRTT is a high speed data protocol used in CDMA radios.  This
00490    *  notification indicates that the status of the 1XRTT connection
00491    *  has changed.
00492    *
00493    *  CURRENTLY USED BY CDMA PHONE LIBRARY ONLY
00494    */
00495   phnEvtOneXStatus,         /**< 0x0021  */
00496
00497   /** Mobile IP connection failed
00498    *
00499    *  Mobile IP is a flavor of the TCP/IP protocol for use on mobile
00500    *  devices.  It allows applications to use a single IP address while
00501    *  in motion.  This notification occurs when a Mobile IP session
00502    *  fails to be established.
00503    *
00504    *  CURRENTLY USED BY CDMA PHONE LIBRARY ONLY
00505    */
00506   phnEvtMIPFailed,          /**< 0x0022  */
00507
00508   /** IOTA Status has changed
00509    *
00510    *  Internet Over The Air (IOTA) is a protocol for a network to
00511    *  update the radio using an internet connection (as opposed to
00512    *  Over The Air (OTA)).  This notification occurs as an IOTA
00513    *  session changes (e.g. is established, committed, ended, etc).
00514    *
00515    *  CURRENTLY GENERATED BY CDMA PHONE LIBRARY ONLY
00516    */
00517   phnEvtIOTAStatus,         /**< 0x0023  */
00518
00519   /** Data Channel availability has changed
00520    *
00521    *  This notification occurs if there is a change in the ability
00522    *  for an application to send/receive data using the radio.  For
00523    *  example on Class B radios, data is not available when a voice
00524    *  call is in progress.
00525    *
00526    * \TODO - this notification should be generated by GSM Phone Library too.
00527    *
00528    *  CURRENTLY GENERATED BY CDMA PHONE LIBRARY ONLY
00529    */
00530   phnEvtDataChannel,        /**< 0x0024  */
00531
00532   /** Mobile IP Registration successful
00533    *
00534    *  Mobile IP is a flavor of the TCP/IP protocol for use on mobile
00535    *  devices.  It allows applications to use a single IP address while
00536    *  in motion.  This notification occurs when a Mobile IP session
00537    *  is successfully established.  The notification phnEvtMIPFailed
00538    *  will occur if the session fails.
00539    *
00540    *  CURRENTLY GENERATED BY CDMA PHONE LIBRARY ONLY
00541    */
00542   phnEvtOneXMipRRQInd,      /**< 0x0025  */
00543
00544   /** 1XRTT Session has failed (mid-session)
00545    *
00546    *  1XRTT is a high speed data protocol used in CDMA radios.  This
00547    *  notification indicates that the 1XRTT session has failed, and
00548    *  is not available.  Note that 1XRTT session may be left in Dormant
00549    *  state.
00550    *
00551    *  CURRENTLY GENERATED BY CDMA PHONE LIBRARY ONLY
00552    */
00553   phnEvtOneXDataFail,       /**< 0x0026  */
00554
00555   /** Start Dialing of Outbound Call
00556    *
00557    *   This notification is sent when an outbound call begins dialing before
00558    *   the call is connected.  This notification is universally broadcast to
00559    *   all applications registered for the Voice service.  Notification
00560    *   uses same notification data as Connect indication.
00561    */
00562   phnEvtStartDial,          /**< 0x0027  */
00563
00564   /** Start of incoming call
00565    *
00566    *   This notification is sent when an incoming call if first detected.
00567    *   This notification is used to perform special pre-call processing
00568    *   like turning off of MMS playback before a call.  Any processing on
00569    *   this notification must be very quick (less than a few hundred miliseconds)
00570    *   as it could potentially delay an incoming call from being answered.
00571    *
00572    *   APPLICATIONS MUST NOT ANSWER THE CALL OR DO ANY CALL CONTROL BASED
00573    *   ON THIS NOTIFICATION.  A separate phnEvtConnectInd notification will
00574    *   be follow for this purpose.  The phnEvtConnectInd notification is normally
00575    *   processed by the Phone App, and uses exclusive broadcast.  Thus it may
00576    *   not be received by all applications.  The phnEvtStartIncomingCall
00577    *   notification is sent to all applications registered for Voice Service
00578    *   using Universal Broadcast.  The acknowledgement flag is NOT used.
00579    */
00580   phnEvtStartIncomingCall,  /**< 0x0028  */
00581
00582   /** Alerting/Preconnected of Outbound Call
00583    *
00584    *   This notification is sent when an outbound call is alerting or
00585    *   preconnected.  This notification is universally broadcast to
00586    *   all applications registered for the Voice service.  Notification
00587    *   uses same notification data as Connect indication.
00588    */
00589   phnEvtAlertingPreConnected,   /**< 0x0029  */
00590
00591   /** Alerting of Outbound Call (NOT USED, for future implementation)
00592    *
00593    *   NOT USED
00594    *   This notification is sent when an outbound call is alerting.
00595    *   This notification is universally broadcast to
00596    *   all applications registered for the Voice service.  Notification
00597    *   uses same notification data as Connect indication.
00598    */
00599   phnEvtAlerting,               /**< 0x002A  */
00600
00601   /** Preconnected of Outbound Call (NOT USED, for future implementation)
00602    *
00603    *   NOT USED
00604    *   This notification is sent when an outbound call is preconnected.
00605    *   This notification is universally broadcast to
00606    *   all applications registered for the Voice service.  Notification
00607    *   uses same notification data as Connect indication.
00608    */
00609   phnEvtPreConnected,           /**< 0x002B  */
00610
00611   /** Data session status change
00612    *  This should replace the OneXStatus, as this will encompass more info
00613    *  than OneXStatus
00614    */
00615   phnEvtDataSessionStatus,           /**< 0x002C   */
00616
00617   /** Data session disconnected
00618    *  This is sent up when the data call is disconnected.
00619    *  We can't use the phnEvtDisconnectInd because the structure uses the
00620    *  Err class.
00621    */
00622   phnEvtDataSessionDisconnected,     /**< 0x002D   */
00623
00624   /** Returns the network time and DST obtained from network to date time panel
00625    */
00626
00627   phnEvtNetworkTime, /**< 0x002E   */
00628
00629   kMaxPhnEvtSupported  /**< Must be at last position*/
00630 } PhnEventCode;
00631
00632 #define isValidPhnEventCode(e) ((e >= phnEvtCardInsertion) && (e < kMaxPhnEvtSupported)) /**<       */
00633
00634
00635 /**
00636  *
00637  */
00638 typedef struct
00639   {
00640     PhoneServiceClassType service;      /**< type of call being disconnected */
00641     Err code;                           /**< cause of disconnect (0 for normal hangup) */
00642   }
00643 PhnDisconnectEventType;
00644
00645 /**
00646  *
00647  **/
00648 typedef struct
00649   {
00650     PhnAddressHandle caller;        /**<        */
00651     PhoneServiceClassType service;  /**<        */
00652     Int16 lineNumber;               /**<        */
00653   }
00654 PhnSubscriberAddrInfo;
00655
00656 /**
00657  *
00658  **/
00659 typedef struct
00660   {
00661       PhnConnectionID call1ID;      /**<        */
00662       PhnConnectionID call2ID;      /**<        */
00663       PhnConnectionID conferenceID;     /**<        */
00664   }
00665 PhnConferenceDesc;
00666
00667
00668 /**
00669  *
00670  **/
00671 typedef struct
00672   {
00673       Err code;     /**<        */
00674       UInt32 id;        /**<        */
00675       // removed Count from CDMA structure to make GSM and CDMA the same. Must update library.
00676       // dont think we use the count now anyway. That was added to debug CRC errors as far as
00677       // I know
00678       UInt16 networkError;  /**< Error code returned by the network. If this
00679                      field is non-zero it contains that error code
00680                      returned by the network. The 'code' above will be
00681                      the Phone Library version of this error. */
00682   }
00683 PhnError;
00684
00685 /**
00686  * SMS Replacement types
00687  **/
00688 typedef UInt8 PhnSMSType;
00689 typedef enum
00690 {
00691   defaultType = 0,
00692   discardType0 = 0x40,          /**< Type 0 messages should be discarded. */
00693     replaceType1 = 0x41,        /**< Replace Short Message Type 1. */
00694     replaceType2 = 0x42,        /**< Replace Short Message Type 2. */
00695     replaceType3 = 0x43,        /**< Replace Short Message Type 3. */
00696     replaceType4 = 0x44,        /**< Replace Short Message Type 4. */
00697     replaceType5 = 0x45,        /**< Replace Short Message Type 5. */
00698     replaceType6 = 0x46,        /**< Replace Short Message Type 6. */
00699     replaceType7 = 0x47     /**< Replace Short Message Type 7. */
00700
00701 } PhnSMSTypeEnum;
00702
00703 /**
00704  * SMS Class types
00705  **/
00706 typedef UInt8 PhnSMSClass;
00707 typedef enum
00708 {
00709   classUnknown = 0, /**<        */
00710   class0,           /**< immediate display */
00711   class1,           /**<        */
00712   class2,       /**<        */
00713   class3        /**<        */
00714 } PhnSMSClassEnum;
00715
00716 /**
00717  * Struct that is sent when a new sms message event
00718  *   id                 - Unique id
00719  *   oldStatus          -
00720  *   newStatus          -
00721  *
00722  *   version            - Version number of the struct
00723  *   size               - Size of the struct
00724  *   msgType            - Indicates if message should be discarded or replaced
00725  *   msgClass           - Indicates msg class
00726  *   msgInd             - True if msg contains an indicator msg
00727  *   indicator.store    - True = store msg; False = may delete msg
00728  *   indicator.activate - True then activate indicator; False = deactivate indicator
00729  *   indicator.indType  - Type of indicator to display
00730  *   trasactionID       -
00731  *   timeStamp          - Time in seconds
00732  *   serviceCenterNumber- Service Center Number
00733  *   senderNumber       - Number of sender
00734  *   callbackAddress    - CallBack number
00735  *   destPort           -
00736  *   sourcePort         -
00737  **/
00738 typedef struct PhnSMSParams
00739 {
00740   UInt32 id;            /**<        */
00741   UInt8  oldStatus;     /**<        */
00742   UInt8  newStatus;     /**<        */
00743
00744   // new params
00745   UInt16  version;      /**<        */
00746   UInt16  size;         /**<        */
00747   PhnSMSType msgType;       /**<        */
00748   PhnSMSClass msgClass;     /**<        */
00749   Boolean moveRequested;    /**<        */
00750   Boolean msgInd;       /**<        */
00751   struct {
00752     Boolean store;      /**<        */
00753     Boolean activate;       /**<        */
00754     PhnMsgBoxType indType;  /**<        */
00755   } indicator;
00756
00757   UInt8   trasactionID;     /**<        */
00758   UInt32 timeStamp;         /**<        */
00759
00760   char serviceCenterNumber[kMaxPhoneNumberLen+1];   /**<        */
00761   char senderNumber[kMaxPhoneNumberLen+1];      /**<        */
00762   char callbackAddress[kMaxPhoneNumberLen+1];       /**<        */
00763
00764   Int32 destPort;       /**<        */
00765   Int32 sourcePort;     /**<        */
00766
00767   UInt16 networkMsgId;      /**<        */
00768   UInt8 priority;       /**<        */
00769   UInt8 privacy;        /**<        */
00770
00771 } PhnSMSParams;
00772
00773 #define PhnSMSParamsVersion 2       /**<        */
00774
00775
00776 /**
00777  * Phone buttons
00778  **/
00779 // <chg 11-04-2002 TRS> eliminate phone & data buttons.  These were from VisorPhone.
00780 typedef enum  {
00781     phnButtonHeadset,       /**<        */
00782     phnButtonRedial,        /**<        */
00783     phnButtonAnswerCall,        /**<        */
00784     phnButtonRejectCall,        /**<        */
00785     phnButtonIgnoreCall,        /**<        */
00786     phnButtonHoldCall,      /**<        */
00787     phnButtonConferenceCall,    /**<        */
00788     phnButtonLast           /**<        */
00789 } PhnModuleButtonType;
00790
00791 #define isValidPhnModuleButtonType(m) (m < phnButtonLast)   /**<        */
00792
00793 /**
00794  *
00795  **/
00796 typedef struct
00797   {
00798     PhnModuleButtonType key;        /**<        */
00799     UInt16            modifiers;    /**<        */
00800   }
00801 PhnKeyPressedParams;
00802
00803 /**
00804  *
00805  **/
00806 typedef struct
00807   {
00808     PhnRegistrationStatus status;   /**<        */
00809   }
00810 PhnRegistrationType;
00811
00812 /**
00813  *
00814  **/
00815 typedef struct
00816   {
00817     PhnPowerType    state;      /**<        */
00818   }
00819 PhnPowerEventType;
00820
00821 typedef Err (* ContinuePowerOnOffCallback) (UInt16 refNum); /**<        */
00822
00823 /**
00824  *
00825  **/
00826 typedef struct
00827   {
00828     PhnIndicationKind kind;         /**<        */
00829     char            filler;         /**<        */
00830     union
00831         {
00832         struct
00833             {
00834             Boolean state;      /**<        */
00835             } simReady;
00836         struct
00837             {
00838             GSMSIMMessagesDialogKind dialog;    /**<        */
00839             Boolean moveMessages;           /**<        */
00840         DWord mSIMMessagesAcknowledge;      /**< creator of move msg dialog for subsequent events */
00841             } simMessages;
00842         struct
00843             {
00844             PhnPasswordType type;       /**<        */
00845             } passwordAccepted;
00846         struct
00847             {
00848             Boolean state;          /**<        */
00849             } networkAvailable;
00850         struct
00851             {
00852               ContinuePowerOnOffCallback continuePowerOnOff;    /**<        */
00853             } powerOnOffContinueCallback;
00854     struct
00855         {
00856             UInt32 indicationCode;  /**<        */
00857         } otaspMsg;
00858
00859     } data;
00860
00861   }
00862 PhnIndicationType;
00863
00864
00865 typedef char PhnPassword[maxPasswordLen+2];     /**<        */
00866
00867 /**
00868  *
00869  **/
00870 typedef struct  {
00871     PhnPasswordType     type;       /**<        */
00872     PhnPasswordType     prevType;   /**<        */
00873     Err         error;      /**<        */
00874     PhnPassword     pin;        /**<        */
00875     PhnPassword     puk;        /**<        */
00876 } PhnPasswordEventType;
00877
00878
00879 /**
00880  *
00881  **/
00882 typedef enum  {
00883     kOpenDialog,        /**<        */
00884     kCloseDialog,       /**<        */
00885     kSetText,       /**<        */
00886     kSetRecipient,      /**<        */
00887     kShowSegment        /**<        */
00888 } PhnProgressType;
00889
00890 #define isValidPhnProgressType(p) (p <= kShowSegment)       /**<        */
00891 //#define isValidPhnProgressType(p) ((p >= kOpenDialog) && (p <= kShowSegment))
00892
00893 /**
00894  *
00895  **/
00896 typedef enum  {
00897     kDialogSetBarring,      /**<        */
00898     kDialogGetBarring,      /**<        */
00899     kDialogSetForwarding,       /**<        */
00900     kDialogGetForwarding,       /**<        */
00901     kDialogSetCallWaiting,      /**<        */
00902     kDialogGetCallWaiting,      /**<        */
00903     kDialogGetOperatorList,     /**<        */
00904     kDialogSetOperator,     /**<        */
00905     kDialogOperatorSelection,   /**<        */
00906     kDialogImmediateSend,       /**<        */
00907     kDialogDeferredSend,        /**<        */
00908     kDialogSendUSSD         /**<        */
00909 } PhnOpenDialogType;
00910
00911 #define isValidPhnOpenDialogType(o) (o <= kDialogSendUSSD)      /**<        */
00912 //#define isValidPhnOpenDialogType(o) ((o >= kDialogSetBarring) && (o <= kDialogSendUSSD))
00913
00914 /**
00915  *
00916  **/
00917 typedef struct {
00918     PhnProgressType     progress;   /**<        */
00919     PhnOpenDialogType   dialog;     /**<        */
00920     DWord           data;       /**< only for SMS progress */
00921 } PhnProgressEventType;
00922
00923 /**
00924  *
00925  **/
00926 typedef struct {
00927     PhnDatabaseID msgID;    /**<        */
00928     DWord msgOwner;     /**<        */
00929     Err error;      /**<        */
00930     UInt8 event;        /**<        */
00931 } PhnMovedMsgDescType;
00932
00933 /**
00934  *
00935  **/
00936 typedef struct {
00937     UInt16 count;           /**<        */
00938     PhnMovedMsgDescType* list;  /**<        */
00939 } PhnMovedMsgsParamsType;
00940
00941 /**
00942  *
00943  **/
00944 typedef struct {
00945     long    result;     /**<        */
00946     CharPtr string;     /**<        */
00947 } PhnUSSDEventType;
00948
00949 /**
00950  *
00951  **/
00952 typedef struct {
00953     MemHandle   dataH;          /**<        */
00954     UInt32      notificationType;   /**<        */
00955 } PhnSATEventType;
00956
00957 // for notificationType = kSATDisplayText
00958 /**
00959  *
00960  **/
00961 typedef struct {
00962     UInt32  signature;      /**<        */
00963     UInt32  notificationType;   /**<        */
00964
00965     UInt32  textOffset;     /**<        */
00966     UInt16  priority;       /**<        */
00967     UInt16  clearMode;      /**<        */
00968 } PhnSATEventDisplayText;
00969
00970 // for notificationType = kSATGetInkey
00971 /**
00972  *
00973  **/
00974 typedef struct {
00975     UInt32  signature;      /**<        */
00976     UInt32  notificationType;   /**<        */
00977
00978     UInt32  textOffset;     /**<        */
00979     UInt16  format;         /**< See GSMSATEventInputFormatEnum */
00980     UInt16  helpInfo;       /**<        */
00981 } PhnSATEventGetInkey;
00982
00983 // header for all SATEvents
00984 /**
00985  *
00986  **/
00987 typedef struct PhnSATEventHeader        PhnSATEventHeader;  /**<        */
00988 struct PhnSATEventHeader {
00989     UInt32  signature;      /**<        */
00990     UInt32  notificationType;   /**<        */
00991 };
00992
00993 // for notificationType = kSATGetInput
00994 /**
00995  *
00996  **/
00997 typedef struct {
00998     UInt32  signature;      /**<        */
00999     UInt32  notificationType;   /**<        */
01000
01001     UInt32  textOffset;     /**<        */
01002     UInt16  format;         /**< See GSMSATEventInputFormatEnum */
01003     UInt16  helpInfo;       /**<        */
01004     UInt16  echoMode;       /**<        */
01005     UInt16  minSize;        /**<        */
01006     UInt32  defaultOffset;      /**< offset of default value string at end of cmd block (0 if none) <chg 05-13-2002 TRS> bug # 13829 */
01007     UInt16  maxSize;        /**<        */
01008     UInt16 pad;
01009 } PhnSATEventGetInput;
01010
01011 // for notificationType = kSATSetupCall
01012 /**
01013  *
01014  **/
01015 typedef struct {
01016     UInt32  signature;      /**<        */
01017     UInt32  notificationType;   /**<        */
01018
01019     UInt32  numberOffset;       /**<        */
01020     UInt32  promptOffset;       /**<        */
01021     UInt16  type;           /**<        */
01022     UInt16  callType;
01023 } PhnSATEventSetupCall;
01024
01025 // for notificationType = kSATPlayTone
01026 /**
01027  *
01028  **/
01029 typedef struct {
01030     UInt32  signature;      /**<        */
01031     UInt32  notificationType;   /**<        */
01032
01033     UInt32  textOffset;     /**<        */
01034     UInt16  toneType;       /**<        */
01035     UInt16  timeUnit;       /**< valid only if timeInterval > 0 */
01036     UInt16  timeInterval;       /**<        */
01037     UInt16  pad;
01038 } PhnSATEventPlayTone;
01039
01040 // contain info for one menu item
01041 /**
01042  *
01043  **/
01044 typedef struct {
01045     UInt32  labelOffset;    /**<        */
01046     UInt32  features;   /**<        */
01047     UInt16  id;     /**<        */
01048     UInt16  nextAction; /**<        */
01049 } PhnSATEventMenuRec;
01050
01051 // for notificationType = kSATDisplaySubmenus
01052 /**
01053  *
01054  **/
01055 typedef struct {
01056     UInt32  signature;      /**<        */
01057     UInt32  notificationType;   /**<        */
01058
01059     UInt32  titleOffset;        /**<        */
01060     UInt32  defaultItem;        /**< only valid in submenu */
01061     UInt32  recordCount;        /**<        */
01062     PhnSATEventMenuRec  record[1];  /**<        */
01063 } PhnSATEventMenu;
01064
01065
01066 // for notificationType = kSATSendSS, kSATSendSMS, and kSATSendUSSD
01067 /**
01068  *
01069  **/
01070 typedef struct {
01071     UInt32  signature;      /**<        */
01072     UInt32  notificationType;   /**<        */
01073
01074     UInt32  textOffset;     /**<        */
01075 } PhnSATEventSendSMS;
01076
01077
01078 // for notificationType = kSATRefresh
01079 /**
01080  *
01081  **/
01082 typedef struct {
01083     UInt32  signature;      /**<        */
01084     UInt32  notificationType;   /**<        */
01085     UInt32  EFList;       /**< This is a bitmap of the efs to be refreshed*/
01086     UInt16  refreshType;  /**<        */
01087     UInt16  pad;
01088   } PhnSATEventRefresh;
01089
01090
01091 // for notificationType = kSATLaunchBrowser
01092 /**
01093  *
01094  **/
01095 typedef struct {
01096     UInt32  signature;      /**<        */
01097     UInt32  notificationType;   /**<        */
01098     UInt32  action;         /**<        */
01099     UInt32  urlOffset;          /**<        */
01100     UInt32  bearerOffset;       /**<        */
01101     UInt32  provOffset;         /**<        */
01102     UInt32  gatewayProxyOffset;     /**<        */
01103     UInt32  alphaIdOffset;      /**<        */
01104   } PhnSATEventLaunchBrowser;
01105
01106 // for notificationType = kSATIdleModeText
01107 /**
01108  *
01109  **/
01110 typedef struct {
01111     UInt32  signature;
01112     UInt32  notificationType;
01113
01114     UInt32  alphaIdOffset;
01115 } PhnSATEventIdleModeText;
01116
01117 // for notificationType = kSATIdleRunAT
01118 /**
01119  *
01120  **/
01121 typedef struct {
01122     UInt32  signature;
01123     UInt32  notificationType;
01124
01125     UInt32  alphaIdOffset;
01126 } PhnSATEventRunAT;
01127
01128
01129 // for notificationType = kSATDataSvc
01130 /**
01131  *
01132  **/
01133 typedef struct {
01134   UInt32  signature;
01135   UInt32  notificationType;
01136
01137   UInt8   chanId;
01138   UInt8   serviceType;      /** See GSMSATDataSvcType */
01139   UInt8 loginNeeded;
01140   UInt8 passwdNeeded;
01141   UInt32  alphaIdOffset;
01142 } PhnSATEventDataSvc;
01143
01144 // for notificationType = kSATSendDTMF
01145 /**
01146  *
01147  **/
01148 typedef struct {
01149   UInt32  signature;
01150   UInt32  notificationType;
01151
01152   UInt32  alphaIdOffset;
01153   UInt32  dtmfChar;
01154 } PhnSATEventSendDTMF;
01155
01156
01157 /**
01158  *
01159  **/
01160 typedef struct {
01161     long    mode;       /**<        */
01162 } PhnPhoneEquipmentMode;
01163
01164
01165 /**
01166  *
01167  **/
01168 typedef enum
01169   {
01170     eDbgUpdateNone,     /**<        */
01171     eDbgUpdateYes,      /**<        */
01172     eDbgUpdateQuit      /**<        */
01173   }
01174 PhnMiscDbgUpdateKind;
01175
01176 #define isValidPhnMiscDbgUpdateKind(x) ((x >= eDbgUpdateNone) && (x <= eDbgUpdateQuit)) /**<        */
01177
01178 /**
01179  *
01180  **/
01181 typedef struct
01182   {
01183     PhnMiscDbgUpdateKind miscUpdate;    /**<        */
01184   }
01185 PhnMiscDbgRptType;
01186
01187
01188 /**
01189  *
01190  **/
01191 typedef enum
01192   {
01193     kMsgIdReserved,     /**<        */
01194     kMsgIdDeliverMT,        /**<        */
01195     kMsgIdSubmitMO,     /**<        */
01196     kMsgIdcancelMO,     /**<        */
01197     kMsgIdDeliveryMTAck,    /**<        */
01198     kMsgIdUserAck       /**<        */
01199   }
01200 PhnMsgIDType;
01201
01202 #define isValidPhnMsgIDType(m) ((m >= kMsgIdReserved) && (m <= kMsgIdUserAck))  /**<        */
01203
01204
01205 /**
01206  *
01207  **/
01208 typedef enum
01209   {
01210     phnDataAvailable,       /**<        */
01211     phnDataNotAvailable     /**< Used by apps that need to know when they can use the data channel */
01212   }
01213 PhnDataChannelType;
01214
01215 #define isValidPhnDataChannelType(x) ((x == phnDataAvailable) || (x == phnDataNotAvailable))    /**<        */
01216
01217
01218 /**
01219  *
01220  **/
01221 typedef struct
01222   {
01223     Boolean init_rrq;           /**< true if initial registration, false if reregistration */
01224     DWord   life_timer;         /**< new lifetime value in seconds */
01225     DWord   rrq_timer;          /**< new reregistration time value in seconds */
01226     DWord   traffic_ck_delay_timer; /**< time in seconds to delay checking for data to trigger re-registration */
01227   }
01228 PhnOnexMipRRQType, *PhnOnexMipRRQPtr;
01229
01230
01231 /**
01232  * @name Palm Notifications
01233  *
01234  **/
01235 /*@{*/
01236 #define NAITextLength       72              /**<        */
01237 #define NAITextSize         (NAITextLength + 1)     /**<        */
01238 #define PasswordLength      16              /**<        */
01239 #define PasswordSize        (PasswordLength + 1)    /**<        */
01240 /*@}*/
01241
01242 /**
01243  * @name WAP defines
01244  *       Text Header elements
01245  *
01246  **/
01247 /*@{*/
01248 #define phnWAPEvent         'Hwap'      /**<        */
01249
01250 #define WAPMsgLength        160         /**<        */
01251 #define WAPMsgSize          (WAPMsgLength + 1)  /**<        */
01252 /*@}*/
01253
01254 /**
01255  * @name WakeUp notification
01256  *
01257  **/
01258 /*@{*/
01259 #define WUHeaderEscapeSeq     "//"              /**< start sequence of the header */
01260 #define WUTextHeader          "//WU"            /**< beginning of an wakeup header */
01261 #define WUTextHeaderLength    4                 /**< length of the header */
01262
01263 #define WUFieldDelimiter     ';'                /**< wakeup message fields are separated by a semi-colon */
01264
01265 #define phnWUEvent         'Hwak'           /**<        */
01266 /*@}*/
01267
01268 /**
01269  * @name UP stuff
01270  * Text Header elements
01271  **/
01272 /*@{*/
01273 #define UPHeaderEscapeSeq     "//"              /**< start sequence of the header */
01274 #define UPTextHeader          "//UP"            /**< beginning of an UP header */
01275 #define UPTextHeaderLength    4                 /**< length of the header */
01276
01277 #define phnUPEvent         'Hsup'       /**<        */
01278
01279 #define UPDataSize            160               /**< maximum size of the data sent from this message */
01280 /*@}*/
01281
01282 /**
01283   *  Network Wakeup Stuff
01284   *  Text Header elements
01285   **/
01286
01287 /** Structure passed to the callbacks registered for incoming wakeup notifications */
01288 struct WUNotificationEventType
01289 {
01290     UInt16 version;     /**< version number to provide future backwards compatibility */
01291
01292     void *headerP;      /**< pointer to raw header */
01293     UInt8 headerLen;    /**< length of headerP */
01294
01295     /** Network wakeup fields */
01296     char  NAI[NAITextSize];       /**< stores the NAI */
01297     char  _filler1_;              /**< for 16 bit allignment */
01298     UInt32 netTimeStamp;          /**< timestamp from the message */
01299     UInt8 reasonCode;             /**< a reason code from the message */
01300     char  _filler2_;              /**< for 16 bit allignment */
01301     char  password[PasswordSize]; /**< the password (encrypted) */
01302     char  _filler3_;              /**< for 16 bit allignment */
01303
01304     /** SMS related fields */
01305     UInt32 msgID; /**< ID into the SMS database to reference this
01306                   * message this ID is not gauranteed to be
01307                   * valid once the notification callback
01308                   * returns.  Users should make a copy of the
01309                   * msg if they want to work on it after the
01310                   * callback returns.
01311                   */
01312     UInt32 datetime;   /**< date/time stamp */
01313     Int32  reserved2;  /**< reserved*/
01314     Int32  reserved3;  /**< reserved*/
01315 };
01316
01317 #ifndef _cplusplus
01318 typedef struct WUNotificationEventType WUNotificationEventType; /**<        */
01319 #endif
01320
01321
01322 // UP Stuff
01323
01324
01325
01326 /** Structure passed to the callbacks registered for incoming UP notifications */
01327 struct UPNotificationEventType
01328 {
01329     UInt16 version;  /**< version number to provide future backwards compatibility */
01330
01331     void *headerP;    /**< pointer to raw header */
01332     UInt8 headerLen;  /**< length of headerP */
01333
01334     /** Network wakeup fields */
01335     char  UPData[UPDataSize + 1];        /**< stores the raw data */
01336     UInt8 _filler100_;
01337
01338     /** SMS related fields */
01339     UInt32 msgID; /**< ID into the SMS database to reference this
01340                   * message this ID is not gauranteed to be
01341                   * valid once the notification callback
01342                   * returns.  Users should make a copy of the
01343                   * msg if they want to work on it after the
01344                   * callback returns.
01345                   */
01346     UInt32 datetime;   /**< date/time stamp */
01347     Int32  reserved2;  /**< reserved*/
01348     Int32  reserved3;  /**< reserved*/
01349 };
01350
01351 #ifndef _cplusplus
01352 typedef struct UPNotificationEventType UPNotificationEventType; /**<        */
01353 #endif
01354
01355
01356 // WAP Stuff
01357
01358 /**
01359  * WAP push message - message content type
01360  **/
01361 typedef enum {
01362   kWAPContentTypeUnknown = 0,       /**<        */
01363   kWAPContentTypeIOTA,          /**<        */
01364   kWAPContentTypeMMS,           /**<        */
01365   kWAPContentTypeMMSText,       /**<        */
01366   kWAPContentTypeServiceLoad,       /**<        */
01367   kWAPContentTypeServiceLoadText,   /**<        */
01368   kWAPContentTypeServiceIndicator,  /**<        */
01369   kWAPContentTypeServiceIndicatorText   /**<        */
01370 } PhnWAPPushContentType;
01371
01372 typedef UInt8 PhnWAPPushContent;
01373 /**
01374  * WAP push message - message type
01375  * http://www.wapforum.org/wina/push-app-id.htm
01376  **/
01377 typedef enum {
01378   //URN                   //Number  //  Description
01379   kWAPAnyApp              = 0x00,   /**< Any Application */
01380   kWAPPushSIA             = 0x01,   /**< WAP Push SIA  */
01381   kWAPWmlUa               = 0x02,   /**< WML User Agent  */
01382   kWAPWtaUa               = 0x03,   /**< WTA User Agent  */
01383   kWAPMmsUa               = 0x04,   /**< This ID will used for application dispatching  to MMS User Agent in the handling of MMS notfication using WAP Push. See WAP-206-MMSCTR for more detail.  */
01384   kWAPPushSyncml          = 0x05,   /**< SyncML PUSH Application ID: used to push a SyncML Alert from a SyncML server side. The SyncML Alert is an indication for starting a SyncML session e.g., for data synchronization. Requested by the WAP WAG Synchronisation Drafting Committee.  */
01385   kWAPLocUa               = 0x06,   /**< This ID is used for application dispatching to Location User Agent in the handling of Location Invocation document. See WAP-257-LOCPROT for details. Requested by the WAP WAG Location Drafting Committee.   */
01386   kWAPSyncmlDm            = 0x07,   /**< This ID is used for SyncML Device Management. Requested by the SyncML Device Management Expert Group.   */
01387   kWAPDrmUa               = 0x08,   /**< This ID is used for DRM User Agent. Requested by the WAP WAG Download DC.   */
01388   kWAPEmnUa               = 0x09,   /**< This ID is used for Email Notification (EMN) User Agent. Requested by the WAP WAG PUSH DC.   */
01389   kWAPWvUa                = 0x0A,   /**< This ID is used for Wireless Village (EMN) User Agent. Requested by Wireless Village.   */
01390
01391   // Registered Values -----------------------------
01392   kWAPMsLocalcontentUa    = 0x8000, /**< An application to receive pages to be stored and access locally. These are not wta channels. Usually the pages will be downloaded as multi-part mime.   */
01393   kWAPMsIMclientUa        = 0x8001, /**< An application which will act as an instant messaging client on a phone.   */
01394   kWAPdocomoImodeMailUa   = 0x8002, /**< Used to identify the i-mode mail application user agent on a mobile device.   */
01395   kWAPdocomoImodeMrUa     = 0x8003, /**< Used to identify the i-mode message request application user agent on a mobile device.   */
01396   kWAPdocomoImodeMfUa     = 0x8004, /**< Used to identify the i-mode message free application user agent on a mobile device.   */
01397   kWAPMotorolaLocationUa  = 0x8005, /**< An application that receives message notifications from the location server.   */
01398   kWAPMotorolaNowUa       = 0x8006, /**< An application that presents personalized information to the user.   */
01399   kWAPMotorolaOtaprovUa   = 0x8007, /**< An application that receives provisioning messages from the server.   */
01400   kWAPMotorolaBrowserUa   = 0x8008, /**< A web browsing application.   */
01401   kWAPMotorolaSplashUa    = 0x8009, /**< An application that receives splash screen content from the server.   */
01402   kWAPUnused              = 0x800A, /**<        */
01403   kWAPNaiMvswCommand      = 0x800B, /**< Used by administrators to issue commands to individual devices.   */
01404   // unused  0x800C through 0x800F  /**<        */
01405   kWAPopenwaveIotaUa      = 0x8010  /**< Used for application dispatching to the IP-based OTA Provisioning Service Agent in the handling of IOTA notfications using WAP Push.   */
01406 } PhnWAPPushAppIdType;
01407
01408
01409 typedef UInt16 PhnWAPPushAppId;
01410
01411 /**
01412  * Structure passed to the callbacks registered for WAP notifications
01413  **/
01414 #define WAPNotificationTypeVersion   3      /**<        */
01415 struct WAPNotificationEventType
01416 {
01417     UInt16 version;         /**< version number to provide future backwards compatibility */
01418
01419     /** Network wakeup fields */
01420     char  *wapMsg;
01421     char  _filler1_;                    /**< for 16 bit allignment */
01422
01423     /** SMS related fields */
01424     UInt32 length;                      /**< originally the msgID, now it stores the length of the wapMsg */
01425     UInt32 datetime;                    /**< date/time stamp */
01426
01427     /** VERSION 3 ADDITION */
01428     UInt32 id;                      /**< msgID */
01429     PhnWAPPushContent contentType;  /**< WAP push message content type */
01430     PhnWAPPushAppId   appId;        /**< WAP push message application id */
01431 };
01432
01433 #ifndef _cplusplus
01434 typedef struct WAPNotificationEventType WAPNotificationEventType;   /**<        */
01435 #endif
01436
01437
01438 /**
01439  *  Phone Event Structure
01440  **/
01441 typedef struct
01442 {
01443   UInt8    eventType;     /**< PhnEventCode */
01444   Boolean  acknowledge;   /**<              */
01445   UInt16   connectionID;  /**<              */
01446   UInt16   launchCode;    /**<              */
01447   Ptr      launchParams;  /**<              */
01448   union Data
01449     {
01450       PhnDisconnectEventType   disconnect;              /**<        */
01451       PhnSubscriberAddrInfo    info;                    /**<        */
01452       PhnConferenceDesc        conference;              /**<        */
01453       PhnError                 error;                   /**<        */
01454       PhnSMSParams             params;                  /**<        */
01455       PhnKeyPressedParams      keyPressed;              /**<        */
01456       PhnRegistrationType      registration;            /**<        */
01457       PhnMsgBoxDataType        msgBox;                  /**<        */
01458       PhnPowerEventType        power;                   /**<        */
01459       PhnPasswordEventType     password;                /**<        */
01460       PhnProgressEventType     progress;                /**<        */
01461       PhnIndicationType        indication;              /**<        */
01462       PhnMovedMsgsParamsType   moved;                   /**<        */
01463       PhnUSSDEventType         ussd;                    /**<        */
01464       PhnSATEventType          sat;                     /**<        */
01465       PhnPhoneEquipmentMode    phoneEquipmentMode;      /**<        */
01466       PhnMiscDbgRptType        miscDbgRpt;              /**<        */
01467       PhnPDDataType            PDDataInfo;              /**< sent asynchronously by the modem */
01468       PhnOneXStatus            oneXStatus;              /**<        */
01469       PhnMIPFailType           mipSessionFailReason;    /**<        */
01470       PhnIOTAReportType        iotaInfo;                /**<        */
01471       PhnDataChannelType       dataChannelAvailability; /**< phnEvtDataChannel event <currently not used> */
01472       PhnOnexMipRRQType        PhnOnxMipRRQ;            /**<        */
01473       PhnOneXDataFailType      oneXFailReason;          /**<        */
01474       WAPNotificationEventType wapEvtParams;            /**<        */
01475       PhnDataSessionStateType  dataSesstionStatus;      /**< Sent when the data session state changes */
01476       PhnNetworkTime           networkTime;  /**< GSM Only, phnEvtNetworkTime */
01477
01478     }
01479   data;
01480 }
01481 PhnEventType, * PhnEventPtr;
01482
01483 #define PhnEventRecord PhnEventType
01484
01485 #endif
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:53 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » telephony

HsPhoneGSM.h

Go to the documentation of this file.
00001 /******************************************************************************
00002  * Copyright (c) 2004 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  *****************************************************************************/
00005 /** @ingroup Telephony
00006  *
00007  */
00008
00009
00010 /**
00011  * @file    HsPhoneGSM.h
00012  *
00013  * @brief  Header File for Phone Library API ---- GSM CATEGORY
00014  *
00015  * Notes:
00016  *  All implementations of the Handspring Phone Library support a common API.
00017  *  This API is broken up into various categories for easier management.  This file
00018  *  defines the SMS category.  These API calls are used for features that only apply
00019  *  to GSM networks.
00020  */
00021
00022
00023 #ifndef HS_PHONEGSM_H
00024 #define HS_PHONEGSM_H
00025 #include <PalmOS.h>
00026 #include <PalmTypes.h>
00027 #ifndef __CORE_COMPATIBILITY_H__
00028 #include <PalmCompatibility.h>
00029     /** workaround for differing header files in sdk-3.5 and sdk-internal */
00030     #ifndef __CORE_COMPATIBILITY_H__
00031     #define __CORE_COMPATIBILITY_H__
00032     #endif
00033 #endif
00034 #include <HsPhoneTraps.h>     /** trap table definition for phone library calls */
00035 #include <HsPhoneErrors.h>    /** error codes returned by phone library functions */
00036 #include <HsPhoneTypes.h>
00037
00038
00039 /**
00040  *  @brief Sets the active line number.
00041  *
00042  *  @param refNum:  IN:  Library reference number obtained from SysLibLoad.
00043  *  @param line:    IN:  Line number to be set to active.
00044  *  @retval 0 for success; otherwise failed and returned an error code
00045  *          as defined in “Phone Library Error Codes.”
00046  **/
00047 extern Err PhnLibSetActiveLine(UInt16 refNum, Int16 line)
00048         PHN_LIB_TRAP(PhnLibTrapSetActiveLine);
00049
00050
00051 /**
00052  *  @brief Retrieve the Fixed Dialing Numbers from the SIM.
00053  *
00054  *  @param refNum:  IN:  Library reference number obtained from SysLibLoad.
00055  *  @param aList:   IN:  Returned with the list of numbers
00056  *  @param info:    IN:
00057  *  @retval 0 for success; otherwise failed and returned an error code
00058  *          as defined in “Phone Library Error Codes.”
00059  **/
00060 extern Err PhnLibGetFDNList(UInt16 refNum, PhnAddressList* aList, PhnPhoneBookInfoPtr info)
00061         PHN_LIB_TRAP(PhnLibTrapGetFDNList);
00062
00063 /**
00064  *  @brief Set entry in the Fix Dialing field on the SIM.
00065  *
00066  *  @param refNum:  IN:  Library reference number obtained from SysLibLoad.
00067  *  @param index:   IN:  index into SIM
00068  *  @param name:    IN:  name value for SIM entry
00069  *  @param number:  IN:  phone number for SIM entry
00070  *  @retval 0 for success; otherwise failed and returned an error code
00071  *          as defined in “Phone Library Error Codes.”
00072  **/
00073 extern Err PhnLibSetFDNEntry (UInt16 refnum, UInt16 index, char* name, char * number)
00074               PHN_LIB_TRAP(PhnLibTrapSetFDNEntry);
00075
00076 /**
00077  *  @brief This routine reads the PhoneBook of phone numbers from your SIM (GSM only).
00078  *         This command can take several seconds if the PhoneBook is large.
00079  *
00080  *  @param refNum:  IN:  Library reference number obtained from SysLibLoad.
00081  *  @param numbers: IN:
00082  *  @param info:    IN:
00083  *  @retval 0 for success; otherwise failed and returned an error code
00084  *          as defined in “Phone Library Error Codes.”
00085  **/
00086 extern Err PhnLibGetPhoneBook (UInt16 refNum, PhnAddressList* numbers, PhnPhoneBookInfoPtr info)
00087               PHN_LIB_TRAP(PhnLibTrapGetPhoneBook);
00088
00089 /**
00090  *  @brief This routine writes the PhoneBook of phone numbers from your SIM (GSM only).
00091  *         This command can take several seconds if the PhoneBook is large.
00092  *
00093  *  @param refNum:  IN:  Library reference number obtained from SysLibLoad.
00094  *  @param numbers: IN:
00095  *  @retval 0 for success; otherwise failed and returned an error code
00096  *          as defined in “Phone Library Error Codes.”
00097  **/
00098 extern Err PhnLibSetPhoneBook (UInt16 refnum, PhnAddressList numbers)
00099               PHN_LIB_TRAP(PhnLibTrapSetPhoneBook);
00100
00101 /**
00102  *  @brief Set entry in SIM Phone Book
00103  *
00104  *  @param refNum:  IN:  Library reference number obtained from SysLibLoad.
00105  *  @param index:   IN:  index into SIM Phone Book
00106  *  @param name:    IN:  name value for SIM Phone Book entry
00107  *  @param number:  IN:  phone number for SIM Phone Book entry
00108  *  @retval 0 for success; otherwise failed and returned an error code
00109  *          as defined in “Phone Library Error Codes.”
00110  **/
00111 extern Err PhnLibSetPhoneBookEntry (UInt16 refnum, UInt16 index, char* name, char * number)
00112               PHN_LIB_TRAP(PhnLibTrapSetPhoneBookEntry);
00113
00114 /**
00115  *  @brief This routine gets the index of the given PhoneBook address on your SIM (GSM only).
00116  *
00117  *  @param unused:  IN:  for the future, set to 0.
00118  *  @param address:
00119  *  @retval Index number.
00120  **/
00121 extern UInt32 PhnLibGetPhoneBookIndex(UInt16, PhnAddressHandle address)
00122                   PHN_LIB_TRAP(PhnLibTrapGetPhoneBookIndex);
00123
00124
00125 /**
00126  *  @brief
00127  *
00128  *  @param refNum:  IN:
00129  *  @param aList:   IN:
00130  *  @param info:    IN:
00131  *  @retval Err Error code.
00132  **/
00133 extern Err PhnLibGetSDNList(UInt16 refNum, PhnAddressList* aList, PhnPhoneBookInfoPtr info)
00134         PHN_LIB_TRAP(PhnLibTrapGetSDNList);
00135
00136 /**
00137  *  @brief Send USSD value to radio
00138  *
00139  *  @param refNum:  IN:  Library reference number obtained from SysLibLoad.
00140  *  @param cmd:     IN:  USSD value to be sent
00141  *  @retval 0 for success; otherwise failed and returned an error code
00142  *          as defined in “Phone Library Error Codes.”
00143  **/
00144 extern Err  PhnLibSendUSSD (UInt16 refNum, CharPtr cmd)
00145                   PHN_LIB_TRAP(PhnLibTrapSendUSSD);
00146
00147 /**
00148  *  @brief Retrieve SAT main menu.
00149  *
00150  *  @param refNum:      IN:  Library reference number obtained from SysLibLoad.
00151  *  @param menuHandlePtr:   IN:  Pointer to a GSMSATEventMenuPtr.
00152  *  @retval 0 for success; otherwise failed and returned an error code
00153  *          as defined in “Phone Library Error Codes.” And the pointer
00154  *          is filled with a pointer to a main menu or phnErrSATUnavailable
00155  *          if there is no active session.
00156  **/
00157 extern Err PhnLibSATGetMainMenu(UInt16 refNum, MemHandle* menuHandlePtr)
00158               PHN_LIB_TRAP(PhnLibTrapSATGetMainMenu);
00159
00160 /**
00161  *  @brief Send application’s request to firmware
00162  *
00163  *  @param refNum:  IN:  Library reference number obtained from SysLibLoad.
00164  *  @param request: IN:  Request type
00165  *  @param decision:    IN:  Decision Type
00166  *  @param data:    IN:  Data to send
00167  *  @param length:  IN:  Length of data to send (only for Input)
00168  *  @retval 0 if succeed
00169  *          phnErrIllegalCondition:unrecognized parameters or an unneeded param is not zero.
00170  *          phnErrSATUnavailable:SAT is not available
00171  *          phnErrSATInactive : no active SAT session; must call
00172  *              PhnLibSATGetMainMenu() before calling this function().
00173  **/
00174 extern Err PhnLibSATSendRequest(UInt16 refNum, SATRequestType request, SATDecisionType decision, UInt32 data, UInt32 length)
00175               PHN_LIB_TRAP(PhnLibTrapSATSendRequest);
00176
00177 /**
00178  *  @brief Terminate an active SAT session.
00179  *
00180  *  @param refNum:  IN: Library reference number obtained from SysLibLoad.
00181  *  @retval 0 if succeeded or an error from PhnLibSATSendRequest() session
00182  **/
00183 extern Err PhnLibSATEndSession(UInt16 refNum)
00184               PHN_LIB_TRAP(PhnLibTrapSATEndSession);
00185
00186 /**
00187  *  @brief This routine reads the IMSI number from the SIM (Subscriber Information
00188  *         Module) on your GSM device. IMSI stands for International Mobile Subscriber
00189  *         Identify, and is used to uniquely identify a user to the wireless network.
00190  *
00191  *  @param refNum:  IN:  Library reference number obtained from SysLibLoad.
00192  *  @param imsi:    IN:  imsi number is a string pointer.
00193  *  @retval Boolean
00194  **/
00195 extern Boolean PhnLibSIMInfo (UInt16 refNum, CharPtr* imsi)
00196               PHN_LIB_TRAP(PhnLibTrapSIMInfo);
00197
00198 /**
00199  *  @brief This routine returns status of the SIM (Subscriber Information Module) on your
00200  *         GSM device. The SIM is managed by the radio module on the handset. The SIM
00201  *         must be present and active before the radio is allowed to make phone calls (other
00202  *         than emergency calls). The SIM also stores various user information and settings.
00203  *
00204  *  @param refNum:  IN: Library reference number obtained from SysLibLoad.
00205  *  @retval Sim Status
00206  **/
00207 extern GSMSIMStatus PhnLibGetSIMStatus(UInt16 refNum)
00208               PHN_LIB_TRAP(PhnLibTrapGetSIMStatus);
00209
00210 /**
00211  *  @brief Check if we are currently attached to the GPRS Network.
00212  *
00213  *  @param refNum:  IN: Library reference number obtained from SysLibLoad.
00214  *  @retval True if we are attached
00215  **/
00216 extern Boolean PhnLibGPRSAttached (UInt16 refNum)
00217                   PHN_LIB_TRAP(PhnLibTrapGPRSAttached);
00218
00219 /**
00220  *  @brief This function will store the given settings as a profile in the radios flash
00221  *         memory. The profile id will be the same as the context id that you pass
00222  *         with valid values between 1 and 32.
00223  *
00224  *  @param refNum:  IN:  Library reference number obtained from SysLibLoad.
00225  *  @param contextId:   IN:
00226  *  @param pdpType: IN:
00227  *  @param *apn:    IN:
00228  *  @param apnLen:  IN:
00229  *  @param *pdpAddr:    IN:
00230  *  @param pdpAddrLen:  IN:
00231  *  @param pdpDataCompression:  IN:
00232  *  @param pdpHdrCompression:   IN:
00233  *  @retval 0 for success; otherwise failed and returned an error code
00234  *          as defined in “Phone Library Error Codes.”
00235  **/
00236 extern Err PhnLibGPRSPDPContextDefine(UInt16 refNum,
00237   UInt16 contextId,
00238   PhnGPRSPDPType pdpType, const char* apn, UInt16 apnLen,
00239   const char* pdpAddr, UInt16 pdpAddrLen,
00240   UInt16 pdpDataCompression, UInt16 pdpHdrCompression)
00241               PHN_LIB_TRAP(PhnLibTrapGPRSPDPContextDefine);
00242
00243 /**
00244  *  @brief Get a linked list of pdp contexts currently stored on the device. It is
00245  *         necessary to call the Destruct after use of the list to free the memory.
00246  *
00247  *  @param refNum:  IN:  Library reference number obtained from SysLibLoad.
00248  *  @param listHeadPP:  IN:  Pointer to a pointer where the head of the linked list will be stored.
00249  *  @retval 0 for success; otherwise failed and returned an error code
00250  *          as defined in “Phone Library Error Codes.”
00251  **/
00252 extern Err PhnLibGPRSPDPContextListConstruct(UInt16 refNum, struct PhnGPRSPDPContextListNodeType** listHeadPP)
00253               PHN_LIB_TRAP(PhnLibTrapGPRSPDPContextListConstruct);
00254
00255 /**
00256  *  @brief Function that cleans up the list of pdp contexts created by the construct functions.
00257  *
00258  *  @param refNum:  IN:  Library reference number obtained from SysLibLoad.
00259  *  @param headNodePP:  IN:  Pointer to a pointer to the head of the list.
00260  *  @retval 0 for success; otherwise failed and returned an error code
00261  *          as defined in “Phone Library Error Codes.”
00262  **/
00263 extern Err PhnLibGPRSPDPContextListDestruct(UInt16 refNum, struct PhnGPRSPDPContextListNodeType** headNodePP)
00264               PHN_LIB_TRAP(PhnLibTrapGPRSPDPContextListDestruct);
00265
00266 /**
00267  *  @brief Set either the Required or Minimum QOS service parameters. If 0 is passed for the
00268  *         parameter, the network will decide the settings. Valid settings are listed below
00269  *
00270  *  @param refNum:  IN:  Library reference number obtained from SysLibLoad.
00271  *  @param qosType: IN:  Required or Minimum.
00272  *  @param contextId:   IN:  id of the profile that you are setting with these QOS Values.
00273  *  @param precedence:  IN:  (1-3) 1 being highest priority
00274  *  @param delay:   IN:  (1-3) Predictive 4 - Best Effort
00275  *  @param reliability: IN:  (1-5) - Unknown
00276  *  @param peakThroughput:  IN:  (1-9) 1 is the lowest and 9 the highest
00277  *  @param meanThroughput:  IN:  (1-9) 1 is the lowest and 9 the highest
00278  *  @retval 0 for success; otherwise failed and returned an error code
00279  *          as defined in “Phone Library Error Codes.”
00280  **/
00281 extern Err PhnLibGPRSQualityOfServiceGet(UInt16 refNum, PhnGPRSQOSType qosType, UInt16 contextId,
00282   UInt16* precedence, UInt16* delay, UInt16* reliability, UInt16* peakThroughput,
00283   UInt16* meanThroughput)
00284               PHN_LIB_TRAP(PhnLibTrapGPRSQualityOfServiceGet);
00285
00286 /**
00287  *  @brief Set either the Required or Minimum QOS service parameters. If 0 is passed for the
00288  *         parameter, the network will decide the settings. Valid settings are listed below.
00289  *
00290  *  @param refNum:  IN:  Library reference number obtained from SysLibLoad.
00291  *  @param qosType:     IN:  Required or Minimum.
00292  *  @param  contextId:  IN:  id of the profile that you are setting with these QOS Values.
00293  *  @param  precedence: IN:  (1-3) 1 being highest priority
00294  *  @param  delay:  IN:  (1-3) Predictive 4 - Best Effort
00295  *  @param  reliability:    IN:  (1-5) - Unknown
00296  *  @param  peakThroughput: IN:  (1-9) 1 is the lowest and 9 the highest
00297  *  @param  meanThroughput: IN:  (1-9) 1 is the lowest and 9 the highest
00298  *  @retval 0 for success; otherwise failed and returned an error code
00299  *          as defined in “Phone Library Error Codes.”
00300  **/
00301 extern Err PhnLibGPRSQualityOfServiceSet(UInt16 refNum, PhnGPRSQOSType qosType, UInt16 contextId,
00302   UInt16 precedence, UInt16 delay, UInt16 reliability, UInt16 peakThroughput,
00303   UInt16 meanThroughput)
00304                 PHN_LIB_TRAP(PhnLibTrapGPRSQualityOfServiceSet);
00305
00306 /**
00307  *  @brief
00308  *
00309  *  @param refNum:  IN:
00310  *  @param digit:   IN:
00311  *  @param sendMode:    IN:
00312  *  @param on:      IN:
00313  *  @retval Err Error code.
00314  **/
00315 extern Err PhnLibSendLongDTMF(UInt refNum, Char digit, PhnAudioSendMode sendMode,
00316     Boolean on)
00317           PHN_LIB_TRAP(PhnLibTrapSendLongDTMF);
00318
00319 /**
00320  *  @brief
00321  *
00322  *  @param refNum:  IN:
00323  *  @param iccid:   IN:
00324  *  @retval Err Error code.
00325  **/
00326 extern Err PhnLibGetICCID (UInt refNum, CharPtr* iccid)
00327               PHN_LIB_TRAP(PhnLibTrapGetICCID);
00328
00329
00330
00331 /**
00332  *  @brief Retreives currrent/camped Location Area Code (LAC) and Cell ID.
00333  *
00334  *  @param refNum:  IN:  Library reference number obtained from SysLibLoad.
00335  *  @param pLac :   IN:  Pointer to UInt32 thats populated with LAC upon successful return.
00336  *  @param pCellId :    IN:  Pointer to UInt32 thats populated with Cell ID upon successful return.
00337  *  @retval Err Error code as defined in HsPhoneErrors.h
00338  **/
00339 extern Err PhnLibGetGSMCellInfo (UInt refNum, UInt32 *pLac, UInt32 *pCellId)
00340               PHN_LIB_TRAP(PhnLibTrapGetGSMCellInfo);
00341
00342
00343
00344 /**
00345  *  @brief
00346  *
00347  *  @param refNum:  IN: Library reference number obtained from SysLibLoad
00348  *  @param spn:     IN: Service Provider Name from SIM
00349  *  @retval Err Error code.
00350  **/
00351 extern Err PhnLibGetSpn (UInt refNum, CharPtr* spn)
00352               PHN_LIB_TRAP(PhnLibTrapGetSpn);
00353 #endif
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:53 2008 for Palm API Guide


Header Files » Incs » common » libraries » telephony

HsPhoneGSMTypes.h

Go to the documentation of this file.
00001 /******************************************************************************
00002  * Copyright (c) 2004 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  *****************************************************************************/
00005 /** @ingroup Telephony
00006  *
00007  */
00008
00009
00010 /**
00011  *
00012  * @file    HsPhoneGSMTypes.h
00013  *
00014  * @brief  Header File for Phone Library API ---- NETWORK CATEGORY
00015  *
00016  * NOTES:
00017  *  All implementations of the Handspring Phone Library support a common API.
00018  *  This API is broken up into various categories for easier management.  This file
00019  *  defines the GSM category.  These API calls are used to interact with the wireless network.
00020  */
00021
00022
00023
00024 #ifndef _HS_PHONE_GSM_TYPES_H__
00025 #define _HS_PHONE_GSM_TYPES_H__
00026 #include <PalmOS.h>
00027 #include <PalmTypes.h>
00028 #ifndef __CORE_COMPATIBILITY_H__
00029 #include <PalmCompatibility.h>
00030     /** workaround for differing header files in sdk-3.5 and sdk-internal */
00031     #ifndef __CORE_COMPATIBILITY_H__
00032     #define __CORE_COMPATIBILITY_H__
00033     #endif
00034 #endif
00035
00036 /**
00037  *  @name
00038  *
00039  */
00040 /*@{*/
00041 #define     GSMLockSelectorOperatorLock     ('PN')  /**<        */
00042 #define     GSMLockSelectorProviderLock     ('PP')  /**<        */
00043 /*@}*/
00044
00045
00046 /**
00047  *  @name
00048  *
00049  */
00050 /*@{*/
00051 //<chg 09-16-2002 TRS> moved from gsmlibrary.h
00052 #define phnNetPrefGPRSPDPContextID  1                   /**<        */
00053
00054 // <chg 09-12-2002 TRS> DUO CLEANUP - moved from gsmlibrary.h (for now)
00055 // This is a prebuilt database.  So if this name changes, need to make
00056 // sure that the following references to the Ring Tone database name
00057 // are updated as well:
00058 // 1. In the Viewer/Prebuilt directory, update the actual name
00059 //    of the pdb file
00060 // 2. In the GSMLibrary Makefile, update ringTonePdbName
00061 // 3. In GSMLibraryCommon.rcp, update the DATA 'dflt' 1 resource
00062 // 4. In PhoneLib.h
00063 #define GSMLibRingsDbName           "System Ring Tones"     /**< Name of GSM RingTone DB  */
00064
00065 // Return if the lineNumber is unknown.  Maybe returned from the PhnLibGetRadioState
00066 // if the activeLineNumber as not been determined yet.
00067 #define kLineNumberUnknown 0                        /**<        */
00068 /*@}*/
00069
00070 /**
00071  *
00072  **/
00073 typedef struct  {
00074     UInt16  firstEntry;     /**<        */
00075     UInt16  lastEntry;      /**<        */
00076     UInt16  maxNameLength;      /**<        */
00077     UInt16  maxNumberLength;    /**<        */
00078 } PhnPhoneBookInfoType, *PhnPhoneBookInfoPtr;
00079
00080
00081
00082 /**
00083  *  SIM Application Toolkit's data types
00084  *  type of request/respond we are sending
00085  **/
00086 typedef enum {
00087     kSATSelectMainMenuItem,     /**<        */
00088     kSATClearText,          /**<        */
00089     kSATSetInkey,           /**<        */
00090     kSATSetInput,           /**<        */
00091     kSATMakeCall,           /**<        */
00092     kSATSelectItem = 6,     /**<        */
00093     kSATReqLaunchBrowser,       /**<        */
00094     kSATReqIdleModeText,
00095     kSATReqDataSrv,
00096     kSATReqPlayTone,            /**<        */
00097     kSATReqRefresh,         /**<        */
00098     kSATCancel     = 95,    /**<        */
00099     kSATUnknownNotification,    /**<        */
00100     kSATApplicationBusy,        /**<        */
00101     kSATUserNotResponse,        /**<        */
00102     kSATEndSession,         /**<        */
00103     kSATReqSendDTMF         /**<        */
00104 } _SATRequestType;
00105
00106 typedef UInt8 SATRequestType;
00107
00108 /**
00109  *  decision we are sending to SIM
00110  **/
00111 typedef enum {
00112     kSATSessionAborted,     /**<        */
00113     kSATItemSelected,       /**<        */
00114     kSATHelpRequested,      /**<        */
00115     kSATNavigateBack        /**<        */
00116 } _SATDecisionType;
00117
00118 typedef UInt8 SATDecisionType;
00119
00120 /**
00121  *  type of notification sent by SAT
00122  **/
00123 typedef enum {
00124     kSATMainMenuAvailable,      /**<        */
00125     kSATDisplayText,        /**<        */
00126     kSATGetInkey,           /**<        */
00127     kSATGetInput,           /**<        */
00128     kSATSetupCall,          /**<        */
00129     kSATPlayTone,           /**<        */
00130     kSATDisplaySubmenus,        /**<        */
00131     kSATRefresh,            /**< application do not get this notification */
00132     kSATSendSS,         /**<        */
00133     kSATSendSMS,            /**<        */
00134     kSATSendUSSD,           /**<        */
00135     kSATLaunchBrowser,          /**<        */
00136     kSATIdleModeText,           /**<        */
00137     kSATRunAT,          /**<        */
00138     kSATDataSvc,            /**<        */
00139     kSATSendDTMF,           /**<        */
00140     kSATTimeout     = 98,   /**<        */
00141     kSATSessionEnd  = 99        /**<        */
00142 } _SATNotificationType;
00143
00144 typedef UInt8 SATNotificationType;
00145
00146 /*Used for Call setup STK command, MTCALL, to specify the mode the call should
00147  * be setup in
00148  */
00149
00150 typedef enum
00151 {
00152   kSATSetupCallModeNotBusy,
00153   kSATSetupCallWithRedialModeNotBusy,
00154   kSATSetupCallHoldOtherCalls,
00155   kSATSetupCallWithRedialHoldOtherCalls,
00156   kSATSetupCallDisconnectOtherCalls,
00157   kSATSetupCallWithRedialDisconnectOtherCalls,
00158
00159   kSATSetupCallMax// do not use
00160 }_SATSetupCallType;
00161
00162 typedef UInt16 SATSetupCallType;
00163
00164 #define isValidSATNotificationType(s) (((s >= kSATMainMenuAvailable) && (s <= kSATSendUSSD)) \
00165               || (s == kSATTimeout) || (s == kSATSessionEnd))   /**<        */
00166
00167 typedef enum
00168 {
00169   kSATEFSimPhoneBook = 0x00000001
00170
00171 }_SATRefreshFile;
00172
00173 typedef UInt32 SATRefreshFile;
00174
00175 typedef enum
00176 {
00177   kSATInitWithFullFileChange,
00178   kSATFileChange,
00179   kSATInitWithFileChange,
00180   kSATInit,
00181   kSATSIMReset,
00182   kSATMax
00183 }_SATRefreshType;
00184
00185 typedef UInt16 SATRefreshType;
00186
00187 /**
00188  *
00189  **/
00190 typedef enum
00191 {
00192   phnGPRSPDPTypeIP = 1,         /**<        */
00193   phnGPRSPDPTypePPP = 2         /**<        */
00194 } _PhnGPRSPDPType;
00195
00196 typedef UInt8 PhnGPRSPDPType;
00197
00198 #define isValidPhnGPRSPDPType(t) ((t >= phnGPRSPDPTypeIP) && (t <= phnGPRSPDPTypePPP))  /**<        */
00199
00200 /**
00201  *
00202  **/
00203 typedef enum
00204 {
00205   kGPRSQOSTypeRequired = 1,     /**<        */
00206   kGPRSQOSTypeMinimum = 2       /**<        */
00207 } _PhnGPRSQOSType;
00208
00209 typedef UInt8 PhnGPRSQOSType;
00210
00211 #define isValidPhnGPRSQOSType(t) ((t >= kGPRSQOSTypeRequired) && (t <= kGPRSQOSTypeMinimum))    /**<        */
00212
00213 /**
00214  *  Used when we get a list of context that are currently
00215  *  stored on the radio.
00216  **/
00217 typedef struct PhnGPRSPDPContextType
00218 {
00219   UInt16 contextId;         /**<        */
00220   PhnGPRSPDPType pdpType;       /**<        */
00221   char*  apn;               /**<        */
00222   char*  pdpAddr;           /**<        */
00223   UInt16 pdpDataCompression;        /**< 0 means OFF, 1 means ON  */
00224   UInt16 pdpHdrCompression;     /**<        */
00225 } PhnGPRSPDPContextType;
00226
00227 /**
00228  *  This is a list node that is returened when we
00229  *  retreive the current list of PDP contexts stored
00230  *  on the device
00231  **/
00232 typedef struct PhnGPRSPDPContextListNodeType
00233 {
00234   struct PhnGPRSPDPContextType type;        /**<        */
00235   struct PhnGPRSPDPContextListNodeType* nextP;  /**<        */
00236 } PhnGPRSPDPContextListNodeType;
00237
00238 /**
00239  *
00240  **/
00241 typedef enum  {
00242     gsmMessagesConfirmMove, gsmMessagesCantReceive  /**<        */
00243 } _GSMSIMMessagesDialogKind;
00244
00245 typedef UInt8 GSMSIMMessagesDialogKind;
00246
00247 #define isValidGSMSIMMessagesDialogKind(d) ((d >= gsmMessagesConfirmMove) && (d <= gsmMessagesCantReceive)) /**<        */
00248
00249 /**
00250  *
00251  **/
00252 enum _GSMSATEventMenuFlag {
00253     phnSATEventMenuFlagHelp     = 1,    /**< help is available */
00254     phnSATEventMenuFlagNextAct  = 2 /**< nextAction is valid  */
00255 };
00256
00257 typedef UInt8 GSMSATEventMenuFlag;
00258
00259
00260 /**
00261  *  Possible values of format for PhnSATEventGetInkey and PhnSATEventGetInput
00262  **/
00263 enum _GSMSATEventInputFormatEnum {
00264     phnSATEventInputFormatDigit     = 0,    /**< Get Inkey or Get Input */
00265                             /**< 0-9, #, *, or + */
00266     phnSATEventInputFormatSMSChar   = 1,        /**< Get Inkey or Get Input */
00267                             /**< SMS character set */
00268     phnSATEventInputFormatUCS2      = 2,    /**< Get Inkey or Get Input */
00269     phnSATEventInputFormatUnpacked  = 3,        /**< Get Input only */
00270     phnSATEventInputFormatPacked    = 4,        /**< Get Input only */
00271
00272     phnSATEventInputFormatYesNo     = 5,    /**< Get Inkey or Get Input */
00273
00274
00275
00276     phnSATEventInputFormatUnknown   = 255       /**< KEEP THIS ONE AT THE END */
00277 };
00278
00279 typedef UInt8 GSMSATEventInputFormatEnum;
00280
00281 /**
00282  *
00283  **/
00284 enum _GSMATEventInputEchoModeEnum {
00285     phnSATEventInputEchoModeShowInput = 0,      /**< Show input as entered */
00286     phnSATEventInputEchoModeHideInput = 1       /**< Display bullets or boxes instead of entered characters */
00287 };
00288 typedef UInt8 GSMATEventInputEchoModeEnum;
00289
00290 /**
00291  *  @name Special response values for PhnSATEventGetInkey (besides a single character)
00292  *
00293  */
00294 /*@{*/
00295 #define phnSATInkeyResponseValueYes     ((UInt32)'YES_')    /**<        */
00296 #define phnSATInkeyResponseValueNo      ((UInt32)'NO__')    /**<        */
00297 /*@}*/
00298
00299
00300 /**
00301  *  Possible values of timeUnit for PhnSATEventPlayTone
00302  **/
00303 enum _GSMSATEventToneTimeUnitEnum {
00304     phnSATEventToneTimeUnitMinutes      = 0,    /**< Duration specified in minutes */
00305     phnSATEventToneTimeUnitSeconds      = 1,    /**< Duration specified in seconds */
00306     phnSATEventToneTimeUnitDeciSeconds  = 2     /**< Duration specified in 1/10 seconds */
00307 };
00308
00309 typedef UInt8 GSMSATEventToneTimeUnitEnum;
00310
00311 /**
00312  *  Possible values of toneType for PhnSATEventPlayTone
00313  **/
00314 enum _GSMSATEventToneTypeEnum {
00315     phnSATEventToneTypeNoneSpecified = 0xFFFF,  /**< Means just do a normal beep... */
00316     phnSATEventToneTypeDial = 0,            /**<        */
00317     phnSATEventToneTypeBusy = 1,            /**<        */
00318     phnSATEventToneTypeCongestion = 2,      /**<        */
00319     phnSATEventToneTypeRadioAck = 3,        /**<        */
00320     phnSATEventToneTypeDropped = 4,         /**<        */
00321     phnSATEventToneTypeError = 5,           /**<        */
00322     phnSATEventToneTypeCallWaiting = 6,     /**<        */
00323     phnSATEventToneTypeRinging = 7,         /**<        */
00324     phnSATEventToneTypeGeneralBeep = 8,     /**<        */
00325     phnSATEventToneTypePositiveBeep = 9,        /**<        */
00326     phnSATEventToneTypeNegativeBeep = 10        /**<        */
00327 };
00328
00329 typedef UInt16 GSMSATEventToneTypeEnum;
00330
00331 #define isValidGSMSATEventToneTypeEnum(x) (((x >= phnSATEventToneTypeDial) && (x <= phnSATEventToneTypeNegativeBeep)) || (x == phnSATEventToneTypeNoneSpecified))   /**<        */
00332
00333
00334 /**
00335  * Possible values of callType for PhnSATEventSetupCall
00336  **/
00337 enum _GSMSATEventSetupCallCallTypeEnum {
00338     phnSATEventSetupCallCallTypeVoice = 0,  /**<  SIM wants to set up a voice call  */
00339     phnSATEventSetupCallCallTypeData  = 1,  /**<  SIM wants to set up a data call */
00340     phnSATEventSetupCallCallTypeFax   = 2   /**<  SIM wants to set up a fax  */
00341 };
00342
00343 typedef UInt8 GSMSATEventSetupCallCallTypeEnum;
00344
00345 /**
00346  * Possible values of serviceType for PhnSATEventDataSvc
00347  **/
00348 enum _GSMSATDataSvcTypeEnum {
00349   phnSATEventDataSvcTypeOpenChannel=1,
00350   phnSATEventDataSvcTypeSendData=2,
00351   phnSATEventDataSvcTypeRcvData=3,
00352   phnSATEventDataSvcTypeCloseChannel=4
00353 };
00354 typedef UInt8 GSMSATDataSvcType;
00355
00356 #define isValidGSMSATEventSetupCallCallTypeEnum(x) ((x >= phnSATEventSetupCallCallTypeVoice) && (x <= phnSATEventSetupCallCallTypeFax)) /**<        */
00357
00358
00359 #endif // _HS_PHONE_GSM_TYPES_H__
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:53 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » telephony

HsPhoneIOTA.h

Go to the documentation of this file.
00001 /******************************************************************************
00002  * Copyright (c) 2004 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  *****************************************************************************/
00005 /** @ingroup Telephony
00006  *
00007  */
00008
00009
00010 /**
00011  * @file    HsPhoneIOTA.h
00012  *
00013  * @brief  Header File for Phone Library API ---- IOTA CATEGORY
00014  *
00015  * Notes:
00016  *  All implementations of the Handspring Phone Library support a common API.
00017  *  This API is broken up into various categories for easier management.  This file
00018  *  defines the IOTA category.  These API calls are used for features specific to
00019  *  IOTA operation on CDMA networks.
00020  */
00021
00022
00023 #ifndef HS_PHONEIOTA_H
00024 #define HS_PHONEIOTA_H
00025 #include <PalmOS.h>
00026 #include <PalmTypes.h>
00027 #ifndef __CORE_COMPATIBILITY_H__
00028 #include <PalmCompatibility.h>
00029     /** workaround for differing header files in sdk-3.5 and sdk-internal */
00030     #ifndef __CORE_COMPATIBILITY_H__
00031     #define __CORE_COMPATIBILITY_H__
00032     #endif
00033 #endif
00034 #include <HsPhoneTraps.h>     /** trap table definition for phone library calls */
00035 #include <HsPhoneErrors.h>    /** error codes returned by phone library functions */
00036 #include <HsPhoneTypes.h>
00037
00038 #define isValidPhnIOTAStatus(i) ((i >= phnIOTAUnknown) && (i <= phnIOTANAMSelect))  /**< No definition. */
00039
00040 #endif
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:53 2008 for Palm API Guide


Header Files » Incs » common » libraries » telephony

HsPhoneIOTATypes.h

Go to the documentation of this file.
00001 /******************************************************************************
00002  * Copyright (c) 2004 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  *****************************************************************************/
00005 /** @ingroup Telephony
00006  *
00007  */
00008
00009
00010 /**
00011  *
00012  * @file    HsPhoneIOTATypes.h
00013  *
00014  * @brief  Header File for Phone Library API ---- IOTA CATEGORY
00015  *
00016  * NOTES:
00017  *  All implementations of the Handspring Phone Library support a common API.
00018  *  This API is broken up into various categories for easier management.  This file
00019  *  defines the IOTA category.  These API calls are used for features specific to
00020  *  IOTA operation on CDMA networks.
00021  */
00022
00023
00024 #ifndef HS_PHONEIOTA_H
00025 #define HS_PHONEIOTA_H
00026 #include <PalmOS.h>
00027 #include <PalmTypes.h>
00028 #ifndef __CORE_COMPATIBILITY_H__
00029 #include <PalmCompatibility.h>
00030     /** workaround for differing header files in sdk-3.5 and sdk-internal */
00031     #ifndef __CORE_COMPATIBILITY_H__
00032     #define __CORE_COMPATIBILITY_H__
00033     #endif
00034 #endif
00035
00036 // Located in Common/Libraries/Telephony
00037 #include <HsPhoneTraps.h>     /** trap table definition for phone library calls */
00038 #include <HsPhoneErrors.h>    /** error codes returned by phone library functions */
00039 #include <HsPhoneTypes.h>
00040
00041
00042 /**
00043  *
00044  **/
00045 typedef enum
00046 {
00047   phnIOTAUnknown = 0,       /**<        */
00048     phnIOTAStart,       /**<        */
00049     phnIOTAEnd,     /**<        */
00050     phnIOTACommit,      /**<        */
00051     phnIOTANAMSelect    /**<        */
00052 }
00053 PhnIOTAStatus;
00054
00055 /**
00056  * @brief
00057  *
00058  **/
00059 typedef struct
00060 {
00061   PhnIOTAStatus     status;         /**< the status that the modem changes into */
00062   UInt8         namInUse;       /**< namInUse4IOTA currently */
00063   PHNErrorCode      error;          /**< == 0 normally, only != 0 for phnIOTAEnd and phnIOTACommit if Commit failed. */
00064 }
00065 PhnIOTAReportType;
00066
00067
00068
00069
00070 // IOTA defines
00071 /**
00072  * @name Text Header elements
00073  *
00074  **/
00075 /*@{*/
00076 #define IOTAHeaderEscapeSeq     "X-Wap-Application-Id: "                            /**< start sequence of the header */
00077 #define IOTATextHeader          "X-Wap-Application-Id: x-wap-application:iota.ua"   /**< beginning of an IOTA header */
00078 #define IOTATextHeaderLength    47                                                  /**< length of the header */
00079
00080 #define IOTATextHeaderTerminator   '\n'         /**< IOTA headers terminate at the line feed */
00081 /*@}*/
00082
00083 #define phnIOTAEvent         'Hita'     /**<        */
00084
00085
00086 typedef UInt8 PhnIOTAItemType;  /**< let's hope it never gets beyond 256 items */
00087 /**
00088  * Items stored in the radio NV (mostly for Sprint support).
00089  * Some of these items may be used for other carriers in the future.
00090  * Most of these items will be match the initial TIL implementation
00091  * since we are focusing on Sprint support.
00092  * We may be able to leverage the NVFlash support in the future and
00093  * get away from the radio NV for most of these (unless we need UPST support).
00094  **/
00095 typedef enum
00096 {
00097   phnIOTAItemBootURL                    = 0x00, /**< provisioning URL */
00098   phnIOTAItemBootNAIURL                 = 0x01, /**< provisioning URL */
00099   phnIOTAItemTrustedDomain              = 0x02, /**< trusted domain for provisioning.  All URLs must come from this */
00100   phnIOTAItemHomepageURL                = 0x03, /**< default browser homepage */
00101   phnIOTAItemVendingURL                 = 0x04, /**< vending URL */
00102   phnIOTAItemDownloadServerURL          = 0x05, /**< download server URL */
00103   phnIOTAItemDownloadServerLock         = 0x06, /**< state of items downloaded from the download server (locked or not) */
00104   phnIOTAItemConnectionTimeout          = 0x07, /**< timeout for IOTA connections */
00105   phnIOTAItemPriWAPPushProxyGatewayURL  = 0x08, /**< Primary WAP push gateway */
00106   phnIOTAItemSecWAPPushProxyGatewayURL  = 0x09, /**< Secondary WAP push gateway */
00107
00108   // The following items are indexed for each PDP profile
00109   // Sprint has 2 profiles, so these are indexed 0..1
00110   phnIOTAItemPriProxyWDPAddress         = 0x0A, /**< WDP address. Translate to the NGG for profile 1 */
00111   phnIOTAItemSecProxyWDPAddress         = 0x0B, /**< WDP address. Translate to the NGG for profile 1 */
00112   phnIOTAItemPriSIPConfigServer         = 0x0C, /**< Primary Config server */
00113   phnIOTAItemSecSIPConfigServer         = 0x0D, /**< Secondary Config server */
00114   phnIOTAItemPriSIPEdgeProxyGateway     = 0x0E, /**< Primary SIP Proxy Edge gateway */
00115   phnIOTAItemSecSIPEdgeProxyGateway     = 0x0F, /**< Secondary SIP Proxy Edge gateway */
00116   phnIOTAItemPriDataExchangeURL         = 0x10, /**< Primary Data Exchange URL */
00117   phnIOTAItemSecDataExchangeURL         = 0x11, /**< Secondary Data Exchange URL */
00118   phnIOTAItemPriDataGatewayURL          = 0x12, /**< Primary Data Gateway URL */
00119   phnIOTAItemSecDataGatewayURL          = 0x13, /**< Secondary Data Gateway URL */
00120   phnIOTAItemPriSIPRetryTimer           = 0x14, /**< Primary SIP Retry timer */
00121   phnIOTAItemSecSIPRetryTimer           = 0x15, /**< Secondary SIP Retry timer */
00122   phnIOTAItemPriSIPRetryCount           = 0x16, /**< Primary SIP Retry count */
00123   phnIOTAItemSecSIPRetryCount           = 0x17, /**< Secondary SIP Retry count */
00124   phnIOTAItemPriIMMessageStore          = 0x18, /**< Primary IM Message store */
00125   phnIOTAItemSecIMMessageStore          = 0x19, /**< Secondary IM Message store */
00126
00127
00128   phnIOTAItemRootCertificate1           = 0x40, /**< Root certificate #1 */
00129   phnIOTAItemRootCertificate2           = 0x41, /**< Root certificate #2 */
00130   phnIOTAItemRootCertificate3           = 0x42, /**< Root certificate #3 */
00131   phnIOTAItemRootCertificate4           = 0x43, /**< Root certificate #4 */
00132
00133   // Sprint items that used to be hard-coded in the IOTA app but now
00134   // moved here, since different radios may possibly support different values.
00135   phnIOTAItemPRLStorageSize             = 0x50, /**< max PRL size radio supports */
00136
00137   // items that are listed as Verizon requirements
00138   phnIOTAItemSIPUsername                = 0x51, /**< Username for SIP accounts */
00139   phnIOTAItemSIPPassword                = 0x52, /**< password for SIP accounts */
00140
00141   // last item
00142   phnIOTAItemLastNVItem                 = 0x60, /**< last IOTA NV Item */
00143
00144   phnIOTAItemUnknown                    = 0xFF  /**< unknown item */
00145 }
00146 PhnIOTAItemEnum;
00147
00148 #define isValidPhnIOTAItemType(i) ((i >= phnIOTAPhnBootNAIUrl) && (i <phnLibIOTAItemLast))  /**<        */
00149
00150
00151 // ========================= Begining of IOTA type section =======================
00152
00153 #define kIOTACertMaxBlocks              132     /**< Index should be < 12, starting from 0 */
00154 #define kIOTACertMaxBlockLen            127 /**<        */
00155 /**
00156  * @brief
00157  *
00158  **/
00159 typedef struct
00160   {
00161   UInt8  index;                 /**<        */
00162   UInt8  cert [kIOTACertMaxBlockLen];       /**<        */
00163   }
00164 PhnIOTAPhnTlsRcUrlType;
00165
00166 #define kIOTAProxyADDRMaxLen           20   /**<        */
00167 #define kIOTANaiSipEdgePxyMaxBlocks    4    /**<        */
00168 /**
00169  * @brief
00170  *
00171  **/
00172 typedef struct
00173   {
00174   UInt8  index;                 /**<        */
00175   UInt8  addr [kIOTAProxyADDRMaxLen];       /**<        */
00176   }
00177 PhnIOTAPhnNAISIPEdgeProxyType;          /**<        */
00178
00179 #define kIOTAPxyAddrWdpMaxBlocks 4      /**<        */
00180 /**
00181  * @brief
00182  *
00183  **/
00184 typedef struct
00185   {
00186   UInt8  index;                 /**<        */
00187   UInt8  addr [kIOTAProxyADDRMaxLen];       /**<        */
00188   }
00189 PhnIOTAPhnProxyAddrWdpType;
00190
00191 #define kIOTAUrlMaxLen                128   /**<        */
00192 #define kIOTAUrlArrayMaxLen     65  /**<        */
00193
00194 #define kIOTASipCfgBlocks 4         /**<        */
00195 /**
00196  * @brief
00197  *
00198  **/
00199 typedef struct
00200 {
00201   UInt8  index;                 /**<        */
00202   UInt8  url [kIOTAUrlArrayMaxLen];     /**<        */
00203 }
00204 PhnIOTAPhnNAISIPCfgSvr;
00205
00206 #define kIOTANaiPpgMaxBlocks 4          /**<        */
00207 /**
00208  * @brief
00209  *
00210  **/
00211 typedef struct
00212 {
00213   UInt8  index;                 /**<        */
00214   UInt8  url [kIOTAUrlArrayMaxLen];     /**<        */
00215 }
00216 PhnIOTAPhnNAIPPGType;
00217
00218 #define kIOTANaiIMStoreMaxBlocks 8      /**<        */
00219 /**
00220  * @brief
00221  *
00222  **/
00223 typedef struct
00224 {
00225   UInt8  index;                 /**<        */
00226   UInt8  url [kIOTAUrlArrayMaxLen];     /**<        */
00227 }
00228 PhnIOTAPhnNAIIMStore;
00229
00230 #define kIOTANaiSipDataxchMaxBlocks 8       /**<        */
00231 /**
00232  * @brief
00233  *
00234  **/
00235 typedef struct
00236 {
00237   UInt8  index ;                /**<        */
00238   UInt8  url [kIOTAUrlArrayMaxLen] ;        /**<        */
00239 }
00240 PhnIOTAPhnNAISIPDataxchType;
00241
00242 #define kIOTANaiSipDdatgwyMaxBlocks 8       /**<        */
00243 /**
00244  * @brief
00245  *
00246  **/
00247 typedef struct
00248 {
00249   UInt8  index ;                /**<        */
00250   UInt8  url [kIOTAUrlArrayMaxLen]  ;       /**<        */
00251 }
00252 PhnIOTAPhnNAISIPDatagwyType;
00253
00254 // Type to hold the SIP re-transmission timers - specified in seconds
00255 #define kIOTAPhnSipRetryTimerMaxLen 9       /**<        */
00256 #define kIOTAPhnSipRetryTimerMaxBloacks 4   /**<        */
00257 /**
00258  * @brief
00259  *
00260  **/
00261 typedef struct
00262 {
00263   UInt8  index;                 /**<        */
00264   UInt8  timer [kIOTAPhnSipRetryTimerMaxLen];   /**<        */
00265 }
00266 PhnIOTAPhnSIPRetryTimerType;
00267
00268 // Type to hold the IP re-transmission counters
00269 #define kIOTAPhnSipRetryCntMaxLen 9     /**<        */
00270 #define kIOTAPhnSipRetryCntMaxBlocks 4      /**<        */
00271 /**
00272  * @brief
00273  *
00274  **/
00275 typedef struct
00276 {
00277   UInt8  index;                 /**<        */
00278   UInt8  cnt [kIOTAPhnSipRetryCntMaxLen];   /**<        */
00279 }
00280 PhnIOTAPhnSIPRetryCntType;
00281
00282 /**
00283  * @brief Holds lock state of user's ability to change the download server URL address.
00284  *
00285  **/
00286 typedef struct
00287 {
00288   Boolean iota_ph_dls_lock  ;           /**<        */
00289 }
00290 PhnIOTAPhnDlsLockType;
00291 /**
00292  * @brief
00293  *
00294  **/
00295 typedef struct
00296 {
00297   UInt8  url [kIOTAUrlMaxLen] ;         /**<        */
00298 }
00299 PhnIOTAPhnHomepagetype;
00300
00301
00302 #define kIOTATrustedDomainMaxLen 64     /**<        */
00303 /**
00304  * @brief
00305  *
00306  **/
00307 typedef struct
00308 {
00309   UInt8  url[kIOTATrustedDomainMaxLen];     /**<        */
00310 }
00311 PhnIOTAPhnTrustedDomainType;
00312
00313
00314 // ========================= End of IOTA type section =======================
00315 /**
00316  * Structure passed to the callbacks registered for incoming IOTA notifications
00317  **/
00318 typedef struct tagIOTANotificationEventType
00319 {
00320     UInt16 version;         /**< version number to provide future backwards compatibility */
00321
00322     void *headerP;          /**< pointer to raw header */
00323     UInt8 headerLen;        /**< length of headerP */
00324     void *dataP;            /**< pointer to data body */
00325     UInt8 dataLen;          /**< length of dataP */
00326
00327     /** SMS related fields */
00328     UInt32 msgID;           /**< ID into the SMS database to reference this
00329                              * message this ID is not gauranteed to be
00330                              * valid once the notification callback
00331                              * returns.  Users should make a copy of the
00332                              * msg if they want to work on it after the
00333                              * callback returns.
00334                              */
00335     UInt32 datetime;        /**< date/time stamp */
00336     Int32  reserved2;       /**< reserved*/
00337     Int32  reserved3;       /**< reserved*/
00338 }
00339 IOTANotificationEventType;
00340
00341
00342 #endif  // HS_PHONEIOTA_H
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:53 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » telephony

HsPhoneLibrary.h

Go to the documentation of this file.
00001 /******************************************************************************
00002  * Copyright (c) 2004 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  *****************************************************************************/
00005 /** @ingroup Telephony
00006  *
00007  */
00008
00009
00010 /**
00011  * @file    HsPhoneLibrary.h
00012  *
00013  * @brief  Header File for Phone Library API ---- LIBRARY CATEGORY
00014  *
00015  * Notes:
00016  *  All implementations of the Handspring Phone Library support a common API.
00017  *  This API is broken up into various categories for easier management.  This file
00018  *  defines the LIBRARY category.  These API calls are used for basic Palm Library
00019  *  operation.
00020  */
00021
00022
00023 #ifndef HS_PHONELIBRARY_H
00024 #define HS_PHONELIBRARY_H
00025 #include <PalmOS.h>
00026 #include <PalmTypes.h>
00027 #ifndef __CORE_COMPATIBILITY_H__
00028 #include <PalmCompatibility.h>
00029     /** workaround for differing header files in sdk-3.5 and sdk-internal */
00030     #ifndef __CORE_COMPATIBILITY_H__
00031     #define __CORE_COMPATIBILITY_H__
00032     #endif
00033 #endif
00034 #include <HsPhoneTraps.h>     /** trap table definition for phone library calls */
00035 #include <HsPhoneErrors.h>    /** error codes returned by phone library functions */
00036 #include <HsPhoneTypes.h>
00037
00038
00039 /**
00040  *  @brief Open the phone library. Global space has been created on SysLibLoad already.
00041  *        This function just manages the openCount.
00042  *
00043  *  @param refNum:  IN:  Library reference number returned by HsGetPhoneLibrary().
00044  *  @retval Err Error code.
00045  **/
00046   extern Err      PhnLibOpen (UInt16 refNum)
00047                   SYS_TRAP (sysLibTrapOpen);
00048
00049 /**
00050  *  @brief Closes up a phone library. This function does not free global space.
00051  *        It just manages the openCount.
00052  *
00053  *  @param refNum:  IN:  Library reference number returned by HsGetPhoneLibrary().
00054  *  @retval Err Error code.
00055  **/
00056   extern Err      PhnLibClose (UInt16 refNum)
00057                   SYS_TRAP (sysLibTrapClose);
00058
00059 /**
00060  *  @brief (For System Use Only)
00061  *
00062  *  @param refNum:  IN:
00063  *  @retval Err Error code.
00064  **/
00065   extern Err      PhnLibSleep (UInt16 refNum)
00066                   SYS_TRAP (sysLibTrapSleep);
00067
00068 /**
00069  *  @brief (For System Use Only)
00070  *
00071  *  @param refNum:  IN:
00072  *  @retval Err Error code.
00073  **/
00074   extern Err      PhnLibWake (UInt16 refNum)
00075                   SYS_TRAP (sysLibTrapWake);
00076
00077 /**
00078  *  @brief This function is used to indicate the version number of the current Phone Library.
00079  *
00080  *  @param refNum:  IN:  Library reference number returned by HsGetPhoneLibrary().
00081  *  @param dwVerP:  IN:  Version number
00082  *  @retval Err Error code.
00083  **/
00084   extern Err      PhnLibGetLibAPIVersion (UInt16 refNum, UInt32* dwVerP)
00085                   PHN_LIB_TRAP (PhnLibTrapGetLibAPIVersion);
00086
00087 /**
00088  *  @brief This is an unsupported function starting with Treo 600.
00089  *
00090  *  @param refNum:  IN:  Library reference number returned by HsGetPhoneLibrary().
00091  *  @retval Nothing
00092  **/
00093   extern void     PhnLibUninstall (UInt16 refNum)
00094                   PHN_LIB_TRAP (PhnLibTrapUninstall);
00095
00096 /**
00097  *  @brief Register or unregister (when services == 0) an application so that notifications
00098  *        from the Phone Library (Chapter 13) can be broadcasted to registered applications.
00099  *
00100  *  @param refNum:  IN:  Library reference number obtained from SysLibLoad.
00101  *  @param creator: IN:  Creator ID of application registering for notifications
00102  *  @param services:    IN:  Bitfield of services for which notifications are desired. See PhnServiceClassType
00103  *                           for bit definitions.
00104  *                           Register with a value of 0 to unregister for notifications.
00105  *  @retval 0 for success; otherwise failed
00106  **/
00107   extern Err      PhnLibRegister (UInt16 refNum, DWord creator, UInt16 services)
00108                   PHN_LIB_TRAP (PhnLibTrapRegister);
00109
00110 #endif
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:53 2008 for Palm API Guide


Header Files » Incs » common » libraries » telephony

hsPhoneLocationTypes.h

Go to the documentation of this file.
00001 /******************************************************************************
00002  * Copyright (c) 2004 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  *****************************************************************************/
00005 /** @ingroup Telephony
00006  *
00007  */
00008
00009
00010 /**
00011  *
00012  * @file hsPhoneLocationTypes.h
00013  *
00014  * @brief  File contains Phone Location data types.
00015  *
00016  */
00017
00018
00019 #ifndef __HS_PHONE_LOCATION_TYPES_H__
00020
00021 #define __HS_PHONE_LOCATION_TYPES_H__
00022
00023 #include <PalmTypes.h>
00024
00025 #include <PalmOS.h>
00026 #include <PalmTypes.h>
00027 #ifndef __CORE_COMPATIBILITY_H__
00028 #include <PalmCompatibility.h>
00029     /** workaround for differing header files in sdk-3.5 and sdk-internal */
00030     #ifndef __CORE_COMPATIBILITY_H__
00031     #define __CORE_COMPATIBILITY_H__
00032     #endif
00033 #endif
00034 #include <HsPhoneTraps.h>     /** trap table definition for phone library calls */
00035 #include <HsPhoneErrors.h>    /** error codes returned by phone library functions */
00036 #include <HsPhoneTypes.h>
00037
00038 typedef UInt8 PhnPDSessionConfigParamType;
00039
00040
00041 /**
00042  *
00043  **/
00044 typedef enum
00045   {
00046     PhnPDConfigIPAddr = 1,  /**< Binary value of the Position Determination Entity (PDE) IP Address */
00047     PhnPDConfigPortID,      /**< Binary value of the PDE Port ID. */
00048     PhnPDConfigGPSLock,     /**< Level of GPS lock set in the modem. */
00049     PhnPDConfigPTLMMode     /**< The protocol transport layer mechanism to be used to talk to the PDE. */
00050   }_PhnPDSessionConfigParamType;
00051
00052
00053
00054 #endif // __HS_PHONE_LOCATION_TYPES_H__
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:53 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » telephony

HsPhoneMisc.h

Go to the documentation of this file.
00001 /******************************************************************************
00002  * Copyright (c) 2004 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  *****************************************************************************/
00005 /** @ingroup Telephony
00006  *
00007  */
00008
00009
00010 /**
00011  * @file    HsPhoneMisc.h
00012  *
00013  * @brief  Header File for Phone Library API ---- MISC CATEGORY
00014  *
00015  * Notes:
00016  *  All implementations of the Handspring Phone Library support a common API.
00017  *  This API is broken up into various categories for easier management.  This file
00018  *  defines the Miscellaneous category.  These API calls are Miscellaneous calls that don't
00019  *  fit into any other category.  Many of them are device control.
00020  */
00021
00022
00023 #ifndef HS_PHONEMISC_H
00024 #define HS_PHONEMISC_H
00025 #include <PalmOS.h>
00026 #include <PalmTypes.h>
00027 #ifndef __CORE_COMPATIBILITY_H__
00028 #include <PalmCompatibility.h>
00029     /** workaround for differing header files in sdk-3.5 and sdk-internal */
00030     #ifndef __CORE_COMPATIBILITY_H__
00031     #define __CORE_COMPATIBILITY_H__
00032     #endif
00033 #endif
00034 #include <HsPhoneTraps.h>     /** trap table definition for phone library calls */
00035 #include <HsPhoneErrors.h>    /** error codes returned by phone library functions */
00036 #include <HsPhoneTypes.h>
00037
00038
00039 /**
00040  *  @brief Retrieve the Line state.
00041  *
00042  *  @param refNum:  IN:  Library reference number obtained from SysLibLoad.
00043  *  @param line:    IN:  Line to query for
00044  *  @param lineState:   IN:  State of the Line
00045  *  @retval 0 for success; otherwise failed and returned an error code as defined in “Phone
00046  *          Library Error Codes.”
00047  **/
00048 extern Err PhnLibGetLineState(UInt16 refNum, UInt16 line, PhnLineStatePtr lineState)
00049       PHN_LIB_TRAP(PhnLibTrapGetLineState);
00050
00051 /**
00052  *  @brief Retrieve state information about the radio.
00053  *
00054  *  @param refNum:  IN:  Library reference number obtained from SysLibLoad.
00055  *  @param radioState:  IN:  State of the Radio
00056  *  @retval 0 for success; otherwise failed and returned an error code as defined in “Phone
00057  *          Library Error Codes.”
00058  **/
00059 extern Err PhnLibGetRadioState(UInt16 refNum, PhnRadioStatePtr radioState)
00060           PHN_LIB_TRAP(PhnLibTrapGetRadioState);
00061
00062 /**
00063  *  @brief
00064  *
00065  *  @param refNum:  IN:
00066  *  @param manufacturer:    IN:
00067  *  @param model:   IN:
00068  *  @param version: IN:
00069  *  @param serial   IN:
00070  *  @retval Err Error code.
00071  **/
00072 extern Boolean PhnLibCardInfo (UInt16 refNum, CharPtr* manufacturer, CharPtr* model, CharPtr* version, CharPtr* serial)
00073                   PHN_LIB_TRAP(PhnLibTrapCardInfo);
00074
00075 /**
00076  *<chg 09-10-2002 TRS> prototype changed.  NOTE that previously was declared to
00077  *return Err, but code returned Boolean, so didn't work anyway.
00078  **/
00079 /**
00080  *  @brief Checks to see if a connection can be made
00081  *
00082  *  @param refNum:  IN:  Library reference number obtained from SysLibLoad.
00083  *  @param connection:  IN:  Type of connection to be made.
00084  *  @param pAvailable:  IN: Result indicating if a connection is available.
00085  *  @retval 0 for success; otherwise failed and returned an error code as defined in “Phone
00086  *          Library Error Codes.”
00087  **/
00088 extern Err PhnLibConnectionAvailable(UInt16 refNum, PhnConnectionEnum connection, Boolean * pAvailable)
00089                   PHN_LIB_TRAP(PhnLibTrapConnectionAvailable);
00090
00091 /**
00092  *  @brief This API have been deprecated. Please use “HsIndicatorState.”
00093  *
00094  *  @param refNum:  IN:
00095  *  @param pulse:   IN:
00096  *  @param repeat:  IN:
00097  *  @retval Err Error code.
00098  **/
00099 extern Err  PhnLibStartVibrate (UInt16 refNum, Boolean pulse, Boolean repeat)
00100                   PHN_LIB_TRAP(PhnLibTrapStartVibrate);
00101
00102 /**
00103  *  @brief This API have been deprecated. Please use “HsIndicatorState.”
00104  *
00105  *  @param refNum:  IN:
00106  *  @retval Err Error code.
00107  **/
00108 extern Err  PhnLibStopVibrate (UInt16 refNum)
00109                   PHN_LIB_TRAP(PhnLibTrapStopVibrate);
00110
00111 /**
00112  *  @brief
00113  *
00114  *  @param refNum:  IN:
00115  *  @param errorRate:   IN:
00116  *  @retval Err Error code.
00117  **/
00118 extern Err  PhnLibErrorRate (UInt16 refNum, WordPtr errorRate)
00119                   PHN_LIB_TRAP(PhnLibTrapErrorRate);
00120
00121 /**
00122  *  @brief
00123  *
00124  *  @param refNum:  IN:
00125  *  @param error:   IN:
00126  *  @param buffer:  IN:
00127  *  @param bufferLen:   IN:
00128  *  @retval Err Error code.
00129  **/
00130 extern void PhnLibGetErrorText (UInt16 refNum, Err error, CharPtr buffer, UInt16 bufferLen)
00131                   PHN_LIB_TRAP(PhnLibTrapGetErrorText);
00132
00133 /**
00134  *  @brief Locate the call item that has the specified service if such item exists return
00135  *         the total number of call items that has the same service.
00136  *
00137  *  @param refNum:  IN:  Library reference number obtained from SysLibLoad.
00138  *  @param service: IN:  The specified connection service (can OR bit combination)
00139  *  @retval Number of call items that has the same status.
00140  **/
00141 extern UInt16     PhnLibGetCallCountByService (UInt16 refNum,
00142                                              PhoneServiceClassType service)
00143                 PHN_LIB_TRAP (PhnLibTrapGetCallCountByService);
00144
00145 /**
00146  *  @brief
00147  *
00148  *  @param refNum:  IN:
00149  *  @param echoCancellationOn:  IN:
00150  *  @retval Err Error code.
00151  **/
00152 extern Err PhnLibGetEchoCancellation(UInt16 refNum, Boolean* echoCancellationOn)
00153               PHN_LIB_TRAP(PhnLibTrapGetEchoCancellation);
00154
00155 /**
00156  *  @brief
00157  *
00158  *  @param refNum:  IN:
00159  *  @param echoCancellationOn:  IN:
00160  *  @retval Err Error code.
00161  **/
00162 extern Err PhnLibSetEchoCancellation(UInt16 refNum, Boolean echoCancellationOn)
00163               PHN_LIB_TRAP(PhnLibTrapSetEchoCancellation);
00164
00165 /**
00166  *  @brief
00167  *
00168  *  @param refNum:  IN:
00169  *  @param equipmentMode:   IN:
00170  *  @retval Err Error code.
00171  **/
00172 extern Err PhnLibGetEquipmentMode(UInt16 refNum, PhnEquipmentMode* equipmentMode)
00173               PHN_LIB_TRAP(PhnLibTrapGetEquipmentMode);
00174
00175 /**
00176  *  @brief
00177  *
00178  *  @param refNum:  IN:
00179  *  @param equipmentMode:   IN:
00180  *  @retval Err Error code.
00181  **/
00182 extern Err PhnLibSetEquipmentMode(UInt16 refNum, PhnEquipmentMode equipmentMode)
00183               PHN_LIB_TRAP(PhnLibTrapSetEquipmentMode);
00184
00185 /**
00186  *  @brief
00187  *
00188  *  @param refNum:  IN:
00189  *  @param headsetConnected:    IN:
00190  *  @retval 0 for success; otherwise failed and returned an error code as defined in “Phone
00191  *          Library Error Codes.”
00192  **/
00193 extern Err      PhnLibGetHeadsetConnectedInfo (UInt16 refNum, Boolean * headsetConnected)
00194     PHN_LIB_TRAP (PhnLibTrapGetHeadsetConnectedInfo);
00195
00196 /**
00197  *  @brief
00198  *
00199  *  @param refNum:  IN:
00200  *  @param gain:    IN:
00201  *  @retval Err Error code.
00202  **/
00203 extern Err  PhnLibGetMicrophone (UInt16 refNum, Int16* gain)
00204                   PHN_LIB_TRAP(PhnLibTrapGetMicrophone);
00205
00206 /**
00207  *  @brief
00208  *
00209  *  @param refNum:  IN:
00210  *  @param gain:    IN:
00211  *  @retval Err Error code.
00212  **/
00213 extern Err    PhnLibSetMicrophone (UInt16 refNum, Int16 gain)
00214               PHN_LIB_TRAP(PhnLibTrapSetMicrophone);
00215
00216 /**
00217  *  @brief
00218  *
00219  *  @param refNum:  IN:
00220  *  @param manufacturer:    IN:
00221  *  @param model:   IN:
00222  *  @param modemSWRev:  IN:
00223  *  @param esn:     IN:
00224  *  @param prlRev:  IN:
00225  *  @param hostSWRev:   IN:
00226  *  @param modemHWRev:  IN:
00227  *  @param priChecksum: IN:
00228  *  @param *eriver: IN:
00229  *  @param *isEriSet:   IN:
00230  *  @retval Err Error code.
00231  **/
00232  extern Boolean  PhnLibCardInfoEx (UInt16 refNum, CharPtr * manufacturer,
00233                                   CharPtr * model, CharPtr * modemSWRev,
00234                                   CharPtr * esn, CharPtr * prlRev, CharPtr * hostSWRev,
00235                                   CharPtr * modemHWRev, CharPtr *priChecksum, Word *eriVer,
00236                                   Boolean *isEriSet)
00237                   PHN_LIB_TRAP (PhnLibTrapCardInfoEx);
00238
00239 /**
00240  *  @brief
00241  *
00242  *  @param refNum:  IN:
00243  *  @param phnFlags:    IN:
00244  *  @retval Err Error code.
00245  **/
00246 extern Err PhnLibGetPhoneCallStatus(UInt16 refNum, UInt32* phnFlags)
00247                   PHN_LIB_TRAP(PhnLibTrapGetPhoneCallStatus);
00248
00249 /**
00250  *  @brief
00251  *
00252  *  @param refNum:  IN:
00253  *  @param toMute:  IN:
00254  *  @retval Err Error code.
00255  **/
00256 extern Err      PhnLibMute (UInt16 refNum, Boolean toMute)
00257                 PHN_LIB_TRAP (PhnLibTrapMute);
00258
00259 /**
00260  *  @brief
00261  *
00262  *  @param refNum:  IN:
00263  *  @param isMute:  IN:
00264  *  @retval Err Error code.
00265  **/
00266 extern Err      PhnLibIsCallMuted (UInt16 refNum, Boolean * isMute)
00267                 PHN_LIB_TRAP (PhnLibTrapIsCallMuted);
00268
00269 /**
00270  *  @brief
00271  *
00272  *  @param refNum:  IN:
00273  *  @retval Err Error code.
00274  **/
00275 extern Boolean  PhnLibIsPhoneActivated (UInt16 refNum)
00276                 PHN_LIB_TRAP (PhnLibTrapIsPhoneActivated);
00277
00278 /**
00279  *  @brief
00280  *
00281  *  @param refNum:  IN:
00282  *  @param bSet:    IN:
00283  *  @param debugInfoP   IN:
00284  *  @param infoLen: IN:
00285  *  @retval Err Error code.
00286  **/
00287 extern Err      PhnLibMiscDebugInfo (UInt16 refNum, Boolean bSet, VoidPtr
00288                                      debugInfoP, UInt16 infoLen)
00289                 PHN_LIB_TRAP (PhnLibTrapMiscDebugInfo);
00290
00291 /**
00292  *  @brief
00293  *
00294  *  @param refNum:  IN:
00295  *  @param attr:    IN:
00296  *  @param flags:   IN:
00297  *  @param dataP:   IN:
00298  *  @retval Err Error code.
00299  **/
00300 extern Err      PhnLibAttrGet (UInt16 refNum, UInt16 attr, UInt32 flags, void* dataP)
00301                 PHN_LIB_TRAP (PhnLibTrapAttrGet);
00302
00303 /**
00304  *  @brief
00305  *
00306  *  @param refNum:  IN:
00307  *  @param attr:    IN:
00308  *  @param flags:   IN:
00309  *  @param dataP:   IN:
00310  *  @retval Err Error code.
00311  **/
00312 extern Err      PhnLibAttrSet (UInt16 refNum, UInt16 attr, UInt32 flags, void* dataP)
00313                 PHN_LIB_TRAP (PhnLibTrapAttrSet);
00314
00315 /**
00316  *  @brief
00317  *
00318  *  @param refNum:  IN:
00319  *  @param deviceId:    IN:
00320  *  @retval Err Error code.
00321  **/
00322 extern Err      PhnLibGetDeviceID (UInt16 refNum, CharPtr * deviceId)
00323                 PHN_LIB_TRAP (PhnLibTrapGetDeviceId);
00324
00325
00326
00327 /**
00328  *  @brief
00329  *
00330  *  @param refNum:  IN:
00331  *  @param noiseCancellationP:  IN:
00332  *  @retval Err Error code.
00333  **/
00334 extern Err PhnLibGetNoiseCancellation(UInt16 refNum, Boolean* noiseCancellationP)
00335               PHN_LIB_TRAP(PhnLibTrapGetNoiseCancellation);
00336
00337 /**
00338  *  @brief
00339  *
00340  *  @param refNum:  IN:
00341  *  @param noiseCancellation:   IN:
00342  *  @retval Err Error code.
00343  **/
00344 extern Err PhnLibSetNoiseCancellation(UInt16 refNum, Boolean noiseCancellation)
00345               PHN_LIB_TRAP(PhnLibTrapSetNoiseCancellation);
00346
00347 /**
00348  *  @brief
00349  *
00350  *  @param refNum:  IN:
00351  *  @param bufferP: OUT: contains MEID or ESN (for non-MEID devices)
00352  *  @retval Err Error code.
00353  **/
00354 extern Err PhnLibGetMEID (UInt16 refNum, CharPtr *bufferP)
00355     PHN_LIB_TRAP (PhnLibTrapGetMEID);
00356
00357 /**
00358  * @brief
00359  *
00360  * @param pointer to base_id, sid, nid storage IN:
00361  * @param base_id, sid, nid                    OUT: contains the values
00362  * @retval Err Error code.
00363  **/
00364 extern Err PhnLibGetBaseStationIdInfo( UInt16 refNum, UInt16 *base_id, UInt16 *sid, UInt16 *nid )
00365      PHN_LIB_TRAP (PhnLibTrapGetBaseStationIdInfo);
00366
00367 /**
00368  * @brief
00369  *
00370  * @param pointer to buffer of char
00371  * IN: pUaStr and length of the buffer provided
00372  * OUT: pUaStr : param pointer to buffer containing values
00373  * @retval Err Error code.
00374  */
00375 extern Err PhnLibGetMMSUAString( UInt16 refNum, char *pUaStr, UInt32 buf_len )
00376      PHN_LIB_TRAP ( PhnLibTrapGetMMSUAString );
00377 #endif
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:53 2008 for Palm API Guide


Header Files » Incs » common » libraries » telephony

HsPhoneMiscTypes.h

Go to the documentation of this file.
00001 /******************************************************************************
00002  * Copyright (c) 2004 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  *****************************************************************************/
00005 /** @ingroup Telephony
00006  *
00007  */
00008
00009
00010 /**
00011  *
00012  * @file    HsPhoneMiscTypes.h
00013  *
00014  * @brief  Header File for Phone Library API ---- NETWORK CATEGORY
00015  *
00016  * NOTES:
00017  *  All implementations of the Handspring Phone Library support a common API.
00018  *  This API is broken up into various categories for easier management.  This file
00019  *  defines the SMS category.  These API calls are used to interact with the wireless network.
00020  */
00021
00022
00023
00024 #ifndef _HS_PHONE_MISC_TYPES_H__
00025 #define _HS_PHONE_MISC_TYPES_H__
00026 #include <PalmOS.h>
00027 #include <PalmTypes.h>
00028 #ifndef __CORE_COMPATIBILITY_H__
00029 #include <PalmCompatibility.h>
00030     /** workaround for differing header files in sdk-3.5 and sdk-internal */
00031     #ifndef __CORE_COMPATIBILITY_H__
00032     #define __CORE_COMPATIBILITY_H__
00033     #endif
00034 #endif
00035
00036
00037 /**
00038  *  Vibrate mode while ringing.
00039  **/
00040 typedef enum
00041   {
00042     phnVibrateOff,      /**<        */
00043     phnVibrateOn        /**<        */
00044   }
00045 PhnVibrateType;
00046
00047 #define isValidPhnVibrateType(t) ((t >= phnVibrateOff) && (t <= phnVibrateOn))  /**<        */
00048
00049
00050 /**
00051  *  Phone Connection Type
00052  **/
00053 typedef enum {
00054   voiceConnection   = 1,    /**<        */
00055   csdConnection     = 2,    /**<        */
00056   gprsConnection    = 3,    /**<        */
00057   oneXConnection    = 4     /**<        */
00058 } PhnConnectionEnum;
00059
00060 #define isValidPhnConnectionEnum(e) ((e >= voiceConnection) && (e <= oneXConnection))   /**<        */
00061
00062 /**
00063  *
00064  **/
00065 typedef enum
00066 {
00067   phnHandsetMode,             /**< sets default mode to handset mode */
00068   phnHeadsetMode,             /**< sets default mode to headdset mode */
00069   phnSpeakerPhoneMode,        /**< sets default mode to speaker phone mode */
00070   phnCarKitMode,              /**< set carkit mode */
00071   phnHandsetLidCloseMode,     /**<        */
00072   phnAutoMode,                /**< automatic mode where modem internaly decides the mode */
00073   phnBluetoothHeadsetMode,    /**<        */
00074   phnBluetoothHandsfreeMode,  /**<        */
00075   phnInvalidEquipmentMode,    /**< Used to flag an invalid mode */
00076   phnEquipmentModeLast        /**<        */
00077
00078 }PhnEquipmentMode;
00079
00080 #define isValidPhnEquipmentMode(m) (m <= phnEquipmentModeLast)  /**<        */
00081
00082
00083 /**
00084  *  Radio state
00085  **/
00086 typedef struct
00087   {
00088     UInt16 version;     /**<        */
00089     UInt32 size;        /**<        */
00090     UInt16 maxConnections;  /**<        */
00091     Boolean alsSupported;   /**< GSM only feature. if False activeLineNumber should always be 1 */
00092     Int16 activeLineNumber; /**<        */
00093   }
00094 PhnRadioStateType,* PhnRadioStatePtr;
00095
00096 #define kRadioStateVersion 1        /**<        */
00097
00098 /**
00099  *  Line State
00100  **/
00101 typedef struct
00102   {
00103     UInt16 version;     /**<        */
00104     UInt16 size;            /**<        */
00105     Boolean activeLine;     /**<        */
00106     Boolean divertIndicator;    /**<        */
00107     Boolean voiceMailIndicator; /**<        */
00108   }
00109 PhnLineStateType, * PhnLineStatePtr;
00110 #define kLineStateVersion 1     /**<        */
00111
00112
00113 /**
00114  *  Phone Library Attributes
00115  **/
00116 typedef enum
00117   {
00118     phnGsmAttrFirst = 0,            /**<        */
00119     phnGsmNoFWVersionCompatibilityCheck,    /**<        */
00120     phnGsmSimBookSimMaxEntries,         /**<        */
00121     phnGsmSimBookSimUsedEntries,        /**<        */
00122     phnGsmRadioAudioSet,            /**<        */
00123         phnGsmFWControlLED,
00124
00125     phnGsmAttrLast
00126   }_PhnLibAttrType;
00127 typedef UInt8  PhnLibAttrType;
00128 typedef UInt8* PhnLibAttrPtr;
00129
00130 typedef enum
00131 {
00132     phnOprtModeNone =-1,   /**< FOR INTERNAL USE OF CM ONLY! */
00133     phnOprtModePwroff,    /**< phone is powering off */
00134     phnOprtModeOffline,   /**< phone is offline Digital*/
00135     phnOprtModeOfflineA, /**< phone is offline analog */
00136     phnOprtModeOnline,    /**< phone is online */
00137     phnOprtModeLPM,       /**< phone is in LPM - Low Power Mode */
00138     phnOprtModeReset,     /**< phone is resetting - i.e. power-cycling */
00139
00140     phnOprtModeMax
00141
00142 } _PhnOprtModeType;
00143
00144 typedef UInt8 PhnOprtModeType;
00145
00146 /**
00147 *  CDMA System info
00148 **/
00149 typedef struct
00150 {
00151  UInt16 sid;
00152  UInt16 nid;
00153  UInt8  bandClass;
00154  UInt16 chNum;
00155  UInt8  wsCode;
00156 } PhnCdmaSystemInfoType, *PhnCdmaSystemInfoPtr;
00157
00158
00159 #endif // _HS_PHONE_MISC_TYPES_H__
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:53 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » telephony

HsPhoneNetwork.h

Go to the documentation of this file.
00001 /******************************************************************************
00002  * Copyright (c) 2004 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  *****************************************************************************/
00005 /** @ingroup Telephony
00006  *
00007  */
00008
00009
00010 /**
00011  * @file    HsPhoneNetwork.h
00012  *
00013  * @brief  Header File for Phone Library API ---- NETWORK CATEGORY
00014  *
00015  * Notes:
00016  *  All implementations of the Handspring Phone Library support a common API.
00017  *  This API is broken up into various categories for easier management.  This file
00018  *  defines the Network category.  These API calls are used to interact with the wireless network.
00019  */
00020
00021
00022 #ifndef HS_PHONENETWORK_H
00023 #define HS_PHONENETWORK_H
00024 #include <PalmOS.h>
00025 #include <PalmTypes.h>
00026 #ifndef __CORE_COMPATIBILITY_H__
00027 #include <PalmCompatibility.h>
00028     /** workaround for differing header files in sdk-3.5 and sdk-internal */
00029     #ifndef __CORE_COMPATIBILITY_H__
00030     #define __CORE_COMPATIBILITY_H__
00031     #endif
00032 #endif
00033 #include <HsPhoneTraps.h>     /**< trap table definition for phone library calls */
00034 #include <HsPhoneErrors.h>    /**< error codes returned by phone library functions */
00035 #include <HsPhoneTypes.h>
00036
00037 /** Phone Library functions */
00038
00039
00040 /**
00041  *  @brief Gets information on a specific voicemail box as specified in the data argument.
00042  *
00043  *  @param refNum:  IN:  Library reference number returned by HsGetPhoneLibrary().
00044  *  @param data:    IN:  See “PhnMsgBoxDataType” for details
00045  *  @retval 0 for success; otherwise failed.
00046  **/
00047
00048 extern Err PhnLibBoxInformation(UInt16 refNum, PhnMsgBoxDataType* data)
00049            PHN_LIB_TRAP(PhnLibTrapBoxInformation);
00050
00051 /**
00052  *  @brief Gets or Set information on a specific voicemail box as specified in the data argument.
00053  *
00054  *  @param refNum:  IN:  Library reference number returned by HsGetPhoneLibrary().
00055  *  @param data:    IN:  See “PhnMsgBoxDataType” for details
00056  *  @param bGetInfo:    IN:  Indicates whether the operation is a get (True) or set (False).
00057  *  @retval 0 for success; otherwise failed.
00058  **/
00059 extern Err PhnLibBoxInformationEx (UInt16 refNum, PhnMsgBoxDataType *data, Boolean bGetInfo)
00060            PHN_LIB_TRAP (PhnLibTrapBoxInformationEx);
00061
00062 /**
00063  *  @brief Return the number of the voice box of the given type for the given line as
00064  *         it is stored on the SIM.
00065  *
00066  *  @param refNum:  IN:  Library reference number returned by HsGetPhoneLibrary().
00067  *  @param type:    IN:  See “PhnMsgBoxType” for details. On Treo™ 600 smartphone by palmOne,
00068  *                           only the kBoxVoice type is supported
00069  *  @param line:    IN:  On a GSM/GPRS device, line can be either “1” or “2”. This is dependant on if
00070  *                           the subscriber account supports 1 or 2 line(s) (on GSM, this is called
00071  *                           Alternative Line Service).
00072  *                           On the CDMA device, it is currently not used.
00073  *  @param number:  IN:  Returns the number as a string.
00074  *  @retval PhnLibGetBoxNumber returns 0 if the number could be determined without
00075  *          encountering an error.
00076  **/
00077 extern Err PhnLibGetBoxNumber(UInt16 refNum, PhnMsgBoxType type, UInt16 line, CharPtr * number)
00078            PHN_LIB_TRAP(PhnLibTrapGetBoxNumber);
00079
00080 /**
00081  *  @brief Get value for home network’s operator ID (MCC+MNC) string
00082  *
00083  *  @param refNum:  IN:  Library reference number returned by HsGetPhoneLibrary().
00084  *  @param *buffer: IN:  Buffer to hold returned string
00085  *  @param bufferSizeP: IN:
00086  *  @retval 0 for success; otherwise failed
00087  **/
00088 extern Err PhnLibHomeOperatorID (UInt16 refNum, char *buffer, Int16* bufferSizeP)
00089            PHN_LIB_TRAP(PhnLibTrapHomeOperatorID);
00090
00091 /**
00092  *  @brief Get value for current network’s operator ID (MCC+MNC) string
00093  *
00094  *  @param refNum:  IN:  Library reference number returned by HsGetPhoneLibrary().
00095  *  @param *buffer: IN:  buffer to hold returned string
00096  *  @param bufferSizeP: IN:
00097  *  @retval 0 for success; otherwise failed
00098  **/
00099 extern Err PhnLibCurrentOperatorID (UInt16 refNum, char *buffer, Int16* bufferSizeP)
00100             PHN_LIB_TRAP(PhnLibTrapCurrentOperatorID);
00101
00102     // Used only by the phone app, so change CDMA function to match this prototype -- ignore mode parameter
00103 /**
00104  *  @brief Get value for current network’s operator string
00105  *
00106  *  @param refNum:  IN:  Library reference number returned by HsGetPhoneLibrary().
00107  *  @param id:      IN:  returned operator ID value
00108  *  @param name:    IN:  returned operator name string
00109  *  @param mode:    IN:  returned registration mode for current operator
00110  *  @retval 0 for success; otherwise failed
00111  **/
00112 extern Err PhnLibCurrentOperator (UInt16 refNum, PhnOperatorID* id, CharPtr* name, GSMRegistrationMode* mode)
00113            PHN_LIB_TRAP(PhnLibTrapCurrentOperator);
00114
00115
00116   // Use this as base -- CDMA function just returns phnErrNotSupported
00117 /**
00118  *  @brief Set value of operator for radio to register to
00119  *
00120  *  @param refNum:  IN:  Library reference number returned by HsGetPhoneLibrary().
00121  *  @param op:      IN:  operator to register to
00122  *  @param regMode: IN:  type of registration to make
00123  *  @retval 0 for success; otherwise failed
00124  **/
00125 extern Err PhnLibSetOperator (UInt16 refNum, PhnOperatorType* op, GSMRegistrationMode regMode)
00126            PHN_LIB_TRAP(PhnLibTrapSetOperator);
00127
00128     // Change to return err, and add PhnRoamStatus parameter
00129 /**
00130  *  @brief Return the roaming status
00131  *
00132  *  @param refNum:  IN:  Library reference number returned by HsGetPhoneLibrary().
00133  *  @param roamStatus:  IN:  PhnLibRoaming returns the roaming status.
00134  *  @retval 0 if no error; error code otherwise
00135  **/
00136 extern Err PhnLibRoaming(UInt16 refNum, PhnRoamStatus * roamStatus)
00137            PHN_LIB_TRAP(PhnLibTrapRoaming);
00138
00139 /**
00140  *  @brief Checks if the phone found any network cellular service.
00141  *
00142  *  @param refNum:  IN:  Library reference number returned by HsGetPhoneLibrary().
00143  *  @retval true if service is found.
00144  *          false if no service
00145  **/
00146 extern Boolean PhnLibRegistered (UInt16 refNum)
00147                PHN_LIB_TRAP(PhnLibTrapRegistered);
00148
00149 /**
00150  *  @brief Return the signal strength
00151  *
00152  *  @param refNum:  IN:  Library reference number returned by HsGetPhoneLibrary().
00153  *  @param quality: IN:  Phone signal strength in dBm
00154  *  @retval 0 if no error
00155  **/
00156 extern Err PhnLibSignalQuality (UInt16 refNum, UInt16 * quality)
00157            PHN_LIB_TRAP(PhnLibTrapSignalQuality);
00158
00159 /**
00160  *  @brief Get the signal quality and ecio level information.
00161  *
00162  *  @param refNum:  IN:  Library reference number returned by HsGetPhoneLibrary().
00163  *  @param quality: IN:  Phone signal strength in dBm
00164  *  @param *bEcio:  IN:
00165  *  @param *ecioLvl:    IN:
00166  *  @retval 0 for success; otherwise failed
00167  **/
00168 extern Err PhnLibSignalQualityEx (UInt16 refNum, UInt16 * quality, Boolean *bEcio, UInt16 *ecioLvl)
00169            PHN_LIB_TRAP (PhnLibTrapSignalQualityEx);
00170
00171 /**
00172  *  @brief Get value for current network’s provider
00173  *
00174  *  @param refNum:  IN:  Library reference number returned by HsGetPhoneLibrary().
00175  *  @param name:    IN:  returned provider name string
00176  *  @retval 0 for success; otherwise failed
00177  **/
00178 extern Err PhnLibCurrentProvider(UInt16 refNum, char** name)
00179            PHN_LIB_TRAP(PhnLibTrapCurrentProvider);
00180
00181 /**
00182  *  @brief Get list of operators available to radio
00183  *
00184  *  @param refNum:  IN:  Library reference number returned by HsGetPhoneLibrary().
00185  *  @param list:    IN:  container for returned list of operator values
00186  *  @retval 0 for success; otherwise failed
00187  **/
00188 extern Err PhnLibGetOperatorList (UInt16 refNum, PhnOperatorListPtr * list)
00189            PHN_LIB_TRAP(PhnLibTrapGetOperatorList);
00190
00191 /**
00192  *  @brief Return a list of phone numbers from the device. These numbers could be
00193  *         voicemail box, data line or fax line (if supported).
00194  *
00195  *  @param refNum:  IN:  Library reference number returned by HsGetPhoneLibrary().
00196  *  @param ownNumbers:  IN:  Pointer to the list of phone box number of the device.
00197  *  @retval 0 for success; otherwise failed
00198  **/
00199 extern Err PhnLibGetOwnNumbers (UInt16 refNum, PhnAddressList* ownNumbers)
00200            PHN_LIB_TRAP(PhnLibTrapGetOwnNumbers);
00201
00202 /**
00203  *  @brief <description to be provided>
00204  *
00205  *  @param refNum:  IN:  Library reference number returned by HsGetPhoneLibrary().
00206  *  @param ownNumbers:  IN:
00207  *  @retval 0 for success; otherwise failed
00208  **/
00209 extern Err PhnLibSetOwnNumbers (UInt16 refnum, PhnAddressList ownNumbers)
00210            PHN_LIB_TRAP(PhnLibTrapSetOwnNumbers);
00211
00212 /**
00213  *  @brief Enable/disable call waiting for phone calls on radio
00214  *
00215  *  @param refNum:  IN:  Library reference number returned by HsGetPhoneLibrary().
00216  *  @param enabled: IN:  flag to enable/disable call waiting
00217  *  @retval 0 for success; otherwise failed
00218  **/
00219 extern Err PhnLibSetCallWaiting (UInt16 refNum, Boolean enabled)
00220            PHN_LIB_TRAP(PhnLibTrapSetCallWaiting);
00221
00222 /**
00223  *  @brief Get call waiting setting for phone calls on radio
00224  *
00225  *  @param refNum:  IN:  Library reference number returned by HsGetPhoneLibrary().
00226  *  @param enabled: IN:  return value of call waiting service on radio.
00227  *                           true if call waiting is enabled
00228  *                           false if call waiting is disabled
00229  *                           value is undefined if return value of function is not 0 (ERROR)
00230  *  @retval 0 for success; otherwise failed
00231  **/
00232 extern Err PhnLibGetCallWaiting (UInt16 refNum, BooleanPtr enabled)
00233            PHN_LIB_TRAP(PhnLibTrapGetCallWaiting);
00234
00235 /**
00236  *  @brief
00237  *
00238  *  @param refNum:  IN:  Library reference number returned by HsGetPhoneLibrary().
00239  *  @param enable:  IN:  True to enable CLIP.
00240  *                           False to disable it.
00241  *  @retval Err Error code.
00242  **/
00243 extern Err PhnLibSetCLIP (UInt16 refNum, Boolean enable)
00244            PHN_LIB_TRAP(PhnLibTrapSetCLIP);
00245
00246 /**
00247  *  @brief (TBC)
00248  *
00249  *  @param refNum:  IN:  Library reference number returned by HsGetPhoneLibrary().
00250  *  @param enabled: IN:
00251  *  @retval Err Error code.
00252  **/
00253 extern Err PhnLibGetCLIP(UInt16 refNum, Boolean* enabled)
00254            PHN_LIB_TRAP(PhnLibTrapGetCLIP);
00255
00256     // Used only by the phone app, so change CDMA function to match this prototype
00257 /**
00258  *  @brief Returns the forwarded number stored in smartphone radio.
00259  *
00260  *  @param refNum:  IN:  Library reference number returned by HsGetPhoneLibrary().
00261  *  @param condition:   IN:  forwarding condition to get values for. Currently CDMA only supports
00262  *                           “phnForwardUnconditional” as defined in “PhnForwardType”.
00263  *  @param destination: IN:  returned forwarding address for given forwarding condition
00264  *  @retval Err 0 for success; otherwise failed
00265  **/
00266 extern Err PhnLibGetForwarding (UInt16 refNum, PhnForwardType condition, PhnAddressHandle * destination)
00267            PHN_LIB_TRAP(PhnLibTrapGetForwarding);
00268
00269 /**
00270  *  @brief
00271  *
00272  *  @param refNum:  IN:  Library reference number returned by HsGetPhoneLibrary().
00273  *  @param mode:    IN:  (TBC)
00274  *  @retval 0 for success; otherwise failed.
00275  **/
00276 extern Err PhnLibSetCLIR (UInt16 refNum, GSMDialCLIRMode mode)
00277            PHN_LIB_TRAP(PhnLibTrapSetCLIR);
00278
00279 /**
00280  *  @brief (TBC)
00281  *
00282  *  @param refNum:  IN:  Library reference number returned by HsGetPhoneLibrary().
00283  *  @param mode:    IN:
00284  *  @param status:  IN:
00285  *  @retval Err Error code.
00286  **/
00287 extern Err PhnLibGetCLIR (UInt16 refNum, GSMDialCLIRMode* mode, PhnCLIRStatus* status)
00288            PHN_LIB_TRAP(PhnLibTrapGetCLIR);
00289
00290 /**
00291  *  @brief Used to Activate a Barring Service
00292  *
00293  *  @param refNum:  IN:  Library reference number returned by HsGetPhoneLibrary().
00294  *  @param facility:    IN:  Barring condition to be set
00295  *  @param password:    IN:  Password to set Barring. This will be used when changing barring option.
00296  *  @retval 0 for success; otherwise failed
00297  **/
00298 extern Err PhnLibSetBarring (UInt16 refNum, PhnBarFacilityType facility, CharPtr password)
00299            PHN_LIB_TRAP(PhnLibTrapSetBarring);
00300
00301 /**
00302  *  @brief Get Barring Service state for given facility
00303  *
00304  *  @param refNum:  IN:  Library reference number returned by HsGetPhoneLibrary().
00305  *  @param facility:    IN:  barring condition to get state for
00306  *  @param enabled: IN:  returned state of given barring service; true = activated.
00307  *  @retval 0 for success; otherwise failed
00308  **/
00309 extern Err PhnLibGetBarring (UInt16 refNum, PhnBarFacilityType facility, Boolean* enabled)
00310            PHN_LIB_TRAP(PhnLibTrapGetBarring);
00311
00312 /**
00313  *  @brief Used to Deactivate a Barring Service
00314  *
00315  *  @param refNum:  IN:  Library reference number returned by HsGetPhoneLibrary().
00316  *  @param facility:    IN:  barring condition to be deactivated
00317  *  @param password:    IN:
00318  *  @retval 0 for success; otherwise failed
00319  **/
00320 extern Err PhnLibDeactivateBarring (UInt16 refNum, PhnBarFacilityType facility, CharPtr password)
00321            PHN_LIB_TRAP(PhnLibTrapDeactivateBarring);
00322
00323 /**
00324  *  @brief Retrieves the roaming indicator text that needs to be displayed if the
00325  *         phone is in enhanced roaming mode.
00326  *
00327  *  @param refNum:  IN:  Library reference number returned by HsGetPhoneLibrary().
00328  *  @param roamTxt: IN:  Pointer to a char of “PhnEnhancedRoamIndMaxLength” maximum length.
00329  *  @param *iconState:  IN:
00330  *  @retval phnErrNotAllowed if called when the phone is not in enhanced roaming.
00331  **/
00332 extern Err PhnLibGetEnhancedRoamIndicator (UInt16 refNum, char * roamTxt, PhnRoamIconState *iconState)
00333            PHN_LIB_TRAP(PhnLibTrapEnhancedRoamIndicator);
00334
00335 /**
00336  *  @brief (TBD)
00337  *
00338  *  @param refNum:  IN:  Library reference number returned by HsGetPhoneLibrary().
00339  *  @param Mode:    IN:  see PhnRoamPrefSelectionType
00340  *  @retval Err Error code.
00341  **/
00342 extern Err PhnLibGetRoamPrefMode (UInt16 refNum, PhnRoamPrefSelectionType *roamPrefP)
00343            PHN_LIB_TRAP (PhnLibTrapGetRoamPrefMode);
00344
00345 /**
00346  *  @brief Set the roaming mode. This API is the same as used when the user
00347  *         checks or unchecks the “Enable Digital roaming” in the Phone
00348  *         Preference on Treo 600. If set, then digital roaming will be allowed.
00349  *
00350  *  @param refNum:  IN:  Library reference number returned by HsGetPhoneLibrary().
00351  *  @param Mode:    IN:  see PhnRoamPrefSelectionType
00352  *  @retval Error status
00353  **/
00354 extern Err PhnLibSetRoamPrefMode (UInt16 refNum, PhnRoamPrefSelectionType roamPref)
00355            PHN_LIB_TRAP (PhnLibTrapSetRoamPrefMode);
00356
00357 /**
00358  *  @brief
00359  *
00360  *  @param refNum:  IN:
00361  *  @param pInfo:   IN:
00362  *  @retval Err Error code.
00363  **/
00364 extern Err PhnLibSetRoamPrefInfo (UInt16 refNum, PhnRoamPrefInfoPtr pInfo)
00365            PHN_LIB_TRAP (PhnLibTrapSetRoamPrefInfo);
00366
00367 /**
00368  *  @brief This function indicate if the Operator has locked the phone to its
00369  *         network (i.e. it can’t be used on other network)
00370  *
00371  *  @param refNum:  IN:  Library reference number returned by HsGetPhoneLibrary().
00372  *  @param facilityType:    IN:  optional facility type, or 0 (TBC)
00373  *  @param enabled: IN:  pointer to output value
00374  *  @retval True if a network was found even if we are unable to register to it.
00375  *          False if no network can be found.
00376  **/
00377 extern Err PhnLibGetOperatorLock(UInt16 refNum, UInt16 facilityType, Boolean* enabled)
00378            PHN_LIB_TRAP(PhnLibTrapGetOperatorLock);
00379
00380 /**
00381  *  @brief (TBD)
00382  *
00383  *  @param refNum:  IN:  Library reference number returned by HsGetPhoneLibrary().
00384  *  @retval Err Error code.
00385  **/
00386 extern Boolean PhnLibNetworkAvailable (UInt16 refNum)
00387                PHN_LIB_TRAP(PhnLibTrapNetworkAvailable);
00388
00389   // GSM and CDMA differ
00390   // Used only by the phone app, so change CDMA function to match this prototype
00391 /**
00392  *  @brief Set call forwarding settings
00393  *
00394  *  @param refNum:  IN:  Library reference number returned by HsGetPhoneLibrary().
00395  *  @param condition:   IN:  forwarding condition to be set
00396  *  @param mode:    IN:  forwarding condition value to be set
00397  *  @param destination: IN:  forwarding address value
00398  *  @retval Err 0 for success; otherwise failed
00399  **/
00400 extern Err PhnLibSetForwarding (UInt16 refNum, PhnForwardType condition, PhnForwardModeType mode, PhnAddressHandle destination)
00401            PHN_LIB_TRAP(PhnLibTrapSetForwarding);
00402
00403 /**
00404  *  @brief This function gives the threshold level of signal quality at which
00405  *         the radio is capable of sending data.
00406  *
00407  *  @param refNum:  IN:  Library reference number returned by HsGetPhoneLibrary().
00408  *  @param threshold:   IN:  (TBC)
00409  *  @retval 0 for success; otherwise failed
00410  **/
00411 extern Err PhnLibUsableSignalStrengthThreshold (UInt16 refNum, WordPtr threshold)
00412            PHN_LIB_TRAP(PhnLibTrapUsableSignalStrengthThreshold);
00413
00414 /**
00415  *  @brief Returns the current state of the data session as well as the available
00416  *         data session type currently available on the network.
00417  *
00418  *  @param refNum:              IN:  Library reference number returned by HsGetPhoneLibrary().
00419  *  @param dataSessionStateP:  OUT:  data structure to be filled out. version field must be set
00420  *  @retval 0 for success; otherwise failed
00421  **/
00422 extern Err PhnLibGetDataSessionInfo(UInt16 refNum, PhnDataSessionStateType *dataSessionStateP)
00423            PHN_LIB_TRAP(PhnLibTrapGetDataSessionInfo);
00424
00425 #endif
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:53 2008 for Palm API Guide


Header Files » Incs » common » libraries » telephony

HsPhoneNetworkTypes.h

Go to the documentation of this file.
00001 /******************************************************************************
00002  * Copyright (c) 2004 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  *****************************************************************************/
00005 /** @ingroup Telephony
00006  *
00007  */
00008
00009
00010 /**
00011  *
00012  * @file    HsPhoneNetworkTypes.h
00013  *
00014  * @brief  Header File for Phone Library API ---- NETWORK CATEGORY
00015  *
00016  * NOTES:
00017  *  All implementations of the Handspring Phone Library support a common API.
00018  *  This API is broken up into various categories for easier management.  This file
00019  *  defines the SMS category.  These API calls are used to interact with the wireless network.
00020  */
00021
00022
00023
00024
00025 #ifndef _HS_PHONE_NETWORK_TYPES_H__
00026 #define _HS_PHONE_NETWORK_TYPES_H__
00027 #include <PalmOS.h>
00028 #include <PalmTypes.h>
00029 #ifndef __CORE_COMPATIBILITY_H__
00030 #include <PalmCompatibility.h>
00031     /** workaround for differing header files in sdk-3.5 and sdk-internal */
00032     #ifndef __CORE_COMPATIBILITY_H__
00033     #define __CORE_COMPATIBILITY_H__
00034     #endif
00035 #endif
00036
00037
00038 #define kMaxPhoneNumberLen  16                  /**< Max length of phone number  */
00039
00040 #define minPasswordLen                  4       /**< Phone password/PIN minimum length  */
00041 #define maxPasswordLen                  8   /**< Phone password/PIN maximum length  */
00042 #define maxPasswordLenCDMA              4   /**<        */
00043
00044 #define phnEnhancedRoamIndMaxLength  40             /**<        */
00045
00046 /**
00047  *  GSM CLIP Subscription Status
00048  **/
00049 typedef enum {
00050     gsmCLIPNotProvisioned,      /**<        */
00051     gsmCLIPProvisioned,     /**<        */
00052     gsmCLIPUnknown          /**<        */
00053 } GSMCLIPStatus;
00054
00055
00056 /**
00057  *
00058  **/
00059 typedef enum {
00060     clirNotProvisioned,         /**< sent: restricted presentation of the calling line */
00061     clirProvisioned,            /**< not sent: don't restrict presentation of the calling line */
00062     clirUnknown,                /**< status not available */
00063     clirTemporaryRestricted,        /**< not sent, override allowed */
00064     clirTemporaryAllowed            /**< sent: override allowed */
00065 } PhnCLIRStatus;
00066
00067 #define isValidPhnCLIRStatus(s) ((s >= clirNotProvisioned) && (s <= clirTemporaryAllowed))  /**<        */
00068
00069
00070 /**
00071  *  GSM CLIR Display Status
00072  **/
00073 typedef enum {
00074   gsmCLIRSubscription,      /**< presentation indicator is used according to the subscription of the CLIR service */
00075   gsmCLIRInvocation,        /**<        */
00076   gsmCLIRSuppression        /**<        */
00077 } GSMCLIRDisplayStatus;
00078
00079 #define isValidGSMDialClirStatus(d) ((d >= gsmDialCLIRNotProvisioned) && (d <= gsmDialCLIRTemporaryAllowed))    /**<        */
00080
00081 /**
00082  * Phone operator status
00083  **/
00084 typedef enum {
00085     phnOpUnknown,       /**<        */
00086     phnOpAvailable,     /**<        */
00087     phnOpCurrent,       /**<        */
00088     phnOpForbidden      /**<        */
00089 } PhnOperatorStatus;
00090
00091 #define isValidPhnOperatorStatus(s) ((s >= phnOpUnknown) && (s <= phnOpForbidden))  /**<        */
00092
00093
00094
00095 /**
00096  *
00097  **/
00098
00099 typedef UInt8 PhnMsgBoxType;        /**<        */
00100 typedef enum
00101   {
00102     kBoxVoice,          /**<        */
00103     kBoxTelefax,        /**<        */
00104     kBoxEMail,          /**<        */
00105     kBoxOther,          /**<        */
00106     kBoxData,           /**<        */
00107     PhnMsgBoxTypeMAX        /**< THIS MUST BE LAST ENTRY.... NOT A VALID VALUE */
00108     // other values reserved for future expansion
00109   }
00110 PhnMsgBoxEnum;
00111
00112 #define isValidPhnMsgBoxType(n) (n < PhnMsgBoxTypeMAX)      /**<        */
00113
00114 typedef UInt8 PhnMsgBoxPriorityType;
00115 typedef enum
00116 {
00117   kSmsPriorityNormal,
00118   kSmsPriorityInteractive,
00119   kSmsPriorityUrgent,
00120   kSmsPriorityEmergency,
00121   kSmsPriorityLast
00122 }
00123 PhnMsgBoxPriorityEnum;
00124
00125 /**
00126  *
00127  **/
00128 typedef struct
00129   {
00130     Boolean         indicatorOn;    /**<        */
00131     PhnMsgBoxType   type;       /**<        */
00132     Int16           messageCount;   /**<        */
00133     Int16           lineNumber;     /**<        */
00134     PhnMsgBoxPriorityType           priority; /**< voicemail priority - example: normal, urgent etc. */
00135   }
00136 PhnMsgBoxDataType;
00137
00138
00139
00140
00141 /**
00142  * Operator info
00143  **/
00144 #define MAX_LONGOPERATORNAME_LENGTH 24      /**<        */
00145 #define MAX_SHORTOPERATORNAME_LENGTH 16     /**<        */
00146 typedef struct
00147   {
00148     PhnOperatorStatus   status;         /**<        */
00149   PhnOperatorID   id;                       /**< Not really used since CDMA just allows one service provider */
00150   char longname[MAX_LONGOPERATORNAME_LENGTH+1];         /**< name + terminating NULL char */
00151   char shortname[MAX_SHORTOPERATORNAME_LENGTH+1];       /**< name + terminating NULL char */
00152   Boolean         isRoaming;                /**< in sync with the current roaming status */
00153   }
00154 PhnOperatorType;
00155
00156 /**
00157  * Operator list
00158  **/
00159 typedef struct
00160   {
00161     short           count;      /**<        */
00162     PhnOperatorType opData[1];      /**<        */
00163   }
00164 PhnOperatorListType,* PhnOperatorListPtr;
00165
00166 /**
00167  *
00168  **/
00169 typedef enum {
00170     gsmRegModeAutomatic,        /**<        */
00171     gsmRegModeManual,       /**<        */
00172     gsmRegModeDeregister,       /**<        */
00173     gsmRegModeFormat,       /**<        */
00174     gsmRegModeManualAutomatic   /**<        */
00175 } GSMRegistrationMode;
00176
00177 #define isValidGSMRegistrationMode(r) (r <= gsmRegModeManualAutomatic)  /**<        */
00178
00179 /**
00180  *  Possible roaming status'
00181  *  GSM devices only use first two
00182  **/
00183 typedef UInt8 PhnRoamStatus;        /**< set a type for this enumeration */
00184 typedef enum
00185   {
00186     PhnRoamStatusOff,           /**<        */
00187     PhnRoamStatusOn,            /**<        */
00188     PhnRoamStatusBlink,         /**<        */
00189     PhnRoamStatusEnhancedIndicator      /**< If this is the roaming status, call PhnLibGetEnhancedRoamIndicator  */
00190   }
00191 PhnRoamStatusEnum;
00192
00193 /**
00194  *  Phone call forwarding reason
00195  **/
00196 typedef UInt8 PhnForwardType;       /**< set a type for this enumeration */
00197 typedef enum {
00198     phnForwardUnconditional,    /**<        */
00199     phnForwardOnBusy,       /**<        */
00200     phnForwardOnNoReplay,       /**<        */
00201     phnForwardOnNotReachable,   /**<        */
00202     phnForwardTelefax,      /**<        */
00203     phnForwardData,         /**<        */
00204     phnForwardCancelAll,        /**<        */
00205     phnForwardConditionalAll,   /**<        */
00206     phnForwardLast          /**<        */
00207 } PhnForwardEnum;
00208
00209 #define isValidPhnForwardType(f) (f < phnForwardLast)       /**<        */
00210
00211 /**
00212  * Phone call barring options
00213  **/
00214 typedef enum {
00215     phnBarOutNone,              /**<        */
00216     phnBarOutAll,               /**<        */
00217     phnBarOutInternational,         /**<        */
00218     phnBarOutInternationalExceptHome,   /**<        */
00219
00220     phnBarInNone,               /**<        */
00221     phnBarInAll,                /**<        */
00222     phnBarInWhenRoaming,            /**<        */
00223     phnBarAll               /**<        */
00224
00225 } PhnBarFacilityTypeEnum;
00226 typedef UInt8   PhnBarFacilityType;
00227 typedef UInt8*  PhnBarFacilityPtr;
00228 #define isValidPhnBarFacilityType(b) (b <= phnBarAll)   /**<        */
00229
00230 /**
00231  * CDMA Roam Preferences
00232  **/
00233 typedef struct
00234   {
00235     Boolean         roamCallGuardEnable;    /**<        */
00236     Boolean         roamRingerEnable;       /**<        */
00237     UInt8           roamRingerID;       /**<        */
00238   }
00239 PhnRoamPrefInfoType,* PhnRoamPrefInfoPtr;
00240
00241 /**
00242  *
00243  **/
00244 typedef enum  {
00245     registrationNone,       /**<        */
00246     registrationHome,       /**<        */
00247     registrationSearch,         /**<        */
00248     registrationDenied,     /**<        */
00249     registrationUnknown,        /**<        */
00250     registrationRoaming     /**<        */
00251 } PhnRegistrationStatus;
00252
00253 #define isValidPhnRegistrationStatus(r) (r <= registrationRoaming)      /**<        */
00254 //#define isValidPhnRegistrationStatus(r) ((r >= registrationNone) && (r <= registrationRoaming))
00255
00256 /**
00257  *  Phone call forwarding mode
00258  **/
00259 typedef UInt8 PhnForwardModeType;   /**<        */
00260 typedef enum {
00261     phnForwardModeDisable,      /**<        */
00262     phnForwardModeEnable,       /**<        */
00263     phnForwardModeInterrogate,  /**<        */
00264     phnForwardModeRegistration, /**<        */
00265     phnForwardModeErasure       /**<        */
00266 } PhnForwardModeEnum;
00267
00268 #define isValidPhnForwardModeType(f) (f <= phnForwardModeErasure)   /**<        */
00269 /**
00270  * MMI Action Code
00271  **/
00272 typedef enum
00273 {
00274   mmiActionNoAction     = 0,        /**<        */
00275   mmiActionActivate     = 0x01,     /**<        */
00276   mmiActionDeactivate   = 0x02,     /**<        */
00277   mmiActionInterrogate  = 0x04,     /**<        */
00278   mmiActionRegister     = 0x08,     /**<        */
00279   mmiActionErasure      = 0x10,     /**<        */
00280   mmiActionUnlock       = 0x20,     /**<        */
00281   mmiActionHandspring   = 0x40      /**<        */
00282 }
00283 PhnMMIActionCodeEnum;
00284 typedef UInt8 PhnMMIActionCode;
00285
00286
00287 /**
00288  * MMI Service Code
00289  **/
00290 typedef enum
00291 {
00292     mmiServiceInvalid = 0,      /**<        */
00293     mmiServiceChangePIN,        /**<        */
00294     mmiServiceChangePIN2,       /**<        */
00295     mmiServiceUnlockPIN,        /**<        */
00296     mmiServiceUnlockPIN2,       /**<        */
00297     mmiServiceIMEI,         /**<        */
00298     mmiServiceCallerId,     /**<        */
00299     mmiServiceNumberSent,       /**<        */
00300     mmiServiceCOLP,         /**<        */
00301     mmiServiceCOLR,         /**<        */
00302     mmiServiceCallWaiting,      /**<        */
00303     mmiServiceForwardUnconditional, /**<        */
00304     mmiServiceForwardBusy,      /**<        */
00305     mmiServiceForwardNoReply,   /**<        */
00306     mmiServiceForwardNotReachable,  /**<        */
00307     mmiServiceForwardAll,       /**<        */
00308     mmiServiceForwardConditionalAll,/**<        */
00309     mmiServiceBAOC,         /**< bar all outging calls */
00310     mmiServiceBAOIC,        /**< bar all outging international calls */
00311     mmiServiceBAOICX,       /**< bar all outging international calls expect home */
00312     mmiServiceBAIC,         /**< bar all incoming calls */
00313     mmiServiceBAICR,        /**< bar all incoming calls while roaming */
00314     mmiServiceAllBarringServ,   /**< bar all services */
00315     mmiServiceAllOutBarringServ,    /**< bar all outgoing services */
00316     mmiServiceAllInBarringServ,     /**< bar all incoming services */
00317     mmiServiceChangeBarPwd,     /**< Change barring password */
00318     mmiServiceUSSD,         /**<        */
00319     mmiServicePhoneNumber,      /**<        */
00320     mmiServiceCallControl,      /**<        */
00321     mmiServiceSelectorOperatorLock, /**<        */
00322     mmiServiceSelectorProviderLock, /**<        */
00323     mmiServiceNNN,          /**<        */
00324     mmiServiceUnimplemented     /**< defined by GSM standard but not implemented in our phone */
00325 }
00326 PhnMMIServiceCodeEnum;
00327 typedef UInt8 PhnMMIServiceCode;
00328
00329 /**
00330  * Call Control Codes
00331  **/
00332 typedef enum {
00333   mmiControlReleaseAllHeld = 0,     /**<        */
00334   mmiControlReleaseAllActive,       /**<        */
00335   mmiControlReleaseCallx,       /**<        */
00336   mmiControlSwap,           /**<        */
00337   mmiControlActivateCallx,      /**<        */
00338   mmiControlConference,         /**<        */
00339   mmiControlTransfer            /**<        */
00340 }PhnCallControlTypeEnum;
00341
00342 typedef UInt8 PhnCallControlType;
00343
00344
00345 typedef enum
00346 {
00347   PhnRoamIconOn,            /**<        */
00348   PhnRoamIconOff,           /**<        */
00349   PhnRoamIconFlash          /**<        */
00350 }
00351 PhnRoamIconState;
00352 /************************************************************
00353  *  Structs
00354  *************************************************************/
00355
00356 #define kMaxMMISequenceLen 64       /**<        */
00357
00358 /**
00359  * Telephone Service Types
00360  **/
00361 typedef enum {
00362   phnTeleserviceUnknown = 0,        /**<        */
00363   phnTeleserviceVoice = 1,      /**<        */
00364   phnTeleserviceData = 2,       /**<        */
00365   phnTeleserviceFax = 4,        /**<        */
00366   phnTeleserviceDefault = 7,        /**<  Voice + Data + Fax */
00367   phnTeleserviceSMS = 8,        /**<        */
00368   phnTeleserviceDataCircSync = 16,  /**<        */
00369   phnTeleserviceDataCircAsync = 32, /**<        */
00370   phnTeleserviceDedicatedPack = 64, /**<        */
00371   phnTeleserviceDedicatedPAD = 128  /**<        */
00372 } PhnTeleserviceType;
00373
00374
00375 /**
00376  * Telephone Service MMI code Types
00377  **/
00378 typedef enum {
00379   phnTeleserviceUnknownMmiCode        = 0,  /**<        */
00380   phnTeleserviceVoiceMmiCode          = 11, /**<        */
00381   phnTeleserviceAllMmiCode            = 12, /**<        */
00382   phnTeleserviceFaxMmiCode            = 13, /**<        */
00383   phnTeleserviceSMSMmiCode            = 16, /**<        */
00384   phnTeleserviceAllExceptSMSCode      = 19, /**<        */
00385   phnTeleserviceDataCircSyncMmiCode   = 24, /**<        */
00386   phnTeleserviceDataCircAsyncMmiCode  = 25, /**<        */
00387   phnTeleserviceDedicatedPackMmiCode  = 26, /**<        */
00388   phnTeleserviceDedicatedPADMmiCode   = 27  /**<        */
00389 } PhnTeleserviceMmiCodeType;
00390
00391 /**
00392  * @brief MMI Decode struct
00393  **/
00394 typedef struct
00395 {
00396   UInt16  size;             /**<        */
00397   PhnMMIActionCode  actionCode;     /**<        */
00398   PhnMMIServiceCode  serviceCode;   /**<        */
00399   Boolean sendHit;          /**<        */
00400   char text[kMaxMMISequenceLen+1];  /**<        */
00401   union
00402   {
00403     struct
00404     {
00405       char  number[kMaxPhoneNumberLen+1];   /**<        */
00406       PhnTeleserviceType type;          /**<        */
00407       UInt16  time;             /**<        */
00408     } mmiForwarding;
00409     struct
00410     {
00411       PhnTeleserviceType type;          /**<        */
00412       char pwd[maxPasswordLen+1];       /**<        */
00413     } mmiBarring;
00414     struct
00415     {
00416       PhnTeleserviceType type;          /**<        */
00417     } mmiCallWaiting;               /**<        */
00418     struct
00419     {
00420       char oldPwd[maxPasswordLen+1];        /**<        */
00421       char newPwd[maxPasswordLen+1];        /**<        */
00422       char repeatNewPwd[maxPasswordLen+1];  /**<        */
00423     } mmiPassword;
00424     struct
00425     {
00426       PhnCallControlType action;        /**<        */
00427       PhnConnectionID id;           /**<        */
00428     } mmiCallControl;
00429     struct
00430     {
00431       char  name[kMaxPhoneNumberLen+1]; /**<        */
00432       char  number[kMaxPhoneNumberLen+1];   /**<        */
00433       GSMDialCLIRMode mode;         /**<        */
00434     } mmiPhoneNumber;
00435
00436   } data;
00437
00438 }
00439 PhnMMIEntryType, *PhnMMIEntryPtr;
00440
00441 #define kMaxImeiLen 24          /**<        */
00442
00443 /**
00444  * @brief MMI result struct
00445  **/
00446 typedef struct
00447 {
00448   UInt16 size;              /**<        */
00449   PhnMMIServiceCode  serviceCode;   /**<        */
00450   union
00451   {
00452     struct
00453     {
00454       Boolean enabled;              /**<        */
00455       char  number[kMaxPhoneNumberLen+1];   /**<        */
00456       PhnTeleserviceType type;          /**<        */
00457       UInt16  time;             /**<        */
00458     } mmiForwarding;
00459     struct
00460     {
00461       Boolean enabled;              /**<        */
00462       PhnTeleserviceType type;          /**<        */
00463     } mmiBarring;
00464     struct
00465     {
00466       Boolean enabled;              /**<        */
00467       PhnTeleserviceType type;          /**<        */
00468     } mmiCallWaiting;
00469     struct
00470     {
00471       Boolean enabled;              /**<        */
00472     } mmiCallerID;
00473     struct
00474     {
00475       GSMCLIRDisplayStatus displayStatus;   /**<        */
00476       PhnCLIRStatus subscriptionStatus;     /**<        */
00477     } mmiNumberSent;
00478     struct
00479     {
00480       Boolean enabled;              /**<        */
00481     } mmiColp;
00482         struct
00483     {
00484       Boolean enabled;              /**<        */
00485     } mmiColr;
00486     struct
00487     {
00488       char imei[kMaxImeiLen+1];         /**<        */
00489     } mmiIMEI;
00490
00491   } data;
00492 }
00493 PhnMMIResultType, *PhnMMIResultPtr;
00494
00495 typedef enum
00496 {
00497   bandGSM_EGSM = 0,
00498   band1800,
00499   band900_1800,
00500   band1900,
00501   bandAuto,
00502   band850,
00503   band1900_850
00504 } _PhnBandSelection;
00505
00506 typedef UInt8 PhnBandSelection;
00507 #define isValidPhnBandSelection(f) (f <= band1900_850)
00508
00509
00510 /**
00511  * This defines the roaming mode of the radio.
00512  */
00513 typedef enum
00514 {
00515   phnRoamPrefHomeOnly,   /**< Home network only (no roaming)      */
00516   phnRoamPrefAny,        /**< Any network       (roaming allowed) */
00517   phnRoamPrefRoamOnly,   /**< Roam network only (roaming only)    */
00518   phnRoamPrefLast        /**< end of list enum                    */
00519 }
00520 _PhnRoamPrefSelectionTypeEnum;
00521 typedef UInt8 PhnRoamPrefSelectionType;
00522 #define isValidRoamMode(x)  (x < phnRoamPrefLast)
00523
00524
00525 /**
00526  * This is now deprecated.
00527  * It is only implemented to maintain backwards compatibility
00528  * Currently, the only user is NetMaster
00529  **/
00530 typedef enum
00531 {
00532     phnOneXStatusPRevNoSvc,     /**< Service is not available. */
00533     phnOneXStatusPRev1,         /**< J-STD-008 service is in use. */
00534     phnOneXStatusPRev3,         /**< IS-95A service is in use. */
00535     phnOneXStatusPRev4,         /**< IS-95B service is in use. */
00536     phnOneXStatusPRev6,         /**< IS-2000 release 0 service is in use. */
00537     phnOneXStatusPRev7      /**< IS-2000 release A service is in use. */
00538 }
00539 _PhnOneXProtRevType;
00540 typedef UInt8 PhnOneXProtRevType;   /**<        */
00541 #define isValidPhnOneXProtRevType(p) (p <= phnOneXStatusPRev7)      /**<        */
00542
00543 /**
00544  * Describes the current packet data session state.
00545  * Currently there are 3 states. Active, dormant, or none.
00546  **/
00547 typedef enum
00548 {
00549   phnPacketDataSessionNone,         /**< No packet data session exists. */
00550   phnPacketDataSessionDormant,      /**< Packet data session dormant    */
00551   phnPacketDataSessionActive        /**< Packet data session active     */
00552 }
00553 _PhnPacketDataSessionType;
00554 typedef UInt8 PhnPacketDataSessionType;     /**<        */
00555 #define isValidPhnPacketDataSessionType(p) (p <= phnPacketDataSessionActive)        /**<        */
00556
00557 /**
00558  * This is now deprecated.
00559  * It is only implemented to maintain backwards compatibility
00560  * Currently, the only user is NetMaster
00561  **/
00562 typedef enum
00563 {
00564     phnMIPSessionNone,      /**<        */
00565     phnMIPSession           /**< A Mobile IP session exists. */
00566 }
00567 _PhnMIPSessionType;
00568 typedef UInt8 PhnMIPSessionType;        /**<        */
00569 #define isValidPhnMIPSessionType(m) (m <= phnMIPSession)        /**<        */
00570
00571
00572 /**
00573  * This is now deprecated.
00574  * It is only implemented to maintain backwards compatibility
00575  * Currently, the only user is NetMaster and the Phone App
00576  **/
00577 typedef struct
00578 {
00579   PhnOneXProtRevType        oneXStatusPRev;     /**<        */
00580   PhnPacketDataSessionType  pdSessionStatus;    /**<        */
00581   PhnMIPSessionType         mipSessionType; /**<        */
00582 }
00583 PhnOneXStatus;
00584
00585
00586 /**
00587  * This defines the different data service types.
00588  */
00589 typedef enum
00590 {
00591   phnDataServiceNone,
00592   phnDataServiceCSD,
00593   phnDataService1xRTT,
00594   phnDataService1xEVDO,
00595   phnDataServiceGPRS,
00596   phnDataServiceEdge,
00597   phnDataServiceLast
00598 }
00599 _PhnDataServiceType;
00600 typedef UInt16 PhnDataServiceType;
00601 #define isValidDataService(x) (x < phnDataServiceLast)
00602
00603
00604 /**
00605  * List of errors on why a data call was disconnected.
00606  */
00607 typedef enum
00608 {
00609   phnPacketDataEndStatusUnknown,       /**< Unknown end status      */
00610   phnPacketDataEndStatusNormal,        /**< Normal                  */
00611   phnPacketDataEndStatusReorder,       /**< reoder                  */
00612   phnPacketDataEndStatusRetry,         /**< retry                   */
00613   phnPacketDataEndStatusTimeout,       /**< call                    */
00614   phnPacketDataEndStatusIntercept,     /**< Intercept               */
00615   phnPacketDataEndStatusReject,        /**< Service Option rejected */
00616   phnPacketDataEndStatusNoReason,      /**< No reason given         */
00617   phnPacketDataEndStatusAuthFailed,    /**< authentication failed   */
00618   phnPacketDataEndStatusDropped,       /**< dropped call            */
00619   phnPacketDataEndStatusLast           /**< place holder for last   */
00620 }
00621 _PhnPacketDataEndStatusEnum;
00622 typedef UInt16 PhnPacketDataEndStatusType;
00623 #define isValidPacketDataEndStatus(x) (x < phnPacketDataEndStatusLast)
00624
00625 #define PhnDataSessionStateTypeMajorVersion 0x0001L  // high word
00626 #define PhnDataSessionStateTypeMinorVersion 0x0000L  // low  word
00627 #define PhnDataSessionStateTypeVersion      (((UInt32)PhnDataSessionStateTypeMajorVersion << 16) | PhnDataSessionStateTypeMinorVersion)
00628 typedef struct
00629 {
00630   UInt32                      version;          /**< (1.0) should be set to the structure version that you are requesting                   */
00631   PhnDataServiceType          availableService; /**< (1.0) data connection type available                                                   */
00632   PhnDataServiceType          sessionType;      /**< (1.0) data connection type (valid only if status is Active or Dormant)                 */
00633   PhnPacketDataSessionType    sessionStatus;    /**< (1.0) data connection status                                                           */
00634   PhnPacketDataEndStatusType  disconnectStatus; /**< (1.0) data connection end status (only useful after a data call has been terminated)   */
00635 }
00636 PhnDataSessionStateType;
00637
00638
00639 /**
00640  *
00641  **/
00642 typedef struct
00643 {
00644   UInt32 timeInSecs;        /**< Current time in minutes */
00645   Boolean daylightSavings;  /**< Is this daylight savings  */
00646   Int16 timeZone;          /**< Number of minutes east of GMT  */
00647   UInt8  daylightSavingsHour; /**< DST adjusted hours : GSM Only  */
00648
00649 } PhnNetworkTime;
00650
00651
00652 #endif // _HS_PHONE_NETWORK_TYPES_H__
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:53 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » telephony

HsPhonePower.h

Go to the documentation of this file.
00001 /******************************************************************************
00002  * Copyright (c) 2004 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  *****************************************************************************/
00005 /** @ingroup Telephony
00006  *
00007  */
00008
00009
00010 /**
00011  * @file    HsPhonePower.h
00012  *
00013  * @brief  Header File for Phone Library API ---- POWER CATEGORY
00014  *
00015  * Notes:
00016  *  All implementations of the Handspring Phone Library support a common API.
00017  *  This API is broken up into various categories for easier management.  This file
00018  *  defines the POWER category.  This category provides routines to query & manage
00019  *  the radio power.
00020  *
00021  */
00022
00023
00024
00025 #ifndef HS_PHONEPOWER_H
00026 #define HS_PHONEPOWER_H
00027 #include <PalmOS.h>
00028 #include <PalmTypes.h>
00029 #ifndef __CORE_COMPATIBILITY_H__
00030 #include <PalmCompatibility.h>
00031     /** workaround for differing header files in sdk-3.5 and sdk-internal */
00032     #ifndef __CORE_COMPATIBILITY_H__
00033     #define __CORE_COMPATIBILITY_H__
00034     #endif
00035 #endif
00036 #include <HsPhoneTraps.h>     /**< trap table definition for phone library calls */
00037 #include <HsPhoneErrors.h>    /**< error codes returned by phone library functions */
00038 #include <HsPhoneTypes.h>
00039
00040
00041
00042 /**
00043  *  @brief
00044  *
00045  *  @param refNum:  IN:
00046  *  @param on:      IN:
00047  *  @retval Err Error code.
00048  **/
00049   extern Err PhnLibSetModulePower (UInt16 refNum, Boolean on)
00050       PHN_LIB_TRAP(PhnLibTrapSetModulePower);
00051
00052
00053 /**
00054  *  @brief
00055  *
00056  *  @param refNum:  IN:
00057  *  @retval Err Error code.
00058  **/
00059   extern PhnPowerType PhnLibModulePowered (UInt16 refNum)
00060       PHN_LIB_TRAP (PhnLibTrapModulePowered);
00061
00062
00063 /**
00064  *  @brief
00065  *
00066  *  @param refNum:  IN:
00067  *  @retval Err Error code.
00068  **/
00069 extern Err PhnLibContinuePhonePowerOn (UInt16 refNum)
00070       PHN_LIB_TRAP (PhnLibTrapContinuePhonePowerOn);
00071
00072
00073 /**
00074  *  @brief
00075  *
00076  *  @param refNum:  IN:
00077  *  @retval Err Error code.
00078  **/
00079 extern Err PhnLibContinuePhonePowerOff (UInt16 refNum)
00080       PHN_LIB_TRAP (PhnLibTrapContinuePhonePowerOff);
00081
00082 #endif
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:53 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » telephony

HsPhoneSecurity.h

Go to the documentation of this file.
00001 /******************************************************************************
00002  * Copyright (c) 2004 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  *****************************************************************************/
00005 /** @ingroup Telephony
00006  *
00007  */
00008
00009
00010 /**
00011  * @file    HsPhoneSecurity.h
00012  *
00013  * @brief  Header File for Phone Library API ---- SECURITY CATEGORY
00014  *
00015  * Notes:
00016  *  All implementations of the Handspring Phone Library support a common API.
00017  *  This API is broken up into various categories for easier management.  This file
00018  *  defines the public portion of the Security category.  These API calls are used
00019  *  to protect access to device and phone features.
00020  *
00021  */
00022
00023
00024 #ifndef HS_PHONESECURITY_H
00025 #define HS_PHONESECURITY_H
00026 #include <PalmOS.h>
00027 #include <PalmTypes.h>
00028 #ifndef __CORE_COMPATIBILITY_H__
00029 #include <PalmCompatibility.h>
00030     /** workaround for differing header files in sdk-3.5 and sdk-internal */
00031     #ifndef __CORE_COMPATIBILITY_H__
00032     #define __CORE_COMPATIBILITY_H__
00033     #endif
00034 #endif
00035 #include <HsPhoneTraps.h>     /**< trap table definition for phone library calls */
00036 #include <HsPhoneErrors.h>    /**< error codes returned by phone library functions */
00037 #include <HsPhoneTypes.h>
00038
00039 /**
00040  *  @brief
00041  *
00042  *  @param refNum:  IN:
00043  *  @param lock:    IN:
00044  *  @param autoLockCheckBoxState:   IN:
00045  *  @retval Err Error code.
00046  **/
00047 extern Err PhnLibGetPhoneLock (UInt16 refNum, Boolean * lock, Boolean * autoLockCheckBoxState)
00048   PHN_LIB_TRAP(PhnLibTrapGetPhoneLock);
00049
00050 extern Err PhnLibSetPhoneLock (UInt16 refNum, Boolean enable, PhnLockMode lockMode, CharPtr password)
00051       PHN_LIB_TRAP (PhnLibTrapSetPhoneLock);
00052
00053 extern Err PhnLibSetOperatorLock(UInt16 refNum, UInt16 facilityType, Boolean enable, CharPtr password)
00054                 PHN_LIB_TRAP(PhnLibTrapSetOperatorLock);
00055
00056
00057 extern Err PhnLibGetRemainingPasswordTries(UInt16 refNum, Int16* pinTries, Int16* pin2Tries, Int16* pukTries, Int16* puk2Tries)
00058                 PHN_LIB_TRAP(PhnLibTrapGetRemainingPasswordTries);
00059
00060 extern Err PhnLibCRSM(UInt16 refNum, UInt16 command, UInt32 fileId,
00061       UInt16 p1, UInt16 p2, UInt16 p3, UInt8* data, UInt16 dataSize,
00062     UInt16* sw1, UInt16* sw2, char ** response, UInt16* responseSize)
00063   PHN_LIB_TRAP(PhnLibTrapCRSM);
00064
00065
00066 #endif
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:53 2008 for Palm API Guide


Header Files » Incs » common » libraries » telephony

HsPhoneSecurityTypes.h

Go to the documentation of this file.
00001 /******************************************************************************
00002  * Copyright (c) 2004 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  *****************************************************************************/
00005 /** @ingroup Telephony
00006  *
00007  */
00008
00009
00010 /**
00011  *
00012  * @file    HsPhoneSecurityTypes.h
00013  *
00014  * @brief  Header File for Phone Library API ---- NETWORK CATEGORY
00015  *
00016  * NOTES:
00017  *  All implementations of the Handspring Phone Library support a common API.
00018  *  This API is broken up into various categories for easier management.  This file
00019  *  defines the Security category.  These API calls are used to interact with the wireless network.
00020  */
00021
00022
00023
00024 #ifndef _HS_PHONE_Security_TYPES_H__
00025 #define _HS_PHONE_Security_TYPES_H__
00026 #include <PalmOS.h>
00027 #include <PalmTypes.h>
00028 #ifndef __CORE_COMPATIBILITY_H__
00029 #include <PalmCompatibility.h>
00030     /** workaround for differing header files in sdk-3.5 and sdk-internal */
00031     #ifndef __CORE_COMPATIBILITY_H__
00032     #define __CORE_COMPATIBILITY_H__
00033     #endif
00034 #endif
00035
00036
00037 #define isValidPhnPasswordType(p) (p <= phnPasswordBarrAC)
00038 //#define isValidPhnPasswordType(p) ((p >= phnPasswordUnknown) && (p <= phnPasswordBarrAC))
00039
00040
00041 /**
00042  *  Phone password types
00043  *  See GSM 07.07, section 8.3 for a list of passwords. The following
00044  *  list is based on on version 6.2.0 of the recommendation.
00045  *
00046  *  It is assumed that all PINs and PUKs below are network-based
00047  *  PINS and PUKs. Function Change() uses a different timeout for
00048  *  such PINs and/or PUKs.
00049  **/
00050 typedef enum {
00051     phnPasswordUnknown,     /**< FAULT or none of the strings below */
00052
00053     phnPasswordNone,        /**< READY */
00054     phnPasswordSIMPIN,      /**< SIM PIN */
00055     phnPasswordSIMPUK,      /**< SIM PUK */
00056     phnPasswordPhSIMPIN,        /**< PH-SIM PIN */
00057     phnPasswordPh1SIMPIN,       /**< PH-FSIM PIN */
00058     phnPasswordPh1SIMPUK,       /**< PH-FSIM PUK */
00059     phnPasswordSIMPIN2,     /**< SIM PIN2 */
00060     phnPasswordSIMPUK2,     /**< SIM PUK2 */
00061
00062     phnPasswordNetworkPIN,      /**< PH-NET PIN */
00063     phnPasswordNetworkPUK,      /**< PH-NET PUK */
00064     phnPasswordNetworkSubsetPIN,    /**< PH-NETSUB PIN */
00065     phnPasswordNetworkSubsetPUK,    /**< PH-NETSUB PUK */
00066     phnPasswordServiceProviderPIN,  /**< PH-SP PIN */
00067     phnPasswordServiceProviderPUK,  /**< PH-SP PUK */
00068     phnPasswordCorporatePIN,    /**< PH-CORP PIN */
00069     phnPasswordCorporatePUK,    /**< PH-CORP PUK */
00070
00071         // The passwords below are supported by the +CPWD command. See GSM 07.07
00072     // section 7.4 and 7.5 for a list of facility-specific passwords.
00073
00074     phnPasswordBarrAO,      /**< all outgoing call */
00075     phnPasswordBarrOI,      /**< outgoing intÕl calls */
00076     phnPasswordBarrOX,      /**< outgoing intÕl calls except to home country */
00077     phnPasswordBarrAI,      /**< all incoming calls */
00078     phnPasswordBarrIR,      /**< incoming calls when roaming outside home country */
00079     phnPasswordBarrAB,      /**< all barring services */
00080     phnPasswordBarrAG,      /**< all outgoing barring services */
00081     phnPasswordBarrAC       /**< all incoming barring services */
00082 } PhnPasswordTypeEnum;
00083
00084 typedef UInt8 PhnPasswordType;
00085
00086 #endif // _HS_PHONE_Security_TYPES_H__
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:53 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » telephony

HsPhoneSMS.h

Go to the documentation of this file.
00001 /******************************************************************************
00002  * Copyright (c) 2004 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  *****************************************************************************/
00005 /** @ingroup Telephony
00006  *
00007  */
00008
00009
00010 /**
00011  * @file    HsPhoneSMS.h
00012  *
00013  * @brief  Header File for Phone Library API ---- SMS CATEGORY
00014  *
00015  * Notes:
00016  *  All implementations of the Handspring Phone Library support a common API.
00017  *  This API is broken up into various categories for easier management.  This file
00018  *  defines the SMS category.  These API calls are used to send/receive Short Message
00019  *  Service (SMS) messages.
00020  */
00021
00022 #ifndef HS_PHONESMS_H
00023 #define HS_PHONESMS_H
00024 #include <PalmOS.h>
00025 #include <PalmTypes.h>
00026 #ifndef __CORE_COMPATIBILITY_H__
00027 #include <PalmCompatibility.h>
00028     /** workaround for differing header files in sdk-3.5 and sdk-internal */
00029     #ifndef __CORE_COMPATIBILITY_H__
00030     #define __CORE_COMPATIBILITY_H__
00031     #endif
00032 #endif
00033 #include <HsPhoneTraps.h>     /** trap table definition for phone library calls */
00034 #include <HsPhoneErrors.h>    /** error codes returned by phone library functions */
00035 #include <HsPhoneTypes.h>
00036
00037
00038 /**
00039  *  @brief
00040  *
00041  *  @param refNum:  IN:
00042  *  @param number:  IN:
00043  *  @param id:      IN:
00044  *  @retval PhnAddressHandle
00045  **/
00046   extern PhnAddressHandle PhnLibNewAddress (UInt16 refNum, const CharPtr number, PhnDatabaseID id)
00047                   PHN_LIB_TRAP(PhnLibTrapNewAddress);
00048
00049 /**
00050  *  @brief This function returns the field’s value for a given address in a newly allocated
00051  *         block. This function returns 0 if there was an error while retrieving the data.
00052  *
00053  *  @param refNum:      IN:
00054  *  @param address: IN:
00055  *  @param fied:    IN:
00056  *  @retval CharPtr
00057  **/
00058   extern CharPtr PhnLibGetField (UInt16 refNum, PhnAddressHandle address, PhnAddressField field)
00059                   PHN_LIB_TRAP(PhnLibTrapGetField);
00060
00061 /**
00062  *  @brief
00063  *
00064  *  @param refNum:  IN:
00065  *  @param address: IN:
00066  *  @retval PhnDatabaseID
00067  **/
00068   extern PhnDatabaseID PhnLibGetID(UInt16 refNum, PhnAddressHandle address)
00069                 PHN_LIB_TRAP(PhnLibTrapGetID);
00070
00071 /**
00072  *  @brief This function lets the specified field of address to the given data. This function
00073  *         returns 0 if the field was modified without an error.
00074  *
00075  *  @param refNum:      IN:
00076  *  @param address: IN:
00077  *  @param field:   IN:
00078  *  @param data:    IN:
00079  *  @retval Err Error Code.
00080  **/
00081   extern Err PhnLibSetField(UInt16 refNum, PhnAddressHandle address, PhnAddressField field, const char* data)
00082                 PHN_LIB_TRAP(PhnLibTrapSetField);
00083
00084 /**
00085  *  @brief
00086  *
00087  *  @param refNum:      IN:
00088  *  @param address: IN:
00089  *  @param number:  IN:
00090  *  @retval Err Error Code.
00091  **/
00092   extern Err PhnLibSetNumber(UInt16 refNum, PhnAddressHandle address, const char* number)
00093                 PHN_LIB_TRAP(PhnLibTrapSetNumber);
00094
00095 /**
00096  *  @brief
00097  *
00098  *  @param refNum:      IN:
00099  *  @param address: IN:
00100  *  @param id:      IN:
00101  *  @retval Err Error code.
00102  **/
00103   extern Err PhnLibSetID(UInt16 refNum, PhnAddressHandle address, PhnDatabaseID id)
00104                 PHN_LIB_TRAP(PhnLibTrapSetID);
00105
00106 /**
00107  *  @brief
00108  *
00109  *  @param refNum:      IN:
00110  *  @param address: IN:
00111  *  @param format:  IN:
00112  *  @retval Char
00113  **/
00114   extern char* PhnLibAddressToText(UInt16 refNum, PhnAddressHandle address ,SMSAddressFormat format)
00115               PHN_LIB_TRAP(PhnLibTrapAddressToText);
00116
00117 /**
00118  *  @brief
00119  *
00120  *  @param refNum:      IN:
00121  *  @param address: IN:
00122  *  @retval Boolean
00123  **/
00124   extern Boolean PhnLibHasName(UInt16 refNum, PhnAddressHandle address)
00125                 PHN_LIB_TRAP(PhnLibTrapHasName);
00126
00127 /**
00128  *  @brief
00129  *
00130  *  @param refNum:      IN:
00131  *  @param a:       IN:
00132  *  @param b:       IN:
00133  *  @retval Boolean
00134  **/
00135   extern Boolean PhnLibEqual(UInt16 refNum, PhnAddressHandle a, PhnAddressHandle b)
00136                 PHN_LIB_TRAP(PhnLibTrapEqual);
00137
00138 /**
00139  *  @brief
00140  *
00141  *  @param refNum:      IN:
00142  *  @retval DmOpenRef
00143  **/
00144   extern DmOpenRef PhnLibGetDBRef(UInt16 refNum)
00145                 PHN_LIB_TRAP(PhnLibTrapGetDBRef);
00146
00147 /**
00148  *  @brief
00149  *
00150  *  @param refNum:      IN:
00151  *  @param db:      IN:
00152  *  @retval Err Error code.
00153  **/
00154   extern Err PhnLibReleaseDBRef(UInt16 refNum, DmOpenRef db)
00155                 PHN_LIB_TRAP(PhnLibTrapReleaseDBRef);
00156
00157 /**
00158  *  @brief Create a new message of the given message type and return the ID of the new
00159  *         record in the message database. All fields are either empty (e.g. message’s text) or
00160  *         contain default values (e.g. sending options).
00161  *
00162  *  @param refNum:      IN:
00163  *  @param type:    IN:  Incoming or Outcoming message. See SMSMessageType for more details.
00164  *  @retval Returns either the ID of the new message record or phnErrUnknownID if there was
00165  *          not sufficient memory to allocate a new message.
00166  **/
00167   extern PhnDatabaseID PhnLibNewMessage(UInt16 refNum, SMSMessageType type)
00168                 PHN_LIB_TRAP(PhnLibTrapNewMessage);
00169
00170 /**
00171  *  @brief This function deletes the message with the given msgID from the message database.
00172  *
00173  *  @param refNum:      IN:
00174  *  @param msgID:   IN:
00175  *  @param archive: IN:
00176  *  @retval This function returns 0 if there was no error during the deletion of the record. If
00177  *          there is no message with the given id, this function returns phnErrUnknownID.
00178  **/
00179   extern Err PhnLibDeleteMessage(UInt16 refNum, PhnDatabaseID msgID, Boolean archive)
00180                 PHN_LIB_TRAP(PhnLibTrapDeleteMessage);
00181
00182 /**
00183  *  @brief This function sends the message to all the recipients.
00184  *
00185  *  @param refNum:      IN:
00186  *  @param msgID:   IN:
00187  *  @param progress:    IN:
00188  *  @retval phnErrUnknownID: If there is no message with the given ID.
00189  *          phnErrIllegalStatus: If the message’s status is not kNone or kPending
00190  *          phnErrNotAllowed: If the error flag is set. It is not permitted to send messages
00191  *             when the error flag is set.
00192  **/
00193   extern Err PhnLibSendMessage(UInt16 refNum, PhnDatabaseID msgID, Boolean progress)
00194                 PHN_LIB_TRAP(PhnLibTrapSendMessage);
00195
00196 /**
00197  *  @brief
00198  *
00199  *  @param refNum:      IN:
00200  *  @retval Err Error code.
00201  **/
00202   extern Err PhnLibSendPendingMessages(UInt16 refNum)
00203                 PHN_LIB_TRAP(PhnLibTrapSendPendingMessages);
00204
00205 /**
00206  *  @brief This function sets the text of the message to the given text.
00207  *
00208  *  @param refNum:      IN:
00209  *  @param msgID:   IN:
00210  *  @param data:    IN:
00211  *  @param size:    IN:
00212  *  @retval 0: if the text was updated successfully.
00213  *          phnErrIllegalChars: If the text contains illegal characters
00214  **/
00215   extern Err PhnLibSetText(UInt16 refNum, PhnDatabaseID msgID, const char* data, Int16 size)
00216                 PHN_LIB_TRAP(PhnLibTrapSetText);
00217
00218 /**
00219  *  @brief This function sets the date of the given message. The date must be given in Palm
00220  *         OS format (as returned by TimGetSeconds).
00221  *
00222  *  @param refNum:      IN:
00223  *  @param msgID:   IN:
00224  *  @param date:    IN:
00225  *  @retval Err Error code.
00226  **/
00227   extern Err PhnLibSetDate(UInt16 refNum, PhnDatabaseID msgID, UInt32 date)
00228                 PHN_LIB_TRAP(PhnLibTrapSetDate);
00229
00230 /**
00231  *  @brief This function updates the sending options for the given message.
00232  *
00233  *  @param refNum:      IN:
00234  *  @param msgID:   IN:
00235  *  @param options: IN:
00236  *  @retval Err Error code.
00237  **/
00238   extern Err PhnLibSetOptions(UInt16 refNum, PhnDatabaseID msgID, const SMSSendOptions* options)
00239                 PHN_LIB_TRAP(PhnLibTrapSetOptions);
00240
00241 /**
00242  *  @brief This function updates the list of addresses with the given list of addresses.
00243  *
00244  *  @param refNum:      IN:
00245  *  @param msgID:   IN:
00246  *  @param list:    IN:
00247  *  @retval Err Error code.
00248  **/
00249   extern Err PhnLibSetAddresses(UInt16 refNum, PhnDatabaseID msgID, const PhnAddressList list)
00250                 PHN_LIB_TRAP(PhnLibTrapSetAddresses);
00251
00252 /**
00253  *  @brief This function sets the status of the given message.
00254  *
00255  *  @param refNum:      IN:
00256  *  @param msgID:   IN:
00257  *  @param status:  IN:
00258  *  @retval Err Error code.
00259  **/
00260   extern Err PhnLibSetStatus(UInt16 refNum, PhnDatabaseID msgID, SMSMessageStatus status)
00261                 PHN_LIB_TRAP(PhnLibTrapSetStatus);
00262
00263 /**
00264  *  @brief This function updates a message’s flags.
00265  *
00266  *  @param refNum:      IN:
00267  *  @param msgID:   IN:
00268  *  @param flags:   IN:
00269  *  @retval Err Error code.
00270  **/
00271   extern Err PhnLibSetFlags(UInt16 refNum, PhnDatabaseID msgID, UInt32 flags)
00272                 PHN_LIB_TRAP(PhnLibTrapSetFlags);
00273
00274 /**
00275  *  @brief This function updates the given message’s owner.
00276  *
00277  *  @param refNum:      IN:
00278  *  @param msgID:   IN:
00279  *  @param owner:   IN
00280  *  @retval Err Error code.
00281  **/
00282   extern Err PhnLibSetOwner(UInt16 refNum, PhnDatabaseID msgID, UInt32 owner)
00283                 PHN_LIB_TRAP(PhnLibTrapSetOwner);
00284
00285 /**
00286  *  @brief This function copies the text of the message into a new block of memory that must
00287  *         be disposed of by the caller.
00288  *
00289  *  @param refNum:      IN:
00290  *  @param msgID:   IN:
00291  *  @param data:    IN:
00292  *  @retval Err Error code.
00293  **/
00294   extern Err PhnLibGetText(UInt16 refNum, PhnDatabaseID msgID, MemHandle* data)
00295                 PHN_LIB_TRAP(PhnLibTrapGetText);
00296
00297 /**
00298  *  @brief This function returns the date of the given message in Palm OS format.
00299  *
00300  *  @param refNum:      IN:
00301  *  @param msgID:   IN:
00302  *  @param date:    IN:
00303  *  @retval Err Error code.
00304  **/
00305   extern Err PhnLibGetDate(UInt16 refNum, PhnDatabaseID msgID, UInt32* date)
00306                 PHN_LIB_TRAP(PhnLibTrapGetDate);
00307
00308 /**
00309  *  @brief This function returns the sending options for the given message.
00310  *
00311  *  @param refNum:      IN:
00312  *  @param msgID:   IN:
00313  *  @param options: IN:
00314  *  @retval Err Error code.
00315  **/
00316   extern Err PhnLibGetOptions(UInt16 refNum, PhnDatabaseID msgID, SMSSendOptions* options)
00317                 PHN_LIB_TRAP(PhnLibTrapGetOptions);
00318
00319 /**
00320  *  @brief This function returns the list of addresses for the given message.
00321  *
00322  *  @param refNum:      IN:
00323  *  @param msgID:   IN:
00324  *  @param list:    IN:
00325  *  @retval Err Error code.
00326  **/
00327   extern Err PhnLibGetAddresses(UInt16 refNum, PhnDatabaseID msgID, PhnAddressList* list)
00328                 PHN_LIB_TRAP(PhnLibTrapGetAddresses);
00329
00330 /**
00331  *  @brief This function returns the status field of the message.
00332  *
00333  *  @param refNum:      IN:
00334  *  @param msgID:   IN:
00335  *  @param status:  IN:
00336  *  @retval Err Error code.
00337  **/
00338   extern Err PhnLibGetStatus(UInt16 refNum, PhnDatabaseID msgID, SMSMessageStatus* status)
00339                 PHN_LIB_TRAP(PhnLibTrapGetStatus);
00340
00341 /**
00342  *  @brief This function returns the message’s flags.
00343  *
00344  *  @param refNum:      IN:  Library reference number returned by HsGetPhoneLibrary().
00345  *  @param msgID:   IN:
00346  *  @param flags:   IN:
00347  *  @retval Err Error code.
00348  **/
00349   extern Err PhnLibGetFlags(UInt16 refNum, PhnDatabaseID msgID, UInt32* flags)
00350                 PHN_LIB_TRAP(PhnLibTrapGetFlags);
00351
00352 /**
00353  *  @brief This function returns the message’s owner.
00354  *
00355  *  @param refNum:      IN:  Library reference number returned by HsGetPhoneLibrary().
00356  *  @param msgID:   IN:
00357  *  @param owner:   IN:
00358  *  @retval Error code.
00359  **/
00360   extern Err PhnLibGetOwner(UInt16 refNum, PhnDatabaseID msgID, UInt32* owner)
00361                 PHN_LIB_TRAP(PhnLibTrapGetOwner);
00362
00363 /**
00364  *  @brief This function returns the message’s type. A client application typically uses the
00365  *         type to map messages to categories.
00366  *
00367  *  @param refNum:      IN:
00368  *  @param msgID:   IN:
00369  *  @param type:    IN:
00370  *  @retval Err Error code.
00371  **/
00372   extern Err PhnLibGetType(UInt16 refNum, PhnDatabaseID msgID, SMSMessageType* type)
00373                 PHN_LIB_TRAP(PhnLibTrapGetType);
00374
00375 /**
00376  *  @brief This function returns true if the given Palm OS character is a legal GSM character.
00377  *         If this function returns false, the given character does not exist within
00378  *         the GSM alphabet.
00379  *
00380  *  @param refNum:      IN:
00381  *  @param c:       IN:
00382  *  @retval Boolean
00383  **/
00384   extern Boolean PhnLibIsLegalCharacter(UInt16 refNum, char c)
00385                 PHN_LIB_TRAP(PhnLibTrapIsLegalCharacter);
00386
00387 /**
00388  *  @brief This function maps the given Palm OS character to its equivalent
00389  *         in the GSM alphabet.
00390  *
00391  *  @param refNum:      IN:
00392  *  @param c:       IN:
00393  *  @retval char
00394  **/
00395   extern char PhnLibMapCharacter(UInt16 refNum, char c)
00396                 PHN_LIB_TRAP(PhnLibTrapMapCharacter);
00397
00398 /**
00399  *  @brief This function sets the number of the service center to be used
00400  *         for sending the SMS messages.
00401  *
00402  *  @param refNum:      IN:
00403  *  @param address: IN:
00404  *  @retval Err Error code.
00405  **/
00406   extern Err PhnLibSetServiceCentreAddress(UInt16 refNum, const PhnAddressHandle address)
00407                 PHN_LIB_TRAP(PhnLibTrapSetServiceCentreAddress);
00408
00409 /**
00410  *  @brief This function returns the number of the service center currently used
00411  *         for sending messages in a newly allocated address.
00412  *
00413  *  @param refNum:      IN:
00414  *  @param address: IN:
00415  *  @retval Error code.
00416  **/
00417   extern Err PhnLibGetServiceCentreAddress(UInt16 refNum, PhnAddressHandle* address)
00418                 PHN_LIB_TRAP(PhnLibTrapGetServiceCentreAddress);
00419
00420 /**
00421  *  @brief This function returns the length of the given text in characters or messages.
00422  *
00423  *  @param refNum:      IN:
00424  *  @param text:    IN:
00425  *  @param inMessages:  IN:
00426  *  @param substitution:    IN:
00427  *  @retval Int16
00428  **/
00429   extern Int16 PhnLibLength(UInt16 refNum, const char* text, Boolean inMessages, Boolean substitution)
00430                 PHN_LIB_TRAP(PhnLibTrapLength);
00431
00432 /**
00433  *  @brief
00434  *
00435  *  @param refNum:      IN:
00436  *  @param text:    IN:
00437  *  @param address: IN:
00438  *  @param info:    IN:
00439  *  @retval Err Error code.
00440  **/
00441   extern Err PhnLibGetLengthDetails(UInt16 refNum, const char* text, const char* address, PhnLibLengthInfoType* info)
00442         PHN_LIB_TRAP(PhnLibTrapGetLengthDetails);
00443
00444 /**
00445  *  @brief This function returns the substitution string for a given GSM character.
00446  *
00447  *  @param refNum:      IN:
00448  *  @param c:       IN:
00449  *  @retval const
00450  **/
00451   extern const char* PhnLibGetSubstitution(UInt16 refNum, char c)
00452                 PHN_LIB_TRAP(PhnLibTrapGetSubstitution);
00453
00454 /**
00455  *  @brief This function returns a new address list. The list is initially empty
00456  *         and must be disposed of by the caller using PhnLibDisposeAddressList()
00457  *         or MemHandleFree().
00458  *
00459  *  @param refNum:      IN:
00460  *  @retval PhnAddressList
00461  **/
00462   extern PhnAddressList PhnLibNewAddressList(UInt16 refNum)
00463                 PHN_LIB_TRAP(PhnLibTrapNewAddressList);
00464
00465 /**
00466  *  @brief This function disposes of the memory used by the given address list.
00467  *         It should be called after your done with PhnLibNewAddressList().
00468  *
00469  *  @param refNum:      IN:
00470  *  @param list:    IN:
00471  *  @retval Err Error code.
00472  **/
00473   extern Err PhnLibDisposeAddressList(UInt16 refNum, PhnAddressList list)
00474                 PHN_LIB_TRAP(PhnLibTrapDisposeAddressList);
00475
00476 /**
00477  *  @brief This function adds a copy of address to the end of list.
00478  *         The address is not disposed of.
00479  *
00480  *  @param refNum:      IN:
00481  *  @param list:    IN:
00482  *  @param address: IN:
00483  *  @retval Err Error code.
00484  **/
00485   extern Err PhnLibAddAddress(UInt16 refNum, PhnAddressList list, const PhnAddressHandle address)
00486                 PHN_LIB_TRAP(PhnLibTrapAddAddress);
00487
00488 /**
00489  *  @brief This function retrieves an item with the given index from list and
00490  *         returns it as a new block on the heap specified by address.
00491  *
00492  *  @param refNum:      IN:
00493  *  @param list:    IN:
00494  *  @param index:   IN:
00495  *  @param address: IN:
00496  *  @retval Err Error code.
00497  **/
00498   extern Err PhnLibGetNth(UInt16 refNum, const PhnAddressList list, Int16 index, PhnAddressHandle* address)
00499                 PHN_LIB_TRAP(PhnLibTrapGetNth);
00500
00501 /**
00502  *  @brief This function replaces the data of the item with the given index from
00503  *         list by the given address.
00504  *
00505  *  @param refNum:      IN:
00506  *  @param list:    IN:
00507  *  @param index:   IN:
00508  *  @param address: IN:
00509  *  @retval Err Error code.
00510  **/
00511   extern Err PhnLibSetNth(UInt16 refNum, PhnAddressList list, Int16 index, const PhnAddressHandle address)
00512                 PHN_LIB_TRAP(PhnLibTrapSetNth);
00513
00514 /**
00515  *  @brief This function returns the length of the given list. If list is 0,
00516  *         this function returns phnErrParam.
00517  *
00518  *  @param refNum:      IN:
00519  *  @param list:    IN:
00520  *  @param count:   IN:
00521  *  @retval Err Error code.
00522  **/
00523   extern Err PhnLibCount(UInt16 refNum, PhnAddressList list, UInt16* count)
00524                 PHN_LIB_TRAP(PhnLibTrapCount);
00525
00526 /**
00527  *  @brief
00528  *
00529  *  @param refNum:      IN:
00530  *  @param info:    IN:
00531  *  @retval Err Error code.
00532  **/
00533   extern Err    PhnLibGetSMSRingInfo (UInt16 refNum, PhnRingingInfoPtr info)
00534                 PHN_LIB_TRAP(PhnLibTrapGetSMSRingInfo);
00535
00536 /**
00537  *  @brief
00538  *
00539  *  @param refNum:      IN:
00540  *  @param info:    IN:
00541  *  @retval Err Error code.
00542  **/
00543   extern Err    PhnLibSetSMSRingInfo (UInt16 refNum, PhnRingingInfoPtr info)
00544                     PHN_LIB_TRAP(PhnLibTrapSetSMSRingInfo);
00545
00546 /**
00547  *  @brief
00548  *
00549  *  @param refNum:      IN:
00550  *  @param smsGateway:  IN:
00551  *  @retval Err Error code.
00552  **/
00553   extern Err    PhnLibGetSMSGateway (UInt16 refNum, char** smsGateway)
00554                     PHN_LIB_TRAP(PhnLibTrapGetSMSGateway);
00555
00556 /**
00557  *  @brief
00558  *
00559  *  @param refNum:      IN:
00560  *  @param prefP:   IN:
00561  *  @retval Err Error code.
00562  **/
00563   extern Err      PhnLibGetSMSPreference (UInt16 refNum, PhnSMSPrefPtr prefP)
00564                   PHN_LIB_TRAP (PhnLibTrapGetSMSPreference);
00565
00566 /**
00567  *  @brief
00568  *
00569  *  @param refNum:      IN:
00570  *  @param prefP:   IN:
00571  *  @retval Err Error code.
00572  **/
00573   extern Err      PhnLibSetSMSPreference (UInt16 refNum, PhnSMSPrefPtr prefP)
00574                   PHN_LIB_TRAP (PhnLibTrapSetSMSPreference);
00575
00576
00577 /**
00578  *  @brief
00579  *
00580  *  @param refNum:      IN:
00581  *  @param list:    IN:
00582  *  @param index:   IN:
00583  *  @retval Err Error code.
00584  **/
00585   extern Err      PhnLibAPGetNth (UInt16 refNum, PhnAddressList list, Int16 index,
00586                                 PhnAddressHandle * address)
00587                   PHN_LIB_TRAP (PhnLibTrapAPGetNth);
00588
00589 /**
00590  *  @brief
00591  *
00592  *  @param refNum:      IN:
00593  *  @param transactionID:   IN:
00594  *  @param acK:     IN:
00595  *  @retval Err Error code.
00596  **/
00597   extern Err      PhnLibSendSMSMTAck (UInt16 refNum, UInt8 transactionId,
00598                                       Boolean ack)
00599                   PHN_LIB_TRAP (PhnLibTrapSendSMSMTAck);
00600
00601 /**
00602  *  @brief
00603  *
00604  *  @param refNum:      IN:
00605  *  @retval Err Error code.
00606  **/
00607   extern Err      PhnLibQuerySMSMT (UInt16 refNum)
00608                   PHN_LIB_TRAP (PhnLibTrapQuerySMSMT);
00609
00610 /**
00611  *  @brief
00612  *
00613  *  @param refNum:      IN:
00614  *  @param number:  IN:
00615  *  @param msgID:   IN:
00616  *  @retval Err Error code.
00617  **/
00618   extern Err PhnLibSetSMSCallbackNumber (UInt16 refNum, const CharPtr number, PhnDatabaseID msgID)
00619                   PHN_LIB_TRAP (PhnLibTrapSetSMSCallbackNumber);
00620
00621 #endif
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:53 2008 for Palm API Guide


Header Files » Incs » common » libraries » telephony

HsPhoneSMSTypes.h

Go to the documentation of this file.
00001 /******************************************************************************
00002  * Copyright (c) 2004 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  *****************************************************************************/
00005 /** @ingroup Telephony
00006  *
00007  */
00008
00009
00010 /**
00011  *
00012  * @file    HsPhoneSMSTypes.h
00013  *
00014  * @brief  Header File for Phone Library API ---- NETWORK CATEGORY
00015  *
00016  * NOTES:
00017  *  All implementations of the Handspring Phone Library support a common API.
00018  *  This API is broken up into various categories for easier management.  This file
00019  *  defines the SMS category.  These API calls are used to interact with the wireless network.
00020  */
00021
00022
00023
00024 #ifndef _HS_PHONE_SMS_TYPES_H__
00025 #define _HS_PHONE_SMS_TYPES_H__
00026 #include <PalmOS.h>
00027 #include <PalmTypes.h>
00028 #ifndef __CORE_COMPATIBILITY_H__
00029 #include <PalmCompatibility.h>
00030     /** workaround for differing header files in sdk-3.5 and sdk-internal */
00031     #ifndef __CORE_COMPATIBILITY_H__
00032     #define __CORE_COMPATIBILITY_H__
00033     #endif
00034 #endif
00035
00036 #if defined (_MSC_VER)  /**< Win 32 compiler */
00037 #pragma pack ( push, 2 )
00038 #endif
00039
00040
00041 /**
00042  * Palm OS address book functions
00043  **/
00044 enum AddressAppRecordFieldEnum {
00045     kName,          /**<        */
00046     kFirstName,         /**<        */
00047     kCompany,       /**<        */
00048     kPhone1,        /**<        */
00049     kPhone2,        /**<        */
00050     kPhone3,        /**<        */
00051     kPhone4,        /**<        */
00052     kPhone5,        /**<        */
00053     kAddress,       /**<        */
00054     kCity,          /**<        */
00055     kState,         /**<        */
00056     kZipCode,       /**<        */
00057     kCountry,       /**<        */
00058     kTitle,         /**<        */
00059     kCustom1,       /**<        */
00060     kCustom2,       /**<        */
00061     kCustom3,       /**<        */
00062     kCustom4,       /**<        */
00063     kNote,          /**<        */
00064     kRecordFieldEnumCount /**< must be the last field */
00065 };
00066
00067 #ifndef __cplusplus
00068 typedef enum AddressAppRecordFieldEnum AddressAppRecordFieldEnum;
00069 #endif
00070
00071
00072 #define isValidAddressAppRecordFieldEnum(x) ((x >= kName) && (x < kRecordFieldEnumCount))   /**<        */
00073
00074 /**
00075  *  Item description here
00076  **/
00077 typedef enum  {
00078     addrWorkLabel,      /**<        */
00079     addrHomeLabel,      /**<        */
00080     addrFaxLabel,       /**<        */
00081     addrOtherLabel,     /**<        */
00082     addrEmailLabel,     /**<        */
00083     addrMainLabel,      /**<        */
00084     addrPagerLabel,     /**<        */
00085     addrMobileLabel,    /**<        */
00086     addrNoLabel     /**<        */
00087 }AddressAppPhoneLabel;
00088
00089 typedef UInt8 AddressAppPhoneLabelType;     /**<        */
00090
00091 /**
00092  * This should probably be private to the library
00093  **/
00094 struct Address {
00095   // All fields should be considered read-only.
00096   AddressAppPhoneLabelType kind;    /**<        */
00097   char filler;              /**<        */
00098   UInt32 uniqueID;          /**<        */
00099   UInt16 phoneBookIndex;        /**<        */
00100   UInt16 count[3];          /**<        */
00101   // immediately followed by address data
00102 };
00103
00104
00105 /**
00106  * Item description here
00107  **/
00108 struct AddrDescriptor {
00109   UInt16 count;     /**< Length of list */
00110     // immediately followed by count pairs of (UInt16,Address)
00111 };
00112
00113 #ifndef _cplusplus
00114 typedef struct Address Address;             /**<        */
00115 typedef struct AddrDescriptor AddrDescriptor;       /**<        */
00116 #endif
00117
00118
00119 /**
00120  * Item description here
00121  **/
00122 struct AddressType {
00123   UInt16 addressSize;       /**<        */
00124   Address address;      /**<        */
00125 };
00126
00127 #ifndef _cplusplus
00128 typedef struct AddressType AddressType;     /**<        */
00129 #endif
00130
00131 /**
00132  *  Item description here
00133  **/
00134 struct AddressAppRecordHeader {
00135     UInt32 options;     /**<        */
00136     UInt32 flags;       /**<        */
00137     UInt8 companyOffset;    /**<        */
00138     char data;      /**<        */
00139 };
00140
00141 #ifndef _cplusplus
00142 typedef struct AddressAppRecordHeader AddressAppRecordHeader;   /**<        */
00143 #endif
00144
00145 /**
00146  *  Item description here
00147  **/
00148 struct AddressAppRecord {
00149 // private:
00150     // Fields within an address.
00151
00152     // Header of an address. This is immediately followed by the address
00153     // data. The first database is part of the following structure.
00154     // (See AddressDB.h for a detailled explanation of the structure.)
00155
00156     MemHandle mData;    /**<        */
00157     UInt32 mID;     /**<        */
00158     Boolean mLocked;    /**<        */
00159     Int8  reserved1;    /**< padding */
00160     AddressAppRecordHeader* mHeader;    /**<        */
00161 };
00162
00163 /**
00164  *  NBS defines
00165  **/
00166
00167 /**
00168  *  @name Identifier elements definitions
00169  **/
00170 /*@{*/
00171 #define NBSHeaderID            0x00  /**< NBS fragment header information identifier */
00172 #define NBSHeaderIDLen         0x03  /**< three bytes */
00173
00174 #define Addressing8bitID       0x04  /**< 8-bit address information identifier */
00175 #define Addressing8bitIDLen    0x02  /**< 2 bytes... src port(1), dest port(1) */
00176
00177 #define Addressing16bitID      0x05  /**< 16-bit address information identifier */
00178 #define Addressing16bitIDLen   0x04  /**< 4 bytes... src port(2), dest port(2) */
00179 /*@}*/
00180
00181
00182 /**
00183  *  @name Text Header elements
00184  **/
00185 /*@{*/
00186 #define NBSHeaderEscapeSeq     "//"      /**< start sequence of the header */
00187 #define NBSTextHeader          "//SCK"   /**< beginning of an NBS text header */
00188 #define NBSTextHeaderLength    5         /**< length of the header */
00189 /*@}*/
00190
00191
00192 /**
00193  *  @name 8bit addressing text header lengths, not including the //SCK
00194  **/
00195 /*@{*/
00196 #define Full8bitTextHeader     0x0A  /**< length for full header with 8-bit addressing    //SCKddoorrttnn */
00197 #define Minimum8bitTextHeader  0x02  /**< length for minimum header with 8-bit addressing //SCKdd */
00198 /*@}*/
00199
00200
00201 /**
00202  *  @name 16bit addressing text header lengths, not including the //SCKL
00203  **/
00204 /*@{*/
00205 #define Full16bitTextHeader    0x0F  /**< length for full header with 16-bit addressing    //SCKLddddoooorrttnn */
00206 #define Minimum16bitTextHeader 0x05  /**< length for minimum header with 16-bit addressing //SCKLdddd */
00207 /*@}*/
00208
00209 #define TextHeaderTerminator   ' '   /**< text based headers terminate at the next space */
00210
00211 #define phnNBSEvent         'Hnbs'
00212
00213
00214 /**
00215  *  @name NBS Port Numbers (Nokia Smart Messaging Spec)
00216  **/
00217 /*@{*/
00218 #define NBSPort_MimeVCard     0xE2  /**<        */
00219 #define NBSPort_MimeVCalendar 0xE4  /**<        */
00220 /*@}*/
00221
00222 /**
00223  *  SMS stuff
00224  **/
00225 typedef enum {
00226   kMTIncoming, kMTOutgoing      /**<        */
00227 } SMSMessageType;
00228
00229 #define isValidSMSMessageType(m) ((m >= kMTIncoming) && (m <= kMTOutgoing))     /**<        */
00230
00231 /**
00232  *  Item description here
00233  **/
00234 typedef enum  {
00235   kNone,            /**<        */
00236   kReceiving, kReceived,    /**<        */
00237   kPending, kSending, kSent /**<        */
00238 }SMSMessageStatus;
00239
00240 #define isValidSMSMessageStatus(m) ((m >= kNone) && (m <= kSent))       /**<        */
00241
00242 /**
00243  * CDMA SMS Preference ?
00244  **/
00245 typedef struct
00246   {
00247     Boolean         audioAlertEnable;   /**<        */
00248     Boolean         confirmDeletion;    /**<        */
00249   }
00250 PhnSMSPrefType ,* PhnSMSPrefPtr;
00251
00252
00253
00254 /**
00255  *
00256  **/
00257 typedef enum  {
00258   kGreekSymbols = 1L << 0,      /**<        */
00259   kMissingPart =    1L << 1,    /**<        */
00260   kAutoDelete = 1L << 2,        /**<        */
00261   kNotification = 1L << 3,      /**<        */
00262   kDontEncode = 1L << 4,        /**<        */
00263   kSubstitution = 1L << 5,      /**<        */
00264   kFailed =     1L << 6,    /**<        */
00265   kStatusReport = 1L << 7,      /**<        */
00266   kFreeReply =  1L << 8,        /**<        */
00267   kInternetEMail =1L << 9,      /**<        */
00268   kTextSegments =   1L << 10,   /**<        */
00269   kSMSErrorType1 = 1L << 11,        /**<        */
00270   kSMSErrorType2 = 1L << 12,        /**<        */
00271   kSMSErrorType3 = 1L << 13,        /**<        */
00272   kSMSHighPriority = 1L << 14,      /**<        */
00273   kSMSLowPriority = 1L << 15,       /**<        */
00274         // application-level flags
00275   kRead = 1L << 16,         /**<        */
00276   kDeferredDelivery = 1L << 17,     /**<        */
00277   kWAPMsg = 1L << 18            /**<        */
00278 }SMSMessageFlags;
00279
00280 /**
00281  *
00282  **/
00283 typedef enum  {
00284   smsFmtIgnoreKind = 0,     /**<        */
00285   smsFmtMatchKind = 8,      /**<        */
00286   smsFmtExceptKind = 16,    /**<        */
00287   smsFmtAllKinds = 24,      /**<        */
00288   smsFmtLastNameFirst = 32, /**<        */
00289   smsFmtShortLabel = 64     /**<        */
00290 }SMSAddressFormat;
00291
00292 /**
00293  *
00294  **/
00295 typedef struct  {
00296   Boolean freeReply;        /**<        */
00297   Boolean statusReport;     /**<        */
00298   unsigned char validity;   /**<        */
00299 }SMSSendOptions;
00300
00301 /**
00302  *
00303  **/
00304 typedef struct  {
00305   UInt32 owner;         /**< application owning this message */
00306   SMSMessageType type;      /**< message type */
00307   SMSMessageStatus status;  /**< message status */
00308   UInt32 date;          /**< date of sending or receipt */
00309   UInt32 flags;         /**< miscellaneous flags */
00310   UInt8 validity;       /**< validity period */
00311   UInt8 segments;       /**< number of segments (incoming message) */
00312                 /**< Size of field Addresses. If there is segmentation information for */
00313                 /**< a message this field contains also the sizes of the parts. The array */
00314                 /**< is therefore a variable-size array. */
00315   UInt16 size[1];       /**<        */
00316 }SmsHeader;
00317
00318
00319 /**
00320  *  Structure passed to the callbacks registered for incoming NBS notifications
00321  **/
00322 struct NBSNotificationEventType
00323 {
00324     UInt16 version;     /**< version number to provide future backwards compatibility */
00325
00326     /** helper fields */
00327     Boolean NBSdatagram;    /**< flag if it is an NBS datagram */
00328     Boolean binary;         /**< true if binary data */
00329
00330     void *headerP;      /**< pointer to raw header */
00331     UInt8 headerLen;    /**< length of headerP */
00332     Int8  reserved0;    /**< padding */
00333     void *dataP;        /**< pointer to data body */
00334     UInt8 dataLen;      /**< length of dataP */
00335
00336     /** NBS datagram fields */
00337     UInt8 refNum;       /**< NBS reference number */
00338     UInt8 maxNum;       /**< max segment number 1-255 */
00339     UInt8 seqNum;       /**< sequence number    1-255, no more than maxNum */
00340     Int8  reserved1;    /**< padding */
00341     Int8  reserved1a;   /**< mo padding */
00342
00343     UInt32 srcPort;     /**< source port */
00344     UInt32 dstPort;     /**< destination port */
00345
00346     /** SMS related fields */
00347     UInt32 msgID;       /**< ID into the SMS database to reference this */
00348                         /**< message this ID is not gauranteed to be */
00349                         /**< valid once the notification callback */
00350                         /**< returns.  Users should make a copy of the */
00351                         /**< msg if they want to work on it after the */
00352                         /**< callback returns. */
00353
00354
00355     char   *senderP;    /**< sender number - null terminated */
00356     UInt32 datetime;    /**< date/time stamp */
00357     Int32  reserved2;   /**< reserved*/
00358     Int32  reserved3;   /**< reserved*/
00359 };
00360
00361 #ifndef _cplusplus
00362 typedef struct NBSNotificationEventType NBSNotificationEventType;       /**<        */
00363 #endif
00364
00365 /**
00366  * NBS
00367  **/
00368 enum { kParseError = -1, kDoneParsing=0, kParseInformationID, kParseInformationLength, kParseInformationData };
00369
00370 /**
00371  *  SMS length information
00372  *
00373  *  @note For CDMA, this can be used to retrieve the SMS/EMS limits.
00374  *        length = max segment length.  size = max EMS length
00375  **/
00376 typedef struct
00377   {                          //        IN                                              OUT
00378   UInt16   size;             /**< unused */
00379   Boolean  substitution;     /**< Substitute characters if needed (GSM ONLY)                           */
00380   UInt16   length;           /**<                                              total length of message */
00381   UInt16   segmentCount;     /**<                                              number of segments used */
00382   Boolean  requestSmsInfo;   /**< unused */
00383 }
00384 PhnLibLengthInfoType;
00385
00386 /**
00387  *  SMS error codes obtained from the network in CDMA
00388  *  The first half of the enums are from IS-41D SMS cause codes
00389      with the exact binary values as in IS-41D. They are in the range
00390      of 0x00 to 0xFF. This does not have the cause codes from the range 0x80000
00391      upwards as the radio doesnt support them
00392  **/
00393 typedef enum  {
00394   /* A. Network Problems:
00395   */
00396   SmsCauseAddressVacant                     = 0,
00397   SmsCauseAddressTranslationFailure,
00398   SmsCauseNetworkResourceShortage,
00399   SmsCauseNetworkFailure,
00400   SmsCauseInvalidTeleserviceId,
00401   SmsCauseOtherNetworkProblem,
00402   SmsCauseOtherNetworkProblemMoreFirst   = 6,
00403   /* all values within this range are treated as
00404      OtherNetworkProblem
00405   */
00406   SmsCauseOtherNetworkProblemMoreLast    = 31,
00407
00408   /* B. Terminal Problems:
00409   */
00410   SmsCauseNoPageResponse                   = 32,
00411   SmsCauseDestinationBusy,
00412   SmsCauseNoAck,
00413   SmsCauseDestinationResourceShortage,
00414   SmsCauseSmsDeliveryPostponed,
00415   SmsCauseDestinationOutOfService,
00416   SmsCauseDestinationNoLongerAtThisAddress,
00417   SmsCauseOtherTerminalProblem,
00418   smsCauseOtherTerminalProblemMoreFirst  = 40,
00419   /* all values within this range are treated as
00420      OtherTerminalProblem
00421   */
00422   SmsCauseOtherTerminalProblemMoreLast   = 47,
00423   SmsCauseSmsDeliveryPostponedMoreFirst  = 48,
00424   SmsCauseSmsDeliveryPostponedMoreLast   = 63,
00425
00426   /* C. Radio Interface Problems:
00427   */
00428   SmsCauseRadioIfResourceShortage         = 64,
00429   SmsCauseRadioIfIncompatible,
00430   SmsCauseOtherRadioIfProblem,
00431   SmsCauseOtherRadioIfProblemMoreFirst  = 67,
00432   /* all values within this range are treated as
00433      OtherRadioIfProblem
00434   */
00435   SmsCauseOtherRadioIfProblemMoreLast   = 95,
00436
00437   /* D. General Problems:
00438   */
00439   SmsCauseUnexpected_Parm_Size               = 96,
00440   SmsCauseSmsOriginationDenied,
00441   SmsCauseSmsTerminationDenied,
00442   SmsCauseSupplServiceNotSupported,
00443   SmsCauseSmsNotSupported,
00444   SmsCauseReserved101,
00445   SmsCauseMissingExpectedParm,
00446   SmsCauseMissingMandatoryParm,
00447   SmsCauseUnrecognizedParmValue,
00448   SmsCauseUnexpectedParmValue,
00449   SmsCauseUserDataSizeError,
00450   SmsCauseOtherGeneralProblems,
00451   SmsCauseOtherGeneralProblemsMoreFirst  = 108,
00452   /* all values within this range are treated as
00453      OtherGeneralProblems
00454   */
00455   SmsCauseOtherGeneralProblemsMoreLast   = 255
00456 }_SmsCauseCode;
00457
00458 typedef UInt32 SmsCauseCode;
00459
00460 /**
00461  *  SMS error codes types
00462  **/
00463
00464 typedef enum
00465 {
00466   SmsErrorNone,
00467   SmsErrorReserved,
00468   SmsErrorTemporary,
00469   SmsErrorPermanent
00470 }_SmsErrorCode;
00471
00472 typedef UInt8 SmsErrorCode;
00473
00474 /**
00475  * MMS info structure.
00476  */
00477 #define kMMSStringMaxLen                       128 /**< URL, MML, and user agent */
00478 #define kMMSPixPlaceMaxLen                      20  /**< pix place address */
00479 #define PhnLibMMSServerInfoSettingsMajorVersion 0x0001
00480 #define PhnLibMMSServerInfoSettingsMinorVersion 0x0000
00481 #define PhnLibMMSServerInfoVersion              (((UInt32)PhnLibMMSServerInfoSettingsMajorVersion << 16) | PhnLibMMSServerInfoSettingsMinorVersion)
00482 typedef struct _PhnLibMMSServerInfo
00483 {
00484   UInt32  version;                                  /**< must be set to PhnLibMMSServerInfoVersion */
00485   UInt32  max_message_size;                         /**< max message size kB */
00486   UInt8   mms_server_name[kMMSStringMaxLen+1];      /**< MMS server [NULL terminated string] */
00487   UInt8   mml_server_name[kMMSStringMaxLen+1];      /**< MML server [NULL terminated string] */
00488   UInt8   pix_place_server[kMMSPixPlaceMaxLen+1];   /**< MMS Pix place address [NULL terminated string] */
00489   UInt8   user_agent[kMMSStringMaxLen+1];           /**< user agent string [NULL terminated string] */
00490   UInt8   maxRetries;                               /**< number of retry attempts */
00491   UInt8   timeout;                                  /**< MMSC timeout */
00492   Boolean deliveryAck;                              /**< delivery ack setting */
00493 }
00494 PhnLibMMSServerInfoType;
00495
00496
00497 #if defined (_MSC_VER)
00498 #pragma pack ( pop )
00499 #endif
00500
00501
00502 #endif // _HS_PHONE_SMS_TYPES_H__
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:53 2008 for Palm API Guide


Header Files » Incs » common » libraries » telephony

HsPhoneTrace.h

Go to the documentation of this file.
00001 /******************************************************************************
00002  * Copyright (c) 2004 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  *****************************************************************************/
00005 /** @ingroup Telephony
00006  *
00007  */
00008
00009
00010 /**
00011  *
00012  * @file    HsPhoneTrace.h
00013  *
00014  * @brief  Trace constants, types, and definitions for Phone Library.
00015  *
00016  */
00017
00018
00019
00020
00021 #ifndef HS_PHONE_TRACE_H
00022 #define HS_PHONE_TRACE_H
00023
00024
00025 /**
00026  *  @name Trace Subcomponent IDs.  These are used in TraceContext to identify area of Phone Library providing
00027  *        a particular trace/error entry.  These are helpful to allow useful filtering of trace log data.
00028  *
00029  **/
00030 /*@{*/
00031 #define PHN_SUBCOMPONENTID_LIB  'LIB!'      /**< general Phone Library (library activation/shutdown, API, etc) */
00032 #define PHN_SUBCOMPONENTID_SMS  'SMS!'      /**< SMS Messaging */
00033 #define PHN_SUBCOMPONENTID_NOT  'NOT!'      /**< Phone Notification Mgr */
00034 #define PHN_SUBCOMPONENTID_RDO  'RDO!'      /**< Radio operation  */
00035 #define PHN_SUBCOMPONENTID_READ 'READ'      /**< low level communication with radio - read */
00036 #define PHN_SUBCOMPONENTID_WRIT 'WRIT'          /**< low level communication with radio - write  */
00037 #define PHN_SUBCOMPONENTID_SIM  'SIM!'      /**< sim operation */
00038 #define PHN_SUBCOMPONENTID_STK  'STK!'          /**< sim toolkit */
00039 /*@}*/
00040
00041 #endif
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:53 2008 for Palm API Guide


Header Files » Incs » common » libraries » telephony

HsPhoneTraps.h

Go to the documentation of this file.
00001 /******************************************************************************
00002  * Copyright (c) 2004 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  *****************************************************************************/
00005 /** @ingroup Telephony
00006  *
00007  */
00008
00009
00010 /**
00011  *
00012  * @file    HsPhoneTraps.h
00013  *
00014  * @brief  Traps of all functions exported by the Phone Library
00015  *
00016  * NOTES:
00017  */
00018
00019
00020
00021 #ifndef HS_PHONE_TRAPS_H
00022 #define HS_PHONE_TRAPS_H
00023
00024 #if (CPU_TYPE == CPU_68K)
00025 #define PHN_LIB_TRAP(trapNum) SYS_TRAP(trapNum)
00026 #endif
00027
00028
00029 #define     PhnLibTrapGetLibAPIVersion                  (0+sysLibTrapCustom)       /**< 0xA805           */
00030 #define     PhnLibTrapUninstall                         (1+sysLibTrapCustom)       /**< 0xA806           */
00031 #define     PhnLibTrapRegister                          (2+sysLibTrapCustom)       /**< 0xA807           */
00032 #define     PhnLibTrapFirstAppForService                (3+sysLibTrapCustom)       /**< 0xA808  GSM Only */
00033 #define     PhnLibTrapNewAddress                        (4+sysLibTrapCustom)       /**< 0xA809           */
00034 #define     PhnLibTrapGetField                          (5+sysLibTrapCustom)       /**< 0xA80A           */
00035 #define     PhnLibTrapGetID                             (6+sysLibTrapCustom)       /**< 0xA80B           */
00036 #define     PhnLibTrapSetField                          (7+sysLibTrapCustom)       /**< 0xA80C           */
00037 #define     PhnLibTrapSetNumber                         (8+sysLibTrapCustom)       /**< 0xA80D           */
00038 #define     PhnLibTrapSetID                             (9+sysLibTrapCustom)       /**< 0xA80E           */
00039 #define     PhnLibTrapAddressToText                     (10+sysLibTrapCustom)      /**< 0xA80F           */
00040 #define     PhnLibTrapHasName                           (11+sysLibTrapCustom)      /**< 0xA810           */
00041 #define     PhnLibTrapEqual                             (12+sysLibTrapCustom)      /**< 0xA811           */
00042 #define     PhnLibTrapDial                              (13+sysLibTrapCustom)      /**< 0xA812           */
00043 #define     PhnLibTrapSendDTMF                          (14+sysLibTrapCustom)      /**< 0xA813           */
00044 #define     PhnLibTrapDisconnect                        (15+sysLibTrapCustom)      /**< 0xA814           */
00045 #define     PhnLibTrapActivate                          (16+sysLibTrapCustom)      /**< 0xA815           */
00046 #define     PhnLibTrapConference                        (17+sysLibTrapCustom)      /**< 0xA816           */
00047 #define     PhnLibTrapHold                              (18+sysLibTrapCustom)      /**< 0xA817           */
00048 #define     PhnLibTrapGetConnectionInfo                 (19+sysLibTrapCustom)      /**< 0xA818           */
00049 #define     PhnLibTrapSetBarring                        (20+sysLibTrapCustom)      /**< 0xA819  GSM Only */
00050 #define     PhnLibTrapGetBarring                        (21+sysLibTrapCustom)      /**< 0xA81A  GSM Only */
00051 #define     PhnLibTrapSetForwarding                     (22+sysLibTrapCustom)      /**< 0xA81B           */
00052 #define     PhnLibTrapGetForwarding                     (23+sysLibTrapCustom)      /**< 0xA81C           */
00053 #define     PhnLibTrapSetCallWaiting                    (24+sysLibTrapCustom)      /**< 0xA81D           */
00054 #define     PhnLibTrapGetCallWaiting                    (25+sysLibTrapCustom)      /**< 0xA81E           */
00055 #define     PhnLibTrapSetPhoneLock                      (26+sysLibTrapCustom)      /**< 0xA81F           */
00056 #define     PhnLibTrapGetPhoneLock                      (27+sysLibTrapCustom)      /**< 0xA820           */
00057 #define     PhnLibTrapSetCLIP                           (28+sysLibTrapCustom)      /**< 0xA821  GSM Only */
00058 #define     PhnLibTrapGetCLIP                           (29+sysLibTrapCustom)      /**< 0xA822  GSM Only */
00059 #define     PhnLibTrapSetOperatorLock                   (30+sysLibTrapCustom)      /**< 0xA823           */
00060 #define     PhnLibTrapGetOperatorLock                   (31+sysLibTrapCustom)      /**< 0xA824  GSM Only */
00061 #define     PhnLibTrapChangePassword                    (32+sysLibTrapCustom)      /**< 0xA825           */
00062 #define     PhnLibTrapPasswordDialog                    (33+sysLibTrapCustom)      /**< 0xA826  GSM Only */
00063 #define     PhnLibTrapCurrentOperator                   (34+sysLibTrapCustom)      /**< 0xA827           */
00064 #define     PhnLibTrapCurrentProvider                   (35+sysLibTrapCustom)      /**< 0xA828  GSM Only */
00065 #define     PhnLibTrapGetOperatorList                   (36+sysLibTrapCustom)      /**< 0xA829           */
00066 #define     PhnLibTrapSetOperator                       (37+sysLibTrapCustom)      /**< 0xA82A           */
00067 #define     PhnLibTrapGetOwnNumbers                     (38+sysLibTrapCustom)      /**< 0xA82B           */
00068 #define     PhnLibTrapSetOwnNumbers                     (39+sysLibTrapCustom)      /**< 0xA82C  GSM Only */
00069 #define     PhnLibTrapGetRingingInfo                    (40+sysLibTrapCustom)      /**< 0xA82D           */
00070 #define     PhnLibTrapSetRingingInfo                    (41+sysLibTrapCustom)      /**< 0xA82E           */
00071 #define     PhnLibTrapGetToneIDs                        (42+sysLibTrapCustom)      /**< 0xA82F           */
00072 #define     PhnLibTrapGetToneName                       (43+sysLibTrapCustom)      /**< 0xA830           */
00073 #define     PhnLibTrapPlayTone                          (44+sysLibTrapCustom)      /**< 0xA831           */
00074 #define     PhnLibTrapStopTone                          (45+sysLibTrapCustom)      /**< 0xA832           */
00075 #define     PhnLibTrapFindEntry                         (46+sysLibTrapCustom)      /**< 0xA833  GSM Only */
00076 #define     PhnLibTrapSelectAddress                     (47+sysLibTrapCustom)      /**< 0xA834  GSM Only */
00077 #define     PhnLibTrapGetMicrophone                     (48+sysLibTrapCustom)      /**< 0xA835  GSM Only */
00078 #define     PhnLibTrapSetMicrophone                     (49+sysLibTrapCustom)      /**< 0xA836  GSM Only */
00079 #define     PhnLibTrapGetVolume                         (50+sysLibTrapCustom)      /**< 0xA837           */
00080 #define     PhnLibTrapSetVolume                         (51+sysLibTrapCustom)      /**< 0xA838           */
00081 #define     PhnLibTrapRegistered                        (52+sysLibTrapCustom)      /**< 0xA839           */
00082 #define     PhnLibTrapRoaming                           (53+sysLibTrapCustom)      /**< 0xA83A           */
00083 #define     PhnLibTrapSignalQuality                     (54+sysLibTrapCustom)      /**< 0xA83B           */
00084 #define     PhnLibTrapErrorRate                         (55+sysLibTrapCustom)      /**< 0xA83C  GSM Only */
00085 #define     PhnLibTrapBattery                           (56+sysLibTrapCustom)      /**< 0xA83D           */
00086 #define     PhnLibTrapCardInfo                          (57+sysLibTrapCustom)      /**< 0xA83E           */
00087 #define     PhnLibTrapSIMInfo                           (58+sysLibTrapCustom)      /**< 0xA83F           */
00088 #define     PhnLibTrapGetSIMStatus                      (59+sysLibTrapCustom)      /**< 0xA840  GSM Only */
00089 #define     PhnLibTrapParamText                         (60+sysLibTrapCustom)      /**< 0xA841  GSM Only */
00090 #define     PhnLibTrapGetErrorText                      (61+sysLibTrapCustom)      /**< 0xA842           */
00091 #define     PhnLibTrapGetDBRef                          (62+sysLibTrapCustom)      /**< 0xA843           */
00092 #define     PhnLibTrapReleaseDBRef                      (63+sysLibTrapCustom)      /**< 0xA844           */
00093 #define     PhnLibTrapNewMessage                        (64+sysLibTrapCustom)      /**< 0xA845           */
00094 #define     PhnLibTrapDeleteMessage                     (65+sysLibTrapCustom)      /**< 0xA846           */
00095 #define     PhnLibTrapSendMessage                       (66+sysLibTrapCustom)      /**< 0xA847           */
00096 #define     PhnLibTrapSetText                           (67+sysLibTrapCustom)      /**< 0xA848           */
00097 #define     PhnLibTrapSetDate                           (68+sysLibTrapCustom)      /**< 0xA849           */
00098 #define     PhnLibTrapSetOptions                        (69+sysLibTrapCustom)      /**< 0xA84A           */
00099 #define     PhnLibTrapSetAddresses                      (70+sysLibTrapCustom)      /**< 0xA84B           */
00100 #define     PhnLibTrapSetStatus                         (71+sysLibTrapCustom)      /**< 0xA84C           */
00101 #define     PhnLibTrapSetFlags                          (72+sysLibTrapCustom)      /**< 0xA84D           */
00102 #define     PhnLibTrapSetOwner                          (73+sysLibTrapCustom)      /**< 0xA84E           */
00103 #define     PhnLibTrapGetText                           (74+sysLibTrapCustom)      /**< 0xA84F           */
00104 #define     PhnLibTrapGetDate                           (75+sysLibTrapCustom)      /**< 0xA850           */
00105 #define     PhnLibTrapGetOptions                        (76+sysLibTrapCustom)      /**< 0xA851           */
00106 #define     PhnLibTrapGetAddresses                      (77+sysLibTrapCustom)      /**< 0xA852           */
00107 #define     PhnLibTrapGetStatus                         (78+sysLibTrapCustom)      /**< 0xA853           */
00108 #define     PhnLibTrapGetFlags                          (79+sysLibTrapCustom)      /**< 0xA854           */
00109 #define     PhnLibTrapGetOwner                          (80+sysLibTrapCustom)      /**< 0xA855           */
00110 #define     PhnLibTrapGetType                           (81+sysLibTrapCustom)      /**< 0xA856           */
00111 #define     PhnLibTrapIsLegalCharacter                  (82+sysLibTrapCustom)      /**< 0xA857           */
00112 #define     PhnLibTrapMapCharacter                      (83+sysLibTrapCustom)      /**< 0xA858           */
00113 #define     PhnLibTrapSetServiceCentreAddress           (84+sysLibTrapCustom)      /**< 0xA859           */
00114 #define     PhnLibTrapGetServiceCentreAddress           (85+sysLibTrapCustom)      /**< 0xA85A           */
00115 #define     PhnLibTrapLength                            (86+sysLibTrapCustom)      /**< 0xA85B           */
00116 #define     PhnLibTrapGetSubstitution                   (87+sysLibTrapCustom)      /**< 0xA85C           */
00117 #define     PhnLibTrapNewAddressList                    (88+sysLibTrapCustom)      /**< 0xA85D           */
00118 #define     PhnLibTrapDisposeAddressList                (89+sysLibTrapCustom)      /**< 0xA85E           */
00119 #define     PhnLibTrapAddAddress                        (90+sysLibTrapCustom)      /**< 0xA85F           */
00120 #define     PhnLibTrapGetNth                            (91+sysLibTrapCustom)      /**< 0xA860           */
00121 #define     PhnLibTrapSetNth                            (92+sysLibTrapCustom)      /**< 0xA861           */
00122 #define     PhnLibTrapCount                             (93+sysLibTrapCustom)      /**< 0xA862           */
00123 #define     PhnLibTrapSetModulePower                    (94+sysLibTrapCustom)      /**< 0xA863           */
00124 #define     PhnLibTrapModulePowered                     (95+sysLibTrapCustom)      /**< 0xA864           */
00125 #define     PhnLibTrapModuleButtonDown                  (96+sysLibTrapCustom)      /**< 0xA865           */
00126 #define     PhnLibTrapBoxInformation                    (97+sysLibTrapCustom)      /**< 0xA866           */
00127 #define     PhnLibTrapGetBoxNumber                      (98+sysLibTrapCustom)      /**< 0xA867           */
00128 #define     PhnLibTrapGetDataApplication                (99+sysLibTrapCustom)      /**< 0xA868    GSM Only */
00129 #define     PhnLibTrapSetDataApplication                (100+sysLibTrapCustom)     /**< 0xA869    GSM Only */
00130 #define     PhnLibTrapDebug                             (101+sysLibTrapCustom)     /**< 0xA86A    GSM Only */
00131 #define     PhnLibTrapGetPhoneBook                      (102+sysLibTrapCustom)     /**< 0xA86B    GSM Only */
00132 #define     PhnLibTrapSetPhoneBook                      (103+sysLibTrapCustom)     /**< 0xA86C    GSM Only */
00133 #define     PhnLibTrapSetPhoneBookEntry                 (104+sysLibTrapCustom)     /**< 0xA86D    GSM Only */
00134 #define     PhnLibTrapGetPhoneBookIndex                 (105+sysLibTrapCustom)     /**< 0xA86E    GSM Only */
00135 #define     PhnLibTrapBatteryCharge                     (106+sysLibTrapCustom)     /**< 0xA86F    GSM Only */
00136 #define     PhnLibTrapGetEchoCancellation               (107+sysLibTrapCustom)     /**< 0xA870    GSM Only */
00137 #define     PhnLibTrapSetEchoCancellation               (108+sysLibTrapCustom)     /**< 0xA871    GSM Only */
00138 #define     PhnLibTrapGetEquipmentMode                  (109+sysLibTrapCustom)     /**< 0xA872           */
00139 #define     PhnLibTrapSetEquipmentMode                  (110+sysLibTrapCustom)     /**< 0xA873           */
00140 #define     PhnLibTrapGetSMSRingInfo                    (111+sysLibTrapCustom)     /**< 0xA874    GSM Only */
00141 #define     PhnLibTrapSetSMSRingInfo                    (112+sysLibTrapCustom)     /**< 0xA875    GSM Only */
00142 #define     PhnLibTrapPlayDTMF                          (113+sysLibTrapCustom)     /**< 0xA876           */
00143 #define     PhnLibTrapStartVibrate                      (114+sysLibTrapCustom)     /**< 0xA877           */
00144 #define     PhnLibTrapStopVibrate                       (115+sysLibTrapCustom)     /**< 0xA878           */
00145 #define     PhnLibTrapSendUSSD                          (116+sysLibTrapCustom)     /**< 0xA879    GSM Only */
00146 #define     PhnLibTrapSATGetMainMenu                    (117+sysLibTrapCustom)     /**< 0xA87A    GSM Only */
00147 #define     PhnLibTrapSATSendRequest                    (118+sysLibTrapCustom)     /**< 0xA87B    GSM Only */
00148 #define     PhnLibTrapSATEndSession                     (119+sysLibTrapCustom)     /**< 0xA87C    GSM Only */
00149 #define     PhnLibTrapHomeOperatorID                    (120+sysLibTrapCustom)     /**< 0xA87D    GSM Only */
00150 #define     PhnLibTrapCurrentOperatorID                 (121+sysLibTrapCustom)     /**< 0xA87E    GSM Only */
00151 #define     PhnLibTrapUsableSignalStrengthThreshold     (122+sysLibTrapCustom)     /**< 0xA87F    GSM Only */
00152 #define     PhnLibTrapConnectionAvailable               (123+sysLibTrapCustom)     /**< 0xA880    GSM Only */
00153 #define     PhnLibTrapGetPhoneCallStatus                (124+sysLibTrapCustom)     /**< 0xA881           */
00154 #define     PhnLibTrapSendSilentDTMF                    (125+sysLibTrapCustom)     /**< 0xA882           */
00155 #define     PhnLibTrapSetCLIR                           (126+sysLibTrapCustom)     /**< 0xA883    GSM Only */
00156 #define     PhnLibTrapGetCLIR                           (127+sysLibTrapCustom)     /**< 0xA884    GSM Only */
00157 #define     PhnLibTrapMute                              (128+sysLibTrapCustom)     /**< 0xA885           */
00158 #define     PhnLibTrapIsCallMuted                       (129+sysLibTrapCustom)     /**< 0xA886           */
00159 #define     PhnLibTrapGetSMSGateway                     (130+sysLibTrapCustom)     /**< 0xA887    GSM Only */
00160 #define     PhnLibTrapDeactivateBarring                 (131+sysLibTrapCustom)     /**< 0xA888    GSM Only */
00161 #define     PhnLibTrapGPRSAttached                      (132+sysLibTrapCustom)     /**< 0xA889    GSM Only */
00162 #define     PhnLibTrapGPRSPDPContextDefine              (133+sysLibTrapCustom)     /**< 0xA88A    GSM Only */
00163 #define     PhnLibTrapGPRSPDPContextListConstruct       (134+sysLibTrapCustom)     /**< 0xA88B    GSM Only */
00164 #define     PhnLibTrapGPRSPDPContextListDestruct        (135+sysLibTrapCustom)     /**< 0xA88C    GSM Only */
00165 #define     PhnLibTrapGetRemainingPasswordTries         (136+sysLibTrapCustom)     /**< 0xA88D    GSM Only */
00166 #define     PhnLibTrapGPRSQualityOfServiceGet           (137+sysLibTrapCustom)     /**< 0xA88E    GSM Only */
00167 #define     PhnLibTrapGPRSQualityOfServiceSet           (138+sysLibTrapCustom)     /**< 0xA88F    GSM Only */
00168 #define     PhnLibTrapSetBoxNumber                      (139+sysLibTrapCustom)     /**< 0xA890    GSM Only */
00169 #define     PhnLibTrapGetBinary                         (140+sysLibTrapCustom)     /**< 0xA891    GSM Only */
00170 #define     PhnLibTrapNetworkAvailable                  (141+sysLibTrapCustom)     /**< 0xA892    GSM Only */
00171 #define     PhnLibTrapSetFDNEntry                       (142+sysLibTrapCustom)     /**< 0xA893    GSM Only */
00172 #define     PhnLibTrapGetFDNList                        (143+sysLibTrapCustom)     /**< 0xA894    GSM Only */
00173 #define     PhnLibTrapDecodeMMI                         (144+sysLibTrapCustom)     /**< 0xA895    GSM Only */
00174 #define     PhnLibTrapExecuteMMI                        (145+sysLibTrapCustom)     /**< 0xA896    GSM Only */
00175 #define     PhnLibTrapSetActiveLine                     (146+sysLibTrapCustom)     /**< 0xA897    GSM Only */
00176 #define     PhnLibTrapSetBand                           (147+sysLibTrapCustom)     /**< 0xA898    GSM Only */
00177 #define     PhnLibTrapGetBand                           (148+sysLibTrapCustom)     /**< 0xA899    GSM Only */
00178 #define     PhnLibTrapGetCustomServiceProfile           (149+sysLibTrapCustom)     /**< 0xA89A    GSM Only */
00179 #define     PhnLibTrapIsEmergencyNumber                 (150+sysLibTrapCustom)     /**< 0xA89B    GSM Only */
00180 #define     PhnLibTrapAttrGet                           (151+sysLibTrapCustom)     /**< 0xA89C    GSM Only */
00181 #define     PhnLibTrapAttrSet                           (152+sysLibTrapCustom)     /**< 0xA89D    GSM Only */
00182 #define     PhnLibTrapGetSDNList                        (153+sysLibTrapCustom)     /**< 0xA89E    GSM Only */
00183 #define     PhnLibTrapSendLongDTMF                      (154+sysLibTrapCustom)     /**< 0xA89F    GSM Only */
00184 #define     PhnLibTrapGetICCID                          (155+sysLibTrapCustom)     /**< 0xA8A0    GSM Only */
00185 #define     PhnLibTrapGetSpn                            (156+sysLibTrapCustom)     /**< 0xA8A1    GSM Only */
00186 #define     PhnLibTrapGPRSAttachRequest                 (157+sysLibTrapCustom)     /**< 0xA8A2    GSM Only */
00187
00188 // Functions were reserved for GSM/GPRS  (these were reserved when Treo 300 shipped). Do
00189 // not need to be GSM/GPRS specific really now that we have one header file, so treat
00190 // them just as free traps for future functions
00191 #define     PhnLibTrapSetNoiseCancellation              (158+sysLibTrapCustom)    /**< 0xA8A3              */
00192 #define     PhnLibTrapGetNoiseCancellation              (159+sysLibTrapCustom)    /**< 0xA8A4              */
00193 #define     PhnLibTrapCRSM                              (160+sysLibTrapCustom)    /**< 0xA8A5              */
00194 #define     PhnLibTrapGetDedicatedDataMode              (161+sysLibTrapCustom)    /**< 0xA8A6              */
00195 #define     PhnLibTrapSetDedicatedDataMode              (162+sysLibTrapCustom)    /**< 0xA8A7              */
00196 #define     PhnLibTrapGetMVNOName                       (163+sysLibTrapCustom)    /**< 0xA8A8              */
00197 #define     PhnLibTrapGetGSMCellInfo                    (164+sysLibTrapCustom)    /**< 0xA8A9              */
00198 #define     GSMReserved8                                (165+sysLibTrapCustom)    /**< 0xA8AA              */
00199 #define     GSMReserved9                                (166+sysLibTrapCustom)    /**< 0xA8AB              */
00200 #define     GSMReserved10                               (167+sysLibTrapCustom)    /**< 0xA8AC              */
00201 #define     GSMReserved11                               (168+sysLibTrapCustom)    /**< 0xA8AD              */
00202 #define     GSMReserved12                               (169+sysLibTrapCustom)    /**< 0xA8AE              */
00203 #define     GSMReserved13                               (170+sysLibTrapCustom)    /**< 0xA8AF              */
00204 #define     GSMReserved14                               (171+sysLibTrapCustom)    /**< 0xA8B0              */
00205 #define     GSMReserved15                               (172+sysLibTrapCustom)    /**< 0xA8B1              */
00206 #define     GSMReserved16                               (173+sysLibTrapCustom)    /**< 0xA8B2              */
00207 #define     GSMReserved17                               (174+sysLibTrapCustom)    /**< 0xA8B3              */
00208 #define     GSMReserved18                               (175+sysLibTrapCustom)    /**< 0xA8B4              */
00209 #define     GSMReserved19                               (176+sysLibTrapCustom)    /**< 0xA8B5              */
00210 #define     GSMReserved20                               (177+sysLibTrapCustom)    /**< 0xA8B6              */
00211 #define     GSMReserved21                               (178+sysLibTrapCustom)    /**< 0xA8B7              */
00212 #define     GSMReserved22                               (179+sysLibTrapCustom)    /**< 0xA8B8              */
00213
00214
00215 #define     PhnLibTrapAPGetNth                          (180+sysLibTrapCustom)    /**< 0xA8B9    CDMA Only */
00216 #define     PhnLibTrapGetMSID                           (181+sysLibTrapCustom)    /**< 0xA8BA    CDMA Only */
00217 #define     PhnLibTrapGetPhnOprtMode                    (182+sysLibTrapCustom)    /**< 0xA8BB    CDMA Only */
00218 #define     PhnLibTrapSetPhnOprtMode                    (183+sysLibTrapCustom)    /**< 0xA8BC    CDMA Only */
00219 #define     PhnLibTrapSendSMSMTAck                      (184+sysLibTrapCustom)    /**< 0xA8BD    CDMA Only */
00220 #define     PhnLibTrapQuerySMSMT                        (185+sysLibTrapCustom)    /**< 0xA8BE    CDMA Only */
00221 #define     PhnLibTrapIsPhoneActivated                  (186+sysLibTrapCustom)    /**< 0xA8BF    CDMA Only */
00222 #define     PhnLibTrapUpdateMessageCount                (187+sysLibTrapCustom)    /**< 0xA8C0    CDMA Only */
00223 #define     PhnLibTrapGetSMSPreference                  (188+sysLibTrapCustom)    /**< 0xA8C1    CDMA Only */
00224 #define     PhnLibTrapSetSMSPreference                  (189+sysLibTrapCustom)    /**< 0xA8C2    CDMA Only */
00225 #define     PhnLibTrapGetSpMode                         (190+sysLibTrapCustom)    /**< 0xA8C3    CDMA Only */
00226 #define     PhnLibTrapLedAlert                          (191+sysLibTrapCustom)    /**< 0xA8C4    CDMA Only */
00227 #define     PhnLibTrapExit911Mode                       (192+sysLibTrapCustom)    /**< 0xA8C5    CDMA Only */
00228 #define     PhnLibTrapMiscDebugInfo                     (193+sysLibTrapCustom)    /**< 0xA8C6    CDMA Only */
00229 #define     PhnLibTrapGetHeadsetConnectedInfo           (194+sysLibTrapCustom)    /**< 0xA8C7    CDMA Only */
00230 #define     PhnLibTrapExitPowerSaveMode                 (195+sysLibTrapCustom)    /**< 0xA8C8    CDMA Only */
00231 #define     PhnLibTrapGetToneLength                     (196+sysLibTrapCustom)    /**< 0xA8C9    CDMA Only */
00232 #define     PhnLibTrapSetToneLength                     (197+sysLibTrapCustom)    /**< 0xA8CA    CDMA Only */
00233 #define     PhnLibTrapUnlockPhoneLock                   (198+sysLibTrapCustom)    /**< 0xA8CB    CDMA Only */
00234 #define     PhnLibTrapLoadCDMATime                      (199+sysLibTrapCustom)    /**< 0xA8CC    CDMA Only */
00235 #define     PhnLibTrapGetCallCountByService             (200+sysLibTrapCustom)    /**< 0xA8CD              */
00236 #define     PhnLibTrapGetDefaultDataApps                (201+sysLibTrapCustom)    /**< 0xA8CE    CDMA Only */
00237 #define     PhnLibTrapModemIssueResetInfo               (202+sysLibTrapCustom)    /**< 0xA8CF    CDMA Only */
00238 #define     PhnLibTrapGetRoamPrefMode                   (203+sysLibTrapCustom)    /**< 0xA8D0    CDMA Only */
00239 #define     PhnLibTrapSetRoamPrefMode                   (204+sysLibTrapCustom)    /**< 0xA8D1    CDMA Only */
00240 #define     PhnLibTrapGetRoamPrefInfo                   (205+sysLibTrapCustom)    /**< 0xA8D2    CDMA Only */
00241 #define     PhnLibTrapSetRoamPrefInfo                   (206+sysLibTrapCustom)    /**< 0xA8D3    CDMA Only */
00242 #define     PhnLibTrapIsSpecialNumber                   (207+sysLibTrapCustom)    /**< 0xA8D4    CDMA Only */
00243 #define     PhnLibTrapSetSpecialNumbers                 (208+sysLibTrapCustom)    /**< 0xA8D5    CDMA Only */
00244 #define     PhnLibTrapGetSpecialNumbers                 (209+sysLibTrapCustom)    /**< 0xA8D6    CDMA Only */
00245 #define     PhnLibTrapGetDTMFburstMode                  (210+sysLibTrapCustom)    /**< 0xA8D7    CDMA Only */
00246 #define     PhnLibTrapSetDTMFburstMode                  (211+sysLibTrapCustom)    /**< 0xA8D8    CDMA Only */
00247 #define     PhnLibTrapSetupDataConfig                   (212+sysLibTrapCustom)    /**< 0xA8D9    CDMA Only */
00248 #define     PhnLibTrapGetTotalDataTxBytes               (213+sysLibTrapCustom)    /**< 0xA8DA    CDMA Only */
00249 #define     PhnLibTrapGetTotalDataRxBytes               (214+sysLibTrapCustom)    /**< 0xA8DB    CDMA Only */
00250 #define     PrvPhnLibTrapCheckPowerSync                 (215+sysLibTrapCustom)    /**< 0xA8DC    CDMA Only */
00251 #define     PhnLibTrapSetPhoneSSMode                    (216+sysLibTrapCustom)    /**< 0xA8DD    CDMA Only */
00252 #define     PhnLibTrapEnableDM                          (217+sysLibTrapCustom)    /**< 0xA8DE    CDMA Only */
00253 #define     PhnLibTrapPowerSaveDisable                  (218+sysLibTrapCustom)    /**< 0xA8DF    CDMA Only */
00254 #define     PhnLibTrapCloseNetIF                        (219+sysLibTrapCustom)    /**< 0xA8E0    CDMA Only */
00255 #define     PhnLibTrapGetMdmPosition                    (220+sysLibTrapCustom)    /**< 0xA8E1    CDMA Only */
00256 #define     PhnLibTrapGetPDSessionConfigParam           (221+sysLibTrapCustom)    /**< 0xA8E2    CDMA Only */
00257 #define     PhnLibTrapSetPDSessionConfigParam           (222+sysLibTrapCustom)    /**< 0xA8E3    CDMA Only */
00258 #define     PhnLibTrapStopPDSession                     (223+sysLibTrapCustom)    /**< 0xA8E4    CDMA Only */
00259 #define     PhnLibTrapSndSave                           (224+sysLibTrapCustom)    /**< 0xA8E5    CDMA Only */
00260 #define     PhnLibTrapSndDelete                         (225+sysLibTrapCustom)    /**< 0xA8E6    CDMA Only */
00261 #define     PhnLibTrapListPDP                           (226+sysLibTrapCustom)    /**< 0xA8E7    CDMA Only */
00262 #define     PhnLibTrapSetPDP                            (227+sysLibTrapCustom)    /**< 0xA8E8    CDMA Only */
00263 #define     PhnLibTrapGetPDP                            (228+sysLibTrapCustom)    /**< 0xA8E9    CDMA Only */
00264 #define     PhnLibTrapCopyPDP                           (229+sysLibTrapCustom)    /**< 0xA8EA    CDMA Only */
00265 #define     PhnLibTrapDeletePDP                         (230+sysLibTrapCustom)    /**< 0xA8EB    CDMA Only */
00266 #define     PhnLibTrapReplacePDPPassword                (231+sysLibTrapCustom)    /**< 0xA8EC    CDMA Only */
00267 #define     PhnLibTrapGetTotalPDPs                      (232+sysLibTrapCustom)    /**< 0xA8ED    CDMA Only */
00268 #define     PhnLibTrapGetOneXStatus                     (233+sysLibTrapCustom)    /**< 0xA8EE    CDMA Only */
00269 #define     PhnLibTrapUpdateCustomizedNV                (234+sysLibTrapCustom)    /**< 0xA8EF    CDMA Only */
00270 #define     PhnLibTrapSetMdmAutoMsgMask                 (235+sysLibTrapCustom)    /**< 0xA8F0    CDMA Only */
00271 #define     PhnLibTrapGetPhoneSSMode                    (236+sysLibTrapCustom)    /**< 0xA8F1    CDMA Only */
00272 #define     PhnLibTrapGetPDPIndexRange                  (237+sysLibTrapCustom)    /**< 0xA8F2    CDMA Only */
00273 #define     PhnLibTrapGetCktSwitchProfile               (238+sysLibTrapCustom)    /**< 0xA8F3    CDMA Only */
00274 #define     PhnLibTrapStartIOTASession                  (239+sysLibTrapCustom)    /**< 0xA8F4    CDMA Only */
00275 #define     PhnLibTrapEndIOTASession                    (240+sysLibTrapCustom)    /**< 0xA8F5    CDMA Only */
00276 #define     PhnLibTrapTunnelIS683ReqMsg                 (241+sysLibTrapCustom)    /**< 0xA8F6    CDMA Only */
00277 #define     PhnLibTrapSelectNAM                         (242+sysLibTrapCustom)    /**< 0xA8F7    CDMA Only */
00278 #define     PhnLibTrapGetNAMInUse                       (243+sysLibTrapCustom)    /**< 0xA8F8    CDMA Only */
00279 #define     PhnLibTrapCommitIOTAParams                  (244+sysLibTrapCustom)    /**< 0xA8F9    CDMA Only */
00280 #define     PhnLibTrapReadIOTAItem                      (245+sysLibTrapCustom)    /**< 0xA8FA    CDMA Only */
00281 #define     PhnLibTrapWriteIOTAItem                     (246+sysLibTrapCustom)    /**< 0xA8FB    CDMA Only */
00282 #define     PhnLibTrapGetIOTAStatus                     (247+sysLibTrapCustom)    /**< 0xA8FC    CDMA Only */
00283 #define     PhnLibTrapSetCurrentUsageHandler            (248+sysLibTrapCustom)    /**< 0xA8FD    CDMA Only */
00284 #define     PhnLibTrapSendDTMFBurst                     (249+sysLibTrapCustom)    /**< 0xA8FE    CDMA Only */
00285 #define     PhnLibTrapAPNewAddress                      (250+sysLibTrapCustom)    /**< 0xA8FF    CDMA Only */
00286 #define     PhnLibTrapAPGetField                        (251+sysLibTrapCustom)    /**< 0xA900    CDMA Only */
00287 #define     Reserved2                                   (252+sysLibTrapCustom)    /**< 0xA901    CDMA Only */
00288 #define     PhnLibTrapCardInfoEx                        (253+sysLibTrapCustom)    /**< 0xA902    CDMA Only */
00289 #define     PhnLibTrapBoxInformationEx                  (254+sysLibTrapCustom)    /**< 0xA903    CDMA Only */
00290 #define     PhnLibTrapSignalQualityEx                   (255+sysLibTrapCustom)    /**< 0xA904    CDMA Only */
00291 #define     PhnLibTrapReplacePDPNAI                     (256+sysLibTrapCustom)    /**< 0xA905    CDMA Only */
00292 #define     PhnLibTrapReplacePDPSvcString               (257+sysLibTrapCustom)    /**< 0xA906    CDMA Only */
00293 #define     PhnLibTrapPDPLockUnlock                     (258+sysLibTrapCustom)    /**< 0xA907    CDMA Only */
00294 #define     PhnLibTrapPhoneRestore                      (259+sysLibTrapCustom)    /**< 0xA908    CDMA Only */
00295 #define     PhnLibTrapVerifyICDVer                      (260+sysLibTrapCustom)    /**< 0xA909    CDMA Only */
00296 #define     PhnLibTrapGetToneIDsEx                      (261+sysLibTrapCustom)    /**< 0xA90A    CDMA only */
00297 #define     PhnLibTrapPlayToneEx                        (262+sysLibTrapCustom)    /**< 0xA90B    CDMA only */
00298 #define     PhnLibTrapEnhancedRoamIndicator             (263+sysLibTrapCustom)    /**< 0xA90C    CDMA only */
00299 #define     PhnLibTrapNewMOMessage                      (264+sysLibTrapCustom)    /**< 0xA90D    CDMA only */
00300 #define     PhnLibTrapGetTTYSetting                     (265+sysLibTrapCustom)    /**< 0xA90E              */
00301 #define     PhnLibTrapSetTTYSetting                     (266+sysLibTrapCustom)    /**< 0xA90F              */
00302 #define     PhnLibTrapGetRadioState                     (267+sysLibTrapCustom)    /**< 0xA910              */
00303 #define     PhnLibTrapGetLineState                      (268+sysLibTrapCustom)    /**< 0xA911              */
00304 #define     PhnLibTrapGetLengthDetails                  (269+sysLibTrapCustom)    /**< 0xA912              */
00305 #define     PhnLibTrapGetPicturesToken                  (270+sysLibTrapCustom)    /**< 0xA913    CDMA Only */
00306 #define     PhnLibTrapSetPicturesToken                  (271+sysLibTrapCustom)    /**< 0xA914    CDMA Only */
00307 #define     PhnLibTrapGetPicturesServerInfo             (272+sysLibTrapCustom)    /**< 0xA915    CDMA Only */
00308 #define     PhnLibTrapSendPendingMessages               (273+sysLibTrapCustom)    /**< 0xA916              */
00309 #define     PhnLibTrapForceDataDormant                  (274+sysLibTrapCustom)    /**< 0xA917    CDMA Only */
00310 #define     PhnLibTrapGetSysPrefMode                    (275+sysLibTrapCustom)    /**< 0xA918    CDMA Only */
00311 #define     PhnLibTrapSetSysPrefMode                    (276+sysLibTrapCustom)    /**< 0xA919    CDMA Only */
00312 #define     PhnLibTrapGetLifeTimer                      (277+sysLibTrapCustom)    /**< 0xA91A              */
00313 #define     PhnLibTrapGetVoicePrivacyMode               (278+sysLibTrapCustom)    /**< 0xA91B    CDMA Only */
00314 #define     PhnLibTrapSetVoicePrivacyMode               (279+sysLibTrapCustom)    /**< 0xA91C    CDMA Only */
00315 #define     PhnLibTrapGetMMSServerInfo                  (280+sysLibTrapCustom)    /**< 0xA91D    CDMA Only */
00316 #define     PhnLibTrapGetSMSSegmentInfo                 (281+sysLibTrapCustom)    /**< 0xA91E    CDMA Only */
00317 #define     PhnLibTrapDebugHook                         (282+sysLibTrapCustom)    /**< 0xA91F              */
00318 #define     PhnLibTrapContinuePhonePowerOn              (283+sysLibTrapCustom)    /**< 0xA920              */
00319 #define     PhnLibTrapContinuePhonePowerOff             (284+sysLibTrapCustom)    /**< 0xA921              */
00320 #define     PhnLibTrapSetSMSCallbackNumber              (285+sysLibTrapCustom)    /**< 0xA922              */
00321 #define     PhnLibTrapGetDeviceId                       (286+sysLibTrapCustom)    /**< 0xA923              */
00322 #define     PhnLibTrapSendFlash                         (287+sysLibTrapCustom)    /**< 0xA924    CDMA ONLY */
00323 #define     PhnLibTrapGetCDMASystemInfo                 (288+sysLibTrapCustom)    /**< 0xA925    CDMA ONLY */
00324 #define     PhnLibTrapGetHomepageFromRadio              (289+sysLibTrapCustom)    /**< 0xA926    CDMA ONLY */
00325 #define     PhnLibTrapGetProxyInfo                      (290+sysLibTrapCustom)    /**< 0xA927    CDMA ONLY */
00326 #define     PhnLibTrapIsRadioGenericCDMA                (291+sysLibTrapCustom)    /**< 0xA928    CDMA ONLY */
00327 #define     PhnLibTrapGetGenericCDMAPreference          (292+sysLibTrapCustom)    /**< 0xA929    CDMA ONLY */
00328 #define     PhnLibTrapIsCarrierDefinedEmergencyNumber   (293+sysLibTrapCustom)    /**< 0xA92A    CDMA ONLY */
00329 #define     PhnLibTrapGetDialPrefix                     (294+sysLibTrapCustom)    /**< 0xA92B    CDMA ONLY */
00330 #define     PhnLibTrapSetDialPrefix                     (295+sysLibTrapCustom)    /**< 0xA92C    CDMA ONLY */
00331 #define     PhnLibTrapGetDataSessionInfo                (296+sysLibTrapCustom)    /**< 0xA92D              */
00332 #define     PhnLibTrapGetMediaTVSettings                (297+sysLibTrapCustom)    /**< 0xA92E    CDMA ONLY */
00333 #define     PhnLibTrapOffHold                           (298+sysLibTrapCustom)    /**< 0xA92F              */
00334 #define     PhnLibTrapGetMMSServerInfoEx                (299+sysLibTrapCustom)    /**< 0xA930    CDMA ONLY */
00335 #define     PhnLibTrapGetDataLife                       (300+sysLibTrapCustom)    /**< 0xA931    CDMA ONLY */
00336 #define     PhnLibTrapHACSetting                        (301+sysLibTrapCustom)    /**< 0xA932              */
00337 #define     PhnLibTrapGetMEID                           (302+sysLibTrapCustom)    /**< 0xA933              */
00338 #define     PhnLibTrapGetBaseStationIdInfo              (303+sysLibTrapCustom)    /**< 0xA934    CDMA ONLY */
00339 #define     PhnLibTrapGetMMSUAString                    (304+sysLibTrapCustom)    /**< 0xA935 VZ CDMA ONLY */
00340 #define     PhnLibTrapLast                              (304+sysLibTrapCustom)    /**< 0xA935              */
00341 #endif
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:53 2008 for Palm API Guide


Header Files » Incs » common » libraries » telephony

HsPhoneTypes.h

Go to the documentation of this file.
00001 /******************************************************************************
00002  * Copyright (c) 2004 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  *****************************************************************************/
00005 /** @ingroup Telephony
00006  *
00007  */
00008
00009
00010 /**
00011  *
00012  * @file    HsPhoneTypes.h
00013  *
00014  * @brief  Telephony data types that are common between ARM and 68K
00015  *
00016  */
00017
00018
00019 #ifndef __HS_PHONE_TYPES_H__
00020
00021 #define __HS_PHONE_TYPES_H__
00022
00023 #include <PalmTypes.h>
00024 #include <PalmCompatibility.h>  /** For VoidHand */
00025
00026 /******************************************************************************
00027  * Defines
00028  *****************************************************************************/
00029 /**
00030  *  @name Type and creator of CDMA and GSM phone libraries.
00031  *
00032  **/
00033 /*@{*/
00034 #define phnLibDbType            'libr'              /**< Phone Library type  */
00035
00036 #define phnLibCDMADbCreator       'PIL!'            /**< CDMA Library creator  */
00037 #define phnLibCDMAName            "Phone Library"       /**< CDMA Library name  */
00038
00039 #define phnLibOldCDMADbCreator    hsFileCCDMAPhoneLib       /**< Old CDMA Library creator  */
00040 #define phnLibOldCDMAName         "PhoneLib.prc"        /**< Old CDMA Library name  */
00041
00042
00043 #define phnLibGSMDbCreator      hsFileCGSMPhoneLib             /**< GSM Library creator  */
00044 #define phnLibGSMDbName         "Phone Library"                /**< GSM Library database name  */
00045 #define phnLibGSMName               "GSMLibrary.lib"        /**< GSM Library name  */
00046
00047
00048 #define phnVoiceCall1Active   0x0001 /**< There is a voice call active on line1  */
00049 #define phnVoiceCall2Active   0x0002 /**< There is a voice call active on line2 */
00050 #define phnCSDCallActive      0x0004 /**< There is a data call currently active */
00051                                          // Note: Actually the virtual modem has
00052                                          // control but does not neccessarily
00053                                          // have an active data call
00054 #define phnGPRSCallActive     0x0008 /**< There is a GPRS (GSM) session active  */
00055 #define phnPacketDataCallActive   0x0008 /**< There is an active 1X (CDMA) call  */
00056 #define phnPacketDataCallDormant  0x0010 /**< There is a dormany 1X (CDMA) call  */
00057
00058 #define phnCall1StatusActive      0x0020 /**< The first  call's status is phnConnectionActive */
00059 #define phnCall2StatusActive      0x0040 /**< The second call's status is phnConnectionActive */
00060 #define phnCall1StatusDialing     0x0080 /**< The first  call's status is phnConnectionDialing */
00061 #define phnCall2StatusDialing     0x0100 /**< The second call's status is phnConnectionDialing */
00062 #define phnCall1StatusIncoming    0x0200 /**< The first  call's status is phnConnectionIncoming */
00063 #define phnCall2StatusIncoming    0x0400 /**< The second call's status is phnConnectionIncoming */
00064 #define phnCall1StatusAlerting    0x0800 /**< The first  call's status is phnConnectionIncoming */
00065 #define phnCall2StatusAlerting    0x1000 /**< The second call's status is phnConnectionIncoming */
00066 /*@}*/
00067
00068 /**
00069  *  @name CDMA Threshold level for signal bar (based on Generic Handset requirement)
00070  *
00071  **/
00072 /*@{*/
00073 #define maxDBm4signalLevel0     105 /**<  will display no bar, mid percent = 10 */
00074 #define maxDBm4signalLevel1     95  /**<  will display 1 bar, mid percent = 30 */
00075 #define maxDBm4signalLevel2     85  /**<  will display 2 bars, mid percent = 50 */
00076 #define maxDBm4signalLevel3     75  /**<  will display 3 bars, mid percent = 70 */
00077 /*@}*/
00078
00079
00080 /**
00081  *  if below maxDBm4signalLevel3 then display 4 bars, mid percent = 90
00082  *  Threshold ecio level for signal bar (based on Generic Handset requirement)
00083  **/
00084 /*@{*/
00085 #define maxDB4ecioLevel0     15 /**<  will display no bar */
00086 #define maxDB4ecioLevel1     13 /**<  will display 1 bar */
00087 #define maxDB4ecioLevel2     11 /**<  will display 2 bars */
00088 #define maxDB4ecioLevel3     9  /**<  will display 3 bars */
00089 /*@}*/
00090
00091 /**
00092  *  @name Volume
00093  *
00094  **/
00095 /*@{*/
00096 #define phnVolumeMin        0       /**< Minimum volume level */
00097 #define phnVolumeMax        7       /**< Maximum volume level */
00098 /*@}*/
00099
00100
00101 /**
00102  *  @name Enumerations and Typedefs
00103  *
00104  **/
00105 /*@{*/
00106 #define phnLibUnknownID         0xff000000  /**<        */
00107 #define phnLibNoLookupNeededID  0xff000001      /**<        */
00108 #define phnLibFtrNumResetFlag   10      /**<        */
00109 #define phnLibFtrNumBottomBRate 11      /**<        */
00110 #define phnLibFtrNumBlockATCmd  12      /**<        */
00111 #define phnLibFtrValBlockATCmd  'noAT'      /**<        */
00112 /*@}*/
00113
00114 typedef UInt16      PhnConnectionID;    /**< Connection ID  */
00115 typedef UInt32      PhnDatabaseID;       /**< Database ID  */
00116 typedef VoidHand    PhnAddressHandle;    /**<       */
00117 typedef VoidHand    PhnAddressList;      /**<       */
00118 typedef UInt32      PhnOperatorID;       /**<       */
00119
00120
00121 /******************************************************************************
00122  * Enumerations
00123  *****************************************************************************/
00124 /**
00125  *  Classes of service for which applications can register
00126  **/
00127 enum _PhoneServiceClassType
00128   {
00129     phnServiceVoice = 1,        /**< 0x0001 */
00130     phnServiceSMS = 2,          /**< 0x0002 */
00131     phnServiceActivation = 4,       /**< 0x0004 */
00132     phnServiceData = 8,         /**< 0x0008 */
00133     phnServiceIOTA = 16,        /**< 0x0010 */
00134     phnServiceSIMToolkit = 32,  /**< 0x0020 */
00135     phnServiceAFLT = 64,        /**< 0x0040 */
00136     phnServiceMisc = 128,       /**< 0x0080 */
00137     phnServiceEssentials = 256, /**< 0x0100 */
00138     phnServiceMMS = 512,            /**< 0x200 */
00139     phnServiceWAP = 1024,           /**< 0x400 */
00140     phnServiceAll = phnServiceVoice | phnServiceSMS | phnServiceAFLT |
00141                     phnServiceData | phnServiceActivation | phnServiceMisc | phnServiceIOTA |
00142                     phnServiceEssentials | phnServiceSIMToolkit | phnServiceMMS | phnServiceWAP,
00143     phnServiceMax = 0xFFFF          /**< Reserved. */
00144   };
00145
00146 typedef UInt16 PhoneServiceClassType;       /**<        */
00147
00148 #define isValidPhoneServiceClassType(s) ((s & phnServiceAll) != 0)  /**<        */
00149
00150 /**
00151  *  Phone address fields
00152  **/
00153 typedef enum {
00154     phnAddrFldPhone,        /**<        */
00155     phnAddrFldFirstName,        /**<        */
00156     phnAddrFldLastName      /**<        */
00157 } _PhnAddressField;
00158
00159 #define isValidPhnAddressField(a) ((a >= phnAddrFldPhone) && (a <= phnAddrFldLastName)) /**<        */
00160
00161 // make sure that size of enum is same across all compilers
00162 typedef UInt8 PhnAddressField;      /**<        */
00163
00164 /**
00165  *  GSM CLIR Mode
00166  **/
00167 typedef enum  {
00168     gsmDialCLIRDefault,             /**<        */
00169     gsmDialCLIRTemporaryInvocation,     /**<        */
00170     gsmDialCLIRTemporarySuppression     /**<        */
00171 } _GSMDialCLIRMode;
00172
00173 #define isValidGSMDialCLIRMode(d) ((d >= gsmDialCLIRDefault) && (d <= gsmDialCLIRTemporarySuppression))     /**<        */
00174
00175 // make sure that size of enum is same across all compilers
00176 typedef UInt8 GSMDialCLIRMode;      /**<        */
00177
00178
00179 /**
00180  *  Power state of the radio
00181  **/
00182 enum _PhnPowerType
00183   {
00184     phnPowerOff,        /**<        */
00185     phnPowerOn,         /**<        */
00186     phnPowerStartCharging,  /**<        */
00187     phnPowerStopCharging,   /**<        */
00188     phnPowerLow,        /**<        */
00189     phnPowerSave                /**< Modem goes to deep sleep after failing to search for service */
00190   };
00191
00192 typedef UInt8 PhnPowerType;     /**<        */
00193
00194 #define isValidPhnPowerType(p) (p <= phnPowerSave)      /**<        */
00195 //#define isValidPhnPowerType(p) ((p >= phnPowerOff) && (p <= phnPowerSave))
00196
00197 /**
00198  *  Status of the SIM on GSM radio only
00199  **/
00200 enum _GSMSIMStatus {
00201     simMissing,         /**<        */
00202     simFailure,         /**<        */
00203     simWrong,       /**<        */
00204     simNotReady,        /**<        */
00205     simReady,       /**<        */
00206     simUnknown,         /**<        */
00207     simPresent      /**<        */
00208     // <chg 05-05-2002 TRS> bug # 13072
00209 };
00210
00211 typedef UInt8 GSMSIMStatus;     /**<        */
00212
00213
00214 /**
00215  *  LifeTimer Enums
00216  **/
00217 enum
00218 {
00219   lifeTimeVoice,    /**<        */
00220   lifeTimeData      /**<        */
00221 };
00222
00223 typedef UInt8 PhnLifeTimer; /**<        */
00224
00225 /**
00226  *  Currently on the GSM side there is no way for the control channel to know
00227  *  that a data call has gone active. To resolove this issue there are two
00228  *  posibble solutions.
00229  *
00230  *  1. Have the radio send an unoslicted event accorss all channels to indicate a
00231  *     data call has gone active
00232  *  2. Have the NetLib post a notification to the GSM Library that a data call is
00233  *     going active.
00234  **/
00235
00236 /**
00237  *
00238  **/
00239 typedef enum
00240   {
00241     autoLockMode,               /**< option Lock Phone on Power Down is chosen */
00242     immediateLockMode           /**< option Lock Phone immediately is chosen */
00243   }
00244 PhnLockModeEnum;
00245 typedef UInt8 PhnLockMode;
00246 #define isValidPhnLockMode(m) ((m >= autoLockMode) && (m <= immediateLockMode))     /**<        */
00247
00248 #endif // ifndef __HS_PHONE_TYPES_H__
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:53 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » hssoundlib

HsSoundLib.h

Go to the documentation of this file.
00001 /******************************************************************************
00002  * Copyright (c) 2004 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  *****************************************************************************/
00005 /**
00006  * @ingroup Sound
00007  *
00008  */
00009
00010 /**
00011  * @file    HsSoundLib.h
00012  *
00013  * @brief   Public 68K include file for main sound support for Treo 600
00014  *          and Treo 650 smartphones.
00015  *
00016  * This header file and associated header files support the specific sound
00017  * functionality of the Treo smartphones. You should use the Palm OS Sound
00018  * Manager APIs for most of your work.
00019  *
00020  * Notes:
00021  * The calling application should always load this library with
00022  * SysLibLoad() before use, even if it is already open by another
00023  * application(ie, SysLibFind() returns a valid refnum). When
00024  * the application is done with the library, it should be
00025  * unloaded with SysLibRemove(). We do this because there is
00026  * no good way to synchronize loading and unloading of libraries
00027  * among multiple applications. It also greatly simplifies internal
00028  * synchronization.
00029  */
00030
00031 #ifndef __HSSOUNDLIB__H__
00032 #define __HSSOUNDLIB__H__
00033
00034 /***********************************************************************
00035  * Palm OS common definitions
00036  ***********************************************************************/
00037 #include <PalmOS.h>
00038 #include <HsSoundLibCommon.h>
00039
00040
00041 #ifdef __cplusplus
00042 extern "C" {
00043 #endif
00044
00045 /**
00046  * @name Preference Macros
00047  */
00048 /*@{*/
00049 #define PmSndSetPreference( libRef, prefID, prefValue ) \
00050         HsSndSwitchSetPort( libRef, pmSndSwitchID_Preferences, (HsSndPortID) (prefValue), (HsSndPortClass) (prefID) );
00051
00052 #define PmSndGetPreference( libRef, prefID, prefValuePtr ) \
00053         HsSndSwitchGetPort( libRef, pmSndSwitchID_Preferences, (HsSndPortID *) (prefValuePtr), (HsSndPortClass) (prefID) );
00054 /*@}*/
00055
00056
00057 /**
00058  * @name Special Function Macros
00059  */
00060 /*@{*/
00061 #define PmSndStreamSetAttackEnvID(libRef,stream,attackEnvID) HsSndFormatPlay( libRef, (HsSndFormatType) pmSndFormatSetAttackEnvID, (HsSndCmdType) attackEnvID, (void*)0, (UInt32) stream )
00062 #define PmSndStreamPause(libRef,stream)  HsSndFormatPlay( libRef, (HsSndFormatType) pmSndFormatPauseStream,  (HsSndCmdType) 0, (void*) 0, (UInt32) stream )
00063 #define PmSndStreamResume(libRef,stream) HsSndFormatPlay( libRef, (HsSndFormatType) pmSndFormatResumeStream, (HsSndCmdType) 0, (void*) 0, (UInt32) stream )
00064 #define PmSndStreamStoppable(libRef,stream) HsSndFormatPlay( libRef, (HsSndFormatType) pmSndFormatSetStoppable,  (HsSndCmdType) 0, (void*) 0, (UInt32) stream )
00065 /*@}*/
00066
00067 /// Open and initialize the Sound library instance.
00068 ///
00069 /// @param libRef:  IN: Library reference number (from SysLibLoad)
00070 /// @return Library error code.
00071 Err   HsSndOpen (UInt16 libRef)
00072           SYS_TRAP (kHsSoundLibTrapOpen);
00073
00074 /// Close the Sound library instance.
00075 ///
00076 /// @param libRef:  IN: Library reference number (from SysLibLoad)
00077 /// @return Library error code.
00078 Err   HsSndClose (UInt16 libRef)
00079           SYS_TRAP (kHsSoundLibTrapClose);
00080
00081 /// Returns the library version number.
00082 ///
00083 /// @param libRef:  IN: Library reference number (from SysLibLoad)
00084 /// @return Library error code.
00085 UInt32  HsSndGetVersion (UInt16 libRef)
00086           SYS_TRAP (kHsSoundLibTrapGetVersion);
00087
00088 /// Returns information about the sound port.
00089 ///
00090 /// @param libRef:      IN: Library reference number
00091 /// @param portID:      IN: Sound port ID.
00092 /// @param *portInfoP:  IN: Pointer to an HsSndPortInfo structure provided by the caller.
00093 /// @return Library error code.
00094 Err   HsSndPortGetInfo (UInt16 libRef, HsSndPortID portID, HsSndPortInfo *portInfoP)
00095           SYS_TRAP (kHsSoundLibTrapPortGetInfo);
00096
00097 /// Set a sound port's audio parameter.
00098 ///
00099 /// @param libRef:      IN: Library reference number (from SysLibLoad)
00100 /// @param portID:      IN: Sound port ID.
00101 /// @param paramSel:    IN: Parameter selector.
00102 /// @param value:       IN: Value to set.
00103 /// @param returnValue: OUT: Pointer to the updated value.
00104 /// @return Library error code.
00105 Err   HsSndPortSetParam (UInt16 libRef, HsSndPortID portID, HsSndParam paramSel, Int16 value, Int16 * returnValue)
00106           SYS_TRAP (kHsSoundLibTrapPortSetParam);
00107
00108 /// Get the current sound port for a particular switch.
00109 ///
00110 /// @param libRef:      IN: Library reference number (from SysLibLoad)
00111 /// @param switchID:    IN: Switch ID.
00112 /// @param portIDP:     OUT: Port ID returned to the caller.
00113 /// @param portClass:   IN: Port class selector.
00114 /// @return Library error code.
00115 Err   HsSndSwitchGetPort (UInt16 libRef, HsSndSwitchID switchID, HsSndPortID * portIDP, HsSndPortClass portClass)
00116           SYS_TRAP (kHsSoundLibTrapSwitchGetPort);
00117
00118 /// Set the current sound port for a particular switch.
00119 ///
00120 /// @param libRef:      IN: Library reference number (from SysLibLoad)
00121 /// @param switchID:    IN: Switch ID.
00122 /// @param portID:      IN: The new port ID for the audio switch.
00123 /// @param portClass:   IN: Port class selector.
00124 /// @return Library error code.
00125 Err   HsSndSwitchSetPort (UInt16 libRef, HsSndSwitchID switchID, HsSndPortID portID, HsSndPortClass portClass)
00126           SYS_TRAP (kHsSoundLibTrapSwitchSetPort);
00127
00128 /// Play a sound.
00129 ///
00130 /// @param libRef:      IN: Library reference number (from SysLibLoad).
00131 /// @param freq:        IN: Frequency of the tone.
00132 /// @param amp:         IN: Amplitude of the tone.
00133 /// @param duration:    IN: Duration of the tone.
00134 /// @param toneType:    IN: Type of tone to play.
00135 /// @return Library error code.
00136 Err   HsSndTonePlay (UInt16 libRef, UInt32 freq, UInt16 amp, UInt32 duration, UInt32 toneType)
00137           SYS_TRAP (kHsSoundLibTrapTonePlay);
00138
00139 /// Stop playing a sound that was started with HsSndTonePlay().
00140 ///
00141 /// @param libRef:  IN: Library reference number (from SysLibLoad).
00142 /// @return Library error code.
00143 Err   HsSndToneStop (UInt16 libRef)
00144           SYS_TRAP (kHsSoundLibTrapToneStop);
00145
00146 /// Play formatted audio data, such as MIDI, AMR, and so forth.
00147 ///
00148 /// @param libRef:          IN: Library reference number (from SysLibLoad).
00149 /// @param format:          IN: Audio format to be played.
00150 /// @param command:         IN: Command to execute.  Should be set to hsSndCmdPlay.
00151 /// @param commandData:     IN: Command to the sound buffer structure HsSndBufferData
00152 /// @param commandFlags:    IN: Command flags for the play command.
00153 /// @return Library error code.
00154 Err   HsSndFormatPlay (UInt16 libRef, HsSndFormatType format, HsSndCmdType command, void * commandData, UInt32 commandFlags)
00155           SYS_TRAP (kHsSoundLibTrapFormatPlay);
00156
00157 /// Records formatted audio data, such as MIDI, AMR, and so forth.
00158 /// (Currently a stub and not implemented yet).
00159 ///
00160 /// @param libRef:          IN: Library reference number (from SysLibLoad).
00161 /// @param format:          IN: Audio format to be recorded.
00162 /// @param command:         IN: Command to execute. Should be set to hsSndCmdPlay.
00163 /// @param commandData:     IN: Pointer to the sound buffer structure HsSndBufferData.
00164 /// @param commandFlags:    IN: The command flags for the record command.
00165 /// @return Library error code.
00166 Err   HsSndFormatRecord (UInt16 libRef, HsSndFormatType format, HsSndCmdType command, void * commandData, UInt32 commandFlags)
00167           SYS_TRAP (kHsSoundLibTrapFormatRecord);
00168
00169 /// Get the user volume setting for the specified sound mode.
00170 ///
00171 /// @param libRef:      IN: Library reference number (from SysLibLoad).
00172 /// @param mode:        IN: The audio configuration mode.
00173 /// @param volumeP:     IN: The sound level.
00174 /// @return Library error code.
00175 Err   HsSndGetUserVolume (UInt16 libRef, HsSndMode mode, Int16 * volumeP)
00176           SYS_TRAP (kHsSoundLibTrapGetUserVolume);
00177
00178 /// Set the user volume for the specified sound mode.
00179 ///
00180 /// @param libRef:  IN: Library reference number (from SysLibLoad).
00181 /// @param mode:    IN: The audio configuration mode.
00182 /// @param volume:  IN: The sound level.
00183 /// @return Library error code.
00184 Err   HsSndSetUserVolume (UInt16 libRef, HsSndMode mode, Int16 volume)
00185           SYS_TRAP (kHsSoundLibTrapSetUserVolume);
00186
00187
00188 /// Get the number of clock ticks per second
00189 ///
00190 /// @param libRef:  IN: Library reference number (from SysLibLoad).
00191 /// @param clkRef:  IN: Clock reference number (see HsSoundLibCommon.h).
00192 /// @param ticksPerSecondP  OUT: Returns the tick per second
00193 /// @return Library error code.
00194 Err    PmSndClkGetTicksPerSecond ( UInt16 libRef, PmClkTickRef clkRef, UInt32* ticksPerSecondP )
00195           SYS_TRAP (kPmSoundLibTrapClkGetTicksPerSecond);
00196
00197 /// Get current clock tick count.
00198 ///
00199 /// @param libRef:  IN: Library reference number (from SysLibLoad).
00200 /// @param clkRef:  IN: Clock reference number (see HsSoundLibCommon.h).
00201 /// @param clockTicksP  OUT: Returns the current clock tick count.
00202 /// @return Library error code.
00203 Err    PmSndClkGetTickCount ( UInt16 libRef, PmClkTickRef clkRef, PmSndU64* clockTicksP )
00204           SYS_TRAP (kPmSoundLibTrapClkGetTickCount);
00205
00206 /// Get current stream sample position and current clock tick count.
00207 ///
00208 /// @param libRef:  IN: Library reference number (from SysLibLoad).
00209 /// @param streamRef IN: Sound stream channel reference id.
00210 /// @param sampleNumberP: OUT: Returns the current sample number for the stream.
00211 /// @param clkRef:  IN: Clock reference number (see HsSoundLibCommon.h).
00212 /// @param clockTicksP  OUT: Returns the current clock tick count.
00213 /// @return Library error code.
00214 Err    PmSndGetPosition ( UInt16 libRef, SndStreamRef streamRef, PmSndU64* sampleNumberP, PmClkTickRef clkRef, PmSndU64* clockTicksP )
00215           SYS_TRAP (kPmSoundLibTrapGetPosition);
00216
00217
00218 #ifdef __cplusplus
00219 }
00220 #endif
00221
00222 #endif // __HSSOUNDLIB__H__
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:53 2008 for Palm API Guide


Header Files » Incs » common » libraries » hssoundlib

HsSoundLibCommon.h

Go to the documentation of this file.
00001 /******************************************************************************
00002  * Copyright (c) 2004-2006 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  *****************************************************************************/
00005 /**
00006  * @defgroup Sound Sound Library
00007  * @brief       This library provides support for the specific sound functionality
00008  *              of the Treo smartphones.
00009  *
00010  * Developers should be able to use Palm OS Sound Manager APIs for most of the work.
00011  * The calling application should always load this library with SysLibLoad() before
00012  * use, even if it is already open by another application (ie. SysLibFind() returns
00013  * a valid refNum). When the application is done with the library it should be
00014  * unloaded with SysLibRemove(). We do this because there is no good way to synchronize
00015  * loading and unloading of libraries among multiple applications. It also greatly
00016  * simplifies internal synchronization.
00017  *
00018  * @{
00019  * @}
00020  */
00021 /**
00022  * @ingroup Sound
00023  */
00024
00025 /**
00026  * @file    HsSoundLibCommon.h
00027  *
00028  * @brief   Public 68K/Arm common header file for sound support for Treo 600,
00029  *          Treo 650, and Treo 700p smartphones and later models.
00030  *
00031  * This file contains the common constants and structures to be used with
00032  * the sound library.
00033  *
00034  */
00035
00036 #ifndef __HSSOUNDLIB_COMMON__H__
00037 #define __HSSOUNDLIB_COMMON__H__
00038
00039 /***********************************************************************
00040  * Palm OS common definitions
00041  ***********************************************************************/
00042
00043 #include <PalmTypes.h>
00044 #include <Common/System/HsErrorClasses.h>
00045
00046 #if CPU_TYPE == CPU_ARM
00047     typedef unsigned long long  PmSndU64;
00048 #elif CPU_TYPE == CPU_x86
00049     typedef __int64             PmSndU64;
00050 #else
00051     typedef unsigned long long  PmSndU64;
00052 #endif
00053
00054 /**
00055  * @name HsSoundLib information
00056  *
00057  */
00058 /*@{*/
00059 #define hsSndLibVersion             0x010D0000      /**<Version of the sound library. */
00060 #define hsSoundLibCreatorID         hsFileSoundLib  /**<Creator ID of the sound library. */
00061 #define hsSoundLibTypeID            sysFileTLibrary /**<Type of the sound library. */
00062 #define hsSoundLibName              "HsSoundLib"    /**<Name of the sound library. */
00063 /*@}*/
00064
00065 /**
00066  * @name Sound library event notifications
00067  *
00068  * Note: Each one of these notifications are reserved as Creator IDs with PalmSource
00069  */
00070 /*@{*/
00071 #define hsSndNotify                 hsFileSoundLib /**<HsSoundLib broadcaster's ID */
00072 #define hsSndNotifyUnplugged        'hOff' /**<No accesory is currently attached to the headset jack. */
00073 #define hsSndNotifyHeadset          'hSet' /**<Headset jack connected and configured for mono headset with microphone. */
00074 #define hsSndNotifyHeadphones       'hPho' /**<Headset jack connected and configured for stereo headphones. */
00075 #define hsSndNotifyHybrid           'hHyb' /**<A hybrid headset/headphone is currently attached to the headset jack. */
00076 #define hsSndNotifyNotHybrid        'hNoH' /**<Currently attached peripheral on headset jack is Not a hybrid headset (see hsSndNotifyHybrid). */
00077 #define hsSndNotifyAnswerButton     'hAns' /**<While a headset or hybrid was connected, the answer-button event was detected. */
00078 #define hsSndNotifyAnswerHold       'hHol' /**<After hsSndNotifyAnswerButton notification, this event is sent if answer-button is still held down for some time. */
00079 #define hsSndNotifyAnswerRelease    'hRel' /**<After hsSndNotifyAnswerButton notification, this event is sent when answer-button released. */
00080 #define hsSndNotifyRingerSwitchOn   'hROn' /**<Notifies that ringer switch is in the on (play sounds to back speaker) position. */
00081 #define hsSndNotifyRingerSwitchOff  'hROf' /**<Notifies that ringer switch is in the silent (no sounds to back speaker) position. */
00082 #define hsSndNotifyHighPriority     'hHPr' /**<A high priority sound is about to start playing. */
00083 #define hsSndNotifyAlert            'hAlr' /**<An alert sound is about to start playing. */
00084 #define hsSndNotifyCarkitActive     'hCar' /**<Wired carkit has been activated, audio goes to carkit path. */
00085 #define hsSndNotifyCarkitInactive   'hCOf' /**<Wired carkit is no longer active, audio routes normally. */
00086 #define hsSndNotifyAthenaAudio      'hAta' /**<Automatic audio switches will route to Athena connector from now on (Treo-650 and later). */
00087 /*@}*/
00088
00089 /**
00090  * @name Sound library resource types
00091  *
00092  */
00093 /*@{*/
00094 #define hsSndRsrcAudioTableType     'hTbl' /**<Resource contains audio table that can be loaded to audio driver. */
00095 #define hsSndRsrcAudioTableID       25000  /**<Default audio table ID which can be loaded automatically during reset. */
00096 /*@}*/
00097
00098 /**
00099  * @name Sound library error codes
00100  */
00101 /*@{*/
00102 #define hsSndErrBase                hsSoundLibErrorClass /* 0x7500 == 29952 */
00103 #define HS_SND_ERR(x)               ((Err)((x) + hsSndErrBase))
00104 #define hsSndErr_Failed             (HS_SND_ERR(1))  /**<The operation or request failed. */
00105 #define hsSndErr_NotSupported       (HS_SND_ERR(2))  /**<Attempt to use functionality that is not supported in this version. */
00106 #define hsSndErr_InvalidPort        (HS_SND_ERR(3))  /**<An invalid port was passed to a function. Operation failed. */
00107 #define hsSndErr_PortCannotMute     (HS_SND_ERR(4))  /**<Unable to change mute state on a port that does not have mute capabilities. */
00108 #define hsSndErr_PortCannotVolume   (HS_SND_ERR(5))  /**<Unable to change volume gains on a port that does not have volume capabilities. */
00109 #define hsSndErr_PortCannotBoost    (HS_SND_ERR(6))  /**<Unable to change boost state on a port that does not have boost capabilities. */
00110 #define hsSndErr_PortCannotPan      (HS_SND_ERR(7))  /**<Unable to change pan settings on a port that does not have panning capabilities. */
00111 #define hsSndErr_InvalidSwitch      (HS_SND_ERR(8))  /**<An invalid switch was passed to a function. Operation failed. */
00112 #define hsSndErr_UnknownSndParam    (HS_SND_ERR(9))  /**<An unknown HsSndParam selector was passed to a function call. */
00113 #define hsSndErr_UnknownPortClass   (HS_SND_ERR(10)) /**<An unknown HsSndPortClass value was passed to a function call. */
00114 #define hsSndErr_PortIDNotInClass   (HS_SND_ERR(11)) /**<The portID/portClass combination is not supported. */
00115 #define hsSndErr_PortMuteLocked     (HS_SND_ERR(12)) /**<Unable to change mute state when hsSndParamMode_Normal is the default. */
00116 #define hsSndErr_PortVolumeLocked   (HS_SND_ERR(13)) /**<Unable to change volume parameter when hsSndParamMode_Normal is the default. */
00117 #define hsSndErr_PortBoostLocked    (HS_SND_ERR(14)) /**<Unable to change boost state when hsSndParamMode_Normal is the default. */
00118 #define hsSndErr_PortPanLocked      (HS_SND_ERR(15)) /**<Unable to change pan value when hsSndParamMode_Normal is the default. */
00119 #define hsSndErr_DoMidiProgressMsg  (HS_SND_ERR(16)) /**<Special message returned by Midi progress callback to request a dynamic volume change. */
00120 #define hsSndErr_UnknownClkRef      (HS_SND_ERR(17)) /**<Unknown clock reference passed to synchronization clock utility */
00121 #define hsSndErr_InvalidPrefValue   (HS_SND_ERR(18)) /**<Unsupported or invalid audio preference value */
00122 #define hsSndErr_LastPublicError    (HS_SND_ERR(63)) /**<just a marker for last public library error code, private sound error codes start at 64 */
00123 /*@}*/
00124
00125 /**
00126  * Beeps
00127  *
00128  * Provides additional system sounds for PalmOS SndPlaySystemSound.
00129  */
00130 enum hsSndSysBeepTag
00131 {
00132     hsSndCardInsert = 64, /**<No definition. */
00133     hsSndCardRemove, /**<No definition. */
00134     hsSndSyncStart, /**<No definition. */
00135     hsSndSyncStop, /**<No definition. */
00136     hsSndChargerAttach, /**<No definition. */
00137     hsSndChargerDetach, /**<No definition. */
00138     hsSndRadioOn, /**<No definition. */
00139     hsSndRadioOff, /**<No definition. */
00140     hsSndBatFull, /**<No definition. */
00141     hsSndBatLow, /**<No definition. */
00142     hsSndBatShutdown, /**<No definition. */
00143     hsSndDeepWake, /**<No definition. */
00144     hsSndDeepSleep, /**<No definition. */
00145     hsSndRadioInServiceArea, /**<No definition. */
00146     hsSndRadioOutServiceArea /**<No definition. */
00147
00148 };
00149
00150 /** Holds beep tone type. @see hsSndSysBeepTag */
00151 typedef UInt8 hsSndSysBeepType;
00152
00153 /**
00154  * @name Sound mode volume controls
00155  *
00156  * Use with HsSndGetUserVolume and HsSndSetUserVolume.
00157  */
00158 /*@{*/
00159 #define hsSndMode_Current               ((HsSndMode) 0x0000) /**<Pass to spefify the currently active sound mode. */
00160 #define hsSndMode_Receiver              ((HsSndMode) 0x0001) /**<Mode when Radio audio goes to receiver speaker. */
00161 #define hsSndMode_Speakerphone          ((HsSndMode) 0x0002) /**<Mode when Radio audio goes to loud speaker (speaker phone) */
00162 #define hsSndMode_SpeakerHost           ((HsSndMode) 0x0003) /**<Mode when radio is off and speaker used exclusively by system and third party audio. */
00163 #define hsSndMode_Headset               ((HsSndMode) 0x0004) /**<Mode when any audio goes to a mono headphones. */
00164 #define hsSndMode_Headphones            ((HsSndMode) 0x0005) /**<Mode when any audio goes to stereo headphones. */
00165 #define hsSndMode_HeadphonesHost        ((HsSndMode) 0x0006) /**<Mode when radio is off and headphones used exclusively by system and third party audio. */
00166 #define hsSndMode_Carkit                ((HsSndMode) 0x0007) /**<Mode when wired carkit is attached and active to the device.*/
00167 #define hsSndMode_Reserved              ((HsSndMode) 0x0008) /**<Reserved for future definition. Do not use. */
00168 /*@}*/
00169
00170 /** Holds audio mode type */
00171 typedef Int16 HsSndMode;
00172
00173 /**
00174  * @name Tone type parameter
00175  *
00176  */
00177 /*@{*/
00178 #define hsSndToneType_Square            0  /**<Used when calling HsSndTonePlay. */
00179 /*@}*/
00180
00181 /**
00182  * Sound command values
00183  *
00184  * The HsSndCmdType is used as the first parameter to the
00185  * function HsSndFormatPlay.  Use these command values.
00186  */
00187 enum HsSndCmdEnumTag
00188 {
00189     hsSndCmdPlay = 1,   /**<Use to initiate a playback session. */
00190     hsSndCmdStop        /**<Use to terminate the current playback session. */
00191
00192 };
00193
00194 /** Holds sound command type */
00195 typedef UInt16 HsSndCmdType;
00196
00197 /** Holds sound port ID information. */
00198 typedef UInt32 HsSndPortID;
00199
00200 /** Holds sound switch ID information. */
00201 typedef UInt32 HsSndSwitchID;
00202
00203 /** Used as a parameter to HsSndPortSetParam function. */
00204 typedef UInt16 HsSndParam;
00205
00206 /** Used as a parameter to HsSndSwitchGetParam function. */
00207 typedef UInt16 HsSndPortClass;
00208
00209 /** Holds sound format type */
00210 typedef UInt16 HsSndFormatType;
00211
00212 #define hsSndBayID_AC97                 0x01000000 /**<An AC97 compatible chip is supported as the analog sound patch bay. */
00213
00214 /**
00215  * @name Utility Macros - I
00216  *
00217  */
00218 /*@{*/
00219 #define HS_AC97(n)                      ((n) | hsSndBayID_AC97) /**<Associates the AC97 Bay ID with other element IDs */
00220 #define HS_RDIO(n)                      ((n) | hsSndBayID_Radio) /**<Associates the Radio Bay ID (hsSndBayID_Radio) with other element IDs */
00221 #define HsSndParamValue_SetWithLock(v)  (((v) & ~hsSndParamMode_Mask) | hsSndParamMode_LockParam) /**<Adds LockParam to parameter value. */
00222 #define HsSndParamValue_SetWithUnlock(v)(((v) & ~hsSndParamMode_Mask) | hsSndParamMode_UnlockParam) /**<Adds UnLockParam to parameter value. */
00223 #define HsSndParamValue_RemoveMode(v)   (((v) & 0x8000)? (v) | hsSndParamMode_Mask : (v) & ~hsSndParamMode_Mask) /**<Removes LockParam or UnLockParam from parameter value. */
00224 /*@}*/
00225
00226 /**
00227  * @name Sound switch configuration types
00228  *
00229  * Used with HsSndSwitchID.
00230  */
00231 /*@{*/
00232 #define hsSndSwitchID_InRadioSpkr       HS_AC97(0x00010000) /**<Controls the destination port for data coming from the Radio. */
00233 #define hsSndSwitchID_OutRadioMic       HS_AC97(0x00020000) /**<Controls the source microphone to connect to the Radio. */
00234 #define hsSndSwitchID_InMic             HS_AC97(0x00030000) /**<Test control for Mfg to directly connect Mic input into any destination speaker. */
00235 #define hsSndSwitchID_InHostPlay        HS_AC97(0x00040000) /**<Controls which speaker to direct PalmOS audio to.*/
00236 #define hsSndSwitchID_OutHostRec        HS_AC97(0x00050000) /**<Controls from which port to digitize and send to PalmOS for recording. */
00237 /*@}*/
00238
00239 /**
00240  * @name Sound port configuration types
00241  *
00242  * Used with HsSndPortID.
00243  */
00244 /*@{*/
00245 #define hsSndPortID_Off                 0x00000000 /**<Special meta port ID used to turn off a sound switch. */
00246 #define hsSndPortID_Current             HS_AC97(0x00000000) /**<Special meta port ID used to specify currently active user port. */
00247 #define hsSndPortID_OutReceiver         HS_AC97(0x00000001) /**<Receiver speaker. */
00248 #define hsSndPortID_OutSpeaker          HS_AC97(0x00000002) /**<Back speaker for system audio and speakerphone functions, */
00249 #define hsSndPortID_OutHeadset          HS_AC97(0x00000003) /**<Audio output to mono headset (right channel output).  Left can be used as input. */
00250 #define hsSndPortID_OutHeadphones       HS_AC97(0x00000004) /**<Configures the headset port for full left and right stereo output, no inputs. */
00251 #define hsSndPortID_OutSpeakerAuto      HS_AC97(0x00000005) /**<Automatic port, according to headset insertion. Use with hsSndSwitchID_InRadioSpkr. */
00252 #define hsSndPortID_InLineRec           HS_AC97(0x00000006) /**<Configures headset jack as input, precluding headset use (special port for test purposes). */
00253 #define hsSndPortID_InBaseMic           HS_AC97(0x00000007) /**<Microphone at the base of the smartphone body. */
00254 #define hsSndPortID_InHeadsetMic        HS_AC97(0x00000008) /**<Microphone on a mono headset. Ccomes from left channel as input. */
00255 #define hsSndPortID_InMicAuto           HS_AC97(0x00000009) /**<Atomatic port, according to headset insertion. Use with hsSndSwitchID_OutRadioMic. */
00256 #define hsSndPortID_OutRadioMic         HS_AC97(0x0000000A) /**<Output connected to the Radio microphone input. */
00257 #define hsSndPortID_InRadioSpkr         HS_AC97(0x0000000B) /**<Input from the Radio speaker output. */
00258 #define hsSndPortID_OutHostRec          HS_AC97(0x0000000C) /**<Output to the Host digitized recording input. */
00259 #define hsSndPortID_InHostPlay          HS_AC97(0x0000000D) /**<Input from the Host converted to analog for output to speakers. */
00260 #define hsSndPortID_OutBtHeadset        HS_AC97(0x0000000E) /**<Output port used by InRadioSpkr switch to put Call in bluetooth headset mode. */
00261 #define hsSndPortID_OutBtHandsfree      HS_AC97(0x0000000F) /**<Output port used by InRadioSpkr switch to put Call in bluetooth handsfree mode. */
00262 #define hsSndPortID_InHostBaseMic       HS_AC97(0x00000010) /**<Input port that controls source base port for host recording. */
00263 #define hsSndPortID_InHostHeadsetMic    HS_AC97(0x00000011) /**<Input port controlling source headset port for host recording. */
00264 #define hsSndPortID_InHostPhone         HS_AC97(0x00000012) /**<Input port used by host if phone or TTY is active. */
00265 #define hsSndPortID_InCarkit            HS_AC97(0x00000013) /**<Input port used when wired carkit is activated. */
00266 #define hsSndPortID_OutCarkit           HS_AC97(0x00000014) /**<Output port used when wired carkit is activated. */
00267 #define hsSndPortID_InBtHeadset         HS_AC97(0x00000015) /**<Input port used by OutRadioMic switch to get uplink audio from BT headset. */
00268 #define hsSndPortID_InBtHandsfree       HS_AC97(0x00000016) /**<Input port used by OutRadioMic switch to get uplink audio from BT handsfree mode. */
00269 #define hsSndPortID_LastPort            HS_AC97(0x00000016) /**<Update at end. Same ID as last defined port in sequence. */
00270 /*@}*/
00271
00272 /**
00273  * @name RadioBayID
00274  */
00275 /*@{*/
00276 #define hsSndBayID_Radio                0x02000000 /**<A defined patch bay for Telephony use. */
00277 /*@}*/
00278
00279 /**
00280  * @name Sound switch configuration type for Radio patch bay
00281  *
00282  * Used with HsSndSwitchID.
00283  */
00284 /*@{*/
00285 #define hsSndSwitchID_RadioCall         HS_RDIO(0x00010000) /**<Keeps track of the audio connection of a Radio call. */
00286 /*@}*/
00287
00288 /**
00289  * @name Sound port configuration type for hsSndSwitchID_RadioCall
00290  *
00291  *  hsSndPortID_Off is already defined for all patch bays.  Use it to turn off the switch indicating no radio call connected.
00292  */
00293 /*@{*/
00294 #define hsSndPortID_ConnectCall         HS_RDIO(0x00000020) /**<Virtual port to indicate a radio call is now connected. */
00295 /*@}*/
00296
00297 /**
00298  * @name Sound port classes
00299  *
00300  * Used when passing a HsSndPortClass parameter in HsSndSwitchGetPort and HsSndSwitchSetPort functions.
00301  */
00302 /*@{*/
00303 #define hsSndPortClass_Virtual          ((UInt16) 0) /**<Symbolic port definition that applies to any port. Use for portID save and restore operations. */
00304 #define hsSndPortClass_Real             ((UInt16) 1) /**<Current physical port. Use to change port parameters. Applies only to actual ports, not "auto" ports. */
00305 #define hsSndPortClass_BaseDefault      ((UInt16) 2) /**<Default port to use when restoring a Built-In port (For example, user unplugged headset while "auto" port was enabled.) */
00306 #define hsSndPortClass_Anchor           ((UInt16) 3) /**<Use to obtain the fixed port in a switch that doesn't change--the port that is patched to other ports. Valid only with HsSndSwitchGetPort.  */
00307 /*@}*/
00308
00309 /**
00310  * @name Sound parameters
00311  *
00312  * Used when passing a parameter of type HsSndParam.
00313  */
00314 /*@{*/
00315 #define hsSndParam_Volume               ((UInt16) 1) /**<Changes the volume of a port */
00316 #define hsSndParam_Mute                 ((UInt16) 2) /**<Change the mute state of a port. */
00317 #define hsSndParam_Boost                ((UInt16) 3) /**<Changes the boost state of a port. */
00318 #define hsSndParam_Pan                  ((UInt16) 4) /**<Change the panning value of a port. */
00319 /*@}*/
00320
00321 /**
00322  * @name Sound parameter expansion macros
00323  *
00324  * Used to add sound parameter values for additional sound parameter control.  For example, muteState = HsSndParamValue_SetWithLock(hsSndMute_Enable);.
00325  */
00326 /*@{*/
00327 #define hsSndParamMode_Mask             0x7000  /**<The 3 upper bits after the sign bit in parameter values are reserved for the parameter mode. */
00328 #define hsSndParamMode_Normal           0x0000  /**<Default parameter mode allowing parameter to be changed with any other hsSndParamMode. */
00329 #define hsSndParamMode_LockParam        0x4000  /**<Limits parameter so it can only be changed with hsSndParamMode_LockParam or hsSndParamMode_UnlockParam. */
00330 #define hsSndParamMode_UnlockParam      0x2000  /**<Removes hsSndParamMode_LockParam so it can be changed with any other hsSndParamMode. */
00331 /*@}*/
00332
00333
00334 /**
00335  * @name Mute parameters
00336  * Used to enable or disable a hsSndParam_Mute parameter.
00337  */
00338 /*@{*/
00339 #define hsSndMute_Enable                1   /**<Activates mute on a port. */
00340 #define hsSndMute_Disable               0   /**<Disables mute on a port. */
00341 /*@}*/
00342
00343 /**
00344  * @name Boost parameters
00345  *
00346  * Used to enable or disable a hsSndParam_Boost parameter.
00347  */
00348 /*@{*/
00349 #define hsSndBoost_Enable               1   /**<Activates boost on a port. */
00350 #define hsSndBoost_Disable              0   /**<Disables boost on a port. */
00351 /*@}*/
00352
00353 /**
00354  * @name Pan parameters
00355  *
00356  * Used as special hsSndParam_Pan parameters otherwise use actual Pan value.
00357  */
00358 /*@{*/
00359 #define hsSndPan_Middle                 ((Int16) 0x0000) /**<Pan at midpoint between left and right. */
00360 #define hsSndPan_Right                  ((Int16) 0x7FFF) /**<Pan all the way to the right.  Cannot use with hsSndParamMode (defaults to Normal mode). */
00361 #define hsSndPan_Left                   ((Int16) 0x8000) /**<Pan all the way to the left.  Cannot use with hsSndParamMode (defaults to Normal mode). */
00362 #define hsSndPan_RightNormal            ((Int16) 0x07FF) /**<Pan all the way to the right. Can use with any hsSndParamMode. */
00363 #define hsSndPan_LeftNormal             ((Int16) 0x0800) /**<Pan all the way to the left.  Can use with any hsSndParamMode. */
00364 /*@}*/
00365
00366 /**
00367  * @name Sound port flag settings
00368  *
00369  * Used with the "flags" variable in HsSndPortInfo structure.
00370  */
00371 /*@{*/
00372 #define hsSndPortFlags_Enabled          0x00000001  /**<Port is enabled and in use. */
00373 #define hsSndPortFlags_Disabled         0x00000000  /**<Port is disabled. */
00374 #define hsSndPortFlags_EnableMask       0x00000001  /**<No definition. */
00375
00376 #define hsSndPortFlags_MuteOn           0x00000002  /**<Volume is muted. */
00377 #define hsSndPortFlags_MuteOff          0x00000000  /**<Volume is as specified. (Not muted). */
00378 #define hsSndPortFlags_MuteMask         0x00000002  /**<No definition. */
00379
00380 #define hsSndPortFlags_TypeDigital      0x00000004  /**<Sound data through port is digital. */
00381 #define hsSndPortFlags_TypeAnalog       0x00000000  /**<Sound data through port is analog. */
00382 #define hsSndPortFlags_TypeMask         0x00000004  /**<No definition. */
00383
00384 #define hsSndPortFlags_BoostOn          0x00000008  /**<Boost control on port is active. */
00385 #define hsSndPortFlags_BoostOff         0x00000000  /**<Boost control on port is inactive. */
00386 #define hsSndPortFlags_BoostMask        0x00000008  /**<No definition. */
00387
00388 #define hsSndPortFlags_CanInputOnly     0x00000000  /**<Port is for sound input exclusively. */
00389 #define hsSndPortFlags_CanOutputOnly    0x00000010  /**<Port is for sound output exclusively. */
00390 #define hsSndPortFlags_CanIOSelect      0x00000020  /**<Port can switch between being for sound input or output. */
00391 #define hsSndPortFlags_CanIOBothways    0x00000030  /**<Port can be for sound input and output simultaneously. */
00392 #define hsSndPortFlags_CanIOMask        0x00000030  /**<No definition. */
00393
00394 #define hsSndPortFlags_InputOn          0x00000040  /**<Port as sound input is enabled. */
00395 #define hsSndPortFlags_InputOff         0x00000000  /**<Port as sound input is disabled. */
00396 #define hsSndPortFlags_InputMask        0x00000040  /**<No definition. */
00397
00398 #define hsSndPortFlags_OutputOn         0x00000080  /**<Port as sound output is enabled. */
00399 #define hsSndPortFlags_OutputOff        0x00000000  /**<Port as sound output is disabled. */
00400 #define hsSndPortFlags_OutputMask       0x00000080  /**<No definition. */
00401
00402 #define hsSndPortFlags_CanMute_Yes      0x00000100  /**<Port has mute control available. */
00403 #define hsSndPortFlags_CanMute_No       0x00000000  /**<Port has no mute control. */
00404 #define hsSndPortFlags_CanMuteMask      0x00000100  /**<No definition. */
00405
00406 #define hsSndPortFlags_CanBoost_Yes     0x00000200  /**<Port has boost control available. */
00407 #define hsSndPortFlags_CanBoost_No      0x00000000  /**<Port has no boost control. */
00408 #define hsSndPortFlags_CanBoostMask     0x00000200  /**<No definition. */
00409
00410 #define hsSndPortFlags_CanPan_Yes       0x00000400  /**<Port has pan control available. */
00411 #define hsSndPortFlags_CanPan_No        0x00000000  /**<Port has No pan control. */
00412 #define hsSndPortFlags_CanPanMask       0x00000400  /**<No definition. */
00413
00414 #define hsSndPortFlags_CanVol_Yes       0x00000800  /**<Port has volume control available. */
00415 #define hsSndPortFlags_CanVol_No        0x00000000  /**<Port has No volume control. */
00416 #define hsSndPortFlags_CanVolMask       0x00000800  /**<No definition. */
00417
00418 #define hsSndPortFlags_Mute_Locked      0x00001000  /**<If locked, can only be changed with lock/unlock mute parameter changes. */
00419 #define hsSndPortFlags_Mute_Unlocked    0x00000000  /**<Mute can be changed with any type of mute parameters. */
00420 #define hsSndPortFlags_Mute_LockMask    0x00001000  /**<No definition. */
00421
00422 #define hsSndPortFlags_Boost_Locked     0x00002000  /**<If locked, can only be changed with lock/unlock boost parameter changes/ */
00423 #define hsSndPortFlags_Boost_Unlocked   0x00000000  /**<Boost can be changed with any type of boost parameters. */
00424 #define hsSndPortFlags_Boost_LockMask   0x00002000  /**<No definition. */
00425
00426 #define hsSndPortFlags_Pan_Locked       0x00004000  /**<If locked, can only be changed with lock/unlock pan parameter changes. */
00427 #define hsSndPortFlags_Pan_Unlocked     0x00000000  /**<Pan can be changed with any type of pan parameters. */
00428 #define hsSndPortFlags_Pan_LockMask     0x00004000  /**<No definition. */
00429
00430 #define hsSndPortFlags_Vol_Locked       0x00008000  /**<If locked, can only be changed with lock/unlock volume parameter changes. */
00431 #define hsSndPortFlags_Vol_Unlocked     0x00000000  /**<Volume can be changed with any type of volume parameters. */
00432 #define hsSndPortFlags_Vol_LockMask     0x00008000  /**<No definition. */
00433 /*@}*/
00434
00435 /**
00436  * @brief Holds sound port information.
00437  */
00438 typedef struct
00439 {
00440     UInt32      signature;   /**< Always set to hsSndPortInfo_Signature. */
00441     UInt32      flags;       /**< Control and information about port. */
00442     HsSndPortID portID;      /**< Identifies the portID. */
00443     Int16       minVol;      /**< Bottom value of the volume range.*/
00444     Int16       maxVol;      /**< Top value of the volume range.*/
00445     Int16       unityVol;    /**< Volume value when there is no gain or dampening.*/
00446     Int16       stepVol;     /**< Step size for volume changes within vol range.*/
00447     Int16       currentVol;  /**< Tracks current volume setting.*/
00448     Int16       currentPan;  /**< Pan control (0 is midpoint pan between L and R) max pan = maxVol - minVol. */
00449     UInt16      stepDB;      /**< How many dBs per step = (stepDB >> 8) / (stepDB & 0x0F). */
00450     UInt16      boostDB;     /**< How many dBs with boost = (boostDB >> 8) / (boostDB & 0x0F). */
00451     UInt16      reserved1;   /**< Reserved field, set to zero */
00452     UInt16      reserved2;   /**< Reserved field, set to zero */
00453 } HsSndPortInfo, *HsSndPortInfoPtr;
00454
00455
00456 /**
00457  * @name Command flag settings
00458  *
00459  * Used with the "Commandflags" parameter in HsSndFormatPlay function.
00460  */
00461 /*@{*/
00462 #define hsSndCmdFlags_noWait        0x00000001  /**< Use wait period for the play command. */
00463 #define hsSndCmdFlags_yesWait       0x00000000  /**< No wait period for the play command. */
00464 #define hsSndCmdFlags_waitMask      0x00000001 /**<No definition. */
00465 /*@}*/
00466
00467
00468 /**
00469  * Sound formats
00470  */
00471 enum HsSndFormatEnumTag
00472 {
00473     hsSndFormatMidi = 2, /**<Midi format. */
00474     hsSndFormatAmr, /**<Obsolete.  Use Codec Plug-in Manager or streaming component. */
00475     pmSndFormatSetAttackEnvID, /**<For internal use only (escape code used by PmSndStreamSetAttackEnvID macro function). */
00476     pmSndFormatPauseStream, /**<For internal use only (escape code used by PmSndStreamPause macro function). */
00477     pmSndFormatResumeStream, /**<For internal use only (escape code used by PmSndStreamResume macro function). */
00478     pmSndFormatSetStoppable /**<For internal use only (escape code used by PmSndStreamStoppable macro function). */
00479 };
00480
00481
00482 /**
00483  * @name Sound buffer flag settings
00484  *
00485  * Used with the "flags" parameter in HsSndBufferData.
00486  */
00487  /*@{*/
00488 #define hsSndBufFlags_canInterrupt        0x0001 /**< Playback can be interrupted by user events. */
00489 #define hsSndBufFlags_cannotInterrupt     0x0000 /**< (Default) Playback cannot be interrupted by user events. */
00490 #define hsSndBufFlags_interruptMask       0x0001 /**<No definition. */
00491
00492 #define hsSndBufFlags_yesRepeat           0x0002 /**< Repeat the buffer using the "repeat" count in HsSndBufferData.controls. */
00493 #define hsSndBufFlags_noRepeat            0x0000 /**< (Default) Buffer used only once. */
00494 #define hsSndBufFlags_repeatMask          0x0002 /**<No definition. */
00495
00496 #define hsSndBufFlags_yesEndDelay         0x0004 /**< Delay completion of playback using the "delay" count in HsSndBufferData.controls. */
00497 #define hsSndBufFlags_noEndDelay          0x0000 /**< (Default) No delay after last batch of audio data processed. */
00498 #define hsSndBufFlags_endDelayMask        0x0004 /**<No definition. */
00499
00500 #define hsSndBufFlags_attackEnvNone       0x0000 /**< (Default) No attack envelope to be used. */
00501 #define hsSndBufFlags_attackEnvRings      0x0010 /**< Use special attack envelope style suitable for call ringtones. */
00502 #define hsSndBufFlags_attackEnvVibeNone   0x0020 /**< Use special attack envelope with initial vibration before envelope */
00503 #define hsSndBufFlags_attackEnvVibeRings  0x0030 /**< Use special attack envelope for ringtones with initial vibration before envelope */
00504 #define hsSndBufFlags_attackEnvRings2     0x0040 /**< Use type 2 attack envelope suitable for call ringtones (stright ramp up) */
00505 #define hsSndBufFlags_attackEnvReserved1  0x0050 /**< Reserved for future use. Do Not use */
00506 #define hsSndBufFlags_attackEnvVibeRings2 0x0060 /**< Use type 2 attack enveloper with initial vibration before envelope */
00507 #define hsSndBufFlags_attackEnvReserved2  0x0070 /**< Reserved for future use. Do Not use */
00508 #define hsSndBufFlags_attackEnvMask       0x00F0 /**< Mask reserves up to 16 different envelope IDs. */
00509
00510 #define hsSndBufFlags_interruptDefault    0x0000 /**< (Default) interrupt sound on most user events if hsSndBufFlags_canInterrupt flag is set. */
00511 #define hsSndBufFlags_interruptPhone      0x0100 /**< interrupt on user events (except Touch, Navigation arrows and pens down). */
00512 #define hsSndBufFlags_interruptModeMask   0x0300 /**< Mask reserves 2 bits for up to 4 different interrupt modes. */
00513 /*@}*/
00514
00515 /**
00516  * @name Buffer amplitude settings
00517  *
00518  * Used with HsSndBufferData.amplitude field.
00519  */
00520 /*@{*/
00521 #define hsSndAmplitude_silent           ((UInt32) 0)    /**< Minimum volume value used to silent a port */
00522 #define hsSndAmplitude_unity            ((UInt32) 1024) /**< Volume value used to pass through sound without amplification or attenuation. */
00523 /*@}*/
00524
00525 /******************************************************************************/
00526 /* HsSndBufferProc */
00527 /**
00528    @brief Callback function used under various conditions with sound.
00529
00530    @param userdata      IN  Userdata passed when setting the callback routine
00531    @param flags         IN  Copy of the HsSndBufferData flags field
00532    @param buffer        IN  Pointer originally passed in HsSndBufferData
00533    @param bytesUsed     OUT How many bytes have been consumed from the buffer
00534    @param time          OUT Number of milliseconds available for callback processing
00535
00536    @return              Error code.
00537
00538 *******************************************************************************/
00539 typedef Err (*HsSndBufferProc)  (void * userdata, UInt32 flags,
00540                                  void * buffer, UInt32 bytesUsed, UInt32 time);
00541
00542 /**
00543  * @brief Holds sound buffer information.
00544  *
00545  * When using the hsSndCmdPlay command in function HsSndFormatPlay,
00546  * you should pass a pointer to a properly filled HsSndBufferData
00547  * structure. This structure provides information about the buffer
00548  * of coded audio data that is going to be processed and played.
00549  */
00550 typedef struct HsSndBufferData
00551 {
00552     UInt32          signature;  /**<Always set to hsSndBufferData_Signature or error returned. */
00553     UInt32          flags;      /**<Flags and status bits for the buffer. Use the hsSndBufferFlags_* symbols appropriately.  Set any undefined or unused flags to zero.*/
00554     UInt32          amplitude;  /**<Volume level for playback. (Valid range from 0 to hsSndAmplitude_unity.)*/
00555     void *          buffer;     /**<Pointer to beginning of coded audio data to process and/or play. */
00556     UInt32          bufferSize; /**<Size in bytes of the buffer of coded audio data. */
00557     HsSndBufferProc progress_callback; /**<When Not NULL, is invoked at regular intervals. If progress_callback returns an error, then the play session terminates.*/
00558     void *          progress_userdata; /**<Passed to progress_callback when invoked. */
00559     HsSndBufferProc completion_callback; /**<When Not NULL, it will be invoked when buffer processing completed. */
00560     void *          completion_userdata; /**<Passed to completion_callback when invoked. */
00561
00562    /**
00563     * Compound field with repeat count and end delay controls.
00564     * Use HsSndBufControl_Set* macros with this field. Repeat Field: valid range from 1 to 254,
00565     * or hsSndBufControl_repeatForever (255). The processing of the buffer will be looped
00566     * according to this number. When repeatForever is used, then termination should be
00567     * done by returning an error code from the progress callback. Alternatively,
00568     * for non-blocking playback, the caller may issue another "Play" call with the "Stop"
00569     * command. This field is valid and non-zero when hsSndBufFlags_yesRepeat is set
00570     * in the buffer flags, otherwise this field must be set to zero. A repeat value of 1
00571     * means play one time. Values of 2 and greater will perform the requested number of
00572     * playbacks by looping on the same buffer data. Use HsSndBufControl_SetRepeat macro to set
00573     * values in this field. endDelay fld:  Valid range from 1 to 255, each unit is a
00574     * 1/50th second delay. Use HsSndBufControl_SetEndDelay macro to set values in this field.
00575     * This field is valid and non-zero when hsSndBufFlags_yesEndDelay is set in the buffer
00576     * flags, otherwise this field must be set to zero.
00577     */
00578     UInt32          controls;
00579     UInt32          reserved1;  /**<reserved, must set to zero*/
00580     UInt32          reserved2;  /**<reserved, must set to zero*/
00581
00582 } HsSndBufferData;
00583
00584
00585 #define hsSndMidiMsg_SetVolume  1
00586
00587
00588 #if CPU_ENDIAN == CPU_ENDIAN_BIG
00589     #define hsSndMidiProgressMsg_Signature  'MidP'
00590 #else
00591     #define hsSndMidiProgressMsg_Signature  'PdiM' /* 'MidP' char array as UInt32 little endian */
00592 #endif
00593 typedef struct HsSndMidiProgressMsg
00594 {
00595     UInt32      signature;
00596     UInt32      msgType;
00597     UInt32      param1;
00598     UInt32      param2;
00599
00600 } HsSndMidiProgressMsg;
00601
00602
00603 #if CPU_ENDIAN == CPU_ENDIAN_BIG
00604     #define hsSndPortInfo_Signature 'SPRT'
00605 #else
00606     #define hsSndPortInfo_Signature 'TRPS' /* "SPRT" char array as UInt32 little endian */
00607 #endif
00608
00609 #if CPU_ENDIAN == CPU_ENDIAN_BIG
00610     #define hsSndBufferData_Signature   'SBDA'
00611 #else
00612     #define hsSndBufferData_Signature   'ADBS' /* 'SBDA' as little endian UInt32 */
00613 #endif
00614
00615 /**
00616  * @name Buffer control macros
00617  *
00618  * Use these macros to set or get the proper control in
00619  * HsSndBufferData.controls field.
00620  */
00621 /*@{*/
00622 #define HsSndBufControl_SetRepeat(controls, value)   (controls = ((controls & 0xFFFFFF00) |  (((UInt32) value) & 0xFF)      ))
00623 #define HsSndBufControl_GetRepeat(controls)          (controls & 0x000000FF)
00624 #define HsSndBufControl_SetEndDelay(controls, value) (controls = ((controls & 0xFFFF00FF) | ((((UInt32) value) & 0xFF) << 8)))
00625 #define HsSndBufControl_GetEndDelay(controls)        ((controls & 0x0000FF00) >> 8)
00626 #define hsSndBufControl_repeatForever                (0xFF)
00627 /*@}*/
00628
00629
00630 // ===============================================================================================
00631 // Gain Envelope Feature Support
00632 // ===============================================================================================
00633 /**
00634  * @name Gain Envelope Definitions
00635  *
00636  * Used as attackEnvID parameter to function PmSndStreamSetAttackEnvID.
00637  */
00638  /*@{*/
00639 #define pmSndAttackEnvIDRings       (hsSndBufFlags_attackEnvRings)      /**< The ringtone attack envelope ramp-up to low volume initially, and to full volume after about 4 seconds */
00640 #define pmSndAttackEnvIDVibeRing    (hsSndBufFlags_attackEnvVibeRings)  /**< Vibrate for 4 seconds, then behave as pmSndAttackEnvIDRings */
00641 #define pmSndAttackEnvIDRings2      (hsSndBufFlags_attackEnvRings2)     /**< The ringtone attack envelope ramp-up in about 1 second */
00642 #define pmSndAttackEnvIDVibeRing2   (hsSndBufFlags_attackEnvVibeRings2) /**< Vibrate for 4 seconds, then behave as pmSndAttackEnvIDRings2 */
00643
00644
00645 // ===============================================================================================
00646 // Sound Preference Definitions (compatible with SndBayID and SndPortID)
00647 // ===============================================================================================
00648 #define pmSndBayID_AUDP                 0x0F000000 /**< we are reserving SndBayID 15 for audio preference purposes */
00649
00650 #define PM_AUDP_CLASS_MASK              0x4000
00651 // Utility macro to associate special port class marker to this IDs (so we can use it as an HsSndPortClass parameter)
00652 #define PM_AUDP_CLASS(n)                ((n) | PM_AUDP_CLASS_MASK) /**< utility to associate preferences class marker to prefIDs */
00653
00654 #define pmSndPrefID_AppsGroupHoldType   PM_AUDP_CLASS(0x0001) /**< specify how to hold application audio (mute/pause) */
00655 #define pmSndPrefID_JackOutIfMicUnused  PM_AUDP_CLASS(0x0002) /**< shall we force jack out to stereo if Mic not in use? */
00656 #define pmSndPrefID_PhoneRxGainLimit    PM_AUDP_CLASS(0x0003) /**< set if gain-limit phone Rx to receiver speaker */
00657 #define pmSndPrefID_WakeOnAnswerBtn     PM_AUDP_CLASS(0x0004) /**< set to be able to wake device when headset answer button is pressed */
00658 #define pmSndPrefID_AudioTable          PM_AUDP_CLASS(0x0005) /**< pass pointer to PmSndGain8Table to load for use, pass zero to return to default */
00659 #define pmSndPrefID_GsmMccArray         PM_AUDP_CLASS(0x0006) /**< pass pointer to PmSndGsmMccArray to load for use, pass zero to return to default */
00660 #define pmSndPrefID_AthenaActive        PM_AUDP_CLASS(0x0007) /**< set to activate audio paths to multi-connector, clear to return to normal (used for wired carkit mode) */
00661 #define pmSndPrefID_SleepMode           PM_AUDP_CLASS(0x0008) /**< set to zero for normal sleep, other values for partial audio sleep modes (for internal use only) */
00662 #define pmSndPrefID_AGCEvent            PM_AUDP_CLASS(0x0009) /**< set to temporarily activate AGC if required (only useful when AGC has been disabled before hand) */
00663 #define pmSndPrefID_AthenaAudio         PM_AUDP_CLASS(0x000A) /**< set to activate or deactivate automatic routing of audio to Athena connector */
00664
00665 typedef UInt16  PmSndPrefID;
00666
00667 // Parameters to use with pmSndPrefID_WakeOnAnswerBtn
00668 #define pmSndPref_WakeOnAnswerBtn_Disable   (0) /**< disable wake up on answer button feature */
00669 #define pmSndPref_WakeOnAnswerBtn_Enable    (1) /**< enable  wake up on answer button feature */
00670
00671 // Parameters to use with pmSndPrefID_AthenaActive
00672 #define pmSndPref_AthenaActive_No           (0) /**< disable routing to Athena path for automatic switches */
00673 #define pmSndPref_AthenaActive_Yes          (1) /**< enable routing to Athena path for automatic switches */
00674
00675 // Parameters to use with pmSndPrefID_AthenaAudio
00676 #define pmSndPref_AthenaAudio_NoRouting     (0)  /**< no athena audio routing when Athena audio connection detected. Handled elsewhere or through pmSndPrefID_AthenaActive */
00677 #define pmSndPref_AthenaAudio_IfMicPresent  (16) /**< when Athena audio class detected, only route if Mic is also present */
00678 #define pmSndPref_AthenaAudio_Unconditional (32) /**< cause unconditional audio routing if Athena audio class detected */
00679
00680 // Utility macro to associate the hsSndBayID_Radio to other elements
00681 #define PM_AUDP(n)                      ((n) | pmSndBayID_AUDP) /**< utility to associate the Preference Bay ID with other element ID */
00682
00683 // Use these for HsSndSwitchID in the Preferences patch bay
00684 #define pmSndSwitchID_Preferences       PM_AUDP(0x00400000) /**< used with the HsSoundLib Switch calls to set and get sound preference data */
00685
00686
00687 // ===============================================================================================
00688 // Media Synchronization Definitions
00689 // ===============================================================================================
00690 typedef UInt32   PmClkTickRef;
00691
00692 #define pmAudioClkTickRef   ((PmClkTickRef) 0x00000001) /**< use as PmClkTickRef when requiring audio tick clock */
00693
00694 #endif // __HSSOUNDLIB_COMMON__H__
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:53 2008 for Palm API Guide


Header Files » Incs » common » libraries » hssoundlib

HsSoundLibTraps.h

Go to the documentation of this file.
00001 /*******************************************************************************
00002  * Copyright (c) 2004-2005 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  ******************************************************************************/
00005 /**
00006  * @ingroup Sound
00007  */
00008
00009 /**
00010  * file     HsSoundLibTraps.h
00011  * brief    Public 68k common header file for Sound Library on Treo devices.
00012  *
00013  * This file contains the function trap numbers for the Sound Library APIs.
00014  */
00015
00016 #ifndef __HSSOUNDLIB_TRAPS__H__
00017 #define __HSSOUNDLIB_TRAPS__H__
00018
00019 /***********************************************************************
00020  * Palm OS common definitions
00021  ***********************************************************************/
00022 #include <PalmTypes.h>
00023
00024 #if 0
00025 #pragma mark -------- Constants --------
00026 #endif
00027
00028 /**
00029  * @name Function Traps
00030  *
00031  */
00032 /*@{*/
00033 #define kHsSoundLibTrapOpen           (sysLibTrapOpen)  /**<No definition. */
00034 #define kHsSoundLibTrapClose          (sysLibTrapClose) /**<No definition. */
00035
00036 #define kHsSoundLibTrapGetVersion     (sysLibTrapCustom + 0) /**<No definition. */
00037 #define kHsSoundLibTrapPortGetInfo    (sysLibTrapCustom + 1) /**<No definition. */
00038 #define kHsSoundLibTrapPortSetParam   (sysLibTrapCustom + 2) /**<No definition. */
00039 #define kHsSoundLibTrapSwitchGetPort  (sysLibTrapCustom + 3) /**<No definition. */
00040 #define kHsSoundLibTrapSwitchSetPort  (sysLibTrapCustom + 4) /**<No definition. */
00041 #define kHsSoundLibTrapTonePlay       (sysLibTrapCustom + 5) /**<No definition. */
00042 #define kHsSoundLibTrapToneStop       (sysLibTrapCustom + 6) /**<No definition. */
00043 #define kHsSoundLibTrapFormatPlay     (sysLibTrapCustom + 7) /**<No definition. */
00044 #define kHsSoundLibTrapFormatRecord   (sysLibTrapCustom + 8) /**<No definition. */
00045 #define kHsSoundLibTrapGetUserVolume  (sysLibTrapCustom + 9) /**<No definition. */
00046 #define kHsSoundLibTrapSetUserVolume  (sysLibTrapCustom + 10) /**<No definition. */
00047 #define kPmSoundLibTrapClkGetTicksPerSecond (sysLibTrapCustom + 11) /**<No definition. */
00048 #define kPmSoundLibTrapClkGetTickCount (sysLibTrapCustom + 12) /**<No definition. */
00049 #define kPmSoundLibTrapGetPosition     (sysLibTrapCustom + 13) /**<No definition. */
00050 #define kPmSoundLibTrapReserved        (sysLibTrapCustom + 14) /**<No definition. */
00051 /*@}*/
00052
00053 #endif // INCLUDE ONCE -- __HSSOUNDLIB_TRAPS__H__
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:53 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » htmllib

HtmlLib68K.h

Go to the documentation of this file.
00001 /*
00002     HtmlLib68K.h
00003     Copyright(c) 1996-2002 ACCESS CO., LTD.
00004     All rights are reserved by ACCESS CO., LTD., whether the whole or
00005     part of the source code including any modifications.
00006 */
00007
00008  /** @defgroup HtmlLib HTML Library
00009  * The HTML Library helps applications render data. Please note that there is a limit of 64K of text data for a single content data object, so it is recommended that you do appropriate checks when adding text data for rendering, especially when adding text data repeatedly.
00010  * Additionally, the caller application is required to provide a set of form widget creation functions to the Html Library for dynamic UI creation. Please see the HtmlLibSetFormWidgetProc routine for details.
00011  *
00012  * @note It is important to be aware that this library modifies the active form pointer, so make sure to NOT cache the form pointer, but re-get it before use.
00013  *
00014  * @{
00015  * @}
00016  */
00017  /**
00018  @ingroup HtmlLib
00019  */
00020
00021 /**
00022 *
00023 * @file HtmlLib68K.h
00024 *
00025 * @brief Public 68K include file for HTML shared library.
00026 *
00027 */
00028
00029 #ifndef HTMLLIb68K_H__
00030 #define HTMLLIb68K_H__
00031
00032 #include <PalmTypes.h>
00033 #include <LibTraps.h>
00034
00035 #include <HtmlLibTrap.h>
00036
00037 #include <ErrorBase.h>
00038
00039 #define htmlErrorClass  (appErrorClass)
00040
00041 /**
00042  * @name HtmlLib error codes
00043  *
00044  */
00045  /*@{*/
00046 /************************************************************
00047  * HtmlLib error codes
00048  *************************************************************/
00049 #define htmlErrInUse            (htmlErrorClass | 1)
00050 #define htmlErrOutOfMemory      (htmlErrorClass | 2)
00051 #define htmlErrInvalidParam     (htmlErrorClass | 3)
00052 #define htmlErrNotFound         (htmlErrorClass | 4)
00053 #define htmlErrNotInitialized   (htmlErrorClass | 5)
00054 #define htmlErrCantOpen         (htmlErrorClass | 6)
00055 /*@}*/
00056
00057 #define htmlLibProgressEvent    (0x7000)
00058
00059 /************************************************************
00060  * HtmlLib l
00061  *************************************************************/
00062
00063 #define HtmlLibID       'AsHL'
00064 #define HtmlLibDBType   'libr'
00065 #define HtmlLibName     "HtmlLibrary"
00066
00067
00068 /*
00069  * Typedef
00070  */
00071
00072 /**
00073  * @name Typedef
00074  */
00075 /*@{*/
00076 typedef UInt8 HtmlDisplayMode;
00077 typedef UInt16 HtmlProgressStatus;
00078 typedef UInt32 HtmlSubmitFormMethod;
00079 typedef Int8 HtmlScrollDirection;
00080 typedef Int8 HtmlScrollbarMode;
00081
00082
00083 /* HtmlFocusTargetType */
00084 #define htmlTargetImage             0x01
00085 #define htmlTargetEmbed             0x02
00086 #define htmlTargetIFrame            0x03
00087 #define htmlTargetElement           0x04
00088 #define htmlTargetInputText         0x05
00089 #define htmlTargetInputPassword     0x06
00090 #define htmlTargetInputCheckbox     0x07
00091 #define htmlTargetInputRadio        0x08
00092 #define htmlTargetInputSubmit       0x09
00093 #define htmlTargetInputReset        0x0a
00094 #define htmlTargetInputFile         0x0b
00095 #define htmlTargetInputButton       0x0c
00096 #define htmlTargetInputTextarea     0x0d
00097 #define htmlTargetInputSelect       0x0e
00098
00099 typedef UInt16 HtmlFocusTargetType;
00100
00101 /**
00102  * @name Callback Functions
00103  */
00104 /*@{*/
00105
00106
00107 /**
00108  *Should be defined (to handle a link selection) and set as the function to be called when a link (url) is selected.
00109  */
00110 typedef void HtmlLibLinkSelCallback(MemHandle htmlLibH, Char *url, void *cbData);
00111
00112 /**
00113  *Should be defined and set as the function to be called when it's necessary to determine if a string of numbers contains a phone number.
00114  *
00115  * Here, buffer contains the string of numbers that are being checked, and this is passed in by the library when the library calls this function. Length is the buffer's length, also passed in by the library. The last two arguments (patternStart and patternEnd) should get set in this callback function if the string of numbers passed in is determined to be a phone number (and thus the return value of the function is to be true). Now, patternStart is the place in the buffer that the phone number starts, and patternEnd is the place in the buffer that the pattern ends. For example, if the entire contents of the buffer passed in happened to be a phone number, then the start would be 0 and the end would be "length - 1", and the return value would be true. However, if what was passed in was not determined to be a phone number, then the return value of the callback function should be false, and the last two arguments do not need to be set.
00116  */
00117 typedef Boolean HtmlLibScanPhoneNumberCallback(MemHandle htmlLibH, Char *buffer, Int32 length, Int32 *patternStart, Int32 *patternEnd);
00118
00119 /**
00120  *Should be defined and set as the function to be called when rendering a page requires additional content.
00121  *
00122  * HtmlLib calls this callback function with the appropriate arguments (where the url is the url of the additional content the library requires).
00123  */
00124 typedef void HtmlLibInclusionCallback(MemHandle htmlLibH, Char *url, void *cbData);
00125
00126 /**
00127  * @note Forms are not supported; thus, use this at your own risk.
00128  *
00129  *Should be defined and set as the function to be called when a submit is activated.
00130  *
00131  * HtmlLib calls this callback function with the appropriate arguments. The following is an example (included in the sample code):
00132  *
00133  * @code
00134  *
00135  * void HtmlSubmitFormCallback(MemHandle htmlLibH, Char *url, HtmlSubmitFormMethod method, Char *query, void *cbData)
00136  * {
00137  *   FrmCustomAlert(SubmitFormAlert, url,
00138  *      (method == htmlHttpMethodPost ? "Post" : "Get"), query);
00139  * }
00140  *
00141  * @endcode
00142  *
00143  */
00144 typedef void HtmlLibSubmitFormCallback(MemHandle htmlLibH, Char *url, HtmlSubmitFormMethod method, Char *query, void *cbData);
00145
00146 typedef Boolean NewControlProc(UInt16 id,
00147     UInt16 style, const Char *textP,
00148     Coord x, Coord y, Coord width, Coord height,
00149     UInt16 font, UInt8 group, Boolean leftAnchor); /**< @see HtmlLibFormWidgetProc*/
00150
00151 typedef Err NewListProc(UInt16 id,
00152                     Coord x, Coord y, Coord width, Coord height,
00153                     UInt16 font, Int16 visibleItems, Int16 triggerId); /**< @see HtmlLibFormWidgetProc*/
00154
00155 typedef Boolean NewFieldProc(UInt16 id,
00156     Coord x, Coord y, Coord width, Coord height,
00157     UInt16 font, UInt32 maxChars, UInt16 editable, UInt16 underlined,
00158     UInt16 singleLine, UInt16 dynamicSize, UInt16 justification,
00159     UInt16 autoShift, UInt16 hasScrollBar, UInt16 numeric);  /**< @see HtmlLibFormWidgetProc*/
00160
00161 typedef void DeleteObjectProc(UInt16 index); /**< @see HtmlLibFormWidgetProc*/
00162
00163 /** @brief The following are necessary form widget creation/deletion routines that need to get set using HtmlLibSetFormWidgetProc. Please see sample code after looking at HtmlLibSetFormWidgetProc.
00164 *
00165 * @see HtmlLibSetFormWidgetProc
00166 */
00167 typedef struct {
00168     NewControlProc *newControlProc;
00169     NewListProc *newListProc;
00170     NewFieldProc *newFieldProc;
00171     DeleteObjectProc *deleteObjectProc;
00172 } HtmlLibFormWidgetProc;
00173 /*@}*/
00174
00175 /* HtmlLibFocusTargetInfo */
00176 typedef struct {
00177     HtmlFocusTargetType type;
00178     RectangleType bounds; /* in window coordinate */
00179     UInt16 formObjectID;  /* set only for form object */
00180 } HtmlLibFocusTargetInfo;
00181
00182
00183 /* HtmlDisplayMode */
00184 /** @name HtmlDisplayMode */
00185 /*@{*/
00186 #define htmlHandheldDisplayMode 0x01
00187 #define htmlFaithfulDisplayMode 0x02
00188 /*@}*/
00189
00190
00191 /* HtmlProgressStatus */
00192 /** @name HtmlProgressStatus */
00193 /*@{*/
00194 #define htmlProgressDone        0x0001
00195 #define htmlProgressBusy        0x0002
00196 #define htmlProgressOutOfMemory 0x0003
00197 #define htmlProgressError       0x0004
00198 /*@}*/
00199
00200
00201 /* HtmlSubmitFormMethod */
00202 /** @name HtmlSubmitFormMethod */
00203 /*@{*/
00204 #define htmlHttpMethodGet   0x00000001
00205 #define htmlHttpMethodPost  0x00000002
00206 /*@}*/
00207
00208
00209 /* HtmlDirections */
00210 /** @name HtmlDirections */
00211 /*@{*/
00212 #define htmlDirLeft         0x01
00213 #define htmlDirRight        0x02
00214 #define htmlDirUp           0x03
00215 #define htmlDirDown         0x04
00216 /*@}*/
00217
00218
00219 /* HtmlScrollMode */
00220 /** @name HtmlScrollMode */
00221 /*@{*/
00222 #define htmlNormalScrollbarMode 0x01
00223 #define htmlNoPageScrollbarMode 0x02
00224 /*@}*/
00225
00226
00227 /*@}*/
00228 /*
00229  * API
00230  */
00231
00232 /** Standard library open routine.
00233  *
00234  * @param refun IN: the library reference number
00235  *
00236  * @return Error code.
00237  */
00238 Err HtmlLibOpen(UInt16 refnum)
00239         SYS_TRAP(kHtmlLibTrapOpen);
00240
00241 /** Standard library close routine.
00242  *
00243  * @param refun IN: the library reference number
00244  *
00245  * @return Error code.
00246  */
00247 Err HtmlLibClose(UInt16 refnum)
00248         SYS_TRAP(kHtmlLibTrapClose);
00249
00250 /** Standard library sleep routine.
00251  *
00252  * @param refun IN: the library reference number
00253  *
00254  * @return Error code.
00255  */
00256 Err HtmlLibSleep(UInt16 refnum)
00257         SYS_TRAP(kHtmlLibTrapSleep);
00258
00259 /** Standard library wake routine.
00260  *
00261  * @param refun IN: the library reference number
00262  *
00263  * @return Error code.
00264  */
00265 Err HtmlLibWake(UInt16 refnum)
00266         SYS_TRAP(kHtmlLibTrapWake);
00267
00268 /** Html Library initialization function.
00269  * Initializes the library, after the library has been loaded.
00270  *
00271  * @param   refNum      IN: the library reference number
00272  * @param   bounds      IN: the screen area the library will draw the rendered content (bounds within 160 x 160 grid)
00273  * @param    errP       IN: error code if library fails to initialize. The error code can be one of
00274  * (htmlErrInUse, htmlErrOutOfMemory, htmlErrInvalidParam, htmlErrInUse, htmlErrCantOpen)
00275  *
00276  * @return A memory handle to the HTML library context.
00277  */
00278 MemHandle HtmlLibInitialize(UInt16 refnum, RectangleType bounds, Err *errP)
00279         SYS_TRAP(kHtmlLibTrapInitialize);
00280
00281 MemHandle HtmlLibInitializeWithHeapSize(UInt16 refnum, RectangleType bounds, Err *errP, UInt32 heapMinSize, UInt32 heapDesiredSize, UInt32 *heapActualSizeP)
00282         SYS_TRAP(kHtmlLibTrapInitializeWithHeapSize);
00283
00284 /** Finalizes the library when you are done using it
00285  * @note  If you need to use the library again after it has been finalized, you will need to re-initialize it.
00286  *
00287  * @param refNum  IN: the library reference number
00288  * @param htmlLibH IN: the memory handle returned by HtmlLibInitialize
00289  */
00290 void HtmlLibFinalize(UInt16 refnum, MemHandle htmllibH)
00291         SYS_TRAP(kHtmlLibTrapFinalize);
00292
00293 /** Resize the screen area.
00294  *
00295  * @param refNum IN: the library reference number
00296  * @param htmlLibH IN: the memory handle returned by HtmlLibInitialize
00297  * @param newBounds IN: the new bounds of the screen area (bounds within 160 x 160 grid)
00298  *
00299  * @return errNone if resize is successful, otherwise returns an error code (errInvalidParam)
00300  */
00301 void HtmlLibResizeScreen(UInt16 refnum, MemHandle htmlLibH, RectangleType newBounds)
00302         SYS_TRAP(kHtmlLibTrapResizeScreen);
00303
00304 /** Sets the display mode (faithful rendering, which corresponds to Blazer's Wide Page Mode, or handheld wrapped, which corresponds to Blazer's Optimized Mode).
00305  *
00306  * @param refNum IN: the library reference number
00307  * @param htmlLibH IN: the memory handle returned by HtmlLibInitialize
00308  * @param mode IN: display mode (htmlFaithfulDisplayMode or htmlHandheldDisplayMode)
00309  *
00310  */
00311 void HtmlLibSetDisplayMode(UInt16 refnum, MemHandle htmlLibH, HtmlDisplayMode mode)
00312         SYS_TRAP(kHtmlLibTrapSetDisplayMode);
00313
00314 /** Specify the function that you want the library to call when a link is followed.
00315  *
00316  * @param refNum  IN: the library reference number
00317  * @param htmlLibH  IN: the memory handle returned by HtmlLibInitialize
00318  * @param callback IN: a pointer to the function you want called when a link is followed.
00319  * @param cbData I/O: the library does nothing with this parameter except pass it on as one of the arguments to your callback function. To not take advantage of this feature, just pass in NULL.
00320  *
00321  * @note  The callback function should be in the following form:
00322  *   void HtmlLinkSelCallback(MemHandle htmlLibH, Char *url, void *cbData);
00323  * The library will call this function, supplying the appropriate arguments (where the url is the url of the link which was selected).
00324  * @see HtmlLibLinkSelCallback
00325  */
00326 void HtmlLibSetLinkSelectionCallback(UInt16 refnum, MemHandle htmlLibH, HtmlLibLinkSelCallback *callback, void *cbData)
00327         SYS_TRAP(kHtmlLibTrapSetLinkSelectionCallback);
00328
00329 /** Specify the function that you want the library to call to determine whether some string of numbers contains a phone number.
00330  *
00331  * @param refNum IN: the library reference number
00332  * @param htmlLibH IN: the memory handle returned by HtmlLibInitialize
00333  * @param callback IN: a pointer to the function that HtmlLib will call to determine whether a string of numbers is a phone number, and should be handled as such.
00334  *
00335  * @note  The callback function should be in the following form:
00336  * Boolean HtmlLibScanPhoneNumberCallback(MemHandle htmlLibH, Char   *buffer, Int32 length, Int32 *patternStart, Int32 *patternEnd);
00337  *
00338  * @see HtmlLibScanPhoneNumberCallback
00339  */
00340 void HtmlLibSetScanPhoneNumberCallback(UInt16 refnum, MemHandle htmlLibH, HtmlLibScanPhoneNumberCallback *callback)
00341         SYS_TRAP(kHtmlLibTrapSetScanPhoneNumberCallback);
00342
00343 /** Specify the function that you want the library to call when rendering a page requires additional content (an image that hasn't been added, an external style sheet, etc).
00344  *
00345  * @param refNum IN: the library reference number
00346  * @param htmlLibH IN: the memory handle returned by HtmlLibInitialize
00347  * @param callback IN: a pointer to the function you want called when rendering a page that requires additional content.
00348  * @param cbData I/O: the library does nothing with this parameter except pass it on as one of the arguments to your callback function. To not take advantage of this feature, just pass in NULL.
00349  *
00350  * @note: The callback function should be in the following form:
00351  * void HtmlLibInclusionCallback(MemHandle htmlLibH, Char *url, void *cbData);
00352  *
00353  * HtmlLib calls this callback function with the appropriate arguments (where the url is the url of the additional content the library requires).
00354  *
00355  * @see HtmlLibInclusionCallback
00356  *
00357  */
00358 void HtmlLibSetInclusionCallback(UInt16 refnum, MemHandle htmlLibH, HtmlLibInclusionCallback *callback, void *cbData)
00359         SYS_TRAP(kHtmlLibTrapSetInclusionCallback);
00360
00361 /** @note:  Forms are not supported; thus, use this at your own risk.
00362  *
00363  * This functions lets you specify the function that you want the library to call when a "submit" is activated.
00364  *
00365  * @param refNum IN: the library reference number
00366  * @param htmlLibH IN: the memory handle returned by HtmlLibInitialize
00367  * @param callback IN: a pointer to the function you want called when a "submit" is activated
00368  * @param cbData I/O: the library does nothing with this parameter except pass it on as one of the arguments to your callback function. To not take advantage of this feature, just pass in NULL.
00369  *
00370  * @note  The callback function should be in the following form:
00371  *
00372  * HtmlLibSubmitFormCallback(MemHandle htmlLibH, Char *url, HtmlSubmitFormMethod method, Char *query, void *cbData);
00373  *
00374  * HtmlLib calls this callback function with the appropriate arguments.
00375  *
00376  * @see HtmlLibSubmitFormCallback
00377  *
00378  */
00379 void HtmlLibSetSubmitFormCallback(UInt16 refnum, MemHandle htmlLibH, HtmlLibSubmitFormCallback *callback, void *cbData)
00380         SYS_TRAP(kHtmlLibTrapSetSubmitFormCallback);
00381
00382 /** Applications should call this function to allow HTML library to process content and draw to screen.
00383  * @note The Html Library will run only if you call this!
00384  *
00385  *@param refNum IN: the library reference number
00386  *@param htmlLibH IN:  the memory handle returned by HtmlLibInitialize
00387  *@param stayTime IN: maximum time (in milliseconds) for HTML library to do processing. (At least 1300 is recommend.)
00388  *
00389  *@return Status - htmlProgressDone, htmlProgressBusy, htmlProgressOutOfMemory, and other error codes.
00390  */
00391 UInt16 HtmlLibProgress(UInt16 refnum, MemHandle htmlLibH, Int32 stayTime)
00392         SYS_TRAP(kHtmlLibTrapProgress);
00393
00394 /** Applications should call this function to notify HTML library of a UI event (any event that your application gets that the library should handle, such as a screen tap, or a key press). It is worth noting that you may create your own events and call this function for the library to handle it. By the same token, you can filter which events to pass to this function - you do not have to pass through every event.
00395  *
00396  *@param refNum IN: the library reference number
00397  *@param htmlLibH IN: the memory handle returned by HtmlLibInitialize
00398  *@param eventP IN: the event you would like the library to handle
00399  *
00400  *@return True if the library considers this event handled.
00401  */
00402 Boolean HtmlLibNotifyUIEvent(UInt16 refnum, MemHandle htmlLibH, EventType *eventP)
00403         SYS_TRAP(kHtmlLibTrapNotifyUIEvent);
00404
00405 /** Applications should call this function to find a given text string on the page.  Page will automatically scroll to show search result.
00406  *
00407  *@param refNum IN: the library reference number
00408  *@param htmlLibH IN: the memory handle returned by HtmlLibInitialize
00409  *@param searchString IN: the given text string we are looking for on the page
00410  *@param wrapSearch IN: true if you would like to wrap search
00411  *
00412  *@return Error code (errNone, htmlErrNotFound).
00413  */
00414 Err HtmlLibFindText(UInt16 refnum, MemHandle htmlLibH, Char *searchString, Boolean wrapSearch)
00415         SYS_TRAP(kHtmlLibTrapFindText);
00416
00417
00418 /** Applications should use this function to retrieve the current selected text.  Caller application must free the pointer returned in selectedText using MemPtrFree.
00419  *
00420  * @param refNum IN: the library reference number
00421  * @param htmlLibH IN: the memory handle returned by HtmlLibInitialize
00422  * @param selectedText IN: the selected text that we are retrieving
00423  *
00424  * @return This function returns false if no current selection, otherwise returns true.
00425  */
00426 Boolean HtmlLibGetTextSelection(UInt16 refnum, MemHandle htmlLibH, Char **selectedText)
00427         SYS_TRAP(kHtmlLibTrapGetTextSelection);
00428
00429
00430
00431 /** This function clears the rendering screen.  It must be called before content object is destroyed.
00432  *
00433  *
00434  * @param refNum IN: the library reference number
00435  * @param htmlLibH IN: the memory handle returned by HtmlLibInitialize
00436  */
00437 void HtmlLibClearScreen(UInt16 refnum, MemHandle htmlLibH)
00438         SYS_TRAP(kHtmlLibTrapClearScreen);
00439
00440
00441
00442 /** This function aborts rendering of the current content.
00443  *
00444  * @param refNum IN: the library reference number
00445  * @param contentH IN: Memory Handle of the current content, returned by HtmlLibCreateContentObject
00446  *
00447  */
00448 void HtmlLibAbortRenderData(UInt16 refnum, MemHandle htmlLibH)
00449         SYS_TRAP(kHtmlLibTrapAbortRenderData);
00450
00451
00452
00453 /** Creates a content object (structure in memory that contains content to be rendered).
00454  *
00455  * @param refNum IN: the library reference number
00456  * @param htmlLibH IN: the memory handle returned by HtmlLibInitialize
00457  *
00458  * @return This function returns the memory handle of a content data object.
00459  */
00460 MemHandle HtmlLibCreateContentObject(UInt16 refnum, MemHandle htmlLibH)
00461         SYS_TRAP(kHtmlLibTrapCreateContentObject);
00462
00463
00464
00465 /** This function destroys the content data object created by HtmlLibCreateContentObject.
00466  *
00467  * @note  Be cautious when destroying a content object - make sure it is not busy doing something else, like rendering data. You can use HtmlLibProgress to check for the status (busy or not), or you can call HtmlLibAbortRenderData first.
00468  * @param refNum IN: the library reference number
00469  * @param contentH IN: Memory Handle returned by HtmlLibCreateContentObject
00470  *
00471  */
00472 void HtmlLibDestroyContentObject(UInt16 refnum, MemHandle contentH)
00473         SYS_TRAP(kHtmlLibTrapDestroyContentObject);
00474
00475
00476
00477 /** This function adds text data to the content data object created by HtmlLibCreateContentObject. Application should call HtmlLibRenderData when it has finished adding text data, for the data to be rendered.
00478  * @note  There is a limit of 64K of text data per content object (and not just per call of HtmlLibAddTextData).
00479  *
00480  * @param refNum IN: the library reference number
00481  * @param contentH IN: Memory Handle returned by HtmlLibCreateContentObject
00482  * @param url IN: url of the page you are adding to (unique, to make sure nothing is written over)
00483  * @param mimeType IN: mime type of the text (such as "text/plain", "text/html")
00484  * @param charset IN: the character set (such as "us-ascii")
00485  * @param data IN: a reference to the text data to be added
00486  * @param dataLen IN: length of the data
00487  *
00488  * @return This function returns an error code (returns errNone if successful).
00489  */
00490 Err HtmlLibAddTextData(UInt16 refnum, MemHandle contentH, Char *url, Char *mimeType, Char *charset, void *data, Int32 dataLen)
00491         SYS_TRAP(kHtmlLibTrapAddTextData);
00492
00493
00494
00495 /** This function adds images to HtmlLib. (You can use this to respond to Inclusion callback - please see section 2.1 Image Rendering).
00496  *
00497  * @param refNum IN: the library reference number
00498  * @param contentH IN: Memory Handle returned by HtmlLibCreateContentObject
00499  * @param url IN: url of the image
00500  * @param mimeType IN: mime type of the image (for example, "image/jpeg")
00501  * @param data IN: image data
00502  * @param dataLen IN: image data size
00503  *
00504  * @return Error code.
00505  *
00506  */
00507 Err HtmlLibAddImageData(UInt16 refnum, MemHandle contentH, Char *url, Char *mimeType, void *data, Int32 dataLen)
00508         SYS_TRAP(kHtmlLibTrapAddImageData);
00509
00510
00511
00512 /** Applications should call this function after adding text data by HtmlLibAddTextData (or image data by HtmlLibAddImageData, see section 2.1 Image Rendering) to have HTML library start rendering the content.
00513  *
00514  * @param refNum IN: the library reference number
00515  * @param contentH IN: Memory Handle returned by HtmlLibCreateContentObject that contains the text data to be rendered
00516  *
00517  */
00518 void HtmlLibRenderData(UInt16 refnum, MemHandle contentH)
00519         SYS_TRAP(kHtmlLibTrapRenderData);
00520
00521
00522
00523 /** This redraws the HtmlLib rendering screen (for example, when application receives a frmUpdate event).
00524  *
00525  * @param refNum IN: the library reference number
00526  * @param htmlLibH IN: the memory handle returned by HtmlLibInitialize
00527  *
00528  */
00529 void HtmlLibRedrawScreen(UInt16 refnum, MemHandle htmlLibH)
00530         SYS_TRAP(kHtmlLibTrapRedrawScreen);
00531
00532
00533
00534 /** This function passes an array of scrollbars to HtmlLib. Html library will not display any scrollbar if application does not call this function (scrollbars cannot be added dynamically).  Application is recommended to pass no less than 4 (or at the very least 2) scrollbars, and up to 9 scrollbars.
00535  * For example (after defining RenderScroll0ScrollBar and RenderScroll1ScrollBar):
00536  *
00537  * @code
00538  *  UInt16 scrollbars[2] = {RenderScroll0ScrollBar, RenderScroll1ScrollBar};
00539  *  HtmlLibSetScrollbars(gRefNum, gHtmlLibH, scrollbars, 2);
00540  * @endcode
00541  *
00542  * @param refNum IN: the library reference number
00543  * @param htmlLibH IN: the memory handle returned by HtmlLibInitialize
00544  * @param scrollbars IN: array of scrollbars
00545  * @param size IN: size of the array of scrollbars
00546  *
00547  */
00548 void HtmlLibSetScrollbars(UInt16 refnum, MemHandle htmlLibH, UInt16 *scrollbars, UInt16 size)
00549         SYS_TRAP(kHtmlLibTrapSetScrollbars);
00550
00551
00552
00553 /** This function obtains the current scroll position in pixels from the top of the page.
00554  *
00555  * @param refNum IN: the library reference number
00556  * @param htmlLibH IN: the memory handle returned by HtmlLibInitialize
00557  * @param valueP IN: at function's return, this contains the position in pixels from the top of the page
00558  *
00559  * @return Error code.
00560  *
00561  */
00562 Err HtmlLibGetVScrollPosition(UInt16 refnum, MemHandle htmlLibH, Int16 *valueP)
00563         SYS_TRAP(kHtmlLibTrapGetVScrollPosition);
00564
00565
00566
00567
00568 /** This function sets the current scroll position in pixels from the top of the page. If the total page height of the current page is less than this, this scrolls the page to the bottom.
00569  *
00570  * @param refNum IN: the library reference number
00571  * @param htmlLibH IN: the memory handle returned by HtmlLibInitialize
00572  * @param newPosition IN: the position in pixels from the top of the page
00573  *
00574  * @return Error code.
00575  *
00576  */
00577 Err HtmlLibSetVScrollPosition(UInt16 refnum, MemHandle htmlLibH, Int16 newPosition)
00578         SYS_TRAP(kHtmlLibTrapSetVScrollPosition);
00579
00580
00581
00582 /** This function lets you know whether scrolling is possible in the indicated direction.
00583  *
00584  * @param refNum IN: the library reference number
00585  * @param htmlLibH IN: the memory handle returned by HtmlLibInitialize
00586  * @param direction IN: htmlDirLeft, htmlDirRight, htmlDirUp, htmlDirDown
00587  *
00588  * @return Function outputs true if scrolling in the indicated direction is possible.
00589  *
00590  */
00591 Boolean HtmlLibCanScroll(UInt16 refnum, MemHandle htmlLibH, HtmlScrollDirection direction)
00592         SYS_TRAP(kHtmlLibTrapCanScroll);
00593
00594
00595
00596
00597 /** This function sets the page's scrollbar mode, without affecting the scrollbars of a textarea. A reason to use htmlNoPageScrollbarMode and not htmlNormalScrollbarMode is if you would like to use your own scrollbars, and use HtmlLib(Set/Get)VScrollPosition to do so.
00598  *
00599  * @param refNum IN: the library reference number
00600  * @param htmlLibH IN: the memory handle returned by HtmlLibInitialize
00601  * @param mode  IN: scrollbar mode (htmlNormalScrollbarMode to enable scrolling or htmlNoPageScrollbarMode for no scrolling)
00602  *
00603  * @return Error code. (htmlErrNotInitialized, htmlErrInUse)
00604  *
00605  */
00606 Err HtmlLibSetScrollbarMode(UInt16 refnum, MemHandle htmlLibH, HtmlScrollbarMode mode)
00607         SYS_TRAP(kHtmlLibTrapSetScrollbarMode);
00608
00609
00610 /** This function will control the size of the font used by HtmlLib.
00611  *
00612  * @param refNum IN: the library reference number
00613  * @param htmlLibH IN: htmlLib handle
00614  * @param value IN: true if you would like bigger font (bigger font corresponds to the  Large font option in Blazer), and false otherwise (false would correspond to the Small font option in Blazer).
00615  *
00616  * @return Error code.
00617  *
00618  */
00619 Err HtmlLibSetBiggerFont(UInt16 refnum, MemHandle htmlLibH, Boolean value)
00620         SYS_TRAP(kHtmlLibTrapSetBiggerFont);
00621
00622
00623 /** This function reinitializes the focus to point to nothing.
00624  *
00625  * @param refNum IN: the library reference number
00626  * @param htmlLibH IN: htmlLib handle
00627  *
00628  * @return True if the focus was reset to point to nothing.
00629  *
00630  */
00631 Boolean HtmlLibResetFocusInfo(UInt16 refnum, MemHandle htmlLibH)
00632         SYS_TRAP(kHtmlLibTrapResetFocusInfo);
00633
00634
00635 /** This function sets the focus according to the condition flags passed in.
00636  *
00637  * @param refNum IN: the library reference number
00638  * @param htmlLibH IN: htmlLib handle
00639  * @param flag - Enables (true) or Disables (false) focus handling
00640  * @param reset_focus - if flag is true: if reset_focus is true, then the code tries to set the next focus onto the next target in the event focus walk chain. If false, it again sets the focus to the current event target.
00641  *
00642  */
00643 void HtmlLibSetFocusStatus(UInt16 refnum, MemHandle htmlLibH, Boolean flag, Boolean reset_focus)
00644         SYS_TRAP(kHtmlLibTrapSetFocusStatus);
00645
00646 /* 68K only */
00647
00648 /**  This function sets the function pointers of some necessary form widget creation/deletion routines.
00649  *The following is sufficient for most purposes (and included in the sample application):
00650  *
00651  * @code
00652  *
00653  *  static HtmlLibFormWidgetProc *widgetProc = NULL;
00654  *
00655  *  widgetProc = MemPtrNew(sizeof(HtmlLibFormWidgetProc));
00656  *  if (widgetProc) {
00657  *      //functions defined in sample code
00658  *      widgetProc->newControlProc = RendererNewControlProc;
00659  *      widgetProc->newFieldProc = RendererNewFieldProc;
00660  *      widgetProc->newListProc = RendererNewListProc;
00661  *      widgetProc->deleteObjectProc = RendererDeleteObjectProc;
00662  *  }
00663  *
00664  *  HtmlLibSetFormWidgetProc(refNum, htmlLibH, widgetProc);
00665  *
00666  * @endcode
00667  *
00668  * A standard example of the necessary form widget creation/deletion routines are provided below, and can be found in the sample code.
00669  *
00670  * @code
00671  *
00672  * static Boolean
00673  * RendererNewControlProc(UInt16 ID,
00674  *     UInt16 style, const Char *textP,
00675  *     Coord x, Coord y, Coord width, Coord height,
00676  *     UInt16 font, UInt8 group, Boolean leftAnchor)
00677  *
00678  *  {
00679  *     ControlType *ctlP;
00680  *     FormType *formP = FrmGetActiveForm();
00681  *     ctlP = CtlNewControl((void**)&formP, ID, style, textP, x, y, width, height, font, group, leftAnchor);
00682  *     if (ctlP) {
00683  *         return true;
00684  *     }
00685  *     return false;
00686  *  }
00687  *
00688  *  static Boolean
00689  *  RendererNewFieldProc(UInt16 id,
00690  *         Coord x, Coord y, Coord width, Coord height,
00691  *     UInt16 font, UInt32 maxChars, UInt16 editable, UInt16 underlined,
00692  *     UInt16 singleLine, UInt16 dynamicSize, UInt16 justification,
00693  *     UInt16 autoShift, UInt16 hasScrollBar, UInt16 numeric)
00694  *
00695  *  {
00696  *     FieldType *fieldP;
00697  *     FormType *formP = FrmGetActiveForm();
00698  *     fieldP = FldNewField((void**)&formP, id, x, y, width, height, (FontID)font,
00699  *                     maxChars, (Boolean)editable, (Boolean)underlined, (Boolean)singleLine,
00700  *                     (Boolean)dynamicSize, (JustificationType)justification, (Boolean)autoShift,
00701  *                     (Boolean)hasScrollBar, (Boolean)numeric);
00702  *     if (fieldP) {
00703  *         return true;
00704  *     }
00705  *     return false;
00706  *  }
00707  *
00708  *  static Err
00709  *  RendererNewListProc(UInt16 id,
00710  *     Coord x, Coord y, Coord width, Coord height,
00711  *     UInt16 font, Int16 visibleItems, Int16 triggerId)
00712  *  {
00713  *     FormType *formP = FrmGetActiveForm();
00714  *     return LstNewList((void**)&formP, id, x, y, width, height, font,
00715  *                         visibleItems, triggerId);
00716  *  }
00717  *
00718  *  static void
00719  *  RendererDeleteObjectProc(UInt16 index)
00720  *  {
00721  *     FormType *formP = FrmGetActiveForm();
00722  *     FrmRemoveObject(&formP, index);
00723  *  }
00724  *
00725  * @endcode
00726  *
00727  *
00728  * @param refNum IN: HTML library reference number
00729  * @param htmlLibH IN: htmlLib handle
00730  * @param proc IN: function pointers of form widget creation/deletion routines.
00731  *
00732  */
00733 void HtmlLibSetFormWidgetProc(UInt16 refnum, MemHandle htmlLibH, HtmlLibFormWidgetProc *proc)
00734         SYS_TRAP(kHtmlLibTrapSetFormWidgetProc);
00735
00736 Boolean HtmlLibGetTargetInfo(UInt16 refnum, MemHandle htmlLibH,  HtmlLibFocusTargetInfo *htmlTargetInfo)
00737         SYS_TRAP(kHtmlLibTrapGetTargetInfo);
00738
00739 Err HtmlLibSetImageMemoryLimit(UInt16 renum, MemHandle htmlLibH, Int32 limit)
00740         SYS_TRAP(kHtmlLibTrapSetImageMemoryLimit);
00741
00742 #endif /* HTMLLIb68K_H__ */
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:53 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » htmllib

HtmlLibTrap.h

Go to the documentation of this file.
00001 /*
00002     HtmlLib68K.h
00003     Copyright(c) 1996-2002 ACCESS CO., LTD.
00004     All rights are reserved by ACCESS CO., LTD., whether the whole or
00005     part of the source code including any modifications.
00006 */
00007 #ifndef HTMLLIbTRAP_H__
00008 #define HTMLLIbTRAP_H__
00009
00010 #ifdef HERCULES_NATIVE
00011 #include <LibTraps68K.h>
00012 #else
00013 #include <LibTraps.h>
00014 #endif
00015
00016 /* const */
00017 #define kHtmlLibTrapOpen sysLibTrapOpen
00018 #define kHtmlLibTrapClose sysLibTrapClose
00019 #define kHtmlLibTrapSleep sysLibTrapSleep
00020 #define kHtmlLibTrapWake sysLibTrapWake
00021 #define kHtmlLibTrapInitialize      (sysLibTrapCustom + 0)
00022 #define kHtmlLibTrapFinalize        (sysLibTrapCustom + 1)
00023 #define kHtmlLibTrapResizeScreen    (sysLibTrapCustom + 2)
00024 #define kHtmlLibTrapSetDisplayMode  (sysLibTrapCustom + 3)
00025 #define kHtmlLibTrapSetLinkSelectionCallback    (sysLibTrapCustom + 4)
00026 #define kHtmlLibTrapSetScanPhoneNumberCallback  (sysLibTrapCustom + 5)
00027 #define kHtmlLibTrapSetInclusionCallback        (sysLibTrapCustom + 6)
00028 #define kHtmlLibTrapSetSubmitFormCallback       (sysLibTrapCustom + 7)
00029 #define kHtmlLibTrapProgress            (sysLibTrapCustom + 8)
00030 #define kHtmlLibTrapNotifyUIEvent       (sysLibTrapCustom + 9)
00031 #define kHtmlLibTrapFindText            (sysLibTrapCustom + 10)
00032 #define kHtmlLibTrapGetTextSelection    (sysLibTrapCustom + 11)
00033 #define kHtmlLibTrapClearScreen         (sysLibTrapCustom + 12)
00034 #define kHtmlLibTrapAbortRenderData     (sysLibTrapCustom + 13)
00035 #define kHtmlLibTrapCreateContentObject     (sysLibTrapCustom + 14)
00036 #define kHtmlLibTrapDestroyContentObject    (sysLibTrapCustom + 15)
00037 #define kHtmlLibTrapAddTextData             (sysLibTrapCustom + 16)
00038 #define kHtmlLibTrapRenderData              (sysLibTrapCustom + 17)
00039 #define kHtmlLibTrapRedrawScreen            (sysLibTrapCustom + 18)
00040 #define kHtmlLibTrapSetScrollbars           (sysLibTrapCustom + 19)
00041 #define kHtmlLibTrapGetVScrollPosition      (sysLibTrapCustom + 20)
00042 #define kHtmlLibTrapSetVScrollPosition      (sysLibTrapCustom + 21)
00043 #define kHtmlLibTrapCanScroll               (sysLibTrapCustom + 22)
00044 #define kHtmlLibTrapSetScrollbarMode        (sysLibTrapCustom + 23)
00045 #define kHtmlLibTrapAddImageData            (sysLibTrapCustom + 24)
00046 #define kHtmlLibTrapSetBiggerFont           (sysLibTrapCustom + 25)
00047 #define kHtmlLibTrapSetFormWidgetProc       (sysLibTrapCustom + 26)
00048 #define kHtmlLibTrapGetTargetInfo           (sysLibTrapCustom + 27)
00049 #define kHtmlLibTrapInitializeWithHeapSize  (sysLibTrapCustom + 28)
00050 #define kHtmlLibTrapSetImageMemoryLimit     (sysLibTrapCustom + 29)
00051 #define kHtmlLibTrapResetFocusInfo          (sysLibTrapCustom + 30)
00052 #define kHtmlLibTrapSetFocusStatus          (sysLibTrapCustom + 31)
00053
00054 #endif /* HTMLLIbTRAP_H__ */
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:53 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » imaging

ImageLib.h

Go to the documentation of this file.
00001 /******************************************************************************
00002  * Copyright (c) 2004 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  *****************************************************************************/
00005 /**
00006  * @ingroup Imaging
00007  */
00008
00009 /**
00010  * @file  ImageLib.h
00011  * @brief Public 68k include file for the Imaging Library.
00012  *
00013  * This file contains routines for capturing, storing, iterating, resizing, and
00014  * manipulating images. The imaging library is a client of both the camera
00015  * driver and the JPEG library.
00016  */
00017
00018 /*
00019  * Copyright (c) 2003 IDEO. All rights reserved.
00020  * Portions ©2004 palmOne, Inc. All rights reserved.
00021  *
00022  *
00023  ****************************************************************/
00024
00025 #ifndef IMAGELIB_H
00026 #define IMAGELIB_H
00027
00028 #include <PalmOS.h>
00029 #include <PalmTypes.h>
00030 #include <VFSMgr.h>
00031
00032 #ifdef __cplusplus
00033 extern "C" {
00034 #endif
00035
00036 /****************************************************************/
00037 /* ImageLibOpen */
00038
00039 /**
00040  * Library open call for 68k clients of the library. This routine maps to the
00041  * sysLibTrapOpen trap.
00042  *
00043  * It is customary for shared libraries to provide open and close functions.
00044  * The open and close functions in ImageLib are empty stubs that exist for the
00045  * sole purpose of adhering to past convention. This function does nothing and
00046  * will always return errNone. All library initialization is done from
00047  * PilotMain.
00048  *
00049  * This function is not available to ARM clients of the library.
00050  *
00051  * @param libRef: IN: Library reference number.
00052  *
00053  * @retval Err 0 on success or error code on failure.
00054  *
00055  ****************************************************************/
00056 Err ImageLibOpen(UInt16 libRef) SYS_TRAP(kImageLibTrapOpen );
00057
00058
00059 /****************************************************************/
00060 /* ImageLibClose */
00061
00062 /**
00063  * Library close function for 68k clients of the library. This routine maps to
00064  * the sysLibTrapClose trap.
00065  *
00066  * This function is an empty stub (see comments for ImageLibOpen). All library
00067  * cleanup is done from PilotMain.
00068  *
00069  * This function is not available to ARM clients of the library.
00070  *
00071  * @see ImageLibOpen
00072  *
00073  * @param libRef:   IN: Library reference number.
00074  *
00075  * @retval Err 0 on success or error code on failure.
00076  *
00077  ****************************************************************/
00078 Err ImageLibClose(UInt16 libRef) SYS_TRAP(kImageLibTrapClose);
00079
00080
00081 /****************************************************************/
00082 /* ImageLibGetVersion */
00083
00084 /**
00085  * Retrieves the version number of the image library.
00086  *
00087  * @param libRef: IN: Library reference number.
00088  * @param dwVerP: OUT: Pointer to library version variable.
00089  *
00090  * @retval Err 0 on success or error code on failure.
00091  *
00092  ****************************************************************/
00093 Err ImageLibGetVersion(UInt16 libRef, UInt32 *dwVerP)
00094     SYS_TRAP(kImageLibTrapGetVersion);
00095
00096
00097 /****************************************************************/
00098 /* ImageLibCameraExists */
00099
00100 /**
00101  * Detects presence of camera driver.
00102  *
00103  * The imaging library loads the camera driver dynamically. If the driver was
00104  * found and was loaded successfully, ImageLibCameraExists writes true to
00105  * existsP, otherwise it writes false.
00106  *
00107  * This routine will attempt to load the camera driver if it hasn't
00108  * already been loaded. The driver will remain loaded until the imaging library
00109  * is unloaded, or until ImageLibTurnCameraOff is called.
00110  *
00111  * @see ImageLibTurnCameraOff
00112  *
00113  * @param libRef:   IN: Library reference number.
00114  * @param existsP:  OUT: true if camera successfully loaded. Otherwise false.
00115  * @retval Err 0 on success or error code on failure.
00116  *
00117  ****************************************************************/
00118 Err ImageLibCameraExists(UInt16 libRef, Boolean* existsP)
00119     SYS_TRAP(kImageLibTrapCameraExists);
00120
00121 /****************************************************************/
00122 /* ImageLibImageCapture */
00123
00124 /**
00125  * Captures an image and stores it in the database.
00126  *
00127  * Images are appended to the end of the database.
00128  *
00129  * The camera driver always captures 640x480 images. If fullSize is false,
00130  * the data from the camera is downsampled to 160x120 using a filtering
00131  * algorithm.
00132  *
00133  * Captures are currently done in 16 bit RGB mode. Capturing an image
00134  * requires at least 600 kB of free space in the dynamic heap (640x480x2).
00135  *
00136  * Captured pictures are stored in uncompressed palmOS bitmap format.
00137  * To compress an image as a JPEG, call ImageLibImageSave.
00138  *
00139  * @see ImageLibImageSave
00140  *
00141  * @param libRef:           IN: Library reference number.
00142  * @param fullsize:         IN: true capture a 640x480 image. false to capture 160x120
00143  * @param playShutterSound: IN: true to play a camera shutter sound.
00144  * @param drawImmediately:  IN: true to immediately draw the captured image to the current draw window.
00145  * @param x:                IN: x location to draw the captured image. Relative to the current draw window. Ignored if drawImmediately is false.
00146  * @param y:                IN: y location to draw the captured image. Relative to the current draw window. Ignored if drawImmediately is false.
00147  * @param newRecNoP:        OUT: index of the new image. If the capture fails, kInvalidRecIndex is written to this value. Pass NULL if you don’t care what the new index is.
00148  * @retval Err 0 on success or error code on failure.
00149  *
00150  ****************************************************************/
00151 Err ImageLibImageCapture(UInt16 libRef,
00152                          Boolean fullsize,
00153                          Boolean playShutterSound,
00154                          Boolean drawImmediately,
00155                          Coord x,
00156                          Coord y,
00157                          UInt16 *newRecNoP)
00158     SYS_TRAP(kImageLibTrapImageCapture);
00159
00160
00161 /****************************************************************/
00162 /* ImageLibImageSave */
00163
00164 /**
00165  * Compresses a captured image to JPEG format.
00166  *
00167  * Compresses a captured image to JPEG, sets the image name, and sets the
00168  * category of the picture. After saving, the uncompressed bitmap data is
00169  * discarded and replaced with the JPEG version of the image.
00170  *
00171  * This routine should only be invoke on newly captured images, and it
00172  * should only be called once per picture.
00173  *
00174  * @see ImageLibImageCapture
00175  *
00176  * @param libRef:   IN: Library reference number.
00177  * @param recIndex: IN: Index of the image to compress.
00178  * @param name:     IN: Name of the picture
00179  * @param category: IN: Category to store the image in
00180  * @retval Err 0 on success or error code on failure.
00181  *
00182  ****************************************************************/
00183 Err ImageLibImageSave(UInt16 libRef,UInt16 recIndex,
00184                       const char * name, UInt16 category)
00185     SYS_TRAP(kImageLibTrapImageSave);
00186
00187
00188 /****************************************************************/
00189 /* ImageLibPreviewBitmapCreate */
00190
00191 /**
00192  * Creates a preview bitmap. If Compresses a captured image to JPEG, sets the image name, and sets the
00193  * category of the picture. After saving, the uncompressed bitmap data is
00194  * discarded and replaced with the JPEG version of the image.
00195  *
00196  * When called from a 68k application, the return value should be treated
00197  * as opaque. The bitmap can safely be passed to the Palm OS bitmap routines,
00198  * but 68k applications should not attempt to dereference members of the bitmap
00199  * structure directly.
00200  *
00201  * Bitmaps created with this function should be disposed of by calling
00202  * ImageLibBitmapDelete. Do note call BmpDelete or MemPtrFree.
00203  *
00204  * If an error occurs, this function returns NULL and writes an error code
00205  * to errP. If the function returns a non-NULL bitmap value, then *errP will
00206  * always be 0.
00207  *
00208  * This function does not perform an image preview. The resulting bitmap
00209  * is empty. To fill the bitmap with a preview image, pass it to
00210  * ImageLibPreviewBitmapFill.
00211  *
00212  * @see ImageLibPreviewBitmapFill
00213  * @see ImageLibBitmapDelete
00214  *
00215  * @param   libRef: IN: Library reference number.
00216  * @param   errP:   OUT: 0 on success, non-zero on error. This parameter should not be null.
00217  * @retval  BitmapType On success, the result is a new 160x120 bitmap whose bit depth matches
00218  *                     the bit depth of the screen. On failure, the result is NULL
00219  *
00220  ****************************************************************/
00221 BitmapType* ImageLibPreviewBitmapCreate(UInt16 libRef, Err *errP)
00222     SYS_TRAP(kImageLibTrapPreviewBitmapCreate);
00223
00224 /****************************************************************/
00225 /* ImageLibPreviewBitmapFill */
00226
00227 /**
00228  * Fills a bitmap with a preview image from the camera.
00229  *
00230  * The imageP argument should represent a bitmap created with
00231  * ImageLibPreviewBitmapCreate.
00232  *
00233  * @see ImageLibPreviewBitmapCreate
00234  * @see ImageLibBitmapDelete
00235  * @see ImageLibPreviewStop
00236  * @see ImageLibPreviewStart
00237  *
00238  * @param   libRef: IN: Library reference number.
00239  * @param   imageP: IN,OUT: Bitmap to fill with a preview.
00240  * @retval  Err 0 on success, non-zero on error.
00241  *
00242  ****************************************************************/
00243 Err ImageLibPreviewBitmapFill(UInt16 libRef, BitmapType* imageP)
00244     SYS_TRAP(kImageLibTrapPreviewBitmapFill);
00245
00246
00247 /****************************************************************/
00248 /* ImageLibPreviewDraw */
00249
00250 /**
00251  * Draws a preview image to the current draw window.
00252  *
00253  * Snaps a preview image with the camera driver and then draws it to the
00254  * current draw window at x,y. x and y are relative coordinates.
00255  *
00256  * @see ImageLibPreviewStop
00257  * @see ImageLibPreviewStart
00258  *
00259  * @param   libRef: IN: Library reference number.
00260  * @param   x:      IN: x location to draw the preview image, relative to the current draw window.
00261  * @param   y:      IN: y location to draw the preview image, relative to the current draw window.
00262  * @retval  Err 0 on success, non-zero on error.
00263  *
00264  ****************************************************************/
00265 Err ImageLibPreviewDraw(UInt16 libRef, Coord x, Coord y)
00266     SYS_TRAP(kImageLibTrapPreviewDraw);
00267
00268
00269
00270 /****************************************************************/
00271 /* ImageLibImageBitmapCreate */
00272
00273 /**
00274  * Creates a 16 bit bitmap for holding an image from the database. If
00275  * recIndex is a valid image index, that image is loaded into the resulting
00276  * bitmap. Otherwise, the result is an empty picture.
00277  *
00278  * When called from a 68k application, the return value should be treated
00279  * as opaque. The bitmap can safely be passed to the Palm OS bitmap routines,
00280  * but 68k applications should not attempt to dereference members of the bitmap
00281  * structure directly.
00282  *
00283  * Bitmaps created with this function should be disposed of by calling
00284  * ImageLibBitmapDelete. Do note call BmpDelete or MemPtrFree.
00285  *
00286  * If an error occurs, this function returns NULL and writes an error code
00287  * to errP. If the function returns a non-NULL bitmap value, then *errP will
00288  * always be 0.
00289  *
00290  * If recIndex is kInvalidRecIndex, the result is an empty 160x120 bitmap.
00291  * If recIndex is not kInvalidRecIndex, the result is a bitmap that contains the
00292  * given image from the database. The returned bitmap will be 160x120 if the
00293  * image in the database is 160x120, 320x240, 640x480, or any other image larger
00294  * than 160x120 with a 4:3 aspect ratio. If the image has a non-standard size,
00295  * it is downsized to fit in a 160x120 box. The aspect ratio of the picture is
00296  * preserved. Images that are less than 160x120 are not scaled at all.
00297  *
00298  * @see ImageLibBitmapDelete
00299  * @see ImageLibPreviewStop
00300  * @see ImageLibPreviewStart
00301  *
00302  * @param   libRef:     IN: Library reference number.
00303  * @param   recIndex:   IN: Index of image to fill bitmap with. Use kInvalidRecIndex to create an empty 160x120, 16 bit bitmap.
00304  * @param   errP:       OUT: If the function succeeds, 0 is written to errP. Otherwise, a non-zero error code is written. This parameter should not be NULL.
00305  * @retval  BitmapType* On success, the result is a new bitmap with a bit depth of 16. On error, the result is NULL.
00306  *
00307  ****************************************************************/
00308 BitmapType* ImageLibImageBitmapCreate(UInt16 libRef,
00309                                       UInt16 recIndex,
00310                                       Err *errP)
00311     SYS_TRAP(kImageLibTrapImageBitmapCreate);
00312
00313
00314 /****************************************************************/
00315 /* ImageLibImageBitmapFill */
00316
00317 /**
00318  * Fills a bitmap with an image from the database.
00319  *
00320  * The imageP argument should represent a bitmap created with
00321  * ImageLibImageBitmapCreate.
00322  *
00323  * The image from the database is resampled as necessary to fit the
00324  * dimensions of imageP. When the image is a jpeg, the DCT scaling features of
00325  * the IJG library are used to get the image size close to the destination size.
00326  * From there, the image is resampled with a filter to match the dimensions of
00327  * imageP. If the aspect ratio of imageP does not match the aspect ratio of
00328  * the picture, the picture is stretched to fit.
00329  *
00330  * @see ImageLibImageBitmapCreate
00331  * @see ImageLibBitmapDelete
00332  *
00333  * @param   libRef:     IN:  Library reference number.
00334  * @param   recIndex:   IN:  index of image to fill bitmap with.
00335  * @param   imageP:     IN,OUT:  Bitmap to fill.
00336  * @retval  Err 0 on success, non-zero on error.
00337  *
00338  ****************************************************************/
00339 Err ImageLibImageBitmapFill(UInt16 libRef, UInt16 recIndex, BitmapType* imageP)
00340     SYS_TRAP(kImageLibTrapImageBitmapFill);
00341
00342 /****************************************************************/
00343 /* ImageLibImageDraw*/
00344
00345 /**
00346  * Draws an image from the database to the current draw window.
00347  *
00348  * Draws an image from the database to the current draw window at x,y. x and y
00349  * are window relative coordinates.
00350  *
00351  * If necessary, the image is downsized to fit in a 160x120 box. The
00352  * aspect ratio of the picture is preserved.
00353  *
00354  * @param   libRef:     IN: Library reference number.
00355  * @param   recIndex:   IN: index of image to draw.
00356  * @param   x:          IN: x location to draw the preview image, relative to the current draw window.
00357  * @param   y:          IN: y location to draw the preview image, relative to the current draw window.
00358  * @retval  Err 0 on success, non-zero on error.
00359  *
00360  ****************************************************************/
00361 Err ImageLibImageDraw(UInt16 libRef, UInt16 recIndex, Coord x, Coord y)
00362     SYS_TRAP(kImageLibTrapImageDraw);
00363
00364
00365 /****************************************************************/
00366 /* ImageLibThumbnailBitmapCreate */
00367
00368 /**
00369  * Creates a 16 bit bitmap for holding an thumbnail image . If
00370  * recIndex is a valid image index, the thumbnail for that image is loaded into
00371  * the resulting bitmap. Otherwise, the result is an empty bitmap.
00372  *
00373  * When called from a 68k application, the return value should be treated
00374  * as opaque. The bitmap can safely be passed to the Palm OS bitmap routines,
00375  * but 68k applications should not attempt to dereference members of the bitmap
00376  * structure directly.
00377  *
00378  * Bitmaps created with this function should be disposed of by calling
00379  * ImageLibBitmapDelete. Do note call BmpDelete or MemPtrFree.
00380  *
00381  * If an error occurs, this function returns NULL and writes an error code
00382  * to errP. If the function returns a non-NULL bitmap value, then *errP will
00383  * always be 0.
00384  *
00385  * The thumbnail is generated on the fly if the image in the database
00386  * does not have a thumbnail record.
00387  *
00388  * @see ImageLibBitmapDelete
00389  *
00390  * @param   libRef:     IN:  Library reference number.
00391  * @param   recIndex:   IN:  index of image to fill the thumbnail bitmap with. Use kInvalidRecIndex to create an empty 40x30, 16 bit bitmap.
00392  * @param   errP:       OUT: If the function succeeds, 0 is written to errP. Otherwise, a non-zero error code is written. This parameter should not be NULL.
00393  * @retval  BitmapType* On success, the result is a new bitmap with a bit depth of 16. On error, the result is NULL.
00394  *
00395  ****************************************************************/
00396 BitmapType* ImageLibThumbnailBitmapCreate(UInt16 libRef,
00397                                           UInt16 recIndex,
00398                                           Err *errP)
00399     SYS_TRAP(kImageLibTrapThumbnailBitmapCreate);
00400
00401
00402 /****************************************************************/
00403 /* ImageLibThumbnailBitmapFill*/
00404
00405 /**
00406  * Fills a bitmap with an thumbnail image from the database.
00407  *
00408  * The imageP argument should represent a bitmap created with
00409  * ImageLibThumbnailBitmapCreate.
00410  *
00411  * The image from the database is resampled as necessary to fit the
00412  * dimensions of imageP. If the aspect ratio of imageP does not match the aspect
00413  * ratio of the picture, the picture is stretched to fit.
00414  *
00415  * @see ImageLibThumbnailBitmapCreate
00416  * @see ImageLibBitmapDelete
00417  *
00418  * @param   libRef:     IN:  Library reference number.
00419  * @param   recIndex:   IN: index of image
00420  * @param   imageP:     IN,OUT:  Bitmap to fill.
00421  * @retval  Err 0 on success, non-zero on error.
00422  *
00423  ****************************************************************/
00424 Err ImageLibThumbnailBitmapFill(UInt16 libRef, UInt16 recIndex, BitmapType* imageP)  SYS_TRAP(kImageLibTrapThumbnailBitmapFill);
00425
00426
00427 /****************************************************************/
00428 /* ImageLibThumbnailDraw*/
00429
00430 /**
00431  * Draws an thumbnail image from the database to the current draw window at x,y.
00432  * x and y * are window relative coordinates.
00433  *
00434  * @param   libRef:     IN:  Library reference number.
00435  * @param   recIndex:   IN:  index of image
00436  * @param   x:          IN:  x location to draw the preview image, relative to the current draw window.
00437  * @param   y:          IN:  y location to draw the preview image, relative to the current draw window.
00438  * @retval  Err 0 on success, non-zero on error.
00439  *
00440  ****************************************************************/
00441 Err ImageLibThumbnailDraw(UInt16 libRef, UInt16 recIndex, Coord x, Coord y)
00442     SYS_TRAP(kImageLibTrapThumbnailDraw);
00443
00444
00445 /****************************************************************/
00446 /* ImageLibBitmapDelete*/
00447
00448 /**
00449  * Deletes a bitmap created by the library.
00450  *
00451  * Use ImageLibBitmapDelete to delete any bitmap that was created and returned
00452  * by the imaging library (ImageLibPreviewBitmapCreate, ImageLibImageBitmapCreate and ImageLibThumbnailBitmapCreate).
00453  *
00454  * @param   libRef: IN: Library reference number.
00455  * @param   bmp:    IN: Bitmap to delete.
00456  * @retval  Err 0 on success, non-zero on error.
00457  *
00458  ****************************************************************/
00459 Err ImageLibBitmapDelete(UInt16 libRef, BitmapType *bmp)
00460     SYS_TRAP(kImageLibTrapBitmapDelete);
00461
00462 /****************************************************************/
00463 /* ImageLibDeleteImage*/
00464
00465 /**
00466  * Delete a picture from the database.
00467  *
00468  * This routine deletes an image and its thumbnail from the database.
00469  *
00470  * Deleting a picture invalidates the record indices of all subsequent
00471  * images in the database. Records are deleted with DmRemoveRecord. They are
00472  * not archived.
00473  *
00474  * @param   libRef:     IN: Library reference number.
00475  * @param   recIndex:   IN: index of image to delete.
00476  * @retval  Err 0 on success, non-zero on error.
00477  *
00478  ****************************************************************/
00479 Err ImageLibDeleteImage(UInt16 libRef, UInt16 recIndex)
00480     SYS_TRAP(kImageLibTrapDeleteImage);
00481
00482 /****************************************************************/
00483 /* ImageLibResizeImage*/
00484
00485 /**
00486  * @deprecated
00487  *
00488  * Resizes a fullsize picture in the database to 160x120 (palm size). The original
00489  * fullsize image is replaced with the palm size version.
00490  *
00491  * If the original image is a full size 640x480 jpeg, the image is
00492  * downsampled using the DCT scaling features of the IJG library. This means
00493  * that the JPEG is decompressed directly to 160x120, and then compressed again
00494  * and saved back to the database.
00495  *
00496  * If the original image is not a 640x480 jpeg, it is scaled as much as
00497  * possible using the IJG scaling features. After decompression, the picture is
00498  * resampled with a filter to get its dimensions to 160x120.
00499  *
00500  * ImageLibResizeImage is deprecated. Use ImageLibResize instead.
00501  *
00502  * @param   libRef:     IN: Library reference number.
00503  * @param   recIndex:   IN: index of image to resize.
00504  * @retval  Err 0 on success, non-zero on error.
00505  *
00506  ****************************************************************/
00507 Err ImageLibResizeImage(UInt16 libRef, UInt16 recIndex)
00508     SYS_TRAP(kImageLibTrapResizeImage);
00509
00510
00511 /****************************************************************/
00512 /* ImageLibGetImageDatabases*/
00513
00514 /**
00515  * Return the references to the database that are used to store pictures.
00516  *
00517  * The image library opens each database when it is loaded, and closes them when it is unloaded.
00518  * Do not close the database references that are returned by this function because the references are still being used by
00519  * the imaging library.
00520  *
00521  * The data in each database is stored in little endian format.
00522  *
00523  * The main database contains one record for each image in the database.
00524  * Each record has a fixed size and contains information about the picture. The
00525  * image database contains the actual JPEG data for each image. The main
00526  * database acts as a master table and the images database is a child table.
00527  *
00528  * The notes database is not currently used.
00529  *
00530  * The category of an image is determined by the category of its record in
00531  * the main database. Categories are not used in the image table.
00532  *
00533  * @param   libRef:     IN:  Library reference number.
00534  * @param   dbMainP:    OUT: Reference to the main database. Pass NULL for this parameter if you don’t want to retrieve it.
00535  * @param   dbNoteP:    OUT: Reference to the note database. Pass NULL for this parameter if you don’t want to retrieve it.
00536  * @param   dbImageP:   OUT: Reference to the images database.
00537  * @retval  Err 0 on success, non-zero on error.
00538  *
00539  ****************************************************************/
00540 Err ImageLibGetImageDatabases(UInt16 libRef, DmOpenRef *dbMainP,
00541                               DmOpenRef *dbNoteP, DmOpenRef *dbImageP)
00542     SYS_TRAP(kImageLibTrapGetImageDatabases);
00543
00544
00545 /****************************************************************/
00546 /* ImageLibGetImageInfo*/
00547
00548 /**
00549  * Retrieves information about an image stored in the database.
00550  *
00551  * @param   libRef:         IN:  Library reference number.
00552  * @param   recIndex:       IN:  Index of the picture
00553  * @param   name:           OUT: Buffer to receive the name of the image. The buffer should be at least 32
00554                                  characters long (31 + null terminator). Pass NULL for this parameter if you don't want to retrieve it.
00555  * @param   fullSizeP:      OUT: true if image is 640x480, false if palm size. Pass NULL for this parameter if you don't want to retrieve it.
00556  * @param   createdP:       OUT: Timestamp when picture was creatd. Pass NULL for this parameter if you don't want to retrieve it.
00557  * @param   sizeP:          OUT: Size of the image data in bytes. Pass NULL for this parameter if you don't want to retrieve it.
00558  * @param   categoryP:      OUT: Category that that picture is assigned to. Pass NULL for this parameter if you don't want to retrieve it.
00559  * @param   categoryName:   OUT: Text description of the picture's category (ie 'Unfiled'). Pass NULL for this parameter if you don't want to retrieve it.
00560  * @param   lockedP:        OUT: true if image is locked.
00561  * @param   uidP:           OUT: Unique ID of the image.
00562  * @retval  Err 0 on success, non-zero on error.
00563  *
00564  ****************************************************************/
00565 Err ImageLibGetImageInfo(UInt16 libRef, UInt16 recIndex, Char* name,
00566                          Boolean* fullSizeP, UInt32* createdP, UInt32* sizeP,
00567                          UInt16* categoryP, Char* categoryName, Boolean *lockedP, UInt32 *uidP) SYS_TRAP(kImageLibTrapGetImageInfo);
00568
00569 /****************************************************************/
00570 /* ImageLibSetImageInfo*/
00571
00572 /**
00573  * Assigns information about an image stored in the database.
00574  *
00575  * @param   libRef:     IN:  Library reference number.
00576  * @param   recIndex:   IN:  Index of the picture
00577  * @param   name:       IN:  Name of the picture. Pass NULL for this parameter if you don't want to set it.
00578  * @param   categoryP:  OUT: Category that that picture is assigned to. Pass NULL for this parameter if you don't want to set it.
00579  * @retval  Err 0 on success, non-zero on error.
00580  *
00581  ****************************************************************/
00582 Err ImageLibSetImageInfo(UInt16 libRef, UInt16 recIndex,
00583                          const char* name, UInt16* categoryP)
00584     SYS_TRAP(kImageLibTrapSetImageInfo);
00585
00586
00587 /****************************************************************/
00588 /* ImageLibCopyImageToVFS*/
00589
00590 /**
00591  * Copies an image from the database to a VFS volume.
00592  *
00593  * Copies an image from the database to a VFS volume, overwriting any previous
00594  * file that existed on the volume with the same name.
00595  *
00596  * volRefNum should be obtained via a call to VFSVolumeEnumerate
00597  *
00598  * @param   libRef:     IN:  Library reference number.
00599  * @param   recIndex:   IN:  Index of the picture
00600  * @param   volRefNum:  IN:  Ref number of the VFS volume
00601  * @param   fileName:   IN:  Filename of the image (ie "/DCIM/picture.jpg")
00602  * @retval  Err 0 on success, non-zero on error.
00603  *
00604  ****************************************************************/
00605 Err ImageLibCopyImageToVFS(UInt16 libRef, UInt16 recIndex,
00606                            UInt16 volRefNum, const char* fileName)
00607     SYS_TRAP(kImageLibTrapCopyImageToVFS);
00608
00609
00610 /****************************************************************/
00611 /* ImageLibCopyImageToVFS*/
00612
00613 /**
00614  * Copies an image from a VFS volume to the database.
00615  *
00616  * volRefNum should be obtained via a call to VFSVolumeEnumerate
00617  *
00618  * If a picture with a matching name and category already exists in the
00619  * database, that image is <b>not</b> overwritten. After the call, there will
00620  * be two images with the same name and category.
00621  *
00622  * @param   libRef:         IN:  Library reference number.
00623  * @param   volRefNum:      IN:  Ref number of the VFS volume
00624  * @param   fileName:       IN:  Filename of the image (ie "/DCIM/picture001.jpg")
00625  * @param   name:           IN:  Name of the image in the database (ie "picture001")
00626  * @param   category:       IN:  Category that the image should be assigned to
00627  * @param   newRecIndexP:   OUT: Record index of the newly stored picture. Pass NULL if you don't care what the new index is.
00628  * @retval  Err 0 on success, non-zero on error.
00629  *
00630  ****************************************************************/
00631 Err ImageLibCopyImageFromVFS(UInt16 libRef, UInt16 volRefNum,
00632                              const char* fileName, const char * name,
00633                              UInt16 category, UInt16 *newRecIndexP)
00634     SYS_TRAP(kImageLibTrapCopyImageFromVFS);
00635
00636
00637 /****************************************************************/
00638 /* ImageLibImageBitmapCreateFromVFS */
00639
00640 /**
00641  * Creates a 16 bit bitmap for holding an image from a VFS volume. The library
00642  * decompresses the image from the volume and stores it in the result.
00643  *
00644  * When called from a 68k application, the return value should be treated
00645  * as opaque. The bitmap can safely be passed to the Palm OS bitmap routines,
00646  * but 68k applications should not attempt to dereference members of the bitmap
00647  * structure directly.
00648  *
00649  * Bitmaps created with this function should be disposed of by calling
00650  * ImageLibBitmapDelete. Do note call BmpDelete or MemPtrFree.
00651  *
00652  * If an error occurs, this function returns NULL and writes an error code
00653  * to errP. If the function returns a non-NULL bitmap value, then *errP will
00654  * always be 0.
00655  *
00656  * The picture is always resized to fit in a 160x120 box. If the image needs
00657  * to be resized, its aspect ratio is maintained.
00658  *
00659  * @see ImageLibBitmapDelete
00660  *
00661  * @param   libRef:     IN:  Library reference number.
00662  * @param   volRefNum:  IN:  Ref number of the VFS volume
00663  * @param   fileName:   IN:  Filename of the image (ie "/DCIM/picture.jpg")
00664  * @param   errP:       OUT: If the function succeeds, 0 is written to errP. Otherwise, a non-zero error code is written. This parameter should not be NULL.
00665  * @retval  BitmapType* On success, the result is a new bitmap with a bit depth of 16. On error, the result is NULL.
00666  *
00667  ****************************************************************/
00668 BitmapType* ImageLibImageBitmapCreateFromVFS(UInt16 libRef, UInt16 volRefNum,
00669                                              const char* fileName, Err *errP)
00670     SYS_TRAP(kImageLibTrapImageBitmapCreateFromVFS);
00671
00672
00673 /****************************************************************/
00674 /* ImageLibImageBitmapFillFromVFS */
00675
00676 /**
00677  *
00678  * Fills a 16 bit bitmap with an image from a VFS volume. The library
00679  * decompresses the image from the volume and stores it in the supplied bitmap.
00680  * The image is resized to fit the dimensions of the supplied bitmap.
00681  *
00682  * The imageP argument should represent a bitmap created with
00683  * ImageLibImageBitmapCreate or ImageLibImageBitmapCreateFromVFS.
00684  *
00685  * The image is resampled as necessary to fit the
00686  * dimensions of imageP. When the image is a jpeg, the DCT scaling features of
00687  * the IJG library are used to get the image size close to the destination size.
00688  * From there, the image is resampled with a filter to match the dimensions of
00689  * imageP. If the aspect ratio of imageP does not match the aspect ratio of
00690  * the picture, the picture is stretched to fit.
00691  *
00692  * @see ImageLibImageBitmapCreate
00693  * @see ImageLibImageBitmapCreateFromVFS
00694  * @see ImageLibBitmapDelete
00695  *
00696  * @param   libRef:     IN:  Library reference number.
00697  * @param   volRefNum:  IN:  Ref number of the VFS volume
00698  * @param   fileName:   IN:  Filename of the image (ie "/DCIM/picture001.jpg")
00699  * @param   imageP:     IN,OUT:  Bitmap to fill.
00700  * @retval  Err 0 on success, non-zero on error.
00701  *
00702  ****************************************************************/
00703 Err ImageLibImageBitmapFillFromVFS(UInt16 libRef, UInt16 volRefNum,
00704                                    const char* fileName, BitmapType* imageP)
00705     SYS_TRAP(kImageLibTrapImageBitmapFillFromVFS);
00706
00707
00708 /****************************************************************/
00709 /* ImageLibImageDrawFromVFS*/
00710
00711 /**
00712  * Draws an image from from a VFS volume to the current draw window at x,y.
00713  * x and y are window relative coordinates.
00714  *
00715  * If necessary, the image is downsized to fit in a 160x120 box. The
00716  * aspect ratio of the picture is preserved.
00717  *
00718  * @param   libRef:     IN:  Library reference number.
00719  * @param   volRefNum:  IN:  Ref number of the VFS volume
00720  * @param   fileName:   IN:  Filename of the image (ie "/DCIM/picture001.jpg")
00721  * @param   x:          IN:  x location to draw the image, relative to the current draw window.
00722  * @param   y:          IN:  y location to draw the image, relative to the current draw window.
00723  * @retval  Err 0 on success, non-zero on error.
00724  *
00725  ****************************************************************/
00726 Err ImageLibImageDrawFromVFS(UInt16 libRef, UInt16 volRefNum,
00727                              const char* fileName, Coord x, Coord y)
00728     SYS_TRAP(kImageLibTrapImageDrawFromVFS);
00729
00730
00731 /****************************************************************/
00732 /* ImageLibThumbnailBitmapCreateFromVFS */
00733
00734 /**
00735  * Creates a 16 bit bitmap for holding an thumbnail image for a VFS JPEG.
00736  *
00737  * When called from a 68k application, the return value should be treated
00738  * as opaque. The bitmap can safely be passed to the Palm OS bitmap routines,
00739  * but 68k applications should not attempt to dereference members of the bitmap
00740  * structure directly.
00741  *
00742  * Bitmaps created with this function should be disposed of by calling
00743  * ImageLibBitmapDelete. Do note call BmpDelete or MemPtrFree.
00744  *
00745  * If an error occurs, this function returns NULL and writes an error code
00746  * to errP. If the function returns a non-NULL bitmap value, then *errP will
00747  * always be 0.
00748  *
00749  * The thumbnail is generated on the fly from VFS file. For large images,
00750  * this operation can be slow.
00751  *
00752  * @see ImageLibBitmapDelete
00753  *
00754  * @param   libRef:     IN:  Library reference number.
00755  * @param   volRefNum:  IN:  Ref number of the VFS volume
00756  * @param   fileName:   IN:  Filename of the image (ie "/DCIM/picture001.jpg")
00757  * @param   errP:       OUT: If the function succeeds, 0 is written to errP. Otherwise, a non-zero error code is written. This parameter should not be NULL.
00758  * @retval  BitmapType* On success, the result is a new bitmap with a bit depth of 16. On error, the result is NULL.
00759  *
00760  ****************************************************************/
00761 BitmapType* ImageLibThumbnailBitmapCreateFromVFS (UInt16 libRef,
00762                                                   UInt16 volRefNum,
00763                                                   const char* fileName,
00764                                                   Err *errP)
00765     SYS_TRAP(kImageLibTrapThumbnailBitmapCreateFromVFS);
00766
00767
00768 /****************************************************************/
00769 /* ImageLibImageBitmapFillFromVFS */
00770
00771 /**
00772  * Fills a bitmap with a thumbnail image from a VFS volume. *
00773  *
00774  * The imageP argument should represent a bitmap created with
00775  * ImageLibThumbnailBitmapCreate or ImageLibThumbnailBitmapCreateFromVFS.
00776  *
00777  * The image is resampled as necessary to fit the
00778  * dimensions of imageP.
00779  *
00780  * @see ImageLibThumbnailBitmapCreate
00781  * @see ImageLibThumbnailBitmapCreateFromVFS
00782  * @see ImageLibBitmapDelete
00783  *
00784  * @param   libRef:     IN:  Library reference number.
00785  * @param   volRefNum:  IN:  Ref number of the VFS volume
00786  * @param   fileName:   IN:  Filename of the image (ie "/DCIM/picture001.jpg")
00787  * @param   imageP:     IN,OUT:  Bitmap to fill.
00788  * @retval  Err 0 on success, non-zero on error.
00789  *
00790  ****************************************************************/
00791 Err ImageLibThumbnailBitmapFillFromVFS(UInt16 libRef, UInt16 volRefNum,
00792                                        const char* fileName, BitmapType* imageP)
00793     SYS_TRAP(kImageLibTrapThumbnailBitmapFillFromVFS);
00794
00795 /****************************************************************/
00796 /* ImageLibThumbnailDrawFromVFS*/
00797
00798 /**
00799  * Draws an thumbnail image from a VFS image to the current draw window at x,y.
00800  * x and y * are window relative coordinates.
00801  *
00802  * @param   libRef:     IN:  Library reference number.
00803  * @param   volRefNum:  IN:  Ref number of the VFS volume
00804  * @param   fileName:   IN:  Filename of the image (ie "/DCIM/picture001.jpg")
00805  * @param   x:          IN:  x location to draw the preview image, relative to the current draw window.
00806  * @param   y:          IN:  y location to draw the preview image, relative to the current draw window.
00807  * @retval  Err 0 on success, non-zero on error.
00808  *
00809  ****************************************************************/
00810 Err ImageLibThumbnailDrawFromVFS(UInt16 libRef, UInt16 volRefNum, const char* fileName, Coord x, Coord y)   SYS_TRAP(kImageLibTrapThumbnailDrawFromVFS);
00811
00812
00813 /****************************************************************/
00814 /* ImageLibDoAttachImageDialog*/
00815
00816 /**
00817  * Displays the attach image dialog.
00818  *
00819  * Displays the attach image dialog. Allows to user to select a picture from a
00820  * list. After choosing an image, the selection is written to the output
00821  * parameters recIndexP, volRefNum, and filename.
00822  *
00823  * If the user cancels the dialog, the return value is still 0. The values
00824  * in recIndexP and volRefNumP indicate that the dialog was cancelled.
00825  *
00826  * @param   libRef:             IN:  Library reference number.
00827  * @param   recIndexP:          OUT: If the user selects an image from the database, recIndexP will contain the index of the image. If the user selects an image from a VFS volume, or they cancel the dialog, or an error occurs, recIndexP will contain kInvalidRecIndex.
00828  * @param   volRefNumP:         OUT: If the user selects an image from the VFS system, volRefNumP will contain the volume ref number of the selected image. In all other cases, volRefNumP will contain vfsInvalidVolRef.
00829  * @param   fileName:           OUT: If the user selects an image from the VFS system, the full path of the file will be copied into fileNameP. fileName should be capable of holding the largest possible VFS filename. If the user does not select a VFS file, fileName[0] will be NULL.
00830  * @param   initialCategory:    IN:  The initial category that should be highlighted in the category dropdown. Pass 0 for unfiled. Pass dmAllCategories to show all pictures from the database.
00831  * @param   showConfirmation:   IN:  If true, a confirmation dialog will be displayed that shows the image in full size. If false, the confirmation dialog is skipped.
00832  * @param   internalImagesOnly: IN:  If true, images from VFS volumes are not displayed to the user.
00833  * @param   dialogTitle:        IN:  The string to display as the title of the dialog. Pass null to display a localized default.
00834  * @param   btnTitle:           IN:  The string to display as the title of the OK button. Pass null to display a localized default.
00835  * @retval  Err 0 on success, non-zero on error.
00836  *
00837  ****************************************************************/
00838 Err ImageLibDoAttachImageDialog(UInt16 libRef,
00839                                 UInt16 *recIndexP,
00840                                 UInt16 *volRefNumP,
00841                                 char* fileName,
00842                                 UInt16 initialCategory,
00843                                 Boolean showConfirmation,
00844                                 Boolean internalImagesOnly,
00845                                 const char *dialogTitle,
00846                                 const char * btnTitle)
00847     SYS_TRAP(kImageLibTrapDoAttachImageDialog);
00848
00849
00850 /****************************************************************/
00851 /* ImageLibCopyImageToBuffer*/
00852
00853 /**
00854  * Copies a JPEG from the image database to a chunk of memory at bufP. The
00855  * allocated memory block must be large enough to hold the entire blob of JPEG
00856  * data. The size of the JPEG can be determined with ImageLibGetImageInfo.
00857  *
00858  * Fullsize images may requires that bufP be larger than 64 kB. Use
00859  * FtrPtrNew or MemChunkNew to create buffers larger than 64 kB. Otherwise,
00860  * consider using ImageLibCopyImageToFile instead.
00861  *
00862  * @see ImageLibGetImageInfo
00863  * @see ImageLibCopyImageToFile
00864  *
00865  * @param   libRef:     IN:  Library reference number.
00866  * @param   recIndex:   IN:  Index of the picture
00867  * @param   bufP:       IN,OUT: Pointer to the block of memory that should receive the image.
00868  * @retval  Err 0 on success, non-zero on error.
00869  *
00870  ****************************************************************/
00871 Err ImageLibCopyImageToBuffer (UInt16 libRef, UInt16 recIndex, MemPtr bufP)
00872     SYS_TRAP(kImageLibTrapCopyImageToBuffer     );
00873
00874
00875 /****************************************************************/
00876 /* ImageLibCopyImageToFile*/
00877
00878 /**
00879  * Copies a JPEG from the image database to a Palm OS file stream. The library
00880  * writes to the file stream at its current postion. When done, the library
00881  * leaves the file handle pointing to the end of the file. To see the jpeg data,
00882  * the file handle should be rewound to its original location.
00883  *
00884  * @param   libRef:     IN:  Library reference number.
00885  * @param   recIndex:   IN:  Index of the picture
00886  * @param   fileH:      IN:  Handle to an open file stream.
00887  * @retval  Err 0 on success, non-zero on error.
00888  *
00889  ****************************************************************/
00890 Err ImageLibCopyImageToFile (UInt16 libRef, UInt16 recIndex, FileHand fileH)
00891     SYS_TRAP(kImageLibTrapCopyImageToFile);
00892
00893
00894 /****************************************************************/
00895 /* ImageLibInsertImageFromBuffer*/
00896
00897 /**
00898  * Inserts a JPEG blob into the image database, storing it with the supplied
00899  * name and category.
00900  *
00901  * @param   libRef:         IN:  Library reference number.
00902  * @param   bufP:           IN:  Pointer to a JPEG image in memory.
00903  * @param   size:           IN:  Size of the source image in bytes.
00904  * @param   name:           IN:  Name of the new image (ie "Picture001")
00905  * @param   category:       IN:  The category to store the image in. Pass 0 for unfiled.
00906  * @param   newRecIndexP:   OUT: Index of the newly created image. Pass NULL if you don’t care about this value.
00907  * @retval  Err 0 on success, non-zero on error.
00908  *
00909  ****************************************************************/
00910 Err ImageLibInsertImageFromBuffer(UInt16 libRef, MemPtr bufP, UInt32 size,
00911                                   const char * name, UInt16 category,
00912                                   UInt16 *newRecIndexP)
00913     SYS_TRAP(kImageLibTrapInsertImageFromBuffer );
00914
00915
00916 /****************************************************************/
00917 /* ImageLibInsertImageFromBuffer*/
00918
00919 /**
00920  * Insert an image into the database from a Palm OS file stream. The file stream
00921  * is read from its current position to the end of the stream. When the routine
00922  * is finished, it leaves the stream open and performs a FileSeek back to the
00923  * original position.
00924  *
00925  * @param   libRef:         IN:  Library reference number.
00926  * @param   fileH:          IN:  Handle to an open file stream that contains a JPEG starting at its current position.
00927  * @param   name:           IN:  Name of the new image (ie "Picture001")
00928  * @param   category:       IN:  The category to store the image in. Pass 0 for unfiled.
00929  * @param   newRecIndexP:   OUT: Index of the newly created image. Pass NULL if you don’t care about this value.
00930  * @retval  Err 0 on success, non-zero on error.
00931  *
00932  ****************************************************************/
00933 Err ImageLibInsertImageFromFile(UInt16 libRef, FileHand fileH,
00934                                const char * name, UInt16 category,
00935                                UInt16 *newRecIndexP)
00936     SYS_TRAP(kImageLibTrapInsertImageFromFile   );
00937
00938
00939 /****************************************************************/
00940 /* ImageLibIterateImages*/
00941
00942 /**
00943  * Creates an iterator for working with a collection of images in the database.
00944  * When finished, the iterator refers to a data structure that contains images
00945  * The iterator can be used to step through images, draw images, sort images, and search for
00946  * images by name.
00947  *
00948  * The returned iterator handle can be passed to other iterator routines
00949  * that take an iterator handle. The handle should be freed by calling
00950  * ImageLibIterFree.
00951  *
00952  * @see ImageLibIterFree
00953  *
00954  * @param   libRef:         IN:  Library reference number.
00955  * @param   category:       IN:  The category to search. Pass 0 for unfiled. Pass dmAllCategories to iterate through all images in the databse.
00956  * @param   sortType:       IN:  Initial sort order of the datastructure (kNoSortOrder, kSortByName, or kSortByDate)
00957  * @param   imageCountP:    OUT: Number of images in the iterator data structure. Pass NULL if you don't care about this value.
00958  * @param   errP:           OUT: 0 on success, non-zero on error. This parameter should not be null.
00959  * @retval  ImageIteratorHandle Opaque iterator handle.
00960  *
00961  ****************************************************************/
00962 ImageIteratorHandle ImageLibIterateImages(UInt16 libRef,
00963                                           UInt16 category,
00964                                           UInt16 sortType,
00965                                           UInt16 *imageCountP,
00966                                           Err *errP)
00967     SYS_TRAP(kImageLibTrapIterateImages);
00968
00969 /****************************************************************/
00970 /* ImageLibIterateVFSImages*/
00971
00972 /**
00973  * Creates an iterator for working with a collection of images on a
00974  * VFS volume. When finished, the iterator refers to a data structure that
00975  * contains images. The iterator can be used to step through images, draw
00976  * images, sort images, and search for images by name.
00977  *
00978  * The returned iterator handle can be passed to other iterator routines
00979  * that take an iterator handle. The handle should be freed by calling
00980  * ImageLibIterFree.
00981  *
00982  * @see ImageLibIterFree
00983  *
00984  * @param   libRef:         IN:  Library reference number.
00985  * @param   volRefNum:      IN:  VFS volume to search.
00986  * @param   path:           IN:  Directory to start searching in.
00987  * @param   recurseBelow:   IN:  true to recurse in all subdirectories of path. false to search in path only.
00988  * @param   sortType:       IN:  Initial sort order of the datastructure (kNoSortOrder, kSortByName, or kSortByDate)
00989  * @param   imageCount:     OUT: Number of images in the iterator data structure. Pass NULL if you don't care about this value.
00990  * @param   errP:           OUT: 0 on success, non-zero on error. This parameter should not be null.
00991  * @retval  ImageIteratorHandle Opaque iterator handle.
00992  *
00993  ****************************************************************/
00994 ImageIteratorHandle ImageLibIterateVFSImages(UInt16 libRef,
00995                                              UInt16 volRefNum,
00996                                              const char *path,
00997                                              Boolean recurseBelow,
00998                                              UInt16 sortType,
00999                                              UInt16 *imageCount, Err *errP)
01000     SYS_TRAP(kImageLibTrapIterateVFSImages)  ;
01001
01002
01003 /****************************************************************/
01004 /* ImageLibIterSort*/
01005
01006 /**
01007  * Sorts the images in an iterator chain. Note that this only reorganizes images
01008  * in the iterator data structure. This does not alter the way images are stored
01009  * in the database or on a card.
01010  * images, sort images, and search for images by name.
01011  *
01012  * The iterator handle should be created with ImageLibIterateImages or
01013  * ImageLibIterateVFSImages.
01014  *
01015  * @see ImageLibIterateImages
01016  * @see ImageLibIterateVFSImages
01017  *
01018  * @param   libRef:     IN:  Library reference number.
01019  * @param   iter:       IN:  Handle to an iterator.
01020  * @param   sortType:   IN:  New sort order of the datastructure (kNoSortOrder, kSortByName, kSortByDate, kSortByNameDesc, or kSortByDateDesc)
01021  * @retval  Err 0 on success, non-zero on error.
01022  *
01023  ****************************************************************/
01024 Err ImageLibIterSort (UInt16 libRef,ImageIteratorHandle iter, UInt16 sortType )
01025     SYS_TRAP(kImageLibTrapIterSort);
01026
01027 /****************************************************************/
01028 /* ImageLibIterGetImageInfo*/
01029 /**
01030  * Retrieves information about a single image in an iterator chain.
01031  *
01032  * The iterator handle should be created with ImageLibIterateImages or
01033  * ImageLibIterateVFSImages.
01034  *
01035  * Pass NULL for any OUT parameter that you don't care about.
01036  *
01037  * @see ImageLibIterateImages
01038  * @see ImageLibIterateVFSImages
01039  *
01040  * @param   libRef:     IN:  Library reference number.
01041  * @param   iter:       IN:  Handle to an iterator.
01042  * @param   index:      IN:  Index of the image in the iterator. [0,imageCount)
01043  * @param   name:       OUT: Buffer to receive the name of the image. For VFS images, this is the full path and filename of the image (ie "/dcim/picture001.jpg"). For internal images, this is the name of the picture (ie "Picture001")
01044  * @param   nameLen:    IN:  Size in bytes of the name buffer.
01045  * @param   categoryP:  OUT: Category of the picture if it is stored in the image database. 0xFF if it is a VFS picture.
01046  * @param   recIndexP:  OUT: Record index of the picture if it is stored in the image database. kInvalidRecIndex if it is a VFS picture.
01047  * @param   volRefNumP: OUT: VFS volume ref number of the picture if it is stored on a VFS volume. vfsInvalidVolRef if it is stored in the internal database.
01048  * @param   createdP:   OUT: Timestamp when picture was creatd. Pass NULL for this parameter if you don't want to retrieve it.
01049  * @param   sizeP:      OUT: Size of the image data in bytes. Pass NULL for this parameter if you don't want to retrieve it.
01050  * @param   path:       OUT: Directory that the picture is stored in if it is a VFS image (ie /DCIM). Empty string if it is an internal image.
01051  * @param   pathLen:    IN:  Size in bytes of the path buffer.
01052  * @param   lockedP:    OUT: true if the image is locked. False otherwise. VFS images are never locked.
01053  * @retval  Err 0 on success, non-zero on error.
01054  *
01055  ****************************************************************/
01056 Err ImageLibIterGetImageInfo(UInt16 libRef, ImageIteratorHandle iter,
01057                              UInt16 index, char *name, UInt16 nameLen,
01058                              UInt16 *categoryP, UInt16 *recIndexP,
01059                              UInt16 *volRefNumP, UInt32* createdP,
01060                              UInt32* sizeP, char *path, UInt16 pathLen,
01061                              Boolean *lockedP)
01062     SYS_TRAP(kImageLibTrapIterGetImageInfo)  ;
01063
01064
01065 /****************************************************************/
01066 /* ImagelibIterGetCount*/
01067
01068 /**
01069  * Retrieves the number of images stored in the iterator data structure.
01070  *
01071  * The iterator handle should be created with ImageLibIterateImages or
01072  * ImageLibIterateVFSImages.
01073  *
01074  * Iterator routines that take an index should ensure that the index is
01075  * less than the value returned in imageCountP.
01076  *
01077  * @see ImageLibIterateImages
01078  * @see ImageLibIterateVFSImages
01079  *
01080  * @param   libRef:         IN:  Library reference number.
01081  * @param   iter:           IN:  Handle to an iterator.
01082  * @param   imageCountP:    OUT: Number of images in the iterator data structure.
01083  * @retval  Err 0 on success, non-zero on error.
01084  *
01085  ****************************************************************/
01086 Err ImagelibIterGetCount(UInt16 libRef, ImageIteratorHandle iter,
01087                          UInt16 *imageCountP)
01088     SYS_TRAP(kImagelibTrapIterGetCount) ;
01089
01090 /****************************************************************/
01091 /* ImageLibIterDeleteImage*/
01092
01093 /**
01094  * Deletes an image (either from the database or from a VFS volume)
01095  *
01096  * Permanently deletes an image given a reference to the image in an iterator.
01097  * Given an iterator and an index to an image in the iterator, this routine
01098  * determines whether the image resides in the internal database or on a VFS
01099  * volume. If it resides on a VFS volume, the routine attempts to delete it by
01100  * calling VFSFileDelete. If it is an internal image, the picture is nuked by
01101  * calling ImageLibDeleteImage. After the image is deleted, it is removed from
01102  * the iterator chain. All subsequent images in the iterator data structure move
01103  * down one spot. The count of images in the iterator chain is decremented by
01104  * one.
01105  *
01106  * The iterator handle should be created with ImageLibIterateImages or
01107  * ImageLibIterateVFSImages.
01108  *
01109  * Deleting an image invalidates the iterator index for all subsequent
01110  * images in the iterator chain. If you need to delete a range of images in an
01111  * iterator, it is best to loop from back to front.
01112  *
01113  * @param   libRef:  IN:  Library reference number.
01114  * @param   iter:    IN:  Handle to an iterator.
01115  * @param   index:   IN:  Index of the image to delete. This is an index into the iterator, not an index to the image database.
01116  * @retval  Err 0 on success, non-zero on error.
01117  *
01118  ****************************************************************/
01119 Err ImageLibIterDeleteImage(UInt16 libRef,ImageIteratorHandle iter,
01120                             UInt16 index)
01121     SYS_TRAP(kImageLibTrapIterDeleteImage) ;
01122
01123 /****************************************************************/
01124 /* ImageLibIterRemoveImage*/
01125
01126 /**
01127  * Removes an image from an iterator chain without deleting it from its
01128  * original location.
01129  *
01130  * Removes an image from an iterator chain without deleting it from its
01131  * original location. Once an image is removed, it can no longer be accessed via
01132  * the iterator. However, the image is still accessible from its original location
01133  * (either in the image database or on a VFS card).
01134  *
01135  * The iterator handle should be created with ImageLibIterateImages or
01136  * ImageLibIterateVFSImages.
01137  *
01138  * Removing an image invalidates the iterator index for all subsequent
01139  * images in the iterator chain. If you need to remove a range of images in an
01140  * iterator, it is best to loop from back to front.
01141  *
01142  * @param   libRef:  IN:  Library reference number.
01143  * @param   iter:    IN:  Handle to an iterator.
01144  * @param   index:   IN:  Index of the image to remove. This is an index into the iterator, not an index to the image database.
01145  * @retval  Err 0 on success, non-zero on error.
01146  *
01147  ****************************************************************/
01148 Err ImageLibIterRemoveImage(UInt16 libRef, ImageIteratorHandle iter,
01149                             UInt16 index)
01150      SYS_TRAP(kImageLibTrapIterRemoveImage) ;
01151
01152
01153 /****************************************************************/
01154 /* ImageLibIterFree*/
01155
01156 /**
01157  * Frees the memory associated with an iterator chain.
01158  *
01159  * The iterator handle should be created with ImageLibIterateImages or
01160  * ImageLibIterateVFSImages.
01161  *
01162  * Once the iterator has been freed, it should not be used anymore.
01163  *
01164  * @param   libRef:  IN:  Library reference number.
01165  * @param   iter:    IN:  Handle to an iterator.
01166  * @retval  Err 0 on success, non-zero on error.
01167  *
01168  ****************************************************************/
01169 Err ImageLibIterFree (UInt16 libRef, ImageIteratorHandle iter)
01170     SYS_TRAP(kImageLibTrapIterFree);
01171
01172
01173 /****************************************************************/
01174 /* ImageLibIterDrawImage*/
01175
01176 /**
01177  * Draws an image in an iterator chain to the current draw window at x,y.
01178  * x and y are window relative coordinates.
01179  *
01180  * If the image resides in the internal database, this routine calls
01181  * ImageLibImageDraw to draw it. If it is a VFS image the call is dispatched to
01182  * ImageLibImageDrawFromVFS
01183  *
01184  * @param   libRef:  IN:  Library reference number.
01185  * @param   iter:    IN:  Handle to an iterator.
01186  * @param   index:   IN:  Index of the image to draw. This is an index into the iterator, not an index to the image database.
01187  * @param   x:       IN:  x location to draw the preview image, relative to the current draw window.
01188  * @param   y:       IN:  y location to draw the preview image, relative to the current draw window.
01189  * @retval  Err 0 on success, non-zero on error.
01190  *
01191  ****************************************************************/
01192 Err ImageLibIterDrawImage(UInt16 libRef, ImageIteratorHandle iter,
01193                           UInt16 index, Coord x, Coord y)
01194     SYS_TRAP(kImageLibTrapIterDrawImage);
01195
01196
01197 /****************************************************************/
01198 /* ImageLibIterDrawThumbnail*/
01199
01200 /**
01201  * Draws a thumbnail for an image in an iterator chain to the current draw
01202  * window at x,y. x and y are window relative coordinates.
01203  *
01204  * If the image resides in the internal database, this routine calls
01205  * ImageLibThumbnailDraw to draw it. If it is a VFS image the call is dispatched to
01206  * ImageLibThumbnailDrawFromVFS
01207  *
01208  * @param   libRef:  IN:  Library reference number.
01209  * @param   iter:    IN:  Handle to an iterator.
01210  * @param   index:   IN:  Index of the image to draw. This is an index into the iterator, not an index to the image database.
01211  * @param   x:       IN:  x location to draw the preview image, relative to the current draw window.
01212  * @param   y:       IN:  y location to draw the preview image, relative to the current draw window.
01213  * @retval  Err 0 on success, non-zero on error.
01214  *
01215  ****************************************************************/
01216 Err ImageLibIterDrawThumbnail (UInt16 libRef, ImageIteratorHandle iter,
01217                                UInt16 index, Coord x, Coord y)
01218     SYS_TRAP(kImageLibTrapIterDrawThumbnail);
01219
01220 /****************************************************************/
01221 /* ImageLibIterSearch*/
01222
01223 /**
01224  * Searches for an image in an iterator chain by name. To match, a picture's
01225  * name must the name string starting in the first character. If partical match
01226  * is true, then the entire string must match. Case is ignored for all
01227  * comparisons. Pattern matching and wildcards are not supported.
01228  *
01229  * @param   libRef:       IN:  Library reference number.
01230  * @param   iterH:        IN:  Handle to an iterator.
01231  * @param   name:         IN:  String to search for.
01232  * @param   partialMatch: IN:  If true, only the beginning of a picture name must match. If false, the entire name must match.
01233  * @param   index:        OUT: Contains the index of the first picture that matches the search string. kInvalidRecIndex if no match found.
01234  * @retval  Err 0 on success, non-zero on error.
01235  *
01236  ****************************************************************/
01237 Err ImageLibIterSearch(UInt16 libRef, ImageIteratorHandle iterH,
01238                        const char *name, Boolean partialMatch,
01239                        UInt16 *index)
01240     SYS_TRAP(kImageLibTrapIterSearch);
01241
01242 /****************************************************************/
01243 /* ImageLibSetProgressCallback*/
01244
01245 /**
01246  * Sets a progress callback function. The image library will invoke this routine
01247  * periodically during long processing, such as compressing or decompressing a
01248  * jpeg or resizing an image.
01249  *
01250  * All of the APIs that decompress or resize images use the callback
01251  * mechanism. ImageLibImageSave also invokes it.
01252  *
01253  * max is the total number of operations that must be performed. For a JPEG
01254  * compression or decompression, this equates to the number of horizontal
01255  * scan lines in the image. The progress value will range from 0 to max.
01256  * The imaging library will invoked the callback repeatedly. On each pass, the
01257  * progress variable will increase by some unspecified amount. The operation
01258  * argument determines the type of operation being performed. Possible values
01259  * are kResizeOperation, kJPEGOperation, and kVFSOperation.
01260  *
01261  * The callback function should have the following signature:
01262  *
01263  * @code void callback(Int32 progress, Int32 max, Int8 operation);@endcode
01264  *
01265  * @param   libRef:     IN:  Library reference number.
01266  * @param   callback:   IN:  Address of the callback function. Pass NULL to reset the callback to nothing.
01267  * @retval  void
01268  *
01269  ****************************************************************/
01270 void ImageLibSetProgressCallback(UInt16 libRef,
01271                                  ImageLibProgressCallbackType callback)
01272     SYS_TRAP(kImageLibTrapSetProgressCallback);
01273
01274
01275 /****************************************************************/
01276 /* ImageLibCopyImage*/
01277
01278 /**
01279  * Creates a copy of an image in the database.
01280  *
01281  * @param   libRef:       IN:  Library reference number.
01282  * @param   recIndex:     IN:  Index of the image to copy.
01283  * @param   newName:      IN:  Name of the newly copied image.
01284  * @param   newRecIndexP: OUT: Index of the newly copied image. Pass NULL if you don't care about this value.
01285  * @retval  Err 0 on success, non-zero on error.
01286  *
01287  ****************************************************************/
01288 Err ImageLibCopyImage(UInt16 libRef, UInt16 recIndex,
01289                       const char *newName, UInt16 *newRecIndexP)
01290     SYS_TRAP(kImageLibTrapCopyImage);
01291
01292
01293 /****************************************************************/
01294 /* ImageLibFindImageByID*/
01295
01296 /**
01297  * Determines the record index of an image in the database given a unique ID.
01298  * The image is found by calling DmFindRecordByID on the main database.
01299  *
01300  * If you need to store a permanent reference to a picture in the
01301  * database, it is best to store its unique ID. You can obtain the unique ID
01302  * of an image by calling ImageLibGetImageInfo. To access an image by unique
01303  * ID, call ImageLibFindImageByID to retrieve the record index, and then use
01304  * the record index to access the picture.
01305  *
01306  * @see ImageLibGetImageInfo
01307  *
01308  * @param   libRef:       IN:  Library reference number.
01309  * @param   uniqueID:     IN:  Unique ID of the image to find.
01310  * @param   recIndexP:    OUT: Record index of the image.
01311  * @retval  Err 0 on success, non-zero on error.
01312  *
01313  ****************************************************************/
01314 Err ImageLibFindImageByID (UInt16 libRef, UInt32 uniqueID, UInt16 *recIndexP)
01315     SYS_TRAP(kImageLibTrapFindImageByID);
01316
01317
01318 /****************************************************************/
01319 /* ImageLibPreviewStart*/
01320
01321 /**
01322  * Turns on the direct draw preview mode of the camera.
01323  *
01324  * This routine serves as a front end to the camera driver's
01325  * CameraLibPreviewStart function. After being called, the camera will display
01326  * preview images to the supplied window at the given coordinates.
01327  *
01328  * @see ImageLibPreviewStop
01329  *
01330  * @param   libRef:       IN:  Library reference number.
01331  * @param   windowH:      IN:  Window handle where preview images should be drawn. This should generally be a screen window.
01332  * @param   x:            IN:  x location to draw the preview image. Relative to windowH.
01333  * @param   y:            IN:  y location to draw the preview image. Relative to windowH.
01334  * @retval  Err 0 on success, non-zero on error.
01335  *
01336  ****************************************************************/
01337 Err ImageLibPreviewStart (UInt16 libRef, void * windowH, Coord x, Coord y)
01338     SYS_TRAP(kImageLibTrapPreviewStart);
01339
01340 /****************************************************************/
01341 /* ImageLibPreviewStop*/
01342
01343 /**
01344  * Turns off the direct draw preview mode of the camera.
01345  *
01346  * This routine serves as a front end to the camera driver's
01347  * CameraLibPreviewStop function. It halts previews that were initiated by a
01348  * call to ImageLibPreviewStart.
01349  *
01350  * @see ImageLibPreviewStart
01351  *
01352  * @param   libRef:       IN:  Library reference number.
01353  * @retval  Err 0 on success, non-zero on error.
01354  *
01355  ****************************************************************/
01356 Err ImageLibPreviewStop  (UInt16 libRef)
01357     SYS_TRAP(kImageLibTrapPreviewStop);
01358
01359 /****************************************************************/
01360 /* ImageLibDrawJPEG*/
01361
01362 /**
01363  * Decompresses a blob of JPEG data and draws it to the current draw window.
01364  * The picture is drawn at left,top, which are relative to the draw window.
01365  *
01366  * If the image needs to be resized, its aspect ratio is maintained. To
01367  * determine how an image will be resized beforehand, call
01368  * ImageLibGetDimensionsJPEG.
01369  *
01370  * @see ImageLibGetDimensionsJPEG
01371  *
01372  * @param   libRef:       IN:  Library reference number.
01373  * @param   jpegDataP:    IN:  Pointer to a JPEG image in memory.
01374  * @param   jpegSize:     IN:  Size of the source image in bytes.
01375  * @param   left:         IN:  x location to draw the image, relative to the current draw window.
01376  * @param   top:          IN:  y location to draw the image, relative to the current draw window.
01377  * @param   fitToScreen:  IN:  If true, the JPEG is resized to fit in a box defined by width and height. If false, image is not resized.
01378  * @param   width:        IN:  Max width of drawn image. Ignored if fitToScreen is false.
01379  * @param   height:       IN:  Max height of drawn image. Ignored if fitToScreen is false.
01380  * @retval  Err 0 on success, non-zero on error.
01381  *
01382  ****************************************************************/
01383 Err ImageLibDrawJPEG(UInt16 libRef, MemPtr jpegDataP, UInt32 jpegSize,
01384                      Coord left, Coord top, Boolean fitToScreen,
01385                      Coord width, Coord height)
01386     SYS_TRAP(kImageLibTrapDrawJPEG);
01387
01388 /****************************************************************/
01389 /* ImageLibTurnCameraOff*/
01390
01391 /**
01392  * Deactivates the camera hardware by unloading the camera driver.
01393  *
01394  * @param   libRef:       IN:  Library reference number.
01395  * @retval  Err 0 on success, non-zero on error.
01396  *
01397  ****************************************************************/
01398 Err ImageLibTurnCameraOff(UInt16 libRef)
01399     SYS_TRAP(kImageLibTrapTurnCameraOff);
01400
01401 /****************************************************************/
01402 /* ImageLibSetImageID*/
01403
01404 /**
01405  * Sets the media and container IDs for an image in the database.
01406  *
01407  * The media ID and container ID should both be 21 bytes in size. The image
01408  * library copies 21 bytes from the supplied buffers into the main record for the
01409  * image.
01410  *
01411  * @see ImageLibGetImageID
01412  *
01413  * @param   libRef:         IN:  Library reference number.
01414  * @param   recIndex:       IN:  Index of image.
01415  * @param   mediaIDP:       IN:  Media ID.
01416  * @param   containerIDP:   IN: Container ID.
01417  * @retval  Err 0 on success, non-zero on error.
01418  *
01419  ****************************************************************/
01420 Err ImageLibSetImageID(UInt16 libRef, UInt16 recIndex,
01421                       const char* mediaIDP, const char *containerIDP)
01422     SYS_TRAP(kImageLibTrapSetImageID);
01423
01424 /****************************************************************/
01425 /* ImageLibGetImageID*/
01426
01427 /**
01428  * Gets the media and container IDs for an image in the database.
01429  *
01430  * The media ID and container ID should both be at least 21 bytes in size.
01431  * The library copies 21 bytes to the supplied buffers.
01432  *
01433  * @see ImageLibSetImageID
01434  *
01435  * @param   libRef:         IN:  Library reference number.
01436  * @param   recIndex:       IN:  Index of image.
01437  * @param   mediaIDP:       IN:  Media ID.
01438  * @param   containerIDP:   IN: Container ID.
01439  * @retval  Err     0 on success, non-zero on error.
01440  *
01441  ****************************************************************/
01442 Err ImageLibGetImageID(UInt16 libRef, UInt16 recIndex,
01443                       char* mediaIDP, char *containerIDP)
01444     SYS_TRAP(kImageLibTrapGetImageID);
01445
01446 /****************************************************************/
01447 /* ImageLibGetDimensions*/
01448
01449 /**
01450  * Retrieves the dimensions of an image in the database.
01451  *
01452  * This routine allows clients of the library to query the dimensions of an image
01453  * in the database. If fitToDimensions is false, the routine copies the full
01454  * dimensions of the image to widthP and heightP. The initial values of widthP
01455  * and heightP are ignored. If fitToDimensions is true, the routine calculates
01456  * how big the image will be after it is downsized to fit in a box determined
01457  * by the initial values of widthP and heightP.
01458  *
01459  * @param   libRef:             IN:  Library reference number.
01460  * @param   recIndex:           IN:  Index of image.
01461  * @param   width:              IN,OUT: On output, contains the width of the image. On input, if fitToDimensions is true, determines the max width that the image should be.
01462  * @param   height:         IN,OUT: On output, contains the height of the image. On input, if fitToDimensions is true, determines the max height that the image should be.
01463  * @param   fitToDimensions:    IN: If true, tells the library to return the dimensions that an image would be if it was forced to draw in a box bounded by widthP and heightP.
01464  * @retval  Err 0 on success, non-zero on error.
01465  *
01466  ****************************************************************/
01467 Err ImageLibGetDimensions     (UInt16 libRef, UInt16 recIndex,
01468                                Coord *width, Coord *height,
01469                                Boolean fitToDimensions)
01470     SYS_TRAP(kImageLibTrapGetDimensions    );
01471
01472
01473 /****************************************************************/
01474 /* ImageLibGetDimensionsVFS*/
01475
01476 /**
01477  * Retrieves the dimensions of an image on a VFS volume.
01478  *
01479  * This routine allows clients of the library to query the dimensions of an image
01480  * that resides on a VFS volume. The routine follows the same semantics as
01481  * ImageLibGetDimensions.
01482  *
01483  * @see ImageLibGetDimensions
01484  *
01485  * @param   libRef:             IN:  Library reference number.
01486  * @param   volRefNum:          IN:  Ref number of the VFS volume
01487  * @param   fileName:           IN:  Filename of the image (ie "/DCIM/picture.jpg")
01488  * @param   width:              IN,OUT: On output, contains the width of the image. On input, if fitToDimensions is true, determines the max width that the image should be.
01489  * @param   height:         IN,OUT: On output, contains the height of the image. On input, if fitToDimensions is true, determines the max height that the image should be.
01490  * @param   fitToDimensions:    IN: If true, tells the library to return the dimensions that an image would be if it was forced to draw in a box bounded by widthP and heightP.
01491  * @retval  Err 0 on success, non-zero on error.
01492  *
01493  ****************************************************************/
01494 Err ImageLibGetDimensionsVFS  (UInt16 libRef, UInt16 volRefNum,
01495                                const char* fileName,  Coord *width,
01496                                Coord *height, Boolean fitToDimensions)
01497     SYS_TRAP(kImageLibTrapGetDimensionsVFS );
01498
01499
01500 /****************************************************************/
01501 /* ImageLibIterGetDimensions*/
01502
01503 /**
01504  * Retrieves the dimensions of an image in an iterator chain.
01505  *
01506  * This routine allows clients of the library to query the dimensions of an image
01507  * in an iterator chain. The routine follows the same semantics as
01508  * ImageLibGetDimensions.
01509  *
01510  * @see ImageLibGetDimensions
01511  *
01512  * @param   libRef:             IN:  Library reference number.
01513  * @param   iter:               IN:  Iterator handle
01514  * @param   index:              IN:  Index of the image in the iterator. [0,imageCount)
01515  * @param   width:              IN,OUT: On output, contains the width of the image. On input, if fitToDimensions is true, determines the max width that the image should be.
01516  * @param   height:         IN,OUT: On output, contains the height of the image. On input, if fitToDimensions is true, determines the max height that the image should be.
01517  * @param   fitToDimensions:    IN: If true, tells the library to return the dimensions that an image would be if it was forced to draw in a box bounded by widthP and heightP.
01518  * @retval  Err 0 on success, non-zero on error.
01519  *
01520  ****************************************************************/
01521 Err ImageLibIterGetDimensions (UInt16 libRef, ImageIteratorHandle iter,
01522                                UInt16 index, Coord *width, Coord *height,
01523                                Boolean fitToDimensions)
01524     SYS_TRAP(kImageLibTrapIterGetDimensions);
01525
01526
01527 /****************************************************************/
01528 /* ImageLibGetDimensionsJPEG*/
01529
01530 /**
01531  * Retrieves the dimensions of a blob of JPEG data in memory.
01532  *
01533  * This routine allows clients of the library to query the dimensions of an
01534  * arbitrary blob of JPEG data. The routine follows the same semantics as
01535  * ImageLibGetDimensions.
01536  *
01537  * @see ImageLibGetDimensions
01538  *
01539  * @param   libRef:             IN:  Library reference number.
01540  * @param   jpegDataP:          IN:  Pointer to a JPEG image in memory.
01541  * @param   jpegSize:           IN:  Size of the source image in bytes.
01542  * @param   width:              IN,OUT: On output, contains the width of the image. On input, if fitToDimensions is true, determines the max width that the image should be.
01543  * @param   height:         IN,OUT: On output, contains the height of the image. On input, if fitToDimensions is true, determines the max height that the image should be.
01544  * @param   fitToDimensions:    IN: If true, tells the library to return the dimensions that an image would be if it was forced to draw in a box bounded by widthP and heightP.
01545  * @retval  Err 0 on success, non-zero on error.
01546  *
01547  ****************************************************************/
01548 Err ImageLibGetDimensionsJPEG (UInt16 libRef, MemPtr jpegDataP, UInt32 jpegSize,
01549                                Coord *width, Coord *height,
01550                                Boolean fitToDimensions)
01551     SYS_TRAP(kImageLibTrapGetDimensionsJPEG);
01552
01553
01554 /****************************************************************/
01555 /* ImageLibResize*/
01556
01557 /**
01558  * Resizes an image in the database to any arbitrary size.
01559  *
01560  * This routine resizes an image in the database to any size. The routine
01561  * can maintain the existing aspect ratio of the image, or it can stretch it
01562  * to fit any size.
01563  *
01564  * @param   libRef:                 IN:  Library reference number.
01565  * @param   recIndex:               IN:  Index of image.
01566  * @param   widthP:                 IN,OUT: On output, contains the new width of the image. On input, if maintainAspectRatio is true, determines the max width that the image should be. If maintainAspectRatio is false, determines the exact width that the image should be after resizing.
01567  * @param   heightP:                IN,OUT: On output, contains the new width of the image. On input, if maintainAspectRatio is true, determines the max width that the image should be. If maintainAspectRatio is false, determines the exact width that the image should be after resizing.
01568  * @param   maintainAspectRatio:    IN: If true, tells the library to maintain the aspect ratio of the image. In this case, the input values of widthP and heightP serve as maximum guidelines. If false, the image is stretched to fit the input values of widthP and heightP. the dimensions that an image would be if it was forced to draw in a box bounded by widthP and heightP.
01569  * @retval  Err 0 on success, non-zero on error.
01570  *
01571  ****************************************************************/
01572 Err ImageLibResize (UInt16 libRef, UInt16 recIndex,
01573                     Coord *widthP, Coord *heightP, Boolean maintainAspectRatio)
01574     SYS_TRAP(kImageLibTrapResize     );
01575
01576 /****************************************************************/
01577 /* ImageLibResizeVFS*/
01578
01579 /**
01580  * Resizes an image on a VFS volume to any arbitrary size.
01581  *
01582  * This routine resizes a VFS image to any size. The routine follows the same
01583  * semantics as ImageLibResize.
01584  *
01585  * @see ImageLibResize
01586  *
01587  * @param   libRef:                 IN:  Library reference number.
01588  * @param   volRefNum:              IN:  Ref number of the VFS volume
01589  * @param   fileName:               IN:  Filename of the image (ie "/DCIM/picture.jpg")
01590  * @param   widthP:                 IN,OUT: On output, contains the new width of the image. On input, if maintainAspectRatio is true, determines the max width that the image should be. If maintainAspectRatio is false, determines the exact width that the image should be after resizing.
01591  * @param   heightP:                IN,OUT: On output, contains the new width of the image. On input, if maintainAspectRatio is true, determines the max width that the image should be. If maintainAspectRatio is false, determines the exact width that the image should be after resizing.
01592  * @param   maintainAspectRatio:    IN: If true, tells the library to maintain the aspect ratio of the image. In this case, the input values of widthP and heightP serve as maximum guidelines. If false, the image is stretched to fit the input values of widthP and heightP. the dimensions that an image would be if it was forced to draw in a box bounded by widthP and heightP.
01593  * @retval  Err 0 on success, non-zero on error.
01594  *
01595  ****************************************************************/
01596 Err ImageLibResizeVFS(UInt16 libRef, UInt16 volRefNum, const char* fileName,
01597                       Coord *widthP, Coord *heightP,
01598                       Boolean maintainAspectRatio)
01599     SYS_TRAP(kImageLibTrapResizeVFS  );
01600
01601
01602 /****************************************************************/
01603 /* ImageLibIterResize*/
01604
01605 /**
01606  * Resizes an image in an iterator chain.
01607  *
01608  * This routine resizes an image in an iterator chain to any size. The routine
01609  * follows the same semantics as ImageLibResize.
01610  *
01611  * @see ImageLibResize
01612  *
01613  * @param   libRef:                 IN:  Library reference number.
01614  * @param   iter:                   IN:  Iterator handle
01615  * @param   index:                  IN:  Index of the image in the iterator. [0,imageCount)
01616  * @param   widthP:                 IN/OUT: On output, contains the new width of the image. On input, if maintainAspectRatio is true, determines the max width that the image should be. If maintainAspectRatio is false, determines the exact width that the image should be after resizing.
01617  * @param   heightP:                IN/OUT: On output, contains the new width of the image. On input, if maintainAspectRatio is true, determines the max width that the image should be. If maintainAspectRatio is false, determines the exact width that the image should be after resizing.
01618  * @param   maintainAspectRatio:    IN: If true, tells the library to maintain the aspect ratio of the image. In this case, the input values of widthP and heightP serve as maximum guidelines. If false, the image is stretched to fit the input values of widthP and heightP. the dimensions that an image would be if it was forced to draw in a box bounded by widthP and heightP.
01619  * @retval  Err 0 on success, non-zero on error.
01620  *
01621  ****************************************************************/
01622 Err ImageLibIterResize (UInt16 libRef, ImageIteratorHandle iter, UInt16 index,
01623                         Coord *widthP, Coord *heightP,
01624                         Boolean maintainAspectRatio)
01625     SYS_TRAP(kImageLibTrapIterResize );
01626
01627
01628
01629 /****************************************************************/
01630 /* ImageLibResizeJPEG*/
01631
01632 /**
01633  * Resizes a JPEG in memory.
01634  *
01635  * This routine resizes a JPEG in memory to any size. The routine
01636  * follows the same semantics as ImageLibResize, except that it creates a new
01637  * JPEG in memory as a result.
01638  *
01639  * @see ImageLibResize
01640  *
01641  * @param   libRef:                 IN:  Library reference number.
01642  * @param   jpegInputP:             IN:  Pointer to a JPEG image in memory.
01643  * @param   inputSize:              IN:  Size of the source image in bytes.
01644  * @param   widthP:                 IN,OUT: On output, contains the new width of the image. On input, if maintainAspectRatio is true, determines the max width that the image should be. If maintainAspectRatio is false, determines the exact width that the image should be after resizing.
01645  * @param   heightP:                IN,OUT: On output, contains the new width of the image. On input, if maintainAspectRatio is true, determines the max width that the image should be. If maintainAspectRatio is false, determines the exact width that the image should be after resizing.
01646  * @param   maintainAspectRatio:    IN: If true, tells the library to maintain the aspect ratio of the image. In this case, the input values of widthP and heightP serve as maximum guidelines. If false, the image is stretched to fit the input values of widthP and heightP. the dimensions that an image would be if it was forced to draw in a box bounded by widthP and heightP.
01647  * @param   outputPP:               OUT: Pointer to the newly sized JPEG. The caller is responsible for freeing this memory.
01648  * @param   outputSizeP:            OUT: Size in bytes of the newly sized JPEG.
01649  * @retval  Err 0 on success, non-zero on error.
01650  *
01651  ****************************************************************/
01652 Err ImageLibResizeJPEG (UInt16 libRef, MemPtr jpegInputP, UInt32 inputSize,
01653                         Coord *widthP, Coord *heightP,
01654                         Boolean maintainAspectRatio, MemPtr *outputPP,
01655                         UInt32 *outputSizeP)
01656     SYS_TRAP(kImageLibTrapResizeJPEG);
01657
01658
01659
01660 /****************************************************************/
01661 /* ImageLibIterRefresh*/
01662
01663 /**
01664  * Refreshes the information for an image in an iterator chain. If the image is
01665  * stored in the image database, this routine updates the name, recIndex,
01666  * category, size, timestamp, and locked status of the image. If it is a VFS
01667  * picture, this routine updates the timestamp and size of the picture.
01668  *
01669  * Call this function when an iterator refers to an image that has changed
01670  * since the iterator was created. For example, if you downsize or resize an
01671  * iternal image, call ImageLibIterRefresh to update the iterator information
01672  * for that image.
01673  *
01674  * If you rename a VFS picture that is referenced by an iterator chain, you
01675  * can pass its new name for the newVFSName argument. Pass the full path and
01676  * filename of the image. If you pass a string for this argument, the name of
01677  * file in the iterator chain will be updated. Pass NULL for the newVFSName
01678  * parameter if the iterator image refers to an internal picture or a VFS
01679  * picture that whose name has not been changed (If you don't know what this is
01680  * about, pass NULL).
01681  *
01682  * @param   libRef:     IN:  Library reference number.
01683  * @param   iter:       IN:  Handle to an iterator.
01684  * @param   index:      IN:  Index of the image in the iterator. [0,imageCount)
01685  * @param   newVFSName: IN:  If picture is a VFS file, pass its new name for this parameters
01686  * @retval  Err 0 on success, non-zero on error.
01687  *
01688  ****************************************************************/
01689 Err ImageLibIterRefresh(UInt16 libRef, ImageIteratorHandle iter, UInt16 index,
01690                         const char *newVFSName)
01691     SYS_TRAP(kImageLibTrapIterRefresh);
01692
01693 /****************************************************************/
01694 /* ImageLibSetJPEGQuality*/
01695
01696 /**
01697  * Sets the compression factor for all JPEG compression operations performed
01698  * by the imaging library. The compression factor shoule be a value in the range
01699  * of 1-99.
01700  *
01701  * @param   libRef:       IN:  Library reference number.
01702  * @param   value:      IN:  new compression quality.
01703  * @retval  Err 0 on success, non-zero on error.
01704  *
01705  ****************************************************************/
01706 Err ImageLibSetJPEGQuality(UInt16 libRef, Int32 value)
01707     SYS_TRAP(kImageLibTrapSetJPEGQuality);
01708
01709 /****************************************************************/
01710 /* ImageLibGetJPEGQuality*/
01711
01712 /**
01713  * Returns the compression factor used for JPEG compression operations.
01714  *
01715  * @param   libRef:       IN:  Library reference number.
01716  * @retval  Int32 Compression value. [1,99]
01717  *
01718  ****************************************************************/
01719 Int32 ImageLibGetJPEGQuality(UInt16 libRef)
01720     SYS_TRAP(kImageLibTrapGetJPEGQuality);
01721
01722
01723
01724 /****************************************************************/
01725 /* ImageLibLockImage*/
01726
01727 /**
01728  * Returns the compression factor used for JPEG compression operations.
01729  *
01730  * Once an image is locked, it is locked forever and can't be unlocked.
01731  *
01732  * @param   libRef:              IN:   Library reference number.
01733  * @param   recIndex:            IN:   Index of the image to compress.
01734  * @retval  Err 0 on success, non-zero on error.
01735  *
01736  ****************************************************************/
01737 Err ImageLibLockImage(UInt16 libRef, UInt16 recIndex)
01738     SYS_TRAP(kImageLibTrapLockImage);
01739
01740
01741 /****************************************************************/
01742 /* ImageLibGetAveragePictureSize*/
01743
01744 /**
01745  * Returns the average size that a picture will be at the current compression factor.
01746  *
01747  * @param   libRef:        IN:   Library reference number.
01748  * @param   fullsize:      IN:   True to return average of last 20 fullsize captures. False to return average of palm size captures.
01749  * @retval  Int32 0 Average size.
01750  *
01751  ****************************************************************/
01752 Int32 ImageLibGetAveragePictureSize(UInt16 libRef, Boolean fullsize)
01753     SYS_TRAP(kImageLibTrapGetAveragePictureSize);
01754
01755
01756 /****************************************************************/
01757 /* ImageLibCheckLockedImages*/
01758
01759 /**
01760  * Verifies the locked images match the given phone number. If they don't, all locked images
01761  * are purged from the database.
01762  *
01763  * @param libRef:       IN: Library reference number.
01764  * @param phoneNumber:  IN: String containing the phone number to verify against.
01765  ****************************************************************/
01766 void ImageLibCheckLockedImages(UInt16 libRef, const Char *phoneNumber)
01767     SYS_TRAP(kImageLibTrapCheckLockedImages);
01768
01769
01770 #ifdef __cplusplus
01771 }
01772 #endif
01773
01774
01775 #endif
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:54 2008 for Palm API Guide


Header Files » Incs » common » libraries » imaging

ImageLibCommon.h

Go to the documentation of this file.
00001 /*******************************************************************************
00002  * Copyright (c) 2004-2005 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  ******************************************************************************/
00005 /**
00006  * @defgroup    Imaging Imaging Library
00007  * @brief       This library provides support for image drawing and manipulation on
00008  *              Treo 600 devices.
00009  *
00010  * Applications can use this library to draw JPEG images on the screen or create
00011  * thumbnails and such on the Treo 600 devices. This library also allows some
00012  * interaction with the camera within the 3rd party application itself. For the
00013  * newer devices, developers should try to use palmOne Photo Library before using
00014  * the Image Library.
00015  *
00016  * palmOne Photo Library allows better integration with the built-in Media application
00017  * and storing image on the device. Developers who would like to use this library
00018  * should first check the version of the library and then make the appropriate API
00019  * calls depending on the version.
00020  *
00021  * The database API provides applications with the ability to:
00022  *  - Get the list of albums.
00023  *  - Create, delete and rename albums.
00024  *  - Get the list of photos in each album.
00025  *  - Add photos to albums.
00026  *
00027  * The image manipulation API provides applications with the ability to:
00028  *  - Create and capture images and video clips.
00029  *  - Read and write image data.
00030  *  - Convert images to different formats.
00031  *  - Display images.
00032  *  - Scale, rotate and crop images.
00033  *
00034  * @{
00035  * @}
00036  */
00037 /**
00038  * @ingroup Imaging
00039  */
00040
00041 /**
00042  * @file    ImageLibCommon.h
00043  * @version 1.0
00044  * @brief   Public 68k common header file for the Image Library API on Treo 600 devices.
00045  *
00046  * This file contains common defines and error codes to be used with Imaging Library API.
00047  * <hr>
00048  */
00049
00050 #ifndef IMAGELIB_COMMON_H
00051 #define IMAGELIB_COMMON_H
00052
00053 #include <PalmOS.h>
00054 #include <PalmTypes.h>
00055
00056 #define ImageLibCreatorID 'imgL'            /**< Imaging library creator ID */
00057 #define ImageLibTypeID    'libr'            /**< Standard library type */
00058 #define ImageLibName      "ImageLibrary"    /**< Imaging library database name */
00059
00060 /**
00061  * @name    Preview Image Dimensions
00062  * @brief   Preview height and width in standard pixels. On a double density device,
00063  *          the bitmap returned would be twice these dimensions.
00064  */
00065 /*@{*/
00066 #define kPalmSizeImageWidth     160
00067 #define kPalmSizeImageHeight    120
00068 #define kFullSizeImageWidth     640
00069 #define kFullSizeImageHeight    480
00070 #define kThumbnailImageWidth     40
00071 #define kThumbnailImageHeight    30
00072 #define kPreviewBitmapWidth     (kPalmSizeImageWidth)
00073 #define kPreviewBitmapHeight    (kPalmSizeImageHeight)
00074 /*@}*/
00075
00076 #define kInvalidRecIndex ((UInt16)0xFFFF ) /**< define for invalid record index */
00077
00078 #define kImageFilenameLength    (dmDBNameLength) /**< max filename length */
00079
00080 /**
00081  * @name Sort Orders
00082  */
00083 /*@{*/
00084 #define kNoSortOrder (0)
00085 #define kSortByName  (1)
00086 #define kSortByDate  (2)
00087 #define kSortByNameDesc  (3)
00088 #define kSortByDateDesc  (4)
00089 /*@}*/
00090
00091 /**
00092  * @name Image Operation Codes
00093  */
00094 /*@{*/
00095 #define kResizeOperation (0)
00096 #define kJPEGOperation   (1)
00097 #define kVFSOperation    (2)
00098 /*@}*/
00099
00100 /** Handle returned by ImageLibIterateImages or ImageLibIterateVFSImages. */
00101 typedef void * ImageIteratorHandle;
00102
00103 /** Passed in when calling ImageLibSetProgressCallback */
00104 typedef void (*ImageLibProgressCallbackType) (Int32 progress, Int32 max, Int8 operation);
00105
00106 /**
00107  * @name Error Codes
00108  */
00109 /*@{*/
00110 #define imageLibErrorClass              (appErrorClass | 0x1000)
00111 #define imageLibErrBadParam             (imageLibErrorClass)
00112 #define imageLibErrNoCamera             (imageLibErrorClass + 1)
00113 #define imageLibErrInternalFailure      (imageLibErrorClass + 2)
00114 #define imageLibErrWriteFailure         (imageLibErrorClass + 3)
00115 #define imageLibErrReadFailure          (imageLibErrorClass + 4)
00116 #define imageLibErrBadData              (imageLibErrorClass + 5)
00117 #define imageLibErrBadImageType         (imageLibErrorClass + 6)
00118 #define imageLibErrBadImageDepth        (imageLibErrorClass + 7)
00119 #define imageLibErrBadDimensions        (imageLibErrorClass + 8)
00120 #define imageLibErrInitializationFailed (imageLibErrorClass + 9)
00121 #define imageLibErrBadColorspace        (imageLibErrorClass + 10)
00122 #define imageLibErrBadThumbnailType     (imageLibErrorClass + 11)
00123 #define imageLibErrThumnailExists       (imageLibErrorClass + 12)
00124 #define imageLibErrBadScaleFactor       (imageLibErrorClass + 13)
00125 #define imageLibErrBadBitmapType        (imageLibErrorClass + 14)
00126 #define imageLibErrImageAlreadyDownsized (imageLibErrorClass + 15)
00127 #define imageLibErrImageLocked           (imageLibErrorClass + 16)
00128 /*@}*/
00129
00130 #endif
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:54 2008 for Palm API Guide


Header Files » Incs » common » libraries » imaging

ImageLibTraps.h

Go to the documentation of this file.
00001 /*******************************************************************************
00002  * Copyright (c) 2004-2005 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  ******************************************************************************/
00005 /**
00006  * @ingroup Imaging
00007  */
00008
00009 /**
00010  * file     ImageLibTraps.h
00011  * version  1.0
00012  * brief    Public 68k common header file for Image Library API on Treo 600 devices.
00013  *
00014  * This file contains the function trap numbers for the Imaging Library API.
00015  */
00016
00017 #ifndef IMAGELIBTRAPS_H
00018 #define IMAGELIBTRAPS_H
00019
00020
00021 #include <PalmTypes.h>
00022
00023 /**
00024  * @name Function Traps
00025  */
00026 /*@{*/
00027 #define kImageLibTrapOpen                          (sysLibTrapOpen      )
00028 #define kImageLibTrapClose                         (sysLibTrapClose     )
00029
00030 #define kImageLibTrapGetVersion                    (sysLibTrapCustom    )
00031 #define kImageLibTrapCameraExists                  (sysLibTrapCustom + 1)
00032 #define kImageLibTrapImageCapture                  (sysLibTrapCustom + 2)
00033 #define kImageLibTrapImageSave                     (sysLibTrapCustom + 3)
00034 #define kImageLibTrapPreviewBitmapCreate           (sysLibTrapCustom + 4)
00035 #define kImageLibTrapPreviewBitmapFill             (sysLibTrapCustom + 5)
00036 #define kImageLibTrapPreviewDraw                   (sysLibTrapCustom + 6)
00037 #define kImageLibTrapImageBitmapCreate             (sysLibTrapCustom + 7)
00038 #define kImageLibTrapImageBitmapFill               (sysLibTrapCustom + 8)
00039 #define kImageLibTrapImageDraw                     (sysLibTrapCustom + 9)
00040 #define kImageLibTrapThumbnailBitmapCreate         (sysLibTrapCustom + 10)
00041 #define kImageLibTrapThumbnailBitmapFill           (sysLibTrapCustom + 11)
00042 #define kImageLibTrapThumbnailDraw                 (sysLibTrapCustom + 12)
00043 #define kImageLibTrapBitmapDelete                  (sysLibTrapCustom + 13)
00044 #define kImageLibTrapDeleteImage                   (sysLibTrapCustom + 14)
00045 #define kImageLibTrapResizeImage                   (sysLibTrapCustom + 15)
00046 #define kImageLibTrapGetImageDatabases             (sysLibTrapCustom + 16)
00047 #define kImageLibTrapGetImageInfo                  (sysLibTrapCustom + 17)
00048 #define kImageLibTrapSetImageInfo                  (sysLibTrapCustom + 18)
00049
00050 #define kImageLibTrapCopyImageToVFS                (sysLibTrapCustom + 19)
00051 #define kImageLibTrapCopyImageFromVFS              (sysLibTrapCustom + 20)
00052 #define kImageLibTrapImageBitmapCreateFromVFS      (sysLibTrapCustom + 21)
00053 #define kImageLibTrapImageBitmapFillFromVFS        (sysLibTrapCustom + 22)
00054 #define kImageLibTrapImageDrawFromVFS              (sysLibTrapCustom + 23)
00055 #define kImageLibTrapThumbnailBitmapCreateFromVFS  (sysLibTrapCustom + 24)
00056 #define kImageLibTrapThumbnailBitmapFillFromVFS    (sysLibTrapCustom + 25)
00057 #define kImageLibTrapThumbnailDrawFromVFS          (sysLibTrapCustom + 26)
00058
00059
00060 #define kImageLibTrapDoInfoDialog                  (sysLibTrapCustom + 27)
00061 #define kImageLibTrapDoAttachImageDialog           (sysLibTrapCustom + 28)
00062 #define kImageLibTrapSetNoteFont                   (sysLibTrapCustom + 29)
00063 #define kImageLibTrapGetNoteFont                   (sysLibTrapCustom + 30)
00064 #define kImageLibTrapDoNoteDialog                  (sysLibTrapCustom + 31)
00065
00066 #define kImageLibTrapCopyImageToBuffer             (sysLibTrapCustom + 32)
00067 #define kImageLibTrapCopyImageToFile               (sysLibTrapCustom + 33)
00068 #define kImageLibTrapInsertImageFromBuffer         (sysLibTrapCustom + 34)
00069 #define kImageLibTrapInsertImageFromFile           (sysLibTrapCustom + 35)
00070 #define kImageLibTrapLockImage                     (sysLibTrapCustom + 36)
00071 #define kImageLibTrapIterateImages                 (sysLibTrapCustom + 37)
00072 #define kImageLibTrapIterateVFSImages              (sysLibTrapCustom + 38)
00073 #define kImageLibTrapIterSort                      (sysLibTrapCustom + 39)
00074 #define kImageLibTrapIterGetImageInfo              (sysLibTrapCustom + 40)
00075 #define kImagelibTrapIterGetCount                  (sysLibTrapCustom + 41)
00076 #define kImageLibTrapIterDeleteImage               (sysLibTrapCustom + 42)
00077 #define kImageLibTrapIterRemoveImage               (sysLibTrapCustom + 43)
00078 #define kImageLibTrapIterFree                      (sysLibTrapCustom + 44)
00079 #define kImageLibTrapIterDrawImage                 (sysLibTrapCustom + 45)
00080 #define kImageLibTrapIterDrawThumbnail             (sysLibTrapCustom + 46)
00081 #define kImageLibTrapIterSearch                    (sysLibTrapCustom + 47)
00082 #define kImageLibTrapSetProgressCallback           (sysLibTrapCustom + 48)
00083 #define kImageLibTrapCopyImage                     (sysLibTrapCustom + 49)
00084 #define kImageLibTrapFindImageByID                 (sysLibTrapCustom + 50)
00085 #define kImageLibTrapPreviewStart                  (sysLibTrapCustom + 51)
00086 #define kImageLibTrapPreviewStop                   (sysLibTrapCustom + 52)
00087 #define kImageLibTrapDrawJPEG                      (sysLibTrapCustom + 53)
00088 #define kImageLibTrapTurnCameraOff                 (sysLibTrapCustom + 54)
00089 #define kImageLibTrapSetImageID                    (sysLibTrapCustom + 55)
00090 #define kImageLibTrapGetImageID                    (sysLibTrapCustom + 56)
00091
00092 #define kImageLibTrapGetDimensions                 (sysLibTrapCustom + 57)
00093 #define kImageLibTrapGetDimensionsVFS              (sysLibTrapCustom + 58)
00094 #define kImageLibTrapIterGetDimensions             (sysLibTrapCustom + 59)
00095 #define kImageLibTrapGetDimensionsJPEG             (sysLibTrapCustom + 60)
00096
00097 #define kImageLibTrapResize                        (sysLibTrapCustom + 61)
00098 #define kImageLibTrapResizeVFS                     (sysLibTrapCustom + 62)
00099 #define kImageLibTrapIterResize                    (sysLibTrapCustom + 63)
00100 #define kImageLibTrapResizeJPEG                    (sysLibTrapCustom + 64)
00101
00102 #define kImageLibTrapIterRefresh                   (sysLibTrapCustom + 65)
00103 #define kImageLibTrapSetJPEGQuality                (sysLibTrapCustom + 66)
00104 #define kImageLibTrapGetJPEGQuality                (sysLibTrapCustom + 67)
00105 #define kImageLibTrapGetAveragePictureSize         (sysLibTrapCustom + 68)
00106 #define kImageLibTrapCheckLockedImages             (sysLibTrapCustom + 69)
00107 /*@}*/
00108
00109 #endif
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:54 2008 for Palm API Guide


Header Files » Incs

Incs/palmOne_68K.h

Go to the documentation of this file.
00001 /**
00002  * @file    palmOne_68K.h
00003  * @version 1.0
00004  * @date    03/05/2004
00005  *
00006  *  Main palmOne Palm OS API Header file
00007  *
00008  * This is the main header file for all third party developers. A developer
00009  * would include if they wanted to use any of the palmOne components. This
00010  * includes all the extentions, libraries and any app components. This file is
00011  * for api calls that will work only in 68K code.
00012  * This file automatically includes the Common/palmOneCommon.h file so there is
00013  * no need for a developer to include that file seperately.
00014  * This is the ONLY file that should be needed for any of the palmOne specific
00015  * components. This file includes all the other header files
00016  * for the 68K space relative to this directory. It has to stay at the top of
00017  * the Incs tree.
00018  *
00019  * \license
00020  *
00021  *    Copyright (c) 2004 palmOne Inc., All Rights Reserved
00022  *
00023  *****************************************************************************/
00024
00025 #ifndef __PALMONE_68K_H__
00026 #define __PALMONE_68K_H__
00027
00028
00029 //Including the standard Palm OS headers
00030 #ifndef __PALMTYPES_H__
00031                                     #include <PalmTypes.h>
00032 #endif
00033 #ifndef __PALMCOMPATIBILITY_H__
00034                                     #include <PalmCompatibility.h>
00035 #endif
00036 #ifndef __PALMOS_H__
00037                                     #include <PalmOS.h>
00038 #endif
00039
00040 //Including the old Handspring Common files that are needed by certain apps
00041 #ifndef __PALMONECHARS_H__
00042                                     #include <68K/System/palmOneChars.h>
00043 #endif
00044
00045
00046 //Now let's include the palmOne headers
00047 #ifndef __HS_COMMON_H__
00048                                     #include <Common/HsCommon.h>
00049 #endif
00050 //5-Way Navigation Headers
00051 #ifndef __PALMONENAVIGATOR_H__
00052                                     #include <68K/System/palmOneNavigator.h>
00053 #endif
00054 #ifndef __HWUTILS68K_H__
00055                                     #include <68K/System/HardwareUtils68K.h>
00056 #endif
00057 #ifndef __PALMBGSERVICE_H__
00058                                     #include <68K/System/PalmBGService.h>
00059 #endif
00060 #ifndef __PALMCREATORS_H__
00061                                     #include <Common/System/PalmCreators.h>
00062 #endif
00063 #ifndef __PALMDISPLAYEXTENT_H__
00064                                     #include <68K/System/PalmDisplayExtent.h>
00065 #endif
00066 #ifndef __PALMERRORBASE_H__
00067                                     #include <68K/System/PalmErrorBase.h>
00068 #endif
00069 #ifndef __PALMFEATURES_H__
00070                                     #include <Common/System/PalmFeatures.h>
00071 #endif
00072 #ifndef __PALMGOLCD_H__
00073                                     #include <68K/System/PalmGoLCD.h>
00074 #endif
00075 #ifndef __PalmHiResTime_H__
00076                                     #include <68K/System/PalmHiResTime.h>
00077 #endif
00078 #ifndef __PalmLED_H__
00079                                     #include <68K/System/PalmLED.h>
00080 #endif
00081 #ifndef __PALMLAUNCHCODES_H__
00082                                     #include <68K/System/PalmLaunchCodes.h>
00083 #endif
00084 #ifndef __PalmLcdOverlay_H__
00085                                     #include <68K/System/PalmLcdOverlay.h>
00086 #endif
00087 // we might be able to remove this
00088 //since it seems related to ARM development
00089 #ifndef PALM_NATIVE_H_
00090                                     #include <68K/System/PalmNative.h>
00091 #endif
00092 #ifndef __PINLIB_H__
00093                                     #include <68K/System/PalmPin.h>
00094 #endif
00095 #ifndef __PalmPower_H__
00096                                     #include <68K/System/PalmPower.h>
00097 #endif
00098 #ifndef __PALMRESOURCES_H__
00099                                     #include <68K/System/PalmResources.h>
00100 #endif
00101 #ifndef __PALMONEVMFONTLIBRARY_H__
00102                                     #include <68K/Libraries/VMFont/palmOneVMFontLib.h>
00103 #endif
00104 #ifndef __PALMVMLAUNCH_H__
00105                                     #include <68K/System/PalmVMLaunch.h>
00106 #endif
00107 #ifndef __PALMVMPLUGIN_H__
00108                                     #include <68K/System/PalmVMPlugin.h>
00109 #endif
00110 #ifndef __SLIDER_H__
00111                                     #include <68K/System/Slider.h>
00112 #endif
00113
00114 //Audio
00115 #ifndef __PalmAudioPlayback_H__
00116                                     #include <68K/Libraries/Audio/PalmAudioPlayback.h>
00117 #endif
00118 #ifndef __PALMSOUNDCUSTOMCTRL_H__
00119                                     #include <68K/Libraries/Audio/PalmSoundCustomCtrl.h>
00120 #endif
00121 // Not including PalmSoundMgrExt.h at this time because of overloading of enum
00122 // already exists in the 5.2 OS.
00123
00124 //Camera
00125 #ifndef __palmOneCameraMgr_H__
00126                                     #include <68K/Libraries/CameraMgr/palmOneCamera.h>
00127 #endif
00128 #ifndef __PalmOneCameraSlider_H__
00129                                     #include <68K/Libraries/CameraMgr/palmOneCameraSlider.h>
00130 #endif
00131
00132 //Codec Pluggin Manager
00133 #ifndef _PALMONECODECPLUGINMGR_H_
00134                                     #include <68K/Libraries/CodecPluginMgr/palmOneCodecPluginMgr.h>
00135 #endif
00136 #ifndef _PALMONECODECFORMAT_H_
00137                                     #include <Common/Libraries/CodecPluginMgr/palmOneCodecFormat.h>
00138 #endif
00139
00140 //Network related libraries
00141 #ifndef PALM_NETSERVICES_H__
00142                                     #include <68K/Libraries/Network/PalmNetServices.h>
00143 #endif
00144 #ifndef _PALM_VPPI_H_
00145                                     #include <68K/Libraries/Network/PalmVPPI.h>
00146 #endif
00147 #ifndef _PALM_WPPI_H_
00148                                     #include <68K/Libraries/Network/PalmWPPI.h>
00149 #endif
00150 #ifndef PALM_WIFI_COMMON_H_
00151                                     #include <68K/Libraries/Network/PalmWiFiCommon.h>
00152 #endif
00153
00154 //Imaging Library
00155 #ifndef PALM_PHOTO_H_
00156                                     #include <68K/Libraries/Imaging/PalmPhoto.h>
00157 #endif
00158
00159 //File Browser Library
00160 #ifndef __FILE_BROWSER_LIB_68K_H__
00161                                     #include <68K/Libraries/filebrowser/FileBrowserLib68K.h>
00162 #endif
00163
00164 //SndFileStream Library
00165 #ifndef __SNDFILESTREAM_H__
00166                                     #include <68K/Libraries/SndFileStream/palmOneSndFileStream.h>
00167 #endif
00168
00169
00170 //Transition of Old Handspring headers
00171
00172
00173 #endif /* __PALMONE_68K_H__ */
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:54 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » locs

LocsLib.h

Go to the documentation of this file.
00001 /******************************************************************************
00002  * Copyright (c) 2004-2005 Palm, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  *****************************************************************************/
00005 /**
00006  * @ingroup Locs
00007  */
00008
00009 /**
00010  *
00011  * @file    LocsLib.h
00012  * @brief   Public 68K include file for location/timezone/DST support on Palm devices.
00013  *
00014  */
00015
00016
00017 #ifndef _LOCSLIB_H_
00018 #define _LOCSLIB_H_
00019
00020 // PalmSource includes:
00021 #include <DataMgr.h>
00022 #include <LibTraps.h>
00023 #include <LocaleMgr.h>
00024 #include <PalmTypes.h>
00025 #include <SystemResources.h>
00026 #include <SysUtils.h>
00027 #include <Common/Libraries/locs/LocsLibCommon.h>
00028
00029
00030 /******************************************************************************
00031  *
00032  *  PROTOTYPES
00033  *
00034  *****************************************************************************/
00035 #ifdef __cplusplus
00036 extern "C" {
00037 #endif
00038
00039
00040 // Required entry points:
00041
00042 /// Standard library open routine.
00043 ///
00044 /// @param iLibRefNum:  IN: Library reference number.
00045 /// @return Error code.
00046 extern Err               LocsLibOpen                   (UInt16 iLibRefNum)
00047     SYS_TRAP (sysLibTrapOpen);
00048
00049 /// Standard library close routine.
00050 ///
00051 /// @param iLibRefNum:  IN: Library reference number.
00052 /// @return Error code.
00053 extern Err               LocsLibClose                  (UInt16 iLibRefNum)
00054     SYS_TRAP (sysLibTrapClose);
00055
00056 /// Standard library sleep routine.
00057 ///
00058 /// @param iLibRefNum:  IN: Library reference number.
00059 /// @return Error code.
00060 extern Err               LocsLibSleep                  (UInt16 iLibRefNum)
00061     SYS_TRAP (sysLibTrapSleep);
00062
00063 /// Standard library wake routine.
00064 ///
00065 /// @param iLibRefNum:  IN: Library reference number.
00066 /// @return Error code.
00067 extern Err               LocsLibWake                   (UInt16 iLibRefNum)
00068     SYS_TRAP (sysLibTrapWake);
00069
00070 // LocsLib general public custom functions (library extends to callers):
00071
00072 /// Get the version of the library on the device.
00073 ///
00074 /// @param iLibRefNum:  IN: Library reference number.
00075 /// @param iSDKVersion: IN: Currently used library version in the SDK
00076 /// @param oVersionP:       OUT: Version of the library on the device.
00077 /// @return Error code.
00078 extern Err               LocsLibGetVersion             (UInt16 iLibRefNum, UInt32 iSDKVersion, UInt32* oVersionP)
00079     SYS_TRAP (locsLibTrapGetVersion);
00080
00081 /// Runs the event loop for handling the Locations dialogues.
00082 /// Note: the preSelect, noEditOnSelect, and sendChangeNotify
00083 /// values of the caller data block don't apply for this API.
00084 ///
00085 /// @param iLibRefNum:  IN: Library reference number.
00086 /// @param ioSelLocsP:  I/O: Pointer to a selected locations object
00087 ///                          that contains data on selected locations.
00088 ///                          e.g.: The Clock 2.0 app displays
00089 ///                          several selected locations and the
00090 ///                          associated times.  If any of those
00091 ///                          locations are removed or renamed, the
00092 ///                          Clock 2.0 app needs to know so it can
00093 ///                          update the display.
00094 ///                          This object is updated if any of the
00095 ///                          selected locations are renamed or removed.
00096 ///                          Use the dirty bits to determine quickly
00097 ///                          if any data were changed and if so, which.
00098 ///                          Pass NULL to ignore.
00099 /// @return True if changes are made.
00100 extern Boolean           LocsLibLaunchEditListDialogue (UInt16 iLibRefNum, LocsLibSelLocsType* ioSelLocsP)
00101     SYS_TRAP (locsLibTrapLaunchEditListDlg);
00102
00103 /// Run the location selection dialogue, and then the
00104 /// Edit Location dialogue if the user tapped [OK] in
00105 /// the location selection dialogue and if the caller
00106 /// didn't specify to skip that dialogue.
00107 ///
00108 /// @param iLibRefNum:  IN: Library reference number.
00109 /// @param ioSelLocsP:  I/O: Pointer to a selected locations object
00110 ///                          that contains data on selected locations.
00111 ///                          e.g.: The Clock 2.0 app displays
00112 ///                          several selected locations and the
00113 ///                          associated times.  If any of those
00114 ///                          locations are removed or renamed, the
00115 ///                          Clock 2.0 app needs to know so it can
00116 ///                          update the display.
00117 ///                          This object is updated if any of the
00118 ///                          selected locations are renamed or removed.
00119 ///                          Use the dirty bits to determine quickly
00120 ///                          if any data were changed and if so, which.
00121 ///                          Must not be NULL.
00122 /// @return True if changes are made.
00123 extern Boolean           LocsLibLaunchSelDialogue      (UInt16 iLibRefNum, LocsLibSelLocsType* ioSelLocsP)
00124     SYS_TRAP (locsLibTrapLaunchSelDialogue);
00125
00126 // Location public custom functions:
00127
00128 /// Copy from one location data into another
00129 ///
00130 /// @param iLibRefNum:       IN:  Library reference number
00131 /// @param thisP:                    IN:  Pointer to the location object to copy to
00132 /// @param iLocToCopyP       IN:  Pointer to the location to be copied
00133 extern void              LocationCopy                  (UInt16 iLibRefNum, LocationType* thisP, const LocationType* iLocToCopyP)
00134     SYS_TRAP (locsLibTrapLocCopy);
00135
00136 /// Destructor for location objects
00137 ///
00138 /// @param iLibRefNum:          IN: Library reference number
00139 /// @param thisP:                       IN: Pointer to the location object to destroy
00140 extern void              LocationFinal                 (UInt16 iLibRefNum, LocationType* thisP)
00141     SYS_TRAP (locsLibTrapLocFinal);
00142
00143 /// Calculate the size in bytes of the location object with the name field size
00144 /// included, but without the size of the pointer to the name field.
00145 ///
00146 /// @param iLibRefNum:      IN: Library reference number
00147 /// @param thisP:                   IN: Pointer to the location object to size
00148 /// @return Size in bytes
00149 extern UInt16            LocationGetSize               (UInt16 iLibRefNum, const LocationType* thisP)
00150     SYS_TRAP (locsLibTrapLocGetSize);
00151
00152 /// Constructor for location objects; initialize the given location data
00153 /// structure.
00154 ///
00155 /// @param iLibRefNum:           IN:  Library reference number
00156 /// @param thisP:                        IN:  Pointer to the location object to initialize
00157 extern void              LocationInit                  (UInt16 iLibRefNum, LocationType* thisP)
00158     SYS_TRAP (locsLibTrapLocInit);
00159
00160 /// Determine if a given DST date is in the past relative to the current time
00161 ///
00162 /// @param iLibRefNum:   IN:  Library reference number
00163 /// @param iDstDateP:        IN:  Pointer to a DST date to use for determining if that
00164 ///                                                     date is in the past relative to the current time.
00165 /// @return True if given DST date is in the past.
00166 extern Boolean           LocationIsDSTPast             (UInt16 iLibRefNum, DSTType* iDstDateP)
00167     SYS_TRAP (locsLibTrapLocIsDSTPast);
00168
00169 /// Create a generic location using the given country and UTC values.
00170 ///
00171 /// @param iLibRefNum:              IN:  Library reference number
00172 /// @param thisP:                           IN:  Pointer to the location object to initialize
00173 ///                                                              with generic location data
00174 /// @param iCountryCode:            IN:  Country code for generic location
00175 /// @param iUTC:                            IN:  UTC (timezone is minutes east west of prime
00176 ///                                                              meridian) for generic location; also used to
00177 ///                                                              create the location name.
00178 /// @return errNone if success.
00179 extern Err               LocationMakeGeneric           (UInt16 iLibRefNum, LocationType* thisP, CountryType iCountryCode, Int16 iUTC)
00180     SYS_TRAP (locsLibTrapLocMakeGeneric);
00181
00182 /// Mutator for changing location name value
00183 ///
00184 /// @param iLibRefNum:   IN:  Library reference number
00185 /// @param thisP:                IN:  Pointer to the location object to change
00186 /// @param iNameP:           IN:  Pointer to the new name
00187 extern void              LocationSetName               (UInt16 iLibRefNum, LocationType* thisP, const Char* iNameP)
00188     SYS_TRAP (locsLibTrapLocSetName);
00189
00190 // LocationsDB public custom functions:
00191
00192 /// Modify a record and re-sort the db if needed.
00193 ///
00194 /// @param iLibRefNum:  IN:  Library reference number
00195 /// @param dbP:                 IN:  Pointer to the given location database
00196 ///                                                  to be modified.
00197 /// @param ioRecordIndexP:   I/O: Pointer to the record index of the location
00198 ///                               record to be modified. If the record is
00199 ///                               moved, this value is updated with the
00200 ///                               new index.
00201 /// @param iLocationP:  IN:  Pointer to the new location data that is
00202 ///                          used to update the record.
00203 ///
00204 /// @return errNone if success.
00205 extern Err               LocDBChangeRecord          (UInt16 iLibRefNum, DmOpenRef dbP, UInt16* ioRecordIndexP, const LocationType* iLocationP)
00206     SYS_TRAP (locsLibTrapDBChangeRecord);
00207
00208 /// Comparison function to be used with system sort routines.
00209 ///
00210 /// Note: the system sort functions, like SysQSort, treat the
00211 /// elements of the passed list as is; i.e.: instead of
00212 /// passing the elements to this function, pointers to
00213 /// the elements are passed.  Thus, it is necessary to
00214 /// here to use double pointers and dereferencing to
00215 /// to compare the actual records.
00216 ///
00217 /// @param iLibRefNum:      IN:  Library reference number
00218 /// @param iRecord01P:      IN:  Pointer to the first location record.
00219 /// @param iRecord02P:      IN:  Pointer to the second location record.
00220 /// @param iFlags                   IN:  Sort order.
00221 ///
00222 /// @return -n if 1st is lesser, +n if 2nd is lesser, 0 if the two are the same,
00223 ///         except for DST data, which isn't compared.
00224 extern Int16             LocDBCompareRecordsSimple  (UInt16 iLibRefNum, LocDBRecordType** iRecord01P, LocDBRecordType** iRecord02P, Int32 iFlags)
00225     SYS_TRAP (locsLibTrapDBCmpRecordsSimple);
00226
00227 /// This function will format and copy locked record (LocationType) data into another
00228 /// locationType
00229 ///
00230 /// @param iLibRefNum:          IN:  library reference number
00231 /// @param ioLocationP:         I/O: Pointer to the location object that is
00232 ///                              filled with the converted record data.
00233 /// @param iRecordP:                IN:  Pointer to the record whose data is
00234 ///                              converted to the location object format.
00235 extern void              LocDBConvertRecord         (UInt16 iLibRefNum, LocationType* ioLocationP, const LocDBRecordType* iRecordP)
00236     SYS_TRAP (locsLibTrapDBConvertRecord);
00237
00238 /// Copy the data in a given location object into a given
00239 /// location db record format. Note: the caller must allocate enough memory to the
00240 /// record object to hold the location data!
00241 ///
00242 /// @param iLibRefNum:      IN:  Library reference number
00243 /// @param ioRecordP:           I/O: Pointer to a record that is filled with
00244 ///                            the location object data.
00245 /// @param iLocationP:      IN:  Pointer to the location object whose data
00246 ///                            is copied to the record.
00247 extern void              LocDBCopyLocation          (UInt16 iLibRefNum, LocDBRecordType* ioRecordP, const LocationType* iLocationP)
00248     SYS_TRAP (locsLibTrapDBCopyLocation);
00249
00250 /// Deletes a record from the cities database.
00251 ///
00252 /// @param iLibRefNum:      IN:  Library reference number
00253 /// @param dbP:                     IN:  Pointer to the database containing the record to delete.
00254 /// @param iRecordIndex:    IN: Index of the record to delete.
00255 ///
00256 /// @return errNone if success.
00257 extern Err               LocDBDeleteRecord          (UInt16 iLibRefNum, DmOpenRef dbP, UInt16 iRecordIndex)
00258     SYS_TRAP (locsLibTrapDBDeleteRecord);
00259
00260 /// Finds a record having the custom bit set.
00261 ///
00262 /// @param iLibRefNum:      IN:  Library reference number
00263 /// @param iDbP:                    IN:  Pointer to a locations record database.
00264 /// @param ioRecordIndex:   I/O: Index of the record to begin searching from,
00265 ///                            and index of the found record.
00266 /// @param oRecordH:            OUT: Pointer to the record handle; set by this
00267 ///                            function.
00268 ///
00269 /// @return Pointer to the record found or NULL. Caller is responsible
00270 ///         for freeing record when done.
00271 extern LocDBRecordType*  LocDBFindCustomRecord      (UInt16 iLibRefNum, DmOpenRef iDbP, UInt16* ioRecordIndex, MemHandle* oRecordH)
00272     SYS_TRAP (locsLibTrapDBFindCustomRecord);
00273
00274 /// Returns the record index for the first record matching
00275 /// the given location data.
00276 ///
00277 /// @param iLibRefNum:      IN:  Library reference number
00278 /// @param dbP:                     IN:  Pointer to the given cities database
00279 ///                            to search for a match.
00280 /// @param oRecordIndexP:   OUT: Pointer to record index var to store the
00281 ///                            record index of the matching record found
00282 ///                            in the search. Set to dmMaxRecordIndex if
00283 ///                            no match is found.
00284 /// @param iMatchLocationP: IN: Pointer to the location data for which
00285 ///                             to find the first matching record in
00286 ///                             the given database.
00287 ///
00288 /// @return Error code for a failure, or errNone if success.  If no match
00289 ///         is found, the index value is set to the value dmMaxRecordIndex.
00290 extern Err               LocDBFindFirst             (UInt16 iLibRefNum, DmOpenRef dbP, UInt16* oRecordIndexP, LocDBRecordType* iMatchValueP)
00291     SYS_TRAP (locsLibTrapDBFindFirst);
00292
00293 /// Sequential search of the locations database records for a
00294 /// match to the given city name.
00295 ///
00296 /// @param iLibRefNum:           IN:  Library reference number
00297 /// @param dbP:                          IN:  Pointer to the record db to search.
00298 /// @param oRecordIndexP:        OUT: Pointer to an index var to set with the
00299 ///                               index of the matching record, or dmMaxRecordIndex
00300 ///                               if no match.
00301 /// @param iNameP:                   IN:  Pointer to the name string for which to find a match.
00302 ///
00303 /// @return errNone if no problems.  No match indicated by oRecordIndexP set to dmMaxRecordIndex.
00304 extern Err               LocDBFindFirstByName       (UInt16 iLibRefNum, DmOpenRef dbP, UInt16* oRecordIndexP, const Char* iNameP)
00305     SYS_TRAP (locsLibTrapDBFindFirstByName);
00306
00307 /// Sequential search of the locations database records for
00308 /// the first location matching the given country and UTC values.
00309 ///
00310 /// @param iLibRefNum:           IN:  Library reference number
00311 /// @param dbP:                          IN:  Pointer to the record db to search.
00312 /// @param oRecordIndexP:        OUT: Pointer to an index var to set with the
00313 ///                               index of the matching record, or dmMaxRecordIndex
00314 ///                               if no match.
00315 /// @param iCountry:                 IN:  The country code for which to find a match.
00316 /// @param iUTC:                         IN:  The UTC for which to find a match.
00317 ///
00318 /// @return errNone if no problems.  No match indicated by oRecordIndexP set to dmMaxRecordIndex.
00319 extern Err               LocDBFindFirstByUTCCountry (UInt16 iLibRefNum, DmOpenRef dbP, UInt16* oRecordIndexP, CountryType iCountry, Int16 iUTC)
00320     SYS_TRAP (locsLibTrapDBFindFirstByUTCCtry);
00321
00322 /// Returns the record index for the first record in the given
00323 /// list matching the given location data.
00324 ///
00325 /// Note: This complements the get list functions, which return
00326 /// a list of pointers to location records in a db.
00327 ///
00328 /// @param iLibRefNum:                       IN:  Library reference number
00329 /// @param iLocsListItemsCount:      IN:  Number of record items in the list.
00330 /// @param iLocsListP:                       IN:  Pointer to the list of location records.
00331 /// @param iMatchLocationP:              IN:  Pointer to the location data for which
00332 ///                                           to find the first matching record in
00333 ///                                     the given list.
00334 ///
00335 /// @return The index of the list item matching the given location, or
00336 ///         if no match found, then dmMaxRecordIndex.
00337 extern UInt16            LocDBFindFirstInList       (UInt16 iLibRefNum, UInt16 iLocsListItemsCount, LocDBRecordType** iLocsListP, const LocationType* iMatchLocationP)
00338     SYS_TRAP (locsLibTrapDBFindFirstInList);
00339
00340 /// Returns a handle to a list of pointers to location records
00341 /// having the custom bit set. It is the responsibility of the caller to free the
00342 /// memory for the returned list.
00343 ///
00344 /// @param iLibRefNum:  IN:  Library reference number
00345 /// @param iDbP:                IN:  Pointer to a locations record database.
00346 /// @param oListCount:  OUT: Number of records found with custom bit set.
00347 ///
00348 /// @return Handle to the list of location record pointers or NULL.
00349 ///         Note: Caller is repsonsible for freeing memory associated
00350 ///         with the list of pointers to records.
00351 extern MemHandle         LocDBGetCustomList         (UInt16 iLibRefNum, DmOpenRef iDbP, UInt16* oListCount)
00352     SYS_TRAP (locsLibTrapDBGetCustomList);
00353
00354 /// Get an array of pointers to those records from the the given database.
00355 ///
00356 /// @param iLibRefNum:  IN:  Library reference number
00357 /// @param iDbP:                IN:  Pointer to an open locations database.
00358 /// @param oListCount:  OUT: Pointer to the list count to be set with
00359 ///                          the number of items in the locations list.
00360 /// @param iCompareF:       IN:  Function pointer for the function to use
00361 ///                          when sorting the list. Pass NULL if the
00362 ///                          list should not be sorted.
00363 /// @param iCompareFlags:   IN:  Any flags for comparison/sort behavior.
00364 ///
00365 /// @return Pointer to the array of location data, or NULL.
00366 ///         Note: Caller is responsible for freeing this memory.
00367 extern LocDBRecordType** LocDBGetRecordList         (UInt16 iLibRefNum, DmOpenRef iDbP, UInt16* oListCount, CmpFuncPtr iCompareF, Int32 iCompareFlags)
00368     SYS_TRAP (locsLibTrapDBGetRecordList);
00369
00370 /// Returns a pointer to a locked record chunk in the given db.
00371 /// It is the responsibility of the caller to unlock and release the record
00372 /// when done using the record. It is must to call LocDBCovertRecordV20 to get
00373 /// formated data in another LocationType variable.
00374 ///
00375 /// @param iLibRefNum:          IN:  library reference number
00376 /// @param dbP:                         IN:  Pointer to a database having the desired record.
00377 /// @param iRecordIndex:        IN:  Index of the record in the given db.
00378 /// @param oRecordHP:               OUT: Pointer to the record handle; set by this function.
00379 ///
00380 /// @return Pointer to the locked record or NULL; if non-NULL, caller
00381 ///         is responsible for unlocking and releasing the record.
00382 extern LocDBRecordType*  LocDBGetRecord             (UInt16 iLibRefNum, DmOpenRef dbP, UInt16 iRecordIndex, MemHandle* oRecordHP)
00383     SYS_TRAP (locsLibTrapDBGetRecord);
00384
00385 /// Open the default db and open and initialize the custom db.
00386 ///
00387 /// @param iLibRefNum:          IN:  library reference number
00388 /// @param oDefDbPP:                OUT: Pointer to the default db pointer to initialize.
00389 /// @param oCusDbPP:                OUT: Pointer to the custom db pointer to initialize.
00390 ///
00391 /// @return On success the default and custom db pointers are initialized.
00392 extern Err               LocDBInitDBs               (UInt16 iLibRefNum, DmOpenRef* oDefDbPP, DmOpenRef* oCusDbPP)
00393     SYS_TRAP (locsLibTrapDBInitDBs);
00394
00395 /// Generates a new record for the given database.
00396 ///
00397 /// @param iLibRefNum:          IN:  library reference number
00398 /// @param dbP:                         IN:  Pointer to the given location database
00399 ///                              into which the location data is to be
00400 ///                              inserted as a new record.
00401 /// @param oRecordIndexP:       OUT: Pointer to the given record index value
00402 ///                              to be initialized with the new location
00403 ///                              record's index.
00404 /// @param iLocationP:          IN:  Pointer to the given location data from
00405 ///                              which to generate the new location record.
00406 ///
00407 /// @return errNone if success.
00408 extern Err               LocDBNewRecord             (UInt16 iLibRefNum, DmOpenRef dbP, UInt16* oRecordIndexP, const LocationType* iLocationP)
00409     SYS_TRAP (locsLibTrapDBNewRecord);
00410
00411 /// Open the custom db and return the dbID and an initialized db pointer.
00412 ///
00413 /// @param iLibRefNum:          IN:  library reference number
00414 /// @param iDbInfoP:                IN:  Pointer to a database info struct having db
00415 ///                              name, crid, type, and card number.
00416 /// @param iOpenMode:               IN:  Read and write mode to open the database for.
00417 /// @param oDbPP:                       OUT: Pointer to a db reference that is set by this
00418 ///                              function.
00419 /// @param iDefDbP:                 IN:  Pointer to the default db from which to init
00420 ///                              the custom db if necessary.  Initialization
00421 ///                              occurs if the custom db must be created, and
00422 ///                              then any records marked as custom in the given
00423 ///                              default db are copied into the custom db.
00424 ///
00425 /// @return Zero (0) on failure the dbP is set to NULL; the database ID
00426 ///         is returned on success and the dbP is set to the address
00427 ///         of the database.
00428 extern LocalID           LocDBOpenCustom            (UInt16 iLibRefNum, const LocDBInfoType* iDbInfoP, UInt16 iOpenMode, DmOpenRef* oDbPP, const DmOpenRef iDefDbP)
00429     SYS_TRAP (locsLibTrapDBOpenCustom);
00430
00431 /// Open the default db and return the dbID and an initialized db pointer.
00432 ///
00433 /// @param iLibRefNum:          IN:  library reference number
00434 /// @param oDbPP:                       OUT: Pointer to a db reference that is set by this
00435 ///                              function.
00436 ///
00437 /// @return Error code (errNone if successful).  Zero (0) on failure
00438 ///         and the dbP is set to NULL; occurs if the default db isn't
00439 ///         found and the install from ROM fails.  The database ID is
00440 ///         returned on success and the dbP is set to the address
00441 ///         of the database.
00442 extern LocalID           LocDBOpenDefault           (UInt16 iLibRefNum, DmOpenRef* oDbPP)
00443     SYS_TRAP (locsLibTrapDBOpenDefault);
00444
00445 /// Determines the size in bytes of a record.
00446 ///
00447 /// @param iLibRefNum:          IN:  library reference number
00448 /// @param iLocRecordP:         IN:  Pointer to the record for which to
00449 ///                              determine the size.
00450 ///
00451 /// @return Size of the given record in bytes.
00452 extern UInt16            LocDBRecordSize            (UInt16 iLibRefNum, const LocDBRecordType* iLocRecordP)
00453     SYS_TRAP (locsLibTrapDBRecordSize);
00454
00455 /// Set the custom field of the record.
00456 ///
00457 /// @param iLibRefNum:          IN:  library reference number
00458 /// @param ioLocRecordP:        I/O: Pointer to the record for which to set the
00459 ///                              custom field.
00460 /// @param iValue:                  IN:  Value to which the custom field is set.
00461 ///
00462 /// @return errNone if success.
00463 extern Err               LocDBSetRecordCustom       (UInt16 iLibRefNum, LocDBRecordType* ioLocRecordP, UInt8 iValue)
00464     SYS_TRAP (locsLibTrapDBSetRecordCustom);
00465
00466 /// Sorts the given location data database.
00467 ///
00468 /// @param iLibRefNum:          IN:  library reference number
00469 /// @param iDbP:                        IN:  Pointer to the location db to sort.
00470 /// @param iSortOrder:          IN:  Sort order desired.
00471 ///
00472 /// @return errNone if success.
00473 extern Err               LocDBSort                  (UInt16 iLibRefNum, DmOpenRef iDbP, LocDBSortOrderType iSortOrder)
00474     SYS_TRAP (locsLibTrapDBSort);
00475
00476 // LocsLibDSTAlarm public functions:
00477
00478 /// Clear an existing DST alert alarm from the system.
00479 ///
00480 /// @param iLibRefNum:          IN:  library reference number
00481 extern void              LocsLibDSTAlarmClear       (UInt16 iLibRefNum)
00482     SYS_TRAP (locsLibTrapDSTAlarmClear);
00483
00484 /// Check if the current time is within a daylight saving time range.
00485 ///
00486 /// @param iLibRefNum:          IN:  library reference number
00487 /// @param iDSTStartP:          IN:  Pointer to the start DST date.
00488 /// @param iDSTEndP:                IN:  Pointer to the end DST date.
00489 /// @param iTimeInSecs:         IN:  The time in seconds against which to check
00490 ///                                                          the given DST date range.
00491 ///
00492 /// @return True if in the DST range.
00493 extern Boolean           LocsLibDSTAlarmIsDST       (UInt16 iLibRefNum, const DSTType* iDSTStartP, const DSTType* iDSTEndP, UInt32 iTimeInSecs)
00494     SYS_TRAP (locsLibTrapDSTAlarmIsDST);
00495
00496 /// Set the DST alert alarm to the given DST date.
00497 ///
00498 /// @param iLibRefNum:          IN:  library reference number
00499 /// @param iDstP:                       IN:  Pointer to the DST date data.
00500 ///
00501 /// @return Time in seconds for which the DST alert was set, or
00502 ///         0 if not set (e.g.: if the given DST date data indicates DST is not observed).
00503 extern UInt32            LocsLibDSTAlarmSet         (UInt16 iLibRefNum, const DSTType* iDstStartP, const DSTType* iDstEndP)
00504     SYS_TRAP (locsLibTrapDSTAlarmSet);
00505
00506 /// Generates a new record for the given database.
00507 ///
00508 /// @param iLibRefNum:          IN:  library reference number
00509 /// @param dbP:                         IN:  Pointer to the given location database
00510 ///                              into which the location data is to be
00511 ///                              inserted as a new record.
00512 /// @param oRecordIndexP:       OUT: Pointer to the given record index value
00513 ///                              to be initialized with the new location
00514 ///                              record's index.
00515 /// @param iLocationP:          IN:  Pointer to the given location data from
00516 ///                              which to generate the new location record.
00517 ///
00518 /// @return errNone if success.
00519 extern Err                LocDBNewRecordV20         (UInt16 iLibRefNum, DmOpenRef dbP, UInt16* oRecordIndexP, LocationType* iLocationP)
00520     SYS_TRAP (locsLibTrapLocDBNewRecordV20);
00521
00522 /// Returns a pointer to a locked record chunk in the given db.
00523 /// It is the responsibility of the caller to unlock and release the record
00524 /// when done using the record. It is must to call LocDBCovertRecordV20 to get
00525 /// formated data in another LocationType variable.
00526 ///
00527 /// @param iLibRefNum:          IN:  library reference number
00528 /// @param dbP:                         IN:  Pointer to a database having the desired record.
00529 /// @param iRecordIndex:        IN:  Index of the record in the given db.
00530 /// @param oRecordHP:               OUT: Pointer to the record handle; set by this function.
00531 ///
00532 /// @return Pointer to the locked record or NULL; if non-NULL, caller
00533 ///         is responsible for unlocking and releasing the record.
00534 extern LocationType*  LocDBGetRecordV20             (UInt16 iLibRefNum, DmOpenRef dbP, UInt16 iRecordIndex, MemHandle* oRecordHP)
00535     SYS_TRAP (locsLibTrapLocDBGetRecordV20);
00536
00537 /// This function will format and copy locked record (LocationType) data into another
00538 /// locationType
00539 ///
00540 /// @param iLibRefNum:          IN:  library reference number
00541 /// @param destRecordP:         IN:  Pointer to the location object that is
00542 ///                              filled with the converted record data.
00543 /// @param srcRecordP:          IN:  Pointer to the record whose data is
00544 ///                              converted to the location object format.
00545 extern void              LocDBConvertRecordV20      (UInt16 iLibRefNum, LocationType* destRecordP, const LocationType* srcRecordP)
00546     SYS_TRAP (locsLibTrapLocDBConvertRecordV20);
00547
00548 /// Modify a record and re-sort the db if needed.
00549 ///
00550 /// @param iLibRefNum:  IN:  Library reference number
00551 /// @param dbP:                 IN:  Pointer to the given location database
00552 ///                                                  to be modified.
00553 /// @param ioRecordIndexP:   I/O: Pointer to the record index of the location
00554 ///                               record to be modified. If the record is
00555 ///                               moved, this value is updated with the
00556 ///                               new index.
00557 /// @param iLocationP:  IN:  Pointer to the new location data that is
00558 ///                          used to update the record.
00559 ///
00560 /// @return errNone if success.
00561 extern Err               LocDBChangeRecordV20       (UInt16 iLibRefNum, DmOpenRef dbP, UInt16* ioRecordIndexP, LocationType* iLocationP)
00562     SYS_TRAP (locsLibTrapLocDBChangeRecordV20);
00563
00564 /// Get an array of pointers to those records from the the given database.
00565 ///
00566 /// @param iLibRefNum:  IN:  Library reference number
00567 /// @param iDbP:                IN:  Pointer to an open locations database.
00568 /// @param oListCount:  OUT: Pointer to the list count to be set with
00569 ///                          the number of items in the locations list.
00570 /// @param iCompareF:       IN:  Function pointer for the function to use
00571 ///                          when sorting the list. Pass NULL if the
00572 ///                          list should not be sorted.
00573 /// @param iCompareFlags:   IN:  Any flags for comparison/sort behavior.
00574 ///
00575 /// @return Pointer to the array of location data, or NULL.
00576 ///         Note: Caller is responsible for freeing this memory.
00577 extern LocationType** LocDBGetRecordListV20         (UInt16 iLibRefNum, DmOpenRef iDbP, UInt16* oListCount, CmpFuncPtr iCompareF, Int32 iCompareFlags)
00578     SYS_TRAP (locsLibTrapLocDBGetRecordListV20);
00579
00580 /// Get a valid location from the locations DB nearest to the
00581 /// location specified
00582 ///
00583 /// @param iLibRefNum:   IN:  Library reference number
00584 /// @param iDefDb:           IN:  Reference to default location database
00585 /// @param iCustDb:          IN:  Reference to custom location database
00586 /// @param iPosP:                IN:  Pointer to reference position
00587 /// @param oLocP:                OUT: Pointer to location, nearest city will
00588 ///                                                     return in this pointer
00589 /// @return Error if database not found.
00590 extern Err          LocDBGetNearestLocation         (UInt16 iLibRefNum,DmOpenRef iDb1P,DmOpenRef iDb2P,PosType* iPosP,LocationType* oLocP)
00591     SYS_TRAP (locsLibTrapLocDBGetNearestLocation);
00592
00593 /// Constructor for location objects v 2.0 (support for note); initialize the
00594 /// given location data structure.
00595 ///
00596 /// @param iLibRefNum:           IN:  Library reference number
00597 /// @param thisP:                        IN:  Pointer to the location object to initialize
00598 extern void              LocationInitV20            (UInt16 iLibRefNum, LocationType* thisP)
00599     SYS_TRAP (locsLibTrapLocationInitV20);
00600
00601 /// Destructor for location objects v 2.0 (support for note)
00602 ///
00603 /// @param iLibRefNum:          IN: Library reference number
00604 /// @param thisP:                       IN: Pointer to the location object to destroy
00605 extern void              LocationFinalV20           (UInt16 iLibRefNum, LocationType* thisP)
00606     SYS_TRAP (locsLibTrapLocationFinalV20);
00607
00608 /// Get version of database
00609 ///
00610 /// @param iLibRefNum:   IN:  Library reference number
00611 /// @param cardNo:           IN:  cardNo for database
00612 /// @param dbNameP:          IN:  Pointer to database name to search
00613 /// @param versionP:         OUT: Pointer to version, version no will return
00614 ///                                               in this variable
00615 ///
00616 /// @return Error if database not found.
00617 extern Err               LocDBGetVersion            (UInt16 iLibRefNum, UInt16 cardNo, const Char *dbNameP, UInt16 *version)
00618     SYS_TRAP (locsLibTrapLocDBGetVersion);
00619
00620 /// Copy note to location note field
00621 ///
00622 /// @param iLibRefNum:   IN:  Library reference number
00623 /// @param thisP:                IN:  Pointer to the location object to change.
00624 /// @param iNoteP:           IN:  Pointer to the new note.
00625 extern void              LocationSetNote            (UInt16 iLibRefNum, LocationType* thisP, const Char* iNameP)
00626     SYS_TRAP (locsLibTrapLocationSetNote);
00627
00628 /// Initialize position values of location
00629 ///
00630 /// @param iLibRefNum:   IN:  Library reference number
00631 /// @param thisP:                IN:  Pointer to the city object to initialize.
00632 /// @param iPosP:                IN:  Pointer to PosType to set values of location
00633 extern void              LocationSetPosition        (UInt16 iLibRefNum, LocationType* thisP, const PosType* iPosP)
00634     SYS_TRAP (locsLibTrapLocationSetPosition);
00635
00636
00637 extern Boolean               LocsLibLocationNote        (UInt16 iLibRefNum, const Char* iNameP, Boolean noteStatus)
00638     SYS_TRAP (locsLibTrapLocsLibLocationNote);
00639
00640 /// Calculate the size in bytes of the location object with the name and note field size
00641 /// included, but without the size of the pointer to the name and note field.
00642 ///
00643 /// @param iLibRefNum:      IN: Library reference number
00644 /// @param locationP:                   IN: Pointer to the location object to size
00645 /// @return Size in bytes
00646 extern UInt16           LocationGetSizeV20          (UInt16  iLibRefNum,  LocationType* locationP)
00647     SYS_TRAP (locsLibTrapLocationGetSizeV20);
00648
00649 // Location public custom functions:
00650
00651 /// Copy from one location data into another
00652 ///
00653 /// @param iLibRefNum:       IN:  Library reference number
00654 /// @param thisP:                    IN:  Pointer to the location object to copy to
00655 /// @param iLocToCopyP       IN:  Pointer to the location to be copied
00656 extern void              LocationCopyV20            (UInt16 iLibRefNum, LocationType* thisP, const LocationType* iLocToCopyP)
00657     SYS_TRAP (locsLibTrapLocationCopyV20);
00658
00659 /// Finds a record having the custom bit set.
00660 ///
00661 /// @param iLibRefNum:      IN:  Library reference number
00662 /// @param iDbP:                    IN:  Pointer to a locations record database.
00663 /// @param ioRecordIndex:   I/O: Index of the record to begin searching from,
00664 ///                            and index of the found record.
00665 /// @param oRecordH:            OUT: Pointer to the record handle; set by this
00666 ///                            function.
00667 ///
00668 /// @return Pointer to the record found or NULL. Caller is responsible
00669 ///         for freeing record when done.
00670 extern LocationType*  LocDBFindCustomRecordV20          (UInt16 iLibRefNum, DmOpenRef iDbP, UInt16* ioRecordIndex, MemHandle* oRecordH)
00671     SYS_TRAP (locsLibTrapLocDBFindCustomRecordV20);
00672
00673
00674 #ifdef __cplusplus
00675 }
00676 #endif
00677
00678
00679
00680 #endif
00681
00682
00683 /******************************************************************************
00684  *
00685  * END LocsLib.h
00686  *
00687  *****************************************************************************/
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:54 2008 for Palm API Guide


Header Files » Incs » common » libraries » locs

LocsLibCommon.h

Go to the documentation of this file.
00001 /*******************************************************************************
00002  * Copyright (c) 2004-2005 Palm, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  ******************************************************************************/
00005 /**
00006  * @defgroup    Locs Locations Library
00007  * @brief       This library provides location/timezone/DST support for applications.
00008  *
00009  * Developers who want to provide location/timezone/DST or country information
00010  * to their application on Palm devices should use Locations Library API.
00011  *
00012  * @{
00013  * @}
00014  */
00015 /**
00016  * @ingroup Locs
00017  */
00018
00019 /**
00020  * @file    LocsLibCommon.h
00021  * @brief   Public 68K common header file for locations library.
00022  *
00023  * This file contains the library constants and error codes used in the APIs.
00024  * <hr>
00025  */
00026
00027 #ifndef LOCS_LIB_COMMON_H
00028 #define LOCS_LIB_COMMON_H
00029
00030 #include <DataMgr.h>
00031 #include <LocaleMgr.h>
00032 #include <PalmTypes.h>
00033 #include <SystemResources.h>
00034 #include <SysUtils.h>
00035
00036
00037 /******************************************************************************
00038  *
00039  *  LIBRARY VERSION
00040  *
00041  * The library version scheme follows the system versioning scheme.
00042  * See sysMakeROMVersion and friends in SystemMgr.h.
00043  *
00044  * For reference:
00045  *
00046  * 0xMMmfsbbb, where
00047  *      MM is major version,
00048  *      m is minor version,
00049  *      f is bug fix,
00050  *      s is stage: 3-release, 2-beta, 1-alpha, 0-development,
00051  *      bbb is build number for non-releases.
00052  *  e.g.:
00053  *      V1.12b3   would be: 0x01122003
00054  *      V2.00a2   would be: 0x02001002
00055  *      V1.01     would be: 0x01013000
00056  *
00057  *  Stages are:
00058  *      sysROMStageDevelopment
00059  *      sysROMStageAlpha
00060  *      sysROMStageBeta
00061  *      sysROMStageRelease
00062  *
00063  *  Note: This scheme was taken from the SampleLib.c of the Palm OS Dev KB
00064  *        download.
00065  *
00066  *****************************************************************************/
00067 /**
00068  *@name Library Versions
00069  */
00070 /*@{*/
00071 #define kLocsLibVersion01               sysMakeROMVersion (1, 0, 0, sysROMStageDevelopment, 1)
00072 #define kLocsLibVersion0121             sysMakeROMVersion (1, 2, 1, sysROMStageDevelopment, 1)
00073 #define kLocsLibVersion013              sysMakeROMVersion (1, 3, 0, sysROMStageDevelopment, 1)
00074 #define kLocsLibVersionCurrent          kLocsLibVersion013
00075 /*@}*/
00076
00077 /******************************************************************************
00078  *
00079  *  LocsLib ERROR CODES
00080  *
00081  *****************************************************************************/
00082 /**
00083  *@name Error Codes
00084  */
00085 /*@{*/
00086 #define locLErrorClass                  (appErrorClass | 0x0100)
00087 #define locLErrNone                     0
00088 #define locLErrCantFindLocsDB           (locLErrorClass | 1)
00089 #define locLErrBadParam                 (locLErrorClass | 2)
00090 #define locLErrBadRefNum                (locLErrorClass | 3)
00091 #define locLErrNoGlobals                (locLErrorClass | 4)
00092 #define locLErrNoMemForGlobals          (locLErrorClass | 5)
00093 #define locLErrNoLibSysReference        (locLErrorClass | 6)
00094 #define locLErrCantOpenLibRsc           (locLErrorClass | 7)
00095 #define locLErrMemAllocFail             (locLErrorClass | 8)
00096 #define locLErrBadVersion               (locLErrorClass | 9)
00097 #define locLErrNotOpen                  (locLErrorClass | 10)
00098 #define locLErrStillOpen                (locLErrorClass | 11)
00099 /*@}*/
00100
00101 /******************************************************************************
00102  *
00103  *  LocsLib General CONSTANTS
00104  *
00105  *****************************************************************************/
00106
00107 // Use this for SysLibFind calls:
00108 /** Library name */
00109 #define kLocsLibName                    "LocsLib-locL"
00110
00111 // The locations library creator ID:
00112 //  Note: this is registered with Palm, Inc.
00113 /** Library creator ID */
00114 #define kLocsFileCLocsLib               (UInt32)('locL')
00115
00116 /** The feature number used to refer to the stored library reference number */
00117 #define kLocsLibFtrNumRefNum            (UInt16)(1)
00118
00119 // The notification types for location change events:
00120 //  Note: used the creator id for the base event, as this seems to be what the
00121 //        other notifcation event types are based on and it seems the best way
00122 //        to assure no confusion.  Apps checking the types based on the first
00123 //        type should also verify the broadcaster is the Locs lib.
00124 /**
00125  *@name Notifications
00126  */
00127 /*@{*/
00128 #define kLocsLibNotifyLocChangeEvent    kLocsFileCLocsLib
00129 #define kLocsLibNotifyLocEditEvent      kLocsLibNotifyLocChangeEvent + 1
00130 #define kLocsLibNotifyLocDeleteEvent    kLocsLibNotifyLocChangeEvent + 2
00131 #define kLocsLibNotifyLocAddEvent       kLocsLibNotifyLocChangeEvent + 3
00132 /*@}*/
00133
00134 // Masks for determing which bits in the selection dirty bits are set:
00135 /**
00136  *@name Bit Masks
00137  */
00138 /*@{*/
00139 #define kLocsLibSel01                   0x00000001
00140 #define kLocsLibSel02                   0x00000002
00141 #define kLocsLibSel03                   0x00000004
00142 #define kLocsLibSel04                   0x00000008
00143 #define kLocsLibSel05                   0x00000010
00144 #define kLocsLibSel06                   0x00000020
00145 #define kLocsLibSel07                   0x00000040
00146 #define kLocsLibSel08                   0x00000080
00147 #define kLocsLibSel09                   0x00000100
00148 #define kLocsLibSelMax                  0x80000000
00149 /*@}*/
00150
00151 /******************************************************************************
00152  *
00153  * Location CONSTANTS
00154  *
00155  ***********************************************************************/
00156
00157 // Max location name length:
00158 #define kLocNameMaxLength           (UInt16)(100)
00159
00160 //Max location note length
00161 #define kLocNoteMaxLength           (UInt16)(4096)
00162
00163 // Location custom member values:
00164 #define kLocNoDisplayInCustom       (UInt8)(0) /**< don't display location in custom database */
00165 #define kLocDisplayInCustom         (UInt8)(1) /**< display location in custom database */
00166
00167 //Undefined position
00168 #define kUndefinedPosition          (Int16)999 /**< flag: position of location in database in undefined */
00169
00170
00171 /******************************************************************************
00172  *
00173  * LocsLibEditList CONSTANTS
00174  *
00175  ***********************************************************************/
00176 #define kLocsLibListUpdateClass      0x0400
00177 #define kLocsLibListUpdate           (UInt16)(kLocsLibListUpdateClass | 1)
00178
00179
00180 /******************************************************************************
00181  *
00182  * LocationsDB CONSTANTS
00183  *
00184  ***********************************************************************/
00185
00186 #define kLocDBVersion               (UInt16)(2)                 /**< Current version of the location DB format */
00187 #define kLocDBMaxLocNameLength      kLocNameMaxLength   /**< Max # of bytes for a location name stored. */
00188
00189 /**
00190  *@name Database Names and Types
00191  */
00192 /*@{*/
00193 #define kLocFileCDatabase           (UInt32)('locL')
00194 #define kLocFileTDefLocDB           (UInt32)('DATA')
00195 #define kLocFileTCusLocDB           (UInt32)('DATC')
00196 #define kLocFileNDefaultDB          "locLDefLocationDB"
00197 #define kLocFileNCustomDB           "locLCusLocationDB"
00198 /*@}*/
00199
00200 // Location record reserve member values:
00201 #define kLocDBTypeDefault           (UInt8)(0) /**< the location database is the default one */
00202 #define kLocDBTypeCustom            (UInt8)(1) /**< the location database is custom */
00203
00204 /** Location database sort constants */
00205 enum _LocDBSortOrderType {
00206     kSortByNameCountryTZ,
00207     kSortByCountryTZName,
00208     kSortByCountryCodeTZName
00209 };
00210
00211 typedef UInt8 LocDBSortOrderType;
00212
00213 /******************************************************************************
00214  *
00215  * LocsLibDSTAlarm CONSTANTS
00216  *
00217  ***********************************************************************/
00218 /**
00219  *@name DST Alarm Constants
00220  */
00221 /*@{*/
00222 #define kLocsLibDSTAlert            (UInt32)(1)
00223 #define kLocsLibDSTStartAlert       (UInt32)(2)
00224 #define kLocsLibDSTEndAlert         (UInt32)(3)
00225 /*@}*/
00226
00227
00228 /******************************************************************************
00229  *
00230  * Location OBJECT TYPES
00231  *  Important!!  Any changes made to the following location data types require
00232  *                a recompile of the DDEditor and a rebuild of the default db
00233  *                to match the new format.
00234  *
00235  ***********************************************************************/
00236
00237 /**< Daylight saving time (DST) data format */
00238 typedef struct DSTDataTag DSTType;
00239 struct DSTDataTag
00240 {
00241     UInt8 hour;         /**< 1 - 24, usually 1 for 1 a.m. */
00242     UInt8 dayOrd;       /**< 0 = Sun, 1 = Mon, 2 = Tues, 3 = Weds, 4 = Thurs, 5 = Fri, 6 = Sat. */
00243     UInt8 weekOrd;      /**< 0 = 1st, 1 = 2nd, 2 = 3rd, 3 = 4th, 4 = Last */
00244     UInt8 month;        /**< 1 - 12 = Jan - Dec
00245                            No year member, as the DST date should be consistent
00246                             from year to year in regards to this "1st Sunday in
00247                             October" format used here. DST boundary alerts are
00248                             always set for the current year, or to the following
00249                             year as needed. */
00250 };
00251
00252 // Note: It's possible that DST adjustments may change in the future,
00253 //        and at that time, a UI can be provided to set the proper adjustment,
00254 //        or an updated default db can be distributed and installed.
00255
00256 /** Container to store degree and minute of a coordinate */
00257 typedef struct{
00258                 Int16   degree;
00259                 Int16   minute;
00260                }Coordinate;
00261
00262 /** Container to store longitude and latitude of a specific location */
00263 typedef struct{
00264                 Coordinate  latitude;
00265                 Coordinate  longitude;
00266                }PosType;
00267
00268 typedef struct LocationDataTag LocationType;
00269 /** Location data format */
00270 struct LocationDataTag
00271 {
00272     Int16       uTC;                                                /**< timezone */
00273     DSTType     dSTStart;                                       /**< date/time when DST begins, e.g. 31 Oct 2am */
00274     DSTType     dSTEnd;                                         /**< date/time when DST end */
00275     Int16       dSTAdjustmentInMinutes;         /**< 0 = DST not observed, 60 = observed. */
00276     CountryType country;                                        /**< see Palm OS documentation for values */
00277     UInt8       custom   : 1,                               /**< not used */
00278                 reserved : 7;                               /**< not used */
00279     Char*       name;                                               /**< for db record type use name[] */
00280     PosType     position;                                           /**< Position (Longitude & Latitude) values */
00281     Char*       note;                                       /**< Note for each City */
00282 };
00283
00284
00285 /******************************************************************************
00286  *
00287  * LocationsDB OBJECT TYPES
00288  *
00289  ***********************************************************************/
00290
00291 typedef struct LocDBInfoTag LocDBInfoType;
00292 /** Helpful struct for passing db info as an argument */
00293 struct LocDBInfoTag
00294 {
00295     Char*  dbName;                       /**< name of location database */
00296     UInt32 dbCreatorID;              /**< creator of the database */
00297     UInt32 dbType;                       /**< database type */
00298     UInt16 dbCardNum;                    /**< cardNo where database resides */
00299 };
00300
00301
00302 typedef struct LocDBRecordTag LocDBRecordType;
00303 /** Location database record format */
00304 struct LocDBRecordTag
00305 {
00306     Int16       uTC;                                                        /**< timezone */
00307     DSTType     dSTStart;                                               /**< time when DST begins e.g. 2am */
00308     DSTType     dSTEnd;                                                 /**< time when DST end */
00309     Int16       dSTAdjustmentInMinutes;                 /**< 0 = DST not observed, 60 = observed. */
00310     CountryType country;                                                /**< Country. See Palm OS documentation for values */
00311     UInt8       custom   : 1,                                       /**< not used */
00312                 reserved : 7;                                       /**< not used */
00313     Char        name[0];                                    /**< LocationType uses Char* name */
00314 };
00315
00316
00317 /******************************************************************************
00318  *
00319  *  LocsLibUtils OBJECT TYPES
00320  *
00321  *****************************************************************************/
00322
00323 typedef struct LocsLibNotifyLocsDataTag LocsLibNotifyLocsDataType;
00324 /** Struct used to pass notification location data to interested apps */
00325 struct LocsLibNotifyLocsDataTag
00326 {
00327     LocationType locationDataNew;            /**< new location data */
00328     const Char*  locationNameOldP;       /**< name of old location */
00329 };
00330
00331
00332 typedef struct LocsLibNotifyDataTag LocsLibNotifyDataType;
00333 /** Helpful struct for passing notification info as an arg */
00334 struct LocsLibNotifyDataTag
00335 {
00336     Boolean                   showWaitDialogue;    /**< If true, a "Please Wait" dialogue will be displayed while waiting for broadcast completion */
00337     UInt32                    notifyType;          /**< One of the Locs lib notification type constants. */
00338     LocsLibNotifyLocsDataType locationData;        /**< The location data to broadcast. */
00339 };
00340
00341
00342 /******************************************************************************
00343  *
00344  *  LocsLib OBJECT TYPES
00345  *
00346  *****************************************************************************/
00347
00348 typedef struct LocsLibSelLocsTag LocsLibSelLocsType;
00349 /** Container for the selected location in the location database */
00350 struct LocsLibSelLocsTag
00351 {
00352     LocationType* locationP;          /**< Location data of the location selected from the Add Sel list. Caller must allocate the memory. */
00353     UInt32        dirtySelections;    /**< indicates which selections were modified
00354                                           e.g.: the 1st selection, element 0, would be
00355                                                 indicated by dirtySelections & kLocsLibSel01 */
00356     Boolean       needSelLoc;         /**< true if the caller wants a location name being chosen from the Add Sel list to be saved in the selLocsList. */
00357     Boolean       warnIfLocExists;    /**< false if the caller doesn't want the user warned if selecting a location that already exists in the custom db. */
00358     Boolean       noEditOnSelect;     /**< true if the caller wants the "Edit Location" dialogue to NOT be displayed after user selects a location; only applies to LocsLibLaunchSelDialogue(). */
00359     Boolean       preSelect;          /**< true if the caller wants the current location to be preselected in the Add Sel list; only applies to ADD/SEL location dialogue (shows master default list of locations).*/
00360     Boolean       sendChangeNotify;   /**< true if the caller wants the selected location data to be broadcast to all registered apps; only applies to LocsLibLaunchSelDialogue().*/
00361     Boolean       noAddToCustomDB;    /**< true if the caller doesn't want the selected location to be added to the custom db.*/
00362     UInt8         numSelLocs;         /**< Number of items in the selLocsList*/
00363     UInt8         reserved;                     /**< Reserved, not used */
00364     Char**        selLocsListP;       /**< List of locations names that are "selected" and the caller needs to know if they are changed.*/
00365 };
00366
00367
00368
00369 /******************************************************************************
00370  *
00371  * Location MACROS
00372  *
00373  ***********************************************************************/
00374
00375 /**
00376  *@name Accessor Macros
00377  */
00378 /*@{*/
00379 #define LocationGetUTC(locationP)          (locationP)->uTC
00380 #define LocationGetDSTStart(locationP)     &((locationP)->dSTStart)
00381 #define LocationGetDSTEnd(locationP)       &((locationP)->dSTEnd)
00382 #define LocationGetDSTAdj(locationP)       (locationP)->dSTAdjustmentInMinutes
00383 #define LocationGetCountry(locationP)      (locationP)->country
00384 #define LocationGetCustom(locationP)       (locationP)->custom
00385 #define LocationGetReserved(locationP)     (locationP)->reserved
00386 #define LocationGetName(locationP)         (locationP)->name
00387 /*@}*/
00388
00389 /**
00390  *@name Mutator Macros
00391  */
00392 /*@}*/
00393 #define LocationSetUTC(locationP, newUTC) \
00394                    ((locationP)->uTC = newUTC)
00395 #define LocationSetDSTStart(locationP, newDstStart) \
00396                    ((locationP)->dSTStart = newDstStart)
00397 #define LocationSetDSTEnd(locationP, newDstEnd) \
00398                    ((locationP)->dSTEnd = newDstEnd)
00399 #define LocationSetDSTAdj(locationP, newDstAdj) \
00400                    ((locationP)->dSTAdjustmentInMinutes = newDstAdj)
00401 #define LocationSetCountry(locationP, newCountry) \
00402                    ((locationP)->country = newCountry)
00403 #define LocationSetCustom(locationP, newCustom) \
00404                    ((locationP)->custom = newCustom)
00405 #define LocationSetReserved(locationP, newReserved) \
00406                    ((locationP)->reserved = newReserved)
00407 /*@}*/
00408 // Note: SetName is implemented as a function.
00409
00410 // Predicate macros:
00411 #define LocationAreDSTDatesEqual(iDST01P, iDST02P) \
00412                    (   (iDST01P)->hour    == (iDST02P)->hour    \
00413                     && (iDST01P)->dayOrd  == (iDST02P)->dayOrd  \
00414                     && (iDST01P)->weekOrd == (iDST02P)->weekOrd \
00415                     && (iDST01P)->month   == (iDST02P)->month)
00416
00417 /******************************************************************************
00418  *
00419  * LocationsDB MACROS
00420  *
00421  ***********************************************************************/
00422 /**
00423  *@name Helper Macros
00424  */
00425 /*@{*/
00426 #define LocDBCompareUTC(iUTC01, iUTC02) \
00427                 (iUTC01 - iUTC02)
00428 #define LocDBCompareCountries(iCountry01, iCountry02) \
00429                 (iCountry01 - iCountry02)
00430 #define LocDBCompareNames(iName01, iName02) \
00431                 (StrCompare (iName01, iName02))
00432
00433 #define LocDBGetUTC(locRecP)          (locRecP)->uTC
00434 #define LocDBGetCountry(locRecP)      (locRecP)->country
00435 /*@}*/
00436
00437 /******************************************************************************
00438  *
00439  *  LOCATIONS LIBRARY TRAP NUMBERS
00440  *
00441  *****************************************************************************/
00442
00443 // These are LocsLib's trap identifiers:
00444 //  Note: The PalmOS constant 'sysLibTrapCustom' is the first trap number
00445 //        that can be used after open, close, sleep, and wake:
00446
00447 /**
00448  *@name Function Traps
00449  */
00450 /*@{*/
00451 #define    locsLibTrapGetVersion                (sysLibTrapCustom + 0)
00452 #define    locsLibTrapLaunchEditListDlg         (sysLibTrapCustom + 1)
00453 #define    locsLibTrapLaunchSelDialogue         (sysLibTrapCustom + 2)
00454 #define    locsLibTrapLocCopy                   (sysLibTrapCustom + 3)
00455 #define    locsLibTrapLocFinal                  (sysLibTrapCustom + 4)
00456 #define    locsLibTrapLocGetSize                (sysLibTrapCustom + 5)
00457 #define    locsLibTrapLocInit                   (sysLibTrapCustom + 6)
00458 #define    locsLibTrapLocIsDSTPast              (sysLibTrapCustom + 7)
00459 #define    locsLibTrapLocMakeGeneric            (sysLibTrapCustom + 8)
00460 #define    locsLibTrapLocSetName                (sysLibTrapCustom + 9)
00461 #define    locsLibTrapDBChangeRecord            (sysLibTrapCustom + 10)
00462 #define    locsLibTrapDBCmpRecordsSimple        (sysLibTrapCustom + 11)
00463 #define    locsLibTrapDBConvertRecord           (sysLibTrapCustom + 12)
00464 #define    locsLibTrapDBCopyLocation            (sysLibTrapCustom + 13)
00465 #define    locsLibTrapDBDeleteRecord            (sysLibTrapCustom + 14)
00466 #define    locsLibTrapDBFindCustomRecord        (sysLibTrapCustom + 15)
00467 #define    locsLibTrapDBFindFirst               (sysLibTrapCustom + 16)
00468 #define    locsLibTrapDBFindFirstByName         (sysLibTrapCustom + 17)
00469 #define    locsLibTrapDBFindFirstByUTCCtry      (sysLibTrapCustom + 18)
00470 #define    locsLibTrapDBFindFirstInList         (sysLibTrapCustom + 19)
00471 #define    locsLibTrapDBGetCustomList           (sysLibTrapCustom + 20)
00472 #define    locsLibTrapDBGetRecordList           (sysLibTrapCustom + 21)
00473 #define    locsLibTrapDBGetRecord               (sysLibTrapCustom + 22)
00474 #define    locsLibTrapDBInitDBs                 (sysLibTrapCustom + 23)
00475 #define    locsLibTrapDBNewRecord               (sysLibTrapCustom + 24)
00476 #define    locsLibTrapDBOpenCustom              (sysLibTrapCustom + 25)
00477 #define    locsLibTrapDBOpenDefault             (sysLibTrapCustom + 26)
00478 #define    locsLibTrapDBRecordSize              (sysLibTrapCustom + 27)
00479 #define    locsLibTrapDBSetRecordCustom         (sysLibTrapCustom + 28)
00480 #define    locsLibTrapDBSort                    (sysLibTrapCustom + 29)
00481 #define    locsLibTrapDSTAlarmClear             (sysLibTrapCustom + 30)
00482 #define    locsLibTrapDSTAlarmIsDST             (sysLibTrapCustom + 31)
00483 #define    locsLibTrapDSTAlarmSet               (sysLibTrapCustom + 32)
00484 #define    locsLibTrapLocDBNewRecordV20         (sysLibTrapCustom + 33)
00485 #define    locsLibTrapLocDBGetRecordV20         (sysLibTrapCustom + 34)
00486 #define    locsLibTrapLocDBConvertRecordV20     (sysLibTrapCustom + 35)
00487 #define    locsLibTrapLocDBChangeRecordV20      (sysLibTrapCustom + 36)
00488 #define    locsLibTrapLocDBGetRecordListV20     (sysLibTrapCustom + 37)
00489 #define    locsLibTrapLocDBGetNearestLocation   (sysLibTrapCustom + 38)
00490 #define    locsLibTrapLocationInitV20           (sysLibTrapCustom + 39)
00491 #define    locsLibTrapLocationFinalV20          (sysLibTrapCustom + 40)
00492 #define    locsLibTrapLocDBGetVersion           (sysLibTrapCustom + 41)
00493 #define    locsLibTrapLocationSetNote           (sysLibTrapCustom + 42)
00494 #define    locsLibTrapLocationSetPosition       (sysLibTrapCustom + 43)
00495 #define    locsLibTrapLocsLibLocationNote       (sysLibTrapCustom + 44)
00496 #define    locsLibTrapLocationGetSizeV20        (sysLibTrapCustom + 45)
00497 #define    locsLibTrapLocationCopyV20           (sysLibTrapCustom + 46)
00498 #define    locsLibTrapLocDBFindCustomRecordV20  (sysLibTrapCustom + 47)
00499 /*@}*/
00500
00501 #endif
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:54 2008 for Palm API Guide


MainPage.h.txt File Reference

Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:07:37 2008 for Palm API Guide


Header Files » Incs » common » libraries » mms

MmsHelperCommon.h

Go to the documentation of this file.
00001 /*******************************************************************************
00002  * Copyright (c) 2004-2005 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  ******************************************************************************/
00005 /**
00006  * @ingroup Helper
00007  */
00008
00009 /**
00010  * @file    MmsHelperCommon.h
00011  * @version 1.0
00012  * @brief   Public 68k common header files to be used with Default Helper Library.
00013  *
00014  * This file contains the type and structure parameters for the MMS Helper Service Class.
00015  * Developers should register to this service using Default Helper library if it wants
00016  * to handle MMS.
00017  *
00018  * <hr>
00019  */
00020
00021 #ifndef HELPER_MMS_H
00022 #define HELPER_MMS_H
00023
00024 /** New helper class registered with PalmSource for sending by MMS */
00025 #define    kHelperServiceClassIDMMS    'mms_'
00026
00027 /** Structure to hold the MMS object. This structure is part of the linked list
00028   * which is pointed by the object member of HelperServiceMMSDetailsType */
00029 typedef struct _HelperServiceMMSObjectType
00030 {
00031     Int16   pageNum;            /**< IN: page of message this content should appear on. */
00032     Char*   mimeType;           /**< IN: IANA Mime type for this object (compulsory!)
00033                                      The object may be passed in a buffer or via a file.
00034                                      Either set bufferP and bufferLen or set tempFileName
00035                                   */
00036
00037     MemPtr  bufferP;            /**< IN: The object is stored in a buffer if this is non-NULL */
00038     UInt32  bufferLen;          /**< IN: Length of the buffer */
00039
00040     Char*   tempFileName;       /**< IN: The temporary file its stored in if bufferP is NULL */
00041     Boolean isVFSFileName;      /**< IN: Is the file local or under VFS e.g Memory card? */
00042     Boolean freeTempFile;       /**< IN: If set, the file should be deleted by the helper application */
00043
00044     Char*   name;               /**< IN: the name of the object as sent to us (maybe the filename) */
00045
00046     struct  _HelperServiceMMSObjectType* nextP; /**< IN: Linked list pointer of objects to send. */
00047
00048 } HelperServiceMMSObjectType;
00049
00050 /**
00051  * @brief Helpers of this Service Class send an MMS message.
00052  *
00053  * "To" address(es) are passed in the 'pData' element of the main structure
00054  * (HelperNotifyExecuteType)
00055  *
00056  * The 'pDetails' struct member may optionally point to
00057  * HelperServiceMMSDetailsType for this service class.
00058  */
00059 typedef struct _HelperServiceMMSDetailsType
00060 {
00061     UInt16  version;                    /**< This is currently version 1 */
00062
00063     Char*   cc;                         /**< IN: carbon copy address string or NULL -- will
00064                                              be duplicated by helper if necessary;
00065                                              multiple addresses are separated by
00066                                              semicolon (ex. "john@host.com; jane@host.com") */
00067
00068     Char*   subject;                    /**< IN: subject string or NULL -- will be duplicated
00069                                              by helper if necessary (ex. "helper API") */
00070
00071     Char*   message;                    /**< IN: initial message body string or NULL -- will be
00072                                              duplicated by helper if necessary (ex.
00073                                              "Lets discuss the helper API tomorrow.")
00074                                              Message will be put on first page. */
00075
00076     HelperServiceMMSObjectType* object; /**< IN: Head of Linked list of objects to send or NULL */
00077
00078     Char*   bcc;                        /**< IN: blind carbon copy address string or NULL -- will
00079                                              be duplicated by helper if necessary;
00080                                              multiple addresses are separated by
00081                                              semicolon (ex. "john@host.com; jane@host.com") */
00082
00083     Boolean justSend;                   /**< IN: Set this to true to send without invoking any UI */
00084
00085 } HelperServiceMMSDetailsType;
00086
00087
00088 #endif //HELPER_MMS_H
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:54 2008 for Palm API Guide


Header Files » Incs » common » libraries » netmaster

NetMasterLibErrors.h

Go to the documentation of this file.
00001 /******************************************************************************
00002  * Copyright (c) 2004 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  *****************************************************************************/
00005 /**
00006  * @ingroup NETMASTER
00007  */
00008
00009 /**
00010  * @file    NetMasterLibErrors.h
00011  * @version 1.0
00012  * @date 01/31/2002
00013  *
00014  * @brief This  is the error declarations file for the NetMaster Library.
00015  *
00016  */
00017
00018 #ifndef _NET_MASTER_LIB_ERRORS_H_
00019 #define _NET_MASTER_LIB_ERRORS_H_
00020
00021 #include <HsErrorClasses.h>
00022
00023 // WARNING:
00024 //    DO NOT MOVE OR REASSIGN ERROR CODE VALUES TO EXISTING CONSTANTS BECAUSE
00025 //    THEY ARE HARD-CODED IN OTHER MODULES, SUCH AS NETLIB PATCHES, SYSTEM
00026 //    PATCHES, AND ERROR STRING LISTS IN THE SYSTEM RESOURCE DATABASE.
00027
00028 /** @name Net Master Error Codes
00029  */
00030 /**@{*/
00031 #define netMasterErrClass           (hsNetMasterErrorClass)     /**< hsNetMasterErrorClass is defined in HsErrorClasses.h as 0x7100 */
00032 #define netMasterErrMemory          (netMasterErrClass + 0x01)  /**< runtime memory error */
00033 #define netMasterErrStorage         (netMasterErrClass + 0x02)  /**< storage memory error */
00034 #define netMasterErrBadArg          (netMasterErrClass + 0x03)  /**< invalid argument, unknown ID */
00035 #define netMasterErrNetNotInstalled (netMasterErrClass + 0x04)  /**< NetLib has not been installed */
00036 #define netMasterErrDispatchTable   (netMasterErrClass + 0x05)  /**< Unrecognized dipatch table format */
00037 #define netMasterErrNoNetPrefLib    (netMasterErrClass + 0x06)  /**< NetPref library not found */
00038 #define netMasterErrConfigNotFound  (netMasterErrClass + 0x07)  /**< NetPref config not found */
00039 #define netMasterErrConfigFailed    (netMasterErrClass + 0x08)  /**< Attempt to configure network settings failed  */
00040 #define netMasterErrNo1xService     (netMasterErrClass + 0x09)  /**< 1xRTT is not available  */
00041 #define netMasterErrMIPFailed       (netMasterErrClass + 0x0A)  /**< Generic Mobile-IP failure  */
00042 #define netMasterErrBadPort         (netMasterErrClass + 0x0B)  /**< Invalid port number -- we remap this from serErrBadPort. */
00043 /**@}*/
00044
00045 /** @name MIP Error Codes
00046  *  Sprint's Mobile-IP (MIP) error codes.
00047  */
00048 /**@{*/
00049 #define netMasterErrMIPNoSimBindings            (netMasterErrClass + 0x0C)  //
00050 #define netMasterErrMIPReasonUnspecified64      (netMasterErrClass + 0x0D)  //
00051 #define netMasterErrMIPAdminProhibited65        (netMasterErrClass + 0x0E)  //
00052 #define netMasterErrMIPInsufficientResources66  (netMasterErrClass + 0x0F)  //
00053 #define netMasterErrMIPMobileNodeAuth67         (netMasterErrClass + 0x10)  //
00054 #define netMasterErrMIPHomeAgentAuth68          (netMasterErrClass + 0x11)  //
00055 #define netMasterErrMIPReqLifetimeTooLong69     (netMasterErrClass + 0x12)  //
00056 #define netMasterErrMIPPoorlyFormedReq70        (netMasterErrClass + 0x13)  //
00057 #define netMasterErrMIPPoorlyFormedReply71      (netMasterErrClass + 0x14)  //
00058 #define netMasterErrMIPReqedEncapUnavail72      (netMasterErrClass + 0x15)  //
00059 #define netMasterErrMIPReservedNUnavail73       (netMasterErrClass + 0x16)  //
00060 #define netMasterErrMIPCantRevTun74             (netMasterErrClass + 0x17)  //
00061 #define netMasterErrMIPMustRevTun75             (netMasterErrClass + 0x18)  //
00062 #define netMasterErrMIPBadTtl76                 (netMasterErrClass + 0x19)  //
00063 #define netMasterErrMIPInvalidCareOfAddr77      (netMasterErrClass + 0x1A)  //
00064 #define netMasterErrMIPRegistration_Timeout78   (netMasterErrClass + 0x1B)  //
00065 #define netMasterErrMIPDelivStyleNotSupported79 (netMasterErrClass + 0x1C)  //
00066 #define netMasterErrMIPHome_Network_Unreachable80 (netMasterErrClass + 0x1D)    //
00067 #define netMasterErrMIPHa_Host_Unreachable81    (netMasterErrClass + 0x1E)  //
00068 #define netMasterErrMIPHa_Port_Unreachable82    (netMasterErrClass + 0x1F)  //
00069 #define netMasterErrMIPHa_Unreachable88         (netMasterErrClass + 0x20)  //
00070 #define netMasterErrMIPNonZeroHaRequested96     (netMasterErrClass + 0x21)  //
00071 #define netMasterErrMIPMissingNai97             (netMasterErrClass + 0x22)  //
00072 #define netMasterErrMIPForeign_Agent98          (netMasterErrClass + 0x23)  //
00073 #define netMasterErrMIPMissingHa99              (netMasterErrClass + 0x24)  //
00074 #define netMasterErrMIPErrorFa1_100             (netMasterErrClass + 0x25)  //
00075 #define netMasterErrMIPErrorFa2_101             (netMasterErrClass + 0x26)  //
00076 #define netMasterErrMIPUnknown_Challenge104     (netMasterErrClass + 0x27)  //
00077 #define netMasterErrMIPMissing_Challenge105     (netMasterErrClass + 0x28)  //
00078 #define netMasterErrMIPStale_Challenge106       (netMasterErrClass + 0x29)  //
00079 #define netMasterErrMIPReasonUnspecified128     (netMasterErrClass + 0x2A)  //
00080 #define netMasterErrMIPAdminProhibited129       (netMasterErrClass + 0x2B)  //
00081 #define netMasterErrMIPInsufficientResources130 (netMasterErrClass + 0x2C)  //
00082 #define netMasterErrMIPMobileNodeAuth131        (netMasterErrClass + 0x2D)  //
00083 #define netMasterErrMIPForeignAgentAuth132      (netMasterErrClass + 0x2E)  //
00084 #define netMasterErrMIPRegIdMismatch133         (netMasterErrClass + 0x2F)  //
00085 #define netMasterErrMIPPoorlyFormedReq134       (netMasterErrClass + 0x30)  //
00086 #define netMasterErrMIPTooManySimMobBindings135 (netMasterErrClass + 0x31)  //
00087 #define netMasterErrMIPUnknownHaAddr136         (netMasterErrClass + 0x32)  //
00088 #define netMasterErrMIPCantRevTun137            (netMasterErrClass + 0x33)  //
00089 #define netMasterErrMIPMustRevTun138            (netMasterErrClass + 0x34)  //
00090 #define netMasterErrMIPReqEncapNotAvail139      (netMasterErrClass + 0x35)  //
00091 #define netMasterErrMIPErrorHa1_140             (netMasterErrClass + 0x36)  //
00092 #define netMasterErrMIPErrorHa2_141             (netMasterErrClass + 0x37)  //
00093
00094 /**
00095  * 801 Username suspension due to repeated incorrect passwords being sent
00096  */
00097 #define netMasterErrMIPUsernameSuspension801    (netMasterErrClass + 0x38)
00098 #define netMasterErrMIPReserved2                (netMasterErrClass + 0x39)  /**< Reserved for future use */
00099 #define netMasterErrMIPReserved3                (netMasterErrClass + 0x3A)  /**< Reserved for future use */
00100 #define netMasterErrMIPReserved4                (netMasterErrClass + 0x3B)  /**< Reserved for future use */
00101 /**@}*/
00102
00103 /** @name Net Master Error Codes
00104  */
00105 /**@{*/
00106
00107 #define netMasterErrAutoLoginNotPossible        (netMasterErrClass + 0x3C)  /**< auto-login did not take place */
00108 #define netMasterErrCDMACarrierNetworkBusy      (netMasterErrClass + 0x3D)  /**< "network busy" event was received from the carrier's network. */
00109 #define netMasterErrOneXServiceUnavailable      (netMasterErrClass + 0x3E)  /**<< requested service unavailable */
00110
00111 /** Authentication UI prompt (such as username/password or script plug-in)
00112  *  was requested during background login -- this is not supported
00113  *  presently.
00114  */
00115 #define netMasterErrAuthReqDuringBGLogin        (netMasterErrClass + 0x3F)
00116
00117 /** UI RPC timed out during a background-initiated login. This is an internal
00118  * error that might occur if the current UI app is not processing events
00119  * for a long time.
00120  */
00121 #define netMasterErrUIRPCTimeout                (netMasterErrClass + 0x40)
00122
00123 /** @internal
00124  * INTERNAL ERROR (not returned outside of NetMaster lib). This may
00125  * be returned internally by various network setting configuration
00126  * routines to indicate that the level of service necessary to establish
00127  * the requested connection is not available (such as when a GPRS connection
00128  * is requested, but GPRS service is not available). When this error is
00129  * returned to the login logic, the login logic may still choose to attempt
00130  * the connection for the sole purpose of getting a more detailed error
00131  * code (which may not have been available during configuration) to display
00132  * to the user, or, if fallback is available, it may skip directly to the
00133  * fallback service.  When returning this error code, the configuration
00134  * routines still perform the full requested configuration.
00135  */
00136 #define netMasterErrInternalConnWouldBeImpossible (netMasterErrClass + 0x41)
00137
00138
00139 /** Net Guard prompt would have been required during background login. Prompting
00140  * is presently not supported during background login.
00141  */
00142 #define netMasterErrNetGuardReqDuringBGLogin    (netMasterErrClass + 0x42)
00143
00144
00145 /** Generic GPRS login error -- returned when we don't have enough specific
00146  * info about the cause of login failure.
00147  */
00148 #define netMasterErrGPRSGenLoginErr             (netMasterErrClass + 0x43)
00149
00150
00151 /** Sprint OneX service is unavailable while roaming
00152  */
00153 #define netMasterErrNoOneXServiceWhileRoaming   (netMasterErrClass + 0x44)
00154
00155 /**@}*/
00156
00157
00158 // NOTE:
00159 // Assign error codes out of this unassigned error code block next.  These
00160 // error codes were inserted because someone mistakenly defined
00161 // netMasterErrOneXServiceNotEnabled as 0x4F instead of 0x3F in the
00162 // Visor3.5CDMA Maint branch, and we need to maintain that value for backward
00163 // compatibility. We need to account for all intervening error codes because
00164 // SysErrString and related functionality doesn't allow gaps in error strings.
00165
00166 /** @name Reserved for future use
00167  */
00168 /**@{*/
00169 #define netMasterErrUnused45                    (netMasterErrClass + 0x45)  // assign this one next
00170 #define netMasterErrUnused46                    (netMasterErrClass + 0x46)  // assign this one next
00171 #define netMasterErrUnused47                    (netMasterErrClass + 0x47)  // assign this one next
00172 #define netMasterErrUnused48                    (netMasterErrClass + 0x48)  // assign this one next
00173 #define netMasterErrUnused49                    (netMasterErrClass + 0x49)  // assign this one next
00174 #define netMasterErrUnused4A                    (netMasterErrClass + 0x4A)  // assign this one next
00175 #define netMasterErrUnused4B                    (netMasterErrClass + 0x4B)  // assign this one next
00176 #define netMasterErrUnused4C                    (netMasterErrClass + 0x4C)  // assign this one next
00177 #define netMasterErrUnused4D                    (netMasterErrClass + 0x4D)  // assign this one next
00178 #define netMasterErrUnused4E                    (netMasterErrClass + 0x4E)  // assign this one next
00179 /**@}*/
00180
00181 /** @name Net Master Error Codes
00182  */
00183 /**@{*/
00184 #define netMasterErrOneXServiceNotEnabled       (netMasterErrClass + 0x4F)  /**< modem doesn't support requested service */
00185 /**@}*/
00186
00187 //End NetMaster error code group.
00188
00189
00190 #endif // _NET_MASTER_LIB_ERRORS_H_
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:54 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » netmaster

NetMasterLibrary.h

Go to the documentation of this file.
00001 /******************************************************************************
00002  * Copyright (c) 2004 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  *****************************************************************************/
00005 /**
00006  * @defgroup NETMASTER NetMaster Library
00007  *
00008  * @{
00009  * @}
00010  */
00011 /**
00012  * @ingroup NETMASTER
00013  */
00014
00015 /**
00016  * @file    NetMasterLibrary.h
00017  * @version 1.0
00018  * @date    01/31/2002
00019  *
00020  * @brief This is the main header file for the NetMaster Library.
00021  *
00022  * Usage Model
00023  *
00024  * The NetMaster library is preloaded by the system software before
00025  * the system sends sysAppLaunchCmdSystemReset.
00026  *
00027  * Clients of NetMaster library need to call SysLibFind (netMasterLibName,...)
00028  * to get a library refNum of NetMaster.
00029  *
00030  * If SysLibFind returns a non-zero error, clients <b>MUST</b> assume that
00031  * NetMaster was not loaded for a <b>good</b> reason
00032  * (such as when the user performed a "safe" reset), or is
00033  * simply not present on the system and fail gracefully.
00034  *
00035  * Clients <b>MUST NOT</b> load NetMaster themselves (such as via SysLibLoad or
00036  * SysLibInstall) -- keep in mind that if the system didn't load it,
00037  * there was a good reason for it!
00038  *
00039  */
00040
00041 #ifndef _NET_MASTER_LIBRARY_H_
00042 #define _NET_MASTER_LIBRARY_H_
00043
00044
00045 #include <NetMasterLibTarget.h>
00046 #include <NetMasterLibTraps.h>
00047 #include <NetMasterLibErrors.h>
00048 #include <NetMasterLibTypes.h>
00049
00050
00051
00052 #ifdef BUILDING_NET_MASTER_LIB_DISPATCH_TABLE   // defined in the dispatch table
00053                                                 // module when building the NetMaster
00054                                                 // library itself
00055   #define NETMASTER_LIB_TRAP(trapNum)
00056
00057 #else
00058   #define NETMASTER_LIB_TRAP(trapNum) SYS_TRAP(trapNum)
00059 #endif
00060
00061
00062
00063 #ifdef __cplusplus
00064 extern "C" {
00065 #endif
00066
00067
00068 /// Get Library API Version number.
00069 ///
00070 ///  @param     refNum:     IN:  Library reference number
00071 ///  @param     majorVerP:  OUT: Major version number
00072 ///  @param     minorVerP:  OUT: Minor version number
00073 ///  @param     bugFixVerP: OUT: Bug fix version number
00074 ///  @retval    Err         NetMaster Library error code
00075
00076 extern Err
00077 NetMasterLibVersionGet (UInt16 refNum, UInt32* majorVerP, UInt32* minorVerP,
00078                         UInt32* bugFixVerP)
00079     NETMASTER_LIB_TRAP (netMasterLibTrapLibVersionGet);
00080
00081
00082 /// An extension, of sorts, of the NetLibOpen function -- allows the
00083 /// caller to specify special options, such as "auto-dismiss on error".
00084 /// See the definition of NetMasterNetLibOpenOptionsType for more details.
00085 ///
00086 /// The refNum parameter must be the refnum of NetMaster library
00087 /// (not of NetLib).
00088 ///
00089 /// IMPORTANT: This call is semantically equivalent to calling NetLibOpen;
00090 /// if this call succeeds (returns 0 error code), the caller is
00091 /// responsible for calling NetLibClose
00092 /// when done with NetLib; if this call fails (non-zero error code
00093 /// returned), the caller must *NOT* make the matching call to NetLibClose.
00094 ///
00095 /// @param  refNum:             IN:  NetMasterLib reference number (from SysLibFind()).
00096 /// @param  netLibOpenOptions:  IN:  See NetMasterNetLibOpenOptionsType.
00097 /// @param  netIFErrsP          OUT: Error returned by the net interface if open failed.
00098 /// @retval Err                 Error code.
00099 extern Err
00100 NetMasterNetLibOpenWithOptions (UInt16 refNum,
00101                             NetMasterNetLibOpenOptionsType netLibOpenOptions,
00102                             UInt16* netIFErrsP)
00103     NETMASTER_LIB_TRAP (netMasterLibTrapNetLibOpenWithOptions);
00104
00105
00106 /// Get the "auto-login" settings
00107 ///
00108 /// @param  refNum:     IN:  NetMasterLib reference number (from SysLibFind).
00109 /// @param  settingsP:  OUT: Any of the NetMasterAutoLoginType constants bitwise-or’ed together.
00110 /// @retval Err         Error code.
00111 extern Err
00112 NetMasterAutoLoginSettingGet (UInt16 refNum,
00113                               NetMasterAutoLoginType* settingsP)
00114     NETMASTER_LIB_TRAP (netMasterLibTrapAutoLoginSettingGet);
00115
00116
00117 /// NetMasterAutoLoginSettingSet:
00118 ///
00119 /// set the "auto-login" settings
00120 ///
00121 /// @param  refNum:         IN:  NetMasterLib reference number.
00122 /// @param  flagsToClear:   IN:  Flags to clear -- any of the NetMasterAutoLoginType
00123 ///                              constants bitwise-or'ed together or
00124 ///                              netMasterAutoLoginClearAll to clear all flags; the
00125 ///                              flag clearing operation is performed before the
00126 ///                              flag setting operation. Pass 0 to skip the clearing
00127 ///                              operation.
00128 /// @param  flagsToSet:     IN:  Flags to set -- any of the NetMasterAutoLoginType
00129 ///                              constants bitwise-or'ed together. Pass 0 to skip the
00130 ///                              setting operation.
00131 /// @retval Err             Error code.
00132 extern Err
00133 NetMasterAutoLoginSettingSet (UInt16 refNum,
00134                               NetMasterAutoLoginType flagsToClear,
00135                               NetMasterAutoLoginType flagsToSet)
00136     NETMASTER_LIB_TRAP (netMasterLibTrapAutoLoginSettingSet);
00137
00138
00139 /// Function:   NetMasterNetLibOpenIfFullyUp
00140 ///
00141 /// Summary:    Open NetLib only if all of its current interfaces are already
00142 ///             fully up.  If this call succeeds (returns true), it is
00143 ///             semantically equivalent to a successful NetLibOpen call, which
00144 ///             implies that the caller is responsible for calling NetLibClose
00145 ///             to match this call when done with NetLib.  If
00146 ///             NetMasterNetLibOpenIfFullyUp fails (returns false),
00147 ///             the caller *MUST NOT* make a matching call to NetLibClose.
00148 ///
00149 /// @param  refNum:         IN:  NetMasterLib reference number (from SysLibFind
00150 ///                              or SysLibLoad)
00151 /// @param  netLibRefNumP:  OUT: NetLib refnum on success, undefined on failure
00152 /// @retval Boolean         True if opened, false if not (failure)
00153 extern Boolean
00154 NetMasterNetLibOpenIfFullyUp (UInt16 refNum, UInt16* netLibRefNumP)
00155     NETMASTER_LIB_TRAP (netMasterLibTrapNetLibOpenIfFullyUp);
00156
00157
00158 /// Function:   NetMasterNetLibIsFullyUp
00159 ///
00160 /// Summary:    Checks if NetLib is fully up -- i.e. all of its interfaces
00161 ///             are up.
00162 ///
00163 /// @param  refNum: IN:  NetMasterLib reference number (from SysLibFind
00164 /// @retval Boolean True if NetLib is fully up, false if at least one interface is down.
00165 extern Boolean
00166 NetMasterNetLibIsFullyUp (UInt16 refNum)
00167     NETMASTER_LIB_TRAP (netMasterLibTrapNetLibIsFullyUp);
00168
00169
00170 /// Shut down NetLib's interfaces, if they are presently up; does nothing
00171 /// if they are presently down; blocking;  If NetLib is in the process
00172 /// of logging on to the IP network (Connection progress dialog is up),
00173 /// will simulate the press of the Cancel key and return without waiting
00174 /// for interfaces to shut down.
00175 ///
00176 /// WARNING: will dead-lock if called from the context of a Notification
00177 /// Manager notification.  This is because Notification Manager erroneously
00178 /// grabs the Memory Manager semaphore before sending a notification, and
00179 /// this causes a dead-lock when the TCP/IP stack's background task calls
00180 /// into Memory Manager or Data Manager API as part of the shut-down.
00181 ///
00182 /// Shut down NetLib’s interfaces, if they are presently up; does nothing if they are
00183 /// presently down.
00184 ///
00185 /// @param  refNum:             IN: NetMasterLib reference number (from SysLibFind)
00186 /// @param  reasonErrCode:      IN: Error code that is the reason for this call to
00187 ///                                 NetMasterNetInterfacesShutDown; 0 if not an error, or reason is unknown.
00188 ///                                 Future version of this API may use the error code to display an alert or log a debug trace.
00189 /// @param  shutDownOptions:    IN: Shutdown options. See NetMasterNetIFShutDownOptionsType.
00190 /// @retval Err Error code.
00191 extern Err
00192 NetMasterNetInterfacesShutDown (UInt16 refNum, Err reasonErrCode,
00193                             NetMasterNetIFShutDownOptionsType shutDownOptions)
00194     NETMASTER_LIB_TRAP (netMasterLibTrapNetInterfacesShutDown);
00195
00196
00197 /// Test if NetLib is in the Logging On state.
00198 /// Returns true if some client is presently inside NetLibOpen or
00199 /// NetLibOpenConfig.
00200 ///
00201 /// @param  refNum:                 IN:  NetMaster library reference number.
00202 /// @param  isLogonActiveP:         OUT: True if NetLib is in the middle of
00203 ///                                      logging in and an error has not yet been encountered.
00204 ///                                      This parameter is OPTIONAL -- pass NULL to ignore.
00205 /// @param  isPrgDialogUpP:         OUT: If NetLib's Service Connection Progress
00206 ///                                      dialog is up, NetMasterIsLoggingIn will set
00207 ///                                      *isPrgDialogUpP to true; false otherwise.
00208 ///                                      This parameter is OPTIONAL -- pass NULL to ignore.
00209 /// @param  waitingInErrorStateP:   OUT: If NetLib's Service Connection Prorgress
00210 ///                                      dialog is in the error acknowledegement state
00211 ///                                      (displaying an error message to the user,
00212 ///                                      waiting for OK), NetMasterIsLoggingIn will set
00213 ///                                      *waitingInErrorStateP to true; false otherwise.
00214 ///                                      This parameter is OPTIONAL -- pass NULL to ignore.
00215 /// @retval Boolean                 True if some client is presently inside NetLibOpen or NetLibOpenConfig.
00216 extern Boolean
00217 NetMasterNetLibIsLoggingIn (UInt16 refNum, Boolean* isLogonActiveP,
00218                             Boolean* isPrgDialogUpP,
00219                             Boolean* waitingInErrorStateP)
00220     NETMASTER_LIB_TRAP (netMasterLibTrapNetLibIsLoggingIn);
00221
00222
00223
00224 //-------------------------------------------------------------------------
00225 // NetMaster Data Session Control API
00226 //-------------------------------------------------------------------------
00227
00228 #if 0
00229 #pragma mark -- Data Session Control API --
00230 #endif
00231
00232
00233 /*
00234
00235         Usage Model for Data Session Control API
00236
00237
00238
00239 Background:
00240
00241 Palm OS 5.2 does *not* provide a robust model for arbitrating the
00242 activation (loogging in) of different network service profiles
00243 between competing tasks.  For example, the MMS application,
00244 running in the background, may receive a trigger and need to log
00245 in with the MMS APN (network profile), while the Browser app
00246 has NetLib open with the Internet or browser-specific APN.
00247 NetLib does not provide a way to arbitrate between the needs
00248 of both apps, and this version of NetLib and/or the initial
00249 hardware that runs it do not support multiple concurrent data
00250 sessions over the same Network Interface (PPP, for example). This
00251 API attempts to bridge the gap somewhat by keeping track of the
00252 current NetLib usage by various tasks, and trying to make
00253 intelligent decisions about when a request to activate a
00254 particular network profile may be allowed to shut down another
00255 previously active profile.  This API also attempts to simplify
00256 and make more robust the process of logging in with a network
00257 profile that is not the "default" network profile. Before this
00258 API, applications had to get the current default network profile
00259 ID, set a new default, call NetLibOpen, do their networking, then
00260 restore the default ID. This worked somewhat in a model where
00261 only one app runs and performs data networking at a time.
00262 However, multiple concurrent clients, possibly running on
00263 different tasks, open lots of room for the multiple writer
00264 problem as well as the inability to restore the default profile
00265 ID should a crash or soft-reset occur during the application's
00266 execution.
00267
00268
00269 Disclaimer:
00270
00271 This API is *not* for everyone.  It is intended to be a
00272 temporary solution to a (hopefully) temprorary limitation in
00273 Palm OS's Network library.  Future versions of Palm OS or NetLib
00274 may make it impossible or unnecessary for this API to be
00275 supported, and it would then be deprecated.  Most apps that
00276 conntect using the "default" network profile (as selected in
00277 the Network Panel) should continue to use the standard NetLib
00278 API (NetLibOpen and NetLibClose) in order to remain compatible
00279 with future releases of Palm OS.
00280
00281
00282 Usage Model:
00283
00284 1. The NetMaster Data Session Control API *MUST NOT* be
00285 intermixed with NetLib's "session control" API, which includes
00286 NetLibOpen, NetLibOpenConfig, NetLibOpenIfCloseWait, NetLibClose,
00287 NetLibConnectionRefresh, NetLibIFUp, NetLibIFDown, NetLibIFAttach,
00288 and NetLibIFDetach.  You MUST either use one set of session
00289 control API or the other, exclusively.
00290
00291 2. The NetMaster Data Session Control API works closely with the
00292 Handspring NetPref library.  Applications first look up the
00293 desired network profile record using the NetPref library API,
00294 then provide this record's ID to NetMasterSCNetAttach via the
00295 netPrefRecID parameter.  This API only works with network
00296 profiles that are managed by NetPref library.  Other profiles
00297 are NOT supported.
00298
00299 3. The NetMaster Data Session Control API is centered around
00300 the concepts of data sessions and data contexts.  A given data
00301 session represents an established (logged-in) data session via
00302 a specific network profile ID.  An "active" data session is one
00303 that is believed to be logged in; otherwise it is "inactive"
00304 A given data context represents a client (an executable such as
00305 an application or library) that successfully attached to a data
00306 session by calling NetMasterSCNetAttach.  Multiple data contexts
00307 may be "attached" to a single data session. The Data Session
00308 Control API provides functions that operation on both Data
00309 Contexts and Data Sessions.  The functions that most clients
00310 utilizing this API will use are NetMasterSCNetAttach,
00311 NetMasterSCNetDetach, NetMasterSCSessionIDGetFromContext, and
00312 NetMasterSCSessionIsActive. The remaining functions are mainly
00313 for troubleshooting purposes.
00314
00315 4. A client begins networking over a particular network profile
00316 by calling NetMasterSCNetAttach() with the desired network
00317 profile ID and other specialized parameters. The client uses
00318 NetMasterSCNetAttach instead of NetLib's NetLibOpen or
00319 NetLibOpenConfig. If there is already an active
00320 data session where the requested network profile ID was
00321 either the primary or fallback profile, NetMasterSCNetAttach
00322 "attaches" the caller to that data session. *See NetPref API
00323 documenation for definition of primary and fallback profiles. If,
00324 on the other hand, the active data session was established from
00325 a different network profile, NetMasterSCNetAttach employs an
00326 internal algorithm to see if it can preempt (shut down) the
00327 active data session, and do so if it can. If it cannot make room
00328 for a new data session by tearing down an existing data session,
00329 the function fails.  If there was no active data session or if
00330 one was successfully shut down to make room for the new data
00331 session, NetMasterSCNetAttach will attempt to establish a new
00332 data session with the requested network profile, and attach the
00333 client to that data session.  On success, NetMasterSCNetAttach
00334 returns an error code of 0 and a non-zero Context ID of a newly
00335 created data context that is attached to the data session. The
00336 returned Context ID may be passed to other functions of this API
00337 family that require a data context ID.  This data context ID is
00338 valid only until you destroy it by calling NetMasterSCNetDetach.
00339 Once the Context ID is destroyed, it *MUST NOT* be passed to any
00340 functions.  If NetMasterSCNetAttach fails, you may need to retry
00341 at a later time.  The error code netErrAlreadyOpenWithOtherConfig
00342 indicates that NetMasterSCNetAttach could not preempt another
00343 active data session.  Other non-zero error codes are typically
00344 either NetLib or NetMaster library error codes.
00345
00346 When the client is finished with using the network session that
00347 was acquired with NetMasterSCNetAttach, such as when exiting the
00348 networking application or terminating its task, etc., the client
00349 MUST destroy the data context by calling NetMasterSCNetDetach.
00350 User's of the NetMaster Data Session Control API call
00351 NetMasterSCNetDetach instead of NetLibClose.
00352
00353 5. Once attached to a data session, the client may periodically
00354 call NetMasterSCSessionIsActive to check if that session is
00355 still logged in.  NetMasterSCSessionIsActive takes a data session
00356 ID as a parameter.  Call NetMasterSCSessionIDGetFromContext
00357 to get the data session ID from a valid data context ID.  If it
00358 reports that the data session is *not* active, this means that
00359 the data session was shut down for some reason, such as loss of
00360 network coverage for an extended time, wireless mode being turned
00361 off, preemted by another client requesting a different network
00362 profile, etc.  When this occurs, you should destroy the data
00363 context by calling NetMasterSCNetDetach, since this API has
00364 *no* concept of data session re-activation. If you need to resume
00365 your data session, you need to get a new data context via
00366 NetMasterSCNetAttach, discussed above.
00367
00368 6. If the application is in a state where
00369 the anchor timeout that it initially requested when
00370 calling NetMasterSCNetAttach is now bigger
00371 than necessary, the application MUST reduce its anchor
00372 timeout to the minimum acceptable value by calling
00373 NetMasterSCContextAnchorTimeoutSet so that other services
00374 may be activated more quickly when necessary.
00375
00376
00377 7. The remaining NetMaster Data Session Control API's are
00378 intended for troubleshooting purposes and not described in detail
00379 yet.
00380
00381 */
00382
00383
00384
00385 // IMPORTANT: NetMasterSCNetAttach/NetMasterSCNetDetach are implemented under
00386 // Palm OS 5.x only and not available before Palm OS 5.0.  These functions
00387 // may be used from UI and background tasks. These functions semantically
00388 // replace NetLibOpen/NetLibClose.
00389 //
00390 // Attach to the network using the specified service; this will call
00391 //  NetLibOpen and execute any required fallback services, as necessary
00392 //  on the caller's behalf.
00393 //
00394 // loginPriority        IN  Login priority -- most applications should use
00395 //                           the netMasterLoginPriorityDefault priority.
00396 //
00397 // anchorTimeoutSec     IN  Initial data session anchor timeout request.
00398 //                           The system may limit this request if it is bigger
00399 //                           than maximum allowed for the given device
00400 //                           configuration.  This value is used by the system
00401 //                           to decide when a data session may be considered
00402 //                           idle, and may be shut down to make room for
00403 //                           a different login request. This value is treated
00404 //                           as a hint only, and the system makes no
00405 //                           guarantees about the longevity of the data
00406 //                           session. The duration is in seconds, which may
00407 //                           be 0.  For system default, pass
00408 //                           netMasterAnchorTimeoutDefault (RECOMMENDED!)
00409 //
00410 // isNetIFErrorP        OUT [OPTIONAL] when non zero error code is returned,
00411 //                           this boolean indicates whether the error
00412 //                           was from the network interface. For
00413 //                           foreground-initiated logins, the
00414 //                           implication is that if it *is* an
00415 //                           error from the network interface,
00416 //                           an error message was most likely
00417 //                           already displayed to the user via the
00418 //                           standard progress dialog UI. If
00419 //                           the error is *not* from the network
00420 //                           interface, no error has been displayed
00421 //                           to the user. Pass NULL to ignore this
00422 //                           parameter..
00423 //
00424 // IMPORTANT: if this call succeeds (returns 0
00425 //  error code), the caller is responsible for calling NetMasterSCNetDetach
00426 //  when done with this data context; if this call fails (non-zero error code
00427 //  returned), the caller must *NOT* make the matching call to
00428 //  NetMasterSCNetDetach.
00429
00430
00431 /// Attach to the network using the specified service; this will call NetLibOpen and
00432 /// execute any required fallback services, as necessary on the caller’s behalf.
00433 ///
00434 /// @param refNum:              IN:  NetMasterLib reference number (from SysLibFind).
00435 /// @param netPrefRecID:        IN:  NetPref Record ID of the network profile to attach.
00436 /// @param netLibOpenOptions:   IN:  Special options, such as “auto-dismiss on error”; 0 = no options.
00437 /// @param loginPriority:       IN:  Login priority. Most applications should use the netMasterLoginPriorityDefault priority.
00438 /// @param anchorTimeoutSec:    IN:  It is bigger than maximum allowed for the given device configuration. This
00439 ///                                  value is used by the system to decide when a data session may be considered
00440 ///                                  idle, and may be shut down to make room for a different login request. This
00441 ///                                  value is treated as a hint only, and the system makes no guarantees about the
00442 ///                                  longevity of the data session. The duration is in seconds, which may be 0. For
00443 ///                                  system default, pass netMasterAnchorTimeoutDefault (RECOMMENDED!)
00444 /// @param dataCxtIDP:          OUT: Data context on success, undefined on failure.
00445 /// @param isNetIFErrorP:       OUT: When non zero error code is returned, this boolean indicates
00446 ///                                  whether the error was from the network interface. For foreground-initiated
00447 ///                                  logins, the implication is that if it *is* an error from the network interface, an
00448 ///                                  error message was most likely already displayed to the user via the standard
00449 ///                                  progress dialog UI. If the error is *not* from the network interface, no error has
00450 ///                                  been displayed to the user. Pass NULL to ignore this parameter.
00451 /// @retval Err                 Error code.
00452 extern Err
00453 NetMasterSCNetAttach (UInt16 refNum, UInt32 netPrefRecID,
00454                     NetMasterNetLibOpenOptionsType netLibOpenOptions,
00455                     NetMasterLoginPriorityEnum loginPriority,
00456                     Int32 anchorTimeoutSec,
00457                     NetMasterDataContextIDType* dataCxtIDP,
00458                     Boolean* isNetIFErrorP)
00459     NETMASTER_LIB_TRAP (netMasterLibTrapSCNetAttach);
00460
00461 /// Detach from the data session that was successfully established by
00462 /// NetMasterSCNetAttach.
00463 ///
00464 /// @param  refNum:      IN: NetMasterLib reference number (from SysLibFind).
00465 /// @param  dataCxtID:   IN: Data context created by NetMasterSCNetAttach.
00466 /// @retval Err          Error code.
00467 extern Err
00468 NetMasterSCNetDetach (UInt16 refNum,
00469                     NetMasterDataContextIDType dataCxtID)
00470     NETMASTER_LIB_TRAP (netMasterLibTrapSCNetDetach);
00471
00472
00473 /// Changes the data context's session anchor timeout value.
00474 /// The requested anchor timeout value is in seconds. The system
00475 /// will apply internal limits to the value if necessary. The
00476 /// actual value is returned via the optional output arugment
00477 /// oActualAnchorTimeoutSecP (pass NULL to ignore).
00478 ///
00479 /// IMPORTANT:
00480 /// If the application is in a state where
00481 /// the anchor timeout that it initially requested when
00482 /// calling NetMasterSCNetAttach is now bigger
00483 /// than necessary, the application MUST reduce its anchor
00484 /// timeout to the minimum acceptable value so that other services
00485 /// may be activated more quickly when necessary.
00486 ///
00487 /// @param refNum:                      IN:  NetMasterLib reference number (from SysLibFind).
00488 /// @param dataCxtID:                   IN:  Data context created by NetMasterSCNetAttach.
00489 /// @param requestedAnchorTimeoutSec:   IN:  Requested anchor timeout in seconds.
00490 /// @param oActualAnchorTimeoutSecP:    OUT: Actual anchor timeout that was applied (pass NULL to ignore).
00491 ///                                          Undefined on error.
00492 /// @retval Err                         Error code.
00493 extern Err
00494 NetMasterSCContextAnchorTimeoutSet (UInt16 refNum,
00495                                     NetMasterDataContextIDType dataCxtID,
00496                                     Int32 requestedAnchorTimeoutSec,
00497                                     Int32* oActualAnchorTimeoutSecP)
00498     NETMASTER_LIB_TRAP (netMasterLibTrapSCContextAnchorTimeoutSet);
00499
00500
00501
00502 /// Given a data context, get the associated data session ID.  0 or more
00503 /// data contexts may be associated with a data session.  A data session
00504 /// represents a single network login instance.  i.e., if you had two
00505 /// concurrent network login instances, such as GPRS and 802.11 for example,
00506 /// there would be two network data sessions.
00507 ///
00508 /// @param refNum:      IN:  NetMasterLib reference number (from SysLibFind).
00509 /// @param dataCxtID:   IN:  Data context created by NetMasterSCNetAttach.
00510 /// @param sessionP:    OUT: Data session ID on success, undefined on failure.
00511 /// @retval Err         Error code.
00512 extern Err
00513 NetMasterSCSessionIDGetFromContext (UInt16 refNum,
00514                                    NetMasterDataContextIDType dataCxtID,
00515                                    NetMasterDataSessionIDType* sessionP)
00516     NETMASTER_LIB_TRAP (netMasterLibTrapSCSessionIDGetFromContext);
00517
00518
00519 /// Get the current count of network data sessions that are active (believed
00520 /// to be logged in).
00521 ///
00522 /// @param refNum:              IN:  NetMasterLib reference number (from SysLibFind).
00523 /// @param activeSessionCountP: OUT: Count of active data sessions.
00524 /// @retval Err                 Error code.
00525 extern Err
00526 NetMasterSCSessionCountGet (UInt16 refNum, Int16* activeSessionCountP)
00527     NETMASTER_LIB_TRAP (netMasterLibTrapSCSessionCountGet);
00528
00529
00530 /// Fill an array with session ID's of the currently active data sessions.
00531 /// Initially, only one active data session may be supported, but this may
00532 /// increase with the hardware and system software capabilities.
00533 ///
00534 /// @param refNum:          IN:  NetMasterLib reference number (from SysLibFind).
00535 /// @param sessionIDs:      OUT: Array for returning session IDs on success, contents undefined on failure.
00536 /// @param maxEntries:      IN:  Max # of session ID’s that may be stored in the caller’s array sessionIDs.
00537 /// @param entriesStoredP:  OUT: On success, number of entries that were actually returned in the sessionIDs
00538 ///                              array, which may be less than maxEntries (possibly 0); undefined on failure.
00539 /// @param Err              Error code.
00540 extern Err
00541 NetMasterSCSessionsEnumerate (UInt16 refNum,
00542                               NetMasterDataSessionIDType sessionIDs[],
00543                               Int16 maxEntries, Int16* entriesStoredP)
00544     NETMASTER_LIB_TRAP (netMasterLibTrapSCSessionsEnumerate);
00545
00546
00547 /// Retrieves the unique ID's of the actual and primary NetPref records
00548 /// that were used to establish the data session. The two may be different if
00549 /// the primary record had a fallback, the primary failed, and the fallback
00550 /// record succeeded.  In other words, *actualNetPrefIDP indicates the NetPref
00551 /// record ID that succeeded in establishing the connection.
00552 ///
00553 /// @param refNum:              IN:  NetMasterLib reference number (from SysLibFind).
00554 /// @param sessionID:           IN:  Data session ID.
00555 /// @param primaryNetPrefIDP:   OUT: NetPref record ID of the primary record used in connection establishment.
00556 /// @param actualNetPrefIDP:    OUT: NetPref record ID of the actual record with which connection establishment
00557 ///                                  succeeded. This may be the same as the primary record or a fallback of the
00558 ///                                  primary record.
00559 /// @retval Err                 Error code.
00560 extern Err
00561 NetMasterSCSessionSvcRecIDGet (UInt16 refNum,
00562                              NetMasterDataSessionIDType sessionID,
00563                              UInt32* primaryNetPrefIDP,
00564                              UInt32* actualNetPrefIDP)
00565     NETMASTER_LIB_TRAP (netMasterLibTrapSCSessionSvcRecIDGet);
00566
00567
00568 /// Checks if the given session is still on the active list (believed
00569 /// to be logged in).
00570 ///
00571 /// @param refNum:      IN:  NetMasterLib reference number (from SysLibFind).
00572 /// @param sessionID:   IN:  Data session ID.
00573 /// @param isActiveP:   OUT: True if the given session is believed to be logged in, false if it’s not logged in.
00574 /// @retval Err         Error code.
00575 extern Err
00576 NetMasterSCSessionIsActive (UInt16 refNum,
00577                             NetMasterDataSessionIDType sessionID,
00578                             Boolean* isActiveP)
00579     NETMASTER_LIB_TRAP (netMasterLibTrapSCSessionIsActive);
00580
00581
00582 /// Request shut down of the given network session.  This
00583 /// function may block for a significant period of time (typically
00584 /// multiple seconds) while the network interfaces are being brought
00585 /// down.
00586 ///
00587 /// @param refNum:          IN: NetMasterLib reference number (from SysLibFind).
00588 /// @param sessionID:       IN: data session ID.
00589 /// @param shutDownOptions: IN: shutdown options. See NetMasterNetIFShutDownOptionsType.
00590 /// @retval Err             Error code.
00591 extern Err
00592 NetMasterSCSessionShutDown (UInt16 refNum,
00593                             NetMasterDataSessionIDType sessionID,
00594                             NetMasterNetIFShutDownOptionsType shutDownOptions)
00595     NETMASTER_LIB_TRAP (netMasterLibTrapSCSessionShutDown);
00596
00597
00598
00599 #ifdef __cplusplus
00600 }
00601 #endif
00602
00603
00604 #endif // _NET_MASTER_LIBRARY_H_
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:54 2008 for Palm API Guide


Header Files » Incs » common » libraries » netmaster

NetMasterLibTarget.h

Go to the documentation of this file.
00001 /******************************************************************************
00002  * Copyright (c) 2004 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  *****************************************************************************/
00005 /**
00006  * @ingroup NETMASTER
00007  */
00008
00009 /**
00010  * @file    NetMasterLibTarget.h
00011  * @version 1.0
00012  * @date    01/31/2002
00013  *
00014  * @brief This is the target parameters file for the NetMaster Library.
00015  *
00016  * We break out these definitions so that other portable modules
00017  * could access them without PalmOS-specific definitions
00018  *
00019  *
00020  */
00021
00022 #ifndef _NET_MASTER_LIB_TARAGET_H_
00023 #define _NET_MASTER_LIB_TARAGET_H_
00024
00025
00026
00027 // 'HsNM' was registered with Palm on February 01, 2002 at 3:59pm
00028 #define netMasterLibCreatorID   'HsNM'  /**< NetMaster Library database creator */
00029
00030 #define netMasterLibTypeID      'libr'  /**< Standard library database type */
00031
00032 #define netMasterLibName        "HsNetMasterLibrary.lib"  /**< Internal library name
00033                                                                which can be passed to SysLibFind() */
00034
00035
00036
00037
00038 #endif // _NET_MASTER_LIB_TARAGET_H_
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:54 2008 for Palm API Guide


Header Files » Incs » common » libraries » netmaster

NetMasterLibTraps.h

Go to the documentation of this file.
00001 /******************************************************************************
00002  * Copyright (c) 2004 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  *****************************************************************************/
00005 /**
00006  * @ingroup NETMASTER
00007  */
00008
00009 /**
00010  * @file    NetMasterLibTraps.h
00011  * @version 1.0
00012  * @date    01/31/2002
00013  *
00014  * @brief Trap definitions for the NetMaster Library.
00015  *
00016  */
00017
00018
00019 #ifndef __NET_MASTER_LIB_TRAPS_H__
00020 #define __NET_MASTER_LIB_TRAPS_H__
00021
00022
00023 // Trap IDs for the NetMaster Library's public functions. The order of the traps
00024 // must be the same as the routines are listed in NetMasterLibDispatchTable.c.
00025 /**
00026  *@name NetMaster Function Trap Numbers
00027  */
00028 /*@{*/
00029 #define netMasterLibTrapLibVersionGet                   (sysLibTrapCustom + 0)
00030 #define netMasterLibTrapSCNetAttach                     (sysLibTrapCustom + 1)
00031 #define netMasterLibTrapLibInit                         (sysLibTrapCustom + 2)
00032 #define netMasterLibTrapAutoLoginSettingGet             (sysLibTrapCustom + 3)
00033 #define netMasterLibTrapAutoLoginSettingSet             (sysLibTrapCustom + 4)
00034 #define netMasterLibTrapServiceSetUp                    (sysLibTrapCustom + 5)
00035 #define netMasterLibTrapNetLibOpenIfFullyUp             (sysLibTrapCustom + 6)
00036 #define netMasterLibTrapNetLibIsFullyUp                 (sysLibTrapCustom + 7)
00037 #define netMasterLibTrapPhoneServiceClassesGet          (sysLibTrapCustom + 8)
00038 #define netMasterLibTrapHandlePhoneEvent                (sysLibTrapCustom + 9)
00039 #define netMasterLibTrapControl                         (sysLibTrapCustom + 10)
00040 #define netMasterLibTrapNetInterfacesShutDown           (sysLibTrapCustom + 11)
00041 #define netMasterLibTrapNetLibIsLoggingIn               (sysLibTrapCustom + 12)
00042 #define netMasterLibTrapNetLibOpenWithOptions           (sysLibTrapCustom + 13)
00043 #define netMasterLibTrapImplementNetLibOpenConfig       (sysLibTrapCustom + 14)
00044 #define netMasterLibTrapImplementNetLibConnectionRefresh (sysLibTrapCustom + 15)
00045 #define netMasterLibTrapImplementNetLibHandlePowerOff   (sysLibTrapCustom + 16)
00046 #define netMasterLibTrapOverrideErrorGetAndClear        (sysLibTrapCustom + 17)
00047 #define netMasterLibTrapOverrideMdmInitStrGetPtr        (sysLibTrapCustom + 18)
00048 #define netMasterLibTrapLoginSMFlagsSetAndGet           (sysLibTrapCustom + 19)
00049 #define netMasterLibTrapDataSessionErrorNotify          (sysLibTrapCustom + 20)
00050 #define netMasterLibTrapSCNetDetach                     (sysLibTrapCustom + 21)
00051 #define netMasterLibTrapSCSessionIDGetFromContext       (sysLibTrapCustom + 22)
00052 #define netMasterLibTrapSCSessionCountGet               (sysLibTrapCustom + 23)
00053 #define netMasterLibTrapSCSessionsEnumerate             (sysLibTrapCustom + 24)
00054 #define netMasterLibTrapSCSessionSvcRecIDGet            (sysLibTrapCustom + 25)
00055 #define netMasterLibTrapSCSessionIsActive               (sysLibTrapCustom + 26)
00056 #define netMasterLibTrapSCSessionShutDown               (sysLibTrapCustom + 27)
00057 #define netMasterLibTrapLoginExecuteFromUI              (sysLibTrapCustom + 28)
00058 #define netMasterLibTrapSCContextAnchorTimeoutSet       (sysLibTrapCustom + 29)
00059 #define netMasterLibTrapPPPPayloadReport                (sysLibTrapCustom + 30)
00060 #define netMasterLibTrapDataCounterGetAndReset          (sysLibTrapCustom + 31)
00061 /*@}*/
00062
00063 #endif /* __NET_MASTER_LIB_TRAPS_H__ */
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:54 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » netmaster

NetMasterLibTypes.h

Go to the documentation of this file.
00001 /******************************************************************************
00002  * Copyright (c) 2004 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  *****************************************************************************/
00005 /**
00006  * @ingroup NETMASTER
00007  */
00008
00009 /**
00010  * @file    NetMasterLibTypes.h
00011  * @version 1.0
00012  * @date    01/31/2002
00013  *
00014  * @brief This file contains public data types exported by the NetMaster Library
00015  *
00016  * For usage model: @see NetMasterLibrary.h
00017  */
00018
00019
00020 #ifndef _NET_MASTER_LIB_TYPES_H_
00021 #define _NET_MASTER_LIB_TYPES_H_
00022
00023
00024
00025 /** Opaque structures */
00026 struct NetMasterContextTypeTag;
00027
00028
00029 /**
00030  * @name NetMaster API Version Number
00031  * @brief Current library API version number returned by NetMasterLibVersionGet()
00032  */
00033 /*@{*/
00034 #define netMasterLibVersionMajor      0
00035 #define netMasterLibVersionMinor      4
00036 #define netMasterLibVersionBugFix     0
00037 /*@}*/
00038
00039 // Change details:
00040 // 0.1.0 -- original
00041 // 0.2.0: implemented original VPN override notification
00042 // 0.3.0: implemented NetMasterNetLibOpenWithOptions ().
00043 // 0.4.0: implemented initial Palm OS 5.x support, including
00044 //         initial Data Session Control API.
00045
00046
00047 /** TCP/IP Network Auto-login definitions used by NetMasterAutoLoginSettingGet()
00048  *  and NetMasterAutoLoginSettingSet()
00049  */
00050 typedef UInt32  NetMasterAutoLoginType;
00051 enum
00052   {
00053     /**
00054      *  For CDMA 1xRTT: Automatically log in to the TCP/IP network when the
00055      *  wireless mode is turned on and network is acquired;
00056      *  For GSM GPRS: Attempt to attach when the radio is powered on (ideally
00057      *  a combined attach)
00058      */
00059     // NOTE: Used by Handspring's Network Panel
00060     netMasterAutoLoginWhenWirelessOn    = 0x00000001UL,
00061
00062     /**
00063      * Prompt the user before connecting to the Internet;
00064      * Also known as the "NetGuard" feature.
00065      */
00066     // NOTE: Used by Handspring's Network Panel
00067     netMasterLoginNetGuardEnabled       = 0x00000002UL,
00068
00069     netMasterAutoLoginClearAll          = 0xFFFFFFFFUL
00070   };
00071
00072
00073 /** NetLib interface shutdown options for NetMasterNetInterfacesShutDown */
00074 typedef UInt32  NetMasterNetIFShutDownOptionsType;
00075 enum
00076   {
00077     /** If the Progress dialog is up, dismiss it even if it is
00078      *  in the error display state
00079      */
00080     netMasterNetIFShutDownOptDismissPrgDialog   = 0x00000001UL,
00081
00082     /** If set, and the session being connected at the moment has
00083      *  a fallback, this will allow the fallback to be processed (for example,
00084      *  when aborting GPRS logon, but allowing the fallback, if any, to
00085      *  take place)
00086      */
00087     netMasterNetIFShutDownOptCurrentOnly        = 0x00000002UL,
00088
00089
00090     /** If set, will cause the cached NetGuard setting to be
00091      *  cleared: apps that Disconnect the network connection as the
00092      *  result of user request (such as Disconnect button or menu item),
00093      *  MUST set this flag -- this causes the system to put up the
00094      *  NetGuard prompt during a subsequent data network login,
00095      *  if dictated by the netMasterLoginNetGuardEnabled setting.
00096      *
00097      *  If *not* set, will cause the cached NetGuard setting to
00098      *  be preserved.
00099      */
00100     netMasterNetIFShutDownOptResetNetGuard      = 0x00000004UL
00101
00102
00103   };
00104
00105
00106 // ------------------------------------------------------------------
00107 // Client Notification Events: (netMasterClientEventNotificationTypeID)
00108 //
00109 // Parameter block and supporting data structures sent to the currently
00110 // registered NetMaster library client(s) via Palm OS Notification Manager.
00111 // ------------------------------------------------------------------
00112
00113 /** The application that wishes to receive these notifications registers
00114  *  via Palm OS Notification Manager's SysNotifyRegister() for the event type
00115  *  netMasterClientEventNotificationTypeID to receive the events listed in
00116  *  NetMasterClientEventEnum. See Palm OS Notification Manager
00117  *  documentation for registration and notification handling details.
00118  */
00119 // (Handspring registered 'HICe' with Palm Source on 08-Oct-2002 at 8:23pm PST)
00120 #define netMasterClientEventNotificationTypeID    'HnMe'
00121
00122
00123 /** NetMaster library client event selector */
00124 typedef UInt16    NetMasterClientEventEnum;
00125 enum
00126   {
00127     netMasterClientEventUnknown     = 0,    // reserve 0
00128
00129     /** Queries the VPN vendor to install its own connection profile name,
00130      *  if any; NetMaster library broadcasts this event to all registered
00131      *  clients from the context of the UI task when a client application
00132      *  calls NetLibOpen() or NetLibOpenConfig().
00133      *  Parameter block:
00134      *  NetMasterClientEventInfoType:NetMasterClientEventVPNConnInstallType
00135      */
00136     netMasterClientEventVPNConnInstall,
00137
00138
00139
00140
00141     netMasterClientEventLAST
00142   };
00143
00144
00145
00146 /**
00147  * @brief Data block for netMasterClientEventVPNConnInstall
00148  */
00149 typedef struct
00150   {
00151     // --------------------------------------------------------------
00152     // Inputs
00153     // --------------------------------------------------------------
00154
00155     /** Name of the connection that NetLib will use unless the VPN
00156      *  client overrides it by setting vpnConnProfileOverrideName
00157      *  to a non-empty connection name string.  Watch out for the case
00158      *  where the user inadvertently selected the VPN connection name
00159      *  itself as the connection name for the network profile. VPN vendors
00160      *  that choose to override this connection name, will likely wish
00161      *  to save this connection name so that their destination connection.
00162      */
00163     Char                    defaultConnProfileName[cncProfileNameSize];
00164
00165     UInt32                  inReserved1;  /**< set to zero by this lib */
00166     UInt32                  inReserved2;  /**< set to zero by this lib */
00167
00168
00169     // --------------------------------------------------------------
00170     // Outputs -- modify only if you wish to override the default
00171     //            connection name!
00172     // --------------------------------------------------------------
00173
00174     /** The VPN vendor may override the default connection name that NetLib
00175      *  will use by setting this field to a non-empty string -- this string
00176      *  MUST be a valid connection name that presently exists in the connection
00177      *  panel!
00178      *
00179      *  If the VPN vendor presently does *not* wish to override the default
00180      *  connection (based on user settings in the VPN vendor's configuration
00181      *  UI), the VPN vendor should leave this field alone (don't modify
00182      *  it in any way in this case to avoid conflicts with other VPN vendor
00183      *  that may be currently installed on the same device).
00184      */
00185     Char                    vpnConnProfileOverrideName[cncProfileNameSize];
00186   }
00187 NetMasterClientEventVPNConnInstallType;
00188
00189
00190 /** Increment this version # when adding fields to NetMasterClientEventInfoType,
00191  *  except when just adding a new event data pointer to eventData
00192  */
00193 #define netMasterClientCurrentEventVersion      1
00194
00195 /**
00196  * @brief This structure is passed as the 'detailsP' of the notification.
00197  * @see Palm OS Notification Manager
00198  */
00199 typedef struct
00200   {
00201     // --------------------------------------------------------------
00202     // Inputs
00203     // --------------------------------------------------------------
00204
00205     /** Version of this structure -- all future versions MUST define
00206       * backward compatible Event structures.
00207       * NetMaster Library sets this to netMasterClientCurrentEventVersion
00208       * at the time the library was built. */
00209     UInt16                      version;
00210
00211     /** Event ID */
00212     NetMasterClientEventEnum    eventID;
00213
00214     /** Data corresponding to the event ID */
00215     union
00216       {
00217         /** genericEventDataP is for the convenience of the internal
00218           * code only. */
00219         void*                                   genericEventDataP;
00220
00221         /** For netMasterClientEventVPNConnInstall */
00222         NetMasterClientEventVPNConnInstallType* vpnConnInstallP;
00223
00224       }
00225     eventData;
00226
00227     UInt32                          inReserved1;    /**< Reserved values; Set to 0 by NetMaster library */
00228     UInt32                          inReserved2;    /**< Reserved values; Set to 0 by NetMaster library */
00229     UInt32                          inReserved3;    /**< Reserved values; Set to 0 by NetMaster library */
00230     UInt32                          inReserved4;    /**< Reserved values; Set to 0 by NetMaster library */
00231
00232
00233     // --------------------------------------------------------------
00234     // Outputs - none for now
00235     // --------------------------------------------------------------
00236   }
00237 NetMasterClientEventInfoType;
00238
00239
00240 /** Special NetLibOpenConfig options passed to
00241  *  NetMasterNetLibOpenWithOptions()
00242  */
00243 typedef UInt32    NetMasterNetLibOpenOptionsType;
00244 enum
00245   {
00246     /** netMasterNetLibOpenOptAutoDismiss:
00247      *
00248      *  If set, auto-dismiss the progress dialog if error occurs
00249      */
00250     netMasterNetLibOpenOptAutoDismiss           = 0x00000001UL,
00251
00252
00253     /** netMasterNetLibOpenOptBypassNetGuard:
00254      *
00255      *  If set, bypass the NetGuard feature -- for use by IOTA
00256      *  service only!!!
00257      *
00258      *  IMPORTANT: *not* available on systems before Palm OS 5.0
00259      */
00260     //
00261     // DOLATER \todo -- should this be in "protected" incs?
00262     netMasterNetLibOpenOptBypassNetGuard        = 0x00000002UL,
00263
00264     /** If this flag is set by the client, then the connection will
00265      *  be attempted only with the requested NetPref record, and the
00266      *  fallback network profile, if any, will be ignored.
00267      *
00268      *  IMPORTANT: *not* available on systems before Palm OS 5.0
00269      */
00270     netMasterNetLibOpenOptPrimaryProfileOnly    = 0x00000004UL
00271
00272   };
00273
00274
00275 /** Login priority values that may be passed to NetMasterSCNetAttach */
00276 typedef UInt32    NetMasterLoginPriorityEnum;
00277 enum
00278   {
00279     /** The vast majority of background and foreground applications SHOULD
00280      *  ALWAYS use the Default login priority.  This allows Data Session
00281      *  Control system software to optimize end-user experience
00282      *  on the device by following specific data session
00283      *  management rules requested by network operators.
00284      */
00285     netMasterLoginPriorityDefault           = 0,
00286
00287     /** The Low login priority is the *least* disruptive to existing data
00288      *  sessions that were established with a different network service
00289      *  profile than the one that you're requesting.
00290      */
00291     netMasterLoginPriorityLow               = 1,
00292
00293     /** The High login priority is the *most* disruptive to existing data
00294      *  sessions that were established with a different network service
00295      *  profile than the one that you're requesting.  This will typically
00296      *  cause even active foreground data sessions to be torn down. This
00297      *  priority is reserved for *internal use only*, and should be avoided
00298      *  by other developers as its usage will typically break the data
00299      *  session management model of the device, resulting in poor end-user
00300      *  experience.
00301      */
00302     netMasterLoginPriorityHigh              = 2
00303
00304   };
00305
00306
00307
00308 /** Default value to pass as the anchorTimeoutSec parameter to NetMasterSCNetAttach */
00309 #define netMasterAnchorTimeoutDefault     (-1)
00310
00311
00312 // ----------------------------------------------------------------
00313 /** Data Context type used by NetMasterSCNetAttach,
00314  *  NetMasterSCNetDetach and friends.
00315  */
00316 // ----------------------------------------------------------------
00317 typedef UInt32    NetMasterDataContextIDType;
00318
00319 // ----------------------------------------------------------------
00320 /** Data Session type used by NetMasterSCSessionIDGetFromContext
00321  *  and friends.
00322  */
00323 // ----------------------------------------------------------------
00324 typedef UInt32    NetMasterDataSessionIDType;
00325
00326
00327 #endif // _NET_MASTER_LIB_TYPES_H_
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:54 2008 for Palm API Guide


Header Files » Incs » common » libraries » netpref

NetPrefLibErrors.h

Go to the documentation of this file.
00001 /******************************************************************************
00002  * Copyright (c) 2004 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  *****************************************************************************/
00005 /**
00006  * @ingroup NETPREF
00007  */
00008
00009 /**
00010  * @file    NetPrefLibErrors.h
00011  * @version 1.0
00012  * @date    12/12/2001
00013  *
00014  * @brief   This is the error declarations file for the NetPref Library.
00015  *
00016  */
00017
00018 /*
00019  * @author  vmk
00020  *
00021  * <hr>
00022  */
00023
00024
00025 #ifndef _NET_PREF_LIB_ERRORS_H_
00026 #define _NET_PREF_LIB_ERRORS_H_
00027
00028 #include <Common/HsCommon.h>      // <HsErrorClasses.h>
00029
00030 //#include "OSServices.h"     // for osSvcErrClassApp
00031
00032
00033 /** hsNetMasterErrorClass is defined in HsErrorClasses.h */
00034 #define netPrefErrClass   (hsNetPrefLibErrorClass)   // 0x7200
00035
00036
00037 #define netPrefErrMemory            (netPrefErrClass + 0x01)  /**< runtime memory error */
00038 #define netPrefErrStorage           (netPrefErrClass + 0x02)  /**< storage memory error */
00039 #define netPrefErrBadArg            (netPrefErrClass + 0x03)  /**< invalid argument, unknown ID */
00040 #define netPrefErrRecNotSaved       (netPrefErrClass + 0x04)  /**< cannot perform the requested
00041                                                                 *  operation on the new record
00042                                                                 *  until it is saved.
00043                                                                 */
00044 #define netPrefErrRecGone           (netPrefErrClass + 0x05)  /**< record could not be found */
00045 #define netPrefErrCCSMIncomplete    (netPrefErrClass + 0x06)  /**< missing or incomplete CCSM table */
00046 #define netPrefErrCSDNotAllowed     (netPrefErrClass + 0x07)  /**< CSD is not allowed */
00047 #define netPrefErrNoCCSMSettings    (netPrefErrClass + 0x08)  /**< settings were not found in the CCSM Carrier Settings DB */
00048 #define netPrefErrNVSync            (netPrefErrClass + 0x09)  /**< Error synchronizing settings with
00049                                                                 *  the radio's NV storage
00050                                                                 */
00051 #define netPrefErrNVRead            (netPrefErrClass + 0x0A)  /**< Error reading setting from
00052                                                                 *  the radio's NV storage
00053                                                                 */
00054 #define netPrefErrCCSMNoCarrierMatch (netPrefErrClass + 0x0B) /**< No matching entry in the CCSM Carrier List DB */
00055 #define netPrefErrRadioIsOff        (netPrefErrClass + 0x0C)  /**< Operation failed because the
00056                                                                 *  radio (wireless mode) is off.
00057                                                                 */
00058 #define netPrefErrPhoneLibOpenFailed  (netPrefErrClass + 0x0D)/**< Error while opening PhoneLib */
00059
00060 #define netPrefErrNVWrite           (netPrefErrClass + 0x0E)  /**< Error writing setting to
00061                                                                 *  the radio's NV storage
00062                                                                 */
00063 #define netPrefErrReadOnlyField     (netPrefErrClass + 0x0F)  /**< Attempting to modify the data of
00064                                                                 *  a read-only field.
00065                                                                 */
00066 #define netPrefErrFieldNotInSet     (netPrefErrClass + 0x10)  /**< Attempting to modify a field that
00067                                                                 *  is not in the record's set.
00068                                                                 */
00069 #define netPrefErrNVWritePDPInUse   (netPrefErrClass + 0x11)  /**< Couldn't save data to PDP in radio's
00070                                                                 *  NV because the PDP is in use (logged
00071                                                                 *  in most likely).
00072                                                                 */
00073
00074 #endif // _NET_PREF_LIB_ERRORS_H_
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:54 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » netpref

NetPrefLibFieldInfoTable.h

Go to the documentation of this file.
00001 /******************************************************************************
00002  * Copyright (c) 2004 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  *****************************************************************************/
00005 /**
00006  * @defgroup NETPREF NetPref Library
00007  *
00008  * @{
00009  * @}
00010  */
00011
00012 /**
00013  * @file    NetPrefLibFieldInfoTable.h
00014  * @version 1.0
00015  * @date    01/11/2002
00016  *
00017  * @brief This header file contains record field information for
00018  *        NetPref settings.
00019  *
00020  */
00021
00022 /*
00023  * @author   Vitaly Kruglikov
00024  * <hr>
00025  */
00026
00027
00028 #ifndef __NETPREFLIBFIELDINFOTABLE_H__
00029 #define __NETPREFLIBFIELDINFOTABLE_H__
00030
00031
00032 /** NOTE: all macros must be defined by the including module; for convenience,
00033  *  this file includes all the undefining statements at the end of the table.
00034  *  The usage model for this table requires that the includer first define each
00035  *  of the required macros and then include this file for the appropriate effect.
00036  */
00037
00038 // Required macros:
00039
00040 // #define NetPrefRecFieldInfoPreamble()
00041
00042 // #define NetPrefRecFieldInfoFIRST(fieldID, idValue)
00043
00044 // #define NetPrefRecFieldInfoGrpStart(fieldID, idValue)
00045
00046 // #define NetPrefRecFieldInfoGrpEnd(fieldID)
00047
00048 // #define NetPrefRecFieldInfoExtended(fieldID, idValue, type, maxSize, flags,
00049 //                                     tagText, tagSize)
00050
00051 // #define NetPrefRecFieldInfoLegacy(fieldID, idValue, type, maxSize, flags,
00052 //                                     tagText, tagSize)
00053
00054 // if maxSize = 0, then size boundaries are determined entirely by field type
00055
00056 // #define NetPrefRecFieldInfoLAST(fieldID)
00057
00058
00059
00060
00061 /** IMPORTANT***
00062  *  All field ID values within a field group must be contiguous.
00063  *  The field id is included at the beginning of each tag, and separated
00064  *  by the ':' character from the rest of each tag.
00065  *
00066  *  For most field values, if not set, the appropriate defaults will apply.
00067  *  The exceptions are account specific settings, such as username, password,
00068  *  phone number (for dial-up profiles), etc.
00069  */
00070
00071 /** PREAMBLE */
00072   NetPrefRecFieldInfoPreamble()
00073
00074 /** reserve 0 */
00075   NetPrefRecFieldInfoFIRST(     netPrefRecFieldUnknown,           0)
00076
00077
00078 /** ========================================================================
00079  *  Range for extended fields:
00080  *  ========================================================================
00081  */
00082
00083 /** start of Handspring-extended fields */
00084   NetPrefRecFieldInfoGrpStart(  netPrefRecFieldExtendedSTART,     1)
00085
00086 /** UInt32; reserved for internal Handspring use only */
00087   NetPrefRecFieldInfoExtended(  netPrefRecFieldUInt32Reserved1,   2, \
00088               netPrefFieldTypeUInt32, 0, 0, [2:i32rsvd1], 12)
00089
00090 /** UInt16, Service Medium alias -- NetPrefSvcMediumEnum;
00091  *  this overrides the connection profile setting (netPrefRecFieldConnection)
00092  *  with a dynamically determined connection profile
00093  */
00094
00095   NetPrefRecFieldInfoExtended(  netPrefRecFieldSvcMediumAlias,    3, \
00096               netPrefFieldTypeUInt16, 0, 0, <3:medium>, 10)
00097
00098 /** UInt16, NetPrefSvcBindingEnum; not needed in most cases.
00099  *  Handspring internal use only!
00100  */
00101   NetPrefRecFieldInfoExtended(  netPrefRecFieldBinding,           4, \
00102               netPrefFieldTypeUInt16, 0, 0, <4:bind>, 8)
00103
00104 /** UInt16, Binding index; 0-based; for example: CCSM Home1/Roam1 binding
00105  *  index should be set to 0; for Home2/Roam2 to 1, etc.  Used when
00106  *  netPrefRecFieldBinding is set to netPrefSvcBindingCCSM
00107  *  Handspring internal use only!
00108  */
00109   NetPrefRecFieldInfoExtended(  netPrefRecFieldBindingIndex,      5, \
00110               netPrefFieldTypeUInt16, 0, 0, <5:bindidx>, 11)
00111
00112 /** UInt32,  NetPrefSvcGatewayType - Internet, WAP, etc. (1 or more
00113  *  netPrefSvcGateway... constants bitwise-or'ed together; if the field is
00114  *  absent, Internet is implied.
00115  */
00116   NetPrefRecFieldInfoExtended(  netPrefRecFieldSvcGatewayType,    6, \
00117               netPrefFieldTypeUInt32,  0, 0, <6:gtwytyp>, 11)
00118
00119 /** UInt32, unique record ID of fallback service (must be one of the
00120  *  records in the Network Preferences database)
00121  */
00122   NetPrefRecFieldInfoExtended(  netPrefRecFieldFallbackID,        7, \
00123               netPrefFieldTypeUInt32, 0, 0, <7:fback>, 9)
00124
00125
00126 /** char*, APN name for GPRS services */
00127   NetPrefRecFieldInfoExtended(  netPrefRecFieldAPN,               8, \
00128               netPrefFieldTypeStr,    0, 0, <8:apn>, 7)
00129
00130 /** char*, Modem Init override string (for CCSM, etc.).  For
00131  *  CSD, ISND, QNC, and plain dial-up services only -- if specified,
00132  *  it will override the modem init string that may have been specified
00133  *  in the Connection profile in Connection Panel.
00134  */
00135   NetPrefRecFieldInfoExtended(  netPrefRecFieldMdmInitStr,        9, \
00136               netPrefFieldTypeStr,    0, 0, <9:mdmins>, 10)
00137
00138 /** UInt8; Is Mobile-IP; non-zero=true (0x01), zero=false (CDMA/1xRTT only) */
00139   NetPrefRecFieldInfoExtended(  netPrefRecFieldIsMobileIP,        10, \
00140               netPrefFieldTypeUInt8,  0, 0, <10:mip>, 8)
00141
00142 /** UInt32, Primary HA Address, if Mobile-IP (CDMA/1xRTT) */
00143   NetPrefRecFieldInfoExtended(  netPrefRecFieldHAAddrPrimary,     11, \
00144               netPrefFieldTypeUInt32, 0, 0, <11:ha1>, 8)
00145
00146 /** UInt32, Secondary HA Address, if Mobile-IP (CDMA/1xRTT) */
00147   NetPrefRecFieldInfoExtended(  netPrefRecFieldHAAddrSecondary,   12, \
00148               netPrefFieldTypeUInt32, 0, 0, <12:ha2>, 8)
00149
00150 /** Binary, HA Password, if Mobile-IP  (CDMA/1xRTT) */
00151   NetPrefRecFieldInfoExtended(  netPrefRecFieldMnHaSS,            13, \
00152               netPrefFieldTypeBin,    0, 0, <13:hapsw>, 10)
00153
00154 /** UInt16, NetPref1xRTTTunnelingEnum; Tunneling, if Mobile-IP (CDMA/1xRTT) */
00155   NetPrefRecFieldInfoExtended(  netPrefRecField1xRTTTunneling,    14, \
00156               netPrefFieldTypeUInt16, 0, 0, <14:1xtnl>, 10)
00157
00158 /** UInt32, SPI for MN-HA authentication, if Mobile-IP (CDMA/1xRTT) */
00159   NetPrefRecFieldInfoExtended(  netPrefRecFieldMnHaSpi,           15, \
00160               netPrefFieldTypeUInt32, 0, 0, <15:haspi>, 10)
00161
00162 /** UInt32, SPI for MN-AAA authentication, if Mobile-IP (CDMA/1xRTT) */
00163   NetPrefRecFieldInfoExtended(  netPrefRecFieldMnAaaSpi,          16, \
00164               netPrefFieldTypeUInt32, 0, 0, <16:aaasp>, 10)
00165
00166 /** char*, Override Dial String for special network connections (CCSM, 1xRTT,
00167  *  etc.).  If set, overrides the default 1xRTT dial string for CDMA/1xRTT
00168  *  services, and netPrefRecFieldPhoneNumber (and related fields) for CSD,
00169  *  ISDN, QNC, and other dial-up services.
00170  */
00171   NetPrefRecFieldInfoExtended(  netPrefRecFieldDialStr,           17, \
00172               netPrefFieldTypeStr,    0, 0, <17:dials>, 10)
00173
00174 /** UInt32, NetPrefRecProtectionType -- record protection options */
00175   NetPrefRecFieldInfoExtended(  netPrefRecFieldRecProtection,     18, \
00176               netPrefFieldTypeUInt32, 0, 0, <18:protect>, 12)
00177
00178 /** UInt32, -- permanent PDP index in radio's NV table (for CDMA/1xRTT
00179  *  services with netPrefSvcBindingIOTA binding only -- internal use only!)
00180  */
00181   NetPrefRecFieldInfoExtended(  netPrefRecFieldPDPIndex,          19, \
00182               netPrefFieldTypeUInt32, 0, 0, <19:pdpidx>, 11)
00183
00184 /** void*, -- Unique ID/Change number of the PDP slot in radio's NV table.
00185  *  Presently used for CDMA/1xRTT IOTA-bound profiles. For internal use only!
00186  */
00187   NetPrefRecFieldInfoExtended(  netPrefRecFieldPDPChangeID,       20, \
00188               netPrefFieldTypeBin,    0, 0, <20:pdpchg>, 11)
00189
00190 /** UInt32,  Service Creator ID [OPTIONAL] -- an application that creates a
00191  *  new service may set this field to a unique Creator ID value (the unique
00192  *  Creator ID MUST be registered with a CreatorID registration authority --
00193  *  for Palm OS, this is done through Palm's developer support WEB pages).
00194  *  Applications that set this field, may also save creator-specific data
00195  *  inside the netPrefRecFieldCreatorData field
00196  */
00197   NetPrefRecFieldInfoExtended(  netPrefRecFieldCreatorID,         21, \
00198               netPrefFieldTypeUInt32,  0, 0, <21:crid>, 9)
00199
00200 /** void*, Creator-specific binary data field; applications that set
00201  *  the netPrefRecFieldCreatorID field may also save application-specific
00202  *  data inside this field.  see also netPrefRecFieldCreatorID.
00203  */
00204   NetPrefRecFieldInfoExtended(  netPrefRecFieldCreatorData,       22, \
00205               netPrefFieldTypeBin,    0, 0, <22:crdata>, 11)
00206
00207 /** NetPrefGPRSQOSType -- GPRS Quality of Service parameters */
00208   NetPrefRecFieldInfoExtended(  netPrefRecFieldGPRSQOS,           23, \
00209               netPrefFieldTypeBin,    0, 0, <23:gprsqos>, 12)
00210
00211 /** NetPref1xRTTQOSType -- 1xRTT Quality of Service parameters.
00212  *  UNDEFINED/RESERVED BY HANDSPRING
00213  */
00214   NetPrefRecFieldInfoExtended(  netPrefRecField1xRTTQOS,          24, \
00215               netPrefFieldTypeBin,    0, 0, <24:1xrttqos>, 13)
00216
00217 /** void*; reserved for internal Handspring use only */
00218   NetPrefRecFieldInfoExtended(  netPrefRecFieldBinReserved1,      25, \
00219               netPrefFieldTypeBin,    0, 0, <25:binrsvd1>, 13)
00220
00221 /** char*, 1xRTT NAI field (CDMA/1xRTT) */
00222   NetPrefRecFieldInfoExtended(  netPrefRecFieldNaiStr,            26, \
00223               netPrefFieldTypeStr,    0, 0, <26:nai>, 8)
00224
00225 /** Binary, 1xRTT MN-AAA Shared Secret (NAI Password) (CDMA/1xRTT)
00226  *
00227  *  IMPORTANT:
00228  *
00229  *  ***The NAI Password may be text or binary.  If it is binary, it may
00230  *  contain zeros anywhere in the password, so you cannot use string functions
00231  *  (such as strlen, strcpy, etc.) on this field.
00232  *
00233  *  ***If an ascii string password is being stored, it MUST be stored *without*
00234  *  the terminating zero-byte!!!
00235  *
00236  *  The NAI Password may be binary or ascii, depending on the method
00237  *  the operator used to set its value (IOTA/MD Digest/etc.), or whether it was
00238  *  entered by the user (user will enter in ascii, most likely).
00239  */
00240   NetPrefRecFieldInfoExtended(  netPrefRecFieldMnAaaSs,           27, \
00241               netPrefFieldTypeBin,    0, 0, <27:mnaaass>, 12)
00242
00243 /** UInt8, -- initial number of VJ Compression slots if VJ compression
00244  *  is enabled; used to set
00245  *  NetLib's netIFSettingVJCompSlots setting (see also
00246  *  netPrefRecFieldVJCompEnable).
00247  */
00248   NetPrefRecFieldInfoExtended(  netPrefRecFieldVJCompSlots,       28, \
00249               netPrefFieldTypeUInt8, 0, 0, <28:vjslots>, 12)
00250
00251 /** NetPrefFallbackInfoType -- Fallback Info: algorithm and status.
00252  *  NOTE: this field MUST be defined as READ/WRITE because the algorithm
00253  *  will need to maintain the fallback status data in the same field.
00254  */
00255   NetPrefRecFieldInfoExtended(  netPrefRecFieldFallbackInfo,      29, \
00256               netPrefFieldTypeBin,    0, 0, <29:fbkinfo>, 12)
00257
00258
00259 /** <chg 2006-01-18 kos> Feature for Camino|Microwave: Per-APN proxy settings (9.1.2)
00260  *  deprecates the old "browser settings" normally stored in the carrier record
00261  */
00262     NetPrefRecFieldInfoExtended( netPrefRecFieldProxyPrimaryHttpServer,  30,  \
00263                 netPrefFieldTypeStr,  0, 0,  <30:HttpSv>, 11 )
00264
00265     NetPrefRecFieldInfoExtended( netPrefRecFieldProxyPrimaryHttpPort,  31,  \
00266                 netPrefFieldTypeUInt32,  0, 0,  <31:HttpPt>, 11 )
00267
00268     NetPrefRecFieldInfoExtended( netPrefRecFieldProxyPrimaryHttpsServer,  32,  \
00269                 netPrefFieldTypeStr,  0, 0,  <32:HttpsSv>, 12 )
00270
00271     NetPrefRecFieldInfoExtended( netPrefRecFieldProxyPrimaryHttpsPort,  33,  \
00272                 netPrefFieldTypeUInt32,  0, 0,  <33:HttpsPt>, 12 )
00273
00274     NetPrefRecFieldInfoExtended( netPrefRecFieldProxySecondaryHttpServer,  34,  \
00275                 netPrefFieldTypeStr,  0, 0,  <34:HttpS2>, 11 )
00276
00277     NetPrefRecFieldInfoExtended( netPrefRecFieldProxySecondaryHttpPort,  35,  \
00278                 netPrefFieldTypeUInt32,  0, 0,  <35:HttpP2>, 11 )
00279
00280     NetPrefRecFieldInfoExtended( netPrefRecFieldProxySecondaryHttpsServer,  36,  \
00281                 netPrefFieldTypeStr,  0, 0,  <36:HttpsS2>, 12 )
00282
00283     NetPrefRecFieldInfoExtended( netPrefRecFieldProxySecondaryHttpsPort,  37,  \
00284                 netPrefFieldTypeUInt32,  0, 0,  <37:HttpsP2>, 12 )
00285
00286     NetPrefRecFieldInfoExtended( netPrefRecFieldProxyExcludedHostsString,  38,  \
00287                 netPrefFieldTypeStr,  0, 0,  <38:ExclHst>, 12 )
00288
00289     NetPrefRecFieldInfoExtended( netPrefRecFieldProxyUsernameNew,  39, \
00290                 netPrefFieldTypeStr,  0, 0,  <39:User2>, 10 )
00291
00292     NetPrefRecFieldInfoExtended( netPrefRecFieldProxyPasswordNew,  40,  \
00293                 netPrefFieldTypeStr,  0, 0,  <40:Pass2>, 10 )
00294
00295     NetPrefRecFieldInfoExtended( netPrefRecFieldProxyReqCustomUaProf,  41,  \
00296                 netPrefFieldTypeUInt8,  0, 0,  <41:CustUa>, 11 )
00297
00298     NetPrefRecFieldInfoExtended( netPrefRecFieldProxyDefaultHomePage,  42,  \
00299                 netPrefFieldTypeStr,  0, 0,  <42:HomePg>, 11 )
00300
00301     NetPrefRecFieldInfoExtended( netPrefRecFieldProxyUaProfHostedOnOwnServers,  43,  \
00302                 netPrefFieldTypeUInt8,  0, 0,  <43:UaOwnSv>, 12 )
00303
00304     NetPrefRecFieldInfoExtended( netPrefRecFieldProxyUrlOfUaProfFile,  44,  \
00305                 netPrefFieldTypeStr,  0, 0,  <44:UrlUa>, 10 )
00306
00307     NetPrefRecFieldInfoExtended( netPrefRecFieldProxyEncryptedMsisdn,  45,  \
00308                 netPrefFieldTypeUInt8,  0, 0,  <45:EncrMSI>, 12 )
00309
00310     NetPrefRecFieldInfoExtended( netPrefRecFieldProxyMsisdnFormat,  46,  \
00311                 netPrefFieldTypeStr,  0, 0,  <46:MSIfmt>, 11 )
00312
00313     NetPrefRecFieldInfoExtended( netPrefRecFieldProxyMsisdnStaticString,  47,  \
00314                 netPrefFieldTypeStr,  0, 0,  <47:MSIStr>, 11 )
00315
00316     NetPrefRecFieldInfoExtended( netPrefRecFieldProxyReqStaticHeaderString,  48,  \
00317                 netPrefFieldTypeUInt8,  0, 0,  <48:ReqStat>, 12 )
00318
00319     NetPrefRecFieldInfoExtended( netPrefRecFieldProxyStaticHeaderString,  49,  \
00320                 netPrefFieldTypeStr,  0, 0,  <49:StatHStr>, 13 )
00321
00322   // ivoj:
00323   // char*, URL filtering
00324   NetPrefRecFieldInfoExtended(  netPrefRecFieldDomain01, 50, \
00325               netPrefFieldTypeStr,    0, 0, <50:domain01>, 13)
00326
00327   // ivoj:
00328   // char*, URL filtering
00329   NetPrefRecFieldInfoExtended(  netPrefRecFieldDomain02, 51, \
00330               netPrefFieldTypeStr,    0, 0, <51:domain02>, 13)
00331
00332   // ivoj:
00333   // char*, URL filtering
00334   NetPrefRecFieldInfoExtended(  netPrefRecFieldDomain03, 52, \
00335               netPrefFieldTypeStr,    0, 0, <52:domain03>, 13)
00336
00337   // ivoj:
00338   // char*, URL filtering
00339   NetPrefRecFieldInfoExtended(  netPrefRecFieldDomain04, 53, \
00340               netPrefFieldTypeStr,    0, 0, <53:domain04>, 13)
00341
00342   // ivoj:
00343   // char*, URL filtering
00344   NetPrefRecFieldInfoExtended(  netPrefRecFieldDomain05, 54, \
00345               netPrefFieldTypeStr,    0, 0, <54:domain05>, 13)
00346
00347   // ivoj:
00348   // char*, URL filtering
00349   NetPrefRecFieldInfoExtended(  netPrefRecFieldDomain06, 55, \
00350               netPrefFieldTypeStr,    0, 0, <55:domain06>, 13)
00351
00352   // ivoj:
00353   // char*, URL filtering
00354   NetPrefRecFieldInfoExtended(  netPrefRecFieldDomain07, 56, \
00355               netPrefFieldTypeStr,    0, 0, <56:domain07>, 13)
00356
00357   // ivoj:
00358   // char*, URL filtering
00359   NetPrefRecFieldInfoExtended(  netPrefRecFieldDomain08, 57, \
00360               netPrefFieldTypeStr,    0, 0, <57:domain08>, 13)
00361
00362   // ivoj:
00363   // char*, URL filtering
00364   NetPrefRecFieldInfoExtended(  netPrefRecFieldDomain09, 58, \
00365               netPrefFieldTypeStr,    0, 0, <58:domain09>, 13)
00366
00367   // ivoj:
00368   // char*, URL filtering
00369   NetPrefRecFieldInfoExtended(  netPrefRecFieldDomain10, 59, \
00370               netPrefFieldTypeStr,    0, 0, <59:domain10>, 13)
00371
00372
00373 /** end of Handspring-extended fields (for internal use only -- # of extended
00374  *  fields will likely grow in the future)
00375  */
00376   NetPrefRecFieldInfoGrpEnd(    netPrefRecFieldExtendedEND)
00377
00378
00379 /** ========================================================================
00380  *  Range for legacy fields:
00381  *  ========================================================================
00382  */
00383
00384 /** START OF LEGACY FIELDS */
00385   NetPrefRecFieldInfoGrpStart(  netPrefRecFieldLegacySTART,       1000)
00386
00387 /** UInt32; 'slip', 'ppp-', 'loop' (netIFCreatorPPP, etc.), or OEM NPPI
00388  *  creator if netPrefRecFieldSvcMediumAlias field is netPrefSvcMediumOEM.
00389  */
00390   NetPrefRecFieldInfoLegacy(    netPrefRecFieldInterfaceID,       1001, \
00391               netPrefFieldTypeUInt32, 0, 0, <1001:ifid>, 11)
00392
00393 /** UInt8; non-zero=true, zero=false */
00394   NetPrefRecFieldInfoLegacy(    netPrefRecFieldIPAddrIsDynamic,   1002, \
00395               netPrefFieldTypeUInt8,  0, 0, <1002:dynip>, 12)
00396
00397 /** UInt32; IP address value, if not dynamic */
00398   NetPrefRecFieldInfoLegacy(    netPrefRecFieldIPAddr,            1003, \
00399               netPrefFieldTypeUInt32, 0, 0, <1003:ipaddr>, 13)
00400
00401 /** UInt8; non-zero=true (0x01), zero=false */
00402   NetPrefRecFieldInfoLegacy(    netPrefRecFieldDNSAddrIsDynamic,  1004, \
00403               netPrefFieldTypeUInt8,  0, 0, <1004:dyndns>, 13)
00404
00405 /** UInt32; primary DNS address if not dynamic */
00406   NetPrefRecFieldInfoLegacy(    netPrefRecFieldDNSAddrPrimary,    1005, \
00407               netPrefFieldTypeUInt32, 0, 0, <1005:pridns>, 13)
00408
00409 /** UInt32; secondary DNS address if not dynamic */
00410   NetPrefRecFieldInfoLegacy(    netPrefRecFieldDNSAddrSecondary,  1006, \
00411               netPrefFieldTypeUInt32, 0, 0, <1006:secdns>, 13)
00412
00413 /** UInt32; expressed in milliseconds; see NetPrefNetCloseWaitEnum for special
00414  *  values; used to set NetLib's netSettingCloseWaitTime setting.
00415  *  IMPORTANT: Beginning with Palm OS 5.0, netPrefRecFieldInactivityTimer
00416  *  must be used to configure the idle timeout of the TCP/IP stack. The
00417  *  "CloseWait" setting is used to control NetLib's CloseWait behavior
00418  *  only.
00419  */
00420   NetPrefRecFieldInfoLegacy(    netPrefRecFieldCloseWaitTime,     1007, \
00421               netPrefFieldTypeUInt32, 0, 0, <1007:cwtm>, 11)
00422
00423 /** UInt16; expressed in seconds; see NetPrefNetIdleTimeoutEnum for
00424  *  special values; used to set NetLib interface's
00425  *  netIFSettingInactivityTimeout setting (also known as "idle timeout").
00426  *  IMPORTANT: This setting is enforced beginning with Palm OS 5.0 and
00427  *  must be used to configure the idle timeout of the TCP/IP stack.
00428  */
00429   NetPrefRecFieldInfoLegacy(    netPrefRecFieldInactivityTimer,   1008, \
00430               netPrefFieldTypeUInt16, 0, 0, <1008:inactm>, 13)
00431
00432 /** UInt16; used to set NetLib's
00433  *  netIFSettingEstablishmentTimeout setting.
00434  */
00435   NetPrefRecFieldInfoLegacy(    netPrefRecFieldEstablishmentTimeout,1009, \
00436               netPrefFieldTypeUInt16, 0, 0, <1009:estbtm>, 13)
00437
00438 /** UInt8; non-zero=true, zero=false; used to set NetLib's
00439  *  netIFSettingVJCompEnable setting.  See also netPrefRecFieldVJCompSlots.
00440  */
00441   NetPrefRecFieldInfoLegacy(    netPrefRecFieldVJCompEnable,      1010, \
00442               netPrefFieldTypeUInt8,  0, 0, <1010:vjcmpr>, 13)
00443
00444 /** UInt8; not in interface -- NOT USED. */
00445   NetPrefRecFieldInfoLegacy(    netPrefRecFieldUseModem,          1011, \
00446               netPrefFieldTypeUInt8,  0, 0, <1011:usemdm>, 13)
00447
00448 /** char*; service name */
00449   NetPrefRecFieldInfoLegacy(    netPrefRecFieldServiceName,       1012, \
00450               netPrefFieldTypeStr,    0, 0, <1012:svcnam>, 13)
00451
00452 /** char*; username
00453  *  (NOTE: the NAI for CDMA One-X (Mobile-IP and
00454  *  Simple-IP) services is stored in another field -- netPrefRecFieldNaiStr.)
00455  */
00456   NetPrefRecFieldInfoLegacy(    netPrefRecFieldUsername,          1013, \
00457               netPrefFieldTypeStr,    0, 0, <1013:usrnam>, 13)
00458
00459 /** char*; password */
00460   NetPrefRecFieldInfoLegacy(    netPrefRecFieldPassword,          1014, \
00461               netPrefFieldTypeStr,    0, 0, <1014:usrpsw>, 13)
00462
00463 /** char*; domain name; used to set NetLib's netSettingDomainName setting;
00464  *  might not be used by NetLib.
00465  */
00466   NetPrefRecFieldInfoLegacy(    netPrefRecFieldDomainName,        1015, \
00467               netPrefFieldTypeStr,    0, 0, <1015:domain>, 13)
00468
00469 /** char*; callback username, password; used to set NetLib's
00470  *  netSettingHostTbl setting; might not be used by NetLib.
00471  */
00472   NetPrefRecFieldInfoLegacy(    netPrefRecFieldHostTable,         1016, \
00473               netPrefFieldTypeStr,    0, 0, <1016:hosttab>, 14)
00474
00475 /** char*; used to set NetLib's netIFSettingDialbackUsername -- yes,
00476  *  netIFSettingDialbackUsername -- ask Palm why :-); might not be
00477  *  used by NetLib.
00478  */
00479   NetPrefRecFieldInfoLegacy(    netPrefRecFieldSMTPHost,          1017, \
00480               netPrefFieldTypeStr,    0, 0, <1017:smtphst>, 14)
00481
00482 /** char*; presently not used. */
00483   NetPrefRecFieldInfoLegacy(    netPrefRecFieldPOPHost,           1018, \
00484               netPrefFieldTypeStr,    0, 0, <1018:pophst>, 13)
00485
00486 /** char*; presently not used.
00487  */
00488   NetPrefRecFieldInfoLegacy(    netPrefRecFieldNewsServer,        1019, \
00489               netPrefFieldTypeStr,    0, 0, <1019:newssrv>, 14)
00490
00491 /** char*; loginScript; scripts contain null terminated strings and end with
00492  *  a double null; ***an empty script is represented with a single null (not
00493  *  double null); used to set NetLib's netIFSettingLoginScript setting for
00494  *  dial-up type of profiles.  Refer to Palm for login-script format.
00495  */
00496   NetPrefRecFieldInfoLegacy(    netPrefRecFieldLoginScript,       1020, \
00497               netPrefFieldTypeZStrList,   0, 0, <1020:script>, 13)
00498
00499 /** char*; connection name; obtained from Palm OS Connection Manager
00500  *  via CncGetProfileList or CncGetProfileInfo -- but avoid the
00501  *  "-Current-" setting, since the New Network panel doesn't use it any
00502  *  longer.  netPrefRecFieldSvcMediumAlias overrides this setting.
00503  */
00504   NetPrefRecFieldInfoLegacy(    netPrefRecFieldConnection,        1021, \
00505               netPrefFieldTypeStr,    0, 0, <1021:connnam>, 14)
00506
00507 /** UInt8; non-zero=true, zero=false; corresponds to the dial prefix setting
00508  *  in the Phone Setup dialog.
00509  */
00510   NetPrefRecFieldInfoLegacy(    netPrefRecFieldDialPrefixEnable,  1022, \
00511               netPrefFieldTypeUInt8,  0, 0, <1022:enprefx>, 14)
00512
00513 /** UInt8; non-zero=true, zero=false; corresponds to the Call Waiting
00514  *  setting in the Phone Setup dialog.
00515  */
00516   NetPrefRecFieldInfoLegacy(    netPrefRecFieldCallWaitingEnable, 1023, \
00517               netPrefFieldTypeUInt8,  0, 0, <1023:encalwt>, 14)
00518
00519 /** UInt8; non-zero=true, zero=false; corresponds to the Calling Card
00520  *  setting in the Phone Setup dialog.
00521  */
00522   NetPrefRecFieldInfoLegacy(    netPrefRecFieldCallingCardEnable, 1024, \
00523               netPrefFieldTypeUInt8,  0, 0, <1024:encalcd>, 14)
00524
00525 /** UInt8; non-zero=true, zero=false. Not used. */
00526   NetPrefRecFieldInfoLegacy(    netPrefRecFieldPulseDialEnable,   1025, \
00527               netPrefFieldTypeUInt8,  0, 0, <1025:enpulse>, 14)
00528
00529 /** char*; phone number; corresponds to the Phone # field in the Phone Setup dialog. */
00530   NetPrefRecFieldInfoLegacy(    netPrefRecFieldPhoneNumber,       1026, \
00531               netPrefFieldTypeStr,    0, 0, <1026:phone>, 12)
00532
00533 /** char*; corresponds to the Dial Prefix setting in the Phone Setup dialog. */
00534   NetPrefRecFieldInfoLegacy(    netPrefRecFieldDialPrefix,        1027, \
00535               netPrefFieldTypeStr,    0, 0, <1027:dlprefx>, 14)
00536
00537 /** char*; corresponds to the Call Waiting setting in the Phone Setup dialog. */
00538   NetPrefRecFieldInfoLegacy(    netPrefRecFieldCallWaitingString, 1028, \
00539               netPrefFieldTypeStr,    0, 0, <1028:calwt>, 12)
00540
00541 /** char*; corresponds to the Calling Card setting in the Phone Setup dialog. */
00542   NetPrefRecFieldInfoLegacy(    netPrefRecFieldCallingCardNumber, 1029, \
00543               netPrefFieldTypeStr,    0, 0, <1029:calcd>, 12)
00544
00545 /** END OF LEGACY FIELDS (for internal use only -- # of legacy
00546  *  fields will likely grow in the future)
00547  */
00548   NetPrefRecFieldInfoGrpEnd(    netPrefRecFieldLegacyEND)
00549
00550 /** ALWAYS KEEP THIS ENTRY AT THE END!!! */
00551   NetPrefRecFieldInfoLAST(      netPrefRecFieldLAST)
00552
00553
00554
00555 // We undefine all required macros here for convenience
00556 #undef NetPrefRecFieldInfoPreamble
00557
00558 #undef NetPrefRecFieldInfoFIRST
00559
00560 #undef NetPrefRecFieldInfoGrpStart
00561
00562 #undef NetPrefRecFieldInfoGrpEnd
00563
00564 #undef NetPrefRecFieldInfoExtended
00565
00566 #undef NetPrefRecFieldInfoLegacy
00567
00568 #undef NetPrefRecFieldInfoLAST
00569
00570 #endif
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:54 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » netpref

NetPrefLibrary.h

Go to the documentation of this file.
00001 /******************************************************************************
00002  * Copyright (c) 2004 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  *****************************************************************************/
00005 /**
00006  * @ingroup NETPREF
00007  */
00008
00009 /**
00010  * @file    NetPrefLibrary.h
00011  * @version 1.0
00012  * @date    06/24/2002
00013  *
00014  * @brief   This is the main header file for the NetPref Library.
00015  *
00016  * USAGE MODEL:
00017  * The model for using the NetPref library is that you "link" it
00018  * in when needed and "unlink" it as you're done -- i.e. we don't
00019  * leave it permanently installed as we do with some other libraries.
00020  * This helps us avoid some unpleasant HotSync issues (such as trying
00021  * to install over a protected database).  For examples of linking
00022  * and unlinking, grep for calls to  NetPrefUtilNetPrefLibLink and
00023  * NetPrefUtilNetPrefLibUnlink in NetworkPanel.c (Network panel src
00024  * folder).  NetPrefUtilNetPrefLibLink and NetPrefUtilNetPrefLibUnlink
00025  * are defined in Viewer\Libraries\NetPref\Public\Util\NetPrefUtils.c/h --
00026  * you may include the .c file with your code, or just copy and paste out
00027  * of those functions.
00028  *
00029  */
00030
00031 /*
00032  * @author   Vitaly Kruglikov
00033  *
00034  * History:
00035  *    12-Dec-2001   vmk   Created by Vitaly Kruglikov
00036  *    24-Jun-2002   vmk   Removed inclusion of private header file
00037  *                        OSServices.h.
00038  * <hr>
00039  */
00040
00041 #ifndef _NET_PREF_LIBRARY_H_
00042 #define _NET_PREF_LIBRARY_H_
00043
00044
00045 #include <NetPrefLibTarget.h>
00046 #include <NetPrefLibTraps.h>
00047 #include <NetPrefLibErrors.h>
00048 #include <NetPrefLibTypes.h>
00049
00050
00051
00052 #ifdef BUILDING_NET_PREF_LIB_DISPATCH_TABLE
00053   #define NETPREF_LIB_TRAP(trapNum)
00054 #else
00055   #define NETPREF_LIB_TRAP(trapNum) SYS_TRAP(trapNum)
00056 #endif
00057
00058 #ifdef __cplusplus
00059 extern "C" {
00060 #endif
00061
00062 /** Standard library open routine.
00063  *
00064  *  @param refnum:  IN:  Library reference number
00065  *  @retval Err     Library error code
00066  */
00067 extern Err NetPrefLibOpen (UInt16 refNum, struct NetPrefContextTypeTag** cxtPP)
00068     NETPREF_LIB_TRAP (sysLibTrapOpen);
00069
00070 /** Standard library close routine.
00071  *
00072  *  @param refnum:  IN:  Library reference number
00073  *  @retval Err     Library error code
00074  */
00075 extern Err NetPrefLibClose (UInt16 refNum, struct NetPrefContextTypeTag* cxtP)
00076     NETPREF_LIB_TRAP (sysLibTrapClose);
00077
00078 /** Standard library sleep routine.
00079  *
00080  *  @param refnum:  IN:  Library reference number
00081  *  @retval Err     Library error code
00082  */
00083 extern Err NetPrefLibSleep (UInt16 refNum)
00084     NETPREF_LIB_TRAP (sysLibTrapSleep);
00085
00086 /** Standard library wake routine.
00087  *
00088  *  @param refnum:  IN:  Library reference number
00089  *  @retval Err     Library error code
00090  */
00091 extern Err NetPrefLibWake (UInt16 refNum)
00092     NETPREF_LIB_TRAP (sysLibTrapWake);
00093
00094 /** Get Library API Version number.
00095  *
00096  *  @param refnum:          IN:  Library reference number
00097  *  @param majorVerP:       OUT: Major version number
00098  *  @param minorVerP:       OUT: Minor version number
00099  *  @param bugFixVerP:      OUT: Bug fix version number
00100  *  @retval Err             NetPref Library error code
00101  */
00102 extern Err
00103 NetPrefLibVersionGet (UInt16 refNum, UInt32* majorVerP, UInt32* minorVerP,
00104                       UInt32* bugFixVerP)
00105     NETPREF_LIB_TRAP (netPrefLibTrapVersionGet);
00106
00107
00108 /** Retrieve the count of records in the NetPref database */
00109 extern Err
00110 NetPrefRecCountGet (UInt16 refNum, struct NetPrefContextTypeTag* cxtP,
00111                     UInt16* countP)
00112     NETPREF_LIB_TRAP (netPrefLibTrapRecCountGet);
00113
00114
00115 /** Get record ID given the 0-based record index, which must be
00116  *  in range of 0..NetPrefRecCountGet()-1.
00117  *  The record's index may change following the NetPrefRecSave opeation.
00118  */
00119 extern Err
00120 NetPrefRecIDGetByIndex (UInt16 refNum, struct NetPrefContextTypeTag* cxtP,
00121                         UInt16 recIndex, UInt32* recIDP)
00122     NETPREF_LIB_TRAP (netPrefLibTrapRecIDGetByIndex);
00123
00124 /** Get record index given the unique record ID, which must be
00125  *   non-zero.
00126  *   The record's index may change following the NetPrefRecSave opeation.
00127  */
00128 extern Err
00129 NetPrefRecIndexGetByID (UInt16 refNum, struct NetPrefContextTypeTag* cxtP,
00130                         UInt32 recID, UInt16* recIndexP)
00131     NETPREF_LIB_TRAP (netPrefLibTrapRecIndexGetByID);
00132
00133
00134 /** Create a new record object.  Pass a non-zero dupRecID to duplicate
00135  *   an existing record.
00136  *   The caller is responsible for calling NetPrefRecRelease() to
00137  *   dispose of the temporary resources associated with the loaded record
00138  */
00139 extern Err
00140 NetPrefRecNew (UInt16 refNum, struct NetPrefContextTypeTag* cxtP,
00141                UInt32 dupRecID, struct NetPrefRecordTypeTag** recPP)
00142     NETPREF_LIB_TRAP (netPrefLibTrapRecNew);
00143
00144
00145 /** Load an existing record into memory; the caller is responsible for
00146  *   calling NetPrefRecRelease() to dispose of the temporary resources
00147  *   associated with the loaded record.
00148  */
00149 extern Err
00150 NetPrefRecLoad (UInt16 refNum, struct NetPrefContextTypeTag* cxtP,
00151                 UInt32 recID, struct NetPrefRecordTypeTag** recPP)
00152     NETPREF_LIB_TRAP (netPrefLibTrapRecLoad);
00153
00154
00155 /** Call this to check if there was an error from application of a binding
00156  *   (such as CCSM) to the record.
00157  */
00158 extern Err
00159 NetPrefRecBindingErrorGet (UInt16 refNum, struct NetPrefContextTypeTag* cxtP,
00160                            struct NetPrefRecordTypeTag* recP)
00161     NETPREF_LIB_TRAP (netPrefLibTrapRecBindingErrorGet);
00162
00163
00164 /** Dispose of the temporary resources associated with a record that
00165  *   was created or loaded via NetPrefRecNew or NetPrefRecLoad.
00166  *   It's the library client's (application's) responsibility to
00167  *   call this function to free up the memory.  Resets *recPP to NULL.
00168  */
00169 extern Err
00170 NetPrefRecRelease (UInt16 refNum, struct NetPrefContextTypeTag* cxtP,
00171                    struct NetPrefRecordTypeTag** recPP)
00172     NETPREF_LIB_TRAP (netPrefLibTrapRecRelease);
00173
00174
00175 /** Save the record to the database, moving it to a new sorted position
00176  *   if necessary.  For existing records, if any fields
00177  *   have been changed, you must call NetPrefRecSave in order to
00178  *   get an accurate record index.
00179  */
00180 extern Err
00181 NetPrefRecSave (UInt16 refNum, struct NetPrefContextTypeTag* cxtP,
00182                 struct NetPrefRecordTypeTag* recP)
00183     NETPREF_LIB_TRAP (netPrefLibTrapRecSave);
00184
00185
00186 /** Check if this record object is "attached" to the database.  A record
00187  *   that has been created via NetPrefRecObjAlloc and never saved is
00188  *   not "attached" to the database.
00189  */
00190 extern Boolean
00191 NetPrefRecIsAttached (UInt16 refNum, struct NetPrefContextTypeTag* cxtP,
00192                       struct NetPrefRecordTypeTag* recP)
00193     NETPREF_LIB_TRAP (netPrefLibTrapRecIsAttached);
00194
00195
00196
00197 /** Allocate a "blank slate" record object.  This record will not be "attached"
00198  *   to the database until saved via NetPrefRecSave.  Intended for use with
00199  *   NetPrefRecObjCopy, and by internal code.
00200  */
00201 extern Err
00202 NetPrefRecObjAlloc (UInt16 refNum, struct NetPrefContextTypeTag* cxtP,
00203                     struct NetPrefRecordTypeTag** recPP)
00204     NETPREF_LIB_TRAP (netPrefLibTrapRecObjAlloc);
00205
00206 /** Copy the contents of the source record object to the destination
00207  *   record object.  This is useful for implementing revert functionality.
00208  */
00209 extern Err
00210 NetPrefRecObjCopy (UInt16 refNum, struct NetPrefContextTypeTag* cxtP,
00211                    struct NetPrefRecordTypeTag* srcRecP,
00212                    struct NetPrefRecordTypeTag* dstRecP)
00213     NETPREF_LIB_TRAP (netPrefLibTrapRecObjCopy);
00214
00215
00216 /** Get the unique record ID of the record's entry in the database.
00217  *
00218  *  WARNING:
00219  *   It is an error to call NetPrefRecIDGet on records that have not been
00220  *   attached to the database -- see NetPrefRecIsAttached().
00221  *
00222  */
00223 extern Err
00224 NetPrefRecIDGet (UInt16 refNum, struct NetPrefContextTypeTag* cxtP,
00225                  struct NetPrefRecordTypeTag* recP, UInt32* recIDP)
00226     NETPREF_LIB_TRAP (netPrefLibTrapRecIDGet);
00227
00228 /** Get the 0-based index of the record's entry in the database.
00229  *  The record's index may change following the NetPrefRecSave opeation.
00230  *
00231  *  WARNING:
00232  *   It is an error to call NetPrefRecIndexGet on records that have not been
00233  *   attached to the database -- see NetPrefRecIsAttached().
00234  */
00235 extern Err
00236 NetPrefRecIndexGet (UInt16 refNum, struct NetPrefContextTypeTag* cxtP,
00237                     struct NetPrefRecordTypeTag* recP, UInt16* recIndexP)
00238     NETPREF_LIB_TRAP (netPrefLibTrapRecIndexGet);
00239
00240
00241 /** Delete the given record from the database; if the record is bound
00242  *   to another, such as that stored in non-volatile memory of the radio
00243  *   module, will delete the primary record as well.  If the client
00244  *  has a memory object representing the record being deleted, the client
00245  *   is still responsible for releasing it via NetPrefRecRelease().
00246  *
00247  */
00248 extern Err
00249 NetPrefRecDelete (UInt16 refNum, struct NetPrefContextTypeTag* cxtP,
00250                   UInt32 recID)
00251     NETPREF_LIB_TRAP (netPrefLibTrapRecDelete);
00252
00253 /** Get a pointer to a given record field; upon successful return,
00254  *   the value of the field is to be interpreted as follows:
00255  *
00256  *    NULL    -- field value is not assigned
00257  *    non-NULL -- field value has been assigned, the
00258  *                value must be treated as read-only!
00259  *  Field view depends on the Medium and Binding of the record
00260  */
00261 extern Err
00262 NetPrefRecFieldGet (UInt16 refNum, struct NetPrefContextTypeTag* cxtP,
00263                    struct NetPrefRecordTypeTag* recP,
00264                    NetPrefRecFieldEnum recFieldID, void** fieldValuePP,
00265                    UInt32* fieldLenP, NetPrefRecFieldViewType* viewFlagsP)
00266     NETPREF_LIB_TRAP (netPrefLibTrapRecFieldGet);
00267
00268
00269 /** Get the attributes of a field */
00270 extern Err
00271 NetPrefRecFieldAttrsGet (UInt16 refNum, struct NetPrefContextTypeTag* cxtP,
00272                          struct NetPrefRecordTypeTag* recP,
00273                          NetPrefRecFieldEnum recFieldID,
00274                          NetPrefRecFieldAttrType* fieldAttrsP)
00275     NETPREF_LIB_TRAP (netPrefLibTrapRecFieldAttrsGet);
00276
00277
00278 /** NetPrefRecFieldSet:
00279  *  Set the value of the field.  The library will duplicate the value
00280  *   passed in fieldValueP. Set fieldValueP to NULL to delete the
00281  *   field's data. NOTE: setting a field invalidates any cached
00282  *   pointer that you may already have to the field's value.
00283  *
00284  *   NOTES:
00285  *    1) Field must be in record's field-set before you can set its
00286  *       data or view flags.
00287  *
00288  *    2) String field values MUST be zero-terminated and the fieldLen
00289  *       MUST include the zero-terminator.
00290  *
00291  *    3) If a change results, the record object will be marked as dirty
00292  *
00293  */
00294 extern Err
00295 NetPrefRecFieldSet (UInt16 refNum, struct NetPrefContextTypeTag* cxtP,
00296                     struct NetPrefRecordTypeTag* recP,
00297                     NetPrefRecFieldEnum recFieldID, void* fieldValueP,
00298                     UInt32 fieldLen)
00299     NETPREF_LIB_TRAP (netPrefLibTrapRecFieldSet);
00300
00301
00302 /** Set the view flags of the field.  If a change results, the record
00303  *  object will be marked as dirty.
00304  *
00305  *  NOTES:
00306  *    1) Field must be in record's field-set before you can set its
00307  *       data or view flags.
00308  *
00309  *    2) If a change results, the record object will be marked as dirty
00310  */
00311 extern Err
00312 NetPrefRecFieldViewSet (UInt16 refNum, struct NetPrefContextTypeTag* cxtP,
00313                         struct NetPrefRecordTypeTag* recP,
00314                         NetPrefRecFieldEnum recFieldID,
00315                         NetPrefRecFieldViewType flagsToClear,
00316                         NetPrefRecFieldViewType flagsToSet)
00317     NETPREF_LIB_TRAP (netPrefLibTrapRecFieldViewSet);
00318
00319
00320
00321 /** NetPrefRecReadOnlyOverrideStart/End: Increment/decrement the
00322  * record object's readOnlyOverrideCount variable.  The two
00323  * function calls must be balanced -- i.e., ...End must be called
00324  * exactly as many times as ...Start regardless of other events,
00325  * such as errors. If greater than zero, NetPrefRecFieldSet
00326  * will allow the field to be set regardless of the record's read-only
00327  * status.  This permits internal record "loaders" to initialize record
00328  * fields regardless of the read-only status of the fields being loaded.
00329  */
00330 extern void
00331 NetPrefRecReadOnlyOverrideStart (UInt16 refNum,
00332                                  struct NetPrefContextTypeTag* cxtP,
00333                                  struct NetPrefRecordTypeTag* recP)
00334     NETPREF_LIB_TRAP (netPrefLibTrapRecReadOnlyOverrideStart);
00335
00336 extern void
00337 NetPrefRecReadOnlyOverrideEnd (UInt16 refNum,
00338                                struct NetPrefContextTypeTag* cxtP,
00339                                struct NetPrefRecordTypeTag* recP)
00340     NETPREF_LIB_TRAP (netPrefLibTrapRecReadOnlyOverrideEnd);
00341
00342
00343 /** Define the field set associated with the record; fields that
00344  * are not in the new field will be removed from the record
00345  * object.  For fields in the new field set, existing data will
00346  * be left alone.
00347  *
00348  * You may pass a pointer to new
00349  * NetPrefRecFieldViewType in initialViewFlagsP to set those
00350  * view flags in all the fields in the new field set (or pass
00351  * NULL to ignore this parameter and leave field view flags
00352  * at their old values).
00353  *
00354  * To remove all fields from the field set, set newNumFields to 0
00355  * and recFieldIDArrayP to NULL;
00356  */
00357 extern Err
00358 NetPrefRecFieldSetDefine (UInt16 refNum, struct NetPrefContextTypeTag* cxtP,
00359                           struct NetPrefRecordTypeTag* recP,
00360                           NetPrefRecFieldEnum* recFieldIDArrayP,
00361                           UInt16 newNumFields,
00362                           NetPrefRecFieldViewType* initialViewFlagsP,
00363                           NetPrefFieldSetDefineOptionsType options)
00364     NETPREF_LIB_TRAP (netPrefLibTrapRecFieldSetDefine);
00365
00366
00367
00368 /** Add a field to the Field-set of a given record and, optionally, set its
00369  * view flags (set initialViewFlagsP to NULL to leave the field's view flags
00370  * alone).
00371  *
00372  * NOTE: If the field was already part of the record's field-set, the field's
00373  * data will be preserved.  However, the field's view flags will be overwritten
00374  * with those supplied via initialViewFlagsP if initialViewFlagsP is not NULL.
00375  */
00376 extern Err
00377 NetPrefRecFieldAddToSet (UInt16 refNum, struct NetPrefContextTypeTag* cxtP,
00378                          struct NetPrefRecordTypeTag* recP,
00379                          NetPrefRecFieldEnum recFieldID,
00380                          NetPrefRecFieldViewType* initialViewFlagsP)
00381     NETPREF_LIB_TRAP (netPrefLibTrapRecFieldAddToSet);
00382
00383
00384 /** Define a "standard" field set based on Service Medium value -- basically,
00385  * this is what the New Network Preference panel uses when it creates new
00386  * services.
00387  *
00388  * You may pass a pointer to new
00389  * NetPrefRecFieldViewType in initialViewFlagsP to set the
00390  * view flags of all the fields in the new field set (or pass
00391  * NULL for default flags).
00392  */
00393 extern Err
00394 NetPrefRecFieldSetDefineStd (UInt16 refNum, struct NetPrefContextTypeTag* cxtP,
00395                              struct NetPrefRecordTypeTag* recP,
00396                              NetPrefSvcMediumEnum svcMedium,
00397                              NetPrefRecFieldViewType* initialViewFlagsP,
00398                              NetPrefFieldSetDefineOptionsType options)
00399     NETPREF_LIB_TRAP (netPrefLibTrapRecFieldSetDefineStd);
00400
00401
00402 /** Get the current field set of the record object.  The array
00403  * recFieldIDArrayP MUST have enough entries (numEntriesAvailable)
00404  * to receive the field ID's of all fields in the field set.
00405  * The actual count of fields in the field set is returned in
00406  * *numFieldsInSetP.
00407  * To simply get the count of fields in the field set, without
00408  * returning the actual field ID's, set numEntriesAvailable to 0
00409  * and recFieldIDArrayP to NULL;
00410  */
00411 extern Err
00412 NetPrefRecFieldSetGet (UInt16 refNum, struct NetPrefContextTypeTag* cxtP,
00413                        struct NetPrefRecordTypeTag* recP,
00414                        NetPrefRecFieldEnum* recFieldIDArrayP,
00415                        UInt16 numEntriesAvailable, UInt16* numFieldsInSetP)
00416     NETPREF_LIB_TRAP (netPrefLibTrapRecFieldSetGet);
00417
00418 /** Check if the record is dirty (has been modified by the client)
00419  */
00420 extern Err
00421 NetPrefRecIsDirty (UInt16 refNum, struct NetPrefContextTypeTag* cxtP,
00422                     struct NetPrefRecordTypeTag* recP,
00423                     UInt8* isDirtyP)
00424     NETPREF_LIB_TRAP (netPrefLibTrapRecIsDirty);
00425
00426
00427 /** Reset all of the record's "dirty" flags.  NOTE: NetPrefRecSave will not
00428  * save a record that is not marked as "dirty"
00429  */
00430 extern void
00431 NetPrefRecDirtyFlagsReset (UInt16 refNum,
00432                            struct NetPrefContextTypeTag* cxtP,
00433                            struct NetPrefRecordTypeTag* recP)
00434     NETPREF_LIB_TRAP (netPrefLibTrapRecDirtyFlagsReset);
00435
00436
00437 /** Mark a record as "dirty" so it would be saved by NetPrefRecSave.
00438  */
00439 extern void
00440 NetPrefRecMarkDirty (UInt16 refNum,
00441                      struct NetPrefContextTypeTag* cxtP,
00442                      struct NetPrefRecordTypeTag* recP)
00443     NETPREF_LIB_TRAP (netPrefLibTrapRecMarkDirty);
00444
00445
00446 /** Get the default service ID for the given target
00447  */
00448 extern Err
00449 NetPrefDefaultTargetGet (UInt16 refNum, struct NetPrefContextTypeTag* cxtP,
00450                          NetPrefSvcTargetEnum svcTarget, UInt32* recIDP)
00451     NETPREF_LIB_TRAP (netPrefLibTrapDefaultTargetGet);
00452
00453
00454 /** Set the given service as the default service for the given target type;
00455  * Set recID to 0 (zero) to clear the default for that target type.
00456  * (WAP, Internet, all, etc.)
00457  */
00458 extern Err
00459 NetPrefDefaultTargetSet (UInt16 refNum, struct NetPrefContextTypeTag* cxtP,
00460                          NetPrefSvcTargetEnum svcTarget, UInt32 recID)
00461     NETPREF_LIB_TRAP (netPrefLibTrapDefaultTargetSet);
00462
00463
00464 /** Update the NetPref database from the Non-Volatile storage of the radio,
00465  * if any.  This should be called by the IOTA application after provisioning,
00466  * as well as when the wireless mode is turned on.  This function is optimized
00467  * to quickly determine if synchronization is necessary, and skip it if not.
00468  * Set "force" to true to skip optimization and force synchronization.
00469  */
00470 extern Err
00471 NetPrefUpdateFromRadioNV (UInt16 refNum, struct NetPrefContextTypeTag* cxtP,
00472                           Boolean force)
00473     NETPREF_LIB_TRAP (netPrefLibTrapUpdateFromRadioNV);
00474
00475
00476 /** Called by the Network prefs. panel when it receives the
00477  * sysAppLaunchCmdSyncNotify action code from HotSync or IR stack.
00478  * This happens whenever the network preferences database NetworkDB
00479  * or the Network panel are HotSynced or IR-beamed to the device.
00480  *
00481  * NOTE: this may be called from a background task with a rather
00482  * small runtime stack (as in the case of HotSync).
00483  */
00484 extern Err
00485 NetPrefHandleHotSyncNotify (UInt16 refNum,
00486                             struct NetPrefContextTypeTag* cxtP,
00487                             UInt16 cmd, void* cmdPBP)
00488     NETPREF_LIB_TRAP (netPrefLibTrapHandleHotSyncNotify);
00489
00490
00491 /***********************************************************************
00492  *
00493  * FUNCTION:     NetPrefRecLongFieldGet
00494  *
00495  * DESCRIPTION:  Get a UInt32 field value from a record
00496  *
00497  * PARAMETERS:
00498  *    refNum          IN  NetPrefLib reference number (from SysLibFind
00499  *                         or SysLibLoad)
00500  *    cxtP            IN  Open NetPref library context as returned by
00501  *                         a successful call to NetPrefLibOpen
00502  *    recP -
00503  *    recFieldID    -
00504  *    resultP   - value, set to zero if not available
00505  *    viewFlagsP - OUT field's view flags -- OPTIONAL - set to
00506  *                                NULL to ignore
00507  *
00508  *  CALLED BY:
00509  *
00510  * RETURNED:     true if available (set), false if not
00511  ***********************************************************************/
00512 extern Boolean
00513 NetPrefRecLongFieldGet (UInt16 refNum,
00514                         struct NetPrefContextTypeTag* cxtP,
00515                         struct NetPrefRecordTypeTag* recP,
00516                         NetPrefRecFieldEnum recFieldID,
00517                         UInt32* resultP,
00518                         NetPrefRecFieldViewType* viewFlagsP)
00519     NETPREF_LIB_TRAP (netPrefLibTrapRecLongFieldGet);
00520
00521
00522 /***********************************************************************
00523  *
00524  * FUNCTION:     NetPrefRecShortFieldGet
00525  *
00526  * DESCRIPTION:  Get a UInt16 field value from a record
00527  *
00528  * PARAMETERS:
00529  *    refNum          IN  NetPrefLib reference number (from SysLibFind
00530  *                         or SysLibLoad)
00531  *    cxtP            IN  Open NetPref library context as returned by
00532  *                         a successful call to NetPrefLibOpen
00533  *    recP -
00534  *    recFieldID    -
00535  *    resultP   - value, set to zero if not available
00536  *    viewFlagsP - [OPTIONAL] view flags
00537  *
00538  *  CALLED BY:
00539  *
00540  * RETURNED:     true if available (set), false if not
00541  ***********************************************************************/
00542 extern Boolean
00543 NetPrefRecShortFieldGet (UInt16 refNum,
00544                         struct NetPrefContextTypeTag* cxtP,
00545                         struct NetPrefRecordTypeTag* recP,
00546                         NetPrefRecFieldEnum recFieldID,
00547                         UInt16* resultP,
00548                         NetPrefRecFieldViewType* viewFlagsP)
00549     NETPREF_LIB_TRAP (netPrefLibTrapRecShortFieldGet);
00550
00551
00552 /***********************************************************************
00553  *
00554  * FUNCTION:     NetPrefRecByteFieldGet
00555  *
00556  * DESCRIPTION:  Get a UInt8 field value from a record
00557  *
00558  * PARAMETERS:
00559  *    refNum          IN  NetPrefLib reference number (from SysLibFind
00560  *                         or SysLibLoad)
00561  *    cxtP            IN  Open NetPref library context as returned by
00562  *                         a successful call to NetPrefLibOpen
00563  *    recP -
00564  *    recFieldID    -
00565  *    resultP   - value, set to zero if not available
00566  *
00567  *  CALLED BY:
00568  *
00569  * RETURNED:     true if available (set), false if not
00570  ***********************************************************************/
00571 extern Boolean
00572 NetPrefRecByteFieldGet (UInt16 refNum,
00573                         struct NetPrefContextTypeTag* cxtP,
00574                         struct NetPrefRecordTypeTag* recP,
00575                         NetPrefRecFieldEnum recFieldID,
00576                         UInt8* resultP,
00577                         NetPrefRecFieldViewType* viewFlagsP)
00578     NETPREF_LIB_TRAP (netPrefLibTrapRecByteFieldGet);
00579
00580
00581 /**************************************************************
00582  *  Function:     NetPrefRecFieldViewGet
00583  *
00584  *  Summary:
00585  *    Returns field view flags for a given field of the given record.
00586  *
00587  *  Parameters:
00588  *    refNum          IN  NetPrefLib reference number (from SysLibFind
00589  *                         or SysLibLoad)
00590  *    cxtP            IN  Open NetPref library context as returned by
00591  *                         a successful call to NetPrefLibOpen
00592  *    recP            IN  NetPref record object
00593  *    recFieldID      IN  NetPref record field ID
00594  *
00595  *  Returns:
00596  *    NetPrefRecFieldViewType
00597  ****************************************************************/
00598 extern NetPrefRecFieldViewType
00599 NetPrefRecFieldViewGet (UInt16 refNum,
00600                          struct NetPrefContextTypeTag* cxtP,
00601                          struct NetPrefRecordTypeTag* recP,
00602                          NetPrefRecFieldEnum recFieldID)
00603     NETPREF_LIB_TRAP (netPrefLibTrapRecFieldViewGet);
00604
00605
00606 /***********************************************************************
00607  *
00608  * FUNCTION:     NetPrefRecLongFieldSetAsFlags
00609  *
00610  * DESCRIPTION:  Set a 32-bit field data value as flags. The clear
00611  *               operation is performed before the set operation.  To
00612  *               skip either operation, set the corresponding parameter to 0.
00613  *
00614  * PARAMETERS:
00615  *    refNum          IN  NetPrefLib reference number (from SysLibFind
00616  *                         or SysLibLoad)
00617  *    cxtP            IN  Open NetPref library context as returned by
00618  *                         a successful call to NetPrefLibOpen
00619  *    recP -
00620  *    recFieldID    -
00621  *    resultP   - value, set to zero if not available
00622  *    flagsToClear    IN flags to clear, or 0 to skip
00623  *    flagsToSet      IN flags to set, or 0 to skip
00624  *
00625  *  CALLED BY:
00626  *
00627  * RETURNED:     0 on success
00628  ***********************************************************************/
00629 extern Err
00630 NetPrefRecLongFieldSetAsFlags (UInt16 refNum,
00631                                struct NetPrefContextTypeTag* cxtP,
00632                                struct NetPrefRecordTypeTag* recP,
00633                                NetPrefRecFieldEnum recFieldID,
00634                                UInt32 flagsToClear, UInt32 flagsToSet)
00635     NETPREF_LIB_TRAP (netPrefLibTrapRecLongFieldSetAsFlags);
00636
00637
00638 /***************************************************************
00639  *  Function:     NetPrefRecFieldSetFromBinHandle
00640  *
00641  *  Summary:      Set a record object binary field from a PalmOS
00642  *                memory handle.
00643  *
00644  *  Parameters:
00645  *    refNum          IN  NetPrefLib reference number (from SysLibFind
00646  *                         or SysLibLoad)
00647  *    cxtP            IN  Open NetPref library context as returned by
00648  *                         a successful call to NetPrefLibOpen
00649  *    recP            IN/OUT  record object
00650  *    recFieldID      IN      field ID -- NetPrefRecFieldEnum
00651  *    dataH           IN      data handle
00652  *
00653  *  Returns:
00654  *    0 on success
00655  ****************************************************************/
00656 extern Err
00657 NetPrefRecFieldSetFromBinHandle (UInt16 refNum,
00658                                 struct NetPrefContextTypeTag* cxtP,
00659                                 struct NetPrefRecordTypeTag* recP,
00660                                 NetPrefRecFieldEnum recFieldID,
00661                                 MemHandle dataH)
00662     NETPREF_LIB_TRAP (netPrefLibTrapRecFieldSetFromBinHandle);
00663
00664
00665 /***************************************************************
00666  *  Function:     NetPrefRecFieldSetFromStrHandle
00667  *
00668  *  Summary:      Set a record object string field from a PalmOS memory handle.
00669  *
00670  *  Parameters:
00671  *    refNum          IN  NetPrefLib reference number (from SysLibFind
00672  *                         or SysLibLoad)
00673  *    cxtP            IN  Open NetPref library context as returned by
00674  *                         a successful call to NetPrefLibOpen
00675  *    recP            IN/OUT  record object
00676  *    recFieldID      IN      field ID -- NetPrefRecFieldEnum
00677  *    dataH           IN      string handle -- zero-terminated; may be NULL
00678  *
00679  *  Returns:
00680  *    0 on success
00681  ****************************************************************/
00682 extern Err
00683 NetPrefRecFieldSetFromStrHandle (UInt16 refNum,
00684                                 struct NetPrefContextTypeTag* cxtP,
00685                                 struct NetPrefRecordTypeTag* recP,
00686                                 NetPrefRecFieldEnum recFieldID,
00687                                 MemHandle dataH)
00688     NETPREF_LIB_TRAP (netPrefLibTrapRecFieldSetFromStrHandle);
00689
00690
00691 /***************************************************************
00692  *  Function:     NetPrefRecFieldSetFromStrPtr
00693  *
00694  *  Summary:      Set a record object string field from a PalmOS memory handle.
00695  *
00696  *  Parameters:
00697  *    refNum          IN  NetPrefLib reference number (from SysLibFind
00698  *                         or SysLibLoad)
00699  *    cxtP            IN  Open NetPref library context as returned by
00700  *                         a successful call to NetPrefLibOpen
00701  *    recP            IN/OUT  record object
00702  *    recFieldID      IN      field ID -- NetPrefRecFieldEnum
00703  *    strP            IN      string pointer -- zero-terminated; may be NULL
00704  *
00705  *  Returns:
00706  *    0 on success
00707  ****************************************************************/
00708 extern Err
00709 NetPrefRecFieldSetFromStrPtr (UInt16 refNum,
00710                               struct NetPrefContextTypeTag* cxtP,
00711                               struct NetPrefRecordTypeTag* recP,
00712                               NetPrefRecFieldEnum recFieldID,
00713                               char* strP)
00714     NETPREF_LIB_TRAP (netPrefLibTrapRecFieldSetFromStrPtr);
00715
00716
00717
00718 /***************************************************************
00719  *  Function:     NetPrefRecConnectionInfoGet
00720  *
00721  *  Summary:      Get the port ID and modem status of the connection
00722  *                referenced by the record object.
00723  *
00724  *  Parameters:
00725  *    refNum          IN  NetPrefLib reference number (from SysLibFind
00726  *                         or SysLibLoad)
00727  *    cxtP            IN  Open NetPref library context as returned by
00728  *                         a successful call to NetPrefLibOpen
00729  *    recP            IN  record object
00730  *
00731  *  Returns:
00732  *    true if got information, false if connection is not in the Connection
00733  *    Manager database
00734  ****************************************************************/
00735 extern Boolean
00736 NetPrefRecConnectionInfoGet (UInt16 refNum,
00737                             struct NetPrefContextTypeTag* cxtP,
00738                             struct NetPrefRecordTypeTag* recP,
00739                             UInt32* portCreatorIDP, Boolean* isModemP)
00740     NETPREF_LIB_TRAP (netPrefLibTrapRecConnectionInfoGet);
00741
00742
00743 /***************************************************************
00744  *  Function:     NetPrefRecMediumDerive
00745  *
00746  *  Summary:      Determine the record's "medium" (NetPrefSvcMediumEnum).
00747  *                Determine based on Connection name and/or
00748  *                the value of the netPrefRecFieldMedium.
00749  *                The precedence goes to netPrefRecFieldMedium.
00750  *
00751  *  Parameters:
00752  *    refNum          IN  NetPrefLib reference number (from SysLibFind
00753  *                         or SysLibLoad)
00754  *    cxtP            IN  Open NetPref library context as returned by
00755  *                         a successful call to NetPrefLibOpen
00756  *    recP            IN  record object
00757  *
00758  *  Returns:
00759  *    NetPrefSvcMediumEnum
00760  ****************************************************************/
00761 extern NetPrefSvcMediumEnum
00762 NetPrefRecMediumDerive (UInt16 refNum,
00763                          struct NetPrefContextTypeTag* cxtP,
00764                          struct NetPrefRecordTypeTag* recP,
00765                          UInt32 defWirelessDriverID)
00766     NETPREF_LIB_TRAP (netPrefLibTrapRecMediumDerive);
00767
00768
00769 /***********************************************************************
00770  *
00771  * FUNCTION:    NetPrefRecIPAddrFieldSet
00772  *
00773  * DESCRIPTION: Set the value of an IP address field in the record object.
00774  *              If the IP address is 0, saves a value of 0 length to
00775  *              optimize memory access performance
00776  *
00777  * PARAMETERS:
00778  *    refNum          IN  NetPrefLib reference number (from SysLibFind
00779  *                         or SysLibLoad)
00780  *    cxtP            IN  Open NetPref library context as returned by
00781  *                         a successful call to NetPrefLibOpen
00782  *    recP  - record object
00783  *    recFieldID - record object field ID to set
00784  *    ipAddr - IP address
00785  *
00786  * RETURNED:    0 on success.
00787  ***********************************************************************/
00788 extern Err
00789 NetPrefRecIPAddrFieldSet (UInt16 refNum,
00790                           struct NetPrefContextTypeTag* cxtP,
00791                           struct NetPrefRecordTypeTag* recP,
00792                           NetPrefRecFieldEnum recFieldID, UInt32 ipAddr)
00793     NETPREF_LIB_TRAP (netPrefLibTrapRecIPAddrFieldSet);
00794
00795
00796 /***********************************************************************
00797  *
00798  * FUNCTION:      NetPrefUtilZStringListSizeGet
00799  *
00800  * DESCRIPTION:   Return the length of a zero-terminated string list.  A
00801  *                zero-terminated string list consists of zero-terminated
00802  *                strings and ends with an empty string.  The size includes.
00803  *                all of the zero-terminators, including the list terminator.
00804  *
00805  * PARAMETERS:
00806  *    refNum          IN  NetPrefLib reference number (from SysLibFind
00807  *                         or SysLibLoad)
00808  *    cxtP            IN  Open NetPref library context as returned by
00809  *                         a successful call to NetPrefLibOpen
00810  *    zStrListP - pointer to the zero-terminated sting list
00811  *
00812  * RETURNED:
00813  *    The size of the list, including all of the zero-terminators and
00814  *    the list terminator.
00815  *
00816  * REVISION HISTORY:
00817  *          Name    Date        Description
00818  *          ----    ----        -----------
00819  *          vmk     2/11/02     Created based on Palm's SetPrefStr from
00820  *                              Network Panel.
00821  ***********************************************************************/
00822 extern UInt32
00823 NetPrefUtilZStringListSizeGet (UInt16 refNum,
00824                                struct NetPrefContextTypeTag* cxtP,
00825                                char* zStrListP)
00826     NETPREF_LIB_TRAP (netPrefLibTrapUtilZStringListSizeGet);
00827
00828 #define NetPrefUtilLoginScriptLen(refNum, cxtP, scriptP) \
00829                 NetPrefUtilZStringListSizeGet ((refNum), (cxtP), \
00830                                                (scriptP))
00831
00832
00833 /***********************************************************************
00834  *
00835  * FUNCTION:     NetPrefRecPhoneStringCompose
00836  *
00837  * DESCRIPTION: Compose a phone string from the record object.
00838  *              contcatenate the dial prefix, disable
00839  *              call waiting, calling card number, and the phone
00840  *              number
00841  *
00842  * PARAMETERS:
00843  *    refNum          IN  NetPrefLib reference number (from SysLibFind
00844  *                         or SysLibLoad)
00845  *    cxtP            IN  Open NetPref library context as returned by
00846  *                         a successful call to NetPrefLibOpen
00847  *    recP            IN  record object
00848  *    destP           OUT string buffer to hold the complete number
00849  *                         maxLen     IN  the allocated length of destP -1
00850  *
00851  * RETURNED:    nothing
00852  ***********************************************************************/
00853 extern void
00854 NetPrefRecPhoneStringCompose (UInt16 refNum,
00855                               struct NetPrefContextTypeTag* cxtP,
00856                               struct NetPrefRecordTypeTag* recP,
00857                               Char* destP, UInt16 maxLen)
00858     NETPREF_LIB_TRAP (netPrefLibTrapRecPhoneStringCompose);
00859
00860
00861 /***********************************************************************
00862  *
00863  * Function:    NetPrefUtilPlatformIDGet
00864  *
00865  * Summary:     Determine on which platform we are running -- CDMA or GSM
00866  *
00867  * Parameters:
00868  *    nothing
00869  *
00870  * Returns:
00871  *    refNum          IN  NetPrefLib reference number (from SysLibFind
00872  *                         or SysLibLoad)
00873  *    cxtP            IN  Open NetPref library context as returned by
00874  *                         a successful call to NetPrefLibOpen -- MAY BE NULL!
00875  *    NetPrefPlatformEnum or netPrefPlatformUnknown if could not
00876  *    identify
00877  ***********************************************************************/
00878 extern NetPrefPlatformEnum
00879 NetPrefUtilPlatformIDGet (UInt16 refNum, struct NetPrefContextTypeTag* cxtP)
00880     NETPREF_LIB_TRAP (netPrefLibTrapUtilPlatformIDGet);
00881
00882
00883 /***********************************************************************
00884  *
00885  * Function:    NetPrefUtilDefWirelessDriverIDGet
00886  *
00887  * Summary:     Get the default wireless driver ID for the given platform
00888  *
00889  * Parameters:
00890  *    refNum          IN  NetPrefLib reference number (from SysLibFind
00891  *                         or SysLibLoad)
00892  *    cxtP            IN  Open NetPref library context as returned by
00893  *                         a successful call to NetPrefLibOpen -- MAY BE NULL!
00894  *    platform        IN    platform ID (from NetPrefUtilPlatformIDGet())
00895  *
00896  * Returns:
00897  *    Wireless driver ID (creator) or 0 if platform is not wireless
00898  ***********************************************************************/
00899 extern UInt32
00900 NetPrefUtilDefWirelessDriverIDGet (UInt16 refNum,
00901                                    struct NetPrefContextTypeTag* cxtP,
00902                                    NetPrefPlatformEnum platform)
00903     NETPREF_LIB_TRAP (netPrefLibTrapUtilDefWirelessDriverIDGet);
00904
00905
00906 #ifdef __cplusplus
00907 }
00908 #endif
00909
00910
00911 #endif // _NET_PREF_LIBRARY_H_
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:54 2008 for Palm API Guide


Header Files » Incs » common » libraries » netpref

NetPrefLibTarget.h

Go to the documentation of this file.
00001 /******************************************************************************
00002  * Copyright (c) 2004 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  *****************************************************************************/
00005 /**
00006  * @ingroup NETPREF
00007  */
00008
00009 /**
00010  * @file    NetPrefLibTarget.h
00011  * @version 1.0
00012  * @date    12/12/2001
00013  *
00014  * @brief   This is the target parameters file for the NetPref Library.
00015  *
00016  * We break out these definitions so that other portable modules
00017  * could access them without PalmOS-specific definishions
00018  *
00019  */
00020
00021 /*
00022  * @author  vmk
00023  *
00024  * <hr>
00025  */
00026
00027 #ifndef _NET_PREF_LIB_TARAGET_H_
00028 #define _NET_PREF_LIB_TARAGET_H_
00029
00030
00031
00032 // 'HsNP' was registered on 12/12/2001 @ 4:56pm
00033 #define netPrefLibCreatorID   'HsNP'    /**< NetPref Library database creator */
00034
00035 #define netPrefLibTypeID      'libr'    /**< Standard library database type */
00036
00037 #define netPrefLibName        "HsNetPrefLibrary.lib"  /**< Internal library name
00038                                                         *  which can be passed to SysLibFind()
00039                                                         */
00040
00041
00042 #endif // _NET_PREF_LIB_TARAGET_H_
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:54 2008 for Palm API Guide


Header Files » Incs » common » libraries » netpref

NetPrefLibTraps.h

Go to the documentation of this file.
00001 /******************************************************************************
00002  * Copyright (c) 2004 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  *****************************************************************************/
00005 /**
00006  * @ingroup NETPREF
00007  */
00008
00009 /**
00010  * @file    NetPrefLibTraps.h
00011  * @version 1.0
00012  * @date    12/12/2001
00013  *
00014  * @brief   Trap definitions for the NetPref Library.
00015  *
00016  */
00017
00018 /*
00019  * @author  vmk
00020  *
00021  * <hr>
00022  */
00023
00024
00025 #ifndef __NET_PREF_LIB_TRAPS_H__
00026 #define __NET_PREF_LIB_TRAPS_H__
00027
00028 /**
00029  * @name Trap IDs
00030  *
00031  * @brief Trap IDs for the NetPref Library's public functions.
00032  *
00033  * The order of the traps must be the same as the routines are listed in NetPrefLibDispatchTable.c.
00034  */
00035 /*@{*/
00036 #define netPrefLibTrapVersionGet                        (sysLibTrapCustom + 0)
00037 #define netPrefLibTrapRecCountGet                       (sysLibTrapCustom + 1)
00038 #define netPrefLibTrapRecIDGetByIndex                   (sysLibTrapCustom + 2)
00039 #define netPrefLibTrapRecNew                            (sysLibTrapCustom + 3)
00040 #define netPrefLibTrapRecLoad                           (sysLibTrapCustom + 4)
00041 #define netPrefLibTrapRecRelease                        (sysLibTrapCustom + 5)
00042 #define netPrefLibTrapRecSave                           (sysLibTrapCustom + 6)
00043 #define netPrefLibTrapRecIDGet                          (sysLibTrapCustom + 7)
00044 #define netPrefLibTrapRecIndexGet                       (sysLibTrapCustom + 8)
00045 #define netPrefLibTrapRecDelete                         (sysLibTrapCustom + 9)
00046 #define netPrefLibTrapRecFieldGet                       (sysLibTrapCustom + 10)
00047 #define netPrefLibTrapRecFieldSet                       (sysLibTrapCustom + 11)
00048 #define netPrefLibTrapDefaultTargetGet                  (sysLibTrapCustom + 12)
00049 #define netPrefLibTrapDefaultTargetSet                  (sysLibTrapCustom + 13)
00050 #define netPrefLibTrapRecObjCopy                        (sysLibTrapCustom + 14)
00051 #define netPrefLibTrapRecIsDirty                        (sysLibTrapCustom + 15)
00052 #define netPrefLibTrapRecIndexGetByID                   (sysLibTrapCustom + 16)
00053 #define netPrefLibTrapRecFieldViewSet                   (sysLibTrapCustom + 17)
00054 #define netPrefLibTrapRecFieldAttrsGet                  (sysLibTrapCustom + 18)
00055 #define netPrefLibTrapUpdateFromRadioNV                 (sysLibTrapCustom + 19)
00056
00057 #define netPrefLibTrapRecFieldSetDefine                 (sysLibTrapCustom + 20)
00058 #define netPrefLibTrapRecFieldSetGet                    (sysLibTrapCustom + 21)
00059 #define netPrefLibTrapRecFieldSetDefineStd              (sysLibTrapCustom + 22)
00060 #define netPrefLibTrapRecFieldAddToSet                  (sysLibTrapCustom + 23)
00061
00062 #define netPrefLibTrapRecReadOnlyOverrideStart          (sysLibTrapCustom + 24)
00063 #define netPrefLibTrapRecReadOnlyOverrideEnd            (sysLibTrapCustom + 25)
00064 #define netPrefLibTrapRecDirtyFlagsReset                (sysLibTrapCustom + 26)
00065 #define netPrefLibTrapRecMarkDirty                      (sysLibTrapCustom + 27)
00066 #define netPrefLibTrapRecObjAlloc                       (sysLibTrapCustom + 28)
00067 #define netPrefLibTrapRecIsAttached                     (sysLibTrapCustom + 29)
00068 #define netPrefLibTrapRecBindingErrorGet                (sysLibTrapCustom + 30)
00069 #define netPrefLibTrapHandleHotSyncNotify               (sysLibTrapCustom + 31)
00070
00071 #define netPrefLibTrapRecShortFieldGet                  (sysLibTrapCustom + 32)
00072 #define netPrefLibTrapRecByteFieldGet                   (sysLibTrapCustom + 33)
00073 #define netPrefLibTrapRecFieldViewGet                   (sysLibTrapCustom + 34)
00074 #define netPrefLibTrapRecLongFieldSetAsFlags            (sysLibTrapCustom + 35)
00075 #define netPrefLibTrapRecFieldSetFromBinHandle          (sysLibTrapCustom + 36)
00076 #define netPrefLibTrapRecFieldSetFromStrHandle          (sysLibTrapCustom + 37)
00077 #define netPrefLibTrapRecFieldSetFromStrPtr             (sysLibTrapCustom + 38)
00078 #define netPrefLibTrapRecConnectionInfoGet              (sysLibTrapCustom + 39)
00079 #define netPrefLibTrapRecMediumDerive                   (sysLibTrapCustom + 40)
00080 #define netPrefLibTrapRecIPAddrFieldSet                 (sysLibTrapCustom + 41)
00081 #define netPrefLibTrapUtilZStringListSizeGet            (sysLibTrapCustom + 42)
00082 #define netPrefLibTrapRecPhoneStringCompose             (sysLibTrapCustom + 43)
00083 #define netPrefLibTrapUtilPlatformIDGet                 (sysLibTrapCustom + 44)
00084 #define netPrefLibTrapUtilDefWirelessDriverIDGet        (sysLibTrapCustom + 45)
00085 #define netPrefLibTrapRecLongFieldGet                   (sysLibTrapCustom + 46)
00086 /*@}*/
00087
00088 #endif /* __NET_PREF_LIB_TRAPS_H__ */
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:54 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » netpref

NetPrefLibTypes.h

Go to the documentation of this file.
00001 /******************************************************************************
00002  * Copyright (c) 2004 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  *****************************************************************************/
00005 /**
00006  * @ingroup NETPREF
00007  */
00008
00009 /**
00010  * @file    NetPrefLibTypes.h
00011  * @version 1.0
00012  * @date    12/12/2001
00013  *
00014  * @brief This file contains public data types exported by the NetPref Library
00015  *
00016  */
00017
00018 /*
00019  * @private author   Vitaly Kruglikov
00020  */
00021
00022
00023 #ifndef _NET_PREF_LIB_TYPES_H_
00024 #define _NET_PREF_LIB_TYPES_H_
00025
00026 /**
00027  * @name Current library API version number
00028  * @brief Returned by NetPrefLibVersionGet()
00029  */
00030 /*@{*/
00031 #define netPrefLibVersionMajor    0
00032 #define netPrefLibVersionMinor    2
00033 #define netPrefLibVersionBugFix   0
00034 /*@}*/
00035
00036 // Changes by minor version number:
00037 //
00038 // 0.1 -- original
00039 // 0.2 -- added functions from NetPrefUtils.c to NetPrefLib API - this
00040 //        change obsoletes most functions in NetPrefUtils.c. The obsoleted
00041 //        functions in NetPrefUtils.c have been suppressed with conditional
00042 //        compillation directive.
00043
00044
00045
00046 // Opaque structures
00047 struct NetPrefContextTypeTag;
00048 struct NetPrefRecordTypeTag;
00049
00050
00051
00052 /** Record field identifiers */
00053 typedef UInt16 NetPrefRecFieldEnum;
00054
00055 /**
00056  * @name Required Macros for Record Field Identifier
00057  * @brief Define the required macros and then include NetPrefLibFieldInfoTable.h in
00058  *        order to define the record field indentifier values (see
00059  *        NetPrefLibFieldInfoTable.h for usage notes and currently defined fieldIDs)
00060  */
00061 /*@{*/
00062 #define NetPrefRecFieldInfoPreamble()
00063
00064 #define NetPrefRecFieldInfoFIRST(fieldID, idValue)      fieldID = idValue,
00065
00066 #define NetPrefRecFieldInfoGrpStart(fieldID, idValue)   fieldID = idValue,
00067
00068 #define NetPrefRecFieldInfoGrpEnd(fieldID)              fieldID,
00069
00070 #define NetPrefRecFieldInfoExtended(fieldID, idValue, type, maxSize, flags, tagText, tagSize) \
00071                                                         fieldID = idValue,
00072
00073 #define NetPrefRecFieldInfoLegacy(fieldID, idValue, type, maxSize, flags, tagText, tagSize) \
00074                                                         fieldID = idValue,
00075
00076 #define NetPrefRecFieldInfoLAST(fieldID)                fieldID
00077 /*@}*/
00078
00079 enum
00080   {
00081     // undefine this to insure the #include is always processed
00082     #ifdef __NETPREFLIBFIELDINFOTABLE_H__
00083         #undef __NETPREFLIBFIELDINFOTABLE_H__
00084     #endif
00085
00086     // See NetPrefLibFieldInfoTable.h for usage notes
00087     #include <NetPrefLibFieldInfoTable.h>
00088
00089     // In performing the following error check, we take advantage of
00090     // our inside knowledge that NetPrefLibFieldInfoTable.h undefines
00091     // the macros that we defined above
00092     #ifdef NetPrefRecFieldInfoLAST
00093       #error inclusion of NetPrefLibFieldInfoTable.h failed
00094     #endif
00095
00096   };
00097
00098
00099
00100 /** NetPref Record ID type */
00101 typedef UInt32  NetPrefRecIDType;
00102
00103
00104
00105 /** Field type identifiers */
00106 typedef UInt16  NetPrefFieldTypeEnum;
00107 enum
00108   {
00109     netPrefFieldTypeStr     = 1,  /**< ascii string -- size must include zero - terminator*/
00110     netPrefFieldTypeUInt8   = 2,
00111     netPrefFieldTypeUInt16  = 3,
00112     netPrefFieldTypeUInt32  = 4,
00113     netPrefFieldTypeBin     = 5,  /**< binary*/
00114     netPrefFieldTypeZStrList= 6   /**< string list: list of zero-terminated strings terminated by empty string. Size must include zero-terminator*/
00115   };
00116
00117 /** Service Medium identifiers (used with netPrefRecFieldSvcMediumAlias) */
00118 typedef UInt16 NetPrefSvcMediumEnum;
00119 enum
00120   {
00121     netPrefSvcMediumUnknown = 0,    /**< reserve 0*/
00122     netPrefSvcMediumDialUp  = 1,    /**< basic dial-up - communication driver selection determines service attributes [DEFAULT]*/
00123     netPrefSvcMediumDirect  = 2,    /**< basic, non-modem type of connection*/
00124     netPrefSvcMedium1xRTT   = 3,    /**< CDMA 3G PDP service*/
00125     netPrefSvcMediumGPRS    = 4,    /**< GSM 2.5G PDP service*/
00126     netPrefSvcMediumQNC     = 5,    /**< CDMA Quick Net Connect*/
00127     netPrefSvcMediumGISDN   = 6,    /**< GSM ISDN over CSD service*/
00128     netPrefSvcMediumGCSD    = 7,    /**< GSM circuit switched data service (AKA wireless dial-up)*/
00129     netPrefSvcMediumCCSD    = 8,    /**< CDMA circuit switched data service (AKA wireless dial-up)*/
00130     netPrefSvcMediumOEM     = 9,    /**< This service is a place-holder for an external OEM plugin*/
00131     netPrefSvcMediumLAST            /**< ALWAYS KEEP THIS ENTRY AT THE END!!!*/
00132   };
00133
00134 /** Service Binding identifiers (use with netPrefRecFieldBinding); */
00135 typedef UInt16 NetPrefSvcBindingEnum;
00136 enum
00137   {
00138     netPrefSvcBindingUnknown  = 0,  /**< reserve 0*/
00139     netPrefSvcBindingIOTA     = 1,  /**< Provisioned via IOTA*/
00140     netPrefSvcBindingCCSM     = 2,  /**< Default Wireless profile based on the CCSM tables */
00141     netPrefSvcBindingCustom   = 3,  /**< Created by user or "user agent" on behalf of the user [DEFAULT]*/
00142     netPrefSvcBindingLAST           /**< ALWAYS KEEP THIS ENTRY AT THE END!!!*/
00143   };
00144
00145
00146 /** 1xRTT Tunneling identifiers (use with netPrefRecField1xRTTTunneling) */
00147 typedef UInt16 NetPref1xRTTTunnelingEnum;
00148 enum
00149   {
00150     netPref1xRTTTunnelingUnknown = 0,   /**< reserve 0*/
00151     netPref1xRTTTunnelingReverse = 1,   /**< reverse tunneling*/
00152     netPref1xRTTTunnelingForward = 2,   /**< forward tunneling*/
00153     netPref1xRTTTunnelingLAST           /**< ALWAYS KEEP THIS ENTRY AT THE END!!!*/
00154   };
00155
00156 /** Default 1xRTT Tunneling value */
00157 #define netPref1xRTTTunnelingDefault  netPref1xRTTTunnelingReverse
00158
00159
00160 /**
00161  * Service Target identifiers used with NetPrefDefaultTargetGet()
00162  * and NetPrefDefaultTargetSet().
00163  *
00164  * NOTE: These values need to correlate with NetPrefSvcGatewayType.
00165  *
00166  * IMPORTANT: These settings are to be used
00167  * for carrier-provisioned services only, and are applied by the
00168  * system's configurator app!!!  Others MUST treat these settings
00169  * as read-only!
00170  */
00171 typedef UInt16 NetPrefSvcTargetEnum;
00172 enum
00173   {
00174     netPrefSvcTargetUnknown   = 0,  /**< reserve 0*/
00175     netPrefSvcTargetInternet  = 1,  /**< provides access to the Internet*/
00176     netPrefSvcTargetWAP       = 2,  /**< provides access to WAP*/
00177     netPrefSvcTargetReserved1 = 3,  /**< reserved*/
00178     netPrefSvcTargetMMS       = 4,  /**< provides access to MMS*/
00179     netPrefSvcTargetBrowser   = 5,  /**< provides access to Web via web browser*/
00180     netPrefSvcTargetMail      = 6,  /**< provides access to e-mail*/
00181     netPrefSvcTargetIM        = 7,  /**< provides access to Instant Messaging*/
00182     netPrefSvcTargetDownloads = 8,  /**< provides access to Downloads*/
00183     netPrefSvcTargetCorporate = 9,  /**< provides access to Corporate network*/
00184     netPrefSvcTargetPictureMail = 10, /**< provides access to Picture Mail*/
00185     netPrefSvcTargetLAST            /**< ALWAYS KEEP THIS ENTRY AT THE END!!!*/
00186   };
00187
00188 /** Record field view attributes bitwise-or'ed together */
00189 typedef UInt32  NetPrefRecFieldViewType;
00190
00191 /** @name Record File View Attributes */
00192 /*@{*/
00193 #define netPrefRecFieldViewRead     0x00000001UL  /**< read allowed by application*/
00194 #define netPrefRecFieldViewWrite    0x00000002UL  /**< write allowed by application*/
00195 #define netPrefRecFieldViewVisible  0x00000004UL  /**< field value is user-visible*/
00196 #define netPrefRecFieldViewEditable 0x00000008UL  /**< field value is user-editable*/
00197   /** Field value is stored exernally -- such as in the CCSM table, radio module's
00198    *  flash memory, etc., i.e. not in the NetPref database
00199    */
00200 #define netPrefRecFieldViewExternal 0x00000010UL
00201 #define netPrefRecFieldViewCache    0x00000020UL  /**< the external field value is cached locally*/
00202 #define netPrefRecFieldViewPrivate  0x00000040UL  /**< PRESENTLY NOT RESPECTED; If set, do not display the actual value to the user*/
00203 /*@}*/
00204
00205 // WARNING: THIS CONSTANT IS FOR INTERNAL USE ONLY -- IT WILL CHANGE
00206 // IN FUTURE VERSIONS!!! (used for error-checking only).
00207 #define netPrefRecFieldViewCurrentlyValidFlags      \
00208                     (   netPrefRecFieldViewRead     \
00209                       | netPrefRecFieldViewWrite    \
00210                       | netPrefRecFieldViewVisible  \
00211                       | netPrefRecFieldViewEditable \
00212                       | netPrefRecFieldViewExternal \
00213                       | netPrefRecFieldViewCache    \
00214                       | netPrefRecFieldViewPrivate)
00215
00216 /** Special value to pass in the flagsToClear parameter to NetPrefRecFieldViewSet in order to clear all field view flags */
00217 #define netPrefRecFieldViewClearAll 0xFFFFFFFFUL
00218
00219 /** Record field attributes (retrieved via NetPrefRecFieldAttrsGet) */
00220 typedef UInt32  NetPrefRecFieldAttrType;
00221
00222 /** @name Record File Attributes */
00223 /*@{*/
00224     /** R/O: set if the field's
00225      * data or flags are part of the record's field
00226      * set.
00227      */
00228     #define netPrefRecFieldAttrInSet    0x10000000UL
00229
00230     /** R/O: set if the field's
00231      * data or flags have been modified in the current
00232      * instance of the record object
00233      */
00234     #define netPrefRecFieldAttrDirty    0x20000000UL
00235 /*@}*/
00236
00237 /** Special values used with netPrefRecFieldCloseWaitTime.  Other, standard,
00238  *  values are expressed in milliseconds.
00239  *  IMPORTANT: Beginning with Palm OS 5.0, netPrefRecFieldInactivityTimer
00240  *  must be used to configure the idle timeout of the TCP/IP stack. The
00241  *  "CloseWait" settting is used to control NetLib's CloseWait behavior
00242  *  only
00243  */
00244 typedef UInt32 NetPrefNetCloseWaitEnum; // was NetPrefNetTimeoutEnum
00245 enum
00246   {
00247     /** Use this value to configure the network interface to be shut down
00248      * when the device (i.e. LCD screen) powers off.
00249      */
00250     netPrefNetCloseWaitEndOnPowerOff    = 0xffffffffUL, // was netPrefNetTimeoutOnPowerOff
00251
00252     /** Use this value to configure the network interface to *not* be shut down
00253      * when the device (i.e. LCD screen) powers off.
00254      */
00255     netPrefNetCloseWaitMaintainSession  = 0xfffffffeUL, // was netPrefNetTimeoutOnWirelessOff
00256
00257     /** Use this value to configure the CloseWait behavior with the carrier-
00258      * default value.
00259      */
00260     netPrefNetCloseWaitCarrierDefault   = 0xfffffffdUL  // was netPrefNetTimeoutCarrierDefault
00261   };
00262
00263
00264 /** Special values used with netPrefRecFieldInactivityTimer.
00265  *  Other, standard, values are expressed in seconds.
00266  */
00267 typedef UInt16 NetPrefNetIdleTimeoutEnum;
00268 enum
00269   {
00270     netPrefNetIdleTimeoutNever          = (UInt16) 0    /**< Never time out due to data idleness*/
00271   };
00272
00273
00274
00275 /** Record protection settings -- used with netPrefRecFieldRecProtection */
00276 typedef UInt32 NetPrefRecProtectionType;
00277 enum
00278   {
00279     /** Record deletion options*/
00280     netPrefRecProtectionDeletionMask                  = 0x00000007UL,
00281     netPrefRecProtectionDeletionAfterWarning          = 0x0UL,
00282     netPrefRecProtectionDeletionNotAllowed            = 0x1UL,
00283
00284
00285     /** Duplication options*/
00286     netPrefRecProtectionDuplicationMask               = (0x7UL << 3),
00287     netPrefRecProtectionDuplicationAllowed            = (0x0UL << 3),
00288     netPrefRecProtectionDuplicationNotAllowed         = (0x1UL << 3),
00289
00290
00291     /** Editing options*/
00292     netPrefRecProtectionEditingMask                   = (0x7UL << 6),
00293     netPrefRecProtectionEditingAllowed                = (0x0UL << 6),
00294     netPrefRecProtectionEditingNotAllowed             = (0x1UL << 6),
00295     netPrefRecProtectionEditingAfterWarning           = (0x2UL << 6)
00296   };
00297
00298
00299
00300 /**
00301  * Record Service gateway type -- used with netPrefRecFieldSvcGatewayType;
00302  * 1 or more values can be bitwise or'ed together to mark
00303  * a record as supporting those gateway types; absense of
00304  * any service type falgs implies Internet.
00305  *
00306  * NOTE: These values need to correlate with NetPrefSvcTargetEnum.
00307  *
00308  * IMPORTANT: These settings are to be used
00309  * for carrier-provisioned services only, and are applied by the
00310  * system's configurator app!!!  Others MUST treat these settings
00311  * as read-only!
00312  */
00313 typedef UInt32 NetPrefSvcGatewayType;
00314 enum
00315   {
00316     netPrefSvcGatewayUnknown        = 0UL,          /**< reserved*/
00317     netPrefSvcGatewayInternet       = 0x00000001UL, /**< Generic Internet "gateway"*/
00318     netPrefSvcGatewayWAP            = 0x00000002UL, /**< Generic WAP gateway*/
00319     netPrefSvcGatewayPrivate        = 0x00000004UL, /**< Application-specific "gateway"*/
00320     netPrefSvcGatewayMMS            = 0x00000008UL, /**< Generic MMS "gateway"*/
00321     netPrefSvcGatewayBrowser        = 0x00000010UL, /**< Web via web browser*/
00322     netPrefSvcGatewayMail           = 0x00000020UL, /**< e-mail*/
00323     netPrefSvcGatewayIM             = 0x00000040UL, /**< Instant Messaging*/
00324     netPrefSvcGatewayDownloads      = 0x00000080UL, /**< Downloads*/
00325     netPrefSvcGatewayCorporate      = 0x00000100UL, /**< Corporate network*/
00326     netPrefSvcGatewayPictureMail    = 0x00000200L,  /**< Picture Mail*/
00327
00328     netPrefSvcGatewayLAST             /**< ALWAYS KEEP THIS ENTRY AT THE END!!!*/
00329   };
00330
00331
00332 /**
00333  * @brief NetPrefGPRSQOSType -- GPRS Quality Of Service (QOS) info
00334  */
00335 typedef struct
00336   {
00337     // IMPORTANT: maintain this structure at fixed size; remove
00338     // space for new fields from the reserved fields, making sure
00339     // to adjust the reserved field size so the overall structure
00340     // size is preserved exactly.  Use reserved space wisely :-)
00341
00342     // NOTE: "ccsmCS_QOS..." in the following comments refers to Hanspring-
00343     // internal data structures.  Developer support will need to provide
00344     // clarification for the use of these fields.
00345
00346     Int8      qosReqPrecedenceClass;  /**< see ccsmCS_QOSReqPrecClassField*/
00347     Int8      qosReqDelayClass;       /**< see ccsmCS_QOSReqDelayClassField*/
00348     Int8      qosReqReliabilityClass; /**< see ccsmCS_QOSReqRelClassField*/
00349     Int8      qosReqPeakThruClass;    /**< see ccsmCS_QOSReqPeakThruClassField*/
00350     Int8      qosReqMeanThruClass;    /**< see ccsmCS_QOSReqMeanThruClassField*/
00351     Int8      qosMinPrecedenceClass;  /**< see ccsmCS_QOSMinPrecClassField*/
00352     Int8      qosMinDelayClass;       /**< see ccsmCS_QOSMinDelayClassField*/
00353     Int8      qosMinReliabilityClass; /**< see ccsmCS_QOSMinRelClassField*/
00354     Int8      qosMinPeakThruClass;    /**< see ccsmCS_QOSMinPeakThruClassField*/
00355     Int8      qosMinMeanThruClass;    /**< see ccsmCS_QOSMinMeanThruClassField*/
00356     Int8      pdpDataCompression;     /**< see ccsmCS_PDPDataComprField*/
00357     Int8      pdpHeaderCompression;   /**< see ccsmCS_PDPHeaderComprField*/
00358
00359     UInt32    reserved[4];            /**< Reserved by Handspring -- init to zero*/
00360   }
00361 NetPrefGPRSQOSType;
00362
00363
00364 /** Options for NetPrefRecFieldSetDefineStd and NetPrefRecFieldSetDefine */
00365 typedef UInt32    NetPrefFieldSetDefineOptionsType;
00366 enum
00367   {
00368     netPrefFieldSetDefineOptionNone = 0,        /**< Pass this value for "no options"*/
00369
00370     // If set, NetPrefRecFieldSetDefineStd and NetPrefRecFieldSetDefine
00371     // will temporarily keep around the data of out-of-set fields; however,
00372     // it will not save such data when saving the field; this feature
00373     // is a convenience for the Network panel that allows the user to
00374     // experiment with different connection mediuma (dial-up, direct, 3G, etc.)
00375     // without losing the data that is in one service medium's field set,
00376     // but not in another.
00377     netPrefFieldSetDefineOptionKeepData = 0x00000001UL
00378   };
00379
00380
00381
00382 // ----------------------------------------------------------------------------
00383 // Fallback info -- used with netPrefRecFieldFallbackInfo
00384 // ----------------------------------------------------------------------------
00385
00386 // NOTE: The Handspring NetMaster library implements the fallback logic.
00387
00388
00389 /** Fallback algorithm */
00390 typedef UInt8     NetPrefFallbackAlgrorithmEnum;
00391 enum
00392   {
00393     /**  Basic algorithm: each time: try primary; if fails, try fallback; */
00394     netPrefFallbackAlgrorithmBasic = 0,
00395
00396     /**
00397      * Mutually exclusive, sticky algorithm: The primary and fallback record
00398      * MUST be cross-linked -- each MUST specify the other as its fallback;
00399      * both records MUST also be tagged with this algorithm.  Regardless of
00400      * which of the cross-linked services is requested during login (unless
00401      * "primary only" is requested -- see NetMaster API), the algorithm will
00402      * attempt to connect with the one that succeeded last time. The first time
00403      * or if both failed last time, it will try the requested service first. If
00404      * the attempt fails, it will try the one specified as its fallback.
00405      */
00406     netPrefFallbackAlgrorithmMutexSticky = 1,
00407
00408
00409
00410     // ADD NEW VALUES *BEFORE* THIS ONE
00411     netPrefFallbackAlgrorithmLAST
00412   };
00413
00414
00415 typedef UInt8 NetPrefFallbackStatusFlagsType;
00416 enum
00417   {
00418     // If set, inidicates that NetPrefFallbackInfoType.status has
00419     // been initialized.
00420     netPrefFallbackStatusFlagInitialized = 0x01
00421
00422   };
00423
00424
00425 /** Flags used in the "Mutex Sticky" fallback algoritm status structure. */
00426 typedef UInt16 NetPrefMutexStickyFBAStatusEnum;
00427 enum
00428   {
00429     netPrefMutexStickyFBAStatusUnknown      = 0, /**< Indicates that the last login status of the corresponding network service is unknown.*/
00430
00431     netPrefMutexStickyFBAStatusFailed       = 1, /**< Indicates that the last login attempt using the corresponding network service failed.*/
00432
00433     netPrefMutexStickyFBAStatusSucceeded    = 2  /**< Indicates that the last login attempt using the corresponding network service succeeded.*/
00434   };
00435
00436
00437 /**
00438  * @brief Fallback info structure
00439  */
00440 typedef struct
00441   {
00442     /** Fallback algorithm ID.
00443      *
00444      * IMPORTANT: when changing fallback algorithm, the
00445      * caller MUST zero-initialize the rest of the NetPrefFallbackInfoType
00446      * structure.
00447      */
00448     NetPrefFallbackAlgrorithmEnum   algorithm;
00449
00450     /** Fallback algoritm status. There is a field here for every fallback
00451      * algorithm that requires status to be maintained.
00452      *
00453      * THIS STATUS STRUCTURE IS FOR USE BY THE HANDSPRING NetMaster LIBRARY
00454      * ONLY!!!
00455      */
00456     NetPrefFallbackStatusFlagsType  fbStatusFlags;
00457
00458     union
00459       {
00460         /** Status for netPrefFallbackAlgrorithmMutexSticky fallback algorithm */
00461         struct NetPrefMutexStickyFBAStatusTypeTag
00462           {
00463             NetPrefMutexStickyFBAStatusEnum  statusID;
00464           }
00465         mutexSticky;
00466
00467       }
00468     status;
00469   }
00470 NetPrefFallbackInfoType;
00471
00472
00473 // ----------------------------------------------------------------------------
00474 // Platform IDs
00475 // ----------------------------------------------------------------------------
00476 typedef UInt16    NetPrefPlatformEnum;
00477 enum
00478   {
00479     netPrefPlatformUnknown    = 0,
00480
00481     netPrefPlatformGSM        = 1,
00482     netPrefPlatformCDMA       = 2,
00483
00484     netPrefPlatformLAST
00485   };
00486
00487
00488
00489 /**
00490  * Max size of a phone number, *not including* zero-terminator
00491  */
00492  #define netPrefMaxPhoneStringSize 80
00493
00494
00495
00496 #endif // _NET_PREF_LIB_TYPES_H_
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:54 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » audio

PalmAudioPlayback.h

Go to the documentation of this file.
00001 /******************************************************************************
00002  * Copyright (c) 2004 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  *****************************************************************************/
00005 /**
00006  * @ingroup Sound
00007  *
00008  */
00009
00010 /**
00011  *
00012  * @file    PalmAudioPlayback.h
00013  *
00014  * @brief   Public 68K include file that supports the stopping of audio
00015  *          playback on Treo 600 and Treo 650 smartphones.
00016  *
00017  * This header file and associated header files support the specific sound
00018  * functionality of the Treo smartphones. You should use the Palm OS Sound
00019  * Manager APIs for most of your work.
00020  *
00021  * Notes:
00022  *   This header contains a notification to call for stopping any existing
00023  *   background audio playback.
00024  *
00025  *   Any application ( usually video capture ) that needs to stop and eventually resume
00026  *   audio playback should use this header. Stopping or resuming playback is done by
00027  *   throwing a notification.
00028  *
00029  *   Audio playback applications should register for this notification and stop playback
00030  *   when they get the stop action code. They can optionally resume action when they get
00031  *   a notification with a resume action code. However resume is not
00032  *   a mandatory feature neither for the calling application nor for the audio application.
00033  *   In other words, the audio application may never get a resume after a stop action code.
00034  *
00035  *   Usage for any application requesting stop of audio playback:
00036  *
00037  *   PalmAudioPlaybackRequestStop('cccc'); // to stop background playback
00038  *   PalmAudioPlaybackRequestResume('cccc'); // to resume background playback
00039  *
00040  *   The calling application should always load this library with
00041  *   SysLibLoad() before use, even if it is already open by another
00042  *   application(ie, SysLibFind() returns a valid refnum). When
00043  *   the application is done with the library, it should be
00044  *   unloaded with SysLibRemove(). We do this because there is
00045  *   no good way to synchronize loading and unloading of libraries
00046  *   among multiple applications. It also greatly simplifies internal
00047  *   synchronization.
00048  */
00049
00050
00051 #ifndef __PalmAudioPlayback_H__
00052 #define __PalmAudioPlayback_H__
00053
00054 /***********************************************************************
00055  * Palm OS common definitions
00056  ***********************************************************************/
00057 #include <PalmTypes.h>
00058 #include <SystemMgr.h>
00059 #include <NotifyMgr.h>
00060 #include <MemoryMgr.h>
00061
00062 /**
00063  * @name PalmAudioPlayback information and notification
00064  *
00065  */
00066
00067 /*@{*/
00068 #define kPalmAudioPlaybackNotify1 sysMakeROMVersion(1, 0, 0, sysROMStageRelease, 0)
00069
00070 /** Version of the PalmAudioPlayback library. */
00071 #define kPalmAudioPlaybackNotifyVersion kPalmAudioPlaybackNotify1
00072
00073 /** PalmAudioPlayback creator ID. */
00074 #define kPalmAudioPlaybackCreator 'apbP'
00075
00076 /** Playback notification event ID.
00077  *
00078  *  Applications playing audio should register for this notification
00079  *  and stop or optionally resume playback depending on the action code the application receives.
00080  */
00081 #define kPalmAudioPlaybackNotifyEvent kPalmAudioPlaybackCreator
00082 /*@}*/
00083
00084 /** Holds action codes for the kPalmAudioPlaybackNotifyEvent broadcast. */
00085 typedef UInt16 PalmAudioPlaybackActionCodeType;
00086
00087 /**
00088  * @name Audio playback action codes
00089  *
00090  */
00091
00092 /*@{*/
00093 /** Playback stop action code. */
00094 #define kPalmAudioPlaybackActionCodeRequestStop     ((PalmAudioPlaybackActionCodeType)1)
00095
00096 /** Playback resume action code. */
00097 #define kPalmAudioPlaybackActionCodeRequestResume    ((PalmAudioPlaybackActionCodeType)2)
00098 /*@}*/
00099
00100 /** Audio playback notification structure.
00101  *
00102  *  Structure that is sent as part of notifyDetailsP when a kPalmAudioPlaybackNotifyEvent
00103  *  is thrown.
00104  */
00105 typedef struct PalmAudioPlaybackNotifyEventTypeTag
00106 {
00107     UInt32 version;                             /**< Version. */
00108     PalmAudioPlaybackActionCodeType actionCode; /**< Action code. */
00109     void* dataP;                                /**< Data for action code, currently NULL. */
00110 } PalmAudioPlaybackNotifyEventType;
00111
00112 /**
00113  * @name Audio playback helper macros
00114  *
00115  */
00116 /*@{*/
00117 #define PalmAudioPlaybackRequestStop(creator) \
00118     { \
00119         PalmAudioPlaybackNotifyEventType request = \
00120         { \
00121             kPalmAudioPlaybackNotifyVersion, \
00122             kPalmAudioPlaybackActionCodeRequestStop, \
00123             0 \
00124         }; \
00125         PalmAudioPlaybackSendRequest(&request, creator); \
00126     }
00127     /**<Request to stop playback. Any application that needs to request a stop of
00128         audio playback should use this macro. "creator" is the creator id of the calling
00129         function. */
00130
00131 #define PalmAudioPlaybackRequestResume(creator) \
00132     { \
00133         PalmAudioPlaybackNotifyEventType request = \
00134         { \
00135             kPalmAudioPlaybackNotifyVersion, \
00136             kPalmAudioPlaybackActionCodeRequestResume, \
00137             0 \
00138         }; \
00139         PalmAudioPlaybackSendRequest(&request, creator); \
00140     }
00141     /**<Request to resume playback. Any application that needs to request that
00142         audio playback be resumed should use this macro. "creator" is the creator id of the calling
00143         function. */
00144
00145 #define PalmAudioPlaybackSendRequest(requestP, creator) \
00146     { \
00147         SysNotifyParamType      notify; \
00148         MemSet(&notify, sizeof(SysNotifyParamType), 0); \
00149         notify.notifyType       = kPalmAudioPlaybackNotifyEvent; \
00150         notify.broadcaster      = creator; \
00151         notify.notifyDetailsP   = (void*)requestP; \
00152         SysNotifyBroadcast(&notify); \
00153     }
00154     /**<Actual broadcast of kPalmAudioPlaybackNotifyEvent notification. Used by Stop and
00155         Resume macros. */
00156 /*@}*/
00157
00158 #endif // __PalmAudioPlayback_H__
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:54 2008 for Palm API Guide


Header Files » Incs » 68k » system

PalmBGService.h

Go to the documentation of this file.
00001 /*******************************************************************************
00002  * Copyright (c) 2004-2005 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  ******************************************************************************/
00005 /**
00006  * @defgroup    BGService Background Service Library
00007  * @brief       This library provides support for applications to perform background
00008  *              network request bypassing NetLib through the default connection.
00009  *
00010  * Application can use this library to connect to a server on a network and perform
00011  * network request by sending protocol-specific string and receiving the returned response.
00012  * Applications can also utilize this library to make background HTTP request by connecting
00013  * to a web server at port 80 and sending HTTP GET/POST string with specific URL.
00014  *
00015  * Network requests are queued up and the responses are returned through the callback function
00016  * that is passed to the network request API.
00017  *
00018  * @{
00019  * @}
00020  */
00021 /**
00022  * @ingroup BGService
00023  */
00024
00025 /**
00026  * @file    PalmBGService.h
00027  * @version 1.0
00028  * @brief   Public 68K header file for palmOne Background Network Service Library
00029  *
00030  * This file contains the function prototypes and structures for the Background Service which
00031  *        lets users make a background network connection.
00032  * <hr>
00033  */
00034
00035 #ifndef __PALMBGSERVICE_H__
00036 #define __PALMBGSERVICE_H__
00037
00038 #include <PalmTypes.h>
00039 #include <LibTraps.h>
00040
00041
00042 /**
00043  * @name Function Traps
00044  *
00045  */
00046 /*@{*/
00047 #define bgTrapAPIVersion            (sysLibTrapCustom+0)    /**<        */
00048 #define bgTrapCancelRqst            (sysLibTrapCustom+1)    /**<        */
00049 #define bgTrapINetLibRqst           (sysLibTrapCustom+3)    /**<        */
00050 #define bgTrapNetLibRqst            (sysLibTrapCustom+4)    /**<        */
00051 /*@}*/
00052
00053 /**
00054  * @name Library Constants
00055  *
00056  */
00057 /*@{*/
00058 #define bgServiceLibName        "BGService.Lib"     /**< Background services library name. */
00059 #define bgServiceCreatorID      'asc9'          /**< Background services Creator ID. */
00060 #define bgServiceType           'appl'          /**< Background services Type. */
00061 /*@}*/
00062
00063
00064 /**
00065  * @name Error Codes
00066  *
00067  */
00068 /*@{*/
00069 #define IBG_SUCCESS         0   /**< Return Value indicating success.*/
00070
00071
00072 #define IBG_ERRNOTPOSSIBLE  2   /**< Return Value indicating on i705 that radio is NOT on or WebClipping is
00073                   *  NOT configured in i705 Wireless panel.
00074                                   */
00075
00076 #define IBG_ERRTIMEOUT      3   /**< Return Value indicating the request made could not be
00077                   *  completed because of a network timeout, or request took longer than
00078                   *  20 minutes to complete for BGServiceNetRqst() or greater than 2
00079                   *  minutes for BGServiceINetRqst().
00080                                   */
00081
00082 #define IBG_ERRREQUEST      4   /**< Return Value indicating an error occurred processing the request.  If
00083                   *  a network error occurred, look at the protocolErr and protocolErrString
00084                   *  members in the returned BGResult value for details.
00085                                   */
00086
00087
00088
00089 #define IBG_ERRRSPTOOBIG    6   /**< Return Value indicating the response handle passed with the request is not
00090                   *  large enough to contain the response gotten from the server.  In this case
00091                   *  a partial response may be contained in the response handle, but it is
00092                   *  truncated.
00093                                   */
00094
00095 #define IBG_ERRSHUTDOWN     7   /**< Return Value indicating the BGService cannot process the request due to a
00096                   *  HotSync or systen reset occurring
00097                                   */
00098
00099 #define IBG_ERRRQSTDONE     8   /**< Return Value indicating a request cannot be cancelled with BGServiceCancelRqst()
00100                   *  because the request was already started.
00101                                   */
00102
00103 #define IBG_MAXBUFSZ        100   /**< Maximum size of protocolErrString. */
00104 /*@}*/
00105
00106 /**
00107  * @brief Structure containing Result of response for a protocol request
00108  */
00109 typedef struct
00110 {
00111     UInt32  majorResult;                      /**< One of the above defined return values */
00112     UInt32  protocolErr;                      /**< Any protocol specific error code, if any */
00113     char    protocolErrString[IBG_MAXBUFSZ];  /**< Any protocol err response from the server */
00114
00115 } BGResult;
00116
00117
00118 /********************************************************************
00119  * Prototypes
00120  ********************************************************************/
00121 #ifdef __cplusplus
00122 extern "C" {
00123 #endif
00124
00125 /**
00126  * @brief Opens the Background Service library.
00127  *    This function should be called prior to calling the other Background Service functions.
00128  *
00129  * @param libRefNum:    IN:  Reference number of the Background Service library.
00130  * @return The error code returned from the library. If this is errNone, the
00131  *     function was sucessful.
00132  *
00133  * @code
00134  * UInt16 bgServiceLibRefNum = 0;
00135  * err = SysLibFind(bgServiceLibName, &bgServiceLibRefNum);
00136  * if( err == sysErrLibNotFound )
00137  * {
00138  *     err = SysLibLoad(bgServiceType, bgServiceCreatorID, &bgServiceLibRefNum);
00139  *         if( !err ) {
00140  *             err = BGServiceOpen(bgServiceLibRefNum);
00141  *         }
00142  * } @endcode
00143  *
00144  * @see BGServiceClose
00145  */
00146 extern Err BGServiceOpen( UInt16 libRefNum )
00147                 SYS_TRAP( sysLibTrapOpen );
00148
00149 /**
00150  * @brief Closes the Background Service library.
00151  *    This function should be called after your application has finished with the Background Service
00152  *    library.
00153  *
00154  * @param libRefNum:    IN:  Reference number of the Background Service  library.
00155  * @return The error code returned from the library. If this is errNone, the
00156  *     function was sucessful.
00157  *
00158  * @code
00159  * err = BGServiceClose(bgServiceLibRefNum);@endcode
00160  *
00161  * @see BGServiceOpen
00162  */
00163 extern Err BGServiceClose( UInt16 libRefNum )
00164                 SYS_TRAP( sysLibTrapClose );
00165
00166 /**
00167  * @brief Returns the version number of Background Service
00168  *
00169  * @param libRefNum:    IN:  Reference number of the library.
00170  * @param pversion: IN:  Pointer to version number returned
00171  *
00172  * @return Always IBG_SUCCESS
00173  */
00174 extern Err BGServiceVersion( UInt16 libRefNum, UInt32 *pversion )
00175                 SYS_TRAP( bgTrapAPIVersion );
00176
00177
00178 /**
00179  * @brief Cancels a current request identified by the Request id
00180  *
00181  * @param libRefNum:    IN:  Reference number of the library.
00182  * @param rqstId:   IN:  Request ID of the BgRequest to be cancelled.
00183  *
00184  * @return IBG_SUCCESS on success, otherwise IBG_ERRRQSTDONE if request
00185  *         was not found or has begun already.
00186  */
00187 extern Err BGServiceCancelRqst( UInt16 libRefNum, UInt32 rqstId )
00188                 SYS_TRAP( bgTrapCancelRqst );
00189
00190
00191 /**
00192  * @brief Background Request's Response Callback function.
00193  *
00194  * @param rqstId    IN:  Request id that identifies a particular request the response is for
00195  * @param presult   IN:  Contains the response protocol error message if any.
00196  * @param responseH IN:  Handle to the response string.
00197  * @param respSz    IN:  Size of response
00198  * @param opaque    IN:  Opaque value passed back to the callback, can be used for userdata
00199  * @return One of the IBG_xxx return codes defined above.  Currently any return
00200  *         value is ignored.
00201  */
00202 typedef UInt32 ( * BGRecvResponseFP )( UInt32 rqstId, BGResult *presult, MemHandle *responseH,
00203                                        UInt32 respSz, UInt32* opaque );
00204
00205
00206 /**
00207  *
00208  * @brief Perform a INetLib request via the HTTP POST command
00209  *
00210  * @param libRefNum:    IN:  Reference number of the library.
00211  * @param purl:     IN:  Url of server to issue request to.  Formatted for INetLibURLCrack command
00212  * @param ppostBuf:     IN:  Any post data for request, formatted for INetLibSockHTTPReqSend command -
00213  *                           No additional formatting is performed.
00214  * @param precvFunc:    IN:  Response callback function
00215  * @param opaque:   IN:  Opaque value passed back to callback routine when called
00216  * @param respH:    IN:  Pre-allocated memory handle to hold response.  Must be big enough to hold
00217  *                           largest response ( for INet typically less than 10K )
00218  * @param prqstId:  IN:  Returned id given to request for later identification or canceling
00219  *
00220  * @return IBG_SUCCESS if accepted, otherwise another error code defined above
00221  */
00222 extern Err BGServiceINetRqst( UInt16 libRefNum, char *purl, char *ppostBuf, BGRecvResponseFP precvFunc,
00223                               UInt32 opaque, MemHandle respH, UInt32 *prqstId )
00224                 SYS_TRAP( bgTrapINetLibRqst );
00225
00226 /**
00227  *
00228  * @brief Perform a NetLib request on the default network connection ( for now )
00229  *
00230  * @param libRefNum:    IN:  Reference number of the library.
00231  * @param notUsed:  IN:  Always pass NULL.
00232  * @param pserver:  IN:  Server to issue request to.  Hostnames are looked up via DNS calls,
00233  *                           although slows down requests.  Better to use IP addresses if possible.
00234  * @param port:     IN:  Port to make call on
00235  * @param prqst:    IN:  Protocol specific string to make once connection is made to server.
00236  * @param pterm:    IN:  Server response terminator to look for to know have gotten complete
00237  *                           response from server, or 0 if don't have a terminator.  Of course
00238  *                           using a terminator greatly speeds up receiving response.
00239  * @param precvFunc:    IN:  Response callback function
00240  * @param opaque:   IN:  Opaque value passed back to callback routine when called
00241  * @param reserved: IN:  Reserved for future use, must always be 0
00242  * @param respH:    IN:  Pre-allocated memory handle to hold response.  Must be big enough to hold
00243  *                           largest response ( for INet typically less than 10K )
00244  * @param prqstId:  IN:  Returned id given to request for later identification or canceling
00245  *
00246  * @return IBG_SUCCESS if accepted, otherwise another error code defined above
00247  ***/
00248 extern Err BGServiceNetRqst( UInt16 libRefNum, char *notUsed, char *pserver, UInt16 port,
00249                              char *prqst, char *pterm, BGRecvResponseFP precvFunc, UInt32 opaque,
00250                              UInt8 reserved, MemHandle respH, UInt32 *prqstId )
00251                 SYS_TRAP( bgTrapNetLibRqst );
00252
00253
00254
00255
00256 #ifdef __cplusplus
00257 }
00258 #endif
00259
00260 #endif // __PALMBGSERVICE_H__
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:54 2008 for Palm API Guide


Header Files » Incs » common » system

PalmCreators.h

Go to the documentation of this file.
00001 /******************************************************************************
00002  * Copyright (c) 2005 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  *****************************************************************************/
00005 /**
00006  *@ingroup System
00007  *
00008  */
00009
00010 /**
00011  * @file    PalmCreators.h
00012  * @version 1.0
00013  * @date    02/29/2002
00014  *
00015  * @brief Contains Palm-specific creator codes.
00016  *
00017  *    Temporary shim to the new filename and location.
00018  *
00019  * <hr>
00020  */
00021
00022 #ifndef __PALMCREATORS_H__
00023 #define __PALMCREATORS_H__
00024
00025 #include <Common/System/palmOneCreators.h>
00026
00027
00028 #endif  // __PALMCREATORS_H__
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:54 2008 for Palm API Guide


Header Files » Incs » 68k » system

PalmDisplayExtent.h

Go to the documentation of this file.
00001 /******************************************************************************
00002  * Copyright (c) 2005 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  *****************************************************************************/
00005 /**
00006  * @defgroup DispExt Display Extent Library
00007  *
00008  * @{
00009  * @}
00010  */
00011 /**
00012  * @ingroup DispExt
00013  *
00014  */
00015
00016 /**
00017  * @file    PalmDisplayExtent.h
00018  * @version 1.0
00019  *
00020  * @brief Public API for the Display Extent Library.
00021  *
00022  *
00023  * <hr>
00024  */
00025
00026
00027 #ifndef __PALMDISPLAYEXTENT_H__
00028 #define __PALMDISPLAYEXTENT_H__
00029
00030 #include <PalmTypes.h>
00031 #include <LibTraps.h>
00032
00033 /**
00034  * @name Library type and creator
00035  *
00036  */
00037 /*@{*/
00038 #define dexLibName          "rotmgr"        /**< PalmDisplayExtent library name. */
00039 #define dexLibCreator       'rotM'              /**< PalmDisplayExtent Creator ID. */
00040 #define dexLibType          sysFileTLibrary     /**< PalmDisplayExtent type. */
00041 #define dexFtrNumVersion    (0)             /**< PalmDisplayExtent feature number. */
00042 /*@}*/
00043
00044
00045 /**
00046  * @name Library Traps
00047  *
00048  */
00049 /*@{*/
00050 #define kDexLibTrapOpen             sysLibTrapOpen      /**<        */
00051 #define kDexLibTrapClose            sysLibTrapClose     /**<        */
00052
00053
00054 #define kDexLibTrapDexGetDisplayAddress     (sysLibTrapCustom + 4)  /**<        */
00055 #define kDexLibTrapDexGetDisplayDimensions  (sysLibTrapCustom + 5)  /**<        */
00056 /*@}*/
00057
00058 /********************************************************************
00059  * Prototypes
00060  ********************************************************************/
00061 #ifdef __cplusplus
00062 extern "C" {
00063 #endif
00064
00065 /**
00066  * @brief Get the physical screen buffer (Display Address).
00067  *
00068  *
00069  * @param refnum:   IN:  Reference number of the Display Extent Manager library.
00070  *
00071  * @retval Returns a pointer to the physical screen buffer.
00072  *
00073  * @remarks You should only use this function if direct screen access is required.
00074  *      This function returns a pointer to the physical display.
00075  *      If you need to do direct screen access in 90, 180, and 270 rotation, use this function.
00076  *      If you use the regular APIs (eg something like BmpGetBits(WinGetBimatp(WinDisplay())))
00077  *      you would get a back buffer pointer instead and would not see anything until you force
00078  *      a screen copy of this back buffer. Note that the address points to the top-left corner
00079  *          of the device in potrait mode always.
00080  * @code
00081  *      // this code draws 6400 red pixels in the screen.
00082  *
00083  *      RGBColorType color = { 0, 255, 0, 0 };
00084  *      IndexedColorType index = WinRGBToIndex(&color);
00085  *      UInt8 *bufferP = (UInt8*)DexGetDisplayAddress(gDexLibRefNum);
00086  *      UInt32 x = 0;
00087  *
00088  *      for( x = 0; x < 6400; x++)
00089  *           bufferP[x] = index;
00090  *@endcode
00091  *
00092  */
00093 void *DexGetDisplayAddress(UInt16 refnum)
00094                 SYS_TRAP(kDexLibTrapDexGetDisplayAddress);
00095
00096 /**
00097  * @brief Get the physical screen width, height, and rowbytes.
00098  *
00099  *
00100  * @param refnum:   IN:  Reference number of the Display Extent Manager library.
00101  * @param width     IN:  Pointer to the width of the screen.
00102  * @param height    IN:  Pointer to the height of the screen.
00103  * @param rowBytes  IN:  Pointer to the rowbytes of the screen.
00104  *
00105  * @retval Nothing
00106  *
00107  */
00108 void DexGetDisplayDimensions(UInt16 refnum, Coord *width, Coord *height, UInt16 *rowBytes)
00109                 SYS_TRAP(kDexLibTrapDexGetDisplayDimensions);
00110
00111 #ifdef __cplusplus
00112 }
00113 #endif
00114
00115 #endif
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:54 2008 for Palm API Guide


Header Files » Incs » 68k » system

PalmErrorBase.h

Go to the documentation of this file.
00001 /******************************************************************************
00002  * Copyright (c) 2005 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  *****************************************************************************/
00005 /**
00006  * @defgroup System System API
00007  *
00008  * @{
00009  * @}
00010  */
00011 /**
00012  *@ingroup System
00013  *
00014  */
00015
00016 /**
00017  * @file    PalmErrorBase.h
00018  * @version 1.0
00019  *
00020  * @brief Include file for Error Management
00021  *
00022  *
00023  * <hr>
00024  */
00025
00026
00027
00028 #ifndef __PALMERRORBASE_H__
00029 #define __PALMERRORBASE_H__
00030
00031 #include "ErrorBase.h"
00032
00033 #define oemErrorClass               0x7000  /**< OEM/Licensee errors (0x7000-0x7EFF shared among ALL partners) */
00034
00035
00036 /**
00037  * @name Error Classes for OEM components
00038  *
00039  */
00040 /*@{*/
00041 #define softGraffitErrorClass   (oemErrorClass | 200)       /**<        */
00042 #define statusBarErrorClass     (oemErrorClass | 300)   /**<        */
00043 /*@}*/
00044 #endif // __PALMERRORBASE_H__
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:54 2008 for Palm API Guide


Header Files » Incs » common » system

PalmFeatures.h

Go to the documentation of this file.
00001 /******************************************************************************
00002  * Copyright (c) 2005 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  *****************************************************************************/
00005 /**
00006  *@ingroup System
00007  *
00008  */
00009
00010 /**
00011  * @file    PalmFeatures.h
00012  * @version 1.0
00013  * @date    02/29/2002
00014  *
00015  * @brief Contains Palm-specific feature definitions.
00016  *
00017  *    Temporary shim to the new filename and location.
00018  *
00019  * <hr>
00020  */
00021
00022 #ifndef __PALMFEATURES_H__
00023 #define __PALMFEATURES_H__
00024
00025 #include <Common/System/palmOneFeatures.h>
00026
00027
00028 #endif // __PALMFEATURES_H__
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:54 2008 for Palm API Guide


Header Files » Incs » 68k » system

PalmGoLCD.h

Go to the documentation of this file.
00001 /******************************************************************************
00002  * Copyright (c) 2005 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  *****************************************************************************/
00005 /**
00006  * @ingroup GoLCD
00007  *
00008  */
00009
00010 /**
00011  * @file    PalmGoLCD.h
00012  * @version 1.1
00013  *
00014  * @brief Public include header file for the GoLCD Library.
00015  *
00016  *    You can use the functions in this API to enable or disable fullscreen
00017  *    writing, enable and disable the Graffiti 2 shift indicator (GSI) as a control for
00018  *    full-screen writing, enable and disable Graffiti 2 inking, and even change the colors
00019  *    of Graffiti 2 inking and the GSI.
00020  *
00021  *    You can check whether the GoLCD Manager is installed by examining its feature set.
00022  *    Call FtrGet as follows:
00023  * @code err = FtrGet (goLcdCreator, goLcdFtrNumVersion, &value); @endcode
00024  *
00025  *
00026  * <hr>
00027  */
00028
00029
00030 #ifndef __PALMGOLCD_H__
00031 #define __PALMGOLCD_H__
00032
00033 #include <PalmTypes.h>
00034 #include <LibTraps.h>
00035
00036 #include <Common/System/PalmGoLCDCommon.h>
00037
00038
00039 /********************************************************************
00040  * Prototypes
00041  ********************************************************************/
00042 #ifdef __cplusplus
00043 extern "C" {
00044 #endif
00045
00046 /**
00047  * @brief Opens the GoLCD library.
00048  *        This function should be called prior to calling the other GoLCD functions.
00049  *
00050  * @param libRefNum:    IN:  Reference number of the GoLCD library.
00051  * @retval Err The error code returned from the library. If this is errNone, the
00052  *     function was sucessful.
00053  *
00054  * @code
00055  * UInt16 gGoLcdLibRefNum = 0;
00056  * err = SysLibFind(goLcdLibName, &gGoLcdLibRefNum);
00057  * if( err == sysErrLibNotFound )
00058  * {
00059  *     err = SysLibLoad(goLcdLibType, goLcdLibCreator, &gGoLcdLibRefNum);
00060  *         if( !err ) {
00061  *             err = GoLcdLibOpen(gGoLcdLibRefNum);
00062  *         }
00063  * } @endcode
00064  *
00065  * @see GoLcdLibClose
00066  */
00067 Err GoLcdLibOpen(UInt16 libRefNum)
00068                 SYS_TRAP(kGoLcdLibTrapOpen);
00069
00070 /**
00071  * @brief Closes the GoLCD library.
00072  *    This function should be called after your application has finished with the GoLCD
00073  *    library.
00074  *
00075  * @param libRefNum:    IN:  Reference number of the GoLCD library.
00076  * @retval Err The error code returned from the library. If this is errNone, the
00077  *     function was sucessful.
00078  *
00079  * @code
00080  * err = GoLcdLibClose(gGoLcdLibRefNum);
00081  * if( err == errNone )
00082  *     err = SysLibRemove(gGoLcdLibRefNum); @endcode
00083  *
00084  * @see GoLcdLibOpen
00085  */
00086 Err GoLcdLibClose(UInt16 libRefNum)
00087                 SYS_TRAP(kGoLcdLibTrapClose);
00088
00089 /**
00090  * @brief Returns whether the GoLCD functionality is enabled, disabled, or not available on
00091  *    this device.
00092  *
00093  * @param libRefNum:    IN:  Reference number of the GoLCD library.
00094  * @retval GoLcdStatusType Returns the current GoLCD status.
00095  *
00096  * @see GoLcdStatusType
00097  *
00098  * @code
00099  * GoLcdStatusType gCurrentGoLcdStatus = goLcdNotAvailable;
00100  * gCurrentGoLcdStatus = GoLcdGetStatus(gGoLcdLibRefNum);
00101  * switch(gCurrentGoLcdStatus) {
00102  *     case goLcdDisabled:
00103  *         // GoLcd is disabled
00104  *         break;
00105  *     case goLcdEnabled:
00106  *         // GoLcd is Enabled
00107  *         break;
00108  *     case goLcdNotAvailable:
00109  *     default:
00110  *         // Not available
00111  *         break;
00112  * } @endcode
00113  *
00114  * @see GoLcdSetStatus
00115  */
00116 GoLcdStatusType GoLcdGetStatus(UInt16 libRefNum)
00117                 SYS_TRAP(kGoLcdLibTrapGetStatus);
00118
00119 /**
00120  * @brief Enables or disables the GoLCD functionality.
00121  *
00122  * @param libRefNum:    IN:  Reference number of the GoLCD library.
00123  * @param status    IN:  Sets the new GoLCD status.
00124  * @retval GoLcdStatusType Returns the previous GoLCD status.
00125  *
00126  * @code
00127  * GoLcdStatusType gPreviousGoLcdStatus = goLcdNotAvailable;
00128  * gPreviousGoLcdStatus = GoLcdSetStatus(gGoLcdLibRefNum, goLcdEnabled); @endcode
00129  *
00130  * @see GoLcdGetStatus
00131  */
00132 GoLcdStatusType GoLcdSetStatus(UInt16 libRefNum, GoLcdStatusType status)
00133                 SYS_TRAP(kGoLcdLibTrapSetStatus);
00134
00135 /**
00136  * @brief Returns the current state of GoLCD inking.
00137  *
00138  * @param libRefNum:    IN:  Reference number of the GoLCD library.
00139  * @param stateP:   IN:  Points to the returned GoLCD ink state.
00140  * @param colorModeP:   IN:  Points to the returned GoLCD color mode for ink.
00141  * @param rgbP:     IN:  Valid only if colorMode is set to goLcdColorOverride. Points to an RGB color
00142  *               value corresponding to the current color used for inking. (The RGBColorType is
00143  *               defined in the header file Bitmap.h.)
00144  *
00145  * @code
00146  * GoLcdInkStateType gCurrentGoLcdInkState = goLcdInkDisabled;
00147  * GoLcdColorModeType gCurrentGoLcdColorMode = goLcdColorDefault;
00148  * RGBColorType gCurrentColor;
00149  * GoLcdGetInkState(gGoLcdLibRefNum, &gCurrentGoLcdInkState, &gCurrentGoLcdColorMode, &gCurrentColor); @endcode
00150  *
00151  * @see GoLcdSetInkState
00152  */
00153 void GoLcdGetInkState(UInt16 libRefNum, GoLcdInkStateType *stateP, GoLcdColorModeType *colorModeP, RGBColorType *rgbP)
00154                 SYS_TRAP(kGoLcdLibTrapGetInkState);
00155
00156 /**
00157  * @brief Sets the state of GoLCD inking.
00158  *
00159  * @param libRefNum:    IN:  Reference number of the GoLCD library.
00160  * @param state:    IN:  Sets the new GoLCD ink state.
00161  * @param colorMode:    IN:  Sets the new GoLCD color mode for ink.
00162  * @param rgbP:     IN:  Valid only if colorMode is set to goLcdColorOverride. Points to an RGB color
00163  *               value corresponding to the current color used for inking. (The RGBColorType is
00164  *               defined in the header file Bitmap.h.)
00165  *
00166  * @remarks <em>Inking</em>, also known as <em>echoing</em>, refers to the drawing of Graffiti 2 strokes in the
00167  *          application area of the display.
00168  *
00169  * @code
00170  * RGBColorType gNewColor = { 0, 255, 0, 0}; // Red
00171  * GoLcdSetInkState(gGoLcdLibRefNum, goLcdInkEnabled, goLcdColorOverride, &gNewColor); @endcode
00172  *
00173  * @see GoLcdGetInkState
00174  */
00175 void GoLcdSetInkState(UInt16 libRefNum, GoLcdInkStateType state, GoLcdColorModeType colorMode, RGBColorType *rgbP)
00176                 SYS_TRAP(kGoLcdLibTrapSetInkState);
00177
00178 /**
00179  * @brief Returns the GSI state associated with GoLCD.
00180  *
00181  * @param libRefNum:    IN:  Reference number of the GoLCD library.
00182  * @param stateP:   IN:  Points to the returned GoLCD GSI state.
00183  * @param colorModeP:   IN:  Points to the returned GoLCD color mode for GSI.
00184  * @param rgbP:     IN:  Valid only if colorMode is set to goLcdColorOverride. Points to an RGB color
00185  *               value corresponding to the current color used for inking. (The RGBColorType is
00186  *               defined in the header file Bitmap.h.)
00187  *
00188  * @remarks In normal operation, the GSI is drawn in the lower-right portion of the screen when
00189  *          the user enters the shift keystroke. The functionality of the GSI can be changed into
00190  *          an enable and disable control for GoLCD. This function returns the current state of
00191  *          the GSI.
00192  *
00193  * @code
00194  * GoLcdGsiStateType gCurrentGoLcdGsiState = goLcdGsiNormal;
00195  * GoLcdColorModeType gCurrentGoLcdColorMode = goLcdColorDefault;
00196  * RGBColorType gCurrentColor;
00197  * GoLcdGetGsiState(gGoLcdLibRefNum, &gCurrentGoLcdGsiState, &gCurrentGoLcdColorMode, &gCurrentColor); @endcode
00198  *
00199  * @see GoLcdSetGsiState
00200  */
00201 void GoLcdGetGsiState(UInt16 libRefNum, GoLcdGsiStateType *stateP, GoLcdColorModeType *colorModeP, RGBColorType *rgbP)
00202                 SYS_TRAP(kGoLcdLibTrapGetGsiState);
00203
00204 /**
00205  * @brief Sets the GSI state associated with GoLCD.
00206  *
00207  * @param libRefNum:    IN:  Reference number of the GoLCD library.
00208  * @param state:    IN:  Sets the GoLCD GSI state.
00209  * @param colorMode:    IN:  Sets the GoLCD color mode for GSI.
00210  * @param rgbP:     IN:  Valid only if colorMode is set to goLcdColorOverride. Points to an RGB color
00211  *               value corresponding to the current color used for inking. (The RGBColorType is
00212  *               defined in the header file Bitmap.h.)
00213  *
00214  * @remarks In normal operation, the GSI is drawn in the lower-right portion of the screen when
00215  *          the user enters the shift keystroke. The functionality of the GSI can be changed into
00216  *          an enable and disable control for GoLCD. This function determines whether the
00217  *          GSI is converted into a GoLCD control. This setting will apply to all GSIs in any
00218  *          active form.
00219  *
00220  * @code
00221  * RGBColorType gNewColor = { 0, 255, 0, 0}; // Red
00222  * GoLcdSetGsiState(gGoLcdLibRefNum, goLcdGsiOverride, goLcdColorOverride, &gNewColor); @endcode
00223  *
00224  * @see GoLcdGetGsiState
00225  */
00226 void GoLcdSetGsiState(UInt16 libRefNum, GoLcdGsiStateType state, GoLcdColorModeType colorMode, RGBColorType *rgbP)
00227                 SYS_TRAP(kGoLcdLibTrapSetGsiState);
00228
00229 /**
00230  * @brief Returns the length, in system ticks, of the time-out value of GoLCD.
00231  *
00232  * @param libRefNum:    IN:  Reference number of the GoLCD library.
00233  * @param mode:     IN:  Specifies the GoLCD mode.
00234  * @retval UInt32 Returns the length (in system ticks) of the time-out value.
00235  *
00236  * @remarks GoLCD starts in goLcdPenTapMode. When a penDownEvent is received, a timer is
00237  *          started. If a penUpEvent is received before the timer reaches the time-out value for
00238  *          this mode, the pen events are passed on to the event handler for the application
00239  *          control. Otherwise, if the pen events exceed the time-out value and the x, y
00240  *          coordinates change significantly, GoLCD enters goLcdGraffitiMode and treats the
00241  *          pen events as a Graffiti 2 stroke.
00242  *          <br> The default time-out value for goLcdPenTapMode is 15 system ticks, or
00243  *          150 milliseconds.
00244  *          <br> When it enters goLcdGraffitiMode, GoLCD continuously interprets all pen events
00245  *          as Graffiti 2 strokes. There is a time-out value associated with goLcdGraffitiMode,
00246  *          however. If it does not receive a new pen event within the allotted time, it returns
00247  *          to goLcdPenTapMode.
00248  *          <br> The default time-out value for goLcdGraffitiMode is 150 system ticks, or
00249  *          1500 milliseconds.
00250  *
00251  * @code
00252  * UInt32 gCurrentTimeout = GoLcdGetTimeout(gGoLcdLibRefNum, goLcdPenTapMode); @endcode
00253  *
00254  * @see GoLcdSetTimeout
00255  */
00256 UInt32 GoLcdGetTimeout(UInt16 libRefNum, GoLcdModeType mode)
00257                 SYS_TRAP(kGoLcdLibTrapGetTimeout);
00258
00259 /**
00260  * @brief Sets the length, in system ticks, of the time-out value of GoLCD.
00261  *
00262  * @param libRefNum:    IN:  Reference number of the GoLCD library.
00263  * @param mode:     IN:  Specifies the GoLCD mode.
00264  * @param ticks:    IN:  The new time-out length in system ticks.
00265  *
00266  * @retval UInt32 Returns the length (in system ticks) of the previous time-out value.
00267  *
00268  * @remarks GoLCD starts in goLcdPenTapMode. When a penDownEvent is received, a timer is
00269  *          started. If a penUpEvent is received before the timer reaches the time-out value for
00270  *          this mode, the pen events are passed on to the event handler for the application
00271  *          control. Otherwise, if the pen events exceed the time-out value and the x, y
00272  *          coordinates change significantly, GoLCD enters goLcdGraffitiMode and treats the
00273  *          pen events as a Graffiti 2 stroke.
00274  *          <br> The default time-out value for goLcdPenTapMode is 15 system ticks, or
00275  *          150 milliseconds.
00276  *          <br> When it enters goLcdGraffitiMode, GoLCD continuously interprets all pen events
00277  *          as Graffiti 2 strokes. There is a time-out value associated with goLcdGraffitiMode,
00278  *          however. If it does not receive a new pen event within the allotted time, it returns
00279  *          to goLcdPenTapMode.
00280  *          <br> The default time-out value for goLcdGraffitiMode is 150 system ticks, or
00281  *          1500 milliseconds.
00282  *
00283  * @code
00284  * UInt32 gPreviousTimeout = GoLcdSetTimeout(gGoLcdLibRefNum, goLcdPenTapMode, 100); @endcode
00285  *
00286  * @see GoLcdGetTimeout
00287  */
00288 UInt32 GoLcdSetTimeout(UInt16 libRefNum, GoLcdModeType mode, UInt32 ticks)
00289                 SYS_TRAP(kGoLcdLibTrapSetTimeout);
00290
00291 /**
00292  * @brief Returns the current bounds defined for use with GoLCD.
00293  *
00294  * @param libRefNum:    IN:  Reference number of the GoLCD library.
00295  * @param rectP:    IN:  Points to the returned rectangle.
00296  *
00297  * @remarks GoLCD ignores any succession of pen events (a series of penDownEvents followed
00298  *          by a penUpEvent) if the initial penDownEvent occurs outside its bounds. By default,
00299  *          its bounds are the entire display and users can start drawing full-screen writing
00300  *          characters anywhere except for the right-most scroll bar and the menu bar area.
00301  *
00302  * @code
00303  * RectangleType gCurrentBounds;
00304  * GoLcdGetBounds(gGoLcdLibRefNum, &gCurrentBounds); @endcode
00305  *
00306  * @see GoLcdSetBounds
00307  */
00308 void GoLcdGetBounds(UInt16 libRefNum, RectangleType *rectP)
00309                 SYS_TRAP(kGoLcdLibTrapGetBounds);
00310
00311 /**
00312  * @brief Sets the bounds defined for use with GoLCD.
00313  *
00314  * @param libRefNum:    IN:  Reference number of the GoLCD library.
00315  * @param rectP:    IN:  Points to the rectangle value to set.
00316  *
00317  *
00318  * @remarks GoLCD ignores any succession of pen events (a series of penDownEvents followed
00319  *          by a penUpEvent) if the initial penDownEvent occurs outside its bounds. By default,
00320  *          its bounds are the entire display and users can start drawing full-screen writing
00321  *          characters anywhere except for the right-most scroll bar and the menu bar area.
00322  *
00323  * @code
00324  * RectangleType gNewBounds = { { 0, 0 } , { 50, 50 } };
00325  * GoLcdGetBounds(gGoLcdLibRefNum, &gNewBounds); @endcode
00326  *
00327  * @see GoLcdGetBounds
00328  */
00329 void GoLcdSetBounds(UInt16 libRefNum, RectangleType *rectP)
00330                 SYS_TRAP(kGoLcdLibTrapSetBounds);
00331
00332 #ifdef __cplusplus
00333 }
00334 #endif
00335
00336 #endif  //__PALMGOLCD_H__
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:54 2008 for Palm API Guide


Header Files » Incs » common » system

PalmGoLCDCommon.h

Go to the documentation of this file.
00001 /*******************************************************************************
00002  * Copyright (c) 2004-2005 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  ******************************************************************************/
00005 /**
00006  * @defgroup    GoLCD Full Screen Writing API
00007  * @brief       This library provides support for applications to enable/disable
00008  *              full screen graffiti programmatically.
00009  *
00010  * Applications can use the functions in this library to enable or disable fullscreen
00011  *    writing, enable and disable the Graffiti 2 shift indicator (GSI) as a control for
00012  * fullscreen writing, enable and disable Graffiti 2 inking, and even change the colors
00013  *    of Graffiti 2 inking and the GSI.
00014  *
00015  * Developers can check whether the GoLCD Manager is installed by examining its feature set.
00016  *    Call FtrGet as follows:
00017  *    @code err = FtrGet (goLcdCreator, goLcdFtrNumVersion, &value); @endcode
00018  *
00019  * @{
00020  * @}
00021  */
00022 /**
00023  * @ingroup GoLCD
00024  */
00025
00026 /**
00027  * @file    PalmGoLCDCommon.h
00028  * @version 1.0
00029  * @brief Public common header file for the GoLCD Library.
00030  *
00031  * This file contains the library constants and structures that hold different states of
00032  * the fullscreen feature, graffiti indicators, inking and the colors.
00033  * <hr>
00034  */
00035
00036 #ifndef __PALMGOLCD_COMMON_H__
00037 #define __PALMGOLCD_COMMON_H__
00038
00039 #include <PalmTypes.h>
00040
00041
00042 /**
00043  * @name Library Constants
00044  *
00045  */
00046 /*@{*/
00047 #define goLcdLibName          "GoLcdLib"    /**< GoLCD library name. */
00048 #define goLcdLibType          'libr'        /**< GoLCD library type. */
00049 #define goLcdLibCreator       'GAny'        /**< GoLCD creator ID. */
00050 #define goLcdLibFtrNum         0        /**< GoLCd feature number. */
00051 /*@}*/
00052
00053 #define goLcdCreator        'GAny'      /**< Feature creator ID */
00054 #define goLcdFtrNumVersion  0           /**< Current version of the supported features */
00055
00056 /**
00057  * Notification code that applications can register for when the status
00058  * of Full Screen Writing (GoLCD) is changed.
00059  */
00060 #define goLcdNotifyStatusEvent  'GAny'
00061
00062
00063 /**
00064  * GoLCD Status.
00065  * One of the following: goLcdNotAvailable, goLcdDisabled, goLcdEnabled
00066  */
00067 typedef Int32 GoLcdStatusType;
00068
00069 /**
00070  * @name Feature Status
00071  */
00072 /*@{*/
00073 #define goLcdNotAvailable      -1       /**< GoLCD not available on this device. */
00074 #define goLcdDisabled           0   /**< GoLCD functionality is disabled. */
00075 #define goLcdEnabled            1   /**< GoLCD functionality is enabled. */
00076 /*@}*/
00077
00078 /**
00079  * GoLCD Ink State.
00080  * One of the following: goLcdInkDisabled, goLcdInkEnabled
00081  */
00082 typedef Int32 GoLcdInkStateType;
00083
00084 /**
00085  * @name Ink States
00086  */
00087 /*@{*/
00088 #define goLcdInkDisabled        0   /**< GoLCD inking is disabled. */
00089 #define goLcdInkEnabled         1   /**< GoLCD inking is enabled. */
00090 /*@}*/
00091
00092 /**
00093  * GoLCD Timeout Mode.
00094  * One of the following: goLcdGraffitiMode, goLcdPenTapMode
00095  */
00096 typedef UInt32 GoLcdModeType;
00097
00098 /**
00099  * When it enters goLcdGraffitiMode, GoLCD continuously
00100  * interprets all pen events as Graffiti 2 strokes. There is a timeout
00101  * value associated with goLcdGraffitiMode, however. If it
00102  * does not receive a new pen event within the allotted time, it
00103  * returns to goLcdPenTapMode.
00104  * <br>
00105  * The default time-out value for goLcdGraffitiMode is
00106  * 150 system ticks, or 1500 milliseconds.
00107  */
00108 #define goLcdGraffitiMode       0
00109
00110 /**
00111  * GoLCD starts in goLcdPenTapMode. When a penDownEvent is
00112  * received, a timer is started. If a penUpEvent is received before
00113  * the timer reaches the time-out value for this mode, the pen
00114  * events are passed on to the event-handler for the application
00115  * control. Otherwise, if the pen events exceed the time-out
00116  * value and the x, y coordinates change significantly, GoLCD
00117  * enters goLcdGraffitiMode and treats the pen events as a
00118  * Graffiti 2 stroke.
00119  * <br>
00120  * The default time-out value for goLcdPenTapMode is 15 system
00121  * ticks, or 150 milliseconds.
00122  */
00123 #define goLcdPenTapMode         1
00124
00125 /** Two modes are currently supported */
00126 #define goLcdModeCount          2
00127
00128
00129 /**
00130  * GoLCD GSI State.
00131  * One of the following: goLcdGsiNormal, goLcdGsiOverride
00132  */
00133 typedef UInt32 GoLcdGsiStateType;
00134
00135 #define goLcdGsiNormal          0   /**< GSI is handled as normal. */
00136 #define goLcdGsiOverride        1   /**< GoLCD overrides the GSI with its own control. */
00137
00138
00139 /**
00140  * GoLCD Color Mode.
00141  * One of the following: goLcdColorDefault, goLcdColorOverride, goLcdColorInverted
00142  */
00143 typedef UInt32 GoLcdColorModeType;
00144
00145 #define goLcdColorDefault       0   /**< Use the default color scheme. */
00146 #define goLcdColorOverride      1   /**< Use the specified color (passed in as a separate argument). */
00147 #define goLcdColorInverted      2   /**< Use only with ink color. Inverts the color of the display area beneath the Graffiti 2 stroke. */
00148
00149 /**
00150  * @name Function Traps
00151  *
00152  */
00153 /*@{*/
00154 #define kGoLcdLibTrapOpen               sysLibTrapOpen
00155 #define kGoLcdLibTrapClose              sysLibTrapClose
00156
00157 #define kGoLcdLibTrapGetStatus          (sysLibTrapCustom)
00158 #define kGoLcdLibTrapSetStatus          (sysLibTrapCustom+1)
00159 #define kGoLcdLibTrapGetInkState        (sysLibTrapCustom+2)
00160 #define kGoLcdLibTrapSetInkState        (sysLibTrapCustom+3)
00161 #define kGoLcdLibTrapGetTimeout         (sysLibTrapCustom+4)
00162 #define kGoLcdLibTrapSetTimeout         (sysLibTrapCustom+5)
00163 #define kGoLcdLibTrapGetBounds          (sysLibTrapCustom+6)
00164 #define kGoLcdLibTrapSetBounds          (sysLibTrapCustom+7)
00165 #define kGoLcdLibTrapGetGsiState        (sysLibTrapCustom+8)
00166 #define kGoLcdLibTrapSetGsiState        (sysLibTrapCustom+9)
00167 /*@}*/
00168
00169 /** Current library version */
00170 #define GoLcdLibAPIVersion          (sysMakeROMVersion(3, 6, 0, sysROMStageBeta, 0))
00171
00172
00173 #endif  //__PALMGOLCD_COMMON_H__
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:54 2008 for Palm API Guide


Header Files » Incs » 68k » system

PalmHiResTime.h

Go to the documentation of this file.
00001 /******************************************************************************
00002  * Copyright (c) 2005 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  *****************************************************************************/
00005 /**
00006  * @ingroup HiRes
00007  *
00008  */
00009
00010 /**
00011  * @file    PalmHiResTime.h
00012  * @version 1.0
00013  *
00014  * @brief Exported High Resolution timer definitions.
00015  *
00016  *
00017  * <hr>
00018  */
00019
00020
00021
00022 #ifndef __PalmHiResTime_H__
00023 #define __PalmHiResTime_H__
00024
00025 // Palm OS common definitions
00026 #include <PalmTypes.h>
00027 #include <ErrorBase.h>
00028 #include <SystemMgr.h>
00029
00030 // To Define when building the library
00031 #if (CPU_TYPE != CPU_68K) || (defined BUILDING_CAM_LIB)
00032     #define ARM_NATIVECODE          /**<        */
00033     #define CAM_LIB_TRAP(trapNum)       /**<        */
00034 #else
00035     #include <LibTraps.h>
00036     #define CAM_LIB_TRAP(trapNum) SYS_TRAP(trapNum)     /**<        */
00037 #endif
00038
00039 /**
00040  * @name Type and creator of the Library
00041  *
00042  */
00043 /*@{*/
00044 #define     kHiResTimeLibType       'libr'          /**< database type */
00045 #define     kHiResTimeLibCreator    'pHRT'              /**< database creator */
00046 /*@}*/
00047
00048 /** Internal library name which can be passed to SysLibFind() */
00049 #define     kHiResTimeLibName       "HRTimer-Lib"
00050
00051 /**
00052  * @name Library versionning
00053  *
00054  */
00055 /*@{*/
00056 #define     kHiResTimeLibVersion1   sysMakeROMVersion(1, 0, 0, sysROMStageRelease, 0)   /**<        */
00057 #define     kHiResTimeLibVersion    kCamLibVersion1         /**<        */
00058 /*@}*/
00059
00060 /** HiRes Timer result codes */
00061 #define kHiResTimeErrorClass            (oemErrorClass + 0x100)
00062
00063 /**
00064  * @name Library trap
00065  *
00066  */
00067 /*@{*/
00068 #define kHRLibTrapTimerTicksPerSecond   (sysLibTrapCustom)          /**<        */
00069 #define kHRLibTrapTimerGetTime          (sysLibTrapCustom+1)        /**<        */
00070 /*@}*/
00071
00072 /***********************************************************************
00073  * API Prototypes
00074  ***********************************************************************/
00075
00076 #ifdef __cplusplus
00077 extern "C" {
00078 #endif
00079
00080 #ifndef ARM_NATIVECODE
00081
00082 /**
00083  * @brief Standard library open function
00084  *
00085  * @param refNum:   IN:
00086  * @retval Err error code.
00087  **/
00088 extern Err HRTimeLibOpen(UInt16 refNum)
00089     CAM_LIB_TRAP(sysLibTrapOpen);
00090
00091 /**
00092  * @brief Standard library close function
00093  *
00094  * @param refNum:   IN:
00095  * @retval Err error code.
00096  **/
00097 extern Err HRTimeLibClose(UInt16 refNum)
00098     CAM_LIB_TRAP(sysLibTrapClose);
00099
00100 /**
00101  * @brief Custom library API functions
00102  *
00103  * @param refNum:   IN:
00104  * @param *ticksP:  IN:
00105  * @retval Err error code.
00106  **/
00107 extern Err HRTimeLibTicksPerSecond(UInt16 refNum, UInt32 *ticksP )
00108     CAM_LIB_TRAP(kHRLibTrapTimerTicksPerSecond);
00109
00110 /**
00111  * @brief
00112  *
00113  * @param refNum:   IN:
00114  * @param *ticksP:  IN:
00115  * @param *rolloverP:   IN:
00116  * @retval Err error code.
00117  **/
00118 extern Err HRTimeLibGetTime(UInt16 refNum, UInt32 *ticksP, UInt32 *rolloverP)
00119     CAM_LIB_TRAP(kHRLibTrapTimerGetTime);
00120
00121 #else
00122 /**
00123  * @brief Currently only used by 68K app.  ARM code can directly call to the HAL
00124  *     functions.  The HAL function prototypes are included here.
00125  *
00126  * @param *ticksP:  IN:
00127  * @retval Err error code.
00128  **/
00129 Err HRTimeLibTicksPerSecond( UInt32 *ticksP );
00130
00131 /**
00132  * @brief
00133  *
00134  * @param *ticksP:  IN:
00135  * @param *rolloverP:   IN:
00136  * @retval Err error code.
00137  **/
00138 Err HRTimeLibGetTime( UInt32 *ticksP, UInt32 *rolloverP );
00139
00140 #endif
00141
00142
00143 #ifdef __cplusplus
00144 }
00145 #endif
00146
00147 #endif // __PalmHiResTime_H__
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:54 2008 for Palm API Guide


Header Files » Incs » 68k » system

PalmLaunchCodes.h

Go to the documentation of this file.
00001 /******************************************************************************
00002  * Copyright (c) 2005 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  *****************************************************************************/
00005 /**
00006  *@ingroup System
00007  *
00008  */
00009
00010 /**
00011  * @file    PalmLaunchCodes.h
00012  * @version 1.0
00013  * @date    03/20/2003
00014  *
00015  * @brief Device specific launch codes.
00016  *
00017  *
00018  * <hr>
00019  */
00020
00021
00022 #ifndef __PALMLAUNCHCODES_H__
00023 #define __PALMLAUNCHCODES_H__
00024
00025 #if defined(__arm__)
00026 #include "CmnLaunchCodes.h"
00027 #else
00028 #include "SystemMgr.h"
00029 #endif
00030
00031 /**
00032  * @name Launch commands
00033  *
00034  */
00035 /*@{*/
00036 #define devAppLaunchCmdCustomBase       (sysAppLaunchCmdCustomBase + 1)     /**< Custom action code base */
00037
00038 #define devAppLaunchCmdGenericCall      (devAppLaunchCmdCustomBase  + 1)    /**< Used when an application wants to launch another application, then to be re-launched when the service is finished */
00039 #define devAppLaunchCmdIncomingCall     (devAppLaunchCmdCustomBase  + 2)    /**<        */
00040 #define devAppLaunchCmdCallerId         (devAppLaunchCmdCustomBase  + 3)    /**<        */
00041 #define devAppLaunchCmdTelPowerOn       (devAppLaunchCmdCustomBase  + 4)    /**<        */
00042 #define devAppLaunchMyFavorite          (devAppLaunchCmdCustomBase  + 4)    /**<        */
00043 #define devAppLaunchCmdIncomingCallTest     (devAppLaunchCmdCustomBase  + 5)    /**<        */
00044 #define devAppLaunchCmdSliderOpened     (devAppLaunchCmdCustomBase  + 6)    /**<        */
00045 #define devAppLaunchCmdSliderClosed     (devAppLaunchCmdCustomBase  + 7)    /**<        */
00046 #define devAppLaunchLauncherDUBegin     (devAppLaunchCmdCustomBase  + 8)    /**<        */
00047 #define devAppLaunchLauncherDUEnd       (devAppLaunchCmdCustomBase  + 9)    /**<        */
00048 #define devAppLaunchLPCM_DUBegin        (devAppLaunchCmdCustomBase  + 10)   /**<        */
00049 #define devAppLaunchLPCM_DUEnd          (devAppLaunchCmdCustomBase  + 11)   /**<        */
00050 #define devAppLaunchWithCodeCheck       (devAppLaunchCmdCustomBase  + 12)   /**<        */
00051 #define sysAppLaunchCmdFromSetupApp     (devAppLaunchCmdCustomBase  + 13)   /**< Used to lock a Panel (panel cannot stop except with Done) */
00052 /*@}*/
00053
00054 /**
00055  * Parameter blocks for action codes
00056  **/
00057
00058 /**
00059  * @brief For devAppLaunchCmdGenericCall
00060  *
00061  **/
00062 typedef struct {
00063     UInt32  senderCreatorId;        /**< IN: the creator ID of the calling code resource */
00064     void*       userDataP;      /**< IN: pointer to custom data (optional) */
00065     UInt8       operation;      /**< IN: one of the sysAppLaunchGenericCallOp<operation> codes */
00066     UInt8       response;       /**< IN: set to 0; OUT: one of the sysAppLaunchGenericCallRet<response> codes, or 0 if not handled */
00067 } DevAppLaunchCmdGenericCallType;
00068
00069 /**
00070  * @name Applicable operation code values:
00071  *
00072  */
00073 /*@{*/
00074 #define devAppLaunchGenericCallOpSubcall    ((UInt8)1)  /**< the sender wishes to launch the handler */
00075 #define devAppLaunchGenericCallOpExit       ((UInt8)2)  /**< the launched code resource replies that it won't launch the caller back */
00076 #define devAppLaunchGenericCallOpReturn     ((UInt8)3)  /**< the sub-call is finished, the launched code resource is ready to launch the caller back */
00077 #define devAppLaunchGenericCallOpCustomBase ((UInt8)0x80)   /**< custom operation code base (custom codes begin at this value) */
00078 /*@}*/
00079
00080 /**
00081  * @name Applicable response code values:
00082  *
00083  */
00084 /*@{*/
00085 #define devAppLaunchGenericCallRetAccepted  ((UInt8)1)  /**< request accepted by the handler */
00086 #define devAppLaunchGenericCallRetRejected  ((UInt8)2)  /**< request rejected by the handler */
00087 /*@}*/
00088
00089
00090 #endif // __PALMLAUNCHCODES_H__
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:54 2008 for Palm API Guide


Header Files » Incs » 68k » system

PalmLcdOverlay.h

Go to the documentation of this file.
00001 /******************************************************************************
00002  * Copyright (c) 2005 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  *****************************************************************************/
00005 /**
00006  * @ingroup LcdOverlay
00007  *
00008  */
00009
00010 /**
00011  * @file    PalmLcdOverlay.h
00012  * @version 1.0
00013  *
00014  * @brief Exported LCD Overlay functions
00015  *
00016  *
00017  * <hr>
00018  */
00019
00020
00021 #ifndef __PalmLcdOverlay_H__
00022 #define __PalmLcdOverlay_H__
00023
00024 // Palm OS common definitions
00025 #include <PalmTypes.h>
00026 #include <ErrorBase.h>
00027 #include <SystemMgr.h>
00028
00029
00030 /**
00031  * @name To Define when building the library
00032  *
00033  */
00034 /*@{*/
00035 #if (CPU_TYPE != CPU_68K) || (defined BUILDING_OVLY_LIB)
00036     #define ARM_NATIVECODE          /**<        */
00037     #define OVLY_LIB_TRAP(trapNum)      /**<        */
00038 #else
00039     #include <LibTraps.h>
00040     #define OVLY_LIB_TRAP(trapNum) SYS_TRAP(trapNum)    /**<        */
00041 #endif
00042 /*@}*/
00043
00044
00045 /**
00046  * @name Type and creator of the Library
00047  *
00048  */
00049 /*@{*/
00050 #define     kLcdOverlayLibType      'libr'      /**< database type */
00051 #define     kLcdOverlayLibCreator   'Povl'          /**< database creator */
00052 /*@}*/
00053
00054 /**
00055  * @name Internal library name which can be passed to SysLibFind()
00056  *
00057  */
00058 /*@{*/
00059 #define     kLcdOverlayLibName      "LcdOverlayManager" /**<        */
00060 /*@}*/
00061
00062 /**
00063  * @name Library versionning
00064  *
00065  */
00066 /*@{*/
00067 #define     kLcdOverlayLibVersion1  sysMakeROMVersion(1, 0, 0, sysROMStageRelease, 0)   /**<        */
00068 #define     kLcdOverlayLibVersion   kLcdOverlayLibVersion1                  /**<        */
00069 /*@}*/
00070
00071 /**
00072  * @name LCD Overlay result codes
00073  *    (appErrorClass is reserved for 3rd party apps/libraries.
00074  *    It is defined in SystemMgr.h)
00075  *
00076  */
00077 /*@{*/
00078 #define kLcdOverlayLibErrorClass    (oemErrorClass + 0x200)                 /**<        */
00079 #define kLcdOverlayLibErrBadParam           (kLcdOverlayLibErrorClass | 0x01)   /**< invalid parameter */
00080 #define kLcdOverlayLibErrNoMemory           (kLcdOverlayLibErrorClass | 0x02)   /**< Memory error */
00081 #define kLcdOverlayLibErrNotOpen            (kLcdOverlayLibErrorClass | 0x03)   /**< library is not open */
00082 #define kLcdOverlayLibErrStillOpen          (kLcdOverlayLibErrorClass | 0x04)   /**< returned from LcdOverlayLibClose() if the library is still open */
00083 #define kLcdOverlayLibErrInternal           (kLcdOverlayLibErrorClass | 0x05)   /**< Internal error */
00084 #define kLcdOverlayLibErrNotSupported       (kLcdOverlayLibErrorClass | 0x06)       /**< Unsupported function */
00085 #define kLcdOverlayLibErrNotCompatible      (kLcdOverlayLibErrorClass | 0x07)       /**< Bad Version */
00086 /*@}*/
00087
00088 /***********************************************************************
00089  * Constants - control commands
00090  ***********************************************************************/
00091
00092 /**
00093  * @name Command definition
00094  *
00095  */
00096 /*@{*/
00097 #define kLcdOverlayLibCtrlFormatSet         0x01    /**< Parameter as LcdOverlayLibFormatType* */
00098 #define kLcdOverlayLibCtrlFormatGet         0x02    /**< Parameter as LcdOverlayLibFormatType* */
00099 #define kLcdOverlayLibCtrlFormatQuery           0x03    /**< Parameter as LcdOverlayLibFormatType* */
00100
00101 #define kLcdOverlayLibCtrlRectSet           0x04    /**< Parameter as RectangleType* (low res coords) */
00102 #define kLcdOverlayLibCtrlRectGet           0x05    /**< Parameter as RectangleType* (low res coords) */
00103
00104 #define kLcdOverlayLibCtrlStart             0x06    /**< No parameter */
00105 #define kLcdOverlayLibCtrlDraw              0x07    /**< Parameter as void* */
00106 #define kLcdOverlayLibCtrlStop              0x08    /**< No parameter */
00107 /*@}*/
00108
00109 typedef UInt16 LcdOverlayLibControlType;        /**<        */
00110
00111 /***********************************************************************
00112  * Constants - Capabilities Settings
00113  ***********************************************************************/
00114
00115 /**
00116  * @brief Generic settings
00117  *        For settings without manual values, only type is used
00118  **/
00119 typedef struct LcdOverlayLibSettingTag
00120 {
00121     UInt32 type;        /**< For Manual, use constant below */
00122     Int32 value;        /**< For manual only */
00123     Int32 minValue;     /**< This value is used for Get/Query Only and is valid for Manual value */
00124     Int32 maxValue;     /**< This value is used for Get/Query Only and is valid for Manual value */
00125 } LcdOverlayLibSettingType;
00126
00127 /**
00128  * @name Overlay data format
00129  *
00130  */
00131 /*@{*/
00132 #define kLcdOverlayLibDataFormatYCbCr444        0x02    /**<        */
00133 #define kLcdOverlayLibDataFormatYCbCr422        0x04    /**<        */
00134 #define kLcdOverlayLibDataFormatYCbCr420        0x08    /**<        */
00135
00136 #define kLcdOverlayLibDataFormatYCbCr444Planar  0x10        /**<        */
00137 #define kLcdOverlayLibDataFormatYCbCr422Planar  0x20        /**<        */
00138 #define kLcdOverlayLibDataFormatYCbCr420Planar  0x40        /**<        */
00139
00140 #define kLcdOverlayLibDataFormatRGB565          0x80    /**<        */
00141 /*@}*/
00142
00143 typedef struct LcdOverlayLibSettingTag      LcdOverlayLibFormatType;    /**<        */
00144
00145 /**
00146  * @name Library trap
00147  *
00148  */
00149 /*@{*/
00150 #define kLcdOverlayLibTrapGetVersion        (sysLibTrapCustom + 0)      /**<        */
00151 #define kLcdOverlayLibTrapControl       (sysLibTrapCustom + 1)      /**<        */
00152 /*@}*/
00153
00154 /***********************************************************************
00155  * API Prototypes
00156  ***********************************************************************/
00157
00158 #ifdef __cplusplus
00159 extern "C" {
00160 #endif
00161
00162 #ifndef ARM_NATIVECODE
00163
00164 /**
00165  * @brief Standard library open function
00166  *
00167  * @param refNum:   IN:
00168  * @retval Err error code.
00169  **/
00170 extern Err LcdOverlayLibOpen(UInt16 refNum)
00171     OVLY_LIB_TRAP(sysLibTrapOpen);
00172
00173 /**
00174  * @brief Standard library close function
00175  *
00176  * @param refNum:   IN:
00177  * @retval Err error code.
00178  **/
00179 extern Err LcdOverlayLibClose(UInt16 refNum)
00180     OVLY_LIB_TRAP(sysLibTrapClose);
00181
00182 /**
00183  * @brief
00184  *
00185  * @param refNum:   IN:
00186  * @retval Err error code.
00187  **/
00188 extern Err LcdOverlayLibSleep(UInt16 refNum)
00189     OVLY_LIB_TRAP(sysLibTrapSleep);
00190
00191 /**
00192  * @brief
00193  *
00194  * @param refNum:   IN:
00195  * @retval Err error code.
00196  **/
00197 extern Err LcdOverlayLibWake(UInt16 refNum)
00198     OVLY_LIB_TRAP(sysLibTrapWake);
00199
00200 /**
00201  * @brief Custom library API functions
00202  *
00203  * @param refNum:   IN:
00204  * @param sdkVersion:   IN:
00205  * @param libVersionP:  IN:
00206  * @retval Err error code.
00207  **/
00208 extern Err LcdOverlayLibGetVersion(UInt16 refNum, UInt32 sdkVersion, UInt32* libVersionP)
00209     OVLY_LIB_TRAP(kLcdOverlayLibTrapGetVersion);
00210
00211 /**
00212  * @brief
00213  *
00214  * @param refNum:   IN:
00215  * @param cmdId:    IN:
00216  * @param parameterP:   IN:
00217  * @retval Err error code.
00218  **/
00219 extern Err LcdOverlayLibControl(UInt16 refNum, LcdOverlayLibControlType cmdId, void* parameterP)
00220     OVLY_LIB_TRAP(kLcdOverlayLibTrapControl);
00221
00222 #else
00223
00224 /**
00225  * Prototype used when building ARM Native Library.
00226  **/
00227 /**
00228  * @brief
00229  *
00230  * @retval Err error code.
00231  **/
00232 extern Err LcdOverlayLibOpen(void);
00233
00234 /**
00235  * @brief
00236  *
00237  * @retval Err error code.
00238  **/
00239 extern Err LcdOverlayLibClose(void);
00240
00241 /**
00242  * @brief
00243  *
00244  * @retval Err error code.
00245  **/
00246 extern Err LcdOverlayLibSleep(void);
00247
00248 /**
00249  * @brief
00250  *
00251  * @retval Err error code.
00252  **/
00253 extern Err LcdOverlayLibWake(void);
00254
00255 /**
00256  * @brief Custom library API functions
00257  *
00258  * @param sdkVersion:   IN:
00259  * @param libVersionP:  IN:
00260  * @retval Err error code.
00261  **/
00262 extern Err LcdOverlayLibGetVersion(UInt32 sdkVersion, UInt32* libVersionP);
00263
00264 /**
00265  * @brief
00266  *
00267  * @param cmdId:    IN:
00268  * @param parameterP:   IN:
00269  * @retval Err error code.
00270  **/
00271 extern Err LcdOverlayLibControl(LcdOverlayLibControlType cmdId, void* parameterP);
00272
00273 #endif
00274
00275
00276 #ifdef __cplusplus
00277 }
00278 #endif
00279
00280 #endif // __PalmLcdOverlay_H__
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:54 2008 for Palm API Guide


Header Files » Incs » 68k » system

PalmLED.h

Go to the documentation of this file.
00001 /******************************************************************************
00002  * Copyright (c) 2005 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  *****************************************************************************/
00005 /**
00006  *@ingroup System
00007  *
00008  */
00009
00010 /**
00011  * @file    PalmLED.h
00012  * @version 1.0
00013  *
00014  * @brief Palm's Generic LED dirver
00015  *
00016  *    Pledlib.prc, version 1.0
00017  *    This file contains the Generic LED driver defines. This driver is a standard
00018  *    libr driver that supports the BT notificaiton led. the interface follows the
00019  *    standard palm unser notification interface.
00020  *
00021  *    Future drivers will support multiple Led's.
00022  *
00023  * NOTE: Make sure to check the version number for this driver implementation.
00024  *
00025  *
00026  * <hr>
00027  */
00028
00029
00030 #ifndef __PalmLED_H__
00031 #define __PalmLED_H__
00032
00033
00034 // Palm OS common definitions
00035 #include <PalmTypes.h>
00036 #include <ErrorBase.h>
00037 #include <SystemMgr.h>
00038
00039
00040 // To Define when building the library
00041 // TODO: DO I need this???
00042 //#if (CPU_TYPE != CPU_68K) || (defined BUILDING_CODECMGR_LIB)
00043 //  #define CODECMGR_LIB_TRAP(trapNum)
00044 //#else
00045 //  #include <LibTraps.h>
00046 //  #define CODECMGR_LIB_TRAP(trapNum)  SYS_TRAP(trapNum)
00047 //#endif
00048
00049 /**
00050  * @name Type and creator of the Library
00051  *
00052  */
00053 /*@{*/
00054 #define kPalmLedName            "PalmLed"       /**<        */
00055 #define kPalmLedType            sysFileTLibrary     /**<        */
00056 #define kPalmLedCreator         'Pled'          /**<        */
00057 #define kPalmLedModule          195         /**<        */
00058 /*@}*/
00059
00060 /**
00061  * @name Library version
00062  *
00063  */
00064 /*@{*/
00065 #define kPalmLedVersion1        sysMakeROMVersion(1, 0, 0, sysROMStageRelease, 0)   /**<        */
00066 #define kPalmLedVersion         kPalmLedVersion1                    /**<        */
00067 /*@}*/
00068
00069 /**
00070  * @name Standard library functions
00071  *
00072  */
00073 /*@{*/
00074 #define kPalmLedTrapGetAttributes   (sysLibTrapCustom+0)    /**<        */
00075 #define kPalmLedTrapSetAttributes   (sysLibTrapCustom+1)    /**<        */
00076 /*@}*/
00077
00078
00079 /**
00080  * @name Get/Set Attribute
00081  *
00082  */
00083 /*@{*/
00084 #define kHALLEDPropertyUnderSleep   10
00085     /**
00086      * dataP points to a UInt32 that indicates how flexible the LED during Sleep is, as follows:
00087      **/
00088     #define kHALLEDPropertySleepOn          1       /**< bit 0 - ON during sleep */
00089     #define kHALLEDPropertySleepPattern     2       /**< bit 1 - pattern on */
00090     #define kHALLEDPropertySleepReserve     4       /**< bit 2 - reserve */
00091     #define kHALLEDPropertySleepColorRed        8       /**< bit 3 - red */
00092     #define kHALLEDPropertySleepColorGreen      0x10        /**< bit 4 - green */
00093     #define kHALLEDPropertySleepColorBlue       0x20        /**< bit 5 - blue */
00094     #define kHALLEDPropertySleepColorAmberWhite 0x40        /**< bit 6 - amber/white */
00095                                     /**< bit 7-31 reserved */
00096
00097 #define kHALLEDCapcityUnderSleep    11
00098     /**
00099      * dataP points to a UInt32 that indicates how flexible the LED during Sleep is, as follows:
00100      **/
00101     #define kHALLEDCapcitySleepOn           1   /**< bit 0  ON during Sleep available */
00102     #define kHALLEDCapcitySleepPattern      2   /**< bit 1  pattern when sleep available. */
00103     #define kHALLEDCapcitySleepPatternSetting   4   /**< bit 2  pattern setting available */
00104     #define kHALLEDCapcitySleepMultiColor       8   /**< bit 3  multi-color available */
00105                                 /**< bit 4-31   reserved */
00106 /*@}*/
00107
00108 /***********************************************************************
00109  * Error codes
00110  ***********************************************************************/
00111
00112 // TBD
00113
00114 /******************************************************************
00115  * Constants and Types
00116  ******************************************************************/
00117
00118  // Iterator used by CodecSupportedFormatEnumerate
00119
00120
00121 /***********************************************************************
00122  * Library trap
00123  ***********************************************************************/
00124
00125
00126
00127 /***********************************************************************
00128  * Generic Led driver defines
00129  ***********************************************************************/
00130
00131
00132 /***********************************************************************
00133  * API Prototypes
00134  ***********************************************************************/
00135
00136 #ifdef __cplusplus
00137 extern "C" {
00138 #endif
00139
00140 #if (CPU_TYPE != CPU_68K) || (defined BUILDING_PALMLED_LIB)
00141 #include <Emul68K.h>
00142
00143
00144
00145 /**
00146  * @brief 68K Glue Code
00147  *
00148  * @param emulStateP:   IN:
00149  * @param *libEntryP:   IN:
00150  * @param trapValue:    IN:
00151  * @retval Err error code.
00152  **/
00153 Err LibDispatch68K(EmulStateRef emulStateP, LibTblEntry68KType *libEntryP, UInt32 trapValue);
00154
00155
00156 #else
00157
00158
00159 /**
00160  * @brief Standard library function
00161  *
00162  * @param refnum:   IN:
00163  * @retval Err error code.
00164  **/
00165 Err PalmLedOpen(UInt16 refnum)
00166         SYS_TRAP(sysLibTrapOpen);
00167
00168 /**
00169  * @brief Standard library function
00170  *
00171  * @param refnum:   IN:
00172  * @retval Err error code.
00173  **/
00174 Err PalmLedClose(UInt16 refnum)
00175         SYS_TRAP(sysLibTrapClose);
00176
00177 /**
00178  * @brief Standard library function
00179  *
00180  * @param refnum:   IN:
00181  * @retval Err error code.
00182  **/
00183 Err PalmLedSleep(UInt16 refnum)
00184         SYS_TRAP(sysLibTrapSleep);
00185
00186 /**
00187  * @brief Standard library function
00188  *
00189  * @param refnum:   IN:
00190  * @retval Err error code.
00191  **/
00192 Err PalmLedWake(UInt16 refnum)
00193         SYS_TRAP(sysLibTrapWake);
00194
00195 /**
00196  * @brief Standard library function
00197  *
00198  * @param refnum:   IN:
00199  * @param attr:     IN:
00200  * @param dataP:    IN:
00201  * @retval Err error code.
00202  **/
00203 Err HALAttnGetPalmLedAttributes(UInt16 refnum, UInt32 attr, void* dataP)
00204         SYS_TRAP(kPalmLedTrapGetAttributes);
00205
00206 /**
00207  * @brief Standard library function
00208  *
00209  * @param refnum:   IN:
00210  * @param attr:     IN:
00211  * @param dataP:    IN:
00212  * @retval Err error code.
00213  **/
00214 Err HALAttnSetPalmLedAttributes(UInt16 refnum, UInt32 attr, void* dataP)
00215         SYS_TRAP(kPalmLedTrapSetAttributes);
00216
00217
00218 #endif // IF(CPU...
00219
00220 #ifdef __cplusplus
00221 }
00222 #endif
00223
00224 #endif // __PalmLED_H__
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:54 2008 for Palm API Guide


Header Files » Incs » 68k » system

PalmNative.h

Go to the documentation of this file.
00001 /******************************************************************************
00002  * Copyright (c) 2005 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  *****************************************************************************/
00005 /**
00006  *@ingroup System
00007  *
00008  */
00009
00010 /**
00011  * @file    PalmNative.h
00012  * @version 1.0
00013  * @date    10/28/2002
00014  *
00015  * @brief Functions and macros to help building ARM code.
00016  *
00017  *
00018  * <hr>
00019  */
00020
00021
00022 #ifndef PALM_NATIVE_H_
00023 #define PALM_NATIVE_H_
00024
00025 #ifdef WIN32
00026 #define NATIVE_CODE __declspec(dllexport)   /**<        */
00027 #define INLINE                  /**<        */
00028 #else
00029
00030 #define NATIVE_CODE             /**<        */
00031 #define INLINE      inline          /**<        */
00032
00033 #endif // WIN32
00034
00035
00036 #ifndef __PALMTYPES_H__
00037 /**
00038  * @name
00039  *
00040  */
00041 /*@{*/
00042 #define false  0                /**<        */
00043 #define true   1                /**<        */
00044 /*@}*/
00045
00046 #ifndef NULL
00047 #define NULL    0               /**<        */
00048 #endif  // NULL
00049
00050 typedef unsigned char   UInt8;          /**<        */
00051 typedef unsigned short  UInt16;         /**<        */
00052 typedef unsigned long   UInt32;         /**<        */
00053
00054 typedef signed char     Int8;           /**<        */
00055 typedef signed short    Int16;          /**<        */
00056 typedef signed long     Int32;          /**<        */
00057 typedef signed char     Char;           /**<        */
00058
00059 typedef unsigned char   Boolean;        /**<        */
00060 typedef UInt16          Err;            /**<        */
00061
00062 static INLINE UInt16 SwapUInt16(UInt16 u)
00063 {
00064   return
00065     (u & 0x00FF) << 8 |
00066     (u >> 8);
00067 }
00068
00069 static INLINE Int16 SwapInt16(Int16 i)
00070 {
00071   return (Int16)SwapUInt16((UInt16) i);
00072 }
00073
00074 static INLINE UInt32 SwapUInt32(UInt32 u)
00075 {
00076   return
00077     (u & 0x0000FFL) << 24 |
00078     (u & 0x00FF00L) << 8  |
00079     (u & 0xFF0000L) >> 8  |
00080     (u >> 24) & 0xFF;
00081 }
00082
00083 static INLINE Int32 SwapInt32(Int32 i)
00084 {
00085   return (Int32)SwapInt32((UInt32)i);
00086 }
00087
00088 static INLINE void* SwapPtr(void* p)
00089 {
00090   return (void*)SwapUInt32((UInt32)p);
00091 }
00092
00093 #endif  // __PALMTYPES_H__
00094
00095 #endif // PALM_NATIVE_H_
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:54 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » network

PalmNetServices.h

Go to the documentation of this file.
00001 /******************************************************************************
00002  * Copyright (c) 2004 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  *****************************************************************************/
00005 /**
00006  * @defgroup Network Network Library
00007  *
00008  * @{
00009  * @}
00010  */
00011 /**
00012  * @ingroup Network
00013  */
00014
00015 /**
00016  * @file    PalmNetServices.h
00017  * @version 1.0
00018  *
00019  * @brief NetServices provides a set of API to access 802.11.
00020  *
00021  */
00022
00023 #ifndef PALM_NETSERVICES_H__
00024 #define PALM_NETSERVICES_H__
00025
00026 #ifdef __MC68K__
00027 #include <LibTraps.h>
00028 #endif
00029
00030
00031 /********************************************************************
00032  * Traps
00033  ********************************************************************/
00034
00035 /**
00036  * @name Function Trap Numbers
00037  */
00038 /*@{*/
00039 #define NetServicesLibTrapGetHWAddr         (sysLibTrapCustom+0)
00040 #define NetServicesLibTrapStartScan         (sysLibTrapCustom+1)
00041 #define NetServicesLibTrapGetScanResults    (sysLibTrapCustom+2)
00042 #define NetServicesLibTrapGetChannel        (sysLibTrapCustom+3)
00043 #define NetServicesLibTrapGetPowerState     (sysLibTrapCustom+4)
00044 #define NetServicesLibTrapGetCommsQuality   (sysLibTrapCustom+5)
00045 #define NetServicesLibTrapSetRadioState     (sysLibTrapCustom+6)
00046 #define NetServicesLibTrapGetRadioState     (sysLibTrapCustom+7)
00047 #define NetServicesLibTrapGetDeviceInfo     (sysLibTrapCustom+10)
00048 #define NetServicesLibTrapGetChannelList    (sysLibTrapCustom+11)
00049
00050 #define NetServicesLibTrapProfileGetInfo    (sysLibTrapCustom+0x10)
00051 #define NetServicesLibTrapProfileRead       (sysLibTrapCustom+0x11)
00052 #define NetServicesLibTrapProfileWrite      (sysLibTrapCustom+0x12)
00053 #define NetServicesLibTrapProfileAdd        (sysLibTrapCustom+0x13)
00054 #define NetServicesLibTrapProfileDelete     (sysLibTrapCustom+0x14)
00055 #define NetServicesLibTrapProfileSetOrder   (sysLibTrapCustom+0x15)
00056 #define NetServicesLibTrapProfileGetOrder   (sysLibTrapCustom+0x16)
00057 #define NetServicesLibTrapProfileFind       (sysLibTrapCustom+0x17)
00058
00059
00060 /*@}*/
00061
00062 /********************************************************************
00063  * Library type and creator
00064  ********************************************************************/
00065
00066 #define ShlLibName      "NetServLib"    /**< PalmNetServices library name. */
00067 #define ShlCreatorID    'NETs'          /**< PalmNetServices creator ID. */
00068 #define ShlLibType      'libr'          /**< PalmNetServices library type. */
00069
00070
00071 /********************************************************************
00072  * Typedefs and constants for the device information returned from
00073  * NetServicesGetDeviceInfo.
00074  ********************************************************************/
00075
00076 #define kNetDriverDateLength    16      /**< Length for the driver date info string. */
00077 #define kNetFWNameLength        16      /**< Length for the firmware name info string. */
00078 #define kNetSerialNumberLength  16      /**< Length for the serial number info string. */
00079
00080 /**
00081  * @brief Device information concerning Hardware and Firmware information for the "adapter".
00082  *
00083  * Revision information and product name data is returned.
00084  */
00085 typedef struct Net80211DeviceInfo
00086 {
00087     UInt32      validFlags;                             /**< Bit flag indicating validity of fields. */
00088     UInt32      fwRev[2];                               /**< Firmware revision. STA/BB (32 bits), PRI/MAC (32 bits). Valid is (validFlags & 1) == 1.*/
00089     Int32       serialNumberSize;                       /**< Serial number size. Valid is (validFlags & 8) == 1. */
00090     UInt8       serialNumber[kNetSerialNumberLength];   /**< Serial number. Valid is (validFlags & 8) == 1. */
00091     Char        driverDate[kNetDriverDateLength];       /**< Driver date. Valid is (validFlags & 2) == 1. */
00092     Char        fwName[kNetFWNameLength];               /**< Firmware name. Valid is (validFlags & 4) == 1. */
00093 } Net80211DeviceInfo, *Net80211DeviceInfoP;
00094
00095
00096 /**
00097  * @brief Data returned from NetServicesProfileGetInfo.
00098  */
00099 typedef struct NetServicesProfileInfo
00100 {
00101     UInt16  profileRev;         /**< Revision of profile database. */
00102     UInt16  numProfiles;        /**< Number of profiles contained in the database. */
00103     UInt16  profileEntrySize;   /**< Size of each individual profile entry. */
00104 } NetServicesProfileInfo, *NetServicesProfileInfoP;
00105
00106 /**
00107  * @brief Profile entries for SmartConnect
00108  */
00109 typedef struct NetServicesProfile
00110 {
00111     Char    profileName[32];    /**< ASCII string - profile reference. */
00112     UInt8   SSID[32];           /**< SSID associated with this profile. */
00113     UInt32  ssidLength;         /**< Length of bytes of the SSID. */
00114     UInt16  ipAllocType;        /**< DHCP/STATIC/IPIPA. */
00115     UInt16  preambleType;       /**< Long or short preamble. */
00116     UInt16  keyIndex;           /**< WEP key index.  Only valid if wep active. */
00117     UInt16  authentication;     /**< OPEN / 64 bit / 128 bit. */
00118     UInt32  opMode;             /**< BSS, IBSS. */
00119     UInt32  channel;            /**< DS Channel.  Only used for ad-hoc. */
00120     UInt32  reqIP;              /**< Static IP address. */
00121     UInt32  ipMask;             /**< IP mask. */
00122     UInt32  ipGateway;          /**< IP gateway. */
00123     UInt32  ipPrimaryDNS;       /**< IP primary DNS. */
00124     UInt32  ipSecondaryDNS;     /**< IP secondary DNS. */
00125     UInt8   wep[4][16];         /**< WEP keys. Up to 5 keys. */
00126     UInt8   dhcpRequestDNS;     /**< 0 = DNS info static, 1 = DNS from DHCP. */
00127 #ifdef WIFI_DOT1X_SUPPORT
00128         UInt32  wppiCreator;            /**< Creator ID of Wi-Fi panel plugin (WPPI). */
00129         UInt32  authenticationMethodID; /**< Identified authentication method to WPPI. */
00130         UInt32  authenticationCookie;   /**< Identifies credentials to WPPI. */
00131 #endif // WIFI_DOT1X_SUPPORT
00132 } NetServicesProfile, *NetServicesProfileP;
00133
00134 /**
00135  * @brief Profile entries version 1
00136  */
00137 typedef struct NetServicesProfileV1
00138 {
00139     Char    profileName[32];    /**< ASCII string - profile reference. */
00140     UInt8   SSID[32];           /**< SSID associated with this profile. */
00141     UInt32  ssidLength;         /**< Length of bytes of the SSID. */
00142     UInt16  ipAllocType;        /**< DHCP/STATIC/IPIPA. */
00143     UInt16  preambleType;       /**< Long or short preamble. */
00144     UInt16  keyIndex;           /**< WEP key index.  Only valid if wep active. */
00145     UInt16  authentication;     /**< OPEN / 64 bit / 128 bit. */
00146     UInt32  opMode;             /**< BSS, IBSS. */
00147     UInt32  channel;            /**< DS Channel.  Only used for ad-hoc. */
00148     UInt32  reqIP;              /**< Static IP address. */
00149     UInt32  ipMask;             /**< IP mask. */
00150     UInt32  ipGateway;          /**< IP gateway. */
00151     UInt32  ipPrimaryDNS;       /**< IP primary DNS. */
00152     UInt32  ipSecondaryDNS;     /**< IP secondary DNS. */
00153     UInt8   wep[4][16];         /**< WEP keys. Up to 5 keys. */
00154     UInt8   dhcpRequestDNS;     /**< 0 = DNS info static, 1 = DNS from DHCP. */
00155 } NetServicesProfileV1, *NetServicesProfileV1P;
00156
00157
00158
00159 /********************************************************************
00160  * Priority order information
00161  ********************************************************************/
00162
00163 #define MAX_ACTIVE_PROFILES     32      /**< Maximum number of profiles. */
00164 #define END_OF_LIST             0xFFFF  /**< End of list marker. */
00165 #define PRIORITY_LIST_SIZE      (sizeof(UInt16) * (MAX_ACTIVE_PROFILES + 1)) /**< Priority list size. */
00166 #define INVALID_INDEX           0xFFFF  /**< Invalid index tag. */
00167
00168 /**
00169  * @brief Priority order to smart connect.
00170  *
00171  * Provided for ease of reference.
00172  */
00173 typedef struct NetServicesProfileOrder
00174 {
00175     UInt16  order[MAX_ACTIVE_PROFILES+1];   /**< Array of order for each active profiles. */
00176 } NetServicesProfileOrder, *NetServicesProfileOrderP;
00177
00178 /********************************************************************
00179  * Prototypes
00180  ********************************************************************/
00181 #ifdef __cplusplus
00182 extern "C" {
00183 #endif
00184
00185 #ifdef __MC68K__
00186 /**
00187  * Gets the HW address (i.e. MAC address) for the interface
00188  *
00189  * @param   libRefNum:  IN:  Reference number of the library.
00190  * @param   hwAddrP:    OUT: Pointer to store MAC address in.
00191  *                           Must be 6 bytes in length.
00192  *
00193  * @retval  Err         Error code.
00194  */
00195 Err NetServicesGetHWAddr( UInt16 libRefNum, UInt8 *hwAddrP )
00196                 SYS_TRAP(NetServicesLibTrapGetHWAddr);
00197
00198 /**
00199  * Inititate a BSS scan.
00200  * The scan completes by broadcasting a notification of
00201  * type WIFI_SCAN_COMPLETE_EVENT.
00202  *
00203  * @param   libRefNum:  IN: Reference number of the library.
00204  *
00205  * @retval  Err         Error code.
00206  */
00207 Err NetServicesStartScan( UInt16 libRefNum )
00208                 SYS_TRAP(NetServicesLibTrapStartScan);
00209
00210 /**
00211  * Retreives scan results from a recent request for a  BSS scan.
00212  * The caller can determine the amount of data available by passing
00213  * a NULL pointer and a zero size for the buffer. The network device
00214  * driver will return the space required to store the result.
00215  *
00216  * @param   libRefNum:      IN:  Reference number of the library.
00217  * @param   scanResultsP:   OUT: Pointer to storage area which will
00218  *                               hold the BSS scan data.
00219  * @param   scanBufSizeP:   OUT: Pointer to variable which holds the
00220  *                               size of the buffer.  Also used as
00221  *                               output to determine size of results.
00222  *
00223  * @retval  Err             Error code.
00224  */
00225 Err NetServicesGetScanResults( UInt16 libRefNum, UInt8 *scanResultsP, UInt32 *scanBufSizeP )
00226                 SYS_TRAP(NetServicesLibTrapGetScanResults);
00227
00228 /**
00229  * Retreives the current channel number being used by the adapter.
00230  * The exact method to get this data is determined by the adapter driver.
00231  *
00232  * @param   libRefNum:  IN:  Reference number of the library.
00233  * @param   channelP    OUT: Pointer to storage area to store current
00234  *                           channel number.
00235  *
00236  * @retval  Err         Error code.
00237  */
00238 Err NetServicesGetChannel( UInt16 libRefNum, UInt16 *channelP )
00239                 SYS_TRAP(NetServicesLibTrapGetChannel);
00240
00241 /**
00242  * Retreives the current mode (i.e. DSS, Freq. Hop) being  used
00243  * by the adapter.  The exact method to get this data is determined
00244  * by the adapter driver.
00245  *
00246  * @param   libRefNum:  IN:  Reference number of the library.
00247  * @param   stateP:     OUT: Pointer to storage area to store current mode.
00248  *
00249  * @retval  Err         Error code.
00250  */
00251 Err NetServicesGetPowerState( UInt16 libRefNum, UInt16 *stateP )
00252                 SYS_TRAP(NetServicesLibTrapGetPowerState);
00253
00254 /**
00255  * Retreives the comms quality from the driver / firmware.
00256  * The comms quality is the signal strength and quality.
00257  *
00258  * @param   libRefNum:  IN:  Reference number of the library.
00259  * @param   strengthP:  OUT: Pointer to storage area to store signal strength.
00260  * @param   qualityP:   OUT: Pointer to storage area for signal quality.
00261  *
00262  * @retval  Err         Error code.
00263  */
00264 Err NetServicesGetCommsQuality( UInt16 libRefNum, UInt8 *strengthP, UInt8 *qualityP )
00265                 SYS_TRAP(NetServicesLibTrapGetCommsQuality);
00266
00267 /**
00268  * Enables/disable the radio at the driver.
00269  *
00270  * @param   libRefNum:  IN: Reference number of the library.
00271  * @param   radioState: IN: Boolean value indicating on/off.
00272  *
00273  * @retval  Err         Error code.
00274  */
00275 Err NetServicesSetRadioState( UInt16 libRefNum, UInt32 radioState )
00276                 SYS_TRAP(NetServicesLibTrapSetRadioState);
00277
00278 /**
00279  * Returns current status of the radio (0 = disabled, 1 = enabled).
00280  *
00281  * @param   libRefNum:      IN:  Reference number of the library.
00282  * @param   radioStateP:    OUT: Pointer to storage area for the radio status.
00283  *
00284  * @retval  Err             Error code.
00285  */
00286 Err NetServicesGetRadioState( UInt16 libRefNum, UInt32 *radioStateP )
00287                 SYS_TRAP(NetServicesLibTrapGetRadioState);
00288
00289
00290 /**
00291  * Queries the Firmware on the 802.11 chipset for revision and status info.
00292  *
00293  * @param   libRefNum:  IN:  Reference number of the library.
00294  * @param   infoP:      OUT: Pointer to storage area for the firmware info.
00295  *
00296  * @retval  Err         Error code.
00297  */
00298 Err NetServicesGetDeviceInfo( UInt16 libRefNum, Net80211DeviceInfoP infoP )
00299                 SYS_TRAP(NetServicesLibTrapGetDeviceInfo);
00300
00301 /**
00302  * Retrieves the allowed channel list from the device driver.
00303  * Used for regulatory domain control.  The channel list is a 16 bit,
00304  * bit significant field with each bit indicating the channel + 1
00305  * (i.e. bit 0 = CHN1).
00306  *
00307  * @param   libRefNum:      IN:  Reference number of the library.
00308  * @param   channelListP:   OUT: Pointer to storage area for the channel list.
00309  *
00310  * @retval  Err             Error code.
00311  */
00312 Err NetServicesGetChannelList( UInt16 libRefNum, UInt16 *channelListP )
00313                 SYS_TRAP(NetServicesLibTrapGetChannelList);
00314
00315 /**
00316  * Provides information about the current profile database and profile manager.
00317  *
00318  * @param   libRefNum:  IN:  Reference number of the library.
00319  * @param   infoP:      OUT: Pointer to storage area where the info will be stored.
00320  *
00321  * @retval  Err         Error code.
00322  */
00323 Err NetServicesProfileGetInfo( UInt16 libRefNum, NetServicesProfileInfoP infoP )
00324                 SYS_TRAP(NetServicesLibTrapProfileGetInfo);
00325
00326 /**
00327  * Reads the specified record from the database.  The index is verified
00328  * first and then the data read into the user space.
00329  *
00330  * @param   libRefNum:  IN:  Reference number of the library.
00331  * @param   profIndex:  IN:  Profile index number.
00332  * @param   profileP:   OUT: Pointer to area where the profile will be read.
00333  *
00334  * @retval  Err         Error code.
00335  */
00336 Err NetServicesProfileRead( UInt16 libRefNum, UInt16 profIndex, NetServicesProfileP profileP )
00337                 SYS_TRAP(NetServicesLibTrapProfileRead);
00338
00339 /**
00340  * Updates the content of the specified record.
00341  *
00342  * @param   libRefNum:  IN: Reference number of the library.
00343  * @param   profIndex:  IN: Record index number.
00344  * @param   profileP:   IN: Pointer to profile data to be written to the database.
00345  *
00346  * @retval  Err         Error code.
00347  */
00348 Err NetServicesProfileWrite( UInt16 libRefNum, UInt16 profIndex, NetServicesProfileP profileP )
00349                 SYS_TRAP(NetServicesLibTrapProfileWrite);
00350
00351 /**
00352  * Deletes/removes the specified record from the database.
00353  *
00354  * @param   libRefNum:  IN: Reference number of the library.
00355  * @param   profIndex:  IN: Profile index number.
00356  *
00357  * @retval  Err         Error code.
00358  */
00359 Err NetServicesProfileDelete( UInt16 libRefNum, UInt16 profIndex )
00360                 SYS_TRAP(NetServicesLibTrapProfileDelete);
00361
00362 /**
00363  * Adds a new record to the end of the profiles database.
00364  *
00365  * @param   libRefNum:  IN: Reference number of the library.
00366  * @param   profileP:   IN: Pointer to new profile entry.
00367  *
00368  * @retval  Err         Error code.
00369  */
00370 Err NetServicesProfileAdd( UInt16 libRefNum, NetServicesProfileP profileP )
00371                 SYS_TRAP(NetServicesLibTrapProfileAdd);
00372
00373 /**
00374  * Requests to update the priority order of the profiles.
00375  * The routine verifies all the profile entries exist and
00376  * then updates the profile header with the info.
00377  *
00378  * @param   libRefNum:  IN: Reference number of the library.
00379  * @param   orderP:     IN: Pointer to new priority list.
00380  *                          Must be terminated by END_OF_LIST (0xFFFF).
00381  *
00382  * @retval  Err         Error code.
00383  */
00384 Err NetServicesProfileSetOrder( UInt16 libRefNum, NetServicesProfileOrderP orderP )
00385                 SYS_TRAP(NetServicesLibTrapProfileSetOrder);
00386
00387 /**
00388  * Requests to retreive the current priority order to the SmartConnect.
00389  *
00390  * @param   libRefNum:  IN: Reference number of the library.
00391  * @param   orderP:     OUT: Pointer to storage area where the list will be stored.
00392  *
00393  * @retval  Err         Error code.
00394  */
00395 Err NetServicesProfileGetOrder( UInt16 libRefNum, NetServicesProfileOrderP orderP )
00396                 SYS_TRAP(NetServicesLibTrapProfileGetOrder);
00397
00398 /**
00399  * Searches through the records in the database for the specified
00400  * profile name.  If the profile exists, the index is returned to
00401  * the caller. A value of INVALID_INDEX indicates the profile was not found.
00402  *
00403  * @param   libRefNum:  IN:  Reference number of the library.
00404  * @param   profNameP:  OUT: Pointer to storage area where the list will be stored.
00405  *
00406  * @retval  Err         Error code.
00407  */
00408 Err NetServicesProfileFind( UInt16 libRefNum, Char *profNameP )
00409                 SYS_TRAP(NetServicesLibTrapProfileFind);
00410
00411
00412 #else   // __MC68K__
00413 Err NetServicesGetHWAddr( UInt16 refnum, UInt8 *hwAddrP );
00414 Err NetServicesStartScan( UInt16 refnum );
00415 Err NetServicesGetScanResults( UInt16 refnum, UInt8 *scanResultsP, UInt32 *scanBufSizeP );
00416 Err NetServicesGetChannel( UInt16 refnum, UInt16 *channelP );
00417 Err NetServicesGetPowerState( UInt16 refnum, UInt16 *modeP );
00418 Err NetServicesGetCommsQuality( UInt16 refNum, UInt8 *strengthP, UInt8 *qualityP );
00419 Err NetServicesSetRadioState( UInt16 refNum, UInt32 enable );
00420 Err NetServicesGetRadioState( UInt16 libRef, UInt32 *radioStateP );
00421 Err NetServicesGetDeviceInfo( UInt16 refNum, Net80211DeviceInfoP storageP );
00422 Err NetServicesGetChannelList( UInt16 refNum, UInt16 *channelP );
00423
00424 Err NetServicesProfileGetInfo( UInt16 libRef, NetServicesProfileInfoP infoP );
00425 Err NetServicesProfileRead( UInt16 libRef, UInt16 profIndex, NetServicesProfileP profileP );
00426 Err NetServicesProfileWrite( UInt16 libRef, UInt16 profIndex, NetServicesProfileP profileP );
00427 Err NetServicesProfileDelete( UInt16 libRef, UInt16 profIndex );
00428 Err NetServicesProfileAdd( UInt16 libRef, NetServicesProfileP profileP );
00429 Err NetServicesProfileSetOrder( UInt16 libRef, NetServicesProfileOrderP orderP );
00430 Err NetServicesProfileGetOrder( UInt16 libRef, NetServicesProfileOrderP orderP );
00431 UInt16 NetServicesProfileFind( UInt16 libRef, Char *profNameP );
00432
00433
00434 #endif  // __MC68K__
00435
00436 #ifdef __cplusplus
00437 }
00438 #endif
00439
00440 #endif // PALM_NETSERVICES_H__
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:54 2008 for Palm API Guide


Header Files

palmOne_68K.h

Go to the documentation of this file.
00001 /**
00002  * @file    palmOne_68K.h
00003  * @version 1.0
00004  * @date    03/05/2004
00005  *
00006  *  Main palmOne Palm OS API Header file
00007  *
00008  * This is the main header file for all third party developers. A developer
00009  * would include if they wanted to use any of the palmOne components. This
00010  * includes all the extentions, libraries and any app components. This file is
00011  * for api calls that will work only in 68K code.
00012  * This file automatically includes the Common/palmOneCommon.h file so there is
00013  * no need for a developer to include that file seperately.
00014  * This is the ONLY file that should be needed for any of the palmOne specific
00015  * components. This file includes all the other header files
00016  * for the 68K space relative to this directory. It has to stay at the top of
00017  * the Incs tree.
00018  *
00019  * \license
00020  *
00021  *    Copyright (c) 2004 palmOne Inc., All Rights Reserved
00022  *
00023  *****************************************************************************/
00024
00025 #ifndef __PALMONE_68K_H__
00026 #define __PALMONE_68K_H__
00027
00028
00029 //Including the standard Palm OS headers
00030 #ifndef __PALMTYPES_H__
00031                                     #include <PalmTypes.h>
00032 #endif
00033 #ifndef __PALMCOMPATIBILITY_H__
00034                                     #include <PalmCompatibility.h>
00035 #endif
00036 #ifndef __PALMOS_H__
00037                                     #include <PalmOS.h>
00038 #endif
00039
00040 //Including the old Handspring Common files that are needed by certain apps
00041 #ifndef __PALMONECHARS_H__
00042                                     #include <68K/System/palmOneChars.h>
00043 #endif
00044
00045
00046 //Now let's include the palmOne headers
00047 #ifndef __HS_COMMON_H__
00048                                     #include <Common/HsCommon.h>
00049 #endif
00050 //5-Way Navigation Headers
00051 #ifndef __PALMONENAVIGATOR_H__
00052                                     #include <68K/System/palmOneNavigator.h>
00053 #endif
00054 #ifndef __HWUTILS68K_H__
00055                                     #include <68K/System/HardwareUtils68K.h>
00056 #endif
00057 #ifndef __PALMBGSERVICE_H__
00058                                     #include <68K/System/PalmBGService.h>
00059 #endif
00060 #ifndef __PALMCREATORS_H__
00061                                     #include <Common/System/PalmCreators.h>
00062 #endif
00063 #ifndef __PALMDISPLAYEXTENT_H__
00064                                     #include <68K/System/PalmDisplayExtent.h>
00065 #endif
00066 #ifndef __PALMERRORBASE_H__
00067                                     #include <68K/System/PalmErrorBase.h>
00068 #endif
00069 #ifndef __PALMFEATURES_H__
00070                                     #include <Common/System/PalmFeatures.h>
00071 #endif
00072 #ifndef __PALMGOLCD_H__
00073                                     #include <68K/System/PalmGoLCD.h>
00074 #endif
00075 #ifndef __PalmHiResTime_H__
00076                                     #include <68K/System/PalmHiResTime.h>
00077 #endif
00078 #ifndef __PalmLED_H__
00079                                     #include <68K/System/PalmLED.h>
00080 #endif
00081 #ifndef __PALMLAUNCHCODES_H__
00082                                     #include <68K/System/PalmLaunchCodes.h>
00083 #endif
00084 #ifndef __PalmLcdOverlay_H__
00085                                     #include <68K/System/PalmLcdOverlay.h>
00086 #endif
00087 // we might be able to remove this
00088 //since it seems related to ARM development
00089 #ifndef PALM_NATIVE_H_
00090                                     #include <68K/System/PalmNative.h>
00091 #endif
00092 #ifndef __PINLIB_H__
00093                                     #include <68K/System/PalmPin.h>
00094 #endif
00095 #ifndef __PalmPower_H__
00096                                     #include <68K/System/PalmPower.h>
00097 #endif
00098 #ifndef __PALMRESOURCES_H__
00099                                     #include <68K/System/PalmResources.h>
00100 #endif
00101 #ifndef __PALMONEVMFONTLIBRARY_H__
00102                                     #include <68K/Libraries/VMFont/palmOneVMFontLib.h>
00103 #endif
00104 #ifndef __PALMVMLAUNCH_H__
00105                                     #include <68K/System/PalmVMLaunch.h>
00106 #endif
00107 #ifndef __PALMVMPLUGIN_H__
00108                                     #include <68K/System/PalmVMPlugin.h>
00109 #endif
00110 #ifndef __SLIDER_H__
00111                                     #include <68K/System/Slider.h>
00112 #endif
00113
00114 //Audio
00115 #ifndef __PalmAudioPlayback_H__
00116                                     #include <68K/Libraries/Audio/PalmAudioPlayback.h>
00117 #endif
00118 #ifndef __PALMSOUNDCUSTOMCTRL_H__
00119                                     #include <68K/Libraries/Audio/PalmSoundCustomCtrl.h>
00120 #endif
00121 // Not including PalmSoundMgrExt.h at this time because of overloading of enum
00122 // already exists in the 5.2 OS.
00123
00124 //Camera
00125 #ifndef __palmOneCameraMgr_H__
00126                                     #include <68K/Libraries/CameraMgr/palmOneCamera.h>
00127 #endif
00128 #ifndef __PalmOneCameraSlider_H__
00129                                     #include <68K/Libraries/CameraMgr/palmOneCameraSlider.h>
00130 #endif
00131
00132 //Codec Pluggin Manager
00133 #ifndef _PALMONECODECPLUGINMGR_H_
00134                                     #include <68K/Libraries/CodecPluginMgr/palmOneCodecPluginMgr.h>
00135 #endif
00136 #ifndef _PALMONECODECFORMAT_H_
00137                                     #include <Common/Libraries/CodecPluginMgr/palmOneCodecFormat.h>
00138 #endif
00139
00140 //Network related libraries
00141 #ifndef PALM_NETSERVICES_H__
00142                                     #include <68K/Libraries/Network/PalmNetServices.h>
00143 #endif
00144 #ifndef _PALM_VPPI_H_
00145                                     #include <68K/Libraries/Network/PalmVPPI.h>
00146 #endif
00147 #ifndef _PALM_WPPI_H_
00148                                     #include <68K/Libraries/Network/PalmWPPI.h>
00149 #endif
00150 #ifndef PALM_WIFI_COMMON_H_
00151                                     #include <68K/Libraries/Network/PalmWiFiCommon.h>
00152 #endif
00153
00154 //Imaging Library
00155 #ifndef PALM_PHOTO_H_
00156                                     #include <68K/Libraries/Imaging/PalmPhoto.h>
00157 #endif
00158
00159 //File Browser Library
00160 #ifndef __FILE_BROWSER_LIB_68K_H__
00161                                     #include <68K/Libraries/filebrowser/FileBrowserLib68K.h>
00162 #endif
00163
00164 //SndFileStream Library
00165 #ifndef __SNDFILESTREAM_H__
00166                                     #include <68K/Libraries/SndFileStream/palmOneSndFileStream.h>
00167 #endif
00168
00169
00170 //Transition of Old Handspring headers
00171
00172
00173 #endif /* __PALMONE_68K_H__ */
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:54 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » cameramgr

palmOneCamera.h

Go to the documentation of this file.
00001 /******************************************************************************
00002  * Copyright (c) 2004 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  *****************************************************************************/
00005 /**
00006  * @ingroup Camera
00007  */
00008
00009 /**
00010  *
00011  * @file    palmOneCamera.h
00012  * @version 3.0
00013  *
00014  * @brief   Public 68K include file for camera support for Treo 650 devices.
00015  *          This version of the library adds functionality for Zire72, and Treo 650.
00016  *
00017  * Notes:
00018  * The calling application should always load this library with
00019  * SysLibLoad() before use, even if it is already open by another
00020  * application(ie, SysLibFind() returns a valid refnum). When
00021  * the application is done with the library, it should be
00022  * unloaded with SysLibRemove(). We do this because there is
00023  * no good way to synchronize loading and unloading of libraries
00024  * among multiple applications. It also greatly simplifies internal
00025  * synchronization.
00026  */
00027
00028 #ifndef __palmOneCameraMgr_H__
00029 #define __palmOneCameraMgr_H__
00030
00031 // Palm OS common definitions
00032 #include <PalmTypes.h>
00033 #include <ErrorBase.h>
00034 #include <SystemMgr.h>
00035 #include <LibTraps.h>
00036 #include <Common/Libraries/CameraMgr/palmOneCameraCommon.h>
00037
00038 #define CAM_LIB_TRAP(trapNum) SYS_TRAP(trapNum)
00039
00040 #ifdef __cplusplus
00041 extern "C" {
00042 #endif
00043
00044 /// Standard library open routine.
00045 ///
00046 /// Library should always be loaded with SysLibLoad()(not SysLibFind())
00047 /// before calling CamLibOpen(). See note at top of file.
00048 ///
00049 /// @param refNum:  IN: Library reference number.
00050 /// @retval Err Error code.
00051 extern Err CamLibOpen(UInt16 refNum)
00052     CAM_LIB_TRAP(sysLibTrapOpen);
00053
00054 /// Closes the Camera Manager.
00055 ///
00056 /// Library should always be unloaded with SysLibRemove() after
00057 /// CamLibClose() is called. See note at top of file.
00058 ///
00059 /// @param refNum:  IN: Library reference number.
00060 /// @retval Err Error code.
00061 extern Err CamLibClose(UInt16 refNum)
00062     CAM_LIB_TRAP(sysLibTrapClose);
00063
00064 /// Standard library sleep function.
00065 ///
00066 /// @param refNum:  IN: Library reference number.
00067 /// @retval Err Error code.
00068 extern Err CamLibSleep(UInt16 refNum)
00069     CAM_LIB_TRAP(sysLibTrapSleep);
00070
00071 /// Standard library wake function.
00072 ///
00073 /// @param refNum:  IN: Library reference number.
00074 /// @retval Err Error code.
00075 extern Err CamLibWake(UInt16 refNum)
00076     CAM_LIB_TRAP(sysLibTrapWake);
00077
00078 /// Checks the version of the Camera Manager Library.
00079 ///
00080 /// @param refNum:      IN: Library reference number.
00081 /// @param sdkVersion:  IN: The version the application expects.
00082 /// @param libVersionP: OUT: The actual version of the library.
00083 /// @retval Err Error code.
00084 extern Err CamLibGetVersion(UInt16 refNum, UInt32 sdkVersion, UInt32* libVersionP)
00085     CAM_LIB_TRAP(kCamLibTrapGetVersion);
00086
00087 /// Check or set a Camera property.
00088 ///
00089 /// @param refNum:      IN: Library reference number.
00090 /// @param cmdId:       IN: The control command used to check or set the camera property.
00091 /// @param parameterP:  IN: Pointer to a parameter based on the control command type.
00092 /// @retval Err Error code.
00093 extern Err CamLibControl(UInt16 refNum, CamLibControlType cmdId, void *parameterP)
00094     CAM_LIB_TRAP(kCamLibTrapControl);
00095
00096 #ifdef __cplusplus
00097 }
00098 #endif
00099
00100 #endif // __PalmCameraLib_H__
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:54 2008 for Palm API Guide


Header Files » Incs » common » libraries » cameramgr

palmOneCameraCommon.h

Go to the documentation of this file.
00001 /*******************************************************************************
00002  * Copyright (c) 2004-2005 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  ******************************************************************************/
00005 /**
00006  * @defgroup    Camera Camera Library
00007  * @brief       This library provides camera support for Zire 72 and Treo 650
00008  *              devices.
00009  *
00010  * Developers who want to provide camera support to their application on Zire 72
00011  * and Treo 650 devices should use Camera Manager Library API instead of the old
00012  * Camera Library.
00013  *
00014  * @{
00015  * @}
00016  */
00017 /**
00018  * @ingroup Camera
00019  */
00020
00021 /**
00022  * @file    palmOneCameraCommon.h
00023  * @version 3.0
00024  * @brief   Public 68K common header file for camera support for Zire 72 and Treo 650 devices.
00025  *
00026  * This file contains the library constants and error codes used in the APIs.
00027  * <hr>
00028  */
00029
00030 #ifndef _PALMONECAMERAMGRCOMMON_H_
00031 #define _PALMONECAMERAMGRCOMMON_H_
00032
00033 #define     kCamLibType     'libr'              /**< Default library type */
00034 #define     kCamLibCreator  'camL'              /**< Camera Manager library creator ID */
00035 #define     kCamLibName     "CameraLib-camL"    /**< Camera Manager library name */
00036
00037
00038 /**
00039  * @name Library Versions
00040  */
00041 /*@{*/
00042 #define     kCamLibVersion1 sysMakeROMVersion(1, 0, 0, sysROMStageRelease, 0)
00043 #define     kCamLibVersion2 sysMakeROMVersion(2, 0, 0, sysROMStageRelease, 0)
00044 #define     kCamLibVersion3 sysMakeROMVersion(3, 0, 0, sysROMStageRelease, 0)
00045 #define     kCamLibVersion  kCamLibVersion3
00046 /*@}*/
00047
00048
00049 /**
00050  * @name Features
00051  */
00052 /*@{*/
00053 #define     kCamLibFtrCaptureVersion    0       /**< Feature id for capture h/w. */
00054 #define     kCamLibCaptureHwrVersion    0x10    /**< Feature value if capture h/w present. */
00055 #define     kCamLibFtrVersionNum        0       /**< Feature version if camera is present. */
00056 /*@}*/
00057
00058
00059 /**
00060  * @name Error Codes
00061  */
00062 /*@{*/
00063 #define kCamLibErrorClass           (oemErrorClass + 0x100)
00064 #define kCamLibErrBadParam          (kCamLibErrorClass | 0x01)/**< Invalid parameter. */
00065 #define kCamLibErrNoMemory          (kCamLibErrorClass | 0x02)/**< Memory error. */
00066 #define kCamLibErrNotOpen           (kCamLibErrorClass | 0x03)/**< Library is not open. */
00067 #define kCamLibErrStillOpen         (kCamLibErrorClass | 0x04)/**< Returned from CamLibClose() if the library is still open. */
00068 #define kCamLibErrInternal          (kCamLibErrorClass | 0x05)/**< Internal error. */
00069 #define kCamLibErrNotSupported      (kCamLibErrorClass | 0x06)/**< Unsupported function. */
00070 #define kCamLibErrNotCompatible     (kCamLibErrorClass | 0x07)/**< Bad Version. */
00071 #define kCamLibErrNoPower           (kCamLibErrorClass | 0x08)/**< Camera not powered. */
00072 #define kCamLibErrAllFramesLocked   (kCamLibErrorClass | 0x09)/**< All video frames are locked. */
00073 /*@}*/
00074
00075
00076 /**
00077  * @name Control Commands
00078  */
00079 /*@{*/
00080 #define kCamLibCtrlPowerOn                  0x01/**< Powers on and initialize the camera module. No parameter. */
00081 #define kCamLibCtrlPowerOff                 0x02/**< Powers off the camera module. No parameter. */
00082 #define kCamLibCtrlHardwareSettingsDlg      0x03/**< Displays the hardware camera settings dialog. No parameter. */
00083 #define kCamLibCtrlPreviewStart             0x04/**< Starts the camera preview mode. No parameter. */
00084 #define kCamLibCtrlPreviewStop              0x05/**< Stops the camera preview mode. No parameter. */
00085 #define kCamLibCtrlCaptureGetBitmapInfo     0x06/**< Used to determine the captured image properties. Parameter is CamLibBitmapInfoType*. */
00086 #define kCamLibCtrlCapture                  0x07/**< Captures the current image. Parameter is CamLibCaptureType*. */
00087 #define kCamLibCtrlStatusGet                0x08/**< Used to determine if a certain camera status is currently in effect. Parameter is CamLibStatusType*. */
00088 #define kCamLibCtrlStatusQuery              0x09/**< Used to determine if a certain camera status is available. Parameter is CamLibStatusType*. */
00089 #define kCamLibCtrlCaptureFormatSet         0x10/**< Sets the capture format. Parameter is CamLibCaptureFormatType*. */
00090 #define kCamLibCtrlCaptureFormatGet         0x11/**< Gets the current capture format. Parameter is CamLibCaptureFormatType*. */
00091 #define kCamLibCtrlCaptureFormatQuery       0x12/**< Queries the capture formats available. Parameter is CamLibCaptureFormatType*. */
00092 #define kCamLibCtrlCaptureSizeSet           0x13/**< Sets the capture size. Parameter is CamLibImageSizeType*. */
00093 #define kCamLibCtrlCaptureSizeGet           0x14/**< Gets the current capture size. Parameter is CamLibImageSizeType*. */
00094 #define kCamLibCtrlCaptureSizeQuery         0x15/**< Queries the capture sizes available. Parameter is CamLibImageSizeType*. */
00095 #define kCamLibCtrlCaptureAreaSet           0x16/**< Sets the capture area. Parameter is RectangleType*. Low-res value. */
00096 #define kCamLibCtrlCaptureAreaGet           0x17/**< Gets the capture area. Parameter is RectangleType*. Low-res value. */
00097 #define kCamLibCtrlPreviewSizeSet           0x20/**< Sets the preview size. Parameter is CamLibImageSizeType*. */
00098 #define kCamLibCtrlPreviewSizeGet           0x21/**< Gets the preview size. Parameter is CamLibImageSizeType*. */
00099 #define kCamLibCtrlPreviewSizeQuery         0x22/**< Queries the preview sizes available. Parameter is CamLibImageSizeType*. */
00100 #define kCamLibCtrlPreviewRectSet           0x23/**< Sets the preview rectangle. Parameter is RectangleType*. Low-res value. */
00101 #define kCamLibCtrlPreviewRectGet           0x24/**< Gets the preview rectangle. Parameter is RectangleType*. Low-res value. */
00102 #define kCamLibCtrlPreviewAreaSet           0x26/**< Sets the preview area. Parameter is RectangleType*. Low-res value. */
00103 #define kCamLibCtrlPreviewAreaGet           0x27/**< Gets the preview area. Parameter is RectangleType*. Low-res value. */
00104 #define kCamLibCtrlWhiteBalanceSet          0x30/**< Sets the white balance. Parameter is CamLibWhiteBalanceType*. */
00105 #define kCamLibCtrlWhiteBalanceGet          0x31/**< Gets the current white balance. Parameter is CamLibWhiteBalanceType*. */
00106 #define kCamLibCtrlWhiteBalanceQuery        0x32/**< Queries the white balances available. Parameter is CamLibWhiteBalanceType*. */
00107 #define kCamLibCtrlLightingSet              0x33/**< Sets the lighting setting. Parameter is CamLibLightingType*. */
00108 #define kCamLibCtrlLightingGet              0x34/**< Gets the current lighting setting. Parameter is CamLibLightingType*. */
00109 #define kCamLibCtrlLightingQuery            0x35/**< Queries the lighting settings available. Parameter is CamLibLightingType*. */
00110 #define kCamLibCtrlZoomSet                  0x36/**< Sets the zoom value. Parameter is CamLibZoomType*. */
00111 #define kCamLibCtrlZoomGet                  0x37/**< Gets the current zoom value. Parameter is CamLibZoomType*. */
00112 #define kCamLibCtrlZoomQuery                0x38/**< Queries the zoom range. Parameter is CamLibZoomType*. */
00113 #define kCamLibCtrlEffectsSet               0x39/**< Sets the camera effect. Parameter is CamLibEffectsType*. */
00114 #define kCamLibCtrlEffectsGet               0x3A/**< Gets the current camera effect. Parameter is CamLibEffectsType*. */
00115 #define kCamLibCtrlEffectsQuery             0x3B/**< Queries the camera effects available. Parameter is CamLibEffectsType*. */
00116 #define kCamLibCtrlSaturationSet            0x3C/**< Sets the saturation level. Parameter is CamLibSaturationType*. */
00117 #define kCamLibCtrlSaturationGet            0x3D/**< Gets the current saturation level. Parameter is CamLibSaturationType*. */
00118 #define kCamLibCtrlSaturationQuery          0x3E/**< Queries the saturation range. Parameter is CamLibSaturationType*. */
00119 #define kCamLibCtrlExposureSet              0x40/**< Sets the exposure. Parameter is CamLibExposureType*. */
00120 #define kCamLibCtrlExposureGet              0x41/**< Gets the exposure. Parameter is CamLibExposureType*. */
00121 #define kCamLibCtrlExposureQuery            0x42/**< Checks the exposure values available. Parameter is CamLibExposureType*. */
00122 #define kCamLibCtrlContrastSet              0x43/**< Sets the contrast. Parameter is CamLibContrastType*. */
00123 #define kCamLibCtrlContrastGet              0x44/**< Gets the current contrast. Parameter is CamLibContrastType*. */
00124 #define kCamLibCtrlContrastQuery            0x45/**< Checks the contrast values available. Parameter is CamLibContrastType*. */
00125 #define kCamLibCtrlSharpnessSet             0x46/**< Sets the sharpness. Parameter is CamLibSharpnessType*. */
00126 #define kCamLibCtrlSharpnessGet             0x47/**< Gets the sharpness. Parameter is CamLibSharpnessType*. */
00127 #define kCamLibCtrlSharpnessQuery           0x48/**< Queries the sharpness range. Parameter is CamLibSharpnessType*. */
00128 #define kCamLibCtrlStreamFormatSet          0x50/**< Sets the video stream format. Parameter is CamLibCaptureFormatType*. */
00129 #define kCamLibCtrlStreamFormatGet          0x51/**< Gets the video stream format. Parameter is CamLibCaptureFormatType*. */
00130 #define kCamLibCtrlStreamFormatQuery        0x52/**< Queries the video stream formats available. Parameter is CamLibCaptureFormatType*. */
00131 #define kCamLibCtrlStreamSizeSet            0x53/**< Sets the video stream size. Parameter is CamLibCaptureSizeType*. */
00132 #define kCamLibCtrlStreamSizeGet            0x54/**< Gets the video stream size. Parameter is CamLibCaptureSizeType*. */
00133 #define kCamLibCtrlStreamSizeQuery          0x55/**< Queries the video stream sizes available. Parameter is CamLibCaptureSizeType*. */
00134 #define kCamLibCtrlStreamStart              0x56/**< Starts the video stream capture. Parameter is CamLibStreamType*. */
00135 #define kCamLibCtrlStreamStop               0x57/**< Stops the video stream capture. Parameter is CamLibStreamType*. */
00136 #define kCamLibCtrlStreamWaitForFrame       0x58/**< Waits and locks a video frame. Parameter is CamLibStreamType*. */
00137 #define kCamLibCtrlStreamUnlockFrame        0x59/**< Unlocks a video frame. Parameter is CamLibStreamType*. */
00138 #define kCamLibCtrlStreamBufNumSet          0x60/**< Sets the number of video frame buffers. Parameter is CamLibBufNumType*. */
00139 #define kCamLibCtrlStreamBufNumGet          0x61/**< Gets the number of video frame buffers. Parameter is CamLibBufNumType*. */
00140 #define kCamLibCtrlStreamBufNumQuery        0x62/**< Queries the number of video frame buffer range. Parameter is CamLibBufNumType*. */
00141 #define kCamLibCtrlStreamPreviewSet         0x63/**< Sets the stream preview on or off. Parameter is CamLibStreamPreviewType*. */
00142 #define kCamLibCtrlStreamPreviewGet         0x64/**< Gets the stream preview status (on or off). Parameter is CamLibStreamPreviewType*. */
00143 #define kCamLibCtrlStreamPreviewQuery       0x65/**< Queries the stream preview available. Parameter is CamLibStreamPreviewType*. */
00144 #define kCamLibCtrlColorSpaceSet            0x66/**< Sets the Color Space. Parameter is CamLibColorSpaceType*.*/
00145 #define kCamLibCtrlColorSpaceGet            0x67/**< Gets the Color Space. Parameter is CamLibColorSpaceType*.*/
00146 #define kCamLibCtrlColorSpaceQuery          0x68/**< Queries for the Color Space. Parameter is CamLibColorSpaceType*.*/
00147 #define kCamLibCtrlShutterSpeedSet          0x69/**< Sets the Shutter Speed. Parameter is CamLibShutterSpeedType*.*/
00148 #define kCamLibCtrlShutterSpeedGet          0x6A/**< Gets the Shutter Speed. Parameter is CamLibShutterSpeedType*.*/
00149 #define kCamLibCtrlShutterSpeedQuery        0x6B/**< Queries for the Shutter Speed. Parameter is CamLibShutterSpeedType*.*/
00150 #define kCamLibCtrlApertureValueSet         0x6C/**< Sets the Aperture Value. Parameter is CamLibApertureValueType*.*/
00151 #define kCamLibCtrlApertureValueGet         0x6D/**< Gets the Aperture Value. Parameter is CamLibApertureValueType*.*/
00152 #define kCamLibCtrlApertureValueQuery       0x6E/**< Queries for the Aperture Value. Parameter is CamLibApertureValueType*.*/
00153 /*@}*/
00154
00155 /** Camera Manager library control structure */
00156 typedef UInt16 CamLibControlType;
00157
00158 /**
00159  * @name Camera Status
00160  */
00161 /*@{*/
00162 #define kCamLibStatusPoweredOn          0x01/**< Is the camera powered on? */
00163 #define kCamLibStatusInPreview          0x02/**< Is the camera in preview mode? */
00164 #define kCamLibStatusInStillCapture     0x04/**< Is the camera in still capture? */
00165 #define kCamLibStatusInVideoCapture     0x08/**< Is the camera in video capture? */
00166 /*@}*/
00167
00168 /** @brief Container for the camera status kCamLibStatus* */
00169 typedef struct CamLibStatusTag
00170 {
00171     UInt32 status;  /**< Camera status */
00172 } CamLibStatusType;
00173
00174 /** @brief Bitmap info structure for every format except PalmBMPV4.  Data starts after the parameters. */
00175 typedef struct CamLibBitmapInfoTag
00176 {
00177     UInt16 width;           /**< Width of the bitmap. */
00178     UInt16 height;          /**< Height of the bitmap. */
00179     UInt32 numBytes;        /**< Number or Bytes to be streamed. */
00180     UInt8  bitsPerPixel;    /**< Number of bits per pixel. */
00181     UInt8  reserved0;       /**< For packing. */
00182     UInt16 reserved1;       /**< For packing. */
00183 } CamLibBitmapInfoType;
00184
00185 /******************************************************************************/
00186 /* CamLibCaptureCallbackFunc */
00187 /**
00188    @brief Image capture callback function pointer
00189
00190    @param bufP      I/O     Pointer to the image buffer
00191    @param size      IN      Size of the buffer
00192    @param userDataP OUT     Pointer to the user data
00193
00194    @return          Error code or zero if no error occurs
00195
00196 *******************************************************************************/
00197 typedef Err CamLibCaptureCallbackFunc(void *bufP, UInt32 size, void *userDataP);
00198
00199 /** @brief Capture settings structure.  The callback is called with userDataP passed. */
00200 typedef struct CamLibCaptureTag
00201 {
00202     CamLibCaptureCallbackFunc *callbackP;   /**< Callback function. */
00203     void *userDataP;                        /**< User data pointer. */
00204 } CamLibCaptureType;
00205
00206 /**
00207  * @brief Video stream structure.  Used for capturing a video stream.
00208  *
00209  * When used with WaitfForFram, bufP will contain the full frame buffer.
00210  */
00211 typedef struct CamLibStreamTag
00212 {
00213     void    *lock;          /**< Reserved. */
00214     void    *bufP;          /**< Pointer to base of frame buffer content. */
00215     UInt32  size;           /**< Size in bytes of frame buffer. */
00216     UInt32  frameTime;      /**< Time-stamp when frame was captured. */
00217     UInt32  frameNum;       /**< Number of frames (relative to start) in stream. */
00218 } CamLibStreamType;
00219
00220
00221 /** Video Stream Capture buffers */
00222 #define kCamLibBufNumManual     0x01
00223
00224 /** @see CamLibSettingTag */
00225 typedef struct CamLibSettingTag CamLibBufNumType;
00226
00227 /**
00228  * @brief Settings Capabilities structure.
00229  * For settings without manual values, only type is used.
00230  */
00231 typedef struct CamLibSettingTag
00232 {
00233     UInt32 type;        /**< Setting type. */
00234     Int32 value;        /**< For manual settings only. */
00235     Int32 minValue;     /**< Used for Get/Query only and is valid for manual value. */
00236     Int32 maxValue;     /**< Used for Get/Query only and is valid for manual value. */
00237 } CamLibSettingType;
00238
00239 /**
00240  * @brief Color Space structure.
00241  */
00242 typedef struct CamLibColorSpaceTag
00243 {
00244     Int32 value;        /**< Value. */
00245
00246 } CamLibColorSpaceType;
00247
00248
00249
00250 /**
00251  * @name Capture Formats
00252  */
00253 /*@{*/
00254 #define kCamLibCaptureDataFormatRGB565              0x0002/**< Capture format in 16-bit RGB. */
00255 #define kCamLibCaptureDataFormatYUV422              0x0004/**< Capture format in 16-bit YUV422. */
00256 #define kCamLibCaptureDataFormatYCbCr422            0x0008/**< Capture format in 16-bit YCbCr422. */
00257 #define kCamLibCaptureDataFormatYUV422Planar        0x0010/**< Capture format in 16-bit YUV422 Planar. */
00258 #define kCamLibCaptureDataFormatYCbCr422Planar      0x0020/**< Capture format in 16-bit YCbCr422 Planar. */
00259 #define kCamLibCaptureDataFormatYUV420              0x0040/**< Capture format in 16-bit YUV420. */
00260 #define kCamLibCaptureDataFormatYCbCr420            0x0080/**< Capture format in 16-bit YCbCr420. */
00261 #define kCamLibCaptureDataFormatYUV420Planar        0x0100/**< Capture format in 16-bit YUV420 Planar. */
00262 #define kCamLibCaptureDataFormatYCbCr420Planar      0x0200/**< Capture format in 16-bit YCbCr420 Planar. */
00263 /*@}*/
00264
00265 /** @see CamLibSettingTag */
00266 typedef struct CamLibSettingTag CamLibCaptureFormatType;
00267
00268 /**
00269  * @name Image Resolution
00270  */
00271 /*@{*/
00272 #define kCamLibImageSizeQQVGA               0x02/**< 160 x 120 High Resolution. */
00273 #define kCamLibImageSizeQVGA                0x04/**< 320 x 240 High Resolution. */
00274 #define kCamLibImageSizeVGA                 0x08/**< 640 x 480 High Resolution. */
00275 #define kCamLibImageSizeSXGA                0x10/**< 1280x 960 High Resolution. */
00276 #define kCamLibImageSizeQCIF                0x20/**< 177 x 144 High Resolution. */
00277 #define kCamLibImageSizeCIF                 0x40/**< 354 x 288 High Resolution. */
00278
00279 /* By definition, SXGA is 1280x1024, but someone erroneously defined
00280  * kCamLibImageSizeSXGA as 1280x960.  kCamLibImageSizeSXGA is now
00281  * deprecated, in favor of two new contstants.
00282  */
00283
00284 #define kCamLibImageSizeSXGA960             0x10/**< 1280x 960 High Resolution. */
00285 #define kCamLibImageSizeSXGA1024            0x80/**< 1280x 1024 High Resolution. */
00286 /*@}*/
00287
00288 /** @see CamLibSettingTag */
00289 typedef struct CamLibSettingTag CamLibImageSizeType;
00290
00291 /**
00292  * @name White Balance Settings
00293  */
00294 /*@{*/
00295 #define kCamLibWhiteBalanceAuto             0x02/**< Automatically determines the correct white balance for capturing and previewing images.*/
00296 #define kCamLibWhiteBalanceIndoor           0x04/**< Sets the white balance for indoor capturing and previewing of images */
00297 #define kCamLibWhiteBalanceIncandescent     0x04/**< Sets the white balance for indoor capturing and previewing of images */
00298 #define kCamLibWhiteBalanceOutdoor          0x08/**< Sets the white balance for outdoor capturing and previewing of images */
00299 #define kCamLibWhiteBalanceSunny            0x08/**< Sets the white balance for outdoor capturing and previewing of images */
00300 #define kCamLibWhiteBalanceExtra            0x10/**< Sets the white balance for flourescent indoor capturing and previewing of images */
00301 #define kCamLibWhiteBalanceFluorescent      0x10/**< Sets the white balance for flourescent indoor capturing and previewing of images */
00302 #define kCamLibWhiteBalanceCloudy           0x20/**< Sets the white balance for cloudy lighting during capture and preview of images */
00303 #define kCamLibWhiteBalanceShade            0x40/**< Sets the white balance for shady lighting during capture and preview of images */
00304 #define kCamLibWhiteBalanceTwilight         0x80/**< Sets the white balance for twilight lighting during capture and preview of images */
00305 /*@}*/
00306
00307 /** @see CamLibSettingTag */
00308 typedef struct CamLibSettingTag CamLibWhiteBalanceType;
00309
00310 /**
00311  * @name Exposure Level Settings
00312  */
00313 /*@{*/
00314 #define kCamLibExposureManual           0x01/**<Sets the exposure level manually through an additional
00315                                                  passed parameter with kCamLibCtrlExposureSet. For manual
00316                                                  values, all values are x1000 of real exposure i.e. exp 1.5 is 1500. */
00317 #define kCamLibExposureAuto             0x02/**<Sets the exposure level automatically.*/
00318 /*@}*/
00319
00320 /** @see CamLibSettingTag */
00321 typedef struct CamLibSettingTag CamLibExposureType;
00322
00323 /**
00324  * @name Contrast Setting
00325  */
00326 /*@{*/
00327 #define kCamLibContrastManual           0x01/**< Sets the contrast value manually. Use kCamLibCtrlContrastGet
00328 to determine the minimum and maximum values allowed and the unit of
00329 measurement. */
00330 /*@}*/
00331
00332 /** @see CamLibSettingTag */
00333 typedef struct CamLibSettingTag CamLibContrastType;
00334
00335 /**
00336  * @name Zoom Setting
00337  */
00338 /*@{*/
00339 #define kCamLibZoomManual               0x01/**< Sets the zoom value manually.
00340 All values here are x1000 of real zoom i.e. x2 is 2000. */
00341 /*@}*/
00342
00343 /** @see CamLibSettingTag */
00344 typedef struct CamLibSettingTag CamLibZoomType;
00345
00346 /**
00347  * @name Lighting Settings
00348  */
00349 /*@{*/
00350 #define kCamLibLightingNormal           0x02/**< The camera is set for normal light. */
00351 #define kCamLibLightingLow              0x04/**< The camera is set for low light. */
00352 /*@}*/
00353
00354 /** @see CamLibSettingTag */
00355 typedef struct CamLibSettingTag CamLibLightingType;
00356
00357 /**
00358  * @name Special Effects
00359  */
00360 /*@{*/
00361 #define kCamLibEffectsNormal            0x02/**< No special effects */
00362 #define kCamLibEffectsBlackWhite        0x04/**< Balck & white effect */
00363 #define kCamLibEffectsSepia             0x08/**< Sepia effect */
00364 #define kCamLibEffectsBluish            0x10/**< Bluish effect */
00365 #define kCamLibEffectsNegative          0x20/**< Negative effect */
00366 /*@}*/
00367
00368 /** @see CamLibSettingTag */
00369 typedef struct CamLibSettingTag CamLibEffectsType;
00370
00371 /**
00372  * @name Saturation Level
00373  */
00374 /*@{*/
00375 #define kCamLibSaturationManual         0x01/**< Sets the saturation level manually */
00376 /*@}*/
00377
00378 /** @see CamLibSettingTag */
00379 typedef struct CamLibSettingTag CamLibSaturationType;
00380
00381 /**
00382  * @name Sharpness Level
00383  */
00384 /*@{*/
00385 #define kCamLibSharpnessManual          0x01/**< Sets the sharpness level manually. */
00386 /*@}*/
00387
00388 /** @see CamLibSettingTag */
00389 typedef struct CamLibSettingTag CamLibSharpnessType;
00390
00391 /**
00392  * @name Stream Preview Settings
00393  */
00394 /*@{*/
00395 #define kCamLibStreamPreviewOn          0x01/**< Stream preview on. */
00396 #define kCamLibStreamPreviewOff         0x02/**< Stream preview off. */
00397 /*@}*/
00398
00399 /** @see CamLibSettingTag */
00400 typedef struct CamLibSettingTag CamLibStreamPreviewType;
00401
00402 /**
00403  * @name Color Space Settings
00404  */
00405 /*@{*/
00406 #define kCamLibColorSpace_sRGB          0x02/**< color space sRGB. */
00407 #define kCamLibColorSpaceUncalibrated   0x04/**< color space uncalibrated. */
00408 /*@}*/
00409
00410 /**
00411  * @name Shutter Speed Settings
00412  */
00413 /*@{*/
00414 #define kCamLibShutterSpeedManual       0x01/**<Sets the shutter speed manually through an additional
00415                                                  passed parameter with kCamLibCtrlShutterSpeedSet.*/
00416 #define kCamLibShutterSpeedAuto         0x02/**<Sets the shutter speed automatically.*/
00417 /*@}*/
00418
00419 /** @see CamLibSettingTag */
00420 typedef struct CamLibSettingTag CamLibShutterSpeedType;
00421
00422 /**
00423  * @name Aperture Value Settings
00424  */
00425 /*@{*/
00426 #define kCamLibApertureValueManual      0x01/**<Sets the aperture value manually through an additional
00427                                                  passed parameter with kCamLibCtrlApertureValueSet.For manual
00428                                                  values, all values are x1000 of real aperture value
00429                                                  i.e. ap val 1.4 is 1400.*/
00430 #define kCamLibApertureValueAuto        0x02/**<Sets the aperture value automatically.*/
00431 /*@}*/
00432
00433 /** @see CamLibSettingTag */
00434 typedef struct CamLibSettingTag CamLibApertureValueType;
00435
00436 /**
00437  * @name Function Traps
00438  */
00439 /*@{*/
00440 #define kCamLibTrapGetVersion       (sysLibTrapCustom + 0)
00441 #define kCamLibTrapControl          (sysLibTrapCustom + 1)
00442 /*@}*/
00443
00444 #endif  // _CAMERAMGRCOMMON_H_
00445
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:54 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » cameramgr

palmOneCameraSlider.h

Go to the documentation of this file.
00001 /******************************************************************************
00002  * Copyright (c) 2004 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  *****************************************************************************/
00005 /**
00006  * @ingroup Camera
00007  *
00008  *
00009  */
00010
00011 /**
00012  * @file    palmOneCameraSlider.h
00013  * @version 1.0
00014  * @brief Public 68K file for camera slider notification for Zire 71 devices.
00015  *
00016  * Contains the Slider notification and status information.
00017  *
00018  * Any application can register to the notification to be nofity
00019  * when the slider is opened or closed.
00020  * Any application can also get the status of the slider by checking
00021  * the feature.
00022  * This is specific to the camera slider.
00023  * The notifyDetailsP param in SysNotifyParamType is null in the notification.
00024  * Application should check the status of the slider by using the Feature.
00025  *
00026  */
00027
00028 #ifndef __PalmCameraSlider_H__
00029 #define __PalmCameraSlider_H__
00030
00031 // Palm OS common definitions
00032 #include <PalmTypes.h>
00033 #include <SystemMgr.h>
00034
00035 /***********************************************************************
00036  * Slider notification and status
00037  ***********************************************************************/
00038
00039 /** Version information for the camera slider. */
00040 #define kCamSliderVersion1  sysMakeROMVersion(1, 0, 0, sysROMStageDevelopment, 0)
00041
00042 /** Version information for the camera slider. */
00043 #define kCamSliderVersion   kCamSliderVersion1
00044
00045 /** Feature for testing if the slider is open. */
00046 #define kCamSliderFlagsOpened           0x00000001
00047
00048 /** Camera Slider creator ID. */
00049 #define kCamSliderCreator       'cslP'
00050
00051 /** Notification creator. */
00052 #define kCamSliderNotifyEvent   kCamSliderCreator
00053
00054 /** Feature value should be kCamSliderVersion. */
00055 #define kCamSliderFtrVersionNum 0
00056
00057 /** Feature value should be kCamSliderFlagsOpened or 0. */
00058 #define kCamSliderFtrFlagsNum   1
00059
00060 #endif // __PalmCameraSlider_H__
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:54 2008 for Palm API Guide


Header Files » Incs » common » libraries » codecpluginmgr

palmOneCodecFormat.h

Go to the documentation of this file.
00001 /*******************************************************************************
00002  * Copyright (c) 2004-2005 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  ******************************************************************************/
00005 /**
00006  * @ingroup Codec
00007  */
00008
00009 /**
00010  * @file    palmOneCodecFormat.h
00011  * @version 1.0
00012  *
00013  * @brief   Public 68K common header file for Codec Plugin Manager API - Codec Formats.
00014  *
00015  * This file contains the list of known codecs. The codecs listed below
00016  * may not be implemented yet. Each format is identified with a 4-byte
00017  * ID as an attempt to avoid collision and be human readable.
00018  * <hr>
00019  */
00020
00021 #ifndef _PALMONECODECFORMAT_H_
00022 #define _PALMONECODECFORMAT_H_
00023
00024 #include <PalmTypes.h>
00025 #include <VFSMgr.h>
00026 #include <FileStream.h>
00027
00028 /**
00029  * @name Audio Codecs
00030  */
00031 /*@{*/
00032 #define palmCodecAudioPCM           'PCM1'  /**< Raw PCM Audio Format. */
00033 #define palmCodecAudioAAC           'DAAC'  /**< AAC Audio Format. */
00034 #define palmCodecAudioMP1           'MPG1'  /**< MPEG Layer 1 Audio Format. */
00035 #define palmCodecAudioMP2           'MPG2'  /**< MPEG Layer 2 Audio Format. */
00036 #define palmCodecAudioMP3           'MPG3'  /**< MPEG Layer 3 Audio Format. */
00037 #define palmCodecAudioVORBIS        'OGGV'  /**< OGG Vorbis Audio Format. */
00038 #define palmCodecAudioIMA_ADPCM     'APCM'  /**< IMA ADPCM Audio Format. */
00039 #define palmCodecAudioDVI_ADPCM     'DPCM'  /**< Intel/MS/DVI ADPCM. */
00040 #define palmCodecAudioALAW          'ALAW'  /**< A-Law Audio Format. */
00041 #define palmCodecAudioULAW          'ULAW'  /**< U-Law Audio Format. */
00042 /*@}*/
00043
00044 /**
00045  * @name Speech Codecs
00046  */
00047 /*@{*/
00048 #define palmCodecAudioAMR           'AMRS'  /**< GSM-AMR Speech Format. */
00049 #define palmCodecAudioQCELP         'QCLP'  /**< CDMA-QCELP Speech Format. */
00050 #define palmCodecAudioG711          'G711'  /**< G.711 Speech Format. */
00051 #define palmCodecAudioG722          'G722'  /**< G.722 Speech Format. */
00052 #define palmCodecAudioG726          'G726'  /**< G.726 Speech Format. */
00053 #define palmCodecAudioG728          'G728'  /**< G.728 Speech Format. */
00054 /*@}*/
00055
00056 /**
00057  * @name Video Codecs
00058  */
00059 /*@{*/
00060 #define palmCodecVideoMPEG4         'MPG4'  /**< MPEG-4 Video Format. */
00061 #define palmCodecVideoMPEG1         'Mpg1'  /**< MPEG-1 Video Format. */
00062 #define palmCodecVideoMPEG2         'Mpg2'  /**< MPEG-2 Video Format. */
00063 #define palmCodecVideoH263          'H263'  /**< H263 Video Format. */
00064 #define palmCodecVideoMJPEG         'MJPG'  /**< Motion JPEG Video Format. */
00065 #define palmCodecVideoDIVX          'DivX'  /**< DivX Video Format. */
00066 #define palmCodecVideoXVID          'XviD'  /**< XviD Video Format. */
00067 #define palmCodecVideoAVC           'AVCd'  /**< AVC(H.264) Video Format. */
00068
00069 /*@}*/
00070
00071 /**
00072  * @name Text Codecs
00073  */
00074 /*@{*/
00075 #define palmCodecText3G             '3GTX'  /**< 3G Text Format. */
00076 /*@}*/
00077
00078 /**
00079  * @name Still Images Codecs
00080  */
00081 /*@{*/
00082 #define palmCodecImageJPEG          'JPEG'  /**< JPEG Image Format. */
00083 #define palmCodecImageGIF87a        'GIF7'  /**< GIF87a Image Format. */
00084 #define palmCodecImageGIF89a        'GIF9'  /**< GIF89a Image Format. */
00085 #define palmCodecImagePNG           'PNGI'  /**< Portable Network Graphics Image Format. */
00086 #define palmCodecImageWBMP          'WBMP'  /**< Windows Bitmap Image Format. */
00087 #define palmCodecImageTIFF          'TIFF'  /**< TIFF Image Format. */
00088 /*@}*/
00089
00090 /**
00091  * @name Image File Formats
00092  */
00093 /*@{*/
00094 #define palmCodecImageJPEGFile      'JPEF'  /**< JPEG Image File Format. */
00095 #define palmCodecImageGIF87aFile    'GI7F'  /**< GIF87a Image File Format. */
00096 #define palmCodecImageGIF89aFile    'GI9F'  /**< GIF89a Image Format. */
00097 #define palmCodecImagePNGFile       'PNGF'  /**< Portable Network Graphics Image File Format. */
00098 #define palmCodecImageWBMPFile      'WBMF'  /**< Windows Bitmap Image File Format. */
00099 #define palmCodecImageTIFFFile      'TFFF'  /**< TIFF Image File Format. */
00100 /*@}*/
00101
00102 #define palmCodecImageBase          'IM00'  /**< Base code for Image formats. */
00103
00104 /**
00105  * Image Formats
00106  */
00107 enum
00108 {
00109     palmCodecImageARGB32 = palmCodecImageBase, /**< 32 bit color with alpha channel. */
00110     palmCodecImageRGBA32,           /**< ('IM01') 32 bit color with alpha channel. */
00111     palmCodecImageRGB32,            /**< ('IM02') 32 bit RGB color without alpha channel. */
00112     palmCodecImageRGB888,           /**< ('IM03') 24 bit RGB color. */
00113     palmCodecImageRGB888Planar,     /**< ('IM04') 24 bit RGB Planar color. */
00114     palmCodecImageRGB565,           /**< ('IM05') 16 bit RGB color. */
00115     palmCodecImageRGB555,           /**< ('IM06') 16 bit RGB color + don't care. */
00116     palmCodecImageBGRA32,           /**< ('IM07') 32 bit BGR color with alpha channel. */
00117     palmCodecImageBGR32,            /**< ('IM08') 32 bit BGR color without alpha channel. */
00118     palmCodecImageBGR888,           /**< ('IM09') 24 bit BGR color. */
00119     palmCodecImageBGR565,           /**< ('IM0:') 16 bit BGR color. */
00120     palmCodecImageBGR555,           /**< ('IM0;') 16 bit BGR color + don't care. */
00121     palmCodecImageYUV444,           /**< ('IM0<') 4:4:4 YUV format. */
00122     palmCodecImageYUV422,           /**< ('IM0=') 4:2:2 YUV format. */
00123     palmCodecImageYUV420,           /**< ('IM0>') 4:2:0 YUV format. */
00124     palmCodecImageYUV411,           /**< ('IM0?') 4:1:1 YUV format. */
00125     palmCodecImageYUV211,           /**< ('IM0@') 2:1:1 YUV format. */
00126     palmCodecImageYUV444Planar,     /**< ('IM0A') 4:4:4 Planar YUV format. */
00127     palmCodecImageYUV422Planar,     /**< ('IM0B') 4:2:2 Planar YUV format. */
00128     palmCodecImageYUV420Planar,     /**< ('IM0C') 4:2:0 Planar YUV format. */
00129     palmCodecImageYUV411Planar,     /**< ('IM0D') 4:1:1 Planar YUV format. */
00130     palmCodecImageYUV211Planar,     /**< ('IM0E') 2:1:1 Planar YUV format. */
00131     palmCodecImageYCbCr444,         /**< ('IM0F') 4:4:4 YCbCr format. */
00132     palmCodecImageYCbCr422,         /**< ('IM0G') 4:2:2 YCbCr format. */
00133     palmCodecImageYCbCr420,         /**< ('IM0H') 4:2:0 YCbCr format. */
00134     palmCodecImageYCbCr411,         /**< ('IM0I') 4:1:1 YCbCr format. */
00135     palmCodecImageYCbCr211,         /**< ('IM0J') 2:1:1 YCbCr format. */
00136     palmCodecImageYCbCr444Planar,   /**< ('IM0K') 4:4:4 Planar YCbCr format. */
00137     palmCodecImageYCbCr422Planar,   /**< ('IM0L') 4:2:2 Planar YCbCr format. */
00138     palmCodecImageYCbCr420Planar,   /**< ('IM0M') 4:2:0 Planar YCbCr format. */
00139     palmCodecImageYCbCr411Planar,   /**< ('IM0N') 4:1:1 Planar YCbCr format. */
00140     palmCodecImageYCbCr211Planar,   /**< ('IM0O') 2:1:1 Planar YCbCr format. */
00141     palmCodecImageRGBIndex16,       /**< ('IM0P') Palettized 16 bit RGB. */
00142     palmCodecImageRGBIndex8,        /**< ('IM0Q') Palettized 8 bit RGB. */
00143     palmCodecImageRGBIndex4,        /**< ('IM0R') Palettized 4 bit RGB. */
00144     palmCodecImageRGBIndex2,        /**< ('IM0S') Palettized 2 bit RGB. */
00145     palmCodecImageRGBIndex1,        /**< ('IM0T') Palettized 1 bit RGB. */
00146     palmCodecImageRGBIndex,         /**< ('IM0U') Palettized RGB (unknowm index size). */
00147     palmCodecImageGRAY8,            /**< ('IM0V') Gray color 8 bit. */
00148     palmCodecImageGRAY4,            /**< ('IM0W') Gray color 4 bit. */
00149     palmCodecImageGRAY2,            /**< ('IM0X') Gray color 2 bit. */
00150     palmCodecImageGRAY1,            /**< ('IM0Y') Gray color 1 bit. */
00151     palmCodecImageGIFFrame,         /**< ('IM0Z') GIF Frame format. */
00152     palmCodecImageCMY,              /**< ('IM0[') Cyan Magenta Yellow format. */
00153     palmCodecImageCMYK,             /**< ('IM0\') Cyan Magenta Yellow BlacK format. */
00154     palmCodecImageHSL,              /**< ('IM0]') Hue Saturation Lightness format. */
00155     palmCodecImageHSI,              /**< ('IM0^') Hue Saturation Intensity format. */
00156     palmCodecImageHSV,              /**< ('IM0_') Hue Saturation Value format. */
00157     palmCodecImageHCI               /**< ('IM0`') Hue Chroma Intensity format. */
00158 };
00159
00160
00161 /**
00162  * Audio channels
00163  */
00164 typedef enum {
00165     palmCodecMONO   = 0x01, /**< One channel. */
00166     palmCodecSTEREO         /**< Two channels. */
00167
00168 } PalmAudioChannelType;
00169
00170 /**
00171  * Basic data types
00172  */
00173 typedef enum {
00174
00175     // Compatibility layer for sound manager
00176     palmCodecINT8           = 0x01, /**< Signed 8-bit. */
00177     palmCodecUINT8          = 0x11, /**< Unsigned 8-bit. */
00178     palmCodecINT16Big       = 0x02, /**< Signed 16-bit big-endian. */
00179     palmCodecINT16Little    = 0x12, /**< Signed 16-bit little-endian. */
00180     palmCodecINT32Big       = 0x04, /**< Signed 32-bit big-endian. */
00181     palmCodecINT32Little    = 0x14, /**< Signed 32-bit little-endian. */
00182     palmCodecFloatBig       = 0x24, /**< Float big-endian. */
00183     palmCodecFloatLittle    = 0x34, /**< Float little-endian. */
00184
00185     // Extra types
00186     palmCodecUINT16Big,             /**< Unsigned 16-bit big-endian. */
00187     palmCodecUINT16Little,          /**< Unsigned 16-bit little-endian. */
00188     palmCodecINT24,                 /**< Signed 24-bit. */
00189     palmCodecUINT24,                /**< Unsigned 24-bit. */
00190     palmCodecUINT32Big,             /**< Unsigned 32-bit big-endian. */
00191     palmCodecUINT32Little           /**< Unsigned 32-bit little-endian. */
00192
00193 } PalmBasicType;
00194
00195 /**
00196  * Endianess
00197  */
00198 typedef enum {
00199     palmCodecBIG_ENDIAN,    /**< Big endian. */
00200     palmCodecLITTLE_ENDIAN  /**< Little endian. */
00201
00202 } PalmEndianType;
00203
00204
00205 /**
00206  * File types
00207  */
00208 typedef enum {
00209     palmCodecVFSFile,       /**< VFS File. */
00210     palmCodecStreamFile     /**< Stream File. */
00211
00212 } PalmFileType;
00213
00214 /**
00215  * BMP compression
00216  */
00217 typedef enum {
00218     palmCodecBMP_None,      /**< No compression. */
00219     palmCodecBMP_RLE4,      /**< RLE 4bit compression. */
00220     palmCodecBMP_RLE8       /**< RLE 8bit compression. */
00221
00222 } PalmBMPCompressionType;
00223
00224 /**
00225  * AAC profiles
00226  */
00227 typedef enum {
00228     palmCodecAACMainProfile,  /**< Main Profile */
00229     palmCodecAACLowComplexity, /**< Low Complexity Profile */
00230     palmCodecAACScaleableSamplingRate /**< SSR Profile*/
00231
00232 } PalmAACProfileType;
00233
00234 /**
00235  * AMR modes
00236  */
00237 typedef enum {
00238     palmCodecAMR475,        /**<  4.75 kBits/second. */
00239     palmCodecAMR515,        /**<  5.15 kBits/second. */
00240     palmCodecAMR59,         /**<  5.9  kBits/second. */
00241     palmCodecAMRM67,        /**<  6.7  kBits/second. */
00242     palmCodecAMR74,         /**<  7.4  kBits/second. */
00243     palmCodecAMR795,        /**<  7.95 kBits/second. */
00244     palmCodecAMR102,        /**< 10.2  kBits/second. */
00245     palmCodecAMR122         /**< 12.2  kBits/second. */
00246
00247 } PalmAMRMode;
00248
00249 /**
00250  * AMR transmission settings
00251  */
00252 typedef enum {
00253     palmCodecAMRDtxDisable, /**< Disable discontinuous transmission mode. */
00254     palmCodecAMRDtxEnable   /**< Enable discontinuous transmission mode. */
00255
00256 } PalmAMRDtxMode;
00257
00258 /**
00259  * QCELP rates
00260  */
00261 typedef enum {
00262     palmCodecQCELPSilent,   /**<   0 Bits per packet. */
00263     palmCodecQCELPEighth,   /**<  20 Bits per packet. */
00264     palmCodecQCELPQuarter,  /**<  54 Bits per packet. */
00265     palmCodecQCELPHalf,     /**< 124 Bits per packet. */
00266     palmCodecQCELPFull      /**< 266 Bits per packet. */
00267
00268 } PalmQCELPRate;
00269
00270 /**
00271  * QCELP encoder settings
00272  */
00273 typedef enum {
00274     palmCodecQCELPReducedDisabled,  /**<  Disable reduced rate encoding. */
00275     palmCodecQCELPReducedEnabled    /**<  Enable reduced rate encoding. */
00276
00277 } PalmQCELPReducedRate;
00278
00279 /**
00280  * AAC file formats
00281  */
00282 typedef enum {
00283     palmCodecAAC_RAW,   /**<  RAW format.  */
00284     palmCodecAAC_ADIF,  /**<  ADIF format. */
00285     palmCodecAAC_ADTS,  /**<  ADTS format. */
00286     palmCodecAAC_MP4A,  /**<  MP4A format. */
00287     palmCodecAAC_LATM   /**<  LATM format. */
00288
00289 } AACHeaderType;
00290
00291 /**
00292  * AAC object type
00293  */
00294 typedef enum {
00295     MAIN        = 1,
00296     LC,
00297     SSR,
00298     LTP,
00299     HE_AAC,
00300     ER_LC       = 17,
00301     ER_LTP      = 19,
00302     LD          = 23,
00303     DRM_ER_LC   = 27
00304
00305 } AACObjectType;
00306
00307 /**
00308  * File flags
00309  */
00310 typedef enum {
00311     VFS = 1,        /**<  VFS.  */
00312     FileStream = 2  /**<  FileStream. */
00313
00314 } FileFlag;
00315
00316 /**
00317  * MPEG4 encoding algorithm
00318  */
00319 typedef enum {
00320     palmCodecMPEG4MVFAST,   /**< Motion Vector Field Adaptation Search Technique. */
00321     palmCodecMPEG4SEA       /**< Successive Elimination Algorithm. */
00322
00323 } PalmMPEG4Algorithm;
00324
00325
00326 /**
00327  * Custom controls / API selectors
00328  */
00329 typedef enum {
00330     palmCodecCtlGetVersion,                 /**< Get the codec version. (UInt32 in SysMakeROM style) */
00331     palmCodecCtlGetAuthor,                  /**< Get the codec author. (Char[64]) */
00332     palmCodecCtlGetDate,                    /**< Get the codec date. (Char[10] like "09/02/2003") */
00333     palmCodecCtlGetComments,                /**< Get comments about the codec. (Char[512]) */
00334     palmCodecCtlLastBuffer,                 /**< Next EncodeDecode call will get the last buffer. */
00335     palmCodecCtlCustomBase  = 0x80000000,   /**< Custom custom control base. */
00336
00337     // AVC specific API
00338     palmCodecCtlAVCGetInfo,                 /**< Get the video frame width/ht info. */
00339     palmCodecCtlAVCGetDecodedFrame,         /**< Get the decoded frame. */
00340     palmCodecCtlAVCSetCropMode,             /**< Set the crop mode. */
00341
00342     // Secure access to particular codec
00343     palmCodecCtlPutSeed,                    /**< Give the codec a random number. */
00344     palmCodecCtlGetKey,                     /**< Get the encoded key from the codec. */
00345     palmCodecCtlPutKey,                     /**< Give the re-encoded key to the codec. */
00346
00347     // AAC specific API
00348     palmCodecCtlAACGetInfo                  /**< Get the audio frame freq/chan info. */
00349
00350 } PalmCodecControlType;
00351
00352
00353 /**
00354  * @brief RAW image format parameters
00355  */
00356 typedef struct {
00357     UInt32  width;              /**< Width of the image. */
00358     UInt32  height;             /**< Height of the image. */
00359     UInt32  rowByte;            /**< Rowbyte of the image. */
00360     UInt32  endianess;          /**< Big Endian, Little Endian. */
00361
00362 } PalmImageParamType;
00363
00364 #define MAX_PLANE_COUNT     5   /**< Maximum number of image planes */
00365
00366 /**
00367  * @brief Planar image structure, passed during EncodeDecode
00368  */
00369 typedef struct {
00370     UInt32  width;              /**< Width of the image. */
00371     UInt32  height;             /**< Height of the image. */
00372
00373     // Plane info
00374     void    *planeP[MAX_PLANE_COUNT];   /**< Image planes. */
00375     UInt32  planeWidth[MAX_PLANE_COUNT];/**< Width of each plane. */
00376     UInt32  planeCount;                 /**< Number of planes used. */
00377
00378 } PalmImagePlanarType;
00379
00380 /**
00381  * @brief PCM format parameters
00382  */
00383 typedef struct {
00384     UInt32  sampleRate;         /**< Sample rate (44100, 32000...). */
00385     UInt32  sampleType;         /**< Sample type (use the one one from Sound Manager). */
00386     UInt32  sampleWidth;        /**< Sample width (mono/stereo). */
00387
00388 } PalmAudioPCMParamType;
00389
00390 /**
00391  * @brief IMA-ADPCM format parameters
00392  */
00393 typedef struct {
00394     UInt32  sampleRate;         /**< Sample rate (44100, 32000...). */
00395     UInt32  sampleWidth;        /**< Sample width (mono/stereo). */
00396     UInt32  blockSize;          /**< Block Size. */
00397
00398 } PalmAudioADPCMParamType;
00399
00400 /**
00401  * @brief AAC format parameters
00402  */
00403 typedef struct {
00404     UInt32  bitRate;            /**< Bits per second. */
00405     UInt32  sampleRate;         /**< Sample rate (44100, 32000...). */
00406     UInt32  sampleWidth;        /**< Sample width (mono/stereo). */
00407     UInt32  profile;            /**< Profile used if any. */
00408
00409 } PalmAudioAACParamType;
00410
00411
00412 /**
00413  * @brief AAC decoding parameters
00414  */
00415 typedef struct {
00416     UInt32 fileFormat;              /**< RAW, ADTS, ADIF, MP4A and LATM */
00417
00418     union {
00419         void *ascP;                 /**< Parameter block for MP4A */
00420         void *esdsP;                /**< Parameter block for RAW */
00421     } u;
00422
00423     void *frameP;                   /**< First AAC frame */
00424     UInt32 frameSize;               /**< Frame size */
00425     UInt32 sampleRate;              /**> Sample rate returned */
00426
00427 } PalmAudioAACDecParamType;
00428
00429 typedef struct {
00430     UInt32 flags;                   /**< Set to VFS or FileStream */
00431
00432     union {
00433         struct {
00434             UInt32 volRefNum;
00435             FileRef fileRef;
00436         } file;
00437
00438         struct {
00439             FileHand fileH;
00440             UInt32 type;
00441             UInt32 creator;
00442         } stream;
00443     } u;
00444
00445 } AacFileRef, *AacFileRefPtr;
00446
00447 /*
00448  * @brief AMR format encoding parameters
00449  */
00450 typedef struct {
00451     UInt32  mode;               /**< Encoding mode (i.e. kBits/second). */
00452     UInt32  dtxMode;            /**< Discontinuous transmission mode. */
00453
00454 } PalmAudioAMRParamType;
00455
00456 /*
00457  * @brief QCELP format encoding parameters
00458  */
00459 typedef struct {
00460     UInt32  maxRate;            /**< Maximum rate. */
00461     UInt32  minRate;            /**< Minimum rate. */
00462     UInt32  reducedRate;        /**< Reduced rate flag. */
00463
00464 } PalmAudioQCELPParamType;
00465
00466 /*
00467  * @brief QCELP format decoding parameter
00468  */
00469 typedef struct {
00470     UInt32  headerSize;         /**< size of RIFF header. */
00471     UInt32  headerP;            /**< RIFF header. */
00472
00473 } PalmAudioQCELPDecParamType;
00474
00475 /**
00476  * @brief MPEG-1 audio decoding parameters
00477  */
00478 typedef struct {
00479     UInt32 avgBytesPerSec;
00480     UInt32 bitsPerSample;
00481     UInt32 channels;
00482     UInt32 sampleRate;
00483
00484 } PalmAudioMP2ParamType;
00485
00486 /**
00487  * @brief File format parameters
00488  */
00489 typedef struct {
00490     UInt32      fileLocationType;   /**< File location type. */
00491     FileRef     vfsFileRef;         /**< File Reference for VFS type. */
00492     FileHand    streamFileHandle;   /**< File Handle for File Stream type. */
00493
00494 } PalmFileFormatParamType;
00495
00496
00497 /**
00498  * @brief BMP format parameters
00499  */
00500 typedef struct {
00501     UInt32  xPixelsPerMeter;    /**< Horizontal resolution. */
00502     UInt32  yPixelsPerMeter;    /**< Vertical resolution. */
00503     UInt32  colorUsed;          /**< Number of color indices actually used. */
00504     UInt32  colorImportant;     /**< Number of color indices actually required. 0 = all colors required. */
00505     UInt32  compression;        /**< Bitmap compression. */
00506
00507 } PalmImageBMPParamType;
00508
00509
00510 /**
00511  * @brief JPEG format encoding parameters
00512  */
00513 typedef struct {
00514     UInt32  quality;            /**< JPEG quality between 0 and 100. */
00515     UInt32  restartInterval;    /**< Number of restart intervals. */
00516     UInt32  JPEGMode;           /**< Baseline/Progressive... */
00517     UInt32  subSampling;        /**< SubSampling YCbCr (444, 422, 411). */
00518
00519 } PalmImageJPEGEncodeParamType;
00520
00521 /**
00522  * @brief GIF frame parameters
00523  *
00524  * Each GIF frame contains more info than a simple palette and image buffer.
00525  */
00526 typedef struct {
00527     UInt32  leftPosition;           /**< Left position of the image. */
00528     UInt32  topPosition;            /**< Top posistion of the image. */
00529     UInt32  imageWidth;             /**< Image width. */
00530     UInt32  imageHeight;            /**< Image height. */
00531     UInt32  localColorBits;         /**< Number of bits for the local color table. */
00532     UInt32  hasLocalColorTable;     /**< 1 if has local color table, 0 otherwise. */
00533     UInt32  isInterlaced;           /**< 1 if interlaced, 0 otherwise. */
00534     UInt32  hasTransparentColor;    /**< 1 if has transparency, 0 otherwise. */
00535     UInt32  transparentColorIndex;  /**< Transparency color index. */
00536     UInt32  disposalMethod;         /**< Disposal method. (Refer to GIF standard)*/
00537     UInt32  delayTime;              /**< Delay for the current image. */
00538     UInt8   localColorTable[256*3]; /**< Local color table. */
00539     UInt32  imageDataSize;          /**< Size of the image buffer. */
00540     UInt8   *imageDataP;            /**< Raw Image. */
00541
00542 } PalmImageGIFFrameParamType;
00543
00544 /**
00545  * @brief Index image parameters
00546  */
00547 typedef struct {
00548     UInt32  width;              /**< Width of the image. */
00549     UInt32  height;             /**< Height of the image. */
00550     UInt32  rowByte;            /**< Rowbyte of the image. */
00551     UInt32  endianess;          /**< Big Endian, Little Endian. */
00552     UInt32  colorBits;          /**< Number of bits for the color table. */
00553     UInt8   *colorTable;        /**< Color table. Should have the size 4*2^(colorBits). */
00554     UInt8   *imageDataP;        /**< Raw Image data. */
00555
00556 } PalmImageINDEXParamType;
00557
00558 /**
00559  * @brief MPEG-1 video decoding parameters
00560  */
00561 typedef struct {
00562     UInt32  width;          /**< Width. */
00563     UInt32  height;         /**< Height. */
00564     UInt32  skipBFrames;    /**< B Frame are very time consuming. If True skip B-Frames. */
00565
00566 } PalmVideoMPEG1DecodeParamType;
00567
00568 /**
00569  * @brief MPEG-4 video format encoding parameters
00570  */
00571 typedef struct {
00572     UInt32  profile;            /**< Profile used if any. */
00573     UInt32  volWidth;           /**< Video Object Layer width. */
00574     UInt32  volHeight;          /**< Video Object Layer height. */
00575     UInt32  keyFrame;           /**< Number of P-Frames between two I-Frames. */
00576     UInt32  frameRate;          /**< Number of frames per second. */
00577     UInt32  bitRate;            /**< Bit rate target. */
00578     UInt32  algorithm;          /**< MV_FAST, SEA... */
00579     UInt32  IVOPQuantization;   /**< Quantization step in I-VOP frames. */
00580     UInt32  VOVOLVersionID;     /**< Version ID for VO & VOL header. */
00581     UInt32  searchRange;        /**< Motion search range (in pixels). */
00582
00583 } PalmVideoMPEG4EncodeParamType;
00584
00585 /**
00586  * @brief MPEG-4 video format decoding parameters
00587  */
00588 typedef struct {
00589     UInt32  profile;            /**< Profile used if any. */
00590     UInt32  volWidth;           /**< Video Object Layer width. */
00591     UInt32  volHeight;          /**< Video Object Layer width. */
00592 } PalmVideoMPEG4DecodeParamType;
00593
00594
00595 /**
00596  * @brief AVC/H264 video format decoding parameters
00597  */
00598 typedef struct {
00599     UInt8           *NALUnit;
00600     UInt32          NALUnitSize;
00601     UInt32          compositionTimestamp;
00602     double          compositionTime;
00603 } PalmVideoAVCDecodeParamType;
00604
00605 /**
00606  * @brief AVC/H264 Custom Control API structure for GetInfo about frame
00607  */
00608 typedef struct {
00609     UInt16          frameWidth;          /**< width of lum. plane in pixels */
00610     UInt16          frameHeight;         /**< Ht of lum. plane in pixels */
00611     UInt16          frameWidthCropped;   /**< Width of cropped lum. plane in pixels */
00612     UInt16          frameHeightCropped;  /**< height of cropped lum. plane in pixels */
00613     UInt16          horizontalOffset;    /**< Horizontal offset of cropped lum. plane */
00614     UInt16          verticalOffset;      /**< Vertical offset of cropped lum. plane */
00615     UInt32          chromaFormat;        /**< Chroma format, only YUV420 for now */
00616 } PalmVideoAVCCustomGetInfoType;
00617
00618 /**
00619  * @brief AVC/H264 Custom Control API structure for getting a decoded frame
00620  */
00621 typedef struct {
00622     PalmImagePlanarType  planarData;
00623     Int32                framesReady;
00624     UInt16               picWidth;            /**< width of lum. plane in pixels */
00625     UInt16               picWidthCropped;     /**< Width of cropped lum. plane in pixels */
00626     UInt16               picHeight;           /**< Ht of lum. plane in pixels */
00627     UInt16               picHeightCropped;    /**< height of cropped lum. plane in pixels */
00628     UInt16               stride;              /**< offset from start of one line of from to start of next */
00629     UInt32               compositionTimestamp;/**< timestamp moment in time decoded data to be played back */
00630     double               compositionTime;     /**< time describing moment in time decoded data to be played back */
00631 } PalmVideoAVCCustomGetDecodedFrameType;
00632
00633 /**
00634  * @brief AVC/H264 Custom Control API structure for getting a decoded frame
00635  */
00636 typedef struct {
00637     Boolean              bCroppedMode;        /**< TRUE - output cropped size, FALSE - full size */
00638 } PalmVideoAVCCustomSetCropModeType;
00639
00640 /**
00641  * @brief AVC/H264 video format decoding parameters
00642  */
00643 typedef struct {
00644     Int32                framesReady;         /**< No. of avail. decoded frames */
00645 } PalmVideoAVCOutputBufferType;
00646
00647
00648 #endif  // _PALMONECODECFORMAT_H_
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:54 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » codecpluginmgr

palmOneCodecPluginMgr.h

Go to the documentation of this file.
00001 /******************************************************************************
00002  * Copyright (c) 2004 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  *****************************************************************************/
00005 /**
00006  * @ingroup Codec
00007  */
00008
00009 /**
00010  * @file    palmOneCodecPluginMgr.h
00011  * @version 3.0
00012  *
00013  * @brief   The Codec Plugin Manager is used to unify all different type of
00014  *          codecs that are available for PalmOne devices and provide a generic
00015  *          API for developers to access these codecs.
00016  *
00017  * A typical application would use the library the following way:
00018  * - Check is an input/output format pair is supported [optional]
00019  * - Create a CodecSession with parameters that match the formats
00020  * - Call EncodeDecode()
00021  * - ...
00022  * - Delete the session.
00023  *
00024  */
00025
00026 #ifndef _PALMONECODECPLUGINMGR_H_
00027 #define _PALMONECODECPLUGINMGR_H_
00028
00029 #include <PalmTypes.h>
00030 #include <ErrorBase.h>
00031 #include <SystemMgr.h>
00032 #include <LibTraps.h>
00033 #include <palmOneCodecPluginMgrCommon.h>
00034
00035 /***********************************************************************
00036  * API Prototypes
00037  ***********************************************************************/
00038
00039 #ifdef __cplusplus
00040 extern "C" {
00041 #endif
00042
00043 /**
00044  * Opens the Codec Plugin Manager library.
00045  *
00046  * @param refNum:   IN: Reference number of the CodecPluginMgr library.
00047  * @retval Err errNone if no error
00048  */
00049 Err CodecMgrOpen(UInt16 refNum)
00050         SYS_TRAP(sysLibTrapOpen);
00051 /**
00052  * Closes the Codec Plugin Manager library.
00053  *
00054  * @param refNum:   IN: Reference number of the CodecPluginMgr library.
00055  * @retval Err The library is closed and errNone is returned. If another application is still using the
00056  *             library, a kCodecMgrLibStillOpen error is returned.
00057  */
00058 Err CodecMgrClose(UInt16 refNum)
00059         SYS_TRAP(sysLibTrapClose);
00060
00061 /**
00062  * Standard Sleep function.
00063  *
00064  * @param refNum:   IN: Reference number of the CodecPluginMgr library.
00065  * @retval Err errNone if no error
00066  */
00067 Err CodecMgrSleep(UInt16 refNum)
00068         SYS_TRAP(sysLibTrapSleep);
00069
00070
00071 /**
00072  * Standard Wake function.
00073  *
00074  * @param refNum:   IN: Reference number of the CodecPluginMgr library.
00075  * @retval Err errNone if no error
00076  */
00077 Err CodecMgrWake(UInt16 refNum)
00078         SYS_TRAP(sysLibTrapWake);
00079
00080 /**
00081  * Return the version of the Codec Plugin Manager library API to which
00082  * this Codec was written. The API version of the manager that is loading
00083  * this plugin is passed in, so that the plugin can either handle older
00084  * managers, or return kCodecMgrLibNotSupported.
00085  *
00086  * @param refNum:                   IN: Reference number of the CodecPluginMgr library.
00087  * @param codecMgrAPIVersion:       IN: The largest version of the codec API supported
00088  * @param codecMgrLibAPIVersionP:   IN: Receives the API version to which this plugin was written.
00089  *                                      If the plugin supports multiple API versions, this should
00090  *                                      be set to the same version as codecMgrAPIVersion.
00091  * @retval Err errNone if no error, kCodecMgrLibNotSupported if the manager
00092  *             is too old to handle this plugin
00093  */
00094 Err CodecMgrLibAPIVersion(UInt16 refNum, UInt32 codecMgrAPIVersion, UInt32 *codecMgrLibAPIVersionP)
00095         SYS_TRAP(kCodecMgrLibTrapLibAPIVersion);
00096
00097 /**
00098  * Create a Codec Session.
00099  * A session is Codec dependent, which means it is up to a Codec to define
00100  * the structure (if any) pointed by the Session.
00101  * This function is called by the CodecPluginMgr. At this stage, the CPM
00102  * has already selected a known format pair from its codec list.
00103  * The input and output parameters have to match the format they represent.
00104  * E.g. palmCodecImageJPEG as input uses PalmJPEGEncodeType
00105  *      palmCodecImageJPEG as output uses PalmJPEGDecodeType etc.
00106  *
00107  * @param refNum:       IN: Reference number of the CodecPluginMgr library.
00108  * @param inputFormat:  IN: Input format for this session.
00109  * @param inputParamP:  IN: Parameter associated with the input format. NULL if not needed.
00110  * @param outputFormat: IN: Output format for this session.
00111  * @param outputParamP: IN: Parameter associated with the output format. NULL if not needed.
00112  * @param sessionP      OUT: Receives the reference to the newly created session.  This reference is passed into all future calls for this session.
00113  *
00114  * @retval Err errNone if no error.
00115  */
00116 Err CodecMgrCreateSession(UInt16 refNum, PalmCodecFormat inputFormat, void *inputParamP, PalmCodecFormat outputFormat, void *outputParamP, PalmCodecSession *sessionP)
00117         SYS_TRAP(kCodecMgrLibTrapCreateSession);
00118
00119
00120 /**
00121  * Create a Codec Session using Creator and Codec  ID.
00122  * A session is Codec dependent, which means it is
00123  * up to a Codec to define the structure (if any) pointed by the Session.
00124  * This function is called by the CodecPluginMgr. At this stage, the CPM
00125  * has already selected a known format pair from its codec list.
00126  * The input and output parameters have to match the format they represent.
00127  * E.g. palmCodecImageJPEG as input uses PalmJPEGEncodeType
00128  *      palmCodecImageJPEG as output uses PalmJPEGDecodeType etc.
00129  *
00130  * This function is used to create a session when a multiple codecs
00131  * using the same input and output format are available.
00132  *
00133  * @param refNum:       IN: Reference number of the CodecPluginMgr library.
00134  * @param inputFormat:  IN: Input format for this session.
00135  * @param inputParamP:  IN: Parameter associated with the input format. NULL if not needed.
00136  * @param outputFormat: IN: Output format for this session.
00137  * @param outputParamP: IN: Parameter associated with the output format. NULL if not needed.
00138  * @param creatorID:    IN: Creator ID of the module containing the codec.
00139  * @param codecID:      IN: Codec ID for a specific codec.
00140  * @param sessionP:     OUT: Receives the reference to the newly created session.  This reference is passed into all future calls for this session.
00141  *
00142  * @return  errNone if no error.
00143  */
00144 Err CodecMgrCreateSessionByID(UInt16 refNum, PalmCodecFormat inputFormat, void *inputParamP, PalmCodecFormat outputFormat, void *outputParamP, UInt32 creatorID, UInt32 codecID, PalmCodecSession *sessionP)
00145         SYS_TRAP(kCodecMgrLibTrapCreateSessionByID);
00146
00147
00148 /**
00149  * Delete a session.
00150  * This function has to delete any allocated memory and set the
00151  * session reference to NULL.
00152  *
00153  * @param refNum:   IN: Reference number of the CodecPluginMgr library.
00154  * @param sessionP: IN: Pointer to the Codec session reference received from CodecCreateSession.
00155  * @retval Err errNone if no error.
00156  */
00157 Err CodecMgrDeleteSession(UInt16 refNum, PalmCodecSession *sessionP)
00158         SYS_TRAP(kCodecMgrLibTrapDeleteSession);
00159
00160 /**
00161  * Reset a session.
00162  *
00163  * @param refNum:   IN: Reference number of the CodecPluginMgr library.
00164  * @param session:  IN: Session to reset.
00165  * @retval Err errNone if no error.
00166  */
00167 Err CodecMgrResetSession(UInt16 refNum, PalmCodecSession session)
00168         SYS_TRAP(kCodecMgrLibTrapResetSession);
00169
00170 /**
00171  * Returns the output buffer size required given an input buffer.
00172  * This function is not required, but rather is provided to try to help the caller
00173  * allocate the appropriate amount of memory for a call to CodecEncodeDecode
00174  * that takes the same parameters.  It is recommended that you always return
00175  * a number equal to or larger then the buffer that will be required to hold
00176  * the output of the CodecEncodeDecode call.
00177  *
00178  * @param refNum:           IN: Reference number of the CodecPluginMgr library.
00179  * @param session:          IN: Codec session reference received from CodecCreateSession.
00180  * @param srcBufferP:       IN: Input buffer.
00181  * @param srcBufferSize:    IN: Size of the input buffer in bytes.
00182  * @param destBufferSizeP:  OUT: Receives that maximum buffer size.
00183  *
00184  * @retval Err errNone if no error, kCodecMgrLibNotSupported if no implemented.
00185  */
00186 Err CodecMgrGetMaxDestBufferSize(UInt16 refNum, PalmCodecSession session, void *srcBufferP, UInt32 srcBufferSize, UInt32 *destBufferSizeP)
00187         SYS_TRAP(kCodecMgrLibTrapGetMaxDestBufferSize);
00188 /**
00189  * Encode or decode a block of data.
00190  * The format of the source and destination buffers are set in a
00191  * preceding call to CodecCreateSession and possibly calls to CodecCustomControl.
00192  * Is is legal for this function to not encode/decode the whole source buffer.  For
00193  * example, if the source buffer contains a non-round number of encoded blocks, and the
00194  * encoding format requires whole blocks, this call should encode/decode the even
00195  * number of blocks, and set srcBufferP appropriately to indicate how much of the
00196  * source data was actually encoded.  The caller should then pass the un-encoded piece of
00197  * the last chunk in on the next call to this function with the next chunk of data
00198  * appended to the end of it.
00199  *
00200  * @param refNum:           IN: Reference number of the CodecPluginMgr library.
00201  * @param session:          IN: Codec session reference received from CodecCreateSession.
00202  * @param srcBufferP:       IN: The source buffer to be processed.
00203  * @param srcBufferSizeP:   IN,OUT: On input, the size of srcBufferP in bytes.  If the whole
00204  *                                  buffer is not processed, on output srcBufferP is set to the amount of
00205  *                                  source data that was processed.
00206  * @param destBufferP:      OUT: The destination buffer which receives the encoded/decoded data.
00207  * @param destBufferSizeP:  IN,OUT: On input, the size of destBufferP in bytes, on output the number of bytes of data written.
00208  *
00209  * @retval Err errNone if no error
00210  */
00211 Err CodecMgrEncodeDecode(UInt16 refNum, PalmCodecSession session, void *srcBufferP, UInt32 *srcBufferSizeP, void *destBufferP, UInt32 *destBufferSizeP)
00212         SYS_TRAP(kCodecMgrLibTrapEncodeDecode);
00213
00214 /**
00215  * Handle a custom call.
00216  *
00217  * The codec identifies the call and its API by a registered creator code and a selector.
00218  * This allows codec developers to extend the API by defining selectors for their
00219  * creator code. It also allows driver developers to support selectors (and custom calls)
00220  * defined by other driver developers.
00221  *
00222  * @param refNum:       IN: Reference number of the CodecPluginMgr library.
00223  * @param session:      IN: Codec session reference received from CodecCreateSession.
00224  * @param apiCreator:   IN: Registered creator code.
00225  * @param apiSelector:  IN: Custom operation to perform.
00226  * @param valueP:       IN: Buffer containing data specific to the operation.
00227  * @param valueLenP:    IN,OUT: Size of the valueP buffer on entry, size of data written to
00228  *                              valueP on exit. If NULL, valueP is ignored.
00229  * @retval Err errNone if no error, kCodecMgrLibNotSupported if not supported.
00230  */
00231 Err CodecMgrCustomControl(UInt16 refNum, PalmCodecSession session, UInt32 apiCreator, UInt32 apiSelector, void *valueP, UInt32 *valueLenP)
00232         SYS_TRAP(kCodecMgrLibTrapCustomControl);
00233
00234 /**
00235  * Enumerate all supported input and output format pairs.
00236  * A pair describes what input format is expected and what output format
00237  * will come out of the Codec. Codecs can accept multiple format pairs.
00238  * For example, an MP3 Codec might be able to decode only MP3, MP2, and MP1.
00239  * In this case, the pairs are:
00240  *      [in: MP3    out: PCM    codecID: 0]
00241  *      [in: MP2    out: PCM    codecID: 0]
00242  *      [in: MP1    out: PCM    codecID: 0]
00243  *
00244  * The Codec ID is used if multiple codecs within the same PRC have the exact
00245  * same input and output formats. For example, a DSP filter bank might specify
00246  * PCM as both the input and output for every codec. Codec ID helps differentiate between
00247  * these Codecs (Low-Pass, High-Pass, Band-Pass...).
00248  * A Codec ID set to 0 (palmNULLCodecID) means that there is no need to look for
00249  * a particular codec (for example, if there is only one codec in the PRC).
00250  *
00251  * Pass a formatIteratorP of palmCodecIteratorStart to get the first pair.
00252  * formatIteratorP will be updated to the next item. When returning the last
00253  * format pair, the formatIteratorP will be set to palmCodecIteratorStop.
00254  *
00255  * Sample:
00256  *
00257  * PalmCodecFormat inputFormat, outputFormat;
00258  * UInt32 codecID;
00259  * UInt32 formatIterator = palmCodecIteratorStart;
00260  * while (formatIterator != palmCodecIteratorStop) {
00261  *      if ((err = CodecEnumerateSupportedFormats(&formatIterator, &inputFormat, &outputFormat, &codecID)) != errNone) {
00262  *              // Do something with the format pair
00263  *      } else {
00264  *              // handle error... possibly by breaking out of the loop
00265  *      }
00266  * }
00267  *
00268  * @param refNum:           IN: Reference number of the CodecPluginMgr library.
00269  * @param formatIteratorP:  IN,OUT: Reference to the last entry enumerated
00270  *                                  Pass palmCodecIteratorStart to get the first entry.
00271  *                                  This is updated on return to reference the next entry
00272  *                                  or set to palmCodecIteratorStop if last directory entry.
00273  * @param inputFormatP:     IN: Receives the input format entry specified with formatIteratorP.
00274  * @param outputFormatP:    IN: Receives the output format entry specified with formatIteratorP.
00275  * @param creatorIDP:       IN: Pointer to the location where the creator ID associated with the current
00276  *                              formatIteratorP entry is stored. Pass NULL to ignore this value for each codec.
00277  * @param codecIDP:         IN: Pointer to the location where the codec ID associated with the current
00278  *                              formatIteratorP entry is stored. Pass NULL to ignore this value for each codec.
00279  *
00280  * @retval Err errNone or kCodecErrBadParam
00281  */
00282 Err CodecMgrEnumerateFormats(UInt16 refNum, UInt32 *formatIteratorP, PalmCodecFormat *inputFormatP, PalmCodecFormat *outputFormatP, UInt32 *creatorIDP, UInt32 *codecIDP)
00283         SYS_TRAP(kCodecMgrLibTrapEnumerateFormats);
00284
00285 /**
00286  * Checks whether an input and output format pair is supported by any codec or by
00287  * a particular codec.
00288  *
00289  * @param refNum:       IN: Reference number of the CodecPluginMgr library.
00290  * @param inputFormat:  IN: Input format for this session.
00291  * @param outputFormat: IN: Output format for this session.
00292  * @param creatorID:    IN: Creator ID of the codec checked. Pass palmCodecNullID to ignore this parameter
00293  *                          and check whether any available codec supports the given input and output
00294  *                          format pair.
00295  * @param codecID:      IN: Codec ID of the codec checked. Pass palmCodecNullID to ignore this parameter
00296  *                          and check whether any available codec supports the given input and output
00297  *                          format pair.
00298  *
00299  * @retval Boolean true if the format is supported by a codec or the specified codec, false if the format
00300  *                 pair is not supported by a codec or the specified codec.
00301  */
00302 Boolean CodecMgrIsFormatSupported(UInt16 refNum, PalmCodecFormat inputFormat, PalmCodecFormat outputFormat, UInt32 creatorID, UInt32 codecID)
00303         SYS_TRAP(kCodecMgrLibTrapIsFormatSupported);
00304
00305 /**
00306  * Get information about a session.
00307  *
00308  * @param refNum:           IN: Reference number of the CodecPluginMgr library.
00309  * @param session:          IN: Session to reset.
00310  * @param inputFormatP:     OUT: Receives the input format entry specified with formatIteratorP.
00311  * @param outputFormatP:    OUT: Receives the output format entry specified with formatIteratorP.
00312  * @param creatorIDP:       OUT: Pointer to the location where the creator ID of the session is returned.
00313  * @param codecIDP:         OUT: Pointer to the location where the codec ID of the session is returned.
00314  *
00315  * @retval Err errNone if no error.
00316  */
00317 Err CodecMgrGetSessionInfo(UInt16 refNum, PalmCodecSession session, PalmCodecFormat *inputFormatP, PalmCodecFormat *outputFormatP, UInt32 *creatorIDP, UInt32 *codecIDP)
00318         SYS_TRAP(kCodecMgrLibTrapGetSessionInfo);
00319
00320
00321
00322 #ifdef __cplusplus
00323 }
00324 #endif
00325
00326 #endif  // _PALMCODECPLUGINMGR_H_
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:54 2008 for Palm API Guide


Header Files » Incs » common » libraries » codecpluginmgr

palmOneCodecPluginMgrCommon.h

Go to the documentation of this file.
00001 /*******************************************************************************
00002  * Copyright (c) 2004-2005 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  ******************************************************************************/
00005 /**
00006  * @defgroup    Codec Codec Plugin Manager
00007  * @brief       This library is used to provide support for audio/video/image
00008  *              codecs plugin and encoding/decoding routines.
00009  *
00010  * The Codec Plugin Manager library is used to unify all different type of
00011  * codecs that are available for palmOne devices and provide a generic
00012  * API for developers to access these codecs for encoding/decoding.
00013  *
00014  * A typical application would use the library the following way:
00015  * - Check if an input/output format pair is supported [optional]
00016  * - Create a CodecSession with parameters that match the formats
00017  * - Call EncodeDecode()
00018  * - ...
00019  * - Delete the session
00020  *
00021  * For more information, please also check the palmOne Developer Guide.
00022  *
00023  * @{
00024  * @}
00025  */
00026 /**
00027  * @ingroup Codec
00028  */
00029
00030 /**
00031  * @file    palmOneCodecPluginMgrCommon.h
00032  * @version 3.0
00033  *
00034  * @brief   Public 68K common header file for Codec Plugin Manager API - Library Definitions.
00035  *
00036  * This file contains the library constants and error codes used in the APIs.
00037  * <hr>
00038  */
00039
00040 #ifndef _PALMONECODECPLUGINMGRCOMMON_H_
00041 #define _PALMONECODECPLUGINMGRCOMMON_H_
00042
00043 #include <PalmTypes.h>
00044 #include <ErrorBase.h>
00045 #include <SystemMgr.h>
00046
00047
00048 /***********************************************************************
00049  * Type and creator of the Library
00050  ***********************************************************************/
00051
00052 #define kCodecMgrLibName        "CodecPluginMgr"    /**< CodecPluginMgr library name. */
00053 #define kCodecMgrLibType        'aext'              /**< CodecPluginMgr library type. */
00054 #define kCodecMgrLibCreator     'CdMg'              /**< CodecPluginMgr creator ID. */
00055
00056
00057 /***********************************************************************
00058  * Library versioning
00059  ***********************************************************************/
00060
00061 /**
00062  * @name Library Versions
00063  */
00064 /*@{*/
00065 #define kCodecMgrLibVersion3    sysMakeROMVersion(3, 0, 0, sysROMStageRelease, 0)
00066 #define kCodecMgrLibVersion     kCodecMgrLibVersion3
00067 /*@}*/
00068
00069 /***********************************************************************
00070  * Error codes
00071  ***********************************************************************/
00072
00073 /** Codec Plug-In Manager error codes. */
00074 #define kCodecMgrLibErrorClass      (oemErrorClass + 0x100)
00075
00076 /**
00077  * @name Library Error Codes
00078  */
00079 /*@{*/
00080 /** Returned from CodecMgrLibClose() if the library is still open. */
00081 #define kCodecMgrLibErrStillOpen    (kCodecMgrLibErrorClass | 0x01)
00082 /** Internal error. */
00083 #define kCodecMgrLibErrInternal     (kCodecMgrLibErrorClass | 0x02)
00084 /** Bad parameters. */
00085 #define kCodecMgrLibErrBadParam     (kCodecMgrLibErrorClass | 0x03)
00086 /** API or Codec not supported. */
00087 #define kCodecMgrLibNotSupported    (kCodecMgrLibErrorClass | 0x04)
00088 /** Bad Codec Manager version. */
00089 #define kCodecMgrLibBadVersion      (kCodecMgrLibErrorClass | 0x05)
00090 /** No codec available. */
00091 #define kCodecMgrLibNoCodec         (kCodecMgrLibErrorClass | 0x06)
00092 /*@}*/
00093
00094 /** Codec Plugins error codes. */
00095 #define kCodecPluginErrorClass      (oemErrorClass + 0x300)
00096
00097 /**
00098  * @name Codec Session Error Codes
00099  */
00100 /*@{*/
00101 /** Codec Plug-In Bad parameters. */
00102 #define kCodecErrBadParam           (kCodecPluginErrorClass | 0x01)
00103 /** Buffer Over-run. */
00104 #define kCodecErrBufferOverrun      (kCodecPluginErrorClass | 0x02)
00105 /** Buffer Under-run. */
00106 #define kCodecErrBufferUnderrun     (kCodecPluginErrorClass | 0x03)
00107 /** Frame Error. */
00108 #define kCodecErrFrameError         (kCodecPluginErrorClass | 0x04)
00109 /** Invalid Header. */
00110 #define kCodecErrInvalidHeader      (kCodecPluginErrorClass | 0x05)
00111 /** Sync not found. */
00112 #define kCodecSyncNotFound          (kCodecPluginErrorClass | 0x06)
00113 /** Invalide decoding/encoding state. */
00114 #define kCodecErrInvalidState       (kCodecPluginErrorClass | 0x07)
00115 /** Alignment error. */
00116 #define kCodecErrAlignment          (kCodecPluginErrorClass | 0x08)
00117 /** Parsing error. */
00118 #define kCodecErrParsing            (kCodecPluginErrorClass | 0x09)
00119 /** Out of memory. */
00120 #define kCodecErrNoMemory           (kCodecPluginErrorClass | 0x10)
00121 /** Not being authorized. */
00122 #define kCodecErrUnAuthorized       (kCodecPluginErrorClass | 0x11)
00123 /** Unknown error. */
00124 #define kCodecErrUnknown            (kCodecPluginErrorClass | 0xFF)
00125 /*@}*/
00126
00127 /******************************************************************
00128  * Constants and Types
00129  ******************************************************************/
00130
00131 /**
00132  * @name CodecSupportedFormatEnumerate Iterator
00133  */
00134 /*@{*/
00135 #define palmCodecIteratorStart      (0xfffffffeL)   /**< Start iterator. */
00136 #define palmCodecIteratorStop       (0xffffffffL)   /**< Stop iterator.  */
00137 /*@}*/
00138
00139 #define palmCodecNullID             (0)             /**< Null ID. */
00140 #define palmCodecInvalidSession     (NULL)          /**< Invalid session. */
00141
00142 /** Palm Codec Session. */
00143 typedef void    *PalmCodecSession;
00144
00145 /** Palm Codec Format. */
00146 typedef UInt32  PalmCodecFormat;
00147
00148 /***********************************************************************
00149  * Library trap
00150  ***********************************************************************/
00151
00152 /**
00153  * @name Function Traps
00154  */
00155 /*@{*/
00156 #define kCodecMgrLibTrapLibAPIVersion           (sysLibTrapCustom + 0)
00157 #define kCodecMgrLibTrapCreateSession           (sysLibTrapCustom + 1)
00158 #define kCodecMgrLibTrapCreateSessionByID       (sysLibTrapCustom + 2)
00159 #define kCodecMgrLibTrapDeleteSession           (sysLibTrapCustom + 3)
00160 #define kCodecMgrLibTrapResetSession            (sysLibTrapCustom + 4)
00161 #define kCodecMgrLibTrapGetMaxDestBufferSize    (sysLibTrapCustom + 5)
00162 #define kCodecMgrLibTrapEncodeDecode            (sysLibTrapCustom + 6)
00163 #define kCodecMgrLibTrapCustomControl           (sysLibTrapCustom + 7)
00164 #define kCodecMgrLibTrapEnumerateFormats        (sysLibTrapCustom + 8)
00165 #define kCodecMgrLibTrapIsFormatSupported       (sysLibTrapCustom + 9)
00166 #define kCodecMgrLibTrapGetSessionInfo          (sysLibTrapCustom + 10)
00167 /*@}*/
00168
00169 #endif  // _PALMONECODECPLUGINMGRCOMMON_H_
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:54 2008 for Palm API Guide


Header Files » Incs » common » system

palmOneCreators.h

Go to the documentation of this file.
00001 /******************************************************************************
00002  * Copyright (c) 2005 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  *****************************************************************************/
00005 /**
00006  *@ingroup System
00007  *
00008  */
00009
00010 /**
00011  * @file    palmOneCreators.h
00012  * @version 1.0
00013  * @date    02/29/2002
00014  *
00015  * @brief Contains Palm-specific creator codes.
00016  *
00017  *
00018  * <hr>
00019  */
00020
00021
00022 #ifndef __PALMONECREATORS_H__
00023 #define __PALMONECREATORS_H__
00024
00025 #include <SystemResources.h>    // for classic creator code definitions
00026
00027 /**
00028  * @name
00029  *
00030  */
00031 /*@{*/
00032 #define sysFileCTelMgrLibOem        'toem'  /**< Creator ID for the Telephony Manager Extension shared library. */
00033 #define sysFileCSimATDriverOem      'sims'  /**< Creator ID for the SIM AT Driver. */
00034 #define sysFileCSimOfficer      'sats'  /**< Creator ID for the SIM Application Toolkit client application. */
00035 #define sysFileCSimWatcherLib       'simw'  /**< Creator ID for the SIM Watcher library. */
00036 #define sysFileCProvisioning        'prov'  /**< Creator ID for the provisioning application. */
00037 #define sysFileCMobileServices      'msvc'  /**< Creator ID for the Mobile Service Library. */
00038 #define sysFileCMyFavorite      'myfv'  /**< Creator ID for the MyFavorite App. */
00039 #define sysFileCNotePad         'npad'  /**< Creator ID for the Notepad app. */
00040 #define sysFileCMobileApp       'mobi'  /**< Creator ID for the Mobile application */
00041 #define kPalmCreatorIDNetSlipHack   'PNHk'  /**< Creator ID for the bluetooth slip app panel hack */
00042 /*@}*/
00043
00044 /**
00045  * @name
00046  *
00047  */
00048 /*@{*/
00049 #define kPalmOneCreatorIDContacts   'PAdd'  /**<        */
00050 #define kPalmOneCreatorIDCalendar   'PDat'  /**<        */
00051 #define kPalmOneCreatorIDMemos      'PMem'  /**<        */
00052 #define kPalmOneCreatorIDNotePad    'npad'  /**<        */
00053 #define kPalmOneCreatorIDTasks      'PTod'  /**<        */
00054 #define kPalmOneCreatorIDVoiceMemo  'Vpad'  /**<        */
00055 #define kPalmOneCreatorIDFavorites  'Fave'  /**<        */
00056 #define kPalmOneCreatorIDFileBrowser    'PFil'  /**<        */
00057 #define kPalmCreatorIDLcdState  'PmLo'  /**< Creator ID for the lcd broadcast of lcd on/off */
00058
00059 /*@}*/
00060
00061 /**
00062  * Media types
00063  *
00064  * Media types for different media used on palmOne devices.
00065  *
00066  */
00067 #define expMediaType_HD             'HDSK'  /**< Media type for the Hard Disk */
00068
00069
00070 #endif  // __PALMONECREATORS_H__
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:54 2008 for Palm API Guide


Header Files » Incs » common » system

palmOneFeatures.h

Go to the documentation of this file.
00001 /******************************************************************************
00002  * Copyright (c) 2005 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  *****************************************************************************/
00005 /**
00006  *@ingroup System
00007  *
00008  */
00009
00010 /**
00011  * @file    palmOneFeatures.h
00012  * @version 1.0
00013  * @date    02/29/2002
00014  *
00015  * @brief Contains Palm-specific feature definitions.
00016  *
00017  * <hr>
00018  */
00019
00020 #ifndef __PALMONEFEATURES_H__
00021 #define __PALMONEFEATURES_H__
00022
00023 /**
00024  * The following feature should be defined on all devices that support hi-res
00025  * screens & include NotePad 2.0 or higher.  As the OS does not yet provide a
00026  * method for the desktop SW/conduits to query the handheld in order to
00027  * determine the density capabilities of the device, this feature has been
00028  * added.  By testing the presence/content of this feature, the device can
00029  * properly convert any old lo-density RLE data to be hi-density PNG data on
00030  * the first hotsync to the device rather than have to do a note-by-note
00031  * conversion at run time on the handheld the first time each old note has been
00032  * opened.
00033  */
00034 #define densityFtrCreator       'dnsT'      /**<        */
00035 #define densityFtrVersion       0       /**<        */
00036 /**
00037  * one of the DensityType values defined in the Bitmap.h file should be stored
00038  * in this feature designating the density supported by the device.
00039  */
00040
00041 /**
00042  * @name
00043  *
00044  */
00045 /*@{*/
00046 #define screenFtrCreator        'scnP'      /**< Creator for screen feature */
00047 #define dpiFtrValue             1   /**< Screen DPI feature */
00048 /*@}*/
00049
00050 /**
00051  * @name Headset feature
00052  *
00053  */
00054 /*@{*/
00055 #define headsetFtrCreator       'hseT'      /**<        */
00056 #define headsetFtrVersion       0       /**<        */
00057 /*@}*/
00058
00059 /**
00060  * @name
00061  *
00062  */
00063 /*@{*/
00064 #define sysExternalHeadsetInsertEvent       'hsiN'  /**< Broadcast when headset is inserted */
00065 #define sysExternalHeadsetRemoveEvent       'hsrM'  /**< Broadcast when headset is removed */
00066 /*@}*/
00067
00068 /**
00069  * Hard Disk Spinup notification
00070  *
00071  * Notification sent by the hard disk slot driver that the disk has spun up
00072  *
00073  */
00074 #define sysNotifyHardDiskSpinup   'HSPU'
00075
00076 /**
00077  * External dialog open/close from backgound task notification
00078  *
00079  * These notifications should be sent by a background task if it wants to
00080  * open a new/close a dialog. This notification should be used in conjunction
00081  * with checking the SysUIBusy flag. The logic to be used is as follows:
00082  *     if (!SysUIBusy)
00083  *         display dialog
00084  *     else
00085  *         call SysNotifyBroadcast with sysNotifyExternalDialogOpenedEvent
00086  *         if (!SysUIBusy)
00087  *             display dialog
00088  *
00089  * The foreground application should also be prepared to handle this event
00090  * especially if it is using the LCD overlay. It should be prepared to receive
00091  * more than one such notification by keeping a count of open dialog event.
00092  * This count should be decremented for every
00093  * sysNotifyExternalDialogClosedEvent. Only when this count becomes zero should
00094  * the application restart using the display (LCD overlay).
00095  *
00096  */
00097 #define sysNotifyExternalDialogOpenedEvent   'edgO'  /**< Broadcast before opening a dialog */
00098 #define sysNotifyExternalDialogClosedEvent   'edgC'  /**< Broadcast after closing the dialog */
00099
00100
00101
00102 /**
00103  * @name USB features
00104  *
00105  * These features provide information on the USB capabilities of the device.
00106  *
00107  */
00108 /*@{*/
00109 #define pmUsbFtrCreator     'pUSB'      /**< Creator for USB feature */
00110 #define pmUsbFtrVersion         0       /**< USB feature number */
00111
00112
00113 #define USBFeatureCreator           'fUSB'
00114 #define USBFeatureVersion           0
00115
00116 #define kUSBMTP                     0x0001
00117 #define kUSBTransfer                0x0002
00118 #define kUSBHotSync                 0x0004
00119 #define kUSBDriveMode               0x0008
00120 #define kUSBConsole                 0x0010
00121 #define kUSBDUN                     0x0020
00122 #define kUSBLogging                 0x0040
00123
00124 #define USBSpeedCreator             'sUSB'
00125 #define USBSpeedVersion             0
00126
00127 #define kUSBFSClient                0x0001
00128 #define kUSBHSClient                0x0002
00129 #define kUSBFSOnTheGo               0x0004
00130 #define kUSBHSOnTheGo               0x0008
00131 #define kUSBFSOnTheGoMultiDevice    0x0010
00132 #define kUSBHSOnTheGoMultiDevice    0x0020
00133
00134 #define USBChargeCreator            'cUSB'
00135 #define USBChargeVersion            0
00136
00137 #define kUSB500mACharge             0x0001
00138
00139 #define USBHwrCreator               'hUSB'
00140 #define USBHwrVersion               0
00141
00142 #define kUSBMiniConnector           0x0001
00143 #define kUSBMultiConnector          0x0002
00144
00145 #define irFtrVersionNumber          1
00146 #define irFtrLowBatteryLevel        1
00147
00148 /*@}*/
00149
00150
00151
00152
00153 #endif // __PALMONEFEATURES_H__
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:54 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » hirestimerlib

palmOneHiResTimer.h

Go to the documentation of this file.
00001 /******************************************************************************
00002  * Copyright (c) 2004 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  *****************************************************************************/
00005 /**
00006  * @ingroup HiRes
00007  */
00008
00009 /**
00010  *
00011  * @file    palmOneHiResTimer.h
00012  * @version 1.0
00013  *
00014  * @brief   Public 68k include file for Hi-Resolution timer for Palm OS.
00015  **/
00016
00017 #ifndef _PALMONEHIRESTIMER_H_
00018 #define _PALMONEHIRESTIMER_H_
00019
00020 #include <PalmTypes.h>
00021 #include <ErrorBase.h>
00022 #include <SystemMgr.h>
00023 #include <LibTraps.h>
00024 #include <palmOneHiResTimerCommon.h>
00025
00026
00027 /***********************************************************************
00028  * API Prototypes
00029  ***********************************************************************/
00030
00031 #ifdef __cplusplus
00032 extern "C" {
00033 #endif
00034
00035
00036 /**
00037  * Opens the Hi-Res Timer library.
00038  *
00039  * @param refNum:   IN: Library reference number.
00040  * @retval Err Error code.
00041  */
00042 extern Err HRTimeLibOpen(UInt16 refNum)
00043     SYS_TRAP(sysLibTrapOpen);
00044
00045 /**
00046  * Closes the Hi-Res Timer library.
00047  *
00048  * @param refNum:   IN: Library reference number.
00049  * @retval Err Error code.
00050  */
00051 extern Err HRTimeLibClose(UInt16 refNum)
00052     SYS_TRAP(sysLibTrapClose);
00053
00054 /**
00055  * Get the frequency of the Hi-Resolution Timer.
00056  *
00057  * @param refNum:   IN:  Library reference number.
00058  * @param ticksP:   OUT: Frequency of the timer.
00059  * @retval Err Error code.
00060  */
00061 extern Err HRTimeLibTicksPerSecond(UInt16 refNum, UInt32 *ticksP)
00062     SYS_TRAP(kHRLibTrapTimerTicksPerSecond);
00063
00064 /**
00065  * Get the current ticks for Hi-Resolution Timer.
00066  *
00067  * @param refNum:       IN:  Library reference number.
00068  * @param ticksP:       OUT: Current ticks.
00069  * @param rolloverP:    OUT: Number of rollover since the timer started.
00070  * @retval Err Error code.
00071  */
00072 extern Err HRTimeLibGetTime(UInt16 refNum, UInt32 *ticksP, UInt32 *rolloverP)
00073     SYS_TRAP(kHRLibTrapTimerGetTime);
00074
00075
00076
00077
00078 #ifdef __cplusplus
00079 }
00080 #endif
00081
00082 #endif  // _PALMONEHIRESTIMER_H_
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:54 2008 for Palm API Guide


Header Files » Incs » common » libraries » hirestimerlib

palmOneHiResTimerCommon.h

Go to the documentation of this file.
00001 /*******************************************************************************
00002  * Copyright (c) 2004-2005 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  ******************************************************************************/
00005 /**
00006  * @defgroup    HiRes Hi-Resolution Timer Library
00007  * @brief       This library provides support for high resolution timer on Palm OS
00008  *              devices.
00009  *
00010  * Applications which would like to use a more granular (higher resolution) timer
00011  * than the standard Palm OS sysTicksPerSecond() can use this library to do so.
00012  *
00013  * @{
00014  * @}
00015  */
00016 /**
00017  * @ingroup HiRes
00018  */
00019
00020 /**
00021  * @file    palmOneHiResTimerCommon.h
00022  * @version 1.0
00023  * @brief   Public 68k common header file for Hi-Resolution Timer API.
00024  *
00025  * This file contains the common library constants and error codes.
00026  * <hr>
00027  */
00028
00029 #ifndef _PALMONEHIRESTIMERCOMMON_H_
00030 #define _PALMONEHIRESTIMERCOMMON_H_
00031
00032 #include <PalmTypes.h>
00033 #include <ErrorBase.h>
00034 #include <SystemMgr.h>
00035
00036
00037 /***********************************************************************
00038  * Type and creator of the Library
00039  ***********************************************************************/
00040
00041 #define     kHiResTimeLibType       'libr'              /**< Hi-Res timer library database type */
00042 #define     kHiResTimeLibCreator    'pHRT'              /**< Hi-Res timer library database creator */
00043
00044 /***********************************************************************
00045  * Internal library name which can be passed to SysLibFind()
00046  ***********************************************************************/
00047
00048 #define     kHiResTimeLibName       "HRTimer-Lib"   /**< Hi-Res timer library name */
00049
00050 /***********************************************************************
00051  * Library versioning
00052  ***********************************************************************/
00053
00054 /**
00055  * @name Library Versions
00056  */
00057 /*@{*/
00058 #define     kHiResTimeLibVersion1   sysMakeROMVersion(1, 0, 0, sysROMStageRelease, 0) /**< Hi-Res timer library version 1 */
00059 #define     kHiResTimeLibVersion2   sysMakeROMVersion(2, 0, 0, sysROMStageRelease, 0) /**< Hi-Res timer library version 2 */
00060 #define     kHiResTimeLibVersion    kCamLibVersion2 /**< Hi-Res timer library version 2 */
00061 /*@}*/
00062
00063 /***********************************************************************
00064  * HiRes Timer result codes
00065  ***********************************************************************/
00066
00067 /**
00068  * @name Error Codes
00069  */
00070 /*@{*/
00071 /** Hi-Res timer base error number */
00072 #define kHiResTimeErrorClass            (oemErrorClass + 0x100)
00073 /** Bad Parameter */
00074 #define kHiResTimeLibErrBadParam        (kHiResTimeErrorClass | 0x01)
00075 /** Library is not open */
00076 #define kHiResTimeLibErrNotOpen         (kHiResTimeErrorClass | 0x02)
00077 /** Returned from HRTimeLibClose() if the library is still open */
00078 #define kHiResTimeLibErrStillOpen       (kHiResTimeErrorClass | 0x03)
00079 /** Fucntion not availabe - If returned by HRTimeLibOpen, there is no HiRes Timer available. */
00080 #define kHiResTimeLibErrNotAvailable    (kHiResTimeErrorClass | 0x04)
00081 /*@}*/
00082
00083 /***********************************************************************
00084  * Library trap
00085  ***********************************************************************/
00086
00087 /**
00088  * @name Function Traps
00089  */
00090 /*@{*/
00091 #define kHRLibTrapTimerTicksPerSecond   (sysLibTrapCustom)
00092 #define kHRLibTrapTimerGetTime          (sysLibTrapCustom+1)
00093 /*@}*/
00094
00095 #endif  // _PALMONEHIRESTIMERCOMMON_H_
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:54 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » lcdoverlaylib

palmOneLcdOverlay.h

Go to the documentation of this file.
00001 /******************************************************************************
00002  * Copyright (c) 2004 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  *****************************************************************************/
00005 /**
00006  * @ingroup LcdOverlay
00007  */
00008
00009 /**
00010  *
00011  * @file    palmOneLcdOverlay.h
00012  * @version 1.0
00013  *
00014  * @brief   Public 68k include file for LCDOverlay API that can be used to display
00015  *          YCbCr images directly on the screen.
00016  */
00017
00018 #ifndef _PALMONELCDOVERLAY_H_
00019 #define _PALMONELCDOVERLAY_H_
00020
00021 #include <PalmTypes.h>
00022 #include <LibTraps.h>
00023 #include <Common\Libraries\LcdOverlayLib\palmOneLcdOverlayCommon.h> // For LCD Overlay common data
00024
00025
00026 /***********************************************************************
00027  * API Prototypes
00028  ***********************************************************************/
00029
00030 #ifdef __cplusplus
00031 extern "C" {
00032 #endif
00033
00034 /**
00035  * Opens LcdOverlay library.
00036  *
00037  * This function should be called prior to calling the other LcdOverlay functions.
00038  *
00039  * @param   refNum: IN: Reference number of the LcdOverlay library.
00040  * @retval  Err The error code returned from the library. If this is errNone, the
00041  *          function was sucessful.
00042  *
00043  */
00044 extern Err LcdOverlayLibOpen(UInt16 refNum)
00045     SYS_TRAP(sysLibTrapOpen);
00046
00047 /**
00048  * Closes LcdOverlay library.
00049  *
00050  *
00051  * @param   refNum: IN: Reference number of the LcdOverlay library.
00052  * @return  Err The error code returned from the library. If this is errNone, the
00053  *          function was sucessful.
00054  *
00055  */
00056 extern Err LcdOverlayLibClose(UInt16 refNum)
00057     SYS_TRAP(sysLibTrapClose);
00058
00059
00060 /**
00061  * Returns version of the LcdOverlay Library.
00062  *
00063  * @param   refNum:         IN:  Reference number of the LcdOverlay library.
00064  * @param   sdkVersion:     IN:  Expected version number.
00065  * @param   libVersionP:    OUT: Pointer to version number returned.
00066  *
00067  * @retval  Err The error code returned from the library. If this is errNone, the
00068  *          function was sucessful.
00069  *
00070  */
00071 extern Err LcdOverlayLibGetVersion(UInt16 refNum, UInt32 sdkVersion, UInt32* libVersionP)
00072     SYS_TRAP(kLcdOverlayLibTrapGetVersion);
00073
00074
00075 /**
00076  * Control the setting of the LcdOverlay Library.
00077  *
00078  *
00079  * @param   refNum:     IN:  Reference number of the LcdOverlay library.
00080  * @param   cmdId:      IN:  The commandId. One of the above stated control commands.
00081  * @param   parameterP: OUT: Parameter associated with a command.
00082  *
00083  * @retval  Err The error code returned from the library. If this is errNone, the
00084  *          function was sucessful.
00085  *
00086  */
00087 extern Err LcdOverlayLibControl(UInt16 refNum, LcdOverlayLibControlType cmdId, void* parameterP)
00088     SYS_TRAP(kLcdOverlayLibTrapControl);
00089
00090
00091 #ifdef __cplusplus
00092 }
00093 #endif
00094
00095
00096 #endif  // _PALMONELCDOVERLAY_H_
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:54 2008 for Palm API Guide


Header Files » Incs » common » libraries » lcdoverlaylib

palmOneLcdOverlayCommon.h

Go to the documentation of this file.
00001 /*******************************************************************************
00002  * Copyright (c) 2004-2005 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  ******************************************************************************/
00005 /**
00006  * @defgroup    LcdOverlay LCD Overlay Library
00007  * @brief       This library provide support for displaying YCbCr images directly
00008  *              on the screen.
00009  *
00010  * Note that the image that is drawn on the screen will always sit on top of the
00011  * form above everything else.
00012  *
00013  * @{
00014  * @}
00015  */
00016 /**
00017  * @ingroup LcdOverlay
00018  */
00019
00020 /**
00021  *
00022  * @file    palmOneLcdOverlayCommon.h
00023  * @version 1.0
00024  * @brief   Public 68k common header file for LCDOverlay API.
00025  *
00026  * This file contains the common constants and error codes for the LCDOverlay library.
00027  */
00028
00029 #ifndef _PALMONELCDOVERLAYCOMMON_H_
00030 #define _PALMONELCDOVERLAYCOMMON_H_
00031
00032 #include <PalmTypes.h>
00033 #include <ErrorBase.h>
00034 #include <SystemMgr.h>
00035
00036 /***********************************************************************
00037  * Library trap
00038  ***********************************************************************/
00039 /**
00040  * @name Function Traps
00041  */
00042 /*@{*/
00043 #define kLcdOverlayLibTrapGetVersion        (sysLibTrapCustom + 0)
00044 #define kLcdOverlayLibTrapControl           (sysLibTrapCustom + 1)
00045 /*@}*/
00046
00047 /***********************************************************************
00048  * Type and creator of the Library
00049  ***********************************************************************/
00050
00051 #define     kLcdOverlayLibName      "LcdOverlayManager" /**< LcdOverlay library name. */
00052 #define     kLcdOverlayLibType      'libr'              /**< LcdOverlay Type. */
00053 #define     kLcdOverlayLibCreator   'Povl'              /**< LcdOverlay Creator ID. */
00054
00055 /***********************************************************************
00056  * Library versioning
00057  ***********************************************************************/
00058
00059 #define     kLcdOverlayLibVersion1  sysMakeROMVersion(1, 0, 0, sysROMStageRelease, 0) /**< LcdOverlay lib version */
00060 #define     kLcdOverlayLibVersion   kLcdOverlayLibVersion1 /**< LcdOverlay lib version */
00061
00062 /***********************************************************************
00063  * LCD Overlay result codes
00064  ***********************************************************************/
00065 /**
00066  * @name Error Codes
00067  */
00068 /*@{*/
00069 /** Lcd Overlay error base number */
00070 #define kLcdOverlayLibErrorClass            (oemErrorClass + 0x200)
00071 /** invalid parameter */
00072 #define kLcdOverlayLibErrBadParam           (kLcdOverlayLibErrorClass | 0x01)
00073 /** Memory error */
00074 #define kLcdOverlayLibErrNoMemory           (kLcdOverlayLibErrorClass | 0x02)
00075 /** library is not open */
00076 #define kLcdOverlayLibErrNotOpen            (kLcdOverlayLibErrorClass | 0x03)
00077 /** returned from LcdOverlayLibClose() if the library is still open */
00078 #define kLcdOverlayLibErrStillOpen          (kLcdOverlayLibErrorClass | 0x04)
00079 /** Internal error */
00080 #define kLcdOverlayLibErrInternal           (kLcdOverlayLibErrorClass | 0x05)
00081 /** Unsupported function */
00082 #define kLcdOverlayLibErrNotSupported       (kLcdOverlayLibErrorClass | 0x06)
00083 /** Bad Version */
00084 #define kLcdOverlayLibErrNotCompatible      (kLcdOverlayLibErrorClass | 0x07)
00085 /*@}*/
00086
00087 /***********************************************************************
00088  * Constants - control commands
00089  ***********************************************************************/
00090 /**
00091  * @name Control Commands
00092  */
00093 /*@{*/
00094 /** Parameter is LcdOverlayLibFormatType*. Set the format type of the overlay. */
00095 #define kLcdOverlayLibCtrlFormatSet         0x01
00096 /** Parameter is LcdOverlayLibFormatType*. Get  the format type of the overlay.*/
00097 #define kLcdOverlayLibCtrlFormatGet         0x02
00098 /** Parameter is LcdOverlayLibFormatType*. Query the type of format types supported. */
00099 #define kLcdOverlayLibCtrlFormatQuery       0x03
00100 /** Parameter is RectangleType* (low res coords). Set the overlay draw rectangle size*/
00101 #define kLcdOverlayLibCtrlRectSet           0x04
00102 /** Parameter is RectangleType* (low res coords). Get the overlay draw rectangle size*/
00103 #define kLcdOverlayLibCtrlRectGet           0x05
00104 /** Turn Overlay on before you do a draw. Takes no parameters */
00105 #define kLcdOverlayLibCtrlStart             0x06
00106 /** Draw picture using Overlay lib. void* pointer to image data */
00107 #define kLcdOverlayLibCtrlDraw              0x07
00108 /** Turn Overlay off usually after drawing is done. Takes no parameters */
00109 #define kLcdOverlayLibCtrlStop              0x08
00110 /*@}*/
00111 typedef UInt16 LcdOverlayLibControlType; /**< Used with the kLcdOverlayLibCtrl defines */
00112
00113 /***********************************************************************
00114  * Constants - Capabilities Settings
00115  ***********************************************************************/
00116
00117 /**
00118  * @brief Structure used in LcdOverlayLibControl() for setting parameters
00119           Currently only type is used to specify the format type (seelist
00120           below) when used with kLcdOverlayLibCtrlFormatSet/Get/Query.
00121  */
00122
00123 typedef struct LcdOverlayLibSettingTag
00124 {
00125     UInt32 type;         /**< Overlay (Image ) format type */
00126     Int32 value;         /**< Not used currently */
00127     Int32 minValue;      /**< Not used currently */
00128     Int32 maxValue;      /**< Not used currently */
00129 } LcdOverlayLibSettingType;
00130
00131 /**
00132  * @brief Struct used in LcdOverlayLibControl() calls.
00133  * @see LcdOverlayLibSettingTag
00134  */
00135 typedef struct LcdOverlayLibSettingTag      LcdOverlayLibFormatType;
00136
00137 /**
00138  * @name Data Formats
00139  * @brief Format types for overlay.
00140  *
00141  * Not all of the formats may be supported, please do a query to find
00142  * the supported formats.
00143  */
00144 /*@{*/
00145 #define kLcdOverlayLibDataFormatYCbCr444        0x02
00146 #define kLcdOverlayLibDataFormatYCbCr422        0x04
00147 #define kLcdOverlayLibDataFormatYCbCr420        0x08
00148 #define kLcdOverlayLibDataFormatYCbCr444Planar  0x10
00149 #define kLcdOverlayLibDataFormatYCbCr422Planar  0x20
00150 #define kLcdOverlayLibDataFormatYCbCr420Planar  0x40
00151 #define kLcdOverlayLibDataFormatRGB565          0x80 /**< This is actually RGB555 with 1 bit for transperancy, may change in future */
00152 /*@}*/
00153
00154 #endif  // _PALMONELCDOVERLAYCOMMON_H_
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:54 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » imaging

palmOnePhoto.h

Go to the documentation of this file.
00001 /******************************************************************************
00002  * Copyright (c) 2004 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  *****************************************************************************/
00005 /**
00006  * @ingroup Imaging
00007  */
00008
00009 /**
00010  * @file    palmOnePhoto.h
00011  * @version 3.0
00012  *
00013  * @brief Palm Photos API: This API is used to access Palm Photos database and manipulate images.
00014  *
00015  * The database API provides users with the ability to:
00016  *  - Get the list of albums.
00017  *  - Create, delete and rename albums.
00018  *  - Get the list of photos in each album.
00019  *  - Add photos to albums.
00020  *
00021  * The image manipulation API provides users with the ability to:
00022  *  - Create and capture images and video clips.
00023  *  - Read and write image data.
00024  *  - Convert images to different formats.
00025  *  - Display images.
00026  *  - Scale, rotate and crop images.
00027  *
00028  * Update to be compliant with DCF
00029  *  - The notion of Unfiled folder has been removed
00030  *  - In PalmPhotoDeleteAlbum() setting the parameter moveToUnfiled
00031  *    moves the photos in the deleted album to DCIM/Palm instead of
00032  *    the Unfiled folder which was DCIM.
00033  */
00034
00035 #ifndef PALMONE_PHOTO_H_
00036 #define PALMONE_PHOTO_H_
00037
00038 /* Include the common define */
00039 #include <Common/Libraries/Imaging/palmOnePhotoCommon.h>
00040
00041 /* Palm OS common definitions */
00042 #include <SystemMgr.h>
00043
00044
00045
00046 /******************************************************************
00047  * Callback functions
00048  ******************************************************************/
00049
00050 /**
00051  * File streaming callback.
00052  * During read operations, *sizeP contains the size of the buffer
00053  * passed to the callback. Setting sizeP before returning in this
00054  * case is simply ingored. If the user doesn't read all the data
00055  * in the buffer, the data left will be lost.
00056  * During write operations, *sizeP contains the max size of the
00057  * buffer used for writing. sizeP is set to the amount of data to
00058  * write before the callback returns. Setting sizeP to 0 means
00059  * no more data to write and the write process should stop.
00060  * The read/write calllback can be stopped at any time by the
00061  * callback returning the error code palmPhotoLibErrAbortReadWrite.
00062  *
00063  * @param bufferP:      IN: Pointer to the buffer containing image data.
00064  * @param sizeP:        IN: Size of the buffer.
00065  * @param userDataP:    IN: Pointer to user data set in PalmPhotoReadWriteParam.
00066  * @retval Err Error code.
00067  */
00068 typedef Err (*PalmPhotoReadWriteCallback) (
00069     void    *bufferP,
00070     UInt32  *sizeP,
00071     void    *userDataP
00072 );
00073
00074 /**
00075  * Selection filter callback.
00076  * This function is called during a selection if provided as a
00077  * parameter. Given an image handle, the filter decides whether
00078  * or not and image should be selected. For example, a user might
00079  * want to select only JPEG images.
00080  *
00081  * @param imageH:       IN: Handle of the image to filter.
00082  * @param userDataP:    IN: Pointer to user data set in PalmPhotoSelectionParam.
00083  * @retval Boolean True if ok to select image, false otherwise.
00084  */
00085 typedef Boolean (*PalmPhotoFilterCallback) (
00086     PalmPhotoHandle imageH,
00087     void            *userDataP
00088 );
00089
00090 /**
00091  * Display callback.
00092  * This function is called during display image if provided as a
00093  * parameter. If the function returns false, the display process
00094  * will be canceled.
00095  *
00096  * @param userDataP:    IN: Pointer to user data set in PalmPhotoDisplayParam.
00097  * @retval Boolean True if the display process should continue, false otherwise.
00098  */
00099 typedef Boolean (*PalmPhotoDisplayCallback) (
00100     void            *userDataP
00101 );
00102
00103 /**
00104  * Capture callback.
00105  * This function is called during capture image if provided as a
00106  * parameter. If the function returns false, the capture process
00107  * will be canceled.
00108  * New in v2.0.
00109  *
00110  * @param userDataP:    IN: Pointer to user data set in PalmPhotoCaptureParamV2.
00111  * @retval Boolean True if the capture process should continue, false otherwise.
00112  */
00113 typedef Boolean (*PalmPhotoCaptureCallbackV2) (
00114     void            *userDataP
00115 );
00116
00117
00118 /******************************************************************
00119  * Callback function parameters
00120  ******************************************************************/
00121
00122 /**
00123  * @brief Photo selection dialog parameters.
00124  *
00125  * This structure is used for the selection dialog and direct image selection.
00126  * When using the PMPSelectImages API, selectionCount contains the maximum
00127  * number of images that can be selected.  If selectionCount is set to
00128  * PALM_PHOTO_SELECT_ALL, the range would be [offset, end]. If albumID is set
00129  * to PALM_PHOTO_ALBUM_ALL, all images can be selected.
00130  *
00131  * NOTE: The API allocates memory inside of selectedImages. It is the caller's
00132  * responsibility to free that memory via PalmPhotoFreeSelections().
00133  */
00134 typedef struct _PalmPhotoSelectionParam
00135 {
00136     UInt16                  albumID;        /**< IN: Album ID for selection.                    */
00137     UInt16                  reserved;       /**< reserved for future use                        */
00138     UInt32                  offset;         /**< IN: Range start.                               */
00139     Int32                   selectionCount; /**< IN: Number of images to select.                */
00140     PalmPhotoFilterCallback filterCallback; /**< IN: Callback to filter the selections.         */
00141     void                    *userDataP;     /**< IN: User data to be passed during callback.    */
00142     PalmPhotoSelections     selectedImages; /**< OUT: Struct containing handle array.           */
00143 } PalmPhotoSelectionParam;
00144
00145
00146 /**
00147  * @brief Photo image manipulation param.
00148  *
00149  * This parameter is used to set the callback for reading and writing
00150  * data of an image. The imageFormat provides the user a way to convert
00151  * images. For example, reading a JPEG image and setting imageFormat to
00152  * RGB565 should convert the JPEG to RGB565.
00153  */
00154 typedef struct _PalmPhotoReadWriteParam
00155 {
00156     PalmPhotoFileFormat         imageFormat;    /**< IN: Memory file image format.  */
00157     UInt16                      reserved;       /**< reserved for future use        */
00158     PalmPhotoReadWriteCallback  rwCallback;     /**< IN: Read/Write callback.       */
00159     void                        *userDataP;     /**< IN: User data.                 */
00160 } PalmPhotoReadWriteParam;
00161
00162
00163 /**
00164  * @brief Photo image display parameters.
00165  *
00166  * The bounds might be ignored by the application.
00167  * New in v2.0: If playing a video, winH and rect are ignored.
00168  */
00169 typedef struct _PalmPhotoDisplayParam
00170 {
00171     WinHandle                   winH;               /**< IN: WinHandle.             */
00172     RectangleType               rect;               /**< IN: Display rectangle.     */
00173     PalmPhotoDisplayCallback    displayCallback;    /**< IN: display callback.      */
00174     void                        *userDataP;         /**< IN: User data.             */
00175 } PalmPhotoDisplayParam;
00176
00177 /**
00178  * @brief Photo image create parameters.
00179  *
00180  * Set imageInfo can determines the type of the file.  To create a
00181  * JPEG image, set imageInfo.fileFormat to palmPhotoJPEGFileFormat.
00182  */
00183
00184 typedef struct _PalmPhotoCreateParam
00185 {
00186     PalmPhotoFileLocation   fileLocation;   /**< IN: file location of new file.     */
00187     PalmPhotoImageInfo      imageInfo;      /**< IN: file information.              */
00188 } PalmPhotoCreateParam;
00189
00190 /**
00191  * @brief Photo/video image capture parameters.
00192  *
00193  * The callback function allows the calling application to cancel the image
00194  * capture operation.  The user may cancel the operation by interacting with
00195  * the capture application.
00196  * New in v2.0.
00197  */
00198
00199 typedef struct _PalmPhotoCaptureParamV2
00200 {
00201     PalmPhotoFileLocation       fileLocation;       /**< IN: file location of new file. */
00202                                                     /**     (Note: only VFSFile         */
00203                                                     /**     supported for video)        */
00204     PalmPhotoImageInfo          imageInfo;          /**< IN: file information.          */
00205     PalmPhotoCaptureCallbackV2  captureCallback;    /**< IN: capture callback.          */
00206     void                        *userDataP;         /**< IN: User data.                 */
00207
00208 } PalmPhotoCaptureParamV2;
00209
00210
00211 /*********************************************************************
00212  * API Prototypes
00213  *********************************************************************/
00214
00215 #ifdef __cplusplus
00216 extern "C" {
00217 #endif
00218
00219 /******************************************************************
00220  * Standard library open, close, sleep and wake functions
00221  ******************************************************************/
00222
00223 /// Standard library open function
00224 /// @param refNum: IN: library reference number
00225 /// @retval Err Error code.
00226 extern Err PalmPhotoLibOpen(UInt16 refNum)
00227     PMP_LIB_TRAP(sysLibTrapOpen);
00228
00229 /// Standard library close function
00230 /// @param refNum: IN: library reference number
00231 /// @retval Err Error code.
00232 extern Err PalmPhotoLibClose(UInt16 refNum)
00233     PMP_LIB_TRAP(sysLibTrapClose);
00234
00235 /// Standard library sleep function
00236 /// @param refNum: IN: library reference number
00237 /// @retval Err Error code.
00238 extern Err PalmPhotoLibSleep(UInt16 refNum)
00239     PMP_LIB_TRAP(sysLibTrapSleep);
00240
00241 /// Standard library wake function
00242 /// @param refNum: IN: library reference number
00243 /// @retval Err Error code.
00244 extern Err PalmPhotoLibWake(UInt16 refNum)
00245     PMP_LIB_TRAP(sysLibTrapWake);
00246
00247
00248 /******************************************************************
00249  * Custom library API functions
00250  ******************************************************************/
00251
00252 /******************************************************************
00253  * Photo API v1.0 functions
00254  ******************************************************************/
00255
00256 /**
00257  * Get the number of albums in Palm Photos.
00258  * For compatibility only; new development should use the V2 version.
00259  *
00260  * @param refNum:   IN: Library reference number.
00261  * @retval          UInt16 Album count.
00262  */
00263 extern UInt16  PalmPhotoAlbumCount(UInt16 refNum)
00264     PMP_LIB_TRAP(sysLibTrapBase + 5);
00265
00266 /**
00267  * Get an album ID given the album index.
00268  * For compatibility only; new development should use the V2 version.
00269  *
00270  * @param refNum:   IN: Library reference number.
00271  * @param index:    IN: Album index.
00272  * @retval          UInt16 Album ID. If album doesn't exist, return PALM_PHOTO_ALBUM_ALL.
00273  */
00274 extern UInt16 PalmPhotoGetAlbumID(UInt16 refNum, UInt16 index)
00275     PMP_LIB_TRAP(sysLibTrapBase + 6);
00276
00277 /**
00278  * Get an album name given the album ID.
00279  * The buffer that will hold the album name is allocated by the user.
00280  *
00281  * @param refNum:   IN:  Library reference number.
00282  * @param albumID:  IN:  Album ID
00283  * @param nameP:    OUT: Buffer that will contain the name of the album.
00284  * @param bufSize:  IN:  Size of the buffer pointed by nameP.
00285  * @retval          Err Error code.
00286  */
00287 extern Err PalmPhotoGetAlbumName(UInt16 refNum, UInt16 albumID, Char *nameP, UInt16 bufSize)
00288     PMP_LIB_TRAP(sysLibTrapBase + 7);
00289
00290 /**
00291  * Create a new album.
00292  * For compatibility only; new development should use the V2 version.
00293  *
00294  * @param refNum:   IN:  Library reference number.
00295  * @param nameP:    IN:  String that contains the name of the new album.
00296  * @param errP:     OUT: Error code.
00297  * @retval          UInt16 If successful, returns the ID of the newly created album.
00298  *                  Otherwise, returns PALM_PHOTO_ALBUM_ALL.
00299  */
00300 extern UInt16 PalmPhotoNewAlbum(UInt16 refNum, const Char *nameP, Err *errP)
00301     PMP_LIB_TRAP(sysLibTrapBase + 8);
00302
00303 /**
00304  * Delete an album by album ID.
00305  *
00306  * @param refNum:           IN: Library reference number.
00307  * @param albumID:          IN: ID of the Album to delete.
00308  * @param moveToUnfiled:    IN: If true, photos from the deleted album are moved to /DCIM/Palm
00309  *                              folder. Otherwise, they are deleted. In previous versions
00310  *                              the Unfiled album was mapped to the /DCIM folder.
00311  * @retval                  Err Error code.
00312  */
00313 extern Err PalmPhotoDeleteAlbum(UInt16 refNum, UInt16 albumID, Boolean moveToUnfiled)
00314     PMP_LIB_TRAP(sysLibTrapBase + 9);
00315
00316 /**
00317  * Rename an album.
00318  * If Photos has "Camera" album, it also can't be renamed.
00319  *
00320  * @param refNum:   IN: Library reference number.
00321  * @param albumID:  IN: ID of the Album to delete.
00322  * @param nameP:    IN: New album name.
00323  * @retval          Err Error code.
00324  */
00325 extern Err PalmPhotoRenameAlbum(UInt16 refNum, UInt16 albumID, const Char *nameP)
00326     PMP_LIB_TRAP(sysLibTrapBase + 10);
00327
00328 /**
00329  * Get image count for an album.
00330  *
00331  * @param refNum:   IN: Library reference number.
00332  * @param albumID:  IN: ID of the Album to retrieve information from.
00333  * @retval          Err Error code.
00334  */
00335 extern UInt16 PalmPhotoImageCount(UInt16 refNum, UInt16 albumID)
00336     PMP_LIB_TRAP(sysLibTrapBase + 11);
00337
00338 /**
00339  * Select images within a specific range.
00340  * The selected images are passed in the selection parameter.
00341  * To free the memory allocated, use the PalmPhotoFreeSelections() function.
00342  *
00343  * @param refNum:           IN: Library reference number.
00344  * @param photoSelectionP:  IN,OUT: Palm Photo selection parameter. Contains array of selections on return.
00345  * @retval                  Err Error code.
00346  */
00347 extern Err PalmPhotoSelectImages(UInt16 refNum, PalmPhotoSelectionParam *photoSelectionP)
00348     PMP_LIB_TRAP(sysLibTrapBase + 12);
00349
00350 /**
00351  * Select images using the Media Selection/Deletion dialog.
00352  * The selected images are passed in the selection parameter.
00353  * To free the memory allocated, use the PalmPhotoFreeSelections() function.
00354  *
00355  * @param refNum:           IN: Library reference number.
00356  * @param photoSelectionP:  IN,OUT: Palm Photo selection parameter. Contains array of selections on return.
00357  * @param dlgType:          IN: Selection dialog type (eg palmPhotoDlgSelection...)
00358  * @param handleCard:       IN: If true, the dialog with intercept card notifications.
00359  * @retval                  Err Error code.
00360  */
00361 extern Err PalmPhotoSelectDlg(UInt16 refNum, PalmPhotoSelectionParam *photoSelectionP, PalmPhotoDlgType dlgType, Boolean handleCard)
00362     PMP_LIB_TRAP(sysLibTrapBase + 13);
00363
00364 /**
00365  * Free memory allocated during the photos selection.
00366  * For compatibility only; new development should use the V2 version.
00367  *
00368  * @param refNum:           IN: Library reference number.
00369  * @param photoSelectionP:  IN,OUT: Palm Photo selection parameter.
00370  */
00371 extern void PalmPhotoFreeSelections(UInt16 refNum, PalmPhotoSelectionParam *photoSelectionP)
00372     PMP_LIB_TRAP(sysLibTrapBase + 14);
00373
00374 /**
00375  * Create a new image.
00376  * For compatibility only; new development should use the V2 version.
00377  *
00378  * @param refNum:       IN:  Library reference number.
00379  * @param createParamP: IN:  Palm Photo create parameter.
00380  * @param errP:         OUT: Error code.
00381  * @retval              PalmPhotoHandle The newly created photo handle or NULL if unsuccessful.
00382  */
00383 extern PalmPhotoHandle PalmPhotoCreateImage(UInt16 refNum, const PalmPhotoCreateParam *createParamP, Err *errP)
00384     PMP_LIB_TRAP(sysLibTrapBase + 15);
00385
00386 /**
00387  * Open an existing image.
00388  * For compatibility only; new development should use the V2 version.
00389  *
00390  * @param refNum:       IN:  Library reference number.
00391  * @param photoFileP:   IN:  Palm Photo file location.
00392  * @param errP:         OUT: Error code.
00393  * @retval              PalmPhotoHandle The opened photo handle or NULL if unsuccessful.
00394  */
00395 extern PalmPhotoHandle PalmPhotoOpenImage(UInt16 refNum, const PalmPhotoFileLocation *photoFileP, Err *errP)
00396     PMP_LIB_TRAP(sysLibTrapBase + 16);
00397
00398 /**
00399  * Close an image.
00400  * For compatibility only; new development should use the V2 version.
00401  *
00402  * @param refNum:   IN: Library reference number.
00403  * @param imageH:   IN: Image handle.
00404  */
00405 extern void PalmPhotoCloseImage(UInt16 refNum, PalmPhotoHandle imageH)
00406     PMP_LIB_TRAP(sysLibTrapBase + 17);
00407
00408 /**
00409  * Get an image information.
00410  *
00411  * @param refNum:   IN:  Library reference number.
00412  * @param imageH:   IN:  Image handle.
00413  * @param infoP:    OUT: Image info structure.
00414  * @retval          Err Error code.
00415  */
00416 extern Err PalmPhotoGetImageInfo(UInt16 refNum, PalmPhotoHandle imageH, PalmPhotoImageInfo *infoP)
00417     PMP_LIB_TRAP(sysLibTrapBase + 18);
00418
00419 /**
00420  * Get an image extra information size.
00421  *
00422  * @param refNum:   IN: Library reference number.
00423  * @param imageH:   IN: Image handle.
00424  * @param infoType: IN: Extra info type to retrieve the size from.
00425  * @retval          UInt32 The size of the extra information of the specified type.
00426  */
00427 extern UInt32 PalmPhotoGetImageExtraInfoSize (UInt16 refNum, PalmPhotoHandle imageH, PalmPhotoExtraInfoType infoType)
00428     PMP_LIB_TRAP(sysLibTrapBase + 19);
00429
00430 /**
00431  * Get an image extra information.
00432  *
00433  * Note: new info types (palmPhotoExtraInfoSound and palmPhotoExtraInfoUID) added in 3.0.
00434  *
00435  * @param refNum:       IN:  Library reference number.
00436  * @param imageH:       IN:  Image handle.
00437  * @param extraInfoP:   OUT: Structure that will hold the extra info requested.
00438  * @retval              Err Error code.
00439  */
00440 extern Err PalmPhotoGetImageExtraInfo(UInt16 refNum, PalmPhotoHandle imageH, PalmPhotoExtraInfoParam *extraInfoP)
00441     PMP_LIB_TRAP(sysLibTrapBase + 20);
00442
00443 /**
00444  * Set an image extra information.
00445  * When user set palmPhotoExtraInfoLocation, if the file name contains illegal
00446  * characters, the function will remove them. If the file name has an incorrect
00447  * file extension, the function will add the correct one.
00448  * For example, if the format is Jpeg, "*22.j" will be converted to "22.jpg".
00449  *
00450  * @param refNum:       IN: Library reference number.
00451  * @param imageH:       IN: Image handle.
00452  * @param extraInfoP:   IN: Structure that the extra info the extra info to set.
00453  * @retval              Err Error code.
00454  */
00455 extern Err PalmPhotoSetImageExtraInfo(UInt16 refNum, PalmPhotoHandle imageH, const PalmPhotoExtraInfoParam *extraInfoP)
00456     PMP_LIB_TRAP(sysLibTrapBase + 21);
00457
00458 /**
00459  * Add an image to a Palm Photos album.
00460  * A new image is created and added to the Photos database, in the specified album.
00461  * The image will be re-encoded in JPEG format at the specified quality.
00462  * If album doesn't exist, the image will be added to the album named "Palm". In the previous
00463  * versions if the album did not exist, the image was added to the "Unfiled" album.
00464  * Passing albumID of PALM_PHOTO_ALBUM_ALL results in the image being added
00465  * to the "Palm" album. In the previous versions passing albumID of
00466  * PALM_PHOTO_ALBUM_ALL resulted in the image being added to the "Unfiled" album.
00467  * For compatibility only; new development should use the V2 version.
00468  *
00469  * @param refNum:       IN:  Library reference number.
00470  * @param albumID:      IN:  Album ID for the image.
00471  * @param imageH:       IN:  Image handle.
00472  * @param addedImageH:  OUT: The new image added to the album.
00473  * @param imageQuality: IN:  Image quality.
00474  * @retval              Err Error code.
00475  */
00476 extern Err PalmPhotoAddImage(UInt16 refNum, UInt16 albumID, PalmPhotoHandle imageH, PalmPhotoHandle* addedImageH, PalmPhotoQualityType imageQuality)
00477     PMP_LIB_TRAP(sysLibTrapBase + 22);
00478
00479 /**
00480  * Delete an image.
00481  *
00482  * @param refNum:       IN: Library reference number.
00483  * @param imageH:       IN: Image handle.
00484  * @retval              Err Error code.
00485  */
00486 extern Err PalmPhotoDeleteImage(UInt16 refNum, PalmPhotoHandle imageH)
00487     PMP_LIB_TRAP(sysLibTrapBase + 23);
00488
00489 /**
00490  * Read image data given an image handle.
00491  * The image format specifies what type of buffer the user expects to copy
00492  * read data into. For example, to convert a JPEG image to RBG565 data, open
00493  * a JPEG image, and set readParamP->imageFormat to palmPhotoRGB565FileFormat.
00494  * The callback function should copy the image data from *bufferP into a buffer
00495  * referenced within readParamP->userDataP.
00496  *
00497  * @param refNum:       IN: Library reference number.
00498  * @param imageH:       IN: Image handle.
00499  * @param readParamP:   IN,OUT: Read parameters.
00500  * @retval              Err Error code.
00501  */
00502 extern Err PalmPhotoReadImage(UInt16 refNum, PalmPhotoHandle imageH, const PalmPhotoReadWriteParam *readParamP)
00503     PMP_LIB_TRAP(sysLibTrapBase + 24);
00504
00505 /**
00506  * Write image data given an image handle.
00507  * The writeParamP->imageFormat parameter specifies the source format the calling
00508  * application is providing to the API to write into storage.  The only valid source
00509  * formats are RGB565 and RGB888.  For example, to convert an RGB565 image to a JPEG,
00510  * you would create a JPEG image and pass its handle in imageH; then you would set
00511  * writeParamP->imageFormat to palmPhotoRGB565FileFormat.  The actual RGB image data
00512  * would be referenced by a pointer inside writeParamP->userDataP.  The callback
00513  * function will pass the RGB data to the API by copying it into *bufferP.
00514  *
00515  * @param refNum:       IN: Library reference number.
00516  * @param imageH:       IN,OUT: Image handle.
00517  * @param writeParamP:  IN: Write parameters.
00518  * @retval              Err Error code.
00519  */
00520 extern Err PalmPhotoWriteImage(UInt16 refNum, PalmPhotoHandle imageH, const PalmPhotoReadWriteParam *writeParamP)
00521     PMP_LIB_TRAP(sysLibTrapBase + 25);
00522
00523 /**
00524  * Display an image or play a video.
00525  * A still image referenced by imageH will be drawn in the window and
00526  * rectangle specified within *displayParamP.  If the window handle is NULL, the
00527  * current draw window is used.  A video referenced by imageH will be played in
00528  * the video player, and the window and rectangle will be ignored.
00529  *
00530  * The image is displayed "shrink to fit" mode, where 100% of the image
00531  * is represented on the handheld display. (See also PalmPhotoDisplayImageToSizeV3
00532  * for "best fit" scaling.)
00533  *
00534  * If the callback function returns false, the Photo API will halt
00535  * the draw or play operation.
00536  *
00537  * @param refNum:           IN: Library reference number.
00538  * @param imageH:           IN: Image handle.
00539  * @param displayParamP:    IN: Display parameter.
00540  * @retval                  Err Error code.
00541  */
00542 extern Err PalmPhotoDisplayImage(UInt16 refNum, PalmPhotoHandle imageH, const PalmPhotoDisplayParam *displayParamP)
00543     PMP_LIB_TRAP(sysLibTrapBase + 26);
00544
00545 /**
00546  * Get an image thumbnail size.
00547  *
00548  * @param refNum:   IN:  Library reference number.
00549  * @param imageH:   IN:  Image handle.
00550  * @param widthP:   OUT: Width of the thumbnail.
00551  * @param heightP:  OUT: Height of the thumbnail.
00552  * @retval          Err Error code.
00553  */
00554 extern Err PalmPhotoGetThumbSize(UInt16 refNum, PalmPhotoHandle imageH, UInt16 *widthP, UInt16 *heightP)
00555     PMP_LIB_TRAP(sysLibTrapBase + 27);
00556
00557 /**
00558  * Checks the version of the Palm Photo Library.
00559  *
00560  * @param refNum:       IN:  Library reference number.
00561  * @param sdkVersion:   IN:  The version the application expects.
00562  * @param libVersionP:  OUT: The actual version of the library.
00563  * @retval              Err Error code.
00564  */
00565 extern Err PalmPhotoLibGetVersion(UInt16 refNum, UInt32 sdkVersion, UInt32* libVersionP)
00566     PMP_LIB_TRAP(sysLibTrapBase + 29);
00567
00568
00569 /******************************************************************
00570  * Photo API v2.0 functions
00571  ******************************************************************/
00572
00573 /**
00574  * Return a scaled image.
00575  * New in v2.0.
00576  *
00577  * @param refNum:           IN:  Library reference number.
00578  * @param imageH:           IN:  Image handle.
00579  * @param scaledImageHP:    OUT: The new image scaled.
00580  * @param width:            IN:  New image width (must be <= existing width).
00581  * @param height:           IN:  New image height (must be <= existing height).
00582  * @retval                  Err Error code.
00583  */
00584 extern Err PalmPhotoScaleImageV2(UInt16 refNum, PalmPhotoHandle imageH, PalmPhotoHandle *scaledImageHP, UInt32 width, UInt32 height)
00585     PMP_LIB_TRAP(sysLibTrapBase + 30);
00586
00587 /**
00588  * Return a rotated image.
00589  * New in v2.0.
00590  *
00591  * @param refNum:           IN:  Library reference number.
00592  * @param imageH:           IN:  Image handle.
00593  * @param rotatedImageHP:   OUT: The new image rotated.
00594  * @param rotation:         IN:  Rotation angle (rotation is counter-clockwise).
00595  * @retval                  Err Error code.
00596  */
00597 extern Err PalmPhotoRotateImageV2(UInt16 refNum, PalmPhotoHandle imageH, PalmPhotoHandle *rotatedImageHP, Int16 rotation)
00598     PMP_LIB_TRAP(sysLibTrapBase + 31);
00599
00600 /**
00601  * Return a cropped image.
00602  * New in v2.0.
00603  *
00604  * @param refNum:           IN:  Library reference number.
00605  * @param imageH:           IN:  Image handle.
00606  * @param croppedImageHP:   OUT: The new image cropped.
00607  * @param cropRectP:        IN:  Cropping rectangle.
00608  * @retval                  Err  Error code.
00609  */
00610 extern Err PalmPhotoCropImageV2(UInt16 refNum, PalmPhotoHandle imageH, PalmPhotoHandle *croppedImageHP, RectangleType *cropRectP)
00611     PMP_LIB_TRAP(sysLibTrapBase + 32);
00612
00613 /**
00614  * Convert an image.
00615  * New in v2.0.
00616  *
00617  * @param refNum:           IN:  Library reference number.
00618  * @param imageH:           IN:  Image handle.
00619  * @param convertedImageHP: OUT: The new image converted.
00620  * @param createParamP:     IN:  File information and location for the new image.
00621  * @retval                  Err  Error code.
00622  */
00623 extern Err PalmPhotoConvertImageV2(UInt16 refNum, PalmPhotoHandle imageH, PalmPhotoHandle *convertedImageHP, const PalmPhotoCreateParam *createParamP)
00624     PMP_LIB_TRAP(sysLibTrapBase + 33);
00625
00626 /**
00627  * Get the error code from the last Photo API function that executed.
00628  * Sets the Photo API error code to errNone, if the library is open.
00629  * If the library is not open, it does not set the error code and
00630  * returns palmPhotoLibErrNotOpen.
00631  * New in v2.0.
00632  *
00633  * @param refNum:   IN: Library reference number.
00634  * @retval          Err Error code.
00635  */
00636 extern Err  PalmPhotoGetLastErrV2( UInt16 refNum )
00637     PMP_LIB_TRAP(sysLibTrapBase + 34);
00638
00639 /**
00640  * Get the number of albums in Palm Photos residing on the specified volume.
00641  * If volumeRef is 0, then the location is on the handheld.
00642  * Otherwise, it is in VFS.
00643  *
00644  * @param refNum:       IN: Library reference number.
00645  * @param volumeRef:    IN: Volume to search for photo albums.
00646  * @retval              UInt16 Album count.
00647  */
00648 extern UInt16  PalmPhotoAlbumCountV2(UInt16 refNum, UInt16 volumeRef)
00649     PMP_LIB_TRAP(sysLibTrapBase + 35);
00650
00651 /**
00652  * Get an album ID given the album index and volume.
00653  * If volumeRef is 0, then the location is on the handheld.
00654  * Otherwise, it is in VFS.
00655  *
00656  * @param refNum:       IN: Library reference number.
00657  * @param volumeRef:    IN: Volume to search for photo album.
00658  * @param index:        IN: Album index.
00659  * @retval              UInt16 Album ID. If album doesn't exist, return PALM_PHOTO_ALBUM_ALL.
00660  */
00661 extern UInt16 PalmPhotoGetAlbumIDV2(UInt16 refNum, UInt16 volumeRef, UInt16 index)
00662     PMP_LIB_TRAP(sysLibTrapBase + 36);
00663
00664 /**
00665  * Create a new album in the selected volume.
00666  * If volumeRef is 0, then the location is on the handheld.
00667  * Otherwise, it is in VFS.
00668  *
00669  * @param refNum:       IN: Library reference number.
00670  * @param volumeRef:    IN: Volume to search for photo album.
00671  * @param nameP:        IN: String that contains the name of the new album.
00672  * @retval              UInt16 If successful, returns the ID of the newly created album.
00673  *                             Otherwise, returns PALM_PHOTO_ALBUM_ALL.
00674  */
00675 extern UInt16 PalmPhotoNewAlbumV2(UInt16 refNum, UInt16 volumeRef, const Char *nameP)
00676     PMP_LIB_TRAP(sysLibTrapBase + 37);
00677
00678 /**
00679  * Free memory allocated during the photos selection.
00680  *
00681  * @param refNum:           IN: Library reference number.
00682  * @param photoSelectionP:  IN,OUT: Palm Photo selection parameter.
00683  * @retval                  Err Error code.
00684  */
00685 extern Err PalmPhotoFreeSelectionsV2(UInt16 refNum, PalmPhotoSelectionParam *photoSelectionP)
00686     PMP_LIB_TRAP(sysLibTrapBase + 38);
00687
00688 /**
00689  * Create a new image.
00690  *
00691  * @param refNum:       IN: Library reference number.
00692  * @param createParamP: IN: Palm Photo create parameter.
00693  * @retval              PalmPhotoHandle The newly created photo handle or NULL if unsuccessful.
00694  */
00695 extern PalmPhotoHandle PalmPhotoCreateImageV2(UInt16 refNum, const PalmPhotoCreateParam *createParamP)
00696     PMP_LIB_TRAP(sysLibTrapBase + 39);
00697
00698 /**
00699  * Capture a new still image or video clip using the built-in camera.
00700  *
00701  * New functionality added in 3.0:
00702  * Can capture video as well as still images.
00703  *     (For video, height and width in captureParam.imageInfo
00704  *     must match a supported resolution as returned by
00705  *     PalmPhotoGetSupportedCaptureResolutionsV3. Location
00706  *     in captureParam.fileLocation must be a VFSFile.)
00707  * Can limit size (in bytes) of captured media.
00708  *    (Set captureParam.imageInfo.fileSize to the desired
00709  *    limit. If fileSize = 0, no constraint s placed on
00710  *    ithe file size.)
00711  *
00712  * @param refNum:           IN: Library reference number.
00713  * @param captureParamP:    IN: Palm Photo capture parameter.
00714  * @retval                  PalmPhotoHandle The newly created photo handle or NULL if unsuccessful.
00715  */
00716 extern PalmPhotoHandle PalmPhotoCaptureImageV2(UInt16 refNum, const PalmPhotoCaptureParamV2 *captureParamP)
00717     PMP_LIB_TRAP(sysLibTrapBase + 40);
00718
00719 /**
00720  * Open an existing image.
00721  *
00722  * @param refNum:       IN: Library reference number.
00723  * @param photoFileP:   IN: Palm Photo file location.
00724  * @retval              PalmPhotoHandle The opened photo handle or NULL if unsuccessful.
00725  */
00726 extern PalmPhotoHandle PalmPhotoOpenImageV2(UInt16 refNum, const PalmPhotoFileLocation *photoFileP)
00727     PMP_LIB_TRAP(sysLibTrapBase + 41);
00728
00729 /**
00730  * Close an image.
00731  *
00732  * @param refNum:   IN: Library reference number.
00733  * @param imageH:   IN: Image handle.
00734  * @retval          Err Error code.
00735  */
00736 extern Err PalmPhotoCloseImageV2(UInt16 refNum, PalmPhotoHandle imageH)
00737     PMP_LIB_TRAP(sysLibTrapBase + 42);
00738
00739 /**
00740  * Add an image to a Palm Photos album.
00741  * The image is added to the indicated Photos album.  If the album
00742  * resides on a different volume than imageH, then the image is copied
00743  * into the new volume.  A handle to the image in the designated album is
00744  * returned in addedImageH.
00745  * No image conversion takes place.  The content of the image in the album is
00746  * identical to that of the original image.
00747  * If album doesn't exist, the image will be added to the "Unfiled" album.
00748  * Passing albumID of PALM_PHOTO_ALBUM_ALL results in the image being added
00749  * to the "Unfiled" album.
00750  *
00751  * @param refNum:       IN:  Library reference number.
00752  * @param albumID:      IN:  Album ID for the image.
00753  * @param imageH:       IN:  Image handle.
00754  * @param addedImageH:  OUT: The new image added to the album.
00755  * @retval              Err Error code.
00756  */
00757 extern Err PalmPhotoAddImageV2(UInt16 refNum, UInt16 albumID, PalmPhotoHandle imageH, PalmPhotoHandle* addedImageH)
00758     PMP_LIB_TRAP(sysLibTrapBase + 43);
00759
00760 /******************************************************************
00761  * Photo API v3 .0 functions
00762  ******************************************************************/
00763
00764 /**
00765  * Check for presence of an enabled camera.
00766  *
00767  * @param refNum:           IN: Library reference number.
00768  * @retval                  Boolean false if no camera or camera is disabled.
00769  *
00770  */
00771 extern Boolean PalmPhotoIsCameraAvailableV3(UInt16 refNum)
00772     PMP_LIB_TRAP(sysLibTrapBase + 44);
00773
00774 /**
00775  * Returns resolutions that are supported by the still or video camera.
00776  * Returns zero (palmPhotoCaptureResNone) if no camera, or camera disabled.
00777  *
00778  * @param refNum:           IN: Library reference number.
00779  * @param mediaType:        IN: palmPhotoMediaTypePhoto or palmPhotoMediaTypeVideo
00780  * @retval                  PalmPhotoCaptureResolution Flags (bit is set for each resolution that camera supports).
00781  *
00782  */
00783 extern PalmPhotoCaptureResolution PalmPhotoGetSupportedCaptureResolutionsV3(UInt16 refNum, PalmPhotoMediaType mediaType)
00784     PMP_LIB_TRAP(sysLibTrapBase + 45);
00785
00786 /**
00787  * Select images using the Photo Selection/Deletion dialog, with
00788  * optional camera support.
00789  * The selected images are passed in the selection parameter.
00790  * To free the memory allocated, use the PalmPhotoFreeSelections() function.
00791  *
00792  * @param refNum:           IN:Library reference number.
00793  * @param photoSelectionP:  IN,OUT: Palm Photo selection parameter. Contains array of selections on return.
00794  * @param captureParamP:    IN: Palm Photo capture parameter. Set to null to suppress the camera.
00795  *                              Camera only supported for single select dialog type.
00796  *                              Camera only supported when media type is photo OR video (not all)
00797  * @param dlgType:          IN: Selection dialog type (eg palmPhotoDlgSelection...)
00798  * @param mediaType:        IN: Dialog displays only photos, only videos, or all media types.
00799  * @param handleCard:       IN: If true, the dialog with intercept card notifications.
00800  * @retval                  Err Error code.
00801  */
00802 extern Err PalmPhotoSelectDlgV3(UInt16 refNum, PalmPhotoSelectionParam *photoSelectionP, const PalmPhotoCaptureParamV2 *captureParamP,
00803             PalmPhotoDlgType dlgType, PalmPhotoMediaType mediaType, Boolean handleCard)
00804     PMP_LIB_TRAP(sysLibTrapBase + 46);
00805
00806
00807 /**
00808  * Display an image or play a video.
00809  * A still image referenced by imageH will be drawn in the window and
00810  * rectangle specified within *displayParamP.  If the window handle is NULL, the
00811  * current draw window is used.  A video referenced by imageH will be played in
00812  * the video player, and the window and rectangle will be ignored.
00813  *
00814  * The image is displayed in "best fit" mode, scaled exactly so that the
00815  * rectangle is completely filled, then cropping anything outside the
00816  * rectangle. (See also PalmPhotoDisplayImage for shrink-to-fit scaling.)
00817  *
00818  * If the callback function returns false, the Photo API will halt
00819  * the draw or play operation.
00820  *
00821  * New in v3.0.
00822  *
00823  * @param refNum:           IN: Library reference number.
00824  * @param imageH:           IN: Image handle.
00825  * @param displayParamP:    IN: Display parameter.
00826  * @retval                  Err Error code.
00827  */
00828 extern Err PalmPhotoDisplayImageToSizeV3(UInt16 refNum, PalmPhotoHandle imageH, const PalmPhotoDisplayParam *displayParamP)
00829     PMP_LIB_TRAP(sysLibTrapBase + 47);
00830
00831 /**
00832  * Display thumbnail for still image or video.
00833  *
00834  * Thumbnail for the image or video referenced by imageH will be drawn
00835  * in the window and rectangle specified within *displayParamP. (In the
00836  * case of video, displays the first frame.) Use PalmPhotoGetThumbSize()
00837  * first to get the thumbnail size. If the window handle is NULL,
00838  * the current draw window is used.
00839  *
00840  * If the callback function returns false, the Photo API will halt
00841  * the draw or play operation.
00842  *
00843  * New in v3.0.
00844  *
00845  * @param refNum:           IN: Library reference number.
00846  * @param imageH:           IN: Image handle.
00847  * @param displayParamP:    IN: Display parameter.
00848  * @retval                  Err Error code.
00849  */
00850 extern Err PalmPhotoDisplayThumbnailV3(UInt16 refNum, PalmPhotoHandle imageH, const PalmPhotoDisplayParam *displayParamP)
00851     PMP_LIB_TRAP(sysLibTrapBase + 53);
00852
00853
00854
00855 #ifdef __cplusplus
00856 }
00857 #endif
00858
00859 #endif /* PALMONE_PHOTO_H_ */
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:54 2008 for Palm API Guide


Header Files » Incs » common » libraries » imaging

palmOnePhotoCommon.h

Go to the documentation of this file.
00001 /*******************************************************************************
00002  * Copyright (c) 2004-2005 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  ******************************************************************************/
00005 /**
00006  * @ingroup Imaging
00007  */
00008
00009 /**
00010  * @file    palmOnePhotoCommon.h
00011  * @version 3.0
00012  *
00013  * @brief   Palm Photos API: This file contains all the defines, enumerations, structures needed by PalmPhoto.h
00014  *
00015  */
00016
00017 #ifndef PALMONE_PHOTO_COMMON_H_
00018 #define PALMONE_PHOTO_COMMON_H_
00019
00020 /* Palm OS common definitions */
00021 #include <SystemMgr.h>
00022
00023 /* If we're actually compiling the library code, then we need to
00024  * eliminate the trap glue that would otherwise be generated from
00025  * this header file in order to prevent compiler errors in CW Pro 2.
00026  */
00027 #ifdef BUILDING_PMP
00028     #define PMP_LIB_TRAP(trapNum)
00029 #else
00030     #define PMP_LIB_TRAP(trapNum) SYS_TRAP(trapNum)
00031 #endif
00032
00033 /*********************************************************************
00034  * Type and creator of Sample Library database
00035  *********************************************************************/
00036
00037 #define     PalmPhotoLibCreatorID           'PMPL'          /**< Palm Photo Library creator id */
00038 #define     PalmPhotoLibTypeID              sysFileTLibrary /**< Standard library type */
00039
00040 /*********************************************************************
00041  * Internal library name which can be passed to SysLibFind()
00042  *********************************************************************/
00043
00044 #define     PalmPhotoLibName                "PalmPhotoLib" /**< Palm Photo Library database name */
00045
00046 /*********************************************************************
00047  * Library versioning
00048  *********************************************************************/
00049
00050 /**
00051  * @name Library Versions
00052  */
00053 /*@{*/
00054 #define kPalmPhotoLibVersion1       sysMakeROMVersion(1, 0, 0, sysROMStageRelease, 0)
00055 #define kPalmPhotoLibVersion2       sysMakeROMVersion(2, 0, 0, sysROMStageRelease, 0)
00056 #define kPalmPhotoLibVersion3       sysMakeROMVersion(3, 0, 0, sysROMStageRelease, 1)
00057 #define kPalmPhotoLibVersion        kPalmPhotoLibVersion3
00058 /*@}*/
00059
00060 /******************************************************************
00061  * Error codes
00062  ******************************************************************/
00063
00064 /**
00065  * @name Error Codes
00066  */
00067 /*@{*/
00068 /** Invalid parameter.                                          */
00069 #define palmPhotoLibErrParam                (oemErrorClass + 0x100)
00070 /** Library not open.                                           */
00071 #define palmPhotoLibErrNotOpen              (palmPhotoLibErrParam | 1)
00072 /** Library is still open.                                      */
00073 #define palmPhotoLibErrStillOpen            (palmPhotoLibErrParam | 2)
00074 /** Photos database does not exist on device.                   */
00075 #define palmPhotoLibErrNotPhotos            (palmPhotoLibErrParam | 3)
00076 /** Could not open Photos database.                             */
00077 #define palmPhotoLibErrNotOpenPhotos        (palmPhotoLibErrParam | 4)
00078 /** The album already exists.                                   */
00079 #define palmPhotoLibErrAlbumExist           (palmPhotoLibErrParam | 5)
00080 /** The selected album does not exist.                          */
00081 #define palmPhotoLibErrAlbumNotExist        (palmPhotoLibErrParam | 6)
00082 /** The album is full.                                          */
00083 #define palmPhotoLibErrAlbumFull            (palmPhotoLibErrParam | 7)
00084 /** The album name is too long.                                 */
00085 #define palmPhotoLibErrAlbumNameTooLong     (palmPhotoLibErrParam | 8)
00086 /** The album cannot be renamed or deleted.                     */
00087 #define palmPhotoLibErrAlbumReadOnly        (palmPhotoLibErrParam | 9)
00088 /** Insufficient free space in dynamic heap.                    */
00089 #define palmPhotoLibErrLowHeap              (palmPhotoLibErrParam | 10)
00090 /** Insufficient free space in storage heap.                    */
00091 #define palmPhotoLibErrLowMemory            (palmPhotoLibErrParam | 11)
00092 /** An image with that name already exists.                     */
00093 #define palmPhotoLibErrImageExist           (palmPhotoLibErrParam | 12)
00094 /** Specified image does not exist.                             */
00095 #define palmPhotoLibErrImageNotFound        (palmPhotoLibErrParam | 13)
00096 /** Image format not supported for the attempted operation.     */
00097 #define palmPhotoLibErrFormatNotSupported   (palmPhotoLibErrParam | 14)
00098 /** Image is not in the Photos database.                        */
00099 #define palmPhotoLibErrImageNotInPhotos     (palmPhotoLibErrParam | 15)
00100 /** Invalid path/image name.                                    */
00101 #define palmPhotoLibErrImageInvalidPath     (palmPhotoLibErrParam | 16)
00102 /** User canceled operation.                                    */
00103 #define palmPhotoLibErrUserCancel           (palmPhotoLibErrParam | 17)
00104 /** Unsupported handheld screen color depth.                    */
00105 #define palmPhotoLibErrScreenDepth          (palmPhotoLibErrParam | 18)
00106 /** Buffer is too small.                                        */
00107 #define palmPhotoLibErrSmallBuffer          (palmPhotoLibErrParam | 19)
00108 /** Unknown or unclassifiable error.                            */
00109 #define palmPhotoLibErrUnknown              (palmPhotoLibErrParam | 20)
00110 /** Image has no thumbnail.                                     */
00111 #define palmPhotoLibErrNoThumbnail          (palmPhotoLibErrParam | 21)
00112 /** Abort a read or write operation.            New in v2.0.    */
00113 #define palmPhotoLibErrAbortReadWrite       (palmPhotoLibErrParam | 22)
00114 /** Rotation angle not supported.               New in v2.0.    */
00115 #define palmPhotoLibErrUnsupportedRotation  (palmPhotoLibErrParam | 23)
00116 /** Invalid volume for operation.               New in v2.0.    */
00117 #define palmPhotoLibErrInvalidVolume        (palmPhotoLibErrParam | 24)
00118 /** Device has no camera.                       New in v2.0.    */
00119 #define palmPhotoLibErrNoCamera             (palmPhotoLibErrParam | 25)
00120 /** Library version is too old.                                 */
00121 #define palmPhotoLibErrOldVersion           (palmPhotoLibErrParam | 26)
00122 /** Invalid operation for media protected by DRM                */
00123 #define palmPhotoLibErrProtectedMedia       (palmPhotoLibErrParam | 27)
00124 /** The Power too lower                 */
00125 #define palmPhotoLibErrLowPower             (palmPhotoLibErrParam | 28)
00126 /*@}*/
00127
00128 /******************************************************************
00129  * Constants and Types
00130  ******************************************************************/
00131
00132 /** Media formats */
00133
00134 /** JPEG file format.                                           */
00135 #define palmPhotoJPEGFileFormat             (0x0001)
00136 /** Raw RGB 888 file format.                                    */
00137 #define palmPhotoRGB888FileFormat           (0x0002)
00138 /** Raw RGB 565 file format.                                    */
00139 #define palmPhotoRGB565FileFormat           (0x0003)
00140 /** GIF 8-bit indexed color format              New in v2.0.    */
00141 #define palmPhotoGIFFileFormat              (0x0004)
00142 /** BMP bitmap format                           New in v2.0.    */
00143 #define palmPhotoBMPFileFormat              (0x0005)
00144 /** TIFF bitmap format                          New in v2.0.    */
00145 #define palmPhotoTIFFFileFormat             (0x0006)
00146 /** PNG bitmap format                           New in v2.0.    */
00147 #define palmPhotoPNGFileFormat              (0x0007)
00148 /** WBMP bitmap format                          New in v2.0.    */
00149 #define palmPhotoWBMPFileFormat             (0x0008)
00150 /** M-JPEG video format                         New in v2.0.    */
00151 #define palmPhotoMJPEGFileFormat            (0x1001)
00152 /** MPEG1 video format                          New in v2.0.    */
00153 #define palmPhotoMPEG1FileFormat            (0x1002)
00154 /** MPEG4 video format                          New in v2.0.    */
00155 #define palmPhotoMPEG4FileFormat            (0x1003)
00156
00157 /** AVI file with ADPCM audio + MPEG4 video     New in v2.0.    */
00158 #define palmPhotoFormat_AVI_ADPCM_MPEG4     (0x1113)
00159 /** AVI file with MP3 audio + MPEG4 video       New in v2.0.    */
00160 #define palmPhotoFormat_AVI_MP3_MPEG4       (0x1123)
00161 /** ASF file with ADPCM audio + MPEG4 video     New in v2.0.    */
00162 #define palmPhotoFormat_ASF_ADPCM_MPEG4     (0x1213)
00163 /** ASF file with MP3 audio + MPEG4 video       New in v2.0.    */
00164 #define palmPhotoFormat_ASF_MP3_MPEG4       (0x1223)
00165 /** 3GP file with AMR audio + MPEG4 video       New in v3.0.    */
00166 #define palmPhotoFormat_3GP_AMR_MPEG4       (0x1333)
00167 /** 3GP file with AMR audio + H.263 video       New in v3.0.    */
00168 #define palmPhotoFormat_3GP_AMR_H263        (0x1334)
00169 /** 3G2 file with QCELP audio + MPEG4 video     New in v3.0.    */
00170 #define palmPhotoFormat_3G2_QCELP_MPEG4     (0x1443)
00171 /** 3G2 file with QCELP audio + H.263 video     New in v3.0.    */
00172 #define palmPhotoFormat_3G2_QCELP_H263      (0x1444)
00173
00174 /** Default still capture format.               New in v3.0.    */
00175 #define palmPhotoPreferredImageFormat       (0xFFFD)
00176 /** Default video capture format.               New in v3.0.    */
00177 #define palmPhotoPreferredVideoFormat       (0xFFFE)
00178
00179 /** Unsupported file format.                                    */
00180 #define palmPhotoUnsupportedFormat          (0xFFFF)
00181
00182 /** @name Old Constant Names */
00183 /** Old (2.0) constant names for compatibility                  */
00184 /*@{*/
00185 #define palmPhotoAVIM4AFileFormat           palmPhotoFormat_AVI_ADPCM_MPEG4
00186 #define palmPhotoAVIM43FileFormat           palmPhotoFormat_AVI_MP3_MPEG4
00187 #define palmPhotoASFM4AFileFormat           palmPhotoFormat_ASF_ADPCM_MPEG4
00188 #define palmPhotoASFM43FileFormat           palmPhotoFormat_ASF_MP3_MPEG4
00189 /*@}*/
00190
00191 /** Palm Photo file format.                                     */
00192 typedef UInt16 PalmPhotoFileFormat;
00193
00194
00195
00196 /** Capture resolution supported by device camera */
00197
00198 /** SUBQCIF (128x96)                            New in v3.0.    */
00199 #define palmPhotoCaptureResSUBQCIF      (0x00000001)
00200 /** QQVGA (160x120)                             New in v3.0.    */
00201 #define palmPhotoCaptureResQQVGA        (0x00000002)
00202 /** QCIF (176x144)                              New in v3.0.    */
00203 #define palmPhotoCaptureResQCIF         (0x00000004)
00204 /** QVGA (320x240)                              New in v3.0.    */
00205 #define palmPhotoCaptureResQVGA         (0x00000008)
00206 /** CIF (352x288)                               New in v3.0.    */
00207 #define palmPhotoCaptureResCIF          (0x00000010)
00208 /** VGA (640x480)                               New in v3.0.    */
00209 #define palmPhotoCaptureResVGA          (0x00000020)
00210 /** SVGA (800x600)                              New in v3.0.    */
00211 #define palmPhotoCaptureResSVGA         (0x00000040)
00212 /** XVGA (1024x768)                             New in v3.0.    */
00213 #define palmPhotoCaptureResXVGA         (0x00000080)
00214 /** SXGA (1280x960)                             New in v3.0.    */
00215 #define palmPhotoCaptureResSXGA         (0x00000100)
00216 /** SXGA (1280x960)                             New in v3.0.    */
00217 #define palmPhotoCaptureResSXGA960      (0x00000100)
00218 /** SXGA (1280x1024)                            New in v3.0.    */
00219 #define palmPhotoCaptureResSXGA1024     (0x00000200)
00220
00221 /** Unknown dimensions (caller must use CameraManager)          */
00222 #define palmPhotoCaptureResOther        (0x80000000)
00223
00224 /** None (no camera or camera disabled)                         */
00225 #define palmPhotoCaptureResNone         (0x00000000)
00226
00227 /** Used with palmPhotoCaptureRes defines */
00228 typedef UInt32 PalmPhotoCaptureResolution;
00229
00230 /** File stream on the device.                                  */
00231 #define palmPhotoStreamLocation             (0x0000)
00232 /** VFS file.                                                   */
00233 #define palmPhotoVFSLocation                (0x0001)
00234 /** Memory file. Read-Only images.                              */
00235 #define palmPhotoMemoryLocation             (0x0002)
00236
00237 /** Palm Photo file location type.                              */
00238 typedef UInt16  PalmPhotoLocationType;
00239
00240 /** Unique ID                                                   */
00241 typedef UInt8 PalmPhotoUID[21];
00242
00243 /** File location.infoP points to a PalmPhotoFileLocation.      */
00244 #define palmPhotoExtraInfoLocation          (0x0000)
00245 /** Date.infoP points to a DateType.                            */
00246 #define palmPhotoExtraInfoDate              (0x0001)
00247 /** Album.infoP points to a (Char *).                           */
00248 #define palmPhotoExtraInfoAlbum             (0x0002)
00249 /** Notes.infoP points to a (Char *).                           */
00250 #define palmPhotoExtraInfoNotes             (0x0003)
00251 /** Notes.infoP points to a PalmPhotoFileLocation. New in v3.0. */
00252 #define palmPhotoExtraInfoSound             (0x0004)
00253 /** Notes.infoP points to a PalmPhotoUID.          New in v3.0. */
00254 #define palmPhotoExtraInfoImageUID          (0x0005)
00255 /** Notes.infoP points to a PalmPhotoUID.          New in v3.0. */
00256 #define palmPhotoExtraInfoSoundUID          (0x0006)
00257 /** Notes.infoP points to a PalmPhotoUID.          New in v3.0. */
00258 #define palmPhotoExtraInfoCompositeUID      (0x0007)
00259
00260 /** Palm Photo extra information type.                          */
00261 typedef UInt16 PalmPhotoExtraInfoType;
00262
00263
00264 /** Mutiple selection dialog.                                   */
00265 #define palmPhotoDlgSelection               (0x0000)
00266 /** Single selection dialog.                                    */
00267 #define palmPhotoDlgSingleSelection         (0x0001)
00268 /** Deletion dialog.                                            */
00269 #define palmPhotoDlgDeletion                (0x0002)
00270
00271 /** Palm Photo dialog type.                                     */
00272 typedef UInt16 PalmPhotoDlgType;
00273
00274
00275 /** Select still image types                                    */
00276 #define palmPhotoMediaTypePhoto             (0x0001)
00277 /** Select video types                                          */
00278 #define palmPhotoMediaTypeVideo             (0x0002)
00279 /** All media types (in 3.0, limited to photos and video).      */
00280 #define palmPhotoMediaTypeAll               (0xFFFF)
00281
00282 /** Palm Photo media type (used in PalmPhotoSelectDlgV3).       */
00283 typedef UInt16 PalmPhotoMediaType;
00284
00285
00286 /** Highest quality compressed image.                           */
00287 #define palmPhotoHighestQuality             (0xFFFF)
00288 /** High quality compressed image.                              */
00289 #define palmPhotoHighQuality                (0xFFFE)
00290 /** Normal quality compressed image.                            */
00291 #define palmPhotoMediumQuality              (0xFFFD)
00292 /** Low quality compressed image.                               */
00293 #define palmPhotoLowQuality                 (0xFFFC)
00294 /** Lowest quality compressed image.                            */
00295 #define palmPhotoLowestQuality              (0xFFFB)
00296
00297 /** Palm Photo image quality type.                              */
00298 typedef UInt16 PalmPhotoQualityType;
00299
00300
00301 /** Maximum file path length.                                   */
00302 #define PALM_PHOTO_MAX_PATH                 (255)
00303 /** Used during selection to select maximum number of photos.   */
00304 #define PALM_PHOTO_SELECT_ALL               ((Int32)0xFFFFFFFF)
00305 /** Used to select all the albums at once.                      */
00306 #define PALM_PHOTO_ALBUM_ALL                ((UInt16)0xFFFF)
00307 /** Used to select all the albums on the handheld at once.      */
00308 #define PALM_PHOTO_ALBUM_ALL_HANDHELD       ((UInt16)0xFFFF)
00309 /** Used to select all the albums on the VFS card at once.      */
00310 #define PALM_PHOTO_ALBUM_ALL_VFS            ((UInt16)0xFFFE)
00311 /** Maximum album name length on device. (Increased for v3.0.)  */
00312 #define PALM_PHOTO_ALBUM_MAX_NAME           (255)
00313
00314
00315 /******************************************************************
00316  * Structures
00317  ******************************************************************/
00318
00319 /**
00320  * @brief Photo file location.
00321  *
00322  * This structure is used to open, create and query location
00323  * information of an image.
00324  */
00325 typedef struct _PalmPhotoFileLocation
00326 {
00327     PalmPhotoLocationType   fileLocationType;   /**< File location type.        */
00328     UInt16                  reserved;           /**< reserved for future use    */
00329     union
00330     {
00331         struct {
00332             Char    name[dmDBNameLength];       /**< File name on the device.   */
00333             UInt32  type;                       /**< Type of the stream.        */
00334             UInt32  creator;                    /**< Creator of the stream.     */
00335         } StreamFile;                           /**< File format: stream        */
00336
00337         struct {
00338             Char    name[PALM_PHOTO_MAX_PATH+1];/**< Full path name.                    */
00339             UInt16  volumeRef;                  /**< Volume where the file is located.  */
00340             UInt16  reserved;                   /**< reserved for future use    */
00341         } VFSFile;                              /**< File format: VFS           */
00342
00343         struct {
00344             void    *bufferP;                   /**< Buffer holding the image.  */
00345             UInt32  bufferSize;                 /**< Size of the buffer.        */
00346         } MemoryFile;                           /**< File format: Memory        */
00347
00348     } file;                                     /**< Image location.            */
00349
00350 } PalmPhotoFileLocation;
00351
00352 /**
00353  * @brief Photo information.
00354  *
00355  * This structure contains the basic image information.
00356  */
00357 typedef struct _PalmPhotoImageInfo
00358 {
00359     UInt32                  width;          /**< Width in pixels of the image.  */
00360     UInt32                  height;         /**< Height in pixels of the image. */
00361     UInt32                  bitsPerPixel;   /**< Color depth of the image.      */
00362     UInt32                  filesize;       /**< File size, in bytes.           */
00363     PalmPhotoFileFormat     fileFormat;     /**< File format, e.g., JPEG, GIF.  */
00364     PalmPhotoQualityType    imageQuality;   /**< Image quality.                 */
00365 } PalmPhotoImageInfo;
00366
00367
00368 /**
00369  * @brief Photo image extra info parameters.
00370  *
00371  * Gets extra information on an image.
00372  */
00373 typedef struct _PalmPhotoExtraInfo
00374 {
00375     PalmPhotoExtraInfoType  infoType;       /**< IN: Image info type.                       */
00376     UInt16                  reserved;       /**< reserved for future use                    */
00377     void                    *infoP;         /**< OUT: Points to the information selected.   */
00378     UInt32                  infoSize;       /**< OUT: Size of the buffer pointed by infoP.  */
00379 } PalmPhotoExtraInfoParam;
00380
00381 /** Palm Photo handle. @see _PalmPhotoType */
00382 typedef struct _PalmPhotoType * PalmPhotoHandle;
00383
00384 /**
00385  * @brief Photo selections.
00386  *
00387  * This strucutre is used during image selections, either by using
00388  * the PalmPhotoSelectDlg() function of the PalmPhotoSelect() function.
00389  */
00390 typedef struct _PalmPhotoSelections
00391 {
00392     UInt32                  imageCount;     /**< Number of images.          */
00393     PalmPhotoHandle         *imageH;        /**< Array of image handles.    */
00394 } PalmPhotoSelections;
00395
00396 #endif // PALMONE_PHOTO_COMMON_H_
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:54 2008 for Palm API Guide


Header Files » Incs » common » system

palmOneResources.h

Go to the documentation of this file.
00001 /******************************************************************************
00002  * Copyright (c) 2005 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  *****************************************************************************/
00005 /**
00006  *@ingroup System
00007  *
00008  */
00009
00010 /**
00011  * @file    palmOneResources.h
00012  * @version 1.0
00013  * @date    02/29/2002
00014  *
00015  * @brief Palm-specific system types and resources.
00016  *
00017  * <hr>
00018  */
00019
00020 #ifndef __PALMONERESOURCES_H__
00021 #define __PALMONERESOURCES_H__
00022
00023 // Feature: sysFtrNumOEMCompanyID
00024 /**
00025  * @name Company ID - registered creator
00026  *
00027  */
00028 /*@{*/
00029 #define kPalmCompanyIDPalm          'Palm'  /**< Company ID. */
00030 #define kPalmCompanyIDHandspring 'hspr' /**< Handspring company ID to be used with past products */
00031 #define kPalmCompanyIDOldPalm       'palm'  /**< Old company ID. For Tungsten|W. */
00032 /*@}*/
00033
00034
00035 // Feature: sysFtrNumOEMDeviceID
00036 /**
00037  * @name Device ID - registered creator
00038  *
00039  */
00040 /*@{*/
00041 #define kPalmOneDeviceIDZire        'Cubs'  /**< Device ID for Zire. */
00042 #define kPalmOneDeviceIDTungstenT   'Frg1'  /**< Device ID for Tungsten|T. */
00043 #define kPalmOneDeviceIDTungstenW   'atlc'  /**< Device ID for Tungsten|W. */
00044 #define kPalmOneDeviceIDTungstenC   'MT64'  /**< Device ID for Tungsten|C. */
00045 #define kPalmOneDeviceIDZire71      'Zpth'  /**< Device ID for Zire71. */
00046 #define kPalmOneDeviceIDTungstenT2  'Frg2'  /**< Device ID for Tungsten|T2. */
00047 #define kPalmOneDeviceIDTungstenT3  'Arz1'  /**< Device ID for Tungsten|T3. */
00048 #define kPalmOneDeviceIDTungstenTE  'Cct1'  /**< Device ID for Tungsten|E. */
00049 #define kPalmOneDeviceIDZire21      'Zi21'  /**< Device ID for Zire21. */
00050 #define kPalmOneDeviceIDTreo600     'H101'  /**< Device ID for Treo600. */
00051 #define kPalmOneDeviceIDTreo600Sim  'H201'  /**< Device ID for Treo600 Simulator. */
00052 #define kPalmOneDeviceIDZire31      'Zi22'  /**< Device ID for Zire31. */
00053 #define kPalmOneDeviceIDZire72      'Zi72'  /**< Device ID for Zire72. */
00054 #define kPalmOneDeviceIDAngus       'TnT5'  /**< Device ID for Tungsten|T5. */
00055 #define kPalmOneDeviceIDTungstenT5  kPalmOneDeviceIDAngus   /**< Device ID for Tungsten|T5. */
00056 #define kPalmOneDeviceIDTreo650     'H102'  /**< Device ID for Treo650. */
00057 #define kPalmOneDeviceIDTreo650Sim  'H202'  /**< Device ID for Treo650 Simulator. */
00058 #define kPalmOneDeviceIDTungstenE2  'Zir4'  /**< Device ID for Tungsten E2. */
00059 #define kPalmOneDeviceIDTungstenX   'TunX'  /**< Device ID for LifeDrive */
00060 #define kPalmDeviceIDTX         'D050'  /**< Device ID for Palm T|X */
00061 #define kPalmDeviceIDZ22        'D051'  /**< Device ID for Palm Z22 */
00062 #define kPalmOneDeviceIDDevice3     'H103'  /**< Device ID reserved for future use. */
00063 #define kPalmOneDeviceIDDevice4     'H104'  /**< Device ID reserved for future use. */
00064 #define kPalmOneDeviceIDDevice5     'H105'  /**< Device ID reserved for future use. */
00065 #define kPalmOneDeviceIDDevice6     'H106'  /**< Device ID reserved for future use. */
00066 #define kPalmOneDeviceIDDevice7     'H107'  /**< Device ID reserved for future use. */
00067 #define kPalmOneDeviceIDDevice8     'H108'  /**< Device ID reserved for future use. */
00068 #define kPalmOneDeviceIDDevice9     'H109'  /**< Device ID reserved for future use. */
00069 #define kPalmOneDeviceIDDeviceA     'H10A'  /**< Device ID reserved for future use. */
00070 #define kPalmOneDeviceIDVentura     'D052'  /**< Device ID for Ventura. */
00071 #define kPalmOneDeviceIDLowrider    'D053'  /**< Device ID for Lowrider. */
00072 #define kPalmOneDeviceIDTorino      'D060'  /**< Device ID for Torino. */
00073 #define kPalmOneDeviceIDGnome       'D061'  /**< Device ID for Gnome. */
00074 #define kPalmOneDeviceIDGandalf     'D062'  /**< Device ID for Gandalf. */
00075 /*@}*/
00076
00077 #endif // __PALMONERESOURCES_H__
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:54 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » sndfilestream

palmOneSndFileStream.h

Go to the documentation of this file.
00001 /******************************************************************************
00002  * Copyright (c) 2004 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  *****************************************************************************/
00005 /**
00006  * @ingroup Sound
00007  *
00008  */
00009
00010 /**
00011  * @file    palmOneSndFileStream.h
00012  *
00013  * @brief   Public 68K include file for sound files stream support for Treo 600
00014  *          and Treo 650 smartphones.
00015  *
00016  * This header file and associated header files support the specific sound
00017  * functionality of the Treo smartphones. You should use the Palm OS Sound
00018  * Manager APIs for most of your work.
00019  *
00020  * Notes:
00021  * The calling application should always load this library with
00022  * SysLibLoad() before use, even if it is already open by another
00023  * application(ie, SysLibFind() returns a valid refnum). When
00024  * the application is done with the library, it should be
00025  * unloaded with SysLibRemove(). We do this because there is
00026  * no good way to synchronize loading and unloading of libraries
00027  * among multiple applications. It also greatly simplifies internal
00028  * synchronization.
00029  */
00030
00031
00032 #ifndef __SNDFILESTREAM_H__
00033 #define __SNDFILESTREAM_H__
00034
00035 /***********************************************************************
00036  * Palm OS common definitions
00037  ***********************************************************************/
00038
00039 #include <PalmTypes.h>
00040 #include <SystemMgr.h>
00041 #include <SystemResources.h>
00042
00043 #if defined( BUILDING_SNDFILESTREAM ) || defined( BUILDING_SNDFILESTREAM_INTO_APP )
00044 #define SNDFILESTREAM_TRAP( x ) /**<Helper macro */
00045 #else
00046 #define SNDFILESTREAM_TRAP( x ) SYS_TRAP( x ) /**<Helper macro. */
00047 #endif
00048
00049 #include <FileStream.h>
00050 #include <SoundMgr.h>
00051 #include <VFSMgr.h>
00052
00053 /**
00054  * @name Type and creator of the Sound File Stream library
00055  *
00056  * Used with FtrGet.
00057  */
00058 /*@{*/
00059 #define kSndFileStreamLibType       sysFileTLibrary                                     /**<Type of the sound file stream library. */
00060 #define kSndFileStreamLibCreator    'sfsL'                                              /**<Creator ID of the sound file stream library. */
00061 #define kSndFileStreamLibName       "SndFileStream-sfsL"                                /**<Name of the sound file stream library. */
00062 #define kSndFileStreamLibVersion    sysMakeROMVersion(1, 4, 0, sysROMStageRelease, 20)  /**<Version of the sound file stream library. */
00063 /*@}*/
00064
00065 /**
00066  * @name Utility macros
00067  *
00068  * These macros take care of opening and closing the sound file stream library
00069  * in various situations.
00070  */
00071 /*@{*/
00072 #if defined( BUILDING_SNDFILESTREAM_INTO_APP )
00073 #define SndFileStreamOpenLibrary( refNum, err )     \
00074     {                                               \
00075         (refNum)    = 0;                            \
00076         (err)       = errNone;                      \
00077     }
00078 #define SndFileStreamCloseLibrary( refNum, err )    \
00079     {                                               \
00080         (refNum)    = sysInvalidRefNum;             \
00081         (err)       = errNone;                      \
00082     }
00083 #else
00084 #define SndFileStreamOpenLibrary( refNum, err )                 \
00085     {                                                           \
00086         Boolean loaded;                                         \
00087                                                                 \
00088         loaded = false;                                         \
00089         (err) = SysLibFind( kSndFileStreamLibName, &(refNum) ); \
00090         if ( sysErrLibNotFound == (err) )                       \
00091         {                                                       \
00092             (err) = SysLibLoad( kSndFileStreamLibType,          \
00093                 kSndFileStreamLibCreator, &(refNum) );          \
00094             loaded = true;                                      \
00095         }                                                       \
00096                                                                 \
00097         if ( errNone == (err) )                                 \
00098         {                                                       \
00099             (err) = SndFileStreamLibOpen( (refNum) );           \
00100             if ( errNone != (err) )                             \
00101             {                                                   \
00102                 if ( loaded )                                   \
00103                 {                                               \
00104                     SysLibRemove( (refNum) );                   \
00105                 }                                               \
00106                                                                 \
00107                 (refNum) = sysInvalidRefNum;                    \
00108             }                                                   \
00109         }                                                       \
00110         else                                                    \
00111         {                                                       \
00112             (refNum) = sysInvalidRefNum;                        \
00113         }                                                       \
00114     }
00115 #define SndFileStreamCloseLibrary( refNum, err )                \
00116     {                                                           \
00117         if ( sysInvalidRefNum == (refNum) )                     \
00118         {                                                       \
00119             (err) = sysErrParamErr;                             \
00120         }                                                       \
00121         else                                                    \
00122         {                                                       \
00123             (err) = SndFileStreamLibClose( (refNum) );          \
00124             if ( errNone == (err) )                             \
00125             {                                                   \
00126                 (err) = SysLibRemove( (refNum) );               \
00127                 (refNum) = sysInvalidRefNum;                    \
00128             }                                                   \
00129             else if ( kSndFileStreamLibErrStillOpen == (err) )  \
00130             {                                                   \
00131                 (err) = errNone;                                \
00132             }                                                   \
00133         }                                                       \
00134     }
00135 #endif
00136 /*@}*/
00137
00138 /**
00139  * @name Error codes
00140  *
00141  * These macros take care of opening and closing the sound file stream library
00142  * in various situations.
00143  */
00144 /*@{*/
00145 #define kSndFileStreamLibErrNone                    errNone
00146 #define kSndFileStreamLibErrAlreadyOpen             1
00147 #define kSndFileStreamLibErrNotOpen                 2
00148 #define kSndFileStreamLibErrStillOpen               3
00149 #define kSndFileStreamLibErrOutOfMemory             4
00150 #define kSndFileStreamLibErrCantOpenFile            5
00151 #define kSndFileStreamLibErrUnsupportedFile         6
00152 #define kSndFileStreamLibErrCancel                  7
00153 #define kSndFileStreamLibErrOperationNotSupported   8
00154 /*@}*/
00155
00156 /**
00157  * @name Play back sound file stream
00158  *
00159  * Use for playbackCount parameter of tagSndFileStreamData to play back a
00160  * stream indefinitely.
00161  */
00162 /*@{*/
00163 #define kSndFileStreamLibPlaybackForever    0xFFFF
00164 /*@}*/
00165
00166 /**
00167  * Notification broadcast by SndFileStream when it has completed playing a stream.
00168  * This is an alternative to using callbacks in the case where SndFileStream is used
00169  * by an ARM app (eg. Blazer) or by a 68K app.
00170  *
00171  * In playback mode, it means that the file has completely played.
00172  * In recording mode, it means that it reaches the recording limit.
00173  */
00174 /*@{*/
00175 #define sndFileStreamNotifyStreamComplete   'StrC'
00176 /*@}*/
00177
00178 /**
00179  * Notification broadcast by SndFileStream when it exceeds the recording limit.
00180  * Currently this notification is handled by the libary itself, for example,
00181  * stop the recording stream. The application should NOT expect to recieve this notification
00182  * even it register it. Instead it should expect sndFileStreamNotifyStreamComplete notification to
00183  * indicate that the recording limit has been reached.
00184  */
00185 /*@{*/
00186 #define sndFileStreamNotifyRecComplete      'RecC'
00187 /*@}*/
00188
00189 /**
00190  * Sound file format
00191  *
00192  * The sound file format of the stream.
00193  */
00194 typedef enum tagSndFileFormatEnum
00195 {
00196     kSndFileFormatRaw = 0,  /**<Raw bytes. */
00197     kSndFileFormatWAV,      /**<RIFF-WAVE. */
00198     kSndFileFormatTreoQCP,  /**<RIFF-QLCM. */
00199     kSndFileFormatTreoAMR,  /**<Raw RTP packets. */
00200     kSndFileFormatMP3,      /**<MP3 format */
00201     kSndFileFormatAAC       /**<AAC format */
00202 }
00203 SndFileFormatType;
00204
00205 /** Reference to sound file stream returned by SndFileStreamCreate()/Open() */
00206 typedef void *SndFileStreamRef;
00207
00208 /**
00209  * @brief Holds data about a sound file stream.
00210  */
00211 typedef struct tagSndFileStreamData
00212 {
00213     UInt16      streamFlags;        /**<Flag for the sound file stream. */
00214     UInt16      streamMode;         /**<Use mode sndInput or sndOutput for sound file stream.*/
00215     UInt32      streamRefCon;       /**<Reserved for third party use. */
00216
00217     UInt16      playbackCount;      /**<How many times to play the sound. Values of 0 and 1 both cause
00218                                         the sound to be played back one time.  Is decremented each time
00219                                         play back of the sound is restarted. */
00220
00221     UInt16      streamComplete;     /**<Set to true when the stream has stopped because
00222                                         the playbackCount has been decremented to zero, maximumBytes is reached, or
00223                                         maximumMilliseconds is reached */
00224
00225     UInt32      dataSize;           /**<Size of the audio data in bytes. */
00226     UInt32      dataDuration;       /**<Duration of the audio data in milliseconds. */
00227     UInt32      customDataSize;     /**<Size of custom data in bytes. */
00228
00229     UInt32      fileFormat;         /**<Format of the sound file stream.  For example, kSndFileFormatWAV. */
00230     UInt32      sampleFormat;       /**<Format of the soud sample. Example: palmCodecAudioIMA_ADPCM */
00231     UInt32      sampleRate;         /**<Sample rate of hte sound file in frames/sec.  For example, 8000. */
00232     UInt32      sampleType;         /**<Type of the sound file.  For example, sndInt16. */
00233     UInt32      sampleWidth;        /**<Whether the sound is stereo, mono, and so forth.  For example, sndMono. */
00234     UInt32      sampleBlockAlign;   /**<Block alignment of the sound file.  For example, 256 for IMA ADPCM. */
00235
00236     UInt32      maximumMilliseconds;/**<Maximum milliseconds of play back. */
00237     UInt32      maximumBytes;       /**<Maximum value for lastPlayedBytes. */
00238
00239     UInt32      currentMillisecond; /**<Current millisecond of audio. */
00240     UInt32      lastByte;           /**<Last byte played or recorded on channel, */
00241
00242     MemPtr      customDataP;        /**<Pointer to custom data. */
00243 }
00244 SndFileStreamData, *SndFileStreamDataPtr;
00245
00246 /// Callback function passed when calling SndFileStreamCreate() and
00247 /// SndFileStreamOpen(). It will be called during playback and recording.
00248 ///
00249 /// @param stream:              IN:  Reference to stream returned by SndFileStreamCreate()/SndFileStreamOpen().
00250 /// @param streamDataP:         IN:  @see SndFileStreamData
00251 /// @param customDataModified:  OUT: If true, custom data has been modified.
00252 /// @retval Err Error code.
00253 typedef Err (*SndFileStreamCallbackPtr)( SndFileStreamRef stream,
00254     SndFileStreamDataPtr streamDataP, Boolean *customDataModified );
00255
00256 /**
00257  * @brief Descriptions of the stream file.
00258  *
00259  * Used with SndFileStreamCreate()/SndFileStreamOpen()
00260  */
00261 typedef struct tagSndFileStreamFileSpec
00262 {
00263     UInt16  flags;      /**< Set to kSndFileStreamFileSpecFlagVFS or kSndFileStreamFileSpecFlagFileStream */
00264
00265     UInt16  volRefNum;  /**< The volume reference number returned from VFSVolumeEnumerate(). */
00266
00267     Char    *fileNameP; /**< Name of the stream file */
00268
00269     UInt32  fileCreator;/**< Creator ID of the stream file  */
00270     UInt32  fileType;   /**< See File Stream Database Types */
00271 }
00272 SndFileStreamFileSpec, *SndFileStreamFileSpecPtr;
00273
00274 /**
00275  * @name File Flags
00276  *
00277  */
00278 /*@{*/
00279 #define kSndFileStreamFileSpecFlagVFS           (0x0001) /**<VFS file */
00280 #define kSndFileStreamFileSpecFlagFileStream    (0x0002) /**<File stream*/
00281 /*@}*/
00282
00283 /**
00284  * @name File stream database types
00285  *
00286  * File stream databases opened using kSndFileStreamFileSpecFlagFileStream.
00287  *
00288  */
00289 /*@{*/
00290 #define kSndFileTypeWAV 'WAVf'  /**<WAV file   -> kSndFileFormatWAV .    */
00291 #define kSndFileTypeQCP 'QCPf'  /**<QCELP file -> kSndFileFormatTreoQCP. */
00292 #define kSndFileTypeAMR 'AMRf'  /**<AMR file   -> kSndFileFormatTreoAMR. */
00293 #define kSndFileTypeMP3 'MP3f'  /**<MP3 file   -> kSndFileFormatMP3      */
00294 #define kSndFileTypeAAC 'AACf'  /**<AAC file   -> kSndFileFormatAAC      */
00295 /*@}*/
00296
00297 /**
00298  * @brief SndFileStreamDeviceControl param when cmd == hsSoundLibCreatorID
00299  *
00300  * Contains hsFormat/hsCmd pair to be used with PmSndStream() calls.
00301  */
00302 typedef struct tagSndFileStreamHsSoundCommandParam
00303 {
00304     UInt16  hsFormat;
00305     UInt16  hsCmd;
00306 }
00307 SndFileStreamHsSoundCommandParam, *SndFileStreamHsSoundCommandParamPtr;
00308
00309 /**
00310  * @name Library traps
00311  *
00312  */
00313 /*@{*/
00314 #define kSndFileStreamLibTrapVersion                (sysLibTrapCustom + 0)
00315 #define kSndFileStreamLibTrapCreate                 (sysLibTrapCustom + 1)
00316 #define kSndFileStreamLibTrapOpen                   (sysLibTrapCustom + 2)
00317 #define kSndFileStreamLibTrapClose                  (sysLibTrapCustom + 3)
00318 #define kSndFileStreamLibTrapStart                  (sysLibTrapCustom + 4)
00319 #define kSndFileStreamLibTrapPause                  (sysLibTrapCustom + 5)
00320 #define kSndFileStreamLibTrapStop                   (sysLibTrapCustom + 6)
00321 #define kSndFileStreamLibTrapSeek                   (sysLibTrapCustom + 7)
00322 #define kSndFileStreamLibTrapGetCurrentStreamData   (sysLibTrapCustom + 8)
00323 #define kSndFileStreamLibTrapDeviceControl          (sysLibTrapCustom + 9)
00324 #define kSndFileStreamLibTrapSetVolume              (sysLibTrapCustom + 10)
00325 #define kSndFileStreamLibTrapGetVolume              (sysLibTrapCustom + 11)
00326 #define kSndFileStreamLibTrapSetPan                 (sysLibTrapCustom + 12)
00327 #define kSndFileStreamLibTrapGetPan                 (sysLibTrapCustom + 13)
00328 #define kSndFileStreamLibTrapUIPlay                 (sysLibTrapCustom + 14)
00329 #define kSndFileStreamLibTrapUIRecord               (sysLibTrapCustom + 15)
00330 /*@}*/
00331
00332 #ifdef __cplusplus
00333 extern "C" {
00334 #endif
00335
00336 /// Opens the Sound File Stream library.
00337 ///
00338 /// @param libRefNum: IN:  Library reference number
00339 /// @retval Err Error code.
00340 extern Err SndFileStreamLibOpen( UInt16 libRefNum )
00341     SNDFILESTREAM_TRAP( sysLibTrapOpen );
00342
00343 /// Closes the Sound File Stream library.
00344 ///
00345 /// @param libRefNum: IN:  Library reference number
00346 /// @retval Err Error code.
00347 extern Err SndFileStreamLibClose( UInt16 libRefNum )
00348     SNDFILESTREAM_TRAP( sysLibTrapClose );
00349
00350 /// Standard library sleep routine.
00351 ///
00352 /// @param libRefNum: IN:  Library reference number
00353 /// @retval Err Error code.
00354 extern Err SndFileStreamLibSleep( UInt16 libRefNum )
00355     SNDFILESTREAM_TRAP( sysLibTrapSleep );
00356
00357 /// Standard library wake routine.
00358 ///
00359 /// @param libRefNum: IN:  Library reference number
00360 /// @retval Err Error code.
00361 extern Err SndFileStreamLibWake( UInt16 libRefNum )
00362     SNDFILESTREAM_TRAP( sysLibTrapWake );
00363
00364 /// Retrieve the library version number.
00365 ///
00366 /// @param libRefNum:    IN:  Library reference number
00367 /// @param *versionP:    OUT: Library version number.
00368 /// @retval Err Error code.
00369 extern Err SndFileStreamLibVersion( UInt16 libRefNum, UInt32 *versionP )
00370     SNDFILESTREAM_TRAP( kSndFileStreamLibTrapVersion );
00371
00372 /// Create a new sound file stream.
00373 ///
00374 /// @param libRefNum:    IN:  Library reference number
00375 /// @param streamP:      OUT: Reference to the created sound stream
00376 /// @param streamDataP:  IN:  @see SndFileStreamData
00377 /// @param fileSpecP:    IN:  Description of the file to be created
00378 /// @param callbackP:    IN:  User defined callback function, to be called on playback/recording.
00379 /// @retval Err Error code.
00380 extern Err SndFileStreamCreate( UInt16 libRefNum, SndFileStreamRef *streamP,
00381         SndFileStreamDataPtr streamDataP, SndFileStreamFileSpecPtr fileSpecP,
00382         SndFileStreamCallbackPtr callbackP )
00383     SNDFILESTREAM_TRAP( kSndFileStreamLibTrapCreate );
00384
00385 /// Open an already existing sound file stream.
00386 ///
00387 /// @param libRefNum:    IN:  Library reference number
00388 /// @param streamP:      OUT: Reference to the opened sound stream.
00389 /// @param streamDataP:  IN:  @see SndFileStreamData
00390 /// @param fileSpecP:    IN:  Description of the file to be opened.
00391 /// @param callbackP:    IN:  User defined callback function, to be called on playback/recording.
00392 /// @retval Err Error code.
00393 extern Err SndFileStreamOpen( UInt16 libRefNum, SndFileStreamRef *streamP,
00394         SndFileStreamDataPtr streamDataP, SndFileStreamFileSpecPtr fileSpecP,
00395         SndFileStreamCallbackPtr callbackP )
00396     SNDFILESTREAM_TRAP( kSndFileStreamLibTrapOpen );
00397
00398 /// Close the reference to the file stream.
00399 ///
00400 /// @param libRefNum:    IN: Library reference number
00401 /// @param stream:       IN: Reference to the sound stream, returned when creating/opening file stream.
00402 /// @retval Err Error code.
00403 extern Err SndFileStreamClose( UInt16 libRefNum, SndFileStreamRef stream )
00404     SNDFILESTREAM_TRAP( kSndFileStreamLibTrapClose );
00405
00406 /// Start streaming sound into file.
00407 ///
00408 /// @param libRefNum:    IN: Library reference number
00409 /// @param stream:       IN: Reference to the sound stream, returned when creating/opening stream.
00410 /// @retval Err Error code.
00411 extern Err SndFileStreamStart( UInt16 libRefNum, SndFileStreamRef stream )
00412     SNDFILESTREAM_TRAP( kSndFileStreamLibTrapStart );
00413
00414 /// Pause sound streaming.
00415 ///
00416 /// @param libRefNum:    IN: Library reference number
00417 /// @param stream:       IN: Reference to the sound stream, returned when creating/opening stream.
00418 /// @param pause:        IN: If true, pause. Otherwise, resume.
00419 /// @retval Err Error code.
00420 extern Err SndFileStreamPause( UInt16 libRefNum, SndFileStreamRef stream,
00421         Boolean pause )
00422     SNDFILESTREAM_TRAP( kSndFileStreamLibTrapPause );
00423
00424 /// Stop sound streaming.
00425 ///
00426 /// @param libRefNum:    IN: Library reference number
00427 /// @param stream:       IN: Reference to the sound stream, returned when creating/opening stream.
00428 /// @retval Err Error code.
00429 extern Err SndFileStreamStop( UInt16 libRefNum, SndFileStreamRef stream )
00430     SNDFILESTREAM_TRAP( kSndFileStreamLibTrapStop );
00431
00432 /// Move the pointer to the stream to a user-defined offset.
00433 ///
00434 /// @param libRefNum:       IN: Library reference number
00435 /// @param stream:          IN: Reference to the sound stream, returned when creating/opening stream.
00436 /// @param seekMilliseconds IN: Offset in milliseconds.
00437 /// @retval Err Error code.
00438 extern Err SndFileStreamSeek( UInt16 libRefNum, SndFileStreamRef stream,
00439         UInt32 seekMilliseconds )
00440     SNDFILESTREAM_TRAP( kSndFileStreamLibTrapSeek );
00441
00442 /// Get streaming data.
00443 ///
00444 /// @param libRefNum:    IN:  Library reference number
00445 /// @param stream:       IN:  Reference to the sound stream, returned when creating/opening stream.
00446 /// @param streamDataP:  OUT: @see SndFileStreamData
00447 /// @retval Err Error code.
00448 extern Err SndFileStreamGetCurrentStreamData( UInt16 libRefNum,
00449         SndFileStreamRef stream, SndFileStreamDataPtr streamDataP )
00450     SNDFILESTREAM_TRAP( kSndFileStreamLibTrapGetCurrentStreamData );
00451
00452 /// Control device when streaming.
00453 ///
00454 /// @param libRefNum:    IN: Library reference number
00455 /// @param stream:       IN: Reference to the sound stream, returned when creating/opening stream.
00456 /// @param cmd:          IN: No definition.
00457 /// @param param:        IN: No definition.
00458 /// @param size:         IN: No definition.
00459 /// @retval Err Error code.
00460 extern Err SndFileStreamDeviceControl( UInt16 libRefNum,
00461         SndFileStreamRef stream, Int32 cmd, void *param, Int32 size )
00462     SNDFILESTREAM_TRAP( kSndFileStreamLibTrapDeviceControl );
00463
00464 /// See SndStreamSetVolume() documented under Palm OS Sound Manager API.
00465 ///
00466 /// @param libRefNum:    IN: Library reference number
00467 /// @param stream:       IN: Reference to the sound stream, returned when creating/opening stream.
00468 /// @param volume:       IN: No definition.
00469 /// @retval Err Error code.
00470 extern Err SndFileStreamSetVolume( UInt16 libRefNum, SndFileStreamRef stream,
00471         Int32 volume )
00472     SNDFILESTREAM_TRAP( kSndFileStreamLibTrapSetVolume );
00473
00474 /// See SndStreamGetVolume() documented under Palm OS Sound Manager API.
00475 ///
00476 /// @param libRefNum:   IN:  Library reference number
00477 /// @param stream:      IN:  Reference to the sound stream, returned when creating/opening stream.
00478 /// @param volumeP:     OUT: Range 0 - 32k. See Palm OS SoundMgr API documentation for more details.
00479 /// @retval Err Error code.
00480 extern Err SndFileStreamGetVolume( UInt16 libRefNum, SndFileStreamRef stream,
00481         Int32 *volumeP )
00482     SNDFILESTREAM_TRAP( kSndFileStreamLibTrapGetVolume );
00483
00484 /// Set stereo balance.
00485 /// See SndStreamSetPan() documented under Palm OS Sound Manager API.
00486 ///
00487 /// @param libRefNum:    IN: Library reference number
00488 /// @param stream:       IN: Reference to the sound stream.
00489 /// @param panPosition:  IN: Range [-1024, 1024]
00490 /// @retval Err Error code.
00491 extern Err SndFileStreamSetPan( UInt16 libRefNum, SndFileStreamRef stream,
00492         Int32 panPosition )
00493     SNDFILESTREAM_TRAP( kSndFileStreamLibTrapSetPan );
00494
00495 /// Get stereo balance.
00496 /// See SndStreamGetPan() documented under Palm OS Sound Manager API.
00497 ///
00498 /// @param libRefNum:        IN:  Library reference number
00499 /// @param stream:           IN:  Reference to the sound stream.
00500 /// @param panPositionP:     OUT: Range [-1024, 1024]
00501 /// @retval Err Error code.
00502 extern Err SndFileStreamGetPan( UInt16 libRefNum, SndFileStreamRef stream,
00503         Int32 *panPositionP )
00504     SNDFILESTREAM_TRAP( kSndFileStreamLibTrapGetPan );
00505
00506 /// Play sound stream with UI
00507 ///
00508 /// @param libRefNum:        IN: Library reference number
00509 /// @param fileSpecP:        IN: Pointer to the sound file to be played.
00510 /// @param allowRerecord:    IN: No definition.
00511 /// @retval Err Error code.
00512 extern Err SndFileStreamUIPlay( UInt16 libRefNum,
00513         SndFileStreamFileSpecPtr fileSpecP, Boolean allowRerecord )
00514     SNDFILESTREAM_TRAP( kSndFileStreamLibTrapUIPlay );
00515
00516 /// Record sound stream with UI
00517 ///
00518 /// @param libRefNum:        IN: Library reference number
00519 /// @param streamDataP:      IN: Stream data to be used for recording.
00520 /// @param fileSpecP:        IN: Pointer to the sound file to be recorded.
00521 /// @param allowRerecord:    IN: No definition.
00522 /// @retval Err Error code.
00523 extern Err SndFileStreamUIRecord( UInt16 libRefNum,
00524         SndFileStreamDataPtr streamDataP, SndFileStreamFileSpecPtr fileSpecP,
00525         Boolean allowRerecord )
00526     SNDFILESTREAM_TRAP( kSndFileStreamLibTrapUIRecord );
00527
00528 #ifdef __cplusplus
00529 }
00530 #endif
00531
00532 #endif //__SNDFILESTREAM_H__
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:54 2008 for Palm API Guide


Header Files » Incs » 68k » system

palmOneStatusBar.h

Go to the documentation of this file.
00001 /*******************************************************************************
00002  * Copyright (c) 2004-2005 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  ******************************************************************************/
00005 /**
00006  * @defgroup    StatusBar Status Bar Library
00007  * @brief       This library provides support to manipulate the state of the status
00008  *              bar on devices that utilize the Dynamic Input Area (DIA).
00009  *
00010  * Devices such as Tungsten T3 and Tungsten T5 allow users to collapse/expand the input
00011  * area to support tall forms. This library allows the status/control bar to be hidden
00012  * programmatically so that forms can be displayed full screen.
00013  *
00014  * Most of the APIs in the library should already exist in Palm OS SDK, and applications
00015  * that are developed for DIA-enabled OS should first try to use the PalmSource's status
00016  * bar API.
00017  *
00018  * @{
00019  * @}
00020  */
00021 /**
00022  * @ingroup StatusBar
00023  */
00024
00025 /**
00026  * @file    palmOneStatusBar.h
00027  * @version 1.0
00028  * @brief   Public common header file for palmOne defined Status Bar library.
00029  *
00030  * This file contains the function prototypes and constants for the palmOne Status Bar Library
00031  * <hr>
00032  */
00033
00034
00035 #ifndef __STATUSBARMGRLIB_H__
00036 #define __STATUSBARMGRLIB_H__
00037
00038 #include <PalmTypes.h>
00039 #include <LibTraps.h>
00040
00041
00042 /**
00043  * @name Library Constants
00044  *
00045  */
00046 /*@{*/
00047 #define palmOneStatusBarLibName         "StatusBarMgrLib"   /**< StatusBar library name */
00048 #define palmOneStatusBarLibCreator      'sBar'              /**< StatusBar library creator ID */
00049 #define palmOneStatusBarLibType         sysFileTLibrary     /**< Default library type */
00050 #define palmOneStatusBarFtrNumVersion   (0)                 /**< Version of the currently supported features */
00051 /*@}*/
00052
00053 /**
00054  * @name Error Codes
00055  *
00056  */
00057 /*@{*/
00058 #define palmOneStatusBarErrorClass          (appErrorClass  | 0x0900)
00059 #define palmOneStatusBarErrNoStatusBar      (palmOneStatusBarErrorClass | 1)
00060 #define palmOneStatusBarErrInvalidSelector  (palmOneStatusBarErrorClass | 2)
00061 #define palmOneStatusBarErrInputWindowOpen  (palmOneStatusBarErrorClass | 3)
00062 #define palmOneStatusBarErrBadParam         (palmOneStatusBarErrorClass | 101)
00063 #define palmOneStatusBarErrInvalidState     (palmOneStatusBarErrorClass | 102)
00064 /*@}*/
00065
00066 /**
00067  * Status Bar Attributes
00068  **/
00069 typedef enum PalmOneStatAttrTypeTag
00070 {
00071     palmOneStatusBarAttrExists     = 0,         /**< device supports the status bar */
00072     palmOneStatusBarAttrBarVisible,             /**< status bar is visible */
00073     palmOneStatusBarAttrDimension               /**< bounds of status bar window */
00074 } PalmOneStatAttrType;
00075
00076
00077 /**
00078  * @name Function Traps
00079  *
00080  */
00081 /*@{*/
00082 #define kPalmOneStatusBarMgrLibTrapOpen     sysLibTrapOpen
00083 #define kPalmOneStatusBarMgrLibTrapClose    sysLibTrapClose
00084 #define kPalmOneStatusBarMgrLibGetAttribute (sysLibTrapCustom)
00085 #define kPalmOneStatusBarMgrLibHide         (sysLibTrapCustom + 1)
00086 #define kPalmOneStatusBarMgrLibShow         (sysLibTrapCustom + 2)
00087 /*@}*/
00088
00089 /**
00090  * Prototypes
00091  **/
00092 #ifdef __cplusplus
00093 extern "C" {
00094 #endif
00095
00096 /**
00097  * @brief Standard open library routine
00098  *
00099  * @param refnum:   IN: Library reference number
00100  * @return Error code.
00101  **/
00102 Err PalmOneStatusBarLibOpen(UInt16 refnum)
00103                 SYS_TRAP(kPalmOneStatusBarMgrLibTrapOpen);
00104
00105 /**
00106  * @brief Standard close library routine
00107  *
00108  * @param refnum:   IN: Library reference number
00109  * @return Error code.
00110  **/
00111 Err PalmOneStatusBarLibClose(UInt16 refnum)
00112                 SYS_TRAP(kPalmOneStatusBarMgrLibTrapClose);
00113
00114 /**
00115  * @brief Retrieve the current state of the status bar
00116  *
00117  * @param refnum:   IN: Library reference number
00118  * @param selector: IN: Attribute selector (dimension or status)
00119  * @param *dataP:   IN: Pointer to the returned attribute value.
00120  * @return Error code.
00121  **/
00122 Err PalmOneStatusBarGetAttribute(UInt16 refnum, PalmOneStatAttrType selector, UInt32 *dataP)
00123                 SYS_TRAP(kPalmOneStatusBarMgrLibGetAttribute);
00124
00125 /**
00126  * @brief Hide the status bar from the bottom of the screen
00127  *
00128  * @param refnum:   IN:  Library reference number
00129  * @return Error code.
00130  **/
00131 Err PalmOneStatusBarHide(UInt16 refnum)
00132                 SYS_TRAP(kPalmOneStatusBarMgrLibHide);
00133
00134 /**
00135  * @brief Unhide/show the status bar at the bottom of the screen
00136  *
00137  * @param refnum:   IN:  Library reference number
00138  * @return Error code.
00139  **/
00140 Err PalmOneStatusBarShow(UInt16 refnum)
00141                 SYS_TRAP(kPalmOneStatusBarMgrLibShow);
00142
00143 #ifdef __cplusplus
00144 }
00145 #endif
00146
00147 #endif  //__STATUSBARMGRLIB_H__
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:54 2008 for Palm API Guide


Header Files » Incs » common » system

palmOneSystemCommon.h

Go to the documentation of this file.
00001 /**
00002  * @file  palmOneSystemCommon.h
00003  * @brief This is the common public header for palmOne system
00004  *        definitions.
00005  */
00006
00007 /*
00008  * \author    Debbie Chyi
00009  * $Id:$
00010  *
00011  ****************************************************************/
00012
00013
00014 #ifndef __PALMONE_SYSTEM_COMMON_H__
00015 #define __PALMONE_SYSTEM_COMMON_H__
00016
00017
00018 // Macro that builds a library version value from the passed-in major
00019 //  and minor values.  Major values are incremented when a library's
00020 //  API changes.  When a major value is incremented, the minor value
00021 //  is reset to 0.  Minor values are incremented when a library is
00022 //  released with code changes but the API itself has not changed
00023 //  from the previous release.
00024 #define sysMakeLibAPIVersion(major, minor)                  \
00025         (                                                   \
00026         (((UInt32)((UInt16)(major) & 0x0FFFF)) << 16) |     \
00027         (((UInt32)((UInt16)(minor) & 0x0FFFF)))             \
00028         )
00029
00030
00031 // Macros for parsing the library version number.  Comments above
00032 //  sysMakeLibVersion describe the difference between and major and
00033 //  minor version numbers.
00034 #define sysGetLibAPIVersionMajor(libVer)        (((UInt16)((libVer) >> 16)) & 0x0FFFF)
00035 #define sysGetLibAPIVersionMinor(libVer)        (((UInt16)(libVer))         & 0x0FFFF)
00036
00037 #endif // __PALMONE_SYSTEM_COMMON_H__
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:54 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » vmfont

palmOneVMFontLib.h

Go to the documentation of this file.
00001 /******************************************************************************
00002  * Copyright (c) 2004 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  *****************************************************************************/
00005 /**
00006  * @ingroup Versamail
00007  */
00008
00009 /**
00010  * @file    palmOneVMFontLib.h
00011  * @version 1.0
00012  *
00013  * @brief Defines APIs and structures for the Palm VersaMail Font Picker / Font Manager
00014  * Service which lets users get / set font characteristics.
00015  */
00016
00017 #ifndef __PALMONEVMFONTLIBRARY_H__
00018 #define __PALMONEVMFONTLIBRARY_H__
00019
00020 #include <PalmTypes.h>
00021 #include <Font.h>
00022 #include <DataMgr.h>
00023 #include <LibTraps.h>
00024 #include <Common/Libraries/VMFont/VMFontLibCommon.h>
00025
00026 #ifdef BUILDING_VMFONTLIB
00027 #define VMFONTLIB_TRAP( trapNum )
00028 #else
00029 #define VMFONTLIB_TRAP( trapNum )  SYS_TRAP( trapNum )
00030 #endif
00031
00032
00033 /********************************************************************
00034  * Prototypes
00035  ********************************************************************/
00036 #ifdef __cplusplus
00037 extern "C" {
00038 #endif
00039
00040 /**
00041  * Opens the Font Picker library. Does Initialization of library.
00042  *
00043  * @brief This function should be called prior to calling the other Font
00044  *        Picker functions.
00045  *
00046  * @param   libRefNum:      IN: Reference number of the Font Picker library.
00047  * @param   clientContextP: OUT: pointer to variable for returning client context.
00048  *                          The client context is used to maintain client-specific
00049  *                          data for multiple client support.The value returned here
00050  *                          will be used as a parameter for other library functions
00051  *                          which require a client context.
00052  *
00053  * @retval  Err The error code returned from the library. If this is errNone, the
00054  *          function was sucessful.
00055  *
00056  * @code
00057  * UInt16 fontPickerLibRefNum = 0;
00058  * UInt32 context;
00059  * err = SysLibFind(fontPickerLibName, &fontPickerLibRefNum);
00060  * if( err == sysErrLibNotFound )
00061  * {
00062  *     err = SysLibLoad(fontPickerType, fontPickerCreatorID, &fontPickerLibRefNum);
00063  *         if( !err ) {
00064  *             err = VMFontOpen(fontPickerLibRefNum, &context);
00065  *         }
00066  * } @endcode
00067  *
00068  * @see VMFontClose
00069  */
00070
00071 extern Err VMFontOpen( UInt16 libRefNum, UInt32 *clientContextP )
00072                 VMFONTLIB_TRAP( sysLibTrapOpen );
00073
00074
00075 /**
00076  * Closes the Font Picker library and perform cleanup.
00077  *
00078  * @brief This function should be called after your application has
00079  *        finished with the Font Picker library.
00080  *
00081  * @param   libRefNum:      IN: Reference number of the Font Picker library.
00082  * @param   clientContext:  IN: Library's client context number got during open.
00083  *
00084  * @retval  Err The error code returned from the library. If this is errNone, the
00085  *          function was sucessful.
00086  *
00087  * @code
00088  * err = VMFontClose(fontPickerLibRefNum, context); @endcode
00089  *
00090  * @see VMFontOpen
00091  */
00092
00093 extern Err VMFontClose( UInt16 libRefNum, UInt32 clientContext )
00094                 VMFONTLIB_TRAP( sysLibTrapClose );
00095
00096
00097
00098 /**
00099  * Get the Font Library Version
00100  *
00101  * @param   libRefNum:      IN: Reference number of the Font Picker library.
00102  * @param   versionP:       OUT: Pointer to the version number
00103  *
00104  * @retval  Err Always errNone
00105  *
00106  */
00107
00108 extern Err VMFontVersion( UInt16 libRefNum, UInt32 *versionP )
00109                 VMFONTLIB_TRAP( flTrapAPIVersion );
00110
00111 /**
00112  * Get the font ID based on the given font characteristics.
00113  * The returned font ID is NOT guaranteed to be always available.
00114  * Therefore to avoid any error, please make sure that VMFontExists
00115  * is used whenever a font is needed.
00116  *
00117  * @param   libRefNum:      IN: Reference number of the Font Picker library.
00118  * @param   fontP:          IN: the font characteristics.
00119  *
00120  * @retval  UInt8 The defined font ID
00121  *
00122  * @code
00123  * // get the font ID for gill Sans MT 9 pt Italic
00124  * VMFontPtr fontP = (VMFontPtr) MemPtrNew (sizeof (VMFontType));
00125  * fontP->face = gillSans;
00126  * fontP->size = size6;
00127  * fontP->style = italic;
00128  * UInt8 myFontID = stdFont;
00129  * if (VMFontExists( theRefNum, fontP ))
00130  *  {    myFontID = VMFontGetFont( theRefNum, fontP );   } @endcode
00131  *
00132  * @see VMFontExists
00133  */
00134
00135 extern UInt8 VMFontGetFont(UInt16 libRefNum, const VMFontPtr fontP)
00136     VMFONTLIB_TRAP(flTrapAPIGetFont);
00137
00138 /**
00139  * Get the Font characteristics based on a saved FontID
00140  *
00141  * @param   libRefNum:      IN: Reference number of the Font Picker library.
00142  * @param   targetP:        IN: the font characteristics.
00143  * @param   fontID:         IN: the font ID passed in.
00144  *
00145  * @retval  UInt8 The defined font ID
00146  *
00147  * @code
00148  * UInt8 myOldID;
00149  * UInt8 myFontID;
00150  * MemHandle handle;
00151  * VMFontPtr fontP;
00152  *
00153  * handle = MemHandleNew(sizeof(VMFontType));
00154  * fontP = (VMFontPtr) MemHandleLock(handle);
00155  *
00156  * myOldID = GetFontIDFromPrefs(); // assume that we have a funct to get the old ID
00157  * myFontID = VMFontGetFontByID( gRefNum, fontP, myOldID );
00158  * @endcode
00159  *
00160  *
00161  */
00162
00163 extern UInt8 VMFontGetFontByID(UInt16 libRefNum, VMFontPtr targetP, UInt8 fontID)
00164     VMFONTLIB_TRAP(flTrapAPIGetFontByID);
00165
00166 /**
00167  * Check to see if the specified font exists in the database.
00168  *
00169  * @param   libRefNum:      IN: Reference number of the Font Picker library.
00170  * @param   fontP:          IN: the font characteristics we want to check.
00171  *
00172  * @retval  Boolean True if the font exists in the database, false otherwise.
00173  *
00174  * @code
00175  * MemHandle handle;
00176  * VMFontPtr fontP;
00177  * Boolean exists = false;
00178  *
00179  * handle = MemHandleNew(sizeof( VMFontType ));
00180  * fontP = (VMFontPtr) MemHandleLock(handle);
00181  *
00182  * fontP->face = segoe;
00183  * fontP->size = size6;
00184  * fontP->style = bold;
00185  *
00186  * exists = VMFontExists( gRefNum, fontP );
00187  *
00188  * MemHandleUnlock(handle);
00189  * MemHandleFree(handle);
00190  * @endcode
00191  *
00192  * @see VMFontGetFont
00193  */
00194
00195 extern Boolean VMFontExists(UInt16 libRefNum, const VMFontPtr fontP)
00196     VMFONTLIB_TRAP(flTrapAPIFontExists);
00197
00198 /**
00199  * Given a font characteristics (defined as VMFontPtr), get the
00200  * human-readable font description of that font in the form of
00201  * "<NAME> <SIZE> <STYLE>", e.g. "Gill Sans MT 9 Bold".
00202  *
00203  * @param   libRefNum:      IN: Reference number of the Font Picker library.
00204  * @param   fontP:          IN: the font characteristics we want to check.
00205  * @param   stringP:        OUT: Pointer to output string buffer.
00206  *
00207  * @retval  Nothing
00208  *
00209  */
00210 extern void VMFontToString(UInt16 libRefNum, const VMFontPtr fontP, char *stringP)
00211     VMFONTLIB_TRAP(flTrapAPIFontToString);
00212
00213
00214 /**
00215  * Given a font face, find out how many size/styles were associated with it.
00216  *
00217  * @param   libRefNum:      IN: Reference number of the Font Picker library.
00218  * @param   face:           IN: the font face we need details about.
00219  * @param   sizeP:          OUT: contains total sizes for the font face
00220  * @param   styleP:         OUT: contains total styles for the font face
00221  *
00222  * @retval  Nothing
00223  *
00224  */
00225 extern void VMFontCountStyleAndSize(UInt16 libRefNum, VMFontFace face, Int8 *sizeP, Int8 *styleP)
00226     VMFONTLIB_TRAP(flTrapAPIFontCountStyleAndSize);
00227
00228 // Font Picker functions
00229
00230 /**
00231  * Initialize the font picker UI internal data structure.
00232  * Please note that it is very important that this function
00233  * is called before any Font picker specific functions are called.
00234  *
00235  * @param   libRefNum:      IN: Reference number of the Font Picker library.
00236  *
00237  * @retval  Nothing
00238  *
00239  */
00240
00241 extern void InitFontUI(UInt16 libRefNum)
00242     VMFONTLIB_TRAP(flTrapAPIInitFontUI);
00243
00244 /**
00245  * Popup the font picker dialog, and let the user pick a font from the
00246  * list.  Once the user taps OK, the selected font id will be copied
00247  * into the target parameter.
00248  *
00249  * @param   libRefNum:      IN:  Reference number of the Font Picker library.
00250  * @param   fontIDP:        OUT: fontID that user has selected.
00251  * @param   oldFontID :     IN:  The font picker will use this font to pre populate the font list.
00252  *                               This is very useful when you have a previously saved font in
00253  *                               the preference that you want to use when popping up the dialog.
00254  *                               If no saved preference is used, then you can always pass in
00255  *                               stdFont as the argument.
00256  *
00257  *
00258  * @retval Boolean True if user tapped OK false if user selected cancel
00259  */
00260
00261 extern Boolean DoFontDialog(UInt16 libRefNum, UInt8 *fontIDP, UInt8 oldFontID)
00262     VMFONTLIB_TRAP(flTrapAPIDoFontDialog);
00263
00264
00265 /**
00266  * Clear the interal cache of the font library
00267  * @param libRefNum: IN: library reference number.
00268  */
00269 extern void VMFontClearCache(UInt16 libRefNum)
00270     VMFONTLIB_TRAP(flTrapAPIClearCache);
00271
00272 /**
00273  * Define the UI rules, e.g.: hide style picker, do not show the style picker,
00274  * show only small fonts, etc.
00275  *
00276  * @brief                   Currently the only controllable UI components are
00277  *
00278  *                          Components visibility controls
00279  *                          - Font face picker: true/false
00280  *                          - Font style picker: true/false
00281  *                          - Font size picker: true/false
00282  *                          List items controls
00283  *                          - Font Size: allSize, smallFonts, largeFonts
00284  *                          - Font Style: allStyle, plainOnly
00285  *
00286  * @param   libRefNum:      IN:Reference number of the Font Picker library.
00287  * @param   fontRules:      IN:fontRules that need to be applied
00288  *
00289  * @retval  Nothing
00290  *
00291  * @code
00292  *
00293  * VMFontUIRules rules;
00294  * UInt8 myFontID;
00295  * UInt8 oldFontID;
00296  *
00297  * // let's hide style drop down list, and only display small fonts
00298  * //(size 6 if available and size 9 fonts)
00299  * rules.fontFaceVisible = true;
00300  * rules.fontSizeVisible = true;
00301  * rules.fontStyleVisible = true;
00302  * rules.sizeRule = smallFonts;
00303  * rules.styleRule = allStyle;
00304  *
00305  * InitFontUI( libRefNum );
00306  * SetFontUIRules( libRefNum, rules ); // apply the rules
00307  * if  (DoFontDialog( libRefNum, &myFontID, oldFontID ))
00308  * {
00309  *    // do something with the font
00310  * }
00311  * else
00312  * {
00313  *    // handle the case when user cancels out of the font picker UI
00314  * }
00315  * @endcode
00316  */
00317
00318 extern void SetFontUIRules(UInt16 libRefNum, VMFontUIRules fontRules)
00319     VMFONTLIB_TRAP(flTrapAPISetFontUIRules);
00320
00321 #ifdef __cplusplus
00322 }
00323 #endif
00324
00325 #endif
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:54 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » imaging

PalmPhoto.h

Go to the documentation of this file.
00001 /******************************************************************************
00002  * Copyright (c) 2004 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  *****************************************************************************/
00005 /**
00006  * @ingroup Imaging
00007  */
00008
00009 /**
00010  * file     PalmPhoto.h
00011  * @version 3.0
00012  * @date    04/28/2004
00013  *
00014  * @brief Palm Photos API.
00015  * @see palmOnephoto.h
00016  *
00017  */
00018
00019 #ifndef Palm_Photo_H_
00020 #define Palm_Photo_H_
00021
00022 // Temporary shim until we move all the apps to the new filename
00023 // if you are adding this library to your application, you should
00024 // use palmOnePhoto.h directly.
00025
00026 #include <68K/Libraries/Imaging/palmOnePhoto.h>
00027
00028 #endif /* Palm_Photo_H_ */
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:54 2008 for Palm API Guide


Header Files » Incs » 68k » system

PalmPin.h

Go to the documentation of this file.
00001 /******************************************************************************
00002  * Copyright (c) 2005 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  *****************************************************************************/
00005 /**
00006  * @defgroup PIN Pen Input Manager Library
00007  *
00008  * @{
00009  * @}
00010  */
00011 /**
00012  * @ingroup PIN
00013  *
00014  */
00015
00016 /**
00017  * @file    PalmPin.h
00018  * @version 1.0
00019  *
00020  * @brief  Public API for the Pen Input Manager Library
00021  *
00022  *
00023  * <hr>
00024  */
00025
00026
00027 #ifndef __PINLIB_H__
00028 #define __PINLIB_H__
00029
00030 #include <PalmTypes.h>
00031 #include <LibTraps.h>
00032
00033 /**
00034  * @name Library type and creator
00035  *
00036  */
00037 /*@{*/
00038 #define pinLibType          sysFileTLibrary     /**<        */
00039 #define pinLibCreator           'pinM'          /**<        */
00040 #define pinLibName          "PinLib"        /**<        */
00041 #define pinFtrNumVersion        0           /**<        */
00042 /*@}*/
00043
00044 /**
00045  * @name Pinlet IDs
00046  *
00047  */
00048 /*@{*/
00049 #define pinClassic          "Classic"   /**<        */
00050 #define pinTriCell          "Tri Cell"  /**<        */
00051 #define pinStdKeyboard          "StdKB"     /**<        */
00052 #define pinletStdKbNum          "StdKBNum"  /**<        */
00053 #define pinletStdKbIntl         "StdKBIntl" /**<        */
00054 /*@}*/
00055
00056 /**
00057  * @name PIN Manager Errors
00058  *
00059  */
00060 /*@{*/
00061 #define pinErrorClass           (appErrorClass | 0x0A00)    /**<        */
00062 #define pinErrInvalidState      (pinErrorClass + 1)     /**<        */
00063 #define pinErrUnknownID         (pinErrorClass + 2)     /**<        */
00064 #define pinErrInvalidInputMode      (pinErrorClass + 3)     /**<        */
00065 /*@}*/
00066
00067 /**
00068  * @name Input area states
00069  *
00070  */
00071 /*@{*/
00072 #define pinInputAreaNone        0   /**<        */
00073 #define pinInputAreaShow        1   /**<        */
00074 #define pinInputAreaHide        2   /**<        */
00075 #define pinInputAreaLegacyMode      3   /**<        */
00076 #define pinInputAreaFullScreen      4   /**<        */
00077 /*@}*/
00078
00079 /**
00080  * @name Input Modes
00081  *
00082  */
00083 /*@{*/
00084 #define pinInputModeNormal      0   /**<        */
00085 #define pinInputModeShift       1   /**<        */
00086 #define pinInputModeCapsLock        2   /**<        */
00087 #define pinInputModePunctuation     3   /**<        */
00088 #define pinInputModeNumeric     4   /**<        */
00089 #define pinInputModeExtended        5   /**<        */
00090 #define pinInputModeHiragana        6   /**<        */
00091 #define pinInputModeKatakana        7   /**<        */
00092 /*@}*/
00093
00094 /**
00095  * @name AIA event and notification
00096  *
00097  */
00098 /*@{*/
00099 #define sysNotifyAiaEvent       'Aian'      /**<        */
00100 #define AiaExtentChangedEvent       0x5000      /**<        */
00101 /*@}*/
00102
00103 typedef struct AiaExtentChangedEventDataType
00104 {
00105     RectangleType newDim;       /**<        */
00106     RectangleType oldDim;       /**<        */
00107 } AiaExtentChangedEventDataType;
00108
00109 /**
00110  * Macro to simplify getting the data out of the event structure.
00111  *
00112  * Example:
00113  * yDiff = AiaExtentChangedData(eventP)->newDim->extent.y -
00114  *         aiaExtentChangedData(eventP)->oldDim->extent.y;
00115  **/
00116 #define aiaExtentChangedData(eventP) ((AiaExtentChangedEventDataType *)(&((eventP)->data.generic))) /**<        */
00117
00118
00119 /**
00120  * @name Library Traps
00121  *
00122  */
00123 /*@{*/
00124 #define kPinLibTrapOpen             sysLibTrapOpen          /**<        */
00125 #define kPinLibTrapClose            sysLibTrapClose         /**<        */
00126 #define kPinLibTrapPinGetInputAreaState     (sysLibTrapCustom + 17)     /**<        */
00127 #define kPinLibTrapPinSetInputAreaState     (sysLibTrapCustom + 18)     /**<        */
00128 #define kPinLibTrapPinResetInputState       (sysLibTrapCustom + 24)     /**<        */
00129 #define kPinLibTrapPinGetCurrentPinletID    (sysLibTrapCustom + 20)     /**<        */
00130 #define kPinLibTrapPinSwitchToPinlet        (sysLibTrapCustom + 21)     /**<        */
00131 #define kPinLibTrapPinGetInputMode      (sysLibTrapCustom + 23)     /**<        */
00132 #define kPinLibTrapPinSetInputMode      (sysLibTrapCustom + 22)     /**<        */
00133 #define kPinLibTrapPINShowReferenceDialog   (sysLibTrapCustom + 25)     /**<        */
00134 /*@}*/
00135
00136 /**
00137  * Prototypes
00138  **/
00139 #ifdef __cplusplus
00140 extern "C" {
00141 #endif
00142
00143 /**
00144  * @brief
00145  *
00146  * @param refnum:   IN:
00147  * @retval Err error code.
00148  **/
00149 Err PinLibOpen(UInt16 refnum)
00150                 SYS_TRAP(kPinLibTrapOpen);
00151
00152 /**
00153  * @brief
00154  *
00155  * @param refnum:   IN:
00156  * @retval Err error code.
00157  **/
00158 Err PinLibClose(UInt16 refnum)
00159                 SYS_TRAP(kPinLibTrapClose);
00160
00161 /**
00162  * @brief
00163  *
00164  * @param refnum:   IN:
00165  * @retval Err error code.
00166  **/
00167 UInt16 PinGetInputAreaState(UInt16 refnum)
00168                 SYS_TRAP(kPinLibTrapPinGetInputAreaState);
00169
00170 /**
00171  * @brief
00172  *
00173  * @param refnum:   IN:
00174  * @param state:    IN:
00175  * @retval Err error code.
00176  **/
00177 Err PinSetInputAreaState(UInt16 refnum, UInt16 state)
00178                 SYS_TRAP(kPinLibTrapPinSetInputAreaState);
00179
00180 /**
00181  * @brief
00182  *
00183  * @param refnum:   IN:
00184  * @retval Err error code.
00185  **/
00186 void PinResetInputState(UInt16 refnum)
00187                 SYS_TRAP(kPinLibTrapPinResetInputState);
00188
00189 /**
00190  * @brief
00191  *
00192  * @param refnum:   IN:
00193  * @retval Err error code.
00194  **/
00195 const char* PinGetCurrentPinletID(UInt16 refnum)
00196                 SYS_TRAP(kPinLibTrapPinGetCurrentPinletID);
00197
00198 /**
00199  * @brief
00200  *
00201  * @param refnum:   IN:
00202  * @param pinletID: IN:
00203  * @param initialInputMode: IN:
00204  * @retval Err error code.
00205  **/
00206 Err PinSwitchToPinlet(UInt16 refnum, const char* pinletID, UInt16 initialInputMode)
00207                 SYS_TRAP(kPinLibTrapPinSwitchToPinlet);
00208
00209 /**
00210  * @brief
00211  *
00212  * @param refnum:   IN:
00213  * @retval Err error code.
00214  **/
00215 UInt16 PinGetInputMode(UInt16 refnum)
00216                 SYS_TRAP(kPinLibTrapPinGetInputMode);
00217
00218 /**
00219  * @brief
00220  *
00221  * @param refnum:   IN:
00222  * @param inputMode:    IN:
00223  * @retval Err error code.
00224  **/
00225 void PinSetInputMode(UInt16 refnum, UInt16 inputMode)
00226                 SYS_TRAP(kPinLibTrapPinSetInputMode);
00227
00228
00229
00230 #ifdef __cplusplus
00231 }
00232 #endif
00233
00234
00235 #endif  //__PINLIB_H__
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:54 2008 for Palm API Guide


Header Files » Incs » 68k » system

PalmPower.h

Go to the documentation of this file.
00001 /******************************************************************************
00002  * Copyright (c) 2005 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  *****************************************************************************/
00005 /**
00006  *@ingroup System
00007  *
00008  */
00009
00010 /**
00011  * @file    PalmPower.h
00012  * @version 1.0
00013  *
00014  * @brief  Battery notification.
00015  *
00016  *     This contains the Battery state notification
00017  *         Any application can register for the notification to be notified
00018  *     when the of the various battery states
00019  *
00020  *
00021  * <hr>
00022  */
00023
00024
00025 #ifndef __PalmPower_H__
00026 #define __PalmPower_H__
00027
00028
00029
00030 /**
00031  * @name Battery state notification
00032  *
00033  */
00034 /*@{*/
00035 #define kPwrBatteryStateBroadcaster     'bsbc'      /**< Battery notification broadcaster. */
00036 #define kPwrBatteryStateNotifyEvent     'bsnt'      /**< Battery notification notifyType */
00037 /*@}*/
00038
00039 #endif // __PalmPower_H__
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:54 2008 for Palm API Guide


Header Files » Incs » 68k » system

PalmResources.h

Go to the documentation of this file.
00001 /******************************************************************************
00002  * Copyright (c) 2005 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  *****************************************************************************/
00005 /**
00006  *@ingroup System
00007  *
00008  */
00009
00010 /**
00011  * file     PalmResources.h
00012  * @version 1.0
00013  *
00014  * @brief  Temporary shim to the new filename and location.
00015  *
00016  *
00017  * <hr>
00018  */
00019
00020
00021 #ifndef __PALMRESOURCES_H__
00022 #define __PALMRESOURCES_H__
00023
00024 #include <Common/System/palmOneResources.h>
00025
00026
00027
00028 #endif // __PALMRESOURCES_H__
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:54 2008 for Palm API Guide


Header Files » Incs » common » system

PalmShimSettings.h

Go to the documentation of this file.
00001 /******************************************************************************
00002  * Copyright (c) 2005 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  *****************************************************************************/
00005 /**
00006  *@ingroup System
00007  *
00008  */
00009
00010 /**
00011  * @file    PalmShimSettings.h
00012  * @version 1.0
00013  * @date    10/28/2002
00014  *
00015  * @brief Shim settings for NetIFSettingGet()/Set().
00016  *
00017  * <hr>
00018  */
00019
00020 #ifndef PALM_SHIM_SETTINGS_H_
00021 #define PALM_SHIM_SETTINGS_H_
00022
00023 /**
00024  * NetIFSettings for the shim.
00025  * Used by NetIFSettingGet()/Set().
00026  */
00027 typedef enum {
00028
00029   netIFSettingShimUp = 0xA000,    /**< True if shim is up; read-only. */
00030   netIFSettingShimHideProgress,   /**< Defaults to false. */
00031   netIFSettingShimConfig,         /**< Mechanism for passing data between app & proto tasks. */
00032   netIFSettingShimLog,            /**< Copy the shim log; read-only. */
00033   netIFSettingShimCreator,        /**< Creator ID of shim; UInt32; read-only. */
00034   netIFSettingShimVersion,        /**< Version of the shim; Char[32]; read-only. */
00035   netIFSettingShimLibVersion,     /**< Version of the shim library; UInt32; little-endian; read-only; see sysMakeROMVersion() macro */
00036   netIFSettingShimVPNStart,       /**< Connect VPN */
00037   netIFSettingShimVPNStop         /**< Disconnect VPN */
00038 } NetIFSettingShimEnum;
00039
00040 #define vpnLibEventNotification 'pVPN'      /**<        */
00041
00042 /**
00043  * IFMediaEvent notifications types
00044  */
00045 enum VPNLibEventNotificationTypeEnum_
00046   {
00047     vpnConnectionUp = 1,            /**<        */
00048     vpnConnectionDown           /**<        */
00049   };
00050
00051 typedef UInt8 VPNLibEventNotificationTypeEnum;  /**<        */
00052
00053 /**
00054  * Notification structure sent in vpnLibEventNotification
00055  */
00056 typedef struct vpnNotifyVPNLibTag
00057   {
00058     VPNLibEventNotificationTypeEnum eType;  /**<        */
00059     UInt8           padding1;       /**<        */
00060     UInt16          padding2;       /**<        */
00061     UInt32          ifCreator;      /**< interface creator */
00062     UInt16          ifInstance;     /**< interface instance */
00063     UInt16          padding3;       /**<        */
00064   }
00065 VPNNotifyEventType;
00066
00067 #endif // PALM_SHIM_SETTINGS_H_
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:54 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » audio

PalmSoundCustomCtrl.h

Go to the documentation of this file.
00001 /******************************************************************************
00002  * Copyright (c) 2004 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  *****************************************************************************/
00005 /**
00006  * @ingroup Sound
00007  *
00008  */
00009
00010 /**
00011  *
00012  * @file    PalmSoundCustomCtrl.h
00013  *
00014  * @brief   Public 68K include file for the Sound Manager custom controls for the
00015  *          IMA_ADPCM codec for Treo 600 and Treo 650 smartphones.
00016  *
00017  * This header file and associated header files support the specific sound
00018  * functionality of the Treo smartphones. You should use the Palm OS Sound
00019  * Manager APIs for most of your work.
00020  *
00021  * Notes:
00022  * How to use the IMA_ADPCM code custom control:
00023  *
00024  * When you create a stream, make sure you set the format to sndFormatIMA_ADPCM and
00025  * that the type is set to 0.
00026  *
00027  * Then use the custom control to set the block align  paramter:
00028  *
00029  * SndCodecCustomControlType ct;
00030  * UInt16 blockAlign= Swap16(blockAlign); // This needs to be in little endian
00031  * ct.apiCreator    = Swap32(codecDriverIMAADPCM);
00032  * ct.apiSelector   = Swap32(codecIMAADPCMSetBlockSize);
00033  * ct.valueP        = (void*)Swap32(&blockAlign);
00034  * ct.valueLenP     = NULL;
00035  * err = SndStreamDeviceControl(streamRef, sndControlCodecCustomControl, &ct, sizeof(ct));
00036  *
00037  * The calling application should always load this library with
00038  * SysLibLoad() before use, even if it is already open by another
00039  * application(ie, SysLibFind() returns a valid refnum). When
00040  * the application is done with the library, it should be
00041  * unloaded with SysLibRemove(). We do this because there is
00042  * no good way to synchronize loading and unloading of libraries
00043  * among multiple applications. It also greatly simplifies internal
00044  * synchronization.
00045  */
00046
00047 #ifndef __PALMSOUNDCUSTOMCTRL_H__
00048 #define __PALMSOUNDCUSTOMCTRL_H__
00049
00050 /**
00051  * @name Custom Control for the IMA_ADPCM codec
00052  *
00053  */
00054 /*@{*/
00055 #define codecDriverIMAADPCM                 'APCM'  /**< IMA ADPCM codec driver. */
00056 #define codecIMAADPCMSetBlockSize           0x0001  /**< IMA ADPCM block size set command. */
00057 /*@}*/
00058
00059 /**
00060  * IMA_ADPCM codec Custom Control type
00061  *
00062  */
00063 enum {
00064     sndControlCodecCustomControl = 12   /**< Param is a SndCodecCustomControlType*. */
00065 };
00066
00067 /**
00068  * @brief Holds Custom Control type information for the Extended Sound Manager.
00069  *
00070  * This structure is used to set/get values specific to a codec.
00071  * Note that if this custom control comes from a 68K app, it's the responsibility
00072  * of the 68K app to flip and align the fields of the structure correctly. The fields
00073  * are defined as being in little-endian format.
00074  */
00075 typedef struct {
00076     UInt32  apiCreator;     /**<Codec creator. (codecDriverIMAADPCM...) */
00077     UInt32  apiSelector;    /**<Codec selector. (codecIMAADPCMSetBlockSize...) */
00078     void    *valueP;        /**<Pointer to the parameters to be passed to the codec. */
00079     UInt16  *valueLenP;     /**<Size of the parameters to be passed to the codec. */
00080 } SndCodecCustomControlType;
00081
00082
00083 #endif // __PALMSOUNDCUSTOMCTRL_H__
00084
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:54 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » audio

PalmSoundMgrExt.h

Go to the documentation of this file.
00001 /******************************************************************************
00002  * Copyright (c) 2004 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  *****************************************************************************/
00005 /**
00006  * @ingroup Sound
00007  *
00008  */
00009
00010 /**
00011  * @file    PalmSoundMgrExt.h
00012  *
00013  * @brief   Public 68K include file for the Extended Sound Manager.
00014  *
00015  * Notes:
00016  * You should check to see if you are using a version of Palm OS SDK that
00017  * implements the Extended Sound API.  For lack of a better check,
00018  * look for the earlier of the system traps and hope that the rest is
00019  * likewise defined.
00020  *
00021  * The calling application should always load this library with
00022  * SysLibLoad() before use, even if it is already open by another
00023  * application(ie, SysLibFind() returns a valid refnum). When
00024  * the application is done with the library, it should be
00025  * unloaded with SysLibRemove(). We do this because there is
00026  * no good way to synchronize loading and unloading of libraries
00027  * among multiple applications. It also greatly simplifies internal
00028  * synchronization.
00029  */
00030
00031
00032 #ifndef __SOUNDMGREXT_H__
00033 #define __SOUNDMGREXT_H__
00034
00035 /***********************************************************************
00036  * Palm OS common definitions
00037  ***********************************************************************/
00038 #include <SoundMgr.h>
00039
00040 #ifndef sysTrapSndStreamCreateExtended
00041
00042 /**
00043  * @name Extended Sound library traps
00044  *
00045  */
00046 /*@{*/
00047 #ifndef sysTrapSndStreamCreateExtended
00048 #define sysTrapSndStreamCreateExtended              0xA466
00049 #endif
00050
00051 #ifndef sysTrapSndStreamDeviceControl
00052 #define sysTrapSndStreamDeviceControl               0xA467
00053 #endif
00054 /*@}*/
00055
00056 /**
00057  * Sound format type
00058  */
00059 enum {
00060     sndFormatPCM        = 0,            /**<Raw PCM (Pulse Code Modulation), (attributes defined by type parameter). */
00061     sndFormatIMA_ADPCM  = 'APCM',       /**<IMA ADPCM (Interactive Multimedia Association Adaptive Differential PCM). */
00062     sndFormatDVI_ADPCM  = 'DPCM',       /**<Intel/MS/DVI ADPCM. */
00063     sndFormatMP3        = 'MPG3',       /**<Moving Picture Experts Group, Audio Layer III (MPEG-1 and MPEG-2 depending on bit-rate). */
00064     sndFormatAAC        = 'DAAC',       /**<Dolby Advanced Audio Coding. */
00065     sndFormatOGG        = 'OGGV'        /**<Ogg Vorbis. */
00066 };
00067
00068 /** Holds sound format type. */
00069 typedef UInt32 SndFormatType;
00070
00071
00072 /// Extended Sound Manager callback.
00073 ///
00074 /// @param userDataP:   IN: Pointer to the user data passed in SndStreamCreateExtended.
00075 /// @param streamRef:   IN: Opaque reference to the stream returned by SndStreamCreateExtended.
00076 /// @param bufferP:     IN: Data buffer.
00077 /// @param bufferSizeP: IN: Pointer to the buffer size in bytes. This MUST be set before returning to the number of bytes read or written.
00078 /// @retval Err Error code.
00079 typedef Err (*SndStreamVariableBufferCallback) (
00080     void            *userDataP,
00081     SndStreamRef    streamRef,
00082     void            *bufferP,
00083     UInt32          *bufferSizeP
00084 );
00085
00086
00087 #ifdef __cplusplus
00088 extern "C" {
00089 #endif
00090
00091 /// Creates a sound stream using the Extended Sound API.
00092 ///
00093 /// @param streamP:     IN: Receives the opaque reference to the stream.
00094 /// @param mode:        IN: Direction of the sream, either sndInput or sndOutput.
00095 /// @param format:      IN: Sound format. (sndFormatPCM...)
00096 /// @param sampleRate:  IN: Sampling rate, in frames-per-second. (8000, 44100,...)
00097 /// @param sampleType:  IN: Sample size and endianness of the data. (sndInt16...)
00098 /// @param width:       IN: The number of channels: sndMono for one channel, sndStrereo for two.
00099 /// @param sndCallback: IN: A callback function that gets called when another buffer for sound is needed.
00100 /// @param userDataP:   IN: Caller-defined data that gets passed to SndStreamVariableBufferCallback.
00101 /// @param bufferSize:  IN: Preferred size in bytes for the buffers that are passed to sndCallback.
00102 /// @param armNative:   IN: Pass true if the callback function is written in ARM-native code. If it’s 68K, pass false.
00103 /// @retval Err Error code.
00104 extern Err SndStreamCreateExtended(
00105         SndStreamRef                    *streamP,
00106         SndStreamMode                   mode,
00107         SndFormatType                   format,
00108         UInt32                          sampleRate,
00109         SndSampleType                   sampleType,
00110         SndStreamWidth                  width,
00111         SndStreamVariableBufferCallback sndCallback,
00112         void                            *userDataP,
00113         UInt32                          bufferSize,
00114         Boolean                         armNative)
00115             SYS_TRAP(sysTrapSndStreamCreateExtended);
00116
00117 /// An extended function to handle new or device specific custom sound controls.
00118 ///
00119 /// @param stream:  IN: Opaque reference to the stream returned by SndStreamCreateExtended.
00120 /// @param cmd:     IN: One of the defined custom control enums, such as sndControlCodecCustomControl.
00121 /// @param paramP:  IN: Pointer to data specific to the specific custom control defined by cmd.
00122 /// @param size:    IN: Size in bytes of the structure passed in paramP.
00123 /// @retval Err Error code.
00124 extern Err SndStreamDeviceControl(SndStreamRef stream, Int32 cmd, void *paramP, Int32 size)
00125                             SYS_TRAP(sysTrapSndStreamDeviceControl);
00126
00127 #ifdef __cplusplus
00128 }
00129 #endif
00130
00131 #endif /* sysTrapSndStreamCreateExtended - 20 aug 2003 */
00132
00133 #endif /* __SOUNDMGREXT_H__ */
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:54 2008 for Palm API Guide


Header Files » Incs » 68k » system

PalmStatusBar.h

Go to the documentation of this file.
00001 /******************************************************************************
00002  * Copyright (c) 2005 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  *****************************************************************************/
00005 /**
00006  * @ingroup StatusBar
00007  *
00008  */
00009
00010 /**
00011  * file     PalmStatusBar.h
00012  * @version 1.0
00013  * @date    03/03/2003
00014  *
00015  * @brief  Public API for the Status Bar Library
00016  *
00017  *
00018  * <hr>
00019  */
00020
00021
00022 #ifndef __STATUSBARMGRLIB_H__
00023 #define __STATUSBARMGRLIB_H__
00024
00025 #include <PalmTypes.h>
00026 #include <LibTraps.h>
00027
00028 /**
00029  * @name Library type and creator
00030  *
00031  */
00032 /*@{*/
00033 #define statLibName     "StatusBarMgrLib"   /**         */
00034 #define statLibCreator      'sBar'          /**         */
00035 #define statLibType     sysFileTLibrary     /**         */
00036 #define statFtrNumVersion   (0)         /**         */
00037 /*@}*/
00038
00039 /**
00040  * @name Status Bar Errors
00041  *
00042  */
00043 /*@{*/
00044 #define statErrorClass      (appErrorClass  | 0x0900)   /**         */
00045 #define statErrNoStatusBar  (statErrorClass | 1)        /**         */
00046 #define statErrInvalidSelector  (statErrorClass | 2)        /**         */
00047 #define statErrInputWindowOpen  (statErrorClass | 3)        /**         */
00048 #define statErrBadParam     (statErrorClass | 101)      /**         */
00049 #define statErrInvalidState (statErrorClass | 102)      /**         */
00050 /*@}*/
00051
00052 /**
00053  * Status Bar Attributes
00054  **/
00055 typedef enum StatAttrTypeTag
00056 {
00057     statAttrExists     = 0,         /**< device supports the status bar */
00058     statAttrBarVisible,             /**< status bar is visible */
00059     statAttrDimension               /**< bounds of status bar window */
00060 } StatAttrType;
00061
00062 /**
00063  * @name Library Traps
00064  *
00065  */
00066 /*@{*/
00067 #define kStatusBarMgrLibTrapOpen    sysLibTrapOpen      /**         */
00068 #define kStatusBarMgrLibTrapClose   sysLibTrapClose     /**         */
00069 #define kStatusBarMgrLibGetAttribute    (sysLibTrapCustom)  /**         */
00070 #define kStatusBarMgrLibHide        (sysLibTrapCustom + 1)  /**         */
00071 #define kStatusBarMgrLibShow        (sysLibTrapCustom + 2)  /**         */
00072 /*@}*/
00073
00074 /**
00075  * Prototypes
00076  **/
00077 #ifdef __cplusplus
00078 extern "C" {
00079 #endif
00080
00081 /**
00082  * @brief
00083  *
00084  * @param refnum:   IN:
00085  * @retval Err error code.
00086  **/
00087 Err StatLibOpen(UInt16 refnum)
00088                 SYS_TRAP(kStatusBarMgrLibTrapOpen);
00089
00090 /**
00091  * @brief
00092  *
00093  * @param refnum:   IN:
00094  * @retval Err error code.
00095  **/
00096 Err StatLibClose(UInt16 refnum)
00097                 SYS_TRAP(kStatusBarMgrLibTrapClose);
00098
00099 /**
00100  * @brief
00101  *
00102  * @param refnum:   IN:
00103  * @param selector: IN:
00104  * @param *dataP:   IN:
00105  * @retval Err error code.
00106  **/
00107 Err StatGetAttribute(UInt16 refnum, StatAttrType selector, UInt32 *dataP)
00108                 SYS_TRAP(kStatusBarMgrLibGetAttribute);
00109
00110 /**
00111  * @brief
00112  *
00113  * @param refnum:   IN:
00114  * @retval Err error code.
00115  **/
00116 Err StatHide(UInt16 refnum)
00117                 SYS_TRAP(kStatusBarMgrLibHide);
00118
00119 /**
00120  * @brief
00121  *
00122  * @param refnum:   IN:
00123  * @retval Err error code.
00124  **/
00125 Err StatShow(UInt16 refnum)
00126                 SYS_TRAP(kStatusBarMgrLibShow);
00127
00128 #ifdef __cplusplus
00129 }
00130 #endif
00131
00132 #endif  //__STATUSBARMGRLIB_H__
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:54 2008 for Palm API Guide


Header Files » Incs » 68k » system

PalmVMLaunch.h

Go to the documentation of this file.
00001 /******************************************************************************
00002  * Copyright (c) 2005 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  *****************************************************************************/
00005 /**
00006  * @ingroup Versamail
00007  *
00008  */
00009
00010 /**
00011  * @file    PalmVMLaunch.h
00012  * @version 1.0
00013  *
00014  * @brief  Defines APIs and structures for launching VersaMail to add a new message
00015  *     from an application
00016  *
00017  *
00018  * <hr>
00019  */
00020
00021
00022 #ifndef __PALMVMLAUNCH_H__
00023 #define __PALMVMLAUNCH_H__
00024
00025 #include <PalmCompatibility.h>
00026 #include <AppLaunchCmd.h>  /**< Declares MailAddRecordParamsType */
00027
00028
00029 /**
00030  * @name Launch Codes
00031  *
00032  */
00033 /*@{*/
00034 #define MMPRO_LAUNCH_CODE           (sysAppLaunchCmdCustomBase + 2)     /**< Launch code for launching VersaMail through SysUIAppSwitch.*/
00035 #define MMPRO_ADD_MESSAGE_WITH_ATTACHMENT   (sysAppLaunchCmdCustomBase + 16)    /**< Launch for adding a message to VersaMail with attachments, more powerful than sysAppLaunchCmdAddRecord */
00036 /*@}*/
00037
00038 /**
00039  * Typedefs and constants used in VM Launch library
00040  **/
00041
00042 /**
00043  * @name
00044  *
00045  */
00046 /*@{*/
00047 #define MM_MAX_ATTACHMENTS      10      /**< Maximum no. of attach */
00048 /*@}*/
00049
00050 /**
00051  * @brief Structure for adding attachments in MMProLaunchStruct
00052  */
00053 typedef struct
00054 {
00055     int type;           /**< Type of attachment */
00056     char* attachName;       /**< Name of attachment */
00057     char* attachment;           /**< Pointer to attachment data*/
00058     unsigned long aSize;        /**< Size of attachment */
00059 } MMProAttachStruct;
00060
00061 /**
00062  * @brief Structure to add a message + attachment passed with MMPRO_LAUNCH_CODE
00063  */
00064 typedef struct
00065 {
00066     Boolean interactive;        /**< Not used */
00067     char* to;           /**< To field */
00068     char* cc;           /**< cc field */
00069     char* bcc;          /**< bcc field */
00070     char* subject;          /**< subject field */
00071     char* body;         /**< body field */
00072     int numAttach;          /**< Number of attachments */
00073     MMProAttachStruct* attachments; /**<Array of attachment(s) */
00074 }MMProLaunchStruct;
00075
00076 /**
00077  * @brief Data links used in an attachment, used in MMProAttachStruct2
00078  */
00079 typedef struct
00080 {
00081     CharPtr data;       /**< Pointer to the data link */
00082     ULong size;         /**< Size of data link */
00083 } MMProAttachDataLinks;
00084
00085 /**
00086  * @brief Structure for adding attachments in MMProLaunchStruct2
00087  */
00088 typedef struct
00089 {
00090     int type;           /**< Type of attachment */
00091     char* attachName;       /**< Name of attachment */
00092     char* attachment;       /**< Pointer to attachment data*/
00093     unsigned long aSize;        /**< Size of attachment */
00094     UInt numDataLinks;      /**< No. of datalinks */
00095     MMProAttachDataLinks *moreData; /**< Array of data link(s) */
00096 } MMProAttachStruct2;
00097
00098 /**
00099  * @brief  Structure to add a message + attachment passed with MMPRO_LAUNCH_CODE
00100  */
00101 typedef struct
00102 {
00103     Boolean interactive;
00104     char* to;           /**< To field */
00105     char* cc;           /**< cc field */
00106     char* bcc;          /**< bcc field */
00107     char* subject;          /**< subject field */
00108     char* body;         /**< body field */
00109     int numAttach;          /**< Number of attachments */
00110     MMProAttachStruct2* attachments; /**< Pointer to attachment array */
00111 }MMProLaunchStruct2;
00112
00113
00114 /**
00115  * @brief  Structure to add attachment in MailAddRecordParamsTypePlus
00116  */
00117 typedef struct
00118 {
00119     char*   attachType;         /**< Mime Type of attachment */
00120     char*   attachDescription;  /**< Attachment description*/
00121     char*   attachFileName;     /**< FileName of attachment */
00122     union
00123     {
00124         char*   attachData;     /**<Pointer to attachment data */
00125         LocalID attachDBID; /**<Currently not supported */
00126     } data;
00127
00128     UInt32      attachSize;     /**< Size of attachment */
00129
00130 }   MailAddRecordAttachment;
00131
00132 /**
00133  * @brief  Structure to add a message + attachment passed with MMPRO_ADD_MESSAGE_WITH_ATTACHMENT
00134  *     Categories & MailAddRecordParamsType are defined in AppLaunchCmd.h.
00135  *
00136  */
00137 typedef struct
00138 {
00139     MailAddRecordParamsType     mainParams; /**< Email data */
00140     UInt8               category;   /**< Mail Category usually Oubox / Draft */
00141     MailAddRecordAttachment     attachments[MM_MAX_ATTACHMENTS];    /**< Pointer to array of attachments */
00142     Int16               numAttachments; /**< No. of attachments */
00143
00144 } MailAddRecordParamsTypePlus;
00145
00146
00147 #endif
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:55 2008 for Palm API Guide


Header Files » Incs » 68k » system

PalmVMPlugin.h

Go to the documentation of this file.
00001 /******************************************************************************
00002  * Copyright (c) 2005 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  *****************************************************************************/
00005 /**
00006  * @ingroup Versamail
00007  *
00008  */
00009
00010 /**
00011  * @file    PalmVMPlugin.h
00012  * @version 1.0
00013  *
00014  * @brief  Defines APIs and structures for the VersaMail Plugin Service which
00015  *     lets users write plugins to view/send attachments
00016  *
00017  *
00018  * <hr>
00019  */
00020
00021
00022 #ifndef __PALMVMPLUGIN_H__
00023 #define __PALMVMPLUGIN_H__
00024
00025
00026 #include <PalmCompatibility.h>
00027
00028
00029 /**
00030  * @name Application Launch Codes
00031  *
00032  */
00033 /*@{*/
00034 #define MMPRO_PLUGIN_LAUNCHCODE         (sysAppLaunchCmdCustomBase + 2)     /**< Plugin receives data from VersaMail and do whatever it deems appropriate with it. */
00035 #define MMPRO_PLUGIN_RECEIVE_LAUNCHCODE     MMPRO_PLUGIN_LAUNCHCODE         /**<        */
00036
00037 #define MMPRO_PLUGIN_QUERY_LAUNCHCODE       (sysAppLaunchCmdCustomBase + 3)     /**< Plugin should return a list of attachments for the user to select from. */
00038 #define MMPRO_PLUGIN_SEND_LAUNCHCODE        (sysAppLaunchCmdCustomBase + 4)     /**< The plugin should return the name of ? selected attachment for sending */
00039 #define MMPRO_PLUGIN_EXTENDED_QUERY_LAUNCHCODE  (sysAppLaunchCmdCustomBase + 5)     /**< Plugin should support selection of attachment and should return */
00040 #define MMPRO_PLUGIN_GET_INFO_LAUNCHCODE    (sysAppLaunchCmdCustomBase + 8)     /**< VersaMail queries the plugin to get the details of Plugin information */
00041
00042 /*@}*/
00043
00044
00045 #define ATTYPE_MAX_NAME_LEN 32  /**< Maximum array size for name of an attachment in listSendNames pointer */
00046
00047
00048
00049 /**
00050  * @brief PluginInfo is specifies what plugin information is needed.
00051  */
00052 typedef enum {
00053
00054     plugin_sendInfo,    /**< Provides info about what can be passed as an email attachment. */
00055     plugin_receiveInfo,     /**< Provides info about what file types can be viewed. */
00056     plugin_allInfo      /**< Provides sendInfo and receiveInfo. */
00057
00058 } PluginInfo;
00059
00060 /**
00061  * @brief Structure used for launch code MMPRO_PLUGIN_GET_INFO_LAUNCHCODE.
00062  */
00063 typedef struct _pluginGetInfoParams
00064 {
00065     PluginInfo  getInfo;        /**< [in]  what plugin information needed. */
00066
00067     UInt32      version;        /**< [out] plugin version. */
00068     Boolean     supportsSending;    /**< [out] can provide data to be passed as an email attachment.*/
00069     Boolean     supportsReceiving;  /**< [out] can view files passed to it.*/
00070
00071     char**      listSendNames;      /**< [out] list of names of the types. (suitable for listing in popup)*/
00072
00073     UInt16      numSendTypes;       /**< [out] the number of types it can send (each one should appear in popup)*/
00074     Int16       numReceiveTypes;    /**< [out] the number of types it can receive */
00075
00076     char**      listSendFileExt;    /**< [out] list of supported file extensions to Send.*/
00077     char**      listReceiveFileExt; /**< [out] list of supported file extensions it can read. */
00078     UInt32*     listMaxSizeExt;     /**< lout] list of max file size supported for each file ext. */
00079
00080     char**      listSendMIMEtypes;  /**< [out] list of supported MIME types to Send. */
00081     char**      listReceiveMIMEtypes;   /**< [out] list of supported MIME types it can read. */
00082     UInt32*     listMaxSizeMime;    /**< lout] list of max file size supported for each MIME type. */
00083     UInt32      ret;                /**< [out] return code for error handling and special cases; */
00084     Char Unused[50];                /**< unused space for future releases */
00085
00086 } pluginGetInfoParams;
00087
00088
00089 /**
00090  * @brief Structure used for datalinks while sending /rcving data.
00091  */
00092 typedef struct _dataLinks
00093 {
00094     CharPtr data;       /**< pointer to data */
00095     ULong size;         /**< size of data */
00096
00097 } dataLinks;
00098
00099
00100 /**
00101  * @brief Structure used for launch code MMPRO_PLUGIN_RECEIVE_LAUNCHCODE.
00102  */
00103 typedef struct _pluginParams
00104 {
00105     ULong version;          /**< [in] plugin version */
00106     Char *MIMEtype;         /**< [in] attachment MIME type */
00107     Char *fileExt;          /**< [in] attachment file extention */
00108     ULong size;         /**< [in] size of data */
00109     CharPtr fname;          /**< [in] filename of attachment */
00110     CharPtr data;           /**< [in] the data */
00111     DmOpenRef db;           /**< [in] reference to open database for large memory allocations */
00112     UInt numDataLinks;          /**< [in] number of data links */
00113     dataLinks *moreData;        /**< [in] ptr to data links */
00114     UInt32 ret;                 /**< [out] return code for error handling and special cases;*/
00115     Char Unused[50];            /**< unused space for future releases */
00116
00117 }pluginParams;
00118
00119
00120
00121 /**
00122  * @brief Structure used for launch code MMPRO_PLUGIN_QUERY_LAUNCHCODE.
00123  */
00124 typedef struct _pluginQueryParams
00125 {
00126     Char *fileExt;              /**< [in] file extention of list of files requested */
00127     Char *MIMEtype;         /**< [in] MIME type of list of files requested */
00128     DmOpenRef db;           /**< [in]reference to open database for large memory allocations */
00129     int numItems;           /**< [out] number of items of this type */
00130     UInt32 *itemSizes;      /**< [out] size of items */
00131     char** listItems;       /**< [out] the items */
00132     void**  itemDescriptors;    /**< [out] private descriptors defined/recognized by plugin. This memory will be freed by VersaMail  */
00133     UInt32 ret;             /**< [out] return code for error handling and special cases; */
00134     Char Unused[50];            /**< unused space for future releases */
00135
00136 }pluginQueryParams;
00137
00138
00139 /**
00140  * @brief Structure used for launch code MMPRO_PLUGIN_SEND_LAUNCHCODE.
00141  */
00142 typedef struct _pluginSendParams
00143 {
00144     Char *MIMEtype;             /**< [in] attachment MIME type */
00145     Char *fileExt;              /**< [in] attachment file extention */
00146
00147     DmOpenRef db;           /**< [in]reference to open database for large memory allocations */
00148     int selectedItem;       /**< [in] item number that was selected */
00149     void *selectedDescriptor;   /**< [in] descriptor of item that was selected */
00150     char* item;         /**< [in] the item selected */
00151     char* name;         /**< [out] name of the attachment file */
00152     char* ptr;          /**< [out] attachment rendered and ready to send! */
00153                     /**< this memory will be freed by MMPRO */
00154     ULong size;         /**< [out] size of attachment above */
00155
00156     UInt numDataLinks;      /**< [out] number of data links */
00157     dataLinks *moreData;        /**< [out] ptr to data links */
00158     UInt32 ret;                 /**< [out] return code for error handling and special cases; */
00159     Char Unused[50];            /**< unused space for future releases */
00160
00161 }pluginSendParams;
00162
00163
00164 /**
00165  * @brief Structure used for launch code MMPRO_PLUGIN_EXTENDED_QUERY_LAUNCHCODE.
00166  */
00167 typedef struct _pluginExtendedQueryParams
00168 {
00169     int type;           /**< [in] attachment type  */
00170     Char *MIMEtype;         /**< [in] attachment MIME type */
00171     Char *fileExt;          /**< [in] attachment file extention */
00172
00173     DmOpenRef db;           /**< [in]reference to open database for large memory allocations */
00174     Boolean supported;          /**< [out] we support this extension */
00175     int numItems;           /**< [out] number of items selected */
00176     char** listNames;       /**< [out] name of the attachment files */
00177     char** listPtrs;        /**< [out] attachments renders and ready to send */
00178     ULong** size;           /**< [out] size for each attachment */
00179     UInt32 ret;                 /**< [out] return code for error handling and special cases; */
00180     Char Unused[50];            /**< unused space for future releases */
00181
00182 }pluginExtendedQueryParams;
00183
00184 #endif // PALMVMPLUGIN_H_
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:55 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » network

PalmVPPI.h

Go to the documentation of this file.
00001 /******************************************************************************
00002  * Copyright (c) 2004 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  *****************************************************************************/
00005 /**
00006  * @ingroup Network
00007  */
00008
00009 /**
00010  * @file    PalmVPPI.h
00011  * @version 1.0
00012  *
00013  * @brief This is the API for VPN panel plug-ins (VPPIs).
00014  *
00015  * The VPN panel allows the user to manage their VPN accounts. Each plug-in provides support for a
00016  * specific VPN protocol such as PPTP or IPSec. A VPPI provides access to
00017  * the user interface of a VPN client. An NPPI (Network panel plug-in)
00018  * provides the underlying implementation as well as an alternate user
00019  * interface.
00020  *
00021  */
00022
00023 #ifndef _PALM_VPPI_H_
00024 #define _PALM_VPPI_H_
00025
00026 /** Database type for VPN panel plug-ins. */
00027 #define sysFileTVPNPanelPlugin      'Vppi'
00028
00029 /** Account name maximum length. */
00030 #define kMaxVPNAccountNameLength    31
00031
00032 /** @brief VPN Account structure. */
00033 typedef struct
00034 {
00035     UInt32  vppiCreator;    /**< Creator ID of the VPPI that "owns" the account. */
00036     UInt32  accountID;      /**< Arbitrary 32-bit ID used by the VPI to identify the account. */
00037     Char    accountName[kMaxVPNAccountNameLength + 1]; /**< User-specified account name. */
00038 } VPNAccountType;
00039
00040
00041 /** Launch code used by the VPN Panel to get the account list. */
00042 #define sysVPPILaunchCmdGetAccounts     sysAppLaunchCmdCustomBase   // 0x8000
00043
00044 /** @brief Structure used by the VPN Panel to query the account from a VPPI. */
00045 typedef struct
00046 {
00047     UInt32          numAccounts;    /**< Number of accounts. */
00048     VPNAccountType* accounts;       /**< Array of accounts. */
00049     Err             err;            /**< Error set by the VPPI before returning the account list. */
00050 } SysVPPILaunchCmdGetAccountsType;
00051
00052
00053 /** Launch code used by the VPN Panel to edit an account. */
00054 #define sysVPPILaunchCmdEditAccount     (sysAppLaunchCmdCustomBase + 1)   // 0x8001
00055
00056 /** @brief Structure used by the VPN Panel to edit an account. */
00057 typedef struct
00058 {
00059     Boolean        useWizardUI;     /**< Whether to show Previous & Done buttons instead of OK & Cancel buttons. */
00060     VPNAccountType account;         /**< Account edited or created. */
00061     Err            err;             /**< Return error. */
00062     Boolean        useSavedAccount; /**< Whether the account information is temporary (for saved state) or permanent. */
00063     Boolean        dirtyBit;        /**< Whether any account settings have been changed. */
00064 } SysVPPILaunchCmdEditAccountType;
00065
00066
00067 /** Launch code used by the VPN Panel to delete an account. */
00068 #define sysVPPILaunchCmdDeleteAccount       (sysAppLaunchCmdCustomBase + 2)   // 0x8002
00069
00070 /** @brief Structure used by the VPN Panel to delete an account. */
00071 typedef struct
00072 {
00073     VPNAccountType account; /**< Account to delete. */
00074     Err            err;     /**< Error code. */
00075 } SysVPPILaunchCmdDeleteAccountType;
00076
00077
00078 /** Launch code used by the VPN Panel to set the current account. */
00079 #define sysVPPILaunchCmdSetCurrentAccount   (sysAppLaunchCmdCustomBase + 3)   // 0x8003
00080
00081 /** @brief Structure used by the VPN Panel to set the current account. */
00082 typedef struct
00083 {
00084     VPNAccountType account; /**< Account to set as current account. */
00085     Err            err;     /**< Error code. */
00086 } SysVPPILaunchCmdSetCurrentAccountType;
00087
00088
00089 /** Launch code used by the VPN Panel to request the VPPI to display a dialog. */
00090 #define sysVPPILaunchCmdPromptAndConfigure      (sysAppLaunchCmdCustomBase + 4)   // 0x8004
00091
00092 /** @brief Structure used by the VPN Panel to request the VPPI to display a dialog. */
00093 typedef struct
00094 {
00095     UInt32   origCreator;   /**< Creator that launched the prompt dialog (in). */
00096     UInt32   origInstance;  /**< Instance that laucnhed the prompt dialog (in). */
00097     Err      errOut;        /**< Error code (out). */
00098 } SysVPPILaunchCmdPromptAndConfigureType;
00099
00100
00101 /** Launch code used by the VPN Panel to show the progess dialog. */
00102 #define sysVPPILaunchCmdProgressPaint   (sysAppLaunchCmdCustomBase + 5)   // 0x8005
00103
00104 /** @brief Structure used by the VPN Panel to show the progess dialog. */
00105 typedef struct
00106 {
00107     UInt32        stage;        /**< Stage calue sent by the VPN Shim to the VPPI (in). */
00108     RectangleType clientRect;   /**< Rectangle in which the progress dialog box is displayed (in). */
00109     Err           errOut;       /**< Error code (out). */
00110 } SysVPPILaunchCmdProgressPaintType;
00111
00112
00113 /** Launch code used by the VPN Panel to show the error dialog. */
00114 #define sysVPPILaunchCmdErrorDialog     (sysAppLaunchCmdCustomBase + 6)   // 0x8006
00115
00116 /** @brief Structure used by the VPN Panel to show the error dialog. */
00117 typedef struct
00118 {
00119     UInt32        error;        /**< Error value sent by the VPN Shim (in). */
00120     Err           errOut;       /**< Error code (out). */
00121 } SysVPPILaunchCmdErrorDialogType;
00122
00123
00124 /** Launch code used by the VPN Panel to clear the password cache. */
00125 #define sysVPPILaunchCmdClearPWCache    (sysAppLaunchCmdCustomBase + 7)   // 0x8007
00126
00127 /** @brief Structure used by the VPN Panel to clear the password cache. */
00128 typedef struct
00129 {
00130     Err           errOut;       /**< Error code. */
00131 } SysVPPILaunchCmdClearPWCacheType;
00132
00133
00134 /** Launch code used by the VPN Panel to determine is the VPPI will prompt for password. */
00135 #define sysVPPILaunchCmdWillPWPrompt    (sysAppLaunchCmdCustomBase + 8)   // 0x8008
00136
00137 /** @brief Structure used by the VPN Panel to determine is the VPPI will prompt for password. */
00138 typedef struct
00139 {
00140     UInt32        secsFromNow;  /**< Seconds from now at which the VPPI will prompt for password (in). */
00141     Err           errOut;       /**< Error code (out). */
00142 } SysVPPILaunchCmdWillPWPromptType;
00143
00144 #endif  //_PALM_VPPI_H_
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:55 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » network

PalmWiFiCommon.h

Go to the documentation of this file.
00001 /******************************************************************************
00002  * Copyright (c) 2004 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  *****************************************************************************/
00005 /**
00006  * @ingroup Network
00007  */
00008
00009 /**
00010  * @file    PalmWiFiCommon.h
00011  * @version 1.0
00012  *
00013  * @brief Constants and structures common to the wifi network panel and driver.
00014  *
00015  */
00016
00017 #ifndef PALM_WIFI_COMMON_H_
00018 #define PALM_WIFI_COMMON_H_
00019
00020 #include <NetMgr.h>
00021
00022 /** Define the appropriate minimum OS version we support */
00023 #define WIFI_MIN_OS_VERSION  sysMakeROMVersion(3,0,0,sysROMStageDevelopment,0)
00024 /** Define the appropriate minimum OS version we support */
00025 #define PALM_OS_20_VERSION   sysMakeROMVersion(2,0,0,sysROMStageDevelopment,0)
00026
00027 /** WiFi creator ID. */
00028 #define WIFI_CREATOR_ID    'WiFi'
00029 /** WiFi configuration name */
00030 #define WIFI_CONFIG_NAME   "WiFi Config"
00031
00032 /** WiFi database type */
00033 #define WIFI_DB_TYPE       'DATA'
00034 /** WiFi database name */
00035 #define WIFI_DB_NAME       "WiFiDB"
00036
00037 /** WiFi driver prefix */
00038 #define WIFI_DRIVER_PREFIX "wi"
00039 /** WiFi driver name */
00040 #define WIFI_DRIVER_NAME   "WiFi Prism3"
00041
00042 /// @name Event Notifications
00043 /// Event notifications from the WiFi -- can be used for SysNotifyRegister
00044 /*@{*/
00045 #define WIFI_ASSOCIATED_EVENT               'WiAs'
00046 #define WIFI_DISASSOCIATED_EVENT            'WiDi'
00047 #define WIFI_SCAN_COMPLETE_EVENT            'WiSc'
00048 #define WIFI_IF_UP_EVENT                    'WiUp'
00049 #define WIFI_IF_DOWN_EVENT                  'WiDn'
00050 /*@}*/
00051
00052
00053 /** Supported Query requests for WiFi driver. */
00054 typedef enum
00055 {
00056     netQuery80211SignalStrength = 0x100,
00057     netQuery80211SignalQuality,
00058     netQuery80211AuthenticationMode,
00059     netQuery80211BssScan,
00060     netQuery80211BssScanList,
00061     netQuery80211Channel,
00062     netQuery80211PowerState,
00063     netQuery80211RadioState,
00064     netQuery80211SSID,
00065     netQuery80211Key,
00066     netQuery80211KeyIndex,
00067     netQuery80211ResetKeys,
00068     netQuery80211OperatingMode,
00069     netQuery80211WepStatus,
00070     netQuery80211FirmwareVersion,
00071     netQuery80211SerialNumber,
00072     netQuery80211FWName,
00073     netQuery80211DriverDate,
00074     netQuery80211WEPRequired,
00075     netQuery80211ChannelList,
00076     netQuery80211BSSID,
00077     netQueryCancel,
00078     netQuery80211MediaState,
00079     netQuery80211SecurityMode, // use security mode #defines
00080     netQuery80211StartConnection,
00081     netQuery80211Last
00082 } NetQueryId;
00083
00084
00085 /** IP address allocation strategies */
00086 enum IPAllocType
00087 {
00088     IPAllocType_DHCP   = 0,
00089     IPAllocType_APIPA  = 1,
00090     IPAllocType_STATIC = 2
00091 };
00092
00093 enum SecurityModeType
00094 {
00095     SecurityModeOpenSystem = 0,
00096     SecurityModeWEP,
00097     SecurityModeWPAPSK,
00098     SecurityModeLast
00099 };
00100
00101 /// @name Encryption Algorithm
00102 /*@{*/
00103 #define AUTHENTICATION_ALGORITHM_OPEN_SYSTEM    1
00104 #define AUTHENTICATION_ALGORITHM_SHARED_KEY     2 //40 bit
00105 #define AUTHENTICATION_ALGORITHM_SHARED_KEY_128 3
00106 /*@}*/
00107
00108 /** Operating mode, referred to as port type in the configuration. */
00109 #define ESS     1
00110
00111
00112
00113 #define IBSS    4
00114
00115 /** @name ESS TX power mode. */
00116 /*@{*/
00117 #define AUTO_TX_POWER           0
00118 #define ENHANCED_TX_POWER       1
00119 /*@}*/
00120
00121 /** @name AdHoc power modes. */
00122 /*@{*/
00123 #define FULL_TX_POWER           0
00124 #define _30_MW_TX_POWER         1
00125 #define _15_MW_TX_POWER         2
00126 #define _5_MW_TX_POWER          3
00127 #define _1_MW_TX_POWER          4
00128 /*@}*/
00129
00130 /** @name AP density constants.
00131  *  @brief Referred as netIFSetting80211Environment in configuration.
00132  */
00133 /*@{*/
00134 #define AP_DENSITY_LOW  0
00135 #define AP_DENSITY_MED  1
00136 #define AP_DENSITY_HIGH 2
00137 /*@}*/
00138
00139 /** @name Adapter Preamble */
00140 /*@{*/
00141 #define LONG_PREAMBLE       0
00142 #define SHORT_PREAMBLE      1
00143 #define AUTO_PREAMBLE       2
00144 /*@}*/
00145
00146 /** Special code required to be passed to reset wep keys */
00147 #define net80211ResetWepPasscode    0x41149339
00148
00149 /** Definitions of media states returned from netQuery80211MediaState */
00150 #define netMediaDisconnected        0
00151 /** Definitions of media states returned from netQuery80211MediaState */
00152 #define netMediaConnected           1
00153
00154 enum WiFiCustomIFSettings
00155 {
00156     netIFSetting80211PowerMode = netIFSettingCustom,
00157     netIFSetting80211Diversity,
00158     netIFSetting80211Channel,
00159     netIFSetting80211EncryptionKey1,
00160     netIFSetting80211EncryptionKey2,
00161     netIFSetting80211EncryptionKey3,
00162     netIFSetting80211EncryptionKey4,
00163     netIFSetting80211EncryptionKeyID,
00164     netIFSetting80211MandatoryBSSId,
00165     netIFSetting80211MUEncryptionAlgorithm,
00166     netIFSetting80211PortType,  // ESS, PsIBBS, IBSS
00167     netIFSetting80211EssTxPower,
00168     netIFSetting80211AdhocTxPower,
00169     netIFSetting80211StationName,
00170     netIFSetting80211Environment,
00171     netIFSetting80211LongPreamble,
00172     netIFSetting80211Gateway,
00173     netIFSettingPrimaryDNS,
00174     netIFSettingSecondaryDNS,
00175     netIFSettingDHCPRequestDNS,
00176     netIFSettingIPAllocType, // 0,1,2=DHCP,APIPA,STATIC
00177     netIFSetting80211SmartConnect,
00178     netIFSettingUIProgHoldOff,
00179     netIFSettingWiFiHideProgress,
00180     netIFSettingAutoPowerDownOnClose,
00181     netIFSettingInterfaceQSize,
00182     netIFSettingDriverQSize,
00183     netIFSetting8021x,
00184     netIFSetting80211MediaDisconnectLingerTime,
00185     netIFSetting80211MobileIP,
00186
00187 #ifdef WIFI_DOT1X_SUPPORT
00188     netIFSettingDot1XWPPICreator,
00189     netIFSettingDot1XAuthenticationMethodID,
00190     netIFSettingDot1XAuthenticationCookie,
00191 #endif // WIFI_DOT1X_SUPPORT
00192
00193     netIFSetting80211Last
00194 };
00195
00196 #define netMacAddrLength        6   /**< max length MAC address */
00197 #define netSSIDMaxLength        32  /**< max length SSID */
00198 #define netNum80211Rates        8   /**< no definition */
00199
00200 /** Wep status codes */
00201 enum NetWepStatus
00202 {
00203     netWEPEnabled,
00204     netWEPDisabled,
00205     netWEPKeyAbsent,
00206     netWEPNotSupported
00207 };
00208
00209 /** @name Network Device Driver Interface Error Codes */
00210 /*@{*/
00211 #define errNetQueryBufTooSmall  11
00212 #define errNetOutOfMemory       12
00213 #define errNetLibMissing        13
00214 #define errNetInterfaceNotFound 14
00215 /*@}*/
00216
00217 // The following are added to support a structure independent method
00218 // for presenting the BSS Scan data to an application.  Macros
00219 // are also provide to access data within a buffer.
00220 // NOTE:  These offsets do not account for the first 4 bytes which
00221 // must always precede the data.  This count field indicates the
00222 // number of BSS structures will follow
00223
00224 /** Offset = 0.  Present/validity flags for each of the entities defined below */
00225 /*@{*/
00226 #define BSSINFO_VFLAG                   0
00227 #define BSSINFO_VFLAG_SIZE              4
00228 /*@}*/
00229
00230 /** Offset = 4.  MAC/HW Address for device. */
00231 /*@{*/
00232 #define BSSINFO_MAC_ADDR_OFFSET         (BSSINFO_VFLAG + BSSINFO_VFLAG_SIZE)
00233 #define BSSINFO_MAC_ADDR_SIZE           8               // Add padding to allow easy access for structure definiton.
00234 #define BSSINFO_MAC_ADDR_VFLAG          0x00000001L
00235 /*@}*/
00236
00237 /** Offset = 12.  Length of the following SSID */
00238 /*@{*/
00239 #define BSSINFO_SSIDLENGTH_OFFSET       (BSSINFO_MAC_ADDR_OFFSET + BSSINFO_MAC_ADDR_SIZE)
00240 #define BSSINFO_SSIDLENGTH_SIZE         4
00241 #define BSSINFO_SSIDLENGTH_VFLAG        0x00000002L
00242 /*@}*/
00243
00244 /** Offset = 16 (0x10).  SSID */
00245 /*@{*/
00246 #define BSSINFO_SSID_OFFSET             (BSSINFO_SSIDLENGTH_OFFSET + BSSINFO_SSIDLENGTH_SIZE)
00247 #define BSSINFO_SSID_SIZE               netSSIDMaxLength
00248 #define BSSINFO_SSID_VFLAG              0x00000004L
00249 /*@}*/
00250
00251 /** Offset = 48 (0x30).  WEP enabled boolean */
00252 /*@{*/
00253 #define BSSINFO_WEP_OFFSET              (BSSINFO_SSID_OFFSET + BSSINFO_SSID_SIZE)
00254 #define BSSINFO_WEP_SIZE                4
00255 #define BSSINFO_WEP_VFLAG               0x00000008L
00256 /*@}*/
00257
00258 /** Offset = 52 (0x34).   Received Signal Strength */
00259 /*@{*/
00260 #define BSSINFO_RSSI_OFFSET             (BSSINFO_WEP_OFFSET + BSSINFO_WEP_SIZE)
00261 #define BSSINFO_RSSI_SIZE               4
00262 #define BSSINFO_RSSI_VFLAG              0x00000010L
00263 /*@}*/
00264
00265 /** Offset = 56 (0x38).  Network type in use (Freq. hopping, DSS) */
00266 /*@{*/
00267 #define BSSINFO_NETWORK_TYPE_OFFSET     (BSSINFO_RSSI_OFFSET + BSSINFO_RSSI_SIZE)
00268 #define BSSINFO_NETWORK_TYPE_SIZE       4
00269 #define BSSINFO_NETWORK_TYPE_VFLAG      0x00000020L
00270 /*@}*/
00271
00272 /** Offset = 60 (0x3C).  Beacon period (in KuSec) */
00273 /*@{*/
00274 #define BSSINFO_BEACON_PERIOD_OFFSET    (BSSINFO_NETWORK_TYPE_OFFSET + BSSINFO_NETWORK_TYPE_SIZE)
00275 #define BSSINFO_BEACON_PERIOD_SIZE      4
00276 #define BSSINFO_BEACON_PERIOD_VFLAG     0x00000040L
00277 /*@}*/
00278
00279 /** Offset = 64 (0x40).  ATim window (in KuSec) */
00280 /*@{*/
00281 #define BSSINFO_ATIM_WINDOW_OFFSET      (BSSINFO_BEACON_PERIOD_OFFSET + BSSINFO_BEACON_PERIOD_SIZE)
00282 #define BSSINFO_ATIM_WINDOW_SIZE        4
00283 #define BSSINFO_ATIM_WINDOW_VFLAG       0x00000080L
00284 /*@}*/
00285
00286 /** Offset = 68 (0x44). DS frequency (in kHz) */
00287 /*@{*/
00288 #define BSSINFO_DSFREQ_OFFSET           (BSSINFO_ATIM_WINDOW_OFFSET + BSSINFO_ATIM_WINDOW_SIZE)
00289 #define BSSINFO_DSFREQ_SIZE             4
00290 #define BSSINFO_DSFREQ_VFLAG            0x00000100L
00291 /*@}*/
00292
00293 /** Offset = 72 (0x48).  Frequency hopping pattern */
00294 /*@{*/
00295 #define BSSINFO_HOPPATTERN_OFFSET       (BSSINFO_DSFREQ_OFFSET + BSSINFO_DSFREQ_SIZE)
00296 #define BSSINFO_HOPPATTERN_SIZE         4
00297 #define BSSINFO_HOPPATTERN_VFLAG        0x00000200L
00298 /*@}*/
00299
00300 /** Offset = 76 (0x4C).  Frequency hopping set */
00301 /*@{*/
00302 #define BSSINFO_HOPSET_OFFSET           (BSSINFO_HOPPATTERN_OFFSET + BSSINFO_HOPPATTERN_SIZE)
00303 #define BSSINFO_HOPSET_SIZE             4
00304 #define BSSINFO_HOPSET_VFLAG            0x00000400L
00305 /*@}*/
00306
00307 /** Offset = 80 (0x50). Frequency hopping dwell time */
00308 /*@{*/
00309 #define BSSINFO_HOPDWELL_OFFSET         (BSSINFO_HOPSET_OFFSET + BSSINFO_HOPSET_SIZE)
00310 #define BSSINFO_HOPDWELL_SIZE           4
00311 #define BSSINFO_HOPDWELL_VFLAG          0x00000800L
00312 /*@}*/
00313
00314 /** Offset = 84 (0x54).  802.11 network mode */
00315 /*@{*/
00316 #define BSSINFO_NETWORK_MODE_OFFSET     (BSSINFO_HOPDWELL_OFFSET + BSSINFO_HOPDWELL_SIZE)
00317 #define BSSINFO_NETWORK_MODE_SIZE       4
00318 #define BSSINFO_NETWORK_MODE_VFLAG      0x00001000L
00319 /*@}*/
00320
00321 /** Offset = 88 (0x58).  Supported rates on interface. */
00322 /*@{*/
00323 #define BSSINFO_SUPPORTED_RATES_OFFSET  (BSSINFO_NETWORK_MODE_OFFSET + BSSINFO_NETWORK_MODE_SIZE)
00324 #define BSSINFO_SUPPORTED_RATES_SIZE    8
00325 #define BSSINFO_SUPPORTED_RATES_VFLAG   0x00002000L
00326 /*@}*/
00327
00328 /** Offset = 96 (0x60).  Channel ID */
00329 /*@{*/
00330 #define BSSINFO_CHID_OFFSET             (BSSINFO_SUPPORTED_RATES_OFFSET + BSSINFO_SUPPORTED_RATES_SIZE)
00331 #define BSSINFO_CHID_SIZE               4
00332 #define BSSINFO_CHID_VFLAG              0x00004000L
00333 /*@}*/
00334
00335 /** Offset = 96 (0x60).  Channel ID */
00336 /*@{*/
00337 #define BSSINFO_ANL_OFFSET              (BSSINFO_CHID_OFFSET + BSSINFO_CHID_SIZE)
00338 #define BSSINFO_ANL_SIZE                4
00339 #define BSSINFO_ANL_VFLAG               0x00008000L
00340 /*@}*/
00341
00342 /** Total size of the BSS info supplied. */
00343 #define BSSINFO_SIZE                    (BSSINFO_ANL_OFFSET + BSSINFO_ANL_SIZE)
00344
00345 /// @name Macros for accessing individual fields
00346 /*@{*/
00347 #define BssInfoMacAddr( infoP, destP )  MemMove( destP, &((UInt8 *) infoP)[BSSINFO_MAC_ADDR_OFFSET], BSSINFO_MAC_ADDR_SIZE )
00348 #define BssInfoSsidLength( infoP, destP ) MemMove( destP, &((UInt8 *) infoP)[BSSINFO_SSIDLENGTH_OFFSET], BSSINFO_SSIDLENGTH_SIZE )
00349 #define BssInfoSsid( infoP, destP ) MemMove( destP, &((UInt8 *) infoP)[BSSINFO_SSID_OFFSET], BSSINFO_SSID_SIZE )
00350 #define BssInfoWep( infoP, destP ) MemMove( destP, &((UInt8 *) infoP)[BSSINFO_WEP_OFFSET], BSSINFO_WEP_SIZE )
00351 #define BssInfoRssi( infoP, destP ) MemMove( destP, &((UInt8 *) infoP)[BSSINFO_RSSI_OFFSET], BSSINFO_RSSI_SIZE )
00352 #define BssInfoNetworkType( infoP, destP ) MemMove( destP, &((UInt8 *) infoP)[BSSINFO_NETWORK_TYPE_OFFSET], BSSINFO_NETWORK_TYPE_SIZE )
00353 #define BssInfoBeaconPeriod( infoP, destP ) MemMove( destP, &((UInt8 *) infoP)[BSSINFO_BEACON_PERIOD_OFFSET], BSSINFO_BEACON_PERIOD_SIZE )
00354 #define BssInfoAtimWindow( infoP, destP ) MemMove( destP, &((UInt8 *) infoP)[BSSINFO_ATIM_WINDOW_OFFSET], BSSINFO_ATIM_WINDOW_SIZE )
00355 #define BssInfoDSFreq( infoP, destP ) MemMove( destP, &((UInt8 *) infoP)[BSSINFO_DSFREQ_OFFSET], BSSINFO_DSFREQ_SIZE )
00356 #define BssInfoHopPattern( infoP, destP ) MemMove( destP, &((UInt8 *) infoP)[BSSINFO_HOPPATTERN_OFFSET], BSSINFO_HOPPATTERN_SIZE )
00357 #define BssInfoHopSet( infoP, destP ) MemMove( destP, &((UInt8 *) infoP)[BSSINFO_HOPSET_OFFSET], BSSINFO_HOPSET_SIZE )
00358 #define BssInfoHopDwell( infoP, destP ) MemMove( destP, &((UInt8 *) infoP)[BSSINFO_HOPDWELL_OFFSET], BSSINFO_HOPDWELL_SIZE )
00359 #define BssInfoNetworkMode( infoP, destP ) MemMove( destP, &((UInt8 *) infoP)[BSSINFO_NETWORK_MODE_OFFSET], BSSINFO_NETWORK_MODE_SIZE )
00360 #define BssInfoSupportedRates( infoP, destP ) MemMove( destP, &((UInt8 *) infoP)[BSSINFO_SUPPORTED_RATES_OFFSET], BSSINFO_SUPPORTED_RATES_SIZE )
00361 #define BssInfoChannelId( infoP, destP ) MemMove( destP, &((UInt8 *) infoP)[BSSINFO_CHID_OFFSET], BSSINFO_CHID_SIZE )
00362 #define BssInfoANL( infoP, destP ) MemMove( destP, &((UInt8 *) infoP)[BSSINFO_ANL_OFFSET], BSSINFO_ANL_SIZE )
00363 /*@}*/
00364
00365 /**
00366  *  @brief Structure to hold BSS Info data
00367  *
00368  *  Accessing the BSS scan info returned via the network interface via
00369  *  the following structure needs to be verified for each specific toolchain
00370  *  and compiler.  It has been verified with the combination of ADS V1.2 and
00371  *  CW 8.3.  The data format has been done to be as toolchain/architecture/alignment
00372  *  independent as possible, however, if a different combination other than the
00373  *  one listed is used, the format must be verified.  The macro's defined
00374  *  above can also be used to access the individual entities of the returned
00375  *  BSS scan data.
00376  */
00377 typedef struct NetBssInfoType
00378 {
00379     UInt32  validFlag;
00380     UInt8   bssMacAddr[BSSINFO_MAC_ADDR_SIZE];
00381     UInt32  bssSsidLength;
00382     UInt8   bssSsid[BSSINFO_SSID_SIZE];
00383     UInt32  bssWepEnabled;
00384     Int32   bssRssi;
00385     UInt32  bssNetworkType;                     // Net80211NetworkType
00386     UInt32  bssBeaconPeriod;
00387     UInt32  bssAtimWindow;
00388     UInt32  bssDSFreq;
00389     UInt32  bssHopPattern;
00390     UInt32  bssHopSet;
00391     UInt32  bssHopDwell;
00392     UInt32  bssNetworkMode;                     // Net80211InfrastructureModeType
00393     UInt8   bssSupportedRates[BSSINFO_SUPPORTED_RATES_SIZE];
00394     UInt32  bssChannelId;
00395     Int32   bssANL;
00396 } NetBssInfoType, *NetBssInfoTypeP;
00397
00398 /**
00399  * @brief Structure to hold network query data
00400  */
00401 typedef struct NetworkDeviceQueryData
00402 {
00403     UInt32  qid;
00404     void    *InfoBuffer;
00405     UInt32  InfoBufferLength;
00406     UInt32  InfoSize;
00407     UInt32  InfoSizeRequired;
00408
00409     /**
00410      * Added a link pointer. This is required if the driver needs to provide
00411      * an intermediate buffer space as a translation process.
00412      */
00413     struct NetworkDeviceQueryData   *linkP;
00414
00415 } NetQueryType, *NetQueryTypeP;
00416
00417 typedef enum _80211NetworkTypeEnum
00418 {
00419     net80211_FH,
00420     net80211_DS,
00421     net80211_Max            // Never returned from scan.  Can be used for bounds checking
00422 } Net80211NetworkType;
00423
00424 /** Infrastructure mode info returned from a BSS scan */
00425 typedef enum _80211InfrastructureEnum
00426 {
00427     net80211Bss,
00428     net80211Infrastructure,
00429     net80211AutoUnknown,
00430     net80211InfrastructureMax           // Never returned from scan.  Can be used for bounds checking.
00431 } Net80211InfrastructureModeType;
00432
00433 /**
00434  * @brief BSS list.
00435  *
00436  * This data structure is returned from a BSS scan.  The count field indicates
00437  * how many BSS structures are provide.
00438  */
00439 typedef struct BSSListStruct
00440 {
00441     UInt32          count;
00442     NetBssInfoType  BSS[1];
00443 } NetBssListType;
00444
00445 /**
00446  * @brief Structure used to get and set the current SSID for the driver (not the Network interface)
00447  */
00448 typedef struct NetSSID
00449 {
00450     UInt32      ssidLength;
00451     UInt8       ssid[32];
00452 } NetSSID, *NetSSIDP;
00453
00454 /**
00455  * @brief Structure used to set the wep keys.
00456  *
00457  * The API's do not return the wep keys via a query.
00458  */
00459 typedef struct NetWepKey
00460 {
00461     UInt32      keyIndex;
00462     UInt32      keyLength;
00463     UInt8       key[16];
00464 } NetWepKey, *NetWepKeyP;
00465
00466
00467
00468
00469
00470
00471 #endif // PALM_WIFI_COMMON_H_
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:55 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » network

PalmWPPI.h

Go to the documentation of this file.
00001 /******************************************************************************
00002  * Copyright (c) 2004 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  *****************************************************************************/
00005 /**
00006  * @ingroup Network
00007  */
00008
00009 /**
00010  * @file    PalmWPPI.h
00011  * @version 1.0
00012  * @date    05/16/2003
00013  *
00014  * @brief This is the API for Wi-Fi panel plug-ins (WPPIs).
00015  *
00016  * The Wi-Fi panel allows the user to manage their network profiles. Each profile includes a
00017  * plugin, an authentication method, and a cookie used to identify the
00018  * user's credentials. Each plugin provides support for one or more
00019  * authentication methods; e.g., LEAP, PEAP, etc. A WPPI provides access to
00020  * the user interface of an 802.1x client.
00021  *
00022  */
00023
00024 #ifndef _PALM_WPPI_H_
00025 #define _PALM_WPPI_H_
00026
00027
00028 // A WPPI is much like an application. It has a PilotMain function that responds
00029 // to certain launch codes. Applications are databases of type 'appl'. WPPIs use
00030 // this type instead:
00031
00032 #define sysFileTWiFiPanelPlugin     'Wppi'  /**< database type for Wi-Fi panel plug-ins */
00033
00034 // The creator ID of the database should be registered as usual. WPPI's don't have
00035 // user-visible names; only authentication methods are visible to the user. A WPPI
00036 // will typically have form resources, etc. These can be in the normal sub-10000 range
00037 // reserved for application.
00038
00039 // A WPPI is always is always sublaunched, so it never has access to global variables
00040 // or multiple code segments. The value returned by the PilotMain function is always
00041 // ignored. Instead, an err field in the command parameter block is used to indicate
00042 // success or failure. This is only used for out-of-memory and stuff like that, not
00043 // for user-cancel. The Wi-Fi panel sets the err field to a non-zero value before
00044 // calling the WPPI. The WPPI is responsible for zeroing the err field before returning
00045 // if it's successful. The error code used doesn't matter; it is only used to indicate
00046 // success or failure.
00047
00048 // Each WPPI is responsible for storing the credentials associated with accounts that
00049 // use its authentication methods.
00050
00051 // The Wi-Fi panel queries each WPPI for a list of authentication methods and then
00052 // merges the results. The query uses the following launch code and command parameter
00053 // block:
00054
00055 #define sysWPPILaunchCmdGetAuthenticationMethods        sysAppLaunchCmdCustomBase   // 0x8000
00056
00057 #define kMaxWiFiAuthenticationMethodNameLength          31
00058
00059 typedef struct
00060     {
00061     UInt32  wppiCreator; /**< the creator ID of the WPPI that provides the authentication method */
00062     UInt32  authenticationMethodID; /**< an arbitrary 32-bit ID used by the WPPI to identify the authentication method */
00063     Char    authenticationMethodName[kMaxWiFiAuthenticationMethodNameLength + 1]; /**< the user-visible name for the authentication method (max width is 50 pixels) */
00064     } WiFiAuthenticationMethodType;
00065
00066 typedef struct
00067     {
00068     UInt32                        numAuthenticationMethods;
00069     WiFiAuthenticationMethodType* authenticationMethods;
00070     Err                           err;
00071     } SysWPPILaunchCmdGetAuthenticationMethodsType;
00072
00073 // The Wi-Fi panel will zero numAuthenticationMethods and authenticationMethods before
00074 // calling the WPPI. It should allocate a chunk in the dynamic heap to store the
00075 // authentication methods and put a pointer to this chunk in the authenticationMethods
00076 // field. The Wi-Fi panel will free this chunk. Note that the WPPI creator ID is
00077 // duplicated in each account.
00078
00079 // A WPPI is expected to maintain a database of credentials for each network that uses
00080 // one of its authentication methods. The records in this database are identified by
00081 // their unique ID. The Wi-Fi panel saves this unique ID, or cookie, along with all the
00082 // other network settings, in its own database. A value of zero is used to indicate
00083 // that there are no credentials because this is a new network or because the user
00084 // switched authentication methods. The WPPI shouldn't save the user's credentials into
00085 // its database until the Wi-Fi panel tells it to. This happens when the user taps the
00086 // OK button in the Edit Network dialog. Until then, the entered credentials should be
00087 // saved in a temporary location such as one or more features.
00088
00089 // The Wi-Fi panel makes the following sequence of calls into the WPPI:
00090 // - sysWPPILaunchCmdOpen
00091 // - sysWPPILaunchCmdDialog (zero or more times)
00092 // - sysWPPILaunchCmdClose
00093 // When the Edit Network dialog opens, the Wi-Fi panel calls sysWPPILaunchCmdOpen
00094 // for the current WPPI and authentication method. When the user taps on the
00095 // credentials selector trigger, the Wi-Fi panel calls sysWPPILaunchCmdDialog.
00096 // When the user taps OK or Cancel in the Edit Network dialog, the Wi-Fi panel
00097 // calls sysWPPILaunchCmdClose. If the user switches authentication methods, the
00098 // Wi-Fi panel calls sysWPPILaunchCmdClose for the old method and
00099 // sysWPPILaunchCmdOpen for the new one. All of these take the same command
00100 // parameter block:
00101
00102 #define kMaxWiFiCredentialsLabelLength                      31  // excludes terminator
00103 #define kMaxWiFiCredentialsSelectorTriggerLength        31  // excludes terminator
00104
00105 typedef struct
00106     {
00107     UInt32  authenticationMethodID; /**< a 32-bit ID used by the WPPI to identify the authentication method */
00108     UInt32  cookie; /**< a unique ID or other identifier used to look up the credentials */
00109     Boolean save; /**< whether to save the user's changes (only for sysWPPILaunchCmdClose) */
00110     Boolean cancel; /**< whether the user tapped Cancel (only for sysWPPILaunchCmdDialog) */
00111     Boolean assigned; /**< whether credentials are considered assigned for validation purposes */
00112     Char    credentialsLabel[kMaxWiFiCredentialsLabelLength + 1]; /**< the label to use for the credentials line in the Edit Network dialog */
00113     Char    credentialsSelectorTrigger[kMaxWiFiCredentialsSelectorTriggerLength + 1]; /**< the selector trigger label indicating whether credentials have been assigned */
00114     Err     err; /**< non-zero on entry; set by WPPI to indicate success or failure */
00115     } SysWPPILaunchCmdType;
00116
00117 #define sysWPPILaunchCmdOpen        sysAppLaunchCmdCustomBase + 1                    // 0x8001
00118
00119 /// If a non-zero cookie is passed in, we're editing an existing network with existing
00120 /// credentials. The WPPI should find the credentials in its database and put them in
00121 /// a temporary location. If a zero cookie is passed in, we're either creating a new
00122 /// network, editing an existing network that didn't previous have credentials, or
00123 /// switching authentication methods. The WPPI should set the credentialsLabel and
00124 /// credentialsSelectorTrigger. Typically, the credentialsLabel is "Credentials:" and
00125 /// the credentialsSelectorTrigger is "-Assigned-" or "-Unassigned-". Every call to
00126 /// sysWPPILaunchCmdOpen is matched with a call to sysWPPILaunchCmdClose.
00127
00128 #define sysWPPILaunchCmdClose       sysAppLaunchCmdCustomBase + 2                    // 0x8002
00129
00130 /// If the save flag is set, the WPPI should write the user's credentials to its
00131 /// database. If the cookie is zero, it should create a new record and save its
00132 /// unique ID in the cookie field of the command parameter block. If the cookie is
00133 /// non-zero, it should overwrite the old record.
00134
00135 #define sysWPPILaunchCmdDialog  sysAppLaunchCmdCustomBase + 3                    // 0x8003
00136
00137 /// The WPPI should open its dialog and allow the user to edit the credentials. It
00138 /// should read from the temporary location to initialize the username and password
00139 /// fields or other UI elements as appropriate. It should write to the temporary
00140 /// location when the user taps OK. It shouldn't access its database. Whether the
00141 /// user tapped Cancel should be stored in the cancel flag in the command parameter
00142 /// block. If the user taps OK and this changes the current credentials state
00143 /// (typically assigned/unassigned), the credentialsSelectorTrigger field should
00144 /// be updated by the WPPI. Note that the user may delete his credentials causing
00145 /// the state to change from assigned to unassigned.
00146
00147 #define sysWPPILaunchCmdDelete  sysAppLaunchCmdCustomBase + 4                    // 0x8004
00148
00149 /// When the user deletes a network, the Wi-Fi panel notifies the WPPI to delete
00150 /// the corresponding credentials. This uses the same command parameter block as
00151 /// above. The cookie field is used to indentify the record in the WPPI's
00152 /// database. A zero value should be ignored. If the user switches authentication
00153 /// methods and taps OK to save the edited network, the Wi-Fi panel notifies the
00154 /// old WPPI to delete the old credentials.
00155
00156 /// Finally, the Wi-Fi Setup wizard displays a detailed description of the selected
00157 /// authentication method. To do this, it sublaunches the WPPI with the following
00158 /// launch code and command parameter block.
00159
00160 #define sysWPPILaunchCmdGetDescription      sysAppLaunchCmdCustomBase + 5           // 0x8005
00161
00162 typedef struct
00163     {
00164     UInt32 authenticationMethodID;
00165     Char*  description;
00166     UInt32 descriptionSize;
00167     Err    err;
00168     } SysWPPILaunchCmdGetDescriptionType;
00169
00170 /// The WPPI should write into the description buffer supplied. The buffer is
00171 /// allocated by the Wi-Fi panel. The WPPI should avoid writing past the end of
00172 /// the buffer. The size of the buffer is included in the command parameter block.
00173 /// The description is displayed in an 8 line, full width field in the normal
00174 /// font.
00175
00176 ///
00177 /// This is invoked to bring up the prompt dialog (WPPI decides if
00178 /// prompt is necessary) or pass any kind of data to the WPPI.
00179 /// Optionally, before exiting, a WPPI can set the
00180 /// netIFSettingDot1XConfig setting to pass information back to the
00181 /// 802.1X plugin.
00182 ///
00183 #define sysWPPILaunchCmdPromptAndConfigure      (sysAppLaunchCmdCustomBase + 6)   // 0x8006
00184
00185 typedef struct
00186 {
00187   UInt32   ifCreator;   // in
00188   UInt32   ifInstance;  // in
00189   Err      errOut;      // out
00190 } SysWPPILaunchCmdPromptAndConfigureType;
00191
00192
00193 ///
00194 /// This is invoked to put up an error dialog.
00195 ///
00196 #define sysWPPILaunchCmdErrorDialog     (sysAppLaunchCmdCustomBase + 7)   // 0x8007
00197
00198 typedef struct
00199 {
00200   UInt32        error;          // in
00201   Err           errOut;         // out
00202 } SysWPPILaunchCmdErrorDialogType;
00203
00204 ///
00205 /// This is invoked to request a password cache clear.
00206 /// Removes temporary passwords from all accounts managed by the WPPI.
00207 ///
00208 #define sysWPPILaunchCmdClearPWCache    (sysAppLaunchCmdCustomBase + 8)   // 0x8008
00209
00210 typedef struct
00211 {
00212   Err           errOut;         // out
00213 } SysWPPILaunchCmdClearPWCache;
00214
00215
00216 #endif  //_PALM_WPPI_H_
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:55 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » pmconnectorlib

PmConnectorLib.h

Go to the documentation of this file.
00001 /******************************************************************************
00002  * Copyright (c) 2004-2005 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  *****************************************************************************/
00005 /**
00006  * @ingroup PmConnectorLib
00007  */
00008
00009 /**
00010  * @file  PmConnectorLib.h
00011  * @brief palmOne library that exports multi-connector related APIs.
00012  *
00013  */
00014
00015 #ifndef __PMCONNECTORLIB_H__
00016 #define __PMCONNECTORLIB_H__
00017
00018
00019 #include <Common/Libraries/PmConnectorLib/PmConnectorLibCommon.h>
00020
00021 // To Define when building the library
00022 #if (CPU_TYPE != CPU_68K) || (defined BUILDING_PMCONNECTOR_LIB)
00023     #define PMCONNECTOR_LIB_TRAP(trapNum)
00024 #else
00025     #include <LibTraps.h>
00026     #define PMCONNECTOR_LIB_TRAP(trapNum) SYS_TRAP(trapNum)
00027 #endif
00028
00029
00030 /********************************************************************
00031  * Prototypes
00032  ********************************************************************/
00033 #ifdef __cplusplus
00034 extern "C" {
00035 #endif
00036
00037 /**
00038  * @brief Standard library open routine
00039  *
00040  * @param refNum:   IN: library reference number
00041  * @retval Err Error code.
00042  */
00043 Err
00044 PmConnectorLibOpen (UInt16 refNum)
00045       PMCONNECTOR_LIB_TRAP (kPmConnectorLibTrapOpen);
00046
00047 /**
00048  * @brief Standard library close routine
00049  *
00050  * @param refNum:   IN: library reference number
00051  * @retval Err Error code.
00052  */
00053 Err
00054 PmConnectorLibClose (UInt16 refNum)
00055       PMCONNECTOR_LIB_TRAP (kPmConnectorLibTrapClose);
00056
00057 /**
00058  * @brief Standard library sleep routine
00059  *
00060  * @param refNum:   IN: library reference number
00061  * @retval Err Error code.
00062  */
00063 Err
00064 PmConnectorLibSleep (UInt16 refNum)
00065       PMCONNECTOR_LIB_TRAP (kPmConnectorLibTrapSleep);
00066
00067 /**
00068  * @brief Standard library wake routine
00069  *
00070  * @param refNum:   IN: library reference number
00071  * @retval Err Error code.
00072  */
00073 Err
00074 PmConnectorLibWake (UInt16 refNum)
00075       PMCONNECTOR_LIB_TRAP (kPmConnectorLibTrapWake);
00076
00077 /**
00078  * @brief Checks the version of the library present on the device
00079  *
00080  * @param refNum:       IN: library reference number
00081  * @param sdkVersion:   IN: sdkVersion defined in the common header file
00082  * @param LibVersionP:  IN: version of the library on the device
00083  * @retval Err Error code. Function returns error when it finds incompatible library
00084  */
00085 Err
00086 PmConnectorLibGetVersion (UInt16 refNum, UInt32 sdkVersion, UInt32 *LibVersionP)
00087       PMCONNECTOR_LIB_TRAP (kPmConnectorLibTrapGetVersion);
00088
00089 /**
00090  * @brief Controls the pins on the connector. Currently supports power on and off
00091  *
00092  * @param refNum:   IN: library reference number
00093  * @param cmdId:    IN: type of control. @see PmConnectorLibControlType
00094  * @param parmP:    IN: contains the value needed depending on type of control
00095  * @retval Err Error code.
00096  */
00097 Err
00098 PmConnectorLibControl (UInt16 refNum, UInt16 cmdId, void *parmP)
00099       PMCONNECTOR_LIB_TRAP (kPmConnectorLibTrapControl);
00100
00101 /**
00102  * @brief Targets audio output to different audio peripherals.
00103  *
00104  * @param refNum            IN: library reference number
00105  * @param outputSetting:    IN: audio capabilities (headphone, speaker, etc)
00106  * @retval Err Error code.
00107  */
00108 Err
00109 PmConnectorLibSetAudioOutput(UInt16 refNum, PmConnectorAudioOutputSettingType outputSetting)
00110       PMCONNECTOR_LIB_TRAP (kPmConnectorLibTrapSetAudioOutput);
00111
00112 /**
00113  * @brief Targets audio input from different audio peripherals.
00114  *
00115  * @param refNum            IN: library reference number
00116  * @param inputSetting:    IN: audio capabilities (headset etc)
00117  * @retval Err Error code.
00118  */
00119 Err
00120 PmConnectorLibSetAudioInput(UInt16 refNum, PmConnectorAudioInputSettingType inputSetting)
00121       PMCONNECTOR_LIB_TRAP (kPmConnectorLibTrapSetAudioInput);
00122
00123
00124 //
00125 // To maintain the same dispatch entry as the MDF the next customcontrol should be  (sysLibTrapCustom + 6)
00126 //
00127 #ifdef __cplusplus
00128 }
00129 #endif
00130
00131
00132 #endif  // __PMCONNECTORLIB_H__
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:55 2008 for Palm API Guide


Header Files » Incs » common » libraries » pmconnectorlib

PmConnectorLibCommon.h

Go to the documentation of this file.
00001 /*******************************************************************************
00002  * Copyright (c) 2004-2005 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  ******************************************************************************/
00005 /**
00006  * @defgroup    PmConnectorLib Multi Connector Library
00007  * @brief       This library provides support for multi-connector related functionalities.
00008  *
00009  * Applications can register itself to be notified when a peripheral is attached
00010  * or detached to the multi-connector port. Applications can also use this library
00011  * to enable/disable the power pin and to re-route audio output.
00012  *
00013  * @{
00014  * @}
00015  */
00016 /**
00017  * @ingroup PmConnectorLib
00018  */
00019
00020 /**
00021  * @file  PmConnectorLibCommon.h
00022  * @brief Public 68k common header file for Multi-Connector Library for palmOne
00023  *        devices that use multi-connector.
00024  *
00025  * This file contains common structures, types and defines for palmOne library
00026  * that exports multi-connector related APIs.
00027  * <hr>
00028  */
00029
00030 #ifndef __PMConnectorLIBCOMMON_H__
00031 #define __PMConnectorLIBCOMMON_H__
00032
00033 #include <NotifyMgr.h>
00034
00035 /********************************************************************
00036  * Constants
00037  ********************************************************************/
00038 #define kPmConnectorLibType             sysFileTLibrary
00039 #define kPmConnectorLibCreator          'PmAt'
00040 #define kPmConnectorLibName             "PmConnector"
00041 #define kPmConnectorNotifyType              'PmCo'
00042 #define kPmConnectorNotifySysAttach         sysExternalConnectorAttachEvent
00043 #define kPmConnectorNotifySysDetach         sysExternalConnectorDetachEvent
00044
00045 // Bits used in notifyDetailsP for kPmConnectorNotifySysAttach and kPmConnectorNotifySysDetach
00046 #define kPmDockStatusCharging           0x08
00047 #define kPmDockStatusUSBCradle          0x10
00048 #define kPmDockStatusSerialPeripheral   0x40
00049
00050 /********************************************************************
00051  * Traps
00052  ********************************************************************/
00053 /**
00054  * @name Function Traps
00055  */
00056 /*@{*/
00057 #define kPmConnectorLibTrapOpen         sysLibTrapOpen
00058 #define kPmConnectorLibTrapClose        sysLibTrapClose
00059 #define kPmConnectorLibTrapSleep        sysLibTrapSleep
00060 #define kPmConnectorLibTrapWake         sysLibTrapWake
00061 #define kPmConnectorLibTrapGetVersion       (sysLibTrapCustom + 0)
00062 #define kPmConnectorLibTrapControl          (sysLibTrapCustom + 1)
00063 #define kPmConnectorLibTrapSetAudioOutput   (sysLibTrapCustom + 2)
00064 #define kPmConnectorLibTrapSetAudioInput    (sysLibTrapCustom + 3)
00065 /*@}*/
00066
00067 /***********************************************************************
00068  * Library version
00069  ***********************************************************************/
00070 #define     kPmConnectorLibVersion  sysMakeROMVersion(1, 3, 2, sysROMStageRelease, 0)
00071
00072
00073 /***********************************************************************
00074  * PmConnectorLib result codes
00075  * (appErrorClass is reserved for 3rd party apps/libraries.
00076  * It is defined in SystemMgr.h)
00077  ***********************************************************************/
00078 /**
00079  * @name Error Codes
00080  */
00081 /*@{*/
00082 #define kPmConnectorLibErrorClass           (oemErrorClass + 0x100)
00083 /* Invalid parameter */
00084 #define kPmConnectorLibErrBadParam          (kPmConnectorLibErrorClass | 0x01)
00085 /* Memory error */
00086 #define kPmConnectorLibErrNoMemory          (kPmConnectorLibErrorClass | 0x02)
00087 /* Library is not open */
00088 #define kPmConnectorLibErrNotOpen           (kPmConnectorLibErrorClass | 0x03)
00089 /* Returned from PmConnectorLibClose() if the library is still open */
00090 #define kPmConnectorLibErrStillOpen         (kPmConnectorLibErrorClass | 0x04)
00091 /* Internal erro */
00092 #define kPmConnectorLibErrInternal          (kPmConnectorLibErrorClass | 0x05)
00093 /* Unsupported function */
00094 #define kPmConnectorLibErrNotSupported      (kPmConnectorLibErrorClass | 0x06)
00095 /* Bad version */
00096 #define kPmConnectorLibErrNotCompatible (kPmConnectorLibErrorClass | 0x07)
00097 /*@}*/
00098
00099 /***********************************************************************
00100  * Constants - control commands
00101  ***********************************************************************/
00102
00103 /**
00104  * @name Control commands for Connector
00105  */
00106 /*@{*/
00107 #define kPmConnectorLibCtrlPowerOn              0x01
00108 #define kPmConnectorLibCtrlPowerOff             0x02
00109 #define kPmConnectorLibCtrlGetDeviceClass       0x03
00110 /*@}*/
00111
00112 /***********************************************************************
00113  * Notification constants
00114  ***********************************************************************/
00115
00116 /**
00117  * @name Notification Constants
00118  */
00119 /*@{*/
00120 #define kPmConnectorClassAudioWHeadset          0x05 // was 0x00 in versions <= 1.2.0
00121 #define kPmConnectorClassAudioNoHeadset         0x00 // was 0x01 in versions <= 1.2.0
00122 #define kPmConnectorClassCarkit                 0x01 // was 0x02 in versions <= 1.2.0
00123 #define kPmConnectorClassGenericSerial          0x03
00124 #define kPmConnectorClassSmartSerial            0x07
00125 #define kPmConnectorClassSerial                 0x10
00126 #define kPmConnectorClassUSB                    0xf0
00127 #define kPmConnectorClassUnknown                0x00ff
00128 #define kPmConnectorClassNoDevice               0x0fff
00129 #define kPmConnectorClassMask                   0x0fff
00130 /*@}*/
00131
00132
00133 /** @brief State of the connector */
00134 typedef enum {
00135     kPmConnectorDeviceAttach = 0x8000,  /**< is currently attached */
00136     kPmConnectorDeviceDetach = 0x4000   /**< is currently detached */
00137 } ePmConnectorDeviceState;
00138
00139 typedef UInt16 PmConnectorStateType;
00140
00141 /** @brief Container for the notification details */
00142 typedef struct {
00143     UInt32                  serialPortId;
00144     UInt32                  deviceClass;
00145     UInt32                  athenaDeviceCreatorCode;
00146     UInt32                  reserved1;
00147     UInt32                  reserved2;
00148 } PmConnectorNotifyDataType;
00149
00150 /**
00151  * @brief Audio Output Routings
00152  */
00153 typedef enum tagAudioOutputSetting
00154 {
00155     kAudioOutputSettingDefault = 0,  //device should do something reaasonable based on its current capabilities
00156     kAudioOutputSettingHeadphone,
00157     kAudioOutputSettingAthena,
00158     kAudioOutputSettingSpeaker
00159 } ePmConnectorAudioOutputSettingsType;
00160
00161 /** Audio Output setting type */
00162 typedef UInt16 PmConnectorAudioOutputSettingType;
00163
00164 typedef enum tagAudioInputSetting
00165 {
00166     kAudioInputDefault = 0,  //device should do something reaasonable based on its current capabilities
00167     kAudioInputExternalMic,
00168     kAudioInputInternalMic
00169 } ePmConnectorAudioInputSettingsType;
00170
00171 typedef UInt16 PmConnectorAudioInputSettingType;
00172
00173
00174 /** Library control type */
00175 typedef UInt16 PmConnectorLibControlType;
00176
00177 #endif // __PMConnectorLIBCOMMON_H__
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:55 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » pmkeylib

PmKeyLib.h

Go to the documentation of this file.
00001 /******************************************************************************
00002  * Copyright (c) 2004 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  *****************************************************************************/
00005 /**
00006  * @ingroup PmKeyLib
00007  */
00008
00009 /**
00010  * @file  PmKeyLib.h
00011  * @brief System Library that exports key-related APIs.
00012  *
00013  * This library is based on key APIs from HsExtensions and was broken apart from HsExtensions
00014  * so the APIs could be ported to other platforms.
00015  *
00016  */
00017
00018 /*
00019  * $Id$
00020  *
00021  *****************************************************************************/
00022
00023 #ifndef __PMKEYLIB_H__
00024 #define __PMKEYLIB_H__
00025
00026
00027 #include <PmKeyLibCommon.h>
00028
00029 /********************************************************************
00030  * Prototypes
00031  ********************************************************************/
00032
00033 #ifdef __cplusplus
00034 extern "C" {
00035 #endif
00036
00037 /// Standard open library function
00038 ///
00039 /// @param refNum: IN: library reference number (returned by SysLibFind() / SysLibLoad() )
00040 /// @retval Err error code.
00041 Err
00042 PmKeyLibOpen (UInt16 refNum)
00043             SYS_TRAP (kPmKeyLibTrapOpen);
00044
00045 /// Standard close library function
00046 ///
00047 /// @param refNum: IN: library reference number (returned by SysLibFind() / SysLibLoad() )
00048 /// @retval Err error code.
00049 Err
00050 PmKeyLibClose (UInt16 refNum)
00051             SYS_TRAP (kPmKeyLibTrapClose);
00052
00053 /// Get the current state of specified keys
00054 ///
00055 /// @param refNum:      IN:  library reference number (returned by SysLibFind() / SysLibLoad() )
00056 /// @param count:       IN:  number of elements in keyCodes[] and pressed[]
00057 /// @param keyCodes:    IN:  array of keyCodes to test
00058 /// @param pressed:     OUT: Each element is set to true if the key specified by the
00059 ///                          corresponding element in keyCodes[] is pressed, and set
00060 ///                          to false if it is not pressed.
00061 ///                          It is acceptable to pass NULL if only the return value is of interest.
00062 /// @retval UInt16 count of keys that are pressed.
00063 UInt16
00064 PmKeyKeysPressed (UInt16 refNum, UInt16 count, const UInt16 keyCodes[], Boolean pressed[])
00065             SYS_TRAP (kPmKeyLibTrapKeysPressed);
00066
00067 /// Stop a key from sending any more auto repeat events until
00068 /// it is released.
00069 ///
00070 /// @param refNum:      IN: library reference number (returned by SysLibFind() / SysLibLoad() )
00071 /// @param keyCode:     IN: key to stop
00072 /// @retval Err errNone if the keyCode is the last key pressed and it is still held.
00073 Err
00074 PmKeyStop (UInt16 refNum, UInt16 keyCode)
00075             SYS_TRAP (kPmKeyLibTrapStop);
00076
00077 /// Enable/disable a key from generating key events.
00078 /// This extends HALKeySetMask().
00079 ///
00080 /// @param refNum:  IN: library reference number (returned by SysLibFind() / SysLibLoad() )
00081 /// @param keyCode: IN: the key to enable/disable
00082 /// @param enabled: IN: true to enable, false to disable
00083 /// @retval Boolean true if previously enabled
00084 Boolean
00085 PmKeyEnableKey (UInt16 refNum, UInt16 keyCode, Boolean enabled)
00086             SYS_TRAP (kPmKeyLibTrapEnableKey);
00087
00088 /// Determine which key generates a certain character
00089 /// This is the complement of HALKeyKeyCodeToChrCode()
00090 ///
00091 /// @param refNum:  IN: library reference number (returned by SysLibFind() / SysLibLoad() )
00092 /// @param chrCode: IN: the character to search for
00093 /// @retval UInt16 the keycode returned.
00094 UInt16
00095 PmKeyChrCodeToKeyCode (UInt16 refNum, UInt16 chrCode)
00096             SYS_TRAP (kPmKeyLibTrapChrCodeToKeyCode);
00097
00098 /// Translate a key code to the character generated by that key.
00099 /// Each key can generate several different characters, depending
00100 /// on which modifier keys are held when it is pressed. The caller
00101 /// needs to specify which modified state of the key should be used
00102 /// to select the appropriate character.
00103 /// This is the complement of HALKeyChrCodeToKeyCode().
00104 ///
00105 /// @param refNum:          IN:  library reference number (returned by SysLibFind() / SysLibLoad() )
00106 /// @param keyCode:         IN:  the key to lookup
00107 /// @param modifiersIn:     IN:  Modifier mask indicating which character
00108 ///                              should be returned
00109 /// @param chrP:            OUT: The character produced by the key
00110 /// @param modifiersOutP:   OUT: The keyMask bits that must be set if a keyDown event is
00111 ///                              formed with the character. (Not including the bits
00112 ///                              set in modifiersIn)
00113 /// @retval None.
00114 void
00115 PmKeyKeyCodeToChrCode (UInt16 refNum, UInt16 keyCode, UInt16 modifiersIn,
00116                        UInt16* chrP, UInt16* modifiersOutP)
00117             SYS_TRAP (kPmKeyLibTrapKeyCodeToChrCode);
00118
00119 /// Determine if an event came from the physical keyboard
00120 ///
00121 /// @param refNum: IN: library reference number (returned by SysLibFind() / SysLibLoad() )
00122 /// @param eventP: IN: the event to check
00123 /// @retval Boolean true if the event came from the keyboard
00124 Boolean
00125 PmKeyEventIsFromKeyboard (UInt16 refNum, EventPtr eventP)
00126             SYS_TRAP (kPmKeyLibTrapEventIsFromKeyboard);
00127
00128 /// Get any palmOne specific key attributes that aren't
00129 /// appropriate to be accessed through a feature. (e.g.
00130 /// dynamic information about device state)
00131 ///
00132 /// The following code sample retrieves the keyguard state (active or
00133 /// inactive) and disables it accordingly.
00134 /// @code
00135 ///     UInt32 keyguard;
00136 ///     PmKeyAttrGet (pmKeyAttrKeyboardLocked, 0, &keyguard);
00137 ///     if (keyguard)
00138 ///     {
00139 ///         keyguard = 0;
00140 ///         PmKeyAttrSet (pmKeyAttrKeyboardLocked, 0, &keyguard);
00141 ///     }
00142 /// @endcode
00143 ///
00144 /// Note that there are new attributes added for version 3 of the
00145 /// PmKeyAttrGet() function, so it is highly recommended that any
00146 /// application that calls this function does one or both of the
00147 /// following:
00148 ///
00149 /// Check the return code.  If its hsErrNotSupported, then the attribute
00150 /// that the function is looking for is NOT SUPPORTED using that particular
00151 /// version of the library!
00152 ///
00153 ///  - OR -
00154 ///
00155 /// Check the version number of the PmKeyLib. To do this, load the PmKeyLib
00156 /// and then get the feature with creator = kPmKeyLibCreator and featureNum =
00157 /// kPmKeyLibFtrValAPIVersion.  Note that if the feature does not exist (and
00158 /// the library successfully loaded), they can assume that it's version 1.0
00159 /// of PmKeyLib.  If the feature does exist, then perform a check similar to
00160 /// the following:
00161 ///
00162 /// @code
00163 ///   if (sysGetLibAPIVersionMajor(pmKeyLibVersion) >= 3)
00164 ///   {
00165 ///     PmKeyAttrGet ( Version3Attribute, 0 , &value );
00166 ///   }
00167 ///    else
00168 ///    {
00169 ///      // PmKeyLib is version 2, use ONLY version 2 attributes for PmKeyAttrGet
00170 ///     PmKeyAttrGet ( Version2Attribute, 0 , &value );
00171 ///    }
00172 /// @endcode
00173 ///
00174 /// @param refNum:  IN:  library reference number (returned by SysLibFind() / SysLibLoad() )
00175 /// @param attr:    IN:  the attribute being retrieved @see PmKeyAttrEnum
00176 /// @param flags:   IN:  depends on attr (currently implemented attributes only take 0 for this argument)
00177 /// @param valueP:  OUT: cast depending on attr (refer to PmKeyAttrEnum for data type this argument should point to)
00178 /// @retval Err error code. 0 if no error, hsErrNotSupported otherwise.
00179 Err
00180 PmKeyAttrGet (UInt16 refNum, UInt16 attr /*PmKeyAttrEnum*/, UInt32 flags, UInt32* valueP)
00181             SYS_TRAP (kPmKeyLibTrapAttrGet);
00182
00183 /// Set palmOne specific attributes
00184 ///
00185 /// @param attr:    IN: the attribute being set
00186 /// @param flags:   IN: depends on attr (currently implemented attributes only take 0 for this argument)
00187 /// @param value:   IN: cast depending on attr (refert to PmKeyAttrEnum for data type this argument should point to)
00188 /// @retval Err error code. 0 if no error, hsErrNotSupported otherwise.
00189 Err
00190 PmKeyAttrSet (UInt16 refNum, UInt16 attr /*PmKeyAttrEnum*/, UInt32 flags, UInt32 value)
00191             SYS_TRAP (kPmKeyLibTrapAttrSet);
00192
00193 #ifdef __cplusplus
00194 }
00195 #endif
00196
00197 #endif  // __PMKEYLIB_H__
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:55 2008 for Palm API Guide


Header Files » Incs » common » libraries » pmkeylib

PmKeyLibCommon.h

Go to the documentation of this file.
00001 /*******************************************************************************
00002  * Copyright (c) 2004-2005 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  ******************************************************************************/
00005 /**
00006  * @defgroup    PmKeyLib Key Library
00007  * @brief       This library provides support for the key-related functionalities.
00008  *
00009  * Application can use this library to detect the state of particular keys, whether
00010  * they are pressed or released. This library can also be used to enable/disable
00011  * a certain key programmatically, translate keycodes to characters, and also manage
00012  * the different settings of the keypad.
00013  *
00014  * @{
00015  * @}
00016  */
00017 /**
00018  * @ingroup PmKeyLib
00019  */
00020
00021 /**
00022  * @file  PmKeyLibCommon.h
00023  * @brief Public 68k common header file for system library that exports key-related APIs.
00024  *
00025  * This library is based on key APIs from HsExtensions and was broken apart from
00026  * HsExtensions so the APIs could be ported to other platforms.
00027  */
00028
00029 #ifndef __PMKEYLIBCOMMON_H__
00030 #define __PMKEYLIBCOMMON_H__
00031
00032 #include <palmOneSystemCommon.h>    // for sysMakeLibAPIVersion
00033
00034 /********************************************************************
00035  * Constants and Enums
00036  ********************************************************************/
00037
00038 #define kPmKeyLibType               sysFileTLibrary /**< standard library type */
00039 #define kPmKeyLibCreator            pmFileCKeyLib   /**< PmKeyLib creator ID */
00040 #define kPmKeyLibName               "PmKeyLib-PmKe" /**< PmKeyLib database name */
00041 #define kPmKeyLibAPIMajorVersion    3   /**< Major version incremented when API
00042                                              changes */
00043 #define kPmKeyLibAPIMinorVersion    0   /**< Minor version incremented with
00044                                              each release of library that
00045                                              doesn't change the API */
00046 #define kPmKeyLibAPIVersion         sysMakeLibAPIVersion(kPmKeyLibAPIMajorVersion, kPmKeyLibAPIMinorVersion)
00047
00048
00049 /**
00050  * @name Feature values
00051  */
00052 /*@{*/
00053 #define kPmKeyLibFtrValAPIVersion   0   /**< Feature value used to get/set
00054                                              library API version
00055                                              (kPmKeyLibAPIVersion).  Note
00056                                              that the first release of the
00057                                              library did not set this feature.
00058                                              Therefore, if the library does
00059                                              exist but the feature does not,
00060                                              you can assume the major version
00061                                              of the library is 1.  Note also
00062                                              that the feature is not set
00063                                              until library is loaded so you
00064                                              must load PmKeyLib before getting
00065                                              the feature */
00066 /*@}*/
00067
00068
00069
00070 // Add in once we need public attributes
00071 enum PmKeyAttrEnumTag
00072 {
00073   /*
00074    * End of enums in API version 1 (no enums defined in version 1)
00075    */
00076
00077
00078   pmKeyAttrPagingMode,          /**< Whether currently pressed key is in page mode */
00079
00080   /*
00081    * End of enums in API version 2
00082    */
00083
00084   pmKeyAttrGetLauncherKeyCode,  /**< Returns the key code for the Launcher key */
00085   pmKeyAttrGetMenuKeyCode,      /**< Returns the key code for the Menu key */
00086   pmKeyAttrGetSendKeyCode,      /**< Returns the key code for the Send key */
00087   pmKeyAttrGetEndKeyCode,       /**< Returns the key code for the End key */
00088   pmKeyAttrGetPhoneKeyCode      /**< Returns the key code for the Phone key */
00089
00090   /*
00091    * End of enums in API version 3
00092    */
00093
00094
00095   /*
00096    * Attributes greater than 0x9000 are defined for internal use
00097    * in Prv/PmPrvKeyLibCommon.h
00098    */
00099 };
00100 typedef UInt16 PmKeyAttrEnum;
00101
00102
00103 /********************************************************************
00104  * Traps
00105  ********************************************************************/
00106 /**
00107  * @name Function Traps
00108  */
00109 /*@{*/
00110 #define kPmKeyLibTrapOpen                     sysLibTrapOpen
00111 #define kPmKeyLibTrapClose                    sysLibTrapClose
00112 #define kPmKeyLibTrapKeysPressed              (sysLibTrapCustom)
00113 #define kPmKeyLibTrapStop                     (sysLibTrapCustom+1)
00114 #define kPmKeyLibTrapEnableKey                (sysLibTrapCustom+2)
00115 #define kPmKeyLibTrapChrCodeToKeyCode         (sysLibTrapCustom+3)
00116 #define kPmKeyLibTrapKeyCodeToChrCode         (sysLibTrapCustom+4)
00117 #define kPmKeyLibTrapEventIsFromKeyboard      (sysLibTrapCustom+5)
00118 #define kPmKeyLibTrapAttrGet                  (sysLibTrapCustom+6)
00119 #define kPmKeyLibTrapAttrSet                  (sysLibTrapCustom+7)
00120 /*
00121  * End of traps in API version 1
00122  */
00123
00124 /*@}*/
00125
00126 #endif // __PMKEYLIBCOMMON_H__
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:55 2008 for Palm API Guide


Header Files » Incs » common » libraries

PmLibErrors.h

Go to the documentation of this file.
00001 /******************************************************************************
00002  * Copyright (c) 2004 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  *****************************************************************************/
00005 /**
00006  * @ingroup SystemDef
00007  */
00008
00009 /**
00010  * @file  PmLibErrors.h
00011  * @brief Errors common to all our portable Pm Libraries
00012  *
00013  */
00014
00015 /* (these libraries share the same error class since we are so limited in the
00016  * number of OEM error classes we can define)
00017  *
00018  * \author Debbie Chyi
00019  *
00020  * $Id: //device/Handheld/Dev/SDK/2.0/Incs/Common/Libraries/PmLibErrors.h
00021  *
00022  *****************************************************************************/
00023
00024 #ifndef __PM_LIB_ERRORS_H__
00025 #define __PM_LIB_ERRORS_H__
00026
00027 #include <Common/System/HsErrorClasses.h>
00028
00029
00030 #define pmErrNotSupported                     (pmLibErrorClass | 0x01)
00031
00032
00033 #endif // __PM_LIB_ERRORS_H__
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:55 2008 for Palm API Guide


Header Files » Incs » 68k » system

PmPalmOSNVFS.h

Go to the documentation of this file.
00001 /******************************************************************************
00002  * Copyright (c) 2005 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  *****************************************************************************/
00005 /**
00006  *@ingroup System
00007  *
00008  */
00009
00010 /**
00011  * @file    PmPalmOSNVFS.h
00012  * @brief Public 68k header file containing the definitions and API for NVFS devices.
00013  *
00014  *
00015  * <hr>
00016  */
00017
00018
00019 #ifndef __PMPALMOSNVFS_H__
00020 #define __PMPALMOSNVFS_H__
00021
00022 #define sysFtrNumDmAutoBackup       31      /**< Is Data Manager Auto Backup supported? */
00023 #define vfsVolumeAttrNonRemovable       (0x00000008UL)  /**< media is non-removable */
00024 #define expCapabilityNonRemovable   0x00000008  /**< card is non-removable */
00025 #define expCapabilityHidden     0x00000010  /**< card is hidden */
00026 #define sysTrapDmSyncDatabase       0xA476      /**<        */
00027 #define vfsIncludePrivateVolumes    0x80000000  /**< Use this flag to show hidden volumes if the device supports hidden volumes */
00028 #define expIncludePrivateSlots      0x80000000  /**< Use this flag to show hidden expansion slots if the device supports hidden slots */
00029 #define dbCacheFlag         0x8000      /**< Flag is used in query the DbCache size when ORd with Storage heap id */
00030
00031 #ifdef  sysTrapLastTrapNumber
00032
00033   #undef  sysTrapLastTrapNumber         /**<        */
00034   #define sysTrapLastTrapNumber     0xA477  /**<        */
00035
00036 #endif // sysTrapLastTrapNumber
00037
00038 /**
00039  * @brief Commit changes in the database to the non-volatile memory
00040  *
00041  * @param dbRef:    IN: Reference to the opened database to be synced/committed
00042  * @retval Err error code.
00043  */
00044 Err     DmSyncDatabase (DmOpenRef dbRef)
00045         SYS_TRAP (sysTrapDmSyncDatabase);
00046
00047
00048 #endif // __PMPALMOSNVFS_H__
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:55 2008 for Palm API Guide


Header Files » Incs » common » libraries » hssoundlib

PmSoundLibAudioGroup.h

Go to the documentation of this file.
00001 /*******************************************************************************
00002  * Copyright (c) 2004-2005 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  ******************************************************************************/
00005 /**
00006  * @ingroup Sound
00007  *
00008  */
00009
00010 /**
00011  *
00012  * @file    PmSoundLibAudioGroup.h
00013  * @brief   Public 68K header file used to associate sound channels with Audio
00014  *          groups on Treo 600 and Treo 650 smartphones.
00015  *
00016  *   We define the concept of Audio Groups to classify sounds depending
00017  *   on the relative importance to the user:
00018  *
00019  *        pmAudioGroupApp    Audio normally generated by user applications
00020  *                           such as games, MP3 players, and others. This is the default
00021  *                           classification even if no audio group is assigned.
00022  *
00023  *        pmAudioGroupSystem Typical audio events generated by the system to
00024  *                           give audible feedback to the user about system events.
00025  *                           Most of the sounds produced through SndPlaySystemSound are
00026  *                           classified internally as System.
00027  *
00028  *        pmAudioGroupAlert  Alerts, Alarms, and Ringtones should be given this classification.
00029  *                           If you depend on the Attention Manager to make a sound, it will also
00030  *                           use this classification. The constant sndAlarm when calling
00031  *                           SndPlaySystemSound is classified as an Alert.
00032  *
00033  *        pmAudioGroupHighPriority
00034  *                           Sounds of great importance to the
00035  *                           user and that are routed with the highest priority.
00036  *                           We currently define hsSndBatLow and hsSndBatShutdown constants,
00037  *                           when calling SndPlaySystemSound, as high priority sounds.
00038  *
00039  *  If you depend on PalmOS Attention Manager for audio alerts, or use PalmOS
00040  *  SndPlaySystemSound, then the audio group is automatically assigned, and there
00041  *  is nothing else you need to do.
00042  *
00043  *  However, if you directly play audio events using other PalmOS APIs such
00044  *  as SndPlayResource, or SndStreamCreate, for example, then you may want
00045  *  to assign the audio group, unless the default pmAudioGroupApp is
00046  *  sufficient for your purposes.
00047  *
00048  *  To assign an audio group we attach that additional information
00049  *  to the PalmOS volume parameter associated with many of the Sound Manager
00050  *  API calls. We have found this is the most effective way to associate
00051  *  the audio group to a sound channel, and have that information filter down,
00052  *  through PalmOS, to our Audio Driver in the Hardware Abstraction Layer (HAL).
00053  *  In this way, there is no need to modify PalmOS, and we can allow a variety
00054  *  of components and applications to take advantage of the behavior and custom
00055  *  routing we assign to the different audio group classifications.
00056  *
00057  *  The drawback is that when the audio group is attached to the volume parameter,
00058  *  then the volume is limited to a maximum of 8K - 1, in steps of 8 (which
00059  *  represents 128 levels to unity). In contrast PalmOS 5.x volume parameter
00060  *  is defined with a maximum of 32K - 1, in steps of 1 (which represents
00061  *  1024 levels to unity). Our constrain is generally acceptable, since it
00062  *  represents granularity of about 1 dB step changes, with up to 8X amplification
00063  *  We currently use less precise granularity of > 10 db step changes, and a
00064  *  maximum of 6X amplification for the case of QCELP/AMR playback.
00065  *
00066  *  There is a risk that an existing application using the PalmOS API may
00067  *  apply a volume parameter that could be mistaken for a volume plus audio
00068  *  group designation, but this risk is fairly minimal as explained next.
00069  *
00070  *  The Audio Group uses a mark in the upper 3-bits of the volume parameter.
00071  *  If this mark is binary '011' which means a positive number >= 24K, then
00072  *  we will interpret the lower three bits as the audio group. The risk of
00073  *  mistaken interpretation from existing PalmOS applications will happen
00074  *  when the application request amplifications of 24X to 32X. In our
00075  *  experience we have Not seen any application going beyond the range of
00076  *  2X to 8X amplification. In case such extremely rare condition do
00077  *  occurs, the effect would be that the range 24X to 32X will be treated
00078  *  as the lower range of 0X to 8X, and there is a chance the sound will
00079  *  be routed/treated as other than application audio.
00080  *
00081  *  One more thing to note is that PalmOS allows negative numbers in the
00082  *  volume parameter to mean one of the usual volume parameters the
00083  *  user may adjust through the preferences panel: system volume, game
00084  *  volume, and alarm volume. In our current implementation we do NOT
00085  *  change these values, and we do NOT assign any audio group designation
00086  *  to these preferences driven volume settings. In other words, they
00087  *  will be treated as application audio group.
00088  *
00089  *  The use of Audio Group in a device will be present when the feature
00090  *  is registered with the PalmOS Feature Manager. This feature will
00091  *  be available when:
00092  *
00093  *     FtrGet( pmSoundLibCreatorID, pmSoundLibAudioGroupFtr, &value );
00094  *
00095  *  return no error, and the UInt32 value is NOT:
00096  *
00097  *     pmSoundLibAudioGroupFtr_Off
00098  *
00099  *  It is important to always check for this feature, since this is
00100  *  a custom enhancement which could be turned off for some future
00101  *  device, or platform.
00102  *
00103  *  To assign an audio group to your volume parameter you will invoke
00104  *  the function PmSndAddAudioGroupToVolume (currently implemented as
00105  *  a macro for simplicity). Here is an example on how to use this:
00106  *
00107  *  @code
00108  *
00109  *      // Includes
00110  *      #include <FeatureMgr.h>
00111  *      #include <Common/Libraries/HsSoundLib/PmSoundLibAudioGroup.h>
00112  *
00113  *      // Declarations
00114  *      UInt32 value  = 0;    // temporary variable for FtrGet
00115  *      Int32  volume = 1024; // default max amplitude in PalmOS 5.x, can also use sndMaxAmp with earlier PalmOS
00116  *
00117  *      // Code Snippet
00118  *      if (   ( !FtrGet( pmSoundLibCreatorID, pmSoundLibAudioGroupFtr, &value ) ) // is the Audio Group feature supported?
00119  *          && ( value != pmSoundLibAudioGroupFtr_Off ) ) // is the Audio Group feature active?
00120  *      {
00121  *          volume = PmSndAddAudioGroupToVolume( volume, pmAudioGroupAlert ); // then, mark this sound as an alert
00122  *      }
00123  *      SndPlayResource( mySound, volume, sndFlagNormal );
00124  *
00125  *  @endcode
00126  *  <hr>
00127  */
00128
00129
00130 #ifndef PMSOUNDLIBAUDIOGROUP_H_
00131 #define PMSOUNDLIBAUDIOGROUP_H_
00132
00133 /***********************************************************************
00134  * Palm OS common definitions
00135  ***********************************************************************/
00136 #include <HsSoundLibCommon.h> /**<Included for hsSoundLibCreatorID. */
00137
00138 /**
00139  * @name PmSoundLibAudioGroup information
00140  *
00141  */
00142 /*@{*/
00143 #define pmSoundLibCreatorID         hsSoundLibCreatorID /**<Pass this as the creator ID used in FtrGet. */
00144 #define pmSoundLibAudioGroupFtr     0x0001 /**<Use this as the featureNum passed to FtrGet. */
00145 #define pmSoundLibAudioGroupFtr_Off 0      /**<Value returned in *valueP of FtrGet when Audio Group is disabled. */
00146 #define pmSoundLibAudioGroupFtr_On  1      /**<Value returned in *valueP of FtrGet when Audio Group is enabled */
00147 /*@}*/
00148
00149 #define PM_AUDIOGROUP_MASK     0xE007 /**<No definition. */
00150
00151 /**
00152  * Holds audio group information.
00153  */
00154 typedef enum PmAudioGroupEnum
00155 {
00156     pmAudioGroupNone         = 0x0000, /**<Default audio group when volume is less than 24K. */
00157     pmAudioGroupApp          = 0x6000, /**<Application audio, treated as pmAudioGroupNone, but group type saved. */
00158     pmAudioGroupSystem       = 0x6001, /**<System audio (as in SndPlaySystemSound). */
00159     pmAudioGroupAlert        = 0x6002, /**<Alert, alarms, ringtones that notify user of an event. */
00160     pmAudioGroupHighPriority = 0x6003, /**<Extremely important event such as low battery shutdown. */
00161
00162     pmAudioGroupInteractive  = 0x6004, /**<Application audio to be used for interactive playback (eg: games). */
00163     pmAudioGroupStreaming    = 0x6005, /**<Application audio to be used for streaming (eg: MP3, video, broadcast). */
00164     pmAudioGroupCall         = 0x6006, /**<Intended for digital phone call audio only. Used for internal purposes. */
00165     pmAudioGroupAlertRingOff = 0x6007  /**<Same as pmAudioGroupAlert, but ignores Ringer switch position */
00166
00167 } PmAudioGroupEnum;
00168
00169 /** @see PmAudioGroupEnum */
00170 typedef UInt16 PmAudioGroup;
00171
00172
00173 /**
00174  * @name Audio Group API functions
00175  *
00176  * Implemented as macros.
00177  */
00178 /*@{*/
00179 #define PmSndAddAudioGroupToVolume(volume,audioGroup)  (Int32)       (((!audioGroup) || (((Int32)(volume)) <= -1))? (volume) : ((((((volume) & 0xE000) == 0x6000)? (volume):(volume)+7) & ~PM_AUDIOGROUP_MASK) | (audioGroup)))/**<Attaches an audio group designation to a PalmOS volume parameter.
00180
00181  Use this macro if you want your sound channel to be designated differently
00182  than application sound.
00183
00184  If this macro were implemented as a function, the prototype would be:
00185
00186  Int32 //returned volume // PmSndAddAudioGroupToVolume  ( Int32 volume, PmAudioGroup audioGroup );
00187 */
00188 #define PmSndRemoveAudioGroupFromVolume(volume)         (Int32)       ((((Int32)(volume)) < 0x6000)? (volume) : ((volume) & ~PM_AUDIOGROUP_MASK ))
00189 /**<Removes the audio group designation from a PalmOS volume parameter.
00190
00191  Use this if you previously attached a sound group designation and
00192  retrieve that volume again using PalmOS APIs. Or if you need to
00193  manipulate the overloaded volume parameter, as a volume only value.
00194
00195  If this macro were implemented as a function, the prototype would be:
00196
00197  Int32 //returned volume // PmSndRemoveAudioGroupFromVolume ( Int32 volume );
00198 */
00199
00200 #define PmSndGetAudioGroupFromVolume(volume)            (PmAudioGroup)((((Int32)(volume)) < 0x6000)? (pmAudioGroupNone) : ((volume) & PM_AUDIOGROUP_MASK))
00201 /**<Removes the volume component of a PalmOS volume parameter, leaving
00202  a pure audio group component.
00203
00204  Use this if you have already attached the audio group to a volume
00205  parameter and need to identify the audio group designation.
00206
00207  If this macro were implemented as a function, the prototype would be:
00208
00209  PmAudioGroup PmSndGetAudioGroupFromVolume ( Int32 volume );
00210 */
00211 /*@}*/
00212
00213 #endif /* #ifndef PMSOUNDLIBAUDIOGROUP_H_ */
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:55 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » pmsysgadgetlib

PmSysGadgetLib.h

Go to the documentation of this file.
00001 /******************************************************************************
00002  * Copyright (c) 2004 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  *****************************************************************************/
00005 /**
00006  * @ingroup PmSysGadgetLib
00007  */
00008
00009 /**
00010  * @file    PmSysGadgetLib.h
00011  * @version 1.0
00012  * @brief   System Library that exports status-related APIs.
00013  *
00014  * This library is based on status gadgets APIs from HsExtensions and
00015  * was broken apart from HsExtensions so the APIs could be ported to other platforms.
00016  *
00017  */
00018
00019 /*
00020  * $Id: //depot/Components/Libraries/PmSysGadget/1.2D/Incs/IncsPublic/68K/Libraries/PmSysGadget/PmSysGadgetLib.h#1 $
00021  *
00022  */
00023
00024 #ifndef __PM_STATUS_LIB_H__
00025 #define __PM_STATUS_LIB_H__
00026
00027 #include <PmSysGadgetLibCommon.h>
00028 #include <PalmTypes.h>
00029
00030 /********************************************************************
00031  * Prototypes
00032  ********************************************************************/
00033
00034 #ifdef __cplusplus
00035 extern "C" {
00036 #endif
00037
00038 /**
00039  * @brief Standard library open routine
00040  *
00041  * @param   refNum: IN: Library reference number
00042  * @retval  Err     Error Code
00043  */
00044 Err
00045 PmSysGadgetLibOpen (UInt16 refNum)
00046             SYS_TRAP (kPmSysGadgetLibTrapOpen);
00047 /**
00048  * @brief Standard library close routine
00049  *
00050  * @param   refNum: IN: Library reference number
00051  * @retval  Err     Error Code
00052  */
00053 Err
00054 PmSysGadgetLibClose (UInt16 refNum)
00055             SYS_TRAP (kPmSysGadgetLibTrapClose);
00056
00057 /**
00058  * @brief Tell the system that a gadget on the form is a certain type of status gadget so that
00059  *        the system can properly draw and update it.
00060  *
00061  * Tell the system that a gadget on the form is a certain type of status gadget so that
00062  * the system can properly draw and update it.
00063  * A form can only have one gadget for each status type. If more than one gadget is
00064  * set to a certain type, only the last one set will be recorded. This function can also be
00065  * used to erase and release a gadget whose type has already been set. To do this, type
00066  * should be set to 0.
00067  *
00068  * @param   refNum:     IN: Library reference number
00069  * @param   frmP:       IN: Form to draw gadget on
00070  * @param   gadgetID:   IN: Gadget resource ID
00071  * @param   type:       IN: Gadget type (battery, signal, bluetooth, etc)
00072  * @retval  Err         Error code
00073  */
00074 Err
00075 PmSysGadgetStatusGadgetTypeSet (UInt16 refNum, void* frmP, UInt16 gadgetID,
00076                                 UInt16 /*PmStatusGadgetTypeEnum*/ type)
00077             SYS_TRAP (kPmSysGadgetLibTrapStatusGadgetTypeSet);
00078
00079 /**
00080  * @brief Explicitly update all status gadgets on the current form.
00081  *
00082  * @param   refNum: IN: Library reference number
00083  * @retval  Nothing
00084  */
00085 void
00086 PmSysGadgetStatusGadgetsUpdate (UInt16 refNum)
00087             SYS_TRAP (kPmSysGadgetLibTrapStatusGadgetsUpdate);
00088
00089 /// Installs big buttons on the given form based on a 'bBut'
00090 /// resource with the same ID.  A 'bBut' resource is basically
00091 /// just an array of HsBigButtonMappingType.
00092 ///
00093 /// Once installed, the gadget will get events from PalmOS and
00094 /// will sent a 'gadgetMisc' event with the selector
00095 /// bbutGadgetMiscSelectSelector when selected.
00096 ///
00097 /// IMPORTANT:
00098 /// The form must not be visible when you install the buttons,
00099 /// since we don't draw them (it turns out to be impossible to
00100 /// check whether the gadget is visible without peeking
00101 /// into its data structure, which we can only do from the
00102 /// event handler).
00103 ///
00104 /// @param refNum:  IN: Library reference number
00105 /// @param frmP:    IN: The form to install the big buttons on.
00106 /// @retval Err Error code.
00107 Err
00108 PmSysGadgetBbutInstallFromResource (UInt16 refNum, FormType* frmP)
00109                 SYS_TRAP (kPmSysGadgetLibTrapBbutInstallFromResource);
00110
00111 /// Set big button on a form.
00112 ///
00113 /// @param refNum:      IN: Library reference number
00114 /// @param frmP:        IN: The form to set the big button's gadget on.
00115 /// @param gadgetID:    IN: The ID of the big button's gadget.
00116 /// @param textP:       IN: Pointer to string to set on the gadget.
00117 /// @param font:        IN: Font ID to be used for the text.
00118 /// @param flags:       IN: Flags associated to the gadget.
00119 /// @retval None.
00120 void
00121 PmSysGadgetBbutInstallNewButton (UInt16 refNum, FormType* frmP, UInt16 gadgetID,
00122                                  const Char* textP, FontID font, UInt8 flags)
00123                 SYS_TRAP (kPmSysGadgetLibTrapBbutInstallNewButton);
00124
00125 /// Set label on a big button gadget.
00126 ///
00127 /// @param refNum:      IN: Library reference number
00128 /// @param frmP:        IN: The form containing the big button's gadget.
00129 /// @param gadgetID:    IN: The ID of the big button's gadget.
00130 /// @param newLabel:    IN: Pointer to label string to set on the gadget.
00131 /// @retval None.
00132 void
00133 PmSysGadgetBbutSetLabel (UInt16 refNum, FormType* frmP, UInt16 gadgetID, const Char* newLabel)
00134                 SYS_TRAP (kPmSysGadgetLibTrapBbutSetLabel);
00135
00136 /// Set bitmap image on a big button gadget.
00137 ///
00138 /// @param refNum:      IN: Library reference number
00139 /// @param frmP:        IN: The form containing the big button's gadget.
00140 /// @param gadgetID:    IN: The ID of the big button's gadget.
00141 /// @param bitmapP:     IN: Pointer to the bitmap to set on the gadget.
00142 /// @retval None.
00143 void
00144 PmSysGadgetBbutSetBitmap (UInt16 refNum, FormType* frmP, UInt16 gadgetID, const BitmapPtr bitmapP)
00145                 SYS_TRAP (kPmSysGadgetLibTrapBbutSetBitmap);
00146
00147 /// Like CtlHitControl, but for big buttons.
00148 ///
00149 /// Notes:
00150 /// Due to the fact that PalmOS lacks accessors for
00151 /// gadgets directly, this function (and any others that
00152 /// refer to a big button's gadget) takes a form pointer
00153 /// and an index instead of a FormGadgetType*.
00154 ///
00155 /// @param frmP:        IN: The form containing the big button's gadget.
00156 /// @param gadgetIndex: IN: The index of the big button's gadget.
00157 /// @retval None.
00158 void
00159 PmSysGadgetBbutHitBigButton (UInt16 refNum, FormType* frmP, UInt16 gadgetIndex)
00160                 SYS_TRAP (kPmSysGadgetLibTrapBbutHitBigButton);
00161
00162 #ifdef __cplusplus
00163 }
00164 #endif
00165
00166 #endif  // __PM_STATUS_LIB_H__
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:55 2008 for Palm API Guide


Header Files » Incs » common » libraries » pmsysgadgetlib

PmSysGadgetLibBbutRscCommon.h

Go to the documentation of this file.
00001 //**************************************************************
00002 // Copyright (c) 2004 palmOne, Inc. or its subsidiaries.
00003 // All rights reserved.
00004 //**************************************************************
00005
00006 // <chg 2005-03-09 doc> Took out Doxygen comments and any /* comments
00007 //  because this header is included by resource files and Palm-RC
00008 //  chokes on them.
00009
00010 //**************************************************************
00011 //
00012 // ToDo:
00013 //
00014 // History:
00015 //    2001-12-18  dia   Creaded by Doug Anderson
00016 //    2002-01-03  dia   We now have a reserved range to keep
00017 //                      real bitmaps and strings in the resource
00018 //                      chain, so we don't need the flags to tell
00019 //                      us whether the user wanted ours; moved
00020 //                      resource IDs to HsResourceIDs.h.
00021 //
00022 //***************************************************************/
00023
00024
00025 #ifndef __PM_SYS_GADGET_BBUT_RSC__H__
00026 #define __PM_SYS_GADGET_BBUT_RSC__H__ 1
00027
00028 // Use this version
00029 // ----------------
00030 #define kPmSysGadgetBbutMappingVersion0             0
00031
00032
00033 // Use these flags
00034 // ---------------
00035 #define kPmSysGadgetBbutFlagNone                    0x00  // None
00036 #define kPmSysGadgetBbutFlagNoBorder                0x01  // Don't draw the border...
00037 #define kPmSysGadgetBbutFlagNoBackground            0x02  // Don't draw the background of the button
00038 #define kPmSysGadgetBbutFlagNoBorderOrBackground    0x03  // Combination for Palm-rc...
00039
00040
00041 // Use these fonts
00042 // ---------------
00043 #define kPmSysGadgetBbutFontStd                 0
00044 #define kPmSysGadgetBbutFontBold                1
00045 #define kPmSysGadgetBbutFontLarge               2
00046 #define kPmSysGadgetBbutFontSymbol              3
00047 #define kPmSysGadgetBbutFontSymbol11            4
00048 #define kPmSysGadgetBbutFontSymbol7             5
00049 #define kPmSysGadgetBbutFontLed                 6
00050 #define kPmSysGadgetBbutFontLargeBold           7
00051
00052 #endif // ifndef __PM_SYS_GADGET_BBUT_RSC__H__
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:55 2008 for Palm API Guide


Header Files » Incs » common » libraries » pmsysgadgetlib

PmSysGadgetLibCommon.h

Go to the documentation of this file.
00001 /*******************************************************************************
00002  * Copyright (c) 2004-2006 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  ******************************************************************************/
00005 /**
00006  * @defgroup    PmSysGadgetLib Gadget Library
00007  * @brief       This library provides supports for application that wants to
00008  *              manage system gadgets or support big buttons in the applications.
00009  *
00010  * Application that wishes to update/ retrieve the status of system gadget such
00011  * as the battery indicator, signal strength or bluetooth indicator can use this
00012  * library to do so. This library also provides APIs for application that wants
00013  * to include big button resource.
00014  *
00015  * @{
00016  * @}
00017  */
00018 /**
00019  * @ingroup PmSysGadgetLib
00020  */
00021
00022 /**
00023  * @file  PmSysGadgetLibCommon.h
00024  * @brief Public 68k header file for system Library that exports system gadget related APIs.
00025  *
00026  * This file contains the common definitions and structures for the gadget-related APIs.
00027  * <hr>
00028  */
00029
00030 #ifndef __PM_SYS_GADGET_LIB_COMMON_H__
00031 #define __PM_SYS_GADGET_LIB_COMMON_H__
00032
00033 /********************************************************************
00034  * Constants
00035  ********************************************************************/
00036
00037 #define kPmSysGadgetLibType     sysFileTLibrary       /**< Library type */
00038 #define kPmSysGadgetLibCreator  pmFileCSysGadgetLib   /**< Library creator ID */
00039 #define kPmSysGadgetLibName     "PmSysGadgetLib-PmSg" /**< Library name */
00040
00041 /**
00042  * This selector gets sent with a frmGadgetMiscEvent to let you know that the
00043  * gadget has been selected.  The numbers are picked semi-randomly so that generic
00044  * code (like PmUIUtilFrmDoDialogWithCallback()) can tell that this is actually
00045  * a button press without doing the wrong thing for other people's gadget events.
00046  *
00047  * Note that in most code, you shouldn't need to worry about checking the data,
00048  * since you know exactly what gadgets are on your form and what kind of events
00049  * they send.
00050  **/
00051 #define kPmSysGadgetBbutGadgetMiscSelectSelector  7014                  /**< Randomish number so people can
00052                                                                              easily detect big button presses */
00053 #define kPmSysGadgetBbutGadgetMiscSelectData      ((void*)0xBADC0DE1)   /**< Magic # to make conflicts even less
00054                                                                              likely for  detecting big  button presses.*/
00055
00056
00057 /**
00058  * This is the type of big button resources.  The ID should match the ID of
00059  * the form...
00060  **/
00061 #define kPmSysGadgetBbutRscType                   'bBut'           /**< Registered: yes */
00062
00063 /**
00064  * Feature that says that status gadget API exists and what revision it is
00065  **/
00066 /*@{*/
00067 #define kPmSysGadgetFtrIDStatusGadgetRev          1
00068 #define kPmSysGadgetFtrValStatusGadgetRev1        0x0001  // Revision 1 of API
00069 /*@}*/
00070
00071 /**
00072  *  Constants added for PTT Notification
00073  */
00074 #define kPttNotificationEvent                     'pPTT'
00075 #define kPttNotificationStatusOffset              (0xF00)
00076
00077 /********************************************************************
00078  * Enums
00079  ********************************************************************/
00080 /**
00081  * Equates for supporting system handled status gadgets
00082  **/
00083 typedef enum
00084   {
00085     pmSysGadgetStatusGadgetNone = 0,       /**< No type specified for status gadget */
00086     pmSysGadgetStatusGadgetBattery = 1,    /**< Status gadget is a battery meter */
00087     pmSysGadgetStatusGadgetSignal = 2,     /**< Status gadget is a signal strength indicator */
00088     pmSysGadgetStatusGadgetBt = 3,         /**< Status gadget is a Bluetooth status indicator */
00089     pmSysGadgetStatusGadgetEvdo = 4,       /**< Status gadget is an EVDO status indicator */
00090     pmSysGadgetStatusGadgetLine = 5,       /**< Status gadget is an Active line status indicator */
00091     pmSysGadgetStatusGadgetRoaming = 6,    /**< Status gadget is a Roaming status indicator */
00092     pmSysGadgetStatusGadgetCallFwd = 7,    /**< Status gadget is a Call Forwarding status indicator */
00093     pmSysGadgetStatusGadgetVm = 8,         /**< Status gadget is a Voicemail status indicator */
00094     pmSysGadgetStatusGadgetOperator = 9,   /**< Status gadget is an Operator status indicator */
00095     pmSysGadgetStatusGadgetPhoneCall = 10, /**< Status gadget is an Operator status indicator */
00096     pmSysGadgetStatusGadgetTty = 11,       /**< Status gadget is a TTY status indicator */
00097     pmSysGadgetStatusGadgetPtt = 12        /**< Status gadget is a PTT status indicator, RJS added 22May06 */
00098   } PmSysGadgetStatusGadgetTypeEnum;
00099
00100 /** Bluetooth radio status */
00101 typedef enum
00102   {
00103     kIndicatorBtOff       = 0x0700, /**< Bt Radio turned off */
00104     kIndicatorBtOn,                 /**< Bt radio turned on */
00105     kIndicatorBtConnectHeadset,     /**< Connected to Headset */
00106     kIndicatorBtConnectOther,       /**< Connected to other Bt devices */
00107     kIndicatorBtDUN,                /**< Connected to DUN */
00108     kIndicatorBtConnectAudio,       /**< Connected audio **/
00109     kIndicatorBtConnectStereo       /**< Connected stereo **/
00110   } PmSysGadgetBtStatusTypeEnum;
00111
00112
00113 /********************************************************************
00114  * Structures
00115  ********************************************************************/
00116
00117 /**
00118  * @brief This is the structure of a single big button mapping...
00119  **/
00120 typedef struct
00121   {
00122     UInt8 flags;
00123     UInt8 font;
00124
00125     UInt16 gadgetID;
00126
00127     UInt16 bitmapID;
00128     UInt16 stringID;
00129   }
00130 PmSysGadgetBbutMappingType;
00131
00132 /**
00133  * @brief This is the structure of a big button resource...
00134  **/
00135 typedef struct
00136   {
00137     UInt16 version;
00138     PmSysGadgetBbutMappingType mapArr[0];
00139   }
00140 PmSysGadgetBbutResourceType;
00141
00142 /**
00143 *   @brief This is the structure used by the PTT notification event
00144 **/
00145 typedef struct
00146 {
00147     UInt32 creatorId;     // creator ID where bitmap can be found
00148     UInt16 uBitmapId;     // bitmap to show in PTT gadget
00149     UInt16 uStatus;       // add the kPttNotificationStatusOffset to the PTT status
00150 }
00151 PmSysGadgetPttNotificationType;
00152
00153
00154 /********************************************************************
00155  * Traps
00156  ********************************************************************/
00157 /**
00158  * @name Function Traps
00159  */
00160 /*@{*/
00161 #define kPmSysGadgetLibTrapOpen                     sysLibTrapOpen
00162 #define kPmSysGadgetLibTrapClose                    sysLibTrapClose
00163 #define kPmSysGadgetLibTrapStatusGadgetTypeSet      (sysLibTrapCustom)
00164 #define kPmSysGadgetLibTrapStatusGadgetsUpdate      (sysLibTrapCustom+1)
00165 #define kPmSysGadgetLibTrapBbutInstallFromResource  (sysLibTrapCustom+2)
00166 #define kPmSysGadgetLibTrapBbutInstallNewButton     (sysLibTrapCustom+3)
00167 #define kPmSysGadgetLibTrapBbutSetLabel             (sysLibTrapCustom+4)
00168 #define kPmSysGadgetLibTrapBbutSetBitmap            (sysLibTrapCustom+5)
00169 #define kPmSysGadgetLibTrapBbutHitBigButton         (sysLibTrapCustom+6)
00170 /*@}*/
00171
00172 #endif // __PM_SYS_GADGET_LIB_COMMON_H__
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:55 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » pmuiutillib

PmUIUtilLib.h

Go to the documentation of this file.
00001 /******************************************************************************
00002  * Copyright (c) 2004 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  *****************************************************************************/
00005 /**
00006  * @ingroup PmUIUtilLib
00007  */
00008
00009 /**
00010  * @file  PmUIUtilLib.h
00011  * @brief This is the public header for PmUIUtil library.
00012  *
00013  * This library contains general utility functions that supplement
00014  * OS functionality.  That is, it contains functions that
00015  * are general enough to be useful to many applications but
00016  * weren't included in the OS utility functions for whatever
00017  * reason.
00018  *
00019  */
00020
00021 #ifndef __PM_UI_UTIL_LIB_H__
00022 #define __PM_UI_UTIL_LIB_H__
00023
00024 #ifdef __cplusplus
00025 extern "C" {
00026 #endif
00027
00028 #include <HsNavCommon.h>
00029 #include <PmUIUtilLibCommon.h>
00030
00031 #if 0
00032 #pragma mark --------   Basic Lib API  ----------------
00033 #endif
00034
00035 /**
00036  * @brief Standard library open routine
00037  *
00038  * @param   refNum: IN: Library reference number
00039  * @retval  Err     Error code
00040  */
00041 Err
00042 PmUIUtilLibOpen (UInt16 refNum)
00043             SYS_TRAP (kPmUIUtilLibTrapOpen);
00044
00045 /**
00046  * @brief Standard library close routine
00047  *
00048  * @param   refNum: IN: Library reference number
00049  * @retval  Err     Error code
00050  */
00051 Err
00052 PmUIUtilLibClose (UInt16 refNum)
00053             SYS_TRAP (kPmUIUtilLibTrapClose);
00054
00055
00056
00057 #if 0
00058 #pragma mark -------- List API --------
00059 #endif
00060
00061 void
00062 PmUIUtilLstSetTempSelection (UInt16 refNum, const FormType* formP, UInt16 listID, Int16 itemNum)
00063             SYS_TRAP (kPmUIUtilLibTrapLstSetTempSelection);
00064
00065 Int16
00066 PmUIUtilLstGetTempSelection (UInt16 refNum, const FormType* formP, UInt16 listID)
00067             SYS_TRAP (kPmUIUtilLibTrapLstGetTempSelection);
00068
00069
00070 #if 0
00071 #pragma mark -------- Attr API --------
00072 #endif
00073
00074 Err
00075 PmUIUtilAttrGet (UInt16 refNum, UInt16 /*PmUIUtilAttrEnum*/ attr, UInt32 flags, UInt32* valueP)
00076             SYS_TRAP (kPmUIUtilLibTrapAttrGet);
00077
00078 Err
00079 PmUIUtilAttrSet (UInt16 refNum, UInt16 /*PmUIUtilAttrEnum*/ attr, UInt32 flags, UInt32 value)
00080             SYS_TRAP (kPmUIUtilLibTrapAttrSet);
00081
00082
00083 #if 0
00084 #pragma mark -------- PalmOne-Specific Nav API --------
00085 #endif
00086
00087 void
00088 PmUIUtilNavGetFocusColor (UInt16 refNum, HsNavFocusColorEnum color, RGBColorType* rgbColorP)
00089             SYS_TRAP (kPmUIUtilLibTrapNavGetFocusColor);
00090
00091 void
00092 PmUIUtilNavSetFocusColor (UInt16 refNum, HsNavFocusColorEnum color, RGBColorType* rgbColorP,
00093                           RGBColorType* oldRgbColorP)
00094             SYS_TRAP (kPmUIUtilLibTrapNavSetFocusColor);
00095
00096 #ifdef __cplusplus
00097 }
00098 #endif
00099
00100 #endif // __PM_UI_UTIL_LIB_H__
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:55 2008 for Palm API Guide


Header Files » Incs » common » libraries » pmuiutillib

PmUIUtilLibCommon.h

Go to the documentation of this file.
00001 /*******************************************************************************
00002  * Copyright (c) 2004-2005 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  ******************************************************************************/
00005 /**
00006  * @defgroup    PmUIUtilLib UI Utility Library
00007  * @brief       This library provides support for the misc. UI-related functionalities.
00008  *
00009  * Applications can use this library API to retrieve the different layers of colors of
00010  * the focus ring and use the colors to manually draw custom-shaped focus rings. Please
00011  * also refer to the HsNav.h header file for more of the library constants and definitions.
00012  *
00013  * @{
00014  * @}
00015  */
00016 /**
00017  * @ingroup PmUIUtilLib
00018  */
00019
00020 /**
00021  * @file  PmUIUtilLibCommon.h
00022  * @brief Public 68k common header file for system Library that exports UI utility API functions.
00023  *
00024  * This file contains the constants and definitions for the system UI-Util library.
00025  * <hr>
00026  */
00027
00028 #ifndef __PM_UI_UTIL_LIB_COMMON_H__
00029 #define __PM_UI_UTIL_LIB_COMMON_H__
00030
00031 #include <palmOneSystemCommon.h>    // for sysMakeLibAPIVersion
00032
00033
00034 /********************************************************************
00035  * Constants and Enums
00036  ********************************************************************/
00037
00038 #define kPmUIUtilLibType            sysFileTLibrary     /**< Library type */
00039 #define kPmUIUtilLibCreator         pmFileCUIUtilLib    /**< Library creator ID */
00040 #define kPmUIUtilLibName            "PmUIUtilLib-PmUU"  /**< Library name */
00041 #define kPmUIUtilLibAPIMajorVersion 2   /**< Major version incremented when API
00042                                              changes */
00043 #define kPmUIUtilLibAPIMinorVersion 0   /**< Minor version incremented with
00044                                              each release of library that
00045                                              doesn't change the API */
00046 #define kPmUIUtilLibAPIVersion      sysMakeLibAPIVersion(kPmUIUtilLibAPIMajorVersion, kPmUIUtilLibAPIMinorVersion)
00047
00048
00049 /**
00050  * @name Feature values
00051  */
00052 /*@{*/
00053 #define kPmUIUtilLibFtrValAPIVersion  0 /**< Feature value used to get/set
00054                                              library version
00055                                              (kPmUIUtilLibAPIVersion).  Note
00056                                              that the first release of the
00057                                              library did not set this feature.
00058                                              Therefore, if the library does
00059                                              exist but the feature does not,
00060                                              you can assume the major version
00061                                              of the library is 1.  Note also
00062                                              that the feature is not set
00063                                              until library is loaded so you
00064                                              must load PmUIUtil before getting
00065                                              the feature */
00066 /*@}*/
00067
00068 enum PmUIUtilAttrEnumTag
00069 {
00070   pmUIUtilAttrAutoSnoozeAttns       /**< whether we want to auto snooze the current instance of the attn dialog */
00071
00072   /*
00073    * End of enums in API version 1
00074    */
00075
00076   /*
00077    * Attributes greater than 0x9000 are defined for internal use
00078    * in Prv/PmPrvKeyLibCommon.h
00079    */
00080 };
00081
00082 /** @see PmUIUtilAttrEnumTag */
00083 typedef UInt16 PmUIUtilAttrEnum;
00084
00085
00086 /********************************************************************
00087  * Traps
00088  ********************************************************************/
00089
00090 /**
00091  * @name Function Traps
00092  */
00093 /*@{*/
00094 #define kPmUIUtilLibTrapOpen                      sysLibTrapOpen
00095 #define kPmUIUtilLibTrapClose                     sysLibTrapClose
00096 #define kPmUIUtilLibTrapGetObjectUsable           (sysLibTrapCustom)
00097 #define kPmUIUtilLibTrapPutObjectAfterTitle       (sysLibTrapCustom+1)
00098 #define kPmUIUtilLibTrapFrmDoDialogWithCallback   (sysLibTrapCustom+2)
00099 #define kPmUIUtilLibTrapFrmDoDialog               (sysLibTrapCustom+3)
00100 #define kPmUIUtilLibTrapFrmDoTimedDialogEx        (sysLibTrapCustom+4)
00101 #define kPmUIUtilLibTrapFrmSetHelpID              (sysLibTrapCustom+5)
00102 #define kPmUIUtilLibTrapFrmSetLabel               (sysLibTrapCustom+6)
00103 #define kPmUIUtilLibTrapFrmSetLabelFont           (sysLibTrapCustom+7)
00104 #define kPmUIUtilLibTrapFrmGetDefaultButtonID     (sysLibTrapCustom+8)
00105 #define kPmUIUtilLibTrapFrmGetEventHandler        (sysLibTrapCustom+9)
00106 #define kPmUIUtilLibTrapCtlGetStyle               (sysLibTrapCustom+10)
00107 #define kPmUIUtilLibTrapCtlGetFont                (sysLibTrapCustom+11)
00108 #define kPmUIUtilLibTrapLstGetItemsText           (sysLibTrapCustom+12)
00109 #define kPmUIUtilLibTrapLstGetTopItem             (sysLibTrapCustom+13)
00110 #define kPmUIUtilLibTrapLstPopupListExt           (sysLibTrapCustom+14)
00111 #define kPmUIUtilLibTrapSclUpdateScrollBar        (sysLibTrapCustom+15)
00112 #define kPmUIUtilLibTrapSclScroll                 (sysLibTrapCustom+16)
00113 #define kPmUIUtilLibTrapSclScrollPage             (sysLibTrapCustom+17)
00114 #define kPmUIUtilLibTrapSliHandleKeyDown          (sysLibTrapCustom+18)
00115 #define kPmUIUtilLibTrapWinGetMaxDepth            (sysLibTrapCustom+19)
00116 #define kPmUIUtilLibTrapAttnNagInfo               (sysLibTrapCustom+20)
00117 #define kPmUIUtilLibTrapAttnEnable                (sysLibTrapCustom+21)
00118 #define kPmUIUtilLibTrapAttnIndicatorAllow        (sysLibTrapCustom+22)
00119 #define kPmUIUtilLibTrapAttnGetAttentionExt       (sysLibTrapCustom+23)
00120 #define kPmUIUtilLibTrapAttnUpdateExt             (sysLibTrapCustom+24)
00121 #define kPmUIUtilLibTrapAttrGet                   (sysLibTrapCustom+25)
00122 #define kPmUIUtilLibTrapAttrSet                   (sysLibTrapCustom+26)
00123 #define kPmUIUtilLibTrapLstSetTempSelection       (sysLibTrapCustom+27)
00124 #define kPmUIUtilLibTrapLstGetTempSelection       (sysLibTrapCustom+28)
00125 #define kPmUIUtilLibTrapNavGetFocusColor          (sysLibTrapCustom+29)
00126 #define kPmUIUtilLibTrapNavSetFocusColor          (sysLibTrapCustom+30)
00127 #define kPmUIUtilLibTrapAttnDiagIsVisible         (sysLibTrapCustom+31)
00128 /*
00129  * End of traps in API version 1
00130  */
00131
00132 /*@}*/
00133
00134 #endif // __PM_UI_UTIL_LIB_COMMON_H__
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:55 2008 for Palm API Guide


Sample Codes

The table below provides a list of sample codes that are available in our SDK. The sample codes can be downloaded from the Palm PDN website under the Palm OS SDK v5.6 quick link.

Library/Feature Name | Sample Code Name
HTTP Library | HTTPLibTest
HTML Library | HtmlLibTest68k
NetPref Library | NetSelector
Camera | CameraV2, CameraV3, PalmPhotoCapturePreview
Codec Plugin Manager | MiniGIF, MiniMP3, MiniADPCM, MiniImage, MiniMPEG4
Default Helper | MMSCounter, MMSReceiver, HelperSender, HelperReceiver
File Browser | FileBrowserSample
Sound | ExtendedSound, MiniBuzzer
Imaging | FotoFinish, FotoFinish2
Multi Connector, hardware detection | Treo650PowerOut, TungstenT5SwitchAudio, PmConnectorTest
Key Library | Keyguard
Favorites DB | CustomFav
Smart Text Engine | STETest
Telephony | GSMStatus, CDMAStatus, PhoneEventReceiver, RadioSample, SimpleSMS, TickStock, PhoneInfo, LaunchCommands
Ring Tone | RingTone
Versamail | AddEmailtoVersaMail, VersaMailAccConfig, VersaMailAttchmntPlugin, VersaMailFontApp
5-Way Navigation | FiveWayV2, NavExample
Full Screen Writing | FullScreenWriting
REM Sleep | REMTimer
Bluetooth | BtClientServer, BTManager
IR | IRCommunication
System | MemoryInfo, NVFSTest, StatusBar, SerialCommunication
Tungsten T5 | TungstenT5FlowControl, TungstenT5SwitchAudio, TungstenT5SwitchAudioAlt
Netlib | Pushdemo
Synchronization | Conduit
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on $datetime for $projectname


Header Files » Incs » 68k » system

Slider.h

Go to the documentation of this file.
00001 /******************************************************************************
00002  * Copyright (c) 2004 PalmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  *****************************************************************************/
00005
00006 /**
00007  * @file    Slider.h
00008  * @version 1.0
00009  * @date    04/03/2002
00010  *
00011  * Header file for all Palm Devices
00012  * Contains constants & structs necessary to access slider saved pref.
00013  *
00014  * @author    George Puckett
00015  * <hr>
00016  */
00017
00018 #ifndef __SLIDER_H__
00019 #define __SLIDER_H__
00020
00021
00022 #include <PalmTypes.h>
00023
00024
00025 /**
00026  * Creator type for Power Panel
00027  */
00028
00029 #define sysFileCPower                       'Powr'
00030
00031 /**
00032  * notification sent to inform HAL that the preferences need to be updated
00033  */
00034
00035 #define SLIDER_PREF_CHANGED_NOTIFY_TYPE     'spcn'
00036
00037 /** App preferences */
00038
00039 #define appPrefsVersion         0
00040 #define appPrefsID              1
00041
00042
00043 /***********************************************************************
00044  *  Types
00045  ***********************************************************************/
00046
00047 /** App Preferences */
00048 typedef struct
00049 {
00050     /** non-zero if the device should auto-on when opened */
00051     UInt8       autoOnWhenOpened;
00052     /** non-zero if the device should auto-off when closed */
00053     UInt8       autoOffWhenClosed;
00054 } PowerPanelAppPrefs;
00055
00056 #endif /* __SLIDER_H__ */
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:55 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » smarttextengine

SmartTextEngine.h

Go to the documentation of this file.
00001 /******************************************************************************
00002  * Copyright (c) 2004 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  *****************************************************************************/
00005 /**
00006  * @defgroup STE Smart Text Engine Library
00007  *
00008  * @{
00009  * @}
00010  */
00011
00012 /**
00013  *
00014  * @file  SmartTextEngine.h
00015  * @brief Public 68K include file for Smart Text Engine shared library.
00016  *
00017  * The Smart Text Engine (STE) Library can be used to enable hyperlink
00018  * in your application and display icon as defined in the Resource Header file.
00019  *
00020  * It will enable user to tap on:
00021  *  - Phone number to dial using the phone application
00022  *  - URL to browse
00023  *  - Email to send an email by launching the default email application
00024  *
00025  * The calling application should always load this library with
00026  * SysLibLoad() before use, even if it is already open by another
00027  * application(ie, SysLibFind() returns a valid refnum). When
00028  * the application is done with the library, it should be
00029  * unloaded with SysLibRemove(). We do this because there is
00030  * no good way to synchronize loading and unloading of libraries
00031  * among multiple applications. It also greatly simplifies internal
00032  * synchronization.
00033  *
00034  * @code
00035  *  Err LoadSmartTextEngine(UInt16* refNumP, Boolean* libLoadedP)
00036  *      {
00037  *      Err error = 0;
00038  *
00039  *      // Routine is pointless without this parameter
00040  *      if (!refNumP)
00041  *          return memErrInvalidParam;
00042  *
00043  *      // always load the library, so we have our own instance of the engine
00044  *          error = SysLibLoad(sysFileTLibrary, hsFileCSmartTextEngine, refNumP);
00045  *      if (error)
00046  *          return error;
00047  *      *libLoadedP = true;
00048  *
00049  *      return error;
00050  *      }
00051  * @endcode
00052  */
00053
00054 #ifndef __SMARTTEXTENGINE68K_H__
00055 #define __SMARTTEXTENGINE68K_H__
00056
00057 #include <PalmTypes.h>
00058 #include <LibTraps.h>
00059
00060 #include "SmartTextEngineTraps.h"
00061 #include "SmartTextEngineDef.h"
00062 #include "SmartTextEngineErrors.h"
00063
00064
00065 #ifdef __cplusplus
00066 extern "C" {
00067 #endif
00068
00069
00070 /// Standard library open routine.
00071 /// Library should always be loaded with SysLibLoad()(not SysLibFind())
00072 /// before calling STEOpen(). See note at top of file.
00073 ///
00074 /// @param refNum:        IN:  Library reference number
00075 /// @retval STEErr Error Code or zero if no error occurs
00076 extern STEErr STEOpen(UInt16 refNum)
00077     SYS_TRAP(sysLibTrapOpen);
00078
00079 /// Standard library close routine.
00080 /// Library should always be unloaded with SysLibRemove() after
00081 /// STEClose() is called. See note at top of file.
00082 ///
00083 /// @param refNum:        IN:  Library reference number
00084 /// @retval STEErr Error Code or zero if no error occurs
00085 extern STEErr STEClose(UInt16 refNum)
00086     SYS_TRAP(sysLibTrapClose);
00087
00088
00089 /// Get Library API Version number.
00090 ///
00091 /// @param refNum:        IN:  Library reference number
00092 /// @param majVerP:       OUT: Major version number
00093 /// @param minVerP:       OUT: Minor version number
00094 /// @retval STEErr Error Code or zero if no error occurs
00095 extern STEErr STEGetAPIVersion(UInt16 refNum, UInt32* majVerP, UInt32* minVerP)
00096     SYS_TRAP(STETrapGetAPIVersion);
00097
00098 /// Styled Text Engine initialization function
00099 /// Before most of the STE can be used, it must be initialized.  This function will return
00100 /// an engineRefNum which is to be used in the STE functions that require the STE
00101 /// to be initialized.
00102 ///
00103 /// There are some functions that do not require the STE to be initialized.  They are noted below.
00104 ///
00105 /// @param    refNum:           IN:   The STE refNum
00106 /// @param    engineRefNum:     OUT:  The STE engine refNum to be used in subsequent calls to the STE
00107 /// @param    listBounds:       IN:   The bounds of the STE list that will be displayed
00108 /// @param    scrollBarID:      IN:   The ID of the scroll used by the STE list.  If this is 0, the list will not
00109 ///                                   scroll.  If there is more text than can be displayed, an ellipsis will be
00110 ///                                   appended to the end.
00111 /// @param    flags:            IN:   The flags for the STE
00112 /// @param    phoneNumberColor: IN:   The color of the phone number hyperlinks
00113 /// @param    urlColor:         IN:   The color of the URL hyperlinks
00114 /// @param    emailColor:       IN:   The color of the email hyperlinks
00115 /// @retval STEErr Error Code or zero if no error occurs
00116 extern STEErr STEInitializeEngine(UInt16 refNum, UInt16* engineRefNum, RectangleType* listBounds, UInt16 scrollBarID, UInt32 flags,
00117                                   UInt8 phoneNumberColor, UInt8 urlColor, UInt8 emailColor)
00118     SYS_TRAP(STETrapInitializeEngine);
00119
00120 ///Frees up the STE engine refNum.  For each STEInitializeEngine, there must be a corresponding
00121 ///STEResetEngine.
00122 ///
00123 ///@param     refNum:           IN:   The STE refNum
00124 ///@param     engineRefNum:     IN:   The STE engine refNum
00125 ///@retval STEErr Error Code or zero if no error occurs
00126 extern STEErr STEResetEngine(UInt16 refNum, UInt16 engineRefNum)
00127     SYS_TRAP(STETrapResetEngine);
00128
00129 ///Initializes the STE to the initial state right after initializing it.  This frees up any text that
00130 ///has been entered into the STE.
00131 ///
00132 ///@param  refNum:          IN:   The STE refNum
00133 ///@param  engineRefNum:    IN:   The STE engine refNum
00134 ///@retval STEErr Error Code or zero if no error occurs
00135 extern STEErr STEReinitializeEngine(UInt16 refNum, UInt16 engineRefNum)
00136     SYS_TRAP(STETrapReinitializeEngine);
00137
00138 ///Function that is used to add text to the STE.  Each text string that is appended
00139 ///is called a record.  Record numbers are 1 based, meaning the first record is record 1.
00140 ///
00141 ///@param     refNum:           IN:   The STE refNum
00142 ///@param     engineRefNum:     IN:   The STE engine refNum
00143 ///@param     textP:            IN:   The text to append to the STE, including any STE delimiters
00144 ///@param     renderImmediate:  IN:   If true, the text will be displayed immediately.  If false, it
00145 ///                           will not be displayed until STERenderList is called.
00146 ///@retval    -
00147 extern void STEAppendTextToEngine(UInt16 refNum, UInt16 engineRefNum, Char* textP, Boolean renderImmediate)
00148     SYS_TRAP(STETrapAppendTextToEngine);
00149
00150 ///Removes the last text that was appended to the engine.
00151 ///You must call STERenderList to update the display after removing the text.
00152 ///
00153 ///@param     refNum:           IN:   The STE refNum
00154 ///@param     engineRefNum:     IN:   The STE engine refNum
00155 ///@retval    -
00156 extern void STERemoveLastRecordFromEngine(UInt16 refNum, UInt16 engineRefNum)
00157     SYS_TRAP(STETrapRemoveLastRecordFromEngine);
00158
00159 ///Renders the text that is currently in the STE.
00160 ///
00161 ///@param     refNum:           IN:   The STE refNum
00162 ///@param     engineRefNum:     IN:   The STE engine refNum
00163 ///@retval    -
00164 extern void STERenderList(UInt16 refNum, UInt16 engineRefNum)
00165     SYS_TRAP(STETrapRenderList);
00166
00167 ///Rerenders the text that is currently in the STE.  This routine should be used if a change is made
00168 ///that can change the formatting (i.e. font size).
00169 ///
00170 ///@param     refNum:           IN:   The STE refNum
00171 ///@param     engineRefNum:     IN:   The STE engine refNum
00172 ///@retval    -
00173 extern void STERerenderList(UInt16 refNum, UInt16 engineRefNum)
00174     SYS_TRAP(STETrapRerenderList);
00175
00176
00177 ///This routine should be called in the form's event handler.   If there is no special handling of
00178 ///events, then this routine can be used to handle all the different events that can affect the STE.
00179 ///
00180 ///@param     refNum:           IN:   The STE refNum
00181 ///@param     engineRefNum:     IN:   The STE engine refNum
00182 ///@param     eventP:           IN:   A pointer to the event record.
00183 ///@retval    Boolean True if handled, False if not handled
00184 extern Boolean STEHandleEvent(UInt16 refNum, UInt16 engineRefNum, EventPtr eventP)
00185     SYS_TRAP(STETrapHandleEvent);
00186
00187 ///This routine handles only the sclRepeat event.   This routine should be used if there is special
00188 ///handling of the events by the application before (or after) the STE handles the event.
00189 ///
00190 ///@param     refNum:           IN:   The STE refNum
00191 ///@param     engineRefNum:     IN:   The STE engine refNum
00192 ///@param     eventP:           IN:   A pointer to the event record.
00193 ///@retval    Boolean True if handled, False if not handled
00194 extern Boolean STEHandleSclRepeatEvent(UInt16 refNum, UInt16 engineRefNum, EventPtr eventP)
00195     SYS_TRAP(STETrapHandleSclRepeatEvent);
00196
00197 ///This routine handles only the penDown event.  This routine should be used if there is special
00198 ///handling of the events by the application before (or after) the STE handles the event.
00199 ///
00200 ///@param     refNum:           IN:   The STE refNum
00201 ///@param     engineRefNum:     IN:   The STE engine refNum
00202 ///@param     eventP:           IN:   A pointer to the event record.
00203 ///@retval    Boolean True if handled, False if not handled
00204 extern Boolean STEHandlePenDownEvent(UInt16 refNum, UInt16 engineRefNum, EventPtr eventP)
00205     SYS_TRAP(STETrapHandlePenDownEvent);
00206
00207 ///This routine handles only the penMove event.  This routine should be used if there is special
00208 ///handling of the events by the application before (or after) the STE handles the event.
00209 ///
00210 ///@param     refNum:           IN:   The STE refNum
00211 ///@param     engineRefNum:     IN:   The STE engine refNum
00212 ///@param     eventP:           IN:   A pointer to the event record.
00213 ///@retval    Boolean True if handled, False if not handled
00214 extern Boolean STEHandlePenMoveEvent(UInt16 refNum, UInt16 engineRefNum, EventPtr eventP)
00215     SYS_TRAP(STETrapHandlePenMoveEvent);
00216
00217 ///This routine handles only the penUp event.   This routine should be used if there is special
00218 ///handling of the events by the application before (or after) the STE handles the event.
00219 ///
00220 ///@param     refNum:           IN:   The STE refNum
00221 ///@param     engineRefNum:     IN:   The STE engine refNum
00222 ///@param     eventP:           IN:   A pointer to the event record.
00223 ///@retval    Boolean True if handled, False if not handled
00224 extern Boolean STEHandlePenUpEvent(UInt16 refNum, UInt16 engineRefNum, EventPtr eventP)
00225     SYS_TRAP(STETrapHandlePenUpEvent);
00226
00227 ///This routine handles only the keyDown event.  This routine should be used if there is special
00228 ///handling of the events by the application before (or after) the STE handles the event.
00229 ///
00230 ///@param     refNum:           IN:   The STE refNum
00231 ///@param     engineRefNum:     IN:   The STE engine refNum
00232 ///@param     eventP:           IN:   A pointer to the event record.
00233 ///@retval    Boolean True if handled, False if not handled
00234 extern Boolean STEHandleKeyDownEvent(UInt16 refNum, UInt16 engineRefNum, EventPtr eventP)
00235     SYS_TRAP(STETrapHandleKeyDownEvent);
00236
00237 ///This routine returns the current scroll position of the STE's scroll bar.
00238 ///
00239 ///@param     refNum:           IN:   The STE refNum
00240 ///@param     engineRefNum:     IN:   The STE engine refNum
00241 ///@retval    UInt16 The position of the scroll bar.
00242 extern UInt16 STEGetScroll(UInt16 refNum, UInt16 engineRefNum)
00243     SYS_TRAP(STETrapGetScroll);
00244
00245 ///This routine sets the current scroll position of the STE's scroll bar.
00246 ///
00247 ///@param     refNum:           IN:   The STE refNum
00248 ///@param     engineRefNum:     IN:   The STE engine refNum
00249 ///@param     scrollValue:      IN:   The position to set the scroll bar
00250 ///@retval    -
00251 extern void STESetScroll(UInt16 refNum, UInt16 engineRefNum, UInt16 scrollValue)
00252     SYS_TRAP(STETrapSetScroll);
00253
00254 ///This routine returns the current scroll position of the STE's scroll bar as a percentage
00255 ///of the entire scroll bar.
00256 ///
00257 ///@param     refNum:           IN:   The STE refNum
00258 ///@param     engineRefNum:     IN:   The STE engine refNum
00259 ///@retval    UInt16 The position of the scroll bar in percentage.
00260 extern UInt16 STEGetScrollPct(UInt16 refNum, UInt16 engineRefNum)
00261     SYS_TRAP(STETrapGetScrollPct);
00262
00263 ///This routine sets the current scroll position percentage of the STE's scroll bar.
00264 ///
00265 ///@param     refNum:           IN:   The STE refNum
00266 ///@param     engineRefNum:     IN:   The STE engine refNum
00267 ///@param     scrollPct:        IN:   The position to set the scroll bar in percentage
00268 ///@retval    -
00269 extern void STESetScrollPct(UInt16 refNum, UInt16 engineRefNum, UInt16 scrollPct)
00270     SYS_TRAP(STETrapSetScrollPct);
00271
00272 ///This routine sets the current scroll bar position so that the specified record
00273 ///appears at the top of the list.
00274 ///
00275 ///@param     refNum:           IN:   The STE refNum
00276 ///@param     engineRefNum:     IN:   The STE engine refNum
00277 ///@param     recordNum:        IN:   The record number to display at the top of the list.
00278 ///@retval    -
00279 extern void STESetScrollToRecordNum(UInt16 refNum, UInt16 engineRefNum, UInt16 recordNum)
00280     SYS_TRAP(STETrapSetScrollToRecordNum);
00281
00282 ///This routine sets the STE flags
00283 ///
00284 ///@param     refNum:           IN:   The STE refNum
00285 ///@param     engineRefNum:     IN:   The STE engine refNum
00286 ///@param     flagsToSet:       IN:   Bitmap representing the flags to set
00287 ///@param     flagsToClear:     IN:   Bitmap representing the flags to clear
00288 ///@retval    -
00289 extern void STESetFlags(UInt16 refNum, UInt16 engineRefNum, UInt32 flagsToSet, UInt32 flagsToClear)
00290     SYS_TRAP(STETrapSetFlags);
00291
00292 ///This routine returns the current STE flags
00293 ///
00294 ///@param     refNum:           IN:   The STE refNum
00295 ///@param     engineRefNum:     IN:   The STE engine refNum
00296 ///@retval    UInt32 The STE flags
00297 extern UInt32 STEGetFlags(UInt16 refNum, UInt16 engineRefNum)
00298     SYS_TRAP(STETrapGetFlags);
00299
00300 ///This routine returns the number of lines in the STE.
00301 ///
00302 ///@param     refNum:           IN:   The STE refNum
00303 ///@param     engineRefNum:     IN:   The STE engine refNum
00304 ///@retval    UInt16 Number of lines in the STE
00305 extern UInt16 STEGetNumLines(UInt16 refNum, UInt16 engineRefNum)
00306     SYS_TRAP(STETrapGetNumLines);
00307
00308 ///This routine returns the number of records in the STE.
00309 ///
00310 ///@param     refNum:           IN:   The STE refNum
00311 ///@param     engineRefNum:     IN:   The STE engine refNum
00312 ///@retval    UInt16 Number of records in the STE
00313 extern UInt16 STEGetNumRecords(UInt16 refNum, UInt16 engineRefNum)
00314     SYS_TRAP(STETrapGetNumRecords);
00315
00316 ///This routine checks if there is a current hot rect selection.  A hot rect
00317 ///is a hyperlink that has been selected with the keyboard.
00318 ///
00319 ///@param     refNum:           IN:   The STE refNum
00320 ///@param     engineRefNum:     IN:   The STE engine refNum
00321 ///@retval    Boolean True if there is a current hot rect selected
00322 extern Boolean STEHasHotRectSelection(UInt16 refNum, UInt16 engineRefNum)
00323     SYS_TRAP(STETrapHasHotRectSelection);
00324
00325 ///This routine checks if there is a current message selected.
00326 ///
00327 ///@param     refNum:           IN:   The STE refNum
00328 ///@param     engineRefNum:     IN:   The STE engine refNum
00329 ///@retval    Boolean True if there is a current message selected
00330 extern Boolean STEHasMessageSelection(UInt16 refNum, UInt16 engineRefNum)
00331     SYS_TRAP(STETrapHasMessageSelection);
00332
00333 ///This routine checks if there is any text currently selected.
00334 ///
00335 ///@param     refNum:           IN:   The STE refNum
00336 ///@param     engineRefNum:     IN:   The STE engine refNum
00337 ///@retval    Boolean True if there is any text selected
00338 extern Boolean STEHasTextSelection(UInt16 refNum, UInt16 engineRefNum)
00339     SYS_TRAP(STETrapHasTextSelection);
00340
00341 ///This routine clears any currently selected text or hot rect.
00342 ///
00343 ///@param     refNum:           IN:   The STE refNum
00344 ///@param     engineRefNum:     IN:   The STE engine refNum
00345 ///@retval    -
00346 extern void STEClearCurrentSelection(UInt16 refNum, UInt16 engineRefNum)
00347     SYS_TRAP(STETrapClearCurrentSelection);
00348
00349 ///This routine will select the specified text selection.   The display will be updated
00350 ///to show the selected text as highlighted.
00351 ///
00352 ///@param     refNum:           IN:   The STE refNum
00353 ///@param     engineRefNum:     IN:   The STE engine refNum
00354 ///@param     messageNumber:    IN:   The record number to start the selection
00355 ///@param     startLocation:    IN:   The byte offset to start the text selection
00356 ///@param     selectionLength:  IN:   The number of bytes in the text selection
00357 ///@retval    UInt16 Returns the line number of the topmost line of the selection
00358 extern UInt16 STESetCurrentTextSelection(UInt16 refNum, UInt16 engineRefNum, UInt16 messageNumber, UInt32 startLocation, UInt32 selectionLength)
00359     SYS_TRAP(STETrapSetCurrentTextSelection);
00360
00361 ///This routine will select the specified text selection.   The display will be updated
00362 ///to show the selected text as highlighted.
00363 ///
00364 ///@param     refNum:           IN:   The STE refNum
00365 ///@param     engineRefNum:     IN:   The STE engine refNum
00366 ///@param     messageNumber:    OUT:  The record number of the start the selection
00367 ///@param     startLocation:    OUT:  The byte offset of the start the text selection
00368 ///@param     selectionLength:  OUT:  The number of bytes in the text selection
00369 ///@retval    -
00370 extern void STEGetCurrentTextSelection(UInt16 refNum, UInt16 engineRefNum, UInt16* messageNumber, UInt16* startLocation, UInt16* selectionLength)
00371     SYS_TRAP(STETrapGetCurrentTextSelection);
00372
00373 ///This routine returns a copy of the actual text that is currently selected.
00374 ///
00375 ///@param     refNum:           IN:   The STE refNum
00376 ///@param     engineRefNum:     IN:   The STE engine refNum
00377 ///@retval    Char* Returns a copy of the current text selection.  This must be freed by the caller.
00378 extern Char* STEGetSelectedText(UInt16 refNum, UInt16 engineRefNum)
00379     SYS_TRAP(STETrapGetSelectedText);
00380
00381 ///This routine copies the selected text to the system's clipboard.
00382 ///
00383 ///@param     refNum:           IN:   The STE refNum
00384 ///@param     engineRefNum:     IN:   The STE engine refNum
00385 ///@retval    -
00386 extern void STECopySelectionToClipboard(UInt16 refNum, UInt16 engineRefNum)
00387     SYS_TRAP(STETrapCopySelectionToClipboard);
00388
00389 ///This routine returns the location of the last tap.   If the user drags the stylus, it is not a tap.
00390 ///
00391 ///@param     refNum:           IN:   The STE refNum
00392 ///@param     engineRefNum:     IN:   The STE engine refNum
00393 ///@param     messageNumber:    OUT:  The record number of the text that was tapped
00394 ///@param     tapLocation:      OUT:  The number of bytes offset from the start of the text to the location tapped
00395 ///@retval    -
00396 extern void STEGetLastTapInfo(UInt16 refNum, UInt16 engineRefNum, UInt16* messageNumber, UInt16* tapLocation)
00397     SYS_TRAP(STETrapGetLastTapInfo);
00398
00399 ///This routine sets the procedure to call as a result of tapping a custom hyperlink
00400 ///
00401 ///@param     refNum:           IN:   The STE refNum
00402 ///@param     engineRefNum:     IN:   The STE engine refNum
00403 ///@param     callback:         IN:   The routine to call
00404 ///@param     armCallback:      IN:   True if the callback routine is ARM code, false if it is 68K code
00405 ///@retval    -
00406 extern void STESetCustomHyperlinkCallback(UInt16 refNum, UInt16 engineRefNum, STECallbackType callback, Boolean armCallback)
00407     SYS_TRAP(STETrapSetCustomHyperlinkCallback);
00408
00409 ///This routine will render the specified text as a "one shot deal".  The text will
00410 ///not respond to any events, and hyperlinks do not work.   This can be used to display
00411 ///rich text with graphics easily in your application.
00412 ///
00413 ///This does NOT require the STE to be initialized.
00414 ///
00415 ///@param     refNum:           IN:   The STE refNum
00416 ///@param     listBounds:       IN:   The bounds of the STE list that will be displayed
00417 ///@param     flags:            IN:   The flags for the STE
00418 ///@param     phoneNumberColor: IN:   The color of the phone number hyperlinks
00419 ///@param     urlColor:         IN:   The color of the URL hyperlinks
00420 ///@param     emailColor:       IN:   The color of the email hyperlinks
00421 ///@param     msgP:             IN:   The text to display
00422 ///@retval    -
00423 extern void STEQuickRender(UInt16 refNum, RectangleType* listBounds, UInt32 flags,
00424                            UInt8 phoneNumberColor, UInt8 urlColor, UInt8 emailColor, Char* msgP)
00425     SYS_TRAP(STETrapQuickRender);
00426
00427 ///This routine will parse the text string for URLs, email addresses, and/or phone numbers.
00428 ///
00429 ///This does NOT require the STE to be initialized.
00430 ///
00431 ///@param     refNum:           IN:   The STE refNum
00432 ///@param     textP:            IN:   The text string to parse
00433 ///@param     msgNumber:        IN:   The message number of this text string  (Used internally by the STE)
00434 ///@param     replaceLineFeeds: IN:   If true, any line feed will be replaced with a space, but a parsed item will be create
00435 ///                                   that specifies a line feed to be at that location
00436 ///@param     flags:            IN:   The flags indicating what type of item to parse out
00437 ///@retval    ParsedInfoList* A parsed info list that has each of the parsed items found in the text string.
00438 extern ParsedInfoList* STEGetParsedInformation(UInt16 refNum, Char* textP, UInt16 msgNumber, Boolean replaceLineFeeds, UInt32 flags)
00439     SYS_TRAP(STETrapGetParsedInformation);
00440
00441
00442 ///This routine append a ParsedInfoList to another ParsedInfoList.
00443 ///
00444 ///This does NOT require the STE to be initialized.
00445 ///This is used internally by the STE.  You probably will not use this function.
00446 ///
00447 ///@param     refNum:            IN:   The STE refNum
00448 ///@param     destParsedInfoH:   IN:   A handle to the destination parsed info list
00449 ///@param     sourceParsedInfoP: IN:   The source parsed info list.
00450 ///@retval    -
00451 extern void STEAppendParsedInfo(UInt16 refNum, MemHandle destParsedInfoH, ParsedInfoList* sourceParsedInfoP)
00452     SYS_TRAP(STETrapAppendParsedInfo);
00453
00454
00455
00456 #ifdef __cplusplus
00457 }
00458 #endif
00459
00460
00461
00462
00463 #endif  //__SMARTTEXTENGINE68K_H__
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:55 2008 for Palm API Guide


Header Files » Incs » common » libraries » smarttextengine

SmartTextEngineDef.h

Go to the documentation of this file.
00001 /******************************************************************************
00002  * Copyright (c) 2004 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  *****************************************************************************/
00005 /** @ingroup STE
00006  *
00007  */
00008
00009 /**
00010  * @file    SmartTextEngineDef.h
00011  *
00012  * @brief Public include file for Smart Text Engine shared library
00013  *
00014  * The calling application should always load this library with
00015  * SysLibLoad() before use, even if it is already open by another
00016  * application(ie, SysLibFind() returns a valid refnum). When
00017  * the application is done with the library, it should be
00018  * unloaded with SysLibRemove(). We do this because there is
00019  * no good way to synchronize loading and unloading of libraries
00020  * among multiple applications. It also greatly simplifies internal
00021  *
00022  */
00023
00024
00025 #ifndef _SMARTTEXTENGINEDEF_H_
00026 #define _SMARTTEXTENGINEDEF_H_
00027
00028 #include <PalmOS.h>
00029
00030 #include "SmartTextEngineErrors.h"
00031 #include "SmartTextEngineRsc.h"
00032
00033
00034 #ifdef __cplusplus
00035 extern "C" {
00036 #endif
00037
00038
00039 #define steLibName          "SmartTextEngine.lib"      /**< Internal library name which can(but shouldn't) be passed to SysLibFind() */
00040 #define steLibDBName        "Smart Text Engine"        /**< Name used for DmFindDatabase */
00041
00042
00043 /**
00044  * @name Parsed types
00045  *
00046  */
00047 /*@{*/
00048 #define kParsedPhoneNumber        1
00049 #define kParsedURL                2
00050 #define kParsedEmail              3
00051 #define kParsedDeviceURL          4
00052 #define kParsedRtspURL            5
00053 /*@}*/
00054
00055 #define kSmartTextBit            0x4000 /**<No definition */
00056
00057 /**
00058  * @name Font types
00059  *
00060  */
00061 /*@{*/
00062 #define kSTEStdFont               (kSmartTextBit | 0x00)
00063 #define kSTEBoldFont              (kSmartTextBit | 0x01)
00064 /*@}*/
00065
00066 /**
00067  * @name Font colors
00068  *
00069  */
00070 /*@{*/
00071 #define kSTECurrentFont           (kSmartTextBit | 0x10)    /**<Current font color*/
00072 #define kSTEBlackFont             (kSmartTextBit | 0x11)    /**<Black font color*/
00073 #define kSTEBlueFont              (kSmartTextBit | 0x12)    /**<Blue font color*/
00074 #define kSTERedFont               (kSmartTextBit | 0x13)    /**<Red font color*/
00075 #define kSTEGreenFont             (kSmartTextBit | 0x14)    /**<Green font color*/
00076 #define kSTEYellowFont            (kSmartTextBit | 0x15)    /**<Yellow font color*/
00077 #define kSTEPurpleFont            (kSmartTextBit | 0x16)    /**<Purple font color*/
00078 #define kSTEOrangeFont            (kSmartTextBit | 0x17)    /**<Orange font color*/
00079 #define kSTEGrayFont              (kSmartTextBit | 0x18)    /**<Gray font color*/
00080 /*@}*/
00081
00082 /**
00083  * @name Formating
00084  *
00085  */
00086 /*@{*/
00087 #define kSTELineBreak             (kSmartTextBit | 0x50)    /**<Line Break**/
00088 #define kSTELeftIndent            (kSmartTextBit | 0x51)    /**<Left Indentation*/
00089 #define kSTERightAlign            (kSmartTextBit | 0x52)    /**<Right Alignment*/
00090 #define kSTECenterAlign           (kSmartTextBit | 0x53)    /**<Center Alignment*/
00091
00092 #define kSTEHorizontalLine        (kSmartTextBit | 0x60)    /**<Horizontal Line*/
00093
00094 #define kSTEBitmap                (kSmartTextBit | 0x70)    /**<Bitmap*/
00095 #define kSTESmileyBitmap          (kSmartTextBit | 0x71)    /**<Smiley Bitmap*/
00096 #define kSTECharacterBitmap       (kSmartTextBit | 0x72)    /**<Character Bitmap*/
00097
00098 #define kSTEHyperlink             (kSmartTextBit | 0x80)    /**<Hyperlink*/
00099 /*@}*/
00100
00101 /**
00102  * @name Emoticons
00103  *
00104  */
00105 /*@{*/
00106 #define kSmileSmiley              (((UInt32)LargeSmiley00BitMap << 16) | Smiley00BitMap)    /**<Smiling Smily*/
00107 #define kWinkSmiley               (((UInt32)LargeSmiley01BitMap << 16) | Smiley01BitMap)    /**<Winking Smily*/
00108 #define kFrownSmiley              (((UInt32)LargeSmiley02BitMap << 16) | Smiley02BitMap)    /**<Frowning Smily*/
00109 #define kBigTeethSmiley           (((UInt32)LargeSmiley03BitMap << 16) | Smiley03BitMap)    /**<Big Teeth Smily*/
00110 #define kTongueSmiley             (((UInt32)LargeSmiley04BitMap << 16) | Smiley04BitMap)    /**<Tongue Smily*/
00111 #define kDevilSmiley              (((UInt32)LargeSmiley05BitMap << 16) | Smiley05BitMap)    /**<Devil Smily*/
00112 #define kOMouthSmiley             (((UInt32)LargeSmiley06BitMap << 16) | Smiley06BitMap)    /**<O-mouth Smily*/
00113 #define kBigTongueSmiley          (((UInt32)LargeSmiley07BitMap << 16) | Smiley07BitMap)    /**<Big Tongue Smily*/
00114 #define kHeartSmiley              (((UInt32)LargeSmiley08BitMap << 16) | Smiley08BitMap)    /**<Heart Smily*/
00115 #define kBigFrownSmiley           (((UInt32)LargeSmiley09BitMap << 16) | Smiley09BitMap)    /**<Big Frown Smily*/
00116 #define kQuestionSmiley           (((UInt32)LargeSmiley10BitMap << 16) | Smiley10BitMap)    /**<Question Smily*/
00117 #define kPukeSmiley               (((UInt32)LargeSmiley11BitMap << 16) | Smiley11BitMap)    /**<Puke Smily*/
00118 #define kBigSmileSmiley           (((UInt32)LargeSmiley12BitMap << 16) | Smiley12BitMap)    /**<Big Smile Smily*/
00119 #define kBlushSmiley              (((UInt32)LargeSmiley13BitMap << 16) | Smiley13BitMap)    /**<Blush Smily*/
00120 #define kSmirkSmiley              (((UInt32)LargeSmiley14BitMap << 16) | Smiley14BitMap)    /**<Smirk Smily*/
00121 #define kClownSmiley              (((UInt32)LargeSmiley15BitMap << 16) | Smiley15BitMap)    /**<Clown Smily*/
00122 #define kStraightMouthSmiley      (((UInt32)LargeSmiley16BitMap << 16) | Smiley16BitMap)    /**<Straight Mouth Smily*/
00123 #define kYinYangSmiley            (((UInt32)LargeSmiley17BitMap << 16) | Smiley17BitMap)    /**<Yin Yang Smily*/
00124 #define kAngelSmiley              (((UInt32)LargeSmiley18BitMap << 16) | Smiley18BitMap)    /**<Angel Smily*/
00125 #define kCigarSmiley              (((UInt32)LargeSmiley19BitMap << 16) | Smiley19BitMap)    /**<Cigar Smily*/
00126 #define kFlipSmiley               (((UInt32)LargeSmiley20BitMap << 16) | Smiley20BitMap)    /**<Flip Smily*/
00127 #define kUFlipSmiley              (((UInt32)LargeSmiley21BitMap << 16) | Smiley21BitMap)    /**<Up Flip Smily*/
00128 #define kLFlipSmiley              (((UInt32)LargeSmiley22BitMap << 16) | Smiley22BitMap)    /**<Left Flip Smily*/
00129 #define kRFlipSmiley              (((UInt32)LargeSmiley23BitMap << 16) | Smiley23BitMap)    /**<Right Flip Smily*/
00130
00131
00132 #define kDeltaCharacter           (((UInt32)Delta14BitMap << 16)  | Delta11BitMap)  /**<Delta Character*/
00133 #define kPhiCharacter             (((UInt32)Phi14BitMap << 16)    | Phi11BitMap)    /**<Phi Character*/
00134 #define kGammaCharacter           (((UInt32)Gamma14BitMap << 16)  | Gamma11BitMap)  /**<Gamma Character*/
00135 #define kLambdaCharacter          (((UInt32)Lambda14BitMap << 16) | Lambda11BitMap) /**<Lambda Character*/
00136 #define kOmegaCharacter           (((UInt32)Omega14BitMap << 16)  | Omega11BitMap)  /**<Omega Character*/
00137 #define kPiCharacter              (((UInt32)Pi14BitMap << 16)     | Pi11BitMap)     /**<Pi Character*/
00138 #define kPsiCharacter             (((UInt32)Psi14BitMap << 16)    | Psi11BitMap)    /**<Psi Character*/
00139 #define kSigmaCharacter           (((UInt32)Sigma14BitMap << 16)  | Sigma11BitMap)  /**<Sigma Character*/
00140 #define kThetaCharacter           (((UInt32)Theta14BitMap << 16)  | Theta11BitMap)  /**<Theta Character*/
00141 #define kXiCharacter              (((UInt32)Xi14BitMap << 16)     | Xi11BitMap)     /**<Xi Character*/
00142 /*@}*/
00143
00144 /**
00145  * @name Link colors (from the CLUT)
00146  *
00147  */
00148 /*@{*/
00149 #define kSTECurrent         254 // taking a chance no one will use this index
00150 #define kSTEBlack           255 /**<Black*/
00151 #define kSTEBlue            95  /**<Blue*/
00152 #define kSTERed             125 /**<Red*/
00153 #define kSTEGreen           210 /**<Green*/
00154 #define kSTEYellow          120 /**<Yellow*/
00155 #define kSTEPurple          23  /**<Purple*/
00156 #define kSTEOrange          116 /**<Orange*/
00157 #define kSTEGray            220 /**<Gray*/
00158 /*@}*/
00159
00160 /**
00161  * @name Inverse Color
00162  *
00163  */
00164 /*@{*/
00165 #define kSTEBlackInverse    0   /**<Black Inverse*/
00166 #define kSTEBlueInverse     114 /**<Blue Inverse*/
00167 #define kSTERedInverse      8   /**<Red Inverse*/
00168 #define kSTEGreenInverse    18  /**<Green Inverse*/
00169 #define kSTEYellowInverse   6   /**<Yellow Inverse*/
00170 #define kSTEPurpleInverse   1   /**<Purple Inverse*/
00171 #define kSTEOrangeInverse   30  /**<Orange Inverse*/
00172 #define kSTEGrayInverse     25  /**<Gray Inverse*/
00173 /*@}*/
00174
00175
00176 // Smart Text delimiters
00177
00178 /**
00179  * @name Use standard or bold font
00180  *
00181  */
00182 /*@{*/
00183 #define steStdFont          "//STESTDFONT//"    /**<Standard Font*/
00184 #define steBoldFont         "//STEBOLDFONT//"   /**<Bold Font*/
00185 /*@}*/
00186
00187 /**
00188  * @name Font colors
00189  *
00190  */
00191 /*@{*/
00192 #define steCurrentFont      "//STECURRENTFONT//" /**<Current font color*/
00193 #define steBlackFont        "//STEBLACKFONT//"  /**<Black font color*/
00194 #define steBlueFont         "//STEBLUEFONT//"   /**<Blue font color*/
00195 #define steRedFont          "//STEREDFONT//"    /**<Red font color*/
00196 #define steGreenFont        "//STEGREENFONT//"  /**<Green font color*/
00197 #define steYellowFont       "//STEYELLOWFONT//" /**<Yellow font color*/
00198 #define stePurpleFont       "//STEPURPLEFONT//" /**<Purple font color*/
00199 #define steOrangeFont       "//STEORANGEFONT//" /**<Orange font color*/
00200 #define steGrayFont         "//STEGRAYFONT//"   /**<Gray font color*/
00201 /*@}*/
00202
00203 /**
00204  * @name Used for formatting
00205  *
00206  */
00207 /*@{*/
00208 #define steLeftIndent       "//STELEFTINDENT="  /**<Left Indentation*/
00209 #define steRightAlign       "//STERIGHTALIGN="  /**<Right Indentation*/
00210 #define steCenterAlign      "//STECENTERALIGN//"    /**<Center Alignment*/
00211 /*@}*/
00212
00213 #define steBitmap           "//STEBITMAP=" /**< Graphics support */
00214
00215 /**
00216  * @name Miscellaneous
00217  *
00218  */
00219 /*@{*/
00220 #define steHorizontalLine   "//STEHORIZONTALLINE//" /**<Horizontal Line*/
00221 #define steLineBreak        "//STELINEBREAK//"  /**<Line Break*/
00222 /*@}*/
00223
00224 // Custom link that calls a callback procedure when selected
00225 #define steHyperlink        "//STEHYPERLINK="   /**<Hyperlink*/
00226
00227 // use this parameter to scroll to the end of the list
00228 #define kScrollToEnd                0xFFFF  /**< Used to scroll to end*/
00229
00230 /**
00231  * @name Text Selection
00232  *
00233  */
00234 /*@{*/
00235 #define kSelectUntilEndOfRecord     0xFFFFFFFE  /**<Select till end of record*/
00236 #define kSelectUntilEnd             0xFFFFFFFF  /**<Select until End*/
00237 /*@}*/
00238
00239 /**
00240  * @name Initializing the Smart Text Engine
00241  *
00242  */
00243 /*@{*/
00244 #define steParsePhoneNumbers        0x00000001  /**<Parse Phone Numbers*/
00245 #define steParseURLs                0x00000002  /**<Parse URLs*/
00246 #define steParseEmail               0x00000004  /**<parse Email*/
00247 #define steParseEmoticons           0x00000008  /**<parse Emotions*/
00248 #define steLargeFont                0x00000010  /**<Large Font*/
00249 #define steCannotSelectText         0x00000020  /**<Cannot Select Text*/
00250 #define steParseMoreEmoticons       0x00000040  /**<Parse More Emoticons*/
00251 #define steScrollWalksLinks         0x00000080  /**<Scroll Walks links*/
00252 #define steInvertHighlighting       0x00000100  /**<Invert highlighting*/
00253 #define steNoLinksBeforeColon       0x00000200  /**<No links before colon*/
00254 #define steAcceleratedScrolling     0x00000400  /**<No Accelerated Scrolling*/
00255 #define steAllowShortPhoneNumbers   0x00000800  /**<Allow Short Phone Numbers*/
00256 #define steParseGSMGreekChars       0x00001000  /**<Parse GSM Greek Characters*/
00257 #define steDoNotCenterVertically    0x00002000  /**<Do not center vertically*/
00258 #define steScrollWalksMessages      0x00004000  /**<Scroll walks messages*/
00259 #define steTextMustBeVisible        0x00008000  /**<If true, then any routine that returns selected text must verify the text is visible first*/
00260 #define steAllowPhoneNumberWords    0x00010000  /**<If true, then the phone number parser will allow numbers like 1-800-TESTING*/
00261 /*@}*/
00262
00263 /** Used for custom hyperlinks */
00264 typedef void (*STECallbackType) (UInt32 refNum);
00265
00266
00267 /**
00268  * @brief Holds parsed item information.
00269  *
00270  * Given a message, or list of messages,
00271  * this structure gives the locations of all parsed items.
00272  */
00273 typedef struct
00274 {
00275   UInt16  parsedType;         /**< what kind of data did we find?*/
00276   UInt16  startLocation;      /**< the starting location of the parsed data we found*/
00277   UInt16  itemLength;         /**< the character length of the parsed data we found*/
00278   UInt16  msgNumber;          /**< when parsing a list of message, this is the message number, otherwise 0*/
00279   UInt16  color;              /**< used to store the font color (for custom hyperlinks)*/
00280   UInt16  nameLength;         /**< used to store the length of the link name (for custom hyperlinks)*/
00281   UInt32  miscData;           /**< used now to store left indentation and other info.  Adapt as needed.*/
00282 } ParsedInfo;
00283
00284 /**
00285  * @brief Holds the list of parsed item information.
00286  */
00287 typedef struct
00288 {
00289   UInt16        size;         /**< how many items did we find in the text?*/
00290   UInt16        maxSize;      /**< maximum number of items that can be added without resizing*/
00291   ParsedInfo    info[1];      /**< parsing info follows*/
00292 } ParsedInfoList;
00293
00294
00295 #ifdef __cplusplus
00296 }
00297 #endif
00298
00299
00300 #endif // _SMARTTEXTENGINEDEF_H_
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:55 2008 for Palm API Guide


Header Files » Incs » common » libraries » smarttextengine

SmartTextEngineErrors.h

Go to the documentation of this file.
00001 /******************************************************************************
00002  * Copyright (c) 2004 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  *****************************************************************************/
00005 /** @ingroup STE
00006  *
00007  */
00008
00009 /**
00010  *
00011  * @file    SmartTextEngineErrors.h
00012  * @brief   Error codes for Smart Text Engine shared library
00013  *
00014  */
00015
00016
00017 #ifndef _SMARTTEXTENGINEERRORS_H_
00018 #define _SMARTTEXTENGINEERRORS_H_
00019
00020 typedef UInt32 STEErr;  /**< Common define for Smart Text Engine Error Code return value */
00021
00022
00023 // Maybe one day I will implement all of these different errors
00024 #define steErrBase                  hsSTEErrorClass     /**< Error Code starting base */
00025 #define steErrUnimplemented         (steErrBase + 1)    /**< Functionality not currently implemented*/
00026 #define steErrInternal              (steErrBase + 2)    /**< Unspecified internal error */
00027 #define steErrDynamicMemory         (steErrBase + 3)    /**< Dynamic memory allocation failed */
00028 #define steErrStorageMemory         (steErrBase + 4)    /**< Storage memory allocation failed */
00029 #define steErrOperationNotAllowed   (steErrBase + 5)    /**< Operation cannot be performed at this time */
00030 #define steErrInvalidArguments      (steErrBase + 6)    /**< Bad arguments */
00031 #define steErrSTEInit               (steErrBase + 7)    /**< STE initialization failed */
00032
00033 #endif // _SMARTTEXTENGINEERRORS_H_
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:55 2008 for Palm API Guide


Header Files » Incs » common » libraries » smarttextengine

SmartTextEngineRsc.h

Go to the documentation of this file.
00001 //*****************************************************************************
00002 // Copyright (c) 2004 palmOne, Inc. or its subsidiaries.
00003 // All rights reserved.
00004 //****************************************************************************/
00005 //* @ingroup STE
00006 //
00007 //
00008
00009 //
00010 //
00011 // @file    SmartTextEngineRsc.h
00012 // @brief   Resource file describing all available icon that can be displayed using the Smart Text Engine shared library.
00013 //
00014 //
00015
00016
00017 // *** DO NOT USE CONSTRUCTOR TO MODIFY THIS FILE !!! ***
00018
00019 #ifndef __SMART_TEXT_ENGINE_RSC_H__
00020 #define __SMART_TEXT_ENGINE_RSC_H__ 1
00021
00022 //
00023 // @name Greek character bitmaps
00024 //
00025 #define Delta11BitMap               9800
00026 #define Gamma11BitMap               9801
00027 #define Lambda11BitMap              9802
00028 #define Omega11BitMap               9803
00029 #define Phi11BitMap                 9804
00030 #define Pi11BitMap                  9805
00031 #define Psi11BitMap                 9806
00032 #define Sigma11BitMap               9807
00033 #define Theta11BitMap               9808
00034 #define Xi11BitMap                  9809
00035
00036 #define Delta14BitMap               9850
00037 #define Gamma14BitMap               9851
00038 #define Lambda14BitMap              9852
00039 #define Omega14BitMap               9853
00040 #define Phi14BitMap                 9854
00041 #define Pi14BitMap                  9855
00042 #define Psi14BitMap                 9856
00043 #define Sigma14BitMap               9857
00044 #define Theta14BitMap               9858
00045 #define Xi14BitMap                  9859
00046
00047
00048
00049 //
00050 // @name Smileys
00051 //
00052 #define SmileyBitMapBaseID          9900
00053 #define Smiley00BitMap              9900
00054 #define Smiley01BitMap              9901
00055 #define Smiley02BitMap              9902
00056 #define Smiley03BitMap              9903
00057 #define Smiley04BitMap              9904
00058 #define Smiley05BitMap              9905
00059 #define Smiley06BitMap              9906
00060 #define Smiley07BitMap              9907
00061 #define Smiley08BitMap              9908
00062 #define Smiley09BitMap              9909
00063 #define Smiley10BitMap              9910
00064 #define Smiley11BitMap              9911
00065 #define Smiley12BitMap              9912
00066 #define Smiley13BitMap              9913
00067 #define Smiley14BitMap              9914
00068 #define Smiley15BitMap              9915
00069 #define Smiley16BitMap              9916
00070 #define Smiley17BitMap              9917
00071 #define Smiley18BitMap              9918
00072 #define Smiley19BitMap              9919
00073 #define Smiley20BitMap              9920
00074 #define Smiley21BitMap              9921
00075 #define Smiley22BitMap              9922
00076 #define Smiley23BitMap              9923
00077
00078
00079
00080 //
00081 // @name Large Smileys
00082 //
00083 #define LargeSmileyBitMapBaseID     9950
00084 #define LargeSmiley00BitMap         9950
00085 #define LargeSmiley01BitMap         9951
00086 #define LargeSmiley02BitMap         9952
00087 #define LargeSmiley03BitMap         9953
00088 #define LargeSmiley04BitMap         9954
00089 #define LargeSmiley05BitMap         9955
00090 #define LargeSmiley06BitMap         9956
00091 #define LargeSmiley07BitMap         9957
00092 #define LargeSmiley08BitMap         9958
00093 #define LargeSmiley09BitMap         9959
00094 #define LargeSmiley10BitMap         9960
00095 #define LargeSmiley11BitMap         9961
00096 #define LargeSmiley12BitMap         9962
00097 #define LargeSmiley13BitMap         9963
00098 #define LargeSmiley14BitMap         9964
00099 #define LargeSmiley15BitMap         9965
00100 #define LargeSmiley16BitMap         9966
00101 #define LargeSmiley17BitMap         9967
00102 #define LargeSmiley18BitMap         9968
00103 #define LargeSmiley19BitMap         9969
00104 #define LargeSmiley20BitMap         9970
00105 #define LargeSmiley21BitMap         9971
00106 #define LargeSmiley22BitMap         9972
00107 #define LargeSmiley23BitMap         9973
00108
00109
00110
00111 #endif // ifndef __SMART_TEXT_ENGINE_RSC_H__
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:55 2008 for Palm API Guide


Header Files » Incs » common » libraries » smarttextengine

SmartTextEngineTraps.h

Go to the documentation of this file.
00001 /******************************************************************************
00002  * Copyright (c) 2004 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  *****************************************************************************/
00005 /** @ingroup STE
00006  *
00007  */
00008
00009 /**
00010  *
00011  * @file    SmartTextEngineTraps.h
00012  *
00013  * @brief   Trap definitions for the Smart Text Engine shared library.
00014  *
00015  */
00016
00017 //          Trap IDs for the Smart Text Engine Library's public functions.
00018 //          The order of the traps must be the same as the routines are
00019 //          listed in SmartTextEngineDispatchTable.c.
00020
00021
00022 #ifndef _SMARTTEXTENGINETRAPS_H_
00023 #define _SMARTTEXTENGINETRAPS_H_
00024
00025
00026 #define STETrapOpen                         sysLibTrapOpen  /**<Open Trap*/
00027 #define STETrapClose                        sysLibTrapClose /**<Close Trap*/
00028
00029 #define STETrapGetAPIVersion                (sysLibTrapCustom + 0)  /**<Trap ID for Get API function*/
00030 #define STETrapInitializeEngine             (sysLibTrapCustom + 1)  /**<Trap ID for Initialize Engine function*/
00031 #define STETrapResetEngine                  (sysLibTrapCustom + 2)  /**<Trap ID for Reset Engine function*/
00032 #define STETrapReinitializeEngine           (sysLibTrapCustom + 3)  /**<Trap ID for Reinitialize Engine function*/
00033 #define STETrapAppendTextToEngine           (sysLibTrapCustom + 4)  /**<Trap ID for Append Text to Engine*/
00034 #define STETrapRemoveLastRecordFromEngine   (sysLibTrapCustom + 5)  /**<Trap ID for Remove last record from engine*/
00035 #define STETrapRenderList                   (sysLibTrapCustom + 6)  /**<Trap ID for render list*/
00036 #define STETrapRerenderList                 (sysLibTrapCustom + 7)  /**<Trap ID for Rerender list*/
00037 #define STETrapHandleEvent                  (sysLibTrapCustom + 8)  /**<Trap ID for Handle Event*/
00038 #define STETrapHandleSclRepeatEvent         (sysLibTrapCustom + 9)  /**<Trap ID for Handle Scl repeat event*/
00039 #define STETrapHandlePenDownEvent           (sysLibTrapCustom + 10) /**<Trap ID for Handle pen down event*/
00040 #define STETrapHandlePenMoveEvent           (sysLibTrapCustom + 11) /**<Trap ID for Handle pen move event*/
00041 #define STETrapHandlePenUpEvent             (sysLibTrapCustom + 12) /**<Trap ID for Handle pen up event*/
00042 #define STETrapHandleKeyDownEvent           (sysLibTrapCustom + 13) /**<Trap ID for Handle key down event*/
00043 #define STETrapGetScroll                    (sysLibTrapCustom + 14) /**<Trap ID for Get scroll*/
00044 #define STETrapSetScroll                    (sysLibTrapCustom + 15) /**<Trap ID for Set scroll*/
00045 #define STETrapGetScrollPct                 (sysLibTrapCustom + 16) /**<Trap ID for Get scroll pct*/
00046 #define STETrapSetScrollPct                 (sysLibTrapCustom + 17) /**<Trap ID for Set scroll pct*/
00047 #define STETrapSetScrollToRecordNum         (sysLibTrapCustom + 18) /**<Trap ID for Set scroll to record num*/
00048 #define STETrapSetFlags                     (sysLibTrapCustom + 19) /**<Trap ID for Set Flags*/
00049 #define STETrapGetNumLines                  (sysLibTrapCustom + 20) /**<Trap ID for Get num lines*/
00050 #define STETrapGetNumRecords                (sysLibTrapCustom + 21) /**<Trap ID for Get num records*/
00051 #define STETrapHasHotRectSelection          (sysLibTrapCustom + 22) /**<Trap ID for Has hot rect selection*/
00052 #define STETrapHasTextSelection             (sysLibTrapCustom + 23) /**<Trap ID for Has text selection*/
00053 #define STETrapClearCurrentSelection        (sysLibTrapCustom + 24) /**<Trap ID for Clear current selection*/
00054 #define STETrapSetCurrentTextSelection      (sysLibTrapCustom + 25) /**<Trap ID for Set current text selection*/
00055 #define STETrapGetCurrentTextSelection      (sysLibTrapCustom + 26) /**<Trap ID for Get current selection*/
00056 #define STETrapGetSelectedText              (sysLibTrapCustom + 27) /**<Trap ID for Get selected text*/
00057 #define STETrapCopySelectionToClipboard     (sysLibTrapCustom + 28) /**<Trap ID for Copy selection clipboard*/
00058 #define STETrapGetLastTapInfo               (sysLibTrapCustom + 29) /**<Trap ID for Last Tap info*/
00059 #define STETrapSetCustomHyperlinkCallback   (sysLibTrapCustom + 30) /**<Trap ID for Set custom hyperlink callback*/
00060 #define STETrapGetFlags                     (sysLibTrapCustom + 31) /**<Trap ID for Get flags*/
00061 #define STETrapHasMessageSelection          (sysLibTrapCustom + 32) /**<Trap ID for Has message selection*/
00062 #define STETrapGetParsedInformation         (sysLibTrapCustom + 33) /**<Trap ID for Get parsed information*/
00063 #define STETrapAppendParsedInfo             (sysLibTrapCustom + 34) /**<Trap ID for Append parsed info*/
00064 #define STEDepracated5                      (sysLibTrapCustom + 35) /**<Trap ID for Depracated5*/
00065 #define STETrapQuickRender                  (sysLibTrapCustom + 36) /**<Trap ID for Quick Render*/
00066
00067 #endif /* _SMARTTEXTENGINETRAPS_H_ */
00068
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:55 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » toneslibrary

TonesLib.h

Go to the documentation of this file.
00001 /******************************************************************************
00002  * Copyright (c) 2004 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  *****************************************************************************/
00005 /**
00006  * @ingroup Tone
00007  *
00008  */
00009
00010 /**
00011  * @file   TonesLib.h
00012  * @brief  Public 68K include file that controls the MIDI tones on a device.
00013  *
00014  * Notes:
00015  *
00016  * The calling application should always load this library with
00017  * SysLibLoad() before use, even if it is already open by another
00018  * application(ie, SysLibFind() returns a valid refnum). When
00019  * the application is done with the library, it should be
00020  * unloaded with SysLibRemove(). We do this because there is
00021  * no good way to synchronize loading and unloading of libraries
00022  * among multiple applications. It also greatly simplifies internal
00023  * synchronization.
00024  */
00025
00026 #ifndef __TONESLIB__H__
00027 #define __TONESLIB__H__
00028
00029 #ifdef __cplusplus
00030 extern "C" {
00031 #endif
00032
00033 /// Minimum db version of TonesLibrary database that implements escalation
00034 /// Done this way since we have no GetLibVersion() API.
00035 #define kTonesLibVersionEscalation  10
00036
00037 /// Open and initialize the Tones library instance.
00038 ///
00039 /// @param refNum: IN:  Library reference number from SysLibLoad.
00040 /// @return Library error code.
00041 Err TonesLibOpen (UInt16 refNum)
00042                  SYS_TRAP (sysLibTrapOpen);
00043
00044 /// Close the Tones library instance.
00045 ///
00046 /// @param refNum: IN:  Library reference number from SysLibLoad.
00047 /// @return Library error code.
00048 Err TonesLibClose (UInt16 refNum)
00049                  SYS_TRAP (sysLibTrapClose);
00050
00051 /// Standard function to receive Palm OS wake up notification.
00052 ///
00053 /// @param refNum: IN:  Library reference number from SysLibLoad.
00054 /// @return Library error code.
00055 Err TonesLibWake (UInt16 refNum)
00056                  SYS_TRAP (sysLibTrapWake);
00057
00058 /// Standard function to receive Palm OS sleep notification.
00059 ///
00060 /// @param refNum: IN:  Library reference number from SysLibLoad.
00061 /// @return Library error code.
00062 Err TonesLibSleep (UInt16 refNum)
00063                  SYS_TRAP (sysLibTrapSleep);
00064
00065 /// Get the list of tone names.
00066 ///
00067 /// @param refNum:      IN:  Library reference number from SysLibLoad.
00068 /// @param list:        IN:  Pointer to the list of tone names to return.
00069 /// @param listLength:  OUT: Count of how many tone names are in the list.
00070 /// @return Library error code.
00071 Err TonesLibGetToneList (UInt16 refNum, ToneItemPtr * list, UInt16 * listLength)
00072                  SYS_TRAP (tonesLibTrapGetToneList);
00073
00074 /// Get the list of tone IDs.
00075 ///
00076 /// @param refNum:      IN:  Library reference number from SysLibLoad.
00077 /// @param list:        IN:  Pointer to the list of tone IDs to return.
00078 /// @param listLength:  OUT: Count of how many tone IDs are in the list.
00079 /// @return Library error code.
00080 Err TonesLibGetToneIDs ( UInt16 refNum, ToneIdentifier ** list, UInt16 * listLength)
00081                  SYS_TRAP (tonesLibTrapGetToneIDs);
00082
00083 /// Get the name of a certain tone given its ID.
00084 ///
00085 /// @param refNum:      IN:  Library reference number from SysLibLoad.
00086 /// @param toneId:      IN:  Tone ID of the tone name to get.
00087 /// @param name:        I/O: Pointer to the returned tone name.
00088 /// @param maxLength:   IN:  Size of the name buffer in bytes.
00089 /// @return Library error code.
00090 Err TonesLibGetToneName (UInt16 refNum, ToneIdentifier toneId, CharPtr name, UInt16
00091     maxLength)
00092                  SYS_TRAP (tonesLibTrapGetToneName);
00093
00094 /// Get the tone data size given its ID.
00095 ///
00096 /// @param refNum:      IN:  Library reference number from SysLibLoad.
00097 /// @param toneId:      IN:  ID number of the tone.
00098 /// @param sizeP:       OUT: Size of the specified tone.
00099 /// @return Library error code.
00100 Err TonesLibGetToneSize (UInt16 refNum, ToneIdentifier toneId, UInt32* sizeP)
00101                  SYS_TRAP (tonesLibTrapGetToneSize);
00102
00103 /// Play a tone given its ID.
00104 ///
00105 /// @param refNum:      IN: Library reference number from SysLibLoad.
00106 /// @param toneId:      IN: ID of the tone to play.
00107 /// @param playCount:   IN: Number of times you want the tone repeated.
00108 /// @param volume:      IN: Volume level at which you want the tone played.
00109 /// @param vibrate:     IN: Vibrate mode to use when playing the tone.
00110 /// @param blocking:    IN: Controls whether the tone play is a blocking call
00111 ///                         or play in the background and return immediately.
00112 /// @return Library error code.
00113 Err TonesLibPlayTone (UInt16 refNum, ToneIdentifier toneId, UInt16 playCount,
00114     ToneVolume volume, ToneVibrateType vibrate, Boolean blocking)
00115                  SYS_TRAP (tonesLibTrapPlayTone);
00116
00117 /// Add a MIDI tone to the system tone database.
00118 ///
00119 /// @param refNum:          IN: Library reference number from SysLibLoad.
00120 /// @param midiTone:        IN: The data buffer handle where the midi tone data is located.
00121 /// @param toneName:        IN: Name of the tone.
00122 /// @param protectedTone:   IN: Save tone as protected record in the tone database.
00123 /// @return Library error code.
00124 Err TonesLibAddMidiTone (UInt16 refNum, MemHandle midiTone, CharPtr toneName,
00125     Boolean protectedTone)
00126                  SYS_TRAP (tonesLibTrapAddMidiTone);
00127
00128 /// Create new tone and return the pointer to the start of the sound stream.
00129 ///
00130 /// @param refNum:          IN:  Library reference number from SysLibLoad.
00131 /// @param streamP:         OUT: Pointer to the sound stream of the new tone.
00132 /// @param toneType:        IN:  Type of the tone. @see ToneType.
00133 /// @param toneName:        IN:  Name of the tone.
00134 /// @param protectedTone:   IN:  Save tone as protected record in the tone database.
00135 /// @return Library error code.
00136 Err TonesLibToneCreate (UInt16 refNum, UInt32* streamP, ToneType toneType,
00137                         CharPtr toneName, Boolean protectedTone)
00138                  SYS_TRAP (tonesLibTrapToneCreate);
00139
00140 /// Write sound data to the stream returned by TonesLibToneCreate().
00141 ///
00142 /// @param refNum:   IN: Library reference number from SysLibLoad.
00143 /// @param stream:   IN: Reference to the steam returned by TonesLibToneCreate().
00144 /// @param dataP:    IN: Pointer to the Tone(Sound) data.
00145 /// @param size:     IN: Size of the data to be written.
00146 /// @return Library error code.
00147 Err TonesLibToneWrite (UInt16 refNum, UInt32 stream, const void* dataP, Int32 size)
00148                  SYS_TRAP (tonesLibTrapToneWrite);
00149
00150 /// Close the reference to the tone stream.
00151 ///
00152 /// @param refNum: IN:  Library reference number from SysLibLoad.
00153 /// @param stream: IN:  Reference to the steam returned by TonesLibToneCreate().
00154 /// @return Library error code.
00155 Err TonesLibToneClose (UInt16 refNum, UInt32 stream)
00156                  SYS_TRAP (tonesLibTrapToneClose);
00157
00158 /// Display UI to manage tones. Users can delete, play, or send a tone from this UI.
00159 ///
00160 /// @param refNum: IN:  Library reference number from SysLibLoad.
00161 /// @return Library error code.
00162 Err TonesLibManageTones (UInt16 refNum)
00163                  SYS_TRAP (tonesLibTrapManageTones);
00164
00165 /// Delete a tone given its ID.
00166 ///
00167 /// @param refNum: IN:  Library reference number from SysLibLoad.
00168 /// @param toneId: IN:  ID of the tone to be deleted.
00169 /// @return Library error code.
00170 Err TonesLibDeleteTone (UInt16 refNum, ToneIdentifier toneId)
00171                   SYS_TRAP (tonesLibTrapDeleteTone);
00172
00173 /// Create the default tone database if it does not exist, and verify that all the tones
00174 /// in a database are resident on the device.
00175 ///
00176 /// @param refNum: IN:  Library reference number from SysLibLoad.
00177 /// @return Library error code.
00178 Err TonesLibInitTonesDB (UInt16 refNum)
00179                    SYS_TRAP (tonesLibTrapInitTonesDB);
00180
00181 /// Get the sound preference for a type of (application) sound.
00182 ///
00183 /// @param refNum:       IN:    Library reference number from SysLibLoad.
00184 /// @param soundType:    IN:    Type of (application: email, SMS, phone call, etc) sound.
00185 /// @param soundPrefs:   OUT:   Preference settings for a type of sound.
00186 /// @return Library error code.
00187 Err TonesLibGetSoundPrefs (UInt16 refNum, SoundPrefType soundType, SoundPreference * soundPrefs)
00188                   SYS_TRAP (tonesLibTrapGetSoundPrefs);
00189
00190 /// Set the sound preference for a type of (application) sound.
00191 ///
00192 /// @param refNum:       IN:    Library reference number from SysLibLoad.
00193 /// @param soundType:    IN:    Type of (application) sound.
00194 /// @param soundPrefs:   IN:    Preference settings for the type of sound.
00195 /// @return Library error code.
00196 Err TonesLibSetSoundPrefs (UInt16 refNum, SoundPrefType soundType, SoundPreference * soundPrefs)
00197                   SYS_TRAP (tonesLibTrapSetSoundPrefs);
00198
00199 /// Display the UI to select tones and return the tone type, tone name, and handle to
00200 /// the tone data.
00201 ///
00202 /// @param refNum:      IN:  Library reference number from SysLibLoad.
00203 /// @param toneType:    OUT: Type of tone.
00204 /// @param toneH:       OUT: Handle to the tone selected. Must be freed by the caller.
00205 /// @param name:        OUT: Name of the tone.
00206 /// @return Library error code.
00207 Err TonesLibPickTone (UInt16 refNum, ToneType * toneType, MemHandle *toneH, Char
00208     * name)
00209                   SYS_TRAP (tonesLibTrapPickTone);
00210
00211 /// Stop the playback of the current tone.
00212 ///
00213 /// @param refNum: IN:  Library reference number from SysLibLoad.
00214 /// @return Library error code.
00215 Err TonesLibStopTone (UInt16 refNum)
00216                   SYS_TRAP (tonesLibTrapStopTone);
00217
00218 /// Get the sound-on volume of a sound type.
00219 ///
00220 /// @param refNum:          IN:  Library reference number from SysLibLoad.
00221 /// @param soundType:       IN:  Type of (application) sound.
00222 /// @param soundOnVolumeP:  OUT: Volume of the sound.
00223 /// @return Library error code.
00224 Err TonesLibGetSoundOnVolume (UInt16 refNum, SoundPrefType soundType,
00225                               ToneVolume* soundOnVolumeP)
00226                   SYS_TRAP (tonesLibTrapGetSoundOnVolume);
00227
00228 /// Set the sound-on volume of a sound type.
00229 ///
00230 /// @param refNum:          IN: Library reference number from SysLibLoad.
00231 /// @param soundType:       IN: Type of (application) sound.
00232 /// @param soundOnVolume:   IN: Volume of the tone.
00233 /// @return Library error code.
00234 Err TonesLibSetSoundOnVolume (UInt16 refNum, SoundPrefType soundType,
00235                               ToneVolume soundOnVolume)
00236                   SYS_TRAP (tonesLibTrapSetSoundOnVolume);
00237
00238 /// Display the UI to create and/or manages tones.
00239 ///
00240 /// @param refNum:  IN: Library reference number from SysLibLoad.
00241 /// @param flags:   IN: Set to kTonesDialogFlagNonModal to hide the Done button from the dialog.
00242 /// @return Library error code.
00243 Err TonesLibDoDialog (UInt16 refNum, UInt32 flags)
00244                  SYS_TRAP (tonesLibTrapDoDialog);
00245
00246 /// No definition.
00247 ///
00248 /// @param refNum: IN:  Library reference number from SysLibLoad.
00249 /// @return Library error code.
00250 Err TonesLibRecordTone (UInt16 refNum)
00251                 SYS_TRAP (tonesLibTrapToneRecord);
00252
00253 /// Query or toggle whether ring tones are escalated in volume when played.
00254 ///
00255 /// @param refNum:  IN: Library reference number from SysLibLoad.
00256 /// @param set:     IN: true if setting, false if querying.
00257 /// @param value:   IN: Value to set if setting, queried value if querying.
00258 /// @return Library error code.
00259 Err TonesLibEscalateRingTones (UInt16 refNum, Boolean set, Boolean *value)
00260                  SYS_TRAP (tonesLibTrapEscalateRingTones);
00261
00262 /// Play a ring tone given its ID.  The difference between this and PlayTone is
00263 /// that tones played this way are affected by TonesLibEscalateRingTones().
00264 ///
00265 /// @param refNum:      IN: Library reference number from SysLibLoad.
00266 /// @param toneId:      IN: ID of the tone to play.
00267 /// @param playCount:   IN: Number of times you want the tone repeated.
00268 /// @param volume:      IN: Volume level at which you want the tone played.
00269 /// @param vibrate:     IN: Vibrate mode to use when playing the tone.
00270 /// @param blocking:    IN: Controls whether the tone play is a blocking call
00271 ///                         or play in the background and return immediately.
00272 /// @return Library error code.
00273 Err TonesLibPlayRingTone (UInt16 refNum, ToneIdentifier toneId, UInt16 playCount,
00274     ToneVolume volume, ToneVibrateType vibrate, Boolean blocking)
00275                  SYS_TRAP (tonesLibTrapPlayRingTone);
00276
00277 // Save a copy of undeletable tones into a separate hidden db
00278 // so that we can copy them back to main MIDI db. This is in case that delete
00279 // protected tones got lost during recovery hot sync where MIDI db from the
00280 // computer profile was copied over to the device.
00281 // Called from SoundPhone Panel at SyncStart notification
00282 //
00283 // @param   refNum  IN: Library reference number from SysLibLoad.
00284 // @return  Library error code
00285 Err TonesLibSaveUndeletableTones(UInt16 refNum)
00286                  SYS_TRAP (tonesLibTrapSaveUndeletableTones);
00287
00288 // After hot Sync has finished copy back delete protected tones from
00289 // backup db to main MIDI db. See TonesLibSaveUndeletableTones also.
00290 // Called from SoundPhone Panel at SyncFinish notification
00291 //
00292 // @param   refNum  IN: Library reference number from SysLibLoad.
00293 // @return  Library error code
00294 Err TonesLibCopyBackUndeletableTones(UInt16 refNum)
00295                  SYS_TRAP (tonesLibTrapCopyBackUndeletableTones);
00296
00297 #ifdef __cplusplus
00298 }
00299 #endif
00300
00301 #endif // __TONESLIB__H__
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:55 2008 for Palm API Guide


Header Files » Incs » common » libraries » toneslibrary

TonesLibTypes.h

Go to the documentation of this file.
00001 /*******************************************************************************
00002  * Copyright (c) 2004-2005 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  ******************************************************************************/
00005 /**
00006  * @defgroup    Tone Ring Tone Library
00007  * @brief       This library provides support for application that wants to
00008  *              manage or play ring tones from within the application itself.
00009  *
00010  * Applications that wish to play, manage or create ring tones from within the
00011  * application themselves can use the APIs provided by this library. This library
00012  * can also be used to set different ring tones preferences that are used by
00013  * the system when there is, for example, an incoming call, email or sms alert, etc.
00014  *
00015  * The calling application should always load this library with
00016  * SysLibLoad() before use, even if it is already open by another
00017  * application(ie, SysLibFind() returns a valid refnum). When
00018  * the application is done with the library, it should be
00019  * unloaded with SysLibRemove(). We do this because there is
00020  * no good way to synchronize loading and unloading of libraries
00021  * among multiple applications. It also greatly simplifies internal
00022  * synchronization.
00023  *
00024  * @{
00025  * @}
00026  */
00027 /**
00028  * @ingroup Tone
00029  */
00030
00031 /**
00032  * @file    TonesLibTypes.h
00033  * @brief   Public 68K header file for the Ring Tone library on Treo devices.
00034  *
00035  * This file contains the common constants for the tones and also the structure
00036  * that contains the ring-tone related sound preferences.
00037  * <hr>
00038  */
00039
00040 #ifndef TONES_LIB_TYPES__H__
00041 #define TONES_LIB_TYPES__H__
00042
00043 #define      tonesLibName           "Tones Library" /**<Name of the Tone Types library. */
00044 #define      tonesLibCreator        hsFileCTonesLib /**<Creator ID of the Tone Types library. */
00045 #define      tonesLibType           sysFileTLibrary /**<Type of the Tone Types library. */
00046
00047 #define      kMaxTonesNameSize       32 /**<Maximum size of a tone name. */
00048 #define       tonesLibPlayForever     0xFFFF /**<Used to play a tone over and over indefinitely. */
00049
00050 /**
00051  * @name Error Codes
00052  *
00053  */
00054 /*@{*/
00055 #define      tonesLibErrClass        0x9000 /**<No definition. */
00056 #define      tonesLibErrCreateDBFailed  tonesLibErrClass | 1/**<No definition. */
00057 #define      tonesLibErrNoMemory        tonesLibErrClass | 2/**<No definition. */
00058 #define      tonesLibErrNoTone          tonesLibErrClass | 3/**<No definition. */
00059 #define      tonesLibErrDBNotFound      tonesLibErrClass | 4/**<No definition. */
00060 #define      tonesLibErrDBWriteFailed   tonesLibErrClass | 5/**<No definition. */
00061 #define      tonesLibErrUserCancel      tonesLibErrClass | 6/**<No definition. */
00062 #define      tonesLibErrBadParams       tonesLibErrClass  | 7/**<No definition. */
00063 #define      tonesLibErrUnknown         tonesLibErrClass | 8/**<No definition. */
00064 #define      tonesLibErrNotAllowed       tonesLibErrClass | 9/**<No definition. */
00065 #define      tonesLibErrAlreadyPlaying       tonesLibErrClass | 10/**<No definition. */
00066 /*@}*/
00067
00068 /**
00069  * @name Utility Macros
00070  *
00071  */
00072 /*@{*/
00073 #define      CompareToneIdentifiers(tone1, tone2) \
00074              (tone1.id == tone2.id && tone1.toneType == tone2.toneType)/**<No definition. */
00075 #define      CopyToneIdentifier(destP, src) \
00076              destP->id = src.id; \
00077              destP->toneType = src.toneType/**<No definition. */
00078 #define      CopyMIDIToneIdentifier(destP, src) \
00079              destP->id = src; \
00080              destP->toneType = toneTypeMIDI/**<No definition. */
00081 /*@}*/
00082
00083 /**
00084  * Tone types
00085  */
00086 enum _ToneType {
00087     toneTypeMIDI,         /**<Record in MIDI Ring Tones DB. */
00088     toneTypeWAV,          /**<WAV in a SndFileStream. */
00089     toneTypeAMR,          /**<AMR in a SndFIleStream. */
00090     toneTypeSystemSound,  /**<Unused. */
00091     toneTypeQCELP,        /**<QCELP in a SndFileStream. */
00092     toneTypeMP3,          /**<MP3 in a SndFileStream */
00093     toneTypeAAC           /**<AAC in a SndFileStream */
00094 };
00095
00096 /** Holds tone type value */
00097 typedef UInt16 ToneType;
00098
00099 /**
00100  * Sound preferences type
00101  */
00102 enum _SoundPrefType
00103 {
00104   soundPrefTypePhone,           /**<Tone pref for phone. */
00105   soundPrefTypeEmail,           /**<Tone pref for email. */
00106   soundPrefTypeCalendar,        /**<Tone pref for Calendar. */
00107   soundPrefTypeIM,              /**<Tone pref for IM. */
00108   soundPrefTypeMMS,             /**<Tone pref for MMS. */
00109   soundPrefTypeSMS,             /**<Tone pref for SMS. */
00110   soundPrefTypeNetworkSounds,   /**<Tone pref for SMS. */
00111   soundPrefTypeLast             /**<Last item in enum. Please keep it as last item. */
00112 };
00113
00114 /** Holds sound preference type value */
00115 typedef UInt16  SoundPrefType;
00116
00117 /**
00118  * Tone volume
00119  */
00120 enum _ToneVolume
00121 {
00122   toneVolumeOff,    /**<Volume off */
00123   toneVolume1,      /**<Volume level 1 */
00124   toneVolume2,      /**<Volume level 2 */
00125   toneVolume3,      /**<Volume level 3 */
00126   toneVolume4,      /**<Volume level 4 */
00127   toneVolume5,      /**<Volume level 5 */
00128   toneVolume6,      /**<Volume level 6 */
00129   toneVolume7       /**<Volume level 7 */
00130 };
00131
00132 /** Holds tone volume value */
00133 typedef UInt16  ToneVolume;
00134
00135 /**
00136  * Number of times to play tone
00137  */
00138 enum _TonePlayNumberTimes
00139 {
00140   tonePlayOnce,     /**<Play once. */
00141   tonePlayTwice,    /**<Play twice. */
00142   tonePlay3Times,   /**<Play three times. */
00143   tonePlay5Times,   /**<Play five times. */
00144   tonePlay10Times,  /**<Play ten times. */
00145   tonePlay100Times  /**<Play one hundred times. */
00146 };
00147
00148 /** Holds number of times to play a tone value */
00149 typedef UInt8 TonePlayNumberTimes;
00150
00151 /**
00152  * Tone repeat interval
00153  */
00154 enum _ToneRepeatInterval
00155 {
00156   toneRepeatEveryMinute,    /**<Repeat every minute. */
00157   toneRepeatEvery5Minutes,  /**<Repeat every 5 minutes. */
00158   toneRepeatEvery10Minutes, /**<Repeat every 10 minutes. */
00159   toneRepeatEvery30Minutes  /**<Repeat every 30 minutes. */
00160 };
00161
00162 /** Holds the tone repeat interval value */
00163 typedef UInt8 ToneRepeatInterval;
00164
00165 /**
00166  * Tone time unit
00167  */
00168 enum _ToneTimeUnit
00169 {
00170   toneTimeUnitMinutes,   /**< Minutes */
00171   toneTimeUnitHours,     /**< Hours */
00172   toneTimeUnitDays       /**< Days  */
00173
00174 };
00175
00176 /** Holds the tone time unit value */
00177 typedef UInt8 ToneTimeUnit;
00178
00179 /**
00180  * Tone vibrate type
00181  */
00182 enum _ToneVibrateType
00183 {
00184   toneVibrateNone,      /**< None */
00185   toneVibrateRing,      /**< Phone ring event */
00186   toneVibrateAlert,     /**< Alert event */
00187   toneVibrateMail,      /**< New mail */
00188   toneVibrateCalender,  /**< Calendar event */
00189   toneVibrateSMS,       /**< New SMS */
00190   toneVibrateVoicemail, /**< New Voicemail */
00191   toneVibrateThenRing,  /**< Phone vibrate-then-ring event */
00192
00193   /* We are reserving the upper 2 bits in the ToneVibrateType for tone interrupt mode information */
00194   toneInterruptPhone = 64,  /**< Interrupt mode for phone '01' in upper two bits */
00195   toneInterruptMode2 = 128, /**< Reserved interrupt mode  '10' in upper two bits */
00196   toneInterruptMode3 = 192, /**< Reserved interrupt mode  '11' in upper two bits */
00197 };
00198
00199 #define toneInterruptMask 0x00C0
00200
00201 /** Holds the tone vibrate type value */
00202 typedef UInt8 ToneVibrateType;
00203
00204 /**
00205  * @brief No definition.
00206  */
00207 typedef struct {
00208     UInt32 id;          /**<Tone ID */
00209     ToneType toneType;  /**<Tony Type (AMR, MIDI, etc). @see ToneType */
00210 } ToneIdentifier;
00211
00212 /**
00213  * @brief Tone characteristics
00214  */
00215 typedef struct {
00216
00217     Char   name [kMaxTonesNameSize];  /**<Name of the ring tone.  */
00218     ToneIdentifier identifier;  /**<Unique ID for the ring tone.  */
00219     Boolean protectedTone;   /**<Whether Tone is protected and cannot be beamed or sent.  */
00220
00221 } ToneItemType, * ToneItemPtr;
00222
00223 /**
00224  * @brief  Structure for IM Sound Pref.
00225  */
00226 typedef struct {
00227
00228     ToneIdentifier chatTone;    /**<Tone used for chatting */
00229     ToneIdentifier messageTone; /**<Tone used for messaging */
00230
00231 } SoundPreferenceIM;
00232
00233 /**
00234  * @brief  Structure for Phone Sound Pref.
00235  */
00236 typedef struct {
00237     ToneIdentifier unknownCallerTone;   /**<Tone used when caller is unknown */
00238     ToneIdentifier knownCallerTone;     /**<Tone used when caller is known */
00239     ToneIdentifier roamingTone;         /**<Tone used when roaming */
00240     ToneIdentifier  voicemailTone;      /**<Tone used for incoming voicemail */
00241     Boolean serviceTone;                /**<No definition. */
00242 } SoundPreferencePhone;
00243
00244 /**
00245  * @brief  Structure for Email Sound Pref.
00246  */
00247 typedef struct {
00248     ToneIdentifier alertTone;   /**<Tone used for new email alert */
00249     Boolean newMailAlert;       /**<Play tone if true */
00250 } SoundPreferenceEmail;
00251
00252 /**
00253  * @brief  Structure for Calendar Sound Pref.
00254  */
00255 typedef struct {
00256     ToneIdentifier alarmTone;               /**<Tone used for alarm */
00257     ToneIdentifier reminderTone;            /**<Tone used for event reminder */
00258     TonePlayNumberTimes playSoundTimes;     /**<Number of times tone should be played */
00259     TonePlayNumberTimes repeatAlarmTimes;   /**<Number of time alarm should be repeated */
00260     ToneRepeatInterval repeatInterval;      /**<Alarm repeat interval */
00261     UInt16 presetTime;                      /**<Alarm preset time */
00262     ToneTimeUnit presetTimeUnit;            /**<Alarm preset time unit (minute, hour, day) */
00263     Boolean alarmPreset;                    /**<Preset alarm if true */
00264 } SoundPreferenceCalendar;
00265
00266 /**
00267  * @brief  Structure for SMS Sound Pref.
00268  */
00269 typedef struct {
00270     ToneIdentifier messageTone; /**<Tone used for SMS */
00271     Boolean privacy;            /**<No definition. */
00272     Boolean msgAlert;           /**<If true, alert when new SMS arrives */
00273     Boolean rcptAlert;          /**<If true, alert when recipient receives SMS */
00274 } SoundPreferenceSMS;
00275
00276 /**
00277  * @brief  Structure for MMS Sound Pref.
00278  */
00279 typedef struct {
00280   ToneIdentifier messageTone;   /**<Tone used when MMS arrives*/
00281 } SoundPreferenceMMS;
00282
00283 /**
00284  * @brief  Structure for network related sounds.
00285  */
00286 typedef struct {
00287     Boolean signalFadedTone;
00288     Boolean eriStatusTone;
00289 } SoundPreferenceNetworkSounds;
00290
00291
00292 /**
00293  * @brief  Structure containing all the Sound Preference data.
00294  */
00295 typedef struct {
00296     /** union of various sound preferences */
00297     union _tonePrefs
00298       {
00299         SoundPreferenceIM imSoundPrefs;                     /**<No definition. */
00300         SoundPreferencePhone phoneSoundPrefs;               /**<No definition. */
00301         SoundPreferenceEmail emailSoundPrefs;               /**<No definition. */
00302         SoundPreferenceCalendar calendarSoundPrefs;         /**<No definition. */
00303         SoundPreferenceSMS  smsSoundPrefs;                  /**<No definition. */
00304         SoundPreferenceMMS  mmsSoundPrefs;                  /**<No definition. */
00305         SoundPreferenceNetworkSounds  networkSoundPrefs;    /**<No definition. */
00306       } tonePrefs;                                          /**<Holds data for various Sound Prefs */
00307     ToneVolume soundOnVolume;                               /**<Volume of tone */
00308     Boolean soundOnVibrate;                                 /**<No definition. */
00309     Boolean soundOffVibrate;                                /**<No definition. */
00310 } SoundPreference;
00311
00312 #define kTonesDialogFlagNonModal      0x00000001    /**<Hides the Done button from the play tone dialog. */
00313
00314 /**
00315  * @name Function Traps
00316  *
00317  */
00318 /*@{*/
00319 #define       tonesLibTrapGetToneList  sysLibTrapCustom /**<Trap ID for the function that gets the tone list. */
00320 #define       tonesLibTrapGetToneIDs    sysLibTrapCustom+1/**<Trap ID for the function that gets the list of tone ids. */
00321 #define       tonesLibTrapGetToneName   sysLibTrapCustom+2/**<Trap ID for the function that gets the name of a tone. */
00322 #define       tonesLibTrapPlayTone      sysLibTrapCustom+3/**<Trap ID for the function that plays a tone. */
00323 #define       tonesLibTrapAddMidiTone       sysLibTrapCustom+4/**<Trap ID for the function to add a MIDI tone.
00324   Note: This used to be tonesLibTrapAddTone. Leaving this
00325           trap number maintains binary compatability with existing
00326           applications. Recompiling older source code will fail since
00327           the new version of TonesLibAddTone takes toneType as
00328           an additional parameter. */
00329 #define       tonesLibTrapManageTones       sysLibTrapCustom+5/**<Trap ID for function to manage tones. */
00330 #define       tonesLibTrapDeleteTone       sysLibTrapCustom+6/**<Trap ID for function to delete a tone. */
00331 #define       tonesLibTrapGetSoundPrefs     sysLibTrapCustom+7/**<Trap ID for function to get a sound preference. */
00332 #define       tonesLibTrapSetSoundPrefs     sysLibTrapCustom+8/**<Trap ID for function to set a sound preference. */
00333 #define       tonesLibTrapInitTonesDB       sysLibTrapCustom+9/**<Trap ID for function to initialize the Tones database. */
00334 #define       tonesLibTrapPickTone          sysLibTrapCustom+10/**<Trap ID for function to pick a tone to attach. */
00335 #define       tonesLibTrapStopTone          sysLibTrapCustom+11/**<Trap ID for function to stop the playback of the current tone. */
00336 #define       tonesLibTrapGetSoundOnVolume  sysLibTrapCustom+12/**<Trap ID for function to get the on volume of a sound type. */
00337 #define       tonesLibTrapSetSoundOnVolume  sysLibTrapCustom+13/**<Trap ID for function to set the on volume of a sound type. */
00338 #define       tonesLibTrapDoDialog          sysLibTrapCustom+14/**<Trap ID for function to display the tones list. */
00339 #define       tonesLibTrapGetToneSize       sysLibTrapCustom+15/**<Trap ID for function to get the size of a tone. */
00340 #define       tonesLibTrapToneCreate        sysLibTrapCustom+16/**<Trap ID for function to begin adding a new tone. */
00341 #define       tonesLibTrapToneWrite         sysLibTrapCustom+17/**<Trap ID for function to write data to a new tone. */
00342 #define       tonesLibTrapToneClose         sysLibTrapCustom+18/**<Trap ID for function to finish adding a new tone. */
00343 #define       tonesLibTrapToneRecord        sysLibTrapCustom+19/**<Trap ID for function to record a new tone. */
00344 #define       tonesLibTrapEscalateRingTones sysLibTrapCustom+20/**<Trap ID for function to set/query ringtone escalation. */
00345 #define       tonesLibTrapPlayRingTone      sysLibTrapCustom+21/**<Trap ID for function to play a ringtone. */
00346 #define       tonesLibTrapSaveUndeletableTones      sysLibTrapCustom+22 /**<Trap ID for function to create backup db. */
00347 #define       tonesLibTrapCopyBackUndeletableTones  sysLibTrapCustom+23 /**<Trap ID for function to copy undeletable tones back. */
00348
00349 /*@}*/
00350
00351 #endif  // TONES_LIB_TYPES__H__
00352
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:55 2008 for Palm API Guide


Header Files » Incs » 68k » libraries » transparencylibrary

TransparencyLib.h

Go to the documentation of this file.
00001 /******************************************************************************
00002  * Copyright (c) 2004 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  *****************************************************************************/
00005 /**
00006  * @ingroup Transparency
00007  */
00008
00009 /**
00010  * @file  TransparencyLib.h
00011  * @brief Transparency Library that couples a Ccp channel and a serial port
00012  *
00013  * This library can be used to couple data between a Ccp channel and a serial
00014  * port. It is meant to be used for diagnostics and tethered mode. Since it is a
00015  * library, it can work without being in a certain application.
00016  */
00017
00018 #ifndef __TRANSPARENCY_LIB_INT__H__
00019 #define __TRANSPARENCY_LIB_INT__H__
00020
00021 #ifdef __cplusplus
00022 extern "C" {
00023 #endif
00024
00025 /// Open the Transparency Library and connect the radio modem directly with a
00026 /// known port.
00027 ///
00028 /// @param refNum:          IN: Library Reference Number.
00029 /// @param portAChannel:    IN: CcpChannelType of radio port.
00030 /// @param portB:           IN: Port ID of the second port. This is the serial or USB port.
00031 /// @retval Err             Error code.
00032 ///
00033 /// @code
00034 /// err = SysLibFind (transLibName, &refNum);
00035 /// if (!err)
00036 ///     err=TransLibOpenConnection(refNum,kCcpChannelTypeModem, 0x8000);
00037 /// @endcode
00038 Err TransLibOpenConnection (UInt16 refNum, CcpChannelType portAChannel, UInt32 portB)
00039                                                SYS_TRAP (transLibTrapOpenConnection);
00040
00041 /// Close the Transparency Library previously open and set the radio module in the
00042 /// correct state.
00043 ///
00044 /// @param refNum: IN: Library Reference Number.
00045 /// @retval Err Error code.
00046 Err TransLibCloseConnection (UInt16 refNum)
00047                            SYS_TRAP (transLibTrapCloseConnection);
00048 #ifdef __cplusplus
00049 }
00050 #endif
00051
00052 #endif // __TRANSPARENCY_LIB_INT__H__
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:55 2008 for Palm API Guide


Header Files » Incs » common » libraries » transparencylibrary

TransparencyLibTypes.h

Go to the documentation of this file.
00001 /*******************************************************************************
00002  * Copyright (c) 2004-2005 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  ******************************************************************************/
00005 /**
00006  * @defgroup    Transparency Transparency Library
00007  * @brief       This library can be used to couple data between a Ccp channel and a serial
00008  *              port.
00009  *
00010  * It is meant to be used for diagnostics and tethered mode. Since it is a
00011  * library, it can work without being in a certain application.
00012  *
00013  * @{
00014  * @}
00015  */
00016 /**
00017  * @ingroup Transparency
00018  */
00019
00020 /**
00021  * @file TransparencyLibTypes.h
00022  * @brief   Public common header file for the Transparency Library on Treo devices.
00023  *
00024  * This file contains the common types of the Transparency Library.
00025  * <hr>
00026  */
00027
00028 #ifndef __TRANSPARENCY_LIB_TYPES_INT__H__
00029
00030 #define __TRANSPARENCY_LIB_TYPES_INT__H__
00031
00032 /**
00033  * Transparency library names
00034  **/
00035 #define  transLibName                   "Transparency Library"
00036
00037 /**
00038  * Creator ID of Transparency Library - 'HsTL'
00039  **/
00040 #define  transLibCreator                hsFileCTransparencyLib
00041
00042 /**
00043  * Type ID of transparency library
00044  **/
00045 #define  transLibType                   sysFileTLibrary
00046
00047 /**
00048  * @name Function Traps
00049  */
00050 /*@{*/
00051 #define transLibTrapOpenConnection      sysLibTrapCustom
00052 #define transLibTrapCloseConnection     sysLibTrapCustom+1
00053 /*@}*/
00054
00055 /**
00056  * @name Error Codes
00057  */
00058 /*@{*/
00059
00060 /**
00061  * Error class for the transparency library
00062  **/
00063 #define   transLibErrorClass  0x5000
00064
00065 /**
00066  *  Unkown command requested. For example, an unknown channel type was passed as
00067  *  a port.
00068  **/
00069 #define   transLibErrUnknown  (transLibErrorClass | 1)
00070
00071 /**
00072  *  No connection is open.
00073  **/
00074 #define   transLibErrNotOpen  (transLibErrorClass | 2)
00075
00076 /**
00077  *  Transparency library already open
00078  **/
00079 #define   transLibErrAlreadyOpen  (transLibErrorClass | 3)
00080
00081 /**
00082  *  Transparency library error when there is cradle not attached to the bottom port
00083  **/
00084 #define   transLibErrDockNotAttached (transLibErrorClass | 4)
00085
00086 /*@}*/
00087
00088 #endif
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:55 2008 for Palm API Guide


Header Files » Incs » common » libraries » vmfont

VMFontLibCommon.h

Go to the documentation of this file.
00001 /*******************************************************************************
00002  * Copyright (c) 2004-2005 palmOne, Inc. or its subsidiaries.
00003  * All rights reserved.
00004  ******************************************************************************/
00005 /**
00006  * @defgroup    Versamail Versamail Library
00007  * @brief       This library provide supports for application that wish to
00008  *              provide users with the Versamail Font Picker dialog and support
00009  *              the font from with the app.
00010  *
00011  * This library also allows application to programmatically manage style and size
00012  * for the font types that Versamail support. Other VersaMail supports include
00013  * launching VersaMail to add a new email with attachment and also the ability
00014  * to create a plugin to send/view attachments.
00015  *
00016  * @{
00017  * @}
00018  */
00019 /**
00020  * @ingroup Versamail
00021  */
00022
00023 /**
00024  * @file    VMFontLibCommon.h
00025  * @version 1.0
00026  * @brief   Public common header file for the Versamail Font Library.
00027  *
00028  * This file contains the constants and structures for the palmOne VersaMail
00029  * Font Picker / Font Manager Service.
00030  */
00031
00032 #ifndef __PALMONEVMFONTLIBCOMMON_H__
00033 #define __PALMONEVMFONTLIBCOMMON_H__
00034
00035 #include <PalmTypes.h>
00036 #include <Font.h>
00037 #include <DataMgr.h>
00038
00039 /********************************************************************
00040  * Traps
00041  ********************************************************************/
00042 /**
00043  * @name Function Traps
00044  */
00045 /*@{*/
00046 #define  flTrapAPIVersion               (sysLibTrapCustom + 0)
00047 #define  flTrapAPIGetFont               (sysLibTrapCustom + 1)
00048 #define  flTrapAPIGetFontByID           (sysLibTrapCustom + 2)
00049 #define  flTrapAPIFontExists            (sysLibTrapCustom + 3)
00050 #define  flTrapAPIFontToString          (sysLibTrapCustom + 4)
00051 #define  flTrapAPIFontCountStyleAndSize (sysLibTrapCustom + 5)
00052 #define  flTrapAPISetFontUIRules        (sysLibTrapCustom + 6)
00053 #define  flTrapAPIInitFontUI            (sysLibTrapCustom + 7)
00054 #define  flTrapAPIDoFontDialog          (sysLibTrapCustom + 8)
00055 #define  flTrapAPIClearCache            (sysLibTrapCustom + 9)
00056 /*@}*/
00057
00058 /********************************************************************
00059  * Library type and creator
00060  ********************************************************************/
00061
00062 #define fontPickerLibName           "PalmSGFontLib.Lib" /**< Font library name. */
00063 #define fontPickerType              'appl'              /**< Font library Type. */
00064 #define fontPickerCreatorID         'MA10'              /**< Font library Creator ID. */
00065
00066
00067 /********************************************************************
00068  * Typedefs and constants used in Font Picker lib
00069  ********************************************************************/
00070
00071 /** A parameter passed was Invalid */
00072 #define VMFontErrParam          (appErrorClass | 1)
00073
00074 /** Error meaning that the library is not open */
00075 #define VMFontErrNotOpen        (appErrorClass | 2)
00076
00077 /** Error returned from VMFontClose() if the library is still open */
00078 #define VMFontErrStillOpen  (appErrorClass | 3)
00079
00080 /**
00081  * Font Face
00082  *
00083  */
00084 enum _VMFontFace {
00085     gillSans  = 0,          /**< Gill Sans MT Font  */
00086     sabon,                  /**< Sabon MT Font  */
00087     //segoe,                /**< Segoe MT Font  */
00088     //thorndale,            /**< ThornDale MT Font  */
00089     palm                    /**< Palm  */
00090 };
00091
00092 typedef UInt8 VMFontFace; /**< Used with _VMFontFace */
00093
00094 /**
00095  * Font Size
00096  *
00097  */
00098 enum _VMFontSize {
00099     size6  = 0,         /**< Size = 6  */
00100     size9  = 1,         /**< Size = 9  */
00101     size12 = 2          /**< Size = 12  */
00102 };
00103
00104 typedef UInt8 VMFontSize; /**< Used with _VMFontSize */
00105
00106 /**
00107  * Font Style
00108  *
00109  */
00110 enum _VMFontStyle {
00111     normal = 0,         /**< Normal Fonts */
00112     bold   = 1,         /**< Bold Fonts */
00113     italic = 2          /**< Italic Fonts */
00114 };
00115
00116 typedef UInt8 VMFontStyle; /**< Used with _VMFontStyle */
00117
00118 /**
00119  * Font Size Rule
00120  *
00121  */
00122 enum _VMFontSizeRule {
00123     allSize,            /**< Both small and large fonts  */
00124     smallFonts,         /**< Only Small fonts  */
00125     largeFonts          /**< Only large fonts  */
00126 };
00127
00128 typedef UInt8 VMFontSizeRule; /**< Used with _VMFontSizeRule */
00129
00130 /**
00131  * Font Style Rule
00132  *
00133  */
00134 enum _VMFontStyleRule {
00135     allStyle,           /**< All font Styles supported */
00136     plainOnly           /**< Only Normal Fonts */
00137 };
00138
00139 typedef UInt8 VMFontStyleRule; /**< Used with _VMFontStyleRule */
00140
00141 /**
00142  * @brief Font UI rules structure used for the font picker setting
00143  *
00144  */
00145 typedef struct {
00146     Boolean fontFaceVisible;    /**< Shows/Hides Font face  */
00147     Boolean fontStyleVisible;   /**< Shows/Hides Font Style */
00148     Boolean fontSizeVisible;    /**< Shows/Hides Font Size */
00149     VMFontSizeRule sizeRule;    /**< Shows the size selected: allSize, smallFonts, largeFonts */
00150     VMFontStyleRule styleRule;  /**< Shows the style selected: allStyle, plainOnly */
00151 } VMFontUIRules;
00152 typedef VMFontUIRules *VMFontUIRulesPtr;
00153
00154 /**
00155  * @brief Font characteristics structure used to describe a font
00156  *
00157  */
00158 typedef struct {
00159     VMFontFace  face;   /**< Font face. */
00160     VMFontSize  size;   /**< Size of Font. */
00161     VMFontStyle style;  /**< Font Style */
00162 } VMFontType;
00163 typedef VMFontType *VMFontPtr;
00164
00165
00166
00167
00168
00169
00170 #endif
Top Palm Developer Network
© 2004-2008, Palm, Inc. All rights reserved.
Generated on Fri Jun 13 10:06:55 2008 for Palm API Guide